Установка SQL Server 2005

Справка по установке SQL Server
Установка SQL Server 2005 |
 | См. также

Мастер установки SQL Server 2005 основан на установщике Microsoft и предоставляет единое дерево компонентов для установки всех компонентов :

  • SQL Server Database Engine

  • Analysis Services

  • Reporting Services

  • Notification Services

  • Integration Services

  • Средства управления

  • Документация и образцы

Примечание. Доступны как 32-разрядные, так и 64-разрядные выпуски SQL Server 2005. 64-разрядные выпуски SQL Server 2005 устанавливаются аналогично 32-разрядным: с помощью мастера установки или из командной строки. Дополнительные сведения о компонентах SQL Server 2005 см. в разделе Выпуски и компоненты SQL Server 2005. При обоих способах установки SQL Server 2005 — с помощью мастера установки SQL Server 2005 или из командной строки — процесс установки включает следующие этапы.

Этап 1. Подготовка компьютера к установке SQL Server 2005

При подготовке компьютера к установке SQL Server 2005 следует учитывать аппаратные и программные требования, а также требования и критические препятствия, обнаруженные средством проверки конфигурации, и соображения безопасности.

Дополнительные сведения см. в разделе Подготовка к установке SQL Server 2005

Этап 2. Установка SQL Server 2005

Чтобы установить SQL Server 2005, запустите программу установки с помощью мастера установки SQL Server 2005 или из командной строки. При этом можно также добавить компоненты к экземпляру SQL Server 2005 или обновить до SQL Server 2005 предыдущую версию SQL Server.

Дополнительные сведения см. в разделе Установка компонентов SQL Server 2005

Этап 3: Настройка установленной копии SQL Server 2005

После завершения программы установки SQL Server 2005 можно начать настройку SQL Server с помощью графических программ и программ командной строки.

Дополнительные сведения: Настройка установки SQL Server

См. также

Задачи

Как обновить до SQL Server 2005 (программа установки)

Другие ресурсы

Настройка высокого уровня доступности
Разделы руководства по установке компонента Database Engine

© Корпорация Майкрософт, 2006. Все права защищены.


Выпуски и компоненты SQL Server 2005

Выпуски и компоненты SQL Server 2005 |
 | См. также
Установка SQL Server 2005 >

Дата обновления: 14 апреля 2006 г.

Требования при установке могут сильно различаться в зависимости от потребностей приложения. Различные выпуски SQL Server 2005 удовлетворяют индивидуальным требованиям каждой организации или отдельного лица к производительности, среде выполнения и цене. Выбор конкретных устанавливаемых компонентов SQL Server 2005 также зависит от индивидуальных потребностей или нужд организации. Следующие разделы помогут понять, как сделать лучший выбор из множества выпусков и компонентов, доступных в SQL Server 2005.

Выбор выпусков SQL Server 2005

В рабочей среде можно использовать все выпуски SQL Server 2005, кроме SQL Server 2005 Developer Edition и SQL Server 2005 Evaluation Edition. В следующих абзацах описаны выпуски SQL Server 2005.

Выпуск SQL Server 2005 Enterprise Edition (32-разрядный и 64-разрядный)

Выпуск Enterprise Edition может быть масштабирован до уровней производительности, необходимых для поддержки обработки в оперативном режиме транзакций (OLTP) самого крупного предприятия, для чрезвычайно сложного анализа данных, систем хранения данных и веб-узлов. Всеобъемлющие возможности выпуска Enterprise Edition в области бизнес-аналитики и анализа и такие возможности, обеспечивающие высокий уровень доступности, как отказоустойчивые кластеры, позволяют ему справляться с самыми критическими рабочими нагрузками на уровне предприятия. Выпуск Enterprise Edition — это наиболее полный выпуск SQL Server, идеально подходящий для самых крупных организаций и наиболее сложных условий.

Выпуск SQL Server 2005 Evaluation Edition (32-разрядный и 64-разрядный)

SQL Server 2005 доступен также в виде 180-дневного ознакомительного выпуска Evaluation Edition для 32-разрядных или 64-разрядных платформ. Выпуск SQL Server Evaluation Edition поддерживает такой же набор функций, что и SQL Server 2005 Enterprise Edition. Выпуск SQL Server Evaluation Edition можно обновить для производственного использования.

Выпуск SQL Server 2005 Standard Edition (32-разрядный и 64-разрядный)

Выпуск SQL Server 2005 Standard Edition — это платформа для управления данными и их анализа в малых и средних организациях. Он включает важнейшую функциональность, необходимую для электронной коммерции, хранения данных и отраслевых решений. Интегрированные возможности выпуска Standard Edition, такие как бизнес-аналитика и высокий уровень доступности, предоставляют организациям основные возможности, необходимые для поддержки их деятельности. Выпуск SQL Server 2005 Standard Edition идеально подходит малым и средним организациям, которым необходима платформа для управления данными и их анализа.

Выпуск SQL Server 2005 для рабочих групп (только 32-разрядная версия)

Выпуск SQL Server 2005 Workgroup Edition — это решение в области управления данными для небольших организаций, которым необходима база данных без ограничений объема или количества пользователей. Выпуск SQL Server 2005 Workgroup Edition может служить внешним веб-сервером или использоваться для обслуживания отдела или филиала. Он включает основные возможности линейки продуктов SQL Server для работы с базами данных и легко обновляется до уровня выпуска SQL Server 2005 Standard Edition или SQL Server 2005 Enterprise Edition. Выпуск SQL Server 2005 Workgroup Edition — это идеальная база данных начального уровня: надежная, устойчивая и легкая в управлении.

Выпуск SQL Server 2005 Developer Edition (32- и 64-разрядные версии)

Выпуск SQL Server 2005 Developer Edition позволяет разработчикам создавать любые типы приложений на основе SQL Server. Он включает в себя все функциональные возможности SQL Server 2005 Enterprise Edition, но лицензируется для использования в качестве системы для разработки и проверки, а не рабочего сервера. SQL Server 2005 Developer Edition — идеальный выбор для независимых поставщиков программного обеспечения, консультантов, системных интеграторов, поставщиков решений и корпоративных разработчиков, создающих и проверяющих приложения. Выпуск SQL Server 2005 Developer Edition можно обновить для производственного использования.

Выпуск SQL Server 2005 Express Edition (только 32-разрядная версия)

Платформа базы данных SQL Server Express основана на SQL Server 2005. Она также является заменой для Microsoft Desktop Engine (MSDE). Благодаря интеграции с Microsoft Visual Studio 2005, SQL Server Express облегчает разработку управляемых данными приложений, обладающих богатыми возможностями, надежными для хранения данных и не требующими продолжительного времени для развертывания.

Выпуск SQL Server Express свободно распространяется и может повторно распространяться (по соглашению), он работает как клиентская база данных, а также как основная база данных сервера. SQL Server Express является идеальным выбором для независимых поставщиков программного обеспечения (ISV), пользователей сервера, непрофессиональных разработчиков, разработчиков веб-приложений и веб-узлов, а также для любителей, создающих клиентские приложения. Если необходимы дополнительные функции базы данных, SQL Server Express можно с легкостью обновить до расширенных версий SQL Server.

Выпуск SQL Server Express содержит также дополнительные компоненты, доступные в составе SQL Server 2005 Express Edition with Advanced Services (SQL Server Express). Наряду с возможностями SQL Server Express, выпуск SQL Server Express with Advanced Services обладает следующими возможностями:

  • среда SQL Server Management Studio Express (SSMSE), облегченная версия среды SQL Server Management Studio;

  • поддержка полнотекстовых каталогов;

  • поддержка просмотра отчетов с помощью служб Reporting Services.

Выпуск SQL Server 2005 Compact Edition (только 32-разрядная версия)

SQL Server Compact Edition — это компактная база данных, обеспечивающая устройства средствами управления данными предприятия. SQL Server Compact Edition позволяет реплицировать данные с помощью SQL Server 2005 и SQL Server 2000, предоставляя пользователям возможность обслуживать мобильные хранилища данных, синхронизированные с базой данных-источником. SQL Server Compact Edition — это единственный выпуск SQL Server, обеспечивающий возможности управления реляционными базами данных с помощью интеллектуальных устройств.

Выпуск SQL Server 2005 Runtime Edition (32-разрядный и 64-разрядный)

Выпуск SQL Server 2005 Runtime Edition реализуется через программу Microsoft ISV Royalty Program. Согласно лицензионному соглашению для выпуска SQL Server 2005 Runtime Edition, независимый поставщик программного обеспечения (ISV) может внедрить код SQL Server в свое решение, но при этом клиент не может использовать код SQL Server в других программах или любом другом контексте. Дополнительные сведения о выпуске SQL Server Runtime Edition см. в статье базы знаний Майкрософт Как получить лицензию на SQL Server Runtime (http://support.microsoft.com/kb/917400).

Использование SQL Server 2005 с интернет-сервером

На интернет-сервере, например на сервере, где работают службы IIS, обычно устанавливают клиентские средства SQL Server 2005. Клиентские средства включают в себя клиентские компоненты соединения, которые используются приложениями, соединяющимися с экземпляром SQL Server.

Примечание.
Хотя установка экземпляра SQL Server на компьютер, на котором выполняются службы IIS, возможна, обычно это делается только в случае небольших веб-узлов, использующих один компьютер-сервер. У большинства веб-узлов их системы IIS среднего уровня расположены на одном сервере или серверном кластере, а базы данных — на отдельном сервере или федерации серверов. Службы SQL Server 2005 Reporting Services обычно устанавливаются на среднем уровне. Дополнительные сведения о требованиях к программному обеспечению для служб Reporting Services см. в разделе Требования к оборудованию и программному обеспечению для установки SQL Server 2005. Дополнительные сведения о федерациях см. в разделе Федеративные серверы баз данных электронной документации по SQL Server 2005.

Использование SQL Server 2005 с приложениями «клиент-сервер»

На компьютер, где работают приложения «клиент-сервер», которые подключаются непосредственно к экземпляру SQL Server, можно установить только клиентские компоненты SQL Server 2005. Установка клиентских компонентов будет хорошим выбором также и в том случае, если администрируется экземпляр SQL Server на сервере базы данных или планируется разработка приложений SQL Server.

При выборе установки клиентских компонентов будут установлены следующие компоненты SQL Server: программы командной строки, средства служб Reporting Services, компоненты соединений, модели программирования, средства управления, средства разработки, электронная документация, а также образцы баз данных и приложений. Дополнительные сведения см. в разделе Как установить SQL Server 2005 (программа установки).

Выбор компонентов SQL Server 2005

Воспользуйтесь страницей Выбор компонентов мастера установки SQL Server, чтобы выбрать компоненты, которые должны быть включены в установку SQL Server 2005. Никакие компоненты в дереве компонентов не выбраны по умолчанию.

Воспользуйтесь приведенными ниже описаниями, чтобы определить, какой набор компонентов удовлетворит вашим требованиям.

Компоненты сервера | Описание
SQL Server Database Engine | Компонент Database Engine включает в себя ядро СУБД, основную службу для хранения, обработки и обеспечения сохранности данных, репликацию, полнотекстовый поиск и средства управления реляционными и XML-данными.
Analysis Services | Службы Analysis Services включают в себя средства для создания и управления приложениями интерактивной аналитической обработки (OLAP) и приложениями интеллектуального анализа данных.
Reporting Services 1,2 | Службы Reporting Services включают в себя серверные и клиентские компоненты для создания, управления и развертывания табличных, матричных и графических отчетов, а также отчетов в свободной форме. Службы Reporting Services являются расширяемой платформой, которую можно использовать для разработки приложений отчетов.
Notification Services | Службы Notification Services представляют собой платформу для разработки и развертывания приложений, посылающих персонифицированные, актуальные сведения подписчикам на различных устройствах.
Integration Services | Integration Services представляет собой набор графических средств и программируемых объектов для перемещения, копирования и преобразования данных.

1 Для установки служб Reporting Services требуются службы IIS версии 5.0 или выше.

2 Для компонента «Конструктор отчетов» служб Reporting Services требуется обозреватель Microsoft Internet Explorer версии 6.0 с пакетом обновления 1 (SP1).

Клиентские компоненты | Описание
Компоненты связи | Устанавливает компоненты для связи между клиентами и серверами и сетевые библиотеки для DB-библиотеки, ODBC и OLE DB.

Средства управления | Описание
SQL Server Management Studio 1 | Среда SQL Server Management Studio, впервые появившаяся в Microsoft SQL Server 2005, представляет собой интегрированную среду для доступа ко всем компонентам SQL Server, для управления ими, их настройки, разработки и администрирования. SQL Server Management Studio объединяет возможности программ Enterprise Manager, Query Analyzer и Analysis Manager, входивших в состав более ранних версий SQL Server, в единой среде, обеспечивающей доступ к SQL Server разработчикам и администраторам с любым уровнем подготовки.
Диспетчер конфигурации SQL Server | Диспетчер конфигурации SQL Server обеспечивает базовые возможности управления конфигурациями для служб, серверных протоколов, клиентских протоколов и псевдонимов клиентов SQL Server.
SQL Server Profiler | Приложение SQL Server Profiler обеспечивает графический интерфейс пользователя для контроля над экземпляром Database Engine или экземпляром служб Analysis Services.
Помощник по настройке ядра СУБД | Помощник по настройке ядра СУБД помогает создавать оптимальные наборы индексов, индексированных представлений и секций.

1. Для установки среды SQL Server Management Studio требуется обозреватель Internet Explorer версии 6.0 с пакетом обновления 1 (SP1).

Средства разработки | Описание
Business Intelligence Development Studio 1 | Среда Business Intelligence Development Studio представляет собой интегрированную среду разработки для решений служб Analysis Services, служб Reporting Services и служб Integration Services.

1 Для установки среды Business Intelligence Development Studio требуется обозреватель Internet Explorer версии 6.0 с пакетом обновления 1 (SP1).

Документация и образцы | Описание
Электронная документация по SQL Server | Основная документация для SQL Server 2005.
Образцы SQL Server | Содержит образцы кода и приложений для компонента Database Engine и служб Analysis Services, Reporting Services и Integration Services.

См. также

Справочник

Компоненты для установки
Выбор компонентов
Обновления версий и выпусков

Основные понятия

Настройка контактной зоны SQL Server

Журнал изменений

Версия Журнал

17 июля 2006 г.

Измененное содержимое:
  • Добавлен выпуск SQL Server Runtime в список выпусков SQL Server 2005.

14 апреля 2006 г.

Измененное содержимое
  • Продолжительность периода пробного использования выпуска SQL Server 2005 Evaluation Edition увеличена со 120 до 180 дней.

  • Пересмотрен список выпусков SQL Server 2005, пригодных для использования в рабочих средах: нельзя использовать лишь выпуски Developer Edition и Evaluation Edition.


Заявление о конфиденциальности SQL Server 2005

Заявление о конфиденциальности SQL Server 2005
Установка SQL Server 2005 >

С информацией о компонентах, собирающих данные пользователя в , можно ознакомиться на этом веб-узле Microsoft.


Юридическое уведомление

Юридическое уведомление
Установка SQL Server 2005 >

Дата обновления: 17 июля 2006 г.

Эта документация, включающая образцы приложений, предоставляется исключительно для информационных целей и без каких-либо гарантий, прямых или косвенных. Данные, содержащиеся в этой документации, включая URL-адреса, а также ссылки на другие веб-узлы, могут меняться без предварительного уведомления. Всю ответственность за использование документации, а также за результаты ее использования несет исключительно пользователь.

Основная задача образцов, содержащихся в документации, состоит в том, чтобы проиллюстрировать какое-либо понятие или показать рациональное использование определенной инструкции или предложения. В большинство образцов не входит весь код, который содержался бы в полноценной промышленной системе. Некоторые обычные операции проверки данных и обработки ошибок удалены из образцов намеренно, чтобы обратить внимание на конкретные концепции или инструкции, используемые в образцах. Техническая поддержка для таких образцов, равно как и для любого исходного кода, не предоставляется.

За исключением специально отмеченных случаев, описанные здесь компании, организации, товары, имена доменов, адреса электронной почты, люди, места и события являются вымышленными; любые совпадения с какими-либо реальными компаниями, организациями, товарами, именами доменов, адресами электронной почты, лицами, местами и событиями являются случайными. Ответственность за соблюдение всех авторских прав и прав на интеллектуальную собственность целиком и полностью несет пользователь. В рамках, предусмотренных законами об авторских правах, никакая часть настоящего документа не может быть воспроизведена, сохранена или введена в систему хранения и извлечения данных, либо передана в любой форме или любым способом (электронным, механическим, методом фотокопирования, записи или иным способом) для любых целей без письменного разрешения корпорации Майкрософт.

Корпорация Майкрософт может являться правообладателем патентов, заявок на получение патентов, товарных знаков и прочих объектов авторского права, которые могут иметь отношение к содержанию данной документации. Предоставление данной документации не означает передачи какой-либо лицензии на использование данных патентов, товарных знаков и объектов авторского права, за исключением использования, явно оговоренного в лицензионном соглашении корпорации Майкрософт.

© Корпорация Майкрософт, 2006. Все права защищены.

Microsoft, MS-DOS, Windows, Windows NT, Windows, Active Directory, ActiveX, BackOffice, bCentral, BizTalk, BizTalk, DirectX, Excel, Hotmail, IntelliSense, J/Direct, Jscript, Jscript, Microsoft Press, MSDN, MS-DOS, Outlook, PivotChart, PivotTable, PowerPoint, SharePoint, Visual Basic, Visual C#, Visual C++, Visual FoxPro, Visual InterDev, Visual J#, Visual J++, Visual SourceSafe, Visual Studio, Win32, Win32s, Windows Mobile, Windows System, SQL Server и WinFX являются охраняемыми товарными знаками корпорации Майкрософт в США и других странах.

SAP NetWeaver является охраняемым товарным знаком SAP AG в Германии и в некоторых других странах.

Все прочие товарные знаки являются собственностью их владельцев.

Политика документирования поддержки и обновления SQL Server 2005

Содержимое документации по SQL Server публикуется только после выполнения необходимых проверок. Документация по продукту (электронная документация по SQL Server, файлы readme, документы об обнаруженных проблемах, а также статьи базы знаний) содержит сведения о функциях сервера SQL Server и его функциональных возможностях, которые достаточно надежны для общего использования всеми заказчиками. Данная политика относится ко всей документации SQL Server, включая файлы Readme отдельных версий и пакетов обновления; файлы Readme рассматриваются как дополнение к электронной документации.

В некоторых случаях функции не предназначены для непосредственного использования клиентами, поэтому они не описываются в документации. Если сведения о какой-либо функции отсутствуют в документации по SQL Server, опубликованной корпорацией Майкрософт, но содержатся в книгах или на веб-узлах сторонних компаний, то на нее не распространяется техническая поддержка Майкрософт (CSS) и она не должна применяться в производственных базах данных и приложениях.

Клиенты не должны использовать недокументированные интерфейсы приложений, в частности следующие: хранимые процедуры, расширенные хранимые процедуры, функции, представления, таблицы, столбцы, свойства и метаданные. Служба поддержки пользователей корпорации Майкрософт не осуществляет сопровождение баз данных и приложений, в которых прямо или косвенно используются недокументированные точки входа.

Для приложений и баз данных, которые прямо или косвенно используют недокументированные точки входа, обновление сервера и баз данных для работы с будущими версиями SQL Server не гарантируется. Разрешено использование только возможностей и функций SQL Server, которые включены в документацию по Microsoft SQL Server. Если функция не включена в документацию по Microsoft SQL Server, то она не является поддерживаемой частью SQL Server.


О лицензионном соглашении SQL Server 2005

О лицензионном соглашении SQL Server 2005
Установка SQL Server 2005 >

Дата обновления: 17 июля 2006 г.

Лицензионное соглашение Microsoft (EULA) копируется на локальный компьютер при установке SQL Server 2005. Этот файл сохраняется в следующей папке: «%ProgramFiles%\Microsoft SQL Server\90\EULA\» или «%ProgramFiles(x86)%\Microsoft SQL Server\90\EULA\».

При установке на один компьютер нескольких экземпляров одного выпуска SQL Server 2005 на одном языке одна из копий лицензионного соглашения будет применяться ко всем экземплярам выпуска на этом языке.

Имена файлов лицензионного соглашения указывают как выпуск SQL Server 2005, так и язык SQL Server 2005. Например:

  • Файл, содержащий лицензию, выданную на SQL Server 2005 Developer Edition на английском языке, будет называться License_DEV_ENU.txt.

  • Файл, содержащий лицензию, выданную на SQL Server 2005 Standard Edition на итальянском языке, будет называться License_STD_ITA.txt.

  • Для помощника по обновлению версии SQL Server 2005 на японском языке файл будет называться License_UA_JPN.txt.

  • Для собственного клиента SQL на английском языке файл будет называться License_SQLNCLI_ENU.txt.

  • Для компонента SQLXML на корейском языке файл будет называться License_SQLXML4_KOR.txt.

Для обозначения выпусков SQL Server 2005 используются следующие части имен файлов:

  • ENT — выпуск Enterprise Edition

  • DEV — выпуск Developer Edition

  • STD — выпуск Standard Edition

  • WKGP — выпуск Workgroup Edition

  • EXPR — выпуск Express Edition

  • UA — помощник по обновлению

Для обозначения версий SQL Server 2005 на разных языках используются следующие части имен файлов:

  • ENU — английский

  • JPN — японский

  • FRA — французский

  • ITA — итальянский

  • KOR — корейский

  • DEU — немецкий

  • ESN — испанский

  • CHS — китайский (упрощенный)

  • CHT — китайский (традиционный)

  • NLA — голландский

  • PTB — бразильский (португальский)

  • SVE — шведский

  • RUS — русский

Варианты лицензирования SQL Server 2005

Сведения о ценах и вариантах лицензирования SQL Server 2005 см. на следующем веб-узле корпорации Майкрософт.

Журнал изменений

Версия Журнал

17 июля 2006 г.

Новое содержимое:
  • Добавлен русский язык в список сегментов имени для поддерживаемых языков.


Подготовка к установке SQL Server 2005

Подготовка к установке SQL Server 2005 |
 | См. также

Дата обновления: 5 декабря 2005 г.

В зависимости от требований программа установки устанавливает новый экземпляр SQL Server, обновляет существующий экземпляр или предоставляет параметры обслуживания. В следующих разделах рассматриваются важные требования к компьютеру, на котором будет установлен SQL Server 2005. Перед установкой SQL Server 2005 ознакомьтесь со следующими сведениями.

Все установки Microsoft SQL Server 2005

  • Убедитесь, что компьютер соответствует системным требованиям для SQL Server 2005. Дополнительные сведения см. в разделе Требования к оборудованию и программному обеспечению для установки SQL Server 2005.

  • Обратитесь к разделу Анализ безопасности при установке SQL Server.

  • Программа установки включает проверку, проводимую перед началом установки, которая определяет неподдерживаемые конфигурации на используемых для установки компьютерах и указывает пользователям способы устранения критических препятствий. Дополнительные сведения см. в разделе Параметры для средства проверки конфигурации системы.

  • Убедитесь, что имеются разрешения администратора на том компьютере, где будет производиться установка SQL Server. При установке SQL Server из удаленной общей папки необходимо использовать учетную запись домена с разрешениями на чтение и выполнение для удаленной общей папки. Чтобы создать отказоустойчивый кластер, необходимо иметь разрешения локального администратора с правом входа в качестве службы и действовать как часть операционной системы на всех узлах виртуального сервера.

    Примечание безопасности.
    При модификации разрешений на учетную запись пользователя домена для запуска программы установки SQL Server убедитесь, чтобы после завершения установки эти разрешения были отменены.

  • Создайте одну или несколько учетных записей пользователя домена, если производится установка SQL Server 2005 на компьютере, где работает Microsoft Windows XP или Windows 2003, и если нужно, чтобы SQL Server 2005 обменивался данными с другими клиентами и серверами. Дополнительные сведения см. в разделе Настройка учетных записей служб Windows.

  • Не устанавливайте SQL Server 2005 на контроллере домена. Дополнительные сведения см. в подразделе «Изоляция служб» в разделе Анализ безопасности при установке SQL Server.

  • Создайте резервную копию текущей установки SQL Server, если экземпляр SQL Server запущен на компьютере, на котором должен быть установлен SQL Server 2005.

  • Убедитесь, что диск, на который будет установлен SQL Server, не является сжатым диском. При попытке установки SQL Server на сжатый диск программа установки завершится неудачно.

  • Закройте антивирусное программное обеспечение на время установки SQL Server.

  • Остановите все службы, которые зависят от SQL Server, включая службы, использующие ODBC, такие как службы IIS. Закройте средство просмотра событий и редакторы реестра (Regedit.exe и Regedt32.exe).

  • Просмотрите все параметры установки SQL Server и будьте готовы сделать соответствующий выбор при выполнении программы установки. Дополнительные сведения см. в разделах Выпуски и компоненты SQL Server 2005, Справочник по пользовательскому интерфейсу программы установки и Как установить SQL Server 2005 (программа установки).

Обновление до SQL Server 2005

  • Дополнительные сведения о поддерживаемых сценариях обновления см. в разделе Обновление до SQL Server 2005.

  • Дополнительные сведения по запуску SQL Server 2005 вместе с предыдущими версиями SQL Server см. в разделах Работа с несколькими версиями SQL Server и Обратная совместимость.

  • Подробное описание процедуры обновления с пошаговыми инструкциями см. в разделе Как обновить до SQL Server 2005 (программа установки).

  • Об известных проблемах и вопросах по обратной совместимости см. в разделах Обновления версий и выпусков, Использование помощника по обновлению для подготовки к обновлениям и Обратная совместимость.

Установка отказоустойчивого кластера

Если устанавливается отказоустойчивый кластер, см. раздел Подготовка к установке отказоустойчивого кластера.

Международные пользователи

Если используется операционная система с региональными настройками, отличающимися от английских (США), или нестандартные параметры кодировки и порядка сортировки, см. раздел Настройка параметров сортировки и поддержка нескольких языков.

Сведения о параметрах сортировки по умолчанию, назначаемых программой установки, см. в разделе Настройка параметров сортировки в программе установки.

См. также

Основные понятия

Установка SQL Server 2005
Отказоустойчивый кластер

Другие ресурсы

Установка компонентов SQL Server 2005
Обновление до SQL Server 2005

© Корпорация Майкрософт, 2006. Все права защищены.


Требования к оборудованию и программному обеспечению для установки SQL Server 2005

Требования к оборудованию и программному обеспечению для установки SQL Server 2005 |
 | См. также
Подготовка к установке SQL Server 2005 >

Дата обновления: 14 апреля 2006 г.

В следующем списке приводятся минимальные требования к оборудованию и программному обеспечению для запуска .

Примечание.
Требования для запуска SQL Server на 32-разрядной платформе отличаются от требований к 64-разрядной платформе.

Требования к оборудованию и программному обеспечению (для 32-разрядной и 64-разрядной платформ)

Монитор

Для работы графических средств SQL Server требуется разрешение VGA или выше, рекомендуется разрешение 1024x768 точек.

Указывающее устройство

Требуется мышь Microsoft mouse или совместимое указывающее устройство.

Дисковод для компакт-дисков или DVD-дисков

Для установки с компакт-дисков или DVD-дисков требуется соответствующий дисковод.

Требования к кластерному оборудованию

На 32-разрядных и 64-разрядных платформах поддерживается установка кластера из восьми узлов (то есть максимального количества узлов, поддерживаемого ). Дополнительные сведения о решениях c высоким уровнем доступности см. в разделах Настройка высокого уровня доступности и Подготовка к установке отказоустойчивого кластера.

Требования к сетевому программному обеспечению

Требования к сетевому программному обеспечению для 64-разрядных версий SQL Server 2005 те же, что и для 32-разрядных версий. Windows Server 2003, Windows XP и Windows 2000 имеют встроенное сетевое программное обеспечение.

Примечание.
SQL Server 2005 не поддерживает протокол Banyan VINES Sequenced Packet (SPP), а также сетевые протоколы Multiprotocol, AppleTalk и NWLink IPX/SPX. Клиенты, подключенные ранее с помощью этих протоколов, для соединения с SQL Server 2005 должны выбрать другой протокол.

Изолированные именованные экземпляры и экземпляры по умолчанию поддерживают следующие сетевые протоколы:

  • Общая память

  • Именованные каналы

  • TCP/IP

  • VIA

Примечание. Общая память не поддерживается отказоустойчивыми кластерами.

Требования к Интернет-компонентам

Требования к Интернет-компонентам для 32- и 64-разрядных версий SQL Server 2005 одинаковые. В следующей таблице приводятся требования к Интернет-компонентам для SQL Server 2005.

Компонент Требование

Программное обеспечение для Интернета1

Для всех выпусков SQL Server 2005 требуется Microsoft Internet Explorer 6.0 с пакетом обновления 1 (SP1) или более поздняя версия, так же как для консоли управления MMC и справки HTML. Достаточно минимальной установки Internet Explorer. Кроме того, Internet Explorer не обязательно должен быть обозревателем по умолчанию.

Но если устанавливаются только клиентские компоненты и устанавливаются соединения с сервером, не требующие шифрования, достаточно будет Internet Explorer 4.01 с пакетом обновления 2 (SP2).

Службы IIS

Для установки служб требуется IIS 5.0 или более поздняя версия.

Дополнительные сведения об установке IIS см. в разделе Как установить службы IIS (Microsoft). Дополнительные сведения об установке IIS 7.0 на Windows Vista см. на веб-узле Майкрософт.

ASP.NET 2.02

Для служб Reporting Services требуется ASP.NET 2.0. При установке служб Reporting Services программа установки SQL Server задействует ASP.NET, если эта программа еще не была запущена.

1Для сред SQL Server Management Studio, Business Intelligence Development Studio требуется обозреватель Microsoft Internet Explorer 6.0 с пакетом обновления 1 (SP1) или более поздняя версия, а также конструктор отчетов, являющийся компонентом служб Reporting Services.

2Для установки служб Reporting Services (64-разрядной версии) на 64-разрядные серверы необходимо установить 64-разрядную версию ASP.NET. Для установки служб Reporting Services (32-разрядной версии) на 32-разрядную подсистему (WOW64) 64-разрядного сервера должна быть установлена 32-разрядная версия ASP.NET. Службы Reporting Services не поддерживаются в параллельной конфигурации 64-разрядной платформы и 32-разрядной подсистемы (WOW64) 64-разрядного сервера. Дополнительные сведения о настройке IIS см. в разделе Как настроить службы IIS для запуска 32-разрядных служб Reporting Services в режиме WOW64.

Требования к программному обеспечению

Для установки SQL Server требуется установщик Microsoft Windows 3.1 или более поздняя версия, а также компоненты доступа к данным MDAC 2.8 с пакетом обновления 1 (SP1) или более поздней версии. Компоненты MDAC 2.8 с пакетом обновления 1 (SP1) можно загрузить с этого веб-узла Майкрософт.

Программа установки SQL Server устанавливает следующие необходимые компоненты:

  • 2.0

  • Собственный клиент

  • Файлы поддержки программы установки SQL Server

Примечание.
SQL Server 2005 Express Edition не устанавливает..NET Framework 2.0. Перед установкой SQL Server 2005 Express Edition необходимо загрузить и установить платформу ..NET Framework с этого веб-узла Майкрософт.

Если она еще не установлена, программа установки SQL Server устанавливает каждый из этих компонентов отдельно. При отмене установки SQL Server 2005 автоматически удаляются только файлы поддержки программы установки . Дополнительные сведения об удалении этой версии см. в разделе Как удалить существующий экземпляр SQL Server 2005 (программа установки).

Примечание.
Пакет средств разработки .NET Framework 2.0 (SDK) не устанавливается при установке SQL Server 2005. Пакет SDK содержит документацию, компилятор C++ и другие инструменты, полезные при использовании .NET Framework для разработки в SQL Server. Пакет .NET Framework SDK можно загрузить с этого веб-узла Майкрософт.

После установки нужных компонентов SQL Server программа установки проверяет соответствие компьютера, на котором устанавливается SQL Server, всем остальным требованиям. Дополнительные сведения см. в разделе Параметры для средства проверки конфигурации системы.

Отказоустойчивым кластерам SQL Server 2005 необходимо наличие Microsoft Cluster Server (MSCS) по крайней мере на одном узле кластера серверов. Сервер MSCS поддерживается только в случае, если он был установлен на компьютер, конфигурация которого была протестирована на совместимость с программным обеспечением MSCS. Дополнительные сведения см. в разделе Подготовка к установке отказоустойчивого кластера.

Поддержка версий на разных языках

Обновление:

  • Английские версии SQL Server можно обновить до любой локализованной версии SQL Server 2005.

  • Локализованные версии SQL Server можно обновить до локализованных версий SQL Server 2005 на том же языке.

  • Локализованные версии SQL Server нельзя обновить до английской версии SQL Server 2005.

  • Локализованные версии SQL Server нельзя обновить до локализованных версий SQL Server 2005 на другом языке.

Все локализованные обновления должны соответствовать поддерживаемому порядку обновления. Дополнительные сведения о поддерживаемом порядке обновления см. в разделе Обновления версий и выпусков.

Дополнительная поддержка версий на разных языках:

  • Английская версия SQL Server 2005 поддерживается на всех локализованных версиях поддерживаемых операционных систем.

  • Локализованные версии SQL Server 2005 поддерживаются в локализованных операционных системах на том же языке, что и локализованная версия SQL Server.

  • Локализованные версии SQL Server 2005 также поддерживаются в английских версиях поддерживаемых операционных систем с помощью настроек пакета многоязыкового пользовательского интерфейса Windows. Однако перед установкой локализованной версии SQL Server 2005 на сервер, работающий под управлением англоязычной версии операционной системы с установленной локализованной версией MUI, необходимо проверить некоторые настройки операционной системы. Необходимо убедиться, что следующие настройки операционной системы соответствуют языку локализации SQL Server.

    • Настройки пользовательского интерфейса операционной системы

    • Пользовательские настройки языкового стандарта операционной системы

    • Настройки языка системы

    Если эти параметры операционной системы не соответствуют языку локализованной версии SQL Server, необходимо правильно настроить эти параметры операционной системы, как описано в разделе Как изменить параметры операционной системы для поддержки локализованных версий.

Поддержка виртуальной операционной системы

SQL Server 2005 можно установить на виртуальных компьютерах Microsoft Virtual Server и Microsoft Virtual PC на поддерживаемых операционных системах и оборудовании. Сведения о Virtual Server см. на веб-узле Майкрософт. Сведения о продукте Virtual PC см. на веб-узле Майкрософт.

Внимание!
Не устанавливайте SQL Server 2005 на Microsoft Virtual Server или Microsoft Virtual PC, работающих на оборудовании, которое не приводится в следующем списке «Требования к оборудованию и программному обеспечению».

Требования к оборудованию и программному обеспечению (только для 32-разрядной платформы)

Требования к оборудованию (32-разрядная платформа)

В этой таблице приводятся требования к оборудованию для установки и запуска SQL Server 2005 на 32-разрядной платформе.

SQL Server 2005 (32-разрядная версия) | Тип процессора1 | Быстродействие процессора2 | Оперативная память (ОЗУ)3
SQL Server 2005 Enterprise Edition 4 SQL Server 2005 Developer Edition SQL Server 2005 Standard Edition | Процессор, совместимый с Pentium III или выше | Минимум 600 МГц Рекомендуется 1 ГГц и выше | Минимум 512 МБ Рекомендуется 1 ГБ или больше Максимум Максимальный объем, поддерживаемый операционной системой
SQL Server 2005 Workgroup Edition | Процессор, совместимый с Pentium III или выше | Минимум 600 МГц Рекомендуется 1 ГГц и выше | Минимум 512 МБ Рекомендуется 1 ГБ или больше Максимум Максимальный объем, поддерживаемый операционной системой
SQL Server 2005 Express Edition | Процессор, совместимый с Pentium III или выше | Минимум 500 МГц Рекомендуется 1 ГГц и выше | Минимум 192 МБ Рекомендуется 512 МБ или больше Максимум Максимальный объем, поддерживаемый операционной системой
SQL Server 2005 Express Edition with Advanced Services | Процессор, совместимый с Pentium III или выше | Минимум 600 МГц Рекомендуется 1 ГГц и выше | Минимум 512 МБ Рекомендуется 1 ГБ или больше Максимум Максимальный объем, поддерживаемый операционной системой

1Средство проверки конфигурации системы (SCC) заблокирует программу установки, если процессор не удовлетворяет требованиям.

2 SCC предупредит пользователя, но не заблокирует программу установки, если процессор не удовлетворяет требованиям к минимальной или рекомендованной частоте. На многопроцессорных компьютерах предупреждения не появляются.

3 SCC предупредит пользователя, но не заблокирует программу установки, если не выполняются требования к минимальному или рекомендованному объему оперативной памяти. Требования к объему памяти относятся только к этой версии и не отражают дополнительные требования операционной системы. SCC проверяет доступный объем памяти при запуске программы установки.

4 Выпуск SQL Server Evaluation Edition поддерживает тот же набор возможностей, что и SQL Server 2005 Enterprise Edition.

Примечание.
Программное обеспечение SQL Server 2005 работает на оборудовании, сертифицированном для использования с операционной системой Microsoft Windows. Дополнительные сведения об оборудовании, сертифицированном для использования с операционной системой Windows, см. на веб-узле Microsoft: Продукты, разработанные для Microsoft Windows — Каталог Windows и HCL.

Требования к свободному месту на жестком диске (32-разрядная и 64-разрядная версии)

Во время установки SQL Server 2005 установщик Windows создает временные файлы на системном диске. Прежде чем запускать программу для установки или обновления версии до SQL Server 2005, проверьте, что на нем доступно не менее 2,0 ГБ свободного места. Это требование применяется даже в том случае, если компоненты SQL Server устанавливаются на диск, отличный от предложенного по умолчанию. Многие файлы устанавливаются на системный диск, как правило, диск C:. Например, файлы журналов программы установки будут записаны на системный диск и могут потребовать 80 МБ для изолированной установки и больше для установки отказоустойчивого кластера. Дополнительные сведения см. в разделе Расположение файлов для экземпляра по умолчанию и именованных экземпляров SQL Server 2005.

Фактические требования к свободному месту на жестком диске зависят от конфигурации системы, а также от устанавливаемых приложений и компонентов. В следующей таблице представлены требования к свободному месту на диске для компонентов SQL Server 2005.

Компонент | Требования к свободному месту на диске
Компонент Database Engine и файлы данных, репликация и полнотекстовый поиск | 280 МБ
Службы Analysis Services и файлы данных | 90 МБ
Службы Reporting Services и диспетчер отчетов | 120 МБ
Компоненты ядра служб Notification Services, клиентские компоненты и компоненты правил | 50 МБ
Integration Services | 120 МБ
Клиентские компоненты | 850 МБ
Электронная документация SQL Server и электронная документация SQL Server 2005 Compact Edition | 240 МБ
Примеры и образцы баз данных. Обратите внимание, что по умолчанию примеры и образцы баз данных не устанавливаются. | 410 МБ

Требования к 32-разрядной операционной системе

В этой таблице представлены операционные системы, под управлением которых выполняется серверное программное обеспечение для всех 32-разрядных версий SQL Server 2005.

 | Enterprise Edition1 | Developer Edition | Standard Edition | Workgroup Edition | Выпуски Express Edition и Express Edition with Advanced Services | Evaluation Edition
Windows 2000 | Нет | Нет | Нет | Нет | Нет | Нет
Windows 2000 Professional Edition с пакетом обновления 4 (SP4)2, 4 | Нет | Да | Да | Да | Да | Да
Windows 2000 Server с пакетом обновления 4 (SP4)2 | Да | Да | Да | Да | Да | Да
Windows 2000 Advanced Server с пакетом обновления 4 (SP4)2 | Да | Да | Да | Да | Да | Да
Windows 2000 Datacenter Edition с пакетом обновления 4 (SP4)2 | Да | Да | Да | Да | Да | Да
Windows XP Embedded | Нет | Нет | Нет | Нет | Нет | Нет
Windows XP Home Edition с пакетом обновления 2 (SP2) | Нет | Да | Нет | Нет | Да | Нет
Windows XP Professional Edition с пакетом обновления 2 (SP2)4 | Нет | Да | Да | Да | Да | Да
Windows XP Media Edition с пакетом обновления 2 (SP2) | Нет | Да | Да | Да | Да | Да
Windows XP Tablet PC Edition с пакетом обновления 2 (SP2) | Нет | Да | Да | Да | Да | Да
Windows Server 2003 Server с пакетом обновления 1 (SP1)6 | Да | Да | Да | Да | Да | Да
Windows Server 2003 Enterprise Edition с пакетом обновления 1 (SP1)6 | Да | Да | Да | Да | Да | Да
Windows Server 2003 Datacenter Edition с пакетом обновления 1 (SP1)6 | Да | Да | Да | Да | Да | Да
Windows Server 2003 Web Edition с пакетом обновления 1 (SP1) | Нет | Нет | Нет | Нет | Да | Нет
Windows Small Business Server 2003 Standard Edition с пакетом обновления 1 (SP1) | Да | Да | Да | Да | Да | Да
Windows Small Business Server 2003 Premium Edition с пакетом обновления 1 (SP1) | Да | Да | Да | Да | Да | Да
Windows Vista Starter Edition | Нет | Нет | Нет | Нет | Нет | Нет
Windows Vista Home Basic Edition | Нет | Да 7 | Нет | Нет | Да 8 | Да 7
Windows Vista Home Premium Edition | Нет | Да 7 | Нет | Нет | Да 8 | Да 7
Windows Vista Ultimate Edition | Да 7 | Да 7 | Да 7 | Да 7 | Да 8 | Да 7
Windows Vista Business Edition | Да 7 | Да 7 | Да 7 | Да 7 | Да 8 | Да 7
Windows Vista Enterprise Edition | Да 7 | Да 7 | Да 7 | Да 7 | Да 8 | Да 7
Windows Server 2003 Itanium Datacenter Edition (64-разрядная версия) с пакетом обновления 1 (SP1) | Нет | Нет | Нет | Нет | Нет | Нет
Windows Server 2003 Itanium Enterprise Edition (64-разрядная версия) с пакетом обновления 1 (SP1) | Нет | Нет | Нет | Нет | Нет | Нет
Windows Server 2003 x64 Standard Edition (64-разрядная версия) с пакетом обновления 1 (SP1)6 | WOW643 | WOW643 | WOW643 | WOW643 | WOW643 | WOW643
Windows Server 2003 x64 Datacenter Edition (64-разрядная версия) с пакетом обновления 1 (SP1)6 | WOW643 | WOW643 | WOW643 | WOW643 | WOW643 | WOW643
Windows Server 2003 x64 Enterprise Edition (64-разрядная версия) с пакетом обновления 1 (SP1)6 | WOW643 | WOW643 | WOW643 | WOW643 | WOW643 | WOW643
Windows XP x64 Professional 2003 | Нет | WOW643 | WOW643 | WOW643 | WOW643 | Нет
Windows Vista Home Basic x64 Edition (64-разрядная версия) | Нет | WOW643,7 | Нет | Нет | WOW643,8 | WOW643,7
Windows Vista Home Premium x64 Edition (64-разрядная версия) | Нет | WOW643,7 | Нет | Нет | WOW643,8 | WOW643,7
Windows Vista Ultimate x64 Edition (64-разрядная версия) | Нет | WOW643,7 | WOW643,7 | WOW643,7 | WOW643,8 | WOW643,7
Windows Vista Business x64 Edition (64-разрядная версия) | Нет | WOW643,7 | WOW643,7 | WOW643,7 | WOW643,8 | WOW643,7
Windows Vista Enterprise x64 Edition (64-разрядная версия) | Нет | WOW643,7 | WOW643,7 | WOW643,7 | WOW643,8 | WOW643,7

1 Выпуск SQL Server 2005 Evaluation Edition поддерживает тот же набор возможностей, что и SQL Server 2005 Enterprise Edition, но SQL Server 2005 Enterprise Edition не поддерживается во всех операционных системах, поддерживающих выпуск Evaluation Edition.

2 Windows 2000 Пакет обновления 4 (SP4) можно загрузить с этого веб-узла Майкрософт. Пакеты обновления для выпуска Windows 2000 Datacenter Edition можно получить у изготовителя оборудования (OEM).

3Эти выпуски SQL Server 2005 можно устанавливать на 32-разрядные подсистемы Windows on Windows (WOW64) 64-разрядного сервера.

4Можно устанавливать электронную документацию по , клиентские средства и некоторые другие средства из прежних выпусков для SQL Server 2005 Enterprise Edition в системах Windows 2000 Professional с пакетом обновления 4 (SP4) и Windows XP с пакетом обновления 2 (SP2). Клиентские средства включают среды SQL Server Management Studio и Business Intelligence Development Studio, SQL Server 2005. Компоненты прежних версий включают среду выполнения служб DTS и объекты SQL-DMO.

5 Службы Reporting Services, устанавливаемые в составе выпуска SQL Server Express Edition with Advanced Services, не устанавливаются на операционные системы, не содержащие служб IIS.

6 Поддержка SQL Server 2005 в выпуске Windows Server 2003 R2 — та же, что в Windows Server 2003 с пакетом обновления 1 (SP1).

7 SQL Server 2005 требует пакета обновления 2 (SP2) в Windows Vista.

8 SQL Server 2005 Express Edition требует пакета обновления 1 (SP1) в Windows Vista. SQL Server 2005 Express Edition with Advanced Services требует пакета обновления 2 (SP2) в Windows Vista.

При установке на поддерживаемые операционные системы могут возникнуть следующие проблемы и ограничения:

  • встроенная поддержка веб-служб (SOAP и HTTP) доступна только для экземпляров SQL Server 2005 под управлением Windows Server 2003;

  • отдельные разделы в документации по службам по программированию, объектам AMO и ADOMD.NET могут указывать на поддержку ранних версий Windows, например Windows 98, Windows ME или Windows NT 4.0. Тем не менее, в этой версии эти три программных интерфейса поддерживаются только операционными системами Windows XP, Windows 2000 и Windows Server 2003;

  • Отказоустойчивым кластерам SQL Server 2005 необходимо наличие Microsoft Cluster Server (MSCS), по крайней мере на одном узле кластера серверов. Сервер MSCS поддерживается только в случае, если он был установлен на компьютер, конфигурация которого была протестирована на совместимость с программным обеспечением MSCS. Дополнительные сведения см. в разделе Подготовка к установке отказоустойчивого кластера.

Поддерживаемые 32-разрядные клиенты

32-разрядные клиентские компоненты SQL Server 2005 можно устанавливать в Windows 2000 Professional с пакетом обновления 4 (SP4) или более поздней версии.

Примечание.
Эта версия поддерживает подключение клиента через поток табличных данных 4.2 с помощью библиотеки прежних выпусков MDAC/DB-Library, а не с помощью новых возможностей SQL Server 2005.

Требования к оборудованию и программному обеспечению (только 64-разрядная платформа)

Требования к оборудованию (64-разрядная платформа)

В этой таблице приводятся требования к оборудованию для установки и запуска SQL Server 2005 на 64-разрядной платформе.

SQL Server 2005 (64-разрядный) | Тип процессора1 | Быстродействие процессора2 | Оперативная память (ОЗУ)3
SQL Server 2005 Enterprise Edition 4 SQL Server 2005 Developer Edition SQL Server 2005 Standard Edition | IA64: не менее процессор Itanium или более мощный x64, не менее: процессор AMD Opteron, AMD Athlon 64, Intel Xeon с поддержкой IEM64T, Intel Pentium 4 с поддержкой EM64T | IA64: не менее 1 ГГц IA64: рекомендуется 1 ГГц или более мощный x64, не менее: 1 ГГц x64: рекомендуется 1 ГГц или более мощный | IA64: не менее 512 МБ IA64: рекомендуется 1 ГБ или больше IA64, не более 32 ТБ Максимальный объем, поддерживаемый операционной системой Минимум: 512 МБ x64: рекомендуется 1 ГБ или больше x64, не более Максимальный объем, поддерживаемый операционной системой

1 Средство проверки конфигурации (SCC) заблокирует программу установки, если процессор не удовлетворяет требованиям.

2 SCC предупредит пользователя, но не заблокирует программу установки, если процессор не удовлетворяет требованиям к минимальной или рекомендованной частоте.

3 SCC предупредит пользователя, но не заблокирует программу установки, если не выполняются требования к минимальному или рекомендованному объему оперативной памяти. Требования к объему памяти относятся только к этой версии и не отражают дополнительные требования операционной системы. SCC проверяет доступный объем памяти при запуске программы установки.

4 Выпуск SQL Server 2005 Evaluation Edition поддерживает тот же набор возможностей, что и SQL Server 2005 Enterprise Edition.

Примечание.
Программное обеспечение SQL Server 2005 работает на оборудовании, сертифицированном для использования с операционной системой Microsoft Windows. Дополнительные сведения об оборудовании, сертифицированном для использования с операционной системой Windows, см. на веб-узле Microsoft: Продукты, разработанные для Microsoft Windows — Каталог Windows и HCL. Дополнительные сведения об установке решений с высоким уровнем доступности см. в разделе Настройка высокого уровня доступности.

Требования к операционной системе (64-разрядная версия)

В этой таблице представлены операционные системы, под управлением которых выполняется серверное программное обеспечение для всех 64-разрядных версий SQL Server 2005.

 | Enterprise Edition1(IA64) | Enterprise Edition1(X64) | Developer Edition (IA64)2 | Developer Edition (X64)3 | Standard Edition (IA64) | Standard Edition (X64) | Выпуски Express Edition и Express Edition with Advanced Services | Evaluation Edition (IA64) | Evaluation Edition (X64)
Windows Server 2003 Itanium Datacenter Edition (64-разрядная версия) с пакетом обновления 1 (SP1) | Да 4 | Нет | Да 4 | Нет | Да 4 | Нет | Нет | Да 4 | Нет
Windows Server 2003 Itanium Enterprise Edition (64-разрядная версия) с пакетом обновления 1 (SP1) | Да 4 | Нет | Да 4 | Нет | Да 4 | Нет | Нет | Да 4 | Нет
Windows Server 2003 x64 Standard Edition (64-разрядная версия) с пакетом обновления 1 (SP1)5 | Нет | Да 4 | Нет | Да 4 | Нет | Да 4 | WOW644 | Нет | Да 4
Windows Server 2003 x64 Datacenter Edition (64-разрядная версия) с пакетом обновления 1 (SP1)5 | Нет | Да 4 | Нет | Да 4 | Нет | Да 4 | WOW644 | Нет | Да 4
Windows Server 2003 x64 Enterprise Edition (64-разрядная версия) с пакетом обновления 1 (SP1)5 | Нет | Да 4 | Нет | Да 4 | Нет | Да 4 | WOW644 | Нет | Да 4
Windows XP x64 Professional 2003 | Нет | Да 4 | Нет | Да 4 | Нет | Да 4 | WOW644 | Нет | Да 4
Windows Vista Home Basic x64 Edition (64-разрядная версия) | Нет | Нет | Нет | Да 6 | Нет | Нет | WOW644,7 | Нет | Да 6
Windows Vista Home Premium x64 Edition (64-разрядная версия) | Нет | Нет | Нет | Да 6 | Нет | Нет | WOW644,7 | Нет | Да 6
Windows Vista Ultimate x64 Edition (64-разрядная версия) | Нет | Нет | Нет | Да 6 | Нет | Да 6 | WOW644,7 | Нет | Да 6
Windows Vista Business x64 Edition (64-разрядная версия) | Нет | Нет | Нет | Да 6 | Нет | Да 6 | WOW644,7 | Нет | Да 6
Windows Vista Enterprise x64 Edition (64-разрядная версия) | Нет | Нет | Нет | Да 6 | Нет | Да 6 | WOW644,7 | Нет | Да 6

1 Выпуск SQL Server 2005 Evaluation Edition поддерживает тот же набор компонентов, что и SQL Server 2005 Enterprise Edition, но выпуск Enterprise Edition поддерживается не во всех операционных системах, поддерживающих выпуск Evaluation Edition.

2 IA64 = архитектура Itanium.

3 X64 = архитектура AMD или архитектура Intel Extended Systems.

4 Встроенные средства и WOW64. Дополнительные сведения о WOW64 см. в разделе «Поддержка расширенных систем».

5 Поддержка SQL Server 2005 в Windows Server 2003 R2 — та же, что в Windows Server 2003 с пакетом обновления 1 (SP1).

6 SQL Server 2005 требует пакета обновления 2 (SP2) в Windows Vista.

7 SQL Server 2005 Express Edition требует SQL Server 2005 с пакетом обновления 1 (SP1) в Windows Vista. SQL Server 2005 Express Edition with Advanced Services требует SQL Server 2005 с пакетом обновления 2 (SP2) в Windows Vista.

Поддержка расширенных систем

SQL Server 2005 64-разрядные версии включают поддержку расширенных систем, также известных как Windows on Windows (WOW64). WOW64 — это функциональная возможность 64-разрядных выпусков Microsoft, позволяющая 32-разрядным приложениям выполняться в своем 32-разрядном режиме. Приложения работают в 32-разрядном режиме даже несмотря на то, что базовая операционная система выполняется на 64-разрядной платформе.

Поддерживаемые клиентские компоненты (64-разрядная версия)

64-разрядные клиентские компоненты SQL Server 2005 можно устанавливать на 64-разрядную версию. Windows Server 2003

См. также

Справочник

Выпуски и компоненты SQL Server 2005
Возможности, поддерживаемые различными выпусками SQL Server 2005

Журнал изменений

Версия Журнал

12 декабря 2006 г.

Измененное содержимое
  • Добавлены сведения о поддержке Windows Vista.

  • Обновлены требования к свободному месту на диске.


Параметры для средства проверки конфигурации системы

Параметры для средства проверки конфигурации системы |
 | См. также
Подготовка к установке SQL Server 2005 >

Дата обновления: 14 апреля 2006 г.

Являясь частью программы установки SQL Server 2005, средство проверки конфигурации системы (SCC) просматривает компьютер, на котором устанавливается . Средство SCC проверяет наличие условий, препятствующих успешной установке SQL Server. Перед тем как программа установки запустит мастер установки SQL Server 2005, SCC получает состояние каждого проверяемого элемента, сравнивает результат с необходимыми условиями и выводит советы по устранению критических препятствий. Все элементы, проверяемые средством SCC, доступны для проверки по сети. Можно проверять как локальный компьютер, так и удаленный, или элемент кластера.

В приведенной ниже таблице перечислены параметры проверки для средства SCC, требования, а также действия, обеспечивающие успешную установку SQL Server 2005.

Проверяемый элемент Описание Метод устранения сбоя

Требование к службе инструментария WMI

Служба инструментария WMI должна быть доступна. Если это требование не будет выполнено, программа установки будет прервана.

Средство SCC сообщит о несовместимости.

Требование к ядру служб Microsoft XML (MSXML)

Некоторые компоненты SQL Server 2005 требуют наличия MSXML. При необходимости они будут установлены программой установки SQL Server.

Этот фактор не блокирует программу установки.

Минимальные требования к операционной системе

Средство SCC проверяет соответствие операционной системы минимальным требованиям.

Дополнительные сведения см. в разделе Требования к оборудованию и программному обеспечению для установки SQL Server 2005.

Требование к версии операционной системы и пакету обновления (SP)

Требуется Microsoft Windows 2000 с пакетом обновления 4 (SP4), Microsoft Windows XP с пакетом обновления 2 (SP2) или Microsoft Windows Server 2003. Все неподдерживаемые операционные системы блокируют программу установки.

Примечание.
Пользователи не могут применять пакет обновления к выпускам операционных систем Datacenter без помощи изготовителя оборудования (OEM).

Для установки пакетов обновления Windows на целевом компьютере пользователю предлагается просмотреть системные требования, используя справку в Интернете или воспользоваться компонентом Windows Update. Если на компьютере установлена операционная система выпуска Datacenter, то для установки пакета обновления необходимо обратиться к производителю оборудования (OEM). Дополнительные сведения см. в разделе Требования к оборудованию и программному обеспечению для установки SQL Server 2005.

Соответствие SQL Server требованиям к операционной системе

Операционная система должна поддерживать данный выпуск SQL Server. Например, выпуск SQL Server Enterprise Edition может быть установлен только на Windows 2000 или более позднюю версию. Если это требование не будет выполнено, программа установки будет прервана.

Пользователю предлагается ссылка на справку в Интернете для просмотра таблицы соответствия операционных систем выпускам SQL Server. Дополнительные сведения см. в разделе Требования к оборудованию и программному обеспечению для установки SQL Server 2005

Минимальные требования к оборудованию

Оборудование должно соответствовать минимальным требованиям к ЦП и памяти. SCC предупредит пользователя, но не заблокирует программу установки, если процессор не удовлетворяет требованиям к минимальной или рекомендованной частоте. На многопроцессорных компьютерах предупреждения не появляются.

SCC проверяет доступный объем памяти при запуске программы установки. SCC предупредит пользователя, но не заблокирует программу установки, если не выполняются требования к минимальному или рекомендованному объему оперативной памяти. Требования к объему памяти относятся только к этой версии и не отражают дополнительные требования операционной системы.

Дополнительные сведения см. в разделе Требования к оборудованию и программному обеспечению для установки SQL Server 2005.

Доступность компонентов1,2

Перед установкой доступных компонентов SQL Server в дереве выбора компонентов SQL Server будет выполнена проверка на соответствие предварительным требованиям.

Результаты отобразятся в отчете SCC, в котором будут перечислены недоступные компоненты и зависимые от них компоненты.

Требование необходимости перезагрузки

Программа установки SQL Server не запустится, если необходимые файлы будут заняты другими службами, процессами или приложениями. Если это требование не будет выполнено, программа установки будет прервана.

Средство SCC предложит перезагрузить операционную систему и повторно запустить программу установки.

Требование к счетчику системного монитора

Средство SCC проверяет значения ключей реестра на соответствие увеличения счетчиков системного монитора для установки SQL Server. Если это требование не будет выполнено, программа установки будет прервана.

Пользователи должны обновить реестр. Сведения о ручном обновлении разделов реестра см. в разделе Как увеличить значение счетчика в разделе реестра для программы установки SQL Server 2005.

Требование к разрешению на доступ к каталогу установки

Средство SCC проверит наличие разрешений на форматирование жестких дисков, а также на чтение и запись. Кроме того, программа установки требует, чтобы SQL Server был установлен на не сжатом диске. Если это требование не будет выполнено, программа установки будет прервана.

Если диск не отформатирован, защищен от записи или сжат, то средство SCC выдает ошибку.

Требование к каталогу COM+

Средство SCC проверит текущую конфигурацию каталога COM+.

Средство SCC определяет неполадки и дает рекомендации по их устранению. Дополнительные сведения см. в файле Readme или в документе «Известные неполадки при установке» на установочном диске SQL Server 2005.

Требование к наличию прав доступа системного администратора

Пользователь, запускающий программу установки, должен обладать правами доступа администратора на всех компьютерах назначения: локальных, удаленных, а также на узлах кластера, на которых устанавливается SQL Server.

Средство SCC предложит пользователю выйти из системы и войти снова после добавления его учетной записи прав доступа администратора либо предложит войти в систему под именем пользователя, обладающего такими правами.

Требование к административной общей папке по умолчанию (только для удаленной/кластерной установки)

На каждом узле кластера должна быть административная общая папка по умолчанию admin$, что позволит процессам установки подключаться к системным файлам. Если это требование не будет выполнено, программа установки будет прервана.

Средство SCC попросит устранить неполадку с помощью включения общей папки по умолчанию.

1 Для установки служб Reporting Services необходимо наличие служб Microsoft IIS 5.0 или более поздней версии.

2 Для установки конструктора отчетов в службах Reporting Services необходим обозреватель Microsoft Internet Explorer 6.0 с пакетом обновления 1 (SP1).

См. также

Справочник

Требования к оборудованию и программному обеспечению для установки SQL Server 2005


Анализ безопасности при установке SQL Server

Анализ безопасности при установке SQL Server |
 | См. также
Подготовка к установке SQL Server 2005 >

Безопасность важна не только для и корпорации Майкрософт, но и для каждого продукта и бизнеса в целом. Следуя простым рекомендациям, можно избежать многих уязвимостей в безопасности. В этом разделе описываются некоторые рекомендации по безопасности, которым стоит следовать как до, так и после установки SQL Server. Сведения по безопасности для конкретных компонентов приводятся в справочных разделах по этим компонентам.

Перед установкой SQL Server

При настройке среды сервера выполняйте следующие рекомендации.

  • Повышение физической безопасности

  • Использование брандмауэров

  • Изолирование служб

  • Создание учетных записей служб с минимально возможными правами доступа

  • Отключение протоколов NetBIOS и SMB

Повышение физической безопасности

Физическая и логическая изоляции составляют основу безопасности SQL Server. Для повышения физической безопасности установки SQL Server выполните следующие действия.

  • Поместите сервер в помещении, недоступном для посторонних.

  • Установите компьютеры, на которых размещены базы данных, в физически защищенных местах, идеальным вариантом является запертая компьютерная комната с системой электромагнитного и противопожарного контроля или системой подавления помех.

  • Установите базы данных в безопасной зоне корпоративной сети, которая не подключена к Интернету напрямую.

  • Регулярно создавайте резервные копии и храните их в безопасном месте за пределами расположения компьютера.

Использование брандмауэров

Брандмауэры являются неотъемлемой частью безопасности установки SQL Server. Брандмауэры будут более эффективны, если следовать приведенным ниже правилам.

  • Установите брандмауэр между сервером и Интернетом.

  • Разделите сеть на зоны безопасности, разделенные брандмауэрами. Заблокируйте весь поток данных, после чего разрешите только необходимый.

  • В многоуровневом окружении используйте несколько брандмауэров для создания защищенных подсетей.

  • Настройте внутренние брандмауэры на разрешение проверки подлинности Windows, если устанавливаете сервер внутри домена Windows.

  • В домене Windows, в котором все версии Windows являются Windows XP или Windows Server 2003 или более поздних версий, отключите проверку подлинности NTLM. .

  • Если приложение использует распределенные транзакции, возможно, придется настроить брандмауэр так, чтобы разрешить передачу данных координатора распределенных транзакций Microsoft (MS DTC) между отдельными экземплярами MS DTC и между MS DTC и диспетчерами ресурсов, такими как SQL Server.

Изолирование служб

Изолирование служб уменьшает риск того, что подвергнувшаяся опасности служба подвергнет опасности другие службы. Чтобы изолировать службы, следуйте приведенным ниже правилам.

  • Если это возможно, не устанавливайте SQL Server на контроллере домена.

  • Запускайте разные службы SQL Server под разными учетными записями Windows.

  • В многоуровневых системах запускайте веб-логику и бизнес-логику на разных компьютерах.

Создание учетных записей служб с минимальными правами доступа

Установка сервера SQL Server автоматически настраивает учетные записи служб с определенными разрешениями, необходимыми для SQL Server. При изменении или настройке служб Windows, используемых сервером SQL Server 2005, следует предоставлять только те разрешения, которые необходимы. Дополнительные сведения см. в разделе Настройка учетных записей служб Windows.

Отключение протоколов NetBIOS и SMB

На внешних серверах сети должны быть отключены все ненужные протоколы, включая NetBIOS и SMB.

NetBIOS использует следующие порты:

  • UDP/137 (служба имен NetBIOS);

  • UDP/138 (служба дейтаграмм NetBIOS);

  • UDP/139 (служба сеанса NetBIOS).

SMB использует следующие порты:

  • TCP/139

  • TCP/445

Веб-серверы и DNS-серверы не требуют наличия NetBIOS или SMB. На этих серверах отключите оба протокола, чтобы избежать угрозы перечисления пользователей. Дополнительные сведения об отключении данных протоколов см. в разделах Как отключить протокол NetBIOS через TCP/IP или Как отключить протокол SMB.

После установки SQL Server

После установки можно усилить безопасность установки SQL Server, следуя приведенным ниже советам относительно учетных записей и режимов проверки подлинности.

Учетные записи службы

  • Запускайте службы SQL Server с минимально возможными правами доступа.

  • Свяжите службы SQL Server с учетными записями Windows.

Режим проверки подлинности

  • Требует проверку подлинности Windows для подключений к SQL Server.

Надежные пароли

  • Всегда назначайте надежный пароль учетной записи sa.

  • Всегда включайте проверку политики паролей.

  • Для любых имен входа SQL Server пользуйтесь только надежными паролями.

См. также

Другие ресурсы

Политика паролей


Сведения об использовании SQL Server 2005 в Windows Vista

Сведения об использовании SQL Server 2005 в Windows Vista
Подготовка к установке SQL Server 2005 >

требуется пакет обновления 2 (SP2) для запуска в Windows Vista. Дополнительные сведения см. в разделе Требования к оборудованию и программному обеспечению для установки SQL Server 2005.

Следующие рекомендации применяются при установке и выполнении SQL Server 2005 с пакетом обновления 2 (SP2) в Windows Vista.

Проблемы, вызванные управлением учетными записями пользователя в Windows Vista

Windows Vista включает новую функцию «Управление учетными записями пользователя» (UAC), которая помогает администраторам управлять повышенными разрешениями. По умолчанию администраторы Windows Vista не пользуются своими административными правами, выполняя большинство операций от имени обычных пользователей (не администраторов) и принимая административные права только по необходимости.

UAC вызывает некоторые проблемы. Дополнительные сведения см. на следующих веб-страницах TechNet.

  • Windows Vista: управление учетными записями пользователя

  • Пошаговое руководство по управлению учетными записями пользователя в Windows Vista

Права администратора не наследуются из Windows

В версиях, предшествующих Windows Vista, члены локальной группы «Администраторы» не нуждались в собственных именах входа SQL Server и правах администратора в SQL Server. Они соединялись с SQL Server в качестве встроенного сервера-участника BUILTIN\Administrators и имели права администратора в SQL Server, поскольку BUILTIN\Administrators является членом фиксированной серверной роли sysadmin.

В Windows Vista эти механизмы применяются только к административным пользователям с повышенными разрешениями Windows, а это не рекомендуется. Вместо этого следует создать имя входа SQL Server (с помощью параметра FROM WINDOWS) для каждого административного пользователя и добавить это имя входа к фиксированной серверной роли sysadmin. Это нужно также сделать для учетных записей Windows, которые используются для запуска заданий агента SQL Server. Это включает задания агента репликации.

Добавление нового имени входа к фиксированной серверной роли sysadmin при входе в систему с именем «имя_компьютера\администратор»

  1. Нажмите кнопку Пуск, выберите пункт Все программы, SQL Server 2005 и щелкните Среда SQL Server Management Studio.

  2. Соединитесь с SQL Server.

  3. Чтобы добавить пользователя Windows к фиксированной серверной роли sysadmin, выполните следующее.

    1. Перейдите на вкладку Безопасность.

    2. Щелкните правой кнопкой мыши значок Имена входа и выберите Новое имя входа.

    3. В текстовое поле Имя входа введите имя пользователя.

    4. Перейдите на вкладку Серверные роли.

    5. Установите флажок sysadmin и нажмите кнопку OK.
Добавление нового имени входа к фиксированной серверной роли sysadmin при входе в систему с неадминистративными правами

  1. Нажмите кнопку Пуск, выберите пункт Все программы, SQL Server 2005, щелкните правой кнопкой мыши Среда SQL Server Management Studio и выберите Запуск от имени..., указав учетную запись администратора.

    Примечание.
    Запуск от имени... с использованием учетной записи администратора повышает уровень разрешений пользователя.

  2. Появится диалоговое окно Управление учетной записью пользователя. Возможно, потребуется представить учетные данные администратора. Нажмите кнопку Продолжить.

  3. В среде SQL Server Management Studio подключитесь к SQL Server.

  4. Чтобы добавить пользователя Windows к фиксированной серверной роли sysadmin, выполните следующее.

    1. Перейдите на вкладку Безопасность.

    2. Щелкните правой кнопкой мыши значок Имена входа и выберите Новое имя входа.

    3. В текстовое поле Имя входа введите имя пользователя.

    4. Перейдите на вкладку Серверные роли.

    5. Установите флажок sysadmin и нажмите кнопку OK.
Отказ в доступе администратору к развертыванию сервера отчетов

UAC может предотвратить доступ администратора к развертыванию сервера отчетов. Чтобы получить административный доступ, подключитесь к SQL Server, используя описанный выше способ, обходящий ограничения, и создайте назначения ролей своей учетной записи для корневой папки и системы. Работать в среде SQL Server Management Studio с повышенными разрешениями нужно только для создания назначения ролей для своей учетной записи и для получения доступа к серверу отчетов, если соответствующее назначение ролей было удалено. После создания назначения ролей для учетной записи можно закрыть среду SQL Server Management Studio и снова открыть ее со стандартными разрешениями. Новое назначение ролей предоставляет достаточные права для создания дополнительных назначений ролей для пользователей.

Отказ в локальном доступе к виртуальным каталогам сервера отчетов

Если попытаться получить доступ к диспетчеру отчетов или серверу отчетов с помощью Internet Explorer, будет получена ошибка отказа в доступе. Чтобы избежать ее, добавьте диспетчер отчетов и URL-адрес сервера отчетов к доверенным веб-узлам в Internet Explorer.

Ошибка при открытии командной строки служб Notification Services

При попытке открыть командную строку служб Notification Services будет получена ошибка «Доступ запрещен». Причина заключается в том, что для доступа к папке служб Notification Services в каталоге <диск>\Program Files\Microsoft SQL Server\90 требуются права администратора.

Чтобы запустить командную строку служб Notification Services, войдите в систему с учетной записью администратора или запустите командную строку Notification Services с повышенными разрешениями.

Использование учетной записи администратора

  1. Войдите в систему с локальной учетной записью администратора.

  2. В меню Пуск выберите Все программы, Microsoft SQL Server 2005, Средства настройки, щелкните правой кнопкой мыши Командная строка Notification Services и выберите Запуск от имени..., указав учетную запись администратора.
Использование повышенных разрешений

  1. Войдите в систему с учетной записью, которая является членом локальной группы администраторов.

  2. В меню Пуск выберите пункт Мой компьютер.

  3. Найдите папку <диск>\Program Files\Microsoft SQL Server\90\NotificationServices.

  4. Когда появится сообщение «Отсутствуют разрешения для доступа к этой папке», нажмите кнопку Продолжить.

    Примечание.
    Если это сообщение не появится, у вас уже имеются разрешения для доступа к этой папке.

  5. Щелкните правой кнопкой мыши Командная строка Notification Services и выберите Запуск от имени..., указав учетную запись администратора.
Команды служб Notification Services в среде SQL Server Management Studio возвращают ошибку

При попытке выполнить команды служб Notification Services в среде SQL Server Management Studio может возникнуть ошибка «Ссылка объекта не установлена на экземпляр объекта». Причина заключается в том, что для запуска некоторых команд служб Notification Services требуются административные разрешения.

Запуск среды SQL Server Management Studio с повышенными разрешениями

  1. Войдите в систему с учетной записью администратора.

  2. Нажмите кнопку Пуск, выберите пункт Все программы, Microsoft SQL Server 2005, щелкните правой кнопкой мыши Среда SQL Server Management Studio и выберите Запуск от имени..., указав учетную запись администратора.

Если не требуется запускать среду SQL Server Management Studio с повышенными разрешениями, то для развертывания и администрирования Notification Services можно использовать командную строку служб Notification Services.

Разрешения на хранилище моментальных снимков репликации необходимо предоставлять явно

UAC может предотвращать доступ администратора к хранилищу моментальных снимков. Необходимо явно предоставить разрешения на доступ к хранилищу моментальных снимков учетным записям Windows, которые используются агентом моментальных снимков, агентом распространителя и агентом слияния. Это нужно сделать, даже если учетные записи Windows входят в группу администраторов. Дополнительные сведения см. в разделе «Модель безопасности агента репликации» в электронной документации SQL Server.

Счетчики производительности SQL Server не видны в системном мониторе

В этой версии SQL Server 2005 с пакетом обновления 2 (SP2) счетчики производительности SQL Server не видны в системном мониторе операционной системы Windows Vista. Тем не менее, счетчики производительности SQL Server представлены в динамическом административном представлении sys.dm_os_performance_counters.


Настройка учетных записей служб Windows

Настройка учетных записей служб Windows |
 | См. также
Подготовка к установке SQL Server 2005 >

Дата обновления: 12 декабря 2006 г.

Каждая служба в SQL Server представляет собой процесс или набор процессов для управления проверкой подлинности операций SQL Server с помощью Microsoft Windows. В этом разделе представлена конфигурация по умолчанию для служб этой версии SQL Server, а также параметры конфигурации служб SQL Server, которые можно настроить во время установки SQL Server.

Примечание безопасности. Всегда запускайте службы SQL Server от имени пользователя с минимально возможными правами.

В зависимости от выбранных при установке компонентов программа установки SQL Server 2005 устанавливает следующие службы.

  • Службы SQL Server Database Services — службы реляционной базы данных компонента SQL Server Database Engine.

  • Агент SQL Server — cлужит для выполнения заданий, контроля за SQL Server, предупреждения о нештатных ситуациях, а также позволяет автоматизировать некоторые задачи по администрированию.

    Примечание.
    Для запуска SQL Server и агента SQL Server в качестве служб Windows SQL Server и агенту SQL Server должна быть назначена учетная запись пользователя Windows. Чаще всего службе SQL Server и агенту SQL Server назначается одна и та же учетная запись — либо пользователя локальной системы, либо пользователя домена. Однако параметры каждой службы можно настроить в процессе установки. Дополнительные сведения о настройке данных учетной записи для каждой службы см. в разделе Учетная запись службы.

  • Службы Analysis Services — предоставляют средства интерактивной аналитической обработки (OLAP) и средства интеллектуального анализа данных для приложений бизнес-аналитики.

  • Службы Reporting Services — cлужат для управления отчетами, их выполнения (в том числе по расписанию), подготовки и доставки.

  • Службы Notification Services — представляют собой платформу для разработки и развертывания приложений, формирующих и отправляющих уведомления.

  • Службы Integration Services — обеспечивают поддержку управления хранением и выполнением пакетов служб Integration Services.

  • Компонент Full-Text Search — позволяет быстро создавать полнотекстовые индексы содержимого и свойств структурированных и частично структурированных данных для обеспечения быстрого лингвистического поиска в этих данных.

  • Обозреватель SQL Server — служба разрешения имен, поставляющая данные соединения с SQL Server для клиентских компьютеров.

  • Модуль поддержки Active Directory сервера SQL Server — обеспечивает публикацию и управление службами SQL Server в Active Directory.

  • Модуль записи SQL — служит для резервного копирования и восстановления приложений для работы в составе службы теневого копирования томов (VSS).

Оставшаяся часть этого раздела состоит из следующих подразделов:

  • Настройка служб, доступных в программе установки SQL Server

  • Использование стартовых учетных записей для запуска служб SQL Server

  • Идентификация зависимых и независимых от экземпляра служб

  • Обзор прав доступа и привилегий NT, предоставляемых учетным записям служб SQL Server

  • Обзор списков управления доступом, создаваемых для учетных записей служб SQL Server

  • Обзор разрешений Windows для служб SQL Server

  • Обзор дополнительных вопросов

  • Локализованные имена служб

Настройка служб, доступных в программе установки SQL Server

Во время выполнения программы установки SQL Server можно настроить некоторые службы SQL Server, указав стартовую учетную запись и определив автозапуск службы. В таблице ниже приведены службы SQL Server, которые могут быть настроены в ходе установки. Для автоматической установки можно использовать параметры в файле установки или командной строке.

Имя службы SQL Server | Настраивается ли в мастере установки | Параметры для автоматической установки1
MSSQLSERVER | Да | SQLACCOUNT, SQLPASSWORD, SQLAUTOSTART
SQLServerAgent | Да | AGTACCOUNT, AGTPASSWORD, AGTAUTOSTART
MSSQLServerOLAPService | Да | ASACCOUNT, ASPASSWORD, ASAUTOSTART
ReportServer | Да | RSACCOUNT, RSPASSWORD, RSAUTOSTART
SQLBrowser | Да | SQLBROWSERACCOUNT, SQLBROWSERPASSWORD, SQLBROWSERAUTOSTART2

1Дополнительные сведения и примеры синтаксиса для удаленной автоматической установки см. в разделе Как установить SQL Server 2005 из командной строки.

2Параметр SQLBROWSERAUTOSTART можно задать, даже если обозреватель SQL Server уже установлен.

Следующие службы не могут быть настроены в ходе установки. Они устанавливаются с настройками по умолчанию:

  • Notification Services

  • Integration Services

  • Компонент Full-Text Search

  • Модуль поддержки Active Directory

  • Модуль записи SQL

Использование стартовых учетных записей для запуска служб SQL Server

Для запуска каждой службы в SQL Server 2005 ей должна быть назначена учетная запись пользователя. Учетные записи могут быть встроенными в систему либо учетными записями пользователей домена.

Кроме учетной записи каждая служба имеет три возможных типа запуска, которыми могут управлять пользователи.

  • Отключено Служба установлена, но в данный момент не запущена.

  • Вручную Служба установлена, но будет запущена только в случае, когда другая служба или приложение затребует ее функциональность.

  • Авто Служба запускается операционной системой после загрузки драйверов устройств во время загрузки системы.

В следующей таблице показаны установленные по умолчанию и дополнительные учетные записи для каждой из служб SQL Server, а также типы запуска для каждой службы.

Имя службы SQL Server | Учетная запись по умолчанию | Дополнительные учетные записи | Тип запуска | Состояние после установки по умолчанию
SQL Server | SQL Server Express Edition в Windows 2000: локальная система SQL Server Express Edition во всех других поддерживаемых операционных системах: сетевая служба Все другие выпуски во всех поддерживаемых операционных системах: пользователь домена1 | SQL Server Express Edition: пользователь домена, локальная система, сетевая служба1. Все другие выпуски: пользователь домена, локальная система, сетевая служба1. | Авто2 | Работает Остановлена, если пользователь отменил автозапуск.
Агент SQL Server | Пользователь домена3 | пользователь домена, локальная система, сетевая служба1,6 | Отключено Авто, если пользователь выбрал автозапуск | Остановлена Работает, если пользователь выбрал автозапуск
Analysis Services | Пользователь домена3 | Пользователь домена, локальная система, сетевая служба, локальная служба | Авто | Работает Остановлена, если пользователь отменил автозапуск
Reporting Services | Пользователь домена3. | Пользователь домена, локальная система, сетевая служба, локальная служба. | Авто | Работает Остановлена, если пользователь отменил автозапуск.
Notification Services4 | Н/Д | Н/Д | Н/Д | Н/Д
Integration Services | Windows 2000: локальная система Все другие поддерживаемые операционные системы: сетевая служба | Пользователь домена, локальная система, сетевая служба, локальная служба | Авто | Работает Остановлена, если пользователь отменил автозапуск.
Компонент Full-Text Search | Та же учетная запись, что и для SQL Server | Пользователь домена, локальная система, сетевая служба, локальная служба | Вручную | Остановлена Работает, если пользователь выбрал автозапуск.
Обозреватель SQL Server | SQL Server Express Edition в Windows 2000: Локальная система SQL Server Express Edition во всех других поддерживаемых операционных системах: локальная служба Все другие выпуски во всех поддерживаемых операционных системах: пользователь домена1,3 | Пользователь домена, локальная система, сетевая служба, локальная служба | Отключен5 Авто, если пользователь выбрал автозапуск. | Остановлена5 Работает, если пользователь выбрал автозапуск.
Модуль поддержки Active Directory в службах SQL Server | Сетевая служба | Локальная система, сетевая служба | Отключен | Остановлена
Модуль записи SQL | Локальная система | Локальная система | Вручную | Остановлена

1 Внимание Корпорация Майкрософт не рекомендует использовать учетную запись «Сетевая служба» для SQL Server и агента SQL Server. Для этих служб SQL Server больше подходят учетные записи «Локальный пользователь» или «Пользователь домена».

2В конфигурациях с отказоустойчивым кластером следует устанавливать тип «Вручную».

3При автоматической установке это свойство является необходимым. Если не задано, в программе установки произойдет сбой. Учетную запись «Локальная система» можно задать с помощью выражения SQLAccount=LocalSystem или ASAccount=LocalSystem. Дополнительные сведения и примеры синтаксиса для удаленной и автоматической установки см. в разделе Как установить SQL Server 2005 из командной строки.

4Программа установки SQL Server может установить службы Notification Services, но не поддерживает их настройку. Дополнительные сведения о включении служб Notification Services после завершения установки см. в разделе «Настройка служб Notification Services в Windows» в электронной документации по SQL Server 2005.

5При конфигурации с отказоустойчивым кластером обозреватель SQL Server настраивается на автоматический запуск и запускается по умолчанию после завершения программы установки.

6Дополнительные сведения о поддерживаемых учетных записях Windows для агента SQL Server см. в разделе Поддерживаемые типы учетных записей Windows, которые могут быть использованы для запуска службы агента SQL Server в SQL Server 2005.

Важно!
При конфигурации с отказоустойчивым кластером учетные записи локальной системы и сетевой службы для служб, поддерживающих работу в кластере, таких как SQL Server, агент SQL Server и служб SSAS, не поддерживаются. Дополнительные сведения см. в разделе Подготовка к установке отказоустойчивого кластера.

Для установки SQL Server 2005 в параллельной конфигурации с ранними версиями SQL Server службы SQL Server 2005 должны использовать учетные записи только из глобальной группы доменов. Кроме того, учетные записи, которые используют службы SQL Server 2005, не должны присутствовать в локальной группе администраторов. Несоблюдение этих рекомендаций может привести к непредвиденным последствиям для безопасности.

Использование учетной записи «Пользователь домена»

Учетную запись «Пользователь домена» рекомендуется использовать, если предусматривается взаимодействие службы с сетевыми службами. Многие операции взаимодействия сервера с сервером могут быть выполнены только с учетной записью пользователя домена, например:

  • удаленные вызовы процедур;

  • репликация;

  • резервное копирование на сетевые диски;

  • гетерогенные соединения, затрагивающие удаленные источники данных;

  • функции работы с почтой агента SQL Server и службы SQL Mail. Данное ограничение действует только при использовании сервера Microsoft Exchange. Клиенты большинства других систем электронной почты, подобных службам SQL Server и агенту SQL Server, должны быть запущены под учетными записями с доступом к сети.

Использование учетной записи «Локальная служба»

«Локальная служба» — особая встроенная учетная запись, подобная учетной записи пользователя, прошедшего проверку подлинности. Учетная запись «Локальная служба» обладает таким же уровнем доступа к ресурсам и объектам, как и члены группы «Пользователи». Такой ограниченный доступ помогает защитить систему в случае компрометации отдельных служб или процессов. Службы, запущенные с учетной записью «Локальная служба», получают доступ к сетевым ресурсам в форме неопределенного сеанса без учетных данных.

Использование учетной записи «Сетевая служба»

«Сетевая служба» — особая встроенная учетная запись, подобная учетной записи пользователя, прошедшего проверку подлинности. Учетная запись «Сетевая служба» обладает таким же уровнем доступа к ресурсам и объектам, что и члены группы «Пользователи». Службы, запущенные с учетной записью «Сетевая служба», получают доступ к сетевым ресурсам с использованием учетных данных учетной записи компьютера.

Важно!
Корпорация Майкрософт не рекомендует использовать учетную запись «Сетевая служба» для служб SQL Server и агента SQL Server. Для этих SQL-служб больше подходят учетные записи «Локальный пользователь» или «Пользователь домена».

Использование учетной записи «Локальная система»

«Локальная система» — учетная запись с широкими правами доступа; следует соблюдать осторожность при назначении разрешений учетной записи «Локальная система» учетным записям служб SQL Server.

Примечание безопасности.
Для повышения безопасности установленной копии SQL Server службы SQL Server следует запускать под локальной учетной записью Windows с минимально возможными правами доступа.

Изменение учетных записей пользователей

Чтобы изменить пароль или другие свойства службы, связанной с SQL Server, используйте диспетчер конфигурации SQL Server. При изменении пароля входа в Windows не забудьте также обновить параметры служб SQL Server в Windows. Если включена служба Kerberos, не забудьте обновить свойство каталога Service Principal Name (SPN) для службы Active Directory.

Дополнительные сведения см. в разделе Изменение паролей и учетных записей пользователей. Сведения об использовании надстроек служб для изменения учетных записей служб SQL Server см. в разделе Как изменить учетные записи служб SQL Server и агента SQL Server, не используя программу SQL Enterprise Manager в SQL Server 2000 или диспетчер конфигурации SQL Server в SQL Server 2005.

Идентификация зависимых и не зависимых от экземпляра служб

Некоторые из служб SQL Server привязаны к экземпляру, в то время как другие не привязаны. Каждая служба, привязанная к экземпляру, соответствует конкретному экземпляру SQL Server, и ей назначается отдельный куст реестра. Можно установить несколько копий служб, привязанных к экземпляру, запуская программу установки SQL Server для каждого компонента или службы. Службы, не привязанные к экземпляру, совместно используются всеми установленными экземплярами SQL Server; они не связаны с конкретным экземпляром, устанавливаются только один раз и не могут быть установлены параллельно.

В службы, привязанные к экземпляру, в входят следующие:

  • SQL Server

  • агент SQL Server;

  • службы Analysis Services;

  • службы Reporting Services;

  • компонент Full-Text Search.

В службы, не привязанные к экземпляру, в SQL Server 2005 входят следующие:

  • службы Notification Services;

  • службы Integration Services;

  • обозреватель SQL Server;

  • модуль поддержки Active Directory в SQL Server;

  • модуль записи SQL.

Обзор прав доступа и привилегий, предоставляемых в Windows NT учетным записям служб SQL Server

Программа установки SQL Server создает группы пользователей для различных служб SQL Server и добавляет в них соответствующие учетные записи служб. Эти группы упрощают предоставление разрешений, необходимых для запуска служб SQL Server и других исполняемых файлов, и позволяют обеспечивать защиту файлов SQL Server. Обратите внимание, что уникальные имена групп файлов обязательны при установке SQL Server 2005 на контроллере домена.

Группам пользователей, созданным программой установки SQL Server, предоставляются следующие права доступа Windows NT.

Служба SQL Server Группа пользователей Разрешения, предоставляемые по умолчанию программой установки SQL Server

SQL Server

Экземпляр по умолчанию: SQLServer2005MSSQLUser$ИмяКомпьютера$MSSQLSERVER

Именованный экземпляр: SQLServer2005MSSQLUser$ИмяКомпьютера$ИмяЭкземпляра

Вход в систему в качестве службы (SeServiceLogonRight)

Работа в качестве части операционной системы (SeTcbPrivilege) (только в Windows 2000)

Вход в систему в качестве пакетного задания (SeBatchLogonRight)

Замена маркера уровня процесса (SeAssignPrimaryTokenPrivilege)

Обход проходной проверки (SeChangeNotifyPrivilege)

Назначение квот памяти процессам (SeIncreaseQuotaPrivilege)

Разрешение на запуск модуля поддержки Active Directory в службах SQL Server

Разрешение на запуск службы SQL Writer

Агент SQL Server

Экземпляр по умолчанию: SQLServer2005SQLAgentUser$ИмяКомпьютера$MSSQLSERVER

Именованный экземпляр: SQLServer2005SQLAgentUser$ИмяКомпьютера$ИмяЭкземпляра

Вход в систему в качестве службы (SeServiceLogonRight)

Работа в качестве части операционной системы (SeTcbPrivilege) (только в Windows 2000)

Вход в систему в качестве пакетного задания (SeBatchLogonRight)

Замена маркера уровня процесса (SeAssignPrimaryTokenPrivilege)

Обход проходной проверки (SeChangeNotifyPrivilege)

Назначение квот памяти процессам (SeIncreaseQuotaPrivilege)

Службы Analysis Services

Экземпляр по умолчанию: SQLServer2005MSOLAPUser$ИмяКомпьютера$MSSQLSERVER

Именованный экземпляр: SQLServer2005MSOLAPUser$ИмяКомпьютера$ИмяЭкземпляра

Вход в систему в качестве службы (SeServiceLogonRight)

Службы Reporting Services1

Экземпляр по умолчанию: SQLServer2005ReportServerUser$ИмяКомпьютера$MSSQLSERVER и SQLServer2005ReportingServicesWebServiceUser$ИмяКомпьютера$MSSQLSERVER

Именованный экземпляр: SQLServer2005ReportServerUser$ИмяКомпьютера$ИмяЭкземпляра и SQLServer2005ReportingServicesWebServiceUser$ИмяКомпьютера$ИмяЭкземпляра

Вход в систему в качестве службы (SeServiceLogonRight)

Службы Notification Services2

Именованный или установленный по умолчанию экземпляр: SQLServer2005NotificationServicesUser$ИмяКомпьютера

Н/Д

Службы Integration Services

Именованный или установленный по умолчанию экземпляр: SQLServer2005DTSUser$ИмяКомпьютера

Вход в систему в качестве службы (SeServiceLogonRight)

Разрешение на запись в журнал событий приложения

Обход проходной проверки (SeChangeNotifyPrivilege)

Создание глобальных объектов (SeCreateGlobalPrivilege)

Олицетворение клиента после проверки подлинности (SeImpersonatePrivilege)

Компонент Full-Text Search

Экземпляр по умолчанию: SQLServer2005MSFTEUser$ИмяКомпьютера$MSSQLSERVER

Именованный экземпляр: SQLServer2005MSFTEUser$ИмяКомпьютера$ИмяЭкземпляра

Вход в систему в качестве службы (SeServiceLogonRight)

Обозреватель SQL Server

Именованный или установленный по умолчанию экземпляр: SQLServer2005SQLBrowserUser$ИмяКомпьютера

Вход в систему в качестве службы (SeServiceLogonRight)

Модуль поддержки Active Directory в службах SQL Server

Именованный или установленный по умолчанию экземпляр: SQLServer2005MSSQLServerADHelperUser$ИмяКомпьютера

Нет3

Модуль записи SQL

Н/Д

Нет3

1Для служб Reporting Services программа установки SQL Server должна также создать группы пользователей SQLServer2005ReportingServicesWebServiceUser$ИмяЭкземпляра и SQLServer2005ASP.NETUser и предоставить для них списки управления доступом (ACL). Дополнительные сведения см. в разделе ниже о списках управления доступом.

2Программа установки SQL Server может установить службы Notification Services, но не поддерживает их настройку. Дополнительные сведения о включении служб Notification Services после завершения установки см. в разделе «Настройка служб Notification Services в Windows» в электронной документации по SQL Server 2005.

3 Программа установки SQL Server не проверяет и не предоставляет разрешения для данной службы.

Обзор списков управления доступом, создаваемых для учетных записей служб SQL Server

Учетные записи служб SQL Server 2005 должны иметь доступ к ресурсам. Списки управления доступом (ACL) устанавливаются на уровне группы пользователей. В следующей таблице перечислены списки ACL, создаваемые программой установки SQL Server.

Важно!
При конфигурации с отказоустойчивым кластером нельзя включать ресурсы на общих дисках ни в один список ACL в локальной группе пользователей. Вместо этого такие ресурсы можно включить в список ACL для локальной учетной записи.

Учетная запись службы | Файлы и папки | Доступ
MSSQLServer | Instid\MSSQL\backup | Полный доступ
 | Instid\MSSQL\binn | Чтение и выполнение
 | Instid\MSSQL\data | Полный доступ
 | Instid\MSSQL\FTData | Полный доступ
 | Instid\MSSQL\Install | Чтение и выполнение
 | Instid\MSSQL\Log | Полный доступ
 | Instid\MSSQL\Repldata | Полный доступ
 | 90\shared | Чтение и выполнение
 | 90\shared\Errordumps | Чтение и запись
 | 90\com | Чтение и выполнение
 | Instid\MSSQL\Template Data (только для выпуска SQL Server Express) | Чтение
SQLServerAgent | Instid\MSSQL\binn | Полный доступ
 | Instid\MSSQL\Log | Полный доступ
 | Instid\MSSQL\jobs | Полный доступ
 | 90\com | Чтение и выполнение
 | 90\shared | Чтение и выполнение
 | 90\shared\Errordumps | Чтение и запись
FTS | Instid\MSSQL\FTData | Полный доступ
 | Instid\MSSQL\FTRef | Чтение и выполнение
 | 90\shared | Чтение и выполнение
 | 90\shared\Errordumps | Чтение и запись
 | Instid\MSSQL\Install | Чтение и выполнение
MSSQLServerOLAPservice | 90\shared | Чтение и выполнение
 | 90\shared\msmdlocal.ini | Полный доступ
 | Instid\OLAP | Чтение и выполнение
 | Instid\Olap\Data | Полный доступ
 | Instid\Olap\Log | Чтение и запись
 | 90\shared\Errordumps | Чтение и запись
SQLServer2005ReportServerUser | Instid\Reporting Services\Log Files | Чтение, запись и удаление
 | Instid\Reporting Services\ReportServer | Чтение и выполнение
 | Instid\Reportingservices\Reportserver\global.asax | Полный доступ
 | Instid\Reportingservices\Reportserver\Reportserver.config | Чтение и запись
 | Instid\Reporting Services\reportManager | Чтение и выполнение
 | Instid\Reporting Services\RSTempfiles | Чтение и запись
 | 90\shared | Чтение и выполнение
 | 90\shared\Errordumps | Чтение и запись
SQLServer2005ReportingServicesWebServiceUser | Instid\Reporting Services\Log Files | Чтение, запись и удаление
 | Instid\Reporting Services\ReportServer | Чтение и выполнение
 | Instid\Reportingservices\Reportserver\global.asax | Полный доступ
 | InstID\Reporting Services\reportservice.asmx | Полный доступ
 | Instid\Reportingservices\Reportserver\Reportserver.config | Чтение, запись и удаление
 | Instid\Reporting Services\reportManager | Чтение и выполнение
 | Instid\Reporting Services\RSTempfiles | Чтение и запись
 | Instid\Reporting Services\reportManager\pages | Чтение
 | Instid\Reporting Services\reportManager\Styles | Чтение
 | Instid\Reporting Services\reportManager\webctrl_client\1_0 | Чтение
 | 90\shared | Чтение и выполнение
 | 90\shared\Errordumps | Чтение и запись
Службы Notification Services | 90\Notification services | Чтение и выполнение, список содержимого папки
 | 90\shared | Чтение и выполнение
 | 90\shared\Errordumps | Чтение и запись
MSDTSServer | 90\dts\binn\MsDtsSrvr.ini.xml | Чтение
 | 90\dts\binn | Чтение и выполнение
 | 90\shared | Чтение и выполнение
 | 90\shared\Errordumps | Чтение и запись
Обозреватель SQL Server | 90\shared\msmdlocal.ini | Чтение
 | 90\shared | Чтение и выполнение
 | 90\shared\Errordumps | Чтение и запись
MSADHekper | N/A (Запускается в качестве встроенных учетных записей) |
SQLWriter | N/A (Запускается с учетной записью Local System) |
Пользователь | Instid\MSSQL\binn | Чтение и выполнение
 | Instid\Reporting Services\ReportServer | Чтение и выполнение
 | Instid\Reportingservices\Reportserver\global.asax | Чтение
 | InstID\Reporting Services\reportservice.asmx | Чтение и выполнение
 | Instid\Reporting Services\reportManager | Чтение и выполнение
 | Instid\Reporting Services\reportManager\pages | Чтение
 | Instid\Reporting Services\reportManager\Styles | Чтение
 | 90\dts | Чтение и выполнение
 | 90\tools | Чтение и выполнение
 | 80\tools | Чтение и выполнение
 | 90\sdk | Чтение
 | Microsoft SQL Server\90\Setup Bootstrap | Чтение и выполнение

Кроме стартовых учетных записей служб SQL Server могут потребоваться разрешения на доступ для встроенных учетных записей или других учетных записей служб SQL Server. В следующей таблице перечислены дополнительные списки ACL, создаваемые программой установки SQL Server.

Запрашивающий компонент | Учетная запись | Ресурс | Разрешения
MSSQLServer | Пользователи журнала производительности | Instid\MSSQL\binn | Просмотр содержимого папки
 | Пользователи системного монитора | Instid\MSSQL\binn | Просмотр содержимого папки
 | Пользователи журнала производительности | Instid\MSSQL\binn\sqlctr90.dll | Чтение и выполнение
 | Пользователи системного монитора | Instid\MSSQL\binn\sqlctr90.dll | Чтение и выполнение
 | Только администратор | \\.\root\Microsoft\SqlServer\ServerEvents\<sql_instance_name>1 | Полный доступ
 | Администраторы | \tools\binn\schemas\sqlserver\2003\03\showplan | Полный доступ
 | Система | \tools\binn\schemas\sqlserver\2003\03\showplan | Полный доступ
 | Пользователи | \tools\binn\schemas\sqlserver\2003\03\showplan | Чтение и выполнение
Службы Reporting Services | <Учетная запись веб-службы сервера отчетов> | <каталог установки>\Reporting Services\LogFiles | DELETE READ_CONTROL SYNCHRONIZE FILE_GENERIC_READ FILE_GENERIC_WRITE FILE_READ_DATA FILE_WRITE_DATA FILE_APPEND_DATA FILE_READ_EA FILE_WRITE_EA FILE_READ_ATTRIBUTES FILE_WRITE_ATTRIBUTES
 | Идентификатор пула приложений диспетчера отчетов | <каталог установки>\Reporting Services\ReportManager | Чтение
 | Учетная запись ASP.NET | <каталог установки>\Reporting Services\ReportManager | Чтение
 | Все | <каталог установки>\Reporting Services\ReportManager | Чтение
 | Идентификатор пула приложений диспетчера отчетов | <каталог_установки>\Reporting Services\ReportManager\Pages\*.* | Чтение
 | Учетная запись ASP.NET | <каталог_установки>\Reporting Services\ReportManager\Pages\*.* | Чтение
 | Все | <каталог_установки>\Reporting Services\ReportManager\Pages\*.* | Чтение
 | Идентификатор пула приложений диспетчера отчетов | <каталог_установки>\Reporting Services\ReportManager\Styles\*.* | Чтение
 | Учетная запись ASP.NET | <каталог_установки>\Reporting Services\ReportManager\Styles\*.* | Чтение
 | Все | <каталог_установки>\Reporting Services\ReportManager\Styles\*.* | Чтение
 | Идентификатор пула приложений диспетчера отчетов | <каталог_установки>\Reporting Services\ReportManager\webctrl_client\1_0\*.* | Чтение
 | Учетная запись ASP.NET | <каталог_установки>\Reporting Services\ReportManager\webctrl_client\1_0\*.* | Чтение
 | Все | <каталог_установки>\Reporting Services\ReportManager\webctrl_client\1_0\*.* | Чтение
 | <Учетная запись веб-службы сервера отчетов> | <каталог установки>\Reporting Services\ReportServer | Чтение
 | <Учетная запись веб-службы сервера отчетов> | <каталог установки>\Reporting Services\ReportServer\global.asax | Полные
 | Все | <каталог установки>\Reporting Services\ReportServer\global.asax | READ_CONTROL FILE_READ_DATA FILE_READ_EA FILE_READ_ATTRIBUTES
 | Сетевая служба | <каталог установки>\Reporting Services\ReportServer\ReportService.asmx | Полные
 | Все | <каталог установки>\Reporting Services\ReportServer\ReportService.asmx | READ_CONTROL SYNCHRONIZE FILE_GENERIC_READ FILE_GENERIC_EXECUTE FILE_READ_DATA FILE_READ_EA FILE_EXECUTE FILE_READ_ATTRIBUTES
 | Учетная запись службы Windows для сервера отчетов | <каталог установки>\Reporting Services\ReportServer\RSReportServer.config | DELETE READ_CONTROL SYNCHRONIZE FILE_GENERIC_READ FILE_GENERIC_WRITE FILE_READ_DATA FILE_WRITE_DATA FILE_APPEND_DATA FILE_READ_EA FILE_WRITE_EA FILE_READ_ATTRIBUTES FILE_WRITE_ATTRIBUTES
 | Все | Разделы реестра сервера отчетов (куст Instid) | Запрос значения Перечисление подразделов Уведомление Управление чтением
 | Пользователь служб терминала | Разделы реестра сервера отчетов (куст Instid) | Запрос значения Установка значения Создание подраздела Перечисление подразделов Уведомление Удаление Управление чтением
 | Опытные пользователи | Разделы реестра сервера отчетов (куст Instid) | Запрос значения Установка значения Создание подраздела Перечисление подразделов Уведомление Удаление Управление чтением

1Это пространство имен поставщика инструментария WMI.

Обзор разрешений Windows для служб SQL Server

В следующей таблице перечислены имена служб, термины, используемые для установленных по умолчанию и именованных экземпляров служб SQL Server, описания функций служб, а также минимальные требуемые разрешения.

Отображаемое имя Имя службы Описание Требуемые разрешения

SQL Server (ИмяЭкземпляра)

Экземпляр по умолчанию: MSSQLSERVER

Именованный экземпляр: MSSQL$ИмяЭкземпляра

SQL Server Database Engine.

Путь к исполняемому файлу — \MSSQL\Binn\sqlservr.exe.

Рекомендуется локальный пользователь.

Минимальные разрешения Функциональность

Учетная запись для запуска службы MSSQLServer

Эта учетная запись должна быть включена в список учетных записей, имеющих разрешения «Список содержимого папки» для корневой папки диска, где установлен SQL Server, а также корневой папки любого другого диска, где хранятся файлы SQL Server.

Примечание.
Разрешения «Список содержимого папки» для корневой папки диска не обязательно должны наследоваться вложенными папками.

Учетная запись для запуска службы MSSQLServer

Учетная запись должна иметь разрешения «Полный доступ» для любых папок, где хранятся файлы данных или журналов (MDF, NDF, LDF).

Агент SQL Server (ИмяЭкземпляра)

Экземпляр по умолчанию: SQLServerAgent

Именованный экземпляр: SQLAgent$ИмяЭкземпляра

Служит для выполнения заданий, контроля за SQL Server, предупреждения о нештатных ситуациях, а также позволяет автоматизировать некоторые задачи по администрированию.

Путь к исполняемому файлу — \MSSQL\Binn\sqlagent90.exe.

Минимальные разрешения | Функциональность
Учетная запись должна быть членом фиксированной серверной роли sysadmin |
Учетная запись должна иметь следующие разрешения Windows1 | Вход в систему в качестве службы. Вход в систему в качестве пакетного задания. Замена маркера уровня процесса. Назначение квот памяти процессам. Работа в качестве части операционной системы. Обход проходной проверки.

Службы Analysis Services (ИмяЭкземпляра)

Экземпляр по умолчанию: MSSQLServerOLAPService

Именованный экземпляр: MSOLAP$ИмяЭкземпляра

Служба, обеспечивающая интерактивную аналитическую обработку (OLAP) и интеллектуальный анализ данных для приложений бизнес-аналитики.

Путь к исполняемому файлу — \OLAP\Bin\msmdsrv.exe.

Сервер отчетов

Экземпляр по умолчанию: ReportServer

Именованный экземпляр: ReportServer$ИмяЭкземпляра

Служит для управления, выполнения, подготовки, ведения расписания и доставки отчетов.

Путь к исполняемому файлу — «\Reporting Services\ReportServer\Bin\ReportingServicesService.exe».

Notification Services

Службы Notification Services представляют собой платформу для разработки и развертывания приложений, формирующих и отправляющих уведомления. Программа установки SQL Server может установить службы Notification Services, но не поддерживает их настройку. Дополнительные сведения о включении служб Notification Services после завершения установки см. в разделе «Настройка служб Notification Services в Windows» в электронной документации по SQL Server 2005.

Integration Services

Именованный или установленный по умолчанию экземпляр: MSDTSServer

Обеспечивает поддержку управления хранением и выполнением пакетов службы Integration Services.

Путь к исполняемому файлу — \DTS\Binn\msdtssrvr.exe.

Обозреватель SQL Server

Именованный или установленный по умолчанию экземпляр: SQLBrowser

Служба разрешения имен, поставляющая сведения о соединениях SQL Server для клиентских компьютеров. Эта служба совместно используется множеством экземпляров SQL Server и служб SSIS.

Путь к исполняемому файлу — \90\shared\sqlbrowser.exe.

Компонент Microsoft FullText Search (MSFTESQL)

Экземпляр по умолчанию: MSFTESQL

Именованный экземпляр: MSFTESQL$ИмяЭкземпляра

Позволяет быстро создавать полнотекстовые индексы содержимого и свойств структурированных и частично структурированных данных для обеспечения быстрого лингвистического поиска в этих данных.

Путь к исполняемому файлу — \MSSQL\Binn\msftesql.exe.

Модуль поддержки Active Directory в службах SQL Server

Именованный или установленный по умолчанию экземпляр: MSSQLServerADHelper.

Осуществляет публикацию служб SQL Server и управление ими в службе каталогов Windows Active Directory.

Путь к исполняемому файлу — \90\Shared\sqladhelper.exe.

SQL Writer

SQLWriter

Служит для резервного копирования и восстановления приложений для работы в составе службы теневого копирования томов (VSS). Для всех экземпляров SQL Server на сервере используется один и тот же экземпляр службы SQL Writer.

Путь к исполняемому файлу — \90\Shared\sqlwriter.exe.

1Дополнительные сведения о способах проверки всех требуемых разрешений Windows см. в разделе Как проверить разрешения для служб SQL Server.

Обзор дополнительных вопросов

В следующей таблице перечислены разрешения, требуемые для расширения функциональности служб SQL Server.

Служба или приложение | Функциональность | Требуемые разрешения
SQL Server (MSSQLSERVER) | Запись в почтовый канал с помощью xp_sendmail. | Привилегии на запись по сети.
SQL Server (MSSQLSERVER) | Запуск xp_cmdshell пользователем, не являющимся администратором SQL Server. | Работа в качестве части операционной системы, а также замена маркера уровня процесса.
Агент SQL Server (MSSQLSERVER) | Использование функции автоматического перезапуска. | Должен быть членом локальной группы Администраторы.
Помощник по настройке ядра СУБД | Позволяет настраивать базы данных для оптимальной производительности запросов. | При первом использовании приложение должно быть инициализировано пользователем с правами системного администратора. После инициализации пользователи — владельцы таблиц (пользователи dbo) могут использовать помощник по настройке Database Engine для настройки только тех таблиц, владельцами которых они являются. Дополнительные сведения см. в разделе «Инициализация помощника по настройке ядра СУБД при первом запуске» электронной документации SQL Server 2005.
Важно!
Перед обновлением до SQL Server 2005 включите проверку подлинности Windows для агента SQL Server и убедитесь, что учетная запись службы агента SQL Server находится в группе SQL Server sysadmin.

Локализованные имена служб

В следующей таблице показаны имена служб, используемые в локализованной версии Microsoft Windows.

Язык | Имя локальной службы | Имя сетевой службы | Имя локальной системы | Имя группы администраторов
Английский Китайский (упрощенное письмо) Традиционный китайский Корейский Японский | NT AUTHORITY\LOCAL SERVICE | NT AUTHORITY\NETWORK SERVICE | NT AUTHORITY\SYSTEM | BUILTIN\Administrators
Немецкий | NT-AUTORITO\LOKALER DIENST | NT-AUTORITO\NETZWERKDIENST | NT-AUTORITO\SYSTEM | VORDEFINIERT\Administratoren
Французский | AUTORITE NT\SERVICE LOCAL | AUTORITE NT\SERVICE R?EAU | AUTORITE NT\SYSTEM | BUILTIN\Administrateurs
Итальянский | NT AUTHORITY\SERVIZIO LOCALE | NT AUTHORITY\SERVIZIO DI RETE | NT AUTHORITY\SYSTEM | BUILTIN\Administrators
Испанский | NT AUTHORITY\SERVICIO LOC | NT AUTHORITY\SERVICIO DE RED | NT AUTHORITY\SYSTEM | BUILTIN\Administradores
Русский | NT AUTHORITY\LOCAL SERVICE | NT AUTHORITY\LOCAL SERVICE | NT AUTHORITY\SYSTEM | BUILTIN\Администраторы

См. также

Справочник

Учетная запись службы
Учетные записи служб (кластеры)

Основные понятия

Анализ безопасности при установке SQL Server

Журнал изменений

Версия Журнал

12 декабря 2006 г.

Измененное содержимое
  • Добавлены рекомендации по безопасности для учетных записей в параллельных конфигурациях.

17 июля 2006 г.

Измененное содержимое
  • Изменен порядок и способ подачи материала с целью сделать раздел более удобочитаемым.

  • Добавлена ссылка на статью базы знаний Microsoft об использовании надстройки служб для изменения учетных записей служб SQL Server и агента SQL Server.

  • Добавлены локализованные имена служб (на русском языке).

5 декабря 2005 г.

Измененное содержимое
  • Из списка учетных записей, которыми может пользоваться агент SQL Server, удалена LocalService.

  • Обновлены группы пользователей, создаваемые программой установки SQL Server.


Возможности, поддерживаемые различными выпусками SQL Server 2005

Возможности, поддерживаемые различными выпусками SQL Server 2005 |
 | См. также
Подготовка к установке SQL Server 2005 >

Дата обновления: 17 июля 2006 г.

Для определения функций, поддерживаемых различными выпусками , можно использовать следующие таблицы.

Возможности компонента SQL Server 2005 Database Engine

Следующие сокращения соответствуют выпускам SQL Server 2005.

  • EE = SQL Server 2005 Enterprise Edition

  • DE = SQL Server 2005 Developer Edition

  • SE = SQL Server 2005 Standard Edition

  • WG = SQL Server 2005 Workgroup Edition

  • SSE = SQL Server 2005 Express Edition

  • SSEA = SQL Server 2005 Express Edition with Advanced Services

Возможности и улучшения компонента Database Engine | EE (32-разрядная версия) EE (64-разрядная версия) DE (32-разрядная версия) DE (64-разрядная версия) | SE (32-разрядная версия) SE (64-разрядная версия) | WG (32-разрядная версия) | SSE (32-разрядная версия) | SSEA (32-разрядная версия)
Возможности программирования |  |  |  |  |
Платформа Microsoft .NET Framework | Да | Да | Нет | Нет | Нет
Интеграция со средой CLR | Да | Да | Да | Да | Да
Определяемые пользователем статистические функции | Да | Да | Да | Да | Да
Определяемые пользователем типы данных | Да | Да | Да | Да | Да
Определяемые пользователем функции | Да | Да | Да | Да | Да
Управляемый поставщик SQL Server (управляемый доступ к данным) | Да | Да | Да | Да | Да
Расширенные триггеры | Да | Да | Да | Да | Да
Обработка событий | Да | Да | Да | Да | Да
Возможности и улучшения компонента Database Engine | EE (32-разрядная версия) EE (64-разрядная версия) DE (32-разрядная версия) DE (64-разрядная версия) | SE (32-разрядная версия) SE (64-разрядная версия) | WG (32-разрядная версия) | SSE (32-разрядная версия) | SSEA (32-разрядная версия)
Типы данных |  |  |  |  |
Определяемые пользователем типы данных среды CLR | Да | Да | Да | Да | Да
Новый тип данных XML | Да | Да | Да | Да | Да
Возможности и улучшения компонента Database Engine | EE (32-разрядная версия) EE (64-разрядная версия) DE (32-разрядная версия) DE (64-разрядная версия) | SE (32-разрядная версия) SE (64-разрядная версия) | WG (32-разрядная версия) | SSE (32-разрядная версия) | SSEA (32-разрядная версия)
Усовершенствования языка Transact-SQL |  |  |  |  |
Обработка исключений | Да | Да | Да | Да | Да
Модули поддержки запросов | Да | Да | Да | Да | Да
Новые возможности инструкции FOR XML | Да | Да | Да | Да | Да
Встроенные объекты (строковая функция) | Да | Да | Да | Да | Да
Модель программирования объектов LOB | Да | Да | Да | Да | Да
Новые аналитические функции (ранжирующие) | Да | Да | Да | Да | Да
Новый оператор Apply (реляционный оператор) | Да | Да | Да | Да | Да
Новые операторы Pivot и Unpivot (реляционные операторы) | Да | Да | Да | Да | Да
Поддержка уведомлений | Да | Да | Да | Да | Да
Рекурсивные запросы | Да | Да | Да | Да | Да
Усовершенствованный оператор TOP | Да | Да | Да | Да | Да
Распределенный запрос | Да | Да | Да | Да | Да
Возможности и улучшения компонента Database Engine | EE (32-разрядная версия) EE (64-разрядная версия) DE (32-разрядная версия) DE (64-разрядная версия) | SE (32-разрядная версия) SE (64-разрядная версия) | WG (32-разрядная версия) | SSE (32-разрядная версия) | SSEA (32-разрядная версия)
Улучшенные возможности полнотекстового поиска |  |  |  |  |
Полнотекстовые запросы к связанным серверам | Да | Да | Да | Нет | Да
Полнотекстовый поиск по нескольким столбцам | Да | Да | Да | Нет | Да
Определение языка в запросе | Да | Да | Да | Нет | Да
Новый компонент Service Broker для сообщений | Да | Да | Да | Только клиент | Только клиент
Поддержка HTTP (встроенная поддержка HTTP) | Да | Да | Да | Нет | Нет
Возможности и улучшения компонента Database Engine | EE (32-разрядная версия) EE (64-разрядная версия) DE (32-разрядная версия) DE (64-разрядная версия) | SE (32-разрядная версия) SE (64-разрядная версия) | WG (32-разрядная версия) | SSE (32-разрядная версия) | SSEA (32-разрядная версия)
Функции управления |  |  |  |  |
Создание резервных копий и восстановление полнотекстовых каталогов | Да | Да | Да | Нет | Да
Полнотекстовые каталоги включены в операциях подсоединения/отсоединения базы данных | Да | Да | Да | Нет | Да
Обновление полнотекстового поиска | Да | Да | Да | Нет | Да
Запросы представлений (ранее — индексирование представлений) | Да | Да | Да | Нет | Нет
Индексирование типа данных XML | Да | Да | Да | Нет | Нет
Усовершенствованная производительность индексов (ранее — Inline Gathering, MSSearch 3.0) | Да | Да | Да | Нет | Нет
Безопасность параллельных служб (ранее — изменение контекста безопасности) | Да | Да | Да | Нет | Нет
Подробные отчеты о состоянии | Да | Да | Да | Нет | Нет
Возможности и улучшения компонента Database Engine | EE (32-разрядная версия) EE (64-разрядная версия) DE (32-разрядная версия) DE (64-разрядная версия) | SE (32-разрядная версия) SE (64-разрядная версия) | WG (32-разрядная версия) | SSE (32-разрядная версия) | SSEA (32-разрядная версия)
Средства безопасности |  |  |  |  |
Возможность предоставления всех разрешений | Да | Да | Да | Да | Да
Детализированное предоставление прав администратора | Да | Да | Да | Да | Да
Интегрированные средства безопасности для SQL-авторизации | Да | Да | Да | Да | Да
Разделение пользователей и схем | Да | Да | Да | Да | Да
Возможности и улучшения компонента Database Engine | EE (32-разрядная версия) EE (64-разрядная версия) DE (32-разрядная версия) DE (64-разрядная версия) | SE (32-разрядная версия) SE (64-разрядная версия) | WG (32-разрядная версия) | SSE (32-разрядная версия) | SSEA (32-разрядная версия)
Средства увеличения доступности (резервирование и защита от сбоя базы данных) |  |  |  |  |
Отказоустойчивый кластер | Да | 2 узла | Нет | Нет | Нет
Поддержка нескольких экземпляров | 50 | 16 | 16 | 16 | 16
Зеркальное отображение базы данных | Да | Только режим полной безопасности | Нет | Нет, может быть использован как следящий сервер | Нет, может быть использован как следящий сервер
Доставка журналов | Да | Да | Да | Нет | Нет
Моментальный снимок базы данных | Да | Нет | Нет | Нет | Нет
Возможности и улучшения компонента Database Engine | EE (32-разрядная версия) EE (64-разрядная версия) DE (32-разрядная версия) DE (64-разрядная версия) | SE (32-разрядная версия) SE (64-разрядная версия) | WG (32-разрядная версия) | SSE (32-разрядная версия) | SSEA (32-разрядная версия)
Возможности сопровождения базы данных |  |  |  |  |
Проверка целостности путем вычисления контрольных сумм для данных и резервных копий | Да | Да | Да | Да | Да
Выделенное административное соединение | Да | Да | Да | Да 1 | Да 1
Динамические расширения AWE | Да | Да | Нет | Нет | Нет
Доступность базы данных во время отмены восстановления | Да | Нет | Нет | Нет | Нет
Обновление с высоким уровнем доступности | Да | Нет | Нет | Нет | Нет
Память с «горячей» заменой2 | Да | Нет | Нет | Нет | Нет
Зеркальный резервный носитель | Да | Нет | Нет | Нет | Нет
Фоновые операции с индексами | Да | Нет | Нет | Нет | Нет
Восстановление страниц | Да | Да | Да | Да | Да
Оперативное восстановление страниц и файлов | Да | Нет | Нет | Нет | Нет
Параллельные операции с индексами | Да | Нет | Нет | Нет | Нет
Возможности и улучшения компонента Database Engine | EE (32-разрядная версия) EE (64-разрядная версия) DE (32-разрядная версия) DE (64-разрядная версия) | SE (32-разрядная версия) SE (64-разрядная версия) | WG (32-разрядная версия) | SSE (32-разрядная версия) | SSEA (32-разрядная версия)
Возможности XML |  |  |  |  |
Тип данных XML | Да | Да | Да | Да | Да
Поддержка XQuery | Да | Да | Да | Да | Да
Язык обработки XML-данных (XML DML) | Да | Да | Да | Да | Да
Представления XML | Да | Да | Да | Да | Да
Новые возможности инструкции FOR XML | Да | Да | Да | Да | Да
Системная поддержка XML-типа (поддержка XML-схемы) | Да | Да | Да | Да | Да
Возможности и улучшения компонента Database Engine | EE (32-разрядная версия) EE (64-разрядная версия) DE (32-разрядная версия) DE (64-разрядная версия) | SE (32-разрядная версия) SE (64-разрядная версия) | WG (32-разрядная версия) | SSE (32-разрядная версия) | SSEA (32-разрядная версия)
Средства повышения масштабируемости и производительности |  |  |  |  |
Помощник по настройке компонента Database Engine (заменяет мастера настройки индексов) | Да | Да | Да | Нет | Нет
Обновляемые распределенные секционированные представления | Да | Нет | Нет | Нет | Нет
Улучшенное опережающее чтение и просмотр (Super Scan) | Да | Нет | Нет | Нет | Нет
Индексированные представления (материализованные представления)3 | Да | Да | Да | Да | Да
Множественные активные наборы результатов (MARS) | Да | Да | Да | Да | Да
Материализованные вычисляемые столбцы | Да | Да | Да | Да | Да
Поддержка организации очередей | Да | Да | Да | Да | Да
Уровень изоляции моментального снимка (управление версиями на уровне строк) | Да | Да | Да | Да | Да
Секционирование таблиц и индексов | Да | Нет | Нет | Нет | Нет
Поддержка VIA | Да | Нет | Нет | Нет | Нет
Параллельная работа DBCC | Да | Нет | Нет | Нет | Нет
Возможности и улучшения компонента Database Engine | EE (32-разрядная версия) EE (64-разрядная версия) DE (32-разрядная версия) DE (64-разрядная версия) | SE (32-разрядная версия) SE (64-разрядная версия) | WG (32-разрядная версия) | SSE (32-разрядная версия) | SSEA (32-разрядная версия)
Функции работы с разными языками (параметры сортировки, поддержка символов и глобальное развертывание) |  |  |  |  |
Поддержка письма в двух направлениях и сложных знаков | Да | Да | Да | Да | Да
Поддержка GB18030 | Да | Да | Да | Да | Да
Поддержка суррогатов | Да | Да | Да | Да | Да
Языковой пакет | Да | Да | Да | Да | Да

1Выделенное административное соединение для выпуска SQL Server Express Edition поддерживается с флагом трассировки 7806. Дополнительные сведения о флагах трассировки см. в подразделе «Флаги трассировки (Transact-SQL)» электронной документации по SQL Server 2005.

2Эта возможность поддерживается только в выпуске SQL Server 2005 Enterprise Edition и доступна только для 64-разрядной версии SQL Server (либо для 32-разрядной версии SQL Server с поддержкой AWE).

3Эта функция поддерживается во всех выпусках SQL Server 2005, за исключением автоматического сопоставления оптимизатора запросов, которое поддерживается только в выпусках Enterprise Edition и Developer Edition.

Возможности средств управления SQL Server 2005

Следующие сокращения соответствуют выпускам SQL Server 2005.

  • EE = SQL Server 2005 Enterprise Edition

  • DE = SQL Server 2005 Developer Edition

  • SE = SQL Server 2005 Standard Edition

  • WG = SQL Server 2005 Workgroup Edition

  • SSE = SQL Server 2005 Express Edition

  • SSEA = SQL Server 2005 Express Edition with Advanced Services

Улучшенные возможности средств управления | EE (32-разрядная версия) DE (32-разрядная версия) EE (64-разрядная версия) DE (64-разрядная версия) | SE (32-разрядная версия) | WG (32-разрядная версия) | SE (64-разрядная версия) | SSE (32-разрядная версия) | SSEA (32-разрядная версия)
Возможности программирования |  |  |  |  |  |
Усовершенствованные средства конструирования |  |  |  |  |  |
Конструктор запросов | Да | Да | Да | Нет | Нет | Нет
Редактор запросов | Да | Да | Да | Нет | Нет | Нет
Редактор запросов многомерных выражений | Да | Да | Да | Нет | Нет | Нет
Технология IntelliSense для многомерных выражений | Да | Да | Да | Нет | Нет | Нет
Технология IntelliSense для языка Transact-SQL | Да | Да | Да | Нет | Нет | Нет
Поддержка управления версиями | Да | Да | Да | Нет | Нет | Нет
XML/A | Да | Да | Да | Нет | Нет | Нет
Улучшенные возможности средств управления | EE (32-разрядная версия) DE (32-разрядная версия) EE (64-разрядная версия) DE (64-разрядная версия) | SE (32-разрядная версия) | WG (32-разрядная версия) | SE (64-разрядная версия) | SSE (32-разрядная версия) | SSEA (32-разрядная версия)
Программирование функций управления |  |  |  |  |  |
Управляющие объекты SQL Server (SMO) | Да | Да | Да | Нет | Да | Да
Поставщик конфигурации инструментария WMI | Да | Да | Да | Нет | Нет | Нет
Функции управления |  |  |  |  |  |
Конфигурация |  |  |  |  |  |
Оснастка консоль управления (MMC) «Диспетчер конфигурации SQL Server» | Да | Да | Да | Да | Да | Да
Улучшенные возможности средств управления | EE (32-разрядная версия) DE (32-разрядная версия) EE (64-разрядная версия) DE (64-разрядная версия) | SE (32-разрядная версия) | WG (32-разрядная версия) | SE (64-разрядная версия) | SSE (32-разрядная версия) | SSEA (32-разрядная версия)
Управление |  |  |  |  |  |
Интеграция со средой Microsoft Visual Studio | Да | Да | Да | Да | Да | Да
Новый стиль диалогов (интерфейс пользователя с полной поддержкой создания сценариев и расписаний) | Да | Да | Да | Нет | Нет | Нет
SQL Server Management Studio | Да | Да | Да | Да | Нет | Среда SQL Server Management Studio Express (подмножество среды SQL Server Management Studio)
Главный сервер | Да (автоматически) | Да (вручную) | Нет | Нет | Нет | Нет
Целевой сервер | Да | Да | Да | Нет | Нет | Нет
Улучшенные возможности средств управления | EE (32-разрядная версия) DE (32-разрядная версия) EE (64-разрядная версия) DE (64-разрядная версия) | SE (32-разрядная версия) | WG (32-разрядная версия) | SE (64-разрядная версия) | SSE (32-разрядная версия) | SSEA (32-разрядная версия)
Операции |  |  |  |  |  |
Пакет диспетчера операций (Microsoft) для SQL Server 2005 | Да | Да | Да | Да | Нет | Нет
Средства командной строки SQLCMD (ранее — OLESQL) | Да | Да | Да | Да | Да | Да
Повторное использование заданий агента SQL Server | Да | Да | Да | Да | Нет | Нет
Счетчики производительности агентов SQL Server | Да | Да | Да | Да | Нет | Нет
Планирование работы агентов SQL Server | Да | Да | Да | Да | Нет | Нет
Безопасность агентов SQL Server | Да | Да | Да | Да | Нет | Нет
Подсистемы агентов SQL Server для OLAP и служб SSIS | Да | Да | Да | Да | Нет | Нет
Агент SQL Server | Да | Да | Да | Да | Нет | Нет
Помощник Web Assistant | Да | Да | Да | Да | Нет | Нет
Служба SQL Mail | Да в 32-разрядной версии Нет в 64-разрядной версии | Да | Да | Нет | Нет | Нет
Компонент Database Mail | Да в 32-разрядной версии Нет в 64-разрядной версии | Да | Да | Нет | Нет | Нет
Улучшенные возможности средств управления | EE (32-разрядная версия) DE (32-разрядная версия) EE (64-разрядная версия) DE (64-разрядная версия) | SE (32-разрядная версия) | WG (32-разрядная версия) | SE (64-разрядная версия) | SSE (32-разрядная версия) | SSEA (32-разрядная версия)
Масштабируемость и производительность |  |  |  |  |  |
Помощник по настройке ядра СУБД | Да | Да | Да | Да | Нет | Нет
Корреляция счетчиков производительности | Да | Да | Да | Да | Нет | Нет
Усовершенствованный SQL Server Profiler | Да | Да | Да | Да | Нет | Нет
Создание профилей служб Analysis Services | Да | Да | Да | Да | Нет | Нет
Возможность экспорта инструкции Showplan и трассировки взаимоблокировок | Да | Да | Да | Да | Нет | Нет
Улучшенные возможности средств управления | EE (32-разрядная версия) DE (32-разрядная версия) EE (64-разрядная версия) DE (64-разрядная версия) | SE (32-разрядная версия) | WG (32-разрядная версия) | SE (64-разрядная версия) | SSE (32-разрядная версия) | SSEA (32-разрядная версия)
Функции работы с разными языками (параметры сортировки, поддержка символов и глобальное развертывание) |  |  |  |  |  |
Поддержка языков с письмом слева направо и сложных языков | Да | Да | Да | Да | Да | Да
Поддержка GB18030 | Да | Да | Да | Да | Да | Да
Поддержка суррогатов | Да | Да | Да | Да | Да | Да

Возможности служб SQL Server 2005 Analysis Services

Следующие сокращения соответствуют выпускам SQL Server 2005.

  • EE = SQL Server 2005 Enterprise Edition

  • DE = SQL Server 2005 Developer Edition

  • SE = SQL Server 2005 Standard Edition

  • WG = SQL Server 2005 Workgroup Edition

  • SSE = SQL Server 2005 Express Edition

  • SSEA = SQL Server 2005 Express Edition with Advanced Services

Улучшенные возможности служб Analysis Services | EE (32-разрядная версия) DE (32-разрядная версия) EE (64-разрядная версия) DE (64-разрядная версия) | SE (32-разрядная версия) | WG (32-разрядная версия) | SSE (32-разрядная версия) SSEA (32-разрядная версия) | SE (64-разрядная версия)
Возможности программирования |  |  |  |  |
Платформа .NET Framework | Да | Да | Нет | Нет | Да
Хранимые процедуры .NET | Да | Да | Да | Да | Да
Межплатформенный и не требующий места на диске клиентский доступ | Да | Да | Нет | Нет | Да
Собственные веб-службы с поддержкой XML | Да | Да | Нет | Нет | Да
Доступ по HTTP | Да | Да | Нет | Нет | Да
Двоичный и сжатый XML-транспорт | Да | Нет | Нет | Нет | Нет
Функции управления |  |  |  |  |
Автоматическое поддержание ссылочной целостности данных | Да | Да | Нет | Нет | Да
Захват и воспроизведение | Да | Да | Нет | Нет | Да
Детальное распределение прав администратора | Да | Да | Нет | Нет | Да
Профайлер | Да | Да | Нет | Нет | Да
Трассировка | Да | Да | Нет | Нет | Да
«Черный ящик» | Да | Да | Нет | Нет | Да
Улучшенные возможности служб Analysis Services | EE (32-разрядная версия) DE (32-разрядная версия) EE (64-разрядная версия) DE (64-разрядная версия) | SE (32-разрядная версия) | WG (32-разрядная версия) | SSE (32-разрядная версия) SSEA (32-разрядная версия) | SE (64-разрядная версия)
Возможности программирования функций управления |  |  |  |  |
Объекты AMO и DMO | Да | Да | Нет | Нет | Да
Средства увеличения доступности |  |  |  |  |
Усовершенствованное создание резервных копий и восстановление | Да | Да | Нет | Нет | Да
Отказоустойчивый кластер | Да | Да | Нет | Нет | Да
Поддержка нескольких экземпляров | 50 | 16 | Нет | Нет | 16
Синхронизация сервера | Да | Да | Нет | Нет | Да
Улучшенные возможности служб Analysis Services | EE (32-разрядная версия) DE (32-разрядная версия) EE (64-разрядная версия) DE (64-разрядная версия) | SE (32-разрядная версия) | WG (32-разрядная версия) | SSE (32-разрядная версия) SSEA (32-разрядная версия) | SE (64-разрядная версия)
Возможности бизнес-аналитики |  |  |  |  |
Автоматическая упаковка и развертывание | Да | Да | Нет | Нет | Да
Мастер бизнес-аналитики | Да | Да | Нет | Нет | Да
Управление представлениями источников данных | Да | Да | Нет | Нет | Да
Интегрированная среда Business Intelligence Development Studio | Да | Да | Нет | Нет | Да
Технология Autobuild Builder | Да | Да | Нет | Нет | Да
Отладчик многомерных выражений | Да | Да | Нет | Нет | Да
Редактор, работающий с несколькими секциями | Да | Да | Нет | Нет | Да
Система управления версиями | Да | Да | Нет | Нет | Да
Универсальный редактор вычислений | Да | Да | Нет | Нет | Да
Улучшенные возможности служб Analysis Services | EE (32-разрядная версия) DE (32-разрядная версия) EE (64-разрядная версия) DE (64-разрядная версия) | SE (32-разрядная версия) | WG (32-разрядная версия) | SSE (32-разрядная версия) SSEA (32-разрядная версия) | SE (64-разрядная версия)
Средства интеллектуального анализа данных |  |  |  |  |
Улучшенная интегрированная обработка OLAP и функции интеллектуального анализа данных (функция прогнозирования многомерных выражений, измерения интеллектуального анализа данных) | Да | Да | Нет | Нет | Да
Параллелизм при обработке моделей | Да | Нет | Нет | Нет | Нет
Параллелизм при прогнозировании моделей | Да | Нет | Нет | Нет | Нет
Преобразование «Извлечение терминов» интеллектуального анализа текста (службы SSIS) | Да | Нет | Нет | Нет | Нет
Преобразование «Уточняющий запрос термина» интеллектуального анализа текста (службы SSIS) | Да | Нет | Нет | Нет | Нет
Преобразование «Запрос интеллектуального анализа данных» (служб SSIS) | Да | Нет | Нет | Нет | Нет
Адресат обработки интеллектуального анализа данных (службы SSIS) | Да | Нет | Нет | Нет | Нет
API-интерфейс для подключаемых модулей алгоритмов | Да | Нет | Нет | Нет | Нет
Средства просмотра алгоритмов | Да | Да | Нет | Нет | Да
Средства интеллектуального анализа данных (в том числе мастеры, редакторы, построители отчетов, диаграмма точности прогнозов) | Да | Да | Нет | Нет | Да
Стандартные алгоритмы интеллектуального анализа данных | Да | Да | Нет | Нет | Да
Дополнительные параметры конфигурации и настройки алгоритмов интеллектуального анализа данных | Да | Нет | Нет | Нет | Нет
Интеграция отчетов с прогнозирующими запросами интеллектуального анализа | Да | Да | Нет | Нет | Да
Улучшенные возможности служб Analysis Services | EE (32-разрядная версия) DE (32-разрядная версия) EE (64-разрядная версия) DE (64-разрядная версия) | SE (32-разрядная версия) | WG (32-разрядная версия) | SSE (32-разрядная версия) SSEA (32-разрядная версия) | SE (64-разрядная версия)
Усовершенствованные аналитические средства |  |  |  |  |
Логика операций со счетами | Да | Нет | Нет | Нет | Нет
Межбазовые и межсерверные связанные меры и измерения | Да | Нет | Нет | Нет | Нет
Перевод метаданных | Да | Нет | Нет | Нет | Нет
Перспективы | Да | Нет | Нет | Нет | Нет
Полуаддитивные меры | Да | Нет | Нет | Нет | Нет
Измерения обратной записи | Да | Нет | Нет | Нет | Нет
Улучшенные возможности служб Analysis Services | EE (32-разрядная версия) DE (32-разрядная версия) EE (64-разрядная версия) DE (64-разрядная версия) | SE (32-разрядная версия) | WG (32-разрядная версия) | SSE (32-разрядная версия) SSEA (32-разрядная версия) | SE (64-разрядная версия)
Возможности построения хранилищ данных |  |  |  |  |
Создание кубов без базы данных | Да | Да | Нет | Нет | Нет
Автоматическое создание промежуточных схем и схем хранилища данных | Да | Да | Нет | Нет | Нет
Автоматическое создание пакетов служб DTS для обновления данных в хранилищах | Да | Да | Нет | Нет | Нет
Расширенные возможности моделирования измерений |  |  |  |  |
Выражения мер | Да | Да | Нет | Нет | Да
Средства повышения масштабируемости и производительности |  |  |  |  |
Упреждающее кэширование | Да | Нет | Нет | Нет | Нет
Автоматическая параллельная обработка секций | Да | Нет | Нет | Нет | Нет
Секционированные кубы | Да | Нет | Нет | Нет | Нет
Распределенные секционированные кубы | Да | Нет | Нет | Нет | Нет

Возможности служб SQL Server 2005 Reporting Services

Следующие сокращения соответствуют выпускам SQL Server 2005.

  • EE = SQL Server 2005 Enterprise Edition

  • DE = SQL Server 2005 Developer Edition

  • SE = SQL Server 2005 Standard Edition

  • WG = SQL Server 2005 Workgroup Edition

  • SSE = SQL Server 2005 Express Edition

  • SSEA = SQL Server 2005 Express Edition with Advanced Services

Усовершенствованные возможности служб Reporting Services | EE (32-разрядная версия) DE (32-разрядная версия) EE (64-разрядная версия) DE (64-разрядная версия) | SE (32-разрядная версия) SE (64-разрядная версия) | WG (32-разрядная версия) | SSE (32-разрядная версия) | SSEA (32-разрядная версия)
Поддержка удаленных и нереляционных источников данных | Да | Да | Нет | Нет | Нет
Модули подготовки отчетов в формате DHTML, Excel, PDF и в виде изображений | Да | Да | Да | Нет | Да
Модули подготовки отчетов в формате MHTML, CSV, XML и модуль подготовки NULL | Да | Да | Нет | Нет | Нет
Модули доставки по электронной почте и в общую папку | Да | Да | Нет | Нет | Нет
Пользовательские модули обработки, доставки и подготовки отчетов | Да | Да | Нет | Нет | Нет
Нестандартные модули проверки подлинности | Да | Да | Да | Нет | Нет
Кэширование отчетов | Да | Да | Нет | Нет | Нет
Журнал отчета | Да | Да | Нет | Нет | Нет
Планирование | Да | Да | Нет | Нет | Нет
Подписки | Да | Да | Нет | Нет | Нет
Управляемые данными подписки | Да | Нет | Нет | Нет | Нет
Пользовательские определения ролей | Да | Да | Нет | Нет | Нет
Источники данных моделей отчета | Да | Да | Да | Нет | Нет
Безопасность элементов модели отчета | Да | Да | Нет | Нет | Нет
Поддержка неограниченного числа переходов в нерегламентированных отчетах | Да | Нет | Нет | Нет | Нет
Построитель отчетов | Да | Да | Да | Нет | Нет
Диспетчер отчетов | Да | Да | Да | Нет | Да
Среда SQL Server Management Studio | Да | Да | Да | Нет | Нет
Конструктор отчетов в среде Business Intelligence Development Studio | Да | Да | Да | Нет | Да?
Масштабное развертывание сервера отчетов | Да | Нет | Нет | Нет | Нет

Дополнительные сведения о возможностях служб Reporting Services, доступных в SQL Server 2005, см. в разделе «Возможности служб Reporting Services» электронной документации по SQL Server 2005.

? Среда Business Intelligence Development Studio устанавливается при помощи набора средств управления SQL Server 2005 Express Edition. Дополнительные сведения см. в разделе Набор средств управления SQL Server Express электронной документации по SQL Server 2005 Express Edition.

Возможности служб SQL Server 2005 Notification Services

Следующие сокращения соответствуют выпускам SQL Server 2005.

  • EE = SQL Server 2005 Enterprise Edition

  • DE = SQL Server 2005 Developer Edition

  • SE = SQL Server 2005 Standard Edition

  • WG = SQL Server 2005 Workgroup Edition

  • SSE = SQL Server 2005 Express Edition

  • SSEA = SQL Server 2005 Express Edition with Advanced Services

Возможности и улучшения служб Notification Services | EE (32-разрядная версия) DE (32-разрядная версия) EE (64-разрядная версия) DE (64-разрядная версия) | SE (32-разрядная версия) | WG (32-разрядная версия) | SSE (32-разрядная версия) SSEA (32-разрядная версия) | SE (64-разрядная версия)
Пакет SDK служб Notification Services (API-интерфейс, программа NSControl, ICF-файлы и ADF-файлы) | Да | Да | Нет | Нет | Да
Ядро и клиентские компоненты служб Notification Services | Да | Да | Нет | Нет | Да
Масштабируемость (параллелизм, многоадресная рассылка, распределенное развертывание) | Да | Нет | Нет | Нет | Нет

Возможности служб SQL Server 2005 Integration Services

Следующие сокращения соответствуют выпускам SQL Server 2005.

  • EE = SQL Server 2005 Enterprise Edition

  • DE = SQL Server 2005 Developer Edition

  • SE = SQL Server 2005 Standard Edition

  • WG = SQL Server 2005 Workgroup Edition

  • SSE = SQL Server 2005 Express Edition

  • SSEA = SQL Server 2005 Express Edition with Advanced Services

Усовершенствованные возможности служб Integration Services | EE (32-разрядная версия) DE (32-разрядная версия) EE (64-разрядная версия) DE (64-разрядная версия) | SE (32-разрядная версия) | WG (32-разрядная версия) | SSE (32-разрядная версия) SSEA (32-разрядная версия) | SE (64-разрядная версия)
Мастер импорта и экспорта SQL Server и поддержка соединений, задач, адаптеров источника и загрузки данных | Да | Да | Да | Нет | Да
Задача «Выполнение SQL» | Да | Да | Да | Нет | Да
Адаптеры источника и загрузки данных OLE DB | Да | Да | Да | Нет | Да
Средства командной строки служб SSIS | Да | Да | Да | Нет | Да
Конструктор пакетов служб SSIS | Да | Да | Да | Нет | Да
Поддержка прежних версий пакетов служб DTS | Да | Да | Да | Да | Да
Служба SSIS | Да | Да | Нет | Нет | Да
Все остальные адаптеры источника и загрузки данных, задачи и преобразования, за исключением тех, что приведены ниже | Да | Да | Нет | Нет | Да
Преобразование «Запрос интеллектуального анализа данных» | Да | Нет | Нет | Нет | Нет
Адаптер загрузки обучающих данных модели интеллектуального анализа данных | Да | Нет | Нет | Нет | Нет
Преобразование «Нечеткое группирование» | Да | Нет | Нет | Нет | Нет
Преобразование «Нечеткий уточняющий запрос» | Да | Нет | Нет | Нет | Нет
Преобразование «Извлечение терминов» | Да | Нет | Нет | Нет | Нет
Преобразование «Уточняющий запрос термина» | Да | Нет | Нет | Нет | Нет
Мастер медленно меняющихся измерений и преобразование «Медленно меняющееся измерение» | Да | Да | Нет | Нет | Нет
Адаптер загрузки данных обработки измерений | Да | Нет | Нет | Нет | Нет
Адаптер загрузки данных обработки секций | Да | Нет | Нет | Нет | Нет

Возможности репликации SQL Server 2005

Следующие сокращения соответствуют выпускам SQL Server 2005.

  • EE = SQL Server 2005 Enterprise Edition

  • DE = SQL Server 2005 Developer Edition

  • SE = SQL Server 2005 Standard Edition

  • WG = SQL Server 2005 Workgroup Edition

  • SSE = SQL Server 2005 Express Edition

  • SSEA = SQL Server 2005 Express Edition with Advanced Services

Усовершенствованные возможности репликации | EE (32-разрядная версия) DE (32-разрядная версия) EE (64-разрядная версия) DE (64-разрядная версия) 4 | SE (32-разрядная версия) | WG (32-разрядная версия) | SSE (32-разрядная версия) SSEA (32-разрядная версия) | SE (64-разрядная версия)
Репликация слиянием | Да | Да | Да 1 | Только подписчик 2 | Да
Репликация транзакций | Да | Да | Да 1 | Только подписчик 3 | Да
Репликация моментальных снимков | Да | Да | Да | Только подписчик | Да
Подписчики, отличные от подписчиков SQL Server | Да | Да | Нет | Нет | Да
Публикация Oracle | Да | Нет | Нет | Нет | Нет
Одноранговая репликация транзакций | Да | Нет | Нет | Нет | Нет

1Если экземпляр WG используется как издатель, то он поддерживает не более 25 подписок на все публикации слиянием и пяти подписок на публикации транзакций. Поддерживается неограниченное количество подписок на публикации моментальных снимков.

2SSE невозможно настроить в качестве издателя или распространителя ни для какого типа репликации. При этом SSE может быть подписчиком, и репликация слиянием позволяет реплицировать изменения в обоих направлениях между издателем и подписчиком.

3SSE не поддерживает обновления посредством очереди с помощью подписок по запросу. Поддерживаются обновления посредством очередей с помощью принудительных подписок и немедленные обновления, использующие как принудительные подписки, так и подписки по запросу (подписки с немедленным обновлением требуют, чтобы координатор распределенных транзакций (MS DTC) был запущен на том же компьютере, что и экземпляр SSE).

4Репликация поддерживает 32-разрядные и 64-разрядные версии SQL Server в одной и той же топологии. Все возможности репликации поддерживаются в 64-разрядной версии со следующими ограничениями.

  • Принудительные подписки от 64-разрядной версии распространителя требуют соответствующей 64-разрядной версии поставщика OLE DB или драйвера ODBC на распространителе. Подписки по запросу от 64-разрядной версии подписчика требуют соответствующей 64-разрядной версии поставщика или драйвера на подписчике. Дополнительные сведения о принудительных подписках и подписках по запросу см. в разделе Подписка на публикации.

  • Чтобы использовать диспетчер синхронизации Windows на 64-разрядном подписчике, который выполняется в режиме WOW (Windows на Windows), необходимо запустить файл mobsync.exe прямо из каталога \Windows\Syswow64, а не из меню Пуск. Запуск исполняемого файла непосредственно из каталога гарантирует использование корректной версии. Дополнительные сведения о режиме WOW см. в разделе Требования к оборудованию и программному обеспечению для установки SQL Server 2005. Дополнительные сведения о диспетчере синхронизации Windows см. в разделе Диспетчер синхронизации Windows.

  • Трансформируемые принудительные подписки от 64-разрядной версии распространителя не поддерживаются, так как недоступны необходимые 64-разрядные версии компонентов служб DTS. Подписки по запросу от 32-разрядной версии экземпляра SQL Server 2005 должны работать с 64-разрядной версией издателя или распространителя. Дополнительные сведения о трансформируемых подписках см. в разделе Преобразование опубликованных данных.

См. также

Другие ресурсы

Спецификации продукта SQL Server 2005

Журнал изменений

Версия Журнал

12 декабря 2006 г.

Измененное содержимое
  • Удалено примечание о том, что поставщик Microsoft OLE DB для DB2 не поддерживается в архитектуре Itanium.

17 июля 2006 г.

Измененное содержимое
  • Документирована поддержка хранимых процедур Microsoft .NET во всех выпусках SQL Server 2005

5 декабря 2005 г.

Измененное содержимое
  • Документирована поддержка выделенного административного соединения для SQL Server 2005 Express Edition.

  • Добавлены сведения о поддержке для SQL Server 2005 Express Edition with Advanced Services.


Настройка высокого уровня доступности

Настройка высокого уровня доступности |
 | См. также
Подготовка к установке SQL Server 2005 >

Дата обновления: 5 декабря 2005 г.

Этот раздел содержит описание нескольких решений по повышению уровня доступности для , улучшающих доступность серверов и баз данных. Решения по повышению уровня доступности защищают от последствий ошибок в программах и сбоев оборудования, помогая сохранить доступность приложений, и предельно сокращают для пользователей время простоя.

SQL Server 2005 предоставляет несколько режимов обеспечения высокого уровня доступности сервера или базы данных. Существуют следующие режимы обеспечения высокого уровня доступности.

  • Отказоустойчивый кластер

    Отказоустойчивый кластер обеспечивает поддержку высокого уровня доступности для всего экземпляра SQL Server. Отказоустойчивый кластер представляет собой сочетание одного или нескольких узлов (серверов), у которых имеются несколько общих дисков. Приложения, такие как SQL Server и службы Notification Services, устанавливаются в кластерную группу службы кластеров Microsoft (MSCS), называемую группой ресурсов. В каждый момент времени каждой группой ресурсов владеет только один узел кластера. Служба приложений имеет виртуальное имя, не зависящее от имен узлов. Это имя используется для ссылки на имя экземпляра отказоустойчивого кластера. Приложение может подключиться к экземпляру отказоустойчивого кластера, указав имя этого экземпляра. При этом приложению необязательно должно быть известно, в каком узле размещается экземпляр отказоустойчивого кластера.

    Экземпляр отказоустойчивого кластера SQL Server выглядит в сети как один компьютер, но при этом обеспечивает переход на другой узел в случае, если текущий узел становится недоступен. Например, при отказе оборудования (за исключением дисков), сбое операционной системы или в ходе запланированного обновления можно настроить экземпляр SQL Server на одном узле отказоустойчивого кластера таким образом, чтобы в случае сбоя переход осуществлялся на любой другой узел в группе дисков.

    Отказоустойчивый кластер не обеспечивает защиту в случае сбоя диска. Можно использовать отказоустойчивый кластер, чтобы уменьшить время простоя системы и обеспечить более высокий уровень доступности приложений. Отказоустойчивый кластер поддерживается в выпусках SQL Server 2005 Enterprise Edition, Developer Edition и, с некоторыми ограничениями, в Standard Edition. Дополнительные сведения об отказоустойчивом кластере см. в разделах Отказоустойчивый кластер и Установка отказоустойчивого кластера.

  • Зеркальное отображение базы данных

    Зеркальное отображение базы данных — это программное решение, предназначенное главным образом для увеличения доступности базы данных за счет почти мгновенного перехода на резервный ресурс. Зеркальное отображение базы данных может использоваться для поддержки одиночной резервной базы данных или зеркальной базы данных, соответствующей базе данных, которая доступна для чтения и записи и называется основной базой данных.

    Зеркальная база данных создается при помощи восстановления резервной копии основной базы данных без воспроизведения транзакций. В результате зеркальная база данных недоступна для клиентов. Однако возможно ее использование для отчетов путем создания моментального снимка зеркальной базы данных. Моментальный снимок базы данных предоставляет клиентам доступ только для чтения к данным, находившимся в базе данных на момент создания моментального снимка.

    В каждую конфигурацию зеркального отображения базы данных входит основной сервер, который содержит основную базу данных, и зеркальный сервер, который содержит зеркальную базу данных. Зеркальный сервер постоянно обновляет зеркальную базу данных, приводя ее в соответствие с основной базой данных.

    Зеркальное отображение базы данных может работать либо в синхронном режиме, обеспечивающем высокую безопасность данных, либо в асинхронном режиме, обеспечивающем высокую производительность. При работе в асинхронном режиме транзакции фиксируются без ожидания завершения записи журнала на диск зеркальным сервером, благодаря чему повышается производительность. В синхронном режиме транзакции фиксируются на обоих участниках, что гарантирует высокую безопасность данных, но может привести к увеличению задержки транзакций.

    В простейшую конфигурацию зеркального отображения базы данных входят только основной и зеркальный серверы. В случае сбоя основного сервера в такой конфигурации зеркальный сервер можно использовать как сервер «горячего» резерва с риском потери данных. В режиме высокой безопасности поддерживается альтернативная конфигурация с автоматическим переходом на резервный ресурс. В этой конфигурации участвует третий экземпляр сервера, называемый следящим, который позволяет зеркальному серверу работать в режиме резервного. Переключение с основной базы данных на зеркальную обычно занимает несколько секунд.

    Зеркальное отображение базы данных полностью поддерживается в SQL Server выпусков Standard Edition и Enterprise Edition, но участники зеркального отображения должны использовать один и тот же выпуск. Экземпляры, работающие с SQL Server выпуска Workgroup Edition или Express Edition, поддерживают только роль следящего сервера. Дополнительные сведения о зеркальном отображении базы данных см. в разделе Зеркальное отображение базы данных.

  • Доставка журналов

    Подобно зеркальному отображению базы данных, доставка журналов функционирует на уровне базы данных. Доставка журналов может использоваться для поддержки одной или нескольких баз данных «горячего резерва», называемых базами данных-получателями, которые соответствуют рабочей базе данных, называемой базой данных-источником. Каждая база данных-получатель создается при помощи восстановления резервной копии базы данных-источника без воспроизведения транзакций или с предложением WITH STANDBY. Восстановление с предложением WITH STANDBY позволяет использовать полученную базу данных-получатель для построения отчетов (с рядом ограничений).

    В конфигурацию доставки журналов входит один сервер-источник (содержащий базу данных-источник), один или несколько серверов-получателей (каждый из которых содержит базу данных-получатель) и сервер мониторинга. Каждый сервер-получатель регулярно обновляет свою базу данных-получатель с помощью резервной копии журналов базы данных-источника. Доставка журналов подразумевает задаваемую пользователем задержку между созданием резервной копии журналов базы данных-источника на сервере-источнике и восстановлением резервной копии журналов на сервере-получателе. Перед переходом на резервный ресурс базу данных-получатель необходимо перевести в актуальное состояние, вручную применив все невосстановленные резервные копии журналов.

    Доставка журналов обеспечивает гибкость поддержки нескольких резервных баз данных. Если требуется несколько резервных баз данных, можно использовать или только доставку журналов, или доставку журналов в дополнение к зеркальному отображению баз данных. При совместном использовании этих решений текущая основная база данных в конфигурации зеркального отображения баз данных одновременно является текущей базой данных-источником в конфигурации доставки журналов.

    Доставка журналов поддерживается в выпусках SQL Server 2005 Enterprise Edition, Standard Edition и Workgroup Edition. Дополнительные сведения о доставке журналов см. в разделе Доставка журналов.

  • Репликация

    В репликации используется принцип публикаций и подписок, который позволяет серверу-источнику (издателю) распространять данные на один или более серверов-получателей (подписчиков). Репликация обеспечивает доступность и масштабируемость этих серверов в режиме реального времени. Она поддерживает фильтрацию, чтобы обеспечить передачу подмножества данных на подписчик, а также разрешает секционированные обновления. Подписчики находятся в оперативном режиме, они доступны для отчетности и других функций, без восстановления запросов. SQL Server предлагает три типа репликации: моментальных снимков, транзакций и слиянием. Репликация транзакций обеспечивает наименьшую задержку, и именно она чаще всего применяется для обеспечения высокого уровня доступности. Дополнительные сведения см. в разделе Улучшение масштабируемости и доступности.

    Репликация поддерживается во всех выпусках SQL Server 2005. Публикация репликации не поддерживается в выпусках SQL Server 2005 Express Edition и SQL Server 2005 Compact Edition. Полный список функций репликации, поддерживаемых каждым выпуском, см. в разделе Возможности, поддерживаемые различными выпусками SQL Server 2005.

    Важно!
    Правильно спроектированная и реализованная стратегия резервного копирования и восстановления — это наиболее важная составляющая любого решения для повышения уровня доступности. Дополнительные сведения см. в разделах Резервное копирование и восстановление баз данных в SQL Server и Резервное копирование и восстановление из копий реплицируемых баз данных.

Выбор решения для обеспечения высокого уровня доступности

В следующем списке приведены соображения по выбору решений для повышения уровня доступности:

  • Работа в отказоустойчивом кластере и зеркальное отображение базы данных обладают следующими общими характеристиками:

    • автоматическое обнаружение сбоя и переход на другой ресурс;

    • переход на другой ресурс вручную;

    • прозрачное перенаправление клиента.

    Применение отказоустойчивого кластера налагает следующие ограничения:

    • работа на уровне экземпляра сервера;

    • требование сертифицированного оборудования;

    • отсутствие средств создания отчетов по резервной базе данных;

    • использование одной копии базы данных;

    • отсутствие защиты от дисковых сбоев.

    Зеркальное отображение базы данных предоставляет следующие преимущества:

    • работа на уровне базы данных;

    • использование одной копии-дубликата базы данных;

      Примечание.
      Если необходимы дополнительные копии, то в дополнение к зеркальному отображению базы данных можно использовать доставку журналов.

    • использование стандартных серверов;

    • ограниченные возможности создания отчетов на зеркальном сервере с использованием моментальных снимков базы данных;

    • нулевая потеря данных при работе в синхронном режиме, достигаемая за счет задержки фиксации транзакций в основной базе данных.

    Зеркальное отображение базы данных предлагает значительное увеличение уровня доступности по сравнению с предыдущим возможным уровнем для SQL Server, а также предлагает легкоуправляемую альтернативу отказоустойчивому кластеру.

    Примечание.
    Дополнительные сведения об использовании зеркального отображения баз данных в отказоустойчивом кластере см. в разделе Зеркальное отображение базы данных и отказоустойчивый кластер. Сведения об использовании служб Notification Services в отказоустойчивом кластере см. в разделе Использование отказоустойчивого кластера со службами Notification Services. Сведения об использовании служб Notification Services с зеркальным отображением базы данных см. в разделе Using Log Shipping or Database Mirroring with Notification Services.

  • Доставка журналов

    Доставка журналов может быть дополнительным или альтернативным средством для зеркального отображения базы данных. Асинхронное зеркальное отображение базы данных и доставка журналов построены на сходных принципах, но обладают существенными отличиями. Доставка журналов предлагает следующие возможности:

    • Поддерживаются несколько баз данных-получателей на нескольких экземплярах сервера для одной базы данных-источника.

    • Позволяет пользователю задать задержку между моментом, когда сервер-источник создает резервную копию журнала базы данных-источника и моментом, когда сервер-получатель должен восстановить резервную копию журнала. Большая задержка может быть полезной, например если данные в базе данных-источнике изменены случайно. Если случайное изменение будет замечено достаточно быстро, задержка позволит получить еще не измененные данные с базы данных-получателя до того, как изменения будут отражены в ней.

      Если рассматривать наименьшее время, необходимое доставке журналов для отражения изменений в базе данных-получателе, то асинхронное зеркальное отображение базы данных имеет потенциальное преимущество, заключающееся в меньшем промежутке времени между моментом изменения в базе данных-источнике и моментом отражения этого изменения в зеркальной базе данных.

      Преимущество зеркального отображения базы данных над доставкой журналов состоит в том, что в режиме с высоким уровнем безопасности в качестве простой стратегии перехода на резервный ресурс поддерживается конфигурация, в которой исключается потеря данных.

      Примечание.
      Сведения об использовании доставки журналов совместно с зеркальным отображением баз данных см. в разделе Зеркальное отображение баз данных и доставка журналов. Сведения об использовании доставки журналов со службами Notification Services см. в разделе Using Log Shipping or Database Mirroring with Notification Services.

  • Репликация

    Репликация предоставляет следующие преимущества:

    • Разрешает фильтрацию в базе данных, чтобы доставлять подмножество данных в базы данных-получатели. Это достигается за счет работы на уровне базы данных.

    • Разрешает наличие нескольких резервных копий базы данных.

    • Обеспечивает доступность и масштабируемость нескольких баз данных в режиме реального времени, поддерживает секционированные обновления.

    • Разрешает полную доступность баз данных-получателей для отчетности и других функций без запросов на восстановление.

    Примечание.
    Сведения об использовании зеркального отображения баз данных совместно с репликацией см. в разделе Replication and Database Mirroring.

В этом разделе

Подраздел | Описание
Отказоустойчивый кластер | Содержит сведения о совместном использовании сочетания одного или нескольких узлов (серверов), у которых имеются несколько общих жестких дисков.
Зеркальное отображение базы данных | Содержит сведения о том, как работает зеркальное отображение базы данных, как настроить и управлять сеансом зеркального отображения базы данных.
Доставка журналов | Содержит сведения о работе доставки журналов, также о настройке и управлении конфигурацией доставки журналов.

См. также

Справочник

Требования к оборудованию и программному обеспечению для установки SQL Server 2005
Возможности, поддерживаемые различными выпусками SQL Server 2005

Другие ресурсы

Репликация SQL Server


Отказоустойчивый кластер

Отказоустойчивый кластер |
 | См. также
Подготовка к установке SQL Server 2005 > Настройка высокого уровня доступности >

Отказоустойчивый кластер в обеспечивает высокий уровень доступности всего экземпляра SQL Server.Например, можно настроить экземпляр SQL Server на одном узле отказоустойчивого кластера так, чтобы в случае отказа оборудования, сбоя операционной системы или в ходе запланированного обновления он переключался на любой другой узел.

Отказоустойчивый кластер - это комбинация из одного или более узлов (серверов) на двух или более общих дисках, которые называются группой ресурсов. Группу ресурсов вместе с ее сетевым именем и IP-адресом, которые составляют кластерное приложение или сервер, называют отказоустойчивым кластером или экземпляром отказоустойчивого кластера. В сети отказоустойчивый кластер SQL Server представлен как один компьютер, но при этом он обеспечивает переход на другой узел в случае, если текущий узел становится недоступным. Отказоустойчивый кластер в сети выступает в роли обычного приложения или отдельного компьютера, но поддерживает дополнительные возможности, увеличивающие его доступность.

Когда используются отказоустойчивые кластеры

Используйте отказоустойчивый кластер для следующего.

  • Управления отказоустойчивым кластером из любого узла конфигурации кластера SQL Server.Дополнительные сведения см. в разделе Установка отказоустойчивого кластера.

  • Переход одного узла отказоустойчивого кластера на любой другой узел в конфигурации отказоустойчивого кластера. Дополнительные сведения см. в разделе Установка отказоустойчивого кластера.

  • Настройки служб Analysis Services для работы на отказоустойчивом кластере.Дополнительные сведения см. в разделе Как установить службы Analysis Services на отказоустойчивом кластере.

  • Выполнения полнотекстовых запросов компонентом Microsoft Search на отказоустойчивом кластере.Дополнительные сведения см. в разделе Использование средств SQL Server с отказоустойчивым кластером.

Установка отказоустойчивого кластера

Для создания отказоустойчивого кластера необходимо выполнить несколько шагов установки.

Для установки, настройки и обслуживания отказоустойчивого кластера SQL Server применяется программа установки SQL Server.Кроме того, при помощи программы установки можно обновить существующий 32-разрядный экземпляр SQL Server 7.0 или до отказоустойчивого кластера SQL Server 2005.Дополнительные сведения см. в разделе Обновления версий и выпусков.

Программа установки SQL Server применяется в отказоустойчивом кластере для следующего.

  • Установки SQL Server на нескольких узлах отказоустойчивого кластера.Количество экземпляров ограничено только количеством узлов, поддерживаемым операционной системой.

    Перед установкой отказоустойчивого кластера необходимо убедиться, что система удовлетворяет минимальным требованиям, и настроить службу кластеров Microsoft (MSCS).Дополнительные сведения о требованиях к отказоустойчивому кластеру см. в разделах Требования к оборудованию и программному обеспечению для установки SQL Server 2005 и Подготовка к установке отказоустойчивого кластера.

    Все узлы отказоустойчивого кластера должны работать на одной платформе (32- или 64-разрядной).Кроме того, 64-разрядные выпуски SQL Server должны быть установлены на 64-разрядном оборудовании, где установлены 64-разрядные версии операционной системы Microsoft Windows.Дополнительные сведения см. в разделе Требования к оборудованию и программному обеспечению для установки SQL Server 2005.

  • Чтобы установить отказоустойчивый кластер Microsoft SQL Server 2005, необходимо создать и настроить отказоустойчивый кластер, запустив программу установки SQL Server. Дополнительные сведения см. в разделе Установка отказоустойчивого кластера.

  • Добавление или удаление узлов из конфигурации отказоустойчивого кластера, не затрагивая другие узлы кластера. Дополнительные сведения см. в разделе Обслуживание отказоустойчивого кластера.

  • Задание нескольких IP-адресов для каждого экземпляра отказоустойчивого кластера. При работе с SQL Server 2005 можно указать несколько IP-адресов для каждого сервера, чтобы использовать все доступные IP-подсети. SQL Server 2005 позволяет указать один IP-адрес для каждой сети.Благодаря этому можно создать резервное соединение на случай, если в одной из подсетей произойдет сбой.

Поддержка отказоустойчивого кластера

В количество узлов отказоустойчивого кластера зависит от операционной системы.Некоторым операционным системам для создания кластера требуются оптоволоконные каналы.Дополнительные сведения см. в разделе Требования к оборудованию и программному обеспечению для установки SQL Server 2005.

Список средств, функций и служб, поддерживаемых отказоустойчивым кластером SQL Server 2005, см. в разделе Возможности, поддерживаемые различными выпусками SQL Server 2005.

См. также

Задачи

Как создать новый отказоустойчивый кластер SQL Server 2005 (установка)

Основные понятия

Подготовка к установке отказоустойчивого кластера


Подготовка к установке отказоустойчивого кластера

Подготовка к установке отказоустойчивого кластера |
 | См. также
Подготовка к установке SQL Server 2005 > Настройка высокого уровня доступности > Отказоустойчивый кластер >

Дата обновления: 12 декабря 2006 г.

Перед тем как установить отказоустойчивый кластер Microsoft SQL Server 2005, необходимо выбрать оборудование и операционную систему, на которых SQL Server 2005 будет работать. Кроме того, необходимо настроить службу кластеров Microsoft (MSCS) и проверить настройки сети, системы безопасности и другого программного обеспечения, которое будет работать на отказоустойчивом кластере.

Предварительная проверка

Прежде чем приступить к установке отказоустойчивого кластера, проанализируйте конфигурацию в соответствии со следующими пунктами.

Проверьте оборудование

  • Применяемое оборудование должно находиться в каталоге Microsoft Windows и перечне совместимого оборудования. Оборудование должно быть упомянуто в категории кластерных решений.

    Важно!
    Добавление отдельных кластерных компонентов не является системой, одобренной при создании отказоустойчивого кластера. Допускается применение лишь систем, приобретенных в качестве кластерных решений и упомянутых в группе кластерных решений. При проверке по каталогу Microsoft Windows и перечне совместимого оборудования укажите категорию «кластерные решения». Все другие категории предназначены для использования производителями оборудования. Дополнительные сведения см. в политике Майкрософт в области поддержки серверных кластеров, перечне совместимого оборудования и каталоге Windows Server.

  • При внедрении отказоустойчивых серверных кластеров в сети хранения данных (SAN) необходимо провести специальную проверку на совместимость оборудования. Законченное аппаратное решение должно находиться к категории «Кластерное или мультикластерное устройство» каталога Microsoft Windows и перечня совместимого оборудования. Дополнительные сведения см. в статье базы знаний Майкрософт Поддержка присоединения нескольких кластеров к одному устройству сети хранения данных (на английском языке).

  • Если кластерное решение включает в себя географически распределенные узлы кластеров, необходимо проанализировать также дополнительные элементы, такие как задержка сети и поддержка использования общих дисков. Законченное решение должно находиться в перечне совместимого оборудования для географически распределенных кластеров. Дополнительные сведения см. в статье базы знаний Майкрософт Кластеры Windows и географически распределенные узлы (на английском языке).

  • Конфигурации SAN поддерживаются также выпусками Advanced Server Edition и Datacenter Edition операционной системы Microsoft Windows 2000. В категории «Кластеры/Многокластерные устройства» каталога Microsoft Windows и перечня совместимого оборудования дан перечень устройств хранения, поддерживающих сети SAN, прошедших испытания и поддерживаемых в качестве элементов хранения сетей SAN с подключением нескольких кластеров MSCS. Подбирая устройства из этого списка к комплектам оборудования для кластерных решений, описанным в категории кластерных конфигураций в каталоге Microsoft Windows и перечне совместимого оборудования, можно собрать такой комплект серверов и кластеров Windows для архитектуры SAN с общими устройствами хранения, который поддерживается Microsoft. Дополнительные сведения см. в статье базы знаний Майкрософт Партнерская программа Windows Datacenter и операционная система Microsoft Windows 2000 Datacenter Server.

  • При развертывании отказоустойчивого кластера SQL Server 2005 на компонентах технологии интернет-интерфейса малых компьютеров (iSCSI) рекомендуется предпринимать соответствующие меры предосторожности. Дополнительные сведения см. в статье базы знаний Майкрософт Поддержка SQL Server 2000 и SQL Server 2005 на компонентах технологии iSCSI (на английском языке).

  • Дополнительные сведения см. в статье базы знаний Майкрософт Политика корпорации Майкрософт в отношении поддержки отказоустойчивых кластеров SQL Server (на английском языке).

  • Определите, какой объем дискового пространства должен быть выделен под ресурс кворума. Диск кворума содержит главную копию конфигурации серверного кластера, а в случае сбоя связи в сети между узлами кластера используется в качестве разрывателя связи. В зависимости от типа внедряемого серверного кластера диск кворума необязательно является физическим диском в общем массиве кластера. Хотя и желательно зарезервировать под диск кворума целый диск кластера, такой диск можно сделать доступным и для других ресурсов.

    Однако в случае совместного использования одного диска ресурсами кворума и другими ресурсами придется выбирать из двух нежелательных альтернатив. Придется либо настроить ресурс так, чтобы его сбои не оказывали влияние на группу, либо смириться с тем, что сбои других ресурсов будут оказывать влияние на группу. В первом варианте теряется поддержка перехода на другой ресурс, а во втором ресурс кворума будет подвергаться сбоям вместе с остальными ресурсами группы, в которую входят ресурс кворума и ресурс, на котором произошел сбой. В результате весь кластер переходит в автономный режим работы на время, которое требуется для переключения группы на другой ресурс.

    Дополнительные сведения о правильной настройке диска кворума см. в статье базы знаний Майкрософт Сведения по настройке диска кворума (на английском языке).

  • Если исходные файлы установки и кластер находятся в разных доменах, то для установки отказоустойчивого кластера SQL Server 2005 необходимо скопировать файлы установки на первичный узел кластера, а затем запустить установку с первичного узла.

Проверьте настройки операционной системы

  • Убедитесь в том, что операционная система установлена должным образом и поддерживает отказоустойчивые кластеры. Дополнительные сведения о поддерживаемых операционных системах см. в разделе Требования к оборудованию и программному обеспечению для установки SQL Server 2005.

  • В Windows Server 2003 включите поставщик службы криптографии Windows (CSP). Если на любом из узлов кластера служба CSP остановлена или отключена, программа установки SQL Server завершается сбоем и отображается диалоговое окно о требованиях совместимости с Windows.

  • При удаленной установке и установке в кластере включите во всех операционных системах службу планировщика заданий. Если «Планировщик заданий» выключен, программа установки SQL Server завершается сбоем и отображается сообщение об ошибке 1058. Дополнительные сведения см. в разделе Как включить службу планировщика задач Windows.

  • SQL Server 2005 поддерживает точки подключения, количество устанавливаемых кластеров SQL Server ограничено числом доступных разделов диска. Если на один раздел диска устанавливается операционная система, а все остальные разделы диска могут использоваться в качестве обычных дисков кластера или дисков кластера, содержащих узлы подключения, максимальное число экземпляров SQL Server на один отказоустойчивый кластер составляет 25.

    Использование подключенного тома или точки подключения позволяет размещать на одном разделе ссылки на множество дисков или томов. Например, если существует диск D:, ссылающийся на обычный диск или том, то в качестве каталогов диска D: можно подключить или «смонтировать» дополнительные диски или тома, не назначая таким дополнительным дискам или томам букв диска.

    Ниже приведены специальные замечания о точках подключения для отказоустойчивых кластеров SQL Server 2005.

    • Программа установки SQL Server требует наличия буквы раздела у базового раздела, к которому подключается диск. При установке отказоустойчивых кластеров на таком базовом разделе должен быть установлен кластер.

    • Базовый раздел, которому назначена буква диска, не может совместно использоваться экземплярами отказоустойчивого кластера. Это обычное для отказоустойчивых кластеров ограничение не касается, однако, изолированных серверов, на которых размещено несколько экземпляров.

    • Настройку отказоустойчивого кластера следует производить с особой осторожностью, следя за тем, чтобы и базовые разделы, и подключенные диски или тома были перечислены в качестве ресурсов в группе ресурсов. Программа установки SQL Server не обеспечивает этого автоматически, а SQL Server также не проверяет этого в ходе выполнения инструкции CREATE/ALTER DATABASE.

    • Проследите за тем, чтобы подключенные диски или тома были смонтированы на базовый раздел с правильной буквой, а также за тем, чтобы подключенный диск был подключен в качестве зависимого от родительского раздела.

Настройте сервер кластеров Microsoft

  • Как минимум на одном узле серверного кластера должен быть настроен сервер кластеров Microsoft (MSCS). Сервер MSCS поддерживается только в случае, если он был установлен на компьютер, конфигурация которого была протестирована на совместимость с MSCS. Кроме того, вместе с сервером MSCS должен работать выпуск SQL Server 2005 Enterprise Edition или Standard Edition. Выпуск SQL Server 2005 Enterprise Edition поддерживает отказоустойчивые кластеры с числом узлов до 8. Выпуск SQL Server 2005 Standard Edition поддерживает отказоустойчивые кластеры, состоящие из двух узлов.

    Дополнительные сведения об установке и настройке сервера MSCS в Windows Server 2003 см. в разделе Кластеры сервера.

    Дополнительные сведения об установке и настройке сервера MSCS в операционной системе Windows 2000 см. в пошаговом руководстве по установке службы кластеров.

  • Сервер MSCS должен иметь возможность проверять состояние экземпляра отказоустойчивого кластера с помощью потока IsAlive. Для этого необходимо установить доверенное соединение с сервером. Необходимо, чтобы учетная запись, с которой работает служба кластеров, была учетной записью администратора на всех узлах в кластере, а также чтобы группа BUILTIN\Администраторы имела разрешение для входа на SQL Server. Эти параметры изменяются только в случае изменения разрешений на узлах кластера.

    Если учетная запись BUILTIN\Администраторы удалена, убедитесь, что учетная запись, с которой работает служба кластеров, может входить на SQL Server для проверки потока IsAlive. В противном случае проверка IsAlive выполняться не будет. Учетная запись службы кластеров MSCS должна обладать по меньшей мере правами роли public на SQL Server, чтобы регулярно запускать @@servername.

  • При установке сервера MSCS важно использовать отдельные учетные записи служб для входа на MSCS и SQL Server. В противном случае нельзя будет изменить пароль службы кластеров с помощью кластерной команды.

  • При использовании сервера MSCS необходимо, чтобы один из узлов мог управлять общей шиной SCSI, прежде чем другие узлы перейдут в оперативный режим. Если этого не обеспечить, то при переключении на другой ресурс приложение может уйти в состояние ожидания оперативного режима и либо не переключится на другой ресурс, либо даст полный сбой. Если для системы кластеров предусмотрен фирменный процесс установки, следует использовать именно его.

Установка координатора распределенных транзакций (Microsoft)

  • Перед установкой SQL Server 2005 в отказоустойчивом кластере определите необходимость создания кластерного ресурса координатора распределенных транзакций (Microsoft) (MSDTC). Если устанавливается только компонент Database Engine, кластерный ресурс MSDTC не требуется. Если устанавливается компонент Database Engine и службы SSIS, службы Notification Services или компоненты рабочей станции, необходимо установить MSDTC. Это требование относится к операционным системам Windows 2000 и Windows Server 2003.

    Диспетчер транзакций MSDTC, учетная запись-посредник MSDTC, а также средства администрирования служб компонентов устанавливаются на каждом узле в кластере серверов Windows. Службы кластеров Microsoft (MSCS) используются кластерами в ходе установки кластера серверов Windows.

    Сведения о настройке координатора MSDTC вручную в операционной системе Windows Server 2003 (где работает сервер MSCS) см. в статьях базы знаний Майкрософт Настройка координатора распределенных транзакций Microsoft в кластере Windows Server 2003 и Разрешение доступа по протоколу DTC в Windows Server 2003.

    Чтобы обеспечить доступность координатора для нескольких кластеризованных приложений, корпорация Майкрософт настоятельно рекомендует предоставить координатору MSDTC собственную группу ресурсов и ресурсы. Если для координатора MSDTC невозможно выделить собственную группу ресурсов, в качестве альтернативы рекомендуется использовать кластерную группу и диск кворума.

Настройте координатор распределенных транзакций Microsoft

  • После установки операционной системы и настройки кластера необходимо настроить координатор MSDTC для работы в кластере с помощью администратора кластера. Если MSDTC не будет настроен для работы в кластере, это не помешает установке SQL Server, но может ограничить функциональные возможности приложений SQL Server.

    Координатор MSDTC может использоваться любым процессом на любом узле в кластере. Эти процессы вызывают учетную запись-посредник MSDTC, которая автоматически перенаправляет вызовы MSDTC диспетчеру транзакций MSDTC, который управляет всем кластером.

    Если в узле, где работает диспетчер транзакций MSDTC, происходит ошибка, то диспетчер транзакций автоматически перезапускается на другом узле в кластере. Новый экземпляр диспетчера транзакций считывает файл журнала MSDTC на общем диске кластера и определяет результат для ожидающих и недавно завершенных транзакций.

    Диспетчеры ресурсов снова подключаются к диспетчеру транзакций и в процессе восстановления определяют результат ожидающих транзакций. Приложения повторно подключаются к координатору MSDTC и могут инициировать новые транзакции.

    Предположим, например, что диспетчер транзакций MSDTC активен в системе B. Приложение и диспетчер ресурсов в системе А вызывают учетную запись-посредник MSDTC. Учетная запись-посредник MSDTC в системе A перенаправляет все вызовы MSDTC диспетчеру транзакций MSDTC в системе B.

    Если в системе B происходит ошибка, управление переходит к диспетчеру транзакций MSDTC в системе A. Последний считывает файл журнала MSDTC на общем диске кластера, выполняет восстановление и приступает к работе в качестве диспетчера транзакций всего кластера.

Анализ прочего программного обеспечения

  • Необходимо, чтобы все узлы кластера имели одинаковую конфигурацию, в т.ч. COM+, буквы разделов диска и пользователей в группе администраторов.

  • Проверьте правильность настройки внутренних соединений кластера (тактовый импульс). Дополнительные сведения см. в статье базы знаний Рекомендуемая закрытая конфигурация с тактовым импульсом для серверов в кластере (на английском языке).

  • Проверьте, чтобы все системные журналы на всех узлах были очищены, и просмотрите их снова. Прежде чем продолжить, убедитесь в том, что в журналах нет сообщений об ошибках.

  • В случае установки SQL Server 2005 параллельно с предыдущими версиями SQL Server службы SQL Server 2005 должны использовать только учетные записи, входящие в глобальную группу доменов. Кроме того, учетные записи, используемые службами SQL Server 2005, не должны входить в локальную группу администраторов. В противном случае система безопасности может повести себя непредвиденным образом.

  • При установке SQL Server 2005 в кластерную группу Windows 2000 с несколькими дисками выберите для данных один диск и сделайте так, чтобы ресурс SQL Server зависел только от этого диска. Чтобы разместить данные или журналы на других или дополнительных дисковых ресурсах, сначала необходимо добавить для ресурса SQL Server зависимость от дополнительного диска. Дополнительные сведения см. в разделе Как добавить зависимости к ресурсу SQL Server 2005.

  • Сведения о развертывании узлов кластера Windows 2000 или Windows Server 2003 в среде, где отсутствуют контроллеры доменов Microsoft Windows 2000 или Windows Server 2003, см. в статье Использование узлов кластеров Windows 2000 и Windows Server 2003 в качестве контроллеров домена (на английском языке).

  • Чтобы использовать шифрование, на всех узлах отказоустойчивого кластера SQL Server необходимо установить сертификат сервера с полным именем DNS кластера MSCS. Например, при наличии кластера из двух узлов с именами Test1.DomainName.com и Test2.DomainName.com, а также экземпляра отказоустойчивого кластера SQL Server с именем Virtsql необходимо получить сертификат Virtsql.DomainName.com и установить его на узлы test1 и test2. Затем для настройки шифрования в отказоустойчивом кластере установите в диспетчере конфигурации SQL Server флажок Принудительное шифрование протокола.

    Важно!
    Не устанавливайте флажок Принудительное шифрование протокола до того, как на всех узлах, входящих в отказоустойчивый кластер, будут установлены сертификаты.

  • Убедитесь в том, что в кластере сервера MSCS не установлены антивирусные программы. Дополнительные сведения см. в статье базы знаний Майкрософт Возможные проблемы со службами кластеров при использовании антивирусного программного обеспечения (на английском языке).

  • SQL Server 2005 не поддерживается на сервере терминалов Windows Server 2003 Terminal Server. Дополнительные сведения см. в статье базы знаний Майкрософт SQL Server 2000 не поддерживается сервером приложений Windows Server 2003 Terminal Server (на английском языке).

  • Убедитесь, что диск, на который будет установлен SQL Server, не является сжатым диском. При попытке установки SQL Server на сжатый диск программа установки SQL Server завершится сбоем.

  • В имени кластерной группы при установке отказоустойчивого кластера нельзя использовать следующие символы:

    • оператор «меньше» (<);

    • оператор «больше» (>);

    • двойная кавычка (");

    • одинарная кавычка (').

Анализ сети

  • Перед запуском программы установки SQL Server отключите протокол NetBIOS для всех адаптеров частной сети.

  • Сетевое имя и IP-адрес SQL Server не должны использоваться для других целей, например для совместного использования файлов. Если требуется создать ресурс общей папки, используйте для этого ресурса другое уникальное сетевое имя и IP-адрес.

    Важно!
    Корпорация Майкрософт рекомендует не размещать общие папки на дисках с данными, поскольку это негативно влияет на поведение и производительность SQL Server.

  • Хотя SQL Server 2005 поддерживает в кластерах и именованные каналы, и сокеты TCP/IP, корпорация Майкрософт рекомендует в кластерных конфигурациях использовать сокеты TCP/IP.

Другие соображения

  • Чтобы создать отказоустойчивый кластер, необходимо иметь разрешения локального администратора с правом входа в качестве службы и выполнять действия от имени компонента операционной системы на всех экземплярах отказоустойчивого кластера.

  • Перед установкой или обновлением отказоустойчивого кластера SQL Server отключите все приложения и все службы, которые могут использовать компоненты SQL Server в ходе установки. Дисковые ресурсы необходимо оставить в оперативном режиме.

  • Создайте группы домена для служб, которые поддерживают работу в кластере и которые должны быть установлены в качестве части отказоустойчивого кластера сервера SQL Server 2005. Служба SQL Server, служба «SQL Server, агент», служба Analysis Services и служба Full-Text Search должны запускаться как учетные записи домена, входящие в глобальную или локальную доменную группу. При необходимости выясните у администратора домена имена существующих доменных групп или попросите создать доменные группы для отказоустойчивого кластера. Дополнительные сведения см. в разделе Доменные группы для служб, поддерживающих работу в кластере.

  • Отказоустойчивые кластеры SQL Server не поддерживают использование узлов кластера в качестве контроллеров домена.

  • Настройте службы DNS или WINS. В среде, где будет устанавливаться отказоустойчивый кластер SQL Server, должен быть запущен DNS-сервер или WINS-сервер. Программе установки SQL Server для виртуальной ссылки на IP-интерфейс SQL Server необходима зарегистрированная служба динамических доменных имен (DDNS). Если динамическая регистрация не может быть завершена, программа установки выдает сообщение об ошибке и выполняет откат установки. Если динамическая регистрация недоступна, необходимо предварительно зарегистрировать сервер в DNS.

  • Просмотрите раздел Анализ безопасности при установке SQL Server.

  • Просмотрите раздел Параметры для средства проверки конфигурации системы.

  • Выясните, поддерживаются ли отказоустойчивыми кластерами инструменты, возможности и компоненты SQL Server, которые предполагается использовать. Дополнительные сведения см. в разделе Отказоустойчивый кластер.

  • Решите, каким образом будет осуществляться мониторинг и обслуживание отказоустойчивого кластера, а также поддерживаться высокий уровень доступности. Дополнительные сведения см. в разделах Обслуживание отказоустойчивого кластера и Использование средств SQL Server с отказоустойчивым кластером.

  • Для экономии времени при установке отказоустойчивого кластера SQL Server 2005 до запуска программы установки SQL Server можно установить платформу Microsoft .NET Framework версии 2.0 на все узлы отказоустойчивого кластера.

См. также

Справочник

Требования к оборудованию и программному обеспечению для установки SQL Server 2005
Параметры для средства проверки конфигурации системы

Основные понятия

Установка отказоустойчивого кластера
Анализ безопасности при установке SQL Server

Журнал изменений

Версия Журнал

12 декабря 2006 г.

Измененное содержимое:
  • Добавлена рекомендация по переводу SQL Server в автономный режим перед установкой или обновлением экземпляра отказоустойчивого кластера.

  • Добавлены рекомендации по безопасности для учетных записей служб при параллельной установке.

  • Обновлен раздел доменных групп. Указано, что учетные записи доменов должны входить в глобальную или локальную доменную группу.

  • Обновлены рекомендации по установке MSDTC.


Установка отказоустойчивого кластера

Установка отказоустойчивого кластера |
 | См. также
Подготовка к установке SQL Server 2005 > Настройка высокого уровня доступности > Отказоустойчивый кластер >

Чтобы установить отказоустойчивый кластер , необходимо создать и настроить экземпляр отказоустойчивого кластера, запустив программу установки SQL Server. В этом подразделе излагаются сведения об элементах отказоустойчивых кластеров, а также важная информация, касающаяся именования отказоустойчивых кластеров. Кроме того, в нем описываются основные шаги установки отказоустойчивых кластеров.

Элементы экземпляра отказоустойчивых кластеров

Экземпляр отказоустойчивого кластера может выполняться на одном или нескольких компьютерах, являющихся узлами-участниками отказоустойчивого кластера. Число узлов-участников ограничивается лишь возможностями операционной системы.

В состав экземпляра отказоустойчивого кластера входят:

  • Комбинация из одного или нескольких дисков в группе кластеров службы кластеров Microsoft (MSCS), известной также как группа ресурсов. Каждая группа ресурсов может содержать не более одного экземпляра SQL Server.

  • Сетевое имя экземпляра отказоустойчивых кластеров.

  • Один или более IP-адресов, назначенных экземпляру отказоустойчивого кластера.

  • Один из экземпляров SQL Server 2005, включающий в себя SQL Server, агент SQL Server и службу Full-text Search (FTS).

Присвоение имени экземпляру отказоустойчивого кластера

Экземпляр отказоустойчивого кластера SQL Server всегда отображается в сети так, как если бы это был один компьютер. При подключении к отказоустойчивому кластеру SQL Server необходимо использовать имя отказоустойчивого кластера SQL Server, а не имя узла компьютера, на котором он запущен. Благодаря этому всегда можно подключиться к экземпляру отказоустойчивого кластера с помощью одного и того же имени, независимо от того, на каком узле запущен SQL Server.

Имя экземпляра отказоустойчивого кластера должно быть уникальным для его домена. SQL Server не прослушивает IP-адреса локальных серверов. Вместо этого SQL Server прослушивает только виртуальный IP-адрес, созданный во время установки экземпляра отказоустойчивого кластера SQL Server.

Функционирование SQL Server после перехода на другой ресурс обеспечивается с помощью отдельных разделов реестра SQL Server и имен служб внутри отказоустойчивого кластера. Поэтому имя, назначенное экземпляру SQL Server, в том числе и применяемому по умолчанию экземпляру, должно быть уникальным для всех узлов отказоустойчивого кластера. Применение уникальных имен экземпляров служит гарантией того, что экземпляры SQL Server, настроенные для аварийного переключения на одиночный сервер, используют различные разделы реестра и имена служб.

Вопросы консолидации SQL Server с отказоустойчивым кластером

  • При планировании консолидации нескольких изолированных серверов с экземплярами отказоустойчивых кластеров SQL Server рекомендуется включить в процесс планирования меры по проверке достаточности аппаратной конфигурации узла кластера для размещения предполагаемого числа экземпляров SQL Server.

    Ниже представлены два типичных сценария и основы рекомендуемых решений, которые можно применять в процессе конфигурации сайта.

    Сценарий 1

    Вы владеете сайтом, на котором размещаются другие сайты, и необходимо предусмотреть размещение до 23 экземпляров SQL Server со следующими требованиями к ресурсам:

    • 2 процессора для 23 экземпляров SQL Server в конфигурации единого узла кластера потребуют 46 ЦП.

    • 2 ГБ памяти для 23 экземпляров SQL Server в конфигурации единого узла кластера потребуют 48 ГБ ОЗУ (2 ГБ дополнительной памяти для ОС).

    • 4 диска для 23 экземпляров SQL Server в конфигурации единого кластерного дискового массива потребуют 92 диска.

    Если число элементов, задействованных при аварийных переключениях, ограничить до половины доступных узлов, требования к оборудованию будут снижены до:

    • 23 процессора, 24 ГБ памяти на узел и доступности 46 дисков.

    С поддержкой точек монтирования общее число дисков может быть в дальнейшем уменьшено. SQL Server потребует 23 диска, каждый из которых должен иметь по три или более точек монтирования для повышения доступного места на диске.

    Одно из возможных ограничений состоит в том, что при повышении требований к процессорам и памяти существующих аппаратных средств может оказаться недостаточно для поддержки этих требований без потери производительности существующих экземпляров SQL Server.

    Сценарий 2

    Миграция существующих экземпляров SQL Server на отказоустойчивый кластер.

    Во-первых, необходимо установить текущие базовые показатели по существующим серверам и отметить все узкие места. Если исходить из того, что базовые статистические показатели производительности обеспечивают следующие потребности и что один накопитель с тремя точками монтирования сможет обеспечить потребности накопителя, будет необходима следующая конфигурация:

    • SQL Server 1 — 8 процессоров, 16 ГБ ОЗУ;

    • SQL Server 2 — 4 процессора, 8 ГБ ОЗУ (требуются большие емкости ОЗУ, при планировании исходите из того, что ОЗУ придется расширять до 12 ГБ);

    • SQL Server 3 — 2 процессора, 16 ГБ ОЗУ (базовые значения свидетельствуют о необходимости установки дополнительных процессоров);

    • SQL Server 4 — 4 процессора, 8 ГБ ОЗУ (необходима дополнительная пропускная способность сетевых каналов связи, установите сетевые адаптеры для 4 выделенных соединений).

    Для замены четырех указанных серверов необходима следующая минимальная конфигурация узла кластера:

    • 18 процессоров, 54 ГБ ОЗУ и 6 сетевых адаптеров.

При расчете минимальной конфигурации для одного узла отказоустойчивого кластера учитываются:

  • общие требования к ЦП;

  • общие требования к памяти;

  • требуемые диски;

  • дополнительные 2 ГБ ОЗУ для операционной системы.

Отметим, что ограничения на диски, характерные для предыдущих версий SQL Server, не касаются SQL Server 2005. С поддержкой монтируемых накопителей, реализованной в SQL Server 2005, каждому экземпляру SQL Server для хранения файлов данных требуется только один кластерный диск.

Установка отказоустойчивого кластера

Чтобы установить отказоустойчивый кластер, необходимо иметь разрешения локального администратора с правом входа в качестве службы и действовать как часть операционной системы на всех узлах отказоустойчивого кластера.

Чтобы установить отказоустойчивый кластер с помощью программы установки SQL Server, нужно выполнить следующие шаги:

  1. Определить, какие сведения необходимы для создания экземпляра отказоустойчивого кластера (это могут быть дисковый ресурс кластера, IP-адреса и сетевое имя) и какие узлы могут быть использованы для перехода на другой ресурс. Дополнительные сведения см. в разделе

    • Подготовка к установке отказоустойчивого кластера

    • Анализ безопасности при установке SQL Server

    Эти меры по конфигурации должны быть предприняты до запуска программы установки SQL Server, для их реализации необходимо использовать оснастку Windows «Администратор кластера». Для каждого экземпляра настраиваемого отказоустойчивого кластера необходимо иметь одну группу MSCS.

  2. Чтобы начать установку отказоустойчивого кластера, требуется запустить программу установки SQL Server. После того как введены все необходимые данные, программа установки устанавливает новый экземпляр двоичных файлов SQL Server на локальном диске каждого компьютера отказоустойчивого кластера и системные базы данных на указанном диске кластера. В каждом узле кластера двоичные файлы устанавливаются по одному и тому же адресу, поэтому следует удостовериться, в том что в каждом узле локальному накопителю присвоено то же буквенное обозначение, что и накопителям других узлов кластера. Новый экземпляр отказоустойчивого кластера SQL Server со всеми ресурсами отказоустойчивого кластера создается, когда программа установки SQL Server завершает работу.

    Если по завершении установки какой-либо ресурс (включая SQL Server) по той или иной причине выходит из строя, происходит повторный запуск ресурсов на том же узле либо группа перемещается на доступный узел отказоустойчивого кластера; это зависит от конфигурации пороговых параметров отказоустойчивого кластера. Доступный узел отказоустойчивого кластера — это один из узлов, определенных как доступные узлы для экземпляра отказоустойчивого кластера в ходе установки SQL Server.

    Примечание.
    Кроме того, экземпляр отказоустойчивого кластера можно создать с помощью INI-файла, хранящегося на установочном компакт-диске SQL Server. Установить отказоустойчивый кластер средствами командной строки могут только опытные пользователи. Дополнительные сведения об установке с помощью ini-файлов см. в разделе Выполнение установки из командной строки.

См. также

Справочник

Требования к оборудованию и программному обеспечению для установки SQL Server 2005

Основные понятия

Подготовка к установке отказоустойчивого кластера

Другие ресурсы

Обновление до SQL Server 2005


Пример отказоустойчивого кластера

Пример отказоустойчивого кластера |
 | См. также
Настройка высокого уровня доступности > Отказоустойчивый кластер > Установка отказоустойчивого кластера >

В следующем примере иллюстрируется настройка отказоустойчивого кластера .

Предварительные требования

Прежде чем продолжить, изучите раздел Подготовка к установке отказоустойчивого кластера.

Пример

CLUSTERNODEA и CLUSTERNODEB - два компьютера в отказоустойчивом кластере.

Запустите программу установки SQL Server на узле кластера, контролирующем диск кластера, где будут расположены файлы данных SQL Server, и создайте экземпляр SQL Server по умолчанию в экземпляре отказоустойчивого кластера с именем SQLCLUSTA. Этот экземпляр отказоустойчивого кластера может работать на узле CLUSTERNODEA или узле CLUSTERNODEB.

Начиная с этого момента установку соединения с сервером выполняйте с указанием SQLCLUSTA в качестве имени сервера в строке соединения.

Выполните программу установки еще раз на узле кластера, контролирующем диск кластера, где будут расположены файлы данных SQL Server.

Важно!
Диск кластера, используемый SQL Server, должен иметь статус отдельного диска. Нельзя использовать логическую секцию диска, использованного для предыдущей установки отказоустойчивого кластера.

Создайте именованный экземпляр Inst1 на новом сервере MSCS с именем SQLCLUSTB. Он должен быть установлен в другой группе ресурсов кластера Microsoft Cluster Service (MSCS). Этот экземпляр отказоустойчивого кластера может работать на узле CLUSTERNODEA или узле CLUSTERNODEB, что определяется узлами, добавленными к определению кластера в процессе установки SQL Server.

Начиная с этого момента установку соединения с сервером выполняйте с указанием SQLCLUSTB\Inst1 в качестве строки соединения.

Два экземпляра отказоустойчивого кластера работают в кластере MSCS, состоящем из узлов CLUSTERNODEA и CLUSTERNODEB. Не считая этого обстоятельства, они полностью отделены друг от друга. Каждый экземпляр отказоустойчивого кластера располагается в собственной группе ресурсов MSCS, имеет уникальный набор IP-адресов, индивидуальное сетевое имя, а также файлы данных, расположенные на отдельном наборе совместно используемых дисков кластера.

Если переход на другой ресурс при сбое происходит для любого ресурса в группе ресурсов MSCS, переход осуществляется для всех ресурсов, являющихся элементами этой группы. В случае с SQLCLUSTA любой сбой (дисковых ресурсов, IP-адреса, сетевого имени или экземпляров SQL Server на виртуальном сервере) вызывает переход всех элементов группы отказоустойчивого кластера на другой ресурс при достижении порогового значения перехода на другой ресурс.

На иллюстрации ниже изображен кластер из двух узлов с исполняемыми файлами и данными. Каждый отказоустойчивый кластер, изображенный на этом рисунке, должен монопольно владеть диском, на котором расположены файлы данных и журнала.

Типичный отказоустойчивый кластер SQL Server 2005

См. также

Основные понятия

Подготовка к установке отказоустойчивого кластера


Обновление до отказоустойчивого кластера SQL Server 2005

Обновление до отказоустойчивого кластера SQL Server 2005 |
 | См. также
Настройка высокого уровня доступности > Отказоустойчивый кластер > Установка отказоустойчивого кластера >

SQL Server 2005 поддерживает обновление версии компонента Database Engine и служб Analysis Services. Дополнительные сведения о поддержке обновления версий см. в разделах Обновление до SQL Server 2005 и Обновления версий и выпусков.

См. также

Задачи

Как произвести обновление до отказоустойчивого кластера SQL Server 2005 (установка)

Справочник

Обновления версий и выпусков

Основные понятия

Подготовка к установке SQL Server 2005

Другие ресурсы

Обновление до SQL Server 2005


Обслуживание отказоустойчивого кластера

Обслуживание отказоустойчивого кластера |
 | См. также
Подготовка к установке SQL Server 2005 > Настройка высокого уровня доступности > Отказоустойчивый кластер >

После установки отказоустойчивого кластера можно изменять или восстанавливать его с помощью программы установки SQL Server Setup. Например, можно добавить дополнительные узлы к экземпляру отказоустойчивого кластера, запустить кластеризованный экземпляр как отдельный экземпляр или удалить узел из конфигурации кластеризованного экземпляра.

Примечание.
Обслуживание кластера в данном выпуске SQL Server возможно можно только с помощью оснастки Установка и удаление программ панели управления.

Добавление узла к существующему экземпляру отказоустойчивого кластера

Программа установки SQL Server предоставляет возможность обслуживания существующего экземпляра отказоустойчивого кластера. При выборе этого параметра появляется возможность добавить другие узлы к конфигурации отказоустойчивого кластера. Можно добавить столько узлов, сколько поддерживает операционная система Microsoft Windows.

Дополнительные сведения см. в разделе Как создать новый отказоустойчивый кластер SQL Server 2005 (установка).

Удаление узла из существующего экземпляра отказоустойчивого кластера

Из конфигурации отказоустойчивого кластера можно удалить узел. Каждый узел в конфигурации отказоустойчивого кластера SQL Server считается равноправным и не зависящим от других узлов кластера, поэтому можно удалить любой узел. Поврежденный узел не может быть удален, а процесс удаления не может удалить SQL Server с недоступного узла. Удаленный узел можно в любой момент опять включить в состав отказоустойчивого кластера. Дополнительные сведения см. в разделе Как создать новый отказоустойчивый кластер SQL Server 2005 (установка).

Использование кластеризованного экземпляра SQL Server в качестве изолированного экземпляра.

Обычно кластеризованный экземпляр SQL Server работает под управлением службы кластеров Microsoft (MSCS). Однако может понадобиться запустить кластеризованный экземпляр SQL Server в качестве изолированного экземпляра. Например, чтобы запустить SQL Server в однопользовательском режиме, может понадобиться запустить кластеризованный экземпляр SQL Server в качестве изолированного экземпляра из командной строки вместо запуска SQL Server с помощью службы MSCS. Для соединения с кластеризованным экземпляром SQL Server в однопользовательском режиме с помощью сокетов ресурсы, определяемые IP-адресом и сетевым именем, должны находиться в автономном режиме для отказоустойчивого кластера, на который установлен данный экземпляр.

Если это невозможно, подключитесь с помощью именованных каналов На клиентской стороне необходимо создать псевдоним для связи через канал, который прослушивается данным экземпляром SQL Server. Воспользуйтесь диспетчером конфигурации SQL Server, чтобы узнать имя канала.

Изменение учетных записей служб

Не изменяйте пароли для любых учетных записей служб SQL Server, если любой из узлов отказоустойчивого кластера отключен или находится в автономном режиме. Если все же необходимо это сделать, переустановите пароль еще раз при помощи диспетчера конфигурации SQL Server, когда все узлы вновь будут находиться в оперативном режиме.

Если учетная запись службы SQL Server не является администратором кластера, административные общие папки нельзя будет удалить ни на одном узле кластера. Для нормальной работы SQL Server в кластере должны быть доступны административные общие папки.

Важно!
Не используйте одну и ту же учетную запись для учетной записи службы SQL Server и для учетной записи службы MSCS. Если сменить пароль для учетной записи службы MSCS, экземпляр SQL Server перестанет работать.

См. также

Задачи

Как произвести восстановление после сбоя отказоустойчивого кластера в сценарии 1
Как произвести восстановление после сбоя отказоустойчивого кластера в сценарии 2
Как

Основные понятия

Подготовка к установке отказоустойчивого кластера


Оптимизация производительности отказоустойчивого кластера

Оптимизация производительности отказоустойчивого кластера |
 | См. также
Настройка высокого уровня доступности > Отказоустойчивый кластер > Обслуживание отказоустойчивого кластера >

Оптимизируя производительность при использовании отказоустойчивого кластера, учитывайте следующие факторы.

Кэширование данных при записи

Если контроллер дисков не является внешним по отношению к компьютеру в кластерной конфигурации, кэширование данных при записи нужно в контроллере отключить для предотвращения утраты данных во время перехода на другой ресурс.

Кэширование данных на контроллерах узлов при обратной записи неизбежно приводит к ухудшению производительности. Однако при использовании внешних контроллеров производительность остается высокой. Внешние массивы дисков не зависят от того, создан ли отказоустойчивый кластер, и могут корректно синхронизировать кэш-память даже по шине SCSI.

Общие папки

Не храните общие папки и кластеризованные базы данных SQL Server на одном диске. Это ухудшает время восстановления и может приводить к переходу кластерной группы на другой ресурс при отказах ресурсов.

Максимальный объем памяти

Производительность отказоустойчивого кластера повышается при большом объеме памяти. Теоретически максимальный объем памяти равен общему объему доступной памяти за вычетом памяти, используемой операционной системой, ресурсами кластера и локальными ресурсами узлов, деленному на число установленных экземпляров Microsoft SQL Server. Задавайте максимальный объем памяти, используя эту формулу. Мы рекомендуем задавать максимальный объем рабочей памяти, равный 80-90 % полученного значения, а затем собирать статистические данные о производительности для дальнейшей оптимизации этого параметра.

Минимальный объем памяти

Минимальный объем памяти следует задавать при использовании нескольких экземпляров SQL Server и заданном максимальном объеме памяти. Задание минимального объема памяти сокращает время перехода на другой ресурс при отказе.

Сходство ЦП кластера

В большинстве ситуаций лучше всего оставить параметры сходства ЦП, заданные по умолчанию. Однако если нужно превысить максимальные рекомендуемые пороги производительности, задайте сходство ЦП кластера в соответствии со сценарием N-1.

Фиксированные IP-порты и фиксированные настройки памяти

Используйте фиксированные IP-порты и фиксированные настройки памяти.

См. также

Другие ресурсы

Хранимая процедура sp_configure (Transact-SQL)
Установка параметров конфигурации сервера


Использование средств SQL Server с отказоустойчивым кластером

Использование средств SQL Server с отказоустойчивым кластером |
 | См. также
Настройка высокого уровня доступности > Отказоустойчивый кластер > Обслуживание отказоустойчивого кластера >

Дата обновления: 5 декабря 2005 г.

Большую часть инструментов и служб можно использовать в отказоустойчивом кластере.Впрочем, перед этим следует ознакомиться с приведенными ниже замечаниями.

Полнотекстовые запросы

При выполнения полнотекстовых запросов в отказоустойчивом кластере с помощью службы поиска Майкрософт следует соблюдать следующие требования.

  • Для правильной работы полнотекстовых запросов на отказоустойчивых кластерах экземпляр должен работать с одной и той же системной учетной записью на всех узлах кластера.

    Примечание.
    Это общее требование для отказоустойчивого кластера, оно относится не только к службе поиска Майкрософт.

  • Изменить стартовую учетную запись SQL Server 2005 в отказоустойчивом кластере можно при помощи диспетчера конфигурации SQL Server.Если в Microsoft Windows сделать это с помощью панели управления или оснастки «Службы», то конфигурация полнотекстового поиска для SQL Server будет нарушена.

Диспетчер конфигурации SQL Server

Для применения диспетчера конфигурации SQL Server на отказоустойчивом кластере следует выполнить следующие требования.

  • Изменить стартовую учетную запись SQL Server 2005 в отказоустойчивом кластере можно при помощи диспетчера конфигурации SQL Server.Если в Windows это делается с помощью панели управления или служебного приложения, то конфигурация сервера может быть повреждена.

  • При создании или изменении баз данных можно только просматривать диски кластера для локального экземпляра отказоустойчивого кластера.

  • Если производится сброс свойства учетной записи службы SQL Server с помощью диспетчера конфигурации SQL Server, то будет предложено перезапустить SQL Server.В конфигурации отказоустойчивого кластера это приводит к отключению полнотекстового поиска и ресурсов агента SQL Server. Однако при повторном запуске SQL Server полнотекстовый поиск и ресурсы агента SQL Server не возвращаются в оперативный режим.Эти ресурсы следует перезапустить вручную с помощью программы Windows Cluster Administrator.

Среда SQL Server Management Studio

  • Если при обзоре таблицы в среде SQL Server Management Studio во время перехода на другой ресурс пропадает соединение с SQL Server, то появляется сообщение об ошибке «Ошибка соединения».Для выхода из окна среды SQL Server Management Studio с отменой изменений следует нажать клавишу ESC.

    Запрос запустить нельзя. Необходимо сохранить изменения или отредактировать сетку.

Диспетчер управления службами

Запустить кластеризованный экземпляр SQL Server можно с помощью диспетчера управления службами.Работу кластеризованного экземпляра SQL Server приостановить нельзя.

Приложение SQL Server Profiler

Приложение SQL Server Profiler можно использовать с отказоустойчивым кластером.Впрочем, если при выполнении трассировки SQL Server Profiler происходит переход на другой ресурс, ее потребуется перезапустить после возвращения сервера в оперативный режим.

Служба SQL Mail

Службу SQL Mail в SQL Server 2005 можно удаленно настраивать с помощью диспетчера конфигурации, если клиент удаленно соединение с сервером с помощью Microsoft SQL Server 2000 с пакетом обновления 3.0 или более поздним.

См. также

Справочник

Возможности, поддерживаемые различными выпусками SQL Server 2005


Диагностика отказоустойчивого кластера

Диагностика отказоустойчивого кластера |
 | См. также
Настройка высокого уровня доступности > Отказоустойчивый кластер > Обслуживание отказоустойчивого кластера >

Дата обновления: 17 июля 2006 г.

Этот подраздел содержит следующие сведения:

  • основные этапы диагностики;

  • восстановление по журналу после сбоя отказоустойчивого кластера;

  • разрешение наиболее частых проблем отказоустойчивого кластера;

  • использование расширенных хранимых процедур и COM-объектов.

Основные этапы диагностики

При работе с отказоустойчивым кластером SQL Server 2005 помните, что кластер серверов состоит из экземпляра отказоустойчивого кластера, работающего под управлением службы кластеров Microsoft (MSCS). Этот экземпляр SQL Server может размещаться на узлах Microsoft MSCS, составляющих кластер серверов Microsoft.

Если на узлах кластера серверов возникнут проблемы, они могут проявить себя как проблемы экземпляра отказоустойчивого кластера. Для идентификации и разрешения этих проблем необходимо предпринять следующие действия в отношении отказоустойчивого кластера SQL Server.

  1. Оборудование:Просмотрите журнал системных событий Microsoft Windows.

  2. Операционная система:Просмотрите журналы событий системы Windows и приложений.

  3. Сеть:Просмотрите журналы событий системы Windows и приложений. Сопоставьте текущую конфигурацию со сведениями, содержащимися в статье базы знаний Майкрософт по рекомендуемой частной конфигурации с тактовым импульсом для кластера серверов.

  4. Безопасность:Просмотрите журналы приложений Windows и событий безопасности.

  5. MSCS:Просмотрите журнал событий системы Windows, журнал приложений и журнал кластера.

  6. SQL Server: Устраните ошибки обычным способом после установления отсутствия ошибок с оборудованием, ОС, сетью, безопасностью и MSCS.

Восстановление по журналу после сбоя отказоустойчивого кластера

Обычно, сбой отказоустойчивого кластера возникает в следующих случаях.

  • Сбой оборудования в одном из узлов двухузлового кластера.Такой сбой оборудования может быть вызван сбоем SCSI-контроллера или ОС.

    Для восстановления после такого сбоя удалите неисправный узел из отказоустойчивого кластера с помощью программы установки SQL Server, устраните сбой оборудования, переключив компьютер в автономный режим, восстановите машину и добавьте восстановленный узел снова к экземпляру отказоустойчивого кластера.

    Дополнительные сведения см. в разделах Как создать новый отказоустойчивый кластер SQL Server 2005 (установка) и Как произвести восстановление после сбоя отказоустойчивого кластера в сценарии 1.

  • Ошибка операционной системы.В этом случае данный узел отключен, но не окончательно неисправен.

    Для восстановления после сбоя ОС восстановите данный узел и проверьте переход на другой ресурс. Если данный экземпляр SQL Server не переключается на другой ресурс должным образом, необходимо программой установки SQL Server удалить SQL Server из отказоустойчивого кластера, произвести необходимые восстановительные процедуры, восстановить резервную копию и снова добавить восстановленный узел к экземпляру отказоустойчивого кластера.

    Такое восстановление после сбоя ОС может занять значительное время.Если сбой ОС можно устранить более простым способом, не прибегайте к этому методу.

    Дополнительные сведения см. в разделах Как создать новый отказоустойчивый кластер SQL Server 2005 (установка) и Как произвести восстановление после сбоя отказоустойчивого кластера в сценарии 2.

Учтите также следующие изменения касательно отказоустойчивых кластеров в SQL Server 2005.

  • В SQL Server 2005 файлы журналов находятся в другом каталоге, нежели в предыдущих выпусках SQL Server.Дополнительные сведения см. в разделе Как просмотреть файлы журналов установки SQL Server 2005.

  • В SQL Server 2005 компоненты, не привязанные к экземпляру, устанавливаются только на главный узел; в SQL Server 2000 такие компоненты устанавливались на все узлы.Дополнительные сведения см. в разделе Настройка учетных записей служб Windows.

  • В SQL Server 2005 структуры каталогов и реестра изменены по сравнению с предыдущими выпусками.Дополнительные сведения см. в разделах Настройка учетных записей служб Windows и Расположение файлов для экземпляра по умолчанию и именованных экземпляров SQL Server 2005.

Разрешение общих проблем

В следующем списке приведено описание общих проблем и даны объяснения по их устранению.

Проблема:Неверное использование синтаксиса командной строки при установке SQL Server 2005

Объяснение 1: Трудно диагностировать проблемы программы установки при использовании в командной строке аргумента /qn, поскольку аргумент /qn подавляет все диалоговые окна программы установки и сообщения об ошибках. Если указан аргумент /qn, все сообщения программы установки, включая сообщения об ошибках, записываются в файлы журналов программы установки.Дополнительные сведения о файлах журналов см. в разделе Как просмотреть файлы журналов установки SQL Server 2005.

Решение 1:Вместо параметра /qn используйте параметры /qb.При использовании аргумента /qb на каждом этапе отображается базовый интерфейс пользователя, в том числе сообщения об ошибках.

Объяснение 2: Использован неверный формат в файле template.ini, расположенном в главном каталоге установочного носителя SQL Server 2005.

Решение 2: Хотя непредвиденные символы могут пропускаться программой установки, включите все нужные переменные в команду установки.

Между переменной и ее значением в командной строке не должно быть пробелов.Например, отсутствует пробел в строке «ADDLOCAL=ALL».При указании строки «ADDLOCAL = ALL» программа установки завершается ошибкой.Другой пример — IP-адрес и его значение.Строка «IP=www.xxx.yyy.zzz,Подключение по локальной сети» является правильной.При добавлении пробела после символа запятой «,» программа установки завершается ошибкой.

Проблема:SQL Server 2005 не удается подключиться к сети после его перемещения на другой узел

Проблема 1: Учетная запись службы SQL Server не может связаться с контроллером домена.

Решение 1:Проверьте журналы событий на предмет записей о проблемах сети, например о сбоях адаптеров или проблемах с DNS.Проверьте контроллер домена командой ping.

Проблема 2: Пароли учетной записи службы SQL Server различны на всех узлах кластера, или узел не был перезапущен, после того как служба SQL Server подверглась миграции с неисправного узла.

Решение 2: Измените пароли учетной записи службы SQL Server при помощи диспетчера конфигурации SQL Server. Если это не было сделано, а пароли учетной записи службы SQL Server изменены на одном узле, необходимо также изменить их на всех остальных узлах.Диспетчер конфигурации SQL Server выполняет это действие автоматически.

Проблема:SQL Server не может получить доступ к дискам кластера

Проблема 1: Программы ПЗУ или драйверы обновлены не на всех узлах.

Решение 1: Удостоверьтесь, что на всех узлах установлены правильные версии программ ПЗУ и одинаковые версии драйверов.

Проблема 2: Узел не может восстановить диски кластера, подвергнутые миграции с неисправного узла на общий диск кластера с другой буквой диска.

Решение 2: Буквы для дисков кластера должны быть одинаковыми на обоих серверах. Если это не так, проверьте исходную установку ОС и службы кластеров Microsoft (MSCS).

Проблема:Сбой службы SQL Server вызывает переход на другой ресурс

Решение: Чтобы сбой определенных служб не вызывал перехода группы SQL Server на другой ресурс, настройте эти службы при помощи программы администрирования кластеров Windows следующим образом:

  • Сбросьте флажок Применить к группе на вкладке Дополнительно диалогового окна Свойства полного текста.Однако, если SQL Server вызовет переход на другой ресурс, служба полнотекстового поиска будет перезапущена.

Проблема:SQL Server не запускается автоматически

Решение: При помощи приложения Cluster Administrator в MSCS настройте автоматический запуск отказоустойчивого кластера. Не следует настраивать службу SQL Server для запуска вручную, нужно настроить приложение «Администратор кластеров» в MSCS для запуска службы SQL Server.

Проблема:Сетевой ресурс, к которому выполняется обращение по имени, недоступен, и нельзя подключиться к SQL Server через TCP/IP

Проблема 1: Сбой службы DNS, в то время как ресурсы кластера настроены на использование DNS.

Решение 1: Устраните проблемы с DNS.

Проблема 2: В сети дублируется какое-либо имя.

Решение 2: С помощью средства NBSTAT найдите дублирующееся имя и устраните проблему.

Проблема 3: SQL Server подключается без использования именованных каналов.

Решение 3: Для подключения через именованные каналы создайте псевдоним при помощи диспетчера конфигурации SQL Server для подключения к нужному компьютеру. Например, при использовании кластера с двумя узлами (Узел A и Узел B) и экземпляра отказоустойчивого кластера (Virtsql) с экземпляром по умолчанию, можно подключиться к серверу, для которого ресурс сетевого имени недоступен, выполнив следующие действия:

  1. Определите, на каком узле группы запущен экземпляр SQL Server при помощи приложения «Администратор кластеров».Например, это оказался Узел A.

  2. Запустите службу SQL Server на этом компьютере командой net start.Дополнительные сведения об использовании net start см. в разделе Запуск SQL Server вручную.

  3. Запустите диспетчер конфигурации SQL Server на Узле A.Просмотрите именованный канал, по которому прослушивает этот сервер.Название будет похоже на \\.\$$\VIRTSQL\pipe\sql\query.

  4. На клиентском компьютере запустите диспетчер конфигурации SQL Server.

  5. Создайте псевдоним SQLTEST1 для соединения с этим каналом по протоколу именованных каналов.Для этого введите Узел A в качестве имени сервера и измените имя канала на \\.\pipe\$$\VIRTSQL\sql\query.

  6. Подключитесь к экземпляру сервера с использованием псевдонима SQLTEST1 в качестве имени сервера.

Проблема:Программа установки SQL Server на кластере завершилась с кодом ошибки 1058

Проблема: Отключение службы планировщика задач на узлах кластера привело к аварийному завершению программы установки с кодом ошибки 1058. В журнал core.log заносится следующая запись:

Копировать код
Error: SetTargetComputer on \\machinename failed with
Unable to start service (1058)
Error: RunRemoteProcess Received return code 1058 from STPCOMPAQ3790N2

Последняя строка данного журнала будет выглядеть, как показано ниже.

Копировать код
<EndFunc Name='DwLaunchMsiExec' Return='1058' GetLastError='183'>

Решение: При помощи диспетчера кластера запустите службу Task Scheduler на всех узлах кластера. Дополнительные сведения см. в разделе Как включить службу планировщика задач Windows.

Проблема:Программа установки SQL Server на кластере завершилась с кодом ошибки 11001

Проблема: Потерянный раздел реестра в ветке [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Microsoft SQL Server\MSSQL.X\Cluster]

Решение: Удостоверьтесь, что куст реестра MSSQL.X в настоящее время не используется, и удалите данный ключ кластера.

Проблема:Ошибка при установке кластера:«У установщика недостаточно прав доступа к этому каталогу:<диск>\Microsoft SQL Server.Работа программы установки прервана.Войдите в систему как администратор или обратитесь к своему системному администратору»

Проблема. Эта ошибка произошла из-за общего диска SCSI, неверно разбитого на секции.

Решение: Создайте повторно единую секцию на этом общем диске следующими действиями:

  1. Удалите данный дисковый ресурс из кластера.

  2. Удалите на этом диске все секции.

  3. Удостоверьтесь в свойствах диска — в том, что он является основным.

  4. Создайте на этом общем диске одну секцию, отформатируйте диск и присвойте ему букву.

  5. Добавьте этот диск к кластеру с помощью приложения «Администратор кластеров» (cluadmin).

  6. Запустите программу установки SQL Server.

Проблема:Приложениям не удалось прикрепить ресурсы SQL Server 2005 в распределенной транзакции

Проблема: Поскольку координатор распределенных транзакций Microsoft (MS DTC) настроен в Windows не полностью, то приложениям, возможно, не удастся прикрепить ресурсы SQL Server 2005 к распределенной транзакции. Эта проблема касается связанных серверов, распределенных запросов и удаленных хранимых процедур, использующих распределенные транзакции.

Решение: Для предотвращения этой проблемы необходимо полностью включить службы MS DTC на сервере, на котором установлен SQL Server 2005.

Чтобы полностью включить координатор MS DTC, выполните следующие шаги.

  1. На панели управления откройте Администрирование, затем Управление компьютером.

  2. В левой области окна «Управление компьютером» разверните узел Службы и приложения и щелкните пункт Службы.

  3. В правой области окна «Управление компьютером» правой кнопкой мыши щелкните Координатор распределенных транзакций и выберите Свойства.

  4. В окне Координатор распределенных транзакций перейдите на вкладку Общие и нажмите кнопку Стоп, чтобы остановить службы.

  5. В окне Координатор распределенных транзакций перейдите на вкладку Вход в систему и выберите в качестве учетной записи для входа в систему NT AUTHORITY\NetworkService.

  6. Нажмите кнопки Применить и ОК, чтобы закрыть окно Координатор распределенных транзакций.Закройте окно Управление компьютером.Закройте окно Администрирование.

Примечание.
Для установки SQL Server 2005 на компьютерах, входящих в состав отказоустойчивого кластера, службы MS DTC должны быть полностью включены и кластеризованы до запуска программы установки.Если службы координатора распределенных транзакций Microsoft (MS DTC) не кластеризованы, программа установки завершается неудачно.Перед запуском программы установки проверьте с помощью программы «Администратор кластеров», что MS DTC был кластеризован.

Проблема: Сбой программы установки отказоустойчивого кластера SQL Server 2005 при установке с компакт-диска

Проблема: При выборе компонента отказоустойчивого кластера и компонента клиентских средств в ходе выполнения программы установки SQL Server 2005, установка может завершиться неудачно с ошибкой «Не удалось завершить удаленную установку» после вставки в дисковод для компакт-дисков установочного диска 2.

Решение: Копируйте установочные файлы с обоих компакт-дисков в один каталог на активном узле кластера или общем сетевом ресурсе. Например:

Копировать код
c:
cd\
md SQLENT

Копируйте содержимое обоих компакт-дисков в каталог SQLENT:

\SQLENT\Servers

\SQLENT\Tools

Примечание.
Эта проблема не возникает при установке с DVD-диска.

Использование расширенных хранимых процедур и COM-объектов

При использовании расширенных хранимых процедур в конфигурациях с отказоустойчивым кластером все такие процедуры должны быть установлены на диск кластера под управлением SQL Server.Это обеспечивает возможность снова использовать расширенные хранимые процедуры после перехода узла на другой ресурс.

Если данные расширенные хранимые процедуры используют COM-компоненты, администратор должен зарегистрировать их на каждом узле кластера.Сведения для загрузки и выполнения COM-компонентов должны быть в реестре активного узла, чтобы можно было создать эти компоненты.В противном случае эти сведения остаются в реестре компьютера, на котором эти СОМ-компоненты были зарегистрированы в первый раз.

См. также

Основные понятия

Как просмотреть файлы журналов установки SQL Server 2005

Другие ресурсы

How Extended Stored Procedures Work
Execution Characteristics of Extended Stored Procedures

Журнал изменений

Версия Журнал

17 июля 2006 г.

Измененное содержимое:
  • Добавлен подраздел о неудачном завершении программы установки при установке с компакт-диска.


Разделы руководства по конфигурированию доступности

Разделы руководства по конфигурированию доступности |
 | См. также
Подготовка к установке SQL Server 2005 > Настройка высокого уровня доступности >

В этом разделе перечислены подразделы, описывающие способы установки и использования функций отказоустойчивого кластера SQL Server 2005:

  • Разделы руководства по отказоустойчивому кластеру

  • Разделы руководства по зеркальному отображению баз данных

  • Разделы руководства по доставке журналов

См. также

Основные понятия

Отказоустойчивый кластер

Другие ресурсы

Зеркальное отображение базы данных
Доставка журналов


Разделы руководства по отказоустойчивому кластеру

Разделы руководства по отказоустойчивому кластеру |
 | См. также
Подготовка к установке SQL Server 2005 > Настройка высокого уровня доступности > Разделы руководства по конфигурированию доступности >

Подразделы в данном разделе руководства описывают создание и обслуживание отказоустойчивого кластера. Перед созданием отказоустойчивого кластера необходимо настроить службу кластеров (MSCS) с помощью администратора кластера.

В этом разделе

  • Как создать новый отказоустойчивый кластер SQL Server 2005 (установка)

  • Как добавить зависимости к ресурсу SQL Server 2005

  • Как

  • Как произвести восстановление после сбоя отказоустойчивого кластера в сценарии 1

  • Как произвести восстановление после сбоя отказоустойчивого кластера в сценарии 2

  • Как изменить IP-адрес отказоустойчивого кластера SQL Server 2005

  • Как включить службу планировщика задач Windows

  • Как

См. также

  • Отказоустойчивый кластер

  • Подготовка к установке отказоустойчивого кластера

См. также

Другие ресурсы

Разделы руководства по конфигурированию доступности


Как создать новый отказоустойчивый кластер SQL Server 2005 (установка)

Как создать новый отказоустойчивый кластер SQL Server 2005 (установка) |
 | См. также
Настройка высокого уровня доступности > Разделы руководства по конфигурированию доступности > Разделы руководства по отказоустойчивому кластеру >

Дата обновления: 12 декабря 2006 г.

С помощью мастера установки SQL Server 2005 можно установить Microsoft SQL Server 2005 или обновить предыдущую версию до SQL Server 2005. Программа установки SQL Server 2005 работает на основе установщика Microsoft Windows и предоставляет единое дерево компонентов, позволяющее установить все компоненты SQL Server 2005. Благодаря этому нет необходимости устанавливать каждый компонент отдельно.

Сведения об обновлении см. разделах Обновления версий и выпусков и Обновление до SQL Server 2005.

Чтобы установить изолированный экземпляр SQL Server 2005 см. раздел Как установить SQL Server 2005 (программа установки). Сведения об обновлении отдельного экземпляра или экземпляра отказоустойчивого кластера см. в разделе Как произвести обновление до отказоустойчивого кластера SQL Server 2005 (установка).

Предварительные требования

Перед началом установки следует ознакомиться со следующими разделами электронной документации по SQL Server:

  • Подготовка к установке SQL Server 2005

  • Подготовка к установке отказоустойчивого кластера

  • Очень важно изучить и в точности следовать инструкциям, содержащимся в статье Рекомендуется базы знаний Microsoft.

  • Перед созданием отказоустойчивого кластера Microsoft SQL Server следует настроить службу кластеров Microsoft (MSCS) и создать хотя бы один дисковый ресурс кластера на общем устройстве с помощью администратора кластеров в Microsoft Windows 2000 или в Windows Server 2003, Enterprise Server.

  • Для локальных установок следует запускать программу установки SQL Server с правами администратора. При установке SQL Server из удаленной общей папки необходимо использовать учетную запись домена с разрешениями на чтение и выполнение для удаленной общей папки.

  • Рекомендуется запускать программу установки из активного узла.

    Примечание.
    Перед началом установки SQL Server запомните расположение общего устройства в администраторе кластера, поскольку эти сведения понадобятся при создании нового отказоустойчивого кластера.

Создание отказоустойчивого кластера SQL Server 2005

  1. Вставьте DVD с Microsoft SQL Server 2005 в DVD-привод. Если мастер установки SQL Server не запустился автоматически, дважды щелкните имя файла Splash.hta в корневом каталоге этого DVD.

    При установке по сети предоставьте общий доступ к файлам установки и подключитесь к этому расположению с компьютера, на который устанавливается SQL Server.

  2. Чтобы начать установку, нажмите кнопку Установить SQL Server.

  3. На странице Лицензионное соглашение прочтите лицензионное соглашение, затем установите флажок для подтверждения принятия условий соглашения. После принятия лицензионного соглашения станет доступна кнопка Далее. Чтобы продолжить, нажмите ее. Чтобы выйти из программы установки, нажмите кнопку Отмена.

  4. Запустится программа обновления компонентов SQL Server, которая устанавливает программы, требуемые для установки SQL Server. Чтобы получить дополнительные сведения о требованиях компонентов, нажмите кнопку Справка в нижней части страницы. Для продолжения работы после обновления компонента нажмите кнопку Готово.

  5. Чтобы продолжить, нажмите кнопку Далее на странице Приветствие мастера установки SQL Server.

  6. На странице Проверка конфигурации системы выполняется проверка компьютера на соответствие всем обязательным требованиям установки. Дополнительные сведения о проверяемых параметрах конфигурации см. в разделе Проверка конфигурации системы (SCC).

    Чтобы прервать проверку, нажмите кнопку Остановить. Для продолжения установки после завершения проверки нажмите кнопку Продолжить.

    Примечание.
    Если при проверке были выявлены какие-либо ошибки, определите их тип и нажмите кнопку Выход. До устранения обнаруженных ошибок завершить установку будет невозможно. Дополнительные сведения см. в разделе Параметры для средства проверки конфигурации системы.

  7. На странице Установка Microsoft SQL Server мастер установки SQL Server выполняет подготовку к установке программы. По окончании процесса подготовки мастер установки продолжит установку.

  8. На странице Регистрационные данные введите данные в текстовые поля Имя и Организация. Чтобы продолжить, нажмите кнопку Далее.

  9. На странице Устанавливаемые компоненты выберите компоненты для установки.

    При выборе группы компонентов ее описание отображается в области Компоненты, которые необходимо установить. Можно установить любую комбинацию компонентов (устанавливаемые компоненты отмечаются флажками). Если при выборе SQL Server или служб Analysis Services программа установки определила, что производится установка на отказоустойчивый кластер, флажки Создать отказоустойчивый кластер SQL Server или Создать отказоустойчивый кластер Analysis Server станут доступными. Чтобы установить отказоустойчивый кластер, должен быть выбран этот параметр. Если на другом сервере уже установлены инструменты администрирования, и нужно сократить время установки, то можно не устанавливать инструменты администрирования на начальном этапе. Впоследствии можно будет настроить новый сервер удаленно, повторно запустив программу установки SQL Server для административных средств.

    Чтобы установить отдельные компоненты или указать расположение для установки файлов, нажмите кнопку Дополнительные параметры. В противном случае выберите нужные компоненты, затем нажмите кнопку Далее.

  10. Если на предыдущей странице была нажата кнопка Дополнительно, то появится страница Выбор компонентов. На странице Выбор компонентов в раскрывающихся списках выберите компоненты программы для установки. Чтобы установить компоненты в определенный каталог, выберите нужные компоненты и нажмите кнопку Обзор. Дополнительные сведения о возможностях этой страницы см. в разделе Выбор компонентов. Если выбор компонентов закончен, то для продолжения нажмите кнопку Далее.

  11. На странице Имя экземпляра выберите для установки экземпляр по умолчанию или именованный экземпляр. Если именованный экземпляр или экземпляр по умолчанию уже установлен и для установки выбран уже существующий экземпляр, то программа установки выполнит его обновление и предоставит возможность установить дополнительные компоненты.

    Для установки нового экземпляра по умолчанию старый экземпляр по умолчанию следует удалить с компьютера.

    Для установки именованного экземпляра нажмите кнопку Именованный экземпляр и в соответствующем поле введите уникальное имя экземпляра. Дополнительные сведения о правилах именования экземпляров см. в разделе Имя экземпляра.

  12. На странице Имя виртуального SQL Server введите уникальное имя для устанавливаемого экземпляра. Это имя будет использоваться для идентификации отказоустойчивого кластера в сети. Виртуальное имя SQL Server должно быть уникальным в сети и отличаться от имен ведущего кластера и узлов кластера. Чтобы продолжить, нажмите кнопку Далее.

    Важно!
    В качестве имени экземпляра нельзя использовать имя DEFAULT или MSSQLSERVER. Имена должны соответствовать правилам для идентификаторов SQL Server. Дополнительные сведения о правилах именования экземпляров см. в разделе Имя экземпляра.

    Примечание.
    Страница Имя виртуального SQL Server отображается только в том случае, если программа установки определит, что на компьютере запущена служба MSCS. Если страница Имя виртуального SQL Server не отображается, то отмените установку и настройте службу MSCS. Подробную справку по этой странице см. в разделе Имя виртуального сервера.

  13. На странице Конфигурация виртуального SQL Server введите IP-адрес каждой сети, настроенной для клиентского доступа. То есть следует ввести по одному IP-адресу для каждой сети общего пользования или смешанной сети, в которой экземпляр отказоустойчивого кластера будет доступен клиентам. Для каждой подсети допустим только один IP-адрес.

    Во избежание конфликта IP-адресов убедитесь, что IP-адреса, назначенные тактовому импульсу и SQL Server 2005, не используются другими приложениями.

    Выберите нужную сеть и введите для нее IP-адрес. Нажмите кнопку Добавить.

    Отобразятся IP-адрес и подсеть. Подсеть поддерживается MSCS. Вводите таким образом IP-адреса для каждой установленной сети до тех пор, пока не зададите адреса для всех нужных сетей. Чтобы продолжить, нажмите кнопку Далее. Дополнительные сведения см. в разделе Конфигурация виртуального сервера.

  14. На странице Выбор группы кластеров выберите из списка Доступные группы кластеров группу, содержащую устройство, которое планируется использовать для SQL Server. Выбранная группа кластеров находится там, где размещены ресурсы виртуального SQL Server. Если выбрана группа, содержащая ресурс кворума кластера, то отобразится предупреждение, рекомендующее не выполнять установку в эту группу. Кроме того, в поле Файлы данных можно указать пользовательский путь для файлов данных. Чтобы продолжить, нажмите кнопку Далее. Дополнительные сведения см. в разделе Выбор группы кластера.

  15. На странице Конфигурация узла кластера укажите узлы, которые нужно включить в экземпляр отказоустойчивого кластера. Чтобы добавить узел в экземпляр отказоустойчивого кластера, выберите компьютер из списка Доступные узлы и нажмите Добавить. Чтобы удалить узел из экземпляра отказоустойчивого кластера, выберите компьютер из списка Выбранные узлы и нажмите кнопку Удалить. Все недоступные узлы отображаются в списке Недоступные узлы вместе с причинами их недоступности.

    Для создания отказоустойчивого кластера с одним узлом в списке Обязательный узел должен быть указан только узел, который будет устанавливаться с экземпляром отказоустойчивого кластера.

    Чтобы продолжить, нажмите кнопку Далее. Дополнительные сведения см. в разделе Настройка узла кластера.

  16. На странице Сведения об удаленной учетной записи укажите сведения об удаленном имени входа: имя пользователя и пароль с правами администратора на все узлы кластера. Это диалоговое окно появляется только при установке на удаленный узел. Предоставляемые учетные данные используются только во время установки SQL Server для настройки SQL Server на каждом узле экземпляра отказоустойчивого кластера. Эта учетная запись должна быть действующей учетной записью администратора на всех узлах кластера. Чтобы продолжить, нажмите кнопку Далее. Дополнительные сведения см. в разделе Сведения об удаленной учетной записи.

  17. На странице Служебные учетные записи (кластеры) укажите имя пользователя, пароль и имя домена для служебных учетных записей SQL Server. Можно использовать одну учетную запись для всех служб. Все учетные записи служб для экземпляра отказоустойчивого кластера должны быть учетными записями домена. После того, как из списка Служба будет выбрана нужная служба, установите флажок Настроить для каждой учетной записи службы, чтобы указать параметры Имя пользователя, Пароль и Домен для отдельных служб. Учетная запись службы агента SQL Server должна являться администратором для узла кластера. Не используйте ту же учетную запись, которая была назначена для службы кластеров.

    При необходимости можно указать отдельную учетную запись для каждой службы. Чтобы указать отдельную учетную запись для каждой службы, выберите вариант Настроить для каждой учетной записи службы, выберите имя службы из раскрывающегося списка и укажите учетные данные входа. Чтобы продолжить, нажмите кнопку Далее. Дополнительные сведения см. в разделе Учетные записи служб (кластеры).

    Примечание.
    Имя домена не может быть полным DNS-именем. Например, если используется DNS-имя my-domain-name.com, введите my-domain-name в поле Домен. SQL Server не поддерживает имена вида my-domain-name.com в поле Домен.

  18. На странице Доменные группы для служб, поддерживающих работу в кластере укажите ИмяДомена\ИмяГруппы для каждой устанавливаемой кластеризованной службы (служба SQL Server, служба «SQL Server, агент», служба Analysis Services и служба Full-Text Search), которые должны выполняться от имени учетной записи домена, входящей в глобальную или локальную группу домена. Чтобы продолжить, нажмите кнопку Далее. Дополнительные сведения см. в разделе Доменные группы для служб, поддерживающих работу в кластере.

  19. На странице Режим проверки подлинности выберите режим проверки подлинности, применяемый для установки SQL Server. Кроме того, следует ввести и подтвердить надежный пароль для имени входа системного администратора (sa). Чтобы продолжить, нажмите кнопку Далее.

    Примечание безопасности.
    При возможности используйте проверку подлинности Windows.

    Примечание безопасности.
    В этом выпуске SQL Server программа установки в некоторых конфигурациях Windows Server 2003 по умолчанию может не требовать использования надежных паролей, если компьютер не является членом домена. Безопасность системы во многом зависит от надежности паролей. Следует всегда использовать надежные пароли. Рекомендации по выбору надежного пароля см. в разделе Режим проверки подлинности электронной документации по SQL Server 2005.

  20. На странице Настройки параметров сортировки укажите способ сортировки для вашего сервера. Можно использовать одни параметры сортировки для SQL Server и служб Analysis Services или же задать различные параметры сортировки для отдельных компонентов.

    Чтобы задать для SQL Server и служб Analysis Services различные параметры сортировки, установите флажок Настроить для каждой учетной записи службы. После этого появится раскрывающийся список. Выберите службу из раскрывающегося списка и назначьте ей параметры сортировки. Выполните это действие для всех служб. Чтобы продолжить, нажмите кнопку Далее. Дополнительные сведения см. в разделе Параметры сортировки.

  21. На странице Настройки сообщений об ошибках и использовании снимите при необходимости флажки для отключения отчетов об ошибках или использовании возможностей. Чтобы продолжить, нажмите кнопку Далее. Дополнительные сведения см. в разделе Параметры отчетов об ошибках и использовании.

  22. На странице Готово к установке проверьте сводный список функций и компонентов для установки SQL Server. Чтобы продолжить, нажмите кнопку Установить.

  23. На странице Процесс установки можно наблюдать за процессом установки на отдельных узлах кластера, выбирая узел из выпадающего списка «Узел». При этом отобразится процесс выполнения установки для выбранного узла. Чтобы просмотреть файл журнала для компонента во время установки, щелкните имя продукта или состояния на странице Ход установки.

  24. На странице Завершение работы мастера установки Microsoft SQL Server можно просмотреть сводный журнал установки. Для этого щелкните соответствующую ссылку на этой странице. Для выхода из мастера установки SQL Server нажмите кнопку Готово.

  25. Если будет предложено перезагрузить компьютер, выполните перезагрузку. После завершения установки важно прочитать сообщение программы установки. Сбой при перезапуске любого из указанных узлов может привести к ошибкам при последующих запусках программы установки.

Следующие шаги

  • Настройка новой установки SQL Server. Чтобы уменьшить уязвимую контактную зону системы, SQL Server 2005 выборочно устанавливает и активирует ключевые службы и функции. Дополнительные сведения об активации возможностей SQL Server 2005 см. в разделе Настройка контактной зоны SQL Server.

Дополнительные сведения о размещении журналов см. в разделе Как просмотреть файлы журналов установки SQL Server 2005.

Дополнительные сведения о проверке новой установки SQL Server см. в разделе Как проверить успешность установки служб SQL Server 2005.

См. также

Задачи

Как установить SQL Server 2005 из командной строки


Как добавить или удалить узлы отказоустойчивого кластера SQL Server 2005 (установка)

Как добавить или удалить узлы отказоустойчивого кластера SQL Server 2005 (установка) |
 | См. также
Настройка высокого уровня доступности > Разделы руководства по конфигурированию доступности > Разделы руководства по отказоустойчивому кластеру >

Дата обновления: 12 декабря 2006 г.

Управление узлами в экземпляре отказоустойчивого кластера осуществляется с помощью данной процедуры.

Важно!
Для обновления или удаления отказоустойчивого кластера SQL Server необходимо обладать правами локального администратора с разрешением на вход в систему в качестве службы на всех узлах отказоустойчивого кластера.

Добавление или удаление узлов отказоустойчивого кластера SQL Server 2005

  1. Дважды щелкните Установка и удаление программ на панели управления.

  2. Выберите компонент SQL Server 2005, который необходимо обновить, и щелкните Изменить. Запустится мастер установки SQL Server 2005.

  3. На странице Выбор компонента выберите имя нужного экземпляра SQL Server 2005. Нажмите кнопку Далее.

  4. На странице Обслуживание компонентов выберите в данном экземпляре SQL Server 2005 нужный компонент. Нажмите кнопку Далее. Запустится средство проверки конфигурации SQL Server 2005.

    На странице Приветствие нажмите кнопку Далее. Средство проверки конфигурации выполнит просмотр текущей конфигурации компьютера.

  5. После завершения работы средства проверки конфигурации нажмите кнопку Далее.

  6. На странице Изменить или удалить экземпляр щелкните Обслуживание виртуального сервера.

  7. На странице Конфигурация узла кластера укажите узлы, которые нужно включить в экземпляр отказоустойчивого кластера. Чтобы добавить узел к отказоустойчивому кластеру, выберите компьютер из списка Доступные узлы и нажмите кнопку Добавить. Чтобы удалить узел из отказоустойчивого кластера, выберите компьютер из списка Выбранные узлы и нажмите кнопку Удалить. Недоступные узлы отображаются в списке Недоступные узлы вместе с причиной, по которой они недоступны.

    Для создания отказоустойчивого кластера с одним узлом в списке Обязательный узел должен быть указан только узел, который будет устанавливаться с отказоустойчивым кластером.

    Нажмите кнопку Далее. Дополнительные сведения см. в разделе Настройка узла кластера.

  8. На странице Готовность к обновлению просмотрите сводные данные по установке SQL Server. Выберите нужные параметры обновления и нажмите кнопку Обновить.

  9. На странице Ход установки можно следить за ходом установки отдельных узлов кластера. Для этого выберите нужный узел в списке Узел. Отобразится процесс его установки. Чтобы просмотреть файл журнала для компонента во время установки, щелкните имя продукта или состояние на странице Ход установки.

  10. На странице Завершение работы мастера установки Microsoft SQL Server можно просмотреть сводный журнал установки. Для этого щелкните ссылку на этой странице. Для выхода из мастера установки SQL Server нажмите кнопку Готово.

    Если будет предложено перезагрузить компьютер, выполните перезагрузку. После завершения установки важно следовать инструкциям программы установки. Если не перезапустить любой из указанных узлов, при последующих запусках программы установки могут возникнуть ошибки.

  11. Все узлы экземпляра отказоустойчивого кластера должны быть одних и тех же версий. После завершения установки SQL Server необходимо загрузить и применить последний пакет обновлений или исправлений SQL Server 2005, чтобы убедиться в том, что все отказоустойчивые узлы кластера имеют одни и те же версии.

См. также

Задачи

Как просмотреть файл журнала установки SQL Server 2005
Как

Основные понятия

Как просмотреть файлы журналов установки SQL Server 2005


Как изменить IP-адрес отказоустойчивого кластера SQL Server 2005

Как изменить IP-адрес отказоустойчивого кластера SQL Server 2005 |
 | См. также
Настройка высокого уровня доступности > Разделы руководства по конфигурированию доступности > Разделы руководства по отказоустойчивому кластеру >

Чтобы обслуживать и обновлять отказоустойчивый кластер , используйте средство Установка и удаление программ на панели управления. Дополнительные сведения о синтаксисе командной строки см. в разделе Как установить SQL Server 2005 из командной строки.

Перед тем как продолжить, просмотрите следующий подраздел электронной документации: Подготовка к установке отказоустойчивого кластера.

Дополнительные сведения об изменении IP-адреса сетевых адаптеров в узлах кластера см. в статье базы знаний Майкрософт.

Важно!
Обслуживание или обновление отказоустойчивого кластера SQL Server может выполняться локальным администратором, имеющим разрешение на вход в систему в качестве службы на все узлы отказоустойчивого кластера.

Изменение IP-адреса отказоустойчивого кластера SQL Server 2005

  1. В меню «Пуск» выберите команду Выполнить и введите cluadmin для запуска администратора кластеров и подключения к локальному экземпляру.

  2. В левой области раскройте узел «Группы» и выберите обновляемую группу.

  3. В области справа щелкните правой кнопкой мыши элемент SQL IP Address1 (имя экземпляра отказоустойчивого кластера) и выберите пункт Свойства.

  4. Перейдите на вкладку Параметры и измените IP-адрес для SQL IP Address1 (имя сервера SQL Server) в поле Адрес.

  5. Нажмите кнопку Применить, чтобы сохранить изменения. Возможно, появится окно предупреждения, содержащее следующий текст:

    «Стандартное расширение администратора кластеров: При попытке установить свойства произошла ошибка: Свойства были сохранены, но не все изменения вступят в силу до того, как ресурс вновь перейдет в оперативный режим. Идентификатор ошибки: 5024 (000013a0).»

  6. Нажмите кнопку ОК, чтобы очистить диалоговое окно Стандартное расширение администратора кластеров и вернуться в администратор кластеров. Чтобы перевести ресурсы в автономный режим и затем возвратить их в оперативный режим, нужно выполнить следующие действия.

  7. В области справа щелкните правой кнопкой мыши элемент SQL IP Address1 (имя экземпляра отказоустойчивого кластера) и выберите пункт Перевести в автономный режим. Состояние SQL IP Address1 (имя экземпляра отказоустойчивого кластера), SQL Network Name (имя экземпляра отказоустойчивого кластера) и SQL Server изменится с «оперативное» на «ожидание перехода в автономное», затем на «автономное».

    Примечание.
    Распространение изменений IP-адреса по корпоративной сети может занять более 30 минут. Попробуйте перевести серверы SQL IP Address1 (имя экземпляра отказоустойчивого кластера) и SQL Network Name (имя экземпляра отказоустойчивого кластера) в оперативный режим, а затем выполнить команду ping для имени экземпляра отказоустойчивого кластера и подождать, пока ему не будет присвоен новый IP-адрес службой DNS.

  8. В области справа щелкните правой кнопкой мыши SQL Server и выберите пункт Перевести в оперативный режим. Состояние SQL IP Address1 (имя экземпляра отказоустойчивого кластера), SQL Network Name (имя экземпляра отказоустойчивого кластера) и SQL Server изменится с «автономное» на «ожидание перехода в оперативное», затем на «оперативное».

  9. Закройте администратор кластеров.

См. также

Основные понятия

Как просмотреть файлы журналов установки SQL Server 2005


Как

Как |
 | См. также
Настройка высокого уровня доступности > Разделы руководства по конфигурированию доступности > Разделы руководства по отказоустойчивому кластеру >

После установки операционной системы и настройки кластера необходимо настроить координатор распределенных транзакций Майкрософт (MS DTC) в Microsoft Windows 2000 и Microsoft Windows Server 2003 для работы в кластере с помощью администратора кластера. Сбой кластера MS DTC не приведет к блокировке программы установки SQL Server 2005, но отсутствие правильной настройки координатора MS DTC может повлиять на функциональность приложения SQL Server 2005. Чтобы гарантировать доступность для множества кластеризованных приложений, настоятельно рекомендуется выделить программе настройки координатора распределенных транзакций Майкрософт отдельные группу ресурсов и ресурсы.

Ручная настройка координатора MS DTC в операционной системе Windows Server 2003 (с работающей службой MSCS)

  1. См. Настройка координатора распределенных транзакций Майкрософт в кластере Windows Server 2003.

См. также

Задачи

Как создать новый отказоустойчивый кластер SQL Server 2005 (установка)


Как включить службу планировщика задач Windows

Как включить службу планировщика задач Windows
Настройка высокого уровня доступности > Разделы руководства по конфигурированию доступности > Разделы руководства по отказоустойчивому кластеру >

Процедура, описанная в данном подразделе, предназначена для выхода из ситуации, когда программа установки SQL Server в кластере завершается по ошибке 1058 по причине того, что служба планировщика задач Windows на узлах кластера отключена. Если служба планировщика задач Windows отключена на узле кластера, ошибка в файле in_core.log будет выглядеть так:

Connection to remote computer's scheduler service.

Error: SetTargetComputer on \\machinename failed with

Unable to start service (1058)

Текст ошибки, отображаемый пользовательским интерфейсом Windows:

Служба не может быть запущена по причине того, что она отключена, либо из-за отсутствия связанных с ней устройств.

Решение этой проблемы заключается в том, что на всех узлах кластера перед запуском программы установки следует включить службу планировщика задач Windows.

Включение службы планировщика задач Windows

  1. В группе Windows "Администрирование" дважды щелкните Службы.

  2. В столбце Имя щелкните правой кнопкой Планировщик задач и выберите Запуск.

  3. Запустите программу установки SQL Server 2005 Setup для установки SQL Server.


Как включить проверку подлинности Kerberos в отказоустойчивом кластере сервера

Как включить проверку подлинности Kerberos в отказоустойчивом кластере сервера |
 | См. также
Настройка высокого уровня доступности > Разделы руководства по конфигурированию доступности > Разделы руководства по отказоустойчивому кластеру >

Kerberos - это сетевой протокол, позволяющий реализовать надежную проверку подлинности в клиентских и серверных приложениях. Он обеспечивает совместимость и в то же время повышает безопасность проверки подлинности в масштабе всей корпоративной сети.

Проверку подлинности Kerberos можно использовать с изолированными экземплярами Microsoft SQL Server 2005 и с экземплярами отказоустойчивого кластера, работающими под управлением ОС Microsoft Windows 2000 с пакетом обновления 3 (SP3). Поддержка этой функциональности обеспечивается в SQL Server 2005 при обычном развертывании домена Microsoft Windows 2000 Active Directory.

Если ресурс сетевого имени, от которого зависит SQL Server, относится к кластеру Windows 2000, можно использовать проверку подлинности Kerberos с этим ресурсом после установки пакета обновления 3 (SP3) для Windows 2000. Дополнительные сведения об активации проверки подлинности Kerberos в кластерах серверов см. в статье по поддержке Kerberos в Windows 2000, которую можно найти в базе знаний Майкрософт.

В следующем разделе описано, как подключиться к серверу, на котором работают службы IIS для установки соединения Kerberos с сервером, на котором выполняется SQL Server.

Предварительные требования

Использовать описываемую функциональность можно только при работе с ОС Windows 2000 с пакетом обновления 3 (SP3).

Перед установкой системы загрузите из Интернета программы Kerbtray и SetSPN.

  • Программу Kerbtray можно загрузить со следующего веб-узла Майкрософт. Используя программу Kerbtray.exe, можно с легкостью проверять и удалять билеты Kerberos с любых связанных компьютеров.

  • Программу SetSPN можно загрузить со следующего веб-узла Майкрософт.

SQL Server использует Kerberos лишь в том случае, если клиент использует для подключения к SQL Server протокол TCP/IP. Например, если клиент подключается с помощью протокола именованных каналов, Kerberos не используется. Если на компьютере установлено несколько экземпляров SQL Server, то для каждого из них необходимо настроить имя сервера-участника (Server Principal Name, SPN), поскольку каждый экземпляр SQL Server использует уникальный порт TCP/IP.

Включение Kerberos для SQL Server 2005

Подключение к серверу Microsoft Internet Information Services и установление соединения Kerberos с SQL Server 2005

  1. Шаг 1. Настройте контроллер домена

На контроллере домена в средстве «Active Directory — пользователи и компьютеры» выполните следующее:

  1. Щелкните правой кнопкой мыши компьютер, который нужно настроить для делегирования (сервер IIS), и выберите пункт «Этот компьютер доверенный для делегирования». Если компьютер, на котором выполняется SQL Server, является последним компьютером, с которым была установлена связь, но имеет связанный сервер, ему также должны быть предоставлены разрешения на делегирование. Если он не является последним компьютером в цепи, разрешения на делегирование должны быть предоставлены всем промежуточным компьютерам.

  2. Предоставьте разрешение на делегирование пользователю домена учетной записи службы SQL Server. При установке SQL Server в кластере необходима учетная запись пользователя домена (этот шаг не требуется, если компьютер выполняет SQL Server в контексте локальной системной учетной записи).

    1. В папке «Пользователи» щелкните правой кнопкой мыши учетную запись пользователя и выберите пункт Свойства.

    2. В диалоговом окне свойств учетной записи пользователя щелкните вкладку Учетная запись.

    3. В разделе Параметры учетной записи установите флажок Доверять учетной записи при делегировании. Убедитесь в том, что для данной учетной записи не установлен флажок Учетная запись конфиденциальна и не может быть делегирована.

  3. При помощи программы Kerbtray.exe проверьте билеты Kerberos, полученные от контроллера домена и узла:

    1. Щелкните правой кнопкой мыши значок Kerbtray в области уведомлений, затем выберите пункт очистить паспорта.

    2. Подождите, пока зеленый цвет значка Kerbtray сменится на желтый. Когда это произойдет, откройте окно командной строки и выполните следующую команду:

      net session* /d

      Это приведет к отмене существующих сеансов, созданию нового сеанса и получению билета Kerberos.

Шаг 2. Настройте сервер IIS

  1. Замените файлы веб-узла по умолчанию Wwwroot файлами-образцами ASP. Чтобы создавать файлы-образцы ASP, используйте код, приведенный в разделе Тестовый сценарий ASP для получения данных SQL Server.

  2. Добавьте файл в папку Wwwroot. С этой целью используйте образец кода, приведенный в подразделе Тестовый сценарий ASP для получения данных SQL Server. Сохраните файл с именем Default.asp.

  3. Сконфигурируйте веб-сервер так, чтобы он использовал только встроенную проверку подлинности Windows:

    1. Щелкните правой кнопкой мыши веб-сервер по умолчанию и выберите папку Безопасность.

    2. В папке Безопасность внесите корректные изменения, после чего снимите параметр анонимный доступ.

    3. Выполните в командной строке следующую команду:

      cscript C:\Inetpub\Adminscripts\adsutil.vbs get w3svc/NTAuthenticationProviders

      Если параметр Согласование задан, возвращается следующий результат:

      NTAuthenticationProviders : (STRING) Negotiate,NTLM

    Дополнительные сведения о том, как настроить сервер IIS, чтобы он поддерживал проверку подлинности Kerberos и NTLM, см. в статье Как настроить сервер IIS, чтобы он поддерживал проверку подлинности Kerberos и NTLM, которую можно найти в базе знаний Майкрософт.

Примечание.
На сервере IIS необходимо установить систему компонентов доступа к данным Microsoft (MDAC) 2.8 с пакетом обновления 1 (SP1) или более поздней версии. Чтобы сделать это (и получить возможность использовать соответствующие инструменты для тестирования), установите на веб-сервере клиентские средства Microsoft SQL Server 2000. Сведения о том, как установить только MDAC 2.8 с пакетом обновления 1 (SP1) или более поздней версии без клиентских средств, можно найти на следующем веб-узле корпорации Microsoft.

  1. Убедитесь в том, что в реестре существует значение HKLM\SW\MS\MSSQLSERVER\Client\DSQUERY. Если этого значения нет, добавьте его в реестр в форме DSQUERY:Reg_SZ:DBNETLIB.

  2. При помощи программы Kerbtray.exe проверьте билеты Kerberos, полученные от контроллера домена и узла:

    1. Щелкните правой кнопкой мыши значок Kerbtray в области уведомлений, затем выберите пункт очистить паспорта.

    2. Подождите, пока зеленый цвет значка Kerbtray сменится на желтый. Когда это произойдет, откройте окно командной строки и выполните следующую команду:

      net session * /d

      Это приведет к отмене существующих сеансов, созданию нового сеанса и получению билета Kerberos.

Шаг 3. Создайте имя участника сервера для SQL Server

Внимание!
SQL Server использует Kerberos лишь в том случае, если клиент использует для подключения к SQL Server протокол TCP/IP. Например, если клиент подключается с помощью протокола именованных каналов, Kerberos не используется. Если на компьютере установлено несколько экземпляров SQL Server, то для каждого из них необходимо настроить имя сервера-участника (Server Principal Name, SPN), поскольку каждый экземпляр SQL Server использует уникальный порт TCP/IP.

Важно!
Если служба SQL Server выполняется в контексте учетной записи LocalSystem, конфигурировать SPN для SQL Server вручную не требуется. Имя SPN создается автоматически при запуске службы SQL Server. Если служба SQL Server выполняется в контексте учетной записи пользователя домена, настроить SPN нужно вручную. Выполните для этого действия, описанные ниже.

Чтобы настроить SPN для SQL Server, используйте программу SETSPN из пакета ресурсов Microsoft Windows Resource Kit. Программу SETSPN можно загрузить со следующего веб-узла корпорации Майкрософт.

Перед запуском программы SETSPN учтите следующее:

  • Выполнять программу setspn.exe нужно в контексте учетной записи входа, имеющей разрешения на регистрацию SPN.

  • Обратите внимание на учетную запись пользователя домена, в контексте которой выполняется экземпляр SQL Server. В следующих примерах эта учетная запись называется <SQL_Service_Account>.

    Внимание! Если экземпляр SQL Server выполняется в контексте учетной записи LocalSystem, запускать программу SETSPN не нужно.

  • Нужно знать полностью определенное имя домена (FQDN) компьютера, на котором выполняется SQL Server. Чтобы определить это имя, используйте программу ping. Для этого выполните действия, описанные ниже.

  1. Определите при помощи программы ping IP-адрес компьютера, на котором выполняется SQL Server:

    C:\>ping MySQLServer

    Pinging MySQLServer.MyDomain.com [10.10.10.10] with 32 bytes of data:

    Reply from 10.10.10.10: bytes=32 time=1ms TTL=128

  2. Выполните команду ping -a для обратного уточняющего запроса IP-адреса, чтобы убедиться, что протокол DNS возвращает корректное имя FQDN:

    C:\>ping -a 10.10.10.10

    Pinging MySQLServer.MyDomain.com [10.10.10.10] with 32 bytes of data:

    Reply from 10.10.10.10: bytes=32 time<1ms TTL=128

  3. Выполните команду ping, указав имя экземпляра отказоустойчивого кластера для получения его IP-адреса, после чего выполните команду ping -a , чтобы убедиться, что протокол DNS возвращает правильное имя FQDN.

Примечание.
При работе с отказоустойчивым кластером SQL Server, используйте полностью определенное имя домена экземпляра отказоустойчивого кластера. Обратите внимание на порт TCP/IP, используемый экземпляром SQL Server. Чтобы получить эти сведения, запустите на компьютере, выполняющем SQL Server, диспетчер конфигурации SQL Server, щелкните экземпляр SQL Server и просмотрите свойства протокола TCP/IP (порт по умолчанию).

Определив учетную запись пользователя домена, в контексте которой выполняется служба SQL Server, и порт TCP/IP, используемый экземпляром SQL Server, выполните следующие действия, чтобы создать SPN для SQL Server.

Примечание.
Выполнять команду SETSPN могут только члены группы администраторов домена.

  1. Если имеется дело с отказоустойчивым кластером SQL Server, выполните следующую команду SETSPN:

    setspn -A MSSQLSvc/<FQDN> <SQL_Service_Account>

    Например, если кластеризованный экземпляр SQL Server 2005 с именем MySQLServer.MyDomain.com выполняется в контексте учетной записи пользователя домена SQLSVC, введите следующую команду:

    setspn -A MSSQLSvc/MySQLServer.MyDomain.com SQLSVC

  2. И для кластеризованных, и для некластеризованных компьютеров, на которых работает SQL Server, выполните следующую команду SETSPN, чтобы зарегистрировать имя SPN для порта, используемого компьютером, на котором выполняется SQL Server:

    setspn -A MSSQLSvc/<FQDN>:<Port> <SQL_Service_Account>

    Например, если экземпляр MySQLServer.MyDomain.com выполняется в контексте учетной записи пользователя домена SQLSVC и ассоциирован с портом 1433, введите следующую команду SETSPN:

    setspn -A MSSQLSvc/MySQLServer.MyDomain.com:1433 SQLSVC

  3. После регистрации имени SPN убедитесь в том, что оно зарегистрировано правильно, при помощи функции LIST (параметр -L) программы SETSPN. Выполните команду SETSPN -L <SQL_Service_Account> с целью получения всех имен SPN, зарегистрированных для учетной записи пользователя домена, в контексте которой работает экземпляр SQL Server:

    setspn -L <SQL_Service_Account>

    Например, если экземпляр MySQLServer.MyDomain.com выполняется в контексте учетной записи пользователя домена SQLSVC и использует порт 1433, введите следующую команду:

    setspn -A SQLSVC

    Имя SPN, созданное на шаге 1 (если SQL Server кластеризован) и 2 (если SQL Server не кластеризован), показано ниже:

    C:\>setspn -l SQLSVC

    Registered ServicePrincipalNames for CN=SQLSVC,CN=Users,DC=MyDomain,DC=com:

        MSSQLSvc/MySQLServer.MyDomain.com

        MSSQLSvc/MySQLServer.MyDomain.com:1433

Примечание.
Если используется отказоустойчивый кластер SQL Server, необходимо зарегистрировать одно имя SPN без номера порта и еще одно с номером порта. Если SQL Server выполняется на типичном некластеризованном компьютере, нужно зарегистрировать только SPN с номером порта. Однако если дополнительное имя SPN без имени порта будет зарегистрировано, никаких проблем с некластеризованными компьютерами не возникнет.

Примечание.
Кроме того, для проверки обоих зарегистрированных имен SPN можно использовать программу Ldifde.exe на контроллере домена. Этот подход описан в подразделе "Как собрать данные об именах серверов-участников Active Directory".

Шаг 4. Настройте клиентские компьютеры

  1. Убедитесь, что на каждом клиентском компьютере, который будет подключаться к серверу, Microsoft Internet Explorer настроен для использования проверки подлинности Windows.

  2. Запустите Internet Explorer и выберите в меню Сервис пункт Свойства обозревателя.

  3. Выберите вкладку Дополнительно.

    В категории Безопасность установите флажок Включить интегрированную проверку подлинности Windows (требуется перезапуск) и нажмите кнопку ОК.

Шаг 5. Протестируйте конфигурацию

Выполните на каждом задействованном компьютере следующие действия.

  1. Войдите в систему и выполните программу Kerbtray.exe для проверки того, что компьютер может получить от контроллера домена корректный билет Kerberos.

  2. Удалите при помощи программы Kerbtray.exe на компьютере все билеты.

  3. Создайте веб-страницу, возвращающую данные SQL Server, и подключитесь к ней.

Примечание.
Замените значение SQLSERVERNAME именем компьютера, на котором выполняется SQL Server.

  • Если данные возвращаются, то эта страница отображает тип проверки подлинности Согласование и данные SQL Server, сформированные в результате выполнения хранимой процедуры sp_helpdb, которая должна возвратить список баз данных на сервере, к которому клиент подключается через страницу ASP.

  • Если в экземпляре SQL Server активирован аудит, в журнале приложений соединение будет указано как надежное.

Тестовый сценарий ASP для получения данных SQL Server

Ниже приведен код тестового сценария ASP, служащего для получения данных SQL Server. Используя этот образец кода, не забудьте заменить значение SQLSERVERNAME именем компьютера, на котором выполняется SQL Server.

<%@ Language=VBScript %>

<HTML>

<HEAD>

<META NAME="GENERATOR" Content="Microsoft Visual Studio 6.0">

</HEAD>

<BODY>

<%="'auth_user' is" & request.servervariables("auth_user")%>

<P>

<%="'auth_type' is" & request.servervariables("auth_type")%>

<P>

Connections string is <B>" Provider=SQLOLEDB.1;Integrated Security=SSPI;Persist Security Info=False;Initial Catalog=pubs;Data Source=SQLSERVERNAME </B>

<P>

<%

set rs = Server.CreateObject("ADODB.Recordset")

set cn = Server.CreateObject("ADODB.Connection")

cn.Open "Provider=SQLOLEDB.1;Integrated Security=SSPI;Persist Security Info=False;Initial Catalog=pubs;Data Source=SQLSERVERNAME"

rs.open "MASTER..sp_helpdb",cn

Response.Write cstr(rs.Fields.Count) +"<BR>"

while not rs.EOF

Response.Write cstr(rs(0))+"<BR>"

rs.MoveNext

wend

rs.Close

cn.Close

set rs = nothing ' Frees memory reserved by the recordset.

set cn = nothing ' Frees memory reserved by the connection.

%>

</BODY>

</HTML>

Сбор данных об именах серверов-участников Active Directory

Чтобы получить список имен серверов-участников Active Directory, выполните на одном из контроллеров домена следующую команду, где betaland - имя домена NetBIOS, а NewoutputUsers.txt - имя выходного файла, которым можно воспользоваться для переноса результатов. Если не используется полный путь, файл помещается в папку, в которой была выполнена команда. Следующая команда опрашивает весь домен:

Копировать код
ldifde -d "CN=Users,DC=betaland" -l servicePrincipalName -F NewoutputUsers.txt

Эта команда создает файл NewoutputUsers.txt с данными, похожими на вывод, приведенный в подразделе "Данные уровня домена, выводимые в файл NewouputUsers.txt".

Если собрать эти данные для всего домена, их объем может оказаться слишком большим. Чтобы ограничить объем собираемых данных конкретным именем пользователя, выполните следующую команду, где User Name - имя пользователя, а betaland - домен, который запрошен:

Копировать код
ldifde -d "CN=User Name,DC=betaland" -l servicePrincipalName -F NewoutputUsers.txt

Сбор сведений о конкретном пользователе позволяет значительно сократить объем данных, в которых придется искать нужные сведения. Если данные собираются в масштабе всего домена, то нужно конкретное имя пользователя на соответствующем сервере. В образце выхода можно увидеть следующее:

  • Записи серверов, которые уже не существуют, но не были полностью удалены из системы Active Directory.

  • Запись пользователя "User Name", который владеет корректными сведениями об именах SPN примерно на десяти разных серверах.

Для исправления некорректных записей Active Directory можно использовать инструмент интерфейсов ADSI.

Внимание Если, используя оснастку ADSI Edit, программу LDP или какое-либо другое клиентское приложение LDAP версии 3, некорректно изменить атрибуты объектов Active Directory, это может привести к серьезным проблемам. Эти проблемы могут потребовать переустановки Microsoft Windows 2000 Server, Microsoft Exchange 2000 Server или обеих систем. Корпорация Майкрософт не гарантирует, что проблемы, возникшие в результате некорректного изменения атрибутов объектов Active Directory, удастся решить. Пользователь несет полную ответственность за последствия, вызванные изменением этих атрибутов.

Сведения уровня домена, выводимая в файл NewouputUsers.txt:

dn: CN=User Name,CN=Users,DC=betaland

changetype: add

servicePrincipalName: MSSQLSvc/CLUSTERDEFAULT.betaland:1257

servicePrincipalName: MSSQLSvc/INST3.betaland:3616

servicePrincipalName: MSSQLSvc/INST2.betaland:3490

servicePrincipalName: MSSQLSvc/SQLMAN.betaland:1433

servicePrincipalName: MSSQLSvc/VSS1.betaland:1433

servicePrincipalName: MSSQLSvc/INST1.betaland:2536

servicePrincipalName: MSSQLSvc/INST4.betaland:3967

servicePrincipalName: MSSQLSvc/SQLVIRTUAL1.betaland:1434

servicePrincipalName: MSSQLSvc/SQLVIRTUAL.betaland:1433

servicePrincipalName: MSSQLSvc/SQLBUSTER.betaland:1315

См. также

Основные понятия

Установка SQL Server 2005

Другие ресурсы

Разделы руководства по конфигурированию доступности
Обновление до SQL Server 2005


Как произвести обновление до отказоустойчивого кластера SQL Server 2005 (установка)

Как произвести обновление до отказоустойчивого кластера SQL Server 2005 (установка) |
 | См. также
Настройка высокого уровня доступности > Разделы руководства по конфигурированию доступности > Разделы руководства по отказоустойчивому кластеру >

Дата обновления: 5 декабря 2005 г.

Можно установить Microsoft SQL Server 2005 или обновить предыдущую версию SQL Server до SQL Server 2005, используя мастер установки SQL Server 2005.

Дополнительные сведения об обновлении см. в разделах Обновления версий и выпусков и Обновление до SQL Server 2005.

Дополнительные сведения об установке изолированного экземпляра SQL Server 2005 см. в разделе Как установить SQL Server 2005 (программа установки).

Предварительные требования

Перед установкой ознакомьтесь со следующими важными сведениями.

  • Подготовка к установке SQL Server 2005

  • Подготовка к установке отказоустойчивого кластера

  • Обратитесь к разделу Использование помощника по обновлению для подготовки к обновлениям.

  • Обновление компонента Database Engine

  • Очень важно точно выполнять инструкции, приведенные в следующей статье на веб-узле Майкрософт.

  • Для локальных установок программу установки SQL Server нужно запускать с правами администратора. При установке SQL Server из удаленной общей папки необходимо использовать учетную запись домена, имеющую разрешения на чтение и выполнение для удаленной общей папки.

  • Для обновления экземпляра SQL Server до отказоустойчивого кластера SQL Server 2005 обновляемый экземпляр должен быть отказоустойчивым кластером. Чтобы обновить изолированный экземпляр SQL Server до отказоустойчивого кластера SQL Server 2005, установите новый отказоустойчивый кластер SQL Server 2005, а затем перенесите пользовательские базы данных из изолированного экземпляра при помощи мастера копирования баз данных. Дополнительные сведения о миграции баз данных см. в разделе Использование мастера копирования баз данных.

Обновление до отказоустойчивого кластера SQL Server 2005

  1. Вставьте установочный DVD-диск SQL Server 2005 в дисковод. Если мастер установки SQL Server не запускается автоматически, дважды щелкните файл Splash.hta в корневом каталоге этого DVD.

    При установке из сети откройте общий доступ к файлам установки и подключитесь к их расположению с компьютера, на который необходимо установить SQL Server.

  2. Чтобы начать процесс установки, щелкните Установить SQL Server.

  3. На странице Лицензионное соглашение прочтите лицензионное соглашение, а затем установите флажок, подтверждая принятие условий соглашения. После принятия лицензионного соглашения станет доступна кнопка Далее. Чтобы продолжить, нажмите кнопку Далее. Чтобы выйти из программы установки, нажмите кнопку Отмена.

  4. Запустится программа обновления компонентов SQL Server, которая устанавливает программы, требуемые для установки SQL Server. Чтобы получить дополнительные сведения о требованиях компонентов, нажмите кнопку Справка в нижней части страницы. Чтобы продолжить работу после завершения обновления, нажмите кнопку Далее.

  5. Чтобы продолжить, нажмите кнопку Далее на странице Приветствие мастера установки SQL Server.

  6. На странице Проверка конфигурации системы (SCC) производится проверка компьютера на наличие условий, которые могут помешать установке. Дополнительные сведения о проверяемых параметрах конфигурации см. в разделе Проверка конфигурации системы (SCC).

    Чтобы прервать просмотр, нажмите кнопку Остановить. Чтобы продолжить установку после завершения проверки, нажмите кнопку Далее.
Примечание.
Если проверка выявила какие-либо ошибки, определите их тип и нажмите кнопку Выход. Невозможно завершить установку, пока блокирующие ее ошибки не будут устранены. Дополнительные сведения см. в разделе Параметры для средства проверки конфигурации системы.

  1. На странице Установка Microsoft SQL Server мастер установки SQL Server производит подготовку к установке программного обеспечения. По окончании процесса подготовки мастер продолжит установку.

  2. На странице Регистрационные сведения введите данные в текстовые поля Имя и Организация. Чтобы продолжить, нажмите кнопку Далее.

  3. На странице Компоненты для установки выберите компоненты для установки.

    При выборе группы компонентов ее описание отображается в области Компоненты, которые необходимо установить. Можно установить любое сочетание компонентов, используя флажки. Если при выборе SQL Server или служб Analysis Services программа установки определила, что производится установка на отказоустойчивый кластер SQL Server, то станут доступны флажки Создать отказоустойчивый кластер SQL Server или Создать отказоустойчивый кластер сервера анализа данных. Этот флажок необходимо установить для установки отказоустойчивого кластера. Если на другой сервер уже установлены инструменты администрирования и желательно сократить время установки, то можно не устанавливать данные инструменты во время начальной установки, а настроить новый сервер дистанционно, запустив программу установки SQL Server второй раз для установки инструментов администрирования.

    Чтобы установить индивидуальные компоненты или выбрать место установки файлов, нажмите кнопку Дополнительно. В противном случае выберите нужные компоненты, затем нажмите кнопку Далее.

  4. Если на предыдущей странице была нажата кнопка Дополнительно, отобразится страница Выбор компонентов. На странице Выбор компонентов с помощью раскрывающихся списков выберите компоненты программы для установки. Чтобы установить компоненты в определенный каталог, выберите компонент и нажмите кнопку Обзор. Дополнительные сведения о возможностях этой страницы см. в разделе Выбор компонентов. Если выбор компонентов завершен, нажмите кнопку Далее, чтобы продолжить.

  5. На странице Имя экземпляра выберите для установки экземпляр по умолчанию или именованный экземпляр. Если именованный экземпляр или экземпляр по умолчанию уже установлен и для установки выбран существующий экземпляр, то программа установки обновляет его и предоставляет возможность установки дополнительных компонентов.

    Чтобы установить новый экземпляр по умолчанию, на компьютере не должен быть установлен экземпляр по умолчанию.

    Для установки нового именованного экземпляра выберите Именованный экземпляр и введите уникальное имя экземпляра в соответствующем поле. Дополнительные сведения о правилах именования экземпляров см. в разделе Имя экземпляра.

  6. На странице Имя виртуального SQL Server введите уникальное имя устанавливаемого экземпляра. Это имя будет использоваться для идентификации отказоустойчивого кластера в сети. Имя экземпляра отказоустойчивого кластера SQL Server должно быть уникальным в сети и отличаться от имен ведущего кластера и узлов кластера. Чтобы продолжить, нажмите кнопку Далее.

Важно!
В качестве имени экземпляра нельзя использовать имена DEFAULT и MSSQLSERVER. Имена должны соответствовать правилам для идентификаторов SQL Server. Дополнительные сведения о правилах именования экземпляров см. в разделе Имя экземпляра.

Примечание.
Страница Имя виртуального SQL Server отображается только в том случае, если программа установки определит, что на компьютере запущена служба MSCS. Если страница Имя виртуального SQL Server не отображается, отмените установку и настройте службу MSCS. Подробную справку по этой странице см. в разделе Имя виртуального сервера.

  1. На странице Существующие компоненты выберите компонент, который необходимо обновить, затем щелкните Подробности для просмотра отчета, проверяющего возможность обновления данного компонента. Если отчет о параметрах установки свидетельствует о том, что обновление компонента возможно, нажмите кнопку Закрыть для возвращения к странице Существующие компоненты, а затем нажмите кнопку Далее для продолжения процесса установки.

  2. На странице Служебные учетные записи (кластеры) укажите имя пользователя, пароль и имя домена для служебных учетных записей SQL Server. Можно использовать одну учетную запись для всех служб. Все учетные записи служб для экземпляра отказоустойчивого кластера SQL Server должны являться учетными записями домена. Установите флажок Настроить для каждой учетной записи службы, чтобы указать параметры Имя пользователя, Пароль и Домен для отдельных служб, выбирая службы списка Служба. Учетная запись службы агента SQL Server должна являться администратором для узла кластера. Не используйте ту учетную запись, которая была назначена службе кластеров.

    При необходимости можно определить отдельную учетную запись для каждой службы. Чтобы указать индивидуальную учетную запись для каждой службы, выберите вариант Настроить для каждой учетной записи службы, выберите имя службы из раскрывающегося списка и укажите учетные данные входа. Чтобы продолжить, нажмите кнопку Далее. Дополнительные сведения см. в разделе Учетные записи служб (кластеры).

Примечание.
Имя домена не может быть полным DNS-именем. Например, если используется DNS-имя my-domain-name.com, введите my-domain-name в поле Домен. SQL Server не поддерживает имена вида my-domain-name.com в поле Домен.

  1. Страница Обновить сведения о входе в систему предназначена для указания учетных данных входа для доступа к обновляемому экземпляру SQL Server; во время обновления мастер установки SQL Server 2005 должен подключиться к существующему экземпляру SQL Server. Чтобы продолжить, нажмите кнопку Далее.

  2. На странице Параметры отчетов об ошибках и использовании при необходимости снимите флажок, чтобы отключить создание отчетов об ошибках или использовании функций. Чтобы продолжить, нажмите кнопку Далее. Дополнительные сведения см. в разделе Параметры отчетов об ошибках и использовании.

  3. На странице Все готово для установки проверьте сводный список функций и компонентов для установки SQL Server. Чтобы продолжить, нажмите кнопку Установить.

  4. На странице Завершение работы мастера установки Microsoft SQL Server можно просмотреть сводный журнал установки, щелкнув находящуюся на ней ссылку. Для выхода из мастера установки SQL Server нажмите кнопку Готово.

  5. Если получено указание о перезагрузке компьютера, выполните его. После завершения установки важно прочитать сообщение программы установки. Сбой при перезапуске любого из указанных узлов может привести к ошибкам при последующих запусках программы установки.

Следующие шаги

  • Настройте установленную копию SQL Server Чтобы уменьшить уязвимую контактную зону системы, SQL Server 2005 выборочно устанавливает и активирует ключевые службы и функции. Дополнительные сведения о том, как активировать функции SQL Server 2005, см. в разделе Настройка контактной зоны SQL Server.

Дополнительные сведения о размещении журналов см. в разделе Как просмотреть файлы журналов установки SQL Server 2005.

Сведения о проверке установленной копии SQL Server см. в разделе Как проверить успешность установки служб SQL Server 2005.

См. также

Задачи

Как установить SQL Server 2005 из командной строки


Как переименовать виртуальный сервер SQL Server 2005

Как переименовать виртуальный сервер SQL Server 2005 |
 | См. также
Настройка высокого уровня доступности > Разделы руководства по конфигурированию доступности > Разделы руководства по отказоустойчивому кластеру >

Если экземпляр SQL Server является частью отказоустойчивого кластера, процесс переименования виртуального сервера отличается от процесса переименования изолированного экземпляра. Сведения о переименовании изолированного экземпляра SQL Server 2005 см. в разделе Как переименовать компьютер, на который установлен изолированный экземпляр SQL Server 2005.

Имя виртуального сервера всегда совпадает с сетевым именем SQL-сервера (сетевое имя виртуального SQL-сервера). Несмотря на то, что имя виртуального сервера можно изменить, изменить имя экземпляра нельзя. Например, можно изменить имя виртуального сервера VS1\экземпляр1 на другое имя, например SQL35\экземпляр1, но часть имени, содержащая имя экземпляра (т.е. экземпляр1) останется неизменной.

Важные предварительные сведения

Прежде чем приступить к процессу переименования, ознакомьтесь со следующими сведениями.

  • SQL Server не поддерживает переименование серверов, участвующих в репликации, за исключением случаев использования доставки журналов с помощью репликации. Сервер-получатель в доставке журналов может быть переименован, если сервер-источник окончательно потерян. Дополнительные сведения см. в разделе Replication and Log Shipping.

  • При переименовании виртуального сервера, настроенного для использования зеркального отображения базы данных, прежде чем приступить к переименованию, необходимо отключить зеркальное отображение базы данных, а затем заново установить зеркальное отображение базы данных с новым именем виртуального сервера. Метаданные для зеркального отображения базы данных не будут обновлены автоматически для отражения нового имени виртуального сервера.

Важно!
Техническая поддержка Майкрософт не распространяется на технологию зеркального отображения баз данных в SQL Server 2005. В настоящее время технология зеркального отображения баз данных по умолчанию отключена, но ее можно включить для использования в целях оценки. Для этого необходимо указать флаг трассировки 1400 в качестве параметра запуска. (Дополнительные сведения о флагах трассировки см. в разделе Флаги трассировки (Transact-SQL) .) Зеркальное отображение баз данных не следует использовать в рабочих средах. Служба технической поддержки Майкрософт не поддерживает базы данных и приложения, в которых используется эта технология. Документация по зеркальному отображению баз данных включена в SQL Server 2005 только в целях оценки. На нее не распространяется политика по документации, действующая при поддержке и обновлении SQL Server 2005.

Переименование виртуального сервера

  1. С помощью администратора кластера измените сетевое имя SQL Server.

  2. Переведите ресурс с этим сетевым именем в автономный режим. При этом ресурсы SQL Server и другие зависимые ресурсы переводятся в автономный режим.

  3. Переведите ресурсы SQL Server обратно в оперативный режим.

Проверка операции переименования

После того как виртуальный сервер переименован, любые соединения, использовавшие старое имя, должны осуществляться с использованием нового имени.

Чтобы убедиться в том, что операция переименования завершена, выберите необходимые данные с помощью функции @@servername или таблицы sys.servers. Функция @@servername возвращает новое имя виртуального сервера, а таблица sys.servers отображает новое имя виртуального сервера. Чтобы проверить правильность перехода на другой ресурс с новым именем, попытайтесь создать сбойную ситуацию на ресурсе SQL Server через другие узлы.

Для установления соединения с любого узла, расположенного в том же кластере, новое имя можно использовать немедленно. Однако для соединений с другого компьютера, использующих новое имя, новое имя не может быть использовано для подключения к серверу до тех пор, пока оно не будет видимо с этого клиентского компьютера. До того момента, как новое имя станет видимо во всей сети, может пройти от нескольких секунд до 3-5 минут (в зависимости от конфигурации сети). Кроме того, может потребоваться дополнительное время на то, чтобы старое имя виртуального сервера перестало быть видимо в сети.

Для минимизации задержки сетевого распространения операции переименования виртуального сервера выполните следующие шаги:

Минимизация задержки сетевого распространения

  1. Выполните следующие команды в командной строке на узле сервера:

    Копировать код
    ipconfig /flushdns
ipconfig /registerdns
nbtstat -RR

См. также

Задачи

Как переименовать компьютер, на который установлен изолированный экземпляр SQL Server 2005


Как добавить зависимости к ресурсу SQL Server 2005

Как добавить зависимости к ресурсу SQL Server 2005 |
 | См. также
Настройка высокого уровня доступности > Разделы руководства по конфигурированию доступности > Разделы руководства по отказоустойчивому кластеру >

Если устанавливается в кластерной группе Windows 2000 с несколькими жесткими дисками и при этом для хранения данных выбирается только один жесткий диск, то ресурсы SQL Server будут настроены на использование только указанного диска. Чтобы разместить данные или журналы на других дисках, необходимо добавить для них зависимости к ресурсу SQL Server.

При добавлении любых ресурсов к группе SQL Server важно не забывать о том, что добавляемый ресурс должен иметь уникальное сетевое имя и IP-адрес.

Не используйте задействованные в SQL Server сетевые имена и IP-адреса в других приложениях. При совместном использовании ресурсов SQL Server другими программами могут возникнуть следующие проблемы:

  • Возникновение неожиданных перебоев в работе.

  • Неудачная установка пакетов обновлений.

  • Неправильная работа программы установки SQL Server. При возникновении этой проблемы становится невозможным устанавливать дополнительные экземпляры SQL Server или выполнять обслуживание подпрограмм.

Рассмотрим эти дополнительные проблемы:

  • Протокол FTP и репликация SQL Server: При работе с экземплярами SQL Server, использующими протокол FTP в репликации SQL Server, служба FTP должна задействовать один из физических дисков, размещающих экземпляр SQL Server, использующий службу FTP.

  • Зависимости ресурсов SQL Server: Для уверенности в доступности SQL Server при добавлении в его группу ресурса рекомендуется кроме зависимости ресурса SQL Server также добавить зависимость на ресурс агента SQL Server. Не добавляйте зависимость на ресурс SQL Server. Для уверенности в доступности компьютера, на котором выполняется SQL Server, необходимо настроить ресурс агента SQL Server таким образом, чтобы при его сбое группа SQL Server не затрагивалась.

  • Совместное использование файлов и принтеров: При добавлении ресурсов общих папок или кластера печати не следует размещать их на физических дисках, используемых компьютером, на котором выполняется SQL Server. При размещении данных ресурсов на указанных жестких дисках может наблюдаться снижение производительности и возможностей компьютера, на котором выполняется SQL Server.

  • Замечания о координаторе MS DTC: После установки операционной системы и настройки кластера необходимо с помощью администратора кластера настроить координатор MS DTC для работы в кластере. Сбой кластера MS DTC не приведет к блокировке программы установки SQL Server 2005, но отсутствие правильной настройки координатора MS DTC может повлиять на функциональность приложения SQL Server 2005.

    Если координатор распределенных транзакций Microsoft (MS DTC) устанавливается в группе SQL Server, в которой содержатся другие ресурсы, зависящие от MS DTC, он будет недоступен в автономном режиме и режиме перехода на другой ресурс. По умолчанию при запуске мастера перехода на другой ресурс SQL Server в новой установке в SQL Server требуется, чтобы ресурс координатора MS DTC размещался в группе SQL Server. В случае, когда координатор MS DTC был кластеризован заранее, в SQL Server 7.0, в отличие от SQL Server 2000, используются уже существующие расположения и ресурсы. Рекомендуется размещать координатор MS DTC в отдельной группе на отдельном жестком диске.

Добавление зависимости на ресурс SQL Server 2005

  1. Откройте оснастку "Администратор кластера" из состава средств администрирования Windows.

  2. Выделите группу, содержащую ресурс SQL Server, который необходимо сделать зависимым.

  3. Если ресурс, соответствующий диску, в группе уже существует, перейдите к шагу 4. В противном случае, выберите группу, содержащую данный диск. Если данная группа не принадлежит к тому же узлу, что и группа, содержащая SQL Server, то ее необходимо переместить в указанный узел.

  4. Переведите ресурс SQL Server в автономный режим.

  5. Выберите ресурс SQL Server, откройте диалоговое окно Свойства и на вкладке Зависимости добавьте ссылку на диск в список зависимостей SQL Server.

См. также

Задачи

Как просмотреть файл журнала установки SQL Server 2005

Основные понятия

Подготовка к установке отказоустойчивого кластера
Как просмотреть файлы журналов установки SQL Server 2005


Как

Как |
 | См. также
Настройка высокого уровня доступности > Разделы руководства по конфигурированию доступности > Разделы руководства по отказоустойчивому кластеру >

Дата обновления: 5 декабря 2005 г.

Выполните следующую процедуру для удаления экземпляра отказоустойчивого кластера .

Важно!
Чтобы обновить или удалить экземпляр отказоустойчивого кластера SQL Server, необходимо иметь разрешения локального администратора для входа в систему в качестве службы на все узлы отказоустойчивого кластера.

Перед удалением отказоустойчивого кластера

Учтите следующие важные моменты перед удалением отказоустойчивого кластера SQL Server 2005.

  • Если на компьютере запущен SQL Server 2005 вместе с предыдущими версиями SQL Server, то программа Enterprise Manager и другие программы, зависящие от объектов SQL-DMO, могут быть отключены. Это может произойти в следующих ситуациях.

    • Параллельная установка SQL Server 2005, SQL Server 2000 или SQL Server 7.0, при которой одна из версий была удалена.

    • Параллельная установка SQL Server 2000 с SQL Server 2005, при которой SQL Server 2000 был установлен после SQL Server 2005.

    Эта проблема связана с удалением регистрации COM-библиотеки SQL Server 2005 SQL-DMO. Чтобы восстановить работоспособность программы SQL Server 2000 Enterprise Manager и других программ, зависящих от библиотеки SQL-DMO, зарегистрируйте библиотеку, выполнив команду "regsvr32.exe sqldmo.dll" из командной строки.

  • Если SQL Server 2000 и SQL Server 2005 были параллельно установлены в кластеризованной среде, при удалении SQL Server 2005 нет необходимости удалять собственный клиент Microsoft SQL. Динамическая библиотека ресурсов SQL Server из SQL Server 2005 всегда использует собственный клиент SQL для подключения к SQL Server. При установке SQL Server 2005 динамическая библиотека ресурсов SQL Server обновляется. При удалении SQL Server 2005 динамическая библиотека ресурсов SQL Server не заменяется версией, требуемой SQL Server 2000. Сохранение собственного клиента SQL в узлах кластера позволяет динамической библиотеке ресурсов SQL Server и далее подключаться к экземплярам SQL Server 2000.

  • Если собственный клиент SQL случайно удален, ресурсы SQL Server не смогут запуститься. Чтобы переустановить собственный клиент SQL, запустите программу установки SQL Server 2005 и установите предварительно необходимые компоненты SQL Server 2005.

  • При удалении отказоустойчивого кластера, обладающего более чем одним кластерным ресурсом SQL IP, необходимо удалить дополнительные ресурсы SQL IP при помощи администратора кластера.

Дополнительные сведения о синтаксисе командной строки см. в разделе Как установить SQL Server 2005 из командной строки.

Удаление отказоустойчивого кластера SQL Server 2005

  1. Чтобы начать процесс удаления, запустите приложение Установка и удаление программ из панели управления.

  2. Выберите компонент SQL Server 2005, который необходимо удалить, а затем щелкните Удалить. Таким образом запустится мастер установки SQL Server 2005.

  3. На странице Выбор компонентов выберите пункт Удалить экземпляры компонентов SQL Server 2005, а затем щелкните имя экземпляра и общие компоненты, чтобы удалить их. Чтобы продолжить, нажмите кнопку Далее.

  4. На странице Данные удаленного имени входа введите пароль учетной записи администратора для всех узлов кластеризованного экземпляра. Чтобы продолжить, нажмите кнопку Далее.

  5. На странице Подтверждение проверьте выбранные компоненты SQL Server, которые будут удалены. Чтобы продолжить процесс удаления, нажмите кнопку Готово.

  6. Мастер установки SQL Server удалит компоненты SQL Server 2005 с компьютера. Если программе установки потребуется доступ к установочному диску SQL Server 2005, она попросит вставить компакт-диск или DVD-диск в дисковод. На компакт- или DVD-диске, использующемся для удаления SQL Server, номер сборки SQL Server должен совпадать с номером сборки удаляемого экземпляра. Для сетевой установки программа установки должна иметь доступ к сетевой папке.

  7. Средство проверки конфигурации SQL Server проверит текущую конфигурацию компьютера. На странице Приветствие нажмите кнопку Далее. После того как средство проверки конфигурации системы завершит просмотр ресурсов, нажмите кнопку Далее, чтобы продолжить.

  8. На странице Ход установки отображается состояние процесса удаления SQL Server 2005 с компьютера. На странице Завершение работы мастера установки Microsoft SQL Server можно просмотреть сводный журнал установки, щелкнув ссылку, представленную на этой странице. Чтобы завершить работу мастера установки SQL Server, нажмите кнопку Готово.
Примечание.
Не пытайтесь удалить компоненты MSXML и SQLXML; они будут удалены автоматически при удалении зависящих от них компонентов.

См. также

Задачи

Как просмотреть файл журнала установки SQL Server 2005
Как

Основные понятия

Как просмотреть файлы журналов установки SQL Server 2005


Как

Как |
 | См. также
Настройка высокого уровня доступности > Разделы руководства по конфигурированию доступности > Разделы руководства по отказоустойчивому кластеру >

Учтите следующие важные моменты перед удалением отказоустойчивого кластера .

  • Если на компьютере запущен SQL Server 2005 вместе с предыдущими версиями SQL Server, то программа Enterprise Manager и другие программы, работающие с объектами SQL-DMO, могут быть отключены. Это может произойти в следующих ситуациях.

    • Параллельная установка SQL Server 2005, SQL Server 2000 и SQL Server 7.0, после которой одна из версий была удалена.

    • Параллельная установка SQL Server 2000 и SQL Server 2005, при которой SQL Server 2000 был установлен после SQL Server 2005.

    Причина этого заключается в том, что происходит отмена регистрации COM-библиотеки SQL-DMO SQL Server 2005. Чтобы восстановить работу программы Enterprise Manager и других программ, зависящих от SQL-DMO, произведите регистрацию библиотеки следующей командной строкой: regsvr32.exe sqldmo.dll. Дополнительные сведения см. в разделе Устранение неполадок при установке ядра СУБД SQL Server.

  • Если собственный клиент SQL случайно удален, запуск ресурсов SQL Server окажется невозможным. Чтобы переустановить собственный клиент SQL, запустите программу установки SQL Server 2005 и установите предварительно необходимые компоненты SQL Server 2005.

  • При удалении отказоустойчивого кластера, использующего более одного кластерного ресурса SQL IP, необходимо удалить дополнительные ресурсы SQL IP с помощью средства администрирования кластера.

Удаление отказоустойчивого кластера SQL Server 2005 после неудачного удаления программой установки SQL Server

  1. Произведите резервное копирование каждого из узлов, прежде чем удалять SQL Server 2005.

  2. В редакторе реестра (regedit.exe) откройте раздел HKLM\Software\Microsoft\Microsoft SQL Server\<instid>\Setup, где <instid> — соответствующий экземпляр удаляемого SQL Server 2005 (например, «MSSQL.1» соответствует первому экземпляру, «MSSQL.2» — второму и т.д.). Установите SqlCluster=0. Это выведет экземпляр SQL Server 2005 из состава кластера.

    Внимание! Неверные действия при изменении реестра могут вызвать серьезные проблемы, вплоть до необходимости переустановки операционной системы. Корпорация Майкрософт не гарантирует, что проблемы, возникшие вследствие неправильного изменения реестра, могут быть решены. Перед изменением создайте резервные копии реестра и всех важных данных.

  3. Убедитесь, что удаляемому узлу доступен общий диск.

  4. Откройте из панели управления окно Установка или удаление программ.

  5. Выберите экземпляр SQL Server 2005, который необходимо удалить, и нажмите кнопку Удалить. Запускается мастер установки SQL Server 2005.

  6. На странице Выбор компонентов выберите пункт Удалить компоненты экземпляра SQL Server 2005, а затем щелкните имя экземпляра и общие компоненты, чтобы удалить их. Чтобы продолжить, нажмите кнопку Далее.

  7. На странице Данные удаленного имени входа введите пароль учетной записи администратора для всех узлов кластеризованного экземпляра. Чтобы продолжить, нажмите кнопку Далее.

  8. На странице Подтверждение проверьте удаляемые компоненты SQL Server. Чтобы продолжить процесс удаления, нажмите кнопку Готово.

  9. Мастер установки SQL Server 2005 удаляет с компьютера компоненты SQL Server 2005. Если программе установки потребуется доступ к установочному диску SQL Server 2005, она попросит вставить его в дисковод компакт- или DVD-дисков. На компакт- или DVD-диске, использующемся для удаления SQL Server, номер сборки SQL Server должен совпадать с номером сборки удаляемого экземпляра. При сетевой установке программа установки должна иметь доступ к сетевой папке.

  10. Средство проверки конфигурации (SCC) SQL Server 2005 проверит текущую конфигурацию компьютера. На странице Приветствие нажмите кнопку Далее. После того как средство проверки конфигурации завершит работу, нажмите кнопку Далее, чтобы продолжить.

  11. На странице Ход установки отображается состояние процесса удаления SQL Server 2005 с компьютера. На странице Завершение работы мастера установки Microsoft SQL Server можно просмотреть сводный журнал установки. Для этого щелкните соответствующую ссылку на этой странице. Чтобы завершить работу мастера установки SQL Server, нажмите кнопку Готово.

    1. Примечание Не пытайтесь удалить компоненты MSXML или SQLXML. Они будут автоматически удалены после удаления всех зависимых от них компонентов.

  12. Переместите общий диск на следующий удаляемый узел и повторите для этого узла шаги с 1 по 11. Для каждого узла выполняйте резервное копирование реестра и других важных данных, в реестре выводите удаляемый экземпляр из кластера, перемещайте общий диск так, чтобы он был доступен удаляемому экземпляру, а затем в окне Установка и удаление программ удалите SQL Server 2005 с этого узла.

  13. Повторите описанные действия для всех оставшихся узлов.

См. также

Задачи

Как
Как добавить или удалить узлы отказоустойчивого кластера SQL Server 2005 (установка)


Как произвести восстановление после сбоя отказоустойчивого кластера в сценарии 1

Как произвести восстановление после сбоя отказоустойчивого кластера в сценарии 1 |
 | См. также
Настройка высокого уровня доступности > Разделы руководства по конфигурированию доступности > Разделы руководства по отказоустойчивому кластеру >

В данном сценарии в кластере, состоящем из двух узлов, сбой вызван отказом оборудования в узле 1. Причина могла, например, заключаться в неисправности дискового контроллера или сбое операционной системы.

Восстановление отказоустойчивого кластера после сбоя оборудования

  1. После сбоя на узле 1 отказоустойчивый кластер переключается на узел 2.

  2. Исключите узел 1 из службы кластеров (MSCS). Для этого откройте администратор кластера из узла 2, щелкните правой кнопкой мыши удаляемый узел и выберите Исключить узел.

  3. Проверьте, исключен ли узел 1 из определения кластера.

  4. Установите новое оборудование взамен отказавшего в узле 1.

  5. При помощи администратора кластера произведите настройку службы кластеров (MSCS), добавив к существующему кластеру узел 1. Дополнительные сведения см. в разделе Подготовка к установке отказоустойчивого кластера.

  6. Убедитесь, что учетные записи администраторов одинаковы на всех узлах кластера. Дополнительные сведения см. в разделе Как создать новый отказоустойчивый кластер SQL Server 2005 (установка).

  7. Запустите программу установки SQL Server, чтобы добавить узел 1 к отказоустойчивому кластеру. Дополнительные сведения см. в разделе Как добавить или удалить узлы отказоустойчивого кластера SQL Server 2005 (установка).

См. также

Задачи

Как просмотреть файл журнала установки SQL Server 2005

Основные понятия

Как просмотреть файлы журналов установки SQL Server 2005


Как произвести восстановление после сбоя отказоустойчивого кластера в сценарии 2

Как произвести восстановление после сбоя отказоустойчивого кластера в сценарии 2 |
 | См. также
Настройка высокого уровня доступности > Разделы руководства по конфигурированию доступности > Разделы руководства по отказоустойчивому кластеру >

В сценарии 2 причиной сбоя является узел 1, неработающий или недоступный, но не поврежденный полностью. Причиной этого может быть ошибка операционной системы или аппаратный сбой.

Процедура

Восстановление отказоустойчивого кластера после сбоя

  1. После сбоя на узле 1 отказоустойчивый кластер переключается на узел 2.

  2. Разрешите проблему на узле 1.

  3. Убедитесь, что кластер службы кластеров Microsoft (MSCS) работает и все узлы находятся в оперативном режиме.

  4. Попытайтесь перевести SQL Server на восстановленный узел. Если эта операция пройдет успешно далее, кроме обычного тестирования, никаких действий предпринимать не надо. Если SQL Server не сможет перейти в оперативный режим на восстановленном узле, обратитесь к разделу Диагностика отказоустойчивого кластера.

См. также

Задачи

Как просмотреть файл журнала установки SQL Server 2005

Основные понятия

Диагностика отказоустойчивого кластера
Как перестроить базу данных master в SQL Server 2005
Как перестроить реестр для SQL Server 2005
Как просмотреть файлы журналов установки SQL Server 2005


Настройка параметров сортировки и поддержка нескольких языков

Настройка параметров сортировки и поддержка нескольких языков |
 | См. также
Подготовка к установке SQL Server 2005 >

поддерживает все языки, доступные в операционных системах Microsoft Windows.В этом разделе представлены подробные сведения о языковой поддержке в SQL Server 2005, а также о способах поддержки форматов данных с кодировкой Юникод и отличной от Юникод в SQL Server.

Изменения параметров сортировки в SQL Server 2005

В SQL Server 2005 внесены следующие изменения и усовершенствования.

  • Поддержка новых и обновленных параметров сортировки Windows Server 2003 и Windows XP, включая параметры сортировки дальневосточных языков, поддерживающие дополнительные символы.

  • Поддержка новых параметров сортировки со сравнением строк дополнительных символов по элементам кода в SQL Server 2005.

  • Добавление двоичного флага для полноценного сравнения элементов кода. Элемент двоичного кода.

  • Усовершенствованный путь миграции от SQL Server 7.0 и SQL Server 2000 к SQL Server 2005.

  • Параметры сортировки Windows Hindi, Lithuanian_Classic и SQL_ALTDiction_CP1253_CS_AS SQL являются устаревшими.Эти параметры сортировки поддерживаются, но не отображаются во встроенной функции ::fn_helpcollations().Поддержка этих параметров сортировки будет удалена из следующей версии SQL Server.Дополнительные сведения о правилах признания функций SQL Server устаревшими см. в разделе Обратная совместимость.

Дополнительные сведения см. в разделе Настройка параметров сортировки в программе установки

См. также

Справочник

Настройка параметров сортировки в программе установки
Выбор параметров сортировки SQL

Основные понятия

Терминология параметров сортировки


Терминология параметров сортировки

Терминология параметров сортировки |
 | См. также
Подготовка к установке SQL Server 2005 > Настройка параметров сортировки и поддержка нескольких языков >

Чтобы воспользоваться всеми преимуществами языковой поддержки SQL Server 2005, следует ознакомиться с терминами, описанными в этом разделе.

Термины

  • Кодовая страница

  • Параметры сортировки

  • Тип данных

  • Глобализация

  • Языковой стандарт

  • Порядок чтения

  • Порядок сортировки

  • Юникод

Кодовая страница

Кодовая страница — это упорядоченный набор символов данного набора символов, в котором числовой индекс или значение элемента кода связано с каждым символом. Кодовую страницу Microsoft Windows часто называют набором символов или кодировкой. Кодовые страницы обеспечивают поддержку наборов символов и раскладок клавиатуры, применяемых в различных языковых стандартах Windows.

См. также: Установка кодовой страницы клиента

В начало

Параметры сортировки

Параметры сортировки задают битовые шаблоны, представляющие в наборе данных каждый символ. Кроме того, параметры сортировки определяют правила сортировки и сравнения данных. SQL Server 2005 поддерживает хранение объектов с различными параметрами сортировки в одной базе данных, и у каждого столбца в базе данных SQL Server может быть собственный набор параметров сортировки. Для столбцов в кодировке, отличной от Юникода, свойство параметров сортировки задает кодовую страницу для данных и, соответственно, возможность представления символов. Данные можно легко перемещать между столбцами в Юникоде. Данные между столбцами в форматах, отличных от Юникода, обычным образом перемещать нельзя, их следует преобразовывать с учетом текущей кодовой страницы.

Результат выполнения инструкции Transact-SQL может различаться в зависимости от контекста различных баз данных, в каждой из которых имеются свои параметры сортировки. Рекомендуется по возможности использовать стандартный набор параметров сортировки в рамках всей организации. Использование стандартных свойств параметров сортировки на всех компьютерах организации устраняет необходимость явно указывать параметры сортировки в каждом символьном выражении или выражении Юникода. Если необходимо работать с объектами, имеющими различные параметры сортировки и кодовые страницы, следует создавать запросы с учетом очередности параметров сортировки. Дополнительные сведения см. в разделе Очередность параметров сортировки (Transact-SQL).

Характеристики параметров сортировки учитывают язык, регистр, диакритические знаки, тип японской азбуки, а также ширину символов.

В параметры сортировки SQL Server 2005 входят следующие типы группирования.

Параметры сортировки Windows

Параметры сортировки Windows определяют правила хранения символьных данных на основе соответствующего языкового стандарта Windows. Для параметров сортировки Windows сравнение данных в формате, отличном от Юникода, реализовано с помощью такого же алгоритма, как и для данных в Юникоде. Базовые правила параметров сортировки Windows задают алфавит или язык, используемый при сортировке по словарю, а также кодовую страницу, используемую для хранения символьных данных не в Юникоде. Сортировка в Юникоде и в других форматах совместима со строковым сравнением в соответствующей версии Windows. Это обеспечивает согласованность типов данных в SQL Server, а также позволяет разработчикам сортировать строки в их приложениях с помощью тех же правил, что и в SQL Server, то есть путем вызова функции CompareStringW из Microsoft Win32 API. Дополнительные сведения см. в разделе Настройка параметров сортировки в программе установки.

Двоичные параметры сортировки

В двоичных параметрах сортировки данные сортируются на основе последовательности закодированных значений, определяемых языковым стандартом и типом данных. Двоичные параметры сортировки в SQL Server определяют языковой стандарт и используемую кодовую страницу ANSI, применяя двоичный порядок сортировки. Двоичные параметры сортировки полезно применять для повышения производительности приложений вследствие относительной простоты. Для типов данных, отличных от Юникода, сравнение данных производится на основе элементов кода, определенных кодовой страницей ANSI. Типы данных в Юникоде сравниваются на основе элементов кода Юникода. Для двоичных параметров сортировки на основе типов данных Юникода при сортировке данных языковой стандарт не учитывается. Например, параметры сортировки Latin_1_General_BIN и Japanese_BIN дают одинаковые результаты сортировки, если используются с данными в Юникоде.

Прежние двоичные параметры сортировки в SQL Server для данных в Юникоде выполняли неполное сравнение каждого элемента кода, при этом в предыдущей версии SQL Server первый символ сравнивался как принадлежащий типу WCHAR, после чего производилось побайтовое сравнение. В целях обратной совместимости семантика существующих двоичных параметров сортировки изменена не будет.

Двоичные параметры сортировки в этом выпуске SQL Server включают новый набор параметров сортировки со сравнением исключительно элементов кода. Пользователям доступна возможность миграции на новые двоичные параметры сортировки для получения преимущества реального сравнения элементов кода. При разработке новых приложений рекомендуется использовать новые двоичные параметры сортировки. Новым суффиксом BIN2 определяются имена наборов параметров сортировки, реализующих новую семантику параметров сортировки элементов кода. Кроме того, добавлен новый флаг сравнения, соответствующий BIN2 для новой двоичной сортировки. Дополнительные сведения см. в разделе Использование двоичных параметров сортировки.

Параметры сортировки SQL Server

Параметры сортировки SQL Server обеспечивают совместимость порядка сортировки с более ранними версиями SQL Server. Параметры сортировки SQL Server основаны на традиционных порядках сортировки SQL Server для данных в формате, отличном от Юникода, например для данных типов char и varchar, определенных в SQL Server. Правила сортировки словаря для данных в формате, отличном от Юникода, не совместимы ни с какими процедурами сортировки операционных систем Windows, однако сортировка данных в Юникоде совместима с правилами сортировки определенной версии Windows. Поскольку параметры сортировки SQL Server применяют для данных в Юникоде и в отличных от него форматах разные правила сортировки, то при сравнении одних и тех же данных могут получиться разные результаты, которые будут зависеть от базового типа данных. Дополнительные сведения см. в разделе Использование параметров сортировки SQL.

Примечание.
При обновлении версии экземпляра SQL Server можно задать параметры сортировки SQL Server, чтобы обеспечить совместимость с существующими экземплярами SQL Server. Поскольку параметры сортировки по умолчанию для экземпляра SQL Server определяются во время установки, очень важно правильно настроить параметры сортировки в следующих случаях.

  • Когда код приложения каким-то образом зависит от поведения предыдущих параметров сортировки SQL Server.

  • Планируется использование репликации SQL Server 2005 с уже установленными SQL Server 6.5 или SQL Server 7.0.

  • Необходимо хранить символьные данные, в которых используется несколько языков.

SQL Server 2005 поддерживает настройку параметров сортировки на следующих уровнях экземпляра SQL Server 2005.

Параметры сортировки уровня сервера

Параметры сортировки по умолчанию для экземпляра SQL Server задаются во время установки. Параметры сортировки по умолчанию для экземпляра также становятся параметрами сортировки по умолчанию для системных баз данных: master, model, tempdb, msdb и distribution. После назначения параметров сортировки любому объекту, отличному от столбца или базы данных, его можно будет изменить только с помощью удаления и повторного создания объекта. Вместо изменения параметров сортировки по умолчанию для экземпляра SQL Server можно задать параметры сортировки при создании новой базы данных или столбца базы данных.

Запрос серверных параметров сортировки для экземпляра SQL Server выполняется с помощью следующей функции SERVERPROPERTY Transact-SQL.

Копировать код
SELECT CONVERT (varchar, SERVERPROPERTY('collation'))

Запрос всех доступных на сервере параметров сортировки выполняется с помощью следующей встроенной функции fn_helpcollations().

Копировать код
SELECT * from ::fn_helpcollations()
Параметры сортировки уровня базы данных

При создании базы данных можно задать ее параметры сортировки по умолчанию с помощью предложения COLLATE в инструкции CREATE DATABASE. Если при создании базы данных не были указаны параметры сортировки, то базе данных назначаются параметры сортировки по умолчанию для базы данных model. Параметры сортировки по умолчанию для базы данных model совпадают с параметрами сортировки по умолчанию для экземпляра SQL Server.

Параметры сортировки пользовательской базы данных можно изменить с помощью инструкции ALTER DATABASE следующим образом.

Копировать код
ALTER DATABASE myDB COLLATE Greek_CS_AI

Текущие параметры сортировки базы данных можно получить с помощью следующей инструкции.

Копировать код
SELECT CONVERT (varchar, DATABASEPROPERTYEX('database_name','collation'))
Примечание.
Изменение параметров сортировки уровня базы данных не влияет на параметры сортировки уровня пользователя, таблицы и столбцов.

Параметры сортировки уровня столбцов

При создании таблицы параметры сортировки для каждого столбца символьной строки можно указывать с помощью предложения COLLATE инструкции CREATE TABLE. Если при создании таблицы не были указаны параметры сортировки, то столбцу присваиваются параметры сортировки по умолчанию для базы данных.

Параметры сортировки для столбца можно изменить с помощью инструкции ALTER TABLE следующим образом.

Копировать код
ALTER TABLE myTable ALTER COLUMN mycol NVARCHAR(10) COLLATE Greek_CS_AI
Параметры сортировки уровня выражений

Параметры сортировки уровня выражения задаются при выполнении инструкции, и они влияют на способ возврата результирующего набора. Это позволяет сортировать результаты с помощью предложения ORDER BY с учетом специфики конкретного языка. Для реализации параметров сортировки уровня выражения предложение COLLATE применяется следующим образом.

Копировать код
SELECT name FROM customer ORDER BY name COLLATE Latin1_General_CS_AI

В начало

Тип данных

Тип данных — это определение, которое указывает диапазон значений, операции, которые могут выполняться над значениями, а также способ хранения значений в памяти компьютера. Определение типов данных позволяет SQL Server предсказуемо управлять данными. char, varchar и text относятся к типам данных с символами в формате, отличном от Юникода. Типы данных в формате Юникод используют представление символов в формате Юникод. К ним относятся следующие типы: nchar, nvarchar и ntext. В приложениях рекомендуется использовать данные в Юникоде, особенно если данные хранятся на нескольких языках.

См. также: Типы данных (компонент Database Engine), Типы данных (Transact-SQL), Типы данных служб Integration Services

В начало

Глобализация

Глобализация — это процесс разработки приложения с функциями и кодом, поддерживающими несколько языков и языковых стандартов. В глобализованном приложении реализовано несколько языковых стандартов для языков, поддерживающих Юникод, для ввода, обработки, отображения и вывода данных.

См. также: Поддержка многоязычных функций в SQL Server

В начало

Языковой стандарт

Языковой стандарт — это набор сведений, связанный с определенным регионом или культурой: имя и идентификатор языка, шрифт, применяемый для записи на нем, а также национальные стандарты. SQL Server 2005 поддерживает все 135 языковых стандартов, поддерживаемых Windows XP. Среди них пять языковых стандартов для китайского языка (КНР, Макао, ОАР Гонконг, Сингапур и Тайвань), тринадцать стандартов для английского языка (Австралия, Белиз, Великобритания, Зимбабве, Ирландия, Канада, Карибские о-ва, Новая Зеландия, США, Тринидад, Филиппины, ЮАР и Ямайка), а также шесть стандартов для французского языка (Бельгия, Канада, Люксембург, Монако, Франция и Швейцария).

В приведенной ниже таблице показаны некоторые различия между четырьмя основными языковыми стандартами, поддерживаемыми Windows.

Языковой стандарт | Английский (США) | Французский (Франция) | Японский | Объединенные Арабские Эмираты
Страна или регион | США | Франция | Япония | Объединенные Арабские Эмираты
Язык | Английский | Французский | Японский | Арабский
Шрифты письменности | Латинский | Латинский | Кана, кандзи | Арабский
Порядок чтения | Слева направо | Слева направо | Слева направо | Справа налево
Кодовая страница, определяемая Windows | 1252 | 1252 | 932 | 1256
Формат времени | 13:00 | 13:00 | 13:00 | 13:00
Календарь | Григорианский | Григорианский | Григорианский (локализованный) | Григорианский (локализованный)
Размер страницы по умолчанию | Letter | A4 | A4 | A4
Разделитель целой и дробной части | . | , | . | ,
Разделитель элементов списка | , | ; | , | ;
Разделитель групп разрядов | , | пробел | , | ,

В начало

Порядок чтения

Порядок чтения — это общее направление последовательности текста, которое относится к порядку слов, а не к порядку ввода символов. Например, если в качестве языка ввода с клавиатуры используется арабский язык, то новые символы будут вводиться справа налево. Если язык ввода с клавиатуры имеет латинский алфавит, то новые символы будут появляться слева направо.

В начало

Порядок сортировки

Порядок сортировки устанавливает способ сортировки значений данных, что влияет на результаты сравнения данных. Сортировка данных выполняется с помощью параметров сортировки, и ее можно оптимизировать с помощью индексов.

См. также: Стили сортировки в параметрах сортировки Windows, Индексы

В начало

Юникод

Юникод представляет алфавитные символы в двухбайтовом виде, что позволяет передавать символами кодировки Юникода почти все письменные языки мира. Юникод был разработан и в настоящее время поддерживается и продвигается некоммерческой организацией Unicode Consortium. Дополнительные сведения см. на веб-узле Unicode Consortium.

Данные на нескольких языках следует всегда хранить в Юникоде (nchar, nvarchar и ntext), а не использовать другие типы данных (char, varchar и text). Применение Юникода позволяет существенно повысить производительность, поскольку требуется выполнять меньше преобразований кодовых страниц. Типы данных, отличные от Юникода, имеют значительные ограничения, поскольку на компьютере, где не применяется Юникод, можно использовать только одну кодовую страницу. Чтобы получить полное представление о трудностях, связанных с применением типов в Юникоде или не в Юникоде, нужно протестировать свой сценарий, измерив разницу производительности для этих двух вариантов в конкретной среде. По меньшей мере, следует стандартизировать параметры сортировки в пределах организации и по возможности развертывать серверы и клиенты с поддержкой Юникода.

В большинстве случаев экземпляр SQL Server будет взаимодействовать с другими серверами или клиентами и сможет применять несколько стандартов доступа к данным. Клиенты SQL Server бывают одного из следующих двух основных типов.

  • Клиенты с поддержкой Юникода, применяющие OLE DB и ODBC версии 3.7 или более поздних.

  • Клиенты без поддержки Юникода, применяющие библиотеку баз данных и ODBC версий 3.6 или более ранних.

В следующей таблице приведены замечания по применению данных на нескольких языках с различными сочетаниями серверов, поддерживающих и не поддерживающих Юникод.

Сервер | Клиент | Преимущества или ограничения
Юникод | Юникод | Идеальная конфигурация, поскольку данные в Юникоде будут использоваться во всей системе. Этот сценарий обеспечивает наилучшую производительность и защиту полученных данных от повреждения. Это случай применения Microsoft ActiveX (ADO), OLE DB, а также ODBC версий 3.7 или более поздних.
Юникод | Не Юникод | В данном сценарии хранение данных не вызывает трудностей, но могут быть ограничения при переносе данных на компьютер клиента. По меньшей мере, данные в Юникоде придется преобразовывать для клиента без поддержки Юникода с помощью кодовой страницы.
Не Юникод | Юникод | Это не лучшая конфигурация для работы с данными на нескольких языках. Данные в Юникоде нельзя будет записывать на сервер без поддержки Юникода. Вероятнее всего, неполадки могут произойти при отправке данных на серверы, которые поддерживают другие кодовые страницы.
Не Юникод | Не Юникод | В этом сценарии очень много ограничений для применения данных на нескольких языках. Можно применять только одну кодовую страницу. Идеальная конфигурация — это сервер и клиенты с поддержкой Юникода.

См. также: Основы Юникода

В начало

См. также

Справочник

Настройка параметров сортировки и поддержка нескольких языков


Настройка параметров сортировки в программе установки

Настройка параметров сортировки в программе установки |
 | См. также
Подготовка к установке SQL Server 2005 > Настройка параметров сортировки и поддержка нескольких языков >

Дата обновления: 14 апреля 2006 г.

Параметры сортировки сопоставления, включающие кодировку, порядок сортировки и другие параметры, зависящие от региональных стандартов, являются ключевым фактором в структурировании и функционировании баз данных . Внутри конкретной организации необходимо разработать стандарт для параметров сортировки и задавать эти параметры при установке SQL Server. Многие межсерверные операции могут привести к сбою или выдать противоречивые результаты, если серверы имеют несогласованные параметры сортировки. Выберите языковой стандарт Microsoft Windows, чтобы обеспечить соответствие параметров сортировки на других экземплярах SQL Server 2005, или выберите Параметры сортировки SQL для соответствия параметров порядку сортировки в ранних версиях SQL Server.

SQL Server 2005 поддерживает настройку параметров сортировки на следующих уровнях экземпляра SQL Server 2005:

  • уровень сервера;

  • уровень базы данных;

  • уровень столбца;

  • уровень выражения.

Дополнительные сведения об уровнях параметров сортировки см. в разделе Терминология параметров сортировки. Дополнительные сведения о перестроении системных баз данных с указанием новых системных параметров сортировки см. в разделе Как установить SQL Server 2005 из командной строки.

Язык системы Windows

Изменяйте параметры сортировки Windows, принятые по умолчанию, только если экземпляр SQL Server должен соответствовать параметрам сортировки, которые используются в другом экземпляре SQL Server, или если параметры сортировки должны соответствовать языку системы Windows на другом компьютере.

Обозначение параметров сортировки

Выберите имя заданного набора параметров сортировки Windows из списка Обозначение параметров сортировки. Например:

  • используйте Latin1_General для кодировки «Английский (США)» (кодовая страница 1252);

  • используйте Modern_Spanish для всех диалектов испанского языка, использующих ту же кодировку, что и «Английский (США)» (кодовая страница 1252);

  • используйте Arabic для всех диалектов арабского языка, использующих ту же кодировку, что и «Арабский» (кодовая страница 1256).;

  • используйте Japanese_Unicode для версии японского языка в Юникоде (кодовая страница 932), использующей порядок сортировки, отличный от порядка Японский, но с той же кодовой страницей (932).

Порядок сортировки

Выберите параметры порядка сортировки, которые будут использоваться с тем же обозначением набора параметров сортировки. Двоичная сортировка — самая быстрая, она выполняется с учетом регистра, но может дать непредвиденный порядок сортировки. Если выбран параметр Двоичный, то параметры С учетом регистра, С учетом диакритических знаков, С учетом типа японской азбуки и С учетом ширины символов становятся недоступными. Дополнительные сведения см. в разделе Стили сортировки в параметрах сортировки Windows.

Двоичные параметры сортировки

Двоичные параметры сортировки сортируют и сравнивают данные в SQL Server на основе битового шаблона для каждого символа. Все двоичные параметры сортировки в SQL Server соответствуют конкретному языку и кодовой странице ANSI, каждое из них выполняет сортировку данных с учетом регистра и с учетом диакритических знаков. Двоичные параметры сортировки обеспечивают самую быструю сортировку данных. Дополнительные сведения см. в разделах Стили сортировки в параметрах сортировки Windows и Использование двоичных параметров сортировки.

Параметры сортировки SQL

Параметр Параметры сортировки SQL используется для совместимости с ранними версиями SQL Server. Выберите этот параметр, чтобы настройка соответствовала SQL Server 2000, SQL Server 7.0 или более ранним версиям. Дополнительные сведения см. в разделе Использование параметров сортировки SQL.

Новые версии параметров сортировки

Чтобы улучшить методы работы параметров сортировки по сравнению с предыдущими версиями, были введены следующие изменения:

  • поддержка сравнения дополнительных символов в параметрах сортировки для языков Дальнего Востока;

  • дополнение в виде новой версии параметров сортировки Indic_General_90_CI_AS (только Юникод) для поддержки изменений алгоритмов сортировки.

    Важно!
    Оба эти обновления в значительной степени влияют на поведение сортировки и сравнения. Во время обновления этих параметров сортировки до версии миграция на новые версии не будет выполняться в принудительном порядке. Если пользователи выполняют миграцию на новые параметры сортировки с целью поддержки дополнительных символов, необходимо выполнить повторную индексацию всех баз данных и объектов SQL Server. Поскольку повторная индексация может занять много времени, сравните затраты на поддержку дополнительных символов с обеспечиваемыми ею преимуществами. Параметры сортировки SQL Server 2000 будут поддерживаться в SQL Server 2005 в случаях, если клиенты решат не проводить миграцию на новые версии.

В этой версии SQL Server 2005 обновлены следующие параметры сортировки для поддержки сортировки по элементам кода в операционной системе Windows Server 2003.

Старое имя набора параметров сортировки | Новое имя набора параметров сортировки
Japanese | Japanese_90
Chinese | Chinese_PRC_90
Chinese_PRC_Stroke | Chinese_PRC_Stroke_90
Chinese_Taiwan_Bopomofo | Chinese_Taiwan_Bopomofo_90
Chinese_Taiwan_Stroke | Chinese_Taiwan_Stroke_90
Korean | Korean_90
Hindi (не рекомендуется в этом выпуске) | Indic_General_90_CI_AS (только Юникод)

Параметры сортировки по умолчанию в программе установки SQL Server

Найдите имя параметра языка Microsoft Windows в разделе панели управления Региональные параметры (Windows 2000) или Язык и региональные стандарты (Windows XP) и с помощью следующей таблицы определите соответствие обозначения параметров сортировки и кодовой страницы существующим параметрам языка Windows в следующей таблице параметров сортировки SQL Server 2005.

Язык системы Windows | LCID (код языка) | Параметры сортировки SQL по умолчанию | Кодовая страница
Африкаанс | 0x436 | Latin1_General_CI_AS | 1252
Албанский | 0x41c | Albanian_CI_AS | 1250
Арабский (Алжир) | 0x1401 | Arabic_CI_AS | 1256
Арабский (Бахрейн) | 0x3c01 | Arabic_CI_AS | 1256
Арабский (Египет) | 0xc01 | Arabic_CI_AS | 1256
Арабский (Ирак) | 0x801 | Arabic_CI_AS | 1256
Арабский (Иордания) | 0x2c01 | Arabic_CI_AS | 1256
Арабский (Кувейт) | 0x3401 | Arabic_CI_AS | 1256
Арабский (Ливан) | 0x3001 | Arabic_CI_AS | 1256
Арабский (Ливия) | 0x1001 | Arabic_CI_AS | 1256
Арабский (Марокко) | 0x1801 | Arabic_CI_AS | 1256
Арабский (Оман) | 0x2001 | Arabic_CI_AS | 1256
Арабский (Катар) | 0x4001 | Arabic_CI_AS | 1256
Арабский (Саудовская Аравия) | 0x401 | Arabic_CI_AS | 1256
Арабский (Сирия) | 0x2801 | Arabic_CI_AS | 1256
Арабский (Тунис) | 0x1c01 | Arabic_CI_AS | 1256
Арабский (ОАЭ) | 0x3801 | Arabic_CI_AS | 1256
Арабский (Йемен) | 0x2401 | Arabic_CI_AS | 1256
Армянский (Армения) | 0x42b | Latin1_General_CI_AS | Юникод
Азербайджанский (кириллица) 1 | 0x82c | Azeri_Cyrillic_90_CI_AS | 1251
Азербайджанский (латиница) 1 | 0x42c | Azeri_Latin_90_CI_AS | 1254
Баскский | 0x42d | Latin1_General_CI_AS | 1252
Белорусский | 0x423 | Cyrillic_General_CI_AS | 1251
Болгарский | 0x402 | Cyrillic_General_CI_AS | 1251
Каталонский | 0x403 | Latin1_General_CI_AS | 1252
Китайский (Гонконг)1 | 0xc04 | Chinese_Hong_Kong_Stroke_90_CI_AS | 950
Китайский (Макао)2 | 0x1404 | Chinese_PRC_90_CI_AS | 950
Китайский (КНР)2 | 0x804 | Chinese_PRC_CI_AS | 936
Китайский (КНР) | 0x20804 | Chinese_PRC_Stroke_CI_AS | 936
Китайский (Сингапур) | 0x1004 | Chinese_PRC_90_CI_AS | 936
Китайский (Тайвань) | 0x404 | Chinese_Taiwan_Stroke_CI_AS | 950
Китайский (Тайвань) | 0x30404 | Chinese_Taiwan_Bopomofo_CI_AS | 950
Хорватский | 0x41a | Croatian_CI_AS | 1250
Чешский | 0x405 | Czech_CI_AS | 1250
Датский | 0x406 | Danish_Norwegian_CI_AS | 1252
Деванагари 1 | 0x465 | Divehi_90_CI_AS (только Юникод) | Юникод
Голландский (Бельгия) | 0x813 | Latin1_General_CI_AS | 1252
Голландский (Нидерланды) | 0x413 | Latin1_General_CI_AS | 1252
Английский (Австралия) | 0xc09 | Latin1_General_CI_AS | 1252
Английский (Белиз) | 0x2809 | Latin1_General_CI_AS | 1252
Английский (Канада) | 0x1009 | Latin1_General_CI_AS | 1252
Английский (Карибский бассейн) | 0x2409 | Latin1_General_CI_AS | 1252
Английский (Гонконг) | 0x3c09 | Latin1_General_CI_AS | 1252
Английский (Индия) | 0x4009 | Latin1_General_CI_AS | 1252
Английский (Индонезия) | 0x3809 | Latin1_General_CI_AS | 1252
Английский (Ирландия) | 0x1809 | Latin1_General_CI_AS | 1252
Английский (Ямайка) | 0x2009 | Latin1_General_CI_AS | 1252
Английский (Малайзия) | 0x4409 | Latin1_General_CI_AS | 1252
Английский (Новая Зеландия) | 0x1409 | Latin1_General_CI_AS | 1252
Английский (Филиппины) | 0x3409 | Latin1_General_CI_AS | 1252
Английский (Сингапур) | 0x4809 | Latin1_General_CI_AS | 1252
Английский (Южная Африка) | 0x1c09 | Latin1_General_CI_AS | 1252
Английский (Тринидад) | 0x2c09 | Latin1_General_CI_AS | 1252
Английский (Великобритания) | 0x809 | Latin1_General_CI_AS | 1252
Английский (США) | 0x409 | SQL_Latin1_General_CP1_CI_AS | 1252
Английский (Зимбабве) | 0x3009 | Latin1_General_CI_AS | 1252
Эстонский | 0x425 | Estonian_CI_AS | 1257
Фарерский | 0x438 | Latin1_General_CI_AS | 1252
Фарси | 0x429 | Arabic_CI_AS | 1256
Финский | 0x40b | Finnish_Swedish_CI_AS | 1252
Французский (Бельгия) | 0x80c | French_CI_AS | 1252
Французский (Канада) | 0xc0c | French_CI_AS | 1252
Французский (Франция) | 0x40c | French_CI_AS | 1252
Французский (Люксембург) | 0x140c | French_CI_AS | 1252
Французский (Монако) | 0x180c | French_CI_AS | 1252
Французский (Швейцария) | 0x100c | French_CI_AS | 1252
Галисийский (Испания) | 0x456 | Latin1_General_CI_AS | 1252
Грузинский | 0x437 | Latin1_General_CI_AS | Юникод
Немецкий (Австрия) | 0xc07 | Latin1_General_CI_AS | 1252
Немецкий (Германия) | 0x407 | Latin1_General_CI_AS | 1252
Немецкий (Лихтенштейн) | 0x1407 | Latin1_General_CI_AS | 1252
Немецкий (Люксембург) | 0x1007 | Latin1_General_CI_AS | 1252
Немецкий (сортировка телефонной книги) | 0x10407 | German_PhoneBook_CI_AS | 1252
Немецкий (Швейцария) | 0x807 | Latin1_General_CI_AS | 1252
Греческий | 0x408 | Greek_CI_AS | 1253
Гуджарати (Индия)3 | 0x447 | Indic_General_90_CI_AS (только Юникод) | Юникод
Иврит | 0x40d | Hebrew_CI_AS | 1255
Хинди3 | 0x0439 | Indic_General_90_CI_AS (только Юникод) | Юникод
Венгерский | 0x40e | Hungarian_CI_AS | 1250
Венгерский (технический) | 0x104e | Hungarian_Technical_CI_AS | 1250
Исландский | 0x40f | Icelandic_CI_AS | 1252
Индонезийский | 0x421 | Latin1_General_CI_AS | 1252
Итальянский (Италия) | 0x410 | Latin1_General_CI_AS | 1252
Итальянский (Швейцария) | 0x810 | Latin1_General_CI_AS | 1252
Японский | 0x411 | Japanese_CI_AS | 932
Японский (Юникод) | 0x10411 | Japanese_Unicode_CI_AS | 932
Каннада (Индия)3 | 0x44b | Indic_General_90_CI_AS (только Юникод) | Юникод
Казахский (Казахстан)1 | 0x43f | Kazakh_90_CI_AS | 1251
Конкани (Индия)3 | 0x457 | Indic_General_90_CI_AS (только Юникод) | Юникод
Корейский (расширенный вансун) | 0x0412 | Korean_Wansung_CI_AS | 949
Киргизский (кириллица) | 0x440 | Cyrillic_General_CI_AS | 1251
Латвийский | 0x426 | Latvian_CI_AS | 1257
Литовский | 0x427 | Lithuanian_CI_AS | 1257
Македонский (Македония) | 0x42f | Macedonian_FYROM_90_CI_AS | 1251
Малайский (Бруней) | 0x83e | Latin1_General_CI_AS | 1252
Малайский (Малайзия) | 0x43e | Latin1_General_CI_AS | 1252
Маратхи (Индия)3 | 0x44e | Indic_General_90_CI_AS (только Юникод) | Юникод
Монгольский (кириллица) | 0x450 | Cyrillic_General_CI_AS | 1251
Норвежский (Букмол) | 0x414 | Danish_Norwegian_CI_AS | 1252
Норвежский (Нюнорск) | 0x814 | Danish_Norwegian_CI_AS | 1252
Польский | 0x415 | Polish_CI_AS | 1250
Португальский (Бразилия) | 0x416 | Latin1_General_CI_AS | 1252
Португальский (Португалия) | 0x816 | Latin1_General_CI_AS | 1252
Пенджаб-Гурмуки (Индия)3 | 0x446 | Indic_General_90_CI_AS (только Юникод) | Юникод
Румынский | 0x418 | Romanian_CI_AS | 1250
Русский | 0x419 | Cyrillic_General_CI_AS | 1251
Санскрит (Индия)3 | 0x44f | Indic_General_90_CI_AS (только Юникод) | Юникод
Сербский (кириллица) | 0xc1a | Cyrillic_General_CI_AS | 1251
Сербский (латиница) | 0x81a | Cyrillic_General_CI_AS | 1250
Словацкий | 0x41b | Slovak_CI_AS | 1250
Словенский | 0x424 | Slovenian_CI_AS | 1250
Испанский (Аргентина) | 0x2c0a | Modern_Spanish_CI_AS | 1252
Испанский (Боливия) | 0x400a | Modern_Spanish_CI_AS | 1252
Испанский (Чили) | 0x340a | Modern_Spanish_CI_AS | 1252
Испанский (Колумбия) | 0x240a | Modern_Spanish_CI_AS | 1252
Испанский (Коста-Рика) | 0x140a | Modern_Spanish_CI_AS | 1252
Испанский (Доминиканская Республика) | 0x1c0a | Modern_Spanish_CI_AS | 1252
Испанский (Эквадор) | 0x300a | Modern_Spanish_CI_AS | 1252
Испанский (Сальвадор) | 0x440a | Modern_Spanish_CI_AS | 1252
Испанский (Гватемала) | 0x100a | Modern_Spanish_CI_AS | 1252
Испанский (Гондурас) | 0x480a | Modern_Spanish_CI_AS | 1252
Испанский (международная сортировка) | 0xc0a | Modern_Spanish_CI_AS | 1252
Испанский (Мексика) | 0x80a | Modern_Spanish_CI_AS | 1252
Испанский (Никарагуа) | 0x4c0a | Modern_Spanish_CI_AS | 1252
Испанский (Панама) | 0x180a | Modern_Spanish_CI_AS | 1252
Испанский (Парагвай) | 0x3c0a | Modern_Spanish_CI_AS | 1252
Испанский (Перу) | 0x280a | Modern_Spanish_CI_AS | 1252
Испанский (Пуэрто-Рико) | 0x500a | Modern_Spanish_CI_AS | 1252
Испанский (традиционная сортировка) | 0x40a | Traditional_Spanish_CI_AS | 1252
Испанский (Уругвай) | 0x380a | Modern_Spanish_CI_AS | 1252
Испанский (Венесуэла) | 0x200a | Modern_Spanish_CI_AS | 1252
Суахили | 0x441 | Latin1_General_CI_AS | 1252
Шведский | 0x41d | Finnish_Swedish_CI_AS | 1252
Шведский (Финляндия) | 0x81d | Finnish_Swedish_CI_AS | 1252
Сирийский (Сирия)1 | 0x45a | Syriac_90_CI_AS (только Юникод) | Юникод
Тамильский (Индия)1 | 0x449 | Indic_General_90_CI_AS (только Юникод) | Юникод
Татарский (Татарстан)1 | 0x444 | Tatar_90_CI_AS | 1251
Телугу (Индия)1 | 0x44a | Indic_General_90_CI_AS (только Юникод) | Юникод
Тайский | 0x41e | Thai_CI_AS | 874
Турецкий | 0x41f | Turkish_CI_AS | 1254
Украинский | 0x422 | Ukrainian_CI_AS | 1251
Урду | 0x420 | Arabic_CI_AS | 1256
Узбекский (латиница)1 | 0x443 | Uzbek_Latin_90_CI_AS | 1254
Узбекский (кириллица) | 0x843 | Cyrillic_General_CI_AS | 1251
Вьетнамский | 0x42a | Vietnamese_CI_AS | 1258

1Новые параметры сортировки для SQL Server 2005. В этих параметрах сортировки используются таблицы сортировки Windows 2003 и поэтому поддерживаются дополнительные символы. В 90 новых параметрах сортировки Windows поддерживается и двоичная сортировка BIN, и BIN2.

2Для сортировки используйте пин-инь или фонетическую транскрипцию.

3Значительные изменения в поведении сортировки. Используйте новый набор параметров сортировки по умолчанию, Indic_General_90_CI_AS (только Юникод).

4 Параметры сортировки Hindi являются устаревшими в SQL Server 2005, так как в этой версии SQL Server используется таблица сортировки Windows 2000. Эти параметры сортировки по-прежнему существуют на сервере, но не будут поддерживаться в следующей версии SQL Server. Кроме того, они не отображаются в ::fn_helpcollations().

5 Параметры сортировки Hindi и Lithuanian_Classic являются устаревшими в SQL Server 2005. Эти параметры сортировки по-прежнему существуют на сервере, но не будут поддерживаться в следующей версии SQL Server. Кроме того, они не отображаются в ::fn_helpcollations().

См. также

Справочник

Настройка параметров сортировки и поддержка нескольких языков
Параметры сортировки
Стили сортировки в параметрах сортировки Windows

Основные понятия

Использование параметров сортировки SQL

Журнал изменений

Версия Журнал

5 декабря 2005 г.

Измененное содержимое
  • Документирована поддержка параметров сортировки Macedonian_FYROM_90.


Стили сортировки в параметрах сортировки Windows

Стили сортировки в параметрах сортировки Windows |
 | См. также
Подготовка к установке SQL Server 2005 > Настройка параметров сортировки и поддержка нескольких языков >

В процессе установки SQL Server выдается запрос на выбор между параметрами сортировки Windows и двоичными параметрами сортировки. Выбор параметров сортировки влияет на поведение конкретного экземпляра при сравнении данных и сортировке. В данном разделе приводятся соображения по выбору между параметрами сортировки Microsoft Windows и двоичными параметрами сортировки для конкретной конфигурации SQL Server.

Примечание.
Для параметров сортировки Windows типы данных Юникода nchar, nvarchar и ntext ведут себя при сортировке аналогично не поддерживающим Юникод типам данных — char, varchar и text.

Параметры сортировки Windows определяют правила хранения символьных данных на основе соответствующего языкового стандарта Windows. Базовые правила параметров сортировки Windows задают алфавит или язык, используемый при сортировке по словарю, а также кодовую страницу, используемую для хранения символьных данных не в Юникоде. В двоичных параметрах сортировки данные сортируются на основе последовательности закодированных значений, определяемых языковым стандартом и типом данных. Двоичные параметры сортировки в SQL Server определяют языковой стандарт и используемую кодовую страницу ANSI, применяя двоичный порядок сортировки. Двоичные параметры сортировки полезно применять для повышения производительности приложений вследствие относительной простоты. Для типов данных не в Юникоде сравнение данных производится на основе элементов кода, определенных кодовой страницей ANSI. Типы данных в Юникоде сравниваются на основе элементов кода Юникода. Для двоичных параметров сортировки на основе типов данных Юникода при сортировке данных языковой стандарт не учитывается. Например, параметры сортировки Latin_1_General_BIN и Japanese_BIN дают одинаковые результаты сортировки, если используются с данными в Юникоде.

В прежних двоичных параметрах сортировки в SQL Server для данных в Юникоде выполнялось неполное сравнение элементов кода, при этом первый символ сравнивался как тип WCHAR, после чего производилось побайтовое сравнение. В целях обратной совместимости семантика существующих двоичных параметров сортировки изменяться не будет.

Двоичные параметры сортировки в этой версии SQL Server включают также новый набор параметров сортировки с использованием сравнения только элементов кода. Пользователям доступна возможность миграции на новые двоичные параметры сортировки для получения преимущества реального сравнения элементов кода. При разработке новых приложений рекомендуется использовать новые двоичные параметры сортировки. Новым суффиксом BIN2 определяются имена наборов параметров сортировки, реализующих новую семантику параметров сортировки элементов кода. Кроме того, добавлен новый флаг сравнения, соответствующий BIN2 для новой двоичной сортировки. Дополнительные сведения см. в разделе Использование двоичных параметров сортировки.

В следующей таблице описаны свойства параметров сортировки Windows при сортировке в SQL Server 2005.

Порядок сортировки (суффикс) Описание порядка сортировки

Двоичный (_BIN)1

Данные в SQL Server сортируются и сравниваются на основе битовых шаблонов, определенных для каждого символа. Двоичный порядок сортировки учитывает регистр и диакритические знаки. Двоичный порядок сортировки является самым быстрым. Дополнительные сведения см. в разделе Использование двоичных параметров сортировки.

Если данный параметр не выбран, в SQL Server применяются правила сортировки и сравнения, определенные в словарях соответствующего языка или алфавита.

Элемент двоичного кода (_BIN2)1

Данные в SQL Server сортируются и сравниваются на основе элементов Юникода для данных в Юникоде. Для типов данных не в Юникоде при выборе BIN2 сравнение производится так же, как и двоичная сортировка.

Преимуществом использования порядка сортировки BIN2 является то, что приложениям, сравнивающим отсортированные данные SQL Server, не требуется никакой повторной сортировки данных. В результате сортировка BIN2 упрощает разработку приложения и увеличивает ожидаемую производительность. Дополнительные сведения см. в разделе Использование двоичных параметров сортировки.

С учетом регистра (_CS)

Различаются буквы верхнего и нижнего регистров. При выборе этого параметра буквы нижнего регистра при сортировке ставятся перед соответствующими буквами верхнего регистра.

Если этот параметр не выбран, при сортировке в SQL Server буквы верхнего и нижнего регистров считаются идентичными.

С учетом диакритических знаков (_AS)

Различаются символы с диакритическими знаками и без них. Например, «a» не равно «?».

Если этот параметр не выбран, при сортировке в SQL Server буквы с диакритическими знаками и без них считаются идентичными.

С учетом типа японской азбуки (_KS)

Различаются два вида японской азбуки: хирагана и катакана.

Если этот параметр не выбран, при сортировке в SQL Server символы хирагана и катакана считаются идентичными.

С учетом ширины символов (_WS)

Различаются одинаковые символы, представленные одним и двумя байтами.

Если этот параметр не выбран, при сортировке в SQL Server однобайтовые и двухбайтовые представления одних и тех же символов считаются идентичными.

1 Если параметр выбран, параметры учета регистра, диакритических знаков, типа японской азбуки и ширины символов недоступны.

Примеры параметров сортировки в Windows

Каждый набор параметров сортировки в Windows представляет собой последовательность суффиксов для определения учета регистра, диакритических знаков, ширины символов и типа японской азбуки. В следующих примерах описан порядок сортировки для различных сочетаний суффиксов.

Суффикс набора параметров сортировки Windows | Описание порядка сортировки
_BIN1 | Двоичная сортировка.
_BIN21 | Двоичный порядок сортировки BIN2, впервые представленный в версии SQL Server 2005.
_CI_AI | Без учета регистра, без учета диакритических знаков, без учета типа японской азбуки, без учета ширины символов.
_CI_AI_KS | Без учета регистра, без учета диакритических знаков, с учетом типа японской азбуки, без учета ширины символов.
_CI_AI_KS_WS | Без учета регистра, без учета диакритических знаков, с учетом типа японской азбуки, с учетом ширины символов.
_CI_AI_WS | Без учета регистра, без учета диакритических знаков, без учета типа японской азбуки, с учетом ширины символов.
_CI_AS | Без учета регистра, с учетом диакритических знаков, без учета типа японской азбуки, без учета ширины символов.
_CI_AS_KS | Без учета регистра, с учетом диакритических знаков, с учетом типа японской азбуки, без учета ширины символов.
_CI_AS_KS_WS | Без учета регистра, с учетом диакритических знаков, с учетом типа японской азбуки, с учетом ширины символов.
_CI_AS_WS | Без учета регистра, с учетом диакритических знаков, без учета типа японской азбуки, с учетом ширины символов.
_CS_AI | С учетом регистра, без учета диакритических знаков, без учета типа японской азбуки, без учета ширины символов.
_CS_AI_KS | С учетом регистра, без учета диакритических знаков, с учетом типа японской азбуки, без учета ширины символов.
_CS_AI_KS_WS | С учетом регистра, без учета диакритических знаков, с учетом типа японской азбуки, с учетом ширины символов.
_CS_AI_WS | С учетом регистра, без учета диакритических знаков, без учета типа японской азбуки, с учетом ширины символов.
_CS_AS | С учетом регистра, с учетом диакритических знаков, без учета типа японской азбуки, без учета ширины символов.
_CS_AS_KS | С учетом регистра, с учетом диакритических знаков, с учетом типа японской азбуки, без учета ширины символов.
_CS_AS_KS_WS | С учетом регистра, с учетом диакритических знаков, с учетом типа японской азбуки, с учетом ширины символов.
_CS_AS_WS | С учетом регистра, с учетом диакритических знаков, без учета типа японской азбуки, с учетом ширины символов.

1 Если выбран порядок сортировки BIN или BIN2, параметры учета регистра, диакритических знаков, типа японской азбуки и ширины символов недоступны.

См. также

Справочник

Настройка параметров сортировки в программе установки

Основные понятия

Использование двоичных параметров сортировки


Использование двоичных параметров сортировки

Использование двоичных параметров сортировки |
 | См. также
Подготовка к установке SQL Server 2005 > Настройка параметров сортировки и поддержка нескольких языков >

Следующие замечания помогут решить, какие параметры сортировки пригодны для реализации в , старые или новые. Поддержка параметров сортировки BIN и BIN2 будет продолжена в следующих версиях SQL Server.

В двоичных параметрах сортировки данные сортируются на основе последовательности закодированных значений, определяемых языковым стандартом и типом данных. Двоичные параметры сортировки в SQL Server определяют языковой стандарт и используемую кодовую страницу ANSI, применяя двоичный порядок сортировки. Двоичные параметры сортировки полезно применять для повышения производительности приложений вследствие их относительной простоты. Для типов данных, отличных от Юникода, сравнение данных производится на основе элементов кода, определенных кодовой страницей ANSI. Типы данных в Юникоде сравниваются на основе элементов кода Юникода. Для двоичных параметров сортировки на основе типов данных Юникода при сортировке данных языковой стандарт не учитывается. Например, параметры сортировки Latin_1_General_BIN и Japanese_BIN дают одинаковые результаты сортировки, если используются с данными в Юникоде.

Прежние двоичные параметры сортировки в SQL Server выполняли неполное сравнение кодовых точек для данных в Юникоде. Старые двоичные параметры сортировки SQL Server сравнивали первые символы как тип данных WCHAR, а затем следовало побитовое сравнение. В целях обратной совместимости семантика существующих двоичных параметров сортировки изменяться не будет.

Правила использования двоичных параметров сортировки

Если приложения взаимодействуют с ранними версиями SQL Server, использующими двоичные параметры сортировки, продолжайте применять их. Двоичные параметры сортировки могут быть более подходящим выбором для смешанной среды.

Правила использования параметров сортировки BIN2

Двоичные параметры сортировки в этом выпуске SQL Server включают новый набор параметров сортировки со сравнением исключительно элементов кода. Пользователи могут переходить на новые двоичные параметры сортировки для получения преимущества реального сравнения элементов кода. При разработке новых приложений рекомендуется использовать новые двоичные параметры сортировки. Новым суффиксом BIN2 определяются имена наборов параметров сортировки, реализующих новую семантику параметров сортировки элементов кода. Кроме того, добавлен новый флаг сравнения, соответствующий BIN2 для новой двоичной сортировки. Преимущества заключаются в более простой среде разработки и более ясной семантике.

См. также

Справочник

Настройка параметров сортировки и поддержка нескольких языков
Настройка параметров сортировки в программе установки


Использование параметров сортировки SQL

Использование параметров сортировки SQL |
 | См. также
Подготовка к установке SQL Server 2005 > Настройка параметров сортировки и поддержка нескольких языков >

Настройки параметров сортировки зависят от типа установки. Обычно следует выбрать параметры сортировки SQL Server, поддерживающие язык системы Microsoft Windows, который чаще всего используется в офисе. Чтобы определить язык системы Windows, используемый на компьютерах с Microsoft Windows 2000, выберите пункт Региональные параметры на панели управления и перейдите на вкладку Общие , если необходимо отобразить текущий язык и региональный стандарт системы. Для определения языка системы Windows, установленного на компьютерах с Windows Server 2003, щелкните Региональные и языковые параметры на панели управления и перейдите на вкладку Региональные параметры, чтобы отобразить текущий языковой стандарт системы. В большинстве случаев на компьютерах установлен тот язык системы Windows, который соответствует языковым требованиям пользователя, таким образом, установка Microsoft SQL Server автоматически определяет язык системы Windows и выбирает соответствующие параметры сортировки.

Параметры сортировки SQL Server управляют следующими аспектами.

  • Кодовая страница, используемая в SQL Server для хранения данных не в формате Юникод.

  • Правила, управляющие тем, как SQL Server сортирует и сравнивает символы, хранимые в типах данных не в формате Юникод. Программа установки SQL Server определит параметры сортировки Windows на компьютере, где устанавливается SQL Server, и автоматически выберет параметры сортировки для экземпляра SQL Server. Сортировка и сравнение могут не совпадать для символов в Юникоде и не в Юникоде.

Выбирайте параметры сортировки SQL Server, если:

  • Используется функция репликации существующими экземплярами SQL Server версии 6.5, SQL Server версии 7.0 или SQL Server 2000.

  • Код приложения зависит от поведения предыдущих параметров сортировки SQL Server.

Используйте следующую таблицу для определения необходимости выбора параметров сортировки. Если требуется, выберите нужные параметры сортировки.

Примечание.
Обновление SQL Server 7.0 или SQL Server 2000 до SQL Server 2005 сохраняет настройки параметров сортировки предыдущего выпуска SQL Server, нет необходимости выбирать параметры сортировки.

Задача Параметры сортировки

Установка на новую систему, причем не требуется синхронизация с какой-либо существующей системой

Используйте параметры сортировки, определенные программой установки, а затем выберите желаемый двоичный порядок, регистр и другие параметры.

Когда программа установки SQL Server определит, что на компьютере используется язык системы «Английский (США)», автоматически будут выбраны параметры сортировки SQL Server: Словарный порядок без учета регистра для использования с кодировкой 1252.

Чтобы выбрать равнозначные параметры сортировки Windows, нужно выбрать раздел Обозначение параметров сортировки, выбрать Latin1_General, снять флажок с учетом регистра и установить флажок с учетом диакритических знаков.

Обновить SQL Server 6.5 или SQL Server 7.0 на использующийся по умолчанию экземпляр SQL Server 2005, или установить использующийся по умолчанию экземпляр SQL Server 2005, который переключит версию с установкой SQL Server 6.5

Используйте параметры сортировки SQL Server, выбранные программой установки.

Синхронизировать (например, для репликации) с существующим экземпляром SQL Server 2005

Выберите SERVERPROPERTY(N'Collation') в окне редактора кода в существующем экземпляре и укажите Параметры сортировки. Дополнительные сведения см. в разделе SERVERPROPERTY (Transact-SQL). Если имя набора параметров сортировки для существующего экземпляра начинается с «SQL», выберите такие же параметры сортировки SQL Server в программе установки. Если имя набора параметров сортировки для существующего экземпляра начинается не с «SQL», то оно относится к имени набора параметров сортировки Windows и состоит из имени обозначения параметров сортировки и следующего за ним описания заданных параметров: двоичного режима, учета регистра, учета диакритических знаков, учета типа японской азбуки и учета ширины символов. Выберите то же обозначение параметров сортировки Windows и те же параметры сортировки в программе установки SQL Server.

Дополнительные сведения о вариантах работы параметров сортировки см. в разделе Стили сортировки в параметрах сортировки Windows.

Синхронизировать с существующей установкой SQL Server 6.5, SQL Server 7.0, или SQL Server 2000

Запустите процедуру sp_helpsort в существующей системе и затем используйте идентификатор сортировки для выбора параметров сортировки SQL Server, чтобы сделать экземпляр SQL Server 2005 совместимым с существующей копией.

Дополнительные сведения см. в разделе Выбор параметров сортировки SQL.

Синхронизировать с языком системы Windows другого компьютера

На панели управления найдите имя языкового стандарта в разделе Региональные параметры (Windows 2000 или Windows 2003) или Язык и региональные стандарты (Windows XP), а затем воспользуйтесь таблицей из раздела Настройка параметров сортировки в программе установки. Установите параметры сортировки как показано в разделе Стили сортировки в параметрах сортировки Windows электронной документации.
Примечание.
При выполнении действия, зависящего от параметров сортировки, параметры сортировки SQL Server, используемые объектом, на который существуют ссылки, должен использовать такую кодовую страницу, которая поддерживается установленной на компьютере операционной системой.

См. также

Справочник

Выбор параметров сортировки SQL
Установка кодовой страницы клиента

Другие ресурсы

Имя параметров сортировки SQL (Transact-SQL)


Выбор параметров сортировки SQL

Выбор параметров сортировки SQL |
 | См. также
Подготовка к установке SQL Server 2005 > Настройка параметров сортировки и поддержка нескольких языков > Использование параметров сортировки SQL >

В этом разделе представлены параметры сортировки для SQL Server для экземпляров , требующие совместимости с более ранними версиями SQL Server, в которых параметры сортировки не используются.

Следующие параметры сортировки SQL Server перечислены на странице Параметры сортировки мастера установки SQL Server.

Идентификатор порядка сортировки SQL | Имя порядка сортировки | Описание | Параметры сортировки SQL
31 | diction.437 | Лексикографический порядок с учетом регистра | SQL_Latin1_General_Cp437_CS_AS_KI_WI
32 | nocase.437 | Лексикографический порядок без учета регистра | SQL_Latin1_General_Cp437_CI_AS_KI_WI
33 | nocasepr.437 | Лексикографический порядок без учета регистра с предпочтением верхнему регистру | SQL_Latin1_General_Pref_Cp437_CI_AS_KI_WI
34 | noaccent.437 | Лексикографический порядок без учета регистра и без учета диакритических знаков | SQL_Latin1_General_Cp437_CI_AI_KI_WI
40 | cp437bin.437 | Двоичный | SQL_Latin1_General_Cp437_BIN
40 | cp850bin.850 | Двоичный | SQL_Latin1_General_Cp850_BIN
41 | diction.850 | Лексикографический порядок с учетом регистра | SQL_Latin1_General_Cp850_CS_AS_KI_WI
42 | nocase.850 | Лексикографический порядок без учета регистра | SQL_Latin1_General_Cp850_CI_AS_KI_WI
44 | noaccent.850 | Лексикографический порядок без учета регистра и без учета диакритических знаков | SQL_Latin1_General_Cp850_CI_AI_KI_WI
44 | nocase34.850 | Лексикографический порядок без учета регистра с предпочтением верхнему регистру | SQL_Latin1_General_Pref_Cp850_CI_AS_KI_WI
49 | nocase34.850 | Строгая совместимость с базами данных версии 1.x без учета регистра | SQL_1xCompat_Cp850_CI_AS_KI_WI
51 | diction.iso | Лексикографический порядок с учетом регистра | SQL_Latin1_General_Cp1_CS_AS_KI_WI
52 | nocase.iso | Лексикографический порядок без учета регистра | SQL_Latin1_General_Cp1_CI_AS_KI_WI
53 | nocasepr.iso | Лексикографический порядок без учета регистра с предпочтением верхнему регистру | SQL_Latin1_General_Pref_Cp1_CI_AS_KI_WI
54 | noaccent.iso | Лексикографический порядок без учета регистра и без учета диакритических знаков | SQL_Latin1_General_Cp1_CI_AI_KI_WI
55 | altdict.850 | Альтернативный лексикографический порядок с учетом регистра | SQL_AltDiction_Cp850_CS_AS_KI_WI
56 | altnocsp.850 | Альтернативный лексикографический порядок без учета регистра и с предпочтением верхнему регистру | SQL_AltDiction_Pref_Cp850_CI_AS_KI_WI
57 | altnoacc.850 | Альтернативный лексикографический порядок без учета регистра и без учета диакритических знаков | SQL_AltDiction_Cp850_CI_AI_KI_WI
58 | scan.850 | Скандинавский лексикографический порядок сортировки без учета регистра и с предпочтением верхнему регистру | SQL_Scandainavian_Pref_Cp850_CI_AS_KI_WI
59 | scandict.850 | Скандинавский лексикографический порядок сортировки с учетом регистра | SQL_Scandainavian_Cp850_CS_AS_KI_WI
60 | scannocase.850 | Скандинавский лексикографический порядок сортировки без учета регистра и без предпочтения регистра | SQL_Scandainavian_Cp850_CI_AS_KI_WI
61 | altnocs.850 | Альтернативный лексикографический порядок без учета регистра | SQL_AltDiction_Cp850_CI_AS_KI_WI
80 | binary.250 | Двоичный | SQL_Latin1_General_1250_BIN
81 | diction.250 | Лексикографический порядок с учетом регистра | SQL_Latin1_General_Cp1250_CS_AS_KI_WI
82 | nocase.250 | Лексикографический порядок без учета регистра | SQL_Latin1_General_Cp1250_CI_AS_KI_WI
83 | csydic.250 | Чешский лексикографический порядок с учетом регистра | SQL_Czech_Cp1250_CS_AS_KI_WI
84 | csync.250 | Чешский лексикографический порядок без учета регистра | SQL_Czech_Cp1250_CI_AS_KI_WI
85 | hundic.250 | Венгерский лексикографический порядок с учетом регистра | SQL_Hungarian_Cp1250_CS_AS_KI_WI
86 | hunnc.250 | Венгерский лексикографический порядок без учета регистра | SQL_Hungarian_Cp1250_CI_AS_KI_WI
87 | plkdic.250 | Польский лексикографический порядок с учетом регистра | SQL_Polish_Cp1250_CS_AS_KI_WI
88 | plknc.250 | Польский лексикографический порядок без учета регистра | SQL_Polish_Cp1250_CI_AS_KI_WI
89 | romdic.250 | Румынский лексикографический порядок с учетом регистра | SQL_Romanian_Cp1250_CS_AS_KI_WI
90 | romnc.250 | Румынский лексикографический порядок без учета регистра | SQL_Romanian_Cp1250_CI_AS_KI_WI
91 | shldic.250 | Хорватский лексикографический порядок с учетом регистра | SQL_Croatian_Cp1250_CS_AS_KI_WI
92 | shlnc.250 | Хорватский лексикографический порядок без учета регистра | SQL_Croatian_Cp1250_CI_AS_KI_WI
93 | skydic.250 | Словацкий лексикографический порядок с учетом регистра | SQL_Slovak_Cp1250_CS_AS_KI_WI
94 | skync.250 | Словацкий лексикографический порядок без учета регистра | SQL_Slovak_Cp1250_CI_AS_KI_WI
95 | slvdic.250 | Словенский лексикографический порядок с учетом регистра | SQL_Slovenian_Cp1250_CS_AS_KI_WI
96 | slvnc.250 | Словенский лексикографический порядок без учета регистра | SQL_Slovenian_Cp1250_CI_AS_KI_WI
104 | binary.250 | Двоичный | SQL_Latin1_General_1251_BIN
105 | diction.251 | Лексикографический порядок с учетом регистра | SQL_Latin1_General_Cp1251_CS_AS_KI_WI
106 | nocase.251 | Лексикографический порядок без учета регистра | SQL_Latin1_General_Cp1251_CI_AS_KI_WI
107 | ukrdic.251 | Украинский лексикографический порядок с учетом регистра | SQL_Ukrainian_Cp1251_CS_AS_KI_WI
108 | ukrnc.251 | Украинский лексикографический порядок без учета регистра | SQL_Ukrainian_Cp1251_CI_AS_KI_WI
112 | binary.253 | Двоичный | SQL_Latin1_General_1253_BIN
113 | diction.253 | Лексикографический порядок с учетом регистра | SQL_Latin1_General_Cp1253_CS_AS_KI_WI
114 | nocase.253 | Лексикографический порядок без учета регистра | SQL_Latin1_General_Cp1253_CI_AS_KI_WI
121 | graltdct.253 | Лексикографический порядок с учетом регистра и с учетом диакритических знаков | SQL_Latin1_General_Cp1253_CI_AS_KI_WI
124 | grnoacce.253 | Лексикографический порядок без учета регистра и без учета диакритических знаков | SQL_Latin1_General_Cp1253_CI_AI_KI_WI
128 | binary.254 | Двоичный | SQL_Latin1_General_1254_BIN
129 | diction.254 | Лексикографический порядок с учетом регистра | SQL_Latin1_General_Cp1254_CS_AS_KI_WI
130 | nocase.254 | Лексикографический порядок без учета регистра | SQL_Latin1_General_Cp1254_CI_AS_KI_WI
136 | binary.255 | Двоичный | SQL_Latin1_General_1255_BIN
137 | diction.255 | Лексикографический порядок с учетом регистра | SQL_Latin1_General_Cp1255_CS_AS_KI_WI
138 | nocase.255 | Лексикографический порядок без учета регистра | SQL_Latin1_General_Cp1255_CI_AS_KI_WI
144 | binary.256 | Двоичный | SQL_Latin1_General_1256_BIN
145 | diction.256 | Лексикографический порядок с учетом регистра | SQL_Latin1_General_Cp1256_CS_AS_KI_WI
146 | nocase.256 | Лексикографический порядок без учета регистра | SQL_Latin1_General_Cp1256_CI_AS_KI_WI
152 | binary.257 | Двоичный | SQL_Latin1_General_1257_BIN
153 | diction.257 | Лексикографический порядок с учетом регистра | SQL_Latin1_General_Cp1257_CS_AS_KI_WI
154 | nocase.257 | Лексикографический порядок без учета регистра | SQL_Latin1_General_Cp1257_CI_AS_KI_WI
155 | etidic.257 | Эстонский лексикографический порядок с учетом регистра | SQL_Estonian_Cp1257_CS_AS_KI_WI
156 | etinc.257 | Эстонский лексикографический порядок без учета регистра | SQL_Estonian_Cp1257_CI_AS_KI_WI
157 | lvidic.257 | Латвийский лексикографический порядок с учетом регистра | SQL_Latvian_Cp1257_CS_AS_KI_WI
158 | lvinc.257 | Латвийский лексикографический порядок без учета регистра | SQL_Latvian_Cp1257_CI_AS_KI_WI
159 | lthdic.257 | Литовский лексикографический порядок с учетом регистра | SQL_Lithuanian_Cp1257_CS_AS_KI_WI
160 | lthnc.257 | Литовский лексикографический порядок без учета регистра | SQL_Lithuanian_Cp1257_CI_AS_KI_WI
183 | danonocp.iso | Датский/норвежский лексикографический порядок без учета регистра с предпочтением верхнему регистру | SQL_Danish_Pref_Cp1_CI_AS_KI_WI
184 | islanocp.iso | Шведский/финский [телефонный] лексикографический порядок без учета регистра с предпочтением верхнему регистру | SQL_SwedishPhone_Pref_Cp1_CI_AS_KI_WI
185 | svf2nocp.iso.iso | Шведский/финский [стандартный] лексикографический порядок без учета регистра с предпочтением верхнему регистру | SQL_SwedishStd_Pref_Cp1_CI_AS_KI_WI
186 | islanocp.iso | Исландский лексикографический порядок без учета регистра с предпочтением верхнему регистру | SQL_Icelandic_Pref_Cp1_CI_AS_KI_WI
Примечание.
Каждое имя набора параметров сортировки SQL Server имеет эквивалентную строку в коде Transact-SQL. Список идентификаторов порядка сортировки и их эквивалентов в языке Transact-SQL см. в разделе Имя параметров сортировки SQL (Transact-SQL).

См. также

Справочник

Настройка параметров сортировки в программе установки

Основные понятия

Использование параметров сортировки SQL


Установка кодовой страницы клиента

Установка кодовой страницы клиента |
 | См. также
Подготовка к установке SQL Server 2005 > Настройка параметров сортировки и поддержка нескольких языков >

Кодовая страница, используемая клиентом, определяется установками операционной системы. Чтобы установить кодовую страницу клиента в операционных системах Microsoft Windows 2000, Microsoft Windows XP или Microsoft Windows Server 2003, используйте раздел Язык и региональные стандарты панели управления, как описано в документации к Windows.

См. также

Справочник

Настройка параметров сортировки и поддержка нескольких языков


Работа с несколькими версиями SQL Server

Работа с несколькими версиями SQL Server |
 | См. также
Подготовка к установке SQL Server 2005 >

Дата обновления: 12 декабря 2006 г.

поддерживает на одном компьютере несколько экземпляров компонента Database Engine, служб и . Можно обновлять предыдущие версии SQL Server либо устанавливать SQL Server 2005 на компьютере, на котором уже установлены предыдущие версии SQL Server.

Применение SQL Server 2005 параллельно с предыдущими версиями SQL Server

Можно установить SQL Server 2005 на компьютер, где уже запущены экземпляры SQL Server предыдущей версии. Поскольку экземпляр по умолчанию уже есть на компьютере, SQL Server 2005 будет установлен как именованный экземпляр.

Внимание! В SQL Server 2005, установленном параллельно с предыдущими версиями SQL Server, службы SQL Server 2005 могут использовать учетные записи только из глобальной группы домена. Кроме того, учетные записи, используемые службами SQL Server 2005, не должны входить в локальную группу администраторов. В противном случае система безопасности может повести себя непредвиденным образом.

Поддержка параллельной работы

Параллельная поддержка | SQL Server 2000 (32-разрядный) | SQL Server 2000 (64-разрядный) | SQL Server 2005 (32-разрядный) | SQL Server 2005 (64-разрядный) IA64 | SQL Server 2005 (64-разрядный) X64
SQL Server 7.0 | Да | Нет | Да | Нет | Нет
SQL Server 2000 (32-разрядный) | Да | Нет | Да | Нет 1 | Да
SQL Server 2000 (64-разрядный) | Нет | Да | Нет | Да | Нет
SQL Server 2005 (32-разрядный) | Да | Нет | Да | Нет | Да
SQL Server 2005 (64-разрядный) IA64 | Нет | Да | Нет | Да | Нет
SQL Server 2005 (64-разрядный) X64 | Да | Нет | Да | Нет | Да

132-разрядные выпуски SQL Server поддерживаются в режиме WOW64 только в версиях X64 64-разрядных операционных систем. 32-разрядные выпуски SQL Server не поддерживаются в режиме WOW64 в версиях IA64 64-разрядных операционных систем.

См. также

Задачи

Как установить SQL Server 2005 (программа установки)

Справочник

Требования к оборудованию и программному обеспечению для установки SQL Server 2005

Основные понятия

Использование помощника по обновлению для подготовки к обновлениям

Другие ресурсы

Обновление до SQL Server 2005
Обратная совместимость

Журнал изменений

Версия Журнал

12 декабря 2006 г.

Измененное содержимое:
  • Добавлены рекомендации по безопасности для учетных записей служб при параллельной установке.


Разделы руководства по подготовке SQL Server 2005

Разделы руководства по подготовке SQL Server 2005 |
 | См. также
Подготовка к установке SQL Server 2005 >

Этот раздел содержит сведения о том, как подготовить SQL Server 2005.

В этом разделе

  • Как изменить настройки операционной системы для поддержки локализованных версий

  • Как отключить протокол NetBIOS через TCP/IP

  • Как отключить протокол SMB

  • Как проверить разрешения для служб SQL Server

См. также

Справочник

Настройка параметров сортировки и поддержка нескольких языков
Настройка учетных записей служб Windows


Как изменить настройки операционной системы для поддержки локализованных версий

Как изменить настройки операционной системы для поддержки локализованных версий |
 | См. также
Подготовка к установке SQL Server 2005 > Разделы руководства по подготовке SQL Server 2005 >

Локализованные версии поддерживаются на английских версиях поддерживаемых операционных систем с помощью настроек пакета многоязыкового интерфейса Microsoft Windows (MUI).

Однако перед установкой локализованной версии SQL Server 2005 на сервер, работающий под управлением англоязычной версии операционной системы с локализованными настройками MUI, необходимо проверить некоторые настройки операционной системы. Необходимо убедиться, что следующие настройки операционной системы соответствуют языку локализации устанавливаемой версии SQL Server:

  • Настройки пользовательского интерфейса операционной системы

  • Пользовательские настройки языка и региональных стандартов операционной системы

  • Настройки языка системы

Если настройки не соответствуют языку локализации устанавливаемой версии SQL Server, используйте следующие процедуры, чтобы правильно установить эти параметры операционной системы.

Внимание!
Установка экземпляров SQL Server с различными языковыми версиями на одном компьютере не поддерживается. Например: экземпляры немецкой версии SQL Server 2005 и португальской версии SQL Server 2005 не поддерживаются одновременно на одном компьютере.

Изменение настройки пользовательского интерфейса операционной системы

  1. При необходимости установите интерфейс MUI операционной системы, соответствующий локализованным версиям SQL Server 2005.

  2. На панели управления откройте Язык и региональные стандарты.

  3. На закладке Языки на панели Язык, используемый в меню и диалоговых окнах выберите значение из раскрывающегося списка.

    Этот параметр влияет на язык интерфейса пользователя SQL Server 2005, поэтому должен совпадать с версией локализации SQL Server 2005.

  4. Нажмите кнопку Применить, чтобы подтвердить изменения, а затем ОК, чтобы закрыть окно.

Изменение настройки языкового стандарта операционной системы

  1. При необходимости установите интерфейс MUI операционной системы, соответствующий локализованным версиям SQL Server 2005.

  2. На панели управления откройте Язык и региональные стандарты.

  3. На вкладке Региональные параметры выберите значение из раскрывающегося списка в области Языковые стандарты и форматы.

    Этот параметр повлияет на форматирование данных, характерное для страны.

  4. Нажмите кнопку Применить, чтобы подтвердить изменения, а затем ОК, чтобы закрыть окно.

Изменение настройки языка системы

  1. При необходимости установите интерфейс MUI операционной системы, соответствующий локализованным версиям SQL Server 2005.

  2. На панели управления откройте Язык и региональные стандарты.

  3. На закладке Дополнительно в области Язык программ, не поддерживающих Юникод, выберите значение из раскрывающегося списка.

    Эта настройка дает возможность программе установки SQL Server выбрать наилучшие параметры сортировки по умолчанию для установки SQL Server 2005.

  4. Нажмите кнопку Применить, чтобы подтвердить изменения, а затем ОК, чтобы закрыть окно.

См. также

Справочник

Настройка параметров сортировки и поддержка нескольких языков
Требования к оборудованию и программному обеспечению для установки SQL Server 2005

Другие ресурсы

Разделы руководства по подготовке SQL Server 2005


Как отключить протокол NetBIOS через TCP/IP

Как отключить протокол NetBIOS через TCP/IP |
 | См. также
Подготовка к установке SQL Server 2005 > Разделы руководства по подготовке SQL Server 2005 >

Дата обновления: 5 декабря 2005 г.

Серверы сети должны запретить все неиспользуемые протоколы, включая протокол NetBIOS. Веб-серверы и серверы систем доменных имен (DNS) не требуют протокола NetBIOS. Этот протокол необходимо отключить, чтобы снизить угрозу сбора сведений о пользователях.

Запрещение NetBIOS через TCP/IP

  1. В меню Пуск щелкните правой кнопкой мыши Мой компьютер, а затем выберите Управление.

  2. Раскройте пункт Служебные программы и выберите Диспетчер устройств.

  3. Щелкните правой кнопкой мыши Диспетчер устройств, наведите курсор мыши на пункт Вид, а затем выберите пункт Показать скрытые устройства.

  4. Раскройте пункт Драйверы устройств не Plug and Play.

  5. Щелкните правой кнопкой мыши NetBIOS через TCP/IP и выберите Отключить.

    Это отключит сетевой опрос портов TCP/445 и UDP/445 для средства прослушивания SMB.

    Примечание.
    Данная процедура отключает работу драйвера netbt.sys. Вкладка WINS диалогового окна Дополнительные параметры TCP/IP содержит флажок Отключить NetBIOS через TCP/IP. Установка этого параметра только отключает службу сеанса NetBIOS (которая прослушивает порт 139 протокола TCP). NetBIOS не отключается полностью.

См. также

Задачи

Как отключить протокол SMB

Основные понятия

Анализ безопасности при установке SQL Server

Другие ресурсы

Разделы руководства по подготовке SQL Server 2005


Как отключить протокол SMB

Как отключить протокол SMB |
 | См. также
Подготовка к установке SQL Server 2005 > Разделы руководства по подготовке SQL Server 2005 >

Дата обновления: 5 декабря 2005 г.

На серверах в демилитаризованной зоне сети необходимо отключить все ненужные протоколы, в том числе протокол SMB. Веб-серверам и DNS-серверам не нужен протокол SMB. Этот протокол необходимо отключить, чтобы противостоять угрозе сбора сведений о пользователях.

Отключение протоколаSMB

  1. В меню Пуск выберите Настройки и щелкните Сетевые подключения.

    Щелкните правой кнопкой мыши подключение к Интернету и выберите пункт Свойства.

  2. Установите флажок Клиент для сетей Microsoft и нажмите кнопку Удалить.

  3. Выполните шаги для удаления.

  4. Выберите Службу доступа к файлам и принтерам сетей Microsoft и нажмите кнопку Удалить.

  5. Выполните шаги для удаления.

Отключение протокола SMB на серверах, доступных из Интернета

  • В окне «Подключение по локальной сети — свойства» используйте диалоговое окно Свойства: Протокол Интернета (TCP/IP), чтобы удалить компоненты Совместный доступ к файлам и принтерам сетей Microsoft и Клиент для сетей Microsoft.

См. также

Задачи

Как отключить протокол NetBIOS через TCP/IP

Основные понятия

Анализ безопасности при установке SQL Server

Другие ресурсы

Разделы руководства по подготовке SQL Server 2005


Как проверить разрешения для служб SQL Server

Как проверить разрешения для служб SQL Server |
 | См. также
Подготовка к установке SQL Server 2005 > Разделы руководства по подготовке SQL Server 2005 >

Дата обновления: 5 декабря 2005 г.

Обычно и SQL Server, и агенту SQL Server присваивается одна и та же учетная запись: либо «Локальная система», либо учетная запись домена. Однако параметры каждой службы можно настроить в процессе установки. Дополнительные сведения о модификации сведений учетной записи для каждой службы во время установки см. в разделе Учетная запись службы.

Примечание безопасности.
Всегда запускайте службы SQL Server с наименьшими возможными правами доступа.

Проверка разрешений для служб SQL Server

  1. Нажмите кнопку Пуск, откройте Панель управления, а затем Администрирование.

  2. Откройте Локальную политику безопасности, выберите папку Локальные политики, а затем дважды щелкните Назначение прав пользователя.

  3. Щелкните правой кнопкой мыши разрешение и выберите пункт Свойства.

  4. Убедитесь, что в диалоговом окне Свойства указана учетная запись, под которой будет выполняться агент SQL Server. Если она не указана, щелкните Добавить пользователя или группу, а затем добавьте учетную запись пользователя, под которой будет запущена служба агента SQL Server.

  5. После того как были сделаны необходимые изменения, нажмите кнопку ОК.

  6. Повторите этот процесс для каждого разрешения и каждой службы.

Безопасность

Настройте службы для SQL Server 2005 так, чтобы они работали с минимальными разрешениями.

См. также

Справочник

Настройка учетных записей служб Windows
Учетная запись службы
Учетные записи служб (кластеры)

Основные понятия

Анализ безопасности при установке SQL Server


Обновление до SQL Server 2005

Обновление до SQL Server 2005 |
 | См. также

Возможно непосредственное обновление экземпляров SQL Server 2000 с пакетом обновления 3 (SP3) или более поздних версий, а также экземпляров SQL Server 7.0 с пакетом обновления 4 (SP4) или более поздних версий до SQL Server 2005. С помощью программы установки возможно проведение большинства операций по обновлению; однако некоторые компоненты поддерживают или запрашивают проведение миграции приложений или решений после запуска программы установки. Дополнительные сведения по обновлению компонентов SQL Server см. в разделе Обновление компонентов SQL Server.

Перед запуском программы установки для обновления до SQL Server 2005 необходимо просмотреть системные требования и матрицу обновления. Чтобы просмотреть системные требования, см. раздел Подготовка к установке SQL Server 2005. Чтобы просмотреть матрицу обновления, см. раздел Обновления версий и выпусков.

Просмотрев системные требования и матрицу обновления, запустите помощник по обновлению SQL Server, чтобы проанализировать экземпляры SQL Server 2000 и SQL Server 7.0. Помощник по обновлению создает список проблем, характерных для установленных экземпляров. Эти проблемы необходимо устранить до или после обновления. Программа установки SQL Server обнаружит критические препятствия, которые могут помешать обновлению до версии SQL Server 2005, но не выдаст список проблем, которые могут повлиять на приложения.

В этом разделе

Раздел | Описание
Обновления версий и выпусков | Выдает список правил для обновления одной версии SQL Server до другой или для обновления до выпуска SQL Server той же версии.
Использование помощника по обновлению для подготовки к обновлениям | Описывает помощник по обновлению, который анализирует экземпляры SQL Server 2000 и SQL Server 7.0 и выдает отчет об обнаруженных проблемах, возникших при обновлении.
Обновление компонентов SQL Server | Содержит сведения и инструкции по обновлению отдельных компонентов SQL Server до SQL Server 2005.
Обратная совместимость | Перечисляет важные изменения, которые могут повлиять на приложения в процессе обновления до SQL Server 2005.

См. также

Основные понятия

Подготовка к установке SQL Server 2005
Установка SQL Server 2005


Обновления версий и выпусков

Обновления версий и выпусков |
 | См. также
Обновление до SQL Server 2005 >

Дата обновления: 14 апреля 2006 г.

В этом выпуске SQL Server 2005 поддерживаются следующие сценарии обновления.

Исходная версия | Поддерживаемые варианты обновления
SQL Server 7.0 Enterprise Edition с пакетом обновления 4 (SP4) | SQL Server 2005 Enterprise Edition
SQL Server 7.0 Developer Edition с пакетом обновления 4 (SP4) | SQL Server 2005 Enterprise Edition SQL Server 2005 Developer Edition
SQL Server 7.0 Standard Edition с пакетом обновления 4 (SP4) | SQL Server 2005 Standard Edition SQL Server 2005 Enterprise Edition
SQL Server 7.0 Desktop Edition с пакетом обновления 4 (SP4) | SQL Server 2005 Standard Edition SQL Server 2005 Workgroup Edition
SQL Server 7.0 Evaluation Edition с пакетом обновления 4 (SP4) | Обновления не поддерживаются
SQL Server Desktop Engine (MSDE) 7.0 с пакетом обновления 4 (SP4) | SQL Server 2005 Express Edition
SQL Server 2000 Enterprise Edition с пакетом обновления 3 (SP3) или более поздней версии1 | SQL Server 2005 Enterprise Edition
SQL Server 2000Developer Edition с пакетом обновления 3 (SP3) или более поздней версии1 | SQL Server 2005 Developer Edition
SQL Server 2000Standard Edition с пакетом обновления 3 (SP3) или более поздней версии1 | SQL Server 2005 Enterprise Edition SQL Server 2005 Developer Edition SQL Server 2005 Standard Edition
SQL Server 2000Workgroup Edition с пакетом обновления 3 (SP3) или более поздней версии1 | SQL Server 2005 Enterprise Edition SQL Server 2005 Developer Edition SQL Server 2005 Standard Edition SQL Server 2005 Workgroup Edition
SQL Server 2000Personal Edition с пакетом обновления 3 (SP3) или более поздней версии1 | SQL Server 2005 Standard Edition SQL Server 2005 Workgroup Edition SQL Server 2005 Express Edition SQL Server 2005 Express Edition with Advanced Services
SQL Server 2000Evaluation Edition с пакетом обновления 3 (SP3) или более поздней версии1 | SQL Server 2005 Evaluation Edition
SQL Server Desktop Engine (MSDE) 2000 с пакетом обновления 3 (SP3) или более поздней версии1 | SQL Server 2005 Workgroup Edition SQL Server 2005 Express Edition SQL Server 2005 Express Edition with Advanced Services
SQL Server 2000 Enterprise Edition для 64-разрядных систем с архитектурой IA64 | SQL Server 2005 Enterprise Edition для 64-разрядных систем с архитектурой IA64
SQL Server 2000 Developer Edition для 64-разрядных систем с архитектурой IA64 | SQL Server 2005 Enterprise Edition для 64-разрядных систем с архитектурой IA64 SQL Server 2005 Developer Edition для 64-разрядных систем с архитектурой IA64
SQL Server 2005 Developer Edition1 | SQL Server 2005 Enterprise Edition SQL Server 2005 Standard Edition SQL Server 2005 Workgroup Edition
SQL Server 2005 Standard Edition1 | SQL Server 2005 Enterprise Edition SQL Server 2005 Developer Edition
SQL Server 2005 Workgroup Edition1 | SQL Server 2005 Enterprise Edition SQL Server 2005 Developer Edition SQL Server 2005 Standard Edition
SQL Server 2005 Evaluation Edition1 | SQL Server 2005 Enterprise Edition SQL Server 2005 Developer Edition SQL Server 2005 Standard Edition SQL Server 2005 Workgroup Edition SQL Server 2005 Express Edition
SQL Server 2005 Express Edition1 | SQL Server 2005 Enterprise Edition SQL Server 2005 Developer Edition SQL Server 2005 Standard Edition SQL Server 2005 Workgroup Edition SQL Server 2005 Express Edition with Advanced Services
SQL Server 2005 Express Edition with Advanced Services1 | SQL Server 2005 Enterprise Edition SQL Server 2005 Developer Edition SQL Server 2005 Standard Edition SQL Server 2005 Workgroup Edition
SQL Server 2005 Developer Edition для 64-разрядных систем с архитектурой IA64 | SQL Server 2005 Enterprise Edition для 64-разрядных систем с архитектурой IA64 SQL Server 2005 Standard Edition для 64-разрядных систем с архитектурой IA64
SQL Server 2005 Developer Edition для 64-разрядных систем с архитектурой X64 | SQL Server 2005 Enterprise Edition для 64-разрядных систем с архитектурой X64 SQL Server 2005 Standard Edition для 64-разрядных систем с архитектурой X64
SQL Server 2005 Standard Edition для 64-разрядных систем с архитектурой IA64 | SQL Server 2005 Enterprise Edition для 64-разрядных систем с архитектурой IA64 SQL Server 2005 Developer Edition для 64-разрядных систем с архитектурой IA64
SQL Server 2005 Standard Edition для 64-разрядных систем с архитектурой X64 | SQL Server 2005 Enterprise Edition для 64-разрядных систем с архитектурой X64 SQL Server 2005 Developer Edition для 64-разрядных систем с архитектурой X64
SQL Server 2005 Evaluation Edition для 64-разрядных систем с архитектурой IA64 | SQL Server 2005 Enterprise Edition для 64-разрядных систем с архитектурой IA64 SQL Server 2005 Developer Edition для 64-разрядных систем с архитектурой IA64 SQL Server 2005 Standard Edition для 64-разрядных систем с архитектурой IA64
SQL Server 2005 Evaluation Edition для 64-разрядных систем с архитектурой X64 | SQL Server 2005 Enterprise Edition для 64-разрядных систем с архитектурой X64 SQL Server 2005 Developer Edition для 64-разрядных систем с архитектурой X64 SQL Server 2005 Standard Edition для 64-разрядных систем с архитектурой X64

1Этот выпуск SQL Server можно обновить до SQL Server 2005 на 32-разрядной подсистеме (WOW64) 64-разрядной версии сервера.

Замечания по обновлению

  • После обновления до SQL Server 2005 с другого выпуска SQL Server 2005 необходимо заново применить все обновления и исправления к обновленному экземпляру SQL Server.

  • Многоверсионные экземпляры в SQL Server 2005 не поддерживаются. Номера версий компонента Database Engine, служб Analysis Services и служб Reporting Services для экземпляра SQL Server 2005 должны совпадать.

  • Перед обновлением до SQL Server 2005 включите проверку подлинности Windows для агента SQL Server и убедитесь, что учетная запись службы «SQL Server, агент» находится в группе SQL Server sysadmin.

  • Перед обновлением с одного выпуска SQL Server 2005 до другого проверьте, что используемые функции поддерживаются и в том выпуске, до которого производится обновление. Дополнительные сведения см. в разделе о соответствующих компонентах в Возможности, поддерживаемые различными выпусками SQL Server 2005.

  • Чтобы экземпляр SQL Server можно было обновить до отказоустойчивого кластера SQL Server 2005, обновляемый экземпляр должен быть отказоустойчивым кластером. Чтобы обновить изолированный экземпляр SQL Server до отказоустойчивого кластера SQL Server 2005, установите новый отказоустойчивый кластер SQL Server 2005, а затем перенесите пользовательские базы данных из изолированного экземпляра с помощью мастера копирования баз данных. Дополнительные сведения об обновлении см. в разделе Как произвести обновление до отказоустойчивого кластера SQL Server 2005 (установка). Дополнительные сведения о миграции баз данных см. в разделе Использование мастера копирования баз данных.

  • Обновление 32-разрядного экземпляра сервера SQL Server 2000 из 32-разрядной подсистемы (WOW64) 64-разрядного сервера до SQL Server 2005 (64-разрядный) на платформе X64 не поддерживается. Однако можно обновить 32-разрядный экземпляр SQL Server до SQL Server 2005 на WOW64 64-разрядного сервера, как отмечается в приводимой выше таблице. Можно также выполнить резервное копирование или отсоединить базы данных от 32-разрядного экземпляра SQL Server 2000 и восстановить или прикрепить их к экземпляру SQL Server 2005 (64-разрядная версия), если базы данных не опубликованы в репликации. В этом случае необходимо также повторно создать имена входа и другие объекты пользователя в системных базах данных master, msdb и model.

Добавление компонентов в экземпляр SQL Server 2005

Добавить компоненты к существующей установке SQL Server 2005 можно, открыв окно Установка и удаление программ из панели управления и выбрав экземпляр SQL Server, к которому нужно добавить компоненты или из которого нужно удалить компоненты. Дополнительные сведения см. в разделе Как изменить компоненты существующего экземпляра SQL Server 2005 (программа установки).

Поддержка версий на разных языках

Для обновлений:

  • Англоязычные версии SQL Server можно обновить до любой локализованной версии SQL Server 2005.

  • Локализованные версии SQL Server можно обновить до локализованных версий SQL Server 2005 на том же языке.

  • Локализованную версию SQL Server нельзя обновить до англоязычной версии SQL Server 2005.

  • Локализованные версии SQL Server нельзя обновить до локализованных версий SQL Server 2005 на других языках.

Дополнительная поддержка версий на разных языках:

  • Английская версия SQL Server 2005 поддерживается на всех локализованных версиях поддерживаемых операционных систем.

  • Локализованные версии SQL Server 2005 поддерживаются на локализованных операционных системах на том же языке, что и локализованная версия SQL Server.

  • Локализованные версии SQL Server 2005 также поддерживаются в английских версиях поддерживаемых операционных систем с помощью пакета многоязыкового пользовательского интерфейса Windows. Однако необходимо проверить определенные настройки операционной системы перед установкой локализованной версии SQL Server 2005 на сервер под управлением английской версии операционной системы с настройками MUI, отличными от английского языка. Необходимо убедиться, что следующие настройки операционной системы соответствуют языку локализации SQL Server:

    • Настройки пользовательского интерфейса операционной системы

    • Пользовательские настройки языкового стандарта операционной системы

    • Настройки языка системы

    Если эти настройки операционной системы не соответствуют языку локализованной версии SQL Server, их необходимо изменить так, как описано в разделе Как изменить настройки операционной системы для поддержки локализованных версий.

См. также

Справочник

Параметры установки
Требования к оборудованию и программному обеспечению для установки SQL Server 2005

Основные понятия

Подготовка к установке SQL Server 2005


Использование помощника по обновлению для подготовки к обновлениям

Использование помощника по обновлению для подготовки к обновлениям |
 | См. также
Обновление до SQL Server 2005 >

Дата обновления: 17 июля 2006 г.

Помощник по обновлению Microsoft SQL Server 2005 поможет провести подготовку к обновлениям SQL Server 2005. Помощник по обновлению анализирует установленные компоненты SQL Server 2000 или SQL Server 7.0 и создает отчет, содержащий список проблем, которые должны быть решены перед началом обновления или после обновления до SQL Server 2005.

Как работает помощник по обновлению

После запуска помощника по обновлению появляется его домашняя страница. С домашней страницы можно запустить следующие средства:

  • мастер анализа помощника по обновлению;

  • средство просмотра отчетов помощника по обновлению;

  • справка помощника по обновлению.

При первом запуске помощника по обновлению следует запустить мастер анализа помощника по обновлению, чтобы проанализировать компоненты SQL Server. После того как мастер закончит анализ, можно просмотреть итоговый отчет с помощью средства просмотра отчетов помощника по обновлению. Каждый отчет предоставляет ссылки на сведения из справки помощника по обновлению, которые помогут исправить или обойти возникшие проблемы.

Анализ помощника по обновлению

Помощник по обновлению анализирует следующие компоненты SQL Server:

  • Database Engine

  • Analysis Services

  • Notification Services

  • Reporting Services

  • Integration Services, ранее известная как службы Data Transformation Services (DTS)

Соответствующий анализатор запускается из контекста помощника по обновлению для каждого компонента SQL Server. В ходе анализа проверяются объекты, доступные для индивидуальных анализаторов, такие как сценарии, хранимые процедуры, триггеры и файлы трассировки. Помощник по обновлению не может анализировать настольные приложения и зашифрованные хранимые процедуры.

На выходе каждого отдельного анализатора создается отчет в формате XML для этого компонента. Просмотреть отчет в формате XML можно с помощью средства просмотра отчетов помощника по обновлению.

Примечание.
Отчеты могут содержать элемент «другие проблемы обновления». Этот элемент содержит ссылку на список проблем, которые не были обнаружены помощником по обновлению, но могут присутствовать на сервере или в приложениях. Следует просмотреть список необнаруживаемых проблем и определить, какие изменения необходимо внести в сервер или приложения из-за необнаруживаемых проблем.

Установка и запуск помощника по обновлению

Место, в которое необходимо установить помощник по обновлению , зависит от того, что необходимо анализировать. Помощник по обновлению поддерживает удаленный анализ всех поддерживаемых компонентов, за исключением служб Reporting Services. Если просмотр экземпляров служб Reporting Services не производится, помощник по обновлению может быть установлен на любой компьютер, который способен подключаться к экземпляру SQL Server и удовлетворяет требованиям к установке помощника по обновлению. Для просмотра экземпляров служб Reporting Services следует установить помощник по обновлению на сервер отчетов.

Помощник по обновлению доступен в папке Servers\redist\Upgrade Advisor на диске SQL Server 2005 и на веб-узле Центр загрузки Майкрософт. Ниже перечислены необходимые условия для установки помощника по обновлению.

  • Windows 2000 с пакетом обновления 4 (SP4), Windows XP с пакетом обновления 2 (SP2), Windows Server 2003 с пакетом обновления 1 (SP1) или более поздние версии.

  • Установщик Microsoft Windows версии 3.1 или более поздняя версия.

    Платформа .NET Framework версии 2.0 требует наличия установщика Windows версии 3.1. Установщик Windows можно установить с веб-узла установщика Windows версии 3.1.

  • Платформа Microsoft .NET Framework версии 2.0 или более поздней. Платформа .NET Framework версии 2.0 доступна на носителе с SQL Server 2005 и на этой странице Центр разработки для платформы Microsoft .NET Framework.

    • Чтобы установить платформу .NET Framework версии 2.0 с носителя SQL Server 2005, перейдите в корневой каталог диска, дважды щелкните папку redist, дважды щелкните папку 2.0 и запустите файл dotnetfx.exe (для 32-разрядной версии) или dotnetfx64.exe (для 64-разрядной версии) в зависимости от операционной системы.

  • Наличие объектов SQL Server 2000 DSO является необходимым условием для поиска проблем обновления в службах Analysis Services. Чтобы установить объекты DSO, вставьте носитель с SQL Server 2000 в дисковод. Запустится программа установки SQL Server 2000. Щелкните Установить компоненты SQL Server 2000. Чтобы начать установку служб Analysis Services, щелкните Службы Analysis Services. В области Выбранные компоненты убедитесь, что компонент Decision Support Objects выбран.

  • Для просмотра пакетов служб DTS необходимы клиентские компоненты SQL Server 2000. Если на компьютере эти компоненты отсутствуют, вставьте диск с SQL Server 2000 в дисковод и произведите их установку.

Чтобы установить помощник по обновлению из веб-узла, нажмите кнопку загрузки на странице загрузки. Затем можно либо сразу начать установку, либо сохранить файл SQLUASetup.msi для последующего запуска. При установке с диска продукта запустите SQLUASetup.msi непосредственно с диска.

После установки помощник по обновлению можно запустить из меню «Пуск» следующим образом.

  • Нажмите Пуск, выберите пункт Все программы, затем Microsoft SQL Server 2005, а затем выберите Помощник по обновлению SQL Server 2005.

Дополнительные сведения о запуске помощника по обновлениям см. в справке помощника по обновлению и в файле Readme. Они устанавливаются вместе с помощником по обновлению.

См. также

Основные понятия

Работа с несколькими версиями SQL Server

Другие ресурсы

Обновление до SQL Server 2005
Обратная совместимость

Журнал изменений

Версия Журнал

17 июля 2006 г.

Измененное содержимое:
  • Добавлено примечание о проблемах обновления, которые не обнаруживаются помощником по обновлению.

  • Добавлено местоположение файла SQLUASetup.msi на диске продукта.


Обновление компонентов SQL Server

Обновление компонентов SQL Server |
 | См. также
Обновление до SQL Server 2005 >

В этом разделе приводятся сведения об обновлении и миграции компонентов из предыдущей версии в SQL Server 2005 и между выпусками SQL Server 2005. Обновление обычно выполняется программой установки SQL Server. Перенос обычно выполняется после установки или обновления SQL Server 2005.

В этом разделе

Подраздел | Описание
Обновление компонента Database Engine | Содержит сведения об обновлении Database Engine из SQL Server 7.0 или SQL Server 2000.
Обновление и миграция служб Analysis Services | Содержит сведения о параметрах обновления для служб Analysis Services и об обновлении и переносе баз данных служб Analysis Services.
Обновление или миграция служб DTS | Содержит сведения об обновлении до служб SQL Server 2005 Integration Services (SSIS) и о переносе пакетов в SQL Server 2005.
Миграция экземпляров служб Notification Services | Содержит сведения о миграции экземпляров служб Notification Services с версии Notification Services 2.0 или обновлении до выпуска SQL Server 2005 с более широкими возможностями.
Обновление служб Reporting Services | Описывает требования и шаги для обновления служб Reporting Services и содержит сведения о том, какие компоненты удаляются.
Обновление реплицируемых баз данных | Содержит сведения об обновлении реплицированных баз данных.
Разделы руководства по обновлению компонентов SQL Server | Содержит пошаговые инструкции по обновлению компонентов SQL Server.

См. также

Основные понятия

Установка SQL Server 2005

Другие ресурсы

Обновление до SQL Server 2005


Обновление компонента Database Engine

Обновление компонента Database Engine |
 | См. также
Обновление до SQL Server 2005 > Обновление компонентов SQL Server >

Дата обновления: 12 декабря 2006 г.

Можно обновить компонент с версии 7.0 или до . Дополнительные сведения о поддерживаемых способах обновления см. в разделе Обновления версий и выпусков.

Программа установки SQL Server 2005 может обновить предыдущую версию SQL Server с минимальным участием пользователя. Однако тщательная подготовка и знание процесса установки поможет с легкостью избежать или решить любые возникающие проблемы.

Этот раздел предоставляет сведения, которые понадобятся для подготовки и понимания процесса обновления; он содержит следующие подразделы.

  • Известные проблемы, связанные с обновлением.

  • Задачи и вопросы, предшествующие обновлению.

  • Ссылки на методические разделы по обновлению Database Engine до SQL Server 2005.

  • Ссылки на методические разделы по миграции баз данных в SQL Server 2005.

  • Вопросы, касающиеся отказоустойчивых кластеров.

  • Задачи и вопросы, следующие за обновлением.

Известные проблемы, связанные с обновлением

Перед обновлением Database Engine до SQL Server 2005 просмотрите повторно раздел Обратная совместимость компонента SQL Server 2005 Database Engine. Сведения об обратной совместимости других компонентов SQL Server см. в разделе Обратная совместимость.

Важно!
Перед обновлением от одного выпуска SQL Server 2005 до другого проверьте, что используемые функции поддерживаются также и в выпуске, до которого производится обновление. Дополнительные сведения см. в разделе о соответствующих компонентах в Возможности, поддерживаемые различными выпусками SQL Server 2005.

Контрольный список действий перед обновлением

Усовершенствование предыдущей версии SQL Server до SQL Server 2005 поддерживается программой установки SQL Server 2005. Можно также произвести миграцию баз данных из предыдущих версий SQL Server в экземпляр SQL Server 2005. Миграция может осуществляться из одного экземпляра SQL Server в другой на том же компьютере или из экземпляра SQL Server на другой сервер. Средства миграции включают в себя использование мастера копирования базы данных, функции резервного копирования и восстановления, использование мастера импорта и экспорта служб SQL Server 2005 Integration Services, а также методов массового экспорта и импорта.

Перед обновлением Database Engine убедитесь в том, что выполнены следующие действия.

Ознакомьтесь с документацией, относящейся к обновлению до SQL Server 2005:

  • Обратитесь к разделу Требования к оборудованию и программному обеспечению для установки SQL Server 2005.

  • Обратитесь к разделу Параметры для средства проверки конфигурации системы.

  • Обратитесь к разделу Анализ безопасности при установке SQL Server.

  • Обратитесь к разделу Использование помощника по обновлению для подготовки к обновлениям.

  • Обратитесь к разделу Обратная совместимость компонента SQL Server 2005 Database Engine.

Перед обновлением до SQL Server 2005 учтите перечисленные ниже моменты и сделайте при необходимости соответствующие изменения.

  • При обновлении 64-разрядного выпуска Microsoft SQL Server 2000 до 64-разрядного выпуска Microsoft SQL Server 2005 необходимо обновить службы Analysis Services перед обновлением компонента Database Engine.

  • Выполните резервное копирование всех файлов базы данных SQL Server из экземпляра, подлежащего обновлению, чтобы можно было полностью восстановить их при необходимости.

  • Выполните соответствующие консольные команды (DBCC) в базах данных, подлежащих обновлению, чтобы убедиться в том, что они находятся в стабильном состоянии.

  • Оцените место на диске, необходимое для обновления компонентов SQL Server, а также пользовательских баз данных. Дополнительные сведения о месте на диске, необходимом для компонентов SQL Server 2005, см. в разделе Требования к оборудованию и программному обеспечению для установки SQL Server 2005.

  • Убедитесь в том, что существующие системные базы данных SQL Server (master, model, msdb и tempdb) настроены для автоматического расширения и что для них имеется достаточно места на диске.

  • Убедитесь в том, что все серверы баз данных имеют регистрационные данные для входа в базу данных master. Это важно для восстановления базы данных, поскольку системные регистрационные данные для входа хранятся в базе данных master.

  • Отключите все хранимые процедуры, запускаемые при старте системы; это необходимо, поскольку процесс обновления будет останавливать и запускать службы на экземпляре SQL Server, подвергаемом обновлению. Хранимые процедуры, запускаемые при старте системы, могут блокировать процесс обновления.

  • Остановите репликацию и убедитесь в том, что журнал репликации пуст.

  • При обновлении экземпляра компонента SQL Server 2000 Database Engine до версии SQL Server 2005 сохраняется значение параметра конфигурации max worker threads. Однако рекомендуется перед обновлением установить параметр max worker threads в значение 0, чтобы компонент Database Engine имел возможность вычислить оптимальное количество потоков. Дополнительные сведения см. в разделе Параметр max worker threads.

  • Закройте все приложения, включая все службы с зависимостями от SQL Server. Процесс обновления может завершиться неудачно, если локальные приложения соединены с экземпляром, подвергаемым обновлению. Дополнительные сведения см. в разделе Устранение неполадок при установке ядра СУБД SQL Server.

Обновление компонента Database Engine

Можно переписать установленную версию 7.0 SQL Server или SQL Server 2000 посредством обновления ее до SQL Server 2005. Если при запуске программы установки SQL Server 2005 будет обнаружена предыдущая версия SQL Server, все рабочие файлы предыдущей версии SQL Server будут обновлены, а все данные, хранящиеся в экземпляре предыдущей версии SQL Server, будут сохранены. Кроме того, предыдущие версии электронной документации для SQL Server останутся на компьютере без изменения. Для доступа к предыдущим версиям электронной документации по SQL Server ознакомьтесь с разделами Как получить доступ к электронной документации по SQL Server 7.0 и Как получить доступ к электронной документации по SQL Server 2000.

Внимание!
Когда производится обновление до версии SQL Server 2005, предыдущий экземпляр SQL Server будет переписан и перестанет существовать на компьютере. Перед обновлением создайте резервную копию баз данных SQL Server и других объектов, связанных с экземпляром предыдущей версии SQL Server.

Можно произвести обновление Database Engineили воспользовавшись мастером установки SQL Server (Setup.exe в режиме пользовательского интерфейса), или из командной строки (Setup.exe).

Внимание!
Если на компьютере имеются средства управления SQL Server 2000 и установлен экземпляр по умолчанию SQL Server 2005, программа установки SQL Server позволит установить экземпляр по умолчанию SQL Server 2000. Однако в этом случае будет отключен установленный экземпляр SQL Server 2005. Поэтому не устанавливайте экземпляр SQL Server по умолчанию, если средства управления SQL Server 2000 и экземпляр по умолчанию SQL Server 2005 уже существуют на компьютере.

Уровень совместимости баз данных после обновления

После обновления SQL Server 2005 автоматически установит уровень совместимости баз данных на уровень предыдущей версии SQL Server. Таким образом, если производится обновление версии 7.0 SQL Server через версию SQL Server 2000 и затем до версии SQL Server 2005, уровень совместимости будет установлен по SQL Server 2000.

Обновление компонента Database Engine до версии SQL Server 2005

  • Как обновить до SQL Server 2005 (программа установки)

  • Как произвести обновление до отказоустойчивого кластера SQL Server 2005 (установка)

  • Обновление реплицируемых баз данных

Миграция баз данных в SQL Server 2005

Можно переместить пользовательские базы данных в экземпляр SQL Server 2005 при помощи функций резервного копирования и восстановления или отсоединения и присоединения в сервере SQL Server 2005.

Важно!
База данных, имеющая одинаковое имя на сервере-источнике и целевом сервере, не может быть перемещена или скопирована. В этом случае она будет помечена как уже существующая.

Миграция пользовательских баз данных в SQL Server 2005

  • Использование мастера копирования баз данных

  • Как выполнить обновление до версии SQL Server 2005 с помощью мастера копирования баз данных

Вопросы по отказоустойчивому кластеру при обновлении компонента Database Engine

Отказоустойчивый кластер SQL Server 2005 обеспечивает поддержку высокого уровня доступности для всего экземпляра SQL Server. Отказоустойчивый кластер является комбинацией одного или нескольких жестких дисков в группе кластеров «Служба кластера» (MSCS) Microsoft, известной как группа ресурсов, которые являются узлами-участниками кластера. Группа ресурсов настроена как виртуальный сервер, который содержит экземпляр SQL Server.

Виртуальный сервер SQL Server регистрируется в сети как изолированный компьютер, при этом он обладает функциональными возможностями, обеспечивающими переход с одного узла на другой, если один из узлов становится недоступным. Например, при отказе оборудования, сбое операционной системы или в ходе запланированного обновления можно настроить экземпляр SQL Server в одном узле отказоустойчивого кластера таким образом, чтобы в случае сбоя переход осуществлялся на любой другой узел в группе дисков. Можно использовать отказоустойчивый кластер, чтобы уменьшить время простоя системы и обеспечить более высокий уровень доступности приложения.

Чтобы обновить экземпляр SQL Server до отказоустойчивого кластера SQL Server 2005, подвергаемый обновлению экземпляр должен быть отказоустойчивым кластером. Чтобы обновить изолированный экземпляр SQL Server до отказоустойчивого кластера SQL Server 2005, установите новый отказоустойчивый кластер SQL Server 2005, а затем осуществите миграцию пользовательских баз данных из изолированного экземпляра, воспользовавшись мастером копирования баз данных. Дополнительные сведения об обновлении см. в разделе Как произвести обновление до отказоустойчивого кластера SQL Server 2005 (установка). Дополнительные сведения о миграции баз данных см. в разделе Использование мастера копирования баз данных.

Дополнительные сведения об отказоустойчивом кластере см. в разделах Отказоустойчивый кластер и Установка отказоустойчивого кластера. Дополнительные сведения по обновлению до отказоустойчивого кластера SQL Server 2005 см. в разделе Как произвести обновление до отказоустойчивого кластера SQL Server 2005 (установка).

После обновления компонента Database Engine

После обновления Database Engine до SQL Server 2005 выполните следующие действия.

  • После обновления до SQL Server 2005 с другого выпуска SQL Server 2005 необходимо повторно установить исправления и пакеты обновления на обновленный экземпляр SQL Server.

  • Регистрация серверов — в процессе обновления удаляются настройки реестра для предыдущего экземпляра SQL Server. После обновления необходимо заново зарегистрировать свои серверы. Дополнительные сведения о регистрации серверов см. в разделе Регистрация серверов электронной документации по SQL Server 2005.

  • Обновление статистики — оптимизация производительности запросов, рекомендуется после обновления обновить статистику для всех баз данных. Используйте хранимую процедуру sp_updatestats для обновления статистики в пользовательских таблицах баз данных SQL Server 2005.

  • Обновите счетчики использования. В предыдущих версиях SQL Server значения счетчиков таблиц и индексов строк, а также счетчиков страниц могут стать некорректными. Чтобы исправить любые неверные счетчики строк или страниц, рекомендуется выполнить DBCC UPDATEUSAGE на всех базах данных сразу после обновления.

  • Настройте новую установку SQL Server. Чтобы уменьшить уязвимую контактную зону системы, SQL Server 2005 по выбору устанавливает и активирует ключевые службы и функции. Дополнительные сведения о том, как активировать функции SQL Server 2005, см. в разделе Настройка контактной зоны SQL Server.

Любые базы данных, в которых возможность использования полнотекстовых каталогов была включена или отключена до обновления, сохранят этот статус после обновления. После обновления полнотекстовые каталоги будут перестроены и автоматически заполнены для всех баз данных с включенной возможностью использования полнотекстовых каталогов. Выполнение этой операции требует много времени и ресурсов. Можно временно приостановить проведение полнотекстового индексирования, выполнив следующую инструкцию.

Копировать код
EXEC sp_fulltext_service 'pause_indexing', 1

Для возобновления заполнения полнотекстового индекса выполните следующую инструкцию.

Копировать код
EXEC sp_fulltext_service 'pause_indexing', 0

См. также

Основные понятия

Работа с несколькими версиями SQL Server
Обновление реплицируемых баз данных

Другие ресурсы

Обратная совместимость

Журнал изменений

Версия Журнал

12 декабря 2006 г.

Измененное содержимое:
  • В подразделе «После обновления компонента Database Engine» удален элемент маркированного списка, посвященный повторному заполнению полнотекстовых каталогов. Правильные сведения приведены в абзаце, рассказывающем об автоматическом перестроении полнотекстовых каталогов.

17 июля 2006 г.

Новое содержимое:
  • Добавлены ссылки на разделы, посвященные регистрации серверов и повторному заполнению полнотекстовых каталогов.


Обновление и миграция служб Analysis Services

Обновление и миграция служб Analysis Services |
 | См. также
Обновление до SQL Server 2005 > Обновление компонентов SQL Server >

Примечание.
Рекомендуется прочитать раздел Обновления версий и выпусков для получения общих сведений о сценариях миграции на продукты и технологии более новых версий.

При использовании Analysis Services будут доступны следующие параметры при установке .

  • Установить службы Analysis Services параллельно с более ранней версией.

  • Обновить более раннюю версию служб Analysis Services.

  • Выполнить миграцию существующих баз данных служб Analysis Services.

Важно!
При выборе любого варианта узнайте, какие компоненты и возможности SQL Server 2000 Analysis Services не рекомендованы, изменены или больше не поддерживаются. Дополнительные сведения см. в разделе Обратная совместимость служб SQL Server 2005 Analysis Services.

Известные проблемы при обновлении

Перед обновлением до SQL Server 2005 Analysis Services ознакомьтесь с разделом Известные проблемы при обновлении служб SQL Server 2005 Analysis Services.

Контрольный список действий перед обновлением

Перед обновлением до SQL Server 2005 Analysis Services проверьте выполнение следующих требований.

  • Требования к оборудованию и программному обеспечению для установки SQL Server 2005

  • Параметры для средства проверки конфигурации системы

  • Анализ безопасности при установке SQL Server

  • Использование помощника по обновлению для подготовки к обновлениям

Установка служб Analysis Services параллельно с более ранней версией

SQL Server 2000 Службы Analysis Services не поддерживают именованные экземпляры. Таким образом, на компьютере, где работают и SQL Server 2000 Analysis Services, и SQL Server 2005 Analysis Services, экземпляр SQL Server 2000 Analysis Services всегда должен быть экземпляром по умолчанию. В данном случае программа установки SQL Server позволяет установить именованные экземпляры только SQL Server 2005 Analysis Services. После этого SQL Server 2000 Analysis Services можно по-прежнему выполнять как экземпляр по умолчанию параллельно с именованными экземплярами SQL Server 2005 Analysis Services.

Дополнительные сведения см. в разделе Как установить службы Analysis Services параллельно с более ранней версией.

Изменение параллельно установленных копий

Можно использовать мастер миграции Analysis Services для переноса баз данных из экземпляра SQL Server 2000 Analysis Services в SQL Server 2005 Analysis Services. Дополнительные сведения о выполнении мастера миграции см. в разделе Миграция существующих баз данных служб Analysis Services.

Если после переноса баз данных экземпляра SQL Server 2000 Analysis Services по умолчанию удалить этот экземпляр, то с помощью средства переименования экземпляра Analysis Services можно будет сделать именованный экземпляр SQL Server 2005 Analysis Services экземпляром по умолчанию на сервере.

Дополнительные сведения см. в разделах Как выполнить миграцию баз данных служб Analysis Services и Как переименовать экземпляр служб Analysis Services.

Обновление служб Analysis Services более ранней версии

Обновление SQL Server 2000 Analysis Services включает в себя установку SQL Server 2005 Analysis Services и преобразование существующих баз данных Analysis Services в формат баз данных SQL Server 2005 Analysis Services. Можно обновить SQL Server 2000 Analysis Services и выполнить перенос существующих баз данных во время установки или же перенести базы данных после установки SQL Server 2005 Analysis Services с помощью других программных средств в дополнение к программе установки SQL Server.

Важно!
При обновлении 64-разрядного выпуска Microsoft SQL Server 2000 до 64-разрядного выпуска Microsoft SQL Server 2005 необходимо обновить службы Analysis Services перед обновлением ядра СУБД.

Обновление экземпляра служб SQL Server 2000 Analysis Services во время установки

  1. На странице Имя экземпляра мастера установки SQL Server выберите Экземпляр по умолчанию.

  2. Для подтверждения наличия экземпляра служб SQL Server 2000 Analysis Services нажмите кнопку Установленные экземпляры.
Миграция экземпляра служб SQL Server 2000 Analysis Services после установки

  1. Установите именованный экземпляр SQL Server 2005 Analysis Services, используя мастер установки SQL Server или альтернативный метод установки этих служб. Дополнительные сведения см. в разделах Установка служб SQL Server Analysis Services с помощью программы установки или Установка служб SQL Server Analysis Services из командной строки.

  2. С помощью мастера миграции Analysis Services произведите миграцию метаданных баз данных SQL Server 2000 Analysis Services в SQL Server 2005 Analysis Services. В результате этого структуры баз данных будут заново созданы в новом формате баз данных SQL Server 2005 Analysis Services, тогда как исходные базы данных останутся неизменными. Дополнительные сведения см. в разделе Миграция существующих баз данных служб Analysis Services.

  3. Обработайте новые базы данных SQL Server 2005 Analysis Services. На этом этапе новые структуры баз данных заполняются данными. Дополнительные сведения см. в разделе Обработка средствами служб Analysis Services.

  4. Убедитесь в успешном обновлении баз данных. Изучите обновленные базы данных в среде SQL Server Management Studio и протестируйте их с помощью клиентских приложений.

  5. Удалите службы SQL Server 2000 Analysis Services, если они больше не нужны.

  6. Если удалить экземпляр служб SQL Server 2000 Analysis Services по умолчанию, то с помощью средства переименования Analysis Services можно будет изменить имя именованного экземпляра SQL Server 2005 Analysis Services, сделав его экземпляром по умолчанию.

Дополнительные сведения см. в разделах Как обновить экземпляр служб Analysis Services, Как выполнить миграцию баз данных служб Analysis Services и Как переименовать экземпляр служб Analysis Services.

Миграция существующих баз данных служб Analysis Services

Мастер миграции Analysis Services позволяет преобразовать базы данных SQL Server 2000 Analysis Services в формат SQL Server 2005 Analysis Services. Во время миграции этот мастер копирует объекты баз данных SQL Server 2000 Analysis Services и воссоздает их на заданном экземпляре SQL Server 2005 Analysis Services. Базы данных-источники остаются неизменными.

Дополнительные сведения о миграции на службы SQL Server 2005 Analysis Services см. в разделах Миграция существующих баз данных служб Analysis Services и Как выполнить миграцию баз данных служб Analysis Services.

После миграции баз данных необходимо обработать базы данных из исходного источника данных, прежде чем можно будет выполнять к ним запросы. Дополнительные сведения см. в разделе Обработка средствами служб Analysis Services.

См. также

Основные понятия

Установка служб SQL Server Analysis Services

Другие ресурсы

Обновление компонентов SQL Server


Миграция существующих баз данных служб Analysis Services

Миграция существующих баз данных служб Analysis Services |
 | См. также
Обновление до SQL Server 2005 > Обновление компонентов SQL Server > Обновление и миграция служб Analysis Services >

Мастер миграции служб Analysis Services используется для обновления баз данных служб Analysis Services до . При выполнении миграции мастер копирует объекты базы данных служб SQL Server 2000 Analysis Services и пересоздает их в экземпляре SQL Server 2005 Analysis Services. Базы данных-источники остаются неизменными. После проверки полной работоспособности новой базы данных старую базу данных можно будет удалить вручную.

Рекомендуется выполнять миграцию баз данных по одной или небольшими группами, чтобы по мере выполнения миграции проверять, все ли объекты правильно перенеслись на целевой сервер. При запуске мастера миграции как на исходном сервере, так и на целевом сервере должна быть запущена служба MSSQLServerOLAPService. (При миграции именованного экземпляра на обоих серверах должна быть запущена служба MSOLAP$instancename.)

После миграции баз данных необходимо обработать базы данных из исходного источника данных, прежде чем можно будет выполнять к ним запросы. Дополнительные сведения см. в разделе Обработка средствами служб Analysis Services.

Использование мастера миграции

Мастер миграции можно запустить из узла сервера служб Analysis Services в обозревателе объектов среды SQL Server Management Studio. Также мастер можно запустить из командной строки, запустив программу MigrationWizard.exe.

Указание источника и адресата

После начальной страницы мастера Приветствие отображается страница Задание источника и назначения. На этой странице указывается исходный сервер и целевой сервер для баз данных, для которых выполняется миграция. Целевой экземпляр служб Analysis Services может быть локальным или удаленным. Если указан целевой компьютер, на котором выполняется более одного экземпляра служб SQL Server 2005 Analysis Services, используйте формат computername\instancename.

Можно также указать сохранение схемы базы данных в файл сценария, чтобы завершить миграцию позже, например с помощью задачи служб Analysis Services «Выполнить DDL» в пакете SQL Server 2005 Integration Services (SSIS). Дополнительные сведения о задаче служб Analysis Services «Выполнить DDL» см. в разделе Задача «Выполнение инструкции DDL служб Analysis Services».

Выбор баз данных для миграции

Следующая страница мастера, Выбор баз данных для миграции, отображает список всех баз данных служб SQL Server 2000 Analysis Services и соответствующих создаваемых баз данных служб SQL Server 2005 Analysis Services. По умолчанию выбраны все базы данных, но можно снять флажки для тех баз данных, для которых выполнять миграцию не нужно.

Имена базы данных-источника и соответствующих целевых баз данных по умолчанию идентичны. Однако если на целевом сервере база данных с таким именем уже существует, мастер миграции назначает для нее уникальное имя. (Например, вторая копия базы данных AdventureWorks будет называться AdventureWorks 1.) Можно оставить имя, назначенное мастером, либо указать новое имя, либо переименовать базу данных после завершения работы мастера.

Дополнительные сведения о соответствии объектов служб SQL Server 2000 Analysis Services объектам SQL Server 2005 Analysis Services см. в разделе Вопросы миграции (службы SSAS).

Примечание.
Мастер миграции не поддерживает базы данных служб Microsoft SQL Server 7.0 Analysis Services.

Проверка баз данных

На странице Проверка баз данных мастер миграции проверяет структуры мигрируемых баз данных. В ходе проверки мастер формирует журнал. Чтобы просмотреть журнал и выборку из него, нажмите кнопку Просмотр журнала, а затем выберите один из следующих параметров:

  • Показать все

  • Показать ошибки

  • Показать предупреждения

  • Показать успешные операции

Если возникли какие-либо ошибки, проверка прекращается. Чтобы продолжить процесс миграции, исправьте ошибки в базе данных, затем нажмите кнопку Перезапустить.

Можно остановить процесс проверки, нажав кнопку Остановить. Мастер отображает сообщение, содержащее число баз данных, которые остались непроверенными.

Миграция баз данных

На странице Миграция баз данных мастер выполняет миграцию объектов служб SQL Server 2000 Analysis Services в формат служб SQL Server 2005 Analysis Services. Можно остановить этот процесс и откатить всю транзакцию, нажав кнопку Остановить, а затем Отмена.

После завершения миграции можно изменить ранее сделанные параметры, нажав кнопку Назад для возврата на предыдущие страницы мастера. В этом случае процесс миграции необходимо будет повторить заново. При повторном запуске миграции базы данных, миграция которых уже была выполнена, будут удалены.

Завершение мастера

На странице Завершение работы мастера отображается сводка по созданным базам данных служб SQL Server 2005 Analysis Services. Чтобы завершить работу мастера, нажмите кнопку Готово.

После миграции базы данных необходимо обработать базу данных из исходного источника данных, прежде чем можно будет выполнять к ней запросы. Дополнительные сведения см. в разделе Обработка средствами служб Analysis Services.

См. также

Основные понятия

Обновление и миграция служб Analysis Services


Вопросы миграции (службы SSAS)

Вопросы миграции (службы SSAS) |
 | См. также
Обновление до SQL Server 2005 > Обновление компонентов SQL Server > Обновление и миграция служб Analysis Services >

При миграции из более ранних версий служб Analysis Services в SQL Server 2005 Analysis Services (SSAS) необходимо учитывать изменения в особенностях, функциональности, структуре и работе. Этот обзорный раздел предоставляет сведения об основных вопросах миграции, связанных с интеллектуальным анализом данных и ядром служб Analysis Services. Дополнительные сведения об определенных областях вопросов миграции см. в следующих разделах:

  • Известные проблемы при обновлении служб SQL Server 2005 Analysis Services

  • Миграция существующих баз данных служб Analysis Services

  • Неподдерживаемая функциональность служб Analysis Services в SQL Server 2005

  • Устаревшие функциональные возможности служб Analysis Services в SQL Server 2005

Дополнительные сведения о новых и улучшенных мастерах служб SQL Server 2005 Analysis Services (SSAS) см. в разделе Улучшения служб Analysis Services (службы SSAS).

Мастер миграции служб Analysis Services

Объекты служб Analysis Services

В следующей таблице представлено соответствие объектов служб SQL Server 2000 Analysis Services объектам служб SQL Server 2005 Analysis Services (SSAS).

SQL Server 2000 Объект служб Analysis Services | Объект служб SQL Server 2005 Analysis Services (SSAS) | Дополнительные сведения
Статистическая обработка | Статистическая обработка | Подвергаются миграции только статистические схемы для гибридных секций OLAP (HOLAP) и многомерных секций OLAP (MOLAP).
База данных служб Analysis Services | База данных служб Analysis Services | Нет
Команда | Сценарий многомерных выражений | Сценарий многомерных выражений пишется для объекта, содержащего коллекцию команд.
Куб | Куб | Для всех измерений, виртуальных измерений и кубов с общим источником данных создается одно представление источника данных. Затем создается представление источника данных для каждой модели интеллектуального анализа данных и измерения интеллектуального анализа данных.
Команды куба и роли базы данных | Не подвергаются миграции | Нет
Роль куба | Разрешение куба | Измерения и разрешения ячеек не подвергаются миграции.
Измерение интеллектуального анализа данных | Измерение интеллектуального анализа данных | Представление источника данных создается также для каждого измерения интеллектуального анализа данных.
Источник данных | Источник данных | Нет
Роль базы данных | Роль базы данных и разрешение базы данных | Нет
Измерение | Измерение с одной иерархией | Нет
Измерения, имеющие общий префикс имени (представляющий несколько иерархий) | Отдельные измерения, каждое с одной иерархией | Многомерные выражения, ссылающиеся на имена исходных иерархий, больше не действуют.
Уровень в иерархии | Атрибут в измерении и уровень в пользовательской иерархии | Нет
Связанные кубы | Не подвергаются миграции | Нет
Свойство элемента на уровне | Свойство элемента на уровне | Нет
Модель интеллектуального анализа данных | Модель интеллектуального анализа данных | Представление источника данных создается для каждой модели интеллектуального анализа данных в базе данных.
Роль модели интеллектуального анализа данных | Подвергается миграции в виде двух разрешений. Одно для структуры интеллектуального анализа данных, другое для модели интеллектуального анализа данных | Нет
Несколько иерархий типа «родители-потомки» в измерении | Одна иерархия типа «родители-потомки», определяемая параметрами родительского атрибута | Многомерные выражения, ссылающиеся на исходные иерархии, больше не действуют. Измерение служб SQL Server 2005 Analysis Services (SSAS) может иметь только одну иерархию типа «родители-потомки»
Удаленные секции | Не подвергаются миграции | Удаленные секции недоступны, пока не будет обновлен сервер, на котором они находятся, или не будет выполнена миграция базы данных, содержащей эти удаленные секции. Базы данных, содержащие удаленные секции, могут подвергаться миграции по отдельности. Определение удаленной секции должно быть обновлено, чтобы идентифицировать имя нового экземпляра сервера.
Репозиторий | Файлы языка определения объектов ODL в формате XML | Нет
Виртуальный куб | Связанные группы показателей | Нет
Виртуальное измерение | Иерархия исходного измерения | Виртуальные измерения типа «родители-потомки» подвергаются миграции как отдельные измерения, поскольку измерения типа «родители-потомки» не могут иметь несколько иерархий.

Формулы пользовательского уровня

В SQL Server 2005 Analysis Services (SSAS) вычисляемые ячейки и формулы уровня пользователя заменяются назначениями. Вычисляемые ячейки поддерживаются в службах SQL Server 2005 Analysis Services (SSAS) и подвергаются миграции из служб SQL Server 2000 Analysis Services в соответствии со своими определениями, но формулы уровня пользователя переносятся в виде назначений.

В службах SQL Server 2005 Analysis Services (SSAS) номер этапа вычисления автоматически увеличивается с каждым проходом. Поэтому, если куб содержит формулы уровня пользователя, следует убедиться, что результаты совпадают с ожидаемыми.

Представления источника данных

Представления источников данных — новая функциональная возможность в службах SQL Server 2005 Analysis Services (SSAS). Представление источника данных отличается от схемы куба в службах SQL Server 2000 Analysis Services тем, что представление источника данных является логическим отображением источника данных, в котором могут определяться несколько кубов, тогда как схема куба в службах SQL Server 2000 Analysis Services является физическим представлением связей между таблицами в каждом кубе.

Миграция измерений с несколькими иерархиями

Модель измерений с несколькими иерархиями изменилась при переходе от служб SQL Server 2000 Analysis Services к службам SQL Server 2005 Analysis Services (SSAS). Там, где это возможно, такие иерархии переносятся в то же самое измерение, но в некоторых обстоятельствах это невозможно. В этих случаях вычисления, зависящие от иерархии исходного измерения, могут завершиться ошибкой.

Синтаксис SQL

В службах SQL Server 2005 Analysis Services (SSAS) изменились средства формулирования запросов SQL. В электронной документации по SQL Server 2005 для нового синтаксиса используется форма Бэкуса-Наура (BNF).

Изменения в наборах строк схемы

Многие наборы строк схемы в службах SQL Server 2005 Analysis Services (SSAS) дополнены для предоставления дополнительных сведений. Во многих случаях положение и значение существующих наборов строк и столбцов остаются точно такими же, как и в SQL Server 2000 Analysis Services. В следующей таблице приводятся изменения в наборах строк схемы в службах SQL Server 2005 Analysis Services (SSAS).

Схема | Столбец | Изменение
DBSCHEMA_TABLES_INFO | Все | Эта схема более не поддерживается.
MDSCHEMA_CELL_FORMULAS | Все | Эта схема более не поддерживается.
MDSCHEMA_DIMENSIONS | DIMENSION_CARDINALITY | Этот столбец возвращает количество элементов ключевых атрибутов измерения.
MDSCHEMA_MEMBERS | LEVELS_LIST | Этот столбец схемы содержит значение NULL.
MDSCHEMA_MEMBERS | MEMBER_ORDINAL | Этот столбец является устаревшим. Возвращается значение 0, а не порядковый номер элемента.

Уникальные имена элементов

Уникальные имена элементов в службах SQL Server 2005 Analysis Services (SSAS) отличаются от уникальных имен элементов в службах SQL Server 2000 Analysis Services. Из-за ограничений на уникальные имена элементов извлечение результатов из схемы элементов может дать другие результаты, чем в службах SQL Server 2000 Analysis Services.

Вопросы миграции интеллектуального анализа данных

Мастер миграции переносит все модели интеллектуального анализа данных из базы данных служб SQL Server 2000 Analysis Services в базу данных назначения служб SQL Server 2005 Analysis Services (SSAS). Для каждой модели интеллектуального анализа данных в базе данных-источнике мастер миграции создает в целевой базе данных новую структуру интеллектуального анализа данных. Такая структура интеллектуального анализа данных в базе данных-источнике содержит только одну модель, и эта модель имеет то же имя, что и модель интеллектуального анализа данных в исходной базе данных.

Чтобы выполнить миграцию отдельных моделей интеллектуального анализа данных из служб SQL Server 2000 Analysis Services в экземпляр служб SQL Server 2005 Analysis Services (SSAS), можно использовать язык разметки прогнозирующих моделей (PMML). Следующая инструкция получит представление PMML в формате XML-сценария модели интеллектуального анализа данных SQL Server 2000 Analysis Services:

SELECT * FROM [Model_Name].PMML

Можно получить те же сведения, выполнив извлечение схемы OLE DB, DMSCHEMA_MINING_MODEL_XML.

Можно использовать сценарий PMML для создания новой модели интеллектуального анализа данных в экземпляре SQL Server 2005 Analysis Services (SSAS), используя инструкцию, аналогичную следующей:

CREATE MINING MODEL [Model_Name] FROM PMML '<PMML script>'

Если для миграции моделей интеллектуального анализа данных используется мастер миграции служб Analysis Services, обратите внимание, что он поддерживает только миграцию метаданных. Таким образом, подвергнутые миграции модели интеллектуального анализа данных остаются необработанными. Однако эти модели все еще содержат исходные привязки данных, поэтому после миграции их можно обработать в службах SQL Server 2005 Analysis Services (SSAS). С другой стороны, если для миграции моделей использовать PMML, исходные привязки данных не сохраняются. Таким образом, подвергнутые миграции модели нельзя будет обработать повторно. Тем не менее, модели эти готовы к использованию, поскольку PMML включает шаблоны и тренды, обнаруженные исходной моделью.

Известны следующие проблемы миграции моделей интеллектуального анализа данных:

  • Нельзя подвергать миграции модели интеллектуального анализа данных, имеющие несколько ключей на уровне вариантов во вложенной таблице.

  • Нельзя подвергать миграции модели интеллектуального анализа данных, созданные поставщиками интеллектуального анализа статистических данных.

Журнал изменений

Версия Журнал

17 июля 2006 г.

Измененное содержимое:
  • Обновлен концептуальный материал для улучшения понимания.

См. также

Основные понятия

Обновление и миграция служб Analysis Services


Обновление служб Reporting Services

Обновление служб Reporting Services |
 | См. также
Обновление до SQL Server 2005 > Обновление компонентов SQL Server >

Дата обновления: 14 апреля 2006 г.

Можно обновить службы Reporting Services с SQL Server 2000 Reporting до версии, поставляемой в составе SQL Server 2005. Способ обновления зависит от сложности установки, наличия пользовательских расширений, а также требований к доступности сервера.

Пользовательским или доступным через Интернет установкам и производственным серверам, требующим бесперебойной работы, необходим план миграции, который заранее определяет оптимальное время для выполнения обновления, способ обновления базы данных сервера отчетов, проверочные шаги, позволяющие выяснить, успешно ли произведено обновление, а также план резервного копирования, на тот случай, если обновление завершится непредвиденным сбоем. Если для обработки, доставки, защиты или форматирования данных используются пользовательские модули подготовки, их, возможно, потребуется перекомпилировать перед выполнением обновления. При обновлении производственного сервера вместо обновления установки может потребоваться ее миграция. Можно также рассмотреть возможность эксплуатации нового экземпляра параллельно с существующей установкой служб Reporting Services. Это позволит разрешить все возникшие затруднения, прежде чем удалять экземпляр SQL Server 2000.

Обновление с SQL Server 2000 до SQL Server 2005

Следующая таблица содержит параметры обновления для различных сценариев развертывания.

Исходное состояние | Действие | Состояние после обновления
Службы Reporting Services и компонент Database Engine на одном экземпляре SQL Server 2000 по умолчанию. | Запустите обновление. Выберите экземпляр по умолчанию. | Службы Reporting Services и компонент Database Engine обновлены до SQL Server 2005.
Один экземпляр служб SQL Server 2000 Reporting Services, который запущен как экземпляр по умолчанию. Один экземпляр компонента SQL Server 2000 Database Engine, который запущен как именованный экземпляр. Оба экземпляра работают на одном том же компьютере. | Запустите обновление. Выберите экземпляр, который необходимо обновить. Каждый из экземпляров может быть обновлен независимо от другого. Можно также обновить все экземпляры одновременно. | Отдельные экземпляры служб Reporting Services и компонента Database Engine, обновленные до SQL Server 2005. Допустимые сочетания. Службы SQL Server 2005 Reporting Services с экземпляром компонента SQL Server 2000 Database Engine. Службы SQL Server 2000 Reporting Services и экземпляр компонента SQL Server 2005 Database Engine. И службы Reporting Services, и компонент Database Engine обновлены до SQL Server 2005.

Обновление односерверной установки

Если запущена установка по умолчанию, которая не была модифицирована, можно обновить целостность служб Reporting Services запуском программы установки. Для хранения базы данных сервера отчетов следует использовать локальный экземпляр компонента SQL Server Database Engine. Дополнительные сведения см. в разделе Обновление установки по умолчанию служб Reporting Services.

Если запущена пользовательская установка, может понадобиться миграция служб Reporting Services. Дополнительные сведения по вопросам миграции и обновления см. в разделах Миграция служб Reporting Services, How to: Install Reporting Services Side-by-Side with an Earlier Version, Использование помощника по обновлению для подготовки к обновлениям и Критические изменения в службах SQL Server 2005 Reporting Services.

Обновление установки на распределенных серверах

Установку служб Reporting Services можно настроить для хранения базы данных сервера отчетов на удаленном компьютере. Можно также настроить установку на работу нескольких серверов отчетов в конфигурации с масштабным развертыванием. При установке базы данных сервера отчетов на удаленном компьютере программа установки обновит схему автоматически. Если это невозможно из-за недостаточных разрешений или ошибок соединения, необходимо обновить базу данных сервера отчетов вручную. Дополнительные сведения см. в разделе Обновление базы данных сервера отчетов.

Можно обновить базу данных сервера отчетов без обновления экземпляра компонента Database Engine, на котором она размещается. При обновлении экземпляра компонента Database Engine убедитесь, что при хранении базы данных сервера отчетов соблюдаются требования к выпуску. Дополнительные сведения о требованиях к выпускам см. в разделе Создание базы данных сервера отчетов. Дополнительные сведения об обновлении нескольких экземпляров сервера отчетов см. в разделе Обновление веб-фермы сервера отчетов.

В этом разделе

Подраздел | Описание
Обновление установки по умолчанию служб Reporting Services | Обновление существующей установки служб Reporting Services, в которой все компоненты сконфигурированы со значениями по умолчанию.
Обновление отчетов | Объясняет, как обновлять отчеты, которые были созданы в предыдущих версиях конструктора отчетов.
Обновление безопасности на основе ролей для доступа к построителю отчетов | Объясняет, как изменять настройки безопасности на основе ролей для реализации новых функций нерегламентированных отчетов.
Обновление базы данных сервера отчетов | Содержит сведения об обновлении схемы базы данных сервера отчетов.
Обновление выпусков служб Reporting Services | Описание функциональных различий между выпусками Evaluation Edition и Standard Edition. Можно обновить любой выпуск служб Reporting Services, включая выпуск Evaluation Edition, если срок его действия не истек.
Обновление веб-фермы сервера отчетов | Обновление множества серверов отчетов, которые разделяют одну базу данных сервера отчетов.
Миграция служб Reporting Services | Предоставляет инструкции для обновления нестандартной установки и установок, которые совмещают компоненты, установленные на множестве компьютеров.

См. также

Задачи

How to: Install Reporting Services Side-by-Side with an Earlier Version

Основные понятия

Установка служб SQL Server Reporting Services


Обновление установки по умолчанию служб Reporting Services

Обновление установки по умолчанию служб Reporting Services |
 | См. также
Обновление до SQL Server 2005 > Обновление компонентов SQL Server > Обновление служб Reporting Services >

При запуске программы установки на компьютере, где уже установлены службы Reporting Services по умолчанию, можно выбрать между обновлением существующего экземпляра и установкой нового. Для обновления существующей установки необходимо выполнить следующие требования:

  • Виртуальные каталоги, используемые для доступа к серверу отчетов и диспетчеру отчетов, должны иметь настройки конфигурации по умолчанию. Виртуальные каталоги создаются на веб-узле по умолчанию. Сопоставления приложения и содержимого, настройки безопасности виртуального каталога, а также разрешения должны иметь значения по умолчанию.

  • Удостоверение процесса ASP.NET не было зашифровано в файле machine.config. Шифрование удостоверения процесса для некоторых организаций является лучшим способом обеспечить безопасность. Программа установки SQL Server не может обновить установки служб Reporting Services, если удостоверение процесса зашифровано.

  • Никаких пользовательских расширений не было добавлено, и сервер отчетов развертывается с модулем безопасности по умолчанию.

Пункты, описанные выше, блокируют процесс обновления; они вступают в действие, когда запускается помощник по обновлению на существующей установке. Дополнительные сведения об этих проблемах и способах их решения см. в документации помощника по обновлению. Можно выполнить миграцию установки служб Reporting Services, если вариант с обновлением не подходит. Дополнительные сведения о миграции и использования помощника обновления см. в разделах Миграция служб Reporting Services и Использование помощника по обновлению для подготовки к обновлениям.

Контрольный список действий перед обновлением

Используйте этот контрольный список, чтобы подготовить установку служб Reporting Services к обновлению.

  1. Выполните резервное копирование базы данных и файлов конфигурации сервера отчетов. Если изменились файлы-образцы или таблицы стилей и нужно сохранить эти измененные версии, создайте их резервные копии.

  2. Выполните резервное копирование симметричного ключа.

  3. Удалите обновление электронной документации служб Reporting Services, если оно было установлено.

  4. Запустите программу установки на компьютере, на котором находится сервер отчетов. Программа установки обнаружит существующую установку и предложит варианты обновления.

Обновление базы данных сервера отчетов

В процессе обновления программа установки соединяется с базами данных сервера отчетов, установленными в локальном экземпляре компонента SQL Server Database Engine по умолчанию, а затем обновляет существующую табличную структуру в соответствии с новой схемой. Проведя обновление базы данных сервера отчетов к новому формату, уже невозможно будет это отменить. База данных при миграции заменяется. Программа установки использует сведения о соединении с базой данных из файла RSReportServer.config, чтобы найти базу данных сервера отчетов и соединиться с ней.

Обновление установки не изменяет имя базы данных сервера отчетов или данных соединения. Данные учетной записи, которые сервер отчетов использует для доступа к базе данных сервера отчетов, не изменяются. Дополнительные сведения об обновлении базы данных см. в разделе Обновление базы данных сервера отчетов.

Усовершенствование содержимого сервера отчетов

При обновлении сервера отчетов происходит также обновление отчетов, но не остального содержимого, хранящегося на сервере отчетов. Опубликованные отчеты и моментальные снимки подвергаются обновлению в ходе длительного процесса в конце работы программы установки. Подписки, расписания, общие источники данных и ресурсы идентичны версиям до обновления. Дополнительные сведения об обновлении отчетов путем замены на месте см. в разделе Обновление отчетов.

Обновление назначений ролей для использования новых функций построения нерегламентированных отчетов

Определения и назначения ролей во время обновления не изменяются. Это означает, что новые задачи и определения ролей, введенные в сервере SQL Server 2005, в обновленной установке не реализованы. Для использования новых задач и ролей необходимо вручную обновить роли и назначения ролей.

Новые задачи и роли поддерживают специальные функции отчетности, позволяющие пользователям создавать модели и использовать построитель отчетов. Перед этим необходимо обновить существующие роли и назначения ролей. Дополнительные сведения см. в разделе Обновление безопасности на основе ролей для доступа к построителю отчетов.

Усовершенствование файлов конфигурации

Файлы конфигурации существующей установки используются в обновленной установке. Новые настройки добавляются и устанавливаются в процессе обновления. Не все новые настройки доступны по завершению процесса обновления. Дополнительные настройки могут быть добавлены, если воспользоваться программой настройки служб Reporting Services.

Если производится обновление SQL Server 2005 с пакетом обновления 1 (SP1), файлы конфигурации не обновляются и не включают никаких новых настроек. Программа установки пакета обновления 1 (SP1) не изменяет файлы конфигурации. Единственным новым параметром конфигурации, добавленным в пакет обновления 1 (SP1), является модуль обработки данных BI для SAP NetWeaver. Дополнительные сведения о ручной настройке этих параметров см. в разделе Настройка служб Reporting Services для использования поставщика данных Microsoft .NET 1.0 для бизнес-аналитики SAP NetWeaver.

Совместное обновление компонентов служб Reporting Services

Службы Reporting Services включают в себя клиентские и серверные компоненты. Если осуществляется обновление серверных компонентов, следует также соответствующим образом обновить все клиентские компоненты. В особенности это относится к конструктору отчетов. Хотя работа конструктора отчетов версии SQL Server 2000 с сервером отчетов SQL Server 2005 возможна, можно заметить рассогласованность между предварительным просмотром отчета в конструкторе отчетов и тем, как отчет выглядит в процессе выполнения. Обратите внимание на то, что, подвергнув конструктор отчетов обновлению, уже невозможно будет использовать его для публикации отчетов на сервере отчетов SQL Server 2000. Различия пространства имен делают невозможной публикацию на обеих версиях сервера отчетов.

Совместное обновление компонентов SQL Server

Можно обновить сервер отчетов и компонент Database Engine раздельно или совместно. Нижеприведенный список кратко описывает обновление компонентов.

  • Если проводится обновление только компонента Database Engine, процесс не оказывает влияния на сервер отчетов и базу данных сервера отчетов. Обновленный компонент Database Engine содержит существующую базу данных сервера отчетов, определенную в соответствии со старой схемой.

  • Если проводится обновление только сервера отчетов, программа установки изменяет табличную структуру базы данных сервера отчетов в соответствии с новым форматом.

  • Если производится обновление обоих компонентов, первым обновляется ядро СУБД, затем сервер отчетов.

Процесс обновления установленной службы Reporting Services запускается только тогда, когда программа установки выявляет принадлежность компонента сервера отчетов или конструктора отчетов к версии SQL Server 2000.

Компоненты, удаляемые в процессе обновления

В процессе обновления программа установки удаляет компоненты, которые заменяются новыми компонентами в выпуске SQL Server 2005. Нижеследующий список перечисляет, какие компоненты обновляются или удаляются. Дополнительные сведения о том, как выбрать компонент в программе установки, см. в разделе Установка служб Reporting Services с помощью программы установки.

  • Сервер отчетов, диспетчер отчетов и базы данных сервера отчетов подвергаются обновлению.

  • Конструктор отчетов удаляется и заменяется установкой среды Business Intelligence Development Studio. В SQL Server 2005 конструктор отчетов работает в среде Business Intelligence Development Studio. Предыдущая версия, работающая в Visual Studio 2003, и все файлы программы удаляются из системы.

  • Электронная документация служб Reporting Services удалена. В новом выпуске документация по продукту включена в электронную документацию SQL Server 2005.

Важно!
Если устанавливалось обновление документации, непременно удалите его прежде, чем приступить к обновлению. Это необходимо сделать вручную. Хотя функция обновления удаляет файлы документации, она не убирает пункт с программой из списка Добавить или удалить программы.

  • Образцы удаляются. Новые версии доступны посредством программы установки.

  • Административные средства командной строки удаляются. Обратите внимание на то, что средство rsactivate.exe больше не используется и не устанавливается в этом выпуске.

См. также

Основные понятия

Обновление служб Reporting Services

Другие ресурсы

Обратная совместимость служб Reporting Services


Обновление отчетов

Обновление отчетов |
 | См. также
Обновление до SQL Server 2005 > Обновление компонентов SQL Server > Обновление служб Reporting Services >

Во время обновления экземпляра служб SQL Server 2000 Reporting Services до SQL Server 2005 можно обновить определения отчетов, опубликованные отчеты и моментальные снимки отчетов. В SQL Server 2005 изменены язык определения отчетов и объектная модель отчетов. Эти изменения затрагивают отчеты, созданные в предыдущих версиях программного обеспечения. Существующие отчеты, которые предполагается запускать на сервере отчетов служб SQL Server 2005 Reporting Services, необходимо обновить.

Определения отчетов (RDL-файлы) обновляются после их открытия в конструкторе отчетов. Опубликованные отчеты и моментальные снимки обновляются при первом использовании после обновления сервера отчетов. Во время обновления отчета он изменяется следующим образом.

  • Пространство имен определения отчетов изменено на http://schemas.microsoft.com/sqlserver/reporting/2005/01/reportdefinition.

  • Элемент Actions изменен, и теперь поддерживает несколько действий. и может содержать более одного дочернего элемента.

  • Элемент CustomReportItem изменен, и теперь поддерживает привязанные к данным элементы управления и модули обработки отчета. Он включает дочерние элементы, которые описывают данные, используемые элементом управления, свойствами и измерениями элемента управления в отчете. XML-структура, используемая с элементом CustomReportItem, при обновлении в конструкторе отчетов кодируется в формате HTML, и будет декодирована во время публикации на сервере отчетов.

  • Элемент Custom заменен коллекцией пользовательских свойств, содержащей пары «имя-значение». При обновлении все экземпляры пользовательских элементов ставятся в соответствие пользовательскому свойству из коллекции пользовательских свойств.

После обновления отчета можно столкнуться с дополнительными ошибками, предупреждениями и сообщениями. Это результат улучшений внутренней объектной модели отчетов и компонентов-обработчиков: сообщения создаются при обнаружении проблем в отчете.

Файлы определения отчетов (RDL) и конструктор отчетов

Определения отчетов могут быть обновлены в соответствии с новым пространством имен при открытии RDL-файлов в конструкторе отчетов SQL Server 2005. Выводится запрос, следует ли обновлять определение отчета при его открытии. После обновления определения отчета его нельзя будет открыть в предыдущих версиях конструктора отчетов.

Кроме того, определения отчетов обновляются при публикации или загрузке на сервер отчетов SQL Server 2005 RDL-файла, созданного с использованием служб Reporting Services более ранней версии. Отчет публикуется в формате языка определения отчетов версии SQL Server 2005. Исходный файл не обновляется, пока он не будет открыт в конструкторе отчетов.

Примечание.
Нельзя публиковать отчет, содержащий пространство имен определения отчета сервера SQL Server 2005, на сервере отчетов SQL Server 2000.

На одном и том же компьютере можно параллельно запустить несколько разных версий конструктора отчетов. Дополнительные сведения см. в разделе How to: Install Reporting Services Side-by-Side with an Earlier Version.

Опубликованные отчеты и моментальные снимки отчетов

Опубликованные и сохраненные отчеты обновляются автоматически, без участия пользователя. Обновление отчета выполняется при первом обращении к нему. Это происходит, когда пользователь открывает отчет или моментальный снимок отчета или когда сервер отчетов обрабатывает подписку. После обновления опубликованного отчета или моментального снимка его нельзя запускать на более ранних версиях продукта.

Версии отчетов, которые могут быть обновлены

Можно обновить отчеты, созданные с использованием следующих версий служб Reporting Services:

  • SQL Server 2000

  • SQL Server 2000 с пакетом обновления 1 (SP1)

  • SQL Server 2000 с пакетом обновления 2 (SP2)

  • SQL Server 2005 Beta 3

  • Версия продукта SQL Server 2005 с пакетом обновления 1 (SP1).

См. также

Основные понятия

Обновление выпусков служб Reporting Services


Обновление безопасности на основе ролей для доступа к построителю отчетов

Обновление безопасности на основе ролей для доступа к построителю отчетов |
 | См. также
Обновление до SQL Server 2005 > Обновление компонентов SQL Server > Обновление служб Reporting Services >

Новое содержимое: 14 апреля 2006 г.

Сервер SQL Server 2005 представляет новые задачи, позволяющие пользователям создавать модели и пользоваться построителем отчетов. При обновлении существующей установки программа установки не изменяет существующие определения ролей и не включает в них новые задачи, предоставляющие доступ к этим функциям. После обновления установки необходимо вручную обновить существующие определения и назначения ролей, включив в них новые задачи. В службы SQL Server 2005 Reporting Services включены следующие новые задачи:

Имя Тип Описание

Просмотр моделей

Задача уровня элемента

Позволяет пользователям просматривать модели в иерархии папок, использовать модели в качестве источников данных для отчетов и выполнять запросы к моделям для получения данных.

Эта задача необходима для просмотра нерегламентированных отчетов, автоматически формируемых сервером отчетов, а также для использования построителя отчетов.

Управление моделями

Задача уровня элемента

Позволяет пользователям создавать, просматривать и удалять модели, а также просматривать и изменять свойства моделей. Пользователи, которые могут выполнять эту задачу, могут также назначать параметры безопасности элементу модели и сопоставлять предопределенные статические отчеты элементам моделей.

Использование отчетов

Задача уровня элемента

Позволяет пользователям загружать публикуемые отчеты с сервера отчетов в локальный экземпляр построителя отчетов. Пользователи, которым доступно выполнение этой задачи, могут открывать и редактировать опубликованные отчеты, основанные на моделях.

Выполнение определений отчета

Задача системного уровня

Позволяет пользователю обрабатывать определение отчета, в текущий момент не хранящееся в сервере отчетов.

В инструментальных средствах, включенных вместе со службами Reporting Services, эта задача используется для доступа к построителю отчетов. Пользователи, которые могут выполнять эту задачу, могут нажать кнопку построителя отчетов в диспетчере отчетов для его запуска.

При прагматичном использовании эта задача способна поддерживать и более широкий диапазон применений. Пользователи, которые могут выполнять эту задачу, имеют разрешение на обработку файлов определений неопубликованных отчетов (RDL).

Обзор моделей

Задача элемента модели

Позволяет пользователю просматривать части модели. Эта задача может использоваться для указания того, какие из частей модели доступны пользователю или группе.

Новые установки служб SQL Server 2005 Reporting Services включают в себя новое определение роли «Построитель отчетов». Эта роль определяет набор задач, необходимых для пользования построителем отчетов. Роль построителя отчетов не создается при обновлении существующей установки. Но если необходимо иметь полный набор определений ролей, доступных в новой установке служб Reporting Services, можно вручную создать определение роли.

Обновление существующих определений ролей на уровне элемента

Если используются предопределенные определения ролей, их можно отредактировать, включив новые задачи. Добавление новых задач к существующим определениям ролей является самым простым способом предоставить текущим пользователям разрешения на просмотр и управление отчетами и моделями построителя отчетов. При добавлении новой задачи к существующему определению роли все назначения роли, включающие это определение, автоматически получают новые задачи.

  1. Найдите определения ролей на сервере отчетов. В среде Management Studio определения ролей расположены под узлом «Безопасность» в папке «Роли». В диспетчере отчетов откройте страницу настроек узла и щелкните Настроить определения роли на уровне элемента.

  2. Раскройте определение роли «Обозреватель». Добавьте к роли задачу «Просмотр моделей», а затем нажмите кнопку OK.

  3. Раскройте определение роли «Диспетчер содержимого». Добавьте «Управление моделями», «Просмотр моделей» и «Использование отчетов», чтобы предоставить все разрешения на модели, а также возможность создавать и изменять отчеты в построителе отчетов. Нажмите кнопку ОК.

  4. Раскройте определение роли «Издатель». Добавьте «Управление моделями», чтобы предоставить разрешение на создание, просмотр и удаление моделей на сервере отчетов. Нажмите кнопку ОК.

Как обновить существующие определения ролей на уровне системы

Чтобы сделать построитель моделей доступным для пользователей, необходимо добавить ряд задач в роли системного уровня.

  1. В среде Management Studio раскройте папку «Системные роли». В диспетчере отчетов откройте страницу «Настройки веб-узла» и щелкните Настроить определения роли на уровне системы.

  2. Раскройте определение роли «Администратор системы». Добавьте задачу «Выполнение определений отчетов». Нажмите кнопку ОК.

  3. Раскройте определение роли «Пользователь системы». Добавьте задачу «Выполнение определений отчетов». Нажмите кнопку ОК.

Создание нового определения роли построителя отчетов

Новые установки служб SQL Server 2005 Reporting Services включают в себя новое определение роли, организующее набор задач, используемых для работы с построителем отчетов, в единую коллекцию задач. При обновлении существующей установки это определение роли нужно создать вручную. Создание отдельного определения роли позволяет назначать пользователям построителя отчетов только те задачи, которые нужны для создания нерегламентированных отчетов.

  1. Создайте новое определение роли в среде Management Studio или при помощи диспетчера отчетов. Дополнительные сведения см. в разделе Как создать, удалить или изменить роль (диспетчер отчетов) или Как удалить или изменить роль (среда Management Studio).

  2. Назовите роль «Построитель отчетов».

  3. Добавьте следующие задачи: «Использование отчетов», «Просмотр отчетов», «Просмотр моделей», «Просмотр ресурсов», «Просмотр папок» и «Управление отдельными подписками».

  4. Сохраните определение роли.

Советы по использованию нового определения роли «Построитель отчетов»

При изменении существующего определения роли при помощи инструкций, указанных ранее в этом подразделе, достаточные разрешения на использование построителя отчетов для создания и сохранения отчетов имеют только пользователи, которые сопоставлены роли «Диспетчер отчетов». Чтобы функциями построителя отчетов могли пользоваться другие пользователи, необходимо создать или изменить назначения ролей, которые сопоставляют группу учетных записей только что созданной роли «Построитель отчетов».

  • Если возможно, создайте учетную запись группы домена, включающей всех пользователей, которым необходим доступ к построителю отчетов. Если это учетная запись группы, можно создать одно назначение ролей для всех пользователей.

  • Если нет возможности создать учетную запись группы, можно создать назначения ролей, сопоставляющие определенную учетную запись определению роли. Если уже имеется определение роли для определенного пользователя, можно изменить его, включив в него новое определение роли. Дополнительные сведения см. в разделе Создание, изменение и удаление назначений ролей.

  • Можно создать сценарий, создающий назначения ролей и выполняющий их на сервере отчетов. Дополнительные сведения см. в разделе Образцы сценариев (службы Reporting Services).

См. также

Другие ресурсы

Роль «Обозреватель»
Роль «Диспетчер содержимого»
Роль «Издатель»
Роль «Системный администратор»
Роль «Пользователь системы»
Роль «Построитель отчетов»
Назначение ролей для доступа к построителю отчетов
Защита моделей


Обновление базы данных сервера отчетов

Обновление базы данных сервера отчетов |
 | См. также
Обновление до SQL Server 2005 > Обновление компонентов SQL Server > Обновление служб Reporting Services >

Новое содержимое: 14 апреля 2006 г.

Схема базы данных сервера отчетов в следующих версиях служб Reporting Services может быть изменена. В данном подразделе описывается, каким образом производится обновление схемы базы данных до последней версии формата. Обратите внимание, что после обновления схемы произвести откат к предыдущей версии будет невозможно. Всегда создавайте резервную копию базы данных сервера отчетов, прежде чем производить обновление, чтобы иметь возможность возврата к предыдущей версии.

Примечание.
Возможно обновление базы данных сервера отчетов, выполняющейся под управлением экземпляра компонента SQL Server 2000 Database Engine без его обновления до SQL Server 2005. Можно также использовать экземпляр компонента SQL Server 2000 Database Engine для сохранения новой базы данных сервера отчетов, созданной для установки служб SQL Server 2005 Reporting Services.

База данных сервера отчетов обновляется в три этапа.

  1. Обновление схемы производится автоматически во время установки или вручную с использованием программы настройки служб Reporting Services.

  2. Метаданные и описания безопасности обновляются при первом использовании базы данных сервера отчетов после обновления схемы.

  3. Опубликованные отчеты и скомпилированные моментальные снимки отчетов обновляются при первом использовании. Дополнительные сведения см. в разделе Обновление отчетов.

Кроме базы данных сервера отчетов при работе сервера отчетов используется временная база данных. Она обновляется автоматически при обновлении базы данных сервера отчетов.

Способы обновления базы данных сервера отчетов

База данных сервера отчетов может быть обновлена автоматически или вручную.

  • Программа установки производит обновление базы данных сервера отчетов автоматически при запуске конфигурации по умолчанию, если база данных сервера отчетов установлена локально.

  • Программа установки также автоматически обновляет базу данных сервера отчетов при запуске программы установки из командной строки. Если база данных сервера отчетов установлена на удаленном экземпляре SQL Server или запущена на другом именованном экземпляре на том же компьютере, следует запустить программу установки из командной строки и указать аргументы RSUPGRADEDATABASEACCOUNT и RSUPGRADEPASSWORD с учетными данными, обладающими разрешениями на обновление схемы.

  • Любую базу данных сервера отчетов можно обновить вручную, независимо от того, запущена она локально или на удаленном сервере. Для обновление базы данных сервера отчетов воспользуйтесь программой настройки служб Reporting Services. Параметр обновления на странице «Установка базы данных» выполнит сценарий, который обновляет схему до самой последней версии.

Обновление базы данных сервера отчетов на удаленном сервере

При обновлении установки службы Reporting Services, содержащей базу данных на удаленном сервере, можно столкнуться с проблемами при обновлении схемы базы данных. По умолчанию программа установки для подключения к удаленному экземпляру SQL Server и обновления схемы пользуется маркером безопасности пользователя, который ее запустил. При наличии разрешений администратора и на локальном, и на удаленном компьютерах, обновление базы данных будет успешно произведено. Аналогичным образом, при запуске программы установки из командной строки с указанием аргументов RSUPGRADEDATABASEACCOUNT и RSUPGRADEPASSWORD с учетными данными, обладающими разрешениями на изменение схемы на удаленном компьютере обновление данных также произойдет успешно. Однако если разрешения на изменение схемы на удаленном компьютере отсутствуют, в соединении будет отказано со следующей ошибкой:

«Программе установки не удалось произвести обновление схемы базы данных сервера отчетов. Необходимо после ее завершения обновить схему базы данных вручную. Для этого запустите программу настройки служб Reporting Services, откройте страницу «Установка базы данных» и нажмите «Обновить». Дополнительные сведения см. в статье 91310 базы знаний Майкрософт».

Будут обновлены программные файлы сервера отчетов, однако база данных сервера отчетов останется в прежнем формате. Пока база данных сервера отчетов не будет обновлена, сервер отчетов будет недоступен.

Обновление базы данных вручную

Если программа установки не обновила базу данных сервера отчетов автоматически, то обновление установки сервера отчетов выполнено лишь частично. Для завершения обновления следует обновить базу данных сервера отчетов вручную, запустив программу настройки служб Reporting Services после завершения программы установки.

  1. Запустите программу настройки служб Reporting Services и подключитесь к только что обновленному экземпляру сервера отчетов. Дополнительные сведения о запуске этой программы и подключении к серверу см. в разделе Как запустить настройку служб Reporting Services.

  2. На странице «Установка базы данных» нажмите кнопку Соединить для подключения к экземпляру SQL Server, на котором располагается база данных сервера отчетов.

  3. Выберите базу данных сервера отчетов, которую необходимо обновить.

  4. Для обновления схемы базы данных нажмите кнопку Обновить.

После выполнения этих действий сервер отчетов станет доступен.

См. также

Задачи

Как запустить настройку служб Reporting Services

Основные понятия

Создание базы данных сервера отчетов
Обновление служб Reporting Services
Обновление установки по умолчанию служб Reporting Services
Миграция служб Reporting Services


Обновление выпусков служб Reporting Services

Обновление выпусков служб Reporting Services |
 | См. также
Обновление до SQL Server 2005 > Обновление компонентов SQL Server > Обновление служб Reporting Services >

Дата обновления: 14 апреля 2006 г.

В этом подразделе описаны требования и положения, действительные при обновлении некоторых выпусков служб Reporting Services. Сценарии обновления, рассматриваемые в этом разделе, включают в себя следующее.

  • Обновите пути для различных версий и выпусков служб Reporting Services.

  • Обновление до выпусков, имеющих большие функциональные возможности (например, с выпуска Standard Edition до Developer или Enterprise Edition).

  • Обновление до выпусков, имеющих меньшие функциональные возможности (например, с выпуска Evaluation до Standard Edition).

Можно также выполнить обновление из SQL Server 2005 Express Edition с дополнительными службами (SQL Server Express) до других выпусков. Дополнительные сведения см. в разделах Как обновить сервер отчетов выпуска SQL Server Express до выпуска с более широкими возможностями и Reporting Services in SQL Server 2005 Express Edition with Advanced Services электронной документации по SQL Server.

Обновление с SQL Server 2000

В следующей таблице показаны возможные пути обновления с выпусков SQL Server 2000 до служб Reporting Services SQL Server 2005.

Выпуск SQL Server 2000 | Выпуск SQL Server 2005
Evaluation | Evaluation
Standard | Standard, Developer, Enterprise
Developer | Developer
Enterprise | Enterprise

Возможны другие пути обновления (например, обновление с выпуска Developer Edition непосредственно до выпуска SQL Server 2005 Enterprise Edition), но программа установки не выполнит автоматически все необходимые шаги обновления. В этом случае можно установить новый экземпляр выпуска, а затем перенести базу данных сервера отчетов в новую установку. Дополнительные сведения см. в разделе Миграция служб Reporting Services.

Обновление выпуска Evaluation Edition

Чтобы обновить выпуск Evaluation Edition, необходимо, чтобы срок действия этого выпуска еще не истек. Если срок действия копии с ограниченным сроком действия истек, можно установить новый выпуск и затем настроить новый экземпляр сервера отчетов для использования существующей базы данных сервера отчетов. Если срок действия копии программного обеспечения с ограниченным сроком действия еще не истек, можно использовать программу установки, но при этом обновление выполняется в два этапа, приведенных ниже.

  1. Обновление выпуска SQL Server 2000 Evaluation Edition до SQL Server 2005 Evaluation Edition.

  2. Обновление выпуска SQL Server 2000 Evaluation Edition до любого другого выпуска SQL Server 2005.

Обновление выпусков в рамках SQL Server 2005

Можно выполнять обновления в рамках одного и того же выпуска SQL Server. В следующей таблице показан путь обновления для различных выпусков служб SQL Server 2005 Reporting Services. В каждом выпуске имеются требования к программному обеспечению, которые должны быть удовлетворены к началу обновления. Обновление может завершиться неудачей, если система не удовлетворяет минимальным требованиям к программному обеспечению, предъявляемым новым выпуском. Дополнительные сведения см. в разделе Обновления версий и выпусков.

SQL Server 2005 | SQL Server 2005
Evaluation | Express, Workgroup, Standard, Developer, Enterprise
Express | Standard, Developer, Enterprise
Workgroup | Standard, Developer, Enterprise
Standard | Developer, Enterprise
Developer | Standard, Developer, Enterprise

Обновление до выпусков, имеющих большие функциональные возможности

При наличии существующей установки служб Reporting Services Standard Edition, Express Edition или Workgroup Edition для обновления до выпуска Developer или Enterprise можно воспользоваться программой установки. В этих выпусках имеются дополнительные возможности. При подобном обновлении выпуска сокращение возможностей не произойдет. Все отчеты, модели и приложения, созданные в выпуске Standard Edition, будут работать и в обновленном выпуске. Дополнительные сведения см. в разделе Возможности, поддерживаемые различными выпусками SQL Server 2005.

Обновление до выпусков, имеющих меньшие функциональные возможности

При обновлении выпуска Evaluation Edition до Standard Edition или Workgroup Edition в обновленном выпуске больше не будет следующих функциональных возможностей:

  • управляемых данными подписок;

  • масштабного развертывания сервера отчетов;

  • поддержки более чем четырех процессоров.

Если какая-либо из этих возможностей имелась в выпуске Evaluation Edition, прочтите следующий раздел, чтобы определить влияние обновления в выпуске Standard Edition на существующие файлы и функциональность.

Управляемые данными подписки

Управляемые данными подписки деактивируются (это означает, что они больше не выполняются), но не удаляются. Удаление подписок необходимо выполнить вручную. Дополнительные сведения см. в разделе Создание, изменение и удаление управляемых данными подписок.

Масштабное развертывание сервера отчетов

При обновлении экземпляра сервера отчетов в масштабном развертывании до выпуска Standard Edition обновленный экземпляр сервера отчетов перестанет работать. Если два экземпляра сервера отчетов имеют общий доступ к одной базе данных сервера отчетов, необходимо создать отдельные базы данных сервера отчетов для каждого экземпляра. Для использования обновленного сервера отчетов можно выбрать одну из следующих возможностей:

  • Создать новую базу данных сервера отчетов для экземпляра сервера отчетов, который более не входит в масштабное развертывание. Дополнительные сведения см. в разделе Создание базы данных сервера отчетов.

  • Скопировать существующую базу данных сервера отчетов, присоединить ее, удалить сведения о ключах, а затем настроить обновленный сервер отчетов, чтобы им можно было пользоваться. Дополнительные сведения см. в разделе Миграция служб Reporting Services.

  • Продолжать использовать существующую базу сервера отчетов с обновленным сервером отчетов. Это можно сделать, удалив сведения о ключе, которые были созданы для другого экземпляра сервера отчетов в развертывании. Чтобы удалить сведения о ключе из экземпляров сервера отчетов, которые более не входят в масштабное развертывание, можно использовать страницу «Инициализация» программы конфигурации служб Reporting Services. Дополнительные сведения см. в разделах Добавление и удаление ключей шифрования для масштабного развертывания и Инициализация (конфигурация служб Reporting Services).

Поддержка более чем четырех процессоров

Программа установки не может обновить до выпуска Standard Edition существующую установку, выполняющуюся более чем на четырех процессорах. Необходимо установить новый экземпляр, а затем выполнить миграцию вашей установки.

См. также

Основные понятия

Обновление выпусков служб Reporting Services
Обновление веб-фермы сервера отчетов

Журнал изменений

Версия Журнал

14 апреля 2006 г.

Новое содержимое
  • SQL Server 2005 Express Edition с дополнительными службами


Обновление веб-фермы сервера отчетов

Обновление веб-фермы сервера отчетов |
 | См. также
Обновление до SQL Server 2005 > Обновление компонентов SQL Server > Обновление служб Reporting Services >

Дата обновления: 14 апреля 2006 г.

Данный подраздел содержит инструкции по обновлению нескольких экземпляров сервера отчетов, которые пользуются одной и той же базой данных сервера отчетов. В предыдущем выпуске эта модель развертывания называлась «Веб-ферма сервера отчетов». Этот термин больше не используется. Серверы отчетов, которые совместно используют одну базу данных, называются масштабным развертыванием сервера отчетов. Масштабное развертывание можно запустить в кластере с распределенной сетевой нагрузкой (NLB cluster). Необходимым условием является настройка узлов сервера отчетов для масштабного развертывания. Если службы Reporting Services развернуты в масштабное развертывание, необходимо обновить каждый из серверов отчетов, входящих в конфигурацию. Нельзя использовать масштабное развертывание, которое содержит различные версии служб Reporting Services на отдельных узлах.

Для обновления масштабного развертывания могут применяться следующие подходы.

  • Выполнить обновление существующего экземпляра, чтобы заменить существующую установку на новую версию. Можно обновлять узлы в любом порядке. База данных сервера отчетов обновляется при первом обновлении. Серверы должны находиться в автономном режиме до тех пор, пока не обновятся все узлы сервера отчетов и база данных (то есть следует остановить службы IIS и службу сервера отчетов Windows). Если начато обновление серверов, то необходимо обновить все узлы. В противном случае оставшиеся узлы сервера отчетов не будут работать до тех пор, пока они не будут обновлены для использования нового формата базы данных.

  • Выполнить параллельное обновление для установки нового экземпляра служб SQL Server 2005 Reporting Services на том же компьютере, что и существующая установка. При наличии временных требований или если установка не удовлетворяет требованиям для обновления на месте, можно установить новый экземпляр служб SQL Server 2005 Reporting Services, выполняющийся параллельно с существующими установками. Во время настройки и тестирования нового программного обеспечения пользователи могут продолжать использовать существующее масштабное развертывание.

До обновления рабочих серверов важно испытать шаги обновления на тестовых серверах, что даст представление о том, чего следует ожидать.

Подготовка к обновлению

Для подготовки к обновлению применяется следующий контрольный список.

  1. Создайте резервную копию базы данных и симметричного ключа сервера отчетов.

  2. Убедитесь в том, что известна учетная запись и пароль для подключения к ядру СУБД SQL Server, на котором находится база данных сервера отчетов. Для выполнения обновления учетная запись должна иметь разрешения локального администратора.

  3. Создайте резервную копию всех файлов конфигурации (в том числе файлов Machine.config и Web.config) для каждого из экземпляров сервера отчетов.

  4. Создайте резервную копию файлов журналов.

  5. Подготовьте сервер к простою. Если используется распределение сетевой нагрузки Microsoft Windows, можно установить уровень приоритета узлов так, чтобы изолировать их от новых подключений. Этот шаг снижает нагрузку до текущих сеансов пользователей.

    1. Войдите в систему каждого из компьютеров.

    2. Запустите диспетчер распределения сетевой нагрузки на первом компьютере и откройте список узлов.

    3. В списке приоритетов узлов отметьте уровень для каждого узла. Используйте уровень приоритета для определения порядка, в котором производится обновление узлов. В первую очередь обновите узел с наименьшим приоритетом.

    4. На узле с наименьшим приоритетом правой кнопкой мыши щелкните имя узла, выберите «Управляющий узел», а затем «Остановить». Благодаря этому все новые соединения перенаправляются к другим узлам. Текущие сеансы продолжают работу. Если сервер отчетов используется многими пользователями, то в целях уменьшения количества открытых сеансов ограничьте создание новых соединений за несколько часов до начала обновления.

    5. Закройте диспетчер распределения сетевой нагрузки, если он открыт. Закройте все остальные открытые оснастки консоли управления (MMC).

  6. Когда все готово к выключению сервера отчетов, выполните следующее:

    1. Остановите службу инструментария управления Windows (WMI).

    2. Остановите службу сервера отчетов Windows.

    3. Сбросьте в исходное состояние службы IIS.

    4. Остановите службы IIS.

Обновление до масштабного развертывания сервера отчетов SQL Server 2005

Следующие шаги предполагают, что установка нового экземпляра производится параллельно с существующей установкой. Если необходимо выполнить обновление на месте, можно воспользоваться инструкциями по установке пакета обновления 1 (SP1).

Эти шаги используются при обновлении сервера отчетов. Если компьютер обладает также экземпляром компонента Database Engine, то его можно обновить одновременно, позже либо не обновлять вообще.

  1. Запустите программу установки. В поле Имя экземпляра введите новое имя для устанавливаемого экземпляра SQL Server 2005. Не следует указывать Экземпляр по умолчанию. Это приведет к обновлению существующей установки вместо создания нового экземпляра сервера отчетов.

  2. После завершения установки просмотрите временные метки для программных файлов, чтобы убедиться, что файлы скопированы успешно.

  3. Запустите службу Windows сервера отчетов.

  4. Откройте файлы reportserverservice.log и найдите фразу «действие завершено успешно». Эта запись подтверждает, что обновление выполнено.

  5. Запустите службы IIS.

  6. Откройте окно обозревателя и введите URL-адрес сервера отчетов. Убедитесь, что сведения о версии в нижней части страницы отражают версию продукта.

  7. Запустите службу WMI.

Обновление до версии с пакетом обновления 1 (SP1)

Пакет обновления 1 (SP1) применяется при выполнении пакета на существующей установке SQL Server 2005. Если масштабное развертывание SQL Server 2005 обновляется до версии с пакетом обновления 1 (SP1), следует применить пакет обновления к каждому из узлов. Обновление первого узла вызывает обновление базы данных сервера отчетов, поэтому все остальные узлы должны быть переведены в автономное состояние до тех пор, пока все они не будут обновлены. Чтобы обновить узел сервера отчетов до версии с пакетом обновления 1 (SP1), выполните следующие действия.

Примечание.
При обновлении базы данных сервера отчетов не происходит обновления экземпляра компонента Database Engine, на котором она размещается. Дополнительные сведения см. в разделе Обновление базы данных сервера отчетов.

  1. Выберите первый обновляемый узел. Переведите все остальные узлы в автономное состояние.

  2. Остановите службу WMI, службу Windows сервера отчетов и все остальные службы SQL Server, входящие в состав обновляемой установки.

  3. Произведите сброс службы IIS, а затем остановите ее.

  4. Запустите пакет, устанавливающий пакет обновления 1 (SP1). Если на компьютере имеется несколько экземпляров, удостоверьтесь в том, что выбран именно тот экземпляр, на котором запущены службы Reporting Services. Если база данных сервера отчетов находится на удаленном компьютере, будет выдано приглашение ввести учетные данные, обладающие разрешениями на обновление базы данных сервера отчетов.

  5. После завершения обновления просмотрите временные метки программных файлов, чтобы удостовериться, что файлы скопированы успешно.

  6. Запустите службу Windows сервера отчетов.

  7. Откройте файлы ReportServerService_<временная_метка>.log и найдите запись «действие завершено успешно». Эта запись подтверждает, что обновление выполнено.

  8. Запустите службы IIS.

  9. Откройте окно обозревателя и введите URL-адрес сервера отчетов (по умолчанию это http://localhost/reportserver). Убедитесь, что сведения о версии в нижней части страницы соответствуют ожидаемой версии продукта.

  10. Запустите службу WMI.

Повторите эти шаги для всех остальных узлов в масштабном развертывании.

См. также

Основные понятия

Обновление выпусков служб Reporting Services
Обновление базы данных сервера отчетов
Обновление компонента Database Engine
Настройка масштабного развертывания сервера отчетов

Журнал изменений

Версия Журнал

14 апреля 2006 г.

Измененное содержимое:
  • Проблема масштабного развертывания экземпляра по умолчанию


Миграция служб Reporting Services

Миграция служб Reporting Services |
 | См. также
Обновление до SQL Server 2005 > Обновление компонентов SQL Server > Обновление служб Reporting Services >

В этом разделе описываются пошаговые инструкции, позволяющие выполнить миграцию развертывания служб SQL Server 2000 Reporting Services в новый экземпляр служб SQL Server 2005 Reporting Services. Миграция установки может оказаться полезной в тех случаях, когда встречается блокировка обновления, нужно производить крупномасштабное развертывание, имеются требования по времени или заменено оборудование или топология установки. Процесс миграции служб Reporting Services включает в себя ручные и автоматические шаги. При выполнении миграции сервера отчетов выполняются следующие задачи.

  • Резервное копирование приложений и файлов конфигурации.

  • Установите новый экземпляр SQL Server 2005 параллельно с существующей установкой SQL Server 2000. Так как службы SQL Server 2000 Reporting Services всегда выполняются на экземпляре SQL Server по умолчанию, новый устанавливаемый экземпляр SQL Server 2005 должен быть настроен как именованный экземпляр.

  • Переместите базу данных сервера отчетов из экземпляра SQL Server 2000 в новый экземпляр SQL Server 2005.

  • После проверки работоспособности нового экземпляра удалите службы SQL Server 2000 Reporting Services.

Если существующая, созданная при предыдущей установке база данных сервера отчетов используется повторно, помните, что существуют ограничения на выпуск SQL Server, используемый для хранения базы данных сервера отчетов. Дополнительные сведения см. в разделе Создание базы данных сервера отчетов.

Резервное копирование файлов и данных

Перед установкой нового экземпляра служб Reporting Services не забудьте выполнить резервное копирование всех файлов в текущей установке.

  1. Создайте резервную копию симметричного ключа для базы данных сервера отчетов. Для выполнения этой операции используйте программу rskeymgmt.

  2. Создайте резервную копию базы данных сервера отчетов с помощью любого из поддерживаемых методов резервного копирования базы данных SQL Server. Дополнительные сведения приведены в указаниях по резервному копированию базы данных сервера отчетов в разделе Перемещение базы данных сервера отчетов на другой компьютер.

  3. Создайте резервную копию файлов конфигурации сервера отчетов. Необходимо создать резервные копии следующих файлов:

    1. Rsreportserver.config ;

    2. Rswebapplication.config ;

    3. Rssvrpolicy.config ;

    4. Rsmgrpolicy.config ;

    5. Reportingservicesservice.exe.config ;

    6. Web.config для приложений ASP.NET сервера отчетов и диспетчера отчетов;

    7. Machine.config для ASP.NET.

  4. Создайте резервную копию настроек виртуального каталога сервера отчетов. Для резервного копирования установок пользуйтесь диспетчером служб IIS.

  5. Для сервера отчетов с высоким уровнем доступности переведите его базу данных в состояние только для чтения и измените роль RSExec компонента SQL Server Database Engine так, чтобы остановить транзакции в базах данных сервера отчетов.

Установите службы SQL Server 2005 Reporting Services

  1. Для установки нового экземпляра служб Reporting Services запустите программу установки SQL Server 2005.

  2. На странице «Компоненты для установки» выберите Службы Reporting Services. Если необходимо установить новый экземпляр службы Database Engine и конструктор отчетов на одном компьютере, можно также выбрать службы SQL Server Database Services, компоненты рабочей станции, электронную документацию и средства разработки.

  3. В поле «Имя экземпляра» введите новое имя для устанавливаемого экземпляра SQL Server 2005. Экземпляр по умолчанию указывать нельзя, это приведет к обновлению существующей установки вместо создания нового экземпляра сервера отчетов.

  4. В поле «Учетная запись службы» задайте учетную запись для службы Windows сервера отчетов. Дополнительные сведения об учетных записях служб см. в разделе Настройка учетных записей служб Windows.

    (Необязательно). При запуске служб в конце программы установки выберите агент SQL Server (он должен быть запущен для поддержки запланированных операций).

  5. В параметрах установки сервера отчетов выберите параметр Установить, но не настраивать сервер. Это позволит настроить сервер отчетов после завершения программы установки.

  6. Закончите установку.

  7. При применении пакета обновления 1 (SP1) остановите все службы SQL Server 2005 (в том числе службу Windows сервера отчетов, агент SQL Server, обозреватель SQL Server и полнотекстовый поиск SQL Server).

  8. Примените пакет обновления 1 (SP1), а затем перезапустите службы.

  9. Присоедините базу данных сервера отчетов, резервная копия которой была создана из экземпляра SQL Server 2000, к новому экземпляру или восстановите базу данных из резервной копии в новый экземпляр. Необходимо переместить и базу данных сервера отчетов, и временную базу данных.

    Не копируйте базы данных. В процессе копирования в новый экземпляр переносятся не все параметры настройки безопасности.

    Если используется новый экземпляр компонента SQL Server 2005 Database Engine, для присоединения или восстановления баз данных можно воспользоваться средой SQL Server Management Studio. Инструкции см. в разделе Перемещение базы данных сервера отчетов на другой компьютер. Если для хранения базы данных сервера отчетов используется SQL Server 2000, создайте копию базы данных для новой установки.

  10. Скопируйте установки из файла rsreportserver.config, используемого в установке SQL Server 2000, в файл rsreportserver.config новой установки SQL Server 2005 следующим образом.

    1. Скопируйте элемент InstallationID. Копирование идентификатора установки необходимо в том случае, если нужно избежать наличия двух неиспользуемых записей в таблице «Ключи» базы данных сервера отчетов. Две неиспользуемые строки являются идентификаторами установки экземпляра SQL Server 2000. Неиспользуемые строки не завершены. Во всех строках отсутствуют имя компьютера и имя экземпляра. Для экземпляра SQL Server 2000 имя компьютера и имя экземпляра не определены, в результате чего после обновления базы данных сервера отчетов в этих столбцах таблицы «Ключи» значения будут отсутствовать. Заметим, что если в записи отсутствует имя компьютера или имя экземпляра, ее нельзя удалить через программу настройки служб Reporting Services. Однако для удаления строк или для добавления отсутствующих имени компьютера или имени экземпляра можно отредактировать таблицу «Ключи». Можно также оставить в таблице неиспользуемые записи, которые не влияют на работу сервера отчетов.

    2. Скопируйте другие пользовательские установки, которые необходимо использовать в новой установке. Если вы используете пользовательские модули в вашей установке, вам может понадобиться перекомпилировать модули, перед тем как их можно будет использовать. Дополнительные сведения см. в документации по помощнику по обновлению.

    Если имеются пользовательские установки трассировки, скопируйте записи в файлы Web.config или Machine.config новой установки.

Настройка сервера отчетов

  1. Запустите программу конфигурации служб Reporting Services и подключитесь к только что установленному экземпляру служб SQL Server 2005 Reporting Services.

  2. Создайте виртуальные каталоги для сервера отчетов и диспетчера отчетов. Имена виртуальных каталогов должны быть уникальными, поэтому, если в установке служб SQL Server 2000 Reporting Services были выбраны имена по умолчанию, для установки SQL Server 2005 необходимо выбрать другие имена.

    При создании виртуального каталога сервера отчетов удостоверение веб-службы должно быть настроено автоматически. Если эта настройка выполнена неверно, можно создать новый пул приложений для выполнения службы.

    Настройка службы Windows сервера отчетов должна выполняться автоматически во время установки. Если необходимо выполнять службу под другой учетной записью, теперь можно ее изменить. Дополнительные сведения об учетных записях службы см. в разделах Настройка учетных записей служб Windows и Соединения и учетные записи при развертывании служб Reporting Services электронной документации по SQL Server.

  3. Для остановки службы Windows сервера отчетов на странице «Состояние сервера» выберите Остановить. Этот шаг очень важен. Если служба не будет остановлена, время ожидания операции обновления базы данных может истечь до того, как схема будет полностью обновлена, в результате чего база данных останется в промежуточном состоянии.

  4. На странице установки базы данных в поле «Имя сервера» выберите экземпляр SQL Server, который содержит обновляемую базу данных сервера отчетов, и нажмите Соединить.

  5. Выберите базу данных сервера отчетов, которую необходимо использовать в установке SQL Server 2005.

  6. Нажмите кнопку Обновить. База данных сервера отчетов и временная база данных обновляются до новой версии схемы.

  7. Укажите учетную запись, используемую для подключения к базе данных сервера отчетов.

  8. На странице «Ключи шифрования» восстановите ключ, используемый для шифрования и дешифрования содержимого базы данных сервера отчетов. Это тот ключ шифрования, резервная копия которого была создана на шаге 1 подраздела «Резервные копии файлов и данных».

  9. Проверьте виртуальные каталоги сервера отчетов и диспетчера отчетов, открыв обозреватель и введя URL-адрес. URL-адреса и сведения о соединении с базой данных, заданные для этого экземпляра, должны включать имя экземпляра.

  10. Проверьте отчеты и убедитесь в том, что они содержат ожидаемые данные. Просмотрите сведения об источнике данных на предмет того, содержатся ли в них данные о подключении к источнику данных.

  11. Удалите службы SQL Server 2000 Reporting Services.

  12. Измените имена виртуальных каталогов на имена, применявшиеся в предыдущей установке. Если использовались пользовательские установки виртуального каталога, обновите виртуальные каталоги, созданные для использования новых значений.

См. также

Основные понятия

Обновление служб Reporting Services

Другие ресурсы

База данных сервера отчетов
Обратная совместимость служб Reporting Services
Программа конфигурации служб Reporting Services


Как обновить сервер отчетов выпуска SQL Server Express до выпуска с более широкими возможностями

Как обновить сервер отчетов выпуска SQL Server Express до выпуска с более широкими возможностями |
 | См. также
Обновление до SQL Server 2005 > Обновление компонентов SQL Server > Обновление служб Reporting Services >

Новое содержимое: 14 апреля 2006 г.

Выпуск SQL Server 2005 Express Edition с дополнительными службами (SQL Server Express) включает подмножество функций служб Reporting Services. Чтобы пользоваться дополнительными функциями, необходимо перейти на другой выпуск. Можно произвести обновление служб Reporting Services для SQL Server 2005 с выпуска Express до выпуска Standard, Developer, Enterprise или Workgroup Edition. Не все функции служб Reporting Services доступны в каждом из выпусков. Если SQL Server Express обновляется по причине необходимости использования какой-либо функции, проверьте, что данный выпуск его поддерживает. Дополнительные сведения см. в разделе Возможности, поддерживаемые различными выпусками SQL Server 2005.

Выпуск Express Edition служб Reporting Services основан на SQL Server 2005 с пакетом обновления 1 (SP1). Поэтому их версия в выпуске Express Edition более новая, чем та, которая поставляется с другими выпусками SQL Server 2005. В выпуск Express Edition включены улучшения из пакета обновления 1 (SP1) и используется версия схемы базы данных сервера отчетов, соответствующая пакету обновления 1 (SP1). При переходе с выпуска Express Edition на другой выпуск SQL Server схема сервера отчетов остается в формате пакета обновления 1 (SP1), и при обновлении версии не изменяется. Чтобы использовать базу данных сервера отчетов, оставшуюся от SQL Server Express, необходимо установить пакет обновления 1 (SP1). Это позволит избежать возможных проблем совместимости между сервером отчетов и базой данных сервера отчетов.

Службы Reporting Services обладают некоторыми требованиями к выпуску компонента SQL Server Database Engine, на котором находится база данных сервера отчетов. После обновления версии сервера отчетов SQL Server Express больше нельзя использовать для хранения базы данных сервера отчетов. Вместо этого необходимо либо выбрать другой экземпляр компонента SQL Server Database Engine, либо произвести обновление экземпляра компонента Database Engine в SQL Server Express на другой выпуск, обеспечивающий совместимость. Это может быть локальный или удаленный экземпляр компонента SQL Server 2000 Database Engine или SQL Server 2005 Database Engine, который допустим для данного выпуска сервера отчетов. Дополнительные сведения о требованиях к выпуску базы данных сервера отчетов см. в разделе Создание базы данных сервера отчетов.

Для обновления установки необходимо указать аргумент SKUUPGRADE=1. Он указывается при запуске мастера установки SQL Server. Или же программу установки можно запустить из командной строки, включив в нее аргумент SKUUPGRADE=1.

Для упрощения процесса обновления и минимизации настройки после завершения установки необходимо одновременно обновлять службы Reporting Services и компонент Database Engine. Если выбрано обновление только служб Reporting Services, следует присоединить базу данных сервера отчетов к желаемому экземпляру компонента Database Engine, а затем настроить сервер отчетов на использование этой базы данных.

Следующий пример показывает командную строку, которая производит одновременное обновление служб Reporting Services и компонента Database Engine:

Копировать код
start /wait setup.exe ADDLOCAL=SQL_Engine,RS_Server PIDKEY=ABCDE12345FGHIJ67890KLMNO INSTANCENAME=SQLEXPRESS UPGRADE=SQL_Engine,RS_Server SKUUPGRADE=1 /qb

Этот пример подразумевает, что программа установки запускается из папки, которая содержит программный файл Setup.exe выпуска, до которого производится обновление (не запускайте программу установки SQL Server Express для обновления до другого выпуска). Указанное в примере значение PIDKEY вымышленное. Указывайте значение, соответствующее выпуску, до которого производится обновление. Дополнительные сведения о запуске программы установки из командной строки см. в разделе Как установить SQL Server 2005 из командной строки.

После завершения обновления необходимо установить пакет обновления 1 (SP1). Если этого не сделать, будет выдано сообщение об ошибке совместимости базы данных.

Обратите внимание, что после начала обновления установки SQL Server Express сервер отчетов и его содержимое не будут доступны, пока все шаги установки не завершаться.

Обновление установки SQL Server Express

  1. Создайте резервную копию базы данных сервера отчетов и временной базы данных сервера отчетов. По умолчанию эти базы данных называются reportserver$SQLExpress и reportserverTempDB$SQLExpress.

  2. Создайте резервную копию файла RSReportServer.config. Если изменялись другие файлы конфигурации (например Web.config или RSWebApplication.config), их также необходимо включить в резервную копию.

  3. Создайте резервную копию ключа шифрования при помощи страницы «Ключи шифрования» программы настройки служб Reporting Services. Дополнительные сведения см. в разделе Создание резервных копий и восстановление ключей шифрования.

  4. Запустите программу установки с аргументом SKUUPGRADE=1.

    Для запуска программы установки в автоматическом режиме из командной строки пользуйтесь синтаксисом, приведенным в следующем примере. Обратите внимание, что значение PIDKEY вымышлено. Указывайте вместо него значение PIDKEY, соответствующее устанавливаемому выпуску.

    Копировать код
    start /wait setup.exe ADDLOCAL=SQL_Engine,RS_Server PIDKEY=ABCDE12345FGHIJ67890KLMNO INSTANCENAME=SQLEXPRESS UPGRADE=SQL_Engine,RS_Server SKUUPGRADE=1 /qb

    Запуск мастера установки SQL Server:

    1. Откройте командную строку, перейдите в каталог, в котором находится установочный носитель, а затем введите в командной строке setup.exe SKUUPGRADE=1 (например d:\setup.exe SKUUPGRADE=1).

    2. На странице «Регистрационные данные» введите идентификационные данные, предназначенные для регистрации вашей копии SQL Server.

    3. На странице «Компоненты для установки» выберите Службы баз данных, Службы Reporting Services и Компоненты рабочей станции, электронная документация и средства разработки.

    4. На странице «Имя экземпляра» выберите Именованный экземпляр, а затем выберите обновляемый экземпляр SQLEXPRESS.

    5. Завершите мастер, установив параметры на оставшихся страницах.

  5. После завершения установки примените пакет обновления 1 (SP1).

Чтобы проверить, успешно ли произошло обновление, откройте диспетчер отчетов. Должна сохраниться возможность просмотра всех ранее созданных отчетов. Если виртуальный каталог не изменялся, URL-адрес для доступа к диспетчеру отчетов в обновленной версии будет тем же, который использовался в установке Express.

Если имена не изменялись, обновленная установка продолжает пользоваться ими. Если использовались имена SQL Server Express по умолчанию, обновленный экземпляр SQL Server продолжает оставаться <servername>\SQLExpress. Для баз данных имена по умолчанию по-прежнему будут reportserver$sqlexpress и reportservertempdb$sqlexpress. URL-адреса по умолчанию по-прежнему будут http://<servername>/reports$SQLExpress и http://<servername>/reportserver$SQLExpress. Во избежание недоразумений можно повторно зарегистрировать экземпляр SQL Server, чтобы изменить имя экземпляра и переименовать виртуальные каталоги сервера отчетов. Переименование базы данных сервера отчетов не поддерживается. Дополнительные сведения см. в разделах Регистрация серверов и Настройка виртуальных каталогов сервера отчетов электронной документации по SQL Server.

Кроме просмотра ранее существовавшего содержимого сервера отчетов, также должна быть возможность создавать подписки и отложенные операции, а также пользоваться другими функциями, которые доступны в установленном выпуске. Дополнительные сведения о том, как создавать подписки и расписания, см. в разделе Разделы руководства по диспетчеру отчетов. Если обновление сервера отчетов завершилось неудачей или не завершилось до конца, можно вместо этого произвести миграцию установки. Дополнительные сведения см. в разделе Миграция служб Reporting Services.

Можно указать клиентские компоненты в командной строке для обновления среды SQL Server Management Studio и Business Intelligence Development Studio. Можно также проверить, правильно ли обновились эти средства, проверив наличие следующих возможностей:

  • Подключение к экземплярам служб Reporting Services в среде SQL Server Management Studio.

  • Создание дополнительных типов проектов в среде Business Intelligence Development Studio (в частности, шаблон проекта «Модель отчета» должен быть доступен в момент создания нового отчета в среде Business Intelligence Development Studio).

Если эти средства обновились неправильно, воспользуйтесь пунктом Установка и удаление программ для их удаления, а затем запустите программу установки SQL Server, чтобы установить их из устанавливаемого выпуска.

При миграции других баз данных SQL Server Express, поставляющих данные для отчетов на другой компонент Database Engine, после обновления необходимо обновить сведения о соединениях, используемых существующими отчетами. Например, если в источнике данных указано значение Data Source=localhost\sqlexpress, его нужно обновить на Data Source=localhost, если произведена миграция базы данных на локальный экземпляр по умолчанию.

См. также

Задачи

Как запустить настройку служб Reporting Services

Основные понятия

Конфигурация по умолчанию для установки сервера отчетов
Обновление служб Reporting Services
Управление ключами шифрования
Настройка соединения с базой данных сервера отчетов


Обновление или миграция служб DTS

Обновление или миграция служб DTS |
 | См. также
Обновление до SQL Server 2005 > Обновление компонентов SQL Server >

Примечание.
Рекомендуется ознакомиться с разделом Обновления версий и выпусков для получения общих сведений о сценариях обновления для продуктов и технологий .

Если вы являетесь текущим или предыдущим пользователем служб DTS, то вам доступны следующие варианты при установке служб .

  • Установка средств поддержки пакетов служб DTS SQL Server 2000

  • Обновление предыдущей версии служб DTS до служб SSIS

  • Миграция существующих пакетов служб DTS в SSIS

Важно!
Независимо от выбора параметра установки необходимо учитывать, что некоторые из функций служб SQL Server 2000 DTS изменены, устарели или больше не поддерживаются. Дополнительные сведения см. в разделе Обратная совместимость служб SQL Server 2005 Integration Services.

Известные проблемы при обновлении

Так как службы Integration Services являются полностью новым продуктом, а не обновлением версии, при обновлении до Integration Services не возникнет конфликтов программного обеспечения. Однако перед обновлением служб DTS до SQL Server 2005 Integration Services рекомендуется просмотреть раздел Обратная совместимость служб SQL Server 2005 Integration Services.

Контрольный список действий перед обновлением

Перед обновлением служб DTS до SQL Server 2005 Integration Services изучите следующие требования.

  • Требования к оборудованию и программному обеспечению для установки SQL Server 2005

  • Параметры для средства проверки конфигурации системы

  • Анализ безопасности при установке SQL Server

  • Использование помощника по обновлению для подготовки к обновлениям

Установка средств поддержки пакетов служб DTS SQL Server 2000

Можно запускать пакеты служб DTS SQL Server 2000 и пакеты служб Integration Services на одном компьютере.

Если для установки выбраны Службы Integration Services, программа установки также устанавливает поддержку пакетов служб DTS SQL Server 2000, включая среду выполнения DTS и перечислитель пакетов служб DTS в SQL Server Management Studio. Обновленная поддержка среды выполнения позволяет пакетам служб DTS получать доступ к источникам данных SQL Server 2005. Если не производится установка служб Integration Services, но необходима поддержка пакетов служб DTS, необходимо обеспечить, чтобы на странице Выбор компонентов были выбраны Компоненты прежних версий.

Примечание.
Хотя поддержка служб SQL Server 2000 DTS устанавливается автоматически при выборе служб Integration Services, некоторые настройки реестра и среды, необходимые для работы DTS, во время или после установки удаляются, если проводится обновление последнего экземпляра SQL Server 2000 на компьютере до SQL Server 2005. Для восстановления этих настроек выберите пункт «Обратная совместимость Microsoft SQL Server 2005» в списке Установка и удаление программ панели управления, нажмите кнопку Изменить и выберите параметр Исправить на странице мастера Обслуживание программы.

В число устанавливаемых файлов, служащих для обеспечения обратной совместимости, входят также задача «Обработка средствами SQL Server 2000 Analysis Services» и зависимый от нее модуль, объекты поддержки принятия решений (DSO). Однако файлы задачи «Прогнозирующий запрос интеллектуального анализа данных» SQL Server 2000 не устанавливаются.

Примечание.
При установке SQL Server 2005 конструктор пакетов служб DTS не устанавливается. Дополнительные сведения см. в разделе Обратная совместимость служб SQL Server 2005 Integration Services. Пакеты служб DTS не могут быть открыты или изменены в BI Development Studio.

Если выбрана установка Integration Services, также устанавливается мастер миграции пакетов. Мастер миграции пакетов можно использовать для обновления пакетов служб DTS SQL Server 2000 до формата Integration Services. Во время миграции мастер копирует пакеты служб DTS, после чего воссоздает их в формате Integration Services. Исходные пакеты при этом не изменяются. Дополнительные сведения см. в разделе Миграция пакетов служб DTS.

Примечание.
Мастер миграции пакетов доступен в следующих выпусках SQL Server 2005: Standard Edition, Enterprise Edition и Developer Edition.

Дополнительные сведения см. в разделе Как обеспечить поддержку пакетов служб DTS.

Обновление предыдущей версии служб DTS до служб Integration Services

Процесс обновления служб DTS SQL Server 2000 до SQL Server 2005 Integration Services состоит из установки SQL Server 2005 Integration Services и (при необходимости) миграции существующих пакетов служб DTS в пакеты формата SQL Server 2005 Integration Services. В этом процессе помимо собственно программы установки используются программные инструменты.

Чтобы обновить экземпляр служб DTS SQL Server 2000 до SQL Server 2005 Integration Services, выполните следующие шаги.

  1. Установите SQL Server 2005 Integration Services, используя мастер установки или альтернативный способ установки. Дополнительные сведения см. в разделах Установка служб SQL Server Integration Services с помощью программы установки и Установка служб SQL Server Integration Services из командной строки.

  2. При необходимости используйте мастер миграции пакетов для переноса пакетов служб DTS SQL Server 2000 на SQL Server 2005 Integration Services. На этом шаге пакеты создаются заново в новом формате пакетов, в то время как первоначальные пакеты остаются неизмененными. Если выбрана установка Integration Services, также устанавливается мастер миграции пакетов. Дополнительные сведения см. в разделе Миграция пакетов служб DTS.

Дополнительные сведения см. в разделах Как обновить службы DTS до служб Integration Services и Обратная совместимость служб SQL Server 2005 Integration Services.

Миграция существующих пакетов служб DTS в службы Integration Services

При необходимости можно использовать мастер миграции пакетов для обновления пакетов служб DTS SQL Server 2000 до формата SQL Server 2005 Integration Services. В ходе процесса миграции мастер копирует пакеты служб DTS SQL Server 2000 и заново создает их в формате SQL Server 2005 Integration Services. Исходные пакеты при этом не изменяются.

Если выбрана установка Integration Services, также устанавливается мастер миграции пакетов.

Примечание.
Мастер миграции пакетов доступен в следующих выпусках SQL Server 2005: Standard Edition, Enterprise Edition и Developer Edition.

Дополнительные сведения см. в разделах Миграция пакетов служб DTS, Как осуществить миграцию пакетов служб DTS до служб Integration Services и Некоторые вопросы миграции пакетов.

См. также

Основные понятия

Обновление командных строк dtsrun


Миграция пакетов служб DTS

Миграция пакетов служб DTS |
 | См. также
Обновление до SQL Server 2005 > Обновление компонентов SQL Server > Обновление или миграция служб DTS >

Дата обновления: 17 июля 2006 г.

Службы SQL Server 2005 Integration Services (SSIS) поддерживают несколько вариантов сохранения решений, созданных с помощью программ и объектной модели служб DTS SQL Server 2000. Можно осуществить миграцию пакетов служб DTS в формат служб SQL Server 2005, продолжить запуск пакетов DTS с помощью среды выполнения служб DTS из SQL Server 2000 или же включить пакеты DTS в решения SQL Server 2005 Integration Services с помощью задачи «Выполнение пакета служб DTS 2000».

При миграции пакетов DTS из SQL Server 2000 в формат SQL Server 2005 Integration Services структура подвергнутого миграции пакета и полнота миграции зависят от содержимого исходного пакета.

Примечание.
Мастер миграции пакетов оставляет исходные пакеты служб DTS без изменений.

Результаты миграции пакетов могут быть следующими:

  • Возможна успешная и полная миграция пакетов, так как они содержат только задачи и функции, соответствующие задачам и функциям SQL Server 2005 Integration Services (SSIS).

  • Пакеты содержат задания и функции служб DTS из SQL Server 2000, прямая миграция которых в задачи и функции SQL Server 2005 Integration Services (SSIS) невозможна, однако функциональность пакета сохраняется путем использования инкапсулированных пакетов SQL Server 2000.

Примечание.
В некоторых случаях, например если имя пакета содержит недопустимые символы (/ \ : [ ] . =) или если в пакете содержатся незарегистрированные объекты, мастер миграции пакетов не может выполнить миграцию до тех пор, пока эти проблемы не будут устранены.

Если всем задачам пакета соответствуют новые задачи в SQL Server 2005, структура пакета после миграции будет очень похожа на структуру исходного пакета SQL Server 2000. Напротив, если не для всех задач есть прямые эквиваленты в SQL Server 2005, структура пакета при миграции изменяется. Каждая задача, не прошедшая миграцию, остается в формате SQL Server 2000 и инкапсулируется в задачу «Выполнение пакета служб DTS 2000». Таким же образом производится миграция и пользовательских задач пакета. Дополнительные сведения см. в разделе Миграция задач.

Другим элементам пакетов, например ограничениям очередности, соединениям и переменным, после миграции соответствуют эквивалентные элементы SQL Server 2005. Дополнительные сведения см. в разделах Миграция ограничений очередностью, Миграция соединений и Миграция переменных.

Миграция паролей для пакетов, прошедших миграцию в пакеты SQL Server 2005 Integration Services (SSIS), не производится. Однако SQL Server 2005 поддерживает защиту паролем пакетов SQL Server 2000 и задачи «Выполнение пакета служб DTS 2000». Задача «Выполнение пакета служб DTS 2000» в пакете SQL Server 2005 может передать пароль пакету SQL Server 2000. Дополнительные сведения см. в разделе Миграция паролей.

Задача «Сценарий ActiveX» в SQL Server 2005 часто способна выполнять код сценария, прошедший миграцию из сценариев ActiveX в пакетах служб DTS SQL Server 2000, без дополнительных изменений. Однако ссылки на объекты пакетов служб DTS из SQL Server 2000 не поддерживаются. Дополнительные сведения см. в разделе Миграция сценариев.

Миграция текстовых заметок, введенных в конструкторе служб DTS, параметров ведения журналов пакетов и обработки ошибок не производится.

После миграции пакетов их следует открыть для проверки на возможные ошибки, включая сбои проверки правильности. Например, некоторые пакеты ссылаются на предшествующие задачи в пределах одного пакета при создании или подготовке источников или назначений данных и могут не пройти проверку правильности, если эти объекты невозможно найти. Сбой проверки правильности такого рода может быть разрешен установкой свойства DelayValidation в значение true для задачи или другого объекта контейнера либо установкой свойства ValidateExternalMetadata в значение false для затрагиваемого компонента потока данных.

Примечание.
После миграции пакетов с помощью среды Management Studio в обозревателе объектов подключитесь к локальному экземпляру служб Integration Services, чтобы просмотреть подвергнутые миграции пакеты. Если в качестве назначения был выбран SQL Server, подвергнутые миграции пакеты будут доступны для просмотра в узле MSDB. Если в качестве цели выбрана папка файловой системы, щелкните правой кнопкой мыши узел Файловая система и выберите Импорт пакета, чтобы отобразить все подвергнутые миграции пакеты. После миграции пакеты из среды BI Development Studio сохраняются в указанную папку файловой системы и добавляются к открытому проекту в узле Пакеты служб SSIS.

Пакеты служб DTS нельзя открывать или изменять в среде BI Development Studio.

В этом разделе

Раздел | Описание
Использование мастера миграции пакетов | Описывает процесс миграции с помощью мастера миграции пакетов.
Некоторые вопросы миграции пакетов | Перечисляет известные проблемы миграции пакетов, которые могут быть определены мастером миграции пакетов либо помощником по обновлению.
Миграция задач | Описывает, как мастер миграции пакетов осуществляет миграцию задач, а также объясняет шаги, которые можно предпринять после миграции для восстановления задач или улучшения их поведения.
Миграция ограничений очередностью | Описывает, как мастер миграции пакетов осуществляет миграцию ограничений очередности, а также объясняет шаги, которые можно предпринять после миграции для улучшения поведения этих элементов.
Миграция переменных | Описывает, как мастер миграции пакетов осуществляет миграцию переменных, а также объясняет шаги, которые можно предпринять после миграции для восстановления переменных или улучшения их поведения.
Миграция соединений | Описывает, как мастер миграции пакетов осуществляет миграцию соединений, а также объясняет шаги, которые можно предпринять после миграции для изменения свойств соединений.
Миграция паролей | Описывает, как мастер миграции пакетов осуществляет миграцию паролей, а также объясняет другие шаги, которые можно предпринять после миграции для улучшения безопасности.
Миграция сценариев | Описывает, как мастер миграции пакетов осуществляет миграцию сценариев ActiveX.
Журнал изменений

Версия Журнал

17 июля 2006 г.

Измененное содержимое:
  • Добавлено примечание о местоположении пакетов, подвергнутых миграции.

См. также

Основные понятия

Обратная совместимость служб SQL Server 2005 Integration Services

Другие ресурсы

SQL Server Integration Services (службы SSIS)


Использование мастера миграции пакетов

Использование мастера миграции пакетов |
 | См. также
Обновление компонентов SQL Server > Обновление или миграция служб DTS > Миграция пакетов служб DTS >

Дата обновления: 17 июля 2006 г.

SQL Server 2005 Integration Services (SSIS) предоставляет мастер миграции пакетов, используемый для миграции пакетов служб DTS, созданных с помощью средств SQL Server 2000.

Примечание.
Мастер миграции пакетов доступен в следующих выпусках SQL Server 2005: Standard, Enterprise, Developer Edition.

Примечание.
Помощник по обновлению не сможет проанализировать, а мастер миграции пакетов не сможет выполнить миграцию пакетов служб DTS, хранящихся в базе данных msdb экземпляра SQL Server 7.0. Однако они работают с пакетами служб DTS SQL Server 7.0, которые сохранены в виде файлов структурированных хранилищ или сохранены в базе данных msdb экземпляра SQL Server 7.0, который был обновлен до SQL Server 2005.

Не все пакеты подлежат полной миграции. Например, некоторые задачи SQL Server 2000 не имеют соответствующих задач в Integration Services, миграция пользовательских задач невозможна, а некоторые сценарии в задачах сценариев ActiveX или в преобразованиях данных также не подлежат миграции. Дополнительные сведения см. в разделах Миграция задач и Некоторые вопросы миграции пакетов.

Пакеты, оставленные в формате пакетов SQL Server 2000, могут использоваться в решениях Integration Services, а их выполнение может быть также продолжено в качестве отдельных пакетов SQL Server 2000.

Многие пакеты SQL Server 2000 защищаются паролем. В случае миграции таких пакетов мастер миграции пакетов запросит их пароли. Защищенный паролем пакет не подлежит миграции до тех пор, пока не будет указан правильный пароль.

SQL Server 2005 не устанавливает поддержку для служб метаданных. Мастер миграции пакетов поддерживает пакеты службы метаданных (репозитория) только в случае, если на локальном компьютере установлены SQL Server 2000, средства SQL Server 2000 или файлы хранилища, предназначенные для распространения. При наличии файлов репозитория мастер миграции пакетов способен осуществлять миграцию пакетов DTS, сохраненных в службах метаданных. При отсутствии файлов хранилища мастер миграции пакетов может осуществлять миграцию только пакетов DTS, сохраненных на SQL Server или в структурированных файлах хранилища.

Запуск мастера миграции пакетов

Мастер миграции пакетов можно запустить из трех различных мест.

  • Из среды SQL Server Management Studio. Подключитесь к экземпляру SQL Server 2005 Database Engine, щелкните правой кнопкой мыши узел Службы DTS в обозревателе объектов под Management\Legacy, а затем выберите Мастер миграции.

  • Из среды Business Intelligence Development Studio. Создайте или откройте проект служб Integration Services, щелкните правой кнопкой мыши узел Пакеты служб SQL Server Integration Services в обозревателе решений, а затем выберите Миграция пакетов служб DTS 2000.

  • Из командной строки. Запустите DTSMigrationWizard.exe из папки C:\Program Files\Microsoft SQL Server\90\DTS\Binn.

Выбор источника пакетов

Мастер миграции пакетов может осуществлять миграцию пакетов SQL Server 2000, сохраненных в базе данных SQL Server msdb, в структурированных файлах хранилища, а также в службах метаданных. Миграция пакетов, сохраненных в файлы Visual Basic, невозможна.

Важно!
SQL Server 2005 не устанавливает поддержку для служб метаданных. Мастер миграции пакетов может получить доступ к пакетам DTS, сохраненным в службах метаданных, только если на компьютере присутствуют SQL Server 2000, средства SQL Server 2000 или файлы репозитория, предназначенные для распространения.

Если пакет размещен в базе данных msdb или в службах метаданных, пользователь должен указать имя сервера, а мастер миграции пакетов проверит подлинность пользователя с помощью проверки подлинности Windows или SQL Server.

Если пакет размещен в структурированном файле хранилища, следует выбрать этот файл для миграции. Структурированный файл хранилища может содержать определения для множества пакетов и включать несколько версий одного пакета. Можно осуществить миграцию отдельных пакетов и их версий из файла.

Дополнительные сведения см. в разделе Выбор местоположения источника (мастер миграции пакетов).

Выбор назначения пакетов

Мастер миграции пакетов может осуществлять миграцию пакетов либо в базу данных msdb в экземпляре SQL Server 2005, либо в файл с расширением dtsx. Файл с расширением dtsx является представлением определения пакета, сохраненного в файловой системе, в формате XML.

Если назначение — SQL Server 2005, пользователь должен указать имя сервера, а мастер миграции пакетов проверит подлинность пользователя с помощью проверки подлинности Windows или SQL Server.

Дополнительные сведения см. в разделе Выбор места назначения (мастер миграции пакетов).

Примечание.
После миграции пакетов с помощью среды Management Studio в обозревателе объектов подключитесь к локальному экземпляру служб Integration Services, чтобы проверить, произведена ли миграция пакетов. Если в качестве цели был выбран SQL Server, подвергнутые миграции пакеты будут доступны для просмотра в узле MSDB. Если в качестве цели выбрана папка файловой системы, щелкните правой кнопкой узел Файловая система и выберите Импорт пакета, чтобы отобразить все подвергнутые миграции пакеты. После миграции пакетов из среды BI Development Studio они сохраняются в указанную папку файловой системы и добавляются к открытому проекту в узле Пакеты служб SQL Server Integration Services.

Пакеты служб DTS нельзя открывать или изменять в среде BI Development Studio.

Выбор пакетов для миграции

После указания источника и назначения мастер миграции пакетов перечислит доступные пакеты в базе данных msdb, в службах метаданных или же в определенном структурированном файле хранилища. Можно выбрать пакеты для миграции и обновить имена, установленные для них мастером миграции пакетов по умолчанию. Имена пакетов можно также обновить в средах Business Intelligence Development Studio или SQL Server Management Studio уже после выполнения миграции пакетов.

Дополнительные сведения см. в разделе Список пакетов (мастер миграции пакета).

Указание паролей для пакетов

Пакеты, разработанные с помощью более ранних версий средств SQL Server, могут быть защищены паролем. Прежде чем мастер сможет получить доступ к определениям пакетов и осуществить их миграцию, следует указать правильный пароль для каждого пакета. Если для нескольких пакетов установлен общий пароль, этот пароль нужно указать только один раз. Мастер миграции пакетов не сможет продолжить работу до тех пор, пока для всех защищенных паролем пакетов не будут указаны пароли. Если ни один пакет не защищен паролем, мастер пропустит этот этап.

Регистрация ошибок миграции

Мастер миграции пакетов можно настроить на регистрацию ошибок, возникающих в процессе миграции.

Дополнительные сведения см. в разделе Указание файла журнала (мастер миграции пакетов).

Просмотр хода выполнения миграции

Мастер миграции пакетов осуществляет миграцию выбранных пакетов по одному. Если мастер не может осуществить миграцию пакета, он предоставляет выбор — закончить процесс миграции для всех оставшихся пакетов или же продолжить миграцию со следующего пакета из списка. По мере миграции каждого пакета его состояние миграции обновляется.

Дополнительные сведения см. в разделах Завершение работы мастера (мастер миграции пакетов) и Миграция пакетов (мастер миграции пакетов).

Проверка пакетов после миграции

После миграции пакетов их следует открыть в среде Business Intelligence Development Studio для проверки на возможные ошибки, включая сбои проверки правильности. Например, некоторые пакеты ссылаются на предшествующие задачи в пределах одного пакета при создании или подготовке источников или назначений данных и могут не пройти проверку правильности, если эти объекты невозможно найти. Сбой проверки правильности такого рода может быть разрешен установкой свойства DelayValidation в значение true для задачи или другого объекта контейнера либо установкой свойства ValidateExternalMetadata в значение false для затрагиваемого компонента потока данных.

Примечание.
После миграции пакетов с помощью среды Management Studio в обозревателе объектов подключитесь к локальному экземпляру служб Integration Services, чтобы проверить, произведена ли миграция пакетов. Если в качестве цели был выбран SQL Server, подвергнутые миграции пакеты будут доступны для просмотра в узле MSDB. Если в качестве цели выбрана папка файловой системы, щелкните правой кнопкой узел Файловая система и выберите Импорт пакета, чтобы отобразить все подвергнутые миграции пакеты. После миграции пакеты из среды BI Development Studio сохраняются в указанную папку файловой системы и добавляются к открытому проекту в узле Пакеты служб SQL Server Integration Services.

См. также

Другие ресурсы

Миграция пакетов служб DTS

Журнал изменений

Версия Журнал

17 июля 2006 г.

Измененное содержимое
  • Добавлено примечание о том, что пакеты служб DTS нельзя открывать в BI Development Studio.

5 декабря 2005 г.

Измененное содержимое
  • Добавлено примечание о местонахождении подвергнутых миграции пакетов.

  • Добавлены сведения о поддержке миграции из сервера SQL Server 7.0.


Некоторые вопросы миграции пакетов

Некоторые вопросы миграции пакетов |
 | См. также
Обновление компонентов SQL Server > Обновление или миграция служб DTS > Миграция пакетов служб DTS >

Дата обновления: 17 июля 2006 г.

Сводка проблем, которые могут возникнуть при миграции пакета служб DTS в формат SQL Server 2005 Integration Services (SSIS) при использовании мастера миграции пакетов.

Мастер миграции пакетов выполняет миграцию определенных функций SQL Server 2000 DTS, не имеющих прямого эквивалента в службах SQL Server 2005 Integration Services (SSIS), инкапсулируя их в задачу «Выполнение пакета служб DTS 2000». Хотя во многих случаях эти подвергнутые миграции пакеты работают без ошибок, в конечном счете, придется заменить устаревшие функциональные возможности прошлых выпусков, инкапсулированные в задаче «Выполнение пакета служб DTS 2000».

После выполнения миграции пакетов их следует открыть и проверить, не появились ли какие-либо проблемы, в том числе сбои проверок данных.Например, некоторые пакеты ссылаются на предшествующие задачи в пределах одного пакета при создании или подготовке источников или назначений данных и могут не пройти проверку правильности, если эти объекты невозможно найти.Сбой проверки правильности такого рода может быть разрешен установкой свойства DelayValidation в значение true для задачи или другого объекта контейнера, либо установкой свойства ValidateExternalMetadata в значение false для затрагиваемого компонента потока данных.

Известные проблемы, обнаруживаемые помощником по обновлению

В следующем списке представлены некоторые проблемы миграции и краткое объяснение каждой проблемы, появляющейся в отчете, созданном помощником по обновлению SQL Server 2005. Мастер миграции пакетов и помощник по обновлению распознают и вносят в отчет одни и те же потенциальные проблемы миграции.

Название проблемы Описание проблемы

Повторная настройка параметров транзакций после миграции пакетов

Мастер миграции пакетов SQL Server 2005 Integration Services (SSIS) не выполняет миграцию параметров транзакций в пакетах служб DTS SQL Server 2000.После миграции необходимо вручную отредактировать полученный в результате пакет служб SSIS, чтобы восстановить его исходное поведение.

Корректирующее действие:после миграции создайте заново нужные параметры транзакций пакета, присвоив соответствующие значения свойствам, относящимся к транзакциям, в пакете и его компонентам в среде Business Intelligence Development Studio. Дополнительные сведения см. в разделе Встраивание транзакций в пакеты.

Замена после миграции пакетов функциональных возможностей сценария ActiveX, связанного с шагами пакета

Мастер миграции пакетов SQL Server 2005 Integration Services (SSIS) не выполняет миграцию сценариев ActiveX, связанных с шагами в пакетах служб DTS SQL Server 2000.После миграции необходимо вручную отредактировать полученный в результате пакет служб SSIS, чтобы восстановить его исходное поведение.

Корректирующее действие:после миграции замените отсутствующий сценарий новой задачей сценария или другими подходящими объектами служб Integration Services. Дополнительные сведения см. в разделе Задача «Сценарий».

Замена после миграции пакетов функциональных возможностей задачи служб Analysis Services, инкапсулированной в задачу «Выполнение пакета служб DTS 2000»

Мастер миграции пакетов SQL Server 2005 Integration Services (SSIS) не выполняет миграцию задачи Analysis Services в пакеты служб DTS SQL Server 2000.Подвергнутый миграции пакет будет содержать функциональные возможности служб DTS в инкапсулированном виде, которые со временем необходимо заменить.

Корректирующее действие:после миграции преобразуйте задачу «Выполнение пакета служб DTS 2000», в которой инкапсулирована задача Analysis Services в задачу обработки служб Integration Services Analysis Services. Дополнительные сведения см. в разделе Задача «Обработка средствами Analysis Services».

Замена после миграции пакета функциональных возможностей комплексной задачи преобразования данных, инкапсулированной в задачу «Выполнение пакета служб DTS 2000»

Мастер миграции пакетов SQL Server 2005 Integration Services (SSIS) не выполняет миграцию комплексных задач преобразования данных в пакеты служб DTS SQL Server 2000.Подвергнутый миграции пакет будет содержать функциональные возможности служб DTS в инкапсулированном виде, которые со временем необходимо заменить.

Корректирующее действие:после миграции перепишите комплексную задачу преобразования данных, используя источники потока данных, преобразования и назначения Integration Services. Дополнительные сведения см. в разделах Создание потока данных пакета и Элементы потока данных.

Замена после миграции пакетов функциональных возможностей пользовательской задачи, инкапсулированной в задачу «Выполнение пакета служб DTS 2000»

Мастер миграции пакетов SQL Server 2005 Integration Services (SSIS) не выполняет миграцию пользовательских задач в пакеты служб DTS SQL Server 2000.Подвергнутый миграции пакет будет содержать функциональные возможности служб DTS в инкапсулированном виде, которые со временем необходимо заменить.

Корректирующее действие: После миграции создайте заново логику пользовательской задачи, используя задачу сценария или компонент сценария, либо пользовательский компонент, если нужная функциональная возможность недоступна во встроенном компоненте служб Integration Services или в их сочетании. Сведения о программировании решений см. в разделе Integration Services Programming.

Заменить функциональные возможности задачи «Управляемый данными запрос», инкапсулированной в задачу «Выполнение пакета служб DTS 2000», после миграции пакетов

Мастер миграции пакетов SQL Server 2005 Integration Services (SSIS) не выполняет миграцию задач запросов, управляемых данными, в пакеты служб DTS SQL Server 2000.Подвергнутый миграции пакет будет содержать функциональные возможности служб DTS в инкапсулированном виде, которые со временем необходимо заменить.

Корректирующее действие:после миграции создайте заново функциональные возможности задачи «Управляемый данными запрос», используя компоненты потока данных Integration Services. Если необходимо заменить задачу «Управляемый данными запрос», обращайтесь к следующим функциям: Преобразование «Медленно изменяющиеся измерения», Преобразование «Условное разбиение» и Преобразование «Команда OLE DB».

Заменить после миграции пакетов функциональные возможности задачи «Запрос прогноза интеллектуального анализа данных», инкапсулированной в задачу «Выполнение пакета служб DTS 2000»

Мастер миграции пакетов SQL Server 2005 Integration Services (SSIS) не выполняет миграцию задачи «Запрос прогноза интеллектуального анализа данных» в пакеты служб DTS SQL Server 2000.Подвергнутый миграции пакет будет содержать функциональные возможности служб DTS в инкапсулированном виде, которые со временем необходимо заменить. SQL Server 2005 не устанавливает поддержку для задачи «Запрос прогноза интеллектуального анализа данных» SQL Server 2000, поэтому подвергнутый миграции пакет не запустится после обновления при отсутствии служб SQL Server 2000 Analysis Services.

Корректирующее действие:после миграции преобразуйте задачу «Выполнение пакета служб DTS 2000», которая инкапсулирует задачу «Прогноз интеллектуального анализа данных», в задачу Integration Services «Запрос интеллектуального анализа» или преобразование «Запрос интеллектуального анализа данных». Дополнительные сведения см. в разделах Задача «Запрос интеллектуального анализа данных» и Преобразование «Запрос интеллектуального анализа данных».

Замена после миграции пакета функциональных возможностей задачи «Динамические свойства»

Мастер миграции пакетов SQL Server 2005 Integration Services (SSIS) не выполняет миграцию задач «Динамические свойства» в пакеты служб DTS SQL Server 2000.После миграции необходимо вручную отредактировать полученный в результате пакет служб SSIS, чтобы восстановить его исходное поведение.

Корректирующее действие:после миграции заново создайте функциональные возможности задачи «Динамические свойства», используя такие возможности служб Integration Services как переменные, выражения для свойств и конфигурации пакетов. Дополнительные сведения см. в разделах Переменные служб Integration Services и Использование переменных в пакетах; Использование выражений свойств в пакетах и Конфигурации пакета.

Замена после миграции пакетов функциональных возможностей задачи «Выполнение пакета» (с пакетом служб метаданных), инкапсулированных в задачу «Выполнение пакета служб DTS 2000»

Мастер миграции пакетов SQL Server 2005 Integration Services (SSIS) не выполняет миграцию задач «Выполнение пакета», которые загружают пакеты служб метаданных.Подвергнутый миграции пакет будет содержать функциональные возможности служб DTS в инкапсулированном виде, которые со временем необходимо заменить. SQL Server 2005 не устанавливает поддержку для служб метаданных SQL Server 2000, поэтому подвергнутый миграции пакет не запустится после обновления при отсутствии клиентских инструментов SQL Server 2000.

Корректирующее действие:после миграции переместите пакет служб метаданных в хранилище SQL Server (в базу данных msdb) или в структурированный файл хранилища и преобразуйте задачу «Выполнение пакета служб DTS 2000», которая инкапсулирует задачу «Выполнение пакета», загружающую пакет служб метаданных в задачу «Выполнение пакета служб DTS 2000», которая загружает этот пакет из SQL Server или структурированного файла хранилища. Дополнительные сведения см. в разделе Сохранение пакетов.

Заменить после миграции пакетов функциональные возможности задачи «Параллельное заполнение данными», инкапсулированной в задачу «Выполнение пакета служб DTS 2000»

Мастер миграции пакетов SQL Server 2005 Integration Services (SSIS) не выполняет миграцию задач «Параллельное заполнение данными» в пакеты служб DTS SQL Server 2000.Подвергнутый миграции пакет будет содержать функциональные возможности служб DTS в инкапсулированном виде, которые со временем необходимо заменить.

Корректирующее действие:после миграции создайте заново функциональные возможности задачи «Параллельное заполнение данными», используя компоненты потока данных служб Integration Services. Дополнительные сведения см. в разделах Создание потока данных пакета и Элементы потока данных.

Заменить после миграции пакетов функциональную возможность UDL-соединения, инкапсулированную в задачу «Выполнение пакета служб DTS 2000»

Мастер миграции пакетов SQL Server 2005 Integration Services (SSIS) не выполняет миграцию задач, получающих данные о соединении из файлов Microsoft Data Link (UDL_файлов).Подвергнутый миграции пакет будет содержать функциональные возможности служб DTS в инкапсулированном виде, которые со временем необходимо заменить.

Корректирующее действие:после миграции преобразуйте задачу «Выполнение пакета служб DTS 2000», которая инкапсулирует соединение с помощью UDL-файла, в эквивалентную задачу Integration Services, использующую диспетчер соединений Integration Services. Дополнительные сведения см. в разделах Диспетчеры соединений и Создание диспетчеров соединений.

Повторное создание сценария ActiveX, получающего доступ к модели объектов DTS, после миграции пакетов

Мастер миграции пакетов служб SQL Server 2005 Integration Services (SSIS) не выполняет миграцию программного кода сценария ActiveX, который получает доступ к модели объектов DTS через свойство Parent коллекции GlobalVariables в пакетах служб SQL Server 2000 DTS. После миграции необходимо вручную отредактировать полученный в результате пакет служб SSIS, чтобы восстановить его исходное поведение.

Корректирующее действие: После миграции измените программный код сценария или перепишите задачу сценария ActiveX, чтобы получить нужные данные из пакета другим способом: например, используя переменные. Дополнительные сведения см. в разделах Переменные служб Integration Services и Использование переменных в пакетах.

Известные проблемы, не обнаруживаемые помощником по обновлению

Следующие проблемы не обнаруживаются, и о них не сообщается мастером миграции пакетов или помощником по обновлению.

Название проблемы | Описание проблемы
Удаление и воссоздание соединений ODBC после миграции пакетов | Подключения ODBC выдают ошибку при попытке изменения соединения после миграции. Корректирующее действие: если миграция пакета уже выполнена, можно удалить и воссоздать соединение ODBC. Эта проблема была устранена в SQL Server 2005 с пакетом обновлений 1 (SP1). Установите пакет обновления 1 (SP1) или более позднюю версию, чтобы предотвратить повторное возникновение этой проблемы.

Журнал изменений

Версия Журнал

17 июля 2006 г.

Измененное содержимое
  • Добавлено описание проблемы, связанной с соединениями ODBC.

  • Добавлены ссылки на ресурсы с дополнительными сведениями по каждой проблеме.

См. также

Основные понятия

Обратная совместимость служб SQL Server 2005 Integration Services


Миграция задач

Миграция задач |
 | См. также
Обновление компонентов SQL Server > Обновление или миграция служб DTS > Миграция пакетов служб DTS >

Многие задачи служб DTS SQL Server 2000 прямо соответствуют задачам служб SQL Server 2005 Integration Services (SSIS), поэтому при миграции пакета на службы SQL Server 2005 Integration Services (SSIS) производится замещение задачи версии SQL Server 2000 соответствующей задачей служб SQL Server 2005 Integration Services (SSIS).

В следующей таблице перечислены соответствия версий задач.

Задача SQL Server 2000 | Задача SQL Server 2005
Задача сценария ActiveX | Задача «Сценарий ActiveX»
Задача «Массовая вставка» | Задача «Массовая вставка»
Задача «Копирование объектов SQL Server» | Задача «Передача объектов SQL Server»
Задача «Прогноз интеллектуального анализа данных» | Задача «Запрос интеллектуального анализа данных»
Задача «Выполнение пакета» | Задача «Выполнение пакета служб DTS 2000»
Задача «Выполнение процесса» | Задача «Выполнение процесса»
Задача «Выполнение SQL» | Задача «Выполнение SQL»
Задача «Протокол передачи файлов» | Задача «FTP»
Задача «Очередь сообщений» | Задача «Очередь сообщений»
Задача «Отправка почты» | Задача «Отправка почты»
Задачи «Передача базы данных», «Передача сообщений об ошибках», «Передача заданий», «Передача имен входа» и «Передача главных хранимых процедур» | Задача «Передача объектов SQL Server», Задача «Передача базы данных», Задача «Передача сообщений об ошибках», Задача «Передача заданий», Задача «Передача имен входа» и Задача «Передача главных хранимых процедур»
Примечание.
Задачи «Сценарий ActiveX», которые пытаются получить доступ к объектной модели пакета с помощью свойства Parent коллекции GlobalVariables, перестанут работать после миграции пакета.

Некоторые задачи SQL Server 2000 не имеют соответствий среди задач служб SQL Server 2005 Integration Services (SSIS):

  • Задача «Службы Analysis Services» (поскольку задача «Службы SQL Server 2005 Integration Services (SSIS) Analysis Services» не работает с экземплярами служб SQL Server 2000 Analysis Services)

  • Задача «Управляемый данными запрос»

  • Задача «Динамические свойства»

  • Задача «Преобразование данных»

В SQL Server 2005 некоторые из этих задач заменены возможностями, которые не являются задачами. В следующей таблице перечислены задачи SQL Server 2000 и сопоставленные им внезадачные возможности SQL Server 2005.

Задача SQL Server 2000 | Возможность SQL Server 2005
Динамические свойства | Конфигурации и выражения свойств. Дополнительные сведения см. в разделе Создание конфигураций пакетов.
Преобразование данных | Задача «Поток данных» и Элементы потока данных.
Управляемый данными запрос | Если необходимо заменить задачу «Управляемый данными запрос», обращайтесь к следующим функциям: Преобразование «Медленно изменяющиеся измерения», Преобразование «Условное разбиение» и Преобразование «Команда OLE DB».

Пользовательские задачи

Миграция на SQL Server 2005 пакета, содержащего пользовательские задачи, выполняется особым образом. Для каждой пользовательской задачи создается пакет SQL Server 2000, а к пакету после миграции добавляется задача «Выполнение пакета DTS 2000», которая вызывает этот пакет SQL Server 2000. Эти новые пакеты SQL Server 2000, называемые промежуточными, встраиваются в пакет после миграции и не сохраняются отдельно. Например, пакет SQL Server 2000, содержащий три пользовательские задачи, становится пакетом SQL Server 2005, в котором содержатся три задачи «Выполнить пакет DTS 2000», и каждая из них указывает на встроенный пакет SQL Server 2000, в котором инкапсулирована пользовательская задача.

Задачи на основе модуля заполнения данными

Имеются три задачи SQL Server 2000 — «Управляемый данными запрос», «Преобразование данных» и «Параллельная накачка данных», — работа которых основана на модуле заполнения данными DTS SQL Server 2000. За исключением самых простых задач преобразований данных, миграция этих задач происходит так же, как и пользовательских. Мастер миграции пакетов создает для каждой задачи новый пакет SQL Server 2000, а затем добавляет в новый пакет задачу «Выполнить пакет DTS 2000» для каждой из задач модуля заполнения данными.

Задача «Динамические свойства»

Задачи «Динамические свойства» не могут мигрировать на SQL Server 2005. При попытке выполнить миграцию такой задачи мастер миграции пакетов выдает предупреждение. Если все же выполнить миграцию, то задача «Динамические свойства» заменяется в прошедшем миграцию пакете задачей-заполнителем. Эта задача представляет собой задачу сценария, в которой перечислены пары «свойство-значение», взятые из задачи «Динамические свойства», которые можно преобразовать в сценарий задачи сценария. Эти данные сохраняются в задаче сценария в виде комментариев в сценарий.

В SQL Server 2005 конфигурации заменяют и расширяют возможности, доступные в задаче «Динамические свойства». Дополнительные сведения см. в разделе Создание конфигураций пакетов.

См. также

Другие ресурсы

Миграция пакетов служб DTS


Миграция ограничений очередностью

Миграция ограничений очередностью |
 | См. также
Обновление компонентов SQL Server > Обновление или миграция служб DTS > Миграция пакетов служб DTS >

Ограничение очередностью в пакете служб DTS SQL Server 2000 мигрирует в коллекцию PrecedenceConstraints нового пакета.

Расширение функциональности ограничения очередностью

После миграции пакета ограничение очередностью может быть расширено следующими способами.

  • Используйте выражение с или вместо результата выполнения предыдущего исполняемого объекта, чтобы указать условия, при которых выполняется задача с ограничением. Дополнительные сведения см. в разделе Добавление выражений к ограничению очередностью.

  • Объедините несколько ограничений очередностью, чтобы указать условия, при которых выполняется задача с ограничением. Дополнительные сведения см. в разделе Применение нескольких ограничений очередностью.

См. также

Другие ресурсы

Миграция пакетов служб DTS
Ограничения очередностью


Миграция переменных

Миграция переменных |
 | См. также
Обновление компонентов SQL Server > Обновление или миграция служб DTS > Миграция пакетов служб DTS >

В службах SQL Server 2005 Integration Services (SSIS) коллекция переменных доступна во всех контейнерах: пакетах, циклах, таких как контейнер «Цикл по каждому элементу», а также в контейнере TaskHost, который содержит в себе каждую задачу. При миграции пакета все глобальные переменные и переменные из задач DTS SQL Server 2000 перемещаются в коллекцию переменных пакета. Например, переменные, используемые задачей SQL Server 2000 «Выполнение SQL», добавляются в коллекцию переменных мигрирующего пакета.

Службы SQL Server 2005 Integration Services (SSIS) используют пространство имен для организации переменных. Все переменные DTS перемещаются в пространство имен User.

Расширение функциональных возможностей переменных

После миграции пакета переменным можно добавить функциональные возможности следующими способами:

  • Создать дополнительные пространства имен и организовать переменные по этим пространствам.

  • Использовать выражения для установки значений переменных.

  • Указать, инициирует ли событие обновление значения переменной.

Дополнительные сведения о переменных см. в разделах Переменные служб Integration Services и Использование переменных в пакетах.

См. также

Другие ресурсы

Миграция пакетов служб DTS


Миграция соединений

Миграция соединений |
 | См. также
Обновление компонентов SQL Server > Обновление или миграция служб DTS > Миграция пакетов служб DTS >

Соединения в пакетах служб DTS из SQL Server 2000 мигрируют в SQL Server 2005 и преобразуются в диспетчеры соединений соответствующего типа.

Диспетчер соединений является логическим представлением соединения с источником данных. Диспетчер соединений задает атрибуты физического соединения, создаваемого ядром во время выполнения при запуске пакета. Подвергнутый миграции пакет может поддерживать несколько диспетчеров соединений, которые принадлежат к одному типу соединения, однако настроены по-разному. Дополнительные сведения см. в разделе Диспетчеры соединений.

Единственная использующая соединение задача SQL Server 2000, миграция которой в SQL Server 2005 возможна без проблем, — это задача «Выполнение SQL». Результатом миграции ее соединений являются диспетчеры соединений OLE DB или ODBC. Значения всех свойств существующих диспетчеров соединений, не заданные до этого момента, в новом диспетчере соединений устанавливаются по умолчанию. Дополнительные сведения см. в разделах Диспетчер соединений OLE DB и Диспетчер соединений ODBC.

Примечание.
При определенных обстоятельствах возможна успешная миграция задачи преобразования данных из SQL Server 2000 вместе с ее соединениями. При миграции задач «Управляемый данными запрос» и «Параллельное заполнение данными» создается задача «Выполнение пакета служб DTS 2000». Дополнительные сведения см. в разделах Миграция задач и Некоторые вопросы миграции пакетов.

Все соединения, используемые в задачах SQL Server 2000, миграция которых в SQL Server 2005 невозможна, остаются частью промежуточных пакетов SQL Server 2000, создаваемых в процессе миграции. Например, соединение в задаче «Преобразование данных» из SQL Server 2000 остается частью промежуточного пакета SQL Server 2000, включающего задачу «Преобразование данных».

Обновление свойств диспетчеров соединений

Диспетчеры соединений содержат свойства, значения которых устанавливаются по умолчанию.

В следующей таблице перечислены эти свойства.

Свойство | Описание
DelayValidation | Значение, определяющее, будет ли отложена проверка правильности соединения до запуска пакета. Значение данного свойства устанавливается мастером миграции пакетов в False.
Description | Описание диспетчера соединений. Мастер миграции пакетов оставляет значение данного свойства пустым.

См. также

Другие ресурсы

Миграция пакетов служб DTS


Миграция паролей

Миграция паролей |
 | См. также
Обновление компонентов SQL Server > Обновление или миграция служб DTS > Миграция пакетов служб DTS >

SQL Server 2005 использует пароли на пакеты только в связи с определенными параметрами уровня защиты пакетов. Поэтому защищенные паролем пакеты, полностью перемещенные с SQL Server 2000 на SQL Server 2005, не сохраняют пароли, хотя пароль необходимо предоставить в процессе миграции. Дополнительные сведения об уровнях защиты пакета в SQL Server 2005 см. в разделе Установка уровня защиты пакетов.

Примечание.
Защищенные паролем пакеты не могут пройти миграцию, если нет предоставленных паролей.

Если установлено исполняющее ядро DTS для SQL Server 2000, можно продолжать выполнение пакетов SQL Server 2000. Также можно включать эти пакеты в решения SQL Server 2005 по преобразованию данных. SQL Server 2005 продолжает поддерживать пароли на пакеты в этом сценарии. Например, задача выполнения пакета DTS 2000 включает свойство пароля для передачи пароля в пакет SQL Server 2000.

Добавление средств безопасности к пакетам

После миграции пакета можно добавить следующие средства безопасности.

  • Установите уровень защиты пакетов, чтобы зашифровать все или наиболее конфиденциальные значения свойства при сохранении пакета. Дополнительные сведения см. в разделе Пакеты служб Integration Services.

  • Добавьте к пакету цифровую подпись и установите свойства, чтобы убедиться, что подпись проверяется при загрузке пакета. Дополнительные сведения см. в разделе Как подписать пакет с помощью цифровой подписи.

  • Зашифруйте контрольные точки для пакетов, использующих контрольные точки. Дополнительные сведения см. в разделе Использование контрольных точек в пакетах.

Дополнительные сведения об обеспечении безопасности служб Integration Services и пакетов Integration Services см. в разделе Вопросы безопасности для служб Integration Services.

См. также

Другие ресурсы

Миграция пакетов служб DTS


Миграция сценариев

Миграция сценариев |
 | См. также
Обновление компонентов SQL Server > Обновление или миграция служб DTS > Миграция пакетов служб DTS >

Можно выполнить миграцию задачи «Сценарий ActiveX» версии SQL Server 2000 до версии SQL Server 2005. Однако задача «Сценарий ActiveX» версии SQL Server 2005 предоставляется только для обеспечения обратной совместимости. После выполнения миграции необходимо заменить VBScript управляемым кодом Visual Basic .NET в задаче «Сценарий» SQL Server 2005 Integration Services (SSIS).

Задачи «Сценарий ActiveX», которые пытаются получить доступ к объектной модели пакета с помощью свойства Parent коллекции GlobalVariables, перестанут работать после миграции пакета.Функциональность должна быть заменена другим кодом сценария или новыми возможностями SQL Server 2005.

См. также

Другие ресурсы

Задача «Сценарий ActiveX»
Задача «Сценарий»
Миграция пакетов служб DTS


Обновление командных строк dtsrun

Обновление командных строк dtsrun |
 | См. также
Обновление до SQL Server 2005 > Обновление компонентов SQL Server > Обновление или миграция служб DTS >

Новое содержимое: 5 декабря 2005 г.

Программа командной строки SQL Server 2000 dtsrun.exe в SQL Server 2005 заменена на dtexec.exe.

Аналогичным образом, существовавшая в SQL Server 2000 программа dtsrunui.exe, которая позволяла в интерактивном режиме строить командные строки, в SQL Server 2005 заменена на dtexecui.exe.

Обновление командных строк

Если необходимо преобразовать командные строки dtsrun, сопоставление аргументов командной строки с соответствующими аргументами dtexec см. в разделе Сопоставление параметров команд программ dtsrun и dtexec.

  • Некоторые параметры командной строки dtsrun имеют в dtexec прямые эквиваленты, например для указания имени сервера или пакета или для присваивания значения переменной.

  • Но некоторые аргументы dtsrun не имеют прямых эквивалентов в dtexec, например аргументы для указания доверенного соединения, которое теперь включается неявно, по умолчанию, или аргумент для загрузки из репозитория, который больше не поддерживается.

  • Имеется также несколько новых аргументов командной строки dtexec для поддержки новых функций служб SQL Server 2005 Integration Services (SSIS), например для передачи строк соединения и управления контрольными точками.

Если необходимо визуальное создание командных строк с помощью пользовательского интерфейса, воспользуйтесь программой dtexecui, которая отображает все доступные аргументы и гарантирует правильность синтаксиса.

Дополнительные сведения об аргументах команды dtexec и примерах синтаксиса dtexec см. в разделе Программа dtexec.

См. также

Другие ресурсы

Программа dtexec
Как запустить пакет с помощью программы DTExec
Как запустить пакет с помощью программы DTExecUI


Миграция экземпляров служб Notification Services

Миграция экземпляров служб Notification Services |
 | См. также
Обновление до SQL Server 2005 > Обновление компонентов SQL Server >

Программа установки Microsoft SQL Server не выполняет автоматическое обновление экземпляров служб Notification Services 2.0. Вместо этого следует обновить компонент Database Engine и установить Microsoft SQL Server 2005 Notification Services, а затем выполнить миграцию экземпляров служб Notification Services. Кроме того, программа установки не выполняет автоматическое обновление метаданных при обновлении до выпуска SQL Server 2005 с более широкими возможностями. Вместо этого, необходимо обновить метаданные, используя средства служб Notification Services.

Этот раздел описывает параметры миграции и содержит ссылки на дополнительные сведения для различных сценариев миграции.

Важно!
Настоятельно рекомендуется испытать этапы миграции на тестовых серверах и затем создать резервную копию экземпляров производственных баз данных перед миграцией производственных экземпляров служб Notification Services.

Известные проблемы миграции

Перед миграцией экземпляров служб Notification Services 2.0 в службы SQL Server 2005 Notification Services изучите все вопросы обновления и миграции. Дополнительные сведения см. в разделе Обратная совместимость служб Notification Services.

Подготовка к миграции на SQL Server 2005

Перед обновлением компонента Database Engine и миграцией экземпляров служб Notification Services ознакомьтесь со следующими разделами:

  • Требования к оборудованию и программному обеспечению для установки SQL Server 2005

  • Использование помощника по обновлению для подготовки к обновлениям

  • Параметры для средства проверки конфигурации системы

  • Анализ безопасности при установке SQL Server

Миграция экземпляров служб Notification Services

Службы Notification Services хранят метаданные экземпляров и приложений, а также рабочие данные в базах данных. Версия экземпляра служб Notification Services должна соответствовать версии экземпляра Database Engine.

  • Если имеются экземпляры служб Notification Services 2.0 и их необходимо обновить до SQL Server 2005, следует обновить компонент Database Engine, установить службы SQL Server 2005 Notification Services, а затем провести миграцию экземпляров служб Notification Services. Дополнительные сведения см. в разделе Миграция экземпляров служб Notification Services 2.0 на SQL Server 2005.

  • Если имеются экземпляры служб SQL Server 2005 Notification Services и их необходимо обновить до выпуска SQL Server 2005 с более широкими возможностями, необходимо обновить метаданные экземпляра. Дополнительные сведения см. в разделе Миграция экземпляров служб Notification Services до выпуска SQL Server 2005 с более широкими возможностями.

Параллельные установки

Можно установить службы Notification Services 2.0 и SQL Server 2005 Notification Services параллельно. Однако внутри экземпляра служб Notification Services версия компонента Database Engine и версия служб Notification Services должны совпадать. Кроме того, пользовательские компоненты должны быть построены со ссылкой на ту же версию служб Notification Services и соответствующую версию платформы Microsoft .NET Framework.

Если сведения о версии в реестре Microsoft Windows и в базе данных не совпадают, экземпляр Notification Services не запустится. Следовательно, после миграции экземпляра служб Notification Services необходимо проверить сведения о версии. Можно отобразить сведения о версии в среде SQL Server Management Studio или с помощью программ командной строки.

  • Как просмотреть сведения о версии служб Notification Services

  • Команда nscontrol listversions

Возврат экземпляров служб Notification Services к предыдущей версии

Если после миграции экземпляров служб Notification Services необходимо вернуться к ранней версии, нужно восстановить предыдущие базы данных из резервных копий и затем повторно зарегистрировать экземпляр Notification Services, используя соответствующую версию программ служб Notification Services.

См. также

Основные понятия

Установка SQL Server 2005
Установка служб SQL Server Notification Services


Миграция экземпляров служб Notification Services 2.0 на SQL Server 2005

Миграция экземпляров служб Notification Services 2.0 на SQL Server 2005 |
 | См. также
Обновление до SQL Server 2005 > Обновление компонентов SQL Server > Миграция экземпляров служб Notification Services >

Версия экземпляра служб Notification Services и его базы данных должны совпадать. Экземпляры служб Notification Services 2.0 должны использовать базы данных Microsoft SQL Server 2000. Экземпляры служб Microsoft SQL Server 2005 Notification Services должны использовать базы данных SQL Server 2005.

Базы данных SQL Server 2000 обновляются при обновлении версии Database Engine или при перемещении базы данных на сервер баз данных SQL Server 2005. Службы SQL Server 2005 Notification Services устанавливаются вместе с Notification Services 2.0. Экземпляры служб Notification Services не обновляются автоматически при запуске программы установки. Необходимо выполнять миграцию экземпляров служб Notification Services на SQL Server 2005 следующим образом:

  • Обновите версию Database Engine.

  • Установите службы SQL Server 2005 Notification Services.

  • Обновите метаданные экземпляра служб Notification Services.

  • Обновите версию экземпляра служб Notification Services.

Матрица миграции

В следующей таблице перечислены все возможные пути миграции со служб Notification Services 2.0 на службы SQL Server 2005 Notification Services. «Да» означает, что возможна миграция с версии в левом столбце на версию, указанную в верхней части столбца. «Нет» означает, что миграция невозможна.

Текущая версия | SQL Server 2005 Evaluation Edition | SQL Server 2005 Developer Edition | SQL Server 2005 Workgroup Edition | SQL Server 2005 Standard Edition | SQL Server 2005 Enterprise Edition
Службы Notification Services 2.0 выпуска Standard Edition | Да 1 | Да 2 |  | Да | Да
Службы Notification Services 2.0 выпуска Enterprise Edition | Да 1 | Да 2 |  | Нет | Да

1. Выпуск SQL Server 2005 Evaluation Edition имеет ограничение по времени. По истечении лимита времени экземпляр служб Notification Services перестанет запускаться.

2. См. лицензионные ограничения SQL Server 2005 Developer Edition.

Примечание Службы Notification Services не поддерживают выпуски SQL Server 2005 Express Edition и SQL Server Workgroup Edition.

Подготовка к миграции экземпляров

Перед обновлением версии существующего экземпляра служб Notification Services на SQL Server 2005 выполните следующие задачи:

  • Перекомпилируйте поставщики событий, модули форматирования данных и протоколы доставки при использовании сборок служб SQL Server 2005 Notification Services и платформы Microsoft .NET Framework 2.0. Пользовательские компоненты, скомпилированные при использовании сборки служб Notification Services 2.0 и платформы .NET Framework 1.1, несовместимы со службами SQL Server 2005 Notification Services.

    Сборки SQL Server 2005 для служб Notification Services находятся в папке %ProgramFiles%\Microsoft SQL Server\90\NotificationServices\n.n.nnn\bin, где n.n.nnn — номер сборки.

  • Удалите образцы приложений служб Notification Services 2.0.

    Образцы служб Notification Services 2.0 не будут работать на сервере SQL Server 2005. Изменился синтаксис правил; правила, использующие функцию Notify(), не поддерживаются в SQL Server 2005.

    Кроме этого, в некоторых образцах приложений используются одинаковые имена в службах Notification Services 2.0 и SQL Server 2005, поэтому нужно удалить образцы служб Notification Services 2.0, прежде чем пользоваться образцами SQL Server 2005, имеющими те же имена.

    Чтобы удалить образцы приложений 2.0, запустите программу RemoveSamplesDB.cmd, которая находится в папке v2.0.NNNN.0\Samples.

  • Убедитесь, что приложения содержат не более одного распространителя на одном сервере. В SQL Server 2005 это недопустимо. При необходимости внесите изменения в файл ADF, чтобы переместить одного из распространителей, затем обновите приложение, и только после этого можно производить миграцию на SQL Server 2005.

  • Выберите подходящее время для обновления версии.

    Выполняйте обновление экземпляров в момент наименьшей активности пользователей, чтобы минимизировать количество собираемых событий, создаваемых и рассылаемых уведомлений и операций по управлению подписками. Постарайтесь избежать обновления версии во время запланированной очистки, которая часто выполняется в периоды низкой активности. Расписание очистки указывается по времени UTC в каждом из файлов определения приложения (ADF).

  • Подготовьте устройство резервного копирования для баз данных экземпляра и приложения.

    Во время обновления будет необходимо создать резервную копию баз данных экземпляра и приложения. Предварительная подготовка устройства резервного копирования позволит сэкономить время, затраченное на обновление версии.

Как произвести миграцию экземпляров

Можно произвести миграцию экземпляров служб Notification Services на SQL Server 2005 с помощью среды SQL Server Management Studio или программам командной строки:

  • Как выполнить миграцию экземпляров служб Notification Services 2.0 в SQL Server 2005 (среда SQL Server Management Studio)

  • Как выполнить миграцию экземпляров служб Notification Services 2.0 на SQL Server 2005 (командная строка)

См. также

Основные понятия

Миграция экземпляров служб Notification Services
Установка служб SQL Server Notification Services
Как просмотреть сведения о версии служб Notification Services


Миграция экземпляров служб Notification Services до выпуска SQL Server 2005 с более широкими возможностями

Миграция экземпляров служб Notification Services до выпуска SQL Server 2005 с более широкими возможностями |
 | См. также
Обновление до SQL Server 2005 > Обновление компонентов SQL Server > Миграция экземпляров служб Notification Services >

При выполнении служб Notification Services на Microsoft SQL Server 2005 может быть выполнена их миграция до выпуска с более широкими возможностями SQL Server 2005. В следующем списке приводятся выпуски SQL Server 2005, поддерживаемые службами Notification Services в порядке от выпусков с узкими возможностями до выпусков с широкими возможностями:

  • SQL Server 2005 Evaluation Edition

  • SQL Server 2005 Developer Edition

  • SQL Server 2005 Standard Edition

  • SQL Server 2005 Enterprise Edition

Можно выполнить миграцию экземпляров выпуска SQL Server 2005 Standard Edition до выпуска Evaluation Edition или Developer Edition, даже если они находятся в списке на более низком уровне. Выпуски Evaluation Edition и Developer Edition обладают такой же функциональностью служб Notification Services, что и выпуск Enterprise Edition. Миграция из выпуска Standard Edition до данных выпусков дает возможность пользователю оценить функциональность выпуска Enterprise Edition.

Исполняемые файлы служб SQL Server 2005 Notification Services обновляются до выпуска с более широкими возможностями SQL Server 2005 с помощью программы установки SQL Server 2005. Однако при выполнении программы установки автоматическая миграция экземпляров служб Notification Services не выполняется. После выполнения программы установки необходимо выполнить миграцию экземпляров до выпуска с более широкими возможностями с помощью следующего процесса.

  • Установите выпуск служб SQL Server 2005 Notification Services с более широкими возможностями.

  • Обновите метаданные экземпляра служб Notification Services.

Матрица миграции

В следующей таблице представлены возможные пути миграции. «Да» означает, что возможна миграция с версии в левом столбце на версию, указанную в верхней части столбца. «Нет» означает, что миграция невозможна.

 | Evaluation Edition | Developer Edition | Standard Edition | Enterprise Edition
Evaluation Edition | --4 | Да 2 | Да 3 | Да
Developer Edition | Нет | --4 | Да 3 | Да
Standard Edition | Да 1 | Да 2 | --4 | Да
Enterprise Edition | Нет | Нет | Нет | --4

1 Выпуск SQL Server 2005 Evaluation Edition имеет ограничение по времени. По истечении лимита времени экземпляр служб Notification Services перестанет запускаться.

2 См. лицензионные ограничения SQL Server 2005 Developer Edition.

3 Обратите внимание, что в выпуске SQL Server 2005 Standard Edition поддерживаются не все возможности. Обновление экземпляра, выполненное в конце процесса миграции, отметит все возможности приложения, не поддерживаемые в выпуске Standard Edition.

4 Миграция выполняется успешно, но никаких изменений не выполнено, так как исходная и конечная версии, а также выпуск, совпадают.

Подготовка к миграции

Перед миграцией экземпляров служб Notification Services из выпуска с менее широкими возможностями в выпуск SQL Server 2005 с более широкими возможностями выполните следующие задачи.

  • Определите наилучшее время для выполнения миграции.

    Выполните миграцию экземпляров в момент наименьшей активности пользователей, чтобы минимизировать воздействие на операции сбора событий, создания и рассылки уведомлений и управления подписками. Постарайтесь избежать миграции во время запланированной очистки, которая часто выполняется в периоды низкой активности. Расписание очистки указывается по времени UTC в каждом из файлов определения приложения ADF.

  • Подготовьте устройство резервного копирования для баз данных экземпляра и приложения.

    Во время миграции будет предложено создать их резервную копию. Предварительная подготовка устройства резервного копирования позволит сэкономить время, затраченное на миграцию экземпляров.

Как выполнить миграцию

Миграцию экземпляров служб Notification Services до другого выпуска SQL Server 2005 можно выполнить с помощью среды SQL Server Management Studio или программ командной строки:

  • Как выполнить миграцию экземпляров служб Notification Services до выпуска с более широкими возможностями (среда SQL Server Management Studio)

  • Как провести миграцию экземпляров служб Notification Services до выпуска с более широкими возможностями (командная строка)

См. также

Основные понятия

Как просмотреть сведения о версии служб Notification Services
Миграция экземпляров служб Notification Services
Установка служб SQL Server Notification Services


Обновление реплицируемых баз данных

Обновление реплицируемых баз данных |
 | См. также
Обновление до SQL Server 2005 > Обновление компонентов SQL Server >

Дата обновления: 17 июля 2006 г.

SQL Server 2005 поддерживает обновление реплицируемых баз данных SQL Server предыдущих версий, при этом на время обновления узла прекращать работу с другими узлами не требуется. Соблюдайте следующие правила, определяющие допустимые версии объектов репликации.

  • SQL Server версии 7.0 с пакетом обновления 4 (SP4) является минимальной версией, необходимой для участия в топологии репликации с SQL Server 2005. При использовании SQL Server 2000 необходим пакет обновления 3 (SP3) или выше.

  • Версия распространителя не должна быть ниже версии издателя (во многих случаях распространителем и издателем является один и тот же экземпляр).

  • Версия издателя не должна превышать версию распространителя.

  • Версия подписчика зависит от типа публикации следующим образом.

    • Подписчик на публикацию транзакций, способный только читать данные, может иметь любую версию, отличающуюся от версии издателя не более чем на две версии. Например, издатель SQL Server 7.0 может работать с подписчиками SQL Server 2005, а издатель SQL Server 2005 — с подписчиками SQL Server 7.0.

    • Обновляемый подписчик на публикацию транзакций SQL Server 2005 может иметь любую версию не ниже SQL Server 2000 с пакетом обновления 3 (SP3).

    • Версия подписчика на публикацию слиянием не должна превышать версию издателя.

Примечание.
Этот раздел доступен в справочной документации по программе установки, а также в электронной документации по SQL Server 2005. Ссылки на разделы, выделенные полужирным шрифтом в справочной документации по установке, относятся к разделам, доступным только в электронной документации.

Обновление до выпусков Standard Edition, Workgroup Edition и Express Edition

Перед обновлением от одного выпуска SQL Server 2005 до другого проверьте, что используемые функции поддерживаются также и в выпуске, до которого производится обновление. Дополнительные сведения см. в подразделе «Возможности репликации SQL Server 2005» раздела Возможности, поддерживаемые различными выпусками SQL Server 2005.

Новая модель безопасности агента репликации

В предыдущих версиях SQL Server агенты выполнялись по умолчанию в контексте учетной записи службы агента SQL Server. SQL Server 2005 обеспечивает разделяемый контроль над всеми учетными записями, в контекстах которых агенты репликации работают и устанавливают соединения к базам данных и другим ресурсам с использованием встроенной авторизации Windows; каждому агенту можно назначить отдельную учетную запись. Дополнительные сведения см. в разделах Вопросы безопасности репликации и Модель безопасности агента репликации.

Реализация новой модели безопасности сказалась на обновлении и выполнении нескольких версий SQL Server в топологии репликации следующим образом.

  • Для повышения уровня безопасности сценарии репликации, созданные для SQL Server 2000 или SQL Server 7.0, должны быть обновлены до SQL Server 2005. Дополнительные сведения см. в разделе How to: Upgrade Replication Scripts (Replication Transact-SQL Programming).

  • Распространитель или подписчик, обновленный с версии SQL Server до SQL Server 2005, по-прежнему будет выполняться в контексте учетной записи агента SQL Server и, скорее всего, получит больше прав доступа, чем нужно. Таким образом, после обновления рекомендуется назначить агентам отдельные учетные записи с минимально необходимыми правами доступа. Чтобы назначить агентам отдельные учетные записи, выполните следующие действия.

    1. Внесите в сценарий публикацию и подписки.

    2. Внесите в сценарии изменения. Дополнительные сведения см. в разделе How to: Upgrade Replication Scripts (Replication Transact-SQL Programming).

    3. Удалите публикацию и подписки. Дополнительные сведения см. в разделах Публикация данных и объектов базы данных и Подписка на публикации.

    4. Заново создайте публикацию и подписки с использованием измененных сценариев.

    Сведения о правах, необходимых для агентов, см. в разделе Модель безопасности агента репликации; сведения об управлении именами для входа и паролями см. в разделе Управление именами входа и паролями в репликации. Новые конфигурации репликации, созданные после обновления, требуют, чтобы каждому агенту репликации соответствовала отдельная конфигурация учетной записи.

    Примечание.
    Любые агенты, использующие при установлении локальных соединений с базами данных проверку подлинности SQL Server, начинают после этого использовать проверку подлинности Windows. Локальными называются соединения, производимые агентом к экземпляру SQL Server, запущенному на том же компьютере, что и агент. Например, агент слияния при подписке по запросу запускается на стороне подписчика, и все его соединения с подписчиком являются локальными.

  • В случае наличия в топологии репликации членов, на которых выполняются предыдущие версии SQL Server, модель безопасности репликации остается прежней. Например:

    • При подписке по запросу подписчика SQL Server 2000 или SQL Server 7.0 новая модель безопасности не используется, потому что агент слияния или распространения создается на стороне подписчика.

    • При принудительной подписке, инициируемой распространителем SQL Server 2005 и принимаемой подписчиком SQL Server 2000 или SQL Server 7.0, используется новая модель безопасности, потому что агент слияния или распространения создается на стороне распространителя.

    • Издатель SQL Server 2000 или SQL Server 7.0 с распространителем SQL Server 2005 не использует новую модель безопасности (для агентов моментальных снимков, чтения журнала или чтения очереди), потому что эти агенты создаются в контексте базы данных публикации.

Выполнение агентов после обновления (репликация слиянием)

После обновления запустите агент моментальных снимков для каждой публикации слиянием и агент слияния для каждой подписки, чтобы обновить метаданные репликации. Применять новый моментальный снимок не требуется, потому что заново инициализировать подписки не нужно. Метаданные подписки обновляются при первом запуске агента слияния после обновления. Это означает, что база данных подписки может оставаться в доступном активном режиме во время обновления издателя.

Механизм репликации слиянием хранит метаданные публикации и подписки в нескольких системных таблицах баз данных публикации и подписки. При запуске агента моментальных снимков обновляются метаданные публикации, а при запуске агента слияния — метаданные подписки. Пользователь должен только сформировать моментальный снимок публикации. Если при публикации слиянием используются параметризованные фильтры, каждой секции также соответствует моментальный снимок. Обновлять эти секционированные снимки не требуется. (В SQL Server 2000 параметризованные фильтры назывались динамическими фильтрами, а секционированные снимки — динамическими снимками.)

Для выполнения агентов можно использовать среду , монитор репликации и окно командной строки. Дополнительные сведения о выполнении агента моментальных снимков см. в следующих разделах.

  • Как создать и применить исходный моментальный снимок (среда SQL Server Management Studio)

  • Как запустить и остановить агент репликации (среда SQL Server Management Studio)

  • How to: Create the Initial Snapshot (Replication Transact-SQL Programming)

  • Programming Replication Agent Executables

Дополнительные сведения о выполнении агента слияния см. в следующих разделах.

  • Как синхронизировать подписку по запросу (среда SQL Server Management Studio)

  • Как синхронизировать принудительную подписку (среда SQL Server Management Studio)

  • How to: Synchronize a Pull Subscription (Replication Programming)

  • How to: Synchronize a Push Subscription (Replication Programming)

Если после обновления SQL Server в топологии, в которой используется репликация слиянием, необходимо использовать новые возможности, измените уровень совместимости всех публикаций. Дополнительные сведения см. в разделе Использование нескольких версий SQL Server в топологии репликации.

Веб-синхронизация для репликации слиянием

Веб-синхронизация репликации слиянием требует, чтобы в виртуальный каталог служб IIS, используемый для синхронизации, было скопировано средство прослушивания репликации SQL Server (библиотека replisapi.dll). При настройке веб-синхронизации этот файл копируется в виртуальный каталог мастером настройки веб-синхронизации. Для обновления компонентов SQL Server, установленных на сервере IIS, необходимо вручную скопировать библиотеку replisapi.dll из каталога COM в виртуальный каталог сервера IIS. Дополнительные сведения о веб-синхронизации см. в разделе Настройка веб-синхронизации.

Восстановление реплицированной базы данных из предыдущей версии

Чтобы обеспечить неизменность параметров репликации при восстановлении реплицированной базы данных на основе ее резервной копии, используйте в качестве целевых объектов восстановления сервер и базу данных с именами, идентичными именам сервера, и базы данных, на основе которых была создана резервная копия.

См. также

Справочник

Обновления версий и выпусков

Основные понятия

Обратная совместимость репликации
Использование нескольких версий SQL Server в топологии репликации

Другие ресурсы

Управление репликацией
Улучшения в репликации

Журнал изменений

Версия Журнал

17 июля 2006 г.

Измененное содержимое:
  • Добавлена информация о том, что базы данных подписки могут оставаться в доступном активном режиме во время обновления издателя.


Разделы руководства по обновлению компонентов SQL Server

Разделы руководства по обновлению компонентов SQL Server |
 | См. также
Обновление до SQL Server 2005 > Обновление компонентов SQL Server >

Материал этого раздела предоставляет сведения об обновлении или миграции существующих компонентов Microsoft SQL Server в Microsoft SQL Server 2005.

В этом разделе

  • Разделы руководства по обновлению ядра СУБД

  • Разделы руководства по обновлению или миграции служб Analysis Services

  • Разделы руководства по миграции служб Notification Services

  • Разделы руководства по обновлению или выполнению миграции служб DTS

См. также

Задачи

Как установить SQL Server 2005 из командной строки

Основные понятия

Подготовка к установке SQL Server 2005
Настройка контактной зоны SQL Server

Другие ресурсы

Разделы руководства по установке компонентов SQL Server


Разделы руководства по обновлению ядра СУБД

Разделы руководства по обновлению ядра СУБД |
 | См. также
Обновление до SQL Server 2005 > Обновление компонентов SQL Server > Разделы руководства по обновлению компонентов SQL Server >

В данном подразделе описывается, как обновить изолированный или кластеризованный экземпляр до версии SQL Server 2005.

В этом разделе

  • Как обновить до SQL Server 2005 (программа установки)

  • Как установить SQL Server 2005 из командной строки

  • Как произвести обновление до отказоустойчивого кластера SQL Server 2005 (установка)

См. также

Справочник

Обновления версий и выпусков

Другие ресурсы

Обновление компонентов SQL Server
Обратная совместимость
Установка компонентов SQL Server 2005


Как обновить до SQL Server 2005 (программа установки)

Как обновить до SQL Server 2005 (программа установки) |
 | См. также
Обновление компонентов SQL Server > Разделы руководства по обновлению компонентов SQL Server > Разделы руководства по обновлению ядра СУБД >

Дата обновления: 5 декабря 2005 г.

Мастер установки SQL Server 2005 основан на установщике Windows и предоставляет единое дерево для обновления компонентов SQL Server. Можно установить SQL Server 2005 параллельно с SQL Server 2000 или SQL Server 7.0 или произвести миграцию существующих баз данных и настроек из предыдущих версий SQL Server и добавить их к экземпляру SQL Server 2005.

Дополнительные сведения о параметрах обновления и миграции см. в разделе Обновление компонентов SQL Server. Дополнительные сведения о поддержке параллельных конфигураций см. в разделе Работа с несколькими версиями SQL Server.

Database Engine

Чтобы обновить экземпляр SQL Server 2000 или SQL Server 7.0 Database Engine, см. описанную ниже процедуру.

Чтобы обновить отказоустойчивый кластер, см. раздел Как произвести обновление до отказоустойчивого кластера SQL Server 2005 (установка).

Чтобы произвести миграцию пользовательских баз данных в SQL Server 2005, см. следующие разделы.

  • Использование мастера копирования баз данных

  • Как выполнить обновление до версии SQL Server 2005 с помощью мастера копирования баз данных

Analysis Services

Сведения об обновлении Analysis Services см. в разделе Обновление и миграция служб Analysis Services.

Reporting Services

Используйте программу установки (мастер установки) SQL Server и средства настройки служб Reporting Services для обновления Reporting Services. Дополнительные сведения см. в разделе Обновление служб Reporting Services.

Notification Services

Для обновления служб Notification Services обновите ядро СУБД и установите службы SQL Server 2005 Notification Services, после чего произведите миграцию экземпляров служб Notification Services. Дополнительные сведения см. в разделе Миграция экземпляров служб Notification Services.

Службы DTS

Сведения об использовании служб DTS вместе с SQL Server 2005 см. в разделе Обновление или миграция служб DTS.

Репликация

SQL Server 2005 поддерживает обновление реплицированных баз данных предыдущих версий SQL Server. Дополнительные сведения см. в разделе Обновление реплицируемых баз данных.

Предварительные требования

Для локальных установок необходимо запускать программу установки с правами администратора. При установке SQL Server из удаленной общей папки необходимо использовать учетную запись домена с разрешениями на чтение и выполнение для удаленной общей папки.

Перед обновлением Database Engine до SQL Server 2005 просмотрите следующие разделы.

  • Требования к оборудованию и программному обеспечению для установки SQL Server 2005

  • Параметры для средства проверки конфигурации системы

  • Анализ безопасности при установке SQL Server

  • Обратная совместимость компонента SQL Server 2005 Database Engine

  • Обновление компонента Database Engine

Процедура

Обновление ядра СУБД SQL Server до SQL Server 2005

  1. Вставьте установочный диск с SQL Server 2005 в CD- или DVD- привод. Мастер установки SQL Server должен запуститься автоматически. Если мастер установки SQL Server не запускается автоматически, дважды щелкните файл Splash.hta в корневом каталоге этого диска.

    Примечание.
    Чтобы запустить программу установки с сетевого диска, перейдите в папку на общем диске, где расположены файлы установки, и дважды щелкните Splash.hta.

  2. Для начала процесса установки нажмите кнопку Установить SQL Server.

  3. На странице Лицензионное соглашение прочтите лицензионное соглашение, затем установите флажок для подтверждения принятия условий соглашения. Принятие лицензионного соглашения активирует кнопку Далее. Чтобы продолжить, нажмите кнопку Далее. Чтобы выйти из программы установки, нажмите кнопку Отмена.

  4. На странице Обновление компонентов SQL Server программа установки устанавливает программное обеспечение, необходимое для SQL Server 2005. Чтобы получить дополнительные сведения о требованиях компонентов, нажмите кнопку Справка внизу страницы. Чтобы начать процесс обновления компонента, нажмите кнопку Установить. Чтобы продолжить работу после завершения обновления, нажмите кнопку Готово. Дополнительные сведения см. в разделе Установка необходимых программ.

  5. Чтобы продолжить, нажмите кнопку Далее на странице Приветствие мастера установки SQL Server.

  6. На странице Проверка конфигурации системы (SCC) производится проверка компьютера на наличие условий, которые могут препятствовать работе программы установки. Чтобы получить сведения об элементах проверки конфигурации, нажмите кнопку Справка внизу этой страницы или см. раздел Параметры для средства проверки конфигурации системы. Чтобы прервать проверку, нажмите кнопку Остановить. Чтобы отобразить список элементов проверки, сгруппированных по результату, нажмите кнопку Фильтр и выберите категорию из раскрывающегося списка. Для просмотра отчета о результатах проверки нажмите кнопку Отчет и выберите параметр из раскрывающегося списка. Предусмотрены возможности просмотра отчета, сохранения отчета в файл, копирования отчета в буфер обмена и отправки отчета по электронной почте. Чтобы продолжить установку после завершения проверки конфигурации, нажмите кнопку Продолжить.

  7. На странице Регистрационные данные введите данные в текстовые поля Имя и Организация. Для данного выпуска ключ продукта вводится автоматически. Чтобы продолжить, нажмите кнопку Далее. Дополнительные сведения см. в разделе Регистрационные сведения.

  8. На странице Устанавливаемые компоненты выберите компоненты для установки. При выборе группы компонентов ее описание отображается на панели Компоненты, которые необходимо установить. Можно установить любую комбинацию компонентов, используя флажки. Если выбран сервер SQL Server или службы Analysis Services и программа установки обнаруживает, что происходит установка на виртуальный сервер, становится доступным флажок Установить отказоустойчивый кластер. Необходимо установить этот флажок для установки отказоустойчивого кластера. Дополнительные сведения см. в разделе Компоненты для установки.

    Чтобы установить отдельные компоненты, нажмите кнопку Дополнительно. В противном случае нажмите кнопку Далее, чтобы продолжить.

  9. Если на предыдущей странице была нажата кнопка Дополнительно, появится страница Выбор компонентов. На странице Выбор компонентов с помощью раскрывающихся списков выберите компоненты программы для установки. Чтобы установить компоненты в определенный каталог, выберите компонент и нажмите кнопку Обзор. Дополнительные сведения о возможностях этой страницы см. в разделе Выбор компонентов. Если выбор компонентов закончен, нажмите кнопку Далее, чтобы продолжить.

  10. На странице Имя экземпляра выберите, какой экземпляр нужно обновить, именованный или по умолчанию. Если именованный экземпляр или экземпляр по умолчанию уже установлен и выбран вновь, программа установки обновляет его и предоставляет возможность установки дополнительных компонентов.

    Чтобы обновить экземпляр SQL Server по умолчанию, установленный на компьютере, щелкните Экземпляр по умолчанию и нажмите кнопку Далее, чтобы продолжить.

    Чтобы обновить именованный экземпляр SQL Server, установленный на компьютере, щелкните Именованный экземпляр и введите имя экземпляра или щелкните Установленные экземпляры на странице Имя экземпляра, выберите экземпляр из списка Установленные экземпляры и нажмите кнопку ОК для заполнения имени экземпляра. После выбора экземпляра для обновления нажмите кнопку Далее, чтобы продолжить.

    Примечание.
    Чтобы можно было обновить экземпляр по умолчанию и именованный экземпляр, они уже должны быть установлены. Чтобы обновить именованный экземпляр, он уже должен быть установлен.

    Дополнительные сведения о правилах именования экземпляров см. в разделе Имя экземпляра.

  11. На странице Существующие компоненты программа установки отображает список компонентов SQL Server, установленных на компьютере. Флажки компонентов, которые могут быть обновлены до SQL Server 2005, доступны. Если флажок какого-либо компонента недоступен, это означает, что данный компонент не может быть обновлен до SQL Server 2005. Для просмотра отчета о доступных параметрах и альтернативах нажмите кнопку Подробности. Чтобы обновить компонент, присутствующий в списке на странице Существующие компоненты, установите его флажок и нажмите кнопку Далее. Дополнительные сведения см. в разделе Существующие компоненты.

  12. Если нужно добавить новые компоненты, на странице Учетная запись службы укажите имя пользователя, пароль и имя домена для учетных записей, не принадлежащих SQL Server. Для этого выпуска программа установки SQL Server 2005 использует данные учетной записи существующей службы SQL Server, помеченной для обновления. Можно использовать одну учетную запись для всех служб.

    При необходимости можно определить индивидуальную учетную запись для каждой службы. Установите флажок Настроить для каждой учетной записи службы, выберите имя службы из списка и введите учетные данные для каждой службы из списка. Чтобы продолжить, нажмите кнопку Далее. Дополнительные сведения см. в разделе Учетная запись службы.

    Примечание.
    Имя домена не может быть полным DNS-именем. Например, если DNS-именем является my-domain-name.com, введите «my-domain-name» в текстовое поле Домен. Программа установки SQL Server не примет значение «my-domain-name.com» в текстовое поле Домен.

  13. Страница Обновить сведения о входе в систему отображается, если обновляемый экземпляр SQL Server настроен на использование смешанного режима (проверка подлинности Windows или проверка подлинности SQL Server). Учетные данные, отображаемые на этой странице, используются для подключения к существующему экземпляру SQL Server с целью выполнения сценариев обновления. Если существующий экземпляр SQL Server настроен на использование проверки подлинности Windows, эта страница не будет отображена. Чтобы продолжить, нажмите кнопку Далее. Дополнительные сведения см. в разделе Обновление учетных данных.

    Примечание безопасности.
    По возможности используйте проверку подлинности Windows.

    Примечание безопасности.
    Для этого выпуска программа установки SQL Server может не требовать ввода надежного пароля для некоторых настроек по умолчанию Microsoft Windows Server 2003, если компьютер не является членом домена. Задание надежных паролей необходимо для безопасности системы. Всегда используйте надежные пароли. Рекомендации по выбору надежного пароля см. в разделе Режим проверки подлинности электронной документации по SQL Server 2005.

  14. Если в качестве компонента для установки выбраны службы Analysis Services, на странице Параметры сортировки укажите параметры сортировки по умолчанию. Можно использовать одинаковые параметры сортировки для SQL Server и служб Analysis Services или задать собственные параметры сортировки для каждого компонента.

    Чтобы установить параметры сортировки отдельно для SQL Server и служб Analysis Services, установите флажок Настроить для каждой учетной записи службы. После установки флажка появится раскрывающийся список. Выберите службу из раскрывающегося списка и назначьте ей параметры сортировки. Повторите для каждой службы. Чтобы продолжить, нажмите кнопку Далее. Дополнительные сведения см. в разделе Параметры сортировки.

  15. Если в качестве устанавливаемого компонента выбраны службы Reporting Services, отобразится страница Виртуальные каталоги сервера отчетов. Примите имена каталогов по умолчанию или укажите расположение каталогов. Чтобы получить дополнительные сведения об этой странице, нажмите кнопку Справка внизу страницы. Чтобы продолжить, нажмите кнопку Далее. Дополнительные сведения см. в разделе Параметры установки сервера отчетов.

  16. Если в качестве устанавливаемого компонента выбраны службы Reporting Services, отобразится страница Настройка базы данных сервера отчетов. Укажите экземпляр сервера для размещения базы данных сервера отчетов. Если база данных сервера отчетов будет размещаться в существующем экземпляре SQL Server, выберите экземпляр из раскрывающегося списка, а затем выберите режим проверки подлинности для доступа к этому экземпляру. Дополнительные сведения см. в разделе Сведения об установке сервера отчетов.

    Если выбран пункт Проверка подлинности SQL Server, введите имя пользователя и пароль с правами доступа администратора для этого экземпляра. Выберите Подтвердить имя базы данных сервера отчетов. Чтобы продолжить, нажмите кнопку Далее.

  17. Если в качестве устанавливаемого компонента выбраны службы Reporting Services, отобразится страница Параметры доставки сервера отчетов. Укажите адрес SMTP-сервера и адрес электронной почты, используемый как адрес отправителя для сообщений электронной почты, отправляемых сервером отчетов. Чтобы продолжить, нажмите кнопку Далее.

  18. На странице Параметры отчетов об ошибках и использовании при необходимости снимите флажок для отключения отчетов об ошибках. Чтобы продолжить, нажмите кнопку Далее. Дополнительные сведения см. в разделе Параметры отчетов об ошибках и использовании.

  19. На странице Все готово для установки проверьте сводный список функций и компонентов для установки SQL Server. В случае сценария обновления будут выбраны все компоненты и возможности существующего экземпляра. Чтобы продолжить, нажмите кнопку Установить. Дополнительные сведения см. в разделе Все готово для установки.

  20. На странице Ход установки можно следить за текущим состоянием процесса установки. Чтобы просмотреть файл журнала для компонента во время установки, щелкните имя продукта или состояния на странице Ход установки.

  21. На странице Завершение работы мастера установки Microsoft SQL Server можно просмотреть сводный журнал установки, щелкнув ссылку, представленную на этой странице. Для выхода из мастера установки SQL Server нажмите кнопку Готово.

  22. Если получено указание о перезагрузке компьютера, выполните его. После завершения установки важно прочитать сообщение программы установки. Если не выполнить перезагрузку компьютера, то при запуске программы установки в будущем могут возникнуть неполадки.

Следующие шаги

После обновления Database Engine до SQL Server 2005 выполните следующие действия.

  • Регистрация серверов: в процессе обновления удаляются настройки реестра для предыдущего экземпляра SQL Server. После обновления необходимо заново зарегистрировать свои серверы.

  • Повторное заполнение полнотекстовых каталогов: в процессе обновления для всех баз данных отключается полнотекстовый поиск. Каталоги должны быть заполнены заново, но эта операция не выполняется автоматически программой установки, поскольку ее выполнение может занять много времени. Так как эта операция улучшает производительность установленного SQL Server 2005, администраторам следует включить в план действий повторное заполнение полнотекстовых каталогов в удобное время.

  • Обновление статистики: оптимизация производительности запросов; рекомендуется после обновления обновить статистику для всех баз данных. Используйте хранимую процедуру sp_updatestats для обновления статистики в пользовательских таблицах баз данных SQL Server 2005.

  • Обновление счетчиков использования: в более ранних версиях SQL Server значения количества строк в таблицах и индексах, а также количество страниц может стать неверным. Чтобы исправить любые неправильные значения количества строк или страниц, рекомендуется запустить DBCC UPDATEUSAGE для всех баз данных сразу после обновления.

  • Настройка новой установки SQL Server: чтобы уменьшить уязвимую контактную зону системы, SQL Server 2005 выборочно устанавливает и активирует ключевые службы и функции. Дополнительные сведения об активации возможностей SQL Server 2005 см. в разделе Настройка контактной зоны SQL Server.

См. также

Задачи

Как изменить компоненты существующего экземпляра SQL Server 2005 (программа установки)

Основные понятия

Как просмотреть файлы журналов установки SQL Server 2005

Другие ресурсы

Обновление до SQL Server 2005
Обратная совместимость


Разделы руководства по обновлению или миграции служб Analysis Services

Разделы руководства по обновлению или миграции служб Analysis Services |
 | См. также
Обновление до SQL Server 2005 > Обновление компонентов SQL Server > Разделы руководства по обновлению компонентов SQL Server >

Этот раздел содержит следующие общие процедуры обновления и переноса баз данных в службы .

Описание общих процедур для установки служб Analysis Services см. в разделе Разделы руководства по установке служб Analysis Services.

Важно!
Подразделы руководства по обновлению и переносу служб Analysis Services в этом разделе уделяют внимание только возможностям обновления и переноса, специфичным для служб Analysis Services. Однако в этих разделах содержатся ссылки на другие разделы, в которых можно получить дополнительные сведения об установке SQL Server.

В этом разделе

  • Как обновить экземпляр служб Analysis Services

  • Как выполнить миграцию баз данных служб Analysis Services

См. также

Основные понятия

Обновление и миграция служб Analysis Services


Как обновить экземпляр служб Analysis Services

Как обновить экземпляр служб Analysis Services |
 | См. также
Обновление компонентов SQL Server > Разделы руководства по обновлению компонентов SQL Server > Разделы руководства по обновлению или миграции служб Analysis Services >

Можно выполнить обновление версии существующего экземпляра служб Analysis Services до и в рамках процесса обновления выполнить миграцию существующих баз данных из старого экземпляра в новый. Чтобы обновить существующий экземпляр служб SQL Server 2000 Analysis Services, запустите программу установки и укажите имя существующего экземпляра в качестве имени нового.

Важно!
Этот раздел и сопутствующие ему разделы руководства об обновлении и миграции служб Analysis Services содержат только те сведения о параметрах обновления и миграции, которые относятся к службам Analysis Services. Однако в этих разделах содержатся ссылки на другие разделы, в которых можно получить дополнительные сведения об установке SQL Server.

Обновление экземпляра служб Analysis Services

  1. Запустите программу установки с помощью мастера установки SQL Server или из командной строки. Дополнительные сведения о запуске программы установки с помощью мастера установки SQL Server см. в разделе Как установить службы Analysis Services с помощью программы установки. Дополнительные сведения о запуске программы установки из командной строки см. в разделе Как установить службы Analysis Services из командной строки.

    Важно!
    При переходе с 64-разрядной версии на 64-разрядную версию необходимо обновлять службы Analysis Services до обновления компонента Database Engine.

  2. Если используется мастер установки SQL Server, выберите Экземпляр по умолчанию на странице Имя экземпляра. Чтобы проверить наличие экземпляра служб SQL Server 2000 Analysis Services, можно нажать кнопку Установленные экземпляры. При запуске программы установки из командной строки используйте параметр instancename для указания существующего экземпляра служб SQL Server 2000 Analysis Services. Так как SQL Server 2000 Analysis Services не поддерживают именованные экземпляры, именем существующего экземпляра обычно является имя сервера.

См. также

Задачи

Как выполнить миграцию баз данных служб Analysis Services

Основные понятия

Обновление и миграция служб Analysis Services


Как выполнить миграцию баз данных служб Analysis Services

Как выполнить миграцию баз данных служб Analysis Services |
 | См. также
Обновление компонентов SQL Server > Разделы руководства по обновлению компонентов SQL Server > Разделы руководства по обновлению или миграции служб Analysis Services >

Миграцию существующих баз данных служб Analysis Services из экземпляра служб Analysis Services в экземпляр можно выполнить либо в момент установки, обновляя существующий экземпляр служб Analysis Services, либо после нее, запустив мастер миграции.

Этот раздел описывает процесс миграции существующих баз данных служб Analysis Services с помощью мастера миграции. При обновлении версии экземпляра служб SQL Server 2000 Analysis Services во время установки (при использовании мастера установки SQL Server) никаких дополнительных параметров, относящихся к миграции баз данных, указывать не нужно.

Важно!
Этот раздел и сопутствующие ему разделы руководства об обновлении и миграции служб Analysis Services содержат только те сведения о параметрах обновления и миграции, которые относятся к службам Analysis Services. Однако в этих разделах содержатся ссылки на другие разделы, в которых можно получить дополнительные сведения об установке SQL Server.

Миграция существующих баз данных служб Analysis Services с помощью мастера миграции

  1. Запустите мастер миграции из серверного узла служб Analysis Services обозревателя объектов в среде SQL Server Management Studio. Также мастер можно запустить из командной строки, запустив программу MigrationWizard.exe.

  2. После запуска мастер отображает страницу Мастер миграции служб Analysis Services. Прочитайте вводное сообщение и нажмите кнопку Далее, чтобы продолжить.

  3. На странице Задание источника и назначения укажите исходный сервер служб SQL Server 2000 Analysis Services и имя экземпляра, а затем сервер назначения служб SQL Server 2005 Analysis Services и имя экземпляра. Вместо указания целевого сервера можно выбрать сохранение схемы в файл сценария и завершить миграцию позже — например, с помощью задачи служб Analysis Services «Выполнить DDL» в пакете SQL Server 2005 Integration Services (SSIS). Дополнительные сведения о задаче служб Analysis Services «Выполнить DDL» см. в разделе Задача «Выполнение инструкции DDL служб Analysis Services».

  4. На странице Выбор баз данных для миграции установите флажки для баз данных, для которых необходимо выполнить миграцию. При необходимости для целевых баз данных можно указать другие имена.

  5. На странице Проверка баз данных мастер анализирует базы данных, предназначенные для миграции, и сообщает об обнаруженных проблемах.

  6. На странице Миграция баз данных мастер отображает ход выполнения миграции баз данных.

  7. На странице Завершение работы мастера мастер сообщает о результатах миграции. Чтобы завершить работу мастера, нажмите кнопку Готово.

  8. После миграции базы данных необходимо обработать базу данных из исходного источника данных, прежде чем можно будет выполнять к ней запросы. Дополнительные сведения см. в разделе Обработка средствами служб Analysis Services.

  9. После миграции можно просмотреть дополнительные сведения о различиях между версиями баз данных служб Analysis Services в разделе Вопросы миграции (службы SSAS).

См. также

Основные понятия

Миграция существующих баз данных служб Analysis Services
Вопросы миграции (службы SSAS)
Обновление и миграция служб Analysis Services


Разделы руководства по обновлению или выполнению миграции служб DTS

Разделы руководства по обновлению или выполнению миграции служб DTS |
 | См. также
Обновление до SQL Server 2005 > Обновление компонентов SQL Server > Разделы руководства по обновлению компонентов SQL Server >

Этот раздел содержит следующие общие процедуры для обновления и миграции пакетов до служб .

Общие процедуры установки служб Integration Services см. в разделе Разделы руководства по установке служб Integration Services.

В этом разделе

  • Как обновить службы DTS до служб Integration Services

  • Как осуществить миграцию пакетов служб DTS до служб Integration Services

См. также

Основные понятия

Обновление или миграция служб DTS
Обратная совместимость служб SQL Server 2005 Integration Services


Как обновить службы DTS до служб Integration Services

Как обновить службы DTS до служб Integration Services |
 | См. также
Обновление компонентов SQL Server > Разделы руководства по обновлению компонентов SQL Server > Разделы руководства по обновлению или выполнению миграции служб DTS >

Пакеты служб DTS SQL Server 2000 по-прежнему могут выполняться вместе с пакетами SQL Server 2005 Integration Services (SSIS).

Дополнительные сведения о параметрах обновления и миграции, доступных пользователям служб DTS, см. в разделе Обновление или миграция служб DTS.

Обновление службы DTS до служб Integration Services

  1. Установите SQL Server 2005 вместе со Integration Services, используя любой метод. Дополнительные сведения см. в разделе Как установить службы Integration Services с помощью программы установки или Как установить службы Integration Services из командной строки.

  2. При установке Integration Services также устанавливается поддержка для служб DTS SQL Server 2000, в том числе возможность перечислять и запускать пакеты служб DTS. Дополнительные сведения см. в разделе Как обеспечить поддержку пакетов служб DTS.

    Примечание.
    Хотя поддержка служб SQL Server 2000 DTS устанавливается автоматически при выборе служб Integration Services, некоторые настройки реестра и среды, необходимые для работы DTS, во время или после установки удаляются, если проводится обновление последнего экземпляра SQL Server 2000 на компьютере до SQL Server 2005. Для восстановления этих настроек выберите пункт «Обратная совместимость Microsoft SQL Server 2005» в списке Установка и удаление программ панели управления, нажмите кнопку Изменить и выберите параметр Восстановить на странице мастера Обслуживание программы.

  3. При желании можно выполнить миграцию пакетов DTS в формат Integration Services, оставив при этом исходные пакеты без изменений. Дополнительные сведения см. в разделе Миграция пакетов служб DTS. Мастер миграции пакетов устанавливается при установке Integration Services.

См. также

Задачи

Как обеспечить поддержку пакетов служб DTS

Основные понятия

Обратная совместимость служб SQL Server 2005 Integration Services


Как осуществить миграцию пакетов служб DTS до служб Integration Services

Как осуществить миграцию пакетов служб DTS до служб Integration Services |
 | См. также
Обновление компонентов SQL Server > Разделы руководства по обновлению компонентов SQL Server > Разделы руководства по обновлению или выполнению миграции служб DTS >

Миграция пакетов служб DTS из SQL Server 2000 в формат пакетов SQL Server 2005 Integration Services (SSIS) является необязательной. Пакеты служб DTS можно запускать наряду с пакетами Integration Services.

Дополнительные сведения о параметрах обновления и миграции, доступных пользователям служб DTS, см. в разделе Обновление или миграция служб DTS.

Для осуществления миграции пакетов служб DTS SQL Server 2005 включает мастер миграции пакетов. Так как мастер оставляет исходные пакеты без изменений, можно всегда продолжить использовать исходные пакеты в случае каких-либо трудностей миграции.

Мастер миграции пакетов устанавливается при установке служб Integration Services. Дополнительные сведения см. в разделе Как обеспечить поддержку пакетов служб DTS.

Примечание.
Мастер миграции пакетов доступен в следующих выпусках SQL Server 2005: Standard Edition, Enterprise Edition, Developer Edition.

Дополнительные сведения о миграции пакетов служб DTS см. в разделе Миграция пакетов служб DTS.

Миграция пакетов служб DTS в службы Integration Services

  1. При желании запустите помощник по обновлению, чтобы проанализировать существующие пакеты и получить отчет о возможных проблемах при миграции. Дополнительные сведения см. в разделе Некоторые вопросы миграции пакетов.

  2. Запустите мастер миграции пакетов, чтобы начать миграцию.

  3. Выполните ручную настройку тех элементов пакетов, для которых она необходима, согласно отчету помощника по обновлению или мастера.

  4. По мере необходимости проведите тестирование пакетов и устранение неполадок, связанных с ними.

См. также

Задачи

Как обеспечить поддержку пакетов служб DTS

Основные понятия

Обратная совместимость служб SQL Server 2005 Integration Services


Разделы руководства по миграции служб Notification Services

Разделы руководства по миграции служб Notification Services |
 | См. также
Обновление до SQL Server 2005 > Обновление компонентов SQL Server > Разделы руководства по обновлению компонентов SQL Server >

Подразделы этого раздела содержат инструкции по обновлению и миграции экземпляров служб Notification Services на Microsoft SQL Server 2005.

В этом разделе

  • Как выполнить миграцию экземпляров служб Notification Services 2.0 на SQL Server 2005 (командная строка)

  • Как выполнить миграцию экземпляров служб Notification Services 2.0 в SQL Server 2005 (среда SQL Server Management Studio)

  • Как провести миграцию экземпляров служб Notification Services до выпуска с более широкими возможностями (командная строка)

  • Как выполнить миграцию экземпляров служб Notification Services до выпуска с более широкими возможностями (среда SQL Server Management Studio)

  • Как просмотреть сведения о версии служб Notification Services

См. также

Задачи

Как зарегистрировать сборку ядра служб Notification Services для взаимодействия COM

Основные понятия

Миграция экземпляров служб Notification Services
Установка служб SQL Server Notification Services


Как выполнить миграцию экземпляров служб Notification Services 2.0 в SQL Server 2005 (среда SQL Server Management Studio)

Как выполнить миграцию экземпляров служб Notification Services 2.0 в SQL Server 2005 (среда SQL Server Management Studio) |
 | См. также
Обновление компонентов SQL Server > Разделы руководства по обновлению компонентов SQL Server > Разделы руководства по миграции служб Notification Services >

Дата обновления: 14 апреля 2006 г.

Если существует экземпляр служб Notification Services 2.0, запущенный на , можно обновить базы данных и службы Notification Services, а затем выполнить миграцию экземпляра служб Notification Services на .

Следующие процедуры показывают способы обновления экземпляра с помощью среды SQL Server Management Studio.

Важно!
Экземпляры служб Notification Services можно развертывать во многих различных конфигурациях. Используйте приведенную ниже процедуру в качестве рекомендации для выработки собственных методов миграции.

Подготовка серверов к обновлению

  1. Отключите экземпляр служб Notification Services с помощью программы командной строки nscontrol служб Notification Services версии 2.0.

    1. В меню Пуск укажите пункт Programs\Microsoft SQL Server Notification Services и выберите Notification Services Command Prompt.

    2. Чтобы отключить экземпляр, введите следующую команду:

      nscontrol disable -name instance_name

  2. На каждом из серверов, на котором выполняется служба Windows NS$имяЭкземпляра, остановите ее.

    1. В меню Пуск укажите пункт Programs\Microsoft SQL Server Notification Services и выберите Notification Services Command Prompt.

    2. Чтобы остановить экземпляр, введите следующую команду:

      net stop NS$instanceName

  3. На каждом из серверов, имеющем интерфейсы поставщика событий, генератора, распространителя или управления подпиской, отмените регистрацию экземпляра.

    1. Введите в открытом окне командной строки служб Notification Services:

      nscontrol unregister -name instance_name

    2. Закройте окно командной строки.

Обновление версии компонента Database Engine и установка служб Notification Services

  1. При помощи программы установки SQL Server 2005 обновите компонент Database Engine с версии SQL Server 2000 до версии SQL Server 2005. Дополнительные сведения см. в разделе Обновление компонента Database Engine.

  2. На каждом из серверов, имеющем интерфейсы поставщика событий, генератора, распространителя или управления подпиской, установите службы SQL Server 2005 Notification Services.

    Если службы Notification Services и базы данных расположены на одном и том же сервере, можно одновременно обновлять базы данных и устанавливать службы Notification Services.

Миграция экземпляра служб Notification Services

  1. Откройте окно командной строки служб SQL Server 2005 Notification Services и добавьте данные экземпляра в системные базы данных:

    1. В меню Пуск выберите меню Все программы\Microsoft SQL Server 2005\средства настройки, а затем выберите пункт Командная строка Notification Services.

    2. Чтобы восстановить метаданные экземпляра, введите следующую команду:

      nscontrol repair -name instance_name -database instanceDatabaseName -schema instanceDatabaseSchema -server databaseServer

  2. Обновление экземпляра и данных базы данных приложения в среде SQL Server Management Studio:

    1. В меню Пуск укажите пункт Программы\Microsoft SQL Server и выберите среду SQL Server Management Studio.

    2. Подключитесь к экземпляру SQL Server, который содержит экземпляр и прикладную базу данных.

    3. В обозревателе объектов откройте Службы Notification Services.

    4. Правой кнопкой мыши щелкните экземпляр, укажите пункт Задачи и выберите Обновить.

      В результате обновляются схема базы данных, хранимые процедуры и номера версий в базах данных экземпляра и приложений.

  3. Измените правила уведомлений в файле определения приложения (ADF) для каждого из приложений, содержащихся в данном экземпляре.

    • Измените все правила формирования уведомлений, в которых используется функция Notify(), для использования синтаксиса INSERT INTO. Например, изменим правило служб Notification Services 2.0:

      Копировать код
      SELECT dbo.FlightNotificationsNotify(S.SubscriberId,
S.DeviceName, S.SubscriberLocale, E.Carrier, E.LeavingFrom,
E.GoingTo, E.Price, E.Conditions)
    FROM FlightEvents E, FlightSubscriptions S
    WHERE E.LeavingFrom = S.LeavingFrom
    AND E.GoingTo = S.GoingTo
    AND ( (E.Carrier = S.Carrier) OR (S.Carrier = '*') )
    AND E.Price &lt; S.Price
      На следующий синтаксис, который не вызывает функцию Notify(), а выбирает данные и вставляет их в представление, имеющее имя класса уведомления (FlightNotifications):

      Копировать код
      INSERT INTO FlightNotifications(SubscriberId, DeviceName,
SubscriberLocale, Carrier, LeavingFrom, GoingTo, Price,
Conditions)
SELECT S.SubscriberId, S.DeviceName, S.SubscriberLocale,
E.Carrier, E.LeavingFrom, E.GoingTo, E.Price, E.Conditions
    FROM FlightEvents E, FlightSubscriptions S
    WHERE E.LeavingFrom = S.LeavingFrom
    AND E.GoingTo = S.GoingTo
    AND ( (E.Carrier = S.Carrier) OR (S.Carrier = '*') )
    AND E.Price &lt; S.Price
    • Измените номера версий в ADF и ICF. (Необязательно)

    • Если экземпляр был перемещен, измените значения SystemName в ADF и значение SqlServerSystem в ICF. Эти значения могут быть параметрами, указывающими, что значения находятся в узле ParameterDefaults либо указываются при создании экземпляра.

  4. В обозревателе объектов щелкните правой кнопкой мыши экземпляр Notification Services, укажите пункт Задачи и выберите Обновить.

    Введите запрашиваемые данные в диалоговое окно Обновление. Обновление экземпляра и его приложений вызывает применение к базам данных изменений файлов ADF и ICF.

    Убедитесь в том, что выбрано Включить экземпляр после обновления.

  5. На каждом из серверов, где был зарегистрирован экземпляр, зарегистрируйте экземпляр.

    Среда SQL Server Management Studio регистрирует экземпляр только на локальном компьютере. Чтобы зарегистрировать экземпляр в среде SQL Server Management Studio, правой кнопкой мыши щелкните экземпляр, выберите Задачи, а затем выберите пункт Зарегистрировать.

    Если нужно зарегистрировать экземпляр на сервере, на котором среда SQL Server Management Studio не установлена, воспользуйтесь программой командной строки SQL Server 2005 nscontrol register.

  6. Замените все пользовательские компоненты новыми, скомпилированными с использованием сборок SQL Server 2005 и платформы Microsoft .NET Framework 2.0.

  7. Если используется COM-взаимодействие, перерегистрируйте базовую сборку служб Notification Services. Дополнительные сведения см. в разделе Как зарегистрировать сборку ядра служб Notification Services для взаимодействия COM.

  8. В обозревателе объектов щелкните правой кнопкой мыши экземпляр и выберите пункт Пуск.

См. также

Задачи

Миграция экземпляров служб Notification Services 2.0 на SQL Server 2005
Как выполнить миграцию экземпляров служб Notification Services 2.0 на SQL Server 2005 (командная строка)

Другие ресурсы

Разделы руководства по управлению экземплярами и приложениями (службы Notification Services)
Команда nscontrol register


Как выполнить миграцию экземпляров служб Notification Services 2.0 на SQL Server 2005 (командная строка)

Как выполнить миграцию экземпляров служб Notification Services 2.0 на SQL Server 2005 (командная строка) |
 | См. также
Обновление компонентов SQL Server > Разделы руководства по обновлению компонентов SQL Server > Разделы руководства по миграции служб Notification Services >

Дата обновления: 14 апреля 2006 г.

При наличии существующего экземпляра служб Notification Services 2.0, выполняющегося под управлением , его можно обновить до . Для этого необходимо обновить базы данных и экземпляр служб Notification Services. Ниже описано, как обновить экземпляр с помощью программ командной строки.

Важно!
Экземпляры служб Notification Services можно развертывать во многих различных конфигурациях. Используйте приведенную ниже процедуру в качестве рекомендации для выработки собственных методов миграции.

Подготовка серверов к обновлению

  1. На сервере, на котором зарегистрирован экземпляр, отключите экземпляр служб Notification Services при помощи входящей в службы Notification Services 2.0 программы командной строки nscontrol:

    1. В меню Пуск последовательно выберите пункты Все программы, Microsoft SQL Server 2005, Средства настройки и выберите пункт Командная строка служб Notification Services.

    2. Чтобы отключить экземпляр, введите следующую команду:

      nscontrol disable -name instance_name

  2. На каждом из серверов, на котором выполняется служба Windows NS$имяЭкземпляра, остановите ее.

    1. Откройте окно командной строки служб Notification Services 2.0 и введите следующую команду, чтобы остановить экземпляр:

      net stop NS$instanceName

  3. На каждом из серверов, имеющем интерфейсы поставщика событий, генератора, распространителя или управления подпиской, отмените регистрацию экземпляра.

    1. Введите в открытом окне командной строки служб Notification Services:

      nscontrol unregister -name instance_name

    2. Закройте окно командной строки.

Обновление версии ядра СУБД и установка службы Notification Services

  1. При помощи программы установки SQL Server 2005 обновите Database Engine с SQL Server 2000 до SQL Server 2005. Дополнительные сведения см. в разделе Обновление компонента Database Engine.

  2. На каждом из серверов, имеющем интерфейсы поставщика событий, генератора, распространителя или управления подпиской, установите службы SQL Server 2005 Notification Services.

    Если службы Notification Services и базы данных расположены на одном и том же сервере, можно одновременно обновлять базы данных и устанавливать службы Notification Services.

    Установки служб Notification Services 2.0 в процессе обновления остаются неизменными.

Выполнение миграции экземпляра служб Notification Services

  1. На каждом из серверов, где экземпляр был зарегистрирован, зарегистрируйте экземпляр:

    1. В меню Пуск последовательно выберите пункты Все программы, Microsoft SQL Server 2005, Средства настройки и выберите пункт Командная строка служб Notification Services.

    2. Зарегистрируйте экземпляр с помощью команды nscontrol register. Следующая команда показывает, как зарегистрировать экземпляр и создать службу Windows, которая подключается к серверу базы данных с помощью проверки подлинности Windows:

      nscontrol register -name instanceName -server databaseServer -service -serviceusername username -servicepassword password

      Для получения дополнительных сведений введите nscontrol register -? или см. раздел Команда nscontrol register.

  2. Чтобы восстановить метаданные экземпляра, на одном из серверов введите следующую команду:

    nscontrol repair -name instance_name -database instanceDatabaseName -schema instanceDatabaseSchema

  3. Чтобы обновить экземпляр и данные приложений, введите следующую команду:

    nscontrol upgrade -name instanceName

  4. Измените правила уведомлений в файле определения приложения (ADF) для каждого из приложений, содержащихся в данном экземпляре.

    • Измените все правила формирования уведомлений, в которых используется функция Notify(), для использования синтаксиса INSERT INTO. Например, изменим правило служб Notification Services 2.0:

      Копировать код
      SELECT dbo.FlightNotificationsNotify(S.SubscriberId,
S.DeviceName, S.SubscriberLocale, E.Carrier, E.LeavingFrom,
E.GoingTo, E.Price, E.Conditions)
    FROM FlightEvents E, FlightSubscriptions S
    WHERE E.LeavingFrom = S.LeavingFrom
    AND E.GoingTo = S.GoingTo
    AND ( (E.Carrier = S.Carrier) OR (S.Carrier = '*') )
    AND E.Price &lt; S.Price
      На следующий синтаксис, который не вызывает функцию Notify(), а выбирает данные и вставляет их в представление, имеющее имя класса уведомления (FlightNotifications):

      Копировать код
      INSERT INTO FlightNotifications(SubscriberId, DeviceName,
SubscriberLocale, Carrier, LeavingFrom, GoingTo, Price,
Conditions)
SELECT S.SubscriberId, S.DeviceName, S.SubscriberLocale,
E.Carrier, E.LeavingFrom, E.GoingTo, E.Price, E.Conditions
    FROM FlightEvents E, FlightSubscriptions S
    WHERE E.LeavingFrom = S.LeavingFrom
    AND E.GoingTo = S.GoingTo
    AND ( (E.Carrier = S.Carrier) OR (S.Carrier = '*') )
    AND E.Price &lt; S.Price
    • Измените номера версий в ADF и ICF. (Необязательно)

    • Если экземпляр был перемещен, измените значения SystemName в ADF и значение SqlServerSystem в ICF. Эти значения могут быть параметрами, указывающими, что значения находятся в узле ParameterDefaults, либо указываются при создании экземпляра.

  5. Чтобы обновить экземпляр служб Notification Services, введите следующую команду:

    nscontrol update -in ICFPath\ICFName.xml

    Конкретные значения аргументов зависят от режима проверки подлинности.

  6. Чтобы включить экземпляр служб Notification Services, введите следующую команду:

    nscontrol enable -name instanceName

    Конкретные значения аргументов зависят от режима проверки подлинности.

  7. Замените все пользовательские компоненты новыми, скомпилированными с использованием сборок SQL Server 2005 и платформы Microsoft .NET Framework 2.0.

  8. Если используется COM-взаимодействие, перерегистрируйте базовую сборку служб Notification Services. Дополнительные сведения см. в разделе Как зарегистрировать сборку ядра служб Notification Services для взаимодействия COM.

  9. После запуска экземпляра введите следующую команду для каждого сервера, на котором выполняются компоненты ядра служб Notification Services:

    net start NS$instanceName

См. также

Задачи

Миграция экземпляров служб Notification Services 2.0 на SQL Server 2005
Как выполнить миграцию экземпляров служб Notification Services 2.0 в SQL Server 2005 (среда SQL Server Management Studio)

Другие ресурсы

Программа nscontrol


Как выполнить миграцию экземпляров служб Notification Services до выпуска с более широкими возможностями (среда SQL Server Management Studio)

Как выполнить миграцию экземпляров служб Notification Services до выпуска с более широкими возможностями (среда SQL Server Management Studio) |
 | См. также
Обновление компонентов SQL Server > Разделы руководства по обновлению компонентов SQL Server > Разделы руководства по миграции служб Notification Services >

Если экземпляр служб Notification Services создается с помощью младшего выпуска Microsoft SQL Server 2005, такого как выпуск Standard Edition, а позже необходимо выполнить обновление до выпуска SQL Server с более широкими возможностями, такого как выпуск Enterprise Edition, нужно обновить экземпляр служб Notification Services до выпуска с более широкими возможностями. Следующие действия показывают, как осуществить миграцию экземпляра служб Notification Services до выпуска с более широкими возможностями в среде SQL Server Management Studio.

Важно!
Экземпляры служб Notification Services можно развертывать во многих различных конфигурациях. Используйте приведенную ниже процедуру в качестве рекомендации для выработки собственных методов миграции.

Обновление службы Notification Services до выпуска с более широкими возможностями

  1. В обозревателе объектов среды SQL Server Management Studio раскройте Службы Notification Services.

  2. Щелкните правой кнопкой мыши экземпляр и выберите пункт Отключить.

  3. Щелкните правой кнопкой мыши экземпляр, для которого необходимо выполнить миграцию, и выберите пункт Остановить.

  4. Закройте среду SQL Server Management Studio и все остальные открытые приложения.

  5. На каждом сервере, где установлен экземпляр служб Notification Services, используйте программу установки для обновления Notification Services до выпуска с более широкими возможностями.

  6. В обозревателе объектов среды SQL Server Management Studio раскройте Службы Notification Services.

  7. В обозревателе объектов щелкните правой кнопкой мыши экземпляр, наведите курсор на пункт Задачи, а затем выберите пункт Усовершенствование. Таким образом будет проведено обновление версий и выпусков экземпляра и баз данных приложений до более старших.

  8. Щелкните правой кнопкой мыши экземпляр и выберите пункт Обновить.

    Введите запрашиваемые данные в диалоговое окно Обновление.

    Убедитесь в том, что выбрано Включить экземпляр после обновления.

  9. Щелкните правой кнопкой мыши на экземпляре и выберите пункт Запустить.

См. также

Задачи

Миграция экземпляров служб Notification Services до выпуска SQL Server 2005 с более широкими возможностями
Как провести миграцию экземпляров служб Notification Services до выпуска с более широкими возможностями (командная строка)

Другие ресурсы

Программа nscontrol


Как провести миграцию экземпляров служб Notification Services до выпуска с более широкими возможностями (командная строка)

Как провести миграцию экземпляров служб Notification Services до выпуска с более широкими возможностями (командная строка) |
 | См. также
Обновление компонентов SQL Server > Разделы руководства по обновлению компонентов SQL Server > Разделы руководства по миграции служб Notification Services >

Если экземпляр служб Notification Services создан с помощью младшего выпуска Microsoft SQL Server 2005, например Standard Edition, и впоследствии потребовалось обновить его до выпуска SQL Server с более широкими возможностями, например до Enterprise Edition, потребуется провести миграцию экземпляра Notification Services для обеспечения соответствия серверу базы данных. Приведенная ниже процедура показывает миграцию экземпляра служб Notification Services на выпуск с более широкими возможностями с помощью программ командной строки.

Важно!
Экземпляры служб Notification Services можно развертывать во многих различных конфигурациях. Используйте приведенную ниже процедуру в качестве рекомендации для выработки собственных методов миграции.

Обновление служб Notification Services до выпуска с более широкими возможностями

  1. Отключите экземпляр на сервере, где зарегистрирована база данных:

    1. В меню Пуск выберите меню Программы\Microsoft SQL Server 2005\Средства настройки, а затем пункт Командная строка Notification Services.

    2. Чтобы отключить экземпляр, введите следующую команду:

      nscontrol disable -имя instanceName

  2. На каждом сервере, на котором выполняется экземпляр, введите в командной строке следующую команду для его остановки:

    net stop ns$instanceName

    Если компоненты ядра находятся в приложении, убедитесь, что экземпляр не запущен.

  3. На каждом сервере, где установлен экземпляр служб Notification Services, обновите его до выпуска с более широкими возможностями.

  4. На сервере введите следующую команду для обновления метаданных в базах данных:

    nscontrol upgrade -имя instanceName -сервер databaseServer

    Аргументы зависят от настройки системы безопасности.

  5. На сервере введите следующую команду для обновления метаданных в базах данных:

    nscontrol update -in ICFPath\ICFName.xml

    Аргументы зависят от настройки системы безопасности.

  6. На всех серверах, где запущена служба Windows NS$instanceName, введите для запуска службы следующую команду:

    net start NS$instanceName

    Если компоненты ядра расположены в приложении, запустите экземпляр.

  7. На одном сервере для включения экземпляра введите следующую команду:

    nscontrol disable -имя instanceName

См. также

Задачи

Миграция экземпляров служб Notification Services до выпуска SQL Server 2005 с более широкими возможностями
Как выполнить миграцию экземпляров служб Notification Services до выпуска с более широкими возможностями (среда SQL Server Management Studio)

Другие ресурсы

Программа nscontrol


Как просмотреть сведения о версии служб Notification Services

Как просмотреть сведения о версии служб Notification Services |
 | См. также
Обновление компонентов SQL Server > Разделы руководства по обновлению компонентов SQL Server > Разделы руководства по миграции служб Notification Services >

Службы Notification Services хранят версию и выпуск Notification Services, используемых для создания или обновления экземпляра, в базе данных экземпляра, а также хранят версию, используемую для регистрации экземпляра в реестре Microsoft Windows. При миграции экземпляра служб Notification Services эти сведения обновляются.

Если версия в реестре Microsoft Windows и версия экземпляра базы данных не совпадают, экземпляр Notification Services не запустится. Если имеются проблемы с запуском экземпляра после миграции, проверьте сведения о версии и выпуске, используя процедуру, описанную ниже.

Процедуры

Просмотр версии продукта и реестра

  • В обозревателе объектов щелкните правой кнопкой мыши службы Notification Services и выберите пункт Версии.

    Диалоговое окно Версии показывает только экземпляры, которые регистрируются локально. Номер версии экземпляра является версией в записи реестра для экземпляра.
Примечание.
На серверах, где не установлена среда SQL Server Management Studio (Microsoft), запустите программу nscontrol listversions из командной строки служб Notification Services.

 Просмотр версии базы данных

  1. В среде SQL Server Management Studio нажмите кнопку Создать запрос и выберите пункт Запрос к ядру СУБД.

  2. В окне «Запрос ядра СУБД» запустите следующий запрос, заменив instanceDatabase именем экземпляра базы данных, а также заменив instanceSchema именем схемы экземпляра.

    Копировать код
    USE [instanceDatabase];
SELECT Top(1) *
FROM [instanceDatabase].[instanceSchema].[NSVersionInfo]
ORDER BY [VersionId] DESC;

См. также

Другие ресурсы

Команда nscontrol listversions
Просмотр состояния экземпляров, приложений и компонентов
@@VERSION (Transact-SQL)


Обратная совместимость

Обратная совместимость |
 | См. также
Обновление до SQL Server 2005 >

В следующих разделах содержатся сведения об обратной совместимости для компонентов . Содержимое этих разделов включает сведения об устаревших и больше не поддерживаемых возможностях, критических изменениях и изменениях в поведении.

В этом разделе

Раздел | Описание
Обратная совместимость компонента SQL Server 2005 Database Engine | Содержит подразделы, где описаны изменения в Database Engine для , которые могут потребовать внесения изменений в приложения.
Обратная совместимость служб SQL Server 2005 Analysis Services | Содержит подразделы, описывающие изменения в службах SSAS для SQL Server 2005, которые могут потребовать внесения изменений в приложения.
Обратная совместимость служб SQL Server 2005 Integration Services | Описывает изменения в службах SSIS для SQL Server 2005, которые могут потребовать внесения изменений в существующие приложения служб DTS.
Обратная совместимость служб Notification Services | Описывает изменения в службах Notification Services для SQL Server 2005, которые могут потребовать внесения изменений в существующие приложения Notification Services 2.0.
Обратная совместимость служб Reporting Services | Содержит подразделы, которые описывают изменения в службах SSRS для SQL Server 2005, которые могут потребовать внесения изменений в существующие решения Reporting Services.
Обратная совместимость репликации | Содержит подразделы, описывающие изменения в Database Engine для SQL Server 2005, которые могут потребовать внесения изменений в существующие решения репликации.

См. также

Другие ресурсы

Обновление компонентов SQL Server
Установка компонентов SQL Server 2005


Обратная совместимость компонента SQL Server 2005 Database Engine

Обратная совместимость компонента SQL Server 2005 Database Engine |
 | См. также
Обновление до SQL Server 2005 > Обратная совместимость >

Подразделы в разделе по обратной совместимости описывают изменения в поведении разных версий .

См. в... | Подразделы о...
Неподдерживаемые функции ядра СУБД в SQL Server 2005 | Функции Database Engine, неподдерживаемые в этом выпуске.
Устаревшие функции ядра СУБД в SQL Server 2005 | Функции Database Engine, устаревшие в этом выпуске.
Критические изменения в функциях ядра СУБД SQL Server 2005 | Изменения функциональных возможностей Database Engine, которые могут потребовать изменений в приложениях.
Изменения в работе функций ядра СУБД в SQL Server 2005 | Другие изменения в поведении функциональных возможностей баз данных в этом выпуске.

См. также

Справочник

Обновления версий и выпусков
Возможности, поддерживаемые различными выпусками SQL Server 2005

Другие ресурсы

sp_dbcmptlevel (Transact-SQL)


Устаревшие функции ядра СУБД в SQL Server 2005

Устаревшие функции ядра СУБД в SQL Server 2005
Обновление до SQL Server 2005 > Обратная совместимость > Обратная совместимость компонента SQL Server 2005 Database Engine >

Дата обновления: 12 декабря 2006 г.

К устаревшим функциям относятся те функции, которые не будут поддерживаться в следующей версии SQL Server, и функции, которые не будут поддерживаться в будущих версиях SQL Server.

Функции, не поддерживаемые в следующей версии SQL Server

Эти функции компонента Database Engine не будут поддерживаться в следующей версии SQL Server. Рекомендуется со временем по возможности заменить эти функции другими.

Категория | Устаревшая функция | Замена
Резервное копирование и восстановление | Инструкция DUMP | BACKUP
Резервное копирование и восстановление | Инструкция LOAD | RESTORE
Резервное копирование и восстановление | BACKUP LOG WITH NO_LOG | Нет Журнал транзакций автоматически усекается, если база данных использует простую модель восстановления. При необходимости удаления цепочки резервных копий журнала из базы данных переключитесь на простую модель восстановления.
Резервное копирование и восстановление | BACKUP LOG WITH TRUNCATE_ONLY | Нет Журнал транзакций автоматически усекается, если база данных использует простую модель восстановления. При необходимости удаления цепочки резервных копий журнала из базы данных переключитесь на простую модель восстановления.
Резервное копирование и восстановление | BACKUP TRANSACTION | BACKUP LOG
Резервное копирование и восстановление | BACKUP { DATABASE | LOG } WITH PASSWORD | Нет
Резервное копирование и восстановление | BACKUP { DATABASE | LOG } WITH MEDIAPASSWORD | Нет
Резервное копирование и восстановление | RESTORE { DATABASE | LOG } … WITH DBO_ONLY | RESTORE { DATABASE | LOG } … … WITH RESTRICTED_USER
Резервное копирование и восстановление | RESTORE { DATABASE | LOG } WITH PASSWORD | Нет
Резервное копирование и восстановление | RESTORE { DATABASE | LOG } WITH MEDIAPASSWORD | Нет
Уровни совместимости | Уровни совместимости 60 и 65 | Нет
Уровни совместимости | Уровень совместимости 70 | Нет
DBCC | DBCC CONCURRENCYVIOLATION | Нет
Программирование расширенных хранимых процедур | srv_getuserdata srv_setuserdata | Вместо этого используйте интеграцию со средой CLR.
Полнотекстовый поиск | Значения действий clean_up, connect_timeout и data_timeout процедуры sp_fulltext_service возвращают нуль. | Нет
Параметры экземпляра | SET REMOTE_PROC_TRANSACTIONS sp_configure 'remote proc trans' | Используйте связанные серверы и распределенные запросы. sp_addlinkedserver
Удаленные серверы | Используются удаленные серверы sp_addserver для создания удаленных серверов | Используются связанные серверы sp_addlinkedserver для создания связанных серверов
Безопасность | sp_addalias sp_dropalias sp_addgroup sp_changegroup sp_dropgroup sp_helpgroup | Замещены ролями
Безопасность | SETUSER | EXECUTE AS
Системные таблицы | syssegments | Нет

Функции, не поддерживаемые в будущих версиях SQL Server

Поддержка этих функций компонента Database Engine в следующей версии SQL Server будет сохранена, однако они будут удалены в более поздних версиях (с какой именно версии SQL Server, пока неизвестно).

Категория Устаревшая функция Замена

Резервное копирование и восстановление

sp_helpdevice

sys.backup_devices

Параметры сортировки

Hindi

Lithuanian_Classic

SQL_AltDiction_CP1253_CS_AS

Нет

Эти параметры сортировки существуют в Microsoft SQL Server 2005, но их нельзя увидеть с помощью функции fn_helpcollations.

Уровень совместимости

Уровень совместимости 80

Нет

Дополнительные сведения об уровнях совместимости см. в разделе sp_dbcmptlevel (Transact-SQL).

Типы данных

sp_addtype

CREATE TYPE

Типы данных

синтаксис timestamp для типа данных rowversion

синтаксис типа данных rowversion.

Управление базами данных

sp_attach_db

sp_attach_single_file_db

Инструкция CREATE DATABASE с параметром FOR ATTACH используется для перестроения нескольких файлов журналов. Если один или более из них находятся в новом месте, используйте параметр FOR ATTACH_REBUILD_LOG.

Объекты базы данных

CREATE DEFAULT

DROP DEFAULT

sp_bindefault

sp_unbindefault

Ключевое слово DEFAULT в инструкциях CREATE TABLE и ALTER TABLE.

Объекты базы данных

CREATE RULE

DROP RULE

sp_bindrule

sp_unbindrule

Ключевое слово CHECK в инструкциях CREATE TABLE и ALTER TABLE.

Объекты базы данных

sp_renamedb

MODIFY NAME в инструкции ALTER DATABASE.

Объекты базы данных

Возможность возвращать результирующие наборы из триггеров

Нет

Параметры базы данных

«Конкатенация значений NULL дает NULL» процедуры sp_dboption.

Нет

Параметры базы данных

sp_dboption

sp_resetstatus

ALTER DATABASE SET { ONLINE | EMERGENCY }

Параметры базы данных

параметр TORN_PAGE_DETECTION инструкции ALTER DATABASE

параметр PAGE_VERIFY TORN_PAGE DETECTION инструкции ALTER DATABASE

DBCC

DBCC DBREINDEX

параметр REBUILD инструкции ALTER INDEX.

DBCC

DBCC INDEXDEFRAG

параметр REORGANIZE инструкции ALTER INDEX

DBCC

DBCC SHOWCONTIG

sys.dm_db_index_physical_stats

Расширенные свойства

Level0type = "type" и Level0type = "USER" для добавления расширенных свойств к объектам типа level-1 или level-2.

Используйте Level0type = «USER» только для добавления расширенного свойства напрямую роли или пользователю.

Используйте Level0type = «SCHEMA» для добавления расширенного свойства к типам level-1, таким как TABLE или VIEW, или типам level-2, таким как COLUMN или TRIGGER. Дополнительные сведения см. в разделе sp_addextendedproperty (Transact-SQL).

Программирование расширенных хранимых процедур

srv_alloc

srv_convert

srv_describe

srv_getbindtoken

srv_got_attention

srv_message_handler

srv_paramdata

srv_paraminfo

srv_paramlen

srv_parammaxlen

srv_paramname

srv_paramnumber

srv_paramset

srv_paramsetoutput

srv_paramtype

srv_pfield

srv_pfieldex

srv_rpcdb

srv_rpcname

srv_rpcnumber

srv_rpcoptions

srv_rpcowner

srv_rpcparams

srv_senddone

srv_sendmsg

srv_sendrow

srv_setcoldata

srv_setcollen

srv_setutype

srv_willconvert

srv_wsendmsg

Вместо этого используйте интеграцию со средой CLR.

Программирование расширенных хранимых процедур

sp_addextendedproc

sp_dropextendedproc

sp_helpextendedproc

Вместо этого используйте интеграцию со средой CLR.

Расширенные хранимые процедуры

xp_LoginConfig

аргумент IsIntegratedSecurityOnly процедуры SERVERPROPERTY

Полнотекстовый поиск

sp_fulltext_catalog

CREATE/ALTER/DROP FULLTEXT CATALOG

Полнотекстовый поиск

sp_fulltext_table

sp_fulltext_column

sp_fulltext_database

CREATE/ALTER/DROP FULLTEXT INDEX

ALTER FULLTEXT INDEX

Полнотекстовый поиск

sp_help_fulltext_tables[_cursor]

sp_help_fulltext_columns[_cursor]

sp_help_fulltext_catalogs[_cursor]

sys.fulltext_indexes

sys.fulltext_index_columns

sys.fulltext_catalogs

Функции

fn_get_sql

sys.dm_exec_sql_text

Параметры индекса

sp_indexoption

fillfactor = 0

ALTER INDEX

fillfactor = 100

Параметры индекса

Синтаксис CREATE INDEX <index_option>::=

Синтаксис CREATE INDEX <relational_index_option>::=

Параметры экземпляра

Значением по умолчанию параметра disallow results from triggers является 0.

Значением по умолчанию параметра disallow results from triggers является 1.

Блокирование

sp_lock

sys.syslock_information

Блокирование

syslockinfo

sys.syslock_information

Метаданные

DATABASEPROPERTY

FILE_ID

INDEXKEY_PROPERTY

DATABASEPROPERTYEX

FILE_IDEX

sys.index_columns

Прочее

DB-Library

Встроенный SQL для языка C

Хотя SQL Server 2005 Database Engine до сих пор поддерживает соединения из существующих приложений, использующих API DB-Library и Embedded SQL, файлы или документация, необходимые для разработки приложений с использованием этих API, не предоставляются. В будущей версии компонента SQL Server Database Engine не будут поддерживаться соединения из приложений, использующих DB-Library или Embedded SQL. Не используйте DB-Library или Embedded SQL для разработки новых приложений. Удалите все зависимости от DB-Library или Embedded SQL при модификации существующих приложений. Используйте вместо этих API-интерфейсов пространство имен SQLClient или такой API-интерфейс как OLE DB или ODBC. В состав SQL Server 2005 не входит DLL-библиотека DB-Library, необходимая для запуска этих приложений. Для запуска приложений DB-Library или Embedded SQL необходимо иметь доступ к DLL-библиотеке DB-Library для SQL Server версии 6.5 7.0 или SQL Server 2000.

Подсказки в запросах

Подсказка FASTFIRSTROW

OPTION (FAST n).

Удаляемые базы данных

sp_certify_removable

sp_create_removable

sp_detach_db

Удаляемые базы данных

sp_dbremove

DROP DATABASE

Безопасность

sp_addapprole

sp_dropapprole

CREATE APPLICATION ROLE

DROP APPLICATION ROLE

Безопасность

sp_addlogin

sp_droplogin

CREATE LOGIN

DROP LOGIN

Безопасность

sp_adduser

sp_dropuser

CREATE USER

DROP USER

Безопасность

sp_grantdbaccess

sp_revokedbaccess

CREATE USER

DROP USER

Безопасность

sp_addrole

sp_droprole

CREATE ROLE

DROP ROLE

Безопасность

sp_approlepassword

sp_password

ALTER APPLICATION ROLE

ALTER LOGIN

Безопасность

sp_changeobjectowner

ALTER SCHEMA или ALTER AUTHORIZATION

Безопасность

sp_defaultdb

sp_defaultlanguage

ALTER LOGIN

Безопасность

sp_denylogin

sp_grantlogin

sp_revokelogin

ALTER LOGIN DISABLE

CREATE LOGIN

DROP LOGIN

Безопасность

USER_ID

FILE_ID

DATABASE_PRINCIPAL_ID

FILE_IDEX

Безопасность

sp_srvrolepermission

sp_dbfixedrolepermission

Эти хранимые процедуры возвращают данные, которые были верны в SQL Server 2000. Выход не отражает изменений в иерархии разрешений, реализованной в SQL Server 2005. Дополнительные сведения см. в разделе «Разрешения фиксированных ролей» электронной документации по SQL Server 2005.

Параметры SET

SET ANSI_NULLS

SET ANSI_PADDING

SET CONCAT_NULL_YIELDS_NULL

Нет

Параметры SET

SET OFFSETS

Нет

Параметры SET

SET ROWCOUNT для инструкций INSERT, UPDATE и DELETE

Ключевое слово TOP.

Системные таблицы

sysaltfiles

syscacheobjects

syscolumns

syscomments

sysconfigures

sysconstraints

syscurconfigs

sysdatabases

sysdepends

sysdevices

sysfilegroups

sysfiles

sysforeignkeys

sysfulltextcatalogs

sysindexes

sysindexkeys

syslockinfo

syslogins

sysmembers

sysmessages

sysobjects

sysoledbusers

sysopentapes

sysperfinfo

syspermissions

sysprocesses

sysprotects

sysreferences

sysremotelogins

sysservers

systypes

sysusers

Представления совместимости. Дополнительные сведения см. в разделе Представления совместимости (Transact-SQL).

Важно!
Представления совместимости не показывают метаданные для новых функций SQL Server 2005. Рекомендуется внести изменения в приложения, чтобы они использовали представления каталога. Дополнительные сведения см. в разделе Представления каталога (Transact-SQL).

Табличные подсказки

Указание NOLOCK и READUNCOMMITTED в предложении FROM инструкций UPDATE и DELETE в применении к целевой таблице инструкции.

Удалите табличные подсказки NOLOCK и READUNCOMMITTED из предложения FROM.

Текстовые указатели

READTEXT, WRITETEXT, UPDATETEXT

Нет

Текстовые указатели

Параметр таблицы «text in row»

Используйте типы данных varchar(max), nvarchar(max) и varbinary(max). Дополнительные сведения см. в разделе sp_tableoption (Transact-SQL).

Текстовые указатели

Типы данных TEXT, NTEXT и IMAGE

Используйте типы данных varchar(max), nvarchar(max) и varbinary(max).

Текстовые указатели

TEXTPTR(), TEXTVALID()

Нет

Transact-SQL

:: последовательность вызова функций

Заменено инструкцией SELECT column_list FROM sys.fn_function_name()

Transact-SQL

Ссылки на столбец из 3-х и 4-х частей в списке SELECT

Использование имен из 2 частей совместимо со стандартом.

Transact-SQL

Строка, заключенная в скобки, использовалась как псевдоним столбца для выражения в списке SELECT:

'string_alias' = expression

expression [AS] column_alias

expression [AS] [column_alias]

expression [AS] [column_alias]

expression [AS] [column_alias]

column_alias = expression

Transact-SQL

Количество хранимых процедур

sys.numbered_procedures

sys.numbered_procedure_parameters

Нет

Transact-SQL

Синтаксис table_name.index_name в инструкции DROP INDEX

Синтаксис index_name ON table_name в инструкции DROP INDEX.

Transact-SQL

UPDATE table1, table2, ... синтаксис SET

Указание более чем одной таблицы в инструкции UPDATE не соответствует стандарту и приводит к неоднозначности.

Журнал изменений

Версия Журнал

12 декабря 2006 г.

Измененное содержимое
  • Из таблицы возможностей, которые не будут поддерживаться в будущих версиях SQL Server, удалены таблицы syslanguages и syscharsets.

17 июля 2006 г.

Новое содержимое:
  • Добавлена таблица syssegments в таблицу возможностей, которые не поддерживаются в следующей версии SQL Server.


Неподдерживаемые функции ядра СУБД в SQL Server 2005

Неподдерживаемые функции ядра СУБД в SQL Server 2005
Обновление до SQL Server 2005 > Обратная совместимость > Обратная совместимость компонента SQL Server 2005 Database Engine >

Дата обновления: 5 декабря 2005 г.

Эти возможности Database Engine предыдущих версий SQL Server не поддерживаются в SQL Server 2005.

Категория Неподдерживаемая возможность Замена

Резервное копирование и восстановление

Именованные канальные устройства резервного копирования.

Дисковые или ленточные устройства.

В целях безопасности SQL Server больше не поддерживает резервное копирование на именованные канальные устройства.

Программы командной строки

Программа isql.

Использование программы sqlcmd.

Примечание.
Программы sqlcmd и osql не поддерживают передачу возвращаемых хранимыми процедурами значений выходным значениям.

Дополнительные сведения см. в разделе Программа sqlcmd.

Параметры конфигурации

Параметр "allow updates" процедуры sp_configure.

Параметр присутствует, но прямые обновления системных таблиц не поддерживаются.

Параметры конфигурации

Параметр "open objects" процедуры sp_configure.

Параметр представлен, но его функциональность отключена. В SQL Server 2005 количество открытых объектов базы данных управляется динамически и ограничено только объемом доступной памяти. Параметр «open objects» сохранен в sp_configure для обеспечения обратной совместимости с существующими сценариями.

Параметры конфигурации

Параметр «set working set size» процедуры sp_configure

Параметр имеется, но его функциональность отключена.

Создание базы данных

DISK INIT

DISK RESIZE

Поведение прежних версий SQL Server 6.x.

Создание базы данных

Параметр FOR LOAD инструкции CREATE DATABASE.

Операции RESTORE могут создать базу данных.

DBCC

DBCC DBREPAIR

Для удаления поврежденной базы данных используйте инструкцию DROP DATABASE.

Дополнительные сведения см. в разделе DROP DATABASE (Transact-SQL).

DBCC

DBCC NEWALLOC

DBCC CHECKALLOC

Дополнительные сведения см. в разделе DBCC (Transact-SQL).

DBCC

DBCC PINTABLE, DBCC UNPINTABLE

Нет.

DBCC

DBCC ROWLOCK

Блокировка на уровне строк выполняется автоматически.

DBCC

DBCC TEXTALL

DBCC TEXTALLOC

DBCC CHECKDB

DBCC CHECKTABLE

Программирование расширенной хранимой процедуры

Использование поля SRV_PWD в структуре SRV_PFIELD в случае переключения контекста олицетворения первоначального имени входа.

Нет.

Сетевые протоколы

Следующие протоколы: NWLink IPX/SPX, AppleTalk, Banyan Vines, Multiprotocol.

Настройте приложение и экземпляры ядра СУБД на использование одного из поддерживаемых протоколов: сокеты TCP/IP, именованные каналы, VIA или общая память.

Дополнительные сведения см. в разделе Выбор сетевого протокола.

Перестроение базы данных master

Rebuildm.exe

Используйте параметр REBUILDDATABASE в программе Setup.exe.

Дополнительные сведения см. в разделе Как установить SQL Server 2005 из командной строки.

Образцы баз данных

Northwind и pubs

Используйте AdventureWorks, однако Northwind и pubs доступны для загрузки или могут быть скопированы из предыдущей установки SQL Server.

Дополнительные сведения см. в разделе Образцы кода и баз данных.

Setup.exe

Параметр программы удаленной установки TARGETCOMPUTER не поддерживается.

Используйте удаленное соединение для запуска программы установки SQL Server из режима пользовательского интерфейса или из командной строки.

Интерфейсы API

Основанный на SQL-DMO поставщик инструментария WMI.

Управляемый код: Microsoft.SqlServer.Management.Smo.Wmi.

Неуправляемый код: WMI Provider for Configuration Management.

Интерфейсы API

API-интерфейс пространства имен SQL (SQL-NS).

Нет.

Transact-SQL

Операторы внешнего соединения *= и =*.

Используйте синтаксис JOIN в предложении FROM.

Дополнительные сведения см. в разделе FROM (Transact-SQL).

Виртуальные таблицы

syslocks

sys.dm_tran_locks

Дополнительные сведения см. в разделе sys.dm_tran_locks.


Критические изменения в функциях ядра СУБД SQL Server 2005

Критические изменения в функциях ядра СУБД SQL Server 2005 |
 | См. также
Обновление до SQL Server 2005 > Обратная совместимость > Обратная совместимость компонента SQL Server 2005 Database Engine >

Дата обновления: 14 апреля 2006 г.

В этом разделе описаны изменения, внесенные в Database Engine , которые могут повлечь за собой сбой в работе приложений, основанных на более ранних версиях SQL Server.

Соединение клиента с сервером

Функция Описание

Сетевые протоколы Banyan VINES Sequenced Packet Protocol (SPP), Multiprotocol, AppleTalk или NWLink IPX/SPX

SQL Server 2005 не поддерживает сетевые протоколы Banyan VINES Sequenced Packet Protocol (SPP), Multiprotocol, AppleTalk и NWLink IPX/SPX. Чтобы подключиться к SQL Server 2005, клиентские приложения должны использовать поддерживаемый протокол. Если установлен псевдоним, использующий один из неподдерживаемых протоколов, то необходимо изменить псевдоним для использования одного из поддерживаемых протоколов.

Если строка соединения приложения явно использует или загружает неподдерживаемые протоколы, указывая NETWORK=DBMSRPCN — для RPC, NETWORK=DBMSADSN — для Appletalk или NETWORK=DBMSVINN — для Banyan VINES или явно указывает префиксы, например spx:server\instance — для SPX, bv:server — для Banyan VINES, adsp:server — для AppleTalk или rpc:server — для multiprotocol, то необходимо изменить приложение таким образом, чтобы оно использовало для соединения только поддерживаемые протоколы.

Дополнительные сведения см. в разделе Выбор сетевого протокола.

Компоненты MDAC

Компоненты MDAC версии ранее 2.6 не поддерживают именованные экземпляры. Для обеспечения возможности подключения приложений к именованным экземплярам обновите текущую версию компонентов MDAC.

Прокси-сервер Winsock

Прокси-сервер Winsock не может быть настроен средствами SQL Server. Дополнительные сведения о настройке прокси-сервера Winsock см. в документации прокси-сервера.

Параметры конфигурации

Функция Описание

AUTO_UPDATE_STATISTICS

Установите значение ON параметра AUTO_UPDATE_STATISTICS до начала обновления любых баз данных. В противном случае статистика базы данных не обновится в ходе обновления SQL Server 2005. Использование статистики от более ранней версии SQL Server может привести к созданию неоптимальных планов запросов. При установке значения ON параметра AUTO_UPDATE_STATISTICS вся статистика будет обновлена при первом обращении к ней. Обновление статистики увеличивает возможность выбора наиболее оптимального плана запросов при выполнении запроса.

Примечание.
В некоторых случаях после установки значения ON для параметра AUTO_UPDATE_STATISTICS процесс обновления статистики может повлиять на производительность выполнения запросов сервером при первом обращении к статистике.

Чтобы установить параметр SET базы данных AUTO_UPDATE_STATISTICS в значение ON, используйте инструкцию ALTER DATABASE или выполните хранимую процедуру sp_updatestats, чтобы обновить статистику базы данных.

параметр max server memory

В SQL Server 2000 буферный пул SQL Server может превысить предел, заданный параметром max server memory, если доступна системная физическая память. В SQL Server 2005 буферный пул не может превысить предел, заданный параметром max server memory. Когда этот предел будет достигнут, запросы будут завершаться с ошибкой «Недостаточно системной памяти».

Если выдается это сообщение об ошибке и установлен параметр max server memory, то следует увеличить значение этого параметра или указать значение по умолчанию, равное 2147483647. Дополнительные сведения см. в разделе Параметры памяти сервера.

Параметр query governor cost limit

Применение инструкции SET GOVERNOR_QUERY_COST_LIMIT или указание параметра query governor cost limit хранимой процедуры sp_configure может привести к тому, что запросы, которые выполнялись в более ранних версиях SQL Server, не будут выполняться в SQL Server 2005. Это вызвано изменениями в моделировании стоимости запроса.

Измените настройки предельного значения стоимости регулятора запросов для соединения или экземпляр сервера до необходимого значения или установите значение 0, чтобы задать неограниченный срок выполнения запроса.

Базы данных, файлы данных и журналов

Функция Описание

Сжатые диски

SQL Server 2005 не может создавать или обновлять базы данных на сжатых дисках. При установке SQL Server 2005 выберите несжатый диск для системных баз данных, а также убедитесь, что обновляемые базы данных не находятся на сжатых дисках. Однако обратите внимание, что после обновления базы данных можно записывать на диск со сжатой файловой системой NTFS базы данных и вторичные файловые группы, доступные только для чтения.

Файлы данных

Файлам данных требуется дополнительное место на диске в связи со следующими изменениями:

  • В файловой группе PRIMARY каждой пользовательской базы данных создаются и поддерживаются дополнительные системные метаданные для объектов базы данных и разрешений пользователей. Например, в более ранних версиях SQL Server разрешения, связанные с объектами, предоставляющими или получающими разрешения, хранились в одной строке в виде битовой карты. В SQL Server 2005 битовая карта расширена до нескольких строк.

  • Столбцы больших объектов (LOB), определенные как данные типа text, ntext или image, дополнительно требуют 40 байт места на диске на каждый столбец. Это единовременное увеличение занимаемого места происходит при первом обновлении каждого столбца LOB.

  • Вместо полнотекстового каталога в файле данных сохраняется полнотекстовая схема идентификаторов документов.

Чтобы убедиться в том, что ресурсы позволяют справиться с увеличением размеров при обновлении и последующих рабочих операциях, рекомендуется установить для параметра «Авторасширение» значение ON для всех файлов данных пользователей перед началом обновления до SQL Server 2005. После окончания обновления и тестирования под нагрузкой можно установить для параметра «Авторасширение» значение OFF или соответственно скорректировать значение приращения FILEGROWTH. Дополнительные сведения см. в разделе ALTER DATABASE (Transact-SQL).

Режим совместимости базы данных

При обновлении базы данных до SQL Server 2005 с любой более ранней версии SQL Server база данных сохраняет свой существующий уровень совместимости. Если после обновления базы данных установить уровень совместимости 90, то различия в уровне совместимости могут повлиять на приложения. Дополнительные сведения об этих различиях см. в разделе sp_dbcmptlevel (Transact-SQL).

Идентификатор базы данных 32767

В SQL Server 2005 этот идентификатор баз данных зарезервирован. Отсоедините базу данных до начала обновления.

Файловые группы

Все базы данных в экземпляре SQL Server должны иметь значение READ_WRITE для файловых групп до начала обновления до SQL Server 2005. Чтобы установить значение READ_WRITE для файловых групп, используйте инструкцию ALTER DATABASE.

Файлы журналов

В SQL Server 2005 необходимо дополнительное место на диске для файлов журналов транзакций. В ходе стадии отката при восстановлении после сбоя SQL Server 2005 позволяет пользователям получить доступ к базе данных. Это возможно потому, что транзакции, не зафиксированные на момент возникновения сбоя, повторно получают все блокировки, которыми они владели перед сбоем. При откате транзакций их блокировки помогают защитить эти транзакции от вмешательства пользователей. Эти дополнительные данные о блокировках должны сохраняться в журнале транзакций.

Чтобы убедиться в том, что ресурсы позволяют справиться с увеличением размеров при обновлении и последующих рабочих операциях, рекомендуется установить для параметра «Авторасширение» значение ON для всех файлов журнала пользователей перед началом обновления до SQL Server 2005. После окончания обновления и тестирования под нагрузкой можно установить для параметра «Авторасширение» значение OFF или соответственно скорректировать значение приращения FILEGROWTH. Дополнительные сведения см. в разделе ALTER DATABASE (Transact-SQL).

База данных model

В SQL Server 2005 база данных model претерпела следующие изменения:

  • Увеличен минимальный размер.

  • Уровень совместимости установлен в 90.

  • Параметру базы данных PAGE_VERIFY присвоено значение CHECKSUM.

База данных tempdb

В SQL Server 2005 для файлов данных и журналов tempdb требуется дополнительное место на диске. Чтобы убедиться в том, что ресурсы позволяют справиться с увеличением размеров при обновлении и последующих рабочих операциях, рекомендуется установить для параметра «Авторасширение» значение ON для всех файлов данных и журналов tempdb перед началом обновления до SQL Server 2005. После окончания обновления и тестирования под нагрузкой можно установить для параметра «Авторасширение» значение OFF или соответственно скорректировать значение приращения FILEGROWTH.

Дополнительные сведения см. в разделе Устранение неполадок, связанных с нехваткой места на диске для базы данных tempdb.

Возможности

Функция Описание

Расширенные хранимые процедуры

Расширенные хранимые процедуры, ранее зарегистрированные без указания полного пути к DLL, могут не работать после обновления до SQL Server 2005. Это происходит потому, что прежний каталог BINN в процессе обновления не добавляется к новому пути. SQL Server может не найти расширенные хранимые процедуры.

Перед началом обновления до SQL Server 2005 выполните следующие шаги для каждой расширенной хранимой процедуры, не зарегистрированной с использованием полного пути:

  1. Чтобы удалить расширенную хранимую процедуру, выполните хранимую процедуру sp_dropextendedproc.

  2. Чтобы зарегистрировать расширенную хранимую процедуру с указанием полного пути, выполните хранимую процедуру sp_addextendedproc.

Доставка журналов

Доставка журналов в более ранних версиях SQL Server несовместима с доставкой журналов в SQL Server 2005 и поэтому не может быть обновлена непосредственно. После обновления до SQL Server 2005 заново настройте доставку журналов, используя среду SQL Server Management Studio или хранимые процедуры. Дополнительные сведения см. в разделе Обновление конфигурации доставки журналов SQL Server 2000.

Программа osql

Программа osql не поддерживает команды ED и !!. Удалите ссылки на команды ED и !! из своих сценариев. Для использования команд ED и !! следует воспользоваться программой sqlcmd.

Поставщик WMI SQL-DMO

Поставщик WMI SQL-DMO больше не поддерживается и недоступен.

Служба SQL Mail

SQL Server поддерживает обновление службы SQL Mail от SQL Server 7.0 или SQL Server 2000, однако для SQL Server 2005 требуется использование в качестве почтового клиента Microsoft Outlook 2002 или более поздних версий.

Примечание.
Эта возможность будет исключена из следующих версий Microsoft SQL Server. Избегайте использования этого свойства в новых разработках и запланируйте изменение приложений, которые сейчас ее используют. Чтобы отправить почту из SQL Server 2005, используйте компонент Database Mail.

Служба SQL Mail

Когда клиент, подключенный с использованием проверки подлинности SQL Server, попытается отправить с помощью службы SQL Mail почтовое сообщение с вложением, то SQL Server не сможет установить надлежащий контекст безопасности и вернет ошибку. Во избежание этой проблемы используйте проверку подлинности Windows.

API-интерфейс пространства имен SQL (SQL-NS)

API-интерфейс пространства имен SQL (SQL-NS) более не поддерживается и недоступен.

Флаги трассировки

В SQL Server 2000 флаги трассировки, установленные в сеансе A, не будут иметь силы в уже существующем сеансе B. Вместо этого флаги трассировки вступят в силу только после первой установки любого флага трассировки в сеансе B. Такое поведение является недетерминированным в SQL Server 2000 и детерминированным в SQL Server 2005. В SQL Server 2005 глобальные флаги трассировки, установленные в сеансе A, немедленно вступают в силу в других параллельных сеансах.

Кроме того, в SQL Server 2005 флаги трассировки могут быть объявлены как локально, так и глобально, с использованием дополнительного аргумента в инструкции DBCC TRACEON. Если второй аргумент не задан, по умолчанию в SQL Server 2005 принимается локальное объявление флагов. Это отличается от SQL Server 2000, где по умолчанию принимается глобальное объявление.

Дополнительные сведения см. в разделе Флаги трассировки (Transact-SQL).

Флаги трассировки

Некоторые флаги трассировки SQL Server 2000 отсутствуют в SQL Server 2005. Также некоторые флаги трассировки имеют в SQL Server 2005 другие функциональные возможности. Следует отключить все флаги трассировки перед началом обновления до SQL Server 2005. После окончания обновления убедитесь, что функции флагов трассировки не изменились. Также перед повторным включением любых флагов трассировки убедитесь, что они по-прежнему необходимы после обновления.

Триггеры

В SQL Server 2005 инструкции языка определения данных (DDL), например CREATE INDEX, не могут применяться к вставленным и удаленным таблицам внутри триггеров DML. В более ранних версиях SQL Server некоторые инструкции DDL могут применяться к вставленным и удаленным таблицам. Дополнительные сведения см. в разделе Использование таблиц inserted и deleted.

Повторяющиеся имена индексов

В SQL Server 2005 повторяющиеся имена индексов таблиц или представлений не допускаются. Перед началом обновления переименуйте индексы, чтобы устранить повторения.

  1. Определите расположение повторяющихся имен индексов, выполнив следующий запрос:

    Копировать код
    SELECT DISTINCT OBJECT_NAME(o.id), name
FROM sysindexes as o
WHERE EXISTS
    (SELECT name FROM sysindexes  as i
      WHERE i.id = o.id
      AND i.name = o.name and i.indid < o.indid);
  2. Для изменения одного из имен индексов используйте хранимую процедуру sp_rename. Поскольку имена индексов одинаковые, невозможно определить, какой из этих индексов будет переименован. Различить такие индексы позволит выполнение следующих действий.

    Копировать код
    EXEC sp_rename N'table_name.index_name', N'new_index_name, N'INDEX'
  3. Проверьте, какой из индексов был переименован, выполнив следующий запрос. Следующий запрос возвращает все индексы, включая имена ключевых столбцов в указанной таблице или представлении:

    Копировать код
    SELECT i.name AS IndexName, c.name AS ColumnName, ik.colid, ik.keyno
FROM sysindexes i
JOIN sysindexkeys ik ON i.id = ik.id and i.indid = ik.indid
JOIN syscolumns c ON c.id = ik.id and ik.colid = c.colid
WHERE i.id = OBJECT_ID('table_or_view_name')
  4. Если это необходимо, снова используйте хранимую процедуру sp_rename для исправления имен индексов.

Имена объектов

В SQL Server 2005 нельзя использовать символ с кодом 0xFFFF в именах объектов. Имя объекта, в котором содержится этот символ Юникода, не может быть использовано в базах данных с уровнем совместимости 90. Переименуйте объекты, имена которых содержат этот символ.

Индексированные представления

Функция Описание

Детерминизм функций

Следующие функциональные выражения считаются в SQL Server 2005 недетерминированными и поэтому могут помешать созданию индексированных представлений:

  • Ссылки на строковые литералы, неявно преобразуемые в типы данных datetime и smalldatetime.

  • Неявное преобразование символьных данных, представленных не в Юникоде, между различными параметрами сортировки.

Выражения, включающие неявные преобразования символьных строк в типы данных datetime или smalldatetime, считаются в SQL Server 2005 недетерминированными, если уровень совместимости не установлен меньшим или равным 80. Это связано с тем, что результаты зависят от значений параметров LANGUAGE и DATEFORMAT сеанса сервера. Например результат выражения CONVERT (datetime, '30 listopad 1996', 113) зависит от значения параметра LANGUAGE, поскольку строка «listopad» обозначает различные месяцы в разных языках. Аналогично: в выражении DATEADD(mm,3,'2000-12-01') SQL Server интерпретирует строку '2000-12-01' в соответствии со значением параметра DATEFORMAT.

Неявное преобразование символьных данных не в Юникоде между различными параметрами сортировки также считается недетерминированным, если уровень совместимости не установлен равным или меньшим 80.

Создание индексов в представлениях, содержащих эти выражения, не допускается в базах данных с уровнем совместимости 90. Несмотря на то, что существующие представления, содержащие такие выражения из обновленных баз данных, поддерживаются, оптимизатор запросов не будет учитывать их в планах запросов, если уровень совместимости равен 80 или 90. Дополнительные сведения о настройке уровней совместимости см. в разделе sp_dbcmptlevel (Transact-SQL).

При определении индексированных представлений в SQL Server 2005 необходимо явно преобразовать литералы в предпочитаемые типы данных при помощи детерминированного стиля форматирования даты. Список детерминированных стилей форматирования даты см. в разделе Функции CAST и CONVERT (Transact-SQL).

Если используется неявное преобразование строк в дату в существующих индексированных представлениях, обновленных до SQL Server 2005, то необходимо убедиться в том, что настройки LANGUAGE и DATEFORMAT совместимы с базами данных и приложениями, во избежание возможного повреждения индексированных представлений.

IGNORE_DUP_KEY

При создании уникального кластеризованного индекса в представлении SQL Server 2005 параметр IGNORE_DUP_KEY должен быть установлен в значение OFF. Это значение установлено по умолчанию. Установка параметра IGNORE_DUP_KEY в значение ON может привести к повреждению индексированных представлений.

Удалите кластеризованный индекс в представлении и создайте его вновь без указания параметра IGNORE_DUP_KEY.

Подсказки в запросах

Подсказки в запросах в определениях индексированных представлений при уровне совместимости 80 игнорируются. Это может привести к тому, что некоторые приложения начнут работать несколько иначе, чем при уровне совместимости 90. Дополнительные сведения см. в разделах Конструирование индексированных представлений, Создание индексированных представлений и Подсказка в запросе (Transact-SQL).

Безопасность

Функция Описание

Имена входа

Следующие имена фиксированных серверных ролей зарезервированы в SQL Server 2005 и не могут быть использованы как пользовательские имена входа:

  • sysadmin

  • serveradmin

  • setupadmin

  • securityadmin

  • processadmin

  • dbcreator

  • diskadmin

  • bulkadmin

Перед началом обновления до SQL Server 2005 выполните следующие шаги:

  1. Запишите идентификаторы защиты (SID) имен входа, выполнив следующую инструкцию:

    Копировать код
    SELECT name, sid
FROM master.dbo.syslogins
WHERE name IN('sysadmin', 'serveradmin','setupadmin',
 'securityadmin','processadmin', 'dbcreator','diskadmin',
 'bulkadmin')
  2. Удалите имена входа.

  3. Чтобы создать новое имя входа, воспользуйтесь системной процедурой sp_addlogin. В параметре @sid для каждого создаваемого имени входа укажите идентификатор SID, который был получен на шаге 1.

Идентификатор защиты имени входа (SID)

В SQL Server 2005 повторяющиеся идентификаторы защиты (SID) не допускаются. Перед началом обновления удалите одно из имен входа и связанных с ним пользователей.

Сопоставление удаленных имен входа

В предыдущих версиях SQL Server входящие соединения, поступавшие от удаленных экземпляров SQL Server, могли быть помечены как доверенные при помощи системной хранимой процедуры sp_remoteoption. SQL Server 2005 не поддерживает этот метод пометки удаленных имен входа. После обновления до SQL Server 2005 удаленные имена входа более не будут помечаться как доверенные.

Для установки удаленных имен входа и управления ими используйте связанные серверы и хранимые процедуры связанных серверов. Дополнительные сведения см. в разделе Связь серверов.

Имена входа SQL Server 6.5

SQL Server 6.5 сохраняет кэши паролей в формате, который более не поддерживается. Старые пароли не могут быть напрямую обновлены до SQL Server 2005.

Чтобы активировать имя входа, необходимо сбросить его пароль. Можно сбросить пароль с помощью инструкции ALTER LOGIN:

Копировать код
ALTER LOGIN <login name> WITH PASSWORD = '<new password>' MUST_CHANGE

Новый пароль будет проверен на соответствие политике сложности паролей системы, если проверка политики не отключена. Рекомендуется использовать сложные пароли и не отключать политику проверки. Параметр MUST_CHANGE принуждает пользователя выбрать новый пароль. Это не обязательно, но рекомендуется.

Можно определить неактивные имена входа SQL Server 6.5 с помощью следующего запроса:

Копировать код
SELECT * FROM sysxlogins WHERE (xstatus & 2048) = 2048;
GO

sys имя пользователя

Имя sys зарезервировано в SQL Server 2005 и не может быть использовано как имя пользователя. Переименуйте пользователя перед обновлением до SQL Server 2005. Если пользователь не переименован, то после обновления база данных будет помечена как подозрительная и будет недоступна до тех пор, пока не будет переведена в оперативный режим.

Процедура перед началом обновления

Перед обновлением до SQL Server 2005 в каждой базе данных, содержащей пользователя sys, выполните следующие действия:

  1. Создайте нового пользователя.

  2. Используйте следующие инструкции, чтобы просмотреть все разрешения, предоставленные пользователем sys и предоставленные пользователю sys.

    Копировать код
    -- Return permissions granted by user sys.
SELECT * FROM sysprotects WHERE grantor = USER_ID('sys')
-- Return permissions granted to user sys.
SELECT * FROM sysprotects WHERE uid = USER_ID('sys')
  3. Чтобы передать права всех объектов, принадлежащих пользователю sys, новому пользователю, используйте процедуру sp_changeobjectowner.

  4. Удалите пользователя sys.

  5. Чтобы восстановить первоначальные разрешения, записанные на шаге 2, используйте предложение AS new_user инструкции GRANT.

  6. Измените сценарии, чтобы они ссылались на нового пользователя.

Процедура после обновления

Если пользователь sys не был переименован перед обновлением, то сделайте следующее:

  1. Выполните инструкцию ALTER DATABASE db_name SET ONLINE. База данных перейдет в режим SINGLE_USER.

  2. Выполните все этапы, описанные в главе «Процедура перед началом обновления».

  3. Выполните инструкцию ALTER DATABASE db_name SET MULTI_USER.

Системные объекты и метаданные

Функция Описание

INFORMATION_SCHEMA.COLUMNS

В SQL Server 2005 столбец ORDINAL_POSITION представления INFORMATION_SCHEMA.COLUMNS не совместим с битовым шаблоном, возвращаемым функцией COLUMNS_UPDATED.

Чтобы получить битовый шаблон, совместимый с COLUMNS_UPDATED, обратитесь к свойству ColumnID системной функции COLUMNPROPERTY при запросе представления INFORMATION_SCHEMA.COLUMNS, как показано в следующем примере:

Копировать код
SELECT TABLE_NAME, COLUMN_NAME,
    COLUMNPROPERTY(OBJECT_ID(TABLE_SCHEMA + '.' + TABLE_NAME),
    COLUMN_NAME, 'ColumnID') AS COLUMN_ID
FROM AdventureWorks.INFORMATION_SCHEMA.COLUMNS
WHERE TABLE_NAME = 'Contact';

INFORMATION_SCHEMA.SCHEMATA

В более ранних версиях SQL Server представление INFORMATION_SCHEMA.SCHEMATA возвращало все базы данных в экземпляре SQL Server. В SQL Server 2005 представление возвращает все схемы в базе данных. Это поведение соответствует стандарту SQL. Дополнительные сведения см. в разделе SCHEMATA (Transact-SQL).

Имена столбцов INFORMATION_SCHEMA, соответствующие значению «%SCHEMA»

В более ранних версиях SQL Server имена столбцов INFORMATION_SCHEMA, соответствующие значению '%SCHEMA', возвращают имя пользователя. В SQL Server 2005 эти столбцы возвращают имя схемы. Когда база данных обновлена до SQL Server 2005, имя схемы всегда будет тем же, что и имя пользователя, поэтому работа любых приложений, ссылающихся на этот столбец, не будет нарушена. Однако пользователи, реализующие функции SQL Server 2005 для разделения пользователей и схем в своих базах данных, должны учитывать, что работа их приложений может нарушиться, если ожидаемыми данными является имя пользователя, а не имя схемы.

Дополнительные сведения см. в разделе Отделение пользователей от схем.

sp_helptrigger

SQL Server 2005 добавляет trigger_schema в качестве последнего столбца в результирующем наборе, возвращаемого системной хранимой процедурой sp_helptrigger. Проверьте использование процедуры sp_helptrigger в приложениях. Возможно, придется изменить приложения для обработки дополнительного столбца. Также можно использовать представление каталога sys.triggers.

syslockinfo и sp_lock

В SQL Server 2000 столбцы rsc_objid и rsc_indid в таблице syslockinfo, а также столбцы objid и indid в хранимой процедуреsp_lock в обязательном порядке возвращают идентификатор объекта и идентификатор индекса. В SQL Server 2005 может быть возвращено нулевое значение.

В SQL Server 2000 syslockinfo и sp_lock возвращают не более двух строк для любого отдельно взятого ресурса блокировки в единичной транзакции. В SQL Server 2005, если включено секционирование блокировок, то могут быть возвращены несколько строк для одного и того же ресурса, выполняющегося в рамках одной транзакции. Может возвращаться до N + 1 строк, где N — число процессоров. Кроме того, в SQL Server 2005 запросы GRANTED и WAITING могут отображаться для одного и того же ресурса. В службах SQL Server 2000 эти запросы не могут отображаться для одного ресурса. Дополнительные сведения см. в разделах sp_lock (Transact-SQL) и sys.syslockinfo (Transact-SQL).

Согласование параметров сортировки для имен системных объектов и имен системных типов

В более ранних версиях SQL Server для сопоставления имен системных объектов и имен системных типов использовались параметры сортировки базы данных master. В SQL Server 2005 имена системных объектов и имена системных типов автоматически приводятся в соответствие с параметрами сортировки текущей базы данных. Если ссылки на эти объекты в сценариях или приложениях не соответствуют тому, как они указаны в каталоге, а параметры сортировки текущей базы данных учитывают регистр, сценарий или приложение могут завершиться с ошибкой. Например инструкция EXEC SP_heLP не выполнится, если параметры сортировки текущей базы данных учитывают регистр.

Изменение системных объектов

В SQL Server 2005 не допускается непосредственное изменение системного каталога. Любая попытка сделать это приведет к возникновению следующей ошибки:

«Сервер: сообщение 259, уровень 16, состояние 2, строка 1»

«Нерегламентированные обновления системных каталогов запрещены».

Измените свои SQL-сценарии так, чтобы они использовали официальные документированные функции API-интерфейса. Например, используйте инструкцию ALTER DATABASE database_name SET EMERGENCY вместо инструкции UPDATE в системной таблице sysdatabases.

Удаление системных объектов

Такие инструкции, как DROP TABLE, DROP PROCEDURE и sp_dropextendedproc не могут использоваться для удаления системных объектов, поскольку эти объекты размещены в базе данных ресурсов, доступной только для чтения.

Удалите из своих приложений все инструкции, которые пытаются удалить системные объекты. Измените свои приложения так, чтобы они отменяли или запрещали разрешение EXECUTE для системных объектов. В качестве альтернативы для отключения некоторых из этих объектов можно воспользоваться средствами конфигурации контактной зоны в составе SQL Server 2005. Например расширенная хранимая процедура xp_cmdshell может быть отключена и включена с помощью одного из средств настройки контактной зоны.

sysperfinfo

В SQL Server 2005 sysperfinfo возвращает для столбца cntr_value значение bigint. Внесите изменения в приложения, использующие sysperfinfo, чтобы убедиться, что они могут обрабатывать значение bigint столбца cntr_value.

В SQL Server 2005 представление sysperfinfo реализовано для обеспечения совместимости. Вместо него следует использовать динамическое административное представление sys.dm_os_performance_counters.

Системные таблицы, запрашиваемые с использованием 'dbo' в критерии поиска

В более ранних версиях SQL Server системные объекты принадлежали пользователю dbo и располагались в базе данных master. В SQL Server 2005 системные объекты принадлежат пользователю sys и логически присутствуют в каждой базе данных. Инструкции, запрашивающие системные таблицы и использующие в критериях поиска ссылку на пользователя dbo, будут завершаться с ошибкой.

Transact-SQL

Функция Описание

@@VERSION

SQL Server 2005 возвращает более подробные сведения, чем SQL Server 2000, в формате: основная_версия.вспомогательная_версия.номер_сборки.дополнительный_номер_сборки.

CREATE STATISTICS

Указание параметра WITH ROWS внутри инструкций CREATE STATISTICS не поддерживается в SQL Server 2005. Измените инструкции CREATE STATISTICS, содержащие параметр WITH ROWS, указав ключевое слово SAMPLE number между WITH и ROWS, или укажите другие параметры, соответствующие документированному синтаксису.

DISK INIT

Инструкция DISK INIT, используемая в более ранних версиях SQL Server для создания базы данных или устройства ведения журнала транзакций, была изъята из SQL Server 2005. Замените все вхождения инструкции DISK INIT на эквивалентные инструкции CREATE DATABASE и ALTER DATABASE.

Использование оператора UNION внутри инструкции INSERT INTO...SELECT

Если оператор UNION находится внутри инструкции INSERT, то SQL Server 2005 самостоятельно проводит приведение типов данных каждого оператора UNION согласно правилам приведения типов данных. Затем типы данных конечного результата операции UNION приводятся к типам соответствующих столбцов таблицы, указанной операцией INSERT. Это изменение поведения операторов может вызвать ошибки приведения типов данных в приложениях.

Следующий пример показывает ошибку приведения типов данных. При уровне совместимости 80 и ниже целочисленная константа 1 в первой инструкции SELECT приводится непосредственно к типу данных целевого столбца ReturnedValue, каковым является varchar(255). При уровне совместимости 90 тип данных результирующего набора UNION определяется до приведения к типу данных целевого столбца. Для второго столбца в первой инструкции SELECT тип данных определен как int. Для второго столбца во второй инструкции SELECT тип данных определен как varchar(4). Поскольку тип данных int имеет больший приоритет, чем тип данных varchar(4), при определении типа данных результирующего набора оператора UNION значение test будет приведено к типу данных int, что вызовет ошибку преобразования типов данных.

Копировать код
CREATE TABLE #test(ReturnedName varchar(255) NOT NULL,
  ReturnedValue varchar(255) NULL)
INSERT INTO #test
SELECT 'col1', 1
UNION ALL
SELECT 'test', 'test'
DROP TABLE #test

UPDATETEXT

SQL Server 2005 не поддерживает использование текстовых указателей в инструкциях UPDATETEXT, которые используются для чтения и записи одного и того же большого бинарного объекта (BLOB) посредством одного и того же текстового указателя. Скопируйте объект BLOB во временную таблицу или переменную-таблицу, а затем снова присвойте значение исходному столбцу.

Ключевое слово WITH при использовании табличных подсказок

В SQL Server 2005, с некоторыми исключениями, табличные подсказки поддерживаются в предложении FROM запроса только в том случае, когда подсказки указаны с ключевым словом WITH.

Дополнительные сведения см. в разделах FROM (Transact-SQL) и Табличная подсказка (Transact-SQL).

Предложение ORDER BY в определении представления

В SQL Server 2005 предложение ORDER BY в определении представления применяется только для определения того, какие строки будут возвращены по предложению TOP. Предложение ORDER BY не гарантирует упорядочивания результатов при запросе представления, если оно не указано в самом запросе.

Инструкция UPDATE с подсказками блокировки

В SQL Server 2000 подсказки блокировки не проверяются на наличие конфликтов в инструкции UPDATE, если выполняются оба следующих условия:

  • Таблица в предложении FROM представлена псевдонимом.

  • Та же таблица упоминается как целевая в инструкции UPDATE без псевдонима.

SQL Server не обрабатывает подсказки блокировки, указанные в предложении FROM и не вызывает ошибку, если подсказки конфликтуют. В SQL Server 2005 ошибка возвращается, если подсказки блокировки конфликтуют с этими условиями.

XML

Функция Описание

OPENXML

Ввиду изменений в MSXML OPENXML более не поддерживает нецелые позиционные предикаты. В SQL Server 2005 базовым ядром, обрабатывающим выражения XPath, используемые в запросах OPENXML, является MSXML 3.0. MSXML 3.0 имеет ядро, в большей степени соответствующее спецификации XPath 1.0, где была изменена семантика нецелых значений в позиционных предикатах.

Например, выражение XPath a[5.1] теперь не возвращает ни одного элемента вместо пятого элемента <a>. Чтобы исправить это, непосредственно используйте округленные значения. Например измените предыдущий пример на a[5].

Выражения OPENXML XPath

MSXML 3.0 имеет ядро, более строго соответствующее спецификации XPath 1.0, где была отменена поддержка следующих функций:

  • format-number()

  • formatNumber()

  • current()

  • element-available()

  • function-available()

  • system-property()

Вместо функций format-number() и formatNumber() можно использовать Transact-SQL. Для других неподдерживаемых функций не имеется непосредственной альтернативы.

Определяемых пользователем тип данных 'xml'

В SQL Server 2005 xml является зарезервированным системным типом. Используйте процедуру sp_rename для переименования типа либо до начала обновления, либо после окончания обновления и измените приложения для работы с новым именем типа данных.

См. также

Справочник

Изменения в работе функций ядра СУБД в SQL Server 2005
Устаревшие функции ядра СУБД в SQL Server 2005
Неподдерживаемые функции ядра СУБД в SQL Server 2005

Другие ресурсы

Обратная совместимость компонента SQL Server 2005 Database Engine
sp_dbcmptlevel (Transact-SQL)

Журнал изменений

Версия Журнал

14 апреля 2006 г.

Новое содержимое:
  • Добавлен элемент в разделе Transact-SQL об использовании ORDER BY в определении представления.

  • Добавлен элемент в разделе Transact-SQL об использовании подсказок блокировки в инструкции UPDATE.


Изменения в работе функций ядра СУБД в SQL Server 2005

Изменения в работе функций ядра СУБД в SQL Server 2005 |
 | См. также
Обновление до SQL Server 2005 > Обратная совместимость > Обратная совместимость компонента SQL Server 2005 Database Engine >

Дата обновления: 17 июля 2006 г.

Этот раздел описывает изменения в работе некоторых функций компонента Database Engine в по сравнению с их работой в предыдущих версиях SQL Server.

Резервное копирование и восстановление

При восстановлении существующей базы данных SQL Server 2005 требуется создать резервную копированию заключительного фрагмента журнала, прежде чем приступить к восстановлению базы данных в соответствии с моделью полного восстановления или восстановления с неполным протоколированием. Попытка восстановить базу данных перед резервным копированием заключительного фрагмента журнала приведет к ошибке, если инструкция RESTORE не содержит предложения WITH REPLACE или WITH STOPAT. Дополнительные сведения по обновлению компонентов SQL Server см. в разделе Резервные копии заключительного фрагмента журнала.

Курсоры

В следующей таблице перечислены неявные преобразования курсора, которые имеют место в SQL Server 2000, но отсутствуют в SQL Server 2005. В качестве временного решения можно запросить определенный тип курсора, не опираясь на неявное преобразование.

Условие | В SQL Server 2000 курсор преобразуется из | В
Запрос содержит встроенную возвращающую табличное значение функцию. | Динамический или набор ключей | Статический
Запрос ссылается на удаленный объект. | Однопроходный | Набор ключей
Запрос не содержит таблиц. | Однопроходный | Статический
Запрос содержит табличную функцию. | Однопроходный | Статический
Запрос содержит производную таблицу. | Однопроходный | Статический
Запрос содержит табличную функцию с несколькими инструкциями. | Динамический Набор ключей | Из «Динамического» в «Статический» Статический
Запрос содержит виртуальную таблицу. | Динамический или набор ключей | Статический
Запрос содержит представление с TOP. | Однопроходный | Статический
Запрос содержит обновляемые секционированные представления. | Однопроходный | Статический
Запрос курсора API содержит индексированное представление с уникальным путем доступа, но не на уровне базовой таблицы. | Набор ключей | Статический
Запрос API-курсора содержит таблицу без кластеризованного индекса или уникального ключа. | Набор ключей | Статический
Результирующий набор курсора API содержит столбец с типом данных text, ntext или image. | Однопроходный | Динамический

SQL Server 2005 не поддерживает асинхронное формирование курсоров, управляемых набором ключей, и статических курсоров Transact-SQL. Операции курсора Transact-SQL, такие как OPEN или FETCH, обычно являются пакетными. Таким образом, нет необходимости в асинхронном формировании курсоров Transact-SQL. SQL Server 2005 продолжает поддерживать использование асинхронных курсоров, управляемых набором ключей, или статических серверных курсоров API в случаях, когда операция OPEN с малым периодом ожидания замедляется из-за двусторонних задержек клиента для каждой операции курсора.

Если в SQL Server 2005 динамический курсор объявлен для таблицы без уникальных индексов и строка удалена за пределами курсора, последующее обновление курсора извлекает местозаполнитель для строки со значением NULL. В более ранних версиях SQL Server курсор не возвращает затронутую строку.

Если в SQL Server 2005 внутри пакета или хранимой процедуры возможны различные объявления курсора посредством логики условий, инструкции INSERT, UPDATE и DELETE, выполняемые через курсор, влекут за собой повторную компиляцию. В SQL Server 2000 эти инструкции не вызывают повторную компиляцию.

В следующем примере использование инструкции UPDATE приведет к повторной компиляции модуля.

Копировать код
IF(@some_condition=1)
   DECLARE c CURSOR FOR
      SELECT region FROM db.dbo.mytable ORDER BY lastname
ELSE
   DECLARE c CURSOR FOR
      SELECT postalcode FROM db.dbo.mytable ORDER BY firstname
...
FETCH NEXT FROM c
...
UPDATE db.dbo.mytable
   SET  firstname='a' WHERE CURRENT OF c

Чтобы избежать повторной компиляции, перепишите код следующим образом:

Копировать код
IF (@some_condition=1)
BEGIN
   DECLARE c CURSOR FOR
     SELECT region FROM db.dbo.mytable ORDER BY lastname
   FETCH NEXT FROM c
   UPDATE db.dbo.mytable
     SET  firstname='a' WHERE CURRENT OF c
END
ELSE
BEGIN
  DECLARE c CURSOR FOR
    SELECT postalcode FROM db.dbo.mytable ORDER BY firstname
  FETCH NEXT FROM c
  UPDATE db.dbo.mytable
    SET  firstname='a' WHERE CURRENT OF c
END

В SQL Server 2005 блокировки прокрутки курсоров вызывают преобразование блокировки с типа S (общая) на U (обновления), если в запросе не указана подсказка блокировки более высокого уровня. SQL Server 2000 автоматически добавляет подсказку блокировки типа U к блокировкам прокрутки курсоров. Поведение курсоров в SQL Server 2005 предусматривает более эффективный параллелизм, однако существует вероятность взаимоблокировок для параллельно выполняемых курсоров. Используйте подсказку UPDLOCK для обеспечения требуемого поведения. Дополнительные сведения по обновлению компонентов SQL Server см. в разделе Табличная подсказка (Transact-SQL).

В SQL Server 2000, когда обновляется значение столбца или строки, встречающееся в буфере выборки курсора более одного раза, обновление может не затронуть другие вхождения из-за размера буфера выборки или расположения строк в нем. В SQL Server 2005 строки в буфере выборки обновляются таким образом, что значения всегда согласованы, независимо от размера буфера выборки или расположения строк.

В SQL Server 2000 курсоры, использующие инструкцию UNION ALL, некорректно возвращают сведения о возможности обновления на основе первого набора в инструкции UNION. Следовательно, некоторые курсоры описываются как обновляемые, хотя они ими не являются. SQL Server 2005 представляет результаты инструкции UNION ALL как вычисляемые и, следовательно, необновляемые. Если все строки курсора исходят из одной таблицы или представления, можно определить курсор, обновляемый посредством изменения запроса для использования предложений IN или OR вместо UNION.

В SQL Server 2000, когда параметр CURSOR_CLOSE_ON_COMMIT установлен в значение ON, все курсоры в соединении закрываются при фиксации транзакции. В SQL Server 2005 во время фиксации транзакции закрываются только курсоры, открытые в пределах текущей транзакции. Курсоры, открытые до начала транзакции, остаются открытыми.

SQL Server 2000 позволяет выполнять ряд объявлений курсоров, которые не являются допустимыми, и преобразует их в другие типы курсоров. SQL Server 2005 не допускает использование недопустимых объявлений. Например, курсор, который запрашивает и обновляемость, и нечувствительность, не является допустимым и в SQL Server 2005 вызывает ошибку.

Базы данных, файлы данных и журналов

Поведение SQL Server 2000 Поведение SQL Server 2005

Параметр базы данных AUTO_CLOSE является синхронным процессом, который может снизить производительность, когда к базе данных обращается приложение, неоднократно устанавливающее и разрывающее соединения с Database Engine.

Процесс AUTO_CLOSE является асинхронным. Повторяющиеся открытия и закрытия базы данных больше не снижают производительность.

Файлы в необработанных секциях не растут автоматически, и, следовательно, параметры MAXSIZE и FILEGROWTH не требуются, если в параметре os_file_name указывается необработанная секция.

Файлы в необработанных секциях растут автоматически. Можно указать параметры MAXSIZE и FILEGROWTH.

Разрешения не устанавливаются для файлов данных и файлов журнала каждой базы данных.

Разрешения устанавливаются для файлов данных и файлов журнала каждый раз, когда к базе данных применяются следующие операции:

Создается | Изменена для добавления нового файла
Присоединена | Создана резервная копия
Отсоединена | Восстановлена

Эти разрешения предотвращают случайное повреждение файлов в случае их сохранения в каталоге с открытыми разрешениями. Дополнительные сведения по обновлению компонентов SQL Server см. в разделе Защита данных и файлов журналов.

Примечание.
не задает разрешения на файлы данных и файлы журнала.

Связанные серверы и распределенные запросы

Связанный сервер, который определялся использованием в качестве имени поставщика «SQLOLEDB», при обновлении будет изменен на «SQLNCLI» (собственный поставщик OLE DB клиента SQL). Представление совместимости sys.sysservers показывает связанные серверы, использующие SQLNCLI как SQLOLEDB. Представление каталога SQL Server 2005 sys.servers показывает связанные серверы, которые используют «SQLNCLI» в виде «SQLNCLI».

Гетерогенные запросы и использование поставщиков OLE DB не поддерживаются при выполнении SQL Server в режиме волокон. Режим волокон включается, если дополнительный параметр конфигурации lightweight pooling установлен в значение 1.

Экземпляр поставщика OLE DB для собственного клиента SQL нельзя создать вне процесса.

Предупреждающие сообщения от связанного сервера в SQL Server 2005 не передаются клиенту. Наиболее значимые классы таких предупреждений:

  • Предупреждения в формате ANSI о том, что значения NULL исключены при вычислении статистической функции

  • Предупреждения об арифметическом переполнении

Например, следующая инструкция Transact-SQL может сформировать предупреждающее сообщение, если существуют значения NULL в col1:

Копировать код
SELECT SUM(col1)
FROM <Table>
GROUP BY col2

В SQL Server 2000 и более ранних версиях связанные серверы передавали предупреждающее сообщение клиенту. В SQL Server 2005 связанные серверы не передают предупреждающие сообщения.

В SQL Server 2000, если удаленная хранимая процедура выполняется неудачно из-за ошибок времени компиляции, таких как неправильная привязка параметров, возвращается значение или состояние, равное 0. Если такая ситуация имеет место в SQL Server 2005, в качестве возвращаемого значения или состояния устанавливается NULL.

Архитектура обработчика запросов

Использование значений параметра в течение повторной компиляции различается в SQL Server 2000 и SQL Server 2005 для пакетов, запущенных в следующих формах:

  • Хранимые процедуры

  • Использование sp_executesql

  • Подготовленные инструкции

Когда SQL Server 2000 повторно компилирует эти пакеты, используются значения параметров, с которыми пакеты вызываются как часть повторной компиляции. Когда SQL Server 2005 повторно компилирует эти запросы, используются значения параметров, существовавшие до того, как инструкция вызывает повторную компиляцию. Эти значения могут отличаться от тех, которые первоначально были переданы в пакет. Дополнительные сведения по обновлению компонентов SQL Server см. в разделе Параметры и повторное использование планов выполнения.

Безопасность

Функция Поведение SQL Server 2000 Поведение SQL Server 2005

GRANT ALL

Предоставляет все применимые разрешения.

Предоставление разрешения ALL на объекты и инструкции является устаревшим. Когда выполняется инструкция GRANT ALL происходит следующее:

  • Команда выполняется успешно, но пользователю предоставляются только разрешения, доступные для предоставления в SQL Server 2000.

  • Выводится следующее сообщение: «Разрешение ALL является устаревшим и поддерживается только для обеспечения совместимости. Оно не означает выдачу ВСЕХ разрешений, определенных для сущности».

SQL Server 2005 предоставляет дополнительные разрешения в различных областях, которые можно использовать для управления пользовательскими разрешениями. Например, разрешение CONTROL можно использовать для предоставления разрешений на объект, эквивалентных разрешениям его владельца.

Сравнения паролей

SQL Server 2000 поддерживает две версии каждого пароля, используемого для входа в SQL Server. Один — текущий пароль, предоставленный пользователем, а другой — пароль, преобразованный SQL Server в буквы верхнего регистра. Это делает доступной проверку подлинности паролей, не учитывающую регистр. Несмотря на то что это поведение удобно для многих пользователей, атаки путем подбора пароля становятся легче из-за снижения количества возможных паролей.

Хранится только текущий пароль. Пароль, вводимый пользователем, должен совпасть с паролем, хранимым на сервере. Если пароль не совпадает с паролем, хранимым в SQL Server, вход не выполняется. Если забыт точный регистр символов пароля, пароль должен быть переустановлен.

Смена языка по умолчанию для учетной записи sa

Язык по умолчанию для учетной записи SQL Server sa — это язык, который выбран во время установки или обновления версии.

В предыдущих версиях запуск хранимой процедуры sp_configure для смены языка сервера по умолчанию также обновлял язык по умолчанию для учетной записи sa.

Чтобы изменить язык по умолчанию для учетной записи sa в SQL Server 2005, необходимо выполнить хранимую процедуру sp_defaultlanguage, затем команду DBCC FREESYSTEMCACHE, после чего начать новый сеанс. Запуск процедуры sp_configure для смены языка сервера по умолчанию не меняет языка по умолчанию для учетной записи sa.

Системные хранимые процедуры

Следующие таблицы содержат список изменений параметров в системных хранимых процедурах Database Engine.

Хранимая процедура | Параметр | Описание изменения
sp_bindefault | @objname | Размер изменен с nvarchar(517) на nvarchar(776).
sp_bindrule | @objname | Размер изменен с nvarchar(517) на nvarchar(776).
sp_changeobjectowner | @objname | Размер изменен с nvarchar(517) на nvarchar(776).
sp_detach_db | @keepfulltextindexfile | Размер изменен с nvarchar(517) на nvarchar(776).
sp_fulltext_service | @action | Размер изменен с varchar(20) на nvarchar(100).
sp_fulltext_service | @value | Тип данных изменен с int на sql_variant.
sp_getapplock | @DbPrincipal | Добавлен параметр.
sp_releaseapplock | @DbPrincipal | Добавлен параметр.
sp_setapprole | @fCreateCookie | Добавлен параметр.
sp_setapprole | @cookie | Добавлен параметр.
sp_settriggerorder | @stmttype | Размер изменен с varchar(10) на varchar(50).
sp_settriggerorder | @namespace | Добавлен параметр.
sp_sproc_columns | @fUsePattern | Добавлен параметр.
sp_stored_procedures | @fUsePattern | Добавлен параметр.
sp_table_privileges | @fUsePattern | Добавлен параметр.
sp_table_privileges_ex | @fUsePattern | Добавлен параметр.
sp_tables | @fUsePattern | Добавлен параметр.
sp_tables_ex | @fUsePattern | Добавлен параметр.

Системные таблицы и представления

Следующие таблицы содержат список изменений в столбцах системных таблиц и представлений.

Системная таблица или представление | Столбец | Описание изменения
COLUMNS | ORDINAL_POSITION | Тип данных изменен с smallint на int.
PARAMETERS | ORDINAL_POSITION | Тип данных изменен с smallint на int.
REFERENTIAL_CONSTRAINTS | MATCH_OPTION | Размер изменен с varchar(4) на varchar(7). Значение по умолчанию изменено с «NONE» на «SIMPLE».
REFERENTIAL_CONSTRAINTS | UPDATE_RULE | Размер изменен с varchar(9) на varchar(11).
REFERENTIAL_CONSTRAINTS | DELETE_RULE | Размер изменен с varchar(9) на varchar(11).
ROUTINE_COLUMNS | ORDINAL_POSITION | Тип данных изменен с smallint на int.
sysaltfiles | name | Тип данных изменен с nchar(128) на sysname.
sysaltfiles | filename | Тип данных изменен с nchar(260) на nvarchar(260).
sysconfigures | config | Тип данных изменен с smallint на int.
syscursorcolumns | data_type_sql | Тип данных изменен с smallint на int.
sysfiles | name | Тип данных изменен с nchar(128) на sysname.
sysfiles | filename | Тип данных изменен с nchar(260) на nvarchar(260).
sysmessages | severity | Тип данных изменен с smallint на tinyint.
sysperfinfo | cntr_value | Тип данных изменен с int на bigint.
sysprocesses | waittime | Тип данных изменен с int на bigint.
sysprocesses | hostprocess | Размер изменен с nchar(8) на nchar(10).
sysprocesses | request_id | Добавлен столбец.
sysprotects | columns | Размер изменен с varbinary(4000) на varbinary(8000).
sysservers | srvcollation | Тип данных изменен с int на sysname.
sysservers | nonsqlsub | Добавлен столбец.
sysoledbusers | rmtpassword | Возвращает только значение NULL.
sysindexes | keys | Возвращает только значение NULL.
sysindexes | statblob | Возвращает только значение NULL.
syscomments | compressed | Возвращает только 0.
sysdevices | size | Возвращает только 0.
sysobjects | schema_ver | Возвращает только 0.
sysremotelogins | status | Возвращает только 0.
sysservers | topologyx | Возвращает только 0.
sysservers | topologyy | Возвращает только 0.

Transact-SQL

Функция Поведение SQL Server 2000 Поведение SQL Server 2005

Программа bcp

Пользователь, который имеет для таблицы разрешения INSERT и SELECT, может использовать программу bcp для массовой загрузки данных в таблицу, используя следующую команду:

Копировать код
bcp <target table> in
<datafile> -c -T

По умолчанию эта команда отключает ограничения CHECK и триггеры в целевых таблицах.

Для запуска программы bcp пользователь должен иметь разрешение ALTER, а также разрешения INSERT и SELECT для целевых таблиц, если ограничения CHECK и триггеры отключены в течение процесса массового копирования. После обновления до SQL Server 2005 команды bcp в приложениях могут дать сбой из-за недостатка разрешений. Эта проблему можно решить одним из следующих способов:

  • Предоставить пользователю разрешение ALTER TABLE на все таблицы, которые затронуты процессом bcp.

  • Изменить команду bcp, чтобы явно применить ограничения CHECK и триггеры, как показано в следующей команде:

    Копировать код
    bcp <target table>
in <datafile> -c -T -h
"CHECK_CONSTRAINTS,
FIRE_TRIGGERS"

Встроенные системные функции

Каждое обращение к встроенным функциям, таким как NEWID и RAND, дает новый результат, потому что он вычисляется один раз для каждого обращения внешнего запроса.

Внешний запрос создает несколько обращений к столбцам представлений или производных таблиц. Однако если эти столбцы определены вызовом таких функций как NEWID и RAND, эти несколько обращений являются причиной того, что эта функция вычисляется только один раз для каждого фактического вызова внутри представления или производной таблицы.

Несколько обращений к таким столбцам во вложенном запросе не вызывают многократного вычисления функций. Это позволяет многократно использовать значение, вычисляемое этими функциями во вложенном запросе.

Например в SQL Server 2000 следующий запрос возвращает два различных значения. В SQL Server 2005 этот запрос возвращает одно значение.

Копировать код
SELECT Column1, Column1
      FROM (
            SELECT RAND() Column1
            FROM (
            SELECT 1 c
            UNION
            SELECT 2 c
                  ) s
            ) t

BULK INSERT

Инструкция BULK INSERT поддерживает преобразование строкового типа в десятичный для строк, представляющих собой числовые значения, которые используют экспоненциальный формат.

Преобразования строковых типов в десятичные, используемые в инструкции BULK INSERT, следуют тем же правилам, что и функция Transact-SQL CONVERT. Эта функция отклоняет строки, представляющие числовые значения, которые используют экспоненциальный формат. Следовательно, инструкция BULK INSERT считает такие строки недопустимыми значениями и сообщает об ошибках преобразования. Дополнительные сведения по обновлению компонентов SQL Server см. в разделе BULK INSERT (Transact-SQL).

преобразования datetime

Преобразования строк в datetime помечены как детерминированные. Однако это неверно для стилей, перечисленных в следующей таблице. Для этих стилей преобразования зависят от параметров языка.

Следующая таблица содержит стили, для которых преобразование строковых значений в datetime не детерминировано.

Все стили меньше 1001 | 106
107 | 109
113 | 130

1 За исключением стилей 20 и 21

SQL Server 2005 помечает преобразования строковых значений в datetime как недетерминированные.

DBCC CHECKFILEGROUP

Если некластеризованный индекс в указанной файловой группе связан с таблицей в другой файловой группе, проверяются индекс и базовая таблица в другой файловой группе.

Если некластеризованный индекс в указанной файловой группе связан с таблицей в другой файловой группе, индекс не проверяется, так как базовая таблица не доступна для проверки.

DBCC SHOW_STATISTICS

Набор строк, возвращенный DBCC SHOW_STATISTICS, не содержит столбец Name.

Первый набор строк, возвращенный DBCC SHOW_STATISTICS, содержит дополнительный столбец с заголовком Name. Этот столбец показывается первым в результирующем наборе. Если имеются приложения, которые обращаются к столбцам, возвращенным инструкцией DBCC SHOW_STATISTICS по порядковому номеру, измените их для обращения к столбцам по имени.

DROP LOGIN

При выполнении инструкции DROP LOGIN имя входа не удаляется, если оно сопоставлено с пользователями базы данных.

При выполнении инструкции DROP LOGIN имя входа удаляется, даже если оно сопоставлено с пользователями базы данных.

Выражения в вычисляемых столбцах, ограничения CHECK и DEFAULT

Исходный текст выражения, включая пробелы, сохраняется в метаданных каталога. Например, выражение вычисляемого столбца, введенное в виде c1 + c2 + 1, будет выглядеть точно так, как если бы было введено в столбце типа text в системной таблице syscomments.

Исходный текст выражения подвергается дешифрованию и нормализации, а выходные данные этой операции сохраняются в метаданных каталога. Семантика дешифрованного выражения будет эквивалентна исходному тексту, однако синтаксическое соответствие не гарантируется. Например, выражение вычисляемого столбца, введенное в виде c1 + c2 + 1, будет выглядеть как (([c1]+[c2])+(1)) в столбце определения в представлении системного каталога sys.computed_columns.

Выражения в запросах

Небезопасные выражения в запросах не всегда формируют исключение во время выполнения.

SQL Server 2005 иногда вычисляет выражения в запросах быстрее, чем они вычисляются в SQL Server 2000. Такая его работа дает следующие важные преимущества:

  • Способность сопоставлять индексы вычисляемых столбцов с выражениями запроса, совпадающими с выражением вычисляемых столбцов.

  • Предотвращение избыточных вычислений результатов выражений.

Однако, в зависимости от характера запроса и данных в базе данных, исключения во время выполнения могут возникать в SQL Server 2005, если запрос содержит существующее небезопасное выражение. Эти исключения во время выполнения содержат следующее:

  • Арифметические исключения: деление на ноль, переполнение, потеря значимости.

  • Ошибки преобразований, такие как потеря точности и попытка преобразовать нечисловую строку в число.

  • Статистическая обработка набора значений, не все из которых гарантированно отличаются от NULL.

Эти исключения не возникают в отдельном приложении SQL Server 2000, которое использует определенные данные. Однако план-запрос, который изменяется из-за меняющейся статистики, потенциально может привести к исключению в SQL Server 2000. Эти исключения во время выполнения можно предотвратить изменением запроса, чтобы включить условные выражения, такие как NULLIF или CASE. Дополнительные сведения по обновлению компонентов SQL Server см. в разделе Устранение ошибок и предупреждений по выражениям запроса.

fn_servershareddrives

Данные, возвращенные системной функцией fn_servershareddrives, могут быть просмотрены членами роли public.

Изменение разрешения: fn_servershareddrives требует наличия у пользователя разрешения VIEW SERVER STATE для сервера.

Важно!
Эта системная функция SQL Server 2000 включена для обратной совместимости. Рекомендуется использовать вместо нее sys.dm_io_cluster_shared_drives.

fn_virtualfilestats

Данные, возвращенные системной функцией fn_virtualfilestats, могут быть просмотрены членами роли public.

Изменение разрешения: fn_virtualfilestats требует наличия у пользователя разрешения VIEW SERVER STATE для сервера.

fn_virtualservernodes

Данные, возвращенные системной функцией fn_virtualservernodes, могут быть просмотрены членами роли public.

Изменение разрешения: fn_virtualservernodes требует наличия у пользователя разрешения VIEW SERVER STATE для сервера.

Важно!
Эта системная функция SQL Server 2000 включена для обратной совместимости. Рекомендуется использовать вместо нее sys.dm_os_cluster_nodes.

HOST_ID

Инструкция HOST_ID возвращает значение char(8).

HOST_ID возвращает значение char(10).

Индексы

Разрешаются индексы, описанные в столбце "Поведение SQL Server 2005".

Следующие индексы могут быть отключены во время процесса обновления или могут требовать перестроения из-за изменений, введенных в SQL Server 2005:

  • Индексы в вычисляемых столбцах, которые используют CHECKSUM(some_timestamp_column), будут отключены, потому что изменилось поведение для функции Transact-SQL CHECKSUM, когда она принимает столбец timestamp в качестве аргумента.

  • Индексы, которые содержат символьные значения 0x3390, 0x33ca или 0x33cb в столбцах nvarchar или nchar, использующих параметры сортировки для турецкого языка, могут потребовать перестроения, потому что изменились принципы сортировки в этих параметрах сортировки.

  • Индексы в вычисляемых столбцах или представлениях, в которых представление или выражение вычисляемого столбца содержит либо неявное преобразование из строкового значения в datetime или smalldatetime, либо явное недетерминированное преобразование из строкового значения в datetime или smalldatetime, будут отключены.

Для индексов, которые требуют перестроения из-за изменений, описанных в первых двух пунктах, приведенных ранее, используйте следующую процедуру.

  1. Проверьте журнал ошибок SQL Server на наличие предупреждающих сообщений 3801, 3803 и 3804.

  2. Запустите инструкцию DBCC CHECKTABLE в базовой таблице, чтобы выяснить наличие проблемы.

  3. Если результаты выполнения инструкции DBCC показывают, что проблема существует, повторно постройте индекс, используя один из следующих методов:

    • Инструкция ALTER INDEX с предложением REBUILD

    • Инструкция CREATE INDEX с предложением DROP_EXISTING

    • DBCC DBREINDEX

  4. Определите отключенные ограничения FOREIGN KEY, используя следующую инструкцию:

    Копировать код
    SELECT * FROM sys.foreign_keys
WHERE is_disabled=1;
  5. Включите все ограничения FOREIGN KEY с помощью инструкции ALTER TABLE CHECK CONSTRAINT.

    Ограничения PRIMARY KEY и UNIQUE включаются путем перестроения соответствующего индекса. Индекс должен быть перестроен до включения ограничений FOREIGN KEY, которые ссылаются на ограничение PRIMARY KEY или UNIQUE.

Для индексов, отключенных из-за изменений и описанных в третьем пункте, приведенном ранее, используйте следующую процедуру.

  1. Определите индексы в вычисляемых столбцах, которые были отключены, используя следующую инструкцию:

    Копировать код
    SELECT object_name(i.object_id) AS
 object_name, i.*
FROM sys.indexes AS i
JOIN sys.index_columns AS ic
ON i.index_id = ic.index_id
  AND i.object_id = ic.object_id
JOIN sys.computed_columns AS
 cc
ON ic.object_id = cc.object_id
  AND ic.column_id = cc.column_id
WHERE i.is_disabled = 1
  2. Для индекса вычисляемого столбца удалите индекс, а затем измените определение вычисляемого столбца, чтобы использовать явную функцию CONVERT с детерминированным стилем данных.

  3. Для индексированного представления удалите представление, а затем переопределите его, используя явную функцию CONVERT с детерминированным стилем данных.

  4. Заново создайте индекс в измененном вычисляемом столбце или представлении.

Индексы

Параллельные индексные операции поддерживаются в выпусках SQL Server 2000 Developer Edition, SQL Server 2000 Standard Edition и SQL Server 2000 Enterprise Edition.

Параллельные индексные операции, которые создают, удаляют или перестраивают индексы, доступны только в выпусках SQL Server 2005 Developer и в SQL Server 2005 Enterprise Edition.

Пользователи, которые проводят обновление от выпуска SQL Server 2000 Standard Edition до выпуска SQL Server 2005 Standard Edition, должны учитывать, что операции, которые создают, удаляют или перестраивают индексы, выполняются последовательно в стандартном выпуске SQL Server 2005 и могут занимать больше времени.

Это не относится к инструкциям SELECT, INSERT, UPDATE, и DELETE. В выпуске SQL Server 2005 Standard Edition они будут выполняться параллельно.

После обновления до выпуска SQL Server 2005 Standard Edition отслеживайте операции создания, удаления или перестроения индексов. Может оказаться, что необходимо настроить сценарии обслуживания или плановые действия по обслуживанию, чтобы предоставить дополнительное время для этих операций.

Для выполнения параллельных индексных операций установите SQL Server 2005 Enterprise Edition.

предложение ORDER BY

Имена столбцов в предложении ORDER BY разрешаются в столбцы, перечисленные в списке выбора, независимо от наличия квалификаторов столбцов.

Например, следующий запрос выполняется без ошибки:

Копировать код
USE pubs
SELECT au_fname AS 'FName',
  au_lname AS 'LName'
FROM authors a
ORDER BY a.LName

SQL Server игнорирует квалификатор a в предложении ORDER BY и разрешает имя столбца LName в список выбора.

Имена и псевдонимы столбцов с квалификаторами разрешаются в столбцы таблиц, перечисленных в предложении FROM. Если в выражении order_by_expression отсутствует квалификатор, то оно должно быть уникальным во всех столбцах, перечисленных в инструкции SELECT.

Например, следующий эквивалентный запрос возвращает ошибку:

Копировать код
USE AdventureWorks
SELECT FirstName AS 'FName',
    LastName AS 'LName'
FROM Person.Contact p
ORDER BY p.LName

SQL Server не игнорирует квалификатор p в предложении ORDER BY и разрешает имя столбца LName в таблицы, перечисленные в предложении FROM. Однако предложение FROM не распознает, что имя столбца LName является псевдонимом столбца таблицы p.

Функция SERVERPROPERTY

Возвращаемым типом свойства ProductVersion в функции SERVERPROPERTY является varchar.

Возвращаемым типом свойства ProductVersion в функции SERVERPROPERTY является nvarchar.

sp_addtype

Любой пользователь может выполнять процедуру sp_addtype.

Пользователи должны быть членами роли базы данных db_ddladmin или db_owner для выполнения процедуры sp_addtype.

Чтобы разрешить пользователям создавать типы псевдонимов данных, следует произвести следующие изменения:

  • Чтобы использовать процедуру sp_addtype, добавьте пользователей к роли базы данных db_ddladmin или db_owner.

  • Чтобы создать тип псевдонима данных посредством использования CREATE TYPE, предоставьте пользователям разрешение CREATE TYPE, а также предоставьте разрешение ALTER пользователям целевой схемы.

sp_altermessage

Процедуру sp_altermessage можно использовать для определения необходимости записи системного сообщения (сообщения с идентификатором Message ID < 50000) в журнал приложений Windows.

Процедуру sp_altermessage нельзя использовать для изменения поведения регистрации системных сообщений (сообщений с идентификатором Message ID < 50000). Для аудита системных сообщений используйте трассировку SQL и класс события «User Error Message Event Class». Дополнительные сведения по обновлению компонентов SQL Server см. в разделе Знакомство с трассировкой SQL.

sp_changedbowner

Только члены фиксированной серверной роли sysadmin, фиксированной роли базы данных db_owner или члены обоих фиксированных ролей базы данных db_ddladmin и db_securityadmin могут выполнять процедуру sp_changeobjectowner.

Пользователю, который может выполнить эту хранимую процедуру как член фиксированных ролей базы данных db_ddladmin и db_securityadmin, также нужно предоставить разрешение CONTROL на защищаемый объект. Выполнение процедуры sp_changeobjectowner без разрешения CONTROL на целевой объект вызовет сбой выполнения и выведет следующее сообщение об ошибке:

«Msg 15247, Level 16, State 1, Procedure sp_changeobjectowner, Line 17

У пользователя нет разрешения на выполнение этого действия».

sp_help

Процедура sp_help возвращает один результирующий набор для функций.

Процедура sp_help возвращает два результирующих набора для функций. Дополнительный результирующий набор предназначен для параметров функций.

sysindexes

Таблица sys.sysindexes включена для обратной совместимости. Однако изменения в SQL Server 2005 препятствуют полной обратной совместимости представления с предыдущими версиями SQL Server.

Системные метаданные

Члены роли public могут запрашивать системные таблицы и отображать метаданные из каталога.

Пользователи, запрашивающие каталог, могут видеть только строки метаданных тех объектов, владельцами которых они являются, или объектов, на которые они имеют некоторые разрешения, или объектов, для которых они имеют права доступа в рамках членства в роли. Дополнительные сведения и рекомендуемые корректирующие действия см. в разделах Настройка видимости метаданных и Устранение неполадок, связанных с видимостью метаданных.

Системные таблицы

Системные таблицы имеют тип 'S'.

Системные таблицы доступны как совместимые представления и имеют тип 'V'. Инструкции, которые запрашивают системные таблицы и включают критерий поиска type = 'S', завершатся ошибкой.

Измените критерий поиска инструкции на type = 'V'

или

выполните миграцию данных в новые представления каталога или динамического административного предстваления. Дополнительные сведения по обновлению компонентов SQL Server см. в разделе Сопоставление системных таблиц сервера SQL Server 2000 системным представлениям сервера SQL Server 2005.

Подсказка TABLOCK при массовом импорте через bcp, BULK INSERT или OPENROWSET(BULK...)

При массовом импорте в таблицу с непустым кластеризованным индексом подсказка TABLOCK игнорируется.

При массовом импорте в таблицу с непустым кластеризованным индексом подсказка TABLOCK запрашивает блокировку X для таблицы. Это предотвращает параллельное выполнение массового импорта. Если в этом случае необходимо параллельное выполнение массового импорта, не указывайте подсказку TABLOCK. Дополнительные сведения о параллельном выполнении массовой загрузки см. в разделе Рекомендации по оптимизации массового импорта данных.

Триггеры

Прямая рекурсия триггеров происходит только тогда, когда триггер срабатывает и выполняет действие, вызывающее повторное срабатывание того же триггера.

Прямая рекурсия триггеров возникает в одном из следующих случаев:

  • Триггер срабатывает и выполняет действие, которое вызывает новое срабатывание того же триггера.

  • Вызывается тот же триггер, но после того, как вызван триггер другого типа (AFTER или INSTEAD OF).

Косвенная рекурсия возникает, когда триггер срабатывает и выполняет действие, которое вызывает срабатывание другого триггера того же типа (AFTER или INSTEAD OF). Второй триггер выполняет действие, вызывающее повторное срабатывание исходного триггера.

Дополнительные сведения см. в разделе «Рекурсивные триггеры» подраздела Использование вложенных триггеров.

Триггеры

При выполнении инструкции UPDATE или DELETE для локального или распределенного секционированного представления, срабатывают все триггеры типа UPDATE или DELETE, определенные для базовых таблиц данного представления, В том числе триггеры таблиц, на которых операция обновления или удаления не отразится.

Если инструкция UPDATE или DELETE выполняется для секционированного представления, триггеры типа UPDATE и DELETE срабатывают только в том случае, если базовой таблицы, для которой определен триггер, коснулась данная операция обновления или удаления. Дополнительные сведения см. в разделе Выполнение триггера DML.

Функция UPDATE()

Функция UPDATE() не определяет изменения в столбцах timestamp. Для этих столбцов предложение IF UPDATE() внутри тела триггера возвращает значение FALSE независимо от того, обновились ли столбцы.

Функция UPDATE() определяет изменения в столбцах timestamp. Для этих столбцов предложение IF UPDATE() внутри тела триггера DML возвращает значение TRUE, если столбцы обновились.

Пользовательские функции

В пользовательских функциях не могут использоваться недетерминированные встроенные системные функции.

В пользовательские функции Transact-SQL может входить большинство недетерминированных встроенных системных функций. Полный список разрешенных встроенных функций см. в разделе Создание пользовательских функций (Database Engine).

Типы данных varchar, nvarchar и varbinary

Строка или двоичное значение нулевой длины, используемые в качестве определения вычисляемого столбца таблицы, создают столбец типа varchar(0), nvarchar(0) или varbinary(0).

Строка или двоичное значение нулевой длины, используемые в качестве определения вычисляемого столбца таблицы, создают столбец типа varchar(1), nvarchar(1) или varbinary(1). Это изменение относится только к типам данных вычисляемых столбцов, но не к вычисляемому значению.

Внесите изменения в приложения, которые проверяют длину вычисляемого столбца и полагаются на минимальную длину столбца в 1 байт для столбцов типа varchar и varbinary, и в 2 байта для столбцов типа nvarchar.

Доступ к виртуальным таблицам

К виртуальным таблицам могут получать доступ гости и члены роли public.

Для доступа к виртуальной таблице, такой как sysprocesses, требуются разрешения VIEW SERVER STATE и SELECT.

Предложение WITH CHECK OPTION для представлений

Операции INSERT и UPDATE допускаются для представлений, для которых указано предложение WITH CHECK OPTION и которые создаются с помощью удаленной таблицы, даже когда эти операции выполняются вне рамок инструкции SELECT представления.

SQL Server 2005 подтверждает предложение WITH CHECK OPTION, когда операции INSERT и UPDATE выполняются на представлениях, созданных с помощью таблицы из удаленных источников данных.

Если операции INSERT и UPDATE дадут сбой на представлениях, созданных с помощью удаленной таблицы, из-за предложения WITH CHECK OPTION и такое поведение необходимо будет исправить, измените представление, не указывая предложение WITH CHECK OPTION.

Дополнительные сведения см. в разделах CREATE VIEW (Transact-SQL), ALTER VIEW (Transact-SQL) и Изменение данных через представление.

xp_cmdshell

Когда происходит ошибка в ходе выполнения xp_cmdshell, выводится сообщение об ошибке, но выполнение не прекращается.

Когда происходит ошибка в ходе выполнения xp_cmdshell, выводится сообщение об ошибке и выполнение прекращается.

См. также

Справочник

Критические изменения в функциях ядра СУБД SQL Server 2005
Устаревшие функции ядра СУБД в SQL Server 2005
Неподдерживаемые функции ядра СУБД в SQL Server 2005

Другие ресурсы

Обратная совместимость компонента SQL Server 2005 Database Engine
sp_dbcmptlevel (Transact-SQL)

Журнал изменений

Версия Журнал

17 июля 2006 г.

Новое содержимое:
  • В таблицу, содержащую список изменений поведения Transact-SQL, добавлена запись «Выражения в вычисляемых столбцах, ограничения CHECK и DEFAULT».

  • В таблице, содержащей список изменений поведения Transact-SQL, в столбце «Поведение в SQL Server 2005» изменено утверждение в записи «Типы данных varchar, nvarchar и varbinary». Тип данных вычисляемого столбца таблицы был изменен с nvarchar(2) на nvarchar(1).

5 декабря 2005 г.

Новое содержимое:
  • Добавлены сведения о недопустимых объявлениях курсоров.

  • Добавлено содержимое раздела «Смена языка по умолчанию для учетной записи sa».

  • Добавлен раздел «DBCC CHECKFILEGROUP».

  • Добавлен раздел «Подсказка TABLOCK при массовом импорте».

  • Добавлен раздел «Триггеры».

Измененное содержимое:
  • Изменено содержимое в подразделе «Типы данных varchar, nvarchar и varbinary».


SQL Server 2005 и SQL Server 2000

SQL Server 2005 и SQL Server 2000
Обновление до SQL Server 2005 > Обратная совместимость > Обратная совместимость компонента SQL Server 2005 Database Engine >

В этом разделе описывается поддержка в SQL Server 2005 следующих компонентов и функций прежних версий:

См... | Сведения о...
Распределенные объекты управления | Поддержка объектов DMO в этом выпуске SQL Server.
Запрос на английском языке | Поддержка запросов на английском языке в этом выпуске SQL Server.
Службы метаданных | Поддержка служб метаданных в этом выпуске SQL Server.


Распределенные объекты управления

Распределенные объекты управления |
 | См. также
Обратная совместимость > Обратная совместимость компонента SQL Server 2005 Database Engine > SQL Server 2005 и SQL Server 2000 >

Функция поддержки распределенных объектов управления (DMO) устанавливается Microsoft SQL Server 2005 как компонент прежних версий. Чтобы установить поддержку Компонентов прежних версий, при установке SQL Server на странице Компоненты для установки нажмите кнопку Дополнительно. Раскройте Клиентские компоненты и выберите пункт Компоненты прежних версий.

См. также

Справочник

Выпуски и компоненты SQL Server 2005
Возможности, поддерживаемые различными выпусками SQL Server 2005


Запрос на английском языке

Запрос на английском языке |
 | См. также
Обратная совместимость > Обратная совместимость компонента SQL Server 2005 Database Engine > SQL Server 2005 и SQL Server 2000 >

Запросы на английском языке в этом выпуске не поддерживаются. Эту функцию нельзя установить или обновить. При обновлении установки , которая включает функцию запросов на английском языке, эта функция остается без изменений.

См. также

Основные понятия

SQL Server 2005 и SQL Server 2000


Службы метаданных

Службы метаданных |
 | См. также
Обратная совместимость > Обратная совместимость компонента SQL Server 2005 Database Engine > SQL Server 2005 и SQL Server 2000 >

Службы метаданных 3.0 — это компонент , который более недоступен в . При обновлении не удаляются существующие таблицы репозитория в базе данных msdb. Однако механизм репозитория, который считывает и обновляет таблицы, недоступен после обновления, и таблицы репозитория также более недоступны. Для удаления неиспользуемых таблиц можно сделать это вручную. Таблицы репозитория могут быть идентифицированы с помощью префикса Rtbl.

Примечание.
Перед удалением таблиц убедитесь, что они не содержат пакетов служб DTS или метаданные служб SSAS, которые нужно сохранить.

См. также

Основные понятия

SQL Server 2005 и SQL Server 2000

Другие ресурсы

Удаление таблицы


Обратная совместимость служб SQL Server 2005 Analysis Services

Обратная совместимость служб SQL Server 2005 Analysis Services |
 | См. также
Обновление до SQL Server 2005 > Обратная совместимость >

Материалы данного раздела описывают изменения функциональности версий служб Analysis Services. Сюда относятся следующие изменения.

  • Функции, существовавшие в службах Analysis Services, но удаленные в службах .

  • Функции, сохраненные в службах SQL Server 2005 Analysis Services для обеспечения совместимости с предыдущими версиями; эти функции будут удалены в следующей версии SQL Server.

  • Функции, изменившиеся в службах SQL Server 2005 Analysis Services.

В этом разделе

Раздел | Описание
Неподдерживаемая функциональность служб Analysis Services в SQL Server 2005 | Описание функций, существовавших в службах SQL Server 2000 Analysis Services и удаленных в SQL Server 2005 Analysis Services.
Устаревшие функциональные возможности служб Analysis Services в SQL Server 2005 | Описание функций, сохраненных в службах SQL Server 2005 Analysis Services для обеспечения совместимости с предыдущими версиями; эти функции будут удалены в следующей версии SQL Server.
Изменение поведения служб Analysis Services в SQL Server 2005 | Описание функций, изменившихся в службах SQL Server 2005 Analysis Services.
Известные проблемы при обновлении служб SQL Server 2005 Analysis Services | Описание проблем, которые могут возникнуть при обновлении версии служб SQL Server 2000 Analysis Services до SQL Server 2005 Analysis Services.

См. также

Основные понятия

Миграция существующих баз данных служб Analysis Services

Другие ресурсы

Обратная совместимость служб SQL Server 2005 Analysis Services


Устаревшие функциональные возможности служб Analysis Services в SQL Server 2005

Устаревшие функциональные возможности служб Analysis Services в SQL Server 2005 |
 | См. также
Обновление до SQL Server 2005 > Обратная совместимость > Обратная совместимость служб SQL Server 2005 Analysis Services >

Следующие функции служб Analysis Services были сохранены в для целей обратной совместимости, но будут исключены в будущих версиях SQL Server. Устаревшие возможности не должны использоваться в новых приложениях.

Устаревшие возможности

Категория | Устаревшая функция | Комментарии
Свойства строки соединения | InsertInto | Исходный синтаксис строки соединения для заполнения локальных кубов.
Свойства строки соединения | CreateCube | Исходный синтаксис строки соединения для заполнения локальных кубов. Не поддерживается в ADOMD.NET.
Возможности | SQL Server 2000 PMML | Эта возможность заменена стандартным языком разметки моделей прогнозирования (PMML).
Многомерные выражения | Create Action | Поддерживается расширенный синтаксис, однако английские инструкции не допускают создания новых типов действий. Вместо них необходимо пользоваться DDL.
Многомерные выражения | CalculationPassValue |
Многомерные выражения | CalculationCurrentPass |
Алгоритмы интеллектуального анализа данных | Деревья решений: параметр Score_Method |
Прочее | Внутреннее свойство ячейки CELL_EVALUATION_LIST | Отсутствует в службах SQL Server 2005 Analysis Services.

См. также

Основные понятия

Миграция существующих баз данных служб Analysis Services

Другие ресурсы

Обратная совместимость служб SQL Server 2005 Analysis Services


Неподдерживаемая функциональность служб Analysis Services в SQL Server 2005

Неподдерживаемая функциональность служб Analysis Services в SQL Server 2005 |
 | См. также
Обновление до SQL Server 2005 > Обратная совместимость > Обратная совместимость служб SQL Server 2005 Analysis Services >

Следующие возможности Analysis Services были удалены из .

Неподдерживаемые возможности

Категория | Неподдерживаемая возможность | Комментарии
Свойства строки соединения | Место выполнения интеллектуального анализа | Оставлено для обратной совместимости, но игнорируется. Выполнение всегда производится на сервере.
Свойства строки соединения | Место интеллектуального анализа |
Свойства строки соединения | Файл журнала | Возможность «Файл журнала» заменена возможностью «Трассировка».
Свойства строки соединения | Место выполнения |
Свойства строки соединения | Уникальные меры по ключу |
Свойства строки соединения | Порог крупного уровня |
Возможности | Объединенные поставщики | Эта возможность заменена алгоритмами подключаемых модулей.
Возможности | Связанные кубы | Эта возможность заменена связанными группами показателей.
Возможности | Формулы пользовательского уровня | Эта возможность заменена сценариями многомерных выражений.
Возможности | Команды ролей кубов и баз данных | Больше не поддерживается.
Многомерные выражения | CreateVirtualDimension | Эта функция многомерных выражений больше не поддерживается.
Многомерные выражения | CreatePropertySet | Эта функция многомерных выражений больше не поддерживается.
Многомерные выражения | Ignore | В SQL Server 2000 Analysis Services эта функция была зарезервирована для будущего использования.
Многомерные выражения | With Cache Create Cache | Оставлена, но больше не поддерживается.
Прочее | Регистрация в службе Active Directory |
Прочее | Пропущенные уровни иерархий типа «родитель-потомок» | Свойство SkippedLevelsColumn, указывающее на то, сколько уровней нужно пропустить при создании подчиненного члена в иерархии типа «родитель-потомок», больше не поддерживается.

См. также

Основные понятия

Миграция существующих баз данных служб Analysis Services

Другие ресурсы

Обратная совместимость служб SQL Server 2005 Analysis Services


Известные проблемы при обновлении служб SQL Server 2005 Analysis Services

Известные проблемы при обновлении служб SQL Server 2005 Analysis Services |
 | См. также
Обновление до SQL Server 2005 > Обратная совместимость > Обратная совместимость служб SQL Server 2005 Analysis Services >

В следующей таблице перечисляются проблемы, которые могут возникнуть при обновлении базы данных служб SQL Server 2000 Analysis Services до SQL Server 2005 Analysis Services (SSAS). В приводимом ниже списке представлены проблемы обновления и краткое описание каждой из этих проблем точно в том же виде, как и в отчете, формируемом помощником по обновлению SQL Server 2005.

Тип проблемы | Описание проблемы
Невозможно выполнить миграцию объекта, зависящего от связанного объекта | Помощник по обновлению в службах Analysis Services не может выполнить миграцию связанных кубов и связанных измерений. Поэтому невозможно выполнить миграцию объектов, ссылающихся на связанный куб или на связанное измерение, так как нельзя выполнить миграцию связанного объекта, на котором основан исходный объект.
Если выполняется миграция нескольких иерархий в одно и то же измерение, функция автоматической проверки существования может дать другие результаты запроса | При миграции нескольких иерархий или виртуальных измерений в одно и то же измерение служб Analysis Services запрос к таким иерархиям, содержащимся в измерении, может дать результаты, отличные от результатов запроса к тем же иерархиям, если бы они были в службах SQL Server 2000 Analysis Services.
При использовании отключенных уровней способ обзора меняется | Службы Analysis Services больше не поддерживают скрытые или отключенные уровни иерархий. Миграция скрытых или отключенных уровней выполняется как миграция видимых и включенных уровней. Вычисления, включающие иерархии, содержащие такие уровни, могут дать непредвиденные результаты.
Для уровней группирования сегментация может отличаться | Автоматическое группирование в службах Analysis Services может вернуть другой набор группы элементов. Вычисления, основанные на этих группах элементов, могут дать непредвиденные результаты.
Преобразование из нейтрального языка в конкретный язык может дать непредвиденные результаты | Идентификаторы нейтрального языка, использовавшиеся в предыдущих версиях служб Analysis Services, в службах Analysis Services мигрируют в идентификаторы с конкретным языком. Миграция идентификаторов с нейтральным языком в идентификаторы с конкретным языком может изменить поведение переводов и параметров сортировки, приводя к непредвиденным результатам.
Команды ролей кубов не поддерживаются | Службы Analysis Services не поддерживают объекты команд ролей кубов и не выполняют миграцию команд из предыдущих версий.
Статистическая обработка формул пользовательского уровня происходит иначе. | Если куб содержит измерение с формулами пользовательского уровня, а также измерения, перед и после него, с нестандартными формулами элемента или с унарными операторами, тогда куб может вернуть результаты, отличные от результатов, возвращаемых в предыдущих версиях служб Analysis Services. Это происходит из-за того, что правила очередности вычислений изменились.
Миграция нестандартных формул элементов и пользовательских формул сверток выполняется в сценарий многомерных выражений | Пользовательские формулы сверток, нестандартные формулы элементов, формулы для всех элементов и формулы пользовательского уровня больше не поддерживаются как свойства измерений или уровней в службах Analysis Services.
Миграция нестандартных статистических выражений не выполняется | Миграция в Analysis Services не выполняется для агрегатов, которые в предыдущих версиях служб Analysis Services формировались вручную. Выполняется миграция только агрегатов, созданных мастером конструирования хранилищ.
Элементы данных всегда существуют в измерениях типа «родители-потомки» | Предыдущие версии служб Analysis Services давали возможность не включать элементы данных в измерения типа «родители-потомки». Элементы данных теперь нельзя исключить из измерений типа «родители-потомки».
Команды роли кубов не поддерживаются | Службы Analysis Services не поддерживают объекты команд ролей базы данных и не выполняют миграцию команд из предыдущих версий Analysis Services.
Миграция свойства DefaultMember выполняется в сценарий многомерных выражений | В предыдущих версиях служб Analysis Services элемент измерения по умолчанию указывался многомерным выражением, содержавшемся в свойстве измерения DefaultMember. В выпуске служб Analysis Services это свойство заменено функциональностью сценариев многомерных выражений и во время миграции это свойство обновляется в сценарий многомерного выражения.
Переименование измерений и иерархий при миграции может стать причиной других результатов запросов | Иерархии измерений в предыдущих версиях служб Analysis Services внутренне представлялись как отдельные измерения, и для их идентификации применялись соглашения по именованию. При миграции до версии служб Analysis Services вместо объединения иерархий измерений внутри родительского измерения может быть создано отдельное измерение с новым именем для каждой иерархии измерений, так как автоматическое существование приводит к правилам безопасности, отличным от правил, применявшимся в предыдущих версиях служб Analysis Services.
Миграция настроек детализации не выполняется | Хотя в службах Analysis Services детализация существует, миграция настроек детализации из предыдущих версий служб Analysis Services не выполняется.
Скрытые уровни после миграции становятся видимыми | Службы Analysis Services больше не поддерживают скрытые или отключенные уровни иерархий. Миграция скрытых или отключенных уровней выполняется как миграция видимых и включенных уровней. Вычисления, включающие иерархии, содержащие такие уровни, могут дать непредвиденные результаты.
Недопустимые объекты вызывают сбой миграции | База данных содержит недопустимые объекты. Если база данных содержит недопустимые объекты, миграция не может быть завершена.
Миграция связанных кубов не выполняется | Предыдущие версии служб Analysis Services поддерживали связанные кубы. В службах Analysis Services эта возможность заменена на связанные измерения и связанные группы показателей.
Уникальные имена элементов могут измениться во время миграции | СлужбыAnalysis Services во время миграции пытаются сохранить уникальные имена элементов, но имеются определенные обстоятельства, при которых уникальные имена элементов изменяются. Если уникальные имена элементов изменяются, клиентские приложения, многомерные выражения и другие свойства, зависящие от уникальных имен элементов, могут дать непредвиденные результаты.
Источники данных ODBC не поддерживаются | Хотя в предыдущих версиях служб Analysis Services допускалось использование источников данных ODBC, в службах Analysis Services эта возможность больше не поддерживается.
Миграция удаленных секций не была выполнена | Удаленные секции поддерживаются в службах Analysis Services, но их миграцию выполнить автоматически нельзя, пока удаленный сервер не будет обновлен до SQL Server 2005.
Некоторые параметры алгоритмов моделей интеллектуального анализа не поддерживаются | Некоторые параметры алгоритмов моделей интеллектуального анализа данных, которые были в предыдущих версиях служб Analysis Services, в службах Analysis Services больше не поддерживаются.
Характер выполнения некоторых функций многомерных выражений изменился | Из-за усовершенствований и изменений языка многомерных выражений в службах Analysis Services некоторые функции многомерных выражений больше не поддерживаются или выполняются не так, как в предыдущих версиях служб Analysis Services.
Настройка безопасности для верхнего уровня измерений не поддерживается | В предыдущих версиях служб Analysis Services можно было указать безопасность измерения таким образом, что пользователь видел верхний уровень не так, как верхний уровень иерархии. Элементы, защищенные с помощью настройки верхнего уровня, после миграции становятся видимыми.
Миграция исходных динамических библиотек пользовательских функций не выполняется, и эти библиотеки не регистрируются | Миграция пользовательских функций, зарегистрированных в предыдущих версиях служб Analysis Services, не выполняется.
Унарные операторы иерархий, не относящихся к типу «родители-потомки», поддерживаются частично | Унарные операторы иерархий, не относящихся к типу «родители-потомки», в службах Analysis Services не поддерживаются, если только не существует связи между атрибутами, являющимися источниками уровней в иерархии.
Виртуальные кубы не поддерживаются | Предыдущие версии служб Analysis Services поддерживали виртуальные кубы, объединенные представления подмножества показателей и измерений из одного или нескольких регулярных или связанных кубов. В службах Analysis Services эта возможность заменена на связанные группы показателей. Во время обновления виртуальные кубы мигрируют как связанные группы показателей.
Миграция содержимого таблицы обратной записи не выполнена | Структура таблиц обратной записи, создаваемых предыдущими версиями служб Analysis Services, обновлена в службах Analysis Services. Миграция данных из таблиц обратной записи, создаваемых предыдущими версиями служб Analysis Services, не может быть выполнена в новую структуру таблиц обратной записи.

См. также

Другие ресурсы

Обратная совместимость служб SQL Server 2005 Analysis Services


Изменение поведения служб Analysis Services в SQL Server 2005

Изменение поведения служб Analysis Services в SQL Server 2005 |
 | См. также
Обновление до SQL Server 2005 > Обратная совместимость > Обратная совместимость служб SQL Server 2005 Analysis Services >

В службах поведение некоторых функций изменилось по сравнению с предыдущими версиями Analysis Services. Эти изменения перечислены в приведенной ниже таблице.

Изменения в поведении

Возможность | Поведение в SQL Server 2000 | Поведение в SQL Server 2005
Обзор | Поддерживает скрытые или отключенные уровни иерархий. | Миграция скрытых или отключенных уровней выполняется как миграция видимых и включенных уровней. Вычисления, в которые входят иерархии с такими уровнями, могут возвращать непредвиденный результат.
Измерение | Поддерживает параметр, позволяющий не включать элементы данных в измерения типа «родители-потомки». | Элементы данных всегда существуют в измерениях типа «родители-потомки» и их больше нельзя исключить из этих измерений.
Многомерные выражения | Функция: CreateVirtualDimension | Выражение вернет значение Error.
Многомерные выражения | Функция: CreatePropertySet | Выражение вернет значение Error.
Многомерные выражения | Инструкция: With Cache | Синтаксис допустим, но ничего не делает.
Многомерные выражения | Инструкция: Create Cache | Синтаксис допустим, но ничего не делает.
Многомерные выражения | Вычисление правил приоритета. | Вычисление правил приоритета отличается от предыдущих версий служб Analysis Services. Из-за приведенной выше пользовательской свертки выражения могут возвращать результаты, которые будут отличаться от результатов в предыдущих версиях служб Analysis Services.
Безопасность | Поддерживает параметр, позволяющий задавать уровень защиты измерения, так что пользователь сможет просматривать верхний уровень, отличный от верхнего уровня в иерархии. | Верхний уровень для безопасности измерения не поддерживается. Элементы защищены с помощью настройки верхнего уровня как видимого после переноса.
Прочее | Функции обновления AutoCommit и AutoRollback. | Пытается зафиксировать сбой несуществующей транзакции. В службах SQL Server 2000 Analysis Services инструкция UPDATE создавала собственную транзакцию. В службах SQL Server 2005 Analysis Services она этого не делает.

См. также

Основные понятия

Миграция существующих баз данных служб Analysis Services

Другие ресурсы

Обратная совместимость служб SQL Server 2005 Analysis Services


Обратная совместимость служб Reporting Services

Обратная совместимость служб Reporting Services |
 | См. также
Обновление до SQL Server 2005 > Обратная совместимость >

В этом разделе описываются различия в поведении между версиями служб SQL Server Reporting Services. Здесь рассмотрены функции, которые больше не доступны или запланированы к удалению в следующем выпуске. Также описаны фундаментальные изменения в продукте, которые полностью изменят пользовательское приложение, использующее функции служб Reporting Services.

В этом разделе

  • Устаревшие возможности служб SQL Server 2005 Reporting Services

  • Неподдерживаемая функциональность в службах SQL Server 2005 Reporting Services

  • Критические изменения в службах SQL Server 2005 Reporting Services

  • Изменения в работе служб SQL Server 2005 Reporting Services

См. также

Основные понятия

Обновление служб Reporting Services

Другие ресурсы

Обратная совместимость
Обновление компонентов SQL Server
Улучшенные возможности служб Reporting Services


Устаревшие возможности служб SQL Server 2005 Reporting Services

Устаревшие возможности служб SQL Server 2005 Reporting Services |
 | См. также
Обновление до SQL Server 2005 > Обратная совместимость > Обратная совместимость служб Reporting Services >

Дата обновления: 5 декабря 2005 г.

В данном разделе описаны функции служб Reporting Services, удаление которых запланировано в следующем выпуске SQL Server. В SQL Server 2005 все еще доступны следующие возможности.

Конечные точки веб-служб сервера отчетов SQL Server 2000

В этой версии веб-службы сервера отчетов SQL Server 2000 считаются устаревшими. Ранее существовавшая конечная точка заменена двумя новыми: ReportingService2005 и ReportExecutionService.

Новые конечные точки реализуют все функции, доступные в предыдущих версиях, а также новые возможности, появившиеся в SQL Server 2005. Дополнительные сведения см. в разделах Улучшенные возможности программирования служб Reporting Services и Report Server Web Service Endpoints электронной документации по SQL Server.

Модуль подготовки отчетов HTML OWC

Модуль подготовки отчетов в формате HTML для веб-компонентов Office (OWC) в данном выпуске является устаревшим. При обновлении с предыдущего выпуска он остается доступным. При новой установке модуль подготовки отчетов в виде HTML веб-компонентов Office отсутствует в числе параметров экспорта. Чтобы использовать устаревшие модули в новой установке, в файлы RSReportServer.config и RSReportDesigner.config можно добавить записи, обеспечивающие доступность модуля. В следующем примере показана запись, которую необходимо добавить:

Копировать код
<Extension Name="HTMLOWC" Type="Microsoft.ReportingServices.Rendering.HtmlRenderer.HtmlOWCRenderingExtension,Microsoft.ReportingServices.HtmlRendering" Visible="false"/>

Поддержка веб-обозревателя Internet Explorer 5.5

Эта версия веб-обозревателя Microsoft Internet Explorer для Windows является устаревшей в SQL Server 2005 с пакетом обновления 2 (SP2). Дополнительные сведения о поддерживаемых типах веб-обозревателей см. в разделе Поддержка веб-обозревателей в службах Reporting Services электронной документации по SQL Server.

Модуль подготовки отчетов в формате HTML 3.2

Формат HTML 3.2 в модуле подготовки отчетов HTML в данной версии является устаревшим. Теперь невозможно выбрать HTML 3.2 в качестве параметра экспорта на панели инструментов отчета. Чтобы подготовить отчеты к просмотру в формате HTML 3.2, необходимо указать это в URL-адресе отчета, используя параметр Format. Дополнительные сведения о том, как определить модуль подготовки отчетов, см. в разделе Specifying a Rendering Format in a URL электронной документации по SQL Server.

Поддержка программой RS конечной точки веб-службы сервера отчетов SQL Server 2000

В данном выпуске служб Reporting Services программа командной строки сервера сценариев для сервера отчетов (rs.exe) поддерживает использование конечной точки SOAP из предыдущего выпуска. В последующих выпусках поддержка этой конечной точки будет удалена из продукта. Следует использовать новые конечные точки SOAP всюду, где это возможно, во всех вновь создаваемых и обновляемых сценариях. Дополнительные сведения см. в разделах Report Server Web Service Endpoints и Программа rs электронной документации по SQL Server.

См. также

Основные понятия

Обновление служб Reporting Services

Другие ресурсы

Обновление компонентов SQL Server
Обратная совместимость служб Reporting Services
Обратная совместимость

Журнал изменений

Версия Журнал

12 декабря 2006 г.

Новое содержимое:
  • Примечание о признании веб-обозревателя Internet Explorer 5.5. устаревшим.

5 декабря 2005 г.

Новое содержимое:
  • Уведомление об отмене конечных точек веб-служб сервера отчетов SQL Server 2000.


Неподдерживаемая функциональность в службах SQL Server 2005 Reporting Services

Неподдерживаемая функциональность в службах SQL Server 2005 Reporting Services |
 | См. также
Обновление до SQL Server 2005 > Обратная совместимость > Обратная совместимость служб Reporting Services >

В этом разделе описаны возможности служб SQL Server Reporting Services, которые больше недоступны в SQL Server 2005.

Rsactivate.exe

Rsactivate.exe — это программа командной строки, которая использовалась для инициализации одного или нескольких экземпляров сервера отчетов, которые были частью одной веб-фермы. Из-за изменений в процессе выполнения инициализации и настройки эта программа больше не нужна и не поставляется. Для создания масштабного развертывания на сервере SQL Server 2005 воспользуйтесь программой настройки служб Reporting Services. Дополнительные сведения об изменениях инициализации см. в разделе Изменения в работе служб SQL Server 2005 Reporting Services. Дополнительные сведения о настройке нескольких серверов отчетов, использующих одну базу данных сервера отчетов, см. в разделе Настройка масштабного развертывания сервера отчетов.

См. также

Основные понятия

Обновление служб Reporting Services

Другие ресурсы

Обновление компонентов SQL Server
Обратная совместимость служб Reporting Services
Обратная совместимость


Критические изменения в службах SQL Server 2005 Reporting Services

Критические изменения в службах SQL Server 2005 Reporting Services |
 | См. также
Обновление до SQL Server 2005 > Обратная совместимость > Обратная совместимость служб Reporting Services >

Дата обновления: 12 декабря 2006 г.

В данном разделе описаны изменения в функциональности служб Reporting Services, нарушающие работу пользовательских приложений, сценариев или отчетов.

Отсутствие поддержки для действий детализации или ссылок на закладки в верхнем или нижнем колонтитулах

В версиях SQL Server 2005 и SQL Server 2005 с пакетом обновления 1 (SP1) службы Reporting Services не поддерживают действия детализации и ссылки на закладки в верхнем и нижнем колонтитулах. Это изменение является критическим для отчетов, созданных в службах Reporting Services SQL Server 2000.

В пакете обновления 2 эта проблема была частично решена. Действия детализации в верхнем и нижнем колонтитулах страницы поддерживаются для отчетов, выполняющихся по требованию, но не для отчетов, выполняющихся как моментальные снимки. Моментальные снимки, содержащие детализацию или ссылки на закладки в верхнем или нижнем колонтитулах, должны быть созданы заново для реализации функциональных возможностей детализации.

  1. Запустите диспетчер отчетов или среду Management Studio.

  2. Определите местоположение отчета и откройте страницу параметров выполнения этого отчета.

  3. Установите флажок Создать моментальный снимок отчета при сохранении этой страницы.

  4. Нажмите кнопку Применить.

  5. Повторите эти шаги для всех отчетов, выполняемых в виде моментального снимка и содержащих детализацию или ссылки на закладки в верхнем или нижнем колонтитулах.

Поставщик инструментария управления Windows (WMI) для сервера отчетов из состава SQL Server 2000 не поддерживается

Службы Reporting Services включают поставщик WMI, который можно использовать для программной настройки среды, в которой выполняется сервер отчетов. Выпуск служб Reporting Services в составе SQL Server 2005 включает новейшую версию поставщика WMI, полностью заменяющую более раннюю версию. Первоначальный выпуск из состава SQL Server 2000 в данной версии SQL Server не поддерживается.

Новые ограничения на проверку подлинности для модулей обработки данных

Данный выпуск служб Reporting Services содержит новые ограничения на обработку учетных данных в некоторых модулях обработки данных:

  • Невозможно настроить соединение с источником данных служб Analysis Services на использование учетных данных базы данных. В случае использования упаковщика ADOMD соединение завершится неудачей.

  • Невозможно настроить соединение с источником XML-данных на использование учетных данных базы данных. В случае если учетные данные не заданы и не определена учетная запись для автоматического выполнения, запрос будет выполнен с использованием анонимного доступа.

  • Модули обработки данных .NET от сторонних поставщиков (например, DB2.NET, Oracle ODP.NET, Teradata) выдают явный сбой обработки данных, если учетные данные базы данных передаются в строке соединения, а учетная запись для автоматического выполнения не настроена.

  • Пользовательские модули обработки данных, реализующие интерфейс IDBConnection (но не IDBConnectionExtension), выдают явный сбой обработки данных в каждом случае, если учетная запись для автоматического выполнения не настроена.

  • Во всех случаях, когда запросы на соединение производятся служебной учетной записью (то есть для сетевого соединения с источником данных применяется контекст безопасности служебной учетной записи), службы Reporting Services удаляют привилегии администратора для этой учетной записи перед отправкой запроса.

Для настройки учетной записи для автоматического выполнения используется программа настройки служб Reporting Services или программа rsconfig. Дополнительные сведения см. в разделах Указание соединений для пользовательских модулей обработки данных и Настройка учетной записи для автоматической обработки отчетов.

Выражения, содержащие ссылку на результат объекта в ошибках компиляции отчетов

Отчеты, в которых используются выражения для установки свойства Action какого-либо элемента, больше не компилируются, если такое выражение включает ссылку Me.Value. При попытке обновления отчетов, содержащих Me.Value в выражениях свойства Action, будут выданы ошибки вроде следующей: «Выражение Value для текстового поля ‘textbox1’ содержит ошибку: [BC30456] 'Value' не является членом 'ReportExprHostImpl.textbox1_TextBoxExprHost.DataValue1_DataValueExprHost'. (rsCompilerErrorInExpression).».

Чтобы избежать подобных ошибок и обновить отчеты, необходимо переписать выражения Action с заменой Me.Value на фактическое выражение значения. В следующем примере показано, как заменить Me.Value в выражении с использованием текстового поля на фактическое выражение значения: =iif(Fields!Name.Value = 0, "Solid", "None").

Поддержка параметров с несколькими значениями может привести к разрыву параметров с одним значением в отчетах

Поддержка параметров с несколькими значениями — новая функция, впервые представленная в данной версии. В случае использования устаревшего конечного пункта SOAP и установки либо считывания параметров с несколькими значениями в коде, такие параметры теперь будут отправлены обратно. В предыдущей версии при указании нескольких параметров возвращался только первый из них. Необходимо учесть, что после обновления предполагаемые параметры с одним значением могут возвращать несколько значений. Рекомендуется проверить существующие вызовы метода Render, чтобы определить, используются ли параметры с одним или с несколькими значениями. Также следует протестировать все отчеты, содержащие параметры, чтобы убедиться, что параметры с одним значением работают нормально.

Обновление параметров с помощью метода SetReportParameters

В предыдущем выпуске при обновлении свойства параметра нужно было повторно задавать все его настройки. Если отчет содержал параметры на основе запросов или вычислений, обновление свойства параметра с одним значением обычно означало необходимость повторной публикации отчета. Результатом сбоя повторной публикации отчета были отчеты, в которых отсутствовали установленные по умолчанию значения параметра на основе запросов после того, как свойство параметра было изменено.

В данной версии можно обновить конкретное свойство параметра без необходимости повторного указания всех его свойств. Значения по умолчанию больше не устанавливаются в NULL, если свойство DefaultValues не задано. Обратите внимание, что это изменение может критически влиять на код или сценарии, использующие устаревшую конечную точку SOAP, если в них обрабатывается ссылка на NULL.

Добавление элемента «Выбрать все» для многозначных параметров

В отчете, созданном службами Reporting Services SQL Server 2005, флажок Выбрать все добавлялся автоматически при создании списка всех доступных значений для параметра отчета с несколькими значениями. Установкой флажка Выбрать все выбирались все доступные значения. Снятием флажка Выбрать все сбрасывались все доступные значения. При обновлении до SQL Server 2005 с пакетом обновления 1 (SP1) флажок Выбрать все становился недоступным. В SQL Server 2005 с пакетом обновления 2 (SP2) флажок Выбрать все был восстановлен. При обновлении клиента для создания отчетов до версии с пакетом обновления 2 (SP2) флажок Выбрать все автоматически добавляется в раскрывающийся список доступных значений в просмотре отчета в конструкторе отчетов. После обновления сервера отчетов до версии с пакетом обновления 2 (SP2) можно использовать средства сервера отчетов (диспетчер отчетов, построитель отчетов и среду SQL Server Management Studio) для просмотра всех существующих и новых отчетов, использующих функциональную возможность Выбрать все. Нет необходимости в повторной публикации существующих отчетов для восстановления функциональности Выбрать все. Если обновление средств выполнено, но флажок Выбрать все не отображается, возможно, причина в соединении с сервером отчетов версии с пакетом обновления 1 (SP1).

Обращение к расширенным свойствам из модуля обработки данных служб Microsoft SQL Server Analysis Services

Если в отчете служб SQL Server 2005 Reporting Services необходимо было обратиться к расширенному свойству Key поля источника данных служб Analysis Services, использовался следующий синтаксис: Fields!FieldName("MEMBER_KEY"). После обновления до SQL Server 2005 с пакетом обновления 1 (SP1) этот синтаксис больше не возвращает значение свойства Key. Теперь нет необходимости в поддержке этого обходного пути. Вместо этого необходимо изменить синтаксис обращения к расширенному свойству поля Key на один из следующих: Fields!FieldName.Key или Fields!FieldName("Key").

Журнал изменений

Версия Журнал

12 декабря 2006 г.

Новое содержимое:
  • Сведения об отсутствии поддержки действий детализации.

Измененное содержимое:
  • Восстановление параметра «Выбрать все» в версии с пакетом обновления 2 (SP2).

См. также

Основные понятия

Обновление служб Reporting Services

Другие ресурсы

Обновление компонентов SQL Server
Обратная совместимость служб Reporting Services
Обратная совместимость


Изменения в работе служб SQL Server 2005 Reporting Services

Изменения в работе служб SQL Server 2005 Reporting Services |
 | См. также
Обновление до SQL Server 2005 > Обратная совместимость > Обратная совместимость служб Reporting Services >

Этот раздел посвящен основным изменениям функций служб SQL Server Reporting Services, которые могут отразиться на работе.

Изменения в процессах инициализации и шифрования

Веб-служба сервера отчетов больше не используется для инициализации установки служб Reporting Services. В этом выпуске инициализация выполняется только службой Windows сервера отчетов. Когда веб-службе сервера отчетов требуется выполнить шифрование или расшифровку, она обращается к службе Windows сервера отчетов, которая получает ключи и выполняет запрошенную операцию. Прежде чем выполнить этот вызов, веб-служба проверяет, запущена ли она под учетным именем, указанным в параметре WebServiceAccount в файле конфигурации RSReportServer.config. Если учетная запись, под которой выполняется веб-служба, не соответствует этому значению, она возвращает ошибку несоответствия учетного имени.

Эта особенность выполнения инициализации усиливает зависимость веб-службы сервера отчетов от службы Windows сервера отчетов. Запуск службы Windows сервера отчетов теперь обязателен для большинства операций веб-службы. Дополнительные сведения см. в разделе Инициализация сервера отчетов.

Команды программы установки

В этом выпуске сокращено число операций, которые могут быть выполнены через командную строку программы установки. Установка через командную строку больше не используется для установки и развертывания установки, включающей удаленные компьютеры. Она также больше не выполняет развертывание установки веб-фермы серверов отчетов. Если раньше для развертывания установки служб Reporting Services использовалась программа установки, то теперь необходимо пользоваться для этого альтернативными средствами и методами. Если имеются пакетные файлы и сценарии для развертывания компонентов служб Reporting Services, то после перехода на новую версию они перестанут работать.

Свойство DefaultValueQueryBased теперь доступно и для чтения, и для записи

Свойство DefaultValueQueryBased — свойство типа Boolean, указывающее, основаны ли значения параметра по умолчанию на запросе. В предыдущих выпусках это свойство было доступно только для чтения. Теперь оно изменено так, что стало доступно для записи, позволяя программно устанавливать значение для опубликованного отчета. При использовании этого свойства в коде проверьте, правильно ли работает приложение.

Модуль подготовки отчетов Excel поддерживает двоичный формат обмена файлами (BIFF)

Модуль подготовки отчетов Excel теперь формирует отчеты для просмотра в собственном формате Microsoft Excel, снимая большинство ограничений, которые имелись в предыдущих версиях.

Изменения, касающиеся высоты строк заголовка

В предыдущем выпуске первая строка многострочного заголовка определяла высоту для всех строк, входящих в заголовок (то есть высота строки была фиксированной и определялась исходя из высоты первой строки заголовка). Теперь высота всех строк может быть переменной. Если существуют отчеты, содержащие многострочные заголовки, проверьте, правильно ли они отображаются после перехода на новую версию.

Начальные пробельные символы в названиях определения роли

В предыдущей версии в определении роли допускалось наличие начальных пробелов. В этой версии больше не поддерживаются начальные пробелы при создании новых имен ролей. Если имеются определения ролей, начинающиеся с пробелов, они будут продолжать работать. Это изменение было сделано в связи с особенностями работы метода DeleteRole. Если DeleteRole обнаруживает пробелы в начале названия определения роли, он удаляет ее.

См. также

Основные понятия

Обновление служб Reporting Services

Другие ресурсы

Обновление компонентов SQL Server
Обратная совместимость служб Reporting Services
Обратная совместимость


Обратная совместимость служб SQL Server 2005 Integration Services

Обратная совместимость служб SQL Server 2005 Integration Services |
 | См. также
Обновление до SQL Server 2005 > Обратная совместимость >

Дата обновления: 17 июля 2006 г.

Службы SQL Server 2005 Integration Services (SSIS) обеспечивают управление, поддержку среды выполнения и конструирования пакетов служб DTS, созданных при помощи инструментальных средств сервера SQL Server 2000 и объектной модели.

Общая совместимость между службами DTS и SSIS

  • Управление пакетами служб DTS

  • Поддержка пакетов служб DTS во время выполнения

    • Установка поддержки пакетов служб DTS во время выполнения

    • Запуск пакетов служб DTS из командной строки

    • Выполнение пакетов служб DTS из пакетов служб Integration Services

  • Поддержка пакетов служб DTS во время проектирования

  • Миграция

    • Миграция команд dtsrun в команды dtexec

    • Миграция пакетов служб DTS в пакеты служб Integration Services

  • Ограниченная поддержка

    • Поддержка служб Integration Services в SQL Server 2005 Express Edition

    • Поддержка пакетов репозитория

    • Поддержка назначений ODBC

Общая совместимость между службами DTS и SSIS

Так как службы Integration Services являются полностью новым продуктом, а не обновлением версии, конфликтов программного обеспечения между службами DTS и SSIS не возникнет.

  • Можно установить службы DTS и SSIS на одном сервере.

  • Можно выполнять пакеты служб DTS и SSIS на одном сервере, где установлены оба продукта. Можно выполнять пакеты служб DTS, даже если инструменты SQL Server 2000 отсутствуют, используя обновленную версию среды выполнения служб DTS, устанавливаемую с Integration Services.

  • Можно сохранять пакеты служб DTS в базе данных MSDB экземпляра SQL Server 2000 или SQL Server 2005. Пакеты служб SSIS можно сохранять только в экземпляре SQL Server 2005.

  • Можно изменять пакеты служб DTS, даже если средства SQL Server 2000 отсутствуют, используя обновленную версию конструктора служб DTS, доступную для загрузки. Нельзя изменять пакеты служб DTS в среде Business Intelligence Development Studio. Пакеты SSIS можно изменять только в BI Development Studio.

Управление пакетами служб DTS

Можно управлять пакетами служб DTS из среды SQL Server Management Studio независимо от того, хранятся ли они в экземпляре сервера SQL Server 2000 или импортированы в экземпляр сервера SQL Server 2005. Чтобы просматривать пакеты служб DTS в среде Management Studio, подключитесь к экземпляру SQL Server и просмотрите в обозревателе объектов в узле служб преобразования данных Management\Legacy\Data.

Выбрав отдельный пакет служб DTS в среде Management Studio, можно открыть его для внесения изменений, выполнить миграцию, выполнить экспорт в структурированный файл хранения или удалить.

Выбрав узел служб DTS в среде Management Studio, можно открывать пакеты, импортировать их в SQL Server из структурированных файлов хранилища или запустить мастер миграции пакетов.

Примечание.
Для изменения пакетов служб DTS необходима отдельная загрузка компонентов конструирования служб DTS. См. раздел Установка поддержки времени проектирования для пакетов служб SQL Server 2000 DTS. Пакеты служб DTS нельзя открывать или изменять в среде BI Development Studio.

Установка поддержки запуска для пакетов служб DTS SQL Server 2000

Можно выполнять пакеты служб DTS и пакеты служб SSIS на одном компьютере.

Когда для установки выбираются Службы Integration Services, программа установки также устанавливает поддержку для пакетов служб DTS, включая поддержку среды выполнения служб DTS и перечисления пакетов DTS в среде SQL Server Management Studio. Поддержка в среде выполнения улучшена для обеспечения возможности доступа пакетов служб DTS к источникам данных SQL Server 2005.

Дополнительные сведения см. в разделе Как обеспечить поддержку пакетов служб DTS.

Примечание.
Хотя поддержка служб SQL Server 2000 DTS устанавливается автоматически при выборе служб Integration Services для установки, некоторые настройки реестра и среды, необходимые для работы DTS, во время или после установки удаляются, если проводится обновление последнего экземпляра SQL Server 2000 на компьютере до SQL Server 2005. Чтобы восстановить эти настройки, выберите пункт «Обратная совместимость Microsoft SQL Server 2005» в списке Установка и удаление программ панели управления, нажмите кнопку Изменить и выберите параметр Исправить на странице мастера Сопровождение программы.

В число устанавливаемых файлов, служащих для обеспечения обратной совместимости, входят также поддержка времени выполнения для задачи «Обработка средствами SQL Server 2000 Analysis Services» и зависимый от нее модуль, объекты принятия решений (DSO). Однако в него не входит поддержка времени проектирования для изменения пакетов служб DTS, содержащих задачу «Обработка средствами SQL Server 2000 Analysis Services». Можно изменять пакеты, содержащие эту задачу, только если службы Analysis Services SQL Server 2000 установлены на том же компьютере.

В число файлов обратной совместимости не входит задача «Прогноз интеллектуального анализа данных SQL Server 2000».

Запуск пакетов служб DTS из командной строки

Пакеты служб SQL Server 2000 DTS могут быть запущены из командной строки. Службы SQL Server 2005 Integration Services (SSIS) устанавливают программу SQL Server 2000 dtsrun.exe при установке поддержки DTS во время выполнения.

Выполнение пакетов служб DTS из пакетов служб Integration Services

Пакеты, созданные при помощи средств сервера SQL Server 2000, могут выполняться как часть решения преобразования данных сервера SQL Server 2005. Службы Integration Services содержат задачу «Выполнение пакета служб DTS 2000» для запуска пакетов служб DTS из пакетов SQL Server 2005 Integration Services.

Дополнительные сведения см. в разделе Задача «Выполнение пакета служб DTS 2000».

Установка поддержки времени проектирования для пакетов DTS SQL Server 2000

Службы SQL Server 2005 Integration Services (SSIS) не устанавливают конструктор DTS. Обновленная версия конструктора пакетов служб DTS доступна в виде отдельного файла, загружаемого из Интернета. Загрузить компоненты конструктора служб DTS Microsoft SQL Server 2000 .

Сведения об управлении определенными свойствами приложения DTS, влияющими на среду конструирования DTS, см. в разделе Установка свойств приложений служб DTS.

Миграция командных строк для выполнения пакетов

Сведения о соответствии параметров командной строки программы SQL Server 2000 dtsrun параметрам командной строки программы SQL Server 2005 dtexec см. в разделе Сопоставление параметров команд программ dtsrun и dtexec.

Миграция пакетов служб DTS

SQL Server 2005 предоставляет мастер миграции пакетов для осуществления миграции пакетов служб DTS SQL Server 2000 в пакетный формат Integration Services. Многие пакеты можно полностью перенести в SQL Server 2005, особенно те пакеты служб DTS, которые используют задачи, соединения и другие объекты, имеющие равноценные аналоги в SQL Server 2005. Другие пакеты можно успешно перенести путем инкапсуляции конкретных задач или функций, которые не могут быть перенесены посредством задачи «Выполнение пакетов служб DTS 2000». Перед выполнением мастера миграции пакетов может понадобиться установить и выполнить помощник обновления для анализа существующих пакетов, чтобы выявить возможные проблемы миграции.

Дополнительные сведения о помощнике по обновлению см. в разделе Использование помощника по обновлению для подготовки к обновлениям.

Примечание.
Мастер миграции пакетов доступен в следующих выпусках SQL Server 2005: Standard Edition, Enterprise Edition, Developer Edition.

Примечание.
Помощник по обновлению не сможет проанализировать, а мастер миграции пакетов не сможет выполнить миграцию пакетов служб DTS, хранящихся в базе данных msdb экземпляра SQL Server 7.0. Однако помощник по обновлению сможет проанализировать, а мастер миграции пакетов сможет выполнить миграцию пакетов служб DTS SQL Server 7.0, сохраненных в виде структурированных файлов хранения, или хранящихся в базе данных msdb экземпляра SQL Server 7.0, обновленного до SQL Server 2005.

Невозможно сохранить или экспортировать пакеты служб Integration Services в формате пакетов служб SQL Server 2000 DTS.

Дополнительные сведения см. в разделе Миграция пакетов служб DTS.

Поддержка пакетов службы DTS SQL Server 2000 в выпуске SQL Server 2005 Express Edition

Выпуск SQL Server 2005 Express Edition не включает в себя Integration Services или поддержку пакетов служб DTS SQL Server 2000.

  • Чтобы получить возможность выполнять пакеты служб DTS на сервере с выпуском SQL Server 2005 Express Edition, необходимо оставить на сервере клиентские средства или распространяемые файлы служб DTS SQL Server 2000 или переустановить их. Выпуск SQL Server 2005 Express Edition не включает в себя среду выполнения служб DTS.

  • Редактирование существующих пакетов служб DTS, хранящихся на сервере SQL Server 2005 Express Edition, возможно при использовании SQL Server 2000, либо дистанционно с сервера, на котором работает выпуск SQL Server 2005 Workgroup, Standard, Enterprise или Developer Edition. Выпуск SQL Server 2005 Express Edition не включает в себя сред SQL Server Management Studio или BI Development Studio.

  • Чтобы выполнить миграцию существующих пакетов служб DTS до служб SQL Server 2005 Integration Services, необходимо использовать выпуск SQL Server 2005 Standard Edition, Enterprise Edition или Developer Edition. Другие выпуски SQL Server 2005 не включают в себя мастер миграции пакетов Integration Services.

Программа импорта и экспорта, поставляемая в составе выпуска SQL Server 2005 Express Edition, не является мастером импорта и экспорта SQL Server и не использует Integration Services.

Поддержка для пакетов служб Meta Data Services (репозиторий)

Службы SQL Server 2000 Meta Data Services, известные как репозиторий, являются устаревшими. SQL Server 2005 не устанавливает и не использует репозиторий.

Конструктор служб DTS SQL Server 2000 и программа dtsrun.exe продолжают поддерживать пакеты служб DTS, которые были сохранены в службах метаданных.

SQL Server 2005 Службы Integration Services поддерживают репозиторий только в помощнике по обновлению и в мастере миграции пакетов и только в случае, если на локальном компьютере установлены SQL Server 2000, средства SQL Server 2000 или файлы репозитория, не ограниченные для свободного распространения. Когда имеются в наличии файлы репозитория, помощник по обновлению может просмотреть, а мастер миграции пакетов может осуществить миграцию пакетов служб DTS, сохраненных в службах метаданных. Когда файлы репозитория отсутствуют, помощник по обновлению может просмотреть, а мастер миграции пакетов может осуществить миграцию только тех пакетов DTS, которые были сохранены в SQL Server или в структурированных файлах репозитория.

Задача «Выполнение пакетов служб DTS 2000 Integration Services» не сможет выполнить пакет DTS, сохраненный в репозитории. Однако среда выполнения DTS SQL Server 2000 может выполнять такие пакеты. Чтобы обойти это ограничение в службах Integration Services в том случае, если присутствуют файлы репозитория, можно создать новый пакет служб SQL Server 2000 DTS в качестве оболочки и сохранить его в SQL Server или в виде структурированного файла хранилища. Для выполнения пакета репозитория пользуйтесь задачей «Выполнение пакета» в новом пакете служб DTS, а для выполнения нового пакета в оболочке — задачей «Выполнение пакета служб DTS 2000» в пакете служб Integration Services.

Поддержка назначений ODBC

SQL Server 2005 Integration Services содержит компонент источника ODBC для загрузки данных из источников данных ODBC, однако не содержит соответствующего компонента назначения ODBC для сохранения данных в назначениях ODBC. Можно создать нерегламентированное назначение ODBC для использования в пределах одного пакета с помощью компонента сценария. Дополнительные сведения см. в разделе Creating an ODBC Destination with the Script Component.

См. также

Основные понятия

Некоторые вопросы миграции пакетов

Другие ресурсы

Сопоставление параметров команд программ dtsrun и dtexec
Использование служб Integration Services на 64-разрядных компьютерах

Журнал изменений

Версия Журнал

17 июля 2006 г.

Измененное содержимое:
  • Добавлен подраздел о назначениях ODBC.

  • Добавлен подраздел о совместимости пакетов служб DTS и SSIS.

  • Добавлено примечание об ограничении экспорта пакетов форматом служб DTS 2000 и о поддержке времени проектирования для пакетов 2000.

14 апреля 2006 г.

Измененное содержимое:
  • Добавлен список всех операций, которые могут выполняться над пакетами служб DTS при помощи инструментальных средств сервера SQL Server 2005.

  • Добавлен раздел по управлению пакетами служб DTS.

  • Добавлен раздел о выполнении пакетов служб DTS из командной строки.

  • В раздел по миграции добавлено замечание о помощнике по обновлению.

  • Добавлена ссылка для загрузки компонентов конструктора служб DTS.

5 декабря 2005 г.

Измененное содержимое:
  • Добавлены сведения о загрузке конструктора DTS и настройке его параметров.

  • Добавлены замечание и ссылка относительно миграции командных строк через dtsrun.exe.

  • Добавлены сведения о поддержке миграции из SQL Server 7.0.


Критические изменения в функциях служб Integration Services в SQL Server 2005

Критические изменения в функциях служб Integration Services в SQL Server 2005
Обновление до SQL Server 2005 > Обратная совместимость > Обратная совместимость служб SQL Server 2005 Integration Services >

Новое содержимое: 17 июля 2006 г.

В этом разделе описаны изменения, внесенные в службы SQL Server 2005 Integration Services (SSIS) после исходного выпуска SQL Server 2005, которые могут повлечь за собой сбои в работе приложений, основанных на более ранних версиях служб Integration Services.

Преобразования столбцов, ранее выполнявшиеся успешно, могут завершаться ошибкой

После установки пакета обновления 1 (SP1) для служб SQL Server 2005 Integration Services (SSIS) преобразования столбцов могут завершиться ошибкой в указанных далее случаях.

Преобразование столбцов Описание проблемы

Преобразования типа String в Unsigned Integer

Если в строковых столбцах имеются отрицательные числа (DT_STR или DT_WSTR), то преобразование типа данных столбца в тип unsigned integer (DT_UI1, DT_UI2, DT_UI4 или DT_UI8) в прошлом выполнялось успешно (отрицательные значения преобразовывались в 0). После установки пакета обновления 1 (SP1) отрицательные значения не преобразуются в 0, но возвращается сообщение об ошибке, и пакет может завершиться неудачей.

Область применения: преобразование «Уточняющий запрос», преобразование «Нечеткий уточняющий запрос», преобразование «Нечеткое группирование» и источник «Плоский файл».

Преобразования типа String в Binary

Если в строковых столбцах (DT_STR или DT_WSTR) содержатся символы, которые не могут быть преобразованы в байтовый массив, а тип данных столбца преобразуется в DT_BYTES, данные могут повредиться скрытым образом, потому что значение столбца будет преобразовано в массив нулей. В ходе установки пакета обновления 1 (SP1) в источник «Плоский файл» добавляется свойство UseBinaryFormat, способствующее интерпретации двоичных данных. После установки пакета обновления 1 (SP1), если свойство UseBinaryFormat имеет значение false (по умолчанию), а в столбце содержатся символы, которые невозможно преобразовать, в ходе преобразования возникает ошибка, и пакеты, ранее выполнявшиеся успешно, теперь могут завершаться неудачей.

Область применения: источник «Плоский файл».


Устаревшие возможности служб SQL Server 2005 Integration Services

Устаревшие возможности служб SQL Server 2005 Integration Services |
 | См. также
Обновление до SQL Server 2005 > Обратная совместимость > Обратная совместимость служб SQL Server 2005 Integration Services >

Новое содержимое: 14 апреля 2006 г.

В данном разделе приведено описание возможностей служб SQL Server 2005 Integration Services, которые будут удалены в следующих версиях продукта.Следующие возможности присутствуют в SQL Server 2005.

Модель объектов служб DTS SQL Server 2000

Модель объектов служб DTS SQL Server 2000 является устаревшей.Перед переходом на следующую версию SQL Server необходимо запланировать отказ от этой модели объектов. Объектная модель служб SQL Server 2000 DTS по-прежнему поддерживается в SQL Server 2000 и SQL Server 2005 в рамках обеспечения поддержки этих версий SQL Server; однако возможность миграции пакетов SQL Server 2000 может не поддерживаться в следующем выпуске.

Устаревшая функциональность служб DTS включает API-интерфейс служб DTS, мастер миграции пакетов для миграции пакетов служб DTS в следующую версию SQL Server, поддержку обслуживания пакетов служб DTS в среде SQL Server Management Studio и задачу «Выполнение пакета служб DTS 2000».

Задача «Сценарий ActiveX»

Задача «Сценарий ActiveX» в SQL Server 2005 Integration Services (SSIS) предоставляется только для обеспечения обратной совместимости со службами DTS и будет отсутствовать в следующей версии SQL Server. Не используйте эту функцию в разработке новых пакетов. Следует как можно скорее изменить пакеты, в настоящее время использующие эту функцию. Воссоздать функциональность сценариев ActiveX scripts возможно с помощью новых компонентов и более гибких ограничений очередностью, доступных в Integration Services. Либо можно переписать сценарии с использованием задачи «Сценарий» Integration Services.

Microsoft Visual Studio для приложений (VSA)

В следующих версиях Integration Services средаVisual Studio для приложений (VSA) будет заменена средой Visual Studio Tools для приложений (VSTA) в качестве ядра в задаче сценария и преобразования «Сценарий».Хотя это изменение не должно значительно повлиять на существующий синтаксис, оно может потребовать преобразования сценариев при миграции на следующую версию Integration Services.

В следующей версии Integration Services:

  • компания Microsoft будет поддерживать преобразование в VSTA существующих сценариев, задач сценариев и преобразований «Сценарий», созданных в VSA;

  • компания Microsoft будет поддерживать выполнение существующих нескопилированных сценариев VSA.

В будущих версиях Integration Services:

  • компания Microsoft будет поддерживать преобразование в VSTA существующих сценариев, задач сценариев и преобразований «Сценарий», созданных в VSA;

  • компания Microsoft не будет поддерживать выполнение сценариев VSA.

Журнал изменений

Версия Журнал

17 июля 2006 г.

Измененное содержимое:
  • Добавлены подробные сведения о поддержке сценариев ActiveX.

См. также

Другие ресурсы

Обновление компонентов SQL Server


Установка свойств приложений служб DTS

Установка свойств приложений служб DTS |
 | См. также
Обновление до SQL Server 2005 > Обратная совместимость > Обратная совместимость служб SQL Server 2005 Integration Services >

Новое содержимое: 5 декабря 2005 г.

Для пользователей служб SQL Server 2005 Integration Services (SSIS), которым до сих пор требуется выполнять пакеты служб DTS SQL Server 2000, корпорация Майкрософт предоставляет в составе программы установки служб SQL Server 2005 Integration Services (SSIS) обновленную версию среды выполнения DTS и в составе веб-загрузки обновленную версию конструктора DTS. Инструментальные средства SQL Server 2005 обеспечивают доступ почти ко всем возможностям DTS при помощи знакомого конструктора и среды выполнения.

Однако инструментальные средства SQL Server 2005 больше не обеспечивают доступ к параметрам в рамках приложения в диалоговом окне DTS Свойства пакета, доступ к которым в программе Enterprise Manager SQL Server 2000 осуществлялся выбором пункта Свойства из раскрывающегося меню узла DTS. В этом подразделе описываются эти параметры, а также способы их настройки — ручной настройки при помощи редактирования соответствующих записей реестра и настройки программным способом при помощи вызова в объектной модели DTS соответствующих методов, изменяющих записи реестра.

Свойства приложения DTS

В этом подразделе рассматриваются следующие свойства приложения DTS.

Кэш: включить кэш (флажок)

В кэше содержатся доступные задачи, преобразования, языки сценариев и поставщики OLE DB для повышения производительности.

Кэш: обновить кэш (кнопка)

Обновляются описанные выше кэшированные списки.

Конструктор: показывать многофазный модуль заполнения в конструкторе служб DTS

Позволяет отображать дополнительные параметры, обеспечивающие отдельную настройку определенных фаз преобразования данных, например, «Предварительные данные источника» или «При неудаче преобразования».

Отладка: включить JIT-отладку

Дает возможность разработчикам нестандартных задач выполнять отладку.

Службы Meta Data Services: включить сохранение в службах Meta Data Services

Позволяет сохранять пакеты в службах Meta Data Services (репозиторий).

Примечание.
В SQL Server 2005 поддержка репозитория ограничена. Дополнительные сведения см. в подразделе «Пакеты служб Meta Data Services (репозитория)» в разделе Обратная совместимость служб SQL Server 2005 Integration Services.

Установка свойств приложения DTS в реестре

Для ручного включения и выключения следующих свойств приложения DTS непосредственным изменением реестра установите следующие значения для REG_DWORD: 0 (включено) или 1 (выключено) в родительском ключе HKEY_CURRENT_USER\Software\Microsoft\Microsoft SQL Server\80\DTS\Settings.

Включение кэша

TasksCache

TransformationsCache

ScriptingLanguagesCache

OLEDBProvidersCache

Отображение многофазного модуля заполнения в конструкторе служб DTS

DesignerSettings

Включение JIT-отладки

JITDebug

Примечание.
Невозможно обновлять кэш редактированием значений реестра. Кэш может обновляться только программным путем.

Для ручного включения и выключения следующих свойств приложения DTS непосредственным изменением реестра установите следующие значения для REG_DWORD: 0 (включено) или 1 (выключено) в родительском ключе HKEY_LOCAL_MACHINE\Software\Microsoft\Microsoft SQL Server\80\DTS\Settings.

Включение сохранения в службах Meta Data Services

EnableSaveToRepository

Внимание!
Следующее предупреждение отображалось в диалоговом окне Свойства пакета, если свойство Включение сохранения в службах Meta Data Services было включено: «Внимание. Сохранение пакетов в службах Meta Data Services не является безопасным. Включить сохранение пакетов в службах Meta Data Services?»

Образец сценария реестра

Следующий сценарий реестра, сохраненный как текстовый файл с расширением REG, а затем запущенный, включает все рассматриваемые в этом подразделе свойства приложений DTS. Для отключения свойств измените новые значения с 00000001 на 00000000.

Копировать код
Windows Registry Editor Version 5.00

[HKEY_CURRENT_USER\Software\Microsoft\Microsoft SQL Server\80\DTS\Settings]
"TasksCache"=dword:00000001
"TransformationsCache"=dword:00000001
"ScriptingLanguagesCache"=dword:00000001
"OLEDBProvidersCache"=dword:00000001
"DesignerSettings"=dword:00000001
"JITDebug"=dword:00000001

[HKEY_LOCAL_MACHINE\Software\Microsoft\Microsoft SQL Server\80\DTS\Settings]
"EnableSaveToRepository"=dword:00000001

Установка свойств приложения DTS в объектной модели DTS.

Для включения или выключения следующих свойств приложения DTS программным путем установите следующие значения объекта DTS Application: True (включено) или False (выключено).

Включение кэша

.TaskInfos.UseCache

.TransformationInfos.UseCache

.ScriptingLanguageInfos.UseCache

.OLEDBProviderInfos.UseCache

Включение JIT-отладки

.JITDebug

Для включения или выключения следующих параметров приложения DTS программным способом установите следующие значения объектов DTS Application в надлежащие значения из перечисления DTSDesignerSettings.

  • Включено — DTSDesignerSettings.DTSDesigner_ShowMultiPhaseTransforms

  • Выключено — DTSDesignerSettings.DTSDesigner_Default

Отображение многофазного модуля заполнения в конструкторе служб DTS

.DesignerSettings

Значение свойства Включение сохранения в службах Meta Data Services не может быть установлено при помощи объектной модели DTS. Это свойство может быть установлено при помощи класса Registry в пространстве имен Microsoft.Win32 библиотеки классов .NET Framework, как показано в следующем примере.

Образец кода

Следующий образец кода для приложения командной строки после компиляции и запуска включает все свойства приложения DTS, рассматриваемые в этом подразделе. Для выключения параметров измените новые значения с True на False и измените значение свойства DesignerSettings на DTSDesignerSettings.DTSDesigner_Default.

Этому приложению требуется ссылка на COM-библиотеку Microsoft DTSPackage Object Library.

Значение параметра Включение сохранения в службах Meta Data Services может быть установлено только непосредственным изменением реестра.

Копировать код
Imports Microsoft.Win32
Imports DTS

Module SetDTSProperties

  Sub Main()

    Const SETTINGS_ROOT_KEY As String = "Software\Microsoft\Microsoft SQL Server\80\DTS\Settings"
    Const METADATASERVICES_VALUE As String = "EnableSaveToRepository"

    Dim dtsApp As New DTS.Application
    Dim keySettingsRoot As RegistryKey

    With dtsApp
      .TaskInfos.UseCache = True
      .TransformationInfos.UseCache = True
      .ScriptingLanguageInfos.UseCache = True
      .OLEDBProviderInfos.UseCache = True
      .DesignerSettings = DTSDesignerSettings.DTSDesigner_ShowMultiPhaseTransforms
      .JITDebug = True
    End With

    keySettingsRoot = Registry.LocalMachine.OpenSubKey(SETTINGS_ROOT_KEY, True)
    If keySettingsRoot Is Nothing Then
      keySettingsRoot = Registry.LocalMachine.CreateSubKey(SETTINGS_ROOT_KEY)
    End If
    With keySettingsRoot
      .SetValue(METADATASERVICES_VALUE, Math.Abs(CType(True, Integer)))
      .Close()
    End With

  End Sub

End Module
Копировать код
using Microsoft.Win32;
using DTS;

class SetDTSProperties
{

  public static void Main()
  {

    const string SETTINGS_ROOT_KEY = "Software\\Microsoft\\Microsoft SQL Server\\80\\DTS\\Settings";
    const string METADATASERVICES_VALUE = "EnableSaveToRepository";

    DTS.Application dtsApp = new DTS.Application();
    RegistryKey keySettingsRoot;

    {
      dtsApp.TaskInfos.UseCache = true;
      dtsApp.TransformationInfos.UseCache = true;
      dtsApp.ScriptingLanguageInfos.UseCache = true;
      dtsApp.OLEDBProviderInfos.UseCache = true;
      dtsApp.DesignerSettings = DTSDesignerSettings.DTSDesigner_ShowMultiPhaseTransforms;
      dtsApp.JITDebug = true;
    }

    keySettingsRoot = Registry.LocalMachine.OpenSubKey(SETTINGS_ROOT_KEY, true);
    if (keySettingsRoot==null)
    {
      keySettingsRoot = Registry.LocalMachine.CreateSubKey(SETTINGS_ROOT_KEY);
    }
    {
      keySettingsRoot.SetValue(METADATASERVICES_VALUE, Math.Abs((int) true));
      keySettingsRoot.Close();
    }

  }

}

Для обновления кэша, когда это необходимо, в приложение может быть добавлена следующая подпрограмма. Кэшированные значения сохраняются в реестре как HKEY_CURRENT_USER\Software\Microsoft\Microsoft SQL Server\80\DTS\Enumeration.

Копировать код
  Private Sub RefreshCache()

    Me.Cursor = Cursors.WaitCursor
    With dtsApp
      .TaskInfos.Refresh()
      .TransformationInfos.Refresh()
      .ScriptingLanguageInfos.Refresh()
      .OLEDBProviderInfos.Refresh()
    End With
    Me.Cursor = Cursors.Default

  End Sub
Копировать код
  private void RefreshCache()
  {

    this.Cursor = Cursors.WaitCursor;
    {
      dtsApp.TaskInfos.Refresh();
      dtsApp.TransformationInfos.Refresh();
      dtsApp.ScriptingLanguageInfos.Refresh();
      dtsApp.OLEDBProviderInfos.Refresh();
    }
    this.Cursor = Cursors.Default;

  }

См. также

Основные понятия

Обратная совместимость служб SQL Server 2005 Integration Services
Обновление или миграция служб DTS


Обратная совместимость служб Notification Services

Обратная совместимость служб Notification Services |
 | См. также
Обновление до SQL Server 2005 > Обратная совместимость >

В следующем разделе приводятся изменения в службах SQL Server 2005 Notification Services, которые могут повлиять на существующие приложения Notification Services.

Устаревшие возможности

Следующие классы в API-интерфейсе служб Notification Services и связанные с ними явные определения интерфейса не являются рекомендованными и замещены классами объектов NMO служб Notification Services.

Устаревший класс | Заменяющий класс NMO
ApplicationEnumeration | ApplicationCollection
DeliveryChannel | DeliveryChannel
DeliveryChannelEnumeration | DeliveryChannelCollection
EventClass | EventClass
EventClassEnumeration | EventClassCollection
InstanceEnumeration | InstanceCollection
NotificationClass | NotificationClass
NotificationClassEnumeration | NotificationClassCollection
NSInstanceDescription | Instance
Protocol | NotificationClassProtocol
ProtocolEnumeration | NotificationClassProtocolCollection
SubscriptionClass | SubscriptionClass
SubscriptionClassEnumeration | SubscriptionClassCollection

Неподдерживаемые функции

Все функции служб Notification Services 2.0 поддерживаются в SQL Server 2005.

Критические изменения

SQL Server 2005 Службы Notification Services содержат некоторые изменения, которые вызовут прекращение работы приложений служб Notification Services версии 2.0 при обновлении до SQL Server 2005. В таблице ниже перечислен список известных критических изменений.

Критическое изменение | Описание
Функция Notify() была удалена. | В службах Notification Services 2.0 было необходимо использовать функцию Notify() в любом правиле подписки, которым были сформированы уведомления. По причинам безопасности и производительности функция Notify() была удалена. Дополнительные сведения см. в разделе Миграция экземпляров служб Notification Services 2.0 на SQL Server 2005.
Пользовательские компоненты должны быть перекомпилированы. | В SQL Server 2005 изменилось строгое имя сборки служб Notification Services. Таким образом, необходимо заново скомпилировать все пользовательские поставщики событий, модули форматирования содержимого, протоколы доставки и пользовательские приложения, построенные с помощью API-интерфейса служб Notification Services. При перекомпиляции этих компонентов или приложений используйте сборки SQL Server 2005 и платформу .NET Framework версии 2.0.
Экземпляры служб Notification Services должны использовать одну и ту же версию Database Engine. | Экземпляры служб Notification Services 2.0 должны использовать ядро СУБД SQL Server 2000. Экземпляры служб SQL Server 2005 Notification Services должны использовать еомпонент SQL Server 2005 Database Engine. После обновления компонента Database Engine до SQL Server 2005 необходимо произвести миграцию экземпляра служб Notification Services на SQL Server 2005. Дополнительные сведения см. в разделе Миграция экземпляров служб Notification Services 2.0 на SQL Server 2005.

Изменения в поведении

Не существует существенных изменений в поведении для служб SQL Server 2005 Notification Services.

См. также

Основные понятия

Миграция экземпляров служб Notification Services
Установка служб SQL Server Notification Services


Обратная совместимость репликации

Обратная совместимость репликации |
 | См. также
Обновление до SQL Server 2005 > Обратная совместимость >

Разделы в главе по обратной совместимости описывают изменения в поведении репликации в разных версиях . При обновлении или наличии нескольких версий SQL Server в топологии репликации важно понимать принцип обратной совместимости.

Раздел | Описание
Устаревшие возможности в репликации SQL Server 2005 | Функциональные возможности репликации, которые были сохранены в в целях обратной совместимости, но будут удалены из будущих версий SQL Server.
Неподдерживаемые возможности репликации в SQL Server 2005 | Функциональные возможности репликации, которые существовали в , но удалены из SQL Server 2005.
Изменения в поведении репликации SQL Server 2005 | Функциональные возможности репликации, измененные в SQL Server 2005.
Критические изменения репликации в SQL Server 2005 | Изменения функциональных возможностей репликации, которые могут потребовать изменений в приложениях.
Использование нескольких версий SQL Server в топологии репликации | Замечания по использованию нескольких версий SQL Server в топологии репликации.

См. также

Основные понятия

Обновление реплицируемых баз данных


Устаревшие возможности в репликации SQL Server 2005

Устаревшие возможности в репликации SQL Server 2005 |
 | См. также
Обновление до SQL Server 2005 > Обратная совместимость > Обратная совместимость репликации >

Дата обновления: 14 апреля 2006 г.

В этом разделе описаны устаревшие возможности репликации, которые не будут включены в последующие версии. Эти возможности доступны в , однако рекомендуется по возможности применять альтернативные возможности.

Примечание.
Этот раздел доступен в справочной документации по программе установки, а также в электронной документации по SQL Server 2005. Ссылки на разделы, выделенные полужирным шрифтом в справочной документации по установке, относятся к разделам, доступным только в электронной документации.

Устаревшие возможности, влияющие на все типы репликации

Следующие возможности, применимые ко всем типам репликации, являются устаревшими в SQL Server 2005.

Возможность Описание

Присоединяемые подписки

Эта возможность может применяться при развертывании большого количества подписок по запросу, что обычно происходит в репликации слиянием. В SQL Server 2005 вместо присоединяемых подписок рекомендуется использовать следующие подходы:

  • Для публикаций слиянием, секционированных с помощью параметризованных фильтров, рекомендуется использовать новые возможности секционированных снимков, которые упрощают инициализацию большого количества подписок. Дополнительные сведения см. в разделе Моментальные снимки для публикаций слиянием с параметризованными фильтрами.

  • Для несекционированных публикаций можно инициализировать подписку с помощью резервной копии. Дополнительные сведения см. в разделах Инициализация подписки на публикацию слиянием без моментального снимка и Инициализация подписки на публикацию транзакций без моментального снимка.

В обоих случаях можно автоматизировать создание большого количества подписок с помощью сценария: создайте одну подписку, внесите ее в сценарий, измените сценарий для каждого подписчика и примените сценарий к каждому подписчику, чтобы создать подписку. Дополнительные сведения см. в разделе Создание сценариев репликации.

Дополнительные сведения о присоединяемых подписках см. в разделе Подсоединяемые подписки.

Анонимные подписки

Указание значения anonymous для параметра @subscriber_type процедуры sp_addmergepullsubscription (Transact-SQL) или параметра @subscription_type процедуры sp_addpullsubscription (Transact-SQL) является устаревшей возможностью.

В SQL Server 2005 значение anonymous обязательно, если необходимо создать подписку без ее регистрации на издателе. Это необходимо в тех случаях, когда невозможно установить соединение с SQL Server издателя в момент настройки подписки. В будущих версиях SQL Server параметр anonymous в данной ситуации будет не нужен.

Регистрация подписчика

Хранимая процедура sp_addsubscriber (Transact-SQL) является устаревшей. Больше не требуется явная регистрация подписчика на издателе.

Объекты SQL-DMO

Существующий код будет продолжать работать, но объекты SQL-DMO не поддерживают новые возможности в SQL Server 2005. Вместо этого используйте объекты RMO. Дополнительные сведения см. в разделе Programming with Replication Management Objects.

Изменения схемы с помощью процедур sp_repladdcolumn и sp_repldropcolumn

Хранимые процедуры sp_repladdcolumn (Transact-SQL) и sp_repldropcolumn (Transact-SQL) являются устаревшими. Вместо них используйте репликацию изменения схемы. Дополнительные сведения см. в разделе Внесение изменений схем в базы данных публикаций.

Хранимые процедуры нельзя использовать для добавления или удаления столбцов с типами данных SQL Server 2005: XML, varchar(max), nvarchar(max), varbinary(max) или определяемых пользователем типов (UDT).

Проверка контрольной суммы

Проверка контрольной суммы должна использоваться только для подписчиков версии 7.0. Используйте проверку двоичной контрольной суммы для подписчиков SQL Server более поздних версий. Также можно использовать проверку количества строк для всех подписчиков SQL Server, включая версию 7.0, а также для подписчиков, подписанных на публикации от издателей Oracle. Дополнительные сведения см. в разделе Проверка реплицированных данных.

Добавление публикаций в Active Directory

Добавление публикаций в Active Directory с помощью параметра @add_to_active_directory процедур sp_addpublication (Transact-SQL) или sp_addmergepublication (Transact-SQL) является устаревшей возможностью. Подписка на публикацию путем определения ее расположения в Active Directory является неподдерживаемой функцией.

параметр -UseInprocLoader

Этот параметр агента распространителя и агента слияния является устаревшим, поскольку он не совместим с типом данных XML. Этот параметр может использоваться, если не выполняется репликация XML-данных. Дополнительные сведения см. в разделах Replication Distribution Agent и Replication Merge Agent.

Устаревшие возможности репликации транзакций

Следующие возможности репликации транзакций являются устаревшими в SQL Server 2005.

Возможность Описание

Истечение срока подписки для публикаций транзакций

Свойство @retention sp_addpublication (Transact-SQL) является устаревшим. Подписки по-прежнему отмечаются как неактивные и должны быть инициализированы повторно, если они не были синхронизированы в течение максимального срока хранения распространения (свойство @max_distretention процедуры sp_adddistributiondb (Transact-SQL). Дополнительные сведения о сроках хранения см. в разделе Окончание срока действия и отключение подписки.

Подписки без синхронизации (no sync) на публикации транзакций

Подписка является подпиской без синхронизации (no sync), если для параметра @sync_type процедуры sp_addsubscription (Transact-SQL) указано значение none. Если необходимо указать, что требуемая схема и данные уже присутствуют в базе данных подписки, укажите для параметра значение replication support only. Дополнительные сведения см. в разделе Инициализация подписки на публикацию транзакций без моментального снимка.

Подписчики ODBC

Вместо этого используйте OLE DB для подписчиков, не являющихся подписчиками SQL Server. Дополнительные сведения о поддерживаемых подписчиках см. в разделе Подписчики, отличные от подписчиков SQL Server.

Трансформируемые подписки

Эта возможность доступна через интерфейс хранимых процедур и более не поддерживается через интерфейс пользователя. Чтобы использовать эту возможность, необходимо установить службы DTS . Дополнительные сведения см. в разделе Обратная совместимость служб SQL Server 2005 Integration Services. Дополнительные сведения о трансформируемых подписках см. в разделе Преобразование опубликованных данных.

Обновляемые подписки с публикациями моментальных снимков

По-прежнему поддерживаются обновляемые подписки с публикациями транзакций. Дополнительные сведения см. в разделе Обновляемые подписки для репликации транзакций.

Элемент управления ActiveX для распространителя

Этот элемент управления позволяет внедрить агент распространителя в приложение. Вместо этого используйте объекты RMO. Дополнительные сведения см. в разделе Synchronizing Subscriptions (RMO Programming).

Интерфейс распространителя репликации

В SQL Server 2000 интерфейс распространителя репликации предоставлял возможность хранения реплицируемых транзакций в базе данных распространителя на сервере распространителя. Этот интерфейс предоставлял возможность публикации из базы данных, не являющейся базой данных SQL Server (чтобы отследить изменения на сервере издателя, было необходимо дополнительное программирование). Хотя данная функция считается устаревшей, существующий код по-прежнему будет работать на сервере, обновленном с версии SQL Server 2000. Дополнительные сведения см. в разделе «Справочник по интерфейсу распространителя репликации» электронной документации по SQL Server 2000.

SQL Server 2005 поддерживает публикацию из баз данных Oracle без дополнительного программирования. Дополнительные сведения см. в разделе Обзор публикации Oracle.

Устаревшие возможности репликации слиянием

Следующие возможности репликации слиянием являются устаревшими в SQL Server 2005.

Возможность Описание

Альтернативные участники синхронизации

Функция альтернативных участников синхронизации позволяет указать альтернативного издателя, с которым может синхронизироваться подписчик. Дополнительные сведения см. в разделе Альтернативные участники синхронизации.

В SQL Server 2005 рекомендуется использовать репликацию слиянием вместе с зеркальным отображением базы данных, а не альтернативных участников синхронизации. Дополнительные сведения см. в разделе Replication and Database Mirroring.

Элемент управления ActiveX для слияния

Этот элемент управления позволяет внедрить в приложение агент слияния. Вместо этого используйте объекты RMO. Дополнительные сведения см. в разделе Synchronizing Subscriptions (RMO Programming).

Инструкция UPDATE для нескольких столбцов

Когда репликация слиянием выполняет обновление, все измененные столбцы обновляются в одной инструкции UPDATE, а все значения неизмененных столбцов сбрасываются в первоначальные. Кроме этого, репликация может использовать несколько инструкций UPDATE — по одной на каждый измененный столбец. Как правило, применение инструкции UPDATE к нескольким столбцам является более эффективным.

В более ранних версиях SQL Server рекомендовалось указывать значение false для параметра статьи fast_multicol_updateproc, чтобы учесть случаи, когда обновление нескольких столбцов одной инструкцией UPDATE могло оказаться менее эффективным:

  • Большинство обновлений затрагивают небольшое число столбцов.

  • Число операций обслуживания индекса для неизмененных столбцов увеличивается из-за того, что такие столбцы сбрасываются, когда появляются обновления.

Благодаря увеличению производительности SQL Server этот параметр в подобных случаях больше не требуется.

См. также

Основные понятия

Обратная совместимость репликации

Другие ресурсы

Улучшения в репликации


Неподдерживаемые возможности репликации в SQL Server 2005

Неподдерживаемые возможности репликации в SQL Server 2005 |
 | См. также
Обновление до SQL Server 2005 > Обратная совместимость > Обратная совместимость репликации >

Дата обновления: 14 апреля 2006 г.

В этом разделе описаны функции репликации, которые не поддерживаются в .

Примечание.
Этот раздел доступен в справочной документации по программе установки, а также в электронной документации по SQL Server 2005. Ссылки на разделы, выделенные полужирным шрифтом в справочной документации по установке, относятся к разделам, доступным только в электронной документации.

Неподдерживаемые функции, влияющие на все типы репликации

В SQL Server 2005 больше не поддерживаются следующие функции репликации.

Функция Описание

Создание принудительных подписок без соединения с подписчиком в мастере создания подписки

Теперь для создания принудительных подписок в мастере создания подписки требуется активное соединение с подписчиком во время настройки. Дополнительные сведения о доступе к мастеру см. в разделе Как создать принудительную подписку (среда SQL Server Management Studio).

Инициализация подписчиков, работающих с SQL Server версии 7.0, с помощью протокола передачи файлов (FTP)

Эта функция доступна для подписчиков, работающих с SQL Server 2000 или более поздних версий. Дополнительные сведения см. в разделе Передача моментальных снимков по протоколу FTP.

Создание подписок в диспетчере синхронизации Windows

Подписки больше нельзя создавать в диспетчере синхронизации, однако синхронизация подписок все еще доступна. Дополнительные сведения см. в разделе Диспетчер синхронизации Windows.

Подписка на публикацию с помощью размещения ее в каталоге Active Directory

Добавление публикаций в Active Directory с помощью параметра @add_to_active_directory процедур sp_addpublication (Transact-SQL) или sp_addmergepublication (Transact-SQL) является устаревшей возможностью. Подписка на публикацию путем определения ее расположения в Active Directory является неподдерживаемой функцией.

Элемент управления ActiveX «Моментальный снимок»

Этот элемент управления позволяет встраивать в приложения агент моментальных снимков. Вместо этого следует использовать новый управляемый агент моментальных снимков. Дополнительные сведения см. в образце кода SnapshotGenerationAgent и разделе How to: Create the Initial Snapshot (RMO Programming).

Удаленная активация агента

SQL Server 2000 поддерживал выполнение агента распространителя или агента слияния на другом компьютере и удаленную активацию этого агента с помощью DCOM. Поддержка распространителей в SQL Server 2005 и более поздних версий больше не осуществляется; она считается устаревшей и для распространителей в более ранних версиях SQL Server. Дополнительные сведения см. в разделе «Активация удаленного агента» в электронной документации по SQL Server 2000.

Подписчики Microsoft Access (Jet 4.0)

Jet представляет собой базу данных, лежащую в основе Access, и в SQL Server 2000 подписка на базы данных Jet поддерживалась репликацией. Такие подписки больше не поддерживаются.

Рекомендуется вместо этого пользоваться . Access может использовать базу данных SQL Server в качестве основы, и на базы данных SQL Server это не влияет. Дополнительные сведения см. в разделе Репликация данных в SQL Server Express.

Неподдерживаемые функции репликации транзакций

В SQL Server 2005 больше не поддерживаются следующие функции репликации транзакций.

Функция | Описание
Параметр Microsoft Message Queuing (MSMQ) для подписок, обновляемых посредством очередей | При использовании подписок, обновляемых посредством очередей, изменения со стороны подписчиков записываются в очередь; затем они считываются из очереди и доставляются издателю агентом чтения очереди. В SQL Server 2000 подписки могли использовать очередь SQL Server либо MSMQ. Тип очереди задавался с помощью параметра @queue_type хранимой процедуры sp_addpublication (Transact-SQL) с допустимыми значениями sql и msmq. В SQL Server 2005 допустимо только значение sql. Существующие публикации, использующие MSMQ, в процессе обновления следует изменить, настроив на использование очереди SQL Server. Имеющиеся приложения, использующие обновление посредством очередей MSMQ, следует переписать таким образом, чтобы приспособить их к очереди SQL Server. Дополнительные сведения подписках, обновляемых посредством очередей, см. в разделе Обновляемые подписки для репликации транзакций.

Неподдерживаемые функции репликации слиянием

В SQL Server 2005 больше не поддерживаются следующие функции репликации слиянием.

Функция Описание

Публикация из выпуска SQL Server 2005 Express Edition

SQL Server MSDE может служить в качестве издателя при публикациях слиянием. Выпуск SQL Server Express Edition, заменяющий MSDE, в качестве издателя служить не может. Он позволяет подписаться на публикации слиянием, публикации транзакций и публикации моментальных снимков. Репликация слиянием и репликация транзакций с обновляемыми подписками позволяют передавать изменения от подписчиков обратно к издателю. Дополнительные сведения о репликации в выпуске SQL Server Express Edition см. в разделе Репликация данных в SQL Server Express.

Интерфейс IVBCustomResolver

Этот интерфейс позволяет создавать на языке Visual Basic пользовательские арбитры конфликтов на базе COM. В SQL Server 2005 рекомендуется использовать вместо арбитров конфликтов на базе COM пользоваться обработчиками бизнес-логики. Дополнительные сведения см. в разделе Выполнение бизнес-логики при синхронизации слиянием.

Можно также создавать COM-арбитры на языке C++. Дополнительные сведения см. в разделе Пользовательские арбитры на основе технологии COM.

См. также

Основные понятия

Обратная совместимость репликации

Другие ресурсы

Улучшения в репликации


Критические изменения репликации в SQL Server 2005

Критические изменения репликации в SQL Server 2005 |
 | См. также
Обновление до SQL Server 2005 > Обратная совместимость > Обратная совместимость репликации >

Дата обновления: 14 апреля 2006 г.

В этом разделе описаны изменения функции репликации, в результате которых может потребоваться изменение приложений.

Примечание.
Этот раздел доступен в справочной документации по программе установки, а также в электронной документации по SQL Server 2005. Ссылки на разделы, выделенные полужирным шрифтом в справочной документации по установке, относятся к разделам, доступным только в электронной документации.

Критические изменения, влияющие на все типы репликации

Следующие критические изменения в влияют на все типы репликации.

Возможность Описание

Изменения, необходимые для сценариев репликации

Модель безопасности агента репликации по сравнению с изменилась. Дополнительные сведения о моделях безопасности см. в разделе Модель безопасности агента репликации. Если пользователь, будучи членом фиксированной серверной роли sysadmin в SQL Server 2005, запускает сценарии репликации, созданные в SQL Server 2000 или SQL Server 7.0, они будут выполняться корректно. Если пользователь является членом фиксированной роли базы данных dbo или какой-либо другой роли, при выполнении сценариев произойдет сбой и их придется обновить. Дополнительные сведения об обновлении сценариев см. в разделе How to: Upgrade Replication Scripts (Replication Transact-SQL Programming). Хотя обновление сценариев, выполняемых членами роли sysadmin, не требуется, рекомендуется его выполнить с целью улучшения безопасности.

Локальные соединения агентов репликации

При обновлении до версии SQL Server 2005 все локальные соединения, использующие проверку подлинности SQL Server, настраиваются на использование проверки подлинности Windows. Локальными называются соединения, производимые агентом к экземпляру SQL Server, запущенному на том же компьютере, что и агент. Например, агент слияния при подписке по запросу запускается на стороне подписчика, и все его соединения с подписчиком являются локальными.

В предыдущих версиях SQL Server агенты по умолчанию запускались в контексте учетной записи службы агента SQL Server. После обновления локальные соединения производятся в контексте этой учетной записи. В SQL Server 2005 возможно управление по отдельности каждой из учетных записей, под которыми агенты репликации запускаются и осуществляют интегрированные с Windows соединения с базами данных и другими ресурсами; для каждого из агентов можно задать отдельную учетную запись. После обновления рекомендуется задать отдельные учетные записи для каждого агента. Дополнительные сведения см. в разделах Обновление реплицируемых баз данных и Модель безопасности агента репликации.

Элементы управления ActiveX

Все элементы управления ActiveX помечаются как небезопасные для выполнения сценариев и инициализации.

Элемент управления ActiveX агента моментальных снимков в SQL Server 2005 недоступен. Вместо этого следует использовать новый управляемый агент моментальных снимков. Дополнительные сведения см. в образце кода SnapshotGenerationAgent и разделе How to: Create the Initial Snapshot (RMO Programming).

Пароль для учетной записи distributor_admin

Доверенные соединения между издателем и удаленным распространителем больше не поддерживаются, так как они не требовали пароля (в версиях более ранних, чем SQL Server 2000 с пакетом обновления 3 (SP3), доверенные соединения использовались по умолчанию). В случае использования удаленного распространителя перед обновлением до SQL Server 2005 следует преобразовать доверенные соединения в недоверенные (это не касается издателей, использующих локальный распространитель). Дополнительные сведения об учетной записи distributor_admin см. в разделе Защита распространителя.

Чтобы определить используемый тип соединения

  • Выполните процедуру Хранимая процедура sp_helpdistpublisher (Transact-SQL) на распространителе. Если значение в столбце trusted равно 1, необходимо изменить соединение на недоверенное.

Чтобы изменить соединение на недоверенное

  1. Выполните процедуру sp_changedistpublisher (Transact-SQL) на распространителе, задав параметру @property значение «trusted», а параметру @value — значение «False».

    Примечание.
    В некоторых версиях электронной документации по SQL Server 2000 значение «trusted» не указано в качестве допустимого для параметра @property. Однако оно допустимо для всех выпусков SQL Server 2000.

  2. Выполните процедуру sp_changedistributor_password (Transact-SQL) на издателе и на распространителе, указав надежный пароль в качестве параметра @password.

Выпуск SQL Server Express Edition не включает агент SQL Server

В случае обновления до выпуска SQL Server Express Edition (SQL Server Express) необходимо перенастроить синхронизацию репликации, так как выпуск SQL Server Express Edition не включает агент SQL Server.

Для использования подписок по запросу необходимо синхронизировать их с помощью объектов RMO, диспетчера синхронизации Windows либо путем запуска агента репликации из командной строки. Дополнительные сведения см. в разделе Репликация данных в SQL Server Express.

Если необходимо продолжить использование агента SQL Server для запуска заданий агента репликации, следует применять принудительные подписки или обновить SQL Server до другой версии (агент SQL Server входит во все версии SQL Server, кроме выпуска Express Edition и ). При принудительных подписках агент распространителя или агент слияния запускается на распространителе, поэтому агент SQL Server в этом случае доступен (выпуск SQL Server Express Edition не может выполнять роль распространителя).

Подписчики Microsoft Access (Jet 4.0)

Jet представляет собой базу данных, лежащую в основе Access, и в SQL Server 2000 подписка на базы данных Jet поддерживалась репликацией. Такие подписки больше не поддерживаются.

Вместо этого рекомендуется использовать . Access может использовать базу данных SQL Server в качестве основы, и на базы данных SQL Server это не влияет. Дополнительные сведения см. в разделе Репликация данных в SQL Server Express.

Критические изменения для репликации транзакций

Следующие критические изменения в SQL Server 2005 влияют на репликацию транзакций.

Возможность Описание

Режим Microsoft Message Queuing (MSMQ) для подписок, обновляемых посредством очередей

При использовании подписок, обновляемых посредством очередей, изменения со стороны подписчиков записываются в очередь; затем они считываются из очереди и доставляются издателю агентом чтения очереди. В SQL Server 2000 подписки могли использовать очередь SQL Server либо MSMQ. Тип очереди задавался с помощью параметра @queue_type хранимой процедуры sp_addpublication (Transact-SQL) с допустимыми значениями sql и msmq. В SQL Server 2005 допустимо только значение sql. Существующие публикации, использующие MSMQ, в процессе обновления следует изменить, настроив на использование очереди SQL Server. Имеющиеся приложения, использующие обновление посредством очередей MSMQ, следует переписать таким образом, чтобы приспособить их к очереди SQL Server. Дополнительные сведения о подписках, обновляемых посредством очередей, см. в разделе Обновляемые подписки для репликации транзакций.

При обновлении существующие очереди подписки MSMQ будут удалены, если служба MSMQ запущена в процессе обновления SQL Server.

Важно!
В Windows 2000 и Windows XP также должна быть запущена служба координатора распределенных транзакций Майкрософт (MSDTC), так как для работы очередей MSMQ на этих платформах требуется MSDTC.

Если служба MSMQ не запущена, следует удалить очереди вручную после завершения обновления. Дополнительные сведения об удалении очередей см. в документации по Windows.

Критические изменения в репликации слиянием

Следующие критические изменения в SQL Server 2005 влияют на репликацию слиянием.

Возможность Описание

Публикация из выпуска SQL Server 2005 Express Edition

SQL Server MSDE может служить в качестве издателя при публикациях слиянием. Выпуск SQL Server Express Edition, заменяющий MSDE, в качестве издателя служить не может. Он позволяет подписаться на публикации слиянием, публикации транзакций и публикации моментальных снимков. Репликация слиянием и репликация транзакций с обновляемыми подписками позволяют передавать изменения от подписчиков обратно к издателю. Дополнительные сведения о репликации в выпуске SQL Server Express Edition см. в разделе Репликация данных в SQL Server Express.

Пакетирование изменений

В предыдущих версиях SQL Server изменения, производимые агентом слияния, выполнялись в построчном режиме. В SQL Server 2005 изменения объединяются в пакеты с целью улучшения производительности; поэтому в пределах одной инструкции можно вставить, обновить или удалить несколько строк. Если в каких-либо из публикуемых таблиц в базах данных подписки или публикации имеются триггеры, убедитесь, что эти триггеры могут обрабатывать многострочную вставку, обновления и удаления. Дополнительные сведения см. в разделе Замечания по работе с несколькими строками в триггерах DML.

Повторное создание таблиц конфликтов

При обновлении до SQL Server 2005 таблицы конфликтов создаются повторно, а их владельцем назначается DBO. Если в SQL Server 2000 владельцем какой-либо из таблиц был другой пользователь, может потребоваться изменение приложения.

При репликации слиянием для каждой статьи публикации создается таблица конфликтов с именем в форме conflict_PublicationName_ArticleName. Все таблицы метаданных при обновлении создаются повторно, а все таблицы конфликтов создаются в схеме DBO.

Новые назначаемые диапазоны идентификаторов

Для таблиц, использующих автоматическое управление диапазонами идентификаторов, при репликации в процессе обновления могут назначаться новые диапазоны идентификаторов. Если диапазон идентификаторов какой-либо из таблиц, назначенный подписчику, больше, чем назначенный издателю, при репликации издателю назначается диапазон, равный диапазону подписчика.

Чтобы определить диапазоны, используемые каждой из статей, выполните процедуру sp_helpmergearticle (Transact-SQL) в базе данных публикации и проверьте столбцы pub_identity_range и identity_range.

См. также

Основные понятия

Обратная совместимость репликации

Другие ресурсы

Улучшения в репликации


Изменения в поведении репликации SQL Server 2005

Изменения в поведении репликации SQL Server 2005 |
 | См. также
Обновление до SQL Server 2005 > Обратная совместимость > Обратная совместимость репликации >

Дата обновления: 14 апреля 2006 г.

В данном разделе описываются изменения в поведении системы репликации, которая реализована в . Дополнительные сведения об улучшении системы репликации см. в разделе Улучшения в репликации.

Примечание.
Этот раздел доступен в справочной документации по программе установки, а также в электронной документации по SQL Server 2005. Ссылки на разделы, выделенные полужирным шрифтом в справочной документации по установке, относятся к разделам, доступным только в электронной документации.

Изменения, связанные со всеми типами репликации

Следующие изменения связаны со всеми типами репликации.

Возможность | Описание
Модель безопасности агента репликации | В предыдущих версиях SQL Server агенты запускались по умолчанию в контексте учетной записи служб агентов SQL Server. позволяет проводить тонкую настройку для каждой учетной записи, под которой агенты репликации запускаются, и устанавливать доверенные соединения Microsoft Windows с базами данных и другими ресурсами. Для каждого агента может быть определена отдельная учетная запись. Дополнительные сведения см. в разделах Вопросы безопасности репликации и Модель безопасности агента репликации. Дополнительные сведения об изменениях, связанных с обновлениями, см. в подразделе «Новая модель безопасности агента репликации» раздела Обновление реплицируемых баз данных и в разделе Критические изменения репликации в SQL Server 2005.
Диспетчер синхронизации Windows | В предыдущих версиях SQL Server возможность синхронизировать подписки с диспетчером синхронизации была разрешена по умолчанию. В SQL Server 2005 необходимо явно разрешить этот параметр, если необходимо использовать диспетчер синхронизации. Дополнительные сведения см. в разделе Как синхронизировать подписку с помощью диспетчера синхронизации Windows.
Средство просмотра конфликтов репликации | В SQL Server 2000 средство просмотра конфликтов репликации было упаковано для перераспространения. В SQL Server 2005 данное средство не представлено отдельным пакетом. Чтобы включить средство просмотра конфликтов репликации в приложение, нужно установить на компьютер платформу Microsoft .NET Framework 2.0, на которой развертывается приложение, и скопировать некоторые файлы на компьютер. Дополнительные сведения см. в разделе «Другие вопросы обновления репликации» в справке помощника по обновлению. Дополнительные сведения о помощнике по обновлению см. в разделе Использование помощника по обновлению для подготовки к обновлениям.
Изменения в параметрах схемы | Параметры схемы позволяют указать, как связанные с таблицами атрибуты и объекты, такие как, например, индексы и ограничения, будут реплицироваться. Поведение некоторых параметров схемы изменилось в SQL Server 2005. В следующем разделе приводятся более подробные сведения.

Изменения в поведении параметров схемы

В следующей таблице приводятся изменения в параметрах схемы в SQL Server 2005.

Примечание.
Если параметр схемы 0x8000 был установлен в SQL Server 2000, он отключается при обновлении до SQL Server 2005. Для параметров схемы 0x10 или 0x40 репликация может создать большее количество индексов в SQL Server 2005, чем в SQL Server 2000.

Параметр | Поведение, если параметр установлен в SQL Server 2000 | Поведение, если параметр установлен в SQL Server 2005
0x80 | Создает ограничение или индекс. Если параметр 0x8000 также включен, в качестве ограничения с индексом создается первичный ключ. Если параметр 0x8000 не включен, создается только индекс для ключевого столбца. | Создает ограничение первичного ключа на стороне подписчика. Любые индексы, связанные с ограничением, также реплицируются, даже если параметры 0x10 и 0x40 не включены (эти параметры в таких случаях управляют созданием индекса).
0x4000 | Создает ограничение или индекс. Если параметр 0x8000 также включен, в качестве ограничения с индексом создается ограничение уникальности. Если параметр 0x8000 не включен, создается только индекс для столбца. | Создает ограничение уникальности на стороне подписчика. Любые индексы, связанные с ограничением, также реплицируются, даже если параметры 0x10 и 0x40 не включены (эти параметры в таких случаях управляют созданием индекса).
0x8000 | Создает ограничения первичного ключа и ограничения уникальности, если задан параметр 0x80 или 0x4000. Если ни один из этих параметров не задан, параметр 0x8000 не влияет на работу. | Параметр не влияет на работу сервера.

Изменение поведения для репликации транзакций

Следующие изменения влияют на репликацию транзакций.

Возможность Описание

Владелец объекта подписчика

Если для создания публикации используется мастер создания публикаций SQL Server 2005, то в качестве владельца объектов, созданных на подписчике, по умолчанию устанавливается владелец соответствующих объектов на издателе. В предыдущих выпусках владелец не был определен во время создания объекта на подписчике. По умолчанию владелец связывался с учетной записью агента распространителя, используемого для связи с подписчиком. Поведение хранимых процедур осталось неизменным sp_addarticle (Transact-SQL).

Режим безопасности обновляемых подписок

Параметр @security_mode из sp_link_publication управляет тем, как триггеры обновляемых подписок выполняют вызовы на издателе. В SQL Server 2005 этот параметр может принимать следующие значения.

  • 0: используется проверка подлинности SQL Server с именем, заданным в хранимой процедуре как имя и пароль входа в систему.

  • 1: используется контекст безопасности (проверка подлинности SQL Server или встроенная проверка подлинности Windows) пользователя, производящего изменение на подписчике.

  • 2: используется существующее, определенное пользователем имя для входа для связанного сервера.

В предыдущих версиях SQL Server использование параметра 0 для определения динамического вызова удаленной процедуры (RPC) от подписчика на издателе было предпочтительнее, чем использование связанного сервера.

Изменение поведения для репликации слиянием

Следующие изменения влияют на репликацию слиянием.

Возможность Описание

Уровень совместимости публикации

В предыдущих версиях SQL Server уровень совместимости автоматически увеличивался, если включались функции, требуемые на более высоком уровне. В SQL Server 2005 необходимо вручную установить уровень совместимости в значение 90RTM перед включением функции, для которой необходим этот уровень совместимости. Для получения дополнительных сведений см. подраздел «Уровни совместимости для публикаций слиянием» раздела Использование нескольких версий SQL Server в топологии репликации.

Действия по компенсации

В предыдущих версиях SQL Server действия по компенсации выполнялись в случае, если возникали ошибки во время синхронизации (такие как нарушения заданных ограничений). В некоторых случаях такое поведение желательно, но иногда это может вызвать проблемы. Например, один неверно настроенный подписчик, на котором возникла ошибка, может привести к отмене изменений на издателе и всех других подписчиках.

В SQL Server 2005 параметр @compensate_for_errors хранимой процедуры sp_addmergearticle определяет, будут ли производиться действия по компенсации. Когда значение установлено в False (значение по умолчанию), действия по компенсации запрещены. Однако ошибки еще регистрируются, и последовательность слияний будет продолжать попытки применить изменения. Хотя может оказаться, что данные в изменяемых строках не сходятся. В случае ошибок можно применить изменения и добиться соответствия данных. Если значение установлено в True, то изменения, которые не будут приняты в узле, во время синхронизации приведут к выполнению действий по компенсации, которые отменят изменения, принятые на других узлах.

Примечание.
Если исходная таблица для статьи уже опубликована в другой публикации, то значение параметра @compensate_for_errors должно быть одинаковым для обеих статей. Для подписок по запросу на подписчике, работающем на SQL Server 2000 версии 8.00.858 или раньше (которую включает пакет обновления 3), действия компенсации будут вызываться, даже если параметр @compensate_for_errors имеет значение False.

Таблицы конфликтов

В предыдущих версиях SQL Server репликация слиянием создает по одной таблице конфликтов на каждую табличную статью в публикации, с именем в форме conflict_<имя_статьи>. В SQL Server 2005 сведения содержатся в двух таблицах: MSmerge_conflicts_info и таблице с именем в форме MSmerge_conflict_<имя_публикации>_<имя_статьи>.

Очистка метаданных, основанных на удержании

SQL Server 2005 использует очистку метаданных, основанных на хранении, которая была введена в SQL Server 2000 с пакетом обновления 1 (SP1). Метаданные периодически удаляются из следующих системных таблиц.

  • MSmerge_contents

  • MSmerge_tombstone

  • MSmerge_genhistory

  • Любые таблицы с образами предыдущего состояния, если есть. Таблицы с образами предыдущего состояния присутствуют, если параметр оптимизации синхронизации @keep_partition_changes включен для публикации (см. следующий раздел для дополнительных сведений об этом параметре).

Параметр @keep_partition_changes

Параметр @keep_partition_changes имеет значение False по умолчанию в предыдущей версии SQL Server, потому что это приводит к большему количеству данных, чем количество данных, хранящихся на издателе. Теперь этот параметр имеет значение True, если уровень совместимости публикации имеет значение 90RTM или более, а параметр @use_partition_groups имеет значение False. Дополнительные сведения об этих параметрах см. в разделе Параметризованные фильтры строк.

См. также

Основные понятия

Обратная совместимость репликации

Другие ресурсы

Улучшения в репликации

Журнал изменений

Версия Журнал

14 апреля 2006 г.

Новое содержимое
  • Добавленные сведения об изменениях в поведении для параметров схемы.


Использование нескольких версий SQL Server в топологии репликации

Использование нескольких версий SQL Server в топологии репликации |
 | См. также
Обновление до SQL Server 2005 > Обратная совместимость > Обратная совместимость репликации >

Дата обновления: 14 апреля 2006 г.

Поддерживается репликация данных в различные версии . В этом разделе описываются:

  • поддерживаемые версии SQL Server;

  • сопоставление типов данных SQL Server 2005 для предыдущих версий;

  • восстановление реплицированной базы данных из предыдущей версии;

  • уровень совместимости для публикаций слиянием.

Сведения о репликации данных в выпусках и см. в разделах Репликация данных в SQL Server Express и Репликация данных в SQL Server Mobile. Сведения о возможностях, поддерживаемых каждым выпуском SQL Server, см. в разделе Возможности, поддерживаемые различными выпусками SQL Server 2005.

Примечание.
Этот раздел доступен в справочной документации по программе установки, а также в электронной документации по SQL Server 2005. Ссылки на разделы, выделенные полужирным шрифтом в справочной документации по установке, относятся к разделам, доступным только в электронной документации.

Поддерживаемые версии SQL Server

SQL Server версии 7.0 с пакетом обновления 4 (SP4) является минимальной версией, необходимой для участия в топологии репликации с SQL Server 2005. При использовании SQL Server 2000 необходим пакет обновления 3 (SP3) или более поздний.

При репликации между различными версиями SQL Server функциональные возможности чаще всего ограничиваются возможностями более ранней из используемых версий. Например, если распространитель обновляется до экземпляра SQL Server 2005, но при этом на издателе запущен экземпляр SQL Server 2000, а на подписчике — экземпляр SQL Server версии 7.0, пользователь будет ограничен общими функциональными возможностями и возможностями репликации экземпляра SQL Server версии 7.0.

Для всех типов репликации версия распространителя должна быть не ниже версии издателя (во многих случаях распространитель является тем же экземпляром, что и издатель). SQL Server 2005 можно использовать в качестве удаленного распространителя для SQL Server 2005 и SQL Server 2000, но не для SQL Server версии 7.0. В следующих таблицах приведены дополнительные сведения о том, какие версии SQL Server могут принимать участие в одной топологии. Дополнительные сведения о возможностях репликации, поддерживаемых в различных выпусках, см. в разделе Возможности, поддерживаемые различными выпусками SQL Server 2005.

Репликация транзакций и репликация моментальных снимков с подписчиками, доступными только для чтения

Распространитель | SQL Server 7.0 | SQL Server 2000 | SQL Server 2005
Издатель | SQL Server 7.0 | SQL Server 7.0 SQL Server 2000 | SQL Server 2000 SQL Server 2005
Подписчики | SQL Server 7.0 SQL Server 2000 SQL Server 2005 | SQL Server 7.0 SQL Server 2000 SQL Server 2005 | SQL Server 7.0 SQL Server 2000 SQL Server 2005

В таблице выше показано, что подписчик на публикацию транзакций, способный только читать данные, может иметь любую версию, отличающуюся от версии издателя не более чем на две версии. Например, издатель SQL Server версии 7.0 может иметь подписчиков SQL Server 2005, а издатель SQL Server 2005 может иметь подписчиков SQL Server версии 7.0.

Репликация транзакций с обновляемыми подписчиками

Распространитель | SQL Server 7.0 | SQL Server 2000 | SQL Server 2005
Издатель | SQL Server 7.01 | SQL Server 7.01 SQL Server 20002 | SQL Server 20002 SQL Server 20053
Подписчики | SQL Server 7.0 | SQL Server 7.0 SQL Server 2000 SQL Server 2005 | SQL Server 7.0 SQL Server 2000 SQL Server 2005

1 Для издателя SQL Server версии 7.0 в качестве подписчиков поддерживаются только SQL Server версии 7.0.

2 Для издателя SQL Server 2000 версии 7.0 в качестве подписчиков поддерживаются SQL Server версии 7.0, SQL Server 2000 и SQL Server 2005.

3 Для издателя SQL Server 2005 поддерживаются подписчики SQL Server 2000 и SQL Server 2005.

Репликация слиянием

Распространитель | SQL Server 7.0 | SQL Server 2000 | SQL Server 2005
Издатель | SQL Server 7.0 | SQL Server 7.0 SQL Server 2000 | SQL Server 2000 SQL Server 2005
Подписчики | SQL Server 7.0 | SQL Server 7.0 SQL Server 2000 | SQL Server 7.0 SQL Server 2000 SQL Server 2005

В таблице выше показано, что подписчик на публикацию слиянием может быть любой версии, но не выше, чем версия издателя. Дополнительные сведения о совместимости предыдущих версий см. в подразделе «Уровень совместимости для публикаций слиянием» ниже в данном разделе.

SQL Server 7.0 и среда SQL Server Management Studio

Среда SQL Server Management Studio может подключаться к экземплярам, запущенным на SQL Server 2000 или более поздних версий. Для подписчиков, на которых запущен SQL Server версии 7.0, верно следующее.

  • Подписки и публикации могут быть созданы с помощью инструментальных средств SQL Server версии 7.0, средств SQL Server 2000, объектов SQL-DMO или хранимых процедур.

  • Агенты для подписок по запросу не могут быть запущены из среды Management Studio или из монитора репликации. Запуск агентов по расписанию может быть назначен при создании подписки, либо они могут запускаться из командной строки.

Для подписчиков, на которых запущен SQL Server версии 7.0, подписки становятся доступны в среде Management Studio и в мониторе репликации после их создания. Дополнительные сведения о создании подписок и публикаций, а также о запуске агентов см. в электронной документации по SQL Server версии 7.0.

Применение распространителя SQL Server 2005 с издателем, который запущен на SQL Server 2000

SQL Server 2005 можно использовать в качестве удаленного распространителя для издателей, запущенных на SQL Server 2000. Чтобы изменить свойства агента в этом сценарии, выполните следующие хранимые процедуры на распространителе. Они позволяют изменять новые свойства, появившиеся в SQL Server 2005:

  • sp_MSchange_snapshot_agent_properties (Transact-SQL)

  • sp_MSchange_logreader_agent_properties (Transact-SQL)

  • sp_MSchange_distribution_agent_properties (Transact-SQL)

  • sp_MSchange_merge_agent_properties (Transact-SQL)

Если на издателе и на распространителе запущен SQL Server 2000, можно изменить учетные данные, с которыми агенты устанавливают соединения с помощью процедур sp_changedistpublisher (Transact-SQL) и sp_changesubstatus (Transact-SQL). Однако если распространитель обновляется до SQL Server 2005, эти процедуры не могут быть использованы для изменения учетных данных, применяемых в существующих заданиях агентов (они оказывают влияние только на те задания агента, которые создаются после вызова процедуры). Чтобы изменить учетные данные для существующих заданий агентов, вызовите одну из четырех приведенных выше процедур.

Сопоставление типов данных SQL Server 2005 для предыдущих версий

В SQL Server 2005 добавлен ряд новых типов данных. Эти новые типы данных сопоставляются с совместимыми типами данных подписчика при использовании принудительных подписок от распространителя SQL Server 2005.

Тип данных SQL Server 2005 | Тип данных SQL Server 2000 или SQL Server 7.0
XML | NTEXT
CLR User Defined Types (UDT) | IMAGE
VARCHAR(max) | TEXT
NVARCHAR(max) | NTEXT
VARBINARY(max) | IMAGE

Следует обеспечить должное сопоставление типов данных VARCHAR(max), NVARCHAR(max), VARBINARY(max), XML и CLR UDT, если производится их репликация на подписчики, работающие под управлением более ранней версии SQL Server (оно выполняется по умолчанию для статей в публикациях слиянием). Процесс сопоставления для этих типов управляется параметрами схемы 0x20, 0x10000000 и 0x20000000 при вызове процедур sp_addarticle (Transact-SQL) и sp_addmergearticle (Transact-SQL). Дополнительные сведения о настройке параметров схемы см. в разделах Как указать параметры схемы (среда SQL Server Management Studio) и How to: Specify Schema Options (Replication Transact-SQL Programming).

В SQL Server 2000 добавлены два новых типа данных, которые сопоставляются с совместимыми типами данных SQL Server версии 7.0. Эти новые типы данных сопоставляются с совместимыми типами данных подписчика при использовании принудительных подписок от распространителя SQL Server 2005 или SQL Server 2000.

Тип данных SQL Server 2005 или SQL Server 2000 | Тип данных SQL Server 7.0
SQL_VARIANT | IMAGE
BIGINT | DECIMAL

Восстановление реплицированной базы данных из предыдущей версии

Можно сохранить настройки репликации при восстановлении резервной копии реплицируемой базы данных из предыдущей версии. При восстановлении из резервных копий серверов и баз данных с теми же именами, что и у сервера или базы данных, для которых была сделана резервная копия, или при указании параметра KEEP_REPLICATION параметры репликации сохраняются. Дополнительные сведения см. в разделе RESTORE (Transact-SQL). После восстановления базы данных из копии выполните хранимую процедуру sp_vupgrade_replication (Transact-SQL), чтобы обновить схему и системные данные для поддержки репликации на текущем уровне продукта.

Хотя сохранение репликации после восстановления из резервной копии предыдущей версии возможно, этим пользуются редко и только в крайнем случае. Чаще используется обновление реплицируемой базы данных в рамках обновления продукта или повторного создания базы данных и конфигурации репликации из набора сценариев.

Уровень совместимости для публикаций слиянием

Репликация слиянием использует уровень совместимости публикаций, чтобы определить, какие возможности могут быть использованы публикациями в указанной базе данных. Диапазон значений: от 70RTM (SQL Server версии 7.0 без установленных пакетов обновления) до 90RTM. Уровень совместимости указан:

  • с параметром @publication_compatibility_level процедуры sp_addmergepublication (Transact-SQL). Дополнительные сведения см. в разделе How to: Set the Publication Compatibility Level (Replication Transact-SQL Programming).

  • на странице Типы подписчиков мастера создания публикаций. Дополнительные сведения о запуске этого мастера см. в разделе Как создать публикацию и определить статьи (среда SQL Server Management Studio);

  • на странице Общие диалогового окна Свойства публикации — <публикация>. Дополнительные сведения см. в разделе Как настроить уровень совместимости для публикации слиянием (среда SQL Server Management Studio).

Для следующих возможностей необходим уровень совместимости 90RTM и выше.

  • Логические записи. Дополнительные сведения см. в разделе Изменения группирования связанных строк с логическими записями.

  • Параметры передачи подписчика. Дополнительные сведения см. в разделе Оптимизация производительности репликации слиянием при работе со статьями, доступными только для загрузки.

  • Неперекрывающиеся секции. Дополнительные сведения см. в разделе Параметризованные фильтры строк.

  • Обработчики бизнес-логики. Дополнительные сведения см. в разделе Выполнение бизнес-логики при синхронизации слиянием.

  • Схема изменяется с помощью инструкций ALTER <OBJECT>. Дополнительные сведения см. в разделе Внесение изменений схем в базы данных публикаций.

Следующие возможности не зависят от уровня совместимости, но для них необходимо наличие агента слияния, который входит в состав SQL Server 2005. Подписчики, использующие предыдущие версии SQL Server, работают так, будто эта возможность отключена.

  • Предварительно вычисляемые секции. Дополнительные сведения см. в разделе Оптимизация производительности параметризованного фильтра с помощью предварительно вычисляемых секций.

  • Веб-синхронизация. Дополнительные сведения см. в разделе Веб-синхронизация для репликации слиянием.

  • Агенты параллельных фаз (указывающие параметр -ParallelUploadDownload для агента слияния). Дополнительные сведения см. в разделе Replication Merge Agent.

  • Новые функции моментальных снимков для публикаций, которые используют параметризованные фильтры, включая возможность:

    • для подписчика — запросить моментальный снимок, если он недоступен для секции подписчика;

    • для администратора — выполнить предварительное формирование моментальных снимков и запланировать их формирование;

    • передавать параметризованные моментальные снимки по протоколу FTP.

    Дополнительные сведения см. в разделах Моментальные снимки для публикаций слиянием с параметризованными фильтрами и Передача моментальных снимков по протоколу FTP.

  • Улучшенные средства ведения журналов и статистика по статьям в мониторе репликации. Дополнительные сведения см. в разделе Как просмотреть сведения и выполнить задачи для подписки (монитор репликации).

Поведение уровня совместимости публикации в SQL Server 2005

Важно понимать поведение уровня совместимости публикации.

  • Уровень совместимости публикации не связан с уровнем совместимости базы данных.

  • Если публикация создается с помощью процедуры sp_addmergepublication (Transact-SQL) или объектов RMO, по умолчанию уровень совместимости публикации устанавливается в значение 80RTM. Если публикация создается мастером создания публикаций, уровень совместимости публикации определяется на основании параметров, выбранных на странице мастера Типы подписчиков.

  • В предыдущих версиях SQL Server уровень совместимости публикаций автоматически увеличивался, если включались функции, требуемые на более высоком уровне. В SQL Server 2005 необходимо вручную установить уровень совместимости публикаций в значение 90RTM перед включением функции, для которой необходим этот уровень совместимости.

    При обновлении издателя SQL Server версии 7.0 и последующем выборе одной или нескольких возможностей, которые потребуют уровень совместимости публикаций 80RTM, уровень совместимости автоматически увеличится.

  • Уровень совместимости публикации может быть уменьшен только в том случае, если агент моментальных снимков не был запущен и нет подписок на публикацию.

  • Все публикации в одной базе данных должны иметь одинаковый уровень совместимости. Из этого вытекает следующее.

    • Если база данных содержит публикацию с меньшим уровнем совместимости (например, 80RTM), а в ту же базу данных необходимо добавить другую публикацию с уровнем совместимости 90RTM, то перед добавлением новой публикации необходимо вручную увеличить уровень совместимости первой публикации.

    • Если база данных содержит две или более публикации с более низкими уровнями совместимости и нужно добавить еще одну публикацию в ту же базу данных с уровнем 90RTM, необходимо: удалить все публикации, кроме одной, увеличить уровень оставшейся публикации до 90RTM, повторно создать удаленные публикации с уровнем 90RTM и создать новую публикацию с уровнем 90RTM.

См. также

Основные понятия

Обратная совместимость репликации
Обновление реплицируемых баз данных

Другие ресурсы

Улучшения в репликации

Журнал изменений

Версия Журнал

14 апреля 2006 г.

Измененное содержимое
  • Добавлены таблицы для уточнения того, какие версии SQL Server можно использовать в той же топологии репликации.

  • Добавлены сведения о параметрах схемы, применяемой при сопоставлении типов данных.

  • Удалены сведения о том, что SQL Server версии 7.0 может использовать экземпляр SQL Server 2005 в качестве удаленного распространителя. Эта конфигурация не поддерживается.


Обратная совместимость полнотекстового поиска

Обратная совместимость полнотекстового поиска
Обновление до SQL Server 2005 > Обратная совместимость >

В подразделах раздела, посвященного обратной совместимости, описаны отличия в работе полнотекстового поиска по сравнению с предыдущей версией.

См... | Разделы о...
Критические изменения полнотекстового поиска в SQL Server 2005 | Изменения в полнотекстовом поиске, которые могут потребовать внесения изменений в приложения.
Изменения в поведении полнотекстового поиска в SQL Server 2005 | Прочие изменения в работе полнотекстового поиска в данном выпуске.


Критические изменения полнотекстового поиска в SQL Server 2005

Критические изменения полнотекстового поиска в SQL Server 2005 |
 | См. также
Обновление до SQL Server 2005 > Обратная совместимость > Обратная совместимость полнотекстового поиска >

В этом разделе описаны изменения в полнотекстовом поиске, которые могут потребовать изменений в приложениях.

Критические изменения, влияющие на приложения

Следующие критические изменения относятся к полнотекстовому поиску в .

Возможность Описание

Средства разбиения по словам и фильтры

Средства разбиения по словам и фильтры, используемые полнотекстовым поиском SQL Server, были значительно изменены для улучшения функциональности и надежности. В некоторых конкретных случаях изменения в средстве разбиения по словам могут повлиять на то, как размечаются некоторые данные. Это может привести к тому, что маркеры, создаваемые в SQL Server 2005, отличаются от маркеров, создаваемых в SQL Server 2000. Например, в SQL Server 2005 была улучшена разметка составных слов на немецком языке, и теперь могут быть размечены составные слова, состоящие более чем из двух частей. Это может повлиять на результаты запросов.

Свойство FULLTEXTCATALOG

В SQL Server 2000 свойство Itemcount возвращало результат статистической обработки числа проиндексированных строк в каждой индексированной полнотекстовой таблице в полнотекстовом каталоге, плюс единица для каждой таблицы в каталоге. В SQL Server 2005 это свойство изменено и точно отражает результат статистической обработки числа проиндексированных строк в каждой индексированной полнотекстовой таблице в полнотекстовом каталоге.

Длина имен полнотекстового каталога

В SQL Server 2005 длина имен полнотекстового каталога ограничена 120 символами, в отличие от 128 в предыдущих выпусках SQL Server.

Средство полнотекстового поиска Microsoft для службы SQL Server и сторонние фильтры

Служба полнотекстового поиска для Microsoft SQL Server (MSFTESQL) по умолчанию не загружает компоненты, которые не имеют подписи Microsoft.

Сторонний фильтр, например PDF-фильтр, установленный на сервере в настоящее время, не будет по умолчанию загружаться службой MSFTESQL после обновления.

Неподдерживаемые свойства полнотекстового поиска

Следующие свойства и настройки, касающиеся полнотекстового поиска, были удалены из SQL Server 2005.

  • DataTimeout

  • ConnectTimeout

  • Clean_up

  • LogSize

Несколько экземпляров SQL Server 2005 не могут совместно использовать средство полнотекстового поиска Microsoft для SQL Server (MSFTESQL).

При обновлении до SQL Server 2005 каждый экземпляр SQL Server имеет отдельный экземпляр средства полнотекстового поиска Microsoft для SQL Server (MSFTESQL).

Путь к каталогам полнотекстового поиска

В SQL Server 2005 изменился путь в представлении sysfulltextcatalogs и путь, возвращаемый системными хранимыми процедурами sp_help_fulltext_catalogs и sp_help_fulltext_catalogs_cursor. В SQL Server 2000 полнотекстовые каталоги размещались в корневом каталоге. В SQL Server 2005 они находятся в каталоге FTData.

Полнотекстовые индексы и недетерминированные и неточные вычисляемые столбцы

SQL Server 2005 не разрешает создавать полнотекстовые индексы на недетерминированных и неточных вычисляемых столбцах. Такие столбцы не могут использоваться как типизированные столбцы или как столбцы полнотекстового ключа.

sysfulltextnotify

Представление sysfulltextnotify не документировано в SQL Server 2000, но по-прежнему может возвращаться запросами. Данное представление было удалено в SQL Server 2005.

Полнотекстовые индексы и системные базы данных

В SQL Server 2000 полнотекстовые индексы поддерживались на базах данных master, tempdb и model. SQL Server 2005 не поддерживает это. Любые полнотекстовые каталоги в этих базах данных удаляются в процессе обновления до SQL Server 2005.

Глобальные средства разбиения по словам и фильтры

В SQL Server 2000 новые средства разбиения по словам и фильтры могли добавляться только как глобальные компоненты уровня операционной системы. SQL Server 2005 позволяет регистрацию новых средств разбиения по словам и фильтров на уровне экземпляра. Это обеспечивает функциональную изоляцию и изоляцию безопасности между экземплярами.

Дополнительные требования к дисковому пространству для полнотекстового поиска

Так как карта идентификаторов документа (DOCID) в SQL Server 2005 хранится в базе данных, требования к размеру на стороне базы данных повысились. Однако требования к размеру дискового пространства на стороне полнотекстового каталога снизились.

См. также

Основные понятия

Изменения в поведении полнотекстового поиска в SQL Server 2005

Другие ресурсы

Обратная совместимость полнотекстового поиска
Компонент Full-Text Search


Изменения в поведении полнотекстового поиска в SQL Server 2005

Изменения в поведении полнотекстового поиска в SQL Server 2005 |
 | См. также
Обновление до SQL Server 2005 > Обратная совместимость > Обратная совместимость полнотекстового поиска >

В этом разделе описываются изменения в поведении средств полнотекстового поиска по сравнению с предыдущими выпусками .

Изменения в поведении

В следующей таблице приводится список изменений в поведении.

Изменение в поведении Описание

Основное слияние

В SQL Server 2000 основное слияние начинается в полночь или после окончания полнотекстового индексирования 500 000 документов.

В SQL Server 2005 основное слияние начинается по окончании полного заполнения, а также при достижении внутреннего порогового значения числа индексных файлов полнотекстового индекса.

Основное слияние также происходит при полнотекстовом индексировании 500 000 документов, как и в SQL Server 2000.

SQL Server 2005 также позволяет пользователям начать основное слияние посредством использования языка определения данных.

Служба MSSearch

В SQL Server 2000 полнотекстовый поиск использовал в качестве ядра полнотекстового индексирования и поиска службу MSSearch. В SQL Server 2005 эта служба была переименована в службу MSFTESQL. Ядро MSFTESQL создано на основе технологии MSSearch.

Хранимые процедуры, относящиеся к полнотекстовому поиску

Так как хранимые процедуры, относящиеся к полнотекстовому поиску, были в SQL Server 2005 полностью переписаны для использования нового языка описания полнотекстовых данных (DDL), то некоторые ошибки могут перейти на уровень инструкций.

Следующие ошибки переходят на уровень инструкций. Остальные ошибки являются ошибками уровня пакета.

  • Ошибка проверки разрешения.

  • Ошибка проверки явной транзакции. (Полнотекстовая хранимая процедура не может быть вызвана внутри явных пользовательских транзакций.)

  • Запуск действия, связанного с полнотекстовым поиском, из баз данных master, temp или model.

  • Ошибка проверки базы данных на защиту от записи.

  • База данных не может использовать полнотекстовые возможности.

  • Проверка параметров:

    • Имя каталога не найдено.

    • Имя таблицы не существует, или таблица не подходит для полнотекстового индексирования.

    • Имя столбца в таблице неверно.

    • Параметры имени базы данных и таблицы имеют значение NULL.

Функциональность очистки полнотекстового каталога

Запуск процедуры очистки sp_fulltext_service в SQL Server 2005 невозможен.

Неучитываемые слова

В SQL Server 2005 запрос, использующий предикат или функцию полнотекстового поиска, содержит неучитываемые слова, и параметр конфигурации transform noise words не включен, выдается предупреждение и не возвращается ни одной строки. Дополнительные сведения об этом параметре см. в разделе Параметр transform noise words.

Возвращены строки с нулевым рангом

В SQL Server 2000 строки с нулевым рангом не возвращаются. В SQL Server 2005 эти строки включаются в результирующий набор. Это может повлиять на результаты хранимых процедур и прочих запросов.

Запуск процедуры sp_fulltext_database

В SQL Server 2005 запуск процедуры sp_fulltext_database 'enable' для пользовательской базы данных, в которой полнотекстовое индексирование уже разрешено, не производит никаких действий.

Примечание.
По умолчанию в пользовательских базах данных полнотекстовое индексирование разрешено.

См. также

Основные понятия

Критические изменения полнотекстового поиска в SQL Server 2005

Другие ресурсы

Обратная совместимость полнотекстового поиска
Компонент Full-Text Search


Установка компонентов SQL Server 2005

Установка компонентов SQL Server 2005 |
 | См. также

Дата обновления: 5 декабря 2005 г.

может быть установлен с помощью мастера установки или из командной строки. Мастер установки предлагает графический интерфейс пользователя, который помогает в выборе всех решений, принимаемых во время установки. Это предпочтительный метод для большинства пользователей. Мастер установки обеспечивает руководство по первоначальной установке SQL Server 2005, включая выбор компонентов, правила именования экземпляров, конфигурацию учетной записи службы, рекомендации по выбору надежного пароля и сценарии для установки параметров сортировки.

Установка из командной строки предназначена для использования в усовершенствованных сценариях, например для установки в автоматическом режиме. Она может быть запущена непосредственно из командной строки или с помощью синтаксиса командной строки, ссылающегося на файл установки для задания параметров установки.

Проверка требований установки SQL Server 2005
  • Требования к оборудованию и программному обеспечению для установки SQL Server 2005

  • Параметры для средства проверки конфигурации системы

  • Анализ безопасности при установке SQL Server

Установка компонентов SQL Server 2005 с помощью мастера установки SQL Server 2005
  • Как установить SQL Server 2005 (программа установки)

  • Как создать новый отказоустойчивый кластер SQL Server 2005 (установка)

Чтобы установить компоненты SQL Server 2005 из командной строки, см. разделы:
  • Как установить SQL Server 2005 из командной строки

  • Сведения об удаленной установке SQL Server 2005

Обновление предыдущей версии SQL Server
  • Обновления версий и выпусков

  • Обновление до SQL Server 2005

Добавление или удаление компонентов SQL Server 2005 с помощью мастера установки SQL Server 2005
  • Как изменить компоненты существующего экземпляра SQL Server 2005 (программа установки)

См. также

Основные понятия

Подготовка к установке SQL Server 2005

Другие ресурсы

Разделы руководства по установке компонента Database Engine


Установка ядра СУБД SQL Server

Установка ядра СУБД SQL Server |
 | См. также
Установка компонентов SQL Server 2005 >

Дата обновления: 5 декабря 2005 г.

Компонент SQL Server Database Engine входит в состав и представляет собой основную службу для хранения, обработки и обеспечения безопасности данных. Database Engine обеспечивает управляемый доступ и быструю обработку транзакций, удовлетворяющий требованиям большинства приложений по обработке данных на предприятии.

Компонент Database Engine поддерживает один или несколько экземпляров сервера на одном компьютере. Дополнительные сведения о выборе устанавливаемых компонентов и возможностей см. в разделе Выпуски и компоненты SQL Server 2005.

О создании стандартной установки SQL Server см. в разделе Как установить SQL Server 2005 (программа установки).

Важно!
Для локальной установки необходимо запустить программу установки с правами администратора. При установке SQL Server из удаленной общей папки необходимо использовать учетную запись домена с разрешениями на чтение и выполнение для удаленной общей папки.

Шаг 1. Подготовьте установку компонента Database Engine

Перед началом установки компонента SQL Server 2005 Database Engine просмотрите следующие требования:

  • Требования к оборудованию и программному обеспечению для установки SQL Server 2005

  • Параметры для средства проверки конфигурации системы

  • Анализ безопасности при установке SQL Server

  • Компоненты SQL Server Database Engine

Шаг 2. Установите компонент Database Engine

Если компьютер удовлетворяет требованиям к установке SQL Server 2005, можно начинать установку компонента Database Engine. В зависимости от среды компонент Database Engine можно установить одним из следующих способов.

  • Установка компонента Database Engine на чистый компьютер с помощью мастера установки. Дополнительные сведения см. в разделе Как установить SQL Server 2005 (программа установки) или Подготовка к установке отказоустойчивого кластера.

  • Установка компонента Database Engine на чистый компьютер из командной строки. Дополнительные сведения см. в разделе Сведения об удаленной установке SQL Server 2005. Пример синтаксиса командной строки см. в разделе Как установить SQL Server 2005 из командной строки.

  • Миграция или обновление предыдущей версии SQL Server до SQL Server 2005. Дополнительные сведения см. в разделах Обновление до SQL Server 2005 и Работа с несколькими версиями SQL Server.

Шаг 3. Проверьте установку компонента Database Engine

После завершения установки проверьте, что все службы SQL Server 2005 запущены. Дополнительные сведения см. в разделе Как проверить успешность установки служб SQL Server 2005.

Шаг 4. Настройте установленный компонент Database Engine

Некоторые возможности SQL Server 2005 по умолчанию выключены. Чтобы просмотреть параметры конфигурации, см. разделы Настройка установки SQL Server и Настройка контактной зоны SQL Server.

См. также

Справочник

Выпуски и компоненты SQL Server 2005
Настройка параметров сортировки и поддержка нескольких языков

Основные понятия

Компоненты SQL Server Database Engine

Другие ресурсы

Разделы руководства по установке компонента Database Engine
Настройка высокого уровня доступности


Компоненты SQL Server Database Engine

Компоненты SQL Server Database Engine |
 | См. также
Установка компонентов SQL Server 2005 > Установка ядра СУБД SQL Server >

Microsoft SQL Server 2005 поддерживает до 50 экземпляров Database Engine на одном компьютере. При выборе «Database Engine SQL Server» на странице Устанавливаемые компоненты мастера установки SQL Server 2005 производится установка следующих функций:

  • Database Engine;

  • репликация;

  • полнотекстовый поиск.

Следующие дополнительные возможности могут применяться во многих типичных пользовательских сценариях:

  • службы Integration Services;

  • компоненты связи;

  • модели программирования;

  • средства управления;

  • SQL Server Management Studio;

  • образцы баз данных AdventureWorks и примеры;

  • электронные руководства.

См. также

Справочник

Выпуски и компоненты SQL Server 2005
Возможности, поддерживаемые различными выпусками SQL Server 2005


Сведения об удаленной установке SQL Server 2005

Сведения об удаленной установке SQL Server 2005 |
 | См. также
Установка компонентов SQL Server 2005 > Установка ядра СУБД SQL Server >

Дата обновления: 5 декабря 2005 г.

Существуют два способа установки из командной строки, они описываются ниже.

Примечание.
Чтобы установить SQL Server 2005 на удаленный компьютер, используйте удаленное соединение для запуска программы установки SQL Server 2005 в режиме интерфейса пользователя или из командной строки.

В этом разделе

Раздел | Описание
Выполнение установки из командной строки | Перечисляются свойства и параметры для установки SQL Server из командной строки, включая автоматическую установку и установку в автоматическом режиме. Также приводятся образцы сценариев.
Указание свойств установки в INI-файле | Предоставляются сведения об использовании шаблона INI-файла, находящегося на DVD SQL Server, предназначенного для установки SQL Server 2005.

См. также

Задачи

Как установить SQL Server 2005 из командной строки


Выполнение установки из командной строки

Выполнение установки из командной строки |
 | См. также
Установка компонентов SQL Server 2005 > Установка ядра СУБД SQL Server > Сведения об удаленной установке SQL Server 2005 >

Дата обновления: 5 декабря 2005 г.

Программа установки SQL Server 2005 в дополнение графическому интерфейсу предоставляет интерфейс командной строки. Используйте синтаксис командной строки для выбора способа установки SQL Server 2005. Установки из командной строки могут задаваться в командной строке или в INI-файле.

Примечание.
Удаленная установка в данной версии не поддерживается. Чтобы установить SQL Server 2005 на удаленный компьютер, используйте удаленное соединение для запуска программы установки SQL Server в режиме интерфейса пользователя или из командной строки. Запись для автоматической установки (ISS-файл) в данной версии не поддерживается.

Примеры синтаксиса команд установки или удаления экземпляра SQL Server 2005 см. в разделе Как установить SQL Server 2005 из командной строки.

См. также

Основные понятия

Как перестроить реестр для SQL Server 2005
Как перестроить базу данных master в SQL Server 2005


Указание свойств установки в INI-файле

Указание свойств установки в INI-файле |
 | См. также
Установка компонентов SQL Server 2005 > Установка ядра СУБД SQL Server > Сведения об удаленной установке SQL Server 2005 >

Дата обновления: 5 декабря 2005 г.

Программа установки SQL Server 2005 в дополнение к графическому интерфейсу предоставляет интерфейс командной строки. Используйте синтаксис командной строки для выбора способа установки SQL Server 2005. Установки из командной строки могут задаваться в командной строке или в INI-файле.

Примечание.
Удаленная установка в этой версии не поддерживается. Чтобы установить SQL Server 2005 на удаленный компьютер, используйте удаленное соединение для запуска программы установки SQL Server в режиме интерфейса пользователя или из командной строки. Запись для автоматической установки (ISS-файл) в этой версии не поддерживается.

Примеры синтаксиса команд установки или удаления экземпляра SQL Server 2005 см. в разделе Как установить SQL Server 2005 из командной строки.

См. также

Основные понятия

Как перестроить реестр для SQL Server 2005
Как перестроить базу данных master в SQL Server 2005


Устранение неполадок при установке ядра СУБД SQL Server

Устранение неполадок при установке ядра СУБД SQL Server |
 | См. также
Установка компонентов SQL Server 2005 > Установка ядра СУБД SQL Server >

Дата обновления: 5 декабря 2005 г.

Ниже приведены некоторые общие проблемы, связанные с установкой Database Engine, а также предлагаемые способы их устранения.

Проблема. Приложениям не удалось прикрепить ресурсы SQL Server 2005 в распределенной транзакции

Объяснение. Поскольку координатор распределенных транзакций Microsoft (MS DTC) настраивается в Microsoft Windows не полностью, возможно, приложениям не удастся связать ресурсы SQL Server 2005 в распределенной транзакции. Эта проблема касается связанных серверов, распределенных запросов и удаленных хранимых процедур, использующих распределенные транзакции.

Решение. Для предотвращения этой проблемы необходимо полностью включить службы MS DTC на сервере, на котором установлен SQL Server 2005.

Для полного включения служб MS DTC выполните следующие шаги.

  1. На Панели управления откройте Администрирование, а затем Управление компьютером.

  2. На левой панели окна «Управление компьютером» раскройте Службы и приложения и щелкните Службы.

  3. На правой панели окна «Управление компьютером» правой кнопкой мыши щелкните Координатор распределенных транзакций и выберите Свойства.

  4. В окне «Координатор распределенных транзакций» перейдите на вкладку Общие и нажмите кнопку Стоп для остановки службы.

  5. В окне координатора распределенных транзакций перейдите на вкладку Вход в систему и выберите в качестве учетной записи для входа в систему NT AUTHORITY\NetworkService.

  6. Нажмите кнопки Применить и ОК, чтобы закрыть окно «Координатор распределенных транзакций». Закройте окно «Управление компьютером». Закройте окно «Администрирование».

Примечание.
Для установки SQL Server 2005 на компьютерах, входящих в состав отказоустойчивого кластера, службы MS DTC должны быть полностью включены и кластеризованы до запуска программы установки. Если службы MS DTC не кластеризованы, выполнение программы установки завершается неудачно. Перед запуском программы установки проверьте с помощью администратора кластеров, что MS DTC поддерживает кластеры.

Проблема. Обновление до SQL Server 2005 завершается с ошибкой, выдается следующее сообщение об ошибке: «Программе установки SQL Server не удалось подключиться к службе баз данных для настройки сервера».

Объяснение. Если порт 1433 недоступен во время обновления до SQL Server 2005, то программа установки SQL Server может вернуть следующее сообщение об ошибке:

Программе установки SQL Server не удалось подключиться к службе базы данных для настройки сервера.

Решение. Чтобы продолжить, завершите процесс, использующий порт 1433, и продолжите работу программы установки SQL Server 2005.

  1. В командной строке выполните программу netstat -o.

  2. Выясните, какое приложение или процесс использует порт 1433.

  3. Чтобы освободить порт 1433, завершите работу приложения или процесса с помощью диспетчера задач.

  4. Возобновите работу программы установки SQL Server 2005.

Если указанными выше способами не удается освободить порт 1433, выполните следующие дополнительные действия.

  1. Откройте окно Установка и удаление программ на панели управления.

  2. Выберите пункт Microsoft SQL Server 2005, а затем нажмите кнопку Изменить.

  3. На странице выбора компонентов установите переключатель для обновления экземпляра SQL Server и нажмите кнопку Далее.

  4. На странице «Поддерживаемые функции» щелкните Ядро СУБД, затем нажмите кнопку Далее.

  5. Нажмите Продолжить, чтобы возобновить операцию обновления до SQL Server 2005.

Проблема. Обновление может завершиться с ошибками, если к обновляемому экземпляру подключены локальные приложения.

Объяснение. Программе установки SQL Server требуется однопользовательский режим для завершения обновления до SQL Server 2005. Если к экземпляру SQL Server во время обновления подключены локальные приложения, программа установки завершится со следующей ошибкой:

Программе установки SQL Server не удалось подключиться к службе базы данных для настройки сервера. Ошибка: [Microsoft][SQL Native Client][SQL Server] Не выполнен вход в систему для пользователя <DomainName\AdminAccount>. Причина: SQL Server работает в однопользовательском режиме. В это время может подключаться только администратор. Дополнительные сведения см. в журналах ошибок сервера. Дополнительные сведения о просмотре журналов ошибок программы установки см. в разделе «Как: Просмотреть файлы журнала программы установки» электронной документации по SQL Server.

Решение. Как правило, этот сбой возникает при запуске служб Reporting Services во время обновления SQL Server. Для устранения этой причины следует закрыть все приложения, которые подключаются к экземпляру SQL Server, и нажать в окне сообщения об ошибке кнопку «Повторить», чтобы продолжить обновление.

Объяснение. Программа установки SQL Server 2005 завершается с ошибками из-за неправильной конфигурации существующих компонентов SQL Server.

Проблема. Возможно, эта неполадка вызвана тем, что в установленной копии клиента SQL Server выбран параметр «принудительное шифрование». В этом случае выводится следующее сообщение об ошибке:

Программе установки SQL Server не удалось подключиться к службе базы данных для настройки сервера. Ошибка: [Microsoft]<имя компонента> поставщик SSL: Имя CN сертификата не соответствует переданному значению. Дополнительные сведения см. в журналах ошибок сервера и журналах программы установки. Дополнительные сведения о просмотре журналов программы установки см. в разделе «Как просмотреть журналы программы установки» электронной документации по SQL Server.

Решение. Отключите принудительное шифрование на существующих клиентах SQL Server с помощью программы SQL Server 2000 Client Network Utility (для клиентов MDAC в SQL Server 2000) или диспетчера конфигурации SQL (для собственного клиента SQL в SQL Server 2005), а затем заново запустите программу установки SQL Server 2005.

См. также

Задачи

Как проверить успешность установки служб SQL Server 2005
Как просмотреть файл журнала установки SQL Server 2005

Основные понятия

Диагностика отказоустойчивого кластера
Как просмотреть файлы журналов установки SQL Server 2005
Как перестроить реестр для SQL Server 2005
Как перестроить базу данных master в SQL Server 2005


Установка служб SQL Server Analysis Services

Установка служб SQL Server Analysis Services |
 | См. также
Установка компонентов SQL Server 2005 >

Этап 1. Подготовка к установке служб SQL Server Analysis Services 2005

Перед установкой служб ознакомьтесь с требованиями из следующих разделов.

  • Требования к оборудованию и программному обеспечению для установки SQL Server 2005

  • Параметры для средства проверки конфигурации системы

  • Анализ безопасности при установке SQL Server

Этап 2. Установка служб SQL Server Analysis Services 2005

После ознакомления с требованиями для установки SQL Server 2005 и проверки соответствия компьютера этим требованиям можно приступить к установке служб SQL Server 2005 Analysis Services. В зависимости от рабочей среды службы Analysis Services можно установить одним из способов, описанных в следующих разделах.

  • Установка служб SQL Server Analysis Services 2005 на чистый компьютер

  • Установка служб SQL Server Analysis Services 2005 параллельно со службами SQL Server Analysis Services 2000

  • Обновление служб SQL Server 2005 Analysis Services

Установка служб SQL Server Analysis Services 2005 на чистый компьютер

Как и любой другой компонент SQL Server 2005, службы Analysis Services можно установить либо с помощью программы установки SQL Server через мастер установки SQL Server, либо с помощью программы установки из командной строки.

Вариант 1. Использование мастера установки SQL Server

Можно установить службы Analysis Services на локальный компьютер или на отказоустойчивый кластер, используя мастер установки SQL Server.

Раздел | Описание
Установка служб SQL Server Analysis Services с помощью программы установки | Сведения по установке, относящиеся к службам SQL Server 2005 Analysis Services.
Как установить SQL Server 2005 (программа установки) | Сведения по установке, которые описывают каждый шаг мастера установки SQL Server и применяются для всех компонентов SQL Server 2005, включая службы Analysis Services.

Вариант 2. Запуск программы установки из командной строки

Можно запустить программу установки SQL Server в командной строке. Если службы Analysis Services устанавливаются на удаленном компьютере, то необходимо запустить программу установки из командной строки.

Подраздел | Описание
Установка служб SQL Server Analysis Services из командной строки | Сведения для программы установки из командной строки, относящиеся к службам Analysis Services.
Как установить SQL Server 2005 из командной строки | Сведения для программы установки из режима командной строки описывают шаги и параметры такого вида установки. Эти сведения применимы ко всем компонентам SQL Server 2005, включая службы Analysis Services.

В начало

Установка служб SQL Server Analysis Services 2005 параллельно со службами SQL Server Analysis Services 2000

Можно установить службы SQL Server 2005 Analysis Services как именованный экземпляр параллельно с экземпляром служб Analysis Services по умолчанию. Поскольку службы SQL Server 2000 Analysis Services не поддерживают именованные экземпляры, то экземпляр служб SQL Server 2000 Analysis Services всегда должен быть экземпляром по умолчанию при параллельной установке.

Если существующие базы данных служб SQL Server 2000 Analysis Services не повреждены, то можно также выполнить их миграцию в формат баз данных служб SQL Server 2005 Analysis Services.

Подраздел | Описание
Обновление и миграция служб Analysis Services | Общие сведения о параллельной установке и миграции баз данных.
Миграция существующих баз данных служб Analysis Services | Сведения о мастере миграции баз данных служб Analysis Services и различиях между SQL Server 2000 Analysis Services и объектами баз данных SQL Server 2005 Analysis Services.
Обратная совместимость служб SQL Server 2005 Analysis Services | Сведения о неподдерживаемых и устаревших функциях и об изменении поведения при переходе от служб SQL Server 2000 Analysis Services к SQL Server 2005 Analysis Services.

В начало

Обновление служб SQL Server 2005 Analysis Services

Можно обновить более ранние версии служб Analysis Services до SQL Server 2005 Analysis Services, используя программу установки или различные средства в дополнение к программе установки SQL Server.

Чтобы произвести обновление, используя программу установки, во время установки введите имя существующего экземпляра служб SQL Server 2000 Analysis Services. Для обновления именованного экземпляра служб SQL Server 2005 Analysis Services после установки используйте мастер миграции служб Analysis Services для переноса существующих баз данных служб Analysis Services на новый экземпляр сервера. Можно удалить службы SQL Server 2000 Analysis Services и использовать средство переименования экземпляра служб Analysis Services, чтобы сделать экземпляр служб SQL Server 2005 Analysis Services экземпляром по умолчанию.

Подраздел | Описание
Обновление и миграция служб Analysis Services | Общие сведения о параллельной установке и миграции баз данных.
Миграция существующих баз данных служб Analysis Services | Сведения о мастере миграции баз данных служб Analysis Services и различиях между объектами баз данных служб SQL Server 2000 Analysis Services и SQL Server 2005 Analysis Services.
Обратная совместимость служб SQL Server 2005 Analysis Services | Сведения о неподдерживаемых и устаревших функциях и об изменении поведения при переходе от служб SQL Server 2000 Analysis Services к SQL Server 2005 Analysis Services.

В начало

См. также

Другие ресурсы

Установка компонентов SQL Server 2005


Установка служб SQL Server Analysis Services с помощью программы установки

Установка служб SQL Server Analysis Services с помощью программы установки |
 | См. также
Установка компонентов SQL Server 2005 > Установка служб SQL Server Analysis Services >

Дата обновления: 5 декабря 2005 г.

Примечание.
Дополнительные сведения об использовании мастера установки для установки компонентов SQL Server 2005 см. в разделе Как установить SQL Server 2005 (программа установки).

Этот раздел содержит только сведения, касающиеся установки служб с помощью мастера установки SQL Server.

  • Выбор компонентов для установки

  • Указание расположения файлов служб Analysis Services

  • Указание экземпляров служб Analysis Services

  • Настройка учетных записей служб Analysis Services

  • Определение режима проверки подлинности служб Analysis Services

  • Задание параметров сортировки служб Analysis Services

Выбор компонентов для установки

Хотя установить службы Analysis Services можно отдельно, примите во внимание тот факт, что многие решения хранилищ данных требуют установки дополнительных компонентов SQL Server 2005 для получения возможности разработки, развертывания и администрирования баз данных служб Analysis Services. В следующей таблице перечислены эти дополнительные, необязательные компоненты SQL Server 2005.

Компонент | Для администратора | Для разработчика | Необязательный
Компоненты связи Компоненты, обеспечивающие связь между клиентами и серверами, включая сетевые библиотеки для DB-Library, ODBC и OLE DB. | X | X |
Средства управления Интерактивные средства для управления SQL Server 2005, включая диспетчер конфигурации SQL Server, SQL Server Management Studio, SQL Server Profiler и монитор репликации. | X |  |
Среда Business Intelligence Development Studio Интегрированная среда разработки для проектов бизнес-аналитики. |  | X |
Набор средств разработки программного обеспечения Программное обеспечение, помогающее разработчикам создавать собственные решения для SQL Server 2005. |  | X |
Службы SQL Server Database Services Компонент SQL Server Database Engine и средства для управления реляционными данными и XML-данными, компонент Full-Text Search и репликация. |  |  | X
Reporting Services Сервер отчетов для управления, выполнения, подготовки и распространения отчетов, а также диспетчер отчетов — пользовательский веб-интерфейс, который обеспечивает доступ к компонентам служб SQL Server 2005 Reporting Services (SSRS), включая инструментальные средства администрирования и пользовательский интерфейс для просмотра отчетов. |  |  | X
Integration Services Службы SQL Server 2005 Integration Services (SSIS), набор графических и программируемых объектов для перемещения, копирования и преобразования данных. |  |  | X
Документация и образцы Электронная документация по SQL Server, справочные материалы по программированию и образцы для всех компонентов SQL Server 2005. | X | X | X

Установка выбранных компонентов

Службы Analysis Services можно установить отдельно или вместе с дополнительными компонентами SQL Server 2005, как описано в следующих процедурах.

Отдельная установка служб Analysis Services

  • На странице Компоненты для установки в мастере установки SQL Server выберите только Службы Analysis Services.

    Примечание.
    Если выбрать установку только служб Analysis Services, то клиентские компоненты SQL Server 2005, включая средства командной строки, компоненты связи, модели программирования, средства разработки и управления, документацию и образцы, не будут установлены по умолчанию.
Добавление или удаление устанавливаемых компонентов с помощью страницы «Компоненты для установки»

  • На странице Компоненты для установки мастера установки установите или снимите флажки для тех компонентов, которые нужно добавить или удалить.

    Примечание.
    Если выбрать параметр установки Компоненты рабочей станции, электронная документация и средства разработки на странице Компоненты для установки, то образцы баз данных и программирования по умолчанию не устанавливаются. Эти параметры необходимо выбрать вручную на странице Выбор компонентов.
Добавление или удаление компонентов с помощью страницы «Выбор компонентов»

  1. На странице Компоненты для установки нажмите кнопку Дополнительно.

  2. На странице Выбор компонентов установите флажки для тех компонентов, которые нужно установить, и снимите флажки для тех компонентов, которые нужно удалить.

    Примечание.
    Страница Выбор компонентов предоставляет удобный способ просмотра подробного списка параметров установки в мастере установки SQL Server, включая компоненты, описанные ранее в этом разделе.

Указание расположения файлов служб Analysis Services

Программа установки SQL Server 2005 помещает программные файлы, файлы данных и общие файлы служб Analysis Services в разные места. У каждого экземпляра служб Analysis Services есть отдельный набор папок, в которых хранятся программные файлы и файлы с данными для экземпляра. Расположение папок по умолчанию для файлов служб Analysis Services приведено в следующей таблице.

Файлы служб Analysis Services | Расположение по умолчанию
Экземпляры SQL Server 2005 и служб Analysis Services | C:\Program Files\Microsoft SQL Server\MSSQL.n где число n представляет собой последовательность, в которой были установлены различные экземпляры, начиная с 1. Это расположение может быть изменено при установке.
Файлы данных и общие файлы для экземпляра служб Analysis Services | C:\Program Files\Microsoft SQL Server\MSSQL.n\OLAP\Data C:\Program Files\Microsoft SQL Server\MSSQL.n\OLAP\bin
Компоненты, общие для всех экземпляров компонента SQL Server 2005 | C:\Program Files\Microsoft SQL Server\90\Shared Эту папку нельзя изменить при установке.
Средства, документация и образцы | C:\Program Files\Microsoft SQL Server\90\Tools Для всех экземпляров служб Analysis Services и других компонентов SQL Server устанавливается один комплект средств и документации.
Изменение расположения файлов служб Analysis Services по умолчанию при установке

  1. На странице Компоненты для установки мастера установки щелкните Дополнительно.

  2. На странице Выбор компонентов щелкните компонент, который поддерживает изменение пути установки по умолчанию, и нажмите кнопку Обзор.

  3. В поле Папка установки на странице Смена папки введите новое расположение файлов.
Важно!
Теперь можно использовать страницу Выбор компонентов мастера установки, чтобы установить определенные компоненты SQL Server 2005 в место, отличное от расположения по умолчанию %ProgramFiles%\Microsoft SQL Server\90. Этот параметр доступен для служб SQL Server 2005 Integration Services (SSIS), служб SQL Server 2005 Notification Services и компонентов рабочей станции (которые включают клиентские средства, документацию и образцы). Соответствующий ключ, используемый при установке из командной строки, — installsqlshareddir.

Указание экземпляров служб Analysis Services

На странице Имя экземпляра мастера установки SQL Server можно указать, устанавливать ли экземпляр служб SQL Server 2005 Analysis Services по умолчанию или именованный экземпляр. Можно установить только один экземпляр служб SQL Server 2005 Analysis Services по умолчанию. Экземпляр по умолчанию не является обязательным.

На странице Имя экземпляра можно указать лишь одно имя экземпляра для всех компонентов SQL Server 2005, выбранных для установки. Поэтому невозможно, например, одновременно установить экземпляр компонента SQL Server Database Engine по умолчанию и именованный экземпляр служб Analysis Services. В таком случае необходимо запустить программу установки отдельно для каждого именованного экземпляра.

Если на сервере уже установлен экземпляр служб SQL Server 2000 Analysis Services, то возможно установить только именованный экземпляр служб SQL Server 2005 Analysis Services, пока существующий экземпляр по умолчанию не будет обновлен до версии SQL Server 2005 Analysis Services. При вводе имени существующего экземпляра на странице Имя экземпляра мастера установки SQL Server страница Обновляемые компоненты запросит подтверждения намерений по обновлению существующего экземпляра.

Если службы SQL Server 2005 Analysis Services устанавливаются параллельно с SQL Server 2000 Analysis Services, необходимо установить службы SQL Server 2005 Analysis Services как именованный экземпляр.

При установке нескольких экземпляров служб SQL Server 2005 Analysis Services на одном сервере они все должны быть именованными, причем желательно, чтобы имена имели смысл и характеризовали экземпляры.

Примечание.
Лицензия на выпуск позволяет устанавливать несколько экземпляров служб SQL Server 2005 Analysis Services на одном компьютере. Для других выпусков SQL Server 2005 требуется отдельная лицензия для каждого экземпляра. За подробностями обратитесь к лицензионному соглашению, поставляемому с продуктом.

Дополнительные сведения о сценариях параллельной установки служб SQL Server 2000 Analysis Services и служб SQL Server 2005 Analysis Services см. в разделе Обновление и миграция служб Analysis Services.

Можно использовать средство переименования экземпляра служб Analysis Services, чтобы переименовать установленный экземпляр служб SQL Server 2005 Analysis Services или сделать именованный экземпляр экземпляром по умолчанию, если такового не существует.

Дополнительные сведения см. в разделе Как переименовать экземпляр служб Analysis Services.

Настройка учетных записей служб Analysis Services

Службы Analysis Services запускаются и выполняются как служба Microsoft Windows. Эта служба появляется в списке установленных служб в диспетчере конфигурации SQL Server и в оснастке «Службы» консоли управления Microsoft (MMC), предоставляющей административную поддержку для служб Windows.

Каждый экземпляр служб Analysis Services поддерживается собственной службой, и каждый экземпляр может использовать различные настройки параметров сортировки и других параметров сервера. Имя службы для каждого экземпляра отражает имя экземпляра, которое было указано во время установки. Имя службы для экземпляра по умолчанию — MSSQLServerOLAPService. Имя службы для именованного экземпляра — MSOLAP$имя_экземпляра, где имя_экземпляра — имя, указанное при установке экземпляра.

Учетная запись, используемая для выполнения службы Analysis Services, должна быть членом локальной группы администраторов.

Просмотр службы Analysis Services в оснастке «Службы»

  1. Нажмите кнопку Пуск, выберите пункты Все программы, Администрирование и щелкните Службы.

  2. В списке служб найдите следующие записи.

    • Для экземпляра служб Analysis Services по умолчанию ищите MSSQLServerOLAPService.

    • Для именованного экземпляра служб Analysis Services ищите MSOLAP$имя_экземпляра.

Дополнительные сведения об учетных записях служб SQL Server 2005 см. в разделе Настройка учетных записей служб Windows.

Определение режима проверки подлинности служб Analysis Services

Службы SQL Server 2005 Analysis Services поддерживают только проверку подлинности Windows.

Задание параметров сортировки служб Analysis Services

В службах Analysis Services используются те же обозначения параметров сортировки и настройки порядка сортировки, что и в компоненте SQL Server Database Engine. Если службы Analysis Services и компонент SQL Server Database Engine устанавливаются с одним и тем же именем экземпляра, можно выбрать одинаковые или различные настройки для двух серверов. Если выбрать использование разных настроек, нужно будет отдельно настроить службы Analysis Services и компонент SQL Server Database Engine, как описано в следующей процедуре.

Использование различных параметров сортировки для служб Analysis Services и для компонента SQL Server Database Engine

  1. На странице Параметры сортировки мастера установки установите флажок Настроить для каждой учетной записи службы.

  2. В столбце Служба выберите Службы Analysis Services и настройте параметры сортировки для служб Analysis Services.

    Примечание.
    Параметр Параметры сортировки SQL не влияет на службы Analysis Services и недоступен при настройке параметров сортировки для служб Analysis Services.

  3. В столбце Служба выберите Компонент Database Engine и настройте параметры сортировки для компонента SQL Server Database Engine.

Дополнительные сведения о настройке параметров сортировки SQL Server 2005 см. в разделе Настройка параметров сортировки и поддержка нескольких языков.

См. также

Основные понятия

Установка служб SQL Server Analysis Services


Установка служб SQL Server Analysis Services из командной строки

Установка служб SQL Server Analysis Services из командной строки |
 | См. также
Установка компонентов SQL Server 2005 > Установка служб SQL Server Analysis Services >

Дата обновления: 5 декабря 2005 г.

Примечание.
Рекомендуется изучить разделы Как установить SQL Server 2005 из командной строки, в которых приводятся подробные сведения об установке продуктов и технологий из командной строки.

Этот раздел содержит сведения, относящиеся только к установке из командной строки, и в нем не рассматриваются другие методы установки или установка других компонентов SQL Server 2005.

Параметры установки служб Analysis Services из командной строки

Службы Analysis Services можно установить из командной строки на локальном или удаленном сервере или на отказоустойчивом кластере. При установке из командной строки можно указать параметры в командной строке или воспользоваться ключом /settings для загрузки параметров из INI-файла. Параметры могут быть указаны либо в командной строке, либо в INI-файле, но не в обоих местах одновременно.

При установке из командной строки укажите ключ addlocal="feature1,feature2,..." для каждого компонента SQL Server 2005, который необходимо установить. В следующей таблице перечислены параметры, необходимые для установки экземпляра Analysis Services.

Значение | Указывает
Analysis_Server | Экземпляр Analysis Services
AnalysisDataFiles | Файл данных для Analysis Services

Например, чтобы установить экземпляр Analysis Services вместе с документацией по продукту, установите аргумент addlocal, как показано в следующем примере.

Копировать код
   setup addlocal="Analysis_Server,AnalysisDataFiles,SQL_BooksOnline"

Дополнительные сведения о возможностях SQL Server 2005, которые можно указать в аргументе addlocal, см. в файле template.ini в корневом каталоге установочного носителя SQL Server 2005 либо в разделе Как установить SQL Server 2005 из командной строки.

Важно!
Теперь имеется возможность установить определенные компоненты SQL Server 2005 в каталоги, отличные от каталога по умолчанию %ProgramFiles%\Microsoft SQL Server\90. Этот параметр доступен для SQL Server 2005 Integration Services (SSIS), SQL Server 2005 Notification Services и компонентов рабочей станции (клиентские средства, документация и образцы). При установке из командной строки это делается с помощью ключа installsqlshareddir.

Другие обязательные параметры установки из командной строки

Ряд параметров, например PIDKEY, необходим для любой установки SQL Server, которая выполняется с помощью команды setup из командной строки. Иногда при установке Analysis Services и других компонентов SQL Server 2005 могут понадобиться и другие параметры.

Дополнительные сведения об установке продуктов и технологий SQL Server 2005 из командной строки см. разделе Как установить SQL Server 2005 из командной строки.

Дополнительные параметры установки служб Analysis Services из командной строки

Наряду с addlocal, для установки Analysis Services могут применяться следующие параметры командной строки /settings.

Примечание.
Перечисленные ниже аргументы нельзя использовать для установки отказоустойчивых кластеров.

Параметр | Описание
INSTALLOLAPDIR="OLAP_executable_folder_path" | Указывает папку, в которую будут установлены исполняемые файлы Analysis Services. Путь по умолчанию — «C:\Program Files\Microsoft SQL Server\MSSQL.1\OLAP\bin». Установите Analysis Services в папку, в пути и имени которой используются только однобайтовые символы.
INSTALLOLAPDATADIR="OLAP_data_folder_path" | Указывает папку, в которой будут созданы кубы Analysis Services. Путь по умолчанию — «C:\Program Files\Microsoft SQL Server\MSSQL.1\OLAP\Data».
OLAPACCOUNT="domain\logon_name" | Указывает домен и имя для входа учетной записи службы MSSQLServerOLAPService. Чтобы указать пароль, соответствующий имени для входа, используйте аргумент OLAPPASSWORD. Если не указать этот аргумент, будет использоваться значение по умолчанию. Учетной записью по умолчанию является учетная запись локальной системы.
OLAPAUTOSTART={1|0} | Указывает, запускается ли автоматически служба MSSQLServerOLAPService при перезапуске операционной системы Microsoft Windows. Чтобы разрешить автоматический запуск службы, укажите 1, в противном случае укажите 0. Если не указать этот аргумент, будет использоваться значение по умолчанию.
OLAPPASSWORD="password" | Указывает пароль учетной записи службы MSSQLServerOLAPService, соответствующий имени для входа, заданному аргументом OLAPACCOUNT. Если не указать этот аргумент, будет использоваться значение по умолчанию.

Дополнительные сведения о параметрах установки SQL Server 2005, которые можно указать при установке из командной строки, см. в файле template.ini, находящемся в корневом каталоге установочного носителя SQL Server 2005, либо в разделе Как установить SQL Server 2005 из командной строки.

Указание параметров установки в INI-файле

Можно указать параметры командной строки setup в INI-файле. Чтобы указать INI-файл при запуске программы установки setup из командной строки, используйте аргумент /settings filename.ini.

Файл template.ini на установочном носителе SQL Server 2005 содержит подробные инструкции по созданию INI-файла. Обратите внимание на то, что первая незакомментированная строка в INI-файле должна содержать строку [Options]. Ниже приведен пример, показывающий формат INI-файла.

Копировать код
[Options]
USERNAME=MyName
COMPANYNAME=MyCompany
PIDKEY=ABCDE12345FGHIJ67890KLMNO
INSTALLSQLDIR="C:\Program Files\Microsoft SQL Server\"
INSTALLOLAPDATADIR="C:\Program Files\Microsoft SQL Server\MSSQL\OLAP\Data"
ADDLOCAL=Server_Components,Analysis_Server,AnalysisDataFiles,...
INSTANCENAME=MyInstance
OLAPACCOUNT=MyDomain/MyAccount
OLAPPASSWORD=MyPassword
OLAPAUTOSTART=1
...

Дополнительные сведения о параметрах установки SQL Server 2005, указываемых в INI-файле, см. в файле template.ini в корневом каталоге установочного носителя SQL Server 2005 либо в разделе Как установить SQL Server 2005 из командной строки.

См. также

Основные понятия

Установка служб SQL Server Analysis Services


Установка служб SQL Server Reporting Services

Установка служб SQL Server Reporting Services |
 | См. также
Установка компонентов SQL Server 2005 >

Службы SQL Server Reporting Services (SSRS) представляют собой глубоко интегрированные решения, которые поддерживают отчеты об авторизации, распространении, управлении и доступе конечных пользователей.Службы Reporting Services включают в себя клиентские и серверные компоненты.Можно установить все эти компоненты на один компьютер или установить их индивидуально на разные компьютеры.Примеры сценариев установки затрагивают использование различных компьютеров, включая среду отчета о производительности, которая развертывает серверы отчетов на узлах кластера, организацию разработки, которая имеет множество клиентов конструкторов отчетов, подключенных к одному экземпляру сервера отчетов, или сервер отчетов рабочей группы, который использует для своего внутреннего хранилища данных удаленный экземпляр SQL Server, доступный всем группам в организации.Можно установить службы Reporting Services вместе с другими компонентами и технологиями SQL Server или без них.Можно запустить множество экземпляров сервера отчетов на одном сервере. Дополнительные сведения см. в разделе Установка нескольких экземпляров служб Reporting Services.

Шаг 1.Подготовьтесь к установке служб Reporting Services

Перед тем как будут установлены службы Reporting Services, ознакомьтесь со следующими требованиями и описаниями компонентов.

  • Планирование развертывания служб Reporting Services

  • Требования к оборудованию и программному обеспечению для установки SQL Server 2005

  • Параметры для средства проверки конфигурации системы

  • Анализ безопасности при установке SQL Server

  • Настройка учетных записей служб Windows

  • Выбор компонентов служб Reporting Services для установки

Примечание.
Существующий файл базы данных сервера отчетов может вызвать ошибку при установке, если выбрана установка по умолчанию.Вы этом случае программа установки пытается создать базу данных сервера отчетов с именем по умолчанию.Если база данных с таким именем уже существует, установка завершится ошибкой и придется производить откат установки.Чтобы избежать этой проблемы, можно переименовать существующую базу данных перед запуском программы установки либо выбрать параметр Установить, но не настраивать сервер, что позволяет ввести другое имя базы данных после завершения установки.

Шаг 2.Установите службы Reporting Services

После ознакомления с требованиями установки для SQL Server 2005 и проверки того, что компьютер соответствует этим требованиям, можно приступить к установке служб SQL Server 2005 Reporting Services.В зависимости от рабочей среды, можно установить службы Reporting Services одним из следующих способов.

  • Запустите Setup.exe из командной строки для выполнения автоматической установки.Дополнительные сведения см. в разделе Установка служб Reporting Services из командной строки.

  • Запустите мастер установки, задав конфигурацию по умолчанию или конфигурацию «только файлы».Дополнительные сведения см. в разделе Установка служб Reporting Services с помощью программы установки.

    Конфигурация по умолчанию устанавливает все компоненты локально на один компьютер.Этот параметр установки доступен, только если одновременно устанавливаются службы Reporting Services и ядро СУБД.

    Установка «только файлы» копирует файлы и выполняет минимальную конфигурацию сервера отчетов.После завершения установки можно использовать программу настройки служб Reporting Services активизации сервера отчетов. Такой подход позволяет определить удаленные компьютеры (например, выбрать удаленный экземпляр ядра СУБД) для размещения на нем базы данных сервера отчетов, или развернуть службы Reporting Services на распределенных серверах, масштабном развертывании или на веб-серверах в сети Интернет.

Пошаговые инструкции см. в разделе Разделы руководства по установке служб Reporting Services.

Шаг 3.Настройте службы Reporting Services

После установки служб Reporting Services можно изменять параметры установки для корректировки желаемой модели развертывания.Примеры моделей развертывания, которые можно применить после завершения установки, включают следующие варианты.

  • Развертывание сервера отчетов на веб-сервере, доступном из Интернета.

  • Развертывание сервера отчетов на сервере, который поддерживает другие веб-приложения.

  • Развертывание одного или более серверов отчетов в распределенном, многосерверном варианте.

Сведения о том, как развертывать сервер отчетов в этих конфигурациях после завершения программы установки, см. в разделе Развертывание служб Reporting Services электронной документации по SQL Server.

Если выполняется установка «только файлы», то необходимо использовать программу настройки служб Reporting Services для подготовки сервера отчетов к работе. Дополнительные сведения см. в разделе Настройка компонентов служб Reporting Services электронной документации по SQL Server.

Важно!
По сравнению с предыдущими выпусками программы установки служб Reporting Services, можно использовать конфигурацию служб Reporting Services для установки сервера отчетов в масштабном развертывании (ранее использовался термин «веб-ферма»). Дополнительные сведения об изменениях в программе установки и масштабном развертывании см. в разделе Улучшенные возможности управления и развертывания служб Reporting Services электронной документации по SQL Server, а также в разделе Настройка масштабного развертывания сервера отчетов.

Шаг 4.Проверьте установку служб Reporting Services

После установки и конфигурации проверьте, что компоненты служб Reporting Services запущены.Дополнительные сведения см. в разделе Как проверить установки служб Reporting Services.

См. также

Задачи

How to: Install Reporting Services Side-by-Side with an Earlier Version

Основные понятия

Установка нескольких экземпляров служб Reporting Services
Установка служб Reporting Services на 64-разрядные компьютеры
Обновление служб Reporting Services

Другие ресурсы

Разделы руководства по установке служб Reporting Services
Улучшенные возможности служб Reporting Services
Обзор компонентов служб Reporting Services
Установка компонентов SQL Server 2005


Выбор компонентов служб Reporting Services для установки

Выбор компонентов служб Reporting Services для установки |
 | См. также
Установка компонентов SQL Server 2005 > Установка служб SQL Server Reporting Services >

Службы SQL Server 2005 Reporting Services (SSRS) состоят из клиентских и серверных компонентов, которые устанавливаются вместе или по отдельности. После определения нужных компонентов можно запустить программу установки. Дополнительные сведения об установке конкретных компонентов см. в разделе Установка служб Reporting Services с помощью программы установки.

Программу установки можно запускать на одном компьютере неоднократно, чтобы установить несколько экземпляров сервера отчетов. Клиентские компоненты можно устанавливать на любые компьютеры, используя любой выпуск служб Reporting Services . Серверным компонентам требуется лицензия SQL Server. Действующую лицензию SQL Server необходимо иметь для любого компьютера, на который устанавливаются серверные компоненты служб Reporting Services.

Примечание.
Доступность того или иного компонента определяется выпуском устанавливаемого программного обеспечения. Дополнительные сведения см. в разделе Возможности, поддерживаемые различными выпусками SQL Server 2005 электронной документации по SQL Server.

Серверные компоненты

В службы Reporting Services включены следующие серверные компоненты.

Сервер отчетов

Сервер отчетов обеспечивает обработку, подготовку к просмотру и доставку отчетов для интерактивной и плановой отчетности. Сервер отчетов реализован как служба Microsoft Windows и веб-служба ASP.NET, которая выполняется под управлением IIS. Это сервер без сохранения состояния, хранящий метаданные и определения объектов в базе данных сервера отчетов. При установке компонента сервера отчетов на компьютер устанавливаются как служба Windows, так и веб-служба.

Корпорация Майкрософт рекомендует устанавливать серверы отчетов на компьютеры под управлением либо Windows Server 2003, либо Windows XP. Хотя компоненты сервера отчетов можно устанавливать и запускать на компьютере под управлением Windows 2000 Server, здесь существуют определенные ограничения на олицетворение и доступ к сети, не позволяющие использовать некоторые функциональные возможности сервера отчетов.

Важно!
При выборе компьютера для установки сервера отчетов избегайте компьютеров, имя которых содержит знак подчеркивания. Сервер отчетов не сохраняет сведения о состоянии сеанса на компьютерах, имя которых содержит знак подчеркивания, а также на тех, к которым применялось обновление системы безопасности MS01-055 для Internet Explorer. Это обновление системы безопасности препятствует отправке файлов «cookie» на клиентские компьютеры, имя которых содержит знак подчеркивания, лишая службы Reporting Services функциональных возможностей управления сеансом. Рекомендованные решения этой проблемы вопроса приводятся в статье 316112 базы знаний Майкрософт.

База данных сервера отчетов

Службы Reporting Services используют две базы данных SQL Server для внутреннего хранения экземпляра сервера отчетов: одну для хранения данных, а другую в качестве временного хранилища. Эти базы данных создаются одновременно и привязываются по имени. По умолчанию базам данных присваиваются имена соответственно reportserver и reportservertempdb. Для баз данных сервера отчетов службам Reporting Services требуется локальный или удаленный экземпляр SQL Server. Можно использовать экземпляр SQL Server 2000 или экземпляр SQL Server 2005. Дополнительные сведения о требованиях, предъявляемых этим выпуском к базе данных сервера отчетов, см. в разделе Создание базы данных сервера отчетов.

Базы данных сервера отчетов могут быть созданы во время или после установки. Они могут быть созданы программой установки в том случае, если параллельно на один компьютер устанавливается экземпляр компонента SQL Server 2005 Database Engine и службы Reporting Services. Однако если базу данных сервера отчетов необходимо разместить на SQL Server 2000 или на удаленном экземпляре SQL Server, необходимо выбрать параметр установки Установить, но не настраивать сервер, а затем, после завершения установки, воспользоваться программой настройки служб Reporting Services для создания и настройки баз данных сервера отчетов. Дополнительные сведения см. в разделе Как установить локальную и удаленную базу данных сервера отчетов.

Диспетчер отчетов

Диспетчер отчетов представляет собой инструмент администрирования на основе веб-служб, который используется для управления одним экземпляром сервера отчетов. Он устанавливается по умолчанию вместе с сервером отчетов. Если для управления сервером отчетов используются другие инструментальные средства (например, среда SQL Server Management Studio или пользовательское приложение), этот компонент можно опустить, удалив его из дерева выбора компонентов.

Построитель отчетов

Построитель отчетов является приложением ClickOnce, которое предоставляет пользователю возможность создания нерегламентированных отчетов, которые не укладываются в модели данных, созданные и опубликованные в конструкторе моделей. Построитель отчетов устанавливается в составе компонента сервера отчетов. Он доступен пользователям из диспетчера отчетов или по URL-адресу. Можно ограничить или запретить доступ к построителю отчетов через настройку назначений ролей или установку системных свойств сервера отчетов. Дополнительные сведения см. в разделе Назначение ролей для доступа к построителю отчетов электронной документации по SQL Server.

Настройка служб Reporting Services

Программа настройки служб Reporting Services устанавливается в составе экземпляра сервера отчетов. Его можно использовать для создания пользовательской конфигурации или развертывания установки сервера отчетов. Это средство является обязательным компонентом установки сервера отчетов.

Клиентские компоненты

В службы Reporting Services включены следующие клиентские компоненты. Эти компоненты можно устанавливать на клиентские компьютеры, они не требуют лицензии SQL Server.

Конструктор отчетов

Службы Reporting Services включают авторское инструментальное средство создания отчетов, которое называется конструктором отчетов. Конструктор отчетов используется для создания, редактирования и предварительного просмотра отчетов, а также их последующего развертывания на сервере отчетов. Конструктор отчетов запускается в Visual Studio 2005.

Конструктор моделей

Конструктор моделей — это средство для создания нерегламентированных бизнес-отчетов в построителе отчетов. Он применяется для указания связей между данными, которые используются для поддержки создания нерегламентированных отчетов. Конструктор моделей запускается из Visual Studio 2005.

Программы командной строки

Службы Reporting Services включают несколько инструментов командной строки, которые можно использовать для администрирования установки служб Reporting Services. В большинстве случаев вместо программ командной строки можно использовать программу настройки служб Reporting Services. Но если работа с командной строкой более предпочтительна, то для выполнения административных задач на сервере отчетов можно установить следующие программы:

  • Программа Rsconfig используется для изменения параметров соединения базы данных сервера отчетов после завершения установки. Она также используется для задания зашифрованных сведений учетной записи, которые применяются для необслуживаемой обработки отчетов.

  • Rs — это сервер сценариев, который может использоваться для обработки сценариев Microsoft Visual Basic, регулярно выполняющих общие задачи, или для запуска одинаковых задач на разных компьютерах.

  • Rskeymgmt используется для резервного копирования и восстановления ключей шифрования сервера отчетов.

Дополнительные сведения обо всех этих программах см. в разделах Программа rsconfig, Программа rs и Программа rskeymgmt электронной документации по SQL Server.

Среда SQL Server Management Studio

Среда SQL Server Management Studio можно использовать для администрирования одного или нескольких экземпляров сервера отчетов. Она обеспечивает комплексное рабочее пространство управления сервером, которое можно использовать для управления всеми серверными компонентами SQL Server из одного местоположения.

Диспетчер конфигурации SQL Server

Диспетчер конфигурации SQL Server используется для просмотра и установки свойств службы Windows сервера отчетов, которая управляют запланированными операциями сервера отчетов и его инициализацией.

Выбор модели развертывания

Все серверные компоненты можно устанавливать на один компьютер, если нужно сохранить лицензии SQL Server или если требования к отчетности не слишком велики. Но если поддерживается большое количество пользователей отчетов, производительность повысится, если установить базу данных сервера отчетов на выделенный сервер. Дополнительные сведения о моделях развертывания см. в разделе Планирование развертывания служб Reporting Services электронной документации по SQL Server.

См. также

Основные понятия

Установка служб SQL Server Reporting Services

Другие ресурсы

Обзор компонентов служб Reporting Services


Конфигурация по умолчанию для установки сервера отчетов

Конфигурация по умолчанию для установки сервера отчетов |
 | См. также
Установка компонентов SQL Server 2005 > Установка служб SQL Server Reporting Services >

При установке компонента сервера отчетов в службах Reporting Services с помощью мастера установки SQL Server в программе установки предусмотрен параметр установки сервера в конфигурации по умолчанию. Выбор этого параметра приведет к установке и развертыванию сервера отчетов. После завершения программы установки сервер отчетов будет запущен и готов к работе. В мастере установки эта возможность задается параметром Установка конфигурации по умолчанию. При установке в режиме командной строки конфигурация по умолчанию задается с помощью параметра DEFAULT в свойстве RSCONFIGURATION.

Требования

Ниже приведены некоторые требования и ограничения для параметра «Установка конфигурации по умолчанию».

  • База данных сервера отчетов должна находиться на локальном экземпляре компонента SQL Server Database Engine. Компонент SQL Server Database Engine должен устанавливаться параллельно с экземпляром сервера отчетов.

  • Пользователь, выполняющий программу установки, должен иметь разрешение администратора для доступа к базам данных и их создания с помощью локального экземпляра компонента Database Engine.

  • Веб-узел по умолчанию или пул приложений должны быть включены в службах IIS, а его IP-адрес нужно сопоставить с (все свободные). На веб-узле по умолчанию будут созданы виртуальные каталоги сервера отчетов и диспетчера отчетов.

  • Веб-узел по умолчанию не может быть настроен для использования соединений через протокол SSL.

  • Служба ASP.NET должна работать под учетной записью ASP.NET по умолчанию. Веб-служба сервера отчетов использует учетную запись ASP.NET. В операционной системе Windows Server 2003 учетная запись по умолчанию для ASP.NET — это «Сетевая служба». На сервере Windows 2000 учетная запись по умолчанию для службы ASP.NET — это учетная запись с минимальными правами доступа, создаваемая специально для рабочего процесса службы ASP.NET. Если служба ASP.NET работает под учетной записью, отличной от учетной записи по умолчанию, программе установки не удастся установить конфигурацию по умолчанию.

  • Перед запуском программы установки необходимо включить учетную запись IWAM_имя_компьютера. С помощью этой учетной записи программа установки настраивает службы IIS.

Параметры конфигурации по умолчанию

В приведенной ниже таблице сравниваются параметры, применяемые для конфигурации по умолчанию, и параметры установки только файлов. В отличие от учетной записи службы Microsoft Windows, значения для конфигурации по умолчанию можно задавать во время установки.

Операция Конфигурация по умолчанию Установка только файлов

Настройка имени экземпляра

Используется имя экземпляра SQL Server

Используется имя экземпляра SQL Server

Установка файлов

Да

Да

Настройка учетной записи веб-службы

В Windows XP и Windows 2000 программа установки использует учетную запись компьютера ASP.Net или учетную запись сетевой службы machine.config. Если используется другая учетная запись, то установка по умолчанию невозможна.

В Windows Server 2003 программа установки использует учетную запись, связанную с пулом приложений, который применяется веб-узлом по умолчанию.

Нет

Настройка службы Windows

Используются значения, указанные на странице «Учетные записи служб» мастера установки. В Windows XP и Windows 2000 значение по умолчанию — «Локальная система». В Windows Server 2003 значение по умолчанию — «Сетевая служба».

Используются значения, указанные на странице «Учетные записи служб» мастера установки.

Задание разрешений к папке

Предоставляются разрешения учетной записи веб-службы, а также учетной записи службы Windows.

Предоставляются разрешения учетной записи службы Windows.

Создание базы данных сервера отчетов

Да. Создаются базы данных reportserver и reportservertempdb.

Нет

Настройка соединения с базами данных

Да. Учетным записям веб-службы и службы Windows предоставляются права доступа к базам данных с помощью роли rsexecrole.

Нет

Создание виртуальных каталогов

Да. Виртуальные каталоги создаются на веб-узле по умолчанию с именами по умолчанию, которые зависят от имени экземпляра.

Нет

Настройка доставки электронной почты

Нет

Нет

Регистрируется поставщик инструментария WMI сервера отчетов

Да

Да

Запуск службы Windows сервера отчетов

Да, если задана служба автоматического запуска и во время установки не возникло ошибок.

Нет

Инициализация сервера отчетов

Да

Нет

См. также

Справочник

Параметры установки сервера отчетов

Основные понятия

Установка служб SQL Server Reporting Services
Установка служб Reporting Services с помощью программы установки


Установка служб Reporting Services с помощью программы установки

Установка служб Reporting Services с помощью программы установки |
 | См. также
Установка компонентов SQL Server 2005 > Установка служб SQL Server Reporting Services >

Чтобы установить компоненты служб Reporting Services, можно использовать мастер установки SQL Server. С помощью мастера можно установить отдельные или все компоненты.

Выбор параметров установки

При установке компонентов сервера мастер установки предоставляет следующие параметры установки сервера отчетов.

  • Установить конфигурацию по умолчанию — установить сервер отчетов со значениями по умолчанию. При выборе этого параметра будет установлен полностью развернутый сервер отчетов, готовый к использованию сразу же по завершении программы установки. Программа установки не предлагает указать имена виртуальных каталогов, выбрать экземпляр ядра СУБД SQL Server или указать иные сведения для завершения установки. Вместо этого она пользуется значениями по умолчанию, описанными в разделе Конфигурация по умолчанию для установки сервера отчетов. Параметр установки по умолчанию доступен только в том случае, если одновременно устанавливаются экземпляры локального ядра СУБД и служб Reporting Services. Если недоступно какое-либо значение по умолчанию, этот параметр установки не может быть выбран.

  • Установить, но не настраивать сервер — используется для копирования программных файлов на диск, настройки учетной записи службы сервера отчетов в Windows и регистрации поставщика инструментария управления Windows (WMI) сервера отчетов. Этот режим установки называется «только файлы». Перед тем как сервер отчетов может быть использован, необходима дополнительная настройка. Дополнительная настройка может быть выполнена с помощью предоставляемой программы настройки служб Reporting Services.

    Для запуска программы настройки служб Reporting Services нажмите Пуск, выберите Все программы, затем Microsoft SQL Server 2005, затем Средства настройки и выберите пункт Настройка служб Reporting Services.

Параметры установки сервера отчетов станут доступны, если указать Службы Reporting Services на странице Устанавливаемые компоненты или Сервер отчетов на странице Выбор компонентов. Заметьте, что эти параметры относятся только к установке компонентов сервера. Эти параметры не влияют на установку клиентских компонентов (например, конструктора отчетов, конструктора моделей или средств администрирования).

Выбор компонентов для установки

Чтобы установить компоненты сервера, необходимо выбрать Службы Reporting Services на странице Устанавливаемые компоненты. Клиентские компоненты устанавливаются по выбору пункта Компоненты рабочей станции, электронная документация и средства разработки на странице Устанавливаемые компоненты.

Для выбора определенных компонентов или для установки документации по службам Reporting Services или образцам щелкните Дополнительно. После нажатия кнопки Дополнительно откроется страница Выбор компонентов, содержащая полный список компонентов, которые можно установить по отдельности.

Как выборочно установить компоненты

Службы Reporting Services включают в себя как серверные, так и клиентские компоненты для создания отчетов и моделей, а также для администрирования сервера отчетов. Можно установить клиентские компоненты SQL Server, полезные для управления установкой сервера. Дополнительные сведения об описании компонентов см. в разделе Выбор компонентов служб Reporting Services для установки.

Для установки этого компонента Выполните следующее действие

Сервер отчетов, программа настройки служб Reporting Services, средство настройки контактной зоны SQL Server, диспетчер конфигурации SQL Server, построитель отчетов.

Сервер отчетов всегда устанавливается со средствами, предназначенными для включения функций сервера. Нет способа исключить их из установки. Однако если на странице Компоненты выбрать Общие средства, то можно указать, где именно в файловой системе эти средства будут установлены.

  1. Выберите Службы Reporting Services на странице Устанавливаемые компоненты.

  2. Нажмите кнопку Дополнительно.

  3. Раскройте Службы Reporting Services.

  4. (Необязательно). Удалите диспетчер отчетов, если его установка не нужна.

  5. (Необязательно). Для выбора определенного месторасположения папки общих программ выберите Общий инструментарий, затем нажмите кнопку Обзор.

Нельзя удалить построитель отчетов из установки компонентов сервера. Однако можно отключить его после завершения работы программы установки, в результате чего он не будет запускаться. Дополнительные сведения о том, как отключить построитель отчетов, см. в разделе Назначение ролей для доступа к построителю отчетов.

Диспетчер отчетов

Диспетчер отчетов по умолчанию выбирается при выборе Службы Reporting Services на странице Устанавливаемые компоненты.

Службы Reporting Services можно установить без диспетчера отчетов, удалив его на странице Выбор компонентов. Можно также развернуть диспетчер отчетов и сервер отчетов на разных компьютерах. Дополнительные сведения о том, как установить диспетчер отчетов и сервер отчетов на различных компьютерах, см. в разделе Настройка сервера отчетов для доступа через Интернет.

Конструктор отчетов и конструктор моделей

Конструктор отчетов и конструктор моделей доступны после установке среды Business Intelligence Development Studio.

  1. Выберите Компоненты рабочей станции, электронная документация и средства разработки на странице Устанавливаемые компоненты.

  2. Для проверки того, что выбрана среда Business Intelligence Development Studio или для изменения списка устанавливаемых компонентов, нажмите кнопку Дополнительно.

Образцы отчетов и приложений
  1. Выберите Компоненты рабочей станции, электронная документация и средства разработки на странице Устанавливаемые компоненты.

  2. Нажмите кнопку Дополнительно.

  3. Раскройте Документация, примеры и образцы баз данных.

  4. Выберите Образцы баз данных и образцы кода и приложений.

См. также

Задачи

Как установить локальную и удаленную базу данных сервера отчетов
Как установить службы Reporting Services на один компьютер
Как проверить установки служб Reporting Services
Как устранять неполадки при установке служб Reporting Services

Основные понятия

Установка служб SQL Server Reporting Services
Выбор компонентов служб Reporting Services для установки
Конфигурация по умолчанию для установки сервера отчетов
Установка служб Reporting Services из командной строки


Установка служб Reporting Services из командной строки

Установка служб Reporting Services из командной строки |
 | См. также
Установка компонентов SQL Server 2005 > Установка служб SQL Server Reporting Services >

В дополнение к программе установки с графическим интерфейсом программа Setup.exe предоставляет интерфейс командной строки. В командной строке или в ini-файле можно указать, каким образом программа Setup.exe должна устанавливать компоненты служб Reporting Services, а также можно запретить использование пользовательского интерфейса. Для запуска установки из командной строки нужно быть локальным администратором системы.

В этом разделе описаны свойства, используемые для установки компонентов служб Reporting Services из командной строки. В ней также приведены примеры общих сценариев установки. Дополнительные сведения о синтаксисе и аргументах, используемых при установке из командной строки, см. в разделах Выполнение установки из командной строки и Указание свойств установки в INI-файле.

Примеры использования командной строки для служб Reporting Services

Следующие примеры иллюстрируют синтаксис и настройки для общих сценариев установки служб Reporting Services. Чтобы эти примеры могли работать, следует сначала перейти в папку, содержащую программу Setup.exe. Примеры настроек иллюстрируют, как различными способами, задавая установочный INI-файл, добиваться конкретных результатов.

Базовый синтаксис для установки из командной строки в режиме молчания

Копировать код
Setup /settings c:\mysetup.ini /qn

Настройки для установки компонентов служб Reporting Services на локальный компьютер

Копировать код
[Options]
INSTANCENAME=MSSQLSERVER
ADDLOCAL=SQL_Engine,SQL_Data_Files,RS_Server,RS_Web_Interface,SQL_WarehouseDevWorkbench,SQL_ComputerManagement,SQL_Workbench,RS_tools
SQLAUTOSTART=1
AGAUTOSTART=1
RSAUTOSTART=1
SECURITYMODE=SQL
SAPWD=<password>
PERPROCESSOR=2
RSCONFIGURATION=Default
RSSQLLOCAL=1

Настройки для установки документации и образцов

Копировать код
[Options]
ADDLOCAL=SQL_Documentation,SQL_BooksOnline,SQL_SQLServerBooksOnline,SQL_Samples,SQL_AdventureWorksSamples,SQL_AdventureWorksDWSamples,SQL_ReportingServicesSamples

Свойства для компонентов служб Reporting Services

При установке служб Reporting Services из командной строки можно задать следующие свойства. Их можно задать либо в командной строке, либо в ini-файле, но не одновременно. Если заданы противоречащие друг другу значения, используются те, что указаны в командной строке.

RSACCOUNT="домен\имя_входаимя"

Необязательное. Значение по умолчанию принимает значение встроенной учетной записи по умолчанию для данной операционной системы. Это свойство применяется к выбору компонента RS_Server. Определяет учетную запись, под которой будет выполняться служба Windows «Сервер отчетов». Длина доменного имени ограничена 254 символами, а длина имени учетной записи — 20 символами. Если значение не поддерживается для RSACCOUNT, в следующей таблице показано, что выбирается встроенная учетная запись по умолчанию.

Операционная система Учетная запись

Windows 2000

Локальная система

Windows XP

Локальная система

Windows Server 2003

Пользователь домена
RSPASSWORD="пароль"

Необязательное. Значение по умолчанию — неопределенный пароль. Это свойство применяется к выбору компонента RS_Server. Указывает пароль, соответствующий имени пользователя, указанному параметром RSACCOUNT. Длина пароля ограничена 255 символами.

RSUPGRADEDATABASEACCOUNT="имя_пользователя"

Необязательное. Задает имя входа базы данных SQL Server, используемую для соединения с экземпляром SQL Server, содержащим базу данных сервера отчетов во время обновления. Пользователь базы данных должен иметь разрешения на изменение схемы. Полезно установить это свойство при обновлении сервера отчетов, выполняющегося на удаленном экземпляре сервера SQL Server. Имя пользователя базы данных должно содержать не более 20 символов.

RSUPGRADEPASSWORD="пароль"

Обязателен, если задан параметр RSUPGRADEDATABASEACCOUNT. Задает пароль для учетной записи. Пустая строка является допустимым значением. Пароль не сохраняется. Его максимальная длина равна 255 символам.

RSCONFIGURATION={ default | filesonly }

Необязательное. Указывает, как устанавливается экземпляр сервера отчетов. Для установки default необходимы локальный экземпляр компонента Database Engine и конфигурация системы со значениями по умолчанию. Экземпляр компонента Database Engine не может быть установлен как виртуальный сервер.

При указании значения filesonly происходит установка файлов программы и осуществляется минимальная настройка установленного сервера отчетов. Чтобы сделать сервер отчетов работоспособным, необходима дальнейшая настройка. Если это свойство не указано, используется значение filesonly. Дополнительные сведения см. в разделах Конфигурация по умолчанию для установки сервера отчетов и Параметры установки сервера отчетов.

RSAUTOSTART={ 1 | 0 }

Необязательное. Значение по умолчанию — true (1). Это свойство применяется к выбору компонента RS_Server. Указывает, запускается ли служба Windows «Сервер отчетов» автоматически при перезагрузке Windows. Если служба Windows сервера отчетов зарегистрирована операционной системой, тип ее запуска устанавливается в соответствии с этим значением. Укажите значение «true» (1), чтобы служба запускалась автоматически или «false» (0), чтобы задать тип запуска вручную.

ADDLOCAL = "выбор_компонента"

Указывает, какие компоненты должны быть установлены для новой или существующей установки. Компоненты указываются в виде списка и разделяются запятыми. Чтобы установка была успешной, при установке конкретных компонентов следует указать также определенные свойства. Следующая таблица перечисляет все компоненты и необходимые свойства.

Следующая таблица перечисляет свойства, которые доступны для каждого компонента. Столбец выбора возможностей — параметр выбора_возможностей, который используется со свойствами ADDLOCAL или REMOVE при добавлении или удалении компонентов, используя командную строку.

Компонент | Значение для выбора возможностей | Доступные свойства
Веб-служба сервера отчетов и служба Windows и программу настройки служб Reporting Services | RS_Server | RSACCOUNT, RSPASSWORD, RSAUTOSTART, RSCONFIGURATION
Диспетчер отчетов | RS_Web_Interface | Нет
Конструктор отчетов и конструктор моделей | SQL_WarehouseDevWorkbench | Нет
Службы Reporting Services. Программы командной строки | RS_Tools | Нет
Важно!
При отсутствии необходимого компонента связанный с ним компонент не будет установлен. Если поврежденный компонент указан в командной строке в свойстве ADDLOCAL, программа установки завершается с ошибкой.

См. также

Основные понятия

Обновление служб Reporting Services
Выбор компонентов служб Reporting Services для установки
Установка служб SQL Server Reporting Services

Другие ресурсы

Обратная совместимость служб Reporting Services


Установка надстройки службы Reporting Services

Установка надстройки службы Reporting Services |
 | См. также
Установка компонентов SQL Server 2005 > Установка служб SQL Server Reporting Services >

Новое содержимое: 12 декабря 2006 г.

Надстройка 2005 Reporting Services для SharePoint Technologies может быть загружена из Интернета, поэтому ее можно установить на сервер, где имеется экземпляр продукта или технологии SharePoint. Она предоставляет набор функций, позволяющий запустить сервер отчетов внутри большего развертывания Microsoft Windows SharePoint Services 3.0 или Microsoft Office SharePoint Server 2007.

В эти функции входит веб-компонент «Обозреватель отчетов», конечная точка прокси-сервера, страницы приложений, что позволяет создавать, просматривать и управлять отчетами, моделями отчетов и другим содержимым сервера отчетов на узле SharePoint.

Для установки надстройки служб Reporting Services необходимо быть администратором фермы SharePoint.

Подготовка к установке

Установка надстройки службы Reporting Services является одним из множества шагов, необходимых для интеграции сервера отчетов с экземпляром продукта или технологии SharePoint. Дополнительные сведения о полном наборе шагов см. в разделе Настройка служб Reporting Services для интеграции с SharePoint 3.0. Порядок выполнения шагов по настройке серверов является существенным. Для получения наилучших результатов следует убедиться, что они выполняются в нужном порядке.

Подготовка к установке надстройки служб Reporting Services:

  1. Проверьте, что имеются две установки серверов — сервер отчетов и сервер SharePoint, — которые удовлетворяют требованиям для интегрированных операций. Дополнительные сведения см. в разделе Требования для запуска служб Reporting Services в режиме интеграции с SharePoint.

  2. Загрузите надстройку служб Reporting Services на сервер, где имеется экземпляр продукта или технологии SharePoint. Можно загрузить надстройку служб Reporting Services из Центра загрузки Майкрософт.

  3. Если ферма SharePoint интегрируется с развертыванием сервера отчетов, скопируйте или загрузите надстройку служб Reporting Services на каждый компьютер на ферме, которая обладает клиентской частью веб-сервера.

Установка надстройки служб Reporting Services на отдельный сервер

  1. Запустите программу Setup.exe на компьютере, обладающем клиентской частью веб-сервера, для развертывания продукта или технологии SharePoint, которые необходимо настроить для интеграции с сервером отчетов.

    Программа установки не позволяет изменять параметры установки. При добавлении новых файлов программа установки использует существующую структуру папок текущего развертывания. Сначала программа установки проверяет, установлена ли программа Windows SharePoint Services 3.0. Затем программа установки копирует файлы приложений и конечную точку прокси-сервера в новую папку.

    Файл программы установки (файл MSI) производит установку надстройки служб Reporting Services на всех поддерживаемых языках. Не существует каких-либо отдельных программ установки для каждого языка. При запуске программы установки устанавливаются файлы установки для всех поддерживаемых языков.

    Программа установки не настраивает сервер на интеграцию с Reporting Services. Настроить интеграцию необходимо после завершения установки.

  2. После завершения установки перейдите к пункту «Администрирование» и выберите Центральный веб-узел администрирования SharePoint 3.0.

  3. Выберите Управление приложениями. Там появится новый раздел под названием Службы Reporting Services. В этом разделе находятся ссылки на страницы, используемые для настройки параметров интеграции. Инструкции по установке настроек см. в разделе Как выполнить интеграцию сервера отчетов в центре администрирования SharePoint.

Установка надстроек служб Reporting Services на виртуальных серверах фермы SharePoint

Развертывание Reporting Services интегрировано с развертыванием продукта или технологии SharePoint на уровне фермы. Если в конфигурации фермы существует несколько веб-приложений SharePoint, то необходимо установить надстройку служб Reporting Services на каждый компьютер, обладающий клиентским приложением веб-сервера. После установки надстроек на все компьютеры запустите центральный веб-узел администрирования для настройки интеграции сервера отчетов во все серверы фермы.

Аргументы командной строки

Для запуска программы установки в режиме установки можно добавлять аргументы в командной строке.

  • Воспользуйтесь SharePointRS.msi -r для исправления существующей установки.

  • Воспользуйтесь SharePointRS.msi -u для удаления существующей надстройки. Для полного удаления надстройки нужно выполнить дополнительные действия. Дополнительные сведения см. в разделе How to: Uninstall the Reporting Services Add-in.

Файлы журналов установки

После запуска программы установки происходит запись сведений в файл журнала в папке %temp% того пользователя, который устанавливает надстройку служб Reporting Services. Именем файла является RS_SP_<число>.log. Каждая запись об ошибке в журнале начинается со строки «SSRSCustomActionError».

См. также

Задачи

Как удалить надстройку для использования служб Reporting Services
Как установить объектную модель службы Windows SharePoint Services на компьютер сервера отчетов

Основные понятия

Режимы развертывания для служб Reporting Services
Требования для запуска служб Reporting Services в режиме интеграции с SharePoint
Настройка служб Reporting Services для интеграции с SharePoint 3.0
Общие сведения о безопасности для служб Reporting Services в режиме интеграции с SharePoint

Другие ресурсы

Managing Permissions and Security for Report Server Items on a SharePoint Site


Установка служб Reporting Services на 64-разрядные компьютеры

Установка служб Reporting Services на 64-разрядные компьютеры |
 | См. также
Установка компонентов SQL Server 2005 > Установка служб SQL Server Reporting Services >

Новое содержимое: 5 декабря 2005 г.

64-разрядные выпуски Microsoft SQL Server 2005 включают службы Reporting Services. В следующей таблице содержатся специальные соглашения для различных типов 64-разрядных архитектур.

Архитектура Специальные сведения

x64

Службы SQL Server 2005 Reporting Services поддерживаются без ограничений в операционных системах x64.

Можно устанавливать и запускать все серверные и клиентские компоненты служб Reporting Services на Microsoft Windows Server 2003 с пакетом обновления 1 (SP1).

Операционная система, пакет обновления и устанавливаемый выпуск SQL Server должны быть 64-разрядными.

IA64

Эта платформа предназначена для производственных серверов. Отсутствует поддержка встроенного конструктора отчетов и конструктора моделей в среде Business Intelligence Development Studio. Средства разработки недоступны для установки на данной архитектуре.

Подсистема Microsoft Windows-32-на-Windows-64 (WOW64)

Можно выполнять 32-разрядные версии приложений ASP.NET служб Reporting Services в WOW64. Чтобы включить эту конфигурацию, необходимо произвести настройку IIS. Дополнительные сведения см. в разделе Как настроить службы IIS для запуска 32-разрядных служб Reporting Services в режиме WOW64.
Примечание.
Службы SQL Server 2000 Reporting Services не поддерживаются ни на одной из 64-разрядных платформ. Хотя в SQL Server 2000 с пакетом обновления 4 (SP4) введена поддержка подсистемы Microsoft Windows32-on-Windows64 (WOW64), она не распространяется на службы SQL Server 2000 Reporting Services.

См. также

Справочник

Возможности, поддерживаемые различными выпусками SQL Server 2005

Основные понятия

Установка служб SQL Server Reporting Services

Другие ресурсы

Использование служб Integration Services на 64-разрядных компьютерах


Установка нескольких экземпляров служб Reporting Services

Установка нескольких экземпляров служб Reporting Services |
 | См. также
Установка компонентов SQL Server 2005 > Установка служб SQL Server Reporting Services >

Новое содержимое: 14 апреля 2006 г.

На одном компьютере может быть установлено несколько экземпляров служб Reporting Services. Установка нескольких экземпляров может оказаться полезной в том случае, если для нескольких веб-узлов необходимо хранить различное содержимое. Каждый экземпляр будет иметь свою собственную базу данных сервера отчетов, свои файлы конфигурации и виртуальные каталоги. Если необходимо использовать одну базу данных сервера отчетов совместно несколькими экземплярами при работе с выпуском SQL Server 2005 Enterprise Edition, можно настроить масштабное развертывание. Дополнительные сведения об этом сценарии развертывания см. в разделе Настройка масштабного развертывания сервера отчетов.

Для установки с несколькими экземплярами возможны следующие конфигурации:

  • Несколько экземпляров одной версии и выпуска. Каждый экземпляр сервера отчетов подключается к собственной локальной или удаленной базе данных сервера отчетов.

  • Несколько экземпляров различных версий и выпусков. Например, можно запускать SQL Server 2005 Express, SQL Server 2005 Developer Edition и SQL Server 2000 Enterprise Edition на одном компьютере.

    Поддержка нескольких экземпляров обеспечивается в SQL Server 2005. При запуске SQL Server 2000 и 2005 на одном компьютере можно использовать только один экземпляр служб Reporting Services SQL Server 2000 и он должен выполняться как экземпляр по умолчанию (то есть как MSSQLSERVER). Каждый дополнительный экземпляр должен быть выпуском SQL Server 2005, установленным в качестве именованного экземпляра.

Каждый экземпляр сервера SQL Server изолирован от других экземпляров, выполняющихся на том же компьютере. На одном компьютере можно установить разные версии и выпуски в качестве отдельных экземпляров (например, SQL Server 2000 Enterprise Edition и SQL Server 2005 Developer Edition в качестве отдельных экземпляров).

При запуске нескольких экземпляров служб Reporting Services на одном компьютере можно настроить все экземпляры на использование веб-узла по умолчанию в службах IIS. В таком случае каждый экземпляр сервера отчетов будет уникально идентифицироваться по его виртуальному каталогу. Либо можно настроить каждый экземпляр на использование конкретного IP-адреса, если необходимо использовать веб-узлы, отличные от веб-узла по умолчанию, или перенаправлять все запросы сервера отчетов через конкретный IP-адрес.

Установка экземпляра сервера отчетов

Для установки нескольких экземпляров служб Reporting Services необходимо выполнить программу установки для каждого из устанавливаемых экземпляров. Нельзя установить несколько экземпляров за один раз.

Установка экземпляра сервера отчетов по умолчанию

При первом запуске программы установки предлагается возможность установить первый экземпляр сервера отчетов в качестве установки по умолчанию, если компьютер отвечает необходимым требованиям. Результатом установки по умолчанию, для которой используются все значения по умолчанию, является создание сервера отчетов, готового к использованию по завершении программы установки. Возможно наличие только одного экземпляра служб Reporting Services по умолчанию на одном экземпляре SQL Server. Дополнительные сведения о требованиях для установки по умолчанию см. в разделе Конфигурация по умолчанию для установки сервера отчетов.

Если использование значений по умолчанию неприемлемо или если компьютер не отвечает всем требованиям для установки по умолчанию, необходимо установить службы Reporting Services как именованный экземпляр.

Установка сервера отчетов в качестве именованного экземпляра

При установке нескольких экземпляров сервера отчетов на одном компьютере каждый дополнительный экземпляр должен быть установлен в качестве именованного экземпляра.

Установка именованного экземпляра сервера отчетов:

  • Укажите имя экземпляра на странице Имя экземпляра мастера установки.

  • Выберите параметр Установить, но не настраивать сервер на странице Параметры установки сервера отчетов.

В файловой системе программные файлы для каждого экземпляра сервера отчетов хранятся для каждого из экземпляров в отдельных папках (например, MSSQL.2, MSSQL.3 и т.д.). Программа установки создает папки в том порядке, в котором устанавливаются экземпляры. Дополнительные сведения об установке нескольких экземпляров см. в разделе Как установить SQL Server 2005 (программа установки).

Настройка экземпляра сервера отчетов

Для настройки различных экземпляров сервера отчетов на одном компьютере можно воспользоваться программой настройки служб Reporting Services, выбрав экземпляр, который необходимо настроить. Для идентификации каждого экземпляра службы Reporting Services используют соглашения по именованию экземпляров SQL Server:

  • Экземпляр по умолчанию использует имя MSSQLServer.

  • Экземпляром по умолчанию SQL Server Express является SQLExpress (отметим, что SQL Server Express всегда устанавливается как именованный экземпляр).

  • Другие именованные экземпляры идентифицируются по имени, заданному при выполнении программы установки.

Дополнительные сведения о том, как выполнить подключение к определенному экземпляру сервера отчетов, см. в разделе Как запустить настройку служб Reporting Services.

Доступ к экземпляру сервера отчетов в конфигурации с несколькими экземплярами

Для доступа к определенному экземпляру сервера отчетов или диспетчера отчетов, или для публикации отчетов на определенном экземпляре необходимо ввести URL-адрес для этого экземпляра.

Виртуальный каталог для каждого экземпляра должен быть уникальным. Если создается виртуальный каталог для именованного экземпляра или экземпляра SQL Server Express по умолчанию, программа настройки служб Reporting Services автоматически вставляет сведения об экземпляре для создания уникального имени виртуального каталога. Например, предположим, имеется сервер с именем SERVER01, на котором вы установили экземпляр сервера отчетов по умолчанию, именованный экземпляр сервера отчетов (идентифицируемый как TestServer) и экземпляр SQL Server Express. Тогда URL-адреса по умолчанию для этих экземпляров будут выглядеть следующим образом:

  • http://server01/reportserver

  • http://server01/reportserver$SQLExpress

  • http://server01/reportserver$TestServer

Настройка экземпляра сервера отчетов на использование пользовательского веб-узла или уникального IP-адреса

По умолчанию экземпляры сервера отчетов настраиваются на веб-узел по умолчанию, где IP-адрес сопоставлен со значением «(Все не назначенные)». Веб-узел по умолчанию может использоваться с существующей конфигурацией для хранения всех экземпляров сервера отчетов, которые устанавливаются на одном и том же компьютере. В качестве альтернативного варианта каждый экземпляр сервера отчетов может работать на отдельном веб-узле. Это необходимо в том случае, если нужно задать соответствие определенного IP-адреса каждому экземпляру сервера отчетов. Дополнительные сведения о настройке каждого экземпляра сервера отчетов на использование конкретного веб-узла или IP-адреса см. в разделе How to: Configure Reporting Services to Use a Non-Default Web Site (Reporting Services Configuration).

Журнал изменений

Версия Журнал

12 декабря 2006 г.

Измененное содержимое:
  • Уточнены ограничения, связанные с установкой нескольких экземпляров одновременно.

17 июля 2006 г.

Измененное содержимое:
  • Уточнено описание процесса установки по умолчанию.

  • Перемещены в отдельный подраздел инструкции по настройке экземпляра сервера отчетов на использование конкретного веб-узла.

См. также

Задачи

Как запустить настройку служб Reporting Services

Справочник

Имя экземпляра

Основные понятия

Установка служб SQL Server Reporting Services
Настройка виртуальных каталогов сервера отчетов


Установка служб SQL Server Integration Services

Установка служб SQL Server Integration Services
Установка компонентов SQL Server 2005 >

Дата обновления: 17 июля 2006 г.

Шаг 1 Подготовка к установке служб Integration Services

Прежде, чем приступить к установке служб , просмотрите следующие требования:

  • Требования к оборудованию и программному обеспечению для установки SQL Server 2005

  • Параметры для средства проверки конфигурации системы

  • Анализ безопасности при установке SQL Server

Примечание.
SQL Server 2005 Службы Integration Services не предоставляют специальных параметров установки для отказоустойчивого кластера. Однако после установки служб Integration Services отдельно на каждом узле кластера их можно вручную настроить для работы в качестве службы, поддерживающей работу в кластере. Дополнительные сведения см. в разделе Как настроить службы Integration Services в кластере.

Шаг 2 Установка служб Integration Services

Просмотрев требования по установке для SQL Server 2005 и убедившись, что компьютер соответствует этим требованиям, можно начинать установку служб Integration Services. В зависимости от конфигурации системы, установка служб Integration Services будет производиться одним из следующих способов:

  • Установка служб Integration Services на «чистом» компьютере

  • Добавление служб Integration Services к существующей установке SQL Server 2005

  • Установка служб Integration Services параллельно со службами DTS SQL Server 2000

  • Обновление до служб Integration Services

Примечание.
Некоторые компоненты SQL Server 2005, выбранные для установки на странице Компоненты для установки и Выбор компонентов мастера установки SQL Server, производят установку не всех компонентов служб Integration Services. Эти компоненты полезны для определенных задач, но функциональные возможности служб Integration Services будут ограничены. Например, при выборе компонента Database Engine выполняется установка только тех компонентов служб Integration Services, которые необходимы для работы мастера импорта и экспорта SQL Server. При выборе среды Business Intelligence Development Studio выполняется установка компонентов Integration Services, необходимых для конструирования пакета, однако служба Integration Services не устанавливается, задача «Очередь сообщений» работать не будет, а запуск пакетов вне среды BI Development Studio будет невозможен. Чтобы гарантировать установку служб Integration Services в полном объеме, необходимо выбрать службы Integration Services на странице Компоненты для установки.

Примечание.
Сведения о возможностях сервера SQL Server 2005, установленного на 64-разрядном компьютере, см. в разделе Использование служб Integration Services на 64-разрядных компьютерах.

Установка служб Integration Services на «чистом» компьютере

Как и в случае с любым компонентом SQL Server 2005, можно установить службы Integration Services либо запуском программы установки SQL Server через мастер установки SQL Server, либо запуском программы установки из командной строки.

Вариант 1. Использование мастера установки SQL Server

Можно установить службы Integration Services на локальный компьютер, используя мастер установки SQL Server.

Раздел Описание

Установка служб SQL Server Integration Services с помощью программы установки

Сведения по установке, касающиеся непосредственно служб Integration Services.

Как установить SQL Server 2005 (программа установки)

Сведения по установке, описывающие каждый шаг мастера установки SQL Server и относящиеся ко всем компонентам SQL Server 2005, включая службы Integration Services.
Вариант 2. Запуск программы установки из командной строки

Можно запустить программу установки SQL Server из командной строки. Если службы Integration Services устанавливаются на удаленном компьютере, необходимо запустить программу установки из командной строки.

Раздел Описание

Установка служб SQL Server Integration Services из командной строки

Сведения по установке из командной строки, касающиеся непосредственно служб Integration Services.

Как установить SQL Server 2005 из командной строки

Сведения по установке, описывающие каждый шаг и параметр в процессе установки из командной строки и относящиеся ко всем компонентам SQL Server 2005, включая службы Integration Services.

Добавление служб Integration Services к существующей установке SQL Server 2005

Также можно добавить службы Integration Services к существующей установке SQL Server 2005. Дополнительные сведения см. в разделе Как добавить службы Integration Services к существующему экземпляру SQL Server 2005.

Установка служб Integration Services параллельно со службами DTS SQL Server 2000

Можно установить службы Integration Services вместе со службами DTS (DTS) . Позже можно по выбору скопировать существующие пакеты DTS в модульный формат служб Integration Services, оставив при этом существующие пакеты без изменений.

Раздел | Описание
Обновление или миграция служб DTS | Общие сведения о параллельной установке и миграции пакетов.
Миграция пакетов служб DTS | Сведения о мастере миграции пакетов и о различиях между пакетами служб DTS SQL Server 2000 и службы Integration Services.
Обратная совместимость служб SQL Server 2005 Integration Services | Сведения о поддержке служб DTS SQL Server 2000 в Integration Services.

Обновление до служб Integration Services

Можно обновить службы DTS до Integration Services, воспользовавшись программой установки SQL Server для установки Integration Services, а затем, по выбору, мастером миграции пакетов для копирования уже существующих пакетов DTS в новый пакетный формат Integration Services с сохранением исходных пакетов без изменения.

Раздел | Описание
Обновление или миграция служб DTS | Общие сведения о параллельной установке и миграции пакетов.
Миграция пакетов служб DTS | Сведения о мастере миграции пакетов и о различиях между пакетами служб DTS SQL Server 2000 и Integration Services.
Обратная совместимость служб SQL Server 2005 Integration Services | Сведения о поддержке служб DTS SQL Server 2000 в Integration Services.

Журнал изменений

Версия Журнал

17 июля 2006 г.

Измененное содержимое:
  • Добавлен раздел о добавлении служб Integration Services к существующей установке SQL Server 2005.

5 декабря 2005 г.

Измененное содержимое
  • Добавлены замечания, обращающие внимание пользователей на подразделы, в которых приводятся дополнительные сведения о конфигурации кластера служб Integration Services и 64-разрядных функциях.


Установка служб SQL Server Integration Services с помощью программы установки

Установка служб SQL Server Integration Services с помощью программы установки
Установка компонентов SQL Server 2005 > Установка служб SQL Server Integration Services >

Дата обновления: 12 декабря 2006 г.

Примечание.
Дополнительные сведения об использовании мастера установки SQL Server для установки компонентов см. в разделе Как установить SQL Server 2005 (программа установки).

Этот раздел содержит только сведения, которые относятся к установке служб с помощью мастера установки SQL Server.

  • Выбор компонентов для установки

  • Указание расположения файлов служб Integration Services

  • Установка службы Windows служб Integration Services

  • Установка средств поддержки пакетов служб DTS SQL Server 2000

К существующей установке служб SQL Server 2005 можно добавить службы Integration Services. Дополнительные сведения см. в разделе Как добавить службы Integration Services к существующему экземпляру SQL Server 2005.

Примечание.
Некоторые компоненты SQL Server 2005, выбранные для установки на странице Компоненты для установки и Выбор компонентов мастера установки SQL Server, производят установку не всех компонентов служб Integration Services. Эти компоненты полезны для определенных задач, но функциональные возможности служб Integration Services будут ограничены. Например, при выборе компонента Database Engine выполняется установка только тех компонентов служб Integration Services, которые необходимы для работы мастера импорта и экспорта SQL Server. При выборе компонента среды Business Intelligence Development Studio устанавливаются компоненты служб Integration Services, необходимые для создания пакета, однако имеются следующие ограничения: не устанавливается служба Integration Services, задача «Очередь сообщений» не работает, а запуск пакетов вне среды BI Development Studio невозможен. Чтобы гарантировать установку служб Integration Services в полном объеме, необходимо выбрать службы Integration Services на странице Компоненты для установки.

Примечание.
Сведения о возможностях сервера SQL Server 2005, установленного на 64-разрядном компьютере, см. в разделе Использование служб Integration Services на 64-разрядных компьютерах.

Выбор компонентов для установки

Хотя можно установить только службы Integration Services, многие решения хранилищ данных потребуют установки дополнительных компонентов SQL Server 2005 для разработки, развертывания и администрирования пакетов Integration Services. В следующей таблице перечислены эти дополнительные, необязательные компоненты SQL Server 2005.

Компонент | Для администратора | Для разработчика | Необязательный
Компоненты связи Компоненты, обеспечивающие связь между клиентами и серверами, включая сетевые библиотеки для DB-Library, ODBC и OLE DB. | X | X |
Средства управления Интерактивные средства для управления SQL Server 2005, включая диспетчер конфигурации SQL Server, SQL Server Management Studio, SQL Server Profiler и монитор репликации. | X |  |
Среда Business Intelligence Development Studio Интегрированная среда разработки для проектов бизнес-аналитики. |  | X |
Набор средств разработки программного обеспечения Программное обеспечение, помогающее разработчикам создавать собственные решения для SQL Server 2005. |  | X |
Службы SQL Server Database Services SQL Server Database Engine и средства для управления реляционными данными и XML-данными, репликацией и полнотекстовым поиском. |  |  | X
SQL Server Analysis Services Службы SQL Server 2005 Analysis Services (SSAS) и средства поддержки интерактивной аналитической обработки (OLAP) и интеллектуального анализа данных. |  |  | X
SQL Server Reporting Services Сервер отчетов для выполнения, подготовки и распространения отчетов и управления ими, а также диспетчер отчетов — пользовательский веб-интерфейс, который обеспечивает доступ к компонентам служб SQL Server 2005 Reporting Services (SSRS) и содержит средства администрирования и пользовательский интерфейс для просмотра отчетов. |  |  | X
Документация и образцы Электронная документация по SQL Server, справочные материалы по программированию и образцы для всех компонентов SQL Server 2005. | X | X | X

Установка выбранных компонентов

Службы Integration Services могут быть установлены либо вместе с дополнительными компонентами SQL Server 2005, либо без них, как описано ниже.

Установка только служб Integration Services

  • На странице Компоненты для установки мастера установки SQL Server выберите только Службы Integration Services.

    Примечание.
    Если выбрать только службы Integration Services, то клиентские компоненты SQL Server 2005 (средства командной строки, компоненты связи, модели программирования, средства управления и разработки, документация и образцы) по умолчанию не устанавливаются.

Добавление или удаление устанавливаемых компонентов с помощью страницы «Компоненты для установки»

  • На странице Компоненты для установки установите флажки для тех компонентов, которые нужно добавить, и снимите для тех, которые нужно удалить.

    Примечание.
    Если выбрать параметр установки Компоненты рабочей станции, электронная документация и средства разработки на странице Компоненты для установки, то образцы баз данных и программирования не устанавливаются. Чтобы установить образцы баз данных и программирования, необходимо выбрать их параметры установки вручную на странице Выбор компонентов.

Добавление или удаление компонентов с помощью страницы «Выбор компонентов»

  1. На странице Компоненты для установки нажмите кнопку Дополнительно.

  2. На странице Выбор компонентов установите флажки для тех компонентов, которые нужно установить, и снимите флажки для тех компонентов, которые нужно удалить.

    Примечание.
    Страница Выбор компонентов предоставляет удобный способ просмотра подробного списка параметров установки в мастере установки SQL Server, включая компоненты, описанные ранее в этом разделе.

Указание расположения файлов служб Integration Services

Программа установки SQL Server 2005 помещает программные и общие файлы служб Integration Services в различные местоположения. Расположение папок для файлов служб Integration Services по умолчанию указано в следующей таблице.

Файлы служб Integration Services | Расположение по умолчанию
Базовые компоненты служб Integration Services и программа командной строки dtexec | C:\Program Files\Microsoft SQL Server\90\DTS\Binn
Диспетчеры соединений служб Integration Services | C:\Program Files\Microsoft SQL Server\90\DTS\Connections
Перечислители служб Integration Services | C:\Program Files\Microsoft SQL Server\90\DTS\ForEachEnumerators
Файлы в формате XML, которые сопоставляют типы данных одной версии базы данных или системы типам другой (например, между SQL Server 2000 и SQL Server 2005 или между SQL Server 2005 и Oracle). Такие файлы сопоставлений используются мастерами экспорта и импорта SQL Server. | C:\Program Files\Microsoft SQL Server\90\DTS\MappingFiles
Компоненты потока данных служб Integration Services: источники, преобразования и адресаты | C:\Program Files\Microsoft SQL Server\90\DTS\PipelineComponents
Исполняемые задачи служб Integration Services | C:\Program Files\Microsoft SQL Server\90\DTS\Tasks
Компоненты, совместно используемые всеми экземплярами компонентов SQL Server 2005 | C:\Program Files\Microsoft SQL Server\90\Shared Эту папку нельзя изменить при установке.
Средства, документация и образцы | C:\Program Files\Microsoft SQL Server\90\Tools Для всех экземпляров служб Analysis Services и других компонентов SQL Server устанавливается один комплект средств и документации.

Изменение во время установки расположения по умолчанию файлов служб Integration Services

  1. На странице Компоненты для установки нажмите кнопку Дополнительно.

  2. На странице Выбор компонентов щелкните компонент, который поддерживает изменение пути установки по умолчанию, и нажмите кнопку Обзор.

  3. В поле Путь установки на странице Смена папки введите новое расположение файлов.
Важно!
Теперь на странице Выбор компонентов есть параметр, позволяющий установить компоненты SQL Server 2005 в расположение, отличное от папки по умолчанию, — %ProgramFiles%\Microsoft SQL Server\90. Этот параметр указывается для служб SQL Server 2005 Integration Services, служб SQL Server 2005 Notification Services и компонентов рабочей станции (клиентские средства, документация и примеры). При установке из командной строки для этого можно использовать следующий ключ: installsqlshareddir.

Установка службы Windows служб Integration Services

При установке Integration Services будет установлена служба Integration Services — новая возможность, содержащая ряд усовершенствований и не имеющая аналога в службах DTS SQL Server 2000. Службы Integration Services позволяют выполнять в среде SQL Server Management Studio следующее:

  • отслеживать выполнение всех пакетов служб Integration Services, выполняющихся на компьютере;

  • отображать в иерархическом виде пакеты и папки служб Integration Services, которые физически хранятся в разных местах.

Примечание.
Эта служба не нужна для создания, хранения и выполнения пакетов служб SSIS.

Службы Integration Services устанавливаются и включаются по умолчанию при выборе компонента Службы SQL Server Integration Services на странице Компоненты для установки. Можно установить только один экземпляр сервера на компьютер.

Эта служба регистрируется для запуска с учетной записью сетевой службы. (В Windows 2000 служба выполняется под учетной записью Local System.) Этот параметр не может быть изменен в мастере установки SQL Server, и на него не влияют никакие другие параметры, устанавливаемые на странице мастера Учетная запись службы.

Служба выполняется в отдельном процессе, а не зависит от процесса агента SQL Server.

По умолчанию службы Integration Services сохраняют пакеты, хранящиеся в SQL Server, в локальном экземпляре по умолчанию Database Engine. Если нужно сохранить пакеты в именованном экземпляре или на другом сервере, необходимо изменить файл конфигурации для службы Integration Services. Дополнительные сведения см. в разделе Настройка служб Integration Services.

Чтобы управлять этой службой, используется диспетчер конфигурации SQL Server или оснастка Службы в консоли управления Microsoft (MMC), которая доступна в разделе Администрирование в панели управления. Дополнительные сведения см. в разделе Управление службой Integration Services.

Установка средств поддержки пакетов служб DTS SQL Server 2000

Если для установки выбраны Службы Integration Services, программа установки также устанавливает поддержку пакетов служб DTS SQL Server 2000, включая среду выполнения DTS и перечисление пакетов служб DTS в среде SQL Server Management Studio. Обновленная поддержка среды выполнения позволяет пакетам служб DTS получать доступ к источникам данных SQL Server 2005. Если не производится установка служб Integration Services, но необходима поддержка пакетов служб DTS, необходимо обеспечить, чтобы на странице Выбор компонентов были выбраны Компоненты прежних версий.

В число устанавливаемых файлов, служащих для обеспечения обратной совместимости, входят также задача «Обработка средствами SQL Server 2000 Analysis Services» и зависимый от нее модуль объектов DSO. Однако файлы задачи «Прогноз интеллектуального анализа данных» SQL Server 2000 не устанавливаются.

Примечание.
При установке SQL Server 2005 конструктор пакетов служб DTS не устанавливается. Дополнительные сведения см. в разделе Обратная совместимость служб SQL Server 2005 Integration Services. Пакеты служб DTS нельзя открывать или изменять в среде BI Development Studio.

Если выбрана установка служб Integration Services, также устанавливается мастер миграции пакетов. Мастер миграции пакетов можно использовать для обновления пакетов служб DTS SQL Server 2000 до формата Integration Services. Во время миграции мастер копирует пакеты служб DTS, после чего повторно создает их в формате Integration Services. Исходные пакеты при этом не изменяются. Дополнительные сведения см. в разделе Миграция пакетов служб DTS.

Примечание.
Мастер миграции пакетов доступен в следующих выпусках SQL Server 2005: Standard, Enterprise, Developer.

Журнал изменений

Версия Журнал

12 декабря 2006 г.

Новое содержимое
  • Добавлена ссылка на раздел об установке Integration Services на существующий экземпляр SQL Server.

  • Добавлена ссылка на раздел об изменении файла конфигурации службы Integration Services для хранения пакетов в расположении, отличном от принятого по умолчанию.

5 декабря 2005 г.

Новое содержимое
  • Добавлено примечание со ссылкой на подраздел с дополнительными сведениями о 64-разрядной версии служб Integration Services.

Измененное содержимое
  • Улучшено описание параметров установки для компонентов прежних версий.


Установка служб SQL Server Integration Services из командной строки

Установка служб SQL Server Integration Services из командной строки
Установка компонентов SQL Server 2005 > Установка служб SQL Server Integration Services >

Дата обновления: 17 июля 2006 г.

Примечание.
Дополнительные сведения об установке компонентов из командной строки см. в разделе Как: установить SQL Server 2005 из командной строки.

Этот раздел содержит сведения, относящиеся только к установке служб из командной строки.

Примечание.
Для некоторых из выбранных компонентов SQL Server 2005 производится установка некоторых компонентов служб Integration Services.Эти компоненты полезны для определенных задач, но функциональные возможности служб Integration Services будут ограничены.Например, при выборе компонента Database Engine выполняется установка только тех компонентов служб Integration Services, которые необходимы для работы мастера импорта и экспорта SQL Server. При выборе компонента среды Business Intelligence Development Studio выполняется установка только тех компонентов служб Integration Services, которые необходимы для проектирования пакета, однако имеются ограничения: служба Integration Services не устанавливается, задача «Очередь сообщений» не функционирует, и выполнение пакетов извне BI Development Studio невозможно. Чтобы выполнить установку служб Integration Services в полном объеме, выберите установку служб Integration Services.

Примечание.
Сведения о возможностях сервера SQL Server 2005, установленного на 64-разрядном компьютере, см. в разделе Использование служб Integration Services на 64-разрядных компьютерах.

Параметры установки служб Integration Services из командной строки

Установка служб из командной строки может производиться на локальном или на удаленном сервере.При установке из командной строки можно указать параметры в командной строке или воспользоваться ключом /settings для загрузки параметров из INI-файла.Параметры могут быть указаны либо в командной строке, либо в INI-файле, но не в обоих местах одновременно.

При установке из командной строки укажите ключи addlocal="feature1,feature2,..." для каждой из функций SQL Server 2005, которую необходимо установить.В следующей таблице перечислены параметры, которые могут быть указаны при установке служб Integration Services, включая компоненты служб Integration Services, средства разработки SQL Server Database Engine и электронную документацию по SQL Server.

Значение | Означает
SQL_DTS | Компоненты служб Integration Services.Также устанавливает поддержку пакетов служб DTS , включая среду выполнения служб DTS и перечислитель пакетов DTS в SQL Server Management Studio.
SQL_WarehouseDevWorkbench | Business Intelligence Development Studio.
SQL_Tools90 | SQL Server Management Studio.
SQL_Engine | SQL Server Database Engine.
SQL_Data_Files | Файлы данных для SQL Server Database Engine.Этот параметр обязателен, если указан параметр SQL_Engine.
SQL_BooksOnline | Электронная документация по SQL Server.Если этот параметр не указан, контекстная справка в конструкторах, редакторах и мастерах будет недоступна.

Например, чтобы установить экземпляр служб Integration Services вместе с документацией по продукту, укажите аргумент addlocal, как показано в следующем примере:

Копировать код
   setup addlocal="SQL_DTS,SQL_BooksOnline"

Дополнительные сведения о возможностях SQL Server 2005, которые можно указать в аргументе addlocal, см. в файле template.ini в корневом каталоге установочного носителя SQL Server 2005 или в разделе Как установить SQL Server 2005 из командной строки.

Важно!
Теперь имеется возможность установить определенные компоненты SQL Server 2005 в каталоги, отличные от %ProgramFiles%\Microsoft SQL Server\90. Эта возможность доступна для служб Integration Services, служб SQL Server 2005 Notification Services и компонентов рабочей станции (клиентские средства, документация и примеры).При установке из командной строки это делается с помощью параметра installsqlshareddir.

Другие обязательные параметры установки из командной строки

Некоторые параметры, например PIDKEY, обязательны при любой установке, выполняемой с помощью команды setup из командной строки.В ряде случаев при установке служб Integration Services и других компонентов SQL Server 2005 могут потребоваться и другие параметры.

Дополнительные сведения об установке продуктов и компонентов SQL Server 2005 из командной строки см. в разделе Как установить SQL Server 2005 из командной строки.

Задание параметров установки в INI-файле

Можно указать дополнительные параметры командной строки setup в INI-файле.В командной строке программы setup укажите аргумент /settings filename.ini, указывающий на INI-файл, в котором содержатся параметры установки.

Файл template.ini на установочном носителе SQL Server 2005 содержит подробные сведения о том, как создать этот файл.Обратите внимание, что первая незакомментированная строка в INI-файле должна содержать строку «[Options]».Ниже приведен пример, показывающий формат INI-файла:

Копировать код
[Options]
USERNAME=MyName
COMPANYNAME=MyCompany
PIDKEY=ABCDE12345FGHIJ67890KLMNO
ADDLOCAL=SQL_DTS, SQL_BooksOnline,...
...

Дополнительные сведения о параметрах установки SQL Server 2005, указываемых в INI-файле, см. в файле template.ini в корневом каталоге установочного носителя SQL Server 2005 либо в Как установить SQL Server 2005 из командной строки.

Журнал изменений

Версия Журнал

5 декабря 2005 г.

Измененное содержимое
  • Добавлено примечание со ссылкой на подраздел с дополнительными сведениями о 64-разрядной версии служб Integration Services.

  • Разъяснены ограничения неполной установки служб Integration Services.


Установка служб SQL Server Notification Services

Установка служб SQL Server Notification Services |
 | См. также
Установка компонентов SQL Server 2005 >

Службы Microsoft SQL Server Notification Services — это платформа для разработки и развертывания приложений, формирующих и отправляющих уведомления. Службы Notification Services можно использовать для формирования и своевременной отправки индивидуальных сообщений тысячам и миллионам подписчиков. Поддерживается доставка сообщений на широкий спектр устройств.

Этот раздел содержит сведения об установке служб Notification Services.

Шаг 1. Проверьте предварительные условия

Перед началом установки служб Notification Services просмотрите следующий список требований:

  • Требования к оборудованию и программному обеспечению для установки SQL Server 2005

  • Параметры для средства проверки конфигурации системы

  • Анализ безопасности при установке SQL Server

Шаг 2. Выберите, какие компоненты необходимо установить

В службы Notification Services входят два набора устанавливаемых компонентов: ядро и клиент. В зависимости от выбранного варианта развертывания можно установить либо все, либо только один набор компонентов.

  • Компоненты ядра выполняют экземпляры и приложения служб Notification Services.

  • Клиентские компоненты обычно используются для взаимодействия с данными экземпляров и приложений, размещенных на других серверах.

В зависимости от того, как используются службы Notification Services, можно установить их компоненты на один или более серверов. Необходимо установить компоненты на любой сервер, который будет отвечать за следующие функции служб Notification Services:

  • Для любого сервера, на котором запущен внутрипроцессный поставщик событий, генератор или распространитель событий, необходимы компоненты ядра.

  • Для любого сервера, на котором выполняется внепроцессный поставщик событий или интерфейс управления подпиской, необходимы клиентские компоненты. Клиентские компоненты необходимы для регистрации экземпляра и использования API-интерфейса служб Notification Services.

  • Для любого сервера, с которого ведется администрирование экземпляров служб Notification Services, необходимы клиентские компоненты. Клиентские компоненты необходимы для регистрации экземпляра и взаимодействия с ним. Клиентские компоненты включены в состав среды SQL Server Management Studio.

Шаг 3. Установите службы Notification Services

Если все готово для установки служб Notification Services, то воспользуйтесь одним из нижеперечисленных методов проведения установки:

  • Установка служб Notification Services с помощью программы установки

  • Установка служб Notification Services из командной строки

Шаг 4. Настройте службы Notification Services

После окончания установки служб Notification Services станут возможными создание приложений Notification Services, настройка экземпляров Notification Services для размещения этих приложений, а также развертывание экземпляров Notification Services. Дополнительные сведения см. в следующих разделах электронной документации по SQL Server:

  • Построение решений на основе служб Notification Services

  • Развертывание служб Notification Services

После развертывания экземпляров служб Notification Services станет возможным настроить эти экземпляры в среде SQL Server Management Studio или с помощью программы командной строки nscontrol. Дополнительные сведения см. в разделе Администрирование служб Notification Services.

Удаление служб Notification Services

Если службы служб Notification Services удаляются без возможности восстановления, то перед удалением продукта необходимо сначала удалить все экземпляры Notification Services. Если экземпляры служб Notification Services обновляются до более новой версии SQL Server, то можно оставить существующие экземпляры и следовать указаниям по миграции на Notification Services. Дополнительные сведения см. в следующих разделах:

  • Удаление экземпляров служб Notification Services

  • Миграция экземпляров служб Notification Services

  • Как удалить службы Notification Services

См. также

Другие ресурсы

Установка компонентов SQL Server 2005


Установка служб Notification Services с помощью программы установки

Установка служб Notification Services с помощью программы установки |
 | См. также
Установка компонентов SQL Server 2005 > Установка служб SQL Server Notification Services >

Когда устанавливаются службы Notification Services, установка экземпляра служб Notification Services не происходит. Вместо этого устанавливаются двоичные файлы служб Notification Services. Затем выполняется настройка и развертывание экземпляров служб Notification Services, содержащих приложения уведомлений.

Экземпляр служб Notification Services может быть запущен на системах различных конфигураций. Например, ядро служб Notification Services и базы данных могут находиться на одном сервере или ядро и базы данных могут находиться на отдельных серверах. Кроме того, можно использовать интерфейсы управления подписками или внепроцессные поставщики событий, находящиеся на удаленных серверах.

Необходимо установить службы Notification Services везде, где нужно запускать ядро Notification Services (в котором содержатся внутрипроцессные поставщики событий, генераторы и распространители), а компоненты клиента служб Notification Services — где нужно запускать внепроцессные поставщики событий, интерфейс управления подписками или консоль администрирования.

Односерверная установка

В случае односерверной установки служб Notification Services и ядро СУБД Microsoft SQL Server запускаются на одном сервере. Это обычный вариант для систем разработки и небольших или средних производственных систем.

При выполнении программы установки устанавливается экземпляр ядра СУБД SQL Server и службы Notification Services. Можно также установить компоненты для рабочих станций, чтобы создавать экземпляры служб Notification Services и управлять ими с помощью среды SQL Server Management Studio.

Установка служб Notification Services и компонента Database Engine

  • How to: Install Notification Services and the Database Engine

Удаленные ядра служб Notification Services

Компоненты ядра служб Notification Services, которые запускают внутрипроцессные поставщики событий, генераторы и распространители, могут быть расположены отдельно от ядра СУБД.

При указании приложения служб Notification Services необходимо указать и сервер, на котором размещены и работают каждый внутрипроцессный поставщик событий, генератор и распространитель. На каждом из указанных серверов необходимо установить компоненты ядра служб Notification Services. Для этого нужно установить службы Notification Services.

Примечание.
Диалоговое окно «Выбор компонентов» в программе установки SQL Server дает возможность установить компоненты ядра и клиентские компоненты. Установка компонентов ядра эквивалентна полной установке служб Notification Services.

Установка служб Notification Services

  • Как установить компоненты ядра служб Notification Services

Удаленные клиенты служб Notification Services

Большинству приложений служб Notification Services требуется одно или несколько клиентских приложений. На серверах, где запущены клиентские приложения, но не компоненты ядра, должны быть установлены клиентские компоненты служб Notification Services.

Клиентские компоненты используются в приложениях следующих типов:

  • Интерфейсы управления подписками

  • Внепроцессные поставщики событий

  • Консоли администрирования

Во время установки клиентских компонентов служб Notification Services устанавливаются все файлы служб Notification Services кроме тех, что требуются для запуска ядра Notification Services.

Примечание.
Клиентские компоненты служб Notification Services также устанавливаются вместе со средой SQL Server Management Studio.

Установка клиентских компонентов

  • Как установить компоненты клиента служб Notification Services

См. также

Основные понятия

Установка служб SQL Server Notification Services
Установка служб Notification Services из командной строки
Миграция экземпляров служб Notification Services


Установка служб Notification Services из командной строки

Установка служб Notification Services из командной строки |
 | См. также
Установка компонентов SQL Server 2005 > Установка служб SQL Server Notification Services >

Программа установки Microsoft SQL Server 2005 кроме графического пользовательского интерфейса содержит интерфейс командной строки. Воспользуйтесь сведениями этого раздела для установки служб Notification Services из командной строки. Дополнительные сведения об установке SQL Server 2005 из командной строки, включая весь синтаксис и список параметров, см. в разделе Как установить SQL Server 2005 из командной строки.

Значения ADDLOCAL служб Notification Services

Каждый компонент служб Notification Services можно установить из командной строки с помощью аргумента ADDLOCAL программы Microsoft Windows Installer. Для установки компонента из командной строки необходимо использовать его правильное имя командной строки. Имя компонента и имя командной строки для каждого компонента показаны в приведенной ниже таблице.

Имя компонента | Имя командной строки
Все компоненты служб Notification Services | Notification_Services
Компоненты ядра | NS_Engine
Клиентские компоненты | NS_Client

Примеры

Следующие примеры показывают, как установить службы Notification Services из командной строки.

Установка всех компонентов служб Notification Services

Этот пример показывает, как установить все компоненты служб Notification Services, демонстрируя в ходе установки диалоговые окна:

start /wait setup.exe /qb ADDLOCAL=Notification_Services

Установка клиентских компонентов служб Notification Services

Этот пример показывает, как выполнить новую установку клиентских компонентов служб Notification Services. Не отображается ни одно диалоговое окно, но командная строка не возвращается до окончания установки:

start /wait setup.exe /qn ADDLOCAL=NS_Client

Удаление клиентских компонентов служб Notification Services

Этот пример показывает, как удалить клиентские компоненты служб Notification Services, демонстрируя в ходе установки диалоговые окна:

start /wait setup.exe REMOVE=NS_Client

См. также

Основные понятия

Установка служб SQL Server Notification Services
Установка служб Notification Services с помощью программы установки


Установка репликации SQL Server

Установка репликации SQL Server |
 | См. также
Установка компонентов SQL Server 2005 >

Дата обновления: 14 апреля 2006 г.

Компоненты репликации могут быть установлены с помощью мастера установки из командной строки или при помощи ini-файла. Устанавливайте репликацию при установке экземпляра SQL Server или при модификации существующего экземпляра.

После установки компонентов репликации необходимо настроить сервер перед началом использования репликации. Дополнительные сведения см. в разделе Настройка и обслуживание репликации электронной документации по SQL Server 2005.

Важно!
Если при изменении существующего экземпляра сервера SQL Server устанавливаются компоненты репликации, после завершения установки необходимо перезапустить агент SQL Server. Это действие позволит гарантировать, что агент SQL Server распознает подсистемы агента репликации и сможет обращаться к агентам репликации из шагов задания.

Установка репликации с помощью программы установки

Установка репликации при установке нового экземпляра SQL Server

  • Чтобы установить компоненты репликации, включая объекты RMO, на странице Компоненты для установки мастера установки выберите Службы SQL Server Database Services.

Установка репликации при изменении существующего экземпляра SQL Server

  • Установка компонентов репликации

    1. На странице Компоненты для установки мастера установки SQL Server выберите Дополнительно.

    2. На странице Выбор компонентов разверните узел Службы Database Services.

    3. Нажмите Репликация, а затем выберите Все компоненты будут установлены на локальный жесткий диск.

  • Установка объектов RMO

    1. На странице Компоненты для установки мастера установки SQL Server выберите Дополнительно.

    2. На странице Выбор компонентов разверните узел Клиентские компоненты.

    3. Выберите Набор средств разработки, а затем нажмите Весь компонент будет установлен на локальный жесткий диск.

Установка репликации из командной строки

Установка репликации при установке нового экземпляра SQL Server

  • Установка компонентов репликации

    • Укажите значение SQL_Engine для параметра ADDLOCAL в командной строке или в INI-файле. Например, командная строка может быть такой:

      Копировать код
      start /wait setup.exe /qb ADDLOCAL=SQL_Engine SQLACCOUNT=domain\user SQLPASSWORD=$tr0ngP@ssw0rd
  • Установка объектов RMO

    • Укажите значение SDK для параметра ADDLOCAL в командной строке или в INI-файле. Например, командная строка может быть такой:

      Копировать код
      start /wait setup.exe /qb ADDLOCAL=SQL_Engine,SDK SQLACCOUNT=domain\user SQLPASSWORD=thepassword

Установка репликации при изменении существующего экземпляра SQL Server

  • Установка компонентов репликации

    • Укажите значение SQL_Replication для параметра ADDLOCAL в командной строке или в INI-файле. Например, командная строка может быть такой:

      Копировать код
      start /wait setup.exe /i <installation package> /qb ADDLOCAL=SQL_Replication
  • Установка объектов RMO

    • Укажите значение SDK для параметра ADDLOCAL в командной строке или в INI-файле. Например, командная строка может быть такой:

      Копировать код
      start /wait setup.exe /i <installation package> /qb ADDLOCAL=SDK

См. также

Основные понятия

Установка SQL Server 2005
Выполнение установки из командной строки
Указание свойств установки в INI-файле

Другие ресурсы

Установка компонентов SQL Server 2005

Журнал изменений

Версия Журнал

14 апреля 2006 г.

Новое содержимое:
  • Добавлены сведения о необходимости перезапуска агента SQL Server, если при изменении существующего экземпляра SQL Server устанавливаются компоненты репликации.


Установка образцов баз данных и примеров AdventureWorks

Установка образцов баз данных и примеров AdventureWorks |
 | См. также
Установка компонентов SQL Server 2005 >

В поддерживаются оперативная обработка транзакций (OLTP), оперативная аналитическая обработка (OLAP), а также предоставляются образцы базы данных хранилища данных. Эти базы данных используются в образцах база данных и в примерах кода, содержащихся в электронной документации по SQL Server 2005. Могут быть загружены образцы баз данных, использовавшиеся в более ранних версиях SQL Server.

В этом разделе

Раздел | Описание
Использование программы установки для установки образца базы данных AdventureWorks и других примеров | Приводится описание установки образцов баз данных AdventureWorks, AdventureWorksDW и Adventure Works DW и примеров с помощью программы установки.
Повторная установка образцов баз данных с помощью сценария | Приводится описание повторной установки образцов баз данных AdventureWorks или AdventureWorksDW с помощью сценария установки.
Загрузка образцов баз данных Northwind и pubs | Приводится описание загрузки образцов баз данных Northwind и pubs из центра загрузки Microsoft.

См. также

Другие ресурсы

Образцы кода и баз данных
Установка компонентов SQL Server 2005


Использование программы установки для установки образца базы данных AdventureWorks и других примеров

Использование программы установки для установки образца базы данных AdventureWorks и других примеров |
 | См. также
Установка компонентов SQL Server 2005 > Установка образцов баз данных и примеров AdventureWorks >

Дата обновления: 17 июля 2006 г.

Образцы баз данных AdventureWorks (OLTP), AdventureWorksDW (хранилище данных), Adventure Works DW (службы Analysis Services) и сопутствующие образцы по умолчанию в SQL Server 2005 не устанавливаются. Можно загрузить образцы со страницы SQL Server 2005 Samples and Sample Databases (образцы баз данных и другие образцы SQL Server 2005) в центре загрузки Microsoft, либо использовать следующие указания для установки образцов баз данных и других образцов во время или после установки SQL Server 2005. Также предоставляются дополнительные инструкции по развертыванию проекта служб Analysis services в Adventure Works DW.

Примечание.
Эта инструкция не применяется к SQL Server 2005 Express Edition и SQL Server 2005 Compact Edition. Загрузку AdventureWorks для этих выпусков можно произвести из раздела Установка образцов баз данных для выпусков Express Edition.

Важно!
При установке образцов баз данных AdventureWorks и AdventureWorksDW используются параметры сортировки SQL_Latin1_General_CP1_CI_AS, а не параметры, выбранные для данного экземпляра SQL Server. Чтобы изменить параметры сортировки для образцов баз данных для согласования с параметрами сортировки сервера, удалите базу данных и создайте ее снова из сценария установки. Дополнительные сведения см. в разделе Повторная установка образцов баз данных с помощью сценария.

Установка образцов во время выполнения программы установки SQL Server 2005

Чтобы установить образцы баз данных и сопутствующие примеры с помощью программы установки, выполните следующие действия.

  1. На странице Компоненты для установки выберите Компоненты рабочей станции, электронная документация и средства разработки.

  2. Нажмите кнопку Дополнительно и раскройте пункт Документация, примеры и образцы баз данных.

  3. Выберите Образцы кода и приложений.

  4. Раскройте пункт Образцы баз данных и выберите образцы баз данных для установки.

    Примечание.
    База данных OLAP (Adventure Works DW) не может быть установлена, если база данных хранилища данных (AdventureWorksDW) не выбрана для установки. Проект служб Analysis Services Adventure Works DW должен быть развернут, прежде чем можно будет производить доступ к базе данных Adventure Works DW.

  5. Для завершения установки примеров после завершения установки выполните следующие шаги.

    1. В меню Пуск последовательно выберите пункты Программы, Microsoft SQL Server 2005, Документация и учебные материалы, Примеры и Примеры Microsoft SQL Server 2005.

    2. Либо при помощи проводника Windows перейдите в папку <диск>:\Program Files\Microsoft SQL Server\90\Tools\Samples\ и дважды щелкните файл SqlServerSamples.msi для запуска программы установки.

    Важно!
    Образцы устанавливаются в папку <диск>:\Program Files\Microsoft SQL Server\90\Samples. Обязательно прочтите и выполните инструкции по установке, которые содержатся в файлах Readme, прилагающихся к образцам. Для просмотра списка образцов см. раздел Образцы.

Установка образцов после завершения программы установки SQL Server 2005

Если образцы баз данных и другие образцы не были установлены во время начальной установки SQL Server 2005, их можно установить позже.

Важно!
Нельзя использовать эту процедуру для повторного создания образца базы данных, которая была удалена. Для повторного создания удаленного образца базы данных переустановите его с помощью сценария установки. Дополнительные сведения см. в разделе Повторная установка образцов баз данных с помощью сценария.

  1. В средстве Установка и удаление программ выберите Microsoft SQL Server 2005 и нажмите кнопку Изменить. Следуйте инструкциям мастера Обслуживание Microsoft SQL Server 2005.

  2. В окне Выбор компонентов выберите Компоненты рабочей станции и нажмите кнопку Дальше.

  3. На странице Вас приветствует мастер установки SQL Server нажмите кнопку Далее.

  4. На странице Проверка конфигурации системы нажмите кнопку Далее.

  5. В окне Изменить или удалить экземпляр выберите Изменить установленные компоненты.

  6. В окне Выбор компонентов раскройте узел Документация, примеры и образцы баз данных.

  7. Выберите Образцы кода и приложений.

  8. Раскройте пункт Образцы баз данных и выберите образец базы данных для установки. Нажмите кнопку Далее.

  9. Чтобы установить и подключить образцы баз данных, на странице Установка образцов баз данных выберите Установить и подключить образцы баз данных, а затем нажмите кнопку Далее.

    Файлы базы данных создаются и сохраняются в папке <диск>:\Program Files\Microsoft SQL Server\MSSQL.n\MSSQL\Data. Базы данных активизируются и готовы к использованию.

  10. Чтобы установить образец базы данных без подключения, на странице Установка образцов баз данных выберите Установить образцы баз данных и нажмите кнопку Далее.

    Файлы базы данных AdventureWorks создаются в папке <диск>:\Program Files\Microsoft SQL Server\90\Tools\Samples\AdventureWorks OLTP. Файлы базы данных AdventureWorksDW создаются в папке <диск>:\Program Files\Microsoft SQL Server\90\Tools\Samples\AdventureWorks Data Warehouse. Перед использованием базу данных необходимо подключить. Дополнительные сведения см. в разделе Присоединение и отсоединение баз данных.

  11. Выберите экземпляр SQL Server, куда устанавливаются образцы базы данных и примеры.

  12. Завершить шаги мастера.

  13. Для завершения установки примеров после завершения установки выполните следующие шаги.

    1. В меню Пуск последовательно выберите пункты Программы, Microsoft SQL Server 2005, Документация и учебные материалы, Примеры и Примеры Microsoft SQL Server 2005.

    2. Либо при помощи проводника Windows перейдите в папку <диск>:\Program Files\Microsoft SQL Server\90\Tools\Samples\ и дважды щелкните файл SqlServerSamples.msi для запуска программы установки.

    Важно!
    Образцы устанавливаются в папку <диск>:\Program Files\Microsoft SQL Server\90\Samples. Обязательно прочтите и выполните инструкции по установке, которые содержатся в файлах Readme, прилагающихся к образцам. Для просмотра списка образцов см. раздел Образцы.

Развертывание проекта служб Analysis Services Adventure Works DW

  1. Убедитесь, что установлены базы данных AdventureWorksDW и Adventure Works DW.

  2. Убедитесь, что установлены службы Analysis Services.

  3. На панели инструментов среды SQL Server Business Intelligence Development Studio нажмите Файл, выберите пункт Открыть, а затем Проект/Решение.

  4. Откройте каталог <диск>:\Program Files\Microsoft SQL Server\90\Tools\Samples\AdventureWorks Analysis Services Project, выберите файл Adventure Works.sln и нажмите кнопку Открыть.

  5. В обозревателе решений щелкните правой кнопкой мыши на Adventure Works DW и выберите пункт Развернуть или Обработка.

См. также

Задачи

Повторная установка образцов баз данных с помощью сценария

Основные понятия

Загрузка образцов баз данных Northwind и pubs

Другие ресурсы

Установка образцов
Установка образцов баз данных и примеров AdventureWorks

Журнал изменений

Версия Журнал

17 июля 2006 г.

Новое содержимое:
  • Добавлена ссылка на страницу загрузки образцов баз данных и других образцов SQL Server 2005.

5 декабря 2005 г.

Новое содержимое:
  • Добавлено примечание о SQL Server 2005 Express Edition и SQL Server 2005 Compact Edition.

Измененное содержимое
  • Исправленные ссылки на пользовательский интерфейс.


Повторная установка образцов баз данных с помощью сценария

Повторная установка образцов баз данных с помощью сценария |
 | См. также
Установка компонентов SQL Server 2005 > Установка образцов баз данных и примеров AdventureWorks >

Если после внесения изменений в образец базы данных нужно вернуться к исходной схеме, то можно переустановить эту базу данных, запустив соответствующий сценарий установки из редактора запросов среды . Сценарий установки удаляет существующий образец базы данных, заново создает объекты базы данных и заполняет таблицы.

Либо можно загрузить базу данных AdventureWorks с веб-узла для разработчиков SQL Server.

Примечание.
Эта инструкция не применяется к SQL Server 2005 Express Edition и SQL Server 2005 Compact Edition. Загрузку AdventureWorks для этих выпусков можно произвести из раздела Установка образцов баз данных для выпусков Express Edition.

Далее описывается, как переустановить базу данных AdventureWorks и хранилище данных AdventureWorksDW.

Переустановка AdventureWorks с помощью сценария

  1. На панели инструментов среды Management Studio нажмите кнопку Файл, выберите Открыть, а затем выберите пункт Файл.

  2. Выберите файл instawdb.sql и нажмите Открыть. По умолчанию этот файл расположен в папке C:\Program Files\Microsoft SQL Server\90\Tools\Samples\AdventureWorks OLTP.

  3. Перед запуском этого сценария найдите в нем инструкцию SET @data_path = @sql_path + 'AWDB\'; и укажите в нем путь до сценария instawdb.sql. Например, SET @data_path = 'C:\Program Files\Microsoft SQL Server\90\Tools\Samples\AdventureWorks OLTP\';.

  4. Запустите сценарий.

Переустановка AdventureWorksDW с помощью сценария

  1. На панели инструментов средства Management Studio нажмите кнопку Файл, выберите Открыть, а затем выберите пункт Файл.

  2. Выберите файл instawdwdb.sql и нажмите Открыть. По умолчанию этот файл расположен в папке C:\Program Files\Microsoft SQL Server\90\Tools\Samples\AdventureWorks Data Warehouse.

  3. Перед запуском этого сценария найдите в нем инструкцию SET @data_path = @sql_path + 'awdwdb\'; и укажите в нем местоположение сценария instawdwdb.sql. Например, SET @data_path = 'C:\Program Files\Microsoft SQL Server\90\Tools\Samples\AdventureWorks Data Warehouse\';.

  4. Запустите сценарий.

См. также

Основные понятия

Использование программы установки для установки образца базы данных AdventureWorks и других примеров


Загрузка образцов баз данных Northwind и pubs

Загрузка образцов баз данных Northwind и pubs |
 | См. также
Установка компонентов SQL Server 2005 > Установка образцов баз данных и примеров AdventureWorks >

Образцы базы данных Northwind и pubs в по умолчанию не устанавливаются. Эти базы данных можно установить со следующего веб-узла Майкрософт.

После загрузки SQL2000SampleDb.msi следует извлечь образцы сценариев баз данных, дважды щелкнув файл SQL2000SampleDb.msi. После чего пакет установки SQL2000SampleDb.msi извлечет сценарии баз данных и файл Readme в следующую папку по умолчанию: C:\SQL Server 2000 Sample Databases. Следуйте инструкциям, содержащимся в файле Readme, для запуска сценариев установки.

Примечание.
Сценарии создания этих баз данных больше не содержат гостевую учетную запись, что сделано с целью улучшения безопасности. Сценарий установки pubs теперь включает все данные соответствующей базы, так что запускать отдельные задания для добавления данных после создания базы pubs больше не требуется.

См. также

Задачи

Повторная установка образцов баз данных с помощью сценария

Основные понятия

Использование программы установки для установки образца базы данных AdventureWorks и других примеров

Другие ресурсы

Сравнение баз данных AdventureWorks и Northwind
Сравнение таблиц в базах данных AdventureWorks и pubs


Разделы руководства по установке компонентов SQL Server

Разделы руководства по установке компонентов SQL Server |
 | См. также
Установка компонентов SQL Server 2005 >

Подразделы в следующих разделах описывают, как устанавливать компоненты .

В этом разделе

  • Разделы руководства по установке компонента Database Engine

  • Разделы руководства по установке служб Analysis Services

  • Разделы руководства по установке служб Reporting Services

  • Разделы руководства по установке служб Notification Services

  • Разделы руководства по установке служб Integration Services

  • Установка репликации SQL Server

См. также

Задачи

Как установить SQL Server 2005 из командной строки

Справочник

Обновления версий и выпусков

Основные понятия

Подготовка к установке SQL Server 2005
Настройка контактной зоны SQL Server

Другие ресурсы

Разделы руководства по установке компонентов SQL Server
Обновление до SQL Server 2005


Разделы руководства по установке компонента Database Engine

Разделы руководства по установке компонента Database Engine |
 | См. также
Установка компонентов SQL Server 2005 > Разделы руководства по установке компонентов SQL Server >

В этом разделе рассматриваются следующие процедуры, используемые для установки, обслуживания и устранения неполадок .

В этом разделе

Подразделы по установке

  • Как установить SQL Server 2005 (программа установки)

  • Как установить SQL Server 2005 из командной строки

  • Как обновить до SQL Server 2005 (программа установки)

  • Как установить службы IIS (Microsoft)

  • Как проверить успешность установки служб SQL Server 2005

Подразделы по обслуживанию

  • Как изменить компоненты существующего экземпляра SQL Server 2005 (программа установки)

  • Как перестроить базу данных master в SQL Server 2005

  • Как перестроить реестр для SQL Server 2005

  • Как удалить существующий экземпляр SQL Server 2005 (программа установки)

Подразделы по устранению неполадок

  • Устранение неполадок при установке ядра СУБД SQL Server

  • Диагностика отказоустойчивого кластера

  • Как решить проблему неудачной проверки настройки системы COM+ в программе установки SQL Server

  • Как увеличить значение счетчика в разделе реестра для программы установки SQL Server 2005

  • Как просмотреть файлы журналов установки SQL Server 2005

См. также

Задачи

Как получить доступ к электронной документации по SQL Server 2005


Как установить SQL Server 2005 (программа установки)

Как установить SQL Server 2005 (программа установки) |
 | См. также
Установка компонентов SQL Server 2005 > Разделы руководства по установке компонентов SQL Server > Разделы руководства по установке компонента Database Engine >

Дата обновления: 5 декабря 2005 г.

Мастер установки Microsoft SQL Server 2005 построен на установщике Windows и предоставляет общее дерево компонентов для всех компонентов SQL Server 2005:

  • Database Engine

  • Analysis Services

  • Reporting Services

  • Notification Services

  • Integration Services

  • Репликация

  • Средства управления

  • Компоненты связи

  • Образцы баз данных, образцы и документация SQL Server 2005

Необязательно устанавливать каждый компонент отдельно.

Предварительные требования

Примечание.
При установке отказоустойчивого кластера не выполняйте эту процедуру. См. раздел Как создать новый отказоустойчивый кластер SQL Server 2005 (установка).

При обновлении предыдущей версии SQL Server до SQL Server 2005 не выполняйте эту процедуру. См. раздел Обновление до SQL Server 2005.

Перед установкой SQL Server 2005 изучите раздел Подготовка к установке SQL Server 2005.

Примечание.
Для локальных установок необходимо запускать программу установки с правами администратора. При установке SQL Server из удаленной общей папки необходимо использовать учетную запись домена с разрешениями на чтение и выполнение для удаленной общей папки.

Установка SQL Server 2005

  1. Чтобы начать процесс установки, вставьте DVD-диск SQL Server 2005 в дисковод для DVD-дисков. Если программа установки не запустилась автоматически, перейдите в корневой каталог DVD-диска и запустите файл splash.hta. При установке из сетевой общей папки перейдите в сетевую папку и запустите файл splash.hta.

  2. Выберите действие Запустить мастер установки SQL Server в диалоговом окне автозапуска.

  3. На странице Лицензионное соглашение прочтите лицензионное соглашение, затем установите флажок для подтверждения принятия условий соглашения. После принятия лицензионного соглашения станет доступна кнопка Далее. Чтобы продолжить, нажмите кнопку Далее. Чтобы выйти из программы установки, нажмите кнопку Отмена.

  4. На странице Обновление компонентов SQL Server программа установки устанавливает программное обеспечение, необходимое для SQL Server 2005. Чтобы получить дополнительные сведения о требованиях компонентов, нажмите кнопку Справка внизу страницы. Чтобы начать процесс обновления компонента, нажмите кнопку Установить. Чтобы продолжить работу после завершения обновления, нажмите кнопку Готово.

  5. Чтобы продолжить, нажмите кнопку Далее на странице Приветствие мастера установки SQL Server.

  6. На странице Проверка конфигурации системы производится проверка компьютера на наличие условий, которые могут препятствовать работе программы установки. Чтобы получить сведения об элементах проверки конфигурации, нажмите кнопку Справка внизу этой страницы или см. раздел Параметры для средства проверки конфигурации системы. Чтобы прервать проверку, нажмите кнопку Остановить. Чтобы отобразить список элементов проверки, сгруппированных по результату, нажмите кнопку Фильтр и выберите категорию из раскрывающегося списка. Чтобы просмотреть отчет о результатах проверки конфигурации, нажмите кнопку Отчет и выберите вариант из раскрывающегося списка. Предусмотрены возможности по просмотру отчета, сохранению отчета в файл, копированию отчета в буфер обмена и отправки отчета по электронной почте. Чтобы продолжить установку после завершения проверки конфигурации, нажмите кнопку Продолжить.

  7. На странице Регистрационные данные введите данные в текстовые поля Имя и Организация. Чтобы продолжить, нажмите кнопку Далее.

  8. На странице Устанавливаемые компоненты выберите компоненты для установки. При выборе группы компонентов ее описание отображается в области Компоненты, которые необходимо установить. Можно установить любое сочетание компонентов, используя флажки. Если при выборе SQL Server или служб Analysis Services программа установки обнаружит, что установка производится на виртуальный сервер, станет доступным флажок Установить как виртуальный сервер. Необходимо установить этот флажок для установки отказоустойчивого кластера.

    Важно!
    При установке отказоустойчивого кластера некоторые этапы установки отличаются, см. раздел Как создать новый отказоустойчивый кластер SQL Server 2005 (установка).

    Чтобы установить отдельные компоненты, нажмите кнопку Дополнительно. В противном случае нажмите кнопку Далее, чтобы продолжить.

  9. Если на предыдущей странице была нажата кнопка Дополнительно, появится страница Выбор компонентов. На странице Выбор компонентов с помощью раскрывающихся списков выберите программные компоненты для установки. Чтобы установить компоненты в определенный каталог, выберите компонент и нажмите кнопку Обзор. Чтобы получить дополнительные сведения об элементах этой страницы, нажмите кнопку Справка. Чтобы продолжить после выбора компонентов, нажмите кнопку Далее.

  10. На странице Имя экземпляра выберите для установки экземпляр по умолчанию или именованный экземпляр. Если именованный экземпляр или экземпляр по умолчанию уже установлены и для установки выбран уже существующий экземпляр, то программа установки обновляет его и предоставляет возможность установки дополнительных компонентов. Чтобы установить новый экземпляр по умолчанию, на компьютере не должен быть установлен экземпляр по умолчанию. Чтобы установить именованный экземпляр, выберите пункт Именованный экземпляр и введите уникальное имя экземпляра в соответствующем поле. Чтобы установить именованный экземпляр параллельно с существующим экземпляром, выберите пункт Именованный экземпляр и введите уникальное имя экземпляра в соответствующем поле. Чтобы получить дополнительные сведения о правилах именования экземпляров, нажмите кнопку Справка внизу страницы или см. раздел Имя экземпляра в электронной документации по SQL Server 2005.

  11. На странице Учетные записи служб укажите имя пользователя, пароль и имя домена для учетных записей служб SQL Server. Можно использовать одну учетную запись для всех служб.

    При необходимости можно определить отдельную учетную запись для каждой службы. Чтобы указать отдельную учетную запись для каждой службы, установите флажок Задать для учетной записи каждой службы, выберите имя службы из раскрывающегося списка и укажите для службы учетные данные входа. Чтобы продолжить, нажмите кнопку Далее.

    Примечание.
    Имя домена не может быть полным именем службы доменных имен (DNS). Например, если используется DNS-имя my-domain-name.com, введите my-domain-name в поле Домен. SQL Server не принимает my-domain-name.com в поле Домен.

  12. На странице Режим проверки подлинности выберите режим проверки подлинности, используемый для установки SQL Server.

    При выборе проверки подлинности Windows установка создает учетную запись sa, которая недоступна по умолчанию. Введите и подтвердите имя входа системного администратора (sa) при выборе смешанного режима проверки подлинности. При попытке взлома пароли выступают в качестве первой линии обороны, поэтому убедитесь, что введены надежные пароли, так как это необходимо для защиты системы. Никогда не указывайте пустой или простой пароль для пользователя sa. Для использования смешанного режима проверки подлинности и активации учетной записи sa после завершения установки, см. раздел «Как изменить режим проверки подлинности сервера» электронной документации по SQL Server 2005. Чтобы продолжить, нажмите кнопку Далее.

    Примечание.
    По возможности используйте проверку подлинности Windows. Не используйте пустой пароль. Выбирайте надежные пароли. Рекомендации по выбору надежного пароля см. в разделе Режим проверки подлинности.

    Примечание.
    Для этого выпуска SQL Server программа установки может не включить требование применения надежного пароля в некоторых конфигурациях Microsoft Windows Server 2003 по умолчанию, где компьютер не является членом домена. На странице Настройка параметров сортировки укажите параметры сортировки для экземпляра SQL Server. Можно использовать одну учетную запись для SQL Server и служб Analysis Services или указать параметры сортировки для отдельных компонентов.

    Чтобы установить параметры сортировки отдельно для SQL Server и служб Analysis Services, установите флажок Задать для учетной записи каждой службы. После установки флажка появится раскрывающийся список. Выберите службу из раскрывающегося списка и назначьте ей параметры сортировки. Повторите для каждой службы. Чтобы продолжить, нажмите кнопку Далее.

  13. Если в качестве устанавливаемого компонента выбраны службы Reporting Services, отобразится страница Параметры установки сервера отчетов. При помощи переключателей выберите, установить ли настройки сервера отчетов в значения по умолчанию. Если требования к установке служб Reporting Services при конфигурации по умолчанию не приемлемы, можно выбрать вариант Установить, но не настраивать сервер. Чтобы просмотреть параметры установки для это страницы, нажмите кнопку Подробности. Для получения дополнительных сведений нажмите кнопку Справка внизу страницы. Чтобы продолжить, нажмите кнопку Далее.

  14. На странице Отчет об ошибках можно снять флажок, чтобы отключить отчет об ошибках. Чтобы получить дополнительные сведения о функциях отчета об ошибках, нажмите кнопку Справка внизу страницы. Чтобы продолжить, нажмите кнопку Далее.

  15. На странице Готово к установке проверьте сводный список функций и компонентов для установки SQL Server. Чтобы продолжить, нажмите кнопку Установить.

  16. На странице Ход установки можно следить за текущим состоянием процесса установки. Чтобы просмотреть файл журнала для компонента во время установки, щелкните имя продукта или состояния на странице Ход установки.

  17. На странице Завершение работы мастера установки Microsoft SQL Server можно просмотреть сводный журнал установки, щелкнув ссылку, представленную на этой странице. Для выхода из мастера установки SQL Server нажмите кнопку Готово.

  18. Если получено указание о перезагрузке компьютера, выполните его. После завершения установки важно прочитать сообщение программы установки. Если не выполнить перезагрузку компьютера, то при запуске программы установки в будущем могут возникнуть неполадки.

Следующие шаги

По завершении программы установки SQL Server 2005 можно убедиться в успешном выполнении установки. Дополнительные сведения см. в разделе Как проверить успешность установки служб SQL Server 2005.

После завершения установки SQL Server 2005 можно выполнить дальнейшую настройку SQL Server, используя графические средства и программы командной строки. Дополнительные сведения см. в разделе Настройка установки SQL Server.

Чтобы сократить подверженную атакам контактную зону системы, SQL Server 2005 выборочно устанавливает и активирует ключевые службы и функции. В конфигурации по умолчанию для новых установок отключены многие функции. Дополнительные сведения см. в разделе Настройка контактной зоны SQL Server.

См. также

Задачи

Как обновить до SQL Server 2005 (программа установки)
Как создать новый отказоустойчивый кластер SQL Server 2005 (установка)
Как произвести обновление до отказоустойчивого кластера SQL Server 2005 (установка)

Основные понятия

Подготовка к установке SQL Server 2005
Диагностика отказоустойчивого кластера
Как просмотреть файлы журналов установки SQL Server 2005

Другие ресурсы

Как выполнить обновление до версии SQL Server 2005 с помощью мастера копирования баз данных


Как решить проблему неудачной проверки настройки системы COM+ в программе установки SQL Server

Как решить проблему неудачной проверки настройки системы COM+ в программе установки SQL Server |
 | См. также
Установка компонентов SQL Server 2005 > Разделы руководства по установке компонентов SQL Server > Разделы руководства по установке компонента Database Engine >

Microsoft Программа установки SQL Server 2005 проверяет, правильно ли настроена система COM+. При обнаружении ошибок в конфигурации установка продолжается, но в отчет о проверке конфигурации системы включается следующее предупреждение:

«В случае неудачной установки SQL Server программа установки выполнит откат изменения, но некоторые MANIFEST-файлы могут остаться. Чтобы решить эту проблему, переименуйте эти файлы и запустите программу установки заново».

Ошибки COM+ могут возникнуть, если не выполняется координатор распределенных транзакций Microsoft (MS DTC) или (в случае Microsoft Cluster Server) если MS DTC не является кластеризованным ресурсом. Система COM+ зависит от MS DTC, а задача «Очередь сообщений» в службах Integration Services зависит от COM +. Если возникнут ошибки COM+, задача «Очередь сообщений» в службах Integration Services не будет доступной, пока система COM+ не будет настроена должным образом.

Чтобы можно было использовать механизм очереди сообщений (MSMQ), убедитесь в том, что координатор распределенных транзакций Microsoft выполняется и правильно настроен. Если SQL Server установлен в кластере, координатор распределенных транзакций должен быть кластерным ресурсом.

Для переустановки системы COM+ выполните действия, указанные ниже.

Установка оснастки «Службы компонентов»

  1. На рабочем столе нажмите кнопку Пуск и выберите пункт Выполнить.

  2. В окне Открыть введите MMC и нажмите кнопку ОК.

  3. В окне консоли щелкните в главном меню пункт Консоль и выберите пункт Добавить или удалить оснастку.

  4. В окне «Добавить или удалить оснастку» нажмите кнопку Добавить.

  5. В окне «Добавить изолированную оснастку» выберите из списка оснастку Службы компонентов и нажмите кнопку Добавить.

  6. Нажмите кнопку Закрыть, чтобы закрыть окно «Добавить изолированную оснастку», после чего нажмите кнопку ОК, чтобы закрыть окно «Добавить/удалить оснастку».

  7. В окне «Корень консоли\Службы компонентов» разверните дерево Службы компонентов. Именно здесь располагаются сообщения об ошибках при возникновении проблем с системой COM+.

  8. Запустите программу установки SQL Server 2005 заново. Если появится сообщение об ошибке, переустановите систему COM+.

Переустановка системы COM+

  1. Откройте панель управления, дважды щелкните значок «Установка и удаление программ» и нажмите кнопку Установка компонентов Windows.

  2. Ничего не изменяя, просто нажмите в окне мастера компонентов Windows кнопку Далее.

  3. Доведите работу мастера до завершения, после чего запустите программу установки SQL Server 2005 заново.

См. также

Задачи

Как просмотреть файл журнала установки SQL Server 2005

Основные понятия

Устранение неполадок при установке ядра СУБД SQL Server
Как просмотреть файлы журналов установки SQL Server 2005


Как увеличить значение счетчика в разделе реестра для программы установки SQL Server 2005

Как увеличить значение счетчика в разделе реестра для программы установки SQL Server 2005 |
 | См. также
Установка компонентов SQL Server 2005 > Разделы руководства по установке компонентов SQL Server > Разделы руководства по установке компонента Database Engine >

Перед началом установки средство проверки конфигурации (SCC) установки SQL Server проверяет значение счетчика в разделе реестра. Если SCC не сможет проверить существующий раздел реестра или не сможет запустить системную программу lodctr.exe, проверка завершится ошибкой, а установка будет прервана.

Неправильное изменение реестра может вызвать серьезные проблемы. Перед внесением изменений в реестр рекомендуется создать резервную копию всех важных данных.

Увеличение значения счетчика в разделе реестра вручную

  1. В Microsoft Windows 2003 или Windows XP нажмите кнопку Пуск, выберите пункт Выполнить, введите regedit.exe в поле Открыть и нажмите кнопку ОК. В Windows 2000 введите regedit32.exe. Будет запущен редактор реестра.

  2. Перейдите к следующему разделу реестра:

    [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Perflib]

    Last Counter=dword:00000ed4 (5276)

    LastHelp=dword:00000ed5 (5277)

  3. Значение «Last Counter» предыдущего шага (5276) должно совпадать с максимальным значением раздела «Counter» из «Perflib\009» в следующем разделе реестра, а значение «Last Help» предыдущего шага (5277) должно совпадать с максимальным значением раздела «Help» из «Perflib\009» в следующем разделе реестра:

    [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Perflib\009]

    Обратите внимание, что 009 используется в английской версии операционной системы. Значения «Last Counter» и «Last Help» устанавливаются Windows динамически и на разных компьютерах они будут разными.

  4. При необходимости измените значения «Last Counter» и «Last Help» в ключе «\Perflib»: щелкните правой кнопкой мыши Last Counter или Last Help в правой части окна, выберите пункт Изменить, выберите Система исчисления = «Десятичная», введите значение в поле Значение и нажмите кнопку ОК. Если нужно, повторите эти же действия для другого ключа и закройте редактор реестра.

  5. Запустите установку SQL Server еще раз.

См. также

Основные понятия

Подготовка к установке SQL Server 2005
Как просмотреть файлы журналов установки SQL Server 2005


Как установить SQL Server 2005 из командной строки

Как установить SQL Server 2005 из командной строки |
 | См. также
Установка компонентов SQL Server 2005 > Разделы руководства по установке компонентов SQL Server > Разделы руководства по установке компонента Database Engine >

Дата обновления: 12 декабря 2006 г.

Перед установкой SQL Server 2005 ознакомьтесь с разделом Подготовка к установке SQL Server 2005. Если устанавливается отказоустойчивый кластер, дополнительно ознакомьтесь с разделом Подготовка к установке отказоустойчивого кластера.

При установке SQL Server 2005 из командной строки можно указать параметры в командной строке или воспользоваться ключом /settings для загрузки параметров из INI-файла. Параметры установки могут быть указаны либо в командной строке, либо в INI-файле, но не в обоих местах одновременно.

Чтобы указать параметры установки из INI-файла, используйте для указания INI-файла аргумент /settings filename.ini. Файл template.ini на установочном носителе SQL Server 2005 содержит подробные инструкции по созданию INI-файла. Обратите внимание на то, что первая незакомментированная строка в INI-файле должна содержать строку [Options]. Ниже приведен пример, показывающий формат INI-файла.

Копировать код
[Options]
USERNAME=MyName
COMPANYNAME=MyCompany
PIDKEY=ABCDE12345FGHIJ67890KLMNO
INSTALLSQLDIR="C:\Program Files\Microsoft SQL Server\"
INSTALLOLAPDATADIR="C:\Program Files\Microsoft SQL Server\MSSQL\OLAP\Data"
ADDLOCAL=SQL_Engine,Analysis_Server,RS_Server...
INSTANCENAME=MyInstance
...

Дополнительные сведения о параметрах установки SQL Server 2005, указываемых в INI-файле, см. в файле template.ini в корневом каталоге установочного носителя SQL Server 2005.

Примечание.
Для локальных установок необходимо запускать программу установки, обладая правами администратора. При установке SQL Server из удаленной общей папки необходимо использовать учетную запись домена с разрешениями на чтение и выполнение для удаленной общей папки. При установке отказоустойчивого кластера необходимо обладать правами администратора на локальном компьютере, а также разрешениями входить в качестве службы и работать как часть операционной системы на всех узлах виртуального сервера.

Используйте следующие образцы сценариев для установки, обновления или удаления компонентов SQL Server 2005 из командной строки. В этих сценариях, написанных с применением синтаксиса командной строки, приведены варианты для типичных случаев установки SQL Server 2005. Проверьте образцы и внесите необходимые изменения.

Образцы сценариев делятся на следующие категории.

  • Сценарии установки

  • Сценарии обслуживания

  • Сценарии удаления

Дополнительные сведения об определенных параметрах установки из командной строки см. в разделе Параметры.

Сценарии установки

Проверьте следующие сценарии установки и внесите необходимые изменения.

Установка нового изолированного экземпляра со всеми компонентами SQL Server 2005

  1. Вставьте установочный диск SQL Server 2005 в дисковод.

  2. В командной строке выполните следующую команду:

    Копировать код
    Start /wait <CD or DVD Drive>\servers\setup.exe /qb INSTANCENAME=<InstanceName> ADDLOCAL=All PIDKEY=<pidkey value with no "-"> SAPWD=<StrongPassword> SQLACCOUNT=<domain\user> SQLPASSWORD=<DomainUserPassword> AGTACCOUNT=<domain\user> AGTPASSWORD=<DomainUserPassword> SQLBROWSERACCOUNT=<domain\user> SQLBROWSERPASSWORD=<DomainUserPassword>
    Важно!
    Не используйте пустой пароль. Выбирайте надежные пароли.

    Примечание.
    Для экземпляра по умолчанию в качестве значения параметра <InstanceName> укажите «MSSQLSERVER». Для именованного экземпляра укажите имя. Рекомендации по именованию экземпляров см. в разделе Имя экземпляра.

    Важно!
    Установка с компакт-диска использует папки \servers и \tools. При установке с компакт-диска необходимо указать папку \servers или \tools в пути к файлу Setup.exe. При установке с DVD-диска требуется один диск. При установке с диска DVD не следует указывать папку \servers или \tools в пути к файлу Setup.exe.

    Ключ /qn отключает вывод всех диалоговых окон и сообщений об ошибках программы установки. Если указан ключ /qn, все сообщения программы установки, включая сообщения об ошибках, записываются в файлы журнала установки. Дополнительные сведения о файлах журналов см. в разделе «Как просмотреть файлы журналов SQL Server 2005».

    Ключ /qb включает отображение основных диалоговых окон программы установки. Также выводятся сообщения об ошибках.

Установка нового изолированного экземпляра с не зависящими от экземпляра компонентами SQL Server 2005 — службы Notification Services, службы Integration Services, компонент Full-Text Search, SQLXML и Replication

  1. Вставьте установочный диск SQL Server 2005 в дисковод.

  2. В командной строке выполните следующую команду:

    Копировать код
    Start /wait <CD or DVD Drive>\servers\setup.exe /qb ADDLOCAL=Client_components,Connectivity,SQLXML PIDKEY=<pidkey value with no "-"> SAPWD=<StrongPassword>
    Важно!
    Не используйте пустой пароль. Выбирайте надежные пароли.

    Примечание.
    Для экземпляра по умолчанию в качестве значения параметра <InstanceName> укажите «MSSQLSERVER». Для именованного экземпляра укажите имя. Рекомендации по именованию экземпляров см. в разделе Имя экземпляра.

    Важно!
    Установка с диска разделена на папки \servers и \tools. При установке с компакт-диска необходимо указать папку \servers или \tools в пути к файлу Setup.exe. При установке с DVD-диска требуется один диск. При установке с диска DVD не следует указывать папку \servers или \tools в пути к файлу Setup.exe.

    Ключ /qn отключает вывод всех диалоговых окон и сообщений об ошибках программы установки. Если указан ключ /qn, все сообщения программы установки, включая сообщения об ошибках, записываются в файлы журналов программы установки. Дополнительные сведения о файлах журналов см. в разделе Как просмотреть файлы журналов установки SQL Server 2005.

    Аргумент /qb включает отображение основных диалоговых окон программы установки. Также выводятся сообщения об ошибках.

Установка только клиентских средств SQL Server 2005

  1. Вставьте установочный диск SQL Server 2005 в дисковод.

  2. В командной строке выполните следующую команду:

    Копировать код
    Start /wait <CD or DVD Drive>\servers\setup.exe /qb INSTANCENAME=<InstanceName> ADDLOCAL=SQL_DTS,Client_Components,Connectivity,SQL_Tools90,SQL_WarehouseDevWorkbench,SQLXML,Tools_Legacy,SQL_Documentation,SQL_BooksOnline PIDKEY=<pidkey value with no "-"> SAPWD=<StrongPassword>
Важно!
Не используйте пустой пароль. Выбирайте надежные пароли.

Примечание.
Для экземпляра по умолчанию в качестве значения параметра <InstanceName> укажите «MSSQLSERVER». Для именованного экземпляра укажите имя. Рекомендации по именованию экземпляров см. в разделе Имя экземпляра.

Важно!
Установка с компакт-диска использует папки \servers и \tools. При установке с компакт-диска необходимо указать папку \servers или \tools в пути к файлу Setup.exe. При установке с DVD-диска требуется один диск. При установке с диска DVD не следует указывать папку \servers или \tools в пути к файлу Setup.exe.

Ключ /qn отключает вывод всех диалоговых окон и сообщений об ошибках программы установки. Если указан ключ /qn, все сообщения программы установки, включая сообщения об ошибках, записываются в файлы журналов программы установки. Дополнительные сведения о файлах журналов см. в разделе Как просмотреть файлы журналов установки SQL Server 2005.

Установка компонентов связи SQL Server 2005 и компонентов SQLXML

  1. Вставьте установочный диск SQL Server 2005 в дисковод.

  2. В командной строке выполните следующую команду:

    Копировать код
    Start /wait <CD or DVD Drive>\servers\setup.exe /qb ADDLOCAL=Client_Components,Connectivity,SQLXML PIDKEY=<pidkey value with no "-"> SAPWD=<StrongPassword>
Важно!
Не используйте пустой пароль. Выбирайте надежные пароли.

Примечание.
Для экземпляра по умолчанию в качестве значения параметра <InstanceName> укажите «MSSQLSERVER». Для именованного экземпляра укажите имя. Рекомендации по именованию экземпляров см. в разделе Имя экземпляра.

Важно!
Установка с диска разделена на папки \servers и \tools. При установке с компакт-диска необходимо указать папку \servers или \tools в пути к файлу Setup.exe. При установке с DVD-диска требуется один диск. При установке с диска DVD не следует указывать папку \servers или \tools в пути к файлу Setup.exe.

Ключ /qn отключает вывод всех диалоговых окон и сообщений об ошибках программы установки. Если указан ключ /qn, все сообщения программы установки, включая сообщения об ошибках, записываются в файлы журналов программы установки. Дополнительные сведения о файлах журналов см. в разделе Как просмотреть файлы журналов установки SQL Server 2005.

Обновление экземпляра SQL Server до SQL Server 2005

  1. Вставьте установочный диск SQL Server 2005 в дисковод.

  2. В командной строке выполните следующую команду:

    Копировать код
    start /wait setup.exe /qn INSTANCENAME=<Instancename> UPGRADE=SQL_Engine ADMINPASSWORD=<Strongpassword>
 SAPWD=<strongpassword> SQLACCOUNT=<domain\user> SQLPASSWORD=<domainuserpassword> AGTACCOUNT=<domain\user> AGTPASSWORD=<domainuserpassword>
SQLBROWSERACCOUNT=<domain\user> SQLBROWSERPASSWORD=<domainuserpassword>
Важно!
Не используйте пустой пароль. Выбирайте надежные пароли.

Примечание.
Для экземпляра по умолчанию в качестве значения параметра <InstanceName> укажите «MSSQLSERVER». Для именованного экземпляра укажите имя. Рекомендации по именованию экземпляров см. в разделе Имя экземпляра.

Важно!
Установка с диска разделена на папки \servers и \tools. При установке с компакт-диска необходимо указать папку \servers или \tools в пути к файлу Setup.exe. При установке с DVD-диска требуется один диск. При установке с диска DVD не следует указывать папку \servers или \tools в пути к файлу Setup.exe.

Ключ /qn отключает вывод всех диалоговых окон и сообщений об ошибках программы установки. Если указан ключ /qn, все сообщения программы установки, включая сообщения об ошибках, записываются в файлы журналов программы установки. Дополнительные сведения о файлах журналов см. в разделе Как просмотреть файлы журналов установки SQL Server 2005.

Установка нового кластеризованного экземпляра SQL Server 2005 из командной строки

  1. Вставьте установочный диск SQL Server 2005 в дисковод.

  2. Для нового отказоустойчивого кластера используйте следующий синтаксис для установки служб базы данных SQL Server и инструментальных средств управления.

    Копировать код
    Start /wait <CD or DVD Drive>\servers\setup.exe /qn VS=<VSName> INSTALLVS=SQL_Engine INSTANCENAME=<InstanceName> ADDLOCAL=SQL_Engine,Client_Components PIDKEY=<pidkey value with no "-"> ADDNODE=<NodeName1,NodeName2> GROUP=<Diskgroup> IP=<IP,Networkname> ADMINPASSWORD=<StrongPassword> SAPWD=<StrongPassord> INSTALLSQLDIR=<InstallationPath> INSTALLSQLDATADIR=<ShareDrivePath> SQLACCOUNT=<domain\user> SQLPASSWORD=<DomainUserPassword> AGTACCOUNT=<domain\user> AGTPASSWORD=<DomainUserPassword> SQLBROWSERACCOUNT=<domain\user> SQLBROWSERPASSWORD=<DomainUserPassword> SQLCLUSTERGROUP="MyDomain\MySQLDomainGroup" AGTCLUSTERGROUP="MyDomain\MyAGTDomainGroup" FTSCLUSTERGROUP="MyDomain\MyFTSDomainGroup" ERRORREPORTING=1, SQMREPORTING=1 SQLCOLLATION=SQL_Latin1_General_CP1_CI_AS
    Важно!
    Не используйте пустой пароль. Выбирайте надежные пароли.

    Ключ /qn отключает вывод всех диалоговых окон и сообщений об ошибках программы установки. Если указан ключ /qn, все сообщения программы установки, включая сообщения об ошибках, записываются в файлы журналов программы установки. Дополнительные сведения о файлах журналов см. в разделе Как просмотреть файлы журналов установки SQL Server 2005.

    Ключ /qb включает отображение основных диалоговых окон программы установки. Также выводятся сообщения об ошибках.

Обновление отказоустойчивого кластера SQL Server до SQL Server 2005

  1. Вставьте установочный диск SQL Server 2005 в дисковод.

  2. В командной строке выполните следующую команду:

    Копировать код
    start /wait setup.exe /qn VS=<VSNAME> INSTALLVS=SQL_Engine INSTANCENAME=<Instancename> UPGRADE=SQL_Engine
ADDNODE=<NodeName1,NodeName2> GROUP=<Diskgroup> ADMINPASSWORD=<Strongpassword> SAPWD=<strongpassword>
SQLACCOUNT=<domain\user> SQLPASSWORD=<domainuserpassword> AGTACCOUNT=<domain\user> AGTPASSWORD=<domainuserpassword>
SQLBROWSERACCOUNT=<domain\user> SQLBROWSERPASSWORD=<domainuserpassword>
 SQLCLUSTERGROUP="MYDOMIAN\MYSQLDOMAINGROUP" AGTCLUSTERGROUP="MYDOMIAN\MYAGTDOMAINGROUP"
FTSCLUSTERGROUP="MYDOMIAN\MYFTSDOMAINGROUP"
Важно!
Не используйте пустой пароль. Выбирайте надежные пароли.

Примечание.
Для экземпляра по умолчанию в качестве значения параметра <InstanceName> укажите «MSSQLSERVER». Для именованного экземпляра укажите имя. Сведения о правилах именования экземпляров см. в разделе Имя экземпляра.

Важно!
Установка с компакт-диска делится между папками \servers и \tools. При установке с компакт-диска необходимо указать папку \servers или \tools в пути к файлу Setup.exe. При установке с DVD-диска требуется один диск. При установке с диска DVD не следует указывать папку \servers или \tools в пути к файлу Setup.exe.

Ключ /qn отключает вывод всех диалоговых окон и сообщений об ошибках программы установки. Если указан ключ /qn, все сообщения программы установки, включая сообщения об ошибках, записываются в файлы журналов программы установки. Дополнительные сведения о файлах журналов см. в разделе Как просмотреть файлы журналов установки SQL Server 2005.

Вернуться в начало.

Сценарии обслуживания

Проверьте следующие сценарии обслуживания и внесите необходимые изменения.

Добавление компонентов к существующему автономному экземпляру SQL Server 2005 из командной строки

  1. Вставьте установочный диск SQL Server 2005 в дисковод.

  2. Чтобы добавить возможность полнотекстового поиска и удалить возможность репликации, используйте следующий синтаксис.

    Копировать код
    Start /wait <CD or DVD Drive>setup.exe /qb INSTANCENAME=<InstanceName> ADDLOCAL=SQL_FullText REMOVE=SQL_Replication

    Для экземпляра по умолчанию в качестве значения параметра <InstanceName> укажите «MSSQLSERVER». Полный список параметров см. ниже в разделе Параметры.

Добавление компонентов к существующему кластеру SQL Server 2005 из командной строки

  1. Вставьте установочный диск SQL Server 2005 в дисковод.

  2. Чтобы добавить службы Analysis Services в существующий кластер, используйте следующий синтаксис.

    Копировать код
    start /wait <CD or DVD Drive>\setup.exe /qn VS=<VSName> INSTALLVS=Analysis_Server INSTANCENAME=<InstanceName> ADDLOCAL=Analysis_Server ADDNODE=n GROUP=<NotSQLDiskGroup> IP=<IP,Networkname> ADMINPASSWORD=<StrongPassword> SAPWD=<StrongPassword> INSTALLSQLDIR=<InstallationPath> INSTALLSQLDATADIR=<ShareDrivePath> ASACCOUNT=<domain\user> ASPASSWORD=<DomainUserPassword> SQLBROWSERACCOUNT=<domain\user> SQLBROWSERPASSWORD=<DomainUserPassword> SQLREPORTING=1
Примечание.
Необходимо использовать различные кластерные группы для установки служб Analysis Services и компонента Database Engine. Необходимо установить службы Analysis Services в отдельную кластерную группу, а затем, после установки, можно переместить службы Analysis Services в группу с SQL Server.

Полный список параметров см. ниже в разделе Параметры.

Добавление узлов к существующему кластеру SQL Server 2005 из командной строки

  1. Вставьте установочный диск SQL Server 2005 в дисковод.

  2. Используйте следующий синтаксис.

    Копировать код
    start /wait <CD or DVD Drive>\setup.exe /qn VS=<VSName> INSTALLVS=SQL_Engine INSTANCENAME=<InstanceName> ADMINPASSWORD=<StrongPassword> ADDNODE=<NodeName>
    Важно!
    Не используйте пустой пароль. Выбирайте надежные пароли.

    Для экземпляра по умолчанию в качестве значения параметра <InstanceName> укажите «MSSQLSERVER».

    Ключ /qn отключает вывод всех диалоговых окон и сообщений об ошибках программы установки. Если указан аргумент /qn, все сообщения программы установки, включая сообщения об ошибках, записываются в файлы журналов программы установки. Дополнительные сведения о файлах журналов см. в разделе Как просмотреть файлы журналов установки SQL Server 2005. Ключ /qb включает отображение основных диалоговых окон программы установки. Также выводятся сообщения об ошибках.

Удаление узлов из существующего кластера SQL Server 2005 из командной строки

  1. Вставьте установочный диск SQL Server 2005 в дисковод.

  2. Используйте следующий синтаксис.

    Копировать код
    start /wait <CD or DVD Drive>\setup.exe /qn VS=<VSName> INSTALLVS=SQL_Engine INSTANCENAME=<InstanceName> ADMINPASSWORD=<StrongPassword> REMOVENODE=<NodeName>
    Важно!
    Не используйте пустой пароль. Выбирайте надежные пароли.

    Для экземпляра по умолчанию в качестве значения параметра <InstanceName> укажите «MSSQLSERVER».

    Ключ /qn отключает вывод всех диалоговых окон и сообщений об ошибках программы установки. Если указан аргумент /qn, все сообщения программы установки, включая сообщения об ошибках, записываются в файлы журналов программы установки. Дополнительные сведения о файлах журналов см. в разделе Как просмотреть файлы журналов установки SQL Server 2005. Ключ /qb включает отображение основных диалоговых окон программы установки. Также выводятся сообщения об ошибках.

    Внимание!
    Если Microsoft SQL Server 2000 и Microsoft SQL Server 2005 установлены вместе в кластеризованной среде, то при удалении SQL Server 2005 не надо удалять собственного клиента Microsoft SQL. Динамическая библиотека ресурсов SQL Server из SQL Server 2005 всегда использует собственного клиента SQL для подключения к SQL Server. При установке SQL Server 2005 обновляется динамическая библиотека ресурсов кластера SQL Server. При установке SQL Server 2005 динамическая библиотека ресурсов SQL Server не заменяется версией, требуемой для SQL Server 2000. Сохранение собственного клиента SQL на узлах кластеров позволяет динамической библиотеке ресурсов SQL Server и далее подключаться к экземплярам SQL Server 2000.

Перестроение системной базы данных и реестра

Свойство REINSTALLMODE применяется для восстановления установленных компонентов SQL Server 2005. Дополнительные сведения об использовании REINSTALLMODE см. в приводимых далее разделах [REINSTALLMODE] и [REBUILDDATABASE].

Перестроение системных баз данных для экземпляра SQL Server 2005 по умолчанию из командной строки

  1. Вставьте установочный диск SQL Server 2005 в дисковод.

  2. Используйте следующий синтаксис.

    Копировать код
    start /wait <CD or DVD Drive>\setup.exe /qn INSTANCENAME=<InstanceName> REINSTALL=SQL_Engine REBUILDDATABASE=1 SAPWD=<NewStrongPassword>
    Важно!
    Не используйте пустой пароль. Выбирайте надежные пароли.

    Для экземпляра по умолчанию в качестве значения параметра <InstanceName> укажите «MSSQLSERVER».

    Внимание! База данных resource (mssqlsystemresource) восстанавливается с установочного носителя SQL Server 2005. После перестроения базы данных resource с установочного носителя необходимо переустановить все пакеты обновления и обновления QFE. Прежде чем продолжить выполнение, см. дополнительные сведения в разделе [REBUILDDATABASE].

    Ключ /qn отключает вывод всех диалоговых окон и сообщений об ошибках программы установки. Если указан ключ /qn, все сообщения программы установки, включая сообщения об ошибках, записываются в файлы журналов программы установки. Дополнительные сведения о файлах журналов см. в разделе Как просмотреть файлы журналов установки SQL Server 2005. Ключ /qb включает отображение основных диалоговых окон программы установки. Также выводятся сообщения об ошибках.

    При перестроении базы данных master все системные базы данных устанавливаются в исходные местоположения. Если одна или несколько системных баз данных были перемещены в другие местоположения, необходимо вернуть их в исходные. Дополнительные сведения о перемещении системных баз данных см. в разделе Перемещение системных баз данных.

Перестроение системных баз данных для кластеризованного экземпляра SQL Server 2005 из командной строки

  1. Вставьте установочный диск SQL Server 2005 в дисковод.

  2. Используйте следующий синтаксис.

    Копировать код
    start /wait <CD or DVD Drive>\setup.exe /qn VS=<VSName> INSTANCENAME=<InstanceName> REINSTALL=SQL_Engine REBUILDDATABASE=1 ADMINPASSWORD=<StrongPassword> SAPWD=<NewStrongPassword> SQLCOLLATION=<NewSystemCollation> SQLACCOUNT=<domain\user> SQLPASSWORD=<DomainUserPassword> AGTACCOUNT=<domain\user> AGTPASSWORD=<DomainUserPassword>
    Важно!
    Не используйте пустой пароль. Выбирайте надежные пароли.

    Для экземпляра по умолчанию в качестве значения параметра <InstanceName> укажите «MSSQLSERVER».

    Внимание! База данных resource (mssqlsystemresource) восстанавливается с установочного носителя SQL Server 2005. После перестроения базы данных resource с установочного носителя необходимо переустановить все пакеты обновления и обновления QFE. Прежде чем продолжить выполнение, ознакомьтесь с дополнительными сведениями в разделе [REBUILDDATABASE].

    Ключ /qn отключает вывод всех диалоговых окон и сообщений об ошибках программы установки. Если указан ключ /qn, все сообщения программы установки, включая сообщения об ошибках, записываются в файлы журналов программы установки. Дополнительные сведения о файлах журналов см. в разделе Как просмотреть файлы журналов установки SQL Server 2005. Ключ /qb включает отображение основных диалоговых окон программы установки. Также выводятся сообщения об ошибках.

    При перестроении базы данных master все системные базы данных устанавливаются в исходные местоположения. Если одна или несколько системных баз данных были перемещены в другие местоположения, необходимо вернуть их в исходные. Дополнительные сведения о перемещении системных баз данных см. в разделе Перемещение системных баз данных.

Задание новых системных параметров сортировки

Параметры сортировки, в которые входит кодировка, порядок сортировки и другие языковые настройки, являются основными для структур и функций всех баз данных SQL Server. Необходимо стандартизовать данные параметры внутри организации и применять их во время каждой установки. Многие межсерверные операции могут закончиться сбоем, если между серверами не согласованы параметры сортировки.

Используйте правильные настройки параметров сортировки при установке SQL Server 2005. Настройки параметров сортировки можно изменить после установки, однако после такого изменения необходимо перестроить системные и пользовательские базы данных, а также заново загрузить пользовательские данные.

Чтобы изменить настройки параметров сортировки для существующего экземпляра SQL Server 2005, необходимо использовать автоматическую установку для перестроения системных баз данных. Данная функция активируется с помощью специального ключа, вызываемого командой REBUILDDATABASE=1. При перестроении системных баз данных происходит удаление всех данных и объектов в системных базах данных master, model и msdb. При перестроении базы данных master все системные базы данных устанавливаются в исходные местоположения. Если одна или несколько системных баз данных были перемещены в другие местоположения, необходимо вернуть их в исходные. Дополнительные сведения о перемещении системных баз данных см. в разделе Перемещение системных баз данных.

Нужно указать параметр /qb или /qn. Параметр /qb включает отображение основных диалоговых окон пользовательского интерфейса и сообщений об ошибках программы установки. Если указан параметр /qn, все диалоговые окна установки, включая сообщения об ошибках, записываются в файлы журналов программы установки.

Важно!
Чтобы перестроить системные базы данных, НЕОБХОДИМО ввести новый пароль системного администратора (sa). Не используйте пустой пароль. Выбирайте надежные пароли.

Перестроение системных баз данных и задание новых системных параметров сортировки

  1. Вставьте установочный диск SQL Server 2005 в дисковод.

  2. В командной строке выполните следующую команду.

    Копировать код
    start /wait <CD or DVD Drive>\setup.exe /qn INSTANCENAME=MSSQLSERVER REINSTALL=SQL_Engine REBUILDDATABASE=1 SAPWD=<NewStrongPassword> SQLCOLLATION=<NewSystemCollation>

    Для экземпляра по умолчанию в качестве значения параметра INSTANCENAME укажите MSSQLSERVER. Для именованного экземпляра укажите имя.

    Важно!
    База данных resource (mssqlsystemresource) восстанавливается из установочного носителя SQL Server 2005. После перестроения базы данных resource с установочного носителя все исправления и обновления теряются и поэтому должны быть применены заново. Прежде чем продолжить выполнение, ознакомьтесь с дополнительными сведениями в разделе [REBUILDDATABASE].

    Ключ /qn отключает вывод всех диалоговых окон и сообщений об ошибках программы установки. Если указан ключ /qn, все сообщения программы установки, включая сообщения об ошибках, записываются в файлы журналов программы установки. Дополнительные сведения о файлах журналов см. в разделе Как просмотреть файлы журналов установки SQL Server 2005. Ключ /qb включает отображение основных диалоговых окон программы установки. Также выводятся сообщения об ошибках.

    При перестроении базы данных master все системные базы данных устанавливаются в исходные местоположения. Если одна или несколько системных баз данных были перемещены в другие местоположения, необходимо вернуть их в исходные. Дополнительные сведения о перемещении системных баз данных см. в разделе Перемещение системных баз данных.

Перестроение реестра

Чтобы перестроить реестр SQL Server 2005, необходимо использовать команду Setup со следующими параметрами: REINSTALL=ALL и REINSTALLMODE=omus. Выполнение файла Setup.exe с указанными параметрами приведет к перестроению, проверке и восстановлению экземпляра SQL Server, а также перестроению реестра. Данная процедура обычно используется для перестроения реестра поврежденной установки SQL Server.

Примечание.
Чтобы перестроить реестр, необходимо использовать тот же пакетный файл и те же параметры, которые были указаны при начальной установке. Если эти сведения недоступны, вместо перестроения реестра рекомендуется переустановить SQL Server.

Нужно указать параметр /qb или /qn. Параметр /qb включает отображение основных диалоговых окон пользовательского интерфейса и сообщений об ошибках программы установки. Если указан параметр /qn, все диалоговые окна установки, включая сообщения об ошибках, записываются в файлы журналов программы установки.

Важно!
Чтобы перестроить системные базы данных, НЕОБХОДИМО ввести новый пароль sa. Не используйте пустой пароль. Выбирайте надежные пароли.

Восстановление всех файлов, перестроение реестра и удаление всех ярлыков SQL Server из командной строки

  1. Вставьте установочный диск SQL Server 2005 в дисковод.

  2. В командной строке выполните следующую команду:

    Копировать код
    start /wait <CD or DVD Drive>\setup.exe /qb INSTANCENAME=MSSQLSERVER REINSTALL=ALL REBUILDDATABASE=1 REINSTALLMODE=omus SAPWD=<NewStrongPassword>

    Для экземпляра по умолчанию в качестве значения параметра INSTANCENAME укажите MSSQLSERVER. Для именованного экземпляра укажите имя.

    Важно!
    База данных resource (mssqlsystemresource) восстанавливается из установочного носителя SQL Server 2005. После перестроения базы данных resource с установочного носителя необходимо переустановить все пакеты обновления и обновления QFE. Прежде чем продолжать выполнение, ознакомьтесь с дополнительными сведениями в разделе [REBUILDDATABASE].

Восстановление ярлыков среды SQL Server Management Studio из командной строки

  1. Вставьте установочный диск SQL Server 2005 в дисковод.

  2. В командной строке выполните следующую команду.

    Копировать код
    start /wait <CD or DVD Drive>\setup.exe /qb REINSTALL=SQL_Tools90 REINSTALLMODE=S

    Для экземпляра по умолчанию в качестве значения параметра INSTANCENAME укажите MSSQLSERVER. Для именованного экземпляра укажите имя.

Восстановление разделов реестра средства полнотекстового поиска из командной строки

  1. Вставьте установочный диск SQL Server 2005 в дисковод.

  2. В командной строке выполните следующую команду.

    Копировать код
    start /wait <CD or DVD Drive>\setup.exe /qb REINSTALL=SQL_FullText INSTANCENAME=MSSQLSERVER REINSTALLMODE=M

    Для экземпляра по умолчанию в качестве значения параметра INSTANCENAME укажите MSSQLSERVER. Для именованного экземпляра укажите имя.

Вернуться в начало.

Сценарии удаления

Проверьте следующие сценарии удаления и внесите необходимые изменения.

Если на компьютере запущен сервер SQL Server 2005 вместе с предыдущими версиями SQL Server, то программа Enterprise Manager и другие программы, зависящие от объектов SQL-DMO, могут быть отключены. Это может произойти в следующих ситуациях:

  • параллельная установка SQL Server 2005, SQL Server 2000 или SQL Server 7.0, при которой одна из версий была удалена;

  • параллельная установка SQL Server 2000 с SQL Server 2005, при которой SQL Server 2000 был установлен после SQL Server 2005.

Эта проблема связана с удалением регистрации COM-библиотеки SQL Server 2005 SQL-DMO. Чтобы вновь включить программу Enterprise Manager и другие программы, зависящие от SQL-DMO, следует повторно зарегистрировать SQL-DMO, выполнив из командной строки следующую команду: regsvr32.exe sqldmo.dll. Дополнительные сведения см. в разделе Устранение неполадок при установке ядра СУБД SQL Server.

Удаление из командной строки установленного по умолчанию изолированного экземпляра SQL Server 2005

  1. Вставьте установочный диск SQL Server 2005 в дисковод.

  2. Удалите SQL Server с использованием следующего синтаксиса.

    Копировать код
    Start /wait <CD or DVD Drive>\setup.exe /qb REMOVE=SQL_Engine,Client_Components INSTANCENAME=<InstanceName>

    Для экземпляра по умолчанию в качестве значения параметра <InstanceName> укажите «MSSQLSERVER». При использовании REMOVE=ALL для удаления компонентов экземпляра также удаляются общие компоненты: инструментальные средства сервера SQL Server, службы Integration Services и службы Notification Services.

  3. Удалите собственный клиент Microsoft SQL с помощью следующего синтаксиса.

    Копировать код
    Start /wait C:\Windows\System32\msiexec /qb /X <CD or DVD Drive>\setup\sqlncli.msi

  4. Удалите Microsoft .NET Framework с помощью следующего синтаксиса.

    Копировать код
    Start /wait <CD or DVD Drive>\redist\2.0\dotnetfix.exe /q:a /c:"install /qu"
    Внимание!
    Удаление .NET Framework 1.1 или 2.0 воздействует на существующие установки среды Microsoft Visual Studio, так как Visual Studio зависит от Microsoft .NET Framework. Если среда Visual Studio установлена, не удаляйте .NET Framework.

Удаление из командной строки установленного по умолчанию кластеризованного экземпляра SQL Server 2005

  1. Вставьте установочный диск SQL Server 2005 в дисковод.

  2. Удалите SQL Server с помощью следующего синтаксиса.

    Копировать код
    start /wait <CD or DVD Drive>\setup.exe /qn VS=<VSName> INSTANCENAME=<InstanceName> REMOVE=SQL_Engine ADMINPASSWORD=<StrongPassword>

    Для экземпляра по умолчанию в качестве значения параметра <InstanceName> укажите «MSSQLSERVER».

    Аргумент /qn отключает вывод всех диалоговых окон и сообщений об ошибках программы установки. Если указан аргумент /qn, все сообщения программы установки, включая сообщения об ошибках, записываются в файлы журналов программы установки. Дополнительные сведения о файлах журналов см. в разделе Как просмотреть файлы журналов установки SQL Server 2005. Аргумент /qb включает отображение основных диалоговых окон программы установки. Также выводятся сообщения об ошибках.

  3. Удалите собственного клиента SQL с помощью следующего синтаксиса.

    Копировать код
    Start /wait <CD or DVD Drive>\msiexec /qb /X <CD or DVD Drive>\setup\sqlncli.msi

    Если программе установки SQL Server не удалось удалить узел кластера, выполните следующие действия.

  4. Запустите программу редактора реестра (regedit.exe), найдите раздел реестра HLKM\Software\Microsoft\Microsoft SQL Server\<instid>\Setup, в котором <instid> обозначает удаляемый экземпляр SQL Server; например MSSQL.1 для первого экземпляра и MSSQL.2 для второго экземпляра.

    Внимание!
    Неправильное редактирование реестра может вызвать серьезные проблемы, которые могут быть исправлены только путем переустановки ОС. Корпорация Майкрософт не гарантирует, что проблемы, возникшие вследствие некорректного редактирования реестра, могут быть разрешены. Перед редактированием реестра создайте резервные копии всех необходимых данных. Дополнительные сведения о создании резервных копий, восстановлении и редактировании реестра см. в статье базы знаний Майкрософт.

  5. В этом разделе реестра укажите SqlCluster=2.

  6. Чтобы обновить раздел SqlCluster на всех узлах кластера, повторите 2 предыдущих шага.

  7. Поместите общий диск в компьютер, на котором производится удаление, и удалите на этом узле SQL Server 2005 с помощью раздела Установка и удаление программ.

  8. Поместите общий диск в следующий узел и удалите SQL Server 2005 с помощью раздела Установка и удаление программ.

  9. Повторите данный процесс для всех оставшихся узлов.

    Если SQL Server 2005 работает вместе с предыдущими версиями SQL Server, могут быть отключены предыдущие версии программы Enterprise Manager или других программ, зависящих от SQL-DMO. Это может произойти в следующих ситуациях:

    • Параллельная установка SQL Server 2005, SQL Server 2000 или SQL Server 7.0, при которой какая-либо из версий удаляется.

    • параллельная установка SQL Server 2000 с SQL Server 2005, при которой SQL Server 2000 был установлен после SQL Server 2005.

    Эта проблема связана с удалением регистрации COM-библиотеки SQL Server 2005 SQL-DMO. Чтобы восстановить работу программы Enterprise Manager и других программ, зависящих от SQL-DMO, выполните повторную регистрацию SQL-DMO с помощью следующей команды: regsvr32.exe sqldmo.dll. Дополнительные сведения см. в разделе Устранение неполадок при установке ядра СУБД SQL Server.

    Если SQL Server 2000 и SQL Server 2005 были параллельно установлены в кластеризованной среде, при удалении SQL Server 2005 нет необходимости удалять собственный клиент Microsoft SQL. Динамическая библиотека ресурсов SQL Server из SQL Server 2005 всегда использует собственный клиент SQL для подключения к SQL Server. При установке SQL Server 2005 обновляется динамическая библиотека ресурсов кластера SQL Server. При удалении SQL Server 2005 динамическая библиотека ресурсов SQL Server не заменяется версией, требуемой для SQL Server 2000. Сохранение собственного клиента SQL на узлах кластера позволяет динамической библиотеке ресурсов SQL Server и далее подключаться к экземплярам SQL Server 2000.

Начало установки SQL Server 2005 из командной строки с использованием INI-файла

  1. Из командной строки выполните Setup.exe.

    Пример команды для установки, ссылающейся на INI-файл, может выглядеть следующим образом:

    Копировать код
                        <CD or DVD Drive>\Setup.exe /settings C:/set.ini /qn

    , где команда Setup.exe должна сопровождаться аргументом /settings, указывающим имя INI-файла, в котором содержатся параметры установки. Далее должен следовать аргумент /qn, который отключает пользовательский интерфейс. В этом примере файл C:\set.ini является текстовым файлом, содержащим параметры установки.

    Если указан параметр /qn, все сообщения программы установки, включая сообщения об ошибках, записываются в файлы журналов программы установки. Дополнительные сведения о параметрах INI-файла см. в материалах, представленных после этого раздела. Дополнительные сведения о расположении файлов журналов программы установки см. в разделе Как просмотреть файлы журналов установки SQL Server 2005.

Вернуться в начало.

Параметры

Для разработки сценариев установки из командной строки можно применять параметры, приведенные в следующей таблице.

[Options] | [PIDKEY] | [INSTALLSQLDIR]
[INSTALLSQLSHAREDDIR] | [INSTALLSQLDATADIR] | [INSTALLASDATADIR]
[ADDLOCAL] | [REMOVE] | [INSTANCENAME]
[UPGRADE] | [SAVESYSDB] | [USESYSDB]
[SQLACCOUNT], [SQLPASSWORD], [AGTACCOUNT], [AGTPASSWORD], [ASACCOUNT], [ASPASSWORD], [RSACCOUNT] и [RSPASSWORD] | [AUTOSTART] | [SECURITYMODE] и [SAPWD]
[SQLCOLLATION] и [ASCOLLATION] | [REBUILDDATABASE] | [REINSTALLMODE]
[RSCONFIGURATION] | [SAMPLEDATABASESERVER] | [DISABLENETWORKPROTOCOLS]
[ERRORREPORTING] | [SKUUPGRADE] |

Дополнительные сведения о каждом параметре см. в описании параметров, приведенном ниже.

Сведения об установке в кластере из командной строки см. в разделе Параметры, необходимые для установки в кластере.

Вернуться в начало.

[Options]

НЕОБХОДИМО, чтобы ini-файл содержал строку [Options]. Эти сведения используются в диалоговом окне Регистрационные сведения.

По умолчанию. Если эти параметры не указаны, на сервере используются имя пользователя и название компании по умолчанию.

Примечание.
Если имя или название содержит пробелы, необходимо заключать его в кавычки.

Копировать код
USERNAME=
COMPANYNAME=

[PIDKEY]

Для промежуточных выпусков SQL Server 2005 в свойстве PIDKEY нет необходимости, так как параметр для файла MSI уже задан. Однако окончательная версия SQL Server 2005 требует указания параметра PIDKEY.

Использование: PIDKEY=ABCDE12345FGHIJ67890KLMNO.

Примечание.
Указанное значение не является реальным значением ключа.

Примечания

  • Параметр PIDKEY не может быть использован для установки выпуска SQL Server Express.

  • Не включайте символ «-» в значение параметра PIDKEY.

Копировать код
PIDKEY=

[INSTALLSQLDIR]

Эти сведения используются в диалоговом окне Выбор компонентов. Чтобы использовать пути по умолчанию, не указывайте данный параметр.

Примечание.
Если идентификатор пути содержит пробелы, необходимо заключать его в кавычки, а в конец каждого пути необходимо добавить обратную косую черту (\).

Использование: параметр INSTALLSQLDIR указывает расположение двоичных файлов экземпляра. Расположение по умолчанию: \Program Files\Microsoft SQL Server\.

Важно!
Параметр INSTALLSQLDIR НЕОБХОДИМ для кластеризованной установки и должен указывать локальный диск, для которого на всех узлах определения кластера существует буква.

Копировать код
INSTALLSQLDIR=

Дополнительные сведения о каталогах установки см. в разделе Расположение файлов для экземпляра по умолчанию и именованных экземпляров SQL Server 2005.

[INSTALLSQLSHAREDDIR]

Параметр INSTALLSQLSHAREDDIR указывает расположение для компонентов служб Integration Services, служб Notification Services и рабочей станции. В образце Setup.exe <options> INSTALLSQLSHAREDDIR="<InstallDir>" могут использоваться следующие пути установки:

  • <каталог установки>\90\DTS\;

  • <каталог установки>\90\DTS\;

  • <каталог установки>\90\DTS\.

Копировать код
INSTALLSQLSHAREDDIR=

Дополнительные сведения о каталогах установки см. в разделе Расположение файлов для экземпляра по умолчанию и именованных экземпляров SQL Server 2005.

[INSTALLSQLDATADIR]

Параметр INSTALLSQLDATADIR указывает расположение файлов данных SQL Server. Расположение по умолчанию определяется параметром INSTALLSQLDIR.

Важно!
Параметр INSTALLSQLDATADIR НЕОБХОДИМ для кластеризованной установки и должен указывать общий диск, являющийся членом группы кластера, указанной для установки.

Копировать код
INSTALLSQLDATADIR=

Дополнительные сведения о каталогах установки см. в разделе Расположение файлов для экземпляра по умолчанию и именованных экземпляров SQL Server 2005.

[INSTALLASDATADIR]

Использование: параметр INSTALLASDATADIR указывает расположение файлов данных служб Analysis Services. Расположение по умолчанию: INSTALLSQLDIR\Data\.

Примечание.
Этот параметр не может быть использован для установки выпуска SQL Server Express.

Если установка служб Analysis Services уже выполнена, данный параметр не учитывается.

Копировать код
INSTALLASDATADIR=

Дополнительные сведения о каталогах установки см. в разделе Расположение файлов для экземпляра по умолчанию и именованных экземпляров SQL Server 2005.

[ADDLOCAL]

Использование: параметр ADDLOCAL указывает, какие компоненты необходимо установить. Если значение параметра ADDLOCAL не указано, программа установки завершается сбоем.

Чтобы установить все компоненты, в командной строке укажите «ADDLOCAL=All».

Правила применения параметра ADDLOCAL следующие.

  • В именах функций учитывается регистр символов.

  • Чтобы применить параметр ADDLOCAL, необходимо ввести перечень устанавливаемых компонентов, разделяя их запятыми. Например, чтобы установить все, за исключением компонентов служб Analysis Services и служб Reporting Services, необходимо ввести следующий список.

    • ADDLOCAL=SQL_Engine,SQL_Data_Files,SQL_FullText,Notification_Services,NS_Engine,NS_Client,SQL_DTS,Client_Components,Connectivity,SQL_Tools90,SDK,SQL_Documentation,SQL_BooksOnline,SQL_Samples,SQL_AdventureWorksSamples,SQL_AdventureWorksDWSamples,SQL_AnalysisServiceSamples,SQL_Samples

  • Если выбрать только родительскую возможность, будет установлена только эта возможность, а не ее дочерние возможности. При установке дочерней возможности родительская возможность устанавливается автоматически. При удалении родительской функции ее дочерние возможности удаляются автоматически.

  • Также можно применять параметр ADDLOCAL для добавления компонентов в режиме обслуживания. Например, чтобы добавить компонент служб Analysis Services после установки, приведенной выше, необходимо указать следующее.

    • ADDLOCAL=Analysis_Server,AnalysisDataFiles,AnalysisSharedTools,Client_Components,Connectivity

В следующей таблице показаны родительские и дочерние возможности и их требования к параметру ADDLOCAL для установки версий X86, IA64 и AMD64 выпусков SQL Server 2005 Enterprise Edition, Developer Edition, Evaluation Edition и Standard Edition.

Возможность SQL Server 2005 | Название родительской возможности | Название дочерней возможности
Службы SQL Server Database Services | SQL_Engine |
Файлы данных SQL Server |  | SQL_Data_Files
Репликация |  | SQL_Replication
Средство полнотекстового поиска |  | SQL_FullText
Службы Analysis Services | Analysis_Server |
Файлы данных служб Analysis Services |  | AnalysisDataFiles
Службы Reporting Services | RS_Server |
Диспетчер отчетов |  | RS_Web_Interface
Notification Services | Notification_Services |
Компоненты обработчика служб Notification Services |  | NS_Engine
Клиентские компоненты служб Notification Services |  | NS_Client
Integration Services |  | SQL_DTS
Клиентские компоненты | Client_Components |
Компоненты связи |  | Возможность подключения
Средства управления |  | SQL_Tools90
Business Intelligence Development Studio |  | SQL_WarehouseDevWorkbench
Набор средств разработки программного обеспечения |  | Пакет SDK
Клиентские функции SQLXML |  | SQLXML
Компоненты прежних версий: среда выполнения служб DTS 2000 и объекты DMO |  | Tools_Legacy
Документация и примеры |  | SQL_Documentation
Электронная документация по SQL Server |  | SQL_BooksOnline
Образцы баз данных |  | SQL_DatabaseSamples
Образец OLTP базы данных AdventureWorks |  | SQL_AdventureWorksSamples
Образец хранилища данных AdventureWorks |  | SQL_AdventureWorksDWSamples
Образец OLAP базы данных AdventureWorks |  | SQL_AdventureWorksASSamples
Образцы |  | SQL_Samples
Копировать код
ADDLOCAL=

В следующей таблице показаны связи между родительскими и дочерними возможностями и их требования к параметру ADDLOCAL для установки версий X86, IA64 и AMD64 сервера SQL Server 2005 Workgroup Edition.

Компонент SQL Server 2005 Workgroup | Название родительской возможности | Название дочерней возможности
Службы SQL Server Database Services | SQL_Engine |
Файлы данных SQL Server |  | SQL_Data_Files
Репликация |  | SQL_Replication
Средство полнотекстового поиска |  | SQL_FullText
Integration Services |  | SQL_DTS
Клиентские компоненты | Client_Components |
Компоненты связи |  | Возможность подключения
Средства управления |  | SQL_Tools90
Набор средств разработки программного обеспечения |  | Пакет SDK
Клиентские функции SQLXML |  | SQLXML
Компоненты прежних версий: среда выполнения служб DTS 2000 и объекты DMO |  | Tools_Legacy
Документация и примеры |  | SQL_Documentation
Электронная документация по SQL Server |  | SQL_BooksOnline
Образцы баз данных |  | SQL_DatabaseSamples
Образец OLTP базы данных AdventureWorks |  | SQL_AdventureWorksSamples
Образец хранилища данных AdventureWorks |  | SQL_AdventureWorksDWSamples
Образец OLAP базы данных AdventureWorks |  | SQL_AdventureWorksASSamples
Образцы |  | SQL_Samples
Копировать код
ADDLOCAL=

В следующей таблице показаны связи между родительскими и дочерними возможностями и их требования к параметру ADDLOCAL для установки версий X86, IA64 и AMD64 SQL Server 2005 Express Edition.

Возможность выпуска SQL Server 2005 Express | Название родительской возможности | Название дочерней возможности
Службы SQL Server Database Services | SQL_Engine |
Файлы данных SQL Server |  | SQL_Data_Files
Репликация |  | SQL_Replication
Клиентские компоненты | Client_Components |
Компоненты связи |  | Связь
Набор средств разработки программного обеспечения |  | Пакет SDK
Копировать код
ADDLOCAL=

[REMOVE]

Параметр REMOVE указывает компоненты, которые необходимо удалить, например SQL Server, службы Reporting Services или службы Analysis Services. Эту команду необходимо применять в сочетании с параметром INSTANCENAME. Например, чтобы удалить компоненты, зависящие от экземпляра, и какой-либо независимый компонент, например Client_Components, необходимо указать следующее.

  • REMOVE=All INSTANCENAME=MSSQLSERVER

    Важно!
    Нельзя применять данный параметр, если существует несколько установленных экземпляров и будет необходимо использовать клиентские средства.

    Чтобы удалить компоненты, не зависящие от экземпляра, например Client_Components и SQL_DTS, укажите REMOVE=ALL без указания имени экземпляра.

    Если параметр REMOVE используется при новой установке, компоненты, перечисленные после команды «REMOVE=», не включаются в установку. Например, чтобы во время новой установки установить все компоненты, кроме компонентов служб Reporting Services, необходимо ввести следующее.

    • ADDLOCAL=All REMOVE=RS_Server,RS_Web_Interface

Параметр REMOVE также может использоваться на этапе обслуживания для удаления компонентов из существующей установки. Например, чтобы удалить возможность полнотекстового поиска, необходимо указать следующее.

  • REMOVE=SQL_FullText

    Важно!
    При удалении родительской функции ее дочерние возможности удаляются автоматически.

    Копировать код
    REMOVE=

[INSTANCENAME]

Эти сведения используются в диалоговом окне Имя экземпляра. Параметр INSTANCENAME НЕОБХОДИМ для компонентов, зависящих от экземпляра. Используйте MSSQLSERVER в качестве имени экземпляра по умолчанию. Для общих, не зависящих от экземпляра компонентов, таких как службыNotification Services, службы Integration Services и клиентских компонентов, этот параметр можно не указывать.

Копировать код
INSTANCENAME=

[UPGRADE]

Параметр UPGRADE указывает, какой компонент следует обновить. Допустимым значением является SQL_Engine для обновления SQL Server. Если указан параметр UPGRADE, НЕОБХОДИМО с помощью параметра INSTANCENAME указать обновляемый экземпляр. Например, чтобы обновить экземпляр SQL Server по умолчанию, примените следующую командную строку.

  • UPGRADE=SQL_Engine INSTANCENAME=MSSQLSERVER

Чтобы обновить именованный экземпляр SQL Server, в котором SQL Server выполняется под учетной записью домена, и добавить клиентские компоненты и средства, запустите следующую команду:

  • UPGRADE=SQL_Engine INSTANCENAME=<InstanceName> SQLACCOUNT=<domainname>\<accountname> SQLPASSWORD=<StrongPassword> ADDLOCAL=Client_Components

    Копировать код
    UPGRADE=

[SAVESYSDB]

Параметр SAVESYSDB может применяться во время удаления, чтобы запретить удаление системных баз данных. Если параметр SAVESYSDB имеет значение 1, системные базы данных сохраняются в каталоге данных SQL. Этот параметр обычно используется в случае, если планируется дальнейшее обновление.

Копировать код
SAVESYSDB=

[USESYSDB]

Параметр USESYSDB указывает корневой путь к каталогу данных системных баз данных во время обновления. Например, если база данных была установлена в D:\Microsoft SQL Server\MSSQL.1\MSSQL\DATA, значение параметра должно быть USESYSDB="D:\Microsoft SQL Server\MSSQL.1\MSSQL".

Если указан путь установки для ядра СУБД, программа установки SQL Server использует этот путь в качестве корневого каталога для всех папок данного экземпляра, включая файлы данных SQL Server. В этом случае при указании корневого каталога «C:\Program Files\Microsoft SQL Server\MSSQL.1\MSSQL\» относящиеся к экземпляру папки добавляются в конец этого пути.

Заказчики, выбравшие использование функции обновления USESYSDB, могут легко попасть в ситуацию, когда продукт устанавливается в рекурсивную структуру папок, например <SQLProgramFiles>\MSSQL.1\MSSQL\MSSQL.1\MSSQL\Data\. Не следует применять параметр USESYSDB, нужно вместо пути установки для ядра СУБД указать путь установки для файлов данных SQL Server.

Примечание.
Файлы данных всегда должны находиться во вложенном каталоге Data. Например, если файлы данных располагаются в каталоге C:\Program Files\Microsoft SQL Server\MSSQL.1\MSSQL\Data, укажите каталог C:\Program Files\Microsoft SQL Server\MSSQL.1\ в качестве корневого каталога данных системных баз данных во время обновления.

Важно!
При использовании параметра USESYSDB для установки SQL Server 2005 с набором файлов данных предыдущей установки убедитесь, что файлы с расширением MDF и LDF для указанных баз данных расположены в том же каталоге.

Копировать код
USESYSDB=

[SQLACCOUNT], [SQLPASSWORD], [AGTACCOUNT], [AGTPASSWORD], [ASACCOUNT], [ASPASSWORD], [RSACCOUNT] и [RSPASSWORD]

Эти сведения используются в диалоговом окне Учетные записи служб. Эти параметры необходимы для установки как изолированного сервера, так и виртуального сервера. Если эти параметры не заданы, программа установки завершится неудачно.

Если эти параметры не заданы при установке выпуска SQL Server Express Edition, то программа установки по умолчанию будет использовать конкретную встроенную учетную запись компьютера в зависимости от используемой операционной системы.

  • Для Windows XP и Windows 2003 установленной по умолчанию учетной записью службы будет являться NetworkService (NT AUTHORITY).

  • Для Windows 2000 установленной по умолчанию учетной записью службы будет являться LocalSystem (NT AUTHORITY\SYSTEM).

Если необходимо, чтобы SQL Express устанавливался с конкретной учетной записью, рекомендуется не использовать установленные по умолчанию настройки. Вместо этого воспользуйтесь параметрами *ACCOUNT и убедитесь, что указан параметр DOMAIN\user name, например SQLACCOUNT=DOMAINNAME\ACCOUNT.

Примечание.
По умолчанию SQL Server и службы Analysis Services настроены на автозапуск.

При использовании параметров *ACCOUNT необходимо указать параметр DOMAIN, например SQLACCOUNT=DOMAINNAME\ACCOUNT.

Важно!
Параметры SQLACCOUNT, SQLPASSWORD, AGTACCOUNT и AGTPASSWORD используются для установки виртуального сервера. Параметры ASACCOUNT и ASPASSWORD нельзя использовать при установке виртуального сервера.

Копировать код
SQLACCOUNT=
SQLPASSWORD=
AGTACCOUNT=
AGTPASSWORD=
ASACCOUNT=
ASPASSWORD=
RSACCOUNT=
RSPASSWORD=

[AUTOSTART]

При использовании параметра *AUTOSTART укажите 1 для автоматического запуска либо 0 для запуска вручную. При автоматическом запуске агента SQL Server также автоматически запускается SQL. Значения параметров по умолчанию приведены ниже.

Копировать код
SQLAUTOSTART=1
AGTAUTOSTART=0
ASAUTOSTART=1
RSAUTOSTART=1

[SECURITYMODE] и [SAPWD]

Эти сведения используются в диалоговом окне Режим проверки подлинности. Чтобы применить смешанный тип проверки подлинности, задайте SECURITYMODE=SQL. Если SECURITYMODE=SQL не указано, используется только проверка подлинности Windows.

Важно!
По возможности используйте проверку подлинности Windows.

Чтобы установить пароль sa, укажите значение параметра SAPWD. Программе установки SQL Server требуется надежный пароль sa.

Важно!
Не используйте пустой пароль. Выбирайте надежные пароли.

SECURITYMODE=SQL

Копировать код
SAPWD=

Дополнительные сведения о рекомендациях по выбору надежного пароля см. в разделе Режим проверки подлинности.

[SQLCOLLATION] и [ASCOLLATION]

Эти сведения используются в диалоговом окне Параметры сортировки. Параметр SQLCOLLATION задает параметры сортировки SQL Server. Параметр ASCOLLATION задает параметры сортировки служб Analysis Services.

Копировать код
SQLCOLLATION=
ASCOLLATION=

Дополнительные сведения о настройках параметров сортировки см. в разделах Настройка параметров сортировки в программе установки, Стили сортировки в параметрах сортировки Windows и Использование двоичных параметров сортировки.

[REBUILDDATABASE]

Сведения о перестроении системных баз данных. В случае повреждения системных баз данных или при необходимости переустановки системных параметров сортировки необходимо привести системные базы данных к состоянию, в котором они были сразу после установки. Данная задача решается с помощью параметра REBUILDDATABASE. Необходимо задать значение REBUILDDATABASE=1. При использовании параметра REBUILDDATABASE требуются дополнительные параметры:

  • SQLACCOUNT, SQLPASSWORD;

  • SQLAGTACCOUNT, SQLAGTPASSWORD;

  • SQLBROWSERACCOUNT, SQLBROWSERPASSWORD.

Последствия перестроения базы данных master

Перестроение базы данных master приводит все системные базы данных к их исходному состоянию и исходным значениям атрибутов.

После перестроения базы данных master

После перестроения базы данных master необходимо:

  1. Восстановить наиболее поздние полные резервные копии баз данных master, model и msdb. Если резервная копия недоступна, перейдите к шагу 2.

  2. Если восстановленная резервная копия базы данных не является самой поздней, повторно создайте отсутствующие записи. Например, в базе данных master создайте все недостающие записи для пользовательских баз данных, устройств резервного копирования, имен входа SQL Server, конечных точек и так далее. Наилучшим способом восстановления записей является запуск сценариев, использовавшихся для создания утраченных записей.

    Примечание безопасности.
    Рекомендуется защитить применяемые сценарии, чтобы предотвратить их изменение неавторизированными пользователями.

    Также рекомендуется создать резервную копию базы данных после ее обновления. Дополнительные сведения см. в разделах Создание резервной копии базы данных master и Резервное копирование баз данных model и msdb электронной документации SQL Server.

  3. Если экземпляр сервера настроен как распространитель репликации, необходимо восстановить базу данных distribution. Дополнительные сведения см. в разделе Резервное копирование и восстановление из копий реплицируемых баз данных электронной документации SQL Server 2005.

  4. В SQL Server системные объекты хранятся в базе данных resource. Эта база данных всегда обновляется при обновлении SQL Server исполняемого файла sqlservr.exe из состава SQL Server. После перестроения базы данных master необходимо заново выполнить все обновления SQL Server, которые были ранее применены к экземпляру сервера. Дополнительные сведения см. в разделе База данных Resource электронной документации SQL Server.

    Важно!
    Не включайте файл mssqlsystemresource.mdf, содержащий базу данных resource, в процедуру регулярного резервного копирования и восстановления. Этот файл не содержит данных или метаданных, он содержит код. По умолчанию резервная копия и компоненты восстановления SQL Server автоматически исключают базу данных resource.

  5. При перестроении базы данных master все системные базы данных устанавливаются в исходные местоположения. Если одна или несколько системных баз данных были перемещены в другие местоположения, необходимо вернуть их в исходные. Дополнительные сведения о перемещении системных баз данных см. в разделе Перемещение системных баз данных.

Примечание.
Параметр REBUILDDATABASE доступен только в режиме автоматической установки. Необходимо использовать параметр /qn или /qb. Аргумент /qn отключает вывод всех диалоговых окон и сообщений об ошибках программы установки. Если указан параметр /qn, все сообщения программы установки, включая сообщения об ошибках, записываются в файлы журналов программы установки. Дополнительные сведения о файлах журналов см. в разделе Как просмотреть файлы журналов установки SQL Server 2005.

Аргумент /qb включает отображение основных диалоговых окон программы установки. Также выводятся сообщения об ошибках.

Важно!
Чтобы перестроить системные базы данных, НЕОБХОДИМО ввести новый пароль sa.

Копировать код
REBUILDDATABASE=

[REINSTALLMODE]

Сведения для восстановления установленных компонентов. При использовании параметра REINSTALLMODE необходимо указать параметр REINSTALL. В параметрах REINSTALL и ADDLOCAL используются одинаковые значения.

Примечание.
Параметр REINSTALLMODE доступен только в режиме автоматической установки, и необходимо использовать параметр /qn или /qb. Аргумент /qn отключает вывод всех диалоговых окон и сообщений об ошибках программы установки. Если указан параметр /qn, все сообщения программы установки, включая сообщения об ошибках, записываются в файлы журналов программы установки. Дополнительные сведения о файлах журналов см. в разделе Как просмотреть файлы журналов установки SQL Server 2005.

Аргумент /qb включает отображение основных диалоговых окон программы установки. Также выводятся сообщения об ошибках.

Поддерживаемые значения параметра REINSTALLMODE:

  • O — переустановить, если файл отсутствует или если этот файл более старой версии;

  • M — перезаписать зависящие от компьютера разделы реестра в HKLM;

  • U — перезаписать пользовательские разделы реестра в HKCU;

  • S — переустановить все контекстные меню.

Копировать код
REINSTALLMODE=

[RSCONFIGURATION]

Эти сведения используются в диалоговом окне Настройка служб Reporting Services. Необходимо указать этот параметр при установке служб Reporting Services либо диспетчера отчетов. Данный параметр может иметь значение FilesOnly либо Default. Параметр FilesOnly только устанавливает файлы, не настраивая службы Reporting Services. Значение параметра по умолчанию обеспечивает установку служб Reporting Services со значениями всех параметров, выбранных по умолчанию.

Копировать код
RSCONFIGURATION=

Дополнительные сведения см. в разделе Параметры установки сервера отчетов.

[SAMPLEDATABASESERVER]

Эти сведения используются в диалоговом окне Образцы баз данных. Данный параметр используется при установке возможности Образцы AdventureWorks или Образцы AdventureWorksDW.

Образцы баз данных могут быть привязаны к любому локальному экземпляру SQL Server при условии совпадения версий. Параметр указывает имена компьютера и экземпляра, на которых необходимо разместить образцы, следующим образом.

  • SAMPLEDATABASESERVER — имя_компьютера\имя_экземпляра

Копировать код
SAMPLEDATABASESERVER=

[DISABLENETWORKPROTOCOLS]

Данный параметр применяется для настройки типа запуска сетевых протоколов. Параметр может иметь одно из следующих трех значений.

  • 0 — общая память включена, именованные каналы включены, TCP/IP включен.

  • 1 — общая память включена, именованные каналы выключены (только локальные), TCP/IP выключен.

  • 2 — общая память включена, именованные каналы выключены (только локальные), TCP/IP включен.

Копировать код
DISABLENETWORKPROTOCOLS=

[ERRORREPORTING]

Эти сведения используются в диалоговом окне Отчеты об ошибках. При включении данной возможности SQL Server и его компоненты, а также службы Analysis Services будут настроены на автоматическую отправку отчетов в корпорацию Майкрософт в случае возникновения неустранимой ошибки в SQL Server Database Engine, агенте SQL Server или Analysis Services. Microsoft использует отчеты об ошибках, чтобы улучшить функциональность SQL Server, и любые поступающие данные расценивает как конфиденциальные.

Чтобы включить отправку отчета об ошибках, укажите значение ERRORREPORTING=1. Если не указать значение ERRORREPORTING=1, возможность отправки отчетов об ошибках будет отключена.

Копировать код
ERRORREPORTING=

[SKUUPGRADE]

При обновлении с одного выпуска SQL Server до другого выпуска SQL Server укажите параметр SKUUPGRADE.

Важно!
При использовании параметра SKUUPGRADE программа установки удаляет все исправления и пакеты обновления из обновляемого экземпляра SQL Server. По завершении обновления выпуска необходимо повторно применить все исправления и пакеты обновления.

Для выполнения обновления выпуска экземпляра по умолчанию SQL Server (только SQL Engine) при помощи автоматической установки выполните следующую команду с аргументами /qb или /qn:

start /wait setup.exe ADDLOCAL=SQL_Engine INSTANCENAME=MSSQLSERVER UPGRADE=SQL_Engine SKUUPGRADE=1 /qb

Копировать код
SKUUPGRADE=

Параметры, необходимые для установки кластера

Примечание.
Чтобы запустить установку кластера, находясь в кластере, необходимо в командной строке указать параметры /qn или /qb. Аргумент /qn отключает вывод всех диалоговых окон и сообщений об ошибках программы установки. Если указан параметр /qn, все сообщения программы установки, включая сообщения об ошибках, записываются в файлы журналов программы установки. Дополнительные сведения о файлах журналов см. в разделе Как просмотреть файлы журналов установки SQL Server 2005.

Ключ /qb включает отображение основных диалоговых окон программы установки. Также выводятся сообщения об ошибках. Дополнительные сведения об отказоустойчивом кластере см. в разделах Настройка высокого уровня доступности и Подготовка к установке отказоустойчивого кластера.

Для установки кластера из командной строки необходимо указать следующие параметры.

[INSTALLSQLDIR] | [INSTALLSQLDATADIR] | [SQLACCOUNT], [SQLPASSWORD], [AGTACCOUNT] и [AGTPASSWORD]
[INSTANCENAME] | [SAPWD] | [VS]
[INSTALLVS] | [IP] | [GROUP]
[ADDNODE] | [REMOVENODE] | [SQLCLUSTERGROUP] и [AGTCLUSTERGROUP]
[ADMINPASSWORD] | [SKUUPGRADE] |

[INSTALLSQLDIR]

Данный параметр требуется для установки отказоустойчивого кластера. Указываемая буква диска должна присутствовать на обоих компьютерах.

Копировать код
INSTALLSQLDIR=

[INSTALLSQLDATADIR]

Данный параметр требуется для установки отказоустойчивого кластера. Общая буква диска должна присутствовать в группе дисков, используемой параметрами GROUP.

Копировать код
INSTALLSQLDATADIR

[SQLACCOUNT], [SQLPASSWORD], [AGTACCOUNT] и [AGTPASSWORD]

Данные параметры требуются для установки отказоустойчивого кластера.

Копировать код
SQLACCOUNT=
SQLPASSWORD=
AGTACCOUNT=
AGTPASSWORD=

[INSTANCENAME]

Данный параметр требуется для установки отказоустойчивого кластера. Используйте MSSQLSERVER в качестве имени экземпляра по умолчанию. Дополнительные сведения о правилах именования экземпляров см. в разделе Имя экземпляра.

Копировать код
INSTANCENAME=

[SAPWD]

Данный параметр требуется для установки отказоустойчивого кластера.

Важно!
Не используйте пустой пароль. Выбирайте надежные пароли.

Копировать код
SAPWD=

Дополнительные сведения о рекомендациях по выбору надежного пароля см. в разделе Режим проверки подлинности.

[VS]

Данный параметр требуется для установки отказоустойчивого кластера. Данный параметр применяется для указания имени виртуального сервера. Длина имени не может превышать 15 символов, при этом имя должно соответствовать правилам именования компьютеров.

Копировать код
VS=

[INSTALLVS]

Данный параметр требуется для установки отказоустойчивого кластера. Укажите сервер, используемый в качестве кластера при установке. Используйте значение «SQL_Engine» для SQL Server и значение «Analysis_Server» для служб Analysis Services.

Копировать код
INSTALLVS=

[IP]

Данный параметр требуется для установки отказоустойчивого кластера. Укажите IP-адрес, содержащий записи для каждой сетевой платы.

  • Формат: "IP адрес,сеть".

  • Пример: IP="xxx.xxx.xxx.xxx,Local Area Connection".

Копировать код
IP=

[GROUP]

Данный параметр требуется для установки отказоустойчивого кластера. Укажите группу кластера, которая содержит диск, на который будут записаны общие файлы данных, содержащие ресурсы SQL Server.

  • Пример: GROUP="Group 2".

Копировать код
GROUP=

[ADDNODE]

Данный параметр требуется для установки отказоустойчивого кластера. Укажите узлы виртуального сервера. Узлы должны существовать в кластере. Также можно использовать данный параметр для добавления узлов к существующему кластеру.

Копировать код
ADDNODE=

[REMOVENODE]

Данный параметр требуется только для обслуживания кластера. Используйте данный параметр для удаления узлов из существующего кластера.

Копировать код
REMOVENODE=

[SQLCLUSTERGROUP] и [AGTCLUSTERGROUP]

Данные параметры требуются для установки отказоустойчивого кластера. Для установки отказоустойчивого кластера необходимо задать глобальное или локальное имя домена или имя группы в формате <ИмяДомена>\<ИмяГруппы>, существующие при выполнении программы установки. Программа установки SQL Server в процессе своей работы не создает группы. Дополнительные сведения см. в разделе Доменные группы для служб, поддерживающих работу в кластере.

Копировать код
SQLCLUSTERGROUP=
AGTCLUSTERGROUP=

[ADMINPASSWORD]

Данный параметр требуется для установки отказоустойчивого кластера. Задайте пароль для учетной записи. Указанная учетная запись должна иметь права администратора на всех удаленных узлах кластера.

Копировать код
ADMINPASSWORD=

См. также

Задачи

Как установить SQL Server 2005 (программа установки)

Основные понятия

Как просмотреть файлы журналов установки SQL Server 2005


Как установить службы IIS (Microsoft)

Как установить службы IIS (Microsoft) |
 | См. также
Установка компонентов SQL Server 2005 > Разделы руководства по установке компонентов SQL Server > Разделы руководства по установке компонента Database Engine >

Для установки и работы некоторых компонентов необходимы службы IIS Microsoft. Дополнительные сведения см. в разделе Требования к оборудованию и программному обеспечению для установки SQL Server 2005. Сведения об установке служб IIS 7.0 в Windows Vista см. на веб-узле Майкрософт.

Установка служб IIS

  1. Закройте все приложения, выполняющиеся в настоящее время.

  2. Откройте панель управления и дважды щелкните Установка и удаление программ.

  3. На левой панели щелкните Добавление и удаление компонентов Windows. Запустится мастер компонентов Windows.

  4. Выберите Службы IIS и нажмите кнопку Далее. Если флажок уже установлен, то службы IIS уже установлены.

    Примечание.
    Для некоторых серверных операционных систем службы IIS могут быть компонентом сервера приложений. Если операционная система относится именно к такому типу, выберите Сервер приложений и нажмите кнопку Далее.

    Службы IIS будут установлены и настроены.

См. также

Основные понятия

Как просмотреть файлы журналов установки SQL Server 2005

Другие ресурсы

Разделы руководства по установке компонента Database Engine


Как проверить успешность установки служб SQL Server 2005

Как проверить успешность установки служб SQL Server 2005 |
 | См. также
Установка компонентов SQL Server 2005 > Разделы руководства по установке компонентов SQL Server > Разделы руководства по установке компонента Database Engine >

Чтобы убедиться в правильности установки , проверьте, что установленные службы запущены на компьютере.

Убеждение в правильности установки служб SQL Server 2005

  1. Проверьте, запущена ли служба SQL Server: На панели управления дважды щелкните Администрирование, дважды щелкните Службы и найдите отображаемое имя соответствующей службы.

    В следующей таблице перечислены отображаемые имена и соответствующие им службы.

    Примечание.
    Настоящие имена служб несколько отличаются от отображаемых. Имена служб можно увидеть, щелкнув правой кнопкой мыши значок службы и выбрав пункт Свойства.

Имя | Служба
SQLServer (MSSQLSERVER) | Экземпляр ядра СУБД SQL Server по умолчанию.
SQL Server (имя_экземпляра) | Именованный экземпляр ядра СУБД SQL Server, где имя_экземпляра соответствует имени этого экземпляра.
Агент SQL Server (MSSQLSERVER) | Экземпляр агента SQL Server по умолчанию. Агент SQL Server выполняет задания, отслеживает SQL Server, обрабатывает предупреждения и допускает автоматизацию административных задач.
Агент SQL Server (имя_экземпляра) | Именованный экземпляр агента SQL Server, где имя_экземпляра соответствует имени этого экземпляра. Агент SQL Server выполняет задания, отслеживает SQL Server, обрабатывает предупреждения и допускает автоматизацию административных задач.
Службы Analysis Services (MSSQLSERVER) | Экземпляр служб Analysis Services по умолчанию.
Сервер анализа данных (имя_экземпляра) | Именованный экземпляр служб Analysis Services, где имя_экземпляра соответствует имени этого экземпляра.
Службы Reporting Services | Экземпляр служб по умолчанию.
Службы Reporting Services (имя_экземпляра) | Именованный экземпляр служб Reporting Services, где имя_экземпляра соответствует имени этого экземпляра.
  1. Если данная служба не запущена, щелкните правой кнопкой мыши ее значок и выберите пункт Запустить. Если запуск не произошел, в свойствах службы найдите путь к исполняемому файлу (exe-файл). Убедитесь, что он находится по указанному пути.

См. также

Задачи

Как просмотреть файл журнала установки SQL Server 2005

Основные понятия

Как просмотреть файлы журналов установки SQL Server 2005
Устранение неполадок при установке ядра СУБД SQL Server
Настройка контактной зоны SQL Server


Как изменить компоненты существующего экземпляра SQL Server 2005 (программа установки)

Как изменить компоненты существующего экземпляра SQL Server 2005 (программа установки) |
 | См. также
Установка компонентов SQL Server 2005 > Разделы руководства по установке компонентов SQL Server > Разделы руководства по установке компонента Database Engine >

Изменить компоненты данного выпуска можно только с помощью раздела «Установка и удаление программ» панели управления Microsoft Windows.

Изменение компонентов установленного экземпляра SQL Server 2005

  1. Откройте панель управления и дважды щелкните пункт Установка и удаление программ.

  2. В разделе Установленные программы щелкните экземпляр SQL Server, который хотите настроить, после чего нажмите кнопку Изменить.

  3. На странице Выбор компонентов — обслуживание выберите экземпляр СУБД или разделяемый компонент, который хотите обновить.

    Нажмите кнопку Отчет для просмотра списка компонентов и функций SQL Server 2005, установленных на компьютере. Отчет включает версию, выпуск, версию обновления и сведения о языке для каждого из установленных компонентов и функций.

    Чтобы продолжить, нажмите кнопку Далее.

  4. На странице Функциональное обслуживание выберите серверный компонент, который нужно обновить. Если на предыдущей странице был выбран разделяемый компонент, эта страница отображена не будет.

    Нажмите кнопку Отчет для просмотра списка компонентов и функций SQL Server 2005, установленных на компьютере. Отчет включает версию, выпуск, версию обновления и сведения о языке для каждого из установленных компонентов и функций.

    Чтобы продолжить, нажмите кнопку Далее.

  5. На странице Изменить/Удалить нажмите кнопку Изменить.

  6. На странице Выбор компонентов внесите изменения в экземпляр SQL Server 2005, используя иерархию его возможностей. Чтобы продолжить, нажмите кнопку Далее.

  7. На странице Все готово для обновления убедитесь в правильности изменений, которые будут выполнены программой установки SQL Server 2005. Чтобы продолжить, нажмите кнопку Далее.

  8. На странице Выполнение установки программа установки отображает состояние установки.

  9. На странице Завершение установки щелкните Готово для завершения мастера установки.

См. также

Задачи

Как установить SQL Server 2005 (программа установки)
Как удалить существующий экземпляр SQL Server 2005 (программа установки)
Как просмотреть файл журнала установки SQL Server 2005

Основные понятия

Как просмотреть файлы журналов установки SQL Server 2005


Как переименовать компьютер, на который установлен изолированный экземпляр SQL Server 2005

Как переименовать компьютер, на который установлен изолированный экземпляр SQL Server 2005 |
 | См. также
Установка компонентов SQL Server 2005 > Разделы руководства по установке компонентов SQL Server > Разделы руководства по установке компонента Database Engine >

Дата обновления: 17 июля 2006 г.

Когда меняется имя компьютера, на котором работает , новое имя распознается в процессе запуска SQL Server. Не нужно заново запускать программу установки, чтобы изменить имя компьютера. Следующие действия нельзя использовать для переименования экземпляра SQL Server 2005. Эти шаги могут использоваться только для переименования части имени экземпляра, соответствующего имени компьютера. Например, можно изменить имя компьютера MB1, на котором расположен экземпляр SQL Server с именем Instance1, на другое имя, например MB2. Однако часть имени, представляющая собой имя экземпляра, Instance1, останется неизменной. В данном примере \\ИмяКомпьютера\ИмяЭкземпляра изменится с \\MB1\Instance1 на \\MB2\Instance1.

Перед началом

Прежде чем приступить к процессу переименования, обратите внимание на следующее:

  • Если экземпляр SQL Server является частью отказоустойчивого кластера SQL Server, процесс переименования компьютера отличается от процесса переименования компьютера, на котором расположен изолированный экземпляр. Сведения о переименовании компьютера, на котором расположен экземпляр отказоустойчивого кластера SQL Server 2005, см. в разделе Как переименовать виртуальный сервер SQL Server 2005.

  • SQL Server не поддерживает переименование компьютеров, участвующих в репликации, за исключением случаев использования доставки журнала с репликацией. Компьютер-получатель в доставке журнала может быть переименован, если компьютер-источник окончательно потерян. Дополнительные сведения см. в разделе Replication and Log Shipping.

  • При переименовании компьютера, настроенного на использование зеркального отображения базы данных, прежде чем приступить к переименованию, необходимо отключить зеркальное отображение базы данных, а затем заново установить зеркальное отображение базы данных с новым именем компьютера. Метаданные для зеркального отображения базы данных не будут обновлены автоматически для отражения нового имени компьютера.

  • После переименования компьютера пользователи, которые подключаются к SQL Server через группу Windows, использующую жестко запрограммированную ссылку на имя компьютера, не смогут подключаться к SQL Server, если в группе Windows будет указано прежнее имя компьютера. Чтобы убедиться в том, что возможно соединение с SQL Server с использованием таких групп Windows после операции переименования, обновите группу Windows для указания нового имени компьютера.

Подключиться к SQL Server с использованием нового имени компьютера можно после перезапуска SQL Server. Однако для обеспечения того, что @@servername возвращает обновленное имя локального экземпляра сервера, выполните вручную одну из следующих процедур, в зависимости от того, что обновляется: экземпляр по умолчанию или именованный экземпляр.

Переименование компьютера, на котором расположен изолированный экземпляр SQL Server 2005

  • В случае с переименованным экземпляром по умолчанию, выполните следующие действия:

    Копировать код
    sp_dropserver <old_name>GOsp_addserver <new_name>, localGO

    Перезапустите экземпляр SQL Server.

  • В случае с переименованным именованным экземпляром, выполните следующие действия:

    Копировать код
    sp_dropserver <old_name\instancename>GOsp_addserver <new_name\instancename>, localGO

    Перезапустите экземпляр SQL Server.

Подтвердите операцию переименования

После того как компьютер переименован, любые соединения, использовавшие старое имя компьютера, должны осуществляться с использованием нового имени.

Подтверждение успешного завершения переименования

  • Выберите данные из @@servername либо sys.servers. Функция @@servername возвращает новое имя, а таблица sys.servers отображает новое имя.

Вопросы, касающиеся удаленных входов систему

Если на компьютере имеются какие-либо имена для удаленного входа в систему, выполнение sp_dropserver может привести к ошибке, подобной этой:

Копировать код
Server: Msg 15190, Level 16, State 1, Procedure sp_dropserver, Line 44There are still remote logins for the server 'SERVER1'.

Чтобы исправить ошибку, необходимо удалить имена для удаленного входа в систему для этого сервера.

Удаление удаленных входов в систему

  • В случае с экземпляром по умолчанию, выполните следующие действия:

    Копировать код
    sp_dropremotelogin old_nameGO

  • В случае с именованным экземпляром, выполните следующие действия:

    Копировать код
    sp_dropremotelogin old_name\instancenameGO

См. также

Задачи

Как переименовать виртуальный сервер SQL Server 2005


Как удалить существующий экземпляр SQL Server 2005 (программа установки)

Как удалить существующий экземпляр SQL Server 2005 (программа установки) |
 | См. также
Установка компонентов SQL Server 2005 > Разделы руководства по установке компонентов SQL Server > Разделы руководства по установке компонента Database Engine >

Следующая процедура позволяет удалить экземпляр .

Примечание.
Перечисленные этапы удаления следует выполнить строго в указанном здесь порядке.

Важно!
Обслуживание или обновление экземпляра SQL Server может производиться локальным администратором, имеющим разрешение на вход в систему в качестве службы.

Перед началом удаления SQL Server 2005 следует учесть следующие важные сведения.

Если на компьютере запущен SQL Server 2005 вместе с предыдущими версиями SQL Server, то программа Enterprise Manager и другие программы, зависящие от объектов SQL-DMO, могут быть отключены. Это может произойти в следующих ситуациях:

  • Параллельная установка SQL Server 2005, SQL Server 2000 или SQL Server 7.0, при которой одна из версий была удалена.

  • Параллельная установка SQL Server 2000 с SQL Server 2005, при которой SQL Server 2000 был установлен после SQL Server 2005.

Эта проблема связана с удалением регистрации COM-библиотеки SQL Server 2005 SQL-DMO. Чтобы вновь включить программу Enterprise Manager и другие программы, зависящие от SQL-DMO, следует зарегистрировать SQL-DMO с помощью запуска ‘regsvr32.exe sqldmo.dll’ из командной строки. Дополнительные сведения см. в разделе «Устранение неполадок при установке SQL Server 2005».

Примечание.
Перед удалением компонентов SQL Server 2005 с компьютера, на котором установлен минимально необходимый объем оперативной памяти, следует удостовериться, что размер файла подкачки равен двойному объему оперативной памяти. В некоторых ситуациях нехватка виртуальной памяти может привести к неполному удалению SQL Server 2005.

Дополнительные сведения о синтаксисе командной строки см. в разделе Как установить SQL Server 2005 из командной строки.

Дополнительные сведения об удалении резервного кластера см. в разделе Как.

Удаление экземпляра SQL Server 2005

  1. Чтобы начать процесс удаления, находясь на рабочем столе Microsoft Windows, последовательно выберите пункты Пуск, Панель управления и Установка и удаление программ.

  2. Выберите компонент SQL Server 2005, который необходимо удалить, а затем щелкните Удалить. Будет запущен мастер установки SQL Server 2005.

  3. На странице Выбор компонентов — удаление выберите нужные серверные и/или совместно используемые компоненты для удаления.

    Нажмите кнопку Отчет для просмотра списка компонентов и функций SQL Server 2005, установленных на компьютере. Отчет включает версию, выпуск, версию обновления и сведения о языке для каждого из установленных компонентов и функций.

    Чтобы продолжить, нажмите кнопку Далее.

  4. На странице Подтверждение — удаление просмотрите список компонентов и функций, подлежащих удалению. Чтобы продолжить, нажмите кнопку Далее.

  5. На странице Выполнение установки будет отображаться состояние программы установки.

  6. На странице Завершение установки щелкните Готово для завершения мастера установки.

См. также

Задачи

Как просмотреть файл журнала установки SQL Server 2005

Основные понятия

Как просмотреть файлы журналов установки SQL Server 2005


Как вручную удалить существующий экземпляр SQL Server 2005

Как вручную удалить существующий экземпляр SQL Server 2005 |
 | См. также
Установка компонентов SQL Server 2005 > Разделы руководства по установке компонентов SQL Server > Разделы руководства по установке компонента Database Engine >

Новое содержимое: 17 июля 2006 г.

Чтобы удалить экземпляр , выполните следующие шаги.

Важно!
Обслуживание или обновление экземпляра SQL Server должно производиться локальным администратором, имеющим разрешение на вход в систему в качестве службы.

В этой статье описано, как удалить изолированный экземпляр вручную. Выполнив шаги, приведенные в этом разделе, систему можно подготовить к повторной установке SQL Server.

Дополнительные сведения по удалению отказоустойчивого кластера SQL Server 2005 см. в разделе Как или Как. Сведения о ручном удалении экземпляра SQL Server 2000 см. в разделе Как вручную удалить экземпляр по умолчанию SQL Server 2000, именованный или виртуальный экземпляр SQL Server 2000.

Перед удалением SQL Server 2005 следует учесть следующие обстоятельства.

  • Для удаления SQL Server 2005 рекомендуется использовать средство Установка и удаление программ на панели управления. В случае если удаление экземпляра SQL Server 2005 с помощью средства Установка и удаление программ невозможна или завершается ошибкой, можно удалить экземпляр вручную, выполнив шаги, описанные в этом разделе.

  • В статье приводятся сведения об изменении реестра. Перед внесением изменений в реестре создайте его резервную копию и убедитесь, что существует возможность восстановления реестра в случае возникновения проблем. Дополнительные сведения о резервном копировании, восстановлении и изменении реестра см. в статье Описание реестра Microsoft Windows базы знаний Майкрософт.

  • Если на компьютере используется SQL Server 2005 вместе с предыдущими версиями SQL Server, то программа Enterprise Manager и другие программы, зависящие от объектов SQL-DMO, могут оказаться отключены. Это может произойти в следующих ситуациях:

    • параллельная установка экземпляров SQL Server 2005, SQL Server 2000 или SQL Server 7.0, когда были удалены один или несколько экземпляров;

    • параллельная установка SQL Server 2000 и SQL Server 2005, при которой SQL Server 2000 был установлен после SQL Server 2005.

    Эта проблема связана с отменой регистрации COM-библиотеки объектов SQL-DMO в SQL Server 2005. Чтобы восстановить работу программы Enterprise Manager и других программ, зависящих от объектов SQL-DMO, зарегистрируйте COM-библиотеку, введя команду regsvr32.exe sqldmo.dll в командной строке. Дополнительные сведения см. в разделе Устранение неполадок при установке ядра СУБД SQL Server.

  • Перед удалением компонентов SQL Server 2005 с компьютера, на котором установлен минимально необходимый объем оперативной памяти, следует удостовериться, что размер файла подкачки вдвое превышает объем физической памяти. В некоторых случаях недостаток виртуальной памяти может привести к неполному удалению SQL Server 2005.

  • Если некоторый компонент SQL Server 2005 не был полностью удален с компьютера, программа установки SQL Server 2005 выведет следующее сообщение об ошибке:

    Компонент, указанный в свойстве ADD_LOCAL, уже установлен. Для обновления существующего компонента обратитесь к файлу template.ini и установите имя компонента в свойстве UPGRADE.

Перед удалением SQL Server 2005 выполните следующие действия.

  • Резервное копирование данных. Возможно, имеются базы данных, которые нужно сохранить в текущем состоянии. Кроме того, может потребоваться сохранить изменения, внесенные в системные базы данных. В этих случаях перед удалением SQL Server 2005 необходимо создать резервную копию данных. В качестве альтернативного решения можно сохранить копию файлов данных и файлов журналов в папке с именем, отличным от MSSQL. Папка MSSQL будет удалена в ходе удаления SQL Server.

    Необходимо сохранить следующие файлы баз данных, которые устанавливаются вместе с SQL Server 2005:

    • Distmdl.*;

    • Master.*;

    • Mastlog.*;

    • Model.*;

    • Modellog.*;

    • Msdbdata.*;

    • Msdblog.*;

    • Mssqlsystemresource.*;

    • Northwind.* (дополнительно устанавливаемая база данных);

    • Pubs.*;

    • Pubs_log.*;

    • Tempdb.*;

    • Templog.*;

    • ReportServer[$ИмяЭкземпляра] (база данных по умолчанию для служб Reporting Services);

    • ReportServer[$ИмяЭкземпляра]TempDB (временная база данных по умолчанию для служб Reporting Services).

  • Удалите локальные группы безопасности. Перед удалением SQL Server 2005 удалите локальные группы безопасности для компонентов SQL Server 2005.

  • Сохранение или переименование папок служб SQL Server Reporting Services. Если в установленную конфигурацию SQL Server входят службы Reporting Services, сохраните или переименуйте следующие папки и вложенные папки:

    • <диск>\Microsoft SQL Server\Reporting Services;

    • <диск>\Microsoft SQL Server\MSSQL\Reporting Services;

    • <диск>\Microsoft SQL Server\<Имя экземпляра SQL Server>\Reporting Services;

    • <диск>\Microsoft SQL Server\90\Tools\Reporting Services

Примечание.
Если после установки применялось средство настройки служб SSRS, имена папок могут отличаться от приведенных в списке. Кроме того, базы данных могут располагаться на удаленном компьютере с SQL Server.

  • Удаление виртуальных каталогов служб Reporting Services. С помощью диспетчера служб IIS удалите следующие виртуальные каталоги:

    • ReportServer[$ИмяЭкземпляра];

    • Reports[$ИмяЭкземпляра].

  • Удаление пула приложений ReportServer. Удалите пул приложений ReportServer с помощью диспетчера служб IIS.

  • Остановка всех служб SQL Server. Перед удалением компонентов SQL Server 2005 рекомендуется остановить все службы SQL Server. Наличие активных соединений может помешать удалению компонентов.

  • Выбор учетной записи с необходимыми разрешениями. Выполните вход на сервер с учетной записью службы SQL Server или с учетной записью, обладающей аналогичным набором разрешений. Например, можно войти на сервер с учетной записью, входящей в локальную группу администраторов.

Внимание!
Неправильное изменение реестра может вызвать серьезные проблемы. Перед внесением изменений в реестр рекомендуется создать резервную копию всех важных данных.

Примечание.
Перечисленные этапы удаления следует выполнять строго в указанном порядке.

Удаление экземпляра SQL Server 2005 вручную

  1. Убедитесь, что установлен компонент «Файлы поддержки программы установки SQL Server».

    Проверьте, присутствует ли компонент Файлы поддержки установки Microsoft SQL Server в списке установленных программ в окне Установка и удаление программ. Если это так, перейдите к шагу 2.

    В противном случае перед продолжением необходимо установить компонент Файлы поддержки установки Microsoft SQL Server. Для этого дважды щелкните файл Servers\setup\sqlsupport.msi на установочном носителе SQL Server 2005. Компонент «Файлы поддержки установки Microsoft SQL Server» будет удален на шаге 5.

  2. Чтобы удалить компоненты SQL Server, в командной строке введите следующую команду:

    Копировать код
    %ProgramFiles%\Microsoft SQL Server\90\Setup Bootstrap\ARPWrapper.exe /Remove

    Поочередно удалите все компоненты SQL Server.

    Примечание.
    Средство Установка и удаление программ также запускает программу ARPWrapper.exe с параметром /Remove, однако ссылка на программу ARPWrapper.exe могла быть удалена.

    Если будет получено одно из следующих сообщений об ошибке, обратитесь к разделу «Решение проблем» далее. Не удалось произвести перечисление реестра.

    Если в экземпляре SQL Server установлено несколько серверных компонентов, например компонент Database Engine и службы Analysis Services, программа установки завершится со следующим сообщением об ошибке:

    Программой установки обнаружена непредвиденная ошибка в хранилище данных. Действие: RestoreSetupParams.

    Эта ошибка происходит вследствие работы счетчика ссылок, который используется для отслеживания числа программ, которые используют один и тот же DLL-файл или MSI-файл. Во время удаления программы значение счетчика ссылок для MSI-файла уменьшается на единицу. После удаления последней программы, использующей MSI-файл, этот файл удаляется. В рассматриваемом случае MSI-файлом является компонент «Файлы поддержки программы установки SQL Server» (SqlSupport.msi). Если получено такое сообщение об ошибке, для устранения проблемы используйте один из следующих методов.

    • Переустановите компонент «Файлы поддержки программы установки SQL Server» (SqlSupport.msi) перед удалением каждого компонента экземпляра.

    • Добавьте в счетчик ссылок для файла SqlSupport.msi ссылку на самого себя. Для этого выполните следующие шаги.

    1. Получите идентификатор GUID для компонента «Файлы поддержки программы установки Microsoft SQL Server». Чтобы получить идентификатор GUID, выполните шаги 1 и 2 из раздела «Решение проблем».

    2. С помощью редактора реестра создайте или измените следующие разделы реестра с указанными значениями.

      Имя ключа: HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Microsoft SQL Server\90\Bootstrap\MSIRefCount

      Значение: Uninstall

      Тип: REG_SZ

      Данные: {11111111-1111-1111-1111-111111111111},{GUID}

      Примечание Здесь GUID обозначает идентификатор GUID файлов поддержки SQL Server. Например, в англоязычной версии SQL Server для платформы x86 файлы поддержки имеют следующий идентификатор GUID:

      Данные: {11111111-1111-1111-1111-111111111111},{53F5C3EE-05ED-4830-994B-50B2F0D50FCE}

    Решение проблем

    Если в ходе удаления компонентов SQL Server возникают проблемы, выполните следующие шаги.

    • Запустите редактор реестра и перейдите к следующему разделу реестра:

      HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Uninstall

    • Последовательно щелкните каждый идентификатор GUID в левой области. Для каждого идентификатора GUID проверьте, отображаются ли в правой области имена, содержащие «», например:

    • Microsoft Службы Analysis Services SQL Server 2005

    • Microsoft Службы Reporting Services SQL Server 2005

    • Microsoft Notification Services SQL Server 2005

    • Microsoft службы Integration Services SQL Server 2005

    • Microsoft Инструменты SQL Server 2005

    • Microsoft Электронная документация по SQL Server 2005

      Если обнаружен компонент с именем, содержащим «», запишите идентификатор GUID, выбранный в левой области.

    • Для каждого идентификатора GUID, записанного на предыдущем шаге, выполните в командной строке следующую команду:

      Копировать код
      start /wait msiexec /x {GUID} /l*v c:\sql_uninstall.log

    Примечания

    • В этом примере команды GUID обозначает идентификатор GUID, записанный на предыдущем шаге.

    • Если будет получено следующее сообщение об ошибке, обратитесь в службу технической поддержки.

      Программой установки обнаружена непредвиденная ошибка в хранилище данных. Обратитесь в службу поддержки пользователей.

    Полный список телефонов службы технической поддержки и расценки на услуги поддержки см. на веб-узле Майкрософт в разделе контактные данные службы поддержки.

    • Откройте файл C:\Sql_uninstall.log. Найдите строку (примерно 15-ю с конца файла) следующего вида:

      MSI (s) (EC:F8) [12:52:18:007]: Product: Средства Microsoft SQL Server 2005 -- Удаление успешно завершено.

    Если удаление завершилось ошибкой, запишите имя и идентификатор GUID компонента и сохраните файл Sql_uninstall.log.

  3. С помощью средства Установка и удаление программ удалите компоненты поддержки в следующем порядке;

    • синтаксический анализатор MSXML 6.0;

    • SQLXML4;

    • SQL Server, службы синхронизации контроля версий;

    • средства обеспечения обратной совместимости SQL Server 2005;

    • все прочие компоненты, относящиеся к SQL Server 2005, кроме собственного клиента SQL Server и файлов поддержки программы установки SQL Server.

    Если удаление любого компонента поддержки завершилось ошибкой, может быть получено следующее сообщение:

    Отсутствуют компоненты, необходимые для установки.

    Если получено это сообщение об ошибке, выполните следующие шаги.

    • Запустите редактор реестра и перейдите к следующему разделу реестра:

      HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Uninstall

    • Последовательно щелкните каждый идентификатор GUID в левой области. Для каждого идентификатора GUID проверьте, отображаются ли в правой области имена, соответствующие распространяемому файлу. Если обнаружен компонент с именем, соответствующим имени распространяемого файла, запишите идентификатор GUID, выбранный в левой области.

    • Для каждого идентификатора GUID, записанного на предыдущем шаге, выполните в командной строке следующую команду:

      Копировать код
      start /wait msiexec /x {GUID} SKIPREDISTPREREQS=1 /l*v c:\sqlredist_uninstall.log
      В этом примере команды GUID обозначает идентификатор GUID, записанный на предыдущем шаге.

    • Откройте файл C:\Sqlredist_uninstall.log. Найдите в конце файла строку следующего вида:

      MSI (s) (EC:F8) [12:52:18:007]: Product: Компонент обратной совместимости Microsoft SQL Server 2005 -- Удаление успешно завершено.

      Если удаление завершилось ошибкой, запишите имя и идентификатор GUID компонента и сохраните файл Sqlredist_uninstall.log.

  4. Если все предыдущие шаги выполнены успешно, удалите компонент «Собственный клиент SQL Server» с помощью средства Установка и удаление программ.

    Не удаляйте компонент «Собственный клиент SQL Server», если еще установлены другие компоненты SQL Server.

  5. Если все предыдущие шаги выполнены успешно, удалите компонент «Файлы поддержки программы установки SQL Server» с помощью средства Установка и удаление программ.

    Если с помощью описанных действий не удалось удалить все компоненты и все файлы, связанные с экземпляром SQL Server, обратитесь в службу технической поддержки. Полный список телефонов службы технической поддержки см. на веб-узле справки и поддержки Microsoft.

См. также

Задачи

Как просмотреть файл журнала установки SQL Server 2005

Основные понятия

Как просмотреть файлы журналов установки SQL Server 2005


Как удалить существующий экземпляр SQL Server 2000 или 7.0

Как удалить существующий экземпляр SQL Server 2000 или 7.0 |
 | См. также
Установка компонентов SQL Server 2005 > Разделы руководства по установке компонентов SQL Server > Разделы руководства по установке компонента Database Engine >

Чтобы удалить существующий экземпляр или SQL Server 7.0, используйте следующую процедуру.

Прежде чем начать удаление SQL Server, необходимо учесть следующие важные обстоятельства.

Если на компьютере используется SQL Server 2005 вместе с предыдущими версиями SQL Server, то программа Enterprise Manager и другие программы, зависящие от объектов SQL-DMO, могут быть отключены. Это может произойти в следующих ситуациях.

  • Параллельная установка SQL Server 2005, SQL Server 2000 или SQL Server 7.0, при которой одна из версий была удалена.

  • Параллельная установка SQL Server 2000 с SQL Server 2005, при которой SQL Server 2000 был установлен после SQL Server 2005.

Эта проблема связана с удалением регистрации COM-библиотеки SQL Server 2005 SQL-DMO. Чтобы восстановить работоспособность программы Enterprise Manager и других программ, зависящих от библиотеки SQL-DMO, зарегистрируйте библиотеку, выполнив команду regsvr32.exe sqldmo.dll из командной строки. Дополнительные сведения см. в разделе «Устранение неполадок при установке SQL Server 2005».

Удаление существующего экземпляра SQL Server

  1. Вставьте компакт-диск с программой SQL Server 2000 в дисковод. Если не произойдет автоматического запуска компакт-диска, сделайте двойной щелчок мышью по файлу Autorun.exe в корневом каталоге компакт-диска.

  2. Щелкните Компоненты SQL Server 2000, а затем Установить сервер баз данных. Программа установки запустит мастер установки SQL Server. На странице Приветствие нажмите кнопку Далее.

  3. В диалоговом окне Имя компьютера нажмите Локальный компьютер или Удаленный компьютер.

  4. В диалоговом окне Выбор установки щелкните Обновить, удалить или добавить компоненты к существующему экземпляру SQL Server, а затем нажмите кнопку Далее.

  5. Если установлен экземпляр по умолчанию, в диалоговом окне Имя экземпляра установлен флажок По умолчанию. Если желаете удалить именованный экземпляр, выберите его в списке Имя экземпляра, а затем нажмите кнопку Далее.

  6. В диалоговом окне Существующая установка щелкните Удалить существующую установку, а затем нажмите кнопку Далее.

  7. Программа установки удаляет выбранную установку. В диалоговом окне Удаление нажмите кнопку Далее, а затем в диалоговом окне Установка завершена нажмите кнопку Готово.

См. также

Задачи

Как обновить до SQL Server 2005 (программа установки)


Как просмотреть файлы журналов установки SQL Server 2005

Как просмотреть файлы журналов установки SQL Server 2005 |
 | См. также
Установка компонентов SQL Server 2005 > Разделы руководства по установке компонентов SQL Server > Разделы руководства по установке компонента Database Engine >

Регистрация программы установки в данном выпуске изменилась. Основным журналом является следующий файл:

%ProgramFiles%\Microsoft SQLServer\90\Setup Bootstrap\LOG\Summary.txt

Содержимое этого файла выглядит примерно так:

--------------------------------------------------------------------------------

Machine : MYSERVER

Product : Microsoft XML Parser

Product Version : 8.60.1639.0

Installation : Successful

--------------------------------------------------------------------------------

Machine : MYSERVER

Product : MSXML 6.0 Parser and SDK

Product Version : 6.00.3562.0

Installation : Successful

--------------------------------------------------------------------------------

Machine : MYSERVER

Product : Microsoft SQLServer2005 Analysis Services

Product Version : 9.00.787

Installation : Successful

--------------------------------------------------------------------------------

Machine : MYSERVER

Product : Microsoft SQL Native Client

Product Version : 9.00.121

Installation : Successful

--------------------------------------------------------------------------------

Если в файле журнала указано, что установка того или иного продукта завершилась неудачей, можно определить причину проблемы, изучив журнал, соответствующий этому продукту (ищите «return value 3»). Журналы установки конкретных продуктов записываются в следующий каталог:

%ProgramFiles%\Microsoft SQL Server\90\Setup Bootstrap\LOG\Files

Имена журналов имеют следующий формат:

SQLSetup[XXXX][s]_[COMPUTERNAME]_[PRODUCTNAME]_[Y].log, где

  • XXXXX = порядковый номер установки (последней установке соответствует наибольший номер)

  • COMPUTERNAME= имя компьютера, на котором выполняется программа установки

  • PRODUCTNAME= название продукта (имя MSI-файла) — например SQLSetup0001_MachineName_RS.log для служб Reporting Services и SQLSetup0001_MachineName_NS.log для служб Notification Services

  • Y= если файл установщика Microsoft Windows (MSI-файл) устанавливается при выполнении одного сеанса установки более одного раза, к имени файла журнала добавляется это число, увеличивающееся с каждым разом на единицу. Чаще всего это имеет место для ядра служб XML Microsoft (MSXML).

Примеры имен журналов установки компонентов SQL Server и их описания приведены в следующей таблице.

Файл журнала | Описание
SQLSetup0001_MachineName_Core.log | Основной файл журнала программы установки SQL Server, содержащий сведения об успехе или неудаче установки всех msi-файлов.
SQLSetup0001_MachineName_SCC.log | Подробные сведения, созданные средством проверки конфигурации системы SQL Server 2005 во время установки SQL Server.
SQLSetup0001_MachineName_SQL.log | Файл журнала установки ядра СУБД.
SQLSetup0001_MachineName_AS.log | Файл журнала установки служб Analysis Services.
SQLSetup0001_MachineName_RS.log | Файл журнала установки служб Reporting Services.
SQLSetup0001_MachineName_NS.log | Файл журнала установки служб SQL Server 2005 Notification Services.
SQLSetup0001_MachineName_DTS.log | Файл журнала установки служб Integration Services.
SQLSetup0001_MachineName_Tools.log | Файл журнала установки клиентских компонентов, среда SQL Server Management Studio и электронной документации.
SQLSetup0001_MachineName_WI.log | Файл журнала установки пользовательского интерфейса (UI).
SQLSetup0001_MachineName_SNAC.log | Файл журнала установки собственного клиента SQL Server.
SQLSetup0001_MachineName_.NET Framework 2.0.log | Файл журнала установки платформы .NET Framework 2.0.
SQLSetup0001_MachineName_MSXML.log | Файл журнала установки компонента MSXML.
SQLSetup0001_MachineName_SQLXML.log | Файл журнала установки компонента SQLXML.
SQLSetup0001_MachineName_Logs.cab | В случае установки отказоустойчивого кластера, этот файл содержит журналы всех узлов кластера.
SQLSetup0001_MachineName_Datastore.xml | Значения всех свойств, кэшируемых во время установки. Представители службы поддержки продукции могут запросить эти сведения с целью скорейшего нахождения и устранения проблем.

См. также

Задачи

Как просмотреть файл журнала установки SQL Server 2005

Основные понятия

Устранение неполадок при установке ядра СУБД SQL Server


Как просмотреть файл журнала установки SQL Server 2005

Как просмотреть файл журнала установки SQL Server 2005 |
 | См. также
Установка компонентов SQL Server 2005 > Разделы руководства по установке компонентов SQL Server > Разделы руководства по установке компонента Database Engine >

Программа установки SQL Server 2005 создает файлы журналов для каждого компонента SQL Server в процессе установки; ведение журнала начнется сразу после запуска Setup.exe.

Считать файл журнала программы установки SQL Server

  1. Открыть проводник Windows и перейти к:

    %ProgramFiles%\Microsoft SQL Server\90\Setup Bootstrap\LOG

  2. Откройте файл Summary.txt. Проверьте его на наличие сообщений об ошибках.

  3. Если данные в файле Summary.txt, указывающем на наличие ошибки, не найдены, откройте файл SQLSetup[xxxx].cab в том же корневом каталоге.

  4. Если файл cab не существует, откройте файл журнала CORE из:

    %ProgramFiles%\Microsoft SQL Server\90\Setup Bootstrap\LOG\Files

    Просмотрите основной журнал с самыми последними изменениями: SQLSetup[xxxx]_[ComputerName]_Core.log.

  5. Если в процессе установки в пользовательском интерфейсе появляется ошибка, посмотрите журнал: SQLSetup[xxxx][s]_[ComputerName]_WI.log.

  6. При синтаксическом анализе файла журнала SQLSetup_[xxxx] найдите файл для 'UE 3'. Это сокращенное название для 'Return Value 3'.

  7. Если в ходе установки компонента произошла ошибка, откройте файл журнала SQLSetup[xxxx]_[ComputerName]_SQL.log и выполните поиск 'UE 3' для обнаружения ошибок.

См. также

Основные понятия

Как просмотреть файлы журналов установки SQL Server 2005


Как перестроить базу данных master в SQL Server 2005

Как перестроить базу данных master в SQL Server 2005 |
 | См. также
Установка компонентов SQL Server 2005 > Разделы руководства по установке компонентов SQL Server > Разделы руководства по установке компонента Database Engine >

Использование команды Setup для перестроения базы данных master изменилось в этом выпуске . Запустите файл Setup.exe для перестроения, проверки и исправления экземпляра SQL Server, а затем перестройте системные базы данных. Эта процедура чаще всего используется для перестроения базы данных master в случае повреждения установки SQL Server.

Примечание.
При возможности используйте проверку подлинности Windows.

Дополнительные сведения и пример синтаксиса командной строки см. в разделе Как установить SQL Server 2005 из командной строки.

См. также

Задачи

Как просмотреть файл журнала установки SQL Server 2005

Основные понятия

Как просмотреть файлы журналов установки SQL Server 2005


Как перестроить реестр для SQL Server 2005

Как перестроить реестр для SQL Server 2005 |
 | См. также
Установка компонентов SQL Server 2005 > Разделы руководства по установке компонентов SQL Server > Разделы руководства по установке компонента Database Engine >

Чтобы перестроить реестр, из командной строки запустите команду Setup с параметрами REINSTALL=ALL, REINSTALDATABASE=1 и REINSTALLMODE=omus. При этом экземпляр будет перестроен, проверен и исправлен. Чаще всего эта процедура используется для перестроения реестра поврежденной установки SQL Server.

Примечание.
Чтобы перестроить реестр, необходимо использовать тот же пакетный файл и те же параметры, указанные при начальной установке. Если отсутствуют эти сведения, удалите и переустановите SQL Server вместо перестроения реестра.

Важно!
При возможности используйте проверку подлинности Windows. Не оставляйте пустым пароль sa. Всегда используйте надежные пароли.

Дополнительные сведения и пример вызова из командной строки см. в разделе Как установить SQL Server 2005 из командной строки.

См. также

Задачи

Как просмотреть файл журнала установки SQL Server 2005

Основные понятия

Как просмотреть файлы журналов установки SQL Server 2005


Как получить доступ к электронной документации по SQL Server 2005

Как получить доступ к электронной документации по SQL Server 2005 |
 | См. также
Установка компонентов SQL Server 2005 > Разделы руководства по установке компонентов SQL Server > Разделы руководства по установке компонента Database Engine >

Следующая процедура позволяет открыть электронную документацию по из меню Пуск на рабочем столе Microsoft Windows или найти каталог по умолчанию электронной документации по SQL Server 2005.

Получение доступа к электронной документации по SQL Server 2005 из меню «Пуск»

  1. В меню Программы, выберите пункт Microsoft SQL Server 2005, а затем Электронная документация по SQL Server.

  2. Откроется электронная документация по SQL Server 2005.

Получение доступа к электронной документации по SQL Server 2005 из проводника Windows

  1. Находясь на рабочем столе Windows, щелкните правой кнопкой мыши Пуск, а затем Проводник.

  2. Перейдите в каталог %ProgramFiles%\ \90\Tools\Books\1033. Это каталог для установки англоязычной версии электронной документации по SQL Server по умолчанию.
Примечание.
Если электронная документация по SQL Server была установлена на другом языке, отличном от английского, каталогом для установки электронной документации по SQL Server по умолчанию будет соответствующая этому языку папка в каталоге …\Tools\Books\.

См. также

Задачи

Как изменить компоненты существующего экземпляра SQL Server 2005 (программа установки)


Как получить доступ к электронной документации по SQL Server 2000

Как получить доступ к электронной документации по SQL Server 2000
Установка компонентов SQL Server 2005 > Разделы руководства по установке компонентов SQL Server > Разделы руководства по установке компонента Database Engine >

Ниже приведены сведения о расположении электронной документации по .

Доступ к электронной документации по SQL Server 2000 из меню «Пуск»

  1. Укажите Все программы, затем Microsoft SQLServer и выберите Электронная документация.

  2. Откроется электронная документация по SQL Server 2000.

Доступ к электронной документации по SQL Server 2000 из проводника Windows

  1. На рабочем столе Microsoft Windows щелкните правой кнопкой мыши кнопку Пуск и выберите Проводник.

  2. Перейдите в каталог %ProgramFiles%\\80\Tools\Books\. По умолчанию в этот каталог устанавливается англоязычная электронная документация по SQL Server.


Как получить доступ к электронной документации по SQL Server 7.0

Как получить доступ к электронной документации по SQL Server 7.0
Установка компонентов SQL Server 2005 > Разделы руководства по установке компонентов SQL Server > Разделы руководства по установке компонента Database Engine >

Чтобы открыть электронную документацию по 7.0 из меню Пуск или перейти в каталог установки электронной документации по SQL Server 7.0, используемый по умолчанию, выполните следующие действия.

Получение доступа к электронной документации по SQL Server 7.0 из меню «Пуск»

  1. Нажмите кнопку Пуск, укажите пункты Все программы, Microsoft SQL Server и выберите Электронная документация.

  2. В результате будет запущена электронная документация по SQL Server 7.0.

Получение доступа к электронной документации по SQL Server 7.0 из проводника Windows

  1. На рабочем столе Microsoft Windows щелкните правой кнопкой мыши кнопку Пуск и выберите Проводник.

  2. Перейдите в каталог %ProgramFiles%\MSSQL7\Books. По умолчанию в этот каталог устанавливается англоязычная электронная документация по SQL Server.


Разделы руководства по установке служб Analysis Services

Разделы руководства по установке служб Analysis Services |
 | См. также
Установка компонентов SQL Server 2005 > Разделы руководства по установке компонентов SQL Server >

В этом разделе содержатся следующие стандартные процедуры, применяемые для установки .

Описание типичных действий по обновлению предыдущей версии Analysis Services и миграции пакетов Analysis Services см. в разделе Разделы руководства по обновлению или миграции служб Analysis Services.

Важно!
В подразделах руководства по установке служб Analysis Services в данном разделе рассматриваются только параметры установки, специфичные для служб Analysis Services. Однако в этих подразделах содержатся ссылки на другие разделы, в которых можно получить дополнительные сведения об установке SQL Server.

В этом разделе

  • Как установить службы Analysis Services с помощью программы установки

  • Как установить службы Analysis Services из командной строки

  • Как установить службы Analysis Services на отказоустойчивом кластере

  • Как установить несколько экземпляров служб Analysis Services

  • Как установить службы Analysis Services параллельно с более ранней версией

  • Как переименовать экземпляр служб Analysis Services

  • Как добавить или удалить элементы экземпляров служб Analysis Services

  • Как удалить экземпляр служб Analysis Services

См. также

Основные понятия

Установка служб SQL Server Analysis Services


Как установить службы Analysis Services с помощью программы установки

Как установить службы Analysis Services с помощью программы установки |
 | См. также
Установка компонентов SQL Server 2005 > Разделы руководства по установке компонентов SQL Server > Разделы руководства по установке служб Analysis Services >

Установить службы можно с помощью мастера установки SQL Server или из командной строки. Мастер установки предлагает графический интерфейс пользователя, который помогает в выборе всех решений, принимаемых во время установки. Это предпочтительный метод для большинства пользователей. Мастер установки предлагает содействие в начальной настройке SQL Server 2005, включая выбор компонентов, правила именования экземпляров, настройке учетных записей служб, рекомендации по выбору надежного пароля и выбор параметров сортировки.

Важно!
Этот и другие подразделы руководства по установке служб Analysis Services в этом разделе описывают только параметры установки, характерные для служб Analysis Services. Однако в этих подразделах содержатся ссылки на другие разделы, в которых можно получить дополнительные сведения об установке SQL Server.

Установка служб Analysis Services с помощью мастера установки

  1. Запустите мастер установки SQL Server.

  2. При необходимости обратитесь к разделу Как установить SQL Server 2005 (программа установки), содержащему пошаговое описание мастера установки, особенно если вместе со службами Analysis Services устанавливаются и другие компоненты SQL Server.

  3. На странице Компоненты для установки мастера установки выберите Службы Analysis Services. Обратитесь к разделу Установка служб SQL Server Analysis Services с помощью программы установки для получения дополнительных сведений о других компонентах SQL Server, которые можно включить в установку, таких как документация, образцы и средства разработки.

  4. На странице Имя экземпляра выберите именованный экземпляр программы или экземпляр по умолчанию. Если экземпляр по умолчанию уже существует или если на компьютере уже присутствует экземпляр служб SQL Server 2000 Analysis Services, который не следует обновлять, можно выбрать только именованный экземпляр.

  5. На странице Учетная запись службы укажите имя пользователя, пароль и имя домена для служб Analysis Services и для учетных записей других служб SQL Server. Можно использовать одну учетную запись для всех служб.

  6. На странице Параметры сортировки укажите параметры сортировки по умолчанию. Можно указать один набор параметров сортировки для служб Analysis Services, а другой — для компонента SQL Server 2005 Database Engine, или указать одинаковые параметры сортировки для всех служб.

  7. Завершите работу мастера установки. На оставшихся страницах мастера нет параметров, имеющих отношение к службам Analysis Services.

См. также

Другие ресурсы

Разделы руководства по установке служб Analysis Services


Как установить службы Analysis Services из командной строки

Как установить службы Analysis Services из командной строки |
 | См. также
Установка компонентов SQL Server 2005 > Разделы руководства по установке компонентов SQL Server > Разделы руководства по установке служб Analysis Services >

Службы можно установить с помощью мастера установки SQL Server или из командной строки. Мастер установки предлагает графический интерфейс пользователя, который помогает в выборе всех решений, принимаемых во время установки. Этот метод предпочтителен для большинства пользователей. Установка из командной строки предназначена для использования в сложных вариантах развертывания продуктов, таких как удаленная установка и установка без запросов. Она может быть запущена непосредственно из командной строки или с помощью синтаксиса командной строки, ссылающегося на ini-файл, чтобы указать параметры установки.

Важно!
Этот и другие подразделы руководства по установке служб Analysis Services в этом разделе описывают только параметры установки, характерные для служб Analysis Services. Однако в этих подразделах содержатся ссылки на другие разделы, в которых можно получить дополнительные сведения об установке SQL Server.

Установка служб Analysis Services из командной строки

  1. Выберите, указывать ли параметры установки в командной строке или в ini-файле. Дополнительные сведения об использовании ini-файлов для указания этих параметров см. в разделе Как установить SQL Server 2005 из командной строки.

  2. Запустите из командной строки программу Setup.exe, задав необходимые параметры в командной строке или в ini-файле, как описано в разделе Как установить SQL Server 2005 из командной строки. Просмотрите сведения о параметрах установки, специфичных для Analysis Services в разделе Установка служб SQL Server Analysis Services из командной строки.

См. также

Другие ресурсы

Разделы руководства по установке служб Analysis Services


Как установить службы Analysis Services на отказоустойчивом кластере

Как установить службы Analysis Services на отказоустойчивом кластере |
 | См. также
Установка компонентов SQL Server 2005 > Разделы руководства по установке компонентов SQL Server > Разделы руководства по установке служб Analysis Services >

Службы можно установить на отказоустойчивом кластере, который благодаря службе Microsoft Cluster Service (MSCS) обеспечивает самую высокую надежность.

Важно!
Этот и другие разделы руководства по установке служб Analysis Services в этой главе описывают только параметры установки, относящиеся к службам Analysis Services. Однако в этих разделах содержатся ссылки на другие разделы, в которых можно получить дополнительные сведения об установке SQL Server.

Примечание.
Средство переименования экземпляра служб SQL Server 2005 Analysis Services (SSAS) не поддерживается в кластерах.

Установка служб Analysis Services на отказоустойчивом кластере

  1. Перед началом установки просмотрите документ Установка служб SQL Server Analysis Services с помощью программы установки, чтобы ознакомиться с параметрами, относящимися к службам Analysis Services, которые придется выбирать при установке.

  2. Просмотрите эти сведения и заполните все необходимые для кластеризованной установки предварительные реквизиты, которые приведены в документе Как создать новый отказоустойчивый кластер SQL Server 2005 (установка). Будьте готовы ввести уникальное имя экземпляра виртуального сервера и IP-адрес для кластеризованной установки служб Analysis Services, отличающиеся от имен и IP-адресов самого кластера и его узлов.

  3. Шаги, необходимые для установки служб SQL Server 2005 Analysis Services на отказоустойчивые кластеры, а также страницы мастера установки SQL Server при установке на отказоустойчивые кластеры одинаковы как для служб Analysis Services, так и для SQL Server 2005 Database Engine. Чтобы запустить мастер установки, выполните шаги, описанные в разделе Как создать новый отказоустойчивый кластер SQL Server 2005 (установка). Выберите соответствующие параметры служб Analysis Services на страницах Компоненты для установки, Имя экземпляра, Учетная запись службы и Параметры сортировки, как показано в Установка служб SQL Server Analysis Services с помощью программы установки.

См. также

Задачи

Как создать новый отказоустойчивый кластер SQL Server 2005 (установка)

Основные понятия

Подготовка к установке отказоустойчивого кластера
Установка служб SQL Server Analysis Services с помощью программы установки
Установка служб SQL Server Analysis Services из командной строки


Как установить несколько экземпляров служб Analysis Services

Как установить несколько экземпляров служб Analysis Services |
 | См. также
Установка компонентов SQL Server 2005 > Разделы руководства по установке компонентов SQL Server > Разделы руководства по установке служб Analysis Services >

На одном компьютере может быть запущено несколько экземпляров служб . Чтобы установить дополнительный экземпляр, запустите программу установки еще раз и укажите уникальное имя для нового экземпляра.

Важно!
Этот и другие подразделы руководства по установке служб Analysis Services в этом разделе описывают только параметры установки, характерные для служб Analysis Services. Однако в этих подразделах содержатся ссылки на другие разделы, в которых можно получить дополнительные сведения об установке SQL Server.

Установка дополнительного экземпляра служб Analysis Services

  1. Запустите программу установки с помощью мастера установки SQL Server или из командной строки. Дополнительные сведения о запуске программы установки с помощью мастера установки SQL Server см. в разделе Как установить службы Analysis Services с помощью программы установки. Дополнительные сведения о запуске программы установки из командной строки см. в разделе Как установить службы Analysis Services из командной строки.

  2. При использовании мастера установки SQL Server укажите уникальное имя экземпляра на странице Имя экземпляра. При запуске программы установки из командной строки укажите уникальное имя экземпляра с помощью параметра instancename.

См. также

Другие ресурсы

Разделы руководства по установке служб Analysis Services


Как установить службы Analysis Services параллельно с более ранней версией

Как установить службы Analysis Services параллельно с более ранней версией |
 | См. также
Установка компонентов SQL Server 2005 > Разделы руководства по установке компонентов SQL Server > Разделы руководства по установке служб Analysis Services >

Службы могут быть установлены параллельно с экземпляром служб Analysis Services SQL Server 2000. Однако экземпляр служб SQL Server 2000 Analysis Services всегда должен быть экземпляром по умолчанию, а экземпляр служб SQL Server 2005 Analysis Services всегда должен быть именованным экземпляром, поскольку SQL Server 2000 Analysis Services не поддерживает именованных экземпляров.

Если позже будет удален экземпляр служб SQL Server 2000 Analysis Services по умолчанию, то экземпляр служб SQL Server 2005 Analysis Services можно будет сделать экземпляром по умолчанию с помощью средства переименования экземпляра служб Analysis Services. Дополнительные сведения см. в разделе Как переименовать экземпляр служб Analysis Services.

Важно!
Этот и другие подразделы руководства по установке служб Analysis Services в этом разделе описывают только параметры установки, характерные для служб Analysis Services. Однако в этих подразделах содержатся ссылки на другие разделы, в которых можно получить дополнительные сведения об установке SQL Server.

Установка служб Analysis Services параллельно с более ранней версией

  1. Запустите программу установки с помощью мастера установки SQL Server или из командной строки. Дополнительные сведения о запуске программы установки с помощью мастера установки SQL Server см. в разделе Как установить службы Analysis Services с помощью программы установки. Дополнительные сведения о запуске программы установки из командной строки см. в разделе Как установить службы Analysis Services из командной строки.

  2. При использовании мастера установки SQL Server укажите уникальное имя экземпляра на странице Имя экземпляра. При запуске программы установки из командной строки укажите уникальное имя экземпляра с помощью параметра instancename.

См. также

Другие ресурсы

Разделы руководства по установке служб Analysis Services


Как переименовать экземпляр служб Analysis Services

Как переименовать экземпляр служб Analysis Services |
 | См. также
Установка компонентов SQL Server 2005 > Разделы руководства по установке компонентов SQL Server > Разделы руководства по установке служб Analysis Services >

Можно переименовать существующий экземпляр служб при помощи диалогового окна Переименование экземпляра.

Важно!
Этот и другие подразделы руководства по установке служб Analysis Services в этом разделе описывают только параметры установки, относящиеся к службам Analysis Services. Однако в этих подразделах содержатся ссылки на другие разделы, в которых можно получить дополнительные сведения об установке SQL Server.

Примечание.
На 64-разрядном компьютере необходимо использовать 64-разрядную версию средства переименования экземпляра.

Примечание.
Средство переименования экземпляра служб SQL Server 2005 Analysis Services (SSAS) не поддерживается в кластерах.

Подключение к экземпляру служб Analysis Services

  1. Запустите программу Переименование экземпляра (Instance Rename), файл asinstancerename.exe, из каталога C:\Program Files\Microsoft SQL Server\90\Tools\Binn\VSShell\Common7\IDE.

  2. В диалоговом окне Переименование экземпляра в списке Экземпляр для переименования выберите экземпляр, который необходимо переименовать.

  3. В поле Новое имя экземпляра введите новое имя для экземпляра.

  4. Проверьте правильность имени пользователя и пароля и нажмите кнопку Переименовать.

См. также

Другие ресурсы

Диалоговое окно «Переименование экземпляра» (службы Analysis Services)
Разделы руководства по установке служб Analysis Services
Управление и поддержка служб Analysis Services


Как добавить или удалить элементы экземпляров служб Analysis Services

Как добавить или удалить элементы экземпляров служб Analysis Services |
 | См. также
Установка компонентов SQL Server 2005 > Разделы руководства по установке компонентов SQL Server > Разделы руководства по установке служб Analysis Services >

Изменить возможности можно только с помощью раздела «Установка и удаление программ» панели управления Microsoft Windows.

Важно!
Этот и другие подразделы руководства по установке служб Analysis Services в этом разделе описывают только параметры установки, характерные для служб Analysis Services. Однако в этих подразделах содержатся ссылки на другие разделы, в которых можно получить дополнительные сведения об установке SQL Server.

Изменение компонентов установленного экземпляра служб SQL Server 2005 Analysis Services

  1. На рабочем столе Microsoft Windows нажмите кнопку Пуск, выберите пункт Панель управления и дважды щелкните значок Установка и удаление программ.

  2. В разделе Установленные программы выберите Microsoft SQL Server 2005 и нажмите кнопку Изменить. В результате будет запущен Мастер обслуживания Microsoft SQL Server 2005.

  3. На странице Выбор компонентов выберите экземпляр SQL Server 2005, включающий экземпляр служб Analysis Services, который нужно изменить.

  4. На странице Функциональное обслуживание выберите службы Analysis Services. После этого Мастер обслуживания Microsoft SQL Server 2005 запустит Мастер установки Microsoft SQL Server 2005.

  5. На странице Изменить или удалить экземпляр нажмите Изменить установленные компоненты.

  6. Нажмите кнопку Далее, а затем следуйте инструкциям на следующих страницах мастера.

См. также

Другие ресурсы

Разделы руководства по установке служб Analysis Services


Как удалить экземпляр служб Analysis Services

Как удалить экземпляр служб Analysis Services |
 | См. также
Установка компонентов SQL Server 2005 > Разделы руководства по установке компонентов SQL Server > Разделы руководства по установке служб Analysis Services >

Чтобы удалить экземпляр служб , выполните следующие действия.

Важно!
Этот и другие подразделы руководства по установке служб Analysis Services в этом разделе описывают только параметры установки, характерные для служб Analysis Services. Однако в этих подразделах содержатся ссылки на другие разделы, в которых можно получить дополнительные сведения об установке SQL Server.

Удаление экземпляра служб SQL Server 2005 Analysis Services

  1. Нажмите на рабочем столе Microsoft Windows кнопку Пуск, выберите Панель управления и дважды щелкните значок Установка и удаление программ.

  2. В разделе Установленные программы выберите Microsoft SQL Server 2005 и нажмите кнопку Изменить. В результате будет запущен Мастер обслуживания Microsoft SQL Server 2005.
Примечание.
Если нажать кнопку Удалить вместо Изменить, то будет невозможно удалить экземпляр службAnalysis Services без удаления компонента SQL Server Database Engine и служб Reporting Services, установленных на экземпляре SQL Server 2005 с этим же именем.

  1. На странице Выбор компонентов выберите экземпляр SQL Server 2005, включающий экземпляр служб Analysis Services, который нужно удалить.

  2. На странице Функциональное обслуживание выберите службы Analysis Services. После этого Мастер обслуживания Microsoft SQL Server 2005 запустит Мастер установки Microsoft SQL Server 2005.

  3. На странице Изменить или удалить экземпляр щелкните Удалить Microsoft SQL Server.

  4. Нажмите кнопку Далее, а затем следуйте инструкциям на следующих страницах мастера.

См. также

Другие ресурсы

Разделы руководства по установке служб Analysis Services


Разделы руководства по установке служб Reporting Services

Разделы руководства по установке служб Reporting Services |
 | См. также
Установка компонентов SQL Server 2005 > Разделы руководства по установке компонентов SQL Server >

Этот раздел содержит операции установки служб Reporting Services.

В этом разделе

  • Как установить службы Reporting Services на один компьютер

  • Как установить локальную и удаленную базу данных сервера отчетов

  • How to: Install Reporting Services Side-by-Side with an Earlier Version

  • Как удалить экземпляр служб Reporting Services

  • Как проверить установки служб Reporting Services

  • Как устранять неполадки при установке служб Reporting Services

  • Как устранить неполадки при параллельной установке служб Reporting Services версий SQL Server 2000 и SQL Server 2005

  • Как настроить службы IIS для запуска 32-разрядных служб Reporting Services в режиме WOW64

См. также

Основные понятия

Обновление служб Reporting Services
Установка служб SQL Server Reporting Services

Другие ресурсы

Разделы руководства по установке компонентов SQL Server
Сведения об удаленной установке SQL Server 2005


Как установить службы Reporting Services на один компьютер

Как установить службы Reporting Services на один компьютер |
 | См. также
Установка компонентов SQL Server 2005 > Разделы руководства по установке компонентов SQL Server > Разделы руководства по установке служб Reporting Services >

Чтобы установить полный набор клиентских и серверных компонентов на один компьютер, воспользуйтесь следующими процедурами. В дополнение к клиентским и серверным компонентам эти инструкции включают также шаги для установки следующих компонентов.

  • Ядро СУБД, которое используется для размещения базы данных сервера отчетов и которое необходимо для установки сервера отчетов в конфигурации по умолчанию.

  • Примеры служб Reporting Services, полезные для ознакомления с возможностями служб Reporting Services. Заметьте, что программа установки SQL Server 2005 только копирует программу установки примеров на жесткий диск. После завершения установки следует запустить программу установки примеров, чтобы установить файлы, а затем загрузить примеры на сервер отчетов.

Эти инструкции предполагают, что службы Reporting Services устанавливаются впервые. Если обновляются службы Reporting Services или они устанавливаются повторно, нельзя будет использовать вариант установки с конфигурацией по умолчанию. В этом случае, чтобы закончить конфигурирование сервера отчетов, после завершения программы установки следует запустить программу настройки служб Reporting Services и средство конфигурирования контактной зоны. Дополнительные сведения см. в разделе Обновление служб Reporting Services.

Установите клиентские и серверные компоненты на один компьютер

  1. Запустите программу установки.

  2. На странице Компоненты для установки выберите Службы SQL Server Database Services, Службы Reporting Services и Компоненты рабочих станций, электронная документация и средства разработки.

  3. Нажмите кнопку Дополнительно.

  4. В разделе Клиентские компоненты откройте Документация, образцы кода и баз данных.

  5. Выберите Образцы баз данных. Если требуется выполнить все образцы отчетов, следует выбрать обе базы данных AdventureWorks. Выберите Все компоненты будут установлены на локальный жесткий диск.

  6. Выберите Образцы кода и приложений. Выберите Все компоненты будут установлены на локальный жесткий диск. Нажмите кнопку Далее.

  7. На странице Имя экземпляра выберите Экземпляр по умолчанию. Нажмите кнопку Далее.

  8. На странице Учетная запись службы укажите учетную запись пользователя домена. В пункте Запустить службы по завершении установки выберите Агент SQL Server. Нажмите кнопку Далее.

  9. На странице Режим проверки подлинности укажите Проверка подлинности Windows. Нажмите кнопку Далее.

  10. На странице Параметры сортировки оставьте значение по умолчанию. Нажмите кнопку Далее.

  11. На странице Параметры установки сервера отчетов выберите Установить конфигурацию по умолчанию. Нажмите кнопку Далее.

  12. На странице Параметры отчетов об ошибках и использовании нажмите кнопку Далее.

  13. Чтобы начать установку, нажмите кнопку Установить.

Настройте конфигурацию сервера отчетов и установите примеры

  1. В меню Пуск выберите Все программы, затем выберите Microsoft SQL Server 2005, затем выберите Средства конфигурации, а затем выберите Настройка контактной зоны SQL Server.

  2. В программе конфигурации контактной зоны для служб и соединений убедитесь, что служба сервера отчетов Windows запущена. В настройке контактной зоны для функциональных возможностей убедитесь, что включен параметр Запланированные события и доставка отчетов. Убедитесь, что параметр Запросы HTTP и веб-служб включен. Убедитесь, что включена встроенная безопасность Windows.

  3. Запустив диспетчер отчетов, убедитесь, что установка успешно завершена. В строке URL-адреса введите https://localhost/reports или http://localhost/reports. Должна отобразиться корневая страница диспетчера отчетов. Если сервер отчетов установлен как именованный экземпляр, то URL-адрес будет другим. Дополнительные сведения см. в разделе Настройка виртуальных каталогов сервера отчетов.

  4. Чтобы установить примеры, нажмите кнопку Пуск, наведите курсор на пункт Все программы, наведите курсор на пункт Microsoft SQL Server 2005, наведите курсор на пункт Документация и учебные материалы, наведите курсор на пункт Примеры и выберите пункт Примеры Microsoft SQL Server 2005. Воспользуйтесь мастером установки, чтобы установить примеры.

  5. Для публикации отчетов используйте среду Business Intelligence Development Studio. Нажмите кнопку Пуск, укажите пункты Все программы и Microsoft SQL Server 2005, а затем выберите пункт среда Business Intelligence Development Studio.

  6. В меню Файл выберите пункт Открыть проект/решение.

  7. В каталоге C:\Program Files\Microsoft SQL Server\90\Samples\Reporting Services\Report Samples\AdventureWorks Sample Reports выберите файл AdventureWorks Sample Reports.sln. Нажмите кнопку Открыть.

  8. В меню Построить выберите пункт Развернуть решение. Если не удается развернуть решение, откройте каждый отчет, а затем попытайтесь повторить развертывание. Состояние успешного развертывания будет показано в окне «Вывод». В нем можно будет увидеть Развертывание в http://localhost/reportserver в окне «Вывод» и состояние для каждого отчета и источника данных, загруженного на сервер.

  9. Открыть диспетчер отчетов. Если он уже открыт, нажмите кнопку Обновить в обозревателе, чтобы показать опубликованные элементы.

  10. Откройте папку AdventureWorks Samples. Щелкните отчет, чтобы открыть его.
Примечание.
В образце отчета «Сопоставление причин покупки» используется база данных служб Analysis Services. В отчете имеются дополнительные требования, которые должны быть удовлетворены перед его запуском. Дополнительные сведения см. в разделе Образцы отчетов AdventureWorks.

См. также

Задачи

Как установить SQL Server 2005 (программа установки)
Как проверить установки служб Reporting Services

Основные понятия

Установка служб SQL Server Reporting Services

Другие ресурсы

Учебники по службам Reporting Services
Образцы служб SQL Server Reporting Services
Разделы руководства по установке служб Reporting Services
Как передавать образцы отчетов на сервер (диспетчер отчетов)
Программа конфигурации служб Reporting Services


Как установить локальную и удаленную базу данных сервера отчетов

Как установить локальную и удаленную базу данных сервера отчетов |
 | См. также
Установка компонентов SQL Server 2005 > Разделы руководства по установке компонентов SQL Server > Разделы руководства по установке служб Reporting Services >

Хранение базы данных сервера отчетов на удаленном экземпляре ядра СУБД SQL Server требует дополнительных шагов конфигурации после завершения установки. Необходимо обладать разрешениями администратора как на локальном, так и на удаленном компьютере. Оба компьютера должны находиться в одном домене или в доверенном домене.

Примечание.
Следующая процедура предназначена для операционной системы Windows Server 2003. Если используется другая операционная система, шаги могут быть иными.

Установить локальную и удаленную базу данных сервера отчетов

  1. Запустите программу установки. Дополнительные сведения см. в разделе Как установить SQL Server 2005 (программа установки).

  2. На странице Выбор компонентов выберите пункт Службы Reporting Services. Нажмите кнопку Далее.

  3. На странице Имя экземпляра выберите пункт Экземпляр по умолчанию. Нажмите кнопку Далее.

  4. На странице Учетная запись службы укажите учетную запись пользователя домена. Если необходима поддержка отложенных действий, следует убедиться, что служба агента SQL Server запускается автоматически. В пункте Запуск служб в конце установки выберите Агент SQL Server. Нажмите кнопку Далее.

  5. На странице Режим проверки подлинности укажите Проверка подлинности Windows. Нажмите кнопку Далее.

  6. На странице Параметры установки сервера отчетов выберите пункт Установить, но не настраивать сервер. Нажмите кнопку Далее.

  7. На странице Настройка параметров отчета об ошибках и использовании нажмите кнопку Далее.

  8. Чтобы начать установку, нажмите кнопку Установить.

Настроить сервер отчетов и создать удаленную базу данных

  1. В меню Пуск последовательно выберите пункты Программы, Microsoft SQL Server 2005, Средства настройки и Настройка контактной зоны SQL Server.

  2. В программе конфигурации контактной зоны для служб и соединений убедитесь, что служба сервера отчетов Windows запущена.

  3. В настройке контактной зоны для функциональных возможностей убедитесь, что включен параметр Запланированные события и доставка отчетов. Убедитесь, что параметр Запросы HTTP и веб-служб включен. Убедитесь в том, что включена Встроенная безопасность Windows.

  4. Откройте приложение Настройка служб Reporting Services. В меню Пуск последовательно выберите пункты Все программы, Microsoft SQL Server 2005, Средства настройки и Настройка служб Reporting Services.

  5. Выберите экземпляр локального сервера отчетов, который был только что установлен. Нажмите кнопку Соединить.

  6. Настройте учетную запись веб-службы и виртуальные каталоги. Если используется операционная система Windows XP или Windows Server 2000, необходимо использовать учетную запись ASP.NET по умолчанию. Если используется Windows Server 2003, можно указать пользовательскую учетную запись.

  7. Настройте базу данных.

    1. Откройте страницу «Установка базы данных».

    2. В поле Имя сервера выберите удаленный экземпляр ядра СУБД SQL Server, а затем нажмите кнопку Соединить. Необходимы разрешения на создание базы данных и настройку ролей на этом сервере. Чтобы создать базу данных, программа настройки служб Reporting Services будет использовать учетные данные.

    3. Чтобы создать новую базу данных сервера отчетов, нажмите кнопку Создать. Откроется диалоговое окно соединения с сервером SQL Server. Введите имя новой базы данных и учетные данные, используемые для ее создания, затем нажмите кнопку ОК.

      Если нужно использовать уже существующую базу данных сервера отчетов, можно выбрать ее вместо создания новой. Если нужно обновить базу данных сервера отчетов SQL Server 2000 до новой схемы, нажмите кнопку Обновить. Обновление базы данных необходимо в том случае, если ее планируется использовать со службами Reporting Services версии SQL Server 2005 (отметим, что после обновления базы данных откатить этот шаг будет нельзя, поэтому проследите, чтобы перед выполнением этого шага имелась резервная копия базы данных).

    4. В поле Тип учетных данных выберите тип учетной записи, используемой для подключения сервера отчетов к базе данных сервера отчетов. Можно использовать учетные данные учетной записи службы, учетной записи домена Windows или имя входа сервера SQL Server.

    5. При выборе учетных данных Windows или SQL Server введите имя пользователя и пароль, которые сервер отчетов использует для подключения к базе данных сервера отчетов. Дополнительные сведения см. в разделе Настройка соединения с базой данных сервера отчетов.

    6. Чтобы сохранить изменения, нажмите кнопку Применить.

  8. Настройте другие параметры согласно потребностям, а затем проверьте установку. Дополнительные сведения см. в разделе Как проверить установки служб Reporting Services.

Следует заметить, что некоторые выпуски SQL Server 2005 обладают различными установленными по умолчанию параметрами для удаленных соединений. Если сервер отчетов не может подключиться к базе данных, проверьте, включены ли удаленные соединения. Инструкции по настройке см. в пункте «Как настроить удаленные соединения для базы данных сервера отчетов» в разделе Настройка сервера отчетов для удаленного администрирования.

См. также

Задачи

Как установить SQL Server 2005 (программа установки)

Справочник

Настройка учетных записей служб Windows

Основные понятия

Установка служб SQL Server Reporting Services

Другие ресурсы

Устранение неполадок при соединении с сервером и базой данных
Разделы руководства по установке служб Reporting Services
Программа конфигурации служб Reporting Services


How to: Install Reporting Services Side-by-Side with an Earlier Version

How to: Install Reporting Services Side-by-Side with an Earlier Version |
 | См. также
Установка компонентов SQL Server 2005 > Разделы руководства по установке компонентов SQL Server > Разделы руководства по установке служб Reporting Services >

Можно установить несколько версий служб Reporting Services, при этом экземпляр служб Reporting Services SQL Server 2000 будет работать параллельно экземпляру служб Reporting Services SQL Server 2005.

Примечание.
При установке платформы .NET Framework 2.0 или регистрации ASP.NET 2.0 на сервере, на котором работают службы IIS 5.0 или в режиме совместимости IIS 5.0, имеющаяся на этом сервере установка служб SQL Server 2000 Reporting Services может прекратить работу. Дополнительные сведения о том, как возобновить работу сервера, см. в разделе Как устранить неполадки при параллельной установке служб Reporting Services версий SQL Server 2000 и SQL Server 2005.

Для параллельного запуска двух версий необходимо установить SQL Server 2005 как именованный экземпляр, а SQL Server 2000 продолжать запускать как экземпляр по умолчанию. SQL Server 2000 не поддерживает именованные экземпляры и не может быть настроен для работы в этом качестве.

При работе двух версий служб Reporting Services на одном компьютере следует учитывать следующие особенности.

  • Компонент SQL Server 2000 Database Engine может использоваться для хранения базы данных сервера отчетов SQL Server 2005.

  • Виртуальные каталоги должны быть уникальными для каждого экземпляра сервера отчетов и диспетчера отчетов. Рассмотрите возможность добавления имени экземпляра или сведений о версии к имени каждого виртуального каталога, чтобы отличать каждый компонент (например, используйте имена ReportServer2005 и Reports2005 для виртуальных каталогов, созданных для компонентов SQL Server 2005).

  • Для всех виртуальных каталогов можно использовать один и тот же веб-узел. Однако следует создать отдельный пул приложений для приложений сервера отчетов и диспетчера отчетов SQL Server 2005.

  • Пространства имен отчетов и конечные точки SOAP для каждой из версий различны. Дополнительные сведения см. в разделе Улучшенные возможности программирования служб Reporting Services электронной документации по SQL Server.

  • Файлы определения отчетов (RDL), создаваемые в версии конструктора отчетов для SQL Server 2005, могут быть опубликованы только на сервере отчетов SQL Server 2005.

  • Файлы определения отчетов (RDL), создаваемые в версии конструктора отчетов для SQL Server 2000, могут быть опубликованы как на сервере отчетов SQL Server 2000, так и на сервере отчетов SQL Server 2005. При публикации RDL-файла SQL Server 2000 на сервере отчетов SQL Server 2005 он будет преобразован и сохранен на сервере отчетов в формате SQL Server 2005. При открытии отчета SQL Server 2000 в версии SQL Server 2005 конструктора отчетов будет предложено произвести его обновление. Дополнительные сведения см. в разделе Обновление отчетов.

  • Программа настройки служб Reporting Services не может применяться для настройки сервера отчетов SQL Server 2000. Однако можно воспользоваться средой Management Studio для соединения с сервером отчетов SQL Server 2000. Обратите внимание, что при установке различных версий служб Reporting Services каждая из установок имеет собственный экземпляр диспетчера отчетов, который может работать только для этой установки. Скорее всего, в разных версиях диспетчера отчетов будут заметны небольшие различия.

Новую и предыдущую версии конструктора отчетов можно запускать параллельно. В этом случае убедитесь, что для обоих экземпляров установлены (и работают) различные версии среды Visual Studio.

  • Для конструктора отчетов SQL Server 2000 требуется Visual Studio 2003. Он не работает в Visual Studio 2005. Можно публиковать отчеты из конструктора отчетов SQL Server 2000 на сервере отчетов SQL Server 2005.

  • SQL Server 2005 работает в среде Visual Studio 2005. Если среда Visual Studio 2005 не установлена, программа установки установит версию оболочки Visual Studio, необходимую для запуска конструктора отчетов. Конструктор отчетов SQL Server 2005 не может применяться для публикации отчетов на сервере отчетов SQL Server 2000.

Установка служб Reporting Services параллельно с более ранней версией

  1. Запустите программу установки SQL Server 2005. После этого необходимо выполнить следующие действия:

    1. Укажите уникальное имя экземпляра на странице Имя экземпляра или в аргументе instancename, если установка производится из командной строки.

    2. Укажите при установке сервера отчетов режим «Только файлы». Для этого установите параметр Установить, но не настраивать на странице Параметры установки сервера отчетов в мастере установки SQL Server или аргумент RSCONFIGURATION=filesonly в командной строке.

  2. После завершения установки запустите программу настройки служб Reporting Services, чтобы развернуть новый экземпляр SQL Server 2005.

  3. Подключитесь к только что установленному экземпляру сервера отчетов. Для этого укажите имя сервера и имя именованного экземпляра SQL Server, а затем нажмите Соединить.

  4. На страницах «Виртуальный каталог сервера отчетов» и «Виртуальный каталог диспетчера отчетов» укажите уникальные виртуальные каталоги для сервера отчетов и диспетчера отчетов. Эти имена не могут совпадать с именами, используемыми в экземпляре SQL Server 2000.

    Настройка учетных записей службы Windows и веб-службы Web будет произведена автоматически после указания виртуальных каталогов. В ряде случаев автоматическая настройка для учетной записи веб-службы может завершиться неудачно. Если используются службы IIS 6.0, эту проблему можно разрешить, указав другой пул приложений.

  5. На странице «Настройка базы данных» подключитесь к экземпляру SQL Server, на котором необходимо разместить базу данных сервера отчетов. По умолчанию указан локальный экземпляр компонента Database Engine. При необходимости введите имя другого сервера. Для соединения с сервером нажмите кнопку Соединить.

  6. Нажмите кнопку Создать, чтобы создать новую базу данных сервера отчетов. В диалоговом окне «Подключение к SQL Server» введите имя базы данных. При соединении с удаленным сервером SQL Server укажите учетные данные с разрешениями на создание базы данных. Нажмите кнопку ОК.

  7. Можно также указать учетные данные, которыми сервер отчетов будет пользоваться для соединения с базой данных. По умолчанию используется учетная запись службы. Нажмите кнопку Применить для сохранения изменений в конфигурации базы данных.

  8. На странице «Ключи шифрования» создайте резервную копию ключей.

  9. Для проверки работоспособности нового экземпляра можно произвести публикацию образцов отчетов, а затем просмотреть их при помощи диспетчера отчетов. Не забудьте указать виртуальный каталог диспетчера отчетов, который определен для нового экземпляра. Пошаговые инструкции по публикации образцов отчетов см. в разделе «Настройка сервера отчетов и установка образцов» в подразделе Как опубликовать образцы отчетов (конструктор отчетов) электронной документации по SQL Server.

См. также

Задачи

Как запустить настройку служб Reporting Services

Справочник

Имя экземпляра

Основные понятия

Установка служб Reporting Services с помощью программы установки
Настройка виртуальных каталогов сервера отчетов
Установка служб SQL Server Reporting Services

Другие ресурсы

Разделы руководства по установке служб Reporting Services
Программа конфигурации служб Reporting Services


Как установить объектную модель службы Windows SharePoint Services на компьютер сервера отчетов

Как установить объектную модель службы Windows SharePoint Services на компьютер сервера отчетов |
 | См. также
Установка компонентов SQL Server 2005 > Разделы руководства по установке компонентов SQL Server > Разделы руководства по установке служб Reporting Services >

При настройке сервера отчетов на работу в режиме интеграции с SharePoint в развертывании распределенного сервера, предполагающем размещение сервера отчетов и экземпляра технологии SharePoint на отдельных компьютерах, необходимо установить локальный экземпляр объектной модели Windows SharePoint Services 3.0 для установки фермы на компьютере сервера отчетов. В развертывании распределенного сервера, сервер отчетов использует объектную модель для доступа к базам данных SharePoint.

Объектная модель не может быть установлена как отдельный компонент. Однако можно установить фронтальный веб-сервер для объединения с сервером отчетов в ферму SharePoint. Настройка фронтального веб-сервера обеспечивает данные подключения, используемые сервером отчетов для подключения к ферме.

Примечание.
Локальный экземпляр объектной модели необходим только в случае, если серверные продукты интегрируются в топологию распределенного сервера, предусматривающую размещение каждого сервера на отдельном компьютере. При интеграции сервера отчетов и продукта или технологии SharePoint на одном компьютере (то есть при использовании двух серверных технологий параллельно) нет необходимости в установке фронтального веб-сервера.

Чтобы установить фронтальный веб-сервер, необходимо быть администратором фермы SharePoint. Необходимо также знать имя сервера базы данных и базы данных конфигурации, используемой развертыванием технологии SharePoint, для которого настраивается интеграция сервера отчетов.

Установка объектной модели служб Windows SharePoint Services

  1. На сервере, где выполняется Reporting Services, запустите программу установки для Windows SharePoint Services 3.0.

  2. В разделе «Типы установки» нажмите кнопку Дополнительно.

  3. В разделе «Тип сервера» выберите Фронтальный веб-сервер.

  4. Нажмите кнопку Установить.

Настройка объектной модели служб Windows SharePoint Services

  1. Запустите мастер настройки продуктов и технологий SharePoint, чтобы объединить фронтальный веб-сервер с удаленной фермой SharePoint.

  2. На странице «Подключиться к ферме серверов» нажмите кнопку Да, чтобы подключиться к существующей ферме серверов. Нажмите кнопку Далее.

  3. На странице «Настройки базы данных конфигурации» укажите экземпляр SQL Server Database Engine, где расположена база данных конфигурации. Если имя базы данных конфигурации неизвестно, нажмите кнопку Получить имена баз данных и выберите нужную базу данных конфигурации.

  4. Введите имя пользователя и пароль, которые будут использоваться фронтальным веб-сервером для подключения к базе данных конфигурации. Нажмите кнопку Далее.

  5. На странице «Завершение работы мастера настройки продуктов и технологий SharePoint» нажмите кнопку Дополнительные настройки.

  6. На странице дополнительных настроек убедитесь в том, что выбран параметр Не использовать этот компьютер для размещения веб-узла.

  7. Нажмите кнопку ОК, нажмите кнопку Далее и завершите работу мастера.

Установка фронтального веб-сервера — всего лишь один шаг в общем процессе настройки. Дополнительные сведения о полном наборе шагов см. в разделе Настройка служб Reporting Services для интеграции с SharePoint 3.0.

См. также

Основные понятия

Интеграция служб Reporting Services и технологии SharePoint
Установка надстройки службы Reporting Services
Режимы развертывания для служб Reporting Services
Требования для запуска служб Reporting Services в режиме интеграции с SharePoint
Настройка служб Reporting Services для интеграции с SharePoint 3.0


Как удалить надстройку для использования служб Reporting Services

Как удалить надстройку для использования служб Reporting Services |
 | См. также
Установка компонентов SQL Server 2005 > Разделы руководства по установке компонентов SQL Server > Разделы руководства по установке служб Reporting Services >

Новое содержимое: 12 декабря 2006 г.

Можно удалить надстройку службы Reporting Services для технологий SharePoint, запустив программу установки в режиме удаления. При удалении надстройки будут удалены функции интеграции сервера, используемые для обработки отчетов и моделей на сервере отчетов.

Удаление надстройки выполняется одинаково для изолированных серверов и для ферм серверов. С помощью программы установки удаляются программные файлы и настройки конфигурации, добавленные во время установки.

Программой установки не будет удалено следующее:

  • Имена входа, созданные для учетной записи веб-службы сервера отчетов и службы Windows сервера отчетов, используемые для доступа к базам данных конфигурации и содержимого SharePoint. Необходимо удалить эти имена входа из экземпляра SQL Server Database Engine, используемого для размещения баз данных SharePoint.

  • Разрешения или группы, созданные для пользователей отчетов. Если были созданы пользовательские уровни разрешений или группы SharePoint для предоставления доступа к функциям сервера отчетов, можно отменить любые разрешения, необходимость в которых отпала.

  • Файлы данных, загруженные в библиотеку SharePoint, включая файлы определения отчета (RDL), модели отчета (SMDL) и общего источника данных (RSDS). Они не удаляются, но их выполнение становится невозможным. Удаление файлов необходимо произвести вручную.

Программой установки не будет удалена база данных сервера отчетов или изменен экземпляр сервера отчетов, используемый для операций в режиме интеграции. После удаления надстройки целесообразным будет переключение сервера отчетов в собственный режим, если этот экземпляр планируется использовать как изолированное приложение для обработки отчетов.

Удаление надстройки службы Reporting Services

  1. Удалите все отчеты и другие элементы сервера отчетов, которые более не используются. Их выполнение будет невозможным после удаления надстройки службы Reporting Services.

  2. В разделе Установка и удаление программ панели управления выберите «Надстройка службы Microsoft SQL Server 2005 Reporting Services для использования технологий Microsoft SharePoint».

  3. Щелкните Удалить.

См. также

Задачи

Как переключать режимы сервера (конфигурация служб Reporting Services)

Основные понятия

Установка надстройки службы Reporting Services
Хранение и синхронизация содержимого сервера отчетов с помощью баз данных SharePoint
Просмотр и управление элементами сервера отчетов с узла SharePoint


Как удалить экземпляр служб Reporting Services

Как удалить экземпляр служб Reporting Services |
 | См. также
Установка компонентов SQL Server 2005 > Разделы руководства по установке компонентов SQL Server > Разделы руководства по установке служб Reporting Services >

С помощью программы установки можно удалить службы SQL Server Reporting Services или их отдельные компоненты. И мастер установки, и программа установки из командной строки, позволяют удалять установленные службы и изменять их состав. Если выбрано полное удаление, некоторые файлы и учетные записи останутся после завершения удаления. Базы данных, файлы журнала, файлы определений отчетов, файлы моделей, проектов, решения и ожидающие обработки задания нужно удалить вручную. В этом разделе содержатся инструкции о том, как удалить элементы, которые остались после удаления программного обеспечения. Сведения о том, как удалить запланированные процессы отчета, которые находятся в очереди, см. в разделе Просмотр и изменение заданий.

Примечание.
Если на одном компьютере установлены 32-разрядные и 64-разрядные версии служб Reporting Services, для удаления 64-разрядной версии служб Reporting Services необходимо воспользоваться 64-разрядной версией программы установки. Для удаления 64-разрядной версии служб Reporting Services нельзя использовать 32-разрядную версию программу установки.

Удаление баз данных сервера отчетов

  1. С помощью среды Management Studio или программы Enterprise Manager (если база данных размещается на сервере SQL Server 2000) подключитесь к экземпляру компонента SQL Server Database Engine, на котором размещены базы данных.

  2. Удалите базы данных. Если использовались имена по умолчанию, их именами будут reportserver и reportservertemp. Чтобы проверить фактические имена файлов, можно запустить программу настройки служб Reporting Services и найти имя базы данных на странице «Настройка базы данных».

  3. Вручную удалите роль базы данных RSExecRole из баз данных Master и MSDB.

Удаление файлов данных

  1. Найдите на жестком диске файлы следующих типов:

    файлы определений отчетов (RDL), семантических моделей (SMDL), общих источников данных (RDS), проектов отчетов (RPTPROJ) и решений (SLN).

  2. Удалите файлы.

Удаление образцов

  • С помощью средства Установка и удаление программ удалите образцы отчетов и приложений служб Reporting Services. Программа установки удалит только установленные ею файлы. Если были созданы дополнительные файлы пользовательских настроек или в папки примеров добавлялись другие файлы, они останутся после завершения удаления. Файлы образцов находятся в папке Tools\Samples\<язык >\ReportingServices.

Удаление файлов журнала

  1. Откройте папку файлов журнала. Файлы журнала находятся в папке «Reporting Services\Log Files».

  2. Удалите файлы.

См. также

Другие ресурсы

Разделы руководства по установке служб Reporting Services


Как проверить установки служб Reporting Services

Как проверить установки служб Reporting Services |
 | См. также
Установка компонентов SQL Server 2005 > Разделы руководства по установке компонентов SQL Server > Разделы руководства по установке служб Reporting Services >

Если сервер отчетов устанавливается в конфигурации по умолчанию, то программа установки проводит установку и развертывание сервера.Можно проверить, развернула ли программа установки сервер отчетов, выполнив несколько простых тестов.Для выполнения этих шагов необходимо быть локальным администратором.Чтобы тестирование могли выполнить другие пользователи, необходимо сконфигурировать доступ к серверу отчетов для этих пользователей.Дополнительные сведения см. в разделе Контрольный список развертывания сервера электронной документации по SQL Server.

Примечание.
Учебные материалы по службам Reporting Services могут помочь в быстром приобретении важных навыков. Имеется также учебное пособие, в котором поясняется предназначение каждого средства. В нем объясняется, как запустить инструмент, и демонстрируется внешний вид каждого средства при первом запуске. Можно использовать этот учебный материал, чтобы убедиться в правильной установке всех средств. Дополнительные сведения см. в разделах Учебники по службам Reporting Services и Учебник. Инструментальные средства служб Reporting Services электронной документации по SQL Server.

Проверка успешной установки и запуска сервера отчетов

  1. Запустите программу настройки служб Reporting Services, подключитесь к экземпляру сервера отчетов, который только что был установлен, и проверьте по индикатору состояния, что настроены все параметры.

  2. Откройте окно служб и проверьте, что служба Windows сервера отчетов запущена.Для просмотра состояния службы Windows сервера отчетов нажмите кнопку Пуск, выберите Панель управления, дважды щелкните элемент Администрирование и откройте окно Службы.Когда появится список служб, найдите службу Сервер отчетов (MSSQLSERVER).Состояние службы должно быть Запущен.

  3. Откройте обозреватель и в строке адреса введите URL-адрес сервера отчетов.Адрес должен состоять из имени сервера и имени виртуального каталога, которое было определено во время установки сервера отчетов.По умолчанию имя виртуального каталога сервера отчетов ReportServer.Можно использовать следующий URL-адрес для проверки установки сервера отчетов:http://<имя компьютера>/ReportServer<имя экземпляра>. URL-адрес будет другим, если сервер отчетов установлен как именованный экземпляр. Дополнительные сведения о формате URL-адреса см. в разделе Настройка виртуальных каталогов сервера отчетов.

  4. Запустите отчет, чтобы проверить работу сервера отчетов.Для выполнения этого шага можно установить и опубликовать образцы отчетов, если нет какого-либо доступного отчета.Дополнительные сведения см. в разделе Образцы отчетов AdventureWorks электронной документации по SQL Server.

Проверка успешной установки и запуска диспетчера отчетов

  1. Откройте обозреватель и в строке адреса введите URL-адрес диспетчера отчетов.Адрес должен состоять из имени сервера и имени виртуального каталога, которое было определено во время установки диспетчера отчетов.По умолчанию виртуальный каталог диспетчера отчетов называется Reports.Можно использовать следующий URL-адрес для проверки установки диспетчера отчетов:http://<имя компьютера>/Reports<имя экземпляра>.

  2. Используйте диспетчер отчетов для создания новой папки или передачи файла с целью проверки, возвращаются ли определения обратно в базу данных сервера отчетов.Если эти операции успешно завершаются, то соединение функционирует.

Проверка успешной установки и запуска конструктора отчетов

  1. Откройте среду Business Intelligence Development Studio и создайте новый проект, основанный на типе проекта сервера отчетов.Дополнительные сведения об использовании мастера проектов сервера отчетов см. в разделе Как создать проект сервера отчетов (конструктор отчетов) электронной документации по SQL Server.

  2. Если установлены образцы отчетов, откройте файлы образцов проектов отчетов и опубликуйте отчеты на сервере отчетов.Дополнительные сведения см. в разделе Отладка и публикация отчетов электронной документации по SQL Server.

  3. Запустите файл сценария (RSS) в среде исполнения сценариев, чтобы проверить работу веб-службы на заданном сервере отчетов.Дополнительные сведения о запуске образца сценария см. в разделе Образцы сценариев (службы Reporting Services) электронной документации по SQL Server.

См. также

Другие ресурсы

Устранение ошибок HTTP
Устранение неполадок при соединении с сервером и базой данных
Причины ошибок служб Reporting Services и способы их устранения
Разделы руководства по установке служб Reporting Services


Как устранять неполадки при установке служб Reporting Services

Как устранять неполадки при установке служб Reporting Services |
 | См. также
Установка компонентов SQL Server 2005 > Разделы руководства по установке компонентов SQL Server > Разделы руководства по установке служб Reporting Services >

Процесс установки служб SQL Server 2005 Reporting Services поддерживает два режима установки: установка экземпляра служб Reporting Services в конфигурации по умолчанию и установка в режиме «только файлы», при которой файлы программы копируются на диск. Если при установке появляются проблемы, рассмотрите возможность установки в режиме «только файлы». Впоследствии при настройке сервера отчетов для работы можно будет изменить настройки компьютера или среды выполнения, чтобы они поддерживали функционирование сервера отчетов. Если появляются проблемы при установке в режиме «только файлы», для решения проблемы воспользуйтесь сведениями из этого раздела.

Проверка наличия необходимых компонентов

  1. Должны быть установлены службы IIS (Internet Information Services) версии 5.0 или выше.

  2. В системе Windows Server 2003 службы IIS не должны быть настроены для работы в режиме изоляции IIS 5.0.

  3. Учетная запись IWAM_имя компьютера не должна быть настроена как перемещаемый профиль.

  4. Должны быть установлены компоненты MDAC версии 2.6 или выше.

  5. Должен быть запущен координатор распределенных транзакций (DTC).

Со службами IIS должна быть зарегистрирована платформа ASP.NET

  1. Запустите программу aspnet_regiis -i из папки %windir%\Microsoft.Net\Framework\v2.0.50110.

  2. Запустите программу iisrest для перезапуска служб IIS.

Проверьте файлы журнала установки

  • Проверьте файлы журнала, созданные программой установки. Дополнительные сведения см. в разделе Как просмотреть файлы журналов установки SQL Server 2005.

См. также

Задачи

Как устранить неполадки при параллельной установке служб Reporting Services версий SQL Server 2000 и SQL Server 2005

Основные понятия

Установка служб SQL Server Reporting Services

Другие ресурсы

Устранение неполадок в службах Reporting Services


Как устранить неполадки при параллельной установке служб Reporting Services версий SQL Server 2000 и SQL Server 2005

Как устранить неполадки при параллельной установке служб Reporting Services версий SQL Server 2000 и SQL Server 2005 |
 | См. также
Установка компонентов SQL Server 2005 > Разделы руководства по установке компонентов SQL Server > Разделы руководства по установке служб Reporting Services >

Новое содержимое: 5 декабря 2005 г.

Установка служб SQL Server 2000 Reporting Services, выполняющаяся в режиме изоляции служб IIS 5.0 или IIS 5.0, может прерваться, если производится параллельная установка служб SQL Server 2005 Reporting Services (или если устанавливается платформа версии 2.0 или регистрируется ASP.NET 2.0 на основном компьютере). Возникающие ошибки зависят от операционной системы.

Операционная система | Сообщение об ошибке.
Microsoft Windows XP | Сервер отчетов не может расшифровать симметричный ключ, используемый для доступа к конфиденциальным или зашифрованным данным в базе данных сервера отчетов. Можно либо восстановить резервную копию ключа, либо удалить все зашифрованное содержимое, а затем перезапустить службу.
Другие серверы Windows | Недопустимый ключ для использования в указанном состоянии.

После установки служб SQL Server 2005 Reporting Services выполните следующие шаги для обновления данной версии установки служб Reporting Services сервера SQL Server 2000.

Обновление установки служб SQL Server 2000 Reporting Services

  1. В каталоге <диск>:\Documents and Settings\<имя_компьютера>\ASPNET\Application Data\Microsoft\Crypto\RSA\ найдите файл с именем '1aedd7b5699f3d6a88e354100b596aae*'.

  2. Удалите файл.

  3. Выполните команду RSActivate –r –c <rsreportserver.config>, указав полный путь к файлу RSReportServer.config установки служб SQL Server 2000 Reporting Services. Если путь содержит пробелы, то убедитесь, что весь путь заключен в кавычки.

См. также

Задачи

How to: Install Reporting Services Side-by-Side with an Earlier Version
Как устранять неполадки при установке служб Reporting Services

Другие ресурсы

Разделы руководства по установке служб Reporting Services


Как настроить службы IIS для запуска 32-разрядных служб Reporting Services в режиме WOW64

Как настроить службы IIS для запуска 32-разрядных служб Reporting Services в режиме WOW64 |
 | См. также
Установка компонентов SQL Server 2005 > Разделы руководства по установке компонентов SQL Server > Разделы руководства по установке служб Reporting Services >

Дата обновления: 5 декабря 2005 г.

Службы IIS 6.0 возвращают сообщение об ошибке «Служба недоступна» при попытке запуска служб Reporting Services в режиме эмуляции x86 Windows-on-Windows 64 (WOW64). Чтобы избежать этой ошибки, необходимо настроить службы IIS для запуска 32-разрядных приложений ASP.NET.

Важно!
Службы IIS должны быть настроены перед установкой служб Reporting Services.

Настройка служб IIS для запуска 32-разрядных служб Reporting Services

  1. Удалите 64-разрядную версию служб Reporting Services. Параллельное развертывание 64-разрядной и 32-разрядной версий не поддерживается.

  2. Чтобы вручную установить платформу .NET, запустите файл dotnetfx64.exe. Этот файл можно найти в папке Redist на носителе с программой установки SQL Server 2005.

  3. В диспетчере IIS щелкните папку Расширения веб-сервера.

  4. В области сведений щелкните правой кнопкой мыши ASP.NET V2.0.50727 и выберите пункт Разрешено.

  5. Щелкните правой кнопкой папку Веб-узлы и выберите пункт Свойства.

  6. Щелкните Фильтры ISAPI.

  7. В поле Имя фильтра выберите ASP.NET_2.0.50727, а затем пункт Редактировать.

  8. Замените файл C:\WINDOWS\Microsoft.NET\Framework64\v2.0.50727\aspnet_filter.dll 32-разрядной версией, которая находится в папке Framework: C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727\aspnet_filter.dll

  9. Нажмите кнопку ОК. Сохраните произведенные изменения и закройте диспетчер IIS.

  10. Откройте окно командной строки, а затем запустите следующую команду:

    Копировать код
    cscript %SystemDrive%\inetpub\AdminScripts\adsutil.vbs set w3svc/AppPools/Enable32bitAppOnWin64 1

  11. Установите 32-разрядную версию служб Reporting Services.

  12. После завершения программы установки откройте диспетчер IIS и выберите папку Расширения веб-сервера.

  13. В области сведений щелкните правой кнопкой мыши ASP.NET V2.0.50727 (32-разрядный), а затем выберите Разрешено.

См. также

Другие ресурсы

Разделы руководства по установке служб Reporting Services


Разделы руководства по установке служб Integration Services

Разделы руководства по установке служб Integration Services |
 | См. также
Установка компонентов SQL Server 2005 > Разделы руководства по установке компонентов SQL Server >

В этом разделе содержатся следующие стандартные процедуры, используемые для установки служб Integration Services.

Стандартные процедуры, проводимые при обновлении из служб DTS и при миграции пакетов служб DTS, см. в разделе Разделы руководства по обновлению или выполнению миграции служб DTS.

Важно!
Подразделы руководства по установке служб Integration Services в этом разделе относятся исключительно к службам Integration Services, однако в них есть ссылки на другие подразделы, содержащие дополнительные сведения по установке SQL Server.

В этом разделе

  • Как установить службы Integration Services с помощью программы установки

  • Как установить службы Integration Services из командной строки

  • Как добавить службы Integration Services к существующему экземпляру SQL Server 2005

  • Как настроить службы Integration Services в кластере

  • Как обеспечить поддержку пакетов служб DTS

См. также

Основные понятия

Установка служб SQL Server Integration Services


Как установить службы Integration Services с помощью программы установки

Как установить службы Integration Services с помощью программы установки |
 | См. также
Установка компонентов SQL Server 2005 > Разделы руководства по установке компонентов SQL Server > Разделы руководства по установке служб Integration Services >

Дата обновления: 17 июля 2006 г.

Службы SQL Server 2005 Integration Services (SSIS) могут быть установлены с помощью мастера установки SQL Server или из командной строки. Мастер установки предоставляет графический пользовательский интерфейс, помогающий принимать все решения во время установки, и является предпочтительным для большинства пользователей. Мастер установки предлагает содействие в начальной настройке SQL Server 2005, включая выбор возможностей, правила именования экземпляров, конфигурацию учетных записей служб, рекомендации по выбору надежного пароля и выбор параметров сортировки.

Важно!
Этот и другие подразделы руководства по установке служб Integration Services в этой разделе рассматривают лишь те параметры установки, которые непосредственно относятся к службам Integration Services, предоставляя при этом ссылки на другие разделы, содержащие дополнительные сведения по установке SQL Server.

Установка служба Integration Services с помощью программы установки

  1. Запустите мастер установки SQL Server, как описано в разделе Как установить SQL Server 2005 (программа установки), если устанавливаются только службы Integration Services или если устанавливаются службы Integration Services вместе с компонентами SQL Server 2005.

    При необходимости добавить службы Integration Services к существующей установке SQL Server 2005 см. раздел Как изменить компоненты существующего экземпляра SQL Server 2005 (программа установки).

  2. Либо ознакомьтесь с разделом Как установить SQL Server 2005 (программа установки), где дается постраничное описание мастера установки, особенно в случае установки дополнительных компонентов SQL Server помимо служб Integration Services.

  3. На странице Компоненты для установки мастера установки выберите Службы Integration Services. Ознакомьтесь с разделом Установка служб SQL Server Integration Services с помощью программы установки для получения информации о других элементах SQL Server, таких как документация, образцы и инструменты разработки.

  4. При выборе Службы Integration Services также устанавливается поддержка служб DTS SQL Server 2000, включая возможность перечисления и запуска пакетов DTS. Дополнительные сведения см. в разделе Как обеспечить поддержку пакетов служб DTS.

  5. Завершите работу мастера установки. После страницы Компоненты для установки оставшиеся страницы мастера относятся в большей степени к компонентам SQL Server 2005, чем компонентам служб Integration Services.

См. также

Задачи

Установка служб SQL Server Integration Services с помощью программы установки


Как установить службы Integration Services из командной строки

Как установить службы Integration Services из командной строки |
 | См. также
Установка компонентов SQL Server 2005 > Разделы руководства по установке компонентов SQL Server > Разделы руководства по установке служб Integration Services >

Службы SQL Server 2005 Integration Services (SSIS) могут быть установлены с помощью мастера установки SQL Server или из командной строки. Мастер установки предоставляет графический пользовательский интерфейс, помогающий принимать все решения во время установки, и является предпочтительным для большинства пользователей. Установки из командной строки предназначены для использования в усовершенствованных сценариях, таких как удаленная и установка в автоматическом режиме, они могут быть запущены непосредственно из командной строки или с помощью синтаксиса командной строки, ссылающегося на ini-файл, чтобы указать параметры установки.

Важно!
Этот и другие подразделы руководства по установке служб Integration Services в этом разделе рассматривают лишь те параметры установки, которые непосредственно относятся к службам Integration Services, предоставляя при этом ссылки на другие разделы, содержащие дополнительные сведения по установке SQL Server.

Установка службы Integration Services из командной строки

  1. Выберите, указывать ли параметры установки в командной строке или в ini-файле. Дополнительные сведения об использовании ini-файлов для указания этих параметров см. в разделе Как установить SQL Server 2005 из командной строки.

  2. Запустите из командной строки программу Setup.exe, задав выбранные необходимые параметры в командной строке или в ini-файле, как описано в разделе Как установить SQL Server 2005 из командной строки. Просмотрите сведения о специальных параметрах установки для Integration Services в разделе Установка служб SQL Server Integration Services из командной строки.

См. также

Основные понятия

Установка служб SQL Server Integration Services из командной строки


Как добавить службы Integration Services к существующему экземпляру SQL Server 2005

Как добавить службы Integration Services к существующему экземпляру SQL Server 2005 |
 | См. также
Установка компонентов SQL Server 2005 > Разделы руководства по установке компонентов SQL Server > Разделы руководства по установке служб Integration Services >

Новое содержимое: 12 декабря 2006 г.

В этой версии функция обслуживания поддерживается только через компонент «Установка и удаление программ» панели управления Microsoft Windows.

Добавление служб Integration Services к существующему экземпляру SQL Server 2005

  1. Откройте панель управления и дважды щелкните Установка и удаление программ.

  2. В разделе Установленные программы щелкните экземпляр SQL Server, который нужно настроить, после чего нажмите кнопку Изменить.

  3. На странице Выбор компонента щелкните ссылку Нажмите кнопку для установки нового компонента.

    Перед этим можно нажать кнопку Отчет, чтобы просмотреть список установленных компонентов и функций SQL Server 2005. Отчет включает версию, выпуск, версию обновления и сведения о языке для каждого из установленных компонентов и функций.

  4. В диалоговом окне Вставьте установочный носитель введите путь к программе setup.exe на установочном носителе SQL Server 2005 или нажмите кнопку Обзор для ее поиска.

  5. В мастере установки SQL Server 2005 на странице Компоненты для установки выберите Службы Integration Services и для продолжения нажмите кнопку Далее.

    Описание каждой страницы мастера см. в разделе Как установить SQL Server 2005 (программа установки).

  6. Завершите шаги мастера установки.

    Дополнительные сведения о параметрах установки Integration Services см. в разделе Как установить службы Integration Services с помощью программы установки.

См. также

Задачи

Как установить службы Integration Services с помощью программы установки


Как настроить службы Integration Services в кластере

Как настроить службы Integration Services в кластере |
 | См. также
Установка компонентов SQL Server 2005 > Разделы руководства по установке компонентов SQL Server > Разделы руководства по установке служб Integration Services >

Новое содержимое: 5 декабря 2005 г.

SQL Server 2005 Службы Integration Services не предоставляют специальных параметров установки для отказоустойчивого кластера. Однако после установки служб Integration Services отдельно на каждом узле кластера их можно вручную настроить для работы в качестве службы, поддерживающей работу в кластере.

Примечание.
После настройки служб Integration Services в кластере или на любом сервере может возникнуть необходимость настроить разрешения DCOM прежде, чем можно будет подключиться к службе с клиентского компьютера. Дополнительные сведения см. в разделе Подключение к удаленному серверу служб Integration Services.

Подготовка к установке служб Integration Services в кластере

  1. Установите и настройте кластер, содержащий один или несколько узлов.

  2. Также можно установить службы, поддерживающие работу в кластере, например компонент SQL Server 2005 SQL Server Database Engine.

  3. Отдельно на каждом из узлов установите службы Integration Services.

  4. Решите, будут ли службы Integration Services работать в кластере.

    1. В той же группе, что и компонент SQL Server 2005 SQL Server Database Engine.

    2. В группе, отличной от той, где находится компонент SQL Server Database Engine.

Настройка служб Integration Services в одной группе с SQL Server

В данной конфигурации:

  • Загрузка и сохранение пакетов в базе данных MSDB производится быстрее.

  • Узел MSDB доступен в среде Management Studio.

Настройка служб Integration Services для работы в кластере в одной группе с SQL Server

  1. Откройте администратор кластера.

  2. В дереве консоли разверните папку «Группы».

  3. В области сведений выберите группу, к которой планируется добавить службы Integration Services.

  4. В меню Файл выберите Создать, а затем нажмите Ресурс.

  5. На странице Создание ресурса в Мастере ресурсов введите имя и выберите тип службы «Общая служба». Не изменяйте значение поля Группа. Нажмите кнопку Далее.

  6. На странице Возможные владельцы добавьте или удалите узлы кластера, которые являются возможными владельцами ресурса. Нажмите кнопку Далее.

  7. Чтобы добавить зависимости на странице Зависимости, выберите ресурс в списке Доступные ресурсы, а затем нажмите Добавить. В случае перехода на другой ресурс как SQL Server, так и общий диск, на котором сохраняются пакеты Integration Services, должны быть переведены в оперативный режим раньше, чем службы Integration Services. После выбора зависимостей нажмите кнопку Далее.

  8. На странице Параметры общей службы введите в качестве службы MsDtsServer. Нажмите кнопку Далее.

  9. На странице Репликация реестра нажмите Добавить, чтобы добавить раздел реестра, который идентифицирует файл конфигурации для службы Integration Services. Этот файл должен находиться на общем диске, относящемуся к той же группе, что и служба Integration Services, и переходить на другой ресурс вместе со службой Integration Services. В диалоговом окне Раздел реестра введите SOFTWARE\Microsoft\MSDTS\ServiceConfigFile. Нажмите кнопку ОК, а затем кнопку Готово. Теперь служба Integration Services добавлена как поддерживающая работу в кластере.

  10. Теперь необходимо изменить расположение и содержимое файла конфигурации службы, чтобы и файл конфигурации, и хранилище пакетов в случае перехода на другой ресурс были доступны всем узлам. Найдите файл конфигурации: %ProgramFiles%\Microsoft SQL Server\90\DTS\Binn\MsDtsSrvr.ini.xml. Скопируйте его на общий диск.

  11. Создайте на общем диске новую папку под названием Packages. Предоставьте разрешения на просмотр содержимого и на запись в созданную папку встроенной группе Users.

  12. Откройте файл конфигурации с общего диска в редакторе текста или XML. Измените значение элемента ServerName, указав имя виртуального SQL Server, относящегося к той же группе.

  13. Измените значение элемента StorePath, указав полный путь папки Packages, созданной на общем диске на предыдущем шаге.

  14. Измените значение раздела реестра HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\MSDTS\ServiceConfigFile, указав полный путь и имя файла конфигурации службы на общем диске.

  15. Теперь переведите службу Integration Services в оперативный режим. В Администраторе кластера выберите службу Integration Services, щелкните ее правой кнопкой мыши и выберите из контекстного меню пункт Перевести в оперативный режим. Теперь служба Integration Services доступна как поддерживающая работу в кластере.

Настройка служб Integration Services в группе, отличной от группы SQL Server

В данной конфигурации:

  • служба Integration Services может находиться в оперативном режиме, в то время как компонент SQL Server 2005 SQL Server Database Engine отключен и пакеты, хранящиеся в его базе данных msdb, недоступны;

  • служба Integration Services при необходимости может быть быстрее перенесена на другой узел;

  • служба Integration Services не конкурирует за ресурсы ЦП с другими службами SQL Server (когда другие службы SQL Server не установлены на том же компьютере).

Настройка служб Integration Services для работы в кластере в группе, отличной от группы SQL Server

  1. В Администраторе кластера выберите группу, отличную от той, к которой относится SQL Server.

  2. Добавьте и настройте ресурсы «IP-адрес», «Сетевое имя» и «Общая служба» для службы Integration Services. Для ресурса «Общая служба» выполните шаги с 1 по 9 из приведенной выше инструкции.

  3. Поместите файл конфигурации и папку Packages на общий диск этой группы. Выполните шаги с 10 по 14 приведенной выше инструкции, чтобы изменить расположение и содержимое файла конфигурации.

  4. Переведите группу в оперативный режим.

См. также

Задачи

Как установить службы Integration Services с помощью программы установки
Как установить службы Integration Services из командной строки


Как обеспечить поддержку пакетов служб DTS

Как обеспечить поддержку пакетов служб DTS |
 | См. также
Установка компонентов SQL Server 2005 > Разделы руководства по установке компонентов SQL Server > Разделы руководства по установке служб Integration Services >

Пакеты служб DTS SQL Server 2000 по-прежнему могут выполняться вместе с пакетами SQL Server 2005 Integration Services (SSIS).

Можно запускать пакеты служб SQL Server 2000 DTS и пакеты служб Integration Services на одном компьютере.

Если для установки выбраны Службы Integration Services, программа установки также устанавливает поддержку пакетов служб DTS SQL Server 2000, включая среду выполнения DTS и перечислитель пакетов служб DTS в SQL Server Management Studio. Обновленная поддержка среды выполнения позволяет пакетам служб DTS получать доступ к источникам данных SQL Server 2005. Если установка служб Integration Services не производится, но необходима поддержка пакетов служб DTS, убедитесь, что на странице Выбор компонентов были выбраны Компоненты прежних версий.

В число устанавливаемых файлов, служащих для обеспечения обратной совместимости, входит также задача «Обработка средствами SQL Server 2000 Analysis Services» и зависимый от нее модуль объектов DSO. Однако файлы задачи «Прогнозирующий запрос интеллектуального анализа данных» SQL Server 2000 не устанавливаются.

Примечание.
При установке SQL Server 2005 конструктор пакетов служб DTS не устанавливается. Дополнительные сведения см. в разделе Обратная совместимость служб SQL Server 2005 Integration Services. Пакеты служб DTS нельзя открывать или изменять в среде BI Development Studio.

Если выбрана установка Integration Services, также устанавливается мастер миграции пакетов. Мастер миграции пакетов можно использовать для обновления пакетов служб SQL Server 2000 DTS до Integration Services. Во время миграции мастер копирует пакеты служб DTS, после чего воссоздает их в формате Integration Services. Исходные пакеты при этом не изменяются. Дополнительные сведения см. в разделе Миграция пакетов служб DTS.

Примечание.
Мастер миграции пакетов доступен в следующих выпусках SQL Server 2005: Standard Edition, Enterprise Edition, Developer Edition.

Выпуск SQL Server 2005 Express Edition не включает в себя Integration Services или поддержку пакетов служб DTS SQL Server 2000.

  • Чтобы получить возможность выполнять пакеты служб DTS на сервере с выпуском SQL Server 2005 Express Edition, необходимо оставить на сервере клиентские средства или распространяемые файлы служб DTS SQL Server 2000 или переустановить их. Выпуск SQL Server 2005 Express Edition не включает в себя среду выполнения служб DTS.

  • Чтобы редактировать существующие пакеты служб DTS на сервере с выпуском SQL Server 2005 Express Edition, необходимо использовать SQL Server 2000 или редактировать их удаленно с сервера, на котором запущен выпуск SQL Server 2005 Workgroup, Standard, Enterprise или Developer Edition. Выпуск SQL Server 2005 Express Edition не включает ни среду SQL Server Management Studio, ни среду Business Intelligence Development Studio.

  • Чтобы выполнить миграцию существующих пакетов служб DTS на SQL Server 2005 Integration Services, необходимо использовать SQL Server 2005 выпусков Standard, Enterprise или Developer Edition. Другие выпуски SQL Server 2005 не включают мастер миграции пакетов Integration Services.

Программа импорта и экспорта, входящая в состав выпуска SQL Server 2005 Express Edition, не является мастером импорта и экспорта SQL Server и не использует Integration Services.

Поддержка пакетов служб DTS

  1. Установите SQL Server 2005 вместе со Integration Services, используя любой метод. Вместе со Integration Services устанавливаются также средства поддержки пакетов служб DTS SQL Server 2000.

См. также

Задачи

Как установить службы Integration Services с помощью программы установки
Как установить службы Integration Services из командной строки


Разделы руководства по установке служб Notification Services

Разделы руководства по установке служб Notification Services |
 | См. также
Установка компонентов SQL Server 2005 > Разделы руководства по установке компонентов SQL Server >

Этот раздел содержит процедуры для установки служб Notification Services.

В этом разделе

  • How to: Install Notification Services and the Database Engine

  • Как установить компоненты ядра служб Notification Services

  • Как установить компоненты клиента служб Notification Services

  • Как зарегистрировать сборку ядра служб Notification Services для взаимодействия COM

  • Как удалить службы Notification Services

См. также

Основные понятия

Установка служб SQL Server Notification Services
Миграция экземпляров служб Notification Services
Установка SQL Server 2005


How to: Install Notification Services and the Database Engine

How to: Install Notification Services and the Database Engine |
 | См. также
Установка компонентов SQL Server 2005 > Разделы руководства по установке компонентов SQL Server > Разделы руководства по установке служб Notification Services >

Чтобы можно было запустить экземпляр служб Notification Services на том же сервере, где размещены ее базы данных, необходимо установить на этом сервере Notification Services и Database Engine. Обычно при разработке и развертывании приложений небольшого или среднего размера используется односерверная конфигурация.

Установка служб Notification Services и ядра СУБД

  1. На странице Запуск выберите пункт Запустить мастер установки SQL Server.

  2. Следуйте инструкциям программы установки до тех пор, пока не откроется страница Компоненты для установки.

  3. Выберите Службы SQL Server Database Services и Службы Notification Services.

    Можно выбрать и другие компоненты, например компоненты рабочей станции, электронную документацию и средства разработки.

  4. Следуйте инструкциям на оставшихся страницах программы установки.

  5. На странице Готовность к установке нажмите кнопку Установить.

См. также

Основные понятия

Установка служб SQL Server Notification Services
Миграция экземпляров служб Notification Services

Другие ресурсы

Разделы руководства по установке служб Notification Services


Как установить компоненты ядра служб Notification Services

Как установить компоненты ядра служб Notification Services |
 | См. также
Установка компонентов SQL Server 2005 > Разделы руководства по установке компонентов SQL Server > Разделы руководства по установке служб Notification Services >

Экземпляр служб Notification Services и его базы данных могут располагаться на отдельных серверах. На сервере, где запущен экземпляр служб Notification Services, необходимо установить Notification Services. Установка служб Notification Services целиком эквивалентна установке компонентов ядра служб Notification Services.

Установка служб Notification Services

  1. На странице Запуск выберите пункт Запустить мастер установки SQL Server.

  2. Следуйте инструкциям программы установки до тех пор, пока не откроется страница Компоненты для установки.

  3. Выберите компонент Службы Notification Services.

    Можно выбрать и другие компоненты, например компоненты рабочей станции, электронную документацию и средства разработки.

  4. Следуйте инструкциям на оставшихся страницах программы установки.

  5. На странице Все готово для установки нажмите кнопку Установить.

См. также

Основные понятия

Установка служб SQL Server Notification Services
Миграция экземпляров служб Notification Services

Другие ресурсы

Разделы руководства по установке служб Notification Services


Как установить компоненты клиента служб Notification Services

Как установить компоненты клиента служб Notification Services |
 | См. также
Установка компонентов SQL Server 2005 > Разделы руководства по установке компонентов SQL Server > Разделы руководства по установке служб Notification Services >

Для клиентских приложений, взаимодействующих с экземплярами служб Notification Services, необходимо наличие компонентов клиента Notification Services. Наиболее распространенные удаленные приложения перечислены ниже:

  • Интерфейсы управления подписками.

  • Внепроцессные поставщики событий.

  • Консоли удаленного администрирования.

Примечание.
Компоненты клиента служб Notification Services включаются в состав при установке Notification Services, компонентов ядра SQL Server или среды SQL Server Management Studio (Microsoft).

Установка компонентов правил

  1. На странице Запуск выберите пункт Запустить мастер установки SQL Server.

  2. Следуйте инструкциям программы установки до тех пор, пока не откроется страница Компоненты для установки.

  3. На странице Компоненты для установки нажмите кнопку Дополнительно.

  4. На странице Выбор компонентов разверните раздел Службы Notification Services.

  5. В разделе «Службы Notification Services» нажмите кнопку Компоненты клиента и выберите пункт Компонент будет установлен на локальный жесткий диск.

    По желанию можно также выбрать другие компоненты SQL Server.

  6. Следуйте инструкциям на оставшихся страницах программы установки.

  7. На странице Все готово для установки нажмите кнопку Установить.

См. также

Основные понятия

Установка служб SQL Server Notification Services
Миграция экземпляров служб Notification Services

Другие ресурсы

Разделы руководства по установке служб Notification Services


Как удалить службы Notification Services

Как удалить службы Notification Services |
 | См. также
Установка компонентов SQL Server 2005 > Разделы руководства по установке компонентов SQL Server > Разделы руководства по установке служб Notification Services >

Если службы Notification Services удаляются окончательно, то следует удалить экземпляры Notification Services. Если производится обновление экземпляров служб Notification Services до новой версии Microsoft SQL Server, оставьте свои экземпляры на месте и следуйте инструкциям по обновлению Notification Services. Не нужно удалять службы Notification Services 2.0, чтобы перейти на SQL Server 2005.

Удаление службы Notification Services

  1. Остановите работу всех экземпляров служб Notification Services, использующих версию, которая удаляется.

  2. (Необязательно.) Удалите экземпляры служб Notification Services.

    Не удаляйте экземпляры, если обновляете их до более свежей версии SQL Server. Дополнительные сведения об удалении экземпляров см. в разделе Удаление экземпляров служб Notification Services.

  3. В меню Пуск выберите пункт Панель управления, затем выберите пункт Установка и удаление программ.

  4. Выберите пункт Microsoft SQL Server 2005, а затем нажмите кнопку Изменить.

  5. На странице Выбор компонентов выберите Службы Notification Services.

  6. Нажмите кнопку Далее, а затем следуйте инструкциям на следующих страницах мастера.

  7. Когда появится страница Изменить или удалить экземпляр, выберите Изменить установленные компоненты.

  8. Выберите Службы Notification Services, затем выберите Весь компонент станет недоступным.

  9. Нажмите кнопку Далее, а затем следуйте инструкциям на следующих страницах мастера.

См. также

Основные понятия

Установка служб SQL Server Notification Services
Миграция экземпляров служб Notification Services


Как зарегистрировать сборку ядра служб Notification Services для взаимодействия COM

Как зарегистрировать сборку ядра служб Notification Services для взаимодействия COM |
 | См. также
Установка компонентов SQL Server 2005 > Разделы руководства по установке компонентов SQL Server > Разделы руководства по установке служб Notification Services >

Интерфейс API для служб Notification Services был разработан в управляемом коде. Однако многие классы сборки Microsoft.SqlServer.NotificationServices.dll могут быть использованы из собственного кода через взаимодействие COM. Программа настройки регистрирует эту сборку для интерфейса взаимодействия COM. Если нужно повторно зарегистрировать эту сборку, следуйте инструкциям в следующем разделе.

Другие сборки служб Notification Services не поддерживают взаимодействие COM.

Регистрация основной сборки для взаимодействия COM

  1. Откройте окно командной строки.

  2. Перейдите в каталог платформы Microsoft .NET Framework версии 2.0. В следующей команде замените N.N.N на полный номер версии платформы .NET Framework.

    CD %WINDIR%\Microsoft.NET\Framework\v N.N.N

  3. Зарегистрируйте сборку с помощью следующей команды:

    regasm /codebase /tlb %ProgramFiles%\Microsoft SQL Server\90\NotificationServices\9.0.242\bin\microsoft.sqlserver.notificationservices.dll"

См. также

Основные понятия

Установка служб SQL Server Notification Services

Другие ресурсы

Взаимодействие COM со службами Notification Services
Разделы руководства по установке служб Notification Services


Установка SQL Server Express

Установка SQL Server Express |
 | См. также

При установке (SQL Server Express) необходимо выбрать параметры, наиболее подходящие для используемой среды. Приведенные в этом разделе сведения призваны помочь с выбором.

В этом разделе

Раздел | Описание
Требования к оборудованию и программному обеспечению (SQL Server Express) | Список требований к оборудованию и программному обеспечению для установки SQL Server Express.
Подготовка к установке SQL Server Express | Ссылки для установки платформы Microsoft .NET Framework, необходимой для установки SQL Server Express.
Использование параметров командной строки для установки SQL Server Express | Описание изменения программы установки SQL Server Express с помощью командной строки. Ссылка на раздел электронной документации SQL Server 2005, содержащий все параметры командной строки для установки SQL Server.
Установка образцов баз данных для выпусков Express Edition | Ссылки для загрузки образцов баз данных Adventureworks, Northwind, а также образцов баз данных pubs.
Обновление выпуска MSDE до версии SQL Server Express | Описание сценариев, в которых выпуск MSDE можно обновить до SQL Server Express.
Справка по пользовательскому интерфейсу программы установки (SQL Server Express) | Инструкции по установке SQL Server Express.
Настройка контактной зоны SQL Server | Документация по пользовательскому интерфейсу средства конфигурации контактной зоны и стандартные настройки для каждого диалогового окна.

См. также

Другие ресурсы

Центр загрузки электронной документации по SQL Server 2005


Требования к оборудованию и программному обеспечению (SQL Server Express)

Требования к оборудованию и программному обеспечению (SQL Server Express) |
 | См. также
Установка SQL Server Express >

Дата обновления: 17 июля 2006 г.

В приведенных ниже таблицах перечислено необходимое программное обеспечение и минимальные требования к оборудованию для запуска (SQL Server Express), with Advanced Services (SQL Server Express) и средствами управления (набор средств управления SQL Server Express).

Примечание.
Чтобы определить, отвечает ли компьютер требованиям, в меню Пуск щелкните правой кнопкой мыши Мой компьютер, затем щелкните Свойства. На вкладке Общие отобразятся тип и тактовая частота процессора, а также объем установленной памяти (ОЗУ).

Требования к системе для SQL Server Express (32-разрядная версия)

Необходимое программное обеспечение

  • Microsoft .NET Framework 2.0

  • Для программы установки SQL Server необходимы компоненты доступа к данным (MDAC) версии 2.8 с пакетом обновления 1 (SP1) или более поздней версии. Компоненты доступа к данным (MDAC) версии 2.8 с пакетом обновления 1 (SP1) можно загрузить с этого веб-узла Майкрософт.

Требования к Интернет-компонентам

Microsoft Internet Explorer 6.0 с пакетом обновления 1 (SP1) или более поздней версии (необходим для платформы .NET Framework)

ОЗУ

Минимум 192 МБ

Рекомендуется 512 МБ и более

Место на диске

600 МБ свободного места

Процессор

Совместимый с Pentium III или более производительный

Минимум 500 МГц

Рекомендуется 1 ГГц и выше

Операционная система

Windows Server 2003 с пакетом обновления 1 (SP1)

Windows Server 2003 Enterprise Edition с пакетом обновления 1 (SP1)

Windows Server 2003 Datacenter Edition с пакетом обновления 1 (SP1)

Windows Small Business Server 2003 Standard Edition с пакетом обновления 1 (SP1)

Windows Small Business Server 2003 Premium Edition с пакетом обновления 1 (SP1)

Windows XP Professional с пакетом обновления 2 (SP2)

Windows XP Home Edition с пакетом обновления 2 (SP2)

Windows XP Tablet Edition с пакетом обновления 2 (SP2)

Windows XP Media Edition с пакетом обновления 2 (SP2)

Windows 2000 Professional Edition с пакетом обновления 4 (SP4)

Windows 2000 Server Edition с пакетом обновления 4 (SP4)

Windows 2000 Advanced Edition с пакетом обновления 4 (SP4)

Windows 2000 Datacenter Server Edition с пакетом обновления 4 (SP4)

Virtual PC

Virtual Server

Windows Vista Home Basic?

Windows Vista Home Premium?

Windows Vista Business?

Windows Vista Enterprise?

Windows Vista Ultimate?

Примечание? В этой версии отсутствует поддержка для Windows XP Embedded Edition.

?В Windows Vista поддерживаются все выпуски SQL Server Express с пакетом обновления SP2. Единственным поддерживаемым выпуском с пакетом обновления SP1 является SQL Server Express SP1.

Системные требования для SQL Server Express with Advanced Services

В приведенных ниже таблицах приведено необходимое программное обеспечение и минимальные требования к оборудованию для запуска with Advanced Services (SQL Server Express).

Необходимое программное обеспечение

  • Microsoft .NET Framework 2.0

  • Для программы установки SQL Server необходимы компоненты доступа к данным (MDAC) версии 2.8 с пакетом обновления 1 (SP1) или более поздней версии. Компоненты доступа к данным (MDAC) версии 2.8 с пакетом обновления 1 (SP1) можно загрузить с этого веб-узла Майкрософт.

Требования к Интернет-компонентам

  • Microsoft Internet Explorer 6.0 с пакетом обновления 1 (SP1) или более поздней версии (необходим для платформы .NET Framework)

  • Службы Internet Information Services (IIS) 5.0 или более поздней версии необходимы для установки служб Microsoft SQL Server 2005 Reporting Services (служб SSRS).

    Дополнительные сведения об установке IIS см. в разделе Как установить службы IIS (Microsoft) электронной документации по SQL Server 2005.

ОЗУ

Минимум 512 МБ

Рекомендуется 1 ГБ или больше

Место на диске

600 МБ свободного места

Процессор

Совместимый с Pentium III или более производительный

Минимум 600 МГц

Рекомендуется 1 ГГц и выше

Операционная система

Windows Server 2003 с пакетом обновления 1 (SP1)

Windows Server 2003 Enterprise Edition с пакетом обновления 1 (SP1)

Windows Server 2003 Datacenter Edition с пакетом обновления 1 (SP1)

Windows Server 2003 Web Edition с пакетом обновления 1 (SP1)

Windows Small Business Server 2003 Standard Edition с пакетом обновления 1 (SP1)

Windows Small Business Server 2003 Premium Edition с пакетом обновления 1 (SP1)

Windows XP Professional с пакетом обновления 2 (SP2)

Windows XP Tablet Edition с пакетом обновления 2 (SP2)

Windows XP Home Edition с пакетом обновления 2 (SP2)?

Windows XP Media Edition с пакетом обновления 2 (SP2)?

Windows 2000 Professional Edition с пакетом обновления 4 (SP4)

Windows 2000 Server Edition с пакетом обновления 4 (SP4)

Windows 2000 Advanced Edition с пакетом обновления 4 (SP4)

Windows 2000 Datacenter Server Edition с пакетом обновления 4 (SP4)

Virtual PC

Virtual Server

Windows Vista Home Basic?

Windows Vista Home Premium?

Windows Vista Business?

Windows Vista Enterprise?

Windows Vista Ultimate?

Примечание.
В этой версии отсутствует поддержка для Windows XP Embedded Edition.

?Службы Reporting Services, устанавливаемые в составе SQL Server Express with Advanced Services, не устанавливаются на операционные системы, не содержащие служб IIS.

?В Windows Vista поддерживаются все выпуски SQL Server Express с пакетом обновления SP2. Единственным поддерживаемым выпуском с пакетом обновления 1 (SP1) является SQL Server Express SP1.

Системные требования для набора средств управления SQL Server 2005 Express Edition с пакетом обновлений SP2

Необходимое программное обеспечение

  • Microsoft .NET Framework 2.0

  • Для программы установки SQL Server необходимы компоненты доступа к данным (MDAC) версии 2.6 или более поздней. Компоненты доступа к данным (MDAC) версии 2.8 с пакетом обновления 1 (SP1) можно загрузить с этого веб-узла Майкрософт.

Требования к интернет-компонентам

  • Microsoft Internet Explorer 6.0 с пакетом обновления 1 (SP1) или более поздней версии (необходим для платформы .NET Framework)

  • Службы Internet Information Services (IIS) 5.0 или более поздней версии необходимы для установки служб Microsoft SQL Server 2005 Reporting Services (служб SSRS).

    Дополнительные сведения об установке IIS см. в разделе Как установить службы IIS (Microsoft) электронной документации по SQL Server 2005.

ОЗУ

Минимум 512 МБ

Рекомендуется 1 ГБ или больше

Место на диске

600 МБ свободного места

Процессор

Совместимый с Pentium III или более производительный

Минимум 600 МГц

Рекомендуется 1 ГГц и выше

Операционная система

Windows Server 2003 с пакетом обновления 1 (SP1)

Windows Server 2003 Enterprise Edition с пакетом обновления 1 (SP1)

Windows Server 2003 Datacenter Edition с пакетом обновления 1 (SP1)

Windows Server 2003 Web Edition с пакетом обновления 1 (SP1)

Windows Small Business Server 2003 Standard Edition с пакетом обновления 1 (SP1)

Windows Small Business Server 2003 Premium Edition с пакетом обновления 1 (SP1)

Windows XP Professional с пакетом обновления 2 (SP2)

Windows XP Tablet Edition с пакетом обновления 2 (SP2)

Windows XP Home Edition с пакетом обновления 2 (SP2)

Windows XP Media Edition с пакетом обновления 2 (SP2)

Windows 2000 Professional Edition с пакетом обновления 4 (SP4)

Windows 2000 Server Edition с пакетом обновления 4 (SP4)

Windows 2000 Advanced Edition с пакетом обновления 4 (SP4)

Windows 2000 Datacenter Server Edition с пакетом обновления 4 (SP4)

Virtual PC

Virtual Server

Windows Vista Home Basic?

Windows Vista Home Premium?

Windows Vista Business?

Windows Vista Enterprise?

Windows Vista Ultimate?

Примечание.
В этой версии отсутствует поддержка для Windows XP Embedded Edition.

?Службы Reporting Services, устанавливаемые в составе SQL Server Express with Advanced Services, не устанавливаются на операционные системы, не содержащие служб IIS.

? В Windows Vista поддерживаются все выпуски SQL Server Express с пакетом обновления SP2. Единственным поддерживаемым выпуском с пакетом обновления SP1 является SQL Server Express SP1.

Пакеты установки SQL Server Express

Для установки доступны два исполняемых файла SQL Server Express:

  • SQLEXPR.EXE. Производит установку на компьютерах на базе процессоров x86, а также с поддержкой WoW64 на базе x64, но не IA64.

  • SQLEXPR32.EXE. Установка только на компьютеры на основе технологии x86. Эта программа не будет выполняться на 64-разрядной платформе (даже на WoW64).

См. также

Задачи

Как установить SQL Server Express

Основные понятия

Подготовка к установке SQL Server Express

Журнал изменений

Версия Журнал

5 декабря 2005 г.

Измененное содержимое:
  • Обновлен список операционных систем.

  • Обновлено описание пакетов установки.

14 апреля 2006 г.

Измененное содержимое
  • Добавлен список операционных систем для новых выпусков SQL Server Express.

17 июля 2006 г.

Измененное содержимое
  • Добавлены компоненты MDAC в качестве требуемого программного обеспечения для всех трех выпусков SQL Server Express.

12 декабря 2006 г.

Измененное содержимое
  • Добавлены сведения о поддержке Windows Vista.


Подготовка к установке SQL Server Express

Подготовка к установке SQL Server Express |
 | См. также
Установка SQL Server Express >

Перед установкой (SQL Server Express) обязательно установите правильную версию .NET Framework, необходимую для работы SQL Server Express.

Версия SQL Server Express Версия платформы .NET Framework

SQL Server 2005 Express Edition - RTM

Если устанавливается SQL Server 2005 Express Edition, выполните следующие шаги.

  1. Удалите с компьютера платформу .NET Framework 1.2 и более поздние версии (не обязательно удалять версии 1.0 и 1.1). После этого установите .NET Framework 2.0 из центра загрузки .NET Framework 2.0.

  2. Установите SQL Server 2005 Express Edition с веб-узла SQL Server Express.

Определение версии .NET Framework, установленной на компьютере

Определить установленную версию .NET Framework можно двумя способами.

  • Если это версия 2.0, то для определения точного номера версии перейдите в папку %WINDIR%\Microsoft.NET\Framework\version, щелкните правой кнопкой мыши mscorlib.dll, затем выберите Свойства и Версия.

  • Или: в меню Пуск выберите Панель управления, откройте компонент Администрирование, а затем — Настройка конфигурации .NET Framework 2.0. В верхней части правой панели будет указана версия .NET Framework.

См. также

Задачи

Как установить SQL Server Express
Как удалить SQL Server Express

Другие ресурсы

Установка SQL Server Express


Использование параметров командной строки для установки SQL Server Express

Использование параметров командной строки для установки SQL Server Express |
 | См. также
Установка SQL Server Express >

В дополнение к графическому интерфейсу пользователя в программе установки SQL Server 2005 Express Edition (SQL Server Express) имеется командная строка. Сведения о настройке способа установки SQL Server Express см. в разделах Выполнение установки из командной строки и Как установить SQL Server 2005 из командной строки электронной документации по SQL Server 2005.

Примечание.
SQL Server Express — это ограниченный выпуск SQL Server 2005. Установка с помощью командной строки для SQL Server Express аналогична процедуре для SQL Server 2005.

Изменение установленных компонентов SQL Server Express

Если SQL Server Express устанавливается из центра загрузки на веб-узле SQL Server Express, для запуска установки следует использовать файл sqlexpr.exe. Если файл sqlexpr.exe запускается непосредственно, без сохранения в папке, то временный каталог, в который распаковываются двоичные файлы, удаляется после завершения установки. Попытка изменить компоненты SQL Server Express, выбрав на панели управления компонент Установка и удаление программ и нажав кнопку Изменить, окажется безрезультатной, поскольку каталог установки не будет найден.

Этот подход не работает, если выпуск SQL Server Express установлен как часть Visual Studio 2005 Express. Дополнительные сведения о среде Visual Studio Express см. на веб-узле Продукты Visual Studio 2005 Express.

Для изменения установленных компонентов SQL Server Express потребуется снова загрузить файл sqlexpr.exe с веб-узла и сохранить его в эту папку. В командной строке нужно будет изменить путь к папке, где хранится файл EXE, и запустить программу установки с помощью команды sqlexpr.exe –x. Появится запрос каталога извлечения и установки.

После извлечения файлов программы установки можно нажать кнопку Изменить и изменить установленные компоненты SQL Server Express, указав каталог извлечения в ответ на запрос.

Запуск SQL Server Express в однопользовательском режиме

В следующем случае SQL Server Express не удастся запустить в однопользовательском режиме.

После установки SQL Server Express запускается служба, проверяется соединение, затем с помощью диспетчера конфигурации SQL Server служба останавливается. После этого в командной строке с помощью следующей команды запускается однопользовательский режим SQL Server Express:

Sqlservr.exe -s SQLEXPRESS -m

Служба запускается. Однако если выключить и снова включить службу, она не запустится.

См. также

Задачи

Как установить SQL Server Express
Как удалить SQL Server Express

Другие ресурсы

Учебник по программе SQLCMD


Установка образцов баз данных для выпусков Express Edition

Установка образцов баз данных для выпусков Express Edition |
 | См. также
Установка SQL Server Express >

Образцы баз данных, которые поддерживаются (SQL Server Express), - Adventureworks, Northwind и общедоступные базы. По умолчанию эти образцы устанавливаются с SQL Server Express. Также их можно загрузить из центра загрузки Майкрософт.

AdventureWorks

Adventureworks можно установить с этого веб-узла корпорации Майкрософт. Загрузите страницу SQLServerDatabasesandSamplesOverview.htm и следуйте изложенным в ней инструкциям относительно SQL Server Express. Для установки образца базы данных дважды щелкните AdventureworksDB.msi.

Northwind и общедоступные базы

Northwind и общедоступные базы можно загрузить с этого веб-узла корпорации Майкрософт.

После загрузки файла SQL2000SampleDb.msi извлеките сценарии образцов баз данных, дважды щелкнув SQL2000SampleDb.msi. SQL2000SampleDb.msi извлечет сценарии баз данных и файл Readme в папку «C:\Program Files\SQL Server 2000 Sample Databases». Для запуска установки сценариев следуйте инструкциям в файле Readme.

Примечание.
Дополнительные сведения см. в разделе Образцы кода и баз данных электронной документации по SQL Server 2005.

См. также

Основные понятия

Использование программы установки для установки образца базы данных AdventureWorks и других примеров


Обновление выпуска MSDE до версии SQL Server Express

Обновление выпуска MSDE до версии SQL Server Express
Установка SQL Server Express >

Если выпуск MDSE был установлен с помощью программной установки MSI, существующий экземпляр выпуска MSDE будет обновлен при установке (SQL Server Express) с тем же именем экземпляра. Воспользуйтесь параметром Экземпляр по умолчанию при запуске программы установки SQL Server Express. Это не относится к тем случаям, когда устанавливается версия SQL Server Express, отличная от английской. В этом случае обновляемый выпуск MSDE должен использовать тот же язык, что и SQL Server Express, либо английский язык.

Если выпуск MSDE был установлен как часть другого приложения, где использовалась собственная программа установки, установщику SQL Server Express не будет известно об этом. В этом сценарии единственный вариант обновления SQL Server Express - это установка SQL Server Express под другим именем экземпляра. При запуске программы установки SQL Server Express укажите новое имя экземпляра с помощью параметра Именованный экземпляр, а затем извлеките базы данных из MSDE и добавьте их в SQL Server Express.

Чтобы узнать, установлен ли выпуск MSDE как часть другого приложения, выберите Панель управления и откройте компонент Установка и удаление программ. Если выпуск MSDE отсутствует в окне Установка и удаление программ, то он был установлен как часть другого приложения. В этом случае единственный способ удалить выпуск MSDE — удалить приложение, вместе с которым он был установлен. В большинстве случаев пользователи приложений позволяют своему поставщику организовывать обновление.

Дополнительные сведения о выполнении обновления см. в статье Обновление MSDE 2000 до SQL Server Express 2005 в библиотеке MSDN.


Как обеспечить сетевой доступ во время установки (SQL Server Express)

Как обеспечить сетевой доступ во время установки (SQL Server Express)
Установка SQL Server Express >

При установке (SQL Server Express) сетевые протоколы по умолчанию отключаются. Эти протоколы можно включить во время или после установки продукта. Возможно, также потребуется включить настройки брандмауэра.

Включение сетевых протоколов

  • При запуске setup.exe из командной строки укажите DisableNetworkProtocols = 0, как показано в следующем примере:

    Копировать код
    setup.exe /qn addlocal=all InstanceName=SQLEXPRESS DisableNetworkProtocols=0

Включение настроек брандмауэра

  1. Нажмите кнопку Пуск, выберите пункт Панель управления, а затем элемент Сетевые подключения.

  2. На панели навигации слева щелкните ссылку Изменить параметры брандмауэра Windows.

  3. На вкладке Исключения в окне Программы и службы, вероятнее всего, SQL Server появится в списке, но не будет выбран в качестве исключения. Если установить этот флажок, в Windows откроется порт 1433 для TCP-запросов. Если же SQL Server не отображается, выполните следующие действия.

    1. Щелкните Добавить программу.

    2. Нажмите кнопку Обзор.

    3. Перейдите в папку drive:/Program Files/Microsoft SQL Server/MSSQL.1\MSSQL\BINN

    4. Добавьте файл sqlservr.exe в список исключений.


Как установить SQL Server Express

Как установить SQL Server Express |
 | См. также
Установка SQL Server Express >

В этом разделе описывается установка (SQL Server Express). Здесь также представлены параметры установки, отличные от .

Для локальной установки необходимо запустить программу установки под учетной записью администратора. Если SQL Server устанавливается с удаленного общего ресурса, необходимо использовать учетную запись домена, у которой есть разрешения чтения и записи на этом удаленном ресурсе.

Установка SQL Server Express

  1. Чтобы начать установку, дважды щелкните файл sqlexpr.exe.

    Примечание.
    SQL Server Express поставляется в виде самораскрывающегося исполняемого файла (sqlexpr.exe) как на компакт-диске Visual Studio 2005, так и на веб-узле SQL Server Express. SQLEXPR.EXE устанавливается на компьютеры на основе технологии x86 и в 32-разрядные подсистемы (WOW64). Дополнительные сведения см. в разделе Требования к оборудованию и программному обеспечению (SQL Server Express).

  2. Прочтите лицензионное соглашение на соответствующей странице и установите флажок Я принимаю условия лицензионного соглашения. Нажмите кнопку Далее.

  3. Запустится Программа обновления компонентов SQL Server и будет установлено программное обеспечение, необходимое для установки SQL Server Express. Для получения дополнительных сведений о требованиях к компонентам нажмите кнопку Справка в нижней части страницы. Нажмите кнопку Далее.

    Важно!
    .NET Framework 2.0 не устанавливается при установке с помощью функции Обновление компонентов SQL Server, однако .NET Framework 2.0 требуется программе установки SQL Server Express перед запуском sqlexpr.exe. Если .NET Framework 2.0 отсутствует, возникнет ошибка. Перед запуском программы установки SQL Server Express убедитесь, что все предыдущие версии .NET Framework удалены, и установите .NET Framework 2.0 из центра загрузки .NET Framework 2.0.

  4. Появится страница «Вас приветствует мастер установки ». Нажмите кнопку Далее.

  5. На странице «Проверка конфигурации» выполняется просмотр компьютера во избежание возможных проблем установки. Чтобы прервать проверку, нажмите кнопку Стоп. Для продолжения установки по завершении проверки нажмите кнопку Продолжить.

  6. На странице «Регистрационные данные» заполните поля Имя и Компания. Нажмите кнопку Далее.

    1. Поскольку SQL Server Express распространяется бесплатно, на этой странице нет текстового поля Ключ продукта.

    2. Если установить флажок Скрыть дополнительные параметры конфигурации, во время установки не появятся страницы «Учетная запись службы», «Настройка режима сопоставления» и «Пользовательские экземпляры».

  7. На странице «Выбор компонентов» выберите устанавливаемые компоненты программы и нажмите кнопку Далее.

    Примечание.
    В программе установки SQL Server Express нет страницы «Выбор настраиваемых компонентов». Вместо этого устанавливаемые компоненты можно выбрать на странице «Выбор компонентов». Чтобы раскрыть компонент и просмотреть вложенные компоненты, щелкните символ «+».

  8. На странице «Имя экземпляра» выберите для установки значение Экземпляр по умолчанию или Именованный экземпляр. Если выбрано значение Экземпляр по умолчанию, существующий экземпляр по умолчанию будет обновлен. Если выбрано значение Именованный экземпляр, укажите имя экземпляра. В противном случае будет использоваться стандартный экземпляр с именем SQLExpress. Нажмите кнопку Далее.

    Щелкните элемент Установленные экземпляры для просмотра списка установленных экземпляров SQL Server Express и компонентов на компьютере, где запущена программа установки SQL Server Express. На панели подробных сведений об установленных экземплярах отобразятся параметры обновления установленных экземпляров.

    При запуске программа установки SQL Server Express проверит, существует ли имя экземпляра SQLExpress.

    1. Если экземпляр SQLExpress существует, по умолчанию появляется страница «Имя экземпляра».

    2. Если экземпляра SQLExpress не существует, по умолчанию страница «Имя экземпляра» будет скрыта от пользователя. Однако если на странице «Регистрационные данные» снять флажок Скрыть дополнительные параметры конфигурации, диалоговое окно Имя экземпляра будет отображаться постоянно.

  9. На странице Учетная запись службы можно назначить службе SQL Server локальную системную учетную запись или учетную запись домена. Эта страница не появится, если установлен флажок Скрыть дополнительные параметры конфигурации

    1. Выберите вариант Использовать локальную учетную запись, не требующую пароля для подключенияSQL Server на том же компьютере, затем нажмите кнопку Далее.

    2. Выберите вариант Использовать учетную запись пользователя домена, введите Имя пользователя, Пароль, а также имя домена в поле Домен и нажмите кнопку Далее.

      Примечание.
      Флажок Запустить службы в конце установки SQL Server по умолчанию для SQL Server Express установлен. Служба SQL Server будет запускаться автоматически при запуске операционной системы.

  10. На странице Режим проверки подлинности укажите режим проверки подлинности, используемый для подключения к экземпляру SQL Server. При выборе проверки подлинности Windows программа установки создает учетную запись sa, которая по умолчанию отключена. Об активации учетной записи sa после завершения программы установки см. разделы Как изменить режим проверки подлинности сервера и ALTER LOGIN (Transact-SQL) электронной документации по SQL Server 2005. Если выбрана смешанная проверка подлинности, необходимо назначить надежный пароль для всех имен входа SQL Server. Введите и подтвердите надежный пароль sa. Нажмите кнопку Далее.

    Важно!
    В целях обеспечения безопасности служба «SQL Server, обозреватель» по умолчанию не запускается в SQL Server Express. Если приложения должны использовать эту службу, вручную запустите ее или измените параметры ее запуска. Дополнительные сведения см. в разделах SQL Server, обозреватель Как запустить и остановить службу обозревателя SQL Server электронной документации по SQL Server 2005.

  11. На странице Настройка режима сопоставления следует изменить Режим сопоставления указателя и порядок сортировки по умолчанию, если требуется привести в соответствие настройки сопоставлений в другом экземпляре SQL Server или на другом компьютере. Выберите Режимы сопоставления SQL для приведения в соответствие настроек порядка сортировки в ранних версиях SQL Server. Нажмите кнопку Далее. Эта страница не появится, если установлен флажок Скрыть дополнительные параметры конфигурации.

    Примечание.
    Раскрывающийся список Настроить для каждой учетной записи службы также не появляется, поскольку в SQL Server Express служба должна всегда указывать на SQL Server.

  12. На странице Пользовательские экземпляры укажите, нужно ли формировать отдельный экземпляр компонента Database Engine для пользователей, не обладающих правами администратора. По умолчанию, функциональность пользовательских экземпляров включена. Для отключения пользовательских экземпляров снимите этот флажок. Эта страница не появится, если установлен флажок Скрыть дополнительные параметры конфигурации. Нажмите кнопку Далее.

  13. На странице Настройки параметров отчетов об ошибках и использовании указывается необходимость ведения отчетов об ошибках и использовании для SQL Server и компонентов. По умолчанию ведение отчетов об ошибках включено. Для отключения ведения отчетов об ошибках снимите флажок. Нажмите кнопку Далее.

  14. На странице Все готово для установки нажмите кнопку Установить, чтобы завершить установку SQL Server.

  15. На странице Выполнение установки можно следить за текущим состоянием процесса установки. Нажмите кнопку Далее.

  16. На странице Завершение работы мастера установки Microsoft SQL Server можно просмотреть сводный журнал установки. Для этого щелкните соответствующую ссылку на этой странице. Для выхода из мастера установки SQL Server нажмите кнопку Готово.

В дополнение к графическому пользовательскому интерфейсу можно установить SQL Server Express с помощью тех же параметров командной строки, что используются для установки SQL Server 2005. Дополнительные сведения о параметрах командной строки см. в разделе Выполнение установки из командной строки электронной документации по SQL Server 2005.

SQL Server Express также поддерживает свойство DISABLENETWORKPROTOCOLS для разрешения доступа к сети во время установки. Дополнительные сведения см. в разделе Как обеспечить сетевой доступ во время установки (SQL Server Express).

См. также

Задачи

Как удалить SQL Server Express

Основные понятия

Подготовка к установке SQL Server Express


Как удалить SQL Server Express

Как удалить SQL Server Express
Установка SQL Server Express >

В этом разделе описано полное удаление (SQL Server Express).

Удаление SQL Server Express

  1. Нажмите кнопку Пуск и выберите Панель управления.

  2. Откройте компонент Установка и удаление программ.

  3. Выберите Microsoft SQL Server 2005 и нажмите кнопку Удалить.

  4. Отобразится страница «Выбор компонентов». По умолчанию установлен флажок Удалить экземпляры компонентов SQL Server 2005. Выберите удаляемый экземпляр.

  5. Для удаления компонентов рабочей станции установите флажок Компоненты рабочей станции.

  6. Появится страница Подтверждение, где будут перечислены удаляемые компоненты. Нажмите кнопку Готово, чтобы завершить удаление SQL Server Express.

    По мере удаления отобразятся страницы «Средство проверки конфигурации» и «Выполнение установки».

  7. Для удаления собственного клиента SQL нажмите кнопку Пуск, выберите Панель управления и щелкните компонент Установка и удаление программ.

  8. Выберите Собственный клиент Microsoft SQL и нажмите кнопку Удалить.

  9. Появится диалоговое окно с запросом подтверждения удаления собственного клиента SQL. Нажмите кнопку Да.

    Собственный клиент SQL будет удален из списка Установка и удаление программ.


Настройка установки SQL Server

Настройка установки SQL Server |
 | См. также

После завершения программы установки можно продолжить настройку SQL Server с помощью графических программ и программ командной строки. Средства, служащие для управления экземпляром SQL Server 2005, описаны в следующей таблице.

Средство или программа | Описание
SQL Server Management Studio | Среда SQL Server Management Studio используется для редактирования и выполнения запросов, а также для запуска стандартных задач мастеров. Дополнительные сведения см. в разделе Общие сведения о среде SQL Server Management Studio.
SQL Server Profiler | Приложение SQL Server Profiler обеспечивает графический пользовательский интерфейс для мониторинга экземпляра SQL Server Database Engine или экземпляра служб Analysis Services. Дополнительные сведения см. в разделе Знакомство с приложением SQL Server Profiler.
Помощник по настройке ядра СУБД | Помощник по настройке ядра СУБД помогает создавать оптимальные наборы индексов, индексированных представлений и секций. Дополнительные сведения см. в разделе Применение помощника по настройке ядра СУБД.
Business Intelligence Development Studio | Business Intelligence Development Studio — это интегрированная среда разработки решений, основанных на службах Analysis Services и Integration Services. Дополнительные сведения см. в разделе Общие сведения о среде Business Intelligence Development Studio.
Программы командной строки | Управляют объектами SQL Server из командной строки. Дополнительные сведения см. в разделе Программы командной строки.
Диспетчер конфигурации SQL Server | Управляет настройками сетевой конфигурации сервера и клиента. Дополнительные сведения см. в разделе Диспетчер конфигурации SQL Server.
Импорт и экспорт данных | Integration Services предоставляют ряд графических средств и программных объектов, позволяющих перемещать, копировать и преобразовывать данные. Дополнительные сведения см. в разделе Обзор служб Integration Services.
Программа установки SQL Server | Служит для установки, обновления и изменения компонентов экземпляра SQL Server 2005. Дополнительные сведения см. в разделе Разделы руководства по установке компонента Database Engine.

Конфигурация по умолчанию

В конфигурации новых экземпляров SQL Server 2005 по умолчанию некоторые возможности и компоненты отключены; это сделано для повышения его защищенности.

По умолчанию отключены следующие компоненты и возможности:

  • Integration Services;

  • агент SQL Server;

  • обозреватель SQL Server;

  • компонент Full-Text Search.

Дополнительные сведения см. в разделе Настройка контактной зоны SQL Server.

См. также

Справочник

Возможности, поддерживаемые различными выпусками SQL Server 2005

Другие ресурсы

Администрирование ядра СУБД
Об агенте SQL Server


Настройка контактной зоны SQL Server

Настройка контактной зоны SQL Server |
 | См. также
Настройка установки SQL Server >

Дата обновления: 17 июля 2006 г.

Сокращение контактной зоны является мерой безопасности, предусматривающей остановку или отключение неиспользуемых компонентов. Сокращение контактной зоны способствует повышению уровня безопасности за счет уменьшения числа возможных путей атаки на систему.

В новых установках некоторые возможности, службы и соединения отключены для уменьшения контактной зоны SQL Server.При обновлении установок все компоненты, службы и соединения остаются в том состоянии, в котором они были до обновления.

С помощью средства настройки контактной зоны SQL Server можно включать, отключать, запускать и останавливать компоненты, службы и средства удаленного соединения для установленных копий SQL Server 2005.Настройку контактной зоны SQL Server можно выполнять как на локальных, так и на удаленных серверах.

Чтобы просматривать и изменять настройки сервера, средство настройки контактной зоны SQL Server использует инструментарий WMI.Инструментарий WMI предоставляет унифицированный способ вызова API-функций, управляющих действиями с реестром по настройке SQL Server.Сведения о настройке разрешений, связанных с инструментарием WMI, см. в разделе Как настроить инструментарий WMI для отображения состояния сервера в инструментальных средствах SQL Server.

Использование средства настройки контактной зоны

После установки SQL Server 2005 или обновления до SQL Server 2005 следует запустить средство настройки контактной зоны SQL Server, чтобы проверить, какие функции и службы включены и работают и какие типы соединений приемлемы для SQL Server 2005. После первоначальной настройки можно использовать средство настройки контактной зоны SQL Server для проверки или изменения состояния функций, служб и соединений.

Запуск средства настройки контактной зоны

Средство настройки контактной зоны SQL Server доступно в меню Пуск SQL Server:

  • В меню Пуск последовательно укажите пункты Все программы, Microsoft SQL Server 2005, Средства настройки и затем Настройка контактной зоны SQL Server.

Сначала отображается начальная страница «Настройка контактной зоны SQL Server».На начальной странице необходимо указать, какой сервер нужно настроить.

  1. Щелкните ссылку сменить компьютер рядом с полем Настроить контактную зону для. Значением по умолчанию является localhost. Если раньше был выбран именованный сервер, то отобразится имя этого сервера.

  2. В диалоговом окне Выбор компьютера выполните одно из следующих действий:

    • чтобы настроить SQL Server 2005 на локальном компьютере, выберите Локальный компьютер;

    • чтобы настроить SQL Server 2005 на другом компьютере, выберите Удаленный компьютер и введите имя компьютера в текстовом поле;

    • чтобы настроить отказоустойчивый кластер, выберите Удаленный компьютер и введите имя экземпляра отказоустойчивого кластера в текстовом поле.

  3. Нажмите кнопку ОК.

Использование средства настройки контактной зоны

После выбора настраиваемого компьютера можно использовать следующие два средства.

  • Средство «Настройка контактной зоны для служб и соединений» для включения или отключения служб Windows и возможности удаленного соединения.

    Описания настроек службы и соединения, а также значений по умолчанию для этих настроек см. в разделе Конфигурация контактной зоны для служб и соединений.

  • Средство «Настройка контактной зоны для функциональных возможностей» применяется для включения или отключения функций Database Engine, Analysis Services и Reporting Services.

    Описания функций и сведения о настройках функций по умолчанию см. в разделе Настройка контактной зоны для функциональных возможностей.

Программа командной строки sac

Выполнить импорт или экспорт настроек контактной зоны можно с помощью программы командной строки sac.Эта программа позволяет настроить контактную зону на одном компьютере, а затем применить те же настройки на других компьютерах.

Самый простой способ использования программы sac — запустить настройку контактной зоны SQL Server на одном компьютере, а затем экспортировать настройки этого компьютера в файл с помощью программы sac. Этот файл можно использовать для применения тех же настроек компонентов SQL Server 2005 на других компьютерах.

Дополнительные сведения см. в разделе Программа sac.

См. также

Основные понятия

Настройка контактной зоны для функциональных возможностей
Конфигурация контактной зоны для служб и соединений

Журнал изменений

Версия Журнал

17 июля 2006 г.

Измененное содержимое
  • Обновлено утверждение о преимуществах сокращения контактной зоны системы.

  • Добавлен подраздел о том, когда следует использовать средство настройки контактной зоны.


Настройка контактной зоны для функциональных возможностей

Настройка контактной зоны для функциональных возможностей |
 | См. также
Настройка установки SQL Server > Настройка контактной зоны SQL Server >

Средство "Настройка контактной зоны для функциональных возможностей" предоставляет единый интерфейс для включения и отключения многих функций компонента Database Engine, служб Analysis Services и служб Reporting Services. Отключение неиспользуемых функций позволяет защитить установленные копии вашего Microsoft SQL Server путем уменьшения контактной зоны SQL Server.

В нижеприведенных таблицах содержится список значений по умолчанию для каждого параметра и гиперссылки на разделы справки F1.

Значения по умолчанию для функций компонента Database Engine

Настройка | Значение по умолчанию | Раздел справки F1
Специальные распределенные запросы | Выключено в новой установке. | Настройка контактной зоны для функциональных возможностей (нерегламентированные удаленные запросы) — компонент Database Engine
Интеграция среды CRL (CLR) | Выключено в новой установке. | Настройка контактной зоны для функциональных возможностей (интеграция со средой CLR) — компонент Database Engine
Выделенное административное соединение (DAC) | Выключено в новой установке. | Настройка контактной зоны для функциональных возможностей (DAC) — компонент Database Engine
Компонент Database Mail | Выключено в новой установке. | Настройка контактной зоны для функциональных возможностей (компонент Database Mail) — компонент Database Engine
Собственные веб-службы с поддержкой XML | Конечные точки не настроены по умолчанию. | Настройка контактной зоны для функциональных возможностей (собственные веб-службы с поддержкой XML) — компонент Database Engine
Хранимые процедуры OLE-автоматизации | Выключено в новой установке. | Настройка контактной зоны для функциональных возможностей (OLE-автоматизация) — компонент Database Engine
Компонент Service Broker | Конечные точки не настроены по умолчанию. | Настройка контактной зоны для функциональных возможностей (компонент Service Broker) — компонент Database Engine
Служба SQL Mail | Выключено в новой установке. | Настройка контактной зоны для функциональных возможностей (служба SQL Mail) — компонент Database Engine
Хранимые процедуры помощника Web Assistant | Выключено в новой установке. | Настройка контактной зоны для функциональных возможностей (помощник Web Assistant) — компонент Database Engine
xp_cmdshell | Выключено в новой установке. | Настройка контактной зоны для функциональных возможностей (xp_cmdshell) — компонент Database Engine

Значения по умолчанию для функций служб Analysis Services

Настройка | Значение по умолчанию | Раздел справки F1
Специальные запросы интеллектуального анализа данных | Выключено в новой установке. | Настройка контактной зоны для функциональных возможностей (нерегламентированные запросы интеллектуального анализа данных) — службы Analysis Services
Анонимные соединения | Выключено в новой установке. | Настройка контактной зоны для функциональных возможностей (анонимные соединения) — службы Analysis Services
Связанные объекты | Выключено в новой установке. | Настройка контактной зоны для функциональных возможностей (связанные объекты) — службы Analysis Services
Пользовательские функции | Выключено в новой установке. | Настройка контактной зоны для функциональных возможностей (пользовательские функции) — службы Analysis Services

Значения по умолчанию для функций служб Reporting Services

Функция | Параметр по умолчанию | Раздел справки F1
Запросы веб-службы и доступ через HTTP | Включено в новой установке. | Настройка контактной зоны для функциональных возможностей (веб-служба и HTTP-доступ) — службы Reporting Services
События и доставка отчетов по расписанию | Включено в новой установке. | Настройка контактной зоны для функциональных возможностей («Запланированные события» и «Доставка отчета») — службы Reporting Services
Встроенная безопасность Windows | Включено в новой установке. | Настройка контактной зоны для функциональных возможностей (встроенная безопасность Windows) — службы Reporting Services

См. также

Основные понятия

Настройка контактной зоны SQL Server
Настройка установки SQL Server


Настройка контактной зоны для функциональных возможностей (нерегламентированные удаленные запросы) — компонент Database Engine

Настройка контактной зоны для функциональных возможностей (нерегламентированные удаленные запросы) — компонент Database Engine |
 | См. также
Настройка установки SQL Server > Настройка контактной зоны SQL Server > Настройка контактной зоны для функциональных возможностей >

Нерегламентированные распределенные запросы используют функции OPENROWSET и OPENDATASOURCE для подключения к удаленным источникам данных, использующие OLE DB. Используйте это диалоговое окно для настройки поддержки нерегламентированных удаленных запросов.

Параметры

Включить поддержку функций OPENDATASOURCE и OPENROWSET

Если флажок установлен, то экземпляр компонента Database Engine поддерживает использование функций OPENROWSET и OPENDATASOURCE для выполнения удаленных запросов без изначального определения связанного сервера. Функции OPENROWSET и OPENDATASOURCE предназначены для редко используемых запросов. Если приложения не используют эти функции, то включать их не следует.

Дополнительные сведения о специальных запросах см. в разделе Идентификация источника данных по нерегламентированному имени электронной документации по SQL Server.

Дополнительные сведения о настройке параметров сервера см. в разделе Хранимая процедура sp_configure (Transact-SQL) электронной документации SQL Server.

См. также

Основные понятия

Настройка контактной зоны для функциональных возможностей
Конфигурация контактной зоны для служб и соединений


Настройка контактной зоны для функциональных возможностей (интеграция со средой CLR) — компонент Database Engine

Настройка контактной зоны для функциональных возможностей (интеграция со средой CLR) — компонент Database Engine |
 | См. также
Настройка установки SQL Server > Настройка контактной зоны SQL Server > Настройка контактной зоны для функциональных возможностей >

Выполнение пользовательских сборок внутри Microsoft SQL Server 2005 по умолчанию отключено. Данное диалоговое окно используется для настройки поддержки среды CLR (CLR).

Параметры

Включить интеграцию со средой CLR

Если этот флажок установлен, то можно использовать основанные на CLR пользовательские функции, процедуры, триггеры и типы из компонента Database Engine.

Даже если этот параметр отключен, можно запускать инструкции языка определения данных (DDL) для создания, изменения или удаления пользовательских сборок и модулей среды CLR, но невозможно исполнять код CLR.

Дополнительные сведения об интеграции со средой CLR см. в разделе Building Database Objects with Common Language Runtime (CLR) Integration электронной документации по SQL Server.

Дополнительные сведения о настройке параметров сервера см. в разделе Хранимая процедура sp_configure (Transact-SQL) электронной документации по SQL Server.

См. также

Основные понятия

Настройка контактной зоны для функциональных возможностей
Конфигурация контактной зоны для служб и соединений


Настройка контактной зоны для функциональных возможностей (DAC) — компонент Database Engine

Настройка контактной зоны для функциональных возможностей (DAC) — компонент Database Engine |
 | См. также
Настройка установки SQL Server > Настройка контактной зоны SQL Server > Настройка контактной зоны для функциональных возможностей >

Дата обновления: 5 декабря 2005 г.

Выделенное административное соединение (DAC) позволяет администратору подключиться к серверу для выполнения диагностических операций или инструкций языка Transact-SQL. DAC может использоваться в тех случаях, когда компонент Database Engine не отвечает на обычные соединения. По умолчанию эта функция включена только для локального соединения. Включение данного параметра позволяет использовать соединение DAC с удаленного компьютера. В конфигурации с кластеризацией необходимо установить этот параметр, чтобы разрешить соединение DAC.

Параметры

Задействовать удаленное DAC

Если этот флажок установлен, для удаленных компьютеров соединения DAC разрешены.

Дополнительные сведения о DAC см. в разделе Использование выделенного административного подключения электронной документации по SQL Server.

Дополнительные сведения о настройке параметров сервера см. в разделе Хранимая процедура sp_configure (Transact-SQL) электронной документации по SQL Server.

См. также

Основные понятия

Настройка контактной зоны для функциональных возможностей
Конфигурация контактной зоны для служб и соединений

Журнал изменений

Версия Журнал

5 декабря 2005 г.

Новое содержимое:
  • Добавлено разъяснение об использовании этого параметра в конфигурации с кластеризацией.


Настройка контактной зоны для функциональных возможностей (компонент Database Mail) — компонент Database Engine

Настройка контактной зоны для функциональных возможностей (компонент Database Mail) — компонент Database Engine |
 | См. также
Настройка установки SQL Server > Настройка контактной зоны SQL Server > Настройка контактной зоны для функциональных возможностей >

Database Mail - это новый компонент, предназначенный для отправки электронных сообщений из компоненты Database Engine по протоколу SMTP. Включайте хранимые процедуры Database Mail только в том случае, если планируется настроить и использовать компонент Database Mail.

Отключение компонента Database Mail не позволяет запускать программу Database Mail, однако если в момент изменения этого параметра она запущена, Database Mail продолжит выполняться и обрабатывать почту (без запросов и вложений) до тех пор, пока не завершит отправку почты и не будет оставаться в режиме ожидания в течение интервала времени, заданного с помощью параметра DatabaseMailExeMinimumLifeTime.

Параметры

Включить хранимые процедуры компонента Database Mail

Если этот флажок установлен, включаются расширенные хранимые процедуры поддержки компонента Database Mail. Для использования компонента Database Mail его необходимо настроить. Дополнительные сведения см. в разделе Компонент Database Mail электронной документации по Microsoft SQL Server.

Дополнительные сведения о настройке параметров SQL Server см. в разделе Хранимая процедура sp_configure (Transact-SQL) электронной документации по SQL Server.

См. также

Основные понятия

Настройка контактной зоны для функциональных возможностей
Конфигурация контактной зоны для служб и соединений


Настройка контактной зоны для функциональных возможностей (собственные веб-службы с поддержкой XML) — компонент Database Engine

Настройка контактной зоны для функциональных возможностей (собственные веб-службы с поддержкой XML) — компонент Database Engine |
 | См. также
Настройка установки SQL Server > Настройка контактной зоны SQL Server > Настройка контактной зоны для функциональных возможностей >

Собственные веб-службы с поддержкой XML обеспечивают доступ к базе данных по протоколу HTTP с использованием сообщений SOAP. Чтобы использовать эту возможность, необходимо создать и запустить конечные точки HTTP. Дополнительные сведения см. в разделах CREATE ENDPOINT (Transact-SQL) и Использование собственных веб-служб с поддержкой XML в SQL Server 2005 электронной документации Microsoft SQL Server 2005.

Примечание.
Конечные точки HTTP SOAP поддерживаются в операционных системах, начиная с Microsoft Windows XP с установленным пакетом обновления 2, и в Microsoft Windows Server 2003.

Параметры

Имя конечной точки

Имя конечной точки HTTP.

Состояние

Текущее состояние конечной точки. Возможные значения: запущена, остановлена или отключена.

Чтобы изменить состояние конечной точки, выберите его в поле "Состояние" и нажмите кнопку Применить.

  • Если состояние равно Запущена, его можно изменить на Остановлена. Остановка конечной точки одновременно останавливает и отключает ее.

  • Если состояние равно Остановлена или Отключена, его можно изменить на Запущена. Запуск конечной точки одновременно запускает и включает ее.

Если нужно лишь отключить конечную точку, воспользуйтесь инструкцией ALTER ENDPOINT (язык Transact-SQL).

См. также

Основные понятия

Настройка контактной зоны для функциональных возможностей
Конфигурация контактной зоны для служб и соединений


Настройка контактной зоны для функциональных возможностей (OLE-автоматизация) — компонент Database Engine

Настройка контактной зоны для функциональных возможностей (OLE-автоматизация) — компонент Database Engine |
 | См. также
Настройка установки SQL Server > Настройка контактной зоны SQL Server > Настройка контактной зоны для функциональных возможностей >

Расширенные хранимые процедуры OLE-автоматизации допускают ссылки пакетов языка Transact-SQL, хранимых процедур и триггеров на пользовательские объекты OLE-автоматизации. Используйте это диалоговое окно, чтобы определить, может ли выполняться какая-либо из приведенных ниже процедур OLE-автоматизации.

  • sp_OACreate

  • sp_OADestroy

  • sp_OAGetErrorInfo

  • sp_OAGetProperty

  • sp_OAMethod

  • sp_OASetProperty

  • sp_OAStop

В новых установках Microsoft SQL Server эти хранимые процедуры по умолчанию отключены.

Параметры

Включить OLE-автоматизацию

Если этот флажок установлен, включаются хранимые процедуры OLE-автоматизации.

Дополнительные сведения об OLE-автоматизации см. в разделе Объекты OLE-автоматизации в Transact-SQL электронной документации по SQL Server.

Дополнительные сведения о настройке параметров SQL Server см. в разделе Хранимая процедура sp_configure (Transact-SQL) электронной документации по SQL Server.

См. также

Основные понятия

Настройка контактной зоны для функциональных возможностей
Конфигурация контактной зоны для служб и соединений


Настройка контактной зоны для функциональных возможностей (компонент Service Broker) — компонент Database Engine

Настройка контактной зоны для функциональных возможностей (компонент Service Broker) — компонент Database Engine |
 | См. также
Настройка установки SQL Server > Настройка контактной зоны SQL Server > Настройка контактной зоны для функциональных возможностей >

Microsoft SQL Server использует конечную точку компонента Service Broker для связи с сервис-брокером за пределами экземпляра SQL Server.

Конечная точка представляет собой объект SQL Server, представляющий SQL Server возможность связи по сети. Каждая конечная точка поддерживает конкретный тип связи. Например, конечная точка HTTP позволяет SQL Server обрабатывать конкретные запросы SOAP. Конечная точка компонента Service Broker позволяет SQL Server отправлять и получать сообщения компонента Service Broker по сети.

Конечные точки компонента Service Broker можно запускать, останавливать или отключать. Это диалоговое окно можно использовать для запуска, остановки или отключения конечной точки компонента Service Broker для экземпляра.

Параметры

Конечная точка компонента Service Broker

Отображает имя конечной точки компонента Service Broker.

Состояние

Отображает текущее состояние конечной точки компонента Service Broker.

Чтобы изменить состояние, выберите новое состояние в поле "Состояние", а затем нажмите кнопку Применить.

  • Если состояние равно Запущена, то его можно изменить на Остановлена. Остановка конечной точки одновременно останавливает и отключает ее.

  • Если состояние равно Остановлена или Отключена, его можно изменить на Запущена. Запуск конечной точки одновременно включает и запускает ее.

Если необходимо только отключить конечную точку, используйте инструкцию ALTER ENDPOINT (Transact-SQL).

См. также

Основные понятия

Настройка контактной зоны для функциональных возможностей
Конфигурация контактной зоны для служб и соединений


Настройка контактной зоны для функциональных возможностей (служба SQL Mail) — компонент Database Engine

Настройка контактной зоны для функциональных возможностей (служба SQL Mail) — компонент Database Engine |
 | См. также
Настройка установки SQL Server > Настройка контактной зоны SQL Server > Настройка контактной зоны для функциональных возможностей >

Служба SQL Mail, вместо которой рекомендуется использовать компонент Database Mail, по умолчанию отключена. Используя это диалоговое окно, можно включить службу SQL Mail, которая поддерживается для обратной совместимости.

Параметры

Включить хранимые процедуры службы SQL Mail

Если установить этот флажок, включатся расширенные хранимые процедуры, поддерживающие службу SQL Mail.

Дополнительные сведения о службе SQL Mail см. в разделе Служба SQL Mail электронной документации по Microsoft SQL Server.

Дополнительные сведения о настройке параметров сервера см. в разделе Хранимая процедура sp_configure (Transact-SQL) электронной документации по SQL Server.

См. также

Основные понятия

Настройка контактной зоны для функциональных возможностей
Конфигурация контактной зоны для служб и соединений


Настройка контактной зоны для функциональных возможностей (помощник Web Assistant) — компонент Database Engine

Настройка контактной зоны для функциональных возможностей (помощник Web Assistant) — компонент Database Engine |
 | См. также
Настройка установки SQL Server > Настройка контактной зоны SQL Server > Настройка контактной зоны для функциональных возможностей >

Хранимые процедуры помощника Web Assistant формируют HTML-файлы из данных Microsoft SQL Server. Эти хранимые процедуры являются устаревшими в Microsoft SQL Server 2005. Используйте это диалоговое окно для включения процедур, используемых помощником Web Assistant.

Службы Reporting Services предоставляют дополнительные параметры для формирования веб-отчетов на основе данных SQL Server. Дополнительные сведения см. в разделе Службы SQL Server Reporting Services электронной документации по SQL Server.

Параметры

Включить помощник Web Assistant

Если этот флажок установлен, включаются хранимые процедуры помощника Web Assistant.

Дополнительные сведения о настройке параметров сервера см. в разделе Хранимая процедура sp_configure (Transact-SQL) электронной документации по SQL Server.

См. также

Основные понятия

Настройка контактной зоны для функциональных возможностей
Конфигурация контактной зоны для служб и соединений


Настройка контактной зоны для функциональных возможностей (xp_cmdshell) — компонент Database Engine

Настройка контактной зоны для функциональных возможностей (xp_cmdshell) — компонент Database Engine |
 | См. также
Настройка установки SQL Server > Настройка контактной зоны SQL Server > Настройка контактной зоны для функциональных возможностей >

Расширенная хранимая процедура xp_cmdshell выполняет командную строку как командная оболочка ОС и возвращает вывод в виде строк текста. Диалоговое окно xp_cmdshell в инструменте "Конфигурация контактной зоны" позволяет настраивать поддержку xp_cmdshell.

Параметры

Включить процедуру xp_cmdshell

Если этот флажок установлен, расширенная хранимая процедура xp_cmdshell может использоваться. Если этот флажок не установлен, расширенную хранимую процедуру xp_cmdshell использовать нельзя.

Дополнительные сведения о процедуре xp_cmdshell см. в разделе xp_cmdshell (Transact-SQL) электронной документации по Microsoft SQL Server.

Дополнительные сведениями о настройке параметров сервера см. в разделе Установка параметров конфигурации сервера электронной документации по SQL Server.

См. также

Основные понятия

Настройка контактной зоны SQL Server
Настройка контактной зоны для функциональных возможностей
Конфигурация контактной зоны для служб и соединений


Настройка контактной зоны для функциональных возможностей (нерегламентированные запросы интеллектуального анализа данных) — службы Analysis Services

Настройка контактной зоны для функциональных возможностей (нерегламентированные запросы интеллектуального анализа данных) — службы Analysis Services |
 | См. также
Настройка установки SQL Server > Настройка контактной зоны SQL Server > Настройка контактной зоны для функциональных возможностей >

Функция расширений интеллектуального анализа данных OPENROWSET поддерживает нерегламентированные запросы с помощью внешних поставщиков. Если приложения и сценарии не используют эту функцию, отключите нерегламентированные запросы интеллектуального анализа данных.

Если нерегламентированные запросы включены, можно включить или отключить передачу имени поставщика OLEDB и строки соединения при использовании OPENROWSET.

Параметры

Включить нерегламентированные запросы интеллектуального анализа данных

Если этот флажок установлен, функция расширения интеллектуального анализа данных OPENROWSET включена.

Дополнительные сведения см. в разделе OPENROWSET (расширения интеллектуального анализа данных) электронной документации по Microsoft SQL Server.

Дополнительные сведения о настройке параметров сервера см. в разделе Хранимая процедура sp_configure (Transact-SQL) в электронной документации по SQL Server.

См. также

Основные понятия

Настройка контактной зоны для функциональных возможностей
Конфигурация контактной зоны для служб и соединений


Настройка контактной зоны для функциональных возможностей (анонимные соединения) — службы Analysis Services

Настройка контактной зоны для функциональных возможностей (анонимные соединения) — службы Analysis Services |
 | См. также
Настройка установки SQL Server > Настройка контактной зоны SQL Server > Настройка контактной зоны для функциональных возможностей >

Анонимные соединения позволяют пользователям, не прошедшим проверку подлинности, устанавливать соединения со службами Analysis Services Microsoft SQL Server 2005. Если приложения не требуют, чтобы пользователи, не прошедшие проверку подлинности, подключались к экземпляру, отключите анонимные соединения.

По умолчанию службы Analysis Services не позволяют пользователям, не прошедшим проверку подлинности, устанавливать соединение с экземпляром. Установка анонимных соединений с экземпляром очень не рекомендуется, но может быть активирована с помощью среды SQL Server Management Studio для изменения значения свойства конфигурации сервера RequireClientAuthentication на 0 или с помощью этого диалогового окна.

Параметры

Включить анонимные соединения

Если этот параметр отмечен флажком, пользователи, не прошедшие проверку подлинности, могут подключаться к службам Analysis Services.

Дополнительные сведения о защите подключений к экземпляру служб Analysis Services см. в разделе Безопасность взаимодействия клиентов с экземпляром служб Analysis Services электронной документации по SQL Server.

См. также

Основные понятия

Настройка контактной зоны для функциональных возможностей
Конфигурация контактной зоны для служб и соединений


Настройка контактной зоны для функциональных возможностей (связанные объекты) — службы Analysis Services

Настройка контактной зоны для функциональных возможностей (связанные объекты) — службы Analysis Services |
 | См. также
Настройка установки SQL Server > Настройка контактной зоны SQL Server > Настройка контактной зоны для функциональных возможностей >

По умолчанию службы Microsoft SQL Server 2005 Analysis Services не позволяют создавать связанные объекты, такие, как связанные измерения и связанные группы мер. Для разрешения связывания этих объектов необходимо, чтобы оба экземпляра разрешили эту возможность. Это достигается изменением значений свойств конфигурации сервера Link\ToOtherInstanceEnabled и Link\FromOtherInstanceEnabled при помощи среды SQL Server Management Studio или при помощи этого диалогового окна.

Параметры

Включить связи с другими экземплярами

При проверке этот экземпляр служб аналитики может связываться с объектами других экземпляров служб Analysis Services.

Дополнительные сведения о связанных объектах см. в разделах Связанные измерения и Связанные группы мер электронной документации по SQL Server.

Включить связи от других экземпляров

При проверке другие экземпляры служб Analysis Services могут связываться с объектами этого экземпляра.

Дополнительные сведения о связанных объектах см. в разделах Связанные измерения и Связанные группы мер электронной документации по SQL Server.

См. также

Основные понятия

Настройка контактной зоны для функциональных возможностей
Конфигурация контактной зоны для служб и соединений


Настройка контактной зоны для функциональных возможностей (пользовательские функции) — службы Analysis Services

Настройка контактной зоны для функциональных возможностей (пользовательские функции) — службы Analysis Services |
 | См. также
Настройка установки SQL Server > Настройка контактной зоны SQL Server > Настройка контактной зоны для функциональных возможностей >

Службы Analysis Services позволяют загружать сборки, содержащие пользовательские функции. Эти функции могут основываться на среде CLR или могут быть объектами COM. Защита объектов, разработанных при помощи среды CLR, может быть обеспечена моделью безопасности CLR. Объекты COM не поддерживают эту модель безопасности. Если приложения не требуют использования пользовательских объектов COM, отключите загрузку этих объектов.

Параметры

Включить загрузку пользовательских функций COM

Если этот флажок установлен, службы Analysis Services будут загружать пользовательские функции COM.

Дополнительные сведения о настройке параметров сервера см. в разделе Хранимая процедура sp_configure (Transact-SQL) в электронной документации по Microsoft SQL Server.

См. также

Основные понятия

Настройка контактной зоны для функциональных возможностей
Конфигурация контактной зоны для служб и соединений


Настройка контактной зоны для функциональных возможностей («Запланированные события» и «Доставка отчета») — службы Reporting Services

Настройка контактной зоны для функциональных возможностей («Запланированные события» и «Доставка отчета») — службы Reporting Services |
 | См. также
Настройка установки SQL Server > Настройка контактной зоны SQL Server > Настройка контактной зоны для функциональных возможностей >

В службах Reporting Services можно создать расписание доставки отчета, выполнения моментальных снимков отчетов, а также задать истечение срока действия кэша отчетов. Если не нужны функции подписок или возможность планирования выполнения отчетов в определенные даты и в намеченное время, то расписания и обработка доставки могут быть отключены. Заметим, что при отключении этой возможности отчеты могут выполняться только по требованию, а электронная почта и доставка через общую папку недоступны.

Параметры

Включить планирование событий и доставки отчетов

Если установлен этот параметр, включается выполнение по расписанию событий и доставки отчетов.

Дополнительные сведения см. в разделе Обработчик планирования и доставки электронной документации по Microsoft SQL Server.

См. также

Основные понятия

Настройка контактной зоны для функциональных возможностей
Конфигурация контактной зоны для служб и соединений


Настройка контактной зоны для функциональных возможностей (веб-служба и HTTP-доступ) — службы Reporting Services

Настройка контактной зоны для функциональных возможностей (веб-служба и HTTP-доступ) — службы Reporting Services |
 | См. также
Настройка установки SQL Server > Настройка контактной зоны SQL Server > Настройка контактной зоны для функциональных возможностей >

Веб-службу сервера отчетов можно настроить так, чтобы все запросы по протоколу Simple Object Access Protocol (SOAP) и запросы доступа к URL-адресам игнорировались. Если в клиентских приложениях не используется веб-служба и для данного экземпляра служб Reporting Services не требуются диспетчер отчетов, построитель отчетов и среда Microsoft SQL Server Management Studio, то можно отключить HTTP-запросы и запросы веб-служб.

Параметры

Включить доступ к веб-службам и URL-адресам

Если данный флажок установлен, в службах Reporting Services разрешены соединения с использованием доступа по протоколу SOAP и доступа к URL-адресам.

Дополнительные сведения см. в разделах Report Server Web Service и URL Access электронной документации по SQL Server.

См. также

Основные понятия

Настройка контактной зоны для функциональных возможностей
Конфигурация контактной зоны для служб и соединений


Настройка контактной зоны для функциональных возможностей (встроенная безопасность Windows) — службы Reporting Services

Настройка контактной зоны для функциональных возможностей (встроенная безопасность Windows) — службы Reporting Services |
 | См. также
Настройка установки SQL Server > Настройка контактной зоны SQL Server > Настройка контактной зоны для функциональных возможностей >

В службах Reporting Services источники данных для отчетов могут использовать встроенную безопасность Windows для соединения с внешними источниками данных. Использование встроенной безопасности Windows, однако, может предоставить доступ к данным под учетной записью пользователя без информирования пользователя. Для гарантии того, что все соединения источников данных для отчетов используют явно заданный набор учетных данных, отключите встроенную безопасность Windows для источников данных для отчетов. Дополнительные сведения о том, почему встроенная безопасность может повысить риск, связанные с конфиденциальными данными, см. в разделе Встроенные средства безопасности и повышенные разрешения.

При отключении встроенной безопасности Windows уменьшается количество параметров для настройки учетных данных источников данных для отчетов. Этот уменьшенный набор параметров применяется к определению источников данных в диспетчере отчетов, среде Management Studio и любых средствах сторонних производителей, используемых для определения соединений с источниками данных для отчета. После отключения встроенной безопасности Windows учетные данные можно получить только следующими способами.

  • Запрашиваемые учетные данные. Пользователям выдается приглашение к вводу имени пользователя и пароля для запуска отчета. Учетные данные могут быть учетными данными домена Windows или учетными данными базы данных.

  • Сохраненные учетные данные. Учетные данные, используемые для запуска отчета, безопасно хранятся в базе данных сервера отчетов. Эти учетные данные могут быть учетными данными домена Windows или учетными данными базы данных. Можно хранить только один набор учетных данных для каждого источника данных. Все пользователи получают доступ к источнику данных, используя одни и те же учетные данные.

  • Без учетных данных. Этот параметр может использоваться, когда источник данных либо не требует учетных данных, либо допускает передачу учетных данных в строке соединения. Поскольку учетные данные отображаются в текстовом виде на странице свойств источника данных, использование данного параметра не рекомендуется. Для использования данного параметра необходимо настроить специальную учетную запись, используемую для автоматического выполнения отчетов. Дополнительные сведения см. в разделе Настройка учетной записи для автоматической обработки отчетов.

Примечание.
Отключение встроенной безопасности Windows не удаляет параметр Использовать встроенную безопасность Windows в диспетчере отчетов, среде Management Studio и средствах разработки отчетов. Если пользователь выберет встроенную безопасность Windows на сервере отчетов, то при выполнении отчета возникнет ошибка.

Параметры

Включить встроенную безопасность Windows для соединения с источниками данных отчетов

Использовать встроенную безопасность Windows для источников данных для отчетов.

Дополнительные сведения см. в разделе Встроенные средства безопасности и повышенные разрешения и Указание учетных данных и сведений о соединении.

См. также

Основные понятия

Настройка контактной зоны для функциональных возможностей
Конфигурация контактной зоны для служб и соединений


Конфигурация контактной зоны для служб и соединений

Конфигурация контактной зоны для служб и соединений |
 | См. также
Настройка установки SQL Server > Настройка контактной зоны SQL Server >

Средство "Настройка контактной зоны для функциональных возможностей" обеспечивает единый интерфейс включения и отключения служб Microsoft SQL Server 2005 и сетевых протоколов, используемых для удаленных соединений. Отключение неиспользуемых служб и типов соединений позволяет повысить защищенность экземпляров Microsoft SQL Server благодаря уменьшению контактной зоны Microsoft SQL Server.

В следующих таблицах перечислены значения по умолчанию для каждого параметра, а также приведены ссылки на разделы справки F1.

Параметры служб и сетевых протоколов Windows по умолчанию

Служба или протокол Параметр по умолчанию Раздел справки F1

Служба компонента Database Engine

Во время установки можно выбрать режим запуска: Автоматический или Вручную.

Настройка контактной зоны для служб и соединений (служба) — компонент Database Engine

Удаленные соединения компонента Database Engine

Удаленные соединения отключены в выпусках SQL Server 2005 Express Edition, Evaluation Edition и Developer Edition и включены в других выпусках.

Настройка контактной зоны для служб и соединений (удаленные соединения) — компонент Database Engine

Служба Analysis Services

Во время установки можно выбрать режим запуска: Автоматический или Вручную.

Настройка контактной зоны для служб и соединений (служба) — службы Analysis Services

Удаленные соединения служб Analysis Services

Удаленные соединения отключены в выпусках SQL Server 2005 Express Edition, Evaluation Edition и Developer Edition и включены в других выпусках.

Настройка контактной зоны для служб и соединений (удаленные соединения) — службы Analysis Services

Службы Reporting Services

Во время установки можно выбрать режим запуска: Автоматический или Вручную.

Настройка контактной зоны для служб и соединений (служба) — службы Reporting Services

Служба SQL Server Agent

Если служба установлена, то выбирается режим запуска Вручную и служба останавливается.

Настройка контактной зоны для служб и соединений (служба) — агент SQL Server

Служба компонента Full-Text Search

Если служба установлена, то выбирается режим запуска Вручную и служба останавливается.

Настройка контактной зоны для служб и соединений (служба) — компонент Full-Text Search

Экземпляры служб Notification Services

Службы не устанавливаются при установке.

Настройка контактной зоны для служб и соединений (служба) — службы Notification Services

Служба Integration Services

Если служба установлена, то выбирается режим запуска Автоматический.

Настройка контактной зоны для служб и соединений (служба) — службы Integration Services

Служба SQL Server Browser

В следующих условиях выбирается режим запуска Автоматический:

  • Если на сервере существуют именованные экземпляры ядра базы данных или служб Analysis Services

  • При установке в кластере

  • При параллельной установке с SQL Server 2000

Настройка контактной зоны для служб и соединений (служб) — обозреватель SQL Server

См. также

Основные понятия

Настройка контактной зоны SQL Server
Настройка контактной зоны для функциональных возможностей


Настройка контактной зоны для служб и соединений (служба) — компонент Database Engine

Настройка контактной зоны для служб и соединений (служба) — компонент Database Engine |
 | См. также
Настройка установки SQL Server > Настройка контактной зоны SQL Server > Конфигурация контактной зоны для служб и соединений >

Компонент Database Engine Windows устанавливается, только если установлен экземпляр компонента Database Engine. Данное диалоговое окно используется для изменения настроек службы для экземпляра.

Параметры

Имя службы

Имя службы.

Отображаемое имя

Имя, отображающееся в столбце Имя на панели "Службы" Microsoft Windows.

Описание

Описание службы, отображающееся в столбце Описание на панели служб Windows.

Тип запуска

Используется для настройки запуска службы.

Авто - служба запускается при загрузке системы.

Вручную - служба запускается вручную или зависимой службой и не запускается при загрузке системы.

Отключено - запрещает системе, пользователю и другим службам запускать данную службу.

Состояние службы

Показывает состояние службы.

Кнопка "Пуск"

Запускает службу.

Кнопка "Стоп"

Останавливает службу.

Кнопка "Пауза"

Приостанавливает службу.

Кнопка "Возобновить"

Возобновляет приостановленную службу.

См. также

Основные понятия

Конфигурация контактной зоны для служб и соединений
Настройка контактной зоны для функциональных возможностей


Настройка контактной зоны для служб и соединений (удаленные соединения) — компонент Database Engine

Настройка контактной зоны для служб и соединений (удаленные соединения) — компонент Database Engine |
 | См. также
Настройка установки SQL Server > Настройка контактной зоны SQL Server > Конфигурация контактной зоны для служб и соединений >

По умолчанию в выпусках SQL Server 2005 Express, Evaluation и Developer разрешены только локальные клиентские соединения. Выпуски Enterprise, Standard и Workgroup также прослушивают сеть для установки удаленных клиентских соединений по TCP/IP. Страница "Удаленные соединения" позволяет изменять протоколы, по которым SQL Server прослушивает сеть для установки входящих клиентских соединений. Предпочтительнее использовать TCP/IP, а не именованные каналы, поскольку это требует открытия меньшего количества портов в брандмауэре.

Настройки на странице "Удаленные соединения" касаются только входящих соединений и не влияют на внешние серверные соединения, такие как соединения, используемые в распределенных запросах.

Примечание.
Для применения изменений необходимо перезапустить службу экземпляра компонента Database Engine.

Параметры

Только локальные соединения

При выборе этого параметра экземпляр компонента Database Engine прослушивает только соединения с общедоступной памятью на локальном компьютере. Соединения от удаленных компьютеров приниматься не будут.

Примечание.
Порт выделенного административного соединения настраивается отдельно. См. раздел Настройка контактной зоны для функциональных возможностей (DAC) — компонент Database Engine.

Локальные и удаленные соединения

При выборе этого параметра экземпляр компонента Database Engine прослушивает соединения с локальным и удаленными компьютерами с помощью выбранных протоколов.

Использовать только TCP/IP

При выборе этого параметра экземпляр компонента Database Engine прослушивает удаленные соединения по протоколу TCP/IP и не учитывает именованные каналы.

Использовать только протокол именованных каналов

При выборе этого параметра экземпляр компонента Database Engine прослушивает удаленные соединения по протоколу именованных каналов и не учитывает TCP/IP.

Использовать протокол TCP/IP и протокол именованных каналов

При выборе этого параметра экземпляр компонента Database Engine прослушивает удаленные соединения по протоколу TCP/IP и протоколу именованных каналов.

См. также

Основные понятия

Конфигурация контактной зоны для служб и соединений
Настройка контактной зоны для функциональных возможностей


Настройка контактной зоны для служб и соединений (служба) — службы Analysis Services

Настройка контактной зоны для служб и соединений (служба) — службы Analysis Services |
 | См. также
Настройка установки SQL Server > Настройка контактной зоны SQL Server > Конфигурация контактной зоны для служб и соединений >

Служба Windows для служб Analysis Services устанавливается вместе с экземплярами служб Analysis Services. Данное диалоговое окно используется для изменения настроек службы.

Параметры

Имя службы

Имя службы.

Отображаемое имя

Имя, которое отображается в столбце Имя панели "Службы" Microsoft Windows.

Описание

Описание службы, которое также отображается в столбце Описание панели "Службы" Windows.

Тип запуска

Позволяет указать способ запуска службы.

Параметр Автоматически указывает, что служба запускается при запуске системы.

Параметр Вручную указывает, что служба запускается вручную или зависимой службой и не запускается при запуске системы.

Параметр Отключена запрещает системе, пользователю и другим службам запускать данную службу.

Состояние службы

Показывает состояние службы.

Кнопка "Запустить"

Запускает службу.

Кнопка "Остановить"

Завершает работу службы.

Кнопка "Приостановить"

Приостанавливает работу службы.?

Кнопка "Продолжить"

Возобновляет работу приостановленной службы.

См. также

Основные понятия

Настройка контактной зоны SQL Server
Конфигурация контактной зоны для служб и соединений


Настройка контактной зоны для служб и соединений (удаленные соединения) — службы Analysis Services

Настройка контактной зоны для служб и соединений (удаленные соединения) — службы Analysis Services |
 | См. также
Настройка установки SQL Server > Настройка контактной зоны SQL Server > Конфигурация контактной зоны для служб и соединений >

В выпусках Microsoft SQL Server 2005 Express Edition, Developer Edition и Evaluation Edition удаленные соединения по умолчанию отключены. В других выпусках удаленные соединения по умолчанию включены. Воспользуйтесь этим диалоговым окном для включения и отключения удаленных соединений.

Включение удаленных соединений для служб Analysis Services открывает порт TCP/IP на сервере. Включать удаленные соединения стоит только в том случае, если нужно разрешить соединения с удаленных компьютеров.

Примечание.
Для применения изменений протокола необходимо перезапустить службу Analysis Services.

Параметры

Только локальные соединения

Выберите этот параметр для отключения удаленных соединений.

Если этот параметр выбран, экземпляр Analysis Services прослушивает соединения только с локального компьютера. Соединения с удаленными компьютерами не устанавливаются.

Локальные и удаленные соединения

Выберите этот параметр для включения удаленных соединений.

Если этот параметр выбран, экземпляр Analysis Services прослушивает соединения с локального компьютера и с удаленных компьютеров при помощи TCP/IP.

См. также

Основные понятия

Конфигурация контактной зоны для служб и соединений
Настройка контактной зоны для функциональных возможностей


Настройка контактной зоны для служб и соединений (служба) — службы Reporting Services

Настройка контактной зоны для служб и соединений (служба) — службы Reporting Services |
 | См. также
Настройка установки SQL Server > Настройка контактной зоны SQL Server > Конфигурация контактной зоны для служб и соединений >

Служба Windows служб Reporting Services устанавливается только при установке служб Reporting Services. Данное диалоговое окно используется для изменения настроек службы.

Параметры

Имя службы

Имя службы.

Отображаемое имя

Имя, отображаемое в столбце Имя панели служб Microsoft Windows.

Описание

Описание службы, отображающееся в столбце Описание панели служб Windows.

Тип запуска

Настройте запуск службы.

Авто - служба запускается при загрузке системы.

Вручную - служба запускается вручную или зависимой службой и не запускается при загрузке системы.

Отключено - запрещает системе, пользователю и другим службам запускать данную службу.

Состояние службы

Показывает состояние службы.

Кнопка "Пуск"

Запускает службу.

Кнопка "Стоп"

Завершает работу службы.

Кнопка "Пауза"

Приостанавливает работу службы.

Кнопка "Продолжить"

Возобновляет работу приостановленной службы.

См. также

Основные понятия

Конфигурация контактной зоны для служб и соединений
Настройка контактной зоны для функциональных возможностей


Настройка контактной зоны для служб и соединений (служба) — агент SQL Server

Настройка контактной зоны для служб и соединений (служба) — агент SQL Server |
 | См. также
Настройка установки SQL Server > Настройка контактной зоны SQL Server > Конфигурация контактной зоны для служб и соединений >

Службы агента Microsoft SQL Server для систем Windows устанавливаются вместе с экземплярами компонента Database Engine. По умолчанию эта служба отключена и остановлена. Если нужно использовать автоматизированное администрирование, эту службу необходимо включить. Данное диалоговое окно используется для изменения настроек службы. Дополнительные сведения о настройке учетной записи для службы агента SQL Server см. в разделе Выбор учетной записи для службы агента SQL Server электронной документации Microsoft по SQL Server 2005.

Параметры

Имя службы

Имя службы.

Отображаемое имя

Имя, отображаемое в столбце Имя панели служб Windows.

Описание

Описание службы, которая также появляется в столбце Описание панели служб Microsoft Windows.

Тип запуска

Позволяет указать способ запуска службы.

Автоматически - служба запускается при запуске системы.

Вручную - служба запускается вручную или зависимой службой и не запускается при загрузке системы.

Отключена - запрещает системе, пользователю и другим службам запускать данную службу.

Состояние службы

Показывает состояние службы.

Кнопка "Пуск"

Запускает службу.

Кнопка "Остановить"

Завершает работу службы.

Кнопка "Пауза"

Приостанавливает работу службы.

Кнопка "Возобновить"

Возобновляет работу приостановленной службы.

См. также

Основные понятия

Конфигурация контактной зоны для служб и соединений
Настройка контактной зоны для функциональных возможностей


Настройка контактной зоны для служб и соединений (служба) — компонент Full-Text Search

Настройка контактной зоны для служб и соединений (служба) — компонент Full-Text Search |
 | См. также
Настройка установки SQL Server > Настройка контактной зоны SQL Server > Конфигурация контактной зоны для служб и соединений >

Механизм полнотекстового поиска Microsoft (MSFTE) для службы Microsoft SQL Server устанавливается только в случае, если установлен компонент Database Engine. Используйте это диалоговое окно для изменения настроек службы.

Параметры

Имя службы

Имя службы.

Отображаемое имя

Имя, отображающееся в столбце Имя на панели "Службы" Microsoft Windows.

Описание

Описание службы, также отображающееся на панели "Службы" Windows в столбце Описание.

Тип запуска

Используйте для настройки параметров запуска службы.

Параметр Автоматически указывает на то, что запуск службы осуществляется при запуске системы.

Параметр Вручную указывает на то, что пользователь или зависимая служба могут осуществить запуск службы, а при запуске системы служба не запускается.

Параметр Отключен предотвращает запуск службы системой, пользователем или какой-либо зависимой службой.

Состояние службы

Показывает состояние службы.

Кнопка "Запустить"

Запускает службу.

Кнопка "Остановить"

Останавливает службу.

Кнопка "Пауза"

Приостанавливает службу.

Кнопка "Возобновить"

Возобновляет приостановленную службу.

См. также

Основные понятия

Конфигурация контактной зоны для служб и соединений
Настройка контактной зоны для функциональных возможностей


Настройка контактной зоны для служб и соединений (служба) — службы Notification Services

Настройка контактной зоны для служб и соединений (служба) — службы Notification Services |
 | См. также
Настройка установки SQL Server > Настройка контактной зоны SQL Server > Конфигурация контактной зоны для служб и соединений >

Службу Windows для служб Notification Services можно установить при развертывании экземпляра служб Notification Services. Службы Microsoft Windows не устанавливаются при установке служб Notification Services. Если на сервере установлена одна или более служб Windows для служб Notification Services, используйте данное диалоговое окно для изменения их настроек.

Параметры

Имя службы

Имя службы.

Отображаемое имя

Имя, отображаемое в столбце Имя панели служб Windows.

Описание

Описание службы, которое также отображается в столбце Описание панели "Службы" Windows.

Тип запуска

Позволяет указать способ запуска службы.

Параметр Автоматически указывает, что служба запускается при запуске системы.

Параметр Вручную указывает, что запустить службу может пользователь или зависимая служба, а также то, что служба запускается вместе с системой.

Параметр Отключена запрещает системе, пользователю и другим службам запускать данную службу.

Состояние службы

Показывает состояние службы.

Кнопка "Запуск"

Запускает службу.

Кнопка "Остановить"

Завершает работу службы.

Кнопка "Пауза"

Приостанавливает работу службы.

Кнопка "Возобновить"

Возобновляет работу приостановленной службы.

См. также

Основные понятия

Конфигурация контактной зоны для служб и соединений
Настройка контактной зоны для функциональных возможностей


Настройка контактной зоны для служб и соединений (служба) — службы Integration Services

Настройка контактной зоны для служб и соединений (служба) — службы Integration Services |
 | См. также
Настройка установки SQL Server > Настройка контактной зоны SQL Server > Конфигурация контактной зоны для служб и соединений >

Служба Windows для служб Integration Services устанавливается только при их установке. Данное диалоговое окно используется для изменения настроек службы.

Параметры

Имя службы

Имя службы.

Отображаемое имя

Имя, которое отображается в столбце Имя панели "Службы" Microsoft Windows.

Описание

Описание службы, которое также отображается в столбце Описание панели "Службы" Windows.

Тип запуска

Позволяет указать способ запуска службы.

Автоматически - служба запускается при загрузке системы.

Вручную - служба запускается вручную или зависимой службой и не запускается при загрузке системы.

Отключена - запрещает системе, пользователю и другим службам запускать данную службу.

Состояние службы

Показывает состояние службы.

Кнопка "Запуск"

Запускает службу.

Кнопка "Остановить"

Завершает работу службы.

Кнопка "Пауза"

Приостанавливает работу службы.

Кнопка "Возобновить"

Возобновляет работу приостановленной службы.

См. также

Основные понятия

Настройка контактной зоны SQL Server
Конфигурация контактной зоны для служб и соединений


Настройка контактной зоны для служб и соединений (служб) — обозреватель SQL Server

Настройка контактной зоны для служб и соединений (служб) — обозреватель SQL Server |
 | См. также
Настройка установки SQL Server > Настройка контактной зоны SQL Server > Конфигурация контактной зоны для служб и соединений >

Служба обозревателя SQL Server возвращает именованный канал и данные порта TCP клиентским приложениям. Включение этой службы полезно, когда имя канала или номер порта именованного экземпляра неизвестно клиентским приложениям. Если отключить эту службу, то можно выбрать статические порты для именованных экземпляров компонента Database Engine и затем задать номер порта в клиентских соединениях. Для именованных экземпляров служб Analysis Services лучше включить службу обозревателя SQL Server.

Параметры

Имя службы

Имя службы.

Отображаемое имя

Имя, отображаемое в столбце Имя панели служб Windows.

Описание

Описание службы, которое также появляется в столбце Описание панели служб Microsoft Windows.

Тип запуска

Используется для настройки запуска службы.

Автоматически указывает, что служба будет запущена в ходе запуска системы.

Вручную указывает, что службу запустить может пользователь или зависимая служба, а также то, что служба не будет запущена вместе с системой.

Отключено запрещает запуск службы системой, пользователем или иной зависимой службой.

Состояние службы

Показывает состояние службы.

Кнопка "Запустить"

Запускает службу.

Кнопка "Остановить"

Останавливает службу.

Кнопка "Приостановить"

Приостанавливает службу.

Кнопка "Возобновить"

Возобновляет приостановленную службу.

См. также

Основные понятия

Конфигурация контактной зоны для служб и соединений
Настройка контактной зоны для функциональных возможностей


Программа sac

Программа sac |
 | См. также
Настройка установки SQL Server > Настройка контактной зоны SQL Server >

Программа sac выполняет операции импорта и экспорта параметров контактной зоны . С помощью этой программы можно настроить контактную зону на одном компьютере, а затем применить те же настройки на других компьютерах.

Самый легкий способ использования программы sac заключается в применении графического интерфейса для конфигурации контактной зоны SQL Server на одном компьютере и последующем использовании sac для экспорта настроек этого компьютера в файл. Затем можно использовать программу sac для применения настроек всех компонентов SQL Server 2005 на других экземплярах SQL Server 2005 на локальном компьютере или на удаленных компьютерах.

Это программа расположена в папке «x:\Program Files\Microsoft SQL Server\90\Shared».

Синтаксис

sac {in | out} filename [-S computer_name]
    [-U SQL_login [–P SQL_ password]]
    [-I instance_name ]
    [-DE] [-AS] [-RS] [-IS] [-NS] [-AG] [-BS] [-FT]
    [-F] [-N] [-T] [-O]
    [-H | -?]

Параметры

in

Импорт настроек контактной зоны из файла и настройка экземпляра с именем instance_name с применением этих настроек.

out

Экспорт настроек конфигурации контактной зоны из экземпляра в файл с именем имя_файла.

filename

При импорте или экспорте настроек контактной зоны необходимо использовать полный путь файла.

-S computer_name

Задает имя удаленного компьютера. Если этот аргумент не указан, программа sac подключается к локальному компьютеру.

-U SQL_login

Указывает имя входа SQL Server, которое нужно использовать для соединения с компонентом Database Engine. Если оно не указано, программа sac использует для соединения с компонентом Database Engine проверку подлинности Windows.

-P SQL_password

Задает пароль для SQL_login. Если этот аргумент не указан, то программа dta запрашивает пароль. При использовании -P в конце команды без указания значения sac использует пароль со значением NULL.

-I instance_name

Определяет экземпляр SQL Server, с которым будет использоваться программа sac. Если этот параметр не указан, программа sac соединяется со всеми экземплярами SQL Server. Именем экземпляра по умолчанию является MSSQLServer.

-DE

Импорт или экспорт настроек компонента Database Engine.

-AS

Импорт или экспорт настроек служб Analysis Services.

-RS

Импорт или экспорт настроек служб Reporting Services.

-IS

Импорт или экспорт настроек служб Integration Services.

-NS

Импорт или экспорт настроек служб Notification Services.

-AG

Импорт или экспорт настроек агента SQL Server.

-BS

Импорт или экспорт настроек службы обозревателя SQL Server.

-FT

Импорт или экспорт настроек службы полнотекстового поиска.

-F

Импорт или экспорт состояния следующих наборов функций для указанных компонентов:

Компонент Наборы функций

Database Engine

Нерегламентированные удаленные запросы

Интеграция со средой CLR

Соединения DAC

Компонент Database Mail

Собственная веб-служба XML

OLE-автоматизация

SQL Server Service Broker

Служба SQL Mail

Помощник Web assistant

xp_cmdshell

Analysis Services

Нерегламентированные запросы интеллектуального анализа данных

Анонимные соединения

Связанные объекты

Пользовательские функции

Reporting Services

Запланированные события и доставка отчетов

Веб-служба и HTTP-доступ

Встроенная безопасность Windows
-N

Импорт или экспорт состояния сетевых протоколов для возможности удаленного подключения указанных компонентов. Только Database Engine и Analysis Services предоставляют возможности для настройки удаленных подключений.

-T

Импорт или экспорт состояния служб Windows для указанных компонентов.

-O

Задает имя файла, в который записываются данные, выводимые программой sac в окно командной строки.

-H | -?

Отображает синтаксис команды. Остальные аргументы не учитываются.

Замечания

В программе sac действуют следующие правила.

  • Аргументы не учитывают регистр.

  • Аргументы команд должны начинаться с дефиса (-) или косой черты (/). Эти символы равнозначны.

  • Аргумент и значение должны разделяться пробелом.

  • Если значение содержит специальные символы, следует заключить его в кавычки.

Примеры

В следующих примерах показаны распространенные сценарии использования программы sac:

A. Экспорт всех настроек экземпляра по умолчанию

В следующем примере показан способ экспорта всех настроек функций, соединений и служб для экземпляра SQL Server по умолчанию в файл server1.out. Поскольку пример задает имя пользователя, но не задает пароль, программа sac запросит ввод пароля.

Копировать код
sac out server1.out –S server1 –U admin –I MSSQLSERVER

Б. Импорт настроек функций на другой сервер

В следующем примере производится импорт только настроек функций из файла server1.out и применение их к экземпляру SQL Server по умолчанию на сервере 2. Поскольку в данном примере не указывается имя пользователя, программа sac использует проверку подлинности Windows.

Копировать код
sac in server1.out –S server2 –F

В. Экспорт всех локальных настроек функций и сетевых компонентов

В следующем примере будет произведен экспорт всех настроек функций и настроек соединения, за исключением настроек служб, для всех экземпляров и компонентов SQL Server на локальном сервере в файл server1.out.

Копировать код
sac out server1.out –F –N

Г. Импорт всех настроек

Следующий пример производит импорт на сервер server2 всех настроек, доступных в файле server1.out.

Копировать код
sac in server1.out –S server2

Д. Экспорт всех настроек компонента Database Engine

В следующем примере производится экспорт всех настроек всех экземпляров компонента Database Engine на локальном сервере в файл server1.out.

Копировать код
sac out server1.out –DE

Ж. Импорт настроек состояния служб

Следующий пример производит импорт только настроек состояния служб из файла server1.out и применяет эти настройки служб к серверу server2.

Копировать код
sac in server1.out –S server2 -T

См. также

Основные понятия

Настройка контактной зоны SQL Server

Другие ресурсы

Программы командной строки

Журнал изменений

Версия Журнал

Измененное содержимое:
  • Из описания синтаксиса удален параметр -AD.


Настройка служб Reporting Services

Настройка служб Reporting Services |
 | См. также
Настройка установки SQL Server >

Используйте программу настройки служб Reporting Services для изменения конфигурации установленной копии служб SQL Server 2005 Reporting Services. Если сервер отчетов был установлен в режиме «только файлы», то перед использованием сервера необходимо применить программу настройки. Если сервер отчетов устанавливался в режиме по умолчанию, то эту программу можно использовать для проверки или изменения настроек, указанных во время установки. Если обновляется предыдущая версия, эту программу можно использовать для преобразования базы данных сервера отчетов в новый формат.

Программа настройки служб Reporting Services может использоваться для настройки экземпляра локального или удаленного сервера отчетов. Для этого необходимо иметь права локального системного администратора на компьютере того сервера отчетов, который нужно настроить.

Примечание.
Программа настройки служб Reporting Services использует значки для обозначения установленных настроек. Однако существует вероятность, что будут заданы недопустимые настройки. Необходимо всегда тестировать службы Reporting Services после установки, чтобы убедиться в их работоспособности. Визуальные индикаторы состояния настройки не заменяют тесты, проверяющие удачное развертывание. Дополнительные сведения о проверке развертывания см. в разделе Как проверить установки служб Reporting Services.

В этом разделе

Ссылка | Описание
Настройка сервера отчетов для доступа через Интернет | Описывает различные подходы по развертыванию отчетов на веб-узле.
Настройка масштабного развертывания сервера отчетов | Объясняет настройку нескольких экземпляров сервера отчетов для использования общей базы данных сервера отчетов.
Настройка служб Reporting Services для интеграции с SharePoint 3.0 | Предоставлены пошаговые инструкции по настройке сервера отчета для его запуска в составе более широкого развертывания продукта или технологии SharePoint.
Настройка виртуальных каталогов сервера отчетов | Описывает создание виртуальных каталогов, используемых для доступа к серверу отчетов и диспетчеру отчетов.
Настройка учетных записей и паролей служб в службах Reporting Services | Содержит рекомендации, описывает шаги для изменения учетных записей служб и паролей.
Создание базы данных сервера отчетов | Описывает создание базы данных сервера отчетов, необходимой для хранения метаданных и объектов сервера.
Настройка соединения с базой данных сервера отчетов | Описывает изменение строки соединения, используемой сервером отчетов для подключения к базе данных сервера отчетов.
Настройка сервера отчетов для работы с электронной почтой | Описывает настройку сервера отчетов для поддержки рассылки отчетов по электронной почте.
Настройка учетной записи для автоматической обработки отчетов | Описывает настройку пользовательской учетной записи для обработки отчетов в автоматическом режиме.
Администрирование баз данных сервера отчетов | Описывает административные задачи и предоставляет сведения о ролях и разрешениях базы данных.
Администрирование службы Windows и веб-службы сервера отчетов | Описывает цель и функцию каждой службы и методы доступа к этим службам.
Запуск и остановка службы Windows сервера отчетов | Объясняет, как запустить и остановить службу Windows сервера отчетов.
Управление ключами шифрования | Объясняет, как пользоваться и управлять ключами шифрования, используемыми при сохранении конфиденциальных данных.
Разделы руководства по настройке служб Reporting Services | Предоставляет пошаговую инструкцию по выполнению типичных задач.
Справка F1 по настройке служб Reporting Services | Содержит разделы справки по страницам в программе настройки служб Reporting Services.

В электронной документации по SQL Server 2005

Справка в Интернете по программе настройки служб Reporting Services входит в состав документации по службам Reporting Services сервера SQL Server 2005. Полный набор документации по продукту содержится в электронной документации по SQL Server 2005.

Пользуясь электронной документацией по SQL Server, пользователь имеет доступ ко всем подразделам, содержащимся в этой справочной системе в Интернете, а также к дополнительным сведениям о развертывании, администрировании и обеспечении безопасности установки служб Reporting Services. Дополнительные сведения см. в разделе Как получить доступ к электронной документации по SQL Server 2005.

См. также

Основные понятия

Установка служб SQL Server Reporting Services
Обновление служб Reporting Services
Настройка установки SQL Server

Другие ресурсы

Разделы руководства по установке служб Reporting Services


Настройка сервера отчетов для доступа через Интернет

Настройка сервера отчетов для доступа через Интернет |
 | См. также
Настройка установки SQL Server > Настройка служб Reporting Services >

Дата обновления: 14 апреля 2006 г.

Хотя службы SQL Server Reporting Services разрабатывались не для развертывания отчетов в Интернете, эти службы можно успешно использовать на веб-сервере, чтобы для широкой публики распространять сведения общего характера, а для прошедших проверку и авторизованных пользователей — корпоративные служебные данные. В зависимости от требований пользователей и приложений можно выбрать любой из следующих подходов:

  • Внедренные отчеты, находящиеся в системе управления веб-узла ReportViewer в создаваемом и развертываемом пользовательском интернет-приложении.

  • Развертывание сервера отчетов в экстрасети при использовании проверки подлинности Windows.

  • Развертывание сервера отчетов в экстрасети при использовании собственной проверки подлинности.

  • Настройка сервера отчетов для запуска в качестве внутреннего сервера в составе более широкого развертывания продукта или технологии SharePoint, в которой клиентский сервер настраивается для развертывания в Интернете.

Примечание.
Диспетчер отчетов не предназначен для работы в качестве интернет-приложения, однако его можно установить на веб-сервер, а затем установить сервер отчетов и базу данных сервера отчетов, защищенную брандмауэром. Чтобы установить диспетчер отчетов на веб-сервер, необходимо выбрать в качестве компонентов сервер отчетов и диспетчер отчетов. После окончания установки можно воспользоваться средством настройки контактной зоны SQL Server для отключения экземпляра сервера отчетов, установленного с диспетчером отчетов. Затем можно настроить диспетчер отчетов для использования второго экземпляра сервера отчетов, защищенного брандмауэром. Для установки указателя диспетчера отчетов на экземпляр сервера отчетов необходимо изменить установки <ReportServerVirtualDirectory> и <ReportServerUrl> в файле RSWebApplication.config.

Применение элементов управления веб-сервера ReportViewer для поддержки отчетов в интернет-приложении

Для развертывания отчетов в интернет-приложении элементы управления веб-сервером ReportViewer могут быть внедрены в созданное и развернутое пользовательское интернет-приложение. Входящий в комплект поставки Visual Studio 2005 элемент управления веб-сервером ReportViewer можно бесплатно распространять вместе с приложением. Элемент управления можно настроить для отображения отчетов, выполняемых на сервере отчетов. Соединение между приложением и сервером отчетов обеспечивается элементом управления через программный интерфейс веб-службы. Все действия по проверке подлинности и авторизации выполняются вашим приложением, которое подключается к серверу отчетов по единственному, доверенному для пользователя соединению.

Примечание.
Элементы управления ReportViewer могут использоваться независимо от служб Reporting Services для хранения файлов определений клиентских отчетов (RDLC), обеспечиваемых приложением. Дополнительные сведения см. в разделе Сравнение служб Reporting Services и элементов управления ReportViewer электронной документации по SQL Server.

Развертывание сервера отчетов и диспетчера отчетов в экстрасети

Чтобы развернуть сервер отчетов в рамках сценария для экстрасети, поддерживающего подключения предопределенных учетных записей службы Microsoft Active Directory, можно использовать стандартный модуль безопасности Windows Authentication. Рассмотрите возможность настроить сервер для подключений по протоколу SSL и использовать обычную проверку подлинности в службах IIS.

Чтобы развернуть сервер отчетов в рамках сценария для экстрасети, поддерживающего подключения с помощью технологии отдельной регистрации входа или модели проверки подлинности, основанной на использовании форм и хранящей сведения о пользователе в базе данных, следует создать нестандартный модуль авторизации для замены стандартного модуля безопасности Windows Authentication. Проверка подлинности на основе форм обычно используется, когда сервер отчетов открывается для широкой публики, но при этом нужно, чтобы только прошедшие проверку пользователи могли видеть его содержимое. По умолчанию службы SQL Server Reporting Services не содержат модуля авторизации на основе форм. Дополнительные сведения о способах создания модуля см. в разделе Implementing a Security Extension электронной документации по SQL Server.

Внимание!
Не рекомендуется настраивать сервер отчетов на доступ «Anonymous», если только не используется пользовательская проверка подлинности. Если не используется пользовательская проверка подлинности, а доступ «Anonymous» на сервере отчетов все же настроен, то станет невозможным сопоставлять пользователей с теми или иными ролями каким-либо разумным способом. Все пользователи будут получать доступ к серверу отчетов под учетной записью «Anonymous», и ни у кого из них не будет разрешения администрировать сервер отчетов с помощью диспетчера отчетов или среды Management Studio. Определяемые после этого назначения ролей не будут отличаться для отдельных пользователей; все пользователи будут иметь равные права доступа к одному и тому же содержимому, а отчеты, запрашивающие данные, зависящие от пользователя, не будут выполняться.

Для развертывания сервера отчетов и диспетчера отчетов на одном компьютере следуйте следующим рекомендациям:

  1. Установите службы Reporting Services на веб-сервере в режиме «только файлы». В мастере установки SQL Server это — вариант Установить, но не настраивать.

  2. Защитите соединение между веб-сервером и экземпляром компонента SQL Server Database Engine, на котором собираетесь поместить базу данных сервера отчетов. Для защиты этого соединения можно воспользоваться протоколом IPSec.

  3. После завершения программы установки воспользуйтесь программой настройки служб Reporting Services, чтобы настроить сервер отчетов:

    1. Укажите учетные записи служб и создайте базу данных сервера отчетов.

    2. Если экземпляр SQL Server находится в другом домене, а протокол Kerberos 5.0 не активизирован, пользуйтесь для подключения к базе данных сервера отчетов проверкой подлинности SQL Server.

  4. Настройте виртуальные каталоги сервера отчетов и диспетчера отчетов, выбирая для доступа через Интернет настроенный веб-узел.

Примечание.
В предыдущих версиях при развертывании сервера отчетов на веб-сервере было необходимо изменять настройки конфигурации. В настоящее время этот шаг выполнять не требуется при условии, что диспетчер отчетов и сервер отчетов устанавливаются вместе.

Настройка параметров прокси-сервера в файлах Web.config

В службы SQL Server 2005 Reporting Services входит параметр Web.config, позволяющий диспетчеру отчетов не обращаться к прокси-серверу при отправке запросов к локальному серверу отчетов, установленному на том же компьютере.

Параметр Web.config представляет собой сетевой параметр defaultProxy платформы System.NET. По умолчанию параметр defaultProxy в файле Web.config для диспетчера отчетов отключен. Именно эту конфигурацию рекомендуется использовать, когда диспетчер отчетов и сервер отчетов вместе развертываются на одном компьютере.

При обновлении служб Reporting Services с версии SQL Server 2000 параметр конфигурации defaultProxy в файле Web.config диспетчера отчетов будет отсутствовать. Для конфигураций, в которых диспетчер отчетов и сервер отчетов выполняются на одном компьютере, параметр defaultProxy можно добавить и включить. Скопируйте следующие настройки в файл Web.config диспетчера отчетов:

Копировать код
<configuration>...<system.net>  <defaultProxy enabled="false" /></system.net></configuration>

Дополнительные сведения об этих параметрах см. в разделах «Настройка интернет-приложений» и «Элемент defaultProxy (сетевые параметры)» в руководстве разработчика для платформы Microsoft .NET Framework.

Проверка развертывания в Интернете

Чтобы убедиться в том, что сервер отчетов доступен, необходимо иметь возможность просмотра пространства имен папок сервера отчетов по интернет-подключению при вводе адреса http: (или https:)//<полное-доменное-имя-вашего-веб-сервера>/сервер_отчетов, где /сервер_отчетов является именем по умолчанию виртуального каталога сервера отчетов.

Примечание.
Развертывание служб Reporting Services на веб-сервере требует тщательных расчетов. Программное обеспечение для обеспечения работы в сети и безопасности, топология сети и конфигурация доменов может изменять характеристики таким образом, что задание точной последовательности шагов развертывания сервера отчетов оказывается затруднительным. При оценке сервера отчетов для доступа через Интернет удостоверьтесь, что используемые для тестирования сценарии включают все функциональные возможности, которые будут использованы, и что тестирование всегда производится по безопасным соединениям.

Запуск сервера отчетов в составе развертывания продукта или технологии SharePoint в Интернете

Если имеется экземпляр продукта или технологии SharePoint, настроенный для соединений через Интернет, этот экземпляр можно использовать в качестве клиентского сервера для отчетов, выполняющихся на сервере отчетов служб Reporting Services. Поставщик проверки подлинности и разрешения, настроенные для веб-фермы SharePoint, используются доступу к содержимому и операциям сервера отчетов. Функции безопасности SharePoint помогают избегать использования пользовательского модуля проверки подлинности на сервере отчетов, который необходимо создать и развернуть вручную. Это также устраняет необходимость установки веб-узла сервера для Интернет-соединений. Дополнительные сведения об интеграции сервера см. в разделе Интеграция служб Reporting Services и технологии SharePoint.

См. также

Основные понятия

Настройка виртуальных каталогов сервера отчетов

Другие ресурсы

Файл конфигурации RSWebApplication
Развертывание служб Reporting Services
Встроенные средства безопасности и повышенные разрешения
Настройка системы безопасности сервера отчетов


Настройка масштабного развертывания сервера отчетов

Настройка масштабного развертывания сервера отчетов |
 | См. также
Настройка установки SQL Server > Настройка служб Reporting Services >

Масштабное развертывание означает установочную конфигурацию, состоящую из множества экземпляров сервера отчетов, использующих одну базу данных сервера отчетов. Эта модель развертывания используется при необходимости запустить службы Reporting Services в кластере сервера. Настройка узлов сервера отчетов для использования общей базы данных является предварительным условием для запуска серверов отчетов в кластере.

Требования для масштабного развертывания включают следующее:

  • Службы Reporting Services должны быть одного из следующих выпусков: Enterprise Edition, Developer Edition или Evaluation Edition. Масштабное развертывание не поддерживается в выпуске Standard Edition. Масштабное развертывание можно выполнить, используя сочетание выпусков, однако они все должны поддерживать эту возможность.

  • Необходимо, чтобы все серверы отчетов находились в одном домене или в доверенном домене.

  • Все серверы отчетов должны иметь одну и ту же версию (SQL Server 2005 или пакет обновления 1 (SP1)).

Масштабное развертывание сервера отчетов может включать экземпляры сервера отчетов, настроенные для запуска в собственном режиме, или экземпляры, настроенные для режима интеграции с SharePoint. Невозможно создать масштабное развертывание, включающее экземпляры сервера отчетов, которые будут выполняться в разных режимах. Дополнительные сведения о режимах сервера см. в разделе Режимы развертывания для служб Reporting Services.

Важно!
Для запуска масштабного развертывания сервера отчетов на отказоустойчивом кластере необходимо также наличие программного обеспечения и средств, предназначенных для создания и обслуживания кластера. Службы Reporting Services не предоставляют этой возможности. Дополнительные сведения о запуске служб Reporting Services в составе отказоустойчивого кластера см. в разделе Планирование развертывания служб Reporting Services электронной документации по SQL Server.

Шаги масштабного развертывания сервера отчетов

Шаги развертывания включают установку, настройку при помощи программы настройки служб Reporting Services и ручное изменение файлов конфигурации сервера отчетов. При использовании приложения Microsoft Application Center необходимо исключить файлы конфигурации из операций по репликации.

Предустановочные шаги для развертывания Application Center

При использовании программы Application Center для управления кластерами серверов необходимо определить фильтры, чтобы исключить файл конфигурации сервера отчетов (RSReportServer.config) из операций по репликации. Для установки необходимых экземпляров сервера отчетов нужно использовать параметр установки «только файлы». Это позволит установить фильтр перед выполнением настройки экземпляров сервера отчетов, которые будут включены в кластер.

  1. Чтобы установить фильтр, необходимо открыть консоль Application Center 2000, щелкнуть правой кнопкой мыши Синхронизации и выбрать Свойства.

  2. Определите фильтр, исключающий файл RSReportServer.config. По умолчанию путь к файлу: c:\Program Files\Microsoft SQL Server\MSSQLn\Reporting Services\ReportServer\RSReportServer.config.

Создание и настройка экземпляров сервера отчетов

Можно установить службы Reporting Services на узлы, уже являющиеся частью кластера сервера. Для установки и активации функциональности служб Reporting Services необходимо выполнить следующие шаги.

  1. Установите и произведите настройку сервера отчетов с масштабным развертыванием. Дополнительные сведения см. в разделе Как настроить масштабное развертывание сервера отчетов (настройка служб Reporting Services).

  2. Запустите средство настройки контактной зоны SQL Server, чтобы проверить, включены ли службы Reporting Services. Включить и запустить службу Windows сервера отчетов. Служба будет включена и запущена при выборе в программе установки параметра Запускать автоматически. Дополнительные сведения см. в разделе Настройка контактной зоны SQL Server.

  3. Настройте проверку состояния представления, изменив файл Web.config диспетчера отчетов для каждого экземпляра сервера отчетов, входящего в развертывание. Этот шаг производится после того, как все узлы в конфигурации с масштабным развертыванием установлены и проинициализированы, но до изменения файлов конфигурации служб Reporting Services. Как только входящие запросы распределены по узлам, должна быть правильно настроена проверка состояния представления. В противном случае появится множество исключений из-за того, что проверка состояния не проходит представления. Дополнительные сведения см. в разделе Настройка проверки состояния представления ниже в этом подразделе.

  4. При использовании протокола SSL убедитесь, что сертификаты SSL установлены в пулах приложений IIS и что виртуальные каталоги настроены на его использование. Страницы «Виртуальные каталоги» программы настройки служб Reporting Services предназначены для задания SSL-соединений как для диспетчера отчетов, так и для сервера отчетов. Прежде чем переходить к следующему шагу, убедитесь, что серверы отчетов настроены правильно, открыв диспетчер отчетов через https://. Дополнительные сведения об использовании протокола SSL для сервера отчетов см. в разделе Настройка сервера отчетов для соединений по протоколу SSL.

  5. Создайте резервную копию всех файлов конфигурации, чтобы в дальнейшем можно быть произвести откат. Последующие шаги подразумевают изменение этих файлов. Если при этом будет допущена ошибка, можно будет выполнить откат до копий, созданных на этом шаге. Необходимо сохранить файлы RSReportServer.config, RSWebApplication.config и Web.config, относящиеся к серверу отчетов и к диспетчеру отчетов.

  6. При использовании виртуального сервера в качестве отдельной точки доступа к кластеру со сбалансированной нагрузкой на сеть (NLB) выполните следующие дополнительные шаги:

    1. Измените файлы конфигурации служб Reporting Services, указав имя виртуального сервера. Дополнительные сведения см. в разделе Указание имени виртуального сервера в файлах конфигурации служб Reporting Services ниже в этом подразделе.

    2. В IIS настройте переадресацию на URL-адрес виртуального сервера. Для этого установите параметры на вкладке «Корневой каталог» в свойствах веб-узла.

    3. Проверьте, чтобы масштабное развертывание было доступно по имени виртуального сервера (например, https://MyReportPortal/reportserver и https://MyReportPortal/reports). Какой из узлов фактически обработал отчет, можно выяснить в файлах журнала либо просмотреть журнал выполнения сервера отчетов (таблица журнала выполнения содержит столбец InstanceName, в котором отражено, который из экземпляров обработал конкретный запрос). Дополнительные сведения см. в разделе Файлы журнала служб Reporting Services электронной документации по SQL Server.

Настройка проверки состояния представления

Для завершения настройки масштабного развертывания необходимо изменить файлы конфигурации, включив проверку состояния представления для интерактивных HTML-отчетов, которые просматриваются в диспетчере отчетов.

В платформе Microsoft .NET Framework 2.0 проверка состояния представления включена по умолчанию, для выполнения проверки используются сведения об идентификаторе процесса ASP.NET. Проверка по идентификатору процесса невозможна в кластерном сценарии или сценарии с горизонтальным масштабированием, где идентификатор процесса различен для каждого узла. Как вариант можно создать ключ проверки для обеспечения проверки состояния представления и вручную настроить для использования каждый узел сервера отчетов.

Следующие шаги содержат ссылки на создание ключей для элемента <machineKey>. Существует множество способов создания значений ключей; их описание представлено в документации .NET Framework. Дополнительные сведения о настройке проверки состояния представления для сети веб-служб см. в справочной документации .NET Framework для элемента <machineKey>.

  1. Создайте ключ проверки. Можно использовать функцию автоформирования, представленную .NET Framework, или создать ключ другим способом. Не используйте параметр AutoGenerate при установке атрибута validationKey.

  2. Создайте ключ расшифровки. Для ключа расшифровки можно задать явное значение, или установить для атрибута decryptionKey значение AutoGenerate.

  3. Откройте в диспетчере отчетов файл Web.config и задайте элемент <machineKey>. Необходимо указать ключ проверки, ключ расшифровки и тип шифрования, используемый для проверки данных. Следующий пример показывает, какие элементы должны быть указаны (значения, содержащиеся в примере, неверны; не копируйте его в файлы конфигурации целиком): <machineKey validationKey="53ab8bv3ebc93bb826a7b3v37b903a9d5d4a0" decryptionKey="26165b97a9d5d4a0" validation="SHA1"/>

  4. Повторите эти шаги для каждого сервера отчетов в масштабном развертывании. Убедитесь в том, что все файлы Web.Config в папках \Reporting Services\Report Manager содержат идентичные элементы <machineKey> в разделе <system.web>.

Указание имени виртуального сервера в файлах конфигурации служб Reporting Services

При настройке сервера отчетов с масштабным развертыванием для запуска в кластере NLB необходимо вручную обновить параметры URL-адреса сервера отчетов в файлах конфигурации, указав имя виртуального сервера. Дополнительные сведения о файлах конфигурации служб Reporting Services см. в разделе Файлы конфигурации служб Reporting Services электронной документации по SQL Server.

  1. Откройте файл RSWebApplication.config в текстовом редакторе.

  2. Задайте в качестве значения для <ReportServerUrl> имя виртуального сервера и удалите запись для <ReportServerVirtualDirectory>. После выполнения этого шага для всех запросов, поступающих через диспетчер отчетов, производится выравнивание нагрузки по серверам, которые работают в пределах масштабного развертывания. В следующем примере показан синтаксис, который следует использовать. Он определяет имя сервера и виртуальный каталог сервера отчетов:

    Копировать код
    <ReportServerUrl>https://MyReportPortal/reportserver</ReportServerUrl><ReportServerVirtualDirectory></ReportServerVirtualDirectory>
  3. Откройте файл RSReportServer.config.

  4. Присвойте адрес виртуального сервера в качестве значения параметру <UrlRoot>. После выполнения этого шага все гиперссылки в отчетах будут указывать на масштабное развертывание и распределение нагрузки будет выполняться правильно. Этот параметр также используется для завершения доставки отчета. В следующем примере показан используемый синтаксис:

    Копировать код
    <ReportServerUrl>https://MyReportPortal/reportserver</ReportServerUrl>
  5. Повторите эти шаги для каждого сервера отчетов в развертывании с горизонтальным масштабированием.

Если программа настройки служб Reporting Services запускается после внесения этих изменений, элемент <ReportServerUrl> может быть сброшен ею в значение по умолчанию. Всегда сохраняйте резервную копию файлов конфигурации на тот случай, если понадобится восстановить настроенные параметры.

См. также

Основные понятия

Установка служб SQL Server Reporting Services

Другие ресурсы

Обзор компонентов служб Reporting Services


Режимы развертывания для служб Reporting Services

Режимы развертывания для служб Reporting Services |
 | См. также
Настройка установки SQL Server > Настройка служб Reporting Services >

Новое содержимое: 12 декабря 2006 г.

SQL Server 2005 Службы Reporting Services поддерживают два метода развертывания для экземпляров сервера отчетов:

  • собственный режим, в том числе собственный режим с веб-частями SharePoint;

  • режим интеграции с SharePoint.

Примечание.
В SQL Server 2005 с пакетом обновления 2 (SP2) появился новый режим работы сервера отчетов служб Reporting Services. В предыдущих версиях все серверы отчетов работали в режиме, который теперь называется собственным.

Собственный режим

В собственном режиме сервер отчетов представляет собой изолированный сервер приложений, поддерживающий операции просмотра, управления, обработки и доставки для отчетов и моделей отчетов. Этот режим включен по умолчанию для экземпляров сервера отчетов.

Все экземпляры сервера отчетов устанавливаются в собственном режиме или без указания режима. Сервер отчетов, установленный в конфигурации по умолчанию, полностью готов к работе в собственном режиме. Если для сервера отчетов устанавливаются только файлы (параметр Установить, но не настраивать сервер на странице «Параметры установки сервера отчетов»), то его настройка не выполняется. В этом случае режим работы сервера определяется флагом базы данных, впоследствии устанавливаемым для этого экземпляра.

Собственный режим с веб-частями SharePoint

В службы Reporting Services входят две веб-части, которые можно установить и зарегистрировать в экземпляре служб Windows SharePoint Services 2.0 или 3.0. Эти веб-части можно использовать на веб-узле SharePoint, чтобы выполнять поиск и просмотр отчетов, хранящихся и обрабатывающихся на сервере отчетов, работающем в собственном режиме. Эти веб-части появились в предыдущих версиях служб Reporting Services. Дополнительные сведения о сравнительных характеристиках веб-частей собственного режима и функций режима интеграции с SharePoint см. в разделе Сравнение уровней интеграции между версиями служб Reporting Services и технологиями SharePoint.

Режим интеграции с SharePoint

После установки служб Reporting Services можно настроить сервер отчетов для работы в режиме интеграции с SharePoint. В этом режиме сервер отчетов включается в конфигурацию веб-приложений SharePoint. Пользователи служб Windows SharePoint Services 3.0 и сервера Office SharePoint Server 2007 могут сохранять отчеты в библиотеках SharePoint и получать к ним доступ из веб-узлов SharePoint, которые используются для доступа к другим деловым документам.

Сервер отчетов, настроенный для работы в режиме интеграции с SharePoint, обладает следующими характеристиками.

  • На сервере отчетов запущен SQL Server 2005 с пакетом обновления 2 (SP2), запущенный на сервере экземпляр служб SharePoint имеет версию 3.0, и оба сервера удовлетворяют требованиям к работе в режиме интеграции. Дополнительные сведения см. в разделе Требования для запуска служб Reporting Services в режиме интеграции с SharePoint.

  • База данных сервера отчетов создана с флагом, допускающим работу в режиме интеграции. Во время подключения экземпляра сервера отчетов к базе данных сервера отчетов, которая работает в режиме интеграции с SharePoint, свойство SharePointIntegrated сервера отчетов автоматически устанавливается в значение True. В этом режиме сервер отчетов переключается на пользовательский модуль безопасности и конечную точку SOAP, которые были указаны при настройке сервера отчетов в режиме SharePointIntegrated.

  • После создания базы данных сервера отчетов с установленным параметром SharePointIntegrated иерархия веб-узлов в службах Windows SharePoint Services становится для сервера отчетов иерархией содержимого. Сервер отчетов принимает в качестве путей только полные URL-адреса SharePoint. Относительные пути не допускаются. Для каждого элемента необходимо указывать расширение файла. Дополнительные сведения об иерархии и требованиях к URL-адресам см. в разделе Deploying Reports, Models, and Shared Data Sources to a SharePoint Site.

  • Сервер отчетов и веб-приложение SharePoint настраиваются на поддержку входящих и исходящих соединений друг с другом, а серверу отчетов предоставляются разрешения на базы данных SharePoint.

Переключение режима

Режимы сервера отчетов являются взаимоисключающими. Переключить режим можно путем перепрофилирования существующей конфигурации сервера отчетов, однако миграция содержимого между базами данных различного типа не поддерживается.

Чтобы переключить режим, измените соединение сервера отчетов с базой данных сервера отчетов так, чтобы соединение указывало на базу данных, поддерживающую выбранный режим работы. Дополнительные сведения о настройке существующего экземпляра сервера отчетов для работы в режиме интеграции с SharePoint см. в разделе Настройка служб Reporting Services для интеграции с SharePoint 3.0.

Развертывание сервера отчетов для интеграции SharePoint в многоязыковой среде

Службы Windows SharePoint Services и продукты Office Server доступны на заметно большем числе языков, чем SQL Server 2005. В настоящее время SQL Server 2005 локализован на следующие языки: испанский, итальянский, китайский (упрощенный), китайский (традиционный), корейский, немецкий, русский, французский и японский.

Если настроить сервер отчетов для работы вместе с продуктами SharePoint, в рабочей среде может оказаться несколько языков. Далее описано, какой язык будут иметь пользовательский интерфейс, документация и сообщения.

  • Все страницы приложений, средства, сообщения об ошибках и предупреждения, создаваемые службами Reporting Services, будут выводиться на языке, используемом экземпляром служб Reporting Services (это один из языков SQL Server).

  • Страницы приложений, открываемые на узле SharePoint, веб-часть «Обозреватель отчетов» и построитель отчетов могут иметь один из 22 языков, поддерживаемых для надстройки Reporting Services. Чтобы просмотреть список поддерживаемых языков, посетите веб-узел загрузки SQL Server и перейдите на страницу загрузки надстройки Reporting Services.

  • Веб-узлы SharePoint, центр администрирования SharePoint, встроенная справка и сообщения доступны на 39 языках, поддерживаемых продуктами Office Server.

Если язык, используемый продуктом или технологией SharePoint, отличается от языка сервера отчетов, службы Reporting Services будут использовать язык из той же языковой группы, который ближе всего к языку SharePoint. Если подходящий язык недоступен, сервер отчетов будет использовать английский язык.

Дополнительные сведения о поддержке языков в службах Reporting Services см. в статье Вопросы международного использования служб Reporting Services на веб-узле msdn.microsoft.com или в разделе Вопросы международного использования служб Reporting Services электронной документации по SQL Server.

См. также

Задачи

Как создать базу данных сервера отчетов для режима интеграции с SharePoint (настройка служб Reporting Services)
Как переключать режимы сервера (конфигурация служб Reporting Services)

Основные понятия

Требования для запуска служб Reporting Services в режиме интеграции с SharePoint
Настройка служб Reporting Services для интеграции с SharePoint 3.0
Общие сведения о безопасности для служб Reporting Services в режиме интеграции с SharePoint
Установка служб SQL Server Reporting Services


Настройка служб Reporting Services для интеграции с SharePoint 3.0

Настройка служб Reporting Services для интеграции с SharePoint 3.0 |
 | См. также
Настройка установки SQL Server > Настройка служб Reporting Services >

Новое содержимое: 12 декабря 2006 г.

Развертывание служб SQL Server 2005 Reporting Services с пакетом обновлений 2 (SP2) можно настроить для работы с развертыванием 3.0 или 2007. Необходимо выполнить шаги по настройке как на сервере отчетов, так и в развертывании SharePoint продукта или технологии, прежде чем пользователи смогут публиковать документацию отчетности в библиотеках SharePoint и получить возможность просматривать и управлять отчетами на веб-узлах SharePoint. Процесс настройки определяет установку сведений о соединении сервера, поэтому важно соблюдать последовательность шагов.

В этом разделе представлен обзор шагов по настройке каждого сервера, он завершается задачами, которые нужно выполнить в разделе Как настроить интеграцию сервера. Программа установки SQL Server по умолчанию не устанавливает сервер отчетов в режиме интеграции с SharePoint. После завершения работы программы установки необходимо вручную настроить сервер отчетов для режима интеграции с SharePoint.

Обзор конфигурации сервера отчетов

Чтобы настроить сервер отчетов для режима интеграции, нужно иметь существующий изолированный сервер отчетов или масштабное развертывание. На сервере отчетов необходимо выполнить следующие задачи.

  • Примените пакет обновления 2 (SP2), если этого еще не сделано.

  • Установите веб-интерфейс Windows SharePoint Services на компьютер с сервером отчетов. Этот шаг нужен, если развертывание сервера отчетов и технологии SharePoint производится на отдельные компьютеры. Установка веб-серверов, обслуживающих клиентов, позволяет объединить компьютер сервера отчетов с веб-фермой SharePoint.

  • По необходимости настройте веб-службу сервера отчетов и службу Windows для запуска с учетными записями домена. Этот шаг нужен только для развертывания распределенных серверов, при котором базы данных SharePoint устанавливаются на те же компьютеры, что и сервер отчетов.

  • Создайте базу данных сервера отчетов в режиме интеграции с SharePoint. Тем самым на сервере отчетов устанавливаются свойства сервера и инициируется новая конечная точка управления SOAP сервера отчетов, которая используется для операций интеграции. Используйте средство настройки служб Reporting Services для создания базы данных.

Если интегрируется масштабное развертывание, все экземпляры сервера отчетов, входящие в состав развертывания, должны выполняться в режиме интеграции с SharePoint. В одном масштабном развертывании нельзя сочетать разные режимы работы сервера.

О настройке учетной записи службы

Сервер отчетов реализуется как веб-служба и служба Windows, которые выполняются со встроенными учетными записями или пользовательскими учетными записями Windows. В режиме интеграции с SharePoint обе службы соединяются с базами данных конфигурации и содержимого SharePoint с разрешениями на запись и выполнение.

В большинстве случаев настройки учетной записи службы по умолчанию подходят для соединения с базой данных SharePoint. Тем не менее, если экземпляр веб-приложения SharePoint расположен на одном компьютере, а экземпляр сервера отчетов и базы данных SharePoint databases — на другом, нельзя использовать встроенные учетные записи компьютера, такие как службы Network Services или «Локальная система» для учетных записей службы сервера отчетов.

Если базы данных SharePoint выполняются на удаленном компьютере, веб-приложение SharePoint явно отказывает в доступе к базе данных учетным записям удаленного компьютера. Если сервер отчетов расположен на том же компьютере, что и базы данных SharePoint, и если любая учетная запись служб Reporting Services выполняется со встроенной учетной записью, ей также будет отказано в доступе. Настройка служб для выполнения с пользовательской учетной записью Windows обеспечит доступ сервера отчетов к базе данных, поскольку эта учетная запись не запрещена. Дополнительные сведения о соединении учетных записей с элементом технологии SharePoint см. в разделе Общие сведения о безопасности для служб Reporting Services в режиме интеграции с SharePoint. Дополнительные сведения о настройке учетных записей служб см. в разделе Как Настройка учетных записей служб (конфигурация служб Reporting Services).

О базе данных сервера отчетов

База данных сервера отчетов представляет собой внутреннее хранилище данных для одного или нескольких экземпляров серверов отчетов. База данных сервера отчетов поддерживает собственный режим или режим интеграции с SharePoint, но не оба. Содержимое базы данных зависит от режима сервера и не является взаимозаменяемым. Если создать базу данных сервера отчетов, поддерживающую режим интеграции с SharePoint, в будущем нельзя автоматически конвертировать базу данных или мигрировать в собственный режим экземпляра сервера отчетов. База данных сервера отчетов используется в следующих целях, в зависимости от режима сервера.

  • При создании для операций в собственном режиме сервера база данных сервера отчетов является единственным репозиторием для постоянных данных, которые использует сервер отчетов.

  • При создании для режима интеграции с SharePoint база данных сервера отчетов хранит свойства сервера, мгновенные снимки выполнения отчета, журнал отчета, определения подписок и расписания. В ней также хранятся вторичные копии отчетов, модели отчетов, общие источники данных и ресурсы для повышения производительности сервера. Первичным хранилищем для документов отчета служат базы данных содержимого SharePoint. Дополнительные сведения см. в разделе Хранение и синхронизация содержимого сервера отчетов с помощью баз данных SharePoint.

Создание базы данных сервера отчетов для режима интеграции с SharePoint является первым важным шагом в настройке сервера отчета для интеграции с SharePoint. Для создания базы данных сервера отчетов и настройки соединения с сервером отчетов можно использовать средство настройки служб Reporting Services. С базой данных сервера отчетов соединяется только сам сервер отчетов. Экземпляры Windows SharePoint Services или Office SharePoint Server никогда не соединяются с базой данных сервера отчетов и не получает из нее данные.

Настройка развертываний SharePoint для интеграции с сервером отчетов

Для настройки интеграции сервера с выполняющимся продуктом или технологией SharePoint необходимо загрузить надстройку служб Reporting Services для технологий SharePoint. Эта надстройка устанавливает программные файлы и страницы приложений, включая страницы, которые открываются на центральном веб-узле для установки URL-адреса сервера отчетов и других параметров интеграции. Можно задать параметры интеграции сервера отчетов для веб-фермы SharePoint или изолированного веб-приложения SharePoint.

Примечание.
К веб-ферме SharePoint можно добавить только один сервер отчетов. Может выполняться установка изолированного сервера отчетов или масштабное развертывание, доступ к которому осуществляется через один URL-адрес.

Продукты и технологии SharePoint могут развертываться как веб-ферма или изолированный сервер. Веб-ферма содержит один или несколько виртуальных северов, каждый из которых является веб-приложением SharePoint. Сервер отчетов интегрируется на уровне веб-фермы. С точки зрения интеграции хранилища данных, для одной фермы может существовать только одна база данных сервера отчетов. Для управления параметрами интеграции всех серверов в веб-ферме используется центральный веб-узел администрирования SharePoint.

Каждое веб-приложение SharePoint в веб-ферму можно настроить для использования разных поставщиков проверки подлинности. Это ни в коей мере не затрагивает интеграцию сервера отчетов. Развертывание сервера отчетов будет обрабатывать запросы каждого сервера в ферме независимо от поставщика проверки подлинности.

Каждое веб-приложение имеет веб-узел верхнего уровня по умолчанию. Для каждого веб-узла верхнего уровня можно установить разные разрешения, чтобы все серверы в ферме имели свой доступ к различным элементам сервера отчетов.

Как настроить интеграцию сервера

Настройка сервера для интеграции требует нескольких инструментальных средств и нескольких шагов. В следующем списке приводятся все необходимые задачи. В них включены ссылки на подробные инструкции, которыми можно пользоваться для завершения каждого шага. Обзор механизма интеграции см. в разделе Интеграция служб Reporting Services и технологии SharePoint.

Порядок установки

До начала настройки интеграции необходимо установить службы Reporting Services и нужный продукт или технологию SharePoint. Службы Reporting Services и продукт или технологию SharePoint можно устанавливать в любом порядке. Однако порядок установки и топология развертывания определяют, нужно ли будет выполнять дополнительные шаги по настройке в службах IIS, а также момент проверки результатов установки.

Параллельное развертывание.

  • Если службы Reporting Services устанавливаются на компьютер с уже установленным экземпляром технологии SharePoint, проверить результаты установки служб Reporting Services можно будет только после настройки параметров интеграции.

  • Если экземпляр технологии SharePoint устанавливается на компьютер с уже установленными службами Reporting Services, веб-служба сервера отчетов остановится, пока не будет изменено назначение порта для веб-узла по умолчанию, как описано в следующем разделе.

Для распределенного развертывания серверов, когда сервер отчетов, веб-приложение SharePoint и базы данных сервера устанавливаются на разные компьютеры, можно использовать параметры по умолчанию, указывающие веб-узел и назначение порта по умолчанию. Если веб-приложение SharePoint и сервер отчетов устанавливаются на разные компьютеры, а базы данных SharePoint размещаются на компьютере сервера отчетов, возникнет ошибка соединения, если не следовать рекомендациям по настройке учетных записей, которые приводятся в предыдущем разделе. Инструкции см. в разделе Как Настройка учетных записей служб (конфигурация служб Reporting Services).

Изменение назначения порта для веб-узла по умолчанию

Параллельная установка сервера отчетов и экземпляра продукта или технологии SharePoint на один компьютер требует, чтобы каждому веб-приложению был назначен свой порт. Если при установке продукта или технологии SharePoint выбрать параметр «Обычная установка» или использовать параметры по умолчанию, Мастер настройки продуктов и технологии SharePoint при настройке веб-приложения SharePoint останавливает веб-узел по умолчанию и назначает порт 80 веб-узлу верхнего уровня. Если для сервера отчетов нужно использовать веб-узел по умолчанию, для него необходимо выбрать другой порт, а затем запустить веб-узел по умолчанию.

  1. Запустите IIS Manager.

  2. Щелкните правой кнопкой пункт Свойства веб-узла по умолчанию.

  3. Задайте другой порт. По умолчанию веб-приложение SharePoint использует порт 80. Чтобы запустить сервер отчетов на том же компьютере на другом веб-узле, выберите неиспользуемый порт (например 8080).

  4. Запустите веб-узел по умолчанию. Этот веб-узел останавливается при создании и настройке коллекции веб-узлов для веб-приложения SharePoint. Для доступа к серверу отчетов необходимо перезапустить этот веб-узел.

  5. Если перед установкой Windows SharePoint Services на компьютере уже имеется рабочая версия служб Reporting Services, все же убедитесь в наличии доступа к серверу отчетов, введя URL-адрес, включая порт (например http://имя_сервера:8080/сервер_отчетов). Хотя интеграция еще не настроена, сервер отчетов должен работать как изолированный сервер.

Установка предварительных условий на сервер отчетов

  1. Примените пакет обновлений SP2 к серверу отчетов.

  2. Если сервер отчетов и веб-приложение SharePoint установлены на разных компьютерах, установите и настройте объектную модель Windows SharePoint Services на компьютере сервера отчетов. Инструкции см. в разделе Как установить объектную модель службы Windows SharePoint Services на компьютер сервера отчетов.

Настройка сервера отчетов для интеграции с SharePoint

  1. Запустите средство настройки служб Reporting Services и подключитесь к экземпляру сервера отчетов, который необходимо настроить для интеграции с SharePoint.

  2. Если выполняется только новая установка, на странице «Виртуальный каталог сервера отчетов» выберите веб-узел по умолчанию и введите имя виртуального каталога.

    Пропустите страницу настройки виртуального каталога диспетчера отчетов. Диспетчер отчетов нельзя использовать с сервером отчетов, настроенным для режима интеграции с SharePoint. После настройки сервера отчетов страница «Настройка виртуального каталога диспетчера отчетов» будет отключена.

  3. На странице «Настройка базы данных» создайте новую базу данных сервера отчетов в режиме интеграции с SharePoint, установив флажок Интегрировать с продуктами и технологиями SharePoint. Инструкции см. в разделе Как создать базу данных сервера отчетов для режима интеграции с SharePoint (настройка служб Reporting Services).

  4. Выполните резервное копирование ключа шифрования.

  5. При новой установке служб Reporting Services нужно также настроить учетную запись автоматической обработки отчетов, если требуется поддержка автоматического выполнения отчетов. При необходимости настройте сервер отчетов для доставки электронной почты. Дополнительные сведения см. в разделах Настройка учетной записи для автоматической обработки отчетов и Настройка сервера отчетов для работы с электронной почтой.

  6. Закройте средство настройки служб Reporting Services.

  7. Если веб-узел по умолчанию настроен на определенный порт, отредактируйте файл RSReportServer.config, чтобы добавить этот порт к параметру конфигурации UrlRoot (например, http://имя_сервера:8080/сервер_отчетов). Службы Reporting Services используют параметр конфигурации UrlRoot для создания в электронных сообщениях ссылок, которые разрешаются к отчетам, обрабатывающимся на сервере отчетов.

После настройки сервера отчетов следующим шагом будет установка надстройки служб Reporting Services и настройка параметров интеграции для веб-приложения SharePoint.

Установка надстройки служб Reporting Services и настройка интеграции для веб-приложения SharePoint

Для установки надстройки служб Reporting Services необходимо быть администратором веб-фермы SharePoint.

  1. Загрузите и запустите программу установки для надстройки служб Reporting Services. Дополнительные сведения см. в разделе Установка надстройки службы Reporting Services.

  2. В разделе «Администрирование» щелкните Центральный веб-узел администрирования SharePoint 3.0.

    Важно!
    Чтобы завершить приведенные ниже шаги, необходимо быть членом группы администраторов веб-фермы SharePoint и администратором коллекции веб-узлов.

  3. Щелкните Управление приложениями. Появится новый раздел с именем Reporting Services. В этм разделе имеются ссылки на страницы, которые используются для указания параметров интеграции. Как минимум нужно установить URL-адрес сервера отчетов, выбрать метод проверки подлинности и предоставить серверу отчетов доступ к базам данных SharePoint. Инструкции см. в разделе Как выполнить интеграцию сервера отчетов в центре администрирования SharePoint.

  4. Закройте центральный веб-узел администрирования.

Проверка установки

Проверьте результаты интеграции, запустив средство настройки служб Reporting Services и открыв страницу «Интеграция SharePoint», чтобы увидеть состояние сервера. Необходимо увидеть ссылку, которая открывает центральный веб-узел администрирования SharePoint.

Проверить установку можно также открыв окно веб-обозревателя на сервере отчетов. URL-адрес должен быть примерно таким: http://имя_сервера:8081/сервер_отчетов. Этот URL-адрес конечной точки прокси-сервера. После добавления элементов сервера отчетов в библиотеку SharePoint можно открыть окно веб-обозревателя на этом URL-адресе, чтобы просмотреть элементы веб-узла.

Наконец, можно открыть веб-приложение SharePoint и загрузить отчеты и другие документы в библиотеку SharePoint.

Добавление элементов сервера отчетов

  1. Откройте веб-приложение SharePoint. URL-адрес по умолчанию — http://<имя_сервера>.

  2. Установите разрешения, чтобы предоставить пользовательский доступ к веб-узлу SharePoint. Необходима защита, но если требуется наследовать существующие разрешения, устанавливать разрешения для отдельных элементов не нужно. Инструкции см. в разделе Managing Permissions and Security for Report Server Items on a SharePoint Site.

  3. Добавьте типы содержимого служб Reporting Services, если нужно создать новые общие источники данных, модели отчетов и отчеты построителя отчетов. Инструкции см. в разделе How to: Add Report Server Content Types to a Library (Reporting Services in SharePoint Integrated Mode).

  4. Создайте общие источники данных, которые будут использоваться с отчетами и моделями. Инструкции см. в разделе How to: Create and Manage Shared Data Sources (Reporting Services in SharePoint Integrated Mode).

  5. Создайте общие расписания, которые будут использоваться с подписками и автоматической обработкой отчетов. Инструкции см. в разделе How to: Create and Manage Shared Schedules (Reporting Services in SharePoint Integrated Mode).

  6. Опубликуйте файлы определения отчетов (RDL), файлы источников данных (RDS) файлы моделей отчетов (SMDL) в библиотеке SharePoint. Можно также использовать команду Upload в библиотеке SharePoint для загрузки файлов RDL-файлов и .SMDL-файлов, но не RDS-файлов. В зависимости от разрешений можно также создавать отчеты в построителе отчетов и сохранять их в библиотеке. Если отчет включает ссылки на общие источники данных или внешние файлы, необходимо обновить эти ссылки. Дополнительные сведения см. в разделах Deploying Reports, Models, and Shared Data Sources to a SharePoint Site и How to: Upload Documents to a SharePoint Library (Reporting Services in SharePoint Integrated Mode).

При загрузке отчетов убедитесь в правильности свойств источников данных для этих отчетов. Источник данных должен иметь допустимую строку соединения, если это внешний источник данных. Тип учетных данных должен быть допустимым для топологии сети. А именно, если в домене не включена проверка подлинности Kerberos, нельзя использовать тип учетных данных для встроенной безопасности Windows. Вместо них следует задать хранимые учетные данные. Убедившись, что свойства источников данных правильные, можно щелкнуть имя отчета, чтобы открыть его. Отчет автоматически откроется в веб-компоненте средства просмотра отчетов.

Если отчет не открывается, проверьте разрешения на отчет и свойства источников данных, определяющих подключение к внешнему источнику данных, который поставляет данные для отчета. На веб-узле или веб-ферме разрешения SharePoint используются для управления доступом к отчетам, моделям отчетов, общим источникам данных и средству «Построитель отчетов», предназначенному для создания нерегламентированных отчетов. Если эти элементы невидимы пользователям, следует проверить разрешения.

Сервером отчетов, выполняющимся в режиме интеграции с SharePoint, нельзя управлять с помощью диспетчера отчетов или среды SQL Server Management Studio. Полный список и описание поддерживаемых и неподдерживаемых функций см. в разделе Функции, поддерживаемые службами Reporting Services в режиме интеграции с SharePoint.

См. также

Задачи

Как выполнить интеграцию сервера отчетов в центре администрирования SharePoint
Как создать базу данных сервера отчетов для режима интеграции с SharePoint (настройка служб Reporting Services)
Как переключать режимы сервера (конфигурация служб Reporting Services)

Основные понятия

Создание резервных копий и восстановление ключей шифрования
Режимы развертывания для служб Reporting Services
Общие сведения о безопасности для служб Reporting Services в режиме интеграции с SharePoint

Другие ресурсы

Файл конфигурации RSReportDesigner
Managing Permissions and Security for Report Server Items on a SharePoint Site
Deploying Reports, Models, and Shared Data Sources to a SharePoint Site


Интеграция служб Reporting Services и технологии SharePoint

Интеграция служб Reporting Services и технологии SharePoint |
 | См. также
Настройка установки SQL Server > Настройка служб Reporting Services > Настройка служб Reporting Services для интеграции с SharePoint 3.0 >

Новое содержимое: 12 декабря 2006 г.

Сервер отчетов можно настроить для запуска в составе развертывания продукта или технологии SharePoint и использовать функции совместной работы и централизованного управления документами Windows SharePoint Services 3.0 или Office SharePoint Server 2007 со службами Reporting Services. Запуск сервера отчетов как части большего развертывания SharePoint предоставляет три уровня интеграции:

  • Общее хранение.

  • Общая безопасность.

  • Одинаковый доступ к веб-узлам для всех бизнес-документов, включая отчеты, модели отчетов и общие источники данных.

Архитектура интеграции сервера

При интеграции сервера отчетов с экземпляром продукта или технологии SharePoint элементы и свойства хранятся в базе данных содержимого SharePoint. Это обеспечивает более глубокий уровень интеграции между технологиями сервера, которые влияют на то, как хранится, защищается и обеспечивается доступ к его содержимому.

Хранение элементов и свойств отчетов в базе данных содержимого SharePoint позволяет просматривать библиотеки SharePoint на предмет типов содержимого серверов отчетов, обеспечивать безопасность элементов посредством одного уровня доступа и поставщика проверки подлинности, который управляет доступом к другим бизнес-документам, находящимся на веб-узле SharePoint, совместно использовать функции управления документами для проверки изменения отчетов, использовать оповещения для информирования об изменении элемента и внедрять веб-компонент «Обозреватель отчетов» на страницы и узлы внутри приложения или настраивать его. В зависимости от разрешений, пользователь может просматривать, а иногда и создавать отчеты и модели отчетов на веб-узле SharePoint.

Сервер отчетов продолжает осуществлять всю обработку, подготовку и доставку данных. Он также поддерживает все запланированные операции по обработке отчетов для моментальных снимков и журналов отчетов. В следующей диаграмме показано взаимодействие компонентов сервера.

Архитектура компонентов для интеграции с SharePoint

При открытии отчета из веб-узла SharePoint конечная точка прокси-сервера на сервере отчетов подключается к серверу отчетов, создает сеанс, подготавливает отчет по обработке данных, получает данные, вставляет отчет в макет отчетов и отображает его в веб-компоненте «Обозреватель отчетов». Когда отчет открыт, можно экспортировать его в различные форматы приложений либо взаимодействовать с данными, детализируя основные числа или выбрав связанный отчет. Операции экспорта или взаимодействия отчетов выполняются на сервере отчетов.

Сервер отчетов синхронизирует операции и данные с Windows SharePoint Services и отслеживает сведения об обрабатываемых им файлах. При изменении свойств или установок для любого элемента сервера отчетов изменения сохраняются в базе данных SharePoint, а затем копируются в базу данных сервера отчетов, которая предоставляет внутреннее хранилище для сервера отчетов.

Обеспечивающие интеграцию компоненты

Для объединения серверов в одно развертывание следует интегрировать установку служб 2005 Reporting Services с экземпляром Windows SharePoint Services or Office SharePoint Server 2007.

Интеграция обеспечивается SQL Server 2005 с пакетом обновлений Service Pack 2 и SQL Server 2005, регистрирующим надстройку служб для технологий SharePoint. Надстройка служб Reporting Services является свободно распространяемым компонентом, который можно загрузить на веб-узле Microsoft и установить на сервер с Windows SharePoint Services 3.0 или Office SharePoint Server 2007.

  • В Windows SharePoint Services надстройка служб Reporting Services предоставляет конечную точку прокси-сервера, веб-компонент средства просмотра отчетов и страницы приложений для просмотра, хранения и управления содержимым сервера отчетов на веб-узле или веб-ферме SharePoint.

  • Для сервера отчетов пакет обновлений Service Pack 2 предоставляет обновленные программные файлы, новую конечную точку SOAP, пользовательские расширения безопасности и доставки, измененное средство настройки служб Reporting Services, сценарии для доступа к базам данных настройки и содержимого SharePoint и сценарий для создания базы данных сервера отчетов, поддерживающую режим интеграции с SharePoint. Сервер отчетов должен быть настроен на работу в режиме интеграции с SharePoint, специально выделенном для поддержки доступа к отчетам и их доставки через веб-узел SharePoint.

После установки надстройки служб Reporting Services на Windows SharePoint Services настройки обоих серверов для интеграции можно загрузить или опубликовать типы содержимого сервера отчетов в библиотеке SharePoint, а затем просматривать и управлять этими документами с веб-узла SharePoint. Передача или публикация содержимого сервера отчетов является важным первым шагом. Веб-компоненты и страницы становятся доступны при выборе определений отчетов RDL, моделей отчетов SMDL и источников общих данных RSDS на веб-узле SharePoint.

В этом разделе

Следующие темы в этом разделе содержат дополнительные сведения о совместной работе серверов. Рекомендации по настройки и установке см. в подразделе Настройка служб Reporting Services для интеграции с SharePoint 3.0.

Функции, поддерживаемые службами Reporting Services в режиме интеграции с SharePoint

Обобщает доступные функциональные возможности сервера отчетов, интегрированного с технологиями SharePoint.

Хранение и синхронизация содержимого сервера отчетов с помощью баз данных SharePoint

Описывает поддержку интеграции сервера отчетов на уровне данных. Этот обзор предоставляет общие сведения о хранении данных, свойств и содержимого.

Общие сведения о безопасности для служб Reporting Services в режиме интеграции с SharePoint

Описывает интеграцию сервера отчетов на уровне безопасности. Доступ к содержимому сервера отчетов и операциям обеспечивается функциями проверки подлинности и авторизации в технологиях SharePoint.

Просмотр и управление элементами сервера отчетов с узла SharePoint

Описывает, как интеграция сервера отчетов распространяется на веб-страницы приложений на веб-узлах SharePoint и на центральном веб-узле администрирования SharePoint. Текущие пользователи служб Reporting Services обнаружат, что функциональные возможности, доступные на веб-узлах SharePoint, за несколькими исключениями эквивалентны страницам приложений диспетчера отчетов.

См. также

Основные понятия

Режимы развертывания для служб Reporting Services
Установка надстройки службы Reporting Services
Требования для запуска служб Reporting Services в режиме интеграции с SharePoint
Сравнение уровней интеграции между версиями служб Reporting Services и технологиями SharePoint

Другие ресурсы

Using the Report Viewer Web Part on a SharePoint Site
Deploying Reports, Models, and Shared Data Sources to a SharePoint Site


Функции, поддерживаемые службами Reporting Services в режиме интеграции с SharePoint

Функции, поддерживаемые службами Reporting Services в режиме интеграции с SharePoint |
 | См. также
Настройка служб Reporting Services > Настройка служб Reporting Services для интеграции с SharePoint 3.0 > Интеграция служб Reporting Services и технологии SharePoint >

Новое содержимое: 12 декабря 2006 г.

В этом разделе приводятся сводные данные о функциях, которые доступны на сервере отчетов, настроенном для интеграции с Windows SharePoint Services 3.0 или Office SharePoint Server 2007. Дополнительные сведения о требованиях к интеграции и о совместной работе серверных технологий см. в разделах Интеграция служб Reporting Services и технологии SharePoint и Требования для запуска служб Reporting Services в режиме интеграции с SharePoint.

Обзор возможностей

Настройка сервера отчетов для работы в режиме интеграции с SharePoint предоставляет следующие дополнительные возможности (доступные только при развертывании в этом режиме).

  • Функции управления документами и совместной работы, в том числе обработка предупреждений и контроль версий. Веб-узел SharePoint предоставляет единый портал для доступа ко всем документам и единую точку управления документами.

  • Использование разрешений SharePoint и поставщиков служб проверки подлинности для управления доступом к отчетам, моделям и другим элементам.

  • Топология развертывания SharePoint используется для распределения отчетов по Интернет-соединению за пределами брандмауэра. Сервер отчетов поддерживает службы обработки отчетов и данных в контексте более крупной конфигурации SharePoint, настроенной для доступа в Интернет.

  • Управление отчетами, моделями, источниками данных, расписаниями и журналом отчетов с помощью пользовательских страниц приложений на веб-узле SharePoint. Можно задавать свойства, создавать расписания, оформлять подписки, а также создавать и вести журнал отчетов на веб-узле SharePoint, используя те же методы, что и при работе с другими средствами SQL Server.

  • Просмотр отчетов в новой настраиваемой веб-части «Средство просмотра отчетов». В эту веб-часть входят средства перемещения по страницам, а также функции поиска, печати и экспорта.

  • Публикация и передача отчетов, моделей отчетов, ресурсов и общих источников данных в библиотеку SharePoint, в том числе центр отчетов на сервере Office SharePoint.

    Использование конструктора отчетов, конструктора моделей и построителя отчетов для создания элементов сервера отчетов. Если используется версия этих средств с пакетом обновления 2 (SP2) и сервер отчетов настроен для работы в режиме интеграции с SharePoint, только что созданные элементы можно сразу публиковать в библиотеке SharePoint. Также можно использовать действие «Передача» на веб-узле SharePoint, чтобы добавить в библиотеку SharePoint любые определения отчетов и модели отчетов.

    Сервер отчетов всегда обрабатывает определения отчетов одинаковым образом, независимо от используемого режима сервера, и режим сервера не влияет на данные отчета и его макет. Любой отчет, который может запускаться на сервере отчетов в собственном режиме, может запускаться и на сервере отчетов, настроенном для работы в режиме интеграции с SharePoint.

  • Создание нерегламентированных отчетов с помощью моделей отчетов и построителя отчетов. С веб-узла SharePoint можно формировать модели и запускать построитель отчетов. Можно добавлять, открывать и сохранять нерегламентированные отчеты на веб-узле SharePoint. Если используется выпуск Enterprise Edition, можно разворачивать нерегламентированные отчеты, поддерживающие неограниченное число переходов.

  • Оформление подписки и доставка отчетов в библиотеку SharePoint с помощью нового модуля доставки SharePoint. Также можно доставлять отчеты по электронной почте или в общую папку. Для доставки отчетов применяются модули доставки сервера отчетов.

  • На сервере Office SharePoint Server подключите веб-часть «Средство просмотра отчетов» к веб-части «Фильтр» или веб-части «Библиотека», расположенным на панелях или страницах для веб-частей.

  • Программирование в контексте новой конечной точки SOAP для создания пользовательских приложений, интегрируемых с веб-узлом SharePoint. Также можно использовать обновленный поставщик инструментария управления Windows (WMI) для программной настройки экземпляра сервера отчетов, работающего в режиме интеграции с SharePoint.

Неподдерживаемые функции SharePoint

При работе в режиме интеграции доступны не все функции. На веб-узле SharePoint нельзя использовать интеграцию с календарем SharePoint Outlook и создавать расписания SharePoint для файлов документов на сервере отчетов. Функции индивидуальной настройки также не поддерживаются.

Неподдерживаемые функции служб Reporting Services

На сервере отчетов, работающем в режиме интеграции с SharePoint, недоступны следующие функции.

  • В режиме интеграции с SharePoint по-другому осуществляется работа с URL-адресами. URL-адреса SharePoint используются в качестве ссылок на отчеты, модели отчетов, общие источники данных и ресурсы. Иерархия папок сервера отчетов не используется.

  • На сервере отчетов нельзя разворачивать или использовать пользовательские модули безопасности служб Reporting Services. Сервер отчетов содержит специализированный модуль безопасности, который используется при настройке сервера отчетов для работы в режиме интеграции с SharePoint. Этот модуль безопасности является внутренним компонентом, который необходим для работы в интегрированном режиме.

  • Для управления экземпляром сервера отчетов, который настроен для интеграции с SharePoint, нельзя использовать диспетчер отчетов или среду Management Studio.

  • Управляемые данными подписки недоступны. (Это относится ко всем выпускам продукта.)

  • Не поддерживается программа командной строки rs.exe. Эта программа не поддерживает конечную точку SOAP, которая используется для программного доступа к серверу отчетов, работающему в режиме интеграции с SharePoint.

  • Связанные отчеты не поддерживаются.

  • Папка «Мои отчеты» не поддерживается.

  • Не поддерживаются функции управления заданиями, которые позволяют остановить длительную обработку отчета.

  • Пакетные методы не поддерживаются.

См. также

Справочник

Выпуски и компоненты SQL Server 2005
Возможности, поддерживаемые различными выпусками SQL Server 2005

Основные понятия

Интеграция служб Reporting Services и технологии SharePoint

Другие ресурсы

Введение в службы Reporting Services


Просмотр и управление элементами сервера отчетов с узла SharePoint

Просмотр и управление элементами сервера отчетов с узла SharePoint |
 | См. также
Настройка служб Reporting Services > Настройка служб Reporting Services для интеграции с SharePoint 3.0 > Интеграция служб Reporting Services и технологии SharePoint >

Новое содержимое: 12 декабря 2006 г.

Если сервер отчетов настроен для работы в режиме интеграции с SharePoint, на узле SharePoint можно просматривать отчеты и другие элементы сервера отчетов, а также управлять этими элементами.

Пользовательские страницы приложений добавляются в веб-приложение SharePoint после установки надстройки Reporting Services в экземпляре Windows SharePoint Services 3.0 или Office SharePoint Server . Существуют страницы для задания свойств источников данных, работы с журналом отчетов, задания параметров обработки отчетов, назначения расписаний, оформления подписок, задания параметров отчетов и создания общих расписаний. Элементами сервера отчетов можно управлять на узле SharePoint, используя те же методы, что и при работе с другими средствами SQL Server.

Чтобы получить доступ к страницам приложений, выберите из раскрывающегося меню действия, относящиеся к определенному элементу. В зависимости от типа элемента и наличия необходимых разрешений может быть доступно создание отчетов в построителе отчетов, формирование моделей и задание параметров безопасности для элементов моделей.

Примечание.
Надстройка Reporting Services добавляет в центр администрирования SharePoint страницы интеграции с сервером отчетов, чтоб дать администраторам сервера возможность настроить соединение с экземпляром сервера отчетов и обновить данные учетных записей служб для веб-приложения SharePoint. Дополнительные сведения см. в разделе Настройка служб Reporting Services для интеграции с SharePoint 3.0.

Поиск элементов сервера отчетов на узле SharePoint

Перед заданием свойств элемента необходимо определить его расположение. Элементы сервера отчетов всегда хранятся в библиотеках или в папке в пределах библиотеки. По умолчанию доступ к библиотекам документов осуществляется с помощью области быстрого запуска, расположенной рядом с главной областью просмотра. Значок библиотеки, расположенный на странице быстрого запуска, позволяет быстро определить библиотеку документов. Кроме того, библиотеку можно определить по наличию в строке меню элементов Создать, Передача и Действия, которые используются для создания элементов библиотеки и управления ими.

Чтобы отличить элементы сервера отчетов от других элементов на узле SharePoint, можно использовать значки для визуального определения элементов или навести указатель мыши на тип элемента и прочитать расширение файла. На рисунке показана модель отчетов, общий источник данных и определение отчета в библиотеке Документы.

Библиотека SharePoint с общими источниками данных

Просмотр отчетов

Определения отчетов (RDL-файлы), которые передаются в библиотеку SharePoint, просматриваются с помощью веб-части «Обозреватель отчетов», которая устанавливается вместе с надстройкой Reporting Services. Во время установки надстройки автоматически определяется связь с расширением RDL, и выбранный отчет будет автоматически открываться для просмотра в веб-части. После открытия отчета можно использовать входящую в состав веб-части панель инструментов для перемещения по страницам отчета, поиска данных в отчете, изменения масштаба, экспорта и печати отчета.

Управление элементами с помощью действий

Задачи управления для каждого элемента поддерживаются с помощью действий, выбираемых из раскрывающегося меню.

  1. Откройте веб-приложение или узел SharePoint, где находится нужное содержимое.

  2. Найдите элемент в библиотеке.

  3. Выделите элемент, щелкнув его.

  4. Щелкните стрелку вниз, которая появляется после выбора элемента.

  5. Выберите действие из раскрывающегося меню. Некоторые действия, такие как Просмотреть свойства и Изменить свойства, являются общими для всех элементов, хранящихся в библиотеке.

Для всех элементов, хранящихся в библиотеке SharePoint, существует общий набор стандартных действий, определяемый разрешениями пользователя. Примерами общих действий являются Просмотреть свойства и Изменить свойства. Нестандартные действия реализуют функции управления, индивидуальные для каждого типа элементов. На рисунке показаны действия для определения отчета. Примерами нестандартных действий для определения отчета служат Управление подписками и Управление параметрами обработки.

Пункты меню для определения отчета

Дополнительные сведения об использовании этих действий для каждого элемента сервера отчетов см. в разделе Report Server How-to Topics (SharePoint Integrated Mode) электронной документации по SQL Server.

См. также

Основные понятия

Функции, поддерживаемые службами Reporting Services в режиме интеграции с SharePoint
Интеграция служб Reporting Services и технологии SharePoint
Настройка служб Reporting Services для интеграции с SharePoint 3.0

Другие ресурсы

Managing Permissions and Security for Report Server Items on a SharePoint Site
How to: Add the Report Viewer Web Part to a Web Page (Reporting Services in SharePoint Integrated Mode)
Using the Report Viewer Web Part on a SharePoint Site
How to: Upload Documents to a SharePoint Library (Reporting Services in SharePoint Integrated Mode)


Общие сведения о безопасности для служб Reporting Services в режиме интеграции с SharePoint

Общие сведения о безопасности для служб Reporting Services в режиме интеграции с SharePoint |
 | См. также
Настройка служб Reporting Services > Настройка служб Reporting Services для интеграции с SharePoint 3.0 > Интеграция служб Reporting Services и технологии SharePoint >

Новое содержимое: 12 декабря 2006 г.

Сервер отчетов, настроенный на работу в режиме интеграции с SharePoint, использует поставщика проверки подлинности и разрешения, определенные в веб-приложении SharePoint, для управления доступом к элементам и операциям сервера отчетов.

Разрешение на доступ к элементам и операциям предоставляется в соответствии с политиками безопасности SharePoint, сопоставляющими учетную запись пользователя или группы с уровнем разрешения, соответствующим элементу. По сути, этот процесс полностью аналогичен использованию назначений ролей для работы сервера отчетов в собственном режиме, когда назначение роли сопоставляет учетную запись пользователя или группы с набором допустимых задач, соответствующим элементу. Как и с большинством других моделей проверки подлинности на основе ролей, система безопасности SharePoint обеспечивает наследование разрешений, что позволяет упростить использование и сократить затраты на обслуживание большого количества политик.

При развертывании типов содержимого сервера отчетов на веб-узле SharePoint необходимо учитывать следующее:

  • Каким образом создаются соединения и передаются запросы между двумя серверами. Поставщик проверки подлинности, используемый в веб-приложении SharePoint, определяет, можно ли в дальнейшем применять встроенную безопасность Windows для доступа к внешним источникам данных, используемых отчетом.

  • Каким образом используется система безопасности по умолчанию для добавления, управления и доступа к элементам и операциям сервера отчетов. Дополнительные сведения см. в разделах Managing Permissions and Security for Report Server Items on a SharePoint Site и Using Built-in Security in Windows SharePoint Services for Report Server Items электронной документации по SQL Server.

  • Каким образом переопределяется система безопасности по умолчанию с помощью настройки разрешений для конкретных отчетов или операций. Дополнительные сведения см. в разделе How to: Set Permissions for Report Server Items on a SharePoint Site (Reporting Services in SharePoint Integrated Mode) электронной документации по SQL Server.

Перед назначением разрешений необходимо настроить каждый сервер для работы в режиме интеграции. Дополнительные сведения см. в разделе Настройка служб Reporting Services для интеграции с SharePoint 3.0.

Поставщики проверки подлинности в технологиях SharePoint

Для веб-приложения SharePoint может использоваться проверка подлинности Windows или проверка подлинности с помощью форм. Сервером отчетов могут обрабатываться запросы по любой из схем. Можно настроить проверку подлинности в таких сочетаниях:

  • проверка подлинности Windows со встроенной безопасностью (протокол Kerberos включен);

  • проверка подлинности Windows, без олицетворения или делегирования;

  • проверка подлинности с помощью форм.

Примечание.
Продуктами и технологиями служб Reporting Services и SharePoint поддерживается проверка подлинности с помощью форм. Реализации, применяемые для каждой группы продуктов, различны и несовместимы между собой. Нестандартные модули проверки подлинности служб Reporting Services не поддерживаются для серверов отчетов, работающих в режиме интеграции с SharePoint.

Отправка запросов на сервер отчетов

Все запросы на элемент или операцию сервера отчетов должны быть действительными проверенными запросами. Используемым поставщиком проверки подлинности определяется способ обработки запроса.

Встроенная безопасность Windows

Если веб-приложение SharePoint настроено на использование проверки подлинности Windows, и протокол Kerberos включен, соединение между веб-приложением SharePoint и сервером отчетов осуществляется с помощью олицетворяемых или делегированных учетных данных текущего пользователя Windows. На приведенной ниже схеме показаны соединения при настройке сервера отчетов для работы в режиме интеграции SharePoint и при использовании веб-приложением SharePoint проверки подлинности Windows (протокол Kerberos включен).

Соединения во встроенном режиме SharePoint
Соединение 1

Пользователь осуществляет доступ к веб-узлу SharePoint с помощью маркера пользователя, созданного при входе пользователя в сеть. Маркер содержит идентификатор пользователя и сведения о принадлежности к группе. Веб-приложение SharePoint выполняет проверку подлинности пользователя. Пользователь запрашивает элемент или операцию сервера отчетов.

Соединение 2

Веб-приложение SharePoint направляет маркер и запрос на сервер отчетов. Запрос на соединение направляется с использованием идентификатора пользователя Windows. Сервер отчетов проверяет наличие у пользователя разрешения на доступ к серверу отчетов.

Соединение 3

Если проверка завершилась успешно, сервер отчетов подтверждает наличие у пользователя разрешения на доступ к элементу или операции.

Сервер отчетов использует внутренний модуль безопасности для проверки разрешений пользователя. С помощью модуля сервер отчетов вызывает объектную модель Windows SharePoint Services для проверки разрешений, хранящихся в базах данных содержимого SharePoint. Невозможно настраивать или управлять этим модулем безопасности. Он является внутренним компонентом, используемым для серверов отчетов, работающих в режиме интеграции с SharePoint.

Если пользователь обладает разрешением на доступ к отчету, другому элементу или операции, запрос обрабатывается.

Используя встроенную безопасность Windows, можно решить известную проблему «двойного прыжка», связанную с тем, что срок действия учетных данных Windows истекает после одного соединения. Это также расширяет возможности выбора вариантов, доступных при настройке соединений с источниками данных для отчетов и моделей. Если идентификатор пользователя Windows используется для подключения к серверу отчетов, сервер отчетов может использовать этот идентификатор в ходе обработки отчета для получения данных из внешних источников данных. Таким образом, при настройке свойств источника данных для отчета можно выбрать параметр Встроенная безопасность Windows для соединения с источником данных. Дополнительные сведения см. в разделе Указание учетных данных и сведений о соединении электронной документации по SQL Server.

Проверка подлинности Windows или с помощью форм и доверенные учетные записи

Если веб-приложение SharePoint настроено на применение проверки подлинности с помощью форм, соединение с сервером отчетов направляется по сети под стандартной учетной записью, имеющей разрешение на олицетворение пользователя SharePoint на сервере отчетов. Тот же подход используется в том случае, когда веб-приложение SharePoint настроено для применения проверки подлинности Windows, и при этом не включен протокол Kerberos. На следующей схеме показаны соединения при использовании доверенных учетных записей и идентификаторов пользователей SharePoint.

Пользовательское соединение и нестандартная проверка подлинности
Соединение 1

Пользователь входит в систему на веб-узле SharePoint. Веб-приложение SharePoint выполняет проверку подлинности пользователя. Веб-приложение SharePoint преобразует идентификатор пользователя в идентификатор пользователя SharePoint (SPUser). Новый маркер пользователя создается для этого пользователя в контексте SPUser. Маркер содержит идентификатор пользователя и сведения о принадлежности к группе. Пользователь запрашивает элемент или операцию сервера отчетов.

Соединение 2

Веб-приложение SharePoint олицетворяет идентификатор пользователя SharePoint в запросе к серверу отчетов. Запрос на соединение направляется под доверенной учетной записью. Для этого используется идентификатор процесса веб-приложения SharePoint.

Сервер отчетов проверяет, является ли поступивший запрос на соединение запросом от доверенной учетной записи, сравнивая эту запись с данными учетной записи, полученными из баз данных конфигурации SharePoint при запуске сервера отчетов. На сервере отчетов доверенной учетной записью является учетная запись пользователя Windows с разрешением на олицетворение веб-приложения SharePoint. Она используется только для олицетворения SPUser. Ей не разрешается доступ к элементам и операциям сервера отчетов.

Соединение 3

Если проверка завершилась успешно, сервер отчетов подтверждает наличие у пользователя SPUser разрешения на доступ к элементу или операции.

С помощью модуля сервер отчетов проверяет разрешения пользователя, вызывая объектную модель Windows SharePoint Services для проверки разрешений, хранящихся в базах данных содержимого SharePoint. Если пользователь обладает разрешением на доступ к отчету, другому элементу или операции, запрос обрабатывается.

Истечение срока действия учетной записи и обработка подписки

При создании подписки на отчет сервер отчетов сохраняет данные учетной записи пользователя SPUser, чтобы с их помощью проверить наличие у пользователя разрешения на просмотр отчета в момент доставки. Если срок действия учетной записи SPUser истек, подписка завершится неуспешно и возвратит ошибку rsSharePointError. Свойством уровня фермы, именуемым TokenTimeout, определяется продолжительность срока действия учетной записи SPUser.

Доступ сервера отчетов к базам данных содержимого SharePoint

И веб-приложение SharePoint, и сервер отчетов подключаются к соответствующим базам данных, чтобы сохранить данные о состоянии приложения и другие данные, однако серверу отчетов необходимо также подключаться к базам данных SharePoint для сохранения и получения элементов, свойств и настроек конфигурации. На следующей схеме показаны серверные соединения с различными базами данных.

Серверные соединения с хранилищами данных

Веб-приложением SharePoint для внутреннего хранения может использоваться локальная или удаленная база данных. Если базы данных SharePoint расположены на удаленных компьютерах, для соединения необходимо использовать учетную запись домена.

Сервером отчетов для внутреннего хранения может использоваться локальная или удаленная база данных. В обоих случаях соединение с базой данных может быть создано с использованием учетной записи домена, имени входа SQL Server или встроенной учетной записи, например Network Service или Local System.

Соединение сервера отчетов с базами данных SharePoint

В службах Reporting Services как для веб-служб, так и для служб Windows требуется доступ к базам данных SharePoint. Учетные записи служб для обеих служб рассматриваются как доверенные пользователи в веб-приложении SharePoint и автоматически получают разрешение на доступ к базам данных SharePoint.

Соединение управляется внутренне; оно настраивается при использовании центра администрирования SharePoint для определения сервера отчетов для веб-приложения SharePoint и задания доверенных учетных записей. В отличие от соединения сервера отчетов с его собственными базами данных, которое можно задать или изменить с помощью программы настройки служб Reporting Services, соединение сервера отчетов с базами данных SharePoint не подлежит настройке или управлению явным образом.

Работа сервера отчетов в режиме интеграции с SharePoint связана с ограничениями в возможностях настройки учетных записей служб в Reporting Services. При настройке учетных записей служб следуйте приведенным ниже рекомендациям:

  • Выбирайте учетные записи, имеющие разрешения на вход в сеть, если учетные записи служб сервера отчетов будут использоваться для подключения к базам данных SharePoint на удаленном компьютере.

  • Избегайте использования встроенных учетных записей (например, Локальная система или Сетевая служба), если сервер отчетов и базы данных SharePoint располагаются на одном компьютере, а веб-приложение SharePoint — на другом, удаленном компьютере. Если базы данных SharePoint находятся на удаленном компьютере, веб-приложение SharePoint явно отказывает в доступе к базе данных встроенным учетным записям, определенным на удаленном компьютере. Это означает, что все службы, выполняющиеся под встроенными учетными записями на этом компьютере, не могут подключиться к базам данных SharePoint.

  • Для любой другой топологии, предусматривающей размещение серверов и баз данных на одном и том же компьютере или на разных компьютерах, учетные записи служб Reporting Services могут настраиваться как учетные записи домена или как встроенные учетные записи.

Ошибки при подключении к базам данных SharePoint

Если серверу отчетов не удается получить доступ к базам данных SharePoint и имеется ошибка конфигурации (например, если учетные записи служб или пароли недействительны, или если локальный экземпляр объектной модели Windows SharePoint не установлен), возникает ошибка rsServerConfigurationError. Для всех остальных ошибок при соединении возвращается ошибка rsSharePointError вместе с дополнительными сведениями об ошибке из локального экземпляра Windows SharePoint Services.

См. также

Основные понятия

Хранение и синхронизация содержимого сервера отчетов с помощью баз данных SharePoint

Другие ресурсы

Using Built-in Security in Windows SharePoint Services for Report Server Items
Comparing Roles and Tasks in Reporting Services to SharePoint Groups and Permissions
How to: Set Permissions for Report Server Items on a SharePoint Site (Reporting Services in SharePoint Integrated Mode)


Хранение и синхронизация содержимого сервера отчетов с помощью баз данных SharePoint

Хранение и синхронизация содержимого сервера отчетов с помощью баз данных SharePoint |
 | См. также
Настройка служб Reporting Services > Настройка служб Reporting Services для интеграции с SharePoint 3.0 > Интеграция служб Reporting Services и технологии SharePoint >

Новое содержимое: 12 декабря 2006 г.

Сервер отчетов, настроенный для работы в режиме интеграции с SharePoint, использует базы данных конфигурации и содержимого SharePoint наряду с собственными внутренними базами данных для хранения содержимого и метаданных.

Как Reporting Services, так и Windows SharePoint Services являются распределенными серверными приложениями, позволяющими запускать службы и внутренние базы данных на отдельных компьютерах. На каждом сервере хранятся различные виды данных. Несколько реляционных баз данных SQL Server обеспечивают внутреннее хранилище для обоих серверов. Знание о том, какой тип данных хранится в каждой из них, поможет понять принципы совместной работы серверов. Кроме того, оно поможет обосновать принятие решений о выделении места на диске и планировании резервного копирования баз данных.

На следующей схеме показан полный набор баз данных, используемых в развертывании сервера отчетов, работающего в режиме интеграции с SharePoint.

Хранилища данных в режиме интеграции с SharePoint

База данных конфигурации SharePoint

Каждое веб-приложение SharePoint располагает базой данных конфигурации, где хранятся настройки приложения. При настройке экземпляра Windows SharePoint Services или Office SharePoint Server для работы с сервером отчетов необходимые параметры определяются на центральном веб-узле администрирования SharePoint. Заданные пользователем настройки сохраняются в этой базе данных. Настройки включают URL-адрес сервера отчетов, данные учетной записи для веб-службы и службы Windows сервера отчетов, данные о поставщике проверки подлинности, используемом на сервере, и настройки на уровне веб-узла, которыми ограничивается или активируется ведение журнала отчета. Дополнительные сведения см. в разделе Настройка служб Reporting Services для интеграции с SharePoint 3.0.

База данных содержимого SharePoint

Каждое веб-приложение SharePoint располагает одной или несколькими базами данных содержимого, где хранятся документы и свойства, управление и доступ к которым обеспечивается через сервер. Для сервера отчетов, настроенного на работу в режиме интеграции с SharePoint, база данных содержимого SharePoint обеспечивает основное хранилище для публикуемых отчетов, моделей отчетов, общих источников данных, ресурсов, свойств и разрешений.

База данных сервера отчетов и временная база данных сервера отчетов

Каждый экземпляр сервера отчетов или масштабное развертывание пользуется одной базой данных сервера отчетов для хранения постоянных данных. Временные данные изолируются во вспомогательной таблице. Это позволяет создавать отдельные расписания резервного копирования и определять различные параметры прироста для каждой из баз данных. Для каждой базы данных сервера отчетов существует одна временная база данных. В ней хранятся данные сеанса и временные моментальные снимки, создаваемые только для обработки подписки, интерактивной подготовки отчетов или кэширования отчетов в целях улучшения производительности.

Данные, хранящиеся в базе данных сервера отчетов, включают расписания, подписки и моментальные снимки для журнала отчета или выполнения отчета. В базе данных сервера отчетов содержатся также внутренние копии файлов содержимого, хранящихся в базе данных содержимого SharePoint. Хранение внутренних копий позволяет улучшить производительность за счет минимизации числа отправок файла на сервер отчетов для обработки. Синхронизация и проверки обеспечивают соответствие отчетов, моделей и источников данных.

Важно!
База данных сервера отчетов может поддерживать операции в собственном режиме или операции в режиме интеграции с SharePoint, но не оба типа операций одновременно. Если база данных сервера отчетов создается для поддержки режима интеграции с SharePoint, впоследствии невозможно выполнить ее преобразование или миграцию для работы в собственном режиме экземпляра сервера отчетов. База данных сервера отчетов содержит метаданные, относящиеся к режиму (в частности, местоположение элементов и сведения о разрешениях), несовместимые с другим режимом.

Подключения к базе данных, разрешения и имена входа

Пользователь, настраивающий сервер отчетов или экземпляр служб Windows SharePoint Services или Office SharePoint Server, должен быть локальным администратором или членом встроенной группы администраторов компьютера.

Как для веб-службы, так и для службы Windows сервера отчетов необходимо соединения с базой данных содержимого SharePoint, но не требуется соединение с базой данных конфигурации. Параметры интеграции сервера отчетов сохраняются в базах данных конфигурации с использованием имени входа и разрешений, созданных для пользователей центрального веб-узла администрирования при установки служб Windows SharePoint Services.

В то же время обе службы, веб-служба и служба Windows сервера отчетов, создают, обновляют и удаляют элементы и свойства в базе данных содержимого SharePoint. Данные соединения, имя входа и разрешения базы данных настраиваются при задании доверенных учетных записей на центральном веб-узле администрирования.

Экземпляр служб Windows SharePoint Services или Office SharePoint Server не добавляет и не получает данных из баз данных сервера отчетов. Все запросы направляются на сервер отчетов, который, в свою очередь, получает доступ к базам данных сервера отчетов с использованием собственных настроек соединения.

Разрешение на просмотр элемента или выполнение операции на сервере отчетов определяется экземпляром служб Windows SharePoint Services или Office SharePoint Server. Проверка подлинности и проверки безопасности выполняются перед отправкой запроса на сервер отчетов. Каждый запрос сопровождается маркером безопасности, содержащим данные разрешения, в соответствии с которыми запрос обслуживается либо отклоняется.

Обслуживание базы данных

Сервер отчетов осуществляет регламентное обслуживание для удаления потерянных моментальных снимков отчета, журнала отчета, расписаний и подписок из базы данных сервера отчетов, удаляемых на веб-узле SharePoint.

Ежедневно сервер отчетов выполняет проверку актуальности связей между элементами, хранящимися в базе данных сервера отчетов, и отчетом, существующим в базе данных содержимого SharePoint. Чтобы изменить частоту выполнения операции очистки, добавьте параметр конфигурации DailyCleanupMinuteofDay в файл RSReportServer. Процесс очистки выполняется в фоновом режиме, для него используются данные расписания, определенные в файлах конфигурации. Процесс очистки нельзя выполнять по требованию.

Если экземпляр служб Windows SharePoint Services или Office SharePoint Server недоступен (например, сервер находится в автономном режиме), операция очистки не выполняется. Если выполнено восстановление базы данных сервера отчетов, которая содержит устаревшие данные, не соответствующие элементам, в настоящее время хранящимся в базе данных SharePoint, эти элементы будут удалены при следующем выполнении операции очистки.

Операцией очистки удаляется только содержимое; при этом не выполняется синхронизация или обновление элементов сервера отчетов, хранящихся в базе данных содержимого SharePoint. По умолчанию операция очистки выполняется ежедневно в 2 часа ночи.

Чтобы задать другое время, необходимо добавить параметр DailyCleanupMinuteofDay в файл RSReportServer.config и указать другое значение. Например:

Копировать код
<Add Key=" DailyCleanupMinuteOfDay " Value="120" />

По умолчанию этот параметр отсутствует в файле RSReportServer.config. Чтобы добавить его, скопируйте запись и поместите ее под элементом Configuration наряду с другими элементами Add в этом разделе. Значение выражается в минутах, начиная с полуночи, с минимальным значением 30 и максимальным значением 1380 (23 часа).

Операции синхронизации и проверки

Чтобы убедиться в том, что копии, хранимые для внутренней обработки на сервере отчетов, соответствуют исходным элементам в библиотеке SharePoint, сервер отчетов выполняет синхронизацию и проверку элементов перед обработкой запроса.

Синхронизация — процесс, в ходе которого создается, обновляется или удаляется внутренняя копия элемента, хранящегося в базе данных сервера отчетов. Сервер отчетов получает элементы и свойства из библиотеки SharePoint и сохраняет их в базе данных сервера отчетов. Основой для сравнения служат данные временных меток. Временные метки хранятся в формате UTC. Если сервер отчетов и веб-узел или ферма SharePoint расположены в разных часовых поясах, временные метки преобразуются в местное время сервера при сохранении.

Проверка представляет собой процесс определения необходимости синхронизации. Если временные метки исходного элемента и его внутренней копии совпадают, синхронизация не выполняется.

Порядок синхронизации элементов

Синхронизация выполняется сервером отчетов. Этот процесс выполняется в фоновом режиме и запускается автоматически при создании, обновлении или получении элемента. Нельзя управлять операциями синхронизации, а также настраивать или явно контролировать их. Синхронизация выполняется на уровне конкретных запросов на создание или обновление элемента. Не существует глобальной операции синхронизации, выполняющей синхронизацию всех элементов и свойств одновременно. Чтобы вручную синхронизировать отчет, модель отчета или общий источник данных, необходимо запустить их.

Внутренние копии элемента создаются или обновляются, если элемент не существует в базе данных сервера отчетов или если элемент в базе данных сервера отчетов является устаревшей версией соответствующего элемента в библиотеке SharePoint. Внутренняя копия создается в ответ на следующие события.

  • Запрос на отчет или модель отчета. При этом создается внутренняя копия отчета, модели отчета и любых общих источников данных, на которые ссылается любой из этих элементов.

  • Публикация отчета или модели отчета из конструктора отчетов или конструктора моделей в библиотеке SharePoint. После добавления элемента в базу данных содержимого SharePoint копия отчета или модели создается и добавляется в базу данных сервера отчетов. Если наряду с моделью отчета опубликован общий источник данных, внутренняя копия общего источника данных не будет создана до момента его использования.

При использовании действия Загрузить на веб-узле SharePoint будет отложено создание внутренней копии в базе данных сервера отчетов. Для любого передаваемого элемента сервера отчетов внутренняя копия создается в момент, когда элемент запрашивается.

Не создаются внутренние копии внешних файлов изображений, используемых в отчете, а также расписаний, моментальных снимков или подписок, сохраняемых исключительно в базе данных сервера отчетов.

О настройках конфигурации и разрешениях

Хотя настройки конфигурации должны быть определены правильно на обоих серверах, они исключены из процессов синхронизации. При изменении учетных записей служб сервера отчетов, URL-адресов, типа проверки подлинности или режима выполнения сервера отчетов (так, чтобы он работал в собственном режиме вместо режима интеграции с SharePoint) необходимо явным образом обновить настройки конфигурации сервера на центральном веб-узле администрирования SharePoint или с помощью программы настройки служб Reporting Services.

Разрешения, заданные на веб-узле или ферме SharePoint, используются сервером отчетов. Синхронизация разрешений между веб-узлом или фермой SharePoint и сервером отчетов не производится.

Доступность сервера и ошибки синхронизации

Для выполнения синхронизации элементов, свойств и операций необходимо, чтобы все компьютеры и соединения, являющиеся частью развертывания, были доступны и функционировали успешно. Выполнение синхронизации невозможно, если верны следующие условия:

  • Серверы или вспомогательные базы данных переведены в автономный режим или по иным причинам недоступны.

  • Данные соединения для какого-либо из серверов или вспомогательных баз данных стали недействительными. Например, при некорректном изменении URL-адреса либо при изменении учетной записи или пароля службы.

  • Данные соединения изменены без предварительного перевода серверов в автономный режим, в результате чего нарушено расписание и поток синхронизированных операций.

В случаях, когда выполнение синхронизации невозможно из-за невозможности создать соединения между серверами или между серверами и их вспомогательными базами данных, сервер отчетов приводит рассинхронизированное содержимое или метаданные в соответствие после того, как соединение восстановлено, в момент, когда запрашивается конкретный отчет, модель отчета, общий источник данных или подписка.

При сбое синхронизации выдается ошибка rsItemNotFound. Это означает, что элемент не найден в библиотеке SharePoint.

См. также

Задачи

Как создать базу данных сервера отчетов для режима интеграции с SharePoint (настройка служб Reporting Services)

Основные понятия

Настройка соединения с базой данных сервера отчетов
Настройка служб Reporting Services для интеграции с SharePoint 3.0

Другие ресурсы

База данных сервера отчетов
Файл конфигурации RSReportServer
База данных сервера отчетов
Deploying Reports, Models, and Shared Data Sources to a SharePoint Site


Сравнение уровней интеграции между версиями служб Reporting Services и технологиями SharePoint

Сравнение уровней интеграции между версиями служб Reporting Services и технологиями SharePoint |
 | См. также
Настройка служб Reporting Services > Настройка служб Reporting Services для интеграции с SharePoint 3.0 > Интеграция служб Reporting Services и технологии SharePoint >

Новое содержимое: 12 декабря 2006 г.

Сервер отчетов, настроенный для режима интеграции с SharePoint в составе более широкого развертывания продукта или технологии SharePoint 3.0, обеспечивает более глубокий уровень интеграции, чем прежде. Эта новая возможность интеграции представлена в SQL Server 2005 с пакетом обновлений Service Pack 2 (SP2) и требует продуктов или технологий SharePoint выпуска 3.0.

Прежние версии служб Reporting Services также обеспечивают интеграцию с продуктами и технологиями SharePoint. А именно, службы SQL Server 2000 Reporting Services SP2, SQL Server 2005 и SQL Server 2005 SP1 предоставляли два веб-компонента (обозреватель отчетов и средство просмотра отчетов), которые регистрировались и использовались в веб-приложении SharePoint. Эти веб-компоненты разрабатывались для технологий SharePoint версии 2.0. Они продолжают работать с пакетом обновления SP2 и могут использоваться в развертывании продукта или технологии SharePoint 3.0. Веб-компоненты не обновлялись с целью включения новых возможностей и в случае использования обеспечивают тот же уровень функциональных возможностей.

В следующей таблице сравниваются новые и старые уровни интеграции. Если в организации планируется новое развертывание или оцениваются новые возможности интеграции, таблица поможет сравнить достоинства и недостатки каждой реализации.

Критерий сравнения Режим интеграции с SharePoint Веб-компоненты SharePoint 2.0

Требования к продукту и версии

Только SQL Server 2005 SP2. Windows SharePoint Services 3.0 или Office SharePoint Server 2007.

Службы SQL Server 2000 Reporting Services Service Pack 2 и далее до SQL Server 2005. Windows SharePoint Services 2.0 и SharePoint Portal Server. Веб-компоненты обладают обратной совместимостью с Windows SharePoint Services 3.0 и Office SharePoint Server 2007.

Ключевые функции

Унифицированный портал для доступа и управления содержимым сервера отчетов.

Клиентским сервером является веб-приложение SharePoint. Службы Reporting Services становятся внутренним сервером, защищенным брандмауэром и обеспечивающим возможности обработки и подготовки данных.

Поставщики проверки подлинности и разрешения, определенные для веб-приложения SharePoint используются для управления доступом к операциям и содержимому сервера отчетов.

Веб-компонент «Средство просмотра» выводит отчеты. Его можно подключить к другим веб-компонентам и настроить для соответствия общему дизайну страниц.

В набор функций интеграции включено ведение нерегламентированных отчетов. Можно создавать и хранить модели и связывать отчеты с сущностями в моделях из веб-приложения SharePoint. Можно создавать и редактировать отчеты с помощью построителя отчетов в веб-приложении SharePoint.

Можно публиковать отчеты, модели и источники данных в библиотеке SharePoint.

Веб-компонент «Обозреватель отчетов» отображает список отчетов, хранящихся на сервере отчетов.

Веб-компонент «Средство просмотра» выводит отчеты.

Веб-компоненты предоставляются по приниципу «как есть» с ограниченной поддержкой настройки.

Сервер отчетов обеспечивает управляемым элементам хранение, обработку и защиту. Доступ к отчетам и управление содержимым осуществляется с помощью инструментов сервера отчетов.

Установка и настройка

Загрузите и установите надстройку служб Reporting Services на все веб-клиенты в веб-ферме SharePoint.

Настройте интеграцию на центральном веб-узле администрирования SharePoint и с помощью средства настройки служб Reporting Services.

Добавьте виртуальные каталоги служб Reporting Services к списку исключений Windows SharePoint Services.

Откройте CAB-файл для установки веб-компонентов.

Измените файл Web.config file и вручную скопируйте файлы.

Требования к режимам

Требует, чтобы сервер отчетов выполнялся в режиме интеграции с SharePoint.

Может использоваться на сервере отчетов, работающем в собственном режиме.

Ограничения

Не поддерживает управляемые данными подписки, связанные отчеты, диспетчер отчетов и среду Management Studio.

Отсутствует поддержка программирования пакетных операций и управления заданиями.

Требует настройки и обслуживания отдельных политик безопасности в веб-приложении SharePoint и на сервере отчетов.

Требует отдельных инструментов управления содержимым и операциями для каждого сервера.

Запланированные операции, источники данных, журналы отчетов, обработка данных и подписок управляются с помощью инструментов сервера отчетов.

См. также

Основные понятия

Интеграция служб Reporting Services и технологии SharePoint
Требования для запуска служб Reporting Services в режиме интеграции с SharePoint
Функции, поддерживаемые службами Reporting Services в режиме интеграции с SharePoint
Хранение и синхронизация содержимого сервера отчетов с помощью баз данных SharePoint
Общие сведения о безопасности для служб Reporting Services в режиме интеграции с SharePoint
Просмотр и управление элементами сервера отчетов с узла SharePoint
Режимы развертывания для служб Reporting Services
Настройка служб Reporting Services для интеграции с SharePoint 3.0

Другие ресурсы

Параллельное развертывание служб Reporting Services и служб Windows SharePoint
Просмотр отчетов с помощью веб-компонентов службы SharePoint


Требования для запуска служб Reporting Services в режиме интеграции с SharePoint

Требования для запуска служб Reporting Services в режиме интеграции с SharePoint |
 | См. также
Настройка установки SQL Server > Настройка служб Reporting Services > Настройка служб Reporting Services для интеграции с SharePoint 3.0 >

Новое содержимое: 12 декабря 2006 г.

2005 Reporting Services можно интегрировать с Windows SharePoint Services или Office SharePoint Server , настроив сервер отчетов для работы в режиме интеграции с SharePoint и установив надстройки служб Reporting Services, которые добавляют страницы инфраструктуры и приложений в веб-приложение SharePoint.

Следующие версии и выпуски могут использоваться для поддержки операций интеграции.

  • Службы SQL Server 2005 Reporting Services с пакетом обновления 2 (SP2). Нельзя интегрировать экземпляр сервера отчетов с более ранней версией.

    Поддерживаются выпуски Evaluation, Standard, Developer и Enterprise. Эта возможность не поддерживается в выпусках Workgroup Edition и SQL Server 2005 Express with Advanced Services.

  • Windows SharePoint Services 3.0 или 2007. Если используется Office SharePoint Server , необходимо иметь Office Server Premium или Office Server Standard Edition.

  • Надстройка служб Reporting Services для технологии SharePoint. Надстройку необходимо установить на используемый экземпляр технологии SharePoint. Существует только одна версия надстройки служб Reporting Services.

Если компьютер не удовлетворяет требованиям, приведенным в этом разделе, можно получить доступ к отчетам с веб-узла SharePoint, используя веб-компоненты, которые поставлялись в предыдущих версиях служб Reporting Services. Дополнительные сведения см. в разделе Сравнение уровней интеграции между версиями служб Reporting Services и технологиями SharePoint.

Требования к оборудованию и программному обеспечению

Компьютер, на котором размещается продукт или технология SharePoint, предназначенная для интеграции с сервером отчетов, должен иметь 2 ГБ ОЗУ.

Он также должен удовлетворять требованиям к оборудованию и программному обеспечению, которые предъявляются каждой серверной технологией. Для просмотра требований к службам SQL Server Reporting Services см. раздел Требования к оборудованию и программному обеспечению для установки SQL Server 2005. Дополнительные сведения о требованиях для продуктов и технологий SharePoint см. в разделе «Определение требований к оборудованию и программному обеспечению» на веб-узле Майкрософт.

Требования к разрешениям

Для запуска программы установки необходимо быть членом локальных администраторов. Программу установки необходимо запускать на локальном компьютере. Ее нельзя запустить удаленно, чтобы применить пакет обновления 2 (SP2) или установить надстройку служб Reporting Services.

Требования к веб-узлу

Если параллельное развертывание обоих серверных продуктов выполняется на одном веб-сервере, необходимо создать специальный веб-узел для сервера отчетов или настроить веб-узел по умолчанию под другой порт. Требования к веб-узлу решаются на этапах конфигурации. Дополнительные сведения см. в разделе Настройка служб Reporting Services для интеграции с SharePoint 3.0.

Требования к поставщику проверки подлинности

В веб-приложении SharePoint нельзя включить анонимный доступ. Если включен анонимный доступ, можно настроить параметры интеграции, но при запуске отчета пользователи будут получать сообщение об ошибке.

Поддерживаются все остальные поставщики проверки подлинности и параметры. Если настраивается интеграция между сервером отчетов и фермой SharePoint, каждое веб-приложение в ферме SharePoint можно настроить на использование разных поставщиков проверки подлинности.

Требования к серверу отчетов

Кроме требований к пакету обновления 2 (SP2) и выпускам, экземпляр сервера отчетов должен иметь локальную установку объектной модели Windows SharePoint Services. Чтобы определить, имеется ли эта объектная модель, программа установки проверяет наличие ключа реестра HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Shared Tools\Web Server Extensions\12.0 с параметром Sharepoint, имеющим значение Installed.

Объектная модель Windows SharePoint Services используется для объединения сервера отчетов с веб-фермой SharePoint. Она хранит указатель на экземпляр базы данных конфигурации технологии SharePoint, с которым соединяется сервер отчетов. Все соединения сервера отчетов с экземпляром технологии SharePoint выполняются через объектную модель. Дополнительные сведения о соединениях сервера см. в разделе Общие сведения о безопасности для служб Reporting Services в режиме интеграции с SharePoint. Дополнительные сведения об установке объектной модели см. в разделе Как установить объектную модель службы Windows SharePoint Services на компьютер сервера отчетов.

Требования к надстройке служб Reporting Services

Надстройка служб Reporting Services устанавливается программой установки, которая выполняется в командной строке на сервере с экземпляром продукта или технологии SharePoint, которые предполагается использовать. Перед установкой надстройки служб Reporting Services программа установки выполняет предварительную проверку на удовлетворение требованиям выпуска, версии и платформы.

Выпуски и версии

Продукт или технология SharePoint должны иметь версию Windows SharePoint Services 3.0 или Office SharePoint Server 2007. Нельзя установить надстройку служб Reporting Services на предварительной версию. Можно использовать выпуски Premium или Standard.

Язык для сценариев многоязычного развертывания

SQL Server 2005 и продукты и технологии SharePoint локализованы на многих языках. Если сервер отчетов интегрируется с экземпляром продукта или технологии SharePoint, локализованным на языке, который не поддерживает сервер отчетов, результатом будет сочетание языков. Дополнительные сведения о поддержке языков см. в разделе Режимы развертывания для служб Reporting Services.

Реляционные базы данных SQL Server

Как службы Reporting Services, так и службы Windows SharePoint Services используют реляционные базы данных SQL Server для внутреннего хранения. Службы Windows SharePoint Services устанавливают для своей базы данных SQL Server 2005 Express. Службы Reporting Services не могут использовать SQL Server Express для своей базы данных. Они требуют установки выпуска Evaluation, Developer, Standard или Enterprise Edition для SQL Server Database Engine.

Если нужно установить службы Reporting Services и экземпляр технологии SharePoint на один компьютер, можно запустить параллельно SQL Server Express и другой выпуск SQL Server 2005. Дополнительные сведения см. в разделе Установка нескольких экземпляров служб Reporting Services.

Службы Reporting Services предъявляют требования к выпуску и версии базы данных сервера отчетов. Дополнительные сведения см. в разделе Создание базы данных сервера отчетов.

Требования к операционной системе

При установке надстройки служб Reporting Services программа установки проверяет, работает ли компьютер под управлением версии x86 или x64 или более поздней.

См. также

Основные понятия

Настройка служб Reporting Services для интеграции с SharePoint 3.0
Сравнение уровней интеграции между версиями служб Reporting Services и технологиями SharePoint
Установка надстройки службы Reporting Services


Настройка виртуальных каталогов сервера отчетов

Настройка виртуальных каталогов сервера отчетов |
 | См. также
Настройка установки SQL Server > Настройка служб Reporting Services >

Дата обновления: 12 декабря 2006 г.

В службах Reporting Services URL-адреса используются для доступа к серверу отчетов, диспетчеру отчетов, построителю отчетов и отдельным отчетам. В этом подразделе описаны URL-адреса, используемые для доступа к серверу отчетов и диспетчеру отчетов, приведены рекомендации по созданию виртуальных каталогов для каждого приложения и содержится общий обзор настроек, хранящихся в файлах конфигурации.

Примечание.
В этом подразделе не описывается доступ с помощью URL-адресов к построителю отчетов или конкретным отчетам, хранящимся на сервере отчетов. Дополнительные сведения о доступе к этим элементам по URL-адресам см. в разделах Запуск построителя отчетов и Using a URL to Access Report Server Items электронной документации по SQL Server.

Об URL-адресах и виртуальных каталогах сервера отчетов в режиме интеграции с SharePoint

Если сервер отчетов настроен для выполнения в составе более широкого развертывания продукта или технологии SharePoint, это скажется на структуре URL виртуального каталога следующим образом.

  • На все элементы на веб-узле SharePoint имеются ссылки, которые представляют собой полные URL-адреса (включающие расширение имени файла) и используются для различения разных типов элементов сервера отчетов. Полный URL-адрес необходимо задавать при ссылках на общие источники данных и модели в отчетах, а также при указании целевого сервера и папок для операций публикации на сервере отчетов.

  • Для параллельного развертывания, когда сервер отчетов и экземпляр технологии SharePoint устанавливаются на один компьютер, нельзя использовать адрес http://localhost/reportserver. Если адрес http://localhost используется для доступа к веб-приложению SharePoint, необходимо использовать веб-узел, не заданный по умолчанию, или назначить уникальный порт для доступа к серверу отчетов.

  • Нельзя настраивать URL-адрес и виртуальный каталог для диспетчера отчетов. В противном случае он перестанет работать после развертывания сервера отчетов в режиме интеграции с SharePoint. Диспетчер отчетов не поддерживается в этом режиме.

Дополнительные сведения о режимах развертывания и требованиях к URL-адресам для публикации элементов см. в разделах Режимы развертывания для служб Reporting Services и Deploying Reports, Models, and Shared Data Sources to a SharePoint Site.

Об URL-адресах и виртуальных каталогах сервера отчетов собственного режима сервера отчетов

В службах SQL Server 2005 Reporting Services сервер отчетов и диспетчер отчетов доступны через URL-адреса, содержащие выделенные виртуальные каталоги, которые настраиваются отдельно для каждого компонента.

  • Виртуальный каталог диспетчера отчетов используется для подключения к диспетчеру отчетов. По умолчанию виртуальный каталог диспетчера отчетов называется reports.

  • Виртуальный каталог сервера отчетов обеспечивает программный доступ к конечным точкам SOAP веб-службы сервера отчетов. Кроме того, он является корневым узлом пространства имен папок сервера отчетов, обеспечивающим URL-адресацию для отчетов, ресурсов, моделей, общих источников данных и папок, которые хранятся на сервере отчетов. По умолчанию виртуальный каталог сервера отчетов называется reportserver.

Виртуальные каталоги являются частью полного URL-адреса, используемого для доступа к диспетчеру отчетов и к серверу отчетов. Полный URL-адрес состоит из следующих частей.

http:// или https://

URL-адрес начинается с префикса. Префикс https используется в случае, если сервер настроен на работу с протоколом SSL.

Префиксы http:// и https:// используются чаще всего, однако поддерживаются и другие префиксы. Дополнительные сведения о строении URL-адреса см. в разделе URL Access Syntax электронной документации по SQL Server.

Имя сервера

Может использоваться имя компьютера в сети. При организации локального доступа может использоваться имя localhost. Если к компьютеру возможен доступ через подключение к Интернету, необходимо использовать полное имя домена.

Веб-узел

Веб-узел является конструкцией IIS, определяющей, какое приложение должно получить запрос.

Может использоваться веб-узел по умолчанию. При работе с пользовательским веб-узлом можно использовать IP-адрес, заголовок компьютера или номер порта. Дополнительные сведения о различных способах идентификации веб-узла см. в разделе Размещение нескольких веб-узлов на одном сервере документации по службам IIS.

Виртуальный каталог

Виртуальный каталог — единственная часть URL-адреса, настраиваемая с помощью служб Reporting Services.

Для создания виртуального каталога используется программа настройки служб Reporting Services. При установке конфигурации по умолчанию виртуальный каталог создается программой установки.

Создавая виртуальный каталог, программа установки использует имя экземпляра, если таковое существует. Например, если в конфигурации по умолчанию установлен выпуск SQL Server 2005 Express Edition with Advanced Services, программа установки в качестве имени виртуального каталога использует reportserver$SQLEXPRESS.

Примечание.
URL-адреса обеспечивают конечным пользователям и разработчикам доступ к серверу отчетов. Дополнительные сведения о подключениях к серверу отчетов см. в разделе Соединения и учетные записи при развертывании служб Reporting Services электронной документации по SQL Server.

Примеры URL-адресов служб Reporting Services

Приведенный ниже список содержит несколько примеров того, как может выглядеть URL-адрес сервера отчетов.

  • http://localhost/reportserver

  • http://localhost/reportserver$SQLEXPRESS

  • http://sales01/reportserver

  • http://sales01:8080/reportserver

  • https://sales.adventure-works.com/reportserver

  • https://www.adventure-works.com:8080/reportserver01

URL-адреса, используемые для доступа к диспетчеру отчетов, имеют тот же формат и обычно создаются на том же веб-узле, где расположен сервер отчетов. Единственным различием является имя виртуального каталога (в данном случае, это reports, но можно использовать любое имя по своему усмотрению).

  • http://localhost/reports

  • http://localhost/reports$SQLEXPRESS

  • http://sales01/reports

  • http://sales01:8080/reports

  • https://sales.adventure-works.com/reports

  • https://www.adventure-works.com:8080/reports

Рекомендации по настройке виртуального каталога

На существующем веб-узле должны быть созданы виртуальные каталоги сервера отчетов и диспетчера отчетов. Можно использовать веб-узел по умолчанию или же пользовательский веб-узел. Для обоих виртуальных каталогов можно использовать один и тот же веб-узел. Каких-либо особых требований к этому веб-узлу не предъявляется. Вся безопасность, ASP.NET, пути, разрешения, а также другие параметры настраиваются в виртуальных каталогах.

При создании виртуального каталога удостоверение веб-службы сервера отчетов настраивается автоматически. Идентификатор веб-службы зависит от применяемой версии сервера служб IIS, как показано ниже.

  • В IIS 6.0 идентификатор веб-службы определяется пулом приложений, содержащим веб-узел. По умолчанию это NetworkService.

  • В IIS 5.0 идентификатор веб-службы всегда является идентификатором процесса ASP.NET. По умолчанию это ИмяКомпьютера\ASPNET.

В виртуальных каталогах служб Reporting Services используется ASP.NET 2.0 (эта версия устанавливается вместе с SQL Server). При использовании на веб-сервере более ранних версий ASP.NET убедитесь в отсутствии конфликтов версий ASP.NET. В одном и том же процессе не могут одновременно работать две различные основные версии ASP.NET. В IIS 6.0 различные версии ASP.NET можно запускать параллельно, с отдельным пулом приложений для каждой версии. В IIS 5.0 каждая версия ASP.NET запускается в качестве отдельного процесса автоматически.

Для виртуальных каталогов сервера отчетов настроен доступ из внутренней сети. Анонимный доступ по умолчанию отключен. В большинстве случаев в URL-адресах сервера отчетов используются сетевые имена компьютеров. Для настройки подключения к Интернету в службах Reporting Services может понадобиться изменить файлы конфигурации сервера отчетов. Дополнительные сведения см. в подразделе «Параметры конфигурации для URL-адресов, используемых службами Reporting Services», а также в разделе Настройка сервера отчетов для доступа через Интернет.

Для создания и настройки виртуальных каталогов можно использовать программу настройки служб Reporting Services.

Сведения о запуске сервера отчетов и диспетчера отчетов на пользовательском веб-узле см. в разделе How to: Configure Reporting Services to Use a Non-Default Web Site (Reporting Services Configuration).

Пул приложений для веб-службы сервера отчетов задается на странице идентификаторов в программе настройки служб Reporting Services.

Нестандартная настройка сервера IIS

Дальнейшую настройку виртуальных каталогов сервера отчетов и диспетчера отчетов, аналогично остальным виртуальным каталогам, можно выполнить через сервер IIS. Дополнительная пользовательская настройка необходима только при развертывании нестандартного модуля безопасности или при использовании веб-узла, не являющегося веб-узлом по умолчанию. Если в результате пользовательской настройки параметров развертывание прерывается, то с помощью программы настройки служб Reporting Services конфигурацию виртуальных каталогов можно перевести на конфигурацию по умолчанию.

Использование нестандартного номера порта

Чтобы настроить сервер отчетов или диспетчер отчетов на использование другого порта, кроме 80, необходимо изменить файлы конфигурации.

  1. Откройте файл RSReportServer.config в текстовом редакторе.

  2. Добавьте номер порта к параметру UrlRoot в файле rsreportserver.config. Например, если Urlroot имеет значение http://sales01/report server, замените это значение на http://sales01:8080/reportserver.

  3. Откройте файл RSWebApplication.config в текстовом редакторе.

  4. Присвойте параметру ReportServerUrl в качестве значения URL-адрес, указанный в UrlRoot.

  5. Удалите значение (но не теги) для ReportServerVirtualDirectory.

  6. Сохраните оба файла.

При использовании нестандартного порта для веб-узла, настроенного на работу с протоколом SSL, необходимы дополнительные шаги. Дополнительные сведения об использовании протокола SSL с портом, отличным от 443, см. в разделе Настройка сервера отчетов для соединений по протоколу SSL.

Перенаправление на виртуальный каталог диспетчера отчетов

IIS позволяет использовать диспетчер отчетов в качестве домашней страницы веб-сервера по умолчанию. Для настройки перенаправления выполните следующие действия.

  1. Откройте диспетчер IIS.

  2. Щелкните правой кнопкой мыши веб-узел, содержащий диспетчер отчетов, и выберите Свойства.

  3. Перейдите на вкладку Корневой каталог.

  4. Выберите Перенаправление на URL-адрес.

  5. В поле Перенаправить на: введите /reports. Удалите префикс «http://», если он есть в текстовом поле.

  6. При использовании IIS 6.0 выберите Каталог ниже введенного URL-адреса. При использовании IIS 5.0 выберите параметр Каталог ниже данного.

  7. Нажмите кнопку ОК.

Настройки конфигурации для задания URL-адресов, используемых службами Reporting Services

Файлы конфигурации служб Reporting Services содержат настройки, для которых в качестве значений используются URL-адреса. В следующей таблице кратко перечислены все URL-адреса, которые можно задать в файле конфигурации служб Reporting Services. Можно воспользоваться описаниями для сравнения URL-адресов. Примеры совместного использования некоторых из этих настроек см. в разделе Файл конфигурации RSWebApplication.

Параметр Описание

ReportServerVirtualDirectory

Задает конечную точку SOAP сервера отчетов, используемого диспетчером отчетов. Допустимые значения включают имя виртуального каталога сервера отчетов. Например, если сервер отчетов имеет URL-адрес «http://adventure-works.com/reportserver», то параметр ReportServerVirtualDirectory будет иметь значение reportserver. Для подключения к серверу отчетов диспетчер отчетов использует имя localhost. Если оно отключено, укажите вместо него ReportServerUrl.

Этот параметр задан в файле RSWebApplication.config. Данное значение создается во время установки или с помощью программы настройки служб Reporting Services при настройке виртуального каталога диспетчера отчетов. Кроме того, это значение можно изменить путем редактирования файла конфигурации.

Данный параметр требует, чтобы диспетчер отчетов и сервер отчетов использовали один и тот же веб-узел. Если они используют разные веб-узлы, удалите значение аргумента ReportServerVirtualDirectory и используйте вместо него ReportServerUrl.

ReportServerUrl

Позволяет альтернативным способом указывать конечную точку SOAP сервера отчетов, который используется диспетчером отчетов. Этот параметр можно использовать вместо ReportServerVirtualDirectory, если виртуальные каталоги диспетчера отчетов и сервера отчетов находятся на отдельных серверах или веб-узлах.

Чтобы задать этот параметр, необходимо вручную отредактировать файл RSWebApplication.config. В случае использования сертификатов SSL допустимыми будут значения http://<server>/<reportserver> и https://<server>/<reportserver>. Если диспетчер отчетов установлен отдельно на веб-сервере, доступном через Интернет, то в качестве данного значения должно быть указано полное имя домена, которое можно использовать для доступа к экземпляру сервера отчетов, защищенному брандмауэром. Этот параметр никогда не принимает значение localhost.

Если установлен сертификат протокола SSL, то этому значению необходимо присвоить имя сервера, зарегистрированного для данного сертификата. Если возникает сообщение об ошибке «Базовое соединение закрыто: не удалось установить доверительную связь для безопасного канала SSL/TLS», задайте в качестве значения параметра ReportServerUrl полное доменное имя сервера, для которого был выдан сертификат SSL. Например, если сертификат был зарегистрирован для https://adventure-works.com.onlinesales, в качестве URL-адреса сервера отчетов будет использоваться https://adventure-works.com.onlinesales/reportserver.

UrlRoot

Используется модулями доставки при формировании URL-адреса, используемого для доступа к элементам, которые хранятся на сервере отчетов. Например, для модуля доставки электронной почты сервера отчетов значение UrlRoot используется для создания гиперссылки к распространяемому отчету.

Это значение также применяется для разрешения ссылок в отчете, готовом для просмотра, созданном с помощью автоматической обработки.

Этот параметр задается в файле RSWebApplication.config.

Данное значение задается во время установки или с помощью программы настройки служб Reporting Services, если сервер отчетов установлен методом «только файлы». Значение этого параметра должно быть допустимым URL-адресом сервера отчетов. Если к серверу отчетов возможен доступ через Интернет, присвойте этому параметру значение, приемлемое для доступа через подключение к Интернету.

См. также

Задачи

How to: Configure Reporting Services to Use a Non-Default Web Site (Reporting Services Configuration)

Основные понятия

Виртуальный каталог сервера отчетов (настройка служб Reporting Services)

Другие ресурсы

Настройка компонентов служб Reporting Services

Журнал изменений

Версия Журнал

12 декабря 2006 г.

Новое содержимое
  • Об URL-адресах и виртуальных каталогах сервера отчетов в режиме интеграции с SharePoint

17 июля 2006 г.

Новое содержимое
  • Добавлены примеры задания настроек конфигурации.

Измененное содержимое
  • ReportServerURL и ReportServerVirtualDirectory

14 апреля 2006 г.

Новое содержимое
  • Добавлены примеры задания URL-адресов для сервера отчетов и диспетчера отчетов.


Настройка учетных записей и паролей служб в службах Reporting Services

Настройка учетных записей и паролей служб в службах Reporting Services |
 | См. также
Настройка установки SQL Server > Настройка служб Reporting Services >

Дата обновления: 12 декабря 2006 г.

Службы Reporting Services используют службу Windows и веб-службу для поддержки операций сервера. В этом разделе описаны установленные по умолчанию учетные записи, используемые для работы служб, их первоначальные конфигурации, а также рассказано, как установить другую учетную запись или пароль. Дополнительные сведения о каждой службе см. в разделе Администрирование службы Windows и веб-службы сервера отчетов.

Установленные по умолчанию учетные записи и первоначальная конфигурация

Служба Windows сервера отчетов может выполняться под встроенной учетной записью или учетной записью пользователя домена. Учетная запись службы Windows всегда настраивается во время установки. Программа установки SQL Server предоставляет возможности выбора учетной записи пользователя домена либо встроенной учетной записи локальной системы при определении параметров на странице Учетная запись службы. Для продолжения установки необходимо выбрать один из следующих типов учетных записей.

Примечание.
Программа установки не предоставляет возможность указать все возможные варианты выбора учетных записей служб. Например, она не позволяет указать NetworkService. Если необходимо использовать учетную запись NetworkService, то по завершении работы программы установки можно использовать программу настройки служб Reporting Services для изменения свойств учетных записей служб.

Учетная запись веб-службы сервера отчетов всегда является удостоверением рабочего процесса ASP.NET. Сведения об учетной записи веб-службы могут быть установлены во время или после установки. Они могут быть установлены во время установки, если был выбран режим установки с конфигурацией по умолчанию. Либо они могут быть установлены после установки при определении виртуального каталога сервера отчетов в программе настройки служб Reporting Services. В любом случае первоначальные настройки веб-службы сервера отчетов всегда являются установленными по умолчанию значениями, определенными в ASP.NET и в версии служб Microsoft IIS, которые используются.

  • В IIS 6.0 на рабочий процесс ASP.NET выполняется под удостоверением безопасности содержащего его пула приложений. Может быть несколько рабочих процессов ASP.NET, каждый из которых содержит отдельный пул приложений, обладающий своим собственным удостоверением безопасности. По умолчанию удостоверением безопасности является NetworkService. NetworkService является удостоверением безопасности установленного по умолчанию пула приложений, который определяет настройки, наследуемые любым новым пулом приложений, который будет впоследствии создан. При настройке конфигурации сервера отчетов веб-служба сервера отчетов назначается выделенному для него пулу приложений, который создается при указании виртуального каталога сервера отчетов. Поскольку этот пул приложений наследует удостоверение безопасности установленного по умолчанию пула приложений, то используемой для запуска веб-службы сервера отчетов учетной записью обычно является NetworkService.

  • В службе IIS 5.0 в Windows 2000 Server или в службе IIS 5.01 в Windows XP существует одна учетная запись рабочего процесса ASP.NET для всех приложений ASP.NET, запущенных на данном компьютере. По умолчанию ASP.NET выполняется под своей собственной учетной записью ИмяКомпьютера\ASPNET. При использовании другой учетной записи необходимо настроить ASP.NET для выполнения под этой учетной записью. В программе настройки служб Reporting Services отсутствуют параметры для установки учетной записи ASP.NET. Необходимо изменить элемент <processModel> в файле Machine.config, если нужно использовать пользовательскую учетную запись для всех запущенных на сервере приложений ASP.NET.

Для просмотра сведений об учетных записях для обеих служб воспользуйтесь программой настройки служб Reporting Services. В программе имеется страница «Удостоверение веб-служб» и страница «Удостоверение служб Windows», на которых отображаются сведения об учетных записях служб.

Изменение учетных записей служб и паролей для интегрированного сервера отчетов SharePoint

При работе сервера отчетов в режиме интеграции с SharePoint и последующем изменении учетных записей, под которыми работает каждый сервер, необходимо обновлять сведения об учетных записях служб, которые хранятся в базе данных конфигураций SharePoint. Для этого запустите центральный веб-узел администрирования, а затем повторно выберите экземпляр сервера отчетов на странице Управление параметрами интеграции. Повторение шагов интеграции приведет к соответствующему обновлению сведений об учетной записи служб. Дополнительные сведения см. в разделе Как выполнить интеграцию сервера отчетов в центре администрирования SharePoint.

Изменение учетных записей и паролей службы

Можно изменять учетные записи служб, пароли или и то, и другое. Сведения о том, как указать учетную запись после того, как было уже определено, какую учетную запись использовать, см. в разделе Как Настройка учетных записей служб (конфигурация служб Reporting Services).

При выборе новой учетной записи для нее будут созданы имя входа и разрешения базы данных. А именно, эта учетная запись будет добавлена к роли RSExecRole. Из этой роли не удаляются учетные записи, добавленные в предыдущий период. Неиспользуемые учетные записи следует удалить. Дополнительные сведения см. в разделе Администрирование баз данных сервера отчетов.

Выбор другой учетной записи

Можно настроить веб-службу и службу Windows сервера отчетов для выполнения под другой учетной записью. Не существует единственно верного подхода к выбору типа учетной записи. Каждый тип учетной записи обладает преимуществами и недостатками, которые необходимо принимать во внимание. При развертывании служб Reporting Services на рабочем сервере рекомендуется настраивать учетные записи на выполнение под пользовательскими учетными записями, которые используются отдельной службой или приложением. Следующие правила и ссылки в этом разделе помогут выбрать наилучший подход при развертывании.

Службы | Ресурсы в Интернете
Служба Windows | Идентификация служб Windows (конфигурация служб Reporting Services) Настройка учетных записей служб Windows в электронной документации по SQL Server Руководство по планированию безопасности учетных записей и служб на узле MSDN
Веб-служба | Web Service Identity - Windows Server 2003 (Reporting Services Configuration)

Изменение пароля до истечения срока его действия

Чтобы сбросить пароль, воспользуйтесь программой настройки служб Reporting Services и выполните следующие инструкции: Как Настройка учетных записей служб (конфигурация служб Reporting Services).

Примечание.
Если срок действия пароля учетной записи службы для компонента Database Engine истек, то при попытке подключиться к серверу отчетов возникает ошибка rsReportServerDatabaseUnavailable. Эта ошибка устраняется с помощью сброса пароля. Полный текст этого сообщения об ошибке см. в разделе Устранение неполадок при соединении с сервером и базой данных.

Изменение пароля для службы Windows сервера отчетов

Если служба Windows сервера отчетов выполняется под учетной записью домена, то по истечении срока действия пароля служба будет недоступна до указания нового пароля. Чтобы сбросить пароль, откройте меню Пуск, последовательно укажите Панель управления, Администрирование и выберите пункт Службы. Щелкните правой кнопкой мыши Службы SQL Server Reporting Services, выберите пункт Свойства, нажмите кнопку Вход и введите новый пароль. После обновления пароля запустите программу настройки служб Reporting Services и обновите пароль на странице «Удостоверение службы Windows». Этот дополнительный шаг необходим для обновления сведений об учетной записи, которая хранится внутри сервера отчетов.

Зависимости от удостоверений служб Windows сервера отчетов

Изменение учетной записи службы Windows сервера отчетов может повлиять на операции, выполняемые сервером отчетов. По этой причине при изменении учетной записи службы важно всегда пользоваться программой настройки служб Reporting Services. Программа настройки служб Reporting Services выполняет следующие дополнительные шаги для сохранения доступности сервера отчетов:

  • Автоматически обновляет ключ шифрования, добавляя в него сведения о профиле новой учетной записи. Так как шифрование выполняется только службой Windows «Сервер отчетов», ключи должны быть обновлены только при перезагрузке службы Windows.

    Примечание.
    Если сервер отчетов является частью масштабного развертывания, то изменяется только обновляемый сервер отчетов. При изменении учетной записи сервера ключи шифрования для других серверов отчетов в развертывании не изменяются.

  • Автоматически обновляет разрешения на вход в ядро СУБД SQL Server, используемое для размещения базы данных сервера отчетов. При использовании учетных записей службы для подключения к базе данных службы Reporting Services предоставили разрешения имени входа SQL Server учетным записям службы, когда настраивались настройки подключения. При перезагрузке учетной записи службы Windows сведения о соединении должны быть обновлены.

  • Автоматически добавляет новые учетные записи к группе сервера отчетов, созданной на локальном компьютере. Эта группа указывается в списках управления доступом (Access Control List, ACL), защищающих файлы служб Reporting Services.

См. также

Задачи

Как Настройка учетных записей служб (конфигурация служб Reporting Services)
Как запустить настройку служб Reporting Services

Справочник

Web Service Identity - Windows Server 2003 (Reporting Services Configuration)
Идентификация служб Windows (конфигурация служб Reporting Services)
Настройка учетных записей служб Windows

Основные понятия

Изменение паролей и учетных записей пользователей
Настройка виртуальных каталогов сервера отчетов
Администрирование службы Windows и веб-службы сервера отчетов
Запуск и остановка службы Windows сервера отчетов

Другие ресурсы

Развертывание служб Reporting Services
Соединения и учетные записи при развертывании служб Reporting Services

Журнал изменений

Версия Журнал

12 декабря 2006 г.

Измененное содержимое:
  • Удостоверение безопасности NetworkService.

  • Изменение учетных записей и паролей служб.

14 апреля 2006 г.

Измененное содержимое:
  • Сведения об удостоверении безопасности Windows Server 2003.


Создание базы данных сервера отчетов

Создание базы данных сервера отчетов |
 | См. также
Настройка установки SQL Server > Настройка служб Reporting Services >

Дата обновления: 12 декабря 2006 г.

Службам Reporting Services необходимы две реляционные базы данных SQL Server для хранения метаданных и объектов сервера отчетов. Одна база данных используется как основное хранилище, а вторая — для хранения временных данных. Эти базы данных создаются одновременно и связываются по именам. По умолчанию эти базы данных имеют имена reportserver и reportservertempdb. В совокупности эти две базы данных называются «базой данных сервера отчетов» или «каталогом сервера отчетов». Хранение этих баз данных может выполнять SQL Server 2000 или SQL Server 2005.

Важно!
Выполнять запросы к базе данных сервера отчетов из приложений не рекомендуется, схема базы данных сервера отчетов не предназначена для общего доступа. Структура таблиц в разных версиях может различаться. При создании приложений, которым необходим доступ к базе данных сервера отчетов, всегда пользуйтесь интерфейсами прикладных программ (API-интерфейсами) служб Reporting Services.

Режимы сервера и базы данных сервера отчетов

При создании базы данных сервера отчетов необходимо заранее знать, будет ли сервер отчетов развертываться в собственном режиме или режиме интеграции с SharePoint. Содержимое базы данных сервера отчетов будет меняться в зависимости от используемого режима. Знание режима выполнения сервера отчетов определяет параметры при создании базы данных.

Поскольку по умолчанию используется собственный режим, при создании базы данных для него не нужно устанавливать никаких параметров. Однако при развертывании сервера отчетов в режиме интеграции с SharePoint integrated mode необходимо установить флажок Создать базу данных сервера отчетов в режиме интеграции с SharePoint.

В противном случае база данных сервера отчетов будет поддерживать только собственный режим. Дополнительные сведения см. в разделе Как создать базу данных сервера отчетов для режима интеграции с SharePoint (настройка служб Reporting Services).

Способы создания базы данных сервера отчетов

Создать базу данных сервера отчетов можно одним из следующих способов.

  • В автоматическом режиме с помощью программы установки. Для этого в мастере установки SQL Server на странице «Параметры установки сервера отчетов» выберите параметр Установить конфигурацию по умолчанию. Если выбран параметр Установить, но не настраивать, то для создания базы данных необходимо воспользоваться программой настройки служб Reporting Services.

  • Вручную с помощью программы настройки служб Reporting Services. Инструкции см. в разделе Как создать базу данных сервера отчетов (настройка служб Reporting Services).

Базу данных сервера отчетов можно создать на локальном или удаленном экземпляре компонента SQL Server Database Engine. Для создания базы данных сервера отчетов на удаленном компьютере необходимо настроить соединение через учетную запись пользователя домена или учетную запись службы с сетевым доступом. Если планируется использовать удаленный экземпляр SQL Server, то тщательно продумайте, с помощью каких учетных данных сервер отчетов будет подключаться к экземпляру SQL Server. Дополнительные сведения см. в разделе Настройка соединения с базой данных сервера отчетов.

Важно!
Сервер отчетов и экземпляр SQL Server, на котором хранится база данных сервера отчетов, могут находиться в разных доменах. При развертывании в Интернете сервер, как правило, защищают с помощью брандмауэра. При настройке доступа в Интернет на сервере отчетов для защиты соединения при соединении с экземпляром SQL Server, который защищен брандмауэром и IPSEC, следует использовать учетные данные SQL Server.

Создание баз данных сервера отчетов в различных выпусках SQL Server

При создании базы данных сервера отчетов убедитесь в том, что данный выпуск SQL Server 2005 может быть использован для ее хранения. В следующей таблице перечислены выпуски компонента Database Engine, которые пригодны для конкретных выпусков служб Reporting Services.

Для данного выпуска служб SQL Server 2005 Reporting Services | Используйте данный выпуск экземпляра компонента Database Engine для хранения базы данных
SQL Server 2005 Express Edition with Advanced Services | SQL Server 2005 Express Edition with Advanced Services (только локально).
Выпуск Workgroup Edition | Выпуск Workgroup Edition (только локально)
Выпуск Evaluation Edition | Выпуски Standard, Evaluation, Enterprise Edition (локально или удаленно)
Выпуск Developer Edition | Выпуски Standard, Developer, Enterprise Edition (локально или удаленно)
Выпуск Standard Edition | Выпуски Standard, Enterprise Edition (локально или удаленно)
Выпуск Enterprise Edition | Выпуски Standard, Enterprise Edition (локально или удаленно)

Создание баз данных сервера отчетов после обновления версии серверов

В ряде случаев при попытке создать базу данных сервера отчетов на экземпляре SQL Server после обновления версии 7.0 может возникнуть исключение. Дело в том, что при обновлении не устанавливается уровень совместимости для базы данных master. В результате в программе настройки служб Reporting Services при создании базы данных возникает исключение. Дополнительные сведения о создании базы данных на сервере после обновления версии см. в разделе Как настроить базы данных сервера отчетов в ядре СУБД после его обновления с версии SQL Server 7.0 (конфигурация служб Reporting Services).

См. также

Задачи

Как создать базу данных сервера отчетов (настройка служб Reporting Services)

Основные понятия

Режимы развертывания для служб Reporting Services
Настройка служб Reporting Services для интеграции с SharePoint 3.0
Администрирование баз данных сервера отчетов

Другие ресурсы

База данных сервера отчетов
Introducing Reporting Services Programming

Журнал изменений

Версия Журнал

12 декабря 2006 г.

Новое содержимое
  • Режимы сервера и базы данных сервера отчетов

14 апреля 2006 г.

Новое содержимое
  • Создание баз данных сервера отчетов в различных выпусках.


Настройка соединения с базой данных сервера отчетов

Настройка соединения с базой данных сервера отчетов |
 | См. также
Настройка установки SQL Server > Настройка служб Reporting Services >

Для функционирования каждого экземпляра сервера отчетов необходимо соединение с базой данных сервера отчетов, в которой хранятся отчеты, модели отчетов, общие источники данных, ресурсы, а также метаданные, управляемые сервером. Исходное соединение может быть создано во время установки сервера отчетов, если производится установка конфигурации по умолчанию. В большинстве случаев для настройки соединения можно также воспользоваться программой настройки служб Reporting Services после завершения установки. Такие параметры соединения, как тип учетной записи и учетные данные, можно изменять в любое время. Пошаговые инструкции по созданию базы данных и настройке соединения см. в разделе Как создать базу данных сервера отчетов (настройка служб Reporting Services).

Соединения с базой данных сервера отчетов необходимо настраивать в следующих случаях.

  • Первоначальная настройка сервера отчетов.

  • Настройка сервера отчетов на использование другой базы данных сервера отчетов.

  • Изменение учетной записи пользователя или пароля, используемых при соединении с базой данных. Подключение к базе данных необходимо обновлять только в том случае, если данные об учетных записях хранятся в файле RSReportServer.config. При использовании в подключении служебных учетных записей (они используют встроенную безопасность Windows) пароль не сохраняется, поэтому нет необходимости обновлять сведения о подключении. Дополнительные сведения об изменении учетных записей см. в разделе Настройка учетных записей и паролей служб в службах Reporting Services.

  • Настройка сервера отчетов с масштабным развертыванием. Настройка масштабного развертывания требует создания нескольких соединений с базой данных сервера отчетов. Дополнительные сведения о том, как выполнять эту операцию, см. в разделе Как настроить масштабное развертывание сервера отчетов (настройка служб Reporting Services).

Доступ сервера отчетов к базе данных сервера отчетов определяется учетными данными и сведениями о соединении, а также ключами шифрования, доступными серверу отчетов. Для хранения и получения конфиденциальных данных необходимо иметь допустимый ключ шифрования. Ключи шифрования создаются автоматически при первичной настройке базы данных. После создания их необходимо обновлять при изменении учетной записи веб-службы сервера отчетов. Дополнительные сведения о работе с ключами шифрования см. в разделе Управление ключами шифрования.

Определение подключения к базе данных сервера отчетов

Для настройки соединений необходимо пользоваться программой настройки служб Reporting Services или программой командной строки rsconfig. Для функционирования сервера отчетов требуются следующие сведения о подключении.

  • Имя экземпляра SQL Server, на котором содержится база данных сервера отчетов. Может быть указан экземпляр компонента SQL Server 2000 Database Engine или SQL Server 2005 Database Engine. В случае использования SQL Server 2005 Express with Advanced Services нужно выбрать локальный экземпляр компонента Database Engine.

  • Имя базы данных сервера отчетов. При создании нового подключения можно создать новую базу данных сервера отчетов либо задать уже существующую. Дополнительные сведения см. в разделе Создание базы данных сервера отчетов.

  • Тип учетных данных. Можно указать учетную запись службы, учетную запись домена Windows или имя входа базы данных SQL Server.

  • Имя пользователя и пароль (обязателен только для учетной записи домена Windows или имени входа SQL Server).

Заданные учетные данные должны иметь доступ к базе данных сервера отчетов. Если используется программа настройки служб Reporting Services, этот шаг выполняется автоматически. Дополнительные сведения о разрешениях, необходимых для доступа к базе данных, см. в разделе «Разрешения базы данных» данного подраздела.

Хранение сведений о подключении к базе данных

Службы Reporting Services хранят зашифрованную информацию о соединении в представленных ниже установках RSreportserver.config. Для создания зашифрованных значений указанных установок необходимо использовать программу настройки служб Reporting Services или программу rsconfig.

Не все из этих значений указываются для каждого из типов соединений. Если подключение настраивается при использовании значений по умолчанию (например, при использовании учетных записей служб), параметры <LogonUser>, <LogonDomain> и <LogonCred> будут пусты, например:

Копировать код
<Dsn></Dsn>
<ConnectionType></ConnectionType>
<LogonUser></LogonUser>
<LogonDomain></LogonDomain>
<LogonCred></LogonCred>

Если соединение настраивается на использование определенной учетной записи Windows или имени входа в базу данных, не забудьте обновить эти сохраненные значения при изменении учетной записи или имени входа.

Выбор типа учетных данных

В подключении к базе данных сервера отчетов используются следующие три типа учетных данных.

  • Встроенная безопасность Windows, использующая веб-службу сервера отчетов и служебные учетные записи Windows.

  • Учетная запись пользователя Windows. Если сервер отчетов и его база данных установлены на том же компьютере, можно пользоваться локальной учетной записью. В противном случае необходимо использовать учетную запись домена.

  • Имя входа SQL Server.

Примечание.
Запрещается проводить нестандартную проверку подлинности для подключения к базе данных сервера отчетов. Нестандартная проверка подлинности используется только для главного подключения к серверу отчетов. Указанная проверка не может быть применена при подключении к базе данных сервера отчетов и внешним источникам данных, содержащим данные для отчетов.
Использование служебных учетных записей и встроенной безопасности

Можно использовать встроенную безопасность Windows для подключения через веб-службу сервера отчетов и служебные учетные записи Windows. Обеим служебным учетным записям предоставляются права доступа к базе данных сервера отчетов. При установке служб Reporting Services в конфигурации по умолчанию выбирается указанный тип учетных данных.

Учетные записи служб обеспечивают высокую степень надежности и простоту управления подключением к базе данных сервера отчетов. При работе со учетными записями служб нет необходимости хранить учетные данные, так как они используют для подключения встроенную безопасность Windows. При последующем изменении пароля служебной учетной записи (например, при смене типа учетной записи со встроенной на доменную) для нее необходимо обновить права доступа к экземпляру SQL Server, на котором хранятся базы данных сервера отчетов. Эти шаги выполняются программой настройки служб Reporting Services. Дополнительные сведения см. в разделе Настройка учетных записей и паролей служб в службах Reporting Services.

При настройке подключения к базе данных с использованием служебных учетных записей, эти учетные записи должны обладать сетевыми разрешениями, если база данных сервера отчетов располагается на удаленном компьютере. Не используйте служебную учетную запись, если база данных сервера отчетов находится на другом домене, защищена брандмауэром, либо в случае применения безопасности рабочих групп, а не безопасности домена. Используйте вместо этого учетную запись пользователя базы данных SQL Server.

Использование учетной записи «Пользователь домена»

Можно указать, что для подключения к базе данных сервера отчетов необходимо использовать только одну учетную запись. Указанная учетная запись будет использоваться для подключения как веб-службой сервера отчетов, так и службой Windows. Если используется локальная учетная запись или учетная запись домена, соединение с базой данных необходимо обновлять всякий раз, когда изменяется пароль для нее. Всегда пользуйтесь для обновления соединения только программой настройки служб Reporting Services.

Использование имени входа SQL Server

Можно задать единое имя входа SQL Server для подключения к базе данных сервера отчетов. При использовании проверки подлинности SQL Server для доступа к базе данных на удаленном компьютере необходимо использовать IPSEC для обеспечения безопасности передачи данных между серверами. При использовании имени входа SQL Server указанная учетная запись будет использоваться для подключения как веб-службой сервера отчетов, так и службой Windows. При использовании имени входа базы данных необходимо обновлять соединение с базой данных каждый раз, когда меняется пароль или учетная запись.

Разрешения базы данных

Учетные записи, предоставляемые для подключения к базе данных сервера отчетов, выполняют следующие функции:

  • Роли public и RSExecRole для базы данных ReportServer.

  • Роль RSExecRole для баз данных master, msdb и ReportServerTempDB.

При использовании программы настройки служб Reporting Services для внесения изменений в подключение указанные разрешения предоставляются автоматически. При использовании программы rsconfig для задания другой учетной записи для подключения необходимо обновить имя входа SQL Server для указанной новой учетной записи. С помощью программы настройки служб Reporting Services можно создать файлы-сценарии, обновляющие имя входа SQL Server для сервера отчетов.

Проверка имени базы данных

Чтобы выяснить, какая база данных сервера отчетов используется конкретным экземпляром сервера отчетов, используйте программу настройки служб Reporting Services. Чтобы найти имя, необходимо подключиться к экземпляру сервера отчетов и открыть страницу установки базы данных.

Использование другой базы данных сервера отчетов или перемещение базы данных сервера отчетов

Чтобы настроить сервер отчетов на использование другой базы данных сервера отчетов, необходимо изменить сведения о подключении. Обычно переключение между базами данных происходит при развертывании рабочего сервера отчетов. Переключение с тестовой базы данных сервера отчета на рабочую базу данных обычно происходит при развертывании рабочего сервера. Также можно перемещать базу данных сервера отчета на другой компьютер. Дополнительные сведения см. в разделах Перемещение базы данных сервера отчетов на другой компьютер и Миграция служб Reporting Services.

Настройка нескольких серверов отчетов для использования общей базы данных сервера отчетов

Можно настроить несколько серверов отчетов на использование общей базы данных сервера отчетов. Обычно данная конфигурация развертывания используется моделью масштабного развертывания, внедряемой при запуске нескольких серверов отчетов в кластере. Данную конфигурацию также можно использовать для проверки установки и настроек нового экземпляра сервера отчетов и сравнения его с уже существующим экземпляром сервера отчетов, обладающего требуемыми настройками. Дополнительные сведения см. в разделе Настройка масштабного развертывания сервера отчетов.

См. также

Основные понятия

Создание базы данных сервера отчетов
Разделы руководства по настройке служб Reporting Services
Настройка учетных записей и паролей служб в службах Reporting Services

Другие ресурсы

Соединение с источником данных
Настройка компонентов служб Reporting Services
Файл конфигурации RSReportServer
Программа rsconfig


Настройка учетной записи для автоматической обработки отчетов

Настройка учетной записи для автоматической обработки отчетов |
 | См. также
Настройка установки SQL Server > Настройка служб Reporting Services >

Дата обновления: 12 декабря 2006 г.

Службы Reporting Services SQL Server 2005 предоставляют специальную учетную запись, используемую для автоматической обработки отчетов и для отправки запросов на соединение по сети. Эти учетные записи используются для:

  • Отправки запросов на соединение по сети для отчетов, которые используют проверку подлинности базы данных. Дополнительные сведения см. в разделе Указание учетных данных и сведений о соединении электронной документации по SQL Server.

  • Получения внешних файлов изображений, используемых в отчете. При необходимости использовать файл изображения, доступ к которому невозможно получить анонимно, можно настроить учетную запись для автоматической обработки отчетов и предоставить этой учетной записи разрешение на доступ к файлу. Дополнительные сведения об учетной записи для автоматического выполнения, предназначенной для получения изображений, см. в разделе Добавление изображения к отчету электронной документации по SQL Server.

  • Подключения к внешним источникам данных отчетов, которые требуют или не требуют проверки подлинности. Отчеты, для которых параметр Учетные данные не требуются задан на странице свойств источника данных, не используют учетные данные для доступа к внешнему источнику данных.

Автоматическая обработка отчетов обозначает любой процесс выполнения отчета, запущенный событием (по расписанию или при обновлении данных), а не по команде пользователя. Сервер отчетов использует эту учетную запись для входа на компьютер, на котором находится внешний источник данных. Необходимость в такой учетной записи возникает по причине того, что учетная запись службы Windows сервера отчетов или веб-службы не применяется для подключения к другим компьютерам.

Важно!
Настройка этой учетной записи необязательна. Однако, если не настроить ее, возможности подключения к некоторым источникам данных будут ограничены, и может оказаться невозможным получение файлов изображений с удаленных компьютеров. Настроив учетную запись, необходимо поддерживать ее актуальность. В частности, если допустить истечение срока действия пароля или если данные учетной записи изменяются в службах каталогов Active Directory, при следующей попытке обработать отчет произойдет следующая ошибка: «Не удалось войти в систему (rsLogonFailed) Ошибка входа в систему: неизвестное имя пользователя или неправильный пароль». Правильное обслуживание учетной записи автоматической обработки отчетов очень важно, даже при отсутствии необходимости получения внешних изображений или отправки запросов на подключение к внешним компьютерам. Если учетная запись была настроена, но впоследствии выяснилось, что она не используется, ее можно удалить, чтобы избежать необходимости выполнения задач по обслуживанию учетной записи.

Чтобы настроить учетную запись или обновить ее данные, запустите программу настройки служб Reporting Services или выполните команду rsconfig -e для установки значений следующих параметров в файле RSreportserver.config в локальном или удаленном экземпляре сервера отчетов:

Копировать код
<UnattendedExecutionAccount>
     <UserName></UserName>
     <Password></Password>
     <Domain></Domain>
</UnattendedExecutionAccount>

Введенные значения будут зашифрованы, и после сохранения их невозможно будет расшифровать и просмотреть в виде обычного текста. Если вы ошиблись при вводе или забыли введенные значения, снова запустите программу настройки служб Reporting Services или выполните команду rsconfig -e.

Настройка учетной записи

Эта учетная запись должна быть учетной записью домена. Чтобы соответствовать своему предназначению, эта учетная запись должна отличаться от той, которая используется для работы службы Windows или веб-службы сервера отчетов. Эта учетная запись должна обладать минимальными разрешениями (достаточно доступа только на чтение) и ограничена доступом только к тем компьютерам, которые поставляют источники данных и ресурсы для сервера отчетов.

Для создания учетной записи можно воспользоваться программой настройки служб Reporting Services или программой rsconfig. Самый простой способ настроить учетную запись для автоматического выполнения — запустить программу настройки служб Reporting Services и указать учетные данные на странице «Учетная запись выполнения». Дополнительные сведения см. в разделе Как запустить настройку служб Reporting Services.

Настройка учетной записи автоматической обработки отчетов

  1. Запустите программу настройки служб Reporting Services и подключитесь к экземпляру сервера отчетов, который необходимо настроить.

  2. На странице «Учетная запись выполнения» выберите Указать учетную запись выполнения.

  3. Введите учетное имя и пароль, еще раз пароль, а затем нажмите Применить.

Обслуживание учетной записи автоматической обработки отчетов

Определив учетную запись, убедитесь, что обеспечена актуальность учетной записи и пароля. Можно использовать программу настройки служб Reporting Services для обновления настроек конфигурации, в которых хранятся сведения об этой учетной записи.

  1. Запустите программу настройки служб Reporting Services и подключитесь к экземпляру сервера отчетов, который необходимо настроить.

  2. На странице «Учетная запись выполнения» убедитесь в том, что параметр Указать учетную запись выполнения выбран.

  3. Введите новую учетную запись или пароль, еще раз введите пароль, а затем нажмите кнопку Применить.

Удаление учетной записи автоматической обработки отчетов

Если учетная запись не используется, ее можно удалить, чтобы избежать необходимости выполнения задач по обслуживанию учетной записи.

  1. Запустите программу настройки служб Reporting Services и подключитесь к экземпляру сервера отчетов, который необходимо настроить.

  2. На странице «Учетная запись выполнения» очистите параметр Указать учетную запись выполнения.

  3. Нажмите кнопку Применить.

Данные учетной записи удаляются из файла RSReportServer.config.

Использование программы RSConfig для настройки и обслуживания учетной записи автоматической обработки отчетов

Кроме того, можно использовать программу rsconfig. Для задания учетной записи укажите аргумент -e для программы rsconfig. Аргумент -e заставляет программу rsconfig сохранять сведения об учетной записи в файле конфигурации. Путь к файлу RSreportserver.config указывать не нужно. Для настройки учетной записи выполните следующие действия:

  1. Создайте или выберите учетную запись домена, имеющую доступ к компьютерам и серверам, поставляющим данные или службы серверу отчетов. Следует использовать учетную запись с ограниченными разрешениями (например, только для чтения).

  2. Откройте командную строку: В меню Пуск выберите пункт Выполнить, введите cmd и нажмите кнопку ОК.

  3. Введите следующую команду для настройки учетной записи в локальном экземпляре сервера отчетов:

    rsconfig -e -u< домен / имя_пользователя > -p< пароль >

Программа rsconfig -e поддерживает дополнительные аргументы. Дополнительные сведения о синтаксисе и примеры команд см. в разделе Программа rsconfig электронной документации по SQL Server.

Журнал изменений

Версия Журнал

12 декабря 2006 г.

Новое содержимое:
  • Сведения о важных ограничениях, связанных с учетной записью для автоматической обработки отчетов.

Измененное содержимое:
  • Инструкции по настройке учетной записи.

См. также

Другие ресурсы

Соединения и учетные записи при развертывании служб Reporting Services
Настройка компонентов служб Reporting Services
Страница «Свойства источников данных» (диспетчер отчетов)
Файл конфигурации RSReportServer
Программа rsconfig
Указание учетных данных и сведений о соединении


Настройка сервера отчетов для работы с электронной почтой

Настройка сервера отчетов для работы с электронной почтой |
 | См. также
Настройка установки SQL Server > Настройка служб Reporting Services >

Дата обновления: 12 декабря 2006 г.

Службы SQL Server 2005 Reporting Services включают модуль доставки по электронной почте, с помощью которого можно рассылать отчеты.

Модуль доставки электронной почты сервера отчетов не настроен по умолчанию. Для минимальной настройки модуля необходимо воспользоваться программой настройки служб Reporting Services. Чтобы указать дополнительные настройки, необходимо изменить файл конфигурации RSReportServer.config. Если нельзя настроить сервер отчетов на использование этого модуля, то вместо этого можно доставлять отчеты в общую папку. Дополнительные сведения см. в разделе Доставка в общую папку с помощью служб Reporting Services.

Требования к конфигурации

  • Рассылка сервера отчетов реализована на основе объектов данных совместной работы (CDO) и требует наличия локального или удаленного сервера или SMTP-перенаправителя (простого протокола пересылки электронной почты).

  • Учетная запись службы Windows сервера отчетов должна обладать разрешениями на отправку почты через SMTP-сервер.

  • Модуль доставки по электронной почте сервера отчетов использует в приложениях электронной почты кодировку UTF-8. Она не может быть изменена: модуль подготовки HTML поддерживает только UTF-8.

Примечание.
Модуль доставки по электронной почте по умолчанию не поддерживает цифровые подписи или шифрование в исходящих сообщениях почты.

Настройка сервера отчетов для работы с локальной или удаленной службой SMTP

Для поддержки рассылки по электронной почте можно использовать локальную службу SMTP, удаленный сервер или SMTP-перенаправитель. Если есть доступ к существующему удаленному SMTP-серверу, следует рассмотреть возможность его использования. Если SMTP-сервер недоступен или впоследствии возникают ошибки при доставке отчетов, которые можно объяснить сбоями подключения к компьютеру, следует перейти к использованию локальной службы SMTP. Более подробные сведения о настройке сервера отчета для работы с локальной или удаленной службой приводятся ниже в этом разделе.

Установка параметров конфигурации для работы с электронной почтой

Прежде чем будет можно использовать рассылку сервера отчетов по электронной почте, следует установить значения конфигурации, указывающие, какой SMTP-сервер использовать.

Для настройки сервера отчетов для доставки электронной почты выполните следующие действия:

  • Воспользуйтесь программой настройки служб Reporting Services, если вы задаете сервер SMTP и учетную запись, имеющую разрешение на отправку электронных сообщений. Это минимальные установки, необходимые для настройки модуля доставки электронной почты сервера отчетов.

  • (Не обязательно). При помощи текстового редактора задайте дополнительные установки в файлах RSreportserver.config и RSwebapplication.config. Эти два файла конфигурации содержат все установки конфигурации для доставки сообщений электронной почты сервера отчетов. Задание дополнительных установок в этих файлах необходимо, если используется локальный SMTP-сервер или если доставка сообщений электронной почты ограничивается определенными узлами. Дополнительные сведения о местоположении и изменении файлов конфигурации см. в разделе Файлы конфигурации служб Reporting Services электронной документации по SQL Server.

В следующей таблице описаны установки, относящиеся к доставке сообщений электронной почты в каждом из файлов:

Файл | Описание
RSwebapplication.config | Указывается модуль доставки по умолчанию для всех подписок, создаваемых и управляемых с помощью диспетчера отчетов. Параметр DefaultDeliveryExtension в файле RSwebapplication.config указывает, что модуль доставки по умолчанию — электронная почта сервера отчетов.
RSreportserver.config | В файле RSreportserver.config содержатся все параметры, относящиеся к службе SMTP.
Примечание.
Параметры электронной почты сервера отчетов основаны на объектах CDO. Если необходимы дальнейшие подробности о конкретных параметрах, можно обратиться к документации по приложениям CDO.

Образец конфигурации электронной почты сервера отчетов

В следующем примере иллюстрируются параметры файла RSreportserver.config для удаленного SMTP-сервера. Описания параметров и их допустимых значений см. в разделе Файл конфигурации RSReportServer или документации по приложениям CDO.

Копировать код
<RSEmailDPConfiguration>
     <SMTPServer>mySMTPServer.Adventure-Works.com</SMTPServer>
     <SMTPServerPort></SMTPServerPort>
     <SMTPAccountName></SMTPAccountName>
     <SMTPConnectionTimeout></SMTPConnectionTimeout>
     <SMTPServerPickupDirectory></SMTPServerPickupDirectory>
     <SMTPUseSSL></SMTPUseSSL>
     <SendUsing>2</SendUsing>
     <SMTPAuthenticate></SMTPAuthenticate>
     <From>my-rs-email-account@Adventure-Works.com</From>
     <EmbeddedRenderFormats>
          <RenderingExtension>MHTML</RenderingExtension>
     </EmbeddedRenderFormats>
     <PrivilegedUserRenderFormats></PrivilegedUserRenderFormats>
     <ExcludedRenderFormats>
          <RenderingExtension>HTMLOWC</RenderingExtension>
          <RenderingExtension>NULL</RenderingExtension>
     </ExcludedRenderFormats>
     <SendEmailToUserAlias>True</SendEmailToUserAlias>
     <DefaultHostName></DefaultHostName>
     <PermittedHosts>
          <HostName>Adventure-Works.com</HostName>
          <HostName>hotmail.com</HostName>
     </PermittedHosts>
</RSEmailDPConfiguration>

Параметры конфигурации для поля сообщения

Определяемые пользователем подписки, которые создаются в соответствии с разрешениями, предоставленными задачей Управление отдельными подписками, содержат предварительно заданное имя пользователя, которое основано на учетной записи пользователя домена. При создании подписки пользователем имя получателя в поле Кому: будет указывать на самого отправителя с использованием учетной записи пользователя домена, создавшего подписку.

Если использовать SMTP-сервер или перенаправитель, который использует учетные записи электронной почты, отличающиеся от учетной записи пользователя домена, то во время доставки отчета произойдет ошибка, когда SMTP-сервер попытается доставить отчет этому пользователю.

Чтобы обойти эту проблему, можно изменить настройки конфигурации, которые позволяют вводить пользователям имена в поле Кому: .

  1. Откройте файл RSReportServer.config в текстовом редакторе.

  2. Присвойте параметру SendEmailToUserAlias значение False.

  3. Установите параметр DefaultHostName равным DNS-имени или IP-адресу SMTP-сервера или перенаправителя.

  4. Сохраните файл.

Параметры конфигурации для удаленной службы SMTP

Соединение между сервером отчетов и локальным SMTP-сервером или перенаправителем определяется следующими параметрами конфигурации:

  • Параметр SendUsing указывает метод отправки сообщений. Возможен выбор между сетевой службой SMTP или локальным каталогом сбора службы SMTP. Чтобы использовать удаленную службу SMTP, этому параметру в файле RSReportServer.config должно быть присвоено значение 2.

  • Параметр SMTPServer указывает удаленный сервер или перенаправитель SMTP. Это значение обязательное, если нужно использовать удаленный сервер или SMTP-перенаправитель.

  • Параметр From задает значение, отображаемое в строке От: сообщения электронной почты. Это значение обязательное, если нужно использовать удаленный сервер или перенаправитель SMTP.

Другие значения, которые используются для удаленной службы SMTP, включают следующее (обратите внимание, что указывать их необязательно, если не нужно заменять ими значения по умолчанию).

  • Параметр SMTPServerPort настроен для использования порта 25.

  • Параметр SMTPAuthenticate указывает, как сервер отчетов подключается к удаленному SMTP-серверу. Значение по умолчанию равно 0 (отсутствие проверки подлинности). В этом случае соединение осуществляется через анонимный доступ. Может потребоваться, чтобы сервер отчетов и SMTP-сервер были элементами одного домена (в зависимости от конфигурации домена).

    Для отправки электронной почты в списки рассылки с ограничениями (например, в списки рассылки, принимающие входящие сообщения только от учетных записей, прошедших проверку подлинности) установите значение SMTPAuthenticate равным 2.

Параметры конфигурации для локальной службы SMTP

Настройка локальной службы SMTP полезна при тестировании или диагностике работы с электронной почтой сервера отчетов. Локальная служба SMTP по умолчанию отключена. Дополнительные сведения о том, как включить ее, см. в разделе Как настроить сервер отчетов для работы с электронной почтой (конфигурация служб Reporting Services).

Соединение между сервером отчетов и локальным сервером или перенаправителем SMTP определяется следующими параметрами конфигурации:

  • Значение SendUsing равно 1.

  • В качестве значения SMTPServerPickupDirectory указана папка на локальном жестком диске.

    Примечание.
    Убедитесь, что не присвоили значения параметру SMTPServer, если пользуетесь локальным SMTP-сервером.

  • Параметр From задает значение, отображаемое в строке От: сообщения электронной почты. Это значение обязательно.

Журнал изменений

Версия Журнал

12 декабря 2006 г.

Измененное содержимое:
  • Параметры конфигурации для локальной службы SMTP.

17 июля 2006 г.

Новое содержимое:
  • Требования к конфигурации.

  • Параметры конфигурации для поля сообщения.

См. также

Задачи

Как запустить настройку служб Reporting Services
Как настроить сервер отчетов для работы с электронной почтой (конфигурация служб Reporting Services)

Другие ресурсы

Доставка отчетов через подписки
Доставка электронной почтой в службах Reporting Services
Файлы конфигурации служб Reporting Services


Администрирование баз данных сервера отчетов

Администрирование баз данных сервера отчетов |
 | См. также
Настройка установки SQL Server > Настройка служб Reporting Services >

Дата обновления: 12 декабря 2006 г.

Развертывание служб Reporting Services использует для внутреннего хранения две реляционные базы данных SQL Server. По умолчанию имена баз данных — ReportServer и ReportServerTempdb соответственно. ReportServerTempdb создается с основной базой данных сервера отчетов и используется для хранения временных данных, сведений о сеансе и кэшированных отчетах.

В службы Reporting Services включены такие задачи администрирования, как резервирование и восстановление из копии баз данных сервера отчетов и управление ключами шифрования, использующимися для шифрования и расшифровки конфиденциальных данных.

В SQL Server встроены различные средства для администрирования баз данных сервера отчетов.

  • Для создания резервных копий, перемещения и восстановления баз данных сервера отчетов используйте среду SQL Server Management Studio, команды Transact-SQL или средства командной строки для работы с базой данных. Инструкции см. в разделе Перемещение базы данных сервера отчетов на другой компьютер электронной документации по SQL Server.

  • Чтобы скопировать содержимое существующей базы данных в другую базу данных сервера отчетов, можно присоединить копию базы данных сервера отчетов и использовать ее с другим экземпляром сервера отчетов. Либо можно создать и выполнить сценарий, использующий вызовы SOAP для повторного создания содержимого сервера отчетов в новой базе данных. Используйте служебную программу rs для выполнения сценария.

  • Для управления соединениями между сервером отчетов и его базой данных и проверки, к верной ли базе данных обращается экземпляр сервера отчетов, можно воспользоваться страницей «Установка базы данных» программы настройки служб Reporting Services. Дополнительные сведения о подключении сервера отчетов к базе данных сервера отчетов см. в разделе Настройка соединения с базой данных сервера отчетов.

  • О сборе показателей текущей производительности сервера отчетов см. в разделе Запросы и отчеты по данным журнала выполнения отчета электронной документации по SQL Server.

Разрешения на вход в систему и доступ к базам данных SQL Server

Базы данных сервера отчетов используются сервером отчетов для внутренних целей. Соединения с любой из баз данных создаются веб-службой сервера отчетов и службой Windows сервера отчетов.

Чтобы задать параметры соединения, можно воспользоваться программой настройки служб Reporting Services. Можно использовать либо учетные данные служб, либо учетные данные пользователя домена, либо имя входа SQL Server. Учетная запись, выбранная для соединения, должна иметь имя входа SQL Server и роли Public и RSExecRole для баз данных сервера отчетов.

Имя входа и разрешения создаются автоматически при использовании программы настройки служб Reporting Services для настройки подключения к базе данных, обновления базы данных сервера отчетов или выполнения эквивалентных сценариев в экземпляре SQL Server, где расположена база данных.

Роль RSExecRole предоставляет разрешения для доступа к таблицам баз данных и выполнения хранимых процедур. Роль RSExecRole создается в базах данных master и msdb при создании базы данных сервера отчетов. Начиная с версии SQL Server 2005 с пакетом обновления 1 (SP1), роль RSExecRole является членом роли db_owner для баз данных сервера отчетов. Эти дополнительные разрешения дают серверу отчетов возможность дополнять схему в последующих версиях, что упростит процесс обновления.

Удаление неиспользуемых учетных записей из роли RSExecRole

Если веб-служба сервера отчетов или служба Windows настроена для запуска с другой учетной записью, новая учетная запись автоматически добавляется к роли RSExecRole. Однако все ранее добавленные и неиспользуемые учатные записи необходимо удалить вручную. Для удаления этих учетных записей выполните следующие действия в среде Management Studio.

  1. Соединитесь с экземпляром Database Engine, на котором размещается база данных сервера отчетов.

  2. Разверните Базы данных, затем ReportServer, Безопасность, Роли, Роли базы данных и дважды щелкните роль RSExecRole.

  3. Выберите учетную запись, которая больше не используется.

  4. Щелкните Удалить.

Соглашения об именах для баз данных сервера отчетов

Имя базы данных-источника должно соответствовать правилам, определенным для Идентификаторы. Имя временной базы данных всегда аналогично имени основной базы данных сервера, но с суффиксом Tempdb. Невозможно выбрать другое имя для временной базы данных.

Переименование базы данных сервера отчетов не поддерживается, так как базы данных сервера отчетов рассматриваются как внутренние компоненты. Переименование баз данных сервера отчетов может вызвать ошибки. А именно: при переименовании базы данных-источника сообщение об ошибке говорит о том, что имена баз данных не синхронизированы. После переименования базы данных ReportServerTempdb может возникнуть следующая внутренняя ошибка при запуске отчетов:

«Произошла внутренняя ошибка на сервере отчетов. Дополнительные подробности см. в журнале ошибок. (rsInternalError)

Недопустимое имя объекта "ReportServerTempDB.dbo.PersistedStream"».

Причина этой ошибки заключается в том, что имя ReportServerTempdb хранится внутренне и используется хранимыми процедурами для выполнения внутренних операций. Переименование временной базы данных приведет к неправильной работе хранимых процедур.

О версиях базы данных

Службы Reporting Services не предоставляют точные сведения о версии базы данных. Но так как версия базы данных всегда синхронизирована с версией продукта, для определения факта смены версии базы данных можно пользоваться сведениями о версии продукта. Эти сведения доступны в файлах журналов, заголовках всех запросов SOAP, а также в URL-адресах сервера отчетов (например, при открытии в обозревателе адреса http://localhost/reportserver).

См. также

Основные понятия

Создание базы данных сервера отчетов
Управление ключами шифрования

Другие ресурсы

Операции резервного копирования и восстановления для служб Reporting Services
База данных сервера отчетов
Развертывание служб Reporting Services
Управление службами Reporting Services
Требования к базе данных сервера отчетов
Хранение зашифрованных данных сервера отчетов

Журнал изменений

Версия Журнал

12 декабря 2006 г.

Новое содержимое
  • Удаление неиспользуемых учетных записей из роли RSExecRole

14 апреля 2006 г.

Новое содержимое
  • Соглашения об именах и сведения о версиях для баз данных сервера отчетов


Администрирование службы Windows и веб-службы сервера отчетов

Администрирование службы Windows и веб-службы сервера отчетов |
 | См. также
Настройка установки SQL Server > Настройка служб Reporting Services >

Сервер отчетов состоит из службы Windows и веб-службы.Эти службы взаимодействуют друг с другом и поддерживают различные функциональные возможности сервера отчетов:

  • Служба Windows сервера отчетов осуществляет инициализацию, двустороннее шифрование, задачи обслуживания базы данных и все операции планирования и доставки. Служба выполняется в фоновом режиме. Она производит полную обработку отчетов, запускаемых по расписанию (в частности, создает моментальные снимки отчетов и запускает отчеты подписок).

    Поскольку служба Windows сервера отчетов отвечает за все операции шифрования, она обязательно должна быть запущена, если передаются или используются зашифрованные значения.Служба Windows сервера отчетов обязательна для выполнения таких операций, как задание сохраненных учетных данных, запуск отчета, который ими пользуется, публикация отчета на сервере отчетов (сведения об источнике данных шифруются).

  • Веб-служба сервера отчетов выполняет полную обработку отчетов, запускаемых по требованию.Кроме того, она предоставляет основные интерфейсы программирования для приложений, которые работают с сервером отчетов.К приложениям, которым требуется веб-служба сервера отчетов, относятся диспетчер отчетов, построитель отчетов и среда SQL Server Management Studio.

В большинстве случаев для обеспечения всех функциональных возможностей служб Reporting Services все службы работают одновременно.Однако, если это допустимо с точки зрения модели развертывания, может быть запущена только служба Windows сервера отчетов — например, если все операции по обработке отчетов выполняются по расписанию. Подобным же образом можно ограничиться запуском веб-службы сервера отчетов, если необходимо только интерактивное получение отчетов по требованию.

Чтобы сделать любую из служб недоступной, запустите средство настройки контактной зоны SQL Server и выберите параметр Настройка контактной зоны для функциональных возможностей. Нельзя полностью отключить службу Windows сервера отчетов; она обеспечивает функциональные возможности инициализации и шифрования, необходимые для операций сервера. Однако можно отключить обработку по расписанию и обработку событий.

Регистрация и настройка службы Windows сервера отчетов производится во время установки. Эта служба выполняется под любой указанной пользователем учетной записью. Рекомендуется использовать учетную запись пользователя домена с наименьшим набором прав, имеющую разрешение на вход в сеть или учетную запись NetworkService, однако можно использовать локальную учетную запись, если база данных сервера отчетов располагается на том же компьютере, что и сервер отчетов. Веб-служба сервера отчетов выполняется по умолчанию под удостоверением ASP.NET. При изменении настроек учетной записи службы обязательно используйте программу настройки служб Reporting Services, чтобы обновить зависимые параметры в соответствии с новыми значениями. Дополнительные сведения об настройке учетной записи см. в разделах Соединения и учетные записи при развертывании служб Reporting Services и Настройка учетных записей и паролей служб в службах Reporting Services.

Требования к службе агента SQL Server

Службе Windows сервера отчетов требуется для работы служба агента SQL Server.Она должна быть запущена под учетной записью домена, если сервер отчетов подключается к SQL Server при использовании учетной записи домена и проверки подлинности Windows (а не имени входа SQL Server или учетной записи службы).Задания службы агента SQL Server, созданные сервером отчетов, который запускается под учетной записью пользователя домена, принадлежат этой учетной записи.Для передачи задачи обработчику планирования и доставки службе агента SQL Server необходимы разрешения на доступ к данным заданий, которые принадлежат учетной записи домена.Если запустить службу агента SQL Server под локальной учетной записью пользователя, она не будет иметь разрешений на доступ к сведениям об учетной записи домена, поэтому подписка и доставка отчета не будут выполнены.

См. также

Задачи

Как Настройка учетных записей служб (конфигурация служб Reporting Services)
Как запустить настройку служб Reporting Services

Основные понятия

Настройка учетных записей и паролей служб в службах Reporting Services
Запуск и остановка службы Windows сервера отчетов
Инициализация сервера отчетов
Управление ключами шифрования

Другие ресурсы

Обработчик планирования и доставки
Указание учетных данных и сведений о соединении
Развертывание служб Reporting Services
Управление службами Reporting Services
Настройка агента SQL Server
Об агенте SQL Server
Агент SQL Server


Запуск и остановка службы Windows сервера отчетов

Запуск и остановка службы Windows сервера отчетов |
 | См. также
Настройка установки SQL Server > Настройка служб Reporting Services >

Для прекращения множества операций, выполняемых сервером отчетов, можно остановить службу Windows сервера отчетов. Последствия остановки службы Windows сервера отчетов таковы.

  • Останавливается обработка всех отчетов, запускаемых по расписанию (подписки, обновления моментальных снимков отчетов, истечение срока хранения в кэше).

  • Приостанавливается выполнение операций шифрования и дешифрования. В число этих операций входит инициализация серверов и доступ к зашифрованным учетным данным и строкам соединения.

  • Прекращается доступ к конечной точке удаленных вызовов процедур (RPC), используемой программой настройки служб Reporting Services, программой rskeymgmt и поставщиком сервера отчетов инструментария управления Windows (WMI).

  • Останавливаются операции обслуживания и очистки базы данных сервера отчетов.

Остановка службы Windows сервера отчетов не влияет на работу веб-службы сервера отчетов. Веб-доступ к серверу отчетов и конечной точке SOAP остается возможным после остановки службы Windows. Если нужно остановить веб-службу, для остановки веб-узла, на котором расположен сервер отчетов, можно использовать диспетчер служб IIS.

Для запуска или остановки службы Windows сервера отчетов можно применять самые разные средства: программу настройки служб Reporting Services, диспетчер конфигурации SQL Server, средство настройки контактной зоны SQL Server или оснастку «Службы» из Microsoft Windows.

Для выполнения каких-либо других операций, кроме запуска и остановки службы, например для смены учетной записи службы, необходимо пользоваться программой настройки служб Reporting Services. Использование для смены учетной записи службы других средств может привести к неработоспособности установки служб Reporting Services. Дополнительные сведения см. в разделе Настройка учетных записей и паролей служб в службах Reporting Services.

Эту службу нельзя приостанавливать и возобновлять, и параметров запуска она не имеет. Хотя явные зависимости отсутствуют, для поддержки отложенных операций на сервере должен быть запущен агент SQL Server.

Использование программы настройки служб Reporting Services

  • Чтобы остановить или запустить службу, запустите программу настройки служб Reporting Services и подключитесь к серверу отчетов. На странице состояния сервера отчетов нажмите Остановить или Запустить.

Использование элемента «Службы» в разделе «Администрирование»

  • Чтобы остановить или запустить службу, откройте раздел «Администрирование», откройте элемент «Службы», щелкните правой кнопкой мыши Службы Reporting Services SQL Server (MSSQLSERVER) и выберите команду Остановить или Перезапустить. Если используется несколько экземпляров параллельно или сервер отчетов работает в качестве именованного экземпляра, убедитесь в том, что имя экземпляра в круглых скобках соответствует экземпляру сервера отчетов, который планируется остановить или перезапустить.

Использование диспетчера конфигурации SQL Server

  • Для остановки или запуска службы запустите диспетчер конфигурации SQL Server, выберите службы SQL Server 2005, щелкните правой кнопкой мыши Сервер отчетов и выберите Остановить или Перезапустить.

Использование средства настройки контактной зоны SQL Server

Средство настройки контактной зоны SQL Server обеспечивает функцию запуска и остановки службы, с помощью которой можно остановить службу, прежде чем сделать ее недоступной для установки служб Reporting Services.

Кроме того, это средство применяется для отключения некоторых функций: обработчика планирования и доставки и запросов веб-службы. Включение и отключение функций влияет на параметры настройки в файле RSReportServer.config. В частности, если выбрать параметр IsWindowsServiceEnabled, то в файле RSReportServer.config следующим параметрам будет присвоено значение true: IsSchedulingService, IsNotificationService, IsEventService. Параметр IsWindowsServiceEnabled в средстве настройки контактной зоны SQL Server является объединением всех трех параметров настройки. Редактирование этих значений в файле конфигурации вручную может изменить установки, произведенные в программе.

  • Для остановки или запуска службы запустите средство настройки контактной зоны SQL Server, нажмите Настройка контактной зоны для служб и соединений, разверните службы Reporting Services и нажмите кнопку Остановить или Запустить.

О веб-службе сервера отчетов

Запуск, пауза, возобновление и остановка службы обычно не относятся к функциям управления веб-службой. ASP.NET запускает и останавливает веб-службу в процессе управления службой. В большинстве случаев запускать или останавливать веб-службу самостоятельно не требуется. Если нужно перезапустить веб-службу сервера отчетов, необходимо перезагрузить службы Microsoft IIS. При использовании IIS 6.0 можно остановить и перезапустить пул приложений.

Чтобы проверить, работает ли веб-служба, можно ввести в адресной строке обозревателя следующий URL-адрес: http://localhost/reportserver.

См. также

Основные понятия

Запуск и остановка службы Windows сервера отчетов
Администрирование службы Windows и веб-службы сервера отчетов

Другие ресурсы

Обработчик планирования и доставки
Развертывание служб Reporting Services


Управление ключами шифрования

Управление ключами шифрования |
 | См. также
Настройка установки SQL Server > Настройка служб Reporting Services >

Службы Reporting Services используют ключи шифрования для защиты учетных данных и сведений о соединении, которые сохраняются в базе данных сервера отчетов. В службах Reporting Services к ключам шифрования относится сочетание открытого, закрытого и симметричного ключей, которые используются для защиты конфиденциальных данных. Симметричный ключ создается при инициализации сервера отчетов в момент его установки или настройки, и используется для шифрования конфиденциальных данных, хранящихся на сервере отчетов. Открытые и закрытые ключи создаются операционной системой, и используются для защиты симметричного ключа. Пара из открытого и закрытого ключей создается для каждого экземпляра, который сохраняет конфиденциальные данные в базе данных сервера отчетов.

Управление ключами шифрования заключается в создании резервной копии и знании порядка восстановления, удаления и смены ключей. При миграции установки сервера отчетов или настройки масштабного развертывания необходимо иметь резервную копию симметричного ключа, чтобы можно было применить ее к новой установке.

Для управления симметричными ключами используется программа настройки служб Reporting Services или программа rskeymgmt. Средства, включенные в службы Reporting Services, предназначены только для управления симметричным ключом (управление закрытым и открытым ключами производит операционная система). Как программа настройки служб Reporting Services, так и программа rskeymgmt поддерживают выполнение следующих задач:

  • Резервное копирование копии симметричного ключа для использования при восстановлении файлов установки сервера отчетов или в ходе запланированного переноса.

  • Восстановление сохраненного симметричного ключа в базе данных сервера отчетов, чтобы позволить новому экземпляру сервера отчетов обращаться к существующим данным, шифрование которых выполнил не он.

  • Удаление зашифрованных данных из базы данных сервера отчетов в маловероятной ситуации, когда не удается обратиться к зашифрованным данным.

  • Повторное создание симметричных ключей и повторное шифрование данных в маловероятной ситуации, когда симметричный ключ становится известен посторонним. Для повышения безопасности следует периодически повторно создавать симметричный ключ (например, раз в несколько месяцев) для защиты базы данных сервера отчетов от электронных атак с целью расшифровки ключа.

  • Добавление или удаление экземпляра сервера отчетов из масштабного развертывания, когда несколько серверов отчетов используют одну базу данных сервера отчетов и симметричный ключ, допускающий двустороннее шифрование для этой базы данных.

В этом разделе

Подраздел | Описание
Инициализация сервера отчетов | Объясняет, как создавать ключи шифрования.
Создание резервных копий и восстановление ключей шифрования | Объясняет, как проводить резервное копирование ключей шифрования и восстанавливать их при восстановлении или перемещении файлов установки сервера отчетов.
Удаление и повторное создание ключей шифрования | Объясняет, как заменить симметричный ключ новой версией, а также как начать сначала, если симметричные ключи невозможно проверить.
Добавление и удаление ключей шифрования для масштабного развертывания | Объясняет, как добавить или удалить ключи шифрования для управления списком серверов отчетов, входящих в масштабное развертывание.

См. также

Основные понятия

Администрирование баз данных сервера отчетов

Другие ресурсы

Хранение зашифрованных данных сервера отчетов
Программа конфигурации служб Reporting Services
Программа rskeymgmt


Инициализация сервера отчетов

Инициализация сервера отчетов |
 | См. также
Настройка установки SQL Server > Настройка служб Reporting Services > Управление ключами шифрования >

В службах Reporting Services инициализированный сервер — это сервер, способный шифровать и дешифровать данные в базе данных сервера отчетов. Инициализация является необходимым условием функционирования сервера отчетов. Инициализация происходит, когда служба Windows сервера отчетов запускается впервые. Она также происходит, когда сервер отчетов подключается к уже развернутой системе или когда вручную повторно создаются ключи как часть процесса восстановления. Дополнительные сведения о создании ключей шифрования и их назначении см. в разделах Управление ключами шифрования и Хранение зашифрованных данных сервера отчетов.

Ключи шифрования частично основываются на данных профиля в службе Windows сервера отчетов. Если изменяется удостоверение пользователя, которое используется для запуска службы Windows сервера отчетов, необходимо соответствующим образом обновить ключи. Если используется программа настройки служб Reporting Services для изменения удостоверения пользователя, этот шаг выполняется автоматически.

Если инициализация по какой-либо причине прошла неудачно, сервер отчетов возвращает ошибку RSReportServerNotActivated в ответ на запросы пользователя и службы. В такой ситуации, вероятно, потребуется произвести диагностику и устранение неисправностей в системе или конфигурации сервера. Дополнительные сведения см. в разделе Устранение неполадок при инициализации и ошибок ключа шифрования.

Обзор процесса инициализации

Процесс инициализации создает и хранит симметричный ключ, используемый для шифрования. Симметричный ключ создается службами криптографии Microsoft Windows и впоследствии используется службой сервера отчетов Windows для шифрования и дешифрования данных. Сам симметричный ключ зашифрован при помощи асимметричного ключа.

В установленных службах Reporting Services только служба Windows сервера отчетов может осуществлять операции шифрования. Когда веб-службе сервера отчетов требуется шифрование или дешифрование, она обращается к службе Windows сервера отчетов для выполнения соответствующей операции.

Ниже описаны этапы инициализации.

  1. При первоначальном запуске служба Windows сервера отчетов считывает файл конфигурации RSReportServer.config, чтобы получить идентификатор установки и сведения для соединения с базой данных.

  2. Служба Windows сервера отчетов запрашивает открытый ключ у служб криптографии. Windows создает секретный и открытый ключ и отсылает открытый ключ службе Windows сервера отчетов.

  3. Служба Windows сервера отчетов соединяется с базой данных сервера отчетов и сохраняет значения идентификатора установки и открытого ключа.

  4. Служба Windows сервера отчетов снова вызывает службы криптографии, на этот раз, запрашивая симметричный ключ. Windows создает симметричный ключ.

  5. Служба Windows сервера отчетов вновь соединяется с базой данных сервера отчетов и добавляет симметричный ключ к значениям открытого ключа и идентификатора установки, которые были сохранены на третьем этапе. Прежде чем сохранить симметричный ключ, служба Windows сервера отчетов шифрует его при помощи открытого ключа. С момента сохранения симметричного ключа сервер отчетов считается инициализированным и доступным для использования.

Инициализация сервера отчетов для масштабного развертывания

Службы Reporting Services поддерживают модель масштабного развертывания, которая опирается на совместное использование одной базы данных сервера отчетов несколькими экземплярами сервера отчетов. Чтобы присоединиться к масштабному развертыванию, сервер отчетов должен создать и сохранить свою копию симметричного ключа в общей базе данных. Хотя все серверы, использующие эту базу данных, пользуются единственным симметричным ключом, каждый сервер отчетов имеет собственную копию этого ключа. Каждая копия отличается от других тем, что она уникальным образом зашифрована при помощи открытого ключа своего владельца.

Первая группа этапов инициализации сервера отчетов для масштабного развертывания идентична первым трем этапам инициализации сочетания одиночного сервера и базы данных.

Процесс инициализации для масштабного развертывания отличается тем, как сервер отчетов получает симметричный ключ. Когда первый сервер проходит инициализацию, он получает симметричный ключ от Windows. Когда второй сервер проходит инициализацию в процессе настройки масштабного развертывания, он получает симметричный ключ от службы Windows сервера отчетов, которая уже инициализирована. Первый экземпляр сервера отчетов использует открытый ключ второго экземпляра, чтобы создать зашифрованную копию симметричного ключа для второго экземпляра сервера отчетов. Симметричный ключ не отображается как простой текст ни на одном этапе этого процесса.

Как инициализировать сервер отчетов

  • Чтобы инициализировать сервер отчетов, используйте программу настройки служб Reporting Services. Инициализация происходит автоматически, когда создается и настраивается база данных сервера отчетов. Дополнительные сведения см. в разделе Настройка соединения с базой данных сервера отчетов.

  • Чтобы инициализировать сервер отчетов для масштабного развертывания, можно использовать страницу «Инициализация» в программе настройки служб Reporting Services или программу RSKeymgmt. Пошаговые инструкции см. в разделе Как настроить масштабное развертывание сервера отчетов (настройка служб Reporting Services).

Примечание.
RSKeymgmt — это приложение командной строки, запускаемое на компьютере, на котором установлен экземпляр сервера отчетов, уже являющийся частью масштабного развертывания. При запуске этой программы указываются аргументы для выбора удаленного экземпляра сервера отчетов, который необходимо инициализировать.

Сервер отчетов будет инициализирован только в случае соответствия идентификатора установки и открытого ключа. Если соответствие установлено, создается симметричный ключ, позволяющий производить обратимое шифрование. Если соответствие не установлено, сервер отчетов отключается, и в этом случае, вероятно, придется применить резервную копию ключа либо удалить зашифрованные данные, если резервная копия ключа недоступна или недействительна. Дополнительные сведения о ключах шифрования, используемых сервером отчетов, см. в разделе Управление ключами шифрования.

Примечание.
Можно также воспользоваться поставщиком инструментария WMI для служб Reporting Services, чтобы программными средствами инициализировать сервер отчетов. Дополнительные сведения см. в разделе Reporting Services WMI Provider.

Как подтвердить инициализацию сервера отчетов

Для подтверждения инициализации сервера отчетов обратитесь к веб-службе сервера отчетов, введя в командной строке http://<имя_сервера>/reportserver. Если получена ошибка RSReportServerNotActivated, инициализация прошла неудачно.

См. также

Другие ресурсы

Операции резервного копирования и восстановления для служб Reporting Services
Устранение неполадок при инициализации и ошибок ключа шифрования
Развертывание служб Reporting Services
Управление службами Reporting Services
Хранение зашифрованных данных сервера отчетов


Создание резервных копий и восстановление ключей шифрования

Создание резервных копий и восстановление ключей шифрования |
 | См. также
Настройка установки SQL Server > Настройка служб Reporting Services > Управление ключами шифрования >

Одним из важных аспектов конфигурирования сервера отчетов является создание резервной копии симметричного ключа, используемого для шифрования конфиденциальных данных. Резервная копия ключа требуется для выполнения многих распространенных операций и позволяет повторно использовать базу данных существующего сервера отчетов в новом сервере. Восстанавливать резервную копию ключа шифрования нужно в ответ на любое из следующих событий:

  • Изменение имени учетной записи Windows-службы сервера отчетов или переназначение пароля. Когда используется программа настройки служб Reporting Services, создание резервной копии ключа входит в операцию изменения имени учетной записи службы.

    Примечание.
    Переназначение пароля и изменение пароля — не одно и то же. Для переназначения пароля необходимо разрешение на перезапись учетных данных в контроллере домена. Переназначение пароля выполняется системным администратором в том случае, если пользователь забывает или не знает конкретный пароль. Восстановление симметричного ключа требуется только при переназначении паролей. При периодическом изменении пароля учетной записи переназначать симметричный ключ не нужно.

  • Переименование компьютера или экземпляра, на котором размещен сервер отчетов (работа экземпляра сервера отчетов основана на имени экземпляра SQL Server).

  • Выполнение миграции сервера отчетов или настройка сервера отчетов на использование другой базы данных сервера отчетов.

  • Восстановление сервера отчетов по журналу после аппаратного сбоя.

Необходимо создать только одну резервную копию симметричного ключа. Между базой данных сервера отчетов и симметричным ключом имеется однозначное соответствие. Несмотря на то, что необходимо создать только одну резервную копию ключа, восстанавливать ключ, возможно, придется несколько раз, если выполняется несколько серверов отчетов, использующих модель масштабного развертывания. Каждому экземпляру сервера отчетов потребуется своя копия симметричного ключа для блокирования и разблокирования данных в базе данных сервера отчетов.

Создание резервных копий ключей шифрования на диске

Созданием резервной копии симметричного ключа называют процесс, в ходе которого ключ записывается в указанный файл, после чего шифруется с использованием заданного пароля. Симметричный ключ не может быть сохранен в незашифрованном состоянии, поэтому при его сохранении на диске необходимо указать пароль для шифрования ключа. После создания файла необходимо сохранить его в безопасном месте и запомнить пароль, служащий для разблокирования файла. Для создания резервной копии симметричного ключа можно использовать или программу настройки служб Reporting Services, или программу rskeymgmt.

Как создать резервную копию ключа шифрования (программа настройки служб Reporting Services)

  1. Запустите программу настройки служб Reporting Services и подключитесь к экземпляру сервера отчетов, который нужно настроить.

  2. Щелкните Ключи шифрования, а затем — Создать резервную копию.

  3. Введите надежный пароль.

  4. Укажите файл, в котором следует сохранить ключ. Созданный файл будет иметь расширение SNK. Подумайте о том, не следует ли записать файл на дискету, чтобы не хранить его на компьютере, на котором выполняется сервер отчетов.

  5. Нажмите кнопку ОК.

Как создать резервную копию ключа шифрования (программа rskeymgmt)

  1. Если защищенный паролем файл должен храниться не на сервере отчетов, вставьте дискету в дисковод.

  2. На компьютере, на котором выполняется сервер отчетов, запустите программу rskeymgmt.exe. Укажите для копирования ключа аргумент -e, задайте имя файла и пароль. Аргументы, которые необходимо задать, приведены в следующем примере.

    Копировать код
    rskeymgmt -e -f a:\rsdbkey.snk -p<password>
  3. Сохраните дискету в безопасном месте.

Восстановление ключей шифрования

При восстановлении симметричного ключа выполняется перезапись существующего симметричного ключа, хранящегося в базе данных сервера отчетов. В результате восстановления ключа шифрования неиспользуемый ключ заменяется копией, которая ранее была сохранена на диске. Восстановление ключа шифрования складывается из следующих операций:

  • Из защищенного паролем файла резервной копии ключа извлекается симметричный ключ.

  • Симметричный ключ шифруется с использованием открытого ключа Windows-службы сервера отчетов.

  • Зашифрованный симметричный ключ сохраняется в базе данных сервера отчетов.

  • Данные симметричного ключа, которые хранились в базе данных до этого (например данные ключа, которые была записаны в базу данных сервера отчетов при развертывании предыдущего экземпляра), удаляются.

Для восстановления ключа шифрования необходим файл с копией ключа. Кроме того, необходимо знать пароль, позволяющий разблокировать хранимую копию ключа. Если эти условия выполнены, можно запустить для восстановления ключа программу настройки служб Reporting Services или программу rskeymgmt. Симметричный ключ должен быть тем же, что служит и для блокирования и разблокирования зашифрованного содержимого, хранящегося в базе данных сервера отчетов. При попытке восстановления некорректной копии ключа сервер отчетов не сможет получить доступ к зашифрованным данным, хранящимся в базе данных сервера отчетов. В этом случае, возможно, придется удалить все зашифрованные значения, если не получится восстановить корректный ключ. Если в силу той или иной причины восстановить ключ шифрования не удается (например нет резервной копии ключа), существующий ключ и зашифрованные данные необходимо удалить. Дополнительные сведения см. в разделе Удаление и повторное создание ключей шифрования. Дополнительные сведения о создании симметричных ключей см. в разделе Инициализация сервера отчетов.

Как восстановить ключ шифрования (программа настройки служб Reporting Services)

  1. Запустите программу настройки служб Reporting Services и подключитесь к экземпляру сервера отчетов, который нужно настроить.

  2. На странице «Ключи шифрования» щелкните Восстановить.

  3. Выберите SNK-файл, содержащий резервную копию ключа.

  4. Введите пароль, позволяющий разблокировать файл.

  5. Нажмите кнопку ОК.

Как восстановить ключ шифрования (программа rskeymgmt)

  1. Вставьте в дисковод дискету с резервной копией ключа шифрования.

  2. На компьютере, на котором выполняется сервер отчетов, запустите программу rskeymgmt.exe. Укажите для восстановления ключа аргумент -a. Необходимо указать полностью определенное имя файла и пароль. Аргументы, которые необходимо задать, приведены в следующем примере:

    Копировать код
    rskeymgmt -a -f a:\rsdbkey.snk -p<password>

См. также

Основные понятия

Управление ключами шифрования

Другие ресурсы

Программа конфигурации служб Reporting Services
Программа rskeymgmt
Операции резервного копирования и восстановления для служб Reporting Services


Удаление и повторное создание ключей шифрования

Удаление и повторное создание ключей шифрования |
 | См. также
Настройка установки SQL Server > Настройка служб Reporting Services > Управление ключами шифрования >

Удаление и повторное создание ключей шифрования — действия, которые выходят за пределы обычного обслуживания ключа шифрования. Эти задачи выполняются в ответ на определенную угрозу серверу отчетов или как последнее средство спасения, когда больше нельзя получить доступ к базе данных сервера отчетов.

  • Создайте повторно симметричный ключ, если есть основания полагать, что существующий симметричный ключ скомпрометирован. Также можно регулярно создавать повторно ключ для наибольшей эффективности системы безопасности.

  • Удалите существующие ключи шифрования и непригодное для использования зашифрованное содержимое, если нельзя восстановить симметричный ключ.

Повторное создание ключей шифрования

Если очевидно, что симметричный ключ известен неправомочным пользователям, или если сервер отчетов подвергся атаке и в качестве меры предосторожности необходимо сбросить симметричный ключ, можно создать повторно симметричный ключ. При создании повторно симметричного ключа все зашифрованные значения будут повторно зашифрованы с помощью нового значения. Если работает несколько серверов отчетов в масштабном развертывании, то все копии симметричного ключа будут обновлены новым значением. Сервер отчетов использует доступные для него открытые ключи, чтобы обновить симметричный ключ для каждого сервера в развертывании.

Когда сервер отчетов находится в рабочем состоянии, можно только создать повторно симметричный ключ. Повторное создание ключей шифрования и повторное шифрование содержимого нарушают работу сервера. На время повторного шифрования необходимо обеспечить автономный режим работы сервера. Во время повторного шифрования какие-либо запросы к серверу отчетов не должны выполняться.

Можно использовать программу настройки служб Reporting Services или программу rskeymgmt, чтобы сбросить симметричный ключ и зашифрованные данные. Дополнительные сведения о создании симметричных ключей см. в разделе Инициализация сервера отчетов.

Как создать повторно ключи шифрования (программа настройки служб Reporting Services)

  1. Используйте средство настройки контактной зоны служб SQL Server Reporting Services, чтобы отключить веб-службу сервера отчетов. Если повторно создаются ключи шифрования для сервера отчетов с масштабным развертыванием, нужно отключить веб-службу сервера отчетов на всех экземплярах в развертывании.

    1. Запустите программу настройки служб SQL Server Reporting Services и щелкните Настройка контактной зоны для функциональных возможностей.

    2. Выберите службы Reporting Services.

    3. Для пункта Веб-службы и HTTP-доступ снимите флажок Включить веб-службы и HTTP-доступ.

  2. Запустите программу настройки служб Reporting Services и подключитесь к экземпляру сервера отчетов, который нужно настроить.

  3. На странице «Ключи шифрования» нажмите кнопку Изменить. Нажмите кнопку ОК.

  4. Перезапустите службу Windows «Сервер отчетов». Если повторно создаются ключи шифрования для масштабного развертывания, нужно перезапустить службу на всех экземплярах.

  5. Запустите средство настройки контактной зоны служб SQL Server Reporting Services, чтобы включить операции веб-службы сервера отчетов. Сделайте это для всех экземпляров при работе с масштабным развертыванием.

Как создать повторно ключи шифрования (rskeymgmt)

  1. Отключите веб-службу и HTTP доступ. Используйте инструкции из предыдущей процедуры, чтобы остановить операции веб-службы.

  2. На компьютере, на котором выполняется сервер отчетов, запустите программу rskeymgmt.exe. Используйте аргумент -s, чтобы сбросить симметричный ключ. Никакие другие аргументы не требуются:

    Копировать код
    rskeymgmt -s
  3. Перезапустите службу Windows и включите операции веб-службы.

Удаление непригодного для использования зашифрованного содержимого

Если по каким-то причинам нельзя восстановить ключ шифрования, сервер отчетов никогда не будет в состоянии расшифровать и использовать любые данные, зашифрованные этим ключом. Чтобы вернуть сервер отчетов к рабочему состоянию, необходимо удалить зашифрованные значения, которые в настоящее время сохранены в базе данных сервера отчетов, и затем вручную повторно определить необходимые значения.

Удаление ключей шифрования удаляет все сведения о симметричном ключе из базы данных сервера отчетов и удаляет любое зашифрованное содержимое. Все незашифрованные данные остаются целыми, будет удалено только зашифрованное содержимое. При удалении ключей шифрования сервер отчетов автоматически повторно инициализирует себя, добавляя новый симметричный ключ. При удалении зашифрованного содержимого происходит следующее:

  • Строки соединения в общих источниках данных будут удалены. Пользователи, выполняющие отчеты, получат сообщение об ошибке «Свойство ConnectionString не инициализировано».

  • Хранимые учетные данные будут удалены. Отчеты и общие источники данных будут перенастроены на использование запрашиваемых учетных данных.

  • Отчеты, основанные на моделях (которым необходимы общие источники данных, настроенные на работу с хранимыми учетными данными или без них), не будут выполняться.

  • Подписки будут деактивированы.

Если зашифрованное содержимое было удалено, его нельзя восстановить. Необходимо повторно определить строки соединений и хранимые учетные данные и активизировать подписки.

Можно использовать программу настройки служб Reporting Services или программу rskeymgmt для удаления значений.

Как удалить ключи шифрования (программа настройки служб Reporting Services)

  1. Запустите программу настройки служб Reporting Services и подключитесь к экземпляру сервера отчетов, который нужно настроить.

  2. Щелкните Ключи шифрования, затем щелкните Удалить. Нажмите кнопку ОК.

  3. Перезапустите службу Windows «Сервер отчетов». Для масштабного развертывания это необходимо сделать на всех экземплярах сервера отчетов.

Как удалить ключи шифрования (rskeymmgt)

  1. На компьютере, на котором выполняется сервер отчетов, запустите программу rskeymgmt.exe. Необходимо использовать аргумент -d. В следующем примере приводится аргумент, который необходимо указать:

    Копировать код
    rskeymgmt -d
  2. Перезапустите службу Windows «Сервер отчетов». Для масштабного развертывания это необходимо сделать на всех экземплярах сервера отчетов.

Как повторно определить зашифрованные значения

  1. Для каждого общего источника данных необходимо повторно ввести строку соединения.

  2. Для каждого отчета и общего источника данных, который использует сохраненные учетные данные, необходимо заново ввести имя пользователя и пароль, затем сохранить. Дополнительные сведения см. в разделе Указание учетных данных и сведений о соединении.

  3. Откройте каждую управляемую данными подписку и заново введите учетные данные для базы данных подписки.

  4. Для подписок, которые используют зашифрованные данные (это включает модуль доставки в общую папку и любые сторонние модули доставки, использующие шифрование), откройте каждую подписку и повторно введите учетные данные. Подписки, которые используют доставку по электронной почте сервера отчетов, не используют зашифрованные данные и не затрагиваются изменением ключа.

См. также

Основные понятия

Управление ключами шифрования

Другие ресурсы

Программа конфигурации служб Reporting Services
Программа rskeymgmt
Хранение зашифрованных данных сервера отчетов


Добавление и удаление ключей шифрования для масштабного развертывания

Добавление и удаление ключей шифрования для масштабного развертывания |
 | См. также
Настройка установки SQL Server > Настройка служб Reporting Services > Управление ключами шифрования >

Службы Reporting Services можно запускать в модели с масштабным развертыванием, настроив несколько серверов отчетов на использование общей базы данных. Членство в масштабном развертывании основано на том, хранит ли сервер отчетов ключ шифрования в базе данных сервера отчетов. Этим членством можно управлять за счет добавления и удаления ключей шифрования для конкретных экземпляров серверов отчетов. При удалении узлов из конфигурации развертывания их можно удалять в любом порядке. При добавлении узлов к конфигурации необходимо объединить все новые экземпляры сервера отчетов, которые уже входят в нее.

Использование программы настройки служб Reporting Services для масштабного развертывания

Наиболее простым способом настройки масштабного развертывания является применение программы настройки служб Reporting Services. Дополнительные сведения и пошаговые инструкции см. в разделах Настройка масштабного развертывания сервера отчетов и Как настроить масштабное развертывание сервера отчетов (настройка служб Reporting Services).

Использование Rskeymgmt для настройки масштабного развертывания

Программа rskeymgmt служит для инициализации использования экземпляром сервера отчетов общей базы данных на серверах отчетов. Добавление сервера отчетов в масштабное развертывание требует инициализации сервера отчетов. Инициализация требует административных разрешений. Необходимо иметь права администратора для удаленного компьютера, на котором размещается сервер отчетов, присоединяемый к развертыванию.

Как присоединить сервер отчетов к масштабному развертыванию (rskeymgmt)

  1. Запустите программу rskeymgmt.exe локально на компьютере, где размещается сервер отчетов, уже являющийся членом масштабного развертывания сервера отчетов.

  2. С помощью аргумента -j присоедините сервер отчетов к базе данных сервера отчетов. Используйте аргументы -m и -n для указания экземпляра удаленного сервера отчетов, который необходимо добавить к конфигурации развертывания. Используйте аргументы -u и -v для указания учетной записи администратора на удаленном компьютере. При создании масштабного развертывания, содержащего несколько экземпляров сервера отчетов на том же компьютере, синтаксис будет немного другим. Дополнительные сведения о синтаксисе, который следует использовать в этом случае, см. в разделе Программа rskeymgmt.

    Следующий пример иллюстрирует аргументы, которые необходимо указать при присоединении удаленного сервера отчетов к масштабному развертыванию (можно опустить учетные данные, если на удаленном компьютере имеются разрешения администратора):

    Копировать код
    rskeymgmt -j -m <remotecomputer> -n <namedreportserverinstance> -u <administratoraccount> -v <administratorpassword>

Как исключить сервер отчетов из масштабного развертывания (rskeymgmt)

  1. Откройте файл rsreportserver.config сервера отчетов, который необходимо удалить, и найдите идентификатор установки. По умолчанию этот файл находится в папке Program Files\Microsoft SQL Server\MSSQL.n\Reporting Services\ReportServer).

    Если установлен всего один экземпляр, на компьютере будет находиться один файл rsreportserver.config. Если установлено несколько экземпляров служб Reporting Services, воспользуйтесь страницей «Состояние сервера» программы настройки служб Reporting Services для поиска идентификатора экземпляра сервера отчетов (например «MSSQL.2»), который необходимо удалить. Имя папки, в которой хранятся программные файлы экземпляра сервера отчетов, содержит идентификатор экземпляра (например: Program Files\Microsoft SQL Server\MSSQL.2).

  2. Запустите программу rskeymgmt.exe. Ее можно запускать только на сервере отчетов, который входит в масштабное развертывание сервера отчетов.

  3. Используйте аргумент -r для исключения экземпляра сервера отчетов из масштабного развертывания. Аргументы, которые необходимо задать, приведены в следующем примере:

    Копировать код
    rskeymgmt -r <installation ID>

См. также

Основные понятия

Управление ключами шифрования
Инициализация сервера отчетов

Другие ресурсы

Программа конфигурации служб Reporting Services
Программа rskeymgmt


Разделы руководства по настройке служб Reporting Services

Разделы руководства по настройке служб Reporting Services |
 | См. также
Настройка установки SQL Server > Настройка служб Reporting Services >

Этот раздел содержит процедуры для настройки экземпляра сервера отчетов с использованием программы настройки служб Reporting Services.

В этом разделе

Подраздел | Описание
Как запустить настройку служб Reporting Services | Представляет шаги запуска программы настройки служб Reporting Services.
Как Настройка учетных записей служб (конфигурация служб Reporting Services) | Поясняет, как указать данные учетной записи и пароля для веб-службы и службы Windows сервера отчетов.
How to: Configure Reporting Services to Use a Non-Default Web Site (Reporting Services Configuration) | Представляет шаги выбора веб-узла, который не является веб-узлом по умолчанию. Это описание предназначено для пользователей, не знакомых с процессом создания веб-узла.
Как создать базу данных сервера отчетов (настройка служб Reporting Services) | Представляет шаги создания базы данных сервера отчетов. Этот шаг требуется для развертывания установки служб Reporting Services.
Как создать базу данных сервера отчетов для режима интеграции с SharePoint (настройка служб Reporting Services) | Объясняет создание базы данных сервера отчетов для сервера отчетов, который выполняется в режиме интеграции с SharePoint.
Как выполнить интеграцию сервера отчетов в центре администрирования SharePoint | Предоставляет инструкции для настройки интеграции в центре администрирования SharePoint.
Как переключать режимы сервера (конфигурация служб Reporting Services) | Объясняет удаление экземпляра сервера отчетов из развертывания технологии или экземпляра SharePoint, чтобы сервер отчетов выполнялся в собственном режиме.
Как настроить масштабное развертывание сервера отчетов (настройка служб Reporting Services) | Представляет шаги настройки нескольких серверов отчетов для совместного использования базы данных сервера отчетов.
Как настроить базы данных сервера отчетов в ядре СУБД после его обновления с версии SQL Server 7.0 (конфигурация служб Reporting Services) | Объясняет, как установить уровень совместимости базы данных во избежание исключительных ситуаций при создании базы данных сервера отчетов на обновленном экземпляре компонента Database Engine.
Как настроить сервер отчетов для работы с электронной почтой (конфигурация служб Reporting Services) | Содержит шаги настройки сервера отчетов для доставки по электронной почте.
Как включите удаленный контроль ошибок (настройка служб Reporting Services) | Поясняет, как задать свойства сервера на сервере отчетов для возвращения дополнительных сведений об условиях возникновения ошибок на удаленных серверах.

См. также

Другие ресурсы

Разделы руководства по службам Reporting Services
Настройка компонентов служб Reporting Services
Программа конфигурации служб Reporting Services


Как запустить настройку служб Reporting Services

Как запустить настройку служб Reporting Services |
 | См. также
Настройка установки SQL Server > Настройка служб Reporting Services > Разделы руководства по настройке служб Reporting Services >

Программу настройки служб Reporting Services используется для развертывания установки служб Reporting Services. Оно может выполняться на компьютере, содержащем локальный экземпляр сервера отчетов. Средство можно также использовать для настройки удаленных экземпляров сервера отчетов, к которым имеются административные права доступа.

Запуск программы настройки служб Reporting Services

  1. Нажмите кнопку Пуск, укажите Программы, затем укажите Microsoft SQL Server 2005, а затем Средства настройки.

  2. Выберите пункт Настройка служб Reporting Services. Отображается диалоговое окно выбора экземпляра установки сервера отчетов, в котором можно выбрать настраиваемый экземпляр сервера отчетов.

  3. В поле Имя компьютера укажите имя компьютера, на котором установлен экземпляр сервера отчетов. По умолчанию указывается имя локального компьютера, но можно ввести имя удаленного экземпляра SQL Server.

    Если указан удаленный компьютер, для установления соединения нажмите кнопку Найти. Сервер отчетов должен быть заранее настроен для удаленного администрирования. Дополнительные сведения см. в разделе Настройка сервера отчетов для удаленного администрирования электронной документации по SQL Server.

  4. В поле Имя экземпляра выберите экземпляр служб SQL Server 2005 Reporting Services, который нужно настроить. В списке отображаются только экземпляры сервера отчетов SQL Server 2005. Более ранние версии служб Reporting Services настраивать нельзя.

  5. Нажмите кнопку Соединить.

См. также

Основные понятия

Разделы руководства по настройке служб Reporting Services

Другие ресурсы

Настройка компонентов служб Reporting Services
Программа конфигурации служб Reporting Services


Как Настройка учетных записей служб (конфигурация служб Reporting Services)

Как Настройка учетных записей служб (конфигурация служб Reporting Services) |
 | См. также
Настройка установки SQL Server > Настройка служб Reporting Services > Разделы руководства по настройке служб Reporting Services >

Для определения учетных записей служб при установке служб Reporting Services воспользуйтесь программой настройки служб Reporting Services, которая позволяет одновременно обновлять другие настройки, зависящие от удостоверения служб.

По умолчанию веб-служба сервера отчетов выполняется под учетной записью Сетевая служба служб IIS 6.0 или под учетной записью ASP.NET служб IIS 5.0. Можно настроить веб-службу для выполнения под другой учетной записью. При использовании учетной записи домена для обеспечения полной работоспособности службы могут потребоваться дополнительные действия.

Служба Windows сервера отчетов выполняется под определенной во время установки учетной записью, хотя возможно настроить ее для выполнения под другой учетной записью, а также изменить пароль, если срок действия предыдущего пароля истек.

Важно!
При изменении удостоверения службы Windows сервера отчетов каждый шаг обновления учетной записи службы записывается на панели задач в нижней части страницы. Во время обновления учетной записи будет остановлена и перезапущена служба Windows сервера отчетов. При этом могут возникать ошибки входа в систему (например, если при вводе учетной записи или пароля были сделаны опечатки). В том маловероятном случае, когда симметричный ключ не был восстановлен, этот шаг может быть выполнен самостоятельно. Для этого необходимо нажать кнопку Восстановить на странице «Ключи шифрования». Чтобы проверить, правильно ли была переустановлена учетная запись, необходимо открыть отчет, в котором используются хранимые учетные данные. При невозможности восстановить резервную копию ключа необходимо удалить зашифрованные данные. Дополнительные сведения см. в разделе Удаление и повторное создание ключей шифрования и Создание резервных копий и восстановление ключей шифрования.

Некоторые шаги настройки учетных записей веб-служб взяты из других статей, опубликованных на веб-узле MSDN. Дополнительные сведения о настройке учетных записей веб-служб см. в статье Как создать учетную запись службы для ASP на веб-узле MSDN.

Для создания учетных записей домена необходимо являться администратором домена.

Настройка службы Windows сервера отчетов

  1. Запустите программу настройки служб Reporting Services и подключитесь к серверу отчетов.

  2. На странице «Удостоверение службы Windows» укажите новую учетную запись и пароль. Нажмите кнопку Применить.

  3. Когда система предложит создать резервную копию симметричного ключа, введите пароль, а также имя файла для резервной копии симметричного ключа и нажмите кнопку ОК.

Настройка веб-службы сервера отчетов для использования учетной записи домена в службах IIS 6.0

  1. Создайте новую учетную запись домена при помощи средства «Active Directory - пользователи и компьютеры» панели управления. Задайте описательное имя для учетной записи. Снимите флажок Потребовать смены пароля при следующем входе в систему и выберите Срок действия пароля никогда не истекает. Назначьте надежный пароль для учетной записи. Надежные пароли должны состоять как минимум из семи знаков, в которые должны входить буквы верхнего и нижнего регистра, числа, а также другие символы, такие как *, ? или $.

  2. Назначьте разрешения ASP.NET для новой учетной записи, выполнив следующую команду в окне командной строки:

    aspnet_regiis -ga ИмяДомена\ИмяУчетнойЗаписи

  3. Запустите диспетчер IIS.

  4. В пуле приложений щелкните правой кнопкой мыши Сервер отчетов, а затем выберите пункт Свойства.

  5. Щелкните Удостоверение.

  6. Введите учетную запись пользователя домена.

  7. Запустите программу настройки служб Reporting Services и подключитесь к серверу отчетов.

  8. Откройте страницу «Удостоверение веб-служб», чтобы выбрать только что настроенный пул приложений.

  9. Нажмите кнопку Применить.

Если в сети настроена проверка подлинности Kerberos, то администратору домена, возможно, придется создать основное имя службы (SPN), которое зарегистрирует учетную запись домена для веб-узла. В противном случае может возникнуть ошибка доступа HTTP 401. Убедитесь, что зарегистрированная учетная запись домена совпадает с используемой в пуле приложений. Дополнительные сведения см. в разделе Настройка ограниченного делегирования для Kerberos (службы IIS 6.0) на веб-узле Microsoft TechNet.

Настройка веб-службы сервера отчетов для использования учетной записи домена в службах IIS 5.0

  1. Создайте новую учетную запись домена при помощи средства «Active Directory - пользователи и компьютеры» панели управления. Задайте описательное имя для учетной записи. Снимите флажок Потребовать смены пароля при следующем входе в систему и выберите Срок действия пароля никогда не истекает. Назначьте надежный пароль для учетной записи. Надежные пароли должны состоять как минимум из семи знаков, в которые должны входить буквы верхнего и нижнего регистра, числа, а также другие символы, такие как *, ? или $.

  2. Сохраните зашифрованную копию учетной записи пользователя и пароля в реестре. На последующих шагах ссылка на этот параметр реестра будет внесена в файл Machine.config.

    1. Загрузите программу aspnet_setreg.exe из статьи Как использовать средство ASP NET для шифрования учетных данных и строк соединения состояния сеанса на узле www.support.microsoft.com.

    2. Выполните следующие команды из командной строки, используя значения домена, имени пользователя и пароля, которые действительны для созданной на шаге 1 учетной записи.

      Копировать код
      aspnet_setreg -k:Software\MyASPNetApp\Identity -u:"domainname\username" -p:"password"

  3. Откройте файл Machine.config при помощи среды Microsoft Visual Studio или Блокнота. Файл Machine.config находится в следующей папке: C:\WINNT\Microsoft.NET\Framework\v1.1.4322\CONFIG. Измените файл конфигурации, добавив ссылки на только что созданный раздел реестра следующим образом.

    1. Найдите элемент <identity impersonate="false" userName="" password=""/>.

    2. Замените его следующей записью:

      Копировать код
      <identity impersonate="true"
userName="registry:HKLM\Software\MyASPNetApp\Identity\ASPNET_SETREG,userName"
password="registry:HKLM\Software\MyASPNetApp\Identity\ASPNET_SETREG,password"/>

  4. Запустите редактор реестра для предоставления разрешений на чтение для данной учетной записи:

    1. Перейдите в раздел My Computer/HKEY_LOCAL_MACHINE/SOFTWARE/MyASPNetApp/Identity/ASPNET_SETREG

    2. Щелкните правой кнопкой мыши по пункту ASPNET_SETREG и выберите Разрешения.

    3. Нажмите кнопку Добавить.

    4. Введите учетную запись пользователя, созданную на шаге 1, и нажмите кнопку ОК.

    5. Выберите учетную запись, щелкните Полный доступ, а затем нажмите кнопку ОК.

  5. Назначьте разрешения на доступ к файлам для папки временных файлов ASP.NET:

    1. Перейдите к папке C:\WINNT\Microsoft.NET\Framework\V1.0.4322\Temporary ASP.NET Files.

    2. Щелкните правой кнопкой мыши по папке Temporary ASP.NET Files, выберите Свойства.

    3. Щелкните Безопасность, нажмите кнопку Добавить, введите учетную запись, а затем выберите учетную запись для указания разрешений на нее.

    4. Щелкните Запись и нажмите кнопку ОК.

  6. Добавьте учетную запись для групп безопасности Windows сервера отчетов.

    1. Нажмите кнопку Пуск, выберите пункт Администрирование, а затем выберите пункт Управление компьютером.

    2. Откройте Локальные пользователи и группы и выберите Группы.

    3. Щелкните правой кнопкой мыши SQLServer2005ReportingServicesWebServiceUser$<имя_компьютера>$<имя_экземпляра>.

    4. Выберите пункт Добавить к группе.

    5. Нажмите кнопку Добавить.

    6. Введите учетную запись и нажмите кнопку ОК.

    Примечание.
    Большинство шагов этой процедуры взяты из статьи «Создание безопасного приложения ASP.NET: проверка подлинности, авторизация и безопасное подключение» на узле MSDN. Дополнительные сведения об этапах см. в указанном документе на узле MSDN. Дополнительные сведения об использовании программы aspnet_setreg.exe см. в разделе Использование ASP на узле www.support.microsoft.com.

См. также

Задачи

Как запустить настройку служб Reporting Services

Справочник

Идентификация служб Windows (конфигурация служб Reporting Services)
Web Service Identity - Windows Server 2003 (Reporting Services Configuration)
Идентификация веб-службы (настройка служб Reporting Services)

Основные понятия

Настройка учетных записей и паролей служб в службах Reporting Services
Администрирование службы Windows и веб-службы сервера отчетов


How to: Configure Reporting Services to Use a Non-Default Web Site (Reporting Services Configuration)

How to: Configure Reporting Services to Use a Non-Default Web Site (Reporting Services Configuration) |
 | См. также
Настройка установки SQL Server > Настройка служб Reporting Services > Разделы руководства по настройке служб Reporting Services >

Дата обновления: 14 апреля 2006 г.

Для сервера отчетов и диспетчера отчетов на пользовательском веб-узле можно создать виртуальные каталоги.Чтобы использовать не веб-узел по умолчанию, необходимо создать узел, выбрать его при создании виртуального каталога, обновить URL-адреса в файлах конфигурации служб Reporting Services и проверить установку, чтобы убедиться в том, что сервер отчетов доступен.То, как указывать URL-адреса и проверять конфигурацию зависит от того, идентифицирован ли веб-узел уникальным IP-адресом, номером порта, заголовочным именем узла или комбинацией.

В зависимости от того, как настроен веб-узел, при проверке URL-адреса может возникнуть одна или несколько ошибок HTTP 401:

  • «HTTP 401.1 — Нет доступа:Вход не выполнен», при работе в операционной системе Windows XP с пакетом обновления 2 или на Windows Server 2003 с пакетом обновления и полностью указанным именем домена веб-узла, отличным от имени компьютера.Существует несколько методов исправления этой ошибки.Дополнительные сведения об этой ошибке и методах ее устранения см. на веб-узле http://support.microsoft.com/kb/896861.

  • «HTTP 401.1 — Нет доступа:Неправильные учетные данные», если пул приложений является местной учетной записью или учетной записью пользователя домена, а веб-узел настроен на использование встроенной безопасности.Поскольку виртуальные каталоги сервера отчетов по умолчанию используют встроенную безопасность, эту ошибку можно ожидать при доступе к серверу отчетов.Дополнительные сведения об этой ошибке и методах ее устранения, см. на веб-узле http://support.microsoft.com/kb/871179.

Можно запустить несколько экземпляров сервера отчетов на одном компьютере без необходимости создавать пользовательские веб-узлы для каждого экземпляра.Дополнительные сведения см. в разделе Установка нескольких экземпляров служб Reporting Services.

Создание виртуальных каталогов в новом пользовательском веб-узле

  1. Создаете новый веб-узел в диспетчере служб IIS. Создавая пользовательский веб-узел, необходимо настроить его на использование конкретного IP-адреса либо имени заголовка компьютера. Инструкции по созданию веб-узла см. в разделе Размещение нескольких веб-узлов на одном сервере документации по службам IIS.

  2. Убедитесь, что веб-узел доступен и что при попытке доступа к узлу не возникает ошибок проверки подлинности.

  3. Запустите программу настройки служб Reporting Services и подключитесь к серверу отчетов, для которого предназначен новый веб-узел.

  4. На странице виртуального каталога сервера отчетов нажмите Создать.

  5. Выберите вновь созданный веб-узел и нажмите кнопку ОК.

  6. Если нужно настроить сервер отчетов на SSL-соединение, установите флажок Запросить соединение по протоколу SSL.

  7. Нажмите кнопку Применить, чтобы создать виртуальный каталог сервера отчетов.

  8. На странице виртуального каталога диспетчера отчетов нажмите Создать.

  9. Выберите вновь созданный веб-узел.Нажмите кнопку ОК.

  10. Нажмите кнопку Применить, чтобы создать виртуальный каталог диспетчера отчетов.

  11. Проверьте, доступен ли сервер отчетов, проверив его URL-адрес.Для этого введите его URL-адрес в окне веб-обозревателя.Если появилась ошибка HTTP 401, просмотрите статьи базы знаний Microsoft, перечисленные в начале раздела.

    Полный URL-адрес сервера отчетов включает в себя префикс, имя сервера и виртуальный каталог:

    Если пользовательскому веб-узлу был присвоен заголовок компьютера, используйте следующий синтаксис: http://<hostheader>/reportserver.

    Если пользовательскому веб-узлу был присвоен IP-адрес, убедитесь в том, что этот IP-адрес разрешается в имя узла, а затем используйте следующий синтаксис: http://<IP-адрес>/reportserver.

    Если пользовательскому веб-узлу был присвоен уникальный номер порта, добавьте номер порта к имени веб-сервера: http://<servername>:<portnumber>/reportserver.

  12. (Необязательно для некоторых конфигураций веб-узла).Отредактируйте файл RSWebApplication.config, чтобы обновить URL-адрес сервера отчетов, используемый диспетчером отчетов для соединения с сервером отчетов.

    Можно пропустить эти шаги, если пользовательскому веб-узлу присвоен конкретный IP-адрес и имя узла разрешается в этот IP-адрес. Также можно пропустить этот шаг, если веб-узел использует протокол SSL и порт 443, а при создании виртуального каталога сервера отчетов был установлен параметр SSL.

    Необходимо выполнить эти шаги, если пользовательским веб-узлом используются заголовки компьютера или собственный номер порта:

    1. Откройте файл RSWebApplication.config.

    2. Удалите запись в ReportServerVirtualDirectory.Удалите только значение; не удаляйте теги.

    3. В параметре ReportServerUrl введите полное имя экземпляра сервера отчетов.Это должно быть то же значение, что и использованное ранее для подтверждения URL-адреса сервера отчетов.

    Эти параметры должны быть похожи на следующий пример:

    Копировать код
    <ReportServerUrl>http://myhostheader/reportserver</ReportServerUrl>
<ReportServerVirtualDirectory></ReportServerVirtualDirectory>

    Настраивая несколько экземпляров сервера отчетов, повторите этот шаг для каждого экземпляра. Дополнительные сведения об этом файле конфигурации см. в разделе Файл конфигурации RSWebApplication электронной документации по SQL Server.

  13. Проверьте, доступен ли диспетчер отчетов, проверив URL-адрес. Например, если URL-адрес сервера отчетов http://<hostheader>/reportserver, URL-адресом диспетчера отчетов, скорее всего, будет http://<hostheader>/reports.

    Если возникнет ошибка «Запрос не выполнен, состояние HTTP 400:Неправильный запрос», указанный в файле RSWebApplication.config URL-адрес неправильный.

  14. Для доставки электронной почты с помощью сервера отчетов отредактируйте файл RSReportServer.config и задайте параметр конфигурации UrlRoot.Это значение должно быть полным URL-адресом сервера отчетов.Это должно быть то же значение, что и использованное на предыдущем шаге для подтверждения URL-адреса сервера отчетов. Дополнительные сведения об этом файле конфигурации см. в разделе Файл конфигурации RSReportServer электронной документации по SQL Server.

См. также

Задачи

Как запустить настройку служб Reporting Services

Основные понятия

Установка нескольких экземпляров служб Reporting Services
Настройка виртуальных каталогов сервера отчетов
Создание базы данных сервера отчетов
Разделы руководства по настройке служб Reporting Services


Как создать базу данных сервера отчетов (настройка служб Reporting Services)

Как создать базу данных сервера отчетов (настройка служб Reporting Services) |
 | См. также
Настройка установки SQL Server > Настройка служб Reporting Services > Разделы руководства по настройке служб Reporting Services >

Службы Reporting Services используют базу данных SQL Server в качестве внутреннего хранилища. База данных — это обязательный компонент. Она предназначена для хранения отчетов, данных сеанса, ресурсов и метаданных сервера.

При установке служб Reporting Services в конфигурации по умолчанию база данных сервера отчетов будет создана автоматически при установке экземпляра сервера отчетов. Однако если произведена установка «только файлы», по окончании установки необходимо создать базу данных. Для создания базы данных сервера отчетов пользуйтесь программой настройки служб Reporting Services.

Создание базы данных сервера отчетов

  1. Запустите программу настройки служб Reporting Services и подключитесь к экземпляру сервера отчетов, для которого необходимо создать базу данных. Дополнительные сведения о подключении к экземпляру сервера отчетов см. в разделе Как запустить настройку служб Reporting Services.

  2. На странице «Настройка базы данных» выберите или введите имя нужного экземпляра компонента SQL Server Database Engine. Можно выбрать экземпляр SQL Server 2000 или экземпляр SQL Server 2005. Для хранения базы данных подходит не любой выпуск. Дополнительные сведения о совместимости выпусков см. в разделе Создание базы данных сервера отчетов.

  3. Нажмите кнопку Соединить. Открывается диалоговое окно «Подключение к SQL Server», в котором можно указать учетные данные, обладающие разрешением на создание базы данных на сервере. Чтобы подключиться к серверу, нажмите кнопку ОК.

  4. Нажмите кнопку Создать на странице «Настройка базы данных». Диалоговое окно «Соединение с SQL Server» откроется еще раз.

  5. Введите имя базы данных сервера отчетов. Вместе с базой данных-источником будет создана временная база данных.

  6. Выберите язык параметров сортировки и нажмите кнопку ОК.

  7. На странице «Настройка базы данных», в поле «Тип учетных данных» укажите учетные данные, которые сервер отчетов будет использовать для соединения с базой данных сервера отчетов. Дополнительные сведения о том как выбрать другие учетные записи, см. в разделах Настройка учетных записей служб Windows и Настройка соединения с базой данных сервера отчетов.

    1. Выберите Учетные данные службы, если хотите использовать учетную запись службы Windows или веб-службы для соединения через встроенные средства безопасности.

    2. Выберите Учетные данные Windows, чтобы указать учетную запись пользователя домена. Учетная запись домена должна быть указана в формате <домен>\<пользователь>.

    3. Выберите Учетные данные SQL Server, чтобы указать имя входа SQL Server.

  8. Нажмите кнопку Применить.

См. также

Задачи

Как запустить настройку служб Reporting Services

Справочник

Настройка базы данных (конфигурация служб Reporting Services)

Основные понятия

Администрирование баз данных сервера отчетов
Создание базы данных сервера отчетов
Разделы руководства по настройке служб Reporting Services
Настройка соединения с базой данных сервера отчетов

Другие ресурсы

База данных сервера отчетов
Настройка компонентов служб Reporting Services
Программа конфигурации служб Reporting Services


Как создать базу данных сервера отчетов для режима интеграции с SharePoint (настройка служб Reporting Services)

Как создать базу данных сервера отчетов для режима интеграции с SharePoint (настройка служб Reporting Services) |
 | См. также
Настройка установки SQL Server > Настройка служб Reporting Services > Разделы руководства по настройке служб Reporting Services >

Новое содержимое: 12 декабря 2006 г.

Используйте программу настройки служб Reporting Services, поставляемую в составе SQL Server 2005 с пакетом обновления 2 (SP2), чтобы создать базу данных сервера отчетов для работы в режиме интеграции с SharePoint и настроить соединение сервера отчетов с базой данных сервера отчетов. Только сервер отчетов подключается к базе данных сервера отчетов. Службы Windows SharePoint Services или экземпляр Office SharePoint Server, с которыми интегрируется сервер отчетов, никогда напрямую не подключаются к базе данных сервера отчетов и не получают из нее данные.

База данных сервера отчетов может поддерживать операции в собственном режиме или в режиме интеграции с SharePoint, но не оба типа операций одновременно. Если база данных сервера отчетов создается для поддержки режима интеграции с SharePoint, впоследствии невозможно выполнить ее преобразование или миграцию для работы в собственном режиме экземпляра сервера отчетов. База данных сервера отчетов содержит метаданные, относящиеся к режиму (в частности, местоположение элементов и сведения о разрешениях), несовместимые с другим режимом.

В базе данных сервера отчетов, созданной для работы в режиме интеграции с SharePoint, сохраняются свойства сервера, моментальные снимки состояния выполнения отчета, журнал отчета, определения подписки и расписания. В ней хранятся вспомогательные копии отчетов, моделей отчетов, общих источников данных и ресурсов, предназначенные для повышения производительности обработки на сервере. Основным хранилищем для документов отчета являются базы данных содержимого SharePoint. Дополнительные сведения см. в разделе Хранение и синхронизация содержимого сервера отчетов с помощью баз данных SharePoint.

Создание базы данных сервера отчетов подразумевает выполнение трех шагов.

  • Подключитесь к экземпляру Database Engine, где расположена база данных.

  • Введите имя базы данных, установите флажок для использования режима интеграции с SharePoint и создайте базу данных.

  • Укажите учетные данные для соединения сервера отчетов с базой данных.

Обязательно выполните все три шага, прежде чем нажать кнопку Применить.

После создания базы данных выполните шаги по настройке интеграции, запустив центр администрирования SharePoint 3.0 и указав настройки интеграции сервера отчетов. Дополнительные сведения см. в разделе Как выполнить интеграцию сервера отчетов в центре администрирования SharePoint.

Создание базы данных сервера отчетов в режиме интеграции с SharePoint

  1. Нажмите кнопку Пуск, укажите Программы, затем укажите Microsoft SQL Server 2005, а затем Средства настройки.

  2. Щелкните Настройка служб Reporting Services. Отображается диалоговое окно Выбор экземпляра установки сервера отчетов, в котором можно выбрать настраиваемый экземпляр сервера отчетов.

  3. В поле Имя компьютера укажите имя компьютера, на котором установлен экземпляр сервера отчетов. По умолчанию указывается имя локального компьютера, но можно ввести имя удаленного экземпляра SQL Server.

    Если указан удаленный компьютер, для установления соединения нажмите кнопку Найти. Сервер отчетов должен быть заранее настроен для удаленного администрирования. Дополнительные сведения см. в разделе Настройка сервера отчетов для удаленного администрирования электронной документации по SQL Server.

  4. В поле Имя экземпляра выберите экземпляр служб SQL Server 2005 Reporting Services, который необходимо настроить. В списке отображаются только экземпляры сервера отчетов SQL Server 2005. Более ранние версии служб Reporting Services настраивать нельзя.

  5. Нажмите кнопку Соединить.

  6. Выберите Настройка базы данных, чтобы открыть страницу настройки базы данных.

  7. Введите имя компонента SQL Server Database Engine для использования.

  8. Нажмите кнопку Соединить.

  9. Нажмите кнопку Создать.

  10. В диалоговом окне Соединение с SQL Server введите имя для новой базы данных.

  11. Установите флажок Создать базу данных сервера отчетов в режиме интеграции с SharePoint.

  12. Нажмите кнопку ОК.

  13. На странице настройки базы данных укажите учетные данные, которые будут использоваться для соединения с базой данных сервера отчетов.

    1. Выберите Учетные данные службы, если хотите использовать учетную запись службы Windows или веб-службы для соединения через встроенные средства безопасности.

    2. Выберите Учетные данные Windows, чтобы указать учетную запись пользователя домена. Учетная запись домена должна быть указана в формате <домен>\<пользователь>.

    3. Выберите Учетные данные SQL Server, чтобы указать имя входа SQL Server.

  14. Нажмите кнопку Применить.

  15. Перезапустите службу Windows сервера отчетов.

См. также

Задачи

Как переключать режимы сервера (конфигурация служб Reporting Services)

Основные понятия

Настройка служб Reporting Services для интеграции с SharePoint 3.0
Режимы развертывания для служб Reporting Services
Настройка соединения с базой данных сервера отчетов
Администрирование баз данных сервера отчетов


Как выполнить интеграцию сервера отчетов в центре администрирования SharePoint

Как выполнить интеграцию сервера отчетов в центре администрирования SharePoint |
 | См. также
Настройка установки SQL Server > Настройка служб Reporting Services > Разделы руководства по настройке служб Reporting Services >

Новое содержимое: 12 декабря 2006 г.

Администратор сервера должен задать параметры интеграции, определяющие соединение между экземпляром технологии SharePoint и сервером отчетов служб Reporting Services.

Чтобы иметь возможность настраивать интеграцию сервера отчетов, необходимо быть администратором веб-узла или фермы SharePoint; также необходимо установить надстройку служб Reporting Services, содержащую страницы конфигурации. Кроме того, необходимо заранее настроить целевой сервер отчетов на работу в режиме интеграции с SharePoint.

Заданные пользователем настройки сохраняются в базе данных конфигурации. При настройке интеграции для фермы, включающей несколько виртуальных серверов, настройки будут использоваться для всех серверов, обслуживающих клиентские запросы в ферме SharePoint.

Задание настроек в центре администрирования является только одним из этапов настройки интеграции сервера. Дополнительные сведения о полном наборе шагов см. в разделе Настройка служб Reporting Services для интеграции с SharePoint 3.0.

Примечание.
После определения URL-адреса сервера отчетов следует впоследствии изменять его с осторожностью. Изменение URL-адреса сервера отчетов приведет к нарушению соединения между серверами, повлияет на выполняемую обработку отчетов и моделей. При изменении URL-адреса сервера отчетов на рабочем сервере обязательно следуйте запланированным процедурам простоя, предусмотренным в организации.

Задание настроек интеграции сервера отчетов в центре администрирования

  1. В разделе «Администрирование» выберите элемент Центр администрирования SharePoint 3.0.

  2. Перейдите на вкладку Управление приложениями.

  3. В разделе «Reporting Services» щелкните Управление параметрами интеграции. Если раздел «Reporting Services» недоступен, необходимо загрузить и установить надстройку Reporting Services.

    1. В поле URL-адрес веб-службы сервера отчетов задайте сервер отчетов, который нужно интегрировать с развертыванием SharePoint. Этим URL-адресом идентифицируется веб-узел сервера отчетов, используемый для текущего веб-узла или фермы SharePoint. URL-адрес может указывать на отдельный экземпляр сервера отчетов либо являться именем виртуального сервера для набора серверов отчетов со сбалансированной нагрузкой, работающего в масштабном развертывании. Ниже приводятся примеры URL-адресов сервера отчетов.

    • http://имя_сервера_отчетов (этот пример используется, если сервер отчетов установлен на другом компьютере).

    • http:///имя_сервера_отчетов:8080/сервер_отчетов (этот пример используется, если сервер отчетов находится на том же компьютере, что и развертывание интегрируемых служб SharePoint, а веб-узлу по умолчанию назначен порт 8080).

    • https://your-server-name:443/reportserver

      Если сервер отчетов и экземпляр технологии SharePoint установлены параллельно и технология SharePoint использует значения по умолчанию, для доступа к веб-узлу SharePoint более высокого уровня будет использоваться порт 80. При установке сервера отчетов на том же веб-сервере необходимо присвоить и использовать другой номер порта для веб-узла по умолчанию либо создать виртуальный каталог сервера отчетов для пользовательского веб-узла, уникально идентифицируемый по номеру порта, IP-адресу или заголовку компьютера. Дополнительные сведения об URL-адресах и виртуальном каталоге сервера отчетов см. в разделе Настройка виртуальных каталогов сервера отчетов.

  4. В разделе «Reporting Services» щелкните Предоставить доступ к базе данных. На этом шаге экземпляр сервера отчетов предоставляет сведения об учетной записи службы. Создается имя входа и разрешения для каждой учетной записи служб Reporting Services. Интеграция сервера отчетов служб Reporting Services с веб-приложением SharePoint требует, чтобы сервер отчетов имел доступ к базам данных конфигурации и содержимого технологии SharePoint. Как веб-служба сервера отчетов, так и служба Windows сервера отчетов, должны подключаться как доверенные пользователи с разрешениями чтения и записи.

    1. Укажите имя сервера отчетов. По умолчанию это имя компьютера.

    2. Укажите, является данный экземпляр экземпляром по умолчанию или именованным экземпляром. Чтобы выяснить это, запустите программу настройки служб Reporting Services и подключитесь к серверу отчетов. В диалоговом окне Выбор экземпляра разверните узел Имя экземпляра, чтобы просмотреть список всех экземпляров, установленных на сервере. MSSQLSERVER — имя экземпляра по умолчанию. Все остальные экземпляры являются именованными экземплярами.

    3. Нажмите кнопку ОК. Откроется диалоговое окно «Ввод учетных данных».

    4. В диалоговом окне Введите учетные данные укажите имя пользователя и пароль для соединения с сервером отчетов, чтобы получить учетные записи веб-службы и службы Windows. Убедитесь, что вводятся учетные данные для учетной записи, которая входит в состав группы «Администраторы» на компьютере сервера отчетов.

  5. В разделе «Reporting Services» нажмите кнопку Установить параметры сервера по умолчанию.

    1. В поле Параметры журнала отчета по умолчанию введите значение по умолчанию для сервера, которое будет определять количество хранящихся копий журнала отчета. Значение по умолчанию устанавливает начальные параметры, определяющие количество моментальных снимков, которые будут храниться для каждого отчета. На странице свойств конкретного отчета можно задать другие значения.

    2. В поле Время ожидания обработки отчета укажите время истечения срока обработки отчета сервером после заданного числа секунд. Это значение применяется для обработки отчетов на сервере отчетов. Оно не влияет на обработку данных на сервере баз данных, предоставляющем данные для отчета. Таймер обработки отчета включается при выборе отчета и останавливается после открытия отчета. Если это значение задано, укажите достаточное время для завершения обработки данных и обработки отчета.

    3. В разделе Журнал обработки отчета укажите, должен ли сервер отчетов создавать журнал трассировки, и количество дней, в течение которых будет храниться этот журнал. Можно определить, должны ли сервером отчетов создаваться журналы трассировки, а также задать число дней для хранения журналов. Журналы сохраняются на компьютере сервера отчетов в папке \Microsoft SQL Server\MSSQL.n\ReportServer\Log. При каждом перезапуске службы начинается запись нового файла журнала. Дополнительные сведения о файлах журналов см. в разделе Журналы трассировки служб Reporting Services.

    4. Флажок Включить встроенную безопасность Windows показывает, может ли соединение с источником данных отчета использовать маркер безопасности Windows для пользователя, запрашивающего отчет.

    5. Флажок Включить нерегламентированные отчеты показывает, могут ли пользователи выполнять нерегламентированные отчеты из отчета построителя отчетов. Установка этого флажка устанавливает свойство EnableLoadReportDefinition на сервере отчетов. Если снять этот флажок, сервер отчетов не будет формировать отчеты с дополнительной информацией, которые используют модель отчета в качестве источника данных.

    6. Нажмите кнопку ОК.

См. также

Основные понятия

Интеграция служб Reporting Services и технологии SharePoint
Настройка виртуальных каталогов сервера отчетов
Установка надстройки службы Reporting Services
Просмотр и управление элементами сервера отчетов с узла SharePoint

Другие ресурсы

Управление журналом отчета
Установка значений времени ожидания для выполнения отчета


Как переключать режимы сервера (конфигурация служб Reporting Services)

Как переключать режимы сервера (конфигурация служб Reporting Services) |
 | См. также
Настройка установки SQL Server > Настройка служб Reporting Services > Разделы руководства по настройке служб Reporting Services >

Новое содержимое: 12 декабря 2006 г.

При настройке сервера отчетов на работу в режиме интеграции с SharePoint можно отсоединить сервер отчета от развертывания экземпляра технологии SharePoint путем переключения сервера в собственный режим.

Чтобы переключить режимы, необходимо подключить сервер к базе данных сервера отчетов, находящейся в собственном режиме. Для переключения режимов не нужно переустанавливать сервер отчетов.

Хотя можно переключить режим сервера отчета, переключить режим базы данных сервера отчетов нельзя. База данных сервера отчетов содержит данные, которые рассчитаны на определенный режим и которые нельзя использовать в другом контексте. При создании базы данных сервера отчетов в режиме интеграции с SharePoint нельзя использовать ее с сервером отчетов, работающим в собственном режиме.

Если нужно удалить параметры интеграции как из сервера отчетов, так и из продукта или технологии SharePoint, необходимо также удалить надстройку служб Reporting Services. Дополнительные сведения см. в разделе Как удалить надстройку для использования служб Reporting Services.

Существует три способа перехода из режима интеграции с SharePoint в собственный режим. Для перехода из программы настройки служб Reporting Services со страницы «Установка базы данных» выполните одно из следующих действий.

  • Нажмите кнопку Изменить, чтобы создать новую базу данных.

  • Из списка существующих баз данных выберите базу данных сервера отчетов, которая уже работает в собственном режиме, укажите учетные данные и нажмите кнопку Применить.

  • Нажмите Создать, чтобы создать новую базу данных. Убедитесь, что снят флажок Создать базу данных сервера отчетов в режиме интеграции с SharePoint.

В этом разделе описаны шаги, необходимые для первого подхода. Дополнительные сведения о настройке сервера отчетов в собственном режиме для работы в режиме интеграции с SharePoint см. в разделе Настройка служб Reporting Services для интеграции с SharePoint 3.0.

Переключение в собственный режим

  1. Нажмите кнопку Пуск, укажите Программы, затем укажите Microsoft SQL Server 2005, а затем Средства настройки.

  2. Выберите Настройка служб Reporting Services. Отобразится диалоговое окно Выбор экземпляра установки сервера отчетов, в котором можно выбрать настраиваемый экземпляр сервера отчетов.

  3. В поле Имя компьютера укажите имя компьютера, на котором установлен экземпляр сервера отчетов. По умолчанию указывается имя локального компьютера, но можно ввести имя удаленного экземпляра SQL Server.

  4. В поле Имя экземпляра выберите экземпляр служб SQL Server 2005 Reporting Services, который необходимо настроить. В списке отображаются только экземпляры сервера отчетов SQL Server 2005. Более ранние версии служб Reporting Services настраивать нельзя.

  5. Нажмите кнопку Соединить.

  6. Нажмите кнопку Настройка базы данных для открытия страницы «Настройка базы данных». Страница содержит сведения о базе данных, которая используется в данный момент. Параметр Режим сервера должен быть установлен в значение Интеграция с SharePoint.

  7. Нажмите кнопку Изменить.

  8. Нажмите кнопку ОК для подтверждения создания новой базы данных.

  9. В диалоговом окне Соединение с SQL Server введите имя новой базы данных.

  10. Убедитесь, что установлен флажок Создать базу данных сервера отчетов в режиме интеграции с SharePoint.

  11. Нажмите кнопку ОК.

  12. На странице «Настройка базы данных» укажите учетные данные, которые сервер отчетов будет использовать для соединения с базой данных сервера отчетов.

    1. Выберите Учетные данные службы, если хотите использовать учетную запись службы Windows или веб-службы для соединения через встроенные средства безопасности.

    2. Выберите Учетные данные Windows, чтобы указать учетную запись пользователя домена. Учетная запись домена должна быть указана в формате <домен>\<пользователь>.

    3. Выберите Учетные данные SQL Server, чтобы указать имя входа SQL Server.

  13. Нажмите кнопку Применить.

При переключении в собственный режим сервера отчетов, интегрированного с SharePoint, местоположение содержимого и используемые для управления доступом разрешения определяются заново. Содержимое должно быть повторно опубликовано на сервере отчетов, нужно назначить роли на сервере отчетов, которые предоставляют доступ к элементам и операциям, и повторно определить подписки и запланированные операции. Журнал отчетов, который создан на сервере отчетов, работавшем в режиме интеграции с SharePoint, не может быть повторно создан на сервере отчетов, работающем в собственном режиме.

См. также

Задачи

Как удалить надстройку для использования служб Reporting Services
Как выполнить интеграцию сервера отчетов в центре администрирования SharePoint
Как создать базу данных сервера отчетов для режима интеграции с SharePoint (настройка служб Reporting Services)

Основные понятия

Режимы развертывания для служб Reporting Services
Настройка служб Reporting Services для интеграции с SharePoint 3.0
Настройка соединения с базой данных сервера отчетов


Как настроить масштабное развертывание сервера отчетов (настройка служб Reporting Services)

Как настроить масштабное развертывание сервера отчетов (настройка служб Reporting Services) |
 | См. также
Настройка установки SQL Server > Настройка служб Reporting Services > Разделы руководства по настройке служб Reporting Services >

Службы Reporting Services поддерживают модель масштабного развертывания, которая позволяет запускать несколько экземпляров сервера отчетов, совместно использующих одну базу данных сервера отчетов. Для создания масштабного развертывания используются программа установки и программа настройки служб Reporting Services. Программа установки выполняется для установки серверов отчетов. Программа настройки служб Reporting Services запускается для настройки каждого сервера отчетов, чтобы он использовал общую базу данных. Подключаться к серверам и выполнять настройку можно только единожды за один раз.

Во время указания базы данных сервера отчетов, которая будет использоваться для хранения внутренних данных, можно создать новую базы данных или обновить существующую базу данных сервера отчетов. В этом подразделе предполагается, что создается новая база данных сервера отчетов. Дополнительные сведения об обновлении базы данных сервера отчетов или существующего масштабного развертывания см. в разделах Обновление базы данных сервера отчетов и Обновление веб-фермы сервера отчетов.

Чтобы избежать проблем совместимости баз данных при подключении экземпляров сервера к совместно используемой базе данных, следует убедиться, что все экземпляры имеют одну и ту же версию. Например, если база данных сервера отчетов создается с помощью экземпляра сервера отчетов, имеющего версию с пакетом обновления 1 (SP1), необходимо установить пакет обновления 1 (SP1) на все остальные экземпляры, входящие в развертывание. Можно использовать экземпляры разных выпусков, если эти выпуски поддерживают масштабное развертывание. Дополнительные сведения см. в разделе Настройка масштабного развертывания сервера отчетов.

При установке новых экземпляров сервера отчетов, входящих в развертывание, можно выбрать, следует ли установить конфигурацию по умолчанию или выполнить установку только файлов (в мастере установки SQL Server это отражается параметром Установить, но не настраивать сервер на странице «Параметры установки сервера отчетов»). Здесь предполагается, что выполняется установка только файлов. Для настройки сервера после окончания работы программы установки будет необходимо запустить программу настройки служб Reporting Services. Дополнительные сведения см. в разделе Установка служб Reporting Services с помощью программы установки.

Примечание.
Доступ через виртуальный сервер и в кластерной конфигурации необходимо обеспечивать с помощью других продуктов. Службы Reporting Services не выполняют функций распределения нагрузки или функций виртуального сервера, позволяющих осуществлять доступ ко всем экземплярам сервера отчетов по общему URL-адресу.

Установка первого экземпляра сервера отчетов

  1. Установите первый экземпляр сервера отчетов, входящий в развертывание.

  2. Запустите программу настройки служб Reporting Services, а затем настройте виртуальные каталоги и учетные записи служб, пользуясь страницами «Виртуальный каталог сервера отчетов», «Виртуальный каталог диспетчера отчетов» и «Удостоверение веб-службы диспетчера отчетов». Дополнительные сведения см. в разделах Настройка виртуальных каталогов сервера отчетов и Как запустить настройку служб Reporting Services.

  3. На странице «Настройка базы данных» введите или выберите имя экземпляра SQL Server, на котором будет размещаться база данных сервера отчетов. Можно выбрать локальный или удаленный экземпляр. Можно использовать экземпляр SQL Server 2000 или экземпляр SQL Server 2005.

  4. Если выполняется соединение с удаленным экземпляром, может понадобиться разрешить для этого экземпляра удаленные соединения. В некоторых версиях SQL Server 2005 удаленные соединения по умолчанию не разрешены. Чтобы проверить, разрешены ли удаленные соединения, запустите средство настройки контактной зоны SQL Server и выясните значение параметра «Удаленные соединения» для требуемого экземпляра. Если удаленный экземпляр является именованным, убедитесь, что на целевом сервере включена и запущена служба «SQL Server, обозреватель». Эта служба сообщает программе настройки служб Reporting Services номер порта, который используется именованным экземпляром.

  5. Чтобы подключиться к экземпляру SQL Server, нажмите кнопку Соединить.

  6. Чтобы создать базу данных сервера отчетов, нажмите кнопку Создать. Отображается диалоговое окно Соединение с SQL Server.

    1. Укажите учетную запись, имеющую разрешение на создание базы данных.

    2. Для создания базы данных нажмите кнопку ОК.

  7. На странице установки базы данных в поле Тип учетных данных выберите тип учетной записи и укажите учетные данные, которые сервер отчетов будет использовать для подключения к базе данных сервера отчетов.

    При выборе Учетные записи служб и при использовании удаленного экземпляра SQL Server убедитесь в том, что учетные записи, под которыми выполняются службы, имеют сетевой доступ. Дополнительные сведения об учетных данных см. в разделе Настройка соединения с базой данных сервера отчетов.

  8. Нажмите кнопку Применить. Программа настройки служб Reporting Services создаст базу данных и настроит соединение.

  9. На странице «Ключи шифрования» создайте резервную копию симметричного ключа. Это проверенные на практике рекомендации. Рекомендуется всегда создавать резервную копию ключа при создании базы данных.

  10. На странице «Инициализация» убедитесь, что для экземпляра сервера отчетов была создана запись. Должен быть установлен флажок Инициализировано.

  11. (Необязательно) Завершите настройку сервера отчетов, определив параметры доставки по электронной почте и учетную запись для автоматического выполнения задач.

  12. (Необязательно) Убедитесь, что сервер отчетов работает. Дополнительные сведения см. в разделе Как проверить установки служб Reporting Services.

Установка и настройка второго экземпляра сервера отчетов

  1. Запустите программу установки, чтобы установить второй экземпляр служб Reporting Services на другом компьютере или в качестве именованного экземпляра на том же компьютере.

  2. Воспользуйтесь программой настройки служб Reporting Services для подключения к только что установленному экземпляру и настройки этого экземпляра. Дополнительные сведения см. в разделе Как запустить настройку служб Reporting Services.

  3. Настройте учетные записи служб и виртуальные каталоги нового экземпляра сервера. Можно использовать те же учетные записи и те же имена виртуальных каталогов, которые задавались для первого экземпляра, или выбрать новые.

  4. На странице «Настройка базы данных» в поле Имя сервера задайте экземпляр компонента SQL Server Database Engine, где размещена база данных сервера отчетов, которую нужно использовать. Это должен быть тот же сервер, к которому производилось подключение на шаге 3 предыдущего набора инструкций. Если используется удаленный экземпляр, обратитесь к шагу 3 предыдущего набора инструкций, где приведены рекомендации по подключению к удаленному экземпляру.

  5. Нажмите кнопку Соединить.

  6. На странице «Настройка базы данных» в поле Имя базы данных выберите базу данных, созданную на шаге 5 предыдущего набора инструкций. Если список баз данных пуст, повторите предыдущие два шага, чтобы установить соединение с сервером.

  7. На странице «Настройка базы данных» в поле Тип учетных данных выберите тип учетной записи и укажите учетные данные, которые сервер отчетов будет использовать для подключения к базе данных сервера отчетов. Можно использовать те же учетные данные, что и для первого экземпляра сервера отчета, или задать новые.

  8. Нажмите кнопку Применить. Отображается диалоговое окно Соединение с SQL Server. Чтобы подключиться к серверу, нажмите кнопку ОК. Сервер отчетов подключается к базе данных сервера отчетов и добавляет свои сведения о ключах. Сведения о ключах необходимы для инициализации.

  9. На странице «Инициализация» убедитесь, что для второго экземпляра сервера отчетов была создана запись. Флажок Инициализировано должен быть снят. Второй экземпляр сервера отчетов еще не инициализирован.

  10. Повторно подключитесь к первому экземпляру сервера отчетов. Поскольку он уже инициализирован для операций обратимого шифрования, он будет использоваться для инициализации нового экземпляра сервера отчетов для масштабного развертывания. Инициализация нового экземпляра сервера отчетов может быть выполнена из сервера отчетов, который уже инициализирован.

  11. На странице «Инициализация» выберите экземпляр сервера отчетов, который присоединяется к конфигурации, и щелкните Инициировать. После этого будет установлен флажок Инициализировано, свидетельствуя о том, что экземпляр сервера отчетов входит в масштабное развертывание. Чтобы изменения отобразились, возможно, понадобится обновить страницу. Если экземпляр сервера отчетов на странице «Инициализация» не указан, проверьте, настроен ли экземпляр для использования общей базы данных.

  12. Повторите эти шаги для добавления в конфигурацию других серверов отчетов. Если планируется запускать серверы отчетов в кластере, необходима дополнительная настройка. Дополнительные сведения см. в разделе Настройка масштабного развертывания сервера отчетов.

См. также

Задачи

Как запустить настройку служб Reporting Services

Основные понятия

Добавление и удаление ключей шифрования для масштабного развертывания
Разделы руководства по настройке служб Reporting Services


Как настроить базы данных сервера отчетов в ядре СУБД после его обновления с версии SQL Server 7.0 (конфигурация служб Reporting Services)

Как настроить базы данных сервера отчетов в ядре СУБД после его обновления с версии SQL Server 7.0 (конфигурация служб Reporting Services) |
 | См. также
Настройка установки SQL Server > Настройка служб Reporting Services > Разделы руководства по настройке служб Reporting Services >

Прежде чем создавать базу данных сервера отчетов на экземпляре компонента SQL Server Database Engine, установленного при обновлении с SQL Server 7.0, следует выполнить хранимую процедуру для задания уровня совместимости. Установка совместимости необходима, чтобы избежать следующего исключения: «Неправильный синтаксис около "COLLATE". Возможно, следует установить более высокое значение уровня совместимости текущей базы данных, чтобы включить эту функцию.»

Эта ошибка возникает при попытке создать базу данных на экземпляре SQL Server, установленном при обновлении с версии 7.0.

Задание уровня совместимости для обновленной базы данных

  1. Выполните команду exec sp_dbcmptlevel в главной базе данных. Дополнительные сведения см. в разделе sp_dbcmptlevel (Transact-SQL).

  2. Запустите программу настройки служб Reporting Services и подключитесь к экземпляру сервера отчетов, который необходимо настроить.

  3. На странице установки базы данных подключитесь к экземпляру компонента SQL Server Database Engine, для которого была выполнена хранимая процедура.

  4. Нажмите кнопку Создать, чтобы создать базу данных.

  5. Укажите имя базы данных и учетную запись, используемую для ее создания, а затем нажмите кнопку ОК.

  6. Укажите учетные данные для подключения к базе данных сервера отчетов. Дополнительные сведения см. в разделе Настройка соединения с базой данных сервера отчетов.

См. также

Основные понятия

Создание базы данных сервера отчетов
Разделы руководства по настройке служб Reporting Services


Как настроить сервер отчетов для работы с электронной почтой (конфигурация служб Reporting Services)

Как настроить сервер отчетов для работы с электронной почтой (конфигурация служб Reporting Services) |
 | См. также
Настройка установки SQL Server > Настройка служб Reporting Services > Разделы руководства по настройке служб Reporting Services >

Новое содержимое: 5 декабря 2005 г.

Электронная почта сервера отчетов — это модуль доставки по умолчанию для подписок; перед использованием он должен быть настроен.Для настройки сервера отчетов для доставки электронной почты требуется доступ к SMTP-серверу.Кроме того, необходимо разрешение на отправку электронной почты на SMTP-сервер для последующей доставки по реальным электронным адресам.

Если сервер отчетов не настроен для доставки электронной почты или нет доступа к SMTP-серверу, можно воспользоваться модулем доставки в общую папку для распространения отчетов в общие папки, доступные через сетевые соединения.

Для настройки электронной почты сервера отчетов можно либо использовать программу настройки служб Reporting Services, либо вручную изменить файлы конфигурации. Файл конфигурации служб Reporting Services обеспечивает минимальный набор настроек, необходимых для сервера отчетов. Если необходимо использовать локальную службу SMTP или задать дополнительные настройки, измените файлы конфигурации.

В зависимости от политик безопасности, применяемых организацией, может возникнуть необходимость заранее запрашивать разрешение на отправку электронной почты с корпоративного SMTP-сервера. Обратитесь к системному или сетевому администратору за дополнительными сведениями.

При необходимости оценить функциональность электронной почты сервера отчетов или решить проблему, связанную с подпиской или доставкой, можно настроить электронную почту сервера отчетов на использование локальной службы SMTP, доставляющей отчеты в локальную папку. Дополнительные сведения см. в разделе Настройка сервера отчетов для работы с электронной почтой.

Настройка электронной почты сервера отчетов с использованием программы настройки служб Reporting Services

  1. Убедитесь, что у службы Windows сервера отчетов есть разрешения Send As на SMTP-сервере. Запустите программу настройки служб Reporting Services и подключитесь к экземпляру сервера отчетов.

  2. На странице «Настройки электронной почты» введите имя SMTP-сервера. Это значение может быть IP-адресом, UNC-именем компьютера в корпоративной сети или полным именем домена.

  3. В поле Адрес отправителя введите имя учетной записи, имеющей разрешение на отправку электронной почты с SMTP-сервера.

  4. Нажмите кнопку Применить.

Настройка удаленной службы SMTP для сервера отчетов

  1. Убедитесь, что у службы Windows сервера отчетов есть разрешения Send As на SMTP-сервере.

  2. Откройте файл RSReportServer.config в текстовом редакторе.

  3. Убедитесь, что параметр <UrlRoot> настроен на URL-адрес сервера отчетов.Это значение устанавливается при настройке сервера отчетов, так что оно должно быть уже заполнено.Если оно не установлено, введите URL-адрес сервера отчетов.

  4. В разделе Delivery найдите параметр <ReportServerEmail>.

  5. В поле <SMTPServer> введите имя SMTP-сервера.Это значение может быть IP-адресом, UNC-именем компьютера в корпоративной сети или полным доменным именем.

  6. Убедитесь, что параметр <SendUsing> установлен в значение 2. Если установлено другое значение, значит сервер отчетов не настроен на использование удаленной службы SMTP.

  7. В поле <From> введите имя учетной записи, имеющей разрешение на отправку электронной почты с SMTP-сервера.

  8. Сохраните файл.

    Сервер отчетов автоматически будет использовать новые настройки; нет необходимости перезапускать службу.Можно указать дополнительные настройки SMTP для последующей конфигурации использования SMTP-сервера для доставки электронной почты на сервер отчетов.Дополнительные сведения см. в разделах Настройка сервера отчетов для работы с электронной почтой и Файл конфигурации RSReportServer.

Настройка локальной службы SMTP для сервера отчетов

  1. Откройте панель управления и щелкните элемент Установка и удаление программ.

  2. Выберите пункт Установка компонентов Windows, чтобы запустить мастер компонентов Windows.

  3. Выберите пункт Сервер приложений и нажмите кнопку Подробности.

  4. Выберите пункт службы IIS и нажмите кнопку Подробности.

  5. Установите флажок Служба SMTP и нажмите кнопку ОК.

  6. В мастере компонентов Windows нажмите кнопку Далее. Нажмите кнопку Готово.

  7. Убедитесь в том, что служба запущена, в консоли Службы.

  8. Откройте файл RSReportServer.config в текстовом редакторе.

  9. Убедитесь, что параметр <UrlRoot> настроен на URL-адрес сервера отчетов. Это значение устанавливается при настройке сервера отчетов так, что оно должно быть уже заполнено. Если оно не установлено, введите URL-адрес сервера отчетов.

  10. В разделе Delivery найдите параметр <ReportServerEmail>.

  11. В <SMTPServer> удалите значения параметра, но не удаляйте теги.

  12. Присвойте параметру <SendUsing> значение 1. Если установлено другое значение, это означает, что сервер отчетов не настроен на использование локальной службы SMTP.

  13. Присвойте параметру <SMTPServerPickupDirectory> в качестве значения имя папки на локальном жестком диске.

  14. В качестве значения параметра <From> укажите учетную запись, имеющей разрешение на отправку электронной почты с SMTP-сервера.

  15. Сохраните файл.

См. также

Основные понятия

Настройка сервера отчетов для работы с электронной почтой

Другие ресурсы

How to: Configure the Default Delivery Extension (Report Manager)
Доставка в общую папку с помощью служб Reporting Services
Доставка электронной почтой в службах Reporting Services
Программа конфигурации служб Reporting Services
Доставка отчетов через подписки


Как включите удаленный контроль ошибок (настройка служб Reporting Services)

Как включите удаленный контроль ошибок (настройка служб Reporting Services) |
 | См. также
Настройка установки SQL Server > Настройка служб Reporting Services > Разделы руководства по настройке служб Reporting Services >

Новое содержимое: 17 июля 2006 г.

Можно задать свойства сервера на сервере отчетов для возвращения дополнительных сведений об условиях возникновения ошибок на удаленных серверах. Если сообщение об ошибке содержит текст «Чтобы получить дополнительные сведения об этой ошибке, перейдите к серверу отчетов на локальном сервере или включите удаленный контроль ошибок», можно задать свойство EnableRemoteErrors для получения доступа к дополнительным сведениям, которые могут помочь в устранении возникшей неполадки.

Примечание.
Можно изменить таблицу ConfigurationInfo в базе данных сервера отчетов, чтобы присвоить параметру EnableRemoteErrors значение True, но, если сервер отчетов активно используется, для изменения настроек необходимо применить сценарий.

Включение удаленного контроля ошибок с помощью сценария

  1. Создайте текстовый файл и скопируйте в него следующий сценарий.

    Копировать код
    Public Sub Main()
  Dim P As New [Property]()
  P.Name = "EnableRemoteErrors"
  P.Value = True
  Dim Properties(0) As [Property]
  Properties(0) = P
  Try
    rs.SetSystemProperties(Properties)
    Console.WriteLine("Remote errors enabled.")
  Catch SE As SoapException
    Console.WriteLine(SE.Detail.OuterXml)
  End Try
End Sub

  2. Сохраните файл с именем EnableRemoteErrors.rss.

  3. Нажмите кнопку Пуск, укажите команду Выполнить, введите cmd и нажмите кнопку ОК, чтобы открыть окно командной строки.

  4. Перейдите к каталогу, содержащему только что созданный файл RSS.

  5. Введите в командной строке следующую команду, заменив местозаполнитель имя_сервера реальным именем сервера:

    Копировать код
    rs -i EnableRemoteErrors.rss -s http://servername/ReportServer

См. также

Другие ресурсы

Report Server System Properties
Настройка сервера отчетов для удаленного администрирования


Справка F1 по настройке служб Reporting Services

Справка F1 по настройке служб Reporting Services |
 | См. также
Настройка установки SQL Server > Настройка служб Reporting Services >

В этом разделе приводится справка F1 для программы настройки служб Reporting Services.

В этом разделе

Раздел | Описание
Состояние сервера отчетов (конфигурация служб Reporting Services) | Содержит сведения о настраиваемом экземпляре сервера отчетов.
Виртуальный каталог сервера отчетов (настройка служб Reporting Services) | Содержит сведения о конфигурации виртуальных каталогов на сервере отчетов.
Виртуальный каталог диспетчера отчетов (конфигурация служб Reporting Services) | Содержит сведения о конфигурации виртуальных каталогов, используемой для доступа к диспетчеру отчетов.
Идентификация служб Windows (конфигурация служб Reporting Services) | Содержит сведения о настройках службы Windows сервера отчетов.
Web Service Identity - Windows Server 2003 (Reporting Services Configuration) | Содержит сведения о настройках веб-службы сервера отчетов для служб IIS версии 6.0.
Идентификация веб-службы (настройка служб Reporting Services) | Содержит сведения о настройках веб-службы сервера отчетов для служб IIS версий 5.1 и 5.5.
Настройка базы данных (конфигурация служб Reporting Services) | Содержит сведения о базах данных сервера отчетов, в которых хранятся отчеты, модели отчетов и метаданные сервера. Используйте эту страницу, чтобы создать и настроить базу данных.
Ключи шифрования (конфигурация служб Reporting Services) | Содержит сведения о симметричных ключах, используемых для обратимого шифрования.
Инициализация (конфигурация служб Reporting Services) | Содержит сведения о добавлении и удалении экземпляров сервера отчетов из конфигурации с масштабным развертыванием.
Настройки электронной почты (конфигурация служб Reporting Services) | Содержит сведения о настройках модуля доставки электронной почты для сервера отчетов.
Учетная запись выполнения (конфигурация служб Reporting Services) | Содержит сведения о конфигурации учетной записи автоматического выполнения.

См. также

Задачи

Как запустить настройку служб Reporting Services

Другие ресурсы

Программа конфигурации служб Reporting Services
Настройка компонентов служб Reporting Services


Состояние сервера отчетов (конфигурация служб Reporting Services)

Состояние сервера отчетов (конфигурация служб Reporting Services) |
 | См. также
Настройка установки SQL Server > Настройка служб Reporting Services > Справка F1 по настройке служб Reporting Services >

Данная страница используется для просмотра данных о состоянии экземпляра сервера отчетов, с которым имеется соединение в настоящий момент. Данная страница является начальной для настройки сервера отчетов. Имеются дополнительные страницы для настройки виртуальных каталогов, учетных записей служб, базы данных сервера отчетов, доставки электронной почты сервера отчетов, конфигурации с масштабным развертыванием и инициализации одиночного сервера, а также управления симметричными ключами.

Легенда внизу страницы отображает значки, которые показывают, настроены ли параметры. Возможно задание настроек, которое приведет к недопустимой конфигурации. Необходимо всегда тестировать службы Reporting Services после установки, чтобы убедиться в их работоспособности. Визуальные признаки состояния настройки не являются заменой тестам, проверяющим удачное развертывание. Дополнительные сведения о проверке развертывания см. в разделе Как проверить установки служб Reporting Services.

Пользователи выпуска SQL Server 2005 Express Edition with Advanced Services (SQL Server Express) должны учесть следующие моменты:

  • электронная почта и масштабное развертывание сервера отчетов не поддерживаются в SQL Server Express;

  • база данных сервера отчетов должна находиться на локальном экземпляре компонента SQL Server Express Database Engine. Удаленный экземпляр SQL Server нельзя применять для размещения базы данных;

  • источники данных в отчетах также должны быть базами данных SQL Server, работающими на локальном экземпляре компонента SQL Server Express Database Engine. Никакие другие источники данных (в том числе удаленные) использовать нельзя. Для работы с другими типами источников данных следует пользоваться другим выпуском служб Reporting Services.

Параметры

Соединить

Открывает диалоговое окно выбора экземпляра установки сервера отчетов, чтобы можно было задать другой сервер для настройки. Для соединения требуется обладать правами локального администратора на компьютере, где запущен настраиваемый сервер отчетов.

Можно подключиться к локальному или удаленному экземпляру сервера отчетов. Дополнительные сведения см. в разделе Настройка сервера отчетов для удаленного администрирования электронной документации по SQL Server.

Обновить

Обновляет текущую страницу самым последним состоянием сервера отчетов.

Имя экземпляра (свойства экземпляра)

Отображает сведения об экземпляре сервера отчетов, с которым имеется соединение в текущий момент. Имена экземпляров сервера отчетов основаны на именованных экземплярах SQL Server. Экземпляр по умолчанию для сервера отчетов называется MSSQLSERVER. Для SQL Server Express имя экземпляра по умолчанию — SQLExpress.

Идентификатор экземпляра (свойства экземпляра)

Каждый компонент SQL Server 2005 может быть запущен в качестве отдельного экземпляра. Можно также запустить несколько экземпляров одного компонента. Каждому экземпляру компонента присваивается идентификатор, соответствующий папке файловой системы, где хранятся программные файлы этого экземпляра. Идентификаторы присваиваются программой установки в том порядке, в котором устанавливаются экземпляры. Например, при установке экземпляра Database Engine, экземпляра Analysis Services и экземпляра Reporting Services Database Engine будет установлен первым (как MSSQL.1), Analysis Services будет установлен вторым (как MSSQL.2), а Reporting Services будет установлен третьим (как MSSQL.3). При установке второго экземпляра компонента, который уже установлен (например, другого экземпляра Database Engine), он будет установлен как MSSQL.4.

Инициализировано (свойства экземпляра)

Указывает, является ли сервер отчетов функционирующим и возможно ли сохранение и получение с него зашифрованных данных.

Состояние сервера (свойства экземпляра)

Указывает, запущена ли служба Windows сервера отчетов.

Пуск

Запускает службу Windows сервера отчетов. Перезапуск службы Windows необходим после некоторых изменений конфигурации (например, при перенастройке сервера отчетов после изменения имени компьютера).

Стоп

Останавливает службу Windows сервера отчетов. Остановка службы приводит к прекращению работы сервера отчетов. Дополнительные сведения см. в разделе Запуск и остановка службы Windows сервера отчетов.

Условные обозначения

Отображает значки, используемые на каждой странице конфигурации для обозначения состояния определенных категорий настроек.

Не поддерживается в текущем режиме относится к режиму развертывания сервера, который может работать в собственном режиме или в режиме интеграции с SharePoint. Если сервер специально не настроен на работу в режиме интеграции с SharePoint, настройки конфигурации для этого режима помечаются как «неподдерживаемые» Дополнительные сведения о режимах см. в разделе Режимы развертывания для служб Reporting Services электронной документации по SQL Server.

См. также

Задачи

Как запустить настройку служб Reporting Services

Основные понятия

Справка F1 по настройке служб Reporting Services
Инициализация сервера отчетов
Установка нескольких экземпляров служб Reporting Services

Другие ресурсы

Настройка компонентов служб Reporting Services


Виртуальный каталог сервера отчетов (настройка служб Reporting Services)

Виртуальный каталог сервера отчетов (настройка служб Reporting Services) |
 | См. также
Настройка установки SQL Server > Настройка служб Reporting Services > Справка F1 по настройке служб Reporting Services >

Можно настроить виртуальный каталог для сервера отчетов при помощи страницы «Виртуальный каталог сервера отчетов». Имя виртуального каталога является частью URL-адреса, используемого для доступа к веб-службе сервера отчетов. Полный URL-адрес содержит префикс (http:// или https://), имя сервера и виртуальный каталог. Имя сервера может быть именем компьютера во внутренней сети или полным именем домена, разрешаемым сервером имени домена, в частной или публичной сети.

Веб-службе сервера отчетов необходим выделенный виртуальный каталог, который используется только сервером отчетов. Все настройки служб IIS, необходимые для служб Reporting Services, настраиваются через созданный виртуальный каталог.

Можно использовать эту страницу для создания виртуального каталога сервера отчетов или повторного применения настроек по умолчанию к существующему виртуальному каталогу. Чтобы создать виртуальный каталог при первой установке служб Reporting Services, нажмите Создать. При создании виртуального каталога программа настройки служб Reporting Services создает и настраивает виртуальный каталог при помощи служб IIS. Данное приложение также обновляет файлы конфигурации, внося URL-адрес сервера отчетов. Если на компьютере имеется сертификат протокола SSL, можно задать применение сертификата для всех вызовов веб-службы сервера отчетов.

Нельзя выбрать виртуальный каталог, созданный ранее. При необходимости повторного использования имени виртуального каталога, следует воспользоваться диспетчером IIS для удаления виртуального каталога. Затем можно использовать эту страницу для создания нового виртуального каталога с ранее применявшимся именем.

Примечание.
Службам Reporting Services необходим выделенный виртуальный каталог для сервера отчетов. Нельзя использовать существующий каталог. Для каждого нового развертывания необходимо создавать новый виртуальный каталог для доступа сервера отчетов.

Параметры

Имя

Указывает имя виртуального каталога.

Веб-узел

Указывает имя веб-узла, используемого для доступа к экземпляру сервера отчетов.

При работе с пользовательским веб-узлом обычно необходима дополнительная настройка во избежание ошибок отказа в доступе. Дополнительные сведения см. в разделе How to: Configure Reporting Services to Use a Non-Default Web Site (Reporting Services Configuration).

Создать

Открывает диалоговое окно Создание виртуального каталога, в котором можно выбрать существующий веб-узел в качестве узла сервера отчетов и ввести имя виртуального каталога. Необходимо задать уникальное имя для виртуального каталога. Узел должен быть существующим веб-узлом.

Применить настройки по умолчанию

Нажмите кнопку Применить настройки по умолчанию для замены текущих настроек виртуального каталога на конфигурации по умолчанию. Никакие пользовательские настройки не сохраняются.

Требуются безопасные соединения по протоколу SSL

Установите этот флажок, чтобы задать уровень соединения SSL. Для данного параметра необходим установленный сертификат. Можно также изменить параметры конфигурации UrlRoot в файле RSReportServer.config, чтобы они указывали полное имя компьютера, для которого регистрируется сертификат. Дополнительные сведения см. в разделе Настройка сервера отчетов для соединений по протоколу SSL электронной документации по SQL Server.

Запрос для:

Указывает уровень соединения SSL в свойствах сервера отчетов. Существует три уровня, они приведены ниже.

1 — Только соединения

2 — Данные отчета

3 — Полный API-интерфейс веб-службы

Данные уровни являются совокупными. Уровень 3 является наиболее безопасным. Уровень 0 не представлен значением в раскрывающемся списке, однако его можно использовать, чтобы указать на отсутствие соединения по протоколу SSL. Дополнительные сведения см. в разделе Using Secure Web Service Methods электронной документации по SQL Server.

Имя сертификата

Указывает полное имя компьютера, для которого регистрируется сертификат. Указанное имя должно быть идентично имени, на которое зарегистрирован этот сертификат.

См. также

Основные понятия

Справка F1 по настройке служб Reporting Services
Настройка виртуальных каталогов сервера отчетов
Настройка сервера отчетов для доступа через Интернет


Виртуальный каталог диспетчера отчетов (конфигурация служб Reporting Services)

Виртуальный каталог диспетчера отчетов (конфигурация служб Reporting Services) |
 | См. также
Настройка установки SQL Server > Настройка служб Reporting Services > Справка F1 по настройке служб Reporting Services >

Используйте страницу «Виртуальный каталог диспетчера отчетов» для создания виртуального каталога, используемого для доступа к диспетчеру отчетов, или для повторного применения настроек по умолчанию к виртуальному каталогу диспетчера отчетов. Имя виртуального каталога является частью URL-адреса, используемого для доступа к диспетчеру отчетов.

При создании виртуального каталога для новой установки служб Reporting Services, чтобы задать имя, нажмите кнопку Создать. При определении виртуального каталога программа настройки служб Reporting Services создает и выполняет настройку виртуального каталога через службы IIS. Файлы конфигурации с именем виртуального каталога диспетчера отчетов при этом обновляются.

При настройке сервера отчетов для работы в режиме интеграции с SharePoint не следует создавать виртуальный каталог. Диспетчер отчетов не поддерживается на сервере отчетов, работающем в режиме интеграции с SharePoint.

Примечание.
Для служб Reporting Services требуется выделенный виртуальный каталог для диспетчера отчетов. Нельзя использовать существующий каталог. При новом развертывании необходимо создать новый виртуальный каталог для диспетчера отчетов.

Нельзя выбрать виртуальный каталог, созданный ранее. При необходимости повторного использования имени виртуального каталога следует воспользоваться диспетчером IIS для удаления виртуального каталога. Затем можно использовать эту страницу для создания нового виртуального каталога с ранее применявшимся именем.

Параметры

Имя

Указывает имя виртуального каталога.

Веб-узел

Указывает имя веб-узла, который используется для доступа к диспетчеру отчетов.

Создать

Открывает диалоговое окно Создание виртуального каталога, в котором можно выбрать существующий веб-узел в качестве узла сервера отчетов и ввести имя виртуального каталога. Необходимо ввести уникальное имя виртуального каталога. Узел должен быть существующим веб-узлом.

Применить установки по умолчанию

Нажмите кнопку Применить установки по умолчанию для замены текущих настроек виртуального каталога на настройки по умолчанию. Никакие пользовательские настройки не сохраняются.

См. также

Основные понятия

Справка F1 по настройке служб Reporting Services
Настройка виртуальных каталогов сервера отчетов
Режимы развертывания для служб Reporting Services

Другие ресурсы

Диспетчер отчетов


Идентификация служб Windows (конфигурация служб Reporting Services)

Идентификация служб Windows (конфигурация служб Reporting Services) |
 | См. также
Настройка установки SQL Server > Настройка служб Reporting Services > Справка F1 по настройке служб Reporting Services >

Дата обновления: 12 декабря 2006 г.

Используйте страницу «Идентификация служб Windows» для определения учетной записи, под которой будет выполняться служба сервера отчетов Windows. Начальная конфигурация этой учетной записи выполняется программой установки. Ее можно изменить, если необходимо изменить учетную запись или пароль.

Настоятельно рекомендуется использовать программу настройки служб Reporting Services для обновления удостоверения службы, так как другие внутренние настройки, которые зависят от удостоверения службы, при изменении удостоверения службы автоматически обновляются.

При выборе учетной записи полезно знать, как используется служба. Служба Windows сервера отчетов используется для инициализации сервера отчетов, она может шифровать и сохранять конфиденциальные данные, запускать запланированную обработку отчетов и подписки в фоновом режиме и поддерживать базу данных сервера отчетов.

В типы учетных записей, которые можно выбрать для служб Windows, входит учетная запись пользователя домена, локальная учетная запись пользователя или встроенная учетная запись (такая как Сетевая служба, Локальная служба или Локальная система). Для большинства задач, которые служба Windows должна выполнить, тип выбранной учетной записи не влияет на ее возможность выполнять эти задачи. Служба Windows сервера отчетов обладает полной функциональностью, вне зависимости от того, какой тип учетной записи выбран.

Рекомендуется использовать учетные записи домена и учетную запись Сетевая служба. Обе обладают одинаковыми преимуществами доступа к контроллерам домена сети, общим папкам и корпоративным серверам электронной почты. Обе обеспечивают работу службы Windows сервера отчетов с разрешениями для имен для входа в сеть.

Локальные учетные записи Windows или встроенные локальные учетные записи могут успешно использоваться, но они имеют определенные требования, и необходимо принимать во внимание соображения по установке других настроек конфигурации, а также по созданию и доставке подписок.

  • Работа службы под локальной учетной записью ограничит возможности позже, при настройке подключений к удаленной базе данных сервера отчетов. В частности, если используется удаленная база данных сервера отчетов, для настройки подключения будет необходимо использовать учетную запись домена или пользователя базы данных SQL Server, которая обладает разрешением на подключение к удаленному экземпляру SQL Server.

  • Работа службы под локальной учетной записью накладывает новые требования на создание подписок. Сервер отчетов хранит сведения о пользователе, который создал подписку. Если пользователь создает подписку во время того, как он подключен под учетной записью домена, то служба Windows сервера отчетов будет пытаться подключиться к контроллеру домена для проверки подлинности пользователя при обработке подписки. Если служба Windows сервера отчетов работает под локальной учетной записью, то запрос проверки подлинности окажется неудачным при попытке сервера отчета отправить запрос на удаленный контроллер домена. Чтобы обойти это ограничение, можно использовать модуль проверки подлинности на основе пользовательских форм или подключить всех пользователей к серверу отчета под локальной учетной записью пользователя.

  • Работа службы под локальной учетной записью накладывает новые требования на доставку подписок. Некоторые модули доставки имеют сведения об учетных записях пользователя в определении подписок. При отправке отчетов по адресам электронной почты, основанным на учетных записях пользователей домена и запуске службы Windows сервера отчета под локальной учетной записью, становится невозможным доступ к удаленному контроллеру домена для разрешения целевой учетной записи электронной почты.

При обновлении идентификации служб Windows используйте следующие правила.

Учетная запись Объяснение

Учетные записи домена

Учетные записи домена Windows используются для служб SQL Server по умолчанию.

Выбирайте учетную запись домена, если для службы Windows сервера отчетов необходим доступ к удаленным компьютерам либо если нужно точно настроить разрешения для службы. Убедитесь, что выбрали учетную запись с минимальными разрешениями.

Избегайте использования учетных записей домена, если не нужно изменять пароль или учетную запись из-за политик истечения срока действия, используемых в организации.

Сетевая служба

Это встроенная учетная запись, обладающая минимальными правами доступа, которая обладает разрешениями на подключение к сети. Это установленная по умолчанию учетная запись, используемая для запуска веб-службы сервера отчетов в Microsoft Windows Server 2003 и Windows XP с пакетом обновлений 2 (Сетевая служба недоступна в других операционных системах Windows), также ее можно использовать для запуска службы Windows.

Выберите Сетевая служба, если нужно избежать простоя, который может произойти в результате политики истечения срока действия пароля. Избегайте использования Сетевая служба, если не хотите запускать сервер отчетов под учетными записями, которые могут использоваться также и другими приложениями.

Локальная служба

Это встроенная учетная запись, подобная учетной записи пользователя, прошедшего проверку подлинности. Службы, запущенные с учетной записью Локальная служба, получают доступ к сетевым ресурсам в форме неопределенного сеанса без учетных данных.

Данная учетная запись не подходит для сценариев развертывания, использующих корпоративные сети. Если проверка подлинности пользователя выполняется сетевым контроллером домена или если нужно использовать учетную запись службы для подключения удаленной базы данных сервера отчетов, выберите другую учетную запись.

Локальная служба является установленной по умолчанию учетной записью службы для сервера отчетов, установленного через выпуск SQL Server 2005 Express Edition with Advanced Services. Этот выпуск обладает встроенными ограничениями, которые запрещают доступ к удаленным серверам и функциями подписок, поэтому неспособность службы Windows получить доступ к сетевым ресурсам не является проблемой. Дополнительные сведения о возможностях сервера отчетов в выпуске Express Edition см. в разделе Reporting Services in SQL Server 2005 Express Edition with Advanced Services.

Локальная система

Избегайте использования данной учетной записи при установках сервера отчетов. Локальная система является учетной записью с высокими правами доступа, которые не обязательны для запуска сервера отчетов. Вместо нее выберите учетную запись домена, учетную запись Сетевая служба или учетную запись Локальная служба.

Если пользователь переключает учетную запись (например, заменяя одну учетную запись Windows другой или меняя встроенную учетную запись на учетную запись домена Windows), то ему будет предложено создать резервную копию симметричного ключа. Резервная копия будет восстанавливаться автоматически при выборе новой учетной записи.

Примечание.
Программа настройки служб Reporting Services напомнит, что надо проводить резервное копирование и восстановление ключа шифрования каждый раз при изменении учетной записи службы. Эти шаги необходимы для обеспечения доступности зашифрованных данных серверу отчетов. Дополнительные сведения об этих действиях см. в разделе Ключи шифрования (конфигурация служб Reporting Services).

Параметры

Имя службы

Определяет имя учетной записи службы сервера отчетов Windows (ReportServer).

Учетная запись службы

Определяет учетную запись, в качестве которой выполняется служба Windows. Можно выбрать только существующую учетную запись, новые учетные записи в конфигурации служб Reporting Services создавать нельзя.

Встроенная учетная запись

Выберите этот параметр для выбора встроенной системной учетной записи.

Учетная запись Windows

Выберите этот параметр для выбора учетной записи домена или локальной учетной записи.

Имя пользователя

Определите учетную запись домена в формате: <домен>\<пользователь>. Укажите локальную учетную запись пользователя Windows в таком формате: <имя компьютера>\<пользователь>.

Пароль

Укажите пароль.

Журнал изменений

Версия Журнал

12 декабря 2006 г.

Измененное содержимое:
  • Все содержимое было уточнено и расширено.

17 июля 2006 г.

Новое содержимое:
  • Таблица правил.

См. также

Задачи

Как Настройка учетных записей служб (конфигурация служб Reporting Services)

Основные понятия

Настройка учетных записей и паролей служб в службах Reporting Services
Справка F1 по настройке служб Reporting Services
Запуск и остановка службы Windows сервера отчетов

Другие ресурсы

Сервер отчетов


Web Service Identity - Windows Server 2003 (Reporting Services Configuration)

Web Service Identity - Windows Server 2003 (Reporting Services Configuration) |
 | См. также
Настройка установки SQL Server > Настройка служб Reporting Services > Справка F1 по настройке служб Reporting Services >

Дата обновления: 17 июля 2006 г.

Эта страница предназначена для просмотра и изменения учетной записи службы, используемой веб-службой сервера отчетов, который выполняется под управлением служб IIS 6.0.

Учетная запись веб-службы сервера отчетов настраивается автоматически при создании виртуального каталога сервера отчетов. Веб-служба выполняется под удостоверением безопасности, настраиваемым для пула приложений выбранного веб-узла. Однако веб-службу можно запускать под другой учетной записью, выбрав и создав пул приложений, настроенный для учетной записи, которую нужно использовать.

Для назначения пула приложений рекомендуется всегда пользоваться программой настройки служб Reporting Services вместо диспетчера IIS, чтобы все нужные настройки, затрагиваемые этим изменением, обновлялись автоматически. В частности, при использовании учетных записей служб для соединения с базой данных сервера отчетов средство предоставляет новой учетной записи доступ к базе данных сервера отчетов каждый раз при изменении удостоверения веб-службы и обновляет ключи шифрования таким образом, чтобы существующие зашифрованные данные были доступны для новой учетной записи. При использовании других средств для создания или настройки пула приложений, настройка сервера отчетов может быть неполной.

Использование учетной записи, не являющейся учетной записью по умолчанию, для пулов приложений

По умолчанию пулы приложений функционируют под учетной записью Network Service, имеющей минимальный набор прав, с сетевыми учетными данными для поддержки соединений с удаленными серверами. В зависимости от требований развертывания учетная запись Network Service может оказаться неподходящей, если планируется использовать учетную запись домена исключительно для операций сервера отчетов. Инструкции и рекомендации по запуску приложений ASP.NET под учетной записью домена см. в статье Как в MSDN.

Обратите внимание на то, что при использовании учетной записи домена, настроенного на проверку подлинности Kerberos, можно столкнуться с ошибками отказа в доступе HTTP 401, если не создать основное имя службы (SPN), регистрирующее учетную запись домена для веб-узла. Убедитесь в том, что регистрируемая учетная запись домена совпадает с учетной записью, используемой для пула приложений. Дополнительные сведения см. на странице Настройка ограниченного делегирования для Kerberos (службы IIS 6.0) на веб-узле Microsoft TechNet.

Примечание.
Настройка SPN является глобальной настройкой в службах IIS. После настройки SPN все пулы приложений, определенные на веб-сервере, должны запускаться под удостоверением SPN. Для настройки SPN необходимо быть администратором домена.

Об индикаторах в виде красного крестика (X)

Иногда после обновления версии служб Reporting Services рядом с идентификатором веб-службы в области навигации может появиться красный крестик (X). Такое может произойти в случае, если настройки предыдущей установки по-прежнему сохраняются в IIS или если на одном компьютере запущено несколько экземпляров сервера отчетов, и для всех этих экземпляров используется один пул приложений.

Красный крестик указывает на наличие расхождения между фактическим удостоверением веб-службы и данными удостоверения веб-службы, сохраненными поставщиком WMI служб Reporting Services. Это расхождение возникает при изменении параметров удостоверения веб-службы в файлах конфигурации. На странице «Удостоверение веб-службы» в разделе Учетная запись службы ASP.NET отображается фактическое удостоверение веб-службы. В некоторых случаях можно синхронизировать настройки, нажав кнопку Применить.

Если это не помогает решить проблему, выберите другой пул приложений или нажмите кнопку Создать, чтобы создать новый пул приложений для сервера отчетов. Указав новый пул приложений, нажмите кнопку Применить, чтобы сохранить изменения.

Примечание.
Если Учетная запись службы ASP.NET пуста, могут возникнуть проблемы с заданием элемента <configuration> в файле Web.config сервера отчетов. Если для изменения файла Web.config использовался редактор Visual Studio, им могло быть добавлено пространство имен к элементу <configuration>. Если элемент <configuration> выглядит как <configuration xmlns="http://schemas.microsoft.com/.NetConfiguration/v2.0">, удалите пространство имен, чтобы элемент приобрел следующий вид: <configuration>.

Параметры

Сервер отчетов

Задает пул приложений для веб-службы сервера отчетов.

Диспетчер отчетов

Задает пул приложений для диспетчера отчетов. По умолчанию диспетчер отчетов использует тот же пул приложений, что и сервер отчетов.

Создать

Создать новый пул приложений и задать встроенную учетную запись или учетную запись пользователя домена для удостоверения безопасности.

Сервер отчетов и диспетчер отчетов могут работать в одном пуле приложений, однако можно выбрать различные пулы приложений, чтобы изолировать их.

См. также

Задачи

Как Настройка учетных записей служб (конфигурация служб Reporting Services)

Основные понятия

Настройка учетных записей и паролей служб в службах Reporting Services
Настройка соединения с базой данных сервера отчетов
Настройка виртуальных каталогов сервера отчетов
Справка F1 по настройке служб Reporting Services
Администрирование службы Windows и веб-службы сервера отчетов

Другие ресурсы

Introducing the Report Server Web Service

Журнал изменений

Версия Журнал

12 декабря 2006 г.

Измененное содержимое
  • Добавлены сведения о решения проблем, обозначаемых индикатором в виде красного крестика.

17 июля 2006 г.

Новое содержимое
  • Добавлены сведения о трактовке индикаторов в виде красного крестика.

  • Добавлены сведения об использовании учетных записей, не являющихся учетными записями по умолчанию.


Идентификация веб-службы (настройка служб Reporting Services)

Идентификация веб-службы (настройка служб Reporting Services) |
 | См. также
Настройка установки SQL Server > Настройка служб Reporting Services > Справка F1 по настройке служб Reporting Services >

На этой странице можно просмотреть данные учетной записи, используемые веб-службой сервера отчетов. Учетная запись веб-службы сервера отчетов настраивается при создании виртуального каталога сервера отчетов.

Эта страница появляется при использовании служб IIS 5.0 или 5.01, или если службы IIS 6.0 работают в режиме изоляции. Если используются эти версии служб IIS, то нельзя настроить удостоверение веб-службы сервера отчетов. Он всегда выполняется с удостоверением процесса ASP.NET.

См. также

Задачи

Как Настройка учетных записей служб (конфигурация служб Reporting Services)

Основные понятия

Настройка виртуальных каталогов сервера отчетов
Справка F1 по настройке служб Reporting Services
Настройка учетных записей и паролей служб в службах Reporting Services
Администрирование службы Windows и веб-службы сервера отчетов

Другие ресурсы

Introducing the Report Server Web Service


Настройка базы данных (конфигурация служб Reporting Services)

Настройка базы данных (конфигурация служб Reporting Services) |
 | См. также
Настройка установки SQL Server > Настройка служб Reporting Services > Справка F1 по настройке служб Reporting Services >

Дата обновления: 12 декабря 2006 г.

Страница «Настройка базы данных» используется для создания и настройки баз данных сервера отчетов, предназначенных для внутреннего хранения одного или нескольких экземпляров сервера отчетов. Создание базы данных сервера отчетов и настройка подключения представляет собой многоэтапный процесс. Очень важно выполнить все необходимые шаги:

  • Укажите экземпляр ядра СУБД SQL Server и нажмите кнопку Подключиться.

  • Выберите, создайте или обновите базу данных сервера отчетов. Нажмите кнопку Создать, чтобы создать новую базу данных. Чтобы использовать существующую базу данных, выберите ее из списка. Нажмите кнопку Обновить, если существующая база данных создана при предыдущей установке.

  • Назначьте разрешения и создайте имя входа для использования при подключении к базе данных. Эти шаги выполняются средством после нажатия кнопки Применить. Можно следить за ходом выполнения шагов 2 и 3 в области «Состояние задачи». Обязательно прокрутите сообщения до конца, чтобы убедиться, что все шаги завершены успешно.

Базой данных сервера отчетов должен поддерживаться определенный режим сервера. Режимом по умолчанию является собственный режим, но можно также создать базу данных сервера отчетов для работы в режиме интеграции с SharePoint, если сервер отчетов используется в крупномасштабном развертывании продукта или технологии SharePoint. Дополнительные сведения см. в разделе Как создать базу данных сервера отчетов (настройка служб Reporting Services) и Как создать базу данных сервера отчетов для режима интеграции с SharePoint (настройка служб Reporting Services).

Примечание.
В выпуске SQL Server 2005 Express Edition with Advanced Services необходимо для хранения баз данных сервера отчетов пользоваться локальным экземпляром компонента SQL Server Express Database Engine. Если создается база данных сервера отчетов на экземпляре SQL Server, обновленном с версии 7.0, может потребоваться настроить уровень совместимости базы данных перед ее созданием. Дополнительные сведения см. в разделе Reporting Services in SQL Server 2005 Express Edition with Advanced Services и Как настроить базы данных сервера отчетов в ядре СУБД после его обновления с версии SQL Server 7.0 (конфигурация служб Reporting Services).

Параметры

Имя сервера

Позволяет задать имя компонента SQL Server Database Engine, на котором запущена база данных сервера отчетов.

Можно использовать экземпляр SQL Server 2000 или экземпляр SQL Server 2005. Можно использовать экземпляр по умолчанию или именованный экземпляр на локальном или удаленном компьютере.

При подключении к именованному экземпляру введите имя сервера в следующем формате: <сервер>\<экземпляр>.

Если выполняется соединение с удаленным экземпляром, может понадобиться разрешить для этого экземпляра удаленные соединения. В некоторых версиях SQL Server 2005 удаленные соединения по умолчанию не разрешены. Чтобы проверить, разрешены ли удаленные соединения, запустите средство настройки контактной зоны SQL Server и выясните значение параметра «Удаленные соединения» для требуемого экземпляра. Если удаленный экземпляр является также и именованным экземпляром, убедитесь в том, что служба обозревателя SQL Server включена и запущена на целевом сервере. Обозреватель SQL Server предоставляет номер порта, используемый именованным экземпляром, программе настройки служб Reporting Services.

Соединить

Выберите Соединение для создания соединения с компонентом SQL Server Database Engine. Откроется диалоговое окно «Соединение с SQL Server», где можно задать учетные данные, используемые для соединения с сервером. Можно использовать учетные данные текущего пользователя или задать имя входа на SQL Server.

Имя базы данных

Позволяет указать имя базы данных сервера отчетов, в которой хранятся серверные данные. Можно указать существующую базу данных или создать новую.

Выберите существующую базу данных в случае обновления или миграции установленных служб Reporting Services. Для выбора доступны только базы данных, содержащие таблицы сервера отчетов.

Если выбрана база данных сервера отчетов, созданная с помощью версии служб Reporting Services из состава SQL Server 2000, можно обновить эту базу данных до нового формата.

Версия базы данных

Определяет версию экземпляра компонента SQL Server Database Engine, где расположена база данных сервера отчетов.

Режим сервера

Указывает на то, поддерживается ли базой данных сервера отчетов собственный режим или режим интеграции с SharePoint. Выбранным режимом сервера определяется структура базы данных сервера отчетов и присваивается свойству SharePointIntegrated сервера отчетов значение true. Дополнительные сведения см. в разделе Режимы развертывания для служб Reporting Services.

Создать

Щелкните Создать, чтобы создать новую базу данных на экземпляре SQL Server, к которому в данный момент установлено подключение. Откроется диалоговое окно «Соединение с SQL Server», где можно задать учетные данные, имеющие разрешение на создание новой базы данных на данном сервере.

Программа настройки служб Reporting Services создаст две базы данных, связанных по имени: базу, содержащую статические данные, и временную базу для хранения данных сеанса и рабочих данных.

Обновить

Нажмите Обновить, чтобы осуществить миграцию таблиц на новую схему базы данных. База данных обновляется на месте. Обновление базы данных необходимо, если планируется использовать ее экземпляром служб SQL Server 2005 Reporting Services.

Примечание.
После обновления базы данных сервера отчетов невозможен ее откат к предыдущей версии. Убедитесь в наличии резервной копии базы данных перед началом ее обновления.

Изменить

Открывает диалоговое окно Изменение базы данных SharePoint, с помощью которого можно создать новую базу данных сервера отчетов в режиме интеграции с SharePoint.

Одновременно с созданием базы данных присваивается значение свойству SharePointIntegrated сервера отчетов.

Тип учетных данных

Позволяет задать учетные данные, используемые сервером отчетов для соединения со своей базой данных. Дополнительные сведения о выборе учетных данных см. в разделе Настройка соединения с базой данных сервера отчетов.

Имя учетной записи

Позволяет задать учетную запись пользователя домена (в случае использования учетных данных Windows) или имя входа на SQL Server (в случае использования учетных данных SQL Server). Учетные данные Windows указываются в следующем формате: <домен>\<учетная_запись>.

Пароль

Позволяет задать пароль для учетной записи.

Сценарий

Щелкните Сценарий для создания файлов сценариев SQL (с расширением SQL) для будущего использования в среде сценариев. Можно создавать сценарии создания или обновления базы данных сервера отчетов до текущей схемы. Также можно создать и запустить сценарий настройки ролей баз данных SQL Server для учетной записи или учетных записей, используемых для подключения к базе данных сервера отчетов.

Журнал изменений

Версия Журнал

12 декабря 2006 г.

Новое содержимое:
  • Описание новых настроек, используемых для создания базы данных сервера отчетов в режиме интеграции с SharePoint.

Измененное содержимое:
  • Добавлены инструкции для подключения к удаленному экземпляру SQL Server.

См. также

Задачи

Как создать базу данных сервера отчетов (настройка служб Reporting Services)

Основные понятия

Обновление базы данных сервера отчетов
Обновление установки по умолчанию служб Reporting Services
Справка F1 по настройке служб Reporting Services
Настройка соединения с базой данных сервера отчетов
Администрирование баз данных сервера отчетов
Настройка масштабного развертывания сервера отчетов

Другие ресурсы

База данных сервера отчетов


Интеграция сSharePoint [настройка служб Reporting Services]

Интеграция сSharePoint [настройка служб Reporting Services] |
 | См. также
Настройка установки SQL Server > Настройка служб Reporting Services > Справка F1 по настройке служб Reporting Services >

Новое содержимое: 12 декабря 2006 г.

Сервер отчетов может быть настроен на работу в собственном режиме или в режиме интеграции с SharePoint, что позволит синхронизировать содержимое и операции сервера отчетов с узлом или фермой SharePoint.

Используйте эту страницу, чтобы просмотреть состояние режима сервера данного экземпляра сервера отчетов. Существуют четыре возможных состояния. Каждое из них отмечается значком определенного цвета рядом с параметром Интеграция с SharePoint в области выбора страницы в программе настройки служб Reporting Services.

  • Серый кружок указывает на то, что режим интеграции с SharePoint не поддерживается для текущего экземпляра. Вероятнее всего, версия или выпуск служб Reporting Services не поддерживает режима интеграции с SharePoint. Версия должна быть выпуском SQL Server 2005 до установки пакета обновления 2 (SP2). При работе с версией с пакетом обновления 2 этот индикатор появляется в случае, когда используется выпуск Workgroup Edition или выпуск Express Edition with Advanced Services.

  • Синий восклицательный знак (!) указывает на то, что режим интеграции с SharePoint поддерживается для текущей версии и выпуска, но не настроен.

  • Зеленая галочка указывает на то, что текущий экземпляр сервера отчетов настроен для работы в режиме интеграции с SharePoint. Зеленая галочка появляется при создании базы данных сервера отчетов в режиме интеграции с SharePoint и последующем подключении к ней. Зеленая галочка не означает, что серверные технологии находятся в рабочем состоянии. Могут потребоваться дополнительные шаги.

  • Красный «икс» (X) указывает на то, что веб-службе или службе Windows сервера отчетов не удается подключиться к базам данных содержимого SharePoint. Возможно, не было установлено необходимое программное обеспечение или служебные учетные записи не были определены как доверенные учетные записи в центральном веб-узле администрирования SharePoint на целевом экземпляре SharePoint.

Параметры

Эта страница не содержит параметров. На этой странице предоставляются сведения о состоянии режима развертывания, используемого текущим экземпляром сервера отчетов. Полный список шагов и необходимых средств см. в разделе Настройка служб Reporting Services для интеграции с SharePoint 3.0.

См. также

Основные понятия

Требования для запуска служб Reporting Services в режиме интеграции с SharePoint
Режимы развертывания для служб Reporting Services
Интеграция служб Reporting Services и технологии SharePoint
Настройка служб Reporting Services для интеграции с SharePoint 3.0
Общие сведения о безопасности для служб Reporting Services в режиме интеграции с SharePoint
Хранение и синхронизация содержимого сервера отчетов с помощью баз данных SharePoint
Требования для запуска служб Reporting Services в режиме интеграции с SharePoint


Ключи шифрования (конфигурация служб Reporting Services)

Ключи шифрования (конфигурация служб Reporting Services) |
 | См. также
Настройка установки SQL Server > Настройка служб Reporting Services > Справка F1 по настройке служб Reporting Services >

Дата обновления: 12 декабря 2006 г.

Используйте страницу "Ключи шифрования", чтобы управлять симметричным ключом, используемым для шифрования и дешифрования данных на сервере отчетов. Управление ключами шифрования является важной частью настройки сервера отчетов. Хотя симметричный ключ создается и применяется автоматически при создании базы данных сервера отчетов, следует создать резервную копию симметричного ключа, чтобы можно было выполнять обычные операции по обслуживанию. Для выполнения следующих задач обслуживания потребуется действительная копия симметричного ключа:

  • Изменение учетной записи службы для службы Windows сервера отчетов.

  • Перенос установленной копии служб Reporting Services на другой компьютер.

  • Настройка нового экземпляра сервера отчетов для монопольного или совместного использования существующей базы данных сервера отчетов.

Восстановление симметричного ключа необходимо при обновлении учетной записи пользователя в службе Windows сервера отчетов (и при изменении учетной записи вне программы настройки служб Reporting Services) или при миграции установки сервера отчетов на другой сервер.

Чтобы защитить симметричный ключ от несанкционированного доступа, симметричный ключ шифруется при помощи закрытого ключа службы Windows сервера отчетов. Только служба Windows сервера отчетов может разблокировать и использовать симметричный ключ для хранения конфиденциальных данных в базе данных сервера отчетов. При изменении удостоверения службы Windows сервера отчетов или при миграции сервера отчетов на новый компьютер закрытый ключ службы Windows сервера отчетов больше не сможет разблокировать симметричный ключ. Чтобы восстановить доступ к симметричному ключу, симметричный ключ дешифруется при помощи закрытого ключа нового удостоверения службы Windows сервера отчетов. Восстановление симметричного ключа является процессом, при котором происходит повторное шифрование.

Симметричный ключ необходимо восстанавливать только в том случае, если такой ключ на данный момент используется для шифрования и дешифрования данных в базе данных сервера отчетов. При восстановлении недействительного симметричного ключа будет закрыт доступ к конфиденциальным данным. В этом случае необходимо удалить ключ и создать его заново.

Важно!
Удаление и повторное создание симметричного ключа является необратимым действием, которое может иметь важные последствия, влияющие на текущую установку. При удалении ключа любые существующие данные, которые шифруются симметричным ключом, будут удалены вместе с ним. Удаленные данные включают в себя строки соединения с внешними источниками данных отчетов, сохраненные строки соединения и некоторые сведения о подписках.

Параметры

Резервное копирование

Копирует симметричный ключ в указанный файл. Симметричный ключ никогда не хранится в виде простого текста. Необходимо ввести пароль для защиты файла.

Восстановить

Применяет ранее сохраненную копию симметричного ключа к базе данных сервера отчетов. Следует ввести пароль, чтобы разблокировать файл.

Предыдущая копия симметричного ключа для экземпляра сервера отчетов, с которым в настоящий момент установлено соединение, перезаписывается восстановленной версией. После восстановления симметричного ключа необходимо инициализировать все серверы отчетов, использующие базу данных сервера отчетов. Дополнительные сведения об инициализации серверов отчетов см. в разделе Инициализация сервера отчетов.

Изменить

Воссоздает симметричный ключ и заново зашифровывает все зашифрованные значения в базе данных сервера отчетов. Убедитесь в том, что служба Windows сервера отчетов остановлена, прежде чем воссоздать симметричный ключ.

В конфигурации с масштабным развертыванием все копии симметричного ключа заменяются новейшими версиями. Прежде чем изменить симметричный ключ, заново просмотрите список серверов, присоединенных к конфигурации с масштабным развертыванием, чтобы убедиться в том, что только действительные экземпляры сервера отчетов получают доступ к новому ключу. Серверы, являющиеся частью конфигурации с масштабным развертыванием, перечислены на странице Инициализировано. Остановите службу Windows на каждом сервере отчетов в конфигурации, прежде чем повторно создать ключ.

Обратите внимание на то, что воссоздание симметричного ключа может быть длительным процессом, если имеется много источников данных и подписок.

Удалить

Удаляет симметричный ключ и все зашифрованное содержимое, включая строки соединения и сохраненные учетные данные. Удалять симметричный ключ следует только в том случае, если восстановить его невозможно.

После удаления симметричного ключа необходимо заново ввести недостающие строки соединения, хранимые учетные данные в отчеты и общие источники данных, потерявшие эти значения. Следует также обновить все подписки, которые используют модули доставки, хранящие зашифрованные данные. Сюда входят модули доставки в общую папку и любые модули доставки от сторонних разработчиков, использующие зашифрованное значение.

Автоматизированного способа обновлять эти данные не существует. Необходимо вручную обновить все отчеты, подписки и общие источники данных, которые используют сохраненные учетные данные и строки соединения.

Журнал изменений

Версия Журнал

12 декабря 2006 г.

Новое содержимое:
  • Сведения относительно восстановления, удаления и повторного создания ключей шифрования.

См. также

Основные понятия

Справка F1 по настройке служб Reporting Services
Создание резервных копий и восстановление ключей шифрования
Удаление и повторное создание ключей шифрования
Инициализация сервера отчетов

Другие ресурсы

Устранение неполадок при инициализации и ошибок ключа шифрования
Хранение зашифрованных данных сервера отчетов


Инициализация (конфигурация служб Reporting Services)

Инициализация (конфигурация служб Reporting Services) |
 | См. также
Настройка установки SQL Server > Настройка служб Reporting Services > Справка F1 по настройке служб Reporting Services >

Инициализированный сервер отчетов описывает сервер, способный шифровать и расшифровывать конфиденциальные данные, которые хранятся в базе данных сервера отчетов (например, сохраненные учетные данные и строки соединений). Инициализация сервера отчетов необходима для выполнения этим сервером операций.

Используйте эту страницу, чтобы просмотреть состояние инициализации для масштабного развертывания или включить сервер отчетов в масштабное развертывание. На этой странице не отображается состояние инициализации для отдельной установки сервера. Отдельная установка сервера инициализируется автоматически при определении соединения с базой данных.

Для сервера отчетов, являющегося в настоящий момент частью масштабного развертывания, на этой странице отображается состояние инициализации экземпляров сервера отчетов, совместно пользующихся одной базой данных сервера отчетов. При просмотре состояния для масштабного развертывания не имеет значения, к какому именно серверу создано соединение. Сведения о состоянии для каждого узла доступны для просмотра на этой странице независимо от экземпляра, к которому создано соединение.

Существуют три возможных состояния инициализации для масштабного развертывания. Каждое из них отмечается значком определенного цвета рядом с параметром «Инициализация» в области выбора страницы в программе настройки служб Reporting Services.

  • Значок состояния серого цвета отображается в случае, если соединение с базой данных не определено или используется выпуск, в котором не поддерживается масштабное развертывание.

    Примечание.
    Масштабное развертывание не поддерживается в выпусках SQL Server 2005 Express Edition with Advanced Services, SQL Server 2005 Workgroup Edition и SQL Server Standard Edition. Дополнительные сведения о доступности компонентов в выпуске Express Edition см. в разделе Reporting Services in SQL Server 2005 Express Edition with Advanced Services электронной документации по SQL Server.

  • Зеленая галочка указывает на то, что текущий экземпляр сервера отчетов инициализирован. Зеленая галочка отображается в случаях, когда соединение с базой данных сервера отчетов настроено и экземпляр сервера отчетов располагает копией симметричного ключа базы данных.

  • Красный «икс» (X) указывает на то, что сервер не инициализирован. Красный «икс» (X) всегда отображается для сервера отчетов, который был удален из масштабного развертывания, но еще не снабжен базой данных сервера отчетов для монопольного использования. Эта ситуация разрешается автоматически при создании новой базы данных сервера отчетов для этого сервера отчетов.

    Красный X также отображается в случаях, когда база данных сервера отчетов недоступна или находится в автономном режиме. Чтобы убедиться в том, что именно это является причиной, используйте среду SQL Server Management Studio для соединения к экземпляру компонента Database Engine, где расположена база данных сервера отчетов.

    Во всех прочих случаях красный X означает, что серверу не удается зашифровать или дешифровать данные в базе данных сервера отчетов. Следует восстановить резервную копию симметричного ключа для разрешения этой проблемы. Если красный X отображается после изменения служебной учетной записи (причем программа настройки служб Reporting Services не использовалась для изменения этой учетной записи), а резервная копия ключа отсутствует, можно временно перевести сервер на работу под старой учетной записью, чтобы получить возможность запастись резервной копией ключа. Дополнительные сведения см. в разделах Управление ключами шифрования и Настройка учетных записей и паролей служб в службах Reporting Services.

Параметры

Компьютер

Позволяет отобразить имя компьютера, на котором находится экземпляр сервера отчетов. При обновлении сервера отчетов, если отсутствует этот параметр, имя компьютера можно добавить в таблицу Keys в базе данных сервера отчетов.

Экземпляр

Позволяет отобразить имя экземпляра сервера отчетов. Экземпляры сервера отчетов основаны на экземплярах SQL Server.

Идентификатор

Позволяет отобразить идентификатор GUID, созданный во время настройки сервера отчетов. Это значение можно использовать с аргументом rskeymgmt -n для инициализации удаленного экземпляра сервера отчетов, который не может шифровать или расшифровывать данные в базе данных сервера отчетов.

Инициализировано

Позволяет указать, инициализирован ли сервер отчетов.

Инициализировать

Нажмите кнопку Инициализировать, чтобы настроить сервер отчетов для использования симметричного ключа в общей базе данных сервера отчетов. Кнопка Инициализировать позволит добавить экземпляр сервера отчетов к масштабному развертыванию или произвести диагностику проблем при миграции или установке.

Для настройки масштабного развертывания выберите экземпляр сервера отчетов, который нужно добавить, а затем нажмите кнопку Инициализировать. Экземпляр сервера отчетов доступен только в случае, если предварительно было настроено соединение с общей базой сервера отчетов. Кроме того, из сервера отчетов, уже инициализированного на использование базы данных сервера отчетов, должна быть выполнена инициализация.

Удалить

Нажмите кнопку Удалить, чтобы удалить ключи шифрования выбранного экземпляра сервера отчетов из базы данных сервера отчетов. Удаление ключей необходимо для удаления сервера отчетов из масштабного развертывания или для диагностики проблем, возникших при установке или миграции. Данный параметр позволяет удалить только ключи шифрования для выбранного экземпляра сервера отчетов. На зашифрованные данные в базе данных сервера отчетов это не влияет.

В качестве предупредительной меры перед удалением симметричного ключа убедитесь, что создана его резервная копия. После удаления ключей шифрования последнего в списке сервера отчетов задайте для базы данных новые требования для любой последующей инициализации сервера отчетов. Новое требование заключается в том, что после инициализации сервера отчетов необходимо восстановить резервную копию симметричного ключа. Восстановление симметричного ключа необходимо для доступа к зашифрованным данным в базе данных сервера отчетов.

Если зашифрованные данные больше не нужны или если нет резервной копии ключа, то зашифрованные данные необходимо удалить. Дополнительные сведения см. в разделе Ключи шифрования (конфигурация служб Reporting Services).

Журнал изменений

Версия Журнал

12 декабря 2006 г.

Измененное содержимое:
  • Добавлены сведения о значках состояния.

См. также

Задачи

Как настроить масштабное развертывание сервера отчетов (настройка служб Reporting Services)

Основные понятия

Настройка масштабного развертывания сервера отчетов
Обновление веб-фермы сервера отчетов
Инициализация сервера отчетов
Управление ключами шифрования

Другие ресурсы

Программа rskeymgmt


Настройки электронной почты (конфигурация служб Reporting Services)

Настройки электронной почты (конфигурация служб Reporting Services) |
 | См. также
Настройка установки SQL Server > Настройка служб Reporting Services > Справка F1 по настройке служб Reporting Services >

Используйте эту страницу, чтобы указать настройки Simple Mail Transport Protocol (SMTP), включающие модуль доставки электронной почты сервера отчетов. Электронную почту сервера отчетов можно использовать для распространения отчетов или уведомлений об обработке отчетов через подписки, доставляемые электронной почтой. Для модуля доставки электронной почты сервера отчетов необходим SMTP-сервер и адрес электронной почты для использования в поле «От».

Дополнительные параметры могут использоваться для дальнейшей настройки подписок, доставляемых электронной почтой, включая параметры, ограничивающие узлы почтового сервера и доступность модулей подготовки отчетов. Эти параметры нельзя задать в программе настройки служб Reporting Services. Для установки дополнительных параметров необходимо вручную отредактировать файл RSReportServer.config. Дополнительные сведения см. в разделах Настройка сервера отчетов для работы с электронной почтой и Файлы конфигурации служб Reporting Services.

Примечание.
Эта возможность в выпуске SQL Server 2005 Express Edition с дополнительными службами не поддерживается. Дополнительные сведения о доступности функциональных возможностей в выпуске Express Edition см. в разделе Reporting Services in SQL Server 2005 Express Edition with Advanced Services электронной документации по SQL Server.

Параметры

Адрес электронной почты отправителя

Указывает адрес электронной почты для использования в поле «От» создаваемого почтового сообщения. Необходимо указать учетную запись, имеющую разрешение на передачу почтовых сообщений из SMTP-сервера.

Метод доставки

Указывает, что электронная почта сервера отчетов направляется через SMTP-сервер. Это единственный метод доставки, который можно указать в программе настройки служб Reporting Services.

Альтернативным методом доставки является использование локального каталога считывания службы SMTP. Можно использовать этот метод доставки, если сетевая служба SMTP недоступна. Чтобы указать локальный каталог считывания службы SMTP, необходимо отредактировать файл конфигурации RSReportServer.config. Если файл конфигурации отредактирован для использования локального каталога считывания службы SMTP, программа настройки служб Reporting Services устанавливает для параметра Способ доставки: значение пользовательский, чтобы указать, что метод доставки определен в файле конфигурации.

В файле конфигурации метод доставки задается параметром SendUsing. Дополнительные сведения о параметре SendUsing см. в разделе Настройка сервера отчетов для работы с электронной почтой.

SMTP-сервер

Выберите используемый SMTP-сервер или шлюз. Можно использовать локальный сервер или SMTP-сервер.

См. также

Основные понятия

Настройка сервера отчетов для работы с электронной почтой
Справка F1 по настройке служб Reporting Services


Учетная запись выполнения (конфигурация служб Reporting Services)

Учетная запись выполнения (конфигурация служб Reporting Services) |
 | См. также
Настройка установки SQL Server > Настройка служб Reporting Services > Справка F1 по настройке служб Reporting Services >

Дата обновления: 17 июля 2006 г.

Эта страница используется для настройки учетной записи, которая используется для автоматической обработки. Такая учетная запись используется в особых случаях, если недоступны другие учетные данные:

  • Когда сервер отчетов соединен с источником данных, который не требует учетных данных. Примерами источников данных, для которых может не потребоваться использование учетных данных, являются XML-документы и некоторые клиентские приложения баз данных.

  • Когда сервер отчетов соединен с другим сервером для получения внешних файлов изображений или других ресурсов, ссылки на которые есть в отчете.

Настраивать эту учетную запись не обязательно, но, если этого не сделать, возможности использования внешних изображений и соединений с некоторыми источниками данных будут ограничены. При получении внешних файлов изображений сервер отчетов проверяет возможность анонимного соединения. Если соединение защищено паролем, сервер отчетов использует учетную запись автоматической обработки отчетов для соединения с удаленным сервером. При получении данных для отчета сервер отчетов олицетворяет текущего пользователя, запрашивает ввод пользователем учетных данных, использует сохраненные учетные данные или использует учетную запись автоматической обработки отчетов, если в свойствах соединения с источником данных в качестве типа учетных данных задано значение Нет. Для сервера отчетов не допускается делегирование или олицетворение учетных данных его служб при соединении с другими компьютерами, поэтому необходимо использование учетной записи автоматической обработки отчетов в случае недоступности других учетных данных.

Указанная учетная запись должна отличаться от той, которая используется для запуска служебных учетных записей. Если она настроена, то сохраняется в файле RSReportServer.config как зашифрованное значение. При использовании сервера отчетов в масштабном развертывании необходимо настроить эту учетную запись на каждом сервере отчетов.

Можно использовать любую учетную запись пользователя Windows. Для получения наилучших результатов выберите учетную запись, имеющую разрешения на чтение и на вход в сеть, для поддержки соединений с другими компьютерами. Эта учетная запись должна обладать разрешениями на чтение для любого внешнего файла изображения или данных, который необходимо использовать в отчете. Не следует определять локальную учетную запись, если все источники данных и внешние изображения, предназначенные для отчета, не хранятся на компьютере сервера отчетов. Используйте эту учетную запись только для автоматической обработки отчетов.

Примечание.
При использовании выпуска SQL Server 2005 Express Edition with Advanced Services эту учетную запись следует настраивать только в том случае, если в отчете есть ссылки на внешние изображения и для доступа к ним требуются определенные разрешения. В Express Edition не поддерживается соединение с источником данных на удаленном сервере. Дополнительные сведения см. в разделе Добавление изображения к отчету.

Параметры

Задание учетной записи выполнения

Установите флажок, чтобы задать учетную запись.

Учетная запись

Задает учетную запись пользователя домена Windows. Чтобы указать учетную запись, используйте следующий формат: <домен>\<пользователь учетной записи>.

Пароль

Задайте пароль.

Подтверждение пароля

Введите пароль еще раз.

Журнал изменений

Версия Журнал

17 июля 2006 г.

Измененное содержимое:
  • Значительное изменение.

См. также

Основные понятия

Справка F1 по настройке служб Reporting Services
Настройка учетной записи для автоматической обработки отчетов

Другие ресурсы

Файл конфигурации RSReportServer
Хранение зашифрованных данных сервера отчетов


Сетевые протоколы и библиотеки

Сетевые протоколы и библиотеки |
 | См. также
Настройка установки SQL Server >

Дата обновления: 5 декабря 2005 г.

Сервер может одновременно прослушивать или отслеживать работу нескольких сетевых протоколов. Однако каждый из этих протоколов должен быть настроен. Если какой-нибудь из протоколов не настроен, сервер не сможет его прослушивать. После установки можно изменить конфигурации протоколов при помощи диспетчера конфигурации SQL Server.

Сетевая конфигурация SQL Server по умолчанию

Экземпляр SQL Server 2005 по умолчанию настроен на TCP/IP-порт 1433 и именованный канал \\.\pipe\sql\query. Именованные экземпляры SQL Server 2005 конфигурируются на использование динамических TCP-портов, их номера назначаются операционной системой.

Если динамические номера портов неприменимы (например, если соединения SQL Server проходят через брандмауэр, который сконфигурирован на то, чтобы пропускать соединения только через определенные порты, или если соединения производятся через клиентские компоненты SQL Server версии 7.0 или более ранней), рекомендуется указывать номера портов ниже 1024. Выберите какой-нибудь порт в этом диапазоне, который не используется операционной системой или другим приложением.

В целях повышения безопасности при установке SQL Server 2005 сетевая функциональность включена неполностью. Для включения, отключения и настройки сетевых протоколов после завершения программы установки пользуйтесь средством настройки контактной зоны SQL Server 2005 или областью настройки сети SQL Server 2005 диспетчера конфигурации SQL Server.

Типы конечных точек

В SQL Server 2005 для соединений SQL Server введено новое понятие. Соединение представляется на сервере в виде конечной точки Transact-SQL. Для конечных точек Transact-SQL можно предоставлять, отменять и запрещать разрешения. По умолчанию все пользователи имеют разрешения на подключение к конечной точке, если только это разрешение не отменено и не запрещено членом группы sysadmin или владельцем конечной точки. В синтаксисе GRANT, REVOKE и DENY ENDPOINT применяется идентификатор, который администратор должен получить из представления каталога конечной точки.

Программа установки SQL Server создает конечные точки Transact-SQL для всех поддерживаемых сетевых протоколов, а также для выделенного административного соединения. В приведенной ниже таблице описаны параметры конфигурации сети по умолчанию.

Конечные точки Transact-SQL создаются программой установки SQL Server следующим образом:

  • локальный компьютер TSQL;

  • именованные каналы TSQL;

  • TCP по умолчанию TSQL;

  • VIA по умолчанию TSQL.

Дополнительные сведения об управлении конечными точками Transact-SQL см. в разделе «Сетевые протоколы и конечные точки TDS» электронной документации по SQL Server 2005.

Конфигурация по умолчанию

В приведенной ниже таблице описаны параметры конфигурации по умолчанию для сети.

Выпуск SQL Server | Новая установка или обновление | Общая память | TCP/IP | Именованные каналы | VIA
Enterprise Edition | Создание | Включена | Включен | Отключены (только локально) | Отключен
Developer Edition | Создание | Включена | Отключен | Отключены (только локально) | Отключен
Standard Edition | Создание | Включена | Включен | Отключены (только локально) | Отключен
Workgroup Edition | Создание | Включена | Включен | Отключены (только локально) | Отключен
Evaluation Edition | Создание | Включена | Отключен | Отключены (только локально) | Отключен
SQL Server Express | Создание | Включена | Отключен | Отключены (только локально) | Отключен
Все выпуски | Обновление или параллельная установка | Включена | Настройки, сохраненные с предыдущей установки | Настройки, сохраненные с предыдущей установки | Отключен

При установке отказоустойчивых кластеров обратите внимание на следующее.

  • Если экземпляр запущен на отказоустойчивом кластере SQL Server 2005, он прослушивает порты каждого из IP-портов, выделенных при установке SQL Server. Чтобы включить дополнительные сетевые протоколы, используйте либо средство настройки контактной зоны, либо диспетчер конфигурации SQL Server.

При установке SQL Server 2005 из командной строки можно указать тип запуска службы обозревателя SQL Server. Программа установки SQL Server установит обозреватель SQL Server в отключенном и остановленном состоянии по умолчанию. Сведения о настройке автоматического запуска см. в описании параметра DISABLENETWORKPROTOCOLS в разделе Как установить SQL Server 2005 из командной строки.

Дополнительные сведения об управлении сетевой конфигурацией SQL Server см. в следующих разделах электронной документации по SQL Server 2005:

  • «Сетевая конфигурация сервера»;

  • «Настройка сетевых протоколов сервера и сетевых библиотек»;

  • «Сетевая конфигурация SQL Server по умолчанию»;

  • «Сетевые библиотеки и сетевые протоколы».

См. также

Основные понятия

Подготовка к установке SQL Server 2005


Расположение файлов для экземпляра по умолчанию и именованных экземпляров SQL Server 2005

Расположение файлов для экземпляра по умолчанию и именованных экземпляров SQL Server 2005 |
 | См. также
Настройка установки SQL Server >

Дата обновления: 5 декабря 2005 г.

Установленная конфигурация состоит из одного или более отдельных экземпляров. Любой экземпляр, как по умолчанию, так и именованный, имеет собственный набор программных файлов и файлов данных, а также набор общих файлов, используемых всеми экземплярами, установленными на компьютере.

Для экземпляра SQL Server, включающего компонент Database Engine, службы Analysis Services и службы Reporting Services, каждый компонент имеет полный набор файлов данных и исполняемых файлов, а также общие файлы, используемые всеми компонентами.

Чтобы изолировать расположение установок для каждого компонента, внутри некоторого экземпляра SQL Server создаются уникальные идентификаторы экземпляров для каждого компонента. Это позволяет производить обновление отдельного компонента до следующих версий SQL Server независимо от других компонентов SQL Server.

Важно!
Не удаляйте следующие каталоги или их содержимое: Binn, Data, Ftdata, HTML или 1033. При необходимости можно удалить другие каталоги, однако возможно, что не удастся вернуть утраченные возможности или восстановить потерянные данные без удаления и переустановки SQL Server 2005.

Примечание.
Не удаляйте и не изменяйте HTM-файлы в каталоге HTML. Они необходимы для правильной работы средств SQL Server.

Общие файлы для всех экземпляров SQL Server 2005

Общие файлы, используемые всеми экземплярами, находящимися на одном компьютере, установлены в папке системный_диск:\Program Files\Microsoft SQL Server\90, где системный_диск — это буква диска, на котором установлены компоненты. Обычно это диск C.

Примечание.
Программные файлы и файлы данных не могут быть установлены на съемном диске, в файловой системе со сжатием данных, а также на общие диски экземпляра отказоустойчивого кластера.

Расположение файлов и сопоставление данных реестра

Во время установки SQL Server для каждого компонента сервера создается идентификатор экземпляра. В этом выпуске SQL Server компонентами сервера являются компонент Database Engine, службы Analysis Services и службы Reporting Services. Идентификатор экземпляра создается в формате MSSQL.n, где n — порядковый номер устанавливаемого компонента. Идентификатор экземпляра используется в каталоге файлов и в корневом каталоге реестра.

Первым создаваемым идентификатором экземпляра является MSSQL.1. Номера идентификаторов возрастают для дополнительных экземпляров: MSSQL.2, MSSQL.3 и так далее. Если в результате удалений в последовательности идентификаторов случаются разрывы, то для их заполнения создаются новые номера идентификаторов. Самый большой номер идентификатора экземпляра не всегда принадлежит последнему установленному экземпляру.

Компоненты сервера устанавливаются в каталоги, имеющие формат <идентификатор_экземпляра>\<имя_компонента>. Например, экземпляр по умолчанию или именованный экземпляр с компонентом Database Engine, службами Analysis Services и службами Reporting Services по умолчанию будет располагать следующими каталогами.

  • <Program Files>\Microsoft SQL Server\MSSQL.1\MSSQL\ — для компонента Database Engine.

  • <Program Files>\Microsoft SQL Server\MSSQL.2\OLAP\ — для служб Analysis Services.

  • <Program Files>\Microsoft SQL Server\MSSQL.3\RS\ — для служб Reporting Services.

При изменении каталога установки по умолчанию вместо <Program Files>\Microsoft SQL Server используется <пользовательский путь>.

Примечание.
Службы Integration Services, Notification Services и клиентские компоненты SQL Server 2005 не зависят от экземпляра, и поэтому им не назначается идентификатор экземпляра. Компоненты, не зависящие от экземпляра, по умолчанию устанавливаются в тот же каталог: <системный диск>:\Program Files\Microsoft SQL Server\90\. Изменение пути установки для одного компонента приводит к его изменению и для всех остальных компонентов. При последующих установках компоненты, не зависящие от экземпляра, устанавливаются в каталог исходной установки.

Для компонентов, зависящих от экземпляра, создается раздел реестра HKLM\Software\Microsoft\Microsoft SQL Server\MSSQL.n. Например:

  • HKLM\Software\Microsoft\Microsoft SQL Server\MSSQL.1

  • HKLM\Software\Microsoft\Microsoft SQL Server\MSSQL.2

  • HKLM\Software\Microsoft\Microsoft SQL Server\MSSQL.3

В реестре также хранится сопоставление идентификаторов экземпляров с именами экземпляров. Сопоставление идентификатора экземпляра с именем экземпляра осуществляется следующим образом.

  • [HKEY_LOCAL_MACHINE\Software\Microsoft\Microsoft SQL Server\Instance Names\SQL] "InstanceName"="MSSQL.1"

  • [HKEY_LOCAL_MACHINE\Software\Microsoft\Microsoft SQL Server\Instance Names\OLAP] "InstanceName"="MSSQL.2"

  • [HKEY_LOCAL_MACHINE\Software\Microsoft\Microsoft SQL Server\Instance Names\RS] "InstanceName"="MSSQL.3"

Образцы баз данных AdventureWorks (новые)

Образцы AdventureWorks устанавливаются в каталог Tools\Samples. Для автоматической установки, если необходимо присоединить образцы баз данных к определенному экземпляру SQL Server, используйте параметр SAMPLEDATABASESERVER=\<имя_экземпляра>. Экземпляр, к которому присоединяется образец базы данных, должен быть локальным экземпляром.

Дополнительные сведения об автоматических установках см. в разделе Сведения об удаленной установке SQL Server 2005, Как установить SQL Server 2005 из командной строки или в инструкциях, содержащихся в файле Template.ini на DVD-диске SQL Server.

Указание путей к файлам

В ходе установки можно изменить путь для установки следующих компонентов.

Путь установки отображается в программе установки только для компонентов с пользовательской целевой папкой.

Компонент | Путь по умолчанию1, 2 | Настраиваемый3 или фиксированный путь
Серверные компоненты ядра СУБД | \Program Files\Microsoft SQL Server\MSSQL.n\MSSQL\Binn\ | Настраиваемый
Файлы данных компонента Database Engine | \Program Files\Microsoft SQL Server\MSSQL.n\MSSQL\Data\ | Настраиваемый
Сервер служб Analysis Services | \Program Files\Microsoft SQL Server\MSSQL.n\OLAP\Bin\ | Настраиваемый
Файлы данных служб Analysis Services | \Program Files\Microsoft SQL Server\MSSQL.n\OLAP\Data\ | Настраиваемый
Сервер отчетов для служб Reporting Services | \Program Files\Microsoft SQL Server\MSSQL.n\Reporting Services\ReportServer\Bin\ | Настраиваемый
Диспетчер отчетов для служб Reporting Services | \Program Files\Microsoft SQL Server\MSSQL.n\Reporting Services\ReportManager\Bin\ | Фиксированный путь
Службы SQL Server Integration Services | <Каталог установки>\90\DTS\ | Настраиваемый4
Службы Notification Services | <Каталог установки>\90\Notification Services\ | Настраиваемый4
Клиентские компоненты | <Каталог установки>\90\Tools\ | Настраиваемый4
Объекты COM для репликации и размещения на сервере | Program Files\Microsoft SQL Server\90\COM\5 | Фиксированный путь
Библиотеки DLL компонентов служб SQL Server Integration Services для подсистемы выполнения преобразования данных, для подсистемы конвейера преобразования данных и для программы командной строки dtexec | Program Files\Microsoft SQL Server\90\DTS\Binn | Фиксированный путь
Библиотеки DLL, обеспечивающие поддержку управляемых соединений для служб SQL Server Integration Services | Program Files\Microsoft SQL Server\90\DTS\Connections | Фиксированный путь
Библиотеки DLL для каждого типа перечислителя, поддерживаемого службами SQL Server Integration Services | Program Files\Microsoft SQL Server\90\DTS\ForEachEnumerators | Фиксированный путь
Служба обозревателя SQL Server, поставщики инструментария WMI | \Program Files\Microsoft SQL Server\90\Shared\ | Фиксированный путь
Компоненты, совместно используемые всеми экземплярами SQL Server 2005 | \Program Files\Microsoft SQL Server\90\Shared\ | Фиксированный путь

1Убедитесь, что папка \Program Files\Microsoft SQL Server\ защищена, ограничив разрешения на доступ.

2Диском по умолчанию для этих путей является системный_диск. Обычно это диск C.

3Путь установки родительского компонента определяет пути установки для дочерних компонентов.

4Существует общий путь установки для служб Integration Services, служб Notification Services и клиентских компонентов SQL Server. Изменение пути установки для одного компонента влечет изменение пути для других компонентов. При последующих установках компоненты устанавливаются в расположение исходной установки.

5Этот каталог используется всеми экземплярами SQL Server, установленными на компьютере. В случае применения обновления (например, установки пакета обновления) к любому из экземпляров на компьютере любое изменение файлов в этой папке затронет все экземпляры, установленные на компьютере.

Примечание.
Для кластеризованных конфигураций необходимо выбрать локальный диск, доступный на всех узлах кластера.

Примечание.
При добавлении компонентов к уже установленной конфигурации невозможно изменить расположение ранее установленного компонента или указать расположение нового компонента. Необходимо либо установить дополнительные компоненты в каталоги, созданные программой установки, либо удалить продукт и установить его заново.

Если во время выполнения установки для компонентов сервера или файлов данных указывается путь установки, программа установки использует имя экземпляра в дополнение к указанному расположению для файлов программ и файлов данных. Программа установки не использует имя экземпляра в именах средств и других общих файлах. Программа установки также не использует имя экземпляра для файлов программ и данных служб Analysis Services, но использует имя экземпляра для репозитория служб Analysis Services.

При указании пути установки для компонента Database Engine программа установки SQL Server использует этот путь в качестве корневого каталога этой установки для всех папок, относящихся к экземпляру, включая файлы данных SQL. В этом случае, если будет указан корневой каталог «C:\Program Files\Microsoft SQL Server\MSSQL.1\MSSQL\», то каталоги, относящиеся к экземпляру, будут добавлены в конец этого пути.

Пользователи, использующие возможности обновления USESYSDB в мастере установки SQL Server (программа установки в режиме интерфейса пользователя), могут оказаться в ситуации, когда продукт устанавливается в рекурсивную структуру папок — например <SQLProgramFiles>\MSSQL.1\MSSQL\MSSQL.1\MSSQL\Data\. Вместо этого, чтобы использовать компонент USESYSDB, нужно вместо пути установки для компонента ядра СУБД указать путь установки для компонента файлов данных SQL.

Примечание.
Обычно файлы данных можно найти в дочернем каталоге с именем Data. Например, при обновлении укажите «C:\Program Files\Microsoft SQL Server\MSSQL.1\», чтобы указать путь к корневому каталогу данных системных баз данных, и тогда файлы данных будут расположены в каталоге «C:\Program Files\Microsoft SQL Server\MSSQL.1\MSSQL\Data».

См. также

Справочник

Выбор компонентов


Изменение паролей и учетных записей пользователей

Изменение паролей и учетных записей пользователей |
 | См. также
Настройка установки SQL Server >

Дата обновления: 17 июля 2006 г.

Microsoft учетные записи и пароли служб связаны с пользовательскими учетными записями и паролями MicrosoftWindows. Изменения в одних могут потребовать изменений в других.

Изменение учетных записей служб SQL Server после установки

После того, как был установлен SQL Server 2005, используйте диспетчер конфигурации SQL Server для изменения присвоенного пароля или других свойств служб SQL Server. Каждая служба должна подвергаться изменению индивидуально. Новая учетная запись пользователя вступает в силу после перезапуска службы.

Важно!
Не следует изменять пароли к любым учетным записям служб SQL Server, если узел отказоустойчивого кластера отключен или недоступен в сети. Если все же необходимо это сделать, придется переустановить пароль заново при помощи диспетчера конфигурации, когда все узлы вновь будут доступны.

Учетным записям предоставляются следующие права.

  • SeServiceLogonRight, что позволяет учетной записи запускаться в качестве службы.

  • SeLockMemoryPrivilege, что позволяет учетной записи использовать функцию памяти AWE SQL Server.

  • SeTcbPrivilege, что позволяет учетной записи олицетворять другие учетные записи.

Если SQL Server выполняется в конфигурации отказоустойчивого кластера, разрешения также выдаются для всех исполняемых файлов и файлов установки данных для всех узлов кластера. Разрешение предоставляется также учетной записи службы в объекте кластера.

Внимание!
Если запускается Microsoft Windows 2000 и нужно использовать шифрованную файловую систему Windows 2000 для шифрования любых файлов SQL Server, необходимо расшифровать файлы прежде, чем сможете изменить учетные записи служб SQL Server. Если подвергнуть изменению учетные записи служб SQL Server, предварительно не расшифровав файлы, в дальнейшем будет невозможно их расшифровать.

Изменение текущей учетной записи службы SQL Server в учетную запись без прав администратора приведет к тому, что существующие полнотекстовые каталоги окажутся недоступными. В подобном случае следует либо заново построить и заполнить все каталоги, принадлежащие данном экземпляру SQL Server, либо переключиться обратно к учетной записи с правами администратора.

Можно изменить учетную запись службы SQLServerAgent в учетную запись администратора, не относящуюся к Windows NT 4.0. Однако учетная запись Windows NT 4.0 должна быть элементом фиксированной серверной роли sysadmin для запуска агента SQL Server.

Дополнительные сведения см. в разделе Настройка учетных записей служб Windows. Дополнительные сведения об использовании надстроек служб для Windows для изменения учетных записей служб SQL Server см. в статье Как изменить учетные записи служб SQL Server или SQL Server Agent без использования программы SQL Enterprise Manager в SQL Server 2000 или диспетчера конфигураций SQL Server в SQL Server 2005.

Изменения паролей Windows

Если после установки SQL Server 2005 меняется пароль Windows (например, истекает срок его действия), необходимо также изменить учетные данные для служб SQL Server в Windows.

Изменение данных учетной записи для входа в службы SQL Server (Windows 2000)

После изменения данных учетной записи службы SQL Server для входа в систему на панели управления, необходимо также изменить учетную запись службы SQL Server в диспетчере конфигурации SQL Server. Это позволит синхронизировать данные учетной записи службы для службы поиска Microsoft.

Примечание безопасности.
Задание надежных паролей необходимо для безопасности системы. Всегда используйте надежные пароли.

Важно!
Хотя службе поиска Майкрософт всегда назначается учетная запись локальной системы, средство полнотекстового поиска отслеживает учетную запись службы SQL Server в Windows. Полнотекстовый поиск и отказоустойчивый кластер окажутся недоступны, если изменения паролей, сделанные Windows, не будут отменены.

Дополнительные сведения о создании учетных записей пользователей в Windows, предоставлении расширенных прав пользователя, установке сроков действия паролей и управлении членством в группах см. в документации по Windows или справке средства «Управление пользователями в доменах». Для пользователей Microsoft Windows 2000 см. разделы «Управление компьютером» или «Редактор групповой политики» документации по Windows 2000.

См. также

Основные понятия

Настройка контактной зоны SQL Server

Журнал изменений

Версия Журнал

17 июля 2006 г.

Измененное содержимое:
  • Добавлена ссылка на статью базы знаний об использовании надстроек служб для изменения учетных записей служб SQL Server и SQL Server Agent.


Системные базы данных и образцы баз данных

Системные базы данных и образцы баз данных |
 | См. также
Настройка установки SQL Server >

Дата обновления: 5 декабря 2005 г.

При установке SQL Server 2005 создаются файлы баз данных и журналов, которые перечислены в следующей таблице.

База данных | Файл базы данных | Файл журнала
master | Master.mdf | Mastlog.ldf
model | Model.mdf | Modellog.ldf
msdb | Msdbdata.mdf | Msdblog.ldf
tempdb | Tempdb.mdf | Templog.ldf

Базы данных master, model, msdb и tempdb являются системными.

Примечание.
Файлы баз данных и журналов по умолчанию находятся в каталоге Program Files\Microsoft SQL Server\Mssql.n\MSSQL\Data, где n означает порядковый номер экземпляра SQL Server. Этот каталог может быть другим, если при установке SQL Server было изменено местонахождение файлов по умолчанию.

Образцы баз данных AdventureWorks

Образцы баз данных включены в SQL Server 2005 для обучения, но по умолчанию они не устанавливаются вместе с программой. Дополнительные сведения об образцах баз данных AdventureWorks см. в разделе Использование программы установки для установки образца базы данных AdventureWorks и других примеров.

См. также

Другие ресурсы

Расширения образцов баз данных (Transact-SQL)


Спецификации продукта SQL Server 2005

Спецификации продукта SQL Server 2005
Настройка установки SQL Server >

В следующих разделах изложены подробные спецификации данного выпуска продукта.

Раздел | Описание
Выпуски и компоненты SQL Server 2005 | Выбор устанавливаемых компонентов и функций.
Возможности, поддерживаемые различными выпусками SQL Server 2005 | Поддержка компонентов и функций в различных выпусках SQL Server.
Задание максимальной вместимости SQL Server 2005 | Максимальные возможности для различных объектов SQL Server.
Максимальное количество процессоров, поддерживаемых выпусками SQL Server 2005 | Максимальное количество процессоров, поддерживаемых различными выпусками SQL Server 2005.


Задание максимальной вместимости SQL Server 2005

Задание максимальной вместимости SQL Server 2005 |
 | См. также
Настройка установки SQL Server > Спецификации продукта SQL Server 2005 >

Дата обновления: 12 декабря 2006 г.

В следующих таблицах приводятся максимальные размеры и количества различных объектов, определяемых в компонентах .

Объекты компонента Database Engine

В следующей таблице приводятся максимальные размеры и количества различных объектов, определяемых в базах данных SQL Server 2005 или ссылающихся на них Transact-SQL инструкциях. Таблица не включает SQL Server Windows CE Edition.

Объект компонента SQL Server 2005 Database Engine | Максимальные размеры и количества для 32-разрядной версии SQL Server 2005 | Максимальные размеры и количества для 64-разрядной версии SQL Server 2005
Размер пакета1 | 65 536 * размер сетевого пакета | 65 536 * размер сетевого пакета
Байтов на столбец с короткой строкой | 8000 | 8000
Байтов на GROUP BY, ORDER BY | 8060 | 8060
Байтов на ключ индекса2 | 900 | 900
Байтов на внешний ключ | 900 | 900
Байтов на первичный ключ | 900 | 900
Байтов на строку8 | 8060 | 8060
Байтов на столбец varchar(max), varbinary(max), xml, text или image | 2^31-1 | 2^31-1
Символов на столбец ntext или nvarchar(max) | 2^30-1 | 2^30-1
Количество кластеризованных индексов в таблице | 1 | 1
Столбцов на GROUP BY, ORDER BY | Ограничивается только числом байтов | Ограничивается только числом байтов
Столбцов или выражений в инструкции GROUP BY WITH CUBE или WITH ROLLUP | 10 | 10
Столбцов на ключ индекса7 | 16 | 16
Столбцов на внешний ключ | 16 | 16
Столбцов на первичный ключ | 16 | 16
Столбцов на базовую таблицу | 1024 | 1 024
Столбцов на инструкцию SELECT | 4 096 | 4096
Столбцов на инструкцию INSERT | 1,024 | 1 024
Соединений на одного клиента | Максимальное значение настроенных соединений | Максимальное значение настроенных соединений
Размер базы данных | 1 048 516 ТБ | 1 048 516 ТБ
Баз данных на один экземпляр SQL Server | 32,767 | 32 767
Файловых групп на одну базу данных | 32 767 | 32 767
Файлов на одну базу данных | 32 767 | 32 767
Размер файла (данные) | 16 ТБ | 16 ТБ
Размер файла (журнал) | 2 ТБ | 2 ТБ
Ссылок на таблицы внешнего ключа для таблицы4 | 253 | 253
Длина идентификатора (в символах) | 128 | 128
Экземпляров на один компьютер | 50 экземпляров на изолированном сервере для всех выпусков SQL Server 2005, за исключением выпуска Workgroup Edition. Workgroup Edition поддерживает максимум 16 экземпляров. SQL Server 2005 поддерживает 25 экземпляров отказоустойчивого кластера. | 50 экземпляров на отдельном сервере. 25 экземпляров на отказоустойчивом кластере.
Длина строки, содержащей инструкции SQL (размер пакета)1 | 65 536 * размер сетевого пакета | 65 536 * размер сетевого пакета
Блокировок на соединение | Максимальное число блокировок на сервер | Максимальное число блокировок на сервер
Блокировок на экземпляр SQL Server5 | до 2 147 483 647 | Ограничено только объемом памяти
Уровней вложенных хранимых процедур6 | 32 | 32
Вложенных запросов | 32 | 32
Уровней вложенных триггеров | 32 | 32
Количество некластеризованных индексов у таблицы | 249 | 249
Параметров на одну хранимую процедуру | 2100 | 2100
Параметров на одну пользовательскую функцию | 2100 | 2100
REFERENCES на таблицу | 253 | 253
Строк на таблицу | Ограничено доступной памятью | Ограничено доступной памятью
Таблиц на одну базу данных3 | Ограничено числом объектов в базе данных | Ограничено числом объектов в базе данных
Секций на секционированную таблицу или индекс | 1000 | 1000
Статистических показателей неиндексированных столбцов | 2000 | 2000
Таблиц на инструкцию SELECT | 256 | 256
Триггеров на таблицу3 | Ограничено числом объектов в базе данных | Ограничено числом объектов в базе данных
Индексов UNIQUE или ограничений на таблицу | 249 некластеризованных и 1 кластеризованный | 249 некластеризованных и 1 кластеризованный
Соединения пользователей | 32 767 | 32 767
XML-индексов | 249 | 249

1 Размер сетевого пакета — это размер пакетов потока табличных данных (TDS), которые используются для связи между приложениями и компонентом Database Engine. Размер пакета по умолчанию равен 4 килобайт (КБ), он зависит от параметра конфигурации network packet size.

2Максимальное число байтов в любом ключе индекса не может превышать 900 в SQL Server 2005. Можно определить ключ, использующий столбцы переменной длины, максимальная длина которых может превышать 900 байт при условии, что в эти столбцы не будут вставляться строки объемом более 900 байт данных. В SQL Server 2005 в некластеризованный индекс можно включать неключевые столбцы, чтобы избежать ограничения максимального размера ключа индекса, равного 900 байт. Дополнительные сведения см. в разделе Индекс с включенными столбцами.

3 Объекты базы данных включают такие объекты, как таблицы, представления, хранимые процедуры, пользовательские функции, триггеры, правила, значения по умолчанию и ограничения. Суммарное число всех объектов в базе данных не может превышать 2 147 483 647.

4 Хотя таблица может содержать неограниченное количество ограничений FOREIGN KEY, рекомендуемый максимум — 253. В зависимости от конфигурации оборудования, на котором установлен SQL Server, определение дополнительных ограничений внешнего ключа может потребовать с точки зрения оптимизатора запросов слишком много ресурсов для обработки.

5 Это значение относится только к статическим блокировкам. Количество динамических блокировок ограничивается только объемом памяти.

6 Если хранимая процедура обращается больше чем к 8 базам данных или более чем к двум базам в режиме чередования, может возникнуть ошибка.

7 Если в таблице имеется один или несколько индексов XML, ключ кластеризации пользовательской таблицы ограничивается 15 столбцами, потому что XML-столбец добавляется к ключу кластеризации первичного XML-индекса. В SQL Server 2005 в некластеризованный индекс можно включать неключевые столбцы, чтобы избежать ограничения максимального количества ключевых столбцов, равного 16. Дополнительные сведения см. в разделе Индекс с включенными столбцами.

8 SQL Server 2005 поддерживает хранение при переполнении строк, которое позволяет столбцам переменной длины включать внестрочные данные. Для столбцов переменной длины с внестрочными данными в главной записи хранится только 24-байтовый корень. По этой причине фактический предел длины выше, чем в предыдущих версиях SQL Server. Дополнительные сведения см. в разделе «Превышающие размер страницы данные строки размером более 8 КБ» электронной документации по SQL Server 2005.

Объекты репликации

В следующей таблице приводятся максимальные размеры и количества различных объектов, определяемых в репликации SQL Server 2005. Таблица не включает выпуск SQL Server Windows CE Edition.

Объект репликации SQL Server 2005 | Максимальные размеры и количества для 32-разрядной версии SQL Server 2005 | Максимальные размеры и количества для 64-разрядной версии SQL Server 2005
Статей (публикация слиянием) | 256 | 256
Статей (моментальный снимок или публикация транзакций) | 32 767 | 32 767
Столбцов в таблице1 (публикация слиянием) | 246 | 246
Столбцов в таблице2 (моментальный снимок или публикация транзакций SQL Server) | 1000 | 1 000
Столбцов в таблице2 (моментальный снимок или публикация транзакций Oracle) | 995 | 995
Байтов на столбец, используемый в фильтре строк (публикация слиянием) | 1 024 | 1024
Байтов на столбец, используемый в фильтре строк (моментальный снимок или публикация транзакций) | 8000 | 8 000

1 Если для обнаружения конфликтов применяется трассировка на уровне строк (по умолчанию), базовая таблица может содержать не более 1 024 столбцов, но столбцы из статьи должны быть отфильтрованы, поэтому публикуется не более 246 столбцов. Если применяется трассировка на уровне строк, базовая таблица может содержать не более 246 столбцов. Дополнительные сведения об уровне трассировки см. в разделе «Уровень трассировки» в подразделе Способы обнаружения и разрешения конфликтов, используемые при репликации слиянием.

2. Базовая таблица может включать максимальное количество столбцов, разрешенное в базе данных публикации (1 024 для SQL Server), но столбцы должны быть отфильтрованы из статей, если они превышают максимальное количество, заданное для данного типа публикации.

См. также

Справочник

Требования к оборудованию и программному обеспечению для установки SQL Server 2005
Параметры для средства проверки конфигурации системы

Другие ресурсы

Установка компонентов SQL Server 2005

Журнал изменений

Версия Журнал

12 декабря 2006 г.

Измененное содержимое
  • Удалено ограничение в разделе «Объекты компонента Database Engine», связанное с количеством байтов в исходном тексте хранимой процедуры.

  • Обновлено максимальное возможное число экземпляров на одном компьютере.

17 июля 2006 г.

Измененное содержимое
  • Обновлено максимальное возможное число экземпляров на одном компьютере.


Максимальное количество процессоров, поддерживаемых выпусками SQL Server 2005

Максимальное количество процессоров, поддерживаемых выпусками SQL Server 2005 |
 | См. также
Настройка установки SQL Server > Спецификации продукта SQL Server 2005 >

Следующая таблица показывает, какое количество процессоров поддерживается в каждом выпуске SQL Server 2005.

Выпуск SQL Server 2005 | Количество поддерживаемых процессоров (32-разрядный) | Количество поддерживаемых процессоров (64-разрядный)
Выпуск Enterprise Edition | Максимальный объем, поддерживаемый операционной системой1 | Максимальный объем, поддерживаемый операционной системой1
Выпуск Developer Edition | Максимальный объем, поддерживаемый операционной системой1 | Максимальный объем, поддерживаемый операционной системой1
Выпуск Standard Edition | 4 | 4
Выпуск Workgroup Edition | 2 | н/д2
SQL Server Express Edition | 1 | н/д2
Выпуск Evaluation Edition | Максимальный объем, поддерживаемый операционной системой1 | Максимальный объем, поддерживаемый операционной системой1

1Эти выпуски SQL Server 2005 поддерживают максимальное число процессоров, поддерживаемых ОС.

2. Версия данного выпуска SQL Server 2005 для 64-разрядных платформ отсутствует.

См. также

Справочник

Объем памяти, поддерживаемый разными выпусками SQL Server 2005
Требования к оборудованию и программному обеспечению для установки SQL Server 2005

Другие ресурсы

Спецификации продукта SQL Server 2005

Журнал изменений

Версия Журнал

17 июля 2006 г.

Измененное содержимое:
  • Обновлена поддержка выпуска Standard Edition, который поддерживает четыре процессора, а не максимальный объем, поддерживаемый операционной системой.


Объем памяти, поддерживаемый разными выпусками SQL Server 2005

Объем памяти, поддерживаемый разными выпусками SQL Server 2005 |
 | См. также
Настройка установки SQL Server > Спецификации продукта SQL Server 2005 >

В следующей таблице приведены сведения о максимальных объемах памяти, поддерживаемых каждым выпуском Microsoft SQL Server 2005.

Выпуск SQL Server 2005 | Максимальный объем памяти (32-разрядный) | Максимальный объем памяти (64-разрядный)
Выпуск Enterprise Edition | Максимальный объем, поддерживаемый ОС1 | Максимальный объем, поддерживаемый ОС1
Выпуск Developer Edition | Максимальный объем, поддерживаемый ОС | 32 ТБ
Выпуск Standard Edition | Максимальный объем, поддерживаемый ОС | 32 ТБ
Выпуск Workgroup Edition | 3 ГБ | н/д2
Выпуск SQL Server Express Edition | 1 ГБ | н/д2
Выпуск Evaluation Edition | Максимальный объем, поддерживаемый ОС | Максимальный объем, поддерживаемый ОС

1Выпуск SQL Server 2005 Enterprise Edition будет поддерживать максимальный объем памяти, поддерживаемый операционной системой.

2Версия данного выпуска SQL Server 2005 для 64-разрядных платформ отсутствует.

См. также

Справочник

Требования к оборудованию и программному обеспечению для установки SQL Server 2005

Другие ресурсы

Спецификации продукта SQL Server 2005


Справочник по пользовательскому интерфейсу программы установки

Справочник по пользовательскому интерфейсу программы установки |
 | См. также

В данном разделе описаны параметры установки, выбираемые в мастере установки . Эти параметры позволяют устанавливать компоненты SQL Server 2005 и обновлять существующий экземпляр SQL Server до версии SQL Server 2005.

Изменение или удаление экземпляра SQL Server 2005 выполняется с помощью программы Установка и удаление программ на панели управления. Дополнительные сведения о процессе обслуживания экземпляра см. в разделе Как изменить компоненты существующего экземпляра SQL Server 2005 (программа установки). Дополнительные сведения об удалении экземпляра см. в разделе Как удалить существующий экземпляр SQL Server 2005 (программа установки).

См. также

Задачи

Как установить SQL Server 2005 (программа установки)

Основные понятия

Подготовка к установке SQL Server 2005
Зарезервированные ключевые слова (Установка)

Другие ресурсы

Обновление до SQL Server 2005
Настройка высокого уровня доступности


Установка необходимых программ

Установка необходимых программ |
 | См. также
Справочник по пользовательскому интерфейсу программы установки >

Для успешной установки необходимо наличие на компьютере, где проводится установка, следующих компонентов программного обеспечения (они будут установлены программой установки SQL Server):

  • Платформа Microsoft .NET Framework версии 2.0

  • Microsoft Собственный клиент SQL Server

  • Microsoft Файлы поддержки программы установки SQL Server 2005

Примечание.
В случае сбоя или отмены установки эти компоненты не удаляются. Для их удаления используйте средство Установка и удаление программ панели управления.

См. также

Задачи

Как установить SQL Server 2005 (программа установки)

Справочник

Требования к оборудованию и программному обеспечению для установки SQL Server 2005
Параметры для средства проверки конфигурации системы

Основные понятия

Анализ безопасности при установке SQL Server


Проверка конфигурации системы (SCC)

Проверка конфигурации системы (SCC) |
 | См. также
Справочник по пользовательскому интерфейсу программы установки >

Пользователи выпуска SQL Server Express: щелкните Проверка конфигурации системы (SQL Server Express), чтобы получить сведения, касающиеся установки SQL Server Express.

На странице Проверка конфигурации системы (SCC) мастера установки отображается ход операций инструмента подготовки системы. Процедуры проверки конфигурации системы (SCC) сканируют компьютер назначения в поисках условий, которые могут блокировать программу установки. При работе в кластерах SCC запускается на всех узлах виртуального сервера.

Чтобы отменить выполнение SCC и выйти из мастера установки, пользователь в любой момент может нажать кнопку Стоп.

Символы хода операций.

  • Символ стрелки = проверка выполняется.

  • Символ флажка = проверка элемента выполнена успешно.

  • Символ X = проверка элемента закончилась неудачей.

После завершения проверки SCC становится доступной кнопка Отчет. Кнопка Продолжить становится доступной, только если успешно выполнена проверка всех элементов или если неудачные проверки некритичны. В отчет SCC вместе с результатами проверки включаются критические препятствия, проверка которых закончилась неудачей.

Кнопка Отчет внизу страницы SCC позволяет просмотреть отчет, сохранить его в виде файла, скопировать в буфер обмена или отправить по электронной почте. Сведения, представленные в отчете, включают следующие компоненты.

  • Список элементов конфигурации, проверенных на компьютере назначения: требования для текущей операционной системы, номер пакета обновления операционной системы, совместимость выпуска SQL Server с текущей операционной системой и службами IIS.

  • Результат проверки каждого элемента.

  • Рекомендуемые действия пользователя для снятия критических препятствий.

См. также

Задачи

Как установить SQL Server 2005 (программа установки)

Справочник

Параметры для средства проверки конфигурации системы
Требования к оборудованию и программному обеспечению для установки SQL Server 2005


Регистрационные сведения

Регистрационные сведения |
 | См. также
Справочник по пользовательскому интерфейсу программы установки >

Пользователи выпуска SQL Server Express Edition: щелкните ссылку Регистрационные сведения (SQL Server Express), чтобы получить сведения по установке выпуска SQL Server Express Edition.

Страница Регистрационные сведения мастера установки используется для ввода идентификационных сведений, которые применяются для регистрации копии SQL Server. Сведения о регистрации включают имя пользователя, название компании и ключ продукта. Ключ продукта необходимо ввести только при первой установке. Во время последующих установок он показывается автоматически.

Параметры

Имя

Введите имя. При установке SQL Server на сетевой сервер введите имя пользователя, отвечающего за администрирование этого сервера. Имя пользователя необходимо для продолжения установки.

Компания

Введите название компании. Если копия продукта предназначена для одного пользователя, можно снова ввести имя. Вводить сведения в этом поле необязательно.

Ключ продукта

Введите ключ продукта, который находится на конверте установочного DVD-диска SQL Server 2005.

См. также

Задачи

Как установить SQL Server 2005 (программа установки)


Компоненты для установки

Компоненты для установки |
 | См. также
Справочник по пользовательскому интерфейсу программы установки >

Дата обновления: 14 апреля 2006 г.

Чтобы выбрать группы компонентов для установки , установите нужные флажки на странице Компоненты для установки мастера установки SQL Server.

Параметры

При выборе группы компонентов ее описание отображается на панели Компоненты, которые необходимо установить. Можно установить любое сочетание компонентов, используя флажки.

Если нужно выбрать для установки отдельные функции, нажмите кнопку Дополнительно. Чтобы установить компоненты в произвольную папку или узнать, сколько свободного места на диске необходимо для отдельных компонентов и функций, нажмите кнопку Дополнительно.

Выберите эту группу компонентов Чтобы установить эти компоненты и функции

Службы SQL Server Database Services

SQL Server Database Engine содержит следующие технологии:

  • Компонент Database Engine — основная служба для хранения, обработки и защиты данных.

  • Репликация — это набор технологий копирования и распространения данных и объектов баз данных из одной базы данных в другую, а также последующей синхронизации между базами данных для поддержания согласованности.

  • Компонент Full-Text Search позволяет выполнять полнотекстовые запросы в таблицах SQL Server для произвольных символьных данных.

  • Средства управления реляционными и XML-данными.

Службы Analysis Services

Службы Analysis Services содержат средства, чтобы создавать и управлять приложениями оперативной аналитической обработки (OLAP) и приложениями интеллектуального анализа данных.

Службы Reporting Services1,2,3,4

Службы Reporting Services включают в себя серверные и клиентские компоненты для создания, управления и развертывания табличных, матричных и графических отчетов, а также отчетов в свободной форме. Службы Reporting Services являются расширяемой платформой, которую можно использовать для разработки приложений отчетов.

Notification Services

Службы Notification Services представляют собой платформу для разработки и развертывания приложений, своевременно отправляющих индвидуально настроенные актуальные сведения подписчикам, использующим устройства различного типа.

Службы Integration Services

Службы Integration Services представляют собой набор графических средств и программируемых объектов для перемещения, копирования и преобразования данных.

Компоненты рабочей станции, электронная документация и средства разработки 5,6

Устанавливает компоненты для связи между клиентами и серверами, включая сетевые библиотеки для DB-Library, OLEDB для OLAP, ODBC, ADODB и ADOMD+.

Средства управления

  • Среда SQL Server Management Studio (SSMS), впервые появившаяся в Microsoft SQL Server 2005, представляет собой интегрированную среду для доступа ко всем компонентам SQL Server, управления ими, их настройки, разработки и администрирования. Среда SQL Server Management Studio объединяет возможности программ Enterprise Manager, Query Analyzer и Analysis Manager, входивших в состав более ранних версий SQL Server, в единой среде, обеспечивающей доступ к SQL Server разработчикам и администраторам с любым уровнем подготовки.

  • Диспетчер конфигурации SQL Server обеспечивает базовые возможности управления конфигурациями для служб, серверных протоколов, клиентских протоколов и псевдонимов клиентов SQL Server.

  • Приложение SQL Server Profiler предоставляет графический пользовательский интерфейс для мониторинга экземпляра компонента Database Engine или экземпляра служб Analysis Services.

  • Помощник по настройке ядра СУБД помогает создавать оптимальные наборы индексов, индексированных представлений и секций.

  • С помощью монитора репликации можно отслеживать состояние и производительность публикаций и подписок в топологии репликации.

  • Клиентские функции SQLXML

Документация

  • Электронная документация по SQL Server является базовой для SQL Server 2005.

  • Наборы средств разработки программного обеспечения

Средства разработки

  • Business Intelligence Development Studio представляет собой интегрированную среду разработки для решений служб Analysis Services, Reporting Services и Integration Services.

1Программа установки не настраивает балансировку нагрузки и адресацию по одному URL-адресу для нескольких узлов при масштабном развертывании сервера отчетов. Чтобы завершить масштабное развертывание, необходимо использовать Windows Server, Microsoft Application Center или программное обеспечение по управлению кластерами сторонних разработчиков. Дополнительные сведения о параметрах развертывания веб-фермы см. в разделе Настройка масштабного развертывания сервера отчетов.

2Службы Reporting Services недоступны, если не установлены службы IIS версии 5.0 или более поздней. Для компонента конструктора отчетов служб Reporting Services необходим обозреватель Microsoft Internet Explorer 6.0 с пакетом обновления 1 (SP1).

3Для установки служб Reporting Services (64-разрядных) на 64-разрядные серверы необходимо установить 64-разрядную версию ASP.NET. Для установки служб Reporting Services (32-разрядных) на 32-разрядные подсистемы (WOW64) 64-разрядного сервера необходимо установить 32-разрядную версию ASP.NET.

4Службы Reporting Services не поддерживаются в параллельных конфигурациях на 64-разрядной платформе и 32-разрядной подсистеме (WOW64) 64-разрядного сервера.

5 Для установки среды SQL Server Management Studio требуется обозреватель Internet Explorer версии 6.0 с пакетом обновления 1 (SP1).

6 Для установки среды Business Intelligence Development Studio требуется обозреватель Internet Explorer версии 6.0 с пакетом обновления 1 (SP1).

Установка отказоустойчивого кластера

При выборе SQL Server или служб Analysis Services, если программа установки определила, что производится установка на виртуальный сервер, будут доступны флажки Создать отказоустойчивый кластер SQL Server или Создать отказоустойчивый кластер сервера анализа данных. Необходимо установить этот флажок для установки отказоустойчивого кластера.

Для обновления экземпляра SQL Server до отказоустойчивого кластера SQL Server 2005 обновляемый экземпляр должен быть отказоустойчивым кластером. Чтобы обновить изолированный экземпляр SQL Server до отказоустойчивого кластера SQL Server 2005, установите новый отказоустойчивый кластер SQL Server 2005, а затем выполните миграцию пользовательских баз данных из изолированного экземпляра при помощи мастера копирования баз данных. Дополнительные сведения об обновлении см. в разделе Как произвести обновление до отказоустойчивого кластера SQL Server 2005 (установка). Дополнительные сведения о миграции баз данных см. в разделе Использование мастера копирования баз данных.

Установка образцов баз данных AdventureWorks

Базы данных AdventureWorks, AdventureWorksDW, AdventureWorksAS и другие связанные с ними образцы баз данных по умолчанию не устанавливаются. Чтобы установить какие-либо из них, выберите Компоненты для рабочих станций, электронная документация и средства разработки на странице Компоненты для установки во время установки SQL Server 2005 и нажмите кнопку Дополнительно. Разверните узел Документация и образцы и выберите базы данных и образцы для установки.

См. также

Справочник

Выпуски и компоненты SQL Server 2005
Выбор компонентов


Выбор компонентов

Выбор компонентов |
 | См. также
Справочник по пользовательскому интерфейсу программы установки >

Дата обновления: 14 апреля 2006 г.

Пользователи выпуска SQL Server Express: щелкните ссылку Выбор компонентов (SQL Server Express), чтобы просмотреть сведения, относящиеся к установке SQL Server Express.

Используйте страницу Выбор компонентов мастера установки для выбора индивидуальных особенностей установки и определите каталог установки. Для существующей установки используйте эту страницу для добавления и удаления компонентов.

Параметры

Страница Выбор компонентов содержит две панели. Левая панель показывает дерево функций, которые можно установить и раскрыть функцию для просмотра ее компонентов. Правая панель отображает описание этих функций. Когда выбирается компонент или его часть, панель Описание компонента отобразит описание выбранного элемента и требования к месту на диске при установке.

Чтобы добавить или удалить функцию, щелкните стрелку за именем функции, затем выберите один из следующих параметров из раскрывающегося списка:

Будет установлен на локальный жесткий диск

Устанавливает выбранную функцию в расположение, заданное строкой Папка установки.

Функция будет установлена на жесткий диск полностью

Установка выбранной функции и всех вложенных компонентов. Раскрывает корневую функцию для просмотра ее вложенных компонентов.

Будет установлена для запуска по сети

Запустите следующие элементы по сети:

  • Монитор репликации

Полная функциональность будет недоступна

Для новых экземпляров SQL Server этот параметр будет передан всем установкам выбранных функций. Для существующего экземпляра этот параметр удаляет установленную функцию. После того как был выбран этот параметр, красный символ X появится в дереве функций рядом с именем функции, а значок на родительской функции в дереве просмотра окажется серым.

Примечание.
Невозможно удалить функцию, если выбран один из вложенных компонентов. Чтобы отменить выбор функции, убедитесь, что снят выбор со всех вложенных компонентов.

Страница Выбор компонентов также предлагает следующие параметры:

Путь установки

В ходе установки можно изменить путь для установки следующих компонентов.

Путь установки отображается только для функций, которые могут быть установлены в папку, выбранную пользователем.

Компонент Путь по умолчанию1, 2 Изменяемый или фиксированный путь

серверные компоненты Database Engine

\Program Files\Microsoft SQL Server\MSSQL.n\MSSQL\Binn\

Настраиваемый

Файлы данных компонента Database Engine

\Program Files\Microsoft SQL Server\MSSQL.n\MSSQL\Data\

Настраиваемый

Сервер служб Analysis Services

\Program Files\Microsoft SQL Server\MSSQL.n\OLAP\Bin\

Настраиваемый

Файлы данных служб Analysis Services

\Program Files\Microsoft SQL Server\MSSQL.n\OLAP\Data\

Настраиваемый

Сервер отчетов для служб Reporting Services

\Program Files\Microsoft SQL Server\MSSQL.n\Reporting Services\ReportServer\Bin\

Настраиваемый

Диспетчер отчетов для служб Reporting Services

\Program Files\Microsoft SQL Server\MSSQL.n\Reporting Services\ReportManager\Bin\

Фиксированный путь

Integration Services

<Каталог установки>\90\DTS\

Настраиваемый4

Notification Services

<Каталог установки>\90\Notification Services\

Настраиваемый4

Клиентские компоненты

<Каталог установки>\90\Tools\

Настраиваемый4

Объекты COM для репликации и размещения на сервере

Program Files\Microsoft SQL Server\90\COM\5

Фиксированный путь

Библиотеки DLL служб Integration Services для механизмов преобразования данных в реальном режиме времени и конвейерной трансформации данных, и программа командной строки dtexec

Program Files\Microsoft SQL Server\90\DTS\Binn

Фиксированный путь

Библиотеки DLL, которые обеспечивают управляемое соединение, поддерживаемое для служб Integration Services

Program Files\Microsoft SQL Server\90\DTS\Connections

Фиксированный путь

Библиотеки DLL для каждого типа перечислителей, которые поддерживают службы Integration Services

Program Files\Microsoft SQL Server\90\DTS\ForEachEnumerators

Фиксированный путь

Служба обозревателя SQL Server, поставщики инструментария WMI

\Program Files\Microsoft SQL Server\90\Shared\

Фиксированный путь

Компоненты, которые разделены между всеми экземплярами SQL Server 2005

\Program Files\Microsoft SQL Server\90\Shared\

Фиксированный путь

1Убедитесь, что папка \Program Files\Microsoft SQL Server\ защищена, ограничив разрешения на доступ.

2 Диск, используемый по умолчанию для этих размещений, определен как systemdrive. Обычно это диск C.

3 Пути установки для вложенных компонентов определяются путями установки родительских функций.

4 Путь установки, разделяемый между службами Integration Services, службами Notification Services и клиентскими компонентами. Изменение пути установки для одного компонента влечет изменение пути для других компонентов. Последующие установки установят компоненты по тому же размещению, что и начальная установка.

5Этот каталог используется всеми экземплярами SQL Server, установленными на компьютере. В случае применения обновления (например, установки пакета обновления) к любому из экземпляров на компьютере любое изменение файлов в этой папке затронет все экземпляры, установленные на компьютере.

Примечание.
Для кластеризованных конфигураций необходимо выбрать локальный диск, доступный на всех узлах кластера.

Примечание.
При добавлении компонентов к уже установленной конфигурации невозможно изменить расположение ранее установленного компонента или указать расположение нового компонента.

При задании пути установки во время установки компонентов сервера или файлов данных, программа установки использует идентификатор экземпляра в дополнение к заданному положению для программ и файлов данных. Программа установки не использует имя экземпляра в именах средств и других общих файлах. Программа установки также не использует имя экземпляра для файлов программ и данных служб Analysis Services, но использует имя экземпляра для репозитория служб Analysis Services.

Дополнительные сведения о каталогах установки см. в разделе Расположение файлов для экземпляра по умолчанию и именованных экземпляров SQL Server 2005.

Дополнительные сведения о требованиях к месту на жестком диске см. в разделе Требования к оборудованию и программному обеспечению для установки SQL Server 2005.

При указании пути установки для компонента Database Engine программа установки SQL Server использует этот путь в качестве корневого каталога этой установки для всех папок, относящихся к экземпляру, включая «Файлы данных SQL». В этом случае, если установлен корневой каталог «C:\Program Files\Microsoft SQL Server\MSSQL.1\MSSQL\», папки экземпляров будут прикреплены к этому пути.

Пользователи, использующие возможности обновления USESYSDB в мастере установки SQL Server (программа установки в режиме интерфейса пользователя), могут оказаться в ситуации, когда продукт устанавливается в рекурсивную структуру папок — например <SQLProgramFiles>\MSSQL.1\MSSQL\MSSQL.1\MSSQL\Data\. Вместо использования компонента USESYSDB задайте путь установки для компонента «Файлы данных SQL», а не для компонента Database Engine.

Примечание. Предполагается, что файлы данных всегда будут находиться в подкаталоге Data. Например во время обновления задайте в качестве корневого пути к данным системных баз данных каталог «C:\Program Files\Microsoft SQL Server\MSSQL.1\». Тогда файлы данных будут располагаться в каталоге «C:\Program Files\Microsoft SQL Server\MSSQL.1\».

Примечание. Нельзя установить SQL Server Windows on Windows (WOW64) в корневой каталог физического диска. Для изменяемых путей должен использоваться каталог, находящийся на уровне ниже корневого. Например нельзя установить серверные компоненты ядра СУБД в каталог C:\. Но можно установить этот компонент в каталог «C:\SQL Server\». Дополнительные сведения о WOW64 см. в описании расширенной системной поддержки в разделе Требования к оборудованию и программному обеспечению для установки SQL Server 2005.

Установка образцов баз данных AdventureWorks

Базы данных AdventureWorks Sample OLTP, AdventureWorksDW Sample Data Warehouse и AdventureWorks Sample OLAP и относящиеся к ним образцы по умолчанию не устанавливаются. Для установки одной или более из этих функций выберите пункты Компоненты рабочей станции, электронная документация и средства разработки со страницы Компоненты для установки во время установки SQL Server 2005, а затем нажмите кнопку Дополнительно. Раскройте пункт Документация и образцы, а затем выберите базы данных и образцы, которые нужно установить.

Обзор...

Открывает страницу Смена папки, которая позволяет изменить папку, в которую будут установлены выбранные элементы. Эта кнопка доступна только для тех элементов, для которых возможно задание пути установки пользователем. Пути установки для вложенных компонентов задаются путем установки их родительской функции. Дополнительные сведения о путях установки см. в разделе Расположение файлов для экземпляра по умолчанию и именованных экземпляров SQL Server 2005.

Место на диске...

Отображает доступное для установки дисковое пространство на различных системных дисках компьютера. После проверки дискового пространства на компьютере в диалоговом окне Расход дискового пространства нажмите кнопку Закрыть для продолжения установки SQL Server.

Примечание.
Кнопки Обзор... и Место на диске... на этой странице отключены для компонента отказоустойчивого кластера, так как для установки отказоустойчивого кластера существует отдельная страница Папки установки.

См. также

Справочник

Выпуски и компоненты SQL Server 2005
Требования к оборудованию и программному обеспечению для установки SQL Server 2005
Компоненты для установки

Основные понятия

Отказоустойчивый кластер


Имя экземпляра

Имя экземпляра |
 | См. также
Справочник по пользовательскому интерфейсу программы установки >

Пользователи выпуска SQL Server Express Edition: чтобы получить специальную информацию об установке выпуска SQL Server Express Edition, щелкните ссылку Имя экземпляра (SQL Server Express).

На странице Имя экземпляра мастера установки SQL Server можно выбрать создание экземпляра SQL Server по умолчанию или именованного экземпляра. Если не выбрано создание именованного экземпляра, используется имя по умолчанию.

Каждый экземпляр SQL Server включает в себя отдельный набор служб с заданными настройками параметров сортировки и прочих параметров. Структура каталогов и реестра, а также наименования служб соответствуют конкретному идентификатору экземпляра SQL Server, созданному в процессе установки SQL Server.

Экземпляр является либо экземпляром по умолчанию, либо именованным. Имя экземпляра по умолчанию — MSSQLSERVER; клиенту не требуется указывать это имя, чтобы подключиться. Именованный экземпляр определяется пользователем при установке.

Именованный экземпляр можно установить в любое время. По умолчанию при первой установке SQL Server 2005 на компьютер выбрана установка экземпляра по умолчанию, однако можно сразу выбрать установку именованного экземпляра SQL Server, не устанавливая экземпляр по умолчанию. Экземпляром по умолчанию могут быть версии SQL Server 6.5, 7.0, 2000 или 2005. В системе может быть только одна установка SQL Server по умолчанию, независимо от различных установленных версий.

Несколько экземпляров

SQL Server 2005 поддерживает создание нескольких экземпляров SQL Server на одном сервере или процессоре, но только один из них может быть экземпляром по умолчанию. Остальные должны быть именованными экземплярами. На одном компьютере одновременно можно запустить несколько экземпляров SQL Server, и каждый экземпляр выполняется независимо от других. Все экземпляры, запущенные на одном сервере или процессоре, должны быть экземплярами одинаковой локализованной версии SQL Server 2005.

В следующей таблице указано количество экземпляров, поддерживаемых для каждого зависящего от экземпляра компонента, в разных выпусках SQL Server 2005.

Выпуск SQL Server 2005 | Экземпляры компонента Database Engine | Экземпляры служб Analysis Services | Экземпляры служб Reporting Services
Enterprise Edition Developer Edition | 50 | 50 | 50
Standard Edition Workgroup Edition Express Edition | 16 | 16 | 16

Параметры

Если выбран Экземпляр по умолчанию, и такой экземпляр уже существует на компьютере, программа установки SQL Server выполнит обновление экземпляра по умолчанию. Если введено имя именованного экземпляра и экземпляр с этим именем уже существует на компьютере, программа установки SQL Server выполнит обновление именованного экземпляра.

Все компоненты одного экземпляра SQL Server 2005 управляются как единое целое; все пакеты обновления и отдельные обновления SQL Server будут применены к каждому компоненту экземпляра SQL Server.

Следующие сведения помогут выбрать между установкой экземпляра по умолчанию и именованного экземпляра SQL Server 2005.

  • При обновлении с версии SQL Server 7.0 обновленный экземпляр становится экземпляром по умолчанию.

  • Если планируется установить один экземпляр SQL Server на сервере базы данных, то это должен быть экземпляр по умолчанию.

  • Если необходимо поддерживать подключение клиентов версии SQL Server 7.0 или более ранней, для этого больше подойдет экземпляр по умолчанию. Хотя старые клиенты можно настроить для подключения к именованному экземпляру, каждый клиент требует указания «имени сервера» и жестко закрепленного сетевого адреса именованного экземпляра.

  • Именованный экземпляр подходит в тех случаях, когда планируется запускать несколько экземпляров на одном компьютере, так как на сервере может размещаться только один экземпляр по умолчанию.

  • Приложения, устанавливающие выпуск SQL Server Express Edition, должны устанавливать его как именованный экземпляр. Таким образом, минимизируются потенциальные конфликты при установке нескольких приложений на одном компьютере.

Экземпляр по умолчанию

Выберите этот параметр, чтобы установить экземпляр SQL Server 2005 по умолчанию. На компьютере может размещаться только один экземпляр по умолчанию; остальные должны быть именованными. Однако если экземпляр SQL Server по умолчанию уже установлен, на этот же компьютер можно добавить экземпляр служб Analysis Services по умолчанию.

Чтобы обновить экземпляр по умолчанию предыдущей версии SQL Server, установите переключатель Экземпляр по умолчанию и нажмите кнопку Далее.

Именованный экземпляр

Выберите этот параметр, чтобы создать новый именованный экземпляр. При указании имени экземпляра SQL Server учитывайте следующее.

  • Имена экземпляров не зависят от регистра.

  • Имена экземпляров не могут содержать термины «Default»,«MSSQLServer» и иные зарезервированные ключевые слова. Если в имени экземпляра используется зарезервированное ключевое слово, возникнет ошибка установки.

  • Длина имени экземпляра ограничена шестнадцатью символами.

  • Первым символом в имени экземпляра должна быть буква или символ подчеркивания (_). Допустимыми буквами являются буквы, определенные Юникодом 2.0, включая латинские символы a-z и A-Z, а также буквенные символы из других языков.

  • Следующими за первым символом могут быть буквы, определенные Юникодом 2.0, десятичные числа из набора символов Basic Latin и других национальных шрифтов, знак доллара ($) и символ подчеркивания (_).

  • В имени экземпляра не допускаются пробелы и другие специальные символы, включая обратную косую черту (\), запятую (,), двоеточие (:), точку с запятой (;), одиночную кавычку ('), амперсанд (&) и знак (@).

    Примечание.
    В имени экземпляра SQL Server могут использоваться только символы, определенные текущей кодовой страницей Microsoft Windows. При использовании неподдерживаемого символа Юникода возникает ошибка установки.

Установленные экземпляры

Просмотр перечня установленных экземпляров и компонентов SQL Server. В области подробных сведений об установленных экземплярах отображаются параметры обновления установленных экземпляров.

Обратите внимание, что все компоненты SQL Server, использующие одно и то же имя экземпляра, должны соответствовать следующим критериям:

  • Одинаковая версия. Например, нельзя установить экземпляр SQL Server 2005 Analysis Services (SSAS) с тем же именем экземпляра, что и SQL Server 2000 Database Engine, на одном компьютере. Кроме того, при обновлении одного компонента с данным именем экземпляра до новой версии или при установке пакета обновления для него следует обновить все компоненты этого экземпляра.

  • Одинаковый выпуск. Например, нельзя установить экземпляр SQL Server 2005 Integration Services (SSIS) выпуска Evaluation Edition с тем же именем экземпляра, что и SQL Server 2005 Database Engine выпуска Enterprise Edition, на одном компьютере.

  • Одинаковый язык. Например, нельзя установить немецкий экземпляр компонента SQL Server 2005 Database Engine с тем же именем экземпляра, что и португальский экземпляр среды SQL Server Management Studio, на одном компьютере.

  • Одинаковое состояние кластеризации. Например, нельзя установить кластеризованный экземпляр SQL Server 2005 Analysis Services (SSAS) с тем же именем экземпляра, что и некластеризованный экземпляр SQL Server 2005 Database Engine, на одном компьютере.

    Примечание.
    Служба Reporting Services не имеет ограничений на кластеризацию.

  • Одинаковая платформа. Например, нельзя установить экземпляр 32-разрядной версии среды Business Intelligence Development Studio с тем же именем экземпляра, что и экземпляр 64-разрядной версии компонента SQL Server 2005 Database Engine.

См. также

Другие ресурсы

Разделы руководства по установке компонента Database Engine


Установленные экземпляры

Установленные экземпляры |
 | См. также
Справочник по пользовательскому интерфейсу программы установки >

На странице Установленные экземпляры мастера установки можно просмотреть список экземпляров и компонентов SQL Server, установленных на компьютере, на котором выполняется программа установки SQL Server. На панели Подробности об установленном экземпляре выводятся параметры обновления установленных экземпляров.

Параметры

Чтобы выбрать компонент или экземпляр для обновления, щелкните его имя и нажмите ОК.

См. также

Другие ресурсы

Обновление до SQL Server 2005


Существующие компоненты

Существующие компоненты |
 | См. также
Справочник по пользовательскому интерфейсу программы установки >

Пользователи выпуска SQL Server Express Edition: щелкните Существующие компоненты (SQL Server Express) для получения сведений, относящихся к установке выпуска SQL Server Express.

На странице Существующие компоненты мастера установки можно просмотреть список компонентов SQL Server, установленных на компьютер, где запущена программа установки SQL Server.

Параметры

Нажмите кнопку Подробности, чтобы отобразить отчет, перечисляющий параметры обслуживания или обновления для каждого установленного компонента SQL Server.

Доступные действия

Обслуживание: обслуживание компонентов производится с помощью окна «Установка и удаление программ» панели управления.

Обновление: существующие компоненты можно обновить до SQL Server 2005.

См. также

Другие ресурсы

Обновление до SQL Server 2005


Параметры установки

Параметры установки |
 | См. также
Справочник по пользовательскому интерфейсу программы установки >

Дата обновления: 14 апреля 2006 г.

Пользователи выпуска SQL Server Express Edition: щелкните ссылку Параметры установки (SQL Server Express) для получения сведений, которые относятся только к установке выпуска SQL Server Express.

Страница Параметры установки мастера установки Microsoft SQL Server предоставляет информацию о параметрах обслуживания и обновления установленных экземпляров и компонентов SQL Server. Эта страница отображается, если компоненты, которые пользователь собирается установить, входят в состав установленного экземпляра SQL Server, имеющего то же имя.

Параметры

В следующих разделах описаны параметры обслуживания и обновления SQL Server.

Обслуживание

Обслуживание экземпляров и компонентов SQL Server 2005, в том числе отказоустойчивых кластеров, осуществляется с помощью раздела «Установка и удаление программ» панели управления.

Обновление

В этом выпуске SQL Server 2005 поддерживаются следующие сценарии обновления.

Исходная версия | Поддерживаемые варианты обновления
SQL Server 7.0 Enterprise Edition с пакетом обновления 4 (SP4) | SQL Server 2005 Enterprise Edition
SQL Server 7.0 Developer Edition с пакетом обновления 4 (SP4) | SQL Server 2005 Enterprise Edition SQL Server 2005 Developer Edition
SQL Server 7.0 Standard Edition с пакетом обновления 4 (SP4) | SQL Server 2005 Standard Edition SQL Server 2005 Enterprise Edition
SQL Server 7.0 Desktop Edition с пакетом обновления 4 (SP4) | SQL Server 2005 Standard Edition SQL Server 2005 Workgroup Edition
SQL Server 7.0 Evaluation Edition с пакетом обновления 4 (SP4) | Обновления не поддерживаются
SQL Server Desktop Engine (MSDE) 7.0 с пакетом обновления 4 (SP4) | SQL Server 2005 Express Edition
SQL Server 2000 Enterprise Edition с пакетом обновления 3 (SP3) или более поздней версии1 | SQL Server 2005 Enterprise Edition
SQL Server 2000Developer Edition с пакетом обновления 3 (SP3) или более поздней версии1 | SQL Server 2005 Developer Edition
SQL Server 2000Standard Edition с пакетом обновления 3 (SP3) или более поздней версии1 | SQL Server 2005 Enterprise Edition SQL Server 2005 Developer Edition SQLServer2005 Standard Edition
SQL Server 2000Workgroup Edition с пакетом обновления 3 (SP3) или более поздней версии1 | SQL Server 2005 Enterprise Edition SQL Server 2005 Developer Edition SQLServer2005 Standard Edition SQL Server 2005 Workgroup Edition
SQL Server 2000Personal Edition с пакетом обновления 3 (SP3) или более поздней версии1 | SQLServer2005 Standard Edition SQL Server 2005 Workgroup Edition SQL Server 2005 Express Edition SQL Server 2005 Express Edition с дополнительными службами
SQL Server 2000Evaluation Edition с пакетом обновления 3 (SP3) или более поздней версии1 | SQL Server 2005 Evaluation Edition
SQL Server Desktop Engine (MSDE) 2000 с пакетом обновления 3 (SP3) или более поздней версии1 | SQL Server 2005 Workgroup Edition SQL Server 2005 Express Edition SQL Server 2005 Express Edition с дополнительными службами
SQL Server 2000 Enterprise Edition для 64-разрядных систем с архитектурой IA64 | SQL Server 2005 Enterprise Edition для 64-разрядных систем с архитектурой IA64
SQL Server 2000 Developer Edition для 64-разрядных систем с архитектурой IA64 | SQL Server 2005 Enterprise Edition для 64-разрядных систем с архитектурой IA64 SQL Server 2005 Developer Edition для 64-разрядных систем с архитектурой IA64
SQL Server 2005 Developer Edition1 | SQL Server 2005 Enterprise Edition SQL Server 2005 Standard Edition SQL Server 2005 Workgroup Edition
SQL Server 2005 Standard Edition1 | SQL Server 2005 Enterprise Edition SQL Server 2005 Developer Edition
SQL Server 2005 Workgroup Edition1 | SQL Server 2005 Enterprise Edition SQL Server 2005 Developer Edition SQL Server 2005 Standard Edition
SQL Server 2005 Evaluation Edition1 | SQL Server 2005 Enterprise Edition SQL Server 2005 Developer Edition SQL Server 2005 Standard Edition SQL Server 2005 Workgroup Edition SQL Server 2005 Express Edition
SQL Server 2005 Express Edition1 | SQL Server 2005 Enterprise Edition SQL Server 2005 Developer Edition SQL Server 2005 Standard Edition SQL Server 2005 Workgroup Edition SQL Server 2005 Express Edition с дополнительными службами
SQL Server 2005 Developer Edition для 64-разрядных систем с архитектурой IA64 | SQL Server 2005 Enterprise Edition для 64-разрядных систем с архитектурой IA64 SQL Server 2005 Standard Edition для 64-разрядных систем с архитектурой IA64
SQL Server 2005 Developer Edition для 64-разрядных систем с архитектурой X64 | SQL Server 2005 Enterprise Edition для 64-разрядных систем с архитектурой X64 SQL Server 2005 Standard Edition для 64-разрядных систем с архитектурой X64
SQL Server 2005 Standard Edition для 64-разрядных систем с архитектурой IA64 | SQL Server 2005 Enterprise Edition для 64-разрядных систем с архитектурой IA64 SQL Server 2005 Developer Edition для 64-разрядных систем с архитектурой IA64
SQL Server 2005 Standard Edition для 64-разрядных систем с архитектурой X64 | SQL Server 2005 Enterprise Edition для 64-разрядных систем с архитектурой X64 SQL Server 2005 Developer Edition для 64-разрядных систем с архитектурой X64
SQL Server 2005 Evaluation Edition для 64-разрядных систем с архитектурой IA64 | SQL Server 2005 Enterprise Edition для 64-разрядных систем с архитектурой IA64 SQL Server 2005 Developer Edition для 64-разрядных систем с архитектурой IA64 SQL Server 2005 Standard Edition для 64-разрядных систем с архитектурой IA64
SQL Server 2005 Evaluation Edition для 64-разрядных систем с архитектурой X64 | SQL Server 2005 Enterprise Edition для 64-разрядных систем с архитектурой X64 SQL Server 2005 Developer Edition для 64-разрядных систем с архитектурой X64 SQL Server 2005 Standard Edition для 64-разрядных систем с архитектурой X64

1Этот выпуск SQL Server можно обновить до SQL Server 2005 на 32-разрядной подсистеме (WOW64) 64-разрядной версии сервера.

Замечания по обновлению

  • После обновления до SQL Server 2005 с другого выпуска SQL Server 2005 необходимо повторно применить исправления и пакеты обновления к обновленному экземпляру сервера SQL Server.

  • Многоверсионные экземпляры не поддерживаются SQL Server 2005. Номера версий Database Engine, служб Analysis Services и служб Reporting Services для экземпляра SQL Server 2005 должны совпадать.

  • Перед обновлением до SQL Server 2005 включите проверку подлинности Windows для агента SQL Server и убедитесь, что учетная запись службы агента SQL Server находится в группе SQL Server sysadmin.

  • Перед обновлением от одного выпуска SQL Server 2005 до другого проверьте, что используемые функции поддерживаются также и в выпуске, до которого производится обновление. Дополнительные сведения см. в разделе о соответствующих компонентах в Возможности, поддерживаемые различными выпусками SQL Server 2005.

  • Чтобы экземпляр SQL Server можно было обновить до отказоустойчивого кластера SQL Server 2005, обновляемый экземпляр должен быть отказоустойчивым кластером. Чтобы обновить изолированный экземпляр SQL Server до отказоустойчивого кластера SQL Server 2005, установите новый отказоустойчивый кластер SQL Server 2005, а затем перенесите пользовательские базы данных из изолированного экземпляра с помощью мастера копирования баз данных. Дополнительные сведения об обновлении см. в разделе Как произвести обновление до отказоустойчивого кластера SQL Server 2005 (установка). Дополнительные сведения о миграции баз данных см. в разделе Использование мастера копирования баз данных.

Добавление компонентов в экземпляр SQL Server 2005

Добавить компоненты к существующей установке SQL Server 2005 можно, открыв окно Установка и удаление программ на панели управления и выбрав экземпляр SQL Server, к которому нужно добавить компоненты или из которого нужно удалить компоненты. Дополнительные сведения см. в разделе Как изменить компоненты существующего экземпляра SQL Server 2005 (программа установки).

Поддержка версий на разных языках

Для обновлений

  • Англоязычные версии SQL Server можно обновить до любой локализованной версии SQL Server 2005.

  • Локализованные версии SQL Server можно обновить до локализованных версий SQL Server 2005 на том же языке.

  • Локализованную версию SQL Server нельзя обновить до англоязычной версии SQL Server 2005.

  • Локализованные версии SQL Server нельзя обновить до локализованных версий SQL Server 2005 на других языках.

Дополнительная поддержка версий на разных языках

  • Английская версия SQL Server 2005 поддерживается на всех локализованных версиях поддерживаемых операционных систем.

  • Локализованные версии SQL Server 2005 поддерживаются на локализованных операционных системах на том же языке, что и локализованная версия SQL Server.

  • Локализованные версии SQL Server 2005 также поддерживаются в английских версиях поддерживаемых операционных систем с помощью пакета многоязыкового пользовательского интерфейса Windows. Однако необходимо проверить определенные настройки операционной системы перед установкой локализованной версии SQL Server 2005 на сервер под управлением английской версии операционной системы с настройками MUI, отличными от английского языка. Необходимо убедиться, что следующие настройки операционной системы соответствуют языку локализации: SQL Server

    • настройки пользовательского интерфейса операционной системы;

    • пользовательские настройки языкового стандарта операционной системы;

    • настройки языка системы.

    Если эти настройки операционной системы не соответствуют языку локализованной версии SQL Server, их необходимо изменить так, как описано в разделе Как изменить настройки операционной системы для поддержки локализованных версий.

См. также

Другие ресурсы

Обновление до SQL Server 2005


Учетная запись службы

Учетная запись службы |
 | См. также
Справочник по пользовательскому интерфейсу программы установки >

Дата обновления: 5 декабря 2005 г.

Пользователи выпуска SQL Server Express Edition: щелкните Учетная запись службы (SQL Server Express) для получения сведений, относящихся к установке выпуска SQL Server Express Edition.

На странице Учетная запись службы мастера установки можно назначить имя входа службам SQL Server. То, какие службы можно настраивать на этой странице, зависит от того, какие компоненты были выбраны во время установки.

Параметры

Можно назначить одно и то же имя входа всем службам SQL Server или настроить учетные записи для каждой из служб индивидуально. Также можно определить, какие службы запускаются автоматически.

Примечание безопасности.
Задание надежных паролей необходимо для безопасности системы. Всегда используйте надежные пароли.

Задать имя входа для учетной записи каждой службы

Выберите флажок Задать для учетной записи каждой службы для выбора отдельных настроек для каждой отдельной службы.

Этот параметр позволяет определить особые учетные записи входа для каждой службы в отдельности. Установите этот флажок для реализации принципа наименьших прав доступа, когда службам SQL Server предоставляется минимум разрешений, необходимых для решения задач данной службой. Дополнительные сведения см. в разделе Настройка учетных записей служб Windows.

Если этот флажок не установлен, то для всех служб SQL Server будет использоваться одна учетная запись и одинаковые настройки.

Выберите одну из следующих служб для индивидуальной настройки.

Выберите эту службу Чтобы настроить проверку подлинности для

SQL Server

Ядро СУБД SQL Server

Агент SQL Server

Служба, которая запускает задания, мониторы и SQL Server, а также позволяет автоматизировать задачи администрирования.

Службы Analysis Services

Службы Analysis Services

Службы Reporting Services

Reporting Services. Учетные записи служб используются для настройки соединения с базой данных сервера отчетов. Выберите учетную запись пользователя домена для подключения к базе данных сервера отчетов на удаленном экземпляре SQL Server. Если используется локальная база данных сервера отчетов, для запуска службы можно использовать учетную запись пользователя домена или запись «Локальная система».

Обозреватель SQL Server

Обозреватель SQL Server представляет службу разрешения имен, которая предоставляет данные о соединении SQL Server с компьютерами клиентов. Эта служба совместно используется множеством экземпляров SQL Server и служб Integration Services.
Использовать встроенную учетную запись системы

У настраиваемых служб SQL Server могут быть учетные записи локальной системы, сетевой службы или локальной службы.

Параметр «Локальная система» задает учетную запись локальной системы, которой не требуется пароль для подключения к SQL Server на этом же компьютере. Однако учетная запись локальной системы, в зависимости от прав доступа, предоставленных данной учетной записи, может ограничить взаимодействие экземпляра SQL Server с другими серверами.

Важно!
Учетная запись локальной системы предоставляет очень много возможностей; она может подходить для настроек не всех служб. Дополнительные сведения см. в разделе Анализ безопасности при установке SQL Server.

«Сетевая служба» — особая встроенная учетная запись, подобная учетной записи пользователя, прошедшего проверку подлинности. Учетная запись «Сетевая служба» обладает таким же уровнем доступа к ресурсам и объектам, как и члены группы «Пользователи». Службы, запущенные с учетной записью «Сетевая служба», получают доступ к сетевым ресурсам с использованием учетных данных учетной записи компьютера.

Важно!
Не рекомендуется использовать учетную запись сетевой службы для служб SQL Server и агента SQL Server. Для этих служб SQL Server больше подходят учетные записи «Локальный пользователь» или «Пользователь домена».

«Локальная служба» — особая встроенная учетная запись, подобная учетной записи пользователя, прошедшего проверку подлинности. Учетная запись «Локальная служба» обладает таким же уровнем доступа к ресурсам и объектам, что и члены группы «Пользователи». Такой ограниченный доступ помогает защитить систему в случае компрометации отдельных служб или процессов. Службы, запущенные с учетной записью «Локальная служба», получают доступ к сетевым ресурсам в виде неопределенного сеанса без учетных данных.

Дополнительные сведения об учетных записях служб см. в разделе Настройка учетных записей служб Windows.

Использовать учетную запись пользователя домена

Определяет учетную запись пользователя домена, которая использует проверку подлинности Windows для подключения к SQL Server. Корпорация Майкрософт рекомендует использовать учетную запись пользователя домена с минимальными правами для службы SQL Server, так как ей не требуются права доступа учетной записи администратора.

Учетная запись агента SQL Server должна иметь права доступа администратора, если создаются задачи CmdExec и ActiveScript, которые принадлежат кому-то другому, а не администратору SQL Server, или если используются возможности AutoRestart. Если в среде необходимы вышеупомянутые возможности, то стоит рассмотреть использование различных учетных записей для разных служб SQL Server и служб агентов SQL Server.

Рекомендации по выбору надежного пароля см. в разделе Режим проверки подлинности.

Примечание.
Имя домена не может быть полным DNS-именем. Например, если имя DNS — my-domain-name.com, то в поле «Домен» укажите my-domain-name. Программа установки SQL Server не позволит ввести my-domain-name.com в поле «Домен».

Запустить службы в конце установки SQL Server

Автоматически запускает службы при запуске операционной системы. В SQL Server 2005 флажок Запускать автоматически будет установлен по умолчанию для служб SQL Server, служб Analysis Services и Reporting Services.

Примечание.
Служба агента SQL Server зависит от службы SQL Server. Если установлен флажок Автоматический запуск агента SQL Server, то флажок Автоматический запуск для службы SQL Server будет установлен автоматически. Причем он не сможет быть снят до тех пор, пока не будет снят этот флажок для агента SQL Server.

Важно!
Выключено по умолчанию — для повышения безопасности SQL Server 2005 некоторые службы и функции не активируются по умолчанию. Их необходимо настроить и включить после завершения установки. Дополнительные сведения см. в разделах Настройка контактной зоны SQL Server и Анализ безопасности при установке SQL Server.

См. также

Справочник

Настройка учетных записей служб Windows

Основные понятия

Анализ безопасности при установке SQL Server


Режим проверки подлинности

Режим проверки подлинности |
 | См. также
Справочник по пользовательскому интерфейсу программы установки >

Пользователи выпуска SQL Server Express Edition: щелкните ссылку Режим проверки подлинности (SQL Server Express) для получения сведений, которые относятся только к установке выпуска SQL Server Express.

Используйте страницу Режим проверки подлинности мастера установки Microsoft SQL Server для выбора режима безопасности, применяемого для проверки подлинности клиентских и серверных соединений с установкой. При выборе смешанного режима необходимо войти и подтвердить пароль системного администратора SQL Server (sa). После того как устройство установит успешное соединение с SQL Server, используется один механизм безопасности как для проверки подлинности Windows, так и для смешанного режима.

Параметры

Режим проверки подлинности Windows

Когда пользователь подключается с помощью учетной записи пользователя Microsoft Windows, SQL Server проверяет учетную запись и пароль, используя сведения из операционной системы Windows. Этот режим проверки подлинности установлен по умолчанию, он безопаснее, чем смешанный режим. Режим проверки подлинности Windows использует протокол безопасности Kerberos, обеспечивает соблюдение политики паролей при условии проверки сложности для надежных паролей, обеспечивает блокировки учетных записей и проверки истечения срока действия пароля.

Примечание безопасности.
По возможности используйте проверку подлинности Windows.

При выборе проверки подлинности Windows установка создает учетную запись sa, которая недоступна по умолчанию. Сведения по использованию смешанного режима проверки подлинности и активации учетной записи sa после завершения установки см. в разделе «Как изменить режим проверки подлинности сервера» в электронной документации по SQL Server 2005.

Важно!
Задание надежных паролей необходимо для безопасности системы. Никогда не указывайте пустой или простой пароль для пользователя sa.

Смешанный режим (проверка подлинности Windows или проверка подлинности SQL Server)

Позволяет пользователям подключаться с использованием проверки подлинности Windows или проверки подлинности SQL Server. Пользователи, подключающиеся при помощи учетной записи Windows, могут воспользоваться доверенными соединениями, которые проверяет Windows.

При выборе смешанного режима проверки подлинности и наличии условий для использования входных имен SQL для согласования унаследованных приложений необходимо установить надежные пароли для всех учетных записей SQL. Это очень важно для учетных записей, являющихся членами роли sysadmin, особенно для учетной записи sa.

Примечание.
Проверка подлинности SQL Server используется исключительно для поддержки обратной совместимости. По возможности используйте проверку подлинности Windows.

Ввод пароля

Введите и подтвердите имя входа системного администратора (sa) при выборе смешанного режима проверки подлинности. При попытке взлома пароли выступают в качестве первой линии обороны, поэтому убедитесь, что введены надежные пароли, так как это необходимо для защиты системы. Никогда не указывайте пустой или простой пароль для пользователя sa.

Примечание.
Пароли SQL Server могут содержать от 1 до 128 символов, включая любую комбинацию букв, символов и цифр. При выборе смешанного режима проверки подлинности необходимо ввести надежный пароль sa прежде, чем мастер установки перейдет на следующую страницу.

Рекомендации по выбору надежного пароля

Надежные пароли не могут быть легко расшифрованы человеком или взломаны при помощи компьютерных программ. Надежные пароли не должны использовать запрещенные условия или термины, такие как:

  • пустой или неопределенный пароль;

  • «Пароль»;

  • «Админ»;

  • «Администратор»;

  • «са»;

  • «сисадмин».

Надежный пароль не может включать в себя следующие термины, связанные с установкой компьютера:

  • имя пользователя, зарегистрированного в компьютере в настоящий момент;

  • имя компьютера.

Надежный пароль должен состоять не менее чем из восьми символов и удовлетворять как минимум трем из следующих четырех критериев.

  • Он должен содержать буквы верхнего регистра.

  • Он должен содержать буквы нижнего регистра.

  • Он должен содержать числа.

  • Он должен содержать неалфавитные символы, например: #, % или ^.

Пароли, введенные на странице Режим проверки подлинности, должны отвечать требованиям политики надежных паролей. При использовании любого типа автоматизации, в котором используется проверка подлинности SQL, убедитесь, что пароль отвечает всем требованиям политики надежных паролей.

Примечание безопасности.
Для этого выпуска программа установки может не использовать требования к надежным паролям при некоторых установленных по умолчанию настройках Windows Server 2003, если компьютер не является членом домена. Задание надежных паролей необходимо для безопасности системы. Никогда не указывайте пустой или простой пароль для пользователя sa.

См. также

Основные понятия

Анализ безопасности при установке SQL Server

Журнал изменений

Версия Журнал

5 декабря 2005 г.

Измененное содержимое
  • Обновлены рекомендации по выбору надежного пароля: Надежные пароли должны содержать более восьми символов.


Параметры сортировки

Параметры сортировки |
 | См. также
Справочник по пользовательскому интерфейсу программы установки >

Дата обновления: 5 декабря 2005 г.

Пользователи выпуска SQL Server Express: чтобы получить специальные сведения об установке выпуска SQL Server Express, щелкните ссылку Настройка параметров сортировки (SQL Server Express).

На странице Параметры сортировки мастера установки можно изменить параметры сортировки по умолчанию, используемые компонентом Database Engine и службами Analysis Services при сортировке и для соответствия языковым стандартам. Параметр Обозначение параметров сортировки позволяет задать соответствие между параметрами сортировки других установленных экземпляров SQL Server или другого компьютера. Параметры сортировки SQL позволяют выбрать настройки, совместимые с порядком сортировки в более ранних версиях SQL Server.

Параметры

Настроить для учетной записи каждой службы

Можно указать индивидуальные параметры сортировки для компонента Database Engine и служб Analysis Services, либо указать один набор параметров сортировки для всех служб. Если для установки выбран и компонент Database Engine, и службы Analysis Services, можно установить флажок рядом с параметром Настроить для учетной записи каждой службы, чтобы активизировать список служб в раскрывающемся списке. Выберите службу в списке и затем выберите параметры сортировки и порядок сортировки для этой службы. После этого нажмите кнопку Далее.

Обозначение параметров сортировки и порядок сортировки

Укажите параметры сортировки, используемые данным экземпляром SQL Server 2005. По умолчанию для англоязычных языковых стандартов выбираются параметров сортировки SQL. По умолчанию для неанглоязычных языковых стандартов в качестве параметров сортировки используется системный параметр Microsoft Windows, то есть параметр Язык программ, не поддерживающих Юникод или ближайший эквивалент в компоненте панели управления «Язык и региональные стандарты».

Параметры по умолчанию нужно изменять только в том случае, если настройки параметров сортировки для этого экземпляра SQL Server должны соответствовать настройкам параметров сортировки другого экземпляра SQL Server, или если они должны соответствовать языковым стандартам Windows другого компьютера.

Примечание. Параметры сортировки SQL нельзя использовать для служб Analysis Services. Если выбрать параметры сортировки SQL для устанавливаемого экземпляра компонента Database Engine программа установки SQL Server выберет параметры сортировки Windows так, чтобы они наилучшим образом соответствовали службам Analysis Services, в зависимости от выбранных параметров сортировки SQL. Если параметры сортировки в компоненте Database Engine и службах Analysis Services не совпадают, результаты работы могут быть противоречивыми. Чтобы гарантировать согласованность результатов работы компонента Database Engine и служб Analysis Services, следует использовать параметры сортировки Windows.

Дополнительные сведения см. в разделе Настройка параметров сортировки в программе установки.

Порядок сортировки

Укажите порядок сортировки для выбранного параметра Обозначение параметров сортировки. Двоичный порядок сортировки является самым быстрым, и в нем учитывается регистр. Если выбран параметр Двоичный, то параметры С учетом регистра, С учетом диакритических знаков, С учетом типа японской азбуки и С учетом ширины символов становятся недоступными. Дополнительные сведения см. в разделе Стили сортировки в параметрах сортировки Windows.

Параметры сортировки SQL

Установите соответствие настроек для совместимости с версиями SQL Server 8.0, 7.0 или более ранними. Параметр Параметры сортировки SQL используется для обеспечения совместимости с более ранними версиями SQL Server. Дополнительные сведения см. в разделе Использование параметров сортировки SQL.

Примечание.
Параметры сортировки SQL нельзя использовать для служб Analysis Services. Если выбрать параметры сортировки SQL для устанавливаемого экземпляра компонента Database Engine программа установки SQL Server выберет параметры сортировки Windows так, чтобы они наилучшим образом соответствовали службам Analysis Services, в зависимости от выбранных параметров сортировки SQL. Если параметры сортировки в компоненте Database Engine и службах Analysis Services не совпадают, результаты могут быть противоречивыми. Чтобы гарантировать согласованность результатов работы компонента Database Engine и служб Analysis Services, следует использовать параметры сортировки Windows.

Типичные сценарии действий пользователя

Таблицу языков системы Windows и соответствующие им параметры сортировки по умолчанию, используемые программой установки SQL Server, см. в разделе Настройка параметров сортировки в программе установки.

Рекомендуется по возможности использовать стандартный набор параметров сортировки в рамках всей организации. Использование стандартных свойств параметров сортировки на всех компьютерах организации устраняет необходимость явно указывать параметры сортировки в каждом символьном выражении или выражении Юникода. Если необходимо работать с объектами, имеющими различные параметры сортировки и кодовые страницы, следует создавать запросы с учетом очередности параметров сортировки.

При выборе параметров сортировки для установки SQL Server учитывайте следующие рекомендации, изложенные в порядке значимости.

  • Выбирайте двоичные параметры сортировки, если допустима двоичная сортировка.

  • Если в приложениях используются и типы данных nchar/nvarchar, и типы данных char/varchar, которые при сравнении могут использоваться совместно, выбирайте параметры сортировки Windows, что позволит достичь единообразного сравнения данных всех типов.

  • Если в приложениях используются только типы данных nchar/nvarchar, применение параметров сортировки Windows и SQL дает одинаковые результаты.

  • Если в приложениях используются только типы данных char/varchar и используются службы Analysis Services, выбирайте параметры сортировки Windows.

  • Если в приложениях используются только типы данных char/varchar, выбирайте параметры сортировки SQL в том случае, если большое значение имеет скорость выполнения строковых сравнений и инструкций LIKE, нет необходимости использовать улучшенную семантику лингвистических сравнений, обеспечиваемую параметрами сортировки Windows, но необходимо использовать порядок сортировки по словарю, обеспечиваемый параметрами сортировки SQL, выберите параметры сортировки SQL.

См. также

Справочник

Настройка параметров сортировки и поддержка нескольких языков
Настройка параметров сортировки в программе установки


Параметры установки сервера отчетов

Параметры установки сервера отчетов |
 | См. также
Справочник по пользовательскому интерфейсу программы установки >

Чтобы указать параметры, определяющие, как будет установлен экземпляр сервера отчетов, используйте страницу Параметры установки сервера отчетов мастера установки . Доступность той или иной возможности при установке зависит от того, устанавливается ли одновременно с сервером отчетов также и локальный экземпляр SQL Server Database Engine и доступно ли использование других значений по умолчанию.

Если программа установки не может выполнить настройку сервера отчетов по умолчанию из-за того, что не выполнено одно или несколько необходимых условий, мастер установки допускает только установку с минимальными возможностями, копируя необходимые файлы, требуя, чтобы для настройки сервера отчетов после завершения установки было использована программа настройки служб Reporting Services.

Если на компьютере установлен и ассоциирован с веб-узлом по умолчанию сертификат SSL, программа установки обнаруживает этот сертификат и настраивает сервер отчетов для использования протокола SSL при подключении к другим системам. Если не установлен протокол SSL или программа установки не может его использовать, можно вручную настроить сервер отчетов для использования протокола SSL с помощью программы настройки служб Reporting Services или установив значение SecureConnectionLevel в файле конфигурации RSReportServer. Дополнительные сведения о том, как изменить SecureConnectionLevel в файле конфигурации, см. в разделе Using Secure Web Service Methods электронной документации по SQL Server.

Параметры

Установить конфигурацию по умолчанию

Устанавливает экземпляр сервера отчетов, используя для его баз данных, учетных записей служб и виртуальных каталогов сервера отчетов значения по умолчанию. При выборе этого параметра после завершения установки экземпляр сервера отчетов готов к использованию. Программа установки создает базу данных сервера отчетов, использующую локальный экземпляр компонента Database Engine, и настраивает сервер отчетов для работы со значениями по умолчанию.

Этот параметр доступен, только если значения по умолчанию, использованные при установке сервера отчетов, допустимы для системы. Этот вариант мы рекомендуем разработчикам, которые хотят установить все компоненты локально, и пользователям, оценивающим программное обеспечение.

Чтобы просмотреть сведения об используемых программой установки настройках по умолчанию или выяснить, почему невозможно установить конфигурацию по умолчанию, нажмите кнопку Подробности. Дополнительные сведения о конфигурации по умолчанию см. в разделе Конфигурация по умолчанию для установки сервера отчетов.

Установить, но не настраивать сервер

Устанавливает программные файлы сервера отчетов, создает учетную запись службы Windows и регистрирует для сервера отчетов поставщик данных инструментария управления Windows (WMI). Этот режим установки называется «только файлы». Этот параметр можно выбрать, если не желаете пользоваться конфигурацией по умолчанию. Если конфигурацию по умолчанию установить невозможно, это единственная доступная возможность.

После завершения программы установки, прежде чем сервер отчетов можно будет использовать, следует создать базу данных сервера отчетов и настроить сервер отчетов. Чтобы настроить сервер отчетов и создать базу данных, воспользуйтесь программой настройки служб Reporting Services. Дополнительные сведения см. в разделах Создание базы данных сервера отчетов и Настройка соединения с базой данных сервера отчетов.

См. также

Задачи

Как запустить настройку служб Reporting Services
Как создать базу данных сервера отчетов (настройка служб Reporting Services)

Основные понятия

Установка служб Reporting Services с помощью программы установки
Конфигурация по умолчанию для установки сервера отчетов
Выбор компонентов служб Reporting Services для установки


Сведения об установке сервера отчетов

Сведения об установке сервера отчетов |
 | См. также
Справочник по пользовательскому интерфейсу программы установки >

На странице Сведения об установке сервера отчетов мастера установки Microsoft SQL Server можно просмотреть информацию о конфигурации сервера отчетов до его создания. Если программа установки не может установить сервер отчетов с конфигурацией по умолчанию, здесь будет объяснено, какие значения отсутствуют. В ином случае здесь будут описаны параметры, имена и пути, использующиеся во время процесса установки. В зависимости от конфигурации компьютера и параметров установки на этой странице могут отображаться следующие сведения:

  • Сведения о сервере отчетов содержат данные учетной записи, использующейся для запуска службы Windows сервера отчетов и веб-службы. Учетная запись службы Windows указывается на странице Учетные записи служб мастера установки. Учетная запись веб-службы совпадает с учетной записью ASP.NET по умолчанию на этом компьютере. Эти учетные записи будут использоваться сервером отчетов для доступа к базе данных сервера отчетов.

  • Сведения о базах данных сервера отчетов определяют локальный экземпляр SQL Server, где находятся базы данных сервера отчетов. Программа установки определяет, какой экземпляр компонента Database Engine используется. Это всегда локальный экземпляр, устанавливаемый параллельно с сервером отчетов. Дополнительные сведения об используемом экземпляре компонента Database Engine см. в разделе Имя экземпляра.

  • Сведения о виртуальных каталогах содержат имена виртуальных каталогов для доступа к серверу отчетов и диспетчеру отчетов. Виртуальные каталоги создаются на веб-узле по умолчанию. Они называются reportserver и reports, соответственно. Во время установки нельзя указать другие имена или выбрать другой веб-узел для виртуальных каталогов.

    После завершения работы программы установки с помощью указанных на этой странице URL-адресов можно осуществлять доступ к компонентам сервера. Если на одном компьютере установлено локально несколько экземпляров сервера отчетов, то URL-адрес определяет имя компьютера и имя экземпляра.

  • Сведения об SSL позволяют узнать, установлен ли на данный компьютер SSL-сертификат и будет ли он использоваться для соединений с сервером отчетов.

Примечание.
После завершения работы программы установки можно изменить конфигурацию сервера отчетов с помощью программы настройки служб Reporting Services.

См. также

Справочник

Учетная запись службы
Параметры установки сервера отчетов

Основные понятия

Установка служб Reporting Services с помощью программы установки
Конфигурация по умолчанию для установки сервера отчетов
Выбор компонентов служб Reporting Services для установки


Параметры отчетов об ошибках и использовании

Параметры отчетов об ошибках и использовании |
 | См. также
Справочник по пользовательскому интерфейсу программы установки >

Дата обновления: 5 декабря 2005 г.

Пользователи выпуска SQL Server Express Edition: щелкните ссылку Настройки параметров отчетов об ошибках и использовании (SQL Server Express) для получения сведений, которые относятся только к установке выпуска SQL Server Express.

Воспользуйтесь страницей Параметры отчетов об ошибках и использовании мастера установки , чтобы включить средства отправки отчетов об ошибках и использовании возможностей для SQL Server 2005.

Параметры

Возможности сбора данных об использовании компонентов и отчета об ошибках для SQL Server 2005 и его компонентов по умолчанию включаются. Однако можно отключить один или оба этих параметра, сняв флажки.

Отчеты об ошибках

Если включить возможность отчета об ошибках, SQL Server будет настроен для автоматической отправки отчета в корпорацию Майкрософт в случае неустранимой ошибки в любом из следующих компонентов SQL Server.

  • Компонент Database Engine

  • Агент SQL Server

  • Analysis Services

  • Reporting Services

  • Notification Services

  • Службы Integration Services

  • Репликация

Корпорация Майкрософт использует отчеты об ошибках, чтобы улучшить функциональность SQL Server, и любые поступающие данные расценивает как конфиденциальные.

Сведения об ошибках отправляются в корпорацию Майкрософт по защищенному (https) соединению и хранятся там с ограничением доступа. Вместо этого отчеты об ошибках можно отправлять на собственный корпоративный сервер отчетов об ошибках. Дополнительные сведения о настройке корпоративного сервера отчетов об ошибках см. на следующем веб-узле Майкрософт.

Отчеты об ошибках содержат следующие сведения:

  • состояние SQL Server при возникновении проблемы;

  • версия операционной системы и сведения об оборудовании компьютера;

  • код продукта, который не используется для идентификации лицензии;

  • сетевой IP-адрес компьютера или прокси-сервера;

  • данные из памяти или файлов процесса, вызвавшего ошибку.

Корпорация Майкрософт не собирает преднамеренно файлы, имя, адрес, адрес электронной почты или личные сведения в любой другой форме. Однако отчет об ошибке может содержать личные сведения из памяти или файлов процесса, вызвавшего ошибку. Хотя потенциально эти сведения можно использовать, чтобы идентифицировать пользователя, корпорация Майкрософт не использует их с этой целью.

Чтобы ознакомиться с правилами, в соответствии с которыми обращается с личными сведениями и ведет сбор данных, см. следующий веб-узел Майкрософт.

Если включить отчеты об ошибках и произойдет неисправимая ошибка, можно увидеть в журнале событий Windows ответ от Майкрософт, указывающий статью базы знаний Майкрософт об этой конкретной ошибке.

Чтобы отключить отчеты об ошибках или использовании возможностей для всех экземпляров SQL Server и его компонентов после завершения установки, перейдите в диалоговое окно Настройки параметров отчета об ошибках и использовании и снимите флажки для пункта Использование возможностей. Если отчеты об ошибках включены для нескольких компонентов SQL Server (SQL Server Database Engine, сервера анализа данных, сервера отчетов и общих компонентов), можно отключить отчеты об ошибках для каждого экземпляра каждого отдельного компонента, а также для общих компонентов, перечисленных как Прочие.

Использование возможностей

Если включить отчеты об использовании возможностей, SQL Server будет настроена периодически отправлять отчет в корпорацию Майкрософт. Отчеты будут содержать сведения об оборудовании компьютера и о том, как используется программное обеспечение и службы SQL Server 2005. Майкрософт будет использовать данные об использовании возможностей для улучшения служб SQL Server. Компоненты SQL Server 2005, контролируемые этим средством, включают в себя:

  • Database Engine;

  • Analysis Services

  • Reporting Services

  • Notification Services

  • службы Integration Services;

  • репликацию;

  • Business Intelligence Development Studio

Сведения об использовании возможностей будут отправлены в корпорацию Майкрософт, где будут храниться с ограничением доступа.

Для отключения отчетов об использовании возможностей после завершения установки воспользуйтесь средством Служба отчетов об ошибках и использовании SQL Server в меню SQL Server 2005 средства настройки.

Все включенные экземпляры SQL Server собирают сведения раз в сутки. По умолчанию время сбора сведений — полночь, чтобы минимизировать нагрузку на сервер. Если необходимо изменить время сбора данных, можно вручную отредактировать раздел реестра, определяющий это время. Для каждого экземпляра SQL Server существует свой раздел реестра; следующий пример относится к первому экземпляру SQL Server, установленному на сервере (MSSQL.1).

HKLM\Software\Microsoft\Microsoft SQL Server\MSSQL.1\CPE\TimeofReporting

Значение этого раздела реестра содержит время сбора данных как число минут с 00:00 (полуночи) до времени запуска. Например, значение, равное 60, запустит сбор данных в 1:00, значение 1200 — в 20:00, и так далее.

См. также

Основные понятия

Настройка установки SQL Server


Все готово для установки

Все готово для установки |
 | См. также
Справочник по пользовательскому интерфейсу программы установки >

Пользователи выпуска SQL Server Express Edition: щелкните ссылку Страница "Готово для установки" (SQL Server Express), чтобы просмотреть сведения, относящиеся к установке выпуска SQL Server Express Edition.

Перед установкой или обновлением на странице Все готово для установки показана сводка необходимых условий и компонентов, которые будут установлены или изменены в ходе установки SQL Server.

Параметры

На этой странице доступны следующие параметры.

  • Чтобы продолжить установку, нажмите кнопку Установить.

  • Чтобы изменить настройки установки, нажмите кнопку Назад.

  • Чтобы выйти из программы установки, нажмите кнопку Отмена.

См. также

Задачи

Как проверить успешность установки служб SQL Server 2005
Как просмотреть файл журнала установки SQL Server 2005

Основные понятия

Как просмотреть файлы журналов установки SQL Server 2005


Обновление учетных данных

Обновление учетных данных |
 | См. также
Справочник по пользовательскому интерфейсу программы установки >

Страница Обновление сведений о входе в систему мастера установки предназначена для указания учетных данных для доступа к обновляемому экземпляру SQL Server.

В процессе обновления программа установки SQL Server 2005 должна получить доступ к обновляемому экземпляру. Учетные данные, указываемые на этой странице, используются для входа в предыдущий экземпляр SQL Server.

Проверка подлинности Windows

Режим проверки подлинности Windows позволяет подключаться с учетной записью Microsoft Windows. Корпорация Майкрософт рекомендует пользоваться именно этим режимом.

Проверка подлинности SQL Server

При подключении пользователя с указанным именем для входа и паролем не через доверенное подключение SQL Server самостоятельно осуществляет проверку подлинности имени входа SQL Server и проверку совпадения введенного пароля с ранее сохраненным. Если в SQL Server такой учетной записи нет, проверка подлинности не проходит и пользователь получает сообщение об ошибке.

Примечание безопасности.
Если возможно, используйте проверку подлинности Windows.

Имя пользователя

Введите имя пользователя для соединения. Этот параметр доступен только при выборе проверки подлинности Windows.

Пароль

Введите пароль, соответствующий указанному имени для входа. Этот параметр можно изменять только при подключении с проверкой подлинности SQL Server.

См. также

Другие ресурсы

Обновление до SQL Server 2005
Как выполнить обновление до версии SQL Server 2005 с помощью мастера копирования баз данных


Блокировка обновления

Блокировка обновления |
 | См. также
Справочник по пользовательскому интерфейсу программы установки >

Компонент Microsoft SQL Server, выбранный для обновления, заблокирован. В окне Блокировка обновления отображается причина блокировки, а также действия пользователя, необходимые для устранения критического препятствия, которое привела к блокировке.

Чтобы продолжить обновление, устраните причины блокировки и запустите программу установки Microsoft SQL Server 2005 еще раз.

См. также

Основные понятия

Использование помощника по обновлению для подготовки к обновлениям

Другие ресурсы

Обновление до SQL Server 2005
Обратная совместимость


Имя виртуального сервера

Имя виртуального сервера |
 | См. также
Справочник по пользовательскому интерфейсу программы установки >

На странице Имя виртуального сервера мастера установки можно указать имя виртуального сервера.

Параметры

Имя виртуального сервера

Введите уникальное имя экземпляра. Это имя будет использоваться для идентификации отказоустойчивого кластера в сети. Виртуальное имя SQL Server должно быть уникальным в сети и отличаться от имен ведущего кластера и узлов кластера.

См. также

Справочник

Имя экземпляра

Основные понятия

Отказоустойчивый кластер


Конфигурация виртуального сервера

Конфигурация виртуального сервера |
 | См. также
Справочник по пользовательскому интерфейсу программы установки >

На странице Конфигурация виртуального сервера мастера установки можно указать конфигурацию IP-адресов виртуального сервера.

Параметры

Имя виртуального сервера

Отображает имя виртуального сервера, соответствующего указанному IP-адресу.

Использовать сеть

Определяет сеть, которой будет принадлежать IP-адрес.

IP-адрес

Определяет IP-адрес для каждой сети, которую следует настроить для клиентского доступа. Введите по одному IP-адресу для каждой сети общего пользования или смешанной сети, в которой виртуальный сервер будет доступен клиентам.

Чтобы избежать конфликтов IP-адресов, убедитесь, что IP-адреса, назначенные тактовому импульсу, и SQL Server 2005, не используются другими приложениями.

Сетевой адрес

Отображает сетевой адрес, предоставляемый службой кластеров Microsoft.

Подсеть

Отображает подсеть, предоставляемую службой кластеров Microsoft.

Добавить

Добавляет сеть и IP-адрес в диалоговое окно Выбранные сетевые и IP-адреса.

Удалить

Удаляет сеть и IP-адрес из диалогового окна Выбранные сетевые и IP-адреса.

Выбранные сети и IP-адреса

Отображает выбранные сетевые и IP-адреса, настроенные для виртуального сервера.

См. также

Основные понятия

Отказоустойчивый кластер


Выбор группы кластера

Выбор группы кластера |
 | См. также
Справочник по пользовательскому интерфейсу программы установки >

Дата обновления: 5 декабря 2005 г.

Страница Выбор кластерной группы мастера установки Microsoft SQL Server используется для выбора кластерной группы. Выбранная кластерная группа находится там, где размещены ресурсы виртуального сервера SQL Server.

Параметры

Доступные кластерные группы

Выберите кластерную группу в месте размещения ресурсов виртуального сервера SQL Server. Для одной кластерной группы может быть установлен только один виртуальный сервер.

Если выбрать группу, содержащую ресурс кластерного кворума, появляется предупреждение. Рекомендуется не устанавливать в ресурс кластерного кворума.

Недоступные кластерные группы

Приводит список недоступных кластерных групп и причин, по которым они недоступны. Например, кластерная группа может быть недоступна, если она уже содержит виртуальный сервер.

Файлы данных

Показывает местоположение по умолчанию для файлов данных Database Engine и файлов данных служб Analysis Services.

Если в кластерной группе имеется несколько дисководов с общим доступом, для выбора дисковода с общими файлами данных используется раскрывающийся список.

См. также

Основные понятия

Установка отказоустойчивого кластера


Учетные записи служб (кластеры)

Учетные записи служб (кластеры) |
 | См. также
Справочник по пользовательскому интерфейсу программы установки >

Дата обновления: 5 декабря 2005 г.

Используйте страницу Учетные записи служб (кластеры) мастера установки для назначения имени входа службе SQL Server. Набор служб, представленных для конфигурирования на этой странице, зависит от возможностей, которые выбраны при установке.

Параметры

Можно назначить одно и то же имя входа всем службам SQL Server или настроить учетные записи для каждой из служб индивидуально. Также можно определить, какие службы запускаются автоматически.

Примечание безопасности.
Задание надежных паролей необходимо для безопасности системы. Всегда используйте надежные пароли.

Настроить для учетной записи каждой службы

Выберите флажок Задать для учетной записи каждой службы для выбора отдельных настроек для каждой отдельной службы.

Этот параметр позволяет определить особые учетные записи входа для каждой службы в отдельности. Установите этот флажок для реализации принципа наименьших прав доступа, когда службам SQL Server предоставляется минимум разрешений, которые необходимы для решения задачи данной службы. Дополнительные сведения см. в разделе Настройка учетных записей служб Windows.

Если этот флажок не установлен, то для всех служб SQL Server будет использоваться одна учетная запись и одинаковые настройки.

Выберите одну из следующих служб для индивидуальной настройки.

Выберите эту службу Чтобы настроить проверку подлинности для

SQL Server

SQL Server Database Engine

Агент SQL Server

Служба, которая запускает задания, мониторы и SQL Server, а также позволяет автоматизировать задачи администрирования.

Analysis Services

Analysis Services

Службы Reporting Services

Reporting Services. Учетные записи служб используются для настройки соединения с базой данных сервера отчетов. Выберите учетную запись пользователя домена для подключения к базе данных сервера отчетов на удаленном экземпляре SQL Server. Если используется локальная база данных сервера отчетов, для запуска службы можно использовать учетную запись пользователя домена или запись «Локальная система».

Обозреватель SQL Server

Обозреватель SQL Server представляет службу разрешения имен, которая обеспечивает данные о соединении SQL Server с компьютерами клиентов. Это служба совместно используется множеством экземпляров SQL Server и служб Integration Services.
Использовать встроенную учетную запись системы

Этот параметр отключен, потому что нельзя использовать встроенную учетную запись системы в кластере SQL Server.

Использовать учетную запись пользователя домена

Определяет учетную запись пользователя домена, которая использует проверку подлинности Windows для подключения к SQL Server. Рекомендуется использовать учетную запись пользователя домена с минимальными правами для служб SQL Server, если только службы SQL Server не требуют прав доступа учетной записи администратора.

Учетная запись агента SQL Server должна иметь права доступа администратора, если создаются задачи CmdExec и ActiveScript, которые принадлежат кому-то другому, нежели администратору SQL Server, или если используются возможности AutoRestart. Если в среде необходимы вышеупомянутые возможности, то стоит рассмотреть использование различных учетных записей для разных служб SQL Server и служб агентов SQL Server.

Рекомендации по выбору надежного пароля см. в разделе Режим проверки подлинности.

Примечание.
Имя домена не может быть полным DNS-именем. Например, если имя DNS — my-domain-name.com, то в поле «Домен» укажите my-domain-name. Программа установки SQL Server не позволит ввести my-domain-name.com в поле «Домен».

Запустить службы в конце установки SQL Server

Автоматически запускает службы при запуске операционной системы. Для SQL Server 2005 значение Автоматический запуск будет установлено по умолчанию для SQL Server, служб Analysis Services и служб Reporting Services.

Примечание.
Служба агента SQL Server зависит от службы SQL Server. Если установлен флажок Автоматический запуск агента SQL Server, то флажок Автоматический запуск для службы SQL Server будет установлен автоматически. Причем он не может быть снят до тех пор, пока не будет снят этот флажок для агента SQL Server.

Важно!
Выключено по умолчанию — для повышения безопасности SQL Server 2005 некоторые службы и функции не активируются по умолчанию. Их необходимо настроить и включить после завершения установки. Дополнительные сведения см. в разделах Настройка контактной зоны SQL Server и Анализ безопасности при установке SQL Server.

См. также

Справочник

Настройка учетных записей служб Windows

Основные понятия

Анализ безопасности при установке SQL Server


Доменные группы для служб, поддерживающих работу в кластере

Доменные группы для служб, поддерживающих работу в кластере |
 | См. также
Справочник по пользовательскому интерфейсу программы установки >

Дата обновления: 12 декабря 2006 г.

На странице Доменные группы для служб, поддерживающих работу в кластере мастера установки указываются глобальные или локальные доменные группы для служб, поддерживающих работу в кластере, которые будут установлены в составе отказоустойчивого кластера SQL Server 2005.

Чтобы гарантировать безопасность среды, доступ к ресурсам в узлах отказоустойчивого кластера должен быть ограничен.В отказоустойчивом кластере SQL Server 2005 группы домена должны быть общими для всех узлов кластера, которые используются для управления доступа к разделам реестра, файлам, объектам SQL Server и другим ресурсам кластера.Управление разрешениями на все ресурсы производится на уровне групп домена, в которые входит учетная запись службы SQL Server.

Добавление групп домена — это одна из основных обязанностей администратора домена.Убедитесь, что все группы домена для отказоустойчивого кластера SQL Server 2005 созданы или изменены с учетом политики безопасности вашей организации.

Параметры

Служба SQL Server, служба агента SQL Server, служба Analysis Services и служба компонента Full-Text Search должны быть запущены под учетной записью домена.Группы домена для этих служб должны существовать на момент запуска программы установки SQL Server. При необходимости выясните у администратора домена имена существующих глобальных или локальных групп домена или попросите создать группы домена для отказоустойчивого кластера.

Для каждой службы, поддерживающей работу в кластере, в устанавливаемом экземпляре SQL Server введите имя домена и группы в формате <Имя_домена>\<Имя_группы>, придерживаясь следующих правил.

  • Доменные группы могут быть глобальными или локальными.

  • Группы домена должны находиться в том же домене, что и учетные записи компьютера.Например, если компьютер, на котором будет установлен SQL Server, находится в домене SQLSVR, а его родителем является MYDOMAIN, группу необходимо определять в домене SQLSVR.Домен SQLSVR может содержать учетные записи пользователей MYDOMAIN.

  • Пользователь должен быть прямым членом группы домена, а не входить в нее через подгруппы.Программа установки не исследует членство в подгруппах при проверке учетной записи пользователя в группе домена.

  • Имя домена и группы домена должны существовать на момент запуска программы установки.При необходимости выясните у администратора домена имена существующих доменных групп или попросите создать доменные группы для отказоустойчивого кластера.Если группы домена созданы непосредственно перед запуском программы установки, подождите некоторое время, пока изменения распространятся по сети предприятия.

  • К группам домена должны быть добавлены соответствующие учетные записи служб.Если учетные записи служб не являются членами соответствующих групп домена на момент запуска программы установки, то она попытается добавить их самостоятельно.В этом случае учетная запись, от которой запускается программа установки, должна иметь соответствующие права доступа для добавления учетных записей в группы домена.Если программа установки SQL Server запускается от учетной записи, которая не имеет прав на добавление пользователей в группы домена, пользователи уже должны быть членами соответствующей группы.

  • Каждая служба должна использовать свою доменную группу.Но для всех служб SQL Server можно использовать одну учетную запись и одну группу домена, либо одну группу домена и разные учетные записи, либо разные группы домена и разные учетные записи.Для оптимальной детализации разрешений пользуйтесь различными учетными записями и различными группами домена для каждой службы SQL Server и каждого виртуального сервера, которые имеются в домене.

  • Доменные группы SQL Server не могут совместно использоваться несколькими приложениями.

Обратите внимание на то, что для диагностики проблем с группами домена необходим доступ к контроллеру домена.

Учетные записи SQL Server не будут удалены из групп домена при отмене установки SQL Server или при изменении учетных записей.Администратор домена должен проследить за тем, чтобы после удаления SQL Server были удалены и ненужные учетные записи.

См. также

Основные понятия

Подготовка к установке отказоустойчивого кластера

Журнал изменений

Версия Журнал

12 декабря 2006 г.

Измененное содержимое:
  • Добавлено указание на то, что группы домена для служб, поддерживающих работу в кластере, могут быть глобальными или локальными.


Настройка узла кластера

Настройка узла кластера |
 | См. также
Справочник по пользовательскому интерфейсу программы установки >

Страница Конфигурация узла кластера мастера установки используется для выбора узлов кластера для их включения в виртуальные серверы.

Параметры

Доступные узлы

Выводит узлы, которые можно включить в определение виртуального сервера. Нажмите кнопку Добавить, чтобы переместить доступный узел в список Выбранные узлы.

Выбранные узлы

Выводит узлы, выбранные для включения в определение виртуального сервера.

Добавить

Перемещает выделенный узел из списка Доступные узлы в список Выбранные узлы, тем самым добавляя этот узел к определению виртуального сервера.

Удалить

Удалить выделенный узел из списка Выбранные узлы. Тем самым этот узел удаляется из определения виртуального сервера.

Требуемый узел

Показывает обязательный узел. Обязательный узел является владельцем кластерной группы, в которой установлены файлы данных SQL Server.

Недоступные узлы

Выводит список недоступных узлов и причину, по которой недоступен каждый из них.

См. также

Основные понятия

Отказоустойчивый кластер


Сведения об удаленной учетной записи

Сведения об удаленной учетной записи |
 | См. также
Справочник по пользовательскому интерфейсу программы установки >

Воспользуйтесь страницей Сведения об удаленной учетной записи мастера установки , чтобы ввести сведения удаленного входа для виртуального сервера.

Параметры

Имя пользователя

Если поле имени входа не заполнено заранее, укажите имя пользователя, соответствующее допустимой учетной записи администратора для всех узлов кластера.

Пароль

Укажите пароль для выбранной учетной записи администратора.

Примечание безопасности.
Задание надежных паролей необходимо для безопасности системы. Всегда используйте надежные пароли.

См. также

Основные понятия

Отказоустойчивый кластер


Изменение или удаление экземпляра

Изменение или удаление экземпляра |
 | См. также
Справочник по пользовательскому интерфейсу программы установки >

Используйте страницу Изменить или удалить экземпляр мастера установки , чтобы выбрать обслуживание или удаление существующего экземпляра SQL Server. Доступ к параметрам обслуживания осуществляется с помощью средства Установка и удаление программ панели управления.

Параметры

Изменение установленных компонентов

Используйте этот параметр для добавления или удаления функций в выбранном экземпляре SQL Server.

Удаление Microsoft SQL Server

Выберите этот параметр для удаления установки SQL Server из своего компьютера.

Примечание.
В данном выпуске обслуживание отказоустойчивых кластеров доступно только через пункт Установка и удаление программ.

См. также

Задачи

Как изменить компоненты существующего экземпляра SQL Server 2005 (программа установки)
Как удалить существующий экземпляр SQL Server 2005 (программа установки)

Справочник

Выпуски и компоненты SQL Server 2005


Обслуживание кластеров

Обслуживание кластеров |
 | См. также
Справочник по пользовательскому интерфейсу программы установки >

Используйте страницу Изменить или удалить мастера установки , чтобы выбрать между изменением и удалением установленного виртуального сервера.

Параметры обслуживания задаются с помощью раздела Установка и удаление программ панели управления. Каждый компонент SQL Server 2005 перечислен отдельно в окне Установка и удаление программ.

Параметры

Обслуживание виртуального сервера

Используйте этот параметр для добавления или удаления узлов.

Удаление Microsoft SQL Server

Выберите этот параметр для удаления виртуального сервера из кластера.

См. также

Задачи

Как создать новый отказоустойчивый кластер SQL Server 2005 (установка)
Как


Выполнение установки

Выполнение установки |
 | См. также
Справочник по пользовательскому интерфейсу программы установки >

С помощью страницы Выполнение установки мастера установки можно следить за состоянием установки SQL Server.

Параметры

Программа установки SQL Server 2005 запускается отдельно на каждом узле отказоустойчивого кластера. Чтобы отслеживать процесс установки на отдельных узлах при установке на отказоустойчивом кластере, используйте раскрывающееся меню Узел для переключения между узлами кластера.

Параметры обслуживания задаются с помощью раздела Установка и удаление программ панели управления.

См. также

Основные понятия

Как просмотреть файлы журналов установки SQL Server 2005


Зарезервированные ключевые слова (Установка)

Зарезервированные ключевые слова (Установка) |
 | См. также
Справочник по пользовательскому интерфейсу программы установки >

использует зарезервированные ключевые слова для определения баз данных, манипулирования ими и доступа к ним. Зарезервированные ключевые слова являются частью грамматики Transact-SQL, и SQL Server использует их для разбора и понимания инструкций и пакетов Transact-SQL.

Имена экземпляров SQL Server не должны совпадать с зарезервированными ключевыми словами. Попытка назвать их так вызовет ошибку установки. Используйте следующую таблицу, чтобы убедиться, что в именах экземпляров SQL Server 2005 зарезервированные ключевые слова не используются.

ADD | EXCEPT | PERCENT
ALL | EXEC | PLAN
ALTER | EXECUTE | PRECISION
AND | EXISTS | PRIMARY
ANY | EXIT | PRINT
AS | FETCH | PROC
ASC | FILE | PROCEDURE
AUTHORIZATION | FILLFACTOR | PUBLIC
BACKUP | FOR | RAISERROR
BEGIN | FOREIGN | READ
BETWEEN | FREETEXT | READTEXT
BREAK | FREETEXTTABLE | RECONFIGURE
BROWSE | FROM | REFERENCES
BULK | FULL | REPLICATION
BY | FUNCTION | RESTORE
CASCADE | GOTO | RESTRICT
CASE | GRANT | RETURN
CHECK | GROUP | REVOKE
CHECKPOINT | HAVING | RIGHT
CLOSE | HOLDLOCK | ROLLBACK
CLUSTERED | IDENTITY | ROWCOUNT
COALESCE | IDENTITY_INSERT | ROWGUIDCOL
COLLATE | IDENTITYCOL | RULE
COLUMN | IF | SAVE
COMMIT | IN | SCHEMA
COMPUTE | INDEX | SELECT
CONSTRAINT | INNER | SESSION_USER
CONTAINS | INSERT | SET
CONTAINSTABLE | INTERSECT | SETUSER
CONTINUE | INTO | SHUTDOWN
CONVERT | IS | SOME
CREATE | JOIN | STATISTICS
CROSS | KEY | SYSTEM_USER
CURRENT | KILL | TABLE
CURRENT_DATE | LEFT | TEXTSIZE
CURRENT_TIME | LIKE | THEN
CURRENT_TIMESTAMP | LINENO | TO
CURRENT_USER | LOAD | TOP
CURSOR | NATIONAL | TRAN
DATABASE | NOCHECK | TRANSACTION
DBCC | NONCLUSTERED | TRIGGER
DEALLOCATE | NOT | TRUNCATE
DECLARE | NULL | TSEQUAL
DEFAULT | NULLIF | UNION
DELETE | OF | UNIQUE
DENY | OFF | UPDATE
DESC | OFFSETS | UPDATETEXT
DISK | ON | USE
DISTINCT | OPEN | USER
DISTRIBUTED | OPENDATASOURCE | VALUES
DOUBLE | OPENQUERY | VARYING
DROP | OPENROWSET | VIEW
DUMMY | OPENXML | WAITFOR
DUMP | OPTION | WHEN
ELSE | OR | WHERE
END | ORDER | WHILE
ERRLVL | OUTER | WITH
ESCAPE | OVER | WRITETEXT

Кроме того, стандарт SQL-2003 определяет список зарезервированных ключевых слов. Избегайте использования зарезервированных ключевых слов SQL-2003 в качестве имен и идентификаторов объектов. Список зарезервированных ключевых слов ODBC, приведенный в следующей таблице, идентичен списку зарезервированных ключевых слов SQL-2003.

Примечание.
Иногда список зарезервированных ключевых слов SQL-2003 может быть более строгим, чем в SQL Server, а иногда менее строгим. Например, список зарезервированных ключевых слов SQL-2003 содержит ключевое слово INT. SQL Server не рассматривает INT как зарезервированное ключевое слово.

Зарезервированные ключевые слова ODBC

Перечисленные ниже слова зарезервированы для использования в вызовах функций ODBC. Эти слова не ограничивают минимальную грамматику SQL; однако для обеспечения совместимости с драйверами, поддерживающими базовую грамматику SQL, следует избегать использования этих ключевых слов в именах экземпляров SQL Server.

ABSOLUTE | EXEC | OVERLAPS
ACTION | EXECUTE | PAD
ADA | EXISTS | PARTIAL
ADD | EXTERNAL | PASCAL
ALL | EXTRACT | POSITION
ALLOCATE | FALSE | PRECISION
ALTER | FETCH | PREPARE
AND | FIRST | PRESERVE
ANY | FLOAT | PRIMARY
ARE | FOR | PRIOR
AS | FOREIGN | PRIVILEGES
ASC | FORTRAN | PROCEDURE
ASSERTION | FOUND | PUBLIC
AT | FROM | READ
AUTHORIZATION | FULL | REAL
AVG | GET | REFERENCES
BEGIN | GLOBAL | RELATIVE
BETWEEN | GO | RESTRICT
BIT | GOTO | REVOKE
BIT_LENGTH | GRANT | RIGHT
BOTH | GROUP | ROLLBACK
BY | HAVING | ROWS
CASCADE | HOUR | SCHEMA
CASCADED | IDENTITY | SCROLL
CASE | IMMEDIATE | SECOND
CAST | IN | SECTION
CATALOG | INCLUDE | SELECT
CHAR | INDEX | SESSION
CHAR_LENGTH | INDICATOR | SESSION_USER
CHARACTER | INITIALLY | SET
CHARACTER_LENGTH | INNER | SIZE
CHECK | INPUT | SMALLINT
CLOSE | INSENSITIVE | SOME
COALESCE | INSERT | SPACE
COLLATE | INT | SQL
COLLATION | INTEGER | SQLCA
COLUMN | INTERSECT | SQLCODE
COMMIT | INTERVAL | SQLERROR
CONNECT | INTO | SQLSTATE
CONNECTION | IS | SQLWARNING
CONSTRAINT | ISOLATION | SUBSTRING
CONSTRAINTS | JOIN | SUM
CONTINUE | KEY | SYSTEM_USER
CONVERT | LANGUAGE | TABLE
CORRESPONDING | LAST | TEMPORARY
COUNT | LEADING | THEN
CREATE | LEFT | TIME
CROSS | LEVEL | TIMESTAMP
CURRENT | LIKE | TIMEZONE_HOUR
CURRENT_DATE | LOCAL | TIMEZONE_MINUTE
CURRENT_TIME | LOWER | TO
CURRENT_TIMESTAMP | MATCH | TRAILING
CURRENT_USER | MAX | TRANSACTION
CURSOR | MIN | TRANSLATE
DATE | MINUTE | TRANSLATION
DAY | MODULE | TRIM
DEALLOCATE | MONTH | TRUE
DEC | NAMES | UNION
DECIMAL | NATIONAL | UNIQUE
DECLARE | NATURAL | UNKNOWN
DEFAULT | NCHAR | UPDATE
DEFERRABLE | NEXT | UPPER
DEFERRED | NO | USAGE
DELETE | NONE | USER
DESC | NOT | USING
DESCRIBE | NULL | VALUE
DESCRIPTOR | NULLIF | VALUES
DIAGNOSTICS | NUMERIC | VARCHAR
DISCONNECT | OCTET_LENGTH | VARYING
DISTINCT | OF | VIEW
DOMAIN | ON | WHEN
DOUBLE | ONLY | WHENEVER
DROP | OPEN | WHERE
ELSE | OPTION | WITH
END | OR | WORK
END-EXEC | ORDER | WRITE
ESCAPE | OUTER | YEAR
EXCEPT | OUTPUT | ZONE
EXCEPTION |  |

Будущие ключевые слова

Следующие ключевые слова могут быть зарезервированы в будущих выпусках SQL Server по мере реализации новых возможностей. Рекомендуется также избегать использования этих слов в именах экземпляров SQL Server.

ABSOLUTE | FOUND | PREPARE
ACTION | FREE | PRESERVE
ADMIN | FULLTEXTTABLE | PRIOR
AFTER | GENERAL | PRIVILEGES
AGGREGATE | GET | READS
ALIAS | GLOBAL | REAL
ALLOCATE | GO | RECURSIVE
ARE | GROUPING | REF
ARRAY | HOST | REFERENCING
ASSERTION | HOUR | RELATIVE
AT | IGNORE | RESULT
BEFORE | IMMEDIATE | RETURNS
BINARY | INDICATOR | ROLE
BIT | INITIALIZE | ROLLUP
BLOB | INITIALLY | ROUTINE
BOOLEAN | INOUT | ROW
BOTH | INPUT | ROWS
BREADTH | INT | SAVEPOINT
CALL | INTEGER | SCROLL
CASCADED | INTERVAL | SCOPE
CAST | ISOLATION | SEARCH
CATALOG | ITERATE | SECOND
CHAR | LANGUAGE | SECTION
CHARACTER | LARGE | SEQUENCE
CLASS | LAST | SESSION
CLOB | LATERAL | SETS
COLLATION | LEADING | SIZE
COMPLETION | LESS | SMALLINT
CONNECT | LEVEL | SPACE
CONNECTION | LIMIT | SPECIFIC
CONSTRAINTS | LOCAL | SPECIFICTYPE
CONSTRUCTOR | LOCALTIME | SQL
CORRESPONDING | LOCALTIMESTAMP | SQLEXCEPTION
CUBE | LOCATOR | SQLSTATE
CURRENT_PATH | MAP | SQLWARNING
CURRENT_ROLE | MATCH | START
CYCLE | MINUTE | STATE
DATA | MODIFIES | STATEMENT
DATE | MODIFY | STATIC
DAY | MODULE | STRUCTURE
DEC | MONTH | TEMPORARY
DECIMAL | NAMES | TERMINATE
DEFERRABLE | NATURAL | THAN
DEFERRED | NCHAR | TIME
DEPTH | NCLOB | TIMESTAMP
DEREF | NEW | TIMEZONE_HOUR
DESCRIBE | NEXT | TIMEZONE_MINUTE
DESCRIPTOR | NO | TRAILING
DESTROY | NONE | TRANSLATION
DESTRUCTOR | NUMERIC | TREAT
DETERMINISTIC | OBJECT | TRUE
DICTIONARY | OLD | UNDER
DIAGNOSTICS | ONLY | UNKNOWN
DISCONNECT | OPERATION | UNNEST
DOMAIN | ORDINALITY | USAGE
DYNAMIC | OUT | USING
EACH | OUTPUT | VALUE
END-EXEC | PAD | VARCHAR
EQUALS | PARAMETER | VARIABLE
EVERY | PARAMETERS | WHENEVER
EXCEPTION | PARTIAL | WITHOUT
EXTERNAL | PATH | WORK
FALSE | POSTFIX | WRITE
FIRST | PREFIX | YEAR
FLOAT | PREORDER | ZONE

См. также

Задачи

Как установить SQL Server 2005 (программа установки)


Выбор компонента — Обслуживание

Выбор компонента — Обслуживание |
 | См. также
Справочник по пользовательскому интерфейсу программы установки >

Используйте страницу Выбор компонента и обслуживание мастера установки , чтобы выбрать экземпляр SQL Server или общие компоненты для обновления.

Параметры

На этой странице допускается только один выбор. Можно выбрать экземпляр или общий компонент для обновления.

Отчет

Просмотрите список компонентов и функций SQL Server 2005, установленных на компьютере. Отчет включает версию, выпуск, версию обновления и сведения о языке для каждого из установленных компонентов и функций.

См. также

Справочник

Компоненты для установки
Возможности, поддерживаемые различными выпусками SQL Server 2005


Установка образцов баз данных

Установка образцов баз данных |
 | См. также
Справочник по пользовательскому интерфейсу программы установки >

Страница Установка образцов баз данных мастера установки Microsoft SQL Server позволяет выбрать метод установки образцов баз данных на существующий экземпляр SQL Server.

Внимание! При установке образцов баз данных AdventureWorks и AdventureWorksDW применяются параметры сортировки SQL_Latin1_General_CP1_CI_AS, а не те, что были выбраны для экземпляра SQL Server. Чтобы изменить параметры сортировки для образцов баз данных для согласования с параметрами сортировки сервера, удалите базу данных и создайте ее снова из сценария установки. Дополнительные сведения см. в разделе Повторная установка образцов баз данных с помощью сценария.

Параметры

Установка образцов баз данных без присоединения

Файлы базы данных AdventureWorks создаются в папке <диск>:\Program Files\Microsoft SQL Server\90\Tools\Samples\AdventureWorks OLTP. Файлы базы данных AdventureWorksDW создаются в папке <диск>:\Program Files\Microsoft SQL Server\90\Tools\Samples\AdventureWorks Data Warehouse. Перед использованием базу данных необходимо подключить. Дополнительные сведения см. в разделе Присоединение и отсоединение баз данных.

Установка с присоединением образцов баз данных

Файлы базы данных создаются и сохраняются в папке <диск>:\Program Files\Microsoft SQL Server\MSSQL.n\MSSQL\Data. База данных присоединяется к выбранному экземпляру SQL Server, после чего она готова к использованию.

Для присоединения баз данных необходимо разрешение на создание базы данных в указанном экземпляре.

Экземпляр SQL Server

Выберите экземпляр SQL Server, куда устанавливаются образцы базы данных и примеры.

Завершение установки образцов

Для завершения установки примеров после завершения установки выполните следующие шаги:

  1. В меню Пуск последовательно выберите пункты Все программы, Microsoft SQL Server 2005, Документация и учебные материалы, Примеры и Примеры Microsoft SQL Server 2005.

  2. Либо при помощи проводника Windows перейдите в папку <диск>:\Program Files\Microsoft SQL Server\90\Tools\Samples\ и дважды щелкните файл SqlServerSamples.msi для запуска программы установки.

Важно!
Образцы устанавливаются в папку <диск>:\Program Files\Microsoft SQL Server\90\Samples. Обязательно прочтите и выполните инструкции по установке, которые содержатся в файлах Readme, прилагающихся к образцам. Список образцов см. в разделе «Образцы» электронной документации по SQL Server 2005.

Развертывание проекта служб Analysis Services Adventure Works DW

  1. Убедитесь, что установлены базы данных AdventureWorksDW и Adventure Works DW.

  2. Убедитесь, что установлены службы Analysis Services.

  3. На панели инструментов среды SQL Server Business Intelligence Development Studio нажмите Файл, выберите пункт Открыть, а затем Проект/Решение.

  4. Откройте каталог <диск>:\Program Files\Microsoft SQL Server\90\Tools\Samples\AdventureWorks Analysis Services Project, выберите файл Adventure Works.sln и нажмите кнопку Открыть.

  5. В обозревателе решений щелкните правой кнопкой мыши на Adventure Works DW и выберите пункт Развернуть или Обработка.

См. также

Справочник

Компоненты для установки
Возможности, поддерживаемые различными выпусками SQL Server 2005

Журнал изменений

Версия Журнал

5 декабря 2005 г.

Измененное содержимое:
  • Это новое содержимое для данной версии.


Выбор компонентов — удаление

Выбор компонентов — удаление |
 | См. также
Справочник по пользовательскому интерфейсу программы установки >

Используйте страницу Выбор компонентов — удаление мастера установки для выбора экземпляра SQL Server и любых общих компонентов, которые необходимо удалить.

Параметры

Для удаления можно выбрать экземпляр и любые общие компоненты.

Отчет

Просмотрите список компонентов и функций SQL Server 2005, установленных на компьютере. Отчет включает версию, выпуск, версию обновления и сведения о языке для каждого из установленных компонентов и функций.

См. также

Справочник

Компоненты для установки
Возможности, поддерживаемые различными выпусками SQL Server 2005


Подтверждение — удаление

Подтверждение — удаление
Справочник по пользовательскому интерфейсу программы установки >

Используйте страницу Подтверждение — удаление мастера установки , чтобы подтвердить выбор функций и компонентов, которые должны быть удалены из установки SQL Server 2005.

Параметры

Это диалоговое окно перечисляет функции и компоненты, выбранные для их последующего удаления. Убедитесь, что этот список полный, а затем нажмите кнопку Далее, чтобы продолжить.


Тип экземпляра — удаление

Тип экземпляра — удаление |
 | См. также
Справочник по пользовательскому интерфейсу программы установки >

Чтобы выбрать компонент для удаления, используйте страницу Тип экземпляра — удаление мастера установки .

Параметры

Выберите компонент для удаления и нажмите кнопку Далее.

См. также

Справочник

Возможности, поддерживаемые различными выпусками SQL Server 2005


Выбор устаревших компонентов

Выбор устаревших компонентов |
 | См. также
Справочник по пользовательскому интерфейсу программы установки >

Страница Выбор устаревших компонентов мастера установки предназначена для выбора компонентов, которые частично удалены. Здесь также можно выполнить удаление компонентов, оставшихся от предыдущих установок после обновления версии.

Параметры

Выберите компонент для удаления и нажмите кнопку Далее.

См. также

Справочник

Возможности, поддерживаемые различными выпусками SQL Server 2005


Справка по пользовательскому интерфейсу программы установки (SQL Server Express)

Справка по пользовательскому интерфейсу программы установки (SQL Server Express)
Справочник по пользовательскому интерфейсу программы установки >

В этом разделе рассказывается о мастере установки , с помощью которого можно установить SQL Server 2005 Express Edition.

Доступ к разделам следующей таблицы можно получить из пользовательского интерфейса, нажав клавишу F1 или кнопку Справка в диалоговых окнах и на страницах мастера.

Разделы справки F1

Проверка конфигурации системы (SQL Server Express)

Регистрационные сведения (SQL Server Express)

Выбор компонентов (SQL Server Express)

Имя экземпляра (SQL Server Express)

Существующие компоненты (SQL Server Express)

Параметры установки (SQL Server Express)

Учетная запись службы (SQL Server Express)

Режим проверки подлинности (SQL Server Express)

Настройка параметров сортировки (SQL Server Express)

Параметры настройки (SQL Server Express)

Настройки параметров отчетов об ошибках и использовании (SQL Server Express)

Страница "Готово для установки" (SQL Server Express)


Проверка конфигурации системы (SQL Server Express)

Проверка конфигурации системы (SQL Server Express)
Справочник по пользовательскому интерфейсу программы установки > Справка по пользовательскому интерфейсу программы установки (SQL Server Express) >

На странице "Проверка конфигурации системы" в мастере установки отображается ход работы средства подготовки системы. Процедуры проверки конфигурации просматривают компьютер, чтобы выявить условия, которые могут блокировать программу установки. Для кластеров проверка конфигурации выполняется на всех узлах в кластере операционной системы.

Чтобы отменить проверку конфигурации и выйти из мастера установки, можно в любое время нажать кнопку Стоп.

Отображаются следующие символы хода выполнения.

  • Стрелка = выполняется проверка.

  • Флажок = элемент успешно проверен.

  • x = элемент не прошел проверку.

По завершении проверки конфигурации станет доступна кнопка Отчет. Кнопка Далее будет доступна только в случае полностью успешной проверки или некритичности ошибок. При наличии ошибок в отчет о проверке добавляется решение по устранению критических препятствий.

Кнопка Отчет в нижней части страницы проверки конфигурации позволяет просмотреть отчет, сохранить его как файл, скопировать в буфер обмена или отправить по электронной почте. Отчет содержит следующие сведения:

  • Список элементов конфигурации, проверенных на целевом компьютере: требования к текущей операционной системе, наличие и номер версии пакета обновления операционной системы, совместимость версии SQL Server с текущей операционной системой, наличие служб IIS.

  • Результат проверки каждого элемента.

  • Рекомендуемое решение для элементов, не прошедших проверку.


Регистрационные сведения (SQL Server Express)

Регистрационные сведения (SQL Server Express)
Справочник по пользовательскому интерфейсу программы установки > Справка по пользовательскому интерфейсу программы установки (SQL Server Express) >

На странице «Регистрационные сведения» в мастере установки требуется ввести идентификационные сведения для регистрации копии SQL Server.

Параметры

Параметр | Описание
Имя | Введите имя пользователя, отвечающего за администрирование сервера, который запускает SQL Server 2005 Express Edition (SQL Server Express). Имя пользователя обязательно для продолжения установки.
Компания | Введите название компании. Для индивидуального использования копии продукта можно снова ввести имя пользователя. Заполнять это поле необязательно.
Примечание.
Поскольку SQL Server Express загружается бесплатно, на странице «Регистрационные сведения» отсутствует текстовое поле «Ключ товара».

Скрыть дополнительные параметры конфигурации

Внизу страницы «Регистрационные сведения» находится флажок Скрыть дополнительные параметры конфигурации. При установке этого флажка не появятся следующие страницы установки:

  • Имя экземпляра

  • Учетная запись службы

  • Настройка параметров сортировки

  • Пользовательские экземпляры


Выбор компонентов (SQL Server Express)

Выбор компонентов (SQL Server Express)
Справочник по пользовательскому интерфейсу программы установки > Справка по пользовательскому интерфейсу программы установки (SQL Server Express) >

Страница "Выбор компонентов" состоит из двух панелей. На левой панели в виде дерева представлены компоненты, которые можно установить. Чтобы раскрыть компонент и просмотреть вложенные части щелкните символ "+". Если щелкнуть компонент или часть, на панели "Описание функции" отобразится описание выбранного элемента и требования к месту на диске.

Для добавления или удаления компонента щелкните значок компонента, затем выберите в раскрывающемся списке один из следующих параметров.

Параметр Описание

Будет установлен на локальный жесткий диск

Установка выбранного компонента в папку, указанную в разделе Путь установки.

Компонент будет установлен на локальный жесткий диск

Установка выбранного компонента и всех вложенных частей. Для просмотра вложенных частей разверните родительский компонент

Компонент будет полностью недоступен

В случае новой установки SQL Server этот параметр позволяет пропустить установку выбранного компонента. Если установка уже выполнялась, этот параметр позволяет удалить компонент из установленного набора. После выбора этого параметра в дереве компонентов рядом с именем компонента появляется красная буква X и значок родительского компонента в дереве становится серым.

Примечание.
Компонент нельзя исключить, если выбрана одна из вложенных частей. Для исключения компонента убедитесь, что все его части также исключены.

Обзор

Запуск страницы "Изменение папок", где можно сменить папку установки выбранных компонентов. Эта кнопка доступна только для компонентов, поддерживающих изменение пути установки. Дополнительные сведения о путях установки см. в разделе Расположение файлов для экземпляра по умолчанию и именованных экземпляров SQL Server 2005 электронной документации по SQL Server 2005.

Место на диске

Отображение места, доступного для установки на различных системных дисках компьютера. После оценки места на диске в диалоговом окне Место на диске нажмите кнопку Закрыть для продолжения установки SQL Server.


Имя экземпляра (SQL Server Express)

Имя экземпляра (SQL Server Express)
Справочник по пользовательскому интерфейсу программы установки > Справка по пользовательскому интерфейсу программы установки (SQL Server Express) >

Указать, следует ли создать экземпляр по умолчанию или именованный экземпляр SQL Server Express, можно на странице Имя экземпляра мастера установки . SQL Server Express всегда устанавливает именованный экземпляр (SQLExpress), если только пользователем не выбран экземпляр по умолчанию. В отличие от него SQL Server 2005 устанавливает экземпляр по умолчанию, если не выбран именованный экземпляр.

Параметры

Параметр Описание

Экземпляр по умолчанию

Если выбрать экземпляр по умолчанию, который уже существует на компьютере, при установке SQL Server экземпляр по умолчанию будет обновлен. Выберите этот параметр, чтобы установить экземпляр по умолчанию SQL Server Express. На компьютере может находиться только один экземпляр по умолчанию.

Примечание.
Имя экземпляра по умолчанию — MSSQLSERVER; клиенту не требуется указывать это имя, чтобы подключиться.

Чтобы обновить экземпляр по умолчанию, созданный во время предыдущей установки SQL Server, выберите вариант Экземпляр по умолчанию, а затем нажмите кнопку Далее.

Именованный экземпляр

При запуске SQL Server Express по умолчанию будет выбран параметр "Именованный экземпляр" с именем SQLExpress.

Выберите этот параметр, чтобы создать новый именованный экземпляр. Назначая имя экземпляру SQL Server, учитывайте следующее.

  • Имена экземпляров не учитывают регистр.

  • Имена экземпляров не могут содержать термины Default, MSSQLServer либо другие зарезервированные ключевые слова. При использовании зарезервированного ключевого слова в имени экземпляра произойдет ошибка.

  • Имя экземпляра может содержать до 16 знаков.

  • Первым знаком имени экземпляра может быть либо буква, либо символ подчеркивания (_). Буквы, которые могут использоваться в именах, определены в стандарте Юникод 2.0, в том числе латинские знаки "a-z" и "A-Z", а также буквы из других языков.

  • В качестве последующих знаков можно использовать буквы, определенные в стандарте Юникод 2.0, десятичные цифры латинского набора символов или наборов символов других стран, знак доллара ($) или символ подчеркивания (_).

  • В именах экземпляров не допускается использование пробелов между специальными знаками, а также использование обратной косой черты (\), запятой (,), двоеточия (:), точки с запятой (;), одинарной кавычки ('), амперсанда (&), знака номера (#) и знака @.

Примечание.
В именах экземпляров SQL Server разрешается использовать только те знаки, которые допустимы на текущей кодовой странице Windows Microsoft. При использовании неподдерживаемого знака в кодировке Юникод произойдет ошибка.

Установленные экземпляры

Страница Установленные экземпляры мастера установки SQL Server предназначена для просмотра списка установленных экземпляров SQL Server Express и компонентов на компьютере, на котором выполняется программа установки SQL Server. На панели Подробности об установленном экземпляре выводятся параметры обновления установленных экземпляров. Чтобы выбрать компонент или экземпляр для обновления, щелкните его имя и нажмите ОК.


Существующие компоненты (SQL Server Express)

Существующие компоненты (SQL Server Express)
Справочник по пользовательскому интерфейсу программы установки > Справка по пользовательскому интерфейсу программы установки (SQL Server Express) >

Используйте страницу "Существующие компоненты" мастера установки для просмотра списка компонентов SQL Server, которые уже установлены на компьютере, запускающем программу установки SQL Server.

Параметры

Параметр Описание

Подробности

Нажмите кнопку Сведения, чтобы просмотреть отчет, в котором перечислены параметры обслуживания и обновления, доступные для каждого установленного компонента SQL Server.

Для получения более подробных сведений о параметрах, отображающихся после нажатия Сведения, см. Параметры установки (SQL Server Express).


Параметры установки (SQL Server Express)

Параметры установки (SQL Server Express)
Справочник по пользовательскому интерфейсу программы установки > Справка по пользовательскому интерфейсу программы установки (SQL Server Express) >

Страница «Параметры установки» мастера установки предназначена для просмотра параметров обслуживания и обновления для существующих экземпляров и компонентов SQL Server Express. Эта страница появляется, когда выбранные для текущей установки компоненты уже установлены с аналогичными именами экземпляров.

Параметры

Параметры обслуживания и обновления описаны в следующих разделах.

Обслуживание

Обслуживание экземпляров SQL Server Express и обслуживание возможностей осуществляется с помощью оснастки Установка и удаление программ на панели управления. Выберите экземпляр SQL Server, для которого необходимо добавить или удалить функции. Дополнительные сведения см. в разделе Как изменить компоненты существующего экземпляра SQL Server 2005 (программа установки).

Обновление

Поддерживаются следующие пути обновления.

Текущие экземпляры SQL Server | Обновление до SQL Server Express (32-разрядная версия) | Обновление до SQL Server Express with Advanced Services (32-разрядная версия)
SQL Server Desktop Engine (MSDE) 7.0 с пакетом обновления 4 (SP4) | Да | Да
SQL Server 7.0 Desktop Edition с пакетом обновления 4 (SP4) | Нет | Нет
SQL Server 7.0 Standard Edition с пакетом обновления 4 (SP4) | Нет | Нет
SQL Server Developer Edition с пакетом обновления 4 (SP4) | Нет | Нет
SQL Server Enterprise Edition с пакетом обновления 4 (SP4) | Нет | Нет
SQL Server 7.0 Evaluation Edition с пакетом обновления 4 (SP4) | Обновления не поддерживаются | Обновления не поддерживаются
SQL Server Desktop Engine (MSDE) 2000 с пакетом обновления 3 (SP3) или более поздней версии | Да | Да
SQL Server 2000 Personal Edition с пакетом обновления 3 (SP3) или более поздней версии | Да | Да
SQL Server 2000 Workgroup Edition с пакетом обновления 3 (SP3) или более поздней версии | Нет | Нет
SQL Server 2000 Standard Edition с пакетом обновления 3 (SP3) или более поздней версии | Нет | Нет
SQL Server 2000 Developer Edition с пакетом обновления 3 (SP3) или более поздней версии | Нет | Нет
SQL Server 2000 Enterprise Edition с пакетом обновления 3 (SP3) или более поздней версии | Нет | Нет
SQL Server 2000 Evaluation Edition или более поздняя версия | Нет | Нет
SQL Server 2005 Express Edition | Нет | Да
SQL Server 2005 Enterprise Edition | Нет | Нет
SQL Server 2005 Workgroup Edition | Нет | Нет
SQL Server 2005 Standard Edition | Нет | Нет
SQL Server 2005 Developer Edition | Нет | Нет
SQL Server 2005 Evaluation Edition | Нет | Нет


Учетная запись службы (SQL Server Express)

Учетная запись службы (SQL Server Express)
Справочник по пользовательскому интерфейсу программы установки > Справка по пользовательскому интерфейсу программы установки (SQL Server Express) >

Используйте в мастере установки страницу «Учетная запись службы», чтобы назначить учетную запись для службы SQL Server.

Можно назначить одно и то же имя входа всем службам SQL Server или настроить учетные записи каждой из служб индивидуально. Также можно определить, какие службы запускаются автоматически.

Примечание безопасности.
Задание надежных паролей необходимо для безопасности системы. Всегда используйте надежные пароли.

Параметры

Параметр Описание

Служба

SQL Server выбирается как служба.

Использовать встроенную учетную запись системы

У настраиваемых служб SQL Server могут быть учетные записи локальной системы, сетевой службы или локальной службы.

Локальная системная учетная запись

Параметр «Локальная система» задает учетную запись локальной системы, которой не требуется пароль для соединения с SQL Server на этом же компьютере. Однако учетная запись локальной системы может запретить SQL Server взаимодействовать с другими серверами, в зависимости от прав, предоставленных учетной записи.

Важно!
Учетная запись «Локальная система» обладает значительными правами. Она может быть неприменима к некоторым настройкам службы. Дополнительные сведения см. в разделе Анализ безопасности при установке SQL Server электронной документации по SQL Server 2005.

Учетная запись «Сетевая служба»

«Сетевая служба» — особая встроенная учетная запись, подобная учетной записи пользователя, прошедшего проверку подлинности. Учетная запись «Сетевая служба» обладает таким же уровнем доступа к ресурсам и объектам, что и члены группы «Пользователи». Службы, запущенные с учетной записью «Сетевая служба», получают доступ к сетевым ресурсам с использованием учетных данных учетной записи компьютера.

Важно!
Не рекомендуется использовать учетную запись «Сетевая служба» для SQL Server. Для служб SQL Server больше подходят учетные записи «Локальный пользователь» или «Пользователь домена».

Учетная запись «Локальная служба»

«Локальная служба» — особая встроенная учетная запись, подобная учетной записи пользователя, прошедшего проверку подлинности. Учетная запись «Локальная служба» обладает таким же уровнем доступа к ресурсам и объектам, как и члены группы «Пользователи». Такой ограниченный доступ помогает защитить систему в случае нарушения безопасности отдельных служб или процессов. Службы, запускаемые с учетной записью «Локальная служба», получают доступ к сетевым ресурсам в качестве нулевого сеанса без использования учетных данных. Дополнительные сведения об учетных записях служб см. в разделе Настройка учетных записей служб Windows электронной документации по SQL Server 2005.

Использование учетной записи пользователя домена

Определяет учетную запись пользователя домена, которая использует проверку подлинности Windows для соединения с SQL Server. Рекомендуется использовать учетную запись пользователя домена с минимальными правами доступа к службе SQL Server, поскольку служба SQL Server не требует учетной записи с правами администратора.

Имя пользователя

Создание или изменение имени пользователя домена.

Пароль

Установка надежных паролей необходима для обеспечения безопасности системы. Всегда используйте надежные пароли. Рекомендации по выбору надежного пароля см. в разделе Режим проверки подлинности (SQL Server Express).

Домен

Создание или изменение имени домена, назначенного учетной записи.

Примечание.
Имя домена не может быть полным DNS-именем. Например, если DNS-имя — my-domain-name.com, то в поле «Домен» укажите my-domain-name.

Запуск служб по завершении установки SQL Server

Автоматический запуск следующих служб при запуске операционной системы.

  • SQL Server

    По умолчанию флажок SQL Server установлен.

  • Обозреватель SQL Server

    Обозреватель SQL Server является службой разрешения имен, предоставляющей возможность передачи сведений о соединении с сервером SQL Server на клиентские компьютеры. Эта служба совместно используется множеством экземпляров SQL Server.

Важно!
Для повышения безопасности SQL Server 2005 Express Edition некоторые службы и функции по умолчанию не включены. Необходимо включить и настроить их после установки. Дополнительные сведения см. в разделе Настройка контактной зоны SQL Server и Анализ безопасности при установке SQL Server.


Режим проверки подлинности (SQL Server Express)

Режим проверки подлинности (SQL Server Express) |
 | См. также
Справочник по пользовательскому интерфейсу программы установки > Справка по пользовательскому интерфейсу программы установки (SQL Server Express) >

На странице «Режим проверки подлинности» мастера установки выбирается форма проверки подлинности, используемая для проверки соединений с этим экземпляром SQL Server Express. Если выбран Смешанный режим, необходимо ввести и подтвердить пароль системного администратора SQL Server (sa). После удачного соединения устройства с SQL Server в режиме проверки подлинности в Windows и смешанном режиме начинает действовать один механизм безопасности.

Параметры

Параметр Описание

Режим проверки подлинности Windows

Когда пользователь выполняет подключение под пользовательской учетной записью Microsoft Windows, SQL Server проверяет имя учетной записи и пароль с помощью сведений операционной системы Windows. Этот режим проверки подлинности используется по умолчанию, и он гораздо надежнее смешанного режима. Режим проверки подлинности Windows использует протокол безопасности Kerberos, политику паролей исходя из сложности проверки надежных паролей, поддерживает блокировку учетных записей и истечение срока пароля.

Примечание безопасности.
По возможности используйте проверку подлинности Windows.

Если выбрана проверка подлинности Windows, программа установки создает учетную запись sa, которая по умолчанию отключена. Сведения об использовании смешанного режима проверки подлинности и активации учетной записи sa после завершения установки см. в разделах Как изменить режим проверки подлинности сервера и ALTER LOGIN (Transact-SQL) электронной документации по SQL Server 2005.

Важно! Не используйте пустой пароль. Выбирайте надежные пароли.

Смешанный режим (проверка подлинности Windows и SQL Server)

Возможность подключения пользователей с помощью режима проверки подлинности Windows и SQL Server. Пользователи, которые подключаются под учетной записью Windows, могут использовать доверенные соединения, которые проверяются Windows.

Если выбран смешанный режим проверки подлинности, необходимо задать надежные пароли для всех имен входа SQL Server. Это особенно важно для имени входа sa, а также для имен входа, являющихся членами фиксированной серверной роли sysadmin.

Примечание Проверка подлинности SQL Server поддерживается исключительно в целях обеспечения обратной совместимости. По возможности используйте проверку подлинности Windows.

Ниже укажите пароль учетной записи sa

При выборе смешанного режима проверки подлинности введите и подтвердите пароль системного администратора (sa). Задание надежных паролей необходимо для безопасности системы. Никогда не указывайте пустой или простой пароль для пользователя sa.

Примечание Пароли SQL Server могут содержать от 1 до 128 знаков, в том числе любое сочетание букв, цифр и других символов. Если выбрать смешанную проверку подлинности, то прежде чем перейти на другую страницу мастера установки, необходимо ввести надежный пароль sa

Рекомендации по выбору надежного пароля

Отгадать надежный пароль человек обычно не в состоянии, его также сложно взломать при помощи компьютерной программы. При установке паролей придерживайтесь следующих рекомендаций.

  1. При установке надежных паролей нельзя использовать определенные символы или готовые слова, в том числе:

    1. незаполненный или ПУСТОЙ

    2. Password

    3. Admin

    4. Administrator

    5. sa

    6. sysadmin

  2. В надежных паролях нельзя использовать следующие сочетания знаков, связанные с процессом установки компьютера.

    1. Имя пользователя, который в текущий момент находится в системе.

    2. Имя компьютера.

  3. Надежный пароль должен включать не менее шести знаков и удовлетворять, по меньшей мере, четырем следующим критериям.

    1. Он должен включать заглавные буквы.

    2. Он должен включать строчные буквы.

    3. Он должен включать цифры.

    4. Он должен содержать символы, отличные от алфавитно-цифровых, например #, % или ^.

Пароли, введенные на странице «Проверка подлинности», должны отвечать требованиям политики надежных паролей. При использовании автоматизированной функции проверки подлинности SQL Server убедитесь, что пароль отвечает требованиям политики надежных паролей.

См. также

Другие ресурсы

Центр загрузки электронной документации по SQL Server 2005


Настройка параметров сортировки (SQL Server Express)

Настройка параметров сортировки (SQL Server Express) |
 | См. также
Справочник по пользовательскому интерфейсу программы установки > Справка по пользовательскому интерфейсу программы установки (SQL Server Express) >

Используйте страницу "Настройка параметров сортировки" мастера установки для изменения стандартных настроек параметров сортировки, используемых в SQL Server для выбора языка и задач сортировки. Выберите параметр Обозначение параметров сортировки, чтобы выбрать настройки параметров сортировки различных установок SQL Server или другого компьютера. Используйте параметр Параметры сортировки SQL, чтобы выбрать настройки, совместимые с порядками сортировки в более ранних версиях SQL Server.

Параметры

Параметр Описание

Обозначение параметров сортировки и порядок сортировки

Указание параметров сортировки для использования в этом экземпляре SQL Server Express. По умолчанию выбираются параметры сортировки SQL для английских языковых стандартов. Стандартные параметры сортировки для языков, отличных от английского, - это язык Microsoft Windows на компьютере: Язык программ, не поддерживающих Юникод, или язык, наиболее соответствующий настройке Языки и региональные стандарты в окне панели управления.

Флажки раздела Обозначение параметров сортировки и порядок сортировки позволяют указывать порядок сортировки для использования с выбранным параметром Обозначение параметров сортировки. Двоичный порядок сортировки - самый быстрый порядок сортировки с учетом регистра. Если выбран параметр Двоичный, параметры С учетом регистра, С учетом диакритических знаков, С учетом типа японской азбуки и С учетом ширины символов недоступны. Дополнительные сведения см. в разделе Стили сортировки в параметрах сортировки Windows электронной документации по SQL Server 2005.

Примечание. Изменяйте стандартные настройки порядка сортировки, только если установка SQL Server будет совпадать с настройками параметров сортировки, используемых другим экземпляром SQL Server, или если она будет совпадать с языком Windows на другом компьютере.

Параметры сортировки SQL

Параметр Параметры сортировки SQL используется для совместимости с более ранними версиями SQL Server. Выберите параметр, чтобы сопоставить настройки, совместимые с SQL Server версий 8.0, 7.0 или более ранних версий. Дополнительные сведения см. в разделе Использование параметров сортировки SQL электронной документации по SQL Server 2005.

См. также

Другие ресурсы

Центр загрузки электронной документации по SQL Server 2005


Параметры настройки (SQL Server Express)

Параметры настройки (SQL Server Express) |
 | См. также
Справочник по пользовательскому интерфейсу программы установки > Справка по пользовательскому интерфейсу программы установки (SQL Server Express) >

Страница «Параметры настройки» используется для создания отдельного экземпляра компонента Database Engine для пользователей, не имеющих разрешений администратора, и для добавления пользователей к роли администратора.

Параметр

Разрешить пользовательские экземпляры

По умолчанию включен. Для отключения возможности использования пользовательских экземпляров следует снять флажок.

Пользовательский экземпляр, известный также как дочерний или клиентский экземпляр, является экземпляром SQL Server, который создается родительским экземпляром (основным экземпляром, работающим как служба, например SQLExpress) от лица пользователя. Пользовательский экземпляр запускается как пользовательский процесс в контексте безопасности такого пользователя. Пользовательский экземпляр изолирован от родительского и любых других пользовательских экземпляров, выполняющихся на компьютере. Возможность создания пользовательских экземпляров также называется «Запуск в качестве нормального пользователя» (RANU).

Добавление пользователя к роли администратора SQL Server

По умолчанию снят. Чтобы добавить текущего пользователя, выполняющего установку, к роли администратора SQL Server, установите этот флажок.

Пользователи Windows Vista, члены группы BUILTIN\Administrators, не добавляются автоматически к фиксированной серверной роли sysadmin при соединении с SQL Server Express. Только пользователи Windows Vista, явно добавленные к роли уровня администратора, могут администрировать SQL Server Express. С экземпляром SQL Server Express может соединяться любой член группы «Built-In\Пользователи», но у него будут ограниченные разрешения для выполнения задач в базе данных. По этой причине пользователям, права на SQL Server Express которых наследуются от групп «BUILTIN\Администраторы» и «Built-In\Пользователи» в предыдущих версиях Windows, должны быть явно предоставлены права администратора в экземплярах SQL Server Express под управлением Windows Vista.

Для изменения ролей пользователя после завершения программы установки используется средство настройки контактной зоны SQL Server 2005 (SQLSAC.exe). Чтобы обновить список пользователей роли «Системный администратор» SQL Server, щелкните ссылку Добавление нового администратора.

Убедитесь, что в списке Выделение ресурсов пользователю приводится имя пользователя в формате «Имя_домена\Имя пользователя», разрешения которого нужно обновить. Выберите роль, которую нужно обновить, из списка экземпляров SQL Server на панели Имеющиеся права доступа и щелкните стрелку справа. Чтобы добавить пользователя к имеющимся ролям для всех доступных экземпляров SQL Server и всем доступным ролям, щелкните двойную стрелку справа.

Для применения изменений после завершения работы нажмите кнопку ОК. Чтобы закрыть средство без применения изменений, нажмите кнопку Отмена.

Параметры командной строки

Для настройки пользовательских экземпляров используется переключатель ENABLERANU.

Для выключения пользовательских экземпляров:

Set ENABLERANU = 0

Для включения пользовательских экземпляров (по умолчанию):

Set ENABLERANU = 1

Примечание.
Пользовательские экземпляры доступны только в выпусках SQL Server 2005 Express Edition.

Параметр ADDUSERASADMIN используется для добавления текущего пользователя к роли администратора SQL Server.

Чтобы добавить текущего пользователя, выполняющего установку, к роли администратора:

Присвойте ADDUSERASADMIN=1

Чтобы не добавлять текущего пользователя, выполняющего установку, к роли администратора:

Присвойте ADDUSERASADMIN=0 (по умолчанию)

Примечание.
Этот параметр командной строки имеется только в выпусках SQL Server 2005 Express Edition.

См. также

Другие ресурсы

Пользовательские экземпляры для тех, кто не обладает правами администратора


Настройки параметров отчетов об ошибках и использовании (SQL Server Express)

Настройки параметров отчетов об ошибках и использовании (SQL Server Express)
Справочник по пользовательскому интерфейсу программы установки > Справка по пользовательскому интерфейсу программы установки (SQL Server Express) >

Страница "Отчеты об ошибках" в мастере установки позволяет отключить функцию ведения отчетов об ошибках в SQL Server 2005 Express Edition (SQL Server Express). По умолчанию для SQL Server Express ведение отчетов об ошибках включено.

Параметр

Параметр Описание

Ведение отчетов об ошибках

По умолчанию флажок ведения отчетов об ошибках установлен. Для отключения ведения отчетов об ошибках снимите флажок.

Если оставить эту функцию включенной, SQL Server будет настроен на автоматическую отправку отчета в Microsoft в случае возникновения критической ошибки в SQL Server Database Engine. Отчеты об ошибках в Microsoft используются для улучшения функций SQL Server, при этом сохраняется конфиденциальность всех сведений.

Сведения об ошибках отправляются по зашифрованному каналу в Microsoft, где они хранятся и предоставляются в соответствии с ограничениями доступа. Кроме того, эти сведения можно отправлять на корпоративный сервер отчетов об ошибках. Дополнительные сведения о настройке корпоративного сервера отчетов об ошибках см. на веб-узле корпорации Майкрософт. Отчеты об ошибках содержат следующие сведения.

  • Состояние SQL Server на момент возникновения проблемы.

  • Сведения о версии операционной системы и оборудовании компьютера.

  • Код цифрового продукта, определяющий лицензию.

  • IP-адрес компьютера в сети.

  • Сведения из памяти или файлов процесса, вызвавшего ошибку.

В Microsoft не выполняется преднамеренного сбора пользовательских файлов, имени, адреса, адреса электронной почты или других личных сведений. Однако отчет об ошибке может содержать связанные с клиентом сведения из памяти или файлов процесса, вызвавшего ошибку. Хотя эти сведения потенциального могут быть использованы для определения личности пользователя, в Microsoft они не используются для этой цели. Сведения о политике сбора данных в отчетах об ошибках Microsoft см. на веб-узле корпорации Майкрософт.

Если ведение отчетов об ошибках включено и возникает критическая ошибка, возможно, появится ответ журнала событий Microsoft Windows со ссылкой на статью об этой ошибке в базе данных Microsoft.

Для отключения ведения отчетов об ошибках по завершении установки нажмите кнопку Пуск и выберите последовательно: Все программы, Microsoft SQL Server 2005, Средства настройки, затем щелкните Служба отчетов об ошибках и использовании SQL Server.

Использование функций

По умолчанию флажок ведения отчетов об использовании функций установлен. Для отключения ведения отчетов об использовании функций снимите флажок. Если включить ведение отчетов об использовании функций, SQL Server будет настроен на периодическую отправку отчета в Microsoft. Отчеты будут включать сведения о конфигурации оборудования и использовании SQL Server Express программного обеспечения и служб. В Microsoft данные об использовании функций будут использованы для улучшения SQL Server.

Сведения собираются раз в день для всех включенных экземпляров SQL Server. По умолчанию сбор запланирован на полночь, что позволяет свести к минимуму нагрузку на сервер. Для смены времени сбора отредактируйте вручную раздел реестра, где указано время сбора. У каждого экземпляра SQL Server собственный раздел реестра; в следующем примере используется первый экземпляр SQL Server, установленный на сервере (MSSQL.1):

HKLM\Software\Microsoft\Microsoft SQL Server\MSSQL.1\CPE\TimeofReporting

Значение этого раздела реестра содержит время сбора в минутах после 00:00 (полуночи). Например, значение 60 означает запуск сбора в 1:00, а 1200 - в 20:00 и т. д.

Для отключения ведения отчетов об ошибках по завершении установки нажмите кнопку Пуск и выберите последовательно: Все программы, Microsoft SQL Server 2005, Средства настройки, затем щелкните Служба отчетов об ошибках и использовании SQL Server.


Страница "Готово для установки" (SQL Server Express)

Страница "Готово для установки" (SQL Server Express)
Справочник по пользовательскому интерфейсу программы установки > Справка по пользовательскому интерфейсу программы установки (SQL Server Express) >

Страница "Готово для установки" появляется, когда у мастера установки SQL Server достаточно сведений, чтобы начать копирование файлов для обновления системы.

Параметры

Параметр | Описание
Установить | Выберите, чтобы установить компоненты из списка.
Назад | Выберите, чтобы изменить любые параметры установки.
Отмена | Выберите, чтобы остановить установку.


Выбор функций обслуживания

Выбор функций обслуживания |
 | См. также
Справочник по пользовательскому интерфейсу программы установки > Справка по пользовательскому интерфейсу программы установки (SQL Server Express) >

На странице Выбор функций обслуживания мастера установки осуществляется выбор серверного компонента, которому требуется обслуживание.

Параметры

Можно выбрать любой отдельный компонент сервера для обслуживания.

Отчет

Просмотрите список компонентов и функций SQL Server 2005, установленных на компьютере. Отчет включает версию, выпуск, версию обновления и сведения о языке для каждого из установленных компонентов и функций.

См. также

Справочник

Компоненты для установки
Возможности, поддерживаемые различными выпусками SQL Server 2005


Искомый раздел будет недоступен, пока программа установки не завершит установку электронной документации

Искомый раздел будет недоступен, пока программа установки не завершит установку электронной документации

После того, как установка завершится, документацию по Microsoft SQL Server можно просмотреть, выбрав пункт меню Справка или нажав клавишу F1 при работе с диалоговыми окнами или элементами интерфейса, либо (из меню Пуск) выбрать Все Программы, затем Microsoft SQL Server 2005, Документация и учебники и Электронная документация по SQL Server.