ISA Server 2006 Enterprise Edition — Руководство по установке

Microsoft Internet Security and Acceleration Server 2006
ISA Server 2006 Enterprise Edition — Руководство по установке

В данном документе предоставляется подробные инструкции по установке сервера Microsoft® Internet Security and Acceleration (ISA) Server 2006 Enterprise Edition.

Перед установкой сервера ISA Server 2006 рекомендуется просмотреть заметки о выпуске, представленные на веб-узле ISA Server. Кроме того, перед установкой сервера ISA Server 2006 необходимо настроить и сконфигурировать аппаратное и программное обеспечение компьютера, на котором будет действовать сервер ISA Server.

Содержание

  • Требования установки

  • Перед началом работы

  • Установка сервера ISA Server Enterprise Edition

  • Дополнительные сведения

  • Удаление программного обеспечения ISA Server

  • Приложение А Добавление адресов во внутреннюю сеть

  • Приложение Б Ключи установки

  • Приложение В Автоматическая установка

  • Приложение Г Файл журнала установки ISA Server

  • Приложение Д Устранение неполадок установки

© 2006. Корпорация Майкрософт. Все права защищены.


ISA Server Enterprise Edition — Требования установки

ISA Server Enterprise Edition — Требования установки
ISA Server 2006 Enterprise Edition — Руководство по установке >

Для использования сервера ISA Server требуется следующее.

  • Персональный компьютер с частотой процессора 550 МГц или выше.

  • Операционная система Microsoft Windows Server™ 2003 SP1 или Microsoft Windows Server 2003 R2.

    Обратите внимание на следующее.

    • Сервер ISA Server 2006 невозможно установить на 64-разрядных версиях операционной системы Windows Server 2003.

    • Если сервер ISA Server 2006 установлен в качестве члена домена, ISA Server Enterprise Edition можно установить только в домене Windows Server 2003 или Windows® 2000 Server.

  • Не менее 256 МБ памяти.

  • 150 МБ свободного места на жестком диске. Этот объем жесткого диска планируется использовать исключительно для кэширования.

  • Одна сетевая плата, совместимая с операционной системой, для обеспечения связи с внутренней сетью.

  • Дополнительная сетевая плата для каждой сети, подключенной к компьютеру ISA Server.

  • Локальный раздел жесткого диска, отформатированный с файловой системой NTFS.

    Примечание:
    Сервер ISA Server можно использовать на компьютере только с одной сетевой платой. Обычно такая необходимость возникает, когда на конце сети расположен другой межсетевой экран, связывающий корпоративный ресурс с Интернетом. В данном сценарии для одной платы сервер ISA Server как правило предоставляет опубликованным серверам дополнительный уровень защиты за счет фильтрации приложений или кэширует содержимое, полученное из Интернета. Дополнительные сведения см. в разделе "Настройка ISA Server на компьютере с одной сетевой платой" на веб-узле Microsoft TechNet.


ISA Server Enterprise Edition — Перед началом работы

ISA Server Enterprise Edition — Перед началом работы
ISA Server 2006 Enterprise Edition — Руководство по установке >

Перед установкой сервера ISA Server 2006 Enterprise Edition необходимо собрать информацию об организации сети, характере трафика, членстве в домене и планировании производительности. Эту информацию можно использовать для повышения эффективности процесса установки.

  • Организация сети

  • Характер трафика

  • Сервер ISA Server и членство в домене

  • Планирование производительности


ISA Server Enterprise Edition — Сеть

ISA Server Enterprise Edition — Сеть
ISA Server 2006 Enterprise Edition — Руководство по установке > ISA Server Enterprise Edition — Перед началом работы >

Необходимо собрать информацию о сервере хранилища настроек и членах массива серверов ISA Server, как это описано в следующих разделах.

Сервер хранилища настроек

Внесите в следующую таблицу информацию о сервере хранилища настроек.

Информацию о сервере хранилища настроек см. ниже в разделе ISA Server Enterprise Edition — Компоненты данного документа.

Свойство | Значение | Свойство | Значение
IP-адрес | ___.___.___.___ | Маска подсети | ___.___.___.___
Основной шлюз | ___.___.___.___ | Не применимо | Не применимо
Предпочитаемый DNS-сервер | ___.___.___.___ | Альтернативный DNS-сервер | ___.___.___.___
Полное доменное имя (FQDN) | _______________ | Не применимо | Не применимо

Обратите внимание на следующее.

  • Необходимо убедиться в правильной настройке службы DNS, так как сервер хранилища настроек должен иметь возможность разрешения полных доменных имен всех членов массива.

Члены массива серверов ISA Server (серверы межсетевого экрана ISA Server)

Необходимо собрать информацию, описанную в следующих таблицах.

Плата внешней сети

Внесите в следующую таблицу данные о плате внешней сети.

Свойство | Значение | Свойство | Значение
IP-адрес | ___.___.___.___ | Маска подсети | ___.___.___.___
Основной шлюз | ___.___.___.___ | Не применимо | Не применимо
Предпочитаемый DNS-сервер | ___.___.___.___ | Альтернативный DNS-сервер | ___.___.___.___

Плата внутренней сети

Внесите в следующую таблицу данные о плате внутренней сети.

Свойство | Значение | Свойство | Значение
IP-адрес | ___.___.___.___ | Маска подсети | ___.___.___.___
Основной шлюз | ___.___.___.___ | Не применимо | Не применимо
Предпочитаемый DNS-сервер | ___.___.___.___ | Альтернативный DNS-сервер | ___.___.___.___

Плата демилитаризованной зоны

Внесите в следующую таблицу данные о плате демилитаризованной зоны.

Свойство | Значение | Свойство | Значение
IP-адрес | ___.___.___.___ | Маска подсети | ___.___.___.___
Основной шлюз | ___.___.___.___ | Не применимо | Не применимо
Предпочитаемый DNS-сервер | ___.___.___.___ | Альтернативный DNS-сервер | ___.___.___.___

Общая информация

Внесите в следующую таблицу данные о полном доменном имени.

Свойство | Значение | Свойство | Значение
Полное доменное имя | _______________ | Не применимо | Не применимо

Обратите внимание на следующее.

  • Если имеется сервер с несколькими сетевыми платами, обычно указывается основной шлюз. На сервере ISA Server основной шлюз, как правило, настраивается на плату внешней сети.

  • При наличии дополнительных внутренних сетей, подключенных через маршрутизатор, прежде чем начинать установку, добавьте требуемые маршруты к серверу ISA Server.

  • Перед установкой сервера ISA Server 2006 необходимо убедиться в правильной настройке маршрутизации.

  • В большинстве случаев DNS-серверы настраиваются на плату внутренней сети и должны указывать на внутренний DNS-сервер. Проверьте корректность разрешения имен.

  • В зависимости от конфигурации можно создать правило доступа, разрешающее DNS-запросы от внутренней сети.

  • Если маршрутизация и разрешение имен работают неправильно, то при установленном сервере ISA Server 2006 возникнут сложности с определением причины проблемы.

Для получения дополнительных сведений см. статьи:

  • "Настройка DNS-серверов для ISA Server" на веб-узле Microsoft TechNet

  • "Коллекция сетей" на веб-узле Microsoft TechNet


ISA Server Enterprise Edition — Характер трафика

ISA Server Enterprise Edition — Характер трафика
ISA Server 2006 Enterprise Edition — Руководство по установке > ISA Server Enterprise Edition — Перед началом работы >

Перед установкой сервера ISA Server полезно выяснить, какие протоколы требуются для обеспечения связи компьютеров с сетями. Эта информация полезна при проектировании базы правил. Многие приложения начинают обмен данными через один порт, а затем переключаются на другой порт или диапазон портов.

Трафик можно разделить на следующие категории:

  • серверные приложения,

  • пользовательские приложения,

  • приложения управления сетью.


ISA Server Enterprise Edition — Сервер ISA Server и членство в домене

ISA Server Enterprise Edition — Сервер ISA Server и членство в домене
ISA Server 2006 Enterprise Edition — Руководство по установке > ISA Server Enterprise Edition — Перед началом работы >

Если сервер хранилища настроек или любой из членов массива не находятся в одном домене или в домене с отношениями доверия, то необходимо выполнить описанные ниже действия.

  • Создайте и экспортируйте сертификат проверки подлинности для сервера хранилища настроек. Убедитесь, что файл экспорта сертификата может быть принят компьютером, выполняющим функции сервера хранилища настроек в процессе установки.

  • Установите корневой сертификат для центра сертификации, который выпустил сертификат сервера для сервера хранилища настроек членов массива.

Информацию об установке ISA Server в рабочей группе, включая инструкции по установке сертификата, см. в разделе, посвященном ISA Server Enterprise Edition в рабочей группе, на веб-узле Microsoft TechNet.


ISA Server Enterprise Edition — Планирование производительности

ISA Server Enterprise Edition — Планирование производительности
ISA Server 2006 Enterprise Edition — Руководство по установке > ISA Server Enterprise Edition — Перед началом работы >

Минимальные системные требования для Microsoft ISA Server 2006 описаны ранее в разделе ISA Server Enterprise Edition — Требования установки данного документа. Однако для улучшения производительности при планировании аппаратного обеспечения для ISA Server 2006 и скорости подключения к Интернету необходимо учитывать ожидаемую нагрузку. При определении аппаратного обеспечения компьютера ISA Server следует ответить на приведенные ниже вопросы.

  • Сколько процессоров и какого типа требуется?

  • Сколько ОЗУ и пространства на диске необходимо и сколько требуется сетевых плат?

  • Какова рекомендованная пропускная способность подключения к Интернету?

Ответы на эти вопросы зависят от конкретных потребностей конфигурации безопасности и сценария развертывания. Особенно на рекомендации к аппаратному обеспечению влияют следующие факторы: конфигурация политики межсетевого экрана, требования к ведению журналов, суммарная пиковая пропускная способность сети, публикуются серверы или просто разрешен доступ к Интернету. Из них суммарная пиковая пропускная способность подключения к Интернету является наиболее важным фактором при определении вычислительных ресурсов, так как в большинстве случаев этот фактор представляет потребности в подключении к Интернету.

В следующей таблице представлены общие рекомендации в зависимости от пропускной способности используемого подключения к Интернету. Следует отметить, что перечисленные здесь рекомендации предполагают наличие веб-трафика и политики с несколькими сотнями правил. Кроме того, не предполагается использование особых конфигураций, таких как кэширование или фильтры сторонних производителей. При использовании кэширования может быть достаточно подключения к Интернету с пропускной способностью, меньшей на 20-30%. Более того, если клиенты настраиваются на использование прокси, то можно ожидать удвоения пропускной способности при тех же конфигурациях аппаратного обеспечения.

Пропускная способность подключения к Интернету | До 7,5 Мбит/с или 5 T1 | До 25 Мбит/с | До 45 Мбит/с или T3 | Примечания
Процессоры | 1 | 1 | 2 |
Тип процессора | Pentium III 550 МГц (или выше) | Pentium 4 2,0–3,0 ГГц | Xeon 2,0–3,0 ГГц | В качестве альтернативы можно использовать другие процессоры сравнимой мощности, эмулирующие набор команд IA-32. В развертываниях, в которых требуется только фильтрация с проверкой с отслеживанием состояния соединений (без фильтрации на более высоком уровне приложений), рекомендованные процессоры Pentium 4 и Xeon обеспечивают необходимую скорость подключений локальной сети.
Память | 256 МБ | 512 МБ | 1 ГБ | При использовании веб-кэширования эти требования могут быть выше.
Пространство на диске | 150 МБ | 2,5 ГБ | 5 ГБ | Этот объем жесткого диска планируется использовать исключительно для ведения журналов.
Сетевая плата | 10/100 Мбит/с | 10/100 Мбит/с | 100/1000 Мбит/с | Это требования для сетевых плат, не подключенных к Интернету.

Дополнительную информацию см. в разделе "Практические рекомендации по обеспечению производительности сервера ISA Server" на веб-узле Microsoft TechNet.


Установка сервера ISA Server Enterprise Edition

Установка сервера ISA Server Enterprise Edition
ISA Server 2006 Enterprise Edition — Руководство по установке >

В данном разделе предоставлена информация о компонентах ISA Server Enterprise Edition, ролях администратора и процедурах установки ISA Server 2006 в следующих двух конфигурациях:

  • ISA Server Enterprise Edition — Компоненты

  • ISA Server Enterprise Edition — Роли администратора

  • Процесс установки

  • Развертывание предприятия

  • Развертывание одного сервера

  • Диспетчер ISA Server


ISA Server Enterprise Edition — Компоненты

ISA Server Enterprise Edition — Компоненты
ISA Server 2006 Enterprise Edition — Руководство по установке > Установка сервера ISA Server Enterprise Edition >

Компоненты ISA Server 2006 Enterprise Edition описаны в следующей таблице.

Компонент Описание

Сервер хранилища настроек

На сервере хранилища настроек хранятся сведения о конфигурации всех массивов предприятия. Сервер хранилища настроек для хранения использует режим ADAM (Active Directory® Application Mode). При установке сервера хранилища настроек, на компьютер автоматически устанавливается ADAM. При конфигурировании массивов в предприятии изменяются данные на сервере хранилища настроек. Компьютеры ISA Server 2006 Enterprise Edition обращаются к серверу хранилища настроек, чтобы проверить появление изменений конфигурации и обновить свои локальные хранилища (на основе реестра). Это делается в целях отражения изменений предприятия.

В предприятии может быть несколько серверов хранилища настроек, каждый из которых содержит точную копию конфигурации предприятия.

Каждый массив связан с конкретным сервером хранилища настроек, от которого он получает обновленную конфигурацию. Кроме того, можно указать альтернативный сервер хранилища настроек, используемый в случае сбоя основного сервера хранилища настроек.

Службы ISA Server

Это компьютер, на котором действует межсетевой экран, виртуальная частная сеть (VPN) и функции кэширования сервера ISA Server. Компьютер с запущенными службами ISA Server подключается к серверу хранилища настроек, на котором хранятся сведения о конфигурации. Каждый компьютер ISA Server Enterprise Edition должен быть членом некоторого массива.

Массив

Массив представляет собой один или несколько компьютеров ISA Server 2006 Enterprise Edition с запущенными службами ISA Server, которые соединены физически и обладают одинаковой общей конфигурацией.

Диспетчер ISA Server

Диспетчер ISA Server — это оснастка консоли управления (MMC), с помощью которой администратор управляет предприятием. С помощью диспетчера ISA Server администратор подключается к конкретному серверу хранилища настроек для управления предприятием.
Примечание:
Все эти компоненты могут быть установлены на одном компьютера. На сервере хранилища настроек хранятся сведения о конфигурации нескольких массивов. Каждому члену массива требуется подключаться к серверу хранилища настроек, чтобы проверить появление изменений, внесенных со времени последней проверки. Кроме того, для установки члена массива требуется доступность сервера хранилища настроек. Это связано с тем, что каждый член массива и диспетчер ISA Server получают сведения о конфигурации от сервера хранилища настроек. В силу важности сервера хранилища настроек для развертывания продукта ISA Server 2006 Enterprise Edition рекомендуется сервер хранилища настроек и члены массива устанавливать на отдельных производственных серверах.

Если службы ISA Server не могут связаться с сервером хранилища настроек, компьютер ISA Server 2006 продолжит предоставлять услуги межсетевого экрана, VPN и прокси на основе последней известной конфигурации, полученной от сервера хранилища настроек. Однако в этом случае отслеживание и изменение конфигурации невозможны, пока не будет восстановлена связь с сервером хранилища настроек.


ISA Server Enterprise Edition — Роли администратора

ISA Server Enterprise Edition — Роли администратора
ISA Server 2006 Enterprise Edition — Руководство по установке > Установка сервера ISA Server Enterprise Edition >

Привилегии различных уровней диспетчера ISA Server определяются посредством ролей администратора. Одним пользователям можно разрешить выполнять функции администраторов на уровне предприятия, а другим — администраторов конкретных массивов. Некоторые администраторы могут изменять политику, тогда как другие могут только просматривать политику или выполнять наблюдение за сервером ISA Server. Роли сервера ISA Server 2006 Enterprise Edition описаны в следующей таблице.

Роль | Описание
Администратор предприятия ISA Server | Пользователи или группы, которым назначена эта роль, имеют полный доступ к предприятию и всем конфигурациям массивов. Кроме того, администратор предприятия может назначать роли другим пользователям и группам.
Аудитор предприятия ISA Server | Пользователи или группы, которым назначена эта роль, могут просматривать конфигурацию предприятия и все конфигурации массивов.
Администратор ISA Server | Пользователи или группы, которым назначена эта роль, могут выполнять любые задания сервера ISA Server, включая конфигурирование правил, применение шаблонов сетей и наблюдение.
Аудитор массива ISA Server | Пользователи или группы, которым назначена эта роль, могут выполнять любые виды наблюдения, включая конфигурирование журналов, определение оповещений и все функции наблюдения, доступные роли сервера базового наблюдения ISA Server.
Аудитор наблюдения за массивом ISA Server | Пользователи или группы, которым назначена эта роль, могут выполнять наблюдение за компьютером ISA Server и сетевой активностью, но не могут настраивать конкретные функциональные возможности наблюдения.

Дополнительные сведения о ролях администратора сервера ISA Server см. в документации по продукту.


ISA Server Enterprise Edition — Процесс установки

ISA Server Enterprise Edition — Процесс установки
ISA Server 2006 Enterprise Edition — Руководство по установке > Установка сервера ISA Server Enterprise Edition >

Перед установкой изучите топологию инфраструктуры серверов Microsoft ISA Server 2006 Enterprise Edition.

Ответьте на приведенные ниже вопросы.

  • Где будет разворачиваться сервер ISA Server: в рабочей группе или в доверенной доменной среде? Дополнительные сведения см. в разделе, посвященном ISA Server Enterprise Edition в рабочей группе, на веб-узле Microsoft TechNet.

  • Где будут установлены серверы хранилища настроек?

  • Будут ли серверы хранилища настроек установлены в одной и той же сети? Дополнительные сведения об установке в нескольких сетях см. в разделе, содержащем рекомендации по развертыванию для ISA Server Enterprise Edition, на веб-узле Microsoft TechNet.

  • Сколько массивов предполагается установить на предприятии?

  • Сколько членов в каждом массиве?

  • Предполагается ли управлять предприятием удаленно?

  • Сколько будет установлено компьютеров удаленного управления?

Перед установкой сервера ISA Server просмотрите предшествующий раздел ISA Server Enterprise Edition — Требования установки в данном документе. Затем выполните развертывание компьютеров в указанном ниже порядке.

  1. Установите сервер хранилища настроек. На сервере хранилища настроек должна быть возможность установки компонента ISA Server 2006. После установки сервер хранилища настроек можно присоединить к существующему предприятию. Можно также создать новое предприятие. В целях обеспечения наиболее эффективного развертывания рекомендуется для каждой организации создавать по одному предприятию. В случае одного предприятия можно управлять всеми массивами организации из одной оснастки управления диспетчера ISA Server.

  2. (Необязательно) Создайте на сервере хранилища настроек массив, правила сети предприятия и политики предприятия. Во время установки членов массива, в соответствии с инструкциями следующего этапа, можно присоединить их к уже существующим массивам.

  3. Установите службы ISA Server на один или несколько компьютеров. При установке компьютера со службами ISA Server первым членом нового массива необходимо указать адреса во внутренней сети. Информацию о внутренней сети см. в документации по продукту.

    Важно:
    Так как внутренняя сеть должна включать в себя IP-адрес, определенный в подключенной и действующей сетевой плате, можно пропустить страницу установки внутренней сети только в том случае, если плата внутренней сети подключена, включена и ей назначен правильный IP-адрес.

Обратите внимание на следующее.

  • В процессе установки сервер ISA Server изменяет динамический диапазон портов драйвера TCP/IP, задавая значение 65535.

  • Если в процессе установки ISA Server выбрать установку компонента "Подробный журнал" (MSDE), то устанавливаются несколько DLL-файлов, включая Ds16gt.dll и Odbc16gt.dll. "Подробный журнал" (MSDE) является необязательным компонентом, устанавливаемым по умолчанию.

Остановка и отключение служб

В процессе установки отключаются следующие службы:

  • брандмауэр подключения к Интернету или общий доступ к подключению Интернета

  • преобразование сетевых IP-адресов (NAT)

Кроме того, на время установки останавливаются следующие службы:

  • служба SNMP,

  • служба FTP-публикации,

  • протокол NNTP (Network News Transfer Protocol),

  • служба IIS Admin,

  • служба веб-публикации.

Эти службы перезапускаются после завершения процесса установки.


Развертывание предприятия

Развертывание предприятия
ISA Server 2006 Enterprise Edition — Руководство по установке > Установка сервера ISA Server Enterprise Edition >

В этом сценарии ISA Server 2006 устанавливается на двух отдельных компьютерах. На первом компьютере устанавливается сервер хранилища настроек, а на втором — службы ISA Server.

Примечание:
В данном сценарии предполагается, что оба компьютера являются членами одного домена. Информацию об установке ISA Server 2006 в среде рабочих групп. см. в разделе, посвященном ISA Server Enterprise Edition в рабочей группе, на веб-узле Microsoft TechNet.

Установка сервера хранилища настроек

На сервере хранилища настроек хранятся сведения о конфигурации всех массивов предприятия. Ниже описывается процедура установки сервера хранилища настроек. Выполните эту процедуру на компьютере, который должен выполнять функции сервера хранилища настроек.

Установка сервера хранилища настроек

  1. Вставьте компакт-диск ISA Server в дисковод или запустите программу ISAAutorun.exe с общего сетевого диска.

  2. В программе установки Microsoft ISA Server щелкните Установить ISA Server 2006 и воспользуйтесь мастером для установки ISA Server 2006 (см. ниже таблицу).

    Страница Поле или свойство Параметр

    Приветствие

    Отсутствует

    Нажмите кнопку Далее.

    Лицензионное соглашение

    Лицензионное соглашение

    Выберите Принимаю условия лицензионного соглашения.

    Сведения о пользователе

    Имя пользователя

    Организация

    Серийный номер продукта

    Введите имя пользователя.

    Введите название организации.

    Введите серийный номер продукта.

    Сценарии установки

    Выберите сценарий установки.

    Выберите Установить сервер хранилища настроек.

    Выбор компонентов

    Просмотрите устанавливаемые компоненты. Обратите внимание, что при этом также устанавливается диспетчер ISA Server.

    Нажмите кнопку Далее.

    Параметры установки предприятия

    Выберите параметры установки предприятия.

    Выберите Создать новую корпоративную конфигурацию ISA Server.

    Предупреждение о создании предприятия

    На данной странице содержится предупреждение о том, что нельзя устанавливать более одного предприятия. Так как создается новое предприятие, это предупреждение можно проигнорировать.

    Нажмите кнопку Далее.

    Создание нового предприятия

    Имя предприятия

    Описание

    Введите имя предприятия.

    Введите описание предприятия (необязательно).

    Среда развертывания предприятия

    Обмен данными между членами массива и серверами хранилища настроек в одном домене или в домене с отношениями доверия автоматически шифруется.

    Если члены массива и сервер хранилища настроек находятся в одной рабочей группе или в доменах без отношений доверия, то для шифрования каналов связи между членами массивов и сервером хранилища настроек необходимо установить цифровой сертификат.

    Выберите Развертывание осуществляется в одном домене или в доменах с установленными отношениями доверия.

    Все готово для установки программы

    Отсутствует

    Нажмите кнопку Установить.

  3. После завершения установки выберите Вызвать диспетчер ISA Server после закрытия мастера, а затем нажмите кнопку Готово.

  4. В диспетчере ISA Server раскройте узел Предприятие, а затем — Политики предприятия. Обратите внимание на то, что в списке перечислена только одна политика, Политика по умолчанию. Щелкните Политика по умолчанию и просмотрите правила в области сведений. Там имеется одно правило политики предприятия. Это правило, блокирующее весь трафик, применяется после всех правил уровня массива. Это правило гарантирует, что сервер ISA Server блокирует любой вид доступа без специального разрешения. Кроме этого правила политики предприятия в политике по умолчанию применяются только правила массива. Щелкните узел Массивы. Обратите внимание, этот узле пуст, так как массив еще не создан.

Обратите внимание на следующие моменты.

  • Если выбрать Развертывание осуществляется в одном домене или в доменах с установленными отношениями доверия, то в случае изменения потребностей развертывания перейти к проверке подлинности сертификата сервера можно в любой момент после установки. Для этого необходимо получить экспортированный сертификат сервера и сохранить его на сервере хранилища настроек. Затем запустите инструмент ISACertTool со страницы загрузки ISA Server.

  • Предприятием можно управлять из сервера хранилища настроек, члена массива или компьютера удаленного управления, если зарегистрироваться с учетными данными, которые использовались при установке сервера хранилища настроек, или с учетными данными пользователя, выполняющего роль администратора предприятия ISA Server.

  • Служба сервера хранилища настроек обычно запускается в контексте учетной записи сетевой службы. Если сервер хранилища настроек устанавливается на контроллере домена, то необходимо предоставить учетную запись, в контексте которой служба может работать. Это связано с тем, что учетная запись сетевой службы не может быть использована, если сервер хранилища настроек запущен на контроллере домена. Службу сервера хранилища настроек можно запустить с помощью учетных данных пользователя из группы "Администраторы домена". Однако для максимальной безопасности конфигурации рекомендуется предоставлять учетные данные пользователя, который не является администратором домена. В этом случае необходимо выполнить приведенную ниже процедуру, чтобы гарантировать наличие у данного пользователя прав доступа, требуемых службой.

Предоставление указанному пользователю прав доступа, необходимых для запуска службы хранилища ISA Server (ISASTGCTRL)

  1. Установите сервер хранилища настроек в соответствии с рекомендациями раздела Установка сервера хранилища настроек.

  2. В процессе установки на странице Учетная запись службы сервера хранилища настроек мастера установки введите учетные данные пользователя, который не является администратором домена.

  3. В папке Program Files\Microsoft ISA Server\ADAMData найдите файл Dnsdomain.bat, где Dnsdomain — DNS-имя компьютера, на котором запущена ADAM.

  4. Чтобы запустить эту программу, в командной строке введите Dnsdomain. Файл Dnsdomain.bat должен появиться в каталоге примерно через минуту после завершения установки ADAM.

Создание массива

После установки сервера хранилища настроек можно создать массив. При создании массива можно настроить совместную работу политики предприятия и политики массива и тип правил, которые могут быть созданы в массиве, перед вводом массива в действие и заполнением его серверами.

Примечание:
Администратор предприятия также может создавать массивы и вносить в них серверы, запустив установку сервера ISA Server и выбрав команду Создать новый массив на странице Членство в массиве. Администратор предприятия может ограничить типы правил, создаваемых администратором массивов, то только после создания массива. Он не может ограничить тип правил, если администратор массивов уже создал правило такого типа.

При создании массива следуйте описанной ниже процедуре.

Создание массива

  1. На сервере хранилища настроек запустите диспетчер ISA Server.

  2. Щелкните Массивы. На панели задач вкладки Задачи щелкните команду Создать новый массив, чтобы запустить мастер создания массива. Используйте этот мастер для создания массива в соответствии с приведенной ниже таблицей.

    Страница Поле или свойство Параметр

    Мастер создания массива

    Имя массива

    Введите имя массива.

    DNS-имя массива

    DNS-имя массива

    Введите DNS-имя массива.

    Примечание:
    Такое DNS-имя должно разрешаться клиентами межсетевого экрана и веб-клиентами.

    Назначение политики предприятия

    Примените эту политику предприятия к новому массиву

    Выберите Политику по умолчанию.

    Типы правил политики массива

    Выберите типы правил политики межсетевого экрана массива, которые могут быть созданы для этого массива.

    Выберите следующее.

    "Запретить" правила доступа

    "Разрешить" правила доступа

    Правила публикации (запретить и разрешить)

    Завершение работы мастера создания массива

    Параметры обзоров.

    Нажмите кнопку Назад, чтобы внести изменения, и кнопку Готово, чтобы завершить работу мастера.

  3. После создания массива привилегии администратора массива можно назначить основному массиву. В диспетчере ISA Server правой кнопкой мыши щелкните имя массива и выберите Свойства. Выполните следующие действия.

    1. На вкладке Назначение ролей нажмите кнопку Добавить. Добавьте нужного пользователя. В раскрывающемся меню Роль выберите Администратор массива ISA Server, а затем нажмите кнопку ОК.

    2. Нажмите кнопку ОК, чтобы закрыть страницу свойств.

  4. В область сведений политики межсетевого экрана нажмите кнопку Применить, чтобы применить изменения.

Добавление сервера хранилища настроек в набор компьютеров удаленного управления

Чтобы включить наблюдение за членами массива из сервера хранилища настроек, необходимо добавить данный сервер хранилища настроек в набор компьютеров удаленного управления.

Чтобы изменить набор компьютеров удаленного управления для данного массива, выполните приведенную ниже процедуру.

Изменение набора компьютеров удаленного управления

  1. На сервере хранилища настроек запустите диспетчер ISA Server.

  2. Раскройте Массивы, раскройте Имя_массива, а затем выберите Политика межсетевого экрана.

  3. В панели задач на вкладке Инструментарий щелкните Сетевые объекты.

  4. Разверните Наборы компьютеров, Компьютеры удаленного управления, а затем щелкните Изменить.

  5. Нажмите кнопку Добавить и выберите Компьютер.

  6. В поле Имя введите имя компьютера, введите IP-адрес сервера хранилища настроек в поле IP-адрес компьютера, а затем нажмите кнопку ОК.

  7. Нажмите кнопку ОК, чтобы закрыть окно свойств набора компьютеров удаленного управления.

  8. В область сведений политики межсетевого экрана нажмите кнопку Применить, чтобы применить изменения.

Установка сервера в массиве

После создания массива в нем можно установить компьютеры ISA Server. Выполните приведенные ниже действия на компьютере, который должен стать членом массива. Выполните установку в контексте учетной записи пользователя, которая использовалась при установке сервера хранилища настроек.

Примечание:
Не устанавливайте члена массива серверов ISA Server через RDP-подключение, если при этом используется преобразование сетевых адресов (NAT). После завершения установки ISA Server RDP-подключение будет прервано без предоставления возможности установления нового RDP-подключения в будущем.

Чтобы установить сервер в массиве, выполните приведенную ниже процедуру.

Установка сервера в массиве

  1. Вставьте компакт-диск ISA Server в дисковод или запустите программу ISAAutorun.exe с общего сетевого диска.

  2. В Программе установки Microsoft ISA Server щелкните Установить ISA Server 2006. Используйте этот мастер для создания массива серверов ISA Server 2006 в соответствии с приведенной ниже таблицей.

    Страница Поле или свойство Параметр

    Приветствие

    Отсутствует

    Нажмите кнопку Далее.

    Лицензионное соглашение

    Лицензионное соглашение

    Выберите Принимаю условия лицензионного соглашения.

    Сведения о пользователе

    Имя пользователя

    Организация

    Серийный номер продукта

    Введите имя пользователя.

    Введите название организации.

    Введите серийный номер продукта.

    Сценарии установки

    Выберите сценарий, лучше всего описывающий данную установку.

    Щелкните Установить службы ISA Server.

    Выбор компонентов

    Просмотрите устанавливаемые компоненты. Обратите внимание, что при этом также устанавливается диспетчер ISA Server.

    Нажмите кнопку Далее.

    Размещение сервера хранилища настроек

    Сервер хранилища настроек (введите полное доменное имя)

    Учетные данные подключения

    Введите полное доменное имя сервера хранилища настроек.

    Примечание:
    При получении сообщения об ошибке, связанной с невозможностью подключения к серверу хранилища настроек, перейдите в командную строку. Попробуйте найти сервер хранилища настроек с помощью только что введенного полного доменного имени, чтобы убедиться в том, что это полное доменное имя разрешается правильным IP-адресом сервера хранилища настроек.

    Подключитесь с помощью учетных данных вошедшего пользователя.

    Членство в массиве

    Выберите членство в массиве для данного компьютера ISA Server.

    Выберите Присоединить к существующему массиву.

    При соединение к существующему массиву

    Имя массива

    Введите имя массива, созданного на предыдущем этапе.

    Параметры проверки подлинности сервера хранилища настроек

    Выберите способ проверки подлинности компьютера ISA Server на сервере хранилища настроек.

    Выберите Проверка подлинности Windows.

    Внутренняя сеть

    Описание определения внутренних сетей см. в ISA Server Enterprise Edition — Приложение А. "Добавление адресов во внутреннюю сеть" описано ниже в этом документе.

    Описание определения внутренних сетей см. в ISA Server Enterprise Edition — Приложение А. "Добавление адресов во внутреннюю сеть" описано ниже в этом документе.

    Сообщения предупреждения служб

    Просмотрите службы, которые будут остановлены или отключены, если продолжить.

    Нажмите кнопку Далее.

    Все готово для установки программы

    Отсутствует

    Нажмите кнопку Установить.

  3. После завершения установки нажмите кнопку Готово.
Примечание:
Программа установки ISA Server отключает брандмауэр подключения к Интернету (ICF). В случае запуска анализатора безопасности Microsoft Baseline Security Analyzer после установки служб ISA Server можно проигнорировать следующее сообщение:


Развертывание одного сервера

Развертывание одного сервера
ISA Server 2006 Enterprise Edition — Руководство по установке > Установка сервера ISA Server Enterprise Edition >

В данном сценарии сервер хранилища настроек и службы ISA Server устанавливаются на одном компьютере.

Примечание:
Не устанавливайте члена массива серверов ISA Server через RDP-подключение, если при этом используется преобразование сетевых адресов (NAT). После завершения установки ISA Server RDP-подключение будет прервано без предоставления возможности установления нового RDP-подключения в будущем.

Чтобы выполнить развертывание одного сервера, выполните следующую процедуру.

Развертывание одного сервера

  1. Вставьте компакт-диск ISA Server в дисковод или запустите программу ISAAutorun.exe с общего сетевого диска.

  2. В Программе установки Microsoft ISA Server щелкните Установить ISA Server 2006. Используйте этот мастер для создания массива серверов ISA Server 2006 в соответствии с приведенной ниже таблицей.

    Страница Поле или свойство Параметр

    Приветствие

    Отсутствует

    Нажмите кнопку Далее.

    Лицензионное соглашение

    Лицензионное соглашение

    Выберите Принимаю условия лицензионного соглашения.

    Сведения о пользователе

    Имя пользователя

    Организация

    Серийный номер продукта

    Введите имя пользователя.

    Введите название организации.

    Введите серийный номер продукта.

    Сценарии установки

    Выберите сценарий установки.

    Выберите Установить службы ISA Server и сервер хранилища настроек.

    Выбор компонентов

    Просмотрите устанавливаемые компоненты. Обратите внимание, что при этом также устанавливается диспетчер ISA Server.

    Нажмите кнопку Далее.

    Параметры установки предприятия

    Выберите параметры установки предприятия.

    Выберите Создать новую корпоративную конфигурацию ISA Server.

    Предупреждение о создании предприятия

    На данной странице предупреждается о том, что нельзя устанавливать более одного предприятия. Так как создается новое предприятие, это предупреждение можно проигнорировать.

    Нажмите кнопку Далее.

    Внутренняя сеть

    Описание определения внутренних сетей см. в ISA Server Enterprise Edition — Приложение А. "Добавление адресов во внутреннюю сеть" описано ниже в этом документе.

    Описание определения внутренних сетей см. в ISA Server Enterprise Edition — Приложение А. "Добавление адресов во внутреннюю сеть" описано ниже в этом документе.

    Подключения клиентов межсетевого экрана

    Выберите, требуется ли разрешать незашифрованные соединения между клиентами межсетевого экрана и данным компьютером ISA Server.

    Убедитесь в том, что флажок Разрешить незашифрованные подключения клиентов межсетевого экрана не установлен. Нажмите кнопку Далее.

    Сообщения предупреждения служб

    Просмотрите службы, которые будут остановлены или отключены, если продолжить.

    Нажмите кнопку Далее.

    Все готово для установки программы

    Отсутствует

    Нажмите кнопку Установить.

Обратите внимание на следующее.

  • Если сервер хранилища настроек и службы ISA Server устанавливаются на одном компьютере, то имеет место следующее.

    • Если выбрать Создать новую корпоративную конфигурацию ISA Server, то именем предприятия будет Enterprise.

    • Автоматически создается новый массив со следующими параметрами:

    Значение Параметр

    Имя

    Задайте имя компьютера.

    Примененная политика предприятия

    Задайте политику по умолчанию.

    Типы политики межсетевого экрана массива

    Задайте "Запретить" правила доступа, "Разрешить" правила доступа, и правила публикации ("Запретить" и "Разрешить").

    Метод проверки подлинности хранилища настроек

    Установите проверку подлинности Windows.
  • Программа установки ISA Server отключает брандмауэр подключения к Интернету (ICF). В случае запуска анализатора безопасности Microsoft Baseline Security Analyzer после установки служб ISA Server можно проигнорировать следующее сообщение:

    Брандмауэр Windows — брандмауэр Windows не установлен, настроен неправильно или недоступен в данной версии Windows.


ISA Server Enterprise Edition — Диспетчер ISA Server

ISA Server Enterprise Edition — Диспетчер ISA Server
ISA Server 2006 Enterprise Edition — Руководство по установке > Установка сервера ISA Server Enterprise Edition >

Сервер ISA Server 2006 управляется с помощью оснастки управления диспетчера ISA Server. Между сервером хранилища настроек и компьютером с запущенным диспетчером ISA Server должно быть установлено надежное и быстрое подключение, чтобы диспетчер ISA Server мог быстро отвечать, отображая обновленные сведения о конфигурации. Аналогично диспетчеру ISA Server требуется надежное подключение к массиву серверов ISA Server, чтобы предоставлять данные о наблюдении в реальном времени.

Если скорость подключения к удаленному серверу хранилища настроек меньше 5 Мбит/с, то рекомендуется подключиться к удаленному серверу хранилища настроек через RDP-подключение и запустить на нем диспетчер ISA Server.

Требования для работы диспетчера ISA Server

Для использования диспетчера ISA Server требуется следующее:

  • операционная система Microsoft Windows Server 2003 SP1 или Microsoft Windows Server 2003 R2;

  • операционная система Microsoft Windows® XP SP1 или Microsoft Windows XP SP2.

    Обратите внимание на следующее.

    • Сервер ISA Server 2006 невозможно установить на 64-разрядных версиях операционных систем Windows Server 2003 и Windows XP.

    • Диспетчер ISA Server невозможно установить в операционной системе Microsoft Windows Server 2003, Web Edition.

  • не менее 256 Мб памяти.

Установка диспетчера ISA Server

Диспетчер ISA Server устанавливается по умолчанию, если выбрать установку служб ISA Server или сервера хранилища настроек.

Чтобы установить диспетчер ISA Server, выполните приведенную ниже процедуру.

Установка диспетчера ISA Server

  1. Вставьте компакт-диск ISA Server в дисковод или запустите программу ISAAutorun.exe с общего сетевого диска.

  2. В Программе установки Microsoft ISA Server щелкните Установить ISA Server 2006. С помощью этого мастера установите ISA Server 2006 в соответствии с приведенной ниже таблицей.

    Страница Поле или свойство Параметр

    Приветствие

    Отсутствует

    Нажмите кнопку Далее.

    Лицензионное соглашение

    Лицензионное соглашение

    Выберите Принимаю условия лицензионного соглашения.

    Сведения о пользователе

    Имя пользователя

    Организация

    Серийный номер продукта

    Введите имя пользователя.

    Введите название организации.

    Введите серийный номер продукта.

    Сценарии установки

    Выберите сценарий установки.

    Выберите Установить диспетчер ISA Server.

    Выбор компонентов

    Просмотрите устанавливаемые компоненты. Обратите внимание, что при этом устанавливается также диспетчер ISA Server.

    Нажмите кнопку Далее.

    Все готово для установки программы

    Отсутствует

    Нажмите кнопку Установить.

  3. После завершения установки выберите Вызвать диспетчер ISA Server, чтобы запустить оснастку управления диспетчера ISA Server, а затем нажмите кнопку Готово.


ISA Server Enterprise Edition — Дополнительные сведения

ISA Server Enterprise Edition — Дополнительные сведения
ISA Server 2006 Enterprise Edition — Руководство по установке >

После установки ISA Server 2006 посетите веб-узел с рекомендациями для ISA Server, где можно найти информацию на следующие темы:

  • Планирование, развертывание и интеграция

  • Конфигурирование и администрирование

  • Публикация

  • Клиенты и проверка подлинности

  • Виртуальная частная сеть

  • Кодирование угла


ISA Server Enterprise Edition — Удаление программного обеспечения ISA Server

ISA Server Enterprise Edition — Удаление программного обеспечения ISA Server
ISA Server 2006 Enterprise Edition — Руководство по установке >

Чтобы установить удалить ISA Server, выполните приведенную ниже процедуру.

Удаление сервера ISA Server

  1. Нажмите кнопку Пуск, выберите Панель управления, а затем дважды щелкните Установка и удаление программ.

  2. В Microsoft ISA Server 2006 щелкните Заменить/Удалить.

  3. На странице приветствия щелкните Далее.

  4. На странице Обслуживание программ выберите Удалить.

  5. Подтвердите настройки на странице Найти сервер хранилища настроек и щелкните Далее.

    Примечание:
    Эта страница отображается только при удалении служб ISA Server с компьютера.

  6. Страница Удаление созданных файлов

    • Выберите Не удалять файлы журналов Microsoft ISA Server 2006, чтобы сохранить файлы журналов.

    • Выберите Не удалять файлы Microsoft ISA Server 2006, чтобы сохранить файлы кэша.

      Примечание:
      Эта страница отображается только при удалении служб ISA Server с компьютера.

  7. Нажмите кнопку Удалить, чтобы удалить ISA Server 2006 с компьютера.

Нажмите кнопку Готово, чтобы завершить работу мастера после завершения процесса удаления.

Обратите внимание на следующее.

  • Приложения наблюдения, такие как агент Microsoft Operations Manager (MOM), используют файлы сервера ISA Server и могут влиять на установку и удаление ISA Server. Во избежание проблем завершите работу этих приложений, прежде чем предпринимать какие-либо из описанных ниже действий.

    • Восстановить или изменить

    • Удалить

    • Установить или удалить пакет обновления или исправление

    • Обновить

  • Перед удалением сервера ISA Server диспетчер ISA Server и системный монитор ISA Server должны быть закрыты.

  • Перед удалением компьютера ISA Server, сконфигурированного как сервер хранилища настроек, необходимо убедиться, что все изменения внесены в сервер-копию хранилища настроек. В противном случае изменения конфигурации будут потеряны.

  • При удалении служб ISA Server невозможно подключиться к серверу хранилища настроек, используемому членом массива. Любые хранящиеся там сведения о конфигурации не будут удалены.

  • Массив удаляется при удалении последнего члена массива.

  • Удаляйте по одному члену массива за один раз.

  • При настройке сервера ISA Server некоторые параметры маршрутизации и удаленного доступа могут измениться. При удалении сервера ISA Server конфигурация маршрутизации и удаленного доступа реконфигурируется следующим образом.

    • Служба маршрутизации и удаленного доступа отключена.

    • Политика удаленного доступа, настроенная сервером ISA Server, удалена.

    • Для службы маршрутизации и удаленного доступа восстановлены параметры по умолчанию, после чего служба отключается. Для настройки маршрутизации и удаленного доступа используйте мастер настройки и включения службы маршрутизации и удаленного доступа, доступный из оснастки маршрутизации и удаленного доступа.

  • При настройке интегрированного режима балансировки нагрузки сети изменяются параметры балансировки нагрузки сети Windows Server 2003. При удалении сервера ISA Server конфигурация балансировки нагрузки сети реконфигурируется следующим образом.

    • Сетевые платы остаются включенными в систему балансировки нагрузки сети.

    • Сервер ISA Server не удаляет сетевую службу балансировки нагрузки сети, даже если она была им установлена.


ISA Server Enterprise Edition — Приложение А. "Добавление адресов во внутреннюю сеть"

ISA Server Enterprise Edition — Приложение А. "Добавление адресов во внутреннюю сеть"
ISA Server 2006 Enterprise Edition — Руководство по установке >

Чтобы добавить адреса во внутреннюю сеть, на странице Внутренняя сеть можно использовать следующие команды.

  • Добавить диапазон Позволяет добавить диапазон IP-адресов. Необходимо указать начало и конец диапазона IP-адресов, например, 10.0.0.1 – 10.0.0.255.

  • Добавить плату Позволяет выбрать сетевую плату. Адреса, включаемые во внутреннюю сеть, будут основаны на IP-адресе и маске подсети выбранной платы.

  • Добавить частный Позволяет добавлять адреса, определенные как адреса без маршрутизации на основе RFC 1918 и функции автоматического назначения частных IP-адресов. Дополнительные сведения о частных адресах см. в следующих источниках:

    • "RFC1918" на веб-узле rfc.net;

    • "Использование автоматической TCP/IP-адресации без DHCP-сервера" в центре справки и поддержки Microsoft.

      В следующей таблице приведены диапазоны адресов на основе RFC 1918 или функции автоматического назначения частных IP-адресов (APIPA).

      Диапазон адресов RFC 1918 или APIPA

      10.0.0.0–10.255.255.255

      RFC 1918

      172.16.0.0–172.31.255.255

      RFC 1918

      192.168.0.0–192.168.255.255

      RFC 1918

      169.254.0.0–169.254.255.255

      APIPA
      Примечание:
      Следующий диапазон адресов нельзя добавить к внутренней сети, так как так как по умолчанию он назначается сети локального узла: 127.0.0.1–127.255.255.255.


ISA Server Enterprise Edition — Приложение Б "Ключи установки"

ISA Server Enterprise Edition — Приложение Б "Ключи установки"
ISA Server 2006 Enterprise Edition — Руководство по установке >

При запуске установки из командной строки можно изменить набор устанавливаемых компонентов, предоставить необходимые данные об установке или восстановить установку.

Запуск установки ISA Server и передача параметров установки

  • Чтобы изменить набор компонентов, устанавливаемых во время установки, в командной строке введите команду: PathToISASetup\Setup.exe ADDLOCAL=FeatureToInstall.

  • Чтобы восстановить установку, в командной строке введите команду: PathToISASetup\Setup.exe REINSTALL=ALL

Полный список параметров и значений см. в таблице из Приложения В "Автоматическая установка".


ISA Server Enterprise Edition — Приложение В "Автоматическая установка"

ISA Server Enterprise Edition — Приложение В "Автоматическая установка"
ISA Server 2006 Enterprise Edition — Руководство по установке >

ISA Server 2006 Enterprise Edition можно установить с помощью автоматической установки.

Автоматическая установка сервера ISA Server

  1. Измените один из образцов файлов ответов, которые можно найти на компакт-диске ISA Server. Описание экземпляров файлов ответов см. в таблице, представленной ниже в данном разделе.

  2. В командной строке введите следующую команду:

PathToISASetup\Setup.exe /V" /q[b|n] FULLPATHANSWERFILE=\"PathToINIFile\INI_filename\"".

Параметры

PathToISASetup

Путь к установочным файлам сервера ISA Server 2006. Этот путь может указывать на компакт-диск ISA Server или общую сетевую папку, содержащую файлы сервера ISA Server.

INI_filename

Имя файла ответов.

/q [b|n]

Выполняется автоматическая установка без вывода сообщений. Если указать b, то процесс установки отображается на индикаторе выполнения. Если указать n, то диалоговые окна не отображаются. Сообщения об ошибках сохраняются в файл журнала установки.

PathToINIFile

Путь к папке с информацией об автоматической установке.

Обратите внимание на следующее.

  • Для выполнения этой процедуры необходимо быть членом группы локальных администраторов.

  • Например, команда CD\FPC\setup.exe /v" /qn FULLPATHANSWERFILE=\"C:\InstallStandaloneServer.ini\"" вызывает автоматическую установку компьютера с запущенными службами ISA Server и сервером хранилища настроек, использующим файл InstallStandaloneServer.ini, расположенный в c:\.

  • Компонент Microsoft SQL Server 2000 Desktop Engine (MSDE 2000), требуемый для выполнения многих функций наблюдения, неправильно установлен при удаленной установке сервера ISA Server с помощью служб терминалов в режиме сервера приложений. Для правильной установки компонента MSDE 2000 службы терминалов необходимо использовать в режиме администрирования.

Папка FPC\Unattended_Setup_Sample\Enterprise_Edition на компакт-диске ISA Server содержит образцы файлов ответов, которые могут использоваться при установке сервера в автоматическом режиме. В следующей таблице перечислены образцы файлов вместе с кратким описанием каждого файла.

Имя файла | Описание
InstallJoinedServer.ini | Установите компьютер со службами ISA Server и присоедините его к конкретному массиву.
InstallNewArrayAndServer.ini | Установите компьютер со службами ISA Server и создайте новый массив с именем Имя_массива.
InstallNewManagementServer.ini | Установите сервер хранилища настроек.
InstallStandaloneServer.ini | Установите компьютер со службами ISA Server и сервер хранилища настроек.
Uninstallserver.ini | Удалите сервер.

В следующей таблице описываются записи и значения в файлах конфигурации. Если в файле ответов значение не указано, значить используется значение по умолчанию. Не все параметры используются в каждой конфигурации установки.

Запись Описание Сценарий

ADDLOCAL= {MSFirewall_Management}, {MSFirewall_Services},{MSDE}, {Storage_Server}

Укажите список компонентов (разделенных запятыми), которые должны быть установлены на компьютере. Чтобы установить все компоненты, задайте ADDLOCAL=ALL.

Необязательно для всех сценариев установки.

ARRAY_AUTHENTICATIONMETHOD

Определяет метод проверки подлинности массива.

Возможные значения: Windows (LDAP) или Сертификат (LDAPS). При задании этого значения также необходимо указать значение параметра CLIENT_CERTIFICATE_FULLPATH.Default: Windows.

Необязательно при следующих установках:

  • сервер в новом массиве;

  • комбинированные службы ISA Server и сервер хранилища настроек.

В сценариях рабочей группы должен иметь значение "Сертификат".

ARRAY_DESCR

Описывает массив.

По умолчанию: пустой.

Необязательно при следующих установках:

  • сервер в новом массиве (не используется при присоединении к существующему массиву).

  • комбинированные службы ISA Server и сервер хранилища настроек.

ARRAY_MODE

Укажите, требуется ли при установке сервера создать новый массив или сервер присоединяется к существующему массиву. Возможные значения: Создать или Присоединить.

По умолчанию: Новый.

Необязательно при следующих установках:

  • сервер в новом массиве (не используется при присоединении к существующему массиву).

  • Новый массив, указанный для данной установки сервера.

ARRAY_DNS_NAME

Укажите имя, используемое клиентами межсетевого экрана и веб-прокси при подключении к данному массиву.

По умолчанию: имя компьютера.

Необязательно при следующих установках:

  • сервер в новом массиве (не используется при присоединении к существующему массиву).

  • комбинированные службы ISA Server и сервер хранилища настроек.

ARRAY_ENTERPRISEPOLICY

Указывает, какую политику предприятия использовать. По умолчанию: Только политика массива.

Требуется при установке сервера в новом массиве. Не следует указывать при установке служб ISA Server и сервера хранилища настроек в новом предприятии.

ARRAY_INTERNALNET

Указывает диапазон IP-адресов во внутренней сети нового массива. Определяет описание нового массива.

N From1-To1,From2-To2,... FromI-ToI, где N — номер диапазона, а FromI-ToI — начальный и конечный адреса в каждом диапазоне.

Требуется при следующих установках:

  • сервер в новом массиве;

  • комбинированные службы ISA Server и сервер хранилища настроек.

  • Присоединение существующего массива, для которого внутренняя сеть не определена.

Не следует указывать при установке сервера в существующем массиве, в котором определена внутренняя сеть.

Необязательно при использовании ARRAY_INTERNALNET_ENTERPRISE_NETS.

ARRAY_INTERNALNET_ENTERPRISE_NETS

Указывает имена корпоративных сетей, которые включены во внутреннюю сеть массива.

Синтаксис: "network1" "network2"..."networkN".

Если имя сети содержит кавычки, замените их двойными кавычками("").

Необязательно, если указан ARRAY_INTERNALNET. В противном случае требуется при установке сервера в новом массиве.

Не следует указывать при установке сервера хранилища настроек для нового предприятия.

ARRAY_NAME

При присоединении к массиву указывает имя нового или существующего массива.

По умолчанию: имя компьютера (для установки нового массива).

Необязательно при следующих установках:

  • сервер в новом массиве (не используется при присоединении к существующему массиву).

  • комбинированные службы ISA Server и сервер хранилища настроек.

Требуется при установке сервера в существующий массив.

CLIENT_CERTIFICATE_FULLPATH

Указывает, какой корневой сертификат использовать при подключении к серверу хранилища настроек.

Необязательно при следующих установках:

  • сервер в новом массиве;

  • комбинированные службы ISA Server и сервер хранилища настроек.

  • сервер в существующем массиве.

Требуется в сценариях рабочей группы.

COMPANYNAME=Имя_компании

Указывает имя компании, устанавливающей данный продукт.

Необязательно для всех сценариев установки.

DONOTDELLOGS = {0|1}

Если задано значение 1, файлы журналов на данном компьютере не удаляются. По умолчанию: 0.

Необязателен при удалении.

DONOTDELCACHE = {0|1}

Если задано значение 1, файлы кэша на данном компьютере не удаляются. По умолчанию: 0.

Необязателен при удалении.

ENTERPRISE_DESCR

Описывает предприятие.

По умолчанию: пустой.

Необязательно при следующих установках:

  • сервер хранилища настроек в новом предприятии;

  • комбинированные службы ISA Server и сервер хранилища настроек в новом предприятии.

ENTERPRISE_MODE

Указывает, чем является данный сервер хранилища настроек: новым предприятием или копией существующего сервера хранилища настроек. Возможные значения: "Новый" или "Копия".

По умолчанию: Новый.

Необязательно при следующих установках:

  • сервер хранилища настроек в новом предприятии;

  • комбинированные службы ISA Server и сервер хранилища настроек в новом предприятии.

ENTERPRISE_NAME

Указывает имя предприятия.

По умолчанию: предприятие.

Необязательно при следующих установках:

  • сервер хранилища настроек в новом предприятии;

  • комбинированные службы ISA Server и сервер хранилища настроек в новом предприятии.

HOST_ID

Указывает идентификатор узла члена массива. Все члены массива должны иметь различные идентификаторы узла.

По умолчанию: назначен автоматически.

Необязательно при следующих установках:

  • сервер в новом массиве;

  • комбинированные службы ISA Server и сервер хранилища настроек.

  • сервер в существующем массиве.

InstallDir={install_directory}

Указывает каталог установки ISA Server. Если он не указан, по умолчанию используется первый диск, имеющий достаточно места. Синтаксис:

Диск:\Папка

Папка по умолчанию: %Program Files%\Microsoft ISA Server.

Необязательно для всех сценариев установки.

INTRA_ARRAY_ADDRESS_IP

Определяет IP-адрес, используемый для связи между компьютерами ISA Server одного массива. Данный IP-адрес должен быть IP-адресом на компьютере ISA Server.

Необязательно при следующих установках:

  • сервер в новом массиве;

  • комбинированные службы ISA Server и сервер хранилища настроек.

  • сервер в существующем массиве.

PIDKEY

Указывает ключ продукта. Это 25-разрядный номер, указанный на обратной стороне коробки компакт-диска ISA Server.

Требуется для всех сценариев установки.

REMOVE={MSFirewall_Management}, {MSFirewall_Services},{MSDE}, {Storage_Server}

Укажите список компонентов (разделенных запятыми), которые должны быть удалены с компьютера. Чтобы удалить все компоненты, задайте REMOVE=ALL.

Необязательно для всех сценариев установки.

SERVER_CERTIFICATE_FULLPATH

Указывает, какой сертификат сервера использовать.

Необязательно при следующих установках:

  • сервер хранилища настроек;

  • комбинированные службы ISA Server и сервер хранилища настроек.

Требуется в сценариях рабочей группы или доменов без отношений доверия.

SERVER_CERTIFICATE_PASSWORD

Указывает пароль для данного сертификата сервера. Необходимо установить SERVER_CERTIFICATE_PASSWORD, если в SERVER_CERTIFICATE_FULLPATH указан зашифрованный сертификат.

Необязательно при установке следующих компонентов:

  • сервер хранилища настроек;

  • комбинированные службы ISA Server и сервер хранилища настроек.

Требуется в сценариях рабочей группы или доменов без отношений доверия.

STORAGESERVICE_ACCOUNT

Указывает имя учетной записи пользователя для данного сервера хранилища настроек.

По умолчанию: NT AUTHORITY\NetworkService.

Требуется при установке сервера хранилища настроек на контроллере домена.

В противном случае указывать не нужно.

STORAGESERVER_COMPUTERNAME

Указывает полное доменное имя сервера хранилища настроек для подключения. Значение по умолчанию — localhost. В этом случае используется сервер хранилища настроек, установленный на данном компьютере.

Требуется при установке следующих компонентов:

  • сервер в новом или существующем массиве;

  • сервер-копия хранилища настроек (если параметр ENTERPRISE_MODE имеет значение "Копия" независимо от установки служб ISA Server).

STORAGESERVER_CONNECT_ACCOUNT

Указывает имя учетной записи пользователя, которая будет использоваться при подключении к компьютеру STORAGESERVER_COMPUTERNAME. По умолчанию: учетная запись текущего пользователя.

Необязательно при следующих установках:

  • сервер в новом массиве;

  • комбинированные службы ISA Server и сервер хранилища настроек (при репликации);

  • сервер в существующем массиве.

STORAGESERVER_CONNECT_PWD

Указывает пароль (открытым текстом) для учетной записи STORAGESERVER_CONNECT_ACCOUNT. По умолчанию: пароль для текущего пользователя.

Необязательно при следующих установках:

  • сервер в новом массиве;

  • комбинированные службы ISA Server и сервер хранилища настроек (при репликации);

  • сервер в существующем массиве.

STORAGESERVICE_PWD

Указывает пароль для учетной записи STORAGESERVICE_ACCOUNT.

По умолчанию: без пароля.

Необязательно при следующих установках:

  • комбинированные службы ISA Server и сервер хранилища настроек.

  • сервер хранилища настроек (или только копия).

SUPPORT_EARLIER_CLIENTS

Указывает, могут ли клиенты, использующие предыдущие версии клиента межсетевого экрана или операционной системы, подключаться к данному массиву ISA Server. Возможные значения: 0 (по умолчанию) или 1.

Необязательно при следующих установках:

  • сервер в новом массиве;

  • комбинированные службы ISA Server и сервер хранилища настроек.


ISA Server Enterprise Edition — Приложение Г "Файл журнала установки ISA Server"

ISA Server Enterprise Edition — Приложение Г "Файл журнала установки ISA Server"
ISA Server 2006 Enterprise Edition — Руководство по установке >

При установке ISA Server 2006 программа установки автоматически создает файлы журнала, которые содержат подробные сведения об установке. Информация в файле журнала установки ISA Server 2006 основана на ведении журналов установщиком Windows. Установщик Windows регистрирует ошибки, возникающие в процессе работы программы установки ISA Server 2006. Установщик Windows также регистрирует и другую информацию. Для просмотра файлов журнала можно воспользоваться программой "Блокнот". Информация, записываемая установщиком в эти журнальные файлы, может помочь администратору в устранении проблем неудачной установки.

При установке сервера ISA Server 2006 в папке %winddir%\temp создаются журнальные файлы, перечисленные в следующей таблице.

Файл журнала | Описание
ISAWRAP_NNN.log | В файле журнала упаковщика установки регистрируется общие сведения об успешной или неудачной установке межсетевого экрана и Microsoft SQL Server Desktop Engine (MSDE).
ISAFWSV_NNN.log | В файле журнала установки службы межсетевого экрана регистрируются события и ошибки, связанные с конфигурацией установки ISA Server 2006.
ISAMSDE_NNN.log | В файле журнала установки базы данных ISA Server 2006 регистрируются события и ошибки, связанные с MSDE.
ISAFWUI_NNN.log | В MSI-файлах журнала последовательности пользовательского интерфейса регистрируются события и ошибки, связанные с конфигурацией установки ISA Server 2006.
ISAADAM_INSTALL_NNN.log | В файле журнала установки ADAM регистрируются события и ошибки, связанные с установкой хранилища ADAM при установке сервера хранилища настроек.
ISAADAM_UNINSTALL_NNN.log | В файле журнала удаления ADAM регистрируются события и ошибки, связанные с удалением хранилища ADAM с компьютера. Хранилище ADAM удаляется вместе с удалением сервера хранилища настроек.
ISAADAM_IMPORTSCHEMA_NNN.log | В файле журнала схемы импорта ADAM регистрируется успешные изменения схемы, автоматически применяемые к хранилищу ADAM во время установки.
ISAADAM_IMPORTSCHEMAERR_NNN.log | Журнал ошибок схемы импорта ADAM создается только при возникновении ошибок, связанных с автоматическим применением изменений схемы к хранилищу ADAM во время установки.
Примечание:
Где NNN — уникальный трехзначный идентификатор установки.

Все файлы журналов установки ISA Server 2006 имеют одинаковый уникальный трехзначный идентификатор установки, указывающий на соответствующую попытку установки. При каждой установке или удалении сервера ISA Server 2006 создаются новые файлы журналов, использующие одинаковый трехзначный идентификатор. Для просмотра таких файлов журналов, выполните приведенную ниже процедуру.

Просмотр файлов журналов установки ISA Server

  1. С помощью проводника Windows Explorer откройте папку %windir%\temp.

  2. Правой кнопкой мыши щелкните нужный файл, а затем — Открыть с.

  3. В диалоговом окне Открыть с нажмите кнопку Блокнот, а затем ОК.

  4. Повторите действия 2 и 3, чтобы просмотреть остальные журналы.


ISA Server Enterprise Edition — Приложение Д. "Устранение неполадок установки"

ISA Server Enterprise Edition — Приложение Д. "Устранение неполадок установки"
ISA Server 2006 Enterprise Edition — Руководство по установке >

Дополнительные сведения о распространенных проблемах, возникающих при установке сервера ISA Server 2006 Enterprise Edition, см. в разделе об устранении неполадок при установке на веб-узле Microsoft TechNet.


Информация об авторских правах для Руководства по установке ISA Server Enterprise Edition

Информация об авторских правах для Руководства по установке ISA Server Enterprise Edition

Информация в данном документе, включая URL-адреса и другие ссылки на веб-узлы Интернета, могут быть изменены без предварительного уведомления. Если не указано иное, компании, организации, продукты, имена доменов, адреса электронной почты, логотипы, люди, места и события, представленные в примерах, являются вымышленными. Любое сходство с реальными компаниями, организациями, продуктами, именами доменов, адресами электронной почты, логотипами, лицами, местами или событиями не преднамеренно. Ответственность за соблюдение любых применимых законов об авторских правах возлагается на пользователя. Без ограничения авторских прав никакая часть данного документа не может быть воспроизведена, сохранена или введена в систему поиска или передана в любой форме или любыми средствами (электрическими, механическими, фотокопированием, записью или иначе) и в любых целях без явного письменного разрешения корпорации Майкрософт.

Корпорация Майкрософт может владеть патентами, патентными приложениями, товарными знаками, авторскими правами и другой интеллектуальной собственностью, относящейся к содержимому данного документа. Предоставление этого документа не означает получение лицензии на эти патенты, товарные знаки, авторские права и другую интеллектуальную собственность, если это явно не записано в лицензионном соглашении от корпорации Майкрософт.

© 2006. Корпорация Майкрософт. Все права защищены.

Microsoft, Active Directory, ActiveSync, Outlook, SharePoint, Windows, Windows Mobile и Windows Server являются товарными знаками или зарегистрированными товарными знаками корпорации Майкрософт в США и других странах.