ISA Server 2006 Standard Edition — Руководство по установке

Microsoft Internet Security and Acceleration Server 2006
ISA Server 2006 Standard Edition — Руководство по установке

В этом документе предоставлены подробные инструкции по установке сервера Microsoft® Internet Security and Acceleration (ISA) Server 2006 Standard Edition.

Перед установкой сервера ISA Server 2006 рекомендуется просмотреть заметки о выпуске, представленные на веб-узле ISA Server. Кроме того, перед установкой сервера ISA Server 2006 необходимо настроить и сконфигурировать аппаратное и программное обеспечение компьютера, на котором будет действовать сервер ISA Server.

Содержание

  • Требования установки

  • Перед началом работы

  • Процедуры установки

  • Установка диспетчера ISA Server

  • Дополнительные сведения

  • Удаление программного обеспечения ISA Server

  • Приложение А Добавление адресов во внутреннюю сеть

  • Приложение Б Ключи установки

  • Приложение В Автоматическая установка

  • Приложение Г Файл журнала установки ISA Server

  • Приложение Д Устранение неполадок установки

© 2006. Корпорация Майкрософт. Все права защищены.


ISA Server Standard Edition — Требования установки

ISA Server Standard Edition — Требования установки
ISA Server 2006 Standard Edition — Руководство по установке >

Для использования сервера ISA Server требуется следующее.

  • Персональный компьютер с частотой процессора 550 МГц или выше.

  • Операционная система Microsoft Windows Server™ 2003 SP1 или Microsoft Windows Server 2003 R2.

    Обратите внимание на следующее.

    • Сервер ISA Server 2006 невозможно установить на 64-разрядных версиях операционной системы Windows Server 2003.

    • Если сервер ISA Server 2006 установлен в качестве члена домена, сервер ISA Server Standard Edition можно установить только в домене Windows Server 2003 или Windows 2000 Server.

  • 256 МБ памяти.

  • 150 МБ свободного места на жестком диске. Этот объем жесткого диска планируется использовать исключительно для кэширования.

  • Одна сетевая плата, совместимая с операционной системой, для обеспечения связи с внутренней сетью.

  • Дополнительная сетевая плата для каждой сети, подключенной к компьютеру ISA Server.

  • Локальный раздел жесткого диска, отформатированный с файловой системой NTFS.

    Примечание:
    Сервер ISA Server можно использовать на компьютере только с одной сетевой платой. Обычно такая необходимость возникает, когда на конце сети расположен другой межсетевой экран, связывающий корпоративный ресурс с Интернетом. В данном сценарии с одной платой сервер ISA Server как правило предоставляет опубликованным серверам дополнительный уровень защиты за счет фильтрации приложений или кэширует содержимое, полученное из Интернета. Дополнительные сведения см. в разделе "Настройка ISA Server на компьютере с одной сетевой платой" на веб-узле Microsoft TechNet.

    Предосторежение:
    Не устанавливайте сервер ISA Server 2006 Standard Edition на многопроцессорном компьютере, если число процессоров больше четырех.


ISA Server Standard Edition — Перед началом работы

ISA Server Standard Edition — Перед началом работы

При установке сервера ISA Server 2006 Standard Edition необходимо иметь информацию об организации сети и характере трафика. Эту информацию можно использовать для повышения эффективности процесса установки.

  • Организация сети

  • Характер трафика

  • Планирование производительности

  • Процесс установки


ISA Server Standard Edition — Сеть

ISA Server Standard Edition — Сеть
ISA Server 2006 Standard Edition — Руководство по установке > ISA Server Standard Edition — Перед началом работы >

Внесите в следующие таблицы информацию о платах внешней сети, внутренней сети и демилитаризованной зоны (также известной как DMZ и экранированная подсеть).

Плата внешней сети

Внесите в следующую таблицу данные о плате внешней сети.

Свойство | Значение | Свойство | Значение
IP-адрес | ___.___.___.___ | Маска подсети | ___.___.___.___
Основной шлюз | ___.___.___.___ | Не применимо | Не применимо
Предпочитаемый DNS-сервер | ___.___.___.___ | Альтернативный DNS-сервер | ___.___.___.___

Плата внутренней сети

Внесите в следующую таблицу данные о плате внутренней сети.

Свойство | Значение | Свойство | Значение
IP-адрес | ___.___.___.___ | Маска подсети | ___.___.___.___
Основной шлюз | ___.___.___.___ | Не применимо | Не применимо
Предпочитаемый DNS-сервер | ___.___.___.___ | Альтернативный DNS-сервер | ___.___.___.___

Плата демилитаризованной зоны

Внесите в следующую таблицу данные о плате демилитаризованной зоны.

Свойство | Значение | Свойство | Значение
IP-адрес | ___.___.___.___ | Маска подсети | ___.___.___.___
Основной шлюз | ___.___.___.___ | Не применимо | Не применимо
Предпочитаемый DNS-сервер | ___.___.___.___ | Альтернативный DNS-сервер | ___.___.___.___

Общая информация

Внесите в следующую таблицу информацию о полном доменном имени.

Свойство | Значение | Свойство | Значение
Полное доменное имя | _______________ | Отсутствует | Отсутствует

Обратите внимание на следующее.

  • Если имеется сервер с несколькими сетевыми платами, обычно указывается основной шлюз. На сервере ISA Server основной шлюз, как правило, настраивается на плату внешней сети.

  • При наличии дополнительных внутренних сетей, подключенных через маршрутизатор, прежде чем начинать установку, добавьте требуемые маршруты к серверу ISA Server.

  • Перед установкой сервера ISA Server 2006 необходимо убедиться в правильной настройке маршрутизации.

  • В большинстве случаев DNS-серверы настраиваются на плату внутренней сети и должны указывать на внутренний DNS-сервер. Проверьте корректность разрешения имен.

  • В зависимости от конфигурации можно создать правило доступа, разрешающее DNS-запросы от внутренней сети.

  • Если маршрутизация и разрешение имен работают неправильно, то при установленном сервере ISA Server 2006 возникнут сложности с определением причины проблемы.

Для получения дополнительных сведений см. статьи:

  • "Настройка DNS-серверов для ISA Server" на веб-узле Microsoft TechNet

  • "Коллекция сетей" на веб-узле Microsoft TechNet


ISA Server Standard Edition — Характер трафика

ISA Server Standard Edition — Характер трафика
ISA Server 2006 Standard Edition — Руководство по установке > ISA Server Standard Edition — Перед началом работы >

Перед установкой сервера ISA Server полезно выяснить, какие протоколы требуются для обеспечения связи компьютеров с сетями. Эта информация полезна при проектировании базы правил. Многие приложения начинают обмен данными через один порт, а затем переключаются на другой порт или диапазон портов.

Трафик можно разделить на следующие категории:

  • серверные приложения,

  • пользовательские приложения,

  • приложения управления сетью.


ISA Server Standard Edition — Планирование производительности

ISA Server Standard Edition — Планирование производительности
ISA Server 2006 Standard Edition — Руководство по установке > ISA Server Standard Edition — Перед началом работы >

Минимальные системные требования для Microsoft ISA Server 2006 описаны ранее в разделе ISA Server Standard Edition — Требования установки данного документа. Однако для улучшения производительности при планировании аппаратного обеспечения для ISA Server 2006 и скорости подключения к Интернету необходимо учитывать ожидаемую нагрузку. При определении аппаратного обеспечения компьютера ISA Server следует ответить на приведенные ниже вопросы.

  • Сколько процессоров и какого типа требуется?

  • Сколько ОЗУ и пространства на диске необходимо и сколько требуется сетевых плат?

  • Какова рекомендованная пропускная способность подключения к Интернету?

Ответы на эти вопросы зависят от конкретных потребностей конфигурации безопасности и сценария развертывания. Особенно на рекомендации к аппаратному обеспечению влияют следующие факторы: конфигурация политики межсетевого экрана, требования к ведению журналов, суммарная пиковая пропускная способность сети, публикуются серверы или просто разрешен доступ к Интернету. Из них суммарная пиковая пропускная способность подключения к Интернету является наиболее важным фактором при определении вычислительных ресурсов, так как в большинстве случаев этот фактор представляет потребности в подключении к Интернету.

В следующей таблице представлены общие рекомендации в зависимости от пропускной способности используемого подключения к Интернету. Следует отметить, что перечисленные здесь рекомендации предполагают наличие веб-трафика и политики с несколькими сотнями правил. Кроме того, не предполагается использование особых конфигураций, таких как кэширование или фильтры сторонних производителей. При использовании кэширования может быть достаточно подключения к Интернету с пропускной способностью, меньшей на 20-30%. Более того, если клиенты настраиваются на использование прокси, то можно ожидать удвоения пропускной способности при тех же конфигурациях аппаратного обеспечения.

Пропускная способность подключения к Интернету До 7,5 Мбит/с или 5 T1 До 25 Мбит/с До 45 Мбит/с или T3 Примечания

Процессоры

1

1

2

Тип процессора

Pentium III 550 МГц (или выше)

Pentium 4 2,0-3,0 ГГц

Xeon 2,0-3,0 ГГц

В качестве альтернативы можно использовать другие процессоры сравнимой мощности, эмулирующие набор команд IA-32.

В развертываниях, в которых требуется только фильтрация с проверкой с отслеживанием состояния соединений (без фильтрации на более высоком уровне приложений), рекомендованные процессоры Pentium 4 и Xeon обеспечивают необходимую скорость подключений локальной сети.

Память

256 МБ

512 МБ

1 ГБ

При использовании веб-кэширования эти требования могут быть выше.

Пространство на диске

150 МБ

2,5 ГБ

5 ГБ

Этот объем жесткого диска планируется использовать исключительно для ведения журналов.

Сетевая плата

10/100 Мбит/с

10/100 Мбит/с

100/1000 Мбит/с

Это требования для сетевых плат, не подключенных к Интернету.

Дополнительную информацию см. в разделе "Практические рекомендации по обеспечению производительности сервера ISA Server" на веб-узле Microsoft TechNet.


ISA Server Standard Edition — Процесс установки

ISA Server Standard Edition — Процесс установки
ISA Server 2006 Standard Edition — Руководство по установке > ISA Server Standard Edition — Перед началом работы >

Перед установкой сервера ISA Server 2006 просмотрите ISA Server Standard Edition — Требования установки.

При установке сервера ISA Server предлагается ввести следующую информацию.

  • Ключ компакт-диска. Это 25-разрядный номер, указанный на обратной стороне коробки компакт-диска ISA Server.

  • Варианты установки. Можно выбрать один из следующих.

    • Полная установка. Устанавливаются все компоненты.

    • Выборочная установка. Можно выбрать устанавливаемые компоненты.

  • Конфигурация внутренней сети. Необходимо настроить диапазоны адресов, которые должны быть включены во внутреннюю сеть. Дополнительные сведения о внутренней сети см. в документации по продукту.

    Важно:
    Так как внутренняя сеть должна включать в себя IP-адрес, определенный в подключенной и действующей сетевой плате, можно пропустить страницу установки внутренней сети только в том случае, если плата внутренней сети подключена, включена и ей назначен правильный IP-адрес.

  • В процессе установки сервер ISA Server изменяет динамический диапазон портов драйвера TCP/IP, задавая значение 65535.

Остановка и отключение служб

В процессе установки отключаются следующие службы:

  • брандмауэр подключения к Интернету или общий доступ к подключению Интернета

  • преобразование сетевых IP-адресов (NAT)

Кроме того, на время установки останавливаются следующие службы:

  • служба SNMP,

  • служба FTP-публикации,

  • протокол NNTP (Network News Transfer Protocol),

  • служба IIS Admin,

  • служба веб-публикации.


ISA Server Standard Edition — Процедуры установки

ISA Server Standard Edition — Процедуры установки

Используйте следующую процедуру для установки ISA Server 2006 Standard Edition.

Примечание:
Не устанавливайте ISA Server 2006 Standard Edition через RDP-подключение, если при этом используется преобразование сетевых адресов (NAT). После завершения установки ISA Server RDP-подключение будет прервано без предоставления возможности установления нового RDP-подключения в будущем.

Установка сервера ISA Server 2006 Standard Edition

  1. Вставьте компакт-диск ISA Server в дисковод или запустите программу ISAAutorun.exe с общего сетевого диска.

  2. В программе установки Microsoft ISA Server щелкните Установить ISA Server 2006 и воспользуйтесь мастером для установки ISA Server 2006 (см. ниже таблицу).

    Страница Поле или свойство Параметр

    Приветствие

    Отсутствует

    Нажмите кнопку Далее.

    Лицензионное соглашение

    Лицензионное соглашение

    Выберите Принимаю условия лицензионного соглашения.

    Сведения о пользователе

    Имя пользователя

    Организация

    Серийный номер продукта

    Введите имя пользователя.

    Введите название организации.

    Введите серийный номер продукта.

    Тип установки

    Выберите тип установки.

    Обычная Устанавливается сервер ISA Server, компонент "Подробный журнал" и диспетчер ISA Server.

    Выборочная Позволяет выбрать устанавливаемые компоненты.

    Выберите Выборочная и щелкните Далее, чтобы выбрать компоненты.

    Выбор компонентов

    Просмотрите устанавливаемые компоненты. Обратите внимание, что при этом также устанавливается диспетчер ISA Server.

    Нажмите кнопку Далее.

    Внутренняя сеть

    Определите внутренние сети.

    Об определении внутренних сетей см. в ISA Server Enterprise Edition — Приложение А. "Добавление адресов во внутреннюю сеть"

    Нажмите кнопку Добавить, чтобы указать диапазон сетевых адресов.

    Нажмите кнопку Добавить плату.

    Выберите одну или несколько плат, которые подключаются к внутренней сети. Эти адреса будут включены во внутренняя сеть, которая по умолчанию определена для сервера ISA Server.

    Нажмите кнопку ОК, затем еще раз ОК и Далее.

    Подключения клиентов межсетевого экрана

    Выберите, требуется ли разрешать незашифрованные соединения между клиентами межсетевого экрана и данным компьютером ISA Server.

    Убедитесь в том, что флажок Разрешить незашифрованные подключения клиентов межсетевого экрана не установлен. Нажмите кнопку Далее.

    Сообщения предупреждения служб

    Просмотрите службы, которые будут остановлены или отключены, если продолжить.

    Нажмите кнопку Далее.

    Все готово для установки программы

    Отсутствует.

    Нажмите кнопку Установить.

  3. Чтобы немедленно запустить диспетчер ISA Server после завершения установки, установите флажок Вызвать диспетчер ISA Server, а затем нажмите кнопку Готово.

    Примечание:
    Программа установки ISA Server отключает брандмауэр подключения к Интернету. В случае запуска анализатора безопасности Microsoft Baseline Security Analyzer после установки ISA Server 2006 Standard Edition можно проигнорировать следующее сообщение: Брандмауэр Windows — брандмауэр Windows не установлен, настроен неправильно или недоступен в данной версии Windows.


ISA Server Standard Edition — Установка диспетчера ISA Server

ISA Server Standard Edition — Установка диспетчера ISA Server
ISA Server 2006 Standard Edition — Руководство по установке >

Сервер ISA Server 2006 управляется с помощью оснастки управления диспетчера ISA Server. Между компьютером ISA Server и компьютером с запущенной программой управления ISA Server должно быть установлено надежное, быстрое подключение, чтобы диспетчер ISA Server мог быстро отвечать, отображая обновленные сведения о конфигурации.

Если скорость подключения к компьютеру ISA Server меньше 5 Мбит/с, то рекомендуется подключиться к компьютеру ISA Server через RDP-подключение и запустить на нем диспетчер ISA Server.

Требования для работы диспетчера ISA Server

Для использования диспетчера ISA Server требуется следующее:

  • операционная система Microsoft Windows Server 2003 SP1 или Microsoft Windows Server 2003 R2;

  • операционная система Microsoft Windows® XP SP1 или Microsoft Windows XP SP2;

    Обратите внимание на следующее.

    • Сервер ISA Server 2006 невозможно установить на 64-разрядных версиях операционных систем Windows Server 2003 и Windows XP.

    • Диспетчер ISA Server невозможно установить в операционной системе Microsoft Windows Server 2003, Web Edition.

  • не менее 256 МБ памяти.

Установка диспетчера ISA Server

Диспетчер ISA Server устанавливается по умолчанию при установке сервера ISA Server Standard Edition.

Чтобы установить диспетчер ISA Server, выполните приведенную ниже процедуру.

Установка диспетчера ISA Server

  1. Вставьте компакт-диск ISA Server в дисковод или запустите программу ISAAutorun.exe с общего сетевого диска.

  2. В Программе установки Microsoft ISA Server щелкните Установить ISA Server 2006. Используйте этот мастер для создания массива серверов ISA Server 2006 в соответствии с приведенной ниже таблицей.

    Страница Поле или свойство Параметр

    Приветствие

    Отсутствует

    Нажмите кнопку Далее.

    Лицензионное соглашение

    Лицензионное соглашение

    Выберите Принимаю условия лицензионного соглашения.

    Сведения о пользователе

    Имя пользователя

    Организация

    Серийный номер продукта

    Введите имя пользователя.

    Введите название организации.

    Введите серийный номер продукта.

    Тип установки

    Выберите тип установки.

    Выберите Выборочная.

    Выборочная установка

    Выберите компоненты программы для установки.
    • Нажмите кнопку ISA Server, а затем — Этот компонент будет недоступен.

    • Щелкните Диспетчер ISA Server, а затем щелкните пункт Этот компонент будет установлен на локальный жесткий диск.

    • Нажмите кнопку Далее.

    Все готово для установки программы

    Отсутствует

    Нажмите кнопку Установить.

  3. После завершения установки выберите Вызвать диспетчер ISA Server, чтобы запустить оснастку управления диспетчера ISA Server, а затем нажмите кнопку Готово.


ISA Server Standard Edition — Дополнительные сведения

ISA Server Standard Edition — Дополнительные сведения

После установки ISA Server 2006 посетите веб-узел с рекомендациями для ISA Server, где можно найти информацию на следующие темы:

  • Планирование, развертывание и интеграция

  • Конфигурирование и администрирование

  • Публикация

  • Клиенты и проверка подлинности

  • Виртуальная частная сеть

  • Область кодирования


ISA Server Standard Edition — Удаление программного обеспечения ISA Server

ISA Server Standard Edition — Удаление программного обеспечения ISA Server
ISA Server 2006 Standard Edition — Руководство по установке >

Чтобы установить удалить ISA Server 2006, выполните приведенную ниже процедуру.

Удаление сервера ISA Server

  1. Нажмите кнопку Пуск, выберите Панель управления, а затем дважды щелкните Установка и удаление программ.

  2. В Microsoft ISA Server 2006 щелкните Заменить/Удалить.

  3. На странице приветствия щелкните Далее.

  4. На странице Обслуживание программ выберите Удалить.

  5. Страница Удаление созданных файлов

    • Щелкните Не удалять файлы журналов Microsoft ISA Server 2006, чтобы сохранить файлы журналов.

    • Выберите Не удалять файлы Microsoft ISA Server 2006, чтобы сохранить файлы кэша.

  6. Нажмите кнопку Удалить, чтобы удалить ISA Server 2006 с компьютера.

  7. Нажмите кнопку Готово, чтобы завершить работу мастера после завершения процесса удаления.

Обратите внимание на следующее.

  • Приложения наблюдения, такие как агент Microsoft Operations Manager (MOM), используют файлы сервера ISA Server и могут влиять на установку и удаление ISA Server. Во избежание проблем завершите работу этих приложений, прежде чем предпринимать какие-либо из описанных ниже действий.

    • Восстановить или изменить

    • Удалить

    • Установить или удалить пакет обновления или исправление

    • Обновить

  • Перед удалением сервера ISA Server диспетчер ISA Server и системный монитор ISA Server должны быть закрыты.

  • При настройке сервера ISA Server некоторые параметры маршрутизации и удаленного доступа могут измениться. При удалении сервера ISA Server конфигурация маршрутизации и удаленного доступа реконфигурируется следующим образом.

    • Служба маршрутизации и удаленного доступа отключена.

    • Политика удаленного доступа, настроенная сервером ISA Server, удалена.

    • Для службы маршрутизации и удаленного доступа восстановлены параметры по умолчанию, после чего служба отключается. Для настройки маршрутизации и удаленного доступа используйте мастер настройки и включения службы маршрутизации и удаленного доступа, доступный из оснастки маршрутизации и удаленного доступа.


ISA Server Standard Edition — Приложение А. "Добавление адресов во внутреннюю сеть"

ISA Server Standard Edition — Приложение А. "Добавление адресов во внутреннюю сеть"
ISA Server 2006 Standard Edition — Руководство по установке >

Чтобы добавить адреса во внутреннюю сеть, на странице Внутренняя сеть можно использовать следующие команды.

  • Добавить диапазон Позволяет добавить диапазон IP-адресов. Необходимо указать начало и конец диапазона IP-адресов, например, 10.0.0.1 – 10.0.0.255.

  • Добавить плату Позволяет выбрать сетевую плату. Адреса, включаемые во внутреннюю сеть, будут основаны на IP-адресе и маске подсети выбранной платы.

  • Добавить частный Позволяет добавлять адреса, определенные как адреса без маршрутизации на основании RFC 1918 и функции автоматического назначения частных IP-адресов. Дополнительные сведения о частных адресах см. в следующих источниках:

    • "RFC1918" на веб-узле rfc.net

    • "Использование автоматической TCP/IP-адресации без DHCP-сервера" в центре справки и поддержки Microsoft

      В следующей таблице приведены диапазоны адресов на основе RFC 1918 или функции автоматического назначения частных IP-адресов (APIPA).

      Диапазон адресов RFC 1918 или APIPA

      10.0.0.0–10.255.255.255

      RFC 1918

      172.16.0.0–172.31.255.255

      RFC 1918

      192.168.0.0–192.168.255.255

      RFC 1918

      169.254.0.0–169.254.255.255

      APIPA
      Примечание:
      Следующий диапазон адресов нельзя добавить к внутренней сети, так как так как по умолчанию он назначается сети локального узла: 127.0.0.1–127.255.255.255.


ISA Server Standard Edition — Приложение Б. "Ключи установки"

ISA Server Standard Edition — Приложение Б. "Ключи установки"
ISA Server 2006 Standard Edition — Руководство по установке >

При запуске установки из командной строки можно изменить набор устанавливаемых компонентов, предоставить требуемые данные об установке или восстановить установку.

Установка сервера ISA Server

  • Чтобы изменить компоненты, устанавливаемые во время установки, в командной строке введите команду: PathToISASetup\Setup.exe ADDLOCAL=FeatureToInstall.

  • Чтобы восстановить установку из командной строки, введите в командной строке команду: PathToISASetup\Setup.exe REINSTALL=ALL.

Полный список параметров и значений см. в таблице из ISA Server Standard Edition — Приложение В "Автоматическая установка"


ISA Server Standard Edition — Приложение В "Автоматическая установка"

ISA Server Standard Edition — Приложение В "Автоматическая установка"
ISA Server 2006 Standard Edition — Руководство по установке >

ISA Server 2006 Standard Edition можно установить с помощью автоматической установки сервера.

Автоматическая установка сервера ISA Server

  1. Измените данный образец файла ответов, который можно найти на компакт-диске ISA Server. Описание этого экземпляра файла ответов см. в таблице, представленной ниже в данном разделе.

  2. В командной строке введите следующую команду:

PathToISASetup \Setup.exe /V" /q[b|n] FULLPATHANSWERFILE=\" PathToINIFile \ INI_filename \"".

Параметры

PathToISASetup

Путь к установочным файлам сервера ISA Server 2006. Этот путь может указывать на компакт-диск ISA Server или общую сетевую папку, содержащую файлы сервера ISA Server.

INI_filename

Имя файла ответов.

/q [b|n]

Выполняется автоматическая установка без вывода сообщений. Если указать b, то процесс установки отображается на индикаторе выполнения. Если указать n, то диалоговые окна не отображаются. Сообщения об ошибках сохраняются в файл журнала установки.

PathToINIFile

Путь к папке с информацией об автоматической установке.

Обратите внимание на следующее.

  • Для выполнения этой процедуры необходимо быть членом группы локальных администраторов.

  • Например, команда CD\FPC\setup.exe /v" /qn FULLPATHANSWERFILE=\"C:\InstallStandaloneServer.ini\"" вызывает автоматическую установку компьютера с запущенными службами ISA Server и сервером хранилища настроек, использующим файл InstallStandaloneServer.ini, расположенный в c:\.

Компонент Microsoft SQL Server 2000 Desktop Engine (MSDE 2000), требуемый для выполнения многих функций наблюдения, неправильно установлен при удаленной установке сервера ISA Server с помощью служб терминалов в режиме сервера приложений. Для правильной установки компонента MSDE 2000 службы терминалов необходимо использовать в режиме администрирования.

Файл Msisaund.ini содержит сведения о конфигурации, которые можно использовать при установке сервера в автоматическом режиме. Его можно найти в папке FPC\Unattended_Setup_Sample\Standard_Edition\ на компакт-диске ISA Server.

В следующей таблице описываются записи и значения в файлах конфигурации. Если в данном файле значение не указано, значить используется значение по умолчанию.

Запись | Описание | Обязательный или необязательный
ADDLOCAL= {MSFirewall_Management}, {MSFirewall_Services},{MSDE}, | Укажите список компонентов (разделенных запятыми), которые должны быть установлены на компьютере. Чтобы установить все компоненты, задайте ADDLOCAL=ALL. По умолчанию: ВСЕ | Необязательный
COMPANYNAME=Имя_компании | Указывает имя компании, устанавливающей данный продукт. | Необязательный
DONOTDELLOGS = {0|1} | Если задано значение 1, файлы журналов на данном компьютере не удаляются. По умолчанию: 0. | Необязателен при удалении.
DONOTDELCACHE = {0|1} | Если задано значение 1, файлы кэша на данном компьютере не удаляются. По умолчанию: 0. | Необязателен при удалении.
InstallDir={install_directory} | Указывает директорию установки ISA Server. Если не указан, по умолчанию используется первый диск, имеющий достаточно места. Синтаксис: Диск:\Папка Папка по умолчанию: %Program Files%\Microsoft ISA Server. | Необязательный
PIDKEY | Указывает ключ продукта. Это 25-разрядный номер, указанный на обратной стороне коробки компакт-диска ISA Server. | Обязательный
REMOVE={MSFirewall_Management}, {MSFirewall_Services},{MSDE} | Укажите список компонентов (разделенных запятыми), которые должны быть удалены с компьютера. Чтобы удалить все компоненты, задайте REMOVE=ALL. | Необязательный
SUPPORT_EARLIER_CLIENTS | Указывает, могут ли клиенты, использующие предыдущие версии клиента межсетевого экрана или операционной системы, подключаться к данному массиву ISA Server. Возможные значения: 0 (по умолчанию) или 1. | Необязательный
INTERNALNETRANGES | Указывает диапазон IP-адресов во внутренней сети. Необходимо указать хотя бы один IP-адрес, иначе автоматическая установка будет прервана. Синтаксис: N From1-To1,From2-To2,... FromN-ToN Здесь N — номер диапазона, а FromI-ToI — начальный и конечный адреса в каждом диапазоне. Пример добавления трех диапазонов адресов: INTERNALNETRANGES=3 10.0.0.0-10.255.255.255,172.16.0.0-172.31.255.255,192.168.0.0-192.168.255.255. | Обязательный


ISA Server Standard Edition — Приложение Г "Файл журнала установки ISA Server"

ISA Server Standard Edition — Приложение Г "Файл журнала установки ISA Server"
ISA Server 2006 Standard Edition — Руководство по установке >

При установке сервера ISA Server 2006 программа установки автоматически создает журнальные файлы, которые содержат подробные сведения об установке. Информация в файле журнала установки ISA Server 2006 основана на ведении журналов установщиком Windows. Установщик Windows регистрирует ошибки, возникающие в процессе работы программы установки ISA Server 2006. Установщик Windows также регистрирует и другую информацию. Для просмотра журнальных файлов можно воспользоваться программой "Блокнот". Информация, записываемая установщиком в эти журнальные файлы, может помочь администратору в устранении проблем неудачной установки.

При установке сервера ISA Server 2006 в папке %winddir%\temp создаются файлы журналов, перечисленные в следующей таблице.

Файл журнала | Описание
ISAWRAP_NNN.log | В файле журнала упаковщика установки регистрируется общие сведения об успешной или неудачной установке межсетевого экрана и Microsoft SQL Server Desktop Engine (MSDE).
ISAFWSV_NNN.log | В файле журнала установки службы межсетевого экрана регистрируются события и ошибки, связанные с конфигурацией установки ISA Server 2006.
ISAMSDE_NNN.log | В файле журнала установки базы данных ISA Server 2006 регистрируются события и ошибки, связанные с MSDE.
ISAFWUI_NNN.log | В MSI-файлах журнала последовательности пользовательского интерфейса регистрируются события и ошибки, связанные с конфигурацией установки ISA Server 2006.
Примечание:
Где NNN — уникальный трехзначный идентификатор установки.

Все файлы журналов установки ISA Server 2006 имеют одинаковый уникальный трехзначный идентификатор установки, указывающий на соответствующую попытку установки. При каждой установке или удалении сервера ISA Server 2006 создаются новые файлы журналов с одинаковым трехзначным идентификатором. Для просмотра таких файлов журналов, выполните приведенную ниже процедуру.

Просмотр файлов журналов установки ISA Server

  1. С помощью проводника Windows Explorer откройте папку %windir%\temp.

  2. Правой кнопкой мыши щелкните нужный файл, а затем — Открыть с.

  3. В диалоговом окне Открыть с щелкните Блокнот, а затем — ОК.

  4. Повторите действия 2 и 3, чтобы просмотреть остальные журналы.


ISA Server Standard Edition — Приложение Д "Устранение неполадок установки"

ISA Server Standard Edition — Приложение Д "Устранение неполадок установки"
ISA Server 2006 Standard Edition — Руководство по установке >

Дополнительные сведения о распространенных проблемах, возникающих при установке сервера ISA Server 2006 Standard Edition, см. в разделе об устранении неполадок при установке на веб-узле Microsoft TechNet.