Administrator utilities

The following lists the available Windows-based administrator utilities.

  • mapadmin
  • nfsadmin
  • nfsshare
  • nfsstat
  • rpcinfo
  • sfuadmin
  • showmount


mapadmin

NAME

mapadmin - Windows command-line utility to manage User Name Mapping

SYNOPSIS

mapadmin [server] [-u usr [-p pword]]
mapadmin [server] [-u usr [-p pword]] {start | stop}
mapadmin [server] [-u usr [-p pword]] config [option...]
mapadmin [server] [-u usr [-p pword]] add -wu WindowsUser
         -uu UNIXUser [-setprimary]
mapadmin [server] [-u usr [-p pword]] add -wg WindowsGroup
         -ug UNIXGroup [-setprimary]
mapadmin [server] [-u usr [-p pword]] setprimary -wu WindowsUser
         [-uu UNIXUser]
mapadmin [server] [-u usr [-p pword]] setprimary -wg WindowsGroup
         [-ug UNIXGroup]
mapadmin [server] [-u usr [-p pword]] delete option[...]
mapadmin [server] [-u usr [-p pword]] list option[...]
mapadmin [server] [-u usr [-p pword]] backup filename
mapadmin [server] [-u usr [-p pword]] restore filename
mapadmin [server] [-u usr [-p pword]] adddomainmap -d WindowsDomain
         {-y NISDomain [-n nisServer] | -f path}
mapadmin [server] [-u usr [-p pword]] removedomainmap
         -d WindowsDomain -y NISDomain
mapadmin [server] [-u usr [-p pword]] removedomainmap -all
mapadmin [server] [-u usr [-p pword]] listdomainmaps

DESCRIPTION

The mapadmin Windows command-line utility administers User Name Mapping. If you are logged on with an account that does not have the privileges required to administer User Name Mapping on the computer, you can specify a user name and password of an account that does.

In addition to specific command arguments, mapadmin accepts the following arguments and options:

server
Specifies the remote computer you want to administer.
-u usr
Specifies the user name of the user whose credentials are to be used. It might be necessary to add the domain name to the user name in the form domain\username.
-p pword
Specifies the password of the user. If you specify the -u option but omit the -p option, you are prompted for the user's password.

The specific action that mapadmin performs depends on the command argument you specify:

start
Starts the User Name Mapping service.
stop
Stops the User Name Mapping service.
config
Specifies general settings for User Name Mapping. The following options are available with this command argument:
-d domain
Specifies the Windows domain name to be used for simple mapping. Although this option continues to be supported for the sake of compatibility with earlier version, you should use adddomainmap instead.
-y nisDomain
Specifies the Network Information Service (NIS) domain to be used for simple mapping. Although this option continues to be supported for the sake of compatibility with earlier version, you should use adddomainmap instead. The following option is available with this option:
-n nisServer
Specifies the NIS server for the NIS domain specified with the -y option.
-r dddd:hh:mm
Specifies the refresh interval for updating from the Windows and NIS databases in days, hours, and minutes. The minimum interval is 5 minutes.
-f path
Specifies the path where PCNFS passwd and group files are located.
-i yes | no
Turns simple mapping on (yes) or off (no). By default, simple mapping is on.
add
Creates a new mapping for a user or group. The following options are available with this command argument:
-wu name
Specifies the name of the Windows user for which a new mapping is being created.
-uu name
Specifies the name of the UNIX user for which a new mapping is being created.
-wg group
Specifies the name of the Windows group for which a new mapping is being created.
-ug group
Specifies the name of the UNIX group for which a new mapping is being created.
-setprimary
Specifies that the new mapping is the primary mapping.
setprimary
Specifies which mapping is the primary mapping for a UNIX user or group with multiple mappings. The following options are available with this command argument:
-wu name
Specifies the Windows user of the primary mapping. If more than one mapping for the user exists, use the -uu option to specify the primary mapping.
-uu name
Specifies the UNIX user of the primary mapping.
-wg group
Specifies the Windows group of the primary mapping. If more than one mapping for the group exists, use the -ug option to specify the primary mapping.
-ug group
Specifies the UNIX group of the primary mapping.
delete
Removes the mapping for a user or group. The following options are available for this command argument:
-wu user
The Windows user for whom the mapping will be deleted, specified as WindowsDomain\UserName. You must specify either the -wu or the -uu option, or both. If you specify both options, the particular mapping identified by the two options will be deleted. If you specify only the -wu option, all mappings for the specified user will be deleted.
-wg group
The Windows group for which the mapping will be deleted, specified as WindowsDomain\GroupName. You must specify either the -wg or the -ug option, or both. If you specify both options, the particular mapping identified by the two options will be deleted. If you specify only the -wg option, all mappings for the specified group will be deleted.
-uu user
The UNIX user for whom the mapping will be deleted, specified as UserName. You must specify either the -wu or the -uu option, or both. If you specify both options, the particular mapping identified by the two options will be deleted. If you specify only the -uu option, all mappings for the specified user will be deleted.
-ug group
The UNIX group for which the mapping will be deleted, specified as GroupName. You must specify either the -wg or the -ug option, or both. If you specify both options, the particular mapping identified by the two options will be deleted. If you specify only the -ug option, all mappings for the specified group will be deleted.
list
Displays information about user and group mappings. The following options are available with this command argument:
-all
Lists both simple and advanced mappings for users and groups.
-simple
Lists all simple mapped users and groups.
-advanced
Lists all advanced mapped users and groups. Maps are listed in the order in which they are evaluated. Primary maps, marked with an asterisk (*), are listed first, followed by secondary maps, which are marked with a carat (^).
-wu name
Lists the mapping for a specified Windows user.
-wg group
Lists the mapping for a Windows group.
-uu name
Lists the mapping for a UNIX user.
-ug group
Lists the mapping for a UNIX group.
backup
Saves User Name Mapping configuration and mapping data to the file specified by filename.
restore
Replaces configuration and mapping data with data from the file (specified by filename) that was created using the backup command argument.
adddomainmap
Adds a simple map between a Windows domain and an NIS domain or PCNFS passwd and group files. The following options are available for this command argument:
-d WindowsDomain
Specifies the Windows domain to be mapped.
-y NISDomain
Specifies the NIS domain to be mapped.
-n nisServer
Specifies the NIS server for the NIS domain specified with the -y option.
-f path
Specifies the fully qualified path of directory containing the PCNFS passwd and group files to be mapped. The files must be located on the computer being managed, and you cannot use mapadmin to manage a remote computer to set up maps for PCNFS users and groups.
removedomainmap
Removes a simple map between a Windows domain and an NIS domain. The following options and argument are available for this command argument:
-d WindowsDomain
Specifies the Windows domain of the map to be removed.
-y NISDomain
Specifies the NIS domain of the map to be removed.
-all
Specifies that all simple maps between Windows and NIS domains are to be removed. This will also remove any simple map between a Windows domain and PCNFS passwd and group files.
listdomainmaps
Lists the Windows domains that are mapped to NIS domains or PCNFS passwd and group files.

If you do not specify a command argument, mapadmin displays the current settings for User Name Mapping.

For all options that specify a user or group name, the following formats can be used:

  • For Windows users, use the form domain\username, \\computer\username, \computer\username, or computer\username
  • For Windows groups, use the form domain\groupname, \\computer\groupname, \computer\groupname, or computer\groupname
  • For UNIX users, use the form NISdomain\username, username@NISdomain, PCNFS@username, or PCNFS\username
  • For UNIX groups, use the form NISdomain\groupname, groupname@NISdomain, PCNFS@groupname, or PCNFS\groupname

Common options

The following options and arguments can be used with any subcommand:

server
Specifies the remote computer you want to administer.
-u usr
Specifies the user name of the user whose credentials are to be used. It might be necessary to add the domain name to the user name in the form domain\username.
-p pword
Specifies the password of the user. If you specify the -u option but omit the -p option, you are prompted for the user's password.

SEE ALSO

User Name Mapping


nfsadmin

NAME

nfsadmin - Windows command-line utility to manage Server for NFS

SYNOPSIS

nfsadmin server [computer] [-u user [-p pwd]]
nfsadmin server [computer] [-u user [-p pwd]] -l
nfsadmin server [computer] [-u user [-p pwd]] -r {client | all}
nfsadmin server [computer] [-u user [-p pwd]] { start | stop}
nfsadmin server [computer] [-u user [-p pwd]] config option[...]
nfsadmin server [computer] [-u user [-p pwd]] creategroup name
nfsadmin server [computer] [-u user [-p pwd]] listgroups
nfsadmin server [computer] [-u user [-p pwd]] deletegroup name
nfsadmin server [computer] [-u user [-p pwd]] renamegroup oldname newname
nfsadmin server [computer] [-u user [-p pwd]] addmembers name host[...]
nfsadmin server [computer] [-u user [-p pwd]] listmembers
nfsadmin server [computer] [-u user [-p pwd]] deletemembers group host[...]

DESCRIPTION

The nfsadmin Windows command-line utility administers Server for NFS on the local computer or on a remote computer running Windows Services for Network File System. If you are logged on with an account that does not have the required privileges, you can specify a user name and password of an account that does. The action performed by nfsadmin depends on the command arguments you supply.

computer
Specifies the remote computer you want to administer. You can specify the computer using a Windows Internet Name Service (WINS) name or a Domain Name System (DNS) name, or by Internet Protocol (IP) address.
-u usr
Specifies the user name of the user whose credentials are to be used. It might be necessary to add the domain name to the user name in the form domain\username
-p pwd
Specifies the password of the user specified using the -u option. If you specify the -u option but omit the -p option, you are prompted for the user's password.
-l
Lists all locks held by clients.
-r {client | all}
Releases the locks held by client or, if all is specified, by all clients.
start
Starts the Server for NFS service.
stop
Stops the Server for NFS service.
config
Specifies general settings for Server for NFS. You must supply at least one of the following options with the config command argument:
mapsvr=server
Sets server as the User Name Mapping server for Server for NFS. Although this option continues to be supported for compatibility with previous versions, you should use the sfuadmin utility instead.
auditlocation={eventlog | file | both | none}
Specifies whether events will be audited and where the events will be recorded. One of the following arguments is required.
eventlog
Specifies that audited events will be recorded only in the Event Viewer application log.
file
Specifies that audited events will be recorded only in the file specified by config fname.
both
Specifies that audited events will be recorded in the Event Viewer application log as well as the file specified by config fname.
none
Specifies that events will not be audited.
fname=file
Sets the file specified by file as the audit file. The default is %sfudir%\log\nfssvr.log
fsize==size
Sets size as the maximum size in megabytes of the audit file. The default maximum size is 7 MB.
audit=[+|-]mount [+|-]read [+|-]write [+|-]create [+|-]delete [+|-]locking [+|-]all
Specifies the events to be logged. To start logging an event, type a plus sign (+) before the event name; to stop logging an event, type a minus sign (-) before the event name. If the sign is omitted, the plus sign is assumed. Do not use all with any other event name.
lockperiod=seconds
Specifies the number of seconds that Server for NFS will wait to reclaim locks after a connection to Server for NFS has been lost and then reestablished or after the Server for NFS service has been restarted.
enabletcp={yes | no}
Specifies whether the Transmission Control Protocol (TCP) protocol will be supported. The default setting is yes.
enableV3={yes | no}
Specifies whether NFS version 3 protocols will be supported. The default setting is yes.
renewauth={yes | no}
Specifies whether client connections will be required to be reauthenticated after the period specified by config renewauthinterval. The default setting is no.
renewauthinterval=seconds
Specifies the number of seconds that elapse before a client is forced to be reauthenticated if config renewauth is set to yes. The default value is 600 seconds.
dircache=size
Specifies the size in kilobytes of the directory cache. The number specified as size must be a multiple of 4 between 4 and 128. The default directory-cache size is 128 KB.
translationfile=[file]
Specifies a file containing mapping information for replacing characters in the names of files when moving them from Windows- to UNIX-based file systems. If file is not specified, then file-name character translation is disabled. For more information on file-name character translation and the format of this file, see File-name character translation. If the value of translationfile is changed, you must restart the server for the change to take effect.
dotfileshidden={yes | no}
Specifies whether files that are created with names beginning with a period (.) will be marked as hidden in the Windows file system and consequently hidden from NFS clients. The default setting is no.
casesensitivelookups={yes | no}
Specifies whether directory lookups will be case sensitive (that is, require exact matching of character case. When casesensitivelookups is set to yes (the default), cdfcase, fatcase, and ntfscase are always set to preserve.
cdfscase={lower | upper | preserve}
Specifies whether the case of characters in the names of file in the compact disc file system (CDFS) will be returned in lower case, upper case, or in the form stored in the directory. The default setting is preserve. This setting cannot be changed if casesensitivelookups is set to yes.
fatcase={lower | upper | preserve}
Specifies whether the case of characters in the names of file in the file allocation table (FAT) file system will be returned in lower case, upper case, or in the form stored in the directory. The default setting is preserve. This setting cannot be changed if casesensitivelookups is set to yes.
ntfscase={lower | upper | preserve}
Specifies whether the case of characters in the names of files in the NTFS file system will be returned in lowercase, uppercase, or in the form stored in the directory. The default setting is preserve. This setting cannot be changed if casesensitivelookups is set to yes.
creategroup name
Creates a new client group, giving it the specified name.
listgroups
Displays the names of all client groups.
deletegroup name
Removes the client group specified by name.
renamegroup oldname newname
Changes the name of the client group specified by oldname to newname
addmembers name host[...]
Adds host to the client group specified by name.
listmembers name
Lists the host computers in the client group specified by name.
deletemembers group host[...]
Removes the client specified by host from the client group specified by group.

If you do not specify a command option or argument, nfsadmin server displays the current Server for NFS configuration settings.

SEE ALSO

Server for NFS


nfsshare

NAME

nfsshare - Windows command-line utility to control network file system (NFS) shares

SYNOPSIS

nfsshare [sharename]
nfsshare [-o option=value...] sharename[=drive:path]
nfsshare /delete {sharename | drive:path | * }

DESCRIPTION

Without arguments, the nfsshare Windows command-line utility lists all network file system (NFS) shares exported by Server for NFS. With sharename as the only argument, nfsshare lists the properties of the NFS share identified by sharename. Options supplied with sharename specify properties of the NFS share identified by sharename. When sharename and drive:path are provided, nfsshare exports the folder identified by drive:path as sharename. When the /delete option is used, the specified folder is no longer made available to NFS clients.

OPTIONS

The nfsshare command accepts the following options and arguments:

-o
Sets option to value. The option argument can be one or more of the following:
anon={yes | no}
Specifies whether anonymous (unmapped) users can access the shared directory. The default is no.
anonuid=uid
Specifies that anonymous (unmapped) users will access the share directory using uid as their user identifier (UID). The default is -2. The anonymous UID will be used when reporting the owner of a file owned by an unmapped user, even if anonymous access is disabled.
anongid=gid
Specifies that anonymous (unmapped) users will access the share directory using gid as their group identifier (GID). The default is -2. The anonymous GID will be used when reporting the owner of a file owned by an unmapped user, even if anonymous access is disabled.
encoding={big5|euc-jp|euc-kr|euc-tw|gb2312-80|ksc5601|shift-jis}
Specifies the default encoding used for file and directory names and, if used, must be set to one of the following:
  • big5 (Chinese)
  • euc-jp (Japanese)
  • euc-kr (Korean)
  • euc-tw (Chinese)
  • gb2312-80 (Simplified Chinese)
  • ksc5601 (Korean)
  • shift-jis (Japanese)

If this is option is not set, the default encoding scheme is ANSI or, on systems configured for non-English locales, the default encoding scheme for the locale. The following are the default encoding schemes for the indicated locales:

  • Japanese: SHIFT-JIS
  • Korean: KS_C_5601-1987
  • Simplified Chinese: GB2312-80
  • Traditional Chinese: BIG5

In Windows NT 4.0, if a default encoding scheme other than ANSI is specified, you must have installed the language pack corresponding to the selected encoding scheme, or the command will fail.

{big5|euc-jp|euc-kr|euc-tw|gb2312-80|ksc5601|shift-jis}=host[:host]...
Specifies the file- and directory-name encoding for individual client computers and client groups. See the encoding option for more information.
na
Specifies that no client or group is to be granted access to the NFS share unless it is explicitly granted access.
noroot[=host[:host]...]
Denies root access to the shared directory by the clients or client groups specified by host. Separate client and group names with a colon (:). If host is not specified, root access will be denied by default to all clients and groups for which root access is not explicitly granted. See "Notes" for more information about interactions among option settings when creating a shared directory.
removeclient=host[:host]...
Removes the specified clients from the list of permissions of the shared directory. Separate client and group names with a colon (:).
ro[=host[:host]...]
Provides read-only access to the shared directory by the clients or client groups specified by host. Separate client and group names with a colon (:). If host is not specified, read-only access will be granted by default to all clients and groups for which access is not explicitly granted or denied. When creating a shared directory, if the ro option is set for one or more clients, but the rw option is not set, only the clients specified with the ro option have access to the shared directory. See "Notes" for more information about interactions among option settings when creating a shared directory.
root[=host[:host]...]
Provides root access to the shared directory by the clients or client groups specified by host. Separate client and group names with a colon (:). If host is not specified, root access will be granted by default to all clients and groups for which root access is not explicitly denied. If the root option is not set when a folder is exported, no clients have root access to the shared directory. See "Notes" for more information about interactions among option settings when creating a shared directory.
rw[=host[:host]...]
Provides read-write access to the shared directory by the clients or client groups specified by host. Separate client and group names with a colon (:). If host is not specified, read-write access will be granted by default to all clients and groups for which access is not explicitly granted or denied. When creating a shared directly, if neither the ro nor the rw option is set, all clients have read-only access to the shared directory by default. See "Notes" for more information about interactions among option settings when creating a shared directory.
/delete
If sharename or drive:path is specified, deletes the specified share.

NOTES

  • To view the complete syntax for this command, at a command prompt, type:

    nfsshare /?

  • The default permissions assigned to client computers when creating a shared directory depends on the combination of options used when exporting the folder. The following table shows how these default permissions are set for some combinations when creating a shared directory.
    Options | Permissions
    (None) | All clients: read-only
    -o root | All clients: read-only
    -o noroot | All clients: read-only
    -o ro=host host: read-only
    All other clients: no access
    -o rw=host host: read-write
    All other clients: no access
    -o root=host host: read-write
    All other clients: read-only
    -o noroot=host host: read-write
    All other clients: read-only
    -o root ro=host host: read-only
    All other clients: read-only
    -o noroot ro=host host: read-only
    All other clients: read-only
    -o root rw=host host: read-write
    All other clients: read-only
    -o noroot rw=host host: read-write
    All other clients: read-only
    -o root root=host host: read-write
    All other clients: read-only
    -o noroot noroot=host host: read-write
    All other clients: read-only
    -o rw=host1 root=host2 noroot=host3 host1: read-write
    host2: read-write
    host3: read-write
    All other clients: no access
    -o root=host1 root=host2 noroot=host3 host1: read-write
    host2: read-write
    host3: read-write
    All other clients: no access

    Note that these default settings apply only when creating a new shared directory. When nfsshare is used to modify an existing shared directory, only the specified properties are changed.

SEE ALSO

Share a directory

Stop sharing a directory


nfsstat

NAME

nfsstat - Windows command-line utility to display or reset counts of calls made to Server for NFS

SYNOPSIS

nfsstat [-z]

DESCRIPTION

When used without the -z option, the nfsstat Windows command-line utility displays the number of NFS V2, NFS V3, and Mount V3 calls made to the server since the counters were set to 0, either when the service started or when the counters were reset using nfsstat -z.


rpcinfo

NAME

rpcinfo - Windows command-line utility to list programs on remote computers

SYNOPSIS

List all programs registered with the port mapper:

rpcinfo -p [node]

Request a response from network nodes that have a specified program:

rpcinfo -b program version

Use Transmission Control Protocol (TCP) to call a program:

rpcinfo -t node program [version]

Use User Datagram Protocol (UDP) to call a program:

rpcinfo -u node program [version]

DESCRIPTION

The rpcinfo(1w) Windows utility makes a remote procedure call (RPC) to an RPC server and reports what it finds.

The rpcinfo utility accepts the following options:

-p [node]
Lists all programs registered with the port mapper on the specified host. If you do not specify a node (computer) name, the program queries the port mapper on the local host.
-b program version
Requests a response from all network nodes that have the specified program and version registered with the port mapper. You must specify both a program name or number and a version number.
-t node program [version]
Uses the TCP transport protocol to call the specified program. You must specify both a node (computer) name and a program name. If you do not specify a version, the program calls all versions.
-u node program [version]
Uses the UDP transport protocol to call the specified program. You must specify both a node (computer) name and a program name. If you do not specify a version, the program calls all versions.


sfuadmin

NAME

sfuadmin - Windows command-line utility to manage Microsoft Services for Network File System

SYNOPSIS

sfuadmin [computer] [-u usr [-p pwd]]
sfuadmin [computer] [-u usr [-p pwd]] config option[...]

DESCRIPTION

The sfuadmin Windows command-line utility administers Microsoft Services for Network File System on the local computer or on a remote computer running Microsoft Services for Network File System. If you are logged on with an account that does not have the required privileges, you can specify a user name and password of an account that does. The action performed by sfuadmin depends on the command arguments you supply.

computer
Specifies the remote computer you want to administer. You can specify the computer using a WINS or DNS name, or by Internet Protocol (IP) address.
-u usr
Specifies the user name of the user whose credentials are to be used. It might be necessary to add the domain name to the user name in the form domain\username
-p pwd
Specifies the password of the user specified using the -u option. If you specify the -u option but omit the -p option, you are prompted for the user's password.
config
Specifies general settings for Microsoft Services for Network File System. You must supply at least one of the following options with the config command argument:
mapsvr=server
Sets server as the User Name Mapping server for all Microsoft Services for Network File System components. To specify the computer being administered as the User Name Mapping server, you can specify localhost as server.

If you do not specify a command option or argument, sfuadmin displays the Microsoft Services for Network File System version number and current configuration settings.


showmount

NAME

showmount - Windows command-line utility to display mounted directories

SYNOPSIS

showmount {-e | -a | -d} [server]

DESCRIPTION

The showmount(1w) Windows command-line utility displays information about mounted file systems exported by Server for NFS on the computer specified by server. If server is not provided, showmount displays information about the computer on which the showmount command is run.

You must provide one of the following options:

-e
Displays all file systems exported on the server.
-a
Displays all network file system (NFS) clients and the directories on the server each has mounted.
-d
Displays all directories on the server that are currently mounted by NFS clients.

SEE ALSO

Server for NFS