Супер Калькулятор от LRV

Внимание! Перед использованием калькулятора зайдите в “Панель управления” Windows, далее в “Язык и стандарты” и в свойствах “Числа” в окне “Разделитель целой и дробной части числа” обязательно замените “запятую“ на ”точку”, иначе при вычислении сохраненных выражений данные в окошках ввода будут округляться до целых, независимо от того какой вы используете разделитель.


Супер Калькулятор от LRV

Супер Калькулятор ver 5.0 от LRV

(русская версия)

Это удобный многофункциональный калькулятор выражений. Позволяет одновременно видеть и вычисляемое выражение и результат. Что очень удобно, так как сразу видно какие данные введены и нет ли в них ошибки.

Супер Калькулятор выполняет все основные арифметические действия с числами, поддерживает операции со скобками, позволяет сохранять свои функции.

Возможности Супер Калькулятора:

- вычисление всех тригонометрических функций,

- вычисление гиперболических функций,

- возведение в степень,

- возможность создания и сохранения выражений с переменными и константами,

- построение графика в плоскости,

- сохранение графика в формате рисунка,

- табулирование функций с заданным шагом с возможностью экспорта результата в файл Excel,

- работа с комплексными числами: (перемножение, деление, сложение, вычитание, возведение в степень, перевод из алгебраической формы в показательную и обратно),

- содержит Decimal – Bin – Hex конвертер,

- имеет “умную” функцию округления,

- возможность работы с градусами и радианами,

- исследование участка функции на максимум и минимум,

- поиск корней на участке функции.


Окно программы

Главное окно программы

Главное окно программы состоит из строки ввода выражения (самое верхнее), строки с результатом вычисления, кнопок и переключателей. Что бы узнать о назначении элемента управления программы прочитайте всплывающую подсказку.

Для вычисления выражения введите его с клавиатуры калькулятора. В выражении можно использовать заранее определенные константы и переменные.

При расчетах с углами можно пользоваться градусами или радианами, переключаясь между ними простым нажатием кнопки, при этом введенное выражение автоматически пересчитывается.

Для того чтобы запомнить результат выражения нажмите на кнопку справа от окошка с результатом “=>M” (при этом результат автоматически копируется также в буфер обмена).

Для вывода (добавления) в строку выражения запомненного числа нажмите кнопку “M=>” (всплывающая подсказка сообщит, какое число хранится в памяти).

Окошко "Название формулы" раскрывает выпадающий список с сохраненными ранее выражениями пользователя. Эти выражения автоматически загружаются при запуске программы.

Для вычисления введенного выражения нажмите "Enter" или кнопку калькулятора "="

Для очистки всех окон нажмите "Сброс".

Редактирование строки выражения осуществляется кнопкой "Del", при этом стирается последняя введенная функция или цифра (при удалении знаков * + - / возможно, понадобится нажать"Del" несколько раз).

Примечание: Что бы избежать синтаксических ошибок при создании выражения рекомендуется пользоваться кнопками калькулятора.

Обратите внимание, что надписи на кнопках не всегда соответствуют синтаксису функции (Ln > Log ; Lg > CLg ; Корень > SQR и т.д.)


Создание формулы

В калькуляторе очень просто создавать собственные формулы или функции, которые затем можно сохранить.

Шаг 1.

Нажмите кнопку "Сброс".

В окне "Название формулы" введите имя новой формулы.

Шаг 2.

В окошках столбца "Имя" задайте имена переменных и констант, используемых в вашем выражении. При этом сначала рекомендуется задавать переменные, а потом константы (см. пример axx + bx + c).

Внимание!! Первая буква переменной не должна быть латинской “e” или начинаться с цифры, или с “PI”.

Шаг 3.

Используя кнопки калькулятора, создайте ваше выражение. Для добавления в выражение заданных переменных просто щелкните по их названиям мышкой.

Шаг 4.

Нажмите кнопку "Сохранить". При этом формула добавится в список и сохранится.

Примечание:

При расчете формул перескакивать из окошка в окошко значений переменных можно, используя клавиши клавиатуры “Вверх” “Вниз”.


Окно программы

Построение графика

Прежде чем строить график, выберите функцию из списка “Название формулы”. Затем задайте значения всем переменным и константам.

Нажмите кнопку “График” в главном окне программы. В открывшемся окне в списке “Переменная” выберите нужную переменную (если вы случайно выбрали не ту переменную или хотите построить график относительно другой переменной - закройте окно “График”, а затем откройте его вновь.)

Задайте отрезок Xmin … Xmax и параметр Число точек (по умолчанию Xmin = -10, Xmax = 10, Число точек = 100).

Нажмите кнопку “Построить”. Произойдет прорисовка графика, на что может потребоваться определенное время. Диапазон оси ординат будет подобран автоматически, для того, что бы график уместился полностью.

Затем вы можете:

- установить диапазон оси ординат вручную (Ymin…Ymax)

- для того, чтобы график стал более гладким увеличьте или уменьшите число точек. Максимальное число точек 5000 (обычно вполне достаточно 50-200). Поэкспериментируйте с этим параметром.

- установите желаемую толщину линии графика,

- если вы поставите галочку в окошке “Автоматический подбор сетки”, то сетка подбирается автоматически.

Вы можете сохранить ваш график в формате рисунка. Для этого нажмите кнопку “Сохранить график ”. График сохранится в С:\Grafic.bmp. Размер файла 641 КБ.


Окно программы

Исследование функции от одной переменной

Создайте функцию или выберите ее из списка “Название формулы”. Затем задайте значения всем переменным и константам (значение переменной относительно которой вы хотите исследовать функцию может быть не заданно).

Нажмите кнопку “Исследование функции”, расположенную в меню “Инструменты”. В открывшемся окне в списке “Переменная” выберите нужную переменную (если вы случайно выбрали не ту переменную или хотите исследовать функцию относительно другой переменной - закройте окно “Исследование функции”, а затем откройте его вновь.)

Задайте отрезок Xmin … Xmax на котором вы хотите исследовать функцию.

Выберите одно из трех возможных действий:

- найти корни

- найти минимум

- найти максимум

Примечание:

Если вы выбрали действие “найти корни ” учтите: если корни расположены слишком близко друг к другу (на расстоянии менее 1/1000 от длины Xmin … Xmax) возможна потеря корня, поэтому рекомендуется предварительно исследовать график для наиболее точного определения диапазона с корнями. Если корней слишком много, то ищите их в несколько этапов небольшими отрезками.

Обратите внимание! Если функция не пересекает ось абсцисс, а только касается ее (например, y = x^2), то такой корень следует искать действием “найти минимум” или “найти максимум” в зависимости от того имеет функция здесь минимум или максимум при этом значение функции по оси Y в этой точке должно равняться нулю.

Если вы выбрали действие “найти минимум” или “найти максимум” так же учтите, что программа поделит отрезок Xmin … Xmax на 1000 точек и по значениям функции в этих точках программа найдет точку с минимальным или максимальным значением функции, а затем в окрестностях этой точки будет найдено уточненное значение минимума или максимума. Если функция на заданном отрезке имеет несколько одинаковых максимумов или минимумов, то в ответе будет лишь один из них.

Рекомендуется предварительно исследовать график функции для более наглядного представления о характере функции на данном отрезке.


Окно программы

Табулятор

Предназначен для быстрого поиска значений функции от точки Xmin до точки Xmax через определенный шаг.

Выберите функцию из списка “Название формулы”. Затем задайте значения всем переменным и константам (значение переменной относительно которой вы хотите табулировать функцию может быть не заданно).

Нажмите кнопку “Табулятор”. В открывшемся окне в списке “Переменная” выберите нужную переменную,

задайте отрезок Xmin … Xmax и шаг. Нажмите кнопку “Табулировать”.

Вы можете экспортировать таблицу в файл Excel, нажав соответствующую кнопку. Файл сохранится по адресу: с:\. Tab.xls.

Обратите внимание: что бы избежать слишком большого числа точек вследствие некорректно заданного шага, введено ограничение: максимальное число точек – 5000.


Окно программы

Комплексные числа

Особенностью этого модуля по сравнению с большинством аналогичных программ является то, что для выполнения действия над двумя комплексными числами не нужно предварительно приводить их к одной форме записи (алгебраической или показательной), просто установите флажок напротив числа, если оно в алгебраической форме, или снимите флажок, если оно в показательной форме.

Ответ так же выдается в удобной для Вас форме с возможностью округления. Не забывайте про переключатель “Градусы – Радианы”.


Окно программы

Конвертер чисел

Преобразует числа в десятичную (Decimal), шестнадцатеричную (Hex) и двоичную (Bin) формы. Набирайте число в соответствующем окошке – в остальных происходит автоматическое преобразование.


Окно программы

Использование округления

Посмотрите, как работает эта функция, например, при установке переключателя в положение “5”:

3.84807788509639E-05 > 0.000038481

3.85450363500314E-23 > 3.8545E-23

25943.6777565788 > 25943.67776

54654654656 > 54654654656

Т.е. если модуль числа больше “1”, то функция работает как обычное округление. “5”- означает округление до пятого знака после “запятой”. Если модуль числа меньше “1”, то функция в данном примере показывает только “5” значащих цифр после “запятой”, при этом также происходит округление.

Если Вы не хотите использовать функцию округления, то установите переключатель в положение “S”.


Лицензия на использование и распространение

Данная версия Супер Калькулятора - свободно распространяемая бесплатная программа (Freeware).

Это означает, что:

1. Всеми авторскими правами на Супер Калькулятор обладает

автор программы –Лащилин Роман Владимирович (Las-RomanLRV@yandex.ru).

2. Программа может распространяться свободно в том виде,

в котором она поставляется. Никакие лица или организации

не имеют права брать оплату за распространение Супер Калькулятора

без письменного разрешения держателя авторских прав.

3. Супер Калькулятор ПОСТАВЛЯЕТСЯ ПО ПРИНЦИПУ "AS IS".

НИКАКИХ ГАРАНТИЙ НЕ ПРИЛАГАЕТСЯ И НЕ ПРЕДУСМАТРИВАЕТСЯ.

ВЫ ИСПОЛЬЗУЕТЕ ЭТО ПРОГРАММНОЕ ОБЕСПЕЧЕНИЕ НА СВОЙ РИСК.

АВТОР НЕ БУДЕТ ОТВЕЧАТЬ НИ ЗА КАКИЕ ПОТЕРИ ИЛИ ИСКАЖЕНИЯ

ДАННЫХ, ЛЮБУЮ УПУЩЕННУЮ ВЫГОДУ В ПРОЦЕССЕ ИСПОЛЬЗОВАНИЯ ИЛИ

НЕПРАВИЛЬНОГО ИСПОЛЬЗОВАНИЯ ЭТОГО ПРОГРАММНОГО ОБЕСПЕЧЕНИЯ.

4. Вы не можете эмулировать, клонировать, сдавать в аренду,

давать напрокат, продавать, изменять, декомпилировать,

дизассемблировать Супер Калькулятор. Любое подобное неавторизованное

использование приводит к немедленному и полному прекращению

действия этой лицензии и может преследоваться по закону.

Все права, явно не предоставленные здесь, принадлежат Роману Лащилину.

5. Установка и использование Супер Калькулятора означает, что вы

понимаете положения настоящего лицензионного соглашения

и согласны с ними.

6. Если вы не согласны с условиями данной лицензии, то должны удалить

файлы Супер Калькулятора со своих устройств хранения информации и отказаться

от дальнейшего использования Супер Калькулятора.