ISA Server 2004 SDK Start Page [ISA Server 2004]

Microsoft Internet Security and Acceleration Server 2004 SDK

Purpose

Microsoft Internet Security and Acceleration (ISA) Server 2004 is an extensible platform that integrates firewall and cache features, and routes requests and responses between the Internet and client computers. ISA Server provides filtering to block access to specific sites, and uses network address translation (NAT) and other methods to enable secure access between an intranet and the Internet. This documentation includes information and libraries for developing extensions, administration tools, security applications, and other components that integrate with and build on the ISA Server platform.

Where Applicable

ISA Server includes firewall services, advanced caching capabilities, packet filtering, and alerting. This documentation includes information relevant to developers wanting to extend these features and automate their configuration.

Developer Audience

The information in this documentation for ISA Server is relevant to programmers, system administrators, and tool vendors. To use this documentation, programming experience in the following areas is desirable:

  • Visual C++® or Visual Basic® applications
  • Visual Basic Scripting Edition (VBScript) or JScript®

Run-Time Requirements

Internet Security and Acceleration Server 2004 requires Microsoft Windows® Server 2003 or an operating system from the Windows 2000 Server family.

Overview

General information about ISA Server.

Administration

How to use the ISA Server administration COM objects.

Application Filter Documentation

Describes the Microsoft Firewall service and how to write application filters to extend it.

Web Proxy Documentation

Describes the ISA Server Web proxy and how to write Web filters to extend it.

Extending ISA Server Management

Describes how to extend the ISA Server MMC snap-in.


About this Documentation [ISA Server 2004]

About this Documentation

This section contains important information about the Internet Security and Acceleration Server 2004 SDK documentation, in two topics:

  • Legal Information
  • Using the Header Buttons


Legal Information [ISA Server 2004]

Legal Information

Microsoft Internet Security and Acceleration Server 2004

Information in this document, including URL and other Internet Web site references, is subject to change without notice. Unless otherwise noted, the example companies, organizations, products, people and events depicted herein are fictitious and no association with any real company, organization, product, person or event is intended or should be inferred. Complying with all applicable copyright laws is the responsibility of the user. Without limiting the rights under copyright, no part of this document may be reproduced, stored in or introduced into a retrieval system, or transmitted in any form or by any means (electronic, mechanical, photocopying, recording, or otherwise), or for any purpose, without the express written permission of Microsoft Corporation.

Microsoft may have patents, patent applications, trademarks, copyrights, or other intellectual property rights covering subject matter in this document. Except as expressly provided in any written license agreement from Microsoft, the furnishing of this document does not give you any license to these patents, trademarks, copyrights, or other intellectual property.

© 2004 Microsoft Corporation. All rights reserved.

Microsoft, Windows, Windows NT, Active Directory, ActiveX, DirectX, JScript, MSDN, NetShow, Visual Basic, Visual C++, Visual Studio, and Win32 are either registered trademarks or trademarks of Microsoft Corporation in the United States and/or other countries.

Macintosh is a trademark of Apple Computer, Inc., used under license.

The names of actual companies and products mentioned herein may be the trademarks of their respective owners.


Using the Header Buttons [ISA Server 2004]

Using the Header Buttons

This version of the Internet Security and Acceleration Server 2004 SDK documentation includes the following header and button bar at the top of many of the topics.

The buttons appear only if the related feature is provided in the topic. The buttons indicate the following features.

The topic contains a See Also section.

To view the See Also links without scrolling to that section, click the button.
The topic contains a Requirements section.

To view the Requirements section without scrolling to that section, click the button.
The topic contains paragraphs that are specific to the programming language.

To view all language-specific paragraphs, click the button, then select Show All. To view the paragraphs for one language only, click the button, then select the preferred language (such as C/C++ or Visual Basic).


About Internet Security and Acceleration Server 2004 [ISA Server 2004]

About Internet Security and Acceleration Server 2004

Microsoft® Internet Security and Acceleration (ISA) Server 2004 integrates firewall and cache features to secure networks and improve their performance. ISA Server 2004 is an extensible platform that provides security, efficient use of network resources by means of sophisticated caching mechanisms, and administration tools. ISA Server 2004 runs on computers that use Microsoft Windows® Server 2003 or an operating system from the Windows 2000 Server family, and relies on the features and functionality of these operating systems.

ISA Server consists of several technologies:

  • Microsoft Firewall service.
  • A Web proxy.
  • Secure network address translation (SecureNAT).
  • Advanced caching capabilities, including RAM caching.
  • Dynamic Internet Protocol (IP) packet filtering.
  • Alerting.

For more information, see the ISA Server 2004 product documentation.

This section contains the following topics:

  • What's New in Firewall_Server_Software_Development Kit
  • Installing the ISA Server Software Development Kit
  • ISA Server Overview
  • About Network Configuration Detection
  • About Multi-networking
  • About Virtual Private Networks
  • About the ISA Server Cache
  • About ISA Server Rules
  • About Authentication in ISA Server
  • About ISA Server Services
  • About ISA Server Clients


What's New in ISA Server Software Development Kit [ISA Server 2004]

What's New in ISA Server Software Development Kit

Internet Security and Acceleration (ISA) Server 2004 introduces numerous new features and functionalities. Some of the most notable advancements are described on this page.

Multiple Networking

The ISA Server 2000 networking model included an internal network and multiple external networks, some of which could be configured as a perimeter network (also known as demilitarized zone, DMZ, or screened subnet). ISA Server 2004 supports the configuration of multiple networks with different access policies behind the ISA Server computer, including virtual private networks and perimeter networks in addition to a standard Internal network. For more information see About Multi-networking.

Network Entities

ISA Server 2004 provides a rich set of network objects, including address ranges, computers, computer sets, networks, network sets, and subnets, that can be used to define source and destination settings for policy rules. For example, you can group networks in network sets and define specific policies for them so that when you add a network, you can add the new network to a network set and apply that policy to it. You can use network rules to specify which network entities have a routing relationship between them and which have a network address translation (NAT) relationship.

Cache Rules

ISA Server 2004 features a centralized cache policy under a single administrative node, the cache rule. This is reflected in changes in the administration object hierarchy. For more information, see Introduction to the ISA Server Cache Objects.

Persistence

ISA Server 2004 has a persistence mechanism that allows you to save and reuse array configurations or portions of configurations, such as specific policies. For more information see About Persistence.

Virtual Private Networking

ISA Server 2004 supports secure virtual private network (VPN) access that can connect branch offices or remote users to corporate networks. ISA Server firewall policy is applied to VPN connections to control what resources and protocols VPN users can access. For more information, see About Virtual Private Networks.

Authentication

ISA Server 2004 can authenticate users using built-in Windows authentication methods, predefined authentication schemes that are installed with ISA Server, or third-party authentication schemes that are registered with Web filters. For more information see About Authentication in ISA Server.

Network Configuration Detection Mechanism for Application Filters

ISA Server 2004 provides a Network Configuration Detection (NCD) module, and an NCD programming interface and events for use by application filters. The ISA Server 2004 NCD module continually checks for changes to the network configuration, and sends NCD notifications describing those changes when they occur. Using the NCD mechanism, you can design a filter that reacts appropriately to changes in Network configuration, such as dynamic changes in virtual adapters, the addition of new network adapaters, or the removal or addition of IP addresses to a network. For more information, see About Network Configuration Detection.

Server-side Notifications for Web Filters

ISA Server 2004 provides server-side notifications for Web filters. For more information, see Introduction to Web Filters.


Installing the ISA Server Software Development Kit [ISA Server 2004]

Installing the ISA Server Software Development Kit

The ISA Server Software Development Kit (SDK) provides an installation script that does the following:

  • Copies the SDK files to the directory of your choice.
  • Copies binaries of the ISA Server COM objects and registers them.

The script is called install.cmd, and is located in the SDK directory on the ISA Server CD.

The command to run the script is:

install <source_directory> <target_directory>

where <source_directory> is the directory of the SDK files on the ISA Server CD, and <target_directory> is the directory where you want to install the SDK.

Note The installation script is designed to be executed by Cmd.exe. It may not run correctly under other command processors. Therefore, if you're using another command processor, run cmd /c path \install.cmd.


ISA Server Overview [ISA Server 2004]

ISA Server Overview

Internet Security and Acceleration Server 2004 offers a complete Internet connectivity solution that contains both an organizational firewall and a complete Web cache solution. These services are complementary — you can use either or both of these functions when you install ISA Server in your network.

ISA Server secures your network, allowing you to implement your business security policy by configuring a broad set of rules that specify which sites, protocols, and content can be passed through the ISA Server computer. ISA Server monitors requests and responses between the Internet and internal client computers, controlling who can access which computers on the corporate network. ISA Server also controls which computers on the Internet can be accessed by internal clients.

This section provides basic information regarding the architecture of ISA Server. This information is useful to developers who require a broad view of ISA Server before developing extensions and filters using the ISA Server Software Development Kit (SDK).

This section includes the following topics:

  • Firewall and Security Overview
  • Cache Overview
  • Network View
  • Server View

The last two topics contain detailed diagrams of the network and server views.


Firewall and Security Overview [ISA Server 2004]

Firewall and Security Overview

ISA Server can be deployed as a dedicated firewall that acts as the secure gateway to the Internet for internal clients. ISA Server protects all communication between internal computers and the Internet. In a simple firewall scenario, the ISA Server computer has two network interface cards, one connected to the local network and one connected to the Internet.

You can use ISA Server to configure the firewall, configuring policies and creating rules to implement your business guidelines. By setting the security access policies, you prevent unauthorized access and malicious content from entering the network. You can also restrict what traffic is allowed for each user and group, application, destination, content type, and schedule.

ISA Server includes the following firewall and security features:

  • Outgoing access policy. You can use ISA Server to configure access rules that control how your internal clients access the Internet. Access rules specify which sites and content can be accessed, and which protocols can be used for access.
  • Intrusion detection. Integrated intrusion detection mechanisms can alert you when a specific attack is launched against your network. For example, you can configure the ISA Server to alert you if a port scanning attempt is detected. For more information, see Intrusions and Alerts.
  • Application filters. ISA Server controls application-specific traffic with data-aware filters. ISA Server uses the filters to determine if packets should be accepted, rejected, redirected, or modified. For more information, see Application Filters.
  • Authentication. ISA Server supports the following user authentication methods: Integrated Windows authentication, client certificates, digest, and basic. ISA Server also supports third-party authentication schemes, registered with Web filters. For more information, see About Authentication in ISA Server.


Cache Overview [ISA Server 2004]

Cache Overview

ISA Server implements a cache of frequently-requested objects to improve network performance. You can configure the cache to ensure that it contains the data that is most frequently used by the organization or accessed by your Internet clients.

ISA Server can be used to allow communication between your Internal network and the Internet. Communication may be initiated by internal clients accessing servers on the Internet—in this case, ISA Server implements forward caching. Communication may be initiated by external clients accessing internal, published servers—for this case, ISA Server features reverse caching. Both scenarios can benefit from the ability of ISA Server to cache information, making it more quickly available to users.

ISA Server caching features include:

  • Scheduled caching. You can use the Microsoft® ISA Server Job Scheduler service to configure when the ISA Server computer should fetch commonly requested content from the Internet to its cache.
  • Reverse caching. ISA Server can cache content of published Web servers, thereby improving their performance and accessibility. All ISA Server caching features are applicable for the content on published servers.

For more information about the ISA Server cache, see About the ISA Server Cache.

Forward caching

ISA Server can be deployed as a forward caching server that provides internal clients with access to the Internet. ISA Server maintains a centralized cache of frequently requested Internet objects that can be accessed by any client Web browser. Objects served from the disk cache require significantly less processing than objects served from the Internet. This improves client browser performance, decreases user response time, and reduces bandwidth consumption on your Internet connection.

Reverse caching

ISA Server can be deployed in front of an organization's Web server that is hosting a commercial Web business or providing access to business partners. With incoming Web requests, ISA Server can impersonate the Web server to the outside world, fulfilling client requests for Web content from its cache. ISA Server forwards requests to the Web server only when the requests cannot be served from its cache.


Network View [ISA Server 2004]

Network View

In a classic view of a multi-networking environment, a firewall or router provides connectivity between one or more networks. Depending on how access control is configured on the firewall or router, communication is allowed to pass between the networks. For example, consider the following figure, which illustrates a classic view of the multi-networking scenario.

In the figure, a corporate network is connected to the Internet, allowing clients access to the Internet. A perimeter network (also known as a DMZ, demilitarized zone, or screened subnet) is connected to the corporate network and to the Internet, allowing access to its resources.

The relationships between the networks can be defined as follows:

  • Clients on the corporate network can access the Internet.
  • Computers on the Internet cannot access the corporate network clients.
  • Clients on the corporate network can access resources on the perimeter network.

Clients on the Internet can access resources on the perimeter network.

You can use ISA Server to define network rules (FPCNetworkRule objects), thereby allowing access between the networks. When you do so, you define not only whether the networks are connected, but also how they are connected. In this way, you establish the network access policy between the networks.

The following figure illustrates the concept of network access policy. Here, network rules have been configured to allow network access between the same networks shown in the previous figure.

In other words, network rules define the relationships between the networks as follows:

  • A routing relationship is defined between the branch office and the headquarters. A routing relationship allows traffic between the networks. Routing relationships are bidirectional and do not call for address translation.
  • A network address translation (NAT) relationship is defined from the corporate network to the perimeter network. NAT relationships are unidirectional and unique. Therefore, no relationship can exist from the perimeter network to the corporate network.
  • A NAT relationship is defined from the corporate network to the Internet. Again, no relationship exists from the Internet to the corporate network.
  • Finally, a NAT relationship is defined from the perimeter network to the Internet.

The general guideline is that when you publish IP addresses, you define a routing relationship. If you do not want to expose IP addresses, you define a NAT relationship.

Administrator's Role

The administrator's tasks include establishing ISA Server rules and policies, and configuring the cache. ISA Server rules determine how ISA Server clients communicate with the Internet and the type of communication that is allowed. These rules also determine how servers on your local network communicate with Internet users.

Four items are shown in the network view figure:

  • A remote computer from which an administrator manages ISA Server.
  • An ISA Server computer, whose components are shown in the Server View figure.
  • Clients and servers that use the ISA Server firewall and cache capabilities.

You can programmatically perform or automate ISA Server administration tasks by accessing the ISA Server COM objects. For more information, see ISA Server Administration Scripting.


Server View [ISA Server 2004]

Server View

ISA Server works at various communication layers to protect the corporate network. At the packet layer, ISA Server implements packet filtering. Data then passes to the Firewall and to the Web proxy, where ISA Server rules are processed to determine if the request should be serviced.

The following figure shows in detail the architecture of the ISA Server array.

An ISA Server may be included in an array, to allow for load balancing and fault tolerance. This is described further in the Internet Security and Acceleration Server 2004 product documentation. The following explanation focuses on the architecture of a single ISA Server. The server includes these components:

  • The firewall, consisting of the Microsoft Firewall service, the ISA Server Web proxy, and application filters:
    • IP packet filter.
    • SecureNAT. A function of ISA Server that performs network address translation (NAT) in place of the Windows NAT mechanism. For more information, see Secure Network Address Translation.
    • Web proxy. Includes Web filters and the cache.
    • Firewall service. Handles connect requests sent by Firewall clients and SecureNAT clients. HTTP requests are diverted to the Web proxy.
    • Application filters. Third-party filters can be developed to extend the Firewall service by using the application filter interfaces.

ISA Server also makes use of the bandwidth control of Quality of Service (QoS) in Windows 2000. QoS is a collection of components that manages bandwidth use for a network. ISA Server applies QoS to connections according to rules established by the ISA Server administrator.

As shown in the diagram, ISA Server protects three types of clients:

  • Firewall clients are computers that have the Firewall Client software installed. Requests from Firewall clients are directed to the Firewall service on the ISA Server computer to determine whether access is allowed. Subsequently, the requests can be filtered by application filters and other add-ins. If the Firewall client requests an HTTP object, the Firewall service redirects the request to the Web proxy. The Web proxy may also cache the requested object, or serve the object from the ISA Server cache. For more information on Firewall clients, see Firewall Clients.
  • SecureNAT clients are computers that send requests to the ISA Server computer but do not have the Firewall Client software installed. Requests from SecureNAT clients are directed first to the NAT driver, which substitutes a global IP address that is valid on the Internet for the internal IP address of the SecureNAT client. The client request is then directed to the Firewall service, to determine whether access is allowed. Finally, the request can be filtered by application filters and other add-ins. If the SecureNAT client requests an HTTP object, the Firewall service redirects the request to the Web proxy. The Web proxy may also cache the requested object, or serve the object from the ISA Server cache.
  • Web proxy clients are any browser applications compatible with the standards of Conseil Europeen pour la Recherche Nucleaire (CERN). ISA Server redirects Web requests from clients to the Web proxy on the ISA Server computer to determine whether access is allowed. The Web proxy can also cache the requested object or serve the object from the ISA Server cache.

Note Firewall client and SecureNAT clients are mutually exclusive — that is, a client computer cannot be both a Firewall client and SecureNAT client. However, Firewall client computers and SecureNAT client computers might also be Web proxy clients. If the Web application on the computer is configured explicitly to use the ISA Server, then all Web requests (HTTP, FTP, HTTP-S, and Gopher) are sent directly to the Web proxy. All other requests are handled first by the Firewall service.


About Network Configuration Detection [ISA Server 2004]

About Network Configuration Detection

The Internet Security and Acceleration Server 2004 Network Configuration Detection (NCD) mechanism allows your application filter to react to network configuration changes without restarting a service. It specifically applies to changes related to plug-and-play network devices. The Internet Security and Acceleration Server 2004 NCD mechanism issues notifications of network configuration changes, and application filters can register to receive those notifications. The mechanism also maintains a consistent view of network information in a single location.

For more information on Network Configuration Detection, see Using Network Configuration Detection.


About Multi-networking [ISA Server 2004]

About Multi-networking

ISA Server introduces the concept of multi-networking. You can use the multi-networking features of ISA Server to protect your network against internal and external security threats, by limiting communication between clients even within your own organization. You can group computers in your internal network into network sets, and configure an access policy specific to each network set. You can also define relationships between the various networks, thereby determining how computers on each network communicate with each other, by way of ISA Server..

In a common publishing scenario, you might want to isolate the published servers on their own network, such as a perimeter network (also known as a DMZ, demilitarized zone, or screened subnet). ISA Server's multi-networking functionality supports such a scenario, so that you can configure how clients on the corporate network access the perimeter network, and how external clients access the network. You can configure the relationships between the various networks, defining different access policies between each network.

In the figure, the ISA Server computer connects between the Internet (external network) and the internal network, the corporate network, and the perimeter network. Each network adapter on the ISA Server computer is connected to one of the networks. Using ISA Server, you can configure different access policies between any pair of networks. That is, you can specify whether and how computers on each of the networks communicate with each other. Each network is isolated from the other, and is only made accessible when you configure rules to allow communication between networks.

You can use the multi-networking features of ISA Server to identify, configure, and define the connectivity and relationships between computers, both internal and external to your organization. To configure the multi-networking environment, you identify networks (FPCNetwork objects), optionally grouping them into network sets (FPCNetworkSets collections), and define relationships between the networks.

After you define networks, you create network rules (FPCNetworkRule objects), which determine whether and how the networks are connected. For both NAT and routing relationships, traffic can be permitted by configuring policy rules. Publishing rules can be configured to allow traffic from the destination network to the source network.


About Virtual Private Networks [ISA Server 2004]

About Virtual Private Networks

ISA Server helps you set up and secure a virtual private network (VPN). A VPN is the extension of a private network that encompasses links across shared or public networks like the Internet. With a VPN, you can send data between two computers across a shared or public network in a manner that emulates a point-to-point private link. Virtual private networking is the act of creating and configuring a virtual private network.

To emulate a point-to-point link, data is encapsulated, or wrapped, with a header that provides routing information, which allows the data to traverse the shared or public network to reach its endpoint. To emulate a private link, the data is encrypted for confidentiality. Packets that are intercepted on the shared or public network are indecipherable without the encryption keys. The link in which the private data is encapsulated and encrypted is a VPN connection.

VPN connections allow users who work at home or on the road to obtain a remote access connection to an organization server using the infrastructure provided by a public internetwork such as the Internet. From the user's perspective, the VPN is a point-to-point connection between the computer, the VPN client, and an organization server (the VPN server). The exact infrastructure of the shared or public network is irrelevant, because it appears as if the data is sent over a dedicated private link.

VPN connections also allow organizations to have routed connections with other organizations over a public internetwork such as the Internet while maintaining secure communications, such as offices that are geographically separate. A routed VPN connection across the Internet logically operates as a dedicated wide area network (WAN) link.

Benefits of co-locating VPN functionality on ISA Server

By using the ISA Server computer as the VPN server, you benefit from protecting your corporate network from malicious VPN connections. Because the VPN server is integrated into the firewall functionality, VPN users are subject to the ISA Server access policy. All VPN clients belong to the VPN Clients network; they are allowed access to resources on the internal network, in accordance with a predefined policy.

Furthermore, all VPN connections to the ISA Server are logged to the Firewall log. This offers you more auditing possibilities.

Finally, ISA Server enables VPN clients access using L2TP over IPSec, which is superior from a security standpoint to the standard PPTP protocol favored by VPN servers.

Types of VPN

There are two types of VPN connections:

  • Remote access VPN connection. A remote access client makes a remote access VPN connection that connects to a private network. ISA Server provides access to the entire network to which the VPN server is attached. The packets sent from the remote client across the VPN connection originate at the remote computer.
  • Router-to-router VPN connection. A router makes a router-to-router VPN connection that connects two portions of a private network. ISA Server provides a connection to the network to which the ISA Server is attached. On a router-to-router VPN connection, the packets sent from either router across the VPN connection typically do not originate at the routers.

VPN Components

  • A VPN connection includes the following components:
  • VPN server. The ISA Server computer that accepts VPN connections from VPN clients.
  • VPN client. A computer that initiates a VPN connection to a VPN server. A VPN client can be an individual computer or a router.
  • Tunnel. The portion of the connection in which your data is encapsulated.
  • VPN connection. The portion of the connection in which your data is encrypted. For typical secure VPN connections, the data is encrypted and encapsulated along the same portion of the connection.
  • Tunneled data. Data that is usually sent across a private point-to-point link.
  • Transit internetwork. The shared or public network crossed by the encapsulated data. For the Windows Server 2003 family, the transit internetwork is always an IP internetwork. The transit internetwork can be the Internet or a private IP-based intranet.

VPN and multi-networking

When you configure the VPN, you can set aside a pool of static IP addresses for the VPN users' computers. When a VPN client connects to the local network, it is assigned an IP address from this address pool. This IP address is added to the VPN Clients network.

In the multi-network environment supported by ISA Server, VPN users are part of the VPN Clients network.

Although the VPN users are virtually part of the local network address range, they are not subject to the local network's access policy, as you configured it for ISA Server. Special rules can be configured to allow them access to network resources.


About the ISA Server Cache [ISA Server 2004]

About the ISA Server Cache

Internet Security and Acceleration Server 2004 maintains a centralized cache of frequently requested Internet objects that can be accessed by all ISA Server clients. ISA Server also allows distributed content caching among multiple ISA Server hosts. Distributed caching may be implemented with arrays, chains, or a combination of both.

This section includes the following topics:

  • How ISA Server Caching Works
  • ISA Server Caching Mechanism
  • Cache Administration


How ISA Server Caching Works [ISA Server 2004]

How ISA Server Caching Works

The Web proxy of ISA Server maintains a cache of Web objects and attempts to fulfill Web requests from the cache. If the request cannot be fulfilled from the cache, the ISA Server computer initiates a new request on behalf of the client. Once the remote Web server responds to the ISA Server computer, the ISA Server computer caches the response to the original client request and sends a response to the client.

ISA Server supports forward caching, used for outgoing requests, and reverse caching, used for incoming requests. Clients in both forward caching and reverse caching benefit from the full gamut of ISA Server caching features.

If you installed ISA Server in Firewall mode, ISA Server does not maintain a cache.

ISA Server analyzes routing rules, cache configuration, and existing cache content to determine if an object should be retrieved from the cache.

First, if the user request is allowed, ISA Server checks if the object exists in its cache. If the request is made to an array of ISA Server computers, then the Cache Array Routing Protocol (CARP) algorithm is used to determine which server's cache should be checked. If the object is not in the cache, then ISA Server checks the routing rule's action, to determine how to route the request. If the object is in the cache, then ISA Server performs the following steps:

  1. ISA Server checks if the object is valid. The object is considered invalid if one of the following conditions is true:

    • The Time to Live (TTL) that is specified in the source has expired.
    • The TTL that you configured in a scheduled cache content download job has expired.
    • The TTL that you configured for the object has expired.

    If the object is valid, ISA Server retrieves the object from the cache and returns it to the user.

  2. If the object is invalid, then ISA Server checks the applicable routing rule. If you configured the routing rule cache properties to return any version of the object, then ISA Server retrieves the invalid object from the cache.
  3. If the routing rule is configured to route the request, then ISA Server determines whether to route the request to the upstream server or to the requested Web server.
  4. If the routing rule is configured to route the request to the Web server, then ISA Server checks if the Web server is accessible.
  5. If the Web server is not accessible, then ISA Server checks if you configured the server to return expired objects from the cache. If you instructed the server to return the expired object as long as the specific expiration time did not pass, then the object is returned from the cache to the user.
  6. If the Web server is available, ISA Server determines if the object is cacheable and if you configured the routing rule's cache properties to cache the response. If so, then ISA Server caches the object and returns the object to the user.


ISA Server Caching Mechanism [ISA Server 2004]

ISA Server Caching Mechanism

When you configure a drive for caching, ISA Server creates a cache content file on that drive with the .cdat extension. A file, named Dir1.cdat, is created in the <drive>:\urlcache folder.

There is a cache content file for each 10 GB of space on a disk, to the maximum that you dedicated for the cache. For example, if you allocate 12 GBs of disk space on a particular drive, ISA Server creates two cache content files. The first file will be 10 GBs and the second file will be 2 GB.

As objects are cached, ISA Server appends them to the cache content file. If the cache content file is too full to hold a new object, ISA Server removes older objects from the cache, by using a formula that evaluates age, how often the object is accessed, and size.

All of the content stored in the ISA Server cache can be deleted by stopping the Microsoft Firewall service and then deleting all of the .cdat files on all of your cache drives. New files that do not contain any stored content will be created when the Firewall service is restarted.

Warning Do not modify cache content files, and do not delete these files when the Firewall service is running.

This section contains the following topics:

  • RAM Caching
  • Cache Array Routing Protocol


RAM Caching [ISA Server 2004]

RAM Caching

In ISA Server, cached pages are stored immediately in memory to be accessed by clients. A "lazy-writer" approach is used to write the pages to a disk. This approach results in faster cache-availability of the page. There is no direct mechanism for checking whether a page has been cached or written to the disk.

The ISA Server cache approach results in improved cache performance. If the system stops responding, Web objects stored in memory that have not yet been written to a disk must be obtained from the Internet.


Cache Array Routing Protocol [ISA Server 2004]

Cache Array Routing Protocol

ISA Server uses the Cache Array Routing Protocol (CARP) to provide seamless scaling and efficiency when using multiple ISA Server computers that are arrayed as a single logical cache. CARP uses hash-based routing to determine the best path through an array to resolve a request. The request resolution path is based upon a hash of array member identities and Uniform Resource Locators (URLs). For any given URL request, the browser or downstream proxy server will know exactly where in the array the information will be stored. The request resolution path indicates if the information was already cached from a previous request, or has to be obtained from the Internet and then cached for future requests.

CARP provides powerful benefits:

  • Because CARP determines the best request resolution path, there is no query messaging between proxy servers, as is found with conventional Internet Cache Protocol (ICP) networks. By doing this, CARP avoids the heavier query congestion that normally occurs with a greater number of servers.
  • CARP eliminates the duplication of contents that otherwise occurs on an array of proxy servers. With an ICP network, an array of five proxy servers can rapidly evolve into duplicate caches of the most frequently-requested URLs. The hash-based routing of CARP keeps this from happening by allowing all five ISA Server computers to exist as a single logical cache. The result is a faster response to queries and a far more efficient use of server resources.
  • CARP has positive scalability. Due to its hash-based routing and its resultant independence from peer-to-peer pinging, CARP becomes faster and more efficient as more proxy servers are added. ICP arrays must conduct queries to determine the location of cached information, an inefficient process that generates extraneous network traffic. ICP arrays have negative scalability: the more servers added to the array, the more querying required between servers to determine location.
  • CARP automatically adjusts to additions or deletions of servers in the array. The hash-based routing means that, when a server is either taken offline or added, only minimal reassignment of URL caches is required.
  • CARP ensures that the cache objects are either distributed evenly between all servers in the array or by the load factor that you configure for each server.

How CARP Works

The CARP process provides efficient routing for requests.

  1. All servers are tracked through an array membership list, which is maintained in Active Directory. Array members are notified when servers are added or removed from the array.
  2. Periodically, the Web proxy client or a downstream server polls and, if necessary, updates the array membership list.

    • Web proxy clients send an array.dll?Get.Routing.Script request to the member server.
    • Downstream servers send an array.dll?Get.Info.v1 request to the member server.
  3. When requesting an object, the client or downstream server uses the membership list, together with a hash function it computes for the name of each requested URL, to determine which server should service the request.
  4. The hash value of the URL is combined with the hash value for each ISA Server. The URL+ISA Server hash that comes up with the highest value becomes "owner" of the information cache.
  5. The server checks if it should handle the request. If not, then it sends the request to another member server, specifying that server's intra-array IP address. The sending member provides its authentication information to the receiving member. In a publishing scenario, it also provides the GUID of the publishing rule.
  6. Once a server has been selected to handle the request, it does so, applying the ISA Server rule if necessary.

The result is a location for all cached information, meaning that the Web browser or downstream server can know exactly where a requested URL is either already stored locally or will be located after caching. Because the hash functions used to assign values are so numerous, the load is statistically distributed and balanced across the array.

The request resolution path that CARP provides means that there is no need to maintain massive location tables for cached information. The browser simply runs the same math function across an object to determine where it is.

Because ISA Server computers in an array may have different hardware and some may be more powerful than others, you may want to divide the cache load accordingly. For this reason, you can configure the CARP functions, specifying the load factor for any given server in the array.

Furthermore, you can configure CARP differently for incoming and outgoing Web requests. For example, CARP can be enabled for all outgoing Web requests, and disabled for all incoming Web requests.


Cache Administration [ISA Server 2004]

Cache Administration

The ISA Server administration COM objects allow you to administer the cache programmatically, automate administrative tasks related to the cache, and extend cache performance by using the FetchUrl method. An introduction to FetchUrl is provided in Extending the Cache.

For more information regarding cache administration, see Managing the ISA Server Cache.


About ISA Server Rules [ISA Server 2004]

About ISA Server Rules

You can configure ISA Server to meet your specific security and performance needs by defining and configuring rules that determine whether users, computers, or applications are granted access to computers in your network and on the Internet. ISA Server allows you to define several types of rules:

  • Access rules.
  • Publishing policy rules, which include server publishing rules and Web publishing rules.
  • System policy rules.

When an internal client requests an Internet object, ISA Server processes the rules to determine if the request is allowed.

Similarly, when an external (Internet) client requests an object from an internal server, ISA Server processes the rules to determine if the request is allowed.

This section includes the following topics:

  • Access Rules
  • Publishing Policy Rules
  • System Policy Rules


Access Rules [ISA Server 2004]

Access Rules

Access rules determine how clients on a source network can access resources on a destination network.

Each access rule is represented by an FPCPolicyRule object contained in an FPCPolicyRules collection.

An access rule defines the actions that will be taken when specific users attempt to access specific sites or content through an ISA Server computer. ISA Server access rules allow you to define exactly which sites and content can be accessed by clients behind the ISA Server computer and which protocols can be used by the clients to gain access. You can configure access rules to apply to all IP traffic, to a specific set of protocol definitions, or to all IP traffic except selected protocols. Access rules also determine when the rule is in effect by applying the rule according to a specific schedule.

ISA Server includes a list of preconfigured, well-known protocol definitions, including the Internet protocols which are most widely used. You can also add or modify additional protocols. When a client requests an object using a specific protocol, ISA Server checks the access rules. A request is processed only if an access rule specifically allows the client to communicate using the specific protocol and to access the requested object, but only at times allowed by the applicable schedule.


Publishing Policy Rules [ISA Server 2004]

Publishing Policy Rules

You can use ISA Server to configure a publishing policy, which consists of server publishing rules and Web publishing rules.

Each server publishing rule or Web publishing rule is represented by an FPCPolicyRule object contained in an FPCPolicyRules collection.

Server Publishing Rules

Server publishing rules filter all incoming requests to internal servers, such as Simple Mail Transfer Protocol (SMTP) servers, File Transfer Protocol (FTP) servers, Structured Query Language (SQL) servers, and others. Requests may be forwarded downstream to an internal server, located behind the ISA Server computer.

Server publishing rules are used when there is a network address translation (NAT) relationship defined by a network rule (FPCNetworkRule) between the network on which the clients sending requests to the published server are located (the source network) and the network on which the published server is located (the destination network). A server publishing rule uses secure network address translation (SecureNAT), which allows requests that are sent to an IP address that is valid on the source network to reach an IP address on a protected network behind the ISA Server computer. The server publishing rule maps a port number and an IP address (or IP addresses) on the network adapter of the ISA Server computer that listens for requests from the clients to a port number and an IP address on the published server. Requests that meet the conditions specified by the rule are then redirected to the IP address of the published server. However, only requests that are identified as part of the designated protocol are processed by the server publishing rule and redirected to the published server.

When there is a routing relationship defined by a network rule between the client network and the network where a server is located, an access rule can allow the clients to send requests directly to the IP address of a server located on a protected network behind the ISA Server computer.

Web Publishing Rules

A Web publishing rule maps published website names to the internal paths of websites and maps DNS names and IP addresses to the internal address of a Web server located behind the ISA Server computer. A Web publishing rule also determines how ISA Server should handle incoming requests for HTTP objects on the published Web server and how ISA Server should respond on behalf of the Web server. Requests are forwarded downstream to the published Web server, or, if possible, they are serviced from the ISA Server cache.

A Web publishing rule defines the response to attempts by outside users to access an internal site. Possible responses include:

  • Denying the request.
  • Delegating the request to a different internal server.


System Policy Rules [ISA Server 2004]

System Policy Rules

System policy rules are policy rules that allow specific types of requests from the Local Host network (the ISA Server computer) to reach specified destinations, or allow specific types of requests from specified sources to reach the Local Host network.

Each access rule is represented by an FPCPolicyRule object contained in an FPCSystemPolicyRules collection.

Each system policy rule belongs to a predefined group of policy rules that apply to a specific service and can be configured together. Such a group is called a system policy configuration group, which is represented by an FPCSystemPolicyConfigGroup object.


About Authentication in ISA Server [ISA Server 2004]

About Authentication in ISA Server

The access policy and publishing rules of ISA Server can be configured to allow or deny a set of computers or a group of users from accessing specific servers. If the rule applies specifically to users, then the ISA Server checks the Web request properties for listeners on the array to determine how the user should be authenticated.

You can configure incoming and outgoing Web request settings so that users must always be authenticated by ISA Server before processing rules. This ensures that requests are allowed only if the user making the request is authenticated.

This section includes the following topics:

  • Authentication Methods
  • ISA Server and Secure Sockets Layers


Authentication Methods [ISA Server 2004]

Authentication Methods

You can configure which authentication method to use. You can configure different authentication methods for incoming Web requests and for outgoing Web requests.

ISA Server supports the following built-in Windows authentication methods:

  • Basic authentication.
  • Digest authentication.
  • Advanced Digest authentication.
  • Integrated authentication.
  • Secure Sockets Layer (SSL) certificates.

ISA Server provides predefined authentication schemes that are defined by FPCAuthenticationScheme objects for authentication. The following authentication schemes are supplied with ISA Server 2004:

  • OWA Forms-Based.
  • RADIUS.
  • SecurID.

ISA Server also supports third-party authentication schemes, registered with Web filters. For more information about third-party authentication schemes, see the reference page for the FPCAuthenticationScheme object.

Microsoft Internet Explorer 5 and later supports all the authentication methods. Other Web browsers may support only the basic authentication method. Be sure that the client Web browsers can use at least one of the authentication methods that you specify in the incoming Web request properties and outgoing Web request properties. Otherwise, the client will not be able to access the requested object.

The authentication method used for a Web request is determined by properties (FPCWebListenerProperties) of the applicable Web listener and by the UseDigestSSP property of the FPCWebProxy object.


ISA Server and Secure Sockets Layers [ISA Server 2004]

ISA Server and Secure Sockets Layers

In ISA Server you can use Secure Sockets Layer (SSL) security features for authentication. Certification is used in two ways when a client requests an object from a server:

  • The server authenticates itself by sending a server certificate to the client.
  • The server requests that the client authenticate itself. In this case, the client must present an appropriate client certificate to the server.

SSL authenticates by checking the contents of an encrypted digital identification submitted by the user's Web browser during the logon process. Server certificates contain identifying information about the server. Client certificates usually contain identifying information about the user and about the organization that issued the certificate. Users obtain client certificates from a trusted external organization.

Client Certificate

If client certificate is the selected authentication method, then ISA Server requests a client certificate from the client before allowing the request.

The ISA Server computer receives the request and sends a server certificate to the client. The ISA Server computer thereby identifies itself as the SSL Web server. The client receives the certificate, and verifies that the certificate indeed belongs to the ISA Server computer.

The client then resends its request to the ISA Server computer. However, the ISA Server computer requires a certificate from the client that must have been previously issued. The ISA Server computer verifies that the certificate indeed belongs to a client that is allowed access.

The client certificate should be installed in the Microsoft Web Proxy certificate store on the ISA Server computer. The certificate should be mapped to the appropriate user account.

ISA Server can present client certificates only in SSL bridging scenarios.

Server certificate

When a client requests SSL objects from a server, it requests that the server authenticate itself. If the ISA Server terminates an SSL connection, then the ISA Server will have to authenticate itself to the client. You must configure and specify a server-side certificate to use when authenticating ISA Server to the client.

The server certificate should be installed in the Local Computer certificate store on the ISA Server computer. The certificate name should be identical to the name of the ISA Server (for outgoing Web requests) or to the name of the published Web servers (for incoming Web requests)


About ISA Server Services [ISA Server 2004]

About ISA Server Services

ISA Server acts as a gateway to the Internet, implementing security in three security layers: the IP packet layer, the application layer, and the circuit layer. This multilayered approach is made possible by the services included with ISA Server:

  • Microsoft® ISA Server Control service. This service is responsible for restarting the other services as necessary, generating alerts, running actions, and other functions.
  • Microsoft ISA Server Job Scheduler service. This service downloads content from the Internet according to a user-defined schedule.
  • Microsoft Firewall service. This service is implemented at the circuit-layer level.

This section contains the following sections:

  • About the Microsoft ISA Server Control Service
  • About the Microsoft ISA Server Job Scheduler Service
  • About the Microsoft Firewall Service


About the Microsoft ISA Server Control Service [ISA Server 2004]

About the Microsoft ISA Server Control Service

The Microsoft® ISA Server Control service (isactrl) performs the following functions:

  • Starting other ISA Server services.
  • Restarting other ISA Server services when certain changes are made through ISA Server Management, as described in the Internet Security and Acceleration Server 2004 product documentation.
  • Generating alerts and running actions.
  • Updating the client configuration files (Msplat.txt and Mspclnt.ini).
  • Deleting unused log files.

You cannot use ISA Server Management to stop or start the Microsoft ISA Server Control service. To stop the service, type the following at a command line:

net stop isactrl

If you stop the Microsoft ISA Server Control service, all the other ISA Server services will also be stopped.


About the Microsoft ISA Server Job Scheduler Service [ISA Server 2004]

About the Microsoft ISA Server Job Scheduler Service

ISA Server further extends caching performance with a downloading job scheduler feature, which can be customized. With the Microsoft® ISA Server Job Scheduler service, you can download HTTP content directly to the ISA Server cache upon request or according to a schedule. You can use this service to update the ISA Server cache with HTTP content that you anticipate will be requested by clients in your organization.

You can configure which content ISA Server should prefetch and schedule when the content should be cached, available for access directly from the ISA Server cache rather than from the Internet. By monitoring and analyzing Internet access, you can determine which Internet objects will be needed and when. Then you can use the Microsoft ISA Server Job Scheduler service to prepare the ISA Server cache accordingly.

You can use the Microsoft ISA Server Job Scheduler service to schedule downloads of HTTP files from a website to a local cache. You can download a single URL, multiple URLs, or an entire website according to a schedule you specify.

Note Sites that have pop-up windows requiring user interaction, such as those that ask for credentials, or offer to install language packs, cannot be downloaded by the Microsoft ISA Server Job Scheduler service. Also, websites that expect cookies when a client requests a page cannot be precached.

You can determine whether the Microsoft ISA Server Job Scheduler service is running through the JobSchedulerServiceStatus property of the FPCServer object. The Microsoft ISA Server Job Scheduler service can be started by calling the StartJobSchedulerService method, and it can be stopped by calling the StopJobSchedulerService method.


About the Microsoft Firewall Service [ISA Server 2004]

About the Microsoft Firewall Service

The Microsoft® Firewall service (fwsrv) is a generic, circuit-level proxy for Windows Sockets (Winsock) applications. The Firewall service makes Telnet, e-mail, news, Microsoft Media Player, RealNetworks RealAudio, Internet Relay Chat (IRC), and other Winsock-compatible client applications perform as though they were connected directly to the Internet. The client application makes Winsock application programming interface (API) calls to communicate with an application running on an Internet-based host. The Firewall service redirects the necessary functions to the ISA Server computer, thus establishing a communication path from the internal application to the Internet application through the ISA Server computer. This redirection eliminates the need for a specific gateway for each protocol, such as Network News Transfer Protocol (NNTP), Simple Mail Transfer Protocol (SMTP), Telnet, or File Transfer Protocol (FTP). The Firewall service allows applications with no built-in support for a proxy to benefit from proxy service without using the protocols.

The Firewall service runs as a stand-alone service on Microsoft Windows Server™ 2003 and Windows® 2000 Server operating systems. It establishes gateway connections between the Windows Sockets (Winsock) applications on the client and the Internet host. The local network remains secure, because communication is channeled through the ISA Server computer. The Firewall service can be enhanced by using application filters.

You can determine whether the Firewall service is running through the FirewallServiceStatus property of the FPCServer object. The Firewall service can be started by calling the StartFirewallService method, and it can be stopped by calling the StopFirewallService method.

This section contains the following topics:

  • The Microsoft Firewall Service and Firewall Clients
  • About the Firewall Client
  • Application Filters
  • About the Web Proxy


The Microsoft Firewall Service and Firewall Clients [ISA Server 2004]

The Microsoft Firewall Service and Firewall Clients

A Firewall client captures a Windows Sockets (Winsock) API call in a client application and redirects it to the Microsoft® Firewall service, which makes the actual call. There are two connections: one on the private network from the client computer to the ISA Server computer and one over the Internet from the Internet host to the ISA Server computer.

The Firewall service consists of two parts: a dynamic-link library (DLL) running on the Firewall client and a service running on the ISA Server computer.

When the Firewall Client software is installed on the client computer, it installs two .dll files. The files intercept Winsock API calls from applications on the client and forward them to the ISA Server computer by using a control channel.

The control channel manages remote Winsock messages, and is designed to do the following:

  • Deliver the set of IP address ranges included in an ISA Server network to Firewall clients residing in the network if Firewall client support is enabled for that network. These IP address ranges are stored on the Firewall clients as a table of IP address pairs called the local address table (LAT). Firewall clients will recognize the IP address ranges received as local destinations, for which no ISA Server computer is required.
  • Establish TCP connections from the client computer to the ISA Server computer. This channel is used to build the virtual connection while attempting to connect with a remote application.
  • Furnish UDP communications to and from the Firewall client and with the ISA Server computer.

The Firewall Client DLL is initialized when the first Winsock connection is attempted. A control channel with the Firewall service is established, and then designated as active through the channel. If Firewall client support is enabled for the Internal network, the set of IP address ranges included in the Internal network is copied from the server to the Firewall client's LAT for determining which destinations are on the Internet and which are local.

Note The Firewall service makes use of the Windows Sockets 2.0 service provider interface (SPI) to implement a layered service provider (LSP). For more information about LSPs, see MSDN.


About the Firewall Client [ISA Server 2004]

About the Firewall Client

You can install Firewall Client software on client computers that run Microsoft® Server™ 2003, Windows® XP, Windows 2000, Windows NT® 4.0, Windows Millennium Edition (Me), Windows 98, or Windows 95. On Windows Server 2003, Windows XP, Windows 2000, and Windows NT 4.0, 16-bit Winsock applications are supported.

The Firewall client component is layered on top of the original Winsock implementation. In platforms that support Winsock 2.0, the client is a layered service provider (LSP). On other platforms, the client setup application renames the original Winsock dynamic-link library (DLL), Wsock32.dll, and installs its own implementation of Wsock32.dll.

The Firewall client communicates with the Microsoft Firewall service by using a dedicated connection called the Firewall service control channel. The control channel connection is established the first time it is needed.

When a client application calls a Winsock function, the client DLL intercepts the call and determines, based on the specified request and the Firewall service configuration files, whether the call is local or remote. Local calls are passed to the original Winsock implementation. Remote calls are redirected to the Firewall service.

When a function call is redirected to the proxy, the client component sends a request through the control channel to the Firewall service and waits for a response. The Firewall service checks the request against the ISA Server policy, processes the request on behalf of the client, and returns a reply through the control channel. The reply is then processed by the Firewall client, and translated to a Winsock error code in case of failure.

The remote Firewall Client software supports basic Winsock 1.0 and Winsock 2.0 functionality. However, the following limitations should be noted:

  • Overlapped I/O on WSARecvFrom. The Winsock API will work, but for a remote socket, the from address that the application will receive is the address of the Firewall service internal socket. However, using a blocking or non-blocking recvfrom, the application will see the actual from address of the Internet host that originally sent the packet.
  • Winsock QoS. ISA Server installs an LSP that supports Quality of Service (QoS) requests. However, for connections made through the Firewall service, Resource Reservation Protocol (RSVP) reservations will not pass through the service.
  • Winsock Name Service Functions. WSALookupService{Begin/Next/End} are implemented, but only resolve queries that would translate into queries by using the gethostbyname, gethostbyaddr, getservbyport, or getservbyname functions.


Application Filters [ISA Server 2004]

Application Filters

Application filters are extensions of the Microsoft® Firewall service. These filters register for and process Firewall service events. By exposing its COM interfaces to developers, ISA Server allows them to extend its security and functionality. Developers can use these interfaces to extend the security and access control for the Firewall service, and to create protocol-specific application filters. These can share the architecture, access control, and administration of the Firewall service. Use of these interfaces is described in Developing Application Filters. Specifically, the interfaces allow a filter to:

  • Receive notifications of special events; for example, when a user connects to a certain remote port.
  • Allow or deny user access to certain operations; for example, binding to a particular port.
  • Examine and possibly modify data that flows through the firewall; for example, to perform virus checking.
  • Initiate network operations (proactive caching) through dynamic IP packet filtering.
  • Integrate seamlessly with ISA Server Management.

See Also

Developing Application Filters, Filter Interfaces


About the Web Proxy [ISA Server 2004]

About the Web Proxy

The ISA Server Web proxy supports requests from any browser that conforms to standards of the Conseil Europeen pour la Recherche Nucleaire (CERN). The Web proxy allows Web access to nearly every desktop operating system, including Windows NT, Windows 95, Windows 98, Windows 2000, Macintosh, and UNIX.

The ISA Server Web proxy works at the application level on behalf of an HTTP client requesting an Internet object retrievable through one of the protocols supported by the filter: FTP, HTTP, HTTPS, and Gopher. The Web proxy protects all Web browser access. The Web proxy operates with a Web proxy client, which can be any client computer that uses CERN-compliant applications and is configured to use the ISA Server Web proxy.

A server running Internet Information Services (IIS) can be installed on an ISA Server computer, but this is not required. For more information on IIS and ISA Server, see Internet Information Services Separation.

You can use the secure Web publishing feature of ISA Server in conjunction with Internet Information Services (IIS) or other Web servers to publish to the Internet without compromising the security of your internal network. ISA Server uses Secure Web publishing and reverse hosting to send requests to Web-publishing servers connected behind the ISA Server Web proxy computer. The ISA Server Web proxy supports the use of Secure Sockets Layer (SSL), and also supports Web (ISAPI) filters.

The ISA Server Web proxy includes the ISA Server cache, described in About the ISA Server Cache.


Web Proxy Clients [ISA Server 2004]

Web Proxy Clients

Web proxy clients (typically browsers) must be specifically configured to use the ISA Server. When a user requests a Web site, the browser parses the URL. If the name contains "dots" such as a fully qualified domain name (FQDN), the browser considers the destination to be remote and sends the HTTP request to the ISA Server for processing.


Web (ISAPI) Filters [ISA Server 2004]

Web (ISAPI) Filters

Web (ISAPI) filters detect and process HTTP events, and can extend the functionality of the Web proxy . By using the Internet Server application programming interface (API), ISA Server supports the Web filter extensibility model, which lets third-party developers examine and change the HTTP request and response flow. ISA Server does not support ISAPI extensions.

For more information about ISA Server support of Web filters, see Developing Web (ISAPI) Filters for ISA Server.


Internet Information Services Separation [ISA Server 2004]

Internet Information Services Separation

Unlike Microsoft Proxy Server 2.0, which implemented the Web proxy service as an ISAPI filter that was loaded by the local IIS Web server, the proxy service has been replaced by the Web proxy. IIS Server can be installed on an ISA Server computer but it is not required.

The incoming Web request and outgoing Web request properties can now run on different TCP ports. For example, by default, ISA Server listens for outgoing Web requests on TCP port 8080, while ISA Server listens for incoming Web requests on TCP port 80. In this way, ISA Server ensures that outgoing Web requests do not interfere with Web publishing on port 80.

If IIS Server is installed on the ISA Server computer, it must be configured to not use the ports that ISA Server uses for outgoing Web requests (by default, 8080) and for incoming Web requests (by default, 80). For example, you can change IIS Server to listen on port 81. Then you can configure the ISA Server computer to direct the incoming Web requests to port 81 on the local IIS Server.

If there is a conflict between ports used by ISA Server and those used by IIS Server, the setup program will stop the IIS publishing service. You can then change IIS Server to listen on a different port and restart the IIS Server publishing service.


About ISA Server Clients [ISA Server 2004]

About ISA Server Clients

ISA Server supports three types of clients:

  • Firewall clients are client computers that have Firewall Client installed and enabled.
  • Secure network address translation (SecureNAT) clients are client computers that do not have Firewall Client installed.
  • Web proxy clients are any client Web application configured to use ISA Server.

The following table compares the ISA Server clients.

Feature | SecureNAT client | Firewall client | Web proxy client
Installation required | Some network configuration changes are required | Yes | No, requires Web browser configuration
Operating system support | Any operating system that supports Transmission Control Protocol/Internet Protocol (TCP/IP) | Only Windows platforms | All platforms, but by way of Web application
Protocol support | Requires application filters for multi-connection protocols | All Winsock applications | Hypertext Transfer Protocol (HTTP), Secure HTTP (HTTPS), File Transfer Protocol (FTP), and Gopher
User-level authentication | No | Yes | Yes
Server applications | No configuration or installation required | Requires configuration file | N/A

Firewall client computers and SecureNAT client computers may also be Web proxy clients. If the Web application on the computer is configured explicitly to use the ISA Server, then all Web requests (HTTP, FTP, HTTPS, and Gopher) are sent directly to the Web proxy. All other requests are handled first by the Firewall service.

This section contains the following topics:

  • SecureNAT Clients
  • Firewall Clients
  • About Web Proxy Clients


SecureNAT Clients [ISA Server 2004]

SecureNAT Clients

Client computers that do not have Firewall client software are secure network address translation (SecureNAT) clients. SecureNAT clients can benefit from many of the features of ISA Server. This includes most access control features, with the exception of high-level protocol support and user-level authentication.

Although SecureNAT clients do not require special software, you should configure the default gateway so that all traffic destined to the Internet is sent by way of ISA Server, either directly or indirectly, through a router. You can configure clients either by using the DHCP service or manually.

Since requests from SecureNAT clients are essentially handled by the Firewall service, SecureNAT clients benefit from the following security features:

  • Application filters can modify the protocol stream to allow handling of complex protocols. In network address translation (NAT), introduced in Windows 2000, this mechanism is accomplished through the use of NAT editors which are written as kernel-mode NAT editor drivers in Windows.
  • The Firewall service can pass all Hypertext Transfer Protocol (HTTP) requests to the Web proxy, which handles caching and ensures that policy rules are applied appropriately.

SecureNAT and Windows NAT

ISA Server extends the Windows NAT functionality by enforcing ISA Server policy for SecureNAT clients. In other words, all ISA Server rules can be applied to SecureNAT clients, despite the fact that Windows NAT does not have an inherent authentication mechanism. (Policies regarding protocol usage, destination, and content type are also applied to SecureNAT clients.)

SecureNAT Clients and Server Publishing

As with Firewall clients, SecureNAT clients can also actually be servers, such as mail servers, which publish information to the Internet. You configure server publishing rules to publish servers as SecureNAT clients.

SecureNAT clients are not supported in cache mode.


Firewall Clients [ISA Server 2004]

Firewall Clients

A Firewall client is a computer with Firewall Client software installed and enabled. The Firewall client runs Winsock applications that use the Microsoft Firewall service of ISA Server 2004. Whenever a Winsock application running on a Firewall client attempts to send a request to a computer, the client checks its local address table (LAT) to see if the specified computer is included in an IP address range in the LAT and can be recognized as a local destination. Addresses specified in the local routing table on the Firewall client are also considered local. If the destination is local, the Firewall client sends the request directly to the computer. If the destination is not local, the request is sent to the Firewall service on an ISA Server computer. The Firewall service handles the request, forwarding it to the appropriate destination, as permitted. The Firewall Client software can send Windows user information, which is required for authentication purposes, to the ISA Server.

Setting up a Firewall client does not configure individual Winsock applications. Instead, it uses the same Winsock dynamic link library (DLL) that the other applications use. The Firewall client then intercepts the application calls and decides whether to route the request to the ISA Server computer.

You can install Firewall Client software on client computers that runWindows 95, Windows 98, Windows Millennium Edition (Me), Windows NT 4.0, Windows 2000, Windows XP, or Windows Server 2003. 16-bit Winsock applications are supported, but only on Windows NT 4.0, Windows 2000, Windows XP, and Windows Server 2003.

Firewall clients are supported only if the Firewall service is running.


About Web Proxy Clients [ISA Server 2004]

About Web Proxy Clients

A Web proxy client is a client computer that has a Web browser application, which complies with Hypertext Transfer Protocol (HTTP) 1.1 and which is configured to use the Web proxy of ISA Server. Each Web browser is configured through its own user interface.

When you install Firewall Client software, the Web browser settings on the Firewall Client desktop can be configured automatically. Subsequently, you can reconfigure the Web browser clients. You can configure the following Web browser properties:

  • The ISA Server and port to which the client should connect.
  • Automatic discovery settings.
  • The computers that the Firewall client's Web browser should access directly.
  • Backup route, if the ISA Server is unavailable.

When the Firewall Client software is installed, the Web browser on the client computer is configured with those settings.

If Firewall Client is not installed, then the Web browser can be configured manually.


Administration COM Documentation [ISA Server 2004]

Administration COM Documentation

This section of the documentation describes the programmatic administration of ISA Server using its COM objects.

This section contains the following topics:

  • About ISA Server Administration
  • ISA Server Administration Scripting
  • Administration Reference


About ISA Server Administration [ISA Server 2004]

About ISA Server Administration

The ISA Server 2004 administration COM object model allows you to extend ISA Server functionality. The administration objects also allow for automation of all the tasks performed through ISA Server Management. This means that administrators can automate any task by using the administration objects.

The ISA Server administration objects support single-threaded apartment applications.

For examples of using the objects to automate administrative tasks, see ISA Server Administration Scripting.

This section contains the following topics:

  • ISA Server Administration Object Model
  • About Administration Scripting
  • About Persistence
  • Upgrading ISA Server 2000 COM Object Utilities
  • Using ISA Server 2000 and ISA Server 2004 COM Objects Together


ISA Server Administration Object Model [ISA Server 2004]

ISA Server Administration Object Model

The following section displays the ISA Server COM hierarchy. Click on an object name to see its reference page.

FPC
FPCArray
FPCArrays
FPCServer

FPCArrays

FPCArrays
FPCArray
FPCAlerts
FPCAlert
FPCAlertActions
FPCAlertAction
FPCConnectivityVerifiers
FPCConnectivityVerifier
FPCServers
FPCArrayPolicy
FPCSystemPolicy
FPCSystemPolicyRules
FPCPolicyRule
FPCSystemPolicyConfigGroup
FPCSelectionIPs
FPCDomainNameSets as FPCRefs
FPCRuleElements
FPCCache
FPCLogs
FPCLog
FPCReports
FPCExtensions
FPCApplicationFilters
FPCApplicationFilter
FPCWebFilters
FPCWebFilter
FPCNetworkConfiguration
FPCClientConfigSettings
FPCClientSettingsSection
FPCAdminSecurity
FPCSecurityRoles
FPCSecurityRole
FPCDelegatedAdmins
FPCDelegatedAdmin
FPCSecurityRole as FPCRef
FPCNetworkTemplate as FPCRef
FPCLogViewer
FPCLogContent
FPCLogEntry
FPCSessionsMonitors
FPCSessionsMonitor
FPCSessionsMonitorEntry

FPCServers

FPCServers
FPCServer
FPCCacheDrives
FPCCacheDrive
FPCDiskDrives
FPCDiskDrive
FPCAdapters
FPCAdapter
FPCReadOnlyIpRangeSet
FPCReadOnlyIpRangeEntry
FPCConnectivityResults
FPCConnectivityResult
FPCSignaledAlerts
FPCSignaledAlert
FPCSignaledAlertInstance
FPCDialupNetworkConnections
FPCCertificates
FPCCertificate
FPCReadOnlyIpRangeSet
FPCReadOnlyIpRangeEntry

FPCArrayPolicy

FPCArrayPolicy
FPCPolicyRules
FPCPolicyRule
FPCSelectionIPs
FPCNetworks as FPCRefs
FPCNetworkSets as FPCRefs
FPCComputers as FPCRefs
FPCAddressRanges as FPCRefs
FPCSubnets as FPCRefs
FPCComputerSets as FPCRefs
FPCSchedule as FPCRef
FPCAccessProperties
FPCSelectionIPs
FPCUserSets as FPCRefs
FPCDomainNameSets as FPCRefs
FPCProtocolDefinitions as FPCRefs
FPCContentTypeSets as FPCRefs
FPCURLSets as FPCRefs
FPCServerPublishingProperties
FPCProtocolDefinition as FPCRef
FPCIPsOnNetworks
FPCIPOnNetwork
FPCNetwork as FPCRef
FPCIPAddresses
FPCWebPublishingProperties
FPCCertificate
FPCPublicNames
FPCPathMappings
FPCPathMapping
FPCWebListener as FPCRef
FPCUserSets as FPCRefs
FPCWebProxy
FPCTunnelPortRanges
FPCTunnelPortRange
FPCAttackDetection
FPCConnectionLimitPolicy
FPCConnectionLimit
FPCUserSets as FPCRefs
FPCComputerSets as FPCRefs
FPCLowLevelSettings

FPCRuleElements

FPCRuleElements
FPCSchedules
FPCSchedule
FPCComputers
FPCComputer
FPCAddressRanges
FPCAddressRange
FPCSubnets
FPCSubnet
FPCComputerSets
FPCComputerSet
FPCComputers
FPCAddressRanges
FPCSubnets
FPCURLSets
FPCURLSet
FPCDomainNameSets
FPCDomainNameSet
FPCProtocolDefinitions
FPCProtocolDefinition
FPCProtocolConnections
FPCProtocolConnection
FPCEventDefinitions
FPCEventDefinition
FPCWebListeners
FPCWebListener
FPCNetworks as FPCRefs
FPCIPsOnNetworks
FPCIPOnNetwork
FPCNetwork as FPCRef
FPCIPAddresses
FPCWebListenerProperties
FPCAppliedSSLCertificates
FPCAppliedSSLCertificate
FPCCertificate
FPCServer as FPCRef
FPCAuthenticationSchemes as FPCRefs
FPCContentTypeSets
FPCContentTypeSet
FPCUserSets
FPCUserSet
FPCAccounts
FPCAccount
FPCNonWindowsUsers
FPCNonWindowsUser
FPCAuthenticationSchemes
FPCAuthenticationScheme
FPCRadiusServers
FPCRadiusServer

FPCCache

FPCCache
FPCCacheConfiguration
FPCActiveCacheConfiguration
FPCCacheRules
FPCCacheRule
FPCURLSets as FPCRefs
FPCSelectionIPs
FPCDomainNameSets as FPCRefs
FPCHTTPCacheConfiguration
FPCFTPCacheConfiguration
FPCCacheContents
FPCScheduledContentDownload
FPCScheduledContentDownloadConfig
FPCScheduledContentDownloadJobStatuses
FPCScheduledContentDownloadJobStatus
FPCCredentials

FPCReports

FPCReports
FPCReportJobs
FPCReportJob
FPCServer as FPCRef
FPCCredentials
FPCReportsProperties
FPCSummaryReports
FPCWebUsageReports
FPCApplicationUsageReports
FPCTrafficReports
FPCSecurityReports
FPCReadyReports
FPCReadyReport
FPCLogSummaryConfiguration

FPCNetworkConfiguration

FPCNetworkConfiguration
FPCFirewallChaining
FPCCredentials
FPCRoutingRules
FPCRoutingRule
FPCURLSets as FPCRefs
FPCSelectionIPs
FPCDomainNameSets as FPCRefs
FPCPrimaryRoute
FPCCredentials
FPCBackupRoute
FPCCredentials
FPCCertificate
FPCNetworks
FPCNetwork
FPCIpRangeSet
FPCIpRangeEntry
FPCLDT
FPCLDTEntry
FPCClientConfig
FPCFirewallClientConfig
FPCWebBrowserClientConfig
FPCClientAutoScript
FPCPublicNames
FPCIpRangeSet
FPCIpRangeEntry
FPCClientBackupRoute
FPCVpnNetworkConfiguration
FPCVpnNetworkIPSecSettings
FPCVpnNetworkL2tpPptpSettings
FPCWebListenerProperties
FPCAppliedSSLCertificates
FPCAppliedSSLCertificate
FPCCertificate
FPCServer as FPCRef
FPCAuthenticationSchemes as FPCRefs
FPCNetworkRules
FPCNetworkRule
FPCSelectionIPs
FPCVpnConfiguration
FPCIpRangeSet
FPCIpRangeEntry
FPCVpnPPPSettings
FPCVpnQuarantineSettings
FPCUserSets as FPCRefs
FPCUserMapping
FPCNetworkSets as FPCRefs
FPCIPsOnNetworks
FPCIPOnNetwork
FPCNetwork as FPCRef
FPCIPAddresses
FPCNetwork as FPCRef
FPCAccounts
FPCNetworkSets
FPCNetworkSet
FPCNetworks as FPCRefs
FPCNetworkTemplates
FPCNetworkTemplate
FPCNetworksInTemplate
FPCNetworkInTemplate
FPCPoliciesInTemplate
FPCPolicyInTemplate
FPCDialingConfiguration
FPCNetwork as FPCRef
FPCNetwork as FPCRef


About Administration Scripting [ISA Server 2004]

About Administration Scripting

Scripting allows you to use the ISA Server administration objects to access and control policies and configurations for any ISA Server computer within an organization.

ISA Server administration scripting has a number of benefits, such as saving time on tasks that are repetitive or need to be carried out on multiple servers. Administration scripting has other advantages:

Simplifies configuration changes: With ISA Server you do not need to write code that stores or retrieves your configuration from storage because the Save and Refresh methods of the administration COM objects will write configuration changes or retrieve the last saved configuration from persitent storage for you. The objects thereby provide simple and comprehensive access to the ISA Server configuration.
Maintains consistency: ISA Server object methods that set the values of multiple related properties with one method call will check whether the combinations of property settings are valid, and return errors if the properties are not set correctly. Consistency is maintained because scripts do not assign conflicting property settings.
Ensures that services receive changes: Most ISA Server administration objects have a Save method that stores changes. The Save method has parameters for specifying whether the updated configuration will be reloaded and whether services will be restarted to apply the new settings.
Allows command-line and Windows scripting: Microsoft Windows Script Host is a language-independent scripting host for Microsoft ActiveX® scripting engines. It allows you to run ISA Server administration scripts from both the Windows desktop and the command prompt. For more information about Windows Script Host, see Windows Script Host. For information about security in Windows Script Host, see Security and Windows Script Host.
Real-time administration: You can create scripts that allow you to query and control the real-time state of your ISA Server computer.
Task scheduling: Using scripts, tasks that must be performed on a regular basis can be scheduled to occur automatically. For example, you could create a script that would automatically back up configuration information.

See Also

Cache Administration, ISA Server Administration Scripting


About Persistence [ISA Server 2004]

About Persistence

ISA Server 2004 provides a persistence mechanism that enables you to export configuration properties to an .xml file, and to import the properties from a saved .xml file. This is done using the properties and methods of the FPCPersist object, which are also available on any ISA Server administration COM object that inherits from it. Using FPCPersist, you can import and export configuration properties, and have flexibility as to what elements are imported and exported.

You can use the persistence mechanism as a means of backing up your configuration from an array, server, or lower-level object and restoring it when necessary. You can also use persistence to copy a configuration from an array, server, or lower-level ISA Server 2004 object to another computer.

When you import a configuration, you must ascertain that the hierarchy of the imported material matches that of the objects to which you are importing the information. You cannot import array-level information to the server level. Similarly, you cannot import optional data to your configuration if that data was not exported.

The FPCPersistSink object provides the Progress method for handling progress events.


Upgrading ISA Server 2000 COM Object Utilities [ISA Server 2004]

Upgrading ISA Server 2000 COM Object Utilities

In most cases, code that uses ISA Server 2000 COM objects can be upgraded to use corresponding ISA Server 2004 COM objects. The following table maps the ISA Server 2000 COM objects to the corresponding ISA Server 2004 COM objects.

ISA Server 2000 COM object | ISA Server 2004 equivalent | Remarks
FPCAccessControlEntry | None | This object is not applicable to ISA Server 2004 Standard Edition.
FPCAccessControlList | None | This object is not applicable to ISA Server 2004 Standard Edition.
FPCAccount | FPCAccount |
FPCAccounts | FPCAccounts |
FPCActiveCacheConfiguration | FPCActiveCacheConfiguration |
FPCAdapter | FPCAdapter |
FPCAdapters | FPCAdapters |
FPCAlert | FPCAlert |
FPCAlertAction | FPCAlertAction |
FPCAlertActions | FPCAlertActions |
FPCAlertInfo | FPCSignaledAlert and FPCSignaledAlertInstance |
FPCAlertNotification | FPCEventDefinition and FPCSignaledAlert | ISA Server 2004 does not have a separate alert service.
FPCAlerts | FPCAlerts |
FPCApplicationFilter | FPCApplicationFilter |
FPCApplicationFilters | FPCApplicationFilters |
FPCArray | FPCArray |
FPCArrayPolicyConfig | None | This object is not applicable to ISA Server 2004 Standard Edition.
FPCArrayPolicyConfigs | None | This collection is not applicable to ISA Server 2004 Standard Edition.
FPCArrays | FPCArrays |
FPCAutoDial | FPCDialingConfiguration |
FPCBackupRoute | FPCBackupRoute |
FPCBandwidthPriority | None | Bandwidth rules and the associated policy elements are not supported in ISA Server 2004.
FPCBandwidthPriorities | None | Bandwidth rules and the associated policy elements are not supported in ISA Server 2004.
FPCBandwidthRule | None | Bandwidth rules and the associated policy elements are not supported in ISA Server 2004.
FPCBandwidthRules | None | Bandwidth rules and the associated policy elements are not supported in ISA Server 2004.
FPCCache | FPCCache |
FPCCacheConfiguration | FPCCacheConfiguration |
FPCCacheContents | FPCCacheContents |
FPCCacheDrive | FPCCacheDrive |
FPCCacheDrives | FPCCacheDrives |
FPCClientAddressSet | FPCAddressRanges | In ISA Server 2004, the FPCAddressRanges collection contains all the IP address ranges defined for the array object.
FPCClientAddressSets | FPCAddressRanges | In ISA Server 2004, the FPCAddressRanges collection contains all the IP address ranges defined for the array object.
FPCClientAutoScript | FPCClientAutoScript |
FPCClientBackupRoute | FPCClientBackupRoute |
FPCClientConfig | FPCClientConfig |
FPCClientConfigSettings | FPCClientConfigSettings |
FPCClientSettingsSection | FPCClientSettingsSection |
FPCContentGroup | FPCContentTypeSet |
FPCContentGroups | FPCContentTypeSets |
FPCCredentials | FPCCredentials |
FPCDeniedMethod | None | In ISA Server 2004, an HTTP method can be blocked by specifying it in the vendor parameters set for the HTTP Filter Web filter in an HTTP allow rule. For an example, see the HttpFilterConfig.vbs sample on the ISA Server 2004 CD.
FPCDeniedMethods | None | In ISA Server 2004, HTTP methods can be blocked by specifying them in the vendor parameters set for the HTTP Filter Web filter in an HTTP allow rule. For an example, see the HttpFilterConfig.vbs sample on the ISA Server 2004 CD.
FPCDestination | FPCAddressRange, FPCComputer, or element of an FPCDomainNameSet collection | These ISA Server 2004 objects do not specify a path.
FPCDestinationSet | FPCRefs containing references to IP address ranges or computers, or FPCDomainNameSet |
FPCDestinationSets | FPCAddressRanges, FPCComputers, FPCDomainNameSets, or combination of these collections |
FPCDialupEntry | FPCDialingConfiguration |
FPCDialupEntries | None | In ISA Server 2004, a single FPCDialingConfiguration object applies to all the networks connected to an ISA Server computer.
FPCDialupNetworkConnections | FPCDialupNetworkConnections |
FPCDirectAddressDestination | Element of an FPCPublicNames collection |
FPCDirectAddressDestinations | FPCPublicNames |
FPCDirectIpDestination | FPCIpRangeEntry |
FPCDirectIpDestinations | FPCIpRangeSet |
FPCDiskDrive | FPCDiskDrive |
FPCDiskDrives | FPCDiskDrives |
FPCEnterprise | None | This object is not applicable to ISA Server 2004 Standard Edition.
FPCEnterprisePolicy | None | This object is not applicable to ISA Server 2004 Standard Edition.
FPCEnterprisePolicies | None | This collection is not applicable to ISA Server 2004 Standard Edition.
FPCEventDefinition | FPCEventDefinition |
FPCEventDefinitions | FPCEventDefinitions |
FPCExtensions | FPCExtensions |
FPCFilterProtocol | FPCProtocolDefinition | In ISA Server 2004, an FPCProtocolDefinition object can represent a protocol for the Microsoft Firewall service or a protocol for an application filter.
FPCFilterProtocols | FPCProtocolDefinitions | In ISA Server 2004, the FPCProtocolDefinitions collection can contain both portocols for the Firewall service and protocols for application filters.
FPCFirewallClientConfig | FPCFirewallClientConfig |
FPCFirewallChaining | FPCFirewallChaining |
FPCFirewallSession | FPCSessionsMonitorEntry in the FPCSessionsMonitor collection accessed through the SessionsMonitorFirewall property of the FPCSessionsMonitors object |
FPCFirewallSessions | FPCSessionsMonitor accessed through the SessionsMonitorFirewall property of the FPCSessionsMonitors object |
FPCFirewallSessionConnection | None |
FPCFirewallSessionConnections | None |
FPCFTPCacheConfiguration | FPCFTPCacheConfiguration |
FPCHTTPCacheConfiguration | FPCHTTPCacheConfiguration |
FPCIpPacketFilter | FPCPolicyRule | In ISA Server 2004, some of the system policy rules are equivalent to predefined IP packet filters from ISA Server 2000. Only dynamic packet filtering is supported in ISA Server 2004.
FPCIpPacketFilters | FPCSystemPolicyRules | In ISA Server 2004, some of the system policy rules are equivalent to predefined IP packet filters from ISA Server 2000. Only dynamic packet filtering is supported in ISA Server 2004.
FPCIpRange | FPCAddressRange or FPCIpRangeEntry |
FPCLAT | FPCIpRangeEntry in the FPCIpRangeSet collection for the network where a Firewall client resides |
FPCLATEntry | FPCIpRangeSet for the Internal network |
FPCLDT | FPCLDT |
FPCLDTEntry | FPCLDTEntry |
FPCListenEntry | FPCWebListener and FPCWebListenerProperties |
FPCListenEntries | FPCWebListeners |
FPCLog | FPCLog |
FPCLogs | FPCLogs |
FPCNetworkConfiguration | FPCNetworkConfiguration |
FPCPolicyElements | FPCRuleElements |
FPCPrimaryRoute | FPCPrimaryRoute |
FPCProtocolConnection | FPCProtocolConnection |
FPCProtocolConnections | FPCProtocolConnections |
FPCProtocolDefinition | FPCProtocolDefinition |
FPCProtocolDefinitions | FPCProtocolDefinitions |
FPCProtocolRule | FPCPolicyRule | In ISA Server 2004, an FPCPolicyRule object can represent an access rule, which can be based on a combination of a protocol rule and a site and content rule.
FPCProtocolRules | FPCPolicyRules |
FPCServerPublishingRule | FPCPolicyRule | In ISA Server 2004, an FPCPolicyRule object can represent an access rule, a server publishing rule, or a Web publishing rule.
FPCServerPublishingRules | FPCPolicyRules | In ISA Server 2004, a single FPCPolicyRules collection holds all access rules, server publishing rules, and Web publishing rules that are defined for the array object.
FPCPublishing | FPCPolicyRules | In ISA Server 2004, a single FPCPolicyRules collection holds all the server publishing rules and Web publishing rules (along with all the access rules) that are defined for the array object.
FPCRef | FPCRef |
FPCRefs | FPCRefs |
FPCRoutingRule | FPCRoutingRule | When an ISA Server 2000 routing rule is upgraded to an ISA Server 2004 routing rule, a corresponding cache rule (FPCCacheRule) with the same destinations must also be created.
FPCRoutingRules | FPCRoutingRules |
FPCSchedule | FPCSchedule |
FPCScheduledContentDownload | FPCScheduledContentDownload |
FPCScheduledContentDownloadConfig | FPCScheduledContentDownloadConfig |
FPCSchedules | FPCSchedules |
FPCSecurityDescriptor | None | This object is not applicable to ISA Server 2004 Standard Edition.
FPCServer | FPCServer |
FPCServers | FPCServers |
FPCSignaledAlert | FPCSignaledAlertInstance |
FPCSignaledAlerts | FPCSignaledAlerts | In ISA Server 2004, the run-time instances of the alert are held in FPCSignaledAlert collections, which are elements of this collection.
FPCSiteAndContentRule | FPCPolicyRule | In ISA Server 2004, an FPCPolicyRule object can represent an access rule, a server publishing rule, or a Web publishing rule.
FPCSiteAndContentRules | FPCPolicyRules | In ISA Server 2004, a single FPCPolicyRules collection holds all access rules, server publishing rules, and Web publishing rules that are defined for the array object.
FPCSnapinNode | FPCSnapinNode |
FPCSSLCertificate | FPCCertificate |
FPCSSLCertificates | FPCPolicyRule FPCCertificates |
FPCTunnelPortRange | FPCTunnelPortRange |
FPCTunnelPortRanges | FPCTunnelPortRanges |
FPCVendorParametersSet | FPCVendorParametersSet |
FPCVendorParametersSets | FPCVendorParametersSets |
FPCWebBrowserClientConfig | FPCWebBrowserClientConfig |
FPCWebFilter | FPCWebFilter |
FPCWebFilters | FPCWebFilters |
FPCWebProxy | FPCWebProxy |
FPCWebPublishingRule | FPCPolicyRule | In ISA Server 2004, an FPCPolicyRule object can represent an access rule, a server publishing rule, or a Web publishing rule.
FPCWebPublishingRules | FPCPolicyRules | In ISA Server 2004, a single FPCPolicyRules collection holds all access rules, server publishing rules, and Web publishing rules that are defined for the array object.
FPCWebRequestConfiguration | FPCWebListenerProperties |
FPCWebSession | FPCSessionsMonitorEntry in the FPCSessionsMonitor collection accessed through the SessionsMonitorWebProxy property of the FPCSessionsMonitors object |
FPCWebSessions | FPCSessionsMonitor accessed through the SessionsMonitorWebProxy property of the FPCSessionsMonitors object |
FPCWebSessionAdditionalInfo | FPCSessionsMonitorEntry in the FPCSessionsMonitor collection accessed through the WebProxy property of the FPCSessionsMonitors object |

See Also

About ISA Server Administration


Using ISA Server 2000 and ISA Server 2004 COM Objects Together [ISA Server 2004]

Using ISA Server 2000 and ISA Server 2004 COM Objects Together

ISA Server 2004 has new administration COM objects that are not compatible with the ISA Server 2000 administration COM objects. Some of the ISA Server 2004 administration COM objects have the same names as ISA Server 2004 COM objects, but they have different class identifiers (CLSIDs). Attempting to use ISA Server 2004 and ISA Server 2000 COM objects with the same name in a single application can result in compilation errors due to name collisions.

If you need to build a single C++ application that supports using both the ISA Server 2004 administration COM objects and the ISA Server 2000 administration COM objects, you can avoid name collisions by using the rename_namespace attribute of the #import directive to rename the namespace of the ISA Server 2004 interfaces when you include the Microsoft Internet Security and Acceleration Server 2004 Administration Library (Msfpccom.dll) in your application.

By using the rename_namespace attribute, you can instruct Visual C++ to generate the classes declared in the ISA Server 2004 .idl file under a namespace that differs from the one specified in the library itself. This way, even if the names of ISA Server 2000 and ISA Server 2004 interfaces are the same you can avoid the resulting name collisions.

The following code instructs Visual C++ to include the file Msfpccom.dll and to change the namespace for the ISA Server 2004 interfaces to FPC2004:

#import "%SystemDrive%\Program Files\Microsoft ISA Server 2004\msfpccom.dll"
        rename_namespace("FPC2004")

Then when using ISA Server 2004 interfaces in your code, you will need to qualify them with FPC2004.


ISA Server Administration Scripting [ISA Server 2004]

ISA Server Administration Scripting

The ISA Server administration object model gives developers a mechanism to extend the functionality of ISA Server. Scripting allows you to use the ISA Server administration COM objects to access and control any ISA Server computer within an organization. The administration objects allow for automation of all the tasks performed through ISA Server Management. This capability allows administrators to create scripts to automate repetitive and complex tasks requiring the use of ISA Server Management. These scripts can then be included in batch files. By programming with the same administration objects that ISA Server uses, developers can provide persistent and configurable data storage for their programs, and can have ISA Server notify programs when the configuration data has changed.

Note ISA Server 2004 does not provide full backward compatibility for programs and scripts written for ISA Server 2000.

Using Microsoft Management Console (MMC), developers can also customize ISA Server Management by adding new property pages, menus, toolbars, and buttons, and by extending the namespace. For examples of ISA Server Management customization, see Extending ISA Server Management.

The following topics demonstrate how administrative tasks performed using ISA Server Management can be automated through the use of the administration objects:

  • Getting Started with Administration COM Objects
  • Extending ISA Server Storage
  • Configuring Arrays
  • Configuring Schedules
  • Defining Groups of Users
  • Managing the ISA Server Cache
  • Configuring Add-ins
  • ISA Server Administration Script Samples

Note The Microsoft Visual Basic® and Visual Basic Scripting Edition (VBScript) samples provided in this documentation are meant to demonstrate use of the ISA Server administration objects. For clarity, the samples ordinarily do not include error handling. It is important that your programs and code include error handling. Error handling is demonstrated in Cut-and-Paste ISA Server Administration Functions.


Getting Started with the Administration COM Objects [ISA Server 2004]

Getting Started with the Administration COM Objects

To start using the administration COM objects, set up your development environment using either of the following procedures, depending on whether you use Microsoft® Visual Basic® or C++. You must have, at a minimum, the administration tools of ISA Server installed for the procedures to work. Example code for creating administration scripts in Visual Basic Scripting Edition (VBScript), including step-by-step examples, is provided in ISA Server Administration Script Samples.

To start using the administration COM objects with Visual Basic

  1. Open Microsoft Visual Studio .NET.
  2. On the Start Page, click New Project.
  3. Under Project Types, click Visual Basic Projects.
  4. Under Templates, click Console Application if you want to create a command-line application, or Windows Application if you wnat to create an application with a Windows user interface, and then click OK.
  5. On the Project menu, click Add Reference.
  6. On the COM tab, select Microsoft Internet Security and Acceleration Server 2004 Administration Library from the dialog box that appears. This library is defined in Msfpccom.dll, which is a file included with ISA Server. Therefore, you need to have ISA Server installed for access to this library. Adding this library as a reference will make the administration COM objects available to your project.
  7. Create an instance of the root ISA Server object as described in Creating the Root ISA Server Object.
  8. Write your program. See Add a Schedule for an introductory example.
  9. To apply your changes, you must call the Save method on an applicable object.

If you are using Visual Basic Scripting Edition (VBScript) and would like to use enumerated types, see Using Enumerated Types in Scripts.

Note Unless otherwise noted, the examples in this section are written in Visual Basic, but you can use any language to script with the administration COM objects. If, for example, you script with VBScript, you can use any text editor to create the scripts.

Include the file Msfpccom.dll by using the following line of code:

#import "%SystemDrive%\Program Files\Microsoft ISA Server 2004\msfpccom.dll"

The file Msfpccom.idl contains the definitions of the ISA Server administration COM objects.

For an example of an administration task performed using C++ code, see Adding a Schedule Using C++.

To start using the administration COM objects with C++

    Topics in this section

    This section contains the following topics:

    • Creating the Root ISA Server Object
    • Restarting Services after Configuration Changes
    • Using Enumerated Types in Scripts
    • Managing Dependent Objects
    • Managing Collections
    • ISA Server Management for Standard Edition and Stand-Alone Servers
    • ISA Server Management from Active Server Pages


Creating the Root ISA Server Object [ISA Server 2004]

Creating the Root ISA Server Object

You can access almost all ISA Server administration COM objects through a single root object. You must first create this root object and then use its properties to access subordinate objects in the object model. All server arrays and other configuration settings are accessed through the root object.

To create this root object in a scripting language such as Microsoft Visual Basic Scripting Edition (VBScript) or Microsoft JScript®, use the CreateObject function. Use the class name "FPC.Root", as in these examples:

  • VBScript
    Set root = CreateObject("FPC.Root")
  • JScript
    root = new ActiveXObject("FPC.Root");

When creating the root object in Visual Basic, use the following:

Dim root As New FPCLib.FPC

CreateObject is also available to Visual Basic programmers and so, alternatively, the following can be used:

Dim root As FPCLib.FPC
Set root = CreateObject("FPC.Root")

Creation of the root object is the first step in all ISA Server scripts. If you are using Visual Basic, you must have the Microsoft Internet Security and Acceleration Server 2004 Administration Library selected as a project reference to create this object. For more information on creating a project reference in Visual Basic, see Getting Started with Administration COM Objects.

When using the administration COM objects in C++, you can use the following code to create the root object and a smart pointer to the IFPC interface:

HRESULT hr;

// Initialize the COM library.
hr = CoInitialize(NULL);

// Create the ISA Server root object.
FPCLib::IFPCPtr sipRoot;

hr = sipRoot.CreateInstance("FPC.Root");

If you are using C++, you must first import the Msfpccom.dll file so that the ISA Server administration COM objects can be used. For more information on importing the Msfpccom.dll file, see Getting Started with Administration COM Objects.

Although almost all ISA Server administration COM objects can be accessed through a single root object, the FPCFilterExpressions collection is not part of the object hierarchy based on the FPC root object and must be created separately. The following VBScript example creates an instance of the FPCFilterExpressions collection:

Set filter = CreateObject("FPC.FPCFilterExpressions")

When creating the filter expressions collection in Visual Basic, use the following:

Dim root As New FPCLib.FPCFilterExpressions

or

Dim root As FPCLib.FPCFilterExpressions
Set root = CreateObject("FPC.FPCFilterExpressions")

When creating the filter expressions collection in C++, you can use the following code to create the collection and a smart pointer to the IFPCFilterExpressions interface:

HRESULT hr;
FPCLib::IFPCFilterExpressionsPtr sipFilterExpressionsCol;

hr = sipFilterExpressionsCol.CreateInstance("FPC.FPCFilterExpressions");

Creating the Root Object for Remote Administration

A script that will be run from a remote administration computer must use the FPCDS object, as follows:

  • VBScript
    Set root = CreateObject("FPCDS.Root")
  • JScript
    root = new ActiveXObject("FPCDS.Root");

When creating the root object in Visual Basic, use the following:

Dim root As New FPCLib.FPCDS

OR

Dim objFPC As New FPCLib.FPC
Set root = CreateObject("FPCDS.Root")

For more information on the FPCDS object, see FPC.


Restarting Services after Configuration Changes [ISA Server 2004]

Restarting Services after Configuration Changes

Configuration changes are applied only after the new settings are written to persistent storage and reloaded to the services that use them. Most changes can be applied dynamically without restarting any services. However, some configuration changes that you make require restarting the Microsoft Firewall service.

The following actions require restarting the Firewall service:

  • Adding, removing, enabling, or disabling an application filter
  • Enabling or disabling IP routing
  • Increasing or decreasing the percentage of physical memory used for caching
  • Reducing or increasing cache size
  • Modifying low-level settings
  • Modifying a tunnel port range
  • Adding or removing a tunnel port range
  • Modifying the settings for the ISA Server Web proxy

The Save method recursively writes all of the properties of an object and its subobjects to persistent storage. For a collection, the method also writes all of its elements and their properties to persistent storage.

The Save method has two parameters that control whether the Firewall service will be restarted and whether the new configuration settings will be reloaded to the services:

  • The fResetRequiredServices parameter indicates whether the Firewall service will be restarted if it needs to be restarted for any of the changes saved to take effect.
  • The fReloadConfiguration parameter indicates whether the call will include synchronous reloading of all changes that can be applied dynamically without restarting the Firewall service.

If the configuration settings being used by the ISA Server services are not updated when new values are written to persistent storage, the configuration settings used by each service will not be updated until the service is restarted or the new settings are reloaded by another call to the Save method.

We recommend making multiple configuration changes and then applying all the changes in a single call to the Save method on an object that contains all the other objects with configuration changes as subobjects. All the unsaved changes can be applied by restarting the required services by using either of the following techniques:

  • Calling the Save method with both the fResetRequiredServices and fReloadConfiguration parameters set to True on an object that contains all the other objects with configuration changes as subobjects.
  • Calling the Save method with fResetRequiredServices set to False and fReloadConfiguration set to True on an object that contains all the other objects with configuration changes as subobjects and then calling the RestartServices method of the FPCArray object. Alternatively, services can be stopped and started through ISA Server Management, as described in the ISA Server product documentation.

At any time, you can ascertain which services need to be restarted to apply unsaved changes by calling the GetServiceRestartMask method. This method retrieves a bitmask that specifies which services need to be restarted for any of the currently unsaved changes in the object on which it was called and all of its subobjects to take effect. Then you can apply the unsaved changes using the techniques described in the previous list.


Using Enumerated Types in Scripts [ISA Server 2004]

Using Enumerated Types in Scripts

Unlike Visual Basic or Microsoft Visual C++®, scripting languages, such as Visual Basic Scripting Edition (VBScript) or JScript®, do not support the use of enumerated values.

For this reason the Internet Security and Acceleration Server 2004 SDK includes two files that define as constants the enumerated values used in ISA Server.

The file Fpccfg.vbs defines enumerated values in VBScript format.

The file Fpccfg.js defines enumerated values in JScript format.

To use enumerated types when composing VBScript or JScript script files, copy the relevant constant definitions from the relevant Fpccfg file to the constant declarations in your code.

For example, include the following code in the declarations section of your script:

const fpcRuleActionDeny = 1
const fpcAllIpTraffic = 0
const fpcAppliesToAllContent = 0

The declaration of constants allows you to write the following:

Set root = CreateObject("FPC.Root")

Dim array       ' An FPCArray object
Dim policyrules ' An FPCPolicyRules collection
Dim rule        ' An FPCPolicyRule object

Set array = root.GetContainingArray
Set policyrules = array.ArrayPolicy.PolicyRules
Set rule = policyrules.AddAccessRule("Deny All Content Always Rule")
rule.Action = fpcRuleActionDeny
rule.AccessProperties.ProtocolSelectionMethod = fpcAppliesToAll
rule.AccessProperties.AppliesToContentMethod = fpcAppliesToAllContent
rule.SetAppliesAlways

If you always declare the appropriate constants in your declarations section at the beginning of each script, you can use enumerated types as you use them in C++ programs.

Alternatively, you can achieve the same effect by hard-coding the values, as shown in the following code:

Set array = root.GetContainingArray
Set policyrules = array.ArrayPolicy.PolicyRules
Set rule = policyrules.AddAccessRule("Deny All Content Always Rule")
rule.Action = 1
rule.AccessProperties.ProtocolSelectionMethod = 0
rule.AccessProperties.AppliesToContentMethod = 0
rule.SetAppliesAlways

These lines will perform the same task as the previous code lines, without the use of enumerated types.

When composing Windows script (.wsf) files that will run in a Windows Script Host environment, the constants can be included by including a <reference> element. The following code example, which displays the name of each network rule defined for the local computer followed by the value of its RoutingType property, shows how to include the ISA Server administration COM library in a .wsf file:

<job id="main">
    <reference object="FPC.Root"/>
    <script language="VBScript">
        ' Create the root obect.
        Set root = CreateObject("FPC.Root")

        ' Declare the other objects needed.
        Dim array         ' An FPCArray object
        Dim networkrules  ' An FPCNetworkRules collection
        Dim networkrule   ' An FPCNetworkRule object

        ' Get references to the array object
        ' and the network rules collection.
        Set array = root.GetContainingArray()
        Set networkrules = array.NetworkConfiguration.NetworkRules

        ' Display the name of each network rule defined
        ' for the array object followed by the value
        ' of its RoutingType property.
        For Each networkrule In networkrules
            Select Case networkrule.RoutingType
                Case fpcRoute  WScript.Echo networkrule.Name & ": fpcRoute"
                Case fpcNat    WScript.Echo networkrule.Name & ": fpcNat"
                Case Else      WScript.Echo networkrule.Name & ": Unknown value"
            End Select
        Next
    </script>
</job>

For more information, see Windows Script Host.

For more information about including type libraries containing definitions of constants in Windows script files, see Using Windows Script Files.

For information about security in Windows Script Host, see Security and Windows Script Host


Managing Dependent Objects [ISA Server 2004]

Managing Dependent Objects

Many ISA Server objects depend upon other objects. This means that you access dependent objects through the properties of their parent object. Keep the following considerations in mind as you manage these dependent objects in your code:

  • When adding an object that contains a reference to another object or when modifying the name of the referenced object, ISA Server attempts to verify the existence of the referenced object. If the referenced object cannot be verified, the operation fails.
  • When removing an object that is referenced by another object, ISA Server checks all instantiated objects to learn whether there are other references to the deleted object. If such references exist, the operation fails.


Managing Collections [ISA Server 2004]

Managing Collections

A collection is an object that holds many individual objects of the same type. Usually, the name of the collection will be the plural of the name of the individual object types within the collection; for example, the FPCNetworkRules collection holds FPCNetworkRule objects.

Collections allow you to quickly assign settings to multiple objects of the same type with a script. For example, a collection is used to hold the policy rules, in the form of FPCPolicyRule objects. You can easily make changes to the rules in a collection with a simple script. See Collection Methods and Properties, for specific method and property information.

ISA Server administration object collections do not support nested For Each loops on the same collection object. For example, the following nested loops will not work because both loops operate on the same collection object:

For Each Rule1 in Array.ArrayPolicy.PolicyRules
    For Each Rule2 in Array.ArrayPolicy.PolicyRules
        MsgBox Rule1.Name & Rule2.Name
    Next
Next

The following pair of nested For Each loops will work because each loop applies to a different collection object:

For Each Array in Arrays
    For Each Rule in Array.ArrayPolicy.PolicyRules
        MsgBox Rule.Name
    Next
Next


Collection Methods and Properties [ISA Server 2004]

Collection Methods and Properties

All the collections that are defined in the ISA Server administration object model have a similar set of methods and properties, which are all or a combination of the following.

Method | Description
Save | Writes the current values of all the properties of the collection and its elements to persistent storage. Modifications made to the collection will not be saved until after this method is called. The Save method is recursive, so calling the Save method of a collection will save the data for every subobject within the collection.
Refresh | Reads the values of all the properties of the collection and its elements from persistent storage. The Refresh method does not check whether there are any unsaved changes made to the elements, so all changes made after the last Save method call will be lost. The Refresh method is useful when you want to cancel changes that have been made but not yet saved with the Save method. The Refresh method is recursive, so calling the Refresh method of a collection will read the data for every subobject within the collection.
Add | Adds an element to the collection, and returns a reference to the newly created element. This method takes a string parameter that identifies the new element. The string parameter can be used later to retrieve the element by using the Item method. To save this new element to persistent storage, call the Save method.
Remove | Removes a specified element from the collection. This method takes a string parameter or index of the element to be removed from the collection.
Item | Returns the requested element from the collection. This method retrieves an element by an index that is an integer value. ISA Server collection indices are one-based, meaning that the items are numbered from 1 upward. There is no element with an index of 0. In some collections, the Item method can retrieve an element by using the name of the element, which is a string value.

Property | Description
_NewEnum | Retrieves an enumerator object for the collection. An enumerator object provides serial access to the elements of the collection.
Count | Returns an integer value of the number of elements in the collection.
VendorParametersSets | Retrieves an FPCVendorParametersSets collection for the storing and loading of custom data into the collection. The VendorParametersSets property is designed to integrate third-party extensions into ISA Server.

Most of the ISA Server collections work in the same way. For specific descriptions, see the individual collection reference pages.

With Microsoft® Visual C++®, you can browse a collection to find a particular item by using the _NewEnum property or the Item method. ISA Server collections include both the _NewEnum property and the Item method. The _NewEnum property retrieves a pointer to the IUnknown interface of an enumerator object that implements an IEnumVARIANT interface for the collection. An interface pointer to the IEnumVARIANT interface of the enumerator object can be retrieved by calling QueryInterface on the IUnknown interface returned.

Note In Visual Basic®, you do not need to explicitly use the _NewEnum property, because it is used implicitly in For Each...In...Next constructs.


ISA Server Management for Standard Edition and Stand-Alone Servers

Certain methods, method parameters, parameter values, properties, and enumerated types are available only for ISA Server Enterprise Edition arrays. They are not available for ISA Server Standard Edition, or for stand-alone servers in the Enterprise Edition.

Methods

  • fpcFetchNoArrayRouting flag in FPCCacheContents.FetchURL

Properties

  • FPCWebProxy.CARPNameSystem


ISA Server Management from Active Server Pages [ISA Server 2004]

ISA Server Management from Active Server Pages

It is possible to access ISA Server administration objects from active server pages (ASPs). However, an ASP that uses ISA Server administration objects may not work under the default IIS setting that allows anonymous access, resulting in an access denied error. This is because when anonymous access is enabled, your ASP page will not have access to ISA Server storage, and there is also a possibility that permission issues will arise.

In order for the ASP to successfully use the ISA Server administration objects, you must disable anonymous access in IIS. Users with permissions will then be allowed to run the ASP page. Users without permissions will continue to get an access denied error, as they would have under anonymous access.

For information on how to disable anonymous access in IIS , see MSDN.


Extending ISA Server Storage [ISA Server 2004]

Extending ISA Server Storage

This section describes how to add extensions to Internet Security and Acceleration Server 2004 by using the FPCVendorParametersSets collection of FPCVendorParametersSet objects.

The vendor component must use the ISA Server central configuration management facilities to store its configuration. The facilities hide the storage location (local or Microsoft® Active Directory™), and provide support for promotion to Active Directory, central backup-and-restore capabilities, and sharing with all array members. A vendor can create new objects or associate additional information to system-defined objects by means of the FPCVendorParametersSets collection.

For example, an application filter can be added to ISA Server by using the FPCVendorParametersSets collection. This filter will then save the Multipurpose Internet Mail Extensions (MIME) data types that it needs to filter; this data will be stored by means of the collection's Save method and will be associated with that filter. After this extension is made to ISA Server, the vendor-specific data will be backed up with all other ISA Server data.

ISA Server storage is hierarchical. An extension developer can pick any node to extend. For example, you may want the extension to be per array, and therefore stored under the array node, or per computer, and therefore stored under the computer node.

To secure the information you store, use encrypted data in the FPCVendorParametersSet objects

See Also

FPCVendorParametersSet


Configuring Arrays [ISA Server 2004]

Configuring Arrays

Each ISA Server computer is associated with an FPCArray object that represents an ISA Server array and provides access to the configuration settings of the ISA Server computer. The FPCArray object is an element of an FPCArrays collection. In ISA Server 2004 Standard Edition, this collection contains only one FPCArray object, which provides access to the configuration settings of a single ISA Server computer.

The FPCArrays collection can be accessed through the Arrays property of the ISA Server root object FPC.

You can retrieve an individual FPCArray object by using either of two methods:

  • Item method of the FPCArrays collection
  • GetContainingArray method of the FPC root object

The Item method of the FPCArrays collection retrieves an FPCArray object that you identify by index or name. Here is a VBScript example:

Set root = CreateObject("FPC.Root")
Dim array
Set array = root.Arrays(1)

The GetContainingArray method of the FPC root object retrieves the FPCArray object that represents the array associated with the current ISA Server computer. The current ISA Server computer is the computer that executes the code calling this method. You can quickly retrieve the FPCArray object for this array by using code similar to this:

Set root = CreateObject("FPC.Root")
Dim array
Set array = root.GetContainingArray

The FPCArray object has properties that provide access to other parts of the administration object model, a factor that can be useful when setting up an ISA Server computer.

See Also

ISA Server Array Examples


ISA Server Array Examples [ISA Server 2004]

ISA Server Array Examples

The following code uses the FPCArray.Servers property to return the name of an individual server.

Dim root As New FPCLib.FPC
Dim serverName As String
Dim array1 As FPCArray
Set array1 = root.Arrays(1)
serverName = array1.Servers(1).Name
MsgBox serverName

The following code retrieves the name of the containing array by using the GetContainingArray method.

Dim root As New FPCLib.FPC
Dim currentArray As String
currentArray = root.GetContainingArray.Name
MsgBox currentArray


Configuring Schedules [ISA Server 2004]

Configuring Schedules

You can use the ISA Server administration COM objects to add, modify, or delete a schedule. Each ISA Server schedule is represented by an FPCSchedule object within the FPCSchedules collection.

This section contains the following topics:

  • Add a Schedule
  • Modify a Schedule


Add a Schedule [ISA Server 2004]

Add a Schedule

The schedules collection is accessed through the Schedules property of the FPCPolicyElements object, as shown in the examples in this topic:

  • Adding a Schedule Using Visual Basic
  • Adding a Schedule Using C++


Adding a Schedule Using Visual Basic [ISA Server 2004]

Adding a Schedule Using Visual Basic

The following is a Visual Basic code fragment that adds a new schedule called "Extended Work Hours," which includes all hours on all days:

Dim root As New FPCLib.FPC
' Declare a schedule collection.
Dim mySchedules As FPCSchedules
' Declare a schedule object.
Dim newSchedule As FPCSchedule
' Retrieve the schedule collection of the current array.
Set mySchedules = root.GetContainingArray.PolicyElements.Schedules
' Add the new Schedule.
Set newSchedule = mySchedules.Add("Extended Work Hours")
' Set the schedule days.
newSchedule.Set fpcALL_WEEK, fpcALL_DAY
' Save the changes.
mySchedules.Save

Note that the changed schedule is not saved to persistent storage until the last line of code, where the Save method is called.

See Also

FPCSchedule, Modify a Schedule


Adding a Schedule Using C++ [ISA Server 2004]

Adding a Schedule Using C++

The following is a C++ code fragment that adds a new schedule called "Extended Work Hours," which includes all hours on all days. This code was written as a Windows Console Application. To use this code:

  1. In Visual C++, create a new Win32 Console Application.
  2. Select the default empty project.
  3. Create a new C++ source file in the workspace.
  4. Paste the following code into the C++ source file, and build the project.
    //Import the ISA Server Msfpccom.dll file so that ISA Server COM objects can be used.
//Use the path to your ISA Server installation directory, or search for Msfpccom.idl.

#import "d:\Program Files\Microsoft ISA Server\msfpccom.dll"
#include <iostream.h>
int main ()
{
    try
    {
        // Define variables.
        HRESULT hr;

        //Initialize the COM library on the current thread.
        hr = CoInitialize( NULL );

        {
            // Define variables.
            FPCLib::IFPCPtr sipRoot;
            FPCLib::IFPCSchedulesPtr sipMyScheduleCol;
            FPCLib::IFPCSchedulePtr sipMySchedule;

            // Create the ISA Server root object.
            hr = sipRoot.CreateInstance("FPC.Root");
            //Retrieve the schedules collection.
            sipMyScheduleCol = sipRoot->GetContainingArray()->PolicyElements->Schedules;
            //Add the new schedule.
            sipMySchedule = sipMyScheduleCol->Add("My New Schedule");
            //Set the schedule.
            sipMySchedule->Set(FPCLib::fpcALL_WEEK, FPCLib::fpcALL_DAY);
            //Save your changes.
            sipMyScheduleCol->Save();
        }
    }
    catch (_com_error& e)
    {
        cout <<
            "Error. HRESULT message is: \"" <<
            e.ErrorMessage() <<
            "\" (" <<
            e.Error() <<
            ")" <<
            endl;
        if (e.ErrorInfo())
        {
            cout << (char *)e.Description() << endl;
        }
    }

        CoUninitialize();

        return 0;
}
  5. Run the application.

See Also

FPCSchedule, Modify a Schedule


Modify a Schedule [ISA Server 2004]

Modify a Schedule

The following Visual Basic code fragment modifies the schedule example shown in Add a Schedule by using the UnSet method of the FPCSchedule object. The "Extended Work Hours" schedule is changed so that it includes all hours of the day, but only the days Monday through Friday. This is done by unsetting the days Saturday and Sunday:

Dim root As New FPCLib.FPC
' Declare a schedule collection.
Dim mySchedules As FPCSchedules
' Declare a schedule object.
Dim mySchedule As FPCSchedule
' Get the schedule collection of the current array.
Set mySchedules = root.GetContainingArray.PolicyElements.Schedules
' Retrieve the "Extended Work Hours" schedule.
Set mySchedule = MySchedules("Extended Work Hours")
' Remove Saturday and Sunday from the schedule.
mySchedule.Unset fpcSAT, fpcALL_DAY
mySchedule.Unset fpcSUN, fpcALL_DAY
' Save changes.
mySchedules.Save

Again, note that the changes will not be saved to persistent storage until the last line of code, where the Save method is called.

See Also

FPCSchedule, Add a Schedule


Defining Groups of Users [ISA Server 2004]

Defining Groups of Users

There are two types of users in Internet Security and Acceleration Server 2004. The first is the Active Directory user or group, represented by an FPCAccount object. The FPCAccounts collection is a collection of those objects.

The second type is the non-Windows user. This is a user who has been authenticated using an authentication scheme other than that of Active Directory. This user is represented by an FPCNonWindowsUser object. The FPCNonWindowsUsers collection is a collection of those objects.

You can also create a set of users, represented by a FPCUserSet object. This set can contain both FPCAccounts collections and FPCNonWindowsUsers collections. The FPCUserSets collection is a collection of FPCUserSet objects.


Managing the ISA Server Cache [ISA Server 2004]

Managing the ISA Server Cache

The ISA Server administration COM objects allow you to administer the cache programmatically, automate administrative tasks related to the cache, and extend cache performance by using the FetchURL method.

This section contains the following topics:

  • Introduction to the ISA Server Cache Objects
  • Extending the Cache


Introduction to the ISA Server Cache Objects [ISA Server 2004]

Introduction to the ISA Server Cache Objects

The ISA Server cache is administered through the cache COM objects. The objects are described briefly here and in more detail in the Administration Reference section.

See the ISA Server Administration Object M odel to view how the cache-related objects fit into the entire object hierarchy.

FPCCache Object

The FPCCache object is primarily a container for most of the configuration objects listed below. You can access the FPCCacheConfiguration and FPCCacheContents objects and the FPCScheduledContentDownloadcollection directly through this object. You can access the FPCActiveCacheConfigurationobject and the FPCCacheRules through the FPCCacheConfiguration object.

This object is a property of the FPCArray object and administers the cache for the entire array.

FPCCacheConfiguration Object

The FPCCacheConfiguration object is primarily a container for the FPCActiveCacheConfigurationobject and the FPCCacheRules collection.

FPCActiveCacheConfiguration Object

The FPCActiveCacheConfiguration object provides access to the active cache configuration settings of an ISA Server computer.

Active caching is the opposite of passive caching, which is caching in reaction to a specific user request for content. If there is room in the cache, the requested object will be stored in the cache.

Through active caching, ISA Server can automatically determine the most popular Web sites visited by its clients, determine how frequently those sites update their content, and then automatically obtain and cache the new content when the old content in the cache has expired. Once it is activated, active caching works automatically.

FTPCacheConfiguration Object

The FPCFTPCacheConfiguration object provides access to the FTP cache configuration settings of an ISA Server computer. FTP caching is the caching of FTP objects. You can use this object to choose whether to activate FTP object caching and configure FTP caching settings.

HTTPCacheConfiguration Object

The FPCHTTPCacheConfiguration object provides access to the HTTP cache configuration settings of an ISA Server computer. HTTP caching is the caching of HTTP objects. You can use this object to choose whether to activate HTTP object caching and configure HTTP caching settings.

FPCCacheRules Collection

The FPCCacheRules collection is a collection of FPCCacheRule objects, each representing a cache rule. A cache rule defines cache policy for all content or specific content groups, including

  • How objects are provided from the cache
  • Whether objects should be stored in the cache
  • The size of objects that can be cached
  • Whether SSL responses will be cached
  • HTTP cache configuration through the FPCHTTPCacheConfiguration object.
  • HTTP cache configuration through the FPCFTPCacheConfiguration object.

FPCCacheContents Object

The FPCCacheContents object permits greater control over active caching through the FPCCacheContents.FetchUrl method. This method is used to specify to the cache the URLs to be prefetched or actively retrieved from the Internet and stored in the cache.

FPCScheduledContentDownload Collection

The FPCScheduledContentDownload collection allows you to create a list of predefined scheduled content download tasks. Each task is represented by an FPCScheduledContentDownloadConfig object.

FPCCacheDrive Object and FPCCacheDrives Collection

The FPCCacheDrives collection is a property of the FPCServer object and represents a collection of FPCCacheDrive objects. Each FPCCacheDrive object represents a cache drive. The FPCCacheDrive objects allow an administrator to programmatically access and adjust the size of the drives.


Extending the Cache [ISA Server 2004]

Extending the Cache

You can use the FetchUrl method to extend the cache or to delete a cached object using FetchUrl.

This section contains the following topics:

  • Using FetchUrl to Extend the Cache
  • Using FetchUrl to Delete a Cached Object


Using FetchUrl to Extend the Cache [ISA Server 2004]

Using FetchUrl to Extend the Cache

The Web proxy normally fetches objects from the Internet and caches them automatically as proxy clients request them (passive caching). In addition, the Web proxy automatically keeps certain popular objects "fresh" within its cache by fetching them itself (active caching). However, occasions occur when an application needs a mechanism to override these automatic operations and exercise greater control over the source of objects that are placed in the cache, or the length of time that they are to remain cached. For example, an application may need to:

  • Make data downloaded from a nonstandard network source (such as a satellite or private network) accessible to Web browsers as if it were normal Internet data.
  • Update certain objects within the the Web proxy's cache on a fixed schedule.
  • Place objects in the Web proxy's cache that would normally not be cached.

The FetchUrl function facilitates these operations by allowing an application to cause the Web proxy to fetch an object from a given location (FetchUrl) and store the object in its cache. The object may also be assigned a new name (CacheUrl), which Web proxy clients will use to retrieve the object from the Web proxy cache and/or assigned a particular time to live (TTL) within the cache.

FetchURL Usage Examples

Here are three examples of how you might use the FetchUrl method.

Example 1

Consider a proxy installation with a very slow Internet connection that requires quick access to the fictional Web site called "fiction.microsoft.com". One solution to this problem would be for the owners of fiction.microsoft.com to produce a CD-ROM that contained all the content found on their Web site and mail it weekly to the proxy customer. An application could use this function to cause the proxy to fetch the data from the CD-ROM and store it in the cache as if it were data from the Internet fiction.microsoft.com site, with a TTL of one week. A complication is that the proxy only supports the HTTP, FTP, and Gopher protocols, so the data cannot be fetched directly from the CD-ROM. There are several possible solutions to this problem:

  • The data on the CD-ROM could be copied into the publishing directory of an HTTP or FTP server or a publishing server could be configured to directly serve the data from the CD-ROM. This is a good solution if the data is provided as normal files (HTML, GIF, and so on) without any HTTP headers already added from the original publishing server, fiction.microsoft.com. If the files already contained HTTP headers from fiction.microsoft.com, serving the data from another HTTP server would add a second set of headers which would render the objects unintelligible to the proxy or to browsers.
  • If the files already contain a set of HTTP headers (for example, if they were the product of a raw Internet download of the contents of fiction.microsoft.com instead of a copy of the data files from the fiction.microsoft.com Web servers), the easiest solution might be to write an alternative HTTP server application that would serve up the data files without adding HTTP headers. The HTTP server application would call FetchUrl to listen on the external socket and receive the data before it gets to the Web proxy. This would allow the application to have complete control over the data being sent to the Web proxy. This method is also particularly useful when the application needs to perform simple housekeeping operations on cached objects such as generating a "304 Not Modified" HTTP response to leave an object unmodified but extend its TTL, or a "404 Gone" response to delete an object from the cache.

Example 2

In a Web hosting scenario, your organization may regularly update part of the information on its Web site. All or part of the Web site data can be cached on an ISA Server cache. When the Web site information changes, the cache will have to be updated. You can use the FetchUrl method to streamline the update process. In the central database for the Web site information, create an application that generates a file listing all of the files that have changed. Use FetchUrl to retrieve that file. Parse the file to create a list of files that require updating. Then use FetchUrl to retrieve each updated file from the database. This use of FetchUrl allows you to update only the cache files that have changed.

Example 3

In a Web hosting scenario, users may upload updated Web objects to your publishing server at unpredictable frequencies. These items will not be cached by ISA Server if the existing cached object still has a valid TTL. You can use FetchURL to delete the cached object from the cache, so that the updated object will be cached.

Remarks

To retrieve an HTTP object in response to a call to FetchUrl, the Web proxy applies the normal HTTP GET method to the URL specified by FetchUrl. If there is already a cached copy of the URL specified by CacheUrl (either loaded into the proxy previously by normal operations or by an earlier call to FetchUrl) the proxy includes an "If-Modified-Since" HTTP header in the request, also known as a conditional GET. The response to a conditional GET may be either a new copy of the data that will be stored in the cache or an HTTP status code 304 "Not Modified" response which will cause the proxy to extend the TTL of the object without changing the contents of the data in the cache.

If FetchUrl is used on an array rather than a stand-alone server, the object is automatically fetched by the single array member that is the designated owner of that object according to the CARP algorithm.

Example Code

The following code sample demonstrates VBScript usage of FetchUrl.

The example companies, organizations, products, domain names, e-mail addresses, logos, people, places, and events depicted herein are fictitious. No association with any real company, organization, product, domain name, email address, logo, person, places, or events is intended or should be inferred.

' When using VBScript, the enum values should be declared as constants
' or explicit numeric values must be used instead

Const fpcTtlIfNone = 1
Const fpcFetchSynchronous = 4

customTTL = 10     '

Set root = CreateObject("FPC.Root")
Set myCache = root.GetContainingArray.Cache.CacheContents

' Fetch "http://www.wideworldimporters.com/home.htm" and to store it in the cache under the name "http://cache_server/home.htm"

myCache.FetchURL "http://www.wideworldimporters.com/home.htm", "http://cache_server/home.htm",  customTTL,  fpcTtlIfNone +  fpcFetchSynchronous


Using FetchUrl to Delete a Cached Object [ISA Server 2004]

Using FetchUrl to Delete a Cached Object

You can use the FetchUrl method to delete a cached HTTP object. Deleting objects by means of FetchUrl works for any cached object, whether or not it was cached by using FetchUrl.

To delete an HTTP object from the cache, set lpszFetchUrl = <empty string>, lpszCacheUrl = <cachedURL>, TtlInMinutes = 0 and Flags = 0.

Note With flags = 0, the default flag setting, the operation is performed as a non-blocking operation. If flags = FETCH_SYNCHRONOUS, it is a blocking operation.


Configuring Add-ins [ISA Server 2004]

Configuring Add-ins

ISA Server 2004 can be extended by add-ins, whose configuration settings can be accessed through the FPCExtensions object. ISA Server add-ins include application filters, which are represented by elements of the FPCApplicationFilters collection, and Web filters, which are represented by elements of the FPCWebFilters collection.

Each FPCApplicationFilter object or FPCWebFilter object representing an add-in is associated with a globally unique identifiers (GUID) that identifies the add-in. An object representing an add-in and other policy-defining objects can provide access to a collection of vendor parameters sets (FPCVendorParametersSets) that can contain configuration settings for add-ins.

This topic describes some details of configuring the following two add-ins:

  • DNS Filter
  • FTP Filter
  • HTTP Filter

DNS Filter

DNS Filter is an application filter that is installed with ISA Server. It intercepts and analyzes DNS traffic destined for the Internal network. DNS Filter is the backbone of the ISA Server intrusion detection mechanism. Intrusion detection identifies when an attack is attempted against your network and performs a set of configured actions, which are defined by alerts, in case of an attack. To detect unwanted intruders, ISA Server compares network traffic and log entries to well-known attack methods. Suspicious activities trigger alerts. Actions include connection termination, service termination, sending e-mail messages, and logging.

The following VBScript code example configures DNS Filter by setting values in the vendor parameters set associated with the filter in the collection of vendor parameters sets accessed through the object representing DNS Filter:

Set root = CreateObject("FPC.Root")
Set array = root.GetContainingArray
Set attackDetection = array.ArrayPolicy.AttackDetection
Set dnsFilter = array.Extensions.ApplicationFilters.Item("{49FE2B2F-3BB4-495C-87C8-3890C3C35756}")

dnsFilter.Enabled = True
Set vpSets = dnsFilter.VendorParametersSets

On Error Resume Next
vpSets.Add "{D96C5E7F-5B13-4E1A-94A1-36CA7B54604E}", False, False
On Error Goto 0		' If a vendor parameters sets for DNS Filter already exists

vpSets.Item("{D96C5E7F-5B13-4E1A-94A1-36CA7B54604E}").Value("DNS_Intrusion_detection") = "1"
vpSets.Item("{D96C5E7F-5B13-4E1A-94A1-36CA7B54604E}").Value("DNS_Hostname_Overflow") = "1"
vpSets.Item("{D96C5E7F-5B13-4E1A-94A1-36CA7B54604E}").Value("DNS_Length_Overflow") = "1"
vpSets.Item("{D96C5E7F-5B13-4E1A-94A1-36CA7B54604E}").Value("DNS_Zone_Transfer") = "0"

vpSets.Save

FTP Access Filter

FTP Access Filter is an application filter that is installed with ISA Server. It enables FTP protocols. When running in read-only mode, FTP Access Filter blocks all commands in the control channel except the following commands: ABOR, ACCT, CDUP, CWD /0, FEAT, HELP, LANG, LIST, MODE, NLST, NOOP, PASS, PASV, PORT, PWD /0, QUIT, REIN, REST, RETR, SITE, STRU, SYST, TYPE, USER, XDUP, XCWD, XPWD, SMNT. This should block any writing to the server side. The default list of allowed commands can be replaced by a customized list that is written to the collection of vendor parameters sets (FPCVendorParametersSets) associated with the filter. The Firewall service must restarted for the new settings to take effect.

The following VBScript code example configures FTP Access Filter to allow only the USER and PASS commands by setting values in the vendor parameters set associated with the filter in the collection of vendor parameters sets accessed through the object representing FTP Access Filter:

Dim root
Dim ftpFilter
Dim vpSet

On Error Resume Next
Err.Clear
Set root = CreateObject("FPC.Root")

' Get the filter's administration object
Set ftpFilter = root.GetContainingArray.Extensions.ApplicationFilters("{680A928F-22B3-11d1-B026-0000F87750CB}")
If ftpFilter is Nothing Then
    Wscript.Echo "FTP Access Filter ({680A928F-22B3-11D1-B026-0000F87750CB}) is not installed in array."
    WScript.Quit
End If

' Get the vendor parameter set containing the filter's configuration.
Set vpSet = ftpFilter.VendorParametersSets.Item("{680A928F-22B3-11D1-B026-0000F87750CB}")

'If this vendor parameters set does not exist, create it.
If vpSet Is Nothing Then
    WScript.Echo "Adding a vendor parameters set ({680A928F-22B3-11D1-B026-0000F87750CB})"
    Err.Clear
    Set vpSet = ftpFilter.VendorParametersSets.Add("{680A928F-22B3-11D1-B026-0000F87750CB}",False)
    ftpFilter.VendorParametersSets.Save
End If

' Add the required parameter.
vpSet.Value("AllowReadCommands") = "USER PASS"
vpSet.Save

HTTP Filter

HTTP Filter is a Web filter that is installed with ISA Server. It can be configured to block HTTP requests based on the following:

  • Request payload length.
  • URL length.
  • HTTP request method, such as the POST, GET, or HEAD request method.
  • HTTP request file name extension, such as .exe, .asp, or .dll.
  • HTTP request or response header.
  • Signature or pattern in the request or response header or body.

New policy rules use a default HTTP filtering configuration, which is not defined in a vendor parameters set and cannot be exported to an XML file. In ISA Server Management, you can right-click the name of a policy rule and then click Configure HTTP to open the Configure HTTP policy for rule dialog box. After you click OK in this dialog box and click the Apply button, a new vendor parameters set containing the configuration for the HTTP Filter Web filter is created for the rule. This configuration can be exported from the vendor parameters set of the rule to an XML file and then imported from the XML file to other rules.

The following VBScript subprocedure, which is taken from the HttpFilterConfig.vbs sample on the ISA Server CD, exports the configuration for the HTTP Filter Web filter from the corresponding vendor parameters set of the specified policy rule to the specified file.

Sub ExportConfiguration(ruleName, fileName)
    const FilterGUID = "{f1076e51-bbaf-48ba-a2d7-b0875211e80d}"
    const Error_FileNotFound = &H80070002
    const ConfigParamName = "XML_POLICY"

    Dim rule, vpSets, vpSet
    Dim errorCode, errorDescript
    Dim xmlText
    Dim fso
    Dim file

    Set fso = CreateObject("Scripting.FileSystemObject")
    set rule = GetPolicyRule(ruleName)
    Set vpSets = rule.VendorParametersSets

    On Error Resume Next
    Set vpSet = vpSets.Item(FilterGUID)
    errorCode = Err.Number
    errorDescript = Err.Description
    On Error GoTo 0

    Select Case errorCode
        case 0:
        case Error_FileNotFound:
            WScript.Echo "The rule is using the default HTTP Filter configuration, which is not" & VbCrLf _
                       & "defined in a vendor parameters set and cannot be exported to an XML" & VbCrLf _
                       & "file."
            WScript.Quit
        case Else
            Err.Raise errorCode,, errorDescript
    End Select

    xmlText = vpSet.Value(ConfigParamName)
    Set file = fso.OpenTextFile(fileName, ForWriting, True)
    file.WriteLine(xmlText)
    file.Close

    WScript.Echo "The configuration was exported successfully."
End Sub

The following VBScript subprocedure, which is also taken from the HttpFilterConfig.vbs sample on the ISA Server CD, imports the configuration for the HTTP Filter Web filter from the specified file to a new vendor parameters set of the specified policy rule.

Sub ImportConfiguration(ruleName, fileName)
    const FilterGUID = "{f1076e51-bbaf-48ba-a2d7-b0875211e80d}"
    const Error_FileAlreadyExists = &H800700B7

    Dim rule, vpSets, vpSet
    Dim errorCode, errorDescript
    Dim xmlText
    Dim fso
    Dim file

    Set fso = CreateObject("Scripting.FileSystemObject")
    set rule = GetPolicyRule(ruleName)
    Set vpSets = rule.VendorParametersSets

    On Error Resume Next
    ' Create a vendor parameters set for the HTTP Filter Web filter
    ' in the vendor parameters sets collection of the specified rule.
    Set vpSet = vpSets.Add(FilterGUID, False)
    errorCode = Err.Number
    errorDescript = Err.Description
    On Error GoTo 0

    Select Case errorCode
        case 0:
        case Error_FileAlreadyExists:
            set vpSet = vpSets(FilterGUID)
        case Else
            Err.Raise errorCode,, errorDescript
    End Select

    Set file = fso.OpenTextFile(fileName)
    xmlText = file.ReadAll
    vpSet.Value(ConfigParamName) = xmlText

    rule.Save

    WScript.Echo "The configuration was imported successfully."
End Sub

However, the maximum header size is a global setting that resides in the vendor parameters set of HTTP Filter and applies to all rules.

The following VBScript subprocedure configures this setting using the value passed to it.

Sub SetNewSize(newLimit)
    const FilterGUID = "{f1076e51-bbaf-48ba-a2d7-b0875211e80d}"
    const ConfigParamName = "XML_POLICY"
    const Error_FileAlreadyExists = &H800700B7

    Dim httpFilter, vpSets, vpSet, newVal
    Dim errorCode, errorDescript
    Dim root

    Set root = WScript.CreateObject("FPC.Root")
    set httpFilter = root.GetContainingArray.Extensions.Webfilters.Item(FilterGUID)
    Set vpSets = httpFilter.VendorParametersSets

    On Error Resume Next
    Set vpSet = vpSets.Add(FilterGUID, False)
    errorCode = err.Number
    errorDescript = err.Description
    On Error GoTo 0

    Select case errorCode
        case 0:
        case Error_FileAlreadyExists:
            Set vpSet = vpSets.Item(FilterGUID)
        case Else
            Err.Raise errorCode,, errorDescript
    End Select

    newVal = "<Configuration MaxRequestHeadersLen="" " & newLimit & " ""/>"
    vpSet(ConfigParamName) = newVal
    httpFilter.Save
    WScript.Echo "The maximum header size was set successfully."
End Sub

See Also

ISA Server Administration Script Samples


ISA Server Administration Script Samples [ISA Server 2004]

ISA Server Administration Script Samples

The following script samples, which were developed using the ISA Server administration COM objects, are provided in the SDK\Admin\Samples folder on the ISA Server 2004 CD:

Name | Description
ActiveSessions.vbs | A script that creates and executes a query on the FPCSessionsMonitor collection for the active sessions of the Microsoft Firewall service and displays the active sessions that existed when the query started.
AddAdmin.vbs | A script that adds a specific user as an administrator with permissions to monitor the ISA Server computer and network activity, for example, to view logs and reports, but not to configure any specific monitoring functionality.
AddCacheRule.vbs | A script that creates a new URL set in the URL sets collection of the proxy server, adds URLs to the URL set, and creates two new cache rules for caching content with a fixed Time to Live (TTL) range from all sites on the External network except the sites in the new URL set.
AddConnectivityVerifier.vbs | A script that creates a new connectivity verifier.
AddRuleAndUrlSet.vbs | A script that creates a new URL set in the URL sets collection, adds sites to the URL set, creates a new access rule, and adds the new URL set to the objects referenced in the URLSets property of the access rule.
ConfigureAlerts.vbs | A script that retrieves the collection of alerts defined in the containing array, iterates through the collection, and sets the e-mail address associated with each alert definition.
ControlAccessByScheduleAndUserSet.vbs | A script that creates the access rules, user set, and URL set needed to allow a specific group of workers in an organization restricted access to the Internet. The group is allowed to access only the sites listed in the URL set and only during the hours specified in the "Work hours" schedule supplied with ISA Server 2004. All other workers using computers that belong to the Internal network are granted unlimited access to the Internet.
HttpFilterConfig.vbs | A script that exports the configuration for the HTTP Filter Web filter from the corresponding vendor parameters set of the specified policy rule to the specified file, or imports the configuration for the HTTP Filter Web filter from the specified file to a new vendor parameters set of the specified policy rule.
ActiveImportExport.vbs | A script that exports the configuration of the array for an ISA Server computer to a specified XML file or imports the configuration in a specified XML file to the array object of the ISA Server computer.
SetNetworkRelation.vbs | A script that creates a new network rule that defines a NAT relationship between any network belonging to the predefined All Protected Networks network set and the External network. This rule will apply to any new perimeter network created in the future because such a network will be included automatically in the All Protected Networks network set.
ShowICMPSystemPolicy.vbs | A script that retrieves the collection of system policy rules defined for an ISA Server computer and then implicitly uses the _NewEnum property to iterate through the collection and display the names of the system policy rules for ICMP along with the user sets to which each rule applies.

This section contains the following topics with code examples taken from the samples to help you write ISA Server administration scripts in Microsoft® Visual Basic® Scripting Edition (VBScript):

  • Step-by-Step Administration Script Examples, which contains several scripts with detailed explanations and embedded comments.
  • Cut-and-Paste ISA Server Administration Functions, which contains ready-to-use VBScript functions and code examples.


Step-by-Step Administration Script Examples [ISA Server 2004]

Step-by-Step Administration Script Examples

The following Microsoft® Visual Basic® Scripting Edition (VBScript) examples provide step-by-step procedures to create an ISA Server administration script. Each step is described in detail with links to the applicable reference pages. The following scripts are provided:

  • Adding Cache Rules
  • Adding an Access Rule
  • Controlling Access by a Schedule and a User Set
  • Exporting and Importing an ISA Server Configuration
  • Adding a Connectivity Verifier
  • Displaying Active Sessions


Adding Cache Rules [ISA Server 2004]

Adding Cache Rules

This VBScript example creates a new FPCURLSet object in the FPCURLSets collection of the ISA Server computer serving as a proxy, adds URLs to the URL set, and creates two new FPCCacheRule objects representing cache rules for caching content with a fixed range of Time to Live (TTL) values from all sites on the External network, except the sites in the new URL set. The script includes a single function, called AddCacheRule.

This example is included as the AddCacheRule.vbs script in the Sdk\Samples\Admin folder on the ISA Server 2004 CD.

The following procedure lists the steps used to add two cache rules in the code example that follows.

To add cache rules

  1. Define values from the FpcIncludeStatus and FpcTimeScale enumerations. For more information about using values defined in ISA Server enumerated types in scripts, see Using Enumerated Types in Scripts.
  2. Create an instance of the FPC COM object, which provides access to the other ISA Server administration COM objects.
  3. Declare an FPCArray object, an FPCCacheRules collection, an FPCURLSet object, an FPCURLSets collection, and two FPCCacheRule objects.
  4. Get references to the existing FPCArray object, FPCCacheRules collection, and FPCURLSets collection.
  5. Verify whether an FPCURLSet object named Not for Caching already exists. If it exists, remove it.
  6. Call the Add method of the URL sets collection to create a new set of URLs named Not for Caching that will be excluded from caching.
  7. Verify whether an FPCCacheRule object named Shorter TTL Cache Rule already exists. If it exists, remove it.
  8. Repeat the preceding step for an FPCCacheRule object named Excluded Cache Rule.
  9. Call the Add method of the cache rules collection to create a new cache rule named Shorter TTL Cache Rule that will allow the caching of content with a shorter TTL in response to requests sent to sites on the External network, except for the URLs specified in the Not for Caching URL set.
  10. Repeat the preceding step for a cache rule named Excluded Cache Rule that will prohibit the caching of content from the URLs specified in the Not for Caching URL set.
  11. Set the Description, URLSets, and HTTPConfiguration properties of the cache rules.
  12. Set the NeverCacheResponse property on the Excluded Cache Rule FPCCacheRule object to True.
  13. Call the Save method on the cache rules collection to write the changes to the new cache rules to persistent storage.

The following code can be saved to a .vbs file and run from a command prompt on a computer running ISA Server 2004.

Sub AddCacheRule()

    ' Define enumeration values.
    const fpcInclude = 0
    const fpcExclude = 1
    const fpcTimeInHours = 3

    ' Create the root object.
    Dim root  ' The FPCLib.FPC root object
    Set root = CreateObject("FPC.Root")

    'Declare the other objects needed.
    Dim array       ' An FPCArray object
    Dim rules       ' An FPCCacheRules collection
    Dim urlsets     ' An FPCURLSets collection
    Dim urlset      ' An FPCURLSet object
    Dim newRule1    ' An FPCCacheRule object
    Dim newRule2    ' An FPCCacheRule object

    ' Get references to the array object, the cache rules collection,
    ' and the URL sets collection.
    Set array = root.GetContainingArray
    Set rules = array.Cache.CacheConfiguration.CacheRules
    Set urlsets = array.RuleElements.URLSets

    ' If a URL set named "Not for Caching" already exists, remove it.
    On Error Resume Next
    Set urlset = urlsets.Item("Not for Caching")
    If Err.Number = 0 Then
        WScript.Echo "The Not for Caching URL set exists. Removing it ..."
        urlsets.Remove "Not for Caching"
        urlsets.Save
    End If

    WScript.Echo "Creating a new URL set for exclusion from caching ..."
    Set urlset = urlsets.Add("Not for Caching")
    urlset.Add "http://www.northwindtraders.com"
    urlset.Add "http://www.northwindtraders.com/*"
    urlsets.Save

    ' If a cache rule named "Shorter TTL Cache Rule" already exists, remove it.
    On Error Resume Next
    Set newRule1 = rules.Item("Shorter TTL Cache Rule")
    If Err.Number = 0 Then
        WScript.Echo "Shorter TTL Cache Rule exists. Removing it ..."
        rules.Remove "Shorter TTL Cache Rule"
        rules.Save
    End If

    ' If a cache rule named "Excluded Cache Rule" already exists, remove it.
    On Error Resume Next
    Set newRule2 = rules.Item("Excluded Cache Rule")
    If Err.Number = 0 Then
        WScript.Echo "Excluded Cache Rule rule exists. Removing it ..."
        rules.Remove "Excluded Cache Rule"
        rules.Save
    End If

    WScript.Echo "Creating new cache rules ..."
    Set newRule2 = rules.Add("Excluded Cache Rule")
    Set newRule1 = rules.Add("Shorter TTL Cache Rule")

    ' Set the descriptions of the new cache rules.
    newRule1.Description = "This rule caches content with a shorter TTL " & _
                           "in response to requests sent to sites on the " & _
                           "External network except for specific URLs."
    newRule2.Description = "This rule prohibits caching of content " & _
                           "from specific URLs."

    ' Add the External network to the first rule.
    newRule1.DestinationSelectionIPs.Networks.Add "External", fpcInclude

    ' Add the new URL set as an exception to the objects referenced by
    ' the URLSets property of the first cache rule and as an included
    ' object in the second cache rule.
    newRule1.UrlSets.Add "Not for Caching", fpcExclude
    newRule2.UrlSets.Add "Not for Caching", fpcInclude

    ' Set shorter TTLs for all requests to which the first rule applies.
    newRule1.HTTPConfiguration.ApplyBoundsToObjectsWithExpiration = True
    newRule1.HTTPConfiguration.MinInterval = minTTL
    newRule1.HTTPConfiguration.MaxIntervalUnits = fpcTimeInHours
    newRule1.HTTPConfiguration.MaxIntervalValue = maxTTL

    ' Set no caching for all requests to which the second rule applies.
    newRule2.NeverCacheResponse = True

    ' Save the changes to the new cache rules.
    rules.Save
    WScript.Echo "Done!"

End Sub

AddCacheRule


Adding an Access Rule [ISA Server 2004]

Adding an Access Rule

This VBScript example creates a new FPCURLSet object in the FPCURLSets collection of the ISA Server computer, adds sites to the URL set, creates a new FPCPolicyRule object representing an access rule, and adds the new URL set to the objects referenced in the URLSets property of the new access rule. The script includes a single function, called AddRuleAndUrlSet.

This example is included as the AddRuleAndUrlSet.vbs script in the Sdk\Samples\Admin folder on the ISA Server 2004 CD.

The following procedure lists the steps used to create a URL set and access rule in the code example that follows.

To add an access rule

  1. Define values from the FpcIncludeStatus and FpcProtocolSelectionType enumerations. For more information about using values defined in ISA Server enumerated types in scripts, see Using Enumerated Types in Scripts.
  2. Create an instance of the FPC COM object, which provides access to the other ISA Server administration COM objects.
  3. Declare an FPCArray object, an FPCPolicyRules collection, an FPCURLSet object, an FPCURLSets collection, and two FPCPolicyRule objects.
  4. Get references to the existing FPCArray object, FPCPolicyRules collection, and FPCURLSets collection.
  5. Call the Add method of the URL sets collection to create a new URL set that will be called Blocked Web Sites, and then use the Add method of the new URL set to add specific URLs to the set.
  6. Call the AddAccessRule method of the policy rules collection to create a new access rule named Deny Access to Some Web Sites that will deny access to the Web sites in the Blocked Web Sites URL set.
  7. Call the Add method of the FPCRefs collection for the Networks property of the FPCSelectionIPs object retrieved in the SourceSelectionIps property of the new rule to define the External network as the source network for the new access rule.
  8. Call the Add method of the FPCRefs collection retrieved in the URLSets property of the FPCAccessProperties object for the new rule to add the Blocked Web Sites URL set to the objects referenced by the URLSets property of the new access rule.
  9. Set the NeverCacheResponse property on the Excluded Cache Rule FPCCacheRule object to True.
  10. Call the Add method of the FPCRefs collection retrieved in the SpecifiedProtocols property of the FPCAccessProperties object for the new rule twice to set the protocols to HTTP and HTTPS, and then set the ProtocolSelectionMethod property to fpcSpecifiedProtocols.
  11. Call the Add method of the FPCRefs collection retrieved in the UserSets property of the FPCAccessProperties object for the new rule to set All Users as the user set to which the rule applies.
  12. Call the Save method of the policy rules collection to write the changes to the new access rules to persistent storage.

The following code can be saved to a .vbs file and run from a command prompt on a computer running ISA Server 2004.

Sub AddRuleAndUrlSet()

    ' Define enumeration values.
    const fpcInclude = 0
    const fpcSpecifiedProtocols = 1

    ' Create the root object.
    Dim root  ' The FPCLib.FPC root object
    Set root = CreateObject("FPC.Root")

    'Declare the other objects needed.
    Dim firewall    ' An FPCArray object
    Dim policyrules ' An FPCPolicyRules collection
    Dim urlsets     ' An FPCURLSets collection
    Dim urlset      ' An FPCURLSet object
    Dim newrule     ' An FPCPolicyRule object

    ' Get references to the array object (firewall), the policy rules collection,
    ' and the URL sets collection.
    Set firewall = root.GetContainingArray
    Set policyrules = firewall.ArrayPolicy.PolicyRules
    Set urlsets = firewall.RuleElements.URLSets

    WScript.Echo "Creating a new URL set containing sites to be blocked ..."
    Set urlset = urlsets.Add("Blocked Web Sites")
    urlset.Add "http://www.northwindtraders.com"
    urlset.Add "http://www.widgets.com"
    urlset.Save

    WScript.Echo "Creating a new access rule ..."
    Set newrule = policyrules.AddAccessRule("Deny Access to Some Web Sites")

    ' Define the source for the new access rule.
    newrule.SourceSelectionIPs.Networks.Add "External", fpcInclude

    ' Add the new destination URL set to the objects referenced by the URLSets property
    ' of the new access rule.
    newrule.AccessProperties.URLSets.Add "Blocked Web Sites", fpcInclude

    'Set the protocols to HTTP and HTTPS.
    newrule.AccessProperties.SpecifiedProtocols.Add "HTTP", fpcInclude
    newrule.AccessProperties.SpecifiedProtocols.Add "HTTPS", fpcInclude
    newrule.AccessProperties.ProtocolSelectionMethod =  fpcSpecifiedProtocols

    ' Set the user set to which the rule applies.
    newrule.AccessProperties.UserSets.Add "All Users", fpcInclude

    ' Save the changes to the new access rule.
    policyrules.Save
    WScript.Echo "Done!"

End Sub

AddRuleAndUrlSet


Controlling Access by a Schedule and a User Set [ISA Server 2004]

Controlling Access by a Schedule and a User Set

This VBScript example creates the user set, URL set, and access rules needed to allow a specific group of workers in an organization restricted access to the Internet. The group is allowed to access only the sites listed in the URL set and only during the hours specified in the work hours schedule supplied with ISA Server 2004. All other workers using computers that belong to the Internal network are granted unlimited access to the Internet. The script includes three subroutines:

  • ControlAccessByScheduleAndUserSet
  • RemoveExistingItem
  • CheckError

The following procedure lists the steps used to create a user set, a URL set, and two access rules in the code example that follows.

To control access by a schedule and a user set

  1. Define values from the FpcPolicyRuleActions, FpcIncludeStatus, FpcProtocolSelectionType, and FpcAppliesToContentMethodType enumerations. For more information about using values defined in ISA Server enumerated types in scripts, see Using Enumerated Types in Scripts.
  2. Create an instance of the FPC COM object, which provides access to the other ISA Server administration COM objects.
  3. Declare an FPCArray object, an FPCPolicyRules collection, two FPCPolicyRule objects, an FPCUserSets collection, an FPCUserSet object, an FPCURLSets collection, and an FPCURLSet object.
  4. Get references to the existing FPCArray object, FPCPolicyRules collection, FPCUserSets collection, and FPCURLSets collection.
  5. Call the RemoveExistingItem subroutine to remove an access rule (an FPCPolicyRule object) named Allow All to Internet Rule if it already exists.
  6. Call the RemoveExistingItem subroutine to remove an access rule named Internal Network Internet Access Deny Rule if it already exists.
  7. Call the RemoveExistingItem subroutine to remove a user set named Staff if it already exists.
  8. Call the Add method of the user sets collection to create a new user set named Staff that will have restricted access to the Internet.
  9. Call the RemoveExistingItem subroutine to remove a URL set named Allowed Web Sites if it already exists.
  10. Call the Add method of the URL sets collection to create a new set of URLs named Allowed Web Sites that will be allowed for users belonging to the Staff users group.
  11. Call the AddAccessRule method of the policy rules collection to create a new access rule named Allow All to Internet Rule that will allow unrestricted access to the Internet to users in the organization.
  12. Configure the Allow All to Internet Rule access rule to apply to the HTTP, HTTPS, and FTP protocols, to the Internal network as the source, to the External network (the Internet) as the destination, to the predefined All Users user set, and to all content types.
  13. Call the AddAccessRule method of the policy rules collection to create a new access rule named Internal Network Internet Access Deny Rule that will deny access to the Internet from the Internal network, except for specific sites, by users belonging to the Staff user set.
  14. Configure the Internal Network Internet Access Deny Rule access rule to apply to the HTTP, HTTPS, and FTP protocols, to the Internal network as the source, to the External network as the destination, to the Allowed Web Sites URL set, to the Staff user set, to the Work hours schedule, and to all content types.
  15. Call the Save method on the policy rules collection to write the changes to the new cache rules to persistent storage.

The following code can be saved to a .vbs file and run from a command prompt on a computer running ISA Server 2004.

Sub CheckError()

    If Err.Number <> 0 Then
        WScript.Echo "An error occurred: 0x" & Hex(Err.Number) & " " & Err.Description
        Err.Clear
    End If

End Sub

Sub RemoveExistingItem(collection, name)

    Dim member     ' Object in the collection

    Err.Clear
    On Error Resume Next
    Set member = collection.Item(name)
    If Err.Number = 0 Then
        WScript.Echo name & " exists. Removing it ..."
        collection.Remove name
        CheckError
        collection.Save
        CheckError
    End If

End Sub

Sub ControlAccessByScheduleAndUserSet()

    ' Define users. You must replace these fictitious user account names by real
    ' user accounts in your organization.
    user1 = "Corporate\Mike"
    user2 = "Coporate\Stephanie"

    ' Define enumeration values.
    const fpcPolicyRuleActionAllow = 0
    const fpcPolicyRuleActionDeny = 1
    const fpcInclude = 0
    const fpcExclude = 1
    const fpcSpecifiedProtocols = 1
    const fpcAppliesToAllContent = 0

    ' Create the root obect.
    Dim root  ' The FPCLib.FPC root object
    Set root = CreateObject("FPC.Root")

    'Declare the other objects needed.
    Dim array        ' An FPCArray object
    Dim policyrules  ' An FPCPolicyRules collection
    Dim denyrule     ' An FPCPolicyRule object
    Dim allowrule    ' An FPCPolicyRule object
    Dim usersets     ' An FPCUserSets colection
    Dim userset      ' An FPCUserSet object
    Dim urlsets      ' An FPCURLSets colection
    Dim urlset       ' An FPCURLSet object

    ' Get references to the array object, the policy rules collection,
    ' the user sets collection, and the URL sets collection.
    Set array = root.GetContainingArray
    Set policyrules = array.ArrayPolicy.PolicyRules
    Set usersets = array.RuleElements.UserSets
    Set urlsets = array.RuleElements.URLSets

    ' If an access rule named "Allow All to Internet Rule" already exists,
    ' remove it.
    RemoveExistingItem policyrules, "Allow All to Internet Rule"

    ' If an access rule named "Internal Network Internet Access Deny Rule" already exists,
    ' remove it.
    RemoveExistingItem policyrules, "Internal Network Internet Access Deny Rule"

    ' If a user set named "Staff" already exists, remove it.
    RemoveExistingItem usersets, "Staff"

    WScript.Echo "Creating a new user set, Staff, containing the users who are considered staff ..."
    On Error Resume Next
    Set userset = usersets.Add("Staff")
    userset.Accounts.Add user1
    CheckError
    userset.Accounts.Add user2
    CheckError
    usersets.Save
    CheckError

    ' If a URL set named "Allowed Web Sites" already exists, remove it.
    Err.Clear
    RemoveExistingItem urlsets, "Allowed Web Sites"

    WScript.Echo "Creating a new URL set containing sites to be allowed ..."
    Set urlset = urlsets.Add("Allowed Web Sites")
    urlset.Add "http://www.northwindtraders.com"
    CheckError
    urlset.Add "http://www.widgets.com"
    CheckError
    urlsets.Save
    CheckError

    WScript.Echo "Creating an allow access rule ..."
    Set allowrule = policyrules.AddAccessRule("Allow All to Internet Rule")
    allowrule.Description = "Allows unrestricted Internet access to all users on break room computers"
    allowrule.Enabled = True
    allowrule.Action = fpcPolicyRuleActionAllow

    'Set the protocols to HTTP, HTTPS, and FTP.
    allowrule.AccessProperties.SpecifiedProtocols.Add "HTTP", fpcInclude
    allowrule.AccessProperties.SpecifiedProtocols.Add "HTTPS", fpcInclude
    allowrule.AccessProperties.SpecifiedProtocols.Add "FTP", fpcInclude
    allowrule.AccessProperties.ProtocolSelectionMethod = fpcSpecifiedProtocols

    ' Add the Internal network to the objects referenced by the Networks property
    ' of the FPCSelectionIPs object accessed through the SourceSelectionIPs property
    ' of the access rule.
    allowrule.SourceSelectionIPs.Networks.Add "Internal", fpcInclude

    ' Add the External network (the Internet) to the objects referenced by the Networks
    ' property of the FPCSelectionIPs object accessed through the DestinationSelectionIPs
    ' property of the access rule.
    allowrule.AccessProperties.DestinationSelectionIPs.Networks.Add "External", fpcInclude

    ' Add the All Users user set to the user sets to which the rule applies.
    allowrule.AccessProperties.UserSets.Add "All Users", fpcInclude

    ' Configure the rule to apply to all content types.
    allowrule.AccessProperties.AppliesToContentMethod = fpcAppliesToAllContent 'Default setting

    WScript.Echo "Creating a deny access rule ..."
    Set denyrule = policyrules.AddAccessRule("Internal Network Internet Access Deny Rule")
    denyrule.Description = "Denies access to the Internet from the Internal network, except for specific sites"
    denyrule.Enabled = True
    denyrule.Action = fpcPolicyRuleActionDeny

    'Set the protocols to HTTP, HTTPS, and FTP.
    denyrule.AccessProperties.SpecifiedProtocols.Add "HTTP", fpcInclude
    denyrule.AccessProperties.SpecifiedProtocols.Add "HTTPS", fpcInclude
    denyrule.AccessProperties.SpecifiedProtocols.Add "FTP", fpcInclude
    denyrule.AccessProperties.ProtocolSelectionMethod = fpcSpecifiedProtocols

    ' Add the Internal network to the objects referenced by the Networks property
    ' of the FPCSelectionIPs object accessed through the SourceSelectionIPs property
    ' of the access rule.
    denyrule.SourceSelectionIPs.Networks.Add "Internal", fpcInclude

    ' Add the External network (the Internet) to the objects referenced by the Networks
    ' property of the FPCSelectionIPs object accessed through the DestinationSelectionIPs
    ' property of the access rule.
    denyrule.AccessProperties.DestinationSelectionIPs.Networks.Add "External", fpcInclude

    ' Add the Allowed Web Sites URL set to the objects that are referenced by the URLSets
    ' property of the access rule and are excluded from the rule.
    denyrule.AccessProperties.URLSets.Add "Allowed Web Sites", fpcExclude

    ' Add the Staff user set to the user sets to which the rule applies.
    denyrule.AccessProperties.UserSets.Add "Staff", fpcInclude

    ' Set the Work hours schedule as the schedule applying to the rule.
    denyrule.SetSchedule "Work hours"

    ' Configure the rule to apply to all content types.
    denyrule.AccessProperties.AppliesToContentMethod = fpcAppliesToAllContent

    'Save the changes to the new access rules.
    policyrules.Save
    CheckError
    WScript.Echo "Done!"

End Sub

ControlAccessByScheduleAndUserSet


Exporting and Importing an ISA Server Configuration [ISA Server 2004]

Exporting and Importing an ISA Server Configuration

This VBScript example exports the configuration of an ISA Server computer to a specified .xml file or imports the configuration stored in a specified .xml file to an ISA Server computer. The script includes a single function, called ImportExport.

This example is included as the ImportExport.vbs script in the Sdk\Samples\Admin folder on the ISA Server 2004 CD.

The following procedure lists the steps used to export the configuration of an ISA Server computer to an .xml file and to import the configuration in an .xml file to an ISA Server computer in the code example that follows.

To export and import an ISA Server configuration

  1. Declare an FPC object and an FPCArray object.
  2. Create an instance of the FPC COM object, which provides access to the other ISA Server administration COM objects.
  3. Get a reference to the existing FPCArray object.
  4. If exporting is requested, perform the following task:

    • Call the ExportToFile method without any optional data to export the ISA Server configuration to the .xml file specified in the command argument.
  5. If importing is requested, perform the following task:

    • Call the ImportFromFile method without any optional data and set the fResetRequiredServices parameter to True to import the configuration into ISA Server.

The following code can be saved to a .vbs file and run from a command prompt on a computer running ISA Server 2004.

Sub ImportExport()
    ' Define a constant to indicate that no optional data will
    ' be exported or imported.
    const noOptionalData = 0

    If WScript.Arguments.Count <> 2 Then
        WScript.Echo "Error: Invalid number of parameters." & vbCrLf & _
                     "Syntax:" & vbCrLf & _
                     "ImportExport {e | i} filename"
        Exit Sub
    End If

    'Declare the objects needed
    Dim root      ' The FPCLib.FPC root object
    Dim firewall  ' An FPCArray object

    ' Create the root object.
    Set root = CreateObject("FPC.Root")

    ' Get a reference to the array object (firewall).
    Set firewall = root.GetContainingArray

    If WScript.Arguments(0) = "e" Then
       WScript.Echo "Exporting the configuration of the " & firewall.Name & " array object to " & WScript.Arguments(1) & " ..."

      ' Export the firewall's configuration to the XML document.
      ' Notice that values are not specified for the optional parameters.
      firewall.ExportToFile WScript.Arguments(1),noOptionalData
      WScript.Echo "Exporting was completed successfully."
      WScript.Quit
    End If

    If WScript.Arguments(0) = "i" Then
      WScript.Echo "Importing the configuration from " & WScript.Arguments(1) & " to the " & firewall.Name & " array object ..."

      ' Import the firewall's configuration from the XML file specified.
      ' Notice that values are not specified for some of the optional parameters.
      firewall.ImportFromFile WScript.Arguments(1),noOptionalData,,,True
      WScript.Echo "Importing was completed successfully."
    End If
End Sub

ImportExport


Adding a Connectivity Verifier [ISA Server 2004]

Adding a Connectivity Verifier

This VBScript example creates a new FPCConnectivityVerifier object in the FPCConnectivityVerifiers collection of the ISA Server computer. The script includes a single function, called AddConnectivityVerifier.

This example is included as the AddConnectivityVerifier.vbs script in the Sdk\Samples\Admin folder on the ISA Server 2004 CD.

The following procedure lists the steps used to create a new connectivity verifier in the code example that follows.

To create a connectivity verifier

  1. Define values from the FpcConnectivityGroupType and FpcRequestType enumerations. For more information about using values defined in ISA Server enumerated types in scripts, see Using Enumerated Types in Scripts.
  2. Create an instance of the FPC COM object, which provides access to the other ISA Server administration COM objects.
  3. Declare an FPCArray object, an FPCConnectivityVerifiers collection, and an FPCConnectivityVerifier object.
  4. Get references to the existing FPCArray object and FPCConnectivityVerifiers collection.
  5. Verify whether an FPCConnectivityVerifier object named DNS Verifier already exists. If it exists, remove it.
  6. Call the Add method of the connectivity verifiers collection to create a new connectivity verifier object named DNS Verifier.
  7. Set the Description and GroupType properties of the new connectivity verifier.
  8. Call the SetConnectivityRequest method to set the server address and request type of the new connectivity verifier.
  9. Use the Threshold property of the new connectivity verifier to set the round-trip time threshold for verification operations to two seconds.
  10. Call the Save method on the connectivity verifiers collection to write the changes to the new connectivity verifier to persistent storage.

The following code can be saved to a .vbs file and run from a command prompt on a computer running ISA Server 2004.

Sub AddConnectivityVerifier()

    ' Define enumeration values.
    const fpcGroupDNS = 2
    const fpcPingRequest = 1
    const serverAddress = "10.0.0.20"
    const thresholdTime = 2000 ' 2 seconds

    ' Create the root object.
    Dim root  ' The FPCLib.FPC root object
    Set root = CreateObject("FPC.Root")

    'Declare the other objects needed.
    Dim array       ' An FPCArray object
    Dim verifiers   ' An FPCConnectivityVerifiers collection
    Dim verifier    ' An FPCConnectivityVerifier object

    ' Get references to the array object and the connectivity verifiers collection.
    Set array = root.GetContainingArray
    Set verifiers = array.ConnectivityVerifiers

    ' If a connectivity verifier named DNS Verifier already exists, remove it.
    verifiers.Refresh
    On Error Resume Next
    Set verifier = verifiers.Item("DNS Verifier")
    If Err.Number = 0 Then
        WScript.Echo "DNS Verifier exists. Removing it ..."
        verifiers.Remove "DNS Verifier"
        verifiers.Save
    End If

    WScript.Echo "Creating a new connectivity verifier ..."
    Set verifier = verifiers.Add("DNS Verifier")

    ' Set the description of the new connectivity verifier.
    verifier.Description = "This connectivity verifier checks connectivity by pinging the DNS server."

    ' Set the type of servers with which connectivity is checked.
    verifier.GroupType = fpcGroupDNS

    ' Set the server address and request type for connectivity verification requests.
    verifier.SetConnectivityRequest serverAddress, fpcPingRequest

    ' Set the round-trip time threshold for verification operations
    verifier.Threshold = thresholdTime

    'Save the changes to the connectivity verifier.
    verifiers.Save
    WScript.Echo "Done!"

End Sub

AddConnectivityVerifier


Displaying Active Sessions [ISA Server 2004]

Displaying Active Sessions

This VBScript example runs a query to find the active sessions on an ISA Server computer and then displays the active sessions found. The script includes a single function, called DisplayActiveSessions.

This example is included as the ActiveSessions.vbs script in the Sdk\Samples\Admin folder on the ISA Server 2004 CD.

The following procedure lists the steps used to find and display active sessions in the code example that follows.

To find and display active sessions

  1. Create an instance of the FPC COM object, which provides access to the other ISA Server administration COM objects.
  2. Declare an FPCArray object, an FPCSessionsMonitor collection, an FPCFilterExpressions collection, and an FPCSessionsMonitorEntry object.
  3. Get references to the existing FPCArray object and the FPCSessionsMonitor collection.
  4. Create an FPCFilterExpressions collection.
  5. Call the ExecuteQuery method to start a query to find the active sessions using the empty FPCFilterExpressions collection.
  6. In a loop, display the ClientIP property of each FPCSessionsMonitorEntry object representing a session found in the FPCSessionsMonitor collection.
  7. When all the sessions that existed when the query started have been displayed, call the EndQuery method to stop the query.

The following code can be saved to a .vbs file and run on a computer running ISA Server 2004. We recommend running this script from a command prompt using the CScript command.

Sub DisplayActiveSessions()

    ' Define an enumeration value.
    const fpcSessionFound = 0
    const bufferSize = 10000

    ' Create the root object.
    Dim root  ' The FPCLib.FPC root object
    Set root = CreateObject("FPC.Root")

    ' Declare the other objects needed.
    Dim array           ' An FPCArray object
    Dim sessionmonitor  ' An FPCSessionsMonitor collection
    Dim filter          ' An FPCFilterExpressions collection
    Dim session         ' An FPCSessionsMonitorEntry object

    ' Get references to the array object and the sessions monitor collection.
    Set array = root.GetContainingArray
    Set sessionmonitor = array.SessionsMonitors.SessionsMonitorFirewall

    ' Create a filter expressions collection.
    Set filter = CreateObject("FPC.FPCFilterExpressions")

    ' Start a query to find the active sessions.
    sessionmonitor.ExecuteQuery filter, bufferSize
    WScript.Echo "Finding the active sessions ... Please wait a few seconds."

    Dim Index
    Index = 1

    On Error Resume Next
    Do
        Set session = sessionmonitor.Item(Index)

        ' An E_PENDING (0x80070002) error is raised when the index points beyond the
        ' end of the current list of sessions.
        If Err.Number <> 0 Then
            WScript.Echo "All existing sessions have been retrieved."
            Exit Do
        End If

        ' An FPCSessionMonitorEntry object can be related to various session events.
        ' Here we are interested only in entries whose Event property equals
        ' fpcSessionFound, which indicates a session that existed when the query started.
        ' Display the client IP address of each session found.
        If session.Event = fpcSessionFound Then
            WScript.Echo "Session with: " & session.ClientIP
        End If

        Index = Index + 1
    Loop Until Err.Number <> 0
    Err.Clear

    ' Stop the query.
    sessionmonitor.EndQuery
    WScript.Echo "The query has been stopped."
    WScript.Echo "Done!"

End Sub

DisplayActiveSessions


Cut-and-Paste ISA Server Administration Functions [ISA Server 2004]

Cut-and-Paste ISA Server Administration Functions

These VBScript functions and code examples have general practicality. Using a cut-and-paste operation, you can place these code examples in your scripts.

Getting the Array

The following code automatically inserts the name of the current array object in the input box. You can also type the name of a different array object. If the input box is left empty, it is the equivalent of clicking Cancel.

set root = WScript.CreateObject("FPC.Root")
Set collArrays = objFPC.Arrays

strArrayName = InputBox("Please enter the array name, or <ENTER> for the containing array:",,root.GetContainingArray.Name)

If strArrayName = "" Then
    'Cancel option. Note that this should read "Exit Function" if used in a function.
    Exit Sub
Else
    On Error Resume Next
    Set objArray = objArrays(strArrayName)
    If Err.Number <> 0 Then
        WScript.Echo "The specified array was not found"
        Exit Sub
    End If
    On Error GoTo 0
End If

Item_Exists

This function is useful for checking if an object exists before your script adds it. For example, if you try to add a rule called My Rule, and there already is such a rule, this function will allow you to handle that situation, rather than having the script terminate with an error.

Note This function checks for the existence of an item based on the Name property only.

Private Function Item_Exists(oCollection , sItemName)
'This function returns True if the item exists in the given collection, False if it does not exist

 Dim oItem  'Object

    Item_Exists = False
    For Each oItem In oCollection
        If oItem.Name = sItemName Then
            Item_Exists = True
            Exit Function
        End If
    Next

End Function

The following is an example of how you would call the function. This example adds a new network rule, unless it exists already.

'The next line means - if Item_Exists does not return True, meaning the item does not exist, then...
If not Item_Exists(collNetworkRules, "New VPN Network Rule") Then
    Set oNetworkRule = collNetworkRules.Add("New VPN Network Rule")
Else
    wscript.echo "New VPN Network Rule already exists"
    wscript.quit
End If

Error Handling

This subroutine tells you if an error was encountered during script execution. To use this subroutine, include the following statement at the beginning of the main script.

On Error Resume Next

Then call the subroutine wherever an error is likely, using the following statement.

CheckError

The following is the CheckError subroutine.

Private Sub CheckError()

'Display error information.
    If Err.Number <> 0 Then
        WScript.Echo  "An error occurred: " & Hex(Err.Number) & " " & Err.Description
        WScript.Quit
    End If
End Sub


Administration Reference [ISA Server 2004]

Administration Reference

This section defines Internet Security and Acceleration (ISA) Server 2004 administration objects. It includes a description of each object and a description of each associated property and method.

This section contains the following topics:

  • COM Objects
  • Enumerated Types
  • Log Fields
  • Administration Object Error Codes
  • MprAdminConnectionRemoveQuarantine


COM Objects [ISA Server 2004]

COM Objects

The ISA Server administration COM object sections display Microsoft® Visual Basic® programming language syntax; however, you can write programs using these objects in any language that supports COM. See ISA Server Administration Object Model for a diagram of the administration COM object hierarchy. The diagram shows the beginning of the hierarchy, starting with the root object.

The administration objects expose two types of application programming interfaces (APIs)— some APIs provide for the configuration of stored ISA Server settings and others provide for the configuration of services that are currently running. For example, the session monitoring collection (FPCSessionsMonitor) permits programmatic monitoring of sessions that are currently running, while most other administration COM objects provide for the programmatic configuration of various internal ISA Server settings. For more detailed examples of object use, see ISA Server Administration Scripting.

This section contains the following topics:

  • FPC Object
  • FPCAccessProperties Object
  • FPCAccount Object
  • FPCAccounts Collection
  • FPCActiveCacheConfiguration Object
  • FPCAdapter Object
  • FPCAdapters Collection
  • FPCAddressRange Object
  • FPCAddressRanges Collection
  • FPCAdminSecurity Object
  • FPCAlert Object
  • FPCAlertAction Object
  • FPCAlertActions Collection
  • FPCAlerts Collection
  • FPCApplicationFilter Object
  • FPCApplicationFilters Collection
  • FPCApplicationUsageReports Object
  • FPCAppliedSSLCertificate Object
  • FPCAppliedSSLCertificates Collection
  • FPCArray Object
  • FPCArrayPolicy Object
  • FPCArrays Collection
  • FPCAttackDetection Object
  • FPCAuthenticationScheme Object
  • FPCAuthenticationSchemes Collection
  • FPCBackupRoute Object
  • FPCCache Object
  • FPCCacheConfiguration Object
  • FPCCacheContents Object
  • FPCCacheDrive Object
  • FPCCacheDrives Collection
  • FPCCacheRule Object
  • FPCCacheRules Collection
  • FPCCertificate Object
  • FPCCertificates Collection
  • FPCClientAutoScript Object
  • FPCClientBackupRoute Object
  • FPCClientConfig Object
  • FPCClientConfigSettings Collection
  • FPCClientSettingsSection Object
  • FPCComputer Object
  • FPCComputers Collection
  • FPCComputerSet Object
  • FPCComputerSets Collection
  • FPCConnectionLimit Object
  • FPCConnectionLimitPolicy Object
  • FPCConnectivityResult Object
  • FPCConnectivityResults Collection
  • FPCConnectivityVerifier Object
  • FPCConnectivityVerifiers Collection
  • FPCContentTypeSet Collection
  • FPCContentTypeSets Collection
  • FPCCredentials Object
  • FPCDelegatedAdmin Object
  • FPCDelegatedAdmins Collection
  • FPCDialingConfiguration Object
  • FPCDialupNetworkConnections Collection
  • FPCDiskDrive Object
  • FPCDiskDrives Collection
  • FPCDomainNameSet Collection
  • FPCDomainNameSets Collection
  • FPCEventDefinition Object
  • FPCEventDefinitions Collection
  • FPCExtensions Object
  • FPCFilterExpression Object
  • FPCFilterExpressions Collection
  • FPCFirewallChaining Object
  • FPCFirewallClientConfig Object
  • FPCFTPCacheConfiguration Object
  • FPCHTTPCacheConfiguration Object
  • FPCIPAddresses Collection
  • FPCIPOnNetwork Object
  • FPCIpOptions Object
  • FPCIpRangeEntry Object
  • FPCIpRangeSet Collection
  • FPCIPsOnNetworks Collection
  • FPCLDT Collection
  • FPCLDTEntry Object
  • FPCLog Object
  • FPCLogContent Collection
  • FPCLogEntry Object
  • FPCLogs Collection
  • FPCLogSummaryConfiguration Object
  • FPCLogViewer Object
  • FPCLowLevelSettings Object
  • FPCNetwork Object
  • FPCNetworkConfiguration Object
  • FPCNetworkInTemplate Object
  • FPCNetworkRule Object
  • FPCNetworkRules Collection
  • FPCNetworks Collection
  • FPCNetworkSet Object
  • FPCNetworkSets Collection
  • FPCNetworksInTemplate Collection
  • FPCNetworkTemplate Object
  • FPCNetworkTemplates Collection
  • FPCNonWindowsUser Object
  • FPCNonWindowsUsers Collection
  • FPCPathMapping Object
  • FPCPathMappings Collection
  • FPCPersist Object
  • FPCPersistSink Object
  • FPCPoliciesInTemplate Collection
  • FPCPolicyInTemplate Object
  • FPCPolicyRule Object
  • FPCPolicyRules Collection
  • FPCPrimaryRoute Object
  • FPCProtocolConnection Object
  • FPCProtocolConnections Collection
  • FPCProtocolDefinition Object
  • FPCProtocolDefinitions Collection
  • FPCPublicNames Collection
  • FPCRadiusServer Object
  • FPCRadiusServers Collection
  • FPCReadOnlyIpRangeEntry Object
  • FPCReadOnlyIpRangeSet Collection
  • FPCReadyReport Object
  • FPCReadyReports Collection
  • FPCRef Object
  • FPCRefs Collection
  • FPCReportJob Object
  • FPCReportJobs Collection
  • FPCReports Collection
  • FPCReportsProperties Object
  • FPCRoutingRule Object
  • FPCRoutingRules Collection
  • FPCRuleElements Object
  • FPCSchedule Object
  • FPCScheduledContentDownload Collection
  • FPCScheduledContentDownloadConfig Object
  • FPCScheduledContentDownloadJobStatus Object
  • FPCScheduledContentDownloadJobStatuses Collection
  • FPCSchedules Collection
  • FPCSecurityReports Object
  • FPCSecurityRole Object
  • FPCSecurityRoles Collection
  • FPCSelectionIPs Object
  • FPCServer Object
  • FPCServerPublishingProperties Object
  • FPCServers Collection
  • FPCSessionsMonitor Collection
  • FPCSessionsMonitorEntry Object
  • FPCSessionsMonitors Object
  • FPCSignaledAlert Collection
  • FPCSignaledAlertInstance Object
  • FPCSignaledAlerts Collection
  • FPCSnapinNode Object
  • FPCSnapinPluginPolicy Object
  • FPCSubnet Object
  • FPCSubnets Collection
  • FPCSummaryReports Object
  • FPCSystemPolicy Object
  • FPCSystemPolicyConfigGroup Object
  • FPCSystemPolicyRules Collection
  • FPCTrafficReports Object
  • FPCTunnelPortRange Object
  • FPCTunnelPortRanges Collection
  • FPCURLSet Collection
  • FPCURLSets Collection
  • FPCUserMapping Object
  • FPCUserSet Object
  • FPCUserSets Collection
  • FPCVendorParametersSet Object
  • FPCVendorParametersSets Collection
  • FPCVpnConfiguration Object
  • FPCVpnNetworkConfiguration Object
  • FPCVpnNetworkIPSecSettings Object
  • FPCVpnNetworkL2tpPptpSettings Object
  • FPCVpnPPPSettings Object
  • FPCVpnQuarantineSettings Object
  • FPCWebBrowserClientConfig Object
  • FPCWebFilter Object
  • FPCWebFilters Collection
  • FPCWebListener Object
  • FPCWebListenerProperties Object
  • FPCWebListeners Collection
  • FPCWebProxy Object
  • FPCWebPublishingProperties Object
  • FPCWebUsageReports Object

See Also

Administration Reference


FPC object [ISA Server 2004]

FPC

The FPC object is the root of the administration COM object hierarchy, and provides programmatic access to almost all of the other FPC objects. For a diagram of the entire hierarchy, see ISA Server Administration Object Model.

Creating this root object is the first step in making any programmatic changes to ISA Server. Using Visual Basic, you can create it with the following code:

  Dim root As New FPCLib.FPC

The CreateObject function is also available to Visual Basic programmers, and alternatively, the following can be used:

  Dim root As FPCLib.FPC
  Set root = CreateObject("FPC.Root")

Scripts written in Visual Basic Scripting Edition (VBScript) must use the CreateObject function to create the root object, as in the following code example:

  Dim root  ' This line may be omitted.
  Set root = CreateObject("FPC.Root")

After the FPC object is created, objects below it in the hierarchy can be accessed through the methods and properties of the root object.

  • The GetContainingArray method of the root object retrieves the FPCArray object that represents the ISA Server array associated with the current ISA Server computer. The current ISA Server computer is the computer that executes the code calling this method. The FPCArray object provides access to the configuration settings of the ISA Server computer.
  • The Arrays property of the root object provides access to the FPCArrays collection, of all the FPCArray objects within the root node. In ISA Server 2004 Standard Edition, this collection contains only one FPCArray object, which provides access to configuration settings of a single ISA Server computer.

For examples of the use of the FPC root object, see ISA Server Administration Scripting.

Click here to see the ISA Server object hierarchy.

Methods

The FPC object defines the following methods.

Method | Description
GetContainingArray | Retrieves the FPCArray object that represents the array containing the current computer.
GetContainingServer | Retrieves the FPCServer object that represents the current ISA Server computer.

Properties

The FPC object has the following property.

Property | Description
Arrays | Gets an FPCArrays collection that contains all the ISA Server arrays for the root object.

Remarks

This object implements the IFPC interface.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

COM Objects


IFPC | FPC Arrays(IFPCArrays) property [ISA Server 2004]

Arrays Property of IFPC[C++]

FPC.Arrays [Visual Basic]

[C++]

The Arrays property gets an FPCArrays collection that contains all the arrays for the root object. This property can be used to access an individual server within each array.

HRESULT get_Arrays(
  IFPCArrays** ppArrays
);

Parameters

ppArrays
Address of an interface pointer that on return points to an IFPCArrays collection that represents a collection of arrays.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The Arrays property gets an FPCArrays collection that contains all the arrays for the root object. This property can be used to access an individual server within each array.

Property Arrays As FPCArrays

Property Value

Reference to an FPCArrays collection.

Remarks

This property is read-only.

Example Code

This VBScript script retrieves the arrays collection. It does not include error handling.

Option Explicit
Dim root
Dim arrays
'Create the root ISA Server object
Set root = CreateObject("FPC.Root")
'Get the arrays collection
Set arrays = root.Arrays

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPC


IFPC | FPC GetContainingArray(IFPCArray) method [ISA Server 2004]

IFPC::GetContainingArray[C++]

FPC.GetContainingArray [Visual Basic]

[C++]

The GetContainingArray method retrieves the IFPCArray interface that represents the array containing the current computer. Assume, for example, that there are two arrays, Array1 and Array2. Array1 contains two computers, a and b. Array2 contains computer c. If you call GetContainingArray on computer a, the method returns Array1. If you call GetContainingArray on computer c, the method returns Array2.

HRESULT GetContainingArray(
  IFPCArray** ppItem
);

Parameters

ppItem
[out] Address of an interface pointer that on return points to the IFPCArray interface that represents the containing array.

Return Values

This method can return one of the following:

  • S_OK, indicating that the operation succeeded.
  • ERROR_FILE_NOT_FOUND, indicating that the IFPCArray interface could not be found because the method was called on a remote administration computer on which the Microsoft Firewall service is not running. In this case, the [out] parameter returned is a null object.
  • An error code indicating that the operation failed. In this case, the [out] parameter returned is a null object.

[Visual Basic]

The GetContainingArray method retrieves the FPCArray object that represents the array containing the current computer. Assume, for example, that there are two arrays, Array1 and Array2. Array1 contains two computers, a and b. Array2 contains computer c. If you call GetContainingArray on computer a, the method returns Array1. If you call GetContainingArray on computer c, the method returns Array2.

Function GetContainingArray() As FPCArray

Parameters

This method has no parameters.

Return Values

This method returns a reference to an FPCArray object if successful. Otherwise, an error is raised that can be intercepted by using an error handler. In particular, an ERROR_FILE_NOT_FOUND is raised if the FPCArray object could not be found because the method was called on a remote administration computer on which the Microsoft Firewall service is not running.

Example Code

The following code example retrieves the name of the array containing the current computer by means of the GetContainingArray method.

Dim root As New FPCLib.FPC
Dim containingArray As String
containingArray = root.GetContainingArray.Name

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPC


IFPC | FPC GetContainingServer(IFPCServer) method [ISA Server 2004]

IFPC::GetContainingServer[C++]

FPC.GetContainingServer [Visual Basic]

[C++]

The GetContainingServer method retrieves the IFPCServer interface that represents the current ISA Server computer.

HRESULT GetContainingServer(
  IFPCServer** ppItem
);

Parameters

ppItem
[out] Address of an interface pointer that on return points to the IFPCServer interface that represents the current ISA Server computer.

Return Values

This method can return one of the following:

  • S_OK, indicating that the operation succeeded.
  • ERROR_FILE_NOT_FOUND, indicating that the IFPCServer interface could not be found because the method was called on a remote administration computer on which the Microsoft Firewall service is not running. In this case, the [out] parameter returned is a null object.
  • An error code indicating that the operation failed. In this case, the [out] parameter returned is a null object.

[Visual Basic]

The GetContainingServer method retrieves the FPCServer object that represents the current ISA Server computer.

Function GetContainingServer() As FPCServer

Parameters

This method has no parameters.

Return Values

This method returns a reference to an FPCServer object if successful. Otherwise, an error is raised that can be intercepted by using an error handler. In particular, an ERROR_FILE_NOT_FOUND is raised if the FPCServer object could not be found because the method was called on a remote administration computer on which the Microsoft Firewall service is not running.

Example Code

The following Visual Basic code example retrieves the name of the current ISA Server computer by means of the GetContainingServer method.

Dim root As New FPCLib.FPC
Dim containingServer As String
containingServer = root.GetContainingServer.Name

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPC


FPCAccessProperties object [ISA Server 2004]

FPCAccessProperties

The FPCAccessProperties object represents the properties of a policy rule that was created as an access rule using the AddAccessRule method.

This object is typically accessed through the AccessProperties property of an FPCPolicyRule object representing an access rule.

Click here to see the ISA Server object hierarchy.

Methods

This object has no methods.

Properties

The FPCAccessProperties object has the following properties.

Property | Description
AppliesToContentMethod | Gets or sets a value from the FpcAppliesToContentMethodType enumerated type that indicates whether the rule applies to all types of content or only to specified types of content.
ContentTypeSetsUsed | Gets an FPCRefs collection that contains references to the FPCContentTypeSet objects defining the content type sets to which the rule applies.
DestinationDomainNameSets | Gets an FPCRefs collection that contains references to the FPCDomainNameSet objects defining the destination domain name sets to which the rule applies.
DestinationSelectionIPs | Gets an FPCSelectionIPs object that specifies the complete set of destination IP addresses to which the rule applies.
ProtocolSelectionMethod | Gets or sets a value from the FpcProtocolSelectionType enumerated type that indicates whether the rule applies to all IP traffic, only to certain protocols, or to all IP traffic except certain protocols.
RedirectUrl | Gets or sets the URL to which HTTP requests are redirected.
SpecifiedProtocols | Gets an FPCRefs collection that contains references to the FPCProtocolDefinition objects defining the protocols to which the rule applies or the protocols that are excluded from the rule.
URLSets | Gets an FPCRefs collection that contains references to the FPCURLSet collections defining the URL sets to which the rule applies.
UserSets | Gets an FPCRefs collection that contains references to the FPCUserSet collections defining the user sets to which the rule applies.

Remarks

This object implements the IFPCAccessProperties interface.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

COM Objects


IFPCAccessProperties.AppliesToContentMethod property [ISA Server 2004]

AppliesToContentMethod Property of IFPCAccessProperties[C++]

FPCAccessProperties.AppliesToContentMethod [Visual Basic]

[C++]

The AppliesToContentMethod property gets or sets a value from the FpcAppliesToContentMethodType enumerated type that indicates whether the rule applies to all types of content or only to specified types of content.

HRESULT get_AppliesToContentMethod(
  FpcAppliesToContentMethodType* pAppliesToContentMethodType
);

HRESULT put_AppliesToContentMethod(
  FpcAppliesToContentMethodType AppliesToContentMethodType
);

Parameters

pAppliesToContentMethodType
Pointer to a variable that on return receives a value from the FpcAppliesToContentMethodType enumerated type indicating whether the rule applies to all types of content or only to the file types and MIME types specified in the ContentTypeSetsUsed property.
AppliesToContentMethodType
Value from the FpcAppliesToContentMethodType enumerated type that indicates whether the rule applies to all types of content or only to the file types and MIME types specified in the ContentTypeSetsUsed property.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write. Its default value is fpcAppliesToAllContent, which indicates that the rule applies to all file types and MIME types.

[Visual Basic]

The AppliesToContentMethod property gets or sets a value from the FpcAppliesToContentMethodType enumerated type that indicates whether the rule applies to all types of content or only to specified types of content.

Property AppliesToContentMethod As FpcAppliesToContentMethodType

Property Value

Value from the FpcAppliesToContentMethodType enumerated type that indicates whether the rule applies to all types of content or only to the file types and MIME types specified in the ContentTypeSetsUsed property.

Remarks

This property is read/write. Its default value is fpcAppliesToAllContent, which indicates that the rule applies to all file types and MIME types.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCAccessProperties


IFPCAccessProperties.ContentTypeSetsUsed(IFPCRefs) property [ISA Server 2004]

ContentTypeSetsUsed Property of IFPCAccessProperties[C++]

FPCAccessProperties.ContentTypeSetsUsed [Visual Basic]

[C++]

The ContentTypeSetsUsed property gets an FPCRefs collection that contains references to the FPCContentTypeSet objects defining the content type sets to which the rule applies.

HRESULT get_ContentTypeSetsUsed(
  IFPCRefs** ppRefs
);

Parameters

ppRefs
Address of an interface pointer that on return points to an IFPCRefs interface that represents the collection of references to the content type sets to which the rule applies.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only. It can be modified by calling the methods of the IFPCRefs interface.

[Visual Basic]

The ContentTypeSetsUsed property gets an FPCRefs collection that contains references to the FPCContentTypeSet objects defining the content type sets to which the rule applies.

Property ContentTypeSetsUsed As FPCRefs

Property Value

Reference to an FPCRefs collection that contains references to the content type sets to which the rule applies.

Remarks

This property is read-only. It can be modified by calling the methods of the FPCRefs collection.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCAccessProperties


IFPCAccessProperties.DestinationDomainNameSets property [ISA Server 2004]

DestinationDomainNameSets Property of IFPCAccessProperties[C++]

FPCAccessProperties.DestinationDomainNameSets [Visual Basic]

[C++]

The DestinationDomainNameSets property gets an FPCRefs collection that contains references to the FPCDomainNameSet objects defining the destination domain name sets to which the rule applies.

HRESULT get_DestinationDomainNameSets(
  IFPCRefs** ppRefs
);

Parameters

ppRefs
Address of an interface pointer that on return points to an IFPCRefs interface that represents the collection of references to the destination domain name sets to which the rule applies.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only. It can be modified by calling the methods of the IFPCRefs interface retrieved.

[Visual Basic]

The DestinationDomainNameSets property gets an FPCRefs collection that contains references to the FPCDomainNameSet objects defining the destination domain name sets to which the rule applies.

Property DestinationDomainNameSets As FPCRefs

Property Value

Reference to an FPCRefs collection that contains references to the destination domain name sets to which the rule applies.

Remarks

This property is read-only. It can be modified by calling the methods of the FPCRefs collection retrieved.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCAccessProperties


IFPCAccessProperties.DestinationSelectionIPs property [ISA Server 2004]

DestinationSelectionIPs Property of IFPCAccessProperties[C++]

FPCAccessProperties.DestinationSelectionIPs [Visual Basic]

[C++]

The DestinationSelectionIPs property gets an FPCSelectionIPs object that specifies the complete set of destination IP addresses to which the rule applies. This set may include computers, networks, network sets, subnets, or IP address ranges.

HRESULT get_DestinationSelectionIPs(
  IFPCSelectionIPs** ppSelectionIPs
);

Parameters

ppSelectionIPs
Address of an interface pointer that on return points to an IFPCSelectionIPs interface that specifies the complete set of destination IP addresses to which the rule applies.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only. It can be modified through the properties of the IFPCSelectionIPs interface retrieved.

You can use the SourceSelectionIPs property to get the complete set of source IP addresses to which an access rule applies.

[Visual Basic]

The DestinationSelectionIPs property gets an FPCSelectionIPs object that specifies the complete set of destination IP addresses to which the rule applies. This set may include computers, networks, network sets, subnets, or IP address ranges.

Property DestinationSelectionIPs As FPCSelectionIPs

Property Value

Reference to an FPCSelectionIPs object that specifies the complete set of destination IP addresses to which the rule applies.

Remarks

This property is read-only. It can be modified through the properties of the FPCSelectionIPs object retrieved.

You can use the SourceSelectionIPs property to get the complete set of source IP addresses to which an access rule applies.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCAccessProperties


IFPCAccessProperties.ProtocolSelectionMethod property [ISA Server 2004]

ProtocolSelectionMethod Property of IFPCAccessProperties[C++]

FPCAccessProperties.ProtocolSelectionMethod [Visual Basic]

[C++]

The ProtocolSelectionMethod property gets or sets a value from the FpcProtocolSelectionType enumerated type that indicates whether the rule applies to all IP traffic, only to certain protocols, or to all IP traffic except certain protocols.

HRESULT get_ProtocolSelectionMethod(
  FpcProtocolSelectionType* pProtocolSelectionType
);

HRESULT put_ProtocolSelectionMethod(
  FpcProtocolSelectionType ProtocolSelectionType
);

Parameters

pProtocolSelectionType
Pointer to a variable that on return receives a value from the FpcProtocolSelectionType enumerated type indicating whether the rule applies to all IP traffic, only to the protocols specified in the SpecifiedProtocols property, or to all IP traffic except the protocols specified in the SpecifiedProtocols property.
ProtocolSelectionType
Value from the FpcProtocolSelectionType enumerated type that indicates whether the rule applies to all IP traffic, only to the protocols specified in the SpecifiedProtocols property, or to all IP traffic except the protocols specified in the SpecifiedProtocols property.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write. Its default value is fpcAllIpTraffic, which indicates that the rule applies to all IP traffic.

[Visual Basic]

The ProtocolSelectionMethod property gets or sets a value from the FpcProtocolSelectionType enumerated type that indicates whether the rule applies to all IP traffic, only to certain protocols, or to all IP traffic except certain protocols.

Property ProtocolSelectionMethod As FpcProtocolSelectionType

Property Value

Value from the FpcProtocolSelectionType enumerated type that indicates whether the rule applies to all IP traffic, only to the protocols specified in the SpecifiedProtocols property, or to all IP traffic except the protocols specified in the SpecifiedProtocols property.

Remarks

This property is read/write. Its default value is fpcAllIpTraffic, which indicates that the rule applies to all IP traffic.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCAccessProperties


IFPCAccessProperties.RedirectUrl(BSTR,BSTR) property [ISA Server 2004]

RedirectUrl Property of IFPCAccessProperties[C++]

FPCAccessProperties.RedirectUrl [Visual Basic]

[C++]

The RedirectUrl property gets or sets the URL to which HTTP requests are redirected.

HRESULT get_RedirectUrl(
  BSTR* pbstrURL
);

HRESULT put_RedirectUrl(
  BSTR bstrURL
);

Parameters

pbstrURL
Pointer to a BSTR that is set on return to a string value specifying the URL to which HTTP requests are redirected.
bstrURL
BSTR that specifies the URL to which HTTP requests are redirected.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write. Its default value is an empty string.

If a URL is specified ISA Server returns the URL specified to the client or user when an HTTP request is rejected. The URL must be specified in the format used in the following example.
http://widgets.microsoft.com/denied.htm

Note If you choose to redirect requests, the URL that you specify must be accessible to the clients or users selected. In other words, either the URL must be on an internal computer or some rule must explicitly allow access to the URL.

[Visual Basic]

The RedirectUrl property gets or sets the URL to which HTTP requests are redirected.

Property RedirectUrl As String

Property Value

String that specifies the URL to which HTTP requests are redirected.

Remarks

This property is read/write. Its default value is an empty string.

If a URL is specified ISA Server returns the URL specified to the client or user when an HTTP request is rejected. The URL must be specified in the format used in the following example.
http://widgets.microsoft.com/denied.htm

Note If you choose to redirect requests, the URL that you specify must be accessible to the clients or users selected. In other words, either the URL must be on an internal computer or some rule must explicitly allow access to the URL.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCAccessProperties


IFPCAccessProperties.SpecifiedProtocols(IFPCRefs) property [ISA Server 2004]

SpecifiedProtocols Property of IFPCAccessProperties[C++]

FPCAccessProperties.SpecifiedProtocols [Visual Basic]

[C++]

The SpecifiedProtocols property gets an FPCRefs collection that contains references to the FPCProtocolDefinition objects defining the protocols to which the rule applies or the protocols that are excluded from the rule.

HRESULT get_SpecifiedProtocols(
  IFPCRefs** ppRefs
);

Parameters

ppRefs
Address of an interface pointer that on return points to an IFPCRefs interface that represents the collection of references to the protocols to which the rule applies or the protocols that are excluded from the rule.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only. It can be modified by calling the methods of the IFPCRefs interface retrieved.

[Visual Basic]

The SpecifiedProtocols property gets an FPCRefs collection that contains references to the FPCProtocolDefinition objects defining the protocols to which the rule applies or the protocols that are excluded from the rule.

Property SpecifiedProtocols As FPCRefs

Property Value

Reference to an FPCRefs collection that contains references to the protocols to which the rule applies or the protocols that are excluded from the rule.

Remarks

This property is read-only. It can be modified by calling the methods of the FPCRefs collection retrieved.

Example Code

The following Visual Basic code illustrates the use of the SpecifiedProtocols property.

  Dim root As New FPCLib.FPC
  Dim containingArray As FPCArray
  Dim policyRules As FPCPolicyRules
  Dim newRule As FPCPolicyRule

  Set containingArray = root.GetContainingArray
  Set policyRules = containingArray.ArrayPolicy.PolicyRules
  Set newRule = policyRules.AddAccessRule("All Web Access")
  newRule.Action = fpcActionAllow
  newRule.Description = "Basic Web access to Everyone"
  newRule.Enabled = True
  newRule.AccessProperties.ProtocolSelectionMethod = fpcSpecifiedProtocols
  newRule.AccessProperties.SpecifiedProtocols.Add ("HTTP", fpcInclude)
  newRule.AccessProperties.SpecifiedProtocols.Add ("HTTPS", fpcInclude)
  newRule.SetAppliesAlways
  policyRules.Save

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCAccessProperties


IFPCAccessProperties | FPCAccessProperties URLSets property [ISA Server 2004]

URLSets Property of IFPCAccessProperties[C++]

FPCAccessProperties.URLSets [Visual Basic]

[C++]

The URLSets property gets an FPCRefs collection that contains references to the FPCURLSet collections defining the URL sets to which the rule applies.

HRESULT get_URLSets(
  IFPCRef** ppRefs
);

Parameters

ppRefs
Address of a variable that receives a pointer to an IFPCRefs interface that represents the collection of references to the URL sets to which the rule applies.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only. It can be modified by calling the methods of the IFPCRefs interface retrieved.

The IncludeStatus property of each reference specifies whether the URL set referenced is included in or excluded from the rule.

[Visual Basic]

The URLSets property gets an FPCRefs collection that contains references to the FPCURLSet collections defining the URL sets to which the rule applies.

Property URLSets As FPCRefs

Property Value

Reference to an FPCRefs collection that contains references to the URL sets to which the rule applies.

Remarks

This property is read-only. It can be modified by calling the methods of the FPCRefs collection retrieved.

The IncludeStatus property of each reference specifies whether the URL set referenced is included in or excluded from the rule.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCAccessProperties


IFPCAccessProperties | FPCAccessProperties UserSets property [ISA Server 2004]

UserSets Property of IFPCAccessProperties[C++]

FPCAccessProperties.UserSets [Visual Basic]

[C++]

The UserSets property gets an FPCRefs collection that contains references to the FPCUserSet collections defining the user sets to which the rule applies.

HRESULT get_UserSets(
  IFPCRefs** ppRefs
);

Parameters

ppRefs
Address of a variable that receives a pointer to an IFPCRefs interface that represents the collection of user sets to which the rule applies.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only. It can be modified by calling the methods of the IFPCRefs interface.

The IncludeStatus property of each reference specifies whether the user set referenced is included in or excluded from the rule.

[Visual Basic]

The UserSets property gets an FPCRefs collection that contains references to the FPCUserSet collections defining the user sets to which the rule applies.

Property UserSets As FPCRefs

Property Value

Reference to an FPCRefs collection that contains references to the user sets to which the rule applies.

Remarks

This property is read-only. It can be modified by calling the methods of the FPCRefs collection.

The IncludeStatus property of each reference specifies whether the user set referenced is included in or excluded from the rule.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCAccessProperties


FPCAccount object [ISA Server 2004]

FPCAccount

The FPCAccount object defines an account for a user or a group of users. You can use this object to determine the account type, retrieve or change the account name, and allow or deny access. You can also define users that are not Windows users, and mixed sets of users. For more information see Defining Groups of Users.

The FPCAccount object is typically an element of an FPCAccounts collection.

Click here to see the ISA Server object hierarchy.

Methods

This object has no methods.

Properties

The FPCAccount object has the following properties.

Property | Description
Account | Gets or sets the name of the account, which can be specified in domain\user-name format.
AccountType | Gets a value from the FpcAccountTypes enumerated type that specifies the type of the account.

Remarks

This object implements the IFPCAccount interface.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

COM Objects


IFPCAccount | FPCAccount Account(BSTR,BSTR) property [ISA Server 2004]

Account Property of IFPCAccount[C++]

FPCAccount.Account [Visual Basic]

[C++]

The Account property gets or sets the name of the account, which can be specified in domain\user-name format.

HRESULT get_Account(
  BSTR* pbstrAccount
);

HRESULT put_Account(
  BSTR bstrAccount
);

Parameters

pbstrAccount
Pointer to a BSTR that is set on return to a string value specifying the name of the account.
bstrAccount
BSTR that specifies the name of the account.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write.

[Visual Basic]

The Account property gets or sets the name of the account, which can be specified in domain\user-name format.

Property Account As String

Property Value

String that specifies the name of the account.

Remarks

This property is read/write.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCAccount


IFPCAccount | FPCAccount AccountType(FpcAccountTypes) property [ISA Server 2004]

AccountType Property of IFPCAccount[C++]

FPCAccount.AccountType [Visual Basic]

[C++]

The AccountType property gets a value from the FpcAccountTypes enumerated type that specifies the type of the account. The possible values indicate whether the account refers to a single user, a group of users, a domain of users, an alias, or a predefined group.

HRESULT get_AccountType(
  FpcAccountTypes* pType
);

Parameters

pType
Pointer to a variable that on return receives a value from the FpcAccountTypes enumerated type specifying the type of the account.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The AccountType property gets a value from the FpcAccountTypes enumerated type that specifies the type of the account. The possible values indicate whether the account refers to a single user, a group of users, a domain of users, an alias, or a predefined group.

Property AccountType As FpcAccountTypes

Property Value

Value from the FpcAccountTypes enumerated type that specifies the type of the account.

Remarks

This property is read-only.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCAccount


FPCAccounts collection [ISA Server 2004]

FPCAccounts Collection

The FPCAccounts collection holds a group of FPCAccount objects. You can use this collection to define a user set that can be associated with a policy rule. When a user set is associated with a policy rule, it can be configured to include or exclude the accounts defined in it. For example, you can apply a policy rule to "all users except John," by associating a user set that is defined with the account for the Everyone group and configured as "included," and then adding a user set that is defined with John's account and configured as "excluded."

This collection is typically accessed through the Accounts property of an FPCUserSet object, and through the DomainGroups property of an FPCVpnConfiguration object.

Click here to see the ISA Server object hierarchy.

Methods

The FPCAccounts collection defines the following methods.

Method | Description
Add | Creates a new FPCAccount object in the collection and returns a reference to it.
Item | Retrieves the requested FPCAccount object from the collection.
Refresh | Reads the values of all the properties of the collection and its elements from persistent storage, discarding any changes that were not saved.
Remove | Removes the specified FPCAccount object from the collection.
RemoveAll | Removes all of the FPCAccount objects from the collection.

Properties

The FPCAccounts collection has the following properties.

Property | Description
_NewEnum | Gets an enumerator object for the collection.
Count | Gets the number of FPCAccount objects in the collection.

Remarks

This collection implements the IFPCAccounts interface.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

COM Objects


IFPCAccounts | FPCAccounts _NewEnum(IUnknown) property [ISA Server 2004]

_NewEnum Property of IFPCAccounts[C++]

FPCAccounts._NewEnum [Visual Basic]

[C++]

The _NewEnum property gets an enumerator object for the collection. An enumerator object provides serial access to the elements of the collection.

HRESULT get__NewEnum(
  IUnknown* ppEnum
);

Parameters

ppEnum
Address of an interface pointer that on return points to the IUnknown interface of an enumerator object that implements an IEnumVARIANT interface for the collection. An interface pointer to the IEnumVARIANT interface of the enumerator object can be retrieved by calling QueryInterface on the IUnknown interface returned.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The _NewEnum property gets an enumerator object for the collection. An enumerator object provides serial access to the elements of the collection.

Property _NewEnum As IUnknown

Property Value

Reference to an enumerator object that provides serial access to the elements of the collection.

Remarks

This property is read-only.

In Visual Basic and VBScript, this property is used implicitly in For Each...In...Next constructs.

Example Code

This VBScript script displays the names of all the accounts in a specified user set. It does not include error handling.

' Create the root object.
Dim root  ' The FPCLib.FPC root object
Set root = CreateObject("FPC.Root")

' Declare the other objects needed.
Dim array     ' An FPCArray object
Dim accounts  ' An FPCAccounts collection
Dim account   ' An FPCAccount object
Dim usersets  ' An FPCUserSets collection
Dim userset   ' An FPCUserSet object

' Get references to the array object
' and the user sets collection.
Set array = root.GetContainingArray()
Set usersets = array.RuleElements.UserSets

' If a user set named "System and Network Service" exists,
' display the names of the accounts in it.
On Error Resume Next
Set userset = usersets.Item("System and Network Service")
Set accounts = userset.Accounts
If Err.Number = 0 Then
    For Each account In accounts
        WScript.Echo "Account name: " + account.Account
    Next
End If

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCAccounts


IFPCAccounts | FPCAccounts Add(String,IFPCAccount) method [ISA Server 2004]

IFPCAccounts::Add[C++]

FPCAccounts.Add [Visual Basic]

[C++]

The Add method creates a new FPCAccount object in the collection and returns a reference to it.

HRESULT Add(
  BSTR Account,
  IFPCAccount** ppNewAccount
);

Parameters

Account
[in] Required. BSTR that specifies the account name. The account name can be specified in the domain\user-name format.
ppNewAccount
[out] Address of an interface pointer that on return points to the new IFPCAccount interface created.

Return Values

This method can return one of the following:

  • S_OK, indicating that the operation succeeded.
  • An error code indicating that the operation failed. In this case, the [out] parameter returned is a null object.

[Visual Basic]

The Add method creates a new FPCAccount object in the collection and returns a reference to it.

Function Add( _
  ByVal Account As String _
) As FPCAccount

Parameters

Account
[in] Required. String that specifies the account name. The account name can be specified in the domain\user-name format.

Return Values

This method returns a reference to an FPCAccount object if successful. Otherwise, an error is raised that can be intercepted by using an error handler.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCAccounts


IFPCAccounts | FPCAccounts Count(long) property [ISA Server 2004]

Count Property of IFPCAccounts[C++]

FPCAccounts.Count [Visual Basic]

[C++]

The Count property gets the number of FPCAccount objects in the collection.

HRESULT get_Count(
  long* plCount
);

Parameters

plCount
Pointer to a variable that on return receives a 32-bit integer specifying the number of FPCAccount objects in the collection.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The Count property gets the number of FPCAccount objects in the collection.

Property Count As Long

Property Value

A 32-bit integer value that specifies the number of FPCAccount objects in the collection.

Remarks

This property is read-only.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCAccounts


IFPCAccounts | FPCAccounts Item(Variant,IFPCAccount) method [ISA Server 2004]

IFPCAccounts::Item[C++]

FPCAccounts.Item [Visual Basic]

[C++]

The Item method retrieves the requested IFPCAccount interface from the collection.

HRESULT Item(
  VARIANT Index,
  IFPCAccount** ppItem
);

Parameters

Index
[in] Required. Name or one-based index of the FPCAccount object to retrieve. The account name can be specified in the domain\user-name format.
ppItem
[out] Address of an interface pointer that on return points to the IFPCAccount interface requested.

Return Values

The method can return one of the following:

  • S_OK, indicating that the operation succeeded.
  • An error code indicating that the operation failed. In this case, the [out] parameter returned is a null object.

Remarks

The Index parameter can be either in the form of an index or a name. The domain\user-name format can be used to specify an account by name.

[Visual Basic]

The Item method retrieves the requested FPCAccount object from the collection.

Function Item( _
  ByVal Index As Variant _
) As FPCAccount

Parameters

Index
[in] Required. Name or one-based index of the FPCAccount object to retrieve. The account name can be specified in the domain\user-name format.

Return Values

This method returns a reference to the FPCAccount object requested if successful. Otherwise, an error is raised that can be intercepted by using an error handler.

Remarks

The Index parameter can be either in the form of an index or a name. For example, the following code specifies an account by name in domain\user-name format.

Dim accnts As FPCAccounts
...
accnts.Item("africa\john")

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCAccounts


IFPCAccounts | FPCAccounts Refresh method [ISA Server 2004]

IFPCAccounts::Refresh[C++]

FPCAccounts.Refresh [Visual Basic]

[C++]

The Refresh method reads the values of all the properties of the collection and its elements from persistent storage, discarding any changes that were not saved.

HRESULT Refresh();

Parameters

This method has no parameters.

Return Values

This method returns S_OK if the call is successful; otherwise, it returns an error code.
[Visual Basic]

The Refresh method reads the values of all the properties of the collection and its elements from persistent storage, discarding any changes that were not saved.

Sub Refresh()

Parameters

This method has no parameters.

Return Values

This method has no return values. If the call is unsuccessful, an error is raised that can be intercepted by using an error handler.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCAccounts


IFPCAccounts | FPCAccounts Remove(Variant) method [ISA Server 2004]

IFPCAccounts::Remove[C++]

FPCAccounts.Remove [Visual Basic]

[C++]

The Remove method removes the specified FPCAccount object from the collection.

HRESULT Remove(
  VARIANT Index
);

Parameters

Index
[in] Required. Name or one-based index of the FPCAccount object to remove.

Return Values

This method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

The Index parameter is either in the form of an index or a name. The domain\user-name format can be used to specify an account by name.

[Visual Basic]

The Remove method removes the specified FPCAccount object from the collection.

Sub Remove( _
  ByVal Index As Variant _
)

Parameters

Index
[in] Required. Name or one-based index of the FPCAccount object to remove.

Return Values

This method has no return values. If the call is unsuccessful, an error is raised that can be intercepted by using an error handler.

Remarks

The Index parameter is either in the form of an index or a name. For example, the following code specifies an account by name in domain\user-name format.

Dim accnts As FPCAccounts
...
accnts.Remove("africa\john")

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCAccounts


IFPCAccounts | FPCAccounts RemoveAll method [ISA Server 2004]

IFPCAccounts::RemoveAll[C++]

FPCAccounts.RemoveAll [Visual Basic]

[C++]

The RemoveAll method removes all of the FPCAccount objects from the collection.

HRESULT RemoveAll();

Parameters

This method has no parameters.

Return Values

This method returns S_OK if the call is successful; otherwise, it returns an error code.
[Visual Basic]

The RemoveAll method removes all of the FPCAccount objects from the collection.

Sub RemoveAll()

Parameters

This method has no parameters.

Return Values

This method has no return values. If the call is unsuccessful, an error is raised that can be intercepted by using an error handler.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCAccounts


FPCActiveCacheConfiguration object [ISA Server 2004]

FPCActiveCacheConfiguration

The FPCActiveCacheConfiguration object provides access to the active cache configuration settings of an ISA Server computer. Active caching is a mechanism for automatically obtaining and caching updated content for popular sites. Objects requested from the cache before they expire are considered active.

The FPCActiveCacheConfiguration object is typically accessed through the ActiveCacheConfiguration property of an FPCCacheConfiguration object. For more information about the cache COM objects, see Introduction to the ISA Server Cache Objects.

Click here to see the ISA Server object hierarchy.

Inheritance

This object inherits from the FPCPersist object, which contains methods and properties related to the persistent storage of an object's data. They include methods for exporting an object's data to and importing it from an XML document.

Methods

This object has no methods.

Properties

The FPCActiveCacheConfiguration object has the following properties.

Property | Description
ActiveCachingEnable | Gets or sets a Boolean value that indicates whether active caching is enabled.
ActiveCachingPolicy | Gets or sets a value from the FPCActiveCachingPolicy enumerated type that specifies the policy for prefetching popular objects into the cache.

Methods Inherited from FPCPersist

Name | Description
CancelWaitForChanges | Cancels the registration established by the WaitForChanges method (for use in C and C++ programming only).
CanImport | Returns a Boolean value that indicates whether the object's properties can be imported from the specified XML document.
Export | Writes the stored values of all of the object's properties to the specified XML document.
ExportToFile | Writes the stored values of all of the object's properties to the specified XML file.
GetServiceRestartMask | Retrieves a 32-bit bitmask of the FpcServices enumerated type that specifies which services need to be restarted for currently unsaved changes to take effect.
Import | Copies the values of all of the object's properties from the specified XML document to persistent storage.
ImportFromFile | Copies the values of all of the object's properties from the specified XML file to persistent storage.
LoadDocProperties | Provides the XML document's properties so that you can know what information can be imported from the document.
Refresh | Reads the values of all of the object's properties from persistent storage, overwriting any changes that have not been saved.
Save | Writes the current values of all of the object's properties to persistent storage.
WaitForChanges | Registers to wait for an event indicating that the contents of the object have changed (for use in C and C++ programming only).

Properties Inherited from FPCPersist

Name | Description
PersistentName | Gets the persistent name of the object. The persistent name of an object is a name that is unique for the object at the respective level of the COM object hierarchy.
VendorParametersSets | Gets an FPCVendorParametersSets object that can hold sets of custom data for extending the object.

Remarks

When active caching is enabled, if you are using a dial-up connection to the Internet, the computer will automatically dial out to the Internet service provider (ISP) to retrieve updated content.

This object implements the IFPCActiveCacheConfiguration interface.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

COM Objects


IFPCActiveCacheConfiguration.ActiveCachingEnable property [ISA Server 2004]

ActiveCachingEnable Property of IFPCActiveCacheConfiguration[C++]

FPCActiveCacheConfiguration.ActiveCachingEnable [Visual Basic]

[C++]

The ActiveCachingEnable property gets or sets a Boolean value that indicates whether active caching is enabled.

HRESULT get_ActiveCachingEnable(
  VARIANT_BOOL* pfEnabled
);

HRESULT put_ActiveCachingEnable(
  VARIANT_BOOL fEnabled
);

Parameters

pfEnabled
Pointer to a Boolean variable that is set on return to VARIANT_TRUE if active caching is enabled, or to VARIANT_FALSE if active caching is disabled.
fEnabled
Boolean value that indicates whether active caching is enabled.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write.

[Visual Basic]

The ActiveCachingEnable property gets or sets a Boolean value that indicates whether active caching is enabled.

Property ActiveCachingEnable As Boolean

Property Value

Boolean value that indicates whether active caching is enabled.

Remarks

This property is read/write.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCActiveCacheConfiguration


IFPCActiveCacheConfiguration.ActiveCachingPolicy property [ISA Server 2004]

ActiveCachingPolicy Property of IFPCActiveCacheConfiguration[C++]

FPCActiveCacheConfiguration.ActiveCachingPolicy [Visual Basic]

[C++]

The ActiveCachingPolicy property gets or sets a value from the FPCActiveCachingPolicy enumerated type that specifies the policy for prefetching popular objects into the cache.

HRESULT get_ActiveCachingPolicy(
  FpcActiveCachingPolicy* pPolicy
);

HRESULT put_ActiveCachingPolicy(
  FpcActiveCachingPolicy Policy
);

Parameters

pPolicy
Pointer to a variable that on return receives the value from the FPCActiveCachingPolicy enumerated type specifying the policy for prefetching popular objects into the cache.
Policy
Value from the FPCActiveCachingPolicy enumerated type that specifies the policy for prefetching popular objects into the cache.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write.

[Visual Basic]

The ActiveCachingPolicy property gets or sets a value from the FPCActiveCachingPolicy enumerated type that specifies the policy for prefetching popular objects into the cache.

Property ActiveCachingPolicy As FpcActiveCachingPolicy

Property Value

Value from the FPCActiveCachingPolicy enumerated type that specifies the policy for prefetching popular objects into the cache.

Remarks

This property is read/write.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCActiveCacheConfiguration


FPCAdapter object [ISA Server 2004]

FPCAdapter

The FPCAdapter object represents a single network adapter of an ISA Server computer. You can connect to the Internet through either a direct or dial-up connection. If you choose a direct connection, you need to set up an external network adapter. This object represents that adapter and is typically an element of an FPCAdapters collection.

Click here to see the ISA Server object hierarchy.

Methods

The FPCAdapter object defines the following method.

Method | Description
IsIpInAddressSet | Determines whether an IP address is included in the address set of the adapter.

Properties

The FPCAdapter object has the following properties.

Property | Description
Description | Gets the description of the network adapter.
DhcpEnabled | Gets a Boolean value that indicates whether the network adapter uses the Dynamic Host Configuration Protocol (DHCP).
FriendlyName | Gets the friendly name of the network adapter.
IpAddresses | Gets a comma-delimited list of all IP addresses bound to the network adapter.
IpAddressSet | Gets the IP address set for the network adapter.
IpRanges | Gets an FPCReadOnlyIpRangeSet collection that contains objects representing the IP ranges for the adapter.

Remarks

This object implements the IFPCAdapter interface.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

COM Objects


IFPCAdapter | FPCAdapter Description(BSTR) property [ISA Server 2004]

Description Property of IFPCAdapter[C++]

FPCAdapter.Description [Visual Basic]

[C++]

The Description property gets the description of the network adapter.

HRESULT get_Description(
  BSTR* pbstrDescription
);

Parameters

pbstrDescription
Pointer to a BSTR that is set on return to a string value specifying the description of the network adapter.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The Description property gets the description of the network adapter.

Property Description As String

Property Value

String that specifies the description of the network adapter.

Remarks

This property is read-only.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCAdapter


IFPCAdapter | FPCAdapter DhcpEnabled(VARIANT_BOOL) property [ISA Server 2004]

DhcpEnabled Property of IFPCAdapter[C++]

FPCAdapter.DhcpEnabled [Visual Basic]

[C++]

The DhcpEnabled property gets a Boolean value that indicates whether the network adapter uses the Dynamic Host Configuration Protocol (DHCP).

HRESULT get_DhcpEnabled(
  VARIANT_BOOL pfEnabled
);

Parameters

pfEnabled
Pointer to a Boolean variable that is set on return to VARIANT_TRUE if the network adapter uses DHCP, or to VARIANT_FALSE the network adapter does not use DHCP.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The DhcpEnabled property gets a Boolean value that indicates whether the network adapter uses the Dynamic Host Configuration Protocol (DHCP).

Property DhcpEnabled As Boolean

Property Value

Boolean value that indicates whether the network adapter uses DHCP.

Remarks

This property is read-only.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCAdapter


IFPCAdapter | FPCAdapter FriendlyName(BSTR) property [ISA Server 2004]

FriendlyName Property of IFPCAdapter[C++]

FPCAdapter.FriendlyName [Visual Basic]

[C++]

The FriendlyName property gets the friendly name of the network adapter.

HRESULT get_FriendlyName(
  BSTR* pbstrFriendlyName
);

Parameters

pbstrFriendlyName
Pointer to a BSTR that is set on return to a string value specifying the friendly name of the network adapter.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The FriendlyName property gets the friendly name of the network adapter.

Property FriendlyName As String

Property Value

String that specifies the friendly name of the network adapter.

Remarks

This property is read-only.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCAdapter


IFPCAdapter | FPCAdapter IpAddresses(BSTR) property [ISA Server 2004]

IpAddresses Property of IFPCAdapter[C++]

FPCAdapter.IpAddresses [Visual Basic]

[C++]

The IpAddresses property gets a comma-delimited list of all IP addresses bound to the network adapter.

HRESULT get_IpAddresses(
  BSTR* pbstrIpAddresses
);

Parameters

pbstrIpAddresses
Pointer to a BSTR that is set on return to a string value containing a comma-delimited list of all IP addresses bound to the network adapter.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The IpAddresses property gets a comma-delimited list of all IP addresses bound to the network adapter.

Property IpAddresses As String

Property Value

String containing a comma-delimited list of all IP addresses bound to the network adapter.

Remarks

This property is read-only.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCAdapter


IFPCAdapter | FPCAdapter IpAddressSet(VARIANT) property [ISA Server 2004]

IpAddressSet Property of IFPCAdapter[C++]

FPCAdapter.IpAddressSet [Visual Basic]

[C++]

The IpAddressSet property gets the IP address set for the network adapter.

HRESULT get_IpAddressSet(
  VARIANT* pIpAddressSet
);

Parameters

pIpAddressSet
Pointer to a variable that receives a VARIANT containing an array of strings that specifies the address set for the network adapter.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The IpAddressSet property gets the IP address set for the network adapter.

Property IpAddressSet As Variant

Property Value

Variant containing an array of strings that specifies the address set for the network adapter.

Remarks

This property is read-only.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCAdapter


IFPCAdapter | FPCAdapter IpRanges (1 Parameter) property [ISA Server 2004]

IpRanges Property of IFPCAdapter[C++]

FPCAdapter.IpRanges [Visual Basic]

[C++]

The IpRanges property gets an FPCReadOnlyIpRangeSet collection that contains objects representing the IP ranges for the adapter.

HRESULT get_IpRanges(
  IFPCReadOnlyIpRangeSet** ppIpRange
);

Parameters

ppIpRange
Address of a variable that receives a pointer to an IFPCReadOnlyIpRangeSet interface that represents the collection of IP ranges for the adapter.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The IpRanges property gets an FPCReadOnlyIpRangeSet collection that contains objects representing the IP ranges for the adapter.

Property IpRanges As FPCReadOnlyIpRangeSet

Property Value

Reference to an FPCReadOnlyIpRangeSet collection that contains objects representing the IP ranges for the adapter.

Remarks

This property is read-only.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCAdapter


IFPCAdapter | FPCAdapter IsIpInAddressSet method [ISA Server 2004]

IFPCAdapter::IsIpInAddressSet[C++]

FPCAdapter.IsIpInAddressSet [Visual Basic]

[C++]

The IsIpInAddressSet method determines whether an IP address is included in the address set of the network adapter.

HRESULT IsIpInAddressSet(
  BSTR IpStr,
  VARIANT_BOOL* pfIsIpInAddressSet
);

Parameters

IpStr
[in] Required. BSTR that specifies the IP address.
pfIsIpInAddressSet
[out] Pointer to a Boolean variable that is set on return to VARIANT_TRUE if the IP address is included in the address set of the network adapter, or to VARIANT_FALSE if the IP address is not included in the address set of the network adapter.

Return Values

This method can return one of the following:

  • S_OK, indicating that the operation succeeded.
  • An error message indicating that the operation failed.
[Visual Basic]

The IsIpInAddressSet method determines whether an IP address is included in the address set of the network adapter.

Function IsIpInAddressSet( _
  ByVal IpStr As String _
) As Boolean

Parameters

IpStr
[in] Required. String that specifies the IP address.

Return Values

This method returns a Boolean value that indicates whether the IP address is included in the address set of the network adapter if the call is successful. Otherwise, an error is raised that can be intercepted by using an error handler.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCAdapter


FPCAdapters collection [ISA Server 2004]

FPCAdapters Collection

The FPCAdapters collection holds a set of FPCAdapter objects that represent the available network adapters on a server. You can connect to the Internet through either a direct or dial-up connection. If you choose a direct connection, you need to set up an external network adapter. This collection is typically accessed through the Adapters property of an FPCServer object.

Click here to see the ISA Server object hierarchy.

Methods

The FPCAdapters collection defines the following methods.

Method | Description
Item | Retrieves the requested FPCAdapter object from the collection.
Refresh | Recursively reads all the properties of the collection and its elements, including the properties of its subobjects and their elements (for collections), from persistent storage, discarding any changes that were not saved.

Properties

The FPCAdapters collection has the following properties.

Property | Description
_NewEnum | Gets an enumerator object for the collection.
Count | Gets the number of FPCAdapter objects in the collection.

Remarks

This collection implements the IFPCAdapters interface.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

COM Objects


IFPCAdapters | FPCAdapters _NewEnum(IUnknown) property [ISA Server 2004]

_NewEnum Property of IFPCAdapters[C++]

FPCAdapters._NewEnum [Visual Basic]

[C++]

The _NewEnum property gets an enumerator object for the collection. An enumerator object provides serial access to the elements of the collection.

HRESULT get__NewEnum(
  IUnknown* ppEnum
);

Parameters

ppEnum
Address of an interface pointer that on return points to the IUnknown interface of an enumerator object that implements an IEnumVARIANT interface for the collection. An interface pointer to the IEnumVARIANT interface of the enumerator object can be retrieved by calling QueryInterface on the IUnknown interface returned.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

When the Microsoft ISA Server Control service (isactrl) is stopped, calls to this property method complete successfully without retrieving any data for the adapters collection. This result should not be interpreted as an empty adapters collection.

[Visual Basic]

The _NewEnum property gets an enumerator object for the collection. An enumerator object provides serial access to the elements of the collection.

Property _NewEnum As IUnknown

Property Value

Reference to an enumerator object that provides serial access to the elements of the collection.

Remarks

This property is read-only.

In Visual Basic and VBScript, this property is used implicitly in For Each...In...Next constructs.

Example Code

This VBScript script displays a comma-delimited list of all IP addresses bound to each network adapter on the local ISA Server computer. It does not include error handling.

' Create the root object.
Dim root  ' The FPCLib.FPC root object
Set root = CreateObject("FPC.Root")

' Declare the other objects needed.
Dim server    ' An FPCServer object
Dim adapters  ' An FPCAdapters collection
Dim adapter   ' An FPCAdapter object

' Get references to the server object
' and the adapters collection.
Set server = root.GetContainingServer()
Set adapters = server.Adapters

'Display the IP addresses bound to each network adapter.
For Each adapter In adapters
    WScript.Echo adapter.FriendlyName & ": " & adapter.IpAddresses
Next

When the Microsoft ISA Server Control service (isactrl) is stopped, this script completes successfully without retrieving any data for the adapters collection. This result should not be interpreted as an empty adapters collection.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCAdapters


IFPCAdapters | FPCAdapters Count(long) property [ISA Server 2004]

Count Property of IFPCAdapters[C++]

FPCAdapters.Count [Visual Basic]

[C++]

The Count property gets the number of FPCAdapter objects in the collection.

HRESULT get_Count(
  long* plCount
);

Parameters

plCount
Pointer to a variable that on return receives a 32-bit integer specifying the number of FPCAdapter objects in the collection.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The Count property gets the number of FPCAdapter objects in the collection.

Property Count As Long

Property Value

A 32-bit integer that specifies the number of FPCAdapter objects.

Remarks

This property is read-only.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCAdapters


IFPCAdapters | FPCAdapters Item(Long,IFPCAdapter) method [ISA Server 2004]

IFPCAdapters::Item[C++]

FPCAdapters.Item [Visual Basic]

[C++]

The Item method retrieves the requested IFPCAdapter interface from the collection.

HRESULT Item(
  long Index,
  IFPCAdapter** ppItem
);

Parameters

Index
[in] Required. One-based index of the object to retrieve.
ppItem
[out] Address of a variable that receives a pointer to the IFPCAdapter interface requested.

Return Values

The method can return one of the following:

  • S_OK, indicating that the operation succeeded.
  • An error code indicating that the operation failed. In this case, the [out] parameter returned is a null object.
[Visual Basic]

The Item method retrieves the requested FPCAdapter object from the collection.

Function Item( _
  ByVal Index As Long _
) As FPCAdapter

Parameters

Index
[in] Required. One-based index of the object to retrieve.

Return Values

This method returns a reference to the FPCAdapter object requested if successful. Otherwise, an error is raised that can be intercepted by using an error handler.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCAdapters


IFPCAdapters | FPCAdapters Refresh method [ISA Server 2004]

IFPCAdapters::Refresh[C++]

FPCAdapters.Refresh [Visual Basic]

[C++]

The Refresh method recursively reads all the properties of the collection and its elements, including the properties of its subobjects and their elements (for collections) from persistent storage, discarding any changes that were not saved.

HRESULT Refresh();

Parameters

This method has no parameters.

Return Values

This method returns S_OK if the call is successful; otherwise, it returns an error code.
[Visual Basic]

The Refresh method recursively reads all the properties of the collection and its elements, including the properties of its subobjects and their elements (for collections) from persistent storage, discarding any changes that were not saved.

Sub Refresh()

Parameters

This method has no parameters.

Return Values

This method has no return values. If the call is unsuccessful, an error is raised that can be intercepted by using an error handler.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCAdapters


FPCAddressRange object [ISA Server 2004]

FPCAddressRange

The FPCAddressRange object represents a range of IP addresses. The lower and upper bounds of the range are set when the object is created by the Add method of an FPCAddressRanges collection, and they can be modified by calling the SetIps method.

The FPCAddressRange object is typically an element of an FPCAddressRanges collection.

Click here to see the ISA Server object hierarchy.

Inheritance

This object inherits from the FPCPersist object, which contains methods and properties related to the persistent storage of an object's data. They include methods for exporting an object's data to and importing it from an XML document.

Methods

The FPCAddressRange object defines the following method.

Method | Description
SetIps | Sets the lower and upper bounds of the IP address range.

Properties

The FPCAddressRange object has the following properties.

Property | Description
Description | Gets or sets the description of the address range.
IP_From | Gets the lower bound of the IP address range.
IP_To | Gets the upper bound of the IP address range.
Name | Gets or sets the name of the IP address range.

Methods Inherited from FPCPersist

Name | Description
CancelWaitForChanges | Cancels the registration established by the WaitForChanges method (for use in C and C++ programming only).
CanImport | Returns a Boolean value that indicates whether the object's properties can be imported from the specified XML document.
Export | Writes the stored values of all of the object's properties to the specified XML document.
ExportToFile | Writes the stored values of all of the object's properties to the specified XML file.
GetServiceRestartMask | Retrieves a 32-bit bitmask of the FpcServices enumerated type that specifies which services need to be restarted for currently unsaved changes to take effect.
Import | Copies the values of all of the object's properties from the specified XML document to persistent storage.
ImportFromFile | Copies the values of all of the object's properties from the specified XML file to persistent storage.
LoadDocProperties | Provides the XML document's properties so that you can know what information can be imported from the document.
Refresh | Reads the values of all of the object's properties from persistent storage, overwriting any changes that have not been saved.
Save | Writes the current values of all of the object's properties to persistent storage.
WaitForChanges | Registers to wait for an event indicating that the contents of the object have changed (for use in C and C++ programming only).

Properties Inherited from FPCPersist

Name | Description
PersistentName | Gets the persistent name of the object. The persistent name of an object is a name that is unique for the object at the respective level of the COM object hierarchy.
VendorParametersSets | Gets an FPCVendorParametersSets object that can hold sets of custom data for extending the object.

Remarks

This object implements the IFPCAddressRange interface.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

COM Objects


IFPCAddressRange | FPCAddressRange Description property [ISA Server 2004]

Description Property of IFPCAddressRange[C++]

FPCAddressRange.Description [Visual Basic]

[C++]

The Description property gets or sets the description of the IP address range.

HRESULT get_Description(
  BSTR* pbstrDescription
);

HRESULT put_Description(
  BSTR bstrDescription
);

Parameters

pbstrDescription
Pointer to a BSTR that is set on return to a string value specifying the description of the IP address range.
bstrDescription
BSTR that specifies the description of the IP address range.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write.

[Visual Basic]

The Description property gets or sets the description of the IP address range.

Property Description As String

Property Value

String that specifies the description of the IP address range.

Remarks

This property is read/write.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCAddressRange


IFPCAddressRange | FPCAddressRange IP_From(BSTR) property [ISA Server 2004]

IP_From Property of IFPCAddressRange[C++]

FPCAddressRange.IP_From [Visual Basic]

[C++]

The IP_From property gets the lower bound of the IP address range.

HRESULT get_IP_From(
  BSTR* pbstrFrom
);

Parameters

pbstrFrom
Pointer to a BSTR that is set on return to a string value specifying the lower bound of the IP address range.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only. The lower and upper bounds of the IP address range can be modified by calling the SetIps method.

[Visual Basic]

The IP_From property gets the lower bound of the IP address range.

Property IP_From As String

Property Value

String that specifies the lower bound of the IP address range.

Remarks

This property is read-only. The lower and upper bounds of the IP address range can be modified by calling the SetIps method.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCAddressRange


IFPCAddressRange | FPCAddressRange IP_To(BSTR) property [ISA Server 2004]

IP_To Property of IFPCAddressRange[C++]

FPCAddressRange.IP_To [Visual Basic]

[C++]

The IP_To property gets the upper bound of the IP address range.

HRESULT get_IP_To(
  BSTR* pbstrTo
);

Parameters

pbstrTo
Pointer to a BSTR that is set on return to a string value specifying the upper bound of the IP address range.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only. The lower and upper bounds of the IP address range can be modified by calling the SetIps method.

[Visual Basic]

The IP_To property gets the upper bound of the IP address range.

Property IP_To As String

Property Value

String that specifies the upper bound of the IP address range.

Remarks

This property is read-only. The lower and upper bounds of the IP address range can be modified by calling the SetIps method.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCAddressRange


IFPCAddressRange | FPCAddressRange Name(BSTR,BSTR) property [ISA Server 2004]

Name Property of IFPCAddressRange[C++]

FPCAddressRange.Name [Visual Basic]

[C++]

The Name property gets or sets the name of the IP address range.

HRESULT get_Name(
  BSTR* pbstrName
);

HRESULT put_Name(
  BSTR bstrName
);

Parameters

pbstrName
Pointer to a BSTR that is set on return to a string value specifying the name of the IP address range.
bstrName
BSTR that specifies the name of the IP address range.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write.

[Visual Basic]

The Name property gets or sets the name of the IP address range.

Property Name As String

Property Value

String that specifies the name of the IP address range.

Remarks

This property is read/write.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCAddressRange


IFPCAddressRange | FPCAddressRange SetIps method [ISA Server 2004]

IFPCAddressRange::SetIps[C++]

FPCAddressRange.SetIps [Visual Basic]

[C++]

The SetIps method sets the lower and upper bounds of the address range.

HRESULT SetIps(
  BSTR Ip_From,
  BSTR Ip_To
);

Parameters

Ip_From
[in] BSTR that specifies the lower bound of the IP address range.
Ip_To
[in] BSTR that specifies the upper bound of the IP address range.

Return Values

This method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This method modifies the IP_From and IP_To properties. The lower and upper bounds of the IP address range are initially set by the values passed to the IP_From and IP_To parameters of the Add method of the IFPCAddressRanges interface when the object is created.

[Visual Basic]

The SetIps method sets the lower and upper bounds of the address range.

Sub SetIps( _
  ByVal Ip_From As String, _
  ByVal Ip_To As String _
)

Parameters

Ip_From
[in] String that specifies the lower bound of the IP address range.
Ip_To
[in] String that specifies the upper bound of the IP range.

Return Values

This method has no return values. If the call is unsuccessful, an error is raised that can be intercepted by using an error handler.

Remarks

This method modifies the IP_From and IP_To properties. The lower and upper bounds of the IP address range are initially set by the values passed to the IP_From and IP_To parameters of the Add method of the FPCAddressRanges collection when the object is created.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCAddressRange


FPCAddressRanges collection [ISA Server 2004]

FPCAddressRanges Collection

The FPCAddressRanges collection holds the set of FPCAddressRange objects that are defined in a computer set, or the set of FPCAddressRange objects that are defined as rule elements. Each FPCAddressRange object represents a range of IP addresses.

The FPCAddressRanges collection can be accessed through the AddressRanges property of an FPCComputerSet object or through the AddressRanges property of an FPCRuleElements object.

Click here to see the ISA Server object hierarchy.

Inheritance

This collection inherits from the FPCPersist object, which contains methods and properties related to the persistent storage of an object's data. They include methods for exporting the object's data to and importing it from an XML document.

Methods

The FPCAddressRanges collection defines the following methods.

Method | Description
Add | Creates a new FPCAddressRange object in the collection and returns a reference to it.
Item | Returns the requested FPCAddressRange object from the collection.
Remove | Removes the specified FPCAddressRange object from the collection.

Properties

The FPCAddressRanges collection has the following properties.

Property | Description
_NewEnum | Gets an enumerator object for the collection.
Count | Gets the number of FPCAddressRange objects in the collection.

Methods Inherited from FPCPersist

Name | Description
CancelWaitForChanges | Cancels the registration established by the WaitForChanges method (for use in C and C++ programming only).
CanImport | Returns a Boolean value that indicates whether the properties of the collection and its elements can be imported from the specified XML document.
Export | Writes the stored values of all the properties of the collection and its elements to the specified XML document.
ExportToFile | Writes the stored values of all the properties of the collection and its elements to the specified XML file.
GetServiceRestartMask | Retrieves a 32-bit bitmask of the FpcServices enumerated type that specifies which services need to be restarted for currently unsaved changes to take effect.
Import | Copies the values of all the properties of the collection and its elements from the specified XML document to persistent storage.
ImportFromFile | Copies the values of all the properties of the collection and its elements from the specified XML file to persistent storage.
LoadDocProperties | Provides the XML document's properties so that you can know what information can be imported from the document.
Refresh | Reads the values of all the properties of the collection and its elements from persistent storage, overwriting any changes that have not been saved.
Save | Writes the current values of all the properties of the collection and its elements to persistent storage.
WaitForChanges | Registers to wait for an event indicating that the contents of the object have changed (for use in C and C++ programming only).

Properties Inherited from FPCPersist

Name | Description
PersistentName | Gets the persistent name of the collection. The persistent name of an object is a name that is unique for the object at the respective level of the COM object hierarchy.
VendorParametersSets | Gets an FPCVendorParametersSets collection that can hold sets of custom data for extending the collection.

Remarks

This collection implements the IFPCAddressRanges interface.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

COM Objects


IFPCAddressRanges | FPCAddressRanges _NewEnum property [ISA Server 2004]

_NewEnum Property of IFPCAddressRanges[C++]

FPCAddressRanges._NewEnum [Visual Basic]

[C++]

The _NewEnum property gets an enumerator object for the collection. An enumerator object provides serial access to the elements of the collection.

HRESULT get__NewEnum(
  IUnknown* ppEnum
);

Parameters

ppEnum
Address of an interface pointer that on return points to the IUnknown interface of an enumerator object that implements an IEnumVARIANT interface for the collection. An interface pointer to the IEnumVARIANT interface of the enumerator object can be retrieved by calling QueryInterface on the IUnknown interface returned.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The _NewEnum property gets an enumerator object for the collection. An enumerator object provides serial access to the elements of the collection.

Property _NewEnum As IUnknown

Property Value

Reference to an enumerator object that provides serial access to the elements of the collection.

Remarks

This property is read-only.

In Visual Basic and VBScript, this property is used implicitly in For Each...In...Next constructs.

Example Code

This VBScript script displays the names of all the address ranges defined for an FPCArray object. It does not include error handling.

' Create the root object.
Dim root  ' The FPCLib.FPC root object
Set root = CreateObject("FPC.Root")

' Declare the other objects needed.
Dim array          ' An FPCArray object
Dim addressranges  ' An FPCAddressRanges collection
Dim addressrange   ' An FPCAddressRange object

' Get references to the array object
' and the address ranges collection.
Set array = root.GetContainingArray()
Set addressranges = array.RuleElements.AddressRanges

' Display the names of the address ranges
' defined for the array object.
For Each addressrange In addressranges
    WScript.Echo "Address range name: " & addressrange.Name
Next

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCAddressRanges


IFPCAddressRanges | FPCAddressRanges Add (4 Parameters) method [ISA Server 2004]

IFPCAddressRanges::Add[C++]

FPCAddressRanges.Add [Visual Basic]

[C++]

The Add method creates a new FPCAddressRange object in the collection and returns a reference to it.

HRESULT Add(
  BSTR Name,
  BSTR IP_From,
  BSTR IP_To,
  IFPCAddressRange** ppNewItem
);

Parameters

Name
[in] Required. BSTR that specifies the name of the IP address range.
IP_From
[in] Required. BSTR that specifies the lower bound of the IP address range.
IP_To
[in] Required. BSTR that specifies the upper bound of the IP address range.
ppNewItem
[out] Address of an interface pointer that on return points to the new IFPCAddressRange interface created.

Return Values

This method can return one of the following:

  • S_OK, indicating that the operation succeeded.
  • An error code, indicating that the operation failed. In this case, the [out] parameter returned is a null object.

[Visual Basic]

The Add method creates a new FPCAddressRange object in the collection and returns a reference to it.

Function Add( _
  ByVal Name As String, _
  ByVal IP_From As String, _
  ByVal IP_To As String _
) As FPCAddressRange

Parameters

Name
[in] Required. String that specifies the name of the IP address range.
IP_From
[in] Required. String that specifies the lower bound of the IP address range.
IP_To
[in] Required. String that specifies the upper bound of the IP address range.

Return Values

This method returns a reference to an FPCAddressRange object if successful. Otherwise, an error is raised that can be intercepted by using an error handler.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCAddressRanges


IFPCAddressRanges | FPCAddressRanges Count(long) property [ISA Server 2004]

Count Property of IFPCAddressRanges[C++]

FPCAddressRanges.Count [Visual Basic]

[C++]

The Count property gets the number of FPCAddressRange objects in the collection.

HRESULT get_Count(
  long* plCount
);

Parameters

plCount
Pointer to a variable that receives a 32-bit integer specifying the number of FPCAddressRange objects.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The Count property gets the number of FPCAddressRange objects in the collection.

Property Count As Long

Property Value

A 32-bit integer that specifies the number of FPCAddressRange objects in the collection.

Remarks

This property is read-only.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCAddressRanges


IFPCAddressRanges | FPCAddressRanges Item method [ISA Server 2004]

IFPCAddressRanges::Item[C++]

FPCAddressRanges.Item [Visual Basic]

[C++]

The Item method retrieves the requested IFPCAddressRange interface from the collection.

HRESULT Item(
  VARIANT Index,
  IFPCAddressRange** ppItem
);

Parameters

Index
[in] Required. Name or one-based index of the object to retrieve.
ppItem
[out] Address of a variable that receives a pointer to the IFPCAddressRange interface requested.

Return Values

This method can return one of the following:

  • S_OK, indicating that the operation succeeded.
  • An error code, indicating that the operation failed. In this case, the [out] parameter returned is a null object.
[Visual Basic]

The Item method retrieves the requested FPCAddressRange object from the collection.

Function Item( _
  ByVal Index As Variant _
) As FPCAddressRange

Parameters

Index
[in] Required. Name or one-based index of the object to retrieve.

Return Values

This method returns a reference to the FPCAddressRange object requested if successful. Otherwise, an error is raised that can be intercepted by using an error handler.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCAddressRanges


IFPCAddressRanges | FPCAddressRanges Remove(Variant) method [ISA Server 2004]

IFPCAddressRanges::Remove[C++]

FPCAddressRanges.Remove [Visual Basic]

[C++]

The Remove method removes the specified FPCAddressRange object from the collection.

HRESULT Remove(
  VARIANT Index
);

Parameters

Index
[in] Required. Name or one-based index of the FPCAddressRange object to remove.

Return Values

This method returns S_OK if the call is successful; otherwise, it returns an error code.
[Visual Basic]

The Remove method removes the specified FPCAddressRange object from the collection.

Sub Remove( _
  ByVal Index As Variant _
)

Parameters

Index
[in] Required. Name or one-based index of the FPCAddressRange object to remove.

Return Values

This method has no return values. If the call is unsuccessful, an error is raised that can be intercepted by using an error handler.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCAddressRanges


FPCAdminSecurity object [ISA Server 2004]

FPCAdminSecurity

The FPCAdminSecurity object holds the administrative security settings.

This object can be accessed through the AdminSecurity property of the FPCArray object.

Click here to see the ISA Server object hierarchy.

Inheritance

This object inherits from the FPCPersist object, which contains methods and properties related to the persistent storage of an object's data. They include methods for exporting an object's data to and importing it from an XML document.

Methods

This object has no methods.

Properties

The FPCAdminSecurity object has the following properties.

Property | Description
DelegatedAdmins | Gets an FPCDelegatedAdmins collection that contains the delegated administrators.
SecurityRoles | Gets an FPCSecurityRoles collection that contains the security role definitions.

Methods Inherited from FPCPersist

Name | Description
CancelWaitForChanges | Cancels the registration established by the WaitForChanges method (for use in C and C++ programming only).
CanImport | Returns a Boolean value that indicates whether the object's properties can be imported from the specified XML document.
Export | Recursively writes the stored values of all the properties of the object and its subobjects to the specified XML document.
ExportToFile | Recursively writes the stored values of all the properties of the object and its subobjects to the specified XML file.
GetServiceRestartMask | Retrieves a 32-bit bitmask of the FpcServices enumerated type that specifies which services need to be restarted for currently unsaved changes to take effect.
Import | Recursively copies the values of all the properties of the object and of its subobjects from the specified XML document to persistent storage.
ImportFromFile | Recursively copies the values of all the properties of the object and of its subobjects from the specified XML file to persistent storage.
LoadDocProperties | Provides the XML document's properties so that you can know what information can be imported from the document.
Refresh | Recursively reads the values of all the properties of the object and of its subobjects from persistent storage, overwriting any changes that have not been saved.
Save | Recursively writes the current values of all the properties of the object and its subobjects to persistent storage.
WaitForChanges | Registers to wait for an event indicating that the contents of the object have changed (for use in C and C++ programming only).

Properties Inherited from FPCPersist

Name | Description
PersistentName | Gets the persistent name of the object. The persistent name of an object is a name that is unique for the object at the respective level of the COM object hierarchy.
VendorParametersSets | Gets an FPCVendorParametersSets collection that can hold sets of custom data for extending the object.

Remarks

This collection implements the IFPCAdminSecurity interface.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

COM Objects


IFPCAdminSecurity | FPCAdminSecurity DelegatedAdmins property [ISA Server 2004]

DelegatedAdmins Property of IFPCAdminSecurity[C++]

FPCAdminSecurity.DelegatedAdmins [Visual Basic]

[C++]

The DelegatedAdmins property gets an FPCDelegatedAdmins collection containing the delegated administrators.

HRESULT get_DelegatedAdmins(
  IFPCDelegatedAdmins* ppDelegatedAdmins
);

Parameters

ppDelegatedAdmins
Address of an interface pointer that on return points to an IFPCDelegatedAdmins interface that represents the collection of delegated administrators.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only. Delegated administrators can be added or removed from the collection by calling the methods of the IFPCDelegatedAdmins interface retrieved.

[Visual Basic]

The DelegatedAdmins property gets an FPCDelegatedAdmins collection containing the delegated administrators.

Property DelegatedAdmins As FPCDelegatedAdmins

Property Value

Reference to an FPCDelegatedAdmins collection that contains the delegated administrators.

Remarks

This property is read-only. Delegated administrators can be added or removed from the collection by calling the methods of the FPCDelegatedAdmins collection retrieved.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCAdminSecurity


IFPCAdminSecurity | FPCAdminSecurity SecurityRoles property [ISA Server 2004]

SecurityRoles Property of IFPCAdminSecurity[C++]

FPCAdminSecurity.SecurityRoles [Visual Basic]

[C++]

The SecurityRoles property gets an FPCSecurityRoles collection that contains the security role definitions.

HRESULT get_SecurityRoles(
  IFPCSecurityRoles* ppSecurityRoles
);

Parameters

ppSecurityRoles
Address of an interface pointer that on return points to an IFPCSecurityRoles interface that represents the collection of security role definitions.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only. Security role definitions can be added and removed from the collection by calling the methods of the IFPCSecurityRoles interface retrieved.

[Visual Basic]

The SecurityRoles property gets an FPCSecurityRoles collection that contains the security role definitions.

Property SecurityRoles As FPCSecurityRoles

Property Value

Reference to an FPCSecurityRoles collection that contains the security role definitions.

Remarks

This property is read-only. Security role definitions can be added and removed from the collection by calling the methods of the FPCSecurityRoles collection retrieved.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCAdminSecurity


FPCAlert object [ISA Server 2004]

FPCAlert

The FPCAlert object defines an alert. When a specific event occurs, this object determines the actions to be taken in response to that event. The FPCAlert object also defines three thresholds that determine whether an alert will be issued and the actions defined for it will be taken. With alerts, an administrator can be notified about the occurrence of certain events and decide which actions should be taken in advance. Properties of the actions to be taken can be accessed through the FPCAlertActions collection.

This object is typically an element of an FPCAlerts collection.

Click here to see the ISA Server object hierarchy.

Inheritance

This object inherits from the FPCPersist object, which contains methods and properties related to the persistent storage of an object's data. They include methods for exporting an object's data to and importing it from an XML document.

Methods

The FPCAlert object defines the following method.

Method | Description
SetDefinitions | Sets the following properties of the alert: the globally unique identifier (GUID) of the event for which the alert is issued, the name of the server that issues the alert, and the additional key.

Properties

The FPCAlert object has the following properties.

Property | Description
Actions | Gets an FPCAlertActions collection that contains FPCAlertAction objects defining the actions to be taken in response to the event that issues the alert.
AdditionalKey | Gets the additional key in the table of subevents defined for the event for which the alert is issued.
Category | Gets or sets a value from the FpcAlertCategory enumerated type that specifies the category of the alert.
Description | Gets or sets the description of the alert.
Enabled | Gets or sets a Boolean value that indicates whether the alert is enabled.
EventGUID | Gets the globally unique identifier (GUID) of the event for which the alert is issued.
EventsBeforeRaise | Gets or sets the minimal number of occurrences of the event for which the alert is issued before the alert can be issued.
MinEventsPerSecond | Gets or sets the minimal frequency of occurrences of the event for which the alert is issued before the alert can be issued.
MinutesBeforeReRaise | Gets or sets a time interval that must pass before the alert can be issued again.
Name | Gets or sets the name of the alert object.
Password | Sets the password in the credentials supplied for command-line actions.
ServerName | Gets the name of the server that is allowed to issue the alert.
Severity | Gets or sets a value from the FpcAlertSeverity enumerated type that specifies the severity of the alert.
UserName | Gets or sets the user name in the credentials supplied for command-line actions.

Methods Inherited from FPCPersist

Name | Description
CancelWaitForChanges | Cancels the registration established by the WaitForChanges method (for use in C and C++ programming only).
CanImport | Returns a Boolean value that indicates whether the object's properties can be imported from the specified XML document.
Export | Recursively writes the stored values of all the properties of the object and its subobjects to the specified XML document.
ExportToFile | Recursively writes the stored values of all the properties of the object and its subobjects to the specified XML file.
GetServiceRestartMask | Retrieves a 32-bit bitmask of the FpcServices enumerated type that specifies which services need to be restarted for currently unsaved changes to take effect.
Import | Recursively copies the values of all the properties of the object and of its subobjects from the specified XML document to persistent storage.
ImportFromFile | Recursively copies the values of all the properties of the object and of its subobjects from the specified XML file to persistent storage.
LoadDocProperties | Provides the XML document's properties so that you can know what information can be imported from the document.
Refresh | Recursively reads the values of all the properties of the object and of its subobjects from persistent storage, overwriting any changes that have not been saved.
Save | Recursively writes the current values of all the properties of the object and its subobjects to persistent storage.
WaitForChanges | Registers to wait for an event indicating that the contents of the object have changed (for use in C and C++ programming only).

Properties Inherited from FPCPersist

Name | Description
PersistentName | Gets the persistent name of the object. The persistent name of an object is a name that is unique for the object at the respective level of the COM object hierarchy.
VendorParametersSets | Gets an FPCVendorParametersSets collection that can hold sets of custom data for extending the object.

Remarks

This object implements the IFPCAlert interface.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

COM Objects


IFPCAlert | FPCAlert Actions(IFPCAlertActions) property [ISA Server 2004]

Actions Property of IFPCAlert[C++]

FPCAlert.Actions [Visual Basic]

[C++]

The Actions property gets an FPCAlertActions collection that contains FPCAlertAction objects defining the actions to be taken in response to the event for which the alert is issued.

HRESULT get_Actions(
  IFPCAlertActions** ppAlertActions
);

Parameters

ppAlertActions
Address of an interface pointer that on return points to an IFPCAlertActions interface that represents the collection of actions to be taken.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only. Actions can be added or removed from the collection by calling the methods of the IFPCAlertActions interface retrieved.

[Visual Basic]

The Actions property gets an FPCAlertActions collection that contains FPCAlertAction objects defining the actions to be taken in response to the event for which the alert is issued.

Property Actions As FPCAlertActions

Property Value

Reference to the FPCAlertActions collection.

Remarks

This property is read-only. Actions can be added or removed from the collection by calling the methods of the FPCAlertActions collection retrieved.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCAlert


IFPCAlert | FPCAlert AdditionalKey(long) property [ISA Server 2004]

AdditionalKey Property of IFPCAlert[C++]

FPCAlert.AdditionalKey [Visual Basic]

[C++]

The AdditionalKey property gets the additional key (index) in the table of subevents defined for the event for which the alert is issued.

HRESULT get_AdditionalKey(
  long* plKey
);

Parameters

plKey
Pointer to a variable that receives a 32-bit integer specifying the additional key.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only. Its value can be modified, along with the values of the EventGUID and ServerName properties, by calling the SetDefinitions method.

Additional keys serve as a means to subdivide event objects into related subevents. For example, a disk-full event can be subdivided into log-disk-full and system-disk-full subevents. This provides for the issuing of either different alerts that are specific to subevents or a single alert that is specific to all subevents.

For example, an administrator can add separate alerts for each separate subevent by specifying the applicable values of the EventGUID and AdditionalKey properties for each subevent. The AdditionalKey property is the index used in the table of subevents. Alternatively, an administrator can treat all subevents as a single event by specifying the EventGUID and setting the AdditionalKey to zero. In other words, the index zero is reserved and should not be overloaded with a user-specified subevent.

If an event has no subevents, the value of this property should be –1.

The table of subevents cannot be modified; an administrator can only select keys from the table.

[Visual Basic]

The AdditionalKey property gets the additional key (index) in the table of subevents defined for the event for which the alert is issued.

Property AdditionalKey As Long

Property Value

A 32-bit integer that specifies the additional key.

Remarks

This property is read-only. Its value can be modified, along with the values of the EventGUID and ServerName properties, by calling the SetDefinitions method.

Additional keys serve as a means to subdivide event objects into related subevents. For example, a disk-full event can be subdivided into log-disk-full and system-disk-full subevents. This provides for the issuing of either different alerts that are specific to subevents or a single alert that is specific to all subevents.

For example, an administrator can add separate alerts for each separate subevent by specifying the applicable values of the EventGUID and AdditionalKey properties for each subevent. The AdditionalKey property is the index used in the table of subevents. Alternatively, an administrator can treat all subevents as a single event by specifying the EventGUID and setting the AdditionalKey to zero. In other words, the index zero is reserved and should not be overloaded with a user-specified subevent.

If an event has no subevents, the value of this property should be –1.

The table of subevents cannot be modified; an administrator can only select keys from the table.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCAlert


IFPCAlert | FPCAlert Category (2 Parameters) property [ISA Server 2004]

Category Property of IFPCAlert[C++]

FPCAlert.Category [Visual Basic]

[C++]

The Category property gets or sets a value from the FpcAlertCategory enumerated type that specifies the category of the alert. The possible categories are:

  • A security alert
  • A cache alert
  • A routing alert
  • A Microsoft Firewall service alert
  • An other or user-defined alert

HRESULT get_Category(
  FpcAlertCategory* pCategory
);

HRESULT put_Category(
  FpcAlertCategory* Category
);

Parameters

Category
Value from the FpcAlertCategory enumerated type that specifies the category of the alert.
pCategory
Pointer to a variable that receives the value from the FpcAlertCategory enumerated type that specifies the category of the alert.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write.

[Visual Basic]

The Category property gets or sets a value from the FpcAlertCategory enumerated type that specifies the category of the alert. The possible categories are:

  • A security alert
  • A cache alert
  • A routing alert
  • A Microsoft Firewall service alert
  • An other or user-defined alert

Property Category As FpcAlertCategory

Property Value

Value from the FpcAlertCategory enumerated type that specifies the category of the alert.

Remarks

This property is read/write.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCAlert


IFPCAlert | FPCAlert Description(BSTR,BSTR) property [ISA Server 2004]

Description Property of IFPCAlert[C++]

FPCAlert.Description [Visual Basic]

[C++]

The Description property gets or sets the description of the alert.

HRESULT get_Description(
  BSTR* pbstrDescription
);

HRESULT put_Description(
  BSTR bstrDescription
);

Parameters

pbstrDescription
Pointer to a BSTR that is set on return to a string value specifying the description of the alert.
bstrDescription
BSTR that specifies the description of the alert.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write.

[Visual Basic]

The Description property gets or sets the description of the alert.

Property Description As String

Property Value

String that specifies the description of the alert.

Remarks

This property is read/write.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCAlert


IFPCAlert | FPCAlert Enabled (2 Parameters) property [ISA Server 2004]

Enabled Property of IFPCAlert[C++]

FPCAlert.Enabled [Visual Basic]

[C++]

The Enabled property gets or sets a Boolean value that indicates whether the alert is enabled.

HRESULT get_Enabled(
  VARIANT_BOOL* pfEnabled
);

HRESULT put_Enabled(
  VARIANT_BOOL fEnabled
);

Parameters

pfEnabled
Pointer to a Boolean variable that is set on return to VARIANT_TRUE if the alert is enabled, or to VARIANT_FALSE if the alert is disabled.
fEnabled
Boolean value that indicates whether the alert is enabled.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write.

[Visual Basic]

The Enabled property gets or sets a Boolean value that indicates whether the alert is enabled.

Property Enabled As Boolean

Property Value

Boolean value that indicates whether the alert is enabled.

Remarks

This property is read/write.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCAlert


IFPCAlert | FPCAlert EventGUID() property [ISA Server 2004]

EventGUID Property of IFPCAlert[C++]

FPCAlert.EventGUID [Visual Basic]

[C++]

The EventGUID property gets the string-formatted globally unique identifier (GUID) of the event for which the alert is issued.

HRESULT get_EventGUID(
  * pbstrGuid
);

Parameters

pbstrGuid
Pointer to a BSTR that is set on return to a string value specifying the string-formatted GUID of the event that signals the alert.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only. Its value can be modified, along with the values of the AdditionalKey and ServerName properties, by calling the SetDefinitions method.

The GUID retrieved is formatted as a string in the form {12345678-1234-1234-1234-123456789ABC}. Note the presence of the braces normally used with GUIDs.

[Visual Basic]

The EventGUID property gets the string-formatted globally unique identifier (GUID) of the event for which the alert is issued.

Property EventGUID As String

Property Value

String containing the GUID of the event for which the alert is issued.

Remarks

This property is read-only. Its value can be modified, along with the values of the AdditionalKey and ServerName properties, by calling the SetDefinitions method.

The GUID retrieved is formatted as a string in the form {12345678-1234-1234-1234-123456789ABC}. Note the presence of the braces normally used with GUIDs.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCAlert


IFPCAlert | FPCAlert EventsBeforeRaise(long,long) property [ISA Server 2004]

EventsBeforeRaise Property of IFPCAlert[C++]

FPCAlert.EventsBeforeRaise [Visual Basic]

[C++]

The EventsBeforeRaise property gets or sets the minimal number of occurrences of the event for which the alert is issued before the alert can be issued.

The MinutesBeforeReRaise, EventsBeforeRaise, and MinEventsPerSecond properties set the three thresholds that the Microsoft Firewall service uses to issue alerts. For each alert, the Firewall service stores the time when the event last occurred, a count of how many times the event has occurred per second, and a count of the total number of times that the event has occurred. An alert is issued, and the alert invokes the actions defined for it only when the three threshold requirements for issuing the alert are met simultaneously.

The EventsBeforeRaise property sets the threshold number of occurrences of the event.

HRESULT get_EventsBeforeRaise(
  long* plThreshold
);

HRESULT put_EventsBeforeRaise(
  long lThreshold
);

Parameters

plThreshold
Pointer to a variable that on return receives a 32-bit integer specifying the threshold number of occurrences of the event.
lThreshold
A 32-bit integer that specifies the threshold number of occurrences of the event.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write.

[Visual Basic]

The EventsBeforeRaise property gets or sets the minimal number of occurrences of the event for which the alert is issued before the alert can be issued.

The MinutesBeforeReRaise, EventsBeforeRaise, and MinEventsPerSecond properties set the three thresholds that the Microsoft Firewall service uses to issue alerts. For each alert, the Firewall service stores the time when the event last occurred, a count of how many times the event has occurred per second, and a count of the total number of times that the event has occurred. An alert is issued, and the alert invokes the actions defined for it only when the three threshold requirements for issuing the alert are met simultaneously.

The EventsBeforeRaise property sets the threshold number of occurrences of the event.

Property EventsBeforeRaise As Long

Property Value

A 32-bit integer that specifies the threshold number of occurrences of the event.

Remarks

This property is read/write.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCAlert


IFPCAlert | FPCAlert MinEventsPerSecond(long,long) property [ISA Server 2004]

MinEventsPerSecond Property of IFPCAlert[C++]

FPCAlert.MinEventsPerSecond [Visual Basic]

[C++]

The MinEventsPerSecond property gets or sets the minimal frequency of occurrences of the event for which the alert is issued before the alert can be issued.

The MinutesBeforeReRaise, EventsBeforeRaise, and MinEventsPerSecond properties set the three thresholds that the Microsoft Firewall service uses to issue alerts. For each alert, the Firewall service stores the time when the event last occurred, a count of how many times the event has occurred per second, and a count of the total number of times that the event has occurred. An alert is issued, and the alert invokes the actions defined for it only when the three threshold requirements for issuing the alert are met simultaneously.

The MinEventsPerSecond property sets the event frequency threshold.

HRESULT get_MinEventsPerSecond(
  long* plThreshold
);

HRESULT put_MinEventsPerSecond(
  long lThreshold
);

Parameters

plThreshold
Pointer to a variable that on return receives a 32-bit integer specifying the event frequency threshold.
lThreshold
A 32-bit integer that specifies the event frequency threshold.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write.

[Visual Basic]

The MinEventsPerSecond property gets or sets the minimal frequency of occurrences of the event for which the alert is issued before the alert can be issued.

The MinutesBeforeReRaise, EventsBeforeRaise, and MinEventsPerSecond properties set the three thresholds that the Microsoft Firewall service uses to issue alerts. For each alert, the Firewall service stores the time when the event last occurred, a count of how many times the event has occurred per second, and a count of the total number of times that the event has occurred. An alert is issued, and the alert invokes the actions defined for it only when the three threshold requirements for issuing the alert are met simultaneously.

The MinEventsPerSecond property sets the event frequency threshold.

Property MinEventsPerSecond As Long

Property Value

A 32-bit integer that specifies the event frequency threshold.

Remarks

This property is read/write.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCAlert


IFPCAlert | FPCAlert MinutesBeforeReRaise(long,long) property [ISA Server 2004]

MinutesBeforeReRaise Property of IFPCAlert[C++]

FPCAlert.MinutesBeforeReRaise [Visual Basic]

[C++]

The MinutesBeforeReRaise property gets or sets a time interval that must pass before the alert can be issued again.

The MinutesBeforeReRaise, EventsBeforeRaise, and MinEventsPerSecond properties set the three thresholds that the Microsoft Firewall service uses to issue alerts. For each alert, the Firewall service stores the time when the event last occurred, a count of how many times the event has occurred per second, and a count of the total number of times that the event has occurred. An alert is issued, and the alert invokes the actions defined for it only when the three threshold requirements for issuing the alert are met simultaneously.

The MinutesBeforeReRaise property sets the threshold time interval.

HRESULT get_MinutesBeforeReRaise(
  long* plInterval
);

HRESULT put_MinutesBeforeReRaise(
  long lInterval
);

Parameters

plInterval
Pointer to a variable that on return receives a 32-bit integer specifying the threshold time interval.
lInterval
A 32-bit integer that specifies the threshold time interval.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property can have the following values:

Value | Description
Positive integer | The number of minutes to wait.
0 | The alert can be issued again immediately.
–1 | The alert must be reset before it can be issued again. You can do this through ISA Server Management.

This property is read/write.

[Visual Basic]

The MinutesBeforeReRaise property gets or sets a time interval that must pass before the alert can be issued again.

The MinutesBeforeReRaise, EventsBeforeRaise, and MinEventsPerSecond properties set the three thresholds that the Microsoft Firewall service uses to issue alerts. For each alert, the Firewall service stores the time when the event last occurred, a count of how many times the event has occurred per second, and a count of the total number of times that the event has occurred. An alert is issued, and the alert invokes the actions defined for it only when the three threshold requirements for issuing the alert are met simultaneously.

The MinutesBeforeReRaise property sets the threshold time interval.

Property MinutesBeforeReRaise As Long

Property Value

A 32-bit integer that specifies the threshold time interval.

Remarks

This property can have the following values:

Value | Description
Positive integer | The number of minutes to wait.
0 | The alert can be issued again immediately.
–1 | The alert must be reset before it can be issued again. You can do this through ISA Server Management.

This property is read/write.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCAlert


IFPCAlert | FPCAlert Name(BSTR,BSTR) property [ISA Server 2004]

Name Property of IFPCAlert[C++]

FPCAlert.Name [Visual Basic]

[C++]

The Name property gets or sets the name of the alert.

HRESULT get_Name(
  BSTR* pbstrName
);

HRESULT put_Name(
  BSTR bstrName
);

Parameters

pbstrName
Pointer to a BSTR that is set on return to a string value specifying the name of the alert.
bstrName
BSTR that specifies the name of the alert.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write.

[Visual Basic]

The Name property gets or sets the name of the alert.

Property Name As String

Property Value

String that specifies the name of the alert.

Remarks

This property is read/write.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCAlert


IFPCAlert | FPCAlert Password(BSTR) property [ISA Server 2004]

Password Property of IFPCAlert[C++]

FPCAlert.Password [Visual Basic]

[C++]

The Password property sets the password in the credentials supplied for command-line actions.

HRESULT put_Password(
  BSTR bstrPassword
);

Parameters

bstrPassword
BSTR that specifies the password.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is write-only.

The credentials specified by the UserName and Password properties can be used to restrict the privileges of commands invoked by the alert service. For example, an account could be created with appropriate permissions, and the user name and password of that account could then be used by the FPCAlert object. The account used must have the Logon as Batch Job permission.

The UserName and Password properties are used only for actions that run programs.

[Visual Basic]

The Password property sets the password in the credentials supplied for command-line actions.

Property Password As String

Property Value

String that specifies the password.

Remarks

This property is write-only.

The credentials specified by the UserName and Password properties can be used to restrict the privileges of commands invoked by the alert service. For example, an account could be created with appropriate permissions, and the user name and password of that account could then be used by the FPCAlert object. The account used must have the Logon as Batch Job permission.

The UserName and Password properties are used only for actions that run programs.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCAlert


IFPCAlert | FPCAlert ServerName() property [ISA Server 2004]

ServerName Property of IFPCAlert[C++]

FPCAlert.ServerName [Visual Basic]

[C++]

The ServerName property gets the name of the server that is allowed to issue the alert.

HRESULT get_ServerName(
  * pbstrServerName
);

Parameters

pbstrServerName
Pointer to a BSTR that is set on return to a string value specifying the name of the server that is allowed to issue the alert.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only. Its value can be modified, along with the values of the AdditionalKey and EventGUID properties, by calling the SetDefinitions method.

If the value of this property is an empty string, or (""), all servers are allowed to issue the alert.

[Visual Basic]

The ServerName property gets the name of the server that is allowed to issue the alert.

Property ServerName As String

Property Value

String that specifies the name of the server that is allowed to issue the alert.

Remarks

This property is read-only. Its value can be modified, along with the values of the AdditionalKey and EventGUID properties, by calling the SetDefinitions method.

If the value of this property is an empty string, or (""), all servers are allowed to issue the alert.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCAlert


IFPCAlert | FPCAlert SetDefinitions(String,String,Long) method [ISA Server 2004]

IFPCAlert::SetDefinitions[C++]

FPCAlert.SetDefinitions [Visual Basic]

[C++]

The SetDefinitions method sets the following properties of the alert: the globally unique identifier (GUID) of the event for which the alert is issued, the name of the server that issues the alert, and the additional key. The three must be set simultaneously because they form a unique identifying triplet.

HRESULT SetDefinitions(
  BSTR EventGUID,
  BSTR ServerName,
  long AdditionalKey
);

Parameters

EventGUID
[in] Required. String-formatted globally unique identifier (GUID) of the event for which the alert is issued.
ServerName
[in, optional] BSTR that specifies the name of the server that is allowed to issue the alert. The default value is an empty string, which indicates that all servers are allowed to issue the alert.
AdditionalKey
[in, optional] A 32-bit integer that specifies an additional key (index) in the table of subevents defined for the event for which the alert is issued. A value of 0 indicates all subevents. The default value is –1, which indicates that no additional key will be assigned to the alert.

Return Values

This method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This method modifies the AdditionalKey, EventGUID, and ServerName properties of the alert.

The GUID supplied in the EventGUID parameter must be formatted as a string in the form {12345678-1234-1234-1234-123456789abc}. Note the presence of the braces normally used with GUIDs.

[Visual Basic]

The SetDefinitions method sets the following properties of the alert: the globally unique identifier (GUID) of the event for which the alert is issued, the name of the server that issues the alert, and the additional key. The three must be set simultaneously because they form a unique identifying triplet.

Sub SetDefinitions( _
  ByVal EventGUID As String, _
  [ ByVal ServerName As String ], _
  [ ByVal AdditionalKey As Long ] _
)

Parameters

EventGUID
[in] Required. String-formatted globally unique identifier (GUID) of the event for which the alert is issued.
ServerName
[in, optional] String value that specifies the name of the server that is allowed to issue the alert. The default value is an empty string, which indicates that all servers are allowed to issue the alert.
AdditionalKey
[in, optional] A 32-bit integer that specifies an additional key (index) in the table of subevents defined for the event for which the alert is issued. A value of 0 indicates all subevents. The default value is –1, which indicates that no additional key will be assigned to the alert.

Return Values

This method has no return values. If the call is unsuccessful, an error is raised that can be intercepted by using an error handler.

Remarks

This method modifies the AdditionalKey, EventGUID, and ServerName properties of the alert.

The GUID supplied in the EventGUID parameter must be formatted as a string in the form {12345678-1234-1234-1234-123456789abc}. Note the presence of the braces normally used with GUIDs.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCAlert


IFPCAlert | FPCAlert Severity (2 Parameters) property [ISA Server 2004]

Severity Property of IFPCAlert[C++]

FPCAlert.Severity [Visual Basic]

[C++]

The Severity property gets or sets a value from the FpcAlertSeverity enumerated type that specifies the severity of the alert. The severity determines the type of event that can be recorded in the system log if the alert's actions include event logging. The possible severity levels are:

  • Information
  • Warning
  • Error

HRESULT get_Severity(
  FpcAlertSeverity* pSeverity
);

HRESULT put_Severity(
  FpcAlertSeverity Severity
);

Parameters

pSeverity
Pointer to a variable that receives a value from the FpcAlertSeverity enumerated type specifying the severity of the alert.
Severity
Value from the FpcAlertSeverity enumerated type that specifies the severity of the alert.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write.

[Visual Basic]

The Severity property gets or sets a value from the FpcAlertSeverity enumerated type that specifies the severity of the alert. The severity determines the type of event that can be recorded in the system log if the alert's actions include event logging. The possible severity levels are:

  • Information
  • Warning
  • Error

Property Severity As FpcAlertSeverity

Property Value

Value from the FpcAlertSeverity enumerated type that specifies the severity of the alert.

Remarks

This property is read/write.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCAlert


IFPCAlert | FPCAlert UserName(BSTR,BSTR) property [ISA Server 2004]

UserName Property of IFPCAlert[C++]

FPCAlert.UserName [Visual Basic]

[C++]

The UserName property gets or sets the user name in the credentials supplied for command-line actions.

HRESULT get_UserName(
  BSTR* pbstrName
);

HRESULT put_UserName(
  BSTR bstrName
);

Parameters

pbstrName
Pointer to a BSTR that is set on return to a string value specifying the user name.
bstrName
BSTR that specifies the user name.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write.

The credentials specified by the UserName and Password properties can be used to restrict the privileges of commands invoked by the alert service. For example, an account could be created with appropriate permissions, and the user name and password of that account could then be used by the FPCAlert object. The account used must have the Logon as Batch Job permission.

The UserName and Password properties are used only for actions that run programs.

[Visual Basic]

The UserName property gets or sets the user name in the credentials supplied for command-line actions.

Property UserName As String

Property Value

String that specifies the user name.

Remarks

This property is read/write.

The credentials specified by the UserName and Password properties can be used to restrict the privileges of commands invoked by the alert service. For example, an account could be created with appropriate permissions, and the user name and password of that account could then be used by the FPCAlert object. The account used must have the Logon as Batch Job permission.

The UserName and Password properties are used only for actions that run programs.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCAlert


FPCAlertAction object [ISA Server 2004]

FPCAlertAction

The FPCAlertAction object defines a single action that can be assigned to an ISA Server alert to be performed when the alert is issued. You can determine the kind of action you want taken by using the Type property. The Type property determines whether the action will be to send an e-mail message, to issue a command, to write to a log, or to perform another task.

This object is typically an element of an FPCAlertActions collection.

Click here to see the ISA Server object hierarchy.

Methods

The FPCAlertAction object defines the following methods.

Method | Description
Refresh | Reads the values of all of the object's properties from persistent storage, discarding any changes that have not been saved.
Save | Writes the current values of all of the object's properties to persistent storage.

Properties

The FPCAlertAction object has the following properties.

Property | Description
Enabled | Gets or sets a Boolean value that indicates whether the action is enabled.
Name | Gets the name of the alert action.
Parameters | Gets an array of strings that specify optional parameters for the action.
Type | Gets a value from the FpcAlertActionTypes enumerated type that specifies the type of action to be performed when an alert is issued.

Remarks

This object implements the IFPCAlertAction interface.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

COM Objects


IFPCAlertAction | FPCAlertAction Enabled property [ISA Server 2004]

Enabled Property of IFPCAlertAction[C++]

FPCAlertAction.Enabled [Visual Basic]

[C++]

The Enabled property gets or sets a Boolean value that indicates whether the action is enabled.

HRESULT get_Enabled(
  VARIANT_BOOL* pfEnabled
);

HRESULT put_Enabled(
  VARIANT_BOOL fEnabled
);

Parameters

pfEnabled
Pointer to a Boolean variable that is set on return to VARIANT_TRUE if the action is enabled, or to VARIANT_FALSE if the action is disabled.
fEnabled
Boolean value that indicates whether the action is enabled.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write.

[Visual Basic]

The Enabled property gets or sets a Boolean value that indicates whether the action is enabled.

Property Enabled As Boolean

Property Value

Boolean value that indicates whether the action is enabled.

Remarks

This property is read/write.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCAlertAction


IFPCAlertAction | FPCAlertAction Name(BSTR,BSTR) property [ISA Server 2004]

Name Property of IFPCAlertAction[C++]

FPCAlertAction.Name [Visual Basic]

[C++]

The Name property gets or sets the name of the alert action.

HRESULT get_Name(
  BSTR* pbstrName
);

HRESULT put_Name(
  BSTR bstrName
);

Parameters

pbstrName
Pointer to a BSTR that is set on return to a string value specifying the name of the alert action.
bstrName
BSTR that specifies the name of the alert action.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write.

[Visual Basic]

The Name property gets or sets the name of the alert action.

Property Name As String

Property Value

String that specifies the name of the alert action.

Remarks

This property is read/write.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCAlertAction


IFPCAlertAction | FPCAlertAction Parameters(VARIANT) property [ISA Server 2004]

Parameters Property of IFPCAlertAction[C++]

FPCAlertAction.Parameters [Visual Basic]

[C++]

The Parameters property gets an array of strings that specifies the parameters for the action.

HRESULT get_Parameters(
  VARIANT* pvarParameters
);

Parameters

pvarParameters
Pointer to a VARIANT that is set on return to a VARIANT containing an array of strings that specifies the parameters for the action.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only. The parameters are set by calling the methods of the IFPCAlertActions interface.

The following table shows the values of the parameters for actions of different types.

Type | param1 | param2 | param3 | param4
Log event | None | None | None | None
Command | Command line | None | None | None
Stop/start service | Service name | Service name | Service name | Service name
Send mail | SERVER= x, where x is an address or IP of an SMTP mail server | TO= x, where x is a space-delimited list of To recipients | CC= x, where x is a space-delimited list of Cc recipients | FROM= x, where x is a valid e-mail address of the sender

[Visual Basic]

The Parameters property gets an array of strings that specifies the parameters for the action.

Property Parameters As Variant

Property Value

Variant containing an array of strings that specifies the parameters for the action.

Remarks

This property is read-only. The parameters are set by calling the methods of the FPCAlertActions collection.

The following table shows the values of the parameters for actions of different types.

Type | param1 | param2 | param3 | param4
Log event | None | None | None | None
Command | Command line | None | None | None
Stop/start service | Service name | Service name | Service name | Service name
Send mail | SERVER= x, where x is an address or IP of an SMTP mail server | TO= x, where x is a space-delimited list of To recipients | CC= x, where x is a space-delimited list of Cc recipients | FROM= x, where x is a valid e-mail address of the sender

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCAlertAction


IFPCAlertAction | FPCAlertAction Refresh method [ISA Server 2004]

IFPCAlertAction::Refresh[C++]

FPCAlertAction.Refresh [Visual Basic]

[C++]

The Refresh method reads all of the object's properties from persistent storage, discarding any changes that have not been saved.

HRESULT Refresh();

Parameters

This method has no parameters.

Return Values

This method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

Changes made to this object can be saved by calling the Save method of this object or the Save method of any object containing this object.

[Visual Basic]

The Refresh method reads all of the object's properties from persistent storage, discarding any changes that have not been saved.

Sub Refresh()

Parameters

This method has no parameters.

Return Values

This method has no return values. If the call is unsuccessful, an error is raised that can be intercepted by using an error handler.

Remarks

Changes made to this object can be saved by calling the Save method of this object or the Save method of any object containing this object.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCAlertAction


IFPCAlertAction | FPCAlertAction Save (2 Parameters) method [ISA Server 2004]

IFPCAlertAction::Save[C++]

FPCAlertAction.Save [Visual Basic]

[C++]

The Save method writes the current values of all of the object's properties to persistent storage. It is important to remember that any changes made by scripts and programs are not saved until after the Save method is called.

HRESULT Save(
  VARIANT_BOOL fResetRequiredServices,
  VARIANT_BOOL fReloadConfiguration
);

Parameters

fResetRequiredServices
[in, optional] Boolean value that indicates whether to restart the services that need to be restarted for any of the changes saved to take effect. The default value is VARIANT_FALSE.
fReloadConfiguration
[in, optional] Boolean value that indicates whether the call will include synchronous reloading of all changes that can be applied dynamically without restarting services. The default value is VARIANT_TRUE.

Return Values

This method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

Configuration changes are applied only after the new settings are written to persistent storage and reloaded to the services that use them. Most changes can be applied dynamically without restarting any services. However, some changes can take effect only after the Microsoft Firewall service is restarted. For more information, see Restarting Services after Configuration Changes.

ISA Server maintains a bitmask that specifies which services need to be started for currently unsaved changes to take effect. This bitmask can be retrieved by calling the GetServiceRestartMask method on an object that contains this object as a subobject. Calling the Save method clears all of the bits in this bitmask even if the fResetRequiredServices parameter is set to VARIANT_FALSE.

If the fReloadConfiguration parameter is set to VARIANT_FALSE the current values of the object's properties will be written to persistent storage without updating the configuration being used by the ISA Server services. The configuration used by each service will not be updated until the service is restarted or the new settings are reloaded by another call to Save.

[Visual Basic]

The Save method writes the current values of all of the object's properties to persistent storage. It is important to remember that any changes made by scripts and programs are not saved until after the Save method is called.

Sub Save( _
  [ ByVal fResetRequiredServices As Boolean ], _
  [ ByVal fReloadConfiguration As Boolean ] _
)

Parameters

fResetRequiredServices
[in, optional] Boolean value that indicates whether to restart the services that need to be restarted for any of the changes saved to take effect. The default value is False.
fReloadConfiguration
[in, optional] Boolean value that indicates whether the call will include synchronous reloading of all the saved configuration changes that can be applied dynamically without restarting services. The default value is True.

Return Values

This method has no return values. If the call is unsuccessful, an error is raised that can be intercepted by using an error handler.

Remarks

Configuration changes are applied only after the new settings are written to persistent storage and reloaded to the services that use them. Most changes can be applied dynamically without restarting any services. However, some changes can take effect only after the Microsoft Firewall service is restarted. For more information, see Restarting Services after Configuration Changes.

ISA Server maintains a bitmask that specifies which services need to be started for currently unsaved changes to take effect. This bitmask can be retrieved by calling the GetServiceRestartMask method on an object that contains this object as a subobject. Calling the Save method clears all of the bits in this bitmask even if the fResetRequiredServices parameter is set to False.

If the fReloadConfiguration parameter is set to False the current values of the object's properties will be written to persistent storage without updating the configuration being used by the ISA Server services. The configuration used by each service will not be updated until the service is restarted or the new settings are reloaded by another call to Save.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCAlertAction


IFPCAlertAction | FPCAlertAction Type (1 Parameter) property [ISA Server 2004]

Type Property of IFPCAlertAction[C++]

FPCAlertAction.Type [Visual Basic]

[C++]

The Type property gets a value from the FpcAlertActionTypes enumerated type that specifies the type of action to be performed when an alert is issued.

HRESULT get_Type(
  FpcAlertActionTypes* pActionType
);

Parameters

pActionType
Pointer to a variable that on return receives a value from the FpcAlertActionTypes enumerated type specifying the type of action to be performed when an alert is issued.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The Type property gets a value from the FpcAlertActionTypes enumerated type that specifies the type of action to be performed when an alert is issued.

Property Type As FpcAlertActionTypes

Property Value

Value from the FpcAlertActionTypes enumerated type that specifies the type of action to be performed when an alert is issued.

Remarks

This property is read-only.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCAlertAction


FPCAlertActions collection [ISA Server 2004]

FPCAlertActions Collection

The FPCAlertActions collection holds a set of FPCAlertAction objects. Each object in this collection defines an action that is performed whenever the alert for which ISA Server created the collection is issued.

The FPCAlertActions collection is typically accessed through the Actions property of an FPCAlert object.

Click here to see the ISA Server object hierarchy.

Methods

The FPCAlertActions collection defines the following methods.

Method | Description
Item | Retrieves the requested FPCAlertAction object from the collection.
Refresh | Reads the values of all the properties of the collection and its elements from persistent storage, discarding any changes that were not saved.
Save | Writes the current values of all the properties of the collection and its elements to persistent storage.
SetCommand | Creates a new command-line action in the collection, or updates the command-line action if it already exists, and then returns a reference to it.
SetLogEvent | Creates a new log-event action in the collection, or updates the log-event action if it already exists, and then returns a reference to it.
SetSendMail | Creates a new send-mail action in the collection, or updates the send-mail action if it already exists, and then returns a reference to it.
SetStartServices | Creates a new start-services action in the collection, or updates the start-services action if it already exists, and then returns a reference to it.
SetStopServices | Creates a new stop-services action in the collection, or updates the stop-services action if it already exists, and then returns a reference to it.
Unset | Sets the actions of the specified type to the disabled state.

Properties

The FPCAlertActions collection has the following properties.

Property | Description
_NewEnum | Gets an enumerator object for the collection.
Count | Gets the number of FPCAlertAction objects in the collection.

Remarks

This collection implements the IFPCAlertActions interface.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

COM Objects


IFPCAlertActions | FPCAlertActions _NewEnum(IUnknown) property [ISA Server 2004]

_NewEnum Property of IFPCAlertActions[C++]

FPCAlertActions._NewEnum [Visual Basic]

[C++]

The _NewEnum property gets an enumerator object for the collection. An enumerator object provides serial access to the elements of the collection.

HRESULT get__NewEnum(
  IUnknown* ppEnum
);

Parameters

ppEnum
Address of an interface pointer that on return points to the IUnknown interface of an enumerator object that implements an IEnumVARIANT interface for the collection. An interface pointer to the IEnumVARIANT interface of the enumerator object can be retrieved by calling QueryInterface on the IUnknown interface returned.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The _NewEnum property gets an enumerator object for the collection. An enumerator object provides serial access to the elements of the collection.

Property _NewEnum As IUnknown

Property Value

Reference to an enumerator object that provides serial access to the elements of the collection.

Remarks

This property is read-only.

In Visual Basic and VBScript, this property is used implicitly in For Each...In...Next constructs.

Example Code

This VBScript script displays the names of all the actions that will be taken when the first alert in the collection of alerts defined for an FPCArray object is issued. It does not include error handling.

' Create the root object.
Dim root  ' The FPCLib.FPC root object
Set root = CreateObject("FPC.Root")

' Declare the other objects needed.
Dim array         ' An FPCArray object
Dim alertactions  ' An FPCAlertActions collection
Dim alertaction   ' An FPCAlertAction object
Dim alerts        ' An FPCAlerts collection
Dim alert         ' An FPCAlert object

' Get references to the array object
' and the alerts collection.
Set array = root.GetContainingArray()
Set alerts = array.Alerts

' If at least one alert is defined in the alerts
' collection, display the names of the alert actions
' defined for it.
On Error Resume Next
Set alert = alerts.Item(1)
Set alertactions = alert.Actions
If Err.Number = 0 Then
    For Each alertaction In alertactions
        WScript.Echo "Alert action name: " + alertaction.Name
    Next
End If

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCAlertActions


IFPCAlertActions | FPCAlertActions Count(long) property [ISA Server 2004]

Count Property of IFPCAlertActions[C++]

FPCAlertActions.Count [Visual Basic]

[C++]

The Count property gets the number of FPCAlertAction objects in the collection.

HRESULT get_Count(
  long* plCount
);

Parameters

plCount
Pointer to a variable that on return receives a 32-bit integer specifying the number of FPCAlertAction objects in the collection.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The Count property gets the number of FPCAlertAction objects in the collection.

Property Count As Long

Property Value

A 32-bit integer that specifies the number of FPCAlertAction objects in the collection.

Remarks

This property is read-only.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCAlertActions


IFPCAlertActions | FPCAlertActions Item (2 Parameters) method [ISA Server 2004]

IFPCAlertActions::Item[C++]

FPCAlertActions.Item [Visual Basic]

[C++]

The Item method retrieves the requested IFPCAlertAction interface from the collection.

HRESULT Item(
  VARIANT Index,
  IFPCAlertAction** ppItem
);

Parameters

Index
[in] Required. Name or one-based index of the object to retrieve.
ppItem
[out] Address of an interface pointer that on return points to the IFPCAlertAction interface requested.

Return Values

The method can return one of the following:

  • S_OK, indicating that the operation succeeded.
  • An error code, indicating that the operation failed. In this case, the [out] parameter returned is a null object.
[Visual Basic]

The Item method retrieves the requested FPCAlertAction object from the collection.

Function Item( _
  ByVal Index As Variant _
) As FPCAlertAction

Parameters

Index
[in] Required. Name or one-based index of the object to retrieve.

Return Values

This method returns a reference to the FPCAlertAction object requested if successful. Otherwise, an error is raised that can be intercepted by using an error handler.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCAlertActions


IFPCAlertActions | FPCAlertActions Refresh method [ISA Server 2004]

IFPCAlertActions::Refresh[C++]

FPCAlertActions.Refresh [Visual Basic]

[C++]

The Refresh method reads the values of all the properties of the collection and its elements from persistent storage, discarding any changes that were not saved.

HRESULT Refresh();

Parameters

This method has no parameters.

Return Values

This method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

Changes made to this collection or its elements can be saved by calling the Save method of this collection or the Save method of any object containing it.

[Visual Basic]

The Refresh method reads the values of all the properties of the collection and its elements from persistent storage, discarding any changes that were not saved.

Sub Refresh()

Parameters

This method has no parameters.

Return Values

This method has no return values. If the call is unsuccessful, an error is raised that can be intercepted by using an error handler.

Remarks

Changes made to this collection or its elements can be saved by calling the Save method of this collection or the Save method of any object containing it.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCAlertActions


IFPCAlertActions | FPCAlertActions Save (2 Parameters) method [ISA Server 2004]

IFPCAlertActions::Save[C++]

FPCAlertActions.Save [Visual Basic]

[C++]

The Save method writes the current values of all the properties of the collection and its elements to persistent storage. It is important to remember that any changes made by scripts and programs are not saved until after the Save method is called.

HRESULT Save(
  VARIANT_BOOL fResetRequiredServices,
  VARIANT_BOOL fReloadConfiguration
);

Parameters

fResetRequiredServices
[in, optional] Boolean value that indicates whether to restart the services that need to be restarted for any of the changes saved to take effect. The default value is VARIANT_FALSE.
fReloadConfiguration
[in, optional] Boolean value that indicates whether the call will include synchronous reloading of all changes that can be applied dynamically without restarting services. The default value is VARIANT_TRUE.

Return Values

This method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

Configuration changes are applied only after the new settings are written to persistent storage and reloaded to the services that use them. Most changes can be applied dynamically without restarting any services. However, some changes can take effect only after the Microsoft Firewall service is restarted. For more information, see Restarting Services after Configuration Changes.

ISA Server maintains a bitmask that specifies which services need to be started for currently unsaved changes to take effect. This bitmask can be retrieved by calling the GetServiceRestartMask method on an object that contains this object as a subobject. Calling the Save method clears all of the bits in this bitmask even if the fResetRequiredServices parameter is set to VARIANT_FALSE.

If the fReloadConfiguration parameter is set to VARIANT_FALSE the current values of the properties of the collection and its elements will be written to persistent storage without updating the configuration being used by the ISA Server services. The configuration used by each service will not be updated until the service is restarted or the new settings are reloaded by another call to Save.

[Visual Basic]

The Save method writes the current values of all the properties of the collection and its elements to persistent storage. It is important to remember that any changes made by scripts and programs are not saved until after the Save method is called.

Sub Save( _
  [ ByVal fResetRequiredServices As Boolean ], _
  [ ByVal fReloadConfiguration As Boolean ] _
)

Parameters

fResetRequiredServices
[in, optional] Boolean value that indicates whether to restart the services that need to be restarted for any of the changes saved to take effect. The default value is False.
fReloadConfiguration
[in, optional] Boolean value that indicates whether the call will include synchronous reloading of all the saved configuration changes that can be applied dynamically without restarting services. The default value is True.

Return Values

This method has no return values. If the call is unsuccessful, an error is raised that can be intercepted by using an error handler.

Remarks

Configuration changes are applied only after the new settings are written to persistent storage and reloaded to the services that use them. Most changes can be applied dynamically without restarting any services. However, some changes can take effect only after the Microsoft Firewall service is restarted. For more information, see Restarting Services after Configuration Changes.

ISA Server maintains a bitmask that specifies which services need to be started for currently unsaved changes to take effect. This bitmask can be retrieved by calling the GetServiceRestartMask method on an object that contains this object as a subobject. Calling the Save method clears all of the bits in this bitmask even if the fResetRequiredServices parameter is set to False.

If the fReloadConfiguration parameter is set to False the current values of the properties of the collection and its elements will be written to persistent storage without updating the configuration being used by the ISA Server services. The configuration used by each service will not be updated until the service is restarted or the new settings are reloaded by another call to Save.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCAlertActions


IFPCAlertActions | FPCAlertActions SetCommand method [ISA Server 2004]

IFPCAlertActions::SetCommand[C++]

FPCAlertActions.SetCommand [Visual Basic]

[C++]

The SetCommand method creates a new command-line action in the collection, or updates the command-line action if it already exists, and then returns a reference to it.

HRESULT SetCommand(
  BSTR ActionName,
  BSTR Command,
  IFPCAlertAction** ppNewAction
);

Parameters

ActionName
[in] Required. String value that specifies the name of the action. This name is used to identify the action in the FPCAlertActions collection if it already exists.
Command
[in] Required. String value that specifies the command line.
ppNewAction
[out] Address of an interface pointer that on return points to the IFPCAlertAction interface for the new or updated command-line action.

Return Values

This method can return one of the following:

  • S_OK, indicating that the operation succeeded.
  • An error code, indicating that the operation failed. In this case, the [out] parameter returned is a null object.

[Visual Basic]

The SetCommand method creates a new command-line action in the collection, or updates the command-line action if it already exists, and then returns a reference to it.

Function SetCommand( _
  ByVal ActionName As String, _
  ByVal Command As String _
) As FPCAlertAction

Parameters

ActionName
[in] Required. String value that specifies the name of the action. This name is used to identify the action in the FPCAlertActions collection if it already exists.
Command
[in] Required. String value that specifies the command line.

Return Values

This method returns a reference to an FPCAlertAction object if successful. Otherwise, an error is raised that can be intercepted by using an error handler.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCAlertActions


IFPCAlertActions | FPCAlertActions SetLogEvent method [ISA Server 2004]

IFPCAlertActions::SetLogEvent[C++]

FPCAlertActions.SetLogEvent [Visual Basic]

[C++]

The SetLogEvent method creates a new log-event action in the collection, or updates the log-event action if it already exists, and then returns a reference to it.

HRESULT SetLogEvent(
  BSTR ActionName,
  IFPCAlertAction** ppNewAction
);

Parameters

ActionName
[in] Required. String value that specifies the name of the action. This name is used to identify the action in the FPCAlertActions collection if it already exists.
ppNewAction
[out] Address of an interface pointer that on return points to the IFPCAlertAction interface for the new or updated log-event action.

Return Values

This method can return one of the following:

  • S_OK, indicating that the operation succeeded.
  • An error code, indicating that the operation failed. In this case, the [out] parameter returned is a null object.

[Visual Basic]

The SetLogEvent method creates a new log-event action in the collection, or updates the log-event action if it already exists, and then returns a reference to it.

Function SetLogEvent( _
  ByVal ActionName As String _
) As FPCAlertAction

Parameters

ActionName
[in] Required. String value that specifies the name of the action. This name is used to identify the action in the FPCAlertActions collection if it already exists.

Return Values

This method returns a reference to an FPCAlertAction object if successful. Otherwise, an error is raised that can be intercepted by using an error handler.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCAlertActions


IFPCAlertActions | FPCAlertActions SetSendMail method [ISA Server 2004]

IFPCAlertActions::SetSendMail[C++]

FPCAlertActions.SetSendMail [Visual Basic]

[C++]

The SetSendMail method creates a new send-mail action in the collection, or updates the send-mail action if it already exists, and then returns a reference to it.

HRESULT SetSendMail(
  BSTR ActionName,
  BSTR Server,
  BSTR FromField,
  BSTR ToField,
  BSTR CcField,
  IFPCAlertAction** ppNewAction
);

Parameters

ActionName
[in] Required. String value that specifies the name of the action. This name is used to identify the action in the FPCAlertActions collection if it already exists.
Server
[in] Required. String value that specifies a name or IP address of a Simple Mail Transfer Protocol (SMTP) server.
FromField
[in] Required. String value that specifies a valid e-mail address of the sender.
ToField
[in] Required. String value that specifies a space-delimited list of mail recipients that appear on the To list.
CcField
[in, optional] String value that specifies a space-delimited list of mail recipients that appear on the Cc list. The default value is an empty string.
ppNewAction
[out] Address of an interface pointer that on return points to the IFPCAlertAction interface for the new or updated send-mail action.

Return Values

This method can return one of the following:

  • S_OK, indicating that the operation succeeded.
  • An error code, indicating that the operation failed. In this case, the [out] parameter returned is a null object.

[Visual Basic]

The SetSendMail method creates a new send-mail action in the collection, or updates the send-mail action if it already exists, and then returns a reference to it.

Function SetSendMail( _
  ByVal ActionName As String, _
  ByVal Server As String, _
  ByVal FromField As String, _
  ByVal ToField As String, _
  [ ByVal CcField As String ] _
) As FPCAlertAction

Parameters

ActionName
[in] Required. String value that specifies the name of the action. This name is used to identify the action in the FPCAlertActions collection if it already exists.
Server
[in] Required. String value that specifies a name or IP address of a Simple Mail Transfer Protocol (SMTP) server.
FromField
[in] Required. String value that specifies a valid e-mail address of the sender.
ToField
[in] Required. String value that specifies a space-delimited list of mail recipients that appear on the To list.
CcField
[in, optional] String value that specifies a space-delimited list of mail recipients that appear on the Cc list. The default value is an empty string.

Return Values

This method returns a reference to an FPCAlertAction object if successful. Otherwise, an error is raised that can be intercepted by using an error handler.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCAlertActions


IFPCAlertActions | FPCAlertActions SetStartServices method [ISA Server 2004]

IFPCAlertActions::SetStartServices[C++]

FPCAlertActions.SetStartServices [Visual Basic]

[C++]

The SetStartServices method creates a new start-services action in the collection, or updates the start-services action if it already exists, and then returns a reference to it.

HRESULT SetStartServices(
  BSTR ActionName,
  FpcServices Services,
  IFPCAlertAction** ppNewAction
);

Parameters

ActionName
[in] Required. String value that specifies the name of the action. This name is used to identify the action in the FPCAlertActions collection if it already exists.
Services
[in] Required. Value from the FpcServices enumerated type that specifies which service to start.
ppNewAction
[out] Address of an interface pointer that on return points to the IFPCAlertAction interface for the new or updated start-services action.

Return Values

This method can return one of the following:

  • S_OK, indicating that the operation succeeded.
  • An error code, indicating that the operation failed. In this case, the [out] parameter returned is a null object.

[Visual Basic]

The SetStartServices method creates a new start-services action in the collection, or updates the start-services action if it already exists, and then returns a reference to it.

Function SetStartServices( _
  ByVal ActionName As String, _
  ByVal Services As FpcServices _
) As FPCAlertAction

Parameters

ActionName
[in] Required. String value that specifies the name of the action. This name is used to identify the action in the FPCAlertActions collection if it already exists.
Services
[in] Required. Value from the FpcServices enumerated type that specifies which service to start.

Return Values

This method returns a reference to an FPCAlertAction object if successful. Otherwise, an error is raised that can be intercepted by using an error handler.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCAlertActions


IFPCAlertActions | FPCAlertActions SetStopServices method [ISA Server 2004]

IFPCAlertActions::SetStopServices[C++]

FPCAlertActions.SetStopServices [Visual Basic]

[C++]

The SetStopServices method creates a new stop-services action in the collection, or updates the stop-services action if it already exists, and then returns a reference to it.

HRESULT SetStopServices(
  BSTR ActionName,
  FpcServices Services,
  IFPCAlertAction** ppNewAction
);

Parameters

ActionName
[in] Required. String value that specifies the name of the action. This name is used to identify the action in the FPCAlertActions collection if it already exists.
Services
[in] Required. Value from the FpcServices enumerated type that specifies which service to stop.
ppNewAction
[out] Address of an interface pointer that on return points to the IFPCAlertAction interface for the new or updated stop-services action.

Return Values

This method can return one of the following:

  • S_OK, indicating that the operation succeeded.
  • An error code, indicating that the operation failed. In this case, the [out] parameter returned is a null object.

[Visual Basic]

The SetStopServices method creates a new stop-services action in the collection, or updates the stop-services action if it already exists, and then returns a reference to it.

Function SetStopServices( _
  ByVal ActionName As String, _
  ByVal Services As FpcServices _
) As FPCAlertAction

Parameters

ActionName
[in] Required. String value that specifies the name of the action. This name is used to identify the action in the FPCAlertActions collection if it already exists.
Services
[in] Required. Value from the FpcServices enumerated type that specifies which service to stop.

Return Values

This method returns a reference to an FPCAlertAction object if successful. Otherwise, an error is raised that can be intercepted by using an error handler.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCAlertActions


IFPCAlertActions | FPCAlertActions Unset (1 Parameter) method [ISA Server 2004]

IFPCAlertActions::Unset[C++]

FPCAlertActions.Unset [Visual Basic]

[C++]

The Unset method sets the actions of the specified type to the disabled state.

HRESULT Unset(
  FpcAlertActionTypes ActionType
);

Parameters

ActionType
[in] Required. Value from the FpcAlertActionTypes enumerated type that specifies the type of actions to disable.

Return Values

This method returns S_OK if the call is successful; otherwise, it returns an error code.
[Visual Basic]

The Unset method sets the actions of the specified type to the disabled state.

Sub Unset( _
  ByVal ActionType As FpcAlertActionTypes _
)

Parameters

ActionType
[in] Required. Value from the FpcAlertActionTypes enumerated type that specifies the type of actions to disable.

Return Values

This method has no return values. If the call is unsuccessful, an error is raised that can be intercepted by using an error handler.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCAlertActions


FPCAlerts collection [ISA Server 2004]

FPCAlerts Collection

The FPCAlerts collection holds a set of individual FPCAlert objects. Each object within this collection defines the actions to be taken in response to a specific event. Each FPCAlert object also defines the three thresholds that determine when the actions will be taken. With alerts, an administrator can be notified when certain events take place and decide which actions should be taken in advance.

The FPCAlerts collection is typically accessed through the Alerts property of the FPCArray object.

Click here to see the ISA Server object hierarchy.

Inheritance

This collection inherits from the FPCPersist object, which contains methods and properties related to the persistent storage of an object's data. They include methods for exporting the object's data to and importing it from an XML document.

Methods

The FPCAlerts collection defines the following methods.

Method | Description
Add | Creates a new FPCAlert object in the collection and returns a reference to it.
AddWithStorageName | Creates a new FPCAlert object with a specified storage name in the collection and returns a reference to it.
Item | Retrieves the requested FPCAlert object from the collection.
Remove | Removes the specified FPCAlert object from the collection.

Properties

The FPCAlerts collection has the following properties.

Property | Description
_NewEnum | Gets an enumerator object for the collection.
Count | Gets the number of FPCAlert objects in the collection.

Methods Inherited from FPCPersist

Name | Description
CancelWaitForChanges | Cancels the registration established by the WaitForChanges method (for use in C and C++ programming only).
CanImport | Returns a Boolean value that indicates whether the object's properties can be imported from the specified XML document.
Export | Recursively writes the stored values of all the properties of the object and its subobjects to the specified XML document.
ExportToFile | Recursively writes the stored values of all the properties of the object and its subobjects to the specified XML file.
GetServiceRestartMask | Retrieves a 32-bit bitmask of the FpcServices enumerated type that specifies which services need to be restarted for currently unsaved changes to take effect.
Import | Recursively copies the values of all the properties of the object and of its subobjects from the specified XML document to persistent storage.
ImportFromFile | Recursively copies the values of all the properties of the object and of its subobjects from the specified XML file to persistent storage.
LoadDocProperties | Provides the XML document's properties so that you can know what information can be imported from the document.
Refresh | Recursively reads the values of all the properties of the object and of its subobjects from persistent storage, overwriting any changes that have not been saved.
Save | Recursively writes the current values of all the properties of the object and its subobjects to persistent storage.
WaitForChanges | Registers to wait for an event indicating that the contents of the object have changed (for use in C and C++ programming only).

Properties Inherited from FPCPersist

Name | Description
PersistentName | Gets the persistent name of the object. The persistent name of an object is a name that is unique for the object at the respective level of the COM object hierarchy.
VendorParametersSets | Gets an FPCVendorParametersSets collection that can hold sets of custom data for extending the object.

Remarks

This collection implements the IFPCAlerts interface.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

COM Objects


IFPCAlerts | FPCAlerts _NewEnum(IUnknown) property [ISA Server 2004]

_NewEnum Property of IFPCAlerts[C++]

FPCAlerts._NewEnum [Visual Basic]

[C++]

The _NewEnum property gets an enumerator object for the collection. An enumerator object provides serial access to the elements of the collection.

HRESULT get__NewEnum(
  IUnknown* ppEnum
);

Parameters

ppEnum
Address of an interface pointer that on return points to the IUnknown interface of an enumerator object that implements an IEnumVARIANT interface for the collection. An interface pointer to the IEnumVARIANT interface of the enumerator object can be retrieved by calling QueryInterface on the IUnknown interface returned.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The _NewEnum property gets an enumerator object for the collection. An enumerator object provides serial access to the elements of the collection.

Property _NewEnum As IUnknown

Property Value

Reference to an enumerator object that provides serial access to the elements of the collection.

Remarks

This property is read-only.

In Visual Basic and VBScript, this property is used implicitly in For Each...In...Next constructs.

Example Code

This VBScript script displays the names of all the alerts defined for an FPCArray object. It does not include error handling.

' Create the root object.
Dim root  ' The FPCLib.FPC root object
Set root = CreateObject("FPC.Root")

' Declare the other objects needed.
Dim array   ' An FPCArray object
Dim alerts  ' An FPCAlerts collection
Dim alert   ' An FPCAlert object

' Get references to the array object
' and the alerts collection.
Set array = root.GetContainingArray()
Set alerts = array.Alerts

' Display the names of the alerts
' defined for the array object.
For Each alert In alerts
    WScript.Echo "Alert name: " & alert.Name
Next

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCAlerts


IFPCAlerts | FPCAlerts Add (5 Parameters) method [ISA Server 2004]

IFPCAlerts::Add[C++]

FPCAlerts.Add [Visual Basic]

[C++]

The Add method creates a new FPCAlert object in the collection and returns a reference to it.

HRESULT Add(
  BSTR Name,
  BSTR EventGUID,
  BSTR ServerName,
  long AdditionalKey,
  IFPCAlert** ppNewAlert
);

Parameters

Name
[in] Required. BSTR that specifies the name of the alert. This name can be used in the Item method to retrieve the alert object.
EventGUID
Required. String-formatted globally unique identifier (GUID) of the event for which the new alert will be issued.
ServerName
[in, optional] BSTR that specifies the name of the server that will be allowed to issue the new alert. The default value is an empty string. If no server is specified, any server will be allowed to issue the alert.
AdditionalKey
[in, optional] A 32-bit integer that specifies an additional key (index) in the table of subevents defined for the event for which the new alert will be issued. The value set should be less than or equal to the number of subevents defined for the event. A value of 0 indicates all subevents. The default value is –1, which indicates that no additional key will be assigned to the alert.
ppNewAlert
[out] Address of an interface pointer that on return points to the new IFPCAlert interface created.

Return Values

This method can return one of the following:

  • S_OK, indicating that the operation succeeded.
  • An error code, indicating that the operation failed. In this case, the [out] parameter returned is a null object.

Remarks

The GUID supplied in the EventGUID parameter must be formatted as a string in the form {12345678-1234-1234-1234-123456789abc}. Note the presence of the braces normally used with GUIDs.

[Visual Basic]

The Add method creates a new FPCAlert object in the collection and returns a reference to it.

Function Add( _
  ByVal Name As String, _
  ByVal EventGUID As String, _
  [ ByVal ServerName As String ], _
  [ ByVal AdditionalKey As Long ] _
) As FPCAlert

Parameters

Name
[in] Required. String value that specifies the name of the alert. This name can be used in the Item method to retrieve the alert object.
EventGUID
Required. String-formatted globally unique identifier (GUID) of the event for which the new alert will be issued.
ServerName
[in, optional] String value that specifies the name of the server that will be allowed to issue the new alert. The default value is an empty string. If no server is specified, any server will be allowed to issue the alert.
AdditionalKey
[in, optional] A 32-bit integer that specifies an additional key (index) in the table of subevents defined for the event for which the new alert will be issued. The value set should be less than or equal to the number of subevents defined for the event. A value of 0 indicates all subevents. The default value is –1, which indicates that no additional key will be assigned to the alert.

Return Values

This method returns a reference to an FPCAlert object if successful. Otherwise, an error is raised that can be intercepted by using an error handler.

Remarks

The GUID supplied in the EventGUID parameter must be formatted as a string in the form {12345678-1234-1234-1234-123456789abc}. Note the presence of the braces normally used with GUIDs.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCAlerts


IFPCAlerts | FPCAlerts AddWithStorageName method [ISA Server 2004]

IFPCAlerts::AddWithStorageName[C++]

FPCAlerts.AddWithStorageName [Visual Basic]

[C++]

The AddWithStorageName method creates a new FPCAlert object with a specified storage name in the collection and returns a reference to it.

HRESULT AddWithStorageName(
  BSTR Name,
  BSTR EventGUID,
  BSTR ServerName,
  BSTR StorageName,
  long AdditionalKey,
  IFPCAlert** ppNewAlert
);

Parameters

Name
[in] Required. BSTR that specifies the name of the alert. This name can be used in the Item method to retrieve the alert object.
EventGUID
Required. String-formatted globally unique identifier (GUID) of the event for which the new alert will be issued.
ServerName
[in, optional] BSTR that specifies the name of the server that will be allowed to issue the new alert. The default value is an empty string. If no server is specified, any server will be allowed to issue the alert.
StorageName
[in, optional] BSTR that specifies the storage name for uniquely identifying the new alert. The default value is an empty string.
AdditionalKey
[in, optional] A 32-bit integer that specifies an additional key (index) in the table of subevents defined for the event for which the new alert will be issued. The value set should be less than or equal to the number of subevents defined for the event. A value of 0 indicates all subevents. The default value is –1, which indicates that no additional key will be assigned to the alert.
ppNewAlert
[out] Address of an interface pointer that on return points to the new IFPCAlert interface created.

Return Values

This method can return one of the following:

  • S_OK, indicating that the operation succeeded.
  • An error code, indicating that the operation failed. In this case, the [out] parameter returned is a null object.

Remarks

The GUID supplied in the EventGUID parameter must be formatted as a string in the form {12345678-1234-1234-1234-123456789ABC}. Note the presence of the braces normally used with GUIDs.

The storage name supplied in the StorageName parameter specifies the name that will be used to identify the alert whenever its properties are written to permanent storage or a file. The storage name is used to compare the identity of objects during import and export operations. The AddWithStorageName method should be used in code that adds an alert during registration of a filter, or in any other third-party add-in that adds an alert when it is initialized.

After an alert object has been created, its storage name can be retrieved using the PersistentName property.

[Visual Basic]

The AddWithStorageName method creates a new FPCAlert object with a specified storage name in the collection and returns a reference to it.

Function AddWithStorageName( _
  ByVal Name As String, _
  ByVal EventGUID As String, _
  [ ByVal ServerName As String ], _
  [ ByVal StorageName As String ], _
  [ ByVal AdditionalKey As Long ] _
) As FPCAlert

Parameters

Name
[in] Required. String value that specifies the name of the alert. This name can be used in the Item method to retrieve the alert object.
EventGUID
Required. String-formatted globally unique identifier (GUID) of the event for which the new alert will be issued.
ServerName
[in, optional] String value that specifies the name of the server that will be allowed to issue the new alert. The default value is an empty string. If no server is specified, any server will be allowed to issue the alert.
StorageName
[in, optional] String value that specifies the storage name for uniquely identifying the new alert. The default value is an empty string.
AdditionalKey
[in, optional] A 32-bit integer that specifies an additional key (index) in the table of subevents defined for the event for which the new alert will be issued. The value set should be less than or equal to the number of subevents defined for the event. A value of 0 indicates all subevents. The default value is –1, which indicates that no additional key will be assigned to the alert.

Return Values

This method returns a reference to an FPCAlert object if successful. Otherwise, an error is raised that can be intercepted by using an error handler.

Remarks

The GUID supplied in the EventGUID parameter must be formatted as a string in the form {12345678-1234-1234-1234-123456789ABC}. Note the presence of the braces normally used with GUIDs.

The storage name supplied in the StorageName parameter specifies the name that will be used to identify the alert whenever its properties are written to permanent storage or a file. The storage name is used to compare the identity of objects during import and export operations. The AddWithStorageName method should be used in code that adds an alert during registration of a filter, or in any other third-party add-in that adds an alert when it is initialized.

After an alert object has been created, its storage name can be retrieved using the PersistentName property.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCAlerts


IFPCAlerts | FPCAlerts Count(long) property [ISA Server 2004]

Count Property of IFPCAlerts[C++]

FPCAlerts.Count [Visual Basic]

[C++]

The Count property gets the number of FPCAlert objects in the collection.

HRESULT get_Count(
  long* plCount
);

Parameters

plCount
Pointer to a variable that on return receives a 32-bit integer specifying the number of FPCAlert objects in the collection.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The Count property gets the number of FPCAlert objects in the collection.

Property Count As Long

Property Value

A 32-bit integer that specifies the number of FPCAlert objects in the collection.

Remarks

This property is read-only.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCAlerts


IFPCAlerts | FPCAlerts Item(Variant,IFPCAlert) method [ISA Server 2004]

IFPCAlerts::Item[C++]

FPCAlerts.Item [Visual Basic]

[C++]

The Item method retrieves the requested IFPCAlert interface from the collection.

HRESULT Item(
  VARIANT Index,
  IFPCAlert** ppItem
);

Parameters

Index
[in] Required. Name or one-based index of the object to retrieve.
ppItem
[out] Address of an interface pointer that on return points to the IFPCAlert interface requested.

Return Values

The method can return one of the following:

  • S_OK, indicating that the operation succeeded.
  • An error code, indicating that the operation failed. In this case, the [out] parameter returned is a null object.
[Visual Basic]

The Item method retrieves the requested FPCAlert object from the collection.

Function Item( _
  ByVal Index As Variant _
) As FPCAlert

Parameters

Index
[in] Required. Name or one-based index of the object to retrieve.

Return Values

This method returns a reference to the FPCAlert object requested if successful. Otherwise, an error is raised that can be intercepted by using an error handler.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCAlerts


IFPCAlerts | FPCAlerts Remove(Variant) method [ISA Server 2004]

IFPCAlerts::Remove[C++]

FPCAlerts.Remove [Visual Basic]

[C++]

The Remove method removes the specified FPCAlert object from the collection.

HRESULT Remove(
  VARIANT Index
);

Parameters

Index
Required. Name or one-based index of the FPCAlert object to remove.

Return Values

This method returns S_OK if the call is successful; otherwise, it returns an error code.
[Visual Basic]

The Remove method removes the specified FPCAlert object from the collection.

Sub Remove( _
  ByVal Index As Variant _
)

Parameters

Index
Required. Name or one-based index of the FPCAlert object to remove.

Return Values

This method has no return values. If the call is unsuccessful, an error is raised that can be intercepted by using an error handler.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCAlerts


FPCApplicationFilter object [ISA Server 2004]

FPCApplicationFilter

The FPCApplicationFilter object represents a single application filter. Application filters work with the Microsoft Firewall service to intercept and process data. Application filters can access the data stream or datagrams associated with a session within the Firewall service. The filters are registered with the Firewall service and act in response to events detected by the service. An application filter can perform protocol-specific or system-specific tasks, such as authentication and checking for viruses.

The FPCApplicationFilter object is an element of an FPCApplicationFilters collection.

Click here to see the ISA Server object hierarchy.

Inheritance

This object inherits from the FPCPersist object, which contains methods and properties related to the persistent storage of an object's data. They include methods for exporting the object's data to and importing it from an XML document.

Methods

This object has no methods.

Properties

The FPCApplicationFilter object has the following properties.

Property | Description
Description | Gets or sets the vendor-supplied description of the application filter.
Enabled | Gets or sets a Boolean value that indicates whether the application filter is enabled.
Guid | Gets vendor-supplied string-formatted globally unique identifier (GUID) for the application filter.
Name | Gets or sets the vendor-supplied name of the application filter.
Predefined | Gets a Boolean value that indicates whether the application filter was installed with ISA Server and cannot be deleted.
Vendor | Gets or sets the name of the company that wrote the application filter.
Version | Gets or sets the vendor-supplied version of the application filter.

Methods Inherited from FPCPersist

Name | Description
CancelWaitForChanges | Cancels the registration established by the WaitForChanges method (for use in C and C++ programming only).
CanImport | Returns a Boolean value that indicates whether the object's properties can be imported from the specified XML document.
Export | Writes the stored values of all of the object's properties to the specified XML document.
ExportToFile | Writes the stored values of all of the object's properties to the specified XML file.
GetServiceRestartMask | Retrieves a 32-bit bitmask of the FpcServices enumerated type that specifies which services need to be restarted for currently unsaved changes to take effect.
Import | Copies the values of all of the object's properties from the specified XML document to persistent storage.
ImportFromFile | Copies the values of all of the object's properties from the specified XML file to persistent storage.
LoadDocProperties | Provides the XML document's properties so that you can know what information can be imported from the document.
Refresh | Reads the values of all of the object's properties from persistent storage, overwriting any changes that have not been saved.
Save | Writes the current values of all of the object's properties to persistent storage.
WaitForChanges | Registers to wait for an event indicating that the contents of the object have changed (for use in C and C++ programming only).

Properties Inherited from FPCPersist

Name | Description
PersistentName | Gets the persistent name of the object. The persistent name of an object is a name that is unique for the object at the respective level of the COM object hierarchy.
VendorParametersSets | Gets an FPCVendorParametersSets object that can hold sets of custom data for extending the object.

Remarks

This object implements the IFPCApplicationFilter interface.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

COM Objects


IFPCApplicationFilter.Description(BSTR,BSTR) property [ISA Server 2004]

Description Property of IFPCApplicationFilter[C++]

FPCApplicationFilter.Description [Visual Basic]

[C++]

The Description property gets or sets the vendor-supplied description of the application filter.

HRESULT get_Description(
  BSTR* pbstrDescription
);

HRESULT put_Description(
  BSTR bstrDescription
);

Parameters

pbstrDescription
Pointer to a BSTR that is set on return to a string value specifying the vendor-supplied description of the application filter.
bstrDescription
BSTR that specifies the vendor-supplied description of the application filter.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write.

Note Although C++ syntax is provided for this property, C++ programmers should set this property using the Description parameter of the IFWXFilterAdmin::InstallFilter method.

[Visual Basic]

The Description property gets or sets the vendor-supplied description of the application filter.

Property Description As String

Property Value

String that specifies the vendor-supplied description of the application filter.

Remarks

This property is read/write.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCApplicationFilter


IFPCApplicationFilter | FPCApplicationFilter Enabled property [ISA Server 2004]

Enabled Property of IFPCApplicationFilter[C++]

FPCApplicationFilter.Enabled [Visual Basic]

[C++]

The Enabled property gets or sets a Boolean value that indicates whether the application filter is enabled.

HRESULT get_Enabled(
  VARIANT_BOOL* pfEnabled
);

HRESULT put_Enabled(
  VARIANT_BOOL fEnabled
);

Parameters

pfEnabled
Pointer to a Boolean variable that is set on return to VARIANT_TRUE if the application filter is enabled, or to VARIANT_FALSE if the application filter is disabled.
fEnabled
Boolean value that indicates whether the application filter is enabled.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write.

Note After the value of the Enabled property has been changed, and the change has been saved by using the Save method, the Microsoft Firewall service must be restarted for the change to take effect. To stop and restart the Firewall service, use the RestartServices method of the IFPCArray interface.

[Visual Basic]

The Enabled property gets or sets a Boolean value that indicates whether the application filter is enabled.

Property Enabled As Boolean

Property Value

Boolean value that indicates whether the application filter is enabled.

Remarks

This property is read/write.

Note After the value of the Enabled property has been changed, and the change has been saved by using the Save method, the Microsoft Firewall service must be restarted for the change to take effect. To stop and restart the Firewall service, use the FPCArray.RestartServices method.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCApplicationFilter


IFPCApplicationFilter | FPCApplicationFilter Guid property [ISA Server 2004]

Guid Property of IFPCApplicationFilter[C++]

FPCApplicationFilter.Guid [Visual Basic]

[C++]

The Guid property gets the vendor-supplied string-formatted globally unique identifier (GUID) for the application filter.

HRESULT get_Guid(
  BSTR* pbstrGuid
);

Parameters

pbstrGuid
Pointer to a BSTR that is set on return to a string value specifying the string-formatted GUID for the application filter.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only. It is set in the guidFilter parameter of the IFWXFilterAdmin::InstallFilter method.

The GUID retrieved is formatted as a string in the form {12345678-1234-1234-1234-123456789ABC}. Note the presence of the braces normally used with GUIDs.

[Visual Basic]

The Guid property gets the vendor-supplied string-formatted globally unique identifier (GUID) for the application filter.

Property Guid As String

Property Value

String that specifies the string-formatted GUID for the application filter.

Remarks

This property is read-only. It is set in the guidFilter parameter of the IFWXFilterAdmin::InstallFilter method.

The GUID retrieved is formatted as a string in the form {12345678-1234-1234-1234-123456789ABC}. Note the presence of the braces normally used with GUIDs.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCApplicationFilter


IFPCApplicationFilter | FPCApplicationFilter Name property [ISA Server 2004]

Name Property of IFPCApplicationFilter[C++]

FPCApplicationFilter.Name [Visual Basic]

[C++]

The Name property gets or sets the vendor-supplied name of the application filter.

HRESULT get_Name(
  BSTR* pbstrName
);

HRESULT put_Name(
  BSTR bstrName
);

Parameters

pbstrName
Pointer to a BSTR that is set on return to a string value specifying the vendor-supplied name of the application filter.
bstrName
BSTR that specifies the vendor-supplied name of the application filter.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write.

Note Although C++ syntax is provided for this property, C++ programmers should set this property using the Name parameter of the IFWXFilterAdmin::InstallFilter method.

[Visual Basic]

The Name property gets or sets the vendor-supplied name of the application filter.

Property Name As String

Property Value

String that specifies the vendor-supplied name of the application filter.

Remarks

This property is read/write.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCApplicationFilter


IFPCApplicationFilter.Predefined(VARIANT_BOOL) property [ISA Server 2004]

Predefined Property of IFPCApplicationFilter[C++]

FPCApplicationFilter.Predefined [Visual Basic]

[C++]

The Predefined property gets a Boolean value that indicates whether the application filter was installed with ISA Server and cannot be deleted.

HRESULT get_Predefined(
  VARIANT_BOOL* pfPredefined
);

Parameters

pfPredefined
Pointer to a Boolean variable that is set on return to VARIANT_TRUE if the application filter was installed with ISA Server and cannot be deleted, or to VARIANT_FALSE if the application filter was not installed with ISA Server and can be deleted.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The Predefined property gets a Boolean value that indicates whether the application filter was installed with ISA Server and cannot be deleted.

Property Predefined As Boolean

Property Value

Boolean value that indicates whether the application filter was installed with ISA Server and cannot be deleted.

Remarks

This property is read-only.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCApplicationFilter


IFPCApplicationFilter | FPCApplicationFilter Vendor property [ISA Server 2004]

Vendor Property of IFPCApplicationFilter[C++]

FPCApplicationFilter.Vendor [Visual Basic]

[C++]

The Vendor property gets or sets the name of the company that wrote the application filter.

HRESULT get_Vendor(
  BSTR* pbstrVendor
);

HRESULT put_Vendor(
  BSTR bstrVendor
);

Parameters

pbstrVendor
Pointer to a BSTR that is set on return to a string value specifying the name of the company that wrote the application filter.
bstrVendor
BSTR that specifies the name of the company that wrote the application filter.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write.

Note Although C++ syntax is provided for this property, C++ programmers should set this property using the Vendor parameter of the IFWXFilterAdmin::InstallFilter method.

[Visual Basic]

The Vendor property gets or sets the name of the company that wrote the application filter.

Property Vendor As String

Property Value

String that specifies the name of the company that wrote the application filter.

Remarks

This property is read/write.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCApplicationFilter


IFPCApplicationFilter | FPCApplicationFilter Version property [ISA Server 2004]

Version Property of IFPCApplicationFilter[C++]

FPCApplicationFilter.Version [Visual Basic]

[C++]

The Version property gets or sets the vendor-supplied version of the application filter.

HRESULT get_Version(
  BSTR* pbstrVersion
);

HRESULT put_Version(
  BSTR bstrVersion
);

Parameters

pbstrVersion
Pointer to a BSTR that is set on return to a string value specifying the vendor-supplied version of the application filter.
bstrVersion
BSTR that specifies the vendor-supplied version of the application filter.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write.

Note Although C++ syntax is provided for this property, C++ programmers should set this property using the VersionString parameter of the IFWXFilterAdmin::InstallFilter method.

[Visual Basic]

The Version property gets or sets the vendor-supplied version of the application filter.

Property Version As String

Property Value

String that specifies the vendor-supplied version of the application filter.

Remarks

This property is read/write.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCApplicationFilter


FPCApplicationFilters collection [ISA Server 2004]

FPCApplicationFilters Collection

The FPCApplicationFilters collection holds the set of FPCApplicationFilter objects that are registered with the Microsoft Firewall service. Each FPCApplicationFilter object represents a single application filter.

This collection is typically accessed through the ApplicationFilters property of an FPCExtensions object.

Click here to see the ISA Server object hierarchy.

Inheritance

This collection inherits from the FPCPersist object, which contains methods and properties related to the persistent storage of an object's data. They include methods for exporting the object's data to and importing it from an XML document.

Methods

The FPCApplicationFilters collection defines the following method.

Method | Description
Item | Retrieves the requested FPCApplicationFilter object from the collection.

Properties

The FPCApplicationFilters collection has the following properties.

Property | Description
_NewEnum | Gets an enumerator object for the collection.
Count | Gets the number of FPCApplicationFilter objects in the collection.

Methods Inherited from FPCPersist

Name | Description
CancelWaitForChanges | Cancels the registration established by the WaitForChanges method (for use in C and C++ programming only).
CanImport | Returns a Boolean value that indicates whether the properties of the collection and its elements can be imported from the specified XML document.
Export | Writes the stored values of all the properties of the collection and its elements to the specified XML document.
ExportToFile | Writes the stored values of all the properties of the collection and its elements to the specified XML file.
GetServiceRestartMask | Retrieves a 32-bit bitmask of the FpcServices enumerated type that specifies which services need to be restarted for currently unsaved changes to take effect.
Import | Copies the values of all the properties of the collection and its elements from the specified XML document to persistent storage.
ImportFromFile | Copies the values of all the properties of the collection and its elements from the specified XML file to persistent storage.
LoadDocProperties | Provides the XML document's properties so that you can know what information can be imported from the document.
Refresh | Reads the values of all the properties of the collection and its elements from persistent storage, overwriting any changes that have not been saved.
Save | Writes the current values of all the properties of the collection and its elements to persistent storage.
WaitForChanges | Registers to wait for an event indicating that the contents of the object have changed (for use in C and C++ programming only).

Properties Inherited from FPCPersist

Name | Description
PersistentName | Gets the persistent name of the collection. The persistent name of an object is a name that is unique for the object at the respective level of the COM object hierarchy.
VendorParametersSets | Gets an FPCVendorParametersSets collection that can hold sets of custom data for extending the collection.

Remarks

This object implements the IFPCApplicationFilters interface.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

COM Objects


IFPCApplicationFilters._NewEnum(IUnknown) property [ISA Server 2004]

_NewEnum Property of IFPCApplicationFilters[C++]

FPCApplicationFilters._NewEnum [Visual Basic]

[C++]

The _NewEnum property gets an enumerator object for the collection. An enumerator object provides serial access to the elements of the collection.

HRESULT get__NewEnum(
  IUnknown* ppEnum
);

Parameters

ppEnum
Address of an interface pointer that on return points to the IUnknown interface of an enumerator object that implements an IEnumVARIANT interface for the collection. An interface pointer to the IEnumVARIANT interface of the enumerator object can be retrieved by calling QueryInterface on the IUnknown interface returned.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The _NewEnum property gets an enumerator object for the collection. An enumerator object provides serial access to the elements of the collection.

Property _NewEnum As IUnknown

Property Value

Reference to an enumerator object that provides serial access to the elements of the collection.

Remarks

This property is read-only.

In Visual Basic and VBScript, this property is used implicitly in For Each...In...Next constructs.

Example Code

This VBScript script displays the vendor-supplied names of all the application filters that are registered with the Microsoft Firewall service. It does not include error handling.

' Create the root object.
Dim root  ' The FPCLib.FPC root object
Set root = CreateObject("FPC.Root")

' Declare the other objects needed.
Dim array               ' An FPCArray object
Dim applicationfilters  ' An FPCApplicationFilters collection
Dim applicationfilter   ' An FPCApplicationFilter object

' Get references to the array object
' and the address ranges collection.
Set array = root.GetContainingArray()
Set applicationfilters = array.Extensions.ApplicationFilters

' Display the names of the application filters
' that are registered with the Microsoft Firewall service.
For Each applicationfilter In applicationfilters
    WScript.Echo "Application filter name: " & applicationfilter.Name
Next

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCApplicationFilters


IFPCApplicationFilters | FPCApplicationFilters Count property [ISA Server 2004]

Count Property of IFPCApplicationFilters[C++]

FPCApplicationFilters.Count [Visual Basic]

[C++]

The Count property gets the number of FPCApplicationFilter objects in the collection.

HRESULT get_Count(
  long* plCount
);

Parameters

plCount
Pointer to a variable that on return receives a 32-bit integer specifying the number of FPCApplicationFilter objects in the collection.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The Count property gets the number of FPCApplicationFilter objects in the collection.

Property Count As Long

Property Value

A 32-bit integer that specifies the number of FPCApplicationFilter objects in the collection.

Remarks

This property is read-only.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCApplicationFilters


IFPCApplicationFilters | FPCApplicationFilters Item method [ISA Server 2004]

IFPCApplicationFilters::Item[C++]

FPCApplicationFilters.Item [Visual Basic]

[C++]

The Item method retrieves the requested IFPCApplicationFilter interface from the collection.

HRESULT Item(
  VARIANT Index,
  IFPCApplicationFilter** ppItem
);

Parameters

Index
[in] Required. One-based index of the object to retrieve.
ppItem
[out] Address of an interface pointer that on return points to the IFPCApplicationFilter interface requested.

Return Values

The method can return one of the following:

  • S_OK, indicating that the operation succeeded.
  • An error code, indicating that the operation failed. In this case, the [out] parameter returned is a null object.
[Visual Basic]

The Item method retrieves the requested FPCApplicationFilter object from the collection.

Function Item( _
  ByVal Index As Variant _
) As FPCApplicationFilter

Parameters

Index
[in] Required. One-based index of the object to retrieve.

Return Values

This method returns a reference to the FPCApplicationFilter object requested if successful. Otherwise, an error is raised that can be intercepted by using an error handler.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCApplicationFilters


FPCApplicationUsageReports object [ISA Server 2004]

FPCApplicationUsageReports

The FPCApplicationUsageReports object provides access to the properties of application usage reports.

This object is typically accessed through the ApplicationUsageReports property of an FPCReportsProperties object.

Click here to see the ISA Server object hierarchy.

Inheritance

This object inherits from the FPCPersist object, which contains methods and properties related to the persistent storage of an object's data. They include methods for exporting the object's data to and importing it from an XML document.

Methods

This object has no methods.

Properties

The FPCApplicationUsageReports object has the following properties.

Property | Description
ApplicationsReportSortOrder | Gets or sets a value from the FpcTopAppsReportSortOrder enumerated type that specifies how the information in the applications report is to be sorted.
ApplicationsReportTopNumber | Gets or sets the number of most frequently used applications to include in the report.
DestinationsReportSortOrder | Gets or sets a value from the FpcTopDestinationsReportSortOrder enumerated type that specifies how the information in the destinations report is to be sorted.
DestinationsReportTopNumber | Gets or sets the number of most frequently accessed destinations to include in the report.
OperatingSystemsReportSortOrder | Gets or sets a value from the FpcOperatingSystemsReportSortOrder enumerated type that specifies how the information in the operating systems report is to be sorted.
OperatingSystemsReportTopNumber | Gets or sets the number of most frequently used client operating systems to include in the report.
ProtocolsReportSortOrder | Gets or sets a value from the FpcTopAppProtocolReportSortOrder enumerated type that specifies how the information in the protocols report is to be sorted.
ProtocolsReportTopNumber | Gets or sets the number of most frequently used protocols to include in the report.
UsersReportSortOrder | Gets or sets a value from the FpcTopUsersReportSortOrder enumerated type that specifies how the information in the users report is to be sorted.
UsersReportTopNumber | Gets or sets the number of most active users to include in the report.

Methods Inherited from FPCPersist

Name | Description
CancelWaitForChanges | Cancels the registration established by the WaitForChanges method (for use in C and C++ programming only).
CanImport | Returns a Boolean value that indicates whether the object's properties can be imported from the specified XML document.
Export | Writes the stored values of all of the object's properties to the specified XML document.
ExportToFile | Writes the stored values of all of the object's properties to the specified XML file.
GetServiceRestartMask | Retrieves a 32-bit bitmask of the FpcServices enumerated type that specifies which services need to be restarted for currently unsaved changes to take effect.
Import | Copies the values of all of the object's properties from the specified XML document to persistent storage.
ImportFromFile | Copies the values of all of the object's properties from the specified XML file to persistent storage.
LoadDocProperties | Provides the XML document's properties so that you can know what information can be imported from the document.
Refresh | Reads the values of all of the object's properties from persistent storage, overwriting any changes that have not been saved.
Save | Writes the current values of all of the object's properties to persistent storage.
WaitForChanges | Registers to wait for an event indicating that the contents of the object have changed (for use in C and C++ programming only).

Properties Inherited from FPCPersist

Name | Description
PersistentName | Gets the persistent name of the object. The persistent name of an object is a name that is unique for the object at the respective level of the COM object hierarchy.
VendorParametersSets | Gets an FPCVendorParametersSets object that can hold sets of custom data for extending the object.

Remarks

This object implements the IFPCApplicationUsageReports interface.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

COM Objects


ApplicationsReportSortOrder property [ISA Server 2004]

ApplicationsReportSortOrder Property of IFPCApplicationUsageReports[C++]

FPCApplicationUsageReports.ApplicationsReportSortOrder [Visual Basic]

[C++]

The ApplicationsReportSortOrder property gets or sets a value from the FpcTopAppsReportSortOrder enumerated type that specifies how the information in the applications report is to be sorted. The applications report contains information about which applications clients are using. The information in the report can be sorted according to the number of users that use each application, or the number of requests submitted from each application.

HRESULT get_ApplicationsReportSortOrder(
  FpcTopAppsReportSortOrder* pApplicationsSortOrder
);

HRESULT put_ApplicationsReportSortOrder(
  FpcTopAppsReportSortOrder ApplicationsSortOrder
);

Parameters

pApplicationsSortOrder
Pointer to a variable that on return receives a value from the FpcTopAppsReportSortOrder enumerated type that specifies how the information in the applications report is to be sorted.
ApplicationsSortOrder
Value from the FpcTopAppsReportSortOrder enumerated type that specifies how the information in the applications report is to be sorted.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write.

[Visual Basic]

The ApplicationsReportSortOrder property gets or sets a value from the FpcTopAppsReportSortOrder enumerated type that specifies how the information in the applications report is to be sorted. The applications report contains information about which applications clients are using. The information in the report can be sorted according to the number of users that use each application, or the number of requests submitted from each application.

Property ApplicationsReportSortOrder As FpcTopAppsReportSortOrder

Property Value

Value from the FpcTopAppsReportSortOrder enumerated type that specifies how the information in the applications report is to be sorted.

Remarks

This property is read/write.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCApplicationUsageReports


ApplicationsReportTopNumber property [ISA Server 2004]

ApplicationsReportTopNumber Property of IFPCApplicationUsageReports[C++]

FPCApplicationUsageReports.ApplicationsReportTopNumber [Visual Basic]

[C++]

The ApplicationsReportTopNumber property gets or sets the number of most frequently used applications to include in the report.

HRESULT get_ApplicationsReportTopNumber(
  long* plTopNApplications
);

HRESULT put_ApplicationsReportTopNumber(
  long lTopNApplications
);

Parameters

plTopNApplications
Pointer to a variable that on return receives a 32-bit integer specifying the number of most frequently used applications to include in the report.
lTopNApplications
A 32-bit integer that specifies the number of most frequently used applications to include in the report.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write.

[Visual Basic]

The ApplicationsReportTopNumber property gets or sets the number of most frequently used applications to include in the report.

Property ApplicationsReportTopNumber As Long

Property Value

A 32-bit integer that specifies the number of most frequently used applications to include in the report.

Remarks

This property is read/write.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCApplicationUsageReports


DestinationsReportSortOrder property [ISA Server 2004]

DestinationsReportSortOrder Property of IFPCApplicationUsageReports[C++]

FPCApplicationUsageReports.DestinationsReportSortOrder [Visual Basic]

[C++]

The DestinationsReportSortOrder property gets or sets a value from the FpcTopDestinationsReportSortOrder enumerated type that specifies how the information in the destinations report is to be sorted. The destinations report contains information about which destinations clients are accessing. The report can be sorted according to the number of users that access each destination, the number of requests sent to each destination, or the number of bytes transferred.

HRESULT get_DestinationsReportSortOrder(
  FpcTopDestinationsReportSortOrder* pDestinationsSortOrder
);

HRESULT put_DestinationsReportSortOrder(
  FpcTopDestinationsReportSortOrder DestinationsSortOrder
);

Parameters

pDestinationsSortOrder
Pointer to a variable that on return receives a value from the FpcTopDestinationsReportSortOrder enumerated type that specifies how the information in the destinations report is to be sorted.
DestinationsSortOrder
Value from the FpcTopDestinationsReportSortOrder enumerated type that specifies how the information in the destinations report is to be sorted.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write.

[Visual Basic]

The DestinationsReportSortOrder property gets or sets a value from the FpcTopDestinationsReportSortOrder enumerated type that specifies how the information in the destinations report is to be sorted. The destinations report contains information about which destinations clients are accessing. The report can be sorted according to the number of users that access each destination, the number of requests sent to each destination, or the number of bytes transferred.

Property DestinationsReportSortOrder As FpcTopDestinationsReportSortOrder

Property Value

Value from the FpcTopDestinationsReportSortOrder enumerated type that specifies how the information in the destinations report is to be sorted.

Remarks

This property is read/write.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCApplicationUsageReports


DestinationsReportTopNumber property [ISA Server 2004]

DestinationsReportTopNumber Property of IFPCApplicationUsageReports[C++]

FPCApplicationUsageReports.DestinationsReportTopNumber [Visual Basic]

[C++]

The DestinationsReportTopNumber property gets or sets the number of most frequently accessed destinations to include in the report.

HRESULT get_DestinationsReportTopNumber(
  long* plTopNDestinations
);

HRESULT put_DestinationsReportTopNumber(
  long lTopNDestinations
);

Parameters

plTopNDestinations
Pointer to a variable that on return receives a 32-bit integer specifying the number of most frequently accessed destinations to include in the report.
lTopNDestinations
A 32-bit integer that specifies the number of most frequently accessed destinations to include in the report.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write.

[Visual Basic]

The DestinationsReportTopNumber property gets or sets the number of most frequently accessed destinations to include in the report.

Property DestinationsReportTopNumber As Long

Property Value

A 32-bit integer that specifies the number of most frequently accessed destinations to include in the report.

Remarks

This property is read/write.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCApplicationUsageReports


OperatingSystemsReportSortOrder property [ISA Server 2004]

OperatingSystemsReportSortOrder Property of IFPCApplicationUsageReports[C++]

FPCApplicationUsageReports.OperatingSystemsReportSortOrder [Visual Basic]

[C++]

The OperatingSystemsReportSortOrder property gets or sets a value from the FpcOperatingSystemsReportSortOrder enumerated type that specifies how the information in the operating systems report is to be sorted. The operating systems report contains information about which operating systems clients are using. The report can be sorted according to the number of users that use each operating system, or the number of requests made using each operating system.

HRESULT get_OperatingSystemsReportSortOrder(
  FpcOperatingSystemsReportSortOrder* pOperatingSystemsSortOrder
);

HRESULT put_OperatingSystemsReportSortOrder(
  FpcOperatingSystemsReportSortOrder OperatingSystemsSortOrder
);

Parameters

pOperatingSystemsSortOrder
Pointer to a variable that on return receives the value from the FpcOperatingSystemsReportSortOrder enumerated type that specifies how the information in the operating systems report is to be sorted.
OperatingSystemsSortOrder
Value from the FpcOperatingSystemsReportSortOrder enumerated type that specifies how the information in the operating systems report is to be sorted.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write.

[Visual Basic]

The OperatingSystemsReportSortOrder property gets or sets a value from the FpcOperatingSystemsReportSortOrder enumerated type that specifies how the information in the operating systems report is to be sorted. The operating systems report contains information about which operating systems clients are using. The report can be sorted according to the number of users that use each operating system, or the number of requests made using each operating system.

Property OperatingSystemsReportSortOrder As FpcOperatingSystemsReportSortOrder

Property Value

Value from the FpcOperatingSystemsReportSortOrder enumerated type that specifies how the information in the operating systems report is to be sorted.

Remarks

This property is read/write.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCApplicationUsageReports


OperatingSystemsReportTopNumber property [ISA Server 2004]

OperatingSystemsReportTopNumber Property of IFPCApplicationUsageReports[C++]

FPCApplicationUsageReports.OperatingSystemsReportTopNumber [Visual Basic]

[C++]

The OperatingSystemsReportTopNumber property gets or sets the number of most frequently used client operating systems to include in the report.

HRESULT get_OperatingSystemsReportTopNumber(
  long* plTopNOperatingSystems
);

HRESULT put_OperatingSystemsReportTopNumber(
  long lTopNOperatingSystems
);

Parameters

plTopNOperatingSystems
Pointer to a variable that on return receives a 32-bit integer specifying the number of most frequently used client operating systems to include in the report.
lTopNOperatingSystems
A 32-bit integer that specifies the number of most frequently used client operating systems to include in the report.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write.

[Visual Basic]

The OperatingSystemsReportTopNumber property gets or sets the number of most frequently used client operating systems to include in the report.

Property OperatingSystemsReportTopNumber As Long

Property Value

A 32-bit integer that specifies the number of most frequently used client operating systems to include in the report.

Remarks

This property is read/write.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCApplicationUsageReports


IFPCApplicationUsageReports.ProtocolsReportSortOrder property [ISA Server 2004]

ProtocolsReportSortOrder Property of IFPCApplicationUsageReports[C++]

FPCApplicationUsageReports.ProtocolsReportSortOrder [Visual Basic]

[C++]

The ProtocolsReportSortOrder property gets or sets a value from the FpcTopAppProtocolReportSortOrder enumerated type that specifies how the information in the protocols report is to be sorted. The protocols report contains information about what protocols clients are using. The information in the report can be sorted according to the number of users that use each protocol or the number of requests made in each protocol.

HRESULT get_ProtocolsReportSortOrder(
  FpcTopAppProtocolReportSortOrder* pProtocolsSortOrder
);

HRESULT put_ProtocolsReportSortOrder(
  FpcTopAppProtocolReportSortOrder ProtocolsSortOrder
);

Parameters

pProtocolsSortOrder
Pointer to a variable that on return receives a value from the FpcTopAppProtocolReportSortOrder enumerated type that indicates how the information in the protocols report is to be sorted.
ProtocolsSortOrder
Value from the FpcTopAppProtocolReportSortOrder enumerated type that indicates how the information in the protocols report is to be sorted.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write.

[Visual Basic]

The ProtocolsReportSortOrder property gets or sets a value from the FpcTopAppProtocolReportSortOrder enumerated type that specifies how the information in the protocols report is to be sorted. The protocols report contains information about what protocols clients are using. The information in the report can be sorted according to the number of users that use each protocol or the number of requests made in each protocol.

Property ProtocolsReportSortOrder As FpcTopAppProtocolReportSortOrder

Property Value

Value from the FpcTopAppProtocolReportSortOrder enumerated type that indicates how the information in the protocols report is to be sorted.

Remarks

This property is read/write.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCApplicationUsageReports


IFPCApplicationUsageReports.ProtocolsReportTopNumber property [ISA Server 2004]

ProtocolsReportTopNumber Property of IFPCApplicationUsageReports[C++]

FPCApplicationUsageReports.ProtocolsReportTopNumber [Visual Basic]

[C++]

The ProtocolsReportTopNumber property gets or sets the number of most frequently used protocols to include in the report.

HRESULT get_ProtocolsReportTopNumber(
  long* plTopNProtocols
);

HRESULT put_ProtocolsReportTopNumber(
  long lTopNProtocols
);

Parameters

plTopNProtocols
Pointer to a variable that on return receives a 32-bit integer specifying the number of most frequently used protocols to include in the report.
lTopNProtocols
A 32-bit integer that specifies the number of most frequently used protocols to include in the report.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write.

[Visual Basic]

The ProtocolsReportTopNumber property gets or sets the number of most frequently used protocols to include in the report.

Property ProtocolsReportTopNumber As Long

Property Value

A 32-bit integer that specifies the number of most frequently used protocols to include in the report.

Remarks

This property is read/write.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCApplicationUsageReports


IFPCApplicationUsageReports.UsersReportSortOrder property [ISA Server 2004]

UsersReportSortOrder Property of IFPCApplicationUsageReports[C++]

FPCApplicationUsageReports.UsersReportSortOrder [Visual Basic]

[C++]

The UsersReportSortOrder property gets or sets a value from the FpcTopUsersReportSortOrder enumerated type that specifies how the information in the users report is to be sorted. The users report contains information about the most active users. The report can be sorted according to the number of requests sent by each user or the number of bytes transferred for each user.

HRESULT get_UsersReportSortOrder(
  FpcTopUsersReportSortOrder* pUsersSortOrder
);

HRESULT put_UsersReportSortOrder(
  FpcTopUsersReportSortOrder UsersSortOrder
);

Parameters

pUsersSortOrder
Pointer to a value from the FpcTopUsersReportSortOrder enumerated type that is set on return to the value indicating how the report information should be sorted.
UsersSortOrder
Value from the FpcTopUsersReportSortOrder enumerated type that indicates how the report information should be sorted.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write.

[Visual Basic]

The UsersReportSortOrder property gets or sets a value from the FpcTopUsersReportSortOrder enumerated type that specifies how the information in the users report is to be sorted. The users report contains information about the most active users. The report can be sorted according to the number of requests sent by each user or the number of bytes transferred for each user.

Property UsersReportSortOrder As FpcTopUsersReportSortOrder

Property Value

Value from the FpcTopUsersReportSortOrder enumerated type that indicates how the report information should be sorted.

Remarks

This property is read/write.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCApplicationUsageReports


IFPCApplicationUsageReports.UsersReportTopNumber property [ISA Server 2004]

UsersReportTopNumber Property of IFPCApplicationUsageReports[C++]

FPCApplicationUsageReports.UsersReportTopNumber [Visual Basic]

[C++]

The UsersReportTopNumber property gets or sets the number of most active users to include in the report.

HRESULT get_UsersReportTopNumber(
  long* plTopNUsers
);

HRESULT put_UsersReportTopNumber(
  long lTopNUsers
);

Parameters

plTopNUsers
Pointer to a variable that on return receives a 32-bit integer specifying the number of most active users to include in the report.
lTopNUsers
A 32-bit integer that specifies the number of most active users to include in the report.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write.

[Visual Basic]

The UsersReportTopNumber property gets or sets the number of most active users to include in the report.

Property UsersReportTopNumber As Long

Property Value

A 32-bit integer that specifies the number of most-active users to include in the report.

Remarks

This property is read/write.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCApplicationUsageReports


FPCAppliedSSLCertificate object [ISA Server 2004]

FPCAppliedSSLCertificate

The FPCAppliedSSLCertificate object represents a Secure Sockets Layer (SSL) server certificate on a server, used to authenticate the ISA Server computer when a client connects to a Web listener through an SSL port.

The FPCAppliedSSLCertificate object is typically an element of an FPCAppliedSSLCertificates collection.

Click here to see the ISA Server object hierarchy.

Inheritance

This object inherits from the FPCPersist object, which contains methods and properties related to the persistent storage of an object's data. They include methods for exporting the object's data to and importing it from an XML document.

Methods

This object has no methods.

Properties

The FPCAppliedSSLCertificate object has the following properties.

Property | Description
Server | Gets an FPCRef object that references the FPCServer object representing the server on which the certificate is stored.
SSLCertificate | Gets an FPCCertificate object that represents the SSL server certificate used.

Methods Inherited from FPCPersist

Name | Description
CancelWaitForChanges | Cancels the registration established by the WaitForChanges method (for use in C and C++ programming only).
CanImport | Returns a Boolean value that indicates whether the object's properties can be imported from the specified XML document.
Export | Recursively writes the stored values of all the properties of the object and its subobjects to the specified XML document.
ExportToFile | Recursively writes the stored values of all the properties of the object and its subobjects to the specified XML file.
GetServiceRestartMask | Retrieves a 32-bit bitmask of the FpcServices enumerated type that specifies which services need to be restarted for currently unsaved changes to take effect.
Import | Recursively copies the values of all the properties of the object and of its subobjects from the specified XML document to persistent storage.
ImportFromFile | Recursively copies the values of all the properties of the object and of its subobjects from the specified XML file to persistent storage.
LoadDocProperties | Provides the XML document's properties so that you can know what information can be imported from the document.
Refresh | Recursively reads the values of all the properties of the object and of its subobjects from persistent storage, overwriting any changes that have not been saved.
Save | Recursively writes the current values of all the properties of the object and its subobjects to persistent storage.
WaitForChanges | Registers to wait for an event indicating that the contents of the object have changed (for use in C and C++ programming only).

Properties Inherited from FPCPersist

Name | Description
PersistentName | Gets the persistent name of the object. The persistent name of an object is a name that is unique for the object at the respective level of the COM object hierarchy.
VendorParametersSets | Gets an FPCVendorParametersSets collection that can hold sets of custom data for extending the object.

Remarks

This object implements the IFPCAppliedSSLCertificate interface.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

COM Objects


IFPCAppliedSSLCertificate.Server(IFPCRef) property [ISA Server 2004]

Server Property of IFPCAppliedSSLCertificate[C++]

FPCAppliedSSLCertificate.Server [Visual Basic]

[C++]

The Server property gets an FPCRef object that references the FPCServer object representing the server on which the certificate is stored.

HRESULT get_Server(
  IFPCRef** ppRef
);

Parameters

ppRef
Address of an interface pointer that on return points to an IFPCRef interface that references the FPCServer object representing the server on which the certificate is stored.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The Server property gets an FPCRef object that references the FPCServer object representing the server on which the certificate is stored.

Property Server As FPCRef

Property Value

Reference to an FPCRef object that references the FPCServer object representing the server on which the certificate is stored.

Remarks

This property is read-only.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCAppliedSSLCertificate


IFPCAppliedSSLCertificate.SSLCertificate property [ISA Server 2004]

SSLCertificate Property of IFPCAppliedSSLCertificate[C++]

FPCAppliedSSLCertificate.SSLCertificate [Visual Basic]

[C++]

The SSLCertificate property gets an FPCCertificate object that represents the SSL server certificate used.

HRESULT get_SSLCertificate(
  IFPCCertificate** ppCertificate
);

Parameters

ppCertificate
Address of an interface pointer that on return points to an IFPCCertificate interface that represents the SSL server certificate used.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The SSLCertificate property gets an FPCCertificate object that represents the SSL server certificate used.

Property SSLCertificate As FPCCertificate

Property Value

Reference to an FPCCertificate object that represents the SSL server certificate used.

Remarks

This property is read-only.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCAppliedSSLCertificate


FPCAppliedSSLCertificates collection [ISA Server 2004]

FPCAppliedSSLCertificates Collection

The FPCAppliedSSLCertificates collection holds a set of individual FPCAppliedSSLCertificate objects that are available to a specific Web listener. Each FPCAppliedSSLCertificate object represents a Secure Sockets Layer (SSL) server certificate that is installed on a server and can be used to authenticate the ISA Server computer when a client connects to the Web listener through the SSL port.

The FPCAppliedSSLCertificates collection is typically accessed through the AppliedSSLCertificates property of an FPCWebListenerProperties object.

Click here to see the ISA Server object hierarchy.

Inheritance

This collection inherits from the FPCPersist object, which contains methods and properties related to the persistent storage of an object's data. They include methods for exporting the object's data to and importing it from an XML document.

Methods

The FPCAppliedSSLCertificates collection defines the following methods.

Method | Description
Add | Creates a new FPCAppliedSSLCertificate object in the collection and returns a reference to it.
Item | Retrieves the requested FPCAppliedSSLCertificate object from the collection.
Remove | Removes the specified FPCAppliedSSLCertificate object from the collection.

Properties

The FPCAppliedSSLCertificates collection has the following properties.

Property | Description
_NewEnum | Gets an enumerator object for the collection.
Count | Gets the number of FPCAppliedSSLCertificate objects in the collection.

Methods Inherited from FPCPersist

Name | Description
CancelWaitForChanges | Cancels the registration established by the WaitForChanges method (for use in C and C++ programming only).
CanImport | Returns a Boolean value that indicates whether the properties of the collection, its elements, and their subobjects can be imported from the specified XML document.
Export | Recursively writes the stored values of all the properties of the collection, its elements, and their subobjects to the specified XML document.
ExportToFile | Recursively writes the stored values of all the properties of the collection, its elements, and their subobjects to the specified XML file.
GetServiceRestartMask | Retrieves a 32-bit bitmask of the FpcServices enumerated type that specifies which services need to be restarted for currently unsaved changes to take effect.
Import | Recursively copies the values of all the properties of the collection, its elements, and their subobjects from the specified XML document to persistent storage.
ImportFromFile | Recursively copies the values of all the properties of the collection, its elements, and their subobjects from the specified XML file to persistent storage.
Save | Recursively writes the current values of all the properties of the collection, its elements, and their subobjects to persistent storage.
WaitForChanges | Registers to wait for an event indicating that the contents of the object have changed (for use in C and C++ programming only).

Properties Inherited from FPCPersist

Name | Description
PersistentName | Gets the persistent name of the collection. The persistent name of an object is a name that is unique for the object at the respective level of the COM object hierarchy.
VendorParametersSets | Gets an FPCVendorParametersSets collection that can hold sets of custom data for extending the collection.

Remarks

This collection implements the IFPCAppliedSSLCertificates interface.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

COM Objects


IFPCAppliedSSLCertificates._NewEnum(IUnknown) property [ISA Server 2004]

_NewEnum Property of IFPCAppliedSSLCertificates[C++]

FPCAppliedSSLCertificates._NewEnum [Visual Basic]

[C++]

The _NewEnum property gets an enumerator object for the collection. An enumerator object provides serial access to the elements of the collection.

HRESULT get__NewEnum(
  IUnknown* ppEnum
);

Parameters

ppEnum
Address of an interface pointer that on return points to the IUnknown interface of an enumerator object that implements an IEnumVARIANT interface for the collection. An interface pointer to the IEnumVARIANT interface of the enumerator object can be retrieved by calling QueryInterface on the IUnknown interface returned.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The _NewEnum property gets an enumerator object for the collection. An enumerator object provides serial access to the elements of the collection.

Property _NewEnum As IUnknown

Property Value

Reference to an enumerator object that provides serial access to the elements of the collection.

Remarks

This property is read-only.

In Visual Basic and VBScript, this property is used implicitly in For Each...In...Next constructs.

Example Code

This VBScript script displays the names of all the SSL server certificates that are available for a specific Web listener. It does not include error handling.

' Create the root object.
Dim root  ' The FPCLib.FPC root object
Set root = CreateObject("FPC.Root")

' Declare the other objects needed.
Dim array                   ' An FPCArray object
Dim appliedsslcertificates  ' An FPCAppliedSSLCertificates collection
Dim appliedsslcertificate   ' An FPCAppliedSSLCertificate object
Dim weblisteners            ' An FPCWebListeners collection
Dim weblistener             ' An FPCWebListener object

' Get references to the array object
' and the Web listeners collection.
Set array = root.GetContainingArray()
Set weblisteners = array.RuleElements.WebListeners

' If at least one Web listener is defined in the Web listeners
' collection, display the names of the SSL server certificates
' that are available for the first Web listener found.
On Error Resume Next
Set weblistener = weblisteners.Item(1)
Set appliedsslcertificates = weblistener.Properties.AppliedSSLCertificates
If Err.Number = 0 Then
    For Each appliedsslcertificate In appliedsslcertificates
        WScript.Echo "AppliedSSLCertificate name: " & appliedsslcertificate.SSLCertificate.FriendlyName
    Next
End If

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCAppliedSSLCertificates


IFPCAppliedSSLCertificates.Add (3 Parameters) method [ISA Server 2004]

IFPCAppliedSSLCertificates::Add[C++]

FPCAppliedSSLCertificates.Add [Visual Basic]

[C++]

The Add method creates a new FPCAppliedSSLCertificate object in the collection and returns a reference to it.

HRESULT Add(
  VARIANT Hash,
  BSTR Server,
  IFPCAppliedSSLCertificate** ppAppliedSSLCertificate
);

Parameters

Hash
[in] Required. Variant that specifies the hash for the certificate.
Server
[in, optional] Required. BSTR that specifies the name of the ISA Server computer where the certificate is stored. The default value is an empty string. This parameter should not be specified in scripts and applications intended for computers running ISA Server 2004, Standard Edition.
ppAppliedSSLCertificate
[out] Address of an interface pointer that on return points to the new IFPCAppliedSSLCertificate interface created.

Return Values

This method can return one of the following:

  • S_OK, indicating that the operation succeeded.
  • An error code, indicating that the operation failed. In this case, the [out] parameter returned is a null object.

[Visual Basic]

The Add method creates a new FPCAppliedSSLCertificate object in the collection and returns a reference to it.

Function Add( _
  ByVal Hash As Variant, _
  [ ByVal Server As String ] _
) As FPCAppliedSSLCertificate

Parameters

Hash
[in] Required. Variant that specifies the hash for the certificate.
Server
[in, optional] Required. String that specifies the name of the ISA Server computer where the certificate is stored. The default value is an empty string. This parameter should not be specified in scripts and applications intended for computers running ISA Server 2004, Standard Edition.

Return Values

This method returns a reference to an FPCAppliedSSLCertificate object if successful. Otherwise, an error is raised that can be intercepted by using an error handler.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCAppliedSSLCertificates


IFPCAppliedSSLCertificates.Count(long) property [ISA Server 2004]

Count Property of IFPCAppliedSSLCertificates[C++]

FPCAppliedSSLCertificates.Count [Visual Basic]

[C++]

The Count property gets the number of FPCAppliedSSLCertificate objects in the collection.

HRESULT get_Count(
  long* plCount
);

Parameters

plCount
Pointer to a variable that on return receives a 32-bit integer specifying the number of FPCAppliedSSLCertificate objects in the collection.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The Count property gets the number of FPCAppliedSSLCertificate objects in the collection.

Property Count As Long

Property Value

A 32-bit integer that specifies the number of FPCAppliedSSLCertificate objects in the collection.

Remarks

This property is read-only.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCAppliedSSLCertificates


IFPCAppliedSSLCertificates.Item (2 Parameters) method [ISA Server 2004]

IFPCAppliedSSLCertificates::Item[C++]

FPCAppliedSSLCertificates.Item [Visual Basic]

[C++]

The Item method retrieves the requested IFPCAppliedSSLCertificate interface from the collection.

HRESULT Item(
  long lIndex,
  IFPCAppliedSSLCertificate** ppAppliedSSLCertificate
);

Parameters

lIndex
[in] Required. One-based index of the object to retrieve.
ppAppliedSSLCertificate
[out] Address of an interface pointer that on return points to the IFPCAppliedSSLCertificate interface requested.

Return Values

The method can return one of the following:

  • S_OK, indicating that the operation succeeded.
  • An error code, indicating that the operation failed. In this case, the [out] parameter returned is a null object.
[Visual Basic]

The Item method retrieves the requested FPCAppliedSSLCertificate object from the collection.

Function Item( _
  ByVal lIndex As Long _
) As FPCAppliedSSLCertificate

Parameters

lIndex
[in] Required. One-based index of the object to retrieve.

Return Values

This method returns a reference to the FPCAppliedSSLCertificate object requested if successful. Otherwise, an error is raised that can be intercepted by using an error handler.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCAppliedSSLCertificates


IFPCAppliedSSLCertificates.Remove(Long) method [ISA Server 2004]

IFPCAppliedSSLCertificates::Remove[C++]

FPCAppliedSSLCertificates.Remove [Visual Basic]

[C++]

The Remove method removes the specified FPCAppliedSSLCertificate object from the collection.

HRESULT Remove(
  long lIndex
);

Parameters

lIndex
[in] Required. One-based index of the FPCAppliedSSLCertificate object to remove.

Return Values

This method returns S_OK if the call is successful; otherwise, it returns an error code.
[Visual Basic]

The Remove method removes the specified FPCAppliedSSLCertificate object from the collection.

Sub Remove( _
  ByVal lIndex As Long _
)

Parameters

lIndex
[in] Required. One-based index of the FPCAppliedSSLCertificate object to remove.

Return Values

This method has no return values. If the call is unsuccessful, an error is raised that can be intercepted by using an error handler.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCAppliedSSLCertificates


FPCArray object [ISA Server 2004]

FPCArray

The FPCArray object defines a single ISA Server array and provides access to the ISA Server configuration settings through its properties. In ISA Server 2004 Standard Edition, the FPCArray object provides access to the configuration settings of a single ISA Server computer.

This object is typically an element of an FPCArrays collection.

The FPCArray object that represents the array associated with the current ISA Server computer can be retrieved by calling the GetContainingArray method of the FPC root object. The current ISA Server computer is the computer that executes the code calling this method.

For examples using the FPCArray object, see ISA Server Administration Scripting.

Click here to see the ISA Server object hierarchy.

Inheritance

This object inherits from the FPCPersist object, which contains methods and properties related to the persistent storage of an object's data. They include methods for exporting the object's data to and importing it from an XML document.

Methods

The FPCArray object defines the following methods.

Method | Description
RestartServices | Restarts the services specified in a bitmask of the FpcServices enumerated type and any services that depend on them.
SelectNetworkTemplateAndPolicy | Sets a selected network template and default policy for the array.

Properties

The FPCArray object has the following properties.

Property | Description
AdminSecurity | Gets an FPCAdminSecurity object that holds the administration security settings for the array.
AdminVersionMajor | Gets the major version number of the schema of the array.
AdminVersionMinor | Gets the minor version number of the schema of the array.
Alerts | Gets an FPCAlerts collection that contains objects defining all the alerts in the array.
ArrayPolicy | Gets an FPCArrayPolicy object that specifies the array policy for the array.
Cache | Gets an FPCCache object that provides access to the cache configuration settings for the array and to a method for downloading content to the cache.
Components | Gets a set of flags indicating the components that are installed in the array.
ConnectivityVerifiers | Gets an FPCConnectivityVerifiers collection that contains objects defining all the connectivity verifiers for the array.
CreatedTime | Gets a Date value that specifies the date and time in Coordinated Universal Time (UTC) when the object was created.
Description | Gets or sets the description of the array in the form of a string.
Extensions | Gets an FPCExtensions object that represents the set of application filters and Web filters for the array.
FWClientConfigSettings | Gets an FPCClientConfigSettings collection that contains the Firewall client settings for the array.
LastModifiedTime | Gets a Date value that specifies the date and time in Coordinated Universal Time (UTC) when the array was modified.
Logging | Gets an FPCLogs collection that contains objects defining all the logging configurations for the array.
LogViewer | Gets an FPCLogViewer object that represents the log viewer for the array.
MailCodePage | Gets or sets the mail code page of the array.
Name | Gets or sets the name of the array.
NetworkConfiguration | Gets an FPCNetworkConfiguration object that holds all the network configuration settings for the array.
NetworkTemplateUsed | Gets an FPCRef object that references the FPCNetworkTemplate object defining the network template used by the array.
Reports | Gets an FPCReports object that holds the ready reports, report jobs, and summary report configuration for the array.
RuleElements | Gets an FPCRuleElements object that holds all rule elements for the array.
Servers | Gets an FPCServers collection that contains objects representing all the ISA Server computers in the array.
SessionsMonitors | Gets an FPCSessionsMonitors object that provides access to the firewall and the ISA Server Web proxy session monitors for the array.
SystemPolicy | Gets an FPCSystemPolicy object that holds the system policy information for the array.
Type | Gets the array's type.

Methods Inherited from FPCPersist

Name | Description
CancelWaitForChanges | Cancels the registration established by the WaitForChanges method (for use in C and C++ programming only).
CanImport | Returns a Boolean value that indicates whether the object's properties can be imported from the specified XML document.
Export | Recursively writes the stored values of all the properties of the object and its subobjects to the specified XML document.
ExportToFile | Recursively writes the stored values of all the properties of the object and its subobjects to the specified XML file.
GetServiceRestartMask | Retrieves a 32-bit bitmask of the FpcServices enumerated type that specifies which services need to be restarted for currently unsaved changes to take effect.
Import | Recursively copies the values of all the properties of the object and of its subobjects from the specified XML document to persistent storage.
ImportFromFile | Recursively copies the values of all the properties of the object and of its subobjects from the specified XML file to persistent storage.
LoadDocProperties | Provides the XML document's properties so that you can know what information can be imported from the document.
Refresh | Recursively reads the values of all the properties of the object and of its subobjects from persistent storage, overwriting any changes that have not been saved.
Save | Recursively writes the current values of all the properties of the object and its subobjects to persistent storage.
WaitForChanges | Registers to wait for an event indicating that the contents of the object have changed (for use in C and C++ programming only).

Properties Inherited from FPCPersist

Name | Description
PersistentName | Gets the persistent name of the object. The persistent name of an object is a name that is unique for the object at the respective level of the COM object hierarchy.
VendorParametersSets | Gets an FPCVendorParametersSets collection that can hold sets of custom data for extending the object.

Remarks

This object implements the IFPCArray interface.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

COM Objects


IFPCArray | FPCArray AdminSecurity(IFPCAdminSecurity) property [ISA Server 2004]

AdminSecurity Property of IFPCArray[C++]

FPCArray.AdminSecurity [Visual Basic]

[C++]

The AdminSecurity property gets an FPCAdminSecurity object that holds the administration security settings for the array.

HRESULT get_AdminSecurity(
  IFPCAdminSecurity** ppAdminSecurity
);

Parameters

ppAdminSecurity
Address of an interface pointer that on return points to an IFPCAdminSecurity interface that represents the administration security settings for the array.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The AdminSecurity property gets an FPCAdminSecurity object that holds the administration security settings for the array.

Property AdminSecurity As FPCAdminSecurity

Property Value

Reference to the FPCAdminSecurity object for the array.

Remarks

This property is read-only.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCArray


IFPCArray | FPCArray AdminVersionMajor(long) property [ISA Server 2004]

AdminVersionMajor Property of IFPCArray[C++]

FPCArray.AdminVersionMajor [Visual Basic]

[C++]

The AdminVersionMajor property gets the major version number of the schema of the array.

HRESULT get_AdminVersionMajor(
  long* pVal
);

Parameters

pVal
Pointer to a variable that is set on return to a 32-bit integer specifying the major version number of the schema of the array.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The AdminVersionMajor property gets the major version number of the schema of the array.

Property AdminVersionMajor As Long

Property Value

A 32-bit integer that specifies the major version number of the schema of the array.

Remarks

This property is read-only.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCArray


IFPCArray | FPCArray AdminVersionMinor(long) property [ISA Server 2004]

AdminVersionMinor Property of IFPCArray[C++]

FPCArray.AdminVersionMinor [Visual Basic]

[C++]

The AdminVersionMinor property gets the minor version number of the schema of the array.

HRESULT get_AdminVersionMinor(
  long* pVal
);

Parameters

pVal
Pointer to a variable that is set on return to a 32-bit integer specifying the minor version number of the schema of the array.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The AdminVersionMinor property gets the minor version number of the schema of the array.

Property AdminVersionMinor As Long

Property Value

A 32-bit integer that specifies the minor version number of the schema of the array.

Remarks

This property is read-only.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCArray


IFPCArray | FPCArray Alerts(IFPCAlerts) property [ISA Server 2004]

Alerts Property of IFPCArray[C++]

FPCArray.Alerts [Visual Basic]

[C++]

The Alerts property gets an FPCAlerts collection that contains objects defining all the alerts in the array.

HRESULT get_Alerts(
  IFPCAlerts** ppAlerts
);

Parameters

ppAlerts
Address of an interface pointer that on return points to an IFPCAlerts interface that represents the collection of all the alerts in the array.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only. You can add, delete, or modify the alerts for the array by calling the methods of the IFPCAlerts interface retrieved.

[Visual Basic]

The Alerts property gets an FPCAlerts collection that contains objects defining all the alerts in the array.

Property Alerts As FPCAlerts

Property Value

Reference to the FPCAlerts collection for the array.

Remarks

This property is read-only. You can add, delete, or modify the alerts for the array by calling the methods of the FPCAlerts collection retrieved.

Example Code

The following code uses the Alerts property to retrieve the name of an individual alert:

Dim root As New FPCLib.FPC
Dim alertName As String
Dim array1 As FPCArray
Set array1 = root.Arrays(1)
alertName = array1.Alerts(1).Name

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCArray


IFPCArray | FPCArray ArrayPolicy(IFPCArrayPolicy) property [ISA Server 2004]

ArrayPolicy Property of IFPCArray[C++]

FPCArray.ArrayPolicy [Visual Basic]

[C++]

The ArrayPolicy property gets an FPCArrayPolicy object that specifies the array policy for the array.

HRESULT get_ArrayPolicy(
  IFPCArrayPolicy** ppArrayPolicy
);

Parameters

ppArrayPolicy
Address of an interface pointer that on return points to an IFPCArrayPolicy interface that specifies the array policy for the array.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only. You can access the details of the array policy through the properties of the IFPCArrayPolicy interface retrieved.

[Visual Basic]

The ArrayPolicy property gets an FPCArrayPolicy object that specifies the array policy for the array.

Property ArrayPolicy As FPCArrayPolicy

Property Value

Reference to an FPCArrayPolicy object that specifies the array policy for the array.

Remarks

This property is read-only. You can access the details of the array policy through the properties of the FPCArrayPolicy object retrieved.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCArray


IFPCArray | FPCArray Cache(IFPCCache) property [ISA Server 2004]

Cache Property of IFPCArray[C++]

FPCArray.Cache [Visual Basic]

[C++]

The Cache property gets an FPCCache object that provides access to the cache configuration settings for the array and to a method for downloading content to the cache.

HRESULT get_Cache(
  IFPCCache** ppCache
);

Parameters

ppCache
Address of an interface pointer that on return points to the IFPCCache interface for the array.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only. You can use such properties of the IFPCCache interface retrieved as CacheConfiguration and CacheContents to adjust the cache configuration settings and download content to the cache.

[Visual Basic]

The Cache property gets an FPCCache object that provides access to the cache configuration settings for the array and to a method for downloading content to the cache.

Property Cache As FPCCache

Property Value

Reference to the FPCCache object for the array.

Remarks

This property is read-only. You can use such properties of the FPCCache object retrieved as CacheConfiguration and CacheContents to adjust the cache configuration settings and download content to the cache.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCArray


IFPCArray | FPCArray Components(long) property [ISA Server 2004]

Components Property of IFPCArray[C++]

FPCArray.Components [Visual Basic]

[C++]

The Components property gets a 32-bit bitmask containing bit flags from the FpcComponents enumerated type that specify the components installed in the array.

HRESULT get_Components(
  long* plComponents
);

Parameters

plComponents
Pointer to a 32-bit integer that is set on return to a bitmask containing bit flags from the FpcComponents enumerated type that specify the components installed in the array.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The Components property gets a 32-bit bitmask containing bit flags from the FpcComponents enumerated type that specify the components installed in the array.

Property Components As Long

Property Value

A 32-bit bitmask containing bit flags from the FpcComponents enumerated type that specify the components installed in the array.

Remarks

This property is read-only.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCArray


IFPCArray | FPCArray ConnectivityVerifiers property [ISA Server 2004]

ConnectivityVerifiers Property of IFPCArray[C++]

FPCArray.ConnectivityVerifiers [Visual Basic]

[C++]

The ConnectivityVerifiers property gets an FPCConnectivityVerifiers collection that contains objects defining all the connectivity verifiers for the array. A connectivity verifier checks for connectivity from an ISA Server computer to another computer, such as an external Web server.

HRESULT get_ConnectivityVerifiers(
  IFPCConnectivityVerifiers** ppConnectivityVerifiers
);

Parameters

ppConnectivityVerifiers
Address of an interface pointer that on return points to an IFPCConnectivityVerifiers interface that represents the collection of connectivity verifiers for the array.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only. You can add, delete, or modify the connectivity verifiers for the array by calling the methods of the IFPCConnectivityVerifiers interface retrieved.

[Visual Basic]

The ConnectivityVerifiers property gets an FPCConnectivityVerifiers collection that contains objects defining all the connectivity verifiers for the array. A connectivity verifier checks for connectivity from an ISA Server computer to another computer, such as an external Web server.

Property ConnectivityVerifiers As FPCAdminSecurity

Property Value

Reference to the FPCConnectivityVerifiers collection for the array.

Remarks

This property is read-only. You can add, delete, or modify the connectivity verifiers for the array by calling the methods of the FPCConnectivityVerifiers collection retrieved.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCArray


IFPCArray | FPCArray CreatedTime(DATE) property [ISA Server 2004]

CreatedTime Property of IFPCArray[C++]

FPCArray.CreatedTime [Visual Basic]

[C++]

The CreatedTime property gets a DATE value that specifies the date and time in Coordinated Universal Time (UTC) when the array was created.

HRESULT get_CreatedTime(
  DATE* pdCreatedTime
);

Parameters

pdCreatedTime
Pointer to a DATE that is set on return to the value specifying the date and time in Coordinated Universal Time (UTC) when the array was created.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The CreatedTime property gets a Date value that specifies the date and time in Coordinated Universal Time (UTC) when the array was created.

Property CreatedTime As Date

Property Value

Date value that specifies the date and time in Coordinated Universal Time (UTC) when the array was created.

Remarks

This property is read-only.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCArray


IFPCArray | FPCArray Description(BSTR,BSTR) property [ISA Server 2004]

Description Property of IFPCArray[C++]

FPCArray.Description [Visual Basic]

[C++]

The Description property gets or sets the description of the array.

HRESULT get_Description(
  BSTR* pbstrDescription
);

HRESULT put_Description(
  BSTR bstrDescription
);

Parameters

pbstrDescription
Pointer to a BSTR that is set on return to a string value specifying the description of the array.
bstrDescription
BSTR that specifies the description of the array.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write.

[Visual Basic]

The Description property gets or sets the description of the array.

Property Description As String

Property Value

String that specifies the description of the array.

Remarks

This property is read/write.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCArray


IFPCArray | FPCArray Extensions(IFPCExtensions) property [ISA Server 2004]

Extensions Property of IFPCArray[C++]

FPCArray.Extensions [Visual Basic]

[C++]

The Extensions property gets an FPCExtensions object that represents the set of application filters and Web filters for the array.

HRESULT get_Extensions(
  IFPCExtensions** ppIFPCExtensions
);

Parameters

ppIFPCExtensions
Address of an interface pointer that on return points to an IFPCExtensions interface that represents the set of application filters and Web filters for the array.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The Extensions property gets an FPCExtensions object that represents the set of application filters and Web filters for the array.

Property Extensions As FPCExtensions

Property Value

Reference to the FPCExtensions object for the array.

Remarks

This property is read-only.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCArray


IFPCArray | FPCArray FWClientConfigSettings property [ISA Server 2004]

FWClientConfigSettings Property of IFPCArray[C++]

FPCArray.FWClientConfigSettings [Visual Basic]

[C++]

The FWClientConfigSettings property gets an FPCClientConfigSettings collection that contains the Firewall client settings for the array. These settings are organized into FPCClientSettingsSection objects, each of which contains a section of client settings.

HRESULT get_FWClientConfigSettings(
  IFPCClientConfigSettings** ppClientConfigSettings
);

Parameters

ppClientConfigSettings
Address of an interface pointer that on return points to an IFPCClientConfigSettings interface that represents the collection of Firewall client settings.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The FWClientConfigSettings property gets an FPCClientConfigSettings collection that contains the Firewall client settings for the array. These settings are organized into FPCClientSettingsSection objects, each of which contains a section of client settings.

Property FWClientConfigSettings As FPCClientConfigSettings

Property Value

Reference to the FPCClientConfigSettings collection for the array.

Remarks

This property is read-only.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCArray


IFPCArray | FPCArray LastModifiedTime(DATE) property [ISA Server 2004]

LastModifiedTime Property of IFPCArray[C++]

FPCArray.LastModifiedTime [Visual Basic]

[C++]

The LastModified property gets a DATE value that specifies the date and time in Coordinated Universal Time (UTC) when the array was last modified.

HRESULT get_LastModifiedTime(
  DATE* pdLastModifiedTime
);

Parameters

pdLastModifiedTime
Pointer to a DATE that is set on return to the value specifying the date and time in Coordinated Universal Time (UTC) when the array was last modified.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The LastModified property gets a Date value that specifies the date and time in Coordinated Universal Time (UTC) when the array was last modified.

Property LastModifiedTime As Date

Property Value

Date value that specifies the date and time in Coordinated Universal Time (UTC) when the array was last modified.

Remarks

This property is read-only.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCArray


IFPCArray | FPCArray Logging(IFPCLogs) property [ISA Server 2004]

Logging Property of IFPCArray[C++]

FPCArray.Logging [Visual Basic]

[C++]

The Logging property gets an FPCLogs collection that contains objects defining all of the logging configurations for the array.

HRESULT get_Logging(
  IFPCLogs** ppLogs
);

Parameters

ppLogs
Address of an interface pointer that on return points to an IFPCLogs interface that represents the collection of logging configurations for the array.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only. You can access and modify the individual logging configurations for the array through the IFPCLogs interface retrieved.

[Visual Basic]

The Logging property gets an FPCLogs collection that contains objects defining all of the logging configurations for the array.

Property Logging As FPCLogs

Property Value

Reference to the FPCLogs collection for the array.

Remarks

This property is read-only. You can access and modify the individual logging configurations for the array through the FPCLogs collection retrieved.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCArray


IFPCArray | FPCArray LogViewer(IFPCLogViewer) property [ISA Server 2004]

LogViewer Property of IFPCArray[C++]

FPCArray.LogViewer [Visual Basic]

[C++]

The LogViewer property gets an FPCLogViewer object that represents the log viewer for the array.

HRESULT get_LogViewer(
  IFPCLogViewer** ppLogViewer
);

Parameters

ppLogViewer
Address of an interface pointer that on return points to an IFPCLogViewer interface that represents the log viewer for the array.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The LogViewer property gets an FPCLogViewer object that represents the log viewer for the array.

Property LogViewer As FPCLogViewer

Property Value

Reference to an FPCLogViewer object that represents the log viewer for the array.

Remarks

This property is read-only.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCArray


IFPCArray | FPCArray MailCodePage(long,long) property [ISA Server 2004]

MailCodePage Property of IFPCArray[C++]

FPCArray.MailCodePage [Visual Basic]

[C++]

The MailCodePage property gets or sets the mail code page of the array.

HRESULT get_MailCodePage(
  long* plCodePage
);

HRESULT put_MailCodePage(
  long lCodePage
);

Parameters

plCodePage
Pointer to a variable that is set on return to a 32-bit integer specifying the mail code page of the array.
lCodePage
A 32-bit integer that specifies the mail code page of the array.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read-only.

[Visual Basic]

The MailCodePage property gets or sets the mail code page of the array.

Property MailCodePage As Long

Property Value

A 32-bit integer that specifies the mail code page of the array.

Remarks

This property is read-only.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCArray


IFPCArray | FPCArray Name(BSTR,BSTR) property [ISA Server 2004]

Name Property of IFPCArray[C++]

FPCArray.Name [Visual Basic]

[C++]

The Name property gets or sets the name of the array.

HRESULT get_Name(
  BSTR* pbstrName
);

HRESULT put_Name(
  BSTR bstrName
);

Parameters

pbstrName
Pointer to a BSTR that is set on return to a string value specifying the name of the array.
bstrName
BSTR that specifies the name of the array.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write.

[Visual Basic]

The Name property gets or sets the name of the array.

Property Name As String

Property Value

String that specifies the name of the array.

Remarks

This property is read/write.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCArray


IFPCArray | FPCArray NetworkConfiguration property [ISA Server 2004]

NetworkConfiguration Property of IFPCArray[C++]

FPCArray.NetworkConfiguration [Visual Basic]

[C++]

The NetworkConfiguration property gets an FPCNetworkConfiguration object that holds all the network configuration settings for the array.

HRESULT get_NetworkConfiguration(
  IFPCNetworkConfiguration** ppNetworkConfiguration
);

Parameters

ppNetworkConfiguration
Address of an interface pointer that on return points to an IFPCNetworkConfiguration interface that provides access to all the network configuration settings for the array.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only. You can access and manipulate the network configuration settings through the properties of the IFPCNetworkConfiguration interface retrieved.

[Visual Basic]

The NetworkConfiguration property gets an FPCNetworkConfiguration object that holds all the network configuration settings for the array.

Property NetworkConfiguration As FPCNetworkConfiguration

Property Value

Reference to the FPCNetworkConfiguration object for the array.

Remarks

This property is read-only. You can access and manipulate the network configuration settings through the properties of the FPCNetworkConfiguration object retrieved.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCArray


IFPCArray | FPCArray NetworkTemplateUsed(IFPCRef) property [ISA Server 2004]

NetworkTemplateUsed Property of IFPCArray[C++]

FPCArray.NetworkTemplateUsed [Visual Basic]

[C++]

The NetworkTemplateUsed property gets an FPCRef object that references the FPCNetworkTemplate object defining the network template used by the array.

HRESULT get_NetworkTemplateUsed(
  IFPCRef** ppRef
);

Parameters

ppRef
Address of an interface pointer that on return points to an IFPCRef interface that references the FPCNetworkTemplate object defining the network template used by the array.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only. The network template used by the array can be set by calling the SelectNetworkTemplateAndPolicy method.

[Visual Basic]

The NetworkTemplateUsed property gets an FPCRef object that references the FPCNetworkTemplate object defining the network template used by the array.

Property NetworkTemplateUsed As FPCRef

Property Value

Reference to an FPCRef object that references the FPCNetworkTemplate object defining the network template used by the array.

Remarks

This property is read-only. The network template used by the array can be set by calling the SelectNetworkTemplateAndPolicy method.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCArray


IFPCArray | FPCArray Reports(IFPCReports) property [ISA Server 2004]

Reports Property of IFPCArray[C++]

FPCArray.Reports [Visual Basic]

[C++]

The Reports property gets an FPCReports object that holds the ready reports, report jobs, and summary report configuration for the array.

HRESULT get_Reports(
  IFPCReports** ppReports
);

Parameters

ppReports
Address of an interface pointer that on return points to an IFPCReports interface that represents the ready reports, report jobs, and summary report configuration for the array.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The Reports property gets an FPCReports object that holds the ready reports, report jobs, and summary report configuration for the array.

Property Reports As FPCReports

Property Value

Reference to the FPCReports object for the array.

Remarks

This property is read-only.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCArray


IFPCArray | FPCArray RestartServices(FpcServices) method [ISA Server 2004]

IFPCArray::RestartServices[C++]

FPCArray.RestartServices [Visual Basic]

[C++]

The RestartServices method restarts the services specified in a bitmask of the FpcServices enumerated type and any services that depend on them. This method can restart any service that can be specified by a value defined in the FpcServices enumerated type.

HRESULT RestartServices(
  FpcServices Services
);

Parameters

Services
[in] Bitmask of the FpcServices enumerated type that specifies the services to be restarted.

Return Values

This method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This method does not return until all of the services that need to be restarted have finished restarting.

The Microsoft Firewall Service depends on the Microsoft Data Engine (MSDE) service. If this method is called to restart the MSDE service, it will also restart the Firewall service.

If a service specified is not running when this method is called, the method starts the service.

[Visual Basic]

The RestartServices method restarts the services specified in a bitmask of the FpcServices enumerated type and any services that depend on them. This method can restart any service that can be specified by a value defined in the FpcServices enumerated type.

Sub RestartServices( _
  ByVal Services As FpcServices _
)

Parameters

Services
[in] Bitmask of the FpcServices enumerated type that specifies the services to be restarted.

Return Values

This method has no return values. If the call is unsuccessful, an error is raised that can be intercepted by using an error handler.

Remarks

This method does not return until all of the services that need to be restarted have finished restarting.

The Microsoft Firewall Service depends on the Microsoft Data Engine (MSDE) service. If this method is called to restart the MSDE service, it will also restart the Firewall service.

If a service specified is not running when this method is called, the method starts the service.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCArray


IFPCArray | FPCArray RuleElements(IFPCRuleElements) property [ISA Server 2004]

RuleElements Property of IFPCArray[C++]

FPCArray.RuleElements [Visual Basic]

[C++]

The RuleElements property gets an FPCRuleElements object that holds all rule elements for the array. The FPCRuleElements object has many properties that allow you to access important ISA Server settings—for example, configuration details, all scheduling information, and computers.

HRESULT get_RuleElements(
  IFPCRuleElements** ppRuleElements
);

Parameters

ppRuleElements
Address of an interface pointer that on return points to an IFPCRuleElements interface that represents the set of all rule elements for the array.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The RuleElements property gets an FPCRuleElements object that holds all rule elements for the array. The FPCRuleElements object has many properties that allow you to access important ISA Server settings—for example, configuration details, all scheduling information, and computers.

Property RuleElements As FPCRuleElements

Property Value

Reference to the FPCRuleElements object for the array.

Remarks

This property is read-only.

Example Code

The following Visual Basic code example uses the RuleElements property to list the number of schedules within an array:

Dim root As New FPCLib.FPC
Dim array1 As FPCArray
Dim numSchedules As Integer
Set array1 = root.Arrays(1)
numSchedules = array1.RuleElements.Schedules.Count

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCArray


IFPCArray | FPCArray SelectNetworkTemplateAndPolicy method [ISA Server 2004]

IFPCArray::SelectNetworkTemplateAndPolicy[C++]

FPCArray.SelectNetworkTemplateAndPolicy [Visual Basic]

[C++]

The SelectNetworkTemplateAndPolicy method sets a selected network template and default policy for the array.

HRESULT SelectNetworkTemplateAndPolicy(
  BSTR networkTemplate,
  BSTR defaultPolicy
);

Parameters

networkTemplate
[in] String value that specifies the network template to be used.
defaultPolicy
[in] String value that specifies the default policy to be used.

Return Values

This method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This method deletes all existing networks, network rules, and policy rules, and replaces them with the network topology and policy selected.

[Visual Basic]

The SelectNetworkTemplateAndPolicy method sets a selected network template and default policy for the array.

Sub SelectNetworkTemplateAndPolicy( _
  ByVal networkTemplate As String, _
  ByVal defaultPolicy As String _
)

Parameters

networkTemplate
[in] String value that specifies the network template to be used.
defaultPolicy
[in] String value that specifies the default policy to be used.

Return Values

This method has no return values.

Remarks

This method deletes all existing networks, network rules, and policy rules, and replaces them with the network topology and policy selected.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCArray


IFPCArray | FPCArray Servers(IFPCServers) property [ISA Server 2004]

Servers Property of IFPCArray[C++]

FPCArray.Servers [Visual Basic]

[C++]

The Servers property gets an FPCServers collection that contains objects representing all the ISA Server computers in the array.

HRESULT get_Servers(
  IFPCServers** ppServers
);

Parameters

ppServers
Address of an interface pointer that on return points to an IFPCServers interface that represents the collection of ISA Server computers in the array.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only. You can access all the properties of each individual ISA Server computer in the array through the IFPCServers interface retrieved.

[Visual Basic]

The Servers property gets an FPCServers collection that contains objects representing all the ISA Server computers in the array.

Property Servers As FPCServers

Property Value

Reference to the FPCServers collection for the array.

Remarks

This property is read-only. You can access all the properties of each ISA Server computer in the array through the FPCServers collection retrieved.

Example Code

The following code uses the Servers property to return the name of an individual server.

Dim root As New FPCLib.FPC
Dim serverName As String
Dim array1 As FPCArray
Set array1 = root.Arrays(1)
serverName = array1.Servers(1).Name

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCArray


IFPCArray | FPCArray SessionsMonitors (1 Parameter) property [ISA Server 2004]

SessionsMonitors Property of IFPCArray[C++]

FPCArray.SessionsMonitors [Visual Basic]

[C++]

The SessionsMonitors property gets an FPCSessionsMonitors object that provides access to the firewall and the ISA Server Web proxy session monitors for the array.

HRESULT get_SessionsMonitors(
  IFPCSessionsMonitors** ppSessionsMonitors
);

Parameters

ppSessionsMonitors
Address of an interface pointer that on return points to an IFPCSessionsMonitors interface that provides access to the firewall and ISA Server Web proxy session monitors.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The SessionsMonitors property gets an FPCSessionsMonitors object that provides access to the firewall and the ISA Server Web proxy session monitors for the array.

Property SessionsMonitors As FPCSessionsMonitors

Property Value

Reference to the FPCSessionsMonitors object for the array.

Remarks

This property is read-only.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCArray


IFPCArray | FPCArray SystemPolicy(IFPCSystemPolicy) property [ISA Server 2004]

SystemPolicy Property of IFPCArray[C++]

FPCArray.SystemPolicy [Visual Basic]

[C++]

The SystemPolicy property gets an FPCSystemPolicy object that holds the system policy information for the array.

HRESULT get_SystemPolicy(
  IFPCSystemPolicy** ppSystemPolicy
);

Parameters

ppSystemPolicy
Address of an interface pointer that on return points to an IFPCSystemPolicy interface that represents the system policy information for the array.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The SystemPolicy property gets an FPCSystemPolicy object that holds the system policy information for the array.

Property SystemPolicy As FPCSystemPolicy

Property Value

Reference to an FPCSystemPolicy object.

Remarks

This property is read-only.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCArray


IFPCArray | FPCArray Type(FpcArrayType) property [ISA Server 2004]

Type Property of IFPCArray[C++]

FPCArray.Type [Visual Basic]

[C++]

The Type property gets a value from the FpcArrayType enumerated type that indicates whether the array consists of a single stand-alone server or multiple servers.

HRESULT get_Type(
  FpcArrayType* pType
);

Parameters

pType
Pointer to a variable that on return receives a value from the FpcArrayType enumerated type indicating whether the array consists of a single stand-alone server or multiple servers.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.
[Visual Basic]

The Type property gets a value from the FpcArrayType enumerated type that indicates whether the array consists of a single stand-alone server or multiple servers.

Property Type As FpcArrayType

Property Value

Value from the FpcArrayType enumerated type that indicates whether the array consists of a single stand-alone server or multiple servers.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCArray


FPCArrayPolicy object [ISA Server 2004]

FPCArrayPolicy

The FPCArrayPolicy object stores the topology of the ISA Server configuration. You can use this object to retrieve an array policy, which consists of the attack detection configuration, connection limit policy, policy rules, and Web proxy properties that are valid for the current FPCArray object.

The FPCArrayPolicy object is typically accessed through the ArrayPolicy property of an FPCArray object.

Click here to see the ISA Server object hierarchy.

Inheritance

This object inherits from the FPCPersist object, which contains methods and properties related to the persistent storage of an object's data. They include methods for exporting the object's data to and importing it from an XML document.

Methods

This object has no methods.

Properties

The FPCArrayPolicy object has the following properties.

Property | Description
AttackDetection | Gets an FPCAttackDetection object that specifies the attack detection configuration on the array.
ConnectionLimitPolicy | Gets an FPCConnectionLimitPolicy object that specifies the limits to the number of transport-layer protocol connections allowed at one time for default users and special users.
Description | Gets or sets the description of the array policy.
LowLevelSettings | Gets an FPCLowLevelSettings object that specifies the low-level settings in the array policy.
Name | Gets or sets the name of the array policy.
PolicyRules | Gets an FPCPolicyRules collection that contains all the policy rules on the array.
WebProxy | Gets the FPCWebProxy object that provides access to Web proxy properties.

Methods Inherited from FPCPersist

Name | Description
CancelWaitForChanges | Cancels the registration established by the WaitForChanges method (for use in C and C++ programming only).
CanImport | Returns a Boolean value that indicates whether the object's properties can be imported from the specified XML document.
Export | Recursively writes the stored values of all the properties of the object and its subobjects to the specified XML document.
ExportToFile | Recursively writes the stored values of all the properties of the object and its subobjects to the specified XML file.
GetServiceRestartMask | Retrieves a 32-bit bitmask of the FpcServices enumerated type that specifies which services need to be restarted for currently unsaved changes to take effect.
Import | Recursively copies the values of all the properties of the object and of its subobjects from the specified XML document to persistent storage.
ImportFromFile | Recursively copies the values of all the properties of the object and of its subobjects from the specified XML file to persistent storage.
LoadDocProperties | Provides the XML document's properties so that you can know what information can be imported from the document.
Refresh | Recursively reads the values of all the properties of the object and of its subobjects from persistent storage, overwriting any changes that have not been saved.
Save | Recursively writes the current values of all the properties of the object and its subobjects to persistent storage.
WaitForChanges | Registers to wait for an event indicating that the contents of the object have changed (for use in C and C++ programming only).

Properties Inherited from FPCPersist

Name | Description
PersistentName | Gets the persistent name of the object. The persistent name of an object is a name that is unique for the object at the respective level of the COM object hierarchy.
VendorParametersSets | Gets an FPCVendorParametersSets collection that can hold sets of custom data for extending the object.

Remarks

This object implements the IFPCArrayPolicy interface.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

COM Objects


IFPCArrayPolicy | FPCArrayPolicy AttackDetection property [ISA Server 2004]

AttackDetection Property of IFPCArrayPolicy[C++]

FPCArrayPolicy.AttackDetection [Visual Basic]

[C++]

The AttackDetection property gets the attack detection configuration on the array.

HRESULT get_AttackDetection(
  IFPCAttackDetection** ppAttackDetection
);

Parameters

ppAttackDetection
Address of an interface pointer that on return points to an IFPCAttackDetection interface that specifies the attack detection configuration on the array.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only. It can be modified by setting the properties of the IFPCAttackDetection interface retrieved.

[Visual Basic]

The AttackDetection property gets the attack detection configuration on the array.

Property AttackDetection As FPCAttackDetection

Property Value

Reference to an FPCAttackDetection object that specifies the attack detection configuration on the array.

Remarks

This property is read-only. It can be modified by setting the properties of the FPCAttackDetection object retrieved.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCArrayPolicy


IFPCArrayPolicy.ConnectionLimitPolicy (1 Parameter) property [ISA Server 2004]

ConnectionLimitPolicy Property of IFPCArrayPolicy[C++]

FPCArrayPolicy.ConnectionLimitPolicy [Visual Basic]

[C++]

The ConnectionLimitPolicy property gets an FPCConnectionLimitPolicy object that specifies the limits to the number of transport-layer protocol connections allowed at one time for default users and special users. Examples of transport-layer protocols are TCP and UDP.

HRESULT get_ConnectionLimitPolicy(
  IFPCConnectionLimitPolicy** ppConnectionLimitPolicy
);

Parameters

ppConnectionLimitPolicy
Address of an interface pointer that on return points to an IFPCConnectionLimitPolicy interface that represents the limits to the number of transport-layer protocol connections allowed at one time for default users and special users.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only. It can be modified by modifying the properties of the IFPCConnectionLimitPolicy interface.

The default limit for each transport-layer protocol is 160 connetions. In the case of UDP, the limit is on the number of connection mappings, rather than on the number of connections.

[Visual Basic]

The ConnectionLimitPolicy property gets an FPCConnectionLimitPolicy object that specifies the limits to the number of transport-layer protocol connections allowed at one time for default users and special users. Examples of transport-layer protocols are TCP and UDP.

Property ConnectionLimitPolicy As FPCConnectionLimitPolicy

Property Value

Reference to an FPCConnectionLimitPolicy object that specifies the limits to the number of transport-layer protocol connections allowed at one time for default users and special users.

Remarks

This property is read-only. It can be modified by modifying the properties of the FPCConnectionLimitPolicy object.

The default limit for each transport-layer protocol is 160 connetions. In the case of UDP, the limit is on the number of connection mappings, rather than on the number of connections.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCArrayPolicy


IFPCArrayPolicy | FPCArrayPolicy Description property [ISA Server 2004]

Description Property of IFPCArrayPolicy[C++]

FPCArrayPolicy.Description [Visual Basic]

[C++]

The Description property gets or sets the description of the access policy.

HRESULT get_Description(
  BSTR** pbstrDescription
);

HRESULT put_Description(
  BSTR bstrDescription
);

Parameters

pbstrDescription
Pointer to a BSTR that is set on return to a string value specifying the description of the access policy.
bstrDescription
BSTR that specifies the description of the access policy.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write.

[Visual Basic]

The Description property gets or sets the description of the access policy.

Property Description As String

Property Value

String that specifies the description of the access policy.

Remarks

This property is read/write.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCArrayPolicy


IFPCArrayPolicy | FPCArrayPolicy LowLevelSettings property [ISA Server 2004]

LowLevelSettings Property of IFPCArrayPolicy[C++]

FPCArrayPolicy.LowLevelSettings [Visual Basic]

[C++]

The LowLevelSettings property gets an FPCLowLevelSettings object that specifies the low-level settings in the array policy.

HRESULT get_LowLevelSettings(
  IFPCLowLevelSettings** ppLowLevelSettings
);

Parameters

ppLowLevelSettings
Address of an interface pointer that on return points to an IFPCLowLevelSettings interface that specifies the low-level settings in the array policy.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only. It can be modified by setting the properties of the IFPCLowLevelSettings interface retrieved.

[Visual Basic]

The LowLevelSettings property gets an FPCLowLevelSettings object that specifies the low-level settings in the array policy.

Property LowLevelSettings As FPCLowLevelSettings

Property Value

Reference to an FPCLowLevelSettings object that specifies the low-level settings in the array policy.

Remarks

This property is read-only. It can be modified by setting the properties of the FPCLowLevelSettings object retrieved.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCArrayPolicy


IFPCArrayPolicy | FPCArrayPolicy Name(BSTR,BSTR) property [ISA Server 2004]

Name Property of IFPCArrayPolicy[C++]

FPCArrayPolicy.Name [Visual Basic]

[C++]

The Name property gets or sets the name of the access policy.

HRESULT get_Name(
  BSTR** pbstrName
);

HRESULT put_Name(
  BSTR bstrName
);

Parameters

pbstrName
Pointer to a BSTR that is set on return to a string value specifying the name of the access policy.
bstrName
BSTR that specifies the name of the access policy.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write.

[Visual Basic]

The Name property gets or sets the name of the access policy.

Property Name As String

Property Value

String that specifies the name of the access policy.

Remarks

This property is read/write.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCArrayPolicy


IFPCArrayPolicy | FPCArrayPolicy PolicyRules property [ISA Server 2004]

PolicyRules Property of IFPCArrayPolicy[C++]

FPCArrayPolicy.PolicyRules [Visual Basic]

[C++]

The PolicyRules property gets an FPCPolicyRules collection that contains all the policy rules on the array.

HRESULT get_PolicyRules(
  IFPCPolicyRules** ppPolicyRules
);

Parameters

ppPolicyRules
Address of an interface pointer that on return points to an IFPCPolicyRules interface that represents the collection of all the policy rules on the array.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only. Policy rules can be added or removed, and their order of application can be modified by calling the methods of the IFPCPolicyRules interface.

[Visual Basic]

The PolicyRules property gets an FPCPolicyRules collection that contains all the policy rules on the array.

Property PolicyRules As FPCPolicyRules

Property Value

Reference to an FPCPolicyRules collection that contains all the policy rules on the array.

Remarks

This property is read-only. Policy rules can be added or removed, and their order of application can be modified by calling the methods of the FPCPolicyRules collection.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCArrayPolicy


IFPCArrayPolicy | FPCArrayPolicy WebProxy property [ISA Server 2004]

WebProxy Property of IFPCArrayPolicy[C++]

FPCArrayPolicy.WebProxy [Visual Basic]

[C++]

The WebProxy property gets an FPCWebProxy object that provides access to the properties of the Web proxy for the array.

HRESULT get_WebProxy(
  IFPCWebProxy** ppWebProxy
);

Parameters

ppWebProxy
Address of an interface pointer that on return points to an IFPCWebProxy interface that provides access to the properties of the Web proxy for the array.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The WebProxy property gets an FPCWebProxy object that provides access to the properties of the Web proxy for the array.

Property WebProxy As FPCWebProxy

Property Value

Reference to an FPCWebProxy object that provides access to the properties of the Web proxy for the array.

Remarks

This property is read-only.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCArrayPolicy


FPCArrays collection [ISA Server 2004]

FPCArrays Collection

The FPCArrays collection holds a set of FPCArray objects. Each ISA Server computer is associated with an FPCArray object that represents an ISA Server array and provides access to the configuration settings of the ISA Server computer. In ISA Server 2004 Standard Edition, this collection contains only one FPCArray object, which provides access to the configuration settings of a single ISA Server computer.

For multiple examples of using the FPCArrays collection, see ISA Server Administration Scripting.

The FPCArrays collection is typically accessed through the Arrays property of the FPC root object.

Click here to see the ISA Server object hierarchy.

Methods

The FPCArrays collection defines the following methods.

Method | Description
Connect | Connects to the array of the specified server, adds the FPCArray object to the collection, and returns a reference to the array object.
Disconnect | Disconnects from the specified array.
Item | Retrieves the requested FPCArray object from the collection.

Properties

The FPCArrays collection has the following properties.

Property | Description
_NewEnum | Gets an enumerator object for the collection.
Count | Gets the number of FPCArray objects in the collection.

Remarks

This collection implements the IFPCArrays interface.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

COM Objects


IFPCArrays | FPCArrays _NewEnum(IUnknown) property [ISA Server 2004]

_NewEnum Property of IFPCArrays[C++]

FPCArrays._NewEnum [Visual Basic]

[C++]

The _NewEnum property gets an enumerator object for the collection. An enumerator object provides serial access to the elements of the collection.

HRESULT get__NewEnum(
  IUnknown* ppEnum
);

Parameters

ppEnum
Address of an interface pointer that on return points to the IUnknown interface of an enumerator object that implements an IEnumVARIANT interface for the collection. An interface pointer to the IEnumVARIANT interface of the enumerator object can be retrieved by calling QueryInterface on the IUnknown interface returned.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The _NewEnum property gets an enumerator object for the collection. An enumerator object provides serial access to the elements of the collection.

Property _NewEnum As IUnknown

Property Value

Reference to an enumerator object that provides serial access to the elements of the collection.

Remarks

This property is read-only.

In Visual Basic and VBScript, this property is used implicitly in For Each...In...Next constructs.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCArrays


IFPCArrays | FPCArrays Connect (5 Parameters) method [ISA Server 2004]

IFPCArrays::Connect[C++]

FPCArrays.Connect [Visual Basic]

[C++]

The Connect method connects to the array of the specified server, adds the FPCArray object to the collection, and returns a reference to the array object.

HRESULT Connect(
  BSTR Server,
  BSTR UserName,
  BSTR Domain,
  BSTR Password,
  IFPCArray** ppArray
);

Parameters

Server
[in] BSTR that specifies the server to which to connect.
UserName
[in, optional] BSTR that specifies the user name. The default value is an empty BSTR.
Domain
[in, optional] BSTR that specifies the name of the user's domain. The default value is an empty BSTR.
Password
[in, optional] BSTR that specifies the password. The default value is an empty BSTR.
ppArray
[out] Address of an interface pointer that on return points to an IFPCArray interface that represents the array of the specified server.

Return Values

This method can return one of the following:

  • S_OK, indicating that the operation succeeded.
  • An error code, indicating that the operation failed. In this case, the [out] parameter returned is a null object.

[Visual Basic]

The Connect method connects to the array of the specified server, adds the FPCArray object to the collection, and returns a reference to the array object.

Function Connect( _
  ByVal Server As String, _
  [ ByVal UserName As String ], _
  [ ByVal Domain As String ], _
  [ ByVal Password As String ] _
) As FPCArray

Parameters

Server
[in] String that specifies the server to which to connect.
UserName
[in, optional] String that specifies the user name. The default value is an empty string.
Domain
[in, optional] String that specifies the name of the user's domain. The default value is an empty string.
Password
[in, optional] String that specifies the password. The default value is an empty string.

Return Values

This method returns a reference to the FPCArray object requested if successful. Otherwise, an error is raised that can be intercepted by using an error handler.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCArrays


IFPCArrays | FPCArrays Count(long) property [ISA Server 2004]

Count Property of IFPCArrays[C++]

FPCArrays.Count [Visual Basic]

[C++]

The Count property gets the number of FPCArray objects in the collection.

HRESULT get_Count(
  long* plCount
);

Parameters

plCount
Pointer to a variable that on return receives a 32-bit integer specifying the number of FPCArray objects in the collection.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The Count property gets the number of FPCArray objects in the collection.

Property Count As Long

Property Value

A 32-bit integer value that specifies the number of FPCArray objects in the collection.

Remarks

This property is read-only.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCArrays


IFPCArrays | FPCArrays Disconnect(IFPCArray) method [ISA Server 2004]

IFPCArrays::Disconnect[C++]

FPCArrays.Disconnect [Visual Basic]

[C++]

The Disconnect method disconnects from the specified array.

HRESULT Disconnect(
  FPCArray pItem
);

Parameters

pItem
[in] Required. Pointer to an IFPCArray interface that represents the array from which to disconnect.

Return Values

The method can return one of the following:

  • S_OK, indicating that the operation succeeded.
  • E_DISCONNECT_CONTAINING_ARRAY, indicating that an attempt was made to disconnect the ISA Server computer from its containing array.
  • An error code indicating that the operation failed.

Remarks

This method cannot be used to disconnect an ISA Server computer from its containing array.

[Visual Basic]

The Disconnect method disconnects from the specified array.

Sub Disconnect( _
  ByVal pItem As IFPCArray _
)

Parameters

pItem
[in] Required. Reference to an FPCArray object that represents the array from which to disconnect.

Return Values

This method has no return values. If the call is unsuccessful, an error is raised that can be intercepted by using an error handler. In particular, an E_DISCONNECT_CONTAINING_ARRAY error is raised when an attempt is made to disconnect an ISA Server computer from its containing array.

Remarks

This method cannot be used to disconnect an ISA Server computer from its containing array.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCArrays


IFPCArrays | FPCArrays Item(Variant,IFPCArray) method [ISA Server 2004]

IFPCArrays::Item[C++]

FPCArrays.Item [Visual Basic]

[C++]

The Item method retrieves the requested IFPCArray interface from the collection.

HRESULT Item(
  VARIANT Index,
  IFPCArray** ppItem
);

Parameters

Index
[in] Required. Name or one-based index of the object to retrieve.
ppItem
[out] Address of an interface pointer that on return points to the IFPCArray interface requested.

Return Values

The method can return one of the following:

  • S_OK, indicating that the operation succeeded.
  • An error code, indicating that the operation failed. In this case, the [out] parameter returned is a null object.

[Visual Basic]

The Item method retrieves the requested FPCArray object from the collection.

Function Item( _
  ByVal Index As Variant _
) As FPCArray

Parameters

Index
[in] Required. Name or one-based index of the object to retrieve.

Return Values

This method returns a reference to the FPCArray object requested if successful. Otherwise, an error is raised that can be intercepted by using an error handler.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCArrays


FPCAttackDetection object [ISA Server 2004]

FPCAttackDetection

The FPCAttackDetection object represents the attack detection configuration on an array and specifies the types of attacks that ISA Server is configured to detect.

This object is typically accessed through the AttackDetection property of an FPCArrayPolicy object.

Click here to see the ISA Server object hierarchy.

Inheritance

This object inherits from the FPCPersist object, which contains methods and properties related to the persistent storage of an object's data. They include methods for exporting the object's data to and importing it from an XML document.

Methods

This object has no methods.

Properties

The FPCAttackDetection object has the following properties.

Property | Description
IntrusionDetectionEnabled | Gets or sets a Boolean value that indicates whether intrusion detection is enabled.
IntrusionDetectionLoggingEnabled | Gets or sets a Boolean value that indicates whether intrusion detection logging is enabled.
IpFragmentsFilteringEnabled | Gets or sets a Boolean value that indicates whether Internet Protocol (IP) fragment filters are enabled.
IpHalfScanDetectionEnabled | Gets or sets a Boolean value that indicates whether IP half-scan attacks are detected and generate an alert.
IpOptions | Gets an FPCIpOptions object that enables configuration of the IP options checking mechanism.
IpRoutingEnabled | Gets or sets a Boolean value that indicates whether IP routing is enabled.
LandAttackDetectionEnabled | Gets or sets a Boolean value that indicates whether land attacks are detected and generate an alert.
PingOfDeathDetectionEnabled | Gets or sets a Boolean value that indicates whether ping-of-death attacks are detected and generate an alert.
PortScanDetectionAllPortsThreshold | If the detection of port scan attacks is enabled, this property gets or sets the total number of ports that can be scanned before ISA Server generates an alert.
PortScanDetectionEnabled | Gets or sets a Boolean value that indicates whether port scan attacks are detected and generate an alert.
PortScanDetectionWellKnownPortsThreshold | If the detection of port scan attacks is enabled, this property gets or sets the total number of well-known ports that can be scanned before ISA Server generates an alert.
UdpBombDetectionEnabled | Gets or sets a Boolean value that indicates whether User Datagram Protocol (UDP) bomb attacks are detected and generate an alert.
WinOutOfBandDetectionEnabled | Gets or sets a Boolean value that indicates whether Windows out-of-band attacks are detected and generate an alert.

Methods Inherited from FPCPersist

Name | Description
CancelWaitForChanges | Cancels the registration established by the WaitForChanges method (for use in C and C++ programming only).
CanImport | Returns a Boolean value that indicates whether the object's properties can be imported from the specified XML document.
Export | Writes the stored values of all of the object's properties to the specified XML document.
ExportToFile | Writes the stored values of all of the object's properties to the specified XML file.
GetServiceRestartMask | Retrieves a 32-bit bitmask of the FpcServices enumerated type that specifies which services need to be restarted for currently unsaved changes to take effect.
Import | Copies the values of all of the object's properties from the specified XML document to persistent storage.
ImportFromFile | Copies the values of all of the object's properties from the specified XML file to persistent storage.
LoadDocProperties | Provides the XML document's properties so that you can know what information can be imported from the document.
Refresh | Reads the values of all of the object's properties from persistent storage, overwriting any changes that have not been saved.
Save | Writes the current values of all of the object's properties to persistent storage.
WaitForChanges | Registers to wait for an event indicating that the contents of the object have changed (for use in C and C++ programming only).

Properties Inherited from FPCPersist

Name | Description
PersistentName | Gets the persistent name of the object. The persistent name of an object is a name that is unique for the object at the respective level of the COM object hierarchy.
VendorParametersSets | Gets an FPCVendorParametersSets object that can hold sets of custom data for extending the object.

Remarks

This object implements the IFPCAttackDetection interface.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

COM Objects


IFPCAttackDetection.IntrusionDetectionLoggingEnabled property [ISA Server 2004]

IntrusionDetectionLoggingEnabled Property of IFPCAttackDetection[C++]

FPCAttackDetection.IntrusionDetectionLoggingEnabled [Visual Basic]

[C++]

The IntrusionDetectionLoggingEnabled property gets or sets a Boolean value that indicates whether intrusion detection logging is enabled.

HRESULT get_IntrusionDetectionLoggingEnabled(
  VARIANT_BOOL* pfIntrusionDetectionLoggingEnabled
);

HRESULT put_IntrusionDetectionLoggingEnabled(
  VARIANT_BOOL fIntrusionDetectionLoggingEnabled
);

Parameters

pfIntrusionDetectionLoggingEnabled
Pointer to a Boolean variable that is set on return to VARIANT_TRUE if intrusion detection logging is enabled, or to VARIANT_FALSE if intrusion detection logging is disabled.
fIntrusionDetectionLoggingEnabled
Boolean value that indicates whether intrusion detection logging is enabled.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write.

ISA Server features intrusion detection, which identifies when an attack is attempted against your network, and then performs a set of configured actions, or alerts, in case of an attack.

[Visual Basic]

The IntrusionDetectionLoggingEnabled property gets or sets a Boolean value that indicates whether intrusion detection logging is enabled.

Property IntrusionDetectionLoggingEnabled As Boolean

Property Value

Boolean value that indicates whether intrusion detection logging is enabled.

Remarks

This property is read/write.

ISA Server features intrusion detection, which identifies when an attack is attempted against your network, and then performs a set of configured actions, or alerts, in case of an attack.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCAttackDetection


IFPCAttackDetection.IntrusionDetectionEnabled property [ISA Server 2004]

IntrusionDetectionEnabled Property of IFPCAttackDetection[C++]

FPCAttackDetection.IntrusionDetectionEnabled [Visual Basic]

[C++]

The IntrusionDetectionEnabled property gets or sets a Boolean value that indicates whether intrusion detection is enabled.

HRESULT get_IntrusionDetectionEnabled(
  VARIANT_BOOL* pfIntrusionDetectionEnabled
);

HRESULT put_IntrusionDetectionEnabled(
  VARIANT_BOOL fIntrusionDetectionEnabled
);

Parameters

pfIntrusionDetectionEnabled
Pointer to a Boolean variable that is set on return to VARIANT_TRUE if intrusion detection is enabled or to VARIANT_FALSE if intrusion detection is disabled.
fIntrusionDetectionEnabled
Boolean value that indicates whether intrusion detection is enabled.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write.

ISA Server features intrusion detection, which identifies when an attack is attempted against your network, and then performs a set of configured actions, or alerts, in case of an attack.

[Visual Basic]

The IntrusionDetectionEnabled property gets or sets a Boolean value that indicates whether intrusion detection is enabled.

Property IntrusionDetectionEnabled As Boolean

Property Value

Boolean value that indicates whether intrusion detection is enabled.

Remarks

This property is read/write.

ISA Server features intrusion detection, which identifies when an attack is attempted against your network, and then performs a set of configured actions, or alerts, in case of an attack.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCAttackDetection


IFPCAttackDetection.IpFragmentsFilteringEnabled property [ISA Server 2004]

IpFragmentsFilteringEnabled Property of IFPCAttackDetection[C++]

FPCAttackDetection.IpFragmentsFilteringEnabled [Visual Basic]

[C++]

The IpFragmentsFilteringEnabled property gets or sets a Boolean value that indicates whether IP fragment filtering is enabled. If IP fragment filtering is enabled, datagram fragments are filtered.

HRESULT get_IpFragmentsFilteringEnabled(
  VARIANT_BOOL* pfFragmentsFilteringEnabled
);

HRESULT put_IpFragmentsFilteringEnabled(
  VARIANT_BOOL fFragmentsFilteringEnabled
);

Parameters

pfFragmentsFilteringEnabled
Pointer to a Boolean value that is set on return to VARIANT_TRUE if IP fragment filtering is enabled, or to VARIANT_FALSE if IP fragment filtering is disabled.
fFragmentsFilteringEnabled
Boolean value that indicates whether IP fragment filtering is enabled.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write.

[Visual Basic]

The IpFragmentsFilteringEnabled property gets or sets a Boolean value that indicates whether IP fragment filtering is enabled. If IP fragment filtering is enabled, datagram fragments are filtered.

Property IpFragmentsFilteringEnabled As Boolean

Property Value

Boolean value that indicates whether IP fragment filtering is enabled.

Remarks

This property is read/write.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCAttackDetection


IFPCAttackDetection.IpHalfScanDetectionEnabled property [ISA Server 2004]

IpHalfScanDetectionEnabled Property of IFPCAttackDetection[C++]

FPCAttackDetection.IpHalfScanDetectionEnabled [Visual Basic]

[C++]

The IpHalfScanDetectionEnabled property gets or sets a Boolean value that indicates whether Internet Protocol (IP) half-scan attacks are detected and generate an alert.

HRESULT get_IpHalfScanDetectionEnabled(
  VARIANT_BOOL* pfIpHalfScanDetectionEnabled
);

HRESULT put_IpHalfScanDetectionEnabled(
  VARIANT_BOOL fIpHalfScanDetectionEnabled
);

Parameters

pfIpHalfScanDetectionEnabled
Pointer to a Boolean value that is set on return to VARIANT_TRUE if the detection of IP half-scan attacks is enabled, or to VARIANT_FALSE if the detection of IP half-scan attacks is disabled.
fIpHalfScanDetectionEnabled
Boolean value that indicates whether the detection of IP half-scan attacks is enabled.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write.

[Visual Basic]

The IpHalfScanDetectionEnabled property gets or sets a Boolean value that indicates whether Internet Protocol (IP) half-scan attacks are detected and generate an alert.

Property IpHalfScanDetectionEnabled As Boolean

Property Value

Boolean value that indicates whether the detection of IP half-scan attacks is enabled.

Remarks

This property is read/write.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCAttackDetection


IFPCAttackDetection | FPCAttackDetection IpOptions property [ISA Server 2004]

IpOptions Property of IFPCAttackDetection[C++]

FPCAttackDetection.IpOptions [Visual Basic]

[C++]

The IpOptions property gets an IFPCIpOptions interface that enables configuration of the IP options checking mechanism.

HRESULT get_IpOptions(
  IFPCIpOptions** ppIpOptions
);

Parameters

ppIpOptions
Address of an interface pointer that on return points to an IFPCIpOptions interface.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read-only. The IFPCIpOptions interface retrieved enables configuration of the IP options checking mechanism.

[Visual Basic]

The IpOptions property gets an FPCIpOptions object that enables configuration of the IP options checking mechanism.

Property IpOptions As FPCIpOptions

Property Value

Reference to an FPCIpOptions object.

Remarks

This property is read-only. The FPCIpOptions object retrieved enables configuration of the IP options checking mechanism.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCAttackDetection


IFPCAttackDetection.IpRoutingEnabled (2 Parameters) property [ISA Server 2004]

IpRoutingEnabled Property of IFPCAttackDetection[C++]

FPCAttackDetection.IpRoutingEnabled [Visual Basic]

[C++]

The IpRoutingEnabled property gets or sets a Boolean value that indicates whether Internet Protocol (IP) routing is enabled.

HRESULT get_IpRoutingEnabled(
  VARIANT_BOOL* pfIpRoutingEnabled
);

HRESULT put_IpRoutingEnabled(
  VARIANT_BOOL fIpRoutingEnabled
);

Parameters

pfIpRoutingEnabled
Pointer to a Boolean value that is set on return to VARIANT_TRUE if IP routing is enabled, or to VARIANT_FALSE if IP routing is disabled.
fIpRoutingEnabled
Boolean value that indicates whether IP routing is enabled.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write.

When IP routing is enabled, the ISA Server computer acts as a router, forwarding packets from the source to the destination. Some filtering is performed by the driver in user mode on the traffic being forwarded. When IP routing is disabled, ISA Server copies each packet, and then resends it through the driver in user mode. Only the data (and not the original network packet) is sent to the destination. Although IP routing improves performance, disabling IP routing is considered more secure.

[Visual Basic]

The IpRoutingEnabled property gets or sets a Boolean value that indicates whether Internet Protocol (IP) routing is enabled.

Property IpRoutingEnabled As Boolean

Property Value

Boolean value that indicates whether IP routing is enabled.

Remarks

This property is read/write.

When IP routing is enabled, the ISA Server computer acts as a router, forwarding packets from the source to the destination. Some filtering is performed by the driver in user mode on the traffic being forwarded. When IP routing is disabled, ISA Server copies each packet, and then resends it through the driver in user mode. Only the data (and not the original network packet) is sent to the destination. Although IP routing improves performance, disabling IP routing is considered more secure.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCAttackDetection


IFPCAttackDetection.LandAttackDetectionEnabled property [ISA Server 2004]

LandAttackDetectionEnabled Property of IFPCAttackDetection[C++]

FPCAttackDetection.LandAttackDetectionEnabled [Visual Basic]

[C++]

The LandAttackDetectionEnabled property gets or sets a Boolean value that indicates whether land attacks are detected and generate an alert.

A land attack is one in which a Transmission Control Protocol (TCP) SYN packet is sent with a spoofed source IP address that matches the destination IP address of the ISA Server computer and with a port number that is allowed by the ISA Server rules so that the ISA Server computer will try to establish a TCP session with itself. If the attack succeeds, the computer enters a closed loop and must be restarted.

HRESULT get_LandAttackDetectionEnabled(
  VARIANT_BOOL* pfLandAttackDetectionEnabled
);

HRESULT put_LandAttackDetectionEnabled(
  VARIANT_BOOL fLandAttackDetectionEnabled
);

Parameters

pfLandAttackDetectionEnabled
Pointer to a Boolean value that is set on return to VARIANT_TRUE if the detection of land attacks is enabled, or to VARIANT_FALSE if the detection of land attacks is disabled.
fLandAttackDetectionEnabled
Boolean value that indicates whether the detection of land attacks is enabled.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write.

[Visual Basic]

The LandAttackDetectionEnabled property gets or sets a Boolean value that indicates whether land attacks are detected and generate an alert.

A land attack is one in which a Transmission Control Protocol (TCP) SYN packet is sent with a spoofed source IP address that matches the destination IP address of the ISA Server computer and with a port number that is allowed by the ISA Server rules so that the ISA Server computer will try to establish a TCP session with itself. If the attack succeeds, the computer enters a closed loop and must be restarted.

Property LandAttackDetectionEnabled As Boolean

Property Value

Boolean value that indicates whether the detection of land attacks is enabled.

Remarks

This property is read/write.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCAttackDetection


IFPCAttackDetection.PingOfDeathDetectionEnabled property [ISA Server 2004]

PingOfDeathDetectionEnabled Property of IFPCAttackDetection[C++]

FPCAttackDetection.PingOfDeathDetectionEnabled [Visual Basic]

[C++]

The PingOfDeathDetectionEnabled property gets or sets a Boolean value that indicates whether ISA Server will detect ping-of-death attacks and generate an alert.

A ping-of-death attack is one in which a large amount of information is appended to an Internet Control Message Protocol (ICMP) echo request (ping) packet.

HRESULT get_PingOfDeathDetectionEnabled(
  VARIANT_BOOL* pfPingOfDeathDetectionEnabled
);

HRESULT put_PingOfDeathDetectionEnabled(
  VARIANT_BOOL fPingOfDeathDetectionEnabled
);

Parameters

pfPingOfDeathDetectionEnabled
Pointer to a Boolean value that is set on return to VARIANT_TRUE if the detection of ping-of-death attacks is enabled, or to VARIANT_FALSE if the detection of ping-of-death attacks is disabled.
fPingOfDeathDetectionEnabled
Boolean value that indicates whether the detection of ping-of-death attacks is enabled.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write.

[Visual Basic]

The PingOfDeathDetectionEnabled property gets or sets a Boolean value that indicates whether ISA Server will detect ping-of-death attacks and generate an alert.

A ping-of-death attack is one in which a large amount of information is appended to an Internet Control Message Protocol (ICMP) echo request (ping) packet.

Property PingOfDeathDetectionEnabled As Boolean

Property Value

Boolean value that indicates whether detection of ping-of-death attacks is enabled.

Remarks

This property is read/write.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCAttackDetection


PortScanDetectionAllPortsThreshold property [ISA Server 2004]

PortScanDetectionAllPortsThreshold Property of IFPCAttackDetection[C++]

FPCAttackDetection.PortScanDetectionAllPortsThreshold [Visual Basic]

[C++]

The PortScanDetectionAllPortsThreshold property gets or sets, if the detection of port scan attacks is enabled, the total number of ports that can be scanned before ISA Server generates an alert.

HRESULT get_PortScanDetectionAllPortsThreshold(
  long* plPortThreshold
);

HRESULT put_PortScanDetectionAllPortsThreshold(
  long lPortThreshold
);

Parameters

plPortThreshold
Pointer to a variable that on return receives a 32-bit integer specifying the number of ports that can be scanned before an alert is generated.
lPortThreshold
A 32-bit integer that specifies the number of ports that can be scanned before an alert is generated.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write.

[Visual Basic]

The PortScanDetectionAllPortsThreshold property gets or sets, if the detection of port scan attacks is enabled, the total number of ports that can be scanned before ISA Server generates an alert.

Property PortScanDetectionAllPortsThreshold As Long

Property Value

A 32-bit integer that specifies the number of ports that can be scanned before an alert is generated.

Remarks

This property is read/write.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCAttackDetection


IFPCAttackDetection.PortScanDetectionEnabled property [ISA Server 2004]

PortScanDetectionEnabled Property of IFPCAttackDetection[C++]

FPCAttackDetection.PortScanDetectionEnabled [Visual Basic]

[C++]

The PortScanDetectionEnabled property gets or sets a Boolean value that indicates whether port scan attacks are detected and generate an alert.

A port scan attack is one in which an attempt is made to scan ports on a computer to detect services running on those ports.

HRESULT get_PortScanDetectionEnabled(
  VARIANT_BOOL* pfPortScanDetectionEnabled
);

HRESULT put_PortScanDetectionEnabled(
  VARIANT_BOOL fPortScanDetectionEnabled
);

Parameters

pfPortScanDetectionEnabled
Pointer to a Boolean value that is set on return to VARIANT_TRUE if the detection of port scan attacks is enabled, or to VARIANT_FALSE if the detection of port scan attacks is disabled.
fPortScanDetectionEnabled
Boolean value that indicates whether the detection of port scan attacks is enabled.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write.

[Visual Basic]

The PortScanDetectionEnabled property gets or sets a Boolean value that indicates whether port scan attacks are detected and generate an alert.

A port scan attack is one in which an attempt is made to scan ports on a computer to detect services running on those ports.

Property PortScanDetectionEnabled As Boolean

Property Value

Boolean value that indicates whether the detection of port scan attacks is enabled.

Remarks

This property is read/write.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCAttackDetection


PortScanDetectionWellKnownPortsThreshold property [ISA Server 2004]

PortScanDetectionWellKnownPortsThreshold Property of IFPCAttackDetection[C++]

FPCAttackDetection.PortScanDetectionWellKnownPortsThreshold [Visual Basic]

[C++]

The PortScanDetectionWellKnownPortsThreshold property gets or sets, if the detection of port scan attacks is enabled, the total number of well-known ports that can be scanned before ISA Server generates an alert.

HRESULT get_PortScanDetectionWellKnownPortsThreshold(
  long* plWellKnownThreshold
);

HRESULT put_PortScanDetectionWellKnownPortsThreshold(
  long lWellKnownThreshold
);

Parameters

plWellKnownThreshold
Pointer to a variable that on return receives a 32-bit integer specifying the number of well-known ports that can be scanned before an alert is generated.
lWellKnownThreshold
A 32-bit integer that specifies the number of well-known ports that can be scanned before an alert is generated.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write.

[Visual Basic]

The PortScanDetectionWellKnownPortsThreshold property gets or sets, if the detection of port scan attacks is enabled, the total number of well-known ports that can be scanned before ISA Server generates an alert.

Property PortScanDetectionWellKnownPortsThreshold As Long

Property Value

A 32-bit integer that specifies the number of well-known ports that can be scanned before an alert is generated.

Remarks

This property is read/write.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCAttackDetection


IFPCAttackDetection.UdpBombDetectionEnabled property [ISA Server 2004]

UdpBombDetectionEnabled Property of IFPCAttackDetection[C++]

FPCAttackDetection.UdpBombDetectionEnabled [Visual Basic]

[C++]

The UdpBombDetectionEnabled property gets or sets a Boolean value that indicates whether ISA Server will detect User Datagram Protocol (UDP) bomb attacks and generate an alert.

A UDP bomb attack is one in which an attempt is made to send an illegal UDP packet.

HRESULT get_UdpBombDetectionEnabled(
  VARIANT_BOOL* pfUdpBombDetectionEnabled
);

HRESULT put_UdpBombDetectionEnabled(
  VARIANT_BOOL fUdpBombDetectionEnabled
);

Parameters

pfUdpBombDetectionEnabled
Pointer to a Boolean value that is set on return to VARIANT_TRUE if the detection of UDP bomb attacks is enabled, or to VARIANT_FALSE if the detection of UDP bomb attacks is disabled.
fUdpBombDetectionEnabled
Boolean value that indicates whether the detection of UDP bomb attacks is enabled.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write.

[Visual Basic]

The UdpBombDetectionEnabled property gets or sets a Boolean value that indicates whether ISA Server will detect User Datagram Protocol (UDP) bomb attacks and generate an alert.

A UDP bomb attack is one in which an attempt is made to send an illegal UDP packet.

Property UdpBombDetectionEnabled As Boolean

Property Value

Boolean value that indicates whether the detection of UDP bomb attacks is enabled.

Remarks

This property is read/write.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCAttackDetection


IFPCAttackDetection.WinOutOfBandDetectionEnabled property [ISA Server 2004]

WinOutOfBandDetectionEnabled Property of IFPCAttackDetection[C++]

FPCAttackDetection.WinOutOfBandDetectionEnabled [Visual Basic]

[C++]

The WinOutOfBandDetectionEnabled property gets or sets a Boolean value that indicates whether ISA Server will detect Windows out-of-band attacks and generate an alert.

HRESULT get_WinOutOfBandDetectionEnabled(
  VARIANT_BOOL* pfWinOutOfBandDetectionEnabled
);

HRESULT put_WinOutOfBandDetectionEnabled(
  VARIANT_BOOL fWinOutOfBandDetectionEnabled
);

Parameters

pfWinOutOfBandDetectionEnabled
Pointer to a Boolean value that is set on return to VARIANT_TRUE if the detection of Windows out-of-band attacks is enabled, or to VARIANT_FALSE if the detection of Windows out-of-band attacks is disabled.
fWinOutOfBandDetectionEnabled
Boolean value that indicates whether the detection of Windows out-of-band attacks is enabled.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write.

[Visual Basic]

The WinOutOfBandDetectionEnabled property gets or sets a Boolean value that indicates whether ISA Server will detect Windows out-of-band attacks and generate an alert.

Property WinOutOfBandDetectionEnabled As Boolean

Property Value

Boolean value that indicates whether the detection of Windows out-of-band attacks is enabled.

Remarks

This property is read/write.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCAttackDetection


FPCAuthenticationScheme object [ISA Server 2004]

FPCAuthenticationScheme

The FPCAuthenticationScheme object represents an authentication scheme. An authentication scheme can be added to ISA Server with a Web filter. Web filter registration should include registration of all the authentication schemes that the filter supports. Web filters register authentication schemes using the FPCAuthenticationSchemes.Add method.

This object is typically an element of an FPCAuthenticationSchemes collection.

Click here to see the ISA Server object hierarchy.

Inheritance

This object inherits from the FPCPersist object, which contains methods and properties related to the persistent storage of an object's data. They include methods for exporting an object's data to and importing it from XML documents.

Methods

This object has no methods.

Properties

The FPCAuthenticationScheme object has the following properties.

Property | Description
Description | Gets or sets the description of the authentication scheme.
Namespace | Gets or sets the namespace of the authentication scheme.
Predefined | Gets a Boolean value that indicates whether the authentication scheme is predefined.
Provides | Gets or sets a value from the FpcAuthenticationSchemeProvides enumerated type that specifies whether the authentication scheme provides a user namespace and whether the authentication scheme provides an authentication method.
Services | Gets or sets a value from the FpcServiceTypes enumerated type that specifies which services can use the authentication scheme.
Vendor | Gets or sets the name of the vendor that supplied the authentication scheme.
Version | Gets or sets the version of the authentication scheme.

Methods Inherited from FPCPersist

Name | Description
CancelWaitForChanges | Cancels the registration established by the WaitForChanges method (for use in C and C++ programming only).
CanImport | Returns a Boolean value that indicates whether the object's properties can be imported from the specified XML document.
Export | Writes the stored values of all of the object's properties to the specified XML document.
ExportToFile | Writes the stored values of all of the object's properties to the specified XML file.
GetServiceRestartMask | Retrieves a 32-bit bitmask of the FpcServices enumerated type that specifies which services need to be restarted for currently unsaved changes to take effect.
Import | Copies the values of all of the object's properties from the specified XML document to persistent storage.
ImportFromFile | Copies the values of all of the object's properties from the specified XML file to persistent storage.
LoadDocProperties | Provides the XML document's properties so that you can know what information can be imported from the document.
Refresh | Reads the values of all of the object's properties from persistent storage, overwriting any changes that have not been saved.
Save | Writes the current values of all of the object's properties to persistent storage.
WaitForChanges | Registers to wait for an event indicating that the contents of the object have changed (for use in C and C++ programming only).

Properties Inherited from FPCPersist

Name | Description
PersistentName | Gets the persistent name of the object. The persistent name of an object is a name that is unique for the object at the respective level of the COM object hierarchy.
VendorParametersSets | Gets an FPCVendorParametersSets object that can hold sets of custom data for extending the object.

Remarks

This object implements the IFPCAuthenticationScheme interface.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

COM Objects


IFPCAuthenticationScheme.Description(BSTR,BSTR) property [ISA Server 2004]

Description Property of IFPCAuthenticationScheme[C++]

FPCAuthenticationScheme.Description [Visual Basic]

[C++]

The Description property gets or sets the description of the authentication scheme.

HRESULT get_Description(
  BSTR* pbstrDescription
);

HRESULT put_Description(
  BSTR bstrDescription
);

Parameters

pbstrDescription
Pointer to a BSTR that is set on return to a string value specifying the description of the authentication scheme.
bstrDescription
BSTR that specifies the description of the authentication scheme.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write.

[Visual Basic]

The Description property gets or sets the description of the authentication scheme.

Property Description As String

Property Value

String that specifies the description of the authentication scheme.

Remarks

This property is read/write.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCAuthenticationScheme


IFPCAuthenticationScheme.Namespace(BSTR,BSTR) property [ISA Server 2004]

Namespace Property of IFPCAuthenticationScheme[C++]

FPCAuthenticationScheme.Namespace [Visual Basic]

[C++]

The Namespace property gets or sets the namespace of the authentication scheme. The namespace specifies the type of authentication.

HRESULT get_Namespace(
  BSTR* pbstrNamespace
);

HRESULT put_Namespace(
  BSTR bstrNamespace
);

Parameters

pbstrNamespace
Pointer to a BSTR that is set on return to a string value specifying the namespace of the authentication scheme.
bstrNamespace
BSTR that specifies the namespace of the authentication scheme.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write.

[Visual Basic]

The Namespace property gets or sets the namespace of the authentication scheme. The namespace specifies the type of authentication.

Property Namespace As String

Property Value

String that specifies the namespace of the authentication scheme.

Remarks

This property is read/write.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCAuthenticationScheme


IFPCAuthenticationScheme.Predefined(VARIANT_BOOL) property [ISA Server 2004]

Predefined Property of IFPCAuthenticationScheme[C++]

FPCAuthenticationScheme.Predefined [Visual Basic]

[C++]

The Predefined property gets a Boolean value that indicates whether the authentication scheme is predefined. A predefined authentication scheme is installed with ISA Server and cannot be deleted.

HRESULT get_Predefined(
  VARIANT_BOOL* pfPredefined
);

Parameters

pfPredefined
Pointer to a Boolean variable that is set on return to VARIANT_TRUE if the authentication scheme is predefined, or to VARIANT_FALSE if the authentication scheme is not predefined.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The Predefined property gets a Boolean value that indicates whether the authentication scheme is predefined. A predefined authentication scheme is installed with ISA Server and cannot be deleted.

Property Predefined As Boolean

Property Value

Boolean value that indicates whether the authentication scheme is predefined.

Remarks

This property is read-only.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCAuthenticationScheme


IFPCAuthenticationScheme.Provides (2 Parameters) property [ISA Server 2004]

Provides Property of IFPCAuthenticationScheme[C++]

FPCAuthenticationScheme.Provides [Visual Basic]

[C++]

The Provides property gets or sets a value from the FpcAuthenticationSchemeProvides enumerated type that specifies whether the authentication scheme provides a user namespace and whether the authentication scheme provides an authentication method.

HRESULT get_Provides(
  FpcAuthenticationSchemeProvides* pSchemeProvides
);

HRESULT put_Provides(
  FpcAuthenticationSchemeProvides SchemeProvides
);

Parameters

pSchemeProvides
Pointer to a variable that on return receives a value from the FpcAuthenticationSchemeProvides enumerated type specifying whether the authentication scheme provides a user namespace and whether the authentication scheme provides an authentication method.
SchemeProvides
Value from the FpcAuthenticationSchemeProvides enumerated type that specifies whether the authentication scheme provides a user namespace and whether the authentication scheme provides an authentication method.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write.

[Visual Basic]

The Provides property gets or sets a value from the FpcAuthenticationSchemeProvides enumerated type that specifies whether the authentication scheme provides a user namespace and whether the authentication scheme provides an authentication method.

Property Provides As FpcAuthenticationSchemeProvides

Property Value

Value from the FpcAuthenticationSchemeProvides enumerated type that specifies whether the authentication scheme provides a user namespace and whether the authentication scheme provides an authentication method.

Remarks

This property is read/write.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCAuthenticationScheme


IFPCAuthenticationScheme.Services (2 Parameters) property [ISA Server 2004]

Services Property of IFPCAuthenticationScheme[C++]

FPCAuthenticationScheme.Services [Visual Basic]

[C++]

The Services property gets or sets a value from the FpcServiceTypes enumerated type that specifies which services can use the authentication scheme.

HRESULT get_Services(
  FpcServiceTypes* pServiceType
);

HRESULT put_Services(
  FpcServiceTypes ServiceType
);

Parameters

pServiceType
Pointer to a variable that on return receives a value from the FpcServiceTypes enumerated type specifying which services can use the authentication scheme.
ServiceType
Value from the FpcServiceTypes enumerated type that specifies which services can use the authentication scheme.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write.

This property must be set to fpcServiceTypeWebProxyReverse, fpcServiceTypeWebProxyForward, or fpcServiceTypeWebProxyBoth when a Web filter registers the authentication scheme.

[Visual Basic]

The Services property gets or sets a value from the FpcServiceTypes enumerated type that specifies which services can use the authentication scheme.

Property Services As FpcServiceTypes

Property Value

Value from the FpcServiceTypes enumerated type that specifies which services can use the authentication scheme.

Remarks

This property is read/write.

This property must be set to fpcServiceTypeWebProxyReverse, fpcServiceTypeWebProxyForward, or fpcServiceTypeWebProxyBoth when a Web filter registers the authentication scheme.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCAuthenticationScheme


IFPCAuthenticationScheme.Vendor(BSTR,BSTR) property [ISA Server 2004]

Vendor Property of IFPCAuthenticationScheme[C++]

FPCAuthenticationScheme.Vendor [Visual Basic]

[C++]

The Vendor property gets or sets the name of the vendor that supplied the authentication scheme.

HRESULT get_Vendor(
  BSTR* pbstrVendor
);

HRESULT put_Vendor(
  BSTR bstrVendor
);

Parameters

pbstrVendor
Pointer to a BSTR that is set on return to a string value specifying the name of the vendor that supplied the authentication scheme.
bstrVendor
BSTR that specifies the name of the vendor that supplied the authentication scheme.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write.

[Visual Basic]

The Vendor property gets or sets the name of the vendor that supplied the authentication scheme.

Property Vendor As String

Property Value

String that specifies the name of the vendor that supplied the authentication scheme.

Remarks

This property is read/write.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCAuthenticationScheme


IFPCAuthenticationScheme.Version(BSTR,BSTR) property [ISA Server 2004]

Version Property of IFPCAuthenticationScheme[C++]

FPCAuthenticationScheme.Version [Visual Basic]

[C++]

The Version property gets or sets a string that specifies the version of the authentication scheme.

HRESULT get_Version(
  BSTR* pbstrVersion
);

HRESULT put_Version(
  BSTR bstrVersion
);

Parameters

pbstrVersion
Pointer to a BSTR that is set on return to a string value specifying the version of the authentication scheme.
bstrVersion
BSTR that specifies the version of the authentication scheme.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write.

[Visual Basic]

The Version property gets or sets a string that specifies the version of the authentication scheme.

Property Version As String

Property Value

String that specifies the version of the authentication scheme.

Remarks

This property is read/write.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCAuthenticationScheme


FPCAuthenticationSchemes collection [ISA Server 2004]

FPCAuthenticationSchemes Collection

The FPCAuthenticationSchemes collection holds a set of FPCAuthenticationScheme objects representing all of the authentication schemes that are defined for an FPCArray object and are available for use by Web listeners.

The FPCAuthenticationSchemes collection is typically accessed through the AuthenticationSchemes property of an FPCRuleElements object.

Click here to see the ISA Server object hierarchy.

Inheritance

This collection inherits from the FPCPersist object, which contains methods and properties related to the persistent storage of an object's data. They include methods for exporting the object's data to and importing it from an XML document.

Methods

The FPCAuthenticationSchemes collection defines the following methods.

Method | Description
Add | Creates a new FPCAuthenticationScheme object in the collection and returns a reference to it.
Item | Retrieves the requested FPCAuthenticationScheme object from the collection.
Remove | Removes the specified FPCAuthenticationScheme object from the collection.

Properties

The FPCAuthenticationSchemes collection has the following properties.

Property | Description
_NewEnum | Gets an enumerator object for the collection.
Count | Gets the number of FPCAuthenticationScheme objects in the collection.

Methods Inherited from FPCPersist

Name | Description
CancelWaitForChanges | Cancels the registration established by the WaitForChanges method (for use in C and C++ programming only).
CanImport | Returns a Boolean value that indicates whether the properties of the collection and its elements can be imported from the specified XML document.
Export | Writes the stored values of all the properties of the collection and its elements to the specified XML document.
ExportToFile | Writes the stored values of all the properties of the collection and its elements to the specified XML file.
GetServiceRestartMask | Retrieves a 32-bit bitmask of the FpcServices enumerated type that specifies which services need to be restarted for currently unsaved changes to take effect.
Import | Copies the values of all the properties of the collection and its elements from the specified XML document to persistent storage.
ImportFromFile | Copies the values of all the properties of the collection and its elements from the specified XML file to persistent storage.
LoadDocProperties | Provides the XML document's properties so that you can know what information can be imported from the document.
Refresh | Reads the values of all the properties of the collection and its elements from persistent storage, overwriting any changes that have not been saved.
Save | Writes the current values of all the properties of the collection and its elements to persistent storage.
WaitForChanges | Registers to wait for an event indicating that the contents of the object have changed (for use in C and C++ programming only).

Properties Inherited from FPCPersist

Name | Description
PersistentName | Gets the persistent name of the collection. The persistent name of an object is a name that is unique for the object at the respective level of the COM object hierarchy.
VendorParametersSets | Gets an FPCVendorParametersSets collection that can hold sets of custom data for extending the collection.

Remarks

This collection implements the IFPCAuthenticationSchemes interface.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

COM Objects


IFPCAuthenticationSchemes._NewEnum(IUnknown) property [ISA Server 2004]

_NewEnum Property of IFPCAuthenticationSchemes[C++]

FPCAuthenticationSchemes._NewEnum [Visual Basic]

[C++]

The _NewEnum property gets an enumerator object for the collection. An enumerator object provides serial access to the elements of the collection.

HRESULT get__NewEnum(
  IUnknown* ppEnum
);

Parameters

ppEnum
Address of an interface pointer that on return points to the IUnknown interface of an enumerator object that implements an IEnumVARIANT interface for the collection. An interface pointer to the IEnumVARIANT interface of the enumerator object can be retrieved by calling QueryInterface on the IUnknown interface returned.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The _NewEnum property gets an enumerator object for the collection. An enumerator object provides serial access to the elements of the collection.

Property _NewEnum As IUnknown

Property Value

Reference to an enumerator object that provides serial access to the elements of the collection.

Remarks

This property is read-only.

In Visual Basic and VBScript, this property is used implicitly in For Each...In...Next constructs.

Example Code

This VBScript script displays the namespaces of all the authentication schemes that are defined for an FPCArray object and are available for use by Web listeners. It does not include error handling.

' Create the root object.
Dim root  ' The FPCLib.FPC root object
Set root = CreateObject("FPC.Root")

' Declare the other objects needed.
Dim array                  ' An FPCArray object
Dim authenticationschemes  ' An FPCAuthenticationSchemes collection
Dim authenticationscheme   ' An FPCAuthenticationScheme object

' Get references to the array object
' and the authentication schemes collection.
Set array = root.GetContainingArray()
Set authenticationschemes = array.RuleElements.AuthenticationSchemes

' Display the namespaces of the authentication schemes
' defined for the array object.
For Each authenticationscheme In authenticationschemes
    WScript.Echo "Namespace: " & authenticationscheme.Namespace
Next

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCAuthenticationSchemes


IFPCAuthenticationSchemes.Add (3 Parameters) method [ISA Server 2004]

IFPCAuthenticationSchemes::Add[C++]

FPCAuthenticationSchemes.Add [Visual Basic]

[C++]

The Add method creates a new FPCAuthenticationScheme object in the collection and returns a reference to it.

HRESULT Add(
  BSTR Namespace,
  BSTR StorageName,
  IFPCAuthenticationScheme** ppNewScheme
);

Parameters

Namespace
[in] Required. BSTR that specifies the namespace of the new authentication scheme.
StorageName
[in] Required. BSTR that specifies the storage name for uniquely identifying the new authentication scheme.
ppNewScheme
[out] Address of an interface pointer that on return points to the new IFPCAuthenticationScheme interface created.

Return Values

This method can return one of the following:

  • S_OK, indicating that the operation succeeded.
  • An error code, indicating that the operation failed. In this case, the [out] parameter returned is a null object.

[Visual Basic]

The Add method creates a new FPCAuthenticationScheme object in the collection and returns a reference to it.

Function Add( _
  ByVal Namespace As String, _
  ByVal StorageName As String _
) As FPCAuthenticationScheme

Parameters

Namespace
[in] Required. String that specifies the namespace of the new authentication scheme.
StorageName
[in] Required. String value that specifies the storage name for uniquely identifying the new authentication scheme.

Return Values

This method returns a reference to an FPCAuthenticationScheme object if successful. Otherwise, an error is raised that can be intercepted by using an error handler.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCAuthenticationSchemes


IFPCAuthenticationSchemes.Count(long) property [ISA Server 2004]

Count Property of IFPCAuthenticationSchemes[C++]

FPCAuthenticationSchemes.Count [Visual Basic]

[C++]

The Count property gets the number of FPCAuthenticationScheme objects in the collection.

HRESULT get_Count(
  long* plCount
);

Parameters

plCount
Pointer to a variable that on return receives a 32-bit integer specifying the number of FPCAuthenticationScheme objects in the collection.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The Count property gets the number of FPCAuthenticationScheme objects in the collection.

Property Count As Long

Property Value

A 32-bit integer that specifies the number of FPCAuthenticationScheme objects in the collection.

Remarks

This property is read-only.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCAuthenticationSchemes


IFPCAuthenticationSchemes.Item (2 Parameters) method [ISA Server 2004]

IFPCAuthenticationSchemes::Item[C++]

FPCAuthenticationSchemes.Item [Visual Basic]

[C++]

The Item method retrieves the requested IFPCAuthenticationScheme interface from the collection.

HRESULT Item(
  VARIANT Index,
  IFPCAuthenticationScheme** ppItem
);

Parameters

Index
[in] Required. Namespace of the authentication scheme or one-based index of the object to retrieve.
ppItem
[out] Address of an interface pointer that on return points to the IFPCAuthenticationScheme interface requested.

Return Values

This method can return one of the following:

  • S_OK, indicating that the operation succeeded.
  • An error code, indicating that the operation failed. In this case, the [out] parameter returned is a null object.
[Visual Basic]

The Item method retrieves the requested FPCAuthenticationScheme object from the collection.

Function Item( _
  ByVal Index As Variant _
) As FPCAuthenticationScheme

Parameters

Index
[in] Required. Namespace of the authentication scheme or one-based index of the object to retrieve.

Return Values

This method returns a reference to the FPCAuthenticationScheme object requested if successful. Otherwise, an error is raised that can be intercepted by using an error handler.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCAuthenticationSchemes


IFPCAuthenticationSchemes.Remove(Variant) method [ISA Server 2004]

IFPCAuthenticationSchemes::Remove[C++]

FPCAuthenticationSchemes.Remove [Visual Basic]

[C++]

The Remove method removes the specified FPCAuthenticationScheme object from the collection.

HRESULT Remove(
  VARIANT Item
);

Parameters

Item
[in] Required. One-based index of the object to remove.

Return Values

This method returns S_OK if the call is successful; otherwise, it returns an error code.

[Visual Basic]

The Remove method removes the specified FPCAuthenticationScheme object from the collection.

Sub Remove( _
  ByVal Item As Variant _
)

Parameters

Item
[in] Required. One-based index of the object to remove.

Return Values

This method has no return values. If the call is unsuccessful, an error is raised that can be intercepted by using an error handler.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCAuthenticationSchemes


FPCBackupRoute object [ISA Server 2004]

FPCBackupRoute

The FPCBackupRoute object represents the backup route, which is used to route requests from Web proxy clients when the primary route is unavailable. The backup route can be direct to the Internet, or it can include an upstream proxy server. This object can also be configured to indicate that there is no backup route.

The FPCBackupRoute object can be accessed through the BackupRoute property of an FPCPrimaryRoute object.

Click here to see the ISA Server object hierarchy.

Methods

The FPCBackupRoute object defines the following methods.

Method | Description
Refresh | Recursively reads the values of all the properties of the object and of its subobjects from persistent storage, discarding any changes that were not saved.
Save | Recursively writes the current values of all the properties of the object and of its subobjects to persistent storage.
SetAutoPollConfig | Sets the configuration for automatic polling of the upstream proxy server on the backup route for array configuration information.
SetServerAndPort | Sets the name of the upstream proxy server on the backup route and the ports on which it listens.

Properties

The FPCBackupRoute object has the following properties.

Property | Description
AuthenticationEnabled | Gets or sets a Boolean value that indicates whether the authentication of downstream clients by the upstream proxy server on the backup route is enabled.
AuthenticationType | Gets or sets a value from the FpcAuthType enumerated type that specifies the type of authentication that the upstream proxy server on the backup route uses if authentication is enabled.
AutomaticPollConfig | Gets a Boolean value that indicates whether polling of the upstream proxy server on the backup route for array configuration information is enabled.
BackupRouteType | Gets or sets a value from the FpcBackupRouteType enumerated type that specifies whether there is a backup route and whether it is direct to the Internet or includes an upstream proxy server.
Credentials | Gets an FPCCredentials object that represents the credentials to be supplied by the ISA Server computer for authenticating a connection to the upstream proxy server on the backup route.
EnableAutoDial | Gets or sets a Boolean value that indicates whether automatic dialing is enabled.
PollAtURL | Gets the URL at which to poll for the array configuration information. This property is valid only if the AutomaticPollConfig property is set to True.
RouteServerName | Gets the name of the upstream proxy server on the backup route.
RouteServerPort | Gets the port on which the upstream proxy server on the backup route listens.
RouteServerSSLPort | Gets the port on which the upstream proxy server on the backup route listens for SSL connections.

Remarks

This object implements the IFPCBackupRoute interface.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

COM Objects


IFPCBackupRoute.AuthenticationEnabled (2 Parameters) property [ISA Server 2004]

AuthenticationEnabled Property of IFPCBackupRoute[C++]

FPCBackupRoute.AuthenticationEnabled [Visual Basic]

[C++]

The AuthenticationEnabled property gets or sets a Boolean value that indicates whether the authentication of downstream clients by the upstream proxy server on the backup route is enabled.

HRESULT get_AuthenticationEnabled(
  VARIANT_BOOL* pfEnabled
);

HRESULT put_AuthenticationEnabled(
  VARIANT_BOOL fEnabled
);

Parameters

pfEnabled
Pointer to a Boolean variable that is set on return to VARIANT_TRUE if the authentication of downstream clients by the upstream proxy server on the backup route is enabled, or to VARIANT_FALSE if such authentication is disabled.
fEnabled
Boolean value that specifies whether the authentication of downstream clients by the upstream proxy server on the backup route is enabled.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write.

[Visual Basic]

The AuthenticationEnabled property gets or sets a Boolean value that indicates whether the authentication of downstream clients by the upstream proxy server on the backup route is enabled.

Property AuthenticationEnabled As Boolean

Property Value

Boolean value that specifies whether the authentication of downstream clients by the upstream proxy server on the backup route is enabled.

Remarks

This property is read/write.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCBackupRoute


IFPCBackupRoute | FPCBackupRoute AuthenticationType property [ISA Server 2004]

AuthenticationType Property of IFPCBackupRoute[C++]

FPCBackupRoute.AuthenticationType [Visual Basic]

[C++]

The AuthenticationType property gets or sets a value from the FpcAuthType enumerated type that specifies the type of authentication that the upstream proxy server on the backup route uses if authentication is enabled.

HRESULT get_AuthenticationType(
  FpcAuthType* pAuthType
);

HRESULT put_AuthenticationType(
  FpcAuthType AuthType
);

Parameters

pAuthType
Pointer to a variable that on return receives the value from the FpcAuthType enumerated type that specifies the type of authentication that the upstream proxy server on the backup route uses if authentication is enabled.
AuthType
Value from the FpcAuthType enumerated type that specifies the type of authentication that the upstream proxy server on the backup route uses if authentication is enabled.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write.

Note that Basic authentication (fpcUiAuthBasic) does not use encryption.

[Visual Basic]

The AuthenticationType property gets or sets a value from the FpcAuthType enumerated type that specifies the type of authentication that the upstream proxy server on the backup route uses if authentication is enabled.

Property AuthenticationType As FpcAuthType

Property Value

Value from the FpcAuthType enumerated type that specifies the type of authentication that the upstream proxy server on the backup route uses if authentication is enabled.

Remarks

This property is read/write.

Note that Basic authentication (fpcUiAuthBasic) does not use encryption.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCBackupRoute


IFPCBackupRoute | FPCBackupRoute AutomaticPollConfig property [ISA Server 2004]

AutomaticPollConfig Property of IFPCBackupRoute[C++]

FPCBackupRoute.AutomaticPollConfig [Visual Basic]

[C++]

The AutomaticPollConfig property gets a Boolean value that indicates whether polling of the upstream proxy server on the backup route for array configuration information is enabled.

HRESULT get_AutomaticPollConfig(
  VARIANT_BOOL* pfEnabled
);

Parameters

pfEnabled
Pointer to a Boolean variable that is set on return to VARIANT_TRUE if polling of the upstream proxy server on the backup route is enabled, or to VARIANT_FALSE if such polling is disabled.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only. It can be modified by calling the SetAutoPollConfig method.

[Visual Basic]

The AutomaticPollConfig property gets a Boolean value that indicates whether polling of the upstream proxy server on the backup route for array configuration information is enabled.

Property AutomaticPollConfig As Boolean

Property Value

A Boolean value that specifies whether polling of the upstream proxy server on the backup route for array configuration information is enabled.

Remarks

This property is read-only. It can be modified by calling the SetAutoPollConfig method.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCBackupRoute


IFPCBackupRoute | FPCBackupRoute BackupRouteType property [ISA Server 2004]

BackupRouteType Property of IFPCBackupRoute[C++]

FPCBackupRoute.BackupRouteType [Visual Basic]

[C++]

The BackupRouteType property gets or sets a value from the FpcBackupRouteType enumerated type that specifies whether there is a backup route and whether it is direct to the Internet or includes an upstream proxy server.

HRESULT get_BackupRouteType(
  FpcBackupRouteType* pRouteType
);

HRESULT put_BackupRouteType(
  FpcBackupRouteType RouteType
);

Parameters

pRouteType
Pointer to a variable that on return receives a value from the FpcBackupRouteType enumerated type that specifies whether there is a backup route and whether it is direct to the Internet or includes an upstream proxy server.
RouteType
Value from the FpcBackupRouteType enumerated type that specifies whether there is a backup route and whether it is direct to the Internet or includes an upstream proxy server.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write.

[Visual Basic]

The BackupRouteType property gets or sets a value from the FpcBackupRouteType enumerated type that specifies whether there is a backup route and whether it is direct to the Internet or includes an upstream proxy server.

Property BackupRouteType As FpcBackupRouteType

Property Value

Value from the FpcBackupRouteType enumerated type that specifies whether there is a backup route and whether it is direct to the Internet or includes an upstream proxy server.

Remarks

This property is read/write.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCBackupRoute


IFPCBackupRoute | FPCBackupRoute Credentials property [ISA Server 2004]

Credentials Property of IFPCBackupRoute[C++]

FPCBackupRoute.Credentials [Visual Basic]

[C++]

The Credentials property gets an FPCCredentials object that represents the credentials to be supplied by the ISA Server computer for authenticating a connection to the upstream proxy server on the backup route.

HRESULT get_Credentials(
  IFPCCredentials** ppCredentials
);

Parameters

ppCredentials
Address of an interface pointer that on return points to an IFPCCredentials interface that represents the credentials to be supplied by the ISA Server computer for authenticating a connection to the upstream proxy server on the backup route.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The Credentials property gets an FPCCredentials object that represents the credentials to be supplied by the ISA Server computer for authenticating a connection to the upstream proxy server on the backup route.

Property Credentials As FPCCredentials

Property Value

Reference to an FPCCredentials object that represents the credentials to be supplied by the ISA Server computer for authenticating a connection to the upstream proxy server on the backup route.

Remarks

This property is read-only.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCBackupRoute


IFPCBackupRoute | FPCBackupRoute EnableAutoDial property [ISA Server 2004]

EnableAutoDial Property of IFPCBackupRoute[C++]

FPCBackupRoute.EnableAutoDial [Visual Basic]

[C++]

The EnableAutoDial property gets or sets a Boolean value that indicates whether automatic dialing is enabled.

HRESULT get_EnableAutoDial(
  VARIANT_BOOL* pfEnabled
);

HRESULT put_EnableAutoDial(
  VARIANT_BOOL fEnabled
);

Parameters

pfEnabled
Pointer to a Boolean variable that is set on return to VARIANT_TRUE if automatic dialing is enabled, or to VARIANT_FALSE if automatic dialing is disabled.
fEnabled
Boolean value that indicates whether automatic dialing is enabled.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read-only.

[Visual Basic]

The EnableAutoDial property gets or sets a Boolean value that indicates whether automatic dialing is enabled.

Property EnableAutoDial As Boolean

Property Value

Boolean value that indicates whether automatic dialing is enabled.

Remarks

This property is read-only.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCBackupRoute


IFPCBackupRoute | FPCBackupRoute PollAtURL(BSTR) property [ISA Server 2004]

PollAtURL Property of IFPCBackupRoute[C++]

FPCBackupRoute.PollAtURL [Visual Basic]

[C++]

The PollAtURL property gets the URL at which to poll for the array configuration information. This property is valid only if the AutomaticPollConfig property is set to VARIANT_TRUE.

HRESULT get_PollAtURL(
  BSTR* pbstrURL
);

Parameters

pbstrURL
Pointer to a BSTR that is set on return to a string value specifying the URL at which to poll for the array configuration information.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

The URL retrieved is typically hosted on the upstream proxy server on the backup route.

[Visual Basic]

The PollAtURL property gets the URL at which to poll for the array configuration information. This property is valid only if the AutomaticPollConfig property is set to True.

Property PollAtURL As String

Property Value

String that specifies the URL at which to poll for the array configuration information.

Remarks

This property is read-only.

The URL retrieved is typically hosted on the upstream proxy server on the backup route.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCBackupRoute


IFPCBackupRoute | FPCBackupRoute Refresh method [ISA Server 2004]

IFPCBackupRoute::Refresh[C++]

FPCBackupRoute.Refresh [Visual Basic]

[C++]

The Refresh method recursively reads the values of all the properties of the object and of its subobjects from persistent storage, discarding any changes that were not saved.

HRESULT Refresh();

Parameters

This method has no parameters.

Return Values

This method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

Changes made to this object can be saved by calling the Save method of this object or the Save method of any object containing it.

[Visual Basic]

The Refresh method recursively reads the values of all the properties of the object and of its subobjects from persistent storage, discarding any changes that were not saved.

Sub Refresh()

Parameters

This method has no parameters.

Return Values

This method has no return values. If the call is unsuccessful, an error is raised that can be intercepted by using an error handler.

Remarks

Changes made to this object can be saved by calling the Save method of this object or the Save method of any object containing it.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCBackupRoute


IFPCBackupRoute | FPCBackupRoute RouteServerName property [ISA Server 2004]

RouteServerName Property of IFPCBackupRoute[C++]

FPCBackupRoute.RouteServerName [Visual Basic]

[C++]

The RouteServerName property gets the name of the upstream proxy server on the backup route.

HRESULT get_RouteServerName(
  BSTR* pbstrURL
);

Parameters

pbstrURL
Pointer to a BSTR that is set on return to a string value specifying the name of the upstream proxy server on the backup route.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The RouteServerName property gets the name of the upstream proxy server on the backup route.

Property RouteServerName As String

Property Value

String that specifies the name of the upstream proxy server on the backup route.

Remarks

This property is read-only.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCBackupRoute


IFPCBackupRoute | FPCBackupRoute RouteServerPort property [ISA Server 2004]

RouteServerPort Property of IFPCBackupRoute[C++]

FPCBackupRoute.RouteServerPort [Visual Basic]

[C++]

The RouteServerPort property gets the port on which the upstream proxy server on the backup route listens.

HRESULT get_RouteServerPort(
  long* plPort
);

Parameters

plPort
Pointer to a variable that on return receives a 32-bit integer specifying the port number. It can be a value from 1 to 65535.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The RouteServerPort property gets the port on which the upstream proxy server on the backup route listens.

Property RouteServerPort As Long

Property Value

A 32-bit integer that specifies the port number. It can be a value from 1 to 65535.

Remarks

This property is read-only.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCBackupRoute


IFPCBackupRoute | FPCBackupRoute RouteServerSSLPort property [ISA Server 2004]

RouteServerSSLPort Property of IFPCBackupRoute[C++]

FPCBackupRoute.RouteServerSSLPort [Visual Basic]

[C++]

The RouteServerSSLPort property gets the port on which the upstream proxy server on the backup route listens for Secure Sockets Layer (SSL) connections.

HRESULT get_RouteServerSSLPort(
  long* plSSLPort
);

Parameters

plSSLPort
Pointer to a variable that on return receives a 32-bit integer specifying the port number. It can be a value from 1 to 65535.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The RouteServerSSLPort property gets the port on which the upstream proxy server on the backup route listens for Secure Sockets Layer (SSL) connections.

Property RouteServerSSLPort As Long

Property Value

A 32-bit integer that specifies the port number. It can be a value from 1 to 65535.

Remarks

This property is read-only.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCBackupRoute


IFPCBackupRoute | FPCBackupRoute Save (2 Parameters) method [ISA Server 2004]

IFPCBackupRoute::Save[C++]

FPCBackupRoute.Save [Visual Basic]

[C++]

The Save method recursively writes the current values of all the properties of the object and of its subobjects to persistent storage. It is important to remember that any changes made by scripts and programs are not saved until after the Save method is called.

HRESULT Save(
  VARIANT_BOOL fResetRequiredServices,
  VARIANT_BOOL fReloadConfiguration
);

Parameters

fResetRequiredServices
[in, optional] Boolean value that indicates whether to restart the services that need to be restarted for any of the changes saved to take effect. The default value is VARIANT_FALSE.
fReloadConfiguration
[in, optional] Boolean value that indicates whether the call will include synchronous reloading of all changes that can be applied dynamically without restarting services. The default value is VARIANT_TRUE.

Return Values

This method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

Configuration changes are applied only after the new settings are written to persistent storage and reloaded to the services that use them. Most changes can be applied dynamically without restarting any services. However, some changes can take effect only after the Microsoft Firewall service is restarted. For more information, see Restarting Services after Configuration Changes.

ISA Server maintains a bitmask that specifies which services need to be started for currently unsaved changes to take effect. This bitmask can be retrieved by calling the GetServiceRestartMask method on an object that contains this object as a subobject. Calling the Save method clears all of the bits in this bitmask even if the fResetRequiredServices parameter is set to VARIANT_FALSE.

If the fReloadConfiguration parameter is set to VARIANT_FALSE the current values of the properties of the object and of its subobjects will be written to persistent storage without updating the configuration being used by the ISA Server services. The configuration used by each service will not be updated until the service is restarted or the new settings are reloaded by another call to Save.

[Visual Basic]

The Save method recursively writes the current values of all the properties of the object and of its subobjects to persistent storage. It is important to remember that any changes made by scripts and programs are not saved until after the Save method is called.

Sub Save( _
  [ ByVal fResetRequiredServices As Boolean ], _
  [ ByVal fReloadConfiguration As Boolean ] _
)

Parameters

fResetRequiredServices
[in, optional] Boolean value that indicates whether to restart the services that need to be restarted for any of the changes saved to take effect. The default value is False.
fReloadConfiguration
[in, optional] Boolean value that indicates whether the call will include synchronous reloading of all the saved configuration changes that can be applied dynamically without restarting services. The default value is True.

Return Values

This method has no return values. If the call is unsuccessful, an error is raised that can be intercepted by using an error handler.

Remarks

Configuration changes are applied only after the new settings are written to persistent storage and reloaded to the services that use them. Most changes can be applied dynamically without restarting any services. However, some changes can take effect only after the Microsoft Firewall service is restarted. For more information, see Restarting Services after Configuration Changes.

ISA Server maintains a bitmask that specifies which services need to be started for currently unsaved changes to take effect. This bitmask can be retrieved by calling the GetServiceRestartMask method on an object that contains this object as a subobject. Calling the Save method clears all of the bits in this bitmask even if the fResetRequiredServices parameter is set to False.

If the fReloadConfiguration parameter is set to False the current values of the properties of the object and of its subobjects will be written to persistent storage without updating the configuration being used by the ISA Server services. The configuration used by each service will not be updated until the service is restarted or the new settings are reloaded by another call to Save.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCBackupRoute


IFPCBackupRoute | FPCBackupRoute SetAutoPollConfig method [ISA Server 2004]

IFPCBackupRoute::SetAutoPollConfig[C++]

FPCBackupRoute.SetAutoPollConfig [Visual Basic]

[C++]

The SetAutoPollConfig method sets the configuration for automatic polling of the upstream proxy server on the backup route for array configuration information.

HRESULT SetAutoPollConfig(
  VARIANT_BOOL fSetAuto,
  BSTR AutoPollUrl
);

Parameters

fSetAuto
[in] Boolean value that indicates whether polling of the upstream proxy server on the backup route for array configuration information is enabled.
AutoPollUrl
[in, optional] BSTR that specifies the URL, usually at the upstream proxy, to poll for the array configuration information. If fSetAuto is set to VARIANT_TRUE, this parameter must hold a valid URL; otherwise, this parameter is ignored.

Return Values

This method returns S_OK if the call is successful; otherwise, it returns an error code.
[Visual Basic]

The SetAutoPollConfig method sets the configuration for automatic polling of the upstream proxy server on the backup route for array configuration information.

Sub SetAutoPollConfig( _
  ByVal fSetAuto As Boolean, _
  [ ByVal AutoPollUrl As String ] _
)

Parameters

fSetAuto
[in] Boolean value that indicates whether polling of the upstream proxy server on the backup route for array configuration information is enabled.
AutoPollUrl
[in, optional] String value that specifies the URL, usually at the upstream proxy server, to poll for the array configuration information. If fSetAuto is set to True, this parameter must hold a valid URL; otherwise, this parameter is ignored.

Return Values

This method has no return values. If the call is unsuccessful, an error is raised that can be intercepted by using an error handler.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCBackupRoute


IFPCBackupRoute | FPCBackupRoute SetServerAndPort method [ISA Server 2004]

IFPCBackupRoute::SetServerAndPort[C++]

FPCBackupRoute.SetServerAndPort [Visual Basic]

[C++]

The SetServerAndPort method sets the name of the upstream proxy server on the backup route and the ports on which it listens.

HRESULT SetServerAndPort(
  BSTR ServerName,
  long Port,
  long SSLPort
);

Parameters

ServerName
[in] String value that specifies the name of the upstream proxy server on the backup route.
Port
[in] A 32-bit integer that specifies the port number on which the upstream proxy server listens. It can have a value from 1 to 65535.
SSLPort
[in] A 32-bit integer that specifies the port number on which the upstream proxy server listens for SSL connections. It can have a value from 1 to 65535.

Return Values

This method returns S_OK if the call is successful; otherwise, it returns an error code.
[Visual Basic]

The SetServerAndPort method sets the name of the upstream proxy server on the backup route and the ports on which it listens.

Sub SetServerAndPort( _
  ByVal ServerName As String, _
  ByVal Port As Long, _
  ByVal SSLPort As Long _
)

Parameters

ServerName
[in] String value that specifies the name of the upstream proxy server on the backup route.
Port
[in] A 32-bit integer that specifies the port number on which the upstream proxy server listens. It can have a value from 1 to 65535.
SSLPort
[in] A 32-bit integer that specifies the port number on which the upstream proxy server listens for SSL connections. It can have a value from 1 to 65535.

Return Values

This method has no return values. If the call is unsuccessful, an error is raised that can be intercepted by using an error handler.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCBackupRoute


FPCCache object [ISA Server 2004]

FPCCache

The FPCCache object is used to administer all cache configuration settings. Most details of the cache configuration are accessed through the CacheConfiguration and CacheContents properties of this object. The CacheConfiguration property returns an object of type FPCCacheConfiguration, and the CacheContents property returns an object of type FPCCacheContents.

The FPCCache object is typically accessed through the Cache property of the FPCArray object.

Click here to see the ISA Server object hierarchy.

Inheritance

This object inherits from the FPCPersist object, which contains methods and properties related to the persistent storage of an object's data. They include methods for exporting the object's data to and importing it from an XML document.

Methods

This object has no methods.

Properties

The FPCCache object has the following properties.

Property | Description
CacheConfiguration | Gets an FPCCacheConfiguration object that provides access to the cache configuration settings for the array.
CacheContents | Gets an FPCCacheContents object that provides a method for downloading content to the cache.
ScheduledContentDownload | Gets an FPCScheduledContentDownload collection that contains the prefetching tasks for the cache.

Methods Inherited from FPCPersist

Name | Description
CancelWaitForChanges | Cancels the registration established by the WaitForChanges method (for use in C and C++ programming only).
CanImport | Returns a Boolean value that indicates whether the object's properties can be imported from the specified XML document.
Export | Recursively writes the stored values of all the properties of the object and its subobjects to the specified XML document.
ExportToFile | Recursively writes the stored values of all the properties of the object and its subobjects to the specified XML file.
GetServiceRestartMask | Retrieves a 32-bit bitmask of the FpcServices enumerated type that specifies which services need to be restarted for currently unsaved changes to take effect.
Import | Recursively copies the values of all the properties of the object and of its subobjects from the specified XML document to persistent storage.
ImportFromFile | Recursively copies the values of all the properties of the object and of its subobjects from the specified XML file to persistent storage.
LoadDocProperties | Provides the XML document's properties so that you can know what information can be imported from the document.
Refresh | Recursively reads the values of all the properties of the object and of its subobjects from persistent storage, overwriting any changes that have not been saved.
Save | Recursively writes the current values of all the properties of the object and its subobjects to persistent storage.
WaitForChanges | Registers to wait for an event indicating that the contents of the object have changed (for use in C and C++ programming only).

Properties Inherited from FPCPersist

Name | Description
PersistentName | Gets the persistent name of the object. The persistent name of an object is a name that is unique for the object at the respective level of the COM object hierarchy.
VendorParametersSets | Gets an FPCVendorParametersSets collection that can hold sets of custom data for extending the object.

Remarks

This object implements the IFPCCache interface.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

COM Objects


IFPCCache | FPCCache CacheConfiguration (1 Parameter) property [ISA Server 2004]

CacheConfiguration Property of IFPCCache[C++]

FPCCache.CacheConfiguration [Visual Basic]

[C++]

The CacheConfiguration property gets an FPCCacheConfiguration object that provides access to the cache configuration settings for the array.

HRESULT get_CacheConfiguration(
  IFPCCacheConfiguration** ppCacheConfiguration
);

Parameters

ppCacheConfiguration
Address of an interface pointer that on return points to an IFPCCacheConfiguration interface that provides access to the cache configuration settings for the array.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only. You can access and modify the cache configuration settings through the properties of the IFPCCacheConfiguration interface retrieved.

[Visual Basic]

The CacheConfiguration property gets an FPCCacheConfiguration object that provides access to the cache configuration settings for the array.

Property CacheConfiguration As FPCCacheConfiguration

Property Value

Reference to the FPCCacheConfiguration object for the array.

Remarks

This property is read-only. You can access and modify the cache configuration settings through the properties of the FPCCacheConfiguration object retrieved.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCCache


IFPCCache | FPCCache CacheContents(IFPCCacheContents) property [ISA Server 2004]

CacheContents Property of IFPCCache[C++]

FPCCache.CacheContents [Visual Basic]

[C++]

The CacheContents property gets an FPCCacheContents object that provides a method for downloading content to the cache.

HRESULT get_CacheContents(
  IFPCCacheContents** ppCacheContents
);

Parameters

ppCacheContents
Address of an interface pointer that on return points to an IFPCCacheContents interface that provides methods for downloading content to the cache.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

You can use the FetchURL method of the IFPCCacheContents object retrieved to download content directly to the ISA Server cache.

[Visual Basic]

The CacheContents property gets an FPCCacheContents object that provides a method for downloading content to the cache.

Property CacheContents As FPCCacheContents

Property Value

Reference to an FPCCacheContents object.

Remarks

This property is read-only.

You can use the FetchURL method of the FPCCacheContents object retrieved to download content directly to the ISA Server cache.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCCache


IFPCCache | FPCCache ScheduledContentDownload property [ISA Server 2004]

ScheduledContentDownload Property of IFPCCache[C++]

FPCCache.ScheduledContentDownload [Visual Basic]

[C++]

The ScheduledContentDownload property gets an FPCScheduledContentDownload collection that contains the prefetching tasks for the cache.

HRESULT get_ScheduledContentDownload(
  IFPCScheduledContentDownload** ppScheduledContentDownload
);

Parameters

ppScheduledContentDownload
Address of an interface pointer that on return points to an IFPCScheduledContentDownload interface that represents the collection of prefetching tasks.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only. You can modify the collection of prefetching tasks and access the properties of each prefetching task through the IFPCScheduledContentDownload interface retrieved.

[Visual Basic]

The ScheduledContentDownload property gets an FPCScheduledContentDownload collection that contains the prefetching tasks for the cache.

Property ScheduledContentDownload As FPCScheduledContentDownload

Property Value

Reference to the FPCScheduledContentDownload collection for the cache.

Remarks

This property is read-only. You can modify the collection of prefetching tasks and access the properties of each prefetching task through the FPCScheduledContentDownload collection retrieved.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCCache


FPCCacheConfiguration object [ISA Server 2004]

FPCCacheConfiguration

The FPCCacheConfiguration object provides access to the cache configuration settings in an ISA Server array. It also provides access to the active cache configuration settings because it is a container for the FPCActiveCacheConfiguration object.

Note To disable the cache on an ISA Server computer, you have to set the CacheLimitInMegs property of the FPCCacheDrive object to zero for all drives on the computer. If there is cache space allocated on any drive, the cache is automatically enabled.

The FPCCacheConfiguration object is typically accessed through the CacheConfiguration property of an FPCCache object.

Click here to see the ISA Server object hierarchy.

Inheritance

This object inherits from the FPCPersist object, which contains methods and properties related to the persistent storage of an object's data. They include methods for exporting an object's data to and importing it from an XML document.

Methods

This object has no methods.

Properties

The FPCCacheConfiguration object has the following properties.

Property | Description
ActiveCacheConfiguration | Gets an FPCActiveCacheConfiguration object for accessing the active cache configuration.
CacheNon200Responses | Gets or sets a Boolean value that indicates whether the caching of responses having a code other than 200 (OK) is enabled.
CacheRules | Gets an FPCCacheRules collection that contains the cache rules which are applied.
CacheWithNoLastModDate | Gets or sets a Boolean value that indicates whether the caching of responses that have no last-modified date is enabled.
MemoryCacheMaxURLSize | Gets or sets the maximum size of an object that may be stored in the physical memory cache.
MemoryUsagePercentage | Gets or sets the percentage of physical memory used for the ISA Server cache.
QueueRequests | Gets or sets a Boolean value that indicates whether requests for objects are queued if those objects are in the process of being stored in the cache.
ReturnExpiredEnable | Gets or sets a Boolean value that indicates whether the ISA Server Web proxy returns expired cached objects when an updated object cannot be retrieved, or issues an error response.
ReturnExpiredMaxTime | Gets or sets the maximum time, in minutes, during which an expired cached object may be returned if the returning of expired cached objects is enabled.
ReturnExpiredTTLPercent | Gets or sets the percentage of an expired cached object's Time to Live (TTL) during which the object may be returned if the returning of expired cached objects is enabled.

Methods Inherited from FPCPersist

Name | Description
CancelWaitForChanges | Cancels the registration established by the WaitForChanges method (for use in C and C++ programming only).
CanImport | Returns a Boolean value that indicates whether the object's properties can be imported from the specified XML document.
Export | Recursively writes the stored values of all the properties of the object and its subobjects to the specified XML document.
ExportToFile | Recursively writes the stored values of all the properties of the object and its subobjects to the specified XML file.
GetServiceRestartMask | Retrieves a 32-bit bitmask of the FpcServices enumerated type that specifies which services need to be restarted for currently unsaved changes to take effect.
Import | Recursively copies the values of all the properties of the object and of its subobjects from the specified XML document to persistent storage.
ImportFromFile | Recursively copies the values of all the properties of the object and of its subobjects from the specified XML file to persistent storage.
LoadDocProperties | Provides the XML document's properties so that you can know what information can be imported from the document.
Refresh | Recursively reads the values of all the properties of the object and of its subobjects from persistent storage, overwriting any changes that have not been saved.
Save | Recursively writes the current values of all the properties of the object and its subobjects to persistent storage.
WaitForChanges | Registers to wait for an event indicating that the contents of the object have changed (for use in C and C++ programming only).

Properties Inherited from FPCPersist

Name | Description
PersistentName | Gets the persistent name of the object. The persistent name of an object is a name that is unique for the object at the respective level of the COM object hierarchy.
VendorParametersSets | Gets an FPCVendorParametersSets collection that can hold sets of custom data for extending the object.

Remarks

This object implements the IFPCCacheConfiguration interface.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

COM Objects


IFPCCacheConfiguration.ActiveCacheConfiguration property [ISA Server 2004]

ActiveCacheConfiguration Property of IFPCCacheConfiguration[C++]

FPCCacheConfiguration.ActiveCacheConfiguration [Visual Basic]

[C++]

The ActiveCacheConfiguration property gets an FPCActiveCacheConfiguration object for accessing the active cache configuration.

HRESULT get_ActiveCacheConfiguration(
  IFPCActiveCacheConfiguration** ppActiveCacheConfiguration
);

Parameters

ppActiveCacheConfiguration
Address of an interface pointer that on return points to an IFPCActiveCacheConfiguration interface that represents the active cache configuration for the ISA Server computer.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only. The active cache configuration can be modified by calling the properties and methods of the IFPCActiveCacheConfiguration interface retrieved.

[Visual Basic]

The ActiveCacheConfiguration property gets an FPCActiveCacheConfiguration object for accessing the active cache configuration.

Property ActiveCacheConfiguration As FPCActiveCacheConfiguration

Property Value

Reference to an FPCActiveCacheConfiguration object that defines the active cache configuration for the ISA Server computer.

Remarks

This property is read-only. The active cache configuration can be modified by calling the properties and methods of the FPCActiveCacheConfiguration object retrieved.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCCacheConfiguration


IFPCCacheConfiguration.CacheNon200Responses property [ISA Server 2004]

CacheNon200Responses Property of IFPCCacheConfiguration[C++]

FPCCacheConfiguration.CacheNon200Responses [Visual Basic]

[C++]

The CacheNon200Responses property gets or sets a Boolean value that indicates whether the caching of responses having a code other than 200 (OK) is enabled.

HRESULT get_CacheNon200Responses(
  VARIANT_BOOL* pfEnabled
);

HRESULT put_CacheNon200Responses(
  VARIANT_BOOL fEnabled
);

Parameters

pfEnabled
Pointer to a Boolean variable that is set on return to VARIANT_TRUE if the caching of responses having a code other than 200 (OK) is enabled, or to VARIANT_FALSE if the caching of such responses is disabled.
fEnabled
Boolean value that indicates whether the caching of responses having a code other than 200 (OK) is enabled.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write.

[Visual Basic]

The CacheNon200Responses property gets or sets a Boolean value that indicates whether the caching of responses having a code other than 200 (OK) is enabled.

Property CacheNon200Responses As Boolean

Property Value

Boolean value that indicates whether the caching of responses having a code other than 200 (OK) is enabled.

Remarks

This property is read/write.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCCacheConfiguration


IFPCCacheConfiguration.CacheRules(IFPCCacheRules) property [ISA Server 2004]

CacheRules Property of IFPCCacheConfiguration[C++]

FPCCacheConfiguration.CacheRules [Visual Basic]

[C++]

The CacheRules property gets an FPCCacheRules collection that contains the cache rules which are applied.

HRESULT get_CacheRules(
  IFPCCacheRules** ppCacheRules
);

Parameters

ppCacheRules
Address of an interface pointer that on return points to an IFPCCacheRules interface that represents the collection of cache rules.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only. Cache rules can be added, removed, or modified, and their order of application can be changed by calling the methods of the IFPCCacheRules interface retrieved.

[Visual Basic]

The CacheRules property gets an FPCCacheRules collection that contains the cache rules which are applied.

Property CacheRules As FPCCacheRules

Property Value

Reference to the FPCCacheRules collection for the cache configuration.

Remarks

This property is read-only. Cache rules can be added, removed, or modified, and their order of application can be changed by calling the methods of the FPCCacheRules collection retrieved.

Example Code

For a VBScript code example of using this property to retrieve the cache rules collection and then add new cache rules to the collection, see Adding Cache Rules.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCCacheConfiguration


IFPCCacheConfiguration.CacheWithNoLastModDate property [ISA Server 2004]

CacheWithNoLastModDate Property of IFPCCacheConfiguration[C++]

FPCCacheConfiguration.CacheWithNoLastModDate [Visual Basic]

[C++]

The CacheWithNoLastModDate property gets or sets a Boolean value that indicates whether the caching of responses that have no last-modified date is enabled.

HRESULT get_CacheWithNoLastModDate(
  VARIANT_BOOL* pfEnabled
);

HRESULT put_CacheWithNoLastModDate(
  VARIANT_BOOL fEnabled
);

Parameters

pfEnabled
Pointer to a Boolean variable that is set on return to VARIANT_TRUE if the caching of responses that have no last-modified date is enabled, or to VARIANT_FALSE if the caching of such responses is disabled.
fEnabled
Boolean value that indicates whether the caching of responses that have no last-modified date is enabled.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write.

[Visual Basic]

The CacheWithNoLastModDate property gets or sets a Boolean value that indicates whether the caching of responses that have no last-modified date is enabled.

Property CacheWithNoLastModDate As Boolean

Property Value

Boolean value that indicates whether the caching of responses that have no last-modified date is enabled.

Remarks

This property is read/write.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCCacheConfiguration


IFPCCacheConfiguration.MemoryCacheMaxURLSize property [ISA Server 2004]

MemoryCacheMaxURLSize Property of IFPCCacheConfiguration[C++]

FPCCacheConfiguration.MemoryCacheMaxURLSize [Visual Basic]

[C++]

The MemoryCacheMaxURLSize property gets or sets the maximum size of an object that may be stored in the physical memory cache. By default, objects smaller than 12,800 bytes are stored in RAM and on disk, and all larger objects are stored only in the disk cache.

HRESULT get_MemoryCacheMaxURLSize(
  long* plMaxURLSize
);

HRESULT put_MemoryCacheMaxURLSize(
  long lMaxURLSize
);

Parameters

plMaxURLSize
Pointer to a variable that on return receives a 32-bit integer specifying the maximum size of an object that may be stored in the physical memory cache.
lMaxURLSize
A 32-bit integer that specifies the maximum size of an object that may be stored in the physical memory cache.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write.

[Visual Basic]

The MemoryCacheMaxURLSize property gets or sets the maximum size of an object that may be stored in the physical memory cache. By default, objects smaller than 12,800 bytes are stored in RAM and on disk, and all larger objects are stored only in the disk cache.

Property MemoryCacheMaxURLSize As Long

Property Value

A 32-bit integer that specifies the maximum size of an object that may be stored in the physical memory cache.

Remarks

This property is read/write.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCCacheConfiguration


IFPCCacheConfiguration.MemoryUsagePercentage property [ISA Server 2004]

MemoryUsagePercentage Property of IFPCCacheConfiguration[C++]

FPCCacheConfiguration.MemoryUsagePercentage [Visual Basic]

[C++]

The MemoryUsagePercentage property gets or sets the percentage of physical memory used for the ISA Server cache.

HRESULT get_MemoryUsagePercentage(
  long* plMemoryUsage
);

HRESULT put_MemoryUsagePercentage(
  long lMemoryUsage
);

Parameters

plMemoryUsage
Pointer to a variable that on return receives a 32-bit integer specifying the percentage of memory used for the ISA Server cache.
lMemoryUsage
A 32-bit integer that specifies the percentage of memory used for the ISA Server cache.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write.

If you are using a particular computer primarily for ISA Server, this number should be higher because a higher percentage will increase the efficiency of the cache. If the computer's resources are needed for other services, you may want to consider lowering the percentage of memory used for ISA Server. For more information, see ISA Server Caching Mechanism.

[Visual Basic]

The MemoryUsagePercentage property gets or sets the percentage of physical memory used for the ISA Server cache.

Property MemoryUsagePercentage As Long

Property Value

A 32-bit integer that specifies the percentage of memory used for the ISA Server cache.

Remarks

This property is read/write.

If you are using a particular computer primarily for ISA Server, this number should be higher because a higher percentage will increase the efficiency of the cache. If the computer's resources are needed for other services, you may want to consider lowering the percentage of memory used for ISA Server. For more information, see ISA Server Caching Mechanism.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCCacheConfiguration


IFPCCacheConfiguration.QueueRequests (2 Parameters) property [ISA Server 2004]

QueueRequests Property of IFPCCacheConfiguration[C++]

FPCCacheConfiguration.QueueRequests [Visual Basic]

[C++]

The QueueRequests property gets or sets a Boolean value that indicates whether requests for objects are queued if those objects are in the process of being stored in the cache.

HRESULT get_QueueRequests(
  VARIANT_BOOL* pfEnabled
);

HRESULT put_QueueRequests(
  VARIANT_BOOL fEnabled
);

Parameters

pfEnabled
Pointer to a Boolean variable that is set on return to VARIANT_TRUE if the queuing of requests is enabled, or to VARIANT_FALSE if the queuing of requests is disabled.
fEnabled
Boolean value that specifies whether the queuing of requests is enabled.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write.

Note This feature should be used carefully. It allows you to queue requests for objects if those objects are being downloaded to the cache when the request comes in. This saves bandwidth and reduces server loads. However, for large objects, the queued request may experience a long delay while the object is cached. In that case, if the request had not been queued, initial chunks of the large object would have been retrieved while the request continued to download data directly from the Internet. This property should therefore be set to VARIANT_TRUE only in environments where you are certain that only relatively small objects, such as SQL queries, will be requested.

[Visual Basic]

The QueueRequests property gets or sets a Boolean value that indicates whether requests for objects are queued if those objects are in the process of being stored in the cache.

Property QueueRequests As Boolean

Property Value

Boolean value that specifies whether the queuing of requests is enabled.

Remarks

This property is read/write.

Note This feature should be used carefully. It allows you to queue requests for objects if those objects are being downloaded to the cache when the request comes in. This saves bandwidth and reduces server loads. However, for large objects, the queued request may experience a long delay while the object is cached. In that case, if the request had not been queued, initial chunks of the large object would have been retrieved while the request continued to download data directly from the Internet. This property should therefore be set to True only in environments where you are certain that only relatively small objects, such as SQL queries, will be requested.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCCacheConfiguration


IFPCCacheConfiguration.ReturnExpiredEnable property [ISA Server 2004]

ReturnExpiredEnable Property of IFPCCacheConfiguration[C++]

FPCCacheConfiguration.ReturnExpiredEnable [Visual Basic]

[C++]

The ReturnExpiredEnable property gets or sets a Boolean value that indicates whether the ISA Server Web proxy returns expired cached objects when an updated object cannot be retrieved, or issues an error response.

HRESULT get_ReturnExpiredEnable(
  VARIANT_BOOL* pfEnabled
);

HRESULT put_ReturnExpiredEnable(
  VARIANT_BOOL fEnabled
);

Parameters

pfEnabled
Pointer to a Boolean variable that is set on return to VARIANT_TRUE if expired cached objects are returned when an updated object cannot be retrieved, or to VARIANT_FALSE if error responses are issued.
fEnabled
Boolean value that indicates whether the ISA Server Web proxy returns expired cached objects when an updated object cannot be retrieved (VARIANT_TRUE), or issues an error response (VARIANT_FALSE).

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write.

[Visual Basic]

The ReturnExpiredEnable property gets or sets a Boolean value that indicates whether the ISA Server Web proxy returns expired cached objects when an updated object cannot be retrieved, or issues an error response.

Property ReturnExpiredEnable As Boolean

Property Value

Boolean value that indicates whether the ISA Server Web proxy returns expired cached objects when an updated object cannot be retrieved (True), or issues an error response (False).

Remarks

This property is read/write.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCCacheConfiguration, ReturnExpiredMaxTime, ReturnExpiredTTLPercent


IFPCCacheConfiguration.ReturnExpiredMaxTime property [ISA Server 2004]

ReturnExpiredMaxTime Property of IFPCCacheConfiguration[C++]

FPCCacheConfiguration.ReturnExpiredMaxTime [Visual Basic]

[C++]

The ReturnExpiredMaxTime property gets or sets the maximum time, in minutes, during which an expired cached object may be returned if the returning of expired cached objects is enabled.

HRESULT get_ReturnExpiredMaxTime(
  long* plMaxTime
);

HRESULT put_ReturnExpiredMaxTime(
  long lMaxTime
);

Parameters

plMaxTime
Pointer to a variable that receives a 32-bit integer specifying the maximum time, in minutes, during which an expired cached object may be returned if the returning of expired cached objects is enabled.
lMaxTime
A 32-bit integer that specifies the maximum time, in minutes, during which an expired cached object may be returned if the returning of expired cached objects is enabled.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write.

The time set in this property is useful for situations where a server cannot be reached to revalidate an expired cached object.

The returning of expired cached objects can be enabled through the ReturnExpiredEnable property.

[Visual Basic]

The ReturnExpiredMaxTime property gets or sets the maximum time, in minutes, during which an expired cached object may be returned if the returning of expired cached objects is enabled.

Property ReturnExpiredMaxTime As Long

Property Value

A 32-bit integer that specifies the maximum time, in minutes, during which an expired cached object may be returned if the returning of expired cached objects is enabled.

Remarks

This property is read/write.

The time set in this property is useful for situations where a server cannot be reached to revalidate an expired cached object.

The returning of expired cached objects can be enabled through the ReturnExpiredEnable property.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCCacheConfiguration


IFPCCacheConfiguration.ReturnExpiredTTLPercent property [ISA Server 2004]

ReturnExpiredTTLPercent Property of IFPCCacheConfiguration[C++]

FPCCacheConfiguration.ReturnExpiredTTLPercent [Visual Basic]

[C++]

The ReturnExpiredTTLPercent property gets or sets the percentage of an expired cached object's Time to Live (TTL) during which the object may be returned if the returning of expired cached objects is enabled.

HRESULT get_ReturnExpiredTTLPercent(
  long* plFactor
);

HRESULT put_ReturnExpiredTTLPercent(
  long lFactor
);

Parameters

plFactor
Pointer to a variable that receives a 32-bit integer specifying the percentage of an expired cached object's TTL during which the object may be returned if the returning of expired cached objects is enabled.
lFactor
A 32-bit integer that specifies the percentage of an expired cached object's TTL during which the object may be returned if the returning of expired cached objects is enabled.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write.

The returning of expired cached objects can be enabled through the ReturnExpiredEnable property.

[Visual Basic]

The ReturnExpiredTTLPercent property gets or sets the percentage of an expired cached object's Time to Live (TTL) during which the object may be returned if the returning of expired cached objects is enabled.

Property ReturnExpiredTTLPercent As Long

Property Value

A 32-bit integer that specifies the percentage of an expired cached object's TTL during which the object may be returned if the returning of expired cached objects is enabled.

Remarks

This property is read/write.

The returning of expired cached objects can be enabled through the ReturnExpiredEnable property.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCCacheConfiguration


FPCCacheContents object [ISA Server 2004]

FPCCacheContents

The FPCCacheContents object has the single method FetchUrl for downloading content directly to the ISA Server cache and setting the time that the cached object will be stored in the cache. The FetchUrl method can also be used to delete an object from the cache.

For more information about using FetchUrl, see Using FetchURL to Extend the Cache.

The ISA Server cache prefetching feature lets you download content directly to the ISA Server cache, upon request or as scheduled. Prefetching allows you to update the ISA Server cache with content that you anticipate will be requested by clients in your organization.

You can configure the content that ISA Server should prefetch. You can also schedule when the content should be cached, available for access directly from the ISA Server cache, rather than from the Internet.

The FPCCacheContents object is typically accessed through the CacheContents property of an FPCCache object.

Click here to see the ISA Server object hierarchy.

Methods

The FPCCacheContents object defines the following method.

Method | Description
FetchUrl | Causes the ISA Server Web proxy to retrieve an object and store it in the cache.

Remarks

This object implements the IFPCCacheContents interface.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

COM Objects


IFPCCacheContents | FPCCacheContents FetchUrl method [ISA Server 2004]

IFPCCacheContents::FetchUrl[C++]

FPCCacheContents.FetchUrl [Visual Basic]

[C++]

The FetchUrl method causes the ISA Server Web proxy to retrieve an object and store it in the cache.

The ISA Server Web proxy normally fetches objects from the Internet and caches them automatically as clients request them (passive caching). In addition, the Web proxy automatically keeps certain popular objects fresh within its cache by fetching them (active caching). However, there are occasions when an application needs a mechanism to override these automatic operations. The override lets the application exercise greater control either over the source of objects that are placed into the cache or the time they are to remain there. The FetchUrl method allows you this greater degree of control.

To delete an object from the cache, set FetchUrl to an empty string, and set CacheUrl to the URL of the object to remove from the cache. When you delete an object by using FetchUrl, you can perform the operation synchronously or asynchronously, and the Time to Live (TTL) must be set to 0.

HRESULT FetchUrl(
  BSTR FetchUrl,
  BSTR CacheUrl,
  long TtlInMinutes,
  FpcFetchUrlFlags Flags
);

Parameters

FetchUrl
[in] String value that specifies the URL of the object to be fetched. The URL may be any combination of protocol, domain, and path that the Web proxy would normally be able to access. The Web proxy currently supports the HTTP, FTP, and Gopher protocols. If FetchUrl is set to an empty string, the FetchUrl method removes the object specified by the value in CacheUrl from the cache.
CacheUrl
[in] String value that specifies the URL that clients use to retrieve the fetched object from the cache. The URL must include one of the protocols supported by the Web proxy (http:// or ftp://), but the domain specified need not be accessible from the ISA Server computer. This is because the data will have been read from the URL specified in the FetchUrl parameter. The CacheUrl parameter can be the same as the FetchUrl parameter.
TtlInMinutes
[in] A 32-bit integer that specifies the TTL, in minutes, during which the object should be served from the cache. After the TTL has passed, the object has expired and the Web proxy will not return it again to requesting clients unless the Web proxy first verifies that the object has not changed. In general, an application that calls FetchUrl needs to set a TTL large enough to ensure that the object will not expire before the application next refreshes it. Note that ISA Server can delete both fresh and expired objects from the cache if the cache directories become full.

This parameter is ignored unless the Flags parameter includes either the fpcFetchTtlIfNone or fpcFetchTtlOverride flag. If neither flag is specified, the Web proxy's normal TTL computation mechanism is used for the object.

Flags
[in] Bitmask of the FpcFetchUrlFlags enumerated type that specifies a set of bit flags to control the TTL of the object in the Web proxy's cache:

fpcFetchTtlOverride
Use the TtlInMinutes parameter to set the TTL for the object regardless of any "Expires" or "Cache-Control: max-age" HTTP header that the publishing Web server may have included with the object. Be careful when overriding a TTL for objects that another party authored. Overriding may cause objects to be cached longer than their intended lifetimes.
fpcFetchTtlIfNone
The TtlInMinutes parameter is used to set the TTL for the object unless the publishing Web server has supplied an "Expires" or "Cache-Control: max-age" HTTP header.

If you have set neither of these flags, the Web proxy uses its normal TTL computation mechanism for the object, which uses an "Expires" or "Cache-Control: max-age" HTTP header if available. Otherwise, the Web proxy estimates a good TTL value based on the time that has elapsed since the object was last modified.

In addition to the preceding flags, you can set one or more of the following flags:

fpcFetchSynchronous
The method does not return to the caller until the fetch has completed and you have stored the object in the cache, or until an error occurs in the processing of the request. Such an error ends the operation. If you do not specify this flag, the method returns immediately and the fetch completes asynchronously to the caller, in which case it is not possible to determine whether the fetch completed successfully.
fpcFetchForceCache
Cache the object even if the caching rules in the HTTP specification normally prohibit this object from being cached; for example, if the object contains a "Cache-Control: no-cache" HTTP header or the response indicates a server error. Be careful when using this flag for objects that were authored by another party. There is often a good reason why the data could not be cached and caching it might cause the site to function improperly or might even be a violation of your license agreement for use of the data. If the CacheUrl parameter contains a question mark, this flag alone will not allow the object to be cached.

Return Values

This method returns S_OK if the call is successful; otherwise, it returns an error code. If an error is returned, the error code portion of the HRESULT (the low 16 bits of the value) may be a value defined by the Windows Internet (WinINet) API or Windows Sockets (Winsock).

Remarks

To retrieve an HTTP object in response to a FetchUrl call, the Web proxy uses the normal HTTP GET method to the URL specified by FetchUrl. If there is already a cached copy (which was either loaded into the proxy server previously by normal operations or by an earlier call to FetchUrl) of the URL specified by CacheUrl, the Web proxy will include an If-Modified-Since header in the request (such a request is known as a conditional GET request). The response to a conditional GET may be either a new copy of the data, which will be stored in the cache, or a 304 (Not Modified) response, which will cause the Web proxy to extend the TTL of the object without changing the contents of the data in the cache.

To delete an object from the cache, set FetchUrl to an empty string, and set CacheUrl to the URL of the object to remove from the cache. When you delete an object using FetchUrl, you can perform the operation synchronously or asynchronously, and the TTL must be set to 0.

The DeleteURL VBScript provided with ISA Server in the folder SDK\samples\admin\scripts demonstrates how to delete a cached object.

Note ERROR_INTERNET_UNABLE_TO_CACHE_FILE (decimal value 12158, hex value 2F7E) is a new value that is not present in all versions of the WinINet API include files. This error code is returned if the HTTP headers in the object or other factors prohibited the Web proxy from caching the object. The caller may still be able to force the object into the cache using the fpcFetchForceCache flag.

[Visual Basic]

The FetchUrl method causes the ISA Server Web proxy to retrieve an object and store it in the cache.

The ISA Server Web proxy normally fetches objects from the Internet and caches them automatically as clients request them (passive caching). In addition, the Web proxy automatically keeps certain popular objects fresh within its cache by fetching them (active caching). However, there are occasions when an application needs a mechanism to override these automatic operations. The override lets the application exercise greater control either over the source of objects that are placed into the cache or the time they are to remain there. The FetchUrl method allows you this greater degree of control.

To delete an object from the cache, set FetchUrl to an empty string, and set CacheUrl to the URL of the object to remove from the cache. When you delete an object by using FetchUrl, you can perform the operation synchronously or asynchronously, and the Time to Live (TTL) must be set to 0.

Sub FetchUrl( _
  ByVal FetchUrl As String, _
  ByVal CacheUrl As String, _
  ByVal TtlInMinutes As Long, _
  ByVal Flags As FpcFetchUrlFlags _
)

Parameters

FetchUrl
[in] String value that specifies the URL of the object to be fetched. The URL may be any combination of protocol, domain, and path that the Web proxy would normally be able to access. The Web proxy currently supports the HTTP, FTP, and Gopher protocols. If FetchUrl is set to an empty string, the FetchUrl method removes the object specified by the value in CacheUrl from the cache.
CacheUrl
[in] String value that specifies the URL that clients use to retrieve the fetched object from the cache. The URL must include one of the protocols supported by the Web proxy (http:// or ftp://), but the domain specified need not be accessible from the ISA Server computer. This is because the data will have been read from the URL specified in the FetchUrl parameter. The CacheUrl parameter can be the same as the FetchUrl parameter.
TtlInMinutes
[in] A 32-bit integer that specifies the TTL, in minutes, during which the object should be served from the cache. After the TTL has passed, the object has expired and the Web proxy will not return it again to requesting clients unless the Web proxy first verifies that the object has not changed. In general, an application that calls FetchUrl needs to set a TTL large enough to ensure that the object will not expire before the application next refreshes it. Note that ISA Server can delete both fresh and expired objects from the cache if the cache directories become full.

This parameter is ignored unless the Flags parameter includes either the fpcFetchTtlIfNone or fpcFetchTtlOverride flag. If neither flag is specified, the Web proxy's normal TTL computation mechanism is used for the object.

Flags
[in] Bitmask of the FpcFetchUrlFlags enumerated type that specifies a set of bit flags to control the TTL of the object in the Web proxy's cache:

fpcFetchTtlOverride
Use the TtlInMinutes parameter to set the TTL for the object regardless of any "Expires" or "Cache-Control: max-age" HTTP header that the publishing Web server may have included with the object. Be careful when overriding a TTL for objects that another party authored. Overriding may cause objects to be cached longer than their intended lifetimes.
fpcFetchTtlIfNone
The TtlInMinutes parameter is used to set the TTL for the object unless the publishing Web server has supplied an "Expires" or "Cache-Control: max-age" HTTP header.

If you have set neither of these flags, the Web proxy uses its normal TTL computation mechanism for the object, which uses an "Expires" or "Cache-Control: max-age" HTTP header if available. Otherwise, the Web proxy estimates a good TTL value based on the time that has elapsed since the object was last modified.

In addition to the preceding flags, you can set one or more of the following flags:

fpcFetchSynchronous
The method does not return to the caller until the fetch has completed and you have stored the object in the cache, or until an error occurs in the processing of the request. Such an error ends the operation. If you do not specify this flag, the method returns immediately and the fetch completes asynchronously to the caller, in which case it is not possible to determine whether the fetch completed successfully.
fpcFetchForceCache
Cache the object even if the caching rules in the HTTP specification normally prohibit this object from being cached; for example, if the object contains a "Cache-Control: no-cache" HTTP header or the response indicates a server error. Be careful when using this flag for objects that were authored by another party. There is often a good reason why the data could not be cached and caching it might cause the site to function improperly or might even be a violation of your license agreement for use of the data. If the CacheUrl parameter contains a question mark, this flag alone will not allow the object to be cached.

Return Values

This method has no return values. If the call is unsuccessful, an error is raised that can be intercepted by using an error handler.

Remarks

To retrieve an HTTP object in response to a FetchUrl call, the Web proxy uses the normal HTTP GET method to the URL specified by FetchUrl. If there is already a cached copy (which was either loaded into the proxy server previously by normal operations or by an earlier call to FetchUrl) of the URL specified by CacheUrl, the Web proxy will include an If-Modified-Since header in the request (such a request is known as a conditional GET request). The response to a conditional GET may be either a new copy of the data, which will be stored in the cache, or a 304 (Not Modified) response, which will cause the Web proxy to extend the TTL of the object without changing the contents of the data in the cache.

To delete an object from the cache, set FetchUrl to an empty string, and set CacheUrl to the URL of the object to remove from the cache. When you delete an object using FetchUrl, you can perform the operation synchronously or asynchronously, and the TTL must be set to 0.

The DeleteURL VBScript provided with ISA Server in the folder SDK\samples\admin\scripts demonstrates how to delete a cached object.

Note ERROR_INTERNET_UNABLE_TO_CACHE_FILE (decimal value 12158, hex value 2F7E) is a new value that is not present in all versions of the WinINet API include files. This error code is returned if the HTTP headers in the object or other factors prohibited the Web proxy from caching the object. The caller may still be able to force the object into the cache using the fpcFetchForceCache flag.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCCacheContents


FPCCacheDrive object [ISA Server 2004]

FPCCacheDrive

The FPCCacheDrive object represents a single cache drive of an ISA Server computer.

This object is typically an element of an FPCCacheDrives collection.

Click here to see the ISA Server object hierarchy.

Methods

This object has no methods.

Properties

The FPCCacheDrive object has the following properties.

Property | Description
CacheLimitInMegs | Gets or sets the disk size, in megabytes, allocated to the cache.
Name | Gets the name of the drive.

Remarks

This object implements the IFPCCacheDrive interface.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

COM Objects


IFPCCacheDrive | FPCCacheDrive CacheLimitInMegs property [ISA Server 2004]

CacheLimitInMegs Property of IFPCCacheDrive[C++]

FPCCacheDrive.CacheLimitInMegs [Visual Basic]

[C++]

The CacheLimitInMegs property gets or sets the disk size allocated to the cache.

HRESULT get_CacheLimitInMegs(
  long* plLimit
);

HRESULT put_CacheLimitInMegs(
  long lLimit
);

Parameters

plLimit
Pointer to a variable that on return receives a 32-bit integer that specifies the disk size allocated to the cache, in megabytes.
lLimit
A 32-bit integer that specifies the disk size allocated to the cache, in megabytes.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write. Its default value is 0.

Settng this property to a nonzero value for any drive automatically enables the cache. To disable the cache, the CacheLimitInMegs property must be set to 0 for all drives.

When you change the cache allocation, and have saved changes by using the Save method, the Microsoft Firewall service must be restarted for your change to take effect. To stop and restart the Firewall service, use the RestartServices method of the IFPCArray interface.

[Visual Basic]

The CacheLimitInMegs property gets or sets the disk size allocated to the cache.

Property CacheLimitInMegs As Long

Property Value

A 32-bit integer that specifies the disk size allocated to the cache, in megabytes.

Remarks

This property is read/write. Its default value is 0.

Settng this property to a nonzero value for any drive automatically enables the cache. To disable the cache, the CacheLimitInMegs property must be set to 0 for all drives.

When you change the cache allocation, and have saved changes by using the Save method, the Microsoft Firewall service must be restarted for your change to take effect. To stop and restart the Firewall service, use the RestartServices method of the FPCArray interface.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCCacheDrive


IFPCCacheDrive | FPCCacheDrive Name(BSTR) property [ISA Server 2004]

Name Property of IFPCCacheDrive[C++]

FPCCacheDrive.Name [Visual Basic]

[C++]

The Name property gets the name of the drive; for example, "C:" or "D:".

HRESULT get_Name(
  BSTR* pbstrName
);

Parameters

pbstrName
Pointer to a BSTR that is set on return to a string value specifying the name of the drive.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The Name property gets the name of the drive; for example, "C:" or "D:".

Property Name As String

Property Value

String that specifies the name of the drive.

Remarks

This property is read-only.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCCacheDrive


FPCCacheDrives collection [ISA Server 2004]

FPCCacheDrives Collection

The FPCCacheDrives collection holds a set of FPCCacheDrive objects that represent the cache drives on an ISA Server computer. This collection can be accessed through the CacheDrives property of an FPCServer object.

Click here to see the ISA Server object hierarchy.

Inheritance

This collection inherits from the FPCPersist object, which contains methods and properties related to the persistent storage of an object's data. They include methods for exporting the object's data to and importing it from an XML document.

Methods

The FPCCacheDrives collection defines the following methods.

Method | Description
Add | Creates a new FPCCacheDrive object in the collection and returns a reference to it.
Item | Retrieves the requested FPCCacheDrive object from the collection.
Remove | Removes the specified FPCCacheDrive object from the collection.

Properties

The FPCCacheDrives collection has the following properties.

Property | Description
_NewEnum | Gets an enumerator object for the collection.
Count | Gets the number of FPCCacheDrive objects in the collection.
TotalCacheInMegs | Gets the total size, in megabytes, allocated to the cache in all drives.

Methods Inherited from FPCPersist

Name | Description
CancelWaitForChanges | Cancels the registration established by the WaitForChanges method (for use in C and C++ programming only).
CanImport | Returns a Boolean value that indicates whether the properties of the collection and its elements can be imported from the specified XML document.
Export | Writes the stored values of all the properties of the collection and its elements to the specified XML document.
ExportToFile | Writes the stored values of all the properties of the collection and its elements to the specified XML file.
GetServiceRestartMask | Retrieves a 32-bit bitmask of the FpcServices enumerated type that specifies which services need to be restarted for currently unsaved changes to take effect.
Import | Copies the values of all the properties of the collection and its elements from the specified XML document to persistent storage.
ImportFromFile | Copies the values of all the properties of the collection and its elements from the specified XML file to persistent storage.
LoadDocProperties | Provides the XML document's properties so that you can know what information can be imported from the document.
Refresh | Reads the values of all the properties of the collection and its elements from persistent storage, overwriting any changes that have not been saved.
Save | Writes the current values of all the properties of the collection and its elements to persistent storage.
WaitForChanges | Registers to wait for an event indicating that the contents of the object have changed (for use in C and C++ programming only).

Properties Inherited from FPCPersist

Name | Description
PersistentName | Gets the persistent name of the collection. The persistent name of an object is a name that is unique for the object at the respective level of the COM object hierarchy.
VendorParametersSets | Gets an FPCVendorParametersSets collection that can hold sets of custom data for extending the collection.

Remarks

This collection implements the IFPCCacheDrives interface.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

COM Objects


IFPCCacheDrives | FPCCacheDrives _NewEnum(IUnknown) property [ISA Server 2004]

_NewEnum Property of IFPCCacheDrives[C++]

FPCCacheDrives._NewEnum [Visual Basic]

[C++]

The _NewEnum property gets an enumerator object for the collection. An enumerator object provides serial access to the elements of the collection.

HRESULT get__NewEnum(
  IUnknown* ppEnum
);

Parameters

ppEnum
Address of an interface pointer that on return points to the IUnknown interface of an enumerator object that implements an IEnumVARIANT interface for the collection. An interface pointer to the IEnumVARIANT interface of the enumerator object can be retrieved by calling QueryInterface on the IUnknown interface returned.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The _NewEnum property gets an enumerator object for the collection. An enumerator object provides serial access to the elements of the collection.

Property _NewEnum As IUnknown

Property Value

Reference to an enumerator object that provides serial access to the elements of the collection.

Remarks

This property is read-only.

In Visual Basic and VBScript, this property is used implicitly in For Each...In...Next constructs.

Example Code

This VBScript script displays the disk size, in megabytes, allocated to the cache for each cache drive on the local ISA Server computer. It does not include error handling.

' Create the root object.
Dim root  ' The FPCLib.FPC root object
Set root = CreateObject("FPC.Root")

' Declare the other objects needed.
Dim server       ' An FPCServer object
Dim cachedrives  ' An FPCCacheDrives collection
Dim cachedrive   ' An FPCCacheDrive object

' Get references to the server object
' and the cache drives collection.
Set server = root.GetContainingServer()
Set cachedrives = server.CacheDrives

' Display the disk size, in megabytes, allocated to the cache
' for each cache drive.
For Each cachedrive In cachedrives
    WScript.Echo cachedrive.Name & " " & cachedrive.CacheLimitInMegs
Next

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCCacheDrives


IFPCCacheDrives | FPCCacheDrives Add (3 Parameters) method [ISA Server 2004]

IFPCCacheDrives::Add[C++]

FPCCacheDrives.Add [Visual Basic]

[C++]

The Add method creates a new FPCCacheDrive object in the collection and returns a reference to it. The Save method must be called for the additional FPCCacheDrive object to be saved to persistent storage.

An ISA Server cache drive must be in NTFS format, and have a minimum size of 5 megabytes.

HRESULT Add(
  BSTR Name,
  long CacheLimitInMegs,
  IFPCCacheDrive** ppNewCacheDrive
);

Parameters

Name
[in] Required. BSTR that specifies the name of the new cache drive, such as "C:".
CacheLimitInMegs
[in] Required. A 32-bit integer that specifies the size, in megabytes, allocated to the cache in this particular drive.
ppNewCacheDrive
[out] Address of an interface pointer that on return points to the new IFPCCacheDrive interface added.

Return Values

This method can return one of the following:

  • S_OK, indicating that the operation succeeded.
  • An error code, indicating that the operation failed. In this case, the [out] parameter returned is a null object.

Remarks

When you add a drive to the FPCCacheDrives collection, and have saved changes by using the Save method, the Microsoft Firewall service must be restarted for your change to take effect. To stop and restart the Firewall service, use the IFPCArray::RestartServices method.

[Visual Basic]

The Add method creates a new FPCCacheDrive object in the collection and returns a reference to it. The Save method must be called for the additional FPCCacheDrive object to be saved to persistent storage.

An ISA Server cache drive must be in NTFS format, and have a minimum size of 5 megabytes.

Function Add( _
  ByVal Name As String, _
  ByVal CacheLimitInMegs As Long _
) As FPCCacheDrive

Parameters

Name
[in] Required. String that specifies the name of the new cache drive, such as "C:".
CacheLimitInMegs
[in] Required. A 32-bit integer that specifies the size, in megabytes, allocated to the cache in this particular drive.

Return Values

This method returns a reference to the FPCCacheDrive object added if the call is successful. Otherwise, an error is raised that can be intercepted by using an error handler.

Remarks

When you add a drive to the FPCCacheDrives collection, and have saved changes by using the Save method, the Microsoft Firewall service must be restarted for your change to take effect. To stop and restart the Firewall service, use the FPCArray.RestartServices method.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCCacheDrives


IFPCCacheDrives | FPCCacheDrives Count(long) property [ISA Server 2004]

Count Property of IFPCCacheDrives[C++]

FPCCacheDrives.Count [Visual Basic]

[C++]

The Count property gets the number of FPCCacheDrive objects in the collection.

HRESULT get_Count(
  long* plCount
);

Parameters

plCount
Pointer to a variable that on return receives a 32-bit integer specifying the number of FPCCacheDrive objects in the collection.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The Count property gets the number of FPCCacheDrive objects in the collection.

Property Count As Long

Property Value

A 32-bit integer that specifies the number of FPCCacheDrive objects in the collection.

Remarks

This property is read-only.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCCacheDrives


IFPCCacheDrives | FPCCacheDrives Item (2 Parameters) method [ISA Server 2004]

IFPCCacheDrives::Item[C++]

FPCCacheDrives.Item [Visual Basic]

[C++]

The Item method retrieves the requested IFPCCacheDrive interface from the collection.

HRESULT Item(
  VARIANT Index,
  IFPCCacheDrive** ppItem
);

Parameters

Index
[in] Required. Name or one-based index of the object to retrieve.
ppItem
[out] Address of an interface pointer that on return points to the IFPCCacheDrive interface requested.

Return Values

This method can return one of the following:

  • S_OK, indicating that the operation succeeded.
  • An error code, indicating that the operation failed. In this case, the [out] parameter returned is a null object.
[Visual Basic]

The Item method retrieves the requested FPCCacheDrive object from the collection.

Function Item( _
  ByVal Index As Variant _
) As FPCCacheDrive

Parameters

Index
[in] Required. Name or one-based index of the object to retrieve.

Return Values

This method returns a reference to the FPCCacheDrive object requested if successful. Otherwise, an error is raised that can be intercepted by using an error handler.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCCacheDrives


IFPCCacheDrives | FPCCacheDrives Remove(Variant) method [ISA Server 2004]

IFPCCacheDrives::Remove[C++]

FPCCacheDrives.Remove [Visual Basic]

[C++]

The Remove method removes the specified FPCCacheDrive object from the collection.

HRESULT Remove(
  VARIANT Index
);

Parameters

Index
[in] Required. Name or one-based index of the FPCCacheDrive object to remove.

Return Values

This method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

When you remove a cache drive from the FPCCacheDrives collection, and have saved changes by using the Save method, the Microsoft Firewall service must be restarted for your change to take effect. To stop and restart the Firewall service, use the IFPCArray::RestartServices method.

[Visual Basic]

The Remove method removes the specified FPCCacheDrive object from the collection.

Sub Remove( _
  ByVal Index As Variant _
)

Parameters

Index
[in] Required. Name or one-based index of the FPCCacheDrive object to remove.

Return Values

This method has no return values. If the call is unsuccessful, an error is raised that can be intercepted by using an error handler.

Remarks

When you remove a cache drive from the FPCCacheDrives collection, and have saved changes by using the Save method, the Microsoft Firewall service must be restarted for your change to take effect. To stop and restart the Firewall service, use the FPCArray.RestartServices method.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCCacheDrives


IFPCCacheDrives | FPCCacheDrives TotalCacheInMegs property [ISA Server 2004]

TotalCacheInMegs Property of IFPCCacheDrives[C++]

FPCCacheDrives.TotalCacheInMegs [Visual Basic]

[C++]

The TotalCacheInMegs property gets the total size, in megabytes, allocated to the cache in all drives.

HRESULT get_TotalCacheInMegs(
  long* plSize
);

Parameters

plSize
Pointer to a 32-bit integer that is set on return to a long value specifying the total size, in megabytes, allocated to the cache in all drives.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The TotalCacheInMegs property gets the total size, in megabytes, allocated to the cache in all drives.

Property TotalCacheInMegs As Long

Property Value

A 32-bit integer that specifies the total size, in megabytes, allocated to the cache in all drives.

Remarks

This property is read-only.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCCacheDrives


FPCCacheRule object [ISA Server 2004]

FPCCacheRule

The FPCCacheRule object represents a single cache rule. A cache rule defines cache policy for all content or specific content groups, including:

  • How objects are provided from the cache.
  • Whether objects should be stored in the cache.
  • The size of objects that can be stored in the cache.
  • Whether Secure Sockets Layer (SSL) responses will be stored in the cache.
  • HTTP cache configuration through the FPCHTTPCacheConfiguration object.
  • FTP cache configuration through the FPCFTPCacheConfiguration object.

This object is typically an element of an FPCCacheRules collection.

Click here to see the ISA Server object hierarchy.

Inheritance

This object inherits from the FPCPersist object, which contains methods and properties related to the persistent storage of an object's data. They include methods for exporting the object's data to and importing it from an XML document.

Methods

The FPCCacheRule object defines the following method.

Method | Description
SetSizeBound | Sets the minimum or maximum size of the objects that can be cached.

Properties

The FPCCacheRule object has the following properties.

Property | Description
CacheAuthenticatedContent | Gets or sets a Boolean value that indicates whether content supplied after user authentication through the proxy will be cached.
CacheContentForOfflineBrowsing | Gets or sets a Boolean value that indicates whether responses will be cached for offline browsing.
CacheDynamicContent | Gets or sets a Boolean value that indicates whether dynamic responses will be cached.
CacheSSLResponses | Gets or sets a Boolean value that indicates whether responses are cached when the incoming or outgoing request uses SSL.
Description | Gets or sets the description of the rule.
DestinationDomainNameSets | Gets an FPCRefs collection that contains references to the FPCDomainNameSet collections defining the domain name sets to which the rule applies as destinations for requests.
DestinationSelectionIPs | Gets an FPCSelectionIPs object that specifies the complete set of destination IP addresses to which the rule applies.
Enabled | Gets or sets a Boolean value that indicates whether the rule is enabled.
FTPConfiguration | Gets an FPCFTPCacheConfiguration object that defines the FTP cache configuration.
HTTPConfiguration | Gets an FPCHTTPCacheConfiguration object that defines the HTTP cache configuration.
IsDefault | Gets a Boolean value that indicates whether the rule is preinstalled and cannot be deleted.
Name | Gets or sets the name of the cache rule.
NeverCacheResponse | Gets or sets a Boolean value that indicates whether responses will never be cached.
ObjectSizeLimit | Gets the maximum size of an object that can be cached.
ObjectSizeLimitEnabled | Gets a Boolean value that indicates whether the object size limit is enabled.
ObjectSizeLimitUnits | Gets a value from the FpcSizeUnits enumerated type that specifies the units in which the ObjectSizeLimit property is expressed.
Order | Gets the ordinal position of the rule in the list of cache rules, which corresponds to their order of application.
URLSets | Gets an FPCRefs collection that contains references to the FPCURLSet collections defining the URL sets to which the rule applies.
UseCacheCondition | Gets or sets a value from the FpcCacheAction enumerated type that specifies the conditions under which an object should be retrieved from the cache.

Methods Inherited from FPCPersist

Name | Description
CancelWaitForChanges | Cancels the registration established by the WaitForChanges method (for use in C and C++ programming only).
CanImport | Returns a Boolean value that indicates whether the object's properties can be imported from the specified XML document.
Export | Recursively writes the stored values of all the properties of the object and its subobjects to the specified XML document.
ExportToFile | Recursively writes the stored values of all the properties of the object and its subobjects to the specified XML file.
GetServiceRestartMask | Retrieves a 32-bit bitmask of the FpcServices enumerated type that specifies which services need to be restarted for currently unsaved changes to take effect.
Import | Recursively copies the values of all the properties of the object and of its subobjects from the specified XML document to persistent storage.
ImportFromFile | Recursively copies the values of all the properties of the object and of its subobjects from the specified XML file to persistent storage.
LoadDocProperties | Provides the XML document's properties so that you can know what information can be imported from the document.
Refresh | Recursively reads the values of all the properties of the object and of its subobjects from persistent storage, overwriting any changes that have not been saved.
Save | Recursively writes the current values of all the properties of the object and its subobjects to persistent storage.
WaitForChanges | Registers to wait for an event indicating that the contents of the object have changed (for use in C and C++ programming only).

Properties Inherited from FPCPersist

Name | Description
PersistentName | Gets the persistent name of the object. The persistent name of an object is a name that is unique for the object at the respective level of the COM object hierarchy.
VendorParametersSets | Gets an FPCVendorParametersSets collection that can hold sets of custom data for extending the object.

Remarks

This object implements the IFPCCacheRule interface.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

COM Objects


IFPCCacheRule.CacheAuthenticatedContent property [ISA Server 2004]

CacheAuthenticatedContent Property of IFPCCacheRule[C++]

FPCCacheRule.CacheAuthenticatedContent [Visual Basic]

[C++]

The CacheAuthenticatedContent property gets or sets a Boolean value that indicates whether content supplied after user authentication through the proxy will be cached.

HRESULT get_CacheAuthenticatedContent(
  VARIANT_BOOL* pfCacheAuthenticatedContent
);

HRESULT put_CacheAuthenticatedContent(
  VARIANT_BOOL fCacheAuthenticatedContent
);

Parameters

pfCacheAuthenticatedContent
Pointer to a Boolean variable that is set on return to VARIANT_TRUE if content supplied after user authentication through the proxy will be cached, or to VARIANT_FALSE if content supplied after user authentication through the proxy will not be cached.
fCacheAuthenticatedContent
Boolean value that indicates whether content supplied after user authentication through the proxy will be cached.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write. By default, content supplied after user authentication through the proxy for retrieval will not be cached.

[Visual Basic]

The CacheAuthenticatedContent property gets or sets a Boolean value that indicates whether content supplied after user authentication through the proxy will be cached.

Property CacheAuthenticatedContent As Boolean

Property Value

Boolean value that indicates whether content supplied after user authentication through the proxy will be cached.

Remarks

This property is read/write. By default, content supplied after user authentication through the proxy for retrieval will not be cached.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCCacheRule


IFPCCacheRule.CacheContentForOfflineBrowsing property [ISA Server 2004]

CacheContentForOfflineBrowsing Property of IFPCCacheRule[C++]

FPCCacheRule.CacheContentForOfflineBrowsing [Visual Basic]

[C++]

The CacheContentForOfflineBrowsing property gets or sets a Boolean value that indicates whether responses will be cached for offline browsing.

HRESULT get_CacheContentForOfflineBrowsing(
  VARIANT_BOOL* pfCacheContentForOfflineBrowsing
);

HRESULT put_CacheContentForOfflineBrowsing(
  VARIANT_BOOL fCacheContentForOfflineBrowsing
);

Parameters

pfCacheContentForOfflineBrowsing
Pointer to a Boolean variable that is set on return to VARIANT_TRUE if responses will be cached for offline browsing, or to VARIANT_FALSE if responses will not be cached for offline browsing.
fCacheContentForOfflineBrowsing
Boolean value that indicates whether responses will be cached for offline browsing.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write.

[Visual Basic]

The CacheContentForOfflineBrowsing property gets or sets a Boolean value that indicates whether responses will be cached for offline browsing.

Property CacheContentForOfflineBrowsing As Boolean

Property Value

Boolean value that indicates whether responses will be cached for offline browsing.

Remarks

This property is read/write.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCCacheRule


IFPCCacheRule | FPCCacheRule CacheDynamicContent property [ISA Server 2004]

CacheDynamicContent Property of IFPCCacheRule[C++]

FPCCacheRule.CacheDynamicContent [Visual Basic]

[C++]

The CacheDynamicContent property gets or sets a Boolean value that indicates whether dynamic responses will be cached.

HRESULT get_CacheDynamicContent(
  VARIANT_BOOL* pfCacheDynamicContent
);

HRESULT put_CacheDynamicContent(
  VARIANT_BOOL fCacheDynamicContent
);

Parameters

pfCacheDynamicContent
Pointer to a Boolean variable that is set on return to VARIANT_TRUE if dynamic responses will be cached, or to VARIANT_FALSE if dynamic responses will not be cached.
fCacheDynamicContent
Boolean value that indicates whether dynamic responses will be cached.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write.

[Visual Basic]

The CacheDynamicContent property gets or sets a Boolean value that indicates whether dynamic responses will be cached.

Property CacheDynamicContent As Boolean

Property Value

Boolean value that indicates whether dynamic responses will be cached.

Remarks

This property is read/write.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCCacheRule


IFPCCacheRule | FPCCacheRule CacheSSLResponses property [ISA Server 2004]

CacheSSLResponses Property of IFPCCacheRule[C++]

FPCCacheRule.CacheSSLResponses [Visual Basic]

[C++]

The CacheSSLResponses property gets or sets a Boolean value that indicates whether responses will be cached when either the incoming or outgoing request uses Secure Sockets Layer (SSL). SSL responses can only be cached in an SSL bridging scenario. For more information, see the product documentation.

HRESULT get_CacheSSLResponses(
  VARIANT_BOOL* pfCacheSSL
);

HRESULT put_CacheSSLResponses(
  VARIANT_BOOL fCacheSSL
);

Parameters

pfCacheSSL
Pointer to a Boolean variable that is set on return to VARIANT_TRUE if SSL responses will be cached, or to VARIANT_FALSE if SSL responses will not be cached.
fCacheSSL
Boolean value that indicates whether SSL responses will be cached.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write.

The default is VARIANT_TRUE (SSL responses will be cached).

[Visual Basic]

The CacheSSLResponses property gets or sets a Boolean value that indicates whether responses will be cached when either the incoming or outgoing request uses Secure Sockets Layer (SSL). SSL responses can only be cached in an SSL bridging scenario. For more information, see the product documentation.

Property CacheSSLResponses As Boolean

Property Value

Boolean value that indicates whether SSL responses will be cached.

Remarks

This property is read/write.

The default is True (SSL responses will be cached).

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCCacheRule


IFPCCacheRule | FPCCacheRule Description(BSTR,BSTR) property [ISA Server 2004]

Description Property of IFPCCacheRule[C++]

FPCCacheRule.Description [Visual Basic]

[C++]

The Description property gets or sets the description of the cache rule.

HRESULT get_Description(
  BSTR** pbstrDescription
);

HRESULT put_Description(
  BSTR bstrDescription
);

Parameters

pbstrDescription
Pointer to a BSTR that is set on return to a string value specifying the description of the cache rule.
bstrDescription
BSTR that specifies the description of the cache rule.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write.

[Visual Basic]

The Description property gets or sets the description of the cache rule.

Property Description As String

Property Value

String that specifies the description of the cache rule.

Remarks

This property is read/write.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCCacheRule


IFPCCacheRule.DestinationDomainNameSets(IFPCRefs) property [ISA Server 2004]

DestinationDomainNameSets Property of IFPCCacheRule[C++]

FPCCacheRule.DestinationDomainNameSets [Visual Basic]

[C++]

The DestinationDomainNameSets property gets an FPCRefs collection that contains references to the FPCDomainNameSet collections defining the domain name sets to which the rule applies as destinations for requests.

HRESULT get_DestinationDomainNameSets(
  IFPCRefs** ppRefs
);

Parameters

ppRefs
Address of a variable that receives a pointer to an IFPCRefs interface that represents the collection of references to the domain name sets to which the rule applies as destinations for requests.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only. It can be modified by calling the methods of the IFPCRefs interface retrieved.

The IncludeStatus property of each reference specifies whether the domain name set referenced is included in or excluded from the rule.

[Visual Basic]

The DestinationDomainNameSets property gets an FPCRefs collection that contains references to the FPCDomainNameSet collections defining the domain name sets to which the rule applies as destinations for requests.

Property DestinationDomainNameSets As FPCRefs

Property Value

Reference to an FPCRefs collection that contains references to the destination domain name sets to which the rule applies as destinations for requests.

Remarks

This property is read-only. It can be modified by calling the methods of the FPCRefs collection retrieved.

The IncludeStatus property of each reference specifies whether the domain name set referenced is included in or excluded from the rule.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCCacheRule


IFPCCacheRule | FPCCacheRule DestinationSelectionIPs property [ISA Server 2004]

DestinationSelectionIPs Property of IFPCCacheRule[C++]

FPCCacheRule.DestinationSelectionIPs [Visual Basic]

[C++]

The DestinationSelectionIPs property gets an FPCSelectionIPs object that specifies the complete set of destination IP addresses to which the rule applies. This set may include computers, networks, network sets, subnets, or IP address ranges.

HRESULT get_DestinationSelectionIPs(
  IFPCSelectionIPs** ppSelectionIPs
);

Parameters

ppSelectionIPs
Address of an interface pointer that on return points to an IFPCSelectionIPs interface that represents the complete set of destination IP addresses to which the rule applies.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only. It can be modified through the properties of the IFPCSelectionIPs interface retrieved.

[Visual Basic]

The DestinationSelectionIPs property gets an FPCSelectionIPs object that specifies the complete set of destination IP addresses to which the rule applies. This set may include computers, networks, network sets, subnets, or IP address ranges.

Property DestinationSelectionIPs As FPCSelectionIPs

Property Value

Reference to an FPCSelectionIPs object that specifies the complete set of destination IP addresses to which the rule applies.

Remarks

This property is read-only. It can be modified through the properties of the FPCSelectionIPs object retrieved.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCCacheRule


IFPCCacheRule | FPCCacheRule Enabled (2 Parameters) property [ISA Server 2004]

Enabled Property of IFPCCacheRule[C++]

FPCCacheRule.Enabled [Visual Basic]

[C++]

The Enabled property gets or sets a Boolean value that indicates whether the rule is enabled.

HRESULT get_Enabled(
  VARIANT_BOOL* pfEnabled
);

HRESULT put_Enabled(
  VARIANT_BOOL fEnabled
);

Parameters

pfEnabled
Pointer to a Boolean variable that is set on return to VARIANT_TRUE if the rule is enabled, or to VARIANT_FALSE if the rule is disabled.
fEnabled
Boolean value that indicates whether the rule is enabled.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write.

[Visual Basic]

The Enabled property gets or sets a Boolean value that indicates whether the rule is enabled.

Property Enabled As Boolean

Property Value

Boolean value that indicates whether the rule is enabled.

Remarks

This property is read/write.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCCacheRule


IFPCCacheRule | FPCCacheRule FTPConfiguration property [ISA Server 2004]

FTPConfiguration Property of IFPCCacheRule[C++]

FPCCacheRule.FTPConfiguration [Visual Basic]

[C++]

The FTPConfiguration property gets an FPCFTPCacheConfiguration object that defines the FTP cache configuration.

HRESULT get_FTPConfiguration(
  IFPCFTPCacheConfiguration** ppCacheConfiguration
);

Parameters

ppCacheConfiguration
Address of an interface pointer that on return points to an IFPCFTPCacheConfiguration interface that represents the FTP cache configuration.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only. The FTP cache configuration can be modified by calling the properties of the IFPCFTPCacheConfiguration interface retrieved.

[Visual Basic]

The FTPConfiguration property gets an FPCFTPCacheConfiguration object that defines the FTP cache configuration.

Property FTPConfiguration As FPCFTPCacheConfiguration

Property Value

Reference to an FPCFTPCacheConfiguration object that defines the FTP cache configuration.

Remarks

This property is read-only. The FTP cache configuration can be modified by calling the properties of the FPCFTPCacheConfiguration object retrieved.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCCacheRule


IFPCCacheRule | FPCCacheRule HTTPConfiguration property [ISA Server 2004]

HTTPConfiguration Property of IFPCCacheRule[C++]

FPCCacheRule.HTTPConfiguration [Visual Basic]

[C++]

The HTTPConfiguration property gets an FPCHTTPCacheConfiguration object that defines the HTTP cache configuration.

HRESULT get_HTTPConfiguration(
  IFPCHTTPCacheConfiguration** ppHTTPCacheConfiguration
);

Parameters

ppHTTPCacheConfiguration
Address of an interface pointer that on return points to an IFPCHTTPCacheConfiguration interface that represents the HTTP cache configuration.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only. The HTTP cache configuration can be modified by calling the properties of the IFPCHTTPCacheConfiguration interface retrieved.

[Visual Basic]

The HTTPConfiguration property gets an FPCHTTPCacheConfiguration object that defines the HTTP cache configuration.

Property HTTPConfiguration As FPCHTTPCacheConfiguration

Property Value

Reference to an FPCHTTPCacheConfiguration object that defines the HTTP cache configuration.

Remarks

This property is read-only. The HTTP cache configuration can be modified by calling the properties of the FPCHTTPCacheConfiguration object retrieved.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCCacheRule


IFPCCacheRule | FPCCacheRule IsDefault(VARIANT_BOOL) property [ISA Server 2004]

IsDefault Property of IFPCCacheRule[C++]

FPCCacheRule.IsDefault [Visual Basic]

[C++]

The IsDefault property gets a Boolean value that indicates whether the rule is a default (preinstalled) rule that cannot be deleted. The properties of a default rule cannot be changed.

HRESULT get_IsDefault(
  VARIANT_BOOL* pfPreInstalled
);

Parameters

pfPreInstalled
Pointer to a Boolean variable that is set on return to VARIANT_TRUE if the rule is preinstalled, or to VARIANT_FALSE if the rule is user-defined.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The IsDefault property gets a Boolean value that indicates whether the rule is a default (preinstalled) rule that cannot be deleted. The properties of a default rule cannot be changed.

Property IsDefault As Boolean

Property Value

Boolean value that indicates whether the rule is preinstalled.

Remarks

This property is read-only.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCCacheRule


IFPCCacheRule | FPCCacheRule Name(BSTR,BSTR) property [ISA Server 2004]

Name Property of IFPCCacheRule[C++]

FPCCacheRule.Name [Visual Basic]

[C++]

The Name property gets or sets the name of the cache rule.

HRESULT get_Name(
  BSTR* pbstrName
);

HRESULT put_Name(
  BSTR bstrName
);

Parameters

pbstrName
Pointer to a BSTR that is set on return to a string value specifying the name of the cache rule.
bstrName
BSTR that specifies the name of the cache rule.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write.

[Visual Basic]

The Name property gets or sets the name of the cache rule.

Property Name As String

Property Value

String that specifies the name of the cache rule.

Remarks

This property is read/write.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCCacheRule


IFPCCacheRule | FPCCacheRule NeverCacheResponse property [ISA Server 2004]

NeverCacheResponse Property of IFPCCacheRule[C++]

FPCCacheRule.NeverCacheResponse [Visual Basic]

[C++]

The NeverCacheResponse property gets or sets a Boolean value that indicates whether responses will never be cached.

HRESULT get_NeverCacheResponse(
  VARIANT_BOOL* pfNeverCacheResponse
);

HRESULT put_NeverCacheResponse(
  VARIANT_BOOL fNeverCacheResponse
);

Parameters

pfNeverCacheResponse
Pointer to a Boolean variable that is set on return to VARIANT_TRUE if responses will never be cached, or to VARIANT_FALSE if responses may be cached.
fNeverCacheResponse
Boolean value that indicates whether responses will never be cached.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write.

[Visual Basic]

The NeverCacheResponse property gets or sets a Boolean value that indicates whether responses will never be cached.

Property NeverCacheResponse As Boolean

Property Value

Boolean value that indicates whether responses will never be cached.

Remarks

This property is read/write.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCCacheRule


IFPCCacheRule | FPCCacheRule ObjectSizeLimit(long) property [ISA Server 2004]

ObjectSizeLimit Property of IFPCCacheRule[C++]

FPCCacheRule.ObjectSizeLimit [Visual Basic]

[C++]

The ObjectSizeLimit property gets the maximum size of an object that can be cached. The size consists of this numerical value and the units defined in the ObjectSizeLimitUnits property.

HRESULT get_ObjectSizeLimit(
  long* pSizeLimit
);

Parameters

pSizeLimit
Pointer to a variable that on return receives a 32-bit integer specifying the maximum size of an object that can be cached.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only. It can be set using the SetSizeBound method.

[Visual Basic]

The ObjectSizeLimit property gets the maximum size of an object that can be cached. The size consists of this numerical value and the units defined in the ObjectSizeLimitUnits property.

Property ObjectSizeLimit As Long

Property Value

A 32-bit integer that specifies the maximum size of an object that can be cached.

Remarks

This property is read-only. It can be set using the SetSizeBound method.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCCacheRule


IFPCCacheRule | FPCCacheRule ObjectSizeLimitEnabled property [ISA Server 2004]

ObjectSizeLimitEnabled Property of IFPCCacheRule[C++]

FPCCacheRule.ObjectSizeLimitEnabled [Visual Basic]

[C++]

The ObjectSizeLimitEnabled property gets a Boolean value that indicates whether the object size limit specified in the ObjectSizeLimit property is enabled.

HRESULT get_ObjectSizeLimitEnabled(
  VARIANT_BOOL* pfEnabled
);

Parameters

pfEnabled
Pointer to a Boolean variable that is set on return to VARIANT_TRUE if the object size limit is enabled, or to VARIANT_FALSE if the object size limit is disabled.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only. It can be set using the SetSizeBound method.

[Visual Basic]

The ObjectSizeLimitEnabled property gets a Boolean value that indicates whether the object size limit specified in the ObjectSizeLimit property is enabled.

Property ObjectSizeLimitEnabled As Boolean

Property Value

Boolean value that indicates whether the object size limit is enabled.

Remarks

This property is read-only. It can be set using the SetSizeBound method.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCCacheRule


IFPCCacheRule | FPCCacheRule ObjectSizeLimitUnits property [ISA Server 2004]

ObjectSizeLimitUnits Property of IFPCCacheRule[C++]

FPCCacheRule.ObjectSizeLimitUnits [Visual Basic]

[C++]

The ObjectSizeLimitUnits property gets a value from the FpcSizeUnits enumerated type that specifies the units in which the ObjectSizeLimit property is expressed.

HRESULT get_ObjectSizeLimitUnits(
  FpcSizeUnits* pSizeUnits
);

Parameters

pSizeUnits
Pointer to a variable that on return receives a value from the FpcSizeUnits enumeration specifying the units in which the ObjectSizeLimit property is expressed.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only. It can be set by calling the SetSizeBound method.

[Visual Basic]

The ObjectSizeLimitUnits property gets a value from the FpcSizeUnits enumerated type that specifies the units in which the ObjectSizeLimit property is expressed.

Property ObjectSizeLimitUnits As FpcSizeUnits

Property Value

A value from the FpcSizeUnits enumeration that specifies the units in which the ObjectSizeLimit property is expressed.

Remarks

This property is read-only. It can be set by calling the SetSizeBound method.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCCacheRule


IFPCCacheRule | FPCCacheRule Order(long) property [ISA Server 2004]

Order Property of IFPCCacheRule[C++]

FPCCacheRule.Order [Visual Basic]

[C++]

The Order property gets the ordinal position of the rule in the list of cache rules, which corresponds to their order of application.

HRESULT get_Order(
  long* plOrder
);

Parameters

plOrder
Pointer to a variable that on return receives a 32-bit integer specifying the ordinal position of the rule in the list of cache rules.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only. It can be modified by calling the MoveDown and MoveUp methods of the FPCCacheRules collection. Because these methods change the ordinal positions of more than one rule in the collection, the Save method must be called on the collection to write the changes to persistent storage.

[Visual Basic]

The Order property gets the ordinal position of the rule in the list of cache rules, which corresponds to their order of application.

Property Order As Long

Property Value

A 32-bit integer that specifies the ordinal position of the rule in the list of cache rules.

Remarks

This property is read-only. It can be modified by calling the MoveDown and MoveUp methods of the FPCCacheRules collection. Because these methods change the ordinal positions of more than one rule in the collection, the Save method must be called on the collection to write the changes to persistent storage.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCCacheRule


IFPCCacheRule | FPCCacheRule SetSizeBound method [ISA Server 2004]

IFPCCacheRule::SetSizeBound[C++]

FPCCacheRule.SetSizeBound [Visual Basic]

[C++]

The SetSizeBound method sets the size limit according to which objects can or cannot be cached.

HRESULT SetSizeBound(
  VARIANT_BOOL Enable,
  long Size,
  FpcSizeUnits Units
);

Parameters

Enable
[in] Required. Boolean value that indicates whether the size limit is enabled.
Size
[in, optional] A 32-bit integer that defines the size limit. The default value is 0.
Units
[in, optional] Value from the FpcSizeUnits enumeration that indicates whether the size limit is defined in kilobytes, megabytes, or gigabytes. The default value is fpcKB, which indicates that the size limit is defined in kilobytes.

Return Values

This method returns S_OK if the call is successful; otherwise, it returns an error code.
[Visual Basic]

The SetSizeBound method sets the size limit according to which objects can or cannot be cached.

Sub SetSizeBound( _
  ByVal Enable As Boolean, _
  [ ByVal Size As Long ], _
  [ ByVal Units As FpcSizeUnits ] _
)

Parameters

Enable
[in] Required. Boolean value that indicates whether the size limit is enabled.
Size
[in, optional] A 32-bit integer that defines the size limit. The default value is 0.
Units
[in, optional] Value from the FpcSizeUnits enumeration that indicates whether the size limit is defined in kilobytes, megabytes, or gigabytes. The default value is fpcKB, which indicates that the size limit is defined in kilobytes.

Return Values

This method has no return values. If the call is unsuccessful, an error is raised that can be intercepted by using an error handler.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCCacheRule


IFPCCacheRule | FPCCacheRule URLSets(IFPCRef) property [ISA Server 2004]

URLSets Property of IFPCCacheRule[C++]

FPCCacheRule.URLSets [Visual Basic]

[C++]

The URLSets property gets an FPCRefs collection that contains references to the FPCURLSet collections defining the URL sets to which the rule applies.

HRESULT get_URLSets(
  IFPCRef** ppRefs
);

Parameters

ppRefs
Address of a variable that on return receives a pointer to an IFPCRefs interface that represents the collection of references to the URL sets to which the rule applies.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only. It can be modified by calling the methods of the IFPCRefs interface retrieved.

The IncludeStatus property of each reference specifies whether the URL set referenced is included in or excluded from the rule.

[Visual Basic]

The URLSets property gets an FPCRefs collection that contains references to the FPCURLSet collections defining the URL sets to which the rule applies.

Property URLSets As FPCRefs

Property Value

Reference to an FPCRefs collection that contains references to the URL sets to which the rule applies.

Remarks

This property is read-only. It can be modified by calling the methods of the FPCRefs collection retrieved.

The IncludeStatus property of each reference specifies whether the URL set referenced is included in or excluded from the rule.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCCacheRule


IFPCCacheRule | FPCCacheRule UseCacheCondition property [ISA Server 2004]

UseCacheCondition Property of IFPCCacheRule[C++]

FPCCacheRule.UseCacheCondition [Visual Basic]

[C++]

The UseCacheCondition property gets or sets a value from the FpcCacheAction enumerated type that specifies the conditions under which an object should be retrieved from the cache. The possible types of cache usage behavior are:

  • If there is a valid (unexpired) version of the object in the cache, the cached object should be used. Otherwise, a new version of the object should be obtained from the Internet.
  • If any version of the object is found in the cache, the cached object should be used. Otherwise, the object should be obtained from the Internet.
  • If any version of the object is found in the cache, the cached object should be used. Otherwise, an error page should be returned, and no attempt should be made to obtain the object from the Internet.

Note This property is not available in firewall mode. For more information see How ISA Server Caching Works.

HRESULT get_UseCacheCondition(
  FpcCacheAction* pCacheAction
);

HRESULT put_UseCacheCondition(
  FpcCacheAction CacheAction
);

Parameters

pCacheAction
Pointer to a value from the FpcCacheAction enumerated type that is set on return to the value specifying the cache usage behavior.
CacheAction
Value from the FpcCacheAction enumerated type that specifies the cache usage behavior.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write.

[Visual Basic]

The UseCacheCondition property gets or sets a value from the FpcCacheAction enumerated type that specifies the conditions under which an object should be retrieved from the cache. The possible types of cache usage behavior are:

  • If there is a valid (unexpired) version of the object in the cache, the cached object should be used. Otherwise, a new version of the object should be obtained from the Internet.
  • If any version of the object is found in the cache, the cached object should be used. Otherwise, the object should be obtained from the Internet.
  • If any version of the object is found in the cache, the cached object should be used. Otherwise, an error page should be returned, and no attempt should be made to obtain the object from the Internet.

Note This property is not available in firewall mode. For more information see How ISA Server Caching Works.

Property UseCacheCondition As FpcCacheAction

Property Value

Value from the FpcCacheAction enumerated type that specifies the cache usage behavior.

Remarks

This property is read/write.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCCacheRule


FPCCacheRules collection [ISA Server 2004]

FPCCacheRules Collection

The FPCCacheRules collection holds a group of FPCCacheRule objects that represent the cache rules defined for an FPCArray object. This collection can be accessed through the CacheRules property of an FPCCacheConfiguration object.

Click here to see the ISA Server object hierarchy.

For a VBScript code example that shows how to retrieve this collection and then add new cache rules to it, see Adding Cache Rules.

Inheritance

This collection inherits from the FPCPersist object, which contains methods and properties related to persistent storage of an object's data. They include methods for exporting an object's data to and importing it from an XML document.

Methods

The FPCCacheRules collection defines the following methods.

Method | Description
Add | Creates a new FPCCacheRule object in the collection and returns a reference to it.
Item | Retrieves the requested FPCCacheRule object from the collection.
MoveDown | Moves the specified rule one step down the list of rules, which corresponds to their order of application.
MoveUp | Moves the specified rule one step up the list of rules, which corresponds to their order of application.
Remove | Removes the specified FPCCacheRule object from the collection.

Properties

The FPCCacheRules collection has the following properties.

Property | Description
_NewEnum | Gets an enumerator object for the collection.
Count | Gets the number of FPCCacheRule objects in the collection.

Methods Inherited from FPCPersist

Name | Description
CancelWaitForChanges | Cancels the registration established by the WaitForChanges method (for use in C and C++ programming only).
CanImport | Returns a Boolean value that indicates whether the properties of the collection, its elements, and their subobjects can be imported from the specified XML document.
Export | Recursively writes the stored values of all the properties of the collection, its elements, and their subobjects to the specified XML document.
ExportToFile | Recursively writes the stored values of all the properties of the collection, its elements, and their subobjects to the specified XML file.
GetServiceRestartMask | Retrieves a 32-bit bitmask of the FpcServices enumerated type that specifies which services need to be restarted for currently unsaved changes to take effect.
Import | Recursively copies the values of all the properties of the collection, its elements, and their subobjects from the specified XML document to persistent storage.
ImportFromFile | Recursively copies the values of all the properties of the collection, its elements, and their subobjects from the specified XML file to persistent storage.
LoadDocProperties | Provides the XML document's properties so that you can know what information can be imported from the document.
Refresh | Recursively reads the values of all the properties of the collection, its elements, and their subobjects from persistent storage, overwriting any changes that have not been saved.
Save | Recursively writes the current values of all the properties of the collection, its elements, and their subobjects to persistent storage.
WaitForChanges | Registers to wait for an event indicating that the contents of the object have changed (for use in C and C++ programming only).

Properties Inherited from FPCPersist

Name | Description
PersistentName | Gets the persistent name of the collection. The persistent name of an object is a name that is unique for the object at the respective level of the COM object hierarchy.
VendorParametersSets | Gets an FPCVendorParametersSets collection that can hold sets of custom data for extending the collection.

Remarks

This collection implements the IFPCCacheRules interface.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

COM Objects


IFPCCacheRules | FPCCacheRules _NewEnum(IUnknown) property [ISA Server 2004]

_NewEnum Property of IFPCCacheRules[C++]

FPCCacheRules._NewEnum [Visual Basic]

[C++]

The _NewEnum property gets an enumerator object for the collection. An enumerator object provides serial access to the elements of the collection.

HRESULT get__NewEnum(
  IUnknown* ppEnum
);

Parameters

ppEnum
Address of an interface pointer that on return points to the IUnknown interface of an enumerator object that implements an IEnumVARIANT interface for the collection. An interface pointer to the IEnumVARIANT interface of the enumerator object can be retrieved by calling QueryInterface on the IUnknown interface returned.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The _NewEnum property gets an enumerator object for the collection. An enumerator object provides serial access to the elements of the collection.

Property _NewEnum As IUnknown

Property Value

Reference to an enumerator object that provides serial access to the elements of the collection.

Remarks

This property is read-only.

In Visual Basic and VBScript, this property is used implicitly in For Each...In...Next constructs.

Example Code

This VBScript script displays the names of all the cache rules defined for an FPCArray object. It does not include error handling.

' Create the root object.
Dim root  ' The FPCLib.FPC root object
Set root = CreateObject("FPC.Root")

' Declare the other objects needed.
Dim array       ' An FPCArray object
Dim cacherules  ' An FPCCacheRules collection
Dim cacherule   ' An FPCCacheRule object

' Get references to the array object
' and the cache rules collection.
Set array = root.GetContainingArray()
Set cacherules = array.Cache.CacheConfiguration.CacheRules

' Display the names of the cache rules
' defined for the array object.
For Each cacherule In cacherules
    WScript.Echo "Cache rule name: " & cacherule.Name
Next

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCCacheRules


IFPCCacheRules | FPCCacheRules Add (2 Parameters) method [ISA Server 2004]

IFPCCacheRules::Add[C++]

FPCCacheRules.Add [Visual Basic]

[C++]

The Add method creates a new FPCCacheRule object, inserts it into the collection, and returns a reference to it.

HRESULT Add(
  BSTR Name,
  IFPCCacheRule** ppNewRule
);

Parameters

Name
[in] Required. BSTR that specifies the name of the new cache rule.
ppNewRule
[out] Address of an interface pointer that on return points to the new IFPCCacheRule interface created.

Return Values

This method can return one of the following:

  • S_OK, indicating that the operation succeeded.
  • An error code, indicating that the operation failed. In this case, the [out] parameter returned is a null object.

[Visual Basic]

The Add method creates a new FPCCacheRule object, inserts it into the collection, and returns a reference to it.

Function Add( _
  ByVal Name As String _
) As FPCCacheRule

Parameters

Name
[in] Required. String that specifies the name of the new cache rule.

Return Values

This method returns a reference to an FPCCacheRule object if successful. Otherwise, an error is raised that can be intercepted by using an error handler.

Example Code

For a VBScript code example that shows how to use this method to add new cache rules to the cache rules collection and then set their properties, see Adding Cache Rules.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCCacheRules


IFPCCacheRules | FPCCacheRules Count(long) property [ISA Server 2004]

Count Property of IFPCCacheRules[C++]

FPCCacheRules.Count [Visual Basic]

[C++]

The Count property gets the number of FPCCacheRule objects in the collection.

HRESULT get_Count(
  long* plCount
);

Parameters

plCount
Pointer to a variable that on return receives a 32-bit integer specifying the number of FPCCacheRule objects in the collection.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The Count property gets the number of FPCCacheRule objects in the collection.

Property Count As Long

Property Value

A 32-bit integer that specifies the number of FPCCacheRule objects.

Remarks

This property is read-only.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCCacheRules


IFPCCacheRules | FPCCacheRules Item (2 Parameters) method [ISA Server 2004]

IFPCCacheRules::Item[C++]

FPCCacheRules.Item [Visual Basic]

[C++]

The Item method retrieves the requested IFPCCacheRule interface from the collection.

HRESULT Item(
  VARIANT Index,
  IFPCCacheRule** ppItem
);

Parameters

Index
[in] Required. Name or one-based index of the object to retrieve.
ppItem
[out] Address of an interface pointer that on return points to the IFPCCacheRule interface requested.

Return Values

This method can return one of the following:

  • S_OK, indicating that the operation succeeded.
  • An error code, indicating that the operation failed. In this case, the [out] parameter returned is a null object.

[Visual Basic]

The Item method retrieves the requested FPCCacheRule object from the collection.

Function Item( _
  ByVal Index As Variant _
) As FPCCacheRule

Parameters

Index
[in] Required. Name or one-based index of the object to retrieve.

Return Values

This method returns a reference to the FPCCacheRule object requested if successful. Otherwise, an error is raised that can be intercepted by using an error handler.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCCacheRules


IFPCCacheRules | FPCCacheRules MoveDown(Long) method [ISA Server 2004]

IFPCCacheRules::MoveDown[C++]

FPCCacheRules.MoveDown [Visual Basic]

[C++]

The MoveDown method moves the specified rule one step down the list of rules, which corresponds to their order of application.

HRESULT MoveDown(
  long index
);

Parameters

index
[in] Required. Index (the current position indicated by the Order property) of the rule to move down.

Return Values

This method returns S_OK if the call is successful; otherwise, it returns an error code.

[Visual Basic]

The MoveDown method moves the specified rule one step down the list of rules, which corresponds to their order of application.

Sub MoveDown( _
  ByVal index As Long _
)

Parameters

index
[in] Required. Index (the current position indicated by the Order property) of the rule to move down.

Return Values

This method has no return values. If the call is unsuccessful, an error is raised that can be intercepted by using an error handler.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCCacheRules, MoveUp


IFPCCacheRules | FPCCacheRules MoveUp(Long) method [ISA Server 2004]

IFPCCacheRules::MoveUp[C++]

FPCCacheRules.MoveUp [Visual Basic]

[C++]

The MoveUp method moves the specified rule one step up the list of rules, which corresponds to their order of application.

HRESULT MoveUp(
  long index
);

Parameters

index
[in] Required. Index (the current position indicated by the Order property) of the rule to move up.

Return Values

This method returns S_OK if the call is successful; otherwise, it returns an error code.

[Visual Basic]

The MoveUp method moves the specified rule one step up the list of rules, which corresponds to their order of application.

Sub MoveUp( _
  ByVal index As Long _
)

Parameters

index
[in] Required. Index (the current position indicated by the Order property) of the rule to move up.

Return Values

This method has no return values. If the call is unsuccessful, an error is raised that can be intercepted by using an error handler.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCCacheRules, MoveDown


IFPCCacheRules | FPCCacheRules Remove(Variant) method [ISA Server 2004]

IFPCCacheRules::Remove[C++]

FPCCacheRules.Remove [Visual Basic]

[C++]

The Remove method removes the specified FPCCacheRule object from the collection.

HRESULT Remove(
  VARIANT Index
);

Parameters

Index
[in] Required. Name or one-based index of the object to remove.

Return Values

This method returns S_OK if the call is successful; otherwise, it returns an error code.
[Visual Basic]

The Remove method removes the specified FPCCacheRule object from the collection.

Sub Remove( _
  ByVal Index As Variant _
)

Parameters

Index
[in] Required. Name or one-based index of the object to remove.

Return Values

This method has no return values. If the call is unsuccessful, an error is raised that can be intercepted by using an error handler.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCCacheRules


FPCCertificate object [ISA Server 2004]

FPCCertificate

The FPCCertificate object represents a certificate stored on the ISA Server computer. The FPCCertificate object provides read-only access to information about the certificate.

This object is typically an element of an FPCCertificates collection and is created by its Refresh method.

Click here to see the ISA Server object hierarchy.

Methods

This object has no methods.

Properties

The FPCCertificate object has the following properties.

Property | Description
ExpirationDate | Gets a Date value that specifies the date and time in Coordinated Universal Time (UTC) when the certificate expires.
FriendlyName | Gets the friendly name of the certificate.
Hash | Gets the hash value of the certificate.
IssuedBy | Gets the name of the entity that issued the certificate.
IssuedTo | Gets the entity to which the certificate was issued.
Subject | Gets the subject of the certificate.

Remarks

This object implements the IFPCCertificate interface.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

COM Objects


IFPCCertificate | FPCCertificate ExpirationDate(DATE) property [ISA Server 2004]

ExpirationDate Property of IFPCCertificate[C++]

FPCCertificate.ExpirationDate [Visual Basic]

[C++]

The ExpirationDate property gets a DATE value that specifies the date and time in Coordinated Universal Time (UTC) when the certificate expires.

HRESULT get_ExpirationDate(
  DATE* pDate
);

Parameters

pDate
Pointer to a DATE that is set on return to the value specifying the date and time in Coordinated Universal Time (UTC) when the certificate expires.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The ExpirationDate property gets a Date value that specifies the date and time in Coordinated Universal Time (UTC) when the certificate expires.

Property ExpirationDate As Date

Property Value

Date value that specifies the date and time in Coordinated Universal Time (UTC) when the certificate expires.

Remarks

This property is read-only.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCCertificate


IFPCCertificate | FPCCertificate FriendlyName(BSTR) property [ISA Server 2004]

FriendlyName Property of IFPCCertificate[C++]

FPCCertificate.FriendlyName [Visual Basic]

[C++]

The FriendlyName property gets the friendly name of the certificate.

HRESULT get_FriendlyName(
  BSTR* pbstrFriendlyName
);

Parameters

pbstrFriendlyName
Pointer to a BSTR that is set on return to a string value specifying the friendly name of the certificate.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The FriendlyName property gets the friendly name of the certificate.

Property FriendlyName As String

Property Value

String that specifies the friendly name of the certificate.

Remarks

This property is read-only.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCCertificate


IFPCCertificate | FPCCertificate Hash(VARIANT) property [ISA Server 2004]

Hash Property of IFPCCertificate[C++]

FPCCertificate.Hash [Visual Basic]

[C++]

The Hash property gets the hash value of the certificate.

HRESULT get_Hash(
  VARIANT* pHash
);

Parameters

pHash
Pointer to a VARIANT that on return receives the hash value of the certificate.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The Hash property gets the hash value of the certificate.

Property Hash As Variant

Property Value

The hash value of the certificate.

Remarks

This property is read-only.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCCertificate


IFPCCertificate | FPCCertificate IssuedBy(BSTR) property [ISA Server 2004]

IssuedBy Property of IFPCCertificate[C++]

FPCCertificate.IssuedBy [Visual Basic]

[C++]

The IssuedBy property gets the name of the entity that issued the certificate.

HRESULT get_IssuedBy(
  BSTR* pbstrIssuedBy
);

Parameters

pbstrIssuedBy
Pointer to a BSTR that is set on return to a string value specifying the entity that issued the certificate.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The IssuedBy property gets the name of the entity that issued the certificate.

Property IssuedBy As String

Property Value

String that specifies the entity that issued the certificate.

Remarks

This property is read-only.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCCertificate


IFPCCertificate | FPCCertificate IssuedTo(BSTR) property [ISA Server 2004]

IssuedTo Property of IFPCCertificate[C++]

FPCCertificate.IssuedTo [Visual Basic]

[C++]

The IssuedTo property gets the name of the entity to which the certificate was issued.

HRESULT get_IssuedTo(
  BSTR* pbstrIssuedTo
);

Parameters

pbstrIssuedTo
Pointer to a BSTR that is set on return to a string value specifying the entity to which the certificate was issued.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The IssuedTo property gets the name of the entity to which the certificate was issued.

Property IssuedTo As String

Property Value

String that specifies the entity to which the certificate was issued.

Remarks

This property is read-only.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCCertificate


IFPCCertificate | FPCCertificate Subject(BSTR) property [ISA Server 2004]

Subject Property of IFPCCertificate[C++]

FPCCertificate.Subject [Visual Basic]

[C++]

The Subject property gets the subject of the certificate.

HRESULT get_Subject(
  BSTR* pbstrSubject
);

Parameters

pbstrSubject
Pointer to a BSTR that is set on return to a string value specifying the subject of the certificate.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The Subject property gets the subject of the certificate.

Property Subject As String

Property Value

String that specifies the subject of the certificate.

Remarks

This property is read-only.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCCertificate


FPCCertificates collection [ISA Server 2004]

FPCCertificates Collection

The FPCCertificates collection holds a set of FPCCertificate objects that represent all of the certificates stored on an ISA Server computer. FPCCertificates collections can be accessed through the SSLClientCertificates, SSLServerCertificates, and TrustedRootCertificates properties of an FPCServer object.

Click here to see the ISA Server object hierarchy.

Methods

The FPCCertificates collection defines the following methods.

Method | Description
Item | Retrieves the requested FPCCertificate object from the collection.
Refresh | Refreshes the FPCCertificates collection to include certificates that may have been added to the ISA Server computer.

Properties

The FPCCertificates collection has the following properties.

Property | Description
_NewEnum | Gets an enumerator object for the collection.
Count | Gets the number of FPCCertificate objects in the collection.

Remarks

This collection implements the IFPCCertificates interface.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

COM Objects


IFPCCertificates | FPCCertificates _NewEnum(IUnknown) property [ISA Server 2004]

_NewEnum Property of IFPCCertificates[C++]

FPCCertificates._NewEnum [Visual Basic]

[C++]

The _NewEnum property gets an enumerator object for the collection. An enumerator object provides serial access to the elements of the collection.

HRESULT get__NewEnum(
  IUnknown* ppEnum
);

Parameters

ppEnum
Address of an interface pointer that on return points to the IUnknown interface of an enumerator object that implements an IEnumVARIANT interface for the collection. An interface pointer to the IEnumVARIANT interface of the enumerator object can be retrieved by calling QueryInterface on the IUnknown interface returned.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The _NewEnum property gets an enumerator object for the collection. An enumerator object provides serial access to the elements of the collection.

Property _NewEnum As IUnknown

Property Value

Reference to an enumerator object that provides serial access to the elements of the collection.

Remarks

This property is read-only.

In Visual Basic and VBScript, this property is used implicitly in For Each...In...Next constructs.

Example Code

This VBScript script displays the names of all the SSL server certificates stored on the local ISA Server computer. It does not include error handling.

' Create the root object.
Dim root  ' The FPCLib.FPC root object
Set root = CreateObject("FPC.Root")

' Declare the other objects needed.
Dim server        ' An FPCServer object
Dim certificates  ' An FPCCertificates collection
Dim certificate   ' An FPCCertificate object

' Get references to the server object
' and the certificates collection for the SSL server certificates.
Set server = root.GetContainingServer()
Set certificates = server.SSLServerCertificates

' Display the name of each SSL server certificate.
For Each certificate In certificates
    WScript.Echo "Certificate name: " & certificate.FriendlyName
Next

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCCertificates


IFPCCertificates | FPCCertificates Count(long) property [ISA Server 2004]

Count Property of IFPCCertificates[C++]

FPCCertificates.Count [Visual Basic]

[C++]

The Count property gets the number of FPCCertificate objects in the collection.

HRESULT get_Count(
  long* plCount
);

Parameters

plCount
Pointer to a variable that receives a 32-bit integer specifying the number of FPCCertificate objects in the collection.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The Count property gets the number of FPCCertificate objects in the collection.

Property Count As Long

Property Value

A 32-bit integer that specifies the number of FPCCertificate objects in the collection.

Remarks

This property is read-only.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCCertificates


IFPCCertificates | FPCCertificates Item (2 Parameters) method [ISA Server 2004]

IFPCCertificates::Item[C++]

FPCCertificates.Item [Visual Basic]

[C++]

The Item method retrieves the requested IFPCCertificate interface from the collection.

HRESULT Item(
  long Index,
  IFPCCertificate** ppItem
);

Parameters

Index
[in] Required. The one-based index of the object to retrieve.
ppItem
[out] Address of an interface pointer that on return points to the IFPCCertificate interface requested.

Return Values

This method can return one of the following:

  • S_OK, indicating that the operation succeeded.
  • An error code, indicating that the operation failed. In this case, the [out] parameter returned is a null object.

[Visual Basic]

The Item method retrieves the requested FPCCertificate object from the collection.

Function Item( _
  ByVal Index As Long _
) As FPCCertificate

Parameters

Index
[in] Required. The one-based index of the object to retrieve.

Return Values

This method returns a reference to the FPCCertificate object requested if successful. Otherwise, an error is raised that can be intercepted by using an error handler.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCCertificates


IFPCCertificates | FPCCertificates Refresh method [ISA Server 2004]

IFPCCertificates::Refresh[C++]

FPCCertificates.Refresh [Visual Basic]

[C++]

The Refresh method refreshes the collection to include certificates that may have been added to the ISA Server computer.

HRESULT Refresh();

Parameters

This method has no parameters.

Return Values

This method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

Certificates are not added by using the FPC objects.

[Visual Basic]

The Refresh method refreshes the collection to include certificates that may have been added to the ISA Server computer.

Sub Refresh()

Parameters

This method has no parameters.

Return Values

This method has no return values. If the call is unsuccessful, an error is raised that can be intercepted by using an error handler.

Remarks

Certificates are not added by using the FPC objects.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCCertificates


FPCClientAutoScript object [ISA Server 2004]

FPCClientAutoScript

The FPCClientAutoScript object defines the contents of the default automatic configuration script for configuring Web browsers running on Firewall Client computers.

You can set the properties of the FPCWebBrowserClientConfig object so that Web browsers running on Firewall clients will be configured to use the automatic configuration script stored at a default location on the ISA Server computer. This script is downloaded to a Web browser running on a Firewall client every time the Web browser is opened and is executed against every URL that the Web browser requests. Because the configuration script is automatically made available to the Web browsers running on Firewall clients, you can update the Web browser settings on all Firewall clients without having to reconfigure the Web browser on each client computer.

Alternatively, you can construct your own custom automatic configuration script and place it on a Web server. When a Web browser looks for the configuration script at the URL that you specify, the Web server receives the request and returns the custom automatic configuration script to the browser.

The FPCClientAutoScript object can be accessed through the AutoScript property of an FPCWebBrowserClientConfig object.

Click here to see the ISA Server object hierarchy.

Methods

The FPCClientAutoScript object defines the following methods.

Method | Description
Refresh | Recursively reads all the values of the properties of the object, including all the properties of its subobjects and their elements (for collections), from persistent storage, discarding any changes that were not saved.
Save | Recursively writes the current values of all the properties of the object, including all the properties of its subobjects and their elements (for collections), to persistent storage.

Properties

The FPCClientAutoScript object has the following properties.

Property | Description
BackupRoute | Gets an FPCClientBackupRoute object that represents the backup route settings for Web browsers running on Firewall Client computers.
BypassLocalServers | Gets or sets a Boolean value that indicates whether Web browsers running on Firewall Client computers will bypass the Web proxy for requests sent to non-dotted names.
DirectAddressDestinations | Gets an FPCPublicNames collection containing the domain names of destinations that Firewall clients will access directly, bypassing the Microsoft Firewall service.
DirectIpDestinations | Gets an FPCIpRangeSet collection containing the ranges of IP addresses that Firewall clients will access directly, bypassing the Microsoft Firewall service.
IncludeLDT | Gets or sets a Boolean value that indicates whether to include the local domain table (LDT) addresses in the list of directly accessed servers.

Remarks

This object implements the IFPCClientAutoScript interface.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

COM Objects


IFPCClientAutoScript.BackupRoute (1 Parameter) property [ISA Server 2004]

BackupRoute Property of IFPCClientAutoScript[C++]

FPCClientAutoScript.BackupRoute [Visual Basic]

[C++]

The BackupRoute property gets an FPCClientBackupRoute object that represents the backup route settings for Web browsers running on Firewall Client computers.

HRESULT get_BackupRoute(
  IFPCClientBackupRoute** ppClientBackupRoute
);

Parameters

ppClientBackupRoute
Address of an interface pointer that on return points to an IFPCClientBackupRoute interface specifying the backup route settings for Web browsers running on Firewall clients.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The BackupRoute property gets an FPCClientBackupRoute object that represents the backup route settings for Web browsers running on Firewall Client computers.

Property BackupRoute As FPCClientBackupRoute

Property Value

FPCClientBackupRoute object that represents the backup route settings for Web browsers running on Firewall clients.

Remarks

This property is read-only.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCClientAutoScript


IFPCClientAutoScript.BypassLocalServers property [ISA Server 2004]

BypassLocalServers Property of IFPCClientAutoScript[C++]

FPCClientAutoScript.BypassLocalServers [Visual Basic]

[C++]

The BypassLocalServers property gets or sets a Boolean value that indicates whether Web browsers running on Firewall Client computers will bypass the Web proxy for requests sent to non-dotted names.

HRESULT get_BypassLocalServers(
  VARIANT_BOOL* pfBypass
);

HRESULT put_BypassLocalServers(
  VARIANT_BOOL fBypass
);

Parameters

pfBypass
Pointer to a Boolean variable that is set on return to VARIANT_TRUE if Web browsers running on Firewall clients will bypass the Web proxy for requests sent to non-dotted names, or to VARIANT_FALSE if Web browsers running on Firewall clients will not bypass the Web proxy for requests sent to non-dotted names.
fBypass
Boolean value that indicates whether Web browsers running on Firewall clients will bypass the Web proxy for requests sent to non-dotted names.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write.

Non-dotted names typically refer to Web servers in the local network. To enable Web browsers running on Firewall clients to bypass the Web proxy for requests sent to dotted names (or IP addresses) that refer to Web servers in the local network, add these names (or IP addresses) to the local domain table (LDT).

[Visual Basic]

The BypassLocalServers property gets or sets a Boolean value that indicates whether Web browsers running on Firewall Client computers will bypass the Web proxy for requests sent to non-dotted names.

Property BypassLocalServers As Boolean

Property Value

Boolean value that indicates whether Web browsers running on Firewall clients will bypass the Web proxy for requests sent to non-dotted names.

Remarks

This property is read/write.

Non-dotted names typically refer to Web servers in the local network. To enable Web browsers running on Firewall clients to bypass the Web proxy for requests sent to dotted names (or IP addresses) that refer to Web servers in the local network, add these names (or IP addresses) to the local domain table (LDT).

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCClientAutoScript


IFPCClientAutoScript.DirectAddressDestinations property [ISA Server 2004]

DirectAddressDestinations Property of IFPCClientAutoScript[C++]

FPCClientAutoScript.DirectAddressDestinations [Visual Basic]

[C++]

The DirectAddressDestinations property gets an IFPCPublicNames interface representing the collection of domain names of destinations that Firewall clients will access directly, bypassing the Microsoft Firewall service.

HRESULT get_DirectAddressDestinations(
  IFPCPublicNames** ppPublicNames
);

Parameters

ppPublicNames
Address of an interface pointer that on return points to an IFPCPublicNames interface representing the collection of domain names of the destinations that Firewall clients will access directly, bypassing the Firewall service.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only. It can be modified by calling the methods of the IFPCPublicNames interface.

Each element of the collection may represent one of the following:

  • A single computer, which is specified by its fully qualified domain name (FQDN).
  • All the computers in a domain, which are specified by a string of the form *.<domain_name>.
  • All the computers in all domains in the network, which are specified by an asterisk (*).

[Visual Basic]

The DirectAddressDestinations property gets an FPCPublicNames collection containing the domain names of destinations that Firewall clients will access directly, bypassing the Microsoft Firewall service.

Property DirectAddressDestinations As FPCPublicNames

Property Value

Reference to an FPCPublicNames collection containing the domain names of destinations that Firewall clients will access directly, bypassing the Firewall service.

Remarks

This property is read-only. It can be modified by calling the methods of the FPCPublicNames collection.

Each element of the collection may represent one of the following:

  • A single computer, which is specified by its fully qualified domain name (FQDN).
  • All the computers in a domain, which are specified by a string of the form *.<domain_name>.
  • All the computers in all domains in the network, which are specified by an asterisk (*).

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCClientAutoScript


IFPCClientAutoScript.DirectIpDestinations property [ISA Server 2004]

DirectIpDestinations Property of IFPCClientAutoScript[C++]

FPCClientAutoScript.DirectIpDestinations [Visual Basic]

[C++]

The DirectIpDestinations property gets an IFPCIpRangeSet interface representing the collection of ranges of IP addresses that Firewall clients will access directly, bypassing the Microsoft Firewall service.

HRESULT get_DirectIpDestinations(
  IFPCIpRangeSet** ppIpRangeSet
);

Parameters

ppIpRangeSet
Address of an interface pointer that on return points to an IFPCIpRangeSet interface representing the collection of ranges of IP addresses that Firewall clients will access directly, bypassing the Firewall service.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only. It can be modified by calling the methods of the IFPCIpRangeSet interface.

[Visual Basic]

The DirectIpDestinations property gets an FPCIpRangeSet collection containing the ranges of IP addresses that Firewall clients will access directly, bypassing the Microsoft Firewall service.

Property DirectIpDestinations As FPCIpRangeSet

Property Value

Reference to an FPCIpRangeSet collection containing the ranges of IP addresses that Firewall clients will access directly, bypassing the Firewall service.

Remarks

This property is read-only. It can be modified by calling the methods of the FPCIpRangeSet collection.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCClientAutoScript


IFPCClientAutoScript.IncludeLDT (2 Parameters) property [ISA Server 2004]

IncludeLDT Property of IFPCClientAutoScript[C++]

FPCClientAutoScript.IncludeLDT [Visual Basic]

[C++]

The IncludeLDT property gets or sets a Boolean value that indicates whether to include the local domain table (LDT) addresses in the list of directly accessed servers.

HRESULT get_IncludeLDT(
  VARIANT_BOOL* pfInclude
);

HRESULT put_IncludeLDT(
  VARIANT_BOOL fInclude
);

Parameters

pfInclude
Pointer to a Boolean variable that is set on return to VARIANT_TRUE if the local domain table (LDT) addresses are included in the list of directly accessed servers, or to VARIANT_FALSE if these addresses are not included.
fInclude
Boolean value that indicates whether the local domain table (LDT) addresses are included in the list of directly accessed servers.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write.

[Visual Basic]

The IncludeLDT property gets or sets a Boolean value that indicates whether to include the local domain table (LDT) addresses in the list of directly accessed servers.

Property IncludeLDT As Boolean

Property Value

Boolean value that indicates whether the local domain table (LDT) addresses are included in the list of directly accessed servers.

Remarks

This property is read/write.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCClientAutoScript


IFPCClientAutoScript | FPCClientAutoScript Refresh method [ISA Server 2004]

IFPCClientAutoScript::Refresh[C++]

FPCClientAutoScript.Refresh [Visual Basic]

[C++]

The Refresh method recursively reads all the values of the properties of the object, including all the properties of its subobjects and their elements (for collections), from persistent storage, discarding any changes that were not saved.

HRESULT Refresh();

Parameters

This method has no parameters.

Return Values

This method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

Changes made to this object can be saved by calling the Save method of this object or the Save method of any object containing it.

[Visual Basic]

The Refresh method recursively reads all the values of the properties of the object, including all the properties of its subobjects and their elements (for collections), from persistent storage, discarding any changes that were not saved.

Sub Refresh()

Parameters

This method has no parameters.

Return Values

This method has no return values. If the call is unsuccessful, an error is raised that can be intercepted by using an error handler.

Remarks

Changes made to this object can be saved by calling the Save method of this object or the Save method of any object containing it.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCClientAutoScript


IFPCClientAutoScript | FPCClientAutoScript Save method [ISA Server 2004]

IFPCClientAutoScript::Save[C++]

FPCClientAutoScript.Save [Visual Basic]

[C++]

The Save method recursively writes the current values of all the properties of the object, including all the properties of its subobjects and their elements (for collections), to persistent storage. It is important to remember that any changes made by scripts and programs are not saved until after the Save method is called.

HRESULT Save(
  VARIANT_BOOL fResetRequiredServices,
  VARIANT_BOOL fReloadConfiguration
);

Parameters

fResetRequiredServices
[in, optional] Boolean value that indicates whether to restart the services that need to be restarted for any of the changes saved to take effect. The default value is VARIANT_FALSE.
fReloadConfiguration
[in, optional] Boolean value that indicates whether the call will include synchronous reloading of all changes that can be applied dynamically without restarting services. The default value is VARIANT_TRUE.

Return Values

This method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

Configuration changes are applied only after the new settings are written to persistent storage and reloaded to the services that use them. Most changes can be applied dynamically without restarting any services. However, some changes can take effect only after the Microsoft Firewall service is restarted. For more information, see Restarting Services after Configuration Changes.

ISA Server maintains a bitmask that specifies which services need to be started for currently unsaved changes to take effect. This bitmask can be retrieved by calling the GetServiceRestartMask method on an object that contains this object as a subobject. Calling the Save method clears all of the bits in this bitmask even if the fResetRequiredServices parameter is set to VARIANT_FALSE.

If the fReloadConfiguration parameter is set to VARIANT_FALSE the current values will be written to persistent storage without updating the configuration being used by the ISA Server services. The configuration used by each service will not be updated until the service is restarted or the new settings are reloaded by another call to Save.

[Visual Basic]

The Save method recursively writes the current values of all the properties of the object, including all the properties of its subobjects and their elements (for collections), to persistent storage. It is important to remember that any changes made by scripts and programs are not saved until after the Save method is called.

Sub Save( _
  [ ByVal fResetRequiredServices As Boolean ], _
  [ ByVal fReloadConfiguration As Boolean ] _
)

Parameters

fResetRequiredServices
[in, optional] Boolean value that indicates whether to restart the services that need to be restarted for any of the changes saved to take effect. The default value is False.
fReloadConfiguration
[in, optional] Boolean value that indicates whether the call will include synchronous reloading of all the saved configuration changes that can be applied dynamically without restarting services. The default value is True.

Return Values

This method has no return values. If the call is unsuccessful, an error is raised that can be intercepted by using an error handler.

Remarks

Configuration changes are applied only after the new settings are written to persistent storage and reloaded to the services that use them. Most changes can be applied dynamically without restarting any services. However, some changes can take effect only after the Microsoft Firewall service is restarted. For more information, see Restarting Services after Configuration Changes.

ISA Server maintains a bitmask that specifies which services need to be started for currently unsaved changes to take effect. This bitmask can be retrieved by calling the GetServiceRestartMask method on an object that contains this object as a subobject. Calling the Save method clears all of the bits in this bitmask even if the fResetRequiredServices parameter is set to False.

If the fReloadConfiguration parameter is set to False the current values will be written to persistent storage without updating the configuration being used by the ISA Server services. The configuration used by each service will not be updated until the service is restarted or the new settings are reloaded by another call to Save.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCClientAutoScript


FPCClientBackupRoute object [ISA Server 2004]

FPCClientBackupRoute

The FPCClientBackupRoute object represents the backup route settings for Web browsers in the script that is automatically downloaded to Firewall clients. You can define a backup route for Web browsers running on Firewall client computers, so that if the ISA Server computer is not available, the Web browsers will access the Internet directly or through an alternate proxy server.

This object can be accessed through the BackupRoute property of the FPCClientAutoScript object.

Click here to see the ISA Server object hierarchy.

Methods

The FPCClientBackupRoute object defines the following methods.

Method | Description
Refresh | Reads all of the object's properties from persistent storage, discarding any changes that were not saved.
Save | Writes the current values of all of the object's properties to persistent storage.

Properties

The FPCClientBackupRoute object has the following properties.

Property | Description
AutoConfigBackupRoute | Gets or sets the backup route for Web browsers in the Firewall client configuration.
ClientBackupRouteType | Gets or sets a value from the FpcClientBackupRouteType enumerated type that specifies whether the backup route is direct to the Internet or includes a proxy server.
Enabled | Gets or sets a Boolean value that indicates whether the backup route settings for Web browsers in the Firewall client configuration are enabled.

Remarks

This object implements the IFPCClientBackupRoute interface.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

COM Objects


IFPCClientBackupRoute.AutoConfigBackupRoute property [ISA Server 2004]

AutoConfigBackupRoute Property of IFPCClientBackupRoute[C++]

FPCClientBackupRoute.AutoConfigBackupRoute [Visual Basic]

[C++]

The AutoConfigBackupRoute property gets or sets the backup route for Web browsers in the Firewall client configuration.

HRESULT get_AutoConfigBackupRoute(
  BSTR* pbstrRoute
);

HRESULT put_AutoConfigBackupRoute(
  BSTR bstrRoute
);

Parameters

pbstrRoute
Pointer to a BSTR that is set on return to a string value specifying the backup route for Web browsers in the Firewall client configuration. If this property is set to DIRECT, the backup route passes directly to the Internet rather than through an alternate proxy server.
bstrRoute
BSTR that specifies the backup route for Web browsers in the Firewall client configuration. If this property is set to DIRECT, the backup route passes directly to the Internet rather than through an alternate proxy server.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write.

[Visual Basic]

The AutoConfigBackupRoute property gets or sets the backup route for Web browsers in the Firewall client configuration.

Property AutoConfigBackupRoute As String

Property Value

String that specifies the backup route for Web browsers in the Firewall client configuration. If this property is set to DIRECT, the backup route passes directly to the Internet rather than through an alternate proxy server.

Remarks

This property is read/write.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCClientBackupRoute


IFPCClientBackupRoute.ClientBackupRouteType property [ISA Server 2004]

ClientBackupRouteType Property of IFPCClientBackupRoute[C++]

FPCClientBackupRoute.ClientBackupRouteType [Visual Basic]

[C++]

The ClientBackupRouteType property gets or sets a value from the FpcClientBackupRouteType enumerated type that specifies whether the backup route is direct to the Internet or includes a proxy server.

HRESULT get_ClientBackupRouteType(
  FpcClientBackupRouteType* pFpcBackupRouteType
);

HRESULT put_ClientBackupRouteType(
  FpcClientBackupRouteType FpcBackupRouteType
);

Parameters

pFpcBackupRouteType
Pointer to a variable that on return receives the value from a FpcClientBackupRouteType enumerated type that specifies whether the backup route is direct to the Internet or includes a proxy server.
FpcBackupRouteType
Value from the FpcClientBackupRouteType enumerated type that specifies whether the backup route is direct to the Internet or includes a proxy server.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write.

[Visual Basic]

The ClientBackupRouteType property gets or sets a value from the FpcClientBackupRouteType enumerated type that specifies whether the backup route is direct to the Internet or includes a proxy server.

Property ClientBackupRouteType As FpcClientBackupRouteType

Property Value

Value from the FpcClientBackupRouteType enumerated type that specifies whether the backup route is direct to the Internet or includes a proxy server.

Remarks

This property is read/write.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCClientBackupRoute


IFPCClientBackupRoute | FPCClientBackupRoute Enabled property [ISA Server 2004]

Enabled Property of IFPCClientBackupRoute[C++]

FPCClientBackupRoute.Enabled [Visual Basic]

[C++]

The Enabled property gets or sets a Boolean value that indicates whether the backup route settings for Web browsers in the Firewall client configuration are enabled.

HRESULT get_Enabled(
  VARIANT_BOOL* pfEnabled
);

HRESULT put_Enabled(
  VARIANT_BOOL fEnabled
);

Parameters

pfEnabled
Pointer to a Boolean variable that is set on return to VARIANT_TRUE if the backup route settings for Web browsers in the Firewall client configuration are enabled, or to VARIANT_FALSE if the backup route settings are disabled.
fEnabled
Boolean value that indicates whether the backup route settings for Web browsers in the Firewall client configuration are enabled.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write.

[Visual Basic]

The Enabled property gets or sets a Boolean value that indicates whether the backup route settings for Web browsers in the Firewall client configuration are enabled.

Property Enabled As Boolean

Property Value

Boolean value that indicates whether the backup route settings for Web browsers in the Firewall client configuration are enabled.

Remarks

This property is read/write.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCClientBackupRoute


IFPCClientBackupRoute | FPCClientBackupRoute Refresh method [ISA Server 2004]

IFPCClientBackupRoute::Refresh[C++]

FPCClientBackupRoute.Refresh [Visual Basic]

[C++]

The Refresh method reads all of the object's properties from persistent storage. When the Refresh method is called, any configuration changes made after the last call to the Save method are lost.

HRESULT Refresh();

Parameters

This method has no parameters.

Return Values

This method returns S_OK if the call is successful; otherwise, it returns an error code.

[Visual Basic]

The Refresh method reads all of the object's properties from persistent storage. When the Refresh method is called, any configuration changes made after the last call to the Save method are lost.

Sub Refresh()

Parameters

This method has no parameters.

Return Values

This method has no return values. If the call is unsuccessful, an error is raised that can be intercepted by using an error handler.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCClientBackupRoute


IFPCClientBackupRoute | FPCClientBackupRoute Save method [ISA Server 2004]

IFPCClientBackupRoute::Save[C++]

FPCClientBackupRoute.Save [Visual Basic]

[C++]

The Save method writes the current values of all of the object's properties to persistent storage. It is important to remember that any changes made by scripts and programs are not saved until after the Save method is called.

HRESULT Save(
  VARIANT_BOOL fResetRequiredServices,
  VARIANT_BOOL fReloadConfiguration
);

Parameters

fResetRequiredServices
[in, optional] Boolean value that indicates whether to restart the services that need to be restarted for any of the changes saved to take effect. The default value is VARIANT_FALSE.
fReloadConfiguration
[in, optional] Boolean value that indicates whether the call will include synchronous reloading of all changes that can be applied dynamically without restarting services. The default value is VARIANT_TRUE.

Return Values

This method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

Configuration changes are applied only after the new settings are written to persistent storage and reloaded to the services that use them. Most changes can be applied dynamically without restarting any services. However, some changes can take effect only after the Microsoft Firewall service is restarted. For more information, see Restarting Services after Configuration Changes.

ISA Server maintains a bitmask that specifies which services need to be started for currently unsaved changes to take effect. This bitmask can be retrieved by calling the GetServiceRestartMask method on an object that contains this object as a subobject. Calling the Save method clears all of the bits in this bitmask even if the fResetRequiredServices parameter is set to VARIANT_FALSE.

If the fReloadConfiguration parameter is set to VARIANT_FALSE the current values of the object's properties will be written to persistent storage without updating the configuration being used by the ISA Server services. The configuration used by each service will not be updated until the service is restarted or the new settings are reloaded by another call to Save.

[Visual Basic]

The Save method writes the current values of all of the object's properties to persistent storage. It is important to remember that any changes made by scripts and programs are not saved until after the Save method is called.

Sub Save( _
  [ ByVal fResetRequiredServices As Boolean ], _
  [ ByVal fReloadConfiguration As Boolean ] _
)

Parameters

fResetRequiredServices
[in, optional] Boolean value that indicates whether to restart the services that need to be restarted for any of the changes saved to take effect. The default value is False.
fReloadConfiguration
[in, optional] Boolean value that indicates whether the call will include synchronous reloading of all the saved configuration changes that can be applied dynamically without restarting services. The default value is True.

Return Values

This method has no return values. If the call is unsuccessful, an error is raised that can be intercepted by using an error handler.

Remarks

Configuration changes are applied only after the new settings are written to persistent storage and reloaded to the services that use them. Most changes can be applied dynamically without restarting any services. However, some changes can take effect only after the Microsoft Firewall service is restarted. For more information, see Restarting Services after Configuration Changes.

ISA Server maintains a bitmask that specifies which services need to be started for currently unsaved changes to take effect. This bitmask can be retrieved by calling the GetServiceRestartMask method on an object that contains this object as a subobject. Calling the Save method clears all of the bits in this bitmask even if the fResetRequiredServices parameter is set to False.

If the fReloadConfiguration parameter is set to False the current values of the object's properties will be written to persistent storage without updating the configuration being used by the ISA Server services. The configuration used by each service will not be updated until the service is restarted or the new settings are reloaded by another call to Save.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCClientBackupRoute


FPCClientConfig object [ISA Server 2004]

FPCClientConfig

The FPCClientConfig object contains the configuration that the Firewall client setup application sets for Firewall clients, and for Web browsers running on Firewall clients. It also contains information that Firewall clients download periodically from the ISA Server computer, and information that is used for creating the Web browser configuration script.

This object is typically accessed through the ClientConfig property of an FPCNetwork object.

Click here to see the ISA Server object hierarchy.

Inheritance

This object inherits from the FPCPersist object, which contains methods and properties related to the persistent storage of an object's data. They include methods for exporting an object's data to and importing it from XML documents.

Methods

This object has no methods.

Properties

The FPCClientConfig object has the following properties.

Property | Description
Browser | Gets an FPCWebBrowserClientConfig object that defines the configuration settings for Web browsers running on Firewall clients.
Firewall | Gets an FPCFirewallClientConfig object that defines the configuration for Firewall clients.

Methods Inherited from FPCPersist

Name | Description
CancelWaitForChanges | Cancels the registration established by the WaitForChanges method (for use in C and C++ programming only).
CanImport | Returns a Boolean value that indicates whether the object's properties can be imported from the specified XML document.
Export | Recursively writes the stored values of all the properties of the object and its subobjects to the specified XML document.
ExportToFile | Recursively writes the stored values of all the properties of the object and its subobjects to the specified XML file.
GetServiceRestartMask | Retrieves a 32-bit bitmask of the FpcServices enumerated type that specifies which services need to be restarted for currently unsaved changes to take effect.
Import | Recursively copies the values of all the properties of the object and of its subobjects from the specified XML document to persistent storage.
ImportFromFile | Recursively copies the values of all the properties of the object and of its subobjects from the specified XML file to persistent storage.
LoadDocProperties | Provides the XML document's properties so that you can know what information can be imported from the document.
Refresh | Recursively reads the values of all the properties of the object and of its subobjects from persistent storage, overwriting any changes that have not been saved.
Save | Recursively writes the current values of all the properties of the object and its subobjects to persistent storage.
WaitForChanges | Registers to wait for an event indicating that the contents of the object have changed (for use in C and C++ programming only).

Properties Inherited from FPCPersist

Name | Description
PersistentName | Gets the persistent name of the object. The persistent name of an object is a name that is unique for the object at the respective level of the COM object hierarchy.
VendorParametersSets | Gets an FPCVendorParametersSets collection that can hold sets of custom data for extending the object.

Remarks

This object implements the IFPCClientConfig interface.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

COM Objects


IFPCClientConfig | FPCClientConfig Browser property [ISA Server 2004]

Browser Property of IFPCClientConfig[C++]

FPCClientConfig.Browser [Visual Basic]

[C++]

The Browser property gets an FPCWebBrowserClientConfig object that defines the configuration settings for Web browsers running on Firewall clients.

HRESULT get_Browser(
  IFPCWebBrowserClientConfig** ppBrowserClientConfig
);

Parameters

ppBrowserClientConfig
Address of an interface pointer that on return points to the IFPCWebBrowserClientConfig interface that represents the configuration settings for Web browsers running on Firewall clients.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code, and the parameter returned is a null object.

Remarks

This property is read-only. It can be modified by setting the properties of the IFPCWebBrowserClientConfig interface retrieved.

[Visual Basic]

The Browser property gets an FPCWebBrowserClientConfig object that defines the configuration settings for Web browsers running on Firewall clients.

Property Browser As FPCWebBrowserClientConfig

Property Value

Reference to an FPCWebBrowserClientConfig object that defines the configuration settings for Web browsers running on Firewall clients.

Remarks

This property is read-only. It can be modified by setting the properties of the FPCWebBrowserClientConfig object retrieved.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCClientConfig


IFPCClientConfig | FPCClientConfig Firewall property [ISA Server 2004]

Firewall Property of IFPCClientConfig[C++]

FPCClientConfig.Firewall [Visual Basic]

[C++]

The Firewall property gets an FPCFirewallClientConfig object that defines the configuration for Firewall clients.

HRESULT get_Firewall(
  IFPCFirewallClientConfig** ppFirewallClientConfig
);

Parameters

ppFirewallClientConfig
Address of an interface pointer that on return points to the IFPCFirewallClientConfig interface that defines the configuration for Firewall clients.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code, and the parameter returned is a null object.

Remarks

This property is read-only. It can be modified by setting the properties of the IFPCFirewallClientConfig interface retrieved.

[Visual Basic]

The Firewall property gets an FPCFirewallClientConfig object that defines the configuration for Firewall clients.

Property Firewall As IFPCFirewallClientConfig

Property Value

FPCFirewallClientConfig object that defines the configuration for Firewall clients.

Remarks

This property is read-only. It can be modified by setting the properties of the FPCFirewallClientConfig object retrieved.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCClientConfig


FPCClientConfigSettings collection [ISA Server 2004]

FPCClientConfigSettings Collection

The FPCClientConfigSettings collection holds a set of FPCClientSettingsSection objects. Each FPCClientSettingsSection object contains a section of Firewall client settings.

The FPCClientConfigSettings collection can be accessed through the FWClientConfigSettings property of an FPCArray object.

Click here to see the ISA Server object hierarchy.

Inheritance

This object inherits from the FPCPersist object, which contains methods and properties related to the persistent storage of an object's data. They include methods for exporting the object's data to and importing it from an XML document.

Methods

The FPCClientConfigSettings collection defines the following methods.

Method | Description
AddSection | Creates a new FPCClientSettingsSection object in the collection and returns a reference to it.
Item | Retrieves the requested FPCClientSettingsSection object from the collection.
Remove | Removes the specified FPCClientSettingsSection object from the collection.

Properties

The FPCClientConfigSettings collection has the following properties.

Property | Description
_NewEnum | Gets an enumerator object for the collection.
Count | Gets the number of FPCClientSettingsSection objects in the collection.
EnableControlChannelEncryption | Gets or sets a Boolean value that indicates whether the ISA Server computer uses an encrypted control channel.
SupportOldFirewallClients | Gets or sets a Boolean value that indicates whether the ISA Server computer supports Firewall clients running earlier versions of the Firewall Client software.

Methods Inherited from FPCPersist

Name | Description
CancelWaitForChanges | Cancels the registration established by the WaitForChanges method (for use in C and C++ programming only).
CanImport | Returns a Boolean value that indicates whether the properties of the collection and its elements can be imported from the specified XML document.
Export | Writes the stored values of all the properties of the collection and its elements to the specified XML document.
ExportToFile | Writes the stored values of all the properties of the collection and its elements to the specified XML file.
GetServiceRestartMask | Retrieves a 32-bit bitmask of the FpcServices enumerated type that specifies which services need to be restarted for currently unsaved changes to take effect.
Import | Copies the values of all the properties of the collection and its elements from the specified XML document to persistent storage.
ImportFromFile | Copies the values of all the properties of the collection and its elements from the specified XML file to persistent storage.
LoadDocProperties | Provides the XML document's properties so that you can know what information can be imported from the document.
Refresh | Reads the values of all the properties of the collection and its elements from persistent storage, overwriting any changes that have not been saved.
Save | Writes the current values of all the properties of the collection and its elements to persistent storage.
WaitForChanges | Registers to wait for an event indicating that the contents of the object have changed (for use in C and C++ programming only).

Properties Inherited from FPCPersist

Name | Description
PersistentName | Gets the persistent name of the collection. The persistent name of an object is a name that is unique for the object at the respective level of the COM object hierarchy.
VendorParametersSets | Gets an FPCVendorParametersSets collection that can hold sets of custom data for extending the collection.

Remarks

This collection implements the IFPCClientConfigSettings interface.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

COM Objects


IFPCClientConfigSettings._NewEnum(IUnknown) property [ISA Server 2004]

_NewEnum Property of IFPCClientConfigSettings[C++]

FPCClientConfigSettings._NewEnum [Visual Basic]

[C++]

The _NewEnum property gets an enumerator object for the collection. An enumerator object provides serial access to the elements of the collection.

HRESULT get__NewEnum(
  IUnknown* ppEnum
);

Parameters

ppEnum
Address of an interface pointer that on return points to the IUnknown interface of an enumerator object that implements an IEnumVARIANT interface for the collection. An interface pointer to the IEnumVARIANT interface of the enumerator object can be retrieved by calling QueryInterface on the IUnknown interface returned.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The _NewEnum property gets an enumerator object for the collection. An enumerator object provides serial access to the elements of the collection.

Property _NewEnum As IUnknown

Property Value

Reference to an enumerator object that provides serial access to the elements of the collection.

Remarks

This property is read-only.

In Visual Basic and VBScript, this property is used implicitly in For Each...In...Next constructs.

Example Code

This VBScript script displays the names of all the sections of Firewall client settings for an FPCArray object. It does not include error handling.

' Create the root object.
Dim root  ' The FPCLib.FPC root object
Set root = CreateObject("FPC.Root")

' Declare the other objects needed.
Dim array                  ' An FPCArray object
Dim clientconfigsettings   ' An FPCClientConfigSettings collection
Dim clientsettingssection  ' An FPCClientSettingsSection object

' Get references to the array object
' and the Firewall client configuration settings collection.
Set array = root.GetContainingArray()
Set clientconfigsettings = array.FWClientConfigSettings

' Display the names of the sections of Firewall client settings
' for the array object.
For Each clientsettingssection In clientconfigsettings
    WScript.Echo "Section name: " & clientsettingssection.Name
Next

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCClientConfigSettings


IFPCClientConfigSettings.AddSection (2 Parameters) method [ISA Server 2004]

IFPCClientConfigSettings::AddSection[C++]

FPCClientConfigSettings.AddSection [Visual Basic]

[C++]

The AddSection method creates a new FPCClientSettingsSection object in the collection and returns a reference to it.

HRESULT AddSection(
  BSTR bstrSection,
  IFPCClientSettingsSection** ppNewSection
);

Parameters

bstrSection
[in] Required. BSTR that specifies the name of the new section.
ppNewSection
[out] Address of an interface pointer that on return points to the new IFPCClientSettingsSection interface created.

Return Values

This method can return one of the following:

  • S_OK, indicating that the operation succeeded.
  • An error code, indicating that the operation failed. In this case, the [out] parameter returned is a null object.

[Visual Basic]

The AddSection method creates a new FPCClientSettingsSection object in the collection and returns a reference to it.

Function AddSection( _
  ByVal bstrSection As String _
) As FPCClientSettingsSection

Parameters

bstrSection
[in] Required. String that specifies the name of the new section.

Return Values

This method returns a reference to the new FPCClientSettingsSection object if successful. Otherwise, an error is raised that can be intercepted by using an error handler.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCClientConfigSettings


IFPCClientConfigSettings.Count(long) property [ISA Server 2004]

Count Property of IFPCClientConfigSettings[C++]

FPCClientConfigSettings.Count [Visual Basic]

[C++]

The Count property gets the number of FPCClientSettingsSection objects in the collection.

HRESULT get_Count(
  long* plCount
);

Parameters

plCount
Pointer to a variable that on return receives a 32-bit integer specifying the number of FPCClientSettingsSection objects in the collection.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The Count property gets the number of FPCClientSettingsSection objects in the collection.

Property Count As Long

Property Value

A 32-bit integer that specifies the number of FPCClientSettingsSection objects in the collection.

Remarks

This property is read-only.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCClientConfigSettings


EnableControlChannelEncryption property [ISA Server 2004]

EnableControlChannelEncryption Property of IFPCClientConfigSettings[C++]

FPCClientConfigSettings.EnableControlChannelEncryption [Visual Basic]

[C++]

The EnableControlChannelEncryption property gets or sets a Boolean value that indicates whether the ISA Server computer uses an encrypted control channel.

HRESULT get_EnableControlChannelEncryption(
  VARIANT_BOOL* pfEnableControlChannelEncryption
);

HRESULT put_EnableControlChannelEncryption(
  VARIANT_BOOL fEnableControlChannelEncryption
);

Parameters

pfEnableControlChannelEncryption
Pointer to a Boolean variable that is set on return to VARIANT_TRUE if the ISA Server computer uses an encrypted control channel, or to VARIANT_FALSE if the ISA Server computer does not use an encrypted control channel.
fEnableControlChannelEncryption
Boolean value that indicates whether the ISA Server computer uses an encrypted control channel.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write.

[Visual Basic]

The EnableControlChannelEncryption property gets or sets a Boolean value that indicates whether the ISA Server computer uses an encrypted control channel.

Property EnableControlChannelEncryption As Boolean

Property Value

Boolean value that indicates whether the ISA Server computer uses an encrypted control channel.

Remarks

This property is read/write.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCClientConfigSettings


IFPCClientConfigSettings.Item (2 Parameters) method [ISA Server 2004]

IFPCClientConfigSettings::Item[C++]

FPCClientConfigSettings.Item [Visual Basic]

[C++]

The Item method retrieves the requested IFPCClientSettingsSection interface from the collection.

HRESULT Item(
  VARIANT Index,
  IFPClientSettingsSection** ppItem
);

Parameters

Index
[in] Required. Name or one-based index of the object to retrieve.
ppItem
[out] Address of an interface pointer that on return points to the IFPCClientSettingsSection interface requested.

Return Values

This method can return one of the following:

  • S_OK, indicating that the operation succeeded.
  • An error code, indicating that the operation failed. In this case, the [out] parameter returned is a null object.

[Visual Basic]

The Item method retrieves the requested FPCClientSettingsSection object from the collection.

Function Item( _
  ByVal Index As Variant _
) As FPCClientSettingsSection

Parameters

Index
[in] Required. Name or one-based index of the object to retrieve.

Return Values

The method returns a reference to the FPCClientSettingsSection object requested if successful. Otherwise, an error is raised that can be intercepted by using an error handler.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCClientConfigSettings


IFPCClientConfigSettings.Remove(Variant) method [ISA Server 2004]

IFPCClientConfigSettings::Remove[C++]

FPCClientConfigSettings.Remove [Visual Basic]

[C++]

The Remove method removes the specified FPCClientSettingsSection object from the collection.

HRESULT Remove(
  VARIANT Index
);

Parameters

Index
[in] Required. Name or one-based index of the FPCClientSettingsSection object to remove.

Return Values

This method returns S_OK if the call is successful; otherwise, it returns an error code.

[Visual Basic]

The Remove method removes the specified FPCClientSettingsSection object from the collection.

Sub Remove( _
  ByVal Index As Variant _
)

Parameters

Index
[in] Required. Name or one-based index of the FPCClientSettingsSection object to remove.

Return Values

This method has no return values. If the call is unsuccessful, an error is raised that can be intercepted by using an error handler.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCClientConfigSettings


IFPCClientConfigSettings.SupportOldFirewallClients property [ISA Server 2004]

SupportOldFirewallClients Property of IFPCClientConfigSettings[C++]

FPCClientConfigSettings.SupportOldFirewallClients [Visual Basic]

[C++]

The SupportOldFirewallClients property gets or sets a Boolean value that indicates whether the ISA Server computer supports Firewall clients running earlier versions of the Firewall Client software.

HRESULT get_SupportOldFirewallClients(
  VARIANT_BOOL* pfSupportOldFirewallClients
);

HRESULT put_SupportOldFirewallClients(
  VARIANT_BOOL fSupportOldFirewallClients
);

Parameters

pfSupportOldFirewallClients
Pointer to a Boolean variable that is set on return to VARIANT_TRUE if the ISA Server computer supports Firewall clients running earlier versions of the Firewall Client software, or to VARIANT_FALSE if the ISA Server computer does not support such Firewall clients.
fSupportOldFirewallClients
Boolean value that indicates whether the ISA Server computer supports Firewall clients running earlier versions of the Firewall Client software.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write. Its value is initially set by the administrator during setup.

ISA Server supports earlier versions of the Firewall Client software, including Firewall Client for ISA Server 2000 and the Winsock Proxy client (from Microsoft Proxy Server 2.0). Note, however, that Firewall clients running earlier versions of the Firewall Client software cannot use encryption when connecting to an ISA Server computer.

[Visual Basic]

The SupportOldFirewallClients property gets or sets a Boolean value that indicates whether the ISA Server computer supports Firewall clients running earlier versions of the Firewall Client software.

Property SupportOldFirewallClients As Boolean

Property Value

Boolean value that indicates whether the ISA Server computer supports Firewall clients running earlier versions of the Firewall Client software.

Remarks

This property is read/write. Its value is initially set by the administrator during setup.

ISA Server supports earlier versions of the Firewall Client software, including Firewall Client for ISA Server 2000 and the Winsock Proxy client (from Microsoft Proxy Server 2.0). Note, however, that Firewall clients running earlier versions of the Firewall Client software cannot use encryption when connecting to an ISA Server computer.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCClientConfigSettings


FPCClientSettingsSection object [ISA Server 2004]

FPCClientSettingsSection

The FPCClientSettingsSection object contains a section of Firewall client settings.

The client settings sections, together with the local domain table (LDT) and the client configuration options, comprise the information stored in the global Firewall client configuration file.

For more information about the Firewall client configuration files, see the Internet Security and Acceleration Server 2004 product documentation.

This object is typically an element of an FPCClientConfigSettings collection. The AddSection method can be used to create a new FPCClientSettingsSection object in the collection.

Click here to see the ISA Server object hierarchy.

Methods

The FPCClientSettingsSection object defines the following methods.

Method | Description
Refresh | Reads all of the object's properties from persistent storage, discarding any changes that were not saved.
RemoveValue | Removes the specified client setting value from the list of client settings.
Save | Writes the current values of all of the object's properties to persistent storage.

Properties

The FPCClientSettingsSection object has the following properties.

Property | Description
AllNames | Gets the names of all the Firewall client settings in the section.
Name | Gets or sets the name of the Firewall client settings section.
Value | Gets or sets the value associated with the setting name supplied.

Remarks

This object implements the IFPCClientSettingsSection interface.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

COM Objects


IFPCClientSettingsSection.AllNames(VARIANT) property [ISA Server 2004]

AllNames Property of IFPCClientSettingsSection[C++]

FPCClientSettingsSection.AllNames [Visual Basic]

[C++]

The AllNames property gets the names of all the Firewall client settings in the section.

HRESULT get_AllNames(
  VARIANT* pItem
);

Parameters

pItem
Pointer to a VARIANT that on return receives a safe array of strings containing the names of all the Firewall client settings in the section.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

The AllNames property retrieves a safe array of all the names of Firewall client settings that were stored through the Value property.

[Visual Basic]

The AllNames property gets the names of all the Firewall client settings in the section.

Property AllNames As Variant

Property Value

Array of strings containing the names of all the Firewall client settings in the section.

Remarks

This property is read-only.

The AllNames property retrieves a safe array of all the names of Firewall client settings that were stored through the Value property.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCClientSettingsSection


IFPCClientSettingsSection.Name(BSTR,BSTR) property [ISA Server 2004]

Name Property of IFPCClientSettingsSection[C++]

FPCClientSettingsSection.Name [Visual Basic]

[C++]

The Name property gets or sets the name of the Firewall client settings section.

HRESULT get_Name(
  BSTR* pbstrName
);

HRESULT put_Name(
  BSTR bstrName
);

Parameters

pbstrName
Pointer to a BSTR that is set on return to a string value specifying the name of the Firewall client settings section.
bstrName
BSTR that specifies the name of the Firewall client settings section.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write.

[Visual Basic]

The Name property gets or sets the name of the Firewall client settings section.

Property Name As String

Property Value

String that specifies the name of the Firewall client settings section.

Remarks

This property is read/write.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCClientSettingsSection


IFPCClientSettingsSection.Refresh method [ISA Server 2004]

IFPCClientSettingsSection::Refresh[C++]

FPCClientSettingsSection.Refresh [Visual Basic]

[C++]

The Refresh method reads all of the object's properties from persistent storage, discarding any changes that were not saved.

HRESULT Refresh();

Parameters

This method has no parameters.

Return Values

This method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

Changes made to this object can be saved by calling the Save method of this object or the Save method of any object containing it.

[Visual Basic]

The Refresh method reads all of the object's properties from persistent storage, discarding any changes that were not saved.

Sub Refresh()

Parameters

This method has no parameters.

Return Values

This method has no return values. If the call is unsuccessful, an error is raised that can be intercepted by using an error handler.

Remarks

Changes made to this object can be saved by calling the Save method of this object or the Save method of any object containing it.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCClientSettingsSection


IFPCClientSettingsSection.RemoveValue(String) method [ISA Server 2004]

IFPCClientSettingsSection::RemoveValue[C++]

FPCClientSettingsSection.RemoveValue [Visual Basic]

[C++]

The RemoveValue method removes the specified client setting value from the list of client settings.

HRESULT RemoveValue(
  BSTR Name
);

Parameters

Name
[in] Required. BSTR that specifies the name of the value to be removed.

Return Values

This method returns S_OK if the call is successful; otherwise, it returns an error code.

[Visual Basic]

The RemoveValue method removes the specified client setting value from the list of client settings.

Sub RemoveValue( _
  ByVal Name As String _
)

Parameters

Name
[in] Required. String that specifies the name of the value to be removed.

Return Values

This method has no return values. If the call is unsuccessful, an error is raised that can be intercepted by using an error handler.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCClientSettingsSection


IFPCClientSettingsSection.Save (2 Parameters) method [ISA Server 2004]

IFPCClientSettingsSection::Save[C++]

FPCClientSettingsSection.Save [Visual Basic]

[C++]

The Save method writes the current values of all of the object's properties to persistent storage. It is important to remember that any changes made by scripts and programs are not saved until after the Save method is called.

HRESULT Save(
  VARIANT_BOOL fResetRequiredServices,
  VARIANT_BOOL fReloadConfiguration
);

Parameters

fResetRequiredServices
[in, optional] Boolean value that indicates whether to restart the services that need to be restarted for any of the changes saved to take effect. The default value is VARIANT_FALSE.
fReloadConfiguration
[in, optional] Boolean value that indicates whether the call will include synchronous reloading of all changes that can be applied dynamically without restarting services. The default value is VARIANT_TRUE.

Return Values

This method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

Configuration changes are applied only after the new settings are written to persistent storage and reloaded to the services that use them. Most changes can be applied dynamically without restarting any services. However, some changes can take effect only after the Microsoft Firewall service is restarted. For more information, see Restarting Services after Configuration Changes.

ISA Server maintains a bitmask that specifies which services need to be started for currently unsaved changes to take effect. This bitmask can be retrieved by calling the GetServiceRestartMask method on an object that contains this object as a subobject. Calling the Save method clears all of the bits in this bitmask even if the fResetRequiredServices parameter is set to VARIANT_FALSE.

If the fReloadConfiguration parameter is set to VARIANT_FALSE the current values of the object's properties will be written to persistent storage without updating the configuration being used by the ISA Server services. The configuration used by each service will not be updated until the service is restarted or the new settings are reloaded by another call to Save.

[Visual Basic]

The Save method writes the current values of all of the object's properties to persistent storage. It is important to remember that any changes made by scripts and programs are not saved until after the Save method is called.

Sub Save( _
  [ ByVal fResetRequiredServices As Boolean ], _
  [ ByVal fReloadConfiguration As Boolean ] _
)

Parameters

fResetRequiredServices
[in, optional] Boolean value that indicates whether to restart the services that need to be restarted for any of the changes saved to take effect. The default value is False.
fReloadConfiguration
[in, optional] Boolean value that indicates whether the call will include synchronous reloading of all the saved configuration changes that can be applied dynamically without restarting services. The default value is True.

Return Values

This method has no return values. If the call is unsuccessful, an error is raised that can be intercepted by using an error handler.

Remarks

Configuration changes are applied only after the new settings are written to persistent storage and reloaded to the services that use them. Most changes can be applied dynamically without restarting any services. However, some changes can take effect only after the Microsoft Firewall service is restarted. For more information, see Restarting Services after Configuration Changes.

ISA Server maintains a bitmask that specifies which services need to be started for currently unsaved changes to take effect. This bitmask can be retrieved by calling the GetServiceRestartMask method on an object that contains this object as a subobject. Calling the Save method clears all of the bits in this bitmask even if the fResetRequiredServices parameter is set to False.

If the fReloadConfiguration parameter is set to False the current values of the object's properties will be written to persistent storage without updating the configuration being used by the ISA Server services. The configuration used by each service will not be updated until the service is restarted or the new settings are reloaded by another call to Save.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCClientSettingsSection


IFPCClientSettingsSection.Value (4 Parameters) property [ISA Server 2004]

Value Property of IFPCClientSettingsSection[C++]

FPCClientSettingsSection.Value [Visual Basic]

[C++]

The Value property gets or sets the value associated with the setting name supplied.

HRESULT get_Value(
  BSTR bstrName,
  BSTR* pbstrValue
);

HRESULT put_Value(
  BSTR bstrName,
  BSTR bstrValue
);

Parameters

bstrName
BSTR specifying the name of the setting for which the value is to be retrieved or set.
pbstrValue
Pointer to a BSTR that is set on return to the string value associated with the setting name specified by the bstrName parameter.
bstrValue
BSTR associated with the setting name specified by the bstrName parameter.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write.

[Visual Basic]

The Value property gets or sets the value associated with the setting name supplied.

Property Value( _
  ByVal Name As String _
) As String

Parameters

Name
String specifying the setting name for which the value is to be retrieved or set.

Property Value

String associated with the setting name specified by the Name parameter.

Remarks

This property is read/write.

The FPCClientSettingsSection object is used to store data that is defined as a {name, value} pair using the Value property. The following example stores a property named x having a value of 1:

FPCClientSettingsSection.Value("x") = "1"

The expression Value("x") will return the value.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCClientSettingsSection


FPCComputer object [ISA Server 2004]

FPCComputer

The FPCComputer object represents a computer.

This object is typically an element of an FPCComputers collection.

Click here to see the ISA Server object hierarchy.

Inheritance

This object inherits from the FPCPersist object, which contains methods and properties related to persistent storage of an object's data. They include methods for exporting an object's data to and importing it from an XML document.

Methods

This object has no methods.

Properties

The FPCComputer object has the following properties.

Property | Description
Description | Gets or sets the description of the computer.
IPAddress | Gets or sets the IP address of the computer.
Name | Gets or sets the name of the computer.

Methods Inherited from FPCPersist

Name | Description
CancelWaitForChanges | Cancels the registration established by the WaitForChanges method (for use in C and C++ programming only).
CanImport | Returns a Boolean value that indicates whether the object's properties can be imported from the specified XML document.
Export | Writes the stored values of all of the object's properties to the specified XML document.
ExportToFile | Writes the stored values of all of the object's properties to the specified XML file.
GetServiceRestartMask | Retrieves a 32-bit bitmask of the FpcServices enumerated type that specifies which services need to be restarted for currently unsaved changes to take effect.
Import | Copies the values of all of the object's properties from the specified XML document to persistent storage.
ImportFromFile | Copies the values of all of the object's properties from the specified XML file to persistent storage.
LoadDocProperties | Provides the XML document's properties so that you can know what information can be imported from the document.
Refresh | Reads the values of all of the object's properties from persistent storage, overwriting any changes that have not been saved.
Save | Writes the current values of all of the object's properties to persistent storage.
WaitForChanges | Registers to wait for an event indicating that the contents of the object have changed (for use in C and C++ programming only).

Properties Inherited from FPCPersist

Name | Description
PersistentName | Gets the persistent name of the object. The persistent name of an object is a name that is unique for the object at the respective level of the COM object hierarchy.
VendorParametersSets | Gets an FPCVendorParametersSets object that can hold sets of custom data for extending the object.

Remarks

This object implements the IFPCComputer interface.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

COM Objects


IFPCComputer | FPCComputer Description(BSTR,BSTR) property [ISA Server 2004]

Description Property of IFPCComputer[C++]

FPCComputer.Description [Visual Basic]

[C++]

The Description property gets or sets the description of the computer.

HRESULT get_Description(
  BSTR** pbstrDescription
);

HRESULT put_Description(
  BSTR bstrDescription
);

Parameters

pbstrDescription
Pointer to a BSTR that is set on return to a string value specifying the description of the computer.
bstrDescription
BSTR that specifies the description of the computer.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write.

[Visual Basic]

The Description property gets or sets the description of the computer.

Property Description As String

Property Value

String that specifies the description of the computer.

Remarks

This property is read/write.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCComputer


IFPCComputer | FPCComputer IPAddress(BSTR,BSTR) property [ISA Server 2004]

IPAddress Property of IFPCComputer[C++]

FPCComputer.IPAddress [Visual Basic]

[C++]

The IPAddress property gets or sets the IP address of the computer.

HRESULT get_IPAddress(
  BSTR** pbstrIPAddress
);

HRESULT put_IPAddress(
  BSTR bstrIPAddress
);

Parameters

pbstrIPAddress
Pointer to a BSTR that is set on return to a string value specifying the IP address of the computer.
bstrIPAddress
BSTR that specifies the IP address of the computer.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write.

[Visual Basic]

The IPAddress property gets or sets the IP address of the computer.

Property IPAddress

Property Value

String that specifies the IP address of the computer.

Remarks

This property is read/write.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCComputer


IFPCComputer | FPCComputer Name(BSTR,BSTR) property [ISA Server 2004]

Name Property of IFPCComputer[C++]

FPCComputer.Name [Visual Basic]

[C++]

The Name property gets or sets the name of the computer.

HRESULT get_Name(
  BSTR** pbstrName
);

HRESULT put_Name(
  BSTR bstrName
);

Parameters

pbstrName
Pointer to a BSTR that is set on return to a string value specifying the name of the computer.
bstrName
BSTR that specifies the name of the computer.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write.

[Visual Basic]

The Name property gets or sets the name of the computer.

Property Name As String

Property Value

String that specifies the name of the computer.

Remarks

This property is read/write.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCComputer


FPCComputers collection [ISA Server 2004]

FPCComputers Collection

The FPCComputers collection holds a set of FPCComputer objects that represent computers.

This collection can be accessed through the Computers property of an FPCRuleElements object or through the Computers property of an FPCComputerSet object.

Click here to see the ISA Server object hierarchy.

Inheritance

This collection inherits from the FPCPersist object, which contains methods and properties related to persistent storage of an object's data. They include methods for exporting an object's data to and importing it from an XML document.

Methods

The FPCComputers collection defines the following methods.

Method | Description
Add | Creates a new FPCComputer object in the collection and returns a reference to it.
Item | Retrieves the requested FPCComputer object from the collection.
Remove | Removes the specified FPCComputer object from the collection.

Properties

The FPCComputers collection has the following properties.

Property | Description
_NewEnum | Gets an enumerator object for the collection.
Count | Gets the number of FPCComputer objects in the collection.

Methods Inherited from FPCPersist

Name | Description
CancelWaitForChanges | Cancels the registration established by the WaitForChanges method (for use in C and C++ programming only).
CanImport | Returns a Boolean value that indicates whether the properties of the collection and its elements can be imported from the specified XML document.
Export | Writes the stored values of all the properties of the collection and its elements to the specified XML document.
ExportToFile | Writes the stored values of all the properties of the collection and its elements to the specified XML file.
GetServiceRestartMask | Retrieves a 32-bit bitmask of the FpcServices enumerated type that specifies which services need to be restarted for currently unsaved changes to take effect.
Import | Copies the values of all the properties of the collection and its elements from the specified XML document to persistent storage.
ImportFromFile | Copies the values of all the properties of the collection and its elements from the specified XML file to persistent storage.
LoadDocProperties | Provides the XML document's properties so that you can know what information can be imported from the document.
Refresh | Reads the values of all the properties of the collection and its elements from persistent storage, overwriting any changes that have not been saved.
Save | Writes the current values of all the properties of the collection and its elements to persistent storage.
WaitForChanges | Registers to wait for an event indicating that the contents of the object have changed (for use in C and C++ programming only).

Properties Inherited from FPCPersist

Name | Description
PersistentName | Gets the persistent name of the collection. The persistent name of an object is a name that is unique for the object at the respective level of the COM object hierarchy.
VendorParametersSets | Gets an FPCVendorParametersSets collection that can hold sets of custom data for extending the collection.

Remarks

This collection implements the IFPCComputers interface.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

COM Objects


IFPCComputers | FPCComputers _NewEnum(IUnknown) property [ISA Server 2004]

_NewEnum Property of IFPCComputers[C++]

FPCComputers._NewEnum [Visual Basic]

[C++]

The _NewEnum property gets an enumerator object for the collection. An enumerator object provides serial access to the elements of the collection.

HRESULT get__NewEnum(
  IUnknown* ppEnum
);

Parameters

ppEnum
Address of an interface pointer that on return points to the IUnknown interface of an enumerator object that implements an IEnumVARIANT interface for the collection. An interface pointer to the IEnumVARIANT interface of the enumerator object can be retrieved by calling QueryInterface on the IUnknown interface returned.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The _NewEnum property gets an enumerator object for the collection. An enumerator object provides serial access to the elements of the collection.

Property _NewEnum As IUnknown

Property Value

Reference to an enumerator object that provides serial access to the elements of the collection.

Remarks

This property is read-only.

In Visual Basic and VBScript, this property is used implicitly in For Each...In...Next constructs.

Example Code

This VBScript script displays the names and IP addresses of all the computers defined for an FPCArray object. It does not include error handling.

' Create the root object.
Dim root  ' The FPCLib.FPC root object
Set root = CreateObject("FPC.Root")

' Declare the other objects needed.
Dim array      ' An FPCArray object
Dim computers  ' An FPCComputers collection
Dim computer   ' An FPCComputer object

' Get references to the array object
' and the computers collection.
Set array = root.GetContainingArray()
Set computers = array.RuleElements.Computers

' Display the names and IP addresses of the computers
' defined for the array object.
For Each computer In computers
    WScript.Echo computer.Name & ": " & computer.IPAddress
Next

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCComputers


IFPCComputers | FPCComputers Add (3 Parameters) method [ISA Server 2004]

IFPCComputers::Add[C++]

FPCComputers.Add [Visual Basic]

[C++]

The Add method creates a new FPCComputer object in the collection and returns a reference to it.

HRESULT Add(
  BSTR Name,
  BSTR IPAddress,
  IFPCComputer** ppNewItem
);

Parameters

Name
[in] Required. BSTR that specifies the name of the new computer.
IPAddress
[in] Required. BSTR that specifies the IP address of the new computer.
ppNewItem
[out] Address of an interface pointer that on return points to the new IFPCComputer interface added.

Return Values

This method can return one of the following:

  • S_OK, indicating that the operation succeeded.
  • An error code, indicating that the operation failed. In this case, the [out] parameter returned is a null object.

[Visual Basic]

The Add method creates a new FPCComputer object in the collection and returns a reference to it.

Function Add( _
  ByVal Name As String, _
  ByVal IPAddress As String _
) As FPCComputer

Parameters

Name
[in] Required. String that specifies the name of the new computer.
IPAddress
[in] Required. String that specifies the IP address of the new computer.

Return Values

This method returns a reference to the FPCComputer object if successful. Otherwise, an error is raised that can be intercepted by using an error handler.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCComputers


IFPCComputers | FPCComputers Count(long) property [ISA Server 2004]

Count Property of IFPCComputers[C++]

FPCComputers.Count [Visual Basic]

[C++]

The Count property gets the number of FPCComputer objects in the collection.

HRESULT get_Count(
  long* plCount
);

Parameters

plCount
Pointer to a variable that on return receives a 32-bit integer specifying the number of FPCComputer objects in the collection.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The Count property gets the number of FPCComputer objects in the collection.

Property Count As Long

Property Value

A 32-bit integer that specifies the number of FPCComputer objects in the collection.

Remarks

This property is read-only.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCComputers


IFPCComputers | FPCComputers Item(Variant,IFPCComputer) method [ISA Server 2004]

IFPCComputers::Item[C++]

FPCComputers.Item [Visual Basic]

[C++]

The Item method retrieves the requested IFPCComputer interface from the collection.

HRESULT Item(
  VARIANT Index,
  IFPCComputer** ppItem
);

Parameters

Index
[in] Required. Name or one-based index of the object to retrieve.
ppItem
[out] Address of an interface pointer that on return points to the IFPCComputer interface requested.

Return Values

This method can return one of the following:

  • S_OK, indicating that the operation succeeded.
  • An error code, indicating that the operation failed. In this case, the [out] parameter returned is a null object.

[Visual Basic]

The Item method retrieves the requested FPCComputer object from the collection.

Function Item( _
  ByVal Index As Variant _
) As FPCComputer

Parameters

Index
[in] Required. Name or one-based index of the object to retrieve.

Return Values

This method returns a reference to the FPCComputer object requested if successful. Otherwise, an error is raised that can be intercepted by using an error handler.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCComputers


IFPCComputers | FPCComputers Remove(Variant) method [ISA Server 2004]

IFPCComputers::Remove[C++]

FPCComputers.Remove [Visual Basic]

[C++]

The Remove method removes the specified FPCComputer object from the collection.

HRESULT Remove(
  VARIANT Index
);

Parameters

Index
[in] Required. Name or one-based index of the FPCComputer object to remove.

Return Values

This method returns S_OK if the call is successful; otherwise, it returns an error code.
[Visual Basic]

The Remove method removes the specified FPCComputer object from the collection.

Sub Remove( _
  ByVal Index As Variant _
)

Parameters

Index
[in] Required. Name or one-based index of the FPCComputer object to remove.

Return Values

This method has no return values. If the call is unsuccessful, an error is raised that can be intercepted by using an error handler.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCComputers


FPCComputerSet object [ISA Server 2004]

FPCComputerSet

The FPCComputerSet object represents a set of computers that is defined by FPCComputers, FPCAddressRanges, and FPCSubnets collections.

This object is typically an element of an FPCComputerSets collection.

Click here to see the ISA Server object hierarchy.

Inheritance

This object inherits from the FPCPersist object, which contains methods and properties related to the persistent storage of an object's data. They include methods for exporting an object's data to and importing it from XML documents.

Methods

This object has no methods.

Properties

The FPCComputerSet object has the following properties.

Property | Description
AddressRanges | Gets an FPCAddressRanges collection that contains the IP address ranges included in the computer set.
Computers | Gets an FPCComputers collection that contains the computers included in the computer set.
Description | Gets or sets the description of the computer set.
Name | Gets or sets the name of the computer set.
Predefined | Gets a Boolean value that indicates whether the computer set is a predefined computer set that was created during the installation of ISA Server and cannot be deleted.
Subnets | Gets an FPCSubnets collection that contains the subnets included in the computer set.

Methods Inherited from FPCPersist

Name | Description
CancelWaitForChanges | Cancels the registration established by the WaitForChanges method (for use in C and C++ programming only).
CanImport | Returns a Boolean value that indicates whether the object's properties can be imported from the specified XML document.
Export | Recursively writes the stored values of all the properties of the object and its subobjects to the specified XML document.
ExportToFile | Recursively writes the stored values of all the properties of the object and its subobjects to the specified XML file.
GetServiceRestartMask | Retrieves a 32-bit bitmask of the FpcServices enumerated type that specifies which services need to be restarted for currently unsaved changes to take effect.
Import | Recursively copies the values of all the properties of the object and of its subobjects from the specified XML document to persistent storage.
ImportFromFile | Recursively copies the values of all the properties of the object and of its subobjects from the specified XML file to persistent storage.
LoadDocProperties | Provides the XML document's properties so that you can know what information can be imported from the document.
Refresh | Recursively reads the values of all the properties of the object and of its subobjects from persistent storage, overwriting any changes that have not been saved.
Save | Recursively writes the current values of all the properties of the object and its subobjects to persistent storage.
WaitForChanges | Registers to wait for an event indicating that the contents of the object have changed (for use in C and C++ programming only).

Properties Inherited from FPCPersist

Name | Description
PersistentName | Gets the persistent name of the object. The persistent name of an object is a name that is unique for the object at the respective level of the COM object hierarchy.
VendorParametersSets | Gets an FPCVendorParametersSets collection that can hold sets of custom data for extending the object.

Remarks

This object implements the IFPCComputerSet interface.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

COM Objects


IFPCComputerSet | FPCComputerSet AddressRanges property [ISA Server 2004]

AddressRanges Property of IFPCComputerSet[C++]

FPCComputerSet.AddressRanges [Visual Basic]

[C++]

The AddressRanges property gets an FPCAddressRanges collection that contains the IP address ranges included in the computer set.

HRESULT get_AddressRanges(
  IFPCAddressRanges** ppAddressRanges
);

Parameters

ppAddressRanges
Address of an interface pointer that on return points to an IFPCAddressRanges interface representing the collection of IP address ranges.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only. It can be modified by calling the methods of the IFPCAddressRanges interface retrieved.

[Visual Basic]

The AddressRanges property gets an FPCAddressRanges collection that contains the IP address ranges included in the computer set.

Property AddressRanges As FPCAddressRanges

Property Value

Reference to an FPCAddressRanges collection that contains the IP address ranges included in the computer set.

Remarks

This property is read-only. It can be modified by calling the methods of the FPCAddressRanges collection retrieved.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCComputerSet


IFPCComputerSet | FPCComputerSet Computers property [ISA Server 2004]

Computers Property of IFPCComputerSet[C++]

FPCComputerSet.Computers [Visual Basic]

[C++]

The Computers property gets an FPCComputers collection that contains the computers included in the computer set.

HRESULT get_Computers(
  IFPCComputers** ppComputers
);

Parameters

ppComputers
Address of an interface pointer that on return points to an IFPCComputers interface representing the collection of computers.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only. It can be modified by calling the methods of the IFPCComputers interface retrieved.

[Visual Basic]

The Computers property gets an FPCComputers collection that contains the computers included in the computer set.

Property Computers As FPCComputers

Property Value

Reference to an FPCComputers collection that contains the computers included in the computer set.

Remarks

This property is read-only. It can be modified by calling the methods of the FPCComputers collection retrieved.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCComputerSet


IFPCComputerSet | FPCComputerSet Description property [ISA Server 2004]

Description Property of IFPCComputerSet[C++]

FPCComputerSet.Description [Visual Basic]

[C++]

The Description property gets or sets the description of the computer set.

HRESULT get_Description(
  BSTR** pbstrDescription
);

HRESULT put_Description(
  BSTR bstrDescription
);

Parameters

pbstrDescription
Pointer to a BSTR that is set on return to a string value specifying the description of the computer set.
bstrDescription
BSTR that specifies the description of the computer set.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write.

[Visual Basic]

The Description property gets or sets the description of the computer set.

Property Description As String

Property Value

String that specifies the description of the computer set.

Remarks

This property is read/write.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCComputerSet


IFPCComputerSet | FPCComputerSet Name(BSTR,BSTR) property [ISA Server 2004]

Name Property of IFPCComputerSet[C++]

FPCComputerSet.Name [Visual Basic]

[C++]

The Name property gets or sets the name of the computer set.

HRESULT get_Name(
  BSTR** pbstrName
);

HRESULT put_Name(
  BSTR bstrName
);

Parameters

pbstrName
Pointer to a BSTR that is set on return to a string value specifying the name of the computer set.
bstrName
BSTR that specifies the name of the compute set.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write.

[Visual Basic]

The Name property gets or sets the name of the computer set.

Property Name As String

Property Value

String that specifies the name of the computer set.

Remarks

This property is read/write.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCComputerSet


IFPCComputerSet | FPCComputerSet Predefined property [ISA Server 2004]

Predefined Property of IFPCComputerSet[C++]

FPCComputerSet.Predefined [Visual Basic]

[C++]

The Predefined property gets a Boolean value that indicates whether the computer set is a predefined computer set that was created during the installation of ISA Server and cannot be deleted.

HRESULT get_Predefined(
  VARIANT_BOOL* pfPredefined
);

Parameters

pfPredefined
Pointer to a Boolean variable that is set on return to VARIANT_TRUE if the computer set is predefined, or to VARIANT_FALSE if the computer set is user-defined.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The Predefined property gets a Boolean value that indicates whether the computer set is a predefined computer set that was created during the installation of ISA Server and cannot be deleted.

Property Predefined As Boolean

Property Value

Boolean value that specifies whether the computer set is predefined.

Remarks

This property is read-only.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCComputerSet


IFPCComputerSet | FPCComputerSet Subnets(IFPCSubnets) property [ISA Server 2004]

Subnets Property of IFPCComputerSet[C++]

FPCComputerSet.Subnets [Visual Basic]

[C++]

The Subnets property gets an FPCSubnets collection that contains the subnets included in the computer set.

HRESULT get_Subnets(
  IFPCSubnets** ppSubnets
);

Parameters

ppSubnets
Address of an interface pointer that on return points to an IFPCSubnets interface representing the collection of subnets.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only. It can be modified by calling the methods of the IFPCSubnets interface retrieved.

[Visual Basic]

The Subnets property gets an FPCSubnets collection that contains the subnets included in the computer set.

Property Subnets As FPCSubnets

Property Value

Reference to an FPCSubnets collection of subnets.

Remarks

This property is read-only. It can be modified by calling the methods of the FPCSubnets collection retrieved.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCComputerSet


FPCComputerSets collection [ISA Server 2004]

FPCComputerSets Collection

The FPCComputerSets collection holds a group of FPCComputerSet objects that represent all of the computer sets defined for an FPCArray object.

This collection can be accessed through the ComputerSets property of an FPCRuleElements object.

Click here to see the ISA Server object hierarchy.

Inheritance

This collection inherits from the FPCPersist object, which contains methods and properties related to the persistent storage of an object's data. They include methods for exporting the object's data to and importing it from an XML document.

Methods

The FPCComputerSets collection defines the following methods.

Method | Description
Add | Creates a new FPCComputerSet object in the collection and returns a reference to it.
Item | Retrieves the requested FPCComputerSet object from the collection.
Remove | Removes the specified FPCComputerSet object from the collection.

Properties

The FPCComputerSets collection has the following properties.

Property | Description
_NewEnum | Gets an enumerator object for the collection.
Count | Gets the number of FPCComputerSet objects in the collection.

Methods Inherited from FPCPersist

Name | Description
CancelWaitForChanges | Cancels the registration established by the WaitForChanges method (for use in C and C++ programming only).
CanImport | Returns a Boolean value that indicates whether the properties of the collection, its elements, and their subobjects can be imported from the specified XML document.
Export | Recursively writes the stored values of all the properties of the collection, its elements, and their subobjects to the specified XML document.
ExportToFile | Recursively writes the stored values of all the properties of the collection, its elements, and their subobjects to the specified XML file.
GetServiceRestartMask | Retrieves a 32-bit bitmask of the FpcServices enumerated type that specifies which services need to be restarted for currently unsaved changes to take effect.
Import | Recursively copies the values of all the properties of the collection, its elements, and their subobjects from the specified XML document to persistent storage.
ImportFromFile | Recursively copies the values of all the properties of the collection, its elements, and their subobjects from the specified XML file to persistent storage.
LoadDocProperties | Provides the XML document's properties so that you can know what information can be imported from the document.
Refresh | Recursively reads the values of all the properties of the collection, its elements, and their subobjects from persistent storage, overwriting any changes that have not been saved.
Save | Recursively writes the current values of all the properties of the collection, its elements, and their subobjects to persistent storage.
WaitForChanges | Registers to wait for an event indicating that the contents of the object have changed (for use in C and C++ programming only).

Properties Inherited from FPCPersist

Name | Description
PersistentName | Gets the persistent name of the collection. The persistent name of an object is a name that is unique for the object at the respective level of the COM object hierarchy.
VendorParametersSets | Gets an FPCVendorParametersSets collection that can hold sets of custom data for extending the collection.

Remarks

This collection implements the IFPCComputerSets interface.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

COM Objects


IFPCComputerSets | FPCComputerSets _NewEnum(IUnknown) property [ISA Server 2004]

_NewEnum Property of IFPCComputerSets[C++]

FPCComputerSets._NewEnum [Visual Basic]

[C++]

The _NewEnum property gets an enumerator object for the collection. An enumerator object provides serial access to the elements of the collection.

HRESULT get__NewEnum(
  IUnknown* ppEnum
);

Parameters

ppEnum
Address of an interface pointer that on return points to the IUnknown interface of an enumerator object that implements an IEnumVARIANT interface for the collection. An interface pointer to the IEnumVARIANT interface of the enumerator object can be retrieved by calling QueryInterface on the IUnknown interface returned.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The _NewEnum property gets an enumerator object for the collection. An enumerator object provides serial access to the elements of the collection.

Property _NewEnum As IUnknown

Property Value

Reference to an enumerator object that provides serial access to the elements of the collection.

Remarks

This property is read-only.

In Visual Basic and VBScript, this property is used implicitly in For Each...In...Next constructs.

Example Code

This VBScript script displays the names of all the computer sets defined for an FPCArray object. It does not include error handling.

' Create the root object.
Dim root  ' The FPCLib.FPC root object
Set root = CreateObject("FPC.Root")

' Declare the other objects needed.
Dim array         ' An FPCArray object
Dim computersets  ' An FPCComputerSets collection
Dim computerset   ' An FPCComputerSet object

' Get references to the array object
' and the computer sets collection.
Set array = root.GetContainingArray()
Set computersets = array.RuleElements.ComputerSets

' Display the names of the computer sets
' defined for the array object.
For Each computerset In computersets
    WScript.Echo "Computer set name: " & computerset.Name
Next

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCComputerSets


IFPCComputerSets | FPCComputerSets Add (2 Parameters) method [ISA Server 2004]

IFPCComputerSets::Add[C++]

FPCComputerSets.Add [Visual Basic]

[C++]

The Add method creates a new FPCComputerSet object in the collection and returns a reference to it.

HRESULT Add(
  BSTR Name,
  IFPCComputerSet** ppNewItem
);

Parameters

Name
[in] Required. BSTR that specifies the name of the new computer set.
ppNewItem
[out] Address of an interface pointer that on return points to the new IFPCComputerSet interface created.

Return Values

This method can return one of the following:

  • S_OK, indicating that the operation succeeded.
  • An error code, indicating that the operation failed. In this case, the [out] parameter returned is a null object.

[Visual Basic]

The Add method creates a new FPCComputerSet object in the collection and returns a reference to it.

Function Add( _
  ByVal Name As String _
) As FPCComputerSet

Parameters

Name
[in] Required. String that specifies the name of the new computer set.

Return Values

This method returns a reference to an FPCComputerSet object if successful. Otherwise, an error is raised that can be intercepted by using an error handler.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCComputerSets


IFPCComputerSets | FPCComputerSets Count(long) property [ISA Server 2004]

Count Property of IFPCComputerSets[C++]

FPCComputerSets.Count [Visual Basic]

[C++]

The Count property gets the number of FPCComputerSet objects in the collection.

HRESULT get_Count(
  long* plCount
);

Parameters

plCount
Pointer to a variable that on return receives a 32-bit integer specifying the number of FPCComputerSet objects in the collection.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The Count property gets the number of FPCComputerSet objects in the collection.

Property Count As Long

Property Value

A 32-bit integer that specifies the number of FPCComputerSet objects in the collection.

Remarks

This property is read-only.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCComputerSets


IFPCComputerSets | FPCComputerSets Item (2 Parameters) method [ISA Server 2004]

IFPCComputerSets::Item[C++]

FPCComputerSets.Item [Visual Basic]

[C++]

The Item method retrieves the requested IFPCComputerSet interface from the collection.

HRESULT Item(
  VARIANT Index,
  IFPCComputerSet** ppItem
);

Parameters

Index
[in] Required. Name or one-based index of the object to retrieve.
ppItem
[out] Address of an interface pointer that on return points to the IFPCComputerSet interface requested.

Return Values

This method can return one of the following:

  • S_OK, indicating that the operation succeeded.
  • An error code, indicating that the operation failed. In this case, the [out] parameter returned is a null object.
[Visual Basic]

The Item method retrieves the requested FPCComputerSet object from the collection.

Function Item( _
  ByVal Index As Variant _
) As FPCComputerSet

Parameters

Index
[in] Required. Name or one-based index of the object to retrieve.

Return Values

This method returns a reference to the FPCComputerSet object requested if successful. Otherwise, an error is raised that can be intercepted by using an error handler.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCComputerSets


IFPCComputerSets | FPCComputerSets Remove(Variant) method [ISA Server 2004]

IFPCComputerSets::Remove[C++]

FPCComputerSets.Remove [Visual Basic]

[C++]

The Remove method removes the specified FPCComputerSet object from the collection.

HRESULT Remove(
  VARIANT Index
);

Parameters

Index
[in] Required. Name or one-based index of the FPCComputerSet object to remove.

Return Values

This method returns S_OK if the call is successful; otherwise, it returns an error code.

[Visual Basic]

The Remove method removes the specified FPCComputerSet object from the collection.

Sub Remove( _
  ByVal Index As Variant _
)

Parameters

Index
[in] Required. Name or one-based index of the FPCComputerSet object to remove.

Return Values

This method has no return values. If the call is unsuccessful, an error is raised that can be intercepted by using an error handler.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCComputerSets


FPCConnectionLimit object [ISA Server 2004]

FPCConnectionLimit

The FPCConnectionLimit object represents the limits imposed on the number of transport-layer protocol connections allowed at one time for a user. Examples of transport-layer protocols are TCP and UDP.

In the case of UDP, the limit applies to connection mappings, rather than to connections.

When the TCP connection limit for a user is reached, no additional TCP connections are allowed for the user.

When the UDP connection limit for a user is reached and the user attempts to make an additional UDP connection, the first UDP connection that the user made is closed, and the new connection is established.

The FPCConnectionLimit object is typically accessed through the DefaultLimit and SpecialLimit properties of an FPCConnectionLimitPolicy object.

Click here to see the ISA Server object hierarchy.

Inheritance

This object inherits from the FPCPersist object, which contains methods and properties related to the persistent storage of an object's data. They include methods for exporting the object's data to and importing it from an XML document.

Methods

This object has no methods.

Properties

The FPCConnectionLimit object has the following properties.

Property | Description
OtherLimit | Gets or sets the number of connections using transport-layer protocols other than TCP or UDP that are allowed for a user.
TcpLimit | Gets or sets the number of TCP connections that are allowed for a user.
UdpLimit | Gets or sets the number of UDP connection mappings that are allowed for a user.

Methods Inherited from FPCPersist

Name | Description
CancelWaitForChanges | Cancels the registration established by the WaitForChanges method (for use in C and C++ programming only).
CanImport | Returns a Boolean value that indicates whether the object's properties can be imported from the specified XML document.
Export | Writes the stored values of all of the object's properties to the specified XML document.
ExportToFile | Writes the stored values of all of the object's properties to the specified XML file.
GetServiceRestartMask | Retrieves a 32-bit bitmask of the FpcServices enumerated type that specifies which services need to be restarted for currently unsaved changes to take effect.
Import | Copies the values of all of the object's properties from the specified XML document to persistent storage.
ImportFromFile | Copies the values of all of the object's properties from the specified XML file to persistent storage.
LoadDocProperties | Provides the XML document's properties so that you can know what information can be imported from the document.
Refresh | Reads the values of all of the object's properties from persistent storage, overwriting any changes that have not been saved.
Save | Writes the current values of all of the object's properties to persistent storage.
WaitForChanges | Registers to wait for an event indicating that the contents of the object have changed (for use in C and C++ programming only).

Properties Inherited from FPCPersist

Name | Description
PersistentName | Gets the persistent name of the object. The persistent name of an object is a name that is unique for the object at the respective level of the COM object hierarchy.
VendorParametersSets | Gets an FPCVendorParametersSets object that can hold sets of custom data for extending the object.

Remarks

This object implements the IFPCConnectionLimit interface.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

COM Objects


IFPCConnectionLimit | FPCConnectionLimit OtherLimit property [ISA Server 2004]

OtherLimit Property of IFPCConnectionLimit[C++]

FPCConnectionLimit.OtherLimit [Visual Basic]

[C++]

The OtherLimit property gets or sets the number of connections using transport-layer protocols other than TCP or UDP that are allowed for a user.

HRESULT get_OtherLimit(
  long* plOtherLimit
);

HRESULT put_OtherLimit(
  long lOtherLimit
);

Parameters

plOtherLimit
Pointer to a variable that on return receives a 32-bit integer specifying the number of connections using transport-layer protocols other than TCP or UDP that are allowed for a user.
lOtherLimit
A 32-bit integer that specifies the number of connections using transport-layer protocols other than TCP or UDP that are allowed for a user.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write. The default value is 160 connections.

[Visual Basic]

The OtherLimit property gets or sets the number of connections using transport-layer protocols other than TCP or UDP that are allowed for a user.

Property OtherLimit As Long

Property Value

A 32-bit integer that specifies the number of connections using transport-layer protocols other than TCP or UDP that are allowed for a user.

Remarks

This property is read/write. The default value is 160 connections.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCConnectionLimit


IFPCConnectionLimit | FPCConnectionLimit TcpLimit property [ISA Server 2004]

TcpLimit Property of IFPCConnectionLimit[C++]

FPCConnectionLimit.TcpLimit [Visual Basic]

[C++]

The TcpLimit property gets or sets the number of TCP connections that are allowed for a user.

HRESULT get_TcpLimit(
  long* plTcpLimit
);

HRESULT put_TcpLimit(
  long lTcpLimit
);

Parameters

plTcpLimit
Pointer to a variable that on return receives a 32-bit integer specifying the number of TCP connections that are allowed for a user.
lTcpLimit
A 32-bit integer that specifies the number of TCP connections that are allowed for a user.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write. The default value is 160 connections.

[Visual Basic]

The TcpLimit property gets or sets the number of TCP connections that are allowed for a user.

Property TcpLimit As Long

Property Value

A 32-bit integer that specifies the number of TCP connections that are allowed for a user.

Remarks

This property is read/write. The default value is 160 connections.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCConnectionLimit


IFPCConnectionLimit | FPCConnectionLimit UdpLimit property [ISA Server 2004]

UdpLimit Property of IFPCConnectionLimit[C++]

FPCConnectionLimit.UdpLimit [Visual Basic]

[C++]

The UdpLimit property gets or sets the number of UDP connection mappings that are allowed for a user.

HRESULT get_UdpLimit(
  long* plUdpLimit
);

HRESULT put_UdpLimit(
  long lUdpLimit
);

Parameters

plUdpLimit
Pointer to a variable that on return receives a 32-bit integer specifying the number of UDP connection mappings that are allowed for a user.
lUdpLimit
A 32-bit integer that specifies the number of UDP connection mappings that are allowed for a user.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write. The default value is 160 connection mappings.

[Visual Basic]

The UdpLimit property gets or sets the number of UDP connection mappings that are allowed for a user.

Property UdpLimit As Long

Property Value

A 32-bit integer that specifies the number of UDP connection mappings that are allowed for a user.

Remarks

This property is read/write. The default value is 160 connection mappings.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCConnectionLimit


FPCConnectionLimitPolicy object [ISA Server 2004]

FPCConnectionLimitPolicy

The FPCConnectionLimitPolicy object represents a connection limit policy. A connection limit establishes how many transport-layer protocol connections can exist at one time for a single user. Examples of transport-layer protocols are TCP and UDP. The policy designates connection limits for default users and connection limits for special users.

When the TCP connection limit for a user is reached, no additional TCP connections are allowed for the user.

When the UDP connection limit for a user is reached and the user attempts to make an additional UDP connection, the first UDP connection that the user made is closed, and the new connection is established.

A typical special user would be a Web server, which would require many more connections than a default user.

Special users can be defined using computer sets.

The FPCConnectionLimitPolicy object is typically accessed through the ConnectionLimitPolicy property of an FPCArrayPolicy object.

Click here to see the ISA Server object hierarchy.

Inheritance

This object inherits from the FPCPersist object, which contains methods and properties related to the persistent storage of an object's data. They include methods for exporting the object's data to and importing it from an XML document.

Methods

This object has no methods.

Properties

The FPCConnectionLimitPolicy object has the following properties.

Property | Description
DefaultLimit | Gets an FPCConnectionLimit object that specifies the connection limits for a default user.
Enabled | Gets or sets a Boolean value that indicates whether the connection limit policy is enabled.
RulePerSecondLimit | Gets or sets the maximum number of connections that can be created for a rule during one second.
SpecialComputerSets | Gets an FPCRefs collection that contains references to the FPCComputerSet objects defining the computer sets to which the special connection limits apply.
SpecialLimit | Gets an FPCConnectionLimit object that specifies the connection limits for a special user.

Methods Inherited from FPCPersist

Name | Description
CancelWaitForChanges | Cancels the registration established by the WaitForChanges method (for use in C and C++ programming only).
CanImport | Returns a Boolean value that indicates whether the object's properties can be imported from the specified XML document.
Export | Recursively writes the stored values of all the properties of the object and its subobjects to the specified XML document.
ExportToFile | Recursively writes the stored values of all the properties of the object and its subobjects to the specified XML file.
GetServiceRestartMask | Retrieves a 32-bit bitmask of the FpcServices enumerated type that specifies which services need to be restarted for currently unsaved changes to take effect.
Import | Recursively copies the values of all the properties of the object and of its subobjects from the specified XML document to persistent storage.
ImportFromFile | Recursively copies the values of all the properties of the object and of its subobjects from the specified XML file to persistent storage.
LoadDocProperties | Provides the XML document's properties so that you can know what information can be imported from the document.
Refresh | Recursively reads the values of all the properties of the object and of its subobjects from persistent storage, overwriting any changes that have not been saved.
Save | Recursively writes the current values of all the properties of the object and its subobjects to persistent storage.
WaitForChanges | Registers to wait for an event indicating that the contents of the object have changed (for use in C and C++ programming only).

Properties Inherited from FPCPersist

Name | Description
PersistentName | Gets the persistent name of the object. The persistent name of an object is a name that is unique for the object at the respective level of the COM object hierarchy.
VendorParametersSets | Gets an FPCVendorParametersSets collection that can hold sets of custom data for extending the object.

Remarks

This object implements the IFPCConnectionLimitPolicy interface.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

COM Objects


IFPCConnectionLimitPolicy.DefaultLimit (1 Parameter) property [ISA Server 2004]

DefaultLimit Property of IFPCConnectionLimitPolicy[C++]

FPCConnectionLimitPolicy.DefaultLimit [Visual Basic]

[C++]

The DefaultLimit property gets an FPCConnectionLimit object that specifies the connection limits for a default user.

HRESULT get_DefaultLimit(
  IFPCConnectionLimit** ppConnectionLimits
);

Parameters

ppConnectionLimits
Address of an interface pointer that on return points to an IFPCConnectionLimit interface that specifies the connection limits for a default user.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only. It can be modified by setting the properties of the IFPCConnectionLimit interface retrieved.

[Visual Basic]

The DefaultLimit property gets an FPCConnectionLimit object that specifies the connection limits for a default user.

Property DefaultLimit As FPCConnectionLimit

Property Value

Reference to an FPCConnectionLimit object that specifies the connection limits for a default user.

Remarks

This property is read-only. It can be modified by setting the properties of the FPCConnectionLimit object retrieved.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCConnectionLimitPolicy


IFPCConnectionLimitPolicy.Enabled (2 Parameters) property [ISA Server 2004]

Enabled Property of IFPCConnectionLimitPolicy[C++]

FPCConnectionLimitPolicy.Enabled [Visual Basic]

[C++]

The Enabled property gets or sets a Boolean value that indicates whether the connection limit policy is enabled.

HRESULT get_Enabled(
  VARIANT_BOOL* pfEnabled
);

HRESULT put_Enabled(
  VARIANT_BOOL fEnabled
);

Parameters

pfEnabled
Pointer to a Boolean variable that is set on return to VARIANT_TRUE if the connection limit policy is enabled, or to VARIANT_FALSE if the connection limit policy is disabled.
fEnabled
Boolean value that indicates whether the connection limit policy is enabled.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write.

[Visual Basic]

The Enabled property gets or sets a Boolean value that indicates whether the connection limit policy is enabled.

Property Enabled As Boolean

Property Value

Boolean value that indicates whether the connection limit policy is enabled.

Remarks

This property is read/write.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCConnectionLimitPolicy


IFPCConnectionLimitPolicy.RulePerSecondLimit property [ISA Server 2004]

RulePerSecondLimit Property of IFPCConnectionLimitPolicy[C++]

FPCConnectionLimitPolicy.RulePerSecondLimit [Visual Basic]

[C++]

The RulePerSecondLimit property gets or sets the maximum number of connections that can be created for a rule during one second.

HRESULT get_RulePerSecondLimit(
  long* plLimit
);

HRESULT put_RulePerSecondLimit(
  long lLimit
);

Parameters

plLimit
Pointer to a variable that on return receives a 32-bit integer specifying the maximum number of connections that can be created for a rule during one second.
lLimit
A 32-bit integer that specifies the maximum number of connections that can be created for a rule during one second.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write. Its default value is 1000, and its range of permissible values extends from 100 and 9,999,999.

When the number of connections created for a specific rule during the current second reaches the limit set by this property, ISA Server will not create another connection for new traffic that has no connection associated with it, the packets will be dropped, and an event will be generated. After the current second passes, the counter is reset, and new connections can be created during the next second until the limit is reached again.

Connections created for TCP traffic are not counted against the maximum number of connections that can be created for a rule during one second. Land attack detection can be enabled for TCP traffic. For more information, see LandAttackDetectionEnabled.

[Visual Basic]

The RulePerSecondLimit property gets or sets the maximum number of connections that can be created for a rule during one second.

Property RulePerSecondLimit As Long

Property Value

A 32-bit integer that specifies the maximum number of connections that can be created for a rule during one second.

Remarks

This property is read/write. Its default value is 1000, and its range of permissible values extends from 100 and 9,999,999.

When the number of connections created for a specific rule during the current second reaches the limit set by this property, ISA Server will not create another connection for new traffic that has no connection associated with it, the packets will be dropped, and an event will be generated. After the current second passes, the counter is reset, and new connections can be created during the next second until the limit is reached again.

Connections created for TCP traffic are not counted against the maximum number of connections that can be created for a rule during one second. Land attack detection can be enabled for TCP traffic. For more information, see LandAttackDetectionEnabled.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCConnectionLimitPolicy


IFPCConnectionLimitPolicy.SpecialComputerSets property [ISA Server 2004]

SpecialComputerSets Property of IFPCConnectionLimitPolicy[C++]

FPCConnectionLimitPolicy.SpecialComputerSets [Visual Basic]

[C++]

The SpecialComputerSets property gets an FPCRefs collection that contains references to the FPCComputerSet objects defining the computer sets to which the special connection limits apply.

HRESULT get_SpecialComputerSets(
  IFPCRefs** ppRefs
);

Parameters

ppRefs
Address of an interface pointer that on return points to an IFPCRefs interface that represents the collection of references to the computer sets to which the special connection limits apply.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only. It can be modified by calling the methods of the IFPCRefs interface retrieved.

[Visual Basic]

The SpecialComputerSets property gets an FPCRefs collection that contains references to the FPCComputerSet objects defining the computer sets to which the special connection limits apply.

Property SpecialComputerSets As FPCRefs

Property Value

Reference to an FPCRefs collection that contains references to the computer sets to which the special connection limits apply.

Remarks

This property is read-only. It can be modified by calling the methods of the FPCRefs object retrieved.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCConnectionLimitPolicy


IFPCConnectionLimitPolicy.SpecialLimit (1 Parameter) property [ISA Server 2004]

SpecialLimit Property of IFPCConnectionLimitPolicy[C++]

FPCConnectionLimitPolicy.SpecialLimit [Visual Basic]

[C++]

The SpecialLimit property gets an FPCConnectionLimit object that specifies the connection limits for a special user. Special users are defined in the SpecialComputerSets property.

HRESULT get_SpecialLimit(
  IFPCConnectionLimit** ppConnectionLimits
);

Parameters

ppConnectionLimits
Address of an interface pointer that on return points to an IFPCConnectionLimit interface that specifies the connection limits for a special user.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only. It can be modified by setting the properties of the IFPCConnectionLimit interface retrieved.

[Visual Basic]

The SpecialLimit property gets an FPCConnectionLimit object that specifies the connection limits for a special user. Special users are defined in the SpecialComputerSets property.

Property SpecialLimit As FPCConnectionLimit

Property Value

Reference to an FPCConnectionLimit object that specifies the connection limits for a special user.

Remarks

This property is read-only. It can be modified by setting the properties of the FPCConnectionLimit object retrieved.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCConnectionLimitPolicy


FPCConnectivityResult object [ISA Server 2004]

FPCConnectivityResult

The FPCConnectivityResult object represents the results of the attempts of a connectivity verifier, which is represented by an FPCConnectivityVerifier object, to verify connectivity. A connectivity verifier checks the connectivity from an ISA Server computer to another computer, such as an external Web server.

This object is typically an element of an FPCConnectivityResults collection.

Click here to see the ISA Server object hierarchy.

Methods

This object has no methods.

Properties

The FPCConnectivityResult object has the following properties.

Property | Description
DateCheckedFirst | Gets a Date value that specifies the date and time in Coordinated Universal Time (UTC) when connectivity was first checked.
DateCheckedLast | Gets a Date value that specifies the date and time in Coordinated Universal Time (UTC) when connectivity was last checked.
ErrorCode | Gets a value from the FpcConnectivityErrorCode enumerated type that specifies the last error code obtained in an attempt to verify connectivity.
RequestType | Gets a value from the FpcRequestType enumerated type that specifies the type of request used for checking connectivity.
Result | Gets the amount of time for the last connectivity verification request to be sent and the reply to be received, in milliseconds.
ServerAddress | Gets the IP address of the remote server to which connectivity was checked.
TCPPort | Gets the TCP port on the remote server used for checking connectivity.

Remarks

This object implements the IFPCConnectivityResult interface.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

COM Objects


IFPCConnectivityResult.DateCheckedFirst(DATE) property [ISA Server 2004]

DateCheckedFirst Property of IFPCConnectivityResult[C++]

FPCConnectivityResult.DateCheckedFirst [Visual Basic]

[C++]

The DateCheckedFirst property gets a DATE value that specifies the date and time in Coordinated Universal Time (UTC) when connectivity was first checked.

HRESULT get_DateCheckedFirst(
  DATE* pdDateCheckedFirst
);

Parameters

pdDateCheckedFirst
Pointer to a DATE that is set on return to the value specifying the date and time in Coordinated Universal Time (UTC) when connectivity was first checked.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The DateCheckedFirst property gets a Date value that specifies the date and time in Coordinated Universal Time (UTC) when connectivity was first checked.

Property DateCheckedFirst As Date

Property Value

Date value that specifies the date and time in Coordinated Universal Time (UTC) when connectivity was first checked.

Remarks

This property is read-only.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCConnectivityResult


IFPCConnectivityResult.DateCheckedLast(DATE) property [ISA Server 2004]

DateCheckedLast Property of IFPCConnectivityResult[C++]

FPCConnectivityResult.DateCheckedLast [Visual Basic]

[C++]

The DateCheckedLast property gets a DATE value that specifies the date and time in Coordinated Universal Time (UTC) when connectivity was last checked.

HRESULT get_DateCheckedLast(
  DATE* pdDateCheckedLast
);

Parameters

pdDateCheckedLast
Pointer to a DATE that is set on return to the value specifying the date and time in Coordinated Universal Time (UTC) when connectivity was last checked.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The DateCheckedLast property gets a Date value that specifies the date and time in Coordinated Universal Time (UTC) when connectivity was last checked.

Property DateCheckedLast As Date

Property Value

Date value that specifies the date and time in Coordinated Universal Time (UTC) when connectivity was last checked.

Remarks

This property is read-only.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCConnectivityResult


IFPCConnectivityResult.ErrorCode (1 Parameter) property [ISA Server 2004]

ErrorCode Property of IFPCConnectivityResult[C++]

FPCConnectivityResult.ErrorCode [Visual Basic]

[C++]

The ErrorCode property gets a value from the FpcConnectivityErrorCode enumerated type that specifies the last error code obtained in an attempt to verify connectivity.

HRESULT get_ErrorCode(
  FpcConnectivityErrorCode* pErrorCode
);

Parameters

pErrorCode
Pointer to a variable that on return receives a value from the FpcConnectivityErrorCode enumerated type specifying the last error code obtained.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The ErrorCode property gets a value from the FpcConnectivityErrorCode enumerated type that specifies the last error code obtained in an attempt to verify connectivity.

Property ErrorCode As FpcConnectivityErrorCode

Property Value

Value from the FpcConnectivityErrorCode enumerated type that specifies the last error code obtained.

Remarks

This property is read-only.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCConnectivityResult


IFPCConnectivityResult.RequestType(FpcRequestType) property [ISA Server 2004]

RequestType Property of IFPCConnectivityResult[C++]

FPCConnectivityResult.RequestType [Visual Basic]

[C++]

The RequestType property gets a value from the FpcRequestType enumerated type that specifies the type of request used for checking connectivity. This can be an HTTP request, a ping request, or a Transmission Control Protocol (TCP) connection request.

HRESULT get_RequestType(
  FpcRequestType* pRequestType
);

Parameters

pRequestType
Pointer to a variable that on return receives a value from the FpcRequestType enumerated type specifying the type of request used for checking connectivity.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The RequestType property gets a value from the FpcRequestType enumerated type that specifies the type of request used for checking connectivity. This can be an HTTP request, a ping request, or a Transmission Control Protocol (TCP) connection request.

Property RequestType As FpcRequestType

Property Value

Value from the FpcRequestType enumerated type that specifies the type of request used for checking connectivity.

Remarks

This property is read-only.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCConnectivityResult


IFPCConnectivityResult.Result(Long) property [ISA Server 2004]

Result Property of IFPCConnectivityResult[C++]

FPCConnectivityResult.Result [Visual Basic]

[C++]

The Result property gets the amount of time for the last connectivity verification request to be sent and the reply to be received, in milliseconds.

HRESULT get_Result(
  Long* plResult
);

Parameters

plResult
Pointer to a variable that on return receives a 32-bit integer specifying the amount of time for the last connectivity verification request to be sent and the reply to be received, in milliseconds.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The Result property gets the amount of time for the last connectivity verification request to be sent and the reply to be received, in milliseconds.

Property Result As Long

Property Value

A 32-bit integer that specifies the amount of time for the last connectivity verification request to be sent and the reply to be received, in milliseconds.

Remarks

This property is read-only.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCConnectivityResult


IFPCConnectivityResult.ServerAddress(BSTR) property [ISA Server 2004]

ServerAddress Property of IFPCConnectivityResult[C++]

FPCConnectivityResult.ServerAddress [Visual Basic]

[C++]

The ServerAddress property gets the IP address of the remote server to which connectivity was checked.

HRESULT get_ServerAddress(
  BSTR* pbstrServerAddress
);

Parameters

pbstrServerAddress
Pointer to a BSTR that is set on return to a string value specifying the IP address of the remote server to which connectivity was checked.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The ServerAddress property gets the IP address of the remote server to which connectivity was checked.

Property ServerAddress As String

Property Value

String that specifies the IP address of the remote server to which connectivity was checked.

Remarks

This property is read-only.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCConnectivityResult


IFPCConnectivityResult.TCPPort(Long) property [ISA Server 2004]

TCPPort Property of IFPCConnectivityResult[C++]

FPCConnectivityResult.TCPPort [Visual Basic]

[C++]

The TCPPort property gets the Transmission Control Protocol (TCP) port on the remote server used for checking connectivity.

HRESULT get_TCPPort(
  Long* plTCPPort
);

Parameters

plTCPPort
Pointer to a variable that on return receives a 32-bit integer specifying the TCP port on the remote server used for checking connectivity.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The TCPPort property gets the Transmission Control Protocol (TCP) port on the remote server used for checking connectivity.

Property TCPPort As Long

Property Value

A 32-bit integer that specifies the TCP port on the remote server used for checking connectivity.

Remarks

This property is read-only.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCConnectivityResult


FPCConnectivityResults collection [ISA Server 2004]

FPCConnectivityResults Collection

The FPCConnectivityResults collection holds a set of FPCConnectivityResult objects. Each FPCConnectivityResult object represents the results of the attempts of a connectivity verifier, which is represented by an FPCConnectivityVerifier object, to verify connectivity.

The FPCConnectivityResults collection can be accessed through the ConnectivityResults property of an FPCServer object.

Click here to see the ISA Server object hierarchy.

Methods

The FPCConnectivityResults collection defines the following methods.

Method | Description
Item | Retrieves the requested FPCConnectivityResult object from the collection.
Refresh | Refreshes the contents of the collection to reflect the results of the most recent connectivity verification operations for the server.

Properties

The FPCConnectivityResults collection has the following properties.

Property | Description
_NewEnum | Gets an enumerator object for the collection.
Count | Gets the number of FPCConnectivityResult objects in the collection.

Remarks

This collection implements the IFPCConnectivityResults interface.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

COM Objects


IFPCConnectivityResults._NewEnum(IUnknown) property [ISA Server 2004]

_NewEnum Property of IFPCConnectivityResults[C++]

FPCConnectivityResults._NewEnum [Visual Basic]

[C++]

The _NewEnum property gets an enumerator object for the collection. An enumerator object provides serial access to the elements of the collection.

HRESULT get__NewEnum(
  IUnknown* ppEnum
);

Parameters

ppEnum
Address of an interface pointer that on return points to the IUnknown interface of an enumerator object that implements an IEnumVARIANT interface for the collection. An interface pointer to the IEnumVARIANT interface of the enumerator object can be retrieved by calling QueryInterface on the IUnknown interface returned.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The _NewEnum property gets an enumerator object for the collection. An enumerator object provides serial access to the elements of the collection.

Property _NewEnum As IUnknown

Property Value

Reference to an enumerator object that provides serial access to the elements of the collection.

Remarks

This property is read-only.

In Visual Basic and VBScript, this property is used implicitly in For Each...In...Next constructs.

Example Code

This VBScript script displays the IP addresses and ports on remote servers with which the local ISA Server computer attempted to verify connectivity. This example does not include error handling.

' Create the root object.
Dim root  ' The FPCLib.FPC root object
Set root = CreateObject("FPC.Root")

' Declare the other objects needed.
Dim server               ' An FPCServer object
Dim connectivityresults  ' An FPCConnectivityResults collection
Dim connectivityresult   ' An FPCConnectivityResult object

' Get references to the server object
' and the connectivity results collection.
Set server = root.GetContainingServer()
Set connectivityresults = server.ConnectivityResults

' Display the IP addresses and TCP ports on remote servers with which attempts
' were made to verify connectivity.
For Each connectivityresult In connectivityresults
    WScript.Echo "IP address and TCP port: " & connectivityresult.ServerAddress & _
                 ":" & connectivityresult.TCPPort
Next

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCConnectivityResults


IFPCConnectivityResults.Count(long) property [ISA Server 2004]

Count Property of IFPCConnectivityResults[C++]

FPCConnectivityResults.Count [Visual Basic]

[C++]

The Count property gets the number of FPCConnectivityResult objects in the collection.

HRESULT get_Count(
  long* plCount
);

Parameters

plCount
Pointer to a variable that on return receives a 32-bit integer specifying the number of FPCConnectivityResult objects in the collection.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The Count property gets the number of FPCConnectivityResult objects in the collection.

Property Count As Long

Property Value

A 32-bit integer that specifies the number of FPCConnectivityResult objects.

Remarks

This property is read-only.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCConnectivityResults


IFPCConnectivityResults | FPCConnectivityResults Item method [ISA Server 2004]

IFPCConnectivityResults::Item[C++]

FPCConnectivityResults.Item [Visual Basic]

[C++]

The Item method retrieves the requested IFPCConnectivityResult interface from the collection.

HRESULT Item(
  VARIANT Index,
  IFPCConnectivityResult** ppItem
);

Parameters

Index
[in] Required. Name or one-based index of the object to retrieve.
ppItem
Address of an interface pointer that on return points to the IFPCConnectivityResult interface requested.

Return Values

This method can return one of the following:

  • S_OK, indicating that the operation succeeded.
  • An error code, indicating that the operation failed. In this case, the [out] parameter returned is a null object.

[Visual Basic]

The Item method retrieves the requested FPCConnectivityResult object from the collection.

Function Item( _
  ByVal Index As Variant _
) As FPCConnectivityResult

Parameters

Index
[in] Required. Name or one-based index of the object to retrieve.

Return Values

This method returns a reference to an FPCConnectivityResult object if successful. Otherwise, an error is raised that can be intercepted by using an error handler.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCConnectivityResults


IFPCConnectivityResults.Refresh method [ISA Server 2004]

IFPCConnectivityResults::Refresh[C++]

FPCConnectivityResults.Refresh [Visual Basic]

[C++]

The Refresh method refreshes the contents of the collection to reflect the results of the most recent connectivity verification operations for the server.

HRESULT Refresh();

Parameters

This method has no parameters.

Return Values

This method returns S_OK if the call is successful; otherwise, it returns an error code.

[Visual Basic]

The Refresh method refreshes the contents of the collection to reflect the results of the most recent connectivity verification operations for the server.

Sub Refresh()

Parameters

This method has no parameters.

Return Values

This method has no return values. If the call is unsuccessful, an error is raised that can be intercepted by using an error handler.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCConnectivityResults


FPCConnectivityVerifier object [ISA Server 2004]

FPCConnectivityVerifier

The FPCConnectivityVerifier object represents a connectivity verifier. A connectivity verifier checks the connectivity from an ISA Server computer to another computer, such as an external Web server.

This object is typically an element of an FPCConnectivityVerifiers collection.

Click here to see the ISA Server object hierarchy.

Inheritance

This object inherits from the FPCPersist object, which contains methods and properties related to the persistent storage of an object's data. They include methods for exporting the object's data to and importing it from an XML document.

Methods

The FPCConnectivityVerifier object defines the following method.

Method | Description
SetConnectivityRequest | Sets the properties of the connectivity verifier object.

Properties

The FPCConnectivityVerifier object has the following properties.

Property | Description
AlertEnabled | Gets or sets a Boolean value that indicates whether an alert will be issued when the round-trip threshold set in the Threshold property is exceeded.
Description | Gets or sets the description of the connectivity verifier.
Enabled | Gets or sets a Boolean value that indicates whether the connectivity verifier is enabled.
GroupType | Gets or sets a value from the FpcConnectivityGroupType enumerated type that specifies the group type used in ISA Server Management to categorize the connectivity verifier according to the type of servers with which connectivity is checked.
Name | Gets or sets the name of the connectivity verifier.
RequestType | Gets a value from the FpcRequestType enumerated type that specifies the type of request to be used in the verification operation of the connectivity verifier.
ServerAddress | Gets the address of the server to which connectivity is to be verified.
TCPPort | Gets the TCP port of the server to which connectivity is to be verified.
Threshold | Gets or sets the round-trip time threshold for the verification operation, in milliseconds. If the threshold is exceeded, an alert can be issued.

Methods Inherited from FPCPersist

Name | Description
CancelWaitForChanges | Cancels the registration established by the WaitForChanges method (for use in C and C++ programming only).
CanImport | Returns a Boolean value that indicates whether the object's properties can be imported from the specified XML document.
Export | Writes the stored values of all of the object's properties to the specified XML document.
ExportToFile | Writes the stored values of all of the object's properties to the specified XML file.
GetServiceRestartMask | Retrieves a 32-bit bitmask of the FpcServices enumerated type that specifies which services need to be restarted for currently unsaved changes to take effect.
Import | Copies the values of all of the object's properties from the specified XML document to persistent storage.
ImportFromFile | Copies the values of all of the object's properties from the specified XML file to persistent storage.
LoadDocProperties | Provides the XML document's properties so that you can know what information can be imported from the document.
Refresh | Reads the values of all of the object's properties from persistent storage, overwriting any changes that have not been saved.
Save | Writes the current values of all of the object's properties to persistent storage.
WaitForChanges | Registers to wait for an event indicating that the contents of the object have changed (for use in C and C++ programming only).

Properties Inherited from FPCPersist

Name | Description
PersistentName | Gets the persistent name of the object. The persistent name of an object is a name that is unique for the object at the respective level of the COM object hierarchy.
VendorParametersSets | Gets an FPCVendorParametersSets object that can hold sets of custom data for extending the object.

Remarks

This object implements the IFPCConnectivityVerifier interface.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

COM Objects


IFPCConnectivityVerifier.AlertEnabled (2 Parameters) property [ISA Server 2004]

AlertEnabled Property of IFPCConnectivityVerifier[C++]

FPCConnectivityVerifier.AlertEnabled [Visual Basic]

[C++]

The AlertEnabled property gets or sets a Boolean value that indicates whether an alert will be issued when the round-trip threshold set in the Threshold property is exceeded.

HRESULT get_AlertEnabled(
  VARIANT_BOOL* pfAlertEnabled
);

HRESULT put_AlertEnabled(
  VARIANT_BOOL fAlertEnabled
);

Parameters

pfAlertEnabled
Pointer to a Boolean variable that is set on return to VARIANT_TRUE if an alert is enabled for the connectivity verifier, or to VARIANT_FALSE if no alert is enabled for the connectivity verifier.
fAlertEnabled
Boolean value that indicates whether an alert is enabled for the connectivity verifier.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write.

[Visual Basic]

The AlertEnabled property gets or sets a Boolean value that indicates whether an alert will be issued when the round-trip threshold set in the Threshold property is exceeded.

Property AlertEnabled As Boolean

Property Value

Boolean value that indicates whether an alert is enabled for the connectivity verifier.

Remarks

This property is read/write.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCConnectivityVerifier


IFPCConnectivityVerifier.Description(BSTR,BSTR) property [ISA Server 2004]

Description Property of IFPCConnectivityVerifier[C++]

FPCConnectivityVerifier.Description [Visual Basic]

[C++]

The Description property gets or sets the description of the connectivity verifier.

HRESULT get_Description(
  BSTR* pbstrDescription
);

HRESULT put_Description(
  BSTR bstrDescription
);

Parameters

pbstrDescription
Pointer to a BSTR that is set on return to a string value specifying the description of the connectivity verifier.
bstrDescription
BSTR that specifies the description of the connectivity verifier.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write.

[Visual Basic]

The Description property gets or sets the description of the connectivity verifier.

Property Description As String

Property Value

String that specifies the description of the connectivity verifier.

Remarks

This property is read/write.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCConnectivityVerifier


IFPCConnectivityVerifier.Enabled (2 Parameters) property [ISA Server 2004]

Enabled Property of IFPCConnectivityVerifier[C++]

FPCConnectivityVerifier.Enabled [Visual Basic]

[C++]

The Enabled property gets or sets a Boolean value that indicates whether the connectivity verifier is enabled.

HRESULT get_Enabled(
  VARIANT_BOOL* pfEnabled
);

HRESULT put_Enabled(
  VARIANT_BOOL fEnabled
);

Parameters

pfEnabled
Pointer to a Boolean variable that is set on return to VARIANT_TRUE if the connectivity verifier is enabled, or to VARIANT_FALSE if the connectivity verifier is disabled.
fEnabled
Boolean value that indicates whether the connectivity verifier is enabled.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write.

[Visual Basic]

The Enabled property gets or sets a Boolean value that indicates whether the connectivity verifier is enabled.

Property Enabled As Boolean

Property Value

Boolean value that specifies whether the connectivity verifier is enabled.

Remarks

This property is read/write.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCConnectivityVerifier


IFPCConnectivityVerifier.GroupType (2 Parameters) property [ISA Server 2004]

GroupType Property of IFPCConnectivityVerifier[C++]

FPCConnectivityVerifier.GroupType [Visual Basic]

[C++]

The GroupType property gets or sets a value from the FpcConnectivityGroupType enumerated type that specifies the group type used in ISA Server Management to categorize the connectivity verifier according to the type of servers with which connectivity is checked.

HRESULT get_GroupType(
  FpcConnectivityGroupType* pGroupType
);

HRESULT put_GroupType(
  FpcConnectivityGroupType GroupType
);

Parameters

pGroupType
Pointer to a variable that on return receives a value from the FpcConnectivityGroupType enumerated type specifying the group type used to categorize the connectivity verifier in ISA Server Management.
GroupType
Value from the FpcConnectivityGroupType enumerated type that specifies the group type used to categorize the connectivity verifier in ISA Server Management.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write.

A connectivity verifier checks for connectivity to a single server. The specific server to which connectivity is to be verified is specified by the ServerAddress property.

[Visual Basic]

The GroupType property gets or sets a value from the FpcConnectivityGroupType enumerated type that specifies the group type used in ISA Server Management to categorize the connectivity verifier according to the type of servers with which connectivity is checked.

Property GroupType As FpcConnectivityGroupType

Property Value

Value from the FpcConnectivityGroupType enumerated type that specifies the group type used to categorize the connectivity verifier in ISA Server Management.

Remarks

This property is read/write.

A connectivity verifier checks for connectivity to a single server. The specific server to which connectivity is to be verified is specified by the ServerAddress property.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCConnectivityVerifier


IFPCConnectivityVerifier.Name(BSTR,BSTR) property [ISA Server 2004]

Name Property of IFPCConnectivityVerifier[C++]

FPCConnectivityVerifier.Name [Visual Basic]

[C++]

The Description property gets or sets the name of the connectivity verifier.

HRESULT get_Name(
  BSTR* pbstrName
);

HRESULT put_Name(
  BSTR bstrName
);

Parameters

pbstrName
Pointer to a BSTR that is set on return to a string value specifying the name of the connectivity verifier.
bstrName
BSTR that specifies the name of the connectivity verifier.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write.

[Visual Basic]

The Description property gets or sets the name of the connectivity verifier.

Property Name As String

Property Value

String that specifies the name of the connectivity verifier.

Remarks

This property is read/write.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCConnectivityVerifier


IFPCConnectivityVerifier.RequestType(FpcRequestType) property [ISA Server 2004]

RequestType Property of IFPCConnectivityVerifier[C++]

FPCConnectivityVerifier.RequestType [Visual Basic]

[C++]

The RequestType property gets a value from the FpcRequestType enumerated type that specifies the type of request to be used in the verification operation of the connectivity verifier. The request can be an HTTP request, a ping request, or a TCP connection request.

HRESULT get_RequestType(
  FpcRequestType* pRequestType
);

Parameters

pRequestType
Pointer to a variable that on return receives a value from the FpcRequestType enumerated type specifying the type of request to be used in the verification operation of the connectivity verifier.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

If this property is set to fpcHttpConnect, a system policy rule, named Allow HTTP/HTTPS requests from ISA Server to selected servers for connectivity verifiers, which belongs to the HTTP Connectivity Verifiers configuration group, must be enabled for the connectivity verifier to work. For information on how to enable a system policy rule by enabling its configuration group, see the Enabled property of the FPCSystemPolicyConfigGroup object.

[Visual Basic]

The RequestType property gets a value from the FpcRequestType enumerated type that specifies the type of request to be used in the verification operation of the connectivity verifier. The request can be an HTTP request, a ping request, or a TCP connection request.

Property RequestType As FpcRequestType

Property Value

Value from the FpcRequestType enumerated type that specifies the type of request to be used in the verification operation of the connectivity verifier.

Remarks

This property is read-only.

If this property is set to fpcHttpConnect, a system policy rule, named Allow HTTP/HTTPS requests from ISA Server to selected servers for connectivity verifiers, which belongs to the HTTP Connectivity Verifiers configuration group, must be enabled for the connectivity verifier to work. For information on how to enable a system policy rule by enabling its configuration group, see the Enabled property of the FPCSystemPolicyConfigGroup object.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCConnectivityVerifier


IFPCConnectivityVerifier.ServerAddress(BSTR) property [ISA Server 2004]

ServerAddress Property of IFPCConnectivityVerifier[C++]

FPCConnectivityVerifier.ServerAddress [Visual Basic]

[C++]

The ServerAddress property gets the address of the server to which connectivity is to be verified.

HRESULT get_ServerAddress(
  BSTR* pbstrServerAddress
);

Parameters

pbstrServerAddress
Pointer to a BSTR that is set on return to a string value specifying the address of the server to which connectivity is to be verified.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The ServerAddress property gets the address of the server to which connectivity is to be verified.

Property ServerAddress As String

Property Value

String that specifies the address of the server to which connectivity is to be verified.

Remarks

This property is read-only.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCConnectivityVerifier


IFPCConnectivityVerifier.SetConnectivityRequest method [ISA Server 2004]

IFPCConnectivityVerifier::SetConnectivityRequest[C++]

FPCConnectivityVerifier.SetConnectivityRequest [Visual Basic]

[C++]

The SetConnectivityRequest method sets the ServerAddress, RequestType, and TCPPort properties of the connectivity verifier object.

HRESULT SetConnectivityRequest(
  BSTR ServerAddress,
  FpcRequestType RequestType,
  long TCPPort
);

Parameters

ServerAddress
[in] String value that specifies the address of the server to which connectivity is to be verified.
RequestType
[in] Value from the FpcRequestType enumerated type that specifies the type of request to be used in the verification operation of the connectivity verifier.
TCPPort
[in, optional] A 32-bit integer that specifies the TCP port of the server to which connectivity is to be verified. This parameter should be set only if the RequestType parameter is set to fpcTcpConnect.

Return Values

This method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

If the value of the RequestType parameter is set to fpcHttpConnect, a system policy rule, named Allow HTTP/HTTPS requests from ISA Server to selected servers for connectivity verifiers, which belongs to the HTTP Connectivity Verifiers configuration group, must be enabled for the connectivity verifier to work. For information on how to enable a system policy rule by enabling its configuration group, see the Enabled property of the FPCSystemPolicyConfigGroup object.

[Visual Basic]

The SetConnectivityRequest method sets the ServerAddress, RequestType, and TCPPort properties of the connectivity verifier object.

Sub SetConnectivityRequest( _
  ByVal ServerAddress As String, _
  ByVal RequestType As FpcRequestType, _
  [ ByVal TCPPort As Long ] _
)

Parameters

ServerAddress
[in] String value that specifies the address of the server to which connectivity is to be verified.
RequestType
[in] Value from the FpcRequestType enumerated type that specifies the type of request to be used in the verification operation of the connectivity verifier.
TCPPort
[in, optional] A 32-bit integer that specifies the TCP port of the server to which connectivity is to be verified. This parameter should be set only if the RequestType parameter is set to fpcTcpConnect.

Return Values

This method has no return values. If the call is unsuccessful, an error is raised that can be intercepted by using an error handler.

Remarks

If the value of the RequestType parameter is set to fpcHttpConnect, a system policy rule, named Allow HTTP/HTTPS requests from ISA Server to selected servers for connectivity verifiers, which belongs to the HTTP Connectivity Verifiers configuration group, must be enabled for the connectivity verifier to work. For information on how to enable a system policy rule by enabling its configuration group, see the Enabled property of the FPCSystemPolicyConfigGroup object.

Example Code

For a VBScript code example that shows how to use this method to set the request type of a new connectivity verifier, see Adding a Connectivity Verifier.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCConnectivityVerifier


IFPCConnectivityVerifier.TCPPort(Long) property [ISA Server 2004]

TCPPort Property of IFPCConnectivityVerifier[C++]

FPCConnectivityVerifier.TCPPort [Visual Basic]

[C++]

The TCPPort property gets the Transmission Control Protocol (TCP) port of the server to which connectivity is to be verified.

HRESULT get_TCPPort(
  Long* plTCPPort
);

Parameters

plTCPPort
Pointer to a variable that receives a 32-bit integer specifying the TCP port of the server to which connectivity is to be verified.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The TCPPort property gets the Transmission Control Protocol (TCP) port of the server to which connectivity is to be verified.

Property TCPPort As Long

Property Value

A 32-bit integer that specifies the TCP port of the server to which connectivity is to be verified.

Remarks

This property is read-only.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCConnectivityVerifier


IFPCConnectivityVerifier.Threshold(long,long) property [ISA Server 2004]

Threshold Property of IFPCConnectivityVerifier[C++]

FPCConnectivityVerifier.Threshold [Visual Basic]

[C++]

The Threshold property gets or sets the round-trip time threshold for the verification operations of the connectivity verifier, in milliseconds. If the threshold is exceeded, an alert will be issued if the AlertEnabled property is set to VARIANT_TRUE.

HRESULT get_Threshold(
  long* plThreshold
);

HRESULT put_Threshold(
  long lThreshold
);

Parameters

plThreshold
Pointer to a variable that receives a 32-bit integer specifying the round-trip time threshold for the verification operations of the connectivity verifier, in milliseconds.
lThreshold
A 32-bit integer that specifies the round-trip time threshold for the verification operations of the connectivity verifier, in milliseconds.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write.

[Visual Basic]

The Threshold property gets or sets the round-trip time threshold for the verification operations of the connectivity verifier, in milliseconds. If the threshold is exceeded, an alert will be issued if the AlertEnabled property is set to True.

Property Threshold As Long

Property Value

A 32-bit integer that specifies the round-trip time threshold for the verification operations of the connectivity verifier, in milliseconds.

Remarks

This property is read/write.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCConnectivityVerifier


FPCConnectivityVerifiers collection [ISA Server 2004]

FPCConnectivityVerifiers Collection

The FPCConnectivityVerifiers collection holds a set of FPCConnectivityVerifier objects that represent all of the connectivity verifiers that are defined for an FPCArray object.

The FPCConnectivityVerifiers collection can be accessed through the ConnectivityVerifiers property of an FPCArray object.

Click here to see the ISA Server object hierarchy.

Inheritance

This collection inherits from the FPCPersist object, which contains methods and properties related to the persistent storage of an object's data. They include methods for exporting an object's data to and importing it from an XML document.

Methods

The FPCConnectivityVerifiers collection defines the following methods.

Method | Description
Add | Creates a new FPCConnectivityVerifier object in the collection and returns a reference to it.
Item | Retrieves the requested FPCConnectivityVerifier object from the collection.
RefreshRate | Gets or sets the time, in seconds, that the connectivity verifiers wait before rechecking connectivity.
Remove | Removes the specified FPCConnectivityVerifier object from the collection.

Properties

The FPCConnectivityVerifiers collection has the following properties.

Property | Description
_NewEnum | Gets an enumerator object for the collection.
Count | Gets the number of FPCConnectivityVerifier objects in the collection.

Methods Inherited from FPCPersist

Name | Description
CancelWaitForChanges | Cancels the registration established by the WaitForChanges method (for use in C and C++ programming only).
CanImport | Returns a Boolean value that indicates whether the properties of the collection and its elements can be imported from the specified XML document.
Export | Writes the stored values of all the properties of the collection and its elements to the specified XML document.
ExportToFile | Writes the stored values of all the properties of the collection and its elements to the specified XML file.
GetServiceRestartMask | Retrieves a 32-bit bitmask of the FpcServices enumerated type that specifies which services need to be restarted for currently unsaved changes to take effect.
Import | Copies the values of all the properties of the collection and its elements from the specified XML document to persistent storage.
ImportFromFile | Copies the values of all the properties of the collection and its elements from the specified XML file to persistent storage.
LoadDocProperties | Provides the XML document's properties so that you can know what information can be imported from the document.
Refresh | Reads the values of all the properties of the collection and its elements from persistent storage, overwriting any changes that have not been saved.
Save | Writes the current values of all the properties of the collection and its elements to persistent storage.
WaitForChanges | Registers to wait for an event indicating that the contents of the object have changed (for use in C and C++ programming only).

Properties Inherited from FPCPersist

Name | Description
PersistentName | Gets the persistent name of the collection. The persistent name of an object is a name that is unique for the object at the respective level of the COM object hierarchy.
VendorParametersSets | Gets an FPCVendorParametersSets collection that can hold sets of custom data for extending the collection.

Remarks

This collection implements the IFPCConnectivityVerifiers interface.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

COM Objects


IFPCConnectivityVerifiers._NewEnum(IUnknown) property [ISA Server 2004]

_NewEnum Property of IFPCConnectivityVerifiers[C++]

FPCConnectivityVerifiers._NewEnum [Visual Basic]

[C++]

The _NewEnum property gets an enumerator object for the collection. An enumerator object provides serial access to the elements of the collection.

HRESULT get__NewEnum(
  IUnknown* ppEnum
);

Parameters

ppEnum
Address of an interface pointer that on return points to the IUnknown interface of an enumerator object that implements an IEnumVARIANT interface for the collection. An interface pointer to the IEnumVARIANT interface of the enumerator object can be retrieved by calling QueryInterface on the IUnknown interface returned.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The _NewEnum property gets an enumerator object for the collection. An enumerator object provides serial access to the elements of the collection.

Property _NewEnum As IUnknown

Property Value

Reference to an enumerator object that provides serial access to the elements of the collection.

Remarks

This property is read-only.

In Visual Basic and VBScript, this property is used implicitly in For Each...In...Next constructs.

Example Code

This VBScript script displays the names of all the connectivity verifiers defined for an FPCArray object and the IP addresses and TCP ports on remote servers with which they check connectivity. This example does not include error handling.

' Create the root object.
Dim root  ' The FPCLib.FPC root object
Set root = CreateObject("FPC.Root")

' Declare the other objects needed.
Dim array                  ' An FPCArray object
Dim connectivityverifiers  ' An FPCConnectivityVerifiers collection
Dim connectivityverifier   ' An FPCConnectivityVerifier object

' Get references to the array object
' and the connectivity verifiers collection.
Set array = root.GetContainingArray()
Set connectivityverifiers = array.ConnectivityVerifiers

' Display the names of the connectivity verifiers defined
' for the array object and the IP addresses and TCP ports
' on remote servers with which they check connectivity.
For Each connectivityverifier In connectivityverifiers
    WScript.Echo "Connectivity verifier name: " & connectivityverifier.Name & vbCrLf & _
                 "IP address and TCP port: " & connectivityverifier.ServerAddress & ":" & _
                 connectivityverifier.TCPPort
Next

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCConnectivityVerifiers


IFPCConnectivityVerifiers.Add (2 Parameters) method [ISA Server 2004]

IFPCConnectivityVerifiers::Add[C++]

FPCConnectivityVerifiers.Add [Visual Basic]

[C++]

The Add method creates a new FPCConnectivityVerifier object in the collection and returns a reference to it.

HRESULT Add(
  BSTR Name,
  IFPCConnectivityVerifier** ppNewConnectivityVerifier
);

Parameters

Name
[in] Required. BSTR that specifies the name of a new connectivity verifier.
ppNewConnectivityVerifier
Address of an interface pointer that on return points to the new IFPCConnectivityVerifier interface created.

Return Values

This method can return one of the following:

  • S_OK, indicating that the operation succeeded.
  • An error code, indicating that the operation failed. In this case, the [out] parameter returned is a null object.

[Visual Basic]

The Add method creates a new FPCConnectivityVerifier object in the collection and returns a reference to it.

Function Add( _
  ByVal Name As String _
) As FPCConnectivityVerifier

Parameters

Name
[in] Required. String that specifies the name of a new connectivity verifier.

Return Values

This method returns a reference to an FPCConnectivityVerifier object if successful. Otherwise, an error is raised that can be intercepted by using an error handler.

Example Code

For a VBScript code example that shows how to use this method to add a new connectivity verifier to the connectivity verifiers collection and then set its properties, see Adding a Connectivity Verifier.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCConnectivityVerifiers


IFPCConnectivityVerifiers.Count(long) property [ISA Server 2004]

Count Property of IFPCConnectivityVerifiers[C++]

FPCConnectivityVerifiers.Count [Visual Basic]

[C++]

The Count property gets the number of FPCConnectivityVerifier objects in the collection.

HRESULT get_Count(
  long* plCount
);

Parameters

plCount
Pointer to a variable that on return receives a 32-bit integer specifying the number of FPCConnectivityVerifier objects in the collection.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The Count property gets the number of FPCConnectivityVerifier objects in the collection.

Property Count As Long

Property Value

A 32-bit integer that specifies the number of FPCConnectivityVerifier objects in the collection.

Remarks

This property is read-only.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCConnectivityVerifiers


IFPCConnectivityVerifiers.Item (2 Parameters) method [ISA Server 2004]

IFPCConnectivityVerifiers::Item[C++]

FPCConnectivityVerifiers.Item [Visual Basic]

[C++]

The Item method retrieves the requested IFPCConnectivityVerifier interface from the collection.

HRESULT Item(
  VARIANT Index,
  IFPCConnectivityVerifier** ppItem
);

Parameters

Index
[in] Required. Name or one-based index of the object to retrieve.
ppItem
Address of an interface pointer that on return points to the IFPCConnectivityVerifier interface requested.

Return Values

This method can return one of the following:

  • S_OK, indicating that the operation succeeded.
  • An error code, indicating that the operation failed. In this case, the [out] parameter returned is a null object.

[Visual Basic]

The Item method retrieves the requested FPCConnectivityVerifier object from the collection.

Function Item( _
  ByVal Index As Variant _
) As FPCConnectivityVerifier

Parameters

Index
[in] Required. Name or one-based index of the object to retrieve.

Return Values

This method returns a reference to an FPCConnectivityVerifier object if successful. Otherwise, an error is raised that can be intercepted by using an error handler.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCConnectivityVerifiers


IFPCConnectivityVerifiers.RefreshRate(long,long) property [ISA Server 2004]

RefreshRate Property of IFPCConnectivityVerifiers[C++]

FPCConnectivityVerifiers.RefreshRate [Visual Basic]

[C++]

The RefreshRate property gets or sets the time, in seconds, that the connectivity verifiers wait before rechecking connectivity.

HRESULT get_RefreshRate(
  long* plRefreshRate
);

HRESULT put_RefreshRate(
  long lRefreshRate
);

Parameters

plRefreshRate
Pointer to a 32-bit integer that is set on return to a long value specifying the time, in seconds, that the connectivity verifiers wait before rechecking connectivity.
lRefreshRate
A 32-bit integer that specifies the time, in seconds, that the connectivity verifiers wait before rechecking connectivity. The value can be from 15 to 1440. The default value is 30.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write.

[Visual Basic]

The RefreshRate property gets or sets the time, in seconds, that the connectivity verifiers wait before rechecking connectivity.

Property RefreshRate As Long

Property Value

A 32-bit integer value that specifies the time, in seconds, that the connectivity verifiers wait before rechecking connectivity. The value can be from 15 to 1440. The default value is 30.

Remarks

This property is read/write.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCConnectivityVerifiers


IFPCConnectivityVerifiers.Remove(Variant) method [ISA Server 2004]

IFPCConnectivityVerifiers::Remove[C++]

FPCConnectivityVerifiers.Remove [Visual Basic]

[C++]

The Remove method removes the specified FPCConnectivityVerifier object from the collection.

HRESULT Remove(
  VARIANT Index
);

Parameters

Index
[in] Required. Name or one-based index of the FPCConnectivityVerifier object to remove.

Return Values

This method returns S_OK if the call is successful; otherwise, it returns an error code.
[Visual Basic]

The Remove method removes the specified FPCConnectivityVerifier object from the collection.

Sub Remove( _
  ByVal Index As Variant _
)

Parameters

Index
[in] Required. Name or one-based index of the FPCConnectivityVerifier object to remove.

Return Values

This method has no return values. If the call is unsuccessful, an error is raised that can be intercepted by using an error handler.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCConnectivityVerifiers


FPCContentTypeSet collection [ISA Server 2004]

FPCContentTypeSet Collection

The FPCContentTypeSet collection holds a content type set that FPCAccessProperties objects can reference. The default content type sets include Audio, Executable, Images, Text, and Video. Each type set includes file types. For example, the Audio content type set includes the file types .aif, .aifc, .au, .m3u, .mid, and others. If you want to change the file types that are included in a type set, do so through its FPCContentTypeSet collection by using the Add and Remove methods. You can also create additional content type sets using the Add method of the FPCContentTypeSets collection.

The FPCContentTypeSet object is typically an element of an FPCContentTypeSets collection.

Click here to see the ISA Server object hierarchy.

Inheritance

This object inherits from the FPCPersist object, which contains methods and properties related to the persistent storage of an object's data. They include methods for exporting an object's data to and importing it from an XML document.

Methods

The FPCContentTypeSet collection defines the following methods.

Method | Description
Add | Adds a new file type or MIME content type to the content type set.
Item | Retrieves the requested file type from the content type set.
Remove | Removes the specified file type from the content type set.
RemoveAll | Removes all of the file types from the content type set.

Properties

The FPCContentTypeSet collection has the following properties.

Property | Description
_NewEnum | Gets an enumerator object for the collection.
Count | Gets the number of file types in the content type set.
Description | Gets or sets the description of the content type set.
Name | Gets or sets the name of the content type set.

Methods Inherited from FPCPersist

Name | Description
CancelWaitForChanges | Cancels the registration established by the WaitForChanges method (for use in C and C++ programming only).
CanImport | Returns a Boolean value that indicates whether the collection's properties and elements can be imported from the specified XML document.
Export | Writes the stored values of the collection's properties and elements to the specified XML document.
ExportToFile | Writes the stored values of the collection's properties and elements to the specified XML file.
GetServiceRestartMask | Retrieves a 32-bit bitmask of the FpcServices enumerated type that specifies which services need to be restarted for currently unsaved changes to take effect.
Import | Copies the values of the collection's properties and elements from the specified XML document to persistent storage.
ImportFromFile | Copies the values of the collection's properties and elements from the specified XML file to persistent storage.
LoadDocProperties | Provides the XML document's properties so that you can know what information can be imported from the document.
Refresh | Reads the values of the collection's properties and elements from persistent storage, overwriting any changes that have not been saved.
Save | Writes the current values of the collection's properties and elements to persistent storage.
WaitForChanges | Registers to wait for an event indicating that the contents of the object have changed (for use in C and C++ programming only).

Properties Inherited from FPCPersist

Name | Description
PersistentName | Gets the persistent name of the collection. The persistent name of an object is a name that is unique for the object at the respective level of the COM object hierarchy.
VendorParametersSets | Gets an FPCVendorParametersSets collection that can hold sets of custom data for extending the collection.

Remarks

This collection implements the IFPCContentTypeSet interface.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

COM Objects


IFPCContentTypeSet | FPCContentTypeSet _NewEnum property [ISA Server 2004]

_NewEnum Property of IFPCContentTypeSet[C++]

FPCContentTypeSet._NewEnum [Visual Basic]

[C++]

The _NewEnum property gets an enumerator object for the collection. An enumerator object provides serial access to the elements of the collection.

HRESULT get__NewEnum(
  IUnknown* ppEnum
);

Parameters

ppEnum
Address of an interface pointer that on return points to the IUnknown interface of an enumerator object that implements an IEnumVARIANT interface for the collection. An interface pointer to the IEnumVARIANT interface of the enumerator object can be retrieved by calling QueryInterface on the IUnknown interface returned.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The _NewEnum property gets an enumerator object for the collection. An enumerator object provides serial access to the elements of the collection.

Property _NewEnum As IUnknown

Property Value

Reference to an enumerator object that provides serial access to the elements of the collection.

Remarks

This property is read-only.

In Visual Basic and VBScript, this property is used implicitly in For Each...In...Next constructs.

Example Code

This VBScript script displays all of the file types in a specific content type set. This example does not include error handling.

' Create the root object.
Dim root  ' The FPCLib.FPC root object
Set root = CreateObject("FPC.Root")

' Declare the other objects needed and a string.
Dim array            ' An FPCArray object
Dim contenttypesets  ' An FPCContentTypeSets collection
Dim contenttypeset   ' An FPCContentTypeSet collection
Dim contenttype      ' A string

' Get references to the array object
' and the content type sets collection.
Set array = root.GetContainingArray()
Set contenttypesets = array.RuleElements.ContentTypeSets

' If at least one content type set is defined in the content
' type sets collection, display the file types in the first
' content type set found.
On Error Resume Next
Set contenttypeset = contenttypesets.Item(1)
If Err.Number = 0 Then
    For Each contenttype In contenttypeset
        WScript.Echo "Content type: " & contenttype
    Next
End If

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCContentTypeSet


IFPCContentTypeSet | FPCContentTypeSet Add(String) method [ISA Server 2004]

IFPCContentTypeSet::Add[C++]

FPCContentTypeSet.Add [Visual Basic]

[C++]

The Add method adds a new file type or MIME content type to the content type set.

HRESULT Add(
  BSTR Name
);

Parameters

Name
[in] Required. BSTR that specifies the name of the new file type or MIME content type.

Return Values

This method returns S_OK if the call is successful; otherwise, it returns an error code.
[Visual Basic]

The Add method adds a new file type or MIME content type to the content type set.

Sub Add( _
  ByVal Name As String _
)

Parameters

Name
[in] Required. String that specifies the name of the new file type or MIME content type.

Return Values

This method has no return values. If the call is unsuccessful, an error is raised that can be intercepted by using an error handler.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCContentTypeSet


IFPCContentTypeSet | FPCContentTypeSet Count(long) property [ISA Server 2004]

Count Property of IFPCContentTypeSet[C++]

FPCContentTypeSet.Count [Visual Basic]

[C++]

The Count property gets the number of file types in the collection.

HRESULT get_Count(
  long* plCount
);

Parameters

plCount
Pointer to a variable that on return receives a 32-bit integer specifying the number of file types in the collection.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The Count property gets the number of file types in the collection.

Property Count As Long

Property Value

A 32-bit integer that specifies the number of file types in the collection.

Remarks

This property is read-only.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCContentTypeSet


IFPCContentTypeSet | FPCContentTypeSet Description property [ISA Server 2004]

Description Property of IFPCContentTypeSet[C++]

FPCContentTypeSet.Description [Visual Basic]

[C++]

The Description property gets or sets the description of the content type set.

HRESULT get_Description(
  BSTR* pbstrDescription
);

HRESULT put_Description(
  BSTR bstrDescription
);

Parameters

pbstrDescription
Pointer to a BSTR that is set on return to a string value specifying the description of the content type set.
bstrDescription
BSTR that specifies the description of the content type set.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write.

[Visual Basic]

The Description property gets or sets the description of the content type set.

Property Description As String

Property Value

String that specifies the description of the content type set.

Remarks

This property is read/write.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCContentTypeSet


IFPCContentTypeSet | FPCContentTypeSet Item method [ISA Server 2004]

IFPCContentTypeSet::Item[C++]

FPCContentTypeSet.Item [Visual Basic]

[C++]

The Item method retrieves the requested file type from the set.

HRESULT Item(
  VARIANT Index,
  BSTR* pbstrItem
);

Parameters

Index
[in] Required. Name or one-based index of the content type to retrieve.
pbstrItem
[out] Pointer to a BSTR that is set on return to a string value specifying the content type requested.

Return Values

This method returns S_OK if the call is successful; otherwise, it returns an error code.
[Visual Basic]

The Item method retrieves the requested file type from the set.

Function Item( _
  ByVal Index As Variant _
) As String

Parameters

Index
[in] Required. Name or one-based index of the content type to retrieve.

Return Values

This method returns a string value that specifies the content type if successful. Otherwise, an error is raised that can be intercepted by using an error handler.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCContentTypeSet


IFPCContentTypeSet | FPCContentTypeSet Name property [ISA Server 2004]

Name Property of IFPCContentTypeSet[C++]

FPCContentTypeSet.Name [Visual Basic]

[C++]

The Name property gets or sets the name of the content type set.

HRESULT get_Name(
  BSTR* pbstrName
);

HRESULT put_Name(
  BSTR bstrName
);

Parameters

pbstrName
Pointer to a BSTR that is set on return to a string value specifying the name of the content type set.
bstrName
BSTR that specifies the name of the content type set.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write.

[Visual Basic]

The Name property gets or sets the name of the content type set.

Property Name As String

Property Value

String that specifies the name of the content type set.

Remarks

This property is read/write.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCContentTypeSet


IFPCContentTypeSet | FPCContentTypeSet Remove(Variant) method [ISA Server 2004]

IFPCContentTypeSet::Remove[C++]

FPCContentTypeSet.Remove [Visual Basic]

[C++]

The Remove method removes the specified file type from the set.

HRESULT Remove(
  VARIANT Index
);

Parameters

Index
[in] Required. Name or one-based index of the file type to remove.

Return Values

This method returns S_OK if the call is successful; otherwise, it returns an error code.
[Visual Basic]

The Remove method removes the specified file type from the set.

Sub Remove( _
  ByVal Index As Variant _
)

Parameters

Index
[in] Required. Name or one-based index of the file type to remove.

Return Values

This method has no return values. If the call is unsuccessful, an error is raised that can be intercepted by using an error handler.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCContentTypeSet


IFPCContentTypeSet | FPCContentTypeSet RemoveAll method [ISA Server 2004]

IFPCContentTypeSet::RemoveAll[C++]

FPCContentTypeSet.RemoveAll [Visual Basic]

[C++]

The RemoveAll method removes all of the file types from the set.

HRESULT RemoveAll();

Parameters

This method has no parameters.

Return Values

This method returns S_OK if the call is successful; otherwise, it returns an error code.
[Visual Basic]

The RemoveAll method removes all of the file types from the set.

Sub RemoveAll()

Parameters

This method has no parameters.

Return Values

This method has no return values. If the call is unsuccessful, an error is raised that can be intercepted by using an error handler.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCContentTypeSet


FPCContentTypeSets collection [ISA Server 2004]

FPCContentTypeSets Collection

The FPCContentTypeSets collection holds a group of FPCContentTypeSet objects that represent all of the content type sets defined for an FPCArray object.

The FPCContentTypeSets collection is typically accessed through the ContentTypeSets property of an FPCRuleElements object.

Click here to see the ISA Server object hierarchy.

Inheritance

This collection inherits from the FPCPersist object, which contains methods and properties related to the persistent storage of an object's data. They include methods for exporting an object's data to and importing it from an XML document.

Methods

The FPCContentTypeSets collection defines the following methods.

Method | Description
Add | Creates a new FPCContentTypeSet object and returns a reference to it.
Item | Retrieves the requested FPCContentTypeSet object from the collection.
Remove | Removes the specified FPCContentTypeSet object from the collection.

Properties

The FPCContentTypeSets collection has the following properties.

Property | Description
_NewEnum | Gets an enumerator object for the collection.
Count | Gets the number of FPCContentTypeSet objects in the collection.

Methods Inherited from FPCPersist

Name | Description
CancelWaitForChanges | Cancels the registration established by the WaitForChanges method (for use in C and C++ programming only).
CanImport | Returns a Boolean value that indicates whether the properties of the collection and its elements can be imported from the specified XML document.
Export | Writes the stored values of all the properties of the collection and its elements to the specified XML document.
ExportToFile | Writes the stored values of all the properties of the collection and its elements to the specified XML file.
GetServiceRestartMask | Retrieves a 32-bit bitmask of the FpcServices enumerated type that specifies which services need to be restarted for currently unsaved changes to take effect.
Import | Copies the values of all the properties of the collection and its elements from the specified XML document to persistent storage.
ImportFromFile | Copies the values of all the properties of the collection and its elements from the specified XML file to persistent storage.
LoadDocProperties | Provides the XML document's properties so that you can know what information can be imported from the document.
Refresh | Reads the values of all the properties of the collection and its elements from persistent storage, overwriting any changes that have not been saved.
Save | Writes the current values of all the properties of the collection and its elements to persistent storage.
WaitForChanges | Registers to wait for an event indicating that the contents of the object have changed (for use in C and C++ programming only).

Properties Inherited from FPCPersist

Name | Description
PersistentName | Gets the persistent name of the collection. The persistent name of an object is a name that is unique for the object at the respective level of the COM object hierarchy.
VendorParametersSets | Gets an FPCVendorParametersSets collection that can hold sets of custom data for extending the collection.

Remarks

This collection implements the IFPCContentTypeSets interface.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

COM Objects


IFPCContentTypeSets | FPCContentTypeSets _NewEnum property [ISA Server 2004]

_NewEnum Property of IFPCContentTypeSets[C++]

FPCContentTypeSets._NewEnum [Visual Basic]

[C++]

The _NewEnum property gets an enumerator object for the collection. An enumerator object provides serial access to the elements of the collection.

HRESULT get__NewEnum(
  IUnknown* ppEnum
);

Parameters

ppEnum
Address of an interface pointer that on return points to the IUnknown interface of an enumerator object that implements an IEnumVARIANT interface for the collection. An interface pointer to the IEnumVARIANT interface of the enumerator object can be retrieved by calling QueryInterface on the IUnknown interface returned.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The _NewEnum property gets an enumerator object for the collection. An enumerator object provides serial access to the elements of the collection.

Property _NewEnum As IUnknown

Property Value

Reference to an enumerator object that provides serial access to the elements of the collection.

Remarks

This property is read-only.

In Visual Basic and VBScript, this property is used implicitly in For Each...In...Next constructs.

Example Code

This VBScript script displays the names of all the content type sets defined for an FPCArray object. It does not include error handling.

' Create the root object.
Dim root  ' The FPCLib.FPC root object
Set root = CreateObject("FPC.Root")

' Declare the other objects needed.
Dim array            ' An FPCArray object
Dim contenttypesets  ' An FPCContentTypeSets collection
Dim contenttypeset   ' An FPCContentTypeSet object

' Get references to the array object
' and the content type sets collection.
Set array = root.GetContainingArray()
Set contenttypesets = array.RuleElements.ContentTypeSets

' Display the names of the content type sets
' defined for the array object.
For Each contenttypeset In contenttypesets
    WScript.Echo "Content type set name: " & contenttypeset.Name
Next

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCContentTypeSets


IFPCContentTypeSets | FPCContentTypeSets Add method [ISA Server 2004]

IFPCContentTypeSets::Add[C++]

FPCContentTypeSets.Add [Visual Basic]

[C++]

The Add method creates a new FPCContentTypeSet object in the collection and returns a reference to it.

HRESULT Add(
  BSTR Name,
  IFPCContentTypeSet** ppNewContentTypeSet
);

Parameters

Name
[in] Required. BSTR that specifies the name of the new content type set.
ppNewContentTypeSet
[out] Address of an interface pointer that on return points to the new IFPCContentTypeSet interface created.

Return Values

This method can return one of the following:

  • S_OK, indicating that the operation succeeded.
  • An error code, indicating that the operation failed. In this case, the [out] parameter returned is a null object.

[Visual Basic]

The Add method creates a new FPCContentTypeSet object in the collection and returns a reference to it.

Function Add( _
  ByVal Name As String _
) As FPCContentTypeSet

Parameters

Name
[in] Required. String that specifies the name of the new content type set.

Return Values

This method returns a reference to the FPCContentTypeSet object if successful. Otherwise, an error is raised that can be intercepted by using an error handler.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCContentTypeSets


IFPCContentTypeSets | FPCContentTypeSets Count(long) property [ISA Server 2004]

Count Property of IFPCContentTypeSets[C++]

FPCContentTypeSets.Count [Visual Basic]

[C++]

The Count property gets the number of FPCContentTypeSet objects in the collection.

HRESULT get_Count(
  long* plCount
);

Parameters

plCount
Pointer to a variable that on return receives a 32-bit integer specifying the number of FPCContentTypeSet objects in the collection.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The Count property gets the number of FPCContentTypeSet objects in the collection.

Property Count As Long

Property Value

A 32-bit integer that specifies the number of FPCContentTypeSet objects in the collection.

Remarks

This property is read-only.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCContentTypeSets


IFPCContentTypeSets | FPCContentTypeSets Item method [ISA Server 2004]

IFPCContentTypeSets::Item[C++]

FPCContentTypeSets.Item [Visual Basic]

[C++]

The Item method retrieves the requested IFPCContentTypeSet interface from the collection.

HRESULT Item(
  VARIANT Index,
  IFPCContentTypeSet** ppContentTypeSet
);

Parameters

Index
[in] Required. Name or one-based index of the object to retrieve.
ppContentTypeSet
[out] Address of an interface pointer that on return points to the IFPCContentTypeSet interface requested.

Return Values

This method can return one of the following:

  • S_OK, indicating that the operation succeeded.
  • An error code, indicating that the operation failed. In this case, the [out] parameter returned is a null object.

[Visual Basic]

The Item method retrieves the requested FPCContentTypeSet object from the collection.

Function Item( _
  ByVal Index As Variant _
) As FPCContentTypeSet

Parameters

Index
[in] Required. Name or one-based index of the object to retrieve.

Return Values

This method returns a reference to the FPCContentTypeSet object requested if successful. Otherwise, an error is raised that can be intercepted by using an error handler.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCContentTypeSets


IFPCContentTypeSets | FPCContentTypeSets Remove method [ISA Server 2004]

IFPCContentTypeSets::Remove[C++]

FPCContentTypeSets.Remove [Visual Basic]

[C++]

The Remove method removes the specified FPCContentTypeSet object from the collection.

HRESULT Remove(
  VARIANT Index
);

Parameters

Index
[in] Required. Name or one-based index of the FPCContentTypeSet object to remove.

Return Values

This method returns S_OK if the call is successful; otherwise, it returns an error code.
[Visual Basic]

The Remove method removes the specified FPCContentTypeSet object from the collection.

Sub Remove( _
  ByVal Index As Variant _
)

Parameters

Index
[in] Required. Name or one-based index of the FPCContentTypeSet object to remove.

Return Values

This method has no return values. If the call is unsuccessful, an error is raised that can be intercepted by using an error handler.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCContentTypeSets


FPCCredentials object [ISA Server 2004]

FPCCredentials

The FPCCredentials object lets you set the user name and password to be used when an ISA Server computer communicates with an upstream proxy server or a remote virtual private network (VPN) site, or dials out using a dial-up entry. For example, chaining with another proxy server computer can require that the user name and password have been checked before chaining takes place. A routing rule that routes requests to an upstream proxy server can also check the user name and password before routing the request.

The FPCCredentials object is accessed through the Credentials property of FPCPrimaryRoute, FPCBackupRoute, FPCDialingConfiguration, FPCFirewallChaining, and FPCReportJob objects and through the RemoteCredentials property of an FPCVpnNetworkL2tpPptpSettings object.

Click here to see the ISA Server object hierarchy.

Methods

The FPCCredentials object defines the following methods.

Method | Description
Refresh | Reads the values of the object's properties from persistent storage, discarding any changes that were not saved.
Save | Writes the current values of the object's properties to persistent storage.

Properties

The FPCCredentials object has the following properties.

Property | Description
Password | Sets the password.
UserName | Gets or sets the user name.

Remarks

This object implements the IFPCCredentials interface.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

COM Objects


IFPCCredentials | FPCCredentials Password(BSTR) property [ISA Server 2004]

Password Property of IFPCCredentials[C++]

FPCCredentials.Password [Visual Basic]

[C++]

The Password property sets the password.

HRESULT get_Password();

HRESULT put_Password(
  BSTR bstrPassword
);

Parameters

bstrPassword
BSTR that specifies the password.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is write-only.

[Visual Basic]

The Password property sets the password.

Property Password As String

Property Value

String that specifies the password.

Remarks

This property is write-only.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCCredentials


IFPCCredentials | FPCCredentials Refresh method [ISA Server 2004]

IFPCCredentials::Refresh[C++]

FPCCredentials.Refresh [Visual Basic]

[C++]

The Refresh method reads the values of the object's properties from persistent storage, discarding any changes that were not saved.

HRESULT Refresh();

Parameters

This method has no parameters.

Return Values

This method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

Changes made to this object can be saved by calling the Save method of this object or the Save method of any object containing it.

[Visual Basic]

The Refresh method reads the values of the object's properties from persistent storage, discarding any changes that were not saved.

Sub Refresh()

Parameters

This method has no parameters.

Return Values

This method has no return values. If the call is unsuccessful, an error is raised that can be intercepted by using an error handler.

Remarks

Changes made to this object can be saved by calling the Save method of this object or the Save method of any object containing it.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCCredentials


IFPCCredentials | FPCCredentials Save (2 Parameters) method [ISA Server 2004]

IFPCCredentials::Save[C++]

FPCCredentials.Save [Visual Basic]

[C++]

The Save method writes the current values of the object's properties to persistent storage. It is important to remember that any changes made by scripts and programs are not saved until after the Save method is called.

HRESULT Save(
  VARIANT_BOOL fResetRequiredServices,
  VARIANT_BOOL fReloadConfiguration
);

Parameters

fResetRequiredServices
[in, optional] Boolean value that indicates whether to restart the services that need to be restarted for any of the changes saved to take effect. The default value is VARIANT_FALSE.
fReloadConfiguration
[in, optional] Boolean value that indicates whether the call will include synchronous reloading of all changes that can be applied dynamically without restarting services. The default value is VARIANT_TRUE.

Return Values

This method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

Configuration changes are applied only after the new settings are written to persistent storage and reloaded to the services that use them. Most changes can be applied dynamically without restarting any services. However, some changes can take effect only after the Microsoft Firewall service is restarted. For more information, see Restarting Services after Configuration Changes.

ISA Server maintains a bitmask that specifies which services need to be started for currently unsaved changes to take effect. This bitmask can be retrieved by calling the GetServiceRestartMask method on an object that contains this object as a subobject. Calling the Save method clears all of the bits in this bitmask even if the fResetRequiredServices parameter is set to VARIANT_FALSE.

If the fReloadConfiguration parameter is set to VARIANT_FALSE the current values of the object's properties will be written to persistent storage without updating the configuration being used by the ISA Server services. The configuration used by each service will not be updated until the service is restarted or the new settings are reloaded by another call to Save.

[Visual Basic]

The Save method writes the current values of the object's properties to persistent storage. It is important to remember that any changes made by scripts and programs are not saved until after the Save method is called.

Sub Save( _
  [ ByVal fResetRequiredServices As Boolean ], _
  [ ByVal fReloadConfiguration As Boolean ] _
)

Parameters

fResetRequiredServices
[in, optional] Boolean value that indicates whether to restart the services that need to be restarted for any of the changes saved to take effect. The default value is False.
fReloadConfiguration
[in, optional] Boolean value that indicates whether the call will include synchronous reloading of all the saved configuration changes that can be applied dynamically without restarting services. The default value is True.

Return Values

This method has no return values. If the call is unsuccessful, an error is raised that can be intercepted by using an error handler.

Remarks

Configuration changes are applied only after the new settings are written to persistent storage and reloaded to the services that use them. Most changes can be applied dynamically without restarting any services. However, some changes can take effect only after the Microsoft Firewall service is restarted. For more information, see Restarting Services after Configuration Changes.

ISA Server maintains a bitmask that specifies which services need to be started for currently unsaved changes to take effect. This bitmask can be retrieved by calling the GetServiceRestartMask method on an object that contains this object as a subobject. Calling the Save method clears all of the bits in this bitmask even if the fResetRequiredServices parameter is set to False.

If the fReloadConfiguration parameter is set to False the current values of the object's properties will be written to persistent storage without updating the configuration being used by the ISA Server services. The configuration used by each service will not be updated until the service is restarted or the new settings are reloaded by another call to Save.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCCredentials


IFPCCredentials | FPCCredentials UserName(BSTR,BSTR) property [ISA Server 2004]

UserName Property of IFPCCredentials[C++]

FPCCredentials.UserName [Visual Basic]

[C++]

The UserName property gets or sets the user name.

HRESULT get_UserName(
  BSTR* pbstrUserName
);

HRESULT put_UserName(
  BSTR bstrUserName
);

Parameters

pbstrUserName
Pointer to a BSTR that is set on return to a string value specifying the user name.
bstrUserName
BSTR that specifies the user name.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write.

[Visual Basic]

The UserName property gets or sets the user name.

Property UserName As String

Property Value

String that specifies the user name.

Remarks

This property is read/write.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCCredentials


FPCDelegatedAdmin object [ISA Server 2004]

FPCDelegatedAdmin

The FPCDelegatedAdmin object defines a delegated administrator.

This object is typically an element of an FPCDelegatedAdmins collection.

Click here to see the ISA Server object hierarchy.

Inheritance

This object inherits from the FPCPersist object, which contains methods and properties related to the persistent storage of an object's data. They include methods for exporting the object's data to and importing it from an XML document.

Methods

This object has no methods.

Properties

The FPCDelegatedAdmin object has the following properties.

Property | Description
Account | Gets or sets the trustee, either by name or by security identifier (SID).
Predefined | Gets a Boolean value that indicates whether the delegated administrator is predefined (installed with ISA Server). A predefined delegated administrator cannot be deleted.
Role | Gets an FPCRef object that references the FPCSecurityRole object defining the trustee's security role.

Methods Inherited from FPCPersist

Name | Description
CancelWaitForChanges | Cancels the registration established by the WaitForChanges method (for use in C and C++ programming only).
CanImport | Returns a Boolean value that indicates whether the object's properties can be imported from the specified XML document.
Export | Recursively writes the stored values of all the properties of the object and its subobjects to the specified XML document.
ExportToFile | Recursively writes the stored values of all the properties of the object and its subobjects to the specified XML file.
GetServiceRestartMask | Retrieves a 32-bit bitmask of the FpcServices enumerated type that specifies which services need to be restarted for currently unsaved changes to take effect.
Import | Recursively copies the values of all the properties of the object and of its subobjects from the specified XML document to persistent storage.
ImportFromFile | Recursively copies the values of all the properties of the object and of its subobjects from the specified XML file to persistent storage.
LoadDocProperties | Provides the XML document's properties so that you can know what information can be imported from the document.
Refresh | Recursively reads the values of all the properties of the object and of its subobjects from persistent storage, overwriting any changes that have not been saved.
Save | Recursively writes the current values of all the properties of the object and its subobjects to persistent storage.
WaitForChanges | Registers to wait for an event indicating that the contents of the object have changed (for use in C and C++ programming only).

Properties Inherited from FPCPersist

Name | Description
PersistentName | Gets the persistent name of the object. The persistent name of an object is a name that is unique for the object at the respective level of the COM object hierarchy.
VendorParametersSets | Gets an FPCVendorParametersSets collection that can hold sets of custom data for extending the object.

Remarks

This object implements the IFPCDelegatedAdmin interface.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

COM Objects


IFPCDelegatedAdmin | FPCDelegatedAdmin Account property [ISA Server 2004]

Account Property of IFPCDelegatedAdmin[C++]

FPCDelegatedAdmin.Account [Visual Basic]

[C++]

The Account property gets or sets the trustee, either by name or by security identifier (SID).

HRESULT get_Account(
  BSTR* pbstrAccount
);

HRESULT put_Account(
  BSTR bstrAccount
);

Parameters

pbstrAccount
Pointer to a BSTR that is set on return to a string value specifying the name or SID of the trustee.
bstrAccount
BSTR that specifies the name or SID of the trustee.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write.

[Visual Basic]

The Account property gets or sets the trustee, either by name or by security identifier (SID).

Property Account As String

Property Value

String that specifies the name or SID of the trustee.

Remarks

This property is read/write.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCDelegatedAdmin


IFPCDelegatedAdmin | FPCDelegatedAdmin Predefined property [ISA Server 2004]

Predefined Property of IFPCDelegatedAdmin[C++]

FPCDelegatedAdmin.Predefined [Visual Basic]

[C++]

The Predefined property gets a Boolean value that indicates whether the delegated administrator is predefined. A predefined delegated administrator is one that is defined during the installation of ISA Server, rather than defined by an administrator. A predefined delegated administrator cannot be deleted.

HRESULT get_Predefined(
  VARIANT_BOOL* pfPredefined
);

Parameters

pfPredefined
Pointer to a Boolean variable that is set on return to VARIANT_TRUE if the delegated administrator is predefined or to VARIANT_FALSE if the delegated administrator is user-defined.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The Predefined property gets a Boolean value that indicates whether the delegated administrator is predefined. A predefined delegated administrator is one that is defined during the installation of ISA Server, rather than defined by an administrator. A predefined delegated administrator cannot be deleted.

Property Predefined As Boolean

Property Value

Boolean value that indicates whether the delegated administrator is predefined.

Remarks

This property is read-only.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCDelegatedAdmin


IFPCDelegatedAdmin | FPCDelegatedAdmin Role(FPCRef) property [ISA Server 2004]

Role Property of IFPCDelegatedAdmin[C++]

FPCDelegatedAdmin.Role [Visual Basic]

[C++]

The Role property gets an FPCRef object that references the FPCSecurityRole object defining the trustee's security role.

HRESULT get_Role(
  FPCRef** ppRef
);

Parameters

ppRef
Address of an interface pointer that on return points to an IFPCRef interface that references the FPCSecurityRole object defining the trustee's security role.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The Role property gets an FPCRef object that references the FPCSecurityRole object defining the trustee's security role.

Property Role As FPCRef

Property Value

Reference to an FPCRef object that references the FPCSecurityRole object defining the trustee's security role.

Remarks

This property is read-only.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCDelegatedAdmin


FPCDelegatedAdmins collection [ISA Server 2004]

FPCDelegatedAdmins Collection

The FPCDelegatedAdmins collection holds a set of FPCDelegatedAdmin objects that represents the delegated administrators defined for an FPCArray object.

The FPCDelegatedAdmins collection is typically accessed through the DelegatedAdmins property of an FPCAdminSecurity object.

Click here to see the ISA Server object hierarchy.

Inheritance

This collection inherits from the FPCPersist object, which contains methods and properties related to the persistent storage of an object's data. They include methods for exporting the object's data to and importing it from an XML document.

Methods

The FPCDelegatedAdmins collection defines the following methods.

Method | Description
Add | Creates a new FPCDelegatedAdmin object in the collection and returns a reference to it.
Item | Retrieves the requested FPCDelegatedAdmin object from the collection.
Remove | Removes the specified FPCDelegatedAdmin object from the collection.
RemoveAll | Removes all of the FPCDelegatedAdmin objects from the collection.

Properties

The FPCDelegatedAdmins collection has the following properties.

Property | Description
_NewEnum | Gets an enumerator object for the collection.
Count | Gets the number of FPCDelegatedAdmin objects in the collection.

Methods Inherited from FPCPersist

Name | Description
CancelWaitForChanges | Cancels the registration established by the WaitForChanges method (for use in C and C++ programming only).
CanImport | Returns a Boolean value that indicates whether the properties of the collection, its elements, and their subobjects can be imported from the specified XML document.
Export | Recursively writes the stored values of all the properties of the collection, its elements, and their subobjects to the specified XML document.
ExportToFile | Recursively writes the stored values of all the properties of the collection, its elements, and their subobjects to the specified XML file.
GetServiceRestartMask | Retrieves a 32-bit bitmask of the FpcServices enumerated type that specifies which services need to be restarted for currently unsaved changes to take effect.
Import | Recursively copies the values of all the properties of the collection, its elements, and their subobjects from the specified XML document to persistent storage.
ImportFromFile | Recursively copies the values of all the properties of the collection, its elements, and their subobjects from the specified XML file to persistent storage.
LoadDocProperties | Provides the XML document's properties so that you can know what information can be imported from the document.
Refresh | Recursively reads the values of all the properties of the collection, its elements, and their subobjects from persistent storage, overwriting any changes that have not been saved.
Save | Recursively writes the current values of all the properties of the collection, its elements, and their subobjects to persistent storage.
WaitForChanges | Registers to wait for an event indicating that the contents of the object have changed (for use in C and C++ programming only).

Properties Inherited from FPCPersist

Name | Description
PersistentName | Gets the persistent name of the collection. The persistent name of an object is a name that is unique for the object at the respective level of the COM object hierarchy.
VendorParametersSets | Gets an FPCVendorParametersSets collection that can hold sets of custom data for extending the collection.

Remarks

This collection implements the IFPCDelegatedAdmins interface.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

COM Objects


IFPCDelegatedAdmins | FPCDelegatedAdmins _NewEnum property [ISA Server 2004]

_NewEnum Property of IFPCDelegatedAdmins[C++]

FPCDelegatedAdmins._NewEnum [Visual Basic]

[C++]

The _NewEnum property gets an enumerator object for the collection. An enumerator object provides serial access to the elements of the collection.

HRESULT get__NewEnum(
  IUnknown* ppEnum
);

Parameters

ppEnum
Address of an interface pointer that on return points to the IUnknown interface of an enumerator object that implements an IEnumVARIANT interface for the collection. An interface pointer to the IEnumVARIANT interface of the enumerator object can be retrieved by calling QueryInterface on the IUnknown interface returned.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The _NewEnum property gets an enumerator object for the collection. An enumerator object provides serial access to the elements of the collection.

Property _NewEnum As IUnknown

Property Value

Reference to an enumerator object that provides serial access to the elements of the collection.

Remarks

This property is read-only.

In Visual Basic and VBScript, this property is used implicitly in For Each...In...Next constructs.

Example Code

This VBScript script displays the names of all the delegated administrators defined for an FPCArray object. It does not include error handling.

' Create the root object.
Dim root  ' The FPCLib.FPC root object
Set root = CreateObject("FPC.Root")

' Declare the other objects needed.
Dim array            ' An FPCArray object
Dim delegatedadmins  ' An FPCDelegatedAdmins collection
Dim delegatedadmin   ' An FPCDelegatedAdmin object

' Get references to the array object
' and the delegated administrators collection.
Set array = root.GetContainingArray()
Set delegatedadmins = array.AdminSecurity.DelegatedAdmins

' Display the name or security identifier (SID) of each delegated administrator
' defined for the array object.
For Each delegatedadmin In delegatedadmins
    WScript.Echo "Delegated administrator name or SID: " & delegatedadmin.Account
Next

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCDelegatedAdmins


IFPCDelegatedAdmins | FPCDelegatedAdmins Add method [ISA Server 2004]

IFPCDelegatedAdmins::Add[C++]

FPCDelegatedAdmins.Add [Visual Basic]

[C++]

The Add method creates a new FPCDelegatedAdmin object, inserts it into the collection, and returns a reference to it.

HRESULT Add(
  BSTR Account,
  BSTR Role,
  IFPCDelegatedAdmin** ppNewDelegatedAdmin
);

Parameters

Account
[in] Account name of the delegated administrator.
Role
[in] Role of the delegated administrator.
ppNewDelegatedAdmin
[out] Address of an interface pointer that on return points to the new IFPCDelegatedAdmin interface created.

Return Values

This method can return one of the following:

  • S_OK, indicating that the operation succeeded.
  • An error code, indicating that the operation failed. In this case, the [out] parameter returned is a null object.

[Visual Basic]

The Add method creates a new FPCDelegatedAdmin object, inserts it into the collection, and returns a reference to it.

Function Add( _
  ByVal Account As String, _
  ByVal Role As String _
) As FPCDelegatedAdmin

Parameters

Account
[in] Account name of the delegated administrator.
Role
[in] Role of the delegated administrator.

Return Values

This method returns a reference to the FPCDelegatedAdmin object if successful. Otherwise, an error is raised that can be intercepted by using an error handler.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCDelegatedAdmins


IFPCDelegatedAdmins | FPCDelegatedAdmins Count(long) property [ISA Server 2004]

Count Property of IFPCDelegatedAdmins[C++]

FPCDelegatedAdmins.Count [Visual Basic]

[C++]

The Count property gets the number of FPCDelegatedAdmin objects in the collection.

HRESULT get_Count(
  long* plCount
);

Parameters

plCount
Pointer to a variable that on return receives a 32-bit integer specifying the number of FPCDelegatedAdmin objects in the collection.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The Count property gets the number of FPCDelegatedAdmin objects in the collection.

Property Count As Long

Property Value

A 32-bit integer that specifies the number of FPCDelegatedAdmin objects in the collection.

Remarks

This property is read-only.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCDelegatedAdmins


IFPCDelegatedAdmins | FPCDelegatedAdmins Item method [ISA Server 2004]

IFPCDelegatedAdmins::Item[C++]

FPCDelegatedAdmins.Item [Visual Basic]

[C++]

The Item method retrieves the requested IFPCDelegatedAdmin interface from the collection.

HRESULT Item(
  VARIANT IndexOrAccount,
  BSTR Role,
  IFPCDelegatedAdmin** ppItem
);

Parameters

IndexOrAccount
[in] Required. Account name or one-based index of the object to retrieve.
Role
[in, optional] Role of the delegated administrator. The default value is an empty string (NULL).
ppItem
[out] Address of an interface pointer that on return points to the IFPCDelegatedAdmin interface requested.

Return Values

This method can return one of the following:

  • S_OK, indicating that the operation succeeded.
  • An error code, indicating that the operation failed. In this case, the [out] parameter returned is a null object.

[Visual Basic]

The Item method retrieves the requested FPCDelegatedAdmin object from the collection.

Function Item( _
  ByVal IndexOrAccount As Variant, _
  [ ByVal Role As String ] _
) As FPCDelegatedAdmin

Parameters

IndexOrAccount
[in] Required. Account name or one-based index of the object to retrieve.
Role
[in, optional] Role of the delegated administrator. The default value is an empty string (NULL).

Return Values

This method returns a reference to the FPCDelegatedAdmin object requested if successful. Otherwise, an error is raised that can be intercepted by using an error handler.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCDelegatedAdmins


IFPCDelegatedAdmins | FPCDelegatedAdmins Remove method [ISA Server 2004]

IFPCDelegatedAdmins::Remove[C++]

FPCDelegatedAdmins.Remove [Visual Basic]

[C++]

The Remove method removes the specified FPCDelegatedAdmin object from the collection.

HRESULT Remove(
  VARIANT IndexOrAccount,
  BSTR Role
);

Parameters

IndexOrAccount
[in] Required. Value of the Account property or one-based index of the FPCDelegatedAdmin object to remove.
Role
[in, optional] String value specifying the role of the delegated administrator. The default value is an empty string (NULL).

Return Values

This method returns S_OK if the call is successful; otherwise, it returns an error code.
[Visual Basic]

The Remove method removes the specified FPCDelegatedAdmin object from the collection.

Sub Remove( _
  ByVal IndexOrAccount As Variant, _
  [ ByVal Role As String ] _
)

Parameters

IndexOrAccount
[in] Required. Value of the Account property or one-based index of the FPCDelegatedAdmin object to remove.
Role
[in, optional] String value specifying the role of the delegated administrator. The default value is an empty string (NULL).

Return Values

This method has no return values. If the call is unsuccessful, an error is raised that can be intercepted by using an error handler.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCDelegatedAdmins


IFPCDelegatedAdmins | FPCDelegatedAdmins RemoveAll method [ISA Server 2004]

IFPCDelegatedAdmins::RemoveAll[C++]

FPCDelegatedAdmins.RemoveAll [Visual Basic]

[C++]

The RemoveAll method removes all of the FPCDelegatedAdmin objects from the collection.

HRESULT RemoveAll();

Parameters

This method has no parameters.

Return Values

This method returns S_OK if the call is successful; otherwise, it returns an error code.
[Visual Basic]

The RemoveAll method removes all of the FPCDelegatedAdmin objects from the collection.

Sub RemoveAll()

Parameters

This method has no parameters.

Return Values

This method has no return values. If the call is unsuccessful, an error is raised that can be intercepted by using an error handler.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCDelegatedAdmins


FPCDialingConfiguration object [ISA Server 2004]

FPCDialingConfiguration

The FPCDialingConfiguration object defines the configuration for automatic dialing.

This object can be accessed through the DialingConfiguration property of an FPCNetworkConfiguration object.

Click here to see the ISA Server object hierarchy.

Inheritance

This object inherits from the FPCPersist object, which contains methods and properties related to the persistent storage of an object's data. They include methods for exporting the object's data to and importing it from an XML document.

Methods

The FPCDialingConfiguration object defines the following methods.

Method | Description
DisableAutoDial | Disables automatic dialing.
EnableAutoDialToNetwork | Enables automatic dialing when the ISA Server computer first tries to access the network.

Properties

The FPCDialingConfiguration object has the following properties.

Property | Description
AutoDialedNetwork | Gets an FPCRef object that references the FPCNetwork object defining the network to which the automatic dialing configuration applies.
AutoDialEnabled | Gets a Boolean value that indicates whether automatic dialing is enabled.
Credentials | Gets an FPCCredentials object that represents the credentials needed for automatic dialing.
DefaultGateway | Gets or sets a Boolean value that indicates whether the dial-up connection should become the default gateway whenever it is active.
DialupConnectionName | Gets or sets the name of the dial-up connection that is used for automatic dialing.

Methods Inherited from FPCPersist

Name | Description
CancelWaitForChanges | Cancels the registration established by the WaitForChanges method (for use in C and C++ programming only).
CanImport | Returns a Boolean value that indicates whether the object's properties can be imported from the specified XML document.
Export | Recursively writes the stored values of all the properties of the object and its subobjects to the specified XML document.
ExportToFile | Recursively writes the stored values of all the properties of the object and its subobjects to the specified XML file.
GetServiceRestartMask | Retrieves a 32-bit bitmask of the FpcServices enumerated type that specifies which services need to be restarted for currently unsaved changes to take effect.
Import | Recursively copies the values of all the properties of the object and of its subobjects from the specified XML document to persistent storage.
ImportFromFile | Recursively copies the values of all the properties of the object and of its subobjects from the specified XML file to persistent storage.
LoadDocProperties | Provides the XML document's properties so that you can know what information can be imported from the document.
Refresh | Recursively reads the values of all the properties of the object and of its subobjects from persistent storage, overwriting any changes that have not been saved.
Save | Recursively writes the current values of all the properties of the object and its subobjects to persistent storage.
WaitForChanges | Registers to wait for an event indicating that the contents of the object have changed (for use in C and C++ programming only).

Properties Inherited from FPCPersist

Name | Description
PersistentName | Gets the persistent name of the object. The persistent name of an object is a name that is unique for the object at the respective level of the COM object hierarchy.
VendorParametersSets | Gets an FPCVendorParametersSets collection that can hold sets of custom data for extending the object.

Remarks

This object implements the IFPCDialingConfiguration interface.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

COM Objects


IFPCDialingConfiguration.AutoDialedNetwork(IFPCRef) property [ISA Server 2004]

AutoDialedNetwork Property of IFPCDialingConfiguration[C++]

FPCDialingConfiguration.AutoDialedNetwork [Visual Basic]

[C++]

The AutoDialedNetwork property gets an FPCRef object that references the FPCNetwork object defining the network to which the automatic dialing configuration applies.

HRESULT get_AutoDialedNetwork(
  IFPCRef** ppRef
);

Parameters

ppRef
Address of an interface pointer that on return points to an IFPCRef interface that references the FPCNetwork object defining the network to which the automatic dialing configuration applies.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The AutoDialedNetwork property gets an FPCRef object that references the FPCNetwork object defining the network to which the automatic dialing configuration applies.

Property AutoDialedNetwork As FPCRef

Property Value

Reference to an FPCRef object that references the FPCNetwork object defining the network to which the automatic dialing configuration applies.

Remarks

This property is read-only.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCDialingConfiguration


IFPCDialingConfiguration.AutoDialEnabled property [ISA Server 2004]

AutoDialEnabled Property of IFPCDialingConfiguration[C++]

FPCDialingConfiguration.AutoDialEnabled [Visual Basic]

[C++]

The AutoDialEnabled property gets a Boolean value that indicates whether automatic dialing is enabled.

HRESULT get_AutoDialEnabled(
  VARIANT_BOOL* pfEnabled
);

Parameters

pfEnabled
Pointer to a Boolean variable that is set on return to VARIANT_TRUE if automatic dialing is enabled, or to VARIANT_FALSE if automatic dialing is disabled.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.
[Visual Basic]

The AutoDialEnabled property gets a Boolean value that indicates whether automatic dialing is enabled.

Property AutoDialEnabled As Boolean

Property Value

Boolean value that indicates whether automatic dialing is enabled.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCDialingConfiguration


IFPCDialingConfiguration.Credentials(IFPCCredentials) property [ISA Server 2004]

Credentials Property of IFPCDialingConfiguration[C++]

FPCDialingConfiguration.Credentials [Visual Basic]

[C++]

The Credentials property gets an FPCCredentials object that represents the credentials needed for automatic dialing.

HRESULT get_Credentials(
  IFPCCredentials** ppCredentials
);

Parameters

ppCredentials
Address of an interface pointer that on return points to an IFPCCredentials interface that represents the credentials needed for automatic dialing.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only. The credentials can be modified through the properties of the IFPCCredentials interface retrieved.

[Visual Basic]

The Credentials property gets an FPCCredentials object that represents the credentials needed for automatic dialing.

Property Credentials As FPCCredentials

Property Value

Reference to an FPCCredentials object that represents the credentials needed for automatic dialing.

Remarks

This property is read-only. The credentials can be modified through the properties of the FPCCredentials object retrieved.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCDialingConfiguration


IFPCDialingConfiguration.DefaultGateway property [ISA Server 2004]

DefaultGateway Property of IFPCDialingConfiguration[C++]

FPCDialingConfiguration.DefaultGateway [Visual Basic]

[C++]

The DefaultGateway property gets or sets a Boolean value that indicates whether the dial-up connection should become the default gateway whenever it is active.

HRESULT get_DefaultGateway(
  VARIANT_BOOL* pfDefaultGateway
);

HRESULT put_DefaultGateway(
  VARIANT_BOOL fDefaultGateway
);

Parameters

pfDefaultGateway
Pointer to a Boolean variable that is set on return to VARIANT_TRUE if the dial-up connection should become the default gateway whenever it is active, or to VARIANT_FALSE if the dial-up connection should not become the default gateway.
fDefaultGateway
Boolean value that indicates whether the dial-up connection should become the default gateway whenever it is active.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write.

[Visual Basic]

The DefaultGateway property gets or sets a Boolean value that indicates whether the dial-up connection should become the default gateway whenever it is active.

Property DefaultGateway As Boolean

Property Value

Boolean value that indicates whether the dial-up connection should become the default gateway whenever it is active.

Remarks

This property is read/write.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCDialingConfiguration


IFPCDialingConfiguration.DialupConnectionName property [ISA Server 2004]

DialupConnectionName Property of IFPCDialingConfiguration[C++]

FPCDialingConfiguration.DialupConnectionName [Visual Basic]

[C++]

The DialupConnectionName property gets or sets the name of the dial-up connection that is used for automatic dialing.

HRESULT get_DialupConnectionName(
  BSTR* pbstrName
);

HRESULT put_DialupConnectionName(
  BSTR bstrName
);

Parameters

pbstrName
Pointer to a BSTR that is set on return to a string value specifying the name of the dial-up connection that is used for automatic dialing.
bstrName
BSTR that specifies the name of the dial-up connection that is used for automatic dialing.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write.

[Visual Basic]

The DialupConnectionName property gets or sets the name of the dial-up connection that is used for automatic dialing.

Property DialupConnectionName As String

Property Value

String that specifies the name of the dial-up connection that is used for automatic dialing.

Remarks

This property is read/write.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCDialingConfiguration


IFPCDialingConfiguration.DisableAutoDial method [ISA Server 2004]

IFPCDialingConfiguration::DisableAutoDial[C++]

FPCDialingConfiguration.DisableAutoDial [Visual Basic]

[C++]

The DisableAutoDial method disables automatic dialing.

HRESULT DisableAutoDial();

Parameters

This method has no parameters.

Return Values

This method returns S_OK if the call is successful; otherwise, it returns an error code.
[Visual Basic]

The DisableAutoDial method disables automatic dialing.

Sub DisableAutoDial()

Parameters

This method has no parameters.

Return Values

This method has no return values. If the call is unsuccessful, an error is raised that can be intercepted by using an error handler.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCDialingConfiguration


IFPCDialingConfiguration.EnableAutoDialToNetwork method [ISA Server 2004]

IFPCDialingConfiguration::EnableAutoDialToNetwork[C++]

FPCDialingConfiguration.EnableAutoDialToNetwork [Visual Basic]

[C++]

The EnableAutoDialToNetwork method enables automatic dialing when the ISA Server computer first tries to access the network.

HRESULT EnableAutoDialToNetwork(
  BSTR NetworkName,
  BSTR NewDialupConnectionName
);

Parameters

NetworkName
[in] BSTR that specifies the name of the network.
NewDialupConnectionName
[in, optional] BSTR that specifies the name of a new dial-up connection to use for automatic dialing. The default value is an empty string.

Return Values

This method returns S_OK if the call is successful; otherwise, it returns an error code.
[Visual Basic]

The EnableAutoDialToNetwork method enables automatic dialing when the ISA Server computer first tries to access the network.

Sub EnableAutoDialToNetwork( _
  ByVal NetworkName As String, _
  [ ByVal newDialupConnectionName As String ] _
)

Parameters

NetworkName
[in] String value that specifies the name of the network.
newDialupConnectionName
[in, optional] String value that specifies the name of a new dial-up connection to use for automatic dialing. The default value is an empty string.

Return Values

This method has no return values. If the call is unsuccessful, an error is raised that can be intercepted by using an error handler.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCDialingConfiguration


FPCDialupNetworkConnections collection [ISA Server 2004]

FPCDialupNetworkConnections Collection

The FPCDialupNetworkConnections collection holds the names of the dial-up network connections that have been set up on an ISA Server computer. This object can be accessed through the DialupNetworkConnections property of an FPCServer object.

Note This collection is not part of persistent storage and retrieves data from the dial-up connections file of the specified server.

Click here to see the ISA Server object hierarchy.

Methods

The FPCDialupNetworkConnections collection defines the following methods.

Method | Description
Item | Retrieves the requested dial-up connection entry from the collection.
Refresh | Reads all of the dial-up connection entries from the dial-up connections file.

Properties

The FPCDialupNetworkConnections collection has the following properties.

Property | Description
_NewEnum | Gets an enumerator object for the collection.
Count | Gets the number of dial-up connection entries in the collection.

Remarks

This collection implements the IFPCDialupNetworkConnections interface.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

COM Objects


IFPCDialupNetworkConnections._NewEnum(IUnknown) property [ISA Server 2004]

_NewEnum Property of IFPCDialupNetworkConnections[C++]

FPCDialupNetworkConnections._NewEnum [Visual Basic]

[C++]

The _NewEnum property gets an enumerator object for the collection. An enumerator object provides serial access to the elements of the collection.

HRESULT get__NewEnum(
  IUnknown* ppEnum
);

Parameters

ppEnum
Address of an interface pointer that on return points to the IUnknown interface of an enumerator object that implements an IEnumVARIANT interface for the collection. An interface pointer to the IEnumVARIANT interface of the enumerator object can be retrieved by calling QueryInterface on the IUnknown interface returned.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The _NewEnum property gets an enumerator object for the collection. An enumerator object provides serial access to the elements of the collection.

Property _NewEnum As IUnknown

Property Value

Reference to an enumerator object that provides serial access to the elements of the collection.

Remarks

This property is read-only.

In Visual Basic and VBScript, this property is used implicitly in For Each...In...Next constructs.

Example Code

This VBScript script displays the names of the dial-up network connections that have been set up on the local ISA Server computer. It does not include error handling.

' Create the root object.
Dim root  ' The FPCLib.FPC root object
Set root = CreateObject("FPC.Root")

' Declare the other objects needed.
Dim server       ' An FPCServer object
Dim connections  ' An FPCDialupNetworkConnections collection
Dim connection   ' A Variant

' Get references to the server object
' and the dial-up network connections collection.
Set server = root.GetContainingServer()
Set connections = server.DialupNetworkConnections

'Display the name of each dial-up network connection.
For Each connection In connections
    WScript.Echo "Dial-up network connection name: " & connection
Next

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCDialupNetworkConnections


IFPCDialupNetworkConnections.Count(long) property [ISA Server 2004]

Count Property of IFPCDialupNetworkConnections[C++]

FPCDialupNetworkConnections.Count [Visual Basic]

[C++]

The Count property gets the number of dial-up connection entries in the collection.

HRESULT get_Count(
  long* plCount
);

Parameters

plCount
Pointer to a variable that on return receives a 32-bit integer specifying the number of dial-up connection entries in the collection.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The Count property gets the number of dial-up connection entries in the collection.

Property Count As Long

Property Value

A 32-bit integer that specifies the number of dial-up connection entries in the collection.

Remarks

This property is read-only.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCDialupNetworkConnections


IFPCDialupNetworkConnections.Item(Long,VARIANT) method [ISA Server 2004]

IFPCDialupNetworkConnections::Item[C++]

FPCDialupNetworkConnections.Item [Visual Basic]

[C++]

The Item method retrieves the requested dial-up connection entry from the collection.

HRESULT Item(
  long Index,
  VARIANT* pItem
);

Parameters

Index
[in] Required. One-based index of the entry to retrieve.
pItem
Pointer to a VARIANT that is set on return to the name of the entry requested, or to –1 if the entry specified by the Index parameter does not exist.

Return Values

This method can return one of the following:

  • S_OK, indicating that the operation succeeded.
  • An error code, indicating that the operation failed. In this case, the [out] parameter returned is –1.
[Visual Basic]

The Item method retrieves the requested dial-up connection entry from the collection.

Function Item( _
  ByVal Index As Long _
) As Variant

Parameters

Index
[in] Required. One-based index of the entry to retrieve.

Return Values

Returns a Variant that contains the name of the entry requested, or –1 if the entry specified by the Index parameter does not exist.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCDialupNetworkConnections


IFPCDialupNetworkConnections.Refresh method [ISA Server 2004]

IFPCDialupNetworkConnections::Refresh[C++]

FPCDialupNetworkConnections.Refresh [Visual Basic]

[C++]

The Refresh method reads all the phone book entries from the phone book by using a remote procedure call (RPC). The FPCDialupNetworkConnections collection is not part of persistent storage and retrieves data from the phone-book file of the specified server. An RPC call is used to query ISA Server services about its sessions because the information is dynamic.

HRESULT Refresh();

Parameters

This method has no parameters.

Return Values

This method returns S_OK if the call is successful; otherwise, it returns an error code.
[Visual Basic]

The Refresh method reads all the phone book entries from the phone book by using a remote procedure call (RPC). The FPCDialupNetworkConnections collection is not part of persistent storage and retrieves data from the phone-book file of the specified server. An RPC call is used to query ISA Server services about its sessions because the information is dynamic.

Sub Refresh()

Parameters

This method has no parameters.

Return Values

This method has no return values. If the call is unsuccessful, an error is raised that can be intercepted by using an error handler.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCDialupNetworkConnections


FPCDiskDrive object [ISA Server 2004]

FPCDiskDrive

The FPCDiskDrive object represents a single disk drive of an ISA Server computer. This object provides read-only access to the drive's properties.

This object is typically an element of an FPCDiskDrives collection.

Click here to see the ISA Server object hierarchy.

Methods

This object has no methods.

Properties

The FPCDiskDrive object has the following properties.

Property | Description
DiskSizeInMegs | Gets the size of the disk drive, in megabytes.
FileSystem | Gets the name of the file system; for example, "FAT", "FAT32", or "NTFS".
FreeSpaceInMegs | Gets the amount of free space, in megabytes, on the disk drive.
Name | Gets the name of the disk drive; for example, "C:" or "D:".

Remarks

This object implements the IFPCDiskDrive interface.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

COM Objects


IFPCDiskDrive | FPCDiskDrive DiskSizeInMegs(long) property [ISA Server 2004]

DiskSizeInMegs Property of IFPCDiskDrive[C++]

FPCDiskDrive.DiskSizeInMegs [Visual Basic]

[C++]

The DiskSizeInMegs property gets the size of the disk drive, in megabytes.

HRESULT get_DiskSizeInMegs(
  long* plSize
);

Parameters

plSize
Pointer to a variable that on return receives a 32-bit integer specifying the size of the disk drive, in megabytes.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The DiskSizeInMegs property gets the size of the disk drive, in megabytes.

Property DiskSizeInMegs As Long

Property Value

A 32-bit integer that specifies the size of the disk drive, in megabytes.

Remarks

This property is read-only.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCDiskDrive


IFPCDiskDrive | FPCDiskDrive FileSystem(BSTR) property [ISA Server 2004]

FileSystem Property of IFPCDiskDrive[C++]

FPCDiskDrive.FileSystem [Visual Basic]

[C++]

The FileSystem property gets the name of the file system; for example, "FAT", "FAT32", or "NTFS".

HRESULT get_FileSystem(
  BSTR* pbstrName
);

Parameters

pbstrName
Pointer to a BSTR that is set on return to a string value specifying the name of the file system; for example, "FAT", "FAT32", or "NTFS".

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The FileSystem property gets the name of the file system; for example, "FAT", "FAT32", or "NTFS".

Property FileSystem As String

Property Value

String that specifies the name of the file system; for example, "FAT", "FAT32", or "NTFS".

Remarks

This property is read-only.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCDiskDrive


IFPCDiskDrive | FPCDiskDrive FreeSpaceInMegs(long) property [ISA Server 2004]

FreeSpaceInMegs Property of IFPCDiskDrive[C++]

FPCDiskDrive.FreeSpaceInMegs [Visual Basic]

[C++]

The FreeSpaceInMegs property gets the amount of free space, in megabytes, on the disk drive.

HRESULT get_FreeSpaceInMegs(
  long* plSize
);

Parameters

plSize
Pointer to a variable that on return receives a 32-bit integer specifying the amount of free space, in megabytes, on the disk drive.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The FreeSpaceInMegs property gets the amount of free space, in megabytes, on the disk drive.

Property FreeSpaceInMegs As Long

Property Value

A 32-bit integer that specifies the amount of free space, in megabytes, on the disk drive.

Remarks

This property is read-only.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCDiskDrive


IFPCDiskDrive | FPCDiskDrive Name(BSTR) property [ISA Server 2004]

Name Property of IFPCDiskDrive[C++]

FPCDiskDrive.Name [Visual Basic]

[C++]

The Name property gets the name of the disk drive; for example, "C:" or "D:".

HRESULT get_Name(
  BSTR* pbstrName
);

Parameters

pbstrName
Pointer to a BSTR that is set on return to a string value specifying the name of the disk drive; for example, "C:" or "D:".

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only. The drive name that is returned cannot be changed with this property.

[Visual Basic]

The Name property gets the name of the disk drive; for example, "C:" or "D:".

Property Name As String

Property Value

String that specifies the name of the disk drive; for example, "C:" or "D:".

Remarks

This property is read-only. The drive name that is returned cannot be changed with this property.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCDiskDrive


FPCDiskDrives collection [ISA Server 2004]

FPCDiskDrives Collection

The FPCDiskDrives collection holds a set of FPCDiskDrive objects. This collection is typically accessed through the DiskDrives property of an FPCServer object.

Click here to see the ISA Server object hierarchy.

Methods

The FPCDiskDrives collection defines the following methods.

Method | Description
Item | Retrieves the requested FPCDiskDrive object from the collection.
Refresh | Reads the values of all the properties of the collection and its elements from persistent storage, discarding any changes that were not saved.

Properties

The FPCDiskDrives collection has the following properties.

Property | Description
_NewEnum | Gets an enumerator object for the collection.
Count | Gets the number of FPCDiskDrive objects in the collection.
TotalCurrentCacheInMegs | Gets the total amount of disk space currently being used by the cache, in megabytes.
TotalDiskSizeInMegs | Gets the total amount of disk space, in megabytes, on all NTFS disk drives.
TotalFreeSizeInMegs | Gets the total amount of free space, in megabytes, on all NTFS disk drives.

Remarks

This collection implements the IFPCDiskDrives interface.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

COM Objects


IFPCDiskDrives | FPCDiskDrives _NewEnum(IUnknown) property [ISA Server 2004]

_NewEnum Property of IFPCDiskDrives[C++]

FPCDiskDrives._NewEnum [Visual Basic]

[C++]

The _NewEnum property gets an enumerator object for the collection. An enumerator object provides serial access to the elements of the collection.

HRESULT get__NewEnum(
  IUnknown* ppEnum
);

Parameters

ppEnum
Address of an interface pointer that on return points to the IUnknown interface of an enumerator object that implements an IEnumVARIANT interface for the collection. An interface pointer to the IEnumVARIANT interface of the enumerator object can be retrieved by calling QueryInterface on the IUnknown interface returned.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The _NewEnum property gets an enumerator object for the collection. An enumerator object provides serial access to the elements of the collection.

Property _NewEnum As IUnknown

Property Value

Reference to an enumerator object that provides serial access to the elements of the collection.

Remarks

This property is read-only.

In Visual Basic and VBScript, this property is used implicitly in For Each...In...Next constructs.

Example Code

This VBScript script displays the name (drive) letter) and amount of free space for each disk drive on the local ISA Server computer. It does not include error handling.

' Create the root object.
Dim root  ' The FPCLib.FPC root object
Set root = CreateObject("FPC.Root")

' Declare the other objects needed.
Dim server  ' An FPCServer object
Dim drives  ' An FPCDiskDrives collection
Dim drive   ' An FPCDiskDrive object

' Get references to the server object
' and the disk drives collection.
Set server = root.GetContainingServer()
Set drives = server.DiskDrives

' Display name (drive letter) and amount of free space
' for each disk drive.
For Each drive In drives
    WScript.Echo "The amount of free space on drive " & drive.Name & _
                 " is " & drive.FreeSpaceInMegs & " megabytes"
Next

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCDiskDrives


IFPCDiskDrives | FPCDiskDrives Count(long) property [ISA Server 2004]

Count Property of IFPCDiskDrives[C++]

FPCDiskDrives.Count [Visual Basic]

[C++]

The Count property gets the number of FPCDiskDrive objects in the collection.

HRESULT get_Count(
  long* plCount
);

Parameters

plCount
Pointer to a variable that on return receives a 32-bit integer specifying the number of FPCDiskDrive objects in the collection.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The Count property gets the number of FPCDiskDrive objects in the collection.

Property Count As Long

Property Value

A 32-bit integer that specifies the number of FPCDiskDrive objects in the collection.

Remarks

This property is read-only.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCDiskDrives


IFPCDiskDrives | FPCDiskDrives Item (2 Parameters) method [ISA Server 2004]

IFPCDiskDrives::Item[C++]

FPCDiskDrives.Item [Visual Basic]

[C++]

The Item method retrieves the requested IFPCDiskDrive interface from the collection.

HRESULT Item(
  VARIANT Index,
  IFPCDiskDrive** ppItem
);

Parameters

Index
[in] Required. Name or one-based index of the object to retrieve.
ppItem
[out] Address of an interface pointer that on return points to the IFPCDiskDrive interface requested.

Return Values

This method can return one of the following:

  • S_OK, indicating that the operation succeeded.
  • An error code, indicating that the operation failed. In this case, the [out] parameter returned is a null object.
[Visual Basic]

The Item method retrieves the requested FPCDiskDrive object from the collection.

Function Item( _
  ByVal Index As Variant _
) As FPCDiskDrive

Parameters

Index
[in] Required. Name or one-based index of the object to retrieve.

Return Values

This method returns a reference to the FPCDiskDrive object requested if successful. Otherwise, an error is raised that can be intercepted by using an error handler.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCDiskDrives


IFPCDiskDrives | FPCDiskDrives Refresh method [ISA Server 2004]

IFPCDiskDrives::Refresh[C++]

FPCDiskDrives.Refresh [Visual Basic]

[C++]

The Refresh method reads the values of all the properties of the collection and its elements from persistent storage, discarding any changes that were not saved.

HRESULT Refresh();

Parameters

This method has no parameters.

Return Values

This method returns S_OK if the call is successful; otherwise, it returns an error code.
[Visual Basic]

The Refresh method reads the values of all the properties of the collection and its elements from persistent storage, discarding any changes that were not saved.

Sub Refresh()

Parameters

This method has no parameters.

Return Values

This method has no return values. If the call is unsuccessful, an error is raised that can be intercepted by using an error handler.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCDiskDrives


IFPCDiskDrives.TotalCurrentCacheInMegs(long) property [ISA Server 2004]

TotalCurrentCacheInMegs Property of IFPCDiskDrives[C++]

FPCDiskDrives.TotalCurrentCacheInMegs [Visual Basic]

[C++]

The TotalCurrentCacheInMegs property gets the total amount of disk space currently being used by the cache, in megabytes.

HRESULT get_TotalCurrentCacheInMegs(
  long* plCurrentCache
);

Parameters

plCurrentCache
Pointer to a variable that on return receives a 32-bit integer specifying the total amount of disk space currently used by the cache, in megabytes.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The TotalCurrentCacheInMegs property gets the total amount of disk space currently being used by the cache, in megabytes.

Property TotalCurrentCacheInMegs As Long

Property Value

A 32-bit integer that specifies the total amount of disk space currently used by the cache, in megabytes.

Remarks

This property is read-only.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCDiskDrives


IFPCDiskDrives | FPCDiskDrives TotalDiskSizeInMegs property [ISA Server 2004]

TotalDiskSizeInMegs Property of IFPCDiskDrives[C++]

FPCDiskDrives.TotalDiskSizeInMegs [Visual Basic]

[C++]

The TotalDiskSizeInMegs property gets the total amount of disk space, in megabytes, on all NTFS disk drives.

HRESULT get_TotalDiskSizeInMegs(
  long* plSize
);

Parameters

plSize
Pointer to a variable that on return receives a 32-bit integer specifying the total amount of disk space, in megabytes, on all NTFS disk drives.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The TotalDiskSizeInMegs property gets the total amount of disk space, in megabytes, on all NTFS disk drives.

Property TotalDiskSizeInMegs As Long

Property Value

A 32-bit integer that specifies the total amount of disk space, in megabytes, on all NTFS disk drives.

Remarks

This property is read-only.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCDiskDrives


IFPCDiskDrives | FPCDiskDrives TotalFreeSizeInMegs property [ISA Server 2004]

TotalFreeSizeInMegs Property of IFPCDiskDrives[C++]

FPCDiskDrives.TotalFreeSizeInMegs [Visual Basic]

[C++]

The TotalFreeSizeInMegs property gets the total amount of free space, in megabytes, on all NTFS disk drives.

HRESULT get_TotalFreeSizeInMegs(
  long* plSize
);

Parameters

plSize
Pointer to a variable that on return receives a 32-bit integer specifying the total amount of free space, in megabytes, on all NTFS disk drives.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The TotalFreeSizeInMegs property gets the total amount of free space, in megabytes, on all NTFS disk drives.

Property TotalFreeSizeInMegs As Long

Property Value

A 32-bit integer that specifies the total amount of free space, in megabytes, on all NTFS disk drives.

Remarks

This property is read-only.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCDiskDrives


FPCDomainNameSet collection [ISA Server 2004]

FPCDomainNameSet Collection

The FPCDomainNameSet collection contains a set of domain names that can be referenced by ISA Server rules.

This object is typically an element of an FPCDomainNameSets collection.

Click here to see the ISA Server object hierarchy.

Inheritance

This object inherits from the FPCPersist object, which contains methods and properties related to the persistent storage of an object's data. They include methods for exporting the object's data to and importing it from an XML document.

Methods

The FPCDomainNameSet collection defines the following methods.

Method | Description
Add | Adds a domain name to the domain name set.
Item | Retrieves the requested domain name from the domain name set.
Remove | Removes the specified domain name from the domain name set.

Properties

The FPCDomainNameSet collection has the following properties.

Property | Description
_NewEnum | Gets an enumerator object for the collection.
Count | Gets the number of domain names in the domain name set.
Description | Gets or sets the description of the domain name set.
Name | Gets or sets the name of the domain name set.
Predefined | Gets a Boolean value that indicates whether the domain name set is a predefined domain name set that was installed with ISA Server and cannot be deleted.

Methods Inherited from FPCPersist

Name | Description
CancelWaitForChanges | Cancels the registration established by the WaitForChanges method (for use in C and C++ programming only).
CanImport | Returns a Boolean value that indicates whether the collection's properties and elements can be imported from the specified XML document.
Export | Writes the stored values of the collection's properties and elements to the specified XML document.
ExportToFile | Writes the stored values of the collection's properties and elements to the specified XML file.
GetServiceRestartMask | Retrieves a 32-bit bitmask of the FpcServices enumerated type that specifies which services need to be restarted for currently unsaved changes to take effect.
Import | Copies the values of the collection's properties and elements from the specified XML document to persistent storage.
ImportFromFile | Copies the values of the collection's properties and elements from the specified XML file to persistent storage.
LoadDocProperties | Provides the XML document's properties so that you can know what information can be imported from the document.
Refresh | Reads the values of the collection's properties and elements from persistent storage, overwriting any changes that have not been saved.
Save | Writes the current values of the collection's properties and elements to persistent storage.
WaitForChanges | Registers to wait for an event indicating that the contents of the object have changed (for use in C and C++ programming only).

Properties Inherited from FPCPersist

Name | Description
PersistentName | Gets the persistent name of the collection. The persistent name of an object is a name that is unique for the object at the respective level of the COM object hierarchy.
VendorParametersSets | Gets an FPCVendorParametersSets collection that can hold sets of custom data for extending the collection.

Remarks

This collection implements the IFPCDomainNameSets interface.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

COM Objects


IFPCDomainNameSet | FPCDomainNameSet _NewEnum property [ISA Server 2004]

_NewEnum Property of IFPCDomainNameSet[C++]

FPCDomainNameSet._NewEnum [Visual Basic]

[C++]

The _NewEnum property gets an enumerator object for the collection. An enumerator object provides serial access to the elements of the collection.

HRESULT get__NewEnum(
  IUnknown* ppEnum
);

Parameters

ppEnum
Address of an interface pointer that on return points to the IUnknown interface of an enumerator object that implements an IEnumVARIANT interface for the collection. An interface pointer to the IEnumVARIANT interface of the enumerator object can be retrieved by calling QueryInterface on the IUnknown interface returned.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The _NewEnum property gets an enumerator object for the collection. An enumerator object provides serial access to the elements of the collection.

Property _NewEnum As IUnknown

Property Value

Reference to an enumerator object that provides serial access to the elements of the collection.

Remarks

This property is read-only.

In Visual Basic and VBScript, this property is used implicitly in For Each...In...Next constructs.

Example Code

This VBScript script displays all of the domain names in a specific domain name set. This example does not include error handling.

' Create the root object.
Dim root  ' The FPCLib.FPC root object
Set root = CreateObject("FPC.Root")

' Declare the other objects needed and a string.
Dim array            ' An FPCArray object
Dim domainnamesets   ' An FPCDomainNameSets collection
Dim domainnameset    ' An FPCDomainNameSet collection
Dim domainname       ' A string

' Get references to the array object
' and the domain name sets collection.
Set array = root.GetContainingArray()
Set domainnamesets = array.RuleElements.DomainNameSets

' If at least one domain name set is defined in the domain
' name sets collection, display the domain names in the first
' domain name set found.
On Error Resume Next
Set domainnameset = domainnamesets.Item(1)
If Err.Number = 0 Then
    For Each domainname In domainnameset
        WScript.Echo "Domain name: " & domainname
    Next
End If

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCDomainNameSet


IFPCDomainNameSet | FPCDomainNameSet Add(String) method [ISA Server 2004]

IFPCDomainNameSet::Add[C++]

FPCDomainNameSet.Add [Visual Basic]

[C++]

The Add method adds a domain name to the domain name set.

HRESULT Add(
  BSTR Name
);

Parameters

Name
[in] BSTR that specifies the domain name to be added.

Return Values

This method returns S_OK if the call is successful; otherwise, it returns an error code.

[Visual Basic]

The Add method adds a domain name to the domain name set.

Sub Add( _
  ByVal Name As String _
)

Parameters

Name
[in] String that specifies the domain name to be added.

Return Values

This method has no return values. If the call is unsuccessful, an error is raised that can be intercepted by using an error handler.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCDomainNameSet


IFPCDomainNameSet | FPCDomainNameSet Count(long) property [ISA Server 2004]

Count Property of IFPCDomainNameSet[C++]

FPCDomainNameSet.Count [Visual Basic]

[C++]

The Count property gets the number of domain names in the set.

HRESULT get_Count(
  long* plCount
);

Parameters

plCount
Pointer to a variable that on return receives a 32-bit integer specifying the number of domain names in the set.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The Count property gets the number of domain names in the set.

Property Count As Long

Property Value

A 32-bit integer that specifies the number of domain names in the set.

Remarks

This property is read-only.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCDomainNameSet


IFPCDomainNameSet | FPCDomainNameSet Description property [ISA Server 2004]

Description Property of IFPCDomainNameSet[C++]

FPCDomainNameSet.Description [Visual Basic]

[C++]

The Description property gets or sets the description of the domain name set.

HRESULT get_Description(
  BSTR* pbstrDescription
);

HRESULT put_Description(
  BSTR bstrDescription
);

Parameters

pbstrDescription
Pointer to a BSTR that is set on return to a string value specifying the description of the domain name set.
bstrDescription
BSTR that specifies the description of the domain name set.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write.

[Visual Basic]

The Description property gets or sets the description of the domain name set.

Property Description As String

Property Value

String that specifies the description of the domain name set.

Remarks

This property is read/write.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCDomainNameSet


IFPCDomainNameSet | FPCDomainNameSet Item(Variant,BSTR) method [ISA Server 2004]

IFPCDomainNameSet::Item[C++]

FPCDomainNameSet.Item [Visual Basic]

[C++]

The Item method retrieves the requested domain name from the domain name set.

HRESULT Item(
  VARIANT vIndex,
  BSTR* pbstrItem
);

Parameters

vIndex
[in] Required. Name or one-based index of the domain name to retrieve.
pbstrItem
[out] Pointer to a BSTR that is set on return to a string value specifying the domain name requested.

Return Values

This method can return one of the following:

  • S_OK, indicating that the operation succeeded.
  • An error code, indicating that the operation failed.

[Visual Basic]

The Item method retrieves the requested domain name from the domain name set.

Function Item( _
  ByVal vIndex As Variant _
) As String

Parameters

vIndex
[in] Required. Name or one-based index of the domain name to retrieve.

Return Values

This method returns a string that specifies the domain name if successful. Otherwise, an error is raised that can be intercepted by using an error handler.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCDomainNameSet


IFPCDomainNameSet | FPCDomainNameSet Name(BSTR,BSTR) property [ISA Server 2004]

Name Property of IFPCDomainNameSet[C++]

FPCDomainNameSet.Name [Visual Basic]

[C++]

The Name property gets or sets the name of the domain name set.

HRESULT get_Name(
  BSTR* pbstrName
);

HRESULT put_Name(
  BSTR bstrName
);

Parameters

pbstrName
Pointer to a BSTR that is set on return to a string value specifying the name of the domain name set.
bstrName
BSTR that specifies the name of the domain name set.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write.

[Visual Basic]

The Name property gets or sets the name of the domain name set.

Property Name As String

Property Value

String that specifies the name of the domain name set.

Remarks

This property is read/write.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCDomainNameSet


IFPCDomainNameSet | FPCDomainNameSet Predefined property [ISA Server 2004]

Predefined Property of IFPCDomainNameSet[C++]

FPCDomainNameSet.Predefined [Visual Basic]

[C++]

The Predefined property gets a Boolean value that indicates whether the domain name set is a predefined domain name set that was installed with ISA Server and cannot be deleted.

HRESULT get_Predefined(
  VARIANT_BOOL* pfPredefined
);

Parameters

pfPredefined
Pointer to a Boolean variable that is set on return to VARIANT_TRUE if the domain name set is predefined, or to VARIANT_FALSE if the domain name set is not predefined.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The Predefined property gets a Boolean value that indicates whether the domain name set is a predefined domain name set that was installed with ISA Server and cannot be deleted.

Property Predefined As Boolean

Property Value

Boolean value that indicates whether the domain name set is predefined.

Remarks

This property is read-only.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCDomainNameSet


IFPCDomainNameSet | FPCDomainNameSet Remove(Variant) method [ISA Server 2004]

IFPCDomainNameSet::Remove[C++]

FPCDomainNameSet.Remove [Visual Basic]

[C++]

The Remove method removes the specified domain name from the set.

HRESULT Remove(
  VARIANT Index
);

Parameters

Index
Required. Name or one-based index of the domain name to remove.

Return Values

This method returns S_OK if the call is successful; otherwise, it returns an error code.

[Visual Basic]

The Remove method removes the specified domain name from the set.

Sub Remove( _
  ByVal Index As Variant _
)

Parameters

Index
Required. Name or one-based index of the domain name to remove.

Return Values

This method has no return values. If the call is unsuccessful, an error is raised that can be intercepted by using an error handler.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCDomainNameSet


FPCDomainNameSets collection [ISA Server 2004]

FPCDomainNameSets Collection

The FPCDomainNameSets collection holds a set of FPCDomainNameSet objects. The rules of an ISA Server computer can refer to domain name sets.

This collection is typically accessed through the DomainNameSets property of an FPCRuleElements object.

Click here to see the ISA Server object hierarchy.

Inheritance

This collection inherits from the FPCPersist object, which contains methods and properties related to the persistent storage of an object's data. They include methods for exporting the object's data to and importing it from an XML document.

Methods

The FPCDomainNameSets collection defines the following methods.

Method | Description
Add | Creates a new FPCDomainNameSet object in the collection and returns a reference to it.
Item | Retrieves the requested FPCDomainNameSet object from the collection.
Remove | Removes the specified FPCDomainNameSet object from the collection.

Properties

The FPCDomainNameSets collection has the following properties.

Property | Description
_NewEnum | Gets an enumerator object for the collection.
Count | Gets the number of FPCDomainNameSet objects in the collection.

Methods Inherited from FPCPersist

Name | Description
CancelWaitForChanges | Cancels the registration established by the WaitForChanges method (for use in C and C++ programming only).
CanImport | Returns a Boolean value that indicates whether the properties of the collection and its elements can be imported from the specified XML document.
Export | Writes the stored values of all the properties of the collection and its elements to the specified XML document.
ExportToFile | Writes the stored values of all the properties of the collection and its elements to the specified XML file.
GetServiceRestartMask | Retrieves a 32-bit bitmask of the FpcServices enumerated type that specifies which services need to be restarted for currently unsaved changes to take effect.
Import | Copies the values of all the properties of the collection and its elements from the specified XML document to persistent storage.
ImportFromFile | Copies the values of all the properties of the collection and its elements from the specified XML file to persistent storage.
LoadDocProperties | Provides the XML document's properties so that you can know what information can be imported from the document.
Refresh | Reads the values of all the properties of the collection and its elements from persistent storage, overwriting any changes that have not been saved.
Save | Writes the current values of all the properties of the collection and its elements to persistent storage.
WaitForChanges | Registers to wait for an event indicating that the contents of the object have changed (for use in C and C++ programming only).

Properties Inherited from FPCPersist

Name | Description
PersistentName | Gets the persistent name of the collection. The persistent name of an object is a name that is unique for the object at the respective level of the COM object hierarchy.
VendorParametersSets | Gets an FPCVendorParametersSets collection that can hold sets of custom data for extending the collection.

Remarks

This collection implements the IFPCDomainNameSets interface.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

COM Objects


IFPCDomainNameSets | FPCDomainNameSets _NewEnum property [ISA Server 2004]

_NewEnum Property of IFPCDomainNameSets[C++]

FPCDomainNameSets._NewEnum [Visual Basic]

[C++]

The _NewEnum property gets an enumerator object for the collection. An enumerator object provides serial access to the elements of the collection.

HRESULT get__NewEnum(
  IUnknown* ppEnum
);

Parameters

ppEnum
Address of an interface pointer that on return points to the IUnknown interface of an enumerator object that implements an IEnumVARIANT interface for the collection. An interface pointer to the IEnumVARIANT interface of the enumerator object can be retrieved by calling QueryInterface on the IUnknown interface returned.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The _NewEnum property gets an enumerator object for the collection. An enumerator object provides serial access to the elements of the collection.

Property _NewEnum As IUnknown

Property Value

Reference to an enumerator object that provides serial access to the elements of the collection.

Remarks

This property is read-only.

In Visual Basic and VBScript, this property is used implicitly in For Each...In...Next constructs.

Example Code

This VBScript script displays the names of all the domain name sets defined for an FPCArray object. It does not include error handling.

' Create the root object.
Dim root  ' The FPCLib.FPC root object
Set root = CreateObject("FPC.Root")

' Declare the other objects needed.
Dim array            ' An FPCArray object
Dim domainnamesets   ' An FPCDomainNameSets collection
Dim domainnameset    ' An FPCDomainNameSet object

' Get references to the array object
' and the domain name sets collection.
Set array = root.GetContainingArray()
Set domainnamesets = array.RuleElements.DomainNameSets

' Display the names of the domain name sets
' defined for the array object.
For Each domainnameset In domainnamesets
    WScript.Echo "Domain name set name: " & domainnameset.Name
Next

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCDomainNameSets


IFPCDomainNameSets | FPCDomainNameSets Add method [ISA Server 2004]

IFPCDomainNameSets::Add[C++]

FPCDomainNameSets.Add [Visual Basic]

[C++]

The Add method creates a new FPCDomainNameSet object in the collection and returns a reference to it.

HRESULT Add(
  BSTR Name,
  IFPCDomainNameSet** ppNewDomainNameSet
);

Parameters

Name
[in] Required. BSTR that specifies the name of the new domain name set.
ppNewDomainNameSet
[out] Address of an interface pointer that on return points to the new IFPCDomainNameSet interface created.

Return Values

This method can return one of the following:

  • S_OK, indicating that the operation succeeded.
  • An error code, indicating that the operation failed. In this case, the [out] parameter returned is a null object.

[Visual Basic]

The Add method creates a new FPCDomainNameSet object in the collection and returns a reference to it.

Function Add( _
  ByVal Name As String _
) As FPCDomainNameSet

Parameters

Name
[in] Required. String that specifies the name of the new domain name set.

Return Values

This method returns a reference to the FPCDomainNameSet object if successful. Otherwise, an error is raised that can be intercepted by using an error handler.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCDomainNameSets


IFPCDomainNameSets | FPCDomainNameSets Count(long) property [ISA Server 2004]

Count Property of IFPCDomainNameSets[C++]

FPCDomainNameSets.Count [Visual Basic]

[C++]

The Count property gets the number of FPCDomainNameSet objects in the collection.

HRESULT get_Count(
  long* plCount
);

Parameters

plCount
Pointer to a variable that on return receives a 32-bit integer specifying the number of FPCDomainNameSet objects in the collection.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The Count property gets the number of FPCDomainNameSet objects in the collection.

Property Count As Long

Property Value

A 32-bit integer that specifies the number of FPCDomainNameSet objects in the collection.

Remarks

This property is read-only.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCDomainNameSets


IFPCDomainNameSets | FPCDomainNameSets Item method [ISA Server 2004]

IFPCDomainNameSets::Item[C++]

FPCDomainNameSets.Item [Visual Basic]

[C++]

The Item method retrieves the requested IFPCDomainNameSet interface from the collection.

HRESULT Item(
  VARIANT Index,
  IFPCDomainNameSet** ppItem
);

Parameters

Index
[in] Required. Name or one-based index of the object to retrieve.
ppItem
[out] Address of an interface pointer that on return points to the IFPCDomainNameSet interface requested.

Return Values

This method can return one of the following:

  • S_OK, indicating that the operation succeeded.
  • An error code, indicating that the operation failed. In this case, the [out] parameter returned is a null object.

[Visual Basic]

The Item method retrieves the requested FPCDomainNameSet object from the collection.

Function Item( _
  ByVal Index As Variant _
) As FPCDomainNameSet

Parameters

Index
[in] Required. Name or one-based index of the object to retrieve.

Return Values

This method returns a reference to the FPCDomainNameSet object requested if successful. Otherwise, an error is raised that can be intercepted by using an error handler.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCDomainNameSets


IFPCDomainNameSets | FPCDomainNameSets Remove(Variant) method [ISA Server 2004]

IFPCDomainNameSets::Remove[C++]

FPCDomainNameSets.Remove [Visual Basic]

[C++]

The Remove method removes the specified FPCDomainNameSet object from the collection.

HRESULT Remove(
  VARIANT Index
);

Parameters

Index
Required. Name or one-based index of the FPCDomainNameSet object to remove.

Return Values

This method returns S_OK if the call is successful; otherwise, it returns an error code.

[Visual Basic]

The Remove method removes the specified FPCDomainNameSet object from the collection.

Sub Remove( _
  ByVal Index As Variant _
)

Parameters

Index
Required. Name or one-based index of the FPCDomainNameSet object to remove.

Return Values

This method has no return values. If the call is unsuccessful, an error is raised that can be intercepted by using an error handler.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCDomainNameSets


FPCEventDefinition object [ISA Server 2004]

FPCEventDefinition

The FPCEventDefinition object is used to define a single event. Events describe conditions that require the attention of an administrator. Predetermined actions can be triggered in response to particular events by using the FPCAlert object. Each event is uniquely identified by its EventGUID property.

This object is typically an element of an FPCEventDefinitions collection.

Click here to see the ISA Server object hierarchy.

Inheritance

This object inherits from the FPCPersist object, which contains methods and properties related to the persistent storage of an object's data. They include methods for exporting an object's data to and importing it from an XML document.

Methods

The FPCEventDefinition object defines the following method.

Method | Description
Signal | Signals the event on the local server.

Properties

The FPCEventDefinition object has the following properties.

Property | Description
AdditionalKeys | Gets the table of additional keys and subevents defined for the event.
AdditionalKeysCount | Gets the number of additional keys for the event.
Description | Gets or sets the description of the event.
EventGUID | Gets the globally unique identifier (GUID) of the event.
EventsBeforeRaise | Gets or sets the default number of times that the event must be signaled before an alert that is issued for the event can be issued.
MinEventsPerSecond | Gets or sets the default number of times in a second that the event must be signaled before an alert that is issued for the event can be issued.
MinutesBeforeReRaise | Gets or sets the default time, in minutes, that must elapse before an alert that is issued for the event can be issued again.
Name | Gets or sets the name of the event.
Predefined | Gets a Boolean value that indicates whether the event is a predefined event that was installed with ISA Server and cannot be deleted.

Methods Inherited from FPCPersist

Name | Description
CancelWaitForChanges | Cancels the registration established by the WaitForChanges method (for use in C and C++ programming only).
CanImport | Returns a Boolean value that indicates whether the object's properties can be imported from the specified XML document.
Export | Writes the stored values of all of the object's properties to the specified XML document.
ExportToFile | Writes the stored values of all of the object's properties to the specified XML file.
GetServiceRestartMask | Retrieves a 32-bit bitmask of the FpcServices enumerated type that specifies which services need to be restarted for currently unsaved changes to take effect.
Import | Copies the values of all of the object's properties from the specified XML document to persistent storage.
ImportFromFile | Copies the values of all of the object's properties from the specified XML file to persistent storage.
LoadDocProperties | Provides the XML document's properties so that you can know what information can be imported from the document.
Refresh | Reads the values of all of the object's properties from persistent storage, overwriting any changes that have not been saved.
Save | Writes the current values of all of the object's properties to persistent storage.
WaitForChanges | Registers to wait for an event indicating that the contents of the object have changed (for use in C and C++ programming only).

Properties Inherited from FPCPersist

Name | Description
PersistentName | Gets the persistent name of the object. The persistent name of an object is a name that is unique for the object at the respective level of the COM object hierarchy.
VendorParametersSets | Gets an FPCVendorParametersSets object that can hold sets of custom data for extending the object.

Remarks

This object implements the IFPCEventDefinition interface.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

COM Objects


IFPCEventDefinition.AdditionalKeys(VARIANT) property [ISA Server 2004]

AdditionalKeys Property of IFPCEventDefinition[C++]

FPCEventDefinition.AdditionalKeys [Visual Basic]

[C++]

The AdditionalKeys property gets the table of additional keys and subevents defined for the event.

HRESULT get_AdditionalKeys(
  VARIANT* pvKeys
);

Parameters

pvKeys
Pointer to a VARIANT that is set on return to a VARIANT containing an array of strings that specify the subevents defined for the event. The index of each string is a 32-bit integer that specifies the additional key for the corresponding subevent. The additional key with an index equal to 0 is reserved to indicate all of the subevents defined for the event.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

Additional keys serve as a means to subdivide event objects into related subevents. For example, a service-started event can be subdivided into subevents for different ISA Server services. This provides for the issuance of either different alerts that are specific to subevents or a single alert that is specific to all subevents.

Note The additional key with an index equal to 0 is reserved to indicate all of the subevents defined for the event.

[Visual Basic]

The AdditionalKeys property gets the table of additional keys and subevents defined for the event.

Property AdditionalKeys As Variant

Property Value

Variant containing an array of strings that specify the subevents defined for the event. The index of each string is the additional key for the corresponding subevent. The additional key with an index equal to 0 is reserved to indicate all of the subevents defined for the event.

Remarks

This property is read-only.

Additional keys serve as a means to subdivide event objects into related subevents. For example, a service-started event can be subdivided into subevents for different ISA Server services. This provides for the issuance of either different alerts that are specific to subevents or a single alert that is specific to all subevents.

Note The additional key with an index equal to 0 is reserved to indicate all of the subevents defined for the event.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCEventDefinition


IFPCEventDefinition.AdditionalKeysCount(long) property [ISA Server 2004]

AdditionalKeysCount Property of IFPCEventDefinition[C++]

FPCEventDefinition.AdditionalKeysCount [Visual Basic]

[C++]

The AdditionalKeysCount property gets the number of additional keys for the event.

HRESULT get_AdditionalKeysCount(
  long* plCount
);

Parameters

plCount
Pointer to a variable that on return receives a 32-bit integer specifying the number of additional keys for the event.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

The number of additional keys is one greater than the number of subevents defined for the event. The additional key with an index equal to 0 is reserved to indicate all of the subevents defined for the event.

[Visual Basic]

The AdditionalKeysCount property gets the number of additional keys for the event.

Property AdditionalKeysCount As Long

Property Value

A 32-bit integer that specifies the number of additional keys for the event.

Remarks

This property is read-only.

The number of additional keys is one greater than the number of subevents defined for the event. The additional key with an index equal to 0 is reserved to indicate all of the subevents defined for the event.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCEventDefinition


IFPCEventDefinition | FPCEventDefinition Description property [ISA Server 2004]

Description Property of IFPCEventDefinition[C++]

FPCEventDefinition.Description [Visual Basic]

[C++]

The Description property gets or sets the description of the event.

HRESULT get_Description(
  BSTR* pbstrDescription
);

HRESULT put_Description(
  BSTR bstrDescription
);

Parameters

pbstrDescription
Pointer to a BSTR that is set on return to a string value specifying the description of the event.
bstrDescription
BSTR that specifies the description of the event.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write.

[Visual Basic]

The Description property gets or sets the description of the event.

Property Description As String

Property Value

String that specifies the description of the event.

Remarks

This property is read/write.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCEventDefinition


IFPCEventDefinition | FPCEventDefinition EventGUID property [ISA Server 2004]

EventGUID Property of IFPCEventDefinition[C++]

FPCEventDefinition.EventGUID [Visual Basic]

[C++]

The EventGUID property gets the string-formatted globally unique identifier (GUID) of the event.

HRESULT get_EventGUID(
  BSTR* pbstrGUID
);

Parameters

pbstrGUID
Pointer to a BSTR that is set on return to the string-formatted GUID of the event.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

The GUID retrieved is formatted as a string in the form {12345678-1234-1234-1234-123456789ABC}. Note the presence of the braces normally used with GUIDs.

[Visual Basic]

The EventGUID property gets the string-formatted globally unique identifier (GUID) of the event.

Property EventGUID As String

Property Value

String that specifies the string-formatted GUID of the event.

Remarks

This property is read-only.

The GUID retrieved is formatted as a string in the form {12345678-1234-1234-1234-123456789ABC}. Note the presence of the braces normally used with GUIDs.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCEventDefinition


IFPCEventDefinition.EventsBeforeRaise(long,long) property [ISA Server 2004]

EventsBeforeRaise Property of IFPCEventDefinition[C++]

FPCEventDefinition.EventsBeforeRaise [Visual Basic]

[C++]

The EventsBeforeRaise property gets or sets the default number of times that the event must be signaled before an alert that is issued for the event can be issued.

HRESULT get_EventsBeforeRaise(
  long* plThreshold
);

HRESULT put_EventsBeforeRaise(
  long lThreshold
);

Parameters

plThreshold
Pointer to a variable that on return receives a 32-bit integer specifying the default threshold.
lThreshold
A 32-bit integer that specifies the default threshold.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write.

This property only establishes a default value for an event. When you create an alert, the alert can use the default value, or you can overwrite it with values specific to the alert by modifying the corresponding property in the FPCAlert object.

The MinutesBeforeReRaise, EventsBeforeRaise, and MinEventsPerSecond properties of the FPCAlert object set the three thresholds that the Microsoft Firewall service uses to issue alerts. For each alert, the Microsoft Firewall service stores the time when the event last occurred, a count of how many times the event has occurred per second, and a count of the total number of times that the event has occurred. An alert is issued and the alert invokes the actions defined for it only when the three threshold requirements for issuing the alert are met simultaneously.

[Visual Basic]

The EventsBeforeRaise property gets or sets the default number of times that the event must be signaled before an alert that is issued for the event can be issued.

Property EventsBeforeRaise As Long

Property Value

A 32-bit integer that specifies the default threshold.

Remarks

This property is read/write.

This property only establishes a default value for an event. When you create an alert, the alert can use the default value, or you can overwrite it with values specific to the alert by modifying the corresponding property in the FPCAlert object.

The MinutesBeforeReRaise, EventsBeforeRaise, and MinEventsPerSecond properties of the FPCAlert object set the three thresholds that the Microsoft Firewall service uses to issue alerts. For each alert, the Microsoft Firewall service stores the time when the event last occurred, a count of how many times the event has occurred per second, and a count of the total number of times that the event has occurred. An alert is issued and the alert invokes the actions defined for it only when the three threshold requirements for issuing the alert are met simultaneously.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCEventDefinition


IFPCEventDefinition.MinEventsPerSecond(long,long) property [ISA Server 2004]

MinEventsPerSecond Property of IFPCEventDefinition[C++]

FPCEventDefinition.MinEventsPerSecond [Visual Basic]

[C++]

The MinEventsPerSecond property gets or sets the default number of times in a second that the event must be signaled before an alert that is issued for the event can be issued.

HRESULT get_MinEventsPerSecond(
  long* plThreshold
);

HRESULT put_MinEventsPerSecond(
  long lThreshold
);

Parameters

plThreshold
Pointer to a variable that receives a 32-bit integer specifying the default event frequency threshold.
lThreshold
A 32-bit integer that specifies the default event frequency threshold.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read/write.

This property only establishes a default value for an event. When you create an alert, the alert can use the default value, or you can overwrite it with values specific to the alert by modifying the corresponding property in the FPCAlert object.

The MinutesBeforeReRaise, EventsBeforeRaise, and MinEventsPerSecond properties of the FPCAlert object set the three thresholds that the Microsoft Firewall service uses to issue alerts. For each alert, the Microsoft Firewall service stores the time when the event last occurred, a count of how many times the event has occurred per second, and a count of the total number of times that the event has occurred. An alert is issued and the alert invokes the actions defined for it only when the three threshold requirements for issuing the alert are met simultaneously.

[Visual Basic]

The MinEventsPerSecond property gets or sets the default number of times in a second that the event must be signaled before an alert that is issued for the event can be issued.

Property MinEventsPerSecond As Long

Property Value

A 32-bit integer that specifies the event frequency threshold.

Remarks

This property is read/write.

This property only establishes a default value for an event. When you create an alert, the alert can use the default value, or you can overwrite it with values specific to the alert by modifying the corresponding property in the FPCAlert object.

The MinutesBeforeReRaise, EventsBeforeRaise, and MinEventsPerSecond properties of the FPCAlert object set the three thresholds that the Microsoft Firewall service uses to issue alerts. For each alert, the Microsoft Firewall service stores the time when the event last occurred, a count of how many times the event has occurred per second, and a count of the total number of times that the event has occurred. An alert is issued and the alert invokes the actions defined for it only when the three threshold requirements for issuing the alert are met simultaneously.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCEventDefinition


IFPCEventDefinition.MinutesBeforeReRaise(long,long) property [ISA Server 2004]

MinutesBeforeReRaise Property of IFPCEventDefinition[C++]

FPCEventDefinition.MinutesBeforeReRaise [Visual Basic]

[C++]

The MinutesBeforeReRaise property gets or sets the default time, in minutes, that must elapse before an alert that is issued for the event can be issued again.

HRESULT get_MinutesBeforeReRaise(
  long* plInterval
);

HRESULT put_MinutesBeforeReRaise(
  long lInterval
);

Parameters

plInterval
Pointer to a variable that receives a 32-bit integer specifying the default threshold time interval.
lInterval
A 32-bit integer that specifies the default threshold time interval.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write.

This property only establishes a default value for an event. When you create an alert, the alert can use the default value, or you can overwrite it with values specific to the alert by modifying the corresponding property in the FPCAlert object.

The MinutesBeforeReRaise, EventsBeforeRaise, and MinEventsPerSecond properties of the FPCAlert object set the three thresholds that the Microsoft Firewall service uses to issue alerts. For each alert, the Microsoft Firewall service stores the time when the event last occurred, a count of how many times the event has occurred per second, and a count of the total number of times that the event has occurred. An alert is issued and the alert invokes the actions defined for it only when the three threshold requirements for issuing the alert are met simultaneously.

[Visual Basic]

The MinutesBeforeReRaise property gets or sets the default time, in minutes, that must elapse before an alert that is issued for the event can be issued again.

Property MinutesBeforeReRaise As Long

Property Value

A 32-bit integer that specifies the default threshold time interval.

Remarks

This property is read/write.

This property only establishes a default value for an event. When you create an alert, the alert can use the default value, or you can overwrite it with values specific to the alert by modifying the corresponding property in the FPCAlert object.

The MinutesBeforeReRaise, EventsBeforeRaise, and MinEventsPerSecond properties of the FPCAlert object set the three thresholds that the Microsoft Firewall service uses to issue alerts. For each alert, the Microsoft Firewall service stores the time when the event last occurred, a count of how many times the event has occurred per second, and a count of the total number of times that the event has occurred. An alert is issued and the alert invokes the actions defined for it only when the three threshold requirements for issuing the alert are met simultaneously.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCEventDefinition


IFPCEventDefinition | FPCEventDefinition Name property [ISA Server 2004]

Name Property of IFPCEventDefinition[C++]

FPCEventDefinition.Name [Visual Basic]

[C++]

The Name property gets or sets the name of the event.

HRESULT get_Name(
  BSTR* pbstrName
);

HRESULT put_Name(
  BSTR bstrName
);

Parameters

pbstrName
Pointer to a BSTR that is set on return to a string value specifying the name of the event.
bstrName
BSTR that specifies the name of the event.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write.

Note The name of each event must be unique.

[Visual Basic]

The Name property gets or sets the name of the event.

Property Name As String

Property Value

String that specifies the name of the event.

Remarks

This property is read/write.

Note The name of each event must be unique.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCEventDefinition


IFPCEventDefinition | FPCEventDefinition Predefined property [ISA Server 2004]

Predefined Property of IFPCEventDefinition[C++]

FPCEventDefinition.Predefined [Visual Basic]

[C++]

The Predefined property gets a Boolean value that indicates whether the event is a predefined event that was installed with ISA Server and cannot be deleted.

HRESULT get_Predefined(
  VARIANT_BOOL* pfPredefined
);

Parameters

pfPredefined
Pointer to a Boolean variable that is set on return to VARIANT_TRUE if the event is predefined, or to VARIANT_FALSE if the event is user-defined.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The Predefined property gets a Boolean value that indicates whether the event is a predefined event that was installed with ISA Server and cannot be deleted.

Property Predefined As Boolean

Property Value

Boolean value that indicates whether the event is predefined.

Remarks

This property is read-only.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCEventDefinition


IFPCEventDefinition | FPCEventDefinition Signal method [ISA Server 2004]

IFPCEventDefinition::Signal[C++]

FPCEventDefinition.Signal [Visual Basic]

[C++]

The Signal method signals the event on the local server. If an alert exists for the event and the conditions for issuing the alert are met, actions may be taken to notify the administrator of the event. Third-party filters can also use this method to signal an event.

HRESULT Signal(
  long SignalCount,
  long AdditionalKey,
  BSTR ShortDesc,
  BSTR LongDesc,
  long EventID,
  BSTR EventSource,
  VARIANT EventStrings,
  VARIANT EventData,
  short EventCategory,
  short EventType
);

Parameters

SignalCount
[in, optional] The number of instances of the event to be signaled. The default value is 1.
AdditionalKey
[in, optional] An additional key (index) from the table of subevents for the event. This parameter cannot be set to 0. The default value is –1.
ShortDesc
[in, optional] BSTR that provides a brief description of the run-time event. This description is used as the subject line of an e-mail message sent in a send-mail action. The default value is an empty string.
LongDesc
[in, optional] BSTR that provides a detailed description of the run-time event. This description is used as the body of an e-mail message sent in a send-mail action. The default value is an empty string.
EventID
[in, optional] A 32-bit integer that specifies the identifier (ID) of the event to be reported to the system event log. The default value is 0.
EventSource
[in, optional] BSTR that specifies the name of the software or application that should log the event. The default value is an empty string.
EventStrings
[in, optional] Variant that contains insertion strings for the event.
EventData
[in, optional] Variant that contains raw data for the event.
EventCategory
[in, optional] A 16-bit integer that specifies the category of the event. The default value is 0.
EventType
[in, optional] A 16-bit integer that specifies the type of the event. The default value is 0.

Return Values

This method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

The EventSource parameter is similar to the lpSourceName parameter of the Windows RegisterEventSource function. Other parameters for this function are similar to parameters in the Windows ReportEvent function, as shown in the following table. For more information, see the relevant function in MSDN.

Signal parameter | ReportEvent parameter
EventID | dwEventID
EventStrings | lpStrings
EventData | lpRawData
EventCategory | wCategory
EventType | wType

Network data (including URLs and other data that comes from untrusted sources) should not be included in the EventStrings parameter for logging, because this can create a security risk. Such data, however, can be included in the RawData parameter for logging.

[Visual Basic]

The Signal method signals the event on the local server. If an alert exists for the event and the conditions for issuing the alert are met, actions may be taken to notify the administrator of the event. Third-party filters can also use this method to signal an event.

Sub Signal( _
  [ ByVal SignalCount As Long ], _
  [ ByVal AdditionalKey As Long ], _
  [ ByVal ShortDesc As String ], _
  [ ByVal LongDesc As String ], _
  [ ByVal EventID As Long ], _
  [ ByVal EventSource As String ], _
  [ ByVal EventStrings As Variant ], _
  [ ByVal EventData As Variant ], _
  [ ByVal EventCategory As Integer ], _
  [ ByVal EventType As Integer ] _
)

Parameters

SignalCount
[in, optional] The number of instances of the event to be signaled. The default value is 1.
AdditionalKey
[in, optional] An additional key (index) from the table of subevents for the event. This parameter cannot be set to 0. The default value is –1.
ShortDesc
[in, optional] String value that provides a brief description of the run-time event. This description is used as the subject line of an e-mail message sent in a send-mail action. The default value is an empty string.
LongDesc
[in, optional] String value that provides a detailed description of the run-time event. This description is used as the body of an e-mail message sent in a send-mail action. The default value is an empty string.
EventID
[in, optional] A 32-bit integer that specifies the identifier (ID) of the event to be reported to the system event log. The default value is 0.
EventSource
[in, optional] String value that specifies the name of the software or application that should log the event. The default value is an empty string.
EventStrings
[in, optional] Variant that contains insertion strings for the event.
EventData
[in, optional] Variant that contains raw data for the event.
EventCategory
[in, optional] A 16-bit integer that specifies the category of the event. The default value is 0.
EventType
[in, optional] A 16-bit integer that specifies the type of the event. The default value is 0.

Return Values

This method has no return values. If the call is unsuccessful, an error is raised that can be intercepted by using an error handler.

Remarks

The EventSource parameter is similar to the lpSourceName parameter of the Windows RegisterEventSource function. Other parameters for this function are similar to parameters in the Windows ReportEvent function, as shown in the following table. For more information, see the relevant function in MSDN.

Signal parameter | ReportEvent parameter
EventID | dwEventID
EventStrings | lpStrings
EventData | lpRawData
EventCategory | wCategory
EventType | wType

Network data (including URLs and other data that comes from untrusted sources) should not be included in the EventStrings parameter for logging, because this can create a security risk. Such data, however, can be included in the RawData parameter for logging.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCEventDefinition


FPCEventDefinitions collection [ISA Server 2004]

FPCEventDefinitions Collection

The FPCEventDefinitions collection holds a set of FPCEventDefinition objects. Events describe conditions that may require the attention of an administrator, and predetermined actions can be taken in response to particular events by using an FPCAlert object.

This collection is typically accessed through the EventDefinitions property of an FPCRuleElements object.

Click here to see the ISA Server object hierarchy.

Inheritance

This collection inherits from the FPCPersist object, which contains methods and properties related to the persistent storage of an object's data. They include methods for exporting the object's data to and importing it from an XML document.

Methods

The FPCEventDefinitions collection defines the following methods.

Method | Description
Add | Creates a new FPCEventDefinition object in the collection and returns a reference to it.
Item | Retrieves the requested FPCEventDefinition object from the collection.
ItemByGuid | Retrieves the requested FPCEventDefinition object from the collection according to the globally unique identifier (GUID) of its event.
Remove | Removes the specified FPCEventDefinition object from the collection.

Properties

The FPCEventDefinitions collection has the following properties.

Property | Description
_NewEnum | Gets an enumerator object for the collection.
Count | Gets the number of FPCEventDefinition objects in the collection.

Methods Inherited from FPCPersist

Name | Description
CancelWaitForChanges | Cancels the registration established by the WaitForChanges method (for use in C and C++ programming only).
CanImport | Returns a Boolean value that indicates whether the properties of the collection and its elements can be imported from the specified XML document.
Export | Writes the stored values of all the properties of the collection and its elements to the specified XML document.
ExportToFile | Writes the stored values of all the properties of the collection and its elements to the specified XML file.
GetServiceRestartMask | Retrieves a 32-bit bitmask of the FpcServices enumerated type that specifies which services need to be restarted for currently unsaved changes to take effect.
Import | Copies the values of all the properties of the collection and its elements from the specified XML document to persistent storage.
ImportFromFile | Copies the values of all the properties of the collection and its elements from the specified XML file to persistent storage.
LoadDocProperties | Provides the XML document's properties so that you can know what information can be imported from the document.
Refresh | Reads the values of all the properties of the collection and its elements from persistent storage, overwriting any changes that have not been saved.
Save | Writes the current values of all the properties of the collection and its elements to persistent storage.
WaitForChanges | Registers to wait for an event indicating that the contents of the object have changed (for use in C and C++ programming only).

Properties Inherited from FPCPersist

Name | Description
PersistentName | Gets the persistent name of the collection. The persistent name of an object is a name that is unique for the object at the respective level of the COM object hierarchy.
VendorParametersSets | Gets an FPCVendorParametersSets collection that can hold sets of custom data for extending the collection.

Remarks

This collection implements the IFPCEventDefinitions interface.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

COM Objects


IFPCEventDefinitions | FPCEventDefinitions _NewEnum property [ISA Server 2004]

_NewEnum Property of IFPCEventDefinitions[C++]

FPCEventDefinitions._NewEnum [Visual Basic]

[C++]

The _NewEnum property gets an enumerator object for the collection. An enumerator object provides serial access to the elements of the collection.

HRESULT get__NewEnum(
  IUnknown* ppEnum
);

Parameters

ppEnum
Address of an interface pointer that on return points to the IUnknown interface of an enumerator object that implements an IEnumVARIANT interface for the collection. An interface pointer to the IEnumVARIANT interface of the enumerator object can be retrieved by calling QueryInterface on the IUnknown interface returned.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The _NewEnum property gets an enumerator object for the collection. An enumerator object provides serial access to the elements of the collection.

Property _NewEnum As IUnknown

Property Value

Reference to an enumerator object that provides serial access to the elements of the collection.

Remarks

This property is read-only.

In Visual Basic and VBScript, this property is used implicitly in For Each...In...Next constructs.

Example Code

This VBScript script displays the names of all the event definitions defined for an FPCArray object. It does not include error handling.

' Create the root object.
Dim root  ' The FPCLib.FPC root object
Set root = CreateObject("FPC.Root")

' Declare the other objects needed.
Dim array             ' An FPCArray object
Dim eventdefinitions  ' An FPCEventDefinitions collection
Dim eventdefinition   ' An FPCEventDefinition object

' Get references to the array object
' and the event definitions collection.
Set array = root.GetContainingArray()
Set eventdefinitions = array.RuleElements.EventDefinitions

' Display the names of the event definitions
' defined for the array object.
For Each eventdefinition In eventdefinitions
    WScript.Echo "Event definition name: " & eventdefinition.Name
Next

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCEventDefinitions


IFPCEventDefinitions | FPCEventDefinitions Add method [ISA Server 2004]

IFPCEventDefinitions::Add[C++]

FPCEventDefinitions.Add [Visual Basic]

[C++]

The Add method creates a new FPCEventDefinition object in the collection and returns a reference to it. A new event definition can be created only through the ISA Server administration COM objects, not in ISA Server Management.

HRESULT Add(
  BSTR Name,
  BSTR EventGUID,
  VARIANT* pAdditionalKeys,
  IFPCEventDefinition** ppNewEvent
);

Parameters

Name
[in] Required. BSTR that specifies the name of the new event. The name should be unique in the collection.
EventGUID
[in] Required. String-formatted globally unique identifier (GUID) of the new event.
pAdditionalKeys
[in, optional] Pointer to a VARIANT containing an array of strings that define subevents for the event. The index of each string is the additional key for the corresponding subevent. The additional key with an index equal to 0 is reserved to indicate all of the subevents defined for the event.
ppNewEvent
[out] Address of an interface pointer that on return points to the new IFPCEventDefinition interface created.

Return Values

This method can return one of the following:

  • S_OK, indicating that the operation succeeded.
  • An error code, indicating that the operation failed. In this case, the [out] parameter returned is a null object.

[Visual Basic]

The Add method creates a new FPCEventDefinition object in the collection and returns a reference to it. A new event definition can be created only through the ISA Server administration COM objects, not in ISA Server Management.

Function Add( _
  ByVal Name As String, _
  ByVal EventGUID As String, _
  [ ByRef AdditionalKeys As Variant ] _
) As FPCEventDefinition

Parameters

Name
[in] Required. String that specifies the name of the new event. The name should be unique in the collection.
EventGUID
[in] Required. String-formatted globally unique identifier (GUID) of the new event.
AdditionalKeys
[in, optional] Array of strings that define subevents for the event. The index of each string is the additional key for the corresponding subevent. The additional key with an index equal to 0 is reserved to indicate all of the subevents defined for the event.

Return Values

This method returns a reference to an FPCEventDefinition object if successful. Otherwise, an error is raised that can be intercepted by using an error handler.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCEventDefinitions


IFPCEventDefinitions | FPCEventDefinitions Count property [ISA Server 2004]

Count Property of IFPCEventDefinitions[C++]

FPCEventDefinitions.Count [Visual Basic]

[C++]

The Count property gets the number of FPCEventDefinition objects in the collection.

HRESULT get_Count(
  long* plCount
);

Parameters

plCount
Pointer to a variable that on return receives a 32-bit integer specifying the number of FPCEventDefinition objects in the collection.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The Count property gets the number of FPCEventDefinition objects in the collection.

Property Count As Long

Property Value

A 32-bit integer that specifies the number of FPCEventDefinition objects in the collection.

Remarks

This property is read-only.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCEventDefinitions


IFPCEventDefinitions | FPCEventDefinitions Item method [ISA Server 2004]

IFPCEventDefinitions::Item[C++]

FPCEventDefinitions.Item [Visual Basic]

[C++]

The Item method retrieves the requested IFPCEventDefinition interface from the collection.

HRESULT Item(
  VARIANT Index,
  IFPCEventDefinition** ppItem
);

Parameters

Index
[in] Required. Name or one-based index of the object to retrieve.
ppItem
[out] Address of an interface pointer that on return points to the IFPCEventDefinition interface requested.

Return Values

This method can return one of the following:

  • S_OK, indicating that the operation succeeded.
  • An error code, indicating that the operation failed. In this case, the [out] parameter returned is a null object.
[Visual Basic]

The Item method retrieves the requested FPCEventDefinition object from the collection.

Function Item( _
  ByVal Index As Variant _
) As FPCEventDefinition

Parameters

Index
[in] Required. Name or one-based index of the object to retrieve.

Return Values

This method returns a reference to the FPCEventDefinition object requested if successful. Otherwise, an error is raised that can be intercepted by using an error handler.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCEventDefinitions


IFPCEventDefinitions | FPCEventDefinitions ItemByGuid method [ISA Server 2004]

IFPCEventDefinitions::ItemByGuid[C++]

FPCEventDefinitions.ItemByGuid [Visual Basic]

[C++]

The ItemByGuid method retrieves the requested IFPCEventDefinition interface from the collection according to its globally unique identifier (GUID) of its event.

HRESULT ItemByGuid(
  BSTR EventGuid,
  IFPCEventDefinition** ppItem
);

Parameters

EventGuid
[in] Required. String value that specifies the globally unique identifier (GUID) of the event defined by the object to be retrieved.
ppItem
[out] Address of an interface pointer that on return points to the IFPCEventDefinition interface requested.

Return Values

This method can return one of the following:

  • S_OK, indicating that the operation succeeded.
  • An error code, indicating that the operation failed. In this case, the [out] parameter returned is a null object.
[Visual Basic]

The ItemByGuid method retrieves the requested FPCEventDefinition object from the collection according to the globally unique identifier (GUID) of its event.

Function ItemByGuid( _
  ByVal EventGuid As String _
) As FPCEventDefinition

Parameters

EventGuid
[in] Required. String value that specifies the globally unique identifier (GUID) of the event defined by the object to be retrieved.

Return Values

This method returns a reference to the FPCEventDefinition object requested if successful. Otherwise, an error is raised that can be intercepted by using an error handler.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCEventDefinitions


IFPCEventDefinitions | FPCEventDefinitions Remove method [ISA Server 2004]

IFPCEventDefinitions::Remove[C++]

FPCEventDefinitions.Remove [Visual Basic]

[C++]

The Remove method removes the specified FPCEventDefinition object from the collection.

HRESULT Remove(
  VARIANT Index
);

Parameters

Index
[in] Required. Name or one-based index of the FPCEventDefinition object to remove.

Return Values

This method returns S_OK if the call is successful; otherwise, it returns an error code.

[Visual Basic]

The Remove method removes the specified FPCEventDefinition object from the collection.

Sub Remove( _
  ByVal Index As Variant _
)

Parameters

Index
[in] Required. Name or one-based index of the FPCEventDefinition object to remove.

Return Values

This method has no return values. If the call is unsuccessful, an error is raised that can be intercepted by using an error handler.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCEventDefinitions


FPCExtensions object [ISA Server 2004]

FPCExtensions

The FPCExtensions object is used to administer all configuration settings of ISA Server extensions. ISA Server extensions include application filters and Web filters.

Application filters work with the Microsoft Firewall service to intercept and process data. Application filters can access the data stream or datagrams associated with a session within the Microsoft Firewall service. The filters are registered with the Firewall service and act in response to events detected by the service. An application filter can perform protocol-specific or system-specific tasks, such as authentication and virus checking.

Web filters are dynamic-link libraries (DLLs) that are loaded when the Firewall service is started, and stay in memory until the service shuts down. Once loaded, Web filters can be configured to receive a number of special filter-event notifications. These filter-event notifications occur with each HTTP request that the ISA Server Web proxy receives and with each response returned through the Web proxy by an external Web server.

This object is typically accessed through the Extensions property of an FPCArray object.

Click here to see the ISA Server object hierarchy.

Inheritance

This object inherits from the FPCPersist object, which contains methods and properties related to the persistent storage of an object's data. They include methods for exporting the object's data to and importing it from an XML document.

Methods

This object has no methods.

Properties

The FPCExtensions object has the following properties.

Property | Description
ApplicationFilters | Gets an FPCApplicationFilters collection that contains the application filters registered with the Microsoft Firewall service.
WebFilters | Gets an FPCWebFilters collection of Web filters that are registered to extend the ISA Server Web proxy.

Methods Inherited from FPCPersist

Name | Description
CancelWaitForChanges | Cancels the registration established by the WaitForChanges method (for use in C and C++ programming only).
CanImport | Returns a Boolean value that indicates whether the object's properties can be imported from the specified XML document.
Export | Recursively writes the stored values of all the properties of the object and its subobjects to the specified XML document.
ExportToFile | Recursively writes the stored values of all the properties of the object and its subobjects to the specified XML file.
GetServiceRestartMask | Retrieves a 32-bit bitmask of the FpcServices enumerated type that specifies which services need to be restarted for currently unsaved changes to take effect.
Import | Recursively copies the values of all the properties of the object and of its subobjects from the specified XML document to persistent storage.
ImportFromFile | Recursively copies the values of all the properties of the object and of its subobjects from the specified XML file to persistent storage.
LoadDocProperties | Provides the XML document's properties so that you can know what information can be imported from the document.
Refresh | Recursively reads the values of all the properties of the object and of its subobjects from persistent storage, overwriting any changes that have not been saved.
Save | Recursively writes the current values of all the properties of the object and its subobjects to persistent storage.
WaitForChanges | Registers to wait for an event indicating that the contents of the object have changed (for use in C and C++ programming only).

Properties Inherited from FPCPersist

Name | Description
PersistentName | Gets the persistent name of the object. The persistent name of an object is a name that is unique for the object at the respective level of the COM object hierarchy.
VendorParametersSets | Gets an FPCVendorParametersSets collection that can hold sets of custom data for extending the object.

Remarks

This object implements the IFPCExtensions interface.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

COM Objects


IFPCExtensions | FPCExtensions ApplicationFilters property [ISA Server 2004]

ApplicationFilters Property of IFPCExtensions[C++]

FPCExtensions.ApplicationFilters [Visual Basic]

[C++]

The ApplicationFilters property gets an FPCApplicationFilters collection that contains the application filters registered with the Microsoft Firewall service.

HRESULT get_ApplicationFilters(
  IFPCApplicationFilters** ppApplicationFilters
);

Parameters

ppApplicationFilters
Address of an interface pointer that on return points to an IFPCApplicationFilters interface that represents the collection of application filters.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only. You can modify the collection of application filters for extending the application proxy and access the properties of each Web filter through the IFPCApplicationFilters interface retrieved.

[Visual Basic]

The ApplicationFilters property gets an FPCApplicationFilters collection that contains the application filters registered with the Microsoft Firewall service.

Property ApplicationFilters As FPCApplicationFilters

Property Value

Reference to the FPCApplicationFilters collection.

Remarks

This property is read-only. You can modify the collection of application filters for extending the application proxy and access the properties of each application filter through the FPCApplicationFilters collection retrieved.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCExtensions


IFPCExtensions | FPCExtensions WebFilters property [ISA Server 2004]

WebFilters Property of IFPCExtensions[C++]

FPCExtensions.WebFilters [Visual Basic]

[C++]

The WebFilters property gets an FPCWebFilters collection of Web filters that are registered to extend the ISA Server Web proxy.

HRESULT get_WebFilters(
  IFPCWebFilters** ppWebFilters
);

Parameters

ppWebFilters
Address of an interface pointer that on return points to an IFPCWebFilters interface that represents the collection of Web filters for extending the Web proxy.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only. You can modify the collection of Web filters for extending the Web proxy and access the properties of each Web filter through the IFPCWebFilters interface retrieved.

[Visual Basic]

The WebFilters property gets an FPCWebFilters collection of Web filters that are registered to extend the ISA Server Web proxy.

Property WebFilters As FPCWebFilters

Property Value

Reference to an FPCWebFilters collection of Web filters for extending the Web proxy.

Remarks

This property is read-only. You can modify the collection of Web filters for extending the Web proxy and access the properties of each Web filter through the FPCWebFilters collection retrieved.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCExtensions


FPCFilterExpression object [ISA Server 2004]

FPCFilterExpression

The FPCFilterExpression object is a read-only object that specifies a filter expression for a log or session filter defined by an FPCFilterExpressions collection.

This object is typically an element of an FPCFilterExpressions collection.

Methods

This object has no methods.

Properties

The FPCFilterExpression object has the following properties.

Property | Description
Condition | Gets a value from the FpcFilterCondition enumerated type that specifies the required relationship between the parameter (criteria) and the value included in the filter expression.
Criteria | Gets a value from the FpcFilterCriteria enumerated type that specifies the parameter used in the filter expression.
DateValue | Gets the value for a filter expression that includes a date value.
EnumValue | Gets the value for a filter expression that includes an enumeration value.
IPAddressValue | Gets the value for a filter expression that includes an IP address.
NumericValue | Gets the value for a filter expression that includes a numeric value.
StringValue | Gets the value for a filter expression that includes a string.
ValueType | Gets a value from the FpcFilterValueType enumerated type that specifies the type of value included in the filter expression.

Remarks

This object implements the IFPCFilterExpression interface.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

COM Objects


IFPCFilterExpression | FPCFilterExpression Condition property [ISA Server 2004]

Condition Property of IFPCFilterExpression[C++]

FPCFilterExpression.Condition [Visual Basic]

[C++]

The Condition property gets a value from the FpcFilterCondition enumerated type that specifies the required relationship between the parameter (criteria) and the value included in the filter expression.

HRESULT get_Condition(
  FpcFilterCondition* pCondition
);

Parameters

pCondition
Pointer to a variable that on return receives a value from the FpcFilterCondition enumerated type specifying the required relationship between the parameter (criteria) and the value included in the filter expression.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The Condition property gets a value from the FpcFilterCondition enumerated type that specifies the required relationship between the parameter (criteria) and the value included in the filter expression.

Property Condition As FpcFilterCondition

Property Value

Value from the FpcFilterCondition enumerated type that specifies the required relationship between the parameter (criteria) and the value included in the filter expression.

Remarks

This property is read-only.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCFilterExpression


IFPCFilterExpression | FPCFilterExpression Criteria property [ISA Server 2004]

Criteria Property of IFPCFilterExpression[C++]

FPCFilterExpression.Criteria [Visual Basic]

[C++]

The Criteria property gets a value from the FpcFilterCriteria enumerated type that specifies the parameter used in the filter expression.

HRESULT get_Criteria(
  FpcFilterCriteria* pCriteria
);

Parameters

pCriteria
Pointer to a variable that on return receives a value from the FpcFilterCriteria enumerated type specifying the parameter used in the filter expression.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The Criteria property gets a value from the FpcFilterCriteria enumerated type that specifies the parameter used in the filter expression.

Property Criteria As FpcFilterCriteria

Property Value

Value from the FpcFilterCriteria enumerated type that specifies the parameter used in the filter expression.

Remarks

This property is read-only.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCFilterExpression


IFPCFilterExpression | FPCFilterExpression DateValue property [ISA Server 2004]

DateValue Property of IFPCFilterExpression[C++]

FPCFilterExpression.DateValue [Visual Basic]

[C++]

The DateValue property gets the value for a filter expression that includes a DATE value.

HRESULT get_DateValue(
  DATE* pDateValue
);

Parameters

pDateValue
Pointer to a DATE that is set on return to the value included in the filter expression.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The DateValue property gets the value for a filter expression that includes a Date value.

Property DateValue As Date

Property Value

The Date value included in the filter expression.

Remarks

This property is read-only.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCFilterExpression


IFPCFilterExpression | FPCFilterExpression EnumValue property [ISA Server 2004]

EnumValue Property of IFPCFilterExpression[C++]

FPCFilterExpression.EnumValue [Visual Basic]

[C++]

The EnumValue property gets the value for a filter expression that includes an enumeration value.

HRESULT get_EnumValue(
  long* pEnumValue
);

Parameters

pEnumValue
Pointer to a variable that on return receives a 32-bit integer specifying the enumeration value included in the filter expression.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The EnumValue property gets the value for a filter expression that includes an enumeration value.

Property EnumValue As Long

Property Value

A 32-bit integer that specifies the enumeration value included in the filter expression.

Remarks

This property is read-only.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCFilterExpression


IFPCFilterExpression.IPAddressValue(BSTR) property [ISA Server 2004]

IPAddressValue Property of IFPCFilterExpression[C++]

FPCFilterExpression.IPAddressValue [Visual Basic]

[C++]

The IPAddressValue property gets the value for a filter expression that includes an IP address.

HRESULT get_IPAddressValue(
  BSTR* pbstrIPAddressValue
);

Parameters

pbstrIPAddressValue
Pointer to a BSTR that is set on return to a string value specifying the IP address included in the filter expression.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The IPAddressValue property gets the value for a filter expression that includes an IP address.

Property IPAddressValue As String

Property Value

String that specifies the IP address included in the filter expression.

Remarks

This property is read-only.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCFilterExpression


IFPCFilterExpression.NumericValue(long) property [ISA Server 2004]

NumericValue Property of IFPCFilterExpression[C++]

FPCFilterExpression.NumericValue [Visual Basic]

[C++]

The NumericValue property gets the value for a filter expression that includes a numeric value.

HRESULT get_NumericValue(
  long* plNumericValue
);

Parameters

plNumericValue
Pointer to a 32-bit integer that is set on return to the numeric value that is included in the filter expression.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The NumericValue property gets the value for a filter expression that includes a numeric value.

Property NumericValue As Long

Property Value

The 32-bit integer value that is included in the filter expression.

Remarks

This property is read-only.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCFilterExpression


IFPCFilterExpression.StringValue(BSTR) property [ISA Server 2004]

StringValue Property of IFPCFilterExpression[C++]

FPCFilterExpression.StringValue [Visual Basic]

[C++]

The StringValue property gets the value for a filter expression that includes a string.

HRESULT get_StringValue(
  BSTR* pbstrStringValue
);

Parameters

pbstrStringValue
Pointer to a BSTR that is set on return to the string value included in the filter expression.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The StringValue property gets the value for a filter expression that includes a string.

Property StringValue As String

Property Value

String value that is included in the filter expression.

Remarks

This property is read-only.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCFilterExpression


IFPCFilterExpression | FPCFilterExpression ValueType property [ISA Server 2004]

ValueType Property of IFPCFilterExpression[C++]

FPCFilterExpression.ValueType [Visual Basic]

[C++]

The ValueType property gets a value from the FpcFilterValueType enumerated type that specifies the type of value included in the filter expression.

HRESULT get_ValueType(
  FpcFilterValueType* pValueType
);

Parameters

pValueType
Pointer to a variable that on return receives a value from the FpcFilterValueType enumerated type specifying the type of value included in the filter expression.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The ValueType property gets a value from the FpcFilterValueType enumerated type that specifies the type of value included in the filter expression.

Property ValueType As FpcFilterValueType

Property Value

Value from the FpcFilterValueType enumerated type that specifies the type of value included in the filter expression.

Remarks

This property is read-only.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCFilterExpression


FPCFilterExpressions collection [ISA Server 2004]

FPCFilterExpressions Collection

The FPCFilterExpressions collection holds a set of FPCFilterExpression objects and defines a filter that you can apply to sessions or log content.

This collection is supplied as an [in] parameter to the ExecuteQuery method of the FPCSessionsMonitor collection and to the ExecuteQuery method of the FPCLogContent collection to specify the filter that will be used in the query.

The FPCFilterExpressions collection is not part of the object hierarchy based on the FPC root object and must be created separately. The following Microsoft Visual Basic Scripting Edition (VBScript) example creates an instance of the FPCFilterExpressions collection:

  Set filter = CreateObject("FPC.FPCFilterExpressions")

When creating the filter expressions collection in Visual Basic, use the following:

  Dim root As New FPCLib.FPCFilterExpressions

or

  Dim root As FPCLib.FPCFilterExpressions
  Set root = CreateObject("FPC.FPCFilterExpressions")

When creating the filter expressions collection in C++, you can use the following code to create the collection and a smart pointer to the IFPCFilterExpressions interface:

  HRESULT hr;
  FPCLib::IFPCFilterExpressionsPtr sipFilterExpressionsCol;

  hr = sipFilterExpressionsCol.CreateInstance("FPC.FPCFilterExpressions");

Methods

The FPCFilterExpressions collection defines the following methods.

Method | Description
AddDateFilter | Creates a new FPCFilterExpression object representing a date filter expression in the collection and returns a reference to it.
AddEnumFilter | Creates a new FPCFilterExpression object representing an enumeration value filter expression in the collection and returns a reference to it.
AddIPAddressFilter | Creates a new FPCFilterExpression object representing an IP address filter expression in the collection and returns a reference to it.
AddNumericFilter | Creates a new FPCFilterExpression object representing a numeric filter expression in the collection and returns a reference to it.
AddStringFilter | Creates a new FPCFilterExpression object representing a string filter expression in the collection and returns a reference to it.
Item | Retrieves the requested FPCFilterExpression object from the collection.
Remove | Removes the specified FPCFilterExpression object from the collection.

Properties

The FPCFilterExpressions collection has the following properties.

Property | Description
_NewEnum | Gets an enumerator object for the collection.
Count | Gets the number of FPCFilterExpression objects in the collection.
FilterType | Gets or sets a value from the FpcFilterType enumerated type that specifies whether the collection defines a session filter or a log filter.

Remarks

This collection implements the IFPCFilterExpressions interface.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

COM Objects


IFPCFilterExpressions._NewEnum(IUnknown) property [ISA Server 2004]

_NewEnum Property of IFPCFilterExpressions[C++]

FPCFilterExpressions._NewEnum [Visual Basic]

[C++]

The _NewEnum property gets an enumerator object for the collection. An enumerator object provides serial access to the elements of the collection.

HRESULT get__NewEnum(
  IUnknown* ppEnum
);

Parameters

ppEnum
Address of an interface pointer that on return points to the IUnknown interface of an enumerator object that implements an IEnumVARIANT interface for the collection. An interface pointer to the IEnumVARIANT interface of the enumerator object can be retrieved by calling QueryInterface on the IUnknown interface returned.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The _NewEnum property gets an enumerator object for the collection. An enumerator object provides serial access to the elements of the collection.

Property _NewEnum As IUnknown

Property Value

Reference to an enumerator object that provides serial access to the elements of the collection.

Remarks

This property is read-only.

In Visual Basic and VBScript, this property is used implicitly in For Each...In...Next constructs.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCFilterExpressions


IFPCFilterExpressions.AddDateFilter (4 Parameters) method [ISA Server 2004]

IFPCFilterExpressions::AddDateFilter[C++]

FPCFilterExpressions.AddDateFilter [Visual Basic]

[C++]

The AddDateFilter method creates a new FPCFilterExpression object representing a date filter expression in the collection and returns a reference to it.

HRESULT AddDateFilter(
  FpcFilterCriteria Criteria,
  FpcFilterCondition Condition,
  DATE Value,
  IFPCFilterExpression** ppNewFilterExpression
);

Parameters

Criteria
[in] Value from the FpcFilterCriteria enumerated type that specifies the parameter (criteria) used in the filter expression.

When the FilterType property of the collection is set to fpcSessionsFilter, the only valid value for this parameter is fpcFilterByActivation.

When the FilterType property of the collection is set to fpcLogViewerFilter, the only valid value for this parameter is fpcFilterByLogTime.

Condition
[in] Value from the FpcFilterCondition enumerated type that specifies the required relationship between the parameter (criteria) and the value included in the filter expression. The following values are valid:

  • fpcLast24Hours
  • fpcLast7days
  • fpcLast30days
  • fpcLastHour
  • fpcLiveData
  • fpcOnOrAfter
  • fpcOnOrBefore
Value
[in] Date literal that, together with the Criteria and Condition parameters, forms the filter expression. This parameter must always be set to a valid date literal, but it is only used if the Criteria parameter is set to fpcOnOrAfter or fpcOnOrBefore.
ppNewFilterExpression
Address of an interface pointer that on return points to the new IFPCFilterExpression interface created.

Return Values

This method can return one of the following:

  • S_OK, indicating that the operation succeeded.
  • An error code, indicating that the operation failed. In this case, the [out] parameter returned is a null object.

Remarks

The FilterType property of the collection must be set to fpcSessionsFilter or fpcLogViewerFilter before running this method.

[Visual Basic]

The AddDateFilter method creates a new FPCFilterExpression object representing a date filter expression in the collection and returns a reference to it.

Function AddDateFilter( _
  ByVal Criteria As FpcFilterCriteria, _
  ByVal Condition As FpcFilterCondition, _
  ByVal Value As Date _
) As FPCFilterExpression

Parameters

Criteria
[in] Value from the FpcFilterCriteria enumerated type that specifies the parameter (criteria) used in the filter expression.

When the FilterType property of the collection is set to fpcSessionsFilter, the only valid value for this parameter is fpcFilterByActivation.

When the FilterType property of the collection is set to fpcLogViewerFilter, the only valid value for this parameter is fpcFilterByLogTime.

Condition
[in] Value from the FpcFilterCondition enumerated type that specifies the required relationship between the parameter (criteria) and the value included in the filter expression. The following values are valid:

  • fpcLast24Hours
  • fpcLast7days
  • fpcLast30days
  • fpcLastHour
  • fpcLiveData
  • fpcOnOrAfter
  • fpcOnOrBefore
Value
[in] Date literal that, together with the Criteria and Condition parameters, forms the filter expression. This parameter must always be set to a valid date literal, but it is only used if the Criteria parameter is set to fpcOnOrAfter or fpcOnOrBefore.

Return Values

This method returns a reference to the FPCFilterExpression object if successful. Otherwise, an error is raised that can be intercepted by using an error handler.

Remarks

The FilterType property of the collection must be set to fpcSessionsFilter or fpcLogViewerFilter before running this method.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCFilterExpressions


IFPCFilterExpressions.AddEnumFilter (4 Parameters) method [ISA Server 2004]

IFPCFilterExpressions::AddEnumFilter[C++]

FPCFilterExpressions.AddEnumFilter [Visual Basic]

[C++]

The AddEnumFilter method creates a new FPCFilterExpression object representing an enumeration value filter expression in the collection and returns a reference to it.

HRESULT AddEnumFilter(
  FpcFilterCriteria Criteria,
  FpcFilterCondition Condition,
  long Value,
  IFPCFilterExpression** ppNewFilterExpression
);

Parameters

Criteria
[in] Value from the FpcFilterCriteria enumerated type that specifies the parameter (criteria) used in the filter expression.

When the FilterType property of the collection is set to fpcSessionsFilter, the only valid value for this parameter is fpcFilterBySessionType.

When the FilterType property of the collection is set to fpcLogViewerFilter, the following values are valid:

  • fpcFilterByAction
  • fpcFilterByAuthenticated
  • fpcFilterByBidirectional
  • fpcFilterByLogType
  • fpcFilterByObjectSource
  • fpcFilterByService
Condition
[in] Value from the FpcFilterCondition enumerated type that specifies the required relationship between the parameter (criteria) and the value included in the filter expression. The following values are valid:

  • fpcEqual
  • fpcNotEqual
Value
[in] A 32-bit integer value (enumeration value) that, together with the Criteria and Condition parameters, forms the filter expression.
ppNewFilterExpression
Address of an interface pointer that on return points to the new IFPCFilterExpression interface created.

Return Values

This method can return one of the following:

  • S_OK, indicating that the operation succeeded.
  • An error code, indicating that the operation failed. In this case, the [out] parameter returned is a null object.

Remarks

The FilterType property of the collection must be set to fpcSessionsFilter or fpcLogViewerFilter before running this method.

[Visual Basic]

The AddEnumFilter method creates a new FPCFilterExpression object representing an enumeration value filter expression in the collection and returns a reference to it.

Function AddEnumFilter( _
  ByVal Criteria As FpcFilterCriteria, _
  ByVal Condition As FpcFilterCondition, _
  ByVal Value As Long _
) As FPCFilterExpression

Parameters

Criteria
[in] Value from the FpcFilterCriteria enumerated type that specifies the parameter (criteria) used in the filter expression.

When the FilterType property of the collection is set to fpcSessionsFilter, the only valid value for this parameter is fpcFilterBySessionType.

When the FilterType property of the collection is set to fpcLogViewerFilter, the following values are valid:

  • fpcFilterByAction
  • fpcFilterByAuthenticated
  • fpcFilterByBidirectional
  • fpcFilterByLogType
  • fpcFilterByObjectSource
  • fpcFilterByService
Condition
[in] Value from the FpcFilterCondition enumerated type that specifies the required relationship between the parameter (criteria) and the value included in the filter expression. The following values are valid:

  • fpcEqual
  • fpcNotEqual
Value
[in] A 32-bit integer value (enumeration value) that, together with the Criteria and Condition parameters, forms the filter expression.

Return Values

This method returns a reference to the FPCFilterExpression object if successful. Otherwise, an error is raised that can be intercepted by using an error handler.

Remarks

The FilterType property of the collection must be set to fpcSessionsFilter or fpcLogViewerFilter before running this method.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCFilterExpressions


IFPCFilterExpressions.AddIPAddressFilter (4 Parameters) method [ISA Server 2004]

IFPCFilterExpressions::AddIPAddressFilter[C++]

FPCFilterExpressions.AddIPAddressFilter [Visual Basic]

[C++]

The AddIPAddressFilter method creates a new FPCFilterExpression object representing an IP address filter expression in the collection and returns a reference to it.

HRESULT AddIPAddressFilter(
  FpcFilterCriteria Criteria,
  FpcFilterCondition Condition,
  BSTR Value,
  IFPCFilterExpression** ppNewFilterExpression
);

Parameters

Criteria
[in] Value from the FpcFilterCriteria enumerated type that specifies the parameter (criteria) used in the filter expression.

When the FilterType property of the collection is set to fpcSessionsFilter, the only valid value for this parameter is fpcFilterByClientIP.

When the FilterType property of the collection is set to fpcLogViewerFilter, the following values are valid:

  • fpcFilterByClientIP
  • fpcFilterByDestHostIP
  • fpcFilterByOriginalClientIP
Condition
[in] Value from the FpcFilterCondition enumerated type that specifies the required relationship between the parameter (criteria) and the value included in the filter expression. The following values are valid:

  • fpcEqual
  • fpcGreaterOrEqual
  • fpcLessOrEqual
  • fpcNotEqual
Value
[in] String value specifying an IP address that, together with the Criteria and Condition parameters, forms the filter expression.
ppNewFilterExpression
Address of an interface pointer that on return points to the new IFPCFilterExpression interface created.

Return Values

This method can return one of the following:

  • S_OK, indicating that the operation succeeded.
  • An error code, indicating that the operation failed. In this case, the [out] parameter returned is a null object.

Remarks

The FilterType property of the collection must be set to fpcSessionsFilter or fpcLogViewerFilter before running this method.

[Visual Basic]

The AddIPAddressFilter method creates a new FPCFilterExpression object representing an IP address filter expression in the collection and returns a reference to it.

Function AddIPAddressFilter( _
  ByVal Criteria As FpcFilterCriteria, _
  ByVal Condition As FpcFilterCondition, _
  ByVal Value As String _
) As FPCFilterExpression

Parameters

Criteria
[in] Value from the FpcFilterCriteria enumerated type that specifies the parameter (criteria) used in the filter expression.

When the FilterType property of the collection is set to fpcSessionsFilter, the only valid value for this parameter is fpcFilterByClientIP.

When the FilterType property of the collection is set to fpcLogViewerFilter, the following values are valid:

  • fpcFilterByClientIP
  • fpcFilterByDestHostIP
  • fpcFilterByOriginalClientIP
Condition
[in] Value from the FpcFilterCondition enumerated type that specifies the required relationship between the parameter (criteria) and the value included in the filter expression. The following values are valid:

  • fpcEqual
  • fpcGreaterOrEqual
  • fpcLessOrEqual
  • fpcNotEqual
Value
[in] String value specifying an IP address that, together with the Criteria and Condition parameters, forms the filter expression.

Return Values

This method returns a reference to the FPCFilterExpression object if successful. Otherwise, an error is raised that can be intercepted by using an error handler.

Remarks

The FilterType property of the collection must be set to fpcSessionsFilter or fpcLogViewerFilter before running this method.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCFilterExpressions


IFPCFilterExpressions.AddNumericFilter (4 Parameters) method [ISA Server 2004]

IFPCFilterExpressions::AddNumericFilter[C++]

FPCFilterExpressions.AddNumericFilter [Visual Basic]

[C++]

The AddNumericFilter method creates a new FPCFilterExpression object representing a numeric value filter expression in the collection and returns a reference to it.

HRESULT AddNumericFilter(
  FpcFilterCriteria Criteria,
  FpcFilterCondition Condition,
  long Value,
  IFPCFilterExpression** ppNewFilterExpression
);

Parameters

Criteria
[in] Value from the FpcFilterCriteria enumerated type that specifies the parameter (criteria) used in the filter expression.

The following values are valid:

  • fpcFilterByBytesReceived
  • fpcFilterByBytesSent
  • fpcFilterByCacheInfo
  • fpcFilterByDestHostPort
  • fpcFilterByErrorInfo
  • fpcFilterByProcessingTime
  • fpcFilterByResultCode
  • fpcFilterBySrcPort
Condition
[in] Value from the FpcFilterCondition enumerated type that specifies the required relationship between the parameter (criteria) and the value included in the filter expression. The following values are valid:

The following values may be used, but not all of the values are valid for each value of the Criteria parameter:

  • fpcEqual
  • fpcNotEqual
  • fpcGreaterOrEqual
  • fpcLessOrEqual
Value
[in] A 32-bit integer value that, together with the Criteria and Condition parameters, forms the filter expression.
ppNewFilterExpression
Address of an interface pointer that on return points to the new IFPCFilterExpression interface created.

Return Values

This method can return one of the following:

  • S_OK, indicating that the operation succeeded.
  • An error code, indicating that the operation failed. In this case, the [out] parameter returned is a null object.

Remarks

The FilterType property of the collection must be set to fpcLogViewerFilter before running this method.

[Visual Basic]

The AddNumericFilter method creates a new FPCFilterExpression object representing a numeric value filter expression in the collection and returns a reference to it.

Function AddNumericFilter( _
  ByVal Criteria As FpcFilterCriteria, _
  ByVal Condition As FpcFilterCondition, _
  ByVal Value As Long _
) As FPCFilterExpression

Parameters

Criteria
[in] Value from the FpcFilterCriteria enumerated type that specifies the parameter (criteria) used in the filter expression.

The following values are valid:

  • fpcFilterByBytesReceived
  • fpcFilterByBytesSent
  • fpcFilterByCacheInfo
  • fpcFilterByDestHostPort
  • fpcFilterByErrorInfo
  • fpcFilterByProcessingTime
  • fpcFilterByResultCode
  • fpcFilterBySrcPort
Condition
[in] Value from the FpcFilterCondition enumerated type that specifies the required relationship between the parameter (criteria) and the value included in the filter expression. The following values are valid:

The following values may be used, but not all of the values are valid for each value of the Criteria parameter:

  • fpcEqual
  • fpcNotEqual
  • fpcGreaterOrEqual
  • fpcLessOrEqual
Value
[in] A 32-bit integer value that, together with the Criteria and Condition parameters, forms the filter expression.

Return Values

This method returns a reference to the FPCFilterExpression object if successful. Otherwise, an error is raised that can be intercepted by using an error handler.

Remarks

The FilterType property of the collection must be set to fpcLogViewerFilter before running this method.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCFilterExpressions


IFPCFilterExpressions.AddStringFilter (4 Parameters) method [ISA Server 2004]

IFPCFilterExpressions::AddStringFilter[C++]

FPCFilterExpressions.AddStringFilter [Visual Basic]

[C++]

The AddStringFilter method creates a new FPCFilterExpression object representing a string filter expression in the collection and returns a reference to it.

HRESULT AddStringFilter(
  FpcFilterCriteria Criteria,
  FpcFilterCondition Condition,
  BSTR Value,
  IFPCFilterExpression** ppNewFilterExpression
);

Parameters

Criteria
[in] Value from the FpcFilterCriteria enumerated type that specifies the parameter (criteria) used in the filter expression.

When the FilterType property of the collection is set to fpcSessionsFilter, the following values are valid:

  • fpcFilterByApplicationName
  • fpcFilterByClientComputerName
  • fpcFilterByClientUserName
  • fpcFilterByServername
  • fpcFilterBySourceNetwork

When the FilterType property of the collection is set to fpcLogViewerFilter, the following values are valid:

  • fpcFilterByClientAgent
  • fpcFilterByClientComputerName
  • fpcFilterByClientUserName
  • fpcFilterByDestHost
  • fpcFilterByDestinationNetwork
  • fpcFilterByDestinationProxy
  • fpcFilterByFilterInfo
  • fpcFilterByHeader
  • fpcFilterByInterface
  • fpcFilterByMimetype
  • fpcFilterByOperation
  • fpcFilterByPayload
  • fpcFilterByProtocol
  • fpcFilterByReferringServer
  • fpcFilterByRule
  • fpcFilterByServername
  • fpcFilterBySourceNetwork
  • fpcFilterBySourceProxy
  • fpcFilterByTransport
  • fpcFilterByUrl
Condition
[in] Value from the FpcFilterCondition enumerated type that specifies the required relationship between the parameter (criteria) and the value included in the filter expression. The following values are valid:

  • fpcEqual
  • fpcContains
  • fpcNotContains
  • fpcNotEqual
Value
[in] String value that, together with the Criteria and Condition parameters, forms the filter expression.
ppNewFilterExpression
Address of an interface pointer that on return points to the new IFPCFilterExpression interface created.

Return Values

This method can return one of the following:

  • S_OK, indicating that the operation succeeded.
  • An error code, indicating that the operation failed. In this case, the [out] parameter returned is a null object.

Remarks

The FilterType property of the collection must be set to fpcSessionsFilter or fpcLogViewerFilter before running this method.

[Visual Basic]

The AddStringFilter method creates a new FPCFilterExpression object representing a string filter expression in the collection and returns a reference to it.

Function AddStringFilter( _
  ByVal Criteria As FpcFilterCriteria, _
  ByVal Condition As FpcFilterCondition, _
  ByVal Value As String _
) As FPCFilterExpression

Parameters

Criteria
[in] Value from the FpcFilterCriteria enumerated type that specifies the parameter (criteria) used in the filter expression.

When the FilterType property of the collection is set to fpcSessionsFilter, the following values are valid:

  • fpcFilterByApplicationName
  • fpcFilterByClientComputerName
  • fpcFilterByClientUserName
  • fpcFilterByServername
  • fpcFilterBySourceNetwork

When the FilterType property of the collection is set to fpcLogViewerFilter, the following values are valid:

  • fpcFilterByClientAgent
  • fpcFilterByClientComputerName
  • fpcFilterByClientUserName
  • fpcFilterByDestHost
  • fpcFilterByDestinationNetwork
  • fpcFilterByDestinationProxy
  • fpcFilterByFilterInfo
  • fpcFilterByHeader
  • fpcFilterByInterface
  • fpcFilterByMimetype
  • fpcFilterByOperation
  • fpcFilterByPayload
  • fpcFilterByProtocol
  • fpcFilterByReferringServer
  • fpcFilterByRule
  • fpcFilterByServername
  • fpcFilterBySourceNetwork
  • fpcFilterBySourceProxy
  • fpcFilterByTransport
  • fpcFilterByUrl
Condition
[in] Value from the FpcFilterCondition enumerated type that specifies the required relationship between the parameter (criteria) and the value included in the filter expression. The following values are valid:

  • fpcEqual
  • fpcContains
  • fpcNotContains
  • fpcNotEqual
Value
[in] String value that, together with the Criteria and Condition parameters, forms the filter expression.

Return Values

This method returns a reference to the FPCFilterExpression object if successful. Otherwise, an error is raised that can be intercepted by using an error handler.

Remarks

The FilterType property of the collection must be set to fpcSessionsFilter or fpcLogViewerFilter before running this method.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCFilterExpressions


IFPCFilterExpressions | FPCFilterExpressions Count property [ISA Server 2004]

Count Property of IFPCFilterExpressions[C++]

FPCFilterExpressions.Count [Visual Basic]

[C++]

The Count property gets the number of FPCFilterExpression objects in the collection.

HRESULT get_Count(
  long* plCount
);

Parameters

plCount
Pointer to a variable that on return receives a 32-bit integer specifying the number of FPCFilterExpression objects in the collection.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The Count property gets the number of FPCFilterExpression objects in the collection.

Property Count As Long

Property Value

A 32-bit integer value that specifies the number of FPCFilterExpression objects in the collection.

Remarks

This property is read-only.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCFilterExpressions


IFPCFilterExpressions.FilterType (2 Parameters) property [ISA Server 2004]

FilterType Property of IFPCFilterExpressions[C++]

FPCFilterExpressions.FilterType [Visual Basic]

[C++]

The FilterType property gets or sets a value from the FpcFilterType enumerated type that specifies whether the collection defines a session filter or a log filter.

HRESULT get_FilterType(
  FpcFilterType* pFilterType
);

HRESULT put_FilterType(
  FpcFilterType FilterType
);

Parameters

pFilterType
Pointer to a variable that on return receives a value from the FpcFilterType enumerated type specifying whether the collection defines a session filter or a log filter.
FilterType
Value from the FpcFilterType enumerated type that specifies whether the collection defines a session filter or a log filter.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write.

[Visual Basic]

The FilterType property gets or sets a value from the FpcFilterType enumerated type that specifies whether the collection defines a session filter or a log filter.

Property FilterType As FpcFilterType

Property Value

Value from the FpcFilterType enumerated type that specifies whether the filter is a log filter or a session filter.

Remarks

This property is read/write.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCFilterExpressions


IFPCFilterExpressions | FPCFilterExpressions Item method [ISA Server 2004]

IFPCFilterExpressions::Item[C++]

FPCFilterExpressions.Item [Visual Basic]

[C++]

The Item method retrieves the requested IFPCFilterExpression interface from the collection.

HRESULT Item(
  long Index,
  IFPCFilterExpression** ppItem
);

Parameters

Index
[in] Required. The one-based index of the object to retrieve.
ppItem
Address of an interface pointer that on return points to the IFPCFilterExpression interface requested.

Return Values

This method can return one of the following:

  • S_OK, indicating that the operation succeeded.
  • An error code, indicating that the operation failed. In this case, the [out] parameter returned is a null object.

[Visual Basic]

The Item method retrieves the requested FPCFilterExpression object from the collection.

Function Item( _
  ByVal Index As Long _
) As FPCFilterExpression

Parameters

Index
[in] Required. The one-based index of the object to retrieve.

Return Values

This method returns a reference to the FPCFilterExpression object if successful. Otherwise, an error is raised that can be intercepted by using an error handler.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCFilterExpressions


IFPCFilterExpressions | FPCFilterExpressions Remove method [ISA Server 2004]

IFPCFilterExpressions::Remove[C++]

FPCFilterExpressions.Remove [Visual Basic]

[C++]

The Remove method removes the specified FPCFilterExpression object from the collection.

HRESULT Remove(
  long Index
);

Parameters

Index
Required. The one-based index of the FPCFilterExpression object to remove.

Return Values

This method returns S_OK if the call is successful; otherwise, it returns an error code.
[Visual Basic]

The Remove method removes the specified FPCFilterExpression object from the collection.

Sub Remove( _
  ByVal Index As Long _
)

Parameters

Index
Required. The one-based index of the FPCFilterExpression object to remove.

Return Values

This method has no return values. If the call is unsuccessful, an error is raised that can be intercepted by using an error handler.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCFilterExpressions


FPCFirewallChaining object [ISA Server 2004]

FPCFirewallChaining

The FPCFirewallChaining object defines Microsoft Firewall service chainings. You can use Microsoft Firewall service chaining to configure the routing of Microsoft Firewall service requests among the servers.

You can use the FPCFirewallChaining object to determine whether chaining is enabled and to determine the name of the array or server to which to chain.

The FPCFirewallChaining object is typically accessed through the FirewallChaining property of the FPCNetworkConfiguration object.

Click here to see the ISA Server object hierarchy.

Inheritance

This object inherits from the FPCPersist object, which contains methods and properties related to the persistent storage of an object's data. They include methods for exporting an object's data to and importing it from an XML document.

Methods

This object has no methods.

Properties

The FPCFirewallChaining object has the following properties.

Property | Description
AuthenticationEnabled | Gets or sets a Boolean value that indicates whether the use of authentication in upstream routing is enabled.
Credentials | Gets an FPCCredentials object that represents the credentials that are to be used for authentication when requests are forwarded to an upstream server.
ForwardTo | Gets the name of the server or array to which to chain.
ForwardType | Gets or sets a value from the FpcFwForwardType enumerated type that specifies whether requests are forwarded to the primary connection or to an upstream ISA Server computer.

Methods Inherited from FPCPersist

Name | Description
CancelWaitForChanges | Cancels the registration established by the WaitForChanges method (for use in C and C++ programming only).
CanImport | Returns a Boolean value that indicates whether the object's properties can be imported from the specified XML document.
Export | Recursively writes the stored values of all the properties of the object and its subobjects to the specified XML document.
ExportToFile | Recursively writes the stored values of all the properties of the object and its subobjects to the specified XML file.
GetServiceRestartMask | Retrieves a 32-bit bitmask of the FpcServices enumerated type that specifies which services need to be restarted for currently unsaved changes to take effect.
Import | Recursively copies the values of all the properties of the object and of its subobjects from the specified XML document to persistent storage.
ImportFromFile | Recursively copies the values of all the properties of the object and of its subobjects from the specified XML file to persistent storage.
LoadDocProperties | Provides the XML document's properties so that you can know what information can be imported from the document.
Refresh | Recursively reads the values of all the properties of the object and of its subobjects from persistent storage, overwriting any changes that have not been saved.
Save | Recursively writes the current values of all the properties of the object and its subobjects to persistent storage.
WaitForChanges | Registers to wait for an event indicating that the contents of the object have changed (for use in C and C++ programming only).

Properties Inherited from FPCPersist

Name | Description
PersistentName | Gets the persistent name of the object. The persistent name of an object is a name that is unique for the object at the respective level of the COM object hierarchy.
VendorParametersSets | Gets an FPCVendorParametersSets collection that can hold sets of custom data for extending the object.

Remarks

This object implements the IFPCFirewallChaining interface.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

COM Objects


IFPCFirewallChaining.AuthenticationEnabled property [ISA Server 2004]

AuthenticationEnabled Property of IFPCFirewallChaining[C++]

FPCFirewallChaining.AuthenticationEnabled [Visual Basic]

[C++]

The AuthenticationEnabled property gets or sets a Boolean value that indicates whether the use of authentication in upstream routing is enabled.

HRESULT get_AuthenticationEnabled(
  VARIANT_BOOL* pfEnabled
);

HRESULT put_AuthenticationEnabled(
  VARIANT_BOOL fEnabled
);

Parameters

pfEnabled
Pointer to a Boolean variable that is set on return to VARIANT_TRUE if the use of authentication in upstream routing is enabled, or to VARIANT_FALSE if the use of authentication in upstream routing is disabled.
fEnabled
Boolean value that indicates whether the use of authentication in upstream routing is enabled.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write.

[Visual Basic]

The AuthenticationEnabled property gets or sets a Boolean value that indicates whether the use of authentication in upstream routing is enabled.

Property AuthenticationEnabled As Boolean

Property Value

Boolean value that indicates whether the use of authentication in upstream routing is enabled.

Remarks

This property is read/write.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCFirewallChaining


IFPCFirewallChaining.Credentials(IFPCCredentials) property [ISA Server 2004]

Credentials Property of IFPCFirewallChaining[C++]

FPCFirewallChaining.Credentials [Visual Basic]

[C++]

The Credentials property gets an FPCCredentials object that represents the credentials that are to be used for authentication when requests are forwarded to an upstream server.

HRESULT get_Credentials(
  IFPCCredentials** ppCredentials
);

Parameters

ppCredentials
Address of an interface pointer that on return points to an IFPCCredentials interface that represents the credentials that are to be used for authentication when requests are forwarded to an upstream server.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only. The credentials can be modified through the properties of the IFPCCredentials interface retrieved.

[Visual Basic]

The Credentials property gets an FPCCredentials object that represents the credentials that are to be used for authentication when requests are forwarded to an upstream server.

Property Credentials As FPCCredentials

Property Value

Reference to an FPCCredentials object that represents the credentials that are to be used for authentication when requests are forwarded to an upstream server.

Remarks

This property is read-only. The credentials can be modified through the properties of the FPCCredentials object retrieved.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCFirewallChaining


IFPCFirewallChaining | FPCFirewallChaining ForwardTo property [ISA Server 2004]

ForwardTo Property of IFPCFirewallChaining[C++]

FPCFirewallChaining.ForwardTo [Visual Basic]

[C++]

The ForwardTo property gets or sets the name or IP address of the server or array to which to chain.

HRESULT get_ForwardTo(
  BSTR* pbstrName
);

HRESULT put_ForwardTo(
  BSTR bstrName
);

Parameters

pbstrName
Pointer to a BSTR that is set on return to a string value specifying the name or IP address of the server or array to which to chain.
bstrName
BSTR that specifies the name or IP address of the server or array to which to chain.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write.

[Visual Basic]

The ForwardTo property gets or sets the name or IP address of the server or array to which to chain.

Property ForwardTo As String

Property Value

String that specifies the name or IP address of the server or array to which to chain.

Remarks

This property is read/write.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCFirewallChaining


IFPCFirewallChaining.ForwardType (2 Parameters) property [ISA Server 2004]

ForwardType Property of IFPCFirewallChaining[C++]

FPCFirewallChaining.ForwardType [Visual Basic]

[C++]

The ForwardType property gets or sets a value from the FpcFwForwardType enumerated type that specifies whether requests are forwarded to the primary connection or to an upstream ISA Server computer.

HRESULT get_ForwardType(
  FpcFwForwardType* pForwardType
);

HRESULT put_ForwardType(
  FpcFwForwardType ForwardType
);

Parameters

pForwardType
Pointer to a variable that on return receives a value from the FpcFwForwardType enumerated type specifying whether requests are forwarded to the primary connection or to an upstream ISA Server computer.
ForwardType
Value from the FpcFwForwardType enumerated type that specifies whether requests are forwarded to the primary connection or to an upstream ISA Server computer.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write.

[Visual Basic]

The ForwardType property gets or sets a value from the FpcFwForwardType enumerated type that specifies whether requests are forwarded to the primary connection or to an upstream ISA Server computer.

Property ForwardType

Property Value

Value from the FpcFwForwardType enumerated type that specifies whether requests are forwarded to the primary connection or to an upstream ISA Server computer.

Remarks

This property is read/write.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCFirewallChaining


FPCFirewallClientConfig object [ISA Server 2004]

FPCFirewallClientConfig

The FPCFirewallClientConfig object represents the configuration of the Firewall clients of an ISA Server computer. This object can be accessed through the Firewall property of an FPCClientConfig object.

Click here to see the ISA Server object hierarchy.

Inheritance

This object inherits from the FPCPersist object, which contains methods and properties related to the persistent storage of an object's data. They include methods for exporting an object's data to and importing it from XML documents.

Methods

This object has no methods.

Properties

The FPCFirewallClientConfig object has the following property.

Property | Description
ServerOrArrayNameOrIP | Gets or sets the name or IP address of the ISA Server computer that will be used by Firewall clients.

Methods Inherited from FPCPersist

Name | Description
CancelWaitForChanges | Cancels the registration established by the WaitForChanges method (for use in C and C++ programming only).
CanImport | Returns a Boolean value that indicates whether the object's properties can be imported from the specified XML document.
Export | Writes the stored values of all of the object's properties to the specified XML document.
ExportToFile | Writes the stored values of all of the object's properties to the specified XML file.
GetServiceRestartMask | Retrieves a 32-bit bitmask of the FpcServices enumerated type that specifies which services need to be restarted for currently unsaved changes to take effect.
Import | Copies the values of all of the object's properties from the specified XML document to persistent storage.
ImportFromFile | Copies the values of all of the object's properties from the specified XML file to persistent storage.
LoadDocProperties | Provides the XML document's properties so that you can know what information can be imported from the document.
Refresh | Reads the values of all of the object's properties from persistent storage, overwriting any changes that have not been saved.
Save | Writes the current values of all of the object's properties to persistent storage.
WaitForChanges | Registers to wait for an event indicating that the contents of the object have changed (for use in C and C++ programming only).

Properties Inherited from FPCPersist

Name | Description
PersistentName | Gets the persistent name of the object. The persistent name of an object is a name that is unique for the object at the respective level of the COM object hierarchy.
VendorParametersSets | Gets an FPCVendorParametersSets object that can hold sets of custom data for extending the object.

Remarks

This object implements the IFPCFirewallClientConfig interface.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

COM Objects


IFPCFirewallClientConfig.ServerOrArrayNameOrIP property [ISA Server 2004]

ServerOrArrayNameOrIP Property of IFPCFirewallClientConfig[C++]

FPCFirewallClientConfig.ServerOrArrayNameOrIP [Visual Basic]

[C++]

The ServerOrArrayNameOrIP property gets or sets the name or IP address of the ISA Server computer that will be used by Firewall clients.

HRESULT get_ServerOrArrayNameOrIP(
  BSTR* pbstrNameOrIP
);

HRESULT put_ServerOrArrayNameOrIP(
  BSTR bstrNameOrIP
);

Parameters

pbstrNameOrIP
Pointer to a BSTR that is set on return to a string value specifying the name or IP address of the ISA Server computer that will be used by Firewall clients.
bstrNameOrIP
BSTR that specifies the name or IP address of the ISA Server computer that will be used by Firewall clients.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.
[Visual Basic]

The ServerOrArrayNameOrIP property gets or sets the name or IP address of the ISA Server computer that will be used by Firewall clients.

Property ServerOrArrayNameOrIP As String

Property Value

String that specifies the name or IP address of the ISA Server computer that will be used by Firewall clients.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCFirewallClientConfig


FPCFTPCacheConfiguration object [ISA Server 2004]

FPCFTPCacheConfiguration

The FPCFTPCacheConfiguration object provides access to the File Transfer Protocol (FTP) cache configuration parameters of an ISA Server computer.

The FPCFTPCacheConfiguration object is typically accessed through the FTPConfiguration property of an FPCCacheRule object.

Click here to see the ISA Server object hierarchy.

Methods

The FPCFTPCacheConfiguration object defines the following methods.

Method | Description
Refresh | Reads the values of all of the object's properties from persistent storage, discarding any changes that were not saved.
Save | Writes the current values of all of the object's properties to persistent storage.

Properties

The FPCFTPCacheConfiguration object has the following properties.

Property | Description
FTPEnable | Gets or sets a Boolean value that indicates whether the caching of FTP responses is enabled.
FTPTTLUnits | Gets or sets the time units in which the Time to Live (TTL) is measured.
FTPTTLValue | Gets or sets the Time to Live (TTL) for cached FTP files.

Remarks

This object implements the IFPCFTPCacheConfiguration interface.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

COM Objects


IFPCFTPCacheConfiguration.FTPEnable (2 Parameters) property [ISA Server 2004]

FTPEnable Property of IFPCFTPCacheConfiguration[C++]

FPCFTPCacheConfiguration.FTPEnable [Visual Basic]

[C++]

The FTPEnabled property gets or sets a Boolean value that indicates whether the caching of File Transfer Protocol (FTP) responses is enabled.

HRESULT get_FTPEnable(
  VARIANT_BOOL* pfEnabled
);

HRESULT put_FTPEnable(
  VARIANT_BOOL fEnabled
);

Parameters

pfEnabled
Pointer to a Boolean variable that is set on return to VARIANT_TRUE if the caching of FTP responses is enabled, or to VARIANT_FALSE if the caching of FTP responses is disabled.
fEnabled
Boolean value that indicates whether the caching of FTP responses is enabled.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write.

[Visual Basic]

The FTPEnabled property gets or sets a Boolean value that indicates whether the caching of File Transfer Protocol (FTP) responses is enabled.

Property FTPEnable As Boolean

Property Value

Boolean value that indicates whether the caching of FTP responses is enabled.

Remarks

This property is read/write.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCFTPCacheConfiguration


IFPCFTPCacheConfiguration.FTPTTLUnits (2 Parameters) property [ISA Server 2004]

FTPTTLUnits Property of IFPCFTPCacheConfiguration[C++]

FPCFTPCacheConfiguration.FTPTTLUnits [Visual Basic]

[C++]

The FTPTTLUnits property gets or sets a value from the FpcTimeScale enumerated type that specifies the units in which the Time to Live (TTL) is measured. The units can be seconds, minutes, hours, days, or weeks.

HRESULT get_FTPTTLUnits(
  FpcTimeScale* pTimeUnits
);

HRESULT put_FTPTTLUnits(
  FpcTimeScale TimeUnits
);

Parameters

pTimeUnits
Pointer to a variable that on return receives a value from the FpcTimeScale enumerated type specifying the units in which the TTL is measured.
TimeUnits
Value from the FpcTimeScale enumerated type that specifies the units in which the TTL is measured.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write.

[Visual Basic]

The FTPTTLUnits property gets or sets a value from the FpcTimeScale enumerated type that specifies the units in which the Time to Live (TTL) is measured. The units can be seconds, minutes, hours, days, or weeks.

Property FTPTTLUnits As FpcTimeScale

Property Value

Value from the FpcTimeScale enumerated type that specifies the units in which the TTL is measured.

Remarks

This property is read/write.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCFTPCacheConfiguration


IFPCFTPCacheConfiguration.FTPTTLValue(long,long) property [ISA Server 2004]

FTPTTLValue Property of IFPCFTPCacheConfiguration[C++]

FPCFTPCacheConfiguration.FTPTTLValue [Visual Basic]

[C++]

The FTPTTLValue property gets or sets the Time to Live (TTL) for cached File Transfer Protocol (FTP) files.

HRESULT get_FTPTTLValue(
  long* plTTL
);

HRESULT put_FTPTTLValue(
  long lTTL
);

Parameters

plTTL
Pointer to a variable that receives a 32-bit integer specifying the TTL for cached FTP files. The TTL is expressed in the units specified by the FTPTTLUnits property.
lTTL
A 32-bit integer that specifies the TTL for cached FTP files. The TTL is expressed in the units specified by the FTPTTLUnits property.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write.

[Visual Basic]

The FTPTTLValue property gets or sets the Time to Live (TTL) for cached File Transfer Protocol (FTP) files.

Property FTPTTLValue As Long

Property Value

A 32-bit integer that specifies the TTL for cached FTP files. The TTL is expressed in the units specified by the FTPTTLUnits property.

Remarks

This property is read/write.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCFTPCacheConfiguration


IFPCFTPCacheConfiguration.Refresh method [ISA Server 2004]

IFPCFTPCacheConfiguration::Refresh[C++]

FPCFTPCacheConfiguration.Refresh [Visual Basic]

[C++]

The Refresh method reads the values of all of the object's properties from persistent storage, discarding any changes that were not saved.

HRESULT Refresh();

Parameters

This method has no parameters.

Return Values

This method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

Changes made to this object can be saved by calling the Save method of this object or the Save method of any object containing it.

[Visual Basic]

The Refresh method reads the values of all of the object's properties from persistent storage, discarding any changes that were not saved.

Sub Refresh()

Parameters

This method has no parameters.

Return Values

This method has no return values. If the call is unsuccessful, an error is raised that can be intercepted by using an error handler.

Remarks

Changes made to this object can be saved by calling the Save method of this object or the Save method of any object containing it.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCFTPCacheConfiguration


IFPCFTPCacheConfiguration.Save (2 Parameters) method [ISA Server 2004]

IFPCFTPCacheConfiguration::Save[C++]

FPCFTPCacheConfiguration.Save [Visual Basic]

[C++]

The Save method writes the current values of all of the object's properties to persistent storage. It is important to remember that any changes made by scripts and programs will not be saved until after the Save method is called.

HRESULT Save(
  VARIANT_BOOL fResetRequiredServices,
  VARIANT_BOOL fReloadConfiguration
);

Parameters

fResetRequiredServices
[in, optional] Boolean value that indicates whether to restart the services that need to be restarted for any of the changes saved to take effect. The default value is VARIANT_FALSE.
fReloadConfiguration
[in, optional] Boolean value that indicates whether the call will include synchronous reloading of all changes that can be applied dynamically without restarting services. The default value is VARIANT_TRUE.

Return Values

This method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

Configuration changes are applied only after the new settings are written to persistent storage and reloaded to the services that use them. Most changes can be applied dynamically without restarting any services. However, some changes can take effect only after the Microsoft Firewall service is restarted. For more information, see Restarting Services after Configuration Changes.

ISA Server maintains a bitmask that specifies which services need to be started for currently unsaved changes to take effect. This bitmask can be retrieved by calling the GetServiceRestartMask method on an object that contains this object as a subobject. Calling the Save method clears all of the bits in this bitmask even if the fResetRequiredServices parameter is set to VARIANT_FALSE.

If the fReloadConfiguration parameter is set to VARIANT_FALSE the current values of the object's properties will be written to persistent storage without updating the configuration being used by the ISA Server services. The configuration used by each service will not be updated until the service is restarted or the new settings are reloaded by another call to Save.

[Visual Basic]

The Save method writes the current values of all of the object's properties to persistent storage. It is important to remember that any changes made by scripts and programs will not be saved until after the Save method is called.

Sub Save( _
  [ ByVal fResetRequiredServices As Boolean ], _
  [ ByVal fReloadConfiguration As Boolean ] _
)

Parameters

fResetRequiredServices
[in, optional] Boolean value that indicates whether to restart the services that need to be restarted for any of the changes saved to take effect. The default value is False.
fReloadConfiguration
[in, optional] Boolean value that indicates whether the call will include synchronous reloading of all the saved configuration changes that can be applied dynamically without restarting services. The default value is True.

Return Values

This method has no return values. If the call is unsuccessful, an error is raised that can be intercepted by using an error handler.

Remarks

Configuration changes are applied only after the new settings are written to persistent storage and reloaded to the services that use them. Most changes can be applied dynamically without restarting any services. However, some changes can take effect only after the Microsoft Firewall service is restarted. For more information, see Restarting Services after Configuration Changes.

ISA Server maintains a bitmask that specifies which services need to be started for currently unsaved changes to take effect. This bitmask can be retrieved by calling the GetServiceRestartMask method on an object that contains this object as a subobject. Calling the Save method clears all of the bits in this bitmask even if the fResetRequiredServices parameter is set to False.

If the fReloadConfiguration parameter is set to False the current values of the object's properties will be written to persistent storage without updating the configuration being used by the ISA Server services. The configuration used by each service will not be updated until the service is restarted or the new settings are reloaded by another call to Save.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCFTPCacheConfiguration


FPCHTTPCacheConfiguration object [ISA Server 2004]

FPCHTTPCacheConfiguration

The FPCHTTPCacheConfiguration object provides access to the HTTP cache configuration parameters of an ISA Server computer.

The FPCHTTPCacheConfiguration object is typically accessed through the HTTPConfiguration property of an FPCCacheRule object.

Click here to see the ISA Server object hierarchy.

Methods

The FPCHTTPCacheConfiguration object defines the following methods.

Method | Description
Refresh | Reads the values of all of the object's properties from persistent storage, discarding any changes that were not saved.
Save | Writes the current values of all of the object's properties to persistent storage.

Properties

The FPCHTTPCacheConfiguration object has the following properties.

Property | Description
AgeFactor | Gets or sets the age factor for determining the Time to Live (TTL) of cached HTTP content.
ApplyBoundsToObjectsWithExpiration | Gets or sets a Boolean value that indicates whether the Time to Live (TTL) bounds are applied to objects that have an expiration time specified by their source.
HTTPEnable | Gets or sets a Boolean value that indicates whether the caching of HTTP content is enabled.
MaxIntervalUnits | Gets or sets a value from the FpcTimeScale enumerated type that specifies the units of time in which the MaxIntervalValue property is expressed.
MaxIntervalValue | Gets or sets the maximum Time to Live (TTL) of cached objects originating from HTTP requests.
MinInterval | Gets or sets the minimum Time to Live (TTL) of cached objects originating from HTTP requests.
MinIntervalUnits | Gets or sets a value from the FpcTimeScale enumerated type that specifies the units of time in which the MinInterval property is expressed.

Remarks

This object implements the IFPCHTTPCacheConfiguration interface.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

COM Objects


IFPCHTTPCacheConfiguration.AgeFactor(long,long) property [ISA Server 2004]

AgeFactor Property of IFPCHTTPCacheConfiguration[C++]

FPCHTTPCacheConfiguration.AgeFactor [Visual Basic]

[C++]

The AgeFactor property gets or sets the age factor for determining the Time to Live (TTL) of cached HTTP content. The age factor establishes the TTL as a percentage of the Web object's age, based on the time when it was created or last modified.

HRESULT get_AgeFactor(
  long* plFactor
);

HRESULT put_AgeFactor(
  long lFactor
);

Parameters

plFactor
Pointer to a variable that on return receives a 32-bit integer specifying the TTL age factor.
lFactor
A 32-bit integer that specifies the TTL age factor.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write. Its default value is 20 percent (%).

[Visual Basic]

The AgeFactor property gets or sets the age factor for determining the Time to Live (TTL) of cached HTTP content. The age factor establishes the TTL as a percentage of the Web object's age, based on the time when it was created or last modified.

Property AgeFactor As Long

Property Value

A 32-bit integer that specifies the TTL age factor.

Remarks

This property is read/write. Its default value is 20 percent (%).

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCHTTPCacheConfiguration


ApplyBoundsToObjectsWithExpiration property [ISA Server 2004]

ApplyBoundsToObjectsWithExpiration Property of IFPCHTTPCacheConfiguration[C++]

FPCHTTPCacheConfiguration.ApplyBoundsToObjectsWithExpiration [Visual Basic]

[C++]

The ApplyBoundsToObjectsWithExpiration property gets or sets a Boolean value that indicates whether the Time to Live (TTL) bounds are applied to objects that have an expiration time specified by their source. If you set this property to True, objects in the cache will be refreshed more frequently, based on the TTL specified in the source.

HRESULT get_ApplyBoundsToObjectsWithExpiration(
  VARIANT_BOOL* pfApply
);

HRESULT put_ApplyBoundsToObjectsWithExpiration(
  VARIANT_BOOL fApply
);

Parameters

pfApply
Pointer to a Boolean variable that is set on return to VARIANT_TRUE if the TTL bounds are applied to objects that have an expiration time specified by their source, or to VARIANT_FALSE if the TTL bounds are not applied to objects that have an expiration time specified by their source.
fApply
Boolean value that specifies whether the TTL bounds are applied to objects that have an expiration time specified by their source.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write. By default, the TTL bounds are not applied to objects that have an expiration time specified by their source.

[Visual Basic]

The ApplyBoundsToObjectsWithExpiration property gets or sets a Boolean value that indicates whether the Time to Live (TTL) bounds are applied to objects that have an expiration time specified by their source. If you set this property to True, objects in the cache will be refreshed more frequently, based on the TTL specified in the source.

Property ApplyBoundsToObjectsWithExpiration As Boolean

Property Value

Boolean value that indicates whether the TTL bounds are applied to objects that have an expiration time specified by their source.

Remarks

This property is read/write. By default, the TTL bounds are not applied to objects that have an expiration time specified by their source.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCHTTPCacheConfiguration


IFPCHTTPCacheConfiguration.HTTPEnable (2 Parameters) property [ISA Server 2004]

HTTPEnable Property of IFPCHTTPCacheConfiguration[C++]

FPCHTTPCacheConfiguration.HTTPEnable [Visual Basic]

[C++]

The HTTPEnable property gets or sets a Boolean value that indicates whether the caching of HTTP content is enabled.

HRESULT get_HTTPEnable(
  VARIANT_BOOL* pfEnabled
);

HRESULT put_HTTPEnable(
  VARIANT_BOOL fEnabled
);

Parameters

pfEnabled
Pointer to a Boolean variable that is set on return to VARIANT_TRUE if the caching of HTTP content is enabled, or to VARIANT_FALSE if the caching of HTTP content is disabled.
fEnabled
A Boolean value that indicates whether the caching of HTTP content is enabled.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write. By default, the caching of HTTP content is enabled.

[Visual Basic]

The HTTPEnable property gets or sets a Boolean value that indicates whether the caching of HTTP content is enabled.

Property HTTPEnable As Boolean

Property Value

A Boolean value that indicates whether the caching of HTTP content is enabled.

Remarks

This property is read/write. By default, the caching of HTTP content is enabled.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCHTTPCacheConfiguration


IFPCHTTPCacheConfiguration.MaxIntervalUnits property [ISA Server 2004]

MaxIntervalUnits Property of IFPCHTTPCacheConfiguration[C++]

FPCHTTPCacheConfiguration.MaxIntervalUnits [Visual Basic]

[C++]

The MaxIntervalUnits property gets or sets a value from the FpcTimeScale enumerated type that specifies the units of time in which the MaxIntervalValue property is expressed.

HRESULT get_MaxIntervalUnits(
  FpcTimeScale* pUnits
);

HRESULT put_MaxIntervalUnits(
  FpcTimeScale Units
);

Parameters

pUnits
Pointer to a variable that on return receives the value from the FpcTimeScale enumerated type specifying the units of time in which the MaxIntervalValue property is expressed.
Units
Value from the FpcTimeScale enumerated type that specifies the units of time in which the MaxIntervalValue property is expressed.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write. By default, the MaxIntervalValue property is expressed in minutes.

[Visual Basic]

The MaxIntervalUnits property gets or sets a value from the FpcTimeScale enumerated type that specifies the units of time in which the MaxIntervalValue property is expressed.

Property MaxIntervalUnits As FpcTimeScale

Property Value

Value from the FpcTimeScale enumerated type that specifies the units of time in which the MaxIntervalValue property is expressed.

Remarks

This property is read/write. By default, the MaxIntervalValue property is expressed in minutes.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCHTTPCacheConfiguration


IFPCHTTPCacheConfiguration.MaxIntervalValue property [ISA Server 2004]

MaxIntervalValue Property of IFPCHTTPCacheConfiguration[C++]

FPCHTTPCacheConfiguration.MaxIntervalValue [Visual Basic]

[C++]

The MaxIntervalValue property gets or sets the maximum Time to Live (TTL) of cached objects originating from HTTP requests.

HRESULT get_MaxIntervalValue(
  long* plMax
);

HRESULT put_MaxIntervalValue(
  long lMax
);

Parameters

plMax
Pointer to a variable that on return receives a 32-bit integer specifying the maximum TTL. The maximum TTL is expressed in the units specified by the MaxIntervalUnits property.
lMax
A 32-bit integer that specifies the maximum TTL interval. The maximum TTL is expressed in the units specified by the MaxIntervalUnits property.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write. By default, the maximum TTL of cached HTTP content is 24 hours (1440 minutes).

[Visual Basic]

The MaxIntervalValue property gets or sets the maximum Time to Live (TTL) of cached objects originating from HTTP requests.

Property MaxIntervalValue As Long

Property Value

A 32-bit integer that specifies the maximum TTL. The maximum TTL is expressed in the units specified by the MaxIntervalUnits property.

Remarks

This property is read/write. By default, the maximum TTL of cached HTTP content is 24 hours (1440 minutes).

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCHTTPCacheConfiguration


IFPCHTTPCacheConfiguration.MinInterval(long,long) property [ISA Server 2004]

MinInterval Property of IFPCHTTPCacheConfiguration[C++]

FPCHTTPCacheConfiguration.MinInterval [Visual Basic]

[C++]

The MinInterval property gets or sets the minimum Time to Live (TTL) of cached objects originating from HTTP requests.

HRESULT get_MinInterval(
  long* plMin
);

HRESULT put_MinInterval(
  long lMin
);

Parameters

plMin
Pointer to a variable that on return receives a 32-bit integer specifying the minimum TTL. The minimum TTL is expressed in the units specified by the MinIntervalUnits property.
lMin
A 32-bit integer that specifies the minimum TTL. The minimum TTL is expressed in the units specified by the MinIntervalUnits property.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write. By default, the minimum TTL of cached HTTP content is 15 minutes.

[Visual Basic]

The MinInterval property gets or sets the minimum Time to Live (TTL) of cached objects originating from HTTP requests.

Property MinInterval As Long

Property Value

A 32-bit integer that specifies the minimum TTL. The minimum TTL is expressed in the units specified by the MinIntervalUnits property.

Remarks

This property is read/write. By default, the minimum TTL of cached HTTP content is 15 minutes.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCHTTPCacheConfiguration


IFPCHTTPCacheConfiguration.MinIntervalUnits property [ISA Server 2004]

MinIntervalUnits Property of IFPCHTTPCacheConfiguration[C++]

FPCHTTPCacheConfiguration.MinIntervalUnits [Visual Basic]

[C++]

The MinIntervalUnits property gets or sets a value from the FpcTimeScale enumerated type that specifies the units of time in which the MinInterval property is expressed.

HRESULT get_MinIntervalUnits(
  FpcTimeScale* pUnits
);

HRESULT put_MinIntervalUnits(
  FpcTimeScale Units
);

Parameters

pUnits
Pointer to a variable that on return receives a value from the FpcTimeScale enumerated type specifying the units of time in which the MinInterval property is expressed.
Units
Value from the FpcTimeScale enumerated type that specifies the units of time in which the MinInterval property is expressed.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write.

[Visual Basic]

The MinIntervalUnits property gets or sets a value from the FpcTimeScale enumerated type that specifies the units of time in which the MinInterval property is expressed.

Property MinIntervalUnits As FpcTimeScale

Property Value

Value from the FpcTimeScale enumerated type that specifies the units of time in which the MinInterval property is expressed.

Remarks

This property is read/write.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCHTTPCacheConfiguration


IFPCHTTPCacheConfiguration.Refresh method [ISA Server 2004]

IFPCHTTPCacheConfiguration::Refresh[C++]

FPCHTTPCacheConfiguration.Refresh [Visual Basic]

[C++]

The Refresh method reads the values of all of the object's properties from persistent storage, discarding any changes that were not saved.

HRESULT Refresh();

Parameters

This method has no parameters.

Return Values

This method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

Changes made to this object can be saved by calling the Save method of this object or the Save method of any object containing it.

[Visual Basic]

The Refresh method reads the values of all of the object's properties from persistent storage, discarding any changes that were not saved.

Sub Refresh()

Parameters

This method has no parameters.

Return Values

This method has no return values. If the call is unsuccessful, an error is raised that can be intercepted by using an error handler.

Remarks

Changes made to this object can be saved by calling the Save method of this object or the Save method of any object containing it.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCHTTPCacheConfiguration


IFPCHTTPCacheConfiguration.Save (2 Parameters) method [ISA Server 2004]

IFPCHTTPCacheConfiguration::Save[C++]

FPCHTTPCacheConfiguration.Save [Visual Basic]

[C++]

The Save method writes the current values of all of the object's properties to persistent storage. It is important to remember that any changes made by scripts and programs will not be saved until after the Save method is called.

HRESULT Save(
  VARIANT_BOOL fResetRequiredServices,
  VARIANT_BOOL fReloadConfiguration
);

Parameters

fResetRequiredServices
[in, optional] Boolean value that indicates whether to restart the services that need to be restarted for any of the changes saved to take effect. The default value is VARIANT_FALSE.
fReloadConfiguration
[in, optional] Boolean value that indicates whether the call will include synchronous reloading of all changes that can be applied dynamically without restarting services. The default value is VARIANT_TRUE.

Return Values

This method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

Configuration changes are applied only after the new settings are written to persistent storage and reloaded to the services that use them. Most changes can be applied dynamically without restarting any services. However, some changes can take effect only after the Microsoft Firewall service is restarted. For more information, see Restarting Services after Configuration Changes.

ISA Server maintains a bitmask that specifies which services need to be started for currently unsaved changes to take effect. This bitmask can be retrieved by calling the GetServiceRestartMask method on an object that contains this object as a subobject. Calling the Save method clears all of the bits in this bitmask even if the fResetRequiredServices parameter is set to VARIANT_FALSE.

If the fReloadConfiguration parameter is set to VARIANT_FALSE the current values of the object's properties will be written to persistent storage without updating the configuration being used by the ISA Server services. The configuration used by each service will not be updated until the service is restarted or the new settings are reloaded by another call to Save.

[Visual Basic]

The Save method writes the current values of all of the object's properties to persistent storage. It is important to remember that any changes made by scripts and programs will not be saved until after the Save method is called.

Sub Save( _
  [ ByVal fResetRequiredServices As Boolean ], _
  [ ByVal fReloadConfiguration As Boolean ] _
)

Parameters

fResetRequiredServices
[in, optional] Boolean value that indicates whether to restart the services that need to be restarted for any of the changes saved to take effect. The default value is False.
fReloadConfiguration
[in, optional] Boolean value that indicates whether the call will include synchronous reloading of all the saved configuration changes that can be applied dynamically without restarting services. The default value is True.

Return Values

This method has no return values. If the call is unsuccessful, an error is raised that can be intercepted by using an error handler.

Remarks

Configuration changes are applied only after the new settings are written to persistent storage and reloaded to the services that use them. Most changes can be applied dynamically without restarting any services. However, some changes can take effect only after the Microsoft Firewall service is restarted. For more information, see Restarting Services after Configuration Changes.

ISA Server maintains a bitmask that specifies which services need to be started for currently unsaved changes to take effect. This bitmask can be retrieved by calling the GetServiceRestartMask method on an object that contains this object as a subobject. Calling the Save method clears all of the bits in this bitmask even if the fResetRequiredServices parameter is set to False.

If the fReloadConfiguration parameter is set to False the current values of the object's properties will be written to persistent storage without updating the configuration being used by the ISA Server services. The configuration used by each service will not be updated until the service is restarted or the new settings are reloaded by another call to Save.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCHTTPCacheConfiguration


FPCIPAddresses collection [ISA Server 2004]

FPCIPAddresses Collection

The FPCIPAddresses collection holds a set of IP addresses stored as strings.

This collection is typically accessed through the IPAddresses property of an FPCIPOnNetwork object.

Click here to see the ISA Server object hierarchy.

Methods

The FPCIPAddresses collection defines the following methods.

Method | Description
Add | Adds an IP address to the collection.
Item | Retrieves the requested IP address from the collection.
Refresh | Reads the collection's data from persistent storage, discarding any changes that were not saved.
Remove | Removes the specified IP address from the collection.
RemoveAll | Removes all of the IP addresses from the collection.
Save | Writes the current data for the collection and its elements to persistent storage.

Properties

The FPCIPAddresses collection has the following properties.

Property | Description
_NewEnum | Gets an enumerator object for the collection.
Count | Gets the number of IP addresses in the collection.

Remarks

This collection implements the IFPCIPAddresses interface.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

COM Objects


IFPCIPAddresses | FPCIPAddresses _NewEnum(IUnknown) property [ISA Server 2004]

_NewEnum Property of IFPCIPAddresses[C++]

FPCIPAddresses._NewEnum [Visual Basic]

[C++]

The _NewEnum property gets an enumerator object for the collection. An enumerator object provides serial access to the elements of the collection.

HRESULT get__NewEnum(
  IUnknown* ppEnum
);

Parameters

ppEnum
Address of an interface pointer that on return points to the IUnknown interface of an enumerator object that implements an IEnumVARIANT interface for the collection. An interface pointer to the IEnumVARIANT interface of the enumerator object can be retrieved by calling QueryInterface on the IUnknown interface returned.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The _NewEnum property gets an enumerator object for the collection. An enumerator object provides serial access to the elements of the collection.

Property _NewEnum As IUnknown

Property Value

Reference to an enumerator object that provides serial access to the elements of the collection.

Remarks

This property is read-only.

In Visual Basic and VBScript, this property is used implicitly in For Each...In...Next constructs.

Example Code

This VBScript script displays all of the IP addresses on which a specific Web listener listens. This example does not include error handling.

' Create the root object.
Dim root  ' The FPCLib.FPC root object
Set root = CreateObject("FPC.Root")

' Declare the other objects needed and a string.
Dim array         ' An FPCArray object
Dim weblisteners  ' An FPCWebListeners collection
Dim weblistener   ' An FPCWebListener object
Dim iponnetwork   ' An FPCIPOnNetwork object
Dim ipaddresses   ' An FPCIPAddresses collection
Dim ipaddress     ' A string

' Get references to the array object
' and the IP addresses collection.
Set array = root.GetContainingArray()
Set weblisteners = array.RuleElements.WebListeners

' If at least one Web listener is defined in the Web
' listeners collection, display all the IP addresses on
' which the first Web listener found listens.
On Error Resume Next
Set weblistener = weblisteners.Item(1)
If Err.Number = 0 Then
    For Each iponnetwork In weblistener.IPsOnNetworks
        Set ipaddresses = iponnetwork.IPAddresses
        For Each ipaddress In ipaddresses
            WScript.Echo "IP Address: " & ipaddress
        Next
    Next
End If

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCIPAddresses


IFPCIPAddresses | FPCIPAddresses Add(String) method [ISA Server 2004]

IFPCIPAddresses::Add[C++]

FPCIPAddresses.Add [Visual Basic]

[C++]

The Add method adds a new IP address to the collection.

HRESULT Add(
  BSTR IP
);

Parameters

IP
[in] Required. BSTR that specifies the new IP address.

Return Values

This method returns S_OK if the call is successful; otherwise, it returns an error code.

[Visual Basic]

The Add method adds a new IP address to the collection.

Sub Add( _
  ByVal IP As String _
)

Parameters

IP
[in] Required. String that specifies the new IP address.

Return Values

This method has no return values. If the call is unsuccessful, an error is raised that can be intercepted by using an error handler.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCIPAddresses


IFPCIPAddresses | FPCIPAddresses Count(long) property [ISA Server 2004]

Count Property of IFPCIPAddresses[C++]

FPCIPAddresses.Count [Visual Basic]

[C++]

The Count property gets the number of IP addresses in the object.

HRESULT get_Count(
  long* plCount
);

Parameters

plCount
Pointer to a variable that on return receives a 32-bit integer specifying the number of IP addresses in the collection.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The Count property gets the number of IP addresses in the object.

Property Count As Long

Property Value

A 32-bit integer that specifies the number of addresses.

Remarks

This property is read-only.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCIPAddresses


IFPCIPAddresses | FPCIPAddresses Item(Variant,BSTR) method [ISA Server 2004]

IFPCIPAddresses::Item[C++]

FPCIPAddresses.Item [Visual Basic]

[C++]

The Item method retrieves the requested IP address from the collection.

HRESULT Item(
  VARIANT Index,
  BSTR* pItem
);

Parameters

Index
[in] Required. One-based index of the IP address to retrieve.
pItem
[out] Pointer to a BSTR that is set on return to a string value specifying the IP address requested.

Return Values

The method can return one of the following:

  • S_OK, indicating that the operation succeeded.
  • An error code, indicating that the operation failed.

[Visual Basic]

The Item method retrieves the requested IP address from the collection.

Function Item( _
  ByVal Index As Variant _
) As String

Parameters

Index
[in] Required. One-based index of the IP address to retrieve.

Return Values

The method returns a string that specifies the IP address if successful. Otherwise, an error is raised that can be intercepted by using an error handler.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCIPAddresses


IFPCIPAddresses | FPCIPAddresses Refresh method [ISA Server 2004]

IFPCIPAddresses::Refresh[C++]

FPCIPAddresses.Refresh [Visual Basic]

[C++]

The Refresh method reads the collection's data from persistent storage, discarding any changes that were not saved.

HRESULT Refresh();

Parameters

This method has no parameters.

Return Values

This method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

Changes made to this collection or its elements can be saved by calling the Save method of this collection or the Save method of any object containing it.

[Visual Basic]

The Refresh method reads the collection's data from persistent storage, discarding any changes that were not saved.

Sub Refresh()

Parameters

This method has no parameters.

Return Values

This method has no return values. If the call is unsuccessful, an error is raised that can be intercepted by using an error handler.

Remarks

Changes made to this collection or its elements can be saved by calling the Save method of this collection or the Save method of any object containing it.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCIPAddresses


IFPCIPAddresses | FPCIPAddresses Remove(Variant) method [ISA Server 2004]

IFPCIPAddresses::Remove[C++]

FPCIPAddresses.Remove [Visual Basic]

[C++]

The Remove method removes the specified IP address from the collection.

HRESULT Remove(
  VARIANT Index
);

Parameters

Index
[in] Required. One-based index of the IP address to remove.

Return Values

This method returns S_OK if the call is successful; otherwise, it returns an error code.
[Visual Basic]

The Remove method removes the specified IP address from the collection.

Sub Remove( _
  ByVal Index As Variant _
)

Parameters

Index
[in] Required. One-based index of the IP address to remove.

Return Values

This method has no return values. If the call is unsuccessful, an error is raised that can be intercepted by using an error handler.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCIPAddresses


IFPCIPAddresses | FPCIPAddresses RemoveAll method [ISA Server 2004]

IFPCIPAddresses::RemoveAll[C++]

FPCIPAddresses.RemoveAll [Visual Basic]

[C++]

The RemoveAll method removes all of the IP addresses from the collection.

HRESULT RemoveAll();

Parameters

This method has no parameters.

Return Values

This method returns S_OK if the call is successful; otherwise, it returns an error code.
[Visual Basic]

The RemoveAll method removes all of the IP addresses from the collection.

Sub RemoveAll()

Parameters

This method has no parameters.

Return Values

This method has no return values. If the call is unsuccessful, an error is raised that can be intercepted by using an error handler.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCIPAddresses


IFPCIPAddresses | FPCIPAddresses Save (2 Parameters) method [ISA Server 2004]

IFPCIPAddresses::Save[C++]

FPCIPAddresses.Save [Visual Basic]

[C++]

The Save method writes the current data for the collection and its elements to persistent storage. It is important to remember that any changes made by scripts and programs are not saved until after the Save method is called.

HRESULT Save(
  VARIANT_BOOL fResetRequiredServices,
  VARIANT_BOOL fReloadConfiguration
);

Parameters

fResetRequiredServices
[in, optional] Boolean value that indicates whether to restart the services that need to be restarted for any of the changes saved to take effect. The default value is VARIANT_FALSE.
fReloadConfiguration
[in, optional] Boolean value that indicates whether the call will include synchronous reloading of all changes that can be applied dynamically without restarting services. The default value is VARIANT_TRUE.

Return Values

This method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

Configuration changes are applied only after the new settings are written to persistent storage and reloaded to the services that use them. Most changes can be applied dynamically without restarting any services. However, some changes can take effect only after the Microsoft Firewall service is restarted. For more information, see Restarting Services after Configuration Changes.

ISA Server maintains a bitmask that specifies which services need to be started for currently unsaved changes to take effect. This bitmask can be retrieved by calling the GetServiceRestartMask method on an object that contains this object as a subobject. Calling the Save method clears all of the bits in this bitmask even if the fResetRequiredServices parameter is set to VARIANT_FALSE.

If the fReloadConfiguration parameter is set to VARIANT_FALSE the current data for the collection and its elements will be written to persistent storage without updating the configuration being used by the ISA Server services. The configuration used by each service will not be updated until the service is restarted or the new settings are reloaded by another call to Save.

[Visual Basic]

The Save method writes the current data for the collection and its elements to persistent storage. It is important to remember that any changes made by scripts and programs are not saved until after the Save method is called.

Sub Save( _
  [ ByVal fResetRequiredServices As Boolean ], _
  [ ByVal fReloadConfiguration As Boolean ] _
)

Parameters

fResetRequiredServices
[in, optional] Boolean value that indicates whether to restart the services that need to be restarted for any of the changes saved to take effect. The default value is False.
fReloadConfiguration
[in, optional] Boolean value that indicates whether the call will include synchronous reloading of all the saved configuration changes that can be applied dynamically without restarting services. The default value is True.

Return Values

This method has no return values. If the call is unsuccessful, an error is raised that can be intercepted by using an error handler.

Remarks

Configuration changes are applied only after the new settings are written to persistent storage and reloaded to the services that use them. Most changes can be applied dynamically without restarting any services. However, some changes can take effect only after the Microsoft Firewall service is restarted. For more information, see Restarting Services after Configuration Changes.

ISA Server maintains a bitmask that specifies which services need to be started for currently unsaved changes to take effect. This bitmask can be retrieved by calling the GetServiceRestartMask method on an object that contains this object as a subobject. Calling the Save method clears all of the bits in this bitmask even if the fResetRequiredServices parameter is set to False.

If the fReloadConfiguration parameter is set to False the current data for the collection and its elements will be written to persistent storage without updating the configuration being used by the ISA Server services. The configuration used by each service will not be updated until the service is restarted or the new settings are reloaded by another call to Save.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCIPAddresses


FPCIPOnNetwork object [ISA Server 2004]

FPCIPOnNetwork

The FPCIPOnNetwork object provides access to a group of one or more IP addresses on which the ISA Server computer listens for requests from a particular network on behalf of a server published by a publishing rule, or on which a Web listener on the ISA Server computer listens for Web requests from a particular network.

This object is typically an element of an FPCIPsOnNetworks collection.

Click here to see the ISA Server object hierarchy.

Methods

The FPCIPOnNetwork object defines the following methods.

Method | Description
Refresh | Recursively reads the values of all of the object's properties, including the properties of its subobjects and their elements (for collections), from persistent storage, overwriting any changes that were not saved.
Save | Recursively writes the current values of all of the object's properties and the elements of its subobject (a collection) to persistent storage.

Properties

The FPCIPOnNetwork object has the following properties.

Property | Description
IPAddresses | Gets an FPCIPAddresses collection that contains a set of IP addresses on the network.
IPSelectionMethod | Gets or sets a value from the FpcIPSelectionMethods enumerated type that specifies the method for selecting IP addresses on the network.
Network | Gets an FPCRef object that references the FPCNetwork object representing the network that contains the IP addresses.

Remarks

This object implements the IFPCIPOnNetwork interface.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

COM Objects


IFPCIPOnNetwork | FPCIPOnNetwork IPAddresses property [ISA Server 2004]

IPAddresses Property of IFPCIPOnNetwork[C++]

FPCIPOnNetwork.IPAddresses [Visual Basic]

[C++]

The IPAddresses property gets an FPCIPAddresses collection that contains a set of IP addresses on the network.

HRESULT get_IPAddresses(
  IFPCIPAddresses** ppIPAddresses
);

Parameters

ppIPAddresses
Address of an interface pointer that on return points to an IFPCIPAddresses interface that represents the collection of IP addresses on the network.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only. IP addresses can be added and removed by calling the methods of the IFPCIPAddresses interface retrieved.

[Visual Basic]

The IPAddresses property gets an FPCIPAddresses collection that contains a set of IP addresses on the network.

Property IPAddresses As FPCIPAddresses

Property Value

Reference to an FPCIPAddresses collection that contains a set of IP addresses on the network.

Remarks

This property is read-only. IP addresses can be added and removed by calling the methods of the FPCIPAddresses collection retrieved.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCIPOnNetwork


IFPCIPOnNetwork | FPCIPOnNetwork IPSelectionMethod property [ISA Server 2004]

IPSelectionMethod Property of IFPCIPOnNetwork[C++]

FPCIPOnNetwork.IPSelectionMethod [Visual Basic]

[C++]

The IPSelectionMethod property gets or sets a value from the FpcIPSelectionMethods enumerated type that specifies the method for selecting IP addresses on the network. All of the IP addresses on the network, only the default IP address, or only the IP addresses listed in the IPAddresses property can be selected.

HRESULT get_IPSelectionMethod(
  FpcIPSelectionMethods* pIPSelectionMethod
);

HRESULT put_IPSelectionMethod(
  FpcIPSelectionMethods IPSelectionMethod
);

Parameters

pIPSelectionMethod
Pointer to a variable that on return receives a value from the FpcIPSelectionMethods enumerated type specifying whether all of the IP addresses on the network, only the default IP address, or only the IP addresses listed in the IPAddresses property will be selected.
IPSelectionMethod
Value from the FpcIPSelectionMethods enumerated type that specifies whether all of the IP addresses on the network, only the default IP address, or only the IP addresses listed in the IPAddresses property will be selected.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write.

[Visual Basic]

The IPSelectionMethod property gets or sets a value from the FpcIPSelectionMethods enumerated type that specifies the method for selecting IP addresses on the network. All of the IP addresses on the network, only the default IP address, or only the IP addresses listed in the IPAddresses property can be selected.

Property IPSelectionMethod As FpcIPSelectionMethods

Property Value

Value from the FpcIPSelectionMethods enumerated type that specifies whether all of the IP addresses on the network, only the default IP address, or only the IP addresses listed in the IPAddresses property will be selected.

Remarks

This property is read/write.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCIPOnNetwork


IFPCIPOnNetwork | FPCIPOnNetwork Network(IFPCRef) property [ISA Server 2004]

Network Property of IFPCIPOnNetwork[C++]

FPCIPOnNetwork.Network [Visual Basic]

[C++]

The Network property gets an FPCRef object that references the FPCNetwork object representing the network that contains the IP addresses.

HRESULT get_Network(
  IFPCRef** ppRef
);

Parameters

ppRef
Address of an interface pointer that on return points to an IFPCRef interface that references the FPCNetwork object representing the network that contains the IP addresses.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The Network property gets an FPCRef object that references the FPCNetwork object representing the network that contains the IP addresses.

Property Network As FPCRef

Property Value

Reference to an FPCRef object that references the FPCNetwork object representing the network that contains the IP addresses.

Remarks

This property is read-only.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCIPOnNetwork


IFPCIPOnNetwork | FPCIPOnNetwork Refresh method [ISA Server 2004]

IFPCIPOnNetwork::Refresh[C++]

FPCIPOnNetwork.Refresh [Visual Basic]

[C++]

The Refresh method recursively reads the values of all of the object's properties, including the properties of its subobjects and their elements (for collections), from persistent storage, discarding any changes that have not been saved.

HRESULT Refresh();

Parameters

This method has no parameters.

Return Values

This method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

Changes made to this object can be saved by calling the Save method of this object or the Save method of any object containing it.

[Visual Basic]

The Refresh method recursively reads the values of all of the object's properties, including the properties of its subobjects and their elements (for collections), from persistent storage, discarding any changes that have not been saved.

Sub Refresh()

Parameters

This method has no parameters.

Return Values

This method has no return values. If the call is unsuccessful, an error is raised that can be intercepted by using an error handler.

Remarks

Changes made to this object can be saved by calling the Save method of this object or the Save method of any object containing it.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCIPOnNetwork


IFPCIPOnNetwork | FPCIPOnNetwork Save (2 Parameters) method [ISA Server 2004]

IFPCIPOnNetwork::Save[C++]

FPCIPOnNetwork.Save [Visual Basic]

[C++]

The Save method recursively writes the current values of all of the object's properties and the elements of its subobject (a collection) to persistent storage. It is important to remember that any changes made by scripts and programs are not saved until after the Save method is called.

HRESULT Save(
  VARIANT_BOOL fResetRequiredServices,
  VARIANT_BOOL fReloadConfiguration
);

Parameters

fResetRequiredServices
[in, optional] Boolean value that indicates whether to restart the services that need to be restarted for any of the changes saved to take effect. The default value is VARIANT_FALSE.
fReloadConfiguration
[in, optional] Boolean value that indicates whether the call will include synchronous reloading of all changes that can be applied dynamically without restarting services. The default value is VARIANT_TRUE.

Return Values

This method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

Configuration changes are applied only after the new settings are written to persistent storage and reloaded to the services that use them. Most changes can be applied dynamically without restarting any services. However, some changes can take effect only after the Microsoft Firewall service is restarted. For more information, see Restarting Services after Configuration Changes.

ISA Server maintains a bitmask that specifies which services need to be started for currently unsaved changes to take effect. This bitmask can be retrieved by calling the GetServiceRestartMask method on an object that contains this object as a subobject. Calling the Save method clears all of the bits in this bitmask even if the fResetRequiredServices parameter is set to VARIANT_FALSE.

If the fReloadConfiguration parameter is set to VARIANT_FALSE the current values will be written to persistent storage without updating the configuration being used by the ISA Server services. The configuration used by each service will not be updated until the service is restarted or the new settings are reloaded by another call to Save.

[Visual Basic]

The Save method recursively writes the current values of all of the object's properties and the elements of its subobject (a collection) to persistent storage. It is important to remember that any changes made by scripts and programs are not saved until after the Save method is called.

Sub Save( _
  [ ByVal fResetRequiredServices As Boolean ], _
  [ ByVal fReloadConfiguration As Boolean ] _
)

Parameters

fResetRequiredServices
[in, optional] Boolean value that indicates whether to restart the services that need to be restarted for any of the changes saved to take effect. The default value is False.
fReloadConfiguration
[in, optional] Boolean value that indicates whether the call will include synchronous reloading of all the saved configuration changes that can be applied dynamically without restarting services. The default value is True.

Return Values

This method has no return values. If the call is unsuccessful, an error is raised that can be intercepted by using an error handler.

Remarks

Configuration changes are applied only after the new settings are written to persistent storage and reloaded to the services that use them. Most changes can be applied dynamically without restarting any services. However, some changes can take effect only after the Microsoft Firewall service is restarted. For more information, see Restarting Services after Configuration Changes.

ISA Server maintains a bitmask that specifies which services need to be started for currently unsaved changes to take effect. This bitmask can be retrieved by calling the GetServiceRestartMask method on an object that contains this object as a subobject. Calling the Save method clears all of the bits in this bitmask even if the fResetRequiredServices parameter is set to False.

If the fReloadConfiguration parameter is set to False the current values will be written to persistent storage without updating the configuration being used by the ISA Server services. The configuration used by each service will not be updated until the service is restarted or the new settings are reloaded by another call to Save.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCIPOnNetwork


FPCIpOptions object [ISA Server 2004]

FPCIpOptions

The FPCIpOptions object enables configuration of the IP options checking mechanism for ISA Server. ISA Server checks for IP options, which are included in the header of an IP packet. Using this object you can configure whether the mechanism checks for all or some IP options, and whether a packet with those options will be denied.

ISA Server has four modes of operation when inspecting the packets for IP options, which are specified by values defined in the FpcIpOptionsAction enumerated type:

fpcAllowPacketsIpOptions
A packet is allowed to pass no matter what IP options it may have.
fpcDenyPacketsIpOptions
A packet is dropped if it has any IP option.
fpcAllowPacketsSelectedIpOptions
Selected IP options are allowed, and a packet is denied if it has an IP option other than those on the list of selected IP options.
fpcDenyPacketsSelectedIpOptions
Selected IP options are not allowed, and a packet is dropped if it has any option that is in the list of selected IP options.

This object can be accessed through the IPOptions property of an FPCAttackDetection object.

Click here to see the ISA Server object hierarchy.

Inheritance

This object inherits from the FPCPersist object, which contains methods and properties related to the persistent storage of an object's data. They include methods for exporting the object's data to and importing it from an XML document.

Methods

The FPCIpOptions object defines the following methods.

Method | Description
Clear | Clears the specified IP option.
ClearAll | Clears all of the IP options.
IsSelected | Queries whether the specified IP option is selected.
Select | Selects the specified IP option.
SelectAll | Selects all of the IP options.

Properties

The FPCIpOptions object has the following property.

Property | Description
IpOptionsAction | Gets or sets a value from the FpcIpOptionsAction enumerated type that specifies whether packets will be allowed or denied with consideration of the IP options included in them.

Methods Inherited from FPCPersist

Name | Description
CancelWaitForChanges | Cancels the registration established by the WaitForChanges method (for use in C and C++ programming only).
CanImport | Returns a Boolean value that indicates whether the object's properties can be imported from the specified XML document.
Export | Writes the stored values of all of the object's properties to the specified XML document.
ExportToFile | Writes the stored values of all of the object's properties to the specified XML file.
GetServiceRestartMask | Retrieves a 32-bit bitmask of the FpcServices enumerated type that specifies which services need to be restarted for currently unsaved changes to take effect.
Import | Copies the values of all of the object's properties from the specified XML document to persistent storage.
ImportFromFile | Copies the values of all of the object's properties from the specified XML file to persistent storage.
LoadDocProperties | Provides the XML document's properties so that you can know what information can be imported from the document.
Refresh | Reads the values of all of the object's properties from persistent storage, overwriting any changes that have not been saved.
Save | Writes the current values of all of the object's properties to persistent storage.
WaitForChanges | Registers to wait for an event indicating that the contents of the object have changed (for use in C and C++ programming only).

Properties Inherited from FPCPersist

Name | Description
PersistentName | Gets the persistent name of the object. The persistent name of an object is a name that is unique for the object at the respective level of the COM object hierarchy.
VendorParametersSets | Gets an FPCVendorParametersSets object that can hold sets of custom data for extending the object.

Remarks

This object implements the IFPCIpOptions interface.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

COM Objects


IFPCIpOptions | FPCIpOptions Clear(Long) method [ISA Server 2004]

IFPCIpOptions::Clear[C++]

FPCIpOptions.Clear [Visual Basic]

[C++]

The Clear method clears the specified IP option.

HRESULT Clear(
  long IpOption
);

Parameters

IpOption
[in] A 32-bit integer value that specifies the IP option to be cleared.

Return Values

This method returns S_OK if the call is successful; otherwise, it returns an error code.

[Visual Basic]

The Clear method clears the specified IP option.

Sub Clear( _
  ByVal IpOption As Long _
)

Parameters

IpOption
[in] A 32-bit integer value that specifies the IP option to be cleared.

Return Values

This method has no return values. If the call is unsuccessful, an error is raised that can be intercepted by using an error handler.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCIpOptions


IFPCIpOptions | FPCIpOptions ClearAll method [ISA Server 2004]

IFPCIpOptions::ClearAll[C++]

FPCIpOptions.ClearAll [Visual Basic]

[C++]

The ClearAll method clears all of the IP options.

HRESULT ClearAll();

Parameters

This method has no parameters.

Return Values

This method returns S_OK if the call is successful; otherwise, it returns an error code.
[Visual Basic]

The ClearAll method clears all of the IP options.

Sub ClearAll()

Parameters

This method has no parameters.

Return Values

This method has no return values. If the call is unsuccessful, an error is raised that can be intercepted by using an error handler.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCIpOptions


IFPCIpOptions | FPCIpOptions IpOptionsAction property [ISA Server 2004]

IpOptionsAction Property of IFPCIpOptions[C++]

FPCIpOptions.IpOptionsAction [Visual Basic]

[C++]

The IpOptionsAction property gets or sets a value from the FpcIpOptionsAction enumerated type that specifies whether packets will be allowed or denied with consideration of the IP options included in them.

HRESULT get_IpOptionsAction(
  FpcIpOptionsAction* pAction
);

HRESULT put_IpOptionsAction(
  FpcIpOptionsAction Action
);

Parameters

pAction
Pointer to a variable that on return receives a value from the FpcIpOptionsAction enumerated type specifying whether packets will be allowed or denied with consideration of the IP options included in them.
Action
Value from the FpcIpOptionsAction enumerated type that specifies whether packets will be allowed or denied with consideration of the IP options included in them.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write.

[Visual Basic]

The IpOptionsAction property gets or sets a value from the FpcIpOptionsAction enumerated type that specifies whether packets will be allowed or denied with consideration of the IP options included in them.

Property IpOptionsAction As FpcIpOptionsAction

Property Value

Value from the FpcIpOptionsAction enumerated type that specifies whether packets will be allowed or denied with consideration of the IP options included in them.

Remarks

This property is read/write.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCIpOptions


IFPCIpOptions | FPCIpOptions IsSelected (2 Parameters) method [ISA Server 2004]

IFPCIpOptions::IsSelected[C++]

FPCIpOptions.IsSelected [Visual Basic]

[C++]

The IsSelected method queries whether the specified IP option is selected.

HRESULT IsSelected(
  long IpOption,
  VARIANT_BOOL* pfSelected
);

Parameters

IpOption
[in] A 32-bit integer that specifies the IP option.
pfSelected
[out] Pointer to a Boolean value that is set on return to VARIANT_TRUE if the specified IP option is selected, or to VARIANT_FALSE if the specified IP option is cleared.

Return Values

This method returns S_OK if the call is successful; otherwise, it returns an error code.
[Visual Basic]

The IsSelected method queries whether the specified IP option is selected.

Function IsSelected( _
  ByVal IpOption As Long _
) As Boolean

Parameters

IpOption
[in] A 32-bit integer that specifies the IP option.

Return Values

Boolean value that is set to True if the specified IP option is selected, or to False if the specified IP option is cleared. If the call is unsuccessful, an error is raised that can be intercepted by using an error handler.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCIpOptions


IFPCIpOptions | FPCIpOptions Select(Long) method [ISA Server 2004]

IFPCIpOptions::Select[C++]

FPCIpOptions.Select [Visual Basic]

[C++]

The Select method selects the specified IP option.

HRESULT Select(
  long IpOption
);

Parameters

IpOption
[in] A 32-bit integer value that specifies the IP option to be selected.

Return Values

This method returns S_OK if the call is successful; otherwise, it returns an error code.
[Visual Basic]

The Select method selects the specified IP option.

Sub Select( _
  ByVal IpOption As Long _
)

Parameters

IpOption
[in] A 32-bit integer value that specifies the IP option to be selected.

Return Values

This method has no return values. If the call is unsuccessful, an error is raised that can be intercepted by using an error handler.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCIpOptions


IFPCIpOptions | FPCIpOptions SelectAll method [ISA Server 2004]

IFPCIpOptions::SelectAll[C++]

FPCIpOptions.SelectAll [Visual Basic]

[C++]

The SelectAll method selects all of the IP options.

HRESULT SelectAll();

Parameters

This method has no parameters.

Return Values

This method returns S_OK if the call is successful; otherwise, it returns an error code.
[Visual Basic]

The SelectAll method selects all of the IP options.

Sub SelectAll()

Parameters

This method has no parameters.

Return Values

This method has no return values. If the call is unsuccessful, an error is raised that can be intercepted by using an error handler.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCIpOptions


FPCIpRangeEntry object [ISA Server 2004]

FPCIpRangeEntry

The FPCIpRangeEntry object defines a range of IP addresses. The lower and upper bounds of the range are set when the object is created by the Add method of an FPCIpRangeSet collection, and they can be modified by calling the SetIps method.

The FPCIpRangeEntry object is typically an element of an FPCIpRangeSet collection.

Click here to see the ISA Server object hierarchy.

Methods

The FPCIpRangeEntry object defines the following method.

Method | Description
SetIps | Sets the lower and upper bounds of the IP address range.

Properties

The FPCIpRangeEntry object has the following properties.

Property | Description
IP_From | Gets the lower bound of the IP address range.
IP_To | Gets the upper bound of the IP address range.

Remarks

This object implements the IFPCIpRangeEntry interface.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

COM Objects


IFPCIpRangeEntry | FPCIpRangeEntry IP_From(BSTR) property [ISA Server 2004]

IP_From Property of IFPCIpRangeEntry[C++]

FPCIpRangeEntry.IP_From [Visual Basic]

[C++]

The IP_From property gets the lower bound of the IP address range.

HRESULT get_IP_From(
  BSTR* pbstrFrom
);

Parameters

pbstrFrom
Pointer to a BSTR that is set on return to a string value specifying the lower bound of the IP address range.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only. The lower and upper bounds of the IP address range can be modified by calling the SetIps method.

[Visual Basic]

The IP_From property gets the lower bound of the IP address range.

Property IP_From As String

Property Value

String that specifies the lower bound of the IP address range.

Remarks

This property is read-only. The lower and upper bounds of the IP address range can be modified by calling the SetIps method.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCIpRangeEntry


IFPCIpRangeEntry | FPCIpRangeEntry IP_To(BSTR) property [ISA Server 2004]

IP_To Property of IFPCIpRangeEntry[C++]

FPCIpRangeEntry.IP_To [Visual Basic]

[C++]

The IP_To property gets the upper bound of the IP address range.

HRESULT get_IP_To(
  BSTR* pbstrTo
);

Parameters

pbstrTo
Pointer to a BSTR that is set on return to a string value specifying the upper bound of the IP address range.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only. The lower and upper bounds of the IP address range can be modified by calling the SetIps method.

[Visual Basic]

The IP_To property gets the upper bound of the IP address range.

Property IP_To As String

Property Value

String that specifies the upper bound of the IP address range.

Remarks

This property is read-only. The lower and upper bounds of the IP address range can be modified by calling the SetIps method.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCIpRangeEntry


IFPCIpRangeEntry | FPCIpRangeEntry SetIps method [ISA Server 2004]

IFPCIpRangeEntry::SetIps[C++]

FPCIpRangeEntry.SetIps [Visual Basic]

[C++]

The SetIps method sets the lower and upper bounds of the IP address range.

HRESULT SetIps(
  BSTR newFrom,
  BSTR newTo
);

Parameters

newFrom
[in] String value that specifies the lower bound of the IP range.
newTo
[in] String value that specifies the upper bound of the IP range.

Return Values

This method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This method modifies the IP_From and IP_To properties. The lower and upper bounds of the IP address range are initially set by the values passed to the IP_From and IP_To parameters of the Add method of an FPCIpRangeSet collection when the object is created.

[Visual Basic]

The SetIps method sets the lower and upper bounds of the IP address range.

Sub SetIps( _
  ByVal newFrom As String, _
  ByVal newTo As String _
)

Parameters

newFrom
[in] String value that specifies the lower bound of the IP range.
newTo
[in] String value that specifies the upper bound of the IP range.

Return Values

This method has no return values. If the call is unsuccessful, an error is raised that can be intercepted by using an error handler.

Remarks

This method modifies the IP_From and IP_To properties. The lower and upper bounds of the IP address range are initially set by the values passed to the IP_From and IP_To parameters of the Add method of an FPCIpRangeSet collection when the object is created.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCIpRangeEntry


FPCIpRangeSet collection [ISA Server 2004]

FPCIpRangeSet Collection

The FPCIpRangeSet collection holds a set of FPCIpRangeEntry objects that define IP address ranges. This collection is used to specify the following sets of IP address ranges:

  • The ranges of IP addresses in a client configuration script that the Web browsers on Firewall clients can access directly, bypassing the Microsoft Firewall service.
  • The set of IP address ranges that define the Internal network or a user-defined network.
  • The static address pool for a virtual private network (VPN) gateway.

This collection can be accessed through the DirectIPDestinations property of an FPCClientAutoScript object, the IpRangeSet property of an FPCNetwork object, or the StaticAddressPool property of an FPCVpnConfiguration object.

Click here to see the ISA Server object hierarchy.

Inheritance

This collection inherits from the FPCPersist object, which contains methods and properties related to the persistent storage of an object's data. They include methods for exporting the object's data to and importing it from an XML document.

Methods

The FPCIpRangeSet collection defines the following methods.

Method | Description
Add | Creates a new FPCIpRangeEntry object in the collection and returns a reference to it.
IsIpInSet | Determines whether the specified IP address is included in any of the IP address ranges in the collection.
IsRangeContained | Determines whether the specified IP address range is contained within any of the IP address ranges in the collection.
IsRangeIntersect | Determines whether the specified IP address range intersects any of the IP address ranges in the collection.
Item | Retrieves the FPCIpRangeEntry object specified by its index or by the upper and lower bounds of its IP address range from the collection.
Remove | Removes the FPCIpRangeEntry object specified by its index or by the upper and lower bounds of its IP address range from the collection.
RemoveAll | Removes all of the FPCIpRangeEntry objects from the collection.

Properties

The FPCIpRangeSet collection has the following properties.

Property | Description
_NewEnum | Gets an enumerator object for the collection.
Count | Gets the number of FPCIpRangeEntry objects in the collection.

Methods Inherited from FPCPersist

Name | Description
CancelWaitForChanges | Cancels the registration established by the WaitForChanges method (for use in C and C++ programming only).
CanImport | Returns a Boolean value that indicates whether the properties of the collection and its elements can be imported from the specified XML document.
Export | Writes the stored values of all the properties of the collection and its elements to the specified XML document.
ExportToFile | Writes the stored values of all the properties of the collection and its elements to the specified XML file.
GetServiceRestartMask | Retrieves a 32-bit bitmask of the FpcServices enumerated type that specifies which services need to be restarted for currently unsaved changes to take effect.
Import | Copies the values of all the properties of the collection and its elements from the specified XML document to persistent storage.
ImportFromFile | Copies the values of all the properties of the collection and its elements from the specified XML file to persistent storage.
LoadDocProperties | Provides the XML document's properties so that you can know what information can be imported from the document.
Refresh | Reads the values of all the properties of the collection and its elements from persistent storage, overwriting any changes that have not been saved.
Save | Writes the current values of all the properties of the collection and its elements to persistent storage.
WaitForChanges | Registers to wait for an event indicating that the contents of the object have changed (for use in C and C++ programming only).

Properties Inherited from FPCPersist

Name | Description
PersistentName | Gets the persistent name of the collection. The persistent name of an object is a name that is unique for the object at the respective level of the COM object hierarchy.
VendorParametersSets | Gets an FPCVendorParametersSets collection that can hold sets of custom data for extending the collection.

Remarks

This collection implements the IFPCIpRangeSet interface.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

COM Objects


IFPCIpRangeSet | FPCIpRangeSet _NewEnum(IUnknown) property [ISA Server 2004]

_NewEnum Property of IFPCIpRangeSet[C++]

FPCIpRangeSet._NewEnum [Visual Basic]

[C++]

The _NewEnum property gets an enumerator object for the collection. An enumerator object provides serial access to the elements of the collection.

HRESULT get__NewEnum(
  IUnknown* ppEnum
);

Parameters

ppEnum
Address of an interface pointer that on return points to the IUnknown interface of an enumerator object that implements an IEnumVARIANT interface for the collection. An interface pointer to the IEnumVARIANT interface of the enumerator object can be retrieved by calling QueryInterface on the IUnknown interface returned.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The _NewEnum property gets an enumerator object for the collection. An enumerator object provides serial access to the elements of the collection.

Property _NewEnum As IUnknown

Property Value

Reference to an enumerator object that provides serial access to the elements of the collection.

Remarks

This property is read-only.

In Visual Basic and VBScript, this property is used implicitly in For Each...In...Next constructs.

Example Code

This VBScript script displays all of the IP address ranges defining the Internal network for an FPCArray object. It does not include error handling.

' Create the root object.
Dim root  ' The FPCLib.FPC root object
Set root = CreateObject("FPC.Root")

' Declare the other objects needed.
Dim array          ' An FPCArray object
Dim iprangeset     ' An FPCIpRangeSet collection
Dim iprangeentry   ' An FPCIpRangeEntry object

' Get references to the array object
' and the IP range set.
Set array = root.GetContainingArray()
Set iprangeset = array.NetworkConfiguration.Networks.Item("Internal").IpRangeSet

' Display all of the IP address ranges defining the Internal network.
For Each iprangeentry In iprangeset
    WScript.Echo "IP address range: " & iprangeentry.IP_From & "-" & iprangeentry.IP_To
Next

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCIpRangeSet


IFPCIpRangeSet | FPCIpRangeSet Add (3 Parameters) method [ISA Server 2004]

IFPCIpRangeSet::Add[C++]

FPCIpRangeSet.Add [Visual Basic]

[C++]

The Add method creates a new FPCIpRangeEntry object in the collection and returns a reference to it. The Save method must be called to save the new FPCIpRangeEntry object to persistent storage.

HRESULT Add(
  BSTR Ip_From,
  BSTR Ip_To,
  IFPCIpRangeEntry** ppNewObj
);

Parameters

Ip_From
[in] Required. BSTR that specifies the lower bound of the IP address range.
Ip_To
[in] Required. BSTR that specifies the upper bound of the IP address range.
ppNewObj
[out] Address of an interface pointer that on return points to the new IFPCIpRangeEntry interface created.

Return Values

This method can return one of the following:

  • S_OK, indicating that the operation succeeded.
  • An error code, indicating that the operation failed. In this case, the [out] parameter returned is a null object.

[Visual Basic]

The Add method creates a new FPCIpRangeEntry object in the collection and returns a reference to it. The Save method must be called to save the new FPCIpRangeEntry object to persistent storage.

Function Add( _
  ByVal Ip_From As String, _
  ByVal Ip_To As String _
) As FPCIpRangeEntry

Parameters

Ip_From
[in] Required. String that specifies the lower bound of the IP address range.
Ip_To
[in] Required. String that specifies the upper bound of the IP address range.

Return Values

This method returns a reference to the FPCIpRangeEntry object if successful. Otherwise, an error is raised that can be intercepted by using an error handler.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCIpRangeSet


IFPCIpRangeSet | FPCIpRangeSet Count(long) property [ISA Server 2004]

Count Property of IFPCIpRangeSet[C++]

FPCIpRangeSet.Count [Visual Basic]

[C++]

The Count property gets the number of FPCIpRangeEntry objects in the collection.

HRESULT get_Count(
  long* plCount
);

Parameters

plCount
Pointer to a variable that on return receives a 32-bit integer specifying the number of number of FPCIpRangeEntry objects in the collection.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The Count property gets the number of FPCIpRangeEntry objects in the collection.

Property Count As Long

Property Value

A 32-bit integer that specifies the number of number of FPCIpRangeEntry objects in the collection.

Remarks

This property is read-only.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCIpRangeSet


IFPCIpRangeSet | FPCIpRangeSet IsIpInSet (2 Parameters) method [ISA Server 2004]

IFPCIpRangeSet::IsIpInSet[C++]

FPCIpRangeSet.IsIpInSet [Visual Basic]

[C++]

The IsIpInSet method determines whether the specified IP address is included in any of the IP address ranges in the collection.

HRESULT IsIpInSet(
  BSTR IpStr,
  VARIANT_BOOL* pfIsIpInSet
);

Parameters

IpStr
[in] Required. BSTR that specifies the IP address.
pfIsIpInSet
[out] Pointer to a Boolean variable that is set on return to VARIANT_TRUE if the specified IP address is included in any IP address range in the collection, or to VARIANT_FALSE if the specified IP address is not included in any IP address range in the collection.

Return Values

This method returns S_OK if the call is successful; otherwise, it returns an error code.

[Visual Basic]

The IsIpInSet method determines whether the specified IP address is included in any of the IP address ranges in the collection.

Function IsIpInSet( _
  ByVal IpStr As String _
) As Boolean

Parameters

IpStr
[in] Required. String that specifies the IP address.

Return Values

This method returns a Boolean value that is set to True if the specified IP address is included in any IP address range in the collection, or to False if the specified IP address is not included in any IP address range in the collection. If the call is unsuccessful, an error is raised that can be intercepted by using an error handler.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCIpRangeSet


IFPCIpRangeSet | FPCIpRangeSet IsRangeContained method [ISA Server 2004]

IFPCIpRangeSet::IsRangeContained[C++]

FPCIpRangeSet.IsRangeContained [Visual Basic]

[C++]

The IsRangeContained method determines whether the specified IP address range is contained within any of the IP address ranges in the collection.

HRESULT IsRangeContained(
  BSTR IpFrom,
  BSTR IpTo,
  VARIANT_BOOL* pfIsIpInSet
);

Parameters

IpFrom
[in] Required. BSTR that specifies the lower bound of the IP address range.
IpTo
[in] Required. BSTR that specifies the upper bound of the IP address range.
pfIsIpInSet
[out] Pointer to a Boolean variable that is set on return to VARIANT_TRUE if the specified IP address range is contained within any of the IP address ranges in the collection, or to VARIANT_FALSE if the specified IP address range is not contained within any of the IP address ranges in the collection.

Return Values

This method returns S_OK if the call is successful; otherwise, it returns an error code.
[Visual Basic]

The IsRangeContained method determines whether the specified IP address range is contained within any of the IP address ranges in the collection.

Function IsRangeContained( _
  ByVal IpFrom As String, _
  ByVal IpTo As String _
) As Boolean

Parameters

IpFrom
[in] Required. String that specifies the lower bound of the IP address range.
IpTo
[in] Required. String that specifies the upper bound of the IP address range.

Return Values

This method returns a Boolean value that is set to True if the specified IP address range is contained within any of the IP address ranges in the collection, or to False if the specified IP address range is not contained within any of the IP address ranges in the collection. If the call is unsuccessful, an error is raised that can be intercepted by using an error handler.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCIpRangeSet


IFPCIpRangeSet | FPCIpRangeSet IsRangeIntersect method [ISA Server 2004]

IFPCIpRangeSet::IsRangeIntersect[C++]

FPCIpRangeSet.IsRangeIntersect [Visual Basic]

[C++]

The IsRangeIntersect method determines whether the specified IP address range intersects any of the IP address ranges in the collection.

HRESULT IsRangeIntersect(
  BSTR IpFrom,
  BSTR IpTo,
  VARIANT_BOOL* pfIsIpInSet
);

Parameters

IpFrom
[in] Required. BSTR that specifies the lower bound of the IP address range.
IpTo
[in] Required. BSTR that specifies the upper bound of the IP address range.
pfIsIpInSet
[out] Pointer to a Boolean variable that is set on return to VARIANT_TRUE if the specified IP address range intersects any of the IP address ranges in the collection, or to VARIANT_FALSE if the specified IP address range does not intersect any of the IP address ranges in the collection.

Return Values

This method returns S_OK if the call is successful; otherwise, it returns an error code.
[Visual Basic]

The IsRangeIntersect method determines whether the specified IP address range intersects any of the IP address ranges in the collection.

Function IsRangeIntersect( _
  ByVal IpFrom As String, _
  ByVal IpTo As String _
) As Boolean

Parameters

IpFrom
[in] Required. String that specifies the lower bound of the IP address range.
IpTo
[in] Required. String that specifies the upper bound of the IP address range.

Return Values

This method returns a Boolean value that is set to True if the specified IP address range intersects any of the IP address ranges in the collection, or to False if the specified IP address range does not intersect any of the IP address ranges in the collection. If the call is unsuccessful, an error is raised that can be intercepted by using an error handler.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCIpRangeSet


IFPCIpRangeSet | FPCIpRangeSet Item (3 Parameters) method [ISA Server 2004]

IFPCIpRangeSet::Item[C++]

FPCIpRangeSet.Item [Visual Basic]

[C++]

The Item method retrieves the IFPCIpRangeEntry interface specified by its index or by the upper and lower bounds of its IP address range from the collection.

HRESULT Item(
  VARIANT IndexOrIP_From,
  BSTR IP_To,
  IFPCIpRangeEntry** ppItem
);

Parameters

IndexOrIP_From
[in] Required. One-based index or lower bound of the IP address range of the object to retrieve.
IP_To
[in, optional] Upper bound of the IP address range of the object to retrieve. This parameter must be specified if the IndexOrIP_From parameter is set to the lower bound of an IP address range. The default value is NULL.
ppItem
[out] Address of a variable that receives a pointer to the IFPCIpRangeEntry interface requested.

Return Values

This method can return one of the following:

  • S_OK, indicating that the operation succeeded.
  • An error code, indicating that the operation failed. In this case, the [out] parameter returned is a null object.

[Visual Basic]

The Item method retrieves the FPCIpRangeEntry object specified by its index or by the upper and lower bounds of its IP address range from the collection.

Function Item( _
  ByVal IndexOrIP_From As Variant, _
  [ ByVal IP_To As String ] _
) As FPCIpRangeEntry

Parameters

IndexOrIP_From
[in] Required. One-based index or lower bound of the IP address range of the object to retrieve.
IP_To
[in, optional] Upper bound of the IP address range of the object to retrieve. This parameter must be specified if the IndexOrIP_From parameter is set to the lower bound of an IP address range. The default value is NULL.

Return Values

This method returns a reference to the FPCIpRangeEntry object requested if successful. Otherwise, an error is raised that can be intercepted by using an error handler.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCIpRangeSet


IFPCIpRangeSet | FPCIpRangeSet Remove(Variant,String) method [ISA Server 2004]

IFPCIpRangeSet::Remove[C++]

FPCIpRangeSet.Remove [Visual Basic]

[C++]

The Remove method removes the FPCIpRangeEntry object specified by its index or by the upper and lower bounds of its IP address range from the collection.

HRESULT Remove(
  VARIANT IndexOrIP_From,
  BSTR IP_To
);

Parameters

IndexOrIP_From
[in] Required. One-based index of the object to remove or the lower bound of its IP address range.
IP_To
[in, optional] Upper bound of the IP address range of the object to remove. This parameter must be specified when the IndexOrIP_From parameter is set to the lower bound of an IP address range. The default value is NULL.

Return Values

This method returns S_OK if the call is successful; otherwise, it returns an error code.
[Visual Basic]

The Remove method removes the FPCIpRangeEntry object specified by its index or by the upper and lower bounds of its IP address range from the collection.

Sub Remove( _
  ByVal IndexOrIP_From As Variant, _
  [ ByVal IP_To As String ] _
)

Parameters

IndexOrIP_From
[in] Required. One-based index of the object to remove or the lower bound of its IP address range.
IP_To
[in, optional] Upper bound of the IP address range of the object to remove. This parameter must be specified when the IndexOrIP_From parameter is set to the lower bound of an IP address range. The default value is NULL.

Return Values

This method has no return values. If the call is unsuccessful, an error is raised that can be intercepted by using an error handler.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCIpRangeSet


IFPCIpRangeSet | FPCIpRangeSet RemoveAll method [ISA Server 2004]

IFPCIpRangeSet::RemoveAll[C++]

FPCIpRangeSet.RemoveAll [Visual Basic]

[C++]

The RemoveAll method removes all of the FPCIpRangeEntry objects from the collection.

HRESULT RemoveAll();

Parameters

This method has no parameters.

Return Values

This method returns S_OK if the call is successful; otherwise, it returns an error code.

[Visual Basic]

The RemoveAll method removes all of the FPCIpRangeEntry objects from the collection.

Sub RemoveAll()

Parameters

This method has no parameters.

Return Values

This method has no return values. If the call is unsuccessful, an error is raised that can be intercepted by using an error handler.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCIpRangeSet


FPCIPsOnNetworks collection [ISA Server 2004]

FPCIPsOnNetworks Collection

The FPCIPsOnNetworks collection provides access to a group of FPCIPOnNetwork objects. Each FPCIPOnNetwork object represents one or more IP addresses on which the ISA Server computer listens for requests from a particular network on behalf of a server published by a publishing rule, or on which a Web listener on the ISA Server computer listens for Web requests from a particular network.

This object is typically accessed through the IPsOnNetworks property of an FPCServerPublishingProperties object or through the IPsOnNetworks property of an FPCWebListener object.

Click here to see the ISA Server object hierarchy.

Methods

The FPCIPsOnNetworks collection defines the following methods.

Method | Description
Add | Adds a new FPCIPOnNetwork object to the collection.
Item | Retrieves the given FPCIPOnNetwork object from the collection.
Refresh | Recursively reads all the properties of the collection and its elements from persistent storage, overwriting any changes that have not been saved.
Remove | Removes an FPCIPOnNetwork object from the collection.
Save | Recursively writes the current values of all the properties of the collection and its elements, including all the properties of its subobjects, to persistent storage.

Properties

The FPCIPsOnNetworks collection has the following properties.

Property | Description
_NewEnum | Gets an enumerator object for the collection.
Count | Gets the number of FPCIPOnNetwork objects in the collection.

Remarks

This collection implements the IFPCIPsOnNetworks interface.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

COM Objects


IFPCIPsOnNetworks | FPCIPsOnNetworks _NewEnum property [ISA Server 2004]

_NewEnum Property of IFPCIPsOnNetworks[C++]

FPCIPsOnNetworks._NewEnum [Visual Basic]

[C++]

The _NewEnum property gets an enumerator object for the collection. An enumerator object provides serial access to the elements of the collection.

HRESULT get__NewEnum(
  IUnknown* ppEnum
);

Parameters

ppEnum
Address of an interface pointer that on return points to the IUnknown interface of an enumerator object that implements an IEnumVARIANT interface for the collection. An interface pointer to the IEnumVARIANT interface of the enumerator object can be retrieved by calling QueryInterface on the IUnknown interface returned.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The _NewEnum property gets an enumerator object for the collection. An enumerator object provides serial access to the elements of the collection.

Property _NewEnum As IUnknown

Property Value

Reference to an enumerator object that provides serial access to the elements of the collection.

Remarks

This property is read-only.

In Visual Basic and VBScript, this property is used implicitly in For Each...In...Next constructs.

Example Code

This VBScript script displays all of the IP addresses on which a specific Web listener listens. This example does not include error handling.

' Create the root object.
Dim root  ' The FPCLib.FPC root object
Set root = CreateObject("FPC.Root")

' Declare the other objects needed and a string.
Dim array         ' An FPCArray object
Dim weblisteners  ' An FPCWebListeners collection
Dim weblistener   ' An FPCWebListener object
Dim iponnetwork   ' An FPCIPOnNetwork object
Dim ipaddresses   ' An FPCIPAddresses collection
Dim ipaddress     ' A string

' Get references to the array object
' and the IP addresses collection.
Set array = root.GetContainingArray()
Set weblisteners = array.RuleElements.WebListeners

' If at least one Web listener is defined in the Web
' listeners collection, display all the IP addresses on
' which the first Web listener found listens.
On Error Resume Next
Set weblistener = weblisteners.Item(1)
If Err.Number = 0 Then
    For Each iponnetwork In weblistener.IPsOnNetworks
        Set ipaddresses = iponnetwork.IPAddresses
        For Each ipaddress In ipaddresses
            WScript.Echo "IP Address: " & ipaddress
        Next
    Next
End If

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCIPsOnNetworks


IFPCIPsOnNetworks | FPCIPsOnNetworks Add (4 Parameters) method [ISA Server 2004]

IFPCIPsOnNetworks::Add[C++]

FPCIPsOnNetworks.Add [Visual Basic]

[C++]

The Add method creates a new FPCIPOnNetwork object in the collection and returns a reference to it.

HRESULT Add(
  BSTR NetworkName,
  FpcIPSelectionMethods IPSelectionMethod,
  BSTR IP,
  IFPCIPOnNetwork** ppNewIPOnNetwork
);

Parameters

NetworkName
[in] Required. BSTR that specifies the name of the network.
IPSelectionMethod
[in, optional] Value from the FpcIPSelectionMethods enumerated type that indicates whether all of the IP addresses on the ISA Server computers, only the default IP address, or only the IP address specified in the IP parameter, will be selected. The default value indicates that all of the IP addresses on the ISA Server computers are selected.
IP
[in, optional] BSTR that specifies the selected IP address. This parameter must be specified if the IPSelectionMethod parameter is set to fpcSpecifiedIPAddress, and it is ignored if the IPSelectionMethod parameter is not set or is set to any other value. The default value is an empty BSTR.
ppNewIPOnNetwork
[out] Address of an interface pointer that on return points to the new IFPCIPOnNetwork interface created.

Return Values

This method can return one of the following:

  • S_OK, indicating that the operation succeeded.
  • An error code, indicating that the operation failed. In this case, the [out] parameter returned is a null object.

[Visual Basic]

The Add method creates a new FPCIPOnNetwork object in the collection and returns a reference to it.

Function Add( _
  ByVal NetworkName As String, _
  [ ByVal IPSelectionMethod As FpcIPSelectionMethods ], _
  [ ByVal IP As String ] _
) As FPCIPOnNetwork

Parameters

NetworkName
[in] Required. String that specifies the name of the network.
IPSelectionMethod
[in, optional] Value from the FpcIPSelectionMethods enumerated type that indicates whether all of the IP addresses on the ISA Server computers, only the default IP address, or only the IP address specified in the IP parameter, will be selected. The default value indicates that all of the IP addresses on the ISA Server computers are selected.
IP
[in, optional] String that specifies the selected IP address. This parameter must be specified if the IPSelectionMethod parameter is set to fpcSpecifiedIPAddress, and it is ignored if the IPSelectionMethod parameter is not set or is set to any other value. The default value is an empty string.

Return Values

This method returns a reference to an FPCIPOnNetwork object if successful. Otherwise, an error is raised that can be intercepted by using an error handler.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCIPsOnNetworks


IFPCIPsOnNetworks | FPCIPsOnNetworks Count(long) property [ISA Server 2004]

Count Property of IFPCIPsOnNetworks[C++]

FPCIPsOnNetworks.Count [Visual Basic]

[C++]

The Count property gets the number of FPCIPOnNetwork objects in the collection.

HRESULT get_Count(
  long* plCount
);

Parameters

plCount
Pointer to a variable that on return receives a 32-bit integer specifying the number of FPCIPOnNetwork objects in the collection.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The Count property gets the number of FPCIPOnNetwork objects in the collection.

Property Count As Long

Property Value

A 32-bit integer that specifies the number of FPCIPOnNetwork objects in the collection.

Remarks

This property is read-only.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCIPsOnNetworks


IFPCIPsOnNetworks | FPCIPsOnNetworks Item method [ISA Server 2004]

IFPCIPsOnNetworks::Item[C++]

FPCIPsOnNetworks.Item [Visual Basic]

[C++]

The Item method retrieves the requested IFPCIPOnNetwork interface from the collection.

HRESULT Item(
  VARIANT IndexOrNetwork,
  IFPCIPOnNetwork** ppIPOnNetwork
);

Parameters

IndexOrNetwork
Required. Network name or one-based index of the object to retrieve.
ppIPOnNetwork
[out] Address of an interface pointer that on return points to the IFPCIPOnNetwork interface requested.

Return Values

The method can return one of the following:

  • S_OK, indicating that the operation succeeded.
  • An error code, indicating that the operation failed. In this case, the [out] parameter returned is a null object.

[Visual Basic]

The Item method retrieves the requested FPCIPOnNetwork object from the collection.

Function Item( _
  ByVal IndexOrNetwork As Variant _
) As FPCIPOnNetwork

Parameters

IndexOrNetwork
Required. Network name or one-based index of the object to retrieve.

Return Values

This method returns a reference to the FPCIPOnNetwork object requested if successful. Otherwise, an error is raised that can be intercepted by using an error handler.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCIPsOnNetworks


IFPCIPsOnNetworks | FPCIPsOnNetworks Refresh method [ISA Server 2004]

IFPCIPsOnNetworks::Refresh[C++]

FPCIPsOnNetworks.Refresh [Visual Basic]

[C++]

The Refresh method recursively reads all the properties of the collection and its elements from persistent storage, discarding any changes that have not been saved.

HRESULT Refresh();

Parameters

This method has no parameters.

Return Values

This method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

Changes made to this collection or its elements can be saved by calling the Save method of this collection or the Save method of any object containing it.

[Visual Basic]

The Refresh method recursively reads all the properties of the collection and its elements from persistent storage, discarding any changes that have not been saved.

Sub Refresh()

Parameters

This method has no parameters.

Return Values

This method has no return values. If the call is unsuccessful, an error is raised that can be intercepted by using an error handler.

Remarks

Changes made to this collection or its elements can be saved by calling the Save method of this collection or the Save method of any object containing it.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCIPsOnNetworks


IFPCIPsOnNetworks | FPCIPsOnNetworks Remove(Variant) method [ISA Server 2004]

IFPCIPsOnNetworks::Remove[C++]

FPCIPsOnNetworks.Remove [Visual Basic]

[C++]

The Remove method removes the specified FPCIPOnNetwork object from the collection.

HRESULT Remove(
  VARIANT IndexOrNetwork
);

Parameters

IndexOrNetwork
[in] Required. Network name or one-based index of the FPCIPOnNetwork object to remove.

Return Values

This method returns S_OK if the call is successful; otherwise, it returns an error code.
[Visual Basic]

The Remove method removes the specified FPCIPOnNetwork object from the collection.

Sub Remove( _
  ByVal IndexOrNetwork As Variant _
)

Parameters

IndexOrNetwork
[in] Required. Network name or one-based index of the FPCIPOnNetwork object to remove.

Return Values

This method has no return values. If the call is unsuccessful, an error is raised that can be intercepted by using an error handler.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCIPsOnNetworks


IFPCIPsOnNetworks | FPCIPsOnNetworks Save method [ISA Server 2004]

IFPCIPsOnNetworks::Save[C++]

FPCIPsOnNetworks.Save [Visual Basic]

[C++]

The Save method recursively writes the current values of all the properties of the collection and its elements, including all the properties of its subobjects, to persistent storage. It is important to remember that any changes made by scripts and programs are not saved until after the Save method is called.

HRESULT Save(
  VARIANT_BOOL fResetRequiredServices,
  VARIANT_BOOL fReloadConfiguration
);

Parameters

fResetRequiredServices
[in, optional] Boolean value that indicates whether to restart the services that need to be restarted for any of the changes saved to take effect. The default value is VARIANT_FALSE.
fReloadConfiguration
[in, optional] Boolean value that indicates whether the call will include synchronous reloading of all changes that can be applied dynamically without restarting services. The default value is VARIANT_TRUE.

Return Values

This method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

Configuration changes are applied only after the new settings are written to persistent storage and reloaded to the services that use them. Most changes can be applied dynamically without restarting any services. However, some changes can take effect only after the Microsoft Firewall service is restarted. For more information, see Restarting Services after Configuration Changes.

ISA Server maintains a bitmask that specifies which services need to be started for currently unsaved changes to take effect. This bitmask can be retrieved by calling the GetServiceRestartMask method on an object that contains this object as a subobject. Calling the Save method clears all of the bits in this bitmask even if the fResetRequiredServices parameter is set to VARIANT_FALSE.

If the fReloadConfiguration parameter is set to VARIANT_FALSE the current values will be written to persistent storage without updating the configuration being used by the ISA Server services. The configuration used by each service will not be updated until the service is restarted or the new settings are reloaded by another call to Save.

[Visual Basic]

The Save method recursively writes the current values of all the properties of the collection and its elements, including all the properties of its subobjects, to persistent storage. It is important to remember that any changes made by scripts and programs are not saved until after the Save method is called.

Sub Save( _
  [ ByVal fResetRequiredServices As Boolean ], _
  [ ByVal fReloadConfiguration As Boolean ] _
)

Parameters

fResetRequiredServices
[in, optional] Boolean value that indicates whether to restart the services that need to be restarted for any of the changes saved to take effect. The default value is False.
fReloadConfiguration
[in, optional] Boolean value that indicates whether the call will include synchronous reloading of all the saved configuration changes that can be applied dynamically without restarting services. The default value is True.

Return Values

This method has no return values. If the call is unsuccessful, an error is raised that can be intercepted by using an error handler.

Remarks

Configuration changes are applied only after the new settings are written to persistent storage and reloaded to the services that use them. Most changes can be applied dynamically without restarting any services. However, some changes can take effect only after the Microsoft Firewall service is restarted. For more information, see Restarting Services after Configuration Changes.

ISA Server maintains a bitmask that specifies which services need to be started for currently unsaved changes to take effect. This bitmask can be retrieved by calling the GetServiceRestartMask method on an object that contains this object as a subobject. Calling the Save method clears all of the bits in this bitmask even if the fResetRequiredServices parameter is set to False.

If the fReloadConfiguration parameter is set to False the current values will be written to persistent storage without updating the configuration being used by the ISA Server services. The configuration used by each service will not be updated until the service is restarted or the new settings are reloaded by another call to Save.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCIPsOnNetworks


FPCLDT collection [ISA Server 2004]

FPCLDT Collection

The FPCLDT collection provides access to all the FPCLDTEntry objects for a network. Through this collection you can add, delete, and modify individual entries of the local domain table (LDT).

An LDT lists servers in a network behind the ISA Server computer. Each entry in the table is stored as an individual FPCLDTEntry object and may represent one of the following:

  • A single computer, which is specified by its fully qualified domain name (FQDN).
  • All the computers in a domain, which are specified by a string of the form *.<domain_name>.
  • All the computers in all domains in the network, which are specified by an asterisk (*).

Firewall Client computers maintain a copy of the LDT for the local network, which is updated regularly. They may be configured to use the LDT for the local network to decide whether a request can sent directly to a destination that is included in the LDT, as it refers to a computer within the local network, or has to be sent to the ISA Server computer for forwarding to its destination by the Microsoft Firewall service.

The FPCLDT collection is typically accessed through the LDT property of an FPCNetwork object.

Click here to see the ISA Server object hierarchy.

Inheritance

This collection inherits from the FPCPersist object, which contains methods and properties related to the persistent storage of an object's data. They include methods for exporting the object's data to and importing it from an XML document.

Methods

The FPCLDT collection defines the following methods.

Method | Description
Add | Creates a new FPCLDTEntry object in the collection and returns a reference to it.
Item | Retrieves the requested FPCLDTEntry object from the collection.
Remove | Removes the specified FPCLDTEntry object from the collection.

Properties

The FPCLDT collection has the following properties.

Property | Description
_NewEnum | Gets an enumerator object for the collection.
Count | Gets the number of FPCLDTEntry objects in the collection.

Methods Inherited from FPCPersist

Name | Description
CancelWaitForChanges | Cancels the registration established by the WaitForChanges method (for use in C and C++ programming only).
CanImport | Returns a Boolean value that indicates whether the properties of the collection and its elements can be imported from the specified XML document.
Export | Writes the stored values of all the properties of the collection and its elements to the specified XML document.
ExportToFile | Writes the stored values of all the properties of the collection and its elements to the specified XML file.
GetServiceRestartMask | Retrieves a 32-bit bitmask of the FpcServices enumerated type that specifies which services need to be restarted for currently unsaved changes to take effect.
Import | Copies the values of all the properties of the collection and its elements from the specified XML document to persistent storage.
ImportFromFile | Copies the values of all the properties of the collection and its elements from the specified XML file to persistent storage.
LoadDocProperties | Provides the XML document's properties so that you can know what information can be imported from the document.
Refresh | Reads the values of all the properties of the collection and its elements from persistent storage, overwriting any changes that have not been saved.
Save | Writes the current values of all the properties of the collection and its elements to persistent storage.
WaitForChanges | Registers to wait for an event indicating that the contents of the object have changed (for use in C and C++ programming only).

Properties Inherited from FPCPersist

Name | Description
PersistentName | Gets the persistent name of the collection. The persistent name of an object is a name that is unique for the object at the respective level of the COM object hierarchy.
VendorParametersSets | Gets an FPCVendorParametersSets collection that can hold sets of custom data for extending the collection.

Remarks

This collection implements the IFPCLDT interface.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

COM Objects


IFPCLDT | FPCLDT _NewEnum(IUnknown) property [ISA Server 2004]

_NewEnum Property of IFPCLDT[C++]

FPCLDT._NewEnum [Visual Basic]

[C++]

The _NewEnum property gets an enumerator object for the collection. An enumerator object provides serial access to the elements of the collection.

HRESULT get__NewEnum(
  IUnknown* ppEnum
);

Parameters

ppEnum
Address of an interface pointer that on return points to the IUnknown interface of an enumerator object that implements an IEnumVARIANT interface for the collection. An interface pointer to the IEnumVARIANT interface of the enumerator object can be retrieved by calling QueryInterface on the IUnknown interface returned.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The _NewEnum property gets an enumerator object for the collection. An enumerator object provides serial access to the elements of the collection.

Property _NewEnum As IUnknown

Property Value

Reference to an enumerator object that provides serial access to the elements of the collection.

Remarks

This property is read-only.

In Visual Basic and VBScript, this property is used implicitly in For Each...In...Next constructs.

Example Code

This VBScript script displays the names of all of the servers included in the local domain table (LDT) for the Internal network. It does not include error handling.

' Create the root object.
Dim root  ' The FPCLib.FPC root object
Set root = CreateObject("FPC.Root")

' Declare the other objects needed.
Dim array      ' An FPCArray object
Dim ldt        ' An FPCLDT collection
Dim ldtentry   ' An FPCLDTEntry object

' Get references to the array object
' and the LDT.
Set array = root.GetContainingArray()
Set ldt = array.NetworkConfiguration.Networks.Item("Internal").LDT

' Display the names of all of the servers included in the LDT.
For Each ldtentry In ldt
    WScript.Echo "IP address range: " & ldtentry.Name
Next

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCLDT


IFPCLDT | FPCLDT Add(String,IFPCLDTEntry) method [ISA Server 2004]

IFPCLDT::Add[C++]

FPCLDT.Add [Visual Basic]

[C++]

The Add method creates a new FPCLDTEntry object in the collection and returns a reference to it. The Save method must be called to save the new FPCLDTEntry object to persistent storage.

HRESULT Add(
  BSTR DomainName,
  IFPCLDTEntry** ppNewLDTEntry
);

Parameters

DomainName
[in] Required. BSTR that specifies the name of the new local domain table (LDT) entry.
ppNewLDTEntry
[out] Address of an interface pointer that on return points to the new IFPCLDTEntry interface created.

Return Values

This method can return one of the following:

  • S_OK, indicating that the operation succeeded.
  • An error code, indicating that the operation failed. In this case, the [out] parameter returned is a null object.

[Visual Basic]

The Add method creates a new FPCLDTEntry object in the collection and returns a reference to it. The Save method must be called to save the new FPCLDTEntry object to persistent storage.

Function Add( _
  ByVal DomainName As String _
) As FPCLDTEntry

Parameters

DomainName
[in] Required. String that specifies the name of the new local domain table (LDT) entry.

Return Values

This method returns a reference to an FPCLDTEntry object if successful. Otherwise, an error is raised that can be intercepted by using an error handler.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCLDT


IFPCLDT | FPCLDT Count(long) property [ISA Server 2004]

Count Property of IFPCLDT[C++]

FPCLDT.Count [Visual Basic]

[C++]

The Count property gets the number of FPCLDTEntry objects in the collection.

HRESULT get_Count(
  long* plCount
);

Parameters

plCount
Pointer to a variable that on return receives a 32-bit integer specifying the number of FPCLDTEntry objects in the collection.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The Count property gets the number of FPCLDTEntry objects in the collection.

Property Count As Long

Property Value

A 32-bit integer that specifies the number of FPCLDTEntry objects in the collection.

Remarks

This property is read-only.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCLDT


IFPCLDT | FPCLDT Item(Variant,IFPCLDTEntry) method [ISA Server 2004]

IFPCLDT::Item[C++]

FPCLDT.Item [Visual Basic]

[C++]

The Item method retrieves the requested IFPCLDTEntry interface from the collection.

HRESULT Item(
  VARIANT Index,
  IFPCLDTEntry** ppItem
);

Parameters

Index
Required. Name or one-based index of the object to retrieve.
ppItem
[out] Address of an interface pointer that on return points to the IFPCLDTEntry interface requested.

Return Values

This method can return one of the following:

  • S_OK, indicating that the operation succeeded.
  • An error code, indicating that the operation failed. In this case, the [out] parameter returned is a null object.

[Visual Basic]

The Item method retrieves the requested FPCLDTEntry object from the collection.

Function Item( _
  ByVal Index As Variant _
) As FPCLDTEntry

Parameters

Index
Required. Name or one-based index of the object to retrieve.

Return Values

This method returns a reference to the FPCLDTEntry object requested if successful. Otherwise, an error is raised that can be intercepted by using an error handler.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCLDT


IFPCLDT | FPCLDT Remove(Variant) method [ISA Server 2004]

IFPCLDT::Remove[C++]

FPCLDT.Remove [Visual Basic]

[C++]

The Remove method removes the specified FPCLDTEntry object from the collection.

HRESULT Remove(
  VARIANT Index
);

Parameters

Index
[in] Required. Name or one-based index of the FPCLDTEntry object to remove.

Return Values

This method returns S_OK if the call is successful; otherwise, it returns an error code.
[Visual Basic]

The Remove method removes the specified FPCLDTEntry object from the collection.

Sub Remove( _
  ByVal Index As Variant _
)

Parameters

Index
[in] Required. Name or one-based index of the FPCLDTEntry object to remove.

Return Values

This method has no return values. If the call is unsuccessful, an error is raised that can be intercepted by using an error handler.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCLDT


FPCLDTEntry object [ISA Server 2004]

FPCLDTEntry

The FPCLDTEntry object represents a single entry in a local domain table (LDT). You can modify individual LDT entries by retrieving this object.

An LDT lists servers in a network behind the ISA Server computer. Each FPCLDTEntry object may represent one of the following:

  • A single computer, which is specified by its fully qualified domain name (FQDN).
  • All the computers in a domain, which are specified by a string of the form *.<domain_name>.
  • All the computers in all domains in the network, which are specified by an asterisk (*).

Firewall Client computers maintain a copy of the LDT for the local network, which is updated regularly. They may be configured to use the LDT for the local network to decide whether a request can sent directly to a destination that is included in the LDT, as it refers to a computer within the local network, or has to be sent to the ISA Server computer for forwarding to its destination by the Microsoft Firewall service.

This object is typically an element of an FPCLDT collection.

Click here to see the ISA Server object hierarchy.

Inheritance

This object inherits from the FPCPersist object, which contains methods and properties related to the persistent storage of an object's data. They include methods for exporting the object's data to and importing it from an XML document.

Methods

This object has no methods.

Properties

The FPCLDTEntry object has the following properties.

Property | Description
Description | Gets or sets the description of the LDT entry.
Name | Gets or sets the domain name for one or more servers in the local network.

Methods Inherited from FPCPersist

Name | Description
CancelWaitForChanges | Cancels the registration established by the WaitForChanges method (for use in C and C++ programming only).
CanImport | Returns a Boolean value that indicates whether the object's properties can be imported from the specified XML document.
Export | Writes the stored values of all of the object's properties to the specified XML document.
ExportToFile | Writes the stored values of all of the object's properties to the specified XML file.
GetServiceRestartMask | Retrieves a 32-bit bitmask of the FpcServices enumerated type that specifies which services need to be restarted for currently unsaved changes to take effect.
Import | Copies the values of all of the object's properties from the specified XML document to persistent storage.
ImportFromFile | Copies the values of all of the object's properties from the specified XML file to persistent storage.
LoadDocProperties | Provides the XML document's properties so that you can know what information can be imported from the document.
Refresh | Reads the values of all of the object's properties from persistent storage, overwriting any changes that have not been saved.
Save | Writes the current values of all of the object's properties to persistent storage.
WaitForChanges | Registers to wait for an event indicating that the contents of the object have changed (for use in C and C++ programming only).

Properties Inherited from FPCPersist

Name | Description
PersistentName | Gets the persistent name of the object. The persistent name of an object is a name that is unique for the object at the respective level of the COM object hierarchy.
VendorParametersSets | Gets an FPCVendorParametersSets object that can hold sets of custom data for extending the object.

Remarks

This object implements the IFPCLDTEntry interface.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

COM Objects


IFPCLDTEntry | FPCLDTEntry Description(BSTR,BSTR) property [ISA Server 2004]

Description Property of IFPCLDTEntry[C++]

FPCLDTEntry.Description [Visual Basic]

[C++]

The Description property gets or sets the description of the domain.

HRESULT get_Description(
  BSTR* pbstrDescription
);

HRESULT put_Description(
  BSTR bstrDescription
);

Parameters

pbstrDescription
Pointer to a BSTR that is set on return to a string value specifying the description of the domain.
bstrDescription
BSTR that specifies the description of the domain.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write.

[Visual Basic]

The Description property gets or sets the description of the domain.

Property Description As String

Property Value

String that specifies the description of the domain.

Remarks

This property is read/write.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCLDTEntry


IFPCLDTEntry | FPCLDTEntry Name(BSTR,BSTR) property [ISA Server 2004]

Name Property of IFPCLDTEntry[C++]

FPCLDTEntry.Name [Visual Basic]

[C++]

The Name property gets or sets the domain name for one or more servers in the local network.

HRESULT get_Name(
  BSTR* pbstrName
);

HRESULT put_Name(
  BSTR bstrName
);

Parameters

pbstrName
Pointer to a BSTR that is set on return to a string value specifying the domain name for one or more servers in the local network.
bstrName
BSTR that specifies the domain name for one or more servers in the local network.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write.

The domain name specified in this property may represent one of the following:

  • A single computer, which is specified by its fully qualified domain name (FQDN).
  • All the computers in a domain, which are specified by a string of the form *.<domain_name>.
  • All the computers in all domains in the network, which are specified by an asterisk (*).

[Visual Basic]

The Name property gets or sets the domain name for one or more servers in the local network.

Property Name As String

Property Value

String that specifies the domain name for one or more servers in the local network.

Remarks

This property is read/write.

The domain name specified in this property may represent one of the following:

  • A single computer, which is specified by its fully qualified domain name (FQDN).
  • All the computers in a domain, which are specified by a string of the form *.<domain_name>.
  • All the computers in all domains in the network, which are specified by an asterisk (*).

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCLDTEntry


FPCLog object [ISA Server 2004]

FPCLog

The FPCLog object is used to specify the logging configuration for a specific component. There are three possible logging components:

  • Web proxy logging.
  • Firewall service logging.
  • Simple Mail Transfer Protocol (SMTP) Message Screener logging.

The FPCLog object is typically an element of an FPCLogs collection.

Click here to see the ISA Server object hierarchy.

Inheritance

This object inherits from the FPCPersist object, which contains methods and properties related to the persistent storage of an object's data. They include methods for exporting the object's data to and importing it from an XML document.

Methods

This object has no methods.

Properties

The FPCLog object has the following properties.

Property | Description
ComponentType | Gets a value from the FpcLoggingComponents enumerated type that specifies the component to which the logging configuration refers.
DeleteOldLogsOnLimitExceeded | Gets or sets a Boolean value that indicates whether old log files will be deleted to maintain the total log size below the maximum allowed value, or to maintain the amount of free disk space above the required minimum.
Enabled | Gets or sets a Boolean value that indicates whether logging is enabled.
KeepMinFreeDiskSpace | Gets or sets a Boolean value that indicates whether the lower limit on the free disk space is enforced.
LimitTotalLogSize | Gets or sets a Boolean value that indicates whether the upper limit on the total log size is enforced.
LogDbDataSource | Gets or sets the name of the Structured Query Language (SQL) data source.
LogDbPassword | Sets the password for the SQL table.
LogDbTableName | Gets or sets the name of the SQL table.
LogDbUserName | Gets or sets the user name of the SQL table.
LogFieldSelection | Gets or sets a bitmask in which each bit specifies whether a particular log field is selected for logging.
LogFileDirectory | Gets or sets the full path of the directory containing the text log files.
LogFileDirectoryType | Gets or sets a value from the FpcLogFileDirectoryType enumerated type that indicates the type of path specified for the log files.
LogFileKeepOld | Gets or sets the number of days during which old log files will be retained.
LogFilesCompress | Gets or sets a Boolean value that indicates whether text log files will be compressed.
LogType | Gets or sets a value from the FpcLogType enumerated type that specifies the type of log.
MaxTotalLogSizeGB | Gets or sets the upper limit on the total amount of disk space used to store log files, in gigabytes.
MinFreeDiskSpaceMB | Gets or sets the lower limit on the amount of free disk space, in megabytes.

Methods Inherited from FPCPersist

Name | Description
CancelWaitForChanges | Cancels the registration established by the WaitForChanges method (for use in C and C++ programming only).
CanImport | Returns a Boolean value that indicates whether the object's properties can be imported from the specified XML document.
Export | Writes the stored values of all of the object's properties to the specified XML document.
ExportToFile | Writes the stored values of all of the object's properties to the specified XML file.
GetServiceRestartMask | Retrieves a 32-bit bitmask of the FpcServices enumerated type that specifies which services need to be restarted for currently unsaved changes to take effect.
Import | Copies the values of all of the object's properties from the specified XML document to persistent storage.
ImportFromFile | Copies the values of all of the object's properties from the specified XML file to persistent storage.
LoadDocProperties | Provides the XML document's properties so that you can know what information can be imported from the document.
Refresh | Reads the values of all of the object's properties from persistent storage, overwriting any changes that have not been saved.
Save | Writes the current values of all of the object's properties to persistent storage.
WaitForChanges | Registers to wait for an event indicating that the contents of the object have changed (for use in C and C++ programming only).

Properties Inherited from FPCPersist

Name | Description
PersistentName | Gets the persistent name of the object. The persistent name of an object is a name that is unique for the object at the respective level of the COM object hierarchy.
VendorParametersSets | Gets an FPCVendorParametersSets object that can hold sets of custom data for extending the object.

Remarks

This object implements the IFPCLog interface.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

COM Objects


IFPCLog | FPCLog ComponentType(FpcLoggingComponents) property [ISA Server 2004]

ComponentType Property of IFPCLog[C++]

FPCLog.ComponentType [Visual Basic]

[C++]

The ComponentType property gets a value from the FpcLoggingComponents enumerated type that specifies the component to which the logging configuration refers. There are three possible logging components:

  • Web proxy logging.
  • Firewall service logging.
  • Simple Mail Transfer Protocol (SMTP) Message Screener logging.

HRESULT get_ComponentType(
  FpcLoggingComponents* pLoggingComponents
);

Parameters

pLoggingComponents
Pointer to a variable that on return receives a value from the FpcLoggingComponents enumerated type specifying the component to which the logging configuration refers.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The ComponentType property gets a value from the FpcLoggingComponents enumerated type that specifies the component to which the logging configuration refers. There are three possible logging components:

  • Web proxy logging.
  • Firewall service logging.
  • Simple Mail Transfer Protocol (SMTP) Message Screener logging.

Property ComponentType As FpcLoggingComponents

Property Value

Value from the FpcLoggingComponents enumerated type that specifies the component to which the logging configuration refers.

Remarks

This property is read-only.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCLog


IFPCLog | FPCLog DeleteOldLogsOnLimitExceeded property [ISA Server 2004]

DeleteOldLogsOnLimitExceeded Property of IFPCLog[C++]

FPCLog.DeleteOldLogsOnLimitExceeded [Visual Basic]

[C++]

The DeleteOldLogsOnLimitExceeded property gets or sets a Boolean value that indicates whether old log files will be deleted to maintain the total log size below the maximum allowed value, or to maintain the amount of free disk space above the required minimum.

HRESULT get_DeleteOldLogsOnLimitExceeded(
  VARIANT_BOOL* pfDeleteOldLogsOnLimitExceeded
);

HRESULT put_DeleteOldLogsOnLimitExceeded(
  VARIANT_BOOL fDeleteOldLogsOnLimitExceeded
);

Parameters

pfDeleteOldLogsOnLimitExceeded
Pointer to a Boolean variable that is set on return to VARIANT_TRUE if old log files will be deleted to maintain the total log size below the maximum allowed value, or to maintain the amount of free disk space above the required minimum, or to VARIANT_FALSE if no new log entries will be stored when these limits are violated.
fDeleteOldLogsOnLimitExceeded
Boolean value that indicates whether old log files will be deleted to maintain the total log size below the maximum allowed value, or to maintain the amount of free disk space above the required minimum.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write. Its default value is VARIANT_TRUE.

This property is applicable only to Firewall service and Web Proxy logging, and not to SMTP Message Screener logging.

[Visual Basic]

The DeleteOldLogsOnLimitExceeded property gets or sets a Boolean value that indicates whether old log files will be deleted to maintain the total log size below the maximum allowed value, or to maintain the amount of free disk space above the required minimum.

Property DeleteOldLogsOnLimitExceeded As Boolean

Property Value

Boolean value that indicates whether old log files will be deleted to maintain the total log size below the maximum allowed value, or to maintain the amount of free disk space above the required minimum.

Remarks

This property is read/write. Its default value is True.

This property is applicable only to Firewall service and Web Proxy logging, and not to SMTP Message Screener logging.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCLog


IFPCLog | FPCLog Enabled(VARIANT_BOOL,VARIANT_BOOL) property [ISA Server 2004]

Enabled Property of IFPCLog[C++]

FPCLog.Enabled [Visual Basic]

[C++]

The Enabled property gets or sets a Boolean value that indicates whether logging is enabled.

HRESULT get_Enabled(
  VARIANT_BOOL* pfEnabled
);

HRESULT put_Enabled(
  VARIANT_BOOL fEnabled
);

Parameters

pfEnabled
Pointer to a Boolean variable that is set on return to VARIANT_TRUE if logging is enabled, or to VARIANT_FALSE if logging is disabled.
fEnabled
Boolean value that indicates whether logging is enabled.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write.

[Visual Basic]

The Enabled property gets or sets a Boolean value that indicates whether logging is enabled.

Property Enabled As Boolean

Property Value

Boolean value that indicates whether logging is enabled.

Remarks

This property is read/write.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCLog


IFPCLog | FPCLog KeepMinFreeDiskSpace (2 Parameters) property [ISA Server 2004]

KeepMinFreeDiskSpace Property of IFPCLog[C++]

FPCLog.KeepMinFreeDiskSpace [Visual Basic]

[C++]

The KeepMinFreeDiskSpace property gets or sets a Boolean value that indicates whether the lower limit on the free disk space is enforced.

HRESULT get_KeepMinFreeDiskSpace(
  VARIANT_BOOL* pfKeepMinFreeDiskSpace
);

HRESULT put_KeepMinFreeDiskSpace(
  VARIANT_BOOL fKeepMinFreeDiskSpace
);

Parameters

pfKeepMinFreeDiskSpace
Pointer to a Boolean variable that is set on return to VARIANT_TRUE if the lower limit on the free disk space is enforced, or to VARIANT_FALSE if the lower limit on the free disk space is not enforced.
fKeepMinFreeDiskSpace
Boolean value that indicates whether the lower limit on the free disk space is enforced.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write. Its default value is VARIANT_TRUE.

The lower limit on the free disk space is specified by the MinFreeDiskSpaceMB property.

This property is applicable only to Firewall service and Web Proxy logging, and not to SMTP Message Screener logging.

[Visual Basic]

The KeepMinFreeDiskSpace property gets or sets a Boolean value that indicates whether the lower limit on the free disk space is enforced.

Property KeepMinFreeDiskSpace As Boolean

Property Value

Boolean value that indicates whether the lower limit on the free disk space is enforced.

Remarks

This property is read/write. Its default value is True.

The lower limit on the free disk space is specified by the MinFreeDiskSpaceMB property.

This property is applicable only to Firewall service and Web Proxy logging, and not to SMTP Message Screener logging.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCLog


IFPCLog | FPCLog LimitTotalLogSize (2 Parameters) property [ISA Server 2004]

LimitTotalLogSize Property of IFPCLog[C++]

FPCLog.LimitTotalLogSize [Visual Basic]

[C++]

The LimitTotalLogSize property gets or sets a Boolean value that indicates whether the upper limit on the total log size is enforced.

HRESULT get_LimitTotalLogSize(
  VARIANT_BOOL* pfLimitTotalLogSize
);

HRESULT put_LimitTotalLogSize(
  VARIANT_BOOL fLimitTotalLogSize
);

Parameters

pfLimitTotalLogSize
Pointer to a Boolean variable that is set on return to VARIANT_TRUE if the upper limit on the total log size is enforced, or to VARIANT_FALSE if the upper limit on the total log size is not enforced.
fLimitTotalLogSize
Boolean value that indicates whether the upper limit on the total log size is enforced.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write. Its default value is VARIANT_TRUE.

The upper limit on the total disk space used to store log files is specified by the MaxTotalLogSizeGB property.

This property is applicable only to Firewall service and Web Proxy logging, and not to SMTP Message Screener logging.

[Visual Basic]

The LimitTotalLogSize property gets or sets a Boolean value that indicates whether the upper limit on the total log size is enforced.

Property LimitTotalLogSize As Boolean

Property Value

Boolean value that indicates whether the upper limit on the total log size is enforced.

Remarks

This property is read/write. Its default value is True.

The upper limit on the total disk space used to store log files is specified by the MaxTotalLogSizeGB property.

This property is applicable only to Firewall service and Web Proxy logging, and not to SMTP Message Screener logging.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCLog


IFPCLog | FPCLog LogDbDataSource(BSTR,BSTR) property [ISA Server 2004]

LogDbDataSource Property of IFPCLog[C++]

FPCLog.LogDbDataSource [Visual Basic]

[C++]

The LogDbDataSource property gets or sets the Structured Query Language (SQL) data source name (DSN).

HRESULT get_LogDbDataSource(
  BSTR* pbstrDSN
);

HRESULT put_LogDbDataSource(
  BSTR bstrDSN
);

Parameters

pbstrDSN
Pointer to a BSTR that is set on return to a string value specifying to the SQL DSN.
bstrDSN
BSTR that specifies the SQL DSN.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write.

[Visual Basic]

The LogDbDataSource property gets or sets the Structured Query Language (SQL) data source name (DSN).

Property LogDbDataSource As String

Property Value

String that specifies the SQL DSN.

Remarks

This property is read/write.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCLog


IFPCLog | FPCLog LogDbPassword(BSTR) property [ISA Server 2004]

LogDbPassword Property of IFPCLog[C++]

FPCLog.LogDbPassword [Visual Basic]

[C++]

The LogDbPassword property sets the password for the Structured Query Language (SQL) table.

HRESULT put_LogDbPassword(
  BSTR bstrPassword
);

Parameters

bstrPassword
BSTR that specifies the password for the SQL table.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is write-only.

[Visual Basic]

The LogDbPassword property sets the password for the Structured Query Language (SQL) table.

Property LogDbPassword As String

Property Value

String that specifies the password for the SQL table.

Remarks

This property is write-only.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCLog


IFPCLog | FPCLog LogDbTableName(BSTR,BSTR) property [ISA Server 2004]

LogDbTableName Property of IFPCLog[C++]

FPCLog.LogDbTableName [Visual Basic]

[C++]

The LogDbTableName property gets or sets the name of the Structured Query Language (SQL) table.

HRESULT get_LogDbTableName(
  BSTR* pbstrTableName
);

HRESULT put_LogDbTableName(
  BSTR bstrTableName
);

Parameters

pbstrTableName
Pointer to a BSTR that is set on return to a string value specifying the name of the SQL table.
bstrTableName
BSTR that specifies the name of the SQL table.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write.

[Visual Basic]

The LogDbTableName property gets or sets the name of the Structured Query Language (SQL) table.

Property LogDbTableName As String

Property Value

String that specifies the name of the SQL table.

Remarks

This property is read/write.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCLog


IFPCLog | FPCLog LogDbUserName(BSTR,BSTR) property [ISA Server 2004]

LogDbUserName Property of IFPCLog[C++]

FPCLog.LogDbUserName [Visual Basic]

[C++]

The LogDbUserName property gets or sets the user name of the Structured Query Language (SQL) table.

HRESULT get_LogDbUserName(
  BSTR* pbstrUserName
);

HRESULT put_LogDbUserName(
  BSTR bstrUserName
);

Parameters

pbstrUserName
Pointer to a BSTR that is set on return to a string value specifying the user name of the SQL table.
bstrUserName
BSTR that specifies the user name of the SQL table.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write.

[Visual Basic]

The LogDbUserName property gets or sets the user name of the Structured Query Language (SQL) table.

Property LogDbUserName As String

Property Value

String that specifies the user name of the SQL table.

Remarks

This property is read/write.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCLog


IFPCLog | FPCLog LogFieldSelection(long,long) property [ISA Server 2004]

LogFieldSelection Property of IFPCLog[C++]

FPCLog.LogFieldSelection [Visual Basic]

[C++]

The LogFieldSelection property gets or sets a bitmask in which each bit specifies whether a particular log field is selected for logging. The first bit (0) refers to the first field of the log object, the second bit refers to the second field, and so on. Tables of the fields that can be included in ISA Server logs and the position of each field are provided in Log Fields.

HRESULT get_LogFieldSelection(
  long* plSelection
);

HRESULT put_LogFieldSelection(
  long lSelection
);

Parameters

plSelection
Pointer to a 32-bit integer that is set on return to a bitmask specifying the log fields that are selected for logging.
lSelection
Bitmask that specifies the fields that are selected for logging.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write.

[Visual Basic]

The LogFieldSelection property gets or sets a bitmask in which each bit specifies whether a particular log field is selected for logging. The first bit (0) refers to the first field of the log object, the second bit refers to the second field, and so on. Tables of the fields that can be included in ISA Server logs and the position of each field are provided in Log Fields.

Property LogFieldSelection As Long

Property Value

Bitmask that specifies the log fields that are selected for logging.

Remarks

This property is read/write.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCLog


IFPCLog | FPCLog LogFileDirectory(BSTR,BSTR) property [ISA Server 2004]

LogFileDirectory Property of IFPCLog[C++]

FPCLog.LogFileDirectory [Visual Basic]

[C++]

The LogFileDirectory property gets or sets the full path of the directory containing the text log files.

HRESULT get_LogFileDirectory(
  BSTR* pbstrDirectory
);

HRESULT put_LogFileDirectory(
  BSTR bstrDirectory
);

Parameters

pbstrDirectory
Pointer to a BSTR that is set on return to a string value specifying the full path of the directory containing the text log files.
bstrDirectory
BSTR that specifies the full path of the directory containing the text log files.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write.

Note that this property is used only if the LogFileDirectoryType property is set to the fpcFullPath value from the FpcLogFileDirectoryType enumerated type. Otherwise, the files are stored in the ServerLogs directory under the ISA Server installation directory.

[Visual Basic]

The LogFileDirectory property gets or sets the full path of the directory containing the text log files.

Property LogFileDirectory As String

Property Value

String that specifies the full path of the directory containing the text log files.

Remarks

This property is read/write.

Note that this property is used only if the LogFileDirectoryType property is set to the fpcFullPath value from the FpcLogFileDirectoryType enumerated type. Otherwise, the files are stored in the ServerLogs directory under the ISA Server installation directory.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCLog


IFPCLog | FPCLog LogFileDirectoryType (2 Parameters) property [ISA Server 2004]

LogFileDirectoryType Property of IFPCLog[C++]

FPCLog.LogFileDirectoryType [Visual Basic]

[C++]

The LogFileDirectoryType property gets or sets a value from the FpcLogFileDirectoryType enumerated type that indicates the type of path specified for the log files.

HRESULT get_LogFileDirectoryType(
  FpcLogFileDirectoryType* pDirectoryType
);

HRESULT put_LogFileDirectoryType(
  FpcLogFileDirectoryType DirectoryType
);

Parameters

pDirectoryType
Pointer to a value from the FpcLogFileDirectoryType enumerated type that is set on return to either fpcFullPath, which indicates that full path is specified for the log file directory, or fpcRelativePath, which indicates that the log files are stored in the ISALogs directory under the ISA Server installation directory.
DirectoryType

Value from the FpcLogFileDirectoryType enumerated type. The value can be either fpcFullPath, which indicates that the directory of the log files is given as a full path, or fpcRelativePath, which indicates that the directory of the log files is relative to the ISA Server installation directory.

If this value is set to fpcRelativePath, the path set in the LogFileDirectory property is ignored.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write.

[Visual Basic]

The LogFileDirectoryType property gets or sets a value from the FpcLogFileDirectoryType enumerated type that indicates the type of path specified for the log files.

Property LogFileDirectoryType As FpcLogFileDirectoryType

Property Value

Value from the FpcLogFileDirectoryType enumerated type. The value can be either fpcFullPath, which indicates that the full path is specified for the log file directory, or fpcRelativePath, which indicates that the log files are stored in the ISALogs directory under the ISA Server installation directory.

If this value is set to fpcRelativePath, the path set in the LogFileDirectory property is ignored.

Remarks

This property is read/write.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCLog


IFPCLog | FPCLog LogFileKeepOld(long,long) property [ISA Server 2004]

LogFileKeepOld Property of IFPCLog[C++]

FPCLog.LogFileKeepOld [Visual Basic]

[C++]

The LogFileKeepOld property gets or sets the number of days during which old log files will be retained. The default value is seven days.

HRESULT get_LogFileKeepOld(
  long* plKeepOld
);

HRESULT put_LogFileKeepOld(
  long lKeepOld
);

Parameters

plKeepOld
Pointer to a 32-bit integer that is set on return to the number of days during which old log files will be retained.
lKeepOld
A 32-bit integer that specifies the number of days during which old log files are to be retained.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write.

This property applies only to text log files. Setting the value to 0 disables the storage of old log files.

[Visual Basic]

The LogFileKeepOld property gets or sets the number of days during which old log files will be retained. The default value is seven days.

Property LogFileKeepOld As Long

Property Value

A 32-bit integer that specifies the number of days during which old log files will be retained.

Remarks

This property is read/write.

This property applies only to text log files. Setting the value to 0 disables the storage of old log files.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCLog


IFPCLog | FPCLog LogFilesCompress (2 Parameters) property [ISA Server 2004]

LogFilesCompress Property of IFPCLog[C++]

FPCLog.LogFilesCompress [Visual Basic]

[C++]

The LogFilesCompress property gets or sets a Boolean value that indicates whether text log files will be compressed.

Note This feature is supported only when logging to partitions formatted using the NTFS file system.

HRESULT get_LogFilesCompress(
  VARIANT_BOOL* pfCompress
);

HRESULT put_LogFilesCompress(
  VARIANT_BOOL fCompress
);

Parameters

pfCompress
Pointer to a Boolean variable that is set on return to VARIANT_TRUE if text log files will be compressed, or to VARIANT_FALSE if these files will not be compressed.
fCompress
A Boolean value that indicates whether text log files will be compressed.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write.

[Visual Basic]

The LogFilesCompress property gets or sets a Boolean value that indicates whether text log files will be compressed.

Note This feature is supported only when logging to partitions formatted using the NTFS file system.

Property LogFilesCompress As Boolean

Property Value

A Boolean value that indicates whether text log files will be compressed.

Remarks

This property is read/write.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCLog


IFPCLog | FPCLog LogType(FpcLogType,FpcLogType) property [ISA Server 2004]

LogType Property of IFPCLog[C++]

FPCLog.LogType [Visual Basic]

[C++]

The LogType property gets or sets a value from the FpcLogType enumerated type that specifies the type of log. The possible types are:

  • Text log files in the World Wide Web Consortium (W3C) extended file format.
  • Text log files in the ISA Server file format.
  • An Open Database Connectivity (ODBC)–compliant database.
  • A Microsoft Data Engine (MSDE) log.

HRESULT get_LogType(
  FpcLogType* pType
);

HRESULT put_LogType(
  FpcLogType Type
);

Parameters

pType
Pointer to a variable that on return receives a value from the FpcLogType enumerated type specifying the log type.
Type
Value from the FpcLogType enumerated type.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write.

[Visual Basic]

The LogType property gets or sets a value from the FpcLogType enumerated type that specifies the type of log. The possible types are:

  • Text log files in the World Wide Web Consortium (W3C) extended file format.
  • Text log files in the ISA Server file format.
  • An Open Database Connectivity (ODBC)–compliant database.
  • A Microsoft Data Engine (MSDE) log.

Property LogType As FpcLogType

Property Value

Value from the FpcLogType enumerated type.

Remarks

This property is read/write.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCLog


IFPCLog | FPCLog MaxTotalLogSizeGB(long,long) property [ISA Server 2004]

MaxTotalLogSizeGB Property of IFPCLog[C++]

FPCLog.MaxTotalLogSizeGB [Visual Basic]

[C++]

The MaxTotalLogSizeGB property gets or sets the upper limit on the total amount of disk space used to store log files, in gigabytes.

HRESULT get_MaxTotalLogSizeGB(
  long* plMaxTotalLogSize
);

HRESULT put_MaxTotalLogSizeGB(
  long lMaxTotalLogSize
);

Parameters

plMaxTotalLogSize
Pointer to a 32-bit integer that is set on return to the upper limit on the total amount of disk space used to store log files, in gigabytes.
lMaxTotalLogSize
A 32-bit integer that specifies the upper limit on the total total amount of disk space used to store log files, in gigabytes.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write. Its default value is 8, and it cannot be set to a value less than 4.

The limit is enforced only if the LimitTotalLogSize property is set to VARIANT_TRUE.

This property is applicable only to Firewall service and Web Proxy logging, and not to SMTP Message Screener logging.

[Visual Basic]

The MaxTotalLogSizeGB property gets or sets the upper limit on the total amount of disk space used to store log files, in gigabytes.

Property MaxTotalLogSizeGB As Long

Property Value

A 32-bit integer that specifies the upper limit on the total amount of disk space used to store log files, in gigabytes.

Remarks

This property is read/write. Its default value is 8, and it cannot be set to a value less than 4.

The limit is enforced only if the LimitTotalLogSize property is set to True.

This property is applicable only to Firewall service and Web Proxy logging, and not to SMTP Message Screener logging.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCLog


IFPCLog | FPCLog MinFreeDiskSpaceMB(long,long) property [ISA Server 2004]

MinFreeDiskSpaceMB Property of IFPCLog[C++]

FPCLog.MinFreeDiskSpaceMB [Visual Basic]

[C++]

The MinFreeDiskSpaceMB property gets or sets the lower limit on the amount of free disk space, in megabytes.

HRESULT get_MinFreeDiskSpaceMB(
  long* plMinFreeDiskSpace
);

HRESULT put_MinFreeDiskSpaceMB(
  long lMinFreeDiskSpace
);

Parameters

plMinFreeDiskSpace
Pointer to a 32-bit integer that is set on return to the lower limit on the amount of free disk space, in megabytes.
lMinFreeDiskSpace
A 32-bit integer that specifies the lower limit on the amount of free disk space, in megabytes.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write. Its default value is 256, and it cannot be set to a value less than 128.

The limit is enforced only if the KeepMinFreeDiskSpace property is set to VARIANT_TRUE.

This property is applicable only to Firewall service and Web Proxy logging, and not to SMTP Message Screener logging.

[Visual Basic]

The MinFreeDiskSpaceMB property gets or sets the lower limit on the amount of free disk space, in megabytes.

Property MinFreeDiskSpaceMB As Long

Property Value

A 32-bit integer that specifies the lower limit on the amount of free disk space, in megabytes.

Remarks

This property is read/write. Its default value is 256, and it cannot be set to a value less than 128.

The limit is enforced only if the KeepMinFreeDiskSpace property is set to True.

This property is applicable only to Firewall service and Web Proxy logging, and not to SMTP Message Screener logging.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCLog


FPCLogContent collection [ISA Server 2004]

FPCLogContent Collection

The FPCLogContent collection holds a set of FPCLogEntry objects.

This collection is typically accessed through the LogContentMSDE and LogContentOnline properties of the FPCLogViewer object.

Click here to see the ISA Server object hierarchy.

Methods

The FPCLogContent collection defines the following methods.

Method | Description
EndQuery | Ends a query on all servers in the array.
ExecuteQuery | Executes a query on the logs of all servers in the array.
Item | Retrieves the requested FPCLogEntry object from the collection. This method returns only when the requested object is found, the associated query ends, or an error occurs in the query.
ItemAsync | Retrieves the requested FPCLogEntry object from the collection if it is available, returns null and sets the error code to E_PENDING if the requested object cannot be found immediately, or returns null and sets an error code if the operation fails or another error occurs.

Properties

The FPCLogContent collection has the following property.

Property | Description
_NewEnum | Gets an enumerator object for the collection.

Remarks

This collection implements the IFPCLogContent interface.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

COM Objects


IFPCLogContent | FPCLogContent _NewEnum(IUnknown) property [ISA Server 2004]

_NewEnum Property of IFPCLogContent[C++]

FPCLogContent._NewEnum [Visual Basic]

[C++]

The _NewEnum property gets an enumerator object for the collection. An enumerator object provides serial access to the elements of the collection.

HRESULT get__NewEnum(
  IUnknown* ppEnum
);

Parameters

ppEnum
Address of an interface pointer that on return points to the IUnknown interface of an enumerator object that implements an IEnumVARIANT interface for the collection. An interface pointer to the IEnumVARIANT interface of the enumerator object can be retrieved by calling QueryInterface on the IUnknown interface returned.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The _NewEnum property gets an enumerator object for the collection. An enumerator object provides serial access to the elements of the collection.

Property _NewEnum As IUnknown

Property Value

Reference to an enumerator object that provides serial access to the elements of the collection.

Remarks

This property is read-only.

In Visual Basic and VBScript, this property is used implicitly in For Each...In...Next constructs.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCLogContent


IFPCLogContent | FPCLogContent EndQuery method [ISA Server 2004]

IFPCLogContent::EndQuery[C++]

FPCLogContent.EndQuery [Visual Basic]

[C++]

The EndQuery method ends the query on all servers in the array.

HRESULT EndQuery();

Parameters

This method has no parameters.

Return Values

This method returns S_OK if the call is successful; otherwise, it returns an error code.

[Visual Basic]

The EndQuery method ends the query on all servers in the array.

Sub EndQuery()

Parameters

This method has no parameters.

Return Values

This method has no return values. If the call is unsuccessful, an error is raised that can be intercepted by using an error handler.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCLogContent


IFPCLogContent | FPCLogContent ExecuteQuery method [ISA Server 2004]

IFPCLogContent::ExecuteQuery[C++]

FPCLogContent.ExecuteQuery [Visual Basic]

[C++]

The ExecuteQuery method executes a query on the logs of all servers in the array.

HRESULT ExecuteQuery(
  IFPCFilterExpressions* pQuery,
  long MaxRowsToFetch
);

Parameters

pQuery
[in] Pointer to an IFPCFilterExpressions interface that represents the collection of filters to apply to the query.
MaxRowsToFetch
[in] The maximum number of rows to retrieve from the log.

Return Values

This method returns S_OK if the call is successful; otherwise, it returns an error code.
[Visual Basic]

The ExecuteQuery method executes a query on the logs of all servers in the array.

Sub ExecuteQuery( _
  ByRef pQuery As FPCFilterExpressions, _
  ByVal MaxRowsToFetch As Long _
)

Parameters

pQuery
[in] An FPCFilterExpressions collection that contains the filters to apply to the query.
MaxRowsToFetch
[in] The maximum number of rows to retrieve from the log.

Return Values

This method generates the query response if successful. Otherwise, an error is raised that can be intercepted by using an error handler.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCLogContent


IFPCLogContent | FPCLogContent Item(Long,IFPCLogEntry) method [ISA Server 2004]

IFPCLogContent::Item[C++]

FPCLogContent.Item [Visual Basic]

[C++]

The Item method retrieves the requested IFPCLogEntry interface from the collection. This method returns only when the requested interface is found, the associated query ends, or an error occurs in the query.

HRESULT Item(
  long index,
  IFPCLogEntry** ppItem
);

Parameters

index
[in] Required. One-based index of the object to retrieve.
ppItem
[out] Address of an interface pointer that on return points to the IFPCLogEntry interface requested.

Return Values

This method can return one of the following:

  • S_OK, indicating that the operation succeeded.
  • S_FALSE, indicating that the query ended before the interface requested was found.
  • E_PENDING, indicating that the Index parameter points beyond the end of the collection.
  • An error code, indicating that the operation failed or an error occurred in the query.
If the return value is not S_OK, the [out] parameter returned is a null object.

Remarks

This method can retrieve an IFPCLogEntry interface that represents a log entry that exists when the query starts. If the interface requested is not found, the method waits until the associated query ends or an error occurs in the query.

[Visual Basic]

The Item method retrieves the requested FPCLogEntry object from the collection. This method returns only when the requested object is found, the associated query ends, or an error occurs in the query.

Function Item( _
  ByVal index As Long _
) As FPCLogEntry

Parameters

index
[in] Required. One-based index of the object to retrieve.

Return Values

This method returns a reference to the FPCLogEntry object requested if successful. Otherwise, an error is raised that can be intercepted by using an error handler.

Remarks

This method can retrieve an FPCLogEntry object that represents a log entry that exists when the query starts. If the object requested is not found, the method waits until the associated query ends or an error occurs in the query.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCLogContent


IFPCLogContent | FPCLogContent ItemAsync (2 Parameters) method [ISA Server 2004]

IFPCLogContent::ItemAsync[C++]

FPCLogContent.ItemAsync [Visual Basic]

[C++]

The ItemAsync method retrieves the requested IFPCLogEntry interface from the collection if it is available, returns E_PENDING if the requested interface cannot be found immediately, or returns an error code if the operation fails of another error occurs.

HRESULT ItemAsync(
  long index,
  IFPCLogEntry** ppItem
);

Parameters

index
[in] Required. One-based index of the object to retrieve.
ppItem
[out] Address of an interface pointer that on return points to the IFPCLogEntry interface requested if the call is successful, or to a null interface if the requested interface cannot be found or the operation fails.

Return Values

This method can return one of the following:

  • S_OK, indicating that the operation succeeded.
  • S_FALSE, indicating that the query ended before the interface requested was found.
  • E_PENDING, indicating that the interface requested was not found.
  • An error code, indicating that the operation failed or an error occurred in the query.
If the return value is not S_OK, the [out] parameter returned is a null object.

[Visual Basic]

The ItemAsync method retrieves the requested FPCLogEntry object from the collection if it is available, returns null and sets the error code to E_PENDING if the requested object cannot be found immediately, or returns null and sets an error code if the operation fails or another error occurs.

Function ItemAsync( _
  ByVal index As Long _
) As FPCLogEntry

Parameters

index
[in] Required. One-based index of the object to retrieve.

Return Values

This method returns a reference to the FPCLogEntry object requested if successful. Otherwise, it returns null and raises an error that can be intercepted by using an error handler. The error code set can be one of the following:

  • S_FALSE, indicating that the query ended before the interface requested was found.
  • E_PENDING, indicating that the interface requested was not found.
  • An error code, indicating that the operation failed or an error occurred in the query.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCLogContent


FPCLogEntry object [ISA Server 2004]

FPCLogEntry

The FPCLogEntry object represents a single entry in a log. This object is created as an element of an FPCLogContent collection.

Click here to see the ISA Server object hierarchy.

Methods

This object has no methods.

Properties

The FPCLogEntry object has the following properties.

Property | Description
Bidirectional | Gets a value from the FpcBidirectional enumerated type that indicates whether the connection was bidirectional.
BytesReceived | Gets the number of bytes sent from the external computer and received by the client during the current connection.
BytesSent | Gets the number of bytes sent from the internal client to the external server during the current connection.
CacheInfo | Gets the cache status of the object, which indicates why the object was or was not cached.
ClientAgent | Gets the client application type sent by the client in the Hypertext Transfer Protocol (HTTP) header.
ClientAuthenticate | Gets a value from the FpcClientAuthenticatedValues enumerated type that indicates whether the client was authenticated to the ISA Server computer.
ClientIP | Gets the requesting client IP address.
ClientUserName | Gets the requesting client user name.
DestHost | Gets the destination host name.
DestHostIP | Gets the destination host IP address.
DestHostPort | Gets the destination host port.
DestinationNetwork | Gets the destination network.
DestinationProxy | Gets the destination proxy.
ErrorInfo | Gets a bitmask that contains additional information on the request that can help identify the source of the error if an error occurred.
FilterInformation | Gets the filter information.
FWAction | Gets a value from the FpcAction enumerated type that specifies the action performed by the Microsoft Firewall service.
Interface | Gets the interface.
LogTime | Gets a Date value that specifies the date and time in Coordinated Universal Time (UTC) when the log entry was made.
LogType | Gets a value from the FpcLoggingComponents enumerated type that specifies the logging component that created the log entry.
MimeType | Gets the Multipurpose Internet Mail Extensions (MIME) type.
ObjectSource | Gets a value from the FpcProxyObjSources enumerated type that specifies the source of the proxy object.
Operation | Gets the application method used.
OriginalClientIP | Gets the original client IP address.
ProcessingTime | Gets the processing time for the request, in milliseconds.
Protocol | Gets the application protocol used for the connection.
RawIPHeader | Gets the raw IP header.
RawPayload | Gets the raw payload.
ReferredServer | Gets the name of the downstream server that sent the request.
ResultCode | Gets the result code, such as a Windows or Winsock error code, or an HTTP status code.
Rule | Gets the rule.
ServerName | Gets the name of the ISA Server computer that handled the request.
Service | Gets a value from the FpcLogServiceType enumerated type that specifies the logged service type.
SourceHost | Gets the source host.
SourceNetwork | Gets the source network.
SourceProxy | Gets the source proxy.
SrcPort | Gets the source port.
Transport | Gets the transport protocol used for the connection.
URL | Gets the URL.

Remarks

This object implements the IFPCLogEntry interface.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

COM Objects


IFPCLogEntry | FPCLogEntry Bidirectional property [ISA Server 2004]

Bidirectional Property of IFPCLogEntry[C++]

FPCLogEntry.Bidirectional [Visual Basic]

[C++]

The Bidirectional property gets a value from the FpcBidirectional enumerated type that indicates whether the connection was bidirectional.

HRESULT get_Bidirectional(
  FpcBidirectional* pVal
);

Parameters

pVal
Pointer to a variable that receives a value from the FpcBidirectional enumerated type which indicates whether the connection was bidirectional.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The Bidirectional property gets a value from the FpcBidirectional enumerated type that indicates whether the connection was bidirectional.

Property Bidirectional As FpcBidirectional

Property Value

Value from the FpcBidirectional enumerated type that indicates whether the connection was bidirectional.

Remarks

This property is read-only.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCLogEntry


IFPCLogEntry | FPCLogEntry BytesReceived(__int64) property [ISA Server 2004]

BytesReceived Property of IFPCLogEntry[C++]

FPCLogEntry.BytesReceived [Visual Basic]

[C++]

The BytesReceived property gets the number of bytes sent from the external computer and received by the client during the current connection.

HRESULT get_BytesReceived(
  __int64* plBytesReceived
);

Parameters

plBytesReceived
Pointer to a variable that receives a 64-bit integer indicating the number of bytes sent from the external computer and received by the client during the current connection.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The BytesReceived property gets the number of bytes sent from the external computer and received by the client during the current connection.

Property BytesReceived As Long

Property Value

A 64-bit integer that specifies the number of bytes sent from the external computer and received by the client during the current connection.

Remarks

This property is read-only.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCLogEntry


IFPCLogEntry | FPCLogEntry BytesSent(__int64) property [ISA Server 2004]

BytesSent Property of IFPCLogEntry[C++]

FPCLogEntry.BytesSent [Visual Basic]

[C++]

The BytesSent property gets the number of bytes sent from the internal client to the external server during the current connection.

HRESULT get_BytesSent(
  __int64* plBytesSent
);

Parameters

plBytesSent
Pointer to a 64-bit integer that is set on return to the number of bytes sent from the internal client to the external server during the current connection.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The BytesSent property gets the number of bytes sent from the internal client to the external server during the current connection.

Property BytesSent As Long

Property Value

A 64-bit integer that specifies the number of bytes sent from the internal client to the external server during the current connection.

Remarks

This property is read-only.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCLogEntry


IFPCLogEntry | FPCLogEntry CacheInfo(Long) property [ISA Server 2004]

CacheInfo Property of IFPCLogEntry[C++]

FPCLogEntry.CacheInfo [Visual Basic]

[C++]

The CacheInfo property gets the cache status of the object, which indicates why the object was or was not cached.

HRESULT get_CacheInfo(
  Long* plCacheInfo
);

Parameters

plCacheInfo
Pointer to a variable that on return receives a 32-bit integer specifying the cache status of the object.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

For a table of some possible values, see Cache Information Values.

[Visual Basic]

The CacheInfo property gets the cache status of the object, which indicates why the object was or was not cached.

Property CacheInfo As Long

Property Value

A 32-bit integer that specifies the cache status of the object.

Remarks

This property is read-only.

For a table of some possible values, see Cache Information Values.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCLogEntry


IFPCLogEntry | FPCLogEntry ClientAgent(BSTR) property [ISA Server 2004]

ClientAgent Property of IFPCLogEntry[C++]

FPCLogEntry.ClientAgent [Visual Basic]

[C++]

The ClientAgent property gets the client application type sent by the client in the Hypertext Transfer Protocol (HTTP) header.

HRESULT get_ClientAgent(
  BSTR* pbstrClientAgent
);

Parameters

pbstrClientAgent
Pointer to a BSTR that is set on return to a string value specifying the client application type.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

For some possible values, see Client Agent Values.

[Visual Basic]

The ClientAgent property gets the client application type sent by the client in the Hypertext Transfer Protocol (HTTP) header.

Property ClientAgent As String

Property Value

String that specifies the client application type.

Remarks

This property is read-only.

For some possible values, see Client Agent Values.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCLogEntry


IFPCLogEntry | FPCLogEntry ClientAuthenticate property [ISA Server 2004]

ClientAuthenticate Property of IFPCLogEntry[C++]

FPCLogEntry.ClientAuthenticate [Visual Basic]

[C++]

The ClientAuthenticate property gets a value from the FpcClientAuthenticatedValues enumerated type that indicates whether the client was authenticated to the ISA Server computer.

HRESULT get_ClientAuthenticate(
  FpcClientAuthenticatedValues* pVal
);

Parameters

pVal
Pointer to a variable that on return receives a value from the FpcClientAuthenticatedValues enumerated type indicating whether the client was authenticated to the ISA Server computer.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The ClientAuthenticate property gets a value from the FpcClientAuthenticatedValues enumerated type that indicates whether the client was authenticated to the ISA Server computer.

Property ClientAuthenticate As FpcClientAuthenticatedValues

Property Value

Value from the FpcClientAuthenticatedValues enumerated type that indicates whether the client was authenticated to the ISA Server computer.

Remarks

This property is read-only.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCLogEntry


IFPCLogEntry | FPCLogEntry ClientIP(BSTR) property [ISA Server 2004]

ClientIP Property of IFPCLogEntry[C++]

FPCLogEntry.ClientIP [Visual Basic]

[C++]

The ClientIP property gets the requesting client IP address.

HRESULT get_ClientIP(
  BSTR* pbstrClientIP
);

Parameters

pbstrClientIP
Pointer to a BSTR that is set on return to a string value specifying the requesting client IP address.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The ClientIP property gets the requesting client IP address.

Property ClientIP As String

Property Value

String that specifies the requesting client IP address.

Remarks

This property is read-only.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCLogEntry


IFPCLogEntry | FPCLogEntry ClientUserName(BSTR) property [ISA Server 2004]

ClientUserName Property of IFPCLogEntry[C++]

FPCLogEntry.ClientUserName [Visual Basic]

[C++]

The ClientUserName property gets the requesting client user name.

HRESULT get_ClientUserName(
  BSTR* pbstrClientUserName
);

Parameters

pbstrClientUserName
Pointer to a BSTR that is set on return to a string value specifying the requesting client user name.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The ClientUserName property gets the requesting client user name.

Property ClientUserName As String

Property Value

String that specifies the requesting client user name.

Remarks

This property is read-only.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCLogEntry


IFPCLogEntry | FPCLogEntry DestHost(BSTR) property [ISA Server 2004]

DestHost Property of IFPCLogEntry[C++]

FPCLogEntry.DestHost [Visual Basic]

[C++]

The DestHost property gets the name of the destination host.

HRESULT get_DestHost(
  BSTR* pbstrDestHost
);

Parameters

pbstrDestHost
Pointer to a BSTR that is set on return to a string value specifying the name of the destination host.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The DestHost property gets the name of the destination host.

Property DestHost As String

Property Value

String that specifies the name of the destination host.

Remarks

This property is read-only.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCLogEntry


IFPCLogEntry | FPCLogEntry DestHostIP(BSTR) property [ISA Server 2004]

DestHostIP Property of IFPCLogEntry[C++]

FPCLogEntry.DestHostIP [Visual Basic]

[C++]

The DestHostIP property gets the destination host IP address.

HRESULT get_DestHostIP(
  BSTR* pbstrDestHostIP
);

Parameters

pbstrDestHostIP
Pointer to a BSTR that is set on return to a string value specifying the destination host IP address.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The DestHostIP property gets the destination host IP address.

Property DestHostIP As String

Property Value

String that specifies the destination host IP address.

Remarks

This property is read-only.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCLogEntry


IFPCLogEntry | FPCLogEntry DestHostPort(Long) property [ISA Server 2004]

DestHostPort Property of IFPCLogEntry[C++]

FPCLogEntry.DestHostPort [Visual Basic]

[C++]

The DestHostPort property gets the destination host port number.

HRESULT get_DestHostPort(
  Long* plDestHostPort
);

Parameters

plDestHostPort
Pointer to a variable that on return receives a 32-bit integer specifying the destination host port number.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The DestHostPort property gets the destination host port number.

Property DestHostPort As Long

Property Value

A 32-bit integer that specifies the destination host port number.

Remarks

This property is read-only.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCLogEntry


IFPCLogEntry | FPCLogEntry DestinationNetwork(BSTR) property [ISA Server 2004]

DestinationNetwork Property of IFPCLogEntry[C++]

FPCLogEntry.DestinationNetwork [Visual Basic]

[C++]

The DestinationNetwork property gets the destination network.

HRESULT get_DestinationNetwork(
  BSTR* pbstrDestinationNetwork
);

Parameters

pbstrDestinationNetwork
Pointer to a BSTR that is set on return to a string value specifying the destination network.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The DestinationNetwork property gets the destination network.

Property DestinationNetwork As String

Property Value

String that specifies the destination network.

Remarks

This property is read-only.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCLogEntry


IFPCLogEntry | FPCLogEntry DestinationProxy(BSTR) property [ISA Server 2004]

DestinationProxy Property of IFPCLogEntry[C++]

FPCLogEntry.DestinationProxy [Visual Basic]

[C++]

The DestinationProxy property gets the name of the destination proxy server.

HRESULT get_DestinationProxy(
  BSTR* pbstrDestinationProxy
);

Parameters

pbstrDestinationProxy
Pointer to a BSTR that is set on return to a string value specifying the name of the destination proxy server.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The DestinationProxy property gets the name of the destination proxy server.

Property DestinationProxy As String

Property Value

String that specifies the name of the destination proxy server.

Remarks

This property is read-only.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCLogEntry


IFPCLogEntry | FPCLogEntry ErrorInfo(long) property [ISA Server 2004]

ErrorInfo Property of IFPCLogEntry[C++]

FPCLogEntry.ErrorInfo [Visual Basic]

[C++]

The ErrorInfo property gets a 32-bit bitmask that contains additional information on the request that can help identify the source of the error if an error occurred.

HRESULT get_ErrorInfo(
  long* plErrorInfo
);

Parameters

plErrorInfo
Pointer to a 32-bit integer that is set on return to a bitmask that contains additional information on the request that can help identify the source of the error if an error occurred.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

For a table of possible bit fields, see Error Information Bit Fields.

[Visual Basic]

The ErrorInfo property gets a 32-bit bitmask that contains additional information on the request that can help identify the source of the error if an error occurred.

Property ErrorInfo As Long

Property Value

A 32-bit bitmask that contains additional information on the request that can help identify the source of the error if an error occurred.

Remarks

This property is read-only.

For a table of possible bit fields, see Error Information Bit Fields.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCLogEntry


IFPCLogEntry | FPCLogEntry FilterInformation(BSTR) property [ISA Server 2004]

FilterInformation Property of IFPCLogEntry[C++]

FPCLogEntry.FilterInformation [Visual Basic]

[C++]

The FilterInformation property gets the filter information.

HRESULT get_FilterInformation(
  BSTR* pbstrFilterInformation
);

Parameters

pbstrFilterInformation
Pointer to a BSTR that is set on return to a string value specifying the filter information.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The FilterInformation property gets the filter information.

Property FilterInformation As String

Property Value

String that specifies the filter information.

Remarks

This property is read-only.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCLogEntry


IFPCLogEntry | FPCLogEntry FWAction(FpcAction) property [ISA Server 2004]

FWAction Property of IFPCLogEntry[C++]

FPCLogEntry.FWAction [Visual Basic]

[C++]

The FWAction property gets a value from the FpcAction enumerated type that specifies the action performed by the Microsoft Firewall service.

HRESULT get_FWAction(
  FpcAction* pAction
);

Parameters

pAction
Pointer to a variable that on return receives a value from the FpcAction enumerated type which specifies the action performed by the Microsoft Firewall service.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The FWAction property gets a value from the FpcAction enumerated type that specifies the action performed by the Microsoft Firewall service.

Property FWAction As FpcAction

Property Value

Value from the FpcAction enumerated type that specifies the action performed by the Microsoft Firewall service.

Remarks

This property is read-only.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCLogEntry


IFPCLogEntry | FPCLogEntry Interface(BSTR) property [ISA Server 2004]

Interface Property of IFPCLogEntry[C++]

FPCLogEntry.Interface [Visual Basic]

[C++]

The Interface property gets the interface.

HRESULT get_Interface(
  BSTR* pbstrInterface
);

Parameters

pbstrInterface
Pointer to a BSTR that is set on return to a string value specifying the interface.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The Interface property gets the interface.

Property Interface As String

Property Value

String that specifies the interface.

Remarks

This property is read-only.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCLogEntry


IFPCLogEntry | FPCLogEntry LogTime(Date) property [ISA Server 2004]

LogTime Property of IFPCLogEntry[C++]

FPCLogEntry.LogTime [Visual Basic]

[C++]

The LogTime property gets a DATE value that specifies the date and time in Coordinated Universal Time (UTC) when the log entry was made.

HRESULT get_LogTime(
  Date* pdLogTime
);

Parameters

pdLogTime
Pointer to a DATE that is set on return to the value specifying the date and time in Coordinated Universal Time (UTC) when the log entry was made.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The LogTime property gets a Date value that specifies the date and time in Coordinated Universal Time (UTC) when the log entry was made.

Property LogTime As Date

Property Value

Date value that specifies the date and time in Coordinated Universal Time (UTC) when the log entry was made.

Remarks

This property is read-only.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCLogEntry


IFPCLogEntry | FPCLogEntry LogType (1 Parameter) property [ISA Server 2004]

LogType Property of IFPCLogEntry[C++]

FPCLogEntry.LogType [Visual Basic]

[C++]

The LogType property gets a value from the FpcLoggingComponents enumerated type that specifies the logging component that created the log entry. The possible components are Web proxy logging, Firewall service logging, and Simple Mail Transfer Protocol (SMTP) Message Screener logging.

HRESULT get_LogType(
  FpcLoggingComponents* pLogType
);

Parameters

pLogType
Pointer to a variable that on return receives a value from the FpcLoggingComponents enumerated type specifying the logging component that created the log entry.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The LogType property gets a value from the FpcLoggingComponents enumerated type that specifies the logging component that created the log entry. The possible components are Web proxy logging, Firewall service logging, and Simple Mail Transfer Protocol (SMTP) Message Screener logging.

Property LogType As FpcLoggingComponents

Property Value

Value from the FpcLoggingComponents enumerated type that specifies the logging component that created the log entry.

Remarks

This property is read-only.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCLogEntry


IFPCLogEntry | FPCLogEntry MimeType(BSTR) property [ISA Server 2004]

MimeType Property of IFPCLogEntry[C++]

FPCLogEntry.MimeType [Visual Basic]

[C++]

The MimeType property gets the Multipurpose Internet Mail Extensions (MIME) type.

HRESULT get_MimeType(
  BSTR* pbstrMimeType
);

Parameters

pbstrMimeType
Pointer to a BSTR that is set on return to a string value specifying the MIME type.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The MimeType property gets the Multipurpose Internet Mail Extensions (MIME) type.

Property MimeType As String

Property Value

String that specifies the MIME type.

Remarks

This property is read-only.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCLogEntry


IFPCLogEntry | FPCLogEntry ObjectSource (1 Parameter) property [ISA Server 2004]

ObjectSource Property of IFPCLogEntry[C++]

FPCLogEntry.ObjectSource [Visual Basic]

[C++]

The ObjectSource property gets a value from the FpcProxyObjSources enumerated type that specifies the source of the proxy object.

HRESULT get_ObjectSource(
  FpcProxyObjSources* pObjectSource
);

Parameters

pObjectSource
Pointer to a variable that on return receives a value from the FpcProxyObjSources enumerated type specifying the source of the proxy object.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

For a table of possible values see Object Source Values.

[Visual Basic]

The ObjectSource property gets a value from the FpcProxyObjSources enumerated type that specifies the source of the proxy object.

Property ObjectSource As FpcProxyObjSources

Property Value

Value from the FpcProxyObjSources enumerated type that specifies the source of the proxy object.

Remarks

This property is read-only.

For a table of possible values see Object Source Values.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCLogEntry


IFPCLogEntry | FPCLogEntry Operation(BSTR) property [ISA Server 2004]

Operation Property of IFPCLogEntry[C++]

FPCLogEntry.Operation [Visual Basic]

[C++]

The Operation property gets the application method used.

HRESULT get_Operation(
  BSTR* pbstrOperation
);

Parameters

pbstrOperation
Pointer to a BSTR that is set on return to a string value specifying the application method used.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The Operation property gets the application method used.

Property Operation As String

Property Value

String that specifies the application method used.

Remarks

This property is read-only.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCLogEntry


IFPCLogEntry | FPCLogEntry OriginalClientIP(BSTR) property [ISA Server 2004]

OriginalClientIP Property of IFPCLogEntry[C++]

FPCLogEntry.OriginalClientIP [Visual Basic]

[C++]

The OriginalClientIP property gets the original client IP address.

HRESULT get_OriginalClientIP(
  BSTR* pbstrOriginalClientIP
);

Parameters

pbstrOriginalClientIP
Pointer to a BSTR that is set on return to a string value specifying the original client IP address.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The OriginalClientIP property gets the original client IP address.

Property OriginalClientIP As String

Property Value

String that specifies the original client IP address.

Remarks

This property is read-only.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCLogEntry


IFPCLogEntry | FPCLogEntry ProcessingTime(Long) property [ISA Server 2004]

ProcessingTime Property of IFPCLogEntry[C++]

FPCLogEntry.ProcessingTime [Visual Basic]

[C++]

The ProcessingTime property gets the processing time for the request, in milliseconds.

HRESULT get_ProcessingTime(
  Long* plProcessingTime
);

Parameters

plProcessingTime
Pointer to a variable that on return receives a 32-bit integer specifying the processing time for the request, in milliseconds.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The ProcessingTime property gets the processing time for the request, in milliseconds.

Property ProcessingTime As Long

Property Value

A 32-bit integer that specifies the processing time for the request, in milliseconds.

Remarks

This property is read-only.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCLogEntry


IFPCLogEntry | FPCLogEntry Protocol(BSTR) property [ISA Server 2004]

Protocol Property of IFPCLogEntry[C++]

FPCLogEntry.Protocol [Visual Basic]

[C++]

The Protocol property gets the application protocol used for the connection.

HRESULT get_Protocol(
  BSTR* pbstrProtocol
);

Parameters

pbstrProtocol
Pointer to a BSTR that is set on return to a string value specifying the application protocol used for the connection.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The Protocol property gets the application protocol used for the connection.

Property Protocol As String

Property Value

String that specifies the application protocol used for the connection.

Remarks

This property is read-only.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCLogEntry


IFPCLogEntry | FPCLogEntry RawIPHeader(BSTR) property [ISA Server 2004]

RawIPHeader Property of IFPCLogEntry[C++]

FPCLogEntry.RawIPHeader [Visual Basic]

[C++]

The RawIPHeader property gets the raw IP header.

HRESULT get_RawIPHeader(
  BSTR* pbstrRawIPHeader
);

Parameters

pbstrRawIPHeader
Pointer to a BSTR that is set on return to a string value specifying the raw IP header.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The RawIPHeader property gets the raw IP header.

Property RawIPHeader As String

Property Value

String that specifies the raw IP header.

Remarks

This property is read-only.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCLogEntry


IFPCLogEntry | FPCLogEntry RawPayload(BSTR) property [ISA Server 2004]

RawPayload Property of IFPCLogEntry[C++]

FPCLogEntry.RawPayload [Visual Basic]

[C++]

The RawPayload property gets the raw payload.

HRESULT get_RawPayload(
  BSTR* pbstrRawPayload
);

Parameters

pbstrRawPayload
Pointer to a BSTR that is set on return to a string value specifying the raw payload.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The RawPayload property gets the raw payload.

Property RawPayload As String

Property Value

String that specifies the raw payload.

Remarks

This property is read-only.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCLogEntry


IFPCLogEntry | FPCLogEntry ReferredServer(BSTR) property [ISA Server 2004]

ReferredServer Property of IFPCLogEntry[C++]

FPCLogEntry.ReferredServer [Visual Basic]

[C++]

The ReferredServer property gets the name of the downstream server that sent the request.

HRESULT get_ReferredServer(
  BSTR* pbstrReferredServer
);

Parameters

pbstrReferredServer
Pointer to a BSTR that is set on return to a string value specifying the name of the downstream server that sent the request.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The ReferredServer property gets the name of the downstream server that sent the request.

Property ReferredServer As String

Property Value

String that specifies the name of the downstream server that sent the request.

Remarks

This property is read-only.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCLogEntry


IFPCLogEntry | FPCLogEntry ResultCode(Long) property [ISA Server 2004]

ResultCode Property of IFPCLogEntry[C++]

FPCLogEntry.ResultCode [Visual Basic]

[C++]

The ResultCode property gets the result code, such as a Windows or Windows Sockets (Winsock) error code, or an HTTP status code.

HRESULT get_ResultCode(
  Long* plResultCode
);

Parameters

plResultCode
Pointer to a variable that on return receives a 32-bit integer specifying the result code.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

For a table of typical values, see Result Code Values.

[Visual Basic]

The ResultCode property gets the result code, such as a Windows or Windows Sockets (Winsock) error code, or an HTTP status code.

Property ResultCode As Long

Property Value

A 32-bit integer that specifies the result code.

Remarks

This property is read-only.

For a table of typical values, see Result Code Values.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCLogEntry


IFPCLogEntry | FPCLogEntry Rule(BSTR) property [ISA Server 2004]

Rule Property of IFPCLogEntry[C++]

FPCLogEntry.Rule [Visual Basic]

[C++]

The Rule property gets the rule that either allowed or denied access for the request.

HRESULT get_Rule(
  BSTR* pbstrRule
);

Parameters

pbstrRule
Pointer to a BSTR that is set on return to a string value specifying the rule that either allowed or denied access for the request.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The Rule property gets the rule that either allowed or denied access for the request.

Property Rule As String

Property Value

String that specifies the rule that either allowed or denied access for the request.

Remarks

This property is read-only.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCLogEntry


IFPCLogEntry | FPCLogEntry ServerName(BSTR) property [ISA Server 2004]

ServerName Property of IFPCLogEntry[C++]

FPCLogEntry.ServerName [Visual Basic]

[C++]

The ServerName property gets the name of the ISA Server computer that handled the request.

HRESULT get_ServerName(
  BSTR* pbstrServerName
);

Parameters

pbstrServerName
Pointer to a BSTR that is set on return to a string value specifying the name of the ISA Server computer that handled the request.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The ServerName property gets the name of the ISA Server computer that handled the request.

Property ServerName As String

Property Value

String that specifies the name of the ISA Server computer that handled the request.

Remarks

This property is read-only.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCLogEntry


IFPCLogEntry | FPCLogEntry Service(FpcLogServiceType) property [ISA Server 2004]

Service Property of IFPCLogEntry[C++]

FPCLogEntry.Service [Visual Basic]

[C++]

The Service property gets a value from the FpcLogServiceType enumerated type that specifies the logged service type.

HRESULT get_Service(
  FpcLogServiceType* pVal
);

Parameters

pVal
Pointer to a variable that on return receives a value from the FpcLogServiceType enumerated type specifying the logged service type.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The Service property gets a value from the FpcLogServiceType enumerated type that specifies the logged service type.

Property Service As FpcLogServiceType

Property Value

Value from the FpcLogServiceType enumerated type that specifies the logged service type.

Remarks

This property is read-only.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCLogEntry


IFPCLogEntry | FPCLogEntry SourceHost(BSTR) property [ISA Server 2004]

SourceHost Property of IFPCLogEntry[C++]

FPCLogEntry.SourceHost [Visual Basic]

[C++]

The SourceHost property gets the name of the source host.

HRESULT get_SourceHost(
  BSTR* pbstrSourceHost
);

Parameters

pbstrSourceHost
Pointer to a BSTR that is set on return to a string value specifying the name of the source host.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The SourceHost property gets the name of the source host.

Property SourceHost As String

Property Value

String that specifies the name of the source host.

Remarks

This property is read-only.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCLogEntry


IFPCLogEntry | FPCLogEntry SourceNetwork(BSTR) property [ISA Server 2004]

SourceNetwork Property of IFPCLogEntry[C++]

FPCLogEntry.SourceNetwork [Visual Basic]

[C++]

The SourceNetwork property gets the source network.

HRESULT get_SourceNetwork(
  BSTR* pbstrSourceNetwork
);

Parameters

pbstrSourceNetwork
Pointer to a BSTR that is set on return to a string value specifying the source network.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The SourceNetwork property gets the source network.

Property SourceNetwork As String

Property Value

String that specifies the source network.

Remarks

This property is read-only.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCLogEntry


IFPCLogEntry | FPCLogEntry SourceProxy(BSTR) property [ISA Server 2004]

SourceProxy Property of IFPCLogEntry[C++]

FPCLogEntry.SourceProxy [Visual Basic]

[C++]

The SourceProxy property gets the name of the source proxy server.

HRESULT get_SourceProxy(
  BSTR* pbstrSourceProxy
);

Parameters

pbstrSourceProxy
Pointer to a BSTR that is set on return to a string value specifying the name of the source proxy server.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The SourceProxy property gets the name of the source proxy server.

Property SourceProxy As String

Property Value

String that specifies the name of the source proxy server.

Remarks

This property is read-only.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCLogEntry


IFPCLogEntry | FPCLogEntry SrcPort(Long) property [ISA Server 2004]

SrcPort Property of IFPCLogEntry[C++]

FPCLogEntry.SrcPort [Visual Basic]

[C++]

The SrcPort property gets the source port number.

HRESULT get_SrcPort(
  Long* plSrcPort
);

Parameters

plSrcPort
Pointer to a variable that on return receives a 32-bit integer specifying the source port number.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The SrcPort property gets the source port number.

Property SrcPort As Long

Property Value

A 32-bit integer that specifies the source port number.

Remarks

This property is read-only.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCLogEntry


IFPCLogEntry | FPCLogEntry Transport(BSTR) property [ISA Server 2004]

Transport Property of IFPCLogEntry[C++]

FPCLogEntry.Transport [Visual Basic]

[C++]

The Transport property gets the transport protocol used for the connection.

HRESULT get_Transport(
  BSTR* pbstrTransport
);

Parameters

pbstrTransport
Pointer to a BSTR that is set on return to a string value specifying the transport protocol used for the connection.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The Transport property gets the transport protocol used for the connection.

Property Transport As String

Property Value

String that specifies the transport protocol used for the connection.

Remarks

This property is read-only.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCLogEntry


IFPCLogEntry | FPCLogEntry URL(BSTR) property [ISA Server 2004]

URL Property of IFPCLogEntry[C++]

FPCLogEntry.URL [Visual Basic]

[C++]

The URL property gets the URL of the logged request.

HRESULT get_URL(
  BSTR* pbstrURL
);

Parameters

pbstrURL
Pointer to a BSTR that is set on return to a string value specifying the URL of the logged request.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The URL property gets the URL of the logged request.

Property URL As String

Property Value

String that specifies the URL of the logged request.

Remarks

This property is read-only.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCLogEntry


FPCLogs collection [ISA Server 2004]

FPCLogs Collection

The FPCLogs collection holds a set of FPCLog objects, each of which defines the logging configuration for a specific component.

The FPCLogs collection can be accessed through the Logging property of an FPCArray object.

Click here to see the ISA Server object hierarchy.

Inheritance

This collection inherits from the FPCPersist object, which contains methods and properties related to the persistent storage of an object's data. They include methods for exporting an object's data to and importing it from an XML document.

Methods

The FPCLogs collection defines the following method.

Method | Description
Item | Retrieves the requested FPCLog object from the collection.

Properties

The FPCLogs collection has the following properties.

Property | Description
_NewEnum | Gets an enumerator object for the collection.
MSDENumberOfInsertsPerBatch | Gets or sets the number of SQL INSERT statements that are buffered before writing the information to a Microsoft Data Engine (MSDE) log.
MSDEQueryTimeout | Gets or sets the time-out period, in seconds, for a Microsoft Data Engine (MSDE) query in offline mode.

Methods Inherited from FPCPersist

Name | Description
CancelWaitForChanges | Cancels the registration established by the WaitForChanges method (for use in C and C++ programming only).
CanImport | Returns a Boolean value that indicates whether the properties of the collection and its elements can be imported from the specified XML document.
Export | Writes the stored values of all the properties of the collection and its elements to the specified XML document.
ExportToFile | Writes the stored values of all the properties of the collection and its elements to the specified XML file.
GetServiceRestartMask | Retrieves a 32-bit bitmask of the FpcServices enumerated type that specifies which services need to be restarted for currently unsaved changes to take effect.
Import | Copies the values of all the properties of the collection and its elements from the specified XML document to persistent storage.
ImportFromFile | Copies the values of all the properties of the collection and its elements from the specified XML file to persistent storage.
LoadDocProperties | Provides the XML document's properties so that you can know what information can be imported from the document.
Refresh | Reads the values of all the properties of the collection and its elements from persistent storage, overwriting any changes that have not been saved.
Save | Writes the current values of all the properties of the collection and its elements to persistent storage.
WaitForChanges | Registers to wait for an event indicating that the contents of the object have changed (for use in C and C++ programming only).

Properties Inherited from FPCPersist

Name | Description
PersistentName | Gets the persistent name of the collection. The persistent name of an object is a name that is unique for the object at the respective level of the COM object hierarchy.
VendorParametersSets | Gets an FPCVendorParametersSets collection that can hold sets of custom data for extending the collection.

Remarks

This collection implements the IFPCLogs interface.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

COM Objects


IFPCLogs | FPCLogs _NewEnum(IUnknown) property [ISA Server 2004]

_NewEnum Property of IFPCLogs[C++]

FPCLogs._NewEnum [Visual Basic]

[C++]

The _NewEnum property gets an enumerator object for the collection. An enumerator object provides serial access to the elements of the collection.

HRESULT get__NewEnum(
  IUnknown* ppEnum
);

Parameters

ppEnum
Address of an interface pointer that on return points to the IUnknown interface of an enumerator object that implements an IEnumVARIANT interface for the collection. An interface pointer to the IEnumVARIANT interface of the enumerator object can be retrieved by calling QueryInterface on the IUnknown interface returned.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The _NewEnum property gets an enumerator object for the collection. An enumerator object provides serial access to the elements of the collection.

Property _NewEnum As IUnknown

Property Value

Reference to an enumerator object that provides serial access to the elements of the collection.

Remarks

This property is read-only.

In Visual Basic and VBScript, this property is used implicitly in For Each...In...Next constructs.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCLogs


IFPCLogs | FPCLogs Item(FpcLoggingComponents,IFPCLog) method [ISA Server 2004]

IFPCLogs::Item[C++]

FPCLogs.Item [Visual Basic]

[C++]

The Item method retrieves the requested IFPCLog interface from the collection. The interface to be retrieved can be for Web proxy logging, Firewall service logging, or Simple Mail Transfer Protocol (SMTP) Message Screener logging.

HRESULT Item(
  FpcLoggingComponents LoggingComponents,
  IFPCLog** ppItem
);

Parameters

LoggingComponents
[in] A value from the FpcLoggingComponents enumerated type that indicates whether the interface to be retrieved is for Web proxy logging, Firewall service logging, or SMTP Message Screener logging.
ppItem
[out] Address of an interface pointer that on return points to the IFPCLog interface specified by the LoggingComponents parameter.

Return Values

The method can return one of the following:

  • S_OK, indicating that the operation succeeded.
  • An error code, indicating that the operation failed. In this case, the [out] parameter returned is a null object.

[Visual Basic]

The Item method retrieves the requested FPCLog object from the collection. The object to be retrieved can be for Web proxy logging, Firewall service logging, or Simple Mail Transfer Protocol (SMTP) Message Screener logging.

Function Item( _
  ByVal LoggingComponents As FpcLoggingComponents _
) As FPCLog

Parameters

LoggingComponents
[in] A value from the FpcLoggingComponents enumerated type that indicates whether the object to be retrieved is for Web proxy logging, Firewall service logging, or SMTP Message Screener logging.

Return Values

This method returns a reference to the FPCLog object requested if successful. Otherwise, an error is raised that can be intercepted by using an error handler.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCLogs


IFPCLogs | FPCLogs MSDENumberOfInsertsPerBatch property [ISA Server 2004]

MSDENumberOfInsertsPerBatch Property of IFPCLogs[C++]

FPCLogs.MSDENumberOfInsertsPerBatch [Visual Basic]

[C++]

The MSDENumberOfInsertsPerBatch property gets or sets the number of SQL INSERT statements that are buffered before writing the information to a Microsoft Data Engine (MSDE) log.

HRESULT get_MSDENumberOfInsertsPerBatch(
  long* plBufferSize
);

HRESULT put_MSDENumberOfInsertsPerBatch(
  long lBufferSize
);

Parameters

plBufferSize
Pointer to a 32-bit integer that is set on return to the number of SQL INSERT statements that are buffered before writing the information to an MSDE log.
lBufferSize
A 32-bit integer value that specifies the number of SQL INSERT statements that are buffered before writing the information to an MSDE log.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write.

The default value is 10,000. In common scenarios, there is no need to deviate from the default value.

[Visual Basic]

The MSDENumberOfInsertsPerBatch property gets or sets the number of SQL INSERT statements that are buffered before writing the information to a Microsoft Data Engine (MSDE) log.

Property MSDENumberOfInsertsPerBatch As Long

Property Value

A 32-bit integer that specifies the number of SQL INSERT statements that are buffered before writing the information to an MSDE log.

Remarks

This property is read/write.

The default value is 10,000. In common scenarios, there is no need to deviate from the default value.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCLogs


IFPCLogs | FPCLogs MSDEQueryTimeout(long,long) property [ISA Server 2004]

MSDEQueryTimeout Property of IFPCLogs[C++]

FPCLogs.MSDEQueryTimeout [Visual Basic]

[C++]

The MSDEQueryTimeout property gets or sets the time-out period, in seconds, for a Microsoft Data Engine (MSDE) query in offline mode.

HRESULT get_MSDEQueryTimeout(
  long* plBufferSize
);

HRESULT put_MSDEQueryTimeout(
  long lBufferSize
);

Parameters

plBufferSize
Pointer to a 32-bit integer that is set on return to the time-out period, in seconds, for an MSDE query in offline mode.
lBufferSize
A 32-bit integer value that specifies the time-out period, in seconds, for an MSDE query in offline mode.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write.

The default value is 150 seconds. In common scenarios, there is no need to deviate from the default value.

[Visual Basic]

The MSDEQueryTimeout property gets or sets the time-out period, in seconds, for a Microsoft Data Engine (MSDE) query in offline mode.

Property MSDEQueryTimeout As Long

Property Value

A 32-bit integer that specifies the time-out period, in seconds, for an MSDE query in offline mode.

Remarks

This property is read/write.

The default value is 150 seconds. In common scenarios, there is no need to deviate from the default value.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCLogs


FPCLogSummaryConfiguration object [ISA Server 2004]

FPCLogSummaryConfiguration

The FPCLogSummaryConfiguration object defines the configuration for generating daily and monthly log summaries.

The FPCLogSummaryConfiguration object is typically accessed through the LogSummaryConfiguration property of an FPCReports object.

Click here to see the ISA Server object hierarchy.

Inheritance

This object inherits from the FPCPersist object, which contains methods and properties related to the persistent storage of an object's data. They include methods for exporting the object's data to and importing it from an XML document.

Methods

The FPCLogSummaryConfiguration object defines the following method.

Method | Description
SetDirectory | Sets the DirectoryName and DirectoryType properties.

Properties

The FPCLogSummaryConfiguration object has the following properties.

Property | Description
DirectoryName | Gets the name of the directory where the daily and monthly log summaries are stored.
DirectoryType | Gets a value from the FpcLogFileDirectoryType enumerated type that specifies whether the path to the directory where the log summaries are stored is a full path, or a path that is relative to the ISA Server installation path.
Enabled | Gets or sets a Boolean value that indicates whether the generation of daily and monthly log summaries is enabled.
KeepOldDailySummaries | Gets or sets the number of old daily log summaries that are stored.
KeepOldMonthlySummaries | Gets or sets the number of old monthly log summaries that are stored.
StartHour | Gets or sets the hour at which the generation of daily log summaries will start. Used with the StartMinutes property to set the start time.
StartMinutes | Gets or sets the minute during the hour specified by the StartHour property at which the generation of daily log summaries will start.

Methods Inherited from FPCPersist

Name | Description
CancelWaitForChanges | Cancels the registration established by the WaitForChanges method (for use in C and C++ programming only).
CanImport | Returns a Boolean value that indicates whether the object's properties can be imported from the specified XML document.
Export | Writes the stored values of all of the object's properties to the specified XML document.
ExportToFile | Writes the stored values of all of the object's properties to the specified XML file.
GetServiceRestartMask | Retrieves a 32-bit bitmask of the FpcServices enumerated type that specifies which services need to be restarted for currently unsaved changes to take effect.
Import | Copies the values of all of the object's properties from the specified XML document to persistent storage.
ImportFromFile | Copies the values of all of the object's properties from the specified XML file to persistent storage.
LoadDocProperties | Provides the XML document's properties so that you can know what information can be imported from the document.
Refresh | Reads the values of all of the object's properties from persistent storage, overwriting any changes that have not been saved.
Save | Writes the current values of all of the object's properties to persistent storage.
WaitForChanges | Registers to wait for an event indicating that the contents of the object have changed (for use in C and C++ programming only).

Properties Inherited from FPCPersist

Name | Description
PersistentName | Gets the persistent name of the object. The persistent name of an object is a name that is unique for the object at the respective level of the COM object hierarchy.
VendorParametersSets | Gets an FPCVendorParametersSets object that can hold sets of custom data for extending the object.

Remarks

This object implements the IFPCLogSummaryConfiguration interface.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

COM Objects


IFPCLogSummaryConfiguration.DirectoryName(BSTR) property [ISA Server 2004]

DirectoryName Property of IFPCLogSummaryConfiguration[C++]

FPCLogSummaryConfiguration.DirectoryName [Visual Basic]

[C++]

The DirectoryName property gets the name of the directory where the daily and monthly log summaries are stored.

HRESULT get_DirectoryName(
  BSTR* pbstrDirectoryName
);

Parameters

pbstrDirectoryName
Pointer to a BSTR that is set on return to a string value specifying the name of the directory where the daily and monthly log summaries are stored.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only. It can be set by calling the SetDirectory method.

[Visual Basic]

The DirectoryName property gets the name of the directory where the daily and monthly log summaries are stored.

Property DirectoryName As String

Property Value

String that specifies the name of the directory where the daily and monthly log summaries are stored.

Remarks

This property is read-only. It can be set by calling the SetDirectory method.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCLogSummaryConfiguration


IFPCLogSummaryConfiguration.DirectoryType property [ISA Server 2004]

DirectoryType Property of IFPCLogSummaryConfiguration[C++]

FPCLogSummaryConfiguration.DirectoryType [Visual Basic]

[C++]

The DirectoryType property gets a value from the FpcLogFileDirectoryType enumerated type that specifies whether the path to the directory where the daily and monthly log summaries are stored is a full path, or a path that is relative to the ISA Server installation path.

HRESULT get_DirectoryType(
  FpcLogFileDirectoryType* pDirectoryType
);

Parameters

pDirectoryType
Pointer to a variable that on return receives a value from the FpcLogFileDirectoryType enumerated type specifying the type of path to the directory where the daily and monthly log summaries are stored.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only. It can be set by calling the SetDirectory method.

[Visual Basic]

The DirectoryType property gets a value from the FpcLogFileDirectoryType enumerated type that specifies whether the path to the directory where the daily and monthly log summaries are stored is a full path, or a path that is relative to the ISA Server installation path.

Property DirectoryType As FpcLogFileDirectoryType

Property Value

Value from the FpcLogFileDirectoryType enumerated type that specifies the type of path to the directory where the daily and monthly log summaries are stored.

Remarks

This property is read-only. It can be set by calling the SetDirectory method.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCLogSummaryConfiguration


IFPCLogSummaryConfiguration.Enabled (2 Parameters) property [ISA Server 2004]

Enabled Property of IFPCLogSummaryConfiguration[C++]

FPCLogSummaryConfiguration.Enabled [Visual Basic]

[C++]

The Enabled property gets or sets a Boolean value that indicates whether the generation of daily and monthly log summaries is enabled.

HRESULT get_Enabled(
  VARIANT_BOOL* pfEnabled
);

HRESULT put_Enabled(
  VARIANT_BOOL fEnabled
);

Parameters

pfEnabled
Pointer to a Boolean variable that is set on return to VARIANT_TRUE if the generation of daily and monthly log summaries is enabled, or to VARIANT_FALSE if the generation of daily and monthly log summaries is disabled.
fEnabled
Boolean value that indicates whether the generation of daily and monthly log summaries is enabled.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write.

[Visual Basic]

The Enabled property gets or sets a Boolean value that indicates whether the generation of daily and monthly log summaries is enabled.

Property Enabled As Boolean

Property Value

Boolean value that indicates whether the generation of daily and monthly log summaries is enabled.

Remarks

This property is read/write.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCLogSummaryConfiguration


IFPCLogSummaryConfiguration.KeepOldDailySummaries property [ISA Server 2004]

KeepOldDailySummaries Property of IFPCLogSummaryConfiguration[C++]

FPCLogSummaryConfiguration.KeepOldDailySummaries [Visual Basic]

[C++]

The KeepOldDailySummaries property gets or sets the number of old daily log summaries that are stored.

HRESULT get_KeepOldDailySummaries(
  long* plNumberDaily
);

HRESULT put_KeepOldDailySummaries(
  long lNumberDaily
);

Parameters

plNumberDaily
Pointer to a variable that on return receives a 32-bit integer specifying the number of old daily log summaries that are stored.
lNumberDaily
A 32-bit integer that specifies the number of old daily log summaries that are stored. This number should be non-negative.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write. By default, 35 daily log summaries are stored.

[Visual Basic]

The KeepOldDailySummaries property gets or sets the number of old daily log summaries that are stored.

Property KeepOldDailySummaries As Long

Property Value

A 32-bit integer that specifies the number of old daily log summaries that are stored. This number should be non-negative.

Remarks

This property is read/write. By default, 35 daily log summaries are stored.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCLogSummaryConfiguration


IFPCLogSummaryConfiguration.KeepOldMonthlySummaries property [ISA Server 2004]

KeepOldMonthlySummaries Property of IFPCLogSummaryConfiguration[C++]

FPCLogSummaryConfiguration.KeepOldMonthlySummaries [Visual Basic]

[C++]

The KeepOldMonthlySummaries property gets or sets the number of old monthly log summaries that are stored.

HRESULT get_KeepOldMonthlySummaries(
  long* plNumberMonthly
);

HRESULT put_KeepOldMonthlySummaries(
  long lNumberMonthly
);

Parameters

plNumberMonthly
Pointer to a variable that on return receives a 32-bit integer specifying the number of old monthly log summaries that are stored.
lNumberMonthly
A 32-bit integer that specifies the number of old monthly log summaries that are stored. This number should be non-negative.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write. By default, 13 monthly log summaries are stored.

[Visual Basic]

The KeepOldMonthlySummaries property gets or sets the number of old monthly log summaries that are stored.

Property KeepOldMonthlySummaries As Long

Property Value

A 32-bit integer that specifies the number of old monthly log summaries that are stored. This number should be non-negative.

Remarks

This property is read/write. By default, 13 monthly log summaries are stored.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCLogSummaryConfiguration


IFPCLogSummaryConfiguration.SetDirectory (2 Parameters) method [ISA Server 2004]

IFPCLogSummaryConfiguration::SetDirectory[C++]

FPCLogSummaryConfiguration.SetDirectory [Visual Basic]

[C++]

The SetDirectory method sets the DirectoryName and DirectoryType properties. These properties specify the path to the directory where the daily and monthly log summaries are stored, and whether the directory name provided is a full path or a path relative to the ISA Server installation directory.

HRESULT SetDirectory(
  FpcLogFileDirectoryType type,
  BSTR dirName
);

Parameters

type
[in] Value from the FpcLogFileDirectoryType enumerated type that specifies whether the directory name provided is a full path or a path relative to the ISA Server installation directory.
dirName
[in] String value that provides the name of the directory where the daily and monthly log summaries will be stored.

Return Values

This method returns S_OK if the call is successful; otherwise, it returns an error code.
[Visual Basic]

The SetDirectory method sets the DirectoryName and DirectoryType properties. These properties specify the path to the directory where the daily and monthly log summaries are stored, and whether the directory name provided is a full path or a path relative to the ISA Server installation directory.

Sub SetDirectory( _
  ByVal type As FpcLogFileDirectoryType, _
  ByVal dirName As String _
)

Parameters

type
[in] Value from the FpcLogFileDirectoryType enumerated type that specifies whether the directory name provided is a full path or a path relative to the ISA Server installation directory.
dirName
[in] String value that provides the name of the directory where the daily and monthly log summaries will be stored.

Return Values

This method has no return values. If the call is unsuccessful, an error is raised that can be intercepted by using an error handler.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCLogSummaryConfiguration


IFPCLogSummaryConfiguration.StartHour(long,long) property [ISA Server 2004]

StartHour Property of IFPCLogSummaryConfiguration[C++]

FPCLogSummaryConfiguration.StartHour [Visual Basic]

[C++]

The StartHour property gets or sets the hour at which the generation of daily log summaries will start. It is used together with the StartMinutes property to set the start time.

HRESULT get_StartHour(
  long* plHour
);

HRESULT put_StartHour(
  long lHour
);

Parameters

plHour
Pointer to a variable that on return receives a 32-bit integer specifying the hour at which the generation of daily log summaries will start.
lHour
A 32-bit integer that specifies the hour at which the generation of daily log summaries will start. The value must be between 0 and 23.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write. Its default value is 0.

The default time at which the generation of daily log summaries starts is 00:30 (12:30 A.M.).

[Visual Basic]

The StartHour property gets or sets the hour at which the generation of daily log summaries will start. It is used together with the StartMinutes property to set the start time.

Property StartHour As Long

Property Value

A 32-bit integer that specifies the hour at which the generation of daily log summaries will start. The value must be between 0 and 23.

Remarks

This property is read/write. Its default value is 0.

The default time at which the generation of daily log summaries starts is 00:30 (12:30 A.M.).

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCLogSummaryConfiguration


IFPCLogSummaryConfiguration.StartMinutes(Long,Long) property [ISA Server 2004]

StartMinutes Property of IFPCLogSummaryConfiguration[C++]

FPCLogSummaryConfiguration.StartMinutes [Visual Basic]

[C++]

The StartMinutes property gets or sets the minute during the hour specified by the StartHour property at which the generation of daily log summaries will start.

HRESULT get_StartMinutes(
  Long* plMinute
);

HRESULT put_StartMinutes(
  Long lMinute
);

Parameters

plMinute
Pointer to a variable that on return receives a 32-bit integer specifying the minute during the hour specified by the StartHour property at which the generation of daily log summaries will start.
lMinute
A 32-bit integer that specifies the minute during the hour specified by the StartHour property at which the generation of daily log summaries will start. The value must be between 0 and 59.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write. Its default value is 30.

The default time at which the generation of daily log summaries starts is 00:30 (12:30 A.M.).

[Visual Basic]

The StartMinutes property gets or sets the minute during the hour specified by the StartHour property at which the generation of daily log summaries will start.

Property StartMinutes As Long

Property Value

A 32-bit integer that specifies the minute during the hour specified by the StartHour property at which the generation of daily log summaries will start. The value must be between 0 and 59.

Remarks

This property is read/write. Its default value is 30.

The default time at which the generation of daily log summaries starts is 00:30 (12:30 A.M.).

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCLogSummaryConfiguration


FPCLogViewer object [ISA Server 2004]

FPCLogViewer

The FPCLogViewer object represents the log viewer for an array.

This object is typically accessed through the LogViewer property of the FPCArray object.

Click here to see the ISA Server object hierarchy.

Methods

This object has no methods.

Properties

The FPCLogViewer object has the following properties.

Property | Description
LogContentMSDE | Gets an FPCLogContent object that represents the Microsoft Data Engine (MSDE) log content.
LogContentOnline | Gets an FPCLogContent object that represents the online log content.

Remarks

This collection implements the IFPCLogViewer interface.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

COM Objects


IFPCLogViewer | FPCLogViewer LogContentMSDE property [ISA Server 2004]

LogContentMSDE Property of IFPCLogViewer[C++]

FPCLogViewer.LogContentMSDE [Visual Basic]

[C++]

The LogContentMSDE property gets an FPCLogContent object that represents the Microsoft Data Engine (MSDE) log content.

HRESULT get_LogContentMSDE(
  IFPCLogContent* ppLogContent
);

Parameters

ppLogContent
Address of an interface pointer that on return points to an IFPCLogContent interface representing the Microsoft Data Engine (MSDE) log content.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The LogContentMSDE property gets an FPCLogContent object that represents the Microsoft Data Engine (MSDE) log content.

Property LogContentMSDE As FPCLogContent

Property Value

Reference to an FPCLogContent object that represents the Microsoft Data Engine (MSDE) log content.

Remarks

This property is read-only.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCLogViewer


IFPCLogViewer | FPCLogViewer LogContentOnline property [ISA Server 2004]

LogContentOnline Property of IFPCLogViewer[C++]

FPCLogViewer.LogContentOnline [Visual Basic]

[C++]

The LogContentOnline property gets an FPCLogContent object that represents the online log content.

HRESULT get_LogContentOnline(
  IFPCLogContent* ppLogContent
);

Parameters

ppLogContent
Address of an interface pointer that on return points to an IFPCLogContent interface representing the online log content.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The LogContentOnline property gets an FPCLogContent object that represents the online log content.

Property LogContentOnline As FPCLogContent

Property Value

Reference to an FPCLogContent object that represents the online log content.

Remarks

This property is read-only.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCLogViewer


FPCLowLevelSettings object [ISA Server 2004]

FPCLowLevelSettings

The FPCLowLevelSettings object defines the low-level settings in the array policy. These settings include the sizes of the DNS cache and buffers used by the Microsoft Firewall service, settings that determine the number of waiting sockets on a Web listener, and more.

This object is typically accessed through the LowLevelSettings property of an FPCArrayPolicy object.

Click here to see the ISA Server object hierarchy.

Methods

This object has no methods.

Properties

The FPCLowLevelSettings object has the following properties.

Property | Description
DefaultAllowedAddressesInAllowFutureConnect | Gets or sets the allowed-addresses flags that will be included in the dwFlags parameter of the AllowFutureConnect method.
DefaultAllowedAddressesInBindForClient | Gets or sets the allowed-addresses flags that will be included in the dwFlags parameter of the BindForClient method.
DnsCacheNegativeTtl | Gets or sets the TTL, in seconds, of entries for unsuccessful lookups in the DNS cache.
DnsCacheRecordMaxKB | Gets or sets the maximum size of a single record in the DNS cache, in kilobytes.
DnsCacheSize | Gets or sets the maximum size of the DNS cache for the Microsoft Firewall service.
FwxListenerMaxPendingAccepts | Gets or sets the maximum total number of sockets that are waiting for an incoming connection or for the first block of data on all Web listeners defined in the array.
FwxListenerMaxPercent | Gets or sets the maximum percentage of sockets that are waiting for the first block of data out of the total number of sockets that are waiting for an incoming connection or for the first block of data on a Web listener.
FwxListenerMinPercent | Gets or sets the minimum percentage of sockets that are waiting for the first block of data out of the total number of sockets that are waiting for an incoming connection or for the first block of data on a Web listener.
FwxListenerToCreatePercent | Gets or sets the percentage of the current number of sockets waiting for an incoming connection or for the first block of data on a Web listener that will be created when the percentage of sockets that are waiting for the first block of data out of the total number of waiting sockets on a Web listener reaches the maximum specified in the FwxListenerMaxPercent property.
FwxListenerToKillPercent | Gets or sets the percentage of the current number of sockets waiting for an incoming connection or for the first block of data on a Web listener for which new waiting sockets will not be created as they complete their pending operations when the percentage of sockets that are waiting for the first block of data out of the total number of waiting sockets on the Web listener drops to the minimum specified in the FwxListenerMinPercent property.
MaxNumberOfPendingIoOfConnections | Gets or sets the maximum number of buffers for pending I/O operations that the Microsoft Firewall service data pump allows to accumulate in connections through which it passes data.
TcpBufferSize | Gets or sets the size of the buffers used by the Microsoft Firewall service when transferring data for connections using the TCP protocol.
UdpBufferSize | Gets or sets the size of the buffers used by the Microsoft Firewall service when transferring data for connections using the UDP protocol.

Remarks

This object implements the IFPCLowLevelSettings interface.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

COM Objects


DefaultAllowedAddressesInAllowFutureConnect property [ISA Server 2004]

DefaultAllowedAddressesInAllowFutureConnect Property of IFPCLowLevelSettings[C++]

FPCLowLevelSettings.DefaultAllowedAddressesInAllowFutureConnect [Visual Basic]

[C++]

The DefaultAllowedAddressesInAllowFutureConnect property gets or sets the allowed-addresses flags that will be included in the dwFlags parameter of the AllowFutureConnect method.

HRESULT get_DefaultAllowedAddressesInAllowFutureConnect(
  long* plAllowedAddresses
);

HRESULT put_DefaultAllowedAddressesInAllowFutureConnect(
  long lAllowedAddresses
);

Parameters

plAllowedAddresses
Pointer to a variable that on return receives a 32-bit integer specifying the allowed-addresses flags that will be included in the dwFlags parameter of the AllowFutureConnect method.
lAllowedAddresses
A 32-bit integer that specifies the default allowed-addresses flags that will be included in the dwFlags parameter of the AllowFutureConnect method. This parameter can be any combination of the following flags:
Value | Meaning
FWX_FLAG_ALLOW_ADDRESSES_IN_CLASS_C_NETWORK | If the address specified in the Address parameter of the AllowFutureConnect method is in the same class-C network as the external peer, a secondary connection to it will be allowed.
FWX_FLAG_ALLOW_ADDRESSES_IN_NETWORK | If the address specified in the Address parameter is in the same network as the external peer, a secondary connection to it will be allowed.
FWX_FLAG_ALLOW_ADDRESSES_ALL | A secondary connection will be allowed to any address that is specified in the Address parameter.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write.

The AllowFutureConnect method uses the flags specified in this property only when the dwFlags parameter does not include any of the flags listed earlier. Otherwise, the method uses the flags passed in the dwFlags parameter.

[Visual Basic]

The DefaultAllowedAddressesInAllowFutureConnect property gets or sets the allowed-addresses flags that will be included in the dwFlags parameter of the AllowFutureConnect method.

Property DefaultAllowedAddressesInAllowFutureConnect As Long

Property Value

A 32-bit integer that specifies the default allowed-addresses flags that will be included in the dwFlags parameter of the AllowFutureConnect method. The value of this property can be any combination of the following flags:
Value | Meaning
FWX_FLAG_ALLOW_ADDRESSES_IN_CLASS_C_NETWORK | If the address specified in the Address parameter of the AllowFutureConnect method is in the same class-C network as the external peer, a secondary connection to it will be allowed.
FWX_FLAG_ALLOW_ADDRESSES_IN_NETWORK | If the address specified in the Address parameter is in the same network as the external peer, a secondary connection to it will be allowed.
FWX_FLAG_ALLOW_ADDRESSES_ALL | A secondary connection will be allowed to any address that is specified in the Address parameter.

Remarks

This property is read/write.

The AllowFutureConnect method uses the flags specified in this property only when the dwFlags parameter does not include any of the flags listed earlier. Otherwise, the method uses the flags passed in the dwFlags parameter.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCLowLevelSettings


DefaultAllowedAddressesInBindForClient property [ISA Server 2004]

DefaultAllowedAddressesInBindForClient Property of IFPCLowLevelSettings[C++]

FPCLowLevelSettings.DefaultAllowedAddressesInBindForClient [Visual Basic]

[C++]

The DefaultAllowedAddressesInBindForClient property gets or sets the allowed-addresses flags that will be included in the dwFlags parameter of the BindForClient method.

HRESULT get_DefaultAllowedAddressesInBindForClient(
  long* plAllowedAddresses
);

HRESULT put_DefaultAllowedAddressesInBindForClient(
  long lAllowedAddresses
);

Parameters

plAllowedAddresses
Pointer to a variable that on return receives a 32-bit integer specifying the allowed-addresses flags that will be included in the dwFlags parameter of the BindForClient method.
lAllowedAddresses
A 32-bit integer that specifies the allowed-addresses flags that will be included in the dwFlags parameter of the BindForClient method. This parameter can be any combination of the following flags:
Value | Meaning
FWX_FLAG_ALLOW_ADDRESSES_IN_CLASS_C_NETWORK | If all of the addresses specified in the ClientAddress parameter of the BindForClient method are in the same class-C network as the client, secondary connections to them will be allowed.
FWX_FLAG_ALLOW_ADDRESSES_IN_NETWORK | If all of the addresses specified in the ClientAddress parameter are in the same network as the client, secondary connections to them will be allowed.
FWX_FLAG_ALLOW_ADDRESSES_ALL | A secondary connection will be allowed to any address specified in the ClientAddress parameter.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write.

The BindForClient method uses the flags specified in this property only when the dwFlags parameter does not include any of the flags listed earlier. Otherwise, the method uses the flags passed in the dwFlags parameter.

[Visual Basic]

The DefaultAllowedAddressesInBindForClient property gets or sets the allowed-addresses flags that will be included in the dwFlags parameter of the BindForClient method.

Property DefaultAllowedAddressesInBindForClient As Long

Property Value

A 32-bit integer that specifies the default allowed-addresses flags that will be included in the dwFlags parameter of the BindForClient method. The value of this property can be any combination of the following flags:
Value | Meaning
FWX_FLAG_ALLOW_ADDRESSES_IN_CLASS_C_NETWORK | If all of the addresses specified in the ClientAddress parameter of the BindForClient method are in the same class-C network as the client, secondary connections to them will be allowed.
FWX_FLAG_ALLOW_ADDRESSES_IN_NETWORK | If all of the addresses specified in the ClientAddress parameter are in the same network as the client, secondary connections to them will be allowed.
FWX_FLAG_ALLOW_ADDRESSES_ALL | A secondary connection will be allowed to any address specified in the ClientAddress parameter.

Remarks

This property is read/write.

The BindForClient method uses the flags specified in this property only when the dwFlags parameter does not include any of the flags listed earlier. Otherwise, the method uses the flags passed in the dwFlags parameter.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCLowLevelSettings


IFPCLowLevelSettings.DnsCacheNegativeTtl(long,long) property [ISA Server 2004]

DnsCacheNegativeTtl Property of IFPCLowLevelSettings[C++]

FPCLowLevelSettings.DnsCacheNegativeTtl [Visual Basic]

[C++]

The DnsCacheNegativeTtl property gets or sets the TTL, in seconds, of entries for unsuccessful lookups in the DNS cache.

HRESULT get_DnsCacheNegativeTtl(
  long* plTTL
);

HRESULT put_DnsCacheNegativeTtl(
  long lTTL
);

Parameters

plTTL
Pointer to a variable that on return receives a 32-bit integer specifying the TTL, in seconds, of entries for unsuccessful lookups in the DNS cache.
lTTL
A 32-bit integer that specifies the TTL, in seconds, of entries for unsuccessful lookups in the DNS cache.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write.

[Visual Basic]

The DnsCacheNegativeTtl property gets or sets the TTL, in seconds, of entries for unsuccessful lookups in the DNS cache.

Property DnsCacheNegativeTtl As Long

Property Value

A 32-bit integer that specifies the TTL, in seconds, of entries for unsuccessful lookups in the DNS cache.

Remarks

This property is read/write.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCLowLevelSettings


IFPCLowLevelSettings.DnsCacheRecordMaxKB(long,long) property [ISA Server 2004]

DnsCacheRecordMaxKB Property of IFPCLowLevelSettings[C++]

FPCLowLevelSettings.DnsCacheRecordMaxKB [Visual Basic]

[C++]

The DnsCacheRecordMaxKB property gets or sets the maximum size of a single record in the DNS cache, in kilobytes.

HRESULT get_DnsCacheRecordMaxKB(
  long* plMaxSize
);

HRESULT put_DnsCacheRecordMaxKB(
  long lMaxSize
);

Parameters

plMaxSize
Pointer to a variable that on return receives a 32-bit integer specifying the maximum size of a single record in the DNS cache, in kilobytes.
lMaxSize
A 32-bit integer that specifies the maximum size of a single record in the DNS cache, in kilobytes.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write.

[Visual Basic]

The DnsCacheRecordMaxKB property gets or sets the maximum size of a single record in the DNS cache, in kilobytes.

Property DnsCacheRecordMaxKB As Long

Property Value

A 32-bit integer that specifies the maximum size of a single record in the DNS cache, in kilobytes.

Remarks

This property is read/write.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCLowLevelSettings


IFPCLowLevelSettings.DnsCacheSize(long,long) property [ISA Server 2004]

DnsCacheSize Property of IFPCLowLevelSettings[C++]

FPCLowLevelSettings.DnsCacheSize [Visual Basic]

[C++]

The DnsCacheSize property gets or sets the maximum size of the DNS cache for the Microsoft Firewall service.

HRESULT get_DnsCacheSize(
  long* plDnsCacheSize
);

HRESULT put_DnsCacheSize(
  long lDnsCacheSize
);

Parameters

plDnsCacheSize
Pointer to a variable that on return receives a 32-bit integer specifying the maximum size of the DNS cache for the Firewall service.
lDnsCacheSize
A 32-bit integer that specifies the maximum size of the DNS cache for the Firewall service.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write.

[Visual Basic]

The DnsCacheSize property gets or sets the maximum size of the DNS cache for the Microsoft Firewall service.

Property DnsCacheSize As Long

Property Value

A 32-bit integer that specifies the maximum size of the DNS cache for the Firewall service.

Remarks

This property is read/write.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCLowLevelSettings


IFPCLowLevelSettings.FwxListenerMaxPendingAccepts property [ISA Server 2004]

FwxListenerMaxPendingAccepts Property of IFPCLowLevelSettings[C++]

FPCLowLevelSettings.FwxListenerMaxPendingAccepts [Visual Basic]

[C++]

The FwxListenerMaxPendingAccepts property gets or sets the maximum total number of sockets that are waiting for an incoming connection or for the first block of data on all Web listeners defined in the array.

HRESULT get_FwxListenerMaxPendingAccepts(
  long* plMaxPendingAccepts
);

HRESULT put_FwxListenerMaxPendingAccepts(
  long lMaxPendingAccepts
);

Parameters

plMaxPendingAccepts
Pointer to a variable that on return receives a 32-bit integer specifying the maximum total number of waiting sockets on all Web listeners defined in the array.
lMaxPendingAccepts
A 32-bit integer that specifies the maximum total number of waiting sockets on all Web listeners defined in the array.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write. Its default value is 15,000. In common scenarios, there is no need to deviate from the default value. This value should be adjusted only for achieving improved performance.

For each Web listener, the Microsoft Firewall service initially creates 50 sockets that wait to accept a new incoming connection and to receive the first block of data. As each of these sockets completes its tasks of accepting a new incoming connection and receiving the first block of data, a new waiting socket is created for the Web listener.

Some of the waiting sockets can be in a state in which they have accepted an incoming connection, but have not received the first block of data. The Firewall service monitors the number of sockets in this state for each Web listener and maintains the percentage of waiting sockets that are in this state between the minimum percentage specified by the FwxListenerMinPercent property and the maximum percentage specified by the FwxListenerMaxPercent property. When the percentage drops to the minimum value, the Firewall service stops creating new waiting sockets for the Web listener until the number of waiting sockets decreases by the current number multiplied by the percentage specified in the FwxListenerToKillPercent property. When the percentage reaches the maximum value, the Firewall service creates new waiting sockets for the Web listener. The number of sockets created equals the current number of waiting sockets multiplied by the percentage specified in the FwxListenerToCreatePercent property.

If the total number of waiting sockets on all Web listeners defined in the array exceeds the number specified by the FwxListenerMaxPendingAccepts property, no new sockets are created.

[Visual Basic]

The FwxListenerMaxPendingAccepts property gets or sets the maximum total number of sockets that are waiting for an incoming connection or for the first block of data on all Web listeners defined in the array.

Property FwxListenerMaxPendingAccepts As Long

Property Value

A 32-bit integer that specifies the maximum total number of waiting sockets on all Web listeners defined in the array.

Remarks

This property is read/write. Its default value is 15,000. In common scenarios, there is no need to deviate from the default value. This value should be adjusted only for achieving improved performance.

For each Web listener, the Microsoft Firewall service initially creates 50 sockets that wait to accept a new incoming connection and to receive the first block of data. As each of these sockets completes its tasks of accepting a new incoming connection and receiving the first block of data, a new waiting socket is created for the Web listener.

Some of the waiting sockets can be in a state in which they have accepted an incoming connection, but have not received the first block of data. The Firewall service monitors the number of sockets in this state for each Web listener and maintains the percentage of waiting sockets that are in this state between the minimum percentage specified by the FwxListenerMinPercent property and the maximum percentage specified by the FwxListenerMaxPercent property. When the percentage drops to the minimum value, the Firewall service stops creating new waiting sockets for the Web listener until the number of waiting sockets decreases by the current number multiplied by the percentage specified in the FwxListenerToKillPercent property. When the percentage reaches the maximum value, the Firewall service creates new waiting sockets for the Web listener. The number of sockets created equals the current number of waiting sockets multiplied by the percentage specified in the FwxListenerToCreatePercent property.

If the total number of waiting sockets on all Web listeners defined in the array exceeds the number specified by the FwxListenerMaxPendingAccepts property, no new sockets are created.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCLowLevelSettings


IFPCLowLevelSettings.FwxListenerMaxPercent(long,long) property [ISA Server 2004]

FwxListenerMaxPercent Property of IFPCLowLevelSettings[C++]

FPCLowLevelSettings.FwxListenerMaxPercent [Visual Basic]

[C++]

The FwxListenerMaxPercent property gets or sets the maximum percentage of sockets that are waiting for the first block of data out of the total number of sockets that are waiting for an incoming connection or for the first block of data on a Web listener. When the percentage reaches this maximum, new sockets are created. The number of sockets created equals the current number of waiting sockets multiplied by the percentage specified in the FwxListenerToCreatePercent property.

HRESULT get_FwxListenerMaxPercent(
  long* plFwxListenerMaxPercent
);

HRESULT put_FwxListenerMaxPercent(
  long lFwxListenerMaxPercent
);

Parameters

plFwxListenerMaxPercent
Pointer to a variable that on return receives a 32-bit integer specifying the maximum percentage of sockets that are waiting for the first block of data out of the total number of sockets that are waiting for an incoming connection or for the first block of data on a Web listener.
lFwxListenerMaxPercent
A 32-bit integer that specifies the maximum percentage of sockets that are waiting for the first block of data out of the total number of sockets that are waiting for an incoming connection or for the first block of data on a Web listener.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write. Its default value is 40, and its range of permissible values is from 1 to 99. In common scenarios, there is no need to deviate from the default value. This value should be adjusted only for achieving improved performance.

For each Web listener, the Microsoft Firewall service initially creates 50 sockets that wait to accept a new incoming connection and to receive the first block of data. As each of these sockets completes its tasks of accepting a new incoming connection and receiving the first block of data, a new waiting socket is created for the Web listener.

Some of the waiting sockets can be in a state in which they have accepted an incoming connection, but have not received the first block of data. The Firewall service monitors the number of sockets in this state for each Web listener and maintains the percentage of waiting sockets that are in this state between the minimum percentage specified by the FwxListenerMinPercent property and the maximum percentage specified by the FwxListenerMaxPercent property. When the percentage drops to the minimum value, the Firewall service stops creating new waiting sockets for the Web listener until the number of waiting sockets decreases by the current number multiplied by the percentage specified in the FwxListenerToKillPercent property. When the percentage reaches the maximum value, the Firewall service creates new waiting sockets for the Web listener. The number of sockets created equals the current number of waiting sockets multiplied by the percentage specified in the FwxListenerToCreatePercent property.

If the total number of waiting sockets on all Web listeners defined in the array exceeds the number specified by the FwxListenerMaxPendingAccepts property no new sockets are created.

[Visual Basic]

The FwxListenerMaxPercent property gets or sets the maximum percentage of sockets that are waiting for the first block of data out of the total number of sockets that are waiting for an incoming connection or for the first block of data on a Web listener. When the percentage reaches this maximum, new sockets are created. The number of sockets created equals the current number of waiting sockets multiplied by the percentage specified in the FwxListenerToCreatePercent property.

Property FwxListenerMaxPercent As Long

Property Value

A 32-bit integer that specifies the maximum percentage of sockets that are waiting for the first block of data out of the total number of sockets that are waiting for an incoming connection or for the first block of data on a Web listener.

Remarks

This property is read/write. Its default value is 40, and its range of permissible values is from 1 to 99. In common scenarios, there is no need to deviate from the default value. This value should be adjusted only for achieving improved performance.

For each Web listener, the Microsoft Firewall service initially creates 50 sockets that wait to accept a new incoming connection and to receive the first block of data. As each of these sockets completes its tasks of accepting a new incoming connection and receiving the first block of data, a new waiting socket is created for the Web listener.

Some of the waiting sockets can be in a state in which they have accepted an incoming connection, but have not received the first block of data. The Firewall service monitors the number of sockets in this state for each Web listener and maintains the percentage of waiting sockets that are in this state between the minimum percentage specified by the FwxListenerMinPercent property and the maximum percentage specified by the FwxListenerMaxPercent property. When the percentage drops to the minimum value, the Firewall service stops creating new waiting sockets for the Web listener until the number of waiting sockets decreases by the current number multiplied by the percentage specified in the FwxListenerToKillPercent property. When the percentage reaches the maximum value, the Firewall service creates new waiting sockets for the Web listener. The number of sockets created equals the current number of waiting sockets multiplied by the percentage specified in the FwxListenerToCreatePercent property.

If the total number of waiting sockets on all Web listeners defined in the array exceeds the number specified by the FwxListenerMaxPendingAccepts property no new sockets are created.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCLowLevelSettings


IFPCLowLevelSettings.FwxListenerMinPercent(long,long) property [ISA Server 2004]

FwxListenerMinPercent Property of IFPCLowLevelSettings[C++]

FPCLowLevelSettings.FwxListenerMinPercent [Visual Basic]

[C++]

The FwxListenerMinPercent property gets or sets the minimum percentage of sockets that are waiting for the first block of data out of the total number of sockets that are waiting for an incoming connection or for the first block of data on a Web listener. When the percentage drops to this minimum, no new sockets are created until the number of waiting sockets decreases by the current number multiplied by the percentage specified in the FwxListenerToKillPercent property.

HRESULT get_FwxListenerMinPercent(
  long* plListenerMinPercent
);

HRESULT put_FwxListenerMinPercent(
  long lListenerMinPercent
);

Parameters

plListenerMinPercent
Pointer to a variable that on return receives a 32-bit integer specifying the minimum percentage of sockets that are waiting for the first block of data out of the total number of sockets that are waiting for an incoming connection or for the first block of data on a Web listener.
lListenerMinPercent
A 32-bit integer that specifies the minimum percentage of sockets that are waiting for the first block of data out of the total number of sockets that are waiting for an incoming connection or for the first block of data on a Web listener.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write. Its default value is 3, and its range of permissible values is from 0 to 99. In common scenarios, there is no need to deviate from the default value. This value should be adjusted only for achieving improved performance.

For each Web listener, the Microsoft Firewall service initially creates 50 sockets that wait to accept a new incoming connection and to receive the first block of data. As each of these sockets completes its tasks of accepting a new incoming connection and receiving the first block of data, a new waiting socket is created for the Web listener.

Some of the waiting sockets can be in a state in which they have accepted an incoming connection, but have not received the first block of data. The Firewall service monitors the number of sockets in this state for each Web listener and maintains the percentage of waiting sockets that are in this state between the minimum percentage specified by the FwxListenerMinPercent property and the maximum percentage specified by the FwxListenerMaxPercent property. When the percentage drops to the minimum value, the Firewall service stops creating new waiting sockets for the Web listener until the number of waiting sockets decreases by the current number multiplied by the percentage specified in the FwxListenerToKillPercent property. When the percentage reaches the maximum value, the Firewall service creates new waiting sockets for the Web listener. The number of sockets created equals the current number of waiting sockets multiplied by the percentage specified in the FwxListenerToCreatePercent property.

If the total number of waiting sockets on all Web listeners defined in the array exceeds the number specified by the FwxListenerMaxPendingAccepts property, no new sockets are created.

[Visual Basic]

The FwxListenerMinPercent property gets or sets the minimum percentage of sockets that are waiting for the first block of data out of the total number of sockets that are waiting for an incoming connection or for the first block of data on a Web listener. When the percentage drops to this minimum, no new sockets are created until the number of waiting sockets decreases by the current number multiplied by the percentage specified in the FwxListenerToKillPercent property.

Property FwxListenerMinPercent As Long

Property Value

A 32-bit integer that specifies the minimum percentage of sockets that are waiting for the first block of data out of the total number of sockets that are waiting for an incoming connection or for the first block of data on a Web listener.

Remarks

This property is read/write. Its default value is 3, and its range of permissible values is from 0 to 99. In common scenarios, there is no need to deviate from the default value. This value should be adjusted only for achieving improved performance.

For each Web listener, the Microsoft Firewall service initially creates 50 sockets that wait to accept a new incoming connection and to receive the first block of data. As each of these sockets completes its tasks of accepting a new incoming connection and receiving the first block of data, a new waiting socket is created for the Web listener.

Some of the waiting sockets can be in a state in which they have accepted an incoming connection, but have not received the first block of data. The Firewall service monitors the number of sockets in this state for each Web listener and maintains the percentage of waiting sockets that are in this state between the minimum percentage specified by the FwxListenerMinPercent property and the maximum percentage specified by the FwxListenerMaxPercent property. When the percentage drops to the minimum value, the Firewall service stops creating new waiting sockets for the Web listener until the number of waiting sockets decreases by the current number multiplied by the percentage specified in the FwxListenerToKillPercent property. When the percentage reaches the maximum value, the Firewall service creates new waiting sockets for the Web listener. The number of sockets created equals the current number of waiting sockets multiplied by the percentage specified in the FwxListenerToCreatePercent property.

If the total number of waiting sockets on all Web listeners defined in the array exceeds the number specified by the FwxListenerMaxPendingAccepts property, no new sockets are created.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCLowLevelSettings


IFPCLowLevelSettings.FwxListenerToCreatePercent property [ISA Server 2004]

FwxListenerToCreatePercent Property of IFPCLowLevelSettings[C++]

FPCLowLevelSettings.FwxListenerToCreatePercent [Visual Basic]

[C++]

The FwxListenerToCreatePercent property gets or sets the percentage of the current number of sockets waiting for an incoming connection or for the first block of data on a Web listener that will be created when the percentage of sockets that are waiting for the first block of data out of the total number of waiting sockets on a Web listener reaches the maximum specified in the FwxListenerMaxPercent property.

HRESULT get_FwxListenerToCreatePercent(
  long* plPercentToCreate
);

HRESULT put_FwxListenerToCreatePercent(
  long lPercentToCreate
);

Parameters

plPercentToCreate
Pointer to a variable that on return receives a 32-bit integer specifying the percentage of the current number of sockets waiting for an incoming connection or for the first block of data on a Web listener that will be created when the percentage of sockets that are waiting for the first block of data out of the total number of waiting sockets on a Web listener reaches the maximum specified in the FwxListenerMaxPercent property.
lPercentToCreate
A 32-bit integer that specifies the percentage of the current number of sockets waiting for an incoming connection or for the first block of data on a Web listener that will be created when the percentage of sockets that are waiting for the first block of data out of the total number of waiting sockets on a Web listener reaches the maximum specified in the FwxListenerMaxPercent property.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write. Its default value is 240, and its range of permissible values is from 1 to 255. In common scenarios, there is no need to deviate from the default value. This value should be adjusted only for achieving improved performance.

For each Web listener, the Microsoft Firewall service initially creates 50 sockets that wait to accept a new incoming connection and to receive the first block of data. As each of these sockets completes its tasks of accepting a new incoming connection and receiving the first block of data, a new waiting socket is created for the Web listener.

Some of the waiting sockets can be in a state in which they have accepted an incoming connection, but have not received the first block of data. The Firewall service monitors the number of sockets in this state for each Web listener and maintains the percentage of waiting sockets that are in this state between the minimum percentage specified by the FwxListenerMinPercent property and the maximum percentage specified by the FwxListenerMaxPercent property. When the percentage drops to the minimum value, the Firewall service stops creating new waiting sockets for the Web listener until the number of waiting sockets decreases by the current number multiplied by the percentage specified in the FwxListenerToKillPercent property. When the percentage reaches the maximum value, the Firewall service creates new waiting sockets for the Web listener. The number of sockets created equals the current number of waiting sockets multiplied by the percentage specified in the FwxListenerToCreatePercent property.

If the total number of waiting sockets on all Web listeners defined in the array exceeds the number specified by the FwxListenerMaxPendingAccepts property, no new sockets are created.

[Visual Basic]

The FwxListenerToCreatePercent property gets or sets the percentage of the current number of sockets waiting for an incoming connection or for the first block of data on a Web listener that will be created when the percentage of sockets that are waiting for the first block of data out of the total number of waiting sockets on a Web listener reaches the maximum specified in the FwxListenerMaxPercent property.

Property FwxListenerToCreatePercent As Long

Property Value

A 32-bit integer that specifies the percentage of the current number of sockets waiting for an incoming connection or for the first block of data on a Web listener that will be created when the percentage of sockets that are waiting for the first block of data out of the total number of waiting sockets on a Web listener reaches the maximum specified in the FwxListenerMaxPercent property.

Remarks

This property is read/write. Its default value is 240, and its range of permissible values is from 1 to 255. In common scenarios, there is no need to deviate from the default value. This value should be adjusted only for achieving improved performance.

For each Web listener, the Microsoft Firewall service initially creates 50 sockets that wait to accept a new incoming connection and to receive the first block of data. As each of these sockets completes its tasks of accepting a new incoming connection and receiving the first block of data, a new waiting socket is created for the Web listener.

Some of the waiting sockets can be in a state in which they have accepted an incoming connection, but have not received the first block of data. The Firewall service monitors the number of sockets in this state for each Web listener and maintains the percentage of waiting sockets that are in this state between the minimum percentage specified by the FwxListenerMinPercent property and the maximum percentage specified by the FwxListenerMaxPercent property. When the percentage drops to the minimum value, the Firewall service stops creating new waiting sockets for the Web listener until the number of waiting sockets decreases by the current number multiplied by the percentage specified in the FwxListenerToKillPercent property. When the percentage reaches the maximum value, the Firewall service creates new waiting sockets for the Web listener. The number of sockets created equals the current number of waiting sockets multiplied by the percentage specified in the FwxListenerToCreatePercent property.

If the total number of waiting sockets on all Web listeners defined in the array exceeds the number specified by the FwxListenerMaxPendingAccepts property, no new sockets are created.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCLowLevelSettings


IFPCLowLevelSettings.FwxListenerToKillPercent property [ISA Server 2004]

FwxListenerToKillPercent Property of IFPCLowLevelSettings[C++]

FPCLowLevelSettings.FwxListenerToKillPercent [Visual Basic]

[C++]

The FwxListenerToKillPercent property gets or sets the percentage of the current number of sockets waiting for an incoming connection or for the first block of data on a Web listener for which new waiting sockets will not be created as they complete their pending operations when the percentage of sockets that are waiting for the first block of data out of the total number of waiting sockets on the Web listener drops to the minimum specified in the FwxListenerMinPercent property.

HRESULT get_FwxListenerToKillPercent(
  long* plPercentToKill
);

HRESULT put_FwxListenerToKillPercent(
  long lPercentToKill
);

Parameters

plPercentToKill
Pointer to a variable that on return receives a 32-bit integer specifying the percentage of the current number of sockets waiting for an incoming connection or for the first block of data on a Web listener for which new waiting sockets will not be created as they complete their pending operations when the percentage of sockets that are waiting for the first block of data out of the total number of waiting sockets on the Web listener drops to the minimum specified in the FwxListenerMinPercent property.
lPercentToKill
A 32-bit integer that specifies the percentage of the current number of sockets waiting for an incoming connection or for the first block of data on a Web listener for which new waiting sockets will not be created as they complete their pending operations when the percentage of sockets that are waiting for the first block of data out of the total number of waiting sockets on the Web listener drops to the minimum specified in the FwxListenerMinPercent property.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write. Its default value is 5, and its range of permissible values is from 1 to 99. In common scenarios, there is no need to deviate from the default value. This value should be adjusted only for achieving improved performance.

For each Web listener, the Microsoft Firewall service initially creates 50 sockets that wait to accept a new incoming connection and to receive the first block of data. As each of these sockets completes its tasks of accepting a new incoming connection and receiving the first block of data, a new waiting socket is created for the Web listener.

Some of the waiting sockets can be in a state in which they have accepted an incoming connection, but have not received the first block of data. The Firewall service monitors the number of sockets in this state for each Web listener and maintains the percentage of waiting sockets that are in this state between the minimum percentage specified by the FwxListenerMinPercent property and the maximum percentage specified by the FwxListenerMaxPercent property. When the percentage drops to the minimum value, the Firewall service stops creating new waiting sockets for the Web listener until the number of waiting sockets decreases by the current number multiplied by the percentage specified in the FwxListenerToKillPercent property. When the percentage reaches the maximum value, the Firewall service creates new waiting sockets for the Web listener. The number of sockets created equals the current number of waiting sockets multiplied by the percentage specified in the FwxListenerToCreatePercent property.

If the total number of waiting sockets on all Web listeners defined in the array exceeds the number specified by the FwxListenerMaxPendingAccepts property, no new sockets are created.

[Visual Basic]

The FwxListenerToKillPercent property gets or sets the percentage of the current number of sockets waiting for an incoming connection or for the first block of data on a Web listener for which new waiting sockets will not be created as they complete their pending operations when the percentage of sockets that are waiting for the first block of data out of the total number of waiting sockets on the Web listener drops to the minimum specified in the FwxListenerMinPercent property.

Property FwxListenerToKillPercent As Long

Property Value

A 32-bit integer that specifies the percentage of the current number of sockets waiting for an incoming connection or for the first block of data on a Web listener for which new waiting sockets will not be created as they complete their pending operations when the percentage of sockets that are waiting for the first block of data out of the total number of waiting sockets on the Web listener drops to the minimum specified in the FwxListenerMinPercent property.

Remarks

This property is read/write. Its default value is 5, and its range of permissible values is from 1 to 99. In common scenarios, there is no need to deviate from the default value. This value should be adjusted only for achieving improved performance.

For each Web listener, the Microsoft Firewall service initially creates 50 sockets that wait to accept a new incoming connection and to receive the first block of data. As each of these sockets completes its tasks of accepting a new incoming connection and receiving the first block of data, a new waiting socket is created for the Web listener.

Some of the waiting sockets can be in a state in which they have accepted an incoming connection, but have not received the first block of data. The Firewall service monitors the number of sockets in this state for each Web listener and maintains the percentage of waiting sockets that are in this state between the minimum percentage specified by the FwxListenerMinPercent property and the maximum percentage specified by the FwxListenerMaxPercent property. When the percentage drops to the minimum value, the Firewall service stops creating new waiting sockets for the Web listener until the number of waiting sockets decreases by the current number multiplied by the percentage specified in the FwxListenerToKillPercent property. When the percentage reaches the maximum value, the Firewall service creates new waiting sockets for the Web listener. The number of sockets created equals the current number of waiting sockets multiplied by the percentage specified in the FwxListenerToCreatePercent property.

If the total number of waiting sockets on all Web listeners defined in the array exceeds the number specified by the FwxListenerMaxPendingAccepts property, no new sockets are created.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCLowLevelSettings


MaxNumberOfPendingIoOfConnections property [ISA Server 2004]

MaxNumberOfPendingIoOfConnections Property of IFPCLowLevelSettings[C++]

FPCLowLevelSettings.MaxNumberOfPendingIoOfConnections [Visual Basic]

[C++]

The MaxNumberOfPendingIoOfConnections property gets or sets the maximum number of buffers for pending I/O operations that the Microsoft Firewall service data pump allows to accumulate in connections through which it passes data.

HRESULT get_MaxNumberOfPendingIoOfConnections(
  long* plMaxNumber
);

HRESULT put_MaxNumberOfPendingIoOfConnections(
  long lMaxNumber
);

Parameters

plMaxNumber
Pointer to a variable that on return receives a 32-bit integer specifying the maximum number of buffers for pending I/O operations that the Firewall service data pump allows to accumulate in connections through which it passes data.
lMaxNumber
A 32-bit integer that specifies the maximum number of buffers for pending I/O operations that the Firewall service data pump allows to accumulate in connections through which it passes data.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write.

[Visual Basic]

The MaxNumberOfPendingIoOfConnections property gets or sets the maximum number of buffers for pending I/O operations that the Microsoft Firewall service data pump allows to accumulate in connections through which it passes data.

Property MaxNumberOfPendingIoOfConnections As Long

Property Value

A 32-bit integer that specifies the maximum number of buffers for pending I/O operations that the Firewall service data pump allows to accumulate in connections through which it passes data.

Remarks

This property is read/write.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCLowLevelSettings


IFPCLowLevelSettings.TcpBufferSize(long,long) property [ISA Server 2004]

TcpBufferSize Property of IFPCLowLevelSettings[C++]

FPCLowLevelSettings.TcpBufferSize [Visual Basic]

[C++]

The TcpBufferSize property gets or sets the size of the buffers used by the Microsoft Firewall service when transferring data for connections using the TCP protocol.

HRESULT get_TcpBufferSize(
  long* plSize
);

HRESULT put_TcpBufferSize(
  long lSize
);

Parameters

plSize
Pointer to a variable that on return receives a 32-bit integer specifying the size of the buffers used by the Firewall service when transferring data for connections using the TCP protocol.
lSize
A 32-bit integer that specifies the size of the buffers used by the Firewall service when transferring data for connections using the TCP protocol.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write.

[Visual Basic]

The TcpBufferSize property gets or sets the size of the buffers used by the Microsoft Firewall service when transferring data for connections using the TCP protocol.

Property TcpBufferSize As Long

Property Value

A 32-bit integer that specifies the size of the buffers used by the Firewall service when transferring data for connections using the TCP protocol.

Remarks

This property is read/write.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCLowLevelSettings


IFPCLowLevelSettings.UdpBufferSize(long,long) property [ISA Server 2004]

UdpBufferSize Property of IFPCLowLevelSettings[C++]

FPCLowLevelSettings.UdpBufferSize [Visual Basic]

[C++]

The UdpBufferSize property gets or sets the size of the buffers used by the Microsoft Firewall service when transferring data for connections using the UDP protocol.

HRESULT get_UdpBufferSize(
  long* plSize
);

HRESULT put_UdpBufferSize(
  long lSize
);

Parameters

plSize
Pointer to a variable that on return receives a 32-bit integer specifying the size of the buffers used by the Firewall service when transferring data for connections using the UDP protocol.
lSize
A 32-bit integer that specifies the size of the buffers used by the Firewall service when transferring data for connections using the UDP protocol.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write.

[Visual Basic]

The UdpBufferSize property gets or sets the size of the buffers used by the Microsoft Firewall service when transferring data for connections using the UDP protocol.

Property UdpBufferSize As Long

Property Value

A 32-bit integer that specifies the size of the buffers used by the Firewall service when transferring data for connections using the UDP protocol.

Remarks

This property is read/write.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCLowLevelSettings


FPCNetwork object [ISA Server 2004]

FPCNetwork

The FPCNetwork object represents a single network. A network is a rule element, which can contain one or more ranges of IP addresses and domains. The networks that are defined for an ISA Server computer should reflect the physical network topology as viewed from the ISA Server computer. Any host having an IP address that is included in a network should be able to exchange traffic with any other host having an IP address that is included in the network without passing it through the ISA Server computer. Rules can be applied to one or more networks, or to all IP addresses except those in a specified network.

ISA Server is installed with the following predefined networks:

  • Local Host. This network represents the ISA Server computer. The Local Host network cannot be modified or deleted.
  • Default External. This network includes all IP addresses that are not associated with any other network. The Default External network cannot be modified or deleted.
  • Internal. The ranges of IP addresses included in the Internal network are initially specified during the installation process. The Internal network cannot be deleted.
  • VPN Clients. This network contains addresses of currently connected VPN clients. The possible IP addresses that can be assigned to VPN clients and moved into this network are included in the VPN static address pool (VpnStaticAddressPool) of the ISA Server computer. The VPN Clients network cannot be deleted.
  • Quarantined VPN Clients. This network contains addresses of VPN clients that have not yet cleared quarantine. The Quarantined VPN Clients network cannot be deleted.

The FPCNetwork object is typically an element of an FPCNetworks collection.

Click here to see the ISA Server object hierarchy.

Inheritance

This object inherits from the FPCPersist object, which contains methods and properties related to the persistent storage of an object's data. They include methods for exporting the object's data to and importing it from an XML document.

Methods

This object has no methods.

Properties

The FPCNetwork object has the following properties.

Property | Description
AutoDiscoveryPort | Gets or sets the port to bind to if the EnableAutoDiscoveryPort property is set to True.
ClientConfig | Gets an FPCClientConfig object that provides access to the configuration of Firewall clients and to the configuration settings for Web browsers running on Firewall clients on the network.
Description | Gets or sets the description of the network.
EnableAutoDiscoveryPort | Gets or sets a Boolean value that indicates whether the Web proxy binds to a specific port so that Web proxy clients on the network can automatically discover the ISA Server computer.
EnableFirewallClients | Gets or sets a Boolean value that indicates whether Firewall clients on the network are supported.
EnableWebProxyClients | Gets or sets a Boolean value that indicates whether Web proxy clients on the network are supported.
IpRangeSet | Gets an FPCIpRangeSet collection that contains the set of IP ranges defining the network.
LDT | Gets an FPCLDT collection that contains the entries in the local domain table (LDT).
Name | Gets or sets the name of the network.
NetworkConnectionType | Gets or sets a value from the FpcNetworkConnectionType enumerated type that specifies the type of connection to the network.
NetworkType | Gets a value from the FpcNetworkTypes enumerated type that specifies the type of network.
Predefined | Gets a Boolean value that indicates whether the network is predefined.
VpnConfiguration | Gets an FPCVpnNetworkConfiguration object that provides access to the configuration settings for site-to-site virtual private network (VPN) connections to the network.
WebListenerProperties | Gets an FPCWebListenerProperties object that contains the properties of the Web listener for outgoing requests from the network.

Methods Inherited from FPCPersist

Name | Description
CancelWaitForChanges | Cancels the registration established by the WaitForChanges method (for use in C and C++ programming only).
CanImport | Returns a Boolean value that indicates whether the object's properties can be imported from the specified XML document.
Export | Recursively writes the stored values of all the properties of the object and its subobjects to the specified XML document.
ExportToFile | Recursively writes the stored values of all the properties of the object and its subobjects to the specified XML file.
GetServiceRestartMask | Retrieves a 32-bit bitmask of the FpcServices enumerated type that specifies which services need to be restarted for currently unsaved changes to take effect.
Import | Recursively copies the values of all the properties of the object and of its subobjects from the specified XML document to persistent storage.
ImportFromFile | Recursively copies the values of all the properties of the object and of its subobjects from the specified XML file to persistent storage.
LoadDocProperties | Provides the XML document's properties so that you can know what information can be imported from the document.
Refresh | Recursively reads the values of all the properties of the object and of its subobjects from persistent storage, overwriting any changes that have not been saved.
Save | Recursively writes the current values of all the properties of the object and its subobjects to persistent storage.
WaitForChanges | Registers to wait for an event indicating that the contents of the object have changed (for use in C and C++ programming only).

Properties Inherited from FPCPersist

Name | Description
PersistentName | Gets the persistent name of the object. The persistent name of an object is a name that is unique for the object at the respective level of the COM object hierarchy.
VendorParametersSets | Gets an FPCVendorParametersSets collection that can hold sets of custom data for extending the object.

Remarks

This object implements the IFPCNetwork interface.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

COM Objects


IFPCNetwork | FPCNetwork AutoDiscoveryPort(long,long) property [ISA Server 2004]

AutoDiscoveryPort Property of IFPCNetwork[C++]

FPCNetwork.AutoDiscoveryPort [Visual Basic]

[C++]

The AutoDiscoveryPort property gets or sets the port to bind to if the EnableAutoDiscoveryPort property is VARIANT_TRUE.

HRESULT get_AutoDiscoveryPort(
  long* plAutoDiscoveryPort
);

HRESULT put_AutoDiscoveryPort(
  long lAutoDiscoveryPort
);

Parameters

plAutoDiscoveryPort
Pointer to a variable that on return receives a 32-bit integer specifying the port.
lAutoDiscoveryPort
A 32-bit integer that specifies the port.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write.

[Visual Basic]

The AutoDiscoveryPort property gets or sets the port to bind to if the EnableAutoDiscoveryPort property is True.

Property AutoDiscoveryPort As Long

Property Value

A 32-bit integer that specifies the port.

Remarks

This property is read/write.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCNetwork


IFPCNetwork | FPCNetwork ClientConfig (1 Parameter) property [ISA Server 2004]

ClientConfig Property of IFPCNetwork[C++]

FPCNetwork.ClientConfig [Visual Basic]

[C++]

The ClientConfig property gets an FPCClientConfig object that provides access to the configuration of Firewall clients and to the configuration settings for Web browsers running on Firewall clients on the network.

HRESULT get_ClientConfig(
  IFPCClientConfig** ppClientConfig
);

Parameters

ppClientConfig
Address of an interface pointer that on return points to an IFPCClientConfig interface that represents the configuration of Firewall clients and to the configuration settings for Web browsers running on Firewall clients on the network.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code, and the parameter returned is a null object.

Remarks

This property is read-only. It can be modified by accessing the properties IFPCClientConfig interface retrieved.

[Visual Basic]

The ClientConfig property gets an FPCClientConfig object that provides access to the configuration of Firewall clients and to the configuration settings for Web browsers running on Firewall clients on the network.

Property ClientConfig As IFPCClientConfig

Property Value

Reference to an FPCClientConfig object that provides access to the configuration of Firewall clients and to the configuration settings for Web browsers running on Firewall clients on the network.

Remarks

This property is read-only. It can be modified by accessing the properties of the FPCClientConfig object retrieved.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCNetwork


IFPCNetwork | FPCNetwork Description(BSTR,BSTR) property [ISA Server 2004]

Description Property of IFPCNetwork[C++]

FPCNetwork.Description [Visual Basic]

[C++]

The Description property gets or sets the description of the network.

HRESULT get_Description(
  BSTR* pbstrDescription
);

HRESULT put_Description(
  BSTR bstrDescription
);

Parameters

pbstrDescription
Pointer to a BSTR that is set on return to a string value specifying the description of the network.
bstrDescription
BSTR that specifies the description of the network.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write.

[Visual Basic]

The Description property gets or sets the description of the network.

Property Description As String

Property Value

String that specifies the description of the network.

Remarks

This property is read/write.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCNetwork


IFPCNetwork | FPCNetwork EnableAutoDiscoveryPort property [ISA Server 2004]

EnableAutoDiscoveryPort Property of IFPCNetwork[C++]

FPCNetwork.EnableAutoDiscoveryPort [Visual Basic]

[C++]

The EnableAutoDiscoveryPort property gets or sets a Boolean value that indicates whether the Web proxy binds to a specific port so that Web proxy clients on the network can automatically discover the ISA Server computer.

HRESULT get_EnableAutoDiscoveryPort(
  VARIANT_BOOL* pfAutoDiscoveryPortEnabled
);

HRESULT put_EnableAutoDiscoveryPort(
  VARIANT_BOOL fAutoDiscoveryPortEnabled
);

Parameters

pfAutoDiscoveryPortEnabled
Pointer to a Boolean variable that is set on return to VARIANT_TRUE if the Web proxy binds to a specific port so that Web proxy clients on the network can automatically discover the ISA Server computer, or to VARIANT_FALSE if it does not bind to the port.
fAutoDiscoveryPortEnabled
Boolean value that indicates whether the Web proxy binds to a specific port so that Web proxy clients on the network can automatically discover the ISA Server computer.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write.

The port to which the Web proxy binds is specified in the AutoDiscoveryPort property.

[Visual Basic]

The EnableAutoDiscoveryPort property gets or sets a Boolean value that indicates whether the Web proxy binds to a specific port so that Web proxy clients on the network can automatically discover the ISA Server computer.

Property EnableAutoDiscoveryPort As Boolean

Property Value

Boolean value that indicates whether the Web proxy binds to a specific port so that Web proxy clients on the network can automatically discover the ISA Server computer.

Remarks

This property is read/write.

The port to which the Web proxy binds is specified in the AutoDiscoveryPort property.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCNetwork


IFPCNetwork | FPCNetwork EnableFirewallClients property [ISA Server 2004]

EnableFirewallClients Property of IFPCNetwork[C++]

FPCNetwork.EnableFirewallClients [Visual Basic]

[C++]

The EnableFirewallClients property gets or sets a Boolean value that indicates whether Firewall clients on the network are supported. If Firewall clients are not supported, secure network address translation (SecureNAT) and Web proxy clients on the network may be supported.

HRESULT get_EnableFirewallClients(
  VARIANT_BOOL* pfFWClientsEnabled
);

HRESULT put_EnableFirewallClients(
  VARIANT_BOOL fFWClientsEnabled
);

Parameters

pfFWClientsEnabled
Pointer to a Boolean variable that is set on return to VARIANT_TRUE if Firewall clients on the network are supported, or to VARIANT_FALSE if Firewall clients on the network are not supported.
fFWClientsEnabled
Boolean value that indicates whether Firewall clients on the network are supported.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write.

[Visual Basic]

The EnableFirewallClients property gets or sets a Boolean value that indicates whether Firewall clients on the network are supported. If Firewall clients are not supported, secure network address translation (SecureNAT) and Web proxy clients on the network may be supported.

Property EnableFirewallClients As Boolean

Property Value

Boolean value that indicates whether Firewall clients on the network are supported.

Remarks

This property is read/write.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCNetwork


IFPCNetwork | FPCNetwork EnableWebProxyClients property [ISA Server 2004]

EnableWebProxyClients Property of IFPCNetwork[C++]

FPCNetwork.EnableWebProxyClients [Visual Basic]

[C++]

The EnableWebProxyClients property gets or sets a Boolean value that indicates whether Web proxy clients on the network are supported.

HRESULT get_EnableWebProxyClients(
  VARIANT_BOOL* pfWebProxyClientsEnabled
);

HRESULT put_EnableWebProxyClients(
  VARIANT_BOOL fWebProxyClientsEnabled
);

Parameters

pfWebProxyClientsEnabled
Pointer to a Boolean variable that is set on return to VARIANT_TRUE if Web proxy clients on the network are supported, or to VARIANT_FALSE if Web proxy clients on the network are not supported.
fWebProxyClientsEnabled
Boolean value indicates whether Web proxy clients on the network are supported.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write.

For the Local Host network, this property must be set to VARIANT_TRUE before attempting to create a new content download job.

[Visual Basic]

The EnableWebProxyClients property gets or sets a Boolean value that indicates whether Web proxy clients on the network are supported.

Property EnableWebProxyClients As Boolean

Property Value

Boolean value that indicates whether Web proxy clients on the network are supported.

Remarks

This property is read/write.

For the Local Host network, this property must be set to True before attempting to create a new content download job.

Example Code

This VBScript code example enables listening for requests from Web proxy clients on the Local Host network if it is not enabled.

' Define an enumeration value.
const fpcLocalHost = 2

' Create the root obect.
Set root = CreateObject("FPC.Root")

' Declare the other objects needed.
Dim array     ' An FPCArray object
Dim networks  ' An FPCNetworks collection
Dim network   ' An FPCNetwork object

' Get references to the array object
' and the networks collection.
Set array = root.GetContainingArray()
Set networks = array.NetworkConfiguration.Networks

' Iterate through the networks, and for the Local Host network,
' enable listening for requests from Web Proxy clients if it is
' not enabled.
For Each network In networks
    If network.NetworkType = fpcLocalHost Then
        If network.EnableWebProxyClients = False Then
            network.EnableWebProxyClients = True
            network.Save
        End If
    End If
Next

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCNetwork


IFPCNetwork | FPCNetwork IpRangeSet(IFPCIpRangeSet) property [ISA Server 2004]

IpRangeSet Property of IFPCNetwork[C++]

FPCNetwork.IpRangeSet [Visual Basic]

[C++]

The IpRangeSet property gets an FPCIpRangeSet collection that contains the set of IP ranges defining the network.

HRESULT get_IpRangeSet(
  IFPCIpRangeSet** ppIpRangeSet
);

Parameters

ppIpRangeSet
Address of an interface pointer that on return points to an IFPCIpRangeSet interface that represents the collection of IP ranges defining the network.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only and is available only for the Internal network and user-defined networks. The set of IP ranges can be modified through the IFPCIpRangeSet interface retrieved.

[Visual Basic]

The IpRangeSet property gets an FPCIpRangeSet collection that contains the set of IP ranges defining the network.

Property IpRangeSet As FPCIpRangeSet

Property Value

Reference to an FPCIpRangeSet collection that contains the set of IP ranges defining the network.

Remarks

This property is read-only and is available only for the Internal network and user-defined networks. The set of IP ranges can be modified through the FPCIpRangeSet collection retrieved.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCNetwork


IFPCNetwork | FPCNetwork LDT(IFPCLDT) property [ISA Server 2004]

LDT Property of IFPCNetwork[C++]

FPCNetwork.LDT [Visual Basic]

[C++]

The LDT property gets an FPCLDT collection that contains the entries in the local domain table (LDT). The LDT lists servers in a network behind the ISA Server computer. Firewall Client computers maintain a copy of the LDT for the local network, which is updated regularly. They may be configured to use the LDT for the local network to decide whether a request can sent directly to a destination that is included in the LDT, as it refers to a computer within the local network, or has to be sent to the ISA Server computer for forwarding to its destination by the Microsoft Firewall service.

HRESULT get_LDT(
  IFPCLDT** ppLDT
);

Parameters

ppLDT
Address of an interface pointer that on return points to an IFPCLDT interface that represents the LDT.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only. Individual entries of the LDT can be added, deleted, or modified by calling the methods of the IFPCLDT interface retrieved.

[Visual Basic]

The LDT property gets an FPCLDT collection that contains the entries in the local domain table (LDT). The LDT lists servers in a network behind the ISA Server computer. Firewall Client computers maintain a copy of the LDT for the local network, which is updated regularly. They may be configured to use the LDT for the local network to decide whether a request can sent directly to a destination that is included in the LDT, as it refers to a computer within the local network, or has to be sent to the ISA Server computer for forwarding to its destination by the Microsoft Firewall service.

Property LDT As FPCLDT

Property Value

Reference to an FPCLDT collection that contains the entries in the LDT.

Remarks

This property is read-only. Individual entries of the LDT can be added, deleted, or modified by calling the methods of the FPCLDT collection retrieved.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCNetwork


IFPCNetwork | FPCNetwork Name(BSTR,BSTR) property [ISA Server 2004]

Name Property of IFPCNetwork[C++]

FPCNetwork.Name [Visual Basic]

[C++]

The Name property gets or sets the name of the network.

HRESULT get_Name(
  BSTR* pbstrName
);

HRESULT put_Name(
  BSTR bstrName
);

Parameters

pbstrName
Pointer to a BSTR that is set on return to a string value specifying the name of the network.
bstrName
BSTR that specifies the name of the network.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write. However, you cannot set this property for a predefined network.

[Visual Basic]

The Name property gets or sets the name of the network.

Property Name As String

Property Value

String that specifies the name of the network.

Remarks

This property is read/write. However, you cannot set this property for a predefined network.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCNetwork


IFPCNetwork | FPCNetwork NetworkConnectionType property [ISA Server 2004]

NetworkConnectionType Property of IFPCNetwork[C++]

FPCNetwork.NetworkConnectionType [Visual Basic]

[C++]

The NetworkConnectionType property gets or sets a value from the FpcNetworkConnectionType enumerated type that specifies the type of connection to the network, such as a connection through a network adapter, a virtual private network (VPN) connection, a dial-up connection, or an Internet Protocol security (IPSec) connection.

HRESULT get_NetworkConnectionType(
  FpcNetworkConnectionType* pConnectionType
);

HRESULT put_NetworkConnectionType(
  FpcNetworkConnectionType ConnectionType
);

Parameters

pConnectionType
Pointer to a variable that on return receives a value from the FpcNetworkConnectionType enumerated type specifying the type of connection to the network.
ConnectionType
Value from the FpcNetworkConnectionType enumerated type that specifies the type of connection to the network.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read/write.

[Visual Basic]

The NetworkConnectionType property gets or sets a value from the FpcNetworkConnectionType enumerated type that specifies the type of connection to the network, such as a connection through a network adapter, a virtual private network (VPN) connection, a dial-up connection, or an Internet Protocol security (IPSec) connection.

Property NetworkConnectionType As FpcNetworkConnectionType

Property Value

Value from the FpcNetworkConnectionType enumerated type that specifies the type of connection to the network.

Remarks

This property is read/write.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCNetwork


IFPCNetwork | FPCNetwork NetworkType(FpcNetworkTypes) property [ISA Server 2004]

NetworkType Property of IFPCNetwork[C++]

FPCNetwork.NetworkType [Visual Basic]

[C++]

The NetworkType property gets a value from the FpcNetworkTypes enumerated type that specifies the type of network, such as the predefined Default External, Internal, Local Host, VPN Clients, or Quarantined VPN Clients network, or a user-defined network.

HRESULT get_NetworkType(
  FpcNetworkTypes* pType
);

Parameters

pType
Pointer to a variable that on return receives a value from the FpcNetworkTypes enumerated type specifying the type of network.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The NetworkType property gets a value from the FpcNetworkTypes enumerated type that specifies the type of network, such as the predefined Default External, Internal, Local Host, VPN Clients, or Quarantined VPN Clients network, or a user-defined network.

Property NetworkType As FpcNetworkTypes

Property Value

Value from the FpcNetworkTypes enumerated type that specifies the type of network.

Remarks

This property is read-only.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCNetwork


IFPCNetwork | FPCNetwork Predefined(VARIANT_BOOL) property [ISA Server 2004]

Predefined Property of IFPCNetwork[C++]

FPCNetwork.Predefined [Visual Basic]

[C++]

The Predefined property gets a Boolean value that indicates whether the network is predefined by ISA Server, rather than defined by the administrator. The predefined networks include the Default External, Internal, Local Host, VPN Clients, and Quarantined VPN Clients networks.

HRESULT get_Predefined(
  VARIANT_BOOL* pfPredefined
);

Parameters

pfPredefined
Pointer to a Boolean variable that is set on return to VARIANT_TRUE if the network is predefined, or to VARIANT_FALSE if the network is user-defined.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The Predefined property gets a Boolean value that indicates whether the network is predefined by ISA Server, rather than defined by the administrator. The predefined networks include the Default External, Internal, Local Host, VPN Clients, and Quarantined VPN Clients networks.

Property Predefined As Boolean

Property Value

Boolean value that indicates whether the network is predefined.

Remarks

This property is read-only.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCNetwork


IFPCNetwork | FPCNetwork VpnConfiguration property [ISA Server 2004]

VpnConfiguration Property of IFPCNetwork[C++]

FPCNetwork.VpnConfiguration [Visual Basic]

[C++]

The VpnConfiguration property gets an FPCVpnNetworkConfiguration object that provides access to the configuration settings for site-to-site virtual private network (VPN) connections to the network.

HRESULT get_VpnConfiguration(
  IFPCVpnNetworkConfiguration** ppVpnNetworkConfiguration
);

Parameters

ppVpnNetworkConfiguration
Address of an interface pointer that on return points to an IFPCVpnNetworkConfiguration interface that represents the configuration settings for site-to-site VPN connections to the network.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code, and the parameter returned is a null object.

Remarks

This property is read-only. The configuration settings for site-to-site VPN connections to the network can be modified by accessing the properties of the IFPCVpnNetworkConfiguration interface retrieved.

[Visual Basic]

The VpnConfiguration property gets an FPCVpnNetworkConfiguration object that provides access to the configuration settings for site-to-site virtual private network (VPN) connections to the network.

Property VpnConfiguration

Property Value

Reference to the FPCVpnNetworkConfiguration object for the network.

Remarks

This property is read-only. The configuration settings for site-to-site VPN connections to the network can be modified by accessing the properties of the FPCVpnNetworkConfiguration object retrieved.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCNetwork


IFPCNetwork | FPCNetwork WebListenerProperties property [ISA Server 2004]

WebListenerProperties Property of IFPCNetwork[C++]

FPCNetwork.WebListenerProperties [Visual Basic]

[C++]

The WebListenerProperties property gets an FPCWebListenerProperties object that contains the properties of the Web listener for outgoing requests from the network.

HRESULT get_WebListenerProperties(
  IFPCWebListenerProperties** ppWebListenerProperties
);

Parameters

ppWebListenerProperties
Address of an interface pointer that on return points to an IFPCWebListenerProperties interface that represents the properties of the Web listener for outgoing requests from the network.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The WebListenerProperties property gets an FPCWebListenerProperties object that contains the properties of the Web listener for outgoing requests from the network.

Property WebListenerProperties As FPCWebListenerProperties

Property Value

Reference to an FPCWebListenerProperties object that contains the properties of the Web listener for outgoing requests from the network.

Remarks

This property is read-only.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCNetwork


FPCNetworkConfiguration object [ISA Server 2004]

FPCNetworkConfiguration

The FPCNetworkConfiguration object is used to access the network configuration.

This object is typically accessed through the NetworkConfiguration property of the FPCArray object.

Click here to see the ISA Server object hierarchy.

Inheritance

This object inherits from the FPCPersist object, which contains methods and properties related to the persistent storage of an object's data. They include methods for exporting the object's data to and importing it from an XML document.

Methods

This object has no methods.

Properties

The FPCNetworkConfiguration object has the following properties.

Property | Description
DialingConfiguration | Gets an FPCDialingConfiguration object that defines the automatic dialing configuration.
FirewallChaining | Gets an FPCFirewallChaining object that specifies settings for forwarding Microsoft Firewall service requests to another server.
NetworkRules | Gets an FPCNetworkRules collection of the network rules defined in the array.
Networks | Gets an FPCNetworks collection of the networks defined in the array.
NetworkSets | Gets an FPCNetworkSets collection of the network sets defined in the array.
NetworkTemplates | Gets an FPCNetworkTemplates collection of the network templates defined in the array.
RoutingRules | Gets an FPCRoutingRules collection of the routing rules defined in the array.
VpnConfiguration | Gets an FPCVpnConfiguration object that defines the VPN settings for an ISA Server computer serving as a VPN gateway.

Methods Inherited from FPCPersist

Name | Description
CancelWaitForChanges | Cancels the registration established by the WaitForChanges method (for use in C and C++ programming only).
CanImport | Returns a Boolean value that indicates whether the object's properties can be imported from the specified XML document.
Export | Recursively writes the stored values of all the properties of the object and its subobjects to the specified XML document.
ExportToFile | Recursively writes the stored values of all the properties of the object and its subobjects to the specified XML file.
GetServiceRestartMask | Retrieves a 32-bit bitmask of the FpcServices enumerated type that specifies which services need to be restarted for currently unsaved changes to take effect.
Import | Recursively copies the values of all the properties of the object and of its subobjects from the specified XML document to persistent storage.
ImportFromFile | Recursively copies the values of all the properties of the object and of its subobjects from the specified XML file to persistent storage.
LoadDocProperties | Provides the XML document's properties so that you can know what information can be imported from the document.
Refresh | Recursively reads the values of all the properties of the object and of its subobjects from persistent storage, overwriting any changes that have not been saved.
Save | Recursively writes the current values of all the properties of the object and its subobjects to persistent storage.
WaitForChanges | Registers to wait for an event indicating that the contents of the object have changed (for use in C and C++ programming only).

Properties Inherited from FPCPersist

Name | Description
PersistentName | Gets the persistent name of the object. The persistent name of an object is a name that is unique for the object at the respective level of the COM object hierarchy.
VendorParametersSets | Gets an FPCVendorParametersSets collection that can hold sets of custom data for extending the object.

Remarks

This object implements the IFPCNetworkConfiguration interface.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

COM Objects


IFPCNetworkConfiguration.DialingConfiguration property [ISA Server 2004]

DialingConfiguration Property of IFPCNetworkConfiguration[C++]

FPCNetworkConfiguration.DialingConfiguration [Visual Basic]

[C++]

The DialingConfiguration property gets an FPCDialingConfiguration object that defines the automatic dialing configuration.

HRESULT get_DialingConfiguration(
  IFPCDialingConfiguration** ppDialingConfiguration
);

Parameters

ppDialingConfiguration
Address of an interface pointer that on return points to an IFPCDialingConfiguration interface that defines Microsoft Firewall service dialing.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only. You can modify the dialing settings by calling the properties and methods of the IFPCDialingConfiguration interface retrieved.

[Visual Basic]

The DialingConfiguration property gets an FPCDialingConfiguration object that defines the automatic dialing configuration.

Property DialingConfiguration As FPCDialingConfiguration

Property Value

Reference to an FPCDialingConfiguration object that defines the Microsoft Firewall service dialing.

Remarks

This property is read-only. You can modify the dialing settings by calling the properties and methods of the FPCDialingConfiguration object retrieved.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCNetworkConfiguration


IFPCNetworkConfiguration.FirewallChaining property [ISA Server 2004]

FirewallChaining Property of IFPCNetworkConfiguration[C++]

FPCNetworkConfiguration.FirewallChaining [Visual Basic]

[C++]

The FirewallChaining property gets an FPCFirewallChaining object that specifies settings for forwarding Microsoft Firewall service requests to another server.

HRESULT get_FirewallChaining(
  IFPCFirewallChaining** ppFirewallChaining
);

Parameters

ppFirewallChaining
Address of an interface pointer that on return points to an IFPCFirewallChaining interface that specifies settings for forwarding Firewall service requests to another server.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only. You can modify the chaining settings by calling the properties of the IFPCFirewallChaining interface retrieved.

[Visual Basic]

The FirewallChaining property gets an FPCFirewallChaining object that specifies settings for forwarding Microsoft Firewall service requests to another server.

Property FirewallChaining As FPCFirewallChaining

Property Value

Reference to an FPCFirewallChaining object that specifies settings for forwarding Firewall service requests to another server.

Remarks

This property is read-only. You can modify the chaining settings by calling the properties of the FPCFirewallChaining object retrieved.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCNetworkConfiguration


IFPCNetworkConfiguration.NetworkRules (1 Parameter) property [ISA Server 2004]

NetworkRules Property of IFPCNetworkConfiguration[C++]

FPCNetworkConfiguration.NetworkRules [Visual Basic]

[C++]

The NetworkRules property gets an FPCNetworkRules collection of the network rules defined in the array.

HRESULT get_NetworkRules(
  IFPCNetworkRules** ppNetworkRules
);

Parameters

ppNetworkRules
Address of an interface pointer that on return points to an IFPCNetworkRules interface that represents the collection of network rules defined in the array.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only. You can modify the network rules through the IFPCNetworkRules interface retrieved.

[Visual Basic]

The NetworkRules property gets an FPCNetworkRules collection of the network rules defined in the array.

Property NetworkRules As FPCNetworkRules

Property Value

Reference to the FPCNetworkRules collection of the network rules defined in the array.

Remarks

This property is read-only. You can modify the network rules through the FPCNetworkRules collection retrieved.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCNetworkConfiguration


IFPCNetworkConfiguration.Networks(IFPCNetworks) property [ISA Server 2004]

Networks Property of IFPCNetworkConfiguration[C++]

FPCNetworkConfiguration.Networks [Visual Basic]

[C++]

The Networks property gets an FPCNetworks collection of the networks defined in the array.

HRESULT get_Networks(
  IFPCNetworks** ppNetworks
);

Parameters

ppNetworks
Address of an interface pointer that on return points to an IFPCNetworks interface that represents the collection of networks defined in the array.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only. You can access the properties of each network through the IFPCNetworks interface retrieved.

[Visual Basic]

The Networks property gets an FPCNetworks collection of the networks defined in the array.

Property Networks As FPCNetworks

Property Value

Reference to an FPCNetworks collection of the networks defined in the array.

Remarks

This property is read-only. You can access the properties of each network through the FPCNetworks collection retrieved.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCNetworkConfiguration


IFPCNetworkConfiguration.NetworkSets(IFPCNetworkSets) property [ISA Server 2004]

NetworkSets Property of IFPCNetworkConfiguration[C++]

FPCNetworkConfiguration.NetworkSets [Visual Basic]

[C++]

The NetworkSets property gets an FPCNetworkSets collection of the network sets defined in the array.

HRESULT get_NetworkSets(
  IFPCNetworkSets** ppNetworkSets
);

Parameters

ppNetworkSets
Address of an interface pointer that on return points to an IFPCNetworkSets interface that represents the collection of network sets defined in the array.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only. You can access the properties of each network set through the IFPCNetworkSets interface retrieved.

[Visual Basic]

The NetworkSets property gets an FPCNetworkSets collection of the network sets defined in the array.

Property NetworkSets As FPCNetworkSets

Property Value

Reference to the FPCNetworkSets collection of the network sets defined in the array.

Remarks

This property is read-only. You can access the properties of each network set through the FPCNetworkSets collection retrieved.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCNetworkConfiguration


IFPCNetworkConfiguration.NetworkTemplates property [ISA Server 2004]

NetworkTemplates Property of IFPCNetworkConfiguration[C++]

FPCNetworkConfiguration.NetworkTemplates [Visual Basic]

[C++]

The NetworkTemplates property gets an FPCNetworkTemplates collection of the network templates defined in the array.

HRESULT get_NetworkTemplates(
  IFPCNetworkTemplates** ppNetworkTemplates
);

Parameters

ppNetworkTemplates
Address of an interface pointer that on return points to an IFPCNetworkTemplates interface that represents the collection of network templates defined in the array.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only. You can access the properties of each network template through the IFPCNetworkTemplates interface retrieved.

[Visual Basic]

The NetworkTemplates property gets an FPCNetworkTemplates collection of the network templates defined in the array.

Property NetworkTemplates As FPCNetworkTemplates

Property Value

Reference to the FPCNetworkTemplates collection of the network templates defined in the array.

Remarks

This property is read-only. You can access the properties of each network template through the FPCNetworkTemplates collection retrieved.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCNetworkConfiguration


IFPCNetworkConfiguration.RoutingRules (1 Parameter) property [ISA Server 2004]

RoutingRules Property of IFPCNetworkConfiguration[C++]

FPCNetworkConfiguration.RoutingRules [Visual Basic]

[C++]

The RoutingRules property gets an FPCRoutingRules collection of the routing rules defined in the array.

HRESULT get_RoutingRules(
  IFPCRoutingRules** ppRoutingRules
);

Parameters

ppRoutingRules
Address of an interface pointer that on return points to an IFPCRoutingRules interface that represents the collection of the routing rules defined in the array.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only. You can modify the collection of routing rules and access the properties of each routing rule through the IFPCRoutingRules interface retrieved.

[Visual Basic]

The RoutingRules property gets an FPCRoutingRules collection of the routing rules defined in the array.

Property RoutingRules As FPCRoutingRules

Property Value

Reference to the FPCRoutingRules collection of the routing rules defined in the array.

Remarks

This property is read-only. You can modify the collection of routing rules and access the properties of each routing rule through the FPCRoutingRules collection retrieved.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCNetworkConfiguration


IFPCNetworkConfiguration.VpnConfiguration property [ISA Server 2004]

VpnConfiguration Property of IFPCNetworkConfiguration[C++]

FPCNetworkConfiguration.VpnConfiguration [Visual Basic]

[C++]

The VpnConfiguration property gets an FPCVpnConfiguration object that defines the VPN settings for an ISA Server computer serving as a VPN gateway.

HRESULT get_VpnConfiguration(
  IFPCVpnConfiguration** ppVpnConfiguration
);

Parameters

ppVpnConfiguration
Address of an interface pointer that on return points to an IFPCVpnConfiguration interface that defines the VPN settings for an ISA Server computer serving as a VPN gateway.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only. You can modify the VPN settings by calling the properties and methods of the IFPCVpnConfiguration interface retrieved.

[Visual Basic]

The VpnConfiguration property gets an FPCVpnConfiguration object that defines the VPN settings for an ISA Server computer serving as a VPN gateway.

Property VpnConfiguration As FPCVpnConfiguration

Property Value

Reference to an FPCVpnConfiguration object that defines object that defines the VPN settings for an ISA Server computer serving as a VPN gateway.

Remarks

This property is read-only. You can modify the VPN settings by calling the properties and methods of the FPCVpnConfiguration object retrieved.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCNetworkConfiguration


FPCNetworkInTemplate object [ISA Server 2004]

FPCNetworkInTemplate

The FPCNetworkInTemplate object represents a network in a template. This object allows you to set and retrieve the name and description of a network in a template, but does not affect the network template which is stored in an XML file. For more information see FPCNetworkTemplate.

This object is typically an element of an FPCNetworksInTemplate collection.

Click here to see the ISA Server object hierarchy.

Methods

This object has no methods.

Properties

The FPCNetworkInTemplate object has the following properties.

Property | Description
Description | Gets the description of the network in the template.
Name | Gets the name of the network in the template.
PersistentName | Gets the persistent name of the network in the template.

Remarks

This object implements the IFPCNetworkInTemplate interface.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

COM Objects


IFPCNetworkInTemplate.Description(BSTR) property [ISA Server 2004]

Description Property of IFPCNetworkInTemplate[C++]

FPCNetworkInTemplate.Description [Visual Basic]

[C++]

The Description property gets the description of the network in the template.

HRESULT get_Description(
  BSTR* pbstrDescription
);

Parameters

pbstrDescription
Pointer to a BSTR that is set on return to a string value specifying the description of the network in the template.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only. The description of each network included in a template is specified in the XML file used in the Add method of the FPCNetworkTemplates collection to create the template.

[Visual Basic]

The Description property gets the description of the network in the template.

Property Description As String

Property Value

String that specifies the description of the network in the template.

Remarks

This property is read-only. The description of each network included in a template is specified in the XML file used in the Add method of the FPCNetworkTemplates collection to create the template.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCNetworkInTemplate


IFPCNetworkInTemplate | FPCNetworkInTemplate Name property [ISA Server 2004]

Name Property of IFPCNetworkInTemplate[C++]

FPCNetworkInTemplate.Name [Visual Basic]

[C++]

The Name property gets the name of the network in the template.

HRESULT get_Name(
  BSTR* pbstrName
);

Parameters

pbstrName
Pointer to a BSTR that is set on return to a string value specifying the name of the network in the template.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only. The name of each network included in a template is specified in the XML file used in the Add method of the FPCNetworkTemplates collection to create the template.

[Visual Basic]

The Name property gets the name of the network in the template.

Property Name As String

Property Value

String that specifies the name of the network in the template.

Remarks

This property is read-only. The name of each network included in a template is specified in the XML file used in the Add method of the FPCNetworkTemplates collection to create the template.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCNetworkInTemplate


IFPCNetworkInTemplate.PersistentName(BSTR) property [ISA Server 2004]

PersistentName Property of IFPCNetworkInTemplate[C++]

FPCNetworkInTemplate.PersistentName [Visual Basic]

[C++]

The PersistentName property gets the persistent name of the network in the network template. The persistent name of a network in a network template is a globally unique identifier (GUID) that does not vary in different localized versions of ISA Server.

HRESULT get_PersistentName(
  BSTR* pbstrPersistentName
);

Parameters

pbstrPersistentName
Pointer to a BSTR that is set on return to a string value specifying the persistent name of the network in the network template.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

The persistent names of all of the predefined objects that are installed with ISA Server are listed in FpcObjectsGuids.h.

[Visual Basic]

The PersistentName property gets the persistent name of the network in the network template. The persistent name of a network in a network template is a globally unique identifier (GUID) that does not vary in different localized versions of ISA Server.

Property PersistentName As String

Property Value

String that specifies the persistent name of the network in the network template.

Remarks

This property is read-only.

The persistent names of all of the predefined objects that are installed with ISA Server are listed in FpcObjectsGuids.vbs and FpcObjectsGuids.js.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCNetworkInTemplate


FPCNetworkRule object [ISA Server 2004]

FPCNetworkRule

The FPCNetworkRule object represents a single ISA Server network rule. Network rules define routing or network address translation (NAT) relationships between specific network entities.

A network entity can represent a single IP address or multiple IP addresses. The sets of all the source and destination IP addresses in the network entities to which a network rule applies are specified through FPCSelectionIPs objects. The following table lists the network entities that can be referenced in the source and destination FPCSelectionIPs objects of a network rule and the objects that represent a single instance of each network entity.

Network Entity | Object
Address range | FPCAddressRange
Computer | FPCComputer
Computer set | FPCComputerSet
Network | FPCNetwork
Network set | FPCNetworkSet
Subnet | FPCSubnet

When no network rule defines a network relationship between two IP addresses, ISA Server drops all traffic sent from one of these IP addresses to the other.

The FPCNetworkRule object is typically an element of an FPCNetworkRules collection.

Click here to see the ISA Server object hierarchy.

Inheritance

This object inherits from the FPCPersist object, which contains methods and properties related to the persistent storage of an object's data. They include methods for exporting the object's data to and importing it from an XML document.

Methods

This object has no methods.

Properties

The FPCNetworkRule object has the following properties.

Property | Description
Description | Gets or sets the description of the rule.
DestinationSelectionIPs | Gets an FPCSelectionIPs object that specifies the complete set of destination IP addresses to which the rule applies.
Enabled | Gets or sets a Boolean value that indicates whether the rule is enabled.
Name | Gets or sets the name of the rule.
Order | Gets the position of the rule in the list of network rules corresponding to their order of application.
Predefined | Gets a Boolean value that indicates whether the network rule is a preinstalled rule that cannot be deleted and whose position in the list of network rules corresponding to their order of application cannot be changed.
RoutingType | Gets or sets a value from the FpcNetworkRoutingTypes enumerated type that specifies the type of relationship between the source and destination network entities to which the rule applies.
SourceSelectionIPs | Gets an FPCSelectionIPs object that specifies the complete set of source IP addresses to which the rule applies.

Methods Inherited from FPCPersist

Name | Description
CancelWaitForChanges | Cancels the registration established by the WaitForChanges method (for use in C and C++ programming only).
CanImport | Returns a Boolean value that indicates whether the object's properties can be imported from the specified XML document.
Export | Recursively writes the stored values of all the properties of the object and its subobjects to the specified XML document.
ExportToFile | Recursively writes the stored values of all the properties of the object and its subobjects to the specified XML file.
GetServiceRestartMask | Retrieves a 32-bit bitmask of the FpcServices enumerated type that specifies which services need to be restarted for currently unsaved changes to take effect.
Import | Recursively copies the values of all the properties of the object and of its subobjects from the specified XML document to persistent storage.
ImportFromFile | Recursively copies the values of all the properties of the object and of its subobjects from the specified XML file to persistent storage.
LoadDocProperties | Provides the XML document's properties so that you can know what information can be imported from the document.
Refresh | Recursively reads the values of all the properties of the object and of its subobjects from persistent storage, overwriting any changes that have not been saved.
Save | Recursively writes the current values of all the properties of the object and its subobjects to persistent storage.
WaitForChanges | Registers to wait for an event indicating that the contents of the object have changed (for use in C and C++ programming only).

Properties Inherited from FPCPersist

Name | Description
PersistentName | Gets the persistent name of the object. The persistent name of an object is a name that is unique for the object at the respective level of the COM object hierarchy.
VendorParametersSets | Gets an FPCVendorParametersSets collection that can hold sets of custom data for extending the object.

Remarks

This object implements the IFPCNetworkRule interface.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

COM Objects


IFPCNetworkRule | FPCNetworkRule Description property [ISA Server 2004]

Description Property of IFPCNetworkRule[C++]

FPCNetworkRule.Description [Visual Basic]

[C++]

The Description property gets or sets the description of the rule.

HRESULT get_Description(
  BSTR* pbstrDescription
);

HRESULT put_Description(
  BSTR bstrDescription
);

Parameters

pbstrDescription
Pointer to a BSTR that is set on return to a string value specifying the description of the rule.
bstrDescription
BSTR that specifies the description of the rule.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write.

[Visual Basic]

The Description property gets or sets the description of the rule.

Property Description As String

Property Value

String that specifies the description of the rule.

Remarks

This property is read/write.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCNetworkRule


IFPCNetworkRule.DestinationSelectionIPs (1 Parameter) property [ISA Server 2004]

DestinationSelectionIPs Property of IFPCNetworkRule[C++]

FPCNetworkRule.DestinationSelectionIPs [Visual Basic]

[C++]

The DestinationSelectionIPs property gets an FPCSelectionIPs object that specifies the complete set of destination IP addresses to which the rule applies. This set may include computers, networks, network sets, subnets, or IP address ranges.

HRESULT get_DestinationSelectionIPs(
  IFPCSelectionIPs** ppSelectionIPs
);

Parameters

ppSelectionIPs
Address of an interface pointer that on return points to an IFPCSelectionIPs interface that represents the complete set of destination IP addresses to which the rule applies.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only. It can be modified through the properties of the IFPCSelectionIPs interface retrieved.

[Visual Basic]

The DestinationSelectionIPs property gets an FPCSelectionIPs object that specifies the complete set of destination IP addresses to which the rule applies. This set may include computers, networks, network sets, subnets, or IP address ranges.

Property DestinationSelectionIPs As FPCSelectionIPs

Property Value

Reference to an FPCSelectionIPs object that specifies the complete set of destination IP addresses to which the rule applies.

Remarks

This property is read-only. It can be modified through the properties of the FPCSelectionIPs object retrieved.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCNetworkRule


IFPCNetworkRule | FPCNetworkRule Enabled property [ISA Server 2004]

Enabled Property of IFPCNetworkRule[C++]

FPCNetworkRule.Enabled [Visual Basic]

[C++]

The Enabled property gets or sets a Boolean value that indicates whether the rule is enabled.

HRESULT get_Enabled(
  VARIANT_BOOL* pfEnabled
);

HRESULT put_Enabled(
  VARIANT_BOOL fEnabled
);

Parameters

pfEnabled
Pointer to a Boolean variable that is set on return to VARIANT_TRUE if the rule is enabled, or to VARIANT_FALSE if the rule is disabled.
fEnabled
Boolean value that indicates whether the rule is enabled.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write.

[Visual Basic]

The Enabled property gets or sets a Boolean value that indicates whether the rule is enabled.

Property Enabled As Boolean

Property Value

Boolean value that indicates whether the rule is enabled.

Remarks

This property is read/write.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCNetworkRule


IFPCNetworkRule | FPCNetworkRule Name(BSTR,BSTR) property [ISA Server 2004]

Name Property of IFPCNetworkRule[C++]

FPCNetworkRule.Name [Visual Basic]

[C++]

The Name property gets or sets the name of the network rule.

HRESULT get_Name(
  BSTR* pbstrName
);

HRESULT put_Name(
  BSTR bstrName
);

Parameters

pbstrName
Pointer to a BSTR that is set on return to a string value specifying the name of the network rule.
bstrName
BSTR that specifies the name of the network rule.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write.

[Visual Basic]

The Name property gets or sets the name of the network rule.

Property Name As String

Property Value

String that specifies the name of the network rule.

Remarks

This property is read/write.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCNetworkRule


IFPCNetworkRule | FPCNetworkRule Order(long) property [ISA Server 2004]

Order Property of IFPCNetworkRule[C++]

FPCNetworkRule.Order [Visual Basic]

[C++]

The Order property gets the ordinal position of the rule in the list of network rules, which corresponds to the order of application. When a request is received, each network rule is checked to determine whether it allows the connection. Once a matching network rule is found, the remaining rules are not checked.

HRESULT get_Order(
  long* plOrder
);

Parameters

plOrder
Pointer to a variable that on return receives a 32-bit integer specifying the ordinal position of the rule in the list of network rules.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only. It can be modified by calling the MoveUp and MoveDown methods of the FPCNetworkRules collection. Because these methods change the ordinal positions of more than one rule in the collection, the Save method must be called on the collection to write the changes to persistent storage.

[Visual Basic]

The Order property gets the ordinal position of the rule in the list of network rules, which corresponds to the order of application. When a request is received, each network rule is checked to determine whether it allows the connection. Once a matching network rule is found, the remaining rules are not checked.

Property Order As Long

Property Value

A 32-bit integer that specifies the ordinal position of the rule in the list of network rules.

Remarks

This property is read-only. It can be modified by calling the MoveUp and MoveDown methods of the FPCNetworkRules collection. Because these methods change the ordinal positions of more than one rule in the collection, the Save method must be called on the collection to write the changes to persistent storage.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCNetworkRule


IFPCNetworkRule | FPCNetworkRule Predefined property [ISA Server 2004]

Predefined Property of IFPCNetworkRule[C++]

FPCNetworkRule.Predefined [Visual Basic]

[C++]

The Predefined property gets a Boolean value that indicates whether the network rule is a predefined network rule that was created during the installation of ISA Server. A predefined rule cannot be deleted, and its position in the list of network rules corresponding to the order of application cannot be changed.

HRESULT get_Predefined(
  VARIANT_BOOL* pfPredefined
);

Parameters

pfPredefined
Pointer to a Boolean variable that is set on return to VARIANT_TRUE if the network rule is preinstalled, or to VARIANT_FALSE if the network rule is user-defined.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The Predefined property gets a Boolean value that indicates whether the network rule is a predefined network rule that was created during the installation of ISA Server. A predefined rule cannot be deleted, and its position in the list of network rules corresponding to the order of application cannot be changed.

Property Predefined As Boolean

Property Value

Boolean value that indicates whether the network rule is predefined.

Remarks

This property is read-only.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCNetworkRule


IFPCNetworkRule | FPCNetworkRule RoutingType property [ISA Server 2004]

RoutingType Property of IFPCNetworkRule[C++]

FPCNetworkRule.RoutingType [Visual Basic]

[C++]

The RoutingType property gets or sets a value from the FpcNetworkRoutingTypes enumerated type that specifies the type of relationship between the source and destination network entities to which the rule applies. Network entities can have a routing relationship or a network address translation (NAT) relationship.

HRESULT get_RoutingType(
  FpcNetworkRoutingTypes* pNetworkRoutingType
);

HRESULT put_RoutingType(
  FpcPolicyRuleActions NetworkRoutingType
);

Parameters

pNetworkRoutingType
Pointer to a value from the FpcNetworkRoutingTypes enumerated type that is set on return to either fpcRoute, which indicates that the network entities have a routing relationship, or to fpcNat, which indicates that the network entities have a NAT relationship.
NetworkRoutingType
Value from the FpcNetworkRoutingTypes enumerated type that specifies the type of network relationship.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write.

When network entities have a routing relationship and access rules allow traffic between them, ISA Server routes traffic between the network entities without NAT. This is a two-way relationship defined by a single rule.

When network entities have a NAT relationship and publishing rules allow traffic from the source network to the destination network, ISA Server replaces the IP addresses of computers in the source network with an IP address of the network adapter on the ISA Server computer that is connected to the destination network. This relationship is defined in one direction only, source to destination, and cannot be defined in the opposite direction. However, traffic that is allowed by access rules is routed in the opposite direction without NAT.

[Visual Basic]

The RoutingType property gets or sets a value from the FpcNetworkRoutingTypes enumerated type that specifies the type of relationship between the source and destination network entities to which the rule applies. Network entities can have a routing relationship or a network address translation (NAT) relationship.

Property RoutingType As FpcNetworkRoutingTypes

Property Value

Value from the FpcNetworkRoutingTypes enumerated type that specifies the type of network relationship.

Remarks

This property is read/write.

When network entities have a routing relationship and access rules allow traffic between them, ISA Server routes traffic between the network entities without NAT. This is a two-way relationship defined by a single rule.

When network entities have a NAT relationship and publishing rules allow traffic from the source network to the destination network, ISA Server replaces the IP addresses of computers in the source network with an IP address of the network adapter on the ISA Server computer that is connected to the destination network. This relationship is defined in one direction only, source to destination, and cannot be defined in the opposite direction. However, traffic that is allowed by access rules is routed in the opposite direction without NAT.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCNetworkRule


IFPCNetworkRule | FPCNetworkRule SourceSelectionIPs property [ISA Server 2004]

SourceSelectionIPs Property of IFPCNetworkRule[C++]

FPCNetworkRule.SourceSelectionIPs [Visual Basic]

[C++]

The SourceSelectionIPs property gets an FPCSelectionIPs object that specifies the complete set of source IP addresses to which the rule applies. This set may include computers, networks, network sets, subnets, or IP address ranges.

HRESULT get_SourceSelectionIPs(
  IFPCSelectionIPs** ppSelectionIPs
);

Parameters

ppSelectionIPs
Address of an interface pointer that on return points to an IFPCSelectionIPs interface that represents the complete set of source IP addresses to which the rule applies.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only. It can be modified through the properties of the IFPCSelectionIPs interface retrieved.

[Visual Basic]

The SourceSelectionIPs property gets an FPCSelectionIPs object that specifies the complete set of source IP addresses to which the rule applies. This set may include computers, networks, network sets, subnets, or IP address ranges.

Property SourceSelectionIPs As FPCSelectionIPs

Property Value

Reference to an FPCSelectionIPs object that specifies the complete set of source IP addresses to which the rule applies.

Remarks

This property is read-only. It can be modified through the properties of the FPCSelectionIPs object retrieved.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCNetworkRule


FPCNetworkRules collection [ISA Server 2004]

FPCNetworkRules Collection

The FPCNetworkRules collection holds a set of FPCNetworkRule objects, each of which represents a network rule. This collection can be accessed through the NetworkRules property of an FPCNetworkConfiguration object.

Click here to see the ISA Server object hierarchy.

Inheritance

This collection inherits from the FPCPersist object, which contains methods and properties related to the persistent storage of an object's data. They include methods for exporting the object's data to and importing it from an XML document.

Methods

The FPCNetworkRules collection defines the following methods.

Method | Description
Add | Creates a new FPCNetworkRule object in the collection and returns a reference to it.
Item | Retrieves the requested FPCNetworkRule object from the collection.
MoveDown | Moves the specified rule one step down the list of network rules, which corresponds to their order of application.
MoveUp | Moves the specified rule one step up the list of network rules, which corresponds to their order of application.
Remove | Removes the specified FPCNetworkRule object from the collection.

Properties

The FPCNetworkRules collection has the following properties.

Property | Description
_NewEnum | Gets an enumerator object for the collection.
Count | Gets the number of FPCNetworkRule objects in the collection.

Methods Inherited from FPCPersist

Name | Description
CancelWaitForChanges | Cancels the registration established by the WaitForChanges method (for use in C and C++ programming only).
CanImport | Returns a Boolean value that indicates whether the properties of the collection, its elements, and their subobjects can be imported from the specified XML document.
Export | Recursively writes the stored values of all the properties of the collection, its elements, and their subobjects to the specified XML document.
ExportToFile | Recursively writes the stored values of all the properties of the collection, its elements, and their subobjects to the specified XML file.
GetServiceRestartMask | Retrieves a 32-bit bitmask of the FpcServices enumerated type that specifies which services need to be restarted for currently unsaved changes to take effect.
Import | Recursively copies the values of all the properties of the collection, its elements, and their subobjects from the specified XML document to persistent storage.
ImportFromFile | Recursively copies the values of all the properties of the collection, its elements, and their subobjects from the specified XML file to persistent storage.
LoadDocProperties | Provides the XML document's properties so that you can know what information can be imported from the document.
Refresh | Recursively reads the values of all the properties of the collection, its elements, and their subobjects from persistent storage, overwriting any changes that have not been saved.
Save | Recursively writes the current values of all the properties of the collection, its elements, and their subobjects to persistent storage.
WaitForChanges | Registers to wait for an event indicating that the contents of the object have changed (for use in C and C++ programming only).

Properties Inherited from FPCPersist

Name | Description
PersistentName | Gets the persistent name of the collection. The persistent name of an object is a name that is unique for the object at the respective level of the COM object hierarchy.
VendorParametersSets | Gets an FPCVendorParametersSets collection that can hold sets of custom data for extending the collection.

Remarks

This collection implements the IFPCNetworkRules interface.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

COM Objects


IFPCNetworkRules | FPCNetworkRules _NewEnum(IUnknown) property [ISA Server 2004]

_NewEnum Property of IFPCNetworkRules[C++]

FPCNetworkRules._NewEnum [Visual Basic]

[C++]

The _NewEnum property gets an enumerator object for the collection. An enumerator object provides serial access to the elements of the collection.

HRESULT get__NewEnum(
  IUnknown* ppEnum
);

Parameters

ppEnum
Address of an interface pointer that on return points to the IUnknown interface of an enumerator object that implements an IEnumVARIANT interface for the collection. An interface pointer to the IEnumVARIANT interface of the enumerator object can be retrieved by calling QueryInterface on the IUnknown interface returned.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The _NewEnum property gets an enumerator object for the collection. An enumerator object provides serial access to the elements of the collection.

Property _NewEnum As IUnknown

Property Value

Reference to an enumerator object that provides serial access to the elements of the collection.

Remarks

This property is read-only.

In Visual Basic and VBScript, this property is used implicitly in For Each...In...Next constructs.

Example Code

This VBScript script displays the names of the network rules defined for an FPCArray object. It does not include error handling.

' Create the root object.
Set root = CreateObject("FPC.Root")

' Declare the other objects needed.
Dim array         ' An FPCArray object
Dim networkrules  ' An FPCNetworkRules collection
Dim networkrule   ' An FPCNetworkRule object

' Get references to the array object
' and the network rules collection.
Set array = root.GetContainingArray()
Set networkrules = array.NetworkConfiguration.NetworkRules

' Display the names of the network rules
' defined for the array object.
For Each networkrule In networkrules
    WScript.Echo "Network rule name: " & networkrule.Name
Next

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCNetworkRules


IFPCNetworkRules | FPCNetworkRules Add (2 Parameters) method [ISA Server 2004]

IFPCNetworkRules::Add[C++]

FPCNetworkRules.Add [Visual Basic]

[C++]

The Add method creates a new FPCNetworkRule object in the collection and returns a reference to it.

HRESULT Add(
  BSTR Name,
  IFPCNetworkRule** ppNetworkRule
);

Parameters

Name
[in] BSTR that specifies the name of the new network rule.
ppNetworkRule
[out] Address of an interface pointer that on return points to the new IFPCNetworkRule interface created.

Return Values

This method can return one of the following:

  • S_OK, indicating that the operation succeeded.
  • An error code, indicating that the operation failed. In this case, the [out] parameter returned is a null object.

[Visual Basic]

The Add method creates a new FPCNetworkRule object in the collection and returns a reference to it.

Function Add( _
  ByVal Name As String _
) As FPCNetworkRule

Parameters

Name
[in] String that specifies the name of the new network rule.

Return Values

This method returns a reference to the FPCNetworkRule object if successful. Otherwise, an error is raised that can be intercepted by using an error handler.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCNetworkRules


IFPCNetworkRules | FPCNetworkRules Count(long) property [ISA Server 2004]

Count Property of IFPCNetworkRules[C++]

FPCNetworkRules.Count [Visual Basic]

[C++]

The Count property gets the number of FPCNetworkRule objects in the collection.

HRESULT get_Count(
  long* plCount
);

Parameters

plCount
Pointer to a variable that on return receives a 32-bit integer specifying the number of FPCNetworkRule objects in the collection.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The Count property gets the number of FPCNetworkRule objects in the collection.

Property Count As Long

Property Value

A 32-bit integer that specifies the number of FPCNetworkRule objects in the collection.

Remarks

This property is read-only.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCNetworkRules


IFPCNetworkRules | FPCNetworkRules Item (2 Parameters) method [ISA Server 2004]

IFPCNetworkRules::Item[C++]

FPCNetworkRules.Item [Visual Basic]

[C++]

The Item method retrieves the requested IFPCNetworkRule interface from the collection.

HRESULT Item(
  VARIANT Index,
  IFPCNetworkRule** ppItem
);

Parameters

Index
[in] Required. Name or one-based index of the object to retrieve.
ppItem
[out] Address of an interface pointer that on return points to the IFPCNetworkRule interface requested.

Return Values

This method can return one of the following:

  • S_OK, indicating that the operation succeeded.
  • An error code, indicating that the operation failed. In this case, the [out] parameter returned is a null object.

[Visual Basic]

The Item method retrieves the requested FPCNetworkRule object from the collection.

Function Item( _
  ByVal Index As Variant _
) As FPCNetworkRule

Parameters

Index
[in] Required. Name or one-based index of the object to retrieve.

Return Values

This method returns a reference to the FPCNetworkRule object requested if successful. Otherwise, an error is raised that can be intercepted by using an error handler.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCNetworkRules


IFPCNetworkRules | FPCNetworkRules MoveDown(Long) method [ISA Server 2004]

IFPCNetworkRules::MoveDown[C++]

FPCNetworkRules.MoveDown [Visual Basic]

[C++]

The MoveDown method moves the specified rule one step down the list of network rules, which corresponds to their order of application.

HRESULT MoveDown(
  long index
);

Parameters

index
[in] Required. Index (the current position indicated by the Order property) of the rule to move down.

Return Values

This method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

The MoveUp method moves a rule one step up the list of network rules.

[Visual Basic]

The MoveDown method moves the specified rule one step down the list of network rules, which corresponds to their order of application.

Sub MoveDown( _
  ByVal index As Long _
)

Parameters

index
[in] Required. Index (the current position indicated by the Order property) of the rule to move down.

Return Values

This method has no return values. If the call is unsuccessful, an error is raised that can be intercepted by using an error handler.

Remarks

The MoveUp method moves a rule one step up the list of network rules.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCNetworkRules


IFPCNetworkRules | FPCNetworkRules MoveUp(Long) method [ISA Server 2004]

IFPCNetworkRules::MoveUp[C++]

FPCNetworkRules.MoveUp [Visual Basic]

[C++]

The MoveUp method moves the specified rule one step up the list of network rules, which corresponds to their order of application.

HRESULT MoveUp(
  long index
);

Parameters

index
[in] Required. Index (the current position indicated by the Order property) of the rule to move up.

Return Values

This method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

The MoveDown method moves a rule one step down the list of network rules.

[Visual Basic]

The MoveUp method moves the specified rule one step up the list of network rules, which corresponds to their order of application.

Sub MoveUp( _
  ByVal index As Long _
)

Parameters

index
[in] Required. Index (the current position indicated by the Order property) of the rule to move up.

Return Values

This method has no return values. If the call is unsuccessful, an error is raised that can be intercepted by using an error handler.

Remarks

The MoveDown method moves a rule one step down the list of network rules.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCNetworkRules


IFPCNetworkRules | FPCNetworkRules Remove(Variant) method [ISA Server 2004]

IFPCNetworkRules::Remove[C++]

FPCNetworkRules.Remove [Visual Basic]

[C++]

The Remove method removes the specified FPCNetworkRule object from the collection.

HRESULT Remove(
  VARIANT Index
);

Parameters

Index
[in] Required. Name or one-based index of the FPCNetworkRule object to remove.

Return Values

This method returns S_OK if the call is successful; otherwise, it returns an error code.
[Visual Basic]

The Remove method removes the specified FPCNetworkRule object from the collection.

Sub Remove( _
  ByVal Index As Variant _
)

Parameters

Index
[in] Required. Name or one-based index of the FPCNetworkRule object to remove.

Return Values

This method has no return values. If the call is unsuccessful, an error is raised that can be intercepted by using an error handler.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCNetworkRules


FPCNetworks collection [ISA Server 2004]

FPCNetworks Collection

The FPCNetworks collection contains a set of FPCNetwork objects. This collection is typically accessed through the Networks property of an FPCNetworkConfiguration object.

Click here to see the ISA Server object hierarchy.

Inheritance

This collection inherits from the FPCPersist object, which contains methods and properties related to the persistent storage of an object's data. They include methods for exporting the object's data to and importing it from an XML document.

Methods

The FPCNetworks collection defines the following methods.

Method | Description
Add | Creates a new FPCNetwork object.
Item | Retrieves the requested FPCNetwork object from the collection.
Remove | Removes the specified FPCNetwork object from the collection.

Properties

The FPCNetworks collection has the following properties.

Property | Description
_NewEnum | Gets an enumerator object for the collection.
Count | Gets the number of FPCNetwork objects in the collection.

Methods Inherited from FPCPersist

Name | Description
CancelWaitForChanges | Cancels the registration established by the WaitForChanges method (for use in C and C++ programming only).
CanImport | Returns a Boolean value that indicates whether the properties of the collection, its elements, and their subobjects can be imported from the specified XML document.
Export | Recursively writes the stored values of all the properties of the collection, its elements, and their subobjects to the specified XML document.
ExportToFile | Recursively writes the stored values of all the properties of the collection, its elements, and their subobjects to the specified XML file.
GetServiceRestartMask | Retrieves a 32-bit bitmask of the FpcServices enumerated type that specifies which services need to be restarted for currently unsaved changes to take effect.
Import | Recursively copies the values of all the properties of the collection, its elements, and their subobjects from the specified XML document to persistent storage.
ImportFromFile | Recursively copies the values of all the properties of the collection, its elements, and their subobjects from the specified XML file to persistent storage.
LoadDocProperties | Provides the XML document's properties so that you can know what information can be imported from the document.
Refresh | Recursively reads the values of all the properties of the collection, its elements, and their subobjects from persistent storage, overwriting any changes that have not been saved.
Save | Recursively writes the current values of all the properties of the collection, its elements, and their subobjects to persistent storage.
WaitForChanges | Registers to wait for an event indicating that the contents of the object have changed (for use in C and C++ programming only).

Properties Inherited from FPCPersist

Name | Description
PersistentName | Gets the persistent name of the collection. The persistent name of an object is a name that is unique for the object at the respective level of the COM object hierarchy.
VendorParametersSets | Gets an FPCVendorParametersSets collection that can hold sets of custom data for extending the collection.

Remarks

This collection implements the IFPCNetworks interface.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

COM Objects


IFPCNetworks | FPCNetworks _NewEnum(IUnknown) property [ISA Server 2004]

_NewEnum Property of IFPCNetworks[C++]

FPCNetworks._NewEnum [Visual Basic]

[C++]

The _NewEnum property gets an enumerator object for the collection. An enumerator object provides serial access to the elements of the collection.

HRESULT get__NewEnum(
  IUnknown* ppEnum
);

Parameters

ppEnum
Address of an interface pointer that on return points to the IUnknown interface of an enumerator object that implements an IEnumVARIANT interface for the collection. An interface pointer to the IEnumVARIANT interface of the enumerator object can be retrieved by calling QueryInterface on the IUnknown interface returned.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The _NewEnum property gets an enumerator object for the collection. An enumerator object provides serial access to the elements of the collection.

Property _NewEnum As IUnknown

Property Value

Reference to an enumerator object that provides serial access to the elements of the collection.

Remarks

This property is read-only.

In Visual Basic and VBScript, this property is used implicitly in For Each...In...Next constructs.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCNetworks


IFPCNetworks | FPCNetworks Add(String,IFPCNetwork) method [ISA Server 2004]

IFPCNetworks::Add[C++]

FPCNetworks.Add [Visual Basic]

[C++]

The Add method creates a new FPCNetwork object in the collection and returns a reference to it.

HRESULT Add(
  BSTR Name,
  IFPCNetwork** ppNetwork
);

Parameters

Name
[in] BSTR that specifies the name of the new network.
ppNetwork
[out] Address of an interface pointer that on return points to the new IFPCNetwork interface added.

Return Values

This method can return one of the following:

  • S_OK, indicating that the operation succeeded.
  • An error code, indicating that the operation failed. In this case, the [out] parameter returned is a null object.

[Visual Basic]

The Add method creates a new FPCNetwork object in the collection and returns a reference to it.

Function Add( _
  ByVal Name As String _
) As FPCNetwork

Parameters

Name
[in] String that specifies the name of the new network.

Return Values

This method returns a reference to the FPCNetwork object if successful. Otherwise, an error is raised that can be intercepted by using an error handler.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCNetworks


IFPCNetworks | FPCNetworks Count(long) property [ISA Server 2004]

Count Property of IFPCNetworks[C++]

FPCNetworks.Count [Visual Basic]

[C++]

The Count property gets the number of FPCNetwork objects in the collection.

HRESULT get_Count(
  long* plCount
);

Parameters

plCount
Pointer to a variable that on return receives a 32-bit integer specifying the number of FPCNetwork objects in the collection.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The Count property gets the number of FPCNetwork objects in the collection.

Property Count As Long

Property Value

A 32-bit integer value that specifies the number of FPCNetwork objects in the collection.

Remarks

This property is read-only.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCNetworks


IFPCNetworks | FPCNetworks Item(Variant,IFPCNetwork) method [ISA Server 2004]

IFPCNetworks::Item[C++]

FPCNetworks.Item [Visual Basic]

[C++]

The Item method retrieves the requested IFPCNetwork interface from the collection.

HRESULT Item(
  VARIANT Index,
  IFPCNetwork** ppItem
);

Parameters

Index
[in] Required. Name or one-based index of the object to retrieve.
ppItem
[out] Address of an interface pointer that on return points to the IFPCNetwork interface requested.

Return Values

This method can return one of the following:

  • S_OK, indicating that the operation succeeded.
  • An error code, indicating that the operation failed. In this case, the [out] parameter returned is a null object.

[Visual Basic]

The Item method retrieves the requested FPCNetwork object from the collection.

Function Item( _
  ByVal Index As Variant _
) As FPCNetwork

Parameters

Index
[in] Required. Name or one-based index of the object to retrieve.

Return Values

This method returns a reference to the FPCNetwork object requested if successful. Otherwise, an error is raised that can be intercepted by using an error handler.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCNetworks


IFPCNetworks | FPCNetworks Remove(Variant) method [ISA Server 2004]

IFPCNetworks::Remove[C++]

FPCNetworks.Remove [Visual Basic]

[C++]

The Remove method removes the specified FPCNetwork object from the collection.

HRESULT Remove(
  VARIANT Index
);

Parameters

Index
[in] Required. Name or one-based index of the FPCNetwork object to remove.

Return Values

This method returns S_OK if the call is successful; otherwise, it returns an error code.
[Visual Basic]

The Remove method removes the specified FPCNetwork object from the collection.

Sub Remove( _
  ByVal Index As Variant _
)

Parameters

Index
[in] Required. Name or one-based index of the FPCNetwork object to remove.

Return Values

This method has no return values. If the call is unsuccessful, an error is raised that can be intercepted by using an error handler.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCNetworks


FPCNetworkSet object [ISA Server 2004]

FPCNetworkSet

The FPCNetworkSet object represents a single network set.

This object is typically an element of an FPCNetworkSets collection.

Click here to see the ISA Server object hierarchy.

Inheritance

This object inherits from the FPCPersist object, which contains methods and properties related to the persistent storage of an object's data. They include methods for exporting an object's data to and importing it from an XML document.

Methods

This object has no methods.

Properties

The FPCNetworkSet object has the following properties.

Property | Description
Description | Gets or sets the description of the network set.
Name | Gets or sets the name of the network set.
Networks | Gets an FPCRefs collection that contains references to the FPCNetwork objects defining the networks included in the network set or excluded from it.
NetworkSetType | Gets a value from the FpcNetworkSetType enumerated type that specifies whether the network set includes only the networks specified in the Networks property, or includes all networks except the networks specified in the Networks property.
Predefined | Gets a Boolean value that indicates whether the network set is a predefined network set that was created during the installation of ISA Server and cannot be deleted.

Methods Inherited from FPCPersist

Name | Description
CancelWaitForChanges | Cancels the registration established by the WaitForChanges method (for use in C and C++ programming only).
CanImport | Returns a Boolean value that indicates whether the object's properties can be imported from the specified XML document.
Export | Recursively writes the stored values of all the properties of the object and its subobjects to the specified XML document.
ExportToFile | Recursively writes the stored values of all the properties of the object and its subobjects to the specified XML file.
GetServiceRestartMask | Retrieves a 32-bit bitmask of the FpcServices enumerated type that specifies which services need to be restarted for currently unsaved changes to take effect.
Import | Recursively copies the values of all the properties of the object and of its subobjects from the specified XML document to persistent storage.
ImportFromFile | Recursively copies the values of all the properties of the object and of its subobjects from the specified XML file to persistent storage.
LoadDocProperties | Provides the XML document's properties so that you can know what information can be imported from the document.
Refresh | Recursively reads the values of all the properties of the object and of its subobjects from persistent storage, overwriting any changes that have not been saved.
Save | Recursively writes the current values of all the properties of the object and its subobjects to persistent storage.
WaitForChanges | Registers to wait for an event indicating that the contents of the object have changed (for use in C and C++ programming only).

Properties Inherited from FPCPersist

Name | Description
PersistentName | Gets the persistent name of the object. The persistent name of an object is a name that is unique for the object at the respective level of the COM object hierarchy.
VendorParametersSets | Gets an FPCVendorParametersSets collection that can hold sets of custom data for extending the object.

Remarks

This object implements the IFPCNetworkSet interface.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

COM Objects


IFPCNetworkSet | FPCNetworkSet Description(BSTR,BSTR) property [ISA Server 2004]

Description Property of IFPCNetworkSet[C++]

FPCNetworkSet.Description [Visual Basic]

[C++]

The Description property gets or sets the description of the network set.

HRESULT get_Description(
  BSTR* pbstrDescription
);

HRESULT put_Description(
  BSTR bstrDescription
);

Parameters

pbstrDescription
Pointer to a BSTR that is set on return to a string value specifying the description of the network set.
bstrDescription
BSTR that specifies the description of the network set.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write.

[Visual Basic]

The Description property gets or sets the description of the network set.

Property Description As String

Property Value

String that specifies the description of the network set.

Remarks

This property is read/write.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCNetworkSet


IFPCNetworkSet | FPCNetworkSet Name(BSTR,BSTR) property [ISA Server 2004]

Name Property of IFPCNetworkSet[C++]

FPCNetworkSet.Name [Visual Basic]

[C++]

The Name property gets or sets the name of the network set.

HRESULT get_Name(
  BSTR* pbstrName
);

HRESULT put_Name(
  BSTR bstrName
);

Parameters

pbstrName
Pointer to a BSTR that is set on return to a string value specifying the name of the network set.
bstrName
BSTR that specifies the name of the network set.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write.

[Visual Basic]

The Name property gets or sets the name of the network set.

Property Name As String

Property Value

String that specifies the name of the network set.

Remarks

This property is read/write.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCNetworkSet


IFPCNetworkSet | FPCNetworkSet Networks(IFPCRefs) property [ISA Server 2004]

Networks Property of IFPCNetworkSet[C++]

FPCNetworkSet.Networks [Visual Basic]

[C++]

The Networks property gets an FPCRefs collection that contains references to the FPCNetwork objects defining the networks included in the network set or excluded from it.

HRESULT get_Networks(
  IFPCRefs** ppRefs
);

Parameters

ppRefs
Address of a variable that on return receives a pointer to an IFPCRefs interface that represents the collection of references to the networks included in the network set or excluded from it.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only. The set of networks included in the network set or excluded from it can be modified by calling the methods of the IFPCRefs interface retrieved.

[Visual Basic]

The Networks property gets an FPCRefs collection that contains references to the FPCNetwork objects defining the networks included in the network set or excluded from it.

Property Networks As FPCRefs

Property Value

Reference to an FPCRefs collection that contains references to the networks included in the network set or excluded from it.

Remarks

This property is read-only. The set of networks included in the network set or excluded from it can be modified by calling the methods of the FPCRefs collection retrieved.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCNetworkSet


IFPCNetworkSet | FPCNetworkSet NetworkSetType property [ISA Server 2004]

NetworkSetType Property of IFPCNetworkSet[C++]

FPCNetworkSet.NetworkSetType [Visual Basic]

[C++]

The NetworkSetType property gets a value from the FpcNetworkSetType enumerated type that specifies whether the network set includes only the networks specified in the Networks property, or includes all networks except the networks specified in the Networks property.

HRESULT get_NetworkSetType(
  FpcNetworkSetType NetworkSetType
);

Parameters

NetworkSetType
Pointer to a variable that on return receives a value from the FpcNetworkSetType enumerated type specifying whether the network set includes only the networks specified in the Networks property, or includes all networks except the networks specified in the Networks property.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only. This property is set when a new network set is created using the Add method of the FPCNetworkSets collection.

[Visual Basic]

The NetworkSetType property gets a value from the FpcNetworkSetType enumerated type that specifies whether the network set includes only the networks specified in the Networks property, or includes all networks except the networks specified in the Networks property.

Property NetworkSetType As FpcNetworkSetType

Property Value

Value from the FpcNetworkSetType enumerated type that specifies whether the network set includes only the networks specified in the Networks property, or includes all networks except the networks specified in the Networks property.

Remarks

This property is read-only. This property is set when a new network set is created using the Add method of the FPCNetworkSets collection.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCNetworkSet


IFPCNetworkSet | FPCNetworkSet Predefined property [ISA Server 2004]

Predefined Property of IFPCNetworkSet[C++]

FPCNetworkSet.Predefined [Visual Basic]

[C++]

The Predefined property gets a Boolean value that indicates whether the network set is a predefined network set that was created during the installation of ISA Server and cannot be deleted.

HRESULT get_Predefined(
  VARIANT_BOOL* pfPredefined
);

Parameters

pfPredefined
Pointer to a Boolean variable that is set on return to VARIANT_TRUE if the network set is predefined, or to VARIANT_FALSE if the network set is user-defined.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The Predefined property gets a Boolean value that indicates whether the network set is a predefined network set that was created during the installation of ISA Server and cannot be deleted.

Property Predefined As Boolean

Property Value

Boolean value that indicates whether the network set is predefined.

Remarks

This property is read-only.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCNetworkSet


FPCNetworkSets collection [ISA Server 2004]

FPCNetworkSets Collection

The FPCNetworkSets collection holds the set of FPCNetworkSet objects that are defined in the array.

This collection is typically accessed through the NetworkSets property of an FPCNetworkConfiguration object.

Click here to see the ISA Server object hierarchy.

Inheritance

This collection inherits from the FPCPersist object, which contains methods and properties related to the persistent storage of an object's data. They include methods for exporting the object's data to and importing it from an XML document.

Methods

The FPCNetworkSets collection defines the following methods.

Method | Description
Add | Creates a new FPCNetworkSet object in the collection and returns a reference to it.
Item | Retrieves the requested FPCNetworkSet object from the collection.
Remove | Removes the specified FPCNetworkSet object from the collection.

Properties

The FPCNetworkSets collection has the following properties.

Property | Description
_NewEnum | Gets an enumerator object for the collection.
Count | Gets the number of FPCNetworkSet objects in the collection.

Methods Inherited from FPCPersist

Name | Description
CancelWaitForChanges | Cancels the registration established by the WaitForChanges method (for use in C and C++ programming only).
CanImport | Returns a Boolean value that indicates whether the properties of the collection, its elements, and their subobjects can be imported from the specified XML document.
Export | Recursively writes the stored values of all the properties of the collection, its elements, and their subobjects to the specified XML document.
ExportToFile | Recursively writes the stored values of all the properties of the collection, its elements, and their subobjects to the specified XML file.
GetServiceRestartMask | Retrieves a 32-bit bitmask of the FpcServices enumerated type that specifies which services need to be restarted for currently unsaved changes to take effect.
Import | Recursively copies the values of all the properties of the collection, its elements, and their subobjects from the specified XML document to persistent storage.
ImportFromFile | Recursively copies the values of all the properties of the collection, its elements, and their subobjects from the specified XML file to persistent storage.
LoadDocProperties | Provides the XML document's properties so that you can know what information can be imported from the document.
Refresh | Recursively reads the values of all the properties of the collection, its elements, and their subobjects from persistent storage, overwriting any changes that have not been saved.
Save | Recursively writes the current values of all the properties of the collection, its elements, and their subobjects to persistent storage.
WaitForChanges | Registers to wait for an event indicating that the contents of the object have changed (for use in C and C++ programming only).

Properties Inherited from FPCPersist

Name | Description
PersistentName | Gets the persistent name of the collection. The persistent name of an object is a name that is unique for the object at the respective level of the COM object hierarchy.
VendorParametersSets | Gets an FPCVendorParametersSets collection that can hold sets of custom data for extending the collection.

Remarks

This collection implements the IFPCNetworkSets interface.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

COM Objects


IFPCNetworkSets | FPCNetworkSets _NewEnum(IUnknown) property [ISA Server 2004]

_NewEnum Property of IFPCNetworkSets[C++]

FPCNetworkSets._NewEnum [Visual Basic]

[C++]

The _NewEnum property gets an enumerator object for the collection. An enumerator object provides serial access to the elements of the collection.

HRESULT get__NewEnum(
  IUnknown* ppEnum
);

Parameters

ppEnum
Address of an interface pointer that on return points to the IUnknown interface of an enumerator object that implements an IEnumVARIANT interface for the collection. An interface pointer to the IEnumVARIANT interface of the enumerator object can be retrieved by calling QueryInterface on the IUnknown interface returned.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The _NewEnum property gets an enumerator object for the collection. An enumerator object provides serial access to the elements of the collection.

Property _NewEnum As IUnknown

Property Value

Reference to an enumerator object that provides serial access to the elements of the collection.

Remarks

This property is read-only.

In Visual Basic and VBScript, this property is used implicitly in For Each...In...Next constructs.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCNetworkSets


IFPCNetworkSets | FPCNetworkSets Add (3 Parameters) method [ISA Server 2004]

IFPCNetworkSets::Add[C++]

FPCNetworkSets.Add [Visual Basic]

[C++]

The Add method creates a new FPCNetworkSet object in the collection and returns a reference to it.

HRESULT Add(
  BSTR Name,
  FpcNetworkSetType NetworkSetType,
  IFPCNetworkSet** ppNetworkSet
);

Parameters

Name
[in] Required. BSTR that specifies the name of the new FPCNetworkSet object to add.
NetworkSetType
[in, optional] Value from the FpcNetworkSetType enumerated type that specifies whether the network set includes only the selected networks, or includes all networks except the selected networks. The default value is fpcSelectedNetworks, which specifies that only selected networks are included.
ppNetworkSet
[out] Address of an interface pointer that on return points to the new IFPCNetworkSet interface created.

Return Values

This method can return one of the following:

  • S_OK, indicating that the operation succeeded.
  • An error code, indicating that the operation failed. In this case, the [out] parameter returned is a null object.

[Visual Basic]

The Add method creates a new FPCNetworkSet object in the collection and returns a reference to it.

Function Add( _
  ByVal Name As String, _
  [ ByVal NetworkSetType As FpcNetworkSetType ] _
) As FPCNetworkSet

Parameters

Name
[in] Required. String that specifies the name of the new FPCNetworkSet object to add.
NetworkSetType
[in, optional] Value from the FpcNetworkSetType enumerated type that specifies whether the network set includes only the selected networks, or includes all networks except the selected networks. The default value is fpcSelectedNetworks, which specifies that only selected networks are included.

Return Values

This method returns a reference to the FPCNetworkSet object added if the call is successful. Otherwise, an error is raised that can be intercepted by using an error handler.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCNetworkSets


IFPCNetworkSets | FPCNetworkSets Count(long) property [ISA Server 2004]

Count Property of IFPCNetworkSets[C++]

FPCNetworkSets.Count [Visual Basic]

[C++]

The Count property gets the number of FPCNetworkSet objects in the collection.

HRESULT get_Count(
  long* plCount
);

Parameters

plCount
Pointer to a variable that on return receives a 32-bit integer specifying the number of FPCNetworkSet objects in the collection.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The Count property gets the number of FPCNetworkSet objects in the collection.

Property Count As Long

Property Value

A 32-bit integer that specifies the number of FPCNetworkSet objects in the collection.

Remarks

This property is read-only.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCNetworkSets


IFPCNetworkSets | FPCNetworkSets Item (2 Parameters) method [ISA Server 2004]

IFPCNetworkSets::Item[C++]

FPCNetworkSets.Item [Visual Basic]

[C++]

The Item method retrieves the requested IFPCNetworkSet interface from the collection.

HRESULT Item(
  VARIANT Index,
  IFPCNetworkSet** ppItem
);

Parameters

Index
[in] Required. Name or one-based index of the object to retrieve.
ppItem
[out] Address of an interface pointer that on return points to the IFPCNetworkSet interface requested.

Return Values

This method can return one of the following:

  • S_OK, indicating that the operation succeeded.
  • An error code, indicating that the operation failed. In this case, the [out] parameter returned is a null object.

[Visual Basic]

The Item method retrieves the requested FPCNetworkSet object from the collection.

Function Item( _
  ByVal Index As Variant _
) As FPCNetworkSet

Parameters

Index
[in] Required. Name or one-based index of the object to retrieve.

Return Values

This method returns a reference to the FPCNetworkSet object requested if successful. Otherwise, an error is raised that can be intercepted by using an error handler.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCNetworkSets


IFPCNetworkSets | FPCNetworkSets Remove(Variant) method [ISA Server 2004]

IFPCNetworkSets::Remove[C++]

FPCNetworkSets.Remove [Visual Basic]

[C++]

The Remove method removes the specified FPCNetworkSet object from the collection.

HRESULT Remove(
  VARIANT Index
);

Parameters

Index
[in] Required. Name or one-based index of the FPCNetworkSet object to remove.

Return Values

This method returns S_OK if the call is successful; otherwise, it returns an error code.

[Visual Basic]

The Remove method removes the specified FPCNetworkSet object from the collection.

Sub Remove( _
  ByVal Index As Variant _
)

Parameters

Index
[in] Required. Name or one-based index of the FPCNetworkSet object to remove.

Return Values

This method has no return values. If the call is unsuccessful, an error is raised that can be intercepted by using an error handler.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCNetworkSets


FPCNetworksInTemplate collection [ISA Server 2004]

FPCNetworksInTemplate Collection

The FPCNetworksInTemplate collection provides access to a group of FPCNetworkInTemplate objects. This collection is typically accessed through the NetworksInTemplate property of an FPCNetworkTemplate object.

Click here to see the ISA Server object hierarchy.

Methods

The FPCNetworksInTemplate collection defines the following method.

Method | Description
Item | Retrieves the requested FPCNetworkInTemplate object from the collection.

Properties

The FPCNetworksInTemplate collection has the following properties.

Property | Description
_NewEnum | Gets an enumerator object for the collection.
Count | Gets the number of FPCNetworkInTemplate objects in the collection.
NetworksAreIdentical | Gets a Boolean value that indicates whether the networks in the template are the same as those in the current configuration.

Remarks

This collection implements the IFPCNetworksInTemplate interface.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

COM Objects


IFPCNetworksInTemplate._NewEnum(IUnknown) property [ISA Server 2004]

_NewEnum Property of IFPCNetworksInTemplate[C++]

FPCNetworksInTemplate._NewEnum [Visual Basic]

[C++]

The _NewEnum property gets an enumerator object for the collection. An enumerator object provides serial access to the elements of the collection.

HRESULT get__NewEnum(
  IUnknown* ppEnum
);

Parameters

ppEnum
Address of an interface pointer that on return points to the IUnknown interface of an enumerator object that implements an IEnumVARIANT interface for the collection. An interface pointer to the IEnumVARIANT interface of the enumerator object can be retrieved by calling QueryInterface on the IUnknown interface returned.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The _NewEnum property gets an enumerator object for the collection. An enumerator object provides serial access to the elements of the collection.

Property _NewEnum As IUnknown

Property Value

Reference to an enumerator object that provides serial access to the elements of the collection.

Remarks

This property is read-only.

In Visual Basic and VBScript, this property is used implicitly in For Each...In...Next constructs.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCNetworksInTemplate


IFPCNetworksInTemplate | FPCNetworksInTemplate Count property [ISA Server 2004]

Count Property of IFPCNetworksInTemplate[C++]

FPCNetworksInTemplate.Count [Visual Basic]

[C++]

The Count property gets the number of FPCNetworkInTemplate objects in the collection.

HRESULT get_Count(
  long* plCount
);

Parameters

plCount
Pointer to a variable that on return receives a 32-bit integer specifying the number of FPCNetworkInTemplate objects in the collection.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The Count property gets the number of FPCNetworkInTemplate objects in the collection.

Property Count As Long

Property Value

A 32-bit integer value that specifies the number of FPCNetworkInTemplate objects in the collection.

Remarks

This property is read-only.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCNetworksInTemplate


IFPCNetworksInTemplate | FPCNetworksInTemplate Item method [ISA Server 2004]

IFPCNetworksInTemplate::Item[C++]

FPCNetworksInTemplate.Item [Visual Basic]

[C++]

The Item method retrieves the requested IFPCNetworkInTemplate interface from the collection.

HRESULT Item(
  VARIANT Index,
  IFPCNetworkInTemplate** ppItem
);

Parameters

Index
[in] Required. Name or one-based index of the object to retrieve.
ppItem
[out] Address of an interface pointer that on return points to the IFPCNetworkInTemplate interface requested.

Return Values

This method can return one of the following:

  • S_OK, indicating that the operation succeeded.
  • An error code, indicating that the operation failed. In this case, the [out] parameter returned is a null object.

[Visual Basic]

The Item method retrieves the requested FPCNetworkInTemplate object from the collection.

Function Item( _
  ByVal Index As Variant _
) As FPCNetworkInTemplate

Parameters

Index
[in] Required. Name or one-based index of the object to retrieve.

Return Values

This method returns a reference to the FPCNetworkInTemplate object requested if successful. Otherwise, an error is raised that can be intercepted by using an error handler.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCNetworksInTemplate


IFPCNetworksInTemplate.NetworksAreIdentical property [ISA Server 2004]

NetworksAreIdentical Property of IFPCNetworksInTemplate[C++]

FPCNetworksInTemplate.NetworksAreIdentical [Visual Basic]

[C++]

The NetworksAreIdentical property gets a Boolean value that indicates whether the networks in the template are the same as those in the current configuration.

HRESULT get_NetworksAreIdentical(
  VARIANT_BOOL* pfNetworksAreIdentical
);

Parameters

pfNetworksAreIdentical
Pointer to a Boolean variable that is set on return to VARIANT_TRUE if the networks in the template are the same as those in the current configuration, or to VARIANT_FALSE if the networks in the template differ from those in the current configuration.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The NetworksAreIdentical property gets a Boolean value that indicates whether the networks in the template are the same as those in the current configuration.

Property NetworksAreIdentical As Boolean

Property Value

Boolean value that indicates whether the networks in the template are the same as those in the current configuration.

Remarks

This property is read-only.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCNetworksInTemplate


FPCNetworkTemplate object [ISA Server 2004]

FPCNetworkTemplate

The FPCNetworkTemplate object represents a network template. A network template defines the relationships between a set of ISA Server networks and the policies that control traffic between those networks. A network template is stored in an XML file. The FPCNetworkTemplate object properties allow you to set and get a name and description for the network template. You cannot use the ISA Server administration COM objects to change the XML file that defines a network template.

The XML file that contains a network template configuration includes:

  • Networks and network sets
  • Network rules that describe the relationships between various networks and network sets
  • Policy elements
  • Policies

Select the network template to apply to an array using the SelectNetworkTemplateAndPolicy method of the FPCArray object.

This object is typically an element of an FPCNetworkTemplates collection.

Click here to see the ISA Server object hierarchy.

Methods

The FPCNetworkTemplate object defines the following methods.

Method | Description
Refresh | Recursively reads the values of all of the object's properties, including the properties of its subobjects and their elements (for collections), from persistent storage, overwriting any changes that were not saved.
Save | Writes the current values of the object's writable properties to persistent storage.

Properties

The FPCNetworkTemplate object has the following properties.

Property | Description
Description | Gets or sets the description of the template.
LargeBMPName | Gets the large bitmap (.bmp) file content of the network template.
MediumBMPName | Gets the medium .bmp file content of the network template.
Name | Gets or sets the name of the template.
NetworksInTemplate | Gets an FPCNetworksInTemplate collection that specifies the networks included in the template.
Order | Gets the ordinal position of the network template.
PersistentName | Gets the persistent name of the network template.
PoliciesInTemplate | Gets an FPCPoliciesInTemplate collection that specifies the policies included in the template.
SmallBMPName | Gets the small .bmp file content of the network template.
XMLName | Gets the name of the XML file that specifies the network configuration and policies in the network template.

Remarks

This collection implements the IFPCNetworkTemplate interface.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

COM Objects


IFPCNetworkTemplate | FPCNetworkTemplate Description property [ISA Server 2004]

Description Property of IFPCNetworkTemplate[C++]

FPCNetworkTemplate.Description [Visual Basic]

[C++]

The Description property gets or sets the description of the network template.

HRESULT get_Description(
  BSTR* pbstrDescription
);

HRESULT put_Description(
  BSTR bstrDescription
);

Parameters

pbstrDescription
Pointer to a BSTR that is set on return to a string value specifying the description of the network template.
bstrDescription
BSTR that specifies the description of the network template.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write.

[Visual Basic]

The Description property gets or sets the description of the network template.

Property Description As String

Property Value

String that specifies the description of the network template.

Remarks

This property is read/write.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCNetworkTemplate


IFPCNetworkTemplate.LargeBMPName(BSTR) property [ISA Server 2004]

LargeBMPName Property of IFPCNetworkTemplate[C++]

FPCNetworkTemplate.LargeBMPName [Visual Basic]

[C++]

The LargeBMPName property gets the large bitmap (.bmp) file for the network template. Network template .bmp files come in small, medium, and large formats.

HRESULT get_LargeBMPName(
  BSTR* pbstrLargeBMPName
);

Parameters

pbstrLargeBMPName
Pointer to a BSTR that is set on return to a string value specifying the name of the large .bmp file for the network template.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The LargeBMPName property gets the large bitmap (.bmp) file for the network template. Network template .bmp files come in small, medium, and large formats.

Property LargeBMPName As String

Property Value

String that specifies the name of the large .bmp file for the network template.

Remarks

This property is read-only.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCNetworkTemplate


IFPCNetworkTemplate.MediumBMPName(BSTR) property [ISA Server 2004]

MediumBMPName Property of IFPCNetworkTemplate[C++]

FPCNetworkTemplate.MediumBMPName [Visual Basic]

[C++]

The MediumBMPName property gets the medium bitmap (.bmp) file for the network template. Network template .bmp files come in small, medium, and large formats.

HRESULT get_MediumBMPName(
  BSTR* pbstrMediumBMPName
);

Parameters

pbstrMediumBMPName
Pointer to a BSTR that is set on return to a string value specifying the name of the medium .bmp file for the network template.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The MediumBMPName property gets the medium bitmap (.bmp) file for the network template. Network template .bmp files come in small, medium, and large formats.

Property MediumBMPName As String

Property Value

String that specifies the name of the medium .bmp file for the network template.

Remarks

This property is read-only.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCNetworkTemplate


IFPCNetworkTemplate | FPCNetworkTemplate Name property [ISA Server 2004]

Name Property of IFPCNetworkTemplate[C++]

FPCNetworkTemplate.Name [Visual Basic]

[C++]

The Name property gets or sets the name of the network template.

HRESULT get_Name(
  BSTR* pbstrName
);

HRESULT put_Name(
  BSTR bstrName
);

Parameters

pbstrName
Pointer to a BSTR that is set on return to a string value specifying the name of the network template.
bstrName
BSTR that specifies the name of the network template.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write.

[Visual Basic]

The Name property gets or sets the name of the network template.

Property Name As String

Property Value

String that specifies the name of the network template.

Remarks

This property is read/write.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCNetworkTemplate


IFPCNetworkTemplate.NetworksInTemplate (1 Parameter) property [ISA Server 2004]

NetworksInTemplate Property of IFPCNetworkTemplate[C++]

FPCNetworkTemplate.NetworksInTemplate [Visual Basic]

[C++]

The NetworksInTemplate property gets an FPCNetworksInTemplate collection that specifies the networks included in the template.

HRESULT get_NetworksInTemplate(
  IFPCNetworksInTemplate** ppNetworksInTemplate
);

Parameters

ppNetworksInTemplate
Address of an interface pointer that on return points to an IFPCNetworksInTemplate interface that represents the collection specifying the networks included in the template.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The NetworksInTemplate property gets an FPCNetworksInTemplate collection that specifies the networks included in the template.

Property NetworksInTemplate As FPCNetworksInTemplate

Property Value

Reference to an FPCNetworksInTemplate collection that contains references to the collection that specifies the networks included in the template.

Remarks

This property is read-only.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCNetworkTemplate


IFPCNetworkTemplate | FPCNetworkTemplate Order(long) property [ISA Server 2004]

Order Property of IFPCNetworkTemplate[C++]

FPCNetworkTemplate.Order [Visual Basic]

[C++]

The Order property gets the ordinal position of the network template in the collection of network templates.

HRESULT get_Order(
  long* plOrder
);

Parameters

plOrder
Pointer to a variable that on return receives a 32-bit integer specifying the ordinal position of the network template in the collection of network templates.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only. Its value is determined by the position of the network template in the FPCNetworkTemplates collection and can be used to retrieve a network template from the collection.

[Visual Basic]

The Order property gets the ordinal position of the network template in the collection of network templates.

Property Order As Long

Property Value

A 32-bit integer that specifies the ordinal position of the network template in the collection of network templates.

Remarks

This property is read-only. Its value is determined by the position of the network template in the FPCNetworkTemplates collection and can be used to retrieve a network template from the collection.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCNetworkTemplate


IFPCNetworkTemplate.PersistentName(BSTR) property [ISA Server 2004]

PersistentName Property of IFPCNetworkTemplate[C++]

FPCNetworkTemplate.PersistentName [Visual Basic]

[C++]

The PersistentName property gets the persistent name of the network template. The persistent name of a network template is a globally unique identifier (GUID) that does not vary in different localized versions of ISA Server.

HRESULT get_PersistentName(
  BSTR* pbstrPersistentName
);

Parameters

pbstrPersistentName
Pointer to a BSTR that is set on return to a string value specifying the persistent name of the network template.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

The persistent names of all of the predefined objects that are installed with ISA Server are listed in FpcObjectsGuids.h.

[Visual Basic]

The PersistentName property gets the persistent name of the network template. The persistent name of a network template is a globally unique identifier (GUID) that does not vary in different localized versions of ISA Server.

Property PersistentName As String

Property Value

String that specifies the persistent name of the network template.

Remarks

This property is read-only.

The persistent names of all of the predefined objects that are installed with ISA Server are listed in FpcObjectsGuids.vbs and FpcObjectsGuids.js.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCNetworkTemplate


IFPCNetworkTemplate.PoliciesInTemplate (1 Parameter) property [ISA Server 2004]

PoliciesInTemplate Property of IFPCNetworkTemplate[C++]

FPCNetworkTemplate.PoliciesInTemplate [Visual Basic]

[C++]

The PoliciesInTemplate property gets an FPCPoliciesInTemplate collection that specifies the policies included in the template.

HRESULT get_PoliciesInTemplate(
  IFPCPoliciesInTemplate** ppPoliciesInTemplate
);

Parameters

ppPoliciesInTemplate
Address of an interface pointer that on return points to an FPCPoliciesInTemplate interface that represents the collection specifying the policies included in the template.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The PoliciesInTemplate property gets an FPCPoliciesInTemplate collection that specifies the policies included in the template.

Property PoliciesInTemplate As FPCPoliciesInTemplate

Property Value

Reference to an FPCPoliciesInTemplate collection that specifies the policies included in the template.

Remarks

This property is read-only.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCNetworkTemplate


IFPCNetworkTemplate | FPCNetworkTemplate Refresh method [ISA Server 2004]

IFPCNetworkTemplate::Refresh[C++]

FPCNetworkTemplate.Refresh [Visual Basic]

[C++]

The Refresh method recursively reads the values of all of the object's properties, including the properties of its subobjects and their elements (for collections), from persistent storage, discarding any changes that have not been saved.

HRESULT Refresh();

Parameters

This method has no parameters.

Return Values

This method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

Changes made to this object can be saved by calling the Save method of this object or the Save method of any object containing it.

[Visual Basic]

The Refresh method recursively reads the values of all of the object's properties, including the properties of its subobjects and their elements (for collections), from persistent storage, discarding any changes that have not been saved.

Sub Refresh()

Parameters

This method has no parameters.

Return Values

This method has no return values. If the call is unsuccessful, an error is raised that can be intercepted by using an error handler.

Remarks

Changes made to this object can be saved by calling the Save method of this object or the Save method of any object containing it.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCNetworkTemplate


IFPCNetworkTemplate | FPCNetworkTemplate Save method [ISA Server 2004]

IFPCNetworkTemplate::Save[C++]

FPCNetworkTemplate.Save [Visual Basic]

[C++]

The Save method writes the current values of the object's writable properties to persistent storage. It is important to remember that any changes made by scripts and programs are not saved until after the Save method is called.

HRESULT Save(
  VARIANT_BOOL fResetRequiredServices,
  VARIANT_BOOL fReloadConfiguration
);

Parameters

fResetRequiredServices
[in, optional] Boolean value that indicates whether to restart the services that need to be restarted for any of the changes saved to take effect. The default value is VARIANT_FALSE.
fReloadConfiguration
[in, optional] Boolean value that indicates whether the call will include synchronous reloading of all changes that can be applied dynamically without restarting services. The default value is VARIANT_TRUE.

Return Values

This method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

Configuration changes are applied only after the new settings are written to persistent storage and reloaded to the services that use them. Most changes can be applied dynamically without restarting any services. However, some changes can take effect only after the Microsoft Firewall service is restarted. For more information, see Restarting Services after Configuration Changes.

ISA Server maintains a bitmask that specifies which services need to be started for currently unsaved changes to take effect. This bitmask can be retrieved by calling the GetServiceRestartMask method on an object that contains this object as a subobject. Calling the Save method clears all of the bits in this bitmask even if the fResetRequiredServices parameter is set to VARIANT_FALSE.

If the fReloadConfiguration parameter is set to VARIANT_FALSE the current values will be written to persistent storage without updating the configuration being used by the ISA Server services. The configuration used by each service will not be updated until the service is restarted or the new settings are reloaded by another call to Save.

[Visual Basic]

The Save method writes the current values of the object's writable properties to persistent storage. It is important to remember that any changes made by scripts and programs are not saved until after the Save method is called.

Sub Save( _
  [ ByVal fResetRequiredServices As Boolean ], _
  [ ByVal fReloadConfiguration As Boolean ] _
)

Parameters

fResetRequiredServices
[in, optional] Boolean value that indicates whether to restart the services that need to be restarted for any of the changes saved to take effect. The default value is False.
fReloadConfiguration
[in, optional] Boolean value that indicates whether the call will include synchronous reloading of all the saved configuration changes that can be applied dynamically without restarting services. The default value is True.

Return Values

This method has no return values. If the call is unsuccessful, an error is raised that can be intercepted by using an error handler.

Remarks

Configuration changes are applied only after the new settings are written to persistent storage and reloaded to the services that use them. Most changes can be applied dynamically without restarting any services. However, some changes can take effect only after the Microsoft Firewall service is restarted. For more information, see Restarting Services after Configuration Changes.

ISA Server maintains a bitmask that specifies which services need to be started for currently unsaved changes to take effect. This bitmask can be retrieved by calling the GetServiceRestartMask method on an object that contains this object as a subobject. Calling the Save method clears all of the bits in this bitmask even if the fResetRequiredServices parameter is set to False.

If the fReloadConfiguration parameter is set to False the current values will be written to persistent storage without updating the configuration being used by the ISA Server services. The configuration used by each service will not be updated until the service is restarted or the new settings are reloaded by another call to Save.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCNetworkTemplate


IFPCNetworkTemplate.SmallBMPName(BSTR) property [ISA Server 2004]

SmallBMPName Property of IFPCNetworkTemplate[C++]

FPCNetworkTemplate.SmallBMPName [Visual Basic]

[C++]

The SmallBMPName property gets the small bitmap (.bmp) file for the network template. Network template .bmp files come in small, medium, and large formats.

HRESULT get_SmallBMPName(
  BSTR* pbstrSmallBMPName
);

Parameters

pbstrSmallBMPName
Pointer to a BSTR that is set on return to a string value specifying the name of the small .bmp file for the network template.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The SmallBMPName property gets the small bitmap (.bmp) file for the network template. Network template .bmp files come in small, medium, and large formats.

Property SmallBMPName As String

Property Value

String that specifies the name of the small .bmp file for the network template.

Remarks

This property is read-only.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCNetworkTemplate


IFPCNetworkTemplate | FPCNetworkTemplate XMLName property [ISA Server 2004]

XMLName Property of IFPCNetworkTemplate[C++]

FPCNetworkTemplate.XMLName [Visual Basic]

[C++]

The XMLName property gets the name of the XML file that specifies the network configuration and policies in the network template.

HRESULT get_XMLName(
  BSTR* pbstrXMLName
);

Parameters

pbstrXMLName
Pointer to a BSTR that is set on return to a string value specifying the name of the XML file.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The XMLName property gets the name of the XML file that specifies the network configuration and policies in the network template.

Property XMLName As String

Property Value

String that specifies the name of the XML file.

Remarks

This property is read-only.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCNetworkTemplate


FPCNetworkTemplates collection [ISA Server 2004]

FPCNetworkTemplates Collection

The FPCNetworkTemplates collection is an ordered set of FPCNetworkTemplate objects, each of which represents a network template. A network template defines the relationships between a set of ISA Server networks and the policies that control traffic between those networks.

Click here to see the ISA Server object hierarchy.

Methods

The FPCNetworkTemplates collection defines the following methods.

Method | Description
Add | Creates a new FPCNetworkTemplate object in the collection and returns a reference to it.
Item | Retrieves the requested FPCNetworkTemplate object from the collection.
Refresh | Recursively reads the values of all the properties of the collection and its elements, including all the properties of its subobjects and their elements (for collections), from persistent storage, overwriting any changes that were not saved.
Remove | Removes the specified FPCNetworkTemplate object from the collection.
Save | Writes the current values of all the writable properties of the collection and its elements to persistent storage.

Properties

The FPCNetworkTemplates collection has the following properties.

Property | Description
_NewEnum | Gets an enumerator object for the collection.
Count | Gets the number of FPCNetworkTemplate objects in the collection.

Remarks

This collection implements the IFPCNetworkTemplates interface.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

COM Objects


IFPCNetworkTemplates | FPCNetworkTemplates _NewEnum property [ISA Server 2004]

_NewEnum Property of IFPCNetworkTemplates[C++]

FPCNetworkTemplates._NewEnum [Visual Basic]

[C++]

The _NewEnum property gets an enumerator object for the collection. An enumerator object provides serial access to the elements of the collection.

HRESULT get__NewEnum(
  IUnknown* ppEnum
);

Parameters

ppEnum
Address of an interface pointer that on return points to the IUnknown interface of an enumerator object that implements an IEnumVARIANT interface for the collection. An interface pointer to the IEnumVARIANT interface of the enumerator object can be retrieved by calling QueryInterface on the IUnknown interface returned.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The _NewEnum property gets an enumerator object for the collection. An enumerator object provides serial access to the elements of the collection.

Property _NewEnum As IUnknown

Property Value

Reference to an enumerator object that provides serial access to the elements of the collection.

Remarks

This property is read-only.

In Visual Basic and VBScript, this property is used implicitly in For Each...In...Next constructs.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCNetworkTemplates


IFPCNetworkTemplates | FPCNetworkTemplates Add method [ISA Server 2004]

IFPCNetworkTemplates::Add[C++]

FPCNetworkTemplates.Add [Visual Basic]

[C++]

The Add method creates a new FPCNetworkTemplate object in the collection and returns a reference to it.

HRESULT Add(
  BSTR Name,
  BSTR XMLName,
  BSTR SmallBMPName,
  BSTR MediumBMPName,
  BSTR LargeBMPName,
  IFPCNetworkTemplate** ppNewNetworkTemplate
);

Parameters

Name
[in] BSTR that specifies the name of the new network template.
XMLName
[in] BSTR that specifies the name of the XML file for the new network template. The XML file specifies the network configuration and policies that will be defined in the new network template.
SmallBMPName
[in] BSTR that specifies the name of the small .bmp file for the new network template.
MediumBMPName
[in] BSTR that specifies the name of the medium .bmp file for the new network template.
LargeBMPName
[in] BSTR that specifies the name of the large .bmp file for the new network template.
ppNewNetworkTemplate
[out] Address of an interface pointer that on return points to the new IFPCNetworkTemplate interface added.

Return Values

This method can return one of the following:

  • S_OK, indicating that the operation succeeded.
  • An error code, indicating that the operation failed. In this case, the [out] parameter returned is a null object.

[Visual Basic]

The Add method creates a new FPCNetworkTemplate object in the collection and returns a reference to it.

Function Add( _
  ByVal Name As String, _
  ByVal XMLName As String, _
  ByVal SmallBMPName As String, _
  ByVal MediumBMPName As String, _
  ByVal LargeBMPName As String _
) As FPCNetworkTemplate

Parameters

Name
[in] String that specifies the name of the new network template.
XMLName
[in] String that specifies the name of the XML file for the new network template. The XML file specifies the network configuration and policies that will be defined in the new network template.
SmallBMPName
[in] String that specifies the name of the small .bmp file for the new network template.
MediumBMPName
[in] String that specifies the name of the medium .bmp file for the new network template.
LargeBMPName
[in] String that specifies the name of the large .bmp file for the new network template.

Return Values

This method returns a reference to the FPCNetworkTemplate object added if the call is successful. Otherwise, an error is raised that can be intercepted by using an error handler.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCNetworkTemplates


IFPCNetworkTemplates | FPCNetworkTemplates Count property [ISA Server 2004]

Count Property of IFPCNetworkTemplates[C++]

FPCNetworkTemplates.Count [Visual Basic]

[C++]

The Count property gets the number of FPCNetworkTemplate objects in the collection.

HRESULT get_Count(
  long* plCount
);

Parameters

plCount
Pointer to a variable that on return receives a 32-bit integer specifying the number of FPCNetworkTemplate objects in the collection.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The Count property gets the number of FPCNetworkTemplate objects in the collection.

Property Count As Long

Property Value

A 32-bit integer value that specifies the number of FPCNetworkTemplate objects in the collection.

Remarks

This property is read-only.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCNetworkTemplates


IFPCNetworkTemplates | FPCNetworkTemplates Item method [ISA Server 2004]

IFPCNetworkTemplates::Item[C++]

FPCNetworkTemplates.Item [Visual Basic]

[C++]

The Item method retrieves the requested IFPCNetworkTemplate interface from the collection.

HRESULT Item(
  VARIANT Index,
  IFPCNetworkTemplate** ppItem
);

Parameters

Index
[in] Required. Name or one-based index of the object to retrieve.
ppItem
[out] Address of an interface pointer that on return points to the IFPCNetworkTemplate interface requested.

Return Values

The method can return one of the following:

  • S_OK, indicating that the operation succeeded.
  • An error code, indicating that the operation failed. In this case, the [out] parameter returned is a null object.

[Visual Basic]

The Item method retrieves the requested FPCNetworkTemplate object from the collection.

Function Item( _
  ByVal Index As Variant _
) As FPCNetworkTemplate

Parameters

Index
[in] Required. Name or one-based index of the object to retrieve.

Return Values

This method returns a reference to the FPCNetworkTemplate object requested if successful. Otherwise, an error is raised that can be intercepted by using an error handler.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCNetworkTemplates


IFPCNetworkTemplates | FPCNetworkTemplates Refresh method [ISA Server 2004]

IFPCNetworkTemplates::Refresh[C++]

FPCNetworkTemplates.Refresh [Visual Basic]

[C++]

The Refresh method recursively reads the values of all the properties of the collection and its elements, including all the properties of its subobjects and their elements (for collections), from persistent storage, discarding any changes that have not been saved.

HRESULT Refresh();

Parameters

This method has no parameters.

Return Values

This method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

Changes made to this collection or its elements can be saved by calling the Save method of this collection or the Save method of any object containing it.

[Visual Basic]

The Refresh method recursively reads the values of all the properties of the collection and its elements, including all the properties of its subobjects and their elements (for collections), from persistent storage, discarding any changes that have not been saved.

Sub Refresh()

Parameters

This method has no parameters.

Return Values

This method has no return values. If the call is unsuccessful, an error is raised that can be intercepted by using an error handler.

Remarks

Changes made to this collection or its elements can be saved by calling the Save method of this collection or the Save method of any object containing it.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCNetworkTemplates


IFPCNetworkTemplates | FPCNetworkTemplates Remove method [ISA Server 2004]

IFPCNetworkTemplates::Remove[C++]

FPCNetworkTemplates.Remove [Visual Basic]

[C++]

The Remove method removes the specified FPCNetworkTemplate object from the collection.

HRESULT Remove(
  VARIANT Index
);

Parameters

Index
[in] Required. Name or one-based index of the FPCNetworkTemplate object to remove.

Return Values

This method returns S_OK if the call is successful; otherwise, it returns an error code.

[Visual Basic]

The Remove method removes the specified FPCNetworkTemplate object from the collection.

Sub Remove( _
  ByVal Index As Variant _
)

Parameters

Index
[in] Required. Name or one-based index of the FPCNetworkTemplate object to remove.

Return Values

This method has no return values. If the call is unsuccessful, an error is raised that can be intercepted by using an error handler.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCNetworkTemplates


IFPCNetworkTemplates | FPCNetworkTemplates Save method [ISA Server 2004]

IFPCNetworkTemplates::Save[C++]

FPCNetworkTemplates.Save [Visual Basic]

[C++]

The Save method writes the current values of all the writable properties of the collection and its elements to persistent storage. It is important to remember that any changes made by scripts and programs are not saved until after the Save method is called.

HRESULT Save(
  VARIANT_BOOL fResetRequiredServices,
  VARIANT_BOOL fReloadConfiguration
);

Parameters

fResetRequiredServices
[in, optional] Boolean value that indicates whether to restart the services that need to be restarted for any of the changes saved to take effect. The default value is VARIANT_FALSE.
fReloadConfiguration
[in, optional] Boolean value that indicates whether the call will include synchronous reloading of all changes that can be applied dynamically without restarting services. The default value is VARIANT_TRUE.

Return Values

This method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

Configuration changes are applied only after the new settings are written to persistent storage and reloaded to the services that use them. Most changes can be applied dynamically without restarting any services. However, some changes can take effect only after the Microsoft Firewall service is restarted. For more information, see Restarting Services after Configuration Changes.

ISA Server maintains a bitmask that specifies which services need to be started for currently unsaved changes to take effect. This bitmask can be retrieved by calling the GetServiceRestartMask method on an object that contains this object as a subobject. Calling the Save method clears all of the bits in this bitmask even if the fResetRequiredServices parameter is set to VARIANT_FALSE.

If the fReloadConfiguration parameter is set to VARIANT_FALSE the current values will be written to persistent storage without updating the configuration being used by the ISA Server services. The configuration used by each service will not be updated until the service is restarted or the new settings are reloaded by another call to Save.

[Visual Basic]

The Save method writes the current values of all the writable properties of the collection and its elements to persistent storage. It is important to remember that any changes made by scripts and programs are not saved until after the Save method is called.

Sub Save( _
  [ ByVal fResetRequiredServices As Boolean ], _
  [ ByVal fReloadConfiguration As Boolean ] _
)

Parameters

fResetRequiredServices
[in, optional] Boolean value that indicates whether to restart the services that need to be restarted for any of the changes saved to take effect. The default value is False.
fReloadConfiguration
[in, optional] Boolean value that indicates whether the call will include synchronous reloading of all the saved configuration changes that can be applied dynamically without restarting services. The default value is True.

Return Values

This method has no return values. If the call is unsuccessful, an error is raised that can be intercepted by using an error handler.

Remarks

Configuration changes are applied only after the new settings are written to persistent storage and reloaded to the services that use them. Most changes can be applied dynamically without restarting any services. However, some changes can take effect only after the Microsoft Firewall service is restarted. For more information, see Restarting Services after Configuration Changes.

ISA Server maintains a bitmask that specifies which services need to be started for currently unsaved changes to take effect. This bitmask can be retrieved by calling the GetServiceRestartMask method on an object that contains this object as a subobject. Calling the Save method clears all of the bits in this bitmask even if the fResetRequiredServices parameter is set to False.

If the fReloadConfiguration parameter is set to False the current values will be written to persistent storage without updating the configuration being used by the ISA Server services. The configuration used by each service will not be updated until the service is restarted or the new settings are reloaded by another call to Save.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCNetworkTemplates


FPCNonWindowsUser object [ISA Server 2004]

FPCNonWindowsUser

The FPCNonWindowsUser object represents a single authenticated user who is not an Active Directory user. For more information about different kinds of users in ISA Server, see Defining Groups of Users. You can manage which non-Windows users are in a user set using the NonWindowsUsers property of the FPCUserSet object. For more information about user sets, see Defining Groups of Users.

This object is typically an element of an FPCNonWindowsUsers collection.

Click here to see the ISA Server object hierarchy.

Methods

The FPCNonWindowsUser object defines the following methods.

Method | Description
Refresh | Reads the object's properties from persistent storage, overwriting any changes that have not been saved.
Save | Writes the current values of the object's properties to persistent storage.

Properties

The FPCNonWindowsUser object has the following properties.

Property | Description
Namespace | Gets the authentication namespace for the user.
UserName | Gets or sets the user name.

Remarks

This object implements the IFPCNonWindowsUser interface.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

COM Objects


IFPCNonWindowsUser | FPCNonWindowsUser Namespace property [ISA Server 2004]

Namespace Property of IFPCNonWindowsUser[C++]

FPCNonWindowsUser.Namespace [Visual Basic]

[C++]

The Namespace property gets the authentication namespace for the user. The namespace identifies the authentication scheme that will be used for the user.

HRESULT get_Namespace(
  BSTR* pbstrNamespace
);

Parameters

pbstrNamespace
Pointer to a BSTR that is set on return to a string value specifying the namespace.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The Namespace property gets the authentication namespace for the user. The namespace identifies the authentication scheme that will be used for the user.

Property Namespace As String

Property Value

String that specifies the namespace.

Remarks

This property is read-only.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCNonWindowsUser


IFPCNonWindowsUser | FPCNonWindowsUser Refresh method [ISA Server 2004]

IFPCNonWindowsUser::Refresh[C++]

FPCNonWindowsUser.Refresh [Visual Basic]

[C++]

The Refresh method reads the object's properties from persistent storage, overwriting any changes that have not been saved.

HRESULT Refresh();

Parameters

This method has no parameters.

Return Values

This method returns S_OK if the call is successful; otherwise, it returns an error code.

[Visual Basic]

The Refresh method reads the object's properties from persistent storage, overwriting any changes that have not been saved.

Sub Refresh()

Parameters

This method has no parameters.

Return Values

This method has no return values. If the call is unsuccessful, an error is raised that can be intercepted by using an error handler.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCNonWindowsUser


IFPCNonWindowsUser | FPCNonWindowsUser Save method [ISA Server 2004]

IFPCNonWindowsUser::Save[C++]

FPCNonWindowsUser.Save [Visual Basic]

[C++]

The Save method writes the current values of the object's properties to persistent storage. It is important to remember that any changes made by scripts and programs are not saved until after the Save method is called.

HRESULT Save(
  VARIANT_BOOL fResetRequiredServices,
  VARIANT_BOOL fReloadConfiguration
);

Parameters

fResetRequiredServices
[in, optional] Boolean value that indicates whether to restart the services that need to be restarted for any of the changes saved to take effect. The default value is VARIANT_FALSE.
fReloadConfiguration
[in, optional] Boolean value that indicates whether the call will include synchronous reloading of all changes that can be applied dynamically without restarting services. The default value is VARIANT_TRUE.

Return Values

This method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

Configuration changes are applied only after the new settings are written to persistent storage and reloaded to the services that use them. Most changes can be applied dynamically without restarting any services. However, some changes can take effect only after the Microsoft Firewall service is restarted. For more information, see Restarting Services after Configuration Changes.

ISA Server maintains a bitmask that specifies which services need to be started for currently unsaved changes to take effect. This bitmask can be retrieved by calling the GetServiceRestartMask method on an object that contains this object as a subobject. Calling the Save method clears all of the bits in this bitmask even if the fResetRequiredServices parameter is set to VARIANT_FALSE.

If the fReloadConfiguration parameter is set to VARIANT_FALSE the current values of the object's properties will be written to persistent storage without updating the configuration being used by the ISA Server services. The configuration used by each service will not be updated until the service is restarted or the new settings are reloaded by another call to Save.

[Visual Basic]

The Save method writes the current values of the object's properties to persistent storage. It is important to remember that any changes made by scripts and programs are not saved until after the Save method is called.

Sub Save( _
  [ ByVal fResetRequiredServices As Boolean ], _
  [ ByVal fReloadConfiguration As Boolean ] _
)

Parameters

fResetRequiredServices
[in, optional] Boolean value that indicates whether to restart the services that need to be restarted for any of the changes saved to take effect. The default value is False.
fReloadConfiguration
[in, optional] Boolean value that indicates whether the call will include synchronous reloading of all the saved configuration changes that can be applied dynamically without restarting services. The default value is True.

Return Values

This method has no return values. If the call is unsuccessful, an error is raised that can be intercepted by using an error handler.

Remarks

Configuration changes are applied only after the new settings are written to persistent storage and reloaded to the services that use them. Most changes can be applied dynamically without restarting any services. However, some changes can take effect only after the Microsoft Firewall service is restarted. For more information, see Restarting Services after Configuration Changes.

ISA Server maintains a bitmask that specifies which services need to be started for currently unsaved changes to take effect. This bitmask can be retrieved by calling the GetServiceRestartMask method on an object that contains this object as a subobject. Calling the Save method clears all of the bits in this bitmask even if the fResetRequiredServices parameter is set to False.

If the fReloadConfiguration parameter is set to False the current values of the object's properties will be written to persistent storage without updating the configuration being used by the ISA Server services. The configuration used by each service will not be updated until the service is restarted or the new settings are reloaded by another call to Save.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCNonWindowsUser


IFPCNonWindowsUser | FPCNonWindowsUser UserName property [ISA Server 2004]

UserName Property of IFPCNonWindowsUser[C++]

FPCNonWindowsUser.UserName [Visual Basic]

[C++]

The UserName property gets or sets the user name.

HRESULT get_UserName(
  BSTR* pbstrName
);

HRESULT put_UserName(
  BSTR bstrName
);

Parameters

pbstrName
Pointer to a BSTR that is set on return to a string value specifying the user name.
bstrName
String that specifies the user name.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write.

[Visual Basic]

The UserName property gets or sets the user name.

Property UserName As String

Property Value

String that specifies the user name.

Remarks

This property is read/write.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCNonWindowsUser


FPCNonWindowsUsers collection [ISA Server 2004]

FPCNonWindowsUsers Collection

The FPCNonWindowsUsers collection contains an ordered set of FPCNonWindowsUser objects. An FPCNonWindowsUser object represents a single user who is not an Active Directory user. For more information, see Defining Groups of Users.

This collection is typically accessed through the NonWindowsUsers property of an FPCUserSet object.

Click here to see the ISA Server object hierarchy.

Methods

The FPCNonWindowsUsers collection defines the following methods.

Method | Description
Add | Creates a new FPCNonWindowsUser object in the collection and returns a reference to it.
AddEveryoneUserOfNamespace | Creates a new FPCNonWindowsUser object for the user called "Everyone" in the specified namespace, adds it to the collection, and returns a reference to it.
Item | Retrieves the requested FPCNonWindowsUser object from the collection.
Refresh | Reads the values of all the properties of the collection and its elements from persistent storage, discarding any changes that have not been saved.
Remove | Removes the specified FPCNonWindowsUser object from the collection.
RemoveAll | Removes all of the FPCNonWindowsUser objects from the collection.
RemoveEveryoneUserOfNamespace | Removes the FPCNonWindowsUser object for the user called "Everyone" in the specified namespace from the collection.
Save | Writes the current values of all the properties of the collection and its elements to persistent storage.

Properties

The FPCNonWindowsUsers collection has the following properties.

Property | Description
_NewEnum | Gets an enumerator object for the collection.
Count | Gets the number of FPCNonWindowsUser objects in the collection.

Remarks

This collection implements the IFPCNonWindowsUsers interface.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

COM Objects


IFPCNonWindowsUsers | FPCNonWindowsUsers _NewEnum property [ISA Server 2004]

_NewEnum Property of IFPCNonWindowsUsers[C++]

FPCNonWindowsUsers._NewEnum [Visual Basic]

[C++]

The _NewEnum property gets an enumerator object for the collection. An enumerator object provides serial access to the elements of the collection.

HRESULT get__NewEnum(
  IUnknown* ppEnum
);

Parameters

ppEnum
Address of an interface pointer that on return points to the IUnknown interface of an enumerator object that implements an IEnumVARIANT interface for the collection. An interface pointer to the IEnumVARIANT interface of the enumerator object can be retrieved by calling QueryInterface on the IUnknown interface returned.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The _NewEnum property gets an enumerator object for the collection. An enumerator object provides serial access to the elements of the collection.

Property _NewEnum As IUnknown

Property Value

Reference to an enumerator object that provides serial access to the elements of the collection.

Remarks

This property is read-only.

In Visual Basic and VBScript, this property is used implicitly in For Each...In...Next constructs.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCNonWindowsUsers


IFPCNonWindowsUsers | FPCNonWindowsUsers Add method [ISA Server 2004]

IFPCNonWindowsUsers::Add[C++]

FPCNonWindowsUsers.Add [Visual Basic]

[C++]

The Add method creates a new FPCNonWindowsUser object in the collection and returns a reference to it.

HRESULT Add(
  BSTR Username,
  BSTR Namespace,
  IFPCNonWindowsUser** ppNonWindowsUser
);

Parameters

Username
[in] Required. BSTR that specifies the name of the user.
Namespace
Required. BSTR that specifies the user's namespace, which identifies the authentication scheme that will be used for the user. The value supplied should not contain more than UNLEN characters. UNLEN is defined in Lmcons.h.
ppNonWindowsUser
[out] Address of an interface pointer that on return points to the new IFPCNonWindowsUser interface created.

Return Values

This method can return one of the following:

  • S_OK, indicating that the operation succeeded.
  • An error code, indicating that the operation failed. In this case, the [out] parameter returned is a null object.

Remarks

This function does not validate the length of the value supplied in the Namespace parameter. A namespace containing more than UNLEN characters should not be used.

[Visual Basic]

The Add method creates a new FPCNonWindowsUser object in the collection and returns a reference to it.

Function Add( _
  ByVal Username As String, _
  ByVal Namespace As String _
) As FPCNonWindowsUser

Parameters

Username
[in] Required. String that specifies the name of the user.
Namespace
Required. String that specifies the user's namespace, which identifies the authentication scheme that will be used for the user. The value supplied should not contain more than UNLEN characters. UNLEN is defined in Lmcons.h.

Return Values

This method returns a reference to an FPCNonWindowsUser object if successful. Otherwise, an error is raised that can be intercepted by using an error handler.

Remarks

This function does not validate the length of the value supplied in the Namespace parameter. A namespace containing more than UNLEN characters should not be used.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCNonWindowsUsers


IFPCNonWindowsUsers.AddEveryoneUserOfNamespace method [ISA Server 2004]

IFPCNonWindowsUsers::AddEveryoneUserOfNamespace[C++]

FPCNonWindowsUsers.AddEveryoneUserOfNamespace [Visual Basic]

[C++]

The AddEveryoneUserOfNamespace method creates a new FPCNonWindowsUser object for the user called "Everyone" in the specified namespace, adds it to the collection, and returns a reference to it.

HRESULT AddEveryoneUserOfNamespace(
  BSTR Namespace,
  IFPCNonWindowsUser** ppNonWindowsUser
);

Parameters

Namespace
[in] Required. BSTR that specifies the authentication namespace for the user "Everyone." The value supplied should not contain more than UNLEN characters. UNLEN is defined in Lmcons.h.
ppNonWindowsUser
[out] Address of an interface pointer that on return points to the new IFPCNonWindowsUser interface created.

Return Values

This method can return one of the following:

  • S_OK, indicating that the operation succeeded.
  • An error code, indicating that the operation failed. In this case, the [out] parameter returned is a null object.

Remarks

This function does not validate the length of the value supplied in the Namespace parameter. A namespace containing more than UNLEN characters should not be used.

[Visual Basic]

The AddEveryoneUserOfNamespace method creates a new FPCNonWindowsUser object for the user called "Everyone" in the specified namespace, adds it to the collection, and returns a reference to it.

Function AddEveryoneUserOfNamespace( _
  ByVal Namespace As String _
) As FPCNonWindowsUser

Parameters

Namespace
[in] Required. String that specifies the authentication namespace for the user "Everyone." The value supplied should not contain more than UNLEN characters. UNLEN is defined in Lmcons.h.

Return Values

This method returns a reference to an FPCNonWindowsUser object if successful. Otherwise, an error is raised that can be intercepted by using an error handler.

Remarks

This function does not validate the length of the value supplied in the Namespace parameter. A namespace containing more than UNLEN characters should not be used.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCNonWindowsUsers


IFPCNonWindowsUsers | FPCNonWindowsUsers Count(long) property [ISA Server 2004]

Count Property of IFPCNonWindowsUsers[C++]

FPCNonWindowsUsers.Count [Visual Basic]

[C++]

The Count property gets the number of FPCNonWindowsUser objects in the collection.

HRESULT get_Count(
  long* plCount
);

Parameters

plCount
Pointer to a variable that on return receives a 32-bit integer specifying the number of FPCNonWindowsUser objects in the collection.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The Count property gets the number of FPCNonWindowsUser objects in the collection.

Property Count As Long

Property Value

A 32-bit integer that specifies the number of FPCNonWindowsUser objects in the collection.

Remarks

This property is read-only.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCNonWindowsUsers


IFPCNonWindowsUsers | FPCNonWindowsUsers Item method [ISA Server 2004]

IFPCNonWindowsUsers::Item[C++]

FPCNonWindowsUsers.Item [Visual Basic]

[C++]

The Item method retrieves the requested IFPCNonWindowsUser interface from the collection. You can specify the interface either by its namespace and user name, or by its one-based index.

HRESULT Item(
  VARIANT IndexOrUsername,
  BSTR Namespace,
  IFPCNonWindowsUser** ppItem
);

Parameters

IndexOrUsername
[in] Required. One-based index or user name of the object to retrieve.
Namespace
[in, optional] BSTR that specifies the authentication namespace for the non-Windows user. This parameter must be specified when you provide a user name in the IndexOrUsername parameter. The default value is an empty BSTR.
ppItem
[out] Address of an interface pointer that on return points to the IFPCNonWindowsUser interface requested.

Return Values

The method can return one of the following:

  • S_OK, indicating that the operation succeeded.
  • An error code, indicating that the operation failed. In this case, the [out] parameter returned is a null object.

[Visual Basic]

The Item method retrieves the requested FPCNonWindowsUser object from the collection. You can specify the object either by its namespace and user name, or by its one-based index.

Function Item( _
  ByVal IndexOrUsername As Variant, _
  [ ByVal Namespace As String ] _
) As FPCNonWindowsUser

Parameters

IndexOrUsername
[in] Required. One-based index or user name of the object to retrieve.
Namespace
[in, optional] String that specifies the authentication namespace for the non-Windows user. This parameter must be specified when you provide a user name in the IndexOrUsername parameter. The default value is an empty string.

Return Values

This method returns a reference to the FPCNonWindowsUser object requested if successful. Otherwise, an error is raised that can be intercepted by using an error handler.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCNonWindowsUsers


IFPCNonWindowsUsers | FPCNonWindowsUsers Refresh method [ISA Server 2004]

IFPCNonWindowsUsers::Refresh[C++]

FPCNonWindowsUsers.Refresh [Visual Basic]

[C++]

The Refresh method reads the values of all the properties of the collection and its elements from persistent storage, discarding any changes that have not been saved.

HRESULT Refresh();

Parameters

This method has no parameters.

Return Values

This method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

Changes made to this collection or its elements can be saved by calling the Save method of this collection or the Save method of any object containing it.

[Visual Basic]

The Refresh method reads the values of all the properties of the collection and its elements from persistent storage, discarding any changes that have not been saved.

Sub Refresh()

Parameters

This method has no parameters.

Return Values

This method has no return values. If the call is unsuccessful, an error is raised that can be intercepted by using an error handler.

Remarks

Changes made to this collection or its elements can be saved by calling the Save method of this collection or the Save method of any object containing it.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCNonWindowsUsers


IFPCNonWindowsUsers | FPCNonWindowsUsers Remove method [ISA Server 2004]

IFPCNonWindowsUsers::Remove[C++]

FPCNonWindowsUsers.Remove [Visual Basic]

[C++]

The Remove method removes the specified FPCNonWindowsUser object from the collection. You can specify the object either by its namespace and user name, or by its one-based index.

HRESULT Remove(
  VARIANT IndexOrUsername,
  BSTR Namespace
);

Parameters

IndexOrUsername
[in] Required. One-based index or user name of the object to retrieve.
Namespace
[in, optional] BSTR that specifies the authentication namespace for the non-Windows user. This parameter must be specified when you provide a user name in the IndexOrUsername parameter. The default value is an empty BSTR.

Return Values

This method returns S_OK if the call is successful; otherwise, it returns an error code.
[Visual Basic]

The Remove method removes the specified FPCNonWindowsUser object from the collection. You can specify the object either by its namespace and user name, or by its one-based index.

Sub Remove( _
  ByVal IndexOrUsername As Variant, _
  [ ByVal Namespace As String ] _
)

Parameters

IndexOrUsername
[in] Required. One-based index or user name of the object to retrieve.
Namespace
[in, optional] String that specifies the authentication namespace for the non-Windows user. This parameter must be specified when you provide a user name in the IndexOrUsername parameter. The default value is an empty string.

Return Values

This method has no return values. If the call is unsuccessful, an error is raised that can be intercepted by using an error handler.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCNonWindowsUsers


IFPCNonWindowsUsers | FPCNonWindowsUsers RemoveAll method [ISA Server 2004]

IFPCNonWindowsUsers::RemoveAll[C++]

FPCNonWindowsUsers.RemoveAll [Visual Basic]

[C++]

The RemoveAll method removes all of the FPCNonWindowsUser objects from the collection.

HRESULT RemoveAll();

Parameters

This method has no parameters.

Return Values

This method returns S_OK if the call is successful; otherwise, it returns an error code.
[Visual Basic]

The RemoveAll method removes all of the FPCNonWindowsUser objects from the collection.

Sub RemoveAll()

Parameters

This method has no parameters.

Return Values

This method has no return values. If the call is unsuccessful, an error is raised that can be intercepted by using an error handler.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCNonWindowsUsers


IFPCNonWindowsUsers.RemoveEveryoneUserOfNamespace method [ISA Server 2004]

IFPCNonWindowsUsers::RemoveEveryoneUserOfNamespace[C++]

FPCNonWindowsUsers.RemoveEveryoneUserOfNamespace [Visual Basic]

[C++]

The RemoveEveryoneUserOfNamespace method removes the FPCNonWindowsUser object for the user called "Everyone" in the specified namespace from the collection.

HRESULT RemoveEveryoneUserOfNamespace(
  BSTR Namespace
);

Parameters

Namespace
[in] BSTR that specifies the authentication namespace for the user called "Everyone."

Return Values

This method returns S_OK if the call is successful; otherwise, it returns an error code.
[Visual Basic]

The RemoveEveryoneUserOfNamespace method removes the FPCNonWindowsUser object for the user called "Everyone" in the specified namespace from the collection.

Sub RemoveEveryoneUserOfNamespace( _
  ByVal Namespace As String _
)

Parameters

Namespace
[in] String that specifies the authentication namespace for the user called "Everyone."

Return Values

This method has no return values. If the call is unsuccessful, an error is raised that can be intercepted by using an error handler.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCNonWindowsUsers


IFPCNonWindowsUsers | FPCNonWindowsUsers Save method [ISA Server 2004]

IFPCNonWindowsUsers::Save[C++]

FPCNonWindowsUsers.Save [Visual Basic]

[C++]

The Save method saves the current values of all the properties of the collection and its elements to persistent storage. It is important to remember that any changes made by scripts and programs are not saved until after the Save method is called.

HRESULT Save(
  VARIANT_BOOL fResetRequiredServices,
  VARIANT_BOOL fReloadConfiguration
);

Parameters

fResetRequiredServices
[in, optional] Boolean value that indicates whether to restart the services that need to be restarted for any of the changes saved to take effect. The default value is VARIANT_FALSE.
fReloadConfiguration
[in, optional] Boolean value that indicates whether the call will include synchronous reloading of all changes that can be applied dynamically without restarting services. The default value is VARIANT_TRUE.

Return Values

This method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

Configuration changes are applied only after the new settings are written to persistent storage and reloaded to the services that use them. Most changes can be applied dynamically without restarting any services. However, some changes can take effect only after the Microsoft Firewall service is restarted. For more information, see Restarting Services after Configuration Changes.

ISA Server maintains a bitmask that specifies which services need to be started for currently unsaved changes to take effect. This bitmask can be retrieved by calling the GetServiceRestartMask method on an object that contains this object as a subobject. Calling the Save method clears all of the bits in this bitmask even if the fResetRequiredServices parameter is set to VARIANT_FALSE.

If the fReloadConfiguration parameter is set to VARIANT_FALSE the current values of the properties of the collection and its elements will be written to persistent storage without updating the configuration being used by the ISA Server services. The configuration used by each service will not be updated until the service is restarted or the new settings are reloaded by another call to Save.

[Visual Basic]

The Save method saves the current values of all the properties of the collection and its elements to persistent storage. It is important to remember that any changes made by scripts and programs are not saved until after the Save method is called.

Sub Save( _
  [ ByVal fResetRequiredServices As Boolean ], _
  [ ByVal fReloadConfiguration As Boolean ] _
)

Parameters

fResetRequiredServices
[in, optional] Boolean value that indicates whether to restart the services that need to be restarted for any of the changes saved to take effect. The default value is False.
fReloadConfiguration
[in, optional] Boolean value that indicates whether the call will include synchronous reloading of all the saved configuration changes that can be applied dynamically without restarting services. The default value is True.

Return Values

This method has no return values. If the call is unsuccessful, an error is raised that can be intercepted by using an error handler.

Remarks

Configuration changes are applied only after the new settings are written to persistent storage and reloaded to the services that use them. Most changes can be applied dynamically without restarting any services. However, some changes can take effect only after the Microsoft Firewall service is restarted. For more information, see Restarting Services after Configuration Changes.

ISA Server maintains a bitmask that specifies which services need to be started for currently unsaved changes to take effect. This bitmask can be retrieved by calling the GetServiceRestartMask method on an object that contains this object as a subobject. Calling the Save method clears all of the bits in this bitmask even if the fResetRequiredServices parameter is set to False.

If the fReloadConfiguration parameter is set to False the current values of the properties of the collection and its elements will be written to persistent storage without updating the configuration being used by the ISA Server services. The configuration used by each service will not be updated until the service is restarted or the new settings are reloaded by another call to Save.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCNonWindowsUsers


FPCPathMapping object [ISA Server 2004]

FPCPathMapping

The FPCPathMapping object represents a mapping of an external path to an internal path on a server published by a Web publishing rule. The external path is the public path used by users in their incoming requests, and the internal path is the private path to the published directory on the Web server.

Path mappings are used in Web publishing rules. Before forwarding a request to the published Web server, ISA Server checks the (external) path specified in the request. If a path mapping is found for the path specified in the request, ISA Server replaces the path specified in the request by the corresponding internal path. Note that the external path in each path mapping must be distinct and unique. For more information, see FPCWebPublishingProperties.

This object is typically an element of an FPCPathMappings collection.

Click here to see the ISA Server object hierarchy.

Methods

The FPCPathMapping object defines the following methods.

Method | Description
Refresh | Reads the object's configuration information from persistent storage, discarding any changes to the configuration that were not saved.
Save | Writes the current values of all of the object's properties to persistent storage.

Properties

The FPCPathMapping object has the following properties.

Property | Description
ExternalPath | Gets the external path for the mapping.
InternalPath | Gets the internal path for the mapping.
SameAsInternalPath | Gets a Boolean value that indicates whether the external path is the same as the internal path.

Remarks

This object implements the IFPCPathMapping interface.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

COM Objects


IFPCPathMapping | FPCPathMapping ExternalPath(BSTR) property [ISA Server 2004]

ExternalPath Property of IFPCPathMapping[C++]

FPCPathMapping.ExternalPath [Visual Basic]

[C++]

The ExternalPath property gets the external path for the mapping. The external path is the public path used by a user when requesting the website. This property is ignored if the SameAsInternalPath property is set to VARIANT_TRUE.

HRESULT get_ExternalPath(
  BSTR** pbstrExternalPath
);

Parameters

pbstrExternalPath
Pointer to a BSTR that is set on return to a string value specifying the internal path to the published subdirectory on the Web server.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only. It is set when the object is created using the IFPCPathMappings::Add method.

[Visual Basic]

The ExternalPath property gets the external path for the mapping. The external path is the public path used by a user when requesting the website. This property is ignored if the SameAsInternalPath property is set to True.

Property ExternalPath As String

Property Value

String value that specifies the external path.

Remarks

This property is read-only. It is set when the object is created using the FPCPathMappings.Add method.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCPathMapping


IFPCPathMapping | FPCPathMapping InternalPath(BSTR) property [ISA Server 2004]

InternalPath Property of IFPCPathMapping[C++]

FPCPathMapping.InternalPath [Visual Basic]

[C++]

The InternalPath property gets the internal path for the mapping. The internal path is the private path to the published subdirectory on the Web server.

HRESULT get_InternalPath(
  BSTR* pbstrInternalPath
);

Parameters

pbstrInternalPath
Pointer to a BSTR that is set on return to a string value specifying the internal path for the mapping.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only. It is set when the object is created using the IFPCPathMappings::Add method.

[Visual Basic]

The InternalPath property gets the internal path for the mapping. The internal path is the private path to the published subdirectory on the Web server.

Property InternalPath As String

Property Value

String that specifies the internal path for the mapping.

Remarks

This property is read-only. It is set when the object is created using the FPCPathMappings.Add method.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCPathMapping


IFPCPathMapping | FPCPathMapping Refresh method [ISA Server 2004]

IFPCPathMapping::Refresh[C++]

FPCPathMapping.Refresh [Visual Basic]

[C++]

The Refresh method reads the values of all of the object's properties from persistent storage, discarding any changes that have not been saved.

HRESULT Refresh();

Parameters

This method has no parameters.

Return Values

This method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

Changes made to this object can be saved by calling the Save method of this object or the Save method of any object containing it.

[Visual Basic]

The Refresh method reads the values of all of the object's properties from persistent storage, discarding any changes that have not been saved.

Sub Refresh()

Parameters

This method has no parameters.

Return Values

This method has no return values. If the call is unsuccessful, an error is raised that can be intercepted by using an error handler.

Remarks

Changes made to this object can be saved by calling the Save method of this object or the Save method of any object containing it.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCPathMapping


IFPCPathMapping | FPCPathMapping SameAsInternalPath property [ISA Server 2004]

SameAsInternalPath Property of IFPCPathMapping[C++]

FPCPathMapping.SameAsInternalPath [Visual Basic]

[C++]

The SameAsInternalPath property gets a Boolean value that indicates whether the external path is the same as the internal path. The external path is the public path used by users when sending incoming requests, and the internal path is the private path to the published subdirectory on the Web server.

HRESULT get_SameAsInternalPath(
  VARIANT_BOOL* pfSameAsInternalPath
);

Parameters

pfSameAsInternalPath
Pointer to a Boolean variable that is set on return to VARIANT_TRUE if the external path is the same as the internal path, or to VARIANT_FALSE if the external path differs from the internal path.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only. It can be set by calling the FPCPathMappings.Add method

When this property is set to VARIANT_TRUE, the ExternalPath property is ignored.

[Visual Basic]

The SameAsInternalPath property gets a Boolean value that indicates whether the external path is the same as the internal path. The external path is the public path used by users when sending incoming requests, and the internal path is the private path to the published subdirectory on the Web server.

Property SameAsInternalPath As Boolean

Property Value

Boolean value that indicates whether the external path is the same as the internal path.

Remarks

This property is read-only. It can be set by calling the FPCPathMappings.Add method

When this property is set to True, the ExternalPath property is ignored.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCPathMapping


IFPCPathMapping | FPCPathMapping Save (2 Parameters) method [ISA Server 2004]

IFPCPathMapping::Save[C++]

FPCPathMapping.Save [Visual Basic]

[C++]

The Save method writes the current values of all of the object's properties to persistent storage. It is important to remember that any changes made by scripts and programs will not be saved until after the Save method is called.

HRESULT Save(
  VARIANT_BOOL fResetRequiredServices,
  VARIANT_BOOL fReloadConfiguration
);

Parameters

fResetRequiredServices
[in, optional] Boolean value that indicates whether to restart the services that need to be restarted for any of the changes saved to take effect. The default value is VARIANT_FALSE.
fReloadConfiguration
[in, optional] Boolean value that indicates whether the call will include synchronous reloading of all changes that can be applied dynamically without restarting services. The default value is VARIANT_TRUE.

Return Values

This method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

Configuration changes are applied only after the new settings are written to persistent storage and reloaded to the services that use them. Most changes can be applied dynamically without restarting any services. However, some changes can take effect only after the Microsoft Firewall service is restarted. For more information, see Restarting Services after Configuration Changes.

ISA Server maintains a bitmask that specifies which services need to be started for currently unsaved changes to take effect. This bitmask can be retrieved by calling the GetServiceRestartMask method on an object that contains this object as a subobject. Calling the Save method clears all of the bits in this bitmask even if the fResetRequiredServices parameter is set to VARIANT_FALSE.

If the fReloadConfiguration parameter is set to VARIANT_FALSE the current values of the object's properties will be written to persistent storage without updating the configuration being used by the ISA Server services. The configuration used by each service will not be updated until the service is restarted or the new settings are reloaded by another call to Save.

[Visual Basic]

The Save method writes the current values of all of the object's properties to persistent storage. It is important to remember that any changes made by scripts and programs will not be saved until after the Save method is called.

Sub Save( _
  [ ByVal fResetRequiredServices As Boolean ], _
  [ ByVal fReloadConfiguration As Boolean ] _
)

Parameters

fResetRequiredServices
[in, optional] Boolean value that indicates whether to restart the services that need to be restarted for any of the changes saved to take effect. The default value is False.
fReloadConfiguration
[in, optional] Boolean value that indicates whether the call will include synchronous reloading of all the saved configuration changes that can be applied dynamically without restarting services. The default value is True.

Return Values

This method has no return values. If the call is unsuccessful, an error is raised that can be intercepted by using an error handler.

Remarks

Configuration changes are applied only after the new settings are written to persistent storage and reloaded to the services that use them. Most changes can be applied dynamically without restarting any services. However, some changes can take effect only after the Microsoft Firewall service is restarted. For more information, see Restarting Services after Configuration Changes.

ISA Server maintains a bitmask that specifies which services need to be started for currently unsaved changes to take effect. This bitmask can be retrieved by calling the GetServiceRestartMask method on an object that contains this object as a subobject. Calling the Save method clears all of the bits in this bitmask even if the fResetRequiredServices parameter is set to False.

If the fReloadConfiguration parameter is set to False the current values of the object's properties will be written to persistent storage without updating the configuration being used by the ISA Server services. The configuration used by each service will not be updated until the service is restarted or the new settings are reloaded by another call to Save.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCPathMapping


FPCPathMappings collection [ISA Server 2004]

FPCPathMappings Collection

The FPCPathMappings collection provides access to a group of FPCPathMapping objects. An FPCPathMapping object represents a mapping of an external path to an internal path on a server published by a Web publishing rule. The external path is the public path used by users in their incoming requests, and the internal path is the private path to the published directory on the Web server.

Path mappings are used in Web publishing rules. Before forwarding a request to the published Web server, ISA Server checks the (external) path specified in the request. If a path mapping is found for the path specified in the request, ISA Server replaces the path specified in the request by the corresponding internal path.

This collection is typically accessed through the PathMappings property of the FPCWebPublishingProperties object.

Click here to see the ISA Server object hierarchy.

Methods

The FPCPathMappings collection defines the following methods.

Method | Description
Add | Creates a new FPCPathMapping object in the collection and returns a reference to it.
Item | Retrieves the requested FPCPathMapping object from the collection.
Refresh | Reads all the properties of the collection and its elements from persistent storage, discarding any changes that have not been saved.
Remove | Removes the specified FPCPathMapping object from the collection.
Save | Writes the current values of all the properties of the collection and its elements to persistent storage.

Properties

The FPCPathMappings collection has the following properties.

Property | Description
_NewEnum | Gets an enumerator object for the collection.
Count | Gets the number of objects in the collection.

Remarks

This collection implements the IFPCPathMappings interface.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

COM Objects


IFPCPathMappings | FPCPathMappings _NewEnum(IUnknown) property [ISA Server 2004]

_NewEnum Property of IFPCPathMappings[C++]

FPCPathMappings._NewEnum [Visual Basic]

[C++]

The _NewEnum property gets an enumerator object for the collection. An enumerator object provides serial access to the elements of the collection.

HRESULT get__NewEnum(
  IUnknown* ppEnum
);

Parameters

ppEnum
Address of an interface pointer that on return points to the IUnknown interface of an enumerator object that implements an IEnumVARIANT interface for the collection. An interface pointer to the IEnumVARIANT interface of the enumerator object can be retrieved by calling QueryInterface on the IUnknown interface returned.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The _NewEnum property gets an enumerator object for the collection. An enumerator object provides serial access to the elements of the collection.

Property _NewEnum As IUnknown

Property Value

Reference to an enumerator object that provides serial access to the elements of the collection.

Remarks

This property is read-only.

In Visual Basic and VBScript, this property is used implicitly in For Each...In...Next constructs.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCPathMappings


IFPCPathMappings | FPCPathMappings Add (4 Parameters) method [ISA Server 2004]

IFPCPathMappings::Add[C++]

FPCPathMappings.Add [Visual Basic]

[C++]

The Add method creates a new FPCPathMapping object in the collection and returns a reference to it.

HRESULT Add(
  BSTR InternalPath,
  VARIANT_BOOL SameAsInternal,
  BSTR ExternalPath,
  IFPCPathMapping** ppNewItem
);

Parameters

InternalPath
[in] BSTR that specifies the internal path.
SameAsInternal
[in] Boolean value that specifies whether the external path is the same as the internal path.
ExternalPath
[in] BSTR that specifies the external path. This parameter is ignored if the SameAsInternal parameter is set to VARIANT_TRUE.
ppNewItem
[out] Address of an interface pointer that on return points to the new IFPCPathMapping interface created.

Return Values

This method can return one of the following:

  • S_OK, indicating that the operation succeeded.
  • An error code, indicating that the operation failed. In this case, the [out] parameter returned is a null object.

[Visual Basic]

The Add method creates a new FPCPathMapping object in the collection and returns a reference to it.

Function Add( _
  ByVal InternalPath As String, _
  ByVal SameAsInternal As Boolean, _
  ByVal ExternalPath As String _
) As FPCPathMapping

Parameters

InternalPath
[in] String that specifies the internal path.
SameAsInternal
[in] Boolean value that specifies whether the external path is the same as the internal path.
ExternalPath
[in] String that specifies the external path. This parameter is ignored if the SameAsInternal parameter is set to True.

Return Values

This method returns a reference to the new FPCPathMapping object if successful. Otherwise, an error is raised that can be intercepted by using an error handler.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCPathMappings


IFPCPathMappings | FPCPathMappings Count(long) property [ISA Server 2004]

Count Property of IFPCPathMappings[C++]

FPCPathMappings.Count [Visual Basic]

[C++]

The Count property gets the number of FPCPathMapping objects in the collection.

HRESULT get_Count(
  long* plCount
);

Parameters

plCount
Pointer to a variable that on return receives a 32-bit integer specifying the number of FPCPathMapping objects in the collection.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The Count property gets the number of FPCPathMapping objects in the collection.

Property Count As Long

Property Value

A 32-bit integer that specifies the number of FPCPathMapping objects in the collection.

Remarks

This property is read-only.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCPathMappings


IFPCPathMappings | FPCPathMappings Item (2 Parameters) method [ISA Server 2004]

IFPCPathMappings::Item[C++]

FPCPathMappings.Item [Visual Basic]

[C++]

The Item method retrieves the requested IFPCPathMapping interface from the collection.

HRESULT Item(
  VARIANT Index,
  IFPCPathMapping** ppItem
);

Parameters

Index
[in] Required. Name or one-based index of the object to retrieve.
ppItem
[out] Address of a variable that receives a pointer to the IFPCPathMapping interface requested.

Return Values

This method can return one of the following:

  • S_OK, indicating that the operation succeeded.
  • An error code, indicating that the operation failed. In this case, the [out] parameter returned is a null object.

[Visual Basic]

The Item method retrieves the requested FPCPathMapping object from the collection.

Function Item( _
  ByVal Index As Variant _
) As FPCPathMapping

Parameters

Index
[in] Required. Name or one-based index of the object to retrieve.

Return Values

This method returns a reference to the FPCPathMapping object requested if successful. Otherwise, an error is raised that can be intercepted by using an error handler.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCPathMappings


IFPCPathMappings | FPCPathMappings Refresh method [ISA Server 2004]

IFPCPathMappings::Refresh[C++]

FPCPathMappings.Refresh [Visual Basic]

[C++]

The Refresh method reads the values of all the properties of the collection and its elements from persistent storage, discarding any changes that have not been saved.

HRESULT Refresh();

Parameters

This method has no parameters.

Return Values

This method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

Changes made to this collection or its elements can be saved by calling the Save method of this collection or the Save method of any object containing it.

[Visual Basic]

The Refresh method reads the values of all the properties of the collection and its elements from persistent storage, discarding any changes that have not been saved.

Sub Refresh()

Parameters

This method has no parameters.

Return Values

This method has no return values. If the call is unsuccessful, an error is raised that can be intercepted by using an error handler.

Remarks

Changes made to this collection or its elements can be saved by calling the Save method of this collection or the Save method of any object containing it.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCPathMappings


IFPCPathMappings | FPCPathMappings Remove(Variant) method [ISA Server 2004]

IFPCPathMappings::Remove[C++]

FPCPathMappings.Remove [Visual Basic]

[C++]

The Remove method removes the specified FPCPathMapping object from the collection.

HRESULT Remove(
  VARIANT Index
);

Parameters

Index
[in] Required. Name or one-based index of the FPCPathMapping object to remove.

Return Values

This method returns S_OK if the call is successful; otherwise, it returns an error code.
[Visual Basic]

The Remove method removes the specified FPCPathMapping object from the collection.

Sub Remove( _
  ByVal Index As Variant _
)

Parameters

Index
[in] Required. Name or one-based index of the FPCPathMapping object to remove.

Return Values

This method has no return values. If the call is unsuccessful, an error is raised that can be intercepted by using an error handler.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCPathMappings


IFPCPathMappings | FPCPathMappings Save (2 Parameters) method [ISA Server 2004]

IFPCPathMappings::Save[C++]

FPCPathMappings.Save [Visual Basic]

[C++]

The Save method writes the current values of all the properties of the collection and its elements to persistent storage. It is important to remember that any changes made by scripts and programs are not saved until after the Save method is called.

HRESULT Save(
  VARIANT_BOOL fResetRequiredServices,
  VARIANT_BOOL fReloadConfiguration
);

Parameters

fResetRequiredServices
[in, optional] Boolean value that indicates whether to restart the services that need to be restarted for any of the changes saved to take effect. The default value is VARIANT_FALSE.
fReloadConfiguration
[in, optional] Boolean value that indicates whether the call will include synchronous reloading of all changes that can be applied dynamically without restarting services. The default value is VARIANT_TRUE.

Return Values

This method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

Configuration changes are applied only after the new settings are written to persistent storage and reloaded to the services that use them. Most changes can be applied dynamically without restarting any services. However, some changes can take effect only after the Microsoft Firewall service is restarted. For more information, see Restarting Services after Configuration Changes.

ISA Server maintains a bitmask that specifies which services need to be started for currently unsaved changes to take effect. This bitmask can be retrieved by calling the GetServiceRestartMask method on an object that contains this object as a subobject. Calling the Save method clears all of the bits in this bitmask even if the fResetRequiredServices parameter is set to VARIANT_FALSE.

If the fReloadConfiguration parameter is set to VARIANT_FALSE the current values of the properties of the collection and its elements will be written to persistent storage without updating the configuration being used by the ISA Server services. The configuration used by each service will not be updated until the service is restarted or the new settings are reloaded by another call to Save.

[Visual Basic]

The Save method writes the current values of all the properties of the collection and its elements to persistent storage. It is important to remember that any changes made by scripts and programs are not saved until after the Save method is called.

Sub Save( _
  [ ByVal fResetRequiredServices As Boolean ], _
  [ ByVal fReloadConfiguration As Boolean ] _
)

Parameters

fResetRequiredServices
[in, optional] Boolean value that indicates whether to restart the services that need to be restarted for any of the changes saved to take effect. The default value is False.
fReloadConfiguration
[in, optional] Boolean value that indicates whether the call will include synchronous reloading of all the saved configuration changes that can be applied dynamically without restarting services. The default value is True.

Return Values

This method has no return values. If the call is unsuccessful, an error is raised that can be intercepted by using an error handler.

Remarks

Configuration changes are applied only after the new settings are written to persistent storage and reloaded to the services that use them. Most changes can be applied dynamically without restarting any services. However, some changes can take effect only after the Microsoft Firewall service is restarted. For more information, see Restarting Services after Configuration Changes.

ISA Server maintains a bitmask that specifies which services need to be started for currently unsaved changes to take effect. This bitmask can be retrieved by calling the GetServiceRestartMask method on an object that contains this object as a subobject. Calling the Save method clears all of the bits in this bitmask even if the fResetRequiredServices parameter is set to False.

If the fReloadConfiguration parameter is set to False the current values of the properties of the collection and its elements will be written to persistent storage without updating the configuration being used by the ISA Server services. The configuration used by each service will not be updated until the service is restarted or the new settings are reloaded by another call to Save.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCPathMappings


FPCPersist object [ISA Server 2004]

FPCPersist

The FPCPersist object provides access to the methods and properties associated with objects whose data can be written to persistent storage. Objects whose data can be written to persistent storage inherit from the FPCPersist object.

Click here to see the ISA Server object hierarchy.

Methods

The FPCPersist object defines the following methods.

Method | Description
CancelWaitForChanges | Cancels the registration established by the WaitForChanges method (for use in C and C++ programming only).
CanImport | Returns a Boolean value that indicates whether the object's properties can be imported from the specified XML document.
Export | Recursively writes the stored values of all the properties of the object and its subobjects to the specified XML document. For a collection, the method also writes all of its elements and their properties to the XML document.
ExportToFile | Recursively writes the stored values of all the properties of the object and its subobjects to the specified XML file. For a collection, the method also writes all of its elements and their properties to the XML file.
GetServiceRestartMask | Retrieves a 32-bit bitmask of the FpcServices enumerated type that specifies which services need to be restarted for currently unsaved changes to take effect.
Import | Recursively copies the values of all the properties of the object and of its subobjects from the specified XML document to persistent storage. For a collection, the method also imports all of its elements and their properties from the XML document.
ImportFromFile | Recursively copies the values of all the properties of the object and of its subobjects from the specified XML file to persistent storage. For a collection, the method also imports all of its elements and their properties from the XML file.
LoadDocProperties | Gets the OptionalData and Comment properties that are stored in a specified XML document.
Refresh | Recursively reads the values of all the properties of the object and of its subobjects from persistent storage, overwriting any changes that have not been saved. For a collection, the method also reads all of its elements and their properties from persistent storage.
Save | Recursively writes all of the properties of the object and its subobjects to persistent storage. For a collection, the method also writes all of its elements and their properties to persistent storage.
WaitForChanges | Registers to wait for an event indicating that the contents of the object have changed (for use in C and C++ programming only). After the notification, you must call the Refresh method to see the changes.

Properties

The FPCPersist object has the following properties.

Property | Description
PersistentName | Gets the persistent name of the object. The persistent name of an object is a name that is unique for the object at the respective level of the COM object hierarchy.
VendorParametersSets | Gets an FPCVendorParametersSets collection that can hold custom data for extending the object.

Remarks

To export to and import from an XML document in Visual Basic, you must add a project reference to Microsoft XML v3.0 in addition to the reference to Microsoft Internet Security and Acceleration Server 2004.

In the event of an XML DOM parsing error, the information will be stored in an XMLDOMParseError object. For more information see XMLDOMParseError in the XML reference of MSDN.

This object implements the IFPCPersist interface.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

COM Objects


IFPCPersist | FPCPersist CancelWaitForChanges method [ISA Server 2004]

IFPCPersist::CancelWaitForChanges

The CancelWaitForChanges method cancels the registration established by the WaitForChanges method.

HRESULT CancelWaitForChanges();

Parameters

This method has no parameters.

Return Values

This method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This method can only be used in C and C++ programming languages. It cannot be used with DCOM.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCPersist


IFPCPersist | FPCPersist CanImport (5 Parameters) method [ISA Server 2004]

IFPCPersist::CanImport[C++]

FPCPersist.CanImport [Visual Basic]

[C++]

The CanImport method returns a Boolean value that indicates whether the object's properties can be imported from the specified XML document.

HRESULT CanImport(
  IUnknown* pDocument,
  VARIANT_BOOL bValidateSchema,
  VARIANT_BOOL* pbRetVal
);

Parameters

pDocument
[in] Pointer to the IUnknown interface on the DOMDocument object whose properties will be examined.
bValidateSchema
[in, optional] Boolean value that indicates whether the schema should be validated. The default value is VARIANT_FALSE.
pbRetVal
[out] Pointer to a Boolean variable that is set on return to VARIANT_TRUE if the object's properties can be imported from the XML document specified, or to VARIANT_FALSE if the object's properties cannot be imported.

Return Values

This method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

Any version of the XML DOM document object from Microsoft XML 2.0 and later can be used.

[Visual Basic]

The CanImport method returns a Boolean value that indicates whether the object's properties can be imported from the specified XML document.

Function CanImport( _
  ByRef pDocument As IUnknown, _
  [ ByVal bValidateSchema As Boolean ] _
) As Boolean

Parameters

pDocument
[in] Reference to the DOMDocument30 object whose properties will be examined.
bValidateSchema
[in, optional] Boolean value that indicates whether the schema should be validated. The default value is False.

Return Values

Boolean value that is set to True if the object's properties can be imported from the XML document specified, or to False if the object's properties cannot be imported.

Remarks

Any version of the XML DOM document object from Microsoft XML 2.0 and later can be used.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCPersist


IFPCPersist | FPCPersist Export (5 Parameters) method [ISA Server 2004]

IFPCPersist::Export[C++]

FPCPersist.Export [Visual Basic]

[C++]

The Export method recursively writes all of the properties of the object and its subobjects to the specified XML document. For a collection, the method also writes all of its elements and their properties to the XML document.

HRESULT Export(
  IUnknown* pDocument,
  long OptionalData,
  BSTR EncryptionPassword,
  BSTR Comment
);

Parameters

pDocument
[in] Pointer to the IUnknown interface on the DOMDocument object to which the information will be saved.
OptionalData
[in] A 32-bit integer value that specifies what optional data to include in the export. This value is a bitwise combination of values from the FpcExportImportOptionalData enumerated type.
EncryptionPassword
[in, optional] BSTR that specifies a password for encrypting the exported information. This parameter is an empty string by default.
Comment
[in, optional] BSTR that specifies a comment for the exported information. This parameter contains an empty string by default.

Return Values

This method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

Any version of the XML DOM document object from Microsoft XML 2.0 and later can be used.

For more information, see About Persistence.

[Visual Basic]

The Export method recursively writes all of the properties of the object and its subobjects to the specified XML document. For a collection, the method also writes all of its elements and their properties to the XML document.

Sub Export( _
  ByRef pDocument As IUnknown, _
  ByVal OptionalData As Long, _
  [ ByVal EncryptionPassword As String ], _
  [ ByVal Comment As String ] _
)

Parameters

pDocument
[in] Reference to the DOMDocument30 object to which the information will be saved.
OptionalData
[in] A 32-bit integer value that specifies what optional data to include in the export. This value is a bitwise combination of values from the FpcExportImportOptionalData enumerated type.
EncryptionPassword
[in, optional] String that specifies a password for encrypting the exported information. This parameter is an empty string by default.
Comment
[in, optional] String that specifies a comment for the exported information. This parameter is an empty string by default.

Return Values

This method has no return values. If the call is unsuccessful, an error is raised that can be intercepted by using an error handler.

Remarks

Any version of the XML DOM document object from Microsoft XML 2.0 and later can be used.

For more information, see About Persistence.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCPersist


IFPCPersist | FPCPersist ExportToFile (4 Parameters) method [ISA Server 2004]

IFPCPersist::ExportToFile[C++]

FPCPersist.ExportToFile [Visual Basic]

[C++]

The ExportToFile method recursively writes the all of the properties of the object and its subobjects to the specified XML file. For a collection, the method also writes all of its elements and their properties to the XML file.

HRESULT ExportToFile(
  BSTR XmlFileName,
  long OptionalData,
  BSTR EncryptionPassword,
  BSTR Comment
);

Parameters

XmlFileName
[in] BSTR that specifies the name of the XML file to which the data will be exported.
OptionalData
[in] A 32-bit integer value that specifies what optional data to include in the export. This value is a bitwise combination of values from the FpcExportImportOptionalData enumerated type.
EncryptionPassword
[in, optional] BSTR that specifies a password for encrypting the exported information. This parameter is an empty string by default.
Comment
[in, optional] BSTR that specifies a comment for the exported information. This parameter contains an empty string by default.

Return Values

This method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

For more information, see About Persistence.

[Visual Basic]

The ExportToFile method recursively writes the all of the properties of the object and its subobjects to the specified XML file. For a collection, the method also writes all of its elements and their properties to the XML file.

Sub ExportToFile( _
  ByVal XmlFileName As String, _
  ByVal OptionalData As Long, _
  [ ByVal EncryptionPassword As String ], _
  [ ByVal Comment As String ] _
)

Parameters

XmlFileName
[in] String that specifies the name of the XML file to which the data will be exported.
OptionalData
[in] A 32-bit integer value that specifies what optional data to include in the export. This value is a bitwise combination of values from the FpcExportImportOptionalData enumerated type.
EncryptionPassword
[in, optional] String that specifies a password for encrypting the exported information. This parameter is an empty string by default.
Comment
[in, optional] String that specifies a comment for the exported information. This parameter is an empty string by default.

Return Values

This method has no return values. If the call is unsuccessful, an error is raised that can be intercepted by using an error handler.

Remarks

For more information, see About Persistence.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCPersist


IFPCPersist | FPCPersist GetServiceRestartMask(long) method [ISA Server 2004]

IFPCPersist::GetServiceRestartMask[C++]

FPCPersist.GetServiceRestartMask [Visual Basic]

[C++]

The GetServiceRestartMask method retrieves a 32-bit bitmask of the FpcServices enumerated type that specifies which services need to be restarted for currently unsaved changes to take effect.

HRESULT GetServiceRestartMask(
  long* plServiceRestartMask
);

Parameters

plServiceRestartMask
[out] Pointer to a 32-bit integer that is set on return to a bitmask that specifies which services need to be restarted for currently unsaved changes to take effect.

Return Values

This method can return one of the following:

  • S_OK, indicating that the operation succeeded.
  • An error code, indicating that the operation failed.

Remarks

The bitmask retrieved specifies the services that need to be restarted to apply any unsaved changes made to the object on which the method was called or any unsaved changes made to any of its subobjects.

The values defined in the FpcServices enumeration can be used to decrypt the bitmask and determine which services need to be restarted. Bit 0 corresponds to the Microsoft Firewall service, and bit 1 corresponds to the Microsoft ISA Server Job Scheduler service.

All unsaved changes can be applied with restarting of the required services by using either of the following techniques:

  • Calling the Save method with both the fResetRequiredServices and fReloadConfiguration parameters set to VARIANT_TRUE on any object that contains the objects with configuration changes as subobjects.
  • Calling Save with fResetRequiredServices set to VARIANT_FALSE and fReloadConfiguration set to VARIANT_TRUE on any object that contains the objects with configuration changes as subobjects and then calling the IFPCArray::RestartServices method with the applicable bitmask.

[Visual Basic]

The GetServiceRestartMask method retrieves a 32-bit bitmask of the FpcServices enumerated type that specifies which services need to be restarted for currently unsaved changes to take effect.

Function GetServiceRestartMask() As Long

Parameters

This method has no parameters.

Return Values

If successful, this method returns a 32-bit bitmask that specifies which services need to be restarted for currently unsaved changes to take effect. Otherwise, an error is raised that can be intercepted by using an error handler.

Remarks

The bitmask retrieved specifies the services that need to be restarted to apply any unsaved changes made to the object on which the method was called or any unsaved changes made to any of its subobjects.

The values defined in the FpcServices enumeration can be used to decrypt the bitmask and determine which services need to be restarted. Bit 0 corresponds to the Microsoft Firewall service, and bit 1 corresponds to the Microsoft ISA Server Job Scheduler service.

  • Calling the Save method with both the fResetRequiredServices and fReloadConfiguration parameters set to True on any object that contains the objects with configuration changes as subobjects.
  • Calling Save with fResetRequiredServices set to False and fReloadConfiguration set to True on any object that contains the objects with configuration changes as subobjects and then calling the FPCArray.RestartServices method with the applicable bitmask.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCPersist


IFPCPersist | FPCPersist Import (7 Parameters) method [ISA Server 2004]

IFPCPersist::Import[C++]

FPCPersist.Import [Visual Basic]

[C++]

The Import method recursively copies the values of all the properties of the object and of its subobjects from the specified XML document to persistent storage. For a collection, the method also imports all of its elements and their properties from the XML document.

HRESULT Import(
  IUnknown* pDocument,
  long OptionalData,
  BSTR EncryptionPassword,
  VARIANT_BOOL CleanCollections,
  VARIANT_BOOL fResetRequiredServices,
  VARIANT_BOOL fReloadConfiguration
);

Parameters

pDocument
[in] Pointer to the IUnknown interface on the DOMDocument object from which the information will be imported.
OptionalData
[in] A 32-bit integer value that specifies what optional data to include in the import. This value is a bitwise combination of values from the FpcExportImportOptionalData enumerated type. The bits set should not call for the inclusion of optional data in the import that were not included in the export.
EncryptionPassword
[in, optional] BSTR that specifies a password for importing encrypted information. This parameter is an empty string by default. The password is required if the export was performed using an encryption password.
CleanCollections
[in, optional] Boolean value that indicates whether to remove existing objects that are not included in the XML document. The default value is VARIANT_FALSE. If this parameter is set to VARIANT_TRUE in a call to the Import method on any interface other than the IFPCArray interface, the call will fail.
fResetRequiredServices
[in, optional] Boolean value that indicates whether to restart the services that need to be restarted for the changes to take effect. The default value is VARIANT_FALSE.
fReloadConfiguration
[in, optional] Boolean value that indicates whether the call will return only after ISA Server has reloaded the saved configuration with the current changes from persistent storage. The default value is VARIANT_TRUE.

Return Values

This method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

Any version of the XML DOM document object from Microsoft XML 2.0 and later can be used.

ISA Server maintains a bitmask that specifies which services need to be started for the configuration changes to take effect. This bitmask can be retrieved by calling the GetServiceRestartMask method. Calling the Import method clears all of the bits in this bitmask even if the fResetRequiredServices parameter is set to VARIANT_FALSE.

If the fReloadConfiguration parameter is set to VARIANT_FALSE the current values of the object's properties will be written to persistent storage without updating the configuration being used by the ISA Server services. The configuration used by each service will not be updated until the service is restarted.

For more information, see About Persistence.

[Visual Basic]

The Import method recursively copies the values of all the properties of the object and of its subobjects from the specified XML document to persistent storage. For a collection, the method also imports all of its elements and their properties from the XML document.

Sub Import( _
  ByRef pDocument As IUnknown, _
  ByVal OptionalData As Long, _
  [ ByVal EncryptionPassword As String ], _
  [ ByVal CleanCollections As Boolean ], _
  [ ByVal fResetRequiredServices As Boolean ], _
  [ ByVal fReloadConfiguration As Boolean ] _
)

Parameters

pDocument
[in] Reference to the DOMDocument30 object from which the information will be imported.
OptionalData
[in] A 32-bit integer value that specifies what optional data to include in the import. This value is a bitwise combination of values from the FpcExportImportOptionalData enumerated type. The bits set should not call for the inclusion of optional data in the import that were not included in the export.
EncryptionPassword
[in, optional] String that specifies a password for importing encrypted information. This parameter is an empty string by default. The password is required if the export was performed using an encryption password.
CleanCollections
[in, optional] Boolean value that indicates whether to remove existing objects that are not included in the XML document. The default value is False. If this parameter is set to True in a call to the Import method on any object other than the FPCArray object, the call will fail.
fResetRequiredServices
[in, optional] Boolean value that indicates whether to restart the services that need to be restarted for the changes to take effect. The default value is False.
fReloadConfiguration
[in, optional] Boolean value that indicates whether the call will return only after ISA Server has reloaded the saved configuration with the current changes from persistent storage. The default value is True.

Return Values

This method has no return values. If the call is unsuccessful, an error is raised that can be intercepted by using an error handler.

Remarks

Any version of the XML DOM document object from Microsoft XML 2.0 and later can be used.

ISA Server maintains a bitmask that specifies which services need to be started for the configuration changes to take effect. This bitmask can be retrieved by calling the GetServiceRestartMask method. Calling the Import method clears all of the bits in this bitmask even if the fResetRequiredServices parameter is set to False.

If the fReloadConfiguration parameter is set to False the current values of the object's properties will be written to persistent storage without updating the configuration being used by the ISA Server services. The configuration used by each service will not be updated until the service is restarted.

For more information, see About Persistence.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCPersist


IFPCPersist | FPCPersist ImportFromFile (6 Parameters) method [ISA Server 2004]

IFPCPersist::ImportFromFile[C++]

FPCPersist.ImportFromFile [Visual Basic]

[C++]

The ImportFromFile method recursively copies the values of all the properties of the object and of its subobjects from the specified XML file to persistent storage. For a collection, the method also imports all of its elements and their properties from the XML file.

HRESULT ImportFromFile(
  BSTR XmlFileName,
  long OptionalData,
  BSTR EncryptionPassword,
  VARIANT_BOOL CleanCollections,
  VARIANT_BOOL fResetRequiredServices,
  VARIANT_BOOL fReloadConfiguration
);

Parameters

XmlFileName
[in] BSTR that specifies the name of the XML file from which the data will be imported.
OptionalData
[in] A 32-bit integer value that specifies what optional data to include in the import. This value is a bitwise combination of values from the FpcExportImportOptionalData enumerated type. The bits set should not call for the inclusion of optional data in the import that were not included in the export.
EncryptionPassword
[in, optional] BSTR that specifies a password for importing encrypted information. This parameter is an empty string by default. The password is required if the export was performed using an encryption password.
CleanCollections
[in, optional] Boolean value that indicates whether to remove existing objects that are not included in the XML file. The default value is VARIANT_FALSE. If this parameter is set to VARIANT_TRUE in a call to the Import method on any interface other than the IFPCArray interface, the call will fail.
fResetRequiredServices
[in, optional] Boolean value that indicates whether to restart the services that need to be restarted for the changes to take effect. The default value is VARIANT_FALSE.
fReloadConfiguration
[in, optional] Boolean value that indicates whether the call will return only after ISA Server has reloaded the saved configuration with the current changes from persistent storage. The default value is VARIANT_TRUE.

Return Values

This method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

ISA Server maintains a bitmask that specifies which services need to be started for the configuration changes to take effect. This bitmask can be retrieved by calling the GetServiceRestartMask method. Calling the ImportFromFile method clears all of the bits in this bitmask even if the fResetRequiredServices parameter is set to VARIANT_FALSE.

If the fReloadConfiguration parameter is set to VARIANT_FALSE the current values of the object's properties will be written to persistent storage without updating the configuration being used by the ISA Server services. The configuration used by each service will not be updated until the service is restarted.

For more information, see About Persistence.

[Visual Basic]

The ImportFromFile method recursively copies the values of all the properties of the object and of its subobjects from the specified XML file to persistent storage. For a collection, the method also imports all of its elements and their properties from the XML file.

Sub ImportFromFile( _
  ByVal XmlFileName As String, _
  ByVal OptionalData As Long, _
  [ ByVal EncryptionPassword As String ], _
  [ ByVal CleanCollections As Boolean ], _
  [ ByVal fResetRequiredServices As Boolean ], _
  [ ByVal fReloadConfiguration As Boolean ] _
)

Parameters

XmlFileName
[in] String that specifies the name of the XML file from which the data will be imported.
OptionalData
[in] A 32-bit integer value that specifies what optional data to include in the import. This value is a bitwise combination of values from the FpcExportImportOptionalData enumerated type. The bits set should not call for the inclusion of optional data in the import that were not included in the export.
EncryptionPassword
[in, optional] String that specifies a password for importing encrypted information. This parameter is an empty string by default. The password is required if the export was performed using an encryption password.
CleanCollections
[in, optional] Boolean value that indicates whether to remove existing objects that are not included in the XML file. The default value is False. If this parameter is set to True in a call to the Import method on any object other than the FPCArray object, the call will fail.
fResetRequiredServices
[in, optional] Boolean value that indicates whether to restart the services that need to be restarted for the changes to take effect. The default value is False.
fReloadConfiguration
[in, optional] Boolean value that indicates whether the call will return only after ISA Server has reloaded the saved configuration with the current changes from persistent storage. The default value is True.

Return Values

This method has no return values. If the call is unsuccessful, an error is raised that can be intercepted by using an error handler.

Remarks

ISA Server maintains a bitmask that specifies which services need to be started for the configuration changes to take effect. This bitmask can be retrieved by calling the GetServiceRestartMask method. Calling the ImportFromFile method clears all of the bits in this bitmask even if the fResetRequiredServices parameter is set to False.

If the fReloadConfiguration parameter is set to False the current values of the object's properties will be written to persistent storage without updating the configuration being used by the ISA Server services. The configuration used by each service will not be updated until the service is restarted.

For more information, see About Persistence.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCPersist


IFPCPersist | FPCPersist LoadDocProperties method [ISA Server 2004]

IFPCPersist::LoadDocProperties[C++]

FPCPersist.LoadDocProperties [Visual Basic]

[C++]

The LoadDocProperties method retrieves the XML document's Comment and OptionalData properties so that you can know what information can be imported from the document.

HRESULT LoadDocProperties(
  IUnknown* pDocument,
  BSTR* ItemType,
  long* OptionalData,
  BSTR* Comment
);

Parameters

pDocument
[in] Pointer to the IUnknown interface on the DOMDocument object from which the document properties will be obtained.
ItemType
[out, optional] Pointer to a BSTR that on return contains a description of the type of item that is stored in the XML document.
OptionalData
[out, optional] Pointer to a 32-bit integer that is set on return to a long value specifying what optional data is included in the XML document. This value is a bitwise combination of values from the FpcExportImportOptionalData enumerated type.
Comment
[out, optional] Pointer to a BSTR that on return contains the comment from the XML document. The comment was specifed in the call to the Export method that created the XML document.

Return Values

This method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

Any version of the XML DOM document object from Microsoft XML 2.0 and later can be used.

[Visual Basic]

The LoadDocProperties method retrieves the XML document's Comment and OptionalData properties so that you can know what information can be imported from the document.

Sub LoadDocProperties( _
  ByRef pDocument As IUnknown, _
  [ ByRef ItemType As String ], _
  [ ByRef OptionalData As Long ], _
  [ ByRef Comment As String ] _
)

Parameters

pDocument
[in] Reference to the DOMDocument30 object from which the document properties will be obtained.
ItemType
[out, optional] String value that describes what type of item is stored in the XML document.
OptionalData
[out, optional] A 32-bit integer that specifies what optional data is included in the XML document. This value is a bitwise combination of values from the FpcExportImportOptionalData enumerated type.
Comment
[out, optional] String value that provides the comment from the XML document. The comment was specified in the call to the Export method that created the XML document.

Return Values

This method has no return values. If the call is unsuccessful, an error is raised that can be intercepted by using an error handler.

Remarks

Any version of the XML DOM document object from Microsoft XML 2.0 and later can be used.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCPersist


IFPCPersist | FPCPersist PersistentName(BSTR) property [ISA Server 2004]

PersistentName Property of IFPCPersist[C++]

FPCPersist.PersistentName [Visual Basic]

[C++]

The PersistentName property gets the persistent name of the object. The persistent name of an object is a name that is unique for the object at the respective level of the COM object hierarchy. For predefined objects, the persistent name is a globally unique identifier (GUID) that does not vary in different localized versions of ISA Server.

HRESULT get_PersistentName(
  BSTR* pbstrPersistentName
);

Parameters

pbstrPersistentName
Pointer to a BSTR that is set on return to a string value specifying the persistent name of the object.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

The persistent names of all of the predefined objects that are installed with ISA Server are listed in FpcObjectsGuids.h.

[Visual Basic]

The PersistentName property gets the persistent name of the object. The persistent name of an object is a name that is unique for the object at the respective level of the COM object hierarchy. For predefined objects, the persistent name is a globally unique identifier (GUID) that does not vary in different localized versions of ISA Server.

Property PersistentName As String

Property Value

String that specifies the persistent name of the object.

Remarks

This property is read-only.

The persistent names of all of the predefined objects that are installed with ISA Server are listed in FpcObjectsGuids.vbs and FpcObjectsGuids.js.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCPersist


IFPCPersist | FPCPersist Refresh method [ISA Server 2004]

IFPCPersist::Refresh[C++]

FPCPersist.Refresh [Visual Basic]

[C++]

The Refresh method recursively reads the values of all the properties of the object and of its subobjects from persistent storage, overwriting any changes that have not been saved. For a collection, the method also reads all of its elements and their properties from persistent storage.

HRESULT Refresh();

Parameters

This method has no parameters.

Return Values

This method returns S_OK if the call is successful; otherwise, it returns an error code.
[Visual Basic]

The Refresh method recursively reads the values of all the properties of the object and of its subobjects from persistent storage, overwriting any changes that have not been saved. For a collection, the method also reads all of its elements and their properties from persistent storage.

Sub Refresh()

Parameters

This method has no parameters.

Return Values

This method has no return values. If the call is unsuccessful, an error is raised that can be intercepted by using an error handler.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCPersist


IFPCPersist | FPCPersist Save (2 Parameters) method [ISA Server 2004]

IFPCPersist::Save[C++]

FPCPersist.Save [Visual Basic]

[C++]

The Save method recursively writes all of the properties of the object and its subobjects to persistent storage. For a collection, the method also writes all of its elements and their properties to persistent storage. It is important to remember that any changes made by scripts and programs are not saved until after the Save method is called.

HRESULT Save(
  VARIANT_BOOL fResetRequiredServices,
  VARIANT_BOOL fReloadConfiguration
);

Parameters

fResetRequiredServices
[in, optional] Boolean value that indicates whether to restart the services that need to be restarted for any of the changes saved to take effect. The default value is VARIANT_FALSE.
fReloadConfiguration
[in, optional] Boolean value that indicates whether the call will include synchronous reloading of all changes that can be applied dynamically without restarting services. The default value is VARIANT_TRUE.

Return Values

This method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

Configuration changes are applied only when the new values are reloaded to the services that use them. Most changes can be applied dynamically without restarting any services. However, changes to the properties in the following table and configuration changes caused by calls to the methods in this table can take effect only after the Microsoft Firewall service is restarted:

Object | Property or method
FPCApplicationFilter | Enabled
FPCAttackDetection | IpRoutingEnabled
FPCCacheConfiguration | MemoryUsagePercentage
FPCCacheDrive | CacheLimitInMegs
FPCLowLevelSettings | All properties
FPCTunnelPortRange | TunnelLowPort TunnelHighPort
FPCTunnelPortRanges | AddRange Remove
FPCWebProxy | All properties

ISA Server maintains a bitmask that specifies which services need to be started for any of the currently unsaved changes to take effect. The bitmask for the current object and its subobject can be retrieved by calling the GetServiceRestartMask method. Calling the Save method clears all of the bits in this bitmask even if the fResetRequiredServices parameter is set to VARIANT_FALSE.

If the fReloadConfiguration parameter is set to VARIANT_FALSE the current values of the object's properties will be written to persistent storage without updating the configuration being used by the ISA Server services. The configuration used by each service will not be updated until the service is restartedor the new settings are reloaded by another call to Save.

[Visual Basic]

The Save method recursively writes all of the properties of the object and its subobjects to persistent storage. For a collection, the method also writes all of its elements and their properties to persistent storage. It is important to remember that any changes made by scripts and programs are not saved until after the Save method is called.

Sub Save( _
  [ ByVal fResetRequiredServices As Boolean ], _
  [ ByVal fReloadConfiguration As Boolean ] _
)

Parameters

fResetRequiredServices
[in, optional] Boolean value that indicates whether to restart the services that need to be restarted for any of the changes saved to take effect. The default value is False.
fReloadConfiguration
[in, optional] Boolean value that indicates whether the call will include synchronous reloading of all the saved configuration changes that can be applied dynamically without restarting services. The default value is True.

Return Values

This method has no return values. If the call is unsuccessful, an error is raised that can be intercepted by using an error handler.

Remarks

Configuration changes are applied only when the new values are reloaded to the services that use them. Most changes can be applied dynamically without restarting any services. However, changes to the properties in the following table and configuration changes caused by calls to the methods in this table can take effect only after the Microsoft Firewall service is restarted:

Object | Property or method
FPCApplicationFilter | Enabled
FPCAttackDetection | IpRoutingEnabled
FPCCacheConfiguration | MemoryUsagePercentage
FPCCacheDrive | CacheLimitInMegs
FPCLowLevelSettings | All properties
FPCTunnelPortRange | TunnelLowPort TunnelHighPort
FPCTunnelPortRanges | AddRange Remove
FPCWebProxy | All properties

ISA Server maintains a bitmask that specifies which services need to be started for any of the currently unsaved changes to take effect. The bitmask for the current object and its subobject can be retrieved by calling the GetServiceRestartMask method. Calling the Save method clears all of the bits in this bitmask even if the fResetRequiredServices parameter is set to False.

If the fReloadConfiguration parameter is set to False the current values of the object's properties will be written to persistent storage without updating the configuration being used by the ISA Server services. The configuration used by each service will not be updated until the service is restarted or the new settings are reloaded by another call to Save.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCPersist


IFPCPersist | FPCPersist VendorParametersSets property [ISA Server 2004]

VendorParametersSets Property of IFPCPersist[C++]

FPCPersist.VendorParametersSets [Visual Basic]

[C++]

The VendorParametersSets property gets an FPCVendorParametersSets collection that can hold custom data for extending the object.

HRESULT get_VendorParametersSets(
  IFPCVendorParametersSets** ppVendorParametersSets
);

Parameters

ppVendorParametersSets
Address of an interface pointer that on return points to an IFPCVendorParametersSets interface that represents the collection of custom data.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only. It can be modified by modifying the IFPCVendorParametersSets interface retrieved.

[Visual Basic]

The VendorParametersSets property gets an FPCVendorParametersSets collection that can hold custom data for extending the object.

Property VendorParametersSets As FPCVendorParametersSets

Property Value

Reference to an FPCVendorParametersSets collection that can hold custom data for extending the object.

Remarks

This property is read-only. It can be modified by modifying the FPCVendorParametersSets collection retrieved.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCPersist


IFPCPersist | FPCPersist WaitForChanges(DWORD) method [ISA Server 2004]

IFPCPersist::WaitForChanges

The WaitForChanges method registers to wait for an event indicating that the contents of the object have changed.

HRESULT WaitForChanges(
  DWORD hEvent
);

Parameters

hEvent
[in] An event that will be signaled whenever the contents of the object change.

Return Values

This method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This method can only be used in C and C++ programming languages. It cannot be used with DCOM.

After notification of the event, call the Refresh method to see the changes.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCPersist


FPCPersistSink object [ISA Server 2004]

FPCPersistSink

The FPCPersistSink object provides a callback function that can be implemented to handle progress events raised during export and import operations.

Methods

The FPCPersistSink object defines the following method.

Method | Description
Progress | Handles progress events that are raised during an export or import operation.

Remarks

This object implements the IFPCPersistSink interface.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

COM Objects


IFPCPersistSink | FPCPersistSink Progress(long) method [ISA Server 2004]

IFPCPersistSink::Progress[C++]

FPCPersistSink.Progress [Visual Basic]

[C++]

The Progress method handles progress events that are raised during an export or import operation. The progress is passed as the current percentage of the total amount of data that will be exported or imported.

HRESULT Progress(
  long Percentage
);

Parameters

Percentage
[in] A 32-bit integer that represents the current percentage of the total amount of data that will be exported or imported.

Return Values

This method returns S_OK if the call is successful; otherwise, it returns an error code.

[Visual Basic]

The Progress method handles progress events that are raised during an export or import operation. The progress is passed as the current percentage of the total amount of data that will be exported or imported.

Sub Progress( _
  ByVal Percentage As Long _
)

Parameters

Percentage
[in] A 32-bit integer that represents the current percentage of the total amount of data that will be exported or imported.

Return Values

This method has no return values. If the call is unsuccessful, an error is raised that can be intercepted by using an error handler.

Example Code

The following code example demonstrates how to declare an object that will receive notification of progress events raised during export or import operations, and implements the event handler. This code example must be part of Visual Basic program with a form object.

Option Explicit
Dim WithEvents arr As FPCArray

Private Sub arr_Progress(ByVal Percentage As Long)
  Debug.Print "Export progress: " & Percentage & "%"
End Sub

Private Sub Form_Load()
  Const serverSpecificData = 4

  Dim root As FPCLib.FPC
  Set root = New FPC
  Set arr = root.GetContainingArray

  ' Export the configuration to a file with
  ' server-specific optional data.
  arr.ExportToFile "d:\Config.xml", serverSpecificData
End Sub

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCPersistSink


FPCPoliciesInTemplate collection [ISA Server 2004]

FPCPoliciesInTemplate Collection

The FPCPoliciesInTemplate collection holds a set of FPCPolicyInTemplate objects. This collection is typically accessed through the PoliciesInTemplate property of the FPCNetworkTemplate object.

Click here to see the ISA Server object hierarchy.

Methods

The FPCPoliciesInTemplate collection defines the following method.

Method | Description
Item | Retrieves the requested FPCPolicyInTemplate object from the collection.

Properties

The FPCPoliciesInTemplate collection has the following properties.

Property | Description
_NewEnum | Gets an enumerator object for the collection.
Count | Gets the number of FPCPolicyInTemplate objects in the collection.

Remarks

This collection implements the IFPCPoliciesInTemplate interface.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

COM Objects


IFPCPoliciesInTemplate._NewEnum(IUnknown) property [ISA Server 2004]

_NewEnum Property of IFPCPoliciesInTemplate[C++]

FPCPoliciesInTemplate._NewEnum [Visual Basic]

[C++]

The _NewEnum property gets an enumerator object for the collection. An enumerator object provides serial access to the elements of the collection.

HRESULT get__NewEnum(
  IUnknown* ppEnum
);

Parameters

ppEnum
Address of an interface pointer that on return points to the IUnknown interface of an enumerator object that implements an IEnumVARIANT interface for the collection. An interface pointer to the IEnumVARIANT interface of the enumerator object can be retrieved by calling QueryInterface on the IUnknown interface returned.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The _NewEnum property gets an enumerator object for the collection. An enumerator object provides serial access to the elements of the collection.

Property _NewEnum As IUnknown

Property Value

Reference to an enumerator object that provides serial access to the elements of the collection.

Remarks

This property is read-only.

In Visual Basic and VBScript, this property is used implicitly in For Each...In...Next constructs.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCPoliciesInTemplate


IFPCPoliciesInTemplate | FPCPoliciesInTemplate Count property [ISA Server 2004]

Count Property of IFPCPoliciesInTemplate[C++]

FPCPoliciesInTemplate.Count [Visual Basic]

[C++]

The Count property gets the number of FPCPolicyInTemplate objects in the collection.

HRESULT get_Count(
  long* plCount
);

Parameters

plCount
Pointer to a variable that on return receives a 32-bit integer specifying the number of FPCPolicyInTemplate objects in the collection.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The Count property gets the number of FPCPolicyInTemplate objects in the collection.

Property Count As Long

Property Value

A 32-bit integer value that specifies the number of FPCPolicyInTemplate objects in the collection.

Remarks

This property is read-only.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCPoliciesInTemplate


IFPCPoliciesInTemplate | FPCPoliciesInTemplate Item method [ISA Server 2004]

IFPCPoliciesInTemplate::Item[C++]

FPCPoliciesInTemplate.Item [Visual Basic]

[C++]

The Item method retrieves the requested IFPCPolicyInTemplate interface from the collection.

HRESULT Item(
  VARIANT Index,
  IFPCPolicyInTemplate** ppItem
);

Parameters

Index
[in] Required. Name or one-based index of the object to retrieve.
ppItem
[out] Address of an interface pointer that on return points to the IFPCPolicyInTemplate interface requested.

Return Values

This method can return one of the following:

  • S_OK, indicating that the operation succeeded.
  • An error code, indicating that the operation failed. In this case, the [out] parameter returned is a null object.

[Visual Basic]

The Item method retrieves the requested FPCPolicyInTemplate object from the collection.

Function Item( _
  ByVal Index As Variant _
) As FPCPolicyInTemplate

Parameters

Index
[in] Required. Name or one-based index of the object to retrieve.

Return Values

This method returns a reference to the FPCPolicyInTemplate object requested if successful. Otherwise, an error is raised that can be intercepted by using an error handler.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCPoliciesInTemplate


FPCPolicyInTemplate object [ISA Server 2004]

FPCPolicyInTemplate

The FPCPolicyInTemplate object represents a policy in a network template. This object is typically an element of an FPCPoliciesInTemplate collection.

Click here to see the ISA Server object hierarchy.

Methods

This object has no methods.

Properties

The FPCPolicyInTemplate object has the following properties.

Property | Description
Description | Gets the description of the policy in the network template.
Name | Gets the name of the policy in the network template.
PersistentName | Gets the persistent name of the policy in the network template.

Remarks

This object implements the IFPCPolicyInTemplate interface.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

COM Objects


IFPCPolicyInTemplate.Description(BSTR) property [ISA Server 2004]

Description Property of IFPCPolicyInTemplate[C++]

FPCPolicyInTemplate.Description [Visual Basic]

[C++]

The Description property gets the description of the policy in the template.

HRESULT get_Description(
  BSTR* pbstrDescription
);

Parameters

pbstrDescription
Pointer to a BSTR that is set on return to a string value specifying the description of the policy in the template.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only. The description of each policy included in a template is specified in the XML file used in the Add method of the FPCNetworkTemplates collection to create the template.

[Visual Basic]

The Description property gets the description of the policy in the template.

Property Description As String

Property Value

String that specifies the description of the policy in the template.

Remarks

This property is read-only. The description of each policy included in a template is specified in the XML file used in the Add method of the FPCNetworkTemplates collection to create the template.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCPolicyInTemplate


IFPCPolicyInTemplate | FPCPolicyInTemplate Name(BSTR) property [ISA Server 2004]

Name Property of IFPCPolicyInTemplate[C++]

FPCPolicyInTemplate.Name [Visual Basic]

[C++]

The Name property gets the name of the policy in the template.

HRESULT get_Name(
  BSTR* pbstrName
);

Parameters

pbstrName
Pointer to a BSTR that is set on return to a string value specifying the name of the policy in the template.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only. The name of each policy included in a template is specified in the XML file used in the Add method of the FPCNetworkTemplates collection to create the template.

[Visual Basic]

The Name property gets the name of the policy in the template.

Property Name As String

Property Value

String that specifies the name of the policy in the template.

Remarks

This property is read-only. The name of each policy included in a template is specified in the XML file used in the Add method of the FPCNetworkTemplates collection to create the template.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCPolicyInTemplate


IFPCPolicyInTemplate.PersistentName(BSTR) property [ISA Server 2004]

PersistentName Property of IFPCPolicyInTemplate[C++]

FPCPolicyInTemplate.PersistentName [Visual Basic]

[C++]

The PersistentName property gets the persistent name of the policy in the network template. The persistent name of a policy in a network template is a globally unique identifier (GUID) that does not vary in different localized versions of ISA Server.

HRESULT get_PersistentName(
  BSTR* pbstrPersistentName
);

Parameters

pbstrPersistentName
Pointer to a BSTR that is set on return to a string value specifying the persistent name of the policy in the network template.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

The persistent names of all of the predefined objects that are installed with ISA Server are listed in FpcObjectsGuids.h.

[Visual Basic]

The PersistentName property gets the persistent name of the policy in the network template. The persistent name of a policy in a network template is a globally unique identifier (GUID) that does not vary in different localized versions of ISA Server.

Property PersistentName As String

Property Value

String that specifies the persistent name of the policy in the network template.

Remarks

This property is read-only.

The persistent names of all of the predefined objects that are installed with ISA Server are listed in FpcObjectsGuids.vbs and FpcObjectsGuids.js.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCPolicyInTemplate


FPCPolicyRule object [ISA Server 2004]

FPCPolicyRule

The FPCPolicyRule object represents an access rule, a server publishing rule, a Web publishing rule, or a system policy rule.

An access rule defines actions that will be taken when specific users attempt to access specific sites or content by using ISA Server. ISA Server access rules allow you to define exactly which sites and content can be accessed by clients behind the ISA Server computer and which protocols can be used by the clients to gain access. Access rules also determine when the rule is in effect by applying the rule according to a specific schedule.

Server publishing processes incoming requests to internal servers, such as Simple Mail Transfer Protocol (SMTP) servers, File Transfer Protocol (FTP) servers, Structured Query Language (SQL) servers, and others. Requests are forwarded downstream to an internal server, located behind the ISA Server computer. Server publishing rules determine how server publishing functions, essentially filtering all incoming and outgoing requests through the ISA Server computer.

Server publishing rules are used when there is a network address translation (NAT) relationship defined by a network rule (FPCNetworkRule) between the network on which the clients sending requests to the published server are located (the source network) and the network on which the published server is located (the destination network). A server publishing rule uses secure network address translation (SecureNAT), which allows requests that are sent to an IP address that is valid on the source network to reach an IP address on a protected network behind the ISA Server computer. The server publishing rule maps a port number and an IP address (or IP addresses) on the network adapter of the ISA Server computer that listens for requests from the clients to a port number and an IP address on the published server. Requests that meet the conditions specified by the rule are then redirected to the IP address of the published server. However, only requests that are identified as part of the designated protocol are processed by the server publishing rule and redirected to the published server. When the network rule defines a routing relationship, the clients should send requests directly to the IP address of the published server.

A Web publishing rule maps published website names to the internal paths of websites and maps DNS names and IP addresses to the internal address of a Web server located behind the ISA Server computer. A Web publishing rule also determines how ISA Server should handle incoming requests for HTTP objects on the internal Web server and how ISA Server should respond on behalf of the internal Web server. Requests are forwarded downstream to the internal Web server. If possible, the requests are serviced from the ISA Server cache.

A Web publishing rule defines the response to attempts by outside users to access an internal site. Possible responses include:

  • Denying the request.
  • Delegating the request to a different internal server.

A system policy rule is a predefined rule that allows specific types of requests from the Local Host network (the ISA Server computer) to reach specified destinations, or allows specific types of requests from specified sources to reach the Local Host network. Each system policy rule belongs to a group of rules that apply to a specific service and can be configured together. Such a group is called a configuration group, which is represented by an FPCSystemPolicyConfigGroup object.

This object is an element of an FPCPolicyRules collection in the case of an access rule, a server publishing rule, or a Web publishing rule, or of an FPCSystemPolicyRules collection in the case of a system policy rule.

Click here to see the ISA Server object hierarchy.

Inheritance

This object inherits from the FPCPersist object, which contains methods and properties related to the persistent storage of an object's data. They include methods for exporting the object's data to and importing it from an XML document.

Methods

The FPCPolicyRule object defines the following methods.

Method | Description
SetAppliesAlways | Sets the rule to apply at all times regardless of the ScheduleUsed property.
SetLimitSourcePortRange | Sets the lower and upper limits of the range of source port numbers to which the rule applies.
SetSchedule | Sets the schedule to which the rule applies.

Properties

The FPCPolicyRule object has the following properties.

Property | Description
AccessProperties | Gets an FPCAccessProperties object that specifies a set of properties of the policy rule when the rule was created as an access rule.
Action | Gets or sets a value from the FpcPolicyRuleActions enumerated type that specifies whether the rule allows or denies requests.
AppliesAlways | Gets a Boolean value that indicates whether the rule applies at all times.
Description | Gets or sets the description of the rule.
Enabled | Gets or sets a Boolean value that indicates whether the rule is enabled.
EnableLogging | Gets or sets a Boolean value that indicates whether the rule is enabled for logging.
IsDefault | Gets a Boolean value that indicates whether the rule is preinstalled, and cannot be deleted or have its position changed in the rule order.
LimitSourcePortHigh | Gets the upper limit of the range of source port numbers to which the rule applies.
LimitSourcePortLow | Gets the lower limit of the range of source port numbers to which the rule applies.
Name | Gets or sets the name of the rule.
Order | Gets the rule's position in the list of policy rules, which corresponds to their order of application.
ScheduleUsed | Gets an FPCRef object that references the FPCSchedule object used to define the actual times when the rule applies.
ServerPublishingProperties | Gets an FPCServerPublishingProperties object that specifies a set of properties of the policy rule when the rule was created as a server publishing rule.
SourceSelectionIPs | Gets an FPCSelectionIPs object that specifies the complete set of source IP addresses to which the rule applies.
System | Gets a Boolean value that indicates whether the rule is a system policy rule.
SystemPolicyGroupId | Gets a value from the FpcSystemPolicyConfigGroupEnum enumerated type that identifies the system policy configuration group to which the rule belongs.
Type | Gets a value from the FpcPolicyRuleTypes enumerated type that indicates whether the policy rule is an access rule, a server publishing rule, or a Web publishing rule.
WebPublishingProperties | Gets an FPCWebPublishingProperties object that specifies a set of properties of the policy rule when the rule was created as a Web publishing rule.

Methods Inherited from FPCPersist

Name | Description
CancelWaitForChanges | Cancels the registration established by the WaitForChanges method (for use in C and C++ programming only).
CanImport | Returns a Boolean value that indicates whether the object's properties can be imported from the specified XML document.
Export | Recursively writes the stored values of all the properties of the object and its subobjects to the specified XML document.
ExportToFile | Recursively writes the stored values of all the properties of the object and its subobjects to the specified XML file.
GetServiceRestartMask | Retrieves a 32-bit bitmask of the FpcServices enumerated type that specifies which services need to be restarted for currently unsaved changes to take effect.
Import | Recursively copies the values of all the properties of the object and of its subobjects from the specified XML document to persistent storage.
ImportFromFile | Recursively copies the values of all the properties of the object and of its subobjects from the specified XML file to persistent storage.
LoadDocProperties | Provides the XML document's properties so that you can know what information can be imported from the document.
Refresh | Recursively reads the values of all the properties of the object and of its subobjects from persistent storage, overwriting any changes that have not been saved.
Save | Recursively writes the current values of all the properties of the object and its subobjects to persistent storage.
WaitForChanges | Registers to wait for an event indicating that the contents of the object have changed (for use in C and C++ programming only).

Properties Inherited from FPCPersist

Name | Description
PersistentName | Gets the persistent name of the object. The persistent name of an object is a name that is unique for the object at the respective level of the COM object hierarchy.
VendorParametersSets | Gets an FPCVendorParametersSets collection that can hold sets of custom data for extending the object.

Remarks

This object implements the IFPCPolicyRule interface.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

COM Objects


IFPCPolicyRule | FPCPolicyRule AccessProperties property [ISA Server 2004]

AccessProperties Property of IFPCPolicyRule[C++]

FPCPolicyRule.AccessProperties [Visual Basic]

[C++]

The AccessProperties property gets an FPCAccessProperties object that specifies a set of properties of the policy rule when the rule is configured as an access rule.

HRESULT get_AccessProperties(
  IFPCAccessProperties** ppAccessProperties
);

Parameters

ppAccessProperties
Address of an interface pointer that on return points to an IFPCAccessProperties interface that specifies a set of properties of the policy rule when the rule is configured as an access rule.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only. However, the properties of the IFPCAccessProperties interface retrieved can be modified directly using its properties and methods.

[Visual Basic]

The AccessProperties property gets an FPCAccessProperties object that specifies a set of properties of the policy rule when the rule is configured as an access rule.

Property AccessProperties As FPCAccessProperties

Property Value

Reference to an FPCAccessProperties object that specifies a set of properties of the policy rule when the rule is configured as an access rule.

Remarks

This property is read-only. However, the properties of the FPCAccessProperties object retrieved can be modified directly using its properties and methods.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCPolicyRule


IFPCPolicyRule | FPCPolicyRule Action (2 Parameters) property [ISA Server 2004]

Action Property of IFPCPolicyRule[C++]

FPCPolicyRule.Action [Visual Basic]

[C++]

The Action property gets or sets the type of action that this rule performs. The action may be to allow requests or deny requests.

HRESULT get_Action(
  FpcPolicyRuleActions* pPolicyRuleActions
);

HRESULT put_Action(
  FpcPolicyRuleActions PolicyRuleActions
);

Parameters

pPolicyRuleActions
Pointer to a value from the FpcPolicyRuleActions enumerated type that is set on return to either fpcPolicyRuleActionAllow, which indicates that the rule allows requests, or to fpcPolicyRuleActionDeny, which indicates that the rule denies requests.
PolicyRuleActions
Value from the FpcPolicyRuleActions enumerated type that specifies whether the rule allows or denies requests.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write. The default value for an access rule is fpcPolicyRuleActionDeny, which indicates that the rule denies requests. The default value for a server publishing rule or a Web publishing rule is fpcPolicyRuleActionAllow, which indicates that the rule allows requests.

[Visual Basic]

The Action property gets or sets the type of action that this rule performs. The action may be to allow requests or deny requests.

Property Action As FpcPolicyRuleActions

Property Value

Value from the FpcPolicyRuleActions enumerated type. The possible values are fpcPolicyRuleActionAllow, which indicates that the rule allows requests, and fpcPolicyRuleActionDeny, which indicates that the rule denies requests.

Remarks

This property is read/write. The default value for an access rule is fpcPolicyRuleActionDeny, which indicates that the rule denies requests. The default value for a server publishing rule or a Web publishing rule is fpcPolicyRuleActionAllow, which indicates that the rule allows requests.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCPolicyRule


IFPCPolicyRule | FPCPolicyRule AppliesAlways property [ISA Server 2004]

AppliesAlways Property of IFPCPolicyRule[C++]

FPCPolicyRule.AppliesAlways [Visual Basic]

[C++]

The AppliesAlways property gets a Boolean value that indicates whether the rule applies at all times.

HRESULT get_AppliesAlways(
  VARIANT_BOOL* pfApplies
);

Parameters

pfApplies
Pointer to a Boolean variable that is set on return to VARIANT_TRUE if the rule applies at all times, or to VARIANT_FALSE if the rule applies only at certain times.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only. Its default value is VARIANT_TRUE. Choosing a schedule by calling the SetSchedule method will set it to VARIANT_FALSE. It can be set to VARIANT_TRUE by calling the SetAppliesAlways method.

[Visual Basic]

The AppliesAlways property gets a Boolean value that indicates whether the rule applies at all times.

Property AppliesAlways As Boolean

Property Value

Boolean value that indicates whether the rule applies at all times.

Remarks

This property is read-only. Its default value is True. Choosing a schedule by calling the SetSchedule method will set it to False. It can be set to True by calling the SetAppliesAlways method.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCPolicyRule


IFPCPolicyRule | FPCPolicyRule Description(BSTR,BSTR) property [ISA Server 2004]

Description Property of IFPCPolicyRule[C++]

FPCPolicyRule.Description [Visual Basic]

[C++]

The Description property gets or sets the description of the rule.

HRESULT get_Description(
  BSTR* pbstrDescription
);

HRESULT put_Description(
  BSTR bstrDescription
);

Parameters

pbstrDescription
Pointer to a BSTR that is set on return to a string value specifying the description of the rule.
bstrDescription
BSTR that specifies the description of the rule.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write. Its default value is an empty string.

[Visual Basic]

The Description property gets or sets the description of the rule.

Property Description As String

Property Value

String that specifies the description of the rule.

Remarks

This property is read/write. Its default value is an empty string.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCPolicyRule


IFPCPolicyRule | FPCPolicyRule Enabled (2 Parameters) property [ISA Server 2004]

Enabled Property of IFPCPolicyRule[C++]

FPCPolicyRule.Enabled [Visual Basic]

[C++]

The Enabled property gets or sets a Boolean value that indicates whether the rule is enabled.

HRESULT get_Enabled(
  VARIANT_BOOL* pfEnabled
);

HRESULT put_Enabled(
  VARIANT_BOOL fEnabled
);

Parameters

pfEnabled
Pointer to a Boolean variable that is set on return to VARIANT_TRUE if the rule is enabled, or to VARIANT_FALSE if the rule is disabled.
fEnabled
Boolean value that indicates whether the rule is enabled.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

For access rules, server publishing rules, and Web publishing rules, this property is read/write, and its default value is VARIANT_TRUE.

For system policy rules, this property is read-only. A system policy rule can be enabled or disabled through the Enabled property of its configuration group.

[Visual Basic]

The Enabled property gets or sets a Boolean value that indicates whether the rule is enabled.

Property Enabled As Boolean

Property Value

Boolean value that indicates whether the rule is enabled.

Remarks

For access rules, server publishing rules, and Web publishing rules, this property is read/write, and its default value is True.

For system policy rules, this property is read-only. A system policy rule can be enabled or disabled through the Enabled property of its configuration group.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCPolicyRule


IFPCPolicyRule | FPCPolicyRule EnableLogging property [ISA Server 2004]

EnableLogging Property of IFPCPolicyRule[C++]

FPCPolicyRule.EnableLogging [Visual Basic]

[C++]

The EnableLogging property gets or sets a Boolean value that indicates whether the rule is enabled for logging.

HRESULT get_EnableLogging(
  VARIANT_BOOL* pfEnableLogging
);

HRESULT put_EnableLogging(
  VARIANT_BOOL fEnableLogging
);

Parameters

pfEnableLogging
Pointer to a Boolean variable that is set on return to VARIANT_TRUE if the rule is enabled for logging, or to VARIANT_FALSE if the rule is not enabled for logging.
fEnableLogging
Boolean value that indicates whether the rule is enabled for logging.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write. Its default value is VARIANT_TRUE.

When a rule is enabled for logging, all client requests that match the rule are recorded in the applicable log.

[Visual Basic]

The EnableLogging property gets or sets a Boolean value that indicates whether the rule is enabled for logging.

Property EnableLogging As Boolean

Property Value

Boolean value that indicates whether the rule is enabled for logging.

Remarks

This property is read/write. Its default value is True.

When a rule is enabled for logging, all client requests that match the rule are recorded in the applicable log.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCPolicyRule


IFPCPolicyRule | FPCPolicyRule IsDefault property [ISA Server 2004]

IsDefault Property of IFPCPolicyRule[C++]

FPCPolicyRule.IsDefault [Visual Basic]

[C++]

The IsDefault property gets a Boolean value that indicates whether the rule is preinstalled, and cannot be deleted or have its position changed in the rule order.

HRESULT get_IsDefault(
  VARIANT_BOOL* pfDefault
);

Parameters

pfDefault
Pointer to a Boolean variable that is set on return to VARIANT_TRUE if the rule is preinstalled, or to VARIANT_FALSE if the rule is not preinstalled.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The IsDefault property gets a Boolean value that indicates whether the rule is preinstalled, and cannot be deleted or have its position changed in the rule order.

Property IsDefault As Boolean

Property Value

Boolean value that indicates whether the rule is preinstalled.

Remarks

This property is read-only.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCPolicyRule


IFPCPolicyRule | FPCPolicyRule LimitSourcePortHigh property [ISA Server 2004]

LimitSourcePortHigh Property of IFPCPolicyRule[C++]

FPCPolicyRule.LimitSourcePortHigh [Visual Basic]

[C++]

The LimitSourcePortHigh property gets the upper limit of the range of source port numbers to which the rule applies.

HRESULT get_LimitSourcePortHigh(
  long* plLimitSourcePortHigh
);

Parameters

plLimitSourcePortHigh
Pointer to a variable that on return receives a 32-bit integer specifying the upper limit of the source port range to which the rule applies.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only. Its default value is 0. Both the lower and upper limits of the source port range can be set using the SetLimitSourcePortRange method.

For access rules and server publishing rules, the lower and upper limits of the source port range can also be set when the rules are created in ISA Server Management. However, for Web Publishing rules, the limits of this range can be set only by using the SetLimitSourcePortRange method.

[Visual Basic]

The LimitSourcePortHigh property gets the upper limit of the range of source port numbers to which the rule applies.

Property LimitSourcePortHigh As Long

Property Value

A 32-bit integer that specifies the upper limit of the source port range to which the rule applies.

Remarks

This property is read-only. Its default value is 0. Both the lower and upper limits of the source port range can be set using the SetLimitSourcePortRange method.

For access rules and server publishing rules, the lower and upper limits of the source port range can also be set when the rules are created in ISA Server Management. However, for Web Publishing rules, the limits of this range can be set only by using the SetLimitSourcePortRange method.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCPolicyRule


IFPCPolicyRule | FPCPolicyRule LimitSourcePortLow property [ISA Server 2004]

LimitSourcePortLow Property of IFPCPolicyRule[C++]

FPCPolicyRule.LimitSourcePortLow [Visual Basic]

[C++]

The LimitSourcePortLow property gets the lower limit of the range of source port numbers to which the rule applies.

HRESULT get_LimitSourcePortLow(
  long* plLimitSourcePortLow
);

Parameters

plLimitSourcePortLow
Pointer to a variable that on return receives a 32-bit integer specifying the lower limit of the source port range to which the rule applies.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only. Its default value is 0. Both the lower and upper limits of the source port range can be set using the SetLimitSourcePortRange method.

For access rules and server publishing rules, the lower and upper limits of the source port range can also be set when the rules are created in ISA Server Management. However, for Web Publishing rules, the limits of this range can be set only by using the SetLimitSourcePortRange method.

[Visual Basic]

The LimitSourcePortLow property gets the lower limit of the range of source port numbers to which the rule applies.

Property LimitSourcePortLow As Long

Property Value

A 32-bit integer that specifies the lower limit of the source port range to which the rule applies.

Remarks

This property is read-only. Its default value is 0. Both the lower and upper limits of the source port range can be set using the SetLimitSourcePortRange method.

For access rules and server publishing rules, the lower and upper limits of the source port range can also be set when the rules are created in ISA Server Management. However, for Web Publishing rules, the limits of this range can be set only by using the SetLimitSourcePortRange method.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCPolicyRule


IFPCPolicyRule | FPCPolicyRule Name(BSTR,BSTR) property [ISA Server 2004]

Name Property of IFPCPolicyRule[C++]

FPCPolicyRule.Name [Visual Basic]

[C++]

The Name property gets or sets the name of the rule.

HRESULT get_Name(
  BSTR* pbstrName
);

HRESULT put_Name(
  BSTR bstrName
);

Parameters

pbstrName
Pointer to a BSTR that is set on return to a string value specifying the name of the rule.
bstrName
BSTR that specifies the name of the rule.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write.

[Visual Basic]

The Name property gets or sets the name of the rule.

Property Name As String

Property Value

String that specifies the name of the rule.

Remarks

This property is read/write.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCPolicyRule


IFPCPolicyRule | FPCPolicyRule Order(long) property [ISA Server 2004]

Order Property of IFPCPolicyRule[C++]

FPCPolicyRule.Order [Visual Basic]

[C++]

The Order property gets the rule's ordinal position in the list of policy rules, which corresponds to their order of application.

HRESULT get_Order(
  long* plOrder
);

Parameters

plOrder
Pointer to a variable that on return receives a 32-bit integer specifying the rule's ordinal position in the list of policy rules.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only. By default, a new rule is added to the top of the list of policy rules with a value of 1 for this property. It can be modified by using the MoveDown and MoveUp methods of the FPCPolicyRules collection. Because these methods change the ordinal positions of more than one rule in the collection, the Save method must be called on the collection to write the changes to persistent storage.

[Visual Basic]

The Order property gets the rule's ordinal position in the list of policy rules, which corresponds to their order of application.

Property Order As Long

Property Value

A 32-bit integer that specifies the rule's ordinal position in the list of policy rules.

Remarks

This property is read-only. By default, a new rule is added to the top of the list of policy rules with a value of 1 for this property. It can be modified by using the MoveDown and MoveUp methods of the FPCPolicyRules collection. Because these methods change the ordinal positions of more than one rule in the collection, the Save method must be called on the collection to write the changes to persistent storage.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCPolicyRule


IFPCPolicyRule | FPCPolicyRule ScheduleUsed(IFPCRef) property [ISA Server 2004]

ScheduleUsed Property of IFPCPolicyRule[C++]

FPCPolicyRule.ScheduleUsed [Visual Basic]

[C++]

The ScheduleUsed property gets an FPCRef object that references the FPCSchedule object used to define the actual times when the rule applies.

HRESULT get_ScheduleUsed(
  IFPCRef** ppRef
);

Parameters

ppRef
Address of an interface pointer that on return points to the IFPCRef interface that references the FPCSchedule object used to define the actual times when the rule applies.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only. The schedule used to define the actual times when the rule applies can be set by calling the SetSchedule method.

By default, if no schedule is assigned to the rule, the rule will apply at all times.

[Visual Basic]

The ScheduleUsed property gets an FPCRef object that references the FPCSchedule object used to define the actual times when the rule applies.

Property ScheduleUsed As FPCRef

Property Value

Reference to an FPCRef object that references the FPCSchedule object used to define the actual times when the rule applies.

Remarks

This property is read-only. The schedule used to define the actual times when the rule applies can be set by calling the SetSchedule method.

By default, if no schedule is assigned to the rule, the rule will apply at all times.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCPolicyRule


IFPCPolicyRule.ServerPublishingProperties property [ISA Server 2004]

ServerPublishingProperties Property of IFPCPolicyRule[C++]

FPCPolicyRule.ServerPublishingProperties [Visual Basic]

[C++]

The ServerPublishingProperties property gets an FPCServerPublishingProperties object that specifies a set of properties of the policy rule when the rule is configured as a server publishing rule.

HRESULT get_ServerPublishingProperties(
  IFPCServerPublishingProperties** ppServerPublishingProperties
);

Parameters

ppServerPublishingProperties
Address of an interface pointer that on return points to an IFPCServerPublishingProperties interface that specifies a set of properties of the policy rule when the rule is configured as a server publishing rule.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only. However, the properties of the IFPCServerPublishingProperties interface retrieved can be modified directly using its properties and methods.

[Visual Basic]

The ServerPublishingProperties property gets an FPCServerPublishingProperties object that specifies a set of properties of the policy rule when the rule is configured as a server publishing rule.

Property ServerPublishingProperties As FPCServerPublishingProperties

Property Value

Reference to an FPCServerPublishingProperties object that specifies a set of properties of the policy rule when the rule is configured as a server publishing rule.

Remarks

This property is read-only. However, the properties of the FPCServerPublishingProperties object retrieved can be modified directly using its properties and methods.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCPolicyRule


IFPCPolicyRule | FPCPolicyRule SetAppliesAlways method [ISA Server 2004]

IFPCPolicyRule::SetAppliesAlways[C++]

FPCPolicyRule.SetAppliesAlways [Visual Basic]

[C++]

The SetAppliesAlways method sets the policy rule to apply at all times and on all days regardless of the schedule of times returned by the ScheduleUsed property. This schedule becomes meaningless when the SetAppliesAlways method is used.

HRESULT SetAppliesAlways();

Parameters

This method has no parameters.

Return Values

This method returns S_OK if the call is successful; otherwise, it returns an error code.
[Visual Basic]

The SetAppliesAlways method sets the policy rule to apply at all times and on all days regardless of the schedule of times returned by the ScheduleUsed property. This schedule becomes meaningless when the SetAppliesAlways method is used.

Sub SetAppliesAlways()

Parameters

This method has no parameters.

Return Values

This method has no return values. If the call is unsuccessful, an error is raised that can be intercepted by using an error handler.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCPolicyRule


IFPCPolicyRule | FPCPolicyRule SetLimitSourcePortRange method [ISA Server 2004]

IFPCPolicyRule::SetLimitSourcePortRange[C++]

FPCPolicyRule.SetLimitSourcePortRange [Visual Basic]

[C++]

The SetLimitSourcePortRange method sets the lower and upper limits of the range of source port numbers to which the rule applies.

HRESULT SetLimitSourcePortRange(
  long PortLow,
  long PortHi
);

Parameters

PortLow
[in] A 32-bit integer that specifies the lower limit of the source port range to which the rule applies.
PortHi
[in] A 32-bit integer that specifies the upper limit of the source port range to which the rule applies.

Return Values

This method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

For access rules and server publishing rules, the lower and upper limits of the source port range can also be set when the rules are created in ISA Server Management. However, for Web Publishing rules, the limits of this range can be set only by using this method.

[Visual Basic]

The SetLimitSourcePortRange method sets the lower and upper limits of the range of source port numbers to which the rule applies.

Sub SetLimitSourcePortRange( _
  ByVal PortLow As Long, _
  ByVal PortHi As Long _
)

Parameters

PortLow
[in] A 32-bit integer that specifies the lower limit of the source port range to which the rule applies.
PortHi
[in] A 32-bit integer that specifies the upper limit of the source port range to which the rule applies.

Return Values

This method has no return values. If the call is unsuccessful, an error is raised that can be intercepted by using an error handler.

Remarks

For access rules and server publishing rules, the lower and upper limits of the source port range can also be set when the rules are created in ISA Server Management. However, for Web Publishing rules, the limits of this range can be set only by using this method.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCPolicyRule


IFPCPolicyRule | FPCPolicyRule SetSchedule(String) method [ISA Server 2004]

IFPCPolicyRule::SetSchedule[C++]

FPCPolicyRule.SetSchedule [Visual Basic]

[C++]

The SetSchedule method sets the schedule to which the rule applies.

HRESULT SetSchedule(
  BSTR ScheduleName
);

Parameters

ScheduleName
[in] BSTR that specifies the name of the schedule to which the rule applies.

Return Values

This method returns S_OK if the call is successful; otherwise, it returns an error code.
[Visual Basic]

The SetSchedule method sets the schedule to which the rule applies.

Sub SetSchedule( _
  ByVal ScheduleName As String _
)

Parameters

ScheduleName
[in] String that specifies the name of the schedule to which the rule applies.

Return Values

This method has no return values. If the call is unsuccessful, an error is raised that can be intercepted by using an error handler.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCPolicyRule


IFPCPolicyRule | FPCPolicyRule SourceSelectionIPs property [ISA Server 2004]

SourceSelectionIPs Property of IFPCPolicyRule[C++]

FPCPolicyRule.SourceSelectionIPs [Visual Basic]

[C++]

The SourceSelectionIPs property gets an FPCSelectionIPs object that specifies the complete set of source IP addresses to which the rule applies.

HRESULT get_SourceSelectionIPs(
  IFPCSelectionIPs** ppSelectionIPs
);

Parameters

ppSelectionIPs
Address of an interface pointer that on return points to an IFPCSelectionIPs interface that specifies the complete set of source IP addresses to which the rule applies.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only. It can be modified through the properties of the IFPCSelectionIPs interface retrieved.

The DestinationSelectionIPs property of an FPCAccessProperties object can be used to retrieve the complete set of destination IP addresses to which an access rule applies.

[Visual Basic]

The SourceSelectionIPs property gets an FPCSelectionIPs object that specifies the complete set of source IP addresses to which the rule applies.

Property SourceSelectionIPs As FPCSelectionIPs

Property Value

Reference to an FPCSelectionIPs object that specifies the complete set of source IP addresses to which the rule applies.

Remarks

This property is read-only. It can be modified through the properties of the FPCSelectionIPs object retrieved.

The DestinationSelectionIPs property of an FPCAccessProperties object can be used to retrieve the complete set of destination IP addresses to which an access rule applies.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCPolicyRule


IFPCPolicyRule | FPCPolicyRule System(VARIANT_BOOL) property [ISA Server 2004]

System Property of IFPCPolicyRule[C++]

FPCPolicyRule.System [Visual Basic]

[C++]

The System property gets a Boolean value that indicates whether the rule is a system policy rule.

HRESULT get_System(
  VARIANT_BOOL* pfSystem
);

Parameters

pfSystem
Pointer to a Boolean variable that is set on return to VARIANT_TRUE if the rule is a system policy rule, or to VARIANT_FALSE if the rule is not a system policy rule.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The System property gets a Boolean value that indicates whether the rule is a system policy rule.

Property System As Boolean

Property Value

Boolean value that indicates whether the rule is a system policy rule.

Remarks

This property is read-only.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCPolicyRule


IFPCPolicyRule | FPCPolicyRule SystemPolicyGroupId property [ISA Server 2004]

SystemPolicyGroupId Property of IFPCPolicyRule[C++]

FPCPolicyRule.SystemPolicyGroupId [Visual Basic]

[C++]

The SystemPolicyGroupId property gets a value from the FpcSystemPolicyConfigGroupEnum enumerated type that identifies the system policy configuration group to which the rule belongs.

HRESULT get_SystemPolicyGroupId(
  FpcSystemPolicyConfigGroupEnum* pSystemPolicyConfigGroup
);

Parameters

pSystemPolicyConfigGroup
Pointer to a variable that on return receives a value from the FpcSystemPolicyConfigGroupEnum enumerated type that identifies the system policy configuration group to which the rule belongs.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only. Its default value is –1, which indicates that the rule is not a system policy rule.

[Visual Basic]

The SystemPolicyGroupId property gets a value from the FpcSystemPolicyConfigGroupEnum enumerated type that identifies the system policy configuration group to which the rule belongs.

Property SystemPolicyGroupId As FpcSystemPolicyConfigGroupEnum

Property Value

Value from the FpcSystemPolicyConfigGroupEnum enumerated type that identifies the system policy configuration group to which the rule belongs.

Remarks

This property is read-only. Its default value is –1, which indicates that the rule is not a system policy rule.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCPolicyRule


IFPCPolicyRule | FPCPolicyRule Type (1 Parameter) property [ISA Server 2004]

Type Property of IFPCPolicyRule[C++]

FPCPolicyRule.Type [Visual Basic]

[C++]

The Type property gets a value from the FpcPolicyRuleTypes enumerated type that indicates whether the policy rule is an access rule, a server publishing rule, or a Web publishing rule.

HRESULT get_Type(
  FpcPolicyRuleTypes* pPolicyRuleTypes
);

Parameters

pPolicyRuleTypes
Pointer to a variable that on return receives a value from the FpcPolicyRuleTypes enumerated type indicating whether the policy rule is an access rule, a server publishing rule, or a Web publishing rule.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only. Its value is determined by the method of the FPCPolicyRules collection that was used to create the rule.

[Visual Basic]

The Type property gets a value from the FpcPolicyRuleTypes enumerated type that indicates whether the policy rule is an access rule, a server publishing rule, or a Web publishing rule.

Property Type As FpcPolicyRuleTypes

Property Value

Value from the FpcPolicyRuleTypes enumerated type that indicates whether the policy rule is an access rule, a server publishing rule, or a Web publishing rule.

Remarks

This property is read-only. Its value is determined by the method of the FPCPolicyRules collection that was used to create the rule.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCPolicyRule


IFPCPolicyRule.WebPublishingProperties (1 Parameter) property [ISA Server 2004]

WebPublishingProperties Property of IFPCPolicyRule[C++]

FPCPolicyRule.WebPublishingProperties [Visual Basic]

[C++]

The WebPublishingProperties property gets a set of properties of the policy rule when the rule is configured as a Web publishing rule.

HRESULT get_WebPublishingProperties(
  IFPCWebPublishingProperties** ppWebPublishingProperties
);

Parameters

ppWebPublishingProperties
Address of an interface pointer that on return points to the IFPCWebPublishingProperties interface that specifies a set of properties of the policy rule when the rule is configured as a Web publishing rule.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only. However, the properties of the IFPCWebPublishingProperties interface referenced can be modified directly using its properties and methods.

[Visual Basic]

The WebPublishingProperties property gets a set of properties of the policy rule when the rule is configured as a Web publishing rule.

Property WebPublishingProperties As FPCWebPublishingProperties

Property Value

Reference to the FPCWebPublishingProperties object that specifies a set of properties of the policy rule when the rule is configured as a Web publishing rule.

Remarks

This property is read-only. However, the properties of the FPCWebPublishingProperties object referenced can be modified directly using its properties and methods.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCPolicyRule


FPCPolicyRules collection [ISA Server 2004]

FPCPolicyRules Collection

The FPCPolicyRules collection provides access to a group of FPCPolicyRule objects of an ISA Server computer. An individual FPCPolicyRule object represents an access rule, a server publishing rule, or a Web publishing rule.

The rules appear in this collection in their order of application. This order can be modified by the MoveUp and MoveDown methods.

An FPCPolicyRules collection is typically accessed through the PolicyRules property of an FPCArrayPolicy object.

Click here to see the ISA Server object hierarchy.

Inheritance

This collection inherits from the FPCPersist object, which contains methods and properties related to persistent object storage. They include methods for exporting an object's configuration to and importing it from an XML document.

Methods

The FPCPolicyRules collection defines the following methods.

Method | Description
AddAccessRule | Creates a new FPCPolicyRule object representing an access rule in the collection and returns a reference to it.
AddServerPublishingRule | Creates a new FPCPolicyRule object representing a server publishing rule in the collection and returns a reference to it.
AddWebPublishingRule | Creates a new FPCPolicyRule object representing a Web publishing rule in the collection and returns a reference to it.
Item | Retrieves the requested FPCPolicyRule object from the collection.
MoveDown | Moves the specified rule down the list of rules, which corresponds to their order of application.
MoveUp | Moves the specified rule up the list of rules, which corresponds to their order of application.
Remove | Removes an FPCPolicyRule object from the collection.

Properties

The FPCPolicyRules collection has the following properties.

Property | Description
_NewEnum | Gets an enumerator object for the collection.
Count | Gets the number of FPCPolicyRule objects in the collection.

Methods Inherited from FPCPersist

Name | Description
CancelWaitForChanges | Cancels the registration established by the WaitForChanges method (for use in C and C++ programming only).
CanImport | Returns a Boolean value that indicates whether the properties of the collection, its elements, and their subobjects can be imported from the specified XML document.
Export | Recursively writes the stored values of all the properties of the collection, its elements, and their subobjects to the specified XML document.
ExportToFile | Recursively writes the stored values of all the properties of the collection, its elements, and their subobjects to the specified XML file.
GetServiceRestartMask | Retrieves a 32-bit bitmask of the FpcServices enumerated type that specifies which services need to be restarted for currently unsaved changes to take effect.
Import | Recursively copies the values of all the properties of the collection, its elements, and their subobjects from the specified XML document to persistent storage.
ImportFromFile | Recursively copies the values of all the properties of the collection, its elements, and their subobjects from the specified XML file to persistent storage.
LoadDocProperties | Provides the XML document's properties so that you can know what information can be imported from the document.
Refresh | Recursively reads the values of all the properties of the collection, its elements, and their subobjects from persistent storage, overwriting any changes that have not been saved.
Save | Recursively writes the current values of all the properties of the collection, its elements, and their subobjects to persistent storage.
WaitForChanges | Registers to wait for an event indicating that the contents of the object have changed (for use in C and C++ programming only).

Properties Inherited from FPCPersist

Name | Description
PersistentName | Gets the persistent name of the collection. The persistent name of an object is a name that is unique for the object at the respective level of the COM object hierarchy.
VendorParametersSets | Gets an FPCVendorParametersSets collection that can hold sets of custom data for extending the collection.

Remarks

This collection implements the IFPCPolicyRules interface.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

COM Objects


IFPCPolicyRules | FPCPolicyRules _NewEnum(IUnknown) property [ISA Server 2004]

_NewEnum Property of IFPCPolicyRules[C++]

FPCPolicyRules._NewEnum [Visual Basic]

[C++]

The _NewEnum property gets an enumerator object for the collection. An enumerator object provides serial access to the elements of the collection.

HRESULT get__NewEnum(
  IUnknown* ppEnum
);

Parameters

ppEnum
Address of an interface pointer that on return points to the IUnknown interface of an enumerator object that implements an IEnumVARIANT interface for the collection. An interface pointer to the IEnumVARIANT interface of the enumerator object can be retrieved by calling QueryInterface on the IUnknown interface returned.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The _NewEnum property gets an enumerator object for the collection. An enumerator object provides serial access to the elements of the collection.

Property _NewEnum As IUnknown

Property Value

Reference to an enumerator object that provides serial access to the elements of the collection.

Remarks

This property is read-only.

In Visual Basic and VBScript, this property is used implicitly in For Each...In...Next constructs.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCPolicyRules


IFPCPolicyRules | FPCPolicyRules AddAccessRule method [ISA Server 2004]

IFPCPolicyRules::AddAccessRule[C++]

FPCPolicyRules.AddAccessRule [Visual Basic]

[C++]

The AddAccessRule method creates a new FPCPolicyRule object representing an access rule in the collection and returns a reference to it.

HRESULT AddAccessRule(
  BSTR Name,
  IFPCPolicyRule** ppNewRule
);

Parameters

Name
[in] Required. BSTR that specifies the name of the new access rule.
ppNewRule
[out] Address of an interface pointer that on return points to an IFPCPolicyRule interface representing the new access rule.

Return Values

This method returns one of the following:

  • S_OK, indicating that the operation succeeded.
  • An error code, indicating that the operation failed. In this case, the [out] parameter returned is a null object.

Remarks

The name assigned to the new rule must be unique. If the AddAccessRule method is called with the name of an existing policy rule, the method fails.

An access rule defines the actions that will be taken when specific users attempt to access specific sites or content through the ISA Server computer. The access rule represented by the IFPCPolicyRule interface created can be configured by setting the properties of the IFPCAccessProperties interface accessed through the AccessProperties property.

[Visual Basic]

The AddAccessRule method creates a new FPCPolicyRule object representing an access rule in the collection and returns a reference to it.

Function AddAccessRule( _
  ByVal Name As String _
) As FPCPolicyRule

Parameters

Name
[in] Required. String that specifies the name of the new access rule.

Return Values

This method returns a reference to the FPCPolicyRule object if the operation is successful. Otherwise, an error is raised that can be intercepted by using an error handler.

Remarks

The name assigned to the new rule must be unique. If the AddAccessRule method is called with the name of an existing policy rule, the method fails.

An access rule defines the actions that will be taken when specific users attempt to access specific sites or content through the ISA Server computer. The access rule defined by the FPCPolicyRule object created can be configured by setting the properties of the FPCAccessProperties object accessed through the AccessProperties property.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCPolicyRules


IFPCPolicyRules.AddServerPublishingRule (4 Parameters) method [ISA Server 2004]

IFPCPolicyRules::AddServerPublishingRule[C++]

FPCPolicyRules.AddServerPublishingRule [Visual Basic]

[C++]

The AddServerPublishingRule method creates a new FPCPolicyRule object representing a server publishing rule in the collection and returns a reference to it.

HRESULT AddServerPublishingRule(
  BSTR Name,
  BSTR PublishedServerIP,
  BSTR Protocol,
  IFPCPolicyRule** ppNewRule
);

Parameters

Name
[in] Required. BSTR that specifies the name of the new server publishing rule.
PublishedServerIP
[in] Required. BSTR that specifies the IP address of the internal server being published.
Protocol
[in] Required. BSTR that specifies the protocol for the new server publishing rule.
ppNewRule
[out] Address of an interface pointer that on return points to an IFPCPolicyRule interface representing the new server publishing rule.

Return Values

This method returns one of the following:

  • S_OK, indicating that the operation succeeded.
  • An error code, indicating that the operation failed. In this case, the [out] parameter returned is a null object.

Remarks

Server publishing rules are used when there is a network address translation (NAT) relationship defined by a network rule (FPCNetworkRule) between the network on which the clients sending requests to the published server are located (the source network) and the network on which the published server is located (the destination network). A server publishing rule uses secure network address translation (SecureNAT), which allows requests that are sent to an IP address that is valid on the source network to reach an IP address on a protected network behind the ISA Server computer. The server publishing rule maps a port number and an IP address (or IP addresses) on the network adapter of the ISA Server computer that listens for requests from the clients to a port number and an IP address on the published server. Requests that meet the conditions specified by the rule are then redirected to the IP address specified in the PublishedServerIP parameter. However, only requests that are identified as part of the protocol specified in the Protocol parameter are processed by the server publishing rule and redirected to the published server.

The name assigned to the new rule must be unique. If the AddServerPublishingRule method is called with the name of an existing policy rule, the method fails.

The server publishing rule represented by the IFPCPolicyRule interface created can be configured by setting the properties of the IFPCServerPublishingProperties interface accessed through the ServerPublishingProperties property.

Before the properties of a new server publishing rule can be written to persistent storage by calling the Save method, at least one network or network set on which the ISA Server will listen for requests must be specified for the rule through the IPsOnNetworks or IPsOnNetworkSets property.

[Visual Basic]

The AddServerPublishingRule method creates a new FPCPolicyRule object representing a server publishing rule in the collection and returns a reference to it.

Function AddServerPublishingRule( _
  ByVal Name As String, _
  ByVal PublishedServerIP As String, _
  ByVal Protocol As String _
) As FPCPolicyRule

Parameters

Name
[in] Required. String that specifies the name of the new server publishing rule.
PublishedServerIP
[in] Required. String that specifies the IP address of the internal server being published.
Protocol
[in] Required. String that specifies the protocol for the new server publishing rule.

Return Values

This method returns a reference to the FPCPolicyRule object if the operation is successful. Otherwise, an error is raised that can be intercepted by using an error handler.

Remarks

Server publishing rules are used when there is a network address translation (NAT) relationship defined by a network rule (FPCNetworkRule) between the network on which the clients sending requests to the published server are located (the source network) and the network on which the published server is located (the destination network). A server publishing rule uses secure network address translation (SecureNAT), which allows requests that are sent to an IP address that is valid on the source network to reach an IP address on a protected network behind the ISA Server computer. The server publishing rule maps a port number and an IP address (or IP addresses) on the network adapter of the ISA Server computer that listens for requests from the clients to a port number and an IP address on the published server. Requests that meet the conditions specified by the rule are then redirected to the IP address specified in the PublishedServerIP parameter. However, only requests that are identified as part of the protocol specified in the Protocol parameter are processed by the server publishing rule and redirected to the published server.

The name assigned to the new rule must be unique. If the AddServerPublishingRule method is called with the name of an existing policy rule, the method fails.

The server publishing rule defined by the FPCPolicyRule object created can be configured by setting the properties of the FPCServerPublishingProperties object accessed through the ServerPublishingProperties property.

Before the properties of a new server publishing rule can be written to persistent storage by calling the Save method, at least one network or network set on which the ISA Server will listen for requests must be specified for the rule through the IPsOnNetworks or IPsOnNetworkSets property.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCPolicyRules


IFPCPolicyRules | FPCPolicyRules AddWebPublishingRule method [ISA Server 2004]

IFPCPolicyRules::AddWebPublishingRule[C++]

FPCPolicyRules.AddWebPublishingRule [Visual Basic]

[C++]

The AddWebPublishingRule method creates a new FPCPolicyRule object representing a Web publishing rule in the collection and returns a reference to it.

HRESULT AddWebPublishingRule(
  BSTR Name,
  IFPCPolicyRule** ppNewRule
);

Parameters

Name
[in] Required. BSTR that specifies the name of the new Web publishing rule.
ppNewRule
[out] Address of an interface pointer that on return points to an IFPCPolicyRule interface representing the new Web publishing rule.

Return Values

This method returns one of the following:

  • S_OK, indicating that the operation succeeded.
  • An error code, indicating that the operation failed. In this case, the [out] parameter returned is a null object.

Remarks

The name assigned to the new rule must be unique. If the AddWebPublishingRule method is called with the name of an existing policy rule, the method fails.

A Web publishing rule maps published website names to the internal paths of websites and maps DNS names and IP addresses to the internal address of a Web server located behind the ISA Server computer. A Web publishing rule also determines how ISA Server should handle incoming requests for HTTP objects on the internal Web server and how ISA Server should respond on behalf of the internal Web server. Requests are forwarded downstream to the internal Web server. If possible, the requests are serviced from the ISA Server cache.

Before the properties of a new Web publishing rule can be written to persistent storage by calling the Save method, the following tasks must be performed:

  • The name or IP address of the server to which the rule will redirect requests must be specified in the WebSite property.
  • At least one public name that will be resolved by the rule to the name or IP address of the Web server published by the rule must specified through PublicNames property.
  • A Web listener must be specified by calling the SetWebListener method.

[Visual Basic]

The AddWebPublishingRule method creates a new FPCPolicyRule object representing a Web publishing rule in the collection and returns a reference to it.

Function AddWebPublishingRule( _
  ByVal Name As String _
) As FPCPolicyRule

Parameters

Name
[in] Required. String that specifies the name of the new Web publishing rule.

Return Values

This method returns a reference to the FPCPolicyRule object if the operation is successful. Otherwise, an error is raised that can be intercepted by using an error handler.

Remarks

The name assigned to the new rule must be unique. If the AddWebPublishingRule method is called with the name of an existing policy rule, the method fails.

A Web publishing rule maps published website names to the internal paths of websites and maps DNS names and IP addresses to the internal address of a Web server located behind the ISA Server computer. A Web publishing rule also determines how ISA Server should handle incoming requests for HTTP objects on the internal Web server and how ISA Server should respond on behalf of the internal Web server. Requests are forwarded downstream to the internal Web server. If possible, the requests are serviced from the ISA Server cache.

Before the properties of a new Web publishing rule can be written to persistent storage by calling the Save method, the following tasks must be performed:

  • The name or IP address of the server to which the rule will redirect requests must be specified in the WebSite property.
  • At least one public name that will be resolved by the rule to the name or IP address of the Web server published by the rule must specified through PublicNames property.
  • A Web listener must be specified by calling the SetWebListener method.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCPolicyRules


IFPCPolicyRules | FPCPolicyRules Count(long) property [ISA Server 2004]

Count Property of IFPCPolicyRules[C++]

FPCPolicyRules.Count [Visual Basic]

[C++]

The Count property gets the number of FPCPolicyRule objects in the collection.

HRESULT get_Count(
  long* plCount
);

Parameters

plCount
Pointer to a variable that on return receives a 32-bit integer specifying the number of FPCPolicyRule objects in the collection.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The Count property gets the number of FPCPolicyRule objects in the collection.

Property Count As Long

Property Value

A 32-bit integer that specifies the number of FPCPolicyRule objects in the collection.

Remarks

This property is read-only.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCPolicyRules


IFPCPolicyRules | FPCPolicyRules Item (2 Parameters) method [ISA Server 2004]

IFPCPolicyRules::Item[C++]

FPCPolicyRules.Item [Visual Basic]

[C++]

The Item method retrieves the requested IFPCPolicyRule interface from the collection.

HRESULT Item(
  VARIANT Index,
  IFPCPolicyRule** ppItem
);

Parameters

Index
[in] Required. Name or one-based index of the collection element to retrieve.
ppItem
[out] Address of an interface pointer that on return points to the IFPCPolicyRule interface requested.

Return Values

This method returns one of the following:

  • S_OK, indicating that the operation succeeded.
  • An error code, indicating that the operation failed. In this case, the [out] parameter returned is a null object.

[Visual Basic]

The Item method retrieves the requested FPCPolicyRule object from the collection.

Function Item( _
  ByVal Index As Variant _
) As FPCPolicyRule

Parameters

Index
[in] Required. Name or one-based index of the collection element to retrieve.

Return Values

This method returns a reference to the FPCPolicyRule object requested if the call is successful. Otherwise, an error is raised that can be intercepted by using an error handler.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCPolicyRules


IFPCPolicyRules | FPCPolicyRules MoveDown(Long) method [ISA Server 2004]

IFPCPolicyRules::MoveDown[C++]

FPCPolicyRules.MoveDown [Visual Basic]

[C++]

The MoveDown method moves the specified rule down the list of rules, which corresponds to their order of application.

HRESULT MoveDown(
  long index
);

Parameters

index
[in] Required. Index (the current position indicated by the Order property of the FPCPolicyRule object) of the rule to move down.

Return Values

This method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

The default rule is always applied last. Its position cannot be changed.

This method is not applicable to system policy rules, which are contained in an FPCSystemPolicyRules collection.

[Visual Basic]

The MoveDown method moves the specified rule down the list of rules, which corresponds to their order of application.

Sub MoveDown( _
  ByVal index As Long _
)

Parameters

index
[in] Required. Index (the current position indicated by the Order property of the FPCPolicyRule object) of the rule to move down.

Return Values

This method has no return values. If the call is unsuccessful, an error is raised that can be intercepted by using an error handler.

Remarks

The default rule is always applied last. Its position cannot be changed.

This method is not applicable to system policy rules, which are contained in an FPCSystemPolicyRules collection.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCPolicyRules, MoveUp


IFPCPolicyRules | FPCPolicyRules MoveUp(Long) method [ISA Server 2004]

IFPCPolicyRules::MoveUp[C++]

FPCPolicyRules.MoveUp [Visual Basic]

[C++]

The MoveUp method moves the specified rule up the list of rules, which corresponds to their order of application.

HRESULT MoveUp(
  long index
);

Parameters

index
[in] Required. Index (the current position indicated by the Order property of the FPCPolicyRule object) of the rule to move up.

Return Values

This method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

The default rule is always applied last. Its position cannot be changed.

This method is not applicable to system policy rules, which are contained in an FPCSystemPolicyRules collection.

[Visual Basic]

The MoveUp method moves the specified rule up the list of rules, which corresponds to their order of application.

Sub MoveUp( _
  ByVal index As Long _
)

Parameters

index
[in] Required. Index (the current position indicated by the Order property of the FPCPolicyRule object) of the rule to move up.

Return Values

This method has no return values. If the call is unsuccessful, an error is raised that can be intercepted by using an error handler.

Remarks

The default rule is always applied last. Its position cannot be changed.

This method is not applicable to system policy rules, which are contained in an FPCSystemPolicyRules collection.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCPolicyRules, MoveDown


IFPCPolicyRules | FPCPolicyRules Remove(Variant) method [ISA Server 2004]

IFPCPolicyRules::Remove[C++]

FPCPolicyRules.Remove [Visual Basic]

[C++]

The Remove method removes the specified FPCPolicyRule object from the collection.

HRESULT Remove(
  VARIANT Index
);

Parameters

Index
[in] Required. Name or one-based index of the element to remove.

Return Values

This method returns S_OK if the call is successful; otherwise, it returns an error code.

[Visual Basic]

The Remove method removes the specified FPCPolicyRule object from the collection.

Sub Remove( _
  ByVal Index As Variant _
)

Parameters

Index
[in] Required. Name or one-based index of the element to remove.

Return Values

This method has no return values. If the call is unsuccessful, an error is raised that can be intercepted by using an error handler.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCPolicyRules


FPCPrimaryRoute object [ISA Server 2004]

FPCPrimaryRoute

The FPCPrimaryRoute object represents the primary route used to route requests from Web proxy clients. The primary route can be direct to the Internet, it can include an upstream proxy server, or it can redirect Web proxy client requests to a specified host. This object is typically accessed through the PrimaryRoute property of an FPCRoutingRule object.

Click here to see the ISA Server object hierarchy.

Methods

The FPCPrimaryRoute object defines the following methods.

Method | Description
Refresh | Recursively reads all of the properties of the object and of its subobjects from persistent storage, overwriting any changes made after the last call to the Save method.
Save | Recursively writes the current values of all properties of the object and its subobjects to persistent storage.
SetAutoPollConfig | Sets the configuration for automatic polling of the upstream proxy server on the primary route for array configuration information.
SetRedirectHostAndPorts | Sets the name of the host for redirecting requests from Web proxy clients and the ports on which it listens.
SetServerAndPort | Sets the name of the upstream proxy server on the primary route and the ports on which it listens.

Properties

The FPCPrimaryRoute object has the following properties.

Property | Description
AuthenticationEnabled | Gets or sets a Boolean value that indicates whether the authentication of downstream clients by the upstream proxy server on the primary route is enabled.
AuthenticationType | Gets or sets a value from the FpcAuthType enumerated type that specifies the type of authentication that the upstream proxy server on the primary route uses if authentication is enabled.
AutomaticPollConfig | Gets a Boolean value that indicates whether polling of the upstream proxy server on the primary route for array configuration information is enabled.
BackupRoute | Gets an FPCBackupRoute object that represents the backup route, which is used to route Web proxy client requests when the upstream proxy server on the primary route is unavailable.
Credentials | Gets an FPCCredentials object that represents the credentials to be supplied by the ISA Server computer for authenticating a connection to the upstream proxy server on the primary route.
EnableAutoDial | Gets or sets a Boolean value that indicates whether automatic dialing is enabled.
PollAtUrl | Gets the URL at which to poll for the upstream server's array configuration information. This property is valid only if the AutomaticPollConfig property is set to True.
RedirectHost | Gets the name of the host for redirecting requests from Web proxy clients.
RedirectHostPort | Gets the port on which the host for redirecting requests from Web proxy clients listens.
RedirectHostSSLPort | Gets the port on which the upstream proxy server on the primary route listens for SSL connections.
RouteServerName | Gets the name of the upstream proxy server on the primary route.
RouteServerPort | Gets the port on which the upstream proxy server on the primary route listens.
RouteServerSSLPort | Gets the port on which the upstream proxy server on the primary route listens for SSL connections.
RouteType | Gets or sets a value from the FpcPrimaryRouteType enumerated type that specifies whether requests from Web proxy clients are sent directly to the requested destination, to an upstream proxy server, or to an alternate host.

Remarks

This object implements the IFPCPrimaryRoute interface.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

COM Objects


IFPCPrimaryRoute.AuthenticationEnabled (2 Parameters) property [ISA Server 2004]

AuthenticationEnabled Property of IFPCPrimaryRoute[C++]

FPCPrimaryRoute.AuthenticationEnabled [Visual Basic]

[C++]

The AuthenticationEnabled property gets or sets a Boolean value that indicates whether the authentication of downstream clients by the upstream proxy server on the primary route is enabled.

HRESULT get_AuthenticationEnabled(
  VARIANT_BOOL* pfEnabled
);

HRESULT put_AuthenticationEnabled(
  VARIANT_BOOL fEnabled
);

Parameters

pfEnabled
Pointer to a Boolean variable that is set on return to VARIANT_TRUE if the authentication of downstream clients by the upstream proxy server on the primary route is enabled, or to VARIANT_FALSE if such authentication is disabled.
fEnabled
Boolean value that specifies whether the authentication of downstream clients by the upstream proxy server on the primary route is enabled.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write.

Authentication should not be enabled unless a valid FPCCredentials object can be retrieved using the Credentials property.

[Visual Basic]

The AuthenticationEnabled property gets or sets a Boolean value that indicates whether the authentication of downstream clients by the upstream proxy server on the primary route is enabled.

Property AuthenticationEnabled As Boolean

Property Value

Boolean value that specifies whether the authentication of downstream clients by the upstream proxy server on the primary route is enabled.

Remarks

This property is read/write.

Authentication should not be enabled unless a valid FPCCredentials object can be retrieved using the Credentials property.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCPrimaryRoute


IFPCPrimaryRoute.AuthenticationType (2 Parameters) property [ISA Server 2004]

AuthenticationType Property of IFPCPrimaryRoute[C++]

FPCPrimaryRoute.AuthenticationType [Visual Basic]

[C++]

The AuthenticationType property gets or sets a value from the FpcAuthType enumerated type that specifies the type of authentication that the upstream proxy server on the primary route uses if authentication is enabled.

HRESULT get_AuthenticationType(
  FpcAuthType* pAuthType
);

HRESULT put_AuthenticationType(
  FpcAuthType AuthType
);

Parameters

pAuthType
Pointer to a variable that on return receives the value from the FpcAuthType enumerated type that specifies the type of authentication that the upstream proxy server on the primary route uses if authentication is enabled.
AuthType
Value from the FpcAuthType enumerated type that specifies the type of authentication that the upstream proxy server on the primary route uses if authentication is enabled.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write.

Note that Basic authentication (fpcUiAuthBasic) does not use encryption.

[Visual Basic]

The AuthenticationType property gets or sets a value from the FpcAuthType enumerated type that specifies the type of authentication that the upstream proxy server on the primary route uses if authentication is enabled.

Property AuthenticationType As FpcAuthType

Property Value

Value from the FpcAuthType enumerated type that specifies the type of authentication that the upstream proxy server on the primary route uses if authentication is enabled.

Remarks

This property is read/write.

Note that Basic authentication (fpcUiAuthBasic) does not use encryption.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCPrimaryRoute


IFPCPrimaryRoute.AutomaticPollConfig(VARIANT_BOOL) property [ISA Server 2004]

AutomaticPollConfig Property of IFPCPrimaryRoute[C++]

FPCPrimaryRoute.AutomaticPollConfig [Visual Basic]

[C++]

The AutomaticPollConfig property gets a Boolean value that indicates whether polling of the upstream proxy server on the primary route for array configuration information is enabled.

HRESULT get_AutomaticPollConfig(
  VARIANT_BOOL* pfEnabled
);

Parameters

pfEnabled
Pointer to a Boolean variable that is set on return to VARIANT_TRUE if polling of the upstream proxy server on the primary route is enabled, or to VARIANT_FALSE if such polling is disabled.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only. It can be modified by calling the SetAutoPollConfig method.

[Visual Basic]

The AutomaticPollConfig property gets a Boolean value that indicates whether polling of the upstream proxy server on the primary route for array configuration information is enabled.

Property AutomaticPollConfig As Boolean

Property Value

Boolean value that indicates whether polling of the upstream proxy server on the primary route for array configuration information is enabled.

Remarks

This property is read-only. It can be modified by calling the SetAutoPollConfig method.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCPrimaryRoute


IFPCPrimaryRoute | FPCPrimaryRoute BackupRoute property [ISA Server 2004]

BackupRoute Property of IFPCPrimaryRoute[C++]

FPCPrimaryRoute.BackupRoute [Visual Basic]

[C++]

The BackupRoute property gets an FPCBackupRoute object that represents the backup route, which is used to route Web proxy client requests when the upstream proxy server on the primary route is unavailable.

HRESULT get_BackupRoute(
  IFPCBackupRoute** ppBackupRoute
);

Parameters

ppBackupRoute
Address of an interface pointer that on return points to an IFPCBackupRoute interface that represents the backup route.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The BackupRoute property gets an FPCBackupRoute object that represents the backup route, which is used to route Web proxy client requests when the upstream proxy server on the primary route is unavailable.

Property BackupRoute As FPCBackupRoute

Property Value

Reference to an FPCBackupRoute object that represents the backup route.

Remarks

This property is read-only.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCPrimaryRoute


IFPCPrimaryRoute | FPCPrimaryRoute Credentials property [ISA Server 2004]

Credentials Property of IFPCPrimaryRoute[C++]

FPCPrimaryRoute.Credentials [Visual Basic]

[C++]

The Credentials property gets an FPCCredentials object that represents the credentials to be supplied by the ISA Server computer for authenticating a connection to the upstream proxy server on the primary route.

HRESULT get_Credentials(
  IFPCCredentials** ppCredentials
);

Parameters

ppCredentials
Address of an interface pointer that on return points to an IFPCCredentials interface that represents the credentials to be supplied by the ISA Server computer for authenticating a connection to the upstream proxy server on the primary route.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The Credentials property gets an FPCCredentials object that represents the credentials to be supplied by the ISA Server computer for authenticating a connection to the upstream proxy server on the primary route.

Property Credentials As FPCCredentials

Property Value

Reference to an FPCCredentials object that represents the credentials to be supplied by the ISA Server computer for authenticating a connection to the upstream proxy server on the primary route.

Remarks

This property is read-only.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCPrimaryRoute


IFPCPrimaryRoute | FPCPrimaryRoute EnableAutoDial property [ISA Server 2004]

EnableAutoDial Property of IFPCPrimaryRoute[C++]

FPCPrimaryRoute.EnableAutoDial [Visual Basic]

[C++]

The EnableAutoDial property gets or sets a Boolean value that indicates whether automatic dialing is enabled.

HRESULT get_EnableAutoDial(
  VARIANT_BOOL* pfEnabled
);

HRESULT put_EnableAutoDial(
  VARIANT_BOOL fEnabled
);

Parameters

pfEnabled
Pointer to a Boolean variable that is set on return to VARIANT_TRUE if automatic dialing is enabled, or to VARIANT_FALSE if automatic dialing is disabled.
fEnabled
Boolean value that indicates whether automatic dialing is enabled.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write.

[Visual Basic]

The EnableAutoDial property gets or sets a Boolean value that indicates whether automatic dialing is enabled.

Property EnableAutoDial As Boolean

Property Value

Boolean value that indicates whether automatic dialing is enabled.

Remarks

This property is read/write.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCPrimaryRoute


IFPCPrimaryRoute | FPCPrimaryRoute PollAtURL(BSTR) property [ISA Server 2004]

PollAtURL Property of IFPCPrimaryRoute[C++]

FPCPrimaryRoute.PollAtURL [Visual Basic]

[C++]

The PollAtURL property gets the URL at which to poll for the upstream server's array configuration information. This property is valid only if the AutomaticPollConfig property is set to VARIANT_TRUE.

HRESULT get_PollAtURL(
  BSTR* pbstrURL
);

Parameters

pbstrURL
Pointer to a BSTR that is set on return to a string value specifying the URL at which to poll for the array configuration information.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

The URL retrieved is typically hosted on the upstream proxy server on the primary route.

[Visual Basic]

The PollAtURL property gets the URL at which to poll for the upstream server's array configuration information. This property is valid only if the AutomaticPollConfig property is set to True.

Property PollAtURL As String

Property Value

String that specifies the URL at which to poll for the array configuration information.

Remarks

This property is read-only.

The URL retrieved is typically hosted on the upstream proxy server on the primary route.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCPrimaryRoute


IFPCPrimaryRoute | FPCPrimaryRoute RedirectHost(BSTR) property [ISA Server 2004]

RedirectHost Property of IFPCPrimaryRoute[C++]

FPCPrimaryRoute.RedirectHost [Visual Basic]

[C++]

The RedirectHost property gets the name of the host for redirecting requests from Web proxy clients.

HRESULT get_RedirectHost(
  BSTR* pbstrHost
);

Parameters

pbstrHost
Pointer to a BSTR that is set on return to a string value specifying the host for redirecting requests from Web proxy clients.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The RedirectHost property gets the name of the host for redirecting requests from Web proxy clients.

Property RedirectHost As String

Property Value

String that specifies the host for redirecting requests from Web proxy clients.

Remarks

This property is read-only.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCPrimaryRoute


IFPCPrimaryRoute | FPCPrimaryRoute RedirectHostPort property [ISA Server 2004]

RedirectHostPort Property of IFPCPrimaryRoute[C++]

FPCPrimaryRoute.RedirectHostPort [Visual Basic]

[C++]

The RedirectHostPort property gets the port on which the host for redirecting requests from Web proxy clients listens.

HRESULT get_RedirectHostPort(
  long* plPort
);

Parameters

plPort
Pointer to a variable that receives a 32-bit integer specifying the port number. It can be a value from 1 to 65535.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The RedirectHostPort property gets the port on which the host for redirecting requests from Web proxy clients listens.

Property RedirectHostPort As Long

Property Value

A 32-bit integer that specifies the port number. It can be a value from 1 to 65535.

Remarks

This property is read-only.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCPrimaryRoute


IFPCPrimaryRoute.RedirectHostSSLPort(long) property [ISA Server 2004]

RedirectHostSSLPort Property of IFPCPrimaryRoute[C++]

FPCPrimaryRoute.RedirectHostSSLPort [Visual Basic]

[C++]

The RedirectHostSSLPort property gets the port on which the host for redirecting requests from Web proxy clients listens for SSL connections.

HRESULT get_RedirectHostSSLPort(
  long* plSSLPort
);

Parameters

plSSLPort
Pointer to a variable that receives a 32-bit integer specifying the port number. It can be a value from 1 to 65535.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The RedirectHostSSLPort property gets the port on which the host for redirecting requests from Web proxy clients listens for SSL connections.

Property RedirectHostSSLPort As Long

Property Value

A 32-bit integer that specifies the port number. It can be a value from 1 to 65535.

Remarks

This property is read-only.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCPrimaryRoute


IFPCPrimaryRoute | FPCPrimaryRoute Refresh method [ISA Server 2004]

IFPCPrimaryRoute::Refresh[C++]

FPCPrimaryRoute.Refresh [Visual Basic]

[C++]

The Refresh method recursively reads all of the properties of the object and of its subobjects from persistent storage, overwriting any changes made after the last call to the Save method.

HRESULT Refresh();

Parameters

This method has no parameters.

Return Values

This method returns S_OK if the call is successful; otherwise, it returns an error code.
[Visual Basic]

The Refresh method recursively reads all of the properties of the object and of its subobjects from persistent storage, overwriting any changes made after the last call to the Save method.

Sub Refresh()

Parameters

This method has no parameters.

Return Values

This method has no return values. If the call is unsuccessful, an error is raised that can be intercepted by using an error handler.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCPrimaryRoute


IFPCPrimaryRoute | FPCPrimaryRoute RouteServerName property [ISA Server 2004]

RouteServerName Property of IFPCPrimaryRoute[C++]

FPCPrimaryRoute.RouteServerName [Visual Basic]

[C++]

The RouteServerName property gets the name of the upstream proxy server on the primary route.

HRESULT get_RouteServerName(
  BSTR* pbstrURL
);

Parameters

pbstrURL
Pointer to a BSTR that is set on return to a string value specifying the name of the upstream proxy server on the primary route.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The RouteServerName property gets the name of the upstream proxy server on the primary route.

Property RouteServerName As String

Property Value

String that specifies the name of the upstream proxy server on the primary route.

Remarks

This property is read-only.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCPrimaryRoute


IFPCPrimaryRoute | FPCPrimaryRoute RouteServerPort property [ISA Server 2004]

RouteServerPort Property of IFPCPrimaryRoute[C++]

FPCPrimaryRoute.RouteServerPort [Visual Basic]

[C++]

The RouteServerPort property gets the port on which the upstream proxy server on the primary route listens.

HRESULT get_RouteServerPort(
  long* plPort
);

Parameters

plPort
Pointer to a variable that receives a 32-bit integer specifying the port number. It can be a value from 1 to 65535.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The RouteServerPort property gets the port on which the upstream proxy server on the primary route listens.

Property RouteServerPort As Long

Property Value

A 32-bit integer that specifies the port number. It can be a value from 1 to 65535.

Remarks

This property is read-only.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCPrimaryRoute


IFPCPrimaryRoute.RouteServerSSLPort(long) property [ISA Server 2004]

RouteServerSSLPort Property of IFPCPrimaryRoute[C++]

FPCPrimaryRoute.RouteServerSSLPort [Visual Basic]

[C++]

The RouteServerSSLPort property gets the port on which the upstream proxy server on the primary route listens for SSL connections.

HRESULT get_RouteServerSSLPort(
  long* plSSLPort
);

Parameters

plSSLPort
Pointer to a variable that on return receives a 32-bit integer specifying the port number. It can be a value from 1 to 65535.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The RouteServerSSLPort property gets the port on which the upstream proxy server on the primary route listens for SSL connections.

Property RouteServerSSLPort As Long

Property Value

A 32-bit integer that specifies the port number. It can be a value from 1 to 65535.

Remarks

This property is read-only.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCPrimaryRoute


IFPCPrimaryRoute | FPCPrimaryRoute RouteType property [ISA Server 2004]

RouteType Property of IFPCPrimaryRoute[C++]

FPCPrimaryRoute.RouteType [Visual Basic]

[C++]

The RouteType property gets or sets a value from the FpcPrimaryRouteType enumerated type that specifies whether requests from Web proxy clients are sent directly to the requested destination, to an upstream proxy server, or to an alternate host.

HRESULT get_RouteType(
  FpcPrimaryRouteType* pRouteType
);

HRESULT put_RouteType(
  FpcPrimaryRouteType RouteType
);

Parameters

pRouteType
Pointer to a variable that on return receives a value from the FpcPrimaryRouteType enumerated type specifying whether requests from Web proxy clients are sent directly to the requested destination, to an upstream proxy server, or to an alternate host.
RouteType
Value from the FpcPrimaryRouteType enumerated type that specifies whether requests from Web proxy clients are sent directly to the requested destination, to an upstream proxy server, or to an alternate host.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write.

[Visual Basic]

The RouteType property gets or sets a value from the FpcPrimaryRouteType enumerated type that specifies whether requests from Web proxy clients are sent directly to the requested destination, to an upstream proxy server, or to an alternate host.

Property RouteType As FpcPrimaryRouteType

Property Value

Value from the FpcPrimaryRouteType enumerated type that specifies whether requests from Web proxy clients are sent directly to the requested destination, to an upstream proxy server, or to an alternate host.

Remarks

This property is read/write.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCPrimaryRoute


IFPCPrimaryRoute | FPCPrimaryRoute Save (2 Parameters) method [ISA Server 2004]

IFPCPrimaryRoute::Save[C++]

FPCPrimaryRoute.Save [Visual Basic]

[C++]

The Save method recursively writes the current values of all properties of the object and its subobjects to persistent storage. It is important to remember that any changes made by scripts and programs will not be saved until after the Save method is called.

HRESULT Save(
  VARIANT_BOOL fResetRequiredServices,
  VARIANT_BOOL fReloadConfiguration
);

Parameters

fResetRequiredServices
[in, optional] Boolean value that indicates whether to restart the services that need to be restarted for any of the changes saved to take effect. The default value is VARIANT_FALSE.
fReloadConfiguration
[in, optional] Boolean value that indicates whether the call will include synchronous reloading of all changes that can be applied dynamically without restarting services. The default value is VARIANT_TRUE.

Return Values

This method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

Configuration changes are applied only after the new settings are written to persistent storage and reloaded to the services that use them. Most changes can be applied dynamically without restarting any services. However, some changes can take effect only after the Microsoft Firewall service is restarted. For more information, see Restarting Services after Configuration Changes.

ISA Server maintains a bitmask that specifies which services need to be started for currently unsaved changes to take effect. This bitmask can be retrieved by calling the GetServiceRestartMask method on an object that contains this object as a subobject. Calling the Save method clears all of the bits in this bitmask even if the fResetRequiredServices parameter is set to VARIANT_FALSE.

If the fReloadConfiguration parameter is set to VARIANT_FALSE the current values of the properties of the object and its subobjects will be written to persistent storage without updating the configuration being used by the ISA Server services. The configuration used by each service will not be updated until the service is restarted or the new settings are reloaded by another call to Save.

[Visual Basic]

The Save method recursively writes the current values of all properties of the object and its subobjects to persistent storage. It is important to remember that any changes made by scripts and programs will not be saved until after the Save method is called.

Sub Save( _
  [ ByVal fResetRequiredServices As Boolean ], _
  [ ByVal fReloadConfiguration As Boolean ] _
)

Parameters

fResetRequiredServices
[in, optional] Boolean value that indicates whether to restart the services that need to be restarted for any of the changes saved to take effect. The default value is False.
fReloadConfiguration
[in, optional] Boolean value that indicates whether the call will include synchronous reloading of all the saved configuration changes that can be applied dynamically without restarting services. The default value is True.

Return Values

This method has no return values. If the call is unsuccessful, an error is raised that can be intercepted by using an error handler.

Remarks

Configuration changes are applied only after the new settings are written to persistent storage and reloaded to the services that use them. Most changes can be applied dynamically without restarting any services. However, some changes can take effect only after the Microsoft Firewall service is restarted. For more information, see Restarting Services after Configuration Changes.

ISA Server maintains a bitmask that specifies which services need to be started for currently unsaved changes to take effect. This bitmask can be retrieved by calling the GetServiceRestartMask method on an object that contains this object as a subobject. Calling the Save method clears all of the bits in this bitmask even if the fResetRequiredServices parameter is set to False.

If the fReloadConfiguration parameter is set to False the current values of the properties of the object and its subobjects will be written to persistent storage without updating the configuration being used by the ISA Server services. The configuration used by each service will not be updated until the service is restarted or the new settings are reloaded by another call to Save.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCPrimaryRoute


IFPCPrimaryRoute | FPCPrimaryRoute SetAutoPollConfig method [ISA Server 2004]

IFPCPrimaryRoute::SetAutoPollConfig[C++]

FPCPrimaryRoute.SetAutoPollConfig [Visual Basic]

[C++]

The SetAutoPollConfig method sets the configuration for automatic polling of the upstream proxy server on the primary route for array configuration information.

HRESULT SetAutoPollConfig(
  VARIANT_BOOL fSetAuto,
  BSTR AutoPollUrl
);

Parameters

fSetAuto
[in] Required. Boolean value that indicates whether polling of the upstream proxy server on the primary route for array configuration information is enabled.
AutoPollUrl
[in, optional] BSTR that specifies the URL, usually at the upstream proxy server, to poll for the array configuration information. If fSetAuto is set to VARIANT_TRUE, this parameter must hold a valid URL; otherwise, this parameter is ignored.

Return Values

This method returns S_OK if the call is successful; otherwise, it returns an error code.
[Visual Basic]

The SetAutoPollConfig method sets the configuration for automatic polling of the upstream proxy server on the primary route for array configuration information.

Sub SetAutoPollConfig( _
  ByVal fSetAuto As Boolean, _
  [ ByVal AutoPollUrl As String ] _
)

Parameters

fSetAuto
[in] Required. Boolean value that indicates whether polling of the upstream proxy server on the primary route for array configuration information is enabled.
AutoPollUrl
[in, optional] String value that specifies the URL, usually at the upstream proxy server, to poll for the array configuration information. If fSetAuto is set to True, this parameter must hold a valid URL; otherwise, this parameter is ignored.

Return Values

This method has no return values. If the call is unsuccessful, an error is raised that can be intercepted by using an error handler.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCPrimaryRoute


IFPCPrimaryRoute.SetRedirectHostAndPorts (3 Parameters) method [ISA Server 2004]

IFPCPrimaryRoute::SetRedirectHostAndPorts[C++]

FPCPrimaryRoute.SetRedirectHostAndPorts [Visual Basic]

[C++]

The SetRedirectHostAndPorts method sets the name of the host for redirecting requests from Web proxy clients and the ports on which it listens.

HRESULT SetRedirectHostAndPorts(
  BSTR Host,
  long RedirectHostPort,
  long RedirectHostSSLPort
);

Parameters

Host
[in] BSTR that specifies the name of the host.
RedirectHostPort
[in] A 32-bit integer that specifies the port on which the host listens. It can have a value from 1 to 65535.
RedirectHostSSLPort
[in] A 32-bit integer that specifies the port on which the host listens for SSL requests. It can have a value from 1 to 65535.

Return Values

This method returns S_OK if the call is successful; otherwise, it returns an error code.
[Visual Basic]

The SetRedirectHostAndPorts method sets the name of the host for redirecting requests from Web proxy clients and the ports on which it listens.

Sub SetRedirectHostAndPorts( _
  ByVal Host As String, _
  ByVal RedirectHostPort As Long, _
  ByVal RedirectHostSSLPort As Long _
)

Parameters

Host
[in] String that specifies the name of the host.
RedirectHostPort
[in] A 32-bit integer that specifies the port on which the host listens. It can have a value from 1 to 65535.
RedirectHostSSLPort
[in] A 32-bit integer that specifies the port on which the host listens for SSL requests. It can have a value from 1 to 65535.

Return Values

This method has no return values. If the call is unsuccessful, an error is raised that can be intercepted by using an error handler.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCPrimaryRoute


IFPCPrimaryRoute | FPCPrimaryRoute SetServerAndPort method [ISA Server 2004]

IFPCPrimaryRoute::SetServerAndPort[C++]

FPCPrimaryRoute.SetServerAndPort [Visual Basic]

[C++]

The SetServerAndPort method sets the name of the upstream proxy server on the primary route and the ports on which it listens.

HRESULT SetServerAndPort(
  BSTR ServerName,
  long Port,
  long SSLPort
);

Parameters

ServerName
[in] BSTR that specifies the name of the upstream proxy server on the primary route.
Port
A 32-bit integer that specifies the port number on which the upstream proxy server listens. It can have a value from 1 to 65535.
SSLPort
A 32-bit integer that specifies the port number on which the upstream proxy server listens for SSL requests. It can have a value from 1 to 65535.

Return Values

This method returns S_OK if the call is successful; otherwise, it returns an error code.
[Visual Basic]

The SetServerAndPort method sets the name of the upstream proxy server on the primary route and the ports on which it listens.

Sub SetServerAndPort( _
  ByVal ServerName As String, _
  ByVal Port As Long, _
  ByVal SSLPort As Long _
)

Parameters

ServerName
[in] String that specifies the name of the upstream proxy server on the primary route.
Port
A 32-bit integer that specifies the port number on which the upstream proxy server listens. It can have a value from 1 to 65535.
SSLPort
A 32-bit integer that specifies the port number on which the upstream proxy server listens for SSL requests. It can have a value from 1 to 65535.

Return Values

This method has no return values. If the call is unsuccessful, an error is raised that can be intercepted by using an error handler.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCPrimaryRoute


FPCProtocolConnection object [ISA Server 2004]

FPCProtocolConnection

The FPCProtocolConnection object represents a single connection in a single Microsoft Firewall service protocol. This object is typically an element of an FPCProtocolConnections collection.

Click here to see the ISA Server object hierarchy.

Methods

The FPCProtocolConnection object defines the following methods.

Method | Description
Refresh | Reads all the properties of the object from persistent storage, discarding any changes that were not saved.
SetICMP | Sets all of the parameters of an ICMP connection.
SetTCP | Sets all of the parameters of a TCP connection.
SetUDP | Sets all of the parameters of a UDP connection.

Properties

The FPCProtocolConnection object has the following properties.

Property | Description
ICMPCode | Gets the ICMP code for the connection.
ICMPType | Gets the ICMP type for the connection.
PortHigh | Gets a port number designating the high end of the range.
PortLow | Gets a port number designating the low end of the range.
Protocol | Gets a value from the FpcConnectionProtocolType enumerated type that specifies the communication protocol used in the connection.
RawDirection | Gets a value from the FpcUDPConnectionDirectionType enumerated type that specifies the direction in which a raw connection can be opened.
TCPDirection | Gets a value from the FpcConnectionDirectionType enumerated type that specifies the direction in which a TCP connection can be opened.
UDPDirection | Gets a value from the FpcUDPConnectionDirectionType enumerated type that specifies the direction in which a UDP connection can be opened.

Remarks

This object implements the IFPCProtocolConnection interface.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

COM Objects


IFPCProtocolConnection.ICMPCode(long) property [ISA Server 2004]

ICMPCode Property of IFPCProtocolConnection[C++]

FPCProtocolConnection.ICMPCode [Visual Basic]

[C++]

The ICMPCode property gets the ICMP code for the connection. The ICMP code is a subdescriptor of the ICMP type.

HRESULT get_ICMPCode(
  long* plCode
);

Parameters

plCode
Pointer to a variable that on return receives a 32-bit integer specifying the ICMP code.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only. It can be modified by calling the SetICMP method. The possible values are 0 to 255.

[Visual Basic]

The ICMPCode property gets the ICMP code for the connection. The ICMP code is a subdescriptor of the ICMP type.

Property ICMPCode As Long

Property Value

A 32-bit integer that specifies the ICMP code.

Remarks

This property is read-only. It can be modified by calling the SetICMP method. The possible values are 0 to 255.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCProtocolConnection


IFPCProtocolConnection.ICMPType(long) property [ISA Server 2004]

ICMPType Property of IFPCProtocolConnection[C++]

FPCProtocolConnection.ICMPType [Visual Basic]

[C++]

The ICMPType property gets the ICMP type for the connection.

HRESULT get_ICMPType(
  long* plType
);

Parameters

plType
Pointer to a variable that on return receives a 32-bit integer specifying the ICMP type.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only. It can be modified by calling the SetICMP method. The possible values are 0 to 255.

[Visual Basic]

The ICMPType property gets the ICMP type for the connection.

Property ICMPType As Long

Property Value

A 32-bit integer that specifies the ICMP type.

Remarks

This property is read-only. It can be modified by calling the SetICMP method. The possible values are 0 to 255.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCProtocolConnection


IFPCProtocolConnection.PortHigh(long) property [ISA Server 2004]

PortHigh Property of IFPCProtocolConnection[C++]

FPCProtocolConnection.PortHigh [Visual Basic]

[C++]

The PortHigh property gets a port number designating the high end of the range.

HRESULT get_PortHigh(
  long* plPort
);

Parameters

plPort
Pointer to a variable that on return receives a 32-bit integer specifying the high end of the port number range.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only. It can be modified by calling the SetTCP or SetUDP method, whichever is applicable. The possible values are 1 to 65535.

It can be set equal to the PortLow property to indicate that there is only one port, not a range of ports.

[Visual Basic]

The PortHigh property gets a port number designating the high end of the range.

Property PortHigh As Long

Property Value

A 32-bit integer that specifies the high end of the port number range.

Remarks

This property is read-only. It can be modified by calling the SetTCP or SetUDP method, whichever is applicable. The possible values are 1 to 65535.

It can be set equal to the PortLow property to indicate that there is only one port, not a range of ports.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCProtocolConnection


IFPCProtocolConnection.PortLow(long) property [ISA Server 2004]

PortLow Property of IFPCProtocolConnection[C++]

FPCProtocolConnection.PortLow [Visual Basic]

[C++]

The PortLow property gets a port number designating the low end of the range.

HRESULT get_PortLow(
  long* plPort
);

Parameters

plPort
Pointer to a variable that on return receives a 32-bit integer specifying the low end of the port number range.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only. It can be modified by calling the SetTCP or SetUDP method, whichever is applicable. The possible values are 1 to 65535.

It can be set equal to the PortHigh property to indicate that there is only one port, not a range of ports.

[Visual Basic]

The PortLow property gets a port number designating the low end of the range.

Property PortLow As Long

Property Value

A 32-bit integer that specifies the low end of the port number range.

Remarks

This property is read-only. It can be modified by calling the SetTCP or SetUDP method, whichever is applicable. The possible values are 1 to 65535.

It can be set equal to the PortHigh property to indicate that there is only one port, not a range of ports.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCProtocolConnection


IFPCProtocolConnection.Protocol (1 Parameter) property [ISA Server 2004]

Protocol Property of IFPCProtocolConnection[C++]

FPCProtocolConnection.Protocol [Visual Basic]

[C++]

The Protocol property gets a value from the FpcConnectionProtocolType enumerated type that specifies the communication protocol used in the connection. The protocol can be either TCP or UDP.

HRESULT get_Protocol(
  FpcConnectionProtocolType* pConnectionProtocolType
);

Parameters

pConnectionProtocolType
Pointer to a variable that on return receives a value from the FpcConnectionProtocolType enumerated type specifying the communication protocol used in the connection.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The Protocol property gets a value from the FpcConnectionProtocolType enumerated type that specifies the communication protocol used in the connection. The protocol can be either TCP or UDP.

Property Protocol As FpcConnectionProtocolType

Property Value

Value from the FpcConnectionProtocolType enumerated type that specifies the communication protocol used in the connection.

Remarks

This property is read-only.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCProtocolConnection


IFPCProtocolConnection.RawDirection (1 Parameter) property [ISA Server 2004]

RawDirection Property of IFPCProtocolConnection[C++]

FPCProtocolConnection.RawDirection [Visual Basic]

[C++]

The RawDirection property gets a value from the FpcUDPConnectionDirectionType enumerated type that specifies the direction in which a raw connection can be opened. A raw connection is a connection in any protocol other than the primary protocols supported by ISA Server, which are TCP, UDP, ICMP, and GRE. Raw connections can be opened to receive only, to send only, to receive and then send, or to send and then receive.

HRESULT get_RawDirection(
  FpcUDPConnectionDirectionType* pDirection
);

Parameters

pDirection
Pointer to a variable that on return receives a value from the FpcUDPConnectionDirectionType enumerated type specifying the direction in which the raw connection can be opened.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The RawDirection property gets a value from the FpcUDPConnectionDirectionType enumerated type that specifies the direction in which a raw connection can be opened. A raw connection is a connection in any protocol other than the primary protocols supported by ISA Server, which are TCP, UDP, ICMP, and GRE. Raw connections can be opened to receive only, to send only, to receive and then send, or to send and then receive.

Property RawDirection As FpcUDPConnectionDirectionType

Property Value

Value from the FpcUDPConnectionDirectionType enumerated type that specifies the direction in which the raw connection can be opened.

Remarks

This property is read-only.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCProtocolConnection


IFPCProtocolConnection | FPCProtocolConnection Refresh method [ISA Server 2004]

IFPCProtocolConnection::Refresh[C++]

FPCProtocolConnection.Refresh [Visual Basic]

[C++]

The Refresh method reads all the properties of the object from persistent storage.

HRESULT Refresh();

Parameters

This method has no parameters.

Return Values

This method returns S_OK if the call is successful; otherwise, it returns an error code.
[Visual Basic]

The Refresh method reads all the properties of the object from persistent storage.

Sub Refresh()

Parameters

This method has no parameters.

Return Values

This method has no return values. If the call is unsuccessful, an error is raised that can be intercepted by using an error handler.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCProtocolConnection


IFPCProtocolConnection | FPCProtocolConnection SetICMP method [ISA Server 2004]

IFPCProtocolConnection::SetICMP[C++]

FPCProtocolConnection.SetICMP [Visual Basic]

[C++]

The SetICMP method sets all of the parameters of an ICMP connection.

HRESULT SetICMP(
  long Code,
  long Type,
  FpcUDPConnectionDirectionType Direction
);

Parameters

Code
[in] A 32-bit integer that specifies the ICMP code.
Type
[in] A 32-bit integer that specifies the ICMP type.
Direction
[in] Value from the FpcUDPConnectionDirectionType enumerated type that specifies the direction in which the connection can be opened.

Return Values

This method returns S_OK if the call is successful; otherwise, it returns an error code.
[Visual Basic]

The SetICMP method sets all of the parameters of an ICMP connection.

Sub SetICMP( _
  ByVal Code As Long, _
  ByVal Type As Long, _
  ByVal Direction As FpcUDPConnectionDirectionType _
)

Parameters

Code
[in] A 32-bit integer that specifies the ICMP code.
Type
[in] A 32-bit integer that specifies the ICMP type.
Direction
[in] Value from the FpcUDPConnectionDirectionType enumerated type that specifies the direction in which the connection can be opened.

Return Values

This method has no return values. If the call is unsuccessful, an error is raised that can be intercepted by using an error handler.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCProtocolConnection


IFPCProtocolConnection | FPCProtocolConnection SetTCP method [ISA Server 2004]

IFPCProtocolConnection::SetTCP[C++]

FPCProtocolConnection.SetTCP [Visual Basic]

[C++]

The SetTCP method sets all of the parameters of a TCP connection.

HRESULT SetTCP(
  long PortLo,
  long PortHi,
  FpcConnectionDirectionType Direction
);

Parameters

PortLo
[in] A 32-bit integer that specifies the low end of the port number range. It can have a value from 1 through 65535.
PortHi
[in] A 32-bit integer that specifies the high end of the port number range. It can have a value from 1 through 65535, but must be equal to or greater than the value of the PortLo parameter.
Direction
[in] Value from the FpcConnectionDirectionType enumerated type that specifies the direction in which the connection can be opened.

Return Values

This method returns S_OK if the call is successful; otherwise, it returns an error code.
[Visual Basic]

The SetTCP method sets all of the parameters of a TCP connection.

Sub SetTCP( _
  ByVal PortLo As Long, _
  ByVal PortHi As Long, _
  ByVal Direction As FpcConnectionDirectionType _
)

Parameters

PortLo
[in] A 32-bit integer that specifies the low end of the port number range. It can have a value from 1 through 65535.
PortHi
[in] A 32-bit integer that specifies the high end of the port number range. It can have a value from 1 through 65535, but must be equal to or greater than the value of the PortLo parameter.
Direction
[in] Value from the FpcConnectionDirectionType enumerated type that specifies the direction in which the connection can be opened.

Return Values

This method has no return values. If the call is unsuccessful, an error is raised that can be intercepted by using an error handler.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCProtocolConnection


IFPCProtocolConnection | FPCProtocolConnection SetUDP method [ISA Server 2004]

IFPCProtocolConnection::SetUDP[C++]

FPCProtocolConnection.SetUDP [Visual Basic]

[C++]

The SetUDP method sets all of the parameters of a UDP connection.

HRESULT SetUDP(
  long PortLo,
  long PortHi,
  FpcUDPConnectionDirectionType Direction
);

Parameters

PortLo
[in] A 32-bit integer that specifies the low end of the port number range. It can have a value from 1 through 65535.
PortHi
[in] A 32-bit integer that specifies the high end of the port number number. It can have a value from 1 through 65535, but must be equal to or greater than the value of the PortLo parameter.
Direction
[in] Value from the FpcUDPConnectionDirectionType enumerated type that specifies the direction in which the connection can be opened.

Return Values

This method returns S_OK if the call is successful; otherwise, it returns an error code.
[Visual Basic]

The SetUDP method sets all of the parameters of a UDP connection.

Sub SetUDP( _
  ByVal PortLo As Long, _
  ByVal PortHi As Long, _
  ByVal Direction As FpcUDPConnectionDirectionType _
)

Parameters

PortLo
[in] A 32-bit integer that specifies the low end of the port number range. It can have a value from 1 through 65535.
PortHi
[in] A 32-bit integer that specifies the high end of the port number number. It can have a value from 1 through 65535, but must be equal to or greater than the value of the PortLo parameter.
Direction
[in] Value from the FpcUDPConnectionDirectionType enumerated type that specifies the direction in which the connection can be opened.

Return Values

This method has no return values. If the call is unsuccessful, an error is raised that can be intercepted by using an error handler.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCProtocolConnection


IFPCProtocolConnection.TCPDirection (1 Parameter) property [ISA Server 2004]

TCPDirection Property of IFPCProtocolConnection[C++]

FPCProtocolConnection.TCPDirection [Visual Basic]

[C++]

The TCPDirection property gets a value from the FpcConnectionDirectionType enumerated type that specifies the direction in which a TCP connection can be opened. TCP connections can be opened for inbound or outbound traffic.

HRESULT get_TCPDirection(
  FpcConnectionDirectionType* pTCPDirection
);

Parameters

pTCPDirection
Pointer to a variable that on return receives a value from the FpcConnectionDirectionType enumerated type specifying the direction in which the TCP connection can be opened.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only. It is initially set when the object is created by calling the AddTCP method of an FPCProtocolConnections collection and can be modified by calling the SetTCP method.

[Visual Basic]

The TCPDirection property gets a value from the FpcConnectionDirectionType enumerated type that specifies the direction in which a TCP connection can be opened. TCP connections can be opened for inbound or outbound traffic.

Property TCPDirection As FpcConnectionDirectionType

Property Value

Value from the FpcConnectionDirectionType enumerated type that specifies the direction in which the TCP connection can be opened.

Remarks

This property is read-only. It is initially set when the object is created by calling the AddTCP method of an FPCProtocolConnections collection and can be modified by calling the SetTCP method.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCProtocolConnection


IFPCProtocolConnection.UDPDirection (1 Parameter) property [ISA Server 2004]

UDPDirection Property of IFPCProtocolConnection[C++]

FPCProtocolConnection.UDPDirection [Visual Basic]

[C++]

The UDPDirection property gets a value from the FpcUDPConnectionDirectionType enumerated type that specifies the direction in which a UDP connection can be opened. UDP connections can be opened to receive only, to send only, to receive and then send, or to send and then receive.

HRESULT get_UDPDirection(
  FpcUDPConnectionDirectionType* pUDPDirection
);

Parameters

pUDPDirection
Pointer to a variable that on return receives a value from the FpcUDPConnectionDirectionType enumerated type specifying the direction in which the UDP connection can be opened.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only. It is initially set when the object is created by calling the AddUDP method of an FPCProtocolConnections collection and can be modified by calling the SetUDP method of the object.

[Visual Basic]

The UDPDirection property gets a value from the FpcUDPConnectionDirectionType enumerated type that specifies the direction in which a UDP connection can be opened. UDP connections can be opened to receive only, to send only, to receive and then send, or to send and then receive.

Property UDPDirection As FpcUDPConnectionDirectionType

Property Value

Value from the FpcUDPConnectionDirectionType enumerated type that specifies the direction in which the UDP connection can be opened.

Remarks

This property is read-only. It is initially set when the object is created by calling the AddUDP method of an FPCProtocolConnections collection and can be modified by calling the SetUDP method of the object.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCProtocolConnection


FPCProtocolConnections collection [ISA Server 2004]

FPCProtocolConnections Collection

The FPCProtocolConnections collection holds a set of FPCProtocolConnection objects that represent all of the primary connections or all of the secondary conditions for a single protocol.

The FPCProtocolConnections collection is typically accessed through the PrimaryConnections or SecondaryConnections property of an FPCProtocolDefinition object.

Click here to see the ISA Server object hierarchy.

Methods

The FPCProtocolConnections collection defines the following methods.

Method | Description
AddICMP | Creates a new FPCProtocolConnection object for an ICMP connection and returns a reference to it.
AddRaw | Creates a new FPCProtocolConnection object for a raw protocol and returns a reference to it.
AddTCP | Creates a new FPCProtocolConnection object for a TCP connection and returns a reference to it.
AddUDP | Creates a new FPCProtocolConnection object for a UDP connection and returns a reference to it.
Item | Retrieves the requested FPCProtocolConnection object from the collection.
Refresh | Recursively reads all the properties of the collection and its elements from persistent storage, overwriting any changes made after the last call to the Save method.
Remove | Removes the specified FPCProtocolConnection object from the collection.
Save | Writes the current values of all the properties of the collection and its elements to persistent storage.

Properties

The FPCProtocolConnections collection has the following properties.

Property | Description
_NewEnum | Gets an enumerator object for the collection.
Count | Gets the number of FPCProtocolConnection objects in the collection.

Remarks

This collection implements the IFPCProtocolConnections interface.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

COM Objects


IFPCProtocolConnections._NewEnum(IUnknown) property [ISA Server 2004]

_NewEnum Property of IFPCProtocolConnections[C++]

FPCProtocolConnections._NewEnum [Visual Basic]

[C++]

The _NewEnum property gets an enumerator object for the collection. An enumerator object provides serial access to the elements of the collection.

HRESULT get__NewEnum(
  IUnknown* ppEnum
);

Parameters

ppEnum
Address of an interface pointer that on return points to the IUnknown interface of an enumerator object that implements an IEnumVARIANT interface for the collection. An interface pointer to the IEnumVARIANT interface of the enumerator object can be retrieved by calling QueryInterface on the IUnknown interface returned.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The _NewEnum property gets an enumerator object for the collection. An enumerator object provides serial access to the elements of the collection.

Property _NewEnum As IUnknown

Property Value

Reference to an enumerator object that provides serial access to the elements of the collection.

Remarks

This property is read-only.

In Visual Basic and VBScript, this property is used implicitly in For Each...In...Next constructs.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCProtocolConnections


IFPCProtocolConnections.AddICMP (4 Parameters) method [ISA Server 2004]

IFPCProtocolConnections::AddICMP[C++]

FPCProtocolConnections.AddICMP [Visual Basic]

[C++]

The AddICMP method creates a new FPCProtocolConnection object for an ICMP connection and returns a reference to it.

HRESULT AddICMP(
  FpcUDPConnectionDirectionType Direction,
  long Code,
  long Type,
  IFPCProtocolConnection** ppNewProtocolConnection
);

Parameters

Direction
[in] Required. Value from the FpcUDPConnectionDirectionType enumerated type that specifies the direction for the new connection.
Code
[in] A 32-bit integer that specifies the ICMP code number used by the filter. It can have a value from 0 to 255. The ICMP code is a subdescriptor of the ICMP type.
Type
[in] A 32-bit integer that specifies the ICMP type number used by the filter. It can have a value from 0 to 255.
ppNewProtocolConnection
[out] Address of an interface pointer that on return points to the new IFPCProtocolConnection interface created.

Return Values

This method can return one of the following:

  • S_OK, indicating that the operation succeeded.
  • An error code, indicating that the operation failed. In this case, the [out] parameter returned is a null object.

[Visual Basic]

The AddICMP method creates a new FPCProtocolConnection object for an ICMP connection and returns a reference to it.

Function AddICMP( _
  ByVal Direction As FpcUDPConnectionDirectionType, _
  ByVal Code As Long, _
  ByVal Type As Long _
) As FPCProtocolConnection

Parameters

Direction
[in] Required. Value from the FpcUDPConnectionDirectionType enumerated type that specifies the direction for the new connection.
Code
[in] A 32-bit integer that specifies the ICMP code number used by the filter. It can have a value from 0 to 255. The ICMP code is a subdescriptor of the ICMP type.
Type
[in] A 32-bit integer that specifies the ICMP type number used by the filter. It can have a value from 0 to 255.

Return Values

This method returns a reference to an FPCProtocolConnection object if successful. Otherwise, an error is raised that can be intercepted by using an error handler.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCProtocolConnections


IFPCProtocolConnections.AddRaw (3 Parameters) method [ISA Server 2004]

IFPCProtocolConnections::AddRaw[C++]

FPCProtocolConnections.AddRaw [Visual Basic]

[C++]

The AddRaw method creates a new FPCProtocolConnection object for a raw protocol and returns a reference to it. A raw protocol is any protocol other than the primary protocols supported by ISA Server, which are TCP, UDP, ICMP, and GRE.

HRESULT AddRaw(
  FpcUDPConnectionDirectionType Direction,
  FpcConnectionProtocolType Protocol,
  IFPCProtocolConnection** ppNewProtocolConnection
);

Parameters

Direction
[in] Required. Value from the FpcUDPConnectionDirectionType enumerated type that specifies the direction of the new connection.
Protocol
[in] Required. Value from the FpcConnectionProtocolType enumerated type that specifies the protocol for the new connection.
ppNewProtocolConnection
[out] Address of an interface pointer that on return points to the new IFPCProtocolConnection interface created.

Return Values

This method can return one of the following:

  • S_OK, indicating that the operation succeeded.
  • An error code indicating that the operation failed. In this case, the [out] parameter returned is a null object.

[Visual Basic]

The AddRaw method creates a new FPCProtocolConnection object for a raw protocol and returns a reference to it. A raw protocol is any protocol other than the primary protocols supported by ISA Server, which are TCP, UDP, ICMP, and GRE.

Function AddRaw( _
  ByVal Direction As FpcUDPConnectionDirectionType, _
  ByVal Protocol As FpcConnectionProtocolType _
) As FPCProtocolConnection

Parameters

Direction
[in] Required. Value from the FpcUDPConnectionDirectionType enumerated type that specifies the direction of the new connection.
Protocol
[in] Required. Value from the FpcConnectionProtocolType enumerated type that specifies the protocol for the new connection.

Return Values

This method returns a reference to an FPCProtocolConnection object if successful. Otherwise, an error is raised that can be intercepted by using an error handler.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCProtocolConnections


IFPCProtocolConnections.AddTCP (4 Parameters) method [ISA Server 2004]

IFPCProtocolConnections::AddTCP[C++]

FPCProtocolConnections.AddTCP [Visual Basic]

[C++]

The AddTCP method creates a new FPCProtocolConnection object for a TCP connection and returns a reference to it.

HRESULT AddTCP(
  FpcConnectionDirectionType Direction,
  long PortLo,
  long PortHi,
  IFPCProtocolConnection** ppNewProtocolConnection
);

Parameters

Direction
[in] Required. Value from the FpcConnectionDirectionType enumerated type that specifies the direction for the new connection.
PortLo
[in] Lower bound of the port range used in the connection.
PortHi
[in] Upper bound of the port range used in the connection.
ppNewProtocolConnection
[out] Address of an interface pointer that on return points to the new IFPCProtocolConnection interface created.

Return Values

This method can return one of the following:

  • S_OK, indicating that the operation succeeded.
  • An error code, indicating that the operation failed. In this case, the [out] parameter returned is a null object.

[Visual Basic]

The AddTCP method creates a new FPCProtocolConnection object for a TCP connection and returns a reference to it.

Function AddTCP( _
  ByVal Direction As FpcConnectionDirectionType, _
  ByVal PortLo As Long, _
  ByVal PortHi As Long _
) As FPCProtocolConnection

Parameters

Direction
[in] Required. Value from the FpcConnectionDirectionType enumerated type that specifies the direction for the new connection.
PortLo
[in] Lower bound of the port range used in the connection.
PortHi
[in] Upper bound of the port range used in the connection.

Return Values

This method returns a reference to an FPCProtocolConnection object if successful. Otherwise, an error is raised that can be intercepted by using an error handler.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCProtocolConnections


IFPCProtocolConnections.AddUDP (4 Parameters) method [ISA Server 2004]

IFPCProtocolConnections::AddUDP[C++]

FPCProtocolConnections.AddUDP [Visual Basic]

[C++]

The AddUDP method creates a new FPCProtocolConnection object for a UDP connection and returns a reference to it.

HRESULT AddUDP(
  FpcUDPConnectionDirectionType Direction,
  long PortLo,
  long PortHi,
  IFPCProtocolConnection** ppNewProtocolConnection
);

Parameters

Direction
[in] Required. Value from the FpcUDPConnectionDirectionType enumerated type that specifies the direction for the new connection.
PortLo
[in] Lower bound of the port range used in the connection.
PortHi
[in] Upper bound of the port range used in the connection.
ppNewProtocolConnection
[out] Address of an interface pointer that on return points to the new IFPCProtocolConnection interface created.

Return Values

This method can return one of the following:

  • S_OK, indicating that the operation succeeded.
  • An error code, indicating that the operation failed. In this case, the [out] parameter returned is a null object.

[Visual Basic]

The AddUDP method creates a new FPCProtocolConnection object for a UDP connection and returns a reference to it.

Function AddUDP( _
  ByVal Direction As FpcUDPConnectionDirectionType, _
  ByVal PortLo As Long, _
  ByVal PortHi As Long _
) As FPCProtocolConnection

Parameters

Direction
[in] Required. Value from the FpcUDPConnectionDirectionType enumerated type that specifies the direction for the new connection.
PortLo
[in] Lower bound of the port range used in the connection.
PortHi
[in] Upper bound of the port range used in the connection.

Return Values

This method returns a reference to an FPCProtocolConnection object if successful. Otherwise, an error is raised that can be intercepted by using an error handler.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCProtocolConnections


IFPCProtocolConnections.Count(long) property [ISA Server 2004]

Count Property of IFPCProtocolConnections[C++]

FPCProtocolConnections.Count [Visual Basic]

[C++]

The Count property gets the number of FPCProtocolConnection objects in the collection.

HRESULT get_Count(
  long* plCount
);

Parameters

plCount
Pointer to a variable that on return receives a 32-bit integer specifying the number of FPCProtocolConnection objects in the collection.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The Count property gets the number of FPCProtocolConnection objects in the collection.

Property Count As Long

Property Value

A 32-bit integer that specifies the number of FPCProtocolConnection objects in the collection.

Remarks

This property is read-only.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCProtocolConnections


IFPCProtocolConnections | FPCProtocolConnections Item method [ISA Server 2004]

IFPCProtocolConnections::Item[C++]

FPCProtocolConnections.Item [Visual Basic]

[C++]

The Item method retrieves the requested IFPCProtocolConnection interface from the collection.

HRESULT Item(
  long Index,
  IFPCProtocolConnection** ppItem
);

Parameters

Index
[in] Required. One-based index of the object to retrieve.
ppItem
[out] Address of a variable that receives a pointer to the IFPCProtocolConnection interface requested.

Return Values

This method can return one of the following:

  • S_OK, indicating that the operation succeeded.
  • An error code, indicating that the operation failed. In this case, the [out] parameter returned is a null object.

[Visual Basic]

The Item method retrieves the requested FPCProtocolConnection object from the collection.

Function Item( _
  ByVal Index As Long _
) As FPCProtocolConnection

Parameters

Index
[in] Required. One-based index of the object to retrieve.

Return Values

This method returns a reference to the FPCProtocolConnection object requested if successful. Otherwise, an error is raised that can be intercepted by using an error handler.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCProtocolConnections


IFPCProtocolConnections.Refresh method [ISA Server 2004]

IFPCProtocolConnections::Refresh[C++]

FPCProtocolConnections.Refresh [Visual Basic]

[C++]

The Refresh method recursively reads all the properties of the collection and its elements from persistent storage, overwriting any changes made after the last call to the Save method.

HRESULT Refresh();

Parameters

This method has no parameters.

Return Values

This method returns S_OK if the call is successful; otherwise, it returns an error code.
[Visual Basic]

The Refresh method recursively reads all the properties of the collection and its elements from persistent storage, overwriting any changes made after the last call to the Save method.

Sub Refresh()

Parameters

This method has no parameters.

Return Values

This method has no return values. If the call is unsuccessful, an error is raised that can be intercepted by using an error handler.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCProtocolConnections


IFPCProtocolConnections.Remove(Variant) method [ISA Server 2004]

IFPCProtocolConnections::Remove[C++]

FPCProtocolConnections.Remove [Visual Basic]

[C++]

The Remove method removes the specified FPCProtocolConnection object from the collection.

HRESULT Remove(
  VARIANT Index
);

Parameters

Index
[in] Required. Name or one-based index of the FPCProtocolConnection object to remove.

Return Values

This method returns S_OK if the call is successful; otherwise, it returns an error code.
[Visual Basic]

The Remove method removes the specified FPCProtocolConnection object from the collection.

Sub Remove( _
  ByVal Index As Variant _
)

Parameters

Index
[in] Required. Name or one-based index of the FPCProtocolConnection object to remove.

Return Values

This method has no return values. If the call is unsuccessful, an error is raised that can be intercepted by using an error handler.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCProtocolConnections


IFPCProtocolConnections | FPCProtocolConnections Save method [ISA Server 2004]

IFPCProtocolConnections::Save[C++]

FPCProtocolConnections.Save [Visual Basic]

[C++]

The Save method writes the current values of all the properties of the collection and its elements to persistent storage. It is important to remember that any changes made by scripts and programs will not be saved until after the Save method is called.

HRESULT Save(
  VARIANT_BOOL fResetRequiredServices,
  VARIANT_BOOL fReloadConfiguration
);

Parameters

fResetRequiredServices
[in, optional] Boolean value that indicates whether to restart the services that need to be restarted for any of the changes saved to take effect. The default value is VARIANT_FALSE.
fReloadConfiguration
[in, optional] Boolean value that indicates whether the call will include synchronous reloading of all changes that can be applied dynamically without restarting services. The default value is VARIANT_TRUE.

Return Values

This method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

Configuration changes are applied only after the new settings are written to persistent storage and reloaded to the services that use them. Most changes can be applied dynamically without restarting any services. However, some changes can take effect only after the Microsoft Firewall service is restarted. For more information, see Restarting Services after Configuration Changes.

ISA Server maintains a bitmask that specifies which services need to be started for currently unsaved changes to take effect. This bitmask can be retrieved by calling the GetServiceRestartMask method on an object that contains this object as a subobject. Calling the Save method clears all of the bits in this bitmask even if the fResetRequiredServices parameter is set to VARIANT_FALSE.

If the fReloadConfiguration parameter is set to VARIANT_FALSE the current values of the properties of the collection and its elements will be written to persistent storage without updating the configuration being used by the ISA Server services. The configuration used by each service will not be updated until the service is restarted or the new settings are reloaded by another call to Save.

[Visual Basic]

The Save method writes the current values of all the properties of the collection and its elements to persistent storage. It is important to remember that any changes made by scripts and programs will not be saved until after the Save method is called.

Sub Save( _
  [ ByVal fResetRequiredServices As Boolean ], _
  [ ByVal fReloadConfiguration As Boolean ] _
)

Parameters

fResetRequiredServices
[in, optional] Boolean value that indicates whether to restart the services that need to be restarted for any of the changes saved to take effect. The default value is False.
fReloadConfiguration
[in, optional] Boolean value that indicates whether the call will include synchronous reloading of all the saved configuration changes that can be applied dynamically without restarting services. The default value is True.

Return Values

This method has no return values. If the call is unsuccessful, an error is raised that can be intercepted by using an error handler.

Remarks

Configuration changes are applied only after the new settings are written to persistent storage and reloaded to the services that use them. Most changes can be applied dynamically without restarting any services. However, some changes can take effect only after the Microsoft Firewall service is restarted. For more information, see Restarting Services after Configuration Changes.

ISA Server maintains a bitmask that specifies which services need to be started for currently unsaved changes to take effect. This bitmask can be retrieved by calling the GetServiceRestartMask method on an object that contains this object as a subobject. Calling the Save method clears all of the bits in this bitmask even if the fResetRequiredServices parameter is set to False.

If the fReloadConfiguration parameter is set to False the current values of the properties of the collection and its elements will be written to persistent storage without updating the configuration being used by the ISA Server services. The configuration used by each service will not be updated until the service is restarted or the new settings are reloaded by another call to Save.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCProtocolConnections


FPCProtocolDefinition object [ISA Server 2004]

FPCProtocolDefinition

The FPCProtocolDefinition object represents a single protocol that is supported by the Microsoft Firewall service. This object can represent one of the predefined protocols that come with ISA Server, a user-defined protocol, or a protocol installed with an application filter.

Protocol definitions are used in access rules and server publishing rules. For access rules, the primary connections specified in a protocol definition are usually defined as outbound. These connections allow traffic from the network entities specified as the rule sources to the network entities specified as the rule destinations. For server publishing rules, the primary connections specified in a protocol definition must be defined as inbound. These connections allow traffic from the network entities specified as the network sources to the published service on the server.

The FPCProtocolDefinition object is typically an element of an FPCProtocolDefinitions collection.

Click here to see the ISA Server object hierarchy.

Inheritance

This object inherits from the FPCPersist object, which contains methods and properties related to the persistent storage of an object's data. They include methods for exporting an object's data to and importing it from an XML document.

Methods

This object has no methods.

Properties

The FPCProtocolDefinition object has the following properties.

Property | Description
ApplicationFilterDefined | Gets or sets a Boolean value that indicates whether the protocol is defined by an application filter.
ApplicationFilters | Gets an FPCRefs collection that contains references to the FPCApplicationFilter objects defining the application filters associated with the protocol.
Description | Gets or sets the description of the protocol.
Guid | Gets the GUID that identifies the protocol.
Name | Gets or sets the name of the protocol.
Predefined | Gets a Boolean value that indicates whether the protocol is a predefined ISA Server protocol.
PrimaryConnections | Gets an FPCProtocolConnections collection that contains all of the protocol's primary connections.
ProtocolCategory | Gets the category of the protocol.
SecondaryConnections | Gets an FPCProtocolConnections collection that contains all of the protocol's secondary connections.

Methods Inherited from FPCPersist

Name | Description
CancelWaitForChanges | Cancels the registration established by the WaitForChanges method (for use in C and C++ programming only).
CanImport | Returns a Boolean value that indicates whether the object's properties can be imported from the specified XML document.
Export | Recursively writes the stored values of all the properties of the object and its subobjects to the specified XML document.
ExportToFile | Recursively writes the stored values of all the properties of the object and its subobjects to the specified XML file.
GetServiceRestartMask | Retrieves a 32-bit bitmask of the FpcServices enumerated type that specifies which services need to be restarted for currently unsaved changes to take effect.
Import | Recursively copies the values of all the properties of the object and of its subobjects from the specified XML document to persistent storage.
ImportFromFile | Recursively copies the values of all the properties of the object and of its subobjects from the specified XML file to persistent storage.
LoadDocProperties | Provides the XML document's properties so that you can know what information can be imported from the document.
Refresh | Recursively reads the values of all the properties of the object and of its subobjects from persistent storage, overwriting any changes that have not been saved.
Save | Recursively writes the current values of all the properties of the object and its subobjects to persistent storage.
WaitForChanges | Registers to wait for an event indicating that the contents of the object have changed (for use in C and C++ programming only).

Properties Inherited from FPCPersist

Name | Description
PersistentName | Gets the persistent name of the object. The persistent name of an object is a name that is unique for the object at the respective level of the COM object hierarchy.
VendorParametersSets | Gets an FPCVendorParametersSets collection that can hold sets of custom data for extending the object.

Remarks

This object implements the IFPCProtocolDefinition interface.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

COM Objects


IFPCProtocolDefinition.ApplicationFilterDefined property [ISA Server 2004]

ApplicationFilterDefined Property of IFPCProtocolDefinition[C++]

FPCProtocolDefinition.ApplicationFilterDefined [Visual Basic]

[C++]

The ApplicationFilterDefined property gets or sets a Boolean value that indicates whether the protocol is defined by an application filter.

HRESULT get_ApplicationFilterDefined(
  VARIANT_BOOL* pfApplicationFilterDefined
);

HRESULT put_ApplicationFilterDefined(
  VARIANT_BOOL fApplicationFilterDefined
);

Parameters

pfApplicationFilterDefined
Pointer to a Boolean variable that is set on return to VARIANT_TRUE if the protocol is defined by an application filter, or to VARIANT_FALSE if the protocol is not defined by an application filter.
fApplicationFilterDefined
Boolean value that indicates whether the protocol is defined by an application filter.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write.

[Visual Basic]

The ApplicationFilterDefined property gets or sets a Boolean value that indicates whether the protocol is defined by an application filter.

Property ApplicationFilterDefined As Boolean

Property Value

Boolean value that indicates whether the protocol is defined by an application filter.

Remarks

This property is read/write.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCProtocolDefinition


IFPCProtocolDefinition.ApplicationFilters(IFPCRefs) property [ISA Server 2004]

ApplicationFilters Property of IFPCProtocolDefinition[C++]

FPCProtocolDefinition.ApplicationFilters [Visual Basic]

[C++]

The ApplicationFilters property gets an FPCRefs collection that contains references to the FPCApplicationFilter objects defining the application filters associated with the protocol.

HRESULT get_ApplicationFilters(
  IFPCRefs** ppRefs
);

Parameters

ppRefs
Address of a variable that receives a pointer to an IFPCRefs interface that represents the collection of references to the application filters associated with the protocol.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only. The set of application filters associated with the protocol can be modified by calling the methods of the IFPCRefs interface retrieved.

[Visual Basic]

The ApplicationFilters property gets an FPCRefs collection that contains references to the FPCApplicationFilter objects defining the application filters associated with the protocol.

Property ApplicationFilters As FPCRefs

Property Value

Reference to the FPCRefs collection that contains references to the application filters associated with the protocol.

Remarks

This property is read-only. The set of application filters associated with the protocol can be modified by calling the methods of the FPCRefs collection retrieved.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCProtocolDefinition


IFPCProtocolDefinition.Description(BSTR,BSTR) property [ISA Server 2004]

Description Property of IFPCProtocolDefinition[C++]

FPCProtocolDefinition.Description [Visual Basic]

[C++]

The Description property gets or sets the description of the protocol.

HRESULT get_Description(
  BSTR* pbstrDescription
);

HRESULT put_Description(
  BSTR bstrDescription
);

Parameters

pbstrDescription
Pointer to a BSTR that is set on return to a string value specifying the description of the protocol.
bstrDescription
BSTR that specifies the description of the protocol.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write.

[Visual Basic]

The Description property gets or sets the description of the protocol.

Property Description As String

Property Value

String that specifies the description of the protocol.

Remarks

This property is read/write.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCProtocolDefinition


IFPCProtocolDefinition | FPCProtocolDefinition Guid property [ISA Server 2004]

Guid Property of IFPCProtocolDefinition[C++]

FPCProtocolDefinition.Guid [Visual Basic]

[C++]

The Guid property gets the string-formatted globally unique identifier (GUID) of the protocol.

HRESULT get_Guid(
  BSTR* pbstrGuid
);

Parameters

pbstrGuid
Pointer to a BSTR that is set on return to a string value specifying the string-formatted GUID of the protocol.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

The GUID retrieved is formatted as a string in the form {12345678-1234-1234-1234-123456789ABC}. Note the presence of the braces normally used with GUIDs.

[Visual Basic]

The Guid property gets the string-formatted globally unique identifier (GUID) of the protocol.

Property Guid As String

Property Value

String that specifies the string-formatted GUID of the protocol.

Remarks

This property is read-only.

The GUID retrieved is formatted as a string in the form {12345678-1234-1234-1234-123456789ABC}. Note the presence of the braces normally used with GUIDs.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCProtocolDefinition


IFPCProtocolDefinition | FPCProtocolDefinition Name property [ISA Server 2004]

Name Property of IFPCProtocolDefinition[C++]

FPCProtocolDefinition.Name [Visual Basic]

[C++]

The Name property gets or sets the name of the protocol.

HRESULT get_Name(
  BSTR* pbstrName
);

HRESULT put_Name(
  BSTR bstrName
);

Parameters

pbstrName
Pointer to a BSTR that is set on return to a string value specifying the name of the protocol.
bstrName
BSTR that specifies the name of the protocol.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write.

[Visual Basic]

The Name property gets or sets the name of the protocol.

Property Name As String

Property Value

String that specifies the name of the protocol.

Remarks

This property is read/write.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCProtocolDefinition


IFPCProtocolDefinition.Predefined(VARIANT_BOOL) property [ISA Server 2004]

Predefined Property of IFPCProtocolDefinition[C++]

FPCProtocolDefinition.Predefined [Visual Basic]

[C++]

The Predefined property gets a Boolean value that indicates whether the protocol is a predefined ISA Server protocol. A predefined protocol is installed with ISA Server and cannot be modified or deleted.

HRESULT get_Predefined(
  VARIANT_BOOL* pfPredefined
);

Parameters

pfPredefined
Pointer to a Boolean variable that is set on return to VARIANT_TRUE if the protocol is a predefined ISA Server protocol, or to VARIANT_FALSE if the protocol is user-defined.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The Predefined property gets a Boolean value that indicates whether the protocol is a predefined ISA Server protocol. A predefined protocol is installed with ISA Server and cannot be modified or deleted.

Property Predefined As Boolean

Property Value

Boolean value that indicates whether the protocol is a predefined ISA Server protocol.

Remarks

This property is read-only.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCProtocolDefinition


IFPCProtocolDefinition.PrimaryConnections property [ISA Server 2004]

PrimaryConnections Property of IFPCProtocolDefinition[C++]

FPCProtocolDefinition.PrimaryConnections [Visual Basic]

[C++]

The PrimaryConnections property gets an FPCProtocolConnections collection that contains all of the protocol's primary connections.

HRESULT get_PrimaryConnections(
  IFPCProtocolConnections** ppPrimaryConnections
);

Parameters

ppPrimaryConnections
Address of an interface pointer that on return points to an IFPCProtocolConnections interface that represents the collection of the protocol's primary connections.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only. The set of connections can be modified by calling the methods of the IFPCProtocolConnections interface retrieved.

[Visual Basic]

The PrimaryConnections property gets an FPCProtocolConnections collection that contains all of the protocol's primary connections.

Property PrimaryConnections As FPCProtocolConnections

Property Value

Reference to an FPCProtocolConnections collection that contains all of the protocol's primary connections.

Remarks

This property is read-only. The set of connections can be modified by calling the methods of the FPCProtocolConnections collection retrieved.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCProtocolDefinition


IFPCProtocolDefinition.ProtocolCategory(long) property [ISA Server 2004]

ProtocolCategory Property of IFPCProtocolDefinition[C++]

FPCProtocolDefinition.ProtocolCategory [Visual Basic]

[C++]

The ProtocolCategory property gets the category of the protocol, such as common protocol or Web protocol. This is a bitwise combination of values from the FpcProtocolCategory enumerated type.

HRESULT get_ProtocolCategory(
  long* plCategory
);

Parameters

plCategory
Pointer to a 32-bit integer which is set on return to a bitwise combination of values from the FpcProtocolCategory enumerated type that specifies the category of the protocol.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The ProtocolCategory property gets the category of the protocol, such as common protocol or Web protocol. This is a bitwise combination of values from the FpcProtocolCategory enumerated type.

Property ProtocolCategory As Long

Property Value

Bitwise combination of values from the FpcProtocolCategory enumerated type that specifies the category of the protocol.

Remarks

This property is read-only.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCProtocolDefinition


IFPCProtocolDefinition.SecondaryConnections property [ISA Server 2004]

SecondaryConnections Property of IFPCProtocolDefinition[C++]

FPCProtocolDefinition.SecondaryConnections [Visual Basic]

[C++]

The SecondaryConnections property gets an FPCProtocolConnections collection that contains all of the protocol's secondary connections.

HRESULT get_SecondaryConnections(
  IFPCProtocolConnections** ppSecondaryConnections
);

Parameters

ppSecondaryConnections
Address of an interface pointer that on return points to an IFPCProtocolConnections interface that represents the collection of the protocol's secondary connections.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only. The set of connections can be modified by calling the methods of the IFPCProtocolConnections interface retrieved.

[Visual Basic]

The SecondaryConnections property gets an FPCProtocolConnections collection that contains all of the protocol's secondary connections.

Property SecondaryConnections As FPCProtocolConnections

Property Value

Reference to an FPCProtocolConnections collection that contains all of the protocol's secondary connections.

Remarks

This property is read-only. The set of connections can be modified by calling the methods of the FPCProtocolConnections collection retrieved.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCProtocolDefinition


FPCProtocolDefinitions collection [ISA Server 2004]

FPCProtocolDefinitions Collection

The FPCProtocolDefinitions collection holds a set of FPCProtocolDefinition objects that define all of the protocols supported by the Microsoft Firewall service in an ISA Server array. Each FPCProtocolDefinition object can represent a predefined protocol that comes with ISA Server or a user-defined protocol.

This collection is typically accessed through the ProtocolDefinitions property of an FPCRuleElements object.

Click here to see the ISA Server object hierarchy.

Inheritance

This collection inherits from the FPCPersist object, which contains methods and properties related to the persistent storage of an object's data. They include methods for exporting the object's data to and importing it from an XML document.

Methods

The FPCProtocolDefinitions collection defines the following methods.

Method | Description
Add | Creates a new FPCProtocolDefinition object in the collection and returns a reference to it.
Item | Retrieves the requested FPCProtocolDefinition object from the collection.
Remove | Removes the specified FPCProtocolDefinition object from the collection.

Properties

The FPCProtocolDefinitions collection has the following properties.

Property | Description
_NewEnum | Gets an enumerator object for the collection.
Count | Gets the number of FPCProtocolDefinition objects in the collection.

Methods Inherited from FPCPersist

Name | Description
CancelWaitForChanges | Cancels the registration established by the WaitForChanges method (for use in C and C++ programming only).
CanImport | Returns a Boolean value that indicates whether the properties of the collection, its elements, and their subobjects can be imported from the specified XML document.
Export | Recursively writes the stored values of all the properties of the collection, its elements, and their subobjects to the specified XML document.
ExportToFile | Recursively writes the stored values of all the properties of the collection, its elements, and their subobjects to the specified XML file.
GetServiceRestartMask | Retrieves a 32-bit bitmask of the FpcServices enumerated type that specifies which services need to be restarted for currently unsaved changes to take effect.
Import | Recursively copies the values of all the properties of the collection, its elements, and their subobjects from the specified XML document to persistent storage.
ImportFromFile | Recursively copies the values of all the properties of the collection, its elements, and their subobjects from the specified XML file to persistent storage.
LoadDocProperties | Provides the XML document's properties so that you can know what information can be imported from the document.
Refresh | Recursively reads the values of all the properties of the collection, its elements, and their subobjects from persistent storage, overwriting any changes that have not been saved.
Save | Recursively writes the current values of all the properties of the collection, its elements, and their subobjects to persistent storage.
WaitForChanges | Registers to wait for an event indicating that the contents of the object have changed (for use in C and C++ programming only).

Properties Inherited from FPCPersist

Name | Description
PersistentName | Gets the persistent name of the collection. The persistent name of an object is a name that is unique for the object at the respective level of the COM object hierarchy.
VendorParametersSets | Gets an FPCVendorParametersSets collection that can hold sets of custom data for extending the collection.

Remarks

This collection implements the IFPCProtocolDefinitions interface.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

COM Objects


IFPCProtocolDefinitions._NewEnum(IUnknown) property [ISA Server 2004]

_NewEnum Property of IFPCProtocolDefinitions[C++]

FPCProtocolDefinitions._NewEnum [Visual Basic]

[C++]

The _NewEnum property gets an enumerator object for the collection. An enumerator object provides serial access to the elements of the collection.

HRESULT get__NewEnum(
  IUnknown* ppEnum
);

Parameters

ppEnum
Address of an interface pointer that on return points to the IUnknown interface of an enumerator object that implements an IEnumVARIANT interface for the collection. An interface pointer to the IEnumVARIANT interface of the enumerator object can be retrieved by calling QueryInterface on the IUnknown interface returned.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The _NewEnum property gets an enumerator object for the collection. An enumerator object provides serial access to the elements of the collection.

Property _NewEnum As IUnknown

Property Value

Reference to an enumerator object that provides serial access to the elements of the collection.

Remarks

This property is read-only.

In Visual Basic and VBScript, this property is used implicitly in For Each...In...Next constructs.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCProtocolDefinitions


IFPCProtocolDefinitions | FPCProtocolDefinitions Add method [ISA Server 2004]

IFPCProtocolDefinitions::Add[C++]

FPCProtocolDefinitions.Add [Visual Basic]

[C++]

The Add method creates a new FPCProtocolDefinition object and returns a reference to it.

HRESULT Add(
  BSTR ProtocolName,
  BSTR ProtocolGuid,
  long category,
  IFPCProtocolDefinition** ppNew
);

Parameters

ProtocolName
[in] Required. BSTR that specifies the name of the new protocol.
ProtocolGuid
[in, optional] BSTR that specifies the globally unique identifier (GUID) of the new protocol. The default value is an empty BSTR.
category
[in, optional] A 32-bit integer value that specifies the category or categories to which the new protocol belongs. This value is a bitwise combination of values from the FpcProtocolCategory enumerated type. The default value is fpcProtocolCategoryUserDefined.
ppNew
[out] Address of an interface pointer that on return points to the new IFPCProtocolDefinition interface created.

Return Values

This method can return one of the following:

  • S_OK, indicating that the operation succeeded.
  • An error code, indicating that the operation failed. In this case, the [out] parameter returned is a null object.

[Visual Basic]

The Add method creates a new FPCProtocolDefinition object and returns a reference to it.

Function Add( _
  ByVal ProtocolName As String, _
  [ ByVal ProtocolGuid As String ], _
  [ ByVal category As Long ] _
) As FPCProtocolDefinition

Parameters

ProtocolName
[in] Required. String that specifies the name of the new protocol.
ProtocolGuid
[in, optional] String that specifies the globally unique identifier (GUID) of the new protocol. The default value is an empty string.
category
[in, optional] A 32-bit integer value that specifies the category or categories to which the new protocol belongs. This value is a bitwise combination of values from the FpcProtocolCategory enumerated type. The default value is fpcProtocolCategoryUserDefined.

Return Values

This method returns a reference to an FPCProtocolDefinition object if successful. Otherwise, an error is raised that can be intercepted by using an error handler.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCProtocolDefinitions


IFPCProtocolDefinitions.Count(long) property [ISA Server 2004]

Count Property of IFPCProtocolDefinitions[C++]

FPCProtocolDefinitions.Count [Visual Basic]

[C++]

The Count property gets the number of FPCProtocolDefinition objects in the collection.

HRESULT get_Count(
  long* plCount
);

Parameters

plCount
Pointer to a variable that on return receives a 32-bit integer specifying the number of FPCProtocolDefinition objects in the collection.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The Count property gets the number of FPCProtocolDefinition objects in the collection.

Property Count As Long

Property Value

A 32-bit integer that specifies the number of FPCProtocolDefinition objects in the collection.

Remarks

This property is read-only.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCProtocolDefinitions


IFPCProtocolDefinitions | FPCProtocolDefinitions Item method [ISA Server 2004]

IFPCProtocolDefinitions::Item[C++]

FPCProtocolDefinitions.Item [Visual Basic]

[C++]

The Item method retrieves the requested IFPCProtocolDefinition interface from the collection.

HRESULT Item(
  VARIANT Index,
  IFPCProtocolDefinition** ppItem
);

Parameters

Index
[in] Required. One-based index of the object to retrieve.
ppItem
[out] Address of a variable that receives a pointer to the IFPCProtocolDefinition interface requested.

Return Values

This method can return one of the following:

  • S_OK, indicating that the operation succeeded.
  • An error code, indicating that the operation failed. In this case, the [out] parameter returned is a null object.

[Visual Basic]

The Item method retrieves the requested FPCProtocolDefinition object from the collection.

Function Item( _
  ByVal Index As Variant _
) As FPCProtocolDefinition

Parameters

Index
[in] Required. One-based index of the object to retrieve.

Return Values

This method returns a reference to the FPCProtocolDefinition object requested if successful. Otherwise, an error is raised that can be intercepted by using an error handler.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCProtocolDefinitions


IFPCProtocolDefinitions.Remove(Variant) method [ISA Server 2004]

IFPCProtocolDefinitions::Remove[C++]

FPCProtocolDefinitions.Remove [Visual Basic]

[C++]

The Remove method removes the specified FPCProtocolDefinition object from the collection.

HRESULT Remove(
  VARIANT Index
);

Parameters

Index
[in] Required. Name or one-based index of the FPCProtocolDefinition object to remove.

Return Values

This method returns S_OK if the call is successful; otherwise, it returns an error code.
[Visual Basic]

The Remove method removes the specified FPCProtocolDefinition object from the collection.

Sub Remove( _
  ByVal Index As Variant _
)

Parameters

Index
[in] Required. Name or one-based index of the FPCProtocolDefinition object to remove.

Return Values

This method has no return values. If the call is unsuccessful, an error is raised that can be intercepted by using an error handler.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCProtocolDefinitions


FPCPublicNames collection [ISA Server 2004]

FPCPublicNames Collection

The FPCPublicNames collection contains a group of public names. Public names can be DNS names and IP addresses that are resolved to the internal address of a Web server through a Web publishing rule. In this case, the FPCPublicNames object is accessed through the PublicNames property of an FPCWebPublishingProperties object. Public names can also be domain names of destinations that clients are allowed to access directly, bypassing the Microsoft Firewall service. In this case, the FPCPublicNames object is accessed through the DirectAddressDestinations property of an FPCClientAutoScript object.

Click here to see the ISA Server object hierarchy.

Methods

The FPCPublicNames collection defines the following methods.

Method | Description
Add | Adds a public name to the collection.
Item | Retrieves the requested public name from the collection.
Refresh | Reads the property and elements of the collection from persistent storage, overwriting any changes that were not saved.
Remove | Removes the specified public name from the collection.
Save | Writes the current values of the collection's property and elements to persistent storage.

Properties

The FPCPublicNames collection has the following properties.

Property | Description
_NewEnum | Gets an enumerator object for the collection.
Count | Gets the number of public names in the collection.

Remarks

This collection implements the IFPCPublicNames interface.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

COM Objects


IFPCPublicNames | FPCPublicNames _NewEnum(IUnknown) property [ISA Server 2004]

_NewEnum Property of IFPCPublicNames[C++]

FPCPublicNames._NewEnum [Visual Basic]

[C++]

The _NewEnum property gets an enumerator object for the collection. An enumerator object provides serial access to the elements of the collection.

HRESULT get__NewEnum(
  IUnknown* ppEnum
);

Parameters

ppEnum
Address of an interface pointer that on return points to the IUnknown interface of an enumerator object that implements an IEnumVARIANT interface for the collection. An interface pointer to the IEnumVARIANT interface of the enumerator object can be retrieved by calling QueryInterface on the IUnknown interface returned.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The _NewEnum property gets an enumerator object for the collection. An enumerator object provides serial access to the elements of the collection.

Property _NewEnum As IUnknown

Property Value

Reference to an enumerator object that provides serial access to the elements of the collection.

Remarks

This property is read-only.

In Visual Basic and VBScript, this property is used implicitly in For Each...In...Next constructs.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCPublicNames


IFPCPublicNames | FPCPublicNames Add(String) method [ISA Server 2004]

IFPCPublicNames::Add[C++]

FPCPublicNames.Add [Visual Basic]

[C++]

The Add method adds a public name to the collection. Public names can be DNS names and IP addresses that are resolved to the internal address of a Web server through a Web publishing rule.

HRESULT Add(
  BSTR Name
);

Parameters

Name
[in] BSTR that specifies the public name.

Return Values

This method returns S_OK if the call is successful; otherwise, it returns an error code.
[Visual Basic]

The Add method adds a public name to the collection. Public names can be DNS names and IP addresses that are resolved to the internal address of a Web server through a Web publishing rule.

Sub Add( _
  ByVal Name As String _
)

Parameters

Name
[in] String that specifies the public name.

Return Values

This method has no return values. If the call is unsuccessful, an error is raised that can be intercepted by using an error handler.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCPublicNames


IFPCPublicNames | FPCPublicNames Count(long) property [ISA Server 2004]

Count Property of IFPCPublicNames[C++]

FPCPublicNames.Count [Visual Basic]

[C++]

The Count property gets the number of public names in the collection.

HRESULT get_Count(
  long* plCount
);

Parameters

plCount
Pointer to a variable that on return receives a 32-bit integer specifying the number of public names in the collection.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The Count property gets the number of public names in the collection.

Property Count As Long

Property Value

A 32-bit integer that specifies the number of public names in the collection.

Remarks

This property is read-only.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCPublicNames


IFPCPublicNames | FPCPublicNames Item(Variant,BSTR) method [ISA Server 2004]

IFPCPublicNames::Item[C++]

FPCPublicNames.Item [Visual Basic]

[C++]

The Item method retrieves the requested public name from the collection.

HRESULT Item(
  VARIANT Index,
  BSTR* pItem
);

Parameters

Index
[in] Required. Name or one-based index of the item to retrieve.
pItem
[out] Pointer to a BSTR that is set on return to a string value specifying the public name.

Return Values

This method can return one of the following:

  • S_OK, indicating that the operation succeeded.
  • An error code, indicating that the operation failed.

[Visual Basic]

The Item method retrieves the requested public name from the collection.

Function Item( _
  ByVal Index As Variant _
) As String

Parameters

Index
[in] Required. Name or one-based index of the item to retrieve.

Return Values

This method returns a string specifying the public name requested if successful. Otherwise, an error is raised that can be intercepted by using an error handler.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCPublicNames


IFPCPublicNames | FPCPublicNames Refresh method [ISA Server 2004]

IFPCPublicNames::Refresh[C++]

FPCPublicNames.Refresh [Visual Basic]

[C++]

The Refresh method reads the property and elements of the collection from persistent storage, overwriting any changes made after the last call to the Save method.

HRESULT Refresh();

Parameters

This method has no parameters.

Return Values

This method returns S_OK if the call is successful; otherwise, it returns an error code.
[Visual Basic]

The Refresh method reads the property and elements of the collection from persistent storage, overwriting any changes made after the last call to the Save method.

Sub Refresh()

Parameters

This method has no parameters.

Return Values

This method has no return values. If the call is unsuccessful, an error is raised that can be intercepted by using an error handler.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCPublicNames


IFPCPublicNames | FPCPublicNames Remove(Variant) method [ISA Server 2004]

IFPCPublicNames::Remove[C++]

FPCPublicNames.Remove [Visual Basic]

[C++]

The Remove method removes the specified public name from the collection.

HRESULT Remove(
  VARIANT Index
);

Parameters

Index
[in] Required. Name or one-based index of the public name to remove.

Return Values

This method returns S_OK if the call is successful; otherwise, it returns an error code.
[Visual Basic]

The Remove method removes the specified public name from the collection.

Sub Remove( _
  ByVal Index As Variant _
)

Parameters

Index
[in] Required. Name or one-based index of the public name to remove.

Return Values

This method has no return values. If the call is unsuccessful, an error is raised that can be intercepted by using an error handler.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCPublicNames


IFPCPublicNames | FPCPublicNames Save (2 Parameters) method [ISA Server 2004]

IFPCPublicNames::Save[C++]

FPCPublicNames.Save [Visual Basic]

[C++]

The Save method writes the current values of the collection's property and elements to persistent storage. It is important to remember that any changes made by scripts and programs are not saved until after the Save method is called.

HRESULT Save(
  VARIANT_BOOL fResetRequiredServices,
  VARIANT_BOOL fReloadConfiguration
);

Parameters

fResetRequiredServices
[in, optional] Boolean value that indicates whether to restart the services that need to be restarted for any of the changes saved to take effect. The default value is VARIANT_FALSE.
fReloadConfiguration
[in, optional] Boolean value that indicates whether the call will include synchronous reloading of all changes that can be applied dynamically without restarting services. The default value is VARIANT_TRUE.

Return Values

This method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

Configuration changes are applied only after the new settings are written to persistent storage and reloaded to the services that use them. Most changes can be applied dynamically without restarting any services. However, some changes can take effect only after the Microsoft Firewall service is restarted. For more information, see Restarting Services after Configuration Changes.

ISA Server maintains a bitmask that specifies which services need to be started for currently unsaved changes to take effect. This bitmask can be retrieved by calling the GetServiceRestartMask method on an object that contains this object as a subobject. Calling the Save method clears all of the bits in this bitmask even if the fResetRequiredServices parameter is set to VARIANT_FALSE.

If the fReloadConfiguration parameter is set to VARIANT_FALSE the current values will be written to persistent storage without updating the configuration being used by the ISA Server services. The configuration used by each service will not be updated until the service is restarted or the new settings are reloaded by another call to Save.

[Visual Basic]

The Save method writes the current values of the collection's property and elements to persistent storage. It is important to remember that any changes made by scripts and programs are not saved until after the Save method is called.

Sub Save( _
  [ ByVal fResetRequiredServices As Boolean ], _
  [ ByVal fReloadConfiguration As Boolean ] _
)

Parameters

fResetRequiredServices
[in, optional] Boolean value that indicates whether to restart the services that need to be restarted for any of the changes saved to take effect. The default value is False.
fReloadConfiguration
[in, optional] Boolean value that indicates whether the call will include synchronous reloading of all the saved configuration changes that can be applied dynamically without restarting services. The default value is True.

Return Values

This method has no return values. If the call is unsuccessful, an error is raised that can be intercepted by using an error handler.

Remarks

Configuration changes are applied only after the new settings are written to persistent storage and reloaded to the services that use them. Most changes can be applied dynamically without restarting any services. However, some changes can take effect only after the Microsoft Firewall service is restarted. For more information, see Restarting Services after Configuration Changes.

ISA Server maintains a bitmask that specifies which services need to be started for currently unsaved changes to take effect. This bitmask can be retrieved by calling the GetServiceRestartMask method on an object that contains this object as a subobject. Calling the Save method clears all of the bits in this bitmask even if the fResetRequiredServices parameter is set to False.

If the fReloadConfiguration parameter is set to False the current values will be written to persistent storage without updating the configuration being used by the ISA Server services. The configuration used by each service will not be updated until the service is restarted or the new settings are reloaded by another call to Save.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCPublicNames


FPCRadiusServer object [ISA Server 2004]

FPCRadiusServer

The FPCRadiusServer object represents a RADIUS server. For more information about RADIUS servers, see RADIUS Authentication and Accounting.

This object is typically an element of an FPCRadiusServers collection.

Click here to see the ISA Server object hierarchy.

Inheritance

This object inherits from the FPCPersist object, which contains methods and properties related to the persistent storage of an object's data. They include methods for exporting the object's data to and importing it from an XML document.

Methods

This object has no methods.

Properties

The FPCRadiusServer object has the following properties.

Property | Description
AlwaysUseMessageAuthenticator | Gets a Boolean value that indicates whether a message authenticator based on the shared secret is sent with every message sent to the RADIUS server.
ConnectionTimeout | Gets or sets the amount of time, in seconds, allowed for a connection to be established with the RADIUS server.
Description | Gets or sets the description of the RADIUS server.
Name | Gets or sets the name of the RADIUS server.
Order | Gets the ordinal position of the RADIUS server in the list of RADIUS servers, which corresponds to the order in which the RADIUS servers handle an authentication request.
Port | Gets or sets the port for connecting with the RADIUS server.
SharedSecret | Sets the shared secret that is used to create digital signatures for authenticating to the RADIUS server.

Methods Inherited from FPCPersist

Name | Description
CancelWaitForChanges | Cancels the registration established by the WaitForChanges method (for use in C and C++ programming only).
CanImport | Returns a Boolean value that indicates whether the object's properties can be imported from the specified XML document.
Export | Writes the stored values of all of the object's properties to the specified XML document.
ExportToFile | Writes the stored values of all of the object's properties to the specified XML file.
GetServiceRestartMask | Retrieves a 32-bit bitmask of the FpcServices enumerated type that specifies which services need to be restarted for currently unsaved changes to take effect.
Import | Copies the values of all of the object's properties from the specified XML document to persistent storage.
ImportFromFile | Copies the values of all of the object's properties from the specified XML file to persistent storage.
LoadDocProperties | Provides the XML document's properties so that you can know what information can be imported from the document.
Refresh | Reads the values of all of the object's properties from persistent storage, overwriting any changes that have not been saved.
Save | Writes the current values of all of the object's properties to persistent storage.
WaitForChanges | Registers to wait for an event indicating that the contents of the object have changed (for use in C and C++ programming only).

Properties Inherited from FPCPersist

Name | Description
PersistentName | Gets the persistent name of the object. The persistent name of an object is a name that is unique for the object at the respective level of the COM object hierarchy.
VendorParametersSets | Gets an FPCVendorParametersSets object that can hold sets of custom data for extending the object.

Remarks

This object implements the IFPCRadiusServer interface.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

COM Objects


IFPCRadiusServer.AlwaysUseMessageAuthenticator property [ISA Server 2004]

AlwaysUseMessageAuthenticator Property of IFPCRadiusServer[C++]

FPCRadiusServer.AlwaysUseMessageAuthenticator [Visual Basic]

[C++]

The AlwaysUseMessageAuthenticator property gets or sets a Boolean value that indicates whether a message authenticator based on the shared secret is to be sent with every message sent to the RADIUS server.

HRESULT get_AlwaysUseMessageAuthenticator(
  VARIANT_BOOL* pfUseAuthenticator
);

HRESULT put_AlwaysUseMessageAuthenticator(
  VARIANT_BOOL fUseAuthenticator
);

Parameters

pfUseAuthenticator
Pointer to a Boolean variable that is set on return to VARIANT_TRUE if a message authenticator is to be sent with every RADIUS request, or to VARIANT_FALSE if no message authenticator is to be sent with a RADIUS request.
fUseAuthenticator
Boolean value that specifies whether a message authenticator is to be sent with every message sent to the RADIUS server.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write.

A message authenticator is a digital signature based on the shared secret. Extensible Authentication Protocol (EAP) messages are always sent with a digital signature.

This property must be set to VARIANT_TRUE if the RADIUS server is a Windows 2000 computer running Internet Authentication Service (IAS) and the RADIUS client that is configured for this server has the Client must always send the signature attribute in the request option selected.

[Visual Basic]

The AlwaysUseMessageAuthenticator property gets or sets a Boolean value that indicates whether a message authenticator based on the shared secret is to be sent with every message sent to the RADIUS server.

Property AlwaysUseMessageAuthenticator As Boolean

Property Value

Boolean value that specifies whether a message authenticator is to be sent with every message sent to the RADIUS server.

Remarks

This property is read/write.

A message authenticator is a digital signature based on the shared secret. Extensible Authentication Protocol (EAP) messages are always sent with a digital signature.

This property must be set to True if the RADIUS server is a Windows 2000 computer running Internet Authentication Service (IAS) and the RADIUS client that is configured for this server has the Client must always send the signature attribute in the request option selected.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCRadiusServer


IFPCRadiusServer | FPCRadiusServer ConnectionTimeout property [ISA Server 2004]

ConnectionTimeout Property of IFPCRadiusServer[C++]

FPCRadiusServer.ConnectionTimeout [Visual Basic]

[C++]

The ConnectionTimeout property gets or sets the amount of time, in seconds, during which a connection may be established with the RADIUS server.

HRESULT get_ConnectionTimeout(
  long* plTimeout
);

HRESULT put_ConnectionTimeout(
  long lTimeout
);

Parameters

plTimeout
Pointer to a variable that on return receives a 32-bit integer specifying the amount of time, in seconds, during which a connection may be established with the RADIUS server.
lTimeout
A 32-bit integer that specifies the amount of time, in seconds, during which a connection may be established with the RADIUS server.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write.

[Visual Basic]

The ConnectionTimeout property gets or sets the amount of time, in seconds, during which a connection may be established with the RADIUS server.

Property ConnectionTimeout As Long

Property Value

A 32-bit integer that specifies the amount of time, in seconds, during which a connection may be established with the RADIUS server.

Remarks

This property is read/write.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCRadiusServer


IFPCRadiusServer | FPCRadiusServer Description property [ISA Server 2004]

Description Property of IFPCRadiusServer[C++]

FPCRadiusServer.Description [Visual Basic]

[C++]

The Description property gets or sets the description for the RADIUS server.

HRESULT get_Description(
  BSTR* pbstrDescription
);

HRESULT put_Description(
  BSTR bstrDescription
);

Parameters

pbstrDescription
Pointer to a BSTR that is set on return to a string value specifying the description for the RADIUS server.
bstrDescription
BSTR that specifies the description for the RADIUS server.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write.

[Visual Basic]

The Description property gets or sets the description for the RADIUS server.

Property Description As String

Property Value

String that specifies the description for the RADIUS server.

Remarks

This property is read/write.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCRadiusServer


IFPCRadiusServer | FPCRadiusServer Name(BSTR,BSTR) property [ISA Server 2004]

Name Property of IFPCRadiusServer[C++]

FPCRadiusServer.Name [Visual Basic]

[C++]

The Name property gets or sets the name of the RADIUS server.

HRESULT get_Name(
  BSTR* pbstrName
);

HRESULT put_Name(
  BSTR bstrName
);

Parameters

pbstrName
Pointer to a BSTR that is set on return to a string value specifying the name of the RADIUS server.
bstrName
BSTR that specifies the name of the RADIUS server.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write.

[Visual Basic]

The Name property gets or sets the name of the RADIUS server.

Property Name As String

Property Value

String that specifies the name of the RADIUS server.

Remarks

This property is read/write.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCRadiusServer


IFPCRadiusServer | FPCRadiusServer Order(long) property [ISA Server 2004]

Order Property of IFPCRadiusServer[C++]

FPCRadiusServer.Order [Visual Basic]

[C++]

The Order property gets the ordinal position of the RADIUS server in the list of RADIUS servers, which corresponds to the order in which the RADIUS servers handle an authentication request. If the first server in the list is unavailable, the request is forwarded to the second server, and so on.

HRESULT get_Order(
  long* plOrder
);

Parameters

plOrder
Pointer to a variable that on return receives a 32-bit integer specifying the ordinal position of the RADIUS server in the list of RADIUS servers.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only. It corresponds to the one-based index of the object in the FPCRadiusServers collection, and can be modified by calling the MoveUp and MoveDown methods of the FPCRadiusServers collection. Because these methods change the ordinal positions of more than one RADIUS server in the collection, the Save method must be called on the collection to write the changes to persistent storage.

[Visual Basic]

The Order property gets the ordinal position of the RADIUS server in the list of RADIUS servers, which corresponds to the order in which the RADIUS servers handle an authentication request. If the first server in the list is unavailable, the request is forwarded to the second server, and so on.

Property Order As Long

Property Value

A 32-bit integer value that specifies the ordinal position of the RADIUS server in the list of RADIUS servers.

Remarks

This property is read-only. It corresponds to the one-based index of the object in the FPCRadiusServers collection, and can be modified by calling the MoveUp and MoveDown methods of the FPCRadiusServers collection. Because these methods change the ordinal positions of more than one RADIUS server in the collection, the Save method must be called on the collection to write the changes to persistent storage.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCRadiusServer


IFPCRadiusServer | FPCRadiusServer Port(long,long) property [ISA Server 2004]

Port Property of IFPCRadiusServer[C++]

FPCRadiusServer.Port [Visual Basic]

[C++]

The Port property gets or sets the port for connecting with the RADIUS server.

HRESULT get_Port(
  long* plPort
);

HRESULT put_Port(
  long lPort
);

Parameters

plPort
Pointer to a variable that on return receives a 32-bit integer specifying the port for connecting with the RADIUS server.
lPort
A 32-bit integer that specifies the port for connecting with the RADIUS server.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write.

[Visual Basic]

The Port property gets or sets the port for connecting with the RADIUS server.

Property Port As Long

Property Value

A 32-bit integer that specifies the port.

Remarks

This property is read/write.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCRadiusServer


IFPCRadiusServer | FPCRadiusServer SharedSecret(BSTR) property [ISA Server 2004]

SharedSecret Property of IFPCRadiusServer[C++]

FPCRadiusServer.SharedSecret [Visual Basic]

[C++]

The SharedSecret property sets the shared secret for the RADIUS server. The shared secret is an encryption key used by the RADIUS server. The same shared secret must be configured on both the FPCRadiusServer object and the RADIUS server for successful RADIUS communications to occur. The shared secret is case-sensitive.

HRESULT put_SharedSecret(
  BSTR bstrSharedSecret
);

Parameters

bstrSharedSecret
BSTR that specifies the shared secret.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is write-only.

[Visual Basic]

The SharedSecret property sets the shared secret for the RADIUS server. The shared secret is an encryption key used by the RADIUS server. The same shared secret must be configured on both the FPCRadiusServer object and the RADIUS server for successful RADIUS communications to occur. The shared secret is case-sensitive.

Property SharedSecret As String

Property Value

String that specifies the shared secret.

Remarks

This property is write-only.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCRadiusServer


FPCRadiusServers collection [ISA Server 2004]

FPCRadiusServers Collection

The FPCRadiusServers collection is an ordered set of FPCRadiusServer objects. An FPCRadiusServer object represents a RADIUS server against which a VPN client and a Web proxy client can perform RADIUS authentication.

This collection is typically accessed through the RadiusServers property of an FPCRuleElements object.

Click here to see the ISA Server object hierarchy.

Inheritance

This collection inherits from the FPCPersist object, which contains methods and properties related to the persistent storage of an object's data. They include methods for exporting an object's data to and importing it from an XML document.

Methods

The FPCRadiusServers collection defines the following methods.

Method | Description
Add | Creates a new FPCRadiusServer object in the collection and returns a reference to it.
Item | Retrieves the requested FPCRadiusServer object from the collection.
MoveDown | Moves the specified server one step down the list of RADIUS servers, which corresponds to the order in which RADIUS servers handle an authentication request.
MoveUp | Moves the specified server one step up the list of RADIUS servers, which corresponds to the order in which RADIUS servers handle an authentication request.
Remove | Removes the specified FPCRadiusServer object from the collection.

Properties

The FPCRadiusServers collection has the following properties.

Property | Description
_NewEnum | Gets an enumerator object for the collection.
Count | Gets the number of FPCRadiusServer objects in the collection.
Retries | Gets or sets the number of times each server in the collection retries an authentication request.
UnavailabilityTime | Gets or sets the time during which a RADIUS server that failed to respond to retried requests will remain unavailable for subsequent requests.

Methods Inherited from FPCPersist

Name | Description
CancelWaitForChanges | Cancels the registration established by the WaitForChanges method (for use in C and C++ programming only).
CanImport | Returns a Boolean value that indicates whether the properties of the collection and its elements can be imported from the specified XML document.
Export | Writes the stored values of all the properties of the collection and its elements to the specified XML document.
ExportToFile | Writes the stored values of all the properties of the collection and its elements to the specified XML file.
GetServiceRestartMask | Retrieves a 32-bit bitmask of the FpcServices enumerated type that specifies which services need to be restarted for currently unsaved changes to take effect.
Import | Copies the values of all the properties of the collection and its elements from the specified XML document to persistent storage.
ImportFromFile | Copies the values of all the properties of the collection and its elements from the specified XML file to persistent storage.
LoadDocProperties | Provides the XML document's properties so that you can know what information can be imported from the document.
Refresh | Reads the values of all the properties of the collection and its elements from persistent storage, overwriting any changes that have not been saved.
Save | Writes the current values of all the properties of the collection and its elements to persistent storage.
WaitForChanges | Registers to wait for an event indicating that the contents of the object have changed (for use in C and C++ programming only).

Properties Inherited from FPCPersist

Name | Description
PersistentName | Gets the persistent name of the collection. The persistent name of an object is a name that is unique for the object at the respective level of the COM object hierarchy.
VendorParametersSets | Gets an FPCVendorParametersSets collection that can hold sets of custom data for extending the collection.

Remarks

This collection implements the IFPCRadiusServers interface.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

COM Objects


IFPCRadiusServers | FPCRadiusServers _NewEnum property [ISA Server 2004]

_NewEnum Property of IFPCRadiusServers[C++]

FPCRadiusServers._NewEnum [Visual Basic]

[C++]

The _NewEnum property gets an enumerator object for the collection. An enumerator object provides serial access to the elements of the collection.

HRESULT get__NewEnum(
  IUnknown* ppEnum
);

Parameters

ppEnum
Address of an interface pointer that on return points to the IUnknown interface of an enumerator object that implements an IEnumVARIANT interface for the collection. An interface pointer to the IEnumVARIANT interface of the enumerator object can be retrieved by calling QueryInterface on the IUnknown interface returned.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The _NewEnum property gets an enumerator object for the collection. An enumerator object provides serial access to the elements of the collection.

Property _NewEnum As IUnknown

Property Value

Reference to an enumerator object that provides serial access to the elements of the collection.

Remarks

This property is read-only.

In Visual Basic and VBScript, this property is used implicitly in For Each...In...Next constructs.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCRadiusServers


IFPCRadiusServers | FPCRadiusServers Add (2 Parameters) method [ISA Server 2004]

IFPCRadiusServers::Add[C++]

FPCRadiusServers.Add [Visual Basic]

[C++]

The Add method creates a new FPCRadiusServer object in the collection and returns a reference to it.

HRESULT Add(
  BSTR Name,
  IFPCRadiusServer** ppNewItem
);

Parameters

Name
[in] Required. BSTR that specifies the name of the new RADIUS server.
ppNewItem
[out] Address of an interface pointer that on return points to the new IFPCRadiusServer interface created.

Return Values

This method can return one of the following:

  • S_OK, indicating that the operation succeeded.
  • An error code, indicating that the operation failed. In this case, the [out] parameter returned is a null object.

[Visual Basic]

The Add method creates a new FPCRadiusServer object in the collection and returns a reference to it.

Function Add( _
  ByVal Name As String _
) As FPCRadiusServer

Parameters

Name
[in] Required. String that specifies the name of the new RADIUS server.

Return Values

This method returns a reference to an FPCRadiusServer object if successful. Otherwise, an error is raised that can be intercepted by using an error handler.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCRadiusServers


IFPCRadiusServers | FPCRadiusServers Count(long) property [ISA Server 2004]

Count Property of IFPCRadiusServers[C++]

FPCRadiusServers.Count [Visual Basic]

[C++]

The Count property gets the number of FPCRadiusServer objects in the collection.

HRESULT get_Count(
  long* plCount
);

Parameters

plCount
Pointer to a variable that on return receives a 32-bit integer specifying the number of FPCRadiusServer objects in the collection.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The Count property gets the number of FPCRadiusServer objects in the collection.

Property Count As Long

Property Value

A 32-bit integer that specifies the number of FPCRadiusServer objects in the collection.

Remarks

This property is read-only.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCRadiusServers


IFPCRadiusServers | FPCRadiusServers Item method [ISA Server 2004]

IFPCRadiusServers::Item[C++]

FPCRadiusServers.Item [Visual Basic]

[C++]

The Item method retrieves the requested IFPCRadiusServer interface from the collection.

HRESULT Item(
  VARIANT Index,
  IFPCRadiusServer** ppItem
);

Parameters

Index
[in] Required. Name or one-based index of the object to retrieve.
ppItem
[out] Address of an interface pointer that on return points to the IFPCRadiusServer interface requested.

Return Values

This method can return one of the following:

  • S_OK, indicating that the operation succeeded.
  • An error code, indicating that the operation failed. In this case, the [out] parameter returned is a null object.
[Visual Basic]

The Item method retrieves the requested FPCRadiusServer object from the collection.

Function Item( _
  ByVal Index As Variant _
) As FPCRadiusServer

Parameters

Index
[in] Required. Name or one-based index of the object to retrieve.

Return Values

This method returns a reference to the FPCRadiusServer object requested if successful. Otherwise, an error is raised that can be intercepted by using an error handler.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCRadiusServers


IFPCRadiusServers | FPCRadiusServers MoveDown method [ISA Server 2004]

IFPCRadiusServers::MoveDown[C++]

FPCRadiusServers.MoveDown [Visual Basic]

[C++]

The MoveDown method moves the specified server one step down the list of RADIUS servers, which corresponds to the order in which RADIUS servers handle an authentication request. If the first server in the list is unavailable, the request is directed to the second server, and so on. Authentication is tried on each RADIUS server the number of times indicated by the Retries property before the request is forwarded to the next server.

HRESULT MoveDown(
  long index
);

Parameters

index
[in] Required. Index (the current position indicated by the Order property of the IFPCRadiusServer interface) of the RADIUS server to move down.

Return Values

This method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

Use the MoveUp method to move a server one step up the list of RADIUS servers.

[Visual Basic]

The MoveDown method moves the specified server one step down the list of RADIUS servers, which corresponds to the order in which RADIUS servers handle an authentication request. If the first server in the list is unavailable, the request is directed to the second server, and so on. Authentication is tried on each RADIUS server the number of times indicated by the Retries property before the request is forwarded to the next server.

Sub MoveDown( _
  ByVal index As Long _
)

Parameters

index
[in] Required. Index (the current position indicated by the Order property of the FPCRadiusServer object) of the RADIUS server to move down.

Return Values

This method has no return values. If the call is unsuccessful, an error is raised that can be intercepted by using an error handler.

Remarks

Use the MoveUp method to move a server one step up the list of RADIUS servers.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCRadiusServers


IFPCRadiusServers | FPCRadiusServers MoveUp(Long,long) method [ISA Server 2004]

IFPCRadiusServers::MoveUp[C++]

FPCRadiusServers.MoveUp [Visual Basic]

[C++]

The MoveUp method moves the specified server one step up the list of RADIUS servers, which corresponds to the order in which RADIUS servers handle an authentication request. If the first server in the list is unavailable, the request is directed to the second server, and so on. Authentication is tried on each RADIUS server the number of times indicated by the Retries property before the request is forwarded to the next server.

HRESULT MoveUp(
  long index
);

Parameters

index
[in] Required. Index (the current position indicated by the Order property of the IFPCRadiusServer interface) of the RADIUS server to move up.

Return Values

This method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

Use the MoveDown method to move a server one step down the list of RADIUS servers.

[Visual Basic]

The MoveUp method moves the specified server one step up the list of RADIUS servers, which corresponds to the order in which RADIUS servers handle an authentication request. If the first server in the list is unavailable, the request is directed to the second server, and so on. Authentication is tried on each RADIUS server the number of times indicated by the Retries property before the request is forwarded to the next server.

Sub MoveUp( _
  ByVal index As Long _
)

Parameters

index
[in] Required. Index (the current position indicated by the Order property of the FPCRadiusServer object) of the RADIUS server to move up.

Return Values

This method has no return values. If the call is unsuccessful, an error is raised that can be intercepted by using an error handler.

Remarks

Use the MoveDown method to move a server one step down the list of RADIUS servers.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCRadiusServers


IFPCRadiusServers | FPCRadiusServers Remove(Variant) method [ISA Server 2004]

IFPCRadiusServers::Remove[C++]

FPCRadiusServers.Remove [Visual Basic]

[C++]

The Remove method removes the specified FPCRadiusServer object from the collection.

HRESULT Remove(
  VARIANT Index
);

Parameters

Index
[in] Required. Name or one-based index of the FPCRadiusServer object to remove.

Return Values

This method returns S_OK if the call is successful; otherwise, it returns an error code.

[Visual Basic]

The Remove method removes the specified FPCRadiusServer object from the collection.

Sub Remove( _
  ByVal Index As Variant _
)

Parameters

Index
[in] Required. Name or one-based index of the FPCRadiusServer object to remove.

Return Values

This method has no return values. If the call is unsuccessful, an error is raised that can be intercepted by using an error handler.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCRadiusServers


IFPCRadiusServers | FPCRadiusServers Retries property [ISA Server 2004]

Retries Property of IFPCRadiusServers[C++]

FPCRadiusServers.Retries [Visual Basic]

[C++]

The Retries property gets or sets the number of times an authentication request is retried. RADIUS servers handle an authentication request in the order determined by the Order property of each of the FPCRadiusServer objects in the collection. If the first server in the collection is unavailable, the request is forwarded to the second server, and so on. The number of times authentication is tried on each RADIUS server before the request is forwarded to the next server is set by the Retries property.

HRESULT get_Retries(
  long* plRetries
);

HRESULT put_Retries(
  long lRetries
);

Parameters

plRetries
Pointer to a variable that on return receives a 32-bit integer specifying the number of retries.
lRetries
A 32-bit integer that specifies the number of retries.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write.

[Visual Basic]

The Retries property gets or sets the number of times an authentication request is retried. RADIUS servers handle an authentication request in the order determined by the Order property of each of the FPCRadiusServer objects in the collection. If the first server in the collection is unavailable, the request is forwarded to the second server, and so on. The number of times authentication is tried on each RADIUS server before the request is forwarded to the next server is set by the Retries property.

Property Retries As Long

Property Value

A 32-bit integer that specifies the number of retries.

Remarks

This property is read/write.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCRadiusServers


IFPCRadiusServers.UnavailabilityTime (2 Parameters) property [ISA Server 2004]

UnavailabilityTime Property of IFPCRadiusServers[C++]

FPCRadiusServers.UnavailabilityTime [Visual Basic]

[C++]

The UnavailabilityTime property gets or sets the time during which a RADIUS server that failed to respond to retried requests will remain unavailable for subsequent requests.

HRESULT get_UnavailabilityTime(
  long* plSeconds
);

HRESULT put_UnavailabilityTime(
  VARIANT_BOOL lSeconds
);

Parameters

plSeconds
Pointer to a variable that on return receives a 32-bit integer specifying the time during which a RADIUS server that failed to respond to retried requests will remain unavailable for subsequent requests.
lSeconds
A 32-bit integer value that specifies the time during which a RADIUS server that failed to respond to retried requests will remain unavailable for subsequent requests.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write.

This property is only used by application filters that call the IFWXRadiusAuthenticator::AuthenticateRadiusUser method to request RADIUS authentication. Specifically, the ISA Server Web proxy, which is implemented as an application filter, uses this method to request RADIUS authentication of its clients, and the availability of RADIUS servers for authentication is therefore affected by the value of this property. Conversely, this property does not influence the availability of RADIUS accounting and authentication for VPN clients.

[Visual Basic]

The UnavailabilityTime property gets or sets the time during which a RADIUS server that failed to respond to retried requests will remain unavailable for subsequent requests.

Property UnavailabilityTime As Long

Property Value

A 32-bit integer that specifies the time during which a RADIUS server that failed to respond to retried requests will remain unavailable for subsequent requests.

Remarks

This property is read/write.

This property is only used by application filters that call the IFWXRadiusAuthenticator::AuthenticateRadiusUser method to request RADIUS authentication. Specifically, the ISA Server Web proxy, which is implemented as an application filter, uses this method to request RADIUS authentication of its clients, and the availability of RADIUS servers for authentication is therefore affected by the value of this property. Conversely, this property does not influence the availability of RADIUS accounting and authentication for VPN clients.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCRadiusServers


FPCReadOnlyIpRangeEntry object [ISA Server 2004]

FPCReadOnlyIpRangeEntry

The FPCReadOnlyIpRangeEntry object represents a read-only range of IP addresses defined by a lower bound and an upper bound.

The FPCReadOnlyIpRangeEntry object is typically an element of an FPCReadOnlyIpRangeSet collection.

Click here to see the ISA Server object hierarchy.

Methods

This object has no methods.

Properties

The FPCReadOnlyIpRangeEntry object has the following properties.

Property | Description
IP_From | Gets the lower bound of the IP address range.
IP_To | Gets the upper bound of the IP address range.

Remarks

This object implements the IFPCReadOnlyIpRangeEntry interface.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

COM Objects


IFPCReadOnlyIpRangeEntry.IP_From(BSTR) property [ISA Server 2004]

IP_From Property of IFPCReadOnlyIpRangeEntry[C++]

FPCReadOnlyIpRangeEntry.IP_From [Visual Basic]

[C++]

The IP_From property gets the lower bound of the IP address range.

HRESULT get_IP_From(
  BSTR* pbstrFrom
);

Parameters

pbstrFrom
Pointer to a BSTR that is set on return to a string value specifying the lower bound of the IP address range.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The IP_From property gets the lower bound of the IP address range.

Property IP_From As String

Property Value

String that specifies the lower bound of the IP address range.

Remarks

This property is read-only.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCReadOnlyIpRangeEntry


IFPCReadOnlyIpRangeEntry.IP_To(BSTR) property [ISA Server 2004]

IP_To Property of IFPCReadOnlyIpRangeEntry[C++]

FPCReadOnlyIpRangeEntry.IP_To [Visual Basic]

[C++]

The IP_To property gets the upper bound of the IP address range.

HRESULT get_IP_To(
  BSTR* pbstrTo
);

Parameters

pbstrTo
Pointer to a BSTR that is set on return to a string value specifying the upper bound of the IP address range.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The IP_To property gets the upper bound of the IP address range.

Property IP_To As String

Property Value

String that specifies the upper bound of the IP address range.

Remarks

This property is read-only.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCReadOnlyIpRangeEntry


FPCReadOnlyIpRangeSet collection [ISA Server 2004]

FPCReadOnlyIpRangeSet Collection

The FPCReadOnlyIpRangeSet collection holds a set of FPCReadOnlyIpRangeEntry objects that define the read-only IP address range. The FPCReadOnlyIpRangeSet collection is typically accessed through the IpRanges property of an FPCAdapter object. This collection can be used to retrieve information about the IP address ranges that are routed through a network adapter.

Click here to see the ISA Server object hierarchy.

Methods

The FPCReadOnlyIpRangeSet collection defines the following methods.

Method | Description
IsIpInSet | Determines whether the specified IP address is included in an IP address range in the collection.
IsRangeIntersect | Determines whether the specified IP address range intersects any of the IP address ranges in the collection.
Item | Retrieves the requested FPCReadOnlyIpRangeEntry object from the collection.
Refresh | Reads all of the properties of the collection and its elements from persistent storage, overwriting any changes that were not saved.

Properties

The FPCReadOnlyIpRangeSet collection has the following properties.

Property | Description
_NewEnum | Gets an enumerator object for the collection.
Count | Gets the number of FPCReadOnlyIpRangeEntry objects in the collection.

Remarks

This collection implements the IFPCReadOnlyIpRangeSet interface.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

COM Objects


IFPCReadOnlyIpRangeSet._NewEnum(IUnknown) property [ISA Server 2004]

_NewEnum Property of IFPCReadOnlyIpRangeSet[C++]

FPCReadOnlyIpRangeSet._NewEnum [Visual Basic]

[C++]

The _NewEnum property gets an enumerator object for the collection. An enumerator object provides serial access to the elements of the collection.

HRESULT get__NewEnum(
  IUnknown* ppEnum
);

Parameters

ppEnum
Address of an interface pointer that on return points to the IUnknown interface of an enumerator object that implements an IEnumVARIANT interface for the collection. An interface pointer to the IEnumVARIANT interface of the enumerator object can be retrieved by calling QueryInterface on the IUnknown interface returned.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The _NewEnum property gets an enumerator object for the collection. An enumerator object provides serial access to the elements of the collection.

Property _NewEnum As IUnknown

Property Value

Reference to an enumerator object that provides serial access to the elements of the collection.

Remarks

This property is read-only.

In Visual Basic and VBScript, this property is used implicitly in For Each...In...Next constructs.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCReadOnlyIpRangeSet


IFPCReadOnlyIpRangeSet | FPCReadOnlyIpRangeSet Count property [ISA Server 2004]

Count Property of IFPCReadOnlyIpRangeSet[C++]

FPCReadOnlyIpRangeSet.Count [Visual Basic]

[C++]

The Count property gets the number of FPCReadOnlyIpRangeEntry objects in the collection.

HRESULT get_Count(
  long* plCount
);

Parameters

plCount
Pointer to a variable that on return receives a 32-bit integer specifying the number of FPCReadOnlyIpRangeEntry objects in the collection.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The Count property gets the number of FPCReadOnlyIpRangeEntry objects in the collection.

Property Count As Long

Property Value

A 32-bit integer that specifies the number of FPCReadOnlyIpRangeEntry objects in the collection.

Remarks

This property is read-only.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCReadOnlyIpRangeSet


IFPCReadOnlyIpRangeSet.IsIpInSet(String,VARIANT_BOOL) method [ISA Server 2004]

IFPCReadOnlyIpRangeSet::IsIpInSet[C++]

FPCReadOnlyIpRangeSet.IsIpInSet [Visual Basic]

[C++]

The IsIpInSet method determines whether the specified IP address is included in an IP address range in the collection.

HRESULT IsIpInSet(
  BSTR IpStr,
  VARIANT_BOOL* pIsIpInSet
);

Parameters

IpStr
[in] Required. BSTR that specifies the IP address.
pIsIpInSet
[out] Pointer to a Boolean variable that is set on return to VARIANT_TRUE if the IP address is included in an IP address range in the collection, or to VARIANT_FALSE if the specified IP address is not included in an IP address range in the collection.

Return Values

This method can return one of the following:

  • S_OK, indicating that the operation succeeded.
  • An error code, indicating that the operation failed.

[Visual Basic]

The IsIpInSet method determines whether the specified IP address is included in an IP address range in the collection.

Function IsIpInSet( _
  ByVal IpStr As String _
) As Boolean

Parameters

IpStr
[in] Required. String that specifies the IP address.

Return Values

This method returns a Boolean value that indicates whether the IP address is included in an IP address range in the collection if the call is successful. Otherwise, an error is raised that can be intercepted by using an error handler.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCReadOnlyIpRangeSet


IFPCReadOnlyIpRangeSet.IsRangeIntersect (3 Parameters) method [ISA Server 2004]

IFPCReadOnlyIpRangeSet::IsRangeIntersect[C++]

FPCReadOnlyIpRangeSet.IsRangeIntersect [Visual Basic]

[C++]

The IsRangeIntersect method determines whether the specified IP address range intersects any of the IP address ranges in the collection.

HRESULT IsRangeIntersect(
  BSTR IpFrom,
  BSTR IpTo,
  VARIANT_BOOL* pIsRangeIntersect
);

Parameters

IpFrom
[in] Required. BSTR that specifies the lower bound of the IP address range.
IpTo
[in] Required. BSTR that specifies the upper bound of the IP address range.
pIsRangeIntersect
[out] Pointer to a Boolean variable that is set on return to VARIANT_TRUE if the IP address range intersects any of the IP address ranges in the collection, or to VARIANT_FALSE if the IP address range does not intersect any of the IP address ranges in the collection.

Return Values

This method can return one of the following:

  • S_OK, indicating that the operation succeeded.
  • An error code, indicating that the operation failed.

[Visual Basic]

The IsRangeIntersect method determines whether the specified IP address range intersects any of the IP address ranges in the collection.

Function IsRangeIntersect( _
  ByVal IpFrom As String, _
  ByVal IpTo As String _
) As Boolean

Parameters

IpFrom
[in] Required. String that specifies the lower bound of the IP address range.
IpTo
[in] Required. String that specifies the upper bound of the IP address range.

Return Values

This method returns a Boolean value that indicates whether the IP address range intersects with IP addresses that are in use if the call is successful. Otherwise, an error is raised that can be intercepted by using an error handler.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCReadOnlyIpRangeSet


IFPCReadOnlyIpRangeSet | FPCReadOnlyIpRangeSet Item method [ISA Server 2004]

IFPCReadOnlyIpRangeSet::Item[C++]

FPCReadOnlyIpRangeSet.Item [Visual Basic]

[C++]

The Item method retrieves the requested IFPCReadOnlyIpRangeEntry interface from the collection.

HRESULT Item(
  VARIANT IndexOrIP_From,
  BSTR IP_To,
  IFPCReadOnlyIpRangeEntry** ppItem
);

Parameters

IndexOrIP_From
[in] Required. One-based index or the lower bound of IP range entry to retrieve.
IP_To
[in, optional] BSTR that specifies the upper bound of the IP range entry to retrieve. This parameter must be specified if the IndexOrIP_From parameter is set to the lower bound of the IP range entry. The default value is NULL.
ppItem
[out] Address of an interface pointer that on return points to the IFPCReadOnlyIpRangeEntry interface requested.

Return Values

This method can return one of the following:

  • S_OK, indicating that the operation succeeded.
  • An error code, indicating that the operation failed. In this case, the [out] parameter returned is a null object.
[Visual Basic]

The Item method retrieves the requested FPCReadOnlyIpRangeEntry object from the collection.

Function Item( _
  ByVal IndexOrIP_From As Variant, _
  [ ByVal IP_To As String ] _
) As FPCReadOnlyIpRangeEntry

Parameters

IndexOrIP_From
[in] Required. One-based index or the lower bound of IP range entry to retrieve.
IP_To
[in, optional] String that specifies the upper bound of the IP range entry to retrieve. This parameter must be specified if the IndexOrIP_From parameter is set to the lower bound of the IP range entry. The default value is NULL.

Return Values

This method returns a reference to the FPCReadOnlyIpRangeEntry object requested if successful. Otherwise, an error is raised that can be intercepted by using an error handler.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCReadOnlyIpRangeSet


IFPCReadOnlyIpRangeSet | FPCReadOnlyIpRangeSet Refresh method [ISA Server 2004]

IFPCReadOnlyIpRangeSet::Refresh[C++]

FPCReadOnlyIpRangeSet.Refresh [Visual Basic]

[C++]

The Refresh method reads all of the properties of the collection and its elements from persistent storage, overwriting any changes that were not saved.

HRESULT Refresh();

Parameters

This method has no parameters.

Return Values

This method returns S_OK if the call is successful; otherwise, it returns an error code.
[Visual Basic]

The Refresh method reads all of the properties of the collection and its elements from persistent storage, overwriting any changes that were not saved.

Sub Refresh()

Parameters

This method has no parameters.

Return Values

This method has no return values. If the call is unsuccessful, an error is raised that can be intercepted by using an error handler.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCReadOnlyIpRangeSet


FPCReadyReport object [ISA Server 2004]

FPCReadyReport

The FPCReadyReport object represents a report that has been completed. This object is typically an element of an FPCReadyReports collection.

Click here to see the ISA Server object hierarchy.

Inheritance

This object inherits from the FPCPersist object, which contains methods and properties related to the persistent storage of an object's data. They include methods for exporting an object's data to and importing it from an XML document.

Methods

The FPCReadyReport object defines the following method.

Method | Description
SaveAsHtml | Saves the report to the specified folder in HTML format.

Properties

The FPCReadyReport object has the following properties.

Property | Description
CreatedTime | Gets a Date value that specifies the date and time in Coordinated Universal Time (UTC) when the report was created.
EndDate | Gets a Date value that specifies the end date for the period covered by the report.
Name | Gets the name of the report.
PeriodType | Gets a value from the FpcReportJobPeriodType enumerated type that specifies the type of period covered by the report.
StartDate | Gets a Date value that specifies the start date for the period covered by the report.
Status | Gets a value from the FpcReportStatus enumerated type that specifies the status of the report.

Methods Inherited from FPCPersist

Name | Description
CancelWaitForChanges | Cancels the registration established by the WaitForChanges method (for use in C and C++ programming only).
CanImport | Returns a Boolean value that indicates whether the object's properties can be imported from the specified XML document.
Export | Writes the stored values of all of the object's properties to the specified XML document.
ExportToFile | Writes the stored values of all of the object's properties to the specified XML file.
GetServiceRestartMask | Retrieves a 32-bit bitmask of the FpcServices enumerated type that specifies which services need to be restarted for currently unsaved changes to take effect.
Import | Copies the values of all of the object's properties from the specified XML document to persistent storage.
ImportFromFile | Copies the values of all of the object's properties from the specified XML file to persistent storage.
LoadDocProperties | Provides the XML document's properties so that you can know what information can be imported from the document.
Refresh | Reads the values of all of the object's properties from persistent storage, overwriting any changes that have not been saved.
Save | Writes the current values of all of the object's properties to persistent storage.
WaitForChanges | Registers to wait for an event indicating that the contents of the object have changed (for use in C and C++ programming only).

Properties Inherited from FPCPersist

Name | Description
PersistentName | Gets the persistent name of the object. The persistent name of an object is a name that is unique for the object at the respective level of the COM object hierarchy.
VendorParametersSets | Gets an FPCVendorParametersSets object that can hold sets of custom data for extending the object.

Remarks

This object implements the IFPCReadyReport interface.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

COM Objects


IFPCReadyReport | FPCReadyReport CreatedTime(DATE) property [ISA Server 2004]

CreatedTime Property of IFPCReadyReport[C++]

FPCReadyReport.CreatedTime [Visual Basic]

[C++]

The CreatedTime property gets a DATE value that specifies the date and time in Coordinated Universal Time (UTC) when the report was created.

HRESULT get_CreatedTime(
  DATE* pdCreatedTime
);

Parameters

pdCreatedTime
Pointer to a DATE value that is set on return to the value specifying the date and time in Coordinated Universal Time (UTC) when the report was created.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The CreatedTime property gets a Date value that specifies the date and time in Coordinated Universal Time (UTC) when the report was created.

Property CreatedTime As Date

Property Value

Date value that specifies the date and time in Coordinated Universal Time (UTC) when the report was created.

Remarks

This property is read-only.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCReadyReport


IFPCReadyReport | FPCReadyReport EndDate(DATE) property [ISA Server 2004]

EndDate Property of IFPCReadyReport[C++]

FPCReadyReport.EndDate [Visual Basic]

[C++]

The EndDate property gets a DATE value that specifies the end date for the period covered by the report.

HRESULT get_EndDate(
  DATE* pdEndDate
);

Parameters

pdEndDate
Pointer to a DATE value that is set on return to the value specifying the end date for the period covered by the report.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The EndDate property gets a Date value that specifies the end date for the period covered by the report.

Property EndDate As Date

Property Value

Date value that specifies the end date for the period covered by the report.

Remarks

This property is read-only.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCReadyReport


IFPCReadyReport | FPCReadyReport Name(BSTR) property [ISA Server 2004]

Name Property of IFPCReadyReport[C++]

FPCReadyReport.Name [Visual Basic]

[C++]

The Name property gets the name of the report.

HRESULT get_Name(
  BSTR* pbstrName
);

Parameters

pbstrName
Pointer to a BSTR that is set on return to a string value specifying the name of the report.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The Name property gets the name of the report.

Property Name

Property Value

String that specifies the name of the report.

Remarks

This property is read-only.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCReadyReport


IFPCReadyReport | FPCReadyReport PeriodType property [ISA Server 2004]

PeriodType Property of IFPCReadyReport[C++]

FPCReadyReport.PeriodType [Visual Basic]

[C++]

The PeriodType property gets a value from the FpcReportJobPeriodType enumerated type that specifies the type of period covered by the report.

HRESULT get_PeriodType(
  FpcReportJobPeriodType* pPeriod
);

Parameters

pPeriod
Pointer to a variable that on return receives a value from the FpcReportJobPeriodType enumerated type specifying the type of period covered by the report.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only. It can be set to different values by the SetAsDailyReportJob, SetAsMultipleDaysReportJob, and SetAsOncePerMonthReportJob methods of the corresponding FPCReportJob object.

[Visual Basic]

The PeriodType property gets a value from the FpcReportJobPeriodType enumerated type that specifies the type of period covered by the report.

Property PeriodType As FpcReportJobPeriodType

Property Value

Value from the FpcReportJobPeriodType enumerated type that specifies the type of period covered by the report.

Remarks

This property is read-only. It can be set to different values by the SetAsDailyReportJob, SetAsMultipleDaysReportJob, and SetAsOncePerMonthReportJob methods of the corresponding FPCReportJob object.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCReadyReport


IFPCReadyReport | FPCReadyReport SaveAsHtml method [ISA Server 2004]

IFPCReadyReport::SaveAsHtml[C++]

FPCReadyReport.SaveAsHtml [Visual Basic]

[C++]

The SaveAsHtml method saves a report to the specified folder in HTML format.

HRESULT SaveAsHtml(
  BSTR bstrDirectory,
  BSTR UserName,
  BSTR Password
);

Parameters

bstrDirectory
[in] BSTR specifying the path up to the parent folder that will contain the folder in which the report will be saved.
UserName
[in, optional] BSTR that specifies the user name. The default value is an empty BSTR.
Password
[in, optional] BSTR that specifies the password. The default value is an empty BSTR.

Return Values

This method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

The name of the folder in which the report will be saved consists of the report name from the Name property, the start date in mm.dd.yyyy format from the StartDate property, and the end date in mm.dd.yyyy format from the EndDate property in the form Name_(mm.dd.yyyy-mm.dd.yyyy). For example, if this property is set to D:\Reports, the name of the report is MyReport, the report covers the period from July 10, 2004 to July 12, 2004, the full path of the folder where the report will be saved will be D:\Reports\MyReport_(07.10.2004-07.12.2004).

[Visual Basic]

The SaveAsHtml method saves a report to the specified folder in HTML format.

Sub SaveAsHtml( _
  ByVal bstrDirectory As String, _
  [ ByVal UserName As String ], _
  [ ByVal Password As String ] _
)

Parameters

bstrDirectory
[in] String specifying the path up to the parent folder that will contain the folder in which the report will be saved.
UserName
[in, optional] String that specifies the user name. The default value is an empty string.
Password
[in, optional] String that specifies the password. The default value is an empty string.

Return Values

This method has no return values. If the call is unsuccessful, an error is raised that can be intercepted by using an error handler.

Remarks

The name of the folder in which the report will be saved consists of the report name from the Name property, the start date in mm.dd.yyyy format from the StartDate property, and the end date in mm.dd.yyyy format from the EndDate property in the form Name_(mm.dd.yyyy-mm.dd.yyyy). For example, if this property is set to D:\Reports, the name of the report is MyReport, the report covers the period from July 10, 2004 to July 12, 2004, the full path of the folder where the report will be saved will be D:\Reports\MyReport_(07.10.2004-07.12.2004).

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCReadyReport


IFPCReadyReport | FPCReadyReport StartDate(DATE) property [ISA Server 2004]

StartDate Property of IFPCReadyReport[C++]

FPCReadyReport.StartDate [Visual Basic]

[C++]

The StartDate property gets a DATE value that specifies the start date for the period covered by the report.

HRESULT get_StartDate(
  DATE* pdStartDate
);

Parameters

pdStartDate
Pointer to a DATE value that is set on return to the value specifying the start date for the period covered by the report.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The StartDate property gets a Date value that specifies the start date for the period covered by the report.

Property StartDate As Date

Property Value

Date value that specifies the start date for the period covered by the report.

Remarks

This property is read-only.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCReadyReport


IFPCReadyReport | FPCReadyReport Status (1 Parameter) property [ISA Server 2004]

Status Property of IFPCReadyReport[C++]

FPCReadyReport.Status [Visual Basic]

[C++]

The Status property gets a value from the FpcReportStatus enumerated type that specifies the status of the report.

HRESULT get_Status(
  FpcReportStatus* pStatus
);

Parameters

pStatus
Pointer to a variable that on return receives a value from the FpcReportStatus enumerated type specifying the status of the report.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The Status property gets a value from the FpcReportStatus enumerated type that specifies the status of the report.

Property Status As FpcReportStatus

Property Value

Value from the FpcReportStatus enumerated type that specifies the status of the report.

Remarks

This property is read-only.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCReadyReport


FPCReadyReports collection [ISA Server 2004]

FPCReadyReports Collection

The FPCReadyReports collection is an ordered set of FPCReadyReport objects. An FPCReadyReport object represents a report that has been completed.

This collection is typically accessed through the ReadyReports property of an FPCReports object.

Click here to see the ISA Server object hierarchy.

Inheritance

This collection inherits from the FPCPersist object, which contains methods and properties related to the persistent storage of an object's data. They include methods for exporting an object's data to and importing it from an XML document.

Methods

The FPCReadyReports collection defines the following methods.

Method | Description
Item | Retrieves the requested FPCReadyReport object from the collection.
Remove | Removes an FPCReadyReport object from the collection.

Properties

The FPCReadyReports collection has the following properties.

Property | Description
_NewEnum | Gets an enumerator object for the collection.
Count | Gets the number of report objects in the collection.

Methods Inherited from FPCPersist

Name | Description
CancelWaitForChanges | Cancels the registration established by the WaitForChanges method (for use in C and C++ programming only).
CanImport | Returns a Boolean value that indicates whether the properties of the collection and its elements can be imported from the specified XML document.
Export | Writes the stored values of all the properties of the collection and its elements to the specified XML document.
ExportToFile | Writes the stored values of all the properties of the collection and its elements to the specified XML file.
GetServiceRestartMask | Retrieves a 32-bit bitmask of the FpcServices enumerated type that specifies which services need to be restarted for currently unsaved changes to take effect.
Import | Copies the values of all the properties of the collection and its elements from the specified XML document to persistent storage.
ImportFromFile | Copies the values of all the properties of the collection and its elements from the specified XML file to persistent storage.
LoadDocProperties | Provides the XML document's properties so that you can know what information can be imported from the document.
Refresh | Reads the values of all the properties of the collection and its elements from persistent storage, overwriting any changes that have not been saved.
Save | Writes the current values of all the properties of the collection and its elements to persistent storage.
WaitForChanges | Registers to wait for an event indicating that the contents of the object have changed (for use in C and C++ programming only).

Properties Inherited from FPCPersist

Name | Description
PersistentName | Gets the persistent name of the collection. The persistent name of an object is a name that is unique for the object at the respective level of the COM object hierarchy.
VendorParametersSets | Gets an FPCVendorParametersSets collection that can hold sets of custom data for extending the collection.

Remarks

This collection implements the IFPCReadyReports interface.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

COM Objects


IFPCReadyReports | FPCReadyReports _NewEnum(IUnknown) property [ISA Server 2004]

_NewEnum Property of IFPCReadyReports[C++]

FPCReadyReports._NewEnum [Visual Basic]

[C++]

The _NewEnum property gets an enumerator object for the collection. An enumerator object provides serial access to the elements of the collection.

HRESULT get__NewEnum(
  IUnknown* ppEnum
);

Parameters

ppEnum
Address of an interface pointer that on return points to the IUnknown interface of an enumerator object that implements an IEnumVARIANT interface for the collection. An interface pointer to the IEnumVARIANT interface of the enumerator object can be retrieved by calling QueryInterface on the IUnknown interface returned.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The _NewEnum property gets an enumerator object for the collection. An enumerator object provides serial access to the elements of the collection.

Property _NewEnum As IUnknown

Property Value

Reference to an enumerator object that provides serial access to the elements of the collection.

Remarks

This property is read-only.

In Visual Basic and VBScript, this property is used implicitly in For Each...In...Next constructs.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCReadyReports


IFPCReadyReports | FPCReadyReports Count(long) property [ISA Server 2004]

Count Property of IFPCReadyReports[C++]

FPCReadyReports.Count [Visual Basic]

[C++]

The Count property gets the number of FPCReadyReport objects in the collection.

HRESULT get_Count(
  long* plCount
);

Parameters

plCount
Pointer to a variable that on return receives a 32-bit integer specifying the number of FPCReadyReport objects in the collection.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The Count property gets the number of FPCReadyReport objects in the collection.

Property Count As Long

Property Value

A 32-bit integer that specifies the number of FPCReadyReport objects in the collection.

Remarks

This property is read-only.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCReadyReports


IFPCReadyReports | FPCReadyReports Item (2 Parameters) method [ISA Server 2004]

IFPCReadyReports::Item[C++]

FPCReadyReports.Item [Visual Basic]

[C++]

The Item method retrieves the requested IFPCReadyReport interface from the collection.

HRESULT Item(
  VARIANT Index,
  IFPCReadyReport** ppItem
);

Parameters

Index
[in] Required. Name or one-based index of the object to retrieve.
ppItem
[out] Address of an interface pointer that on return points to the IFPCReadyReport interface requested.

Return Values

This method can return one of the following:

  • S_OK, indicating that the operation succeeded.
  • An error code, indicating that the operation failed. In this case, the [out] parameter returned is a null object.

[Visual Basic]

The Item method retrieves the requested FPCReadyReport object from the collection.

Function Item( _
  ByVal Index As Variant _
) As FPCReadyReport

Parameters

Index
[in] Required. Name or one-based index of the object to retrieve.

Return Values

This method returns a reference to the FPCReadyReport object requested if successful. Otherwise, an error is raised that can be intercepted by using an error handler.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCReadyReports


IFPCReadyReports | FPCReadyReports Remove(Variant) method [ISA Server 2004]

IFPCReadyReports::Remove[C++]

FPCReadyReports.Remove [Visual Basic]

[C++]

The Remove method removes the specified FPCReadyReport object from the collection.

HRESULT Remove(
  VARIANT Index
);

Parameters

Index
[in] Required. Name or one-based index of the FPCReadyReport object to remove.

Return Values

This method returns S_OK if the call is successful; otherwise, it returns an error code.

[Visual Basic]

The Remove method removes the specified FPCReadyReport object from the collection.

Sub Remove( _
  ByVal Index As Variant _
)

Parameters

Index
[in] Required. Name or one-based index of the FPCReadyReport object to remove.

Return Values

This method has no return values. If the call is unsuccessful, an error is raised that can be intercepted by using an error handler.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCReadyReports


FPCRef object [ISA Server 2004]

FPCRef

The FPCRef object is used to reference another object. You can use the FPCRef object and the FPCRefs collection to retrieve values needed for specific scripting situations.

This object is typically an element of an FPCRefs collection.

Click here to see the ISA Server object hierarchy.

Methods

The FPCRef object defines the following methods.

Method | Description
Refresh | Reads the object's configuration information from persistent storage, discarding any changes to the configuration that were not saved.
Save | Saves the object's configuration to persistent storage.

Properties

The FPCRef object has the following properties.

Property | Description
IncludeStatus | Gets a value from the FpcIncludeStatus enumerated type that specifies whether the referenced item is included in or excluded from the list of items to which a rule applies.
Name | Gets the name of the object referenced by this object.

Remarks

This object implements the IFPCRef interface.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

COM Objects


IFPCRef | FPCRef IncludeStatus(FpcIncludeStatus) property [ISA Server 2004]

IncludeStatus Property of IFPCRef[C++]

FPCRef.IncludeStatus [Visual Basic]

[C++]

The IncludeStatus property gets a value from the FpcIncludeStatus enumerated type that specifies whether the referenced item is included in or excluded from a rule.

HRESULT get_IncludeStatus(
  FpcIncludeStatus* pIncludeStatus
);

Parameters

pIncludeStatus
Pointer to a variable that on return receives a value from the FpcIncludeStatus enumerated type specifying whether the referenced item is included in or excluded from the list of items to which a rule applies.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only. It is set by the call to the Add method of the FPCRefs collection that creates the object.

The value of this property is meaningless for items in some FPCRefs collections, such as the collection accessed through the SpecifiedProtocols property of the FPCAccessProperties object. Here the inclusion of the specified protocols in the rule, or their exclusion from the rule, is indicated by the ProtocolSelectionMethod property.

[Visual Basic]

The IncludeStatus property gets a value from the FpcIncludeStatus enumerated type that specifies whether the referenced item is included in or excluded from a rule.

Property IncludeStatus As FpcIncludeStatus

Property Value

Value from the FpcIncludeStatus enumerated type that specifies whether the referenced item is included in or excluded from the list of items to which a rule applies.

Remarks

This property is read-only. It is set by the call to the Add method of the FPCRefs collection that creates the object.

The value of this property is meaningless for items in some FPCRefs collections, such as the collection accessed through the SpecifiedProtocols property of the FPCAccessProperties object. Here the inclusion of the specified protocols in the rule, or their exclusion from the rule, is indicated by the ProtocolSelectionMethod property.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCRef


IFPCRef | FPCRef Name(BSTR) property [ISA Server 2004]

Name Property of IFPCRef[C++]

FPCRef.Name [Visual Basic]

[C++]

The Name property gets the name of the object referenced by this object.

HRESULT get_Name(
  BSTR* pbstrName
);

Parameters

pbstrName
Pointer to a BSTR that is set on return to a string value specifying the name of the object referenced by this object.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The Name property gets the name of the object referenced by this object.

Property Name As String

Property Value

String that specifies the name of the object referenced by this object.

Remarks

This property is read-only.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCRef


IFPCRef | FPCRef Refresh method [ISA Server 2004]

IFPCRef::Refresh[C++]

FPCRef.Refresh [Visual Basic]

[C++]

The Refresh method reads all of the object's properties from persistent storage, overwriting any changes made after the last call to the Save method.

HRESULT Refresh();

Parameters

This method has no parameters.

Return Values

This method returns S_OK if the call is successful; otherwise, it returns an error code.
[Visual Basic]

The Refresh method reads all of the object's properties from persistent storage, overwriting any changes made after the last call to the Save method.

Sub Refresh()

Parameters

This method has no parameters.

Return Values

This method has no return values. If the call is unsuccessful, an error is raised that can be intercepted by using an error handler.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCRef


IFPCRef | FPCRef Save(VARIANT_BOOL,VARIANT_BOOL) method [ISA Server 2004]

IFPCRef::Save[C++]

FPCRef.Save [Visual Basic]

[C++]

The Save method writes the current values of all of the object's properties to persistent storage. It is important to remember that any changes made by scripts and programs are not saved until after the Save method is called.

HRESULT Save(
  VARIANT_BOOL fResetRequiredServices,
  VARIANT_BOOL fReloadConfiguration
);

Parameters

fResetRequiredServices
[in, optional] Boolean value that indicates whether to restart the services that need to be restarted for any of the changes saved to take effect. The default value is VARIANT_FALSE.
fReloadConfiguration
[in, optional] Boolean value that indicates whether the call will include synchronous reloading of all changes that can be applied dynamically without restarting services. The default value is VARIANT_TRUE.

Return Values

This method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

Configuration changes are applied only after the new settings are written to persistent storage and reloaded to the services that use them. Most changes can be applied dynamically without restarting any services. However, some changes can take effect only after the Microsoft Firewall service is restarted. For more information, see Restarting Services after Configuration Changes.

ISA Server maintains a bitmask that specifies which services need to be started for currently unsaved changes to take effect. This bitmask can be retrieved by calling the GetServiceRestartMask method on an object that contains this object as a subobject. Calling the Save method clears all of the bits in this bitmask even if the fResetRequiredServices parameter is set to VARIANT_FALSE.

If the fReloadConfiguration parameter is set to VARIANT_FALSE the current values of the object's properties will be written to persistent storage without updating the configuration being used by the ISA Server services. The configuration used by each service will not be updated until the service is restarted or the new settings are reloaded by another call to Save.

[Visual Basic]

The Save method writes the current values of all of the object's properties to persistent storage. It is important to remember that any changes made by scripts and programs are not saved until after the Save method is called.

Sub Save( _
  [ ByVal fResetRequiredServices As Boolean ], _
  [ ByVal fReloadConfiguration As Boolean ] _
)

Parameters

fResetRequiredServices
[in, optional] Boolean value that indicates whether to restart the services that need to be restarted for any of the changes saved to take effect. The default value is False.
fReloadConfiguration
[in, optional] Boolean value that indicates whether the call will include synchronous reloading of all the saved configuration changes that can be applied dynamically without restarting services. The default value is True.

Return Values

This method has no return values. If the call is unsuccessful, an error is raised that can be intercepted by using an error handler.

Remarks

Configuration changes are applied only after the new settings are written to persistent storage and reloaded to the services that use them. Most changes can be applied dynamically without restarting any services. However, some changes can take effect only after the Microsoft Firewall service is restarted. For more information, see Restarting Services after Configuration Changes.

ISA Server maintains a bitmask that specifies which services need to be started for currently unsaved changes to take effect. This bitmask can be retrieved by calling the GetServiceRestartMask method on an object that contains this object as a subobject. Calling the Save method clears all of the bits in this bitmask even if the fResetRequiredServices parameter is set to False.

If the fReloadConfiguration parameter is set to False the current values of the object's properties will be written to persistent storage without updating the configuration being used by the ISA Server services. The configuration used by each service will not be updated until the service is restarted or the new settings are reloaded by another call to Save.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCRef


FPCRefs collection [ISA Server 2004]

FPCRefs Collection

The FPCRefs collection represents a group of objects that are used by a rule. The FPCRefs collection can contain references to user sets, computer sets, or URL sets, for example. Note that each instance of the FPCRefs collection will contain a homogenous set of FPCRef objects.

The FPCRef object is used to reference another object. You can use the FPCRef object and the FPCRefs collection to retrieve values needed for specific scripting situations.

The FPCRefs collection is used in various properties of FPCAccessProperties, FPCCacheRule, FPCConnectionLimitPolicy, FPCNetworkSet, FPCProtocolDefinition, FPCRoutingRule, FPCSelectionIPs, FPCServerPublishingProperties, FPCSystemPolicyConfigGroup, FPCVpnConfiguration, FPCVpnQuarantineSettings, FPCWebListener, FPCWebListenerProperties, and FPCWebPublishingProperties objects.

Click here to see the ISA Server object hierarchy.

Methods

The FPCRefs collection defines the following methods.

Method | Description
Add | Creates a new FPCRef object, adds it to the collection, and returns a reference to it.
Exists | Returns a Boolean value that indicates whether the collection contains an object with the name specified.
Item | Retrieves the requested FPCRef object from the collection.
Refresh | Recursively reads the values of all the properties of the collection and its elements, including the properties of its subobjects from persistent storage, overwriting any changes that were not saved.
Remove | Removes the specified FPCRef object from the collection.
RemoveAll | Removes all elements from the collection.
RemoveSpecified | Removes the object that has the name specified from the collection.
Save | Recursively writes the values of the properties of the collection and its elements, including the properties of its subobjects to persistent storage.

Properties

The FPCRefs collection has the following properties.

Property | Description
_NewEnum | Gets an enumerator object for the collection.
Count | Gets the number of FPCRef objects in the collection.

Remarks

This collection implements the IFPCRefs interface.

Example Code [Visual Basic]

' Use the FPCRefs.Add method to add an FPCRef object reference to
' a user set to the list of user sets for exclusion.
array.ArrayPolicy.PolicyRules(1).AccessProperties.UserSets.Add "UserSet_1", fpcExclude

' Use the FPCRef.Name property to retrieve the name of the excluded
' user set.
array.ArrayPolicy.PolicyRules(1).AccessProperties.UserSets(1).Name

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

COM Objects


IFPCRefs | FPCRefs _NewEnum(IUnknown) property [ISA Server 2004]

_NewEnum Property of IFPCRefs[C++]

FPCRefs._NewEnum [Visual Basic]

[C++]

The _NewEnum property gets an enumerator object for the collection. An enumerator object provides serial access to the elements of the collection.

HRESULT get__NewEnum(
  IUnknown* ppEnum
);

Parameters

ppEnum
Address of an interface pointer that on return points to the IUnknown interface of an enumerator object that implements an IEnumVARIANT interface for the collection. An interface pointer to the IEnumVARIANT interface of the enumerator object can be retrieved by calling QueryInterface on the IUnknown interface returned.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The _NewEnum property gets an enumerator object for the collection. An enumerator object provides serial access to the elements of the collection.

Property _NewEnum As IUnknown

Property Value

Reference to an enumerator object that provides serial access to the elements of the collection.

Remarks

This property is read-only.

In Visual Basic and VBScript, this property is used implicitly in For Each...In...Next constructs.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCRefs


IFPCRefs | FPCRefs Add(String,FpcIncludeStatus,IFPCRef) method [ISA Server 2004]

IFPCRefs::Add[C++]

FPCRefs.Add [Visual Basic]

[C++]

The Add method creates a new FPCRef object in the collection and returns a reference to it.

HRESULT Add(
  BSTR Name,
  FpcIncludeStatus IncludeStatus,
  IFPCRef** ppNewRef
);

Parameters

Name
[in] Required. BSTR that specifies the name of the new object.
IncludeStatus
[in] Required. Value from the FpcIncludeStatus enumerated type that specifies whether the referenced item will be included in or excluded from the list of items to which a rule applies.
ppNewRef
[out] Address of an interface pointer that on return points to the new IFPCRef interface added.

Return Values

This method can return one of the following:

  • S_OK, indicating that the operation succeeded.
  • An error code, indicating that the operation failed. In this case, the [out] parameter returned is a null object.

Remarks

The IncludeStatus parameter must be set even when the collection is accessed through a property for which this parameter is meaningless, such as the SpecifiedProtocols property of the FPCAccessProperties object. Here the inclusion of the specified protocols in the rule, or their exclusion from the rule, is indicated by the ProtocolSelectionMethod property.

[Visual Basic]

The Add method creates a new FPCRef object in the collection and returns a reference to it.

Function Add( _
  ByVal Name As String, _
  ByVal IncludeStatus As FpcIncludeStatus _
) As FPCRef

Parameters

Name
[in] Required. String that specifies the name of the new object.
IncludeStatus
[in] Required. Value from the FpcIncludeStatus enumerated type that specifies whether the referenced item will be included in or excluded from the list of items to which a rule applies.

Return Values

This method returns a reference to the FPCRef object added if the call is successful. Otherwise, an error is raised that can be intercepted by using an error handler.

Remarks

The IncludeStatus parameter must be set even when the collection is accessed through a property for which this parameter is meaningless, such as the SpecifiedProtocols property of the FPCAccessProperties object. Here the inclusion of the specified protocols in the rule, or their exclusion from the rule, is indicated by the ProtocolSelectionMethod property.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCRefs


IFPCRefs | FPCRefs Count(long) property [ISA Server 2004]

Count Property of IFPCRefs[C++]

FPCRefs.Count [Visual Basic]

[C++]

The Count property gets the number of FPCRef objects in the collection.

HRESULT get_Count(
  long* plCount
);

Parameters

plCount
Pointer to a variable that on returns receives a 32-bit integer specifying the number of FPCRef objects in the collection.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The Count property gets the number of FPCRef objects in the collection.

Property Count As Long

Property Value

A 32-bit integer that specifies the number of FPCRef objects in the collection.

Remarks

This property is read-only.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCRefs


IFPCRefs | FPCRefs Exists(String,VARIANT_BOOL) method [ISA Server 2004]

IFPCRefs::Exists[C++]

FPCRefs.Exists [Visual Basic]

[C++]

The Exists method returns a Boolean value that indicates whether the collection contains an object with the name specified.

HRESULT Exists(
  BSTR Name,
  VARIANT_BOOL* pfExits
);

Parameters

Name
[in] Required. BSTR that specifies the name of the object.
pfExits
[out] Pointer to a Boolean variable that is set on return to VARIANT_TRUE if the collection contains an object with the name specified, or to VARIANT_FALSE if the collection does not contain an object with the name specified.

Return Values

This method returns S_OK if the call is successful; otherwise, it returns an error code.

[Visual Basic]

The Exists method returns a Boolean value that indicates whether the collection contains an object with the name specified.

Function Exists( _
  ByVal Name As String _
) As Boolean

Parameters

Name
[in] Required. String that specifies the name of the object.

Return Values

Boolean value that is set to True if the collection contains an object with the name specified, or to False if the collection does not contain an object with the name specified.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCRefs


IFPCRefs | FPCRefs Item(Long,IFPCRef) method [ISA Server 2004]

IFPCRefs::Item[C++]

FPCRefs.Item [Visual Basic]

[C++]

The Item method retrieves the requested IFPCRef interface from the collection.

HRESULT Item(
  long Index,
  IFPCRef** ppItem
);

Parameters

Index
[in] One-based index of the object to retrieve.
ppItem
[out] Address of a variable that receives a pointer to the IFPCRef interface requested.

Return Values

This method can return one of the following:

  • S_OK, indicating that the operation succeeded.
  • An error code, indicating that the operation failed. In this case, the [out] parameter returned is a null object.
[Visual Basic]

The Item method retrieves the requested FPCRef object from the collection.

Function Item( _
  ByVal Index As Long _
) As FPCRef

Parameters

Index
[in] One-based index of the object to retrieve.

Return Values

This method returns a reference to the FPCRef object requested if successful. Otherwise, an error is raised that can be intercepted by using an error handler.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCRefs


IFPCRefs | FPCRefs Refresh method [ISA Server 2004]

IFPCRefs::Refresh[C++]

FPCRefs.Refresh [Visual Basic]

[C++]

The Refresh method recursively reads all of the properties of the collection and of its elements from persistent storage, overwriting any changes made after the last call to the Save method.

HRESULT Refresh();

Parameters

This method has no parameters.

Return Values

This method returns S_OK if the call is successful; otherwise, it returns an error code.
[Visual Basic]

The Refresh method recursively reads all of the properties of the collection and of its elements from persistent storage, overwriting any changes made after the last call to the Save method.

Sub Refresh()

Parameters

This method has no parameters.

Return Values

This method has no return values. If the call is unsuccessful, an error is raised that can be intercepted by using an error handler.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCRefs


IFPCRefs | FPCRefs Remove(Long) method [ISA Server 2004]

IFPCRefs::Remove[C++]

FPCRefs.Remove [Visual Basic]

[C++]

The Remove method removes the specified FPCRef object from the collection.

HRESULT Remove(
  long Index
);

Parameters

Index
[in] One-based index of the FPCRef object to remove.

Return Values

This method returns S_OK if the call is successful; otherwise, it returns an error code.

[Visual Basic]

The Remove method removes the specified FPCRef object from the collection.

Sub Remove( _
  ByVal Index As Long _
)

Parameters

Index
[in] One-based index of the FPCRef object to remove.

Return Values

This method has no return values. If the call is unsuccessful, an error is raised that can be intercepted by using an error handler.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCRefs


IFPCRefs | FPCRefs RemoveAll method [ISA Server 2004]

IFPCRefs::RemoveAll[C++]

FPCRefs.RemoveAll [Visual Basic]

[C++]

The RemoveAll method removes all the FPCRef objects from the collection.

HRESULT RemoveAll();

Parameters

This method has no parameters.

Return Values

This method returns S_OK if the call is successful; otherwise, it returns an error code.
[Visual Basic]

The RemoveAll method removes all the FPCRef objects from the collection.

Sub RemoveAll()

Parameters

This method has no parameters.

Return Values

This method has no return values. If the call is unsuccessful, an error is raised that can be intercepted by using an error handler.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCRefs


IFPCRefs | FPCRefs RemoveSpecified(String) method [ISA Server 2004]

IFPCRefs::RemoveSpecified[C++]

FPCRefs.RemoveSpecified [Visual Basic]

[C++]

The RemoveSpecified method removes the object with the specified name from the collection.

HRESULT RemoveSpecified(
  BSTR Name
);

Parameters

Name
[in] Required. BSTR that specifies the name of the object to be removed.

Return Values

This method returns S_OK if the call is successful; otherwise, it returns an error code.
[Visual Basic]

The RemoveSpecified method removes the object with the specified name from the collection.

Sub RemoveSpecified( _
  ByVal Name As String _
)

Parameters

Name
[in] Required. String that specifies the name of the object to be removed.

Return Values

This method has no return values. If the call is unsuccessful, an error is raised that can be intercepted by using an error handler.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCRefs


IFPCRefs | FPCRefs Save(VARIANT_BOOL,VARIANT_BOOL) method [ISA Server 2004]

IFPCRefs::Save[C++]

FPCRefs.Save [Visual Basic]

[C++]

The Save method recursively writes the current values of all the properties of the collection and its elements to persistent storage. It is important to remember that any changes made by scripts and programs are not saved until after the Save method is called.

HRESULT Save(
  VARIANT_BOOL fResetRequiredServices,
  VARIANT_BOOL fReloadConfiguration
);

Parameters

fResetRequiredServices
[in, optional] Boolean value that indicates whether to restart the services that need to be restarted for any of the changes saved to take effect. The default value is VARIANT_FALSE.
fReloadConfiguration
[in, optional] Boolean value that indicates whether the call will include synchronous reloading of all changes that can be applied dynamically without restarting services. The default value is VARIANT_TRUE.

Return Values

This method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

Configuration changes are applied only after the new settings are written to persistent storage and reloaded to the services that use them. Most changes can be applied dynamically without restarting any services. However, some changes can take effect only after the Microsoft Firewall service is restarted. For more information, see Restarting Services after Configuration Changes.

ISA Server maintains a bitmask that specifies which services need to be started for currently unsaved changes to take effect. This bitmask can be retrieved by calling the GetServiceRestartMask method on an object that contains this object as a subobject. Calling the Save method clears all of the bits in this bitmask even if the fResetRequiredServices parameter is set to VARIANT_FALSE.

If the fReloadConfiguration parameter is set to VARIANT_FALSE the current values of the properties of the collection and its elements will be written to persistent storage without updating the configuration being used by the ISA Server services. The configuration used by each service will not be updated until the service is restarted or the new settings are reloaded by another call to Save.

[Visual Basic]

The Save method recursively writes the current values of all the properties of the collection and its elements to persistent storage. It is important to remember that any changes made by scripts and programs are not saved until after the Save method is called.

Sub Save( _
  [ ByVal fResetRequiredServices As Boolean ], _
  [ ByVal fReloadConfiguration As Boolean ] _
)

Parameters

fResetRequiredServices
[in, optional] Boolean value that indicates whether to restart the services that need to be restarted for any of the changes saved to take effect. The default value is False.
fReloadConfiguration
[in, optional] Boolean value that indicates whether the call will include synchronous reloading of all the saved configuration changes that can be applied dynamically without restarting services. The default value is True.

Return Values

This method has no return values. If the call is unsuccessful, an error is raised that can be intercepted by using an error handler.

Remarks

Configuration changes are applied only after the new settings are written to persistent storage and reloaded to the services that use them. Most changes can be applied dynamically without restarting any services. However, some changes can take effect only after the Microsoft Firewall service is restarted. For more information, see Restarting Services after Configuration Changes.

ISA Server maintains a bitmask that specifies which services need to be started for currently unsaved changes to take effect. This bitmask can be retrieved by calling the GetServiceRestartMask method on an object that contains this object as a subobject. Calling the Save method clears all of the bits in this bitmask even if the fResetRequiredServices parameter is set to False.

If the fReloadConfiguration parameter is set to False the current values of the properties of the collection and its elements will be written to persistent storage without updating the configuration being used by the ISA Server services. The configuration used by each service will not be updated until the service is restarted or the new settings are reloaded by another call to Save.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCRefs


FPCReportJob object [ISA Server 2004]

FPCReportJob

The FPCReportJob object represents a single report job. Report jobs specify the items to include in the reports and when to generate the reports.

Report jobs can be recurring, meaning that they generate reports at a regular frequency such as monthly or weekly, or run-once, meaning that they generate a single report.

When you set up a report job, in addition to configuring how frequently a report will be generated, you configure the period of time that the report will cover.

This object is typically an element of an FPCReportJobs collection.

Click here to see the ISA Server object hierarchy.

Inheritance

This object inherits from the FPCPersist object, which contains methods and properties related to the persistent storage of an object's data. They include methods for exporting the object's data to and importing it from an XML document.

Methods

The FPCReportJob object defines the following methods.

Method | Description
Run | Runs the report job if it is a recurring report job.
SetAsDailyReportJob | Sets the report job to run every day starting from a specified date.
SetAsMultipleDaysReportJob | Sets the report job to run on specific days of the week starting from a specified date.
SetAsOncePerMonthReportJob | Sets the report job to run once a month, on a specified day of the month, starting from a specified date.
SetAsRunOnceReportJob | Sets the report job to run only once over a specified period.
SetEmailing | Sets the properties for sending an e-mail message when the report job is completed.
SetPublishing | Sets the EnablePublishing and PublishDirectory properties.
SetServer | Sets the server on which the report job will run.
SetPublishingCredentials | Sets the UsePublishingCredentials property and the credentials for publishing reports generated by the report job.

Properties

The FPCReportJob object has the following properties.

Property | Description
AddLinkToPublishedReport | Gets a Boolean value that indicates whether a link to the published report will be added in the body of the e-mail message.
Categories | Gets or sets a value from the FpcReportJobCategory enumerated type that specifies the category of the report job.
Credentials | Gets an FPCCredentials object that represents the credentials needed to generate a report.
Description | Gets or sets the description of the report job.
EmailBody | Gets the body of the e-mail message that will be sent when the report job is completed.
EmailCC | Gets the Cc line of the e-mail message that will be sent when the report job is completed.
EmailFrom | Gets the From line of the e-mail message that will be sent when the report job is completed.
EmailTo | Gets the To line of the e-mail message that will be sent when the report job is completed.
Enabled | Gets or sets a Boolean value that indicates whether the report job is enabled.
EnableEmailing | Gets a Boolean value that indicates whether an e-mail message will be sent when the report job is completed.
EnablePublishing | Gets a Boolean value that indicates whether saving reports to a file is enabled.
Name | Gets or sets the name of the report job.
PeriodType | Gets a value from the FPCReportJobPeriodType enumerated type that specifies the type of period that the report will cover.
PublishCredentials | Gets an FPCCredentials object that represents the credentials for publishing reports generated by the report job.
PublishDirectory | Gets the directory to which the reports will be saved.
RecurrenceType | Gets the frequency with which a report will be generated.
RecurringReportJobDayOfMonth | Gets the day of the month on which a monthly report job will run.
RecurringReportJobDaysOfWeek | Gets a bitmask of the FpcDaysOfWeek enumerated type that specifies the days of the week on which a weekly report job will run.
RecurringReportJobStartDate | Gets the starting date for a recurring report job.
RunOnceReportJobPeriodEnd | Gets the concluding date of the period to be covered by a run-once report job.
RunOnceReportJobPeriodStart | Gets the starting date of the period to be covered by a run-once report job.
Server | Gets an FPCRef object that references the FPCServer object representing the server on which the report job will run.
SmtpServer | Gets the name of the SMTP server that will be used to send an e-mail message when the report job is completed.
UsePublishingCredentials | Gets a Boolean value that indicates whether credentials will be used in publishing reports generated by the report job.

Methods Inherited from FPCPersist

Name | Description
CancelWaitForChanges | Cancels the registration established by the WaitForChanges method (for use in C and C++ programming only).
CanImport | Returns a Boolean value that indicates whether the object's properties can be imported from the specified XML document.
Export | Recursively writes the stored values of all the properties of the object and its subobjects to the specified XML document.
ExportToFile | Recursively writes the stored values of all the properties of the object and its subobjects to the specified XML file.
GetServiceRestartMask | Retrieves a 32-bit bitmask of the FpcServices enumerated type that specifies which services need to be restarted for currently unsaved changes to take effect.
Import | Recursively copies the values of all the properties of the object and of its subobjects from the specified XML document to persistent storage.
ImportFromFile | Recursively copies the values of all the properties of the object and of its subobjects from the specified XML file to persistent storage.
LoadDocProperties | Provides the XML document's properties so that you can know what information can be imported from the document.
Refresh | Recursively reads the values of all the properties of the object and of its subobjects from persistent storage, overwriting any changes that have not been saved.
Save | Recursively writes the current values of all the properties of the object and its subobjects to persistent storage.
WaitForChanges | Registers to wait for an event indicating that the contents of the object have changed (for use in C and C++ programming only).

Properties Inherited from FPCPersist

Name | Description
PersistentName | Gets the persistent name of the object. The persistent name of an object is a name that is unique for the object at the respective level of the COM object hierarchy.
VendorParametersSets | Gets an FPCVendorParametersSets collection that can hold sets of custom data for extending the object.

Remarks

This object implements the IFPCReportJob interface.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

COM Objects


IFPCReportJob.AddLinkToPublishedReport(VARIANT_BOOL) property [ISA Server 2004]

AddLinkToPublishedReport Property of IFPCReportJob[C++]

FPCReportJob.AddLinkToPublishedReport [Visual Basic]

[C++]

The AddLinkToPublishedReport property gets a Boolean value that indicates whether a link to the published report will be added in the body of the e-mail message.

HRESULT get_AddLinkToPublishedReport(
  VARIANT_BOOL* fEnableEmail
);

Parameters

fEnableEmail
Pointer to a Boolean variable that is set on return to VARIANT_TRUE if a link to the published report will be added in the body of the e-mail message, or to VARIANT_FALSE if a link to the published report will not be added in the body of the e-mail message.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only. It can be set by calling the SetEmailing method.

[Visual Basic]

The AddLinkToPublishedReport property gets a Boolean value that indicates whether a link to the published report will be added in the body of the e-mail message.

Property AddLinkToPublishedReport As Boolean

Property Value

Boolean value that indicates whether a link to the published report will be added in the body of the e-mail message.

Remarks

This property is read-only. It can be set by calling the SetEmailing method.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCReportJob


IFPCReportJob | FPCReportJob Categories property [ISA Server 2004]

Categories Property of IFPCReportJob[C++]

FPCReportJob.Categories [Visual Basic]

[C++]

The Categories property gets or sets a value from the FpcReportJobCategory enumerated type that specifies the category of the report job.

HRESULT get_Categories(
  FpcReportJobCategory* pReportJobCategory
);

HRESULT put_Categories(
  FpcReportJobCategory ReportJobCategory
);

Parameters

pReportJobCategory
Pointer to a variable that on return receives a value from the FpcReportJobCategory enumerated type specifying the category of the report job.
ReportJobCategory
Value from the FpcReportJobCategory enumerated type that specifies the category of the report job.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write.

[Visual Basic]

The Categories property gets or sets a value from the FpcReportJobCategory enumerated type that specifies the category of the report job.

Property Categories As FpcReportJobCategory

Property Value

Value from the FpcReportJobCategory enumerated type that specifies the category of the report job.

Remarks

This property is read/write.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCReportJob


IFPCReportJob | FPCReportJob Credentials property [ISA Server 2004]

Credentials Property of IFPCReportJob[C++]

FPCReportJob.Credentials [Visual Basic]

[C++]

The Credentials property gets an FPCCredentials object that represents the credentials needed to generate a report.

HRESULT get_Credentials(
  IFPCCredentials** ppCredentials
);

Parameters

ppCredentials
Address of an interface pointer that on return points to an IFPCCredentials interface that represents the credentials needed to generate the report.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The Credentials property gets an FPCCredentials object that represents the credentials needed to generate a report.

Property Credentials As FPCCredentials

Property Value

Reference to an FPCCredentials object that represents the credentials needed to generate the report.

Remarks

This property is read-only.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCReportJob


IFPCReportJob | FPCReportJob Description(BSTR,BSTR) property [ISA Server 2004]

Description Property of IFPCReportJob[C++]

FPCReportJob.Description [Visual Basic]

[C++]

The Description property gets or sets the description of the report job.

HRESULT get_Description(
  BSTR* pbstrDescription
);

HRESULT put_Description(
  BSTR bstrDescription
);

Parameters

pbstrDescription
Pointer to a BSTR that is set on return to a string value specifying the description of the report job.
bstrDescription
BSTR that specifies the description of the report job.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write.

[Visual Basic]

The Description property gets or sets the description of the report job.

Property Description As String

Property Value

String that specifies the description of the report job.

Remarks

This property is read/write.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCReportJob


IFPCReportJob | FPCReportJob EmailBody(BSTR) property [ISA Server 2004]

EmailBody Property of IFPCReportJob[C++]

FPCReportJob.EmailBody [Visual Basic]

[C++]

The EmailBody property gets the body of the e-mail message that will be sent when the report job is completed.

HRESULT get_EmailBody(
  BSTR* pbstrEmailBody
);

Parameters

pbstrEmailBody
Pointer to a BSTR that is set on return to a string value specifying the body of the e-mail message that will be sent when the report job is completed.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only. It can be set using the SetEmailing method.

[Visual Basic]

The EmailBody property gets the body of the e-mail message that will be sent when the report job is completed.

Property EmailBody As String

Property Value

String that specifies the body of the e-mail message that will be sent when the report job is completed.

Remarks

This property is read-only. It can be set using the SetEmailing method.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCReportJob


IFPCReportJob | FPCReportJob EmailCC(BSTR) property [ISA Server 2004]

EmailCC Property of IFPCReportJob[C++]

FPCReportJob.EmailCC [Visual Basic]

[C++]

The EmailCC property gets the Cc line of the e-mail message that will be sent when the report job is completed.

HRESULT get_EmailCC(
  BSTR* pbstrEmailCC
);

Parameters

pbstrEmailCC
Pointer to a BSTR that is set on return to a string value specifying the Cc line of the e-mail message that will be sent when the report job is completed.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only. It can be set using the SetEmailing method.

[Visual Basic]

The EmailCC property gets the Cc line of the e-mail message that will be sent when the report job is completed.

Property EmailCC As String

Property Value

String that specifies the Cc line of the e-mail message that will be sent when the report job is completed.

Remarks

This property is read-only. It can be set using the SetEmailing method.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCReportJob


IFPCReportJob | FPCReportJob EmailFrom(BSTR) property [ISA Server 2004]

EmailFrom Property of IFPCReportJob[C++]

FPCReportJob.EmailFrom [Visual Basic]

[C++]

The EmailFrom property gets the From line of the e-mail message that will be sent when the report job is completed.

HRESULT get_EmailFrom(
  BSTR* pbstrEmailFrom
);

Parameters

pbstrEmailFrom
Pointer to a BSTR that is set on return to a string value specifying the From line of the e-mail message that will be sent when the report job is completed.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only. It can be set using the SetEmailing method.

[Visual Basic]

The EmailFrom property gets the From line of the e-mail message that will be sent when the report job is completed.

Property EmailFrom As String

Property Value

String that specifies the From line of the e-mail message that will be sent when the report job is completed.

Remarks

This property is read-only. It can be set using the SetEmailing method.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCReportJob


IFPCReportJob | FPCReportJob EmailTo(BSTR) property [ISA Server 2004]

EmailTo Property of IFPCReportJob[C++]

FPCReportJob.EmailTo [Visual Basic]

[C++]

The EmailTo property gets the To line of the e-mail message that will be sent when the report job is completed.

HRESULT get_EmailTo(
  BSTR* pbstrEmailTo
);

Parameters

pbstrEmailTo
Pointer to a BSTR that is set on return to a string value specifying the To line of the e-mail message that will be sent when the report job is completed.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only. It can be set using the SetEmailing method.

[Visual Basic]

The EmailTo property gets the To line of the e-mail message that will be sent when the report job is completed.

Property EmailTo As String

Property Value

String that specifies the To line of the e-mail message that will be sent when the report job is completed.

Remarks

This property is read-only. It can be set using the SetEmailing method.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCReportJob


IFPCReportJob | FPCReportJob Enabled (2 Parameters) property [ISA Server 2004]

Enabled Property of IFPCReportJob[C++]

FPCReportJob.Enabled [Visual Basic]

[C++]

The Enabled property gets or sets a Boolean value that indicates whether the report job is enabled.

HRESULT get_Enabled(
  VARIANT_BOOL* pfEnabled
);

HRESULT put_Enabled(
  VARIANT_BOOL fEnabled
);

Parameters

pfEnabled
Pointer to a Boolean variable that is set on return to VARIANT_TRUE if the report job is enabled, or to VARIANT_FALSE if the report job is disabled.
fEnabled
Boolean value that indicates whether the report job is enabled.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write.

[Visual Basic]

The Enabled property gets or sets a Boolean value that indicates whether the report job is enabled.

Property Enabled As Boolean

Property Value

Boolean value that indicates whether the report job is enabled.

Remarks

This property is read/write.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCReportJob


IFPCReportJob | FPCReportJob EnableEmailing property [ISA Server 2004]

EnableEmailing Property of IFPCReportJob[C++]

FPCReportJob.EnableEmailing [Visual Basic]

[C++]

The EnableEmailing property gets a Boolean value that indicates whether an e-mail message will be sent when the report job is completed.

HRESULT get_EnableEmailing(
  VARIANT_BOOL* fEnableEmail
);

Parameters

fEnableEmail
Pointer to a Boolean variable that is set on return to VARIANT_TRUE if sending an e-mail message upon completion of the report job is enabled, or to VARIANT_FALSE if sending an e-mail message upon completion of the report job is disabled.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only. It can be set by calling the SetEmailing method.

[Visual Basic]

The EnableEmailing property gets a Boolean value that indicates whether an e-mail message will be sent when the report job is completed.

Property EnableEmailing As Boolean

Property Value

Boolean value that indicates whether an e-mail message will be sent when the report job is completed.

Remarks

This property is read-only. It can be set by calling the SetEmailing method.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCReportJob


IFPCReportJob | FPCReportJob EnablePublishing property [ISA Server 2004]

EnablePublishing Property of IFPCReportJob[C++]

FPCReportJob.EnablePublishing [Visual Basic]

[C++]

The EnablePublishing property gets a Boolean value that indicates whether report publishing is enabled. Report publishing refers to the saving of reports to a file.

HRESULT get_EnablePublishing(
  VARIANT_BOOL* pfEnablePublishing
);

Parameters

pfEnablePublishing
Pointer to a Boolean variable that is set on return to VARIANT_TRUE if report publishing is enabled, or to VARIANT_FALSE if report publishing is disabled.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only. It can be set by calling the SetPublishing method.

[Visual Basic]

The EnablePublishing property gets a Boolean value that indicates whether report publishing is enabled. Report publishing refers to the saving of reports to a file.

Property EnablePublishing As Boolean

Property Value

Boolean value that indicates whether publishing of the report job is enabled.

Remarks

This property is read-only. It can be set by calling the SetPublishing method.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCReportJob


IFPCReportJob | FPCReportJob Name(BSTR,BSTR) property [ISA Server 2004]

Name Property of IFPCReportJob[C++]

FPCReportJob.Name [Visual Basic]

[C++]

The Name property gets or sets the name of the report job.

HRESULT get_Name(
  BSTR* pbstrName
);

HRESULT put_Name(
  BSTR bstrName
);

Parameters

pbstrName
Pointer to a BSTR that is set on return to a string value specifying the name of the report job.
bstrName
BSTR that specifies the name of the report job.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write.

[Visual Basic]

The Name property gets or sets the name of the report job.

Property Name As String

Property Value

String that specifies the name of the report job.

Remarks

This property is read/write.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCReportJob


IFPCReportJob | FPCReportJob PeriodType (1 Parameter) property [ISA Server 2004]

PeriodType Property of IFPCReportJob[C++]

FPCReportJob.PeriodType [Visual Basic]

[C++]

The PeriodType property gets a value from the FPCReportJobPeriodType enumerated type that specifies the type of period that the report will cover. A report job can cover a day, a week, a month, or a year, or can generate a run-once report.

HRESULT get_PeriodType(
  FpcReportJobPeriodType* pPeriodType
);

Parameters

pPeriodType
Pointer to a variable that on return receives a value from the FPCReportJobPeriodType enumerated type specifying the type of period that the report will cover.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The PeriodType property gets a value from the FPCReportJobPeriodType enumerated type that specifies the type of period that the report will cover. A report job can cover a day, a week, a month, or a year, or can generate a run-once report.

Property PeriodType As FpcReportJobPeriodType

Property Value

Value from the FPCReportJobPeriodType enumerated type that specifies the type of period that the report will cover.

Remarks

This property is read-only.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCReportJob


IFPCReportJob | FPCReportJob PublishCredentials property [ISA Server 2004]

PublishCredentials Property of IFPCReportJob[C++]

FPCReportJob.PublishCredentials [Visual Basic]

[C++]

The PublishCredentials property gets an FPCCredentials object that represents the credentials for publishing reports generated by the report job.

HRESULT get_PublishCredentials(
  IFPCCredentials** ppPublishCredentials
);

Parameters

ppPublishCredentials
Address of an interface pointer that on return points to an IFPCCredentials interface that represents the credentials for publishing reports generated by the report job.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The PublishCredentials property gets an FPCCredentials object that represents the credentials for publishing reports generated by the report job.

Property PublishCredentials As FPCCredentials

Property Value

Reference to an FPCCredentials object that represents the credentials for publishing reports generated by the report job.

Remarks

This property is read-only.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCReportJob


IFPCReportJob | FPCReportJob PublishDirectory(BSTR) property [ISA Server 2004]

PublishDirectory Property of IFPCReportJob[C++]

FPCReportJob.PublishDirectory [Visual Basic]

[C++]

The PublishDirectory property gets the directory to which reports will be saved.

HRESULT get_PublishDirectory(
  BSTR* pbstrDirectory
);

Parameters

pbstrDirectory
Pointer to a BSTR that is set on return to a string value specifying the directory to which reports will be saved.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only. It can be set by calling the SetPublishing method.

[Visual Basic]

The PublishDirectory property gets the directory to which reports will be saved.

Property PublishDirectory As String

Property Value

String that specifies the directory to which reports will be saved.

Remarks

This property is read-only. It can be set by calling the SetPublishing method.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCReportJob


IFPCReportJob | FPCReportJob RecurrenceType property [ISA Server 2004]

RecurrenceType Property of IFPCReportJob[C++]

FPCReportJob.RecurrenceType [Visual Basic]

[C++]

The RecurrenceType property gets a value from the FpcScheduledTaskRunningPeriod enumerated type that specifies the frequency with which the report will be generated.

HRESULT get_RecurrenceType(
  FpcScheduledTaskRunningPeriod* pRecurrence
);

Parameters

pRecurrence
Pointer to a variable that on return receives a value from the FpcScheduledTaskRunningPeriod enumerated type specifying the frequency with which the report will be generated.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The RecurrenceType property gets a value from the FpcScheduledTaskRunningPeriod enumerated type that specifies the frequency with which the report will be generated.

Property RecurrenceType As FpcScheduledTaskRunningPeriod

Property Value

Value from the FpcScheduledTaskRunningPeriod enumerated type that specifies the frequency with which the report will be generated.

Remarks

This property is read-only.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCReportJob


IFPCReportJob.RecurringReportJobDayOfMonth(long) property [ISA Server 2004]

RecurringReportJobDayOfMonth Property of IFPCReportJob[C++]

FPCReportJob.RecurringReportJobDayOfMonth [Visual Basic]

[C++]

The RecurringReportJobDayOfMonth property gets the day of the month on which a monthly report job will run.

HRESULT get_RecurringReportJobDayOfMonth(
  long* plDayOfMonth
);

Parameters

plDayOfMonth
Pointer to a 32-bit integer that is set on return to a long value specifying the day of the month.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The RecurringReportJobDayOfMonth property gets the day of the month on which a monthly report job will run.

Property RecurringReportJobDayOfMonth As Long

Property Value

A 32-bit integer that specifies the day of the month.

Remarks

This property is read-only.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCReportJob


IFPCReportJob.RecurringReportJobDaysOfWeek property [ISA Server 2004]

RecurringReportJobDaysOfWeek Property of IFPCReportJob[C++]

FPCReportJob.RecurringReportJobDaysOfWeek [Visual Basic]

[C++]

The RecurringReportJobDaysOfWeek property gets a bitmask of the FpcDaysOfWeek enumerated type that specifies the day of the week on which a weekly report job will run.

HRESULT get_RecurringReportJobDaysOfWeek(
  FpcDaysOfWeek* pDaysOfWeek
);

Parameters

pDaysOfWeek
Pointer to a value from the FpcDaysOfWeek enumerated type that is set on return to the bitmask specifying the day of the week on which a weekly report job will run.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only. It is set by calling the SetAsMultipleDaysReportJob method.

Each of the first seven bits in the bitmask corresponds to a day of the week. Bit 0 corresponds to Sunday, bit 1 corresponds to Monday, and so on.

[Visual Basic]

The RecurringReportJobDaysOfWeek property gets a bitmask of the FpcDaysOfWeek enumerated type that specifies the day of the week on which a weekly report job will run.

Property RecurringReportJobDaysOfWeek As FpcDaysOfWeek

Property Value

Bitmask of the FpcDaysOfWeek enumerated type that specifies the day of the week on which a weekly report job will run.

Remarks

This property is read-only. It is set by calling the SetAsMultipleDaysReportJob method.

Each of the first seven bits in the bitmask corresponds to a day of the week. Bit 0 corresponds to Sunday, bit 1 corresponds to Monday, and so on.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCReportJob


IFPCReportJob.RecurringReportJobStartDate(DATE) property [ISA Server 2004]

RecurringReportJobStartDate Property of IFPCReportJob[C++]

FPCReportJob.RecurringReportJobStartDate [Visual Basic]

[C++]

The RecurringReportJobStartDate property gets the start date for a recurring report job.

HRESULT get_RecurringReportJobStartDate(
  DATE* pdStartDate
);

Parameters

pdStartDate
Pointer to a DATE that is set on return to the value specifying the start date.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The RecurringReportJobStartDate property gets the start date for a recurring report job.

Property RecurringReportJobStartDate As Date

Property Value

Date value that specifies the start date.

Remarks

This property is read-only.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCReportJob


IFPCReportJob | FPCReportJob Run method [ISA Server 2004]

IFPCReportJob::Run[C++]

FPCReportJob.Run [Visual Basic]

[C++]

The Run method runs the report job.

HRESULT Run();

Parameters

This method has no parameters.

Return Values

This method returns S_OK if the call is successful; otherwise, it returns an error code.
[Visual Basic]

The Run method runs the report job.

Sub Run()

Parameters

This method has no parameters.

Return Values

This method has no return values. If the call is unsuccessful, an error is raised that can be intercepted by using an error handler.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCReportJob


IFPCReportJob.RunOnceReportJobPeriodEnd(DATE) property [ISA Server 2004]

RunOnceReportJobPeriodEnd Property of IFPCReportJob[C++]

FPCReportJob.RunOnceReportJobPeriodEnd [Visual Basic]

[C++]

The RunOnceReportJobPeriodEnd property gets the concluding date of the period to be covered by a run-once report job.

HRESULT get_RunOnceReportJobPeriodEnd(
  DATE* pdEndDate
);

Parameters

pdEndDate
Pointer to a DATE that is set on return to the value specifying the concluding date of the period to be covered by a run-once report job.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

For a run-once report job, the RunOnceReportJobPeriodStart and RunOnceReportJobPeriodEnd properties define the period. Both of these properties can be set using the SetAsRunOnceReportJob method.

[Visual Basic]

The RunOnceReportJobPeriodEnd property gets the concluding date of the period to be covered by a run-once report job.

Property RunOnceReportJobPeriodEnd As Date

Property Value

Date value that specifies the concluding date of the period to be covered by a run-once report job.

Remarks

This property is read-only.

For a run-once report job, the RunOnceReportJobPeriodStart and RunOnceReportJobPeriodEnd properties define the period. Both of these properties can be set using the SetAsRunOnceReportJob method.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCReportJob


IFPCReportJob.RunOnceReportJobPeriodStart(DATE) property [ISA Server 2004]

RunOnceReportJobPeriodStart Property of IFPCReportJob[C++]

FPCReportJob.RunOnceReportJobPeriodStart [Visual Basic]

[C++]

The RunOnceReportJobPeriodStart property gets the starting date of the period to be covered by a run-once report job.

HRESULT get_RunOnceReportJobPeriodStart(
  DATE* pdStartDate
);

Parameters

pdStartDate
Pointer to a DATE that is set on return to the value specifying the starting date of the period to be covered by a run-once report job.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

For a run-once report job, the RunOnceReportJobPeriodStart and RunOnceReportJobPeriodEnd properties define the period. Both of these properties can be set using the SetAsRunOnceReportJob method.

[Visual Basic]

The RunOnceReportJobPeriodStart property gets the starting date of the period to be covered by a run-once report job.

Property RunOnceReportJobPeriodStart As Date

Property Value

Date value that specifies the starting date of the period to be covered by a run-once report job.

Remarks

This property is read-only.

For a run-once report job, the RunOnceReportJobPeriodStart and RunOnceReportJobPeriodEnd properties define the period. Both of these properties can be set using the SetAsRunOnceReportJob method.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCReportJob


IFPCReportJob | FPCReportJob Server(IFPCRef) property [ISA Server 2004]

Server Property of IFPCReportJob[C++]

FPCReportJob.Server [Visual Basic]

[C++]

The Server property gets an FPCRef object that references the FPCServer object representing the server on which the report job will run.

HRESULT get_Server(
  IFPCRef** ppRef
);

Parameters

ppRef
Address of an interface pointer that on return points to an IFPCRef interface that references the FPCServer object representing the server on which the report job will run.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only. The server on which the report job will run can be set by calling the SetServer method.

[Visual Basic]

The Server property gets an FPCRef object that references the FPCServer object representing the server on which the report job will run.

Property Server As FPCRef

Property Value

Reference to an FPCRef object that references the FPCServer object representing the server on which the report job will run.

Remarks

This property is read-only. The server on which the report job will run can be set by calling the SetServer method.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCReportJob


IFPCReportJob | FPCReportJob SetAsDailyReportJob method [ISA Server 2004]

IFPCReportJob::SetAsDailyReportJob[C++]

FPCReportJob.SetAsDailyReportJob [Visual Basic]

[C++]

The SetAsDailyReportJob method sets the report job to run every day starting from a specified date.

HRESULT SetAsDailyReportJob(
  FpcReportJobPeriodType PeriodType,
  DATE StartDate
);

Parameters

PeriodType
[in] Value from the FpcReportJobPeriodType enumerated type that specifies the type of period (such as a day, a week, or a month) that the daily report will cover. The value fpcReportJobPeriodCustom, which is reserved for report jobs that run once, is not allowed.
StartDate
[in, optional] Date value indicating the day on which the report will start being generated. The default value is the day on which the report job was created.

Return Values

This method returns S_OK if the call is successful; otherwise, it returns an error code.
[Visual Basic]

The SetAsDailyReportJob method sets the report job to run every day starting from a specified date.

Sub SetAsDailyReportJob( _
  ByVal PeriodType As FpcReportJobPeriodType, _
  [ ByVal StartDate As Date ] _
)

Parameters

PeriodType
[in] Value from the FpcReportJobPeriodType enumerated type that specifies the type of period (such as a day, a week, or a month) that the daily report will cover. The value fpcReportJobPeriodCustom, which is reserved for report jobs that run once, is not allowed.
StartDate
[in, optional] Date value indicating the day on which the report will start being generated. The default value is the day on which the report job was created.

Return Values

This method has no return values. If the call is unsuccessful, an error is raised that can be intercepted by using an error handler.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCReportJob


IFPCReportJob.SetAsMultipleDaysReportJob (3 Parameters) method [ISA Server 2004]

IFPCReportJob::SetAsMultipleDaysReportJob[C++]

FPCReportJob.SetAsMultipleDaysReportJob [Visual Basic]

[C++]

The SetAsMultipleDaysReportJob method sets the report job to run on specific days of the week starting from a specified date.

HRESULT SetAsMultipleDaysReportJob(
  FpcDaysOfWeek Days,
  FpcReportJobPeriodType PeriodType,
  DATE StartDate
);

Parameters

Days
[in] Bitmask of the FpcDaysOfWeek enumerated type that specifies the days of the week on which the report will run.
PeriodType
[in] Value from the FpcReportJobPeriodType enumerated type that specifies the type of period (such as a day, a week, or a month) that each report will cover. The value fpcReportJobPeriodCustom, which is reserved for report jobs that run once, is not allowed.
StartDate
[in, optional] Date value indicating the day on which the report will start being generated. The default value is the day on which the report job was created.

Return Values

This method returns S_OK if the call is successful; otherwise, it returns an error code.
[Visual Basic]

The SetAsMultipleDaysReportJob method sets the report job to run on specific days of the week starting from a specified date.

Sub SetAsMultipleDaysReportJob( _
  ByVal Days As FpcDaysOfWeek, _
  ByVal PeriodType As FpcReportJobPeriodType, _
  [ ByVal StartDate As Date ] _
)

Parameters

Days
[in] Bitmask of the FpcDaysOfWeek enumerated type that specifies the days of the week on which the report will run.
PeriodType
[in] Value from the FpcReportJobPeriodType enumerated type that specifies the type of period (such as a day, a week, or a month) that each report will cover. The value fpcReportJobPeriodCustom, which is reserved for report jobs that run once, is not allowed.
StartDate
[in, optional] Date value indicating the day on which the report will start being generated. The default value is the day on which the report job was created.

Return Values

This method has no return values. If the call is unsuccessful, an error is raised that can be intercepted by using an error handler.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCReportJob


IFPCReportJob.SetAsOncePerMonthReportJob (3 Parameters) method [ISA Server 2004]

IFPCReportJob::SetAsOncePerMonthReportJob[C++]

FPCReportJob.SetAsOncePerMonthReportJob [Visual Basic]

[C++]

The SetAsOncePerMonthReportJob method sets the report job to run once a month, on a specified day of the month, starting from a specified date.

HRESULT SetAsOncePerMonthReportJob(
  long DayOfMonth,
  FpcReportJobPeriodType PeriodType,
  DATE StartDate
);

Parameters

DayOfMonth
[in] A 32-bit integer that specifies the day of the month on which the report will be generated.
PeriodType
[in] Value from the FpcReportJobPeriodType enumerated type that specifies the type of period (such as a day, a week, or a month) that the daily report will cover. The value fpcReportJobPeriodCustom, which is reserved for report jobs that run once, is not allowed.
StartDate
[in, optional] Date value indicating the day on which the report will start being generated. The default value is the day on which the report job was created.

Return Values

This method returns S_OK if the call is successful; otherwise, it returns an error code.
[Visual Basic]

The SetAsOncePerMonthReportJob method sets the report job to run once a month, on a specified day of the month, starting from a specified date.

Sub SetAsOncePerMonthReportJob( _
  ByVal DayOfMonth As Long, _
  ByVal PeriodType As FpcReportJobPeriodType, _
  [ ByVal StartDate As Date ] _
)

Parameters

DayOfMonth
[in] A 32-bit integer that specifies the day of the month on which the report will be generated.
PeriodType
[in] Value from the FpcReportJobPeriodType enumerated type that specifies the type of period (such as a day, a week, or a month) that the daily report will cover. The value fpcReportJobPeriodCustom, which is reserved for report jobs that run once, is not allowed.
StartDate
[in, optional] Date value indicating the day on which the report will start being generated. The default value is the day on which the report job was created.

Return Values

This method has no return values. If the call is unsuccessful, an error is raised that can be intercepted by using an error handler.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCReportJob


IFPCReportJob | FPCReportJob SetAsRunOnceReportJob method [ISA Server 2004]

IFPCReportJob::SetAsRunOnceReportJob[C++]

FPCReportJob.SetAsRunOnceReportJob [Visual Basic]

[C++]

The SetAsRunOnceReportJob method sets the report job to run only once for a specified period.

HRESULT SetAsRunOnceReportJob(
  DATE PeriodStart,
  DATE dPeriodEnd
);

Parameters

PeriodStart
[in] Date value indicating the beginning of the period covered by the report job.
dPeriodEnd
[in] Date value indicating the end of the period covered by the report job.

Return Values

This method returns S_OK if the call is successful; otherwise, it returns an error code.
[Visual Basic]

The SetAsRunOnceReportJob method sets the report job to run only once for a specified period.

Sub SetAsRunOnceReportJob( _
  ByVal PeriodStart As Date, _
  ByVal dPeriodEnd As Date _
)

Parameters

PeriodStart
[in] Date value indicating the beginning of the period covered by the report job.
dPeriodEnd
[in] Date value indicating the end of the period covered by the report job.

Return Values

This method has no return values. If the call is unsuccessful, an error is raised that can be intercepted by using an error handler.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCReportJob


IFPCReportJob | FPCReportJob SetEmailing (8 Parameters) method [ISA Server 2004]

IFPCReportJob::SetEmailing[C++]

FPCReportJob.SetEmailing [Visual Basic]

[C++]

The SetEmailing method sets the properties for sending an e-mail message when the report job is completed.

HRESULT SetEmailing(
  VARIANT_BOOL fEnableEmailing,
  BSTR bstrSmtpServer,
  BSTR bstrEmailFrom,
  BSTR bstrEmailTo,
  BSTR bstrEmailCC,
  BSTR bstrEmailBody,
  VARIANT_BOOL fAddLinkToPublishedReport
);

Parameters

fEnableEmailing
[in] Boolean value that indicates whether sending the e-mail message is enabled.
bstrSmtpServer
[in, optional] String value that specifies the name of the SMTP server to be used to send the e-mail message. The default value is an empty string (NULL).
bstrEmailFrom
[in, optional] String value that specifies the From line of the e-mail message. The default value is an empty string (NULL).
bstrEmailTo
[in, optional] String value that specifies the To line of the e-mail message. The default value is an empty string (NULL).
bstrEmailCC
[in, optional] String value that specifies the Cc line of the e-mail message. The default value is an empty string (NULL).
bstrEmailBody
[in] String value that specifies the body of the e-mail message.
fAddLinkToPublishedReport
[in, optional] Boolean value that indicates whether a link to the published report will be added to the body of the e-mail message. The default value is VARIANT_FALSE.

Return Values

This method returns S_OK if the call is successful; otherwise, it returns an error code.
[Visual Basic]

The SetEmailing method sets the properties for sending an e-mail message when the report job is completed.

Sub SetEmailing( _
  ByVal fEnableEmailing As Boolean, _
  [ ByVal bstrSmtpServer As String ], _
  [ ByVal bstrEmailFrom As String ], _
  [ ByVal bstrEmailTo As String ], _
  [ ByVal bstrEmailCC As String ], _
  ByVal bstrEmailBody As String, _
  [ ByVal fAddLinkToPublishedReport As Boolean ] _
)

Parameters

fEnableEmailing
[in] Boolean value that indicates whether sending the e-mail message is enabled.
bstrSmtpServer
[in, optional] String value that specifies the name of the SMTP server to be used to send the e-mail message. The default value is an empty string (NULL).
bstrEmailFrom
[in, optional] String value that specifies the From line of the e-mail message. The default value is an empty string (NULL).
bstrEmailTo
[in, optional] String value that specifies the To line of the e-mail message. The default value is an empty string (NULL).
bstrEmailCC
[in, optional] String value that specifies the Cc line of the e-mail message. The default value is an empty string (NULL).
bstrEmailBody
[in] String value that specifies the body of the e-mail message.
fAddLinkToPublishedReport
[in, optional] Boolean value that indicates whether a link to the published report will be added to the body of the e-mail message. The default value is False.

Return Values

This method has no return values. If the call is unsuccessful, an error is raised that can be intercepted by using an error handler.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCReportJob


IFPCReportJob | FPCReportJob SetPublishing method [ISA Server 2004]

IFPCReportJob::SetPublishing[C++]

FPCReportJob.SetPublishing [Visual Basic]

[C++]

The SetPublishing method sets the EnablePublishing and PublishDirectory properties.

HRESULT SetPublishing(
  VARIANT_BOOL fEnablePublishing,
  BSTR bstrPublishDirectory
);

Parameters

fEnablePublishing
[in] Boolean value that specifies whether the report can be published (saved to a directory).
bstrPublishDirectory
[in, optional] String value that specifies the directory to which the report job will be saved. The default is an empty (NULL) string.

Return Values

This method returns S_OK if the call is successful; otherwise, it returns an error code.
[Visual Basic]

The SetPublishing method sets the EnablePublishing and PublishDirectory properties.

Sub SetPublishing( _
  ByVal fEnablePublishing As Boolean, _
  [ ByVal bstrPublishDirectory As String ] _
)

Parameters

fEnablePublishing
[in] Boolean value that specifies whether the report can be published (saved to a directory).
bstrPublishDirectory
[in, optional] String value that specifies the directory to which the report job will be saved. The default is an empty (NULL) string.

Return Values

This method has no return values. If the call is unsuccessful, an error is raised that can be intercepted by using an error handler.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCReportJob


IFPCReportJob | FPCReportJob SetPublishingCredentials method [ISA Server 2004]

IFPCReportJob::SetPublishingCredentials[C++]

FPCReportJob.SetPublishingCredentials [Visual Basic]

[C++]

The SetPublishingCredentials method sets the UsePublishingCredentials property and the credentials for publishing reports generated by the report job.

HRESULT SetPublishingCredentials(
  VARIANT_BOOL fUsePublishingCredentials,
  BSTR UserName,
  BSTR Password
);

Parameters

fUsePublishingCredentials
[in] Boolean value that specifies whether credentials will be used in publishing reports generated by the report job.
UserName
[in, optional] String value that specifies the user name that will be included in the credentials for publishing reports. The default is an empty (NULL) string.
Password
[in, optional] String value that specifies the password that will be included in the credentials for publishing reports. The default is an empty (NULL) string.

Return Values

This method returns S_OK if the call is successful; otherwise, it returns an error code.
[Visual Basic]

The SetPublishingCredentials method sets the UsePublishingCredentials property and the credentials for publishing reports generated by the report job.

Sub SetPublishingCredentials( _
  ByVal fUsePublishingCredentials As Boolean, _
  [ ByVal UserName As String ], _
  [ ByVal Password As String ] _
)

Parameters

fUsePublishingCredentials
[in] Boolean value that specifies whether credentials will be used in publishing reports generated by the report job.
UserName
[in, optional] String value that specifies the user name that will be included in the credentials for publishing reports. The default is an empty (NULL) string.
Password
[in, optional] String value that specifies the password that will be included in the credentials for publishing reports. The default is an empty (NULL) string.

Return Values

This method has no return values. If the call is unsuccessful, an error is raised that can be intercepted by using an error handler.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCReportJob


IFPCReportJob | FPCReportJob SetServer(String) method [ISA Server 2004]

IFPCReportJob::SetServer[C++]

FPCReportJob.SetServer [Visual Basic]

[C++]

The SetServer method sets the name of the server on which the report job will run.

HRESULT SetServer(
  BSTR bstrServerName
);

Parameters

bstrServerName
[in] String value that specifies the name of the server on which the report job will run.

Return Values

This method returns S_OK if the call is successful; otherwise, it returns an error code.
[Visual Basic]

The SetServer method sets the name of the server on which the report job will run.

Sub SetServer( _
  ByVal bstrServerName As String _
)

Parameters

bstrServerName
[in] String value that specifies the name of the server on which the report job will run.

Return Values

This method has no return values. If the call is unsuccessful, an error is raised that can be intercepted by using an error handler.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCReportJob


IFPCReportJob | FPCReportJob SmtpServer(BSTR) property [ISA Server 2004]

SmtpServer Property of IFPCReportJob[C++]

FPCReportJob.SmtpServer [Visual Basic]

[C++]

The SmtpServer property gets the name of the SMTP server that will be used to send an e-mail message when the report job is completed.

HRESULT get_SmtpServer(
  BSTR* pbstrSmtpServer
);

Parameters

pbstrSmtpServer
Pointer to a BSTR that is set on return to a string value specifying the name of the SMTP server that will be used to send an e-mail message when the report job is completed.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only. It can be set using the SetEmailing method.

[Visual Basic]

The SmtpServer property gets the name of the SMTP server that will be used to send an e-mail message when the report job is completed.

Property SmtpServer As String

Property Value

String that specifies the name of the SMTP server that will be used to send an e-mail message when the report job is completed.

Remarks

This property is read-only. It can be set using the SetEmailing method.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCReportJob


IFPCReportJob.UsePublishingCredentials(VARIANT_BOOL) property [ISA Server 2004]

UsePublishingCredentials Property of IFPCReportJob[C++]

FPCReportJob.UsePublishingCredentials [Visual Basic]

[C++]

The UsePublishingCredentials property gets a Boolean value that indicates whether credentials will be used in publishing reports generated by the report job.

HRESULT get_UsePublishingCredentials(
  VARIANT_BOOL* pfUsePublishingCredentials
);

Parameters

pfUsePublishingCredentials
Pointer to a Boolean variable that is set on return to VARIANT_TRUE if credentials will be used in publishing reports generated by the report job, or to VARIANT_FALSE if credentials will not be used in publishing reports generated by the report job.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only. It can be set by calling the SetPublishingCredentials method.

[Visual Basic]

The UsePublishingCredentials property gets a Boolean value that indicates whether credentials will be used in publishing reports generated by the report job.

Property UsePublishingCredentials As Boolean

Property Value

Boolean value that indicates whether credentials will be used in publishing reports generated by the report job.

Remarks

This property is read-only. It can be set by calling the SetPublishingCredentials method.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCReportJob


FPCReportJobs collection [ISA Server 2004]

FPCReportJobs Collection

The FPCReportJobs collection provides access to a group of FPCReportJob objects, which represent individual report jobs. Report jobs specify the items to include in the reports and when to generate them.

This collection is typically accessed through the ReportJobs property of the FPCReports object.

Click here to see the ISA Server object hierarchy.

Inheritance

This collection inherits from the FPCPersist object, which contains methods and properties related to the persistent storage of an object's data. They include methods for exporting an object's data to and importing it from an XML document.

Methods

The FPCReportJobs collection defines the following methods.

Method | Description
Add | Creates a new FPCReportJob object in the collection and returns a reference to it.
Item | Retrieves the requested FPCReportJob object from the collection.
Remove | Removes an FPCReportJob object from the collection.

Properties

The FPCReportJobs collection has the following properties.

Property | Description
_NewEnum | Gets an enumerator object for the collection.
Count | Gets the number of FPCReportJob objects in the collection.
ReportsProperties | Gets an FPCReportsProperties object that contains the properties of the reports in the report jobs.

Methods Inherited from FPCPersist

Name | Description
CancelWaitForChanges | Cancels the registration established by the WaitForChanges method (for use in C and C++ programming only).
CanImport | Returns a Boolean value that indicates whether the properties of the collection, its elements, and their subobjects can be imported from the specified XML document.
Export | Recursively writes the stored values of all the properties of the collection, its elements, and their subobjects to the specified XML document.
ExportToFile | Recursively writes the stored values of all the properties of the collection, its elements, and their subobjects to the specified XML file.
GetServiceRestartMask | Retrieves a 32-bit bitmask of the FpcServices enumerated type that specifies which services need to be restarted for currently unsaved changes to take effect.
Import | Recursively copies the values of all the properties of the collection, its elements, and their subobjects from the specified XML document to persistent storage.
ImportFromFile | Recursively copies the values of all the properties of the collection, its elements, and their subobjects from the specified XML file to persistent storage.
LoadDocProperties | Provides the XML document's properties so that you can know what information can be imported from the document.
Refresh | Recursively reads the values of all the properties of the collection, its elements, and their subobjects from persistent storage, overwriting any changes that have not been saved.
Save | Recursively writes the current values of all the properties of the collection, its elements, and their subobjects to persistent storage.
WaitForChanges | Registers to wait for an event indicating that the contents of the object have changed (for use in C and C++ programming only).

Properties Inherited from FPCPersist

Name | Description
PersistentName | Gets the persistent name of the collection. The persistent name of an object is a name that is unique for the object at the respective level of the COM object hierarchy.
VendorParametersSets | Gets an FPCVendorParametersSets collection that can hold sets of custom data for extending the collection.

Remarks

This collection implements the IFPCReportJobs interface.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

COM Objects


IFPCReportJobs | FPCReportJobs _NewEnum(IUnknown) property [ISA Server 2004]

_NewEnum Property of IFPCReportJobs[C++]

FPCReportJobs._NewEnum [Visual Basic]

[C++]

The _NewEnum property gets an enumerator object for the collection. An enumerator object provides serial access to the elements of the collection.

HRESULT get__NewEnum(
  IUnknown* ppEnum
);

Parameters

ppEnum
Address of an interface pointer that on return points to the IUnknown interface of an enumerator object that implements an IEnumVARIANT interface for the collection. An interface pointer to the IEnumVARIANT interface of the enumerator object can be retrieved by calling QueryInterface on the IUnknown interface returned.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The _NewEnum property gets an enumerator object for the collection. An enumerator object provides serial access to the elements of the collection.

Property _NewEnum As IUnknown

Property Value

Reference to an enumerator object that provides serial access to the elements of the collection.

Remarks

This property is read-only.

In Visual Basic and VBScript, this property is used implicitly in For Each...In...Next constructs.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCReportJobs


IFPCReportJobs | FPCReportJobs Add (3 Parameters) method [ISA Server 2004]

IFPCReportJobs::Add[C++]

FPCReportJobs.Add [Visual Basic]

[C++]

The Add method creates a new FPCReportJob object in the collection and returns a reference to it.

HRESULT Add(
  BSTR Name,
  BSTR ServerName,
  IFPCReportJob** ppNewReportJob
);

Parameters

Name
[in] Required. BSTR that specifies the name of the new report job.
ServerName
[in] Required. BSTR that specifies the name of the server where the report job will run.
ppNewReportJob
[out] Address of an interface pointer that on return points to the new IFPCReportJob interface created.

Return Values

This method can return one of the following:

  • S_OK, indicating that the operation succeeded.
  • An error code, indicating that the operation failed. In this case, the [out] parameter returned is a null object.

[Visual Basic]

The Add method creates a new FPCReportJob object in the collection and returns a reference to it.

Function Add( _
  ByVal Name As String, _
  ByVal ServerName As String _
) As FPCReportJob

Parameters

Name
[in] Required. String that specifies the name of the new report job.
ServerName
[in] Required. String that specifies the name of the server where the report job will run.

Return Values

This method returns a reference to an FPCReportJob object if successful. Otherwise, an error is raised that can be intercepted by using an error handler.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCReportJobs


IFPCReportJobs | FPCReportJobs Count(long) property [ISA Server 2004]

Count Property of IFPCReportJobs[C++]

FPCReportJobs.Count [Visual Basic]

[C++]

The Count property gets the number of FPCReportJob objects in the collection.

HRESULT get_Count(
  long* plCount
);

Parameters

plCount
Pointer to a variable that on return receives a 32-bit integer specifying the number of FPCReportJob objects in the collection.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The Count property gets the number of FPCReportJob objects in the collection.

Property Count As Long

Property Value

A 32-bit integer that specifies the number of FPCReportJob objects in the collection.

Remarks

This property is read-only.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCReportJobs


IFPCReportJobs | FPCReportJobs Item (2 Parameters) method [ISA Server 2004]

IFPCReportJobs::Item[C++]

FPCReportJobs.Item [Visual Basic]

[C++]

The Item method retrieves the requested IFPCReportJob interface from the collection.

HRESULT Item(
  VARIANT Index,
  IFPCReportJob** ppItem
);

Parameters

Index
[in] Required. Name or one-based index of the object to retrieve.
ppItem
[out] Address of an interface pointer that on return points to the IFPCReportJob interface requested.

Return Values

The method can return one of the following:

  • S_OK, indicating that the operation succeeded.
  • An error code, indicating that the operation failed. In this case, the [out] parameter returned is a null object.

[Visual Basic]

The Item method retrieves the requested FPCReportJob object from the collection.

Function Item( _
  ByVal Index As Variant _
) As FPCReportJob

Parameters

Index
[in] Required. Name or one-based index of the object to retrieve.

Return Values

This method returns a reference to the FPCReportJob object requested if successful. Otherwise, an error is raised that can be intercepted by using an error handler.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCReportJobs


IFPCReportJobs | FPCReportJobs Remove(Variant) method [ISA Server 2004]

IFPCReportJobs::Remove[C++]

FPCReportJobs.Remove [Visual Basic]

[C++]

The Remove method removes the specified FPCReportJob object from the collection.

HRESULT Remove(
  VARIANT Index
);

Parameters

Index
[in] Required. Name or one-based index of the FPCReportJob object to remove.

Return Values

This method returns S_OK if the call is successful; otherwise, it returns an error code.

[Visual Basic]

The Remove method removes the specified FPCReportJob object from the collection.

Sub Remove( _
  ByVal Index As Variant _
)

Parameters

Index
[in] Required. Name or one-based index of the FPCReportJob object to remove.

Return Values

This method has no return values. If the call is unsuccessful, an error is raised that can be intercepted by using an error handler.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCReportJobs


IFPCReportJobs | FPCReportJobs ReportsProperties property [ISA Server 2004]

ReportsProperties Property of IFPCReportJobs[C++]

FPCReportJobs.ReportsProperties [Visual Basic]

[C++]

The ReportsProperties property gets an FPCReportsProperties object that contains the properties of the reports in the report jobs.

HRESULT get_ReportsProperties(
  IFPCReportsProperties** ppReportsProperties
);

Parameters

ppReportsProperties
Address of an interface pointer that on return points to an IFPCReportsProperties interface that represents the properties of the reports in the report jobs.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only. The properties of the reports in the report jobs can be accessed through the properties of the IFPCReportsProperties interface retrieved.

[Visual Basic]

The ReportsProperties property gets an FPCReportsProperties object that contains the properties of the reports in the report jobs.

Property ReportsProperties As FPCReportsProperties

Property Value

Reference to an FPCReportsProperties object that contains the properties of the reports in the report jobs.

Remarks

This property is read-only. The properties of the reports in the report jobs can be accessed through the properties of the FPCReportsProperties object retrieved.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCReportJobs


FPCReports object [ISA Server 2004]

FPCReports

The FPCReports object defines the configuration for generating daily and monthly log summaries and provides access to reports.

The FPCReports object is typically accessed through the Reports property of the FPCArray object.

Click here to see the ISA Server object hierarchy.

Inheritance

This object inherits from the FPCPersist object, which contains methods and properties related to the persistent storage of an object's data. They include methods for exporting an object's data to and importing it from an XML document.

Methods

This object has no methods.

Properties

The FPCReports object has the following properties.

Property | Description
LogSummaryConfiguration | Gets an FPCLogSummaryConfigration object that contains the settings for generating daily and monthly log summaries.
ReadyReports | Gets an FPCReadyReports collection that contains all reports that are ready.
ReportJobs | Gets an FPCReportJobs collection that contains all the report jobs. Report jobs specify the items to include in the reports, when to generate them, and the period of time that the reports will cover.

Methods Inherited from FPCPersist

Name | Description
CancelWaitForChanges | Cancels the registration established by the WaitForChanges method (for use in C and C++ programming only).
CanImport | Returns a Boolean value that indicates whether the object's properties can be imported from the specified XML document.
Export | Recursively writes the stored values of all the properties of the object and its subobjects to the specified XML document.
ExportToFile | Recursively writes the stored values of all the properties of the object and its subobjects to the specified XML file.
GetServiceRestartMask | Retrieves a 32-bit bitmask of the FpcServices enumerated type that specifies which services need to be restarted for currently unsaved changes to take effect.
Import | Recursively copies the values of all the properties of the object and of its subobjects from the specified XML document to persistent storage.
ImportFromFile | Recursively copies the values of all the properties of the object and of its subobjects from the specified XML file to persistent storage.
LoadDocProperties | Provides the XML document's properties so that you can know what information can be imported from the document.
Refresh | Recursively reads the values of all the properties of the object and of its subobjects from persistent storage, overwriting any changes that have not been saved.
Save | Recursively writes the current values of all the properties of the object and its subobjects to persistent storage.
WaitForChanges | Registers to wait for an event indicating that the contents of the object have changed (for use in C and C++ programming only).

Properties Inherited from FPCPersist

Name | Description
PersistentName | Gets the persistent name of the object. The persistent name of an object is a name that is unique for the object at the respective level of the COM object hierarchy.
VendorParametersSets | Gets an FPCVendorParametersSets collection that can hold sets of custom data for extending the object.

Remarks

This object implements the IFPCReports interface.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

COM Objects


IFPCReports | FPCReports LogSummaryConfiguration property [ISA Server 2004]

LogSummaryConfiguration Property of IFPCReports[C++]

FPCReports.LogSummaryConfiguration [Visual Basic]

[C++]

The LogSummaryConfiguration property gets an FPCLogSummaryConfigration object that contains the settings for generating daily and monthly log summaries.

HRESULT get_LogSummaryConfiguration(
  IFPCLogSummaryConfiguration** ppLogSummaryConfiguration
);

Parameters

ppLogSummaryConfiguration
Address of an interface pointer that on return points to an IFPCLogSummaryConfigration interface that provides access to the settings for generating daily and monthly log summaries.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only. It can be modified by using the properties and methods of the IFPCLogSummaryConfigration interface.

[Visual Basic]

The LogSummaryConfiguration property gets an FPCLogSummaryConfigration object that contains the settings for generating daily and monthly log summaries.

Property LogSummaryConfiguration As FPCLogSummaryConfiguration

Property Value

Reference to an FPCLogSummaryConfigration object that contains the settings for generating daily and monthly log summaries.

Remarks

This property is read-only. It can be modified by using the properties and methods of the FPCLogSummaryConfigration object.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCReports


IFPCReports | FPCReports ReadyReports (1 Parameter) property [ISA Server 2004]

ReadyReports Property of IFPCReports[C++]

FPCReports.ReadyReports [Visual Basic]

[C++]

The ReadyReports property gets an FPCReadyReports collection that contains all reports that are ready.

HRESULT get_ReadyReports(
  IFPCReadyReports** ppReadyReports
);

Parameters

ppReadyReports
Address of an interface pointer that on return points to an IFPCReadyReports interface that represents the collection of all reports that are ready.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The ReadyReports property gets an FPCReadyReports collection that contains all reports that are ready.

Property ReadyReports As FPCReadyReports

Property Value

Reference to an FPCReadyReports collection.

Remarks

This property is read-only.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCReports


IFPCReports | FPCReports ReportJobs(IFPCReportJobs) property [ISA Server 2004]

ReportJobs Property of IFPCReports[C++]

FPCReports.ReportJobs [Visual Basic]

[C++]

The ReportJobs property gets an FPCReportJobs collection that contains all the report jobs. Report jobs specify the items to include in the reports, when to generate them, and the period of time that the reports will cover.

HRESULT get_ReportJobs(
  IFPCReportJobs** ppReportJobs
);

Parameters

ppReportJobs
Address of an interface pointer that on return points to an IFPCReportJobs interface that represents the collection of all the report jobs.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The ReportJobs property gets an FPCReportJobs collection that contains all the report jobs. Report jobs specify the items to include in the reports, when to generate them, and the period of time that the reports will cover.

Property ReportJobs As FPCReportJobs

Property Value

Reference to an FPCReportJobs collection that contains all the report jobs.

Remarks

This property is read-only.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCReports


FPCReportsProperties object [ISA Server 2004]

FPCReportsProperties

The FPCReportsProperties object provides access to objects representing the properties of the different kinds of reports:

  • Application usage reports
  • Security reports
  • Summary reports
  • Traffic reports
  • Web usage reports

The FPCReportsProperties object can be accessed through the ReportsProperties property of an FPCReportJobs collection.

Click here to see the ISA Server object hierarchy.

Inheritance

This object inherits from the FPCPersist object, which contains methods and properties related to the persistent storage of an object's data. They include methods for exporting the object's data to and importing it from an XML document.

Methods

This object has no methods.

Properties

The FPCReportsProperties object has the following properties.

Property | Description
ApplicationUsageReports | Gets an FPCApplicationUsageReports object that represents the properties of application usage reports.
SecurityReports | Gets an FPCSecurityReports object that represents the properties of security reports.
SummaryReports | Gets an FPCSummaryReports object that represents the properties of summary reports.
TrafficReports | Gets an FPCTrafficReports object that represents the properties of traffic reports.
WebUsageReports | Gets an FPCWebUsageReports object that represents the properties of Web usage reports.

Methods Inherited from FPCPersist

Name | Description
CancelWaitForChanges | Cancels the registration established by the WaitForChanges method (for use in C and C++ programming only).
CanImport | Returns a Boolean value that indicates whether the object's properties can be imported from the specified XML document.
Export | Recursively writes the stored values of all the properties of the object and its subobjects to the specified XML document.
ExportToFile | Recursively writes the stored values of all the properties of the object and its subobjects to the specified XML file.
GetServiceRestartMask | Retrieves a 32-bit bitmask of the FpcServices enumerated type that specifies which services need to be restarted for currently unsaved changes to take effect.
Import | Recursively copies the values of all the properties of the object and of its subobjects from the specified XML document to persistent storage.
ImportFromFile | Recursively copies the values of all the properties of the object and of its subobjects from the specified XML file to persistent storage.
LoadDocProperties | Provides the XML document's properties so that you can know what information can be imported from the document.
Refresh | Recursively reads the values of all the properties of the object and of its subobjects from persistent storage, overwriting any changes that have not been saved.
Save | Recursively writes the current values of all the properties of the object and its subobjects to persistent storage.
WaitForChanges | Registers to wait for an event indicating that the contents of the object have changed (for use in C and C++ programming only).

Properties Inherited from FPCPersist

Name | Description
PersistentName | Gets the persistent name of the object. The persistent name of an object is a name that is unique for the object at the respective level of the COM object hierarchy.
VendorParametersSets | Gets an FPCVendorParametersSets collection that can hold sets of custom data for extending the object.

Remarks

This object implements the IFPCReportsProperties interface.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

COM Objects


IFPCReportsProperties.ApplicationUsageReports property [ISA Server 2004]

ApplicationUsageReports Property of IFPCReportsProperties[C++]

FPCReportsProperties.ApplicationUsageReports [Visual Basic]

[C++]

The ApplicationUsageReports property gets an FPCApplicationUsageReports object that represents the properties of the application usage reports.

HRESULT get_ApplicationUsageReports(
  IFPCApplicationUsageReports** ppApplicationUsageReports
);

Parameters

ppApplicationUsageReports
Address of an interface pointer that on return points to an IFPCApplicationUsageReports interface that represents the properties of the application usage reports.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The ApplicationUsageReports property gets an FPCApplicationUsageReports object that represents the properties of the application usage reports.

Property ApplicationUsageReports As FPCApplicationUsageReports

Property Value

Reference to an FPCApplicationUsageReports object that represents the properties of the application usage reports.

Remarks

This property is read-only.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCReportsProperties


IFPCReportsProperties.SecurityReports (1 Parameter) property [ISA Server 2004]

SecurityReports Property of IFPCReportsProperties[C++]

FPCReportsProperties.SecurityReports [Visual Basic]

[C++]

The SecurityReports property gets an FPCSecurityReports object that represents the properties of the security reports.

HRESULT get_SecurityReports(
  IFPCSecurityReports** ppSecurityReports
);

Parameters

ppSecurityReports
Address of an interface pointer that on return points to an IFPCSecurityReports interface that represents the properties of the security reports.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The SecurityReports property gets an FPCSecurityReports object that represents the properties of the security reports.

Property SecurityReports As FPCSecurityReports

Property Value

Reference to an FPCSecurityReports object that represents the properties of the security reports.

Remarks

This property is read-only.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCReportsProperties


IFPCReportsProperties.SummaryReports (1 Parameter) property [ISA Server 2004]

SummaryReports Property of IFPCReportsProperties[C++]

FPCReportsProperties.SummaryReports [Visual Basic]

[C++]

The SummaryReports property gets an FPCSummaryReports object that represents the properties of the summary reports.

HRESULT get_SummaryReports(
  IFPCSummaryReports** ppSummaryReports
);

Parameters

ppSummaryReports
Address of an interface pointer that on return points to an IFPCSummaryReports interface that represents the properties of the summary reports.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The SummaryReports property gets an FPCSummaryReports object that represents the properties of the summary reports.

Property SummaryReports As FPCSummaryReports

Property Value

Reference to an FPCSummaryReports object that represents the properties of the summary reports.

Remarks

This property is read-only.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCReportsProperties


IFPCReportsProperties.TrafficReports (1 Parameter) property [ISA Server 2004]

TrafficReports Property of IFPCReportsProperties[C++]

FPCReportsProperties.TrafficReports [Visual Basic]

[C++]

The TrafficReports property gets an FPCTrafficReports object that represents the properties of the traffic reports.

HRESULT get_TrafficReports(
  IFPCTrafficReports** ppTrafficReports
);

Parameters

ppTrafficReports
Address of an interface pointer that on return points to an IFPCTrafficReports interface that represents the properties of the traffic reports.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The TrafficReports property gets an FPCTrafficReports object that represents the properties of the traffic reports.

Property TrafficReports As FPCTrafficReports

Property Value

Reference to an FPCTrafficReports object that represents the properties of the traffic reports.

Remarks

This property is read-only.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCReportsProperties


IFPCReportsProperties.WebUsageReports (1 Parameter) property [ISA Server 2004]

WebUsageReports Property of IFPCReportsProperties[C++]

FPCReportsProperties.WebUsageReports [Visual Basic]

[C++]

The WebUsageReports property gets an FPCWebUsageReports object that represents the properties of the Web usage reports.

HRESULT get_WebUsageReports(
  IFPCWebUsageReports** ppWebUsageReports
);

Parameters

ppWebUsageReports
Address of an interface pointer that on return points to an IFPCWebUsageReports interface that represents the properties of the Web usage reports.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The WebUsageReports property gets an FPCWebUsageReports object that represents the properties of the Web usage reports.

Property WebUsageReports As FPCWebUsageReports

Property Value

Reference to an FPCWebUsageReports object that represents the properties of the Web usage reports.

Remarks

This property is read-only.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCReportsProperties


FPCRoutingRule object [ISA Server 2004]

FPCRoutingRule

The FPCRoutingRule object represents a single routing rule that has been defined in an ISA Server array. Routing rules determine whether a Web proxy client request is sent directly to the Internet, to another upstream proxy server, or to an alternate destination. You can use this object to access all attributes of each routing rule defined in an array.

This object is typically an element of an FPCRoutingRules collection.

Click here to see the ISA Server object hierarchy.

Inheritance

This object inherits from the FPCPersist object, which contains methods and properties related to the persistent storage of an object's data. They include methods for exporting an object's data to and importing it from an XML document.

Methods

This object has no methods.

Properties

The FPCRoutingRule object has the following properties.

Property | Description
DelegateBasicCredentials | Gets or sets a Boolean value that indicates whether basic credentials are delegated.
Description | Gets or sets the description of the rule.
DestinationDomainNameSets | Gets an FPCRefs collection that contains references to the FPCDomainNameSet collections defining the domain name sets to which the rule applies as destinations.
DestinationSelectionIPs | Gets an FPCSelectionIPs object that specifies the complete set of destination IP addresses to which the rule applies.
Enabled | Gets or sets a Boolean value that indicates whether this rule is enabled.
IsDefault | Gets a Boolean value that indicates whether the rule is preinstalled and cannot be deleted.
Name | Gets or sets the name of the rule.
NonSecureProtocolRedirection | Gets or sets the protocol used when delegating a request that came on a nonsecure channel.
Order | Gets the ordinal position of the rule in the list of routing rules, which corresponds to their order of application.
PrimaryRoute | Gets an FPCPrimaryRoute object that represents the primary route used to route requests from Web proxy clients.
SecureProtocolRedirection | Gets or sets the protocol used when delegating a request that came on a secure channel.
SSLClientCertificate | Gets or sets an FPCCertificate object that represents the SSL client certificate to use when the ISA Server Web proxy authenticates to the published server.
SSLRequireSecureChannel | Gets or sets a value from the FpcSSLRequireSecureChannelMode enumerated type that indicates whether a secure channel is required and whether 128-bit encryption is required.
URLSets | Gets an FPCRefs collection that contains references to the FPCURLSet collections defining the URL sets to which the rule applies.

Methods Inherited from FPCPersist

Name | Description
CancelWaitForChanges | Cancels the registration established by the WaitForChanges method (for use in C and C++ programming only).
CanImport | Returns a Boolean value that indicates whether the object's properties can be imported from the specified XML document.
Export | Recursively writes the stored values of all the properties of the object and its subobjects to the specified XML document.
ExportToFile | Recursively writes the stored values of all the properties of the object and its subobjects to the specified XML file.
GetServiceRestartMask | Retrieves a 32-bit bitmask of the FpcServices enumerated type that specifies which services need to be restarted for currently unsaved changes to take effect.
Import | Recursively copies the values of all the properties of the object and of its subobjects from the specified XML document to persistent storage.
ImportFromFile | Recursively copies the values of all the properties of the object and of its subobjects from the specified XML file to persistent storage.
LoadDocProperties | Provides the XML document's properties so that you can know what information can be imported from the document.
Refresh | Recursively reads the values of all the properties of the object and of its subobjects from persistent storage, overwriting any changes that have not been saved.
Save | Recursively writes the current values of all the properties of the object and its subobjects to persistent storage.
WaitForChanges | Registers to wait for an event indicating that the contents of the object have changed (for use in C and C++ programming only).

Properties Inherited from FPCPersist

Name | Description
PersistentName | Gets the persistent name of the object. The persistent name of an object is a name that is unique for the object at the respective level of the COM object hierarchy.
VendorParametersSets | Gets an FPCVendorParametersSets collection that can hold sets of custom data for extending the object.

Remarks

This object implements the IFPCRoutingRule interface.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

COM Objects


IFPCRoutingRule.DelegateBasicCredentials property [ISA Server 2004]

DelegateBasicCredentials Property of IFPCRoutingRule[C++]

FPCRoutingRule.DelegateBasicCredentials [Visual Basic]

[C++]

The DelegateBasicCredentials property gets or sets a Boolean value that indicates whether basic credentials are delegated.

HRESULT get_DelegateBasicCredentials(
  VARIANT_BOOL* pfDelegated
);

HRESULT put_DelegateBasicCredentials(
  VARIANT_BOOL fDelegated
);

Parameters

pfDelegated
Pointer to a Boolean variable that is set on return to VARIANT_TRUE if basic credentials are delegated, or to VARIANT_FALSE if basic credentials are not delegated.
fDelegated
Boolean value that indicates whether basic credentials are delegated.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write.

[Visual Basic]

The DelegateBasicCredentials property gets or sets a Boolean value that indicates whether basic credentials are delegated.

Property DelegateBasicCredentials As Boolean

Property Value

Boolean value that indicates whether basic credentials are delegated.

Remarks

This property is read/write.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCRoutingRule


IFPCRoutingRule | FPCRoutingRule Description property [ISA Server 2004]

Description Property of IFPCRoutingRule[C++]

FPCRoutingRule.Description [Visual Basic]

[C++]

The Description property gets or sets the description of the rule.

HRESULT get_Description(
  BSTR* pbstrDescription
);

HRESULT put_Description(
  BSTR bstrDescription
);

Parameters

pbstrDescription
Pointer to a BSTR that is set on return to a string value specifying the description of the rule.
bstrDescription
BSTR that specifies the description of the rule.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write.

[Visual Basic]

The Description property gets or sets the description of the rule.

Property Description As String

Property Value

String that specifies the description of the rule.

Remarks

This property is read/write.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCRoutingRule


IFPCRoutingRule.DestinationDomainNameSets(IFPCRefs) property [ISA Server 2004]

DestinationDomainNameSets Property of IFPCRoutingRule[C++]

FPCRoutingRule.DestinationDomainNameSets [Visual Basic]

[C++]

The DestinationDomainNameSets property gets an FPCRefs collection that contains references to the FPCDomainNameSet collections defining the domain name sets to which the rule applies as destinations.

HRESULT get_DestinationDomainNameSets(
  IFPCRefs** ppRefs
);

Parameters

ppRefs
Address of an interface pointer that on return points to an IFPCRefs interface that represents the collection of references to the domain name sets to which the rule applies as destinations.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only. It can be modified by calling the methods of the IFPCRefs interface retrieved.

The IncludeStatus property of each reference specifies whether the domain name set referenced is included in or excluded from the rule.

[Visual Basic]

The DestinationDomainNameSets property gets an FPCRefs collection that contains references to the FPCDomainNameSet collections defining the domain name sets to which the rule applies as destinations.

Property DestinationDomainNameSets As FPCRefs

Property Value

Reference to an FPCRefs collection that contains references to the domain name sets to which the rule applies as destinations.

Remarks

This property is read-only. It can be modified by calling the methods of the FPCRefs collection retrieved.

The IncludeStatus property of each reference specifies whether the domain name set referenced is included in or excluded from the rule.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCRoutingRule


IFPCRoutingRule.DestinationSelectionIPs (1 Parameter) property [ISA Server 2004]

DestinationSelectionIPs Property of IFPCRoutingRule[C++]

FPCRoutingRule.DestinationSelectionIPs [Visual Basic]

[C++]

The DestinationSelectionIPs property gets an FPCSelectionIPs object that specifies the complete set of destination IP addresses to which the rule applies. This set may include computers, networks, network sets, subnets, or IP address ranges.

HRESULT get_DestinationSelectionIPs(
  IFPCSelectionIPs** ppSelectionIPs
);

Parameters

ppSelectionIPs
Address of an interface pointer that on return points to an IFPCSelectionIPs interface that represents the complete set of destination IP addresses to which the rule applies.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only. It can be modified through the properties of the IFPCSelectionIPs interface retrieved.

[Visual Basic]

The DestinationSelectionIPs property gets an FPCSelectionIPs object that specifies the complete set of destination IP addresses to which the rule applies. This set may include computers, networks, network sets, subnets, or IP address ranges.

Property DestinationSelectionIPs

Property Value

Reference to an FPCSelectionIPs object that specifies the complete set of destination IP addresses to which the rule applies.

Remarks

This property is read-only. It can be modified through the properties of the FPCSelectionIPs object retrieved.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCRoutingRule


IFPCRoutingRule | FPCRoutingRule Enabled property [ISA Server 2004]

Enabled Property of IFPCRoutingRule[C++]

FPCRoutingRule.Enabled [Visual Basic]

[C++]

The Enabled property gets or sets a Boolean value that indicates whether the rule is enabled.

Note The default routing rule cannot be disabled.

HRESULT get_Enabled(
  VARIANT_BOOL* pfEnabled
);

HRESULT put_Enabled(
  VARIANT_BOOL fEnabled
);

Parameters

pfEnabled
Pointer to a Boolean variable that is set on return to VARIANT_TRUE if the rule is enabled, or to VARIANT_FALSE if the rule is disabled.
fEnabled
Boolean value that indicates whether the rule is enabled.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write.

[Visual Basic]

The Enabled property gets or sets a Boolean value that indicates whether the rule is enabled.

Note The default routing rule cannot be disabled.

Property Enabled As Boolean

Property Value

Boolean value that indicates whether the rule is enabled.

Remarks

This property is read/write.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCRoutingRule


IFPCRoutingRule | FPCRoutingRule IsDefault property [ISA Server 2004]

IsDefault Property of IFPCRoutingRule[C++]

FPCRoutingRule.IsDefault [Visual Basic]

[C++]

The IsDefault property gets a Boolean value that indicates whether the rule is preinstalled, and cannot be deleted or have its position changed in the rule order.

HRESULT get_IsDefault(
  VARIANT_BOOL* pfDefault
);

Parameters

pfDefault
Pointer to a Boolean variable that is set on return to VARIANT_TRUE if the rule is preinstalled, or to VARIANT_FALSE if the rule is not preinstalled.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The IsDefault property gets a Boolean value that indicates whether the rule is preinstalled, and cannot be deleted or have its position changed in the rule order.

Property IsDefault As Boolean

Property Value

Boolean value that specifies whether the rule is preinstalled.

Remarks

This property is read-only.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCRoutingRule


IFPCRoutingRule | FPCRoutingRule Name(BSTR,BSTR) property [ISA Server 2004]

Name Property of IFPCRoutingRule[C++]

FPCRoutingRule.Name [Visual Basic]

[C++]

The Name property gets or sets the name of the rule.

HRESULT get_Name(
  BSTR* pbstrName
);

HRESULT put_Name(
  BSTR bstrName
);

Parameters

pbstrName
Pointer to a BSTR that is set on return to a string value specifying the name of the rule.
bstrName
BSTR that specifies the name of the rule.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write.

[Visual Basic]

The Name property gets or sets the name of the rule.

Property Name As String

Property Value

String that specifies the name of the rule.

Remarks

This property is read/write.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCRoutingRule


IFPCRoutingRule.NonSecureProtocolRedirection property [ISA Server 2004]

NonSecureProtocolRedirection Property of IFPCRoutingRule[C++]

FPCRoutingRule.NonSecureProtocolRedirection [Visual Basic]

[C++]

The NonSecureProtocolRedirection property gets or sets a value from the FpcPublishProtocolRedirectionType enumerated type that specifies the protocol to use when redirecting (bridging) HTTP requests arriving on a nonsecure channel. The possible protocols are the Hypertext Transfer Protocol (HTTP) and Secure Sockets Layer (SSL) protocols.

HRESULT get_NonSecureProtocolRedirection(
  FpcPublishProtocolRedirectionType* pPublishProtocolRedirectionType
);

HRESULT put_NonSecureProtocolRedirection(
  FpcPublishProtocolRedirectionType FpcPublishProtocolRedirectionType
);

Parameters

pPublishProtocolRedirectionType
Pointer to a variable that on return receives a value from the FpcPublishProtocolRedirectionType enumerated type specifying the protocol to use when redirecting (bridging) HTTP requests arriving on a nonsecure channel.
FpcPublishProtocolRedirectionType
Value from the FpcPublishProtocolRedirectionType enumerated type that specifies the protocol to use when redirecting (bridging) HTTP requests arriving on a nonsecure channel.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write.

[Visual Basic]

The NonSecureProtocolRedirection property gets or sets a value from the FpcPublishProtocolRedirectionType enumerated type that specifies the protocol to use when redirecting (bridging) HTTP requests arriving on a nonsecure channel. The possible protocols are the Hypertext Transfer Protocol (HTTP) and Secure Sockets Layer (SSL) protocols.

Property NonSecureProtocolRedirection As FpcPublishProtocolRedirectionType

Property Value

Value from the FpcPublishProtocolRedirectionType enumerated type that specifies the protocol to use when redirecting (bridging) HTTP requests arriving on a nonsecure channel.

Remarks

This property is read/write.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCRoutingRule


IFPCRoutingRule | FPCRoutingRule Order(long) property [ISA Server 2004]

Order Property of IFPCRoutingRule[C++]

FPCRoutingRule.Order [Visual Basic]

[C++]

The Order property gets the ordinal position of the rule in the list of routing rules, which corresponds to their order of application.

HRESULT get_Order(
  long* plOrder
);

Parameters

plOrder
Pointer to a variable that on return receives a 32-bit integer specifying the ordinal position of the rule in the list of routing rules.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only. It can be modified by calling the MoveDown and MoveUp methods of the FPCRoutingRules collection. Because these methods change the ordinal positions of more than one rule in the collection, the Save method must be called on the collection to write the changes to persistent storage.

[Visual Basic]

The Order property gets the ordinal position of the rule in the list of routing rules, which corresponds to their order of application.

Property Order As Long

Property Value

A 32-bit integer that specifies the ordinal position of the rule in the list of routing rules.

Remarks

This property is read-only. It can be modified by calling the MoveDown and MoveUp methods of the FPCRoutingRules collection. Because these methods change the ordinal positions of more than one rule in the collection, the Save method must be called on the collection to write the changes to persistent storage.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCRoutingRule


IFPCRoutingRule | FPCRoutingRule PrimaryRoute property [ISA Server 2004]

PrimaryRoute Property of IFPCRoutingRule[C++]

FPCRoutingRule.PrimaryRoute [Visual Basic]

[C++]

The PrimaryRoute property gets an FPCPrimaryRoute object that represents the primary route used to route requests from Web proxy clients. The primary route can be direct to the Internet, it can include an upstream proxy server, or it can redirect Web proxy client requests to a specified host.

HRESULT get_PrimaryRoute(
  IFPCPrimaryRoute** ppPrimaryRoute
);

Parameters

ppPrimaryRoute
Address of an interface pointer that on return points to an IFPCPrimaryRoute interface specifying the primary route used to route requests from Web proxy clients.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The PrimaryRoute property gets an FPCPrimaryRoute object that represents the primary route used to route requests from Web proxy clients. The primary route can be direct to the Internet, it can include an upstream proxy server, or it can redirect Web proxy client requests to a specified host.

Property PrimaryRoute As FPCPrimaryRoute

Property Value

Reference to an FPCPrimaryRoute object that represents the primary route used to route requests from Web proxy clients.

Remarks

This property is read-only.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCRoutingRule


IFPCRoutingRule.SecureProtocolRedirection property [ISA Server 2004]

SecureProtocolRedirection Property of IFPCRoutingRule[C++]

FPCRoutingRule.SecureProtocolRedirection [Visual Basic]

[C++]

The SecureProtocolRedirection property gets or sets a value from the FpcPublishProtocolRedirectionType enumerated type that specifies the protocol to use when redirecting (bridging) SSL requests that came on a secure channel. The possible protocols are the Hypertext Transfer Protocol (HTTP) and Secure Sockets Layer (SSL) protocols.

HRESULT get_SecureProtocolRedirection(
  FpcPublishProtocolRedirectionType* pPublishProtocolRedirectionType
);

HRESULT put_SecureProtocolRedirection(
  FpcPublishProtocolRedirectionType PublishProtocolRedirectionType
);

Parameters

pPublishProtocolRedirectionType
Pointer to a variable that on return receives a value from the FpcPublishProtocolRedirectionType enumerated type specifying the protocol to use when redirecting (bridging) SSL requests arriving on a secure channel.
PublishProtocolRedirectionType
Value from the FpcPublishProtocolRedirectionType enumerated type that specifies the protocol to use when redirecting (bridging) SSL requests arriving on a secure channel.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write.

[Visual Basic]

The SecureProtocolRedirection property gets or sets a value from the FpcPublishProtocolRedirectionType enumerated type that specifies the protocol to use when redirecting (bridging) SSL requests that came on a secure channel. The possible protocols are the Hypertext Transfer Protocol (HTTP) and Secure Sockets Layer (SSL) protocols.

Property SecureProtocolRedirection As FpcPublishProtocolRedirectionType

Property Value

Value from the FpcPublishProtocolRedirectionType enumerated type that specifies the protocol to use when redirecting (bridging) SSL requests arriving on a secure channel.

Remarks

This property is read/write.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCRoutingRule


IFPCRoutingRule.SSLClientCertificate (2 Parameters) property [ISA Server 2004]

SSLClientCertificate Property of IFPCRoutingRule[C++]

FPCRoutingRule.SSLClientCertificate [Visual Basic]

[C++]

The SSLClientCertificate property gets or sets an FPCCertificate object that represents the SSL client certificate to use when the ISA Server Web proxy authenticates to a Web server.

HRESULT get_SSLClientCertificate(
  IFPCCertificate** ppCertificate
);

HRESULT put_SSLClientCertificate(
  IFPCCertificate* pCertificate
);

Parameters

ppCertificate
Address of an interface pointer that on return points to an IFPCCertificate interface representing the SSL client certificate to use when the Web proxy authenticates to a Web server.
pCertificate
Pointer to the IFPCCertificate interface that represents the SSL client certificate to use when the Web proxy authenticates to a Web server.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write.

[Visual Basic]

The SSLClientCertificate property gets or sets an FPCCertificate object that represents the SSL client certificate to use when the ISA Server Web proxy authenticates to a Web server.

Property SSLClientCertificate As FPCCertificate

Property Value

Reference to an FPCCertificate object that represents the SSL client certificate to use when the Web proxy authenticates to a Web server.

Remarks

This property is read/write.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCRoutingRule


IFPCRoutingRule.SSLRequireSecureChannel property [ISA Server 2004]

SSLRequireSecureChannel Property of IFPCRoutingRule[C++]

FPCRoutingRule.SSLRequireSecureChannel [Visual Basic]

[C++]

The SSLRequireSecureChannel property gets or sets a value from the FpcSSLRequireSecureChannelMode enumerated type that indicates whether a secure channel is required and whether 128-bit encryption is required.

HRESULT get_SSLRequireSecureChannel(
  FpcSSLRequireSecureChannelMode* pSSLRequireSecureChannelMode
);

HRESULT put_SSLRequireSecureChannel(
  FpcSSLRequireSecureChannelMode SSLRequireSecureChannelMode
);

Parameters

pSSLRequireSecureChannelMode
Pointer to a variable that on return receives a value from the from the FpcSSLRequireSecureChannelMode enumerated type specifying whether a secure channel is required and whether 128-bit encryption is required.
SSLRequireSecureChannelMode
Value from the FpcSSLRequireSecureChannelMode enumerated type that indicates whether a secure channel is required and whether 128-bit encryption is required.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write.

[Visual Basic]

The SSLRequireSecureChannel property gets or sets a value from the FpcSSLRequireSecureChannelMode enumerated type that indicates whether a secure channel is required and whether 128-bit encryption is required.

Property SSLRequireSecureChannel As FpcSSLRequireSecureChannelMode

Property Value

Value from the FpcSSLRequireSecureChannelMode enumerated type that indicates whether a secure channel is required and whether 128-bit encryption is required.

Remarks

This property is read/write.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCRoutingRule


IFPCRoutingRule | FPCRoutingRule URLSets(IFPCRefs) property [ISA Server 2004]

URLSets Property of IFPCRoutingRule[C++]

FPCRoutingRule.URLSets [Visual Basic]

[C++]

The URLSets property gets an FPCRefs collection that contains references to the FPCURLSet collections defining the URL sets to which the rule applies.

HRESULT get_URLSets(
  IFPCRefs** ppRefs
);

Parameters

ppRefs
Address of an interface pointer that on return points to an IFPCRefs interface that represents the collection of references to the URL sets to which the rule applies.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only. It can be modified by calling the methods of the IFPCRefs interface retrieved.

The IncludeStatus property of each URL set referenced specifies whether the URL set is included in or excluded from the rule.

[Visual Basic]

The URLSets property gets an FPCRefs collection that contains references to the FPCURLSet collections defining the URL sets to which the rule applies.

Property URLSets As FPCRefs

Property Value

Reference to an FPCRefs collection that contains references to the URL sets to which the rule applies.

Remarks

This property is read-only. It can be modified by calling the methods of the FPCRefs collection retrieved.

The IncludeStatus property of each URL set referenced specifies whether the URL set is included in or excluded from the rule.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCRoutingRule


FPCRoutingRules collection [ISA Server 2004]

FPCRoutingRules Collection

The FPCRoutingRules collection provides access to the set of FPCRoutingRule objects that represent the routing rules defined in an ISA Server array. Routing rules determine whether a Web proxy client request is sent directly to the Internet, to another upstream proxy server, or to an alternate destination.

By using the MoveUp and MoveDown methods, you can adjust the order in which the routing rules in the collection are applied.

When you install ISA Server, it configures a default routing rule. The default rule is initially configured so that all requested objects will be retrieved from the ISA Server cache. If the object is not in the cache, it will be retrieved directly from the Internet. The default routing rule is applied last, and its position in the list of rules cannot be changed. You can modify the default routing rule's action and how it redirects outgoing Web requests, but you cannot delete it.

The FPCRoutingRules collection is typically accessed through the RoutingRules property of an FPCNetworkConfiguration object.

Click here to see the ISA Server object hierarchy.

Inheritance

This collection inherits from the FPCPersist object, which contains methods and properties related to the persistent storage of an object's data. They include methods for exporting the object's data to and importing it from an XML document.

Methods

The FPCRoutingRules collection defines the following methods.

Method | Description
Add | Creates a new FPCRoutingRule object, adds it to the collection, and returns a reference to it.
Item | Retrieves the requested FPCRoutingRule object from the collection.
MoveDown | Moves the specified routing rule one step down the list of rules, which corresponds to their order of application.
MoveUp | Moves the specified routing rule one step up the list of rules, which corresponds to their order of application.
Remove | Removes the specified FPCRoutingRule object from the collection.

Properties

The FPCRoutingRules collection has the following properties.

Property | Description
_NewEnum | Gets an enumerator object for the collection.
Count | Gets the number of FPCRoutingRule objects in the collection.

Methods Inherited from FPCPersist

Name | Description
CancelWaitForChanges | Cancels the registration established by the WaitForChanges method (for use in C and C++ programming only).
CanImport | Returns a Boolean value that indicates whether the properties of the collection, its elements, and their subobjects can be imported from the specified XML document.
Export | Recursively writes the stored values of all the properties of the collection, its elements, and their subobjects to the specified XML document.
ExportToFile | Recursively writes the stored values of all the properties of the collection, its elements, and their subobjects to the specified XML file.
GetServiceRestartMask | Retrieves a 32-bit bitmask of the FpcServices enumerated type that specifies which services need to be restarted for currently unsaved changes to take effect.
Import | Recursively copies the values of all the properties of the collection, its elements, and their subobjects from the specified XML document to persistent storage.
ImportFromFile | Recursively copies the values of all the properties of the collection, its elements, and their subobjects from the specified XML file to persistent storage.
LoadDocProperties | Provides the XML document's properties so that you can know what information can be imported from the document.
Refresh | Recursively reads the values of all the properties of the collection, its elements, and their subobjects from persistent storage, overwriting any changes that have not been saved.
Save | Recursively writes the current values of all the properties of the collection, its elements, and their subobjects to persistent storage.
WaitForChanges | Registers to wait for an event indicating that the contents of the object have changed (for use in C and C++ programming only).

Properties Inherited from FPCPersist

Name | Description
PersistentName | Gets the persistent name of the collection. The persistent name of an object is a name that is unique for the object at the respective level of the COM object hierarchy.
VendorParametersSets | Gets an FPCVendorParametersSets collection that can hold sets of custom data for extending the collection.

Remarks

This collection implements the IFPCRoutingRules interface.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

COM Objects


IFPCRoutingRules | FPCRoutingRules _NewEnum(IUnknown) property [ISA Server 2004]

_NewEnum Property of IFPCRoutingRules[C++]

FPCRoutingRules._NewEnum [Visual Basic]

[C++]

The _NewEnum property gets an enumerator object for the collection. An enumerator object provides serial access to the elements of the collection.

HRESULT get__NewEnum(
  IUnknown* ppEnum
);

Parameters

ppEnum
Address of an interface pointer that on return points to the IUnknown interface of an enumerator object that implements an IEnumVARIANT interface for the collection. An interface pointer to the IEnumVARIANT interface of the enumerator object can be retrieved by calling QueryInterface on the IUnknown interface returned.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The _NewEnum property gets an enumerator object for the collection. An enumerator object provides serial access to the elements of the collection.

Property _NewEnum As IUnknown

Property Value

Reference to an enumerator object that provides serial access to the elements of the collection.

Remarks

This property is read-only.

In Visual Basic and VBScript, this property is used implicitly in For Each...In...Next constructs.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCRoutingRules


IFPCRoutingRules | FPCRoutingRules Add (2 Parameters) method [ISA Server 2004]

IFPCRoutingRules::Add[C++]

FPCRoutingRules.Add [Visual Basic]

[C++]

The Add method creates a new FPCRoutingRule object in the collection and returns a reference to it.

HRESULT Add(
  BSTR Name,
  IFPCRoutingRule** ppNewRule
);

Parameters

Name
[in] Required. BSTR that specifies the name of the new routing rule.
ppNewRule
Address of an interface pointer that on return points to the new IFPCRoutingRule interface created.

Return Values

This method can return one of the following:

  • S_OK, indicating that the operation succeeded.
  • An error code, indicating that the operation failed. In this case, the [out] parameter returned is a null object.

[Visual Basic]

The Add method creates a new FPCRoutingRule object in the collection and returns a reference to it.

Function Add( _
  ByVal Name As String _
) As FPCRoutingRule

Parameters

Name
[in] Required. String that specifies the name of the new routing rule.

Return Values

This method returns a reference to the new FPCRoutingRule object if successful. Otherwise, an error is raised that can be intercepted by using an error handler.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCRoutingRules


IFPCRoutingRules | FPCRoutingRules Count(long) property [ISA Server 2004]

Count Property of IFPCRoutingRules[C++]

FPCRoutingRules.Count [Visual Basic]

[C++]

The Count property gets the number of FPCRoutingRule objects in the collection.

HRESULT get_Count(
  long* plCount
);

Parameters

plCount
Pointer to a variable that on return receives a 32-bit integer specifying the number of FPCRoutingRule objects in the collection.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The Count property gets the number of FPCRoutingRule objects in the collection.

Property Count As Long

Property Value

A 32-bit integer that specifies the number of FPCRoutingRule objects in the collection.

Remarks

This property is read-only.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCRoutingRules


IFPCRoutingRules | FPCRoutingRules Item (2 Parameters) method [ISA Server 2004]

IFPCRoutingRules::Item[C++]

FPCRoutingRules.Item [Visual Basic]

[C++]

The Item method retrieves the requested IFPCRoutingRule interface from the collection.

HRESULT Item(
  VARIANT Index,
  IFPCRoutingRule** ppItem
);

Parameters

Index
[in] Required. Name or one-based index of the object to retrieve.
ppItem
[out] Address of an interface pointer that on return points to the IFPCRoutingRule interface requested.

Return Values

This method can return one of the following:

  • S_OK, indicating that the operation succeeded.
  • An error code, indicating that the operation failed. In this case, the [out] parameter returned is a null object.

[Visual Basic]

The Item method retrieves the requested FPCRoutingRule object from the collection.

Function Item( _
  ByVal Index As Variant _
) As FPCRoutingRule

Parameters

Index
[in] Required. Name or one-based index of the object to retrieve.

Return Values

This method returns a reference to the FPCRoutingRule object requested if successful. Otherwise, an error is raised that can be intercepted by using an error handler.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCRoutingRules


IFPCRoutingRules | FPCRoutingRules MoveDown(Long) method [ISA Server 2004]

IFPCRoutingRules::MoveDown[C++]

FPCRoutingRules.MoveDown [Visual Basic]

[C++]

The MoveDown method moves the specified routing rule one step down the list of rules, which corresponds to their order of application.

HRESULT MoveDown(
  long index
);

Parameters

index
[in] Required. Index (the current position indicated by the Order property) of the rule to move down.

Return Values

This method returns S_OK if the call is successful; otherwise, it returns an error code.
[Visual Basic]

The MoveDown method moves the specified routing rule one step down the list of rules, which corresponds to their order of application.

Sub MoveDown( _
  ByVal index As Long _
)

Parameters

index
[in] Required. Index (the current position indicated by the Order property) of the rule to move down.

Return Values

This method has no return values. If the call is unsuccessful, an error is raised that can be intercepted by using an error handler.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCRoutingRules, MoveUp


IFPCRoutingRules | FPCRoutingRules MoveUp(Long) method [ISA Server 2004]

IFPCRoutingRules::MoveUp[C++]

FPCRoutingRules.MoveUp [Visual Basic]

[C++]

The MoveUp method moves the specified routing rule one step up the list of rules, which corresponds to their order of application.

HRESULT MoveUp(
  long index
);

Parameters

index
[in] Required. Index (the current position indicated by the Order property) of the rule to move up.

Return Values

This method returns S_OK if the call is successful; otherwise, it returns an error code.
[Visual Basic]

The MoveUp method moves the specified routing rule one step up the list of rules, which corresponds to their order of application.

Sub MoveUp( _
  ByVal index As Long _
)

Parameters

index
[in] Required. Index (the current position indicated by the Order property) of the rule to move up.

Return Values

This method has no return values. If the call is unsuccessful, an error is raised that can be intercepted by using an error handler.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCRoutingRules, MoveDown


IFPCRoutingRules | FPCRoutingRules Remove(Variant) method [ISA Server 2004]

IFPCRoutingRules::Remove[C++]

FPCRoutingRules.Remove [Visual Basic]

[C++]

The Remove method removes the specified FPCRoutingRule object from the collection.

HRESULT Remove(
  VARIANT Index
);

Parameters

Index
[in] Required. Name or one-based index of the FPCRoutingRule object to remove.

Return Values

This method returns S_OK if the call is successful; otherwise, it returns an error code.
[Visual Basic]

The Remove method removes the specified FPCRoutingRule object from the collection.

Sub Remove( _
  ByVal Index As Variant _
)

Parameters

Index
[in] Required. Name or one-based index of the FPCRoutingRule object to remove.

Return Values

This method has no return values. If the call is unsuccessful, an error is raised that can be intercepted by using an error handler.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCRoutingRules


FPCRuleElements object [ISA Server 2004]

FPCRuleElements

The FPCRuleElements object is used to access ISA Server configuration settings, including schedules, URL sets, domain name sets, and protocol definitions. Many of the properties of the FPCRuleElements object are mirrored by items in the ISA Server Management toolbox. The configuration settings of each of these categories are programmatically managed through the FPCRuleElements object.

This object is typically accessed through the RuleElements property of an FPCArray object.

Click here to see the ISA Server object hierarchy.

Inheritance

This object inherits from the FPCPersist object, which contains methods and properties related to the persistent storage of an object's data. They include methods for exporting the object's data to and importing it from an XML document.

Methods

This object has no methods.

Properties

The FPCRuleElements object has the following properties.

Property | Description
AddressRanges | Gets an FPCAddressRanges collection that contains the IP address ranges defined in the array.
AuthenticationSchemes | Gets an FPCAuthenticationSchemes collection that contains the authentication schemes defined in the array.
Computers | Gets an FPCComputers collection that contains the computers defined in the array.
ComputerSets | Gets an FPCComputerSets collection that contains the computer sets defined in the array.
ContentTypeSets | Gets an FPCContentTypeSets collection that contains the content type sets defined in the array.
DomainNameSets | Gets an FPCDomainNameSets collection that contains the domain name sets defined in the array.
EventDefinitions | Gets an FPCEventDefinitions collection that contains the events defined in the array.
ProtocolDefinitions | Gets an FPCProtocolDefinitions collection that contains the Microsoft Firewall service protocols defined in the array.
RadiusServers | Gets an FPCRadiusServers collection that contains the RADIUS servers defined in the array.
Schedules | Gets an FPCSchedules collection that contains the schedules defined in the array.
Subnets | Gets an FPCSubnets collection that contains the subnets defined in the array.
URLSets | Gets an FPCURLSets collection that contains the URL sets defined in the array.
UserSets | Gets an FPCUserSets collection that contains the user sets defined in the array.
WebListeners | Gets an FPCWebListeners collection that contains the Web listeners defined in the array.

Methods Inherited from FPCPersist

Name | Description
CancelWaitForChanges | Cancels the registration established by the WaitForChanges method (for use in C and C++ programming only).
CanImport | Returns a Boolean value that indicates whether the object's properties can be imported from the specified XML document.
Export | Recursively writes the stored values of all the properties of the object and its subobjects to the specified XML document.
ExportToFile | Recursively writes the stored values of all the properties of the object and its subobjects to the specified XML file.
GetServiceRestartMask | Retrieves a 32-bit bitmask of the FpcServices enumerated type that specifies which services need to be restarted for currently unsaved changes to take effect.
Import | Recursively copies the values of all the properties of the object and of its subobjects from the specified XML document to persistent storage.
ImportFromFile | Recursively copies the values of all the properties of the object and of its subobjects from the specified XML file to persistent storage.
LoadDocProperties | Provides the XML document's properties so that you can know what information can be imported from the document.
Refresh | Recursively reads the values of all the properties of the object and of its subobjects from persistent storage, overwriting any changes that have not been saved.
Save | Recursively writes the current values of all the properties of the object and its subobjects to persistent storage.
WaitForChanges | Registers to wait for an event indicating that the contents of the object have changed (for use in C and C++ programming only).

Properties Inherited from FPCPersist

Name | Description
PersistentName | Gets the persistent name of the object. The persistent name of an object is a name that is unique for the object at the respective level of the COM object hierarchy.
VendorParametersSets | Gets an FPCVendorParametersSets collection that can hold sets of custom data for extending the object.

Remarks

This object implements the IFPCRuleElements interface.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

COM Objects


IFPCRuleElements | FPCRuleElements AddressRanges property [ISA Server 2004]

AddressRanges Property of IFPCRuleElements[C++]

FPCRuleElements.AddressRanges [Visual Basic]

[C++]

The AddressRanges property gets an FPCAddressRanges collection that contains the IP address ranges defined in the array.

HRESULT get_AddressRanges(
  IFPCAddressRanges** ppAddressRanges
);

Parameters

ppAddressRanges
Address of an interface pointer that on return points to an IFPCAddressRanges interface that represents the collection of all IP address ranges defined in the array.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only. Address ranges can be added or removed by calling the methods of the IFPCAddressRanges interface.

[Visual Basic]

The AddressRanges property gets an FPCAddressRanges collection that contains the IP address ranges defined in the array.

Property AddressRanges As FPCAddressRanges

Property Value

Reference to an FPCAddressRanges collection that contains the IP address ranges defined in the array.

Remarks

This property is read-only. Address ranges can be added or removed by calling the methods of the FPCAddressRanges collection.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCRuleElements


IFPCRuleElements.AuthenticationSchemes (1 Parameter) property [ISA Server 2004]

AuthenticationSchemes Property of IFPCRuleElements[C++]

FPCRuleElements.AuthenticationSchemes [Visual Basic]

[C++]

The AuthenticationSchemes property gets an FPCAuthenticationSchemes collection that contains the authentication schemes defined in the array.

HRESULT get_AuthenticationSchemes(
  IFPCAuthenticationSchemes** ppAuthenticationSchemes
);

Parameters

ppAuthenticationSchemes
Address of an interface pointer that on return points to an IFPCAuthenticationSchemes interface that represents the collection of all authentication schemes defined in the array.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only. Authentication schemes can be added or removed by calling the methods of the IFPCAuthenticationSchemes interface.

[Visual Basic]

The AuthenticationSchemes property gets an FPCAuthenticationSchemes collection that contains the authentication schemes defined in the array.

Property AuthenticationSchemes As FPCAuthenticationSchemes

Property Value

Reference to an FPCAuthenticationSchemes collection that contains the authentication schemes defined in the array.

Remarks

This property is read-only. Authentication schemes can be added or removed by calling the methods of the FPCAuthenticationSchemes collection.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCRuleElements


IFPCRuleElements | FPCRuleElements Computers property [ISA Server 2004]

Computers Property of IFPCRuleElements[C++]

FPCRuleElements.Computers [Visual Basic]

[C++]

The Computers property gets an FPCComputers collection that contains the computers defined in the array.

HRESULT get_Computers(
  IFPCComputers** ppComputers
);

Parameters

ppComputers
Address of an interface pointer that on return points to an IFPCComputers interface that represents the collection of all computers defined in the array.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only. It can be modified by calling the methods of the IFPCComputers interface.

[Visual Basic]

The Computers property gets an FPCComputers collection that contains the computers defined in the array.

Property Computers As FPCComputers

Property Value

Reference to an FPCComputers collection that contains the computers defined in the array.

Remarks

This property is read-only. It can be modified by calling the methods of the FPCComputers collection.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCRuleElements


IFPCRuleElements | FPCRuleElements ComputerSets property [ISA Server 2004]

ComputerSets Property of IFPCRuleElements[C++]

FPCRuleElements.ComputerSets [Visual Basic]

[C++]

The ComputerSets property gets an FPCComputerSets collection that contains the computer sets defined in the array.

HRESULT get_ComputerSets(
  IFPCComputerSets** ppComputerSets
);

Parameters

ppComputerSets
Address of an interface pointer that on return points to an IFPCComputerSets interface that represents the collection of all computer sets defined in the array.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only. Computer sets can be added or removed by calling the methods of the IFPCComputerSets interface retrieved.

[Visual Basic]

The ComputerSets property gets an FPCComputerSets collection that contains the computer sets defined in the array.

Property ComputerSets As FPCComputerSets

Property Value

Reference to an FPCComputerSets collection that contains the computer sets defined in the array.

Remarks

This property is read-only. Computer sets can be added or removed by calling the methods of the FPCComputerSets collection retrieved.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCRuleElements


IFPCRuleElements | FPCRuleElements ContentTypeSets property [ISA Server 2004]

ContentTypeSets Property of IFPCRuleElements[C++]

FPCRuleElements.ContentTypeSets [Visual Basic]

[C++]

The ContentTypeSets property gets an FPCContentTypeSets collection that contains the content type sets defined in the array.

Each content type set in the FPCContentTypeSets collection is represented by an FPCContentTypeSet collection. The default content type sets include Audio, Executable, Images, Text, and Video. Each content type set includes file types. For example, the Audio content type set could include the file types .aif, .aifc, .au, .m3u, .mid, and others.

HRESULT get_ContentTypeSets(
  IFPCContentTypeSets** ppContentTypeSets
);

Parameters

ppContentTypeSets
Address of an interface pointer that on return points to an IFPCContentTypeSets interface that represents the collection of all content type sets defined in the array.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only. It can be modified by calling the methods of the IFPCContentTypeSets interface.

[Visual Basic]

The ContentTypeSets property gets an FPCContentTypeSets collection that contains the content type sets defined in the array.

Each content type set in the FPCContentTypeSets collection is represented by an FPCContentTypeSet collection. The default content type sets include Audio, Executable, Images, Text, and Video. Each content type set includes file types. For example, the Audio content type set could include the file types .aif, .aifc, .au, .m3u, .mid, and others.

Property ContentTypeSets As FPCContentTypeSets

Property Value

Reference to an FPCContentTypeSets collection that contains the content type sets defined in the array.

Remarks

This property is read-only. It can be modified by calling the methods of the FPCContentTypeSets collection.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCRuleElements


IFPCRuleElements | FPCRuleElements DomainNameSets property [ISA Server 2004]

DomainNameSets Property of IFPCRuleElements[C++]

FPCRuleElements.DomainNameSets [Visual Basic]

[C++]

The DomainNameSets property gets an FPCDomainNameSets collection that contains the domain name sets defined in the array.

HRESULT get_DomainNameSets(
  IFPCDomainNameSets** ppDomainNameSets
);

Parameters

ppDomainNameSets
Address of an interface pointer that on return points to an IFPCDomainNameSets interface that represents the collection of all domain name sets defined in the array.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only. It can be modified by calling the methods of the IFPCDomainNameSets interface.

[Visual Basic]

The DomainNameSets property gets an FPCDomainNameSets collection that contains the domain name sets defined in the array.

Property DomainNameSets As FPCDomainNameSets

Property Value

Reference to an FPCDomainNameSets collection that contains the domain name sets defined in the array.

Remarks

This property is read-only. It can be modified by calling the methods of the FPCDomainNameSets collection.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCRuleElements


IFPCRuleElements | FPCRuleElements EventDefinitions property [ISA Server 2004]

EventDefinitions Property of IFPCRuleElements[C++]

FPCRuleElements.EventDefinitions [Visual Basic]

[C++]

The EventDefinitions property gets an FPCEventDefinitions collection that contains the events defined in the array.

HRESULT get_EventDefinitions(
  IFPCEventDefinitions** ppEventDefinitions
);

Parameters

ppEventDefinitions
Address of an interface pointer that on return points to an IFPCEventDefinitions interface that represents the collection of all events defined in the array.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only. Event definitions can be added and removed by calling the Add and Remove methods of the IFPCEventDefinitions interface retrieved.

Each FPCEventDefinition object in the collection defines a single event. Events describe conditions that require the attention of an administrator, and predetermined actions can be triggered in response to a particular event by using an FPCAlert object.

[Visual Basic]

The EventDefinitions property gets an FPCEventDefinitions collection that contains the events defined in the array.

Property EventDefinitions As FPCEventDefinitions

Property Value

Reference to an FPCEventDefinitions collection that contains the events defined in the array.

Remarks

This property is read-only. Event definitions can be added and removed by calling the Add and Remove methods of the FPCEventDefinitions collection retrieved.

Each FPCEventDefinition object in the collection defines a single event. Events describe conditions that require the attention of an administrator, and predetermined actions can be triggered in response to a particular event by using an FPCAlert object.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCRuleElements


IFPCRuleElements.ProtocolDefinitions (1 Parameter) property [ISA Server 2004]

ProtocolDefinitions Property of IFPCRuleElements[C++]

FPCRuleElements.ProtocolDefinitions [Visual Basic]

[C++]

The ProtocolDefinitions property gets an FPCProtocolDefinitions collection that contains the Microsoft Firewall service protocols defined in the array.

HRESULT get_ProtocolDefinitions(
  IFPCProtocolDefinitions** ppProtocolDefinitions
);

Parameters

ppProtocolDefinitions
Address of an interface pointer that on return points to an IFPCProtocolDefinitions interface that represents the collection of all Firewall service protocols defined in the array.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only. User-defined Firewall service protocols can be added and removed by calling the Add and Remove methods of the IFPCProtocolDefinitions interface retrieved. The predefined protocols are read-only.

[Visual Basic]

The ProtocolDefinitions property gets an FPCProtocolDefinitions collection that contains the Microsoft Firewall service protocols defined in the array.

Property ProtocolDefinitions As FPCProtocolDefinitions

Property Value

Reference to an FPCProtocolDefinitions collection that contains the Firewall service protocols defined in the array.

Remarks

This property is read-only. User-defined Firewall service protocols can be added and removed by calling the Add and Remove methods of the FPCProtocolDefinitions collection retrieved. The predefined protocols are read-only.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCRuleElements


IFPCRuleElements | FPCRuleElements RadiusServers property [ISA Server 2004]

RadiusServers Property of IFPCRuleElements[C++]

FPCRuleElements.RadiusServers [Visual Basic]

[C++]

The RadiusServers property gets an FPCRadiusServers collection that contains the RADIUS servers defined in the array.

HRESULT get_RadiusServers(
  IFPCRadiusServers** ppRadiusServers
);

Parameters

ppRadiusServers
Address of an interface pointer that on return points to an IFPCRadiusServers interface that represents the collection of all RADIUS servers defined in the array.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only. RADIUS servers can be added and removed by calling the Add and Remove methods of the IFPCRadiusServers interface retrieved.

[Visual Basic]

The RadiusServers property gets an FPCRadiusServers collection that contains the RADIUS servers defined in the array.

Property RadiusServers As FPCRadiusServers

Property Value

Reference to an FPCRadiusServers collection that contains the RADIUS servers defined in the array.

Remarks

This property is read-only. RADIUS servers can be added and removed by calling the Add and Remove methods of the FPCRadiusServers collection retrieved.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCRuleElements


IFPCRuleElements | FPCRuleElements Schedules property [ISA Server 2004]

Schedules Property of IFPCRuleElements[C++]

FPCRuleElements.Schedules [Visual Basic]

[C++]

The Schedules property gets an FPCSchedules collection that contains the schedules defined in the array.

HRESULT get_Schedules(
  IFPCSchedules** ppSchedules
);

Parameters

ppSchedules
Address of an interface pointer that on return points to an IFPCSchedules interface that represents the collection of all schedules defined in the array.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only. Schedules can be added and removed by calling the methods of the IFPCSchedules interface retrieved.

ISA Server schedules are specified in terms of hour blocks defined for each day of the week and are stored as elements of the FPCSchedules collection. For an example of using the FPCSchedules collection, see Configuring Schedules.

[Visual Basic]

The Schedules property gets an FPCSchedules collection that contains the schedules defined in the array.

Property Schedules As FPCSchedules

Property Value

Reference to an FPCSchedules collection that contains the schedules defined in the array.

Remarks

This property is read-only. Schedules can be added and removed by calling the methods of the FPCSchedules collection retrieved.

ISA Server schedules are specified in terms of hour blocks defined for each day of the week and are stored as elements of the FPCSchedules collection. For an example of using the FPCSchedules collection, see Configuring Schedules.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCRuleElements


IFPCRuleElements | FPCRuleElements Subnets property [ISA Server 2004]

Subnets Property of IFPCRuleElements[C++]

FPCRuleElements.Subnets [Visual Basic]

[C++]

The Subnets property gets an FPCSubnets collection that contains the subnets defined in the array.

HRESULT get_Subnets(
  IFPCSubnets** ppSubnets
);

Parameters

ppSubnets
Address of an interface pointer that on return points to an IFPCSubnets interface that represents the collection of all subnets defined in the array.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only. It can be modified by calling the methods of the IFPCSubnets interface.

[Visual Basic]

The Subnets property gets an FPCSubnets collection that contains the subnets defined in the array.

Property Subnets As FPCSubnets

Property Value

Reference to an FPCSubnets collection that contains the subnets defined in the array.

Remarks

This property is read-only. It can be modified by calling the methods of the FPCSubnets collection.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCRuleElements


IFPCRuleElements | FPCRuleElements URLSets property [ISA Server 2004]

URLSets Property of IFPCRuleElements[C++]

FPCRuleElements.URLSets [Visual Basic]

[C++]

The URLSets property gets an FPCURLSets collection that contains the URL sets defined in the array.

HRESULT get_URLSets(
  IFPCURLSets** ppURLSets
);

Parameters

ppURLSets
Address of an interface pointer that on return points to an IFPCURLSets interface that represents the collection of all URL sets defined in the array.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only. It can be modified by calling the methods of the IFPCURLSets interface.

[Visual Basic]

The URLSets property gets an FPCURLSets collection that contains the URL sets defined in the array.

Property URLSets As FPCURLSets

Property Value

Reference to an FPCURLSets collection that contains the URL sets defined in the array.

Remarks

This property is read-only. It can be modified by calling the methods of the FPCURLSets collection.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCRuleElements


IFPCRuleElements | FPCRuleElements UserSets property [ISA Server 2004]

UserSets Property of IFPCRuleElements[C++]

FPCRuleElements.UserSets [Visual Basic]

[C++]

The UserSets property gets an FPCUserSets collection that contains the user sets defined in the array.

HRESULT get_UserSets(
  IFPCUserSets** ppUserSets
);

Parameters

ppUserSets
Address of an interface pointer that on return points to an IFPCUserSets interface that represents the collection of all user sets defined in the array.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only. User sets can be added and removed by calling the methods of the IFPCUserSets interface retrieved.

[Visual Basic]

The UserSets property gets an FPCUserSets collection that contains the user sets defined in the array.

Property UserSets As FPCUserSets

Property Value

Reference to an FPCUserSets collection that contains the user sets defined in the array.

Remarks

This property is read-only. User sets can be added and removed by calling the methods of the FPCUserSets collection retrieved.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCRuleElements


IFPCRuleElements | FPCRuleElements WebListeners property [ISA Server 2004]

WebListeners Property of IFPCRuleElements[C++]

FPCRuleElements.WebListeners [Visual Basic]

[C++]

The WebListeners property gets an FPCWebListeners collection that contains the Web listeners defined in the array.

HRESULT get_WebListeners(
  IFPCWebListeners** ppWebListeners
);

Parameters

ppWebListeners
Address of an interface pointer that on return points to an IFPCWebListeners interface that represents the collection of all Web listeners defined in the array.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only. Web listeners can be added and removed by calling the methods of the IFPCWebListeners interface retrieved.

Each FPCWebListener object in the collection represents a listener for incoming Web requests.

[Visual Basic]

The WebListeners property gets an FPCWebListeners collection that contains the Web listeners defined in the array.

Property WebListeners As FPCWebListeners

Property Value

Reference to an FPCWebListeners collection that contains the Web listeners defined in the array.

Remarks

This property is read-only. Web listeners can be added and removed by calling the methods of the FPCWebListeners collection retrieved.

Each FPCWebListener object in the collection represents a listener for incoming Web requests.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCRuleElements


FPCSchedule object [ISA Server 2004]

FPCSchedule

The FPCSchedule object defines a schedule. A schedule is defined by blocks representing hours that are selected for each day of the week. Each day of the week can have different hour blocks selected. Schedules are used by ISA Server to define a set of hours during which a certain configuration detail, such as a policy rule, applies.

The hour blocks used to define a schedule include the specified time and the one-hour period following that time. For example, the hour designated by 2_PM is the one-hour time block between 2:00 P.M. (14:00) and 3 P.M. (15:00).

The FPCSchedule object is typically an element of an FPCSchedules collection.

Click here to see the ISA Server object hierarchy.

Inheritance

This object inherits from the FPCPersist object, which contains methods and properties related to the persistent storage of an object's data. They include methods for exporting the object's data to and importing it from an XML document.

Methods

The FPCSchedule object defines the following methods.

Method | Description
IsSet | Returns a Boolean variable indicating whether every hour in the specified set is part of the schedule.
Set | Adds a set of hours to the schedule.
UnSet | Removes a set of hours from the schedule.

Properties

The FPCSchedule object has the following properties.

Property | Description
Description | Gets or sets the description of the schedule.
Name | Gets or sets the name of the schedule.

Methods Inherited from FPCPersist

Name | Description
CancelWaitForChanges | Cancels the registration established by the WaitForChanges method (for use in C and C++ programming only).
CanImport | Returns a Boolean value that indicates whether the object's properties can be imported from the specified XML document.
Export | Writes the stored values of all of the object's properties to the specified XML document.
ExportToFile | Writes the stored values of all of the object's properties to the specified XML file.
GetServiceRestartMask | Retrieves a 32-bit bitmask of the FpcServices enumerated type that specifies which services need to be restarted for currently unsaved changes to take effect.
Import | Copies the values of all of the object's properties from the specified XML document to persistent storage.
ImportFromFile | Copies the values of all of the object's properties from the specified XML file to persistent storage.
LoadDocProperties | Provides the XML document's properties so that you can know what information can be imported from the document.
Refresh | Reads the values of all of the object's properties from persistent storage, overwriting any changes that have not been saved.
Save | Writes the current values of all of the object's properties to persistent storage.
WaitForChanges | Registers to wait for an event indicating that the contents of the object have changed (for use in C and C++ programming only).

Properties Inherited from FPCPersist

Name | Description
PersistentName | Gets the persistent name of the object. The persistent name of an object is a name that is unique for the object at the respective level of the COM object hierarchy.
VendorParametersSets | Gets an FPCVendorParametersSets object that can hold sets of custom data for extending the object.

Remarks

This collection implements the IFPCSchedule interface.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

COM Objects


IFPCSchedule | FPCSchedule Description(BSTR,BSTR) property [ISA Server 2004]

Description Property of IFPCSchedule[C++]

FPCSchedule.Description [Visual Basic]

[C++]

The Description property gets or sets the description of the schedule.

HRESULT get_Description(
  BSTR* pbstrDescription
);

HRESULT put_Description(
  BSTR bstrDescription
);

Parameters

pbstrDescription
Pointer to a BSTR that is set on return to a string value specifying the description of the schedule.
bstrDescription
BSTR that specifies the description of the schedule.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write.

[Visual Basic]

The Description property gets or sets the description of the schedule.

Property Description As String

Property Value

String that specifies the description of the schedule.

Remarks

This property is read/write.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCSchedule


IFPCSchedule | FPCSchedule IsSet (3 Parameters) method [ISA Server 2004]

IFPCSchedule::IsSet[C++]

FPCSchedule.IsSet [Visual Basic]

[C++]

The IsSet method returns a Boolean value that indicates whether every hour in the specified set is part of the schedule.

HRESULT IsSet(
  FpcScheduleDays Day,
  FpcScheduleHours Hour,
  VARIANT_BOOL* pfIsSet
);

Parameters

Day
[in] Value from the FpcScheduleDays enumerated type that specifies a day or the entire week. It can be ALL_WEEK, SUN, MON, and so on.
Hour
[in] Value from the FpcScheduleHours enumerated type that specifies an hour or hours. It can be ALL_DAY, AM_0, AM_1, PM_1, PM_2, and so on.
pfIsSet
[out] Pointer to a Boolean variable that is set on return to VARIANT_TRUE if every hour in the set specified by the Day and Hour parameters is part of the schedule, or to VARIANT_FALSE if any hour in the set is not part of the schedule.

Return Values

This method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

The hour blocks defined by a schedule include the specified time and the one-hour block following that time. For example, the hour designated by 2_PM is the one-hour time block between 2:00 P.M. (14:00) and 3:00 P.M. (15:00).

[Visual Basic]

The IsSet method returns a Boolean value that indicates whether every hour in the specified set is part of the schedule.

Function IsSet( _
  ByVal Day As FpcScheduleDays, _
  ByVal Hour As FpcScheduleHours _
) As Boolean

Parameters

Day
[in] Value from the FpcScheduleDays enumerated type that specifies a day or the entire week. It can be ALL_WEEK, SUN, MON, and so on.
Hour
[in] Value from the FpcScheduleHours enumerated type that specifies an hour or hours. It can be ALL_DAY, AM_0, AM_1, PM_1, PM_2, and so on.

Return Values

Boolean value that is set to True if every hour in the set specified by the Day and Hour parameters is part of the schedule, or to False if any hour in the set is not part of the schedule.

Remarks

The hour blocks defined by a schedule include the specified time and the one-hour block following that time. For example, the hour designated by 2_PM is the one-hour time block between 2:00 P.M. (14:00) and 3:00 P.M. (15:00).

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCSchedule, Set, UnSet


IFPCSchedule | FPCSchedule Name(BSTR,BSTR) property [ISA Server 2004]

Name Property of IFPCSchedule[C++]

FPCSchedule.Name [Visual Basic]

[C++]

The Name property gets or sets the name of the schedule.

HRESULT get_Name(
  BSTR* pbstrName
);

HRESULT put_Name(
  BSTR bstrName
);

Parameters

pbstrName
Pointer to a BSTR that is set on return to a string value specifying the name of the schedule.
bstrName
BSTR that specifies the name of the schedule.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write.

[Visual Basic]

The Name property gets or sets the name of the schedule.

Property Name As String

Property Value

String that specifies the name of the schedule.

Remarks

This property is read/write.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCSchedule


IFPCSchedule | FPCSchedule Set (2 Parameters) method [ISA Server 2004]

IFPCSchedule::Set[C++]

FPCSchedule.Set [Visual Basic]

[C++]

The Set method adds a set of hours to the schedule.

HRESULT Set(
  FpcScheduleDays Day,
  FpcScheduleHours Hour
);

Parameters

Day
[in] Value from the FpcScheduleDays enumerated type that specifies a day or the entire week. It can be ALL_WEEK, SUN, MON, and so on.
Hour
[in] Value from the FpcScheduleHours enumerated type that specifies an hour or hours. It can be ALL_DAY, AM_0, AM_1, PM_1, PM_2, and so on.

Return Values

This method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

The hour blocks defined by a schedule include the specified time and the one-hour block following that time. For example, the hour designated by 2_PM is the one-hour time block between 2:00 P.M. (14:00) and 3:00 P.M. (15:00).

Example Code

The following example adds "3 A.M. on Sunday" to the set:

Set(SUN, AM_3)

The following example adds "6 A.M. on every day" to the set:

Set(ALL_WEEK, AM_6)

The following example adds all of Monday to the set:

Set(MON, ALL_DAY)

The following example adds all hours of the week to the set:

Set(ALL_WEEK, ALL_DAY)

[Visual Basic]

The Set method adds a set of hours to the schedule.

Sub Set( _
  ByVal Day As FpcScheduleDays, _
  ByVal Hour As FpcScheduleHours _
)

Parameters

Day
[in] Value from the FpcScheduleDays enumerated type that specifies a day or the entire week. It can be ALL_WEEK, SUN, MON, and so on.
Hour
[in] Value from the FpcScheduleHours enumerated type that specifies an hour or hours. It can be ALL_DAY, AM_0, AM_1, PM_1, PM_2, and so on.

Return Values

This method has no return values. If the call is unsuccessful, an error is raised that can be intercepted by using an error handler.

Remarks

The hour blocks defined by a schedule include the specified time and the one-hour block following that time. For example, the hour designated by 2_PM is the one-hour time block between 2:00 P.M. (14:00) and 3:00 P.M. (15:00).

Example Code

The following example adds "3 A.M. on Sunday" to the set:

Set(SUN, AM_3)

The following example adds "6 A.M. on every day" to the set:

Set(ALL_WEEK, AM_6)

The following example adds all of Monday to the set:

Set(MON, ALL_DAY)

The following example adds all hours of the week to the set:

Set(ALL_WEEK, ALL_DAY)

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCSchedule, IsSet, UnSet


IFPCSchedule | FPCSchedule UnSet (2 Parameters) method [ISA Server 2004]

IFPCSchedule::UnSet[C++]

FPCSchedule.UnSet [Visual Basic]

[C++]

The UnSet method removes a set of hours from the schedule.

HRESULT UnSet(
  FpcScheduleDays Day,
  FpcScheduleHours Hour
);

Parameters

Day
[in] Value from the FpcScheduleDays enumerated type that specifies a day or the entire week. It can be ALL_WEEK, SUN, MON, and so on.
Hour
[in] Value from the FpcScheduleHours enumerated type that specifies an hour or hours. It can be ALL_DAY, AM_0, AM_1, PM_1, PM_2, and so on.

Return Values

This method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

The hour blocks defined by a schedule include the specified time and the one-hour block beyond that time. For example, the hour designated by 2_PM is the one-hour time block between 2:00 P.M. (14:00) and 3:00 P.M. (15:00).

[Visual Basic]

The UnSet method removes a set of hours from the schedule.

Sub UnSet( _
  ByVal Day As FpcScheduleDays, _
  ByVal Hour As FpcScheduleHours _
)

Parameters

Day
[in] Value from the FpcScheduleDays enumerated type that specifies a day or the entire week. It can be ALL_WEEK, SUN, MON, and so on.
Hour
[in] Value from the FpcScheduleHours enumerated type that specifies an hour or hours. It can be ALL_DAY, AM_0, AM_1, PM_1, PM_2, and so on.

Return Values

This method has no return values. If the call is unsuccessful, an error is raised that can be intercepted by using an error handler.

Remarks

The hour blocks defined by a schedule include the specified time and the one-hour block beyond that time. For example, the hour designated by 2_PM is the one-hour time block between 2:00 P.M. (14:00) and 3:00 P.M. (15:00).

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCSchedule, IsSet, Set


FPCScheduledContentDownload collection [ISA Server 2004]

FPCScheduledContentDownload Collection

The FPCScheduledContentDownload collection holds a set of FPCScheduledContentDownloadConfig objects that define individual content download jobs. This collection allows you to obtain a list of the content download jobs that are already defined, to retrieve the FPCScheduledContentDownloadConfig object for a specific job and access its properties, to define new content download jobs, and to remove existing jobs.

Content download jobs can run only if:

  • The Local Host network is configured to listen for requests from Web proxy clients (see the EnableWebProxyClients property of the FPCNetwork object representing the Local Host network).
  • There is a Web listener (an FPCWebListener object) that listens for requests from the Local Host network.
  • The Scheduled Download Jobs system policy configuration group is enabled (see the Enabled property of the FPCSystemPolicyConfigGroup object), or an access rule that allows HTTP traffic to the All Networks network set from the Local Host network is enabled.
  • The Microsoft Firewall service and the Microsoft ISA Server Job Scheduler service are running (see the FirewallServiceStatus and JobSchedulerServiceStatus properties of the applicable FPCServer object).
  • The Web proxy is enabled (see the Enabled property of the FPCApplicationFilter object representing the Web Proxy Filter add-in).

In addition, downloaded content can be stored in the ISA Server cache only if a cache drive with a size (CacheLimitInMegs) greater than zero is configured.

The FPCScheduledContentDownload collection is accessed through the ScheduledContentDownload property of the FPCCache object.

Click here to see the ISA Server object hierarchy.

Inheritance

This object inherits from the FPCPersist object, which contains methods and properties related to the persistent storage of an object's data. They include methods for exporting the object's data to and importing it from an XML document.

Methods

The FPCScheduledContentDownload collection defines the following methods.

Method | Description
Add | Creates a new FPCScheduledContentDownloadConfig object in the collection and returns a reference to it.
Item | Retrieves the requested FPCScheduledContentDownloadConfig object from the collection.
Remove | Removes the specified FPCScheduledContentDownloadConfig object from the collection.

Properties

The FPCScheduledContentDownload collection has the following properties.

Property | Description
_NewEnum | Gets an enumerator object for the collection.
Count | Gets the number of FPCScheduledContentDownloadConfig objects in the collection.

Methods Inherited from FPCPersist

Name | Description
CancelWaitForChanges | Cancels the registration established by the WaitForChanges method (for use in C and C++ programming only).
CanImport | Returns a Boolean value that indicates whether the properties of the collection, its elements, and their subobjects can be imported from the specified XML document.
Export | Recursively writes the stored values of all the properties of the collection, its elements, and their subobjects to the specified XML document.
ExportToFile | Recursively writes the stored values of all the properties of the collection, its elements, and their subobjects to the specified XML file.
GetServiceRestartMask | Retrieves a 32-bit bitmask of the FpcServices enumerated type that specifies which services need to be restarted for currently unsaved changes to take effect.
Import | Recursively copies the values of all the properties of the collection, its elements, and their subobjects from the specified XML document to persistent storage.
ImportFromFile | Recursively copies the values of all the properties of the collection, its elements, and their subobjects from the specified XML file to persistent storage.
LoadDocProperties | Provides the XML document's properties so that you can know what information can be imported from the document.
Refresh | Recursively reads the values of all the properties of the collection, its elements, and their subobjects from persistent storage, overwriting any changes that have not been saved.
Save | Recursively writes the current values of all the properties of the collection, its elements, and their subobjects to persistent storage.
WaitForChanges | Registers to wait for an event indicating that the contents of the object have changed (for use in C and C++ programming only).

Properties Inherited from FPCPersist

Name | Description
PersistentName | Gets the persistent name of the collection. The persistent name of an object is a name that is unique for the object at the respective level of the COM object hierarchy.
VendorParametersSets | Gets an FPCVendorParametersSets collection that can hold sets of custom data for extending the collection.

Remarks

This collection implements the IFPCScheduledContentDownload interface.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

COM Objects


IFPCScheduledContentDownload._NewEnum(IUnknown) property [ISA Server 2004]

_NewEnum Property of IFPCScheduledContentDownload[C++]

FPCScheduledContentDownload._NewEnum [Visual Basic]

[C++]

The _NewEnum property gets an enumerator object for the collection. An enumerator object provides serial access to the elements of the collection.

HRESULT get__NewEnum(
  IUnknown* ppEnum
);

Parameters

ppEnum
Address of an interface pointer that on return points to the IUnknown interface of an enumerator object that implements an IEnumVARIANT interface for the collection. An interface pointer to the IEnumVARIANT interface of the enumerator object can be retrieved by calling QueryInterface on the IUnknown interface returned.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The _NewEnum property gets an enumerator object for the collection. An enumerator object provides serial access to the elements of the collection.

Property _NewEnum As IUnknown

Property Value

Reference to an enumerator object that provides serial access to the elements of the collection.

Remarks

This property is read-only.

In Visual Basic and VBScript, this property is used implicitly in For Each...In...Next constructs.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCScheduledContentDownload


IFPCScheduledContentDownload.Add (3 Parameters) method [ISA Server 2004]

IFPCScheduledContentDownload::Add[C++]

FPCScheduledContentDownload.Add [Visual Basic]

[C++]

The Add method creates a new FPCScheduledContentDownloadConfig object in the collection and returns a reference to it.

HRESULT Add(
  BSTR Name,
  BSTR URL,
  IFPCScheduledContentDownloadConfig** ppNewScheduledContentDownloadConfig
);

Parameters

Name
[in] Required. BSTR that specifies the name of the content download job.
URL
[in] Required. BSTR that specifies the URL from which content is to be fetched.
ppNewScheduledContentDownloadConfig
[out] Address of an interface pointer that on return points to the new IFPCScheduledContentDownloadConfig interface created.

Return Values

This method can return one of the following:

  • S_OK, indicating that the operation succeeded.
  • An error code, indicating that the operation failed. In this case, the [out] parameter returned is a null object.

Remarks

The content download job created can run only if:

  • The Local Host network is configured to listen for requests from Web proxy clients (see the EnableWebProxyClients property of the FPCNetwork object representing the Local Host network).
  • There is a Web listener (an FPCWebListener object) that listens for requests from the Local Host network.
  • The Scheduled Download Jobs system policy configuration group is enabled (see the Enabled property of the FPCSystemPolicyConfigGroup object), or an access rule that allows HTTP traffic to the All Networks network set from the Local Host network is enabled.
  • The Microsoft Firewall service and the Microsoft ISA Server Job Scheduler service are running (see the FirewallServiceStatus and JobSchedulerServiceStatus properties of the applicable FPCServer object).
  • The Web proxy is enabled (see the Enabled property of the FPCApplicationFilter object representing the Web Proxy Filter add-in).

In addition, downloaded content can be stored in the ISA Server cache only if a cache drive with a size (CacheLimitInMegs) greater than zero is configured.

[Visual Basic]

The Add method creates a new FPCScheduledContentDownloadConfig object in the collection and returns a reference to it.

Function Add( _
  ByVal Name As String, _
  ByVal URL As String _
) As FPCScheduledContentDownloadConfig

Parameters

Name
[in] Required. String that specifies the name of the new content download job.
URL
[in] Required. String that specifies the URL from which content is to be fetched.

Return Values

This method returns a reference to an FPCScheduledContentDownloadConfig object if successful. Otherwise, an error is raised that can be intercepted by using an error handler.

Remarks

The content download job created can run only if:

  • The Local Host network is configured to listen for requests from Web proxy clients (see the EnableWebProxyClients property of the FPCNetwork object representing the Local Host network).
  • There is a Web listener (an FPCWebListener object) that listens for requests from the Local Host network.
  • The Scheduled Download Jobs system policy configuration group is enabled (see the Enabled property of the FPCSystemPolicyConfigGroup object), or an access rule that allows HTTP traffic to the All Networks network set from the Local Host network is enabled.
  • The Microsoft Firewall service and the Microsoft ISA Server Job Scheduler service are running (see the FirewallServiceStatus and JobSchedulerServiceStatus properties of the applicable FPCServer object).
  • The Web proxy is enabled (see the Enabled property of the FPCApplicationFilter object representing the Web Proxy Filter add-in).

In addition, downloaded content can be stored in the ISA Server cache only if a cache drive with a size (CacheLimitInMegs) greater than zero is configured.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCScheduledContentDownload


IFPCScheduledContentDownload.Count(long) property [ISA Server 2004]

Count Property of IFPCScheduledContentDownload[C++]

FPCScheduledContentDownload.Count [Visual Basic]

[C++]

The Count property gets the number of FPCScheduledContentDownloadConfig objects in the collection.

HRESULT get_Count(
  long* plCount
);

Parameters

plCount
Pointer to a variable that on return receives a 32-bit integer specifying the number of FPCScheduledContentDownloadConfig objects in the collection.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The Count property gets the number of FPCScheduledContentDownloadConfig objects in the collection.

Property Count As Long

Property Value

A 32-bit integer that specifies the number of FPCScheduledContentDownloadConfig objects in the collection.

Remarks

This property is read-only.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCScheduledContentDownload


IFPCScheduledContentDownload.Item (2 Parameters) method [ISA Server 2004]

IFPCScheduledContentDownload::Item[C++]

FPCScheduledContentDownload.Item [Visual Basic]

[C++]

The Item method retrieves the requested IFPCScheduledContentDownloadConfig interface from the collection.

HRESULT Item(
  VARIANT Index,
  IFPCScheduledContentDownloadConfig** ppItem
);

Parameters

Index
Required. Name or one-based index of the object to retrieve.
ppItem
[out] Address of an interface pointer that on return points to the IFPCScheduledContentDownloadConfig interface requested.

Return Values

This method can return one of the following:

  • S_OK, indicating that the operation succeeded.
  • An error message, indicating that the operation failed. In this case, the [out] parameter returned is a null object.

[Visual Basic]

The Item method retrieves the requested FPCScheduledContentDownloadConfig object from the collection.

Function Item( _
  ByVal Index As Variant _
) As FPCDelegatedAdmin

Parameters

Index
Required. Name or one-based index of the object to retrieve.

Return Values

This method returns a reference to the FPCScheduledContentDownloadConfig object requested if successful. Otherwise, an error is raised that can be intercepted by using an error handler.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCScheduledContentDownload


IFPCScheduledContentDownload.Remove(Variant) method [ISA Server 2004]

IFPCScheduledContentDownload::Remove[C++]

FPCScheduledContentDownload.Remove [Visual Basic]

[C++]

The Remove method removes the specified FPCScheduledContentDownloadConfig object from the collection.

HRESULT Remove(
  VARIANT Index
);

Parameters

Index
[in] Required. Name or one-based index of the FPCScheduledContentDownloadConfig object to remove.

Return Values

This method returns S_OK if the call is successful; otherwise, it returns an error code.
[Visual Basic]

The Remove method removes the specified FPCScheduledContentDownloadConfig object from the collection.

Sub Remove( _
  ByVal Index As Variant _
)

Parameters

Index
[in] Required. Name or one-based index of the FPCScheduledContentDownloadConfig object to remove.

Return Values

This method has no return values. If the call is unsuccessful, an error is raised that can be intercepted by using an error handler.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCScheduledContentDownload


FPCScheduledContentDownloadConfig object [ISA Server 2004]

FPCScheduledContentDownloadConfig

The FPCScheduledContentDownloadConfig object defines a single content download job contained in the FPCScheduledContentDownload collection. This collection allows you to create a list of content download jobs and access their properties.

With the Microsoft ISA Server Job Scheduler service, you can download Hypertext Transfer Protocol (HTTP) content directly to the ISA Server cache upon request or according to a schedule. Using this prefetching feature, you can update the ISA Server cache with HTTP content that you anticipate will be requested by clients in your organization, so that the content will be available for access directly from the ISA Server cache, rather than from the Internet.

A content download job can be scheduled to run only once on a specified date, to run every day, or to run on specified days of the week. A content download job that runs on more than one day can be scheduled to run once on each day or to run repeatedly on each day.

Each content download job is configured to download HTTP files from a specified URL to the ISA Server cache. A job can be configured to follow links to a specified maximum depth and to download content only from the domain of the root URL, or from other domains as well.

A content download job can run only if:

  • There is a Web listener (an FPCWebListener object) that listens for requests from the Local Host network.
  • The Scheduled Download Jobs system policy configuration group is enabled (see the Enabled property of the FPCSystemPolicyConfigGroup object), or an access rule that allows HTTP traffic to the All Networks network set from the Local Host network is enabled.
  • The Microsoft Firewall service and the Microsoft ISA Server Job Scheduler service are running (see the FirewallServiceStatus and JobSchedulerServiceStatus properties of the applicable FPCServer object).
  • The Web proxy is enabled (see the Enabled property of the FPCApplicationFilter object representing the Web Proxy Filter add-in).

In addition, downloaded content can be stored in the ISA Server cache only if a cache drive with a size (CacheLimitInMegs) greater than zero is configured.

The FPCScheduledContentDownloadConfig object is typically an element of an FPCScheduledContentDownload collection.

Click here to see the ISA Server object hierarchy.

Inheritance

This object inherits from the FPCPersist object, which contains methods and properties related to the persistent storage of an object's data. They include methods for exporting the object's data to and importing it from an XML document.

Methods

The FPCScheduledContentDownloadConfig object defines the following methods.

Method | Description
AbortOnAllServers | Stops the content download job.
Run | Runs the content download job.
SetDailyFrequency | Sets the hour and minute parts of the start and end times for repeated runs on a single day.
SetTaskPeriod | Sets the values of the TaskPeriod property (the type of schedule) and the ScheduleDays property (the days of the week on which the content download job will run) of the content download job.

Properties

The FPCScheduledContentDownloadConfig object has the following properties.

Property | Description
DailyFreqEndHour | Gets the hour part of the end time for repeated runs on a single day.
DailyFreqEndMinute | Gets the minute part of the end time for repeated runs on a single day.
DailyFreqStartHour | Gets the hour part of the start time for repeated runs on a single day.
DailyFreqStartMinute | Gets the minute part of the start time for repeated runs on a single day.
DailyFreqTimeUnits | Gets or sets a value from the FpcTimeScale enumerated type that specifies the time units of the repetition time for repeated runs on a single day.
DailyFreqTimeValue | Gets or sets the repetition time for repeated runs on a single day in the units specified by the DailyFreqTimeUnits property.
DailyFrequency | Gets or sets a value from the FpcDailyFrequency enumerated type that specifies whether the download job is to run once on a single day or more than once on a single day.
DailyHour | Gets or sets the hour part of the time for a one-time run on a single day.
DailyMinute | Gets or sets the minute part of the time for a one-time run on a single day.
Description | Gets or sets the description of the content download job.
DownloadOnceHour | Gets or sets the hour part of the start time for a content download job that runs only once.
DownloadOnceMinute | Gets or sets the minute part of the start time for a content download job that runs only once.
Enabled | Gets or sets a Boolean value that indicates whether the content download job is enabled.
FetchUrlCacheContent | Gets or sets a value from the FpcCacheContent enumerated type that specifies the conditions under which content will be cached.
FetchUrlFlagNoArrayRoute | Gets or sets a Boolean value that indicates whether the fpcFetchNoArrayRouting (FETCH_NO_ARRAY_ROUTING) flag is set in internal calls to the FetchUrl method.
FetchUrlFlagSync | Gets or sets a Boolean value that indicates whether the fpcFetchSynchronous (FETCH_SYNCHRONOUS) flag is set in internal calls to the FetchUrl method.
FetchUrlFlagTtlIfNone | Gets or sets a Boolean value that indicates whether the fpcFetchTtlIfNone (FETCH_TTL_IF_NONE) flag is set in internal calls to the FetchUrl method.
FetchUrlFlagTtlOverride | Gets or sets a Boolean value that indicates whether the fpcFetchTtlOverride (FETCH_TTL_OVERRIDE) flag is set in internal calls to the FetchUrl method.
MaxDepth | Gets or sets the upper limit of the depth to fetch.
MaxPages | Gets or sets the upper limit of the total cache object size in kilobytes.
Name | Gets or sets the name of the content download job.
NumberOfConcurrentConnections | Gets or sets the number of concurrent TCP connections that may be created for the content download job.
ScheduleDays | Gets a bitmask of the FpcDaysOfWeek enumerated type that specifies the days of the week on which the content download job will run.
ScheduledContentDownloadJobStatuses | Gets an FPCScheduledContentDownloadJobStatuses collection that contains the status of the scheduled content download job.
StartDateDay | Gets or sets the day part of the date to start the content download job.
StartDateMonth | Gets or sets the month part of the date to start the content download job.
StartDateYear | Gets or sets the year part of the date to start the content download job.
StayInDomain | Gets or sets a Boolean value that indicates whether to download content only from the domain of the root URL, or from other domains as well.
TaskPeriod | Gets a value from the FpcScheduledTaskRunningPeriod enumerated type that specifies whether the content download job is run only once, every day, or on specified days of the week.
TTL | Gets or sets the Time to Live (TTL), in minutes, of the pages to be downloaded.
URL | Gets or sets the URL to be downloaded.

Methods Inherited from FPCPersist

Name | Description
CancelWaitForChanges | Cancels the registration established by the WaitForChanges method (for use in C and C++ programming only).
CanImport | Returns a Boolean value that indicates whether the object's properties can be imported from the specified XML document.
Export | Recursively writes the stored values of all the properties of the object and its subobjects to the specified XML document.
ExportToFile | Recursively writes the stored values of all the properties of the object and its subobjects to the specified XML file.
GetServiceRestartMask | Retrieves a 32-bit bitmask of the FpcServices enumerated type that specifies which services need to be restarted for currently unsaved changes to take effect.
Import | Recursively copies the values of all the properties of the object and of its subobjects from the specified XML document to persistent storage.
ImportFromFile | Recursively copies the values of all the properties of the object and of its subobjects from the specified XML file to persistent storage.
LoadDocProperties | Provides the XML document's properties so that you can know what information can be imported from the document.
Refresh | Recursively reads the values of all the properties of the object and of its subobjects from persistent storage, overwriting any changes that have not been saved.
Save | Recursively writes the current values of all the properties of the object and its subobjects to persistent storage.
WaitForChanges | Registers to wait for an event indicating that the contents of the object have changed (for use in C and C++ programming only).

Properties Inherited from FPCPersist

Name | Description
PersistentName | Gets the persistent name of the object. The persistent name of an object is a name that is unique for the object at the respective level of the COM object hierarchy.
VendorParametersSets | Gets an FPCVendorParametersSets collection that can hold sets of custom data for extending the object.

Remarks

This object implements the IFPCScheduledContentDownloadConfig interface.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

COM Objects


IFPCScheduledContentDownloadConfig.AbortOnAllServers method [ISA Server 2004]

IFPCScheduledContentDownloadConfig::AbortOnAllServers[C++]

FPCScheduledContentDownloadConfig.AbortOnAllServers [Visual Basic]

[C++]

The AbortOnAllServers method stops the content download job.

HRESULT AbortOnAllServers();

Parameters

This method has no parameters.

Return Values

This method returns S_OK if the call is successful; otherwise, it returns an error code.
[Visual Basic]

The AbortOnAllServers method stops the content download job.

Sub AbortOnAllServers()

Parameters

This method has no parameters.

Return Values

This method has no return values. If the call is unsuccessful, an error is raised that can be intercepted by using an error handler.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCScheduledContentDownloadConfig


IFPCScheduledContentDownloadConfig.DailyFreqEndHour property [ISA Server 2004]

DailyFreqEndHour Property of IFPCScheduledContentDownloadConfig[C++]

FPCScheduledContentDownloadConfig.DailyFreqEndHour [Visual Basic]

[C++]

The DailyFreqEndHour property gets the hour part of the end time for repeated runs on a single day.

HRESULT get_DailyFreqEndHour(
  long* plHour
);

Parameters

plHour
Pointer to a variable that on return receives a 32-bit integer specifying the hour part of the end time for repeated runs on a single day.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only. It can be set by calling the SetDailyFrequency method. Its default value is 0, and its range of permissible values is from 0 to 23.

[Visual Basic]

The DailyFreqEndHour property gets the hour part of the end time for repeated runs on a single day.

Property DailyFreqEndHour As Long

Property Value

A 32-bit integer that specifies the hour part of the end time for repeated runs on a single day.

Remarks

This property is read-only. It can be set by calling the SetDailyFrequency method. Its default value is 0, and its range of permissible values is from 0 to 23.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCScheduledContentDownloadConfig


IFPCScheduledContentDownloadConfig.DailyFreqEndMinute property [ISA Server 2004]

DailyFreqEndMinute Property of IFPCScheduledContentDownloadConfig[C++]

FPCScheduledContentDownloadConfig.DailyFreqEndMinute [Visual Basic]

[C++]

The DailyFreqEndMinute property gets the minute part of the end time for repeated runs on a single day.

HRESULT get_DailyFreqEndMinute(
  long* plMinute
);

Parameters

plMinute
Pointer to a variable that on return receives a 32-bit integer specifying the minute part of the end time for repeated runs on a single day.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only. It can be set by calling the SetDailyFrequency method. Its default value is 0, and its range of permissible values is from 0 to 59.

[Visual Basic]

The DailyFreqEndMinute property gets the minute part of the end time for repeated runs on a single day.

Property DailyFreqEndMinute As Long

Property Value

A 32-bit integer that specifies the minute part of the end time for repeated runs on a single day.

Remarks

This property is read-only. It can be set by calling the SetDailyFrequency method. Its default value is 0, and its range of permissible values is from 0 to 59.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCScheduledContentDownloadConfig


IFPCScheduledContentDownloadConfig.DailyFreqStartHour property [ISA Server 2004]

DailyFreqStartHour Property of IFPCScheduledContentDownloadConfig[C++]

FPCScheduledContentDownloadConfig.DailyFreqStartHour [Visual Basic]

[C++]

The DailyFreqStartHour property gets the hour part of the start time for repeated runs on a single day.

HRESULT get_DailyFreqStartHour(
  long* plHour
);

Parameters

plHour
Pointer to a variable that on return receives a 32-bit integer specifying the hour part of the start time for repeated runs on a single day.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only. It can be set by calling the SetDailyFrequency method. Its default value is 0, and its range of permissible values is from 0 to 23.

[Visual Basic]

The DailyFreqStartHour property gets the hour part of the start time for repeated runs on a single day.

Property DailyFreqStartHour As Long

Property Value

A 32-bit integer that specifies the hour part of the start time for repeated runs on a single day.

Remarks

This property is read-only. It can be set by calling the SetDailyFrequency method. Its default value is 0, and its range of permissible values is from 0 to 23.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCScheduledContentDownloadConfig


DailyFreqStartMinute property [ISA Server 2004]

DailyFreqStartMinute Property of IFPCScheduledContentDownloadConfig[C++]

FPCScheduledContentDownloadConfig.DailyFreqStartMinute [Visual Basic]

[C++]

The DailyFreqStartMinute property gets the minute part of the start time for repeated runs on a single day.

HRESULT get_DailyFreqStartMinute(
  long* plMinute
);

Parameters

plMinute
Pointer to a variable that on return receives a 32-bit integer specifying the minute part of the start time for repeated runs on a single day.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only. Set this property using the SetDailyFrequency method. Its default value is 0, and its range of permissible values is from 0 to 59.

[Visual Basic]

The DailyFreqStartMinute property gets the minute part of the start time for repeated runs on a single day.

Property DailyFreqStartMinute As Long

Property Value

A 32-bit integer that specifies the minute part of the start time for repeated runs on a single day.

Remarks

This property is read-only. Set this property using the SetDailyFrequency method. Its default value is 0, and its range of permissible values is from 0 to 59.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCScheduledContentDownloadConfig


IFPCScheduledContentDownloadConfig.DailyFreqTimeUnits property [ISA Server 2004]

DailyFreqTimeUnits Property of IFPCScheduledContentDownloadConfig[C++]

FPCScheduledContentDownloadConfig.DailyFreqTimeUnits [Visual Basic]

[C++]

The DailyFreqTimeUnits property gets or sets a value from the FpcTimeScale enumerated type that specifies the time units of the repetition time for repeated runs on a single day.

HRESULT get_DailyFreqTimeUnits(
  FpcTimeScale* pTimeUnits
);

HRESULT put_DailyFreqTimeUnits(
  FpcTimeScale TimeUnits
);

Parameters

pTimeUnits
Pointer to a value from the FpcTimeScale enumerated type that is set on return to fpcTimeInMinutes if the repetition time for repeated runs on a single day is measured in minutes or to fpcTimeInHours if the repetition time is measured in hours.
TimeUnits
Value from the FpcTimeScale enumerated type that specifies the time units of the repetition time for repeated runs on a single day. Only the fpcTimeInMinutes and fpcTimeInHours values are allowed.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write. Its default value is fpcTimeInHours.

A repeated run takes place every time that the specified time elapses. For example, it can take place every three minutes or every 12 hours. For example, to set the repetition time to 12 hours, set the number of units (12) using the DailyFreqTimeValue property and the time units (hours) using this property.

[Visual Basic]

The DailyFreqTimeUnits property gets or sets a value from the FpcTimeScale enumerated type that specifies the time units of the repetition time for repeated runs on a single day.

Property DailyFreqTimeUnits As FpcTimeScale

Property Value

Value from the FpcTimeScale enumerated type that specifies the time units of the repetition time for repeated runs on a single day. Only the fpcTimeInMinutes and fpcTimeInHours values are allowed.

Remarks

This property is read/write. Its default value is fpcTimeInHours.

A repeated run takes place every time that the specified time elapses. For example, it can take place every three minutes or every 12 hours. For example, to set the repetition time to 12 hours, set the number of units (12) using the DailyFreqTimeValue property and the time units (hours) using this property.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCScheduledContentDownloadConfig


IFPCScheduledContentDownloadConfig.DailyFreqTimeValue property [ISA Server 2004]

DailyFreqTimeValue Property of IFPCScheduledContentDownloadConfig[C++]

FPCScheduledContentDownloadConfig.DailyFreqTimeValue [Visual Basic]

[C++]

The DailyFreqTimeValue property gets or sets the repetition time for repeated runs on a single day in the units specified by the DailyFreqTimeUnits property.

HRESULT get_DailyFreqTimeValue(
  long* plTimeValue
);

HRESULT put_DailyFreqTimeValue(
  long lTimeValue
);

Parameters

plTimeValue
Pointer to a variable that on return receives a 32-bit integer specifying the repetition time for repeated runs on a single day in the units specified by the DailyFreqTimeUnits property.
lTimeValue
A 32-bit integer that specifies the repetition time for repeated runs on a single day in the units specified by the DailyFreqTimeUnits property.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write. Its default value is 1, and its range of permissible values is from 1 to 65,535.

A periodical run takes place every time that the specified repetition time elapses. For example, it can take place every three minutes or every 12 hours. For example, to set the repetition time to 12 hours, set the number of units (12) using this property and the time units (hours) using the DailyFreqTimeUnits property.

[Visual Basic]

The DailyFreqTimeValue property gets or sets the repetition time for repeated runs on a single day in the units specified by the DailyFreqTimeUnits property.

Property DailyFreqTimeValue As Long

Property Value

A 32-bit integer that specifies the repetition time for repeated runs on a single day in the units specified by the DailyFreqTimeUnits property.

Remarks

This property is read/write. Its default value is 1, and its range of permissible values is from 1 to 65,535.

A periodical run takes place every time that the specified repetition time elapses. For example, it can take place every three minutes or every 12 hours. For example, to set the repetition time to 12 hours, set the number of units (12) using this property and the time units (hours) using the DailyFreqTimeUnits property.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCScheduledContentDownloadConfig


IFPCScheduledContentDownloadConfig.DailyFrequency property [ISA Server 2004]

DailyFrequency Property of IFPCScheduledContentDownloadConfig[C++]

FPCScheduledContentDownloadConfig.DailyFrequency [Visual Basic]

[C++]

The DailyFrequency property gets or sets a value from the FpcDailyFrequency enumerated type that specifies whether the download job is to run once on a single day or more than once on a single day.

HRESULT get_DailyFrequency(
  FpcDailyFrequency* pDailyFrequency
);

HRESULT put_DailyFrequency(
  FpcDailyFrequency DailyFrequency
);

Parameters

pDailyFrequency
Pointer to a value from the FpcDailyFrequency enumerated type that is set on return to fpcOnce if the download job is to run once on a single day or to fpcRecurring if the download job is to run more than once on a single day.
DailyFrequency
Value from the FpcDailyFrequency enumerated type that specifies whether the download job is to run once on a single day or more than once on a single day.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write. Its default value is fpcOnce.

[Visual Basic]

The DailyFrequency property gets or sets a value from the FpcDailyFrequency enumerated type that specifies whether the download job is to run once on a single day or more than once on a single day.

Property DailyFrequency As FpcDailyFrequency

Property Value

Value from the FpcDailyFrequency enumerated type that specifies whether the download job is to run once on a single day or more than once on a single day.

Remarks

This property is read/write. Its default value is fpcOnce.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCScheduledContentDownloadConfig


IFPCScheduledContentDownloadConfig.DailyHour property [ISA Server 2004]

DailyHour Property of IFPCScheduledContentDownloadConfig[C++]

FPCScheduledContentDownloadConfig.DailyHour [Visual Basic]

[C++]

The DailyHour property gets or sets the hour part of the time for a one-time run on a single day.

HRESULT get_DailyHour(
  long* plHour
);

HRESULT put_DailyHour(
  long lHour
);

Parameters

plHour
Pointer to a variable that on return receives a 32-bit integer specifying the hour part of the time for a one-time run on a single day.
lHour
A 32-bit integer that specifies the hour part of the time for a one-time run on a single day.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write. Its default value is 0, and its range of permissible values is from 0 to 23.

[Visual Basic]

The DailyHour property gets or sets the hour part of the time for a one-time run on a single day.

Property DailyHour As Long

Property Value

A 32-bit integer that specifies the hour part of the time for a one-time run on a single day.

Remarks

This property is read/write. Its default value is 0, and its range of permissible values is from 0 to 23.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCScheduledContentDownloadConfig


IFPCScheduledContentDownloadConfig.DailyMinute property [ISA Server 2004]

DailyMinute Property of IFPCScheduledContentDownloadConfig[C++]

FPCScheduledContentDownloadConfig.DailyMinute [Visual Basic]

[C++]

The DailyMinute property gets or sets the minute part of the time for a one-time run on a single day.

HRESULT get_DailyMinute(
  long* plMinute
);

HRESULT put_DailyMinute(
  long lMinute
);

Parameters

plMinute
Pointer to a variable that on return receives a 32-bit integer specifying the minute part of the time for a one-time run on a single day.
lMinute
A 32-bit integer that specifies the minute part of the time for a one-time run on a single day.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write. Its default value is 0, and its range of permissible values is from 0 to 59.

[Visual Basic]

The DailyMinute property gets or sets the minute part of the time for a one-time run on a single day.

Property DailyMinute As Long

Property Value

A 32-bit integer that specifies the minute part of the time for a one-time run on a single day.

Remarks

This property is read/write. Its default value is 0, and its range of permissible values is from 0 to 59.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCScheduledContentDownloadConfig


IFPCScheduledContentDownloadConfig.Description property [ISA Server 2004]

Description Property of IFPCScheduledContentDownloadConfig[C++]

FPCScheduledContentDownloadConfig.Description [Visual Basic]

[C++]

The Description property gets or sets the description of the content download job.

HRESULT get_Description(
  BSTR* pbstrDescription
);

HRESULT put_Description(
  BSTR bstrDescription
);

Parameters

pbstrDescription
Pointer to a BSTR that is set on return to a string value specifying the description of the content download job.
bstrDescription
BSTR that specifies the description of the content download job.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write.

[Visual Basic]

The Description property gets or sets the description of the content download job.

Property Description As String

Property Value

String that specifies the description of the content download job.

Remarks

This property is read/write.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCScheduledContentDownloadConfig


IFPCScheduledContentDownloadConfig.DownloadOnceHour property [ISA Server 2004]

DownloadOnceHour Property of IFPCScheduledContentDownloadConfig[C++]

FPCScheduledContentDownloadConfig.DownloadOnceHour [Visual Basic]

[C++]

The DownloadOnceHour property gets or sets the hour part of the start time for a content download job that runs only once.

HRESULT get_DownloadOnceHour(
  long* plHour
);

HRESULT put_DownloadOnceHour(
  long lHour
);

Parameters

plHour
Pointer to a variable that on return receives a 32-bit integer specifying the hour part of the start time for a content download job that runs only once.
lHour
A 32-bit integer that specifies the hour part of the start time for a content download job that runs only once.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write. Its default value is 0, and its range of permissible values is from 0 to 23.

[Visual Basic]

The DownloadOnceHour property gets or sets the hour part of the start time for a content download job that runs only once.

Property DownloadOnceHour As Long

Property Value

A 32-bit integer that specifies the hour part of the start time for a content download job that runs only once.

Remarks

This property is read/write. Its default value is 0, and its range of permissible values is from 0 to 23.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCScheduledContentDownloadConfig


IFPCScheduledContentDownloadConfig.DownloadOnceMinute property [ISA Server 2004]

DownloadOnceMinute Property of IFPCScheduledContentDownloadConfig[C++]

FPCScheduledContentDownloadConfig.DownloadOnceMinute [Visual Basic]

[C++]

The DownloadOnceMinute property gets or sets the minute part of the start time for a content download job that runs only once.

HRESULT get_DownloadOnceMinute(
  long* plMinute
);

HRESULT put_DownloadOnceMinute(
  long lMinute
);

Parameters

plMinute
Pointer to a variable that on return receives a 32-bit integer specifying the minute part of the start time for a content download job that runs only once.
lMinute
A 32-bit integer that specifies the minute part of the start time for a content download job that runs only once.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write. Its default value is 0, and its range of permissible values is from 0 to 59.

[Visual Basic]

The DownloadOnceMinute property gets or sets the minute part of the start time for a content download job that runs only once.

Property DownloadOnceMinute As Long

Property Value

A 32-bit integer that specifies the minute part of the start time for a content download job that runs only once.

Remarks

This property is read/write. Its default value is 0, and its range of permissible values is from 0 to 59.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCScheduledContentDownloadConfig


IFPCScheduledContentDownloadConfig.Enabled property [ISA Server 2004]

Enabled Property of IFPCScheduledContentDownloadConfig[C++]

FPCScheduledContentDownloadConfig.Enabled [Visual Basic]

[C++]

The Enabled property gets or sets a Boolean value that indicates whether the content download job is enabled.

HRESULT get_Enabled(
  VARIANT_BOOL* pfEnabled
);

HRESULT put_Enabled(
  VARIANT_BOOL fEnabled
);

Parameters

pfEnabled
Pointer to a Boolean variable that is set on return to VARIANT_TRUE if the content download job is enabled, or to VARIANT_FALSE if the content download job is disabled.
fEnabled
Boolean value that indicates whether the content download job is enabled.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write. Its default value is VARIANT_TRUE.

[Visual Basic]

The Enabled property gets or sets a Boolean value that indicates whether the content download job is enabled.

Property Enabled As Boolean

Property Value

Boolean value that indicates whether the content download job is enabled.

Remarks

This property is read/write. Its default value is True.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCScheduledContentDownloadConfig


FetchUrlCacheContent property [ISA Server 2004]

FetchUrlCacheContent Property of IFPCScheduledContentDownloadConfig[C++]

FPCScheduledContentDownloadConfig.FetchUrlCacheContent [Visual Basic]

[C++]

The FetchUrlCacheContent property gets or sets a value from the FpcCacheContent enumerated type that specifies the conditions under which content will be cached.

HRESULT get_FetchUrlCacheContent(
  FpcCacheContent* pCacheContent
);

HRESULT put_FetchUrlCacheContent(
  FpcCacheContent CacheContent
);

Parameters

pCacheContent
Pointer to a value from the FpcCacheContent enumerated type that is set on return to the value specifying the conditions under which content will be cached.
CacheContent
Value from the FpcCacheContent enumerated type that specifies the conditions under which content will be cached.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write. Its default value is fpcCacheAlways.

The only values from the FpcCacheContent enumerated type that are allowed for this property are fpcCacheAlways, fpcCacheCacheableAndDynamic, and fpcCacheCacheable. Setting this property to fpcNeverCache will result in a run-time error.

[Visual Basic]

The FetchUrlCacheContent property gets or sets a value from the FpcCacheContent enumerated type that specifies the conditions under which content will be cached.

Property FetchUrlCacheContent As FpcCacheContent

Property Value

Value from the FpcCacheContent enumerated type that specifies the conditions under which content will be cached.

Remarks

This property is read/write. Its default value is fpcCacheAlways.

The only values from the FpcCacheContent enumerated type that are allowed for this property are fpcCacheAlways, fpcCacheCacheableAndDynamic, and fpcCacheCacheable. Setting this property to fpcNeverCache will result in a run-time error.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCScheduledContentDownloadConfig


FetchUrlFlagNoArrayRoute property [ISA Server 2004]

FetchUrlFlagNoArrayRoute Property of IFPCScheduledContentDownloadConfig[C++]

FPCScheduledContentDownloadConfig.FetchUrlFlagNoArrayRoute [Visual Basic]

[C++]

The FetchUrlFlagNoArrayRoute property gets or sets a Boolean value that indicates whether the fpcFetchNoArrayRouting (FETCH_NO_ARRAY_ROUTING) flag is set in internal calls to the FetchUrl method.

HRESULT get_FetchUrlFlagNoArrayRoute(
  VARIANT_BOOL* pfFetchUrlFlagNoArrayRoute
);

HRESULT put_FetchUrlFlagNoArrayRoute(
  VARIANT_BOOL fFetchUrlFlagNoArrayRoute
);

Parameters

pfFetchUrlFlagNoArrayRoute
Pointer to a Boolean variable that is set on return to VARIANT_TRUE if the fpcFetchNoArrayRouting (FETCH_NO_ARRAY_ROUTING) flag is set in internal calls to the FetchUrl method, or to VARIANT_FALSE if the flag is not set.
fFetchUrlFlagNoArrayRoute
Boolean value that indicates whether the fpcFetchNoArrayRouting (FETCH_NO_ARRAY_ROUTING) flag is set in internal calls to the FetchUrl method.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write. Its default value is VARIANT_FALSE.

If the ISA Server computer is a member of a multiple-server array, setting the fpcFetchNoArrayRouting (FETCH_NO_ARRAY_ROUTING) flag in a call to the FetchUrl method indicates that the object fetched should be cached locally even if the normal array cache-sharing mechanism, the Cache Array Routing Protocol (CARP), indicates that the object should be cached on a different array member. If this flag is not set, the object is automatically cached on the array member that the CARP algorithm designates. This flag is ignored if the ISA Server computer is not a member of a multiple-server array. This flag therefore applies only to an array in ISA Server Enterprise Edition. It does not apply to a stand-alone server or to ISA Server Standard Edition.

[Visual Basic]

The FetchUrlFlagNoArrayRoute property gets or sets a Boolean value that indicates whether the fpcFetchNoArrayRouting (FETCH_NO_ARRAY_ROUTING) flag is set in internal calls to the FetchUrl method.

Property FetchUrlFlagNoArrayRoute As Boolean

Property Value

Boolean value that indicates whether the fpcFetchNoArrayRouting (FETCH_NO_ARRAY_ROUTING) flag is set in internal calls to the FetchUrl method.

Remarks

This property is read/write. Its default value is False.

If the ISA Server computer is a member of a multiple-server array, setting the fpcFetchNoArrayRouting (FETCH_NO_ARRAY_ROUTING) flag in a call to the FetchUrl method indicates that the object fetched should be cached locally even if the normal array cache-sharing mechanism, the Cache Array Routing Protocol (CARP), indicates that the object should be cached on a different array member. If this flag is not set, the object is automatically cached on the array member that the CARP algorithm designates. This flag is ignored if the ISA Server computer is not a member of a multiple-server array. This flag therefore applies only to an array in ISA Server Enterprise Edition. It does not apply to a stand-alone server or to ISA Server Standard Edition.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCScheduledContentDownloadConfig


IFPCScheduledContentDownloadConfig.FetchUrlFlagSync property [ISA Server 2004]

FetchUrlFlagSync Property of IFPCScheduledContentDownloadConfig[C++]

FPCScheduledContentDownloadConfig.FetchUrlFlagSync [Visual Basic]

[C++]

The FetchUrlFlagSync property gets or sets a Boolean value that indicates whether the fpcFetchSynchronous (FETCH_SYNCHRONOUS) flag is set in internal calls to the FetchUrl method.

HRESULT get_FetchUrlFlagSync(
  VARIANT_BOOL* pfFetchUrlFlagSync
);

HRESULT put_FetchUrlFlagSync(
  VARIANT_BOOL fFetchUrlFlagSync
);

Parameters

pfFetchUrlFlagSync
Pointer to a Boolean variable that is set on return to VARIANT_TRUE if the fpcFetchSynchronous (FETCH_SYNCHRONOUS) flag is set in internal calls to the FetchUrl method, or to VARIANT_FALSE if the flag is not set.
fFetchUrlFlagSync
Boolean value that indicates whether the fpcFetchSynchronous (FETCH_SYNCHRONOUS) flag is set in internal calls to the FetchUrl method.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write. Its default value is VARIANT_FALSE.

If the fpcFetchSynchronous (FETCH_SYNCHRONOUS) flag is set, the FetchUrl method does not return to the caller until the fetch has completed and the object is stored in the cache, or until an error occurs in the processing of the request and the operation ends. If this flag is not set, the method returns immediately and the fetch operation completes asynchronously.

[Visual Basic]

The FetchUrlFlagSync property gets or sets a Boolean value that indicates whether the fpcFetchSynchronous (FETCH_SYNCHRONOUS) flag is set in internal calls to the FetchUrl method.

Property FetchUrlFlagSync As Boolean

Property Value

Boolean value that indicates whether the fpcFetchSynchronous (FETCH_SYNCHRONOUS) flag is set in internal calls to the FetchUrl method.

Remarks

This property is read/write. Its default value is False.

If the fpcFetchSynchronous (FETCH_SYNCHRONOUS) flag is set, the FetchUrl method does not return to the caller until the fetch has completed and the object is stored in the cache, or until an error occurs in the processing of the request and the operation ends. If this flag is not set, the method returns immediately and the fetch operation completes asynchronously.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCScheduledContentDownloadConfig


FetchUrlFlagTtlIfNone property [ISA Server 2004]

FetchUrlFlagTtlIfNone Property of IFPCScheduledContentDownloadConfig[C++]

FPCScheduledContentDownloadConfig.FetchUrlFlagTtlIfNone [Visual Basic]

[C++]

The FetchUrlFlagTtlIfNone property gets or sets a Boolean value that indicates whether the fpcFetchTtlIfNone (FETCH_TTL_IF_NONE) flag is set in internal calls to the FetchUrl method.

HRESULT get_FetchUrlFlagTtlIfNone(
  VARIANT_BOOL* pfFetchUrlFlagTtlIfNone
);

HRESULT put_FetchUrlFlagTtlIfNone(
  VARIANT_BOOL fFetchUrlFlagTtlIfNone
);

Parameters

pfFetchUrlFlagTtlIfNone
Pointer to a Boolean variable that is set on return to VARIANT_TRUE if the fpcFetchTtlIfNone (FETCH_TTL_IF_NONE) flag is set in internal calls to the FetchUrl method, or to VARIANT_FALSE if the flag is not set.
fFetchUrlFlagTtlIfNone
Boolean value that indicates whether the fpcFetchTtlIfNone (FETCH_TTL_IF_NONE) flag is set in internal calls to the FetchUrl method.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write. Its default value is VARIANT_FALSE.

The fpcFetchTtlIfNone (FETCH_TTL_IF_NONE) flag is used to set the TTL for the object unless the publishing Web server has supplied an "Expires" or "Cache-Control: max-age" HTTP header.

[Visual Basic]

The FetchUrlFlagTtlIfNone property gets or sets a Boolean value that indicates whether the fpcFetchTtlIfNone (FETCH_TTL_IF_NONE) flag is set in internal calls to the FetchUrl method.

Property FetchUrlFlagTtlIfNone As Boolean

Property Value

Boolean value that indicates whether the fpcFetchTtlIfNone (FETCH_TTL_IF_NONE) flag is set in internal calls to the FetchUrl method.

Remarks

This property is read/write. Its default value is False.

The fpcFetchTtlIfNone (FETCH_TTL_IF_NONE) flag is used to set the TTL for the object unless the publishing Web server has supplied an "Expires" or "Cache-Control: max-age" HTTP header.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCScheduledContentDownloadConfig


FetchUrlFlagTtlOverride property [ISA Server 2004]

FetchUrlFlagTtlOverride Property of IFPCScheduledContentDownloadConfig[C++]

FPCScheduledContentDownloadConfig.FetchUrlFlagTtlOverride [Visual Basic]

[C++]

The FetchUrlFlagTtlOverride property gets or sets a Boolean value that indicates whether the fpcFetchTtlOverride (FETCH_TTL_OVERRIDE) flag is set in internal calls to the FetchUrl method.

HRESULT get_FetchUrlFlagTtlOverride(
  VARIANT_BOOL* pfFetchUrlFlagTtlOverride
);

HRESULT put_FetchUrlFlagTtlOverride(
  VARIANT_BOOL fFetchUrlFlagTtlOverride
);

Parameters

pfFetchUrlFlagTtlOverride
Pointer to a Boolean variable that is set on return to VARIANT_TRUE if the fpcFetchTtlOverride (FETCH_TTL_OVERRIDE) flag is set in internal calls to the FetchUrl method, or to VARIANT_FALSE if the flag is not set.
fFetchUrlFlagTtlOverride
Boolean value that indicates whether the fpcFetchTtlOverride (FETCH_TTL_OVERRIDE) flag is set in internal calls to the FetchUrl method.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write. Its default value is VARIANT_FALSE.

If the fpcFetchTtlOverride (FETCH_TTL_OVERRIDE) flag is set, the Time to Live (TTL) for the object is set to the value specified in the TTL property regardless of any "Expires" or "Cache-Control: max-age" HTTP header that the publishing Web server may have included with the object.

[Visual Basic]

The FetchUrlFlagTtlOverride property gets or sets a Boolean value that indicates whether the fpcFetchTtlOverride (FETCH_TTL_OVERRIDE) flag is set in internal calls to the FetchUrl method.

Property FetchUrlFlagTtlOverride As Boolean

Property Value

Boolean value that indicates whether the fpcFetchTtlOverride (FETCH_TTL_OVERRIDE) flag is set in internal calls to the FetchUrl method.

Remarks

This property is read/write. Its default value is False.

If the fpcFetchTtlOverride (FETCH_TTL_OVERRIDE) flag is set, the Time to Live (TTL) for the object is set to the value specified in the TTL property regardless of any "Expires" or "Cache-Control: max-age" HTTP header that the publishing Web server may have included with the object.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCScheduledContentDownloadConfig


IFPCScheduledContentDownloadConfig.MaxDepth property [ISA Server 2004]

MaxDepth Property of IFPCScheduledContentDownloadConfig[C++]

FPCScheduledContentDownloadConfig.MaxDepth [Visual Basic]

[C++]

The MaxDepth property gets or sets the upper limit of the depth to fetch. Depth refers to the number of links that will be followed when downloading content.

HRESULT get_MaxDepth(
  long* plMaxDepth
);

HRESULT put_MaxDepth(
  long lMaxDepth
);

Parameters

plMaxDepth
Pointer to a variable that on return receives a 32-bit integer specifying the upper limit of the depth to fetch.
lMaxDepth
A 32-bit integer that specifies the upper limit of the depth to fetch.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write. Its default value is 1.

[Visual Basic]

The MaxDepth property gets or sets the upper limit of the depth to fetch. Depth refers to the number of links that will be followed when downloading content.

Property MaxDepth As Long

Property Value

A 32-bit integer that specifies the upper limit of the depth to fetch.

Remarks

This property is read/write. Its default value is 1.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCScheduledContentDownloadConfig


IFPCScheduledContentDownloadConfig.MaxPages property [ISA Server 2004]

MaxPages Property of IFPCScheduledContentDownloadConfig[C++]

FPCScheduledContentDownloadConfig.MaxPages [Visual Basic]

[C++]

The MaxPages property gets or sets the upper limit of the total cache object size in kilobytes.

HRESULT get_MaxPages(
  long* plMaxPages
);

HRESULT put_MaxPages(
  long lMaxPages
);

Parameters

plMaxPages
Pointer to a variable that on return receives a 32-bit integer specifying the upper limit of the total cache object size in kilobytes.
lMaxPages
A 32-bit integer that specifies the upper limit of the total cache object size in kilobytes.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write. Its default value is 100.

This property must be set to a positive integer. The Microsoft ISA Server Job Scheduler service will not allow an infinite number of pages to be retrieved.

[Visual Basic]

The MaxPages property gets or sets the upper limit of the total cache object size in kilobytes.

Property MaxPages As Long

Property Value

A 32-bit integer that specifies the upper limit of the total cache object size in kilobytes.

Remarks

This property is read/write. Its default value is 100.

This property must be set to a positive integer. The Microsoft ISA Server Job Scheduler service will not allow an infinite number of pages to be retrieved.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCScheduledContentDownloadConfig


IFPCScheduledContentDownloadConfig.Name(BSTR,BSTR) property [ISA Server 2004]

Name Property of IFPCScheduledContentDownloadConfig[C++]

FPCScheduledContentDownloadConfig.Name [Visual Basic]

[C++]

The Name property gets or sets the name of the content download job.

HRESULT get_Name(
  BSTR* pbstrName
);

HRESULT put_Name(
  BSTR bstrName
);

Parameters

pbstrName
Pointer to a BSTR that is set on return to a string value specifying the name of the content download job.
bstrName
BSTR that specifies the name of the content download job.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write.

[Visual Basic]

The Name property gets or sets the name of the content download job.

Property Name As String

Property Value

String that specifies the name of the content download job.

Remarks

This property is read/write.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCScheduledContentDownloadConfig


NumberOfConcurrentConnections property [ISA Server 2004]

NumberOfConcurrentConnections Property of IFPCScheduledContentDownloadConfig[C++]

FPCScheduledContentDownloadConfig.NumberOfConcurrentConnections [Visual Basic]

[C++]

The NumberOfConcurrentConnections property gets or sets the number of concurrent TCP connections that may be created for the content download job.

HRESULT get_NumberOfConcurrentConnections(
  long* plNumber
);

HRESULT put_NumberOfConcurrentConnections(
  long lNumber
);

Parameters

plNumber
Pointer to a variable that on return receives a 32-bit integer specifying the number of concurrent TCP connections that may be created for the content download job.
lNumber
A 32-bit integer that specifies the number of concurrent TCP connections that may be created for the content download job.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write. Its default value is 4, and its range of permissible values is from 1 to 64.

[Visual Basic]

The NumberOfConcurrentConnections property gets or sets the number of concurrent TCP connections that may be created for the content download job.

Property NumberOfConcurrentConnections

Property Value

A 32-bit integer that specifies the number of concurrent connections allowed for the content download job.

Remarks

This property is read/write. Its default value is 4, and its range of permissible values is from 1 to 64.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCScheduledContentDownloadConfig


IFPCScheduledContentDownloadConfig.Run method [ISA Server 2004]

IFPCScheduledContentDownloadConfig::Run[C++]

FPCScheduledContentDownloadConfig.Run [Visual Basic]

[C++]

The Run method starts the content download job.

HRESULT Run();

Parameters

This method has no parameters.

Return Values

This method returns S_OK if the call is successful; otherwise, it returns an error code.
[Visual Basic]

The Run method starts the content download job.

Sub Run()

Parameters

This method has no parameters.

Return Values

This method has no return values. If the call is unsuccessful, an error is raised that can be intercepted by using an error handler.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCScheduledContentDownloadConfig


IFPCScheduledContentDownloadConfig.ScheduleDays property [ISA Server 2004]

ScheduleDays Property of IFPCScheduledContentDownloadConfig[C++]

FPCScheduledContentDownloadConfig.ScheduleDays [Visual Basic]

[C++]

The ScheduleDays property gets a bitmask of the FpcDaysOfWeek enumerated type that specifies the days of the week on which the content download job will run.

HRESULT get_ScheduleDays();

Parameters

pDays
Pointer to a value from the FpcDaysOfWeek enumerated type that is set on return to the bitmask specifying the days of the week on which the content download job will run.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only. It is set by calling the SetTaskPeriod method. Its default value is fpcNone.

Each of the first seven bits in the bitmask corresponds to a day of the week. Bit 0 corresponds to Sunday, bit 1 corresponds to Monday, and so on.

Example Code

The following code sets the ScheduleDays property to Sunday, Tuesday, and Thursday.

Dim jobConfig As FPCScheduledContentDownloadConfig
...
jobConfig.ScheduleDays = 0x15

The hexadecimal value 0x15 (which corresponds to the decimal value 21) is equal to the binary value 10101. The right bit represents Sunday, the next bit represents Monday, and so forth. Thus, the bits corresponding to Sunday, Tuesday, and Thursday are set, while the bits corresponding to Monday and Wednesday are not set.

[Visual Basic]

The ScheduleDays property gets a bitmask of the FpcDaysOfWeek enumerated type that specifies the days of the week on which the content download job will run.

Property ScheduleDays As FpcDaysOfWeek

Property Value

Bitmask of the FpcDaysOfWeek enumerated type that specifies the days of the week on which on which the content download job will run.

Remarks

This property is read-only. It is set by calling the SetTaskPeriod method. Its default value is fpcNone.

Each of the first seven bits in the bitmask corresponds to a day of the week. Bit 0 corresponds to Sunday, bit 1 corresponds to Monday, and so on.

Example Code

The following code sets the ScheduleDays property to Sunday, Tuesday, and Thursday.

Dim jobConfig As FPCScheduledContentDownloadConfig
...
jobConfig.ScheduleDays = 0x15

The hexadecimal value 0x15 (which corresponds to the decimal value 21) is equal to the binary value 10101. The right bit represents Sunday, the next bit represents Monday, and so forth. Thus, the bits corresponding to Sunday, Tuesday, and Thursday are set, while the bits corresponding to Monday and Wednesday are not set.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCScheduledContentDownloadConfig


ScheduledContentDownloadJobStatuses property [ISA Server 2004]

ScheduledContentDownloadJobStatuses Property of IFPCScheduledContentDownloadConfig[C++]

FPCScheduledContentDownloadConfig.ScheduledContentDownloadJobStatuses [Visual Basic]

[C++]

The ScheduledContentDownloadJobStatuses property gets an FPCScheduledContentDownloadJobStatuses collection that contains the status of the scheduled content download job.

HRESULT get_ScheduledContentDownloadJobStatuses(
  IFPCScheduledContentDownloadJobStatuses** ppScheduledContentDownloadJobStatuses
);

Parameters

ppScheduledContentDownloadJobStatuses
Address of an interface pointer that on return points to an IFPCScheduledContentDownloadJobStatuses interface representing the status of the scheduled content download jobs.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The ScheduledContentDownloadJobStatuses property gets an FPCScheduledContentDownloadJobStatuses collection that contains the status of the scheduled content download job.

Property ScheduledContentDownloadJobStatuses As FPCScheduledContentDownloadJobStatuses

Property Value

Reference to an FPCScheduledContentDownloadJobStatuses collection that contains the status of the scheduled content download jobs.

Remarks

This property is read-only.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCScheduledContentDownloadConfig


IFPCScheduledContentDownloadConfig.SetDailyFrequency method [ISA Server 2004]

IFPCScheduledContentDownloadConfig::SetDailyFrequency[C++]

FPCScheduledContentDownloadConfig.SetDailyFrequency [Visual Basic]

[C++]

The SetDailyFrequency method sets the hour and minute parts of the start and end times for repeated runs on a single day.

HRESULT SetDailyFrequency(
  long StartTimeHour,
  long StartTimeMinute,
  long EndTimeHour,
  long EndTimeMinute
);

Parameters

StartTimeHour
[in] The hour part of the start time for repeated runs on a single day.
StartTimeMinute
[in] The minute part of the start time for repeated runs on a single day.
EndTimeHour
[in] The hour part of the end time for repeated runs on a single day.
EndTimeMinute
[in] The minute part of the end time for repeated runs on a single day.

Return Values

This method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This method sets the DailyFreqStartHour, DailyFreqStartMinute, DailyFreqEndHour, and DailyFreqEndMinute properties.

[Visual Basic]

The SetDailyFrequency method sets the hour and minute parts of the start and end times for repeated runs on a single day.

Sub SetDailyFrequency( _
  ByVal StartTimeHour As Long, _
  ByVal StartTimeMinute As Long, _
  ByVal EndTimeHour As Long, _
  ByVal EndTimeMinute As Long _
)

Parameters

StartTimeHour
[in] The hour part of the start time for repeated runs on a single day.
StartTimeMinute
[in] The minute part of the start time for repeated runs on a single day.
EndTimeHour
[in] The hour part of the end time for repeated runs on a single day.
EndTimeMinute
[in] The minute part of the end time for repeated runs on a single day.

Return Values

This method has no return values. If the call is unsuccessful, an error is raised that can be intercepted by using an error handler.

Remarks

This method sets the DailyFreqStartHour, DailyFreqStartMinute, DailyFreqEndHour, and DailyFreqEndMinute properties.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCScheduledContentDownloadConfig


IFPCScheduledContentDownloadConfig.SetTaskPeriod method [ISA Server 2004]

IFPCScheduledContentDownloadConfig::SetTaskPeriod[C++]

FPCScheduledContentDownloadConfig.SetTaskPeriod [Visual Basic]

[C++]

The SetTaskPeriod method sets the values of the TaskPeriod property (the type of schedule) and the ScheduleDays property (the days of the week on which the content download job will run) of the content download job.

HRESULT SetTaskPeriod(
  FpcScheduledTaskRunningPeriod Period,
  FpcDaysOfWeek Days
);

Parameters

Period
[in] Value from the FpcScheduledTaskRunningPeriod enumerated type that specifies whether the content download job will run only once, every day, or on specified days of the week.
Days
[in, optional] Bitmask of the FpcDaysOfWeek enumerated type that specifies the days of the week on which the content download job will run. This parameter is used if the Period parameter is set to the fpcRunOnSpecifiedDaysOfWeek value of the FpcScheduledTaskRunningPeriod enumerated type. The default value is fpcNone.

Return Values

This method returns S_OK if the call is successful; otherwise, it returns an error code.
[Visual Basic]

The SetTaskPeriod method sets the values of the TaskPeriod property (the type of schedule) and the ScheduleDays property (the days of the week on which the content download job will run) of the content download job.

Sub SetTaskPeriod( _
  ByVal Period As FpcScheduledTaskRunningPeriod, _
  [ ByVal Days As FpcDaysOfWeek ] _
)

Parameters

Period
[in] Value from the FpcScheduledTaskRunningPeriod enumerated type that specifies whether the content download job will run only once, every day, or on specified days of the week.
Days
[in, optional] Bitmask of the FpcDaysOfWeek enumerated type that specifies the days of the week on which the content download job will run. This parameter is used if the Period parameter is set to the fpcRunOnSpecifiedDaysOfWeek value of the FpcScheduledTaskRunningPeriod enumerated type. The default value is fpcNone.

Return Values

This method has no return values. If the call is unsuccessful, an error is raised that can be intercepted by using an error handler.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCScheduledContentDownloadConfig


IFPCScheduledContentDownloadConfig.StartDateDay property [ISA Server 2004]

StartDateDay Property of IFPCScheduledContentDownloadConfig[C++]

FPCScheduledContentDownloadConfig.StartDateDay [Visual Basic]

[C++]

The StartDateDay property gets or sets the day part of the date to start the content download job.

HRESULT get_StartDateDay(
  long* plStartDateDay
);

HRESULT put_StartDateDay(
  long lStartDateDay
);

Parameters

plStartDateDay
Pointer to a variable that on return receives a 32-bit integer specifying the day part of the date to start the content download job.
lStartDateDay
A 32-bit integer that specifies the day part of the date to start the content download job.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write. Its default value corresponds to the day of the month when the content download job was created, and its range of permissible values is from 1 to 31.

The date to start the scheduled content download is specified in the form dd.mm.yyyy, where dd equals the two-digit day, mm equals the two-digit month, and yyyy equals the four-digit year. The day is set by this property, the month is set by the StartDateMonth property, and the year is set by the StartDateYear property.

[Visual Basic]

The StartDateDay property gets or sets the day part of the date to start the content download job.

Property StartDateDay As Long

Property Value

A 32-bit integer that specifies the day part of the date to start the content download job.

Remarks

This property is read/write. Its default value corresponds to the day of the month when the content download job was created, and its range of permissible values is from 1 to 31.

The date to start the scheduled content download is specified in the form dd.mm.yyyy, where dd equals the two-digit day, mm equals the two-digit month, and yyyy equals the four-digit year. The day is set by this property, the month is set by the StartDateMonth property, and the year is set by the StartDateYear property.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCScheduledContentDownloadConfig


IFPCScheduledContentDownloadConfig.StartDateMonth property [ISA Server 2004]

StartDateMonth Property of IFPCScheduledContentDownloadConfig[C++]

FPCScheduledContentDownloadConfig.StartDateMonth [Visual Basic]

[C++]

The StartDateMonth property gets or sets the month part of the date to start the content download job.

HRESULT get_StartDateMonth(
  long* plStartDateMonth
);

HRESULT put_StartDateMonth(
  long lStartDateMonth
);

Parameters

plStartDateMonth
Pointer to a variable that on return receives a 32-bit integer specifying the month part of the date to start the content download job.
lStartDateMonth
A 32-bit integer that specifies the month part of the date to start the content download job.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write. Its default value corresponds to the month when the content download job was created, and its range of permissible values is from 1 to 12.

The date to start the scheduled content download is specified in the form dd.mm.yyyy, where dd equals the two-digit day, mm equals the two-digit month, and yyyy equals the four-digit year. The day is set by the StartDateDay property, the month is set by this property, and the year is set by the StartDateYear property.

[Visual Basic]

The StartDateMonth property gets or sets the month part of the date to start the content download job.

Property StartDateMonth As Long

Property Value

A 32-bit integer that specifies the month part of the date to start the content download job.

Remarks

This property is read/write. Its default value corresponds to the month when the content download job was created, and its range of permissible values is from 1 to 12.

The date to start the scheduled content download is specified in the form dd.mm.yyyy, where dd equals the two-digit day, mm equals the two-digit month, and yyyy equals the four-digit year. The day is set by the StartDateDay property, the month is set by this property, and the year is set by the StartDateYear property.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCScheduledContentDownloadConfig


IFPCScheduledContentDownloadConfig.StartDateYear property [ISA Server 2004]

StartDateYear Property of IFPCScheduledContentDownloadConfig[C++]

FPCScheduledContentDownloadConfig.StartDateYear [Visual Basic]

[C++]

The StartDateYear property gets or sets the year part of the date to start the content download job.

HRESULT get_StartDateYear(
  long* plStartDateYear
);

HRESULT put_StartDateYear(
  long lStartDateYear
);

Parameters

plStartDateYear
Pointer to a variable that on return receives a 32-bit integer specifying the year part of the date to start the content download job.
lStartDateYear
A 32-bit integer that specifies the year part of the date to start the content download job.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write. Its default value corresponds to the year when the content download job was created, and its range of permissible values is from 1601 to 9999.

The date to start the scheduled content download is specified in the form dd.mm.yyyy, where dd equals the two-digit day, mm equals the two-digit month, and yyyy equals the four-digit year. The day is set by the StartDateDay property, the month is set by the StartDateMonth property, and the year is set by this property.

[Visual Basic]

The StartDateYear property gets or sets the year part of the date to start the content download job.

Property StartDateYear As Long

Property Value

A 32-bit integer that specifies the year part of the date to start the content download job.

Remarks

This property is read/write. Its default value corresponds to the year when the content download job was created, and its range of permissible values is from 1601 to 9999.

The date to start the scheduled content download is specified in the form dd.mm.yyyy, where dd equals the two-digit day, mm equals the two-digit month, and yyyy equals the four-digit year. The day is set by the StartDateDay property, the month is set by the StartDateMonth property, and the year is set by this property.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCScheduledContentDownloadConfig


IFPCScheduledContentDownloadConfig.StayInDomain property [ISA Server 2004]

StayInDomain Property of IFPCScheduledContentDownloadConfig[C++]

FPCScheduledContentDownloadConfig.StayInDomain [Visual Basic]

[C++]

The StayInDomain property gets or sets a Boolean value that indicates whether to download content only from the domain of the root URL, or from other domains as well.

HRESULT get_StayInDomain(
  VARIANT_BOOL* pfStayInDomain
);

HRESULT put_StayInDomain(
  VARIANT_BOOL fStayInDomain
);

Parameters

pfStayInDomain
Pointer to a Boolean variable that is set on return to VARIANT_TRUE if content is to be downloaded only from the domain of the root URL, or to VARIANT_FALSE if content can be downloaded from the initial domain and other domains.
fStayInDomain
Boolean value that indicates whether to download content only from the domain of the root URL, or from other domains as well.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write. Its default value is VARIANT_FALSE.

[Visual Basic]

The StayInDomain property gets or sets a Boolean value that indicates whether to download content only from the domain of the root URL, or from other domains as well.

Property StayInDomain As Boolean

Property Value

Boolean value that indicates whether to download content only from the domain of the root URL, or from other domains as well.

Remarks

This property is read/write. Its default value is False.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCScheduledContentDownloadConfig


IFPCScheduledContentDownloadConfig.TaskPeriod property [ISA Server 2004]

TaskPeriod Property of IFPCScheduledContentDownloadConfig[C++]

FPCScheduledContentDownloadConfig.TaskPeriod [Visual Basic]

[C++]

The TaskPeriod property gets a value from the FpcScheduledTaskRunningPeriod enumerated type that specifies whether the content download job is run only once, every day, or on specified days of the week.

HRESULT get_TaskPeriod(
  FpcScheduledTaskRunningPeriod* pScheduledContentDownloadPeriod
);

Parameters

pScheduledContentDownloadPeriod
Pointer to a value from the FpcScheduledTaskRunningPeriod enumerated type that is set on return to the value specifying whether the content download job is run only once, every day, or on specified days of the week.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only. It can be set by calling the SetTaskPeriod method. Its default value is fpcRunOnce.

[Visual Basic]

The TaskPeriod property gets a value from the FpcScheduledTaskRunningPeriod enumerated type that specifies whether the content download job is run only once, every day, or on specified days of the week.

Property TaskPeriod As FpcScheduledTaskRunningPeriod

Property Value

Value from the FpcScheduledTaskRunningPeriod enumerated type that specifies whether the content download job is run only once, every day, or on specified days of the week.

Remarks

This property is read-only. It can be set by calling the SetTaskPeriod method. Its default value is fpcRunOnce.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCScheduledContentDownloadConfig


IFPCScheduledContentDownloadConfig.TTL(long,long) property [ISA Server 2004]

TTL Property of IFPCScheduledContentDownloadConfig[C++]

FPCScheduledContentDownloadConfig.TTL [Visual Basic]

[C++]

The TTL property gets or sets the Time to Live (TTL), in minutes, of the pages to be downloaded.

HRESULT get_TTL(
  long* plTTL
);

HRESULT put_TTL(
  long lTTL
);

Parameters

plTTL
Pointer to a 32-bit integer that is set on return to a long value specifying the TTL, in minutes, of the pages to be downloaded.
lTTL
A 32-bit integer value that specifies the TTL, in minutes, of the pages to be downloaded.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write. Its default value is 60 minutes.

[Visual Basic]

The TTL property gets or sets the Time to Live (TTL), in minutes, of the pages to be downloaded.

Property TTL As Long

Property Value

A 32-bit integer value that specifies the TTL, in minutes, of the pages to be downloaded.

Remarks

This property is read/write. Its default value is 60 minutes.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCScheduledContentDownloadConfig


IFPCScheduledContentDownloadConfig.URL(BSTR,BSTR) property [ISA Server 2004]

URL Property of IFPCScheduledContentDownloadConfig[C++]

FPCScheduledContentDownloadConfig.URL [Visual Basic]

[C++]

The URL property gets or sets the URL to be downloaded.

HRESULT get_URL(
  BSTR* pbstrURL
);

HRESULT put_URL(
  BSTR bstrURL
);

Parameters

pbstrURL
Pointer to a BSTR that is set on return to a string value specifying the URL to be downloaded.
bstrURL
BSTR that specifies the URL to be downloaded.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write.

[Visual Basic]

The URL property gets or sets the URL to be downloaded.

Property URL As String

Property Value

String that specifies the URL to be downloaded.

Remarks

This property is read/write.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCScheduledContentDownloadConfig


FPCScheduledContentDownloadJobStatus object [ISA Server 2004]

FPCScheduledContentDownloadJobStatus

The FPCScheduledContentDownloadJobStatus object represents the status of a single run of a content download job on a single server.

This object is typically an element of an FPCScheduledContentDownloadJobStatuses collection.

Click here to see the ISA Server object hierarchy.

Methods

The FPCScheduledContentDownloadJobStatus object defines the following methods.

Method | Description
Abort | Ends the run of the content download job.
Refresh | Obtains the current information about the status of the run of the content download job using a remote procedure call (RPC).

Properties

The FPCScheduledContentDownloadJobStatus object has the following properties.

Property | Description
CurrentDepth | Gets the current depth for the run of the content download job.
NumberofObjectsFetched | Gets the number of objects downloaded in the run of the content download job.
NumberofObjectsQueued | Gets the number of objects queued for the run of the content download job.
ServerName | Gets the name of the server on which the content download job is running.
StartTime | Gets the time at which the run of the content download job started.

Remarks

This object implements the IFPCScheduledContentDownloadJobStatus interface.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

COM Objects


IFPCScheduledContentDownloadJobStatus.Abort method [ISA Server 2004]

IFPCScheduledContentDownloadJobStatus::Abort[C++]

FPCScheduledContentDownloadJobStatus.Abort [Visual Basic]

[C++]

The Abort method ends the run of the content download job.

HRESULT Abort();

Parameters

This method has no parameters.

Return Values

This method returns S_OK if the call is successful; otherwise, it returns an error code.
[Visual Basic]

The Abort method ends the run of the content download job.

Sub Abort()

Parameters

This method has no parameters.

Return Values

This method has no return values. If the call is unsuccessful, an error is raised that can be intercepted by using an error handler.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCScheduledContentDownloadJobStatus


IFPCScheduledContentDownloadJobStatus.CurrentDepth property [ISA Server 2004]

CurrentDepth Property of IFPCScheduledContentDownloadJobStatus[C++]

FPCScheduledContentDownloadJobStatus.CurrentDepth [Visual Basic]

[C++]

The CurrentDepth property gets the current depth for the run of the content download job. Depth refers to the number of links that have been followed in the run.

The maximum depth for a content download job can be set using the MaxDepth property.

HRESULT get_CurrentDepth(
  long* plDepth
);

Parameters

plDepth
Pointer to a variable that on return receives a 32-bit integer specifying the current depth for the run of the content download job.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The CurrentDepth property gets the current depth for the run of the content download job. Depth refers to the number of links that have been followed in the run.

The maximum depth for a content download job can be set using the MaxDepth property.

Property CurrentDepth As Long

Property Value

A 32-bit integer specifying the current depth for the run of the content download job.

Remarks

This property is read-only.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCScheduledContentDownloadJobStatus


NumberOfObjectsFetched property [ISA Server 2004]

NumberOfObjectsFetched Property of IFPCScheduledContentDownloadJobStatus[C++]

FPCScheduledContentDownloadJobStatus.NumberOfObjectsFetched [Visual Basic]

[C++]

The NumberOfObjectsFetched property gets the number of objects downloaded in the run of the content download job.

HRESULT get_NumberOfObjectsFetched(
  long* plNumberFetched
);

Parameters

plNumberFetched
Pointer to a variable that on return receives a 32-bit integer specifying the number of objects downloaded in the run of the content download job.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The NumberOfObjectsFetched property gets the number of objects downloaded in the run of the content download job.

Property NumberOfObjectsFetched As Long

Property Value

A 32-bit integer that specifies the number of objects downloaded in the run of the content download job.

Remarks

This property is read-only.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCScheduledContentDownloadJobStatus


NumberOfObjectsQueued property [ISA Server 2004]

NumberOfObjectsQueued Property of IFPCScheduledContentDownloadJobStatus[C++]

FPCScheduledContentDownloadJobStatus.NumberOfObjectsQueued [Visual Basic]

[C++]

The NumberOfObjectsQueued property gets the number of objects queued for the run of the content download job. The job will download a certain number of objects based on the links that it follows from object to object. The job queues those objects for download.

HRESULT get_NumberOfObjectsQueued(
  long* plNumberQueued
);

Parameters

plNumberQueued
Pointer to a variable that on return receives a 32-bit integer specifying the number of objects queued for the run of the content download job.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The NumberOfObjectsQueued property gets the number of objects queued for the run of the content download job. The job will download a certain number of objects based on the links that it follows from object to object. The job queues those objects for download.

Property NumberOfObjectsQueued As Long

Property Value

A 32-bit integer that specifies the number of objects queued for the run of the content download job.

Remarks

This property is read-only.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCScheduledContentDownloadJobStatus


IFPCScheduledContentDownloadJobStatus.Refresh method [ISA Server 2004]

IFPCScheduledContentDownloadJobStatus::Refresh[C++]

FPCScheduledContentDownloadJobStatus.Refresh [Visual Basic]

[C++]

The Refresh method obtains the current information about the status of the run of the content download job using a remote procedure call (RPC).

HRESULT Refresh();

Parameters

This method has no parameters.

Return Values

This method returns S_OK if the call is successful; otherwise, it returns an error code.
[Visual Basic]

The Refresh method obtains the current information about the status of the run of the content download job using a remote procedure call (RPC).

Sub Refresh()

Parameters

This method has no parameters.

Return Values

This method has no return values. If the call is unsuccessful, an error is raised that can be intercepted by using an error handler.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCScheduledContentDownloadJobStatus


IFPCScheduledContentDownloadJobStatus.ServerName property [ISA Server 2004]

ServerName Property of IFPCScheduledContentDownloadJobStatus[C++]

FPCScheduledContentDownloadJobStatus.ServerName [Visual Basic]

[C++]

The ServerName property gets the name of the server on which the content download job is running.

HRESULT get_ServerName(
  BSTR* bstrServerName
);

Parameters

bstrServerName
Pointer to a BSTR that is set on return to a string value specifying the name of the server on which the content download job is running.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The ServerName property gets the name of the server on which the content download job is running.

Property ServerName As String

Property Value

String specifying the name of the server on which the content download job is running.

Remarks

This property is read-only.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCScheduledContentDownloadJobStatus


IFPCScheduledContentDownloadJobStatus.StartTime(DATE) property [ISA Server 2004]

StartTime Property of IFPCScheduledContentDownloadJobStatus[C++]

FPCScheduledContentDownloadJobStatus.StartTime [Visual Basic]

[C++]

The StartTime property gets the time at which the run of the content download job started.

HRESULT get_StartTime(
  DATE* pdTime
);

Parameters

pdTime
Pointer to a DATE that is set on return to a DATE value specifying the time at which the run of the content download job started.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The StartTime property gets the time at which the run of the content download job started.

Property StartTime As Date

Property Value

Date value that specifies the time at which the run of the content download job started.

Remarks

This property is read-only.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCScheduledContentDownloadJobStatus


FPCScheduledContentDownloadJobStatuses collection [ISA Server 2004]

FPCScheduledContentDownloadJobStatuses Collection

The FPCScheduledContentDownloadJobStatuses collection holds a set of FPCScheduledContentDownloadJobStatus objects that contain the status of individual runs of a single content download job.

The FPCScheduledContentDownloadJobStatuses collection is typically accessed through the ScheduledContentDownloadJobStatuses property of an FPCScheduledContentDownloadConfig object representing a single content download job.

Click here to see the ISA Server object hierarchy.

Methods

The FPCScheduledContentDownloadJobStatuses collection defines the following methods.

Method | Description
Item | Retrieves the requested FPCScheduledContentDownloadJobStatus object from the collection.
Refresh | Obtains the current information about the status of all the runs of the content download job using a remote procedure call (RPC).

Properties

The FPCScheduledContentDownloadJobStatuses collection has the following properties.

Property | Description
_NewEnum | Gets an enumerator object for the collection.
Count | Gets the number of FPCScheduledContentDownloadJobStatus objects in the collection.

Remarks

This object implements the IFPCScheduledContentDownloadJobStatuses interface.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

COM Objects


IFPCScheduledContentDownloadJobStatuses._NewEnum property [ISA Server 2004]

_NewEnum Property of IFPCScheduledContentDownloadJobStatuses[C++]

FPCScheduledContentDownloadJobStatuses._NewEnum [Visual Basic]

[C++]

The _NewEnum property gets an enumerator object for the collection. An enumerator object provides serial access to the elements of the collection.

HRESULT get__NewEnum(
  IUnknown* ppEnum
);

Parameters

ppEnum
Address of an interface pointer that on return points to the IUnknown interface of an enumerator object that implements an IEnumVARIANT interface for the collection. An interface pointer to the IEnumVARIANT interface of the enumerator object can be retrieved by calling QueryInterface on the IUnknown interface returned.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The _NewEnum property gets an enumerator object for the collection. An enumerator object provides serial access to the elements of the collection.

Property _NewEnum As IUnknown

Property Value

Reference to an enumerator object that provides serial access to the elements of the collection.

Remarks

This property is read-only.

In Visual Basic and VBScript, this property is used implicitly in For Each...In...Next constructs.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCScheduledContentDownloadJobStatuses


IFPCScheduledContentDownloadJobStatuses.Count(long) property [ISA Server 2004]

Count Property of IFPCScheduledContentDownloadJobStatuses[C++]

FPCScheduledContentDownloadJobStatuses.Count [Visual Basic]

[C++]

The Count property gets the number of FPCScheduledContentDownloadJobStatus objects in the collection.

HRESULT get_Count(
  long* plCount
);

Parameters

plCount
Pointer to a variable that on return receives a 32-bit integer specifying the number of FPCScheduledContentDownloadJobStatus objects in the collection.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The Count property gets the number of FPCScheduledContentDownloadJobStatus objects in the collection.

Property Count As Long

Property Value

A 32-bit integer that specifies the number of FPCScheduledContentDownloadJobStatus objects in the collection.

Remarks

This property is read-only.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCScheduledContentDownloadJobStatuses


IFPCScheduledContentDownloadJobStatuses.Item method [ISA Server 2004]

IFPCScheduledContentDownloadJobStatuses::Item[C++]

FPCScheduledContentDownloadJobStatuses.Item [Visual Basic]

[C++]

The Item method retrieves the requested IFPCScheduledContentDownloadJobStatus interface from the collection.

HRESULT Item(
  VARIANT Index,
  IFPCScheduledContentDownloadJobStatus** ppItem
);

Parameters

Index
[in] Required. Name or one-based index of the collection element to retrieve.
ppItem
[out] Address of an interface pointer that on return points to the IFPCScheduledContentDownloadJobStatus interface requested.

Return Values

This method returns one of the following:

  • S_OK, indicating that the operation succeeded.
  • An error code, indicating that the operation failed. In this case, the [out] parameter returned is a null object.

[Visual Basic]

The Item method retrieves the requested FPCScheduledContentDownloadJobStatus object from the collection.

Function Item( _
  ByVal Index As Variant _
) As FPCScheduledContentDownloadJobStatus

Parameters

Index
[in] Required. Name or one-based index of the collection element to retrieve.

Return Values

This method returns a reference to the FPCScheduledContentDownloadJobStatus object requested if the call is successful. Otherwise, an error is raised that can be intercepted by using an error handler.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCScheduledContentDownloadJobStatuses


IFPCScheduledContentDownloadJobStatuses.Refresh method [ISA Server 2004]

IFPCScheduledContentDownloadJobStatuses::Refresh[C++]

FPCScheduledContentDownloadJobStatuses.Refresh [Visual Basic]

[C++]

The Refresh method obtains the current information about the status of all the runs of the content download job using a remote procedure call (RPC).

HRESULT Refresh();

Parameters

This method has no parameters.

Return Values

This method returns S_OK if the call is successful; otherwise, it returns an error code.
[Visual Basic]

The Refresh method obtains the current information about the status of all the runs of the content download job using a remote procedure call (RPC).

Sub Refresh()

Parameters

This method has no parameters.

Return Values

This method has no return values.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCScheduledContentDownloadJobStatuses


FPCSchedules collection [ISA Server 2004]

FPCSchedules Collection

The FPCSchedules collection is an ordered set of FPCSchedule objects. Each object within this collection defines a schedule. A schedule is defined by blocks representing hours that are selected for each day of the week. Each day of the week can have different hour blocks selected. Each day of the week can have different hour blocks selected. Schedules are used by ISA Server to define a set of hours during which a certain configuration, such as a policy rule, applies.

This collection is typically accessed through the Schedules property of the FPCRuleElements object.

Click here to see the ISA Server object hierarchy.

Inheritance

This collection inherits from the FPCPersist object, which contains methods and properties related to persistent object storage. They include methods for exporting an object's configuration to and importing it from an XML document.

Methods

The FPCSchedules collection defines the following methods.

Method | Description
Add | Creates a new FPCSchedule object in the collection and returns a reference to it.
Item | Retrieves the requested FPCSchedule object from the collection.
Remove | Removes a schedule from the collection.

Properties

The FPCSchedules collection has the following properties.

Property | Description
_NewEnum | Gets an enumerator object for the collection.
Count | Gets the number of schedule objects in the collection.

Methods Inherited from FPCPersist

Name | Description
CancelWaitForChanges | Cancels the registration established by the WaitForChanges method (for use in C and C++ programming only).
CanImport | Returns a Boolean value that indicates whether the properties of the collection and its elements can be imported from the specified XML document.
Export | Writes the stored values of all the properties of the collection and its elements to the specified XML document.
ExportToFile | Writes the stored values of all the properties of the collection and its elements to the specified XML file.
GetServiceRestartMask | Retrieves a 32-bit bitmask of the FpcServices enumerated type that specifies which services need to be restarted for currently unsaved changes to take effect.
Import | Copies the values of all the properties of the collection and its elements from the specified XML document to persistent storage.
ImportFromFile | Copies the values of all the properties of the collection and its elements from the specified XML file to persistent storage.
LoadDocProperties | Provides the XML document's properties so that you can know what information can be imported from the document.
Refresh | Reads the values of all the properties of the collection and its elements from persistent storage, overwriting any changes that have not been saved.
Save | Writes the current values of all the properties of the collection and its elements to persistent storage.
WaitForChanges | Registers to wait for an event indicating that the contents of the object have changed (for use in C and C++ programming only).

Properties Inherited from FPCPersist

Name | Description
PersistentName | Gets the persistent name of the collection. The persistent name of an object is a name that is unique for the object at the respective level of the COM object hierarchy.
VendorParametersSets | Gets an FPCVendorParametersSets collection that can hold sets of custom data for extending the collection.

Remarks

This collection implements the IFPCSchedules interface.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

COM Objects


IFPCSchedules | FPCSchedules _NewEnum(IUnknown) property [ISA Server 2004]

_NewEnum Property of IFPCSchedules[C++]

FPCSchedules._NewEnum [Visual Basic]

[C++]

The _NewEnum property gets an enumerator object for the collection. An enumerator object provides serial access to the elements of the collection.

HRESULT get__NewEnum(
  IUnknown* ppEnum
);

Parameters

ppEnum
Address of an interface pointer that on return points to the IUnknown interface of an enumerator object that implements an IEnumVARIANT interface for the collection. An interface pointer to the IEnumVARIANT interface of the enumerator object can be retrieved by calling QueryInterface on the IUnknown interface returned.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The _NewEnum property gets an enumerator object for the collection. An enumerator object provides serial access to the elements of the collection.

Property _NewEnum As IUnknown

Property Value

Reference to an enumerator object that provides serial access to the elements of the collection.

Remarks

This property is read-only.

In Visual Basic and VBScript, this property is used implicitly in For Each...In...Next constructs.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCSchedules


IFPCSchedules | FPCSchedules Add(String,IFPCSchedule) method [ISA Server 2004]

IFPCSchedules::Add[C++]

FPCSchedules.Add [Visual Basic]

[C++]

The Add method creates a new FPCSchedule object in the collection and returns a reference to it.

HRESULT Add(
  BSTR Name,
  IFPCSchedule** ppNewSchedule
);

Parameters

Name
[in] Required. BSTR that specifies the name of the new schedule.
ppNewSchedule
Address of an interface pointer that on return points to the new IFPCSchedule interface created.

Return Values

This method can return one of the following:

  • S_OK, indicating that the operation succeeded.
  • An error code indicating that the operation failed. In this case, the [out] parameter returned is a null object.

Remarks

Newly created schedules do not contain any defined hour blocks. You can define hour blocks by calling the methods of an individual FPCSchedule object.

The additional FPCSchedule object created by this method is not saved to persistent storage until after the Save method is called.

[Visual Basic]

The Add method creates a new FPCSchedule object in the collection and returns a reference to it.

Function Add( _
  ByVal Name As String _
) As FPCSchedule

Parameters

Name
[in] Required. String that specifies the name of the new schedule.

Return Values

This method returns a reference to the new FPCSchedule object if successful. Otherwise, an error is raised that can be intercepted by using an error handler.

Remarks

Newly created schedules do not contain any defined hour blocks. You can define hour blocks by calling the methods of an individual FPCSchedule object.

The additional FPCSchedule object created by this method is not saved to persistent storage until after the Save method is called.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCSchedules


IFPCSchedules | FPCSchedules Count(long) property [ISA Server 2004]

Count Property of IFPCSchedules[C++]

FPCSchedules.Count [Visual Basic]

[C++]

The Count property gets the number of FPCSchedule objects in the collection.

HRESULT get_Count(
  long* plCount
);

Parameters

plCount
Pointer to a variable that on return receives a 32-bit integer specifying the number of FPCSchedule objects in the collection.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The Count property gets the number of FPCSchedule objects in the collection.

Property Count As Long

Property Value

A 32-bit integer that specifies the number of FPCSchedule objects in the collection.

Remarks

This property is read-only.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCSchedules


IFPCSchedules | FPCSchedules Item(Variant,IFPCSchedule) method [ISA Server 2004]

IFPCSchedules::Item[C++]

FPCSchedules.Item [Visual Basic]

[C++]

The Item method retrieves the requested IFPCSchedule interface from the collection.

HRESULT Item(
  VARIANT Index,
  IFPCSchedule** ppItem
);

Parameters

Index
[in] Required. Name or one-based index of the object to retrieve.
ppItem
[out] Address of a variable that receives a pointer to the IFPCSchedule interface requested.

Return Values

This method can return one of the following:

  • S_OK, indicating that the operation succeeded.
  • An error message indicating that the operation failed. In this case, the [out] parameter returned is a null object.

[Visual Basic]

The Item method retrieves the requested FPCSchedule object from the collection.

Function Item( _
  ByVal Index As Variant _
) As FPCSchedule

Parameters

Index
[in] Required. Name or one-based index of the object to retrieve.

Return Values

This method returns a reference to the FPCSchedule object requested if successful. Otherwise, an error is raised that can be intercepted by using an error handler.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCSchedules


IFPCSchedules | FPCSchedules Remove(Variant) method [ISA Server 2004]

IFPCSchedules::Remove[C++]

FPCSchedules.Remove [Visual Basic]

[C++]

The Remove method removes the specified FPCSchedule object from the collection.

HRESULT Remove(
  VARIANT Index
);

Parameters

Index
[in] Required. Name or one-based index of the FPCSchedule object to remove.

Return Values

This method returns S_OK if the call is successful; otherwise, it returns an error code.
[Visual Basic]

The Remove method removes the specified FPCSchedule object from the collection.

Sub Remove( _
  ByVal Index As Variant _
)

Parameters

Index
[in] Required. Name or one-based index of the FPCSchedule object to remove.

Return Values

This method has no return values. If the call is unsuccessful, an error is raised that can be intercepted by using an error handler.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCSchedules


FPCSecurityReports object [ISA Server 2004]

FPCSecurityReports

The FPCSecurityReports object contains the properties of security reports.

Click here to see the ISA Server object hierarchy.

Inheritance

This object inherits from the FPCPersist object, which contains methods and properties related to the persistent storage of an object's data. They include methods for exporting the object's data to and importing it from an XML document.

Methods

This object has no methods.

Properties

The FPCSecurityReports object has the following properties.

Property | Description
AuthorizationFailuresReportTopNumber | Gets or sets the number of authorization failures to include in the report.
DroppedPacketsReportTopNumber | Gets or sets the number of dropped packets to include in the report.

Methods Inherited from FPCPersist

Name | Description
CancelWaitForChanges | Cancels the registration established by the WaitForChanges method (for use in C and C++ programming only).
CanImport | Returns a Boolean value that indicates whether the object's properties can be imported from the specified XML document.
Export | Writes the stored values of all of the object's properties to the specified XML document.
ExportToFile | Writes the stored values of all of the object's properties to the specified XML file.
GetServiceRestartMask | Retrieves a 32-bit bitmask of the FpcServices enumerated type that specifies which services need to be restarted for currently unsaved changes to take effect.
Import | Copies the values of all of the object's properties from the specified XML document to persistent storage.
ImportFromFile | Copies the values of all of the object's properties from the specified XML file to persistent storage.
LoadDocProperties | Provides the XML document's properties so that you can know what information can be imported from the document.
Refresh | Reads the values of all of the object's properties from persistent storage, overwriting any changes that have not been saved.
Save | Writes the current values of all of the object's properties to persistent storage.
WaitForChanges | Registers to wait for an event indicating that the contents of the object have changed (for use in C and C++ programming only).

Properties Inherited from FPCPersist

Name | Description
PersistentName | Gets the persistent name of the object. The persistent name of an object is a name that is unique for the object at the respective level of the COM object hierarchy.
VendorParametersSets | Gets an FPCVendorParametersSets object that can hold sets of custom data for extending the object.

Remarks

This object implements the IFPCSecurityReports interface.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

COM Objects


AuthorizationFailuresReportTopNumber property [ISA Server 2004]

AuthorizationFailuresReportTopNumber Property of IFPCSecurityReports[C++]

FPCSecurityReports.AuthorizationFailuresReportTopNumber [Visual Basic]

[C++]

The AuthorizationFailuresReportTopNumber property gets or sets the number of authorization failures to include in the report.

HRESULT get_AuthorizationFailuresReportTopNumber(
  long* plTopNAuthorizationFailures
);

HRESULT put_AuthorizationFailuresReportTopNumber(
  long*** lTopNAuthorizationFailures
);

Parameters

plTopNAuthorizationFailures
Pointer to a variable that on return receives a 32-bit integer specifying the number of authorization failures to include in the report.
lTopNAuthorizationFailures
A 32-bit integer that specifies the number of authorization failures to include in the report.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write.

[Visual Basic]

The AuthorizationFailuresReportTopNumber property gets or sets the number of authorization failures to include in the report.

Property AuthorizationFailuresReportTopNumber As Long

Property Value

A 32-bit integer that specifies the number of authorization failures to include in the report.

Remarks

This property is read/write.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCSecurityReports


IFPCSecurityReports.DroppedPacketsReportTopNumber property [ISA Server 2004]

DroppedPacketsReportTopNumber Property of IFPCSecurityReports[C++]

FPCSecurityReports.DroppedPacketsReportTopNumber [Visual Basic]

[C++]

The DroppedPacketsReportTopNumber property gets or sets the number of dropped packets to include in the report.

HRESULT get_DroppedPacketsReportTopNumber(
  long* plTopNDroppedPackets
);

HRESULT put_DroppedPacketsReportTopNumber(
  long lTopNDroppedPackets
);

Parameters

plTopNDroppedPackets
Pointer to a variable that on return receives a 32-bit integer specifying the number of dropped packets to include in the report.
lTopNDroppedPackets
A 32-bit integer that specifies the number of dropped packets to include in the report.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write.

[Visual Basic]

The DroppedPacketsReportTopNumber property gets or sets the number of dropped packets to include in the report.

Property DroppedPacketsReportTopNumber As Long

Property Value

A 32-bit integer that specifies the number of dropped packets to include in the report.

Remarks

This property is read/write.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCSecurityReports


FPCSecurityRole object [ISA Server 2004]

FPCSecurityRole

The FPCSecurityRole object represents a security role that can be used in assigning permissions to administrators for performing specific sets of tasks. The permissions associated with a security role are specified in the Definition property in XML format.

ISA Server 2004 has three predefined administrative roles.

  • ISA Server Basic Monitoring.
  • ISA Server Extended Monitoring.
  • ISA Server Full Administrator.

This object is typically an element of an FPCSecurityRoles collection.

Click here to see the ISA Server object hierarchy.

Inheritance

This object inherits from the FPCPersist object, which contains methods and properties related to the persistent storage of an object's data. They include methods for exporting the object's data to and importing it from an XML document.

Methods

This object has no methods.

Properties

The FPCSecurityRole object has the following properties.

Property | Description
Definition | Gets the definition of the security role in XML format.
Description | Gets the description of the security role.
Name | Gets the name of the security role.
Predefined | Gets a Boolean value that indicates whether the security role is predefined.

Methods Inherited from FPCPersist

Name | Description
CancelWaitForChanges | Cancels the registration established by the WaitForChanges method (for use in C and C++ programming only).
CanImport | Returns a Boolean value that indicates whether the object's properties can be imported from the specified XML document.
Export | Writes the stored values of all of the object's properties to the specified XML document.
ExportToFile | Writes the stored values of all of the object's properties to the specified XML file.
GetServiceRestartMask | Retrieves a 32-bit bitmask of the FpcServices enumerated type that specifies which services need to be restarted for currently unsaved changes to take effect.
Import | Copies the values of all of the object's properties from the specified XML document to persistent storage.
ImportFromFile | Copies the values of all of the object's properties from the specified XML file to persistent storage.
LoadDocProperties | Provides the XML document's properties so that you can know what information can be imported from the document.
Refresh | Reads the values of all of the object's properties from persistent storage, overwriting any changes that have not been saved.
Save | Writes the current values of all of the object's properties to persistent storage.
WaitForChanges | Registers to wait for an event indicating that the contents of the object have changed (for use in C and C++ programming only).

Properties Inherited from FPCPersist

Name | Description
PersistentName | Gets the persistent name of the object. The persistent name of an object is a name that is unique for the object at the respective level of the COM object hierarchy.
VendorParametersSets | Gets an FPCVendorParametersSets object that can hold sets of custom data for extending the object.

Remarks

This object implements the IFPCSecurityRole interface.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

COM Objects


IFPCSecurityRole | FPCSecurityRole Definition(BSTR) property [ISA Server 2004]

Definition Property of IFPCSecurityRole[C++]

FPCSecurityRole.Definition [Visual Basic]

[C++]

The Definition property gets the definition of the security role in XML format.

HRESULT get_Definition(
  BSTR* pbstrDefinition
);

Parameters

pbstrDefinition
Pointer to a BSTR that is set on return to a string value specifying the definition of the security role in XML format.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The Definition property gets the definition of the security role in XML format.

Property Definition As String

Property Value

String that specifies the definition of the security role in XML format.

Remarks

This property is read-only.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCSecurityRole


IFPCSecurityRole | FPCSecurityRole Description(BSTR) property [ISA Server 2004]

Description Property of IFPCSecurityRole[C++]

FPCSecurityRole.Description [Visual Basic]

[C++]

The Description property gets the description of the security role.

HRESULT get_Description(
  BSTR* pbstrDescription
);

Parameters

pbstrDescription
Pointer to a BSTR that is set on return to a string value specifying the description of the security role.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The Description property gets the description of the security role.

Property Description As String

Property Value

String that specifies description of the security role.

Remarks

This property is read-only.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCSecurityRole


IFPCSecurityRole | FPCSecurityRole Name(BSTR) property [ISA Server 2004]

Name Property of IFPCSecurityRole[C++]

FPCSecurityRole.Name [Visual Basic]

[C++]

The Name property gets the name of the security role.

HRESULT get_Name(
  BSTR* pbstrName
);

Parameters

pbstrName
Pointer to a BSTR that is set on return to a string value specifying the name of the security role.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The Name property gets the name of the security role.

Property Name As String

Property Value

String that specifies the name of the security role.

Remarks

This property is read-only.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCSecurityRole


IFPCSecurityRole | FPCSecurityRole Predefined property [ISA Server 2004]

Predefined Property of IFPCSecurityRole[C++]

FPCSecurityRole.Predefined [Visual Basic]

[C++]

The Predefined property gets a Boolean value that indicates whether the security role is a predefined security role that was defined during the installation of ISA Server and cannot be deleted.

HRESULT get_Predefined(
  VARIANT_BOOL* pfPredefined
);

Parameters

pfPredefined
Pointer to a Boolean variable that is set on return to VARIANT_TRUE if the security role is predefined, or to VARIANT_FALSE if the security role is user-defined.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The Predefined property gets a Boolean value that indicates whether the security role is a predefined security role that was defined during the installation of ISA Server and cannot be deleted.

Property Predefined As Boolean

Property Value

Boolean value that specifies whether the security role is predefined.

Remarks

This property is read-only.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCSecurityRole


FPCSecurityRoles collection [ISA Server 2004]

FPCSecurityRoles Collection

The FPCSecurityRoles collection is an ordered set of individual FPCSecurityRole objects. Each FPCSecurityRole object defines a security role that can be used in setting administration security.

The FPCSecurityRoles collection is typically accessed through the SecurityRoles property of the FPCAdminSecurity object.

Click here to see the ISA Server object hierarchy.

Inheritance

This collection inherits from the FPCPersist object, which contains methods and properties related to the persistent storage of an object's data. They include methods for exporting the object's data to and importing it from an XML document.

Methods

The FPCSecurityRoles collection defines the following method.

Method | Description
Item | Returns the requested FPCSecurityRole object from the collection.

Properties

The FPCSecurityRoles collection has the following properties.

Property | Description
_NewEnum | Gets an enumerator object for the collection.
Count | Gets the number of FPCSecurityRole objects in the collection.

Methods Inherited from FPCPersist

Name | Description
CancelWaitForChanges | Cancels the registration established by the WaitForChanges method (for use in C and C++ programming only).
CanImport | Returns a Boolean value that indicates whether the properties of the collection and its elements can be imported from the specified XML document.
Export | Writes the stored values of all the properties of the collection and its elements to the specified XML document.
ExportToFile | Writes the stored values of all the properties of the collection and its elements to the specified XML file.
GetServiceRestartMask | Retrieves a 32-bit bitmask of the FpcServices enumerated type that specifies which services need to be restarted for currently unsaved changes to take effect.
Import | Copies the values of all the properties of the collection and its elements from the specified XML document to persistent storage.
ImportFromFile | Copies the values of all the properties of the collection and its elements from the specified XML file to persistent storage.
LoadDocProperties | Provides the XML document's properties so that you can know what information can be imported from the document.
Refresh | Reads the values of all the properties of the collection and its elements from persistent storage, overwriting any changes that have not been saved.
Save | Writes the current values of all the properties of the collection and its elements to persistent storage.
WaitForChanges | Registers to wait for an event indicating that the contents of the object have changed (for use in C and C++ programming only).

Properties Inherited from FPCPersist

Name | Description
PersistentName | Gets the persistent name of the collection. The persistent name of an object is a name that is unique for the object at the respective level of the COM object hierarchy.
VendorParametersSets | Gets an FPCVendorParametersSets collection that can hold sets of custom data for extending the collection.

Remarks

This collection implements the IFPCSecurityRoles interface.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

COM Objects


IFPCSecurityRoles | FPCSecurityRoles _NewEnum property [ISA Server 2004]

_NewEnum Property of IFPCSecurityRoles[C++]

FPCSecurityRoles._NewEnum [Visual Basic]

[C++]

The _NewEnum property gets an enumerator object for the collection. An enumerator object provides serial access to the elements of the collection.

HRESULT get__NewEnum(
  IUnknown* ppEnum
);

Parameters

ppEnum
Address of an interface pointer that on return points to the IUnknown interface of an enumerator object that implements an IEnumVARIANT interface for the collection. An interface pointer to the IEnumVARIANT interface of the enumerator object can be retrieved by calling QueryInterface on the IUnknown interface returned.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The _NewEnum property gets an enumerator object for the collection. An enumerator object provides serial access to the elements of the collection.

Property _NewEnum As IUnknown

Property Value

Reference to an enumerator object that provides serial access to the elements of the collection.

Remarks

This property is read-only.

In Visual Basic and VBScript, this property is used implicitly in For Each...In...Next constructs.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCSecurityRoles


IFPCSecurityRoles | FPCSecurityRoles Count(long) property [ISA Server 2004]

Count Property of IFPCSecurityRoles[C++]

FPCSecurityRoles.Count [Visual Basic]

[C++]

The Count property gets the number of FPCSecurityRole objects in the collection.

HRESULT get_Count(
  long* plCount
);

Parameters

plCount
Pointer to a variable that on return receives a 32-bit integer specifying the number of FPCSecurityRole objects in the collection.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The Count property gets the number of FPCSecurityRole objects in the collection.

Property Count As Long

Property Value

A 32-bit integer that specifies the number of FPCSecurityRole objects in the collection.

Remarks

This property is read-only.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCSecurityRoles


IFPCSecurityRoles | FPCSecurityRoles Item method [ISA Server 2004]

IFPCSecurityRoles::Item[C++]

FPCSecurityRoles.Item [Visual Basic]

[C++]

The Item method retrieves the requested IFPCSecurityRole interface from the collection.

HRESULT Item(
  VARIANT Index,
  IFPCSecurityRole** ppItem
);

Parameters

Index
[in] Required. Name or one-based index of the object to retrieve.
ppItem
[out] Address of an interface pointer that on return points to the IFPCSecurityRole interface requested.

Return Values

This method can return one of the following:

  • S_OK, indicating the operation succeeded
  • An error message, indicating that the operation failed. In this case, the [out] parameter returned is a null object.

[Visual Basic]

The Item method retrieves the requested FPCSecurityRole object from the collection.

Function Item( _
  ByVal Index As Variant _
) As FPCSecurityRole

Parameters

Index
[in] Required. Name or one-based index of the object to retrieve.

Return Values

This method returns a reference to the FPCSecurityRole object requested if successful. Otherwise, an error is raised that can be intercepted by using an error handler.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCSecurityRoles


FPCSelectionIPs object [ISA Server 2004]

FPCSelectionIPs

The FPCSelectionIPs object represents the complete set of source or destination IP addresses, which may refer to computers, networks, network sets, subnets, or IP address ranges, to which a rule or a system policy configuration group applies.

This object is typically accessed through the following properties:

  • The DestinationSelectionIPs property of an FPCAccessProperties object representing the properties of a policy rule.
  • The DestinationSelectionIPs property of an FPCCacheRule object representing a cache rule.
  • The SourceSelectionIPs and DestinationSelectionIPs properties of an FPCNetworkRule object representing a network rule.
  • The SourceSelectionIPs property of an FPCPolicyRule object representing a policy rule.
  • The DestinationSelectionIPs property of an FPCRoutingRule object representing a routing rule.
  • The SourceSelectionIPs and DestinationSelectionIPs properties of an FPCSystemPolicyConfigGroup object representing a system policy configuration group.

Click here to see the ISA Server object hierarchy.

Inheritance

This object inherits from the FPCPersist object, which contains methods and properties related to the persistent storage of an object's data. They include methods for exporting the object's data to and importing it from an XML document.

Methods

This object has no methods.

Properties

The FPCSelectionIPs object has the following properties.

Property | Description
AddressRanges | Gets an FPCRefs collection that contains references to the IP address ranges in the set.
Computers | Gets an FPCRefs collection that contains references to the computers in the set.
ComputerSets | Gets an FPCRefs collection that contains references to the computer sets in the set.
Networks | Gets an FPCRefs collection that contains references to the networks in the set.
NetworkSets | Gets an FPCRefs collection that contains references to the network sets in the set.
Subnets | Gets an FPCRefs collection that contains references to the subnets in the set.

Methods Inherited from FPCPersist

Name | Description
CancelWaitForChanges | Cancels the registration established by the WaitForChanges method (for use in C and C++ programming only).
CanImport | Returns a Boolean value that indicates whether the object's properties can be imported from the specified XML document.
Export | Recursively writes the stored values of all the properties of the object and its subobjects to the specified XML document.
ExportToFile | Recursively writes the stored values of all the properties of the object and its subobjects to the specified XML file.
GetServiceRestartMask | Retrieves a 32-bit bitmask of the FpcServices enumerated type that specifies which services need to be restarted for currently unsaved changes to take effect.
Import | Recursively copies the values of all the properties of the object and of its subobjects from the specified XML document to persistent storage.
ImportFromFile | Recursively copies the values of all the properties of the object and of its subobjects from the specified XML file to persistent storage.
LoadDocProperties | Provides the XML document's properties so that you can know what information can be imported from the document.
Refresh | Recursively reads the values of all the properties of the object and of its subobjects from persistent storage, overwriting any changes that have not been saved.
Save | Recursively writes the current values of all the properties of the object and its subobjects to persistent storage.
WaitForChanges | Registers to wait for an event indicating that the contents of the object have changed (for use in C and C++ programming only).

Properties Inherited from FPCPersist

Name | Description
PersistentName | Gets the persistent name of the object. The persistent name of an object is a name that is unique for the object at the respective level of the COM object hierarchy.
VendorParametersSets | Gets an FPCVendorParametersSets collection that can hold sets of custom data for extending the object.

Remarks

This object implements the IFPCSelectionIPs interface.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

COM Objects


IFPCSelectionIPs | FPCSelectionIPs AddressRanges property [ISA Server 2004]

AddressRanges Property of IFPCSelectionIPs[C++]

FPCSelectionIPs.AddressRanges [Visual Basic]

[C++]

The AddressRanges property gets an FPCRefs collection that contains references to the IP address ranges in the set.

HRESULT get_AddressRanges(
  IFPCRefs** ppRefs
);

Parameters

ppRefs
Address of an interface pointer that on return points to an IFPCRefs interface that represents the collection of IP address ranges.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The AddressRanges property gets an FPCRefs collection that contains references to the IP address ranges in the set.

Property AddressRanges As FPCRefs

Property Value

Reference to an FPCRefs collection that contains references to the IP address ranges in the set.

Remarks

This property is read-only.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCSelectionIPs


IFPCSelectionIPs | FPCSelectionIPs Computers property [ISA Server 2004]

Computers Property of IFPCSelectionIPs[C++]

FPCSelectionIPs.Computers [Visual Basic]

[C++]

The Computers property gets an FPCRefs collection that contains references to the computers in the set.

HRESULT get_Computers(
  IFPCRefs** ppRefs
);

Parameters

ppRefs
Address of an interface pointer that on return points to an IFPCRefs interface that represents the collection of computers in the set.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The Computers property gets an FPCRefs collection that contains references to the computers in the set.

Property Computers As FPCRefs

Property Value

Reference to an FPCRefs collection that contains references to the computers in the set.

Remarks

This property is read-only.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCSelectionIPs


IFPCSelectionIPs | FPCSelectionIPs ComputerSets property [ISA Server 2004]

ComputerSets Property of IFPCSelectionIPs[C++]

FPCSelectionIPs.ComputerSets [Visual Basic]

[C++]

The ComputerSets property gets an FPCRefs collection that contains references to the computer sets in the set of IP addresses.

HRESULT get_ComputerSets(
  IFPCRefs** ppRefs
);

Parameters

ppRefs
Address of an interface pointer that on return points to an IFPCRefs interface that represents the collection of computer sets in the set of IP addresses.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The ComputerSets property gets an FPCRefs collection that contains references to the computer sets in the set of IP addresses.

Property ComputerSets As FPCRefs

Property Value

Reference to an FPCRefs collection that contains references to the computer sets in the set of IP addresses.

Remarks

This property is read-only.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCSelectionIPs


IFPCSelectionIPs | FPCSelectionIPs Networks(IFPCRefs) property [ISA Server 2004]

Networks Property of IFPCSelectionIPs[C++]

FPCSelectionIPs.Networks [Visual Basic]

[C++]

The Networks property gets an FPCRefs collection that contains references to the networks in the set.

HRESULT get_Networks(
  IFPCRefs** ppRefs
);

Parameters

ppRefs
Address of an interface pointer that on return points to an IFPCRefs interface that represents the collection of networks in the set.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The Networks property gets an FPCRefs collection that contains references to the networks in the set.

Property Networks As FPCRefs

Property Value

Reference to an FPCRefs collection that contains references to the networks in the set.

Remarks

This property is read-only.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCSelectionIPs


IFPCSelectionIPs | FPCSelectionIPs NetworkSets property [ISA Server 2004]

NetworkSets Property of IFPCSelectionIPs[C++]

FPCSelectionIPs.NetworkSets [Visual Basic]

[C++]

The NetworkSets property gets an FPCRefs collection that contains references to the network sets in the set of IP addresses.

HRESULT get_NetworkSets(
  IFPCRefs** ppRefs
);

Parameters

ppRefs
Address of an interface pointer that on return points to an IFPCRefs interface that represents the collection of network sets in the set of IP addresses.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The NetworkSets property gets an FPCRefs collection that contains references to the network sets in the set of IP addresses.

Property NetworkSets As FPCRefs

Property Value

Reference to an FPCRefs collection that contains references to the network sets in the set of IP addresses.

Remarks

This property is read-only.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCSelectionIPs


IFPCSelectionIPs | FPCSelectionIPs Subnets(IFPCRefs) property [ISA Server 2004]

Subnets Property of IFPCSelectionIPs[C++]

FPCSelectionIPs.Subnets [Visual Basic]

[C++]

The Subnets property gets an FPCRefs collection that contains references to the subnets in the set.

HRESULT get_Subnets(
  IFPCRefs** ppRefs
);

Parameters

ppRefs
Address of an interface pointer that on return points to an IFPCRefs interface that represents the collection of subnets in the set.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The Subnets property gets an FPCRefs collection that contains references to the subnets in the set.

Property Subnets As FPCRefs

Property Value

Reference to an FPCRefs collection that contains references to the subnets in the set.

Remarks

This property is read-only.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCSelectionIPs


FPCServer object [ISA Server 2004]

FPCServer

The FPCServer object represents a single ISA Server computer that is associated with an FPCArray object. The FPCServer object has multiple properties that are used to set configuration settings. By using this object, you can programmatically access drives, available network adapters, product information, and other generic server attributes such as a server's name and description.

This object is typically an element of an FPCServers collection.

Click here to see the ISA Server object hierarchy.

Inheritance

This object inherits from the FPCPersist object, which contains methods and properties related to the persistent storage of an object's data. They include methods for exporting the object's data to and importing it from an XML document.

Methods

The FPCServer object defines the following methods.

Method | Description
ActivateRASServerOnDomain | Adds or removes the server from the RAS and IAS Servers groups on the domain controller.
StartFirewallService | Starts the Microsoft Firewall service on the server.
StartJobSchedulerService | Starts the Microsoft ISA Server Job Scheduler service on the server.
StartMSDEService | Starts the Microsoft Data Engine (MSDE) service on the server.
StartRemoteAccessService | Starts the Routing and Remote Access service on the server.
StopFirewallService | Stops the Microsoft Firewall service on the server.
StopJobSchedulerService | Stops the Microsoft ISA Server Job Scheduler service on the server.
StopMSDEService | Stops the Microsoft Data Engine (MSDE) service on the server.
StopRemoteAccessService | Stops the Routing and Remote Access service on the server.
VPNDisconnect | Disconnects the VPN connection between the specified remote IP address and the server.

Properties

The FPCServer object has the following properties.

Property | Description
Adapters | Gets an FPCAdapters collection that contains objects representing the available network adapters on the server.
CacheDrives | Gets an FPCCacheDrives collection that contains objects representing the cache drives on the server.
ConnectivityResults | Gets an FPCConnectivityResults collection that contains objects representing the results of attempts to verify connectivity for the server.
CreatedTime | Gets a Date value that specifies the date and time in Coordinated Universal Time (UTC) when the object was created.
Description | Gets or sets the description of the server.
DialupNetworkConnections | Gets an FPCDialupNetworkConnections collection that holds the names of the dial-up network connections that have been set up on the server.
DiskDrives | Gets an FPCDiskDrives collection that contains objects representing the disk drives on the server.
FirewallClientSessionsCount | Gets the number of Firewall client sessions running on the server.
FirewallServiceStatus | Gets a Boolean value that indicates whether the Microsoft Firewall service is running on the server.
FirewallServiceUpTime | Gets the number of seconds that the Microsoft Firewall service has been working properly on the server.
FQDN | Gets the fully qualified domain name (FQDN) of the server.
InstallationDirectory | Gets the ISA Server installation directory on the server.
JobSchedulerServiceStatus | Gets a Boolean value that indicates whether the Microsoft ISA Server Job Scheduler service is running on the server.
JobSchedulerServiceUpTime | Gets the number of seconds that the Microsoft ISA Server Job Scheduler service has been working properly on the server.
LastModifiedTime | Gets a Date value that specifies the date and time in Coordinated Universal Time (UTC) when the object was last modified.
LoadFactor | Gets or sets the load factor for the server.
MSDEServiceStatus | Gets a Boolean value that indicates whether the Microsoft Data Engine (MSDE) service is running on the server.
Name | Gets the name of the server.
OperatingSystemMajorVersion | Gets the major version number of the operating system installed on the server.
OperatingSystemMinorVersion | Gets the minor version number of the operating system installed on the server.
OperatingSystemSuiteMask | Gets a bitmask that specifies the product suites available on the server.
ProductID | Gets the identifier (ID) of the product installed on the server.
ProductVersion | Gets the version of ISA Server installed on the server.
QuarantinedVPNConnectionsCount | Gets the number of quarantined VPN connections running on the server.
RemoteAccessServiceStatus | Gets a Boolean value that indicates whether the Routing and Remote Access service is running on the server.
SecureNATSessionsCount | Gets the number of SecureNAT sessions running on the server.
ServerStatus | Gets a Boolean value that indicates whether the server is functioning.
ServicePackMajorVersion | Gets the major version number of the latest service pack installed on the server.
ServicePackMinorVersion | Gets the minor version number of the latest service pack installed on the server.
SignaledAlerts | Gets the FPCSignaledAlerts collection for the server.
SiteToSiteVPNConnectionsCount | Gets the number of site-to-site VPN connections running on the server.
SSLClientCertificates | Gets an FPCCertificates collection that contains objects representing the Secure Sockets Layer (SSL) client certificates available on the server.
SSLServerCertificates | Gets an FPCCertificates collection that contains objects representing the Secure Sockets Layer (SSL) server certificates available on the server.
TrustedRootCertificates | Gets an FPCCertificates collection that contains objects representing the trusted root certificates available on the server.
VPNConnectionsCount | Gets the number of VPN connections running on the server.
VpnStaticAddressPool | Gets an FPCReadOnlyIpRangeSet collection that contains objects representing the IP address ranges from which the server can assign IP addresses to VPN clients connecting to it.
WebProxySessionsCount | Gets the number of ISA Server Web proxy sessions running on the server.

Methods Inherited from FPCPersist

Name | Description
CancelWaitForChanges | Cancels the registration established by the WaitForChanges method (for use in C and C++ programming only).
CanImport | Returns a Boolean value that indicates whether the object's properties can be imported from the specified XML document.
Export | Recursively writes the stored values of all the properties of the object and its subobjects to the specified XML document.
ExportToFile | Recursively writes the stored values of all the properties of the object and its subobjects to the specified XML file.
GetServiceRestartMask | Retrieves a 32-bit bitmask of the FpcServices enumerated type that specifies which services need to be restarted for currently unsaved changes to take effect.
Import | Recursively copies the values of all the properties of the object and of its subobjects from the specified XML document to persistent storage.
ImportFromFile | Recursively copies the values of all the properties of the object and of its subobjects from the specified XML file to persistent storage.
LoadDocProperties | Provides the XML document's properties so that you can know what information can be imported from the document.
Refresh | Recursively reads the values of all the properties of the object and of its subobjects from persistent storage, overwriting any changes that have not been saved.
Save | Recursively writes the current values of all the properties of the object and its subobjects to persistent storage.
WaitForChanges | Registers to wait for an event indicating that the contents of the object have changed (for use in C and C++ programming only).

Properties Inherited from FPCPersist

Name | Description
PersistentName | Gets the persistent name of the object. The persistent name of an object is a name that is unique for the object at the respective level of the COM object hierarchy.
VendorParametersSets | Gets an FPCVendorParametersSets collection that can hold sets of custom data for extending the object.

Remarks

This object implements the IFPCServer interface.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

COM Objects


IFPCServer | FPCServer ActivateRASServerOnDomain method [ISA Server 2004]

IFPCServer::ActivateRASServerOnDomain[C++]

FPCServer.ActivateRASServerOnDomain [Visual Basic]

[C++]

The ActivateRASServerOnDomain method adds or removes the server from the RAS and IAS Servers groups on the domain controller.

HRESULT ActivateRASServerOnDomain(
  VARIANT_BOOL fActivate
);

Parameters

fActivate
[in] Boolean value that should be set to VARIANT_TRUE if the method is called to add the server to the RAS and IAS Servers groups on the domain controller, or to VARIANT_FALSE if the method is called to remove the server from the RAS and IAS Servers groups on the domain controller.

Return Values

This method returns S_OK if the call is successful; otherwise, it returns an error code.

If this method is called on a computer that does not belong to a domain, it returns E_FPC_SERVER_NOT_JOINED_TO_DOMAIN.

[Visual Basic]

The ActivateRASServerOnDomain method adds or removes the server from the RAS and IAS Servers groups on the domain controller.

Sub ActivateRASServerOnDomain( _
  ByVal fActivate As Boolean _
)

Parameters

fActivate
[in] Boolean value that should be set to True if the method is called to add the server to the RAS and IAS Servers groups on the domain controller, or to False if the method is called to remove the server from the RAS and IAS Servers groups on the domain controller.

Return Values

This method has no return values. If the call is unsuccessful, an error is raised that can be intercepted by using an error handler.

If this method is called on a computer that does not belong to a domain, it raises an E_FPC_SERVER_NOT_JOINED_TO_DOMAIN error.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCServer


IFPCServer | FPCServer Adapters(IFPCAdapters) property [ISA Server 2004]

Adapters Property of IFPCServer[C++]

FPCServer.Adapters [Visual Basic]

[C++]

The Adapters property gets an FPCAdapters collection that contains objects representing the available network adapters on the server.

HRESULT get_Adapters(
  IFPCAdapters** ppAdapters
);

Parameters

ppAdapters
Address of an interface pointer that on return points to the IFPCAdapters interface that represents the collection of available network adapters on the server.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The Adapters property gets an FPCAdapters collection that contains objects representing the available network adapters on the server.

Property Adapters As FPCAdapters

Property Value

Reference to the FPCAdapters collection for the server.

Remarks

This property is read-only.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCServer


IFPCServer | FPCServer CacheDrives(IFPCCacheDrives) property [ISA Server 2004]

CacheDrives Property of IFPCServer[C++]

FPCServer.CacheDrives [Visual Basic]

[C++]

The CacheDrives property gets an FPCCacheDrives collection that contains objects representing the cache drives on the server.

HRESULT get_CacheDrives(
  IFPCCacheDrives** ppCacheDrives
);

Parameters

ppCacheDrives
Address of an interface pointer that on return points to the IFPCCacheDrives interface representing the collection of cache drives on the server.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The CacheDrives property gets an FPCCacheDrives collection that contains objects representing the cache drives on the server.

Property CacheDrives As FPCCacheDrives

Property Value

Reference to the FPCCacheDrives collection for the server.

Remarks

This property is read-only.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCServer


IFPCServer | FPCServer ConnectivityResults property [ISA Server 2004]

ConnectivityResults Property of IFPCServer[C++]

FPCServer.ConnectivityResults [Visual Basic]

[C++]

The ConnectivityResults property gets the FPCConnectivityResults collection for the server. Each FPCConnectivityResult object in the collection represents the results of a connectivity verification attempt by an FPCConnectivityVerifier object.

HRESULT get_ConnectivityResults(
  IFPCConnectivityResults** ppConnectivityResults
);

Parameters

ppConnectivityResults
Address of an interface pointer that on return points to the IFPCConnectivityResults interface for the server.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The ConnectivityResults property gets the FPCConnectivityResults collection for the server. Each FPCConnectivityResult object in the collection represents the results of a connectivity verification attempt by an FPCConnectivityVerifier object.

Property ConnectivityResults As FPCConnectivityResults

Property Value

Reference to the FPCConnectivityResults collection for the server.

Remarks

This property is read-only.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCServer


IFPCServer | FPCServer CreatedTime(DATE) property [ISA Server 2004]

CreatedTime Property of IFPCServer[C++]

FPCServer.CreatedTime [Visual Basic]

[C++]

The CreatedTime property gets a DATE value that specifies the date and time in Coordinated Universal Time (UTC) when the object was created.

HRESULT get_CreatedTime(
  DATE* pdCreatedTime
);

Parameters

pdCreatedTime
Pointer to a DATE that is set on return to the value specifying the date and time in Coordinated Universal Time (UTC) when the object was created.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The CreatedTime property gets a Date value that specifies the date and time in Coordinated Universal Time (UTC) when the object was created.

Property CreatedTime As Date

Property Value

Date value that specifies the date and time in Coordinated Universal Time (UTC) when the object was created.

Remarks

This property is read-only.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCServer


IFPCServer | FPCServer Description(BSTR,BSTR) property [ISA Server 2004]

Description Property of IFPCServer[C++]

FPCServer.Description [Visual Basic]

[C++]

The Description property gets or sets the description server.

HRESULT get_Description(
  BSTR* pbstrDescription
);

HRESULT put_Description(
  BSTR bstrDescription
);

Parameters

pbstrDescription
Pointer to a BSTR that is set on return to a string value specifying the description of the server.
bstrDescription
BSTR that specifies the description of the server.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write.

[Visual Basic]

The Description property gets or sets the description server.

Property Description As String

Property Value

String that specifies the description of the server.

Remarks

This property is read/write.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCServer


IFPCServer | FPCServer DialupNetworkConnections property [ISA Server 2004]

DialupNetworkConnections Property of IFPCServer[C++]

FPCServer.DialupNetworkConnections [Visual Basic]

[C++]

The DialupNetworkConnections property gets an FPCDialupNetworkConnections collection that holds the names of the dial-up network connections that have been set up on the server.

HRESULT get_DialupNetworkConnections(
  IFPCDialupNetworkConnections** ppDialupNetworkConnections
);

Parameters

ppDialupNetworkConnections
Address of an interface pointer that on return points to the IFPCDialupNetworkConnections interface representing the collection of dial-up network connections that have been set up on the server.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The DialupNetworkConnections property gets an FPCDialupNetworkConnections collection that holds the names of the dial-up network connections that have been set up on the server.

Property DialupNetworkConnections As FPCDialupNetworkConnections

Property Value

Reference to an FPCDialupNetworkConnections collection that holds the names of the dial-up network connections that have been set up on the server.

Remarks

This property is read-only.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCServer


IFPCServer | FPCServer DiskDrives(IFPCDiskDrives) property [ISA Server 2004]

DiskDrives Property of IFPCServer[C++]

FPCServer.DiskDrives [Visual Basic]

[C++]

The DiskDrives property gets an FPCDiskDrives collection that contains objects representing the disk drives on the server.

HRESULT get_DiskDrives(
  IFPCDiskDrives** ppDiskDrives
);

Parameters

ppDiskDrives
Address of an interface pointer that on return points to an IFPCDiskDrives interface that represents the collection of disk drives for the server.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The DiskDrives property gets an FPCDiskDrives collection that contains objects representing the disk drives on the server.

Property DiskDrives As FPCDiskDrives

Property Value

Reference to the FPCDiskDrives collection for the server.

Remarks

This property is read-only.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCServer


IFPCServer | FPCServer FirewallClientSessionsCount property [ISA Server 2004]

FirewallClientSessionsCount Property of IFPCServer[C++]

FPCServer.FirewallClientSessionsCount [Visual Basic]

[C++]

The FirewallClientSessionsCount property gets the number of Firewall client sessions running on the server.

HRESULT get_FirewallClientSessionsCount(
  long* plCount
);

Parameters

plCount
Pointer to a variable that on return receives a 32-bit integer specifying the number of Firewall client sessions running on the server.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The FirewallClientSessionsCount property gets the number of Firewall client sessions running on the server.

Property FirewallClientSessionsCount As Long

Property Value

A 32-bit integer that specifies the number of Firewall client sessions running on the server.

Remarks

This property is read-only.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCServer


IFPCServer | FPCServer FirewallServiceStatus property [ISA Server 2004]

FirewallServiceStatus Property of IFPCServer[C++]

FPCServer.FirewallServiceStatus [Visual Basic]

[C++]

The FirewallServiceStatus property gets a Boolean value that indicates whether the Microsoft Firewall service is running.

HRESULT get_FirewallServiceStatus(
  VARIANT_BOOL* pfFirewallServiceStatus
);

Parameters

pfFirewallServiceStatus
Pointer to a Boolean variable that is set on return to VARIANT_TRUE if the Firewall service is running, or to VARIANT_FALSE if the rule is disabled, and the Firewall service is not running.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The FirewallServiceStatus property gets a Boolean value that indicates whether the Microsoft Firewall service is running.

Property FirewallServiceStatus As Boolean

Property Value

Boolean value that indicates whether the Firewall service is running.

Remarks

This property is read-only.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCServer


IFPCServer | FPCServer FirewallServiceUpTime(long) property [ISA Server 2004]

FirewallServiceUpTime Property of IFPCServer[C++]

FPCServer.FirewallServiceUpTime [Visual Basic]

[C++]

The FirewallServiceUpTime property gets the number of seconds that the Microsoft Firewall service has been working properly on the server.

HRESULT get_FirewallServiceUpTime(
  long* plSeconds
);

Parameters

plSeconds
Pointer to a variable that on return receives a 32-bit integer specifying the number of seconds that the Firewall service has been working properly on the server.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The FirewallServiceUpTime property gets the number of seconds that the Microsoft Firewall service has been working properly on the server.

Property FirewallServiceUpTime As Long

Property Value

A 32-bit integer value that specifies the number of seconds that the Firewall service has been working properly on the server.

Remarks

This property is read-only.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCServer


IFPCServer | FPCServer FQDN(BSTR) property [ISA Server 2004]

FQDN Property of IFPCServer[C++]

FPCServer.FQDN [Visual Basic]

[C++]

The FQDN property gets the fully qualified domain name (FQDN) of the server.

HRESULT get_FQDN(
  BSTR* pbstrFQDN
);

Parameters

pbstrFQDN
Pointer to a BSTR that is set on return to a string value specifying the FQDN of the server.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The FQDN property gets the fully qualified domain name (FQDN) of the server.

Property FQDN As String

Property Value

String that specifies the FQDN of the server.

Remarks

This property is read-only.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCServer


IFPCServer | FPCServer InstallationDirectory(BSTR) property [ISA Server 2004]

InstallationDirectory Property of IFPCServer[C++]

FPCServer.InstallationDirectory [Visual Basic]

[C++]

The InstallationDirectory property gets the ISA Server installation directory on the server.

HRESULT get_InstallationDirectory(
  BSTR* pbstrInstallationDirectory
);

Parameters

pbstrInstallationDirectory
Pointer to a BSTR that is set on return to a string value specifying the ISA Server installation directory on the server.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The InstallationDirectory property gets the ISA Server installation directory on the server.

Property InstallationDirectory As String

Property Value

String that specifies the ISA Server installation directory on the server.

Remarks

This property is read-only.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCServer


IFPCServer | FPCServer JobSchedulerServiceStatus property [ISA Server 2004]

JobSchedulerServiceStatus Property of IFPCServer[C++]

FPCServer.JobSchedulerServiceStatus [Visual Basic]

[C++]

The JobSchedulerServiceStatus property gets a Boolean value that indicates whether the Microsoft ISA Server Job Scheduler service is running on the server.

HRESULT get_JobSchedulerServiceStatus(
  VARIANT_BOOL* pfJobSchedulerServiceStatus
);

Parameters

pfJobSchedulerServiceStatus
Pointer to a Boolean variable that is set on return to VARIANT_TRUE if the Job Scheduler service is running on the server, or to VARIANT_FALSE if the Job Scheduler service is not running on the server.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The JobSchedulerServiceStatus property gets a Boolean value that indicates whether the Microsoft ISA Server Job Scheduler service is running on the server.

Property JobSchedulerServiceStatus As Boolean

Property Value

Boolean value that indicates whether the Job Scheduler service is running on the server.

Remarks

This property is read-only.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCServer


IFPCServer | FPCServer JobSchedulerServiceUpTime property [ISA Server 2004]

JobSchedulerServiceUpTime Property of IFPCServer[C++]

FPCServer.JobSchedulerServiceUpTime [Visual Basic]

[C++]

The JobSchedulerServiceUpTime property gets the number of seconds that the Microsoft ISA Server Job Scheduler service has been working properly on the server.

HRESULT get_JobSchedulerServiceUpTime(
  long* plSeconds
);

Parameters

plSeconds
Pointer to a variable that on return receives a 32-bit integer specifying the number of seconds that the Job Scheduler service has been working properly on the server.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The JobSchedulerServiceUpTime property gets the number of seconds that the Microsoft ISA Server Job Scheduler service has been working properly on the server.

Property JobSchedulerServiceUpTime As Long

Property Value

A 32-bit integer value that specifies the number of seconds that the Job Scheduler service has been working properly on the server.

Remarks

This property is read-only.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCServer


IFPCServer | FPCServer LastModifiedTime(DATE) property [ISA Server 2004]

LastModifiedTime Property of IFPCServer[C++]

FPCServer.LastModifiedTime [Visual Basic]

[C++]

The LastModifiedTime property gets a DATE value that specifies the date and time in Coordinated Universal Time (UTC) when the object was last modified.

HRESULT get_LastModifiedTime(
  DATE* pdLastModifiedTime
);

Parameters

pdLastModifiedTime
Pointer to a DATE that is set on return to the value specifying the date and time in Coordinated Universal Time (UTC) when the object was last modified.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The LastModifiedTime property gets a Date value that specifies the date and time in Coordinated Universal Time (UTC) when the object was last modified.

Property LastModifiedTime As Date

Property Value

Date value that specifies the date and time in Coordinated Universal Time (UTC) when the object was last modified.

Remarks

This property is read-only.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCServer


IFPCServer | FPCServer LoadFactor(long,long) property [ISA Server 2004]

LoadFactor Property of IFPCServer[C++]

FPCServer.LoadFactor [Visual Basic]

[C++]

The LoadFactor property gets or sets the load factor of the server. A load factor is a relative number that assigns more traffic to servers that are able to handle more requests.

HRESULT get_LoadFactor(
  long* plLoadFactor
);

HRESULT put_LoadFactor(
  long lLoadFactor
);

Parameters

plLoadFactor
Pointer to a variable that on return receives a 32-bit integer specifying the load factor.
lLoadFactor
A 32-bit integer that specifies the load factor.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write.

[Visual Basic]

The LoadFactor property gets or sets the load factor of the server. A load factor is a relative number that assigns more traffic to servers that are able to handle more requests.

Property LoadFactor As Long

Property Value

A 32-bit integer that specifies the load factor.

Remarks

This property is read/write.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCServer


IFPCServer | FPCServer MSDEServiceStatus property [ISA Server 2004]

MSDEServiceStatus Property of IFPCServer[C++]

FPCServer.MSDEServiceStatus [Visual Basic]

[C++]

The MSDEServiceStatus property gets a Boolean value that indicates whether the Microsoft Data Engine (MSDE) service is running.

HRESULT get_MSDEServiceStatus(
  VARIANT_BOOL* pfMSDEServiceStatus
);

Parameters

pfMSDEServiceStatus
Pointer to a Boolean variable that is set on return to VARIANT_TRUE if the MSDE service is running, or to VARIANT_FALSE if the rule is disabled, and the MSDE service is not running.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The MSDEServiceStatus property gets a Boolean value that indicates whether the Microsoft Data Engine (MSDE) service is running.

Property MSDEServiceStatus As Boolean

Property Value

Boolean value that indicates whether the MSDE service is running.

Remarks

This property is read-only.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCServer


IFPCServer | FPCServer Name(BSTR) property [ISA Server 2004]

Name Property of IFPCServer[C++]

FPCServer.Name [Visual Basic]

[C++]

The Name property gets the name of the server.

HRESULT get_Name(
  BSTR* pbstrName
);

Parameters

pbstrName
Pointer to a BSTR that is set on return to a string value specifying the name of the server.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read-only.

[Visual Basic]

The Name property gets the name of the server.

Property Name As String

Property Value

String that specifies the name of the server.

Remarks

This property is read-only.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCServer


IFPCServer | FPCServer OperatingSystemMajorVersion property [ISA Server 2004]

OperatingSystemMajorVersion Property of IFPCServer[C++]

FPCServer.OperatingSystemMajorVersion [Visual Basic]

[C++]

The OperatingSystemMajorVersion property gets the major version number of the operating system installed on the server.

HRESULT get_OperatingSystemMajorVersion(
  long* plMajorVersion
);

Parameters

plMajorVersion
Pointer to a variable that on return receives a 32-bit integer specifying the major version number of the operating system installed on the server.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The OperatingSystemMajorVersion property gets the major version number of the operating system installed on the server.

Property OperatingSystemMajorVersion As Long

Property Value

A 32-bit integer that specifies the major version number of the operating system installed on the server.

Remarks

This property is read-only.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCServer


IFPCServer | FPCServer OperatingSystemMinorVersion property [ISA Server 2004]

OperatingSystemMinorVersion Property of IFPCServer[C++]

FPCServer.OperatingSystemMinorVersion [Visual Basic]

[C++]

The OperatingSystemMinorVersion property gets the minor version number of the operating system installed on the server.

HRESULT get_OperatingSystemMinorVersion(
  long* plMinorVersion
);

Parameters

plMinorVersion
Pointer to a variable that on return receives a 32-bit integer specifying the minor version number of the operating system installed on the server.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The OperatingSystemMinorVersion property gets the minor version number of the operating system installed on the server.

Property OperatingSystemMinorVersion As Long

Property Value

A 32-bit integer that specifies the minor version number of the operating system installed on the server.

Remarks

This property is read-only.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCServer


IFPCServer | FPCServer OperatingSystemSuiteMask(long) property [ISA Server 2004]

OperatingSystemSuiteMask Property of IFPCServer[C++]

FPCServer.OperatingSystemSuiteMask [Visual Basic]

[C++]

The OperatingSystemSuiteMask property gets a bitmask that specifies the product suites available on the server.

HRESULT get_OperatingSystemSuiteMask(
  long* plProductSuites
);

Parameters

plProductSuites
Pointer to a 32-bit integer that is set on return to a bitmask specifying the product suites available on the server.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The OperatingSystemSuiteMask property gets a bitmask that specifies the product suites available on the server.

Property OperatingSystemSuiteMask As Long

Property Value

A 32-bit integer that is set to a bitmask specifying the product suites available on the server.

Remarks

This property is read-only.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCServer


IFPCServer | FPCServer ProductId(BSTR) property [ISA Server 2004]

ProductId Property of IFPCServer[C++]

FPCServer.ProductId [Visual Basic]

[C++]

The ProductId property gets the identifier (ID) of the product installed on the server.

HRESULT get_ProductId(
  BSTR* pbstrProductId
);

Parameters

pbstrProductId
Pointer to a BSTR that is set on return to a string value specifying the ID of the product installed on the server.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The ProductId property gets the identifier (ID) of the product installed on the server.

Property ProductId As String

Property Value

String that specifies the ID of the product installed on the server.

Remarks

This property is read-only.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCServer


IFPCServer | FPCServer ProductVersion(BSTR) property [ISA Server 2004]

ProductVersion Property of IFPCServer[C++]

FPCServer.ProductVersion [Visual Basic]

[C++]

The ProductVersion property gets the version of ISA Server installed on the server.

HRESULT get_ProductVersion(
  BSTR* pbstrVersion
);

Parameters

pbstrVersion
Pointer to a BSTR that is set on return to a string value specifying the version of ISA Server installed on the server.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The ProductVersion property gets the version of ISA Server installed on the server.

Property ProductVersion As String

Property Value

String that specifies the version of ISA Server installed on the server.

Remarks

This property is read-only.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCServer


IFPCServer.QuarantinedVPNConnectionsCount(long) property [ISA Server 2004]

QuarantinedVPNConnectionsCount Property of IFPCServer[C++]

FPCServer.QuarantinedVPNConnectionsCount [Visual Basic]

[C++]

The QuarantinedVPNConnectionsCount property gets the number of quarantined VPN connections running on the server.

HRESULT get_QuarantinedVPNConnectionsCount(
  long* plCount
);

Parameters

plCount
Pointer to a variable that on return receives a 32-bit integer specifying the number of quarantined VPN connections running on the server.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The QuarantinedVPNConnectionsCount property gets the number of quarantined VPN connections running on the server.

Property QuarantinedVPNConnectionsCount As Long

Property Value

A 32-bit integer that specifies the number of quarantined VPN connections running on the server.

Remarks

This property is read-only.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCServer


IFPCServer | FPCServer RemoteAccessServiceStatus property [ISA Server 2004]

RemoteAccessServiceStatus Property of IFPCServer[C++]

FPCServer.RemoteAccessServiceStatus [Visual Basic]

[C++]

The RemoteAccessServiceStatus property gets a Boolean value that indicates whether the Routing and Remote Access service is running on the server.

HRESULT get_RemoteAccessServiceStatus(
  VARIANT_BOOL* pfRemoteAccessServiceStatus
);

Parameters

pfRemoteAccessServiceStatus
Pointer to a Boolean variable that is set on return to VARIANT_TRUE if the Routing and Remote Access service is running on the server, or to VARIANT_FALSE if the Routing and Remote Access service is not running on the server.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The RemoteAccessServiceStatus property gets a Boolean value that indicates whether the Routing and Remote Access service is running on the server.

Property RemoteAccessServiceStatus As Boolean

Property Value

Boolean value that indicates whether the Routing and Remote Access service is running on the server.

Remarks

This property is read-only.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCServer


IFPCServer | FPCServer SecureNATSessionsCount(long) property [ISA Server 2004]

SecureNATSessionsCount Property of IFPCServer[C++]

FPCServer.SecureNATSessionsCount [Visual Basic]

[C++]

The SecureNATSessionsCount property gets the number of secure network address translation (SecureNAT) sessions running on the server.

HRESULT get_SecureNATSessionsCount(
  long* plCount
);

Parameters

plCount
Pointer to a variable that on return receives a 32-bit integer specifying the number of SecureNAT sessions running on the server.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The SecureNATSessionsCount property gets the number of secure network address translation (SecureNAT) sessions running on the server.

Property SecureNATSessionsCount As Long

Property Value

A 32-bit integer that specifies the number of SecureNAT sessions running on the server.

Remarks

This property is read-only.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCServer


IFPCServer | FPCServer ServerStatus(VARIANT_BOOL) property [ISA Server 2004]

ServerStatus Property of IFPCServer[C++]

FPCServer.ServerStatus [Visual Basic]

[C++]

The ServerStatus property gets a Boolean value that indicates whether the server is functioning.

HRESULT get_ServerStatus(
  VARIANT_BOOL* pfServerStatus
);

Parameters

pfServerStatus
Pointer to a Boolean variable that is set on return to VARIANT_TRUE if the server is functioning, or to VARIANT_FALSE if the server is not functioning.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The ServerStatus property gets a Boolean value that indicates whether the server is functioning.

Property ServerStatus As Boolean

Property Value

Boolean value that indicates whether the server is functioning.

Remarks

This property is read-only.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCServer


IFPCServer | FPCServer ServicePackMajorVersion(long) property [ISA Server 2004]

ServicePackMajorVersion Property of IFPCServer[C++]

FPCServer.ServicePackMajorVersion [Visual Basic]

[C++]

The ServicePackMajorVersion property gets the major version number of the latest service pack installed on the server.

HRESULT get_ServicePackMajorVersion(
  long* pVal
);

Parameters

pVal
Pointer to a variable that is set on return to a 32-bit integer specifying the major version number of the latest service pack installed on the server.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The ServicePackMajorVersion property gets the major version number of the latest service pack installed on the server.

Property ServicePackMajorVersion As Long

Property Value

A 32-bit integer that specifies the major version number of the latest service pack installed on the server.

Remarks

This property is read-only.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCServer


IFPCServer | FPCServer ServicePackMinorVersion(long) property [ISA Server 2004]

ServicePackMinorVersion Property of IFPCServer[C++]

FPCServer.ServicePackMinorVersion [Visual Basic]

[C++]

The ServicePackMinorVersion property gets the minor version number of the latest service pack installed on the server.

HRESULT get_ServicePackMinorVersion(
  long* pVal
);

Parameters

pVal
Pointer to a variable that is set on return to a 32-bit integer specifying the minor version number of the latest service pack installed on the server.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The ServicePackMinorVersion property gets the minor version number of the latest service pack installed on the server.

Property ServicePackMinorVersion As Long

Property Value

A 32-bit integer that specifies the minor version number of the latest service pack installed on the server.

Remarks

This property is read-only.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCServer


IFPCServer | FPCServer SignaledAlerts (1 Parameter) property [ISA Server 2004]

SignaledAlerts Property of IFPCServer[C++]

FPCServer.SignaledAlerts [Visual Basic]

[C++]

The SignaledAlerts property gets the FPCSignaledAlerts collection for the server.

HRESULT get_SignaledAlerts(
  IFPCSignaledAlerts** ppSignaledAlerts
);

Parameters

ppSignaledAlerts
Address of an interface pointer that on return points to the IFPCSignaledAlerts interface for the server.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The SignaledAlerts property gets the FPCSignaledAlerts collection for the server.

Property SignaledAlerts As FPCSignaledAlerts

Property Value

Reference to the FPCSignaledAlerts collection for the server.

Remarks

This property is read-only.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCServer


IFPCServer | FPCServer SiteToSiteVPNConnectionsCount property [ISA Server 2004]

SiteToSiteVPNConnectionsCount Property of IFPCServer[C++]

FPCServer.SiteToSiteVPNConnectionsCount [Visual Basic]

[C++]

The SiteToSiteVPNConnectionsCount property gets the number of site-to-site VPN connections running on the server.

HRESULT get_SiteToSiteVPNConnectionsCount(
  long* plCount
);

Parameters

plCount
Pointer to a variable that on return receives a 32-bit integer specifying the number of site-to-site VPN connections running on the server.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The SiteToSiteVPNConnectionsCount property gets the number of site-to-site VPN connections running on the server.

Property SiteToSiteVPNConnectionsCount As Long

Property Value

A 32-bit integer that specifies the number of site-to-site VPN connections running on the server.

Remarks

This property is read-only.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCServer


IFPCServer | FPCServer SSLClientCertificates property [ISA Server 2004]

SSLClientCertificates Property of IFPCServer[C++]

FPCServer.SSLClientCertificates [Visual Basic]

[C++]

The SSLClientCertificates property gets an FPCCertificates collection that contains objects representing the Secure Sockets Layer (SSL) client certificates available on the server.

HRESULT get_SSLClientCertificates(
  IFPCCertificates** ppClientCertificates
);

Parameters

ppClientCertificates
Address of an interface pointer that on return points to an IFPCCertificates interface that represents the collection of SSL client certificates available on the server.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The SSLClientCertificates property gets an FPCCertificates collection that contains objects representing the Secure Sockets Layer (SSL) client certificates available on the server.

Property SSLClientCertificates As FPCCertificates

Property Value

Reference to the FPCCertificates collection of SSL client certificates available on the server.

Remarks

This property is read-only.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCServer


IFPCServer | FPCServer SSLServerCertificates property [ISA Server 2004]

SSLServerCertificates Property of IFPCServer[C++]

FPCServer.SSLServerCertificates [Visual Basic]

[C++]

The SSLServerCertificates property gets an FPCCertificates collection that contains objects representing the Secure Sockets Layer (SSL) server certificates available on the server.

HRESULT get_SSLServerCertificates(
  IFPCCertificates** ppServerCertificates
);

Parameters

ppServerCertificates
Address of an interface pointer that on return points to an IFPCCertificates interface that represents the collection of SSL server certificates available on the server.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The SSLServerCertificates property gets an FPCCertificates collection that contains objects representing the Secure Sockets Layer (SSL) server certificates available on the server.

Property SSLServerCertificates As FPCCertificates

Property Value

Reference to the FPCCertificates collection of SSL server certificates available on the server.

Remarks

This property is read-only.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCServer


IFPCServer | FPCServer StartFirewallService(Boolean) method [ISA Server 2004]

IFPCServer::StartFirewallService[C++]

FPCServer.StartFirewallService [Visual Basic]

[C++]

The StartFirewallService method starts the Microsoft Firewall service on the server.

HRESULT StartFirewallService(
  VARIANT_BOOL fWaitUntilComplete
);

Parameters

fWaitUntilComplete
[in, optional] Boolean value that specifies whether the method waits for the operation to complete before returning S_OK or an error. The default value is VARIANT_FALSE.

Return Values

This method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

Call the StopFirewallService method to stop the Firewall service on the server.

[Visual Basic]

The StartFirewallService method starts the Microsoft Firewall service on the server.

Sub StartFirewallService( _
  [ ByVal fWaitUntilComplete As Boolean ] _
)

Parameters

fWaitUntilComplete
[in, optional] Boolean value that specifies whether the method waits for the operation to complete before returning or raising an error. The default value is False.

Return Values

This method has no return values. If the call is unsuccessful, an error is raised that can be intercepted by using an error handler.

Remarks

Call the StopFirewallService method to stop the Firewall service on the server.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCServer


IFPCServer | FPCServer StartJobSchedulerService method [ISA Server 2004]

IFPCServer::StartJobSchedulerService[C++]

FPCServer.StartJobSchedulerService [Visual Basic]

[C++]

The StartJobSchedulerService method starts the Microsoft ISA Server Job Scheduler service on the server.

HRESULT StartJobSchedulerService(
  VARIANT_BOOL fWaitUntilComplete
);

Parameters

fWaitUntilComplete
[in, optional] Boolean value that specifies whether the method waits for the operation to complete before returning S_OK or an error. The default value is VARIANT_TRUE.

Return Values

This method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

The Microsoft ISA Server Job Scheduler service can be stopped on the server by calling the StopJobSchedulerService method.

[Visual Basic]

The StartJobSchedulerService method starts the Microsoft ISA Server Job Scheduler service on the server.

Sub StartJobSchedulerService( _
  [ ByVal fWaitUntilComplete As Boolean ] _
)

Parameters

fWaitUntilComplete
[in, optional] Boolean value that specifies whether the method waits for the operation to complete before returning or raising an error. The default value is True.

Return Values

This method has no return values. If the call is unsuccessful, an error is raised that can be intercepted by using an error handler.

Remarks

The Microsoft ISA Server Job Scheduler service can be stopped on the server by calling the StopJobSchedulerService method.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCServer


IFPCServer | FPCServer StartMSDEService(Boolean) method [ISA Server 2004]

IFPCServer::StartMSDEService[C++]

FPCServer.StartMSDEService [Visual Basic]

[C++]

The StartMSDEService method starts the Microsoft Data Engine (MSDE) service on the server.

HRESULT StartMSDEService(
  VARIANT_BOOL fWaitUntilComplete
);

Parameters

fWaitUntilComplete
[in, optional] Boolean value that specifies whether the method waits for the operation to complete before returning S_OK or an error. The default value is VARIANT_FALSE.

Return Values

This method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

Call the StopMSDEService method to stop the MSDE service on the server.

[Visual Basic]

The StartMSDEService method starts the Microsoft Data Engine (MSDE) service on the server.

Sub StartMSDEService( _
  [ ByVal fWaitUntilComplete As Boolean ] _
)

Parameters

fWaitUntilComplete
[in, optional] Boolean value that specifies whether the method waits for the operation to complete before returning or raising an error. The default value is False.

Return Values

This method has no return values. If the call is unsuccessful, an error is raised that can be intercepted by using an error handler.

Remarks

Call the StopMSDEService method to stop the MSDE service on the server.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCServer


IFPCServer | FPCServer StartRemoteAccessService method [ISA Server 2004]

IFPCServer::StartRemoteAccessService[C++]

FPCServer.StartRemoteAccessService [Visual Basic]

[C++]

The StartRemoteAccessService method starts the Routing and Remote Access service on the server.

HRESULT StartRemoteAccessService(
  VARIANT_BOOL fWaitUntilComplete
);

Parameters

fWaitUntilComplete
[in, optional] Boolean value that specifies whether the method waits for the operation to complete before returning S_OK or an error. The default value is VARIANT_FALSE.

Return Values

This method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

Call the StopRemoteAccessService method to stop the Routing and Remote Access service on the server.

[Visual Basic]

The StartRemoteAccessService method starts the Routing and Remote Access service on the server.

Sub StartRemoteAccessService( _
  [ ByVal fWaitUntilComplete As Boolean ] _
)

Parameters

fWaitUntilComplete
[in, optional] Boolean value that specifies whether the method waits for the operation to complete before returning or raising an error. The default value is False.

Return Values

This method has no return values. If the call is unsuccessful, an error is raised that can be intercepted by using an error handler.

Remarks

Call the StopRemoteAccessService method to stop the Routing and Remote Access service on the server.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCServer


IFPCServer | FPCServer StopFirewallService(Boolean) method [ISA Server 2004]

IFPCServer::StopFirewallService[C++]

FPCServer.StopFirewallService [Visual Basic]

[C++]

The StopFirewallService method stops the Microsoft Firewall service on the server.

HRESULT StopFirewallService(
  VARIANT_BOOL fWaitUntilComplete
);

Parameters

fWaitUntilComplete
[in, optional] Boolean value that specifies whether the method waits for the operation to complete before returning S_OK or an error. The default value is VARIANT_FALSE.

Return Values

This method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

Call the StartFirewallService method to start the Firewall service on the server.

[Visual Basic]

The StopFirewallService method stops the Microsoft Firewall service on the server.

Sub StopFirewallService( _
  [ ByVal fWaitUntilComplete As Boolean ] _
)

Parameters

fWaitUntilComplete
[in, optional] Boolean value that specifies whether the method waits for the operation to complete before returning or raising an error. The default value is False.

Return Values

This method has no return values. If the call is unsuccessful, an error is raised that can be intercepted by using an error handler.

Remarks

Call the StartFirewallService method to start the Firewall service on the server.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCServer


IFPCServer | FPCServer StopJobSchedulerService(Boolean) method [ISA Server 2004]

IFPCServer::StopJobSchedulerService[C++]

FPCServer.StopJobSchedulerService [Visual Basic]

[C++]

The StopJobSchedulerService method stops the Microsoft ISA Server Job Scheduler service on the server.

HRESULT StopJobSchedulerService(
  VARIANT_BOOL fWaitUntilComplete
);

Parameters

fWaitUntilComplete
[in, optional] Boolean value that specifies whether the method waits for the operation to complete before returning S_OK or an error. The default value is VARIANT_TRUE.

Return Values

This method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

The Microsoft ISA Server Job Scheduler service can be started on the server by calling the StartJobSchedulerService method.

[Visual Basic]

The StopJobSchedulerService method stops the Microsoft ISA Server Job Scheduler service on the server.

Sub StopJobSchedulerService( _
  [ ByVal fWaitUntilComplete As Boolean ] _
)

Parameters

fWaitUntilComplete
[in, optional] Boolean value that specifies whether the method waits for the operation to complete before returning or raising an error. The default value is True.

Return Values

This method has no return values. If the call is unsuccessful, an error is raised that can be intercepted by using an error handler.

Remarks

The Microsoft ISA Server Job Scheduler service can be started on the server by calling the StartJobSchedulerService method.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCServer


IFPCServer | FPCServer StopMSDEService(Boolean) method [ISA Server 2004]

IFPCServer::StopMSDEService[C++]

FPCServer.StopMSDEService [Visual Basic]

[C++]

The StopMSDEService method stops the Microsoft Data Engine (MSDE) service on the server.

HRESULT StopMSDEService(
  VARIANT_BOOL fWaitUntilComplete
);

Parameters

fWaitUntilComplete
[in, optional] Boolean value that specifies whether the method waits for the operation to complete before returning S_OK or an error. The default value is VARIANT_FALSE.

Return Values

This method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

Call the StartMSDEService method to start the MSDE service on the server.

[Visual Basic]

The StopMSDEService method stops the Microsoft Data Engine (MSDE) service on the server.

Sub StopMSDEService( _
  [ ByVal fWaitUntilComplete As Boolean ] _
)

Parameters

fWaitUntilComplete
[in, optional] Boolean value that specifies whether the method waits for the operation to complete before returning or raising an error. The default value is False.

Return Values

This method has no return values. If the call is unsuccessful, an error is raised that can be intercepted by using an error handler.

Remarks

Call the StartMSDEService method to start the MSDE service on the server.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCServer


IFPCServer | FPCServer StopRemoteAccessService(Boolean) method [ISA Server 2004]

IFPCServer::StopRemoteAccessService[C++]

FPCServer.StopRemoteAccessService [Visual Basic]

[C++]

The StopRemoteAccessService method stops the Routing and Remote Access service on the server.

HRESULT StopRemoteAccessService(
  VARIANT_BOOL fWaitUntilComplete
);

Parameters

fWaitUntilComplete
[in, optional] Boolean value that specifies whether the method waits for the operation to complete before returning S_OK or an error. The default value is VARIANT_FALSE.

Return Values

This method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

Call the StartRemoteAccessService method to start the Routing and Remote Access service on the server.

[Visual Basic]

The StopRemoteAccessService method stops the Routing and Remote Access service on the server.

Sub StopRemoteAccessService( _
  [ ByVal fWaitUntilComplete As Boolean ] _
)

Parameters

fWaitUntilComplete
[in, optional] Boolean value that specifies whether the method waits for the operation to complete before returning or raising an error. The default value is False.

Return Values

This method has no return values. If the call is unsuccessful, an error is raised that can be intercepted by using an error handler.

Remarks

Call the StartRemoteAccessService method to start the Routing and Remote Access service on the server.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCServer


IFPCServer | FPCServer TrustedRootCertificates property [ISA Server 2004]

TrustedRootCertificates Property of IFPCServer[C++]

FPCServer.TrustedRootCertificates [Visual Basic]

[C++]

The TrustedRootCertificates property gets an FPCCertificates collection that contains objects representing the trusted root certificates available on the server.

HRESULT get_TrustedRootCertificates(
  IFPCCertificates** ppTrustedRootCertificates
);

Parameters

ppTrustedRootCertificates
Address of an interface pointer that on return points to an IFPCCertificates interface that represents the collection of trusted root certificates available on the server.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The TrustedRootCertificates property gets an FPCCertificates collection that contains objects representing the trusted root certificates available on the server.

Property TrustedRootCertificates As FPCCertificates

Property Value

Reference to the FPCCertificates collection of trusted root certificates available on the server.

Remarks

This property is read-only.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCServer


IFPCServer | FPCServer VPNDisconnect(String) method [ISA Server 2004]

IFPCServer::VPNDisconnect[C++]

FPCServer.VPNDisconnect [Visual Basic]

[C++]

The VPNDisconnect method disconnects the VPN connection between the specified remote IP address and the server.

HRESULT VPNDisconnect(
  BSTR RemoteIPAddress
);

Parameters

RemoteIPAddress
[in] String that specifies the remote IP address for the VPN connection.

Return Values

This method returns S_OK if the call is successful; otherwise, it returns an error code.
[Visual Basic]

The VPNDisconnect method disconnects the VPN connection between the specified remote IP address and the server.

Sub VPNDisconnect( _
  ByVal RemoteIPAddress As String _
)

Parameters

RemoteIPAddress
[in] String that specifies the remote IP address for the VPN connection.

Return Values

This method has no return values. If the call is unsuccessful, an error is raised that can be intercepted by using an error handler.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCServer


IFPCServer | FPCServer VPNConnectionsCount(long) property [ISA Server 2004]

VPNConnectionsCount Property of IFPCServer[C++]

FPCServer.VPNConnectionsCount [Visual Basic]

[C++]

The VPNConnectionsCount property gets the number of VPN connections running on the server.

HRESULT get_VPNConnectionsCount(
  long* plCount
);

Parameters

plCount
Pointer to a variable that on return receives a 32-bit integer specifying the number of VPN connections running on the server.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The VPNConnectionsCount property gets the number of VPN connections running on the server.

Property VPNConnectionsCount As Long

Property Value

A 32-bit integer that specifies the number of VPN connections running on the server.

Remarks

This property is read-only.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCServer


IFPCServer | FPCServer VpnStaticAddressPool property [ISA Server 2004]

VpnStaticAddressPool Property of IFPCServer[C++]

FPCServer.VpnStaticAddressPool [Visual Basic]

[C++]

The VpnStaticAddressPool property gets an FPCReadOnlyIpRangeSet collection that contains objects representing the IP address ranges comprising the VPN static address pool for the server. The VPN static address pool contains the IP addresses that ISA Server can assign to a VPN client when it connects to the server.

HRESULT get_VpnStaticAddressPool(
  IFPCReadOnlyIpRangeSet** ppVpnStaticAddressPool
);

Parameters

ppVpnStaticAddressPool
Address of an interface pointer that on return points to the IFPCReadOnlyIpRangeSet interface that represents the VPN static address pool for the server.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The VpnStaticAddressPool property gets an FPCReadOnlyIpRangeSet collection that contains objects representing the IP address ranges comprising the VPN static address pool for the server. The VPN static address pool contains the IP addresses that ISA Server can assign to a VPN client when it connects to the server.

Property VpnStaticAddressPool As FPCReadOnlyIpRangeSet

Property Value

Reference to the FPCReadOnlyIpRangeSet collection that represents the VPN static address pool for the server.

Remarks

This property is read-only.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCServer


IFPCServer | FPCServer WebProxySessionsCount(long) property [ISA Server 2004]

WebProxySessionsCount Property of IFPCServer[C++]

FPCServer.WebProxySessionsCount [Visual Basic]

[C++]

The WebProxySessionsCount property gets the number of the ISA Server Web proxy sessions running on the server.

HRESULT get_WebProxySessionsCount(
  long* plCount
);

Parameters

plCount
Pointer to a variable that on return receives a 32-bit integer specifying the number of the Web proxy sessions running on the server.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The WebProxySessionsCount property gets the number of the ISA Server Web proxy sessions running on the server.

Property WebProxySessionsCount As Long

Property Value

A 32-bit integer value that specifies the number of the Web proxy sessions running on the server.

Remarks

This property is read-only.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCServer


FPCServerPublishingProperties object [ISA Server 2004]

FPCServerPublishingProperties

The FPCServerPublishingProperties object represents the properties of a policy rule that was created as a server publishing rule using the AddServerPublishingRule method. It also provides a method for setting the published protocol of the rule.

This object can be accessed through the ServerPublishingProperties property of an FPCPolicyRule object representing a server publishing rule.

Click here to see the ISA Server object hierarchy.

Methods

The FPCServerPublishingProperties object defines the following method.

Method | Description
SetPublishedProtocol | Sets the published protocol of the rule.

Properties

The FPCServerPublishingProperties object has the following properties.

Property | Description
IPsOnNetworks | Gets an FPCIPsOnNetworks collection that contains the IP addresses on which the ISA Server computer listens for requests from particular networks on behalf of the server published by the rule.
IPsOnNetworkSets | Gets an FPCRefs collection that contains references to the network sets from which the ISA Server computer listens for requests on behalf of the server published by the rule.
OverridePublishPort | Gets or sets the port number for overriding the default port on which the ISA Server computer will listen for requests on behalf of the server published by the rule.
OverrideServerPort | Gets or sets the port number for overriding the default port on the server published by the rule to which the ISA Server computer will forward requests.
PublishedProtocol | Gets an FPCRef object that references the published protocol of the rule.
PublishedServerIP | Gets or sets the IP address of the published server to which the rule applies.
UseFirewallIPAsSource | Gets or sets a Boolean value that indicates whether the IP address on which the ISA Server computer received a request on behalf of the server published by the rule will be used as the source IP address when the request is forwarded to the published server.

Remarks

This object implements the IFPCServerPublishingProperties interface.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

COM Objects


IFPCServerPublishingProperties.IPsOnNetworks property [ISA Server 2004]

IPsOnNetworks Property of IFPCServerPublishingProperties[C++]

FPCServerPublishingProperties.IPsOnNetworks [Visual Basic]

[C++]

The IPsOnNetworks property gets an FPCIPsOnNetworks collection that contains the IP addresses on which the ISA Server computer listens for requests from particular networks on behalf of the server published by the rule.

HRESULT get_IPsOnNetworks(
  IFPCIPsOnNetworks** ppIPsOnNetworks
);

Parameters

ppIPsOnNetworks
Address of an interface pointer that on return points to an IFPCIPsOnNetworks interface that represents the collection of IP addresses on which the ISA Server computer listens for requests from particular networks on behalf of the server published by the rule.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only. It can be modified by calling the methods of the IFPCIPsOnNetworks interface.

[Visual Basic]

The IPsOnNetworks property gets an FPCIPsOnNetworks collection that contains the IP addresses on which the ISA Server computer listens for requests from particular networks on behalf of the server published by the rule.

Property IPsOnNetworks As FPCIPsOnNetworks

Property Value

Reference to an FPCIPsOnNetworks collection that contains the IP addresses on which the ISA Server computer listens for requests from particular networks on behalf of the server published by the rule.

Remarks

This property is read-only. It can be modified by calling the methods of the FPCIPsOnNetworks collection.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCServerPublishingProperties


IFPCServerPublishingProperties.IPsOnNetworkSets property [ISA Server 2004]

IPsOnNetworkSets Property of IFPCServerPublishingProperties[C++]

FPCServerPublishingProperties.IPsOnNetworkSets [Visual Basic]

[C++]

The IPsOnNetworkSets property gets an FPCRefs collection that contains references to the network sets from which the ISA Server computer listens for requests on behalf of the server published by the rule.

HRESULT get_IPsOnNetworkSets(
  IFPCRefs** ppRefs
);

Parameters

ppRefs
Address of an interface pointer that on return points to an IFPCRefs interface that represents the collection of references to the network sets from which the ISA Server computer listens for requests on behalf of the server published by the rule.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only. It can be modified by calling the methods of the IFPCRefs interface.

[Visual Basic]

The IPsOnNetworkSets property gets an FPCRefs collection that contains references to the network sets from which the ISA Server computer listens for requests on behalf of the server published by the rule.

Property IPsOnNetworkSets As FPCRefs

Property Value

An FPCRefs collection that contains references to the network sets from which the ISA Server computer listens for requests on behalf of the server published by the rule.

Remarks

This property is read-only. It can be modified by calling the methods of the FPCRefs collection.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCServerPublishingProperties


IFPCServerPublishingProperties.OverridePublishPort property [ISA Server 2004]

OverridePublishPort Property of IFPCServerPublishingProperties[C++]

FPCServerPublishingProperties.OverridePublishPort [Visual Basic]

[C++]

The OverridePublishPort property gets or sets the port number for overriding the default port on which the ISA Server computer will listen for requests on behalf of the server published by the rule. The default port is specified in the PrimaryConnections property of the FPCProtocolDefinition object for the protocol specified in the PublishedProtocol property. If the value of the OverridePublishPort property is nonzero and if the protocol definition specifies only a single port for primary connections, this value will override the default port number. If the protocol definition specifies multiple ports for primary connections, these ports cannot be overridden, and the value of the OverridePublishPort property must be set to zero.

HRESULT get_OverridePublishPort(
  long* plPublishPort
);

HRESULT put_OverridePublishPort(
  long lPublishPort
);

Parameters

plPublishPort
Pointer to a 32-bit integer that is set on return to the port number for overriding the default port on which the ISA Server computer listens for requests on behalf of the server published by the rule, or to 0 if the the default port should not be overridden.
lPublishPort
A 32-bit integer that specifies the port number for overriding the default port on which the ISA Server computer listens for requests on behalf of the server published by the rule.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write. Its default value is 0.

If the value of this property is 0, the default port number assigned to the published protocol is used.

[Visual Basic]

The OverridePublishPort property gets or sets the port number for overriding the default port on which the ISA Server computer will listen for requests on behalf of the server published by the rule. The default port is specified in the PrimaryConnections property of the FPCProtocolDefinition object for the protocol specified in the PublishedProtocol property. If the value of the OverridePublishPort property is nonzero and if the protocol definition specifies only a single port for primary connections, this value will override the default port number. If the protocol definition specifies multiple ports for primary connections, these ports cannot be overridden, and the value of the OverridePublishPort property must be set to zero.

Property OverridePublishPort As Long

Property Value

A 32-bit integer that specifies the port number for overriding the default port on which the ISA Server computer listens for requests on behalf of the server published by the rule.

Remarks

This property is read/write. Its default value is 0.

If the value of this property is 0, the default port number assigned to the published protocol is used.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCServerPublishingProperties


IFPCServerPublishingProperties.OverrideServerPort property [ISA Server 2004]

OverrideServerPort Property of IFPCServerPublishingProperties[C++]

FPCServerPublishingProperties.OverrideServerPort [Visual Basic]

[C++]

The OverrideServerPort property gets or sets the port number for overriding the default port on the server published by the rule to which the ISA Server computer will forward requests. The default port is specified in the PrimaryConnections property of the FPCProtocolDefinition object for the protocol specified in the PublishedProtocol property. If the value of the OverrideServerPort property is nonzero and if the protocol definition specifies only a single port for primary connections, this value will override the default port number. If the protocol definition specifies multiple ports for primary connections, these ports cannot be overridden, and the value of the OverrideServerPort property must be set to zero.

HRESULT get_OverrideServerPort(
  long* plServerPort
);

HRESULT put_OverrideServerPort(
  long lServerPort
);

Parameters

plServerPort
Pointer to a 32-bit integer that is set on return to the port number for overriding the default port on the server published by the rule to which the ISA Server computer will forward requests, or to 0 if the the default port should not be overridden.
lServerPort
A 32-bit integer that specifies the port number for overriding the default port on the server published by the rule to which the ISA Server computer will forward requests.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write. Its default value is 0.

If the value of this property is 0, the default port number assigned to the published protocol is used.

[Visual Basic]

The OverrideServerPort property gets or sets the port number for overriding the default port on the server published by the rule to which the ISA Server computer will forward requests. The default port is specified in the PrimaryConnections property of the FPCProtocolDefinition object for the protocol specified in the PublishedProtocol property. If the value of the OverrideServerPort property is nonzero and if the protocol definition specifies only a single port for primary connections, this value will override the default port number. If the protocol definition specifies multiple ports for primary connections, these ports cannot be overridden, and the value of the OverrideServerPort property must be set to zero.

Property OverrideServerPort As Long

Property Value

A 32-bit integer that specifies the port number for overriding the default port on the server published by the rule to which the ISA Server computer will forward requests.

Remarks

This property is read/write. Its default value is 0.

If the value of this property is 0, the default port number assigned to the published protocol is used.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCServerPublishingProperties


IFPCServerPublishingProperties.PublishedProtocol property [ISA Server 2004]

PublishedProtocol Property of IFPCServerPublishingProperties[C++]

FPCServerPublishingProperties.PublishedProtocol [Visual Basic]

[C++]

The PublishedProtocol property gets an FPCRef object that references the FPCProtocolDefinition object defining the published protocol of the rule.

HRESULT get_PublishedProtocol(
  IFPCRef** ppRef
);

Parameters

ppRef
Address of an interface pointer that on return points to an IFPCRef interface that references the FPCProtocolDefinition object defining the published protocol of the rule.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only. The published protocol of the rule can be set by calling the SetPublishedProtocol method.

[Visual Basic]

The PublishedProtocol property gets an FPCRef object that references the FPCProtocolDefinition object defining the published protocol of the rule.

Property PublishedProtocol As FPCRef

Property Value

An FPCRef object that references the FPCProtocolDefinition object defining the published protocol of the rule.

Remarks

This property is read-only. The published protocol of the rule can be set by calling the SetPublishedProtocol method.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCServerPublishingProperties


IFPCServerPublishingProperties.PublishedServerIP property [ISA Server 2004]

PublishedServerIP Property of IFPCServerPublishingProperties[C++]

FPCServerPublishingProperties.PublishedServerIP [Visual Basic]

[C++]

The PublishedServerIP property gets or sets the IP address of the published server to which the rule applies.

HRESULT get_PublishedServerIP(
  BSTR* pbstrIP
);

HRESULT put_PublishedServerIP(
  BSTR bstrIP
);

Parameters

pbstrIP
Pointer to a BSTR that is set on return to the IP address of the published server to which the rule applies.
bstrIP
String value that specifies the IP address of the published server to which the rule applies.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write. Its value is initially set by the PublishedServerIP parameter of the AddServerPublishingRule method when the rule is created.

[Visual Basic]

The PublishedServerIP property gets or sets the IP address of the published server to which the rule applies.

Property PublishedServerIP As String

Property Value

String that specifies the IP address of the published server to which the rule applies.

Remarks

This property is read/write. Its value is initially set by the PublishedServerIP parameter of the AddServerPublishingRule method when the rule is created.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCServerPublishingProperties


IFPCServerPublishingProperties.SetPublishedProtocol method [ISA Server 2004]

IFPCServerPublishingProperties::SetPublishedProtocol[C++]

FPCServerPublishingProperties.SetPublishedProtocol [Visual Basic]

[C++]

The SetPublishedProtocol method sets the published protocol of the rule.

HRESULT SetPublishedProtocol(
  BSTR Name
);

Parameters

Name
[in] String value that specifies the published protocol of the rule.

Return Values

This method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This method is used to set the PublishedProtocol property.

[Visual Basic]

The SetPublishedProtocol method sets the published protocol of the rule.

Sub SetPublishedProtocol( _
  ByVal Name As String _
)

Parameters

Name
[in] String value that specifies the published protocol of the rule.

Return Values

This method has no return values. If the call is unsuccessful, an error is raised that can be intercepted by using an error handler.

Remarks

This method is used to set the PublishedProtocol property.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCServerPublishingProperties


IFPCServerPublishingProperties.UseFirewallIPAsSource property [ISA Server 2004]

UseFirewallIPAsSource Property of IFPCServerPublishingProperties[C++]

FPCServerPublishingProperties.UseFirewallIPAsSource [Visual Basic]

[C++]

The UseFirewallIPAsSource property gets or sets a Boolean value that indicates whether the IP address on which the ISA Server computer received a request on behalf of the server published by the rule will be used as the source IP address when the request is forwarded to the published server.

HRESULT get_UseFirewallIPAsSource(
  VARIANT_BOOL* pfUseFirewallIPAsSource
);

HRESULT put_UseFirewallIPAsSource(
  VARIANT_BOOL fUseFirewallIPAsSource
);

Parameters

pfUseFirewallIPAsSource
Pointer to a Boolean variable that is set on return to VARIANT_TRUE if the IP address on which the ISA Server computer received a request on behalf of the server published by the rule will be used as the source IP address when the request is forwarded to the server, or to VARIANT_FALSE if the original source IP address will be used.
fUseFirewallIPAsSource
Boolean value that indicates whether the IP address on which the ISA Server computer received a request on behalf of the server published by the rule will be used as the source IP address when the request is forwarded to the published server.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write. Its default value is VARIANT_FALSE.

[Visual Basic]

The UseFirewallIPAsSource property gets or sets a Boolean value that indicates whether the IP address on which the ISA Server computer received a request on behalf of the server published by the rule will be used as the source IP address when the request is forwarded to the published server.

Property UseFirewallIPAsSource As Boolean

Property Value

Boolean value that indicates whether the IP address on which the ISA Server computer received a request on behalf of the server published by the rule will be used as the source IP address when the request is forwarded to the published server.

Remarks

This property is read/write. Its default value is False.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCServerPublishingProperties


FPCServers collection [ISA Server 2004]

FPCServers Collection

The FPCServers collection holds a group of FPCServer objects. This collection represents all the servers within the current array. All settings that can be configured within each ISA Server computer can be accessed by using objects within this collection.

This collection is typically accessed through the Servers property of an FPCArray object.

Click here to see the ISA Server object hierarchy.

Inheritance

This collection inherits from the FPCPersist object, which contains methods and properties related to the persistent storage of an object's data. They include methods for exporting the object's data to and importing it from an XML document.

Methods

The FPCServers collection defines the following method.

Method | Description
Item | Retrieves the requested FPCServer object from the collection.

Properties

The FPCServers collection has the following properties.

Property | Description
_NewEnum | Gets an enumerator object for the collection.
Count | Gets the number of FPCServer objects in the collection.

Methods Inherited from FPCPersist

Name | Description
CancelWaitForChanges | Cancels the registration established by the WaitForChanges method (for use in C and C++ programming only).
CanImport | Returns a Boolean value that indicates whether the properties of the collection, its elements, and their subobjects can be imported from the specified XML document.
Export | Recursively writes the stored values of all the properties of the collection, its elements, and their subobjects to the specified XML document.
ExportToFile | Recursively writes the stored values of all the properties of the collection, its elements, and their subobjects to the specified XML file.
GetServiceRestartMask | Retrieves a 32-bit bitmask of the FpcServices enumerated type that specifies which services need to be restarted for currently unsaved changes to take effect.
Import | Recursively copies the values of all the properties of the collection, its elements, and their subobjects from the specified XML document to persistent storage.
ImportFromFile | Recursively copies the values of all the properties of the collection, its elements, and their subobjects from the specified XML file to persistent storage.
LoadDocProperties | Provides the XML document's properties so that you can know what information can be imported from the document.
Refresh | Recursively reads the values of all the properties of the collection, its elements, and their subobjects from persistent storage, overwriting any changes that have not been saved.
Save | Recursively writes the current values of all the properties of the collection, its elements, and their subobjects to persistent storage.
WaitForChanges | Registers to wait for an event indicating that the contents of the object have changed (for use in C and C++ programming only).

Properties Inherited from FPCPersist

Name | Description
PersistentName | Gets the persistent name of the collection. The persistent name of an object is a name that is unique for the object at the respective level of the COM object hierarchy.
VendorParametersSets | Gets an FPCVendorParametersSets collection that can hold sets of custom data for extending the collection.

Remarks

This collection implements the IFPCServers interface.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

COM Objects


IFPCServers | FPCServers _NewEnum(IUnknown) property [ISA Server 2004]

_NewEnum Property of IFPCServers[C++]

FPCServers._NewEnum [Visual Basic]

[C++]

The _NewEnum property gets an enumerator object for the collection. An enumerator object provides serial access to the elements of the collection.

HRESULT get__NewEnum(
  IUnknown* ppEnum
);

Parameters

ppEnum
Address of an interface pointer that on return points to the IUnknown interface of an enumerator object that implements an IEnumVARIANT interface for the collection. An interface pointer to the IEnumVARIANT interface of the enumerator object can be retrieved by calling QueryInterface on the IUnknown interface returned.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The _NewEnum property gets an enumerator object for the collection. An enumerator object provides serial access to the elements of the collection.

Property _NewEnum As IUnknown

Property Value

Reference to an enumerator object that provides serial access to the elements of the collection.

Remarks

This property is read-only.

In Visual Basic and VBScript, this property is used implicitly in For Each...In...Next constructs.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCServers


IFPCServers | FPCServers Count(long) property [ISA Server 2004]

Count Property of IFPCServers[C++]

FPCServers.Count [Visual Basic]

[C++]

The Count property gets the number of FPCServer objects in the collection.

HRESULT get_Count(
  long* plCount
);

Parameters

plCount
Pointer to a variable that on return receives a 32-bit integer specifying the number of FPCServer objects in the collection.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The Count property gets the number of FPCServer objects in the collection.

Property Count As Long

Property Value

A 32-bit integer that specifies the number of FPCServer objects in the collection.

Remarks

This property is read-only.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCServers


IFPCServers | FPCServers Item(Variant,IFPCServer) method [ISA Server 2004]

IFPCServers::Item[C++]

FPCServers.Item [Visual Basic]

[C++]

The Item method retrieves the requested IFPCServer interface from the collection.

HRESULT Item(
  VARIANT Index,
  IFPCServer** ppItem
);

Parameters

Index
[in] Required. Name or one-based index of the object to retrieve.
ppItem
[out] Address of an interface pointer that on return points to the IFPCServer interface requested.

Return Values

This method can return one of the following:

  • S_OK, indicating that the operation succeeded.
  • An error message, indicating that the operation failed. In this case, the [out] parameter returned is a null object.

[Visual Basic]

The Item method retrieves the requested FPCServer object from the collection.

Function Item( _
  ByVal Index As Variant _
) As FPCServer

Parameters

Index
[in] Required. Name or one-based index of the object to retrieve.

Return Values

This method returns a reference to the FPCServer object requested if successful. Otherwise, an error is raised that can be intercepted by using an error handler.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCServers


FPCSessionsMonitor collection [ISA Server 2004]

FPCSessionsMonitor Collection

The FPCSessionsMonitor collection holds a group of FPCSessionsMonitorEntry objects.

An FPCSessionsMonitor collection for the Microsoft Firewall service sessions can be accessed through the SessionsMonitorFirewall property of an FPCSessionsMonitors object. An FPCSessionsMonitor collection for the ISA Server Web proxy sessions can be accessed through the SessionsMonitorWebProxy property of an FPCSessionsMonitors object.

Click here to see the ISA Server object hierarchy.

Methods

The FPCSessionsMonitor collection defines the following methods.

Method | Description
DisconnectSession | Disconnects the session with the specified session ID.
EndQuery | Ends the active query on all servers in the array.
ExecuteQuery | Starts a new query using the specified filters on all servers in the array.
Item | Retrieves the requested FPCSessionsMonitorEntry object from the collection. This method returns only when the requested object is found, the associated query ends, or an error occurs in the query.
ItemAsync | Retrieves the requested FPCSessionsMonitorEntry object from the collection if it is available, returns null and sets the error code to E_PENDING if the requested object cannot be found immediately, or returns null and sets an error code if the operation fails or another error occurs.

Properties

The FPCSessionsMonitor collection has the following property.

Property | Description
_NewEnum | Gets an enumerator object for the collection.

Remarks

This collection implements the IFPCSessionsMonitors interface.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

COM Objects


IFPCSessionsMonitor | FPCSessionsMonitor _NewEnum property [ISA Server 2004]

_NewEnum Property of IFPCSessionsMonitor[C++]

FPCSessionsMonitor._NewEnum [Visual Basic]

[C++]

The _NewEnum property gets an enumerator object for the collection. An enumerator object provides serial access to the elements of the collection.

HRESULT get__NewEnum(
  IUnknown* ppEnum
);

Parameters

ppEnum
Address of an interface pointer that on return points to the IUnknown interface of an enumerator object that implements an IEnumVARIANT interface for the collection. An interface pointer to the IEnumVARIANT interface of the enumerator object can be retrieved by calling QueryInterface on the IUnknown interface returned.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The _NewEnum property gets an enumerator object for the collection. An enumerator object provides serial access to the elements of the collection.

Property _NewEnum As IUnknown

Property Value

Reference to an enumerator object that provides serial access to the elements of the collection.

Remarks

This property is read-only.

In Visual Basic and VBScript, this property is used implicitly in For Each...In...Next constructs.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCSessionsMonitor


IFPCSessionsMonitor.DisconnectSession(String,String) method [ISA Server 2004]

IFPCSessionsMonitor::DisconnectSession[C++]

FPCSessionsMonitor.DisconnectSession [Visual Basic]

[C++]

The DisconnectSession method disconnects the session with the specified session ID.

HRESULT DisconnectSession(
  BSTR ServerName,
  BSTR SessionID
);

Parameters

ServerName
[in] Required. String specifying the name of the server for the connection.
SessionID
[in] Required. String specifying the session ID.

Return Values

This method returns S_OK if the call is successful; otherwise, it returns an error code.
[Visual Basic]

The DisconnectSession method disconnects the session with the specified session ID.

Sub DisconnectSession( _
  ByVal ServerName As String, _
  ByVal SessionID As String _
)

Parameters

ServerName
[in] Required. String specifying the name of the server for the connection.
SessionID
[in] Required. String specifying the session ID.

Return Values

This method has no return values. If the call is unsuccessful, an error is raised that can be intercepted by using an error handler.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCSessionsMonitor


IFPCSessionsMonitor | FPCSessionsMonitor EndQuery method [ISA Server 2004]

IFPCSessionsMonitor::EndQuery[C++]

FPCSessionsMonitor.EndQuery [Visual Basic]

[C++]

The EndQuery method ends the active query on all servers in the array.

HRESULT EndQuery();

Parameters

This method has no parameters.

Return Values

This method returns S_OK if the call is successful; otherwise, it returns an error code.
[Visual Basic]

The EndQuery method ends the active query on all servers in the array.

Sub EndQuery()

Parameters

This method has no parameters.

Return Values

This method has no return values. If the call is unsuccessful, an error is raised that can be intercepted by using an error handler.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCSessionsMonitor


IFPCSessionsMonitor | FPCSessionsMonitor ExecuteQuery method [ISA Server 2004]

IFPCSessionsMonitor::ExecuteQuery[C++]

FPCSessionsMonitor.ExecuteQuery [Visual Basic]

[C++]

The ExecuteQuery method starts a new query using the specified filters on all servers in the array.

HRESULT ExecuteQuery(
  IFPCFilterExpressions* pFilter,
  long nBufferSize
);

Parameters

pFilter
[in] Pointer to an IFPCFilterExpressions interface that represents the collection of filters to be used in the query.
nBufferSize
[in] A 32-bit integer value that specifies the buffer size.

Return Values

This method returns S_OK if the call is successful; otherwise, it returns an error code.
[Visual Basic]

The ExecuteQuery method starts a new query using the specified filters on all servers in the array.

Sub ExecuteQuery( _
  ByRef Filter As FPCFilterExpressions, _
  ByVal nBufferSize As Long _
)

Parameters

Filter
[in] Reference to an FPCFilterExpressions collection that represents the filters to be used in the query.
nBufferSize
[in] A 32-bit integer value that specifies the buffer size.

Return Values

This method has no return values. If the call is unsuccessful, an error is raised that can be intercepted by using an error handler.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCSessionsMonitor


IFPCSessionsMonitor | FPCSessionsMonitor Item method [ISA Server 2004]

IFPCSessionsMonitor::Item[C++]

FPCSessionsMonitor.Item [Visual Basic]

[C++]

The Item method retrieves the requested IFPCSessionsMonitorEntry interface from the collection. This method returns only when the requested interface is found, the associated query ends, or an error occurs in the query.

HRESULT Item(
  long Index,
  IFPCSessionsMonitorEntry** ppItem
);

Parameters

Index
[in] Required. One-based index of the object to retrieve.
ppItem
[out] Address of an interface pointer that on return points to the IFPCSessionsMonitorEntry interface requested.

Return Values

The method can return one of the following:

  • S_OK, indicating that the operation succeeded.
  • S_FALSE, indicating that the query ended before the interface requested was found.
  • E_PENDING, indicating that the Index parameter points beyond the end of the collection.
  • An error code, indicating that the operation failed or an error occurred in the query.
If the return value is not S_OK, the [out] parameter returned is a null object.

Remarks

This method can retrieve an IFPCSessionsMonitorEntry interface that represents an active session that exists when the query starts. If the interface requested is not found, the method waits until the associated query ends or an error occurs in the query.

[Visual Basic]

The Item method retrieves the requested FPCSessionsMonitorEntry object from the collection. This method returns only when the requested object is found, the associated query ends, or an error occurs in the query.

Function Item( _
  ByVal Index As Long _
) As FPCSessionsMonitorEntry

Parameters

Index
[in] Required. One-based index of the object to retrieve.

Return Values

This method returns a reference to the FPCSessionsMonitorEntry object requested if successful. Otherwise, an error is raised that can be intercepted by using an error handler.

Remarks

This method can retrieve an FPCSessionsMonitorEntry object that represents an active session that exists when the query starts. If the object requested is not found, the method waits until the associated query ends or an error occurs in the query.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCSessionsMonitor


IFPCSessionsMonitor | FPCSessionsMonitor ItemAsync method [ISA Server 2004]

IFPCSessionsMonitor::ItemAsync[C++]

FPCSessionsMonitor.ItemAsync [Visual Basic]

[C++]

The ItemAsync method retrieves the requested IFPCSessionsMonitorEntry interface from the collection if it is available, returns E_PENDING if the requested interface cannot be found immediately, or returns an error code if the operation fails or another error occurs.

HRESULT ItemAsync(
  long Index,
  IFPCSessionsMonitorEntry** ppItem
);

Parameters

Index
[in] Required. One-based index of the object to retrieve.
ppItem
Address of an interface pointer that on return points to the IFPCSessionsMonitorEntry interface requested if the call is successful, or to a null interface if the requested interface cannot be found or the operation fails.

Return Values

This method can return one of the following:

  • S_OK, indicating that the operation succeeded.
  • S_FALSE, indicating that the query ended before the interface requested was found.
  • E_PENDING, indicating that the interface requested was not found.
  • An error code, indicating that the operation failed or an error occurred in the query.
If the return value is not S_OK, the [out] parameter returned is a null object.
[Visual Basic]

The ItemAsync method retrieves the requested FPCSessionsMonitorEntry object from the collection if it is available, returns null and sets the error code to E_PENDING if the requested object cannot be found immediately, or returns null and sets an error code if the operation fails or another error occurs.

Function ItemAsync( _
  ByVal Index As Long _
) As FPCSessionsMonitorEntry

Parameters

Index
[in] Required. One-based index of the object to retrieve.

Return Values

This method returns a reference to an FPCSessionsMonitorEntry object requested if successful. Otherwise, it returns null and raises an error that can be intercepted by using an error handler. The error code set can be one of the following:

  • S_FALSE, indicating that the query ended before the interface requested was found.
  • E_PENDING, indicating that the interface requested was not found.
  • An error code, indicating that the operation failed or an error occurred in the query.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCSessionsMonitor


FPCSessionsMonitorEntry object [ISA Server 2004]

FPCSessionsMonitorEntry

The FPCSessionsMonitorEntry object represents an entry in the session monitor for the Microsoft Firewall service sessions or the ISA Server Web proxy sessions.

The FPCSessionsMonitorEntry object is typically an element of an FPCSessionMonitor collection that represents a session monitor for Firewall service sessions or Web proxy sessions.

Click here to see the ISA Server object hierarchy.

Methods

This object has no methods.

Properties

The FPCSessionsMonitorEntry object has the following properties.

Property | Description
Activation | Gets a Date value that specifies the date and time in Coordinated Universal Time (UTC) when the session became active.
ClientComputer | Gets the name of the client computer for the session.
ClientIP | Gets the IP address of the client participating in the session.
ClientProcess | Gets the name of the process in which the client is participating.
ClientUserName | Gets the user name of the client account for the session.
Event | Gets a value from the FpcSessionMonitorEvent enumeration that indicates the type of session event.
ServerName | Gets the name of the server participating in the session.
SessionID | Gets a string value that specifies the session ID.
SessionType | Gets a value from the FpcSessionType enumeration that indicates the type of session.
SourceNetwork | Sets the name of the source network for the session.
SourceNetworkType | Sets a value from the FpcNetworkTypes enumeration that indicates the type of the source network for the session.

Remarks

This object implements the IFPCSessionsMonitorEntry interface.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

COM Objects


IFPCSessionsMonitorEntry.Activation(DATE) property [ISA Server 2004]

Activation Property of IFPCSessionsMonitorEntry[C++]

FPCSessionsMonitorEntry.Activation [Visual Basic]

[C++]

The Activation property gets a Date value that specifies the date and time in Coordinated Universal Time (UTC) when the session became active.

HRESULT get_Activation(
  DATE* pActivation
);

Parameters

pActivation
Pointer to a DATE that is set on return to the value specifying the date and time in Coordinated Universal Time (UTC) when the session became active.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The Activation property gets a Date value that specifies the date and time in Coordinated Universal Time (UTC) when the session became active.

Property Activation As Date

Property Value

Date value that specifies the date and time in Coordinated Universal Time (UTC) when the session became active.

Remarks

This property is read-only.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCSessionsMonitorEntry


IFPCSessionsMonitorEntry.ClientComputer(BSTR) property [ISA Server 2004]

ClientComputer Property of IFPCSessionsMonitorEntry[C++]

FPCSessionsMonitorEntry.ClientComputer [Visual Basic]

[C++]

The ClientComputer property gets the name of the client computer for the session.

HRESULT get_ClientComputer(
  BSTR* pbstrClientComputer
);

Parameters

pbstrClientComputer
Pointer to a BSTR that is set on return to a string value specifying the name of the client computer for the session.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The ClientComputer property gets the name of the client computer for the session.

Property ClientComputer As String

Property Value

String value specifying the name of the client computer for the session.

Remarks

This property is read-only.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCSessionsMonitorEntry


IFPCSessionsMonitorEntry.ClientIP(BSTR) property [ISA Server 2004]

ClientIP Property of IFPCSessionsMonitorEntry[C++]

FPCSessionsMonitorEntry.ClientIP [Visual Basic]

[C++]

The ClientIP property gets the IP address of the client participating in the session.

HRESULT get_ClientIP(
  BSTR* pbstrClientIP
);

Parameters

pbstrClientIP
Pointer to a BSTR that is set on return to a string value specifying the IP address of the client participating in the session.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The ClientIP property gets the IP address of the client participating in the session.

Property ClientIP As String

Property Value

String value specifying the IP address of the client participating in the session.

Remarks

This property is read-only.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCSessionsMonitorEntry


IFPCSessionsMonitorEntry.ClientProcess(BSTR) property [ISA Server 2004]

ClientProcess Property of IFPCSessionsMonitorEntry[C++]

FPCSessionsMonitorEntry.ClientProcess [Visual Basic]

[C++]

The ClientProcess property gets the name of the process in which the client is participating.

HRESULT get_ClientProcess(
  BSTR* pbstrClientProcess
);

Parameters

pbstrClientProcess
Pointer to a BSTR that is set on return to a string value specifying the name of the process in which the client is participating.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The ClientProcess property gets the name of the process in which the client is participating.

Property ClientProcess As String

Property Value

String value specifying the name of the process in which the client is participating.

Remarks

This property is read-only.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCSessionsMonitorEntry


IFPCSessionsMonitorEntry.ClientUserName(BSTR) property [ISA Server 2004]

ClientUserName Property of IFPCSessionsMonitorEntry[C++]

FPCSessionsMonitorEntry.ClientUserName [Visual Basic]

[C++]

The ClientUserName property gets the user name of the client account for the session.

HRESULT get_ClientUserName(
  BSTR* pbstrClientUserName
);

Parameters

pbstrClientUserName
Pointer to a BSTR that is set on return to a string value specifying the user name of the client account for the session.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The ClientUserName property gets the user name of the client account for the session.

Property ClientUserName As String

Property Value

String value specifying the user name of the client account for the session.

Remarks

This property is read-only.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCSessionsMonitorEntry


IFPCSessionsMonitorEntry.Event (1 Parameter) property [ISA Server 2004]

Event Property of IFPCSessionsMonitorEntry[C++]

FPCSessionsMonitorEntry.Event [Visual Basic]

[C++]

The Event property gets a value from the FpcSessionMonitorEvent enumeration that indicates the type of session event.

HRESULT get_Event(
  FpcSessionMonitorEvent* pSessionMonitorEvent
);

Parameters

pSessionMonitorEvent
Pointer to a value from the FpcSessionMonitorEvent enumeration that is set on return to the value indicating the type of session event.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The Event property gets a value from the FpcSessionMonitorEvent enumeration that indicates the type of session event.

Property Event As FpcSessionMonitorEvent

Property Value

Value from the FpcSessionMonitorEvent enumeration that indicates the type of session event.

Remarks

This property is read-only.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCSessionsMonitorEntry


IFPCSessionsMonitorEntry.ServerName(BSTR) property [ISA Server 2004]

ServerName Property of IFPCSessionsMonitorEntry[C++]

FPCSessionsMonitorEntry.ServerName [Visual Basic]

[C++]

The ServerName property gets the name of the server participating in the session.

HRESULT get_ServerName(
  BSTR* pbstrServerName
);

Parameters

pbstrServerName
Pointer to a BSTR that is set on return to a string value specifying the name of the server participating in the session.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The ServerName property gets the name of the server participating in the session.

Property ServerName As String

Property Value

String value specifying the name of the server participating in the session.

Remarks

This property is read-only.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCSessionsMonitorEntry


IFPCSessionsMonitorEntry.SessionID(BSTR) property [ISA Server 2004]

SessionID Property of IFPCSessionsMonitorEntry[C++]

FPCSessionsMonitorEntry.SessionID [Visual Basic]

[C++]

The SessionID property gets a string value that specifies the session ID.

HRESULT get_SessionID(
  BSTR* pbstrSessionID
);

Parameters

pbstrSessionID
Pointer to a BSTR that is set on return to a string value that specifies the session ID.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The SessionID property gets a string value that specifies the session ID.

Property SessionID As String

Property Value

String value that specifies the session ID.

Remarks

This property is read-only.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCSessionsMonitorEntry


IFPCSessionsMonitorEntry.SessionType(FpcSessionType) property [ISA Server 2004]

SessionType Property of IFPCSessionsMonitorEntry[C++]

FPCSessionsMonitorEntry.SessionType [Visual Basic]

[C++]

The SessionType property gets a value from the FpcSessionType enumeration that indicates the type of session.

HRESULT get_SessionType(
  FpcSessionType* pSessionType
);

Parameters

pSessionType
Pointer to a value from the FpcSessionType enumeration that is set on return to the value indicating the type of session.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The SessionType property gets a value from the FpcSessionType enumeration that indicates the type of session.

Property SessionType As FpcSessionType

Property Value

Value from the FpcSessionType enumeration that indicates the type of session.

Remarks

This property is read-only.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCSessionsMonitorEntry


IFPCSessionsMonitorEntry.SourceNetwork(BSTR) property [ISA Server 2004]

SourceNetwork Property of IFPCSessionsMonitorEntry[C++]

FPCSessionsMonitorEntry.SourceNetwork [Visual Basic]

[C++]

The SourceNetwork property sets the name of the source network for the session.

HRESULT put_SourceNetwork(
  BSTR SourceNetwork
);

Parameters

SourceNetwork
String value that specifies the name of the source network for the session.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is write-only.

[Visual Basic]

The SourceNetwork property sets the name of the source network for the session.

Property SourceNetwork As String

Property Value

String value specifying the name of the source network for the session.

Remarks

This property is write-only.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCSessionsMonitorEntry


IFPCSessionsMonitorEntry.SourceNetworkType property [ISA Server 2004]

SourceNetworkType Property of IFPCSessionsMonitorEntry[C++]

FPCSessionsMonitorEntry.SourceNetworkType [Visual Basic]

[C++]

The SourceNetworkType property sets a value from the FpcNetworkTypes enumeration that indicates the type of the source network for the session.

HRESULT put_SourceNetworkType(
  FpcNetworkTypes SourceNetworkType
);

Parameters

SourceNetworkType
Value from the FpcNetworkTypes enumeration that indicates the type of the source network for the session.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is write-only.

[Visual Basic]

The SourceNetworkType property sets a value from the FpcNetworkTypes enumeration that indicates the type of the source network for the session.

Property SourceNetworkType As FpcNetworkTypes

Property Value

Value from the FpcNetworkTypes enumeration that indicates the type of the source network for the session.

Remarks

This property is write-only.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCSessionsMonitorEntry


FPCSessionsMonitors object [ISA Server 2004]

FPCSessionsMonitors

The FPCSessionsMonitors object provides access to objects that represent the Microsoft Firewall service and ISA Server Web proxy session monitors.

The FPCSessionsMonitors object is typically accessed through the SessionsMonitors property of an FPCArray object

Click here to see the ISA Server object hierarchy.

Methods

This object has no methods.

Properties

The FPCSessionsMonitors object has the following properties.

Property | Description
SessionsMonitorFirewall | Gets an FPCSessionsMonitor collection that represents the session monitor for Firewall service sessions.
SessionsMonitorWebProxy | Gets an FPCSessionsMonitor collection that represents the session monitor for Web proxy sessions.

Remarks

This object implements the IFPCSessionsMonitors interface.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

COM Objects


IFPCSessionsMonitors.SessionsMonitorFirewall property [ISA Server 2004]

SessionsMonitorFirewall Property of IFPCSessionsMonitors[C++]

FPCSessionsMonitors.SessionsMonitorFirewall [Visual Basic]

[C++]

The SessionsMonitorFirewall property gets an FPCSessionsMonitor collection that represents the session monitor for the Microsoft Firewall service sessions.

HRESULT get_SessionsMonitorFirewall(
  IFPCSessionsMonitor** ppSessionsMonitorFirewall
);

Parameters

ppSessionsMonitorFirewall
Address of an interface pointer that on return points to an IFPCSessionsMonitor interface that represents the session monitor for Firewall service sessions.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The SessionsMonitorFirewall property gets an FPCSessionsMonitor collection that represents the session monitor for the Microsoft Firewall service sessions.

Property SessionsMonitorFirewall As FPCSessionsMonitor

Property Value

Reference to an FPCSessionsMonitor collection that represents the session monitor for Firewall service sessions.

Remarks

This property is read-only.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCSessionsMonitors


IFPCSessionsMonitors.SessionsMonitorWebProxy property [ISA Server 2004]

SessionsMonitorWebProxy Property of IFPCSessionsMonitors[C++]

FPCSessionsMonitors.SessionsMonitorWebProxy [Visual Basic]

[C++]

The SessionsMonitorWebProxy property gets an FPCSessionsMonitor collection that represents the session monitor for Web proxy sessions.

HRESULT get_SessionsMonitorWebProxy(
  IFPCSessionsMonitor** ppSessionsMonitorWebProxy
);

Parameters

ppSessionsMonitorWebProxy
Address of an interface pointer that on return points to an IFPCSessionsMonitor interface that represents the session monitor for Web proxy sessions.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The SessionsMonitorWebProxy property gets an FPCSessionsMonitor collection that represents the session monitor for Web proxy sessions.

Property SessionsMonitorWebProxy As FPCSessionsMonitor

Property Value

Reference to an FPCSessionsMonitor collection that represents the session monitor for Web proxy sessions.

Remarks

This property is read-only.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCSessionsMonitors


FPCSignaledAlert collection [ISA Server 2004]

FPCSignaledAlert Collection

The FPCSignaledAlert collection holds all instances of a single alert that have been issued. Each alert instance that has been issued is represented by an FPCSignaledAlertInstance object. This collection is typically an element of an FPCSignaledAlerts collection.

The FPCSignaledAlert collection contains the run-time instances of the alert defined by the FPCAlert object with the same event GUID and additional key. The alerts that have been issued appear under Monitoring in ISA Server Management. The FPCAlert object contains alert configuration information, and the FPCSignaledAlert object contains both configuration and run-time information.

Click here to see the ISA Server object hierarchy.

Methods

The FPCSignaledAlert collection defines the following methods.

Method | Description
Acknowledge | Acknowledges all instances of the alert.
Item | Retrieves the requested FPCSignaledAlertInstance object from the collection.
Refresh | Reads the stored values of all of the collection's properties by means of a remote procedure call (RPC).
Reset | Resets the alert.

Properties

The FPCSignaledAlert collection has the following properties.

Property | Description
_NewEnum | Gets an enumerator object for the collection.
AdditionalKey | Gets the additional key (index) in the table of subevents defined for the event for which the alert is issued.
Count | Gets the number of FPCSignaledAlertInstance objects in the collection.
EventGuid | Gets the string-formatted globally unique identifier (GUID) of the event that triggered the alert.
Name | Gets the name of the alert.
Server | Gets the name of the server on which the alert was issued.
Severity | Gets a value from the FpcAlertSeverity enumerated type that indicates the severity of the alert.

Remarks

This object implements the IFPCSignaledAlert interface.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

COM Objects


IFPCSignaledAlert | FPCSignaledAlert _NewEnum property [ISA Server 2004]

_NewEnum Property of IFPCSignaledAlert[C++]

FPCSignaledAlert._NewEnum [Visual Basic]

[C++]

The _NewEnum property gets an enumerator object for the collection. An enumerator object provides serial access to the elements of the collection.

HRESULT get__NewEnum(
  IUnknown* ppEnum
);

Parameters

ppEnum
Address of an interface pointer that on return points to the IUnknown interface of an enumerator object that implements an IEnumVARIANT interface for the collection. An interface pointer to the IEnumVARIANT interface of the enumerator object can be retrieved by calling QueryInterface on the IUnknown interface returned.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The _NewEnum property gets an enumerator object for the collection. An enumerator object provides serial access to the elements of the collection.

Property _NewEnum As IUnknown

Property Value

Reference to an enumerator object that provides serial access to the elements of the collection.

Remarks

This property is read-only.

In Visual Basic and VBScript, this property is used implicitly in For Each...In...Next constructs.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCSignaledAlert


IFPCSignaledAlert | FPCSignaledAlert Acknowledge method [ISA Server 2004]

IFPCSignaledAlert::Acknowledge[C++]

FPCSignaledAlert.Acknowledge [Visual Basic]

[C++]

The Acknowledge method acknowledges all instances of the alert.

HRESULT Acknowledge();

Parameters

This method has no parameters.

Return Values

This method returns S_OK if the call is successful; otherwise, it returns an error code.
[Visual Basic]

The Acknowledge method acknowledges all instances of the alert.

Sub Acknowledge()

Parameters

This method has no parameters.

Return Values

This method has no return values. If the call is unsuccessful, an error is raised that can be intercepted by using an error handler.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCSignaledAlert


IFPCSignaledAlert | FPCSignaledAlert AdditionalKey property [ISA Server 2004]

AdditionalKey Property of IFPCSignaledAlert[C++]

FPCSignaledAlert.AdditionalKey [Visual Basic]

[C++]

The AdditionalKey property gets the additional key (index) in the table of subevents defined for the event for which the alert is issued.

HRESULT get_AdditionalKey(
  long* plAdditionalKey
);

Parameters

plAdditionalKey
Pointer to a variable that on return receives a 32-bit integer specifying the additional key.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The AdditionalKey property gets the additional key (index) in the table of subevents defined for the event for which the alert is issued.

Property AdditionalKey As Long

Property Value

A 32-bit integer that specifies the additional key.

Remarks

This property is read-only.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCSignaledAlert


IFPCSignaledAlert | FPCSignaledAlert Count(long) property [ISA Server 2004]

Count Property of IFPCSignaledAlert[C++]

FPCSignaledAlert.Count [Visual Basic]

[C++]

The Count property gets the number of FPCSignaledAlertInstance objects (representing instances of the signaled alert) in the collection.

HRESULT get_Count(
  long* plCount
);

Parameters

plCount
Pointer to a variable that on return receives a 32-bit integer specifying the number of FPCSignaledAlertInstance objects in the collection.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The Count property gets the number of FPCSignaledAlertInstance objects (representing instances of the signaled alert) in the collection.

Property Count As Long

Property Value

A 32-bit integer that specifies the number of FPCSignaledAlertInstance objects.

Remarks

This property is read-only.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCSignaledAlert


IFPCSignaledAlert | FPCSignaledAlert EventGuid(BSTR) property [ISA Server 2004]

EventGuid Property of IFPCSignaledAlert[C++]

FPCSignaledAlert.EventGuid [Visual Basic]

[C++]

The EventGuid property gets the string-formatted globally unique identifier (GUID) of the event that triggered the alert.

HRESULT get_EventGuid(
  BSTR* pbstrGuid
);

Parameters

pbstrGuid
Pointer to a BSTR that is set on return to the string-formatted GUID of the event that triggered the alert.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

The GUID retrieved is formatted as a string in the form {12345678-1234-1234-1234-123456789ABC}. Note the presence of the braces normally used with GUIDs.

[Visual Basic]

The EventGuid property gets the string-formatted globally unique identifier (GUID) of the event that triggered the alert.

Property EventGuid As String

Property Value

String that specifies the string-formatted GUID of the event that triggered the alert.

Remarks

This property is read-only.

The GUID retrieved is formatted as a string in the form {12345678-1234-1234-1234-123456789ABC}. Note the presence of the braces normally used with GUIDs.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCSignaledAlert


IFPCSignaledAlert | FPCSignaledAlert Item method [ISA Server 2004]

IFPCSignaledAlert::Item[C++]

FPCSignaledAlert.Item [Visual Basic]

[C++]

The Item method retrieves the requested IFPSignaledAlertInstance interface from the collection.

HRESULT Item(
  long Index,
  IFPCSignaledAlertInstance** ppItem
);

Parameters

Index
[in] Required. One-based index of the object to retrieve.
ppItem
[out] Address of an interface pointer that on return points to the IFPCSignaledAlertInstance interface requested.

Return Values

This method can return one of the following:

  • S_OK, indicating the operation succeeded.
  • An error message, indicating that the operation failed. In this case, the [out] parameter returned is a null object.

[Visual Basic]

The Item method retrieves the requested FPCSignaledAlertInstance object from the collection.

Function Item( _
  ByVal Index As Long _
) As FPCSignaledAlertInstance

Parameters

Index
[in] Required. One-based index of the object to retrieve.

Return Values

This method returns a reference to the FPCSignaledAlertInstance object if successful. Otherwise, an error is raised that can be intercepted by using an error handler.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCSignaledAlert


IFPCSignaledAlert | FPCSignaledAlert Name(BSTR) property [ISA Server 2004]

Name Property of IFPCSignaledAlert[C++]

FPCSignaledAlert.Name [Visual Basic]

[C++]

The Name property gets the name of the alert.

HRESULT get_Name(
  BSTR* pbstrName
);

Parameters

pbstrName
Pointer to a BSTR that is set on return to a string value specifying the name of the alert.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The Name property gets the name of the alert.

Property Name As String

Property Value

String that specifies the name of the alert.

Remarks

This property is read-only.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCSignaledAlert


IFPCSignaledAlert | FPCSignaledAlert Refresh method [ISA Server 2004]

IFPCSignaledAlert::Refresh[C++]

FPCSignaledAlert.Refresh [Visual Basic]

[C++]

The Refresh method reads the stored values of all of the collection's properties by means of a remote procedure call (RPC).

HRESULT Refresh();

Parameters

This method has no parameters.

Return Values

This method returns S_OK if the call is successful; otherwise, it returns an error code.
[Visual Basic]

The Refresh method reads the stored values of all of the collection's properties by means of a remote procedure call (RPC).

Sub Refresh()

Parameters

This method has no parameters.

Return Values

This method has no return values. If the call is unsuccessful, an error is raised that can be intercepted by using an error handler.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCSignaledAlert


IFPCSignaledAlert | FPCSignaledAlert Reset method [ISA Server 2004]

IFPCSignaledAlert::Reset[C++]

FPCSignaledAlert.Reset [Visual Basic]

[C++]

The Reset method resets the alert. This clears all counters held by the Microsoft Firewall service, putting the alert back in a state that is ready for triggering.

HRESULT Reset();

Parameters

This method has no parameters.

Return Values

This method returns S_OK if the call is successful; otherwise, it returns an error code.
[Visual Basic]

The Reset method resets the alert. This clears all counters held by the Microsoft Firewall service, putting the alert back in a state that is ready for triggering.

Sub Reset()

Parameters

This method has no parameters.

Return Values

This method has no return values. If the call is unsuccessful, an error is raised that can be intercepted by using an error handler.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCSignaledAlert


IFPCSignaledAlert | FPCSignaledAlert Server(BSTR) property [ISA Server 2004]

Server Property of IFPCSignaledAlert[C++]

FPCSignaledAlert.Server [Visual Basic]

[C++]

The Server property gets the name of the server on which the alert was issued.

HRESULT get_Server(
  BSTR* pbstrServer
);

Parameters

pbstrServer
Pointer to a BSTR that is set on return to a string value specifying the name of the server on which the alert was issued.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The Server property gets the name of the server on which the alert was issued.

Property Server As String

Property Value

String that specifies the name of the server on which the alert was issued.

Remarks

This property is read-only.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCSignaledAlert


IFPCSignaledAlert | FPCSignaledAlert Severity property [ISA Server 2004]

Severity Property of IFPCSignaledAlert[C++]

FPCSignaledAlert.Severity [Visual Basic]

[C++]

The Severity property gets a value from the FpcAlertSeverity enumerated type that specifies the severity of the alert. The severity determines the type of event that can be recorded in the system log if the alert's actions include event logging. The possible severity levels are:

  • Information
  • Warning
  • Error

HRESULT get_Severity(
  FpcSeverity* pSeverity
);

Parameters

pSeverity
Pointer to a variable that on return receives a value from the FpcAlertSeverity enumerated type specifying the severity of the alert.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The Severity property gets a value from the FpcAlertSeverity enumerated type that specifies the severity of the alert. The severity determines the type of event that can be recorded in the system log if the alert's actions include event logging. The possible severity levels are:

  • Information
  • Warning
  • Error

Property Severity As FpcAlertSeverity

Property Value

Value from the FpcAlertSeverity enumerated type that specifies the severity of the alert.

Remarks

This property is read-only.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCSignaledAlert


FPCSignaledAlertInstance object [ISA Server 2004]

FPCSignaledAlertInstance

The FPCSignaledAlertInstance object represents a single instance of an alert that has been issued. This object is typically an element of an FPCSignaledAlert collection.

Click here to see the ISA Server object hierarchy.

Methods

The FPCSignaledAlertInstance object defines the following methods.

Method | Description
Acknowledge | Acknowledges the alert instance.
Reset | Resets the alert instance.

Properties

The FPCSignaledAlertInstance object has the following properties.

Property | Description
Acknowledged | Gets a Boolean value that indicates whether the alert instance has been acknowledged.
Count | Gets the number of instances of the alert that were issued with the same timestamp.
Description | Gets the description of the alert instance.
Resolution | Gets a possible resolution of the issue that caused the alert instance.
TimeStamp | Gets a Date value that specifies the date and time in Coordinated Universal Time (UTC) when the alert instance was issued.

Remarks

This object implements the IFPCSignaledAlertInstance interface.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

COM Objects


IFPCSignaledAlertInstance.Acknowledge method [ISA Server 2004]

IFPCSignaledAlertInstance::Acknowledge[C++]

FPCSignaledAlertInstance.Acknowledge [Visual Basic]

[C++]

The Acknowledge method acknowledges the alert instance.

HRESULT Acknowledge();

Parameters

This method has no parameters.

Return Values

This method returns S_OK if the call is successful; otherwise, it returns an error code.
[Visual Basic]

The Acknowledge method acknowledges the alert instance.

Sub Acknowledge()

Parameters

This method has no parameters.

Return Values

This method has no return values. If the call is unsuccessful, an error is raised that can be intercepted by using an error handler.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCSignaledAlertInstance


IFPCSignaledAlertInstance.Acknowledged(VARIANT_BOOL) property [ISA Server 2004]

Acknowledged Property of IFPCSignaledAlertInstance[C++]

FPCSignaledAlertInstance.Acknowledged [Visual Basic]

[C++]

The Acknowledged property gets a Boolean value that indicates whether the alert instance has been acknowledged.

HRESULT get_Acknowledged(
  VARIANT_BOOL* pfAcknowledged
);

Parameters

pfAcknowledged
Pointer to a Boolean variable that is set on return to VARIANT_TRUE if the alert instance has been acknowledged, or to VARIANT_FALSE if the alert instance has not been acknowledged.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The Acknowledged property gets a Boolean value that indicates whether the alert instance has been acknowledged.

Property Acknowledged As Boolean

Property Value

Boolean value that indicates whether the alert instance has been acknowledged.

Remarks

This property is read-only.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCSignaledAlertInstance


IFPCSignaledAlertInstance.Count(long) property [ISA Server 2004]

Count Property of IFPCSignaledAlertInstance[C++]

FPCSignaledAlertInstance.Count [Visual Basic]

[C++]

The Count property gets the number of alert instances that were issued with the same timestamp.

HRESULT get_Count(
  long* plCount
);

Parameters

plCount
Pointer to a variable that on return receives a 32-bit integer specifying the number of alert instances that were issued with the same timestamp.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The Count property gets the number of alert instances that were issued with the same timestamp.

Property Count As Long

Property Value

A 32-bit integer that specifies the number of alert instances that were issued with the same timestamp.

Remarks

This property is read-only.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCSignaledAlertInstance


IFPCSignaledAlertInstance.Description(BSTR) property [ISA Server 2004]

Description Property of IFPCSignaledAlertInstance[C++]

FPCSignaledAlertInstance.Description [Visual Basic]

[C++]

The Description property gets a description of the alert instance.

HRESULT get_Description(
  BSTR* pbstrDescription
);

Parameters

pbstrDescription
Pointer to a BSTR that is set on return to a string value specifying the description of the alert instance.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The Description property gets a description of the alert instance.

Property Description As String

Property Value

String value specifying the description of the alert instance.

Remarks

This property is read-only.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCSignaledAlertInstance


IFPCSignaledAlertInstance.Reset method [ISA Server 2004]

IFPCSignaledAlertInstance::Reset[C++]

FPCSignaledAlertInstance.Reset [Visual Basic]

[C++]

The Reset method resets the altert instance.

HRESULT Reset();

Parameters

This method has no parameters.

Return Values

This method returns S_OK if the call is successful; otherwise, it returns an error code.
[Visual Basic]

The Reset method resets the altert instance.

Sub Reset()

Parameters

This method has no parameters.

Return Values

This method has no return values. If the call is unsuccessful, an error is raised that can be intercepted by using an error handler.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCSignaledAlertInstance


IFPCSignaledAlertInstance.Resolution(BSTR) property [ISA Server 2004]

Resolution Property of IFPCSignaledAlertInstance[C++]

FPCSignaledAlertInstance.Resolution [Visual Basic]

[C++]

The Resolution property gets a possible resolution of the issue that caused the alert instance.

HRESULT get_Resolution(
  BSTR* pbstrResolution
);

Parameters

pbstrResolution
Pointer to a BSTR that is set on return to a string value specifying a possible resolution of the issue that caused the alert instance.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The Resolution property gets a possible resolution of the issue that caused the alert instance.

Property Resolution As BSTR

Property Value

String that specifies a possible resolution of the issue that caused the alert instance.

Remarks

This property is read-only.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCSignaledAlertInstance


IFPCSignaledAlertInstance.TimeStamp(DATE) property [ISA Server 2004]

TimeStamp Property of IFPCSignaledAlertInstance[C++]

FPCSignaledAlertInstance.TimeStamp [Visual Basic]

[C++]

The TimeStamp property gets a Date value that specifies the date and time in Coordinated Universal Time (UTC) when the alert instance was issued.

HRESULT get_TimeStamp(
  DATE* pdTimeStamp
);

Parameters

pdTimeStamp
Pointer to a DATE that is set on return to the value specifying the date and time in Coordinated Universal Time (UTC) when the alert instance was issued.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The TimeStamp property gets a Date value that specifies the date and time in Coordinated Universal Time (UTC) when the alert instance was issued.

Property TimeStamp As DATE

Property Value

Date value that specifies the date and time in Coordinated Universal Time (UTC) when the alert instance was issued.

Remarks

This property is read-only.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCSignaledAlertInstance


FPCSignaledAlerts collection [ISA Server 2004]

FPCSignaledAlerts Collection

The FPCSignaledAlerts collection holds the set of FPCSignaledAlert objects for the ISA Server computer. Each FPCSignaledAlert object, in turn, is a collection that holds all the run-time instances of a single alert defined by an FPCAlert object.

This object is typically accessed through the SignaledAlerts property of an FPCServer object.

Click here to see the ISA Server object hierarchy.

Methods

The FPCSignaledAlerts collection defines the following methods.

Method | Description
Item | Retrieves the requested FPCSignaledAlert object from the collection.
Refresh | Reads the stored values of all the properties of the FPCSignaledAlert objects by means of remote procedure calls (RPCs).

Properties

The FPCSignaledAlerts collection has the following properties.

Property | Description
_NewEnum | Gets an enumerator object for the collection.
Count | Gets the number of FPCSignaledAlert objects in the collection.

Remarks

This collection implements the IFPCSignaledAlerts interface.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

COM Objects


IFPCSignaledAlerts | FPCSignaledAlerts _NewEnum property [ISA Server 2004]

_NewEnum Property of IFPCSignaledAlerts[C++]

FPCSignaledAlerts._NewEnum [Visual Basic]

[C++]

The _NewEnum property gets an enumerator object for the collection. An enumerator object provides serial access to the elements of the collection.

HRESULT get__NewEnum(
  IUnknown* ppEnum
);

Parameters

ppEnum
Address of an interface pointer that on return points to the IUnknown interface of an enumerator object that implements an IEnumVARIANT interface for the collection. An interface pointer to the IEnumVARIANT interface of the enumerator object can be retrieved by calling QueryInterface on the IUnknown interface returned.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The _NewEnum property gets an enumerator object for the collection. An enumerator object provides serial access to the elements of the collection.

Property _NewEnum As IUnknown

Property Value

Reference to an enumerator object that provides serial access to the elements of the collection.

Remarks

This property is read-only.

In Visual Basic and VBScript, this property is used implicitly in For Each...In...Next constructs.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCSignaledAlerts


IFPCSignaledAlerts | FPCSignaledAlerts Count(long) property [ISA Server 2004]

Count Property of IFPCSignaledAlerts[C++]

FPCSignaledAlerts.Count [Visual Basic]

[C++]

The Count property gets the number of FPCSignaledAlert objects in the collection.

HRESULT get_Count(
  long* plCount
);

Parameters

plCount
Pointer to a variable that on return receives a 32-bit integer specifying the number of FPCSignaledAlert objects in the collection.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The Count property gets the number of FPCSignaledAlert objects in the collection.

Property Count As Long

Property Value

A 32-bit integer that specifies the number of FPCSignaledAlert objects in the collection.

Remarks

This property is read-only.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCSignaledAlerts


IFPCSignaledAlerts | FPCSignaledAlerts Item method [ISA Server 2004]

IFPCSignaledAlerts::Item[C++]

FPCSignaledAlerts.Item [Visual Basic]

[C++]

The Item method retrieves the requested IFPCSignaledAlert interface from the collection.

HRESULT Item(
  VARIANT IndexOrEventGuid,
  VARIANT AdditionalKey,
  VARIANT Server,
  IFPCLDTEntry** ppItem
);

Parameters

IndexOrEventGuid
[in] Required. Globally unique identifier (GUID) of the event for which the alert is issued or one-based index of the object to retrieve.
AdditionalKey
[in, optional] Index specifying the subevent for which the alert is issued. This parameter should be set only if the Index parameter contains an event GUID. For more information, see IFPCAlert::AdditionalKey.
Server
[in, optional] Name of the server that is allowed to issue the alert. This parameter should be set if only a specific server is allowed to issue the alert.
ppItem
[out] Address of an interface pointer that on return points to the IFPCSignaledAlert interface requested.

Return Values

This method can return one of the following:

  • S_OK, indicating that the operation succeeded.
  • An error message, indicating that the operation failed. In this case, the [out] parameter returned is a null object.

[Visual Basic]

The Item method retrieves the requested FPCSignaledAlert object from the collection.

Function Item( _
  ByVal IndexOrEventGuid As Variant, _
  [ ByVal AdditionalKey As Variant ], _
  [ ByVal Server As Variant ] _
) As FPCLDTEntry

Parameters

IndexOrEventGuid
[in] Required. Globally unique identifier (GUID) of the event for which the alert is issued or one-based index of the object to retrieve.
AdditionalKey
[in, optional] Index specifying the subevent for which the alert is issued. This parameter should be set only if the Index parameter contains an event GUID. For more information, see FPCAlert.AdditionalKey.
Server
[in, optional] Name of the server that is allowed to issue the alert. This parameter should be set if only a specific server is allowed to issue the alert.

Return Values

This method returns a reference to the FPCSignaledAlert object requested if successful. Otherwise, an error is raised that can be intercepted by using an error handler.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCSignaledAlerts


IFPCSignaledAlerts | FPCSignaledAlerts Refresh method [ISA Server 2004]

IFPCSignaledAlerts::Refresh[C++]

FPCSignaledAlerts.Refresh [Visual Basic]

[C++]

The Refresh method reads the stored values of all the properties of the FPCSignaledAlert objects in the collection by means of a remote procedure call (RPC).

HRESULT Refresh();

Parameters

This method has no parameters.

Return Values

This method returns S_OK if the call is successful; otherwise, it returns an error code.

[Visual Basic]

The Refresh method reads the stored values of all the properties of the FPCSignaledAlert objects in the collection by means of a remote procedure call (RPC).

Sub Refresh()

Parameters

This method has no parameters.

Return Values

This method has no return values. If the call is unsuccessful, an error is raised that can be intercepted by using an error handler.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCSignaledAlerts


FPCSnapinNode object [ISA Server 2004]

FPCSnapinNode

The FPCSnapinNode object represents an ISA Server Management node that is being extended. For more information, see Extending ISA Server Management.

The FPCSnapinNode object cannot be retrieved through a property of an object in the ISA Server object hierarchy based on the FPC object. It is retrieved by querying the IDataObject interface of the data object of the ISA Server node that is being extended.

Methods

The FPCSnapinNode object defines the following method.

Method | Description
Refresh | Recursively reads all the data for the node being extended from persistent storage.

Properties

The FPCSnapinNode object has the following properties.

Property | Description
ComRoot | Gets the FPC root object.
CurrentObject | Gets the object that is being extended.
ParentArray | Gets an FPCArray object that represents the array under which the extension is being created.
ParentPolicy | Gets the enterprise policy object under which the extension is being created. The enterprise policy object is not available in ISA Server, Standard Edition.
PluginPolicy | Gets an FPCSnapinPluginPolicy object that defines the plug-in policy for the node being extended.

Remarks

This object implements the IFPCSnapinNode interface.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

COM Objects


IFPCSnapinNode | FPCSnapinNode ComRoot(IDispatch) property [ISA Server 2004]

ComRoot Property of IFPCSnapinNode[C++]

FPCSnapinNode.ComRoot [Visual Basic]

[C++]

The ComRoot property gets the FPC root object.

HRESULT get_ComRoot(
  IDispatch** ppRootObject
);

Parameters

ppRootObject
Address of a pointer to IDispatch that on return points to the IFPC interface of the root object.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only. The IFPC interface retrieved can be used to access all ISA Server administration COM objects that are subobjects of it.

[Visual Basic]

The ComRoot property gets the FPC root object.

Property ComRoot As IDispatch

Property Value

Reference to the FPC root object.

Remarks

This property is read-only. The FPC object retrieved can be used to access all ISA Server administration COM objects that are subobjects of it.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCSnapinNode


IFPCSnapinNode | FPCSnapinNode CurrentObject property [ISA Server 2004]

CurrentObject Property of IFPCSnapinNode[C++]

FPCSnapinNode.CurrentObject [Visual Basic]

[C++]

The CurrentObject property gets the object that is being extended.

HRESULT get_CurrentObject(
  IDispatch** ppCurrentObject
);

Parameters

ppCurrentObject
Address of a pointer to IDispatch that on return points to the object that is being extended.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only. The FPCVendorParametersSets collection for the object retrieved can be accessed by calling its VendorParametersSets property.

[Visual Basic]

The CurrentObject property gets the object that is being extended.

Property CurrentObject As IDispatch

Property Value

Reference to the object that is being extended.

Remarks

This property is read-only. The FPCVendorParametersSets collection for the object retrieved can be accessed by calling its VendorParametersSets property.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCSnapinNode


IFPCSnapinNode | FPCSnapinNode ParentArray(IDispatch) property [ISA Server 2004]

ParentArray Property of IFPCSnapinNode[C++]

FPCSnapinNode.ParentArray [Visual Basic]

[C++]

The ParentArray property gets an FPCArray object that represents the array under which the extension is being created.

HRESULT get_ParentArray(
  IDispatch** ppArray
);

Parameters

ppArray
Address of a pointer to IDispatch that on return points to the IFPCArray interface representing the array under which the extension is being created.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

This property retrieves an FPCArray object as exposed through the ISA Server administration COM object model.

[Visual Basic]

The ParentArray property gets an FPCArray object that represents the array under which the extension is being created.

Property ParentArray As IDispatch

Property Value

Reference to an FPCArray object representing the array under which the extension is being created.

Remarks

This property is read-only.

This property retrieves an FPCArray object as exposed through the ISA Server administration COM object model.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCSnapinNode


IFPCSnapinNode | FPCSnapinNode ParentPolicy property [ISA Server 2004]

ParentPolicy Property of IFPCSnapinNode[C++]

FPCSnapinNode.ParentPolicy [Visual Basic]

[C++]

The ParentPolicy property gets the enterprise policy object under which the extension is being created. The enterprise policy object is not available in ISA Server, Standard Edition.

HRESULT get_ParentPolicy(
  IDispatch** ppPolicy
);

Parameters

ppPolicy
Address of a pointer to IDispatch that on return points to an interface representing the enterprise policy under which the extension is being created.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The ParentPolicy property gets the enterprise policy object under which the extension is being created. The enterprise policy object is not available in ISA Server, Standard Edition.

Property ParentPolicy As IDispatch

Property Value

Reference to the enterprise policy object under which the extension is being created.

Remarks

This property is read-only.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCSnapinNode


IFPCSnapinNode | FPCSnapinNode PluginPolicy property [ISA Server 2004]

PluginPolicy Property of IFPCSnapinNode[C++]

FPCSnapinNode.PluginPolicy [Visual Basic]

[C++]

The PluginPolicy property gets an FPCSnapinPluginPolicy object that defines the plug-in policy for the node being extended.

HRESULT get_PluginPolicy(
  FPCSnapinPluginPolicy** ppPluginPolicy
);

Parameters

ppPluginPolicy
Address of an interface pointer that on return points to an IFPCSnapinPluginPolicy interface that represents the plug-in policy for the node being extended.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The PluginPolicy property gets an FPCSnapinPluginPolicy object that defines the plug-in policy for the node being extended.

Property PluginPolicy As FPCSnapinPluginPolicy

Property Value

Reference to an FPCSnapinPluginPolicy object that defines the plug-in policy for the node being extended.

Remarks

This property is read-only.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCSnapinNode


IFPCSnapinNode | FPCSnapinNode Refresh method [ISA Server 2004]

IFPCSnapinNode::Refresh[C++]

FPCSnapinNode.Refresh [Visual Basic]

[C++]

The Refresh method recursively reads all the data for the node being extended from persistent storage. Call this method after the configuration is changed.

HRESULT Refresh();

Parameters

This method has no parameters.

Return Values

This method returns S_OK if the call is successful; otherwise, it returns an error code.

Example Code

CComQIPtr<IFPCSnapinNode> spIFPCSnapinNode = m_pDataObject;
if (spIFPCSnapinNode != NULL)
{
    spIFPCSnapinNode->Refresh();
}

[Visual Basic]

The Refresh method recursively reads all the data for the node being extended from persistent storage. Call this method after the configuration is changed.

Sub Refresh()

Parameters

This method has no parameters.

Return Values

This method has no return values. If the call is unsuccessful, an error is raised that can be intercepted by using an error handler.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCSnapinNode


FPCSnapinPluginPolicy object [ISA Server 2004]

FPCSnapinPluginPolicy

The FPCSnapinPluginPolicy object represents the plug-in policy for an ISA Server Management snap-in node that is being extended.

This object is typically accessed through the PluginPolicy property of an FPCSnapinNode object.

Click here to see the ISA Server object hierarchy.

Methods

The FPCSnapinPluginPolicy object defines the following methods.

Method | Description
IndicatePluginPolicy | Indicates that the extension must implement the plug-in policy.
IsApplicationFilterSelected | Verifies that any protocol applied to specified application filter is selected.
IsProtocolSelected | Verifies that the specified protocol is selected.

Properties

The FPCSnapinPluginPolicy object has the following properties.

Property | Description
CurrentAction | Gets a value from the FpcPolicyRuleActions enumerated type that specifies whether the policy rule of the plug-in policy currently allows or denies requests.
PolicyRule | Gets an FPCPolicyRule object that represents the policy rule of the plug-in policy.
VendorParametersSets | Gets a VendorParametersSets collection in which custom data can be stored for the extension.

Remarks

This object implements the IFPCSnapinPluginPolicy interface.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

COM Objects


IFPCSnapinPluginPolicy.CurrentAction (1 Parameter) property [ISA Server 2004]

CurrentAction Property of IFPCSnapinPluginPolicy[C++]

FPCSnapinPluginPolicy.CurrentAction [Visual Basic]

[C++]

The CurrentAction property gets a value from the FpcPolicyRuleActions enumerated type that specifies whether the policy rule of the plug-in policy currently allows or denies requests.

HRESULT get_CurrentAction(
  FpcPolicyRuleActions* pPolicyRuleAction
);

Parameters

pPolicyRuleAction
Pointer to a value from the FPCPolicyRuleActions enumerated type that is set on return to either fpcPolicyRuleActionAllow, which indicates that the policy rule of the plug-in currently allows requests, or to fpcPolicyRuleActionDeny, which indicates that the policy rule currently denies requests.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only. It can be modified by setting the Action property of the IFPCPolicyRule interface retrieved by calling the PolicyRule property.

[Visual Basic]

The CurrentAction property gets a value from the FpcPolicyRuleActions enumerated type that specifies whether the policy rule of the plug-in policy currently allows or denies requests.

Property CurrentAction As FpcPolicyRuleActions

Property Value

Value from the FpcPolicyRuleActions enumerated type. The possible values are fpcPolicyRuleActionAllow, which indicates that the policy rule of the plug-in currently allows requests, and fpcPolicyRuleActionDeny, which indicates that the policy rule currently denies requests.

Remarks

This property is read-only. It can be modified by setting the Action property of the FPCPolicyRule object retrieved by calling the PolicyRule property.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCSnapinPluginPolicy


IFPCSnapinPluginPolicy.IndicatePluginPolicy method [ISA Server 2004]

IFPCSnapinPluginPolicy::IndicatePluginPolicy[C++]

FPCSnapinPluginPolicy.IndicatePluginPolicy [Visual Basic]

[C++]

The IndicatePluginPolicy method indicates that the extension must implement the plug-in policy.

HRESULT IndicatePluginPolicy();

Parameters

This method has no parameters.

Return Values

This method returns S_OK if the call is successful; otherwise, it returns an error code.
[Visual Basic]

The IndicatePluginPolicy method indicates that the extension must implement the plug-in policy.

Sub IndicatePluginPolicy()

Parameters

This method has no parameters.

Return Values

This method has no return values. If the call is unsuccessful, an error is raised that can be intercepted by using an error handler.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCSnapinPluginPolicy


IFPCSnapinPluginPolicy.IsApplicationFilterSelected method [ISA Server 2004]

IFPCSnapinPluginPolicy::IsApplicationFilterSelected[C++]

FPCSnapinPluginPolicy.IsApplicationFilterSelected [Visual Basic]

[C++]

The IsApplicationFilterSelected method verifies that any protocol applied to specified application filter is selected.

HRESULT IsApplicationFilterSelected(
  BSTR bstrAppFilterGuid
);

Parameters

bstrAppFilterGuid
[in] String containing the globally unique identifier (GUID) of the application filter to check in the form {12345678-1234-1234-1234-123456789ABC}. Note the presence of the braces normally used with GUIDs.

Return Values

This method can return one of the following:

  • S_OK (0x00000000), indicating that the specified application filter is selected.
  • S_FALSE (0x00000001), indicating that the specified application filter is not selected.
  • An error code with the severity bit set to 1, indicating that the operation failed.

[Visual Basic]

The IsApplicationFilterSelected method cannot be used in Visual Basic.

Sub IsApplicationFilterSelected( _
  ByVal bstrAppFilterGuid As String _
)

Parameters

bstrAppFilterGuid
[in] String containing the globally unique identifier (GUID) of the application filter to check in the form {12345678-1234-1234-1234-123456789ABC}. Note the presence of the braces normally used with GUIDs.

Return Values

This method has no return values. If the call is unsuccessful, an error is raised that can be intercepted by using an error handler.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCSnapinPluginPolicy


IFPCSnapinPluginPolicy.IsProtocolSelected(String) method [ISA Server 2004]

IFPCSnapinPluginPolicy::IsProtocolSelected[C++]

FPCSnapinPluginPolicy.IsProtocolSelected [Visual Basic]

[C++]

The IsProtocolSelected method verifies that the specified protocol is selected.

HRESULT IsProtocolSelected(
  BSTR bstrProtocolGuid
);

Parameters

bstrProtocolGuid
[in] String containing the globally unique identifier (GUID) of the protocol to check in the form {12345678-1234-1234-1234-123456789ABC}. Note the presence of the braces normally used with GUIDs.

Return Values

This method can return one of the following:

  • S_OK (0x00000000), indicating that the specified protocol is selected.
  • S_FALSE (0x00000001), indicating that the specified protocol is not selected.
  • An error code with the severity bit set to 1, indicating that the operation failed.
[Visual Basic]

The IsProtocolSelected method cannot be used in Visual Basic.

Sub IsProtocolSelected( _
  ByVal bstrProtocolGuid As String _
)

Parameters

bstrProtocolGuid
[in] String containing the globally unique identifier (GUID) of the protocol to check in the form {12345678-1234-1234-1234-123456789ABC}. Note the presence of the braces normally used with GUIDs.

Return Values

This method has no return values. If the call is unsuccessful, an error is raised that can be intercepted by using an error handler.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCSnapinPluginPolicy


IFPCSnapinPluginPolicy.PolicyRule(IFPCPolicyRule) property [ISA Server 2004]

PolicyRule Property of IFPCSnapinPluginPolicy[C++]

FPCSnapinPluginPolicy.PolicyRule [Visual Basic]

[C++]

The PolicyRule property gets an FPCPolicyRule object that represents the policy rule of the plug-in policy.

HRESULT get_PolicyRule(
  IFPCPolicyRule** ppPolicyRule
);

Parameters

ppPolicyRule
Address of an interface pointer that on return points to an IFPCPolicyRule interface that represents the policy rule of the plug-in policy.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only. It can be modified by calling the properties and methods of the IFPCPolicyRule interface.

[Visual Basic]

The PolicyRule property gets an FPCPolicyRule object that represents the policy rule of the plug-in policy.

Property PolicyRule As FPCPolicyRule

Property Value

Reference to an FPCPolicyRule object that represents the policy rule of the plug-in policy.

Remarks

This property is read-only. It can be modified by calling the properties and methods of the FPCPolicyRule object.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCSnapinPluginPolicy


IFPCSnapinPluginPolicy.VendorParametersSets property [ISA Server 2004]

VendorParametersSets Property of IFPCSnapinPluginPolicy[C++]

FPCSnapinPluginPolicy.VendorParametersSets [Visual Basic]

[C++]

The VendorParametersSets property gets an FPCVendorParametersSets collection in which custom data can be stored for the extension.

HRESULT get_VendorParametersSets(
  IFPCVendorParametersSets** ppVendorParametersSets
);

Parameters

ppVendorParametersSets
Address of an interface pointer that on return points to an IFPCVendorParametersSets interface that represents a collection in which custom data can be stored for the extension.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only. Data can be added or removed by calling the methods of the IFPCVendorParametersSets interface.

[Visual Basic]

The VendorParametersSets property gets an FPCVendorParametersSets collection in which custom data can be stored for the extension.

Property VendorParametersSets As FPCVendorParametersSets

Property Value

Reference to an FPCVendorParametersSets collection.

Remarks

This property is read-only. Data can be added or removed by calling the methods of the FPCVendorParametersSets collection.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCSnapinPluginPolicy


FPCSubnet object [ISA Server 2004]

FPCSubnet

The FPCSubnet object represents a subnet.

This object is typically an element of an FPCSubnets collection.

Click here to see the ISA Server object hierarchy.

Inheritance

This object inherits from the FPCPersist object, which contains methods and properties related to the persistent storage of an object's data. They include methods for exporting the object's data to and importing it from an XML document.

Methods

This object has no methods.

Properties

The FPCSubnet object has the following properties.

Property | Description
Description | Gets or sets the description of the subnet.
IPAddress | Gets or sets the IP address of the subnet.
IPMask | Gets or sets the IP mask of the subnet.
Name | Gets or sets the name of the subnet.

Methods Inherited from FPCPersist

Name | Description
CancelWaitForChanges | Cancels the registration established by the WaitForChanges method (for use in C and C++ programming only).
CanImport | Returns a Boolean value that indicates whether the object's properties can be imported from the specified XML document.
Export | Writes the stored values of all of the object's properties to the specified XML document.
ExportToFile | Writes the stored values of all of the object's properties to the specified XML file.
GetServiceRestartMask | Retrieves a 32-bit bitmask of the FpcServices enumerated type that specifies which services need to be restarted for currently unsaved changes to take effect.
Import | Copies the values of all of the object's properties from the specified XML document to persistent storage.
ImportFromFile | Copies the values of all of the object's properties from the specified XML file to persistent storage.
LoadDocProperties | Provides the XML document's properties so that you can know what information can be imported from the document.
Refresh | Reads the values of all of the object's properties from persistent storage, overwriting any changes that have not been saved.
Save | Writes the current values of all of the object's properties to persistent storage.
WaitForChanges | Registers to wait for an event indicating that the contents of the object have changed (for use in C and C++ programming only).

Properties Inherited from FPCPersist

Name | Description
PersistentName | Gets the persistent name of the object. The persistent name of an object is a name that is unique for the object at the respective level of the COM object hierarchy.
VendorParametersSets | Gets an FPCVendorParametersSets object that can hold sets of custom data for extending the object.

Remarks

This object implements the IFPCSubnet interface.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

COM Objects


IFPCSubnet | FPCSubnet Description(BSTR,BSTR) property [ISA Server 2004]

Description Property of IFPCSubnet[C++]

FPCSubnet.Description [Visual Basic]

[C++]

The Description property gets or sets the description of the subnet.

HRESULT get_Description(
  BSTR** pbstrDescription
);

HRESULT put_Description(
  BSTR bstrDescription
);

Parameters

pbstrDescription
Pointer to a BSTR that is set on return to a string value specifying the description of the subnet.
bstrDescription
BSTR that specifies the description of the subnet.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write.

[Visual Basic]

The Description property gets or sets the description of the subnet.

Property Description As String

Property Value

String that specifies the description of the subnet.

Remarks

This property is read/write.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCSubnet


IFPCSubnet | FPCSubnet IPAddress(BSTR,BSTR) property [ISA Server 2004]

IPAddress Property of IFPCSubnet[C++]

FPCSubnet.IPAddress [Visual Basic]

[C++]

The IPAddress property gets or sets the IP address of the subnet.

HRESULT get_IPAddress(
  BSTR** pbstrIPAddress
);

HRESULT put_IPAddress(
  BSTR bstrIPAddress
);

Parameters

pbstrIPAddress
Pointer to a BSTR that is set on return to a string value specifying the IP address of the subnet.
bstrIPAddress
BSTR that specifies the IP address of the subnet.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write.

[Visual Basic]

The IPAddress property gets or sets the IP address of the subnet.

Property IPAddress As String

Property Value

String that specifies the IP address of the subnet.

Remarks

This property is read/write.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCSubnet


IFPCSubnet | FPCSubnet IPMask(BSTR,BSTR) property [ISA Server 2004]

IPMask Property of IFPCSubnet[C++]

FPCSubnet.IPMask [Visual Basic]

[C++]

The IPMask property gets or sets the IP mask of the subnet.

HRESULT get_IPMask(
  BSTR** pbstrIPMask
);

HRESULT put_IPMask(
  BSTR bstrIPMask
);

Parameters

pbstrIPMask
Pointer to a BSTR that is set on return to a string value specifying the IP mask of the subnet.
bstrIPMask
BSTR that specifies the IP mask of the subnet.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write.

[Visual Basic]

The IPMask property gets or sets the IP mask of the subnet.

Property IPMask As String

Property Value

String that specifies the IP mask of the subnet.

Remarks

This property is read/write.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCSubnet


IFPCSubnet | FPCSubnet Name(BSTR,BSTR) property [ISA Server 2004]

Name Property of IFPCSubnet[C++]

FPCSubnet.Name [Visual Basic]

[C++]

The Name property gets or sets the name of the subnet.

HRESULT get_Name(
  BSTR** pbstrName
);

HRESULT put_Name(
  BSTR bstrName
);

Parameters

pbstrName
Pointer to a BSTR that is set on return to a string value specifying the name of the subnet.
bstrName
BSTR that specifies the name of the subnet.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write.

[Visual Basic]

The Name property gets or sets the name of the subnet.

Property Name As String

Property Value

String that specifies the name of the subnet.

Remarks

This property is read/write.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCSubnet


FPCSubnets collection [ISA Server 2004]

FPCSubnets Collection

The FPCSubnets collection holds an ordered set of FPCSubnet objects, each of which represents a subnet.

Click here to see the ISA Server object hierarchy.

Inheritance

This collection inherits from the FPCPersist object, which contains methods and properties related to the persistent storage of an object's data. They include methods for exporting an object's data to and importing it from an XML document.

Methods

The FPCSubnets collection defines the following methods.

Method | Description
Add | Creates a new FPCSubnet object, adds it to the collection, and returns a reference to it.
Item | Retrieves the requested FPCSubnet object from the collection.
Remove | Removes a specified FPCSubnet object from the collection.

Properties

The FPCSubnets collection has the following properties.

Property | Description
_NewEnum | Gets an enumerator object for the collection.
Count | Gets the number of FPCSubnet objects in the collection.

Methods Inherited from FPCPersist

Name | Description
CancelWaitForChanges | Cancels the registration established by the WaitForChanges method (for use in C and C++ programming only).
CanImport | Returns a Boolean value that indicates whether the properties of the collection and its elements can be imported from the specified XML document.
Export | Writes the stored values of all the properties of the collection and its elements to the specified XML document.
ExportToFile | Writes the stored values of all the properties of the collection and its elements to the specified XML file.
GetServiceRestartMask | Retrieves a 32-bit bitmask of the FpcServices enumerated type that specifies which services need to be restarted for currently unsaved changes to take effect.
Import | Copies the values of all the properties of the collection and its elements from the specified XML document to persistent storage.
ImportFromFile | Copies the values of all the properties of the collection and its elements from the specified XML file to persistent storage.
LoadDocProperties | Provides the XML document's properties so that you can know what information can be imported from the document.
Refresh | Reads the values of all the properties of the collection and its elements from persistent storage, overwriting any changes that have not been saved.
Save | Writes the current values of all the properties of the collection and its elements to persistent storage.
WaitForChanges | Registers to wait for an event indicating that the contents of the object have changed (for use in C and C++ programming only).

Properties Inherited from FPCPersist

Name | Description
PersistentName | Gets the persistent name of the collection. The persistent name of an object is a name that is unique for the object at the respective level of the COM object hierarchy.
VendorParametersSets | Gets an FPCVendorParametersSets collection that can hold sets of custom data for extending the collection.

Remarks

This collection implements the IFPCSubnets interface.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

COM Objects


IFPCSubnets | FPCSubnets _NewEnum(IUnknown) property [ISA Server 2004]

_NewEnum Property of IFPCSubnets[C++]

FPCSubnets._NewEnum [Visual Basic]

[C++]

The _NewEnum property gets an enumerator object for the collection. An enumerator object provides serial access to the elements of the collection.

HRESULT get__NewEnum(
  IUnknown* ppEnum
);

Parameters

ppEnum
Address of an interface pointer that on return points to the IUnknown interface of an enumerator object that implements an IEnumVARIANT interface for the collection. An interface pointer to the IEnumVARIANT interface of the enumerator object can be retrieved by calling QueryInterface on the IUnknown interface returned.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The _NewEnum property gets an enumerator object for the collection. An enumerator object provides serial access to the elements of the collection.

Property _NewEnum As IUnknown

Property Value

Reference to an enumerator object that provides serial access to the elements of the collection.

Remarks

This property is read-only.

In Visual Basic and VBScript, this property is used implicitly in For Each...In...Next constructs.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCSubnets


IFPCSubnets | FPCSubnets Add (4 Parameters) method [ISA Server 2004]

IFPCSubnets::Add[C++]

FPCSubnets.Add [Visual Basic]

[C++]

The Add method creates a new FPCSubnet object, adds it to the collection, and returns a reference to it.

HRESULT Add(
  BSTR Name,
  BSTR IPAddress,
  BSTR IPMask,
  IFPCSubnet** ppNewItem
);

Parameters

Name
[in] Required. BSTR that specifies the name of the new subnet.
IPAddress
[in] Required. BSTR that specifies the IP address of the new subnet.
IPMask
[in] Required. BSTR that specifies the IP mask of the new subnet.
ppNewItem
[out] Address of an interface pointer that on return points to the new IFPCSubnet interface created.

Return Values

This method can return one of the following:

  • S_OK, indicating that the operation succeeded.
  • An error code, indicating that the operation failed. In this case, the [out] parameter returned is a null object.

[Visual Basic]

The Add method creates a new FPCSubnet object, adds it to the collection, and returns a reference to it.

Function Add( _
  ByVal Name As String, _
  ByVal IPAddress As String, _
  ByVal IPMask As String _
) As FPCSubnet

Parameters

Name
[in] Required. String that specifies the name of the new subnet.
IPAddress
[in] Required. String that specifies the IP address of the new subnet.
IPMask
[in] Required. String that specifies the IP mask of the new subnet.

Return Values

This method returns a reference to the new FPCSubnet object if successful. Otherwise, an error is raised that can be intercepted by using an error handler.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCSubnets


IFPCSubnets | FPCSubnets Count(long) property [ISA Server 2004]

Count Property of IFPCSubnets[C++]

FPCSubnets.Count [Visual Basic]

[C++]

The Count property gets the number of FPCSubnet objects in the collection.

HRESULT get_Count(
  long* plCount
);

Parameters

plCount
Pointer to a variable that on return receives a 32-bit integer specifying the number of FPCSubnet objects in the collection.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The Count property gets the number of FPCSubnet objects in the collection.

Property Count As Long

Property Value

A 32-bit integer that specifies the number of FPCSubnet objects in the collection.

Remarks

This property is read-only.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCSubnets


IFPCSubnets | FPCSubnets Item(Variant,IFPCSubnet) method [ISA Server 2004]

IFPCSubnets::Item[C++]

FPCSubnets.Item [Visual Basic]

[C++]

The Item method retrieves the requested IFPCSubnet interface from the collection.

HRESULT Item(
  VARIANT Index,
  IFPCSubnet** ppItem
);

Parameters

Index
[in] Required. Name or one-based index of the object to retrieve.
ppItem
[out] Address of an interface pointer that on return points to the FPCSubnet interface requested.

Return Values

This method can return one of the following:

  • S_OK, indicating the operation succeeded.
  • An error message, indicating that the operation failed. In this case, the [out] parameter returned is a null object.

[Visual Basic]

The Item method retrieves the requested FPCSubnet object from the collection.

Function Item( _
  ByVal Index As Variant _
) As IFPCSubnet

Parameters

Index
[in] Required. Name or one-based index of the object to retrieve.

Return Values

This method returns a reference to the FPCSubnet object if successful. Otherwise, an error is raised that can be intercepted by using an error handler.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCSubnets


IFPCSubnets | FPCSubnets Remove(Variant) method [ISA Server 2004]

IFPCSubnets::Remove[C++]

FPCSubnets.Remove [Visual Basic]

[C++]

The Remove method removes the specified FPCSubnet object from the collection.

HRESULT Remove(
  VARIANT Index
);

Parameters

Index
Required. Name or one-based index of the FPCSubnet object to remove.

Return Values

This method returns S_OK if the call is successful; otherwise, it returns an error code.
[Visual Basic]

The Remove method removes the specified FPCSubnet object from the collection.

Sub Remove( _
  ByVal Index As Variant _
)

Parameters

Index
Required. Name or one-based index of the FPCSubnet object to remove.

Return Values

This method has no return values. If the call is unsuccessful, an error is raised that can be intercepted by using an error handler.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCSubnets


FPCSummaryReports object [ISA Server 2004]

FPCSummaryReports

The FPCSummaryReports object provides access to the properties of summary reports.

The FPCSummaryReports object can be accessed through the SummaryReports property of an FPCReportsProperties object.

Click here to see the ISA Server object hierarchy.

Inheritance

This object inherits from the FPCPersist object, which contains methods and properties related to the persistent storage of an object's data. They include methods for exporting the object's data to and importing it from an XML document.

Methods

This object has no methods.

Properties

The FPCSummaryReports object has the following properties.

Property | Description
CacheReportSortOrder | Gets or sets a value from the FpcCacheReportSortOrder enumerated type that specifies how the information in the cache report is to be sorted.
ProtocolsReportTopNumber | Gets or sets the number of most frequently used protocols to include in a report.
SitesReportSortOrder | Gets or sets a value from the FpcTopSitesReportSortOrder enumerated type that specifies how the information in the sites report is to be sorted.
SitesReportTopNumber | Gets or sets the number of most frequently accessed sites to include in a report.
UsersReportSortOrder | Gets or sets a value from the FpcTopUsersReportSortOrder enumerated type that specifies how the information in the users report is to be sorted.
UsersReportTopNumber | Gets or sets the number of most active users to include in a report.

Methods Inherited from FPCPersist

Name | Description
CancelWaitForChanges | Cancels the registration established by the WaitForChanges method (for use in C and C++ programming only).
CanImport | Returns a Boolean value that indicates whether the object's properties can be imported from the specified XML document.
Export | Writes the stored values of all of the object's properties to the specified XML document.
ExportToFile | Writes the stored values of all of the object's properties to the specified XML file.
GetServiceRestartMask | Retrieves a 32-bit bitmask of the FpcServices enumerated type that specifies which services need to be restarted for currently unsaved changes to take effect.
Import | Copies the values of all of the object's properties from the specified XML document to persistent storage.
ImportFromFile | Copies the values of all of the object's properties from the specified XML file to persistent storage.
LoadDocProperties | Provides the XML document's properties so that you can know what information can be imported from the document.
Refresh | Reads the values of all of the object's properties from persistent storage, overwriting any changes that have not been saved.
Save | Writes the current values of all of the object's properties to persistent storage.
WaitForChanges | Registers to wait for an event indicating that the contents of the object have changed (for use in C and C++ programming only).

Properties Inherited from FPCPersist

Name | Description
PersistentName | Gets the persistent name of the object. The persistent name of an object is a name that is unique for the object at the respective level of the COM object hierarchy.
VendorParametersSets | Gets an FPCVendorParametersSets object that can hold sets of custom data for extending the object.

Remarks

This object implements the IFPCSummaryReports interface.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

COM Objects


IFPCSummaryReports.CacheReportSortOrder property [ISA Server 2004]

CacheReportSortOrder Property of IFPCSummaryReports[C++]

FPCSummaryReports.CacheReportSortOrder [Visual Basic]

[C++]

The CacheReportSortOrder property gets or sets the sort order for cache summary reports.

HRESULT get_CacheReportSortOrder(
  FpcCacheReportSortOrder* pCacheReportSortOrder
);

HRESULT put_CacheReportSortOrder(
  FpcCacheReportSortOrder CacheReportSortOrder
);

Parameters

pCacheReportSortOrder
Pointer to a value from the FpcCacheReportSortOrder enumerated type that is set on return to the value specifying the sort order.
CacheReportSortOrder
Value from the FpcCacheReportSortOrder enumerated type that specifies the sort order.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write.

[Visual Basic]

The CacheReportSortOrder property gets or sets the sort order for cache summary reports.

Property CacheReportSortOrder As FpcCacheReportSortOrder

Property Value

Value from the FpcCacheReportSortOrder enumerated type that specifies the sort order.

Remarks

This property is read/write.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCSummaryReports


IFPCSummaryReports.ProtocolsReportTopNumber property [ISA Server 2004]

ProtocolsReportTopNumber Property of IFPCSummaryReports[C++]

FPCSummaryReports.ProtocolsReportTopNumber [Visual Basic]

[C++]

The ProtocolsReportTopNumber property gets or sets the number of most used protocols to report.

HRESULT get_ProtocolsReportTopNumber(
  long* plTopNProtocols
);

HRESULT put_ProtocolsReportTopNumber(
  long lTopNProtocols
);

Parameters

plTopNProtocols
Pointer to a 32-bit integer that is set on return to a long value specifying the number of most used protocols to report.
lTopNProtocols
Long value that specifies the number of most used protocols to report.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write.

[Visual Basic]

The ProtocolsReportTopNumber property gets or sets the number of most used protocols to report.

Property ProtocolsReportTopNumber As Long

Property Value

A 32-bit integer that specifies the number of most used protocols to report.

Remarks

This property is read/write.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCSummaryReports


IFPCSummaryReports.SitesReportSortOrder property [ISA Server 2004]

SitesReportSortOrder Property of IFPCSummaryReports[C++]

FPCSummaryReports.SitesReportSortOrder [Visual Basic]

[C++]

The SitesReportSortOrder property gets or sets a value from the FpcTopSitesReportSortOrder enumerated type that specifies how the information in the sites report is to be sorted. The sites report contains information about which sites clients are visiting. The report can be sorted according to the number of users that visit each site, the number of requests sent to each site, or the number of bytes transferred.

HRESULT get_SitesReportSortOrder(
  FpcTopSitesReportSortOrder pSitesReportSortOrder
);

HRESULT put_SitesReportSortOrder(
  FpcTopSitesReportSortOrder SitesReportSortOrder
);

Parameters

pSitesReportSortOrder
Pointer to a variable that on return receives a value from the FpcTopSitesReportSortOrder enumerated type that specifies how the information in the sites report is to be sorted.
SitesReportSortOrder
Value from the FpcTopSitesReportSortOrder enumerated type that specifies how the information in the sites report is to be sorted.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write.

[Visual Basic]

The SitesReportSortOrder property gets or sets a value from the FpcTopSitesReportSortOrder enumerated type that specifies how the information in the sites report is to be sorted. The sites report contains information about which sites clients are visiting. The report can be sorted according to the number of users that visit each site, the number of requests sent to each site, or the number of bytes transferred.

Property SitesReportSortOrder As FpcTopSitesReportSortOrder

Property Value

Value from the FpcTopSitesReportSortOrder enumerated type that specifies how the information in the sites report is to be sorted.

Remarks

This property is read/write.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCSummaryReports


IFPCSummaryReports.SitesReportTopNumber(long,long) property [ISA Server 2004]

SitesReportTopNumber Property of IFPCSummaryReports[C++]

FPCSummaryReports.SitesReportTopNumber [Visual Basic]

[C++]

The SitesReportTopNumber property gets or sets the number of most accessed sites to report.

HRESULT get_SitesReportTopNumber(
  long* plTopNSites
);

HRESULT put_SitesReportTopNumber(
  long lTopNSites
);

Parameters

plTopNSites
Pointer to a 32-bit integer that is set on return to a long value specifying the number of most accessed sites to report.
lTopNSites
Long value that specifies the number of most accessed sites to report.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write.

[Visual Basic]

The SitesReportTopNumber property gets or sets the number of most accessed sites to report.

Property SitesReportTopNumber As Long

Property Value

A 32-bit integer that specifies the number of most accessed sites to report.

Remarks

This property is read/write.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCSummaryReports


IFPCSummaryReports.UsersReportSortOrder property [ISA Server 2004]

UsersReportSortOrder Property of IFPCSummaryReports[C++]

FPCSummaryReports.UsersReportSortOrder [Visual Basic]

[C++]

The UsersReportSortOrder property gets or sets a value from the FpcTopUsersReportSortOrder enumerated type that specifies how the information in the users report is to be sorted. The users report contains information about the most active users. The report can be sorted according to the number of requests sent by each user or the number of bytes transferred for each user.

HRESULT get_UsersReportSortOrder(
  FpcTopUsersReportSortOrder pTopUsersReportSortOrder
);

HRESULT put_UsersReportSortOrder(
  FpcTopUsersReportSortOrder TopUsersReportSortOrder
);

Parameters

pTopUsersReportSortOrder
Pointer to a variable that on return receives a value from the FpcTopUsersReportSortOrder enumerated type that specifies how the information in the users report is to be sorted.
TopUsersReportSortOrder
Value from the FpcTopUsersReportSortOrder enumerated type that specifies how the information in the users report is to be sorted.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write.

[Visual Basic]

The UsersReportSortOrder property gets or sets a value from the FpcTopUsersReportSortOrder enumerated type that specifies how the information in the users report is to be sorted. The users report contains information about the most active users. The report can be sorted according to the number of requests sent by each user or the number of bytes transferred for each user.

Property UsersReportSortOrder As FpcTopUsersReportSortOrder

Property Value

Value from the FpcTopUsersReportSortOrder enumerated type that specifies how the information in the users report is to be sorted.

Remarks

This property is read/write.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCSummaryReports


IFPCSummaryReports.UsersReportTopNumber(long,long) property [ISA Server 2004]

UsersReportTopNumber Property of IFPCSummaryReports[C++]

FPCSummaryReports.UsersReportTopNumber [Visual Basic]

[C++]

The UsersReportTopNumber property gets or sets the number of most active users to include in the report.

HRESULT get_UsersReportTopNumber(
  long* plTopNUsers
);

HRESULT put_UsersReportTopNumber(
  long lTopNUsers
);

Parameters

plTopNUsers
Pointer to a 32-bit integer that is set on return to a long value specifying the number of most active users to include in the report.
lTopNUsers
Long value that specifies the number of most active users to include in the report.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write.

[Visual Basic]

The UsersReportTopNumber property gets or sets the number of most active users to include in the report.

Property UsersReportTopNumber As Long

Property Value

A 32-bit integer that specifies the number of most active users to include in the report.

Remarks

This property is read/write.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCSummaryReports


FPCSystemPolicy object [ISA Server 2004]

FPCSystemPolicy

The FPCSystemPolicy object represents the system policy for an array. The system policy is defined by a set of policy rules, called system policy rule. A system policy rule is a predefined rule that allows specific types of requests from the Local Host network (the ISA Server computer) to reach specified destinations, or allows specific types of requests from specified sources to reach the Local Host network. Each system policy rule belongs to a group of policy rules that apply to a specific service and can be configured together. Such a group is called a configuration group.

This object is typically accessed through the SystemPolicy property of the FPCArray object.

Click here to see the ISA Server object hierarchy.

Inheritance

This object inherits from the FPCPersist object, which contains methods and properties related to the persistent storage of an object's data. They include methods for exporting the object's data to and importing it from an XML document.

Methods

The FPCSystemPolicy object defines the following method.

Method | Description
CreateConfigurationGroupInstance | Creates an instance of the FPCSystemPolicyConfigGroup object for the system policy configuration group requested and returns a reference to it.

Properties

The FPCSystemPolicy object has the following property.

Property | Description
PolicyRules | Gets the FPCSystemPolicyRules collection of all of the system policy rules for the array.

Methods Inherited from FPCPersist

Name | Description
CancelWaitForChanges | Cancels the registration established by the WaitForChanges method (for use in C and C++ programming only).
CanImport | Returns a Boolean value that indicates whether the object's properties can be imported from the specified XML document.
Export | Recursively writes the stored values of all the properties of the object and its subobjects to the specified XML document.
ExportToFile | Recursively writes the stored values of all the properties of the object and its subobjects to the specified XML file.
GetServiceRestartMask | Retrieves a 32-bit bitmask of the FpcServices enumerated type that specifies which services need to be restarted for currently unsaved changes to take effect.
Import | Recursively copies the values of all the properties of the object and of its subobjects from the specified XML document to persistent storage.
ImportFromFile | Recursively copies the values of all the properties of the object and of its subobjects from the specified XML file to persistent storage.
LoadDocProperties | Provides the XML document's properties so that you can know what information can be imported from the document.
Refresh | Recursively reads the values of all the properties of the object and of its subobjects from persistent storage, overwriting any changes that have not been saved.
Save | Recursively writes the current values of all the properties of the object and its subobjects to persistent storage.
WaitForChanges | Registers to wait for an event indicating that the contents of the object have changed (for use in C and C++ programming only).

Properties Inherited from FPCPersist

Name | Description
PersistentName | Gets the persistent name of the object. The persistent name of an object is a name that is unique for the object at the respective level of the COM object hierarchy.
VendorParametersSets | Gets an FPCVendorParametersSets collection that can hold sets of custom data for extending the object.

Remarks

This collection implements the IFPCSystemPolicy interface.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

COM Objects


IFPCSystemPolicy.CreateConfigurationGroupInstance method [ISA Server 2004]

IFPCSystemPolicy::CreateConfigurationGroupInstance[C++]

FPCSystemPolicy.CreateConfigurationGroupInstance [Visual Basic]

[C++]

The CreateConfigurationGroupInstance method creates an instance of the IFPCSystemPolicyConfigGroup interface for the system policy configuration group requested and supplies a pointer to it.

HRESULT CreateConfigurationGroupInstance(
  FpcSystemPolicyConfigGroupEnum Service,
  IFPCSystemPolicyConfigGroup** ppConfigGroup
);

Parameters

Service
[in] Value from the FpcSystemPolicyConfigGroupEnum enumerated type that indicates a specific configuration group.
ppConfigGroup
[out] Address of an interface pointer that on return points to the instance of the IFPCSystemPolicyConfigGroup interface created.

Return Values

This method can return one of the following:

  • S_OK, indicating that the operation succeeded.
  • An error code, indicating that the operation failed. In this case, the [out] parameter returned is a null object.

Remarks

Each new instance of the IFPCSystemPolicyConfigGroup interface is created with the last saved properties of the rules belonging to the applicable configuration group.

Changes made in a configuration group can be saved only by calling the Save method on the IFPCSystemPolicyConfigGroup interface. They are not written to persistent storage when the FPCSystemPolicy object or any object above it in the ISA Server object hierarchy is saved.

[Visual Basic]

The CreateConfigurationGroupInstance method creates an instance of the FPCSystemPolicyConfigGroup object for the system policy configuration group requested and returns a reference to it.

Function CreateConfigurationGroupInstance( _
  ByVal Service As FpcSystemPolicyConfigGroupEnum _
) As FPCSystemPolicyConfigGroup

Parameters

Service
[in] Value from the FpcSystemPolicyConfigGroupEnum enumerated type that indicates a specific configuration group.

Return Values

This method returns a reference to the instance of the FPCSystemPolicyConfigGroup object created if successful. Otherwise, an error is raised that can be intercepted by using an error handler.

Remarks

Each new instance of the FPCSystemPolicyConfigGroup object is created with the last saved properties of the rules belonging to the applicable configuration group.

Changes made in a configuration group can be saved only by calling the Save method on the FPCSystemPolicyConfigGroup object. They are not written to persistent storage when the FPCSystemPolicy object or any object above it in the ISA Server object hierarchy is saved.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCSystemPolicy


IFPCSystemPolicy | FPCSystemPolicy PolicyRules property [ISA Server 2004]

PolicyRules Property of IFPCSystemPolicy[C++]

FPCSystemPolicy.PolicyRules [Visual Basic]

[C++]

The PolicyRules property gets the FPCSystemPolicyRules collection of all of the system policy rules in the array.

HRESULT get_PolicyRules(
  IFPCSystemPolicyRules** ppSystemPolicyRules
);

Parameters

ppSystemPolicyRules
Address of an interface pointer that on return points to an IFPCSystemPolicyRules interface that represents the collection of system policy rules.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The PolicyRules property gets the FPCSystemPolicyRules collection of all of the system policy rules in the array.

Property PolicyRules As FPCSystemPolicyRules

Property Value

Reference to an FPCSystemPolicyRules collection of system policy rules.

Remarks

This property is read-only.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCSystemPolicy


FPCSystemPolicyConfigGroup object [ISA Server 2004]

FPCSystemPolicyConfigGroup

The FPCSystemPolicyConfigGroup object allows you to access the group-specific properties of the system policy rules belonging to a specific configuration group. The available configuration groups are defined in the FpcSystemPolicyConfigGroupEnum enumerated type.

An instance of this object can be created by calling the CreateConfigurationGroupInstance method of an FPCSystemPolicy object. Each new instance of the FPCSystemPolicyConfigGroup object is created with the last saved properties of the rules belonging to the applicable configuration group. Changes made in a configuration group can be saved only by calling the Save method on the FPCSystemPolicyConfigGroup object. They are not written to persistent storage when the FPCSystemPolicy object or any object above it in the ISA Server object hierarchy is saved.

Click here to see the ISA Server object hierarchy.

Inheritance

This object inherits from the FPCPersist object, which contains methods and properties related to the persistent storage of an object's data. They include methods for exporting the object's data to and importing it from an XML document.

Methods

This object has no methods.

Properties

The FPCSystemPolicyConfigGroup object has the following properties.

Property | Description
DestinationDomainNameSets | Gets an FPCRefs collection that contains references to the FPCDomainNameSet collections defining the destination domain name sets to which the rules of the configuration group apply.
DestinationSelectionIPs | Gets an FPCSelectionIPs object that specifies the complete set of destination IP addresses to which the rules of the configuration group apply.
Enabled | Gets or sets a Boolean value that indicates whether the system policy rules of the configuration group are enabled.
SourceSelectionIPs | Gets an FPCSelectionIPs object that specifies the complete set of source IP addresses to which the rules of the configuration group apply.
URLSets | Gets an FPCRefs collection that contains references to the FPCURLSet collections defining the URL sets to which the rules of the configuration group apply.

Methods Inherited from FPCPersist

Name | Description
CancelWaitForChanges | Cancels the registration established by the WaitForChanges method (for use in C and C++ programming only).
CanImport | Returns a Boolean value that indicates whether the object's properties can be imported from the specified XML document.
Export | Recursively writes the stored values of all the properties of the object and its subobjects to the specified XML document.
ExportToFile | Recursively writes the stored values of all the properties of the object and its subobjects to the specified XML file.
GetServiceRestartMask | Retrieves a 32-bit bitmask of the FpcServices enumerated type that specifies which services need to be restarted for currently unsaved changes to take effect.
Import | Recursively copies the values of all the properties of the object and of its subobjects from the specified XML document to persistent storage.
ImportFromFile | Recursively copies the values of all the properties of the object and of its subobjects from the specified XML file to persistent storage.
LoadDocProperties | Provides the XML document's properties so that you can know what information can be imported from the document.
Refresh | Recursively reads the values of all the properties of the object and of its subobjects from persistent storage, overwriting any changes that have not been saved.
Save | Recursively writes the current values of all the properties of the object and its subobjects to persistent storage.
WaitForChanges | Registers to wait for an event indicating that the contents of the object have changed (for use in C and C++ programming only).

Properties Inherited from FPCPersist

Name | Description
PersistentName | Gets the persistent name of the object. The persistent name of an object is a name that is unique for the object at the respective level of the COM object hierarchy.
VendorParametersSets | Gets an FPCVendorParametersSets collection that can hold sets of custom data for extending the object.

Remarks

This collection implements the IFPCSystemPolicyConfigGroup interface.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

COM Objects


IFPCSystemPolicyConfigGroup.DestinationDomainNameSets property [ISA Server 2004]

DestinationDomainNameSets Property of IFPCSystemPolicyConfigGroup[C++]

FPCSystemPolicyConfigGroup.DestinationDomainNameSets [Visual Basic]

[C++]

The DestinationDomainNameSets property gets an FPCRefs collection that contains references to the FPCDomainNameSet collections defining the destination domain name sets to which the rules of the configuration group apply.

HRESULT get_DestinationDomainNameSets(
  IFPCRefs** ppRefs
);

Parameters

ppRefs
Address of a variable that receives a pointer to an IFPCRefs interface that represents the collection of destination domain name sets to which the rules of the configuration group apply.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only. It can be modified by calling the methods of the IFPCRefs interface retrieved.

[Visual Basic]

The DestinationDomainNameSets property gets an FPCRefs collection that contains references to the FPCDomainNameSet collections defining the destination domain name sets to which the rules of the configuration group apply.

Property DestinationDomainNameSets As FPCRefs

Property Value

Reference to an FPCRefs collection that contains references to the destination domain name sets to which the rules of the configuration group apply.

Remarks

This property is read-only. It can be modified by calling the methods of the FPCRefs collection retrieved.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCSystemPolicyConfigGroup


IFPCSystemPolicyConfigGroup.DestinationSelectionIPs property [ISA Server 2004]

DestinationSelectionIPs Property of IFPCSystemPolicyConfigGroup[C++]

FPCSystemPolicyConfigGroup.DestinationSelectionIPs [Visual Basic]

[C++]

The DestinationSelectionIPs property gets an FPCSelectionIPs object that specifies the complete set of destination IP addresses to which the rules of the configuration group apply. This set may include computers, networks, network sets, subnets, or IP address ranges.

HRESULT get_DestinationSelectionIPs(
  IFPCSelectionIPs** ppSelectionIPs
);

Parameters

ppSelectionIPs
Address of an interface pointer that on return points to an IFPCSelectionIPs interface that represents the complete set of destination IP addresses to which the rules of the configuration group apply.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only. It can be modified through the properties of the IFPCSelectionIPs interface retrieved.

[Visual Basic]

The DestinationSelectionIPs property gets an FPCSelectionIPs object that specifies the complete set of destination IP addresses to which the rules of the configuration group apply. This set may include computers, networks, network sets, subnets, or IP address ranges.

Property DestinationSelectionIPs As FPCSelectionIPs

Property Value

Reference to an FPCSelectionIPs object that specifies the complete set of destination IP addresses to which the rules of the configuration group apply.

Remarks

This property is read-only. It can be modified through the properties of the FPCSelectionIPs object retrieved.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCSystemPolicyConfigGroup


IFPCSystemPolicyConfigGroup.Enabled (2 Parameters) property [ISA Server 2004]

Enabled Property of IFPCSystemPolicyConfigGroup[C++]

FPCSystemPolicyConfigGroup.Enabled [Visual Basic]

[C++]

The Enabled property gets or sets a Boolean value that indicates whether the rules of the configuration group are enabled.

HRESULT get_Enabled(
  VARIANT_BOOL* pfEnabled
);

HRESULT put_Enabled(
  VARIANT_BOOL fEnabled
);

Parameters

pfEnabled
Pointer to a Boolean variable that is set on return to VARIANT_TRUE if the rules of the configuration group are enabled, or to VARIANT_FALSE if the rules of the configuration group are disabled.
fEnabled
Boolean value that indicates whether the rules of the configuration group are enabled.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write.

[Visual Basic]

The Enabled property gets or sets a Boolean value that indicates whether the rules of the configuration group are enabled.

Property Enabled As Boolean

Property Value

Boolean value that indicates whether the rules of the configuration group are enabled.

Remarks

This property is read/write.

Example Code

This VBScript code example enables the Scheduled Download Jobs system policy configuration group if it is not enabled.

' Define an enumeration value.
const fpcSystemPolicyConfigGroup_Prefetcher = 12

' Create the root obect.
Dim root  ' The FPCLib.FPC root object
Set root = CreateObject("FPC.Root")

' Declare the other objects needed.
Dim array         ' An FPCArray object
Dim configgroup   ' An FPCSystemPolicyConfigGroup object

' Get a reference to the array object.
Set array = root.GetContainingArray()

' Create an instance of the sytem policy configuration
' group object for the Job Scheduler service.
Set configgroup = array.SystemPolicy.CreateConfigurationGroupInstance(fpcSystemPolicyConfigGroup_Prefetcher)

' If the Scheduled Download Jobs system policy configuration group
' is disabled, enable it.
If configgroup.Enabled = False Then
    configgroup.Enabled = True
    configgroup.Save
End If

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCSystemPolicyConfigGroup


IFPCSystemPolicyConfigGroup.SourceSelectionIPs property [ISA Server 2004]

SourceSelectionIPs Property of IFPCSystemPolicyConfigGroup[C++]

FPCSystemPolicyConfigGroup.SourceSelectionIPs [Visual Basic]

[C++]

The SourceSelectionIPs property gets an FPCSelectionIPs object that specifies the complete set of source IP addresses to which the rules of the configuration group apply. This set may include computers, networks, network sets, subnets, or IP address ranges.

HRESULT get_SourceSelectionIPs(
  IFPCSelectionIPs** ppSelectionIPs
);

Parameters

ppSelectionIPs
Address of an interface pointer that on return points to an IFPCSelectionIPs interface that represents the complete set of source IP addresses to which the rules of the configuration group apply.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only. It can be modified through the properties of the IFPCSelectionIPs interface retrieved.

[Visual Basic]

The SourceSelectionIPs property gets an FPCSelectionIPs object that specifies the complete set of source IP addresses to which the rules of the configuration group apply. This set may include computers, networks, network sets, subnets, or IP address ranges.

Property SourceSelectionIPs As FPCSelectionIPs

Property Value

Reference to an FPCSelectionIPs object that specifies the complete set of source IP addresses to which the rules of the configuration group apply.

Remarks

This property is read-only. It can be modified through the properties of the FPCSelectionIPs object retrieved.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCSystemPolicyConfigGroup


IFPCSystemPolicyConfigGroup.URLSets(IFPCRefs) property [ISA Server 2004]

URLSets Property of IFPCSystemPolicyConfigGroup[C++]

FPCSystemPolicyConfigGroup.URLSets [Visual Basic]

[C++]

The URLSets property gets an FPCRefs collection that contains references to the FPCURLSet collections defining the URL sets to which the rules of the configuration group apply.

HRESULT get_URLSets(
  IFPCRefs** ppRefs
);

Parameters

ppRefs
Address of a variable that receives a pointer to an IFPCRefs interface that represents the collection of references to the URL sets to which the rules of the configuration group apply.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only. It can be modified by calling the methods of the IFPCRefs interface.

[Visual Basic]

The URLSets property gets an FPCRefs collection that contains references to the FPCURLSet collections defining the URL sets to which the rules of the configuration group apply.

Property URLSets As FPCRefs

Property Value

Reference to an FPCRefs collection that contains references to the URL sets to which the rules of the configuration group apply.

Remarks

This property is read-only. It can be modified by calling the methods of the FPCRefs collection.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCSystemPolicyConfigGroup


FPCSystemPolicyRules collection [ISA Server 2004]

FPCSystemPolicyRules Collection

The FPCSystemPolicyRules collection is a read-only collection of FPCPolicyRule objects that represent system policy rules. A system policy rule is a predefined rule that allows specific types of requests from the Local Host network (the ISA Server computer) to reach specified destinations, or allows specific types of requests from specified sources to reach the Local Host network.

This collection is accessed through the PolicyRules property of the FPCSystemPolicy object.

Click here to see the ISA Server object hierarchy.

Inheritance

This collection inherits from the FPCPersist object, which contains methods and properties related to the persistent storage of an object's data. They include methods for exporting the object's data to and importing it from an XML document.

Methods

The FPCSystemPolicyRules collection defines the following method.

Method | Description
Item | Retrieves the requested FPCPolicyRule object from the collection of system policy rules.

Properties

The FPCSystemPolicyRules collection has the following properties.

Property | Description
_NewEnum | Gets an enumerator object for the collection.
Count | Gets the number of FPCPolicyRule objects representing system policy rules in the collection.

Methods Inherited from FPCPersist

Name | Description
CancelWaitForChanges | Cancels the registration established by the WaitForChanges method (for use in C and C++ programming only).
CanImport | Returns a Boolean value that indicates whether the properties of the collection, its elements, and their subobjects can be imported from the specified XML document.
Export | Recursively writes the stored values of all the properties of the collection, its elements, and their subobjects to the specified XML document.
ExportToFile | Recursively writes the stored values of all the properties of the collection, its elements, and their subobjects to the specified XML file.
GetServiceRestartMask | Retrieves a 32-bit bitmask of the FpcServices enumerated type that specifies which services need to be restarted for currently unsaved changes to take effect.
Import | Recursively copies the values of all the properties of the collection, its elements, and their subobjects from the specified XML document to persistent storage.
ImportFromFile | Recursively copies the values of all the properties of the collection, its elements, and their subobjects from the specified XML file to persistent storage.
LoadDocProperties | Provides the XML document's properties so that you can know what information can be imported from the document.
Refresh | Recursively reads the values of all the properties of the collection, its elements, and their subobjects from persistent storage, overwriting any changes that have not been saved.
Save | Recursively writes the current values of all the properties of the collection, its elements, and their subobjects to persistent storage.
WaitForChanges | Registers to wait for an event indicating that the contents of the object have changed (for use in C and C++ programming only).

Properties Inherited from FPCPersist

Name | Description
PersistentName | Gets the persistent name of the collection. The persistent name of an object is a name that is unique for the object at the respective level of the COM object hierarchy.
VendorParametersSets | Gets an FPCVendorParametersSets collection that can hold sets of custom data for extending the collection.

Remarks

This collection implements the IFPCSystemPolicyRules interface.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

COM Objects


IFPCSystemPolicyRules._NewEnum(IUnknown) property [ISA Server 2004]

_NewEnum Property of IFPCSystemPolicyRules[C++]

FPCSystemPolicyRules._NewEnum [Visual Basic]

[C++]

The _NewEnum property gets an enumerator object for the collection. An enumerator object provides serial access to the elements of the collection.

HRESULT get__NewEnum(
  IUnknown* ppEnum
);

Parameters

ppEnum
Address of an interface pointer that on return points to the IUnknown interface of an enumerator object that implements an IEnumVARIANT interface for the collection. An interface pointer to the IEnumVARIANT interface of the enumerator object can be retrieved by calling QueryInterface on the IUnknown interface returned.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The _NewEnum property gets an enumerator object for the collection. An enumerator object provides serial access to the elements of the collection.

Property _NewEnum As IUnknown

Property Value

Reference to an enumerator object that provides serial access to the elements of the collection.

Remarks

This property is read-only.

In Visual Basic and VBScript, this property is used implicitly in For Each...In...Next constructs.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCSystemPolicyRules


IFPCSystemPolicyRules | FPCSystemPolicyRules Count property [ISA Server 2004]

Count Property of IFPCSystemPolicyRules[C++]

FPCSystemPolicyRules.Count [Visual Basic]

[C++]

The Count property gets the number of FPCPolicyRule objects representing system policy rules in the collection.

HRESULT get_Count(
  long* plCount
);

Parameters

plCount
Pointer to a 32-bit integer that is set on return to a long value specifying the number of FPCPolicyRule objects.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The Count property gets the number of FPCPolicyRule objects representing system policy rules in the collection.

Property Count As Long

Property Value

A 32-bit integer that specifies the number of FPCPolicyRule objects representing system policy rules in the collection.

Remarks

This property is read-only.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCSystemPolicyRules


IFPCSystemPolicyRules | FPCSystemPolicyRules Item method [ISA Server 2004]

IFPCSystemPolicyRules::Item[C++]

FPCSystemPolicyRules.Item [Visual Basic]

[C++]

The Item method retrieves the requested IFPCPolicyRule interface from the collection of system policy rules.

HRESULT Item(
  VARIANT Index,
  IFPCPolicyRule** ppItem
);

Parameters

Index
Required. Name or one-based index of the object to retrieve.
ppItem
[out] Address of an interface pointer that on return points to the IFPCPolicyRule interface requested.

Return Values

This method can return one of the following:

  • S_OK, indicating that the operation succeeded.
  • An error code, indicating that the operation failed. In this case, the [out] parameter returned is a null object.

[Visual Basic]

The Item method retrieves the requested FPCPolicyRule object from the collection of system policy rules.

Sub Item( _
  ByVal Index As Variant _
)

Parameters

Index
Required. Name or one-based index of the object to retrieve.

Return Values

This method returns a reference to the FPCPolicyRule object if successful. Otherwise, an error is raised that can be intercepted by using an error handler.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCSystemPolicyRules


FPCTrafficReports object [ISA Server 2004]

FPCTrafficReports

The FPCTrafficReports object contains the properties of traffic reports.

Click here to see the ISA Server object hierarchy.

Inheritance

This object inherits from the FPCPersist object, which contains methods and properties related to the persistent storage of an object's data. They include methods for exporting the object's data to and importing it from an XML document.

Methods

This object has no methods.

Properties

The FPCTrafficReports object has the following properties.

Property | Description
CacheReportSortOrder | Gets or sets the sort order for the cache report.
ProtocolsReportTopNumber | Gets or sets the number of most used protocols to include in the report.

Methods Inherited from FPCPersist

Name | Description
CancelWaitForChanges | Cancels the registration established by the WaitForChanges method (for use in C and C++ programming only).
CanImport | Returns a Boolean value that indicates whether the object's properties can be imported from the specified XML document.
Export | Writes the stored values of all of the object's properties to the specified XML document.
ExportToFile | Writes the stored values of all of the object's properties to the specified XML file.
GetServiceRestartMask | Retrieves a 32-bit bitmask of the FpcServices enumerated type that specifies which services need to be restarted for currently unsaved changes to take effect.
Import | Copies the values of all of the object's properties from the specified XML document to persistent storage.
ImportFromFile | Copies the values of all of the object's properties from the specified XML file to persistent storage.
LoadDocProperties | Provides the XML document's properties so that you can know what information can be imported from the document.
Refresh | Reads the values of all of the object's properties from persistent storage, overwriting any changes that have not been saved.
Save | Writes the current values of all of the object's properties to persistent storage.
WaitForChanges | Registers to wait for an event indicating that the contents of the object have changed (for use in C and C++ programming only).

Properties Inherited from FPCPersist

Name | Description
PersistentName | Gets the persistent name of the object. The persistent name of an object is a name that is unique for the object at the respective level of the COM object hierarchy.
VendorParametersSets | Gets an FPCVendorParametersSets object that can hold sets of custom data for extending the object.

Remarks

This collection implements the IFPCTrafficReports interface.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

COM Objects


IFPCTrafficReports.CacheReportSortOrder property [ISA Server 2004]

CacheReportSortOrder Property of IFPCTrafficReports[C++]

FPCTrafficReports.CacheReportSortOrder [Visual Basic]

[C++]

The CacheReportSortOrder property gets or sets how information in the cache report is sorted. The cache report contains information about what cache clients are using. The report can be sorted based on the number of requests to the cache, or on the number of bytes retrieved from the cache.

HRESULT get_CacheReportSortOrder(
  FpcCacheReportSortOrder* pCacheSortOrder
);

HRESULT put_CacheReportSortOrder(
  FpcCacheReportSortOrder CacheSortOrder
);

Parameters

pCacheSortOrder
Pointer to a value from the FpcCacheReportSortOrder enumerated type that is set on return to the value indicating how the report information should be sorted.
CacheSortOrder
Value from the FpcCacheReportSortOrder enumerated type that indicates how the report information is sorted.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write.

[Visual Basic]

The CacheReportSortOrder property gets or sets how information in the cache report is sorted. The cache report contains information about what cache clients are using. The report can be sorted based on the number of requests to the cache, or on the number of bytes retrieved from the cache.

Property CacheReportSortOrder As FpcCacheReportSortOrder

Property Value

Value from the FpcCacheReportSortOrder enumerated type that indicates how the report information is sorted.

Remarks

This property is read/write.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCTrafficReports


IFPCTrafficReports.ProtocolsReportTopNumber property [ISA Server 2004]

ProtocolsReportTopNumber Property of IFPCTrafficReports[C++]

FPCTrafficReports.ProtocolsReportTopNumber [Visual Basic]

[C++]

The ProtocolsReportTopNumber property gets or sets the number of most used protocols to include in the report.

HRESULT get_ProtocolsReportTopNumber(
  long* plTopNProtocols
);

HRESULT put_ProtocolsReportTopNumber(
  long lTopNProtocols
);

Parameters

plTopNProtocols
Pointer to a 32-bit integer that is set on return to a long value specifying the number of most used protocols to include in the report.
lTopNProtocols
Long value that specifies the number of most used protocols to include in the report.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write.

[Visual Basic]

The ProtocolsReportTopNumber property gets or sets the number of most used protocols to include in the report.

Property ProtocolsReportTopNumber As Long

Property Value

A 32-bit integer that specifies the number of most used protocols to include in the report.

Remarks

This property is read/write.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCTrafficReports


FPCTunnelPortRange object [ISA Server 2004]

FPCTunnelPortRange

The FPCTunnelPortRange object provides access to a tunnel port range.

A tunnel port allows ISA Server to work as a data pump for communication to particular ports on an External server. Because this effectively bypasses ISA Server protocol rules, the external port ranges for which this is possible are set by default to 443–443 (the single port 443 for SSL) and to 563–563 (the single port 563 for NNTP). You can use the properties of the FPCTunnelPortRange object to change the port range in which a tunnel port can be created.

This object is typically an element of an FPCTunnelPortRanges collection.

Click here to see the ISA Server object hierarchy.

Methods

The FPCTunnelPortRange object defines the following methods.

Method | Description
Refresh | Reads the values of all of the object's properties from persistent storage, discarding any changes that have not been saved.
Save | Writes the current values of all of the object's properties to persistent storage.

Properties

The FPCTunnelPortRange object has the following properties.

Property | Description
Name | Gets or sets the name of the tunnel port range.
TunnelHighPort | Gets or sets the high end of the tunnel port range.
TunnelLowPort | Gets or sets the low end of the tunnel port range.

Remarks

This object implements the IFPCTunnelPortRange interface.

Example Code [Visual Basic]

The following Visual Basic example shows how to create a new tunnel port range consisting of a single port.

Dim root As FPC
Dim tpRanges As FPCTunnelPortRanges
Dim newRange As FPCTunnelPortRange

set root = CreateObject("FPC.Root")
set tpRanges = root.GetContainingArray.ArrayPolicy.WebProxy.TunnelPortRanges
set newRange = tpRanges.AddRange("SSL 3520", 3520, 3520)
tpRanges.Save

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

COM Objects


IFPCTunnelPortRange | FPCTunnelPortRange Name property [ISA Server 2004]

Name Property of IFPCTunnelPortRange[C++]

FPCTunnelPortRange.Name [Visual Basic]

[C++]

The Name property gets or sets the name of the tunnel port range.

HRESULT get_Name(
  BSTR* pbstrName
);

HRESULT put_Name(
  BSTR bstrName
);

Parameters

pbstrName
Pointer to a BSTR that is set on return to a string value specifying the name of the tunnel port range.
bstrName
BSTR that specifies the name of the tunnel port range.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write.

[Visual Basic]

The Name property gets or sets the name of the tunnel port range.

Property Name As String

Property Value

String that specifies the name of the tunnel port range.

Remarks

This property is read/write.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCTunnelPortRange


IFPCTunnelPortRange | FPCTunnelPortRange Refresh method [ISA Server 2004]

IFPCTunnelPortRange::Refresh[C++]

FPCTunnelPortRange.Refresh [Visual Basic]

[C++]

The Refresh method reads the values of all of the object's properties from persistent storage, discarding any changes that have not been saved.

HRESULT Refresh();

Parameters

This method has no parameters.

Return Values

This method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

Changes made to this object can be saved by calling the Save method of this object or the Save method of any object containing it.

[Visual Basic]

The Refresh method reads the values of all of the object's properties from persistent storage, discarding any changes that have not been saved.

Sub Refresh()

Parameters

This method has no parameters.

Return Values

This method has no return values. If the call is unsuccessful, an error is raised that can be intercepted by using an error handler.

Remarks

Changes made to this object can be saved by calling the Save method of this object or the Save method of any object containing it.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCTunnelPortRange


IFPCTunnelPortRange | FPCTunnelPortRange Save method [ISA Server 2004]

IFPCTunnelPortRange::Save[C++]

FPCTunnelPortRange.Save [Visual Basic]

[C++]

The Save method saves the current values of all of the object's properties to persistent storage. It is important to remember that any changes made by scripts and programs are not saved until after the Save method is called.

HRESULT Save(
  VARIANT_BOOL fResetRequiredServices,
  VARIANT_BOOL fReloadConfiguration
);

Parameters

fResetRequiredServices
[in, optional] Boolean value that indicates whether to restart the services that need to be restarted for any of the changes saved to take effect. The default value is VARIANT_FALSE.
fReloadConfiguration
[in, optional] Boolean value that indicates whether the call will include synchronous reloading of all changes that can be applied dynamically without restarting services. The default value is VARIANT_TRUE.

Return Values

This method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

Configuration changes are applied only after the new settings are written to persistent storage and reloaded to the services that use them. Although most changes can be applied dynamically without restarting any services, changes to the properties of this object can take effect only after the Microsoft Firewall service is restarted. For more information, see Restarting Services after Configuration Changes.

ISA Server maintains a bitmask that specifies which services need to be started for currently unsaved changes to take effect. This bitmask can be retrieved by calling the GetServiceRestartMask method on an object that contains this object as a subobject. Calling the Save method clears all of the bits in this bitmask even if the fResetRequiredServices parameter is set to VARIANT_FALSE.

If the fReloadConfiguration parameter is set to VARIANT_FALSE the current values of the object's properties will be written to persistent storage without updating the configuration being used by the ISA Server services. The configuration used by each service will not be updated until the service is restarted or the new settings are reloaded by another call to Save.

[Visual Basic]

The Save method saves the current values of all of the object's properties to persistent storage. It is important to remember that any changes made by scripts and programs are not saved until after the Save method is called.

Sub Save( _
  [ ByVal fResetRequiredServices As Boolean ], _
  [ ByVal fReloadConfiguration As Boolean ] _
)

Parameters

fResetRequiredServices
[in, optional] Boolean value that indicates whether to restart the services that need to be restarted for any of the changes saved to take effect. The default value is False.
fReloadConfiguration
[in, optional] Boolean value that indicates whether the call will include synchronous reloading of all the saved configuration changes that can be applied dynamically without restarting services. The default value is True.

Return Values

This method has no return values. If the call is unsuccessful, an error is raised that can be intercepted by using an error handler.

Remarks

Configuration changes are applied only after the new settings are written to persistent storage and reloaded to the services that use them. Although most changes can be applied dynamically without restarting any services, changes to the properties of this object can take effect only after the Microsoft Firewall service is restarted. For more information, see Restarting Services after Configuration Changes.

ISA Server maintains a bitmask that specifies which services need to be started for currently unsaved changes to take effect. This bitmask can be retrieved by calling the GetServiceRestartMask method on an object that contains this object as a subobject. Calling the Save method clears all of the bits in this bitmask even if the fResetRequiredServices parameter is set to False.

If the fReloadConfiguration parameter is set to False the current values of the object's properties will be written to persistent storage without updating the configuration being used by the ISA Server services. The configuration used by each service will not be updated until the service is restarted or the new settings are reloaded by another call to Save.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCTunnelPortRange


IFPCTunnelPortRange.TunnelHighPort(long,long) property [ISA Server 2004]

TunnelHighPort Property of IFPCTunnelPortRange[C++]

FPCTunnelPortRange.TunnelHighPort [Visual Basic]

[C++]

The TunnelHighPort property gets or sets the high end of the port range.

HRESULT get_TunnelHighPort(
  long* plHighPort
);

HRESULT put_TunnelHighPort(
  long lHighPort
);

Parameters

plHighPort
Pointer to a variable that on return receives a 32-bit integer specifying the high end of the port range.
lHighPort
A 32-bit integer that specifies the high end of the port range.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write.

[Visual Basic]

The TunnelHighPort property gets or sets the high end of the port range.

Property TunnelHighPort As Long

Property Value

A 32-bit integer that specifies the high end of the port range.

Remarks

This property is read/write.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCTunnelPortRange


IFPCTunnelPortRange.TunnelLowPort(long,long) property [ISA Server 2004]

TunnelLowPort Property of IFPCTunnelPortRange[C++]

FPCTunnelPortRange.TunnelLowPort [Visual Basic]

[C++]

The TunnelLowPort property gets or sets the low end of the port range.

HRESULT get_TunnelLowPort(
  long* plLowPort
);

HRESULT put_TunnelLowPort(
  long lLowPort
);

Parameters

plLowPort
Pointer to a variable that on return receives a 32-bit integer specifying the low end of the port range.
lLowPort
A 32-bit integer that specifies the low end of the port range.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write.

[Visual Basic]

The TunnelLowPort property gets or sets the low end of the port range.

Property TunnelLowPort As Long

Property Value

A 32-bit integer that specifies the low end of the port range.

Remarks

This property is read/write.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCTunnelPortRange


FPCTunnelPortRanges collection [ISA Server 2004]

FPCTunnelPortRanges Collection

The FPCTunnelPortRanges collection holds a set of FPCTunnelPortRange objects. Each FPCTunnelPortRange object represents a single range of tunnel ports. A tunnel port allows ISA Server to work as a data pump for communication to particular ports on an External server. Because this effectively bypasses ISA Server protocol rules, the external port ranges for which this is possible are set by default to 443–443 (the single port 443 for SSL) and to 563–563 (the single port 563 for NNTP).

The FPCTunnelPortRanges collection can be accessed through the TunnelPortRanges property of an FPCWebProxy object.

Click here to see the ISA Server object hierarchy.

Methods

The FPCTunnelPortRanges collection defines the following methods.

Method | Description
AddRange | Creates a new FPCTunnelPortRange object in the collection and returns a reference to it.
Item | Retrieves the requested FPCTunnelPortRange object from the collection.
Refresh | Reads the values of all the properties of the collection and its elements from persistent storage, discarding any changes that have not been saved.
Remove | Removes the specified FPCTunnelPortRange object from the collection.
Save | Writes the current values of all the properties of the collection and its elements to persistent storage.

Properties

The FPCTunnelPortRanges collection has the following properties.

Property | Description
_NewEnum | Gets an enumerator object for the collection.
Count | Gets the number of FPCTunnelPortRange objects in the collection.

Remarks

This collection implements the IFPCTunnelPortRanges interface.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

COM Objects


IFPCTunnelPortRanges | FPCTunnelPortRanges _NewEnum property [ISA Server 2004]

_NewEnum Property of IFPCTunnelPortRanges[C++]

FPCTunnelPortRanges._NewEnum [Visual Basic]

[C++]

The _NewEnum property gets an enumerator object for the collection. An enumerator object provides serial access to the elements of the collection.

HRESULT get__NewEnum(
  IUnknown* ppEnum
);

Parameters

ppEnum
Address of an interface pointer that on return points to the IUnknown interface of an enumerator object that implements an IEnumVARIANT interface for the collection. An interface pointer to the IEnumVARIANT interface of the enumerator object can be retrieved by calling QueryInterface on the IUnknown interface returned.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The _NewEnum property gets an enumerator object for the collection. An enumerator object provides serial access to the elements of the collection.

Property _NewEnum As IUnknown

Property Value

Reference to an enumerator object that provides serial access to the elements of the collection.

Remarks

This property is read-only.

In Visual Basic and VBScript, this property is used implicitly in For Each...In...Next constructs.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCTunnelPortRanges


IFPCTunnelPortRanges | FPCTunnelPortRanges AddRange method [ISA Server 2004]

IFPCTunnelPortRanges::AddRange[C++]

FPCTunnelPortRanges.AddRange [Visual Basic]

[C++]

The AddRange method creates a new FPCTunnelPortRange object in the collection and returns a reference to it.

HRESULT AddRange(
  BSTR bstrName,
  long lLowPort,
  long lHighPort,
  IFPCTunnelPortRange** ppNewDest
);

Parameters

bstrName
[in] Required. String value that specifies the name of the new tunnel port range.
lLowPort
[in] Required. A 32-bit integer that specifies the low end of the port range.
lHighPort
[in] Required. A 32-bit integer that specifies the high end of the port range.
ppNewDest
[out] Address of an interface pointer that on return points to the new IFPCTunnelPortRange interface created.

Return Values

This method can return one of the following:

  • S_OK, indicating that the operation succeeded.
  • An error code, indicating that the operation failed. In this case, the [out] parameter returned is a null object.
[Visual Basic]

The AddRange method creates a new FPCTunnelPortRange object in the collection and returns a reference to it.

Function AddRange( _
  ByVal bstrName As String, _
  ByVal lLowPort As Long, _
  ByVal lHighPort As Long _
) As FPCTunnelPortRange

Parameters

bstrName
[in] Required. String value that specifies the name of the new tunnel port range.
lLowPort
[in] Required. A 32-bit integer that specifies the low end of the port range.
lHighPort
[in] Required. A 32-bit integer that specifies the high end of the port range.

Return Values

This method returns a reference to an FPCTunnelPortRange object if successful. Otherwise, an error is raised that can be intercepted by using an error handler.

Example Code

The following Visual Basic example shows how to create a new tunnel port range consisting of a single port.

Dim root As FPC
Dim tpRanges As FPCTunnelPortRanges
Dim newRange As FPCTunnelPortRange

Set root = CreateObject("FPC.Root")
Set tpRanges = root.GetContainingArray.ArrayPolicy.WebProxy.TunnelPortRanges
set newRange = tpRanges.AddRange("SSL 3520", 3520, 3520)
tpRanges.Save

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCTunnelPortRanges


IFPCTunnelPortRanges | FPCTunnelPortRanges Count property [ISA Server 2004]

Count Property of IFPCTunnelPortRanges[C++]

FPCTunnelPortRanges.Count [Visual Basic]

[C++]

The Count property gets the number of FPCTunnelPortRange objects in the collection.

HRESULT get_Count(
  long* plCount
);

Parameters

plCount
Pointer to a variable that on return receives a 32-bit integer specifying the number of FPCTunnelPortRange objects in the collection.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The Count property gets the number of FPCTunnelPortRange objects in the collection.

Property Count As Long

Property Value

A 32-bit integer that specifies the number of FPCTunnelPortRange objects in the collection.

Remarks

This property is read-only.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCTunnelPortRanges


IFPCTunnelPortRanges | FPCTunnelPortRanges Item method [ISA Server 2004]

IFPCTunnelPortRanges::Item[C++]

FPCTunnelPortRanges.Item [Visual Basic]

[C++]

The Item method retrieves the requested IFPCTunnelPortRange interface from the collection.

HRESULT Item(
  VARIANT Index,
  IFPCTunnelPortRange** ppItem
);

Parameters

Index
[in] Required. Name or one-based index of the object to retrieve.
ppItem
[out] Address of a variable that receives a pointer to the IFPCTunnelPortRange interface requested.

Return Values

This method can return one of the following:

  • S_OK, indicating that the operation succeeded.
  • An error message, indicating that the operation failed. In this case, the [out] parameter returned is a null object.
[Visual Basic]

The Item method retrieves the requested FPCTunnelPortRange object from the collection.

Function Item( _
  ByVal Index As Variant _
) As FPCTunnelPortRange

Parameters

Index
[in] Required. Name or one-based index of the object to retrieve.

Return Values

This method returns a reference to the FPCTunnelPortRange object requested if successful. Otherwise, an error is raised that can be intercepted by using an error handler.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCTunnelPortRanges


IFPCTunnelPortRanges | FPCTunnelPortRanges Refresh method [ISA Server 2004]

IFPCTunnelPortRanges::Refresh[C++]

FPCTunnelPortRanges.Refresh [Visual Basic]

[C++]

The Refresh method reads the values of all the properties of the collection and its elements from persistent storage, discarding any changes that have not been saved.

HRESULT Refresh();

Parameters

This method has no parameters.

Return Values

This method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

Changes made to this collection or its elements can be saved by calling the Save method of this collection or the Save method of any object containing it.

[Visual Basic]

The Refresh method reads the values of all the properties of the collection and its elements from persistent storage, discarding any changes that have not been saved.

Sub Refresh()

Parameters

This method has no parameters.

Return Values

This method has no return values. If the call is unsuccessful, an error is raised that can be intercepted by using an error handler.

Remarks

Changes made to this collection or its elements can be saved by calling the Save method of this collection or the Save method of any object containing it.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCTunnelPortRanges


IFPCTunnelPortRanges | FPCTunnelPortRanges Remove method [ISA Server 2004]

IFPCTunnelPortRanges::Remove[C++]

FPCTunnelPortRanges.Remove [Visual Basic]

[C++]

The Remove method removes the specified FPCTunnelPortRange object from the collection.

HRESULT Remove(
  VARIANT Index
);

Parameters

Index
[in] Required. One-based index or name of the FPCTunnelPortRange object to remove.

Return Values

This method returns S_OK if the call is successful; otherwise, it returns an error code.
[Visual Basic]

The Remove method removes the specified FPCTunnelPortRange object from the collection.

Sub Remove( _
  ByVal Index As Variant _
)

Parameters

Index
[in] Required. One-based index or name of the FPCTunnelPortRange object to remove.

Return Values

This method has no return values. If the call is unsuccessful, an error is raised that can be intercepted by using an error handler.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCTunnelPortRanges


IFPCTunnelPortRanges | FPCTunnelPortRanges Save method [ISA Server 2004]

IFPCTunnelPortRanges::Save[C++]

FPCTunnelPortRanges.Save [Visual Basic]

[C++]

The Save method writes the current values of all the properties of the collection and its elements to persistent storage. It is important to remember that any changes made by scripts and programs are not saved until after the Save method is called.

HRESULT Save(
  VARIANT_BOOL fResetRequiredServices,
  VARIANT_BOOL fReloadConfiguration
);

Parameters

fResetRequiredServices
[in, optional] Boolean value that indicates whether to restart the services that need to be restarted for any of the changes saved to take effect. The default value is VARIANT_FALSE.
fReloadConfiguration
[in, optional] Boolean value that indicates whether the call will include synchronous reloading of all changes that can be applied dynamically without restarting services. The default value is VARIANT_TRUE.

Return Values

This method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

Configuration changes are applied only after the new settings are written to persistent storage and reloaded to the services that use them. Although most changes can be applied dynamically without restarting any services, changes to this collection can take effect only after the Microsoft Firewall service is restarted. For more information, see Restarting Services after Configuration Changes.

ISA Server maintains a bitmask that specifies which services need to be started for currently unsaved changes to take effect. This bitmask can be retrieved by calling the GetServiceRestartMask method on an object that contains this object as a subobject. Calling the Save method clears all of the bits in this bitmask even if the fResetRequiredServices parameter is set to VARIANT_FALSE.

If the fReloadConfiguration parameter is set to VARIANT_FALSE the current values of the properties of the collection and its elements will be written to persistent storage without updating the configuration being used by the ISA Server services. The configuration used by each service will not be updated until the service is restarted or the new settings are reloaded by another call to Save.

[Visual Basic]

The Save method writes the current values of all the properties of the collection and its elements to persistent storage. It is important to remember that any changes made by scripts and programs are not saved until after the Save method is called.

Sub Save( _
  [ ByVal fResetRequiredServices As Boolean ], _
  [ ByVal fReloadConfiguration As Boolean ] _
)

Parameters

fResetRequiredServices
[in, optional] Boolean value that indicates whether to restart the services that need to be restarted for any of the changes saved to take effect. The default value is False.
fReloadConfiguration
[in, optional] Boolean value that indicates whether the call will include synchronous reloading of all the saved configuration changes that can be applied dynamically without restarting services. The default value is True.

Return Values

This method has no return values. If the call is unsuccessful, an error is raised that can be intercepted by using an error handler.

Remarks

Configuration changes are applied only after the new settings are written to persistent storage and reloaded to the services that use them. Although most changes can be applied dynamically without restarting any services, changes to this collection can take effect only after the Microsoft Firewall service is restarted. For more information, see Restarting Services after Configuration Changes.

ISA Server maintains a bitmask that specifies which services need to be started for currently unsaved changes to take effect. This bitmask can be retrieved by calling the GetServiceRestartMask method on an object that contains this object as a subobject. Calling the Save method clears all of the bits in this bitmask even if the fResetRequiredServices parameter is set to False.

If the fReloadConfiguration parameter is set to False the current values of the properties of the collection and its elements will be written to persistent storage without updating the configuration being used by the ISA Server services. The configuration used by each service will not be updated until the service is restarted or the new settings are reloaded by another call to Save.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCTunnelPortRanges


FPCURLSet collection [ISA Server 2004]

FPCURLSet Collection

The FPCURLSet collection holds a set of Uniform Resource Locators (URLs) that can be referenced by ISA Server rules.

This collection is typically an element of an FPCURLSets collection.

Click here to see the ISA Server object hierarchy.

Inheritance

This collection inherits from the FPCPersist object, which contains methods and properties related to the persistent storage of an object's data. They include methods for exporting the object's data to and importing it from an XML document.

Methods

The FPCURLSet collection defines the following methods.

Method | Description
Add | Adds a URL to the URL set.
Item | Retrieves a requested URL from the URL set.
Remove | Removes the specified URL from the URL set.

Properties

The FPCURLSet collection has the following properties.

Property | Description
_NewEnum | Gets an enumerator object for the collection.
Count | Gets the number of URLs in the URL set.
Description | Gets or sets the description of the URL set.
Name | Gets or sets the name of the URL set.
Predefined | Gets a Boolean value that indicates whether the URL set is a predefined URL set that was created during the installation of ISA Server and cannot be deleted.

Methods Inherited from FPCPersist

Name | Description
CancelWaitForChanges | Cancels the registration established by the WaitForChanges method (for use in C and C++ programming only).
CanImport | Returns a Boolean value that indicates whether the collection's properties and elements can be imported from the specified XML document.
Export | Writes the stored values of the collection's properties and elements to the specified XML document.
ExportToFile | Writes the stored values of the collection's properties and elements to the specified XML file.
GetServiceRestartMask | Retrieves a 32-bit bitmask of the FpcServices enumerated type that specifies which services need to be restarted for currently unsaved changes to take effect.
Import | Copies the values of the collection's properties and elements from the specified XML document to persistent storage.
ImportFromFile | Copies the values of the collection's properties and elements from the specified XML file to persistent storage.
LoadDocProperties | Provides the XML document's properties so that you can know what information can be imported from the document.
Refresh | Reads the values of the collection's properties and elements from persistent storage, overwriting any changes that have not been saved.
Save | Writes the current values of the collection's properties and elements to persistent storage.
WaitForChanges | Registers to wait for an event indicating that the contents of the object have changed (for use in C and C++ programming only).

Properties Inherited from FPCPersist

Name | Description
PersistentName | Gets the persistent name of the collection. The persistent name of an object is a name that is unique for the object at the respective level of the COM object hierarchy.
VendorParametersSets | Gets an FPCVendorParametersSets collection that can hold sets of custom data for extending the collection.

Remarks

This collection implements the IFPCURLSets interface.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

COM Objects


IFPCURLSet | FPCURLSet _NewEnum(IUnknown) property [ISA Server 2004]

_NewEnum Property of IFPCURLSet[C++]

FPCURLSet._NewEnum [Visual Basic]

[C++]

The _NewEnum property gets an enumerator object for the collection. An enumerator object provides serial access to the elements of the collection.

HRESULT get__NewEnum(
  IUnknown* ppEnum
);

Parameters

ppEnum
Address of an interface pointer that on return points to the IUnknown interface of an enumerator object that implements an IEnumVARIANT interface for the collection. An interface pointer to the IEnumVARIANT interface of the enumerator object can be retrieved by calling QueryInterface on the IUnknown interface returned.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The _NewEnum property gets an enumerator object for the collection. An enumerator object provides serial access to the elements of the collection.

Property _NewEnum As IUnknown

Property Value

Reference to an enumerator object that provides serial access to the elements of the collection.

Remarks

This property is read-only.

In Visual Basic and VBScript, this property is used implicitly in For Each...In...Next constructs.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCURLSet


IFPCURLSet | FPCURLSet Add(String) method [ISA Server 2004]

IFPCURLSet::Add[C++]

FPCURLSet.Add [Visual Basic]

[C++]

The Add method adds a new Uniform Resource Locator (URL) to the URL set.

HRESULT Add(
  BSTR Name
);

Parameters

Name
[in] Required. BSTR that specifies the name of the new URL.

Return Values

This method returns S_OK if the call is successful; otherwise, it returns an error code.
[Visual Basic]

The Add method adds a new Uniform Resource Locator (URL) to the URL set.

Sub Add( _
  ByVal Name As String _
)

Parameters

Name
[in] Required. String that specifies the name of the new URL.

Return Values

This method has no return values. If the call is unsuccessful, an error is raised that can be intercepted by using an error handler.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCURLSet


IFPCURLSet | FPCURLSet Count(long) property [ISA Server 2004]

Count Property of IFPCURLSet[C++]

FPCURLSet.Count [Visual Basic]

[C++]

The Count property gets the number of Uniform Resource Locators (URLs) in the URL set.

HRESULT get_Count(
  long* plCount
);

Parameters

plCount
Pointer to a variable that on return receives a 32-bit integer specifying the number of URLs in the URL set.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The Count property gets the number of Uniform Resource Locators (URLs) in the URL set.

Property Count As Long

Property Value

A 32-bit integer that specifies the number of URLs in the URL set.

Remarks

This property is read-only.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCURLSet


IFPCURLSet | FPCURLSet Description(BSTR,BSTR) property [ISA Server 2004]

Description Property of IFPCURLSet[C++]

FPCURLSet.Description [Visual Basic]

[C++]

The Description property gets or sets the description of the URL set.

HRESULT get_Description(
  BSTR* pbstrDescription
);

HRESULT put_Description(
  BSTR bstrDescription
);

Parameters

pbstrDescription
Pointer to a BSTR that is set on return to a string value specifying the description of the URL set.
bstrDescription
BSTR that specifies the description of the URL set.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write.

[Visual Basic]

The Description property gets or sets the description of the URL set.

Property Description As String

Property Value

String that specifies the description of the URL set.

Remarks

This property is read/write.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCURLSet


IFPCURLSet | FPCURLSet Item(Variant,BSTR) method [ISA Server 2004]

IFPCURLSet::Item[C++]

FPCURLSet.Item [Visual Basic]

[C++]

The Item method retrieves the requested Uniform Resource Locator (URL) from the URL set.

HRESULT Item(
  VARIANT Index,
  BSTR* pItem
);

Parameters

Index
[in] Required. Name or one-based index of the URL to retrieve.
pItem
[out] Pointer to a BSTR that is set on return to a string value specifying the URL.

Return Values

This method can return one of the following:

  • S_OK, indicating the operation succeeded.
  • An error message, indicating that the operation failed.
[Visual Basic]

The Item method retrieves the requested Uniform Resource Locator (URL) from the URL set.

Function Item( _
  ByVal Index As Variant _
) As String

Parameters

Index
[in] Required. Name or one-based index of the URL to retrieve.

Return Values

This method returns a string specifying the URL requested if successful. Otherwise, an error is raised that can be intercepted by using an error handler.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCURLSet


IFPCURLSet | FPCURLSet Name(BSTR,BSTR) property [ISA Server 2004]

Name Property of IFPCURLSet[C++]

FPCURLSet.Name [Visual Basic]

[C++]

The Name property gets or sets the name of the URL set.

HRESULT get_Name(
  BSTR* pbstrName
);

HRESULT put_Name(
  BSTR bstrName
);

Parameters

pbstrName
Pointer to a BSTR that is set on return to a string value specifying the name of the URL set.
bstrName
BSTR that specifies the name of the URL set.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write.

[Visual Basic]

The Name property gets or sets the name of the URL set.

Property Name As String

Property Value

String that specifies the name of the URL set.

Remarks

This property is read/write.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCURLSet


IFPCURLSet | FPCURLSet Predefined(VARIANT_BOOL) property [ISA Server 2004]

Predefined Property of IFPCURLSet[C++]

FPCURLSet.Predefined [Visual Basic]

[C++]

The Predefined property gets a Boolean value that indicates whether the URL set is a predefined URL set that was created during the installation of ISA Server and cannot be deleted.

HRESULT get_Predefined(
  VARIANT_BOOL* pfPredefined
);

Parameters

pfPredefined
Pointer to a Boolean variable that is set on return to VARIANT_TRUE if the URL set is predefined, or to VARIANT_FALSE if the URL set is user-defined.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The Predefined property gets a Boolean value that indicates whether the URL set is a predefined URL set that was created during the installation of ISA Server and cannot be deleted.

Property Predefined As Boolean

Property Value

Boolean value that specifies whether the URL set is predefined.

Remarks

This property is read-only.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCURLSet


IFPCURLSet | FPCURLSet Remove(Variant) method [ISA Server 2004]

IFPCURLSet::Remove[C++]

FPCURLSet.Remove [Visual Basic]

[C++]

The Remove method removes the specified Uniform Resource Locator (URL) from the URL set.

HRESULT Remove(
  VARIANT Index
);

Parameters

Index
[in] Required. Name or one-based index of the URL to remove.

Return Values

This method returns S_OK if the call is successful; otherwise, it returns an error code.
[Visual Basic]

The Remove method removes the specified Uniform Resource Locator (URL) from the URL set.

Sub Remove( _
  ByVal Index As Variant _
)

Parameters

Index
[in] Required. Name or one-based index of the URL to remove.

Return Values

This method has no return values. If the call is unsuccessful, an error is raised that can be intercepted by using an error handler.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCURLSet


FPCURLSets collection [ISA Server 2004]

FPCURLSets Collection

The FPCURLSets collection holds an ordered set of FPCURLSet objects. The rules of an ISA Server computer refer to the Uniform Resource Locator (URL) sets.

This collection is typically accessed through the URLSets property of the FPCRuleElements object.

Click here to see the ISA Server object hierarchy.

For VBScript code examples that show how to retrieve this collection and then add new URL sets to it for use in cache rules and access rules, see Adding Cache Rules, Adding an Access Rule, and Controlling Access by a Schedule and a User Set.

Inheritance

This collection inherits from the FPCPersist object, which contains methods and properties related to the persistent storage of an object's data. They include methods for exporting the object's data to and importing it from an XML document.

Methods

The FPCURLSets collection defines the following methods.

Method | Description
Add | Creates a new FPCURLSet object, adds it to the collection, and returns a reference to it.
Item | Retrieves the requested FPCURLSet object from the collection.
Remove | Removes an FPCURLSet object from the collection.

Properties

The FPCURLSets collection has the following properties.

Property | Description
_NewEnum | Gets an enumerator object for the collection.
Count | Gets the number of FPCURLSet objects in the collection.

Methods Inherited from FPCPersist

Name | Description
CancelWaitForChanges | Cancels the registration established by the WaitForChanges method (for use in C and C++ programming only).
CanImport | Returns a Boolean value that indicates whether the properties of the collection and its elements can be imported from the specified XML document.
Export | Writes the stored values of all the properties of the collection and its elements to the specified XML document.
ExportToFile | Writes the stored values of all the properties of the collection and its elements to the specified XML file.
GetServiceRestartMask | Retrieves a 32-bit bitmask of the FpcServices enumerated type that specifies which services need to be restarted for currently unsaved changes to take effect.
Import | Copies the values of all the properties of the collection and its elements from the specified XML document to persistent storage.
ImportFromFile | Copies the values of all the properties of the collection and its elements from the specified XML file to persistent storage.
LoadDocProperties | Provides the XML document's properties so that you can know what information can be imported from the document.
Refresh | Reads the values of all the properties of the collection and its elements from persistent storage, overwriting any changes that have not been saved.
Save | Writes the current values of all the properties of the collection and its elements to persistent storage.
WaitForChanges | Registers to wait for an event indicating that the contents of the object have changed (for use in C and C++ programming only).

Properties Inherited from FPCPersist

Name | Description
PersistentName | Gets the persistent name of the collection. The persistent name of an object is a name that is unique for the object at the respective level of the COM object hierarchy.
VendorParametersSets | Gets an FPCVendorParametersSets collection that can hold sets of custom data for extending the collection.

Remarks

This collection implements the IFPCURLSets interface.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

COM Objects


IFPCURLSets | FPCURLSets _NewEnum(IUnknown) property [ISA Server 2004]

_NewEnum Property of IFPCURLSets[C++]

FPCURLSets._NewEnum [Visual Basic]

[C++]

The _NewEnum property gets an enumerator object for the collection. An enumerator object provides serial access to the elements of the collection.

HRESULT get__NewEnum(
  IUnknown* ppEnum
);

Parameters

ppEnum
Address of an interface pointer that on return points to the IUnknown interface of an enumerator object that implements an IEnumVARIANT interface for the collection. An interface pointer to the IEnumVARIANT interface of the enumerator object can be retrieved by calling QueryInterface on the IUnknown interface returned.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The _NewEnum property gets an enumerator object for the collection. An enumerator object provides serial access to the elements of the collection.

Property _NewEnum As IUnknown

Property Value

Reference to an enumerator object that provides serial access to the elements of the collection.

Remarks

This property is read-only.

In Visual Basic and VBScript, this property is used implicitly in For Each...In...Next constructs.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCURLSets


IFPCURLSets | FPCURLSets Add(String,IFPCURLSet) method [ISA Server 2004]

IFPCURLSets::Add[C++]

FPCURLSets.Add [Visual Basic]

[C++]

The Add method creates a new FPCURLSet object in the collection and returns a reference to it.

HRESULT Add(
  BSTR Name,
  IFPCURLSet** ppNewSet
);

Parameters

Name
[in] Required. BSTR that specifies the name of the new URL set.
ppNewSet
[out] Address of an interface pointer that on return points to the new IFPCURLSet interface created.

Return Values

This method can return one of the following:

  • S_OK, indicating that the operation succeeded.
  • An error code, indicating that the operation failed. In this case, the [out] parameter returned is a null object.

[Visual Basic]

The Add method creates a new FPCURLSet object in the collection and returns a reference to it.

Function Add( _
  ByVal Name As String _
) As FPCURLSet

Parameters

Name
[in] Required. String that specifies the name of the new URL set.

Return Values

This method returns a reference to the FPCURLSet object if successful. Otherwise, an error is raised that can be intercepted by using an error handler.

Example Code

For VBScript code examples that show how to use this method to add new URL sets to the URL sets collection for use in cache rules and access rules, see Adding Cache Rules, Adding an Access Rule, and Controlling Access by a Schedule and a User Set.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCURLSets


IFPCURLSets | FPCURLSets Count(long) property [ISA Server 2004]

Count Property of IFPCURLSets[C++]

FPCURLSets.Count [Visual Basic]

[C++]

The Count property gets the number of FPCURLSet objects in the collection.

HRESULT get_Count(
  long* plCount
);

Parameters

plCount
Pointer to a variable that on return receives a 32-bit integer specifying the number of FPCURLSet objects in the collection.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The Count property gets the number of FPCURLSet objects in the collection.

Property Count As Long

Property Value

A 32-bit integer that specifies the number of FPCURLSet objects in the collection.

Remarks

This property is read-only.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCURLSets


IFPCURLSets | FPCURLSets Item(Variant,IFPCURLSet) method [ISA Server 2004]

IFPCURLSets::Item[C++]

FPCURLSets.Item [Visual Basic]

[C++]

The Item method retrieves the requested IFPCURLSet interface from the collection.

HRESULT Item(
  VARIANT vIndex,
  IFPCURLSet** ppItem
);

Parameters

vIndex
[in] Required. Name or one-based index of the object to retrieve.
ppItem
[out] Address of an interface pointer that on return points to the IFPCURLSet interface requested.

Return Values

This method can return one of the following:

  • S_OK, indicating the operation succeeded
  • An error message, indicating that the operation failed. In this case, the [out] parameter returned is a null object.

[Visual Basic]

The Item method retrieves the requested FPCURLSet object from the collection.

Function Item( _
  ByVal vIndex As Variant _
) As FPCURLSet

Parameters

vIndex
[in] Required. Name or one-based index of the object to retrieve.

Return Values

This method returns a reference to the FPCURLSet object if successful. Otherwise, an error is raised that can be intercepted by using an error handler.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCURLSets


IFPCURLSets | FPCURLSets Remove(Variant) method [ISA Server 2004]

IFPCURLSets::Remove[C++]

FPCURLSets.Remove [Visual Basic]

[C++]

The Remove method removes the specified FPCURLSet object from the collection.

HRESULT Remove(
  VARIANT Index
);

Parameters

Index
[in] Required. Name or one-based index of the FPCURLSet object to remove.

Return Values

This method returns S_OK if the call is successful; otherwise, it returns an error code.
[Visual Basic]

The Remove method removes the specified FPCURLSet object from the collection.

Sub Remove( _
  ByVal Index As Variant _
)

Parameters

Index
[in] Required. Name or one-based index of the FPCURLSet object to remove.

Return Values

This method has no return values. If the call is unsuccessful, an error is raised that can be intercepted by using an error handler.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCURLSets


FPCUserMapping object [ISA Server 2004]

FPCUserMapping

The FPCUserMapping object represents the user mapping that is used to map VPN clients connecting to the ISA Server computer using an authentication method that is not based on Windows (RADIUS or EAP) to the Windows namespace. The FPCUserMapping object specifies a domain name that ISA Server can combine with a user name in the user mapping process when the user name supplied does not contain a domain name. As a result, access rules that specify user sets containing Windows users and groups are also applied to authenticated users that do not use Windows.

The FPCUserMapping object can be accessed through the RADIUSUserMapping property of the FPCVpnConfiguration object.

Click here to see the ISA Server object hierarchy.

Methods

The FPCUserMapping object defines the following methods.

Method | Description
Refresh | Reads the values of all of the object's properties from persistent storage, discarding any changes that have not been saved.
Save | Writes the current values of all of the object's properties to persistent storage.

Properties

The FPCUserMapping object has the following properties.

Property | Description
Domain | Gets or sets the domain name that ISA Server can combine with a user name in the user mapping process when the user name supplied does not contain a domain name.
Enabled | Gets or sets a Boolean value that indicates whether the user mapping is enabled.

Remarks

This object implements the IFPCUserMapping interface.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

COM Objects


IFPCUserMapping | FPCUserMapping Domain(BSTR,BSTR) property [ISA Server 2004]

Domain Property of IFPCUserMapping[C++]

FPCUserMapping.Domain [Visual Basic]

[C++]

The Domain property gets or sets the domain name that ISA Server can combine with a user name in the user mapping process when the user name supplied does not contain a domain name.

HRESULT get_Domain(
  BSTR* pbstrDomain
);

HRESULT put_Domain(
  BSTR bstrDomain
);

Parameters

pbstrDomain
Pointer to a BSTR that is set on return to a string value specifying the domain name for the user mapping.
bstrDomain
BSTR that specifies the domain name for the user mapping.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write.

[Visual Basic]

The Domain property gets or sets the domain name that ISA Server can combine with a user name in the user mapping process when the user name supplied does not contain a domain name.

Property Domain As String

Property Value

String that specifies the domain name for the user mapping.

Remarks

This property is read/write.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCUserMapping


IFPCUserMapping | FPCUserMapping Enabled property [ISA Server 2004]

Enabled Property of IFPCUserMapping[C++]

FPCUserMapping.Enabled [Visual Basic]

[C++]

The Enabled property gets or sets a Boolean value that indicates whether the user mapping is enabled.

HRESULT get_Enabled(
  VARIANT_BOOL* pfEnabled
);

HRESULT put_Enabled(
  VARIANT_BOOL fEnabled
);

Parameters

pfEnabled
Pointer to a Boolean variable that is set on return to VARIANT_TRUE if the user mapping is enabled, or to VARIANT_FALSE if the user mapping is disabled.
fEnabled
Boolean value that indicates whether the user mapping is enabled.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write.

[Visual Basic]

The Enabled property gets or sets a Boolean value that indicates whether the user mapping is enabled.

Property Enabled As Boolean

Property Value

Boolean value that indicates whether the user mapping is enabled.

Remarks

This property is read/write.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCUserMapping


IFPCUserMapping | FPCUserMapping Refresh method [ISA Server 2004]

IFPCUserMapping::Refresh[C++]

FPCUserMapping.Refresh [Visual Basic]

[C++]

The Refresh method reads the values of all of the object's properties from persistent storage, discarding any changes that have not been saved.

HRESULT Refresh();

Parameters

This method has no parameters.

Return Values

This method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

Changes made to this object can be saved by calling the Save method of this object or the Save method of any object containing it.

[Visual Basic]

The Refresh method reads the values of all of the object's properties from persistent storage, discarding any changes that have not been saved.

Sub Refresh()

Parameters

This method has no parameters.

Return Values

This method has no return values. If the call is unsuccessful, an error is raised that can be intercepted by using an error handler.

Remarks

Changes made to this object can be saved by calling the Save method of this object or the Save method of any object containing it.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCUserMapping


IFPCUserMapping | FPCUserMapping Save (2 Parameters) method [ISA Server 2004]

IFPCUserMapping::Save[C++]

FPCUserMapping.Save [Visual Basic]

[C++]

The Save method writes the current values of all of the object's properties to persistent storage. It is important to remember that any changes made to this object by scripts and programs are not saved until after the Save method is called.

HRESULT Save(
  VARIANT_BOOL fResetRequiredServices,
  VARIANT_BOOL fReloadConfiguration
);

Parameters

fResetRequiredServices
[in, optional] Boolean value that indicates whether to restart the services that need to be restarted for any of the changes saved to take effect. The default value is VARIANT_FALSE.
fReloadConfiguration
[in, optional] Boolean value that indicates whether the call will include synchronous reloading of all changes that can be applied dynamically without restarting services. The default value is VARIANT_TRUE.

Return Values

This method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

Configuration changes are applied only after the new settings are written to persistent storage and reloaded to the services that use them. Most changes can be applied dynamically without restarting any services. However, some changes can take effect only after the Microsoft Firewall service is restarted. For more information, see Restarting Services after Configuration Changes.

ISA Server maintains a bitmask that specifies which services need to be started for currently unsaved changes to take effect. This bitmask can be retrieved by calling the GetServiceRestartMask method on an object that contains this object as a subobject. Calling the Save method clears all of the bits in this bitmask even if the fResetRequiredServices parameter is set to VARIANT_FALSE.

If the fReloadConfiguration parameter is set to VARIANT_FALSE the current values of the object's properties will be written to persistent storage without updating the configuration being used by the ISA Server services. The configuration used by each service will not be updated until the service is restarted or the new settings are reloaded by another call to Save.

[Visual Basic]

The Save method writes the current values of all of the object's properties to persistent storage. It is important to remember that any changes made to this object by scripts and programs are not saved until after the Save method is called.

Sub Save( _
  [ ByVal fResetRequiredServices As Boolean ], _
  [ ByVal fReloadConfiguration As Boolean ] _
)

Parameters

fResetRequiredServices
[in, optional] Boolean value that indicates whether to restart the services that need to be restarted for any of the changes saved to take effect. The default value is False.
fReloadConfiguration
[in, optional] Boolean value that indicates whether the call will include synchronous reloading of all the saved configuration changes that can be applied dynamically without restarting services. The default value is True.

Return Values

This method has no return values. If the call is unsuccessful, an error is raised that can be intercepted by using an error handler.

Remarks

Configuration changes are applied only after the new settings are written to persistent storage and reloaded to the services that use them. Most changes can be applied dynamically without restarting any services. However, some changes can take effect only after the Microsoft Firewall service is restarted. For more information, see Restarting Services after Configuration Changes.

ISA Server maintains a bitmask that specifies which services need to be started for currently unsaved changes to take effect. This bitmask can be retrieved by calling the GetServiceRestartMask method on an object that contains this object as a subobject. Calling the Save method clears all of the bits in this bitmask even if the fResetRequiredServices parameter is set to False.

If the fReloadConfiguration parameter is set to False the current values of the object's properties will be written to persistent storage without updating the configuration being used by the ISA Server services. The configuration used by each service will not be updated until the service is restarted or the new settings are reloaded by another call to Save.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCUserMapping


FPCUserSet object [ISA Server 2004]

FPCUserSet

The FPCUserSet object defines a set of users. These may be a combination of Active Directory accounts and authenticated users that are not represented by Active Directory accounts. For more information about different kinds of users in ISA Server, see Defining Groups of Users.

This object is typically an element of an FPCUserSets collection.

Click here to see the ISA Server object hierarchy.

Inheritance

This object inherits from the FPCPersist object, which contains methods and properties related to the persistent storage of an object's data. They include methods for exporting the object's data to and importing it from an XML document.

Methods

This object has no methods.

Properties

The FPCUserSet object has the following properties.

Property | Description
Accounts | Gets an FPCAccounts collection that contains the Active Directory user accounts included in the user set.
Description | Gets or sets the description of the set.
Name | Gets or sets the name of the user set.
NonWindowsUsers | Gets an FPCNonWindowsUsers collection that contains the non-Active Directory authenticated users included in the user set.
Predefined | Gets a Boolean value that indicates whether the user set is predefined.

Methods Inherited from FPCPersist

Name | Description
CancelWaitForChanges | Cancels the registration established by the WaitForChanges method (for use in C and C++ programming only).
CanImport | Returns a Boolean value that indicates whether the object's properties can be imported from the specified XML document.
Export | Recursively writes the stored values of all the properties of the object and its subobjects to the specified XML document.
ExportToFile | Recursively writes the stored values of all the properties of the object and its subobjects to the specified XML file.
GetServiceRestartMask | Retrieves a 32-bit bitmask of the FpcServices enumerated type that specifies which services need to be restarted for currently unsaved changes to take effect.
Import | Recursively copies the values of all the properties of the object and of its subobjects from the specified XML document to persistent storage.
ImportFromFile | Recursively copies the values of all the properties of the object and of its subobjects from the specified XML file to persistent storage.
LoadDocProperties | Provides the XML document's properties so that you can know what information can be imported from the document.
Refresh | Recursively reads the values of all the properties of the object and of its subobjects from persistent storage, overwriting any changes that have not been saved.
Save | Recursively writes the current values of all the properties of the object and its subobjects to persistent storage.
WaitForChanges | Registers to wait for an event indicating that the contents of the object have changed (for use in C and C++ programming only).

Properties Inherited from FPCPersist

Name | Description
PersistentName | Gets the persistent name of the object. The persistent name of an object is a name that is unique for the object at the respective level of the COM object hierarchy.
VendorParametersSets | Gets an FPCVendorParametersSets collection that can hold sets of custom data for extending the object.

Remarks

This object implements the IFPCUserSet interface.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

COM Objects


IFPCUserSet | FPCUserSet Accounts(IFPCAccounts) property [ISA Server 2004]

Accounts Property of IFPCUserSet[C++]

FPCUserSet.Accounts [Visual Basic]

[C++]

The Accounts property gets an FPCAccounts collection that contains the Active Directory user accounts included in the user set.

HRESULT get_Accounts(
  IFPCAccounts** ppAccounts
);

Parameters

ppAccounts
Address of an interface pointer that on return points to an IFPCAccounts interface that represents the collection of Active Directory user accounts included in the user set.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only. Accounts can be added or removed from the collection by calling the methods of the IFPCAccounts interface retrieved.

[Visual Basic]

The Accounts property gets an FPCAccounts collection that contains the Active Directory user accounts included in the user set.

Property Accounts As FPCAccounts

Property Value

Reference to the FPCAccounts collection for the user set.

Remarks

This property is read-only. Accounts can be added or removed by calling the methods of the FPCAccounts collection retrieved.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCUserSet


IFPCUserSet | FPCUserSet Description(BSTR,BSTR) property [ISA Server 2004]

Description Property of IFPCUserSet[C++]

FPCUserSet.Description [Visual Basic]

[C++]

The Description property gets or sets the description of the user set.

HRESULT get_Description(
  BSTR* pbstrDescription
);

HRESULT put_Description(
  BSTR bstrDescription
);

Parameters

pbstrDescription
Pointer to a BSTR that is set on return to a string value specifying the description of the user set.
bstrDescription
BSTR that specifies the description of the user set.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write.

[Visual Basic]

The Description property gets or sets the description of the user set.

Property Description As String

Property Value

String that specifies the description of the user set.

Remarks

This property is read/write.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCUserSet


IFPCUserSet | FPCUserSet Name(BSTR,BSTR) property [ISA Server 2004]

Name Property of IFPCUserSet[C++]

FPCUserSet.Name [Visual Basic]

[C++]

The Name property gets or sets the name of the user set.

HRESULT get_Name(
  BSTR* pbstrName
);

HRESULT put_Name(
  BSTR bstrName
);

Parameters

pbstrName
Pointer to a BSTR that is set on return to a string value specifying the name of the user set.
bstrName
BSTR that specifies the name of the user set.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write.

[Visual Basic]

The Name property gets or sets the name of the user set.

Property Name As String

Property Value

String that specifies the name of the user set.

Remarks

This property is read/write.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCUserSet


IFPCUserSet | FPCUserSet NonWindowsUsers property [ISA Server 2004]

NonWindowsUsers Property of IFPCUserSet[C++]

FPCUserSet.NonWindowsUsers [Visual Basic]

[C++]

The NonWindowsUsers property gets an FPCNonWindowsUsers collection that contains the non-Active Directory authenticated users included in the user set.

HRESULT get_NonWindowsUsers(
  IFPCNonWindowsUsers** ppNonWindowsUsers
);

Parameters

ppNonWindowsUsers
Address of an interface pointer that on return points to an IFPCNonWindowsUsers interface that represents the collection of non-Active Directory authenticated users included in the user set.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only. Non-Active Directory authenticated users can be added or removed from the collection by calling the methods of the IFPCNonWindowsUsers interface retrieved.

[Visual Basic]

The NonWindowsUsers property gets an FPCNonWindowsUsers collection that contains the non-Active Directory authenticated users included in the user set.

Property NonWindowsUsers As FPCNonWindowsUsers

Property Value

Reference to the FPCNonWindowsUsers collection for the user set.

Remarks

This property is read-only. Non-Active Directory authenticated users can be added or removed by calling the methods of the FPCNonWindowsUsers collection retrieved.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCUserSet


IFPCUserSet | FPCUserSet Predefined(VARIANT_BOOL) property [ISA Server 2004]

Predefined Property of IFPCUserSet[C++]

FPCUserSet.Predefined [Visual Basic]

[C++]

The Predefined property gets or sets a Boolean value that indicates whether the user set is a predefined user set that was created during the installation of ISA Server and cannot be deleted.

HRESULT get_Predefined(
  VARIANT_BOOL* pfPredefined
);

Parameters

pfPredefined
Pointer to a Boolean variable that is set on return to VARIANT_TRUE if the user set is predefined, or to VARIANT_FALSE if the user set is user-defined.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The Predefined property gets or sets a Boolean value that indicates whether the user set is a predefined user set that was created during the installation of ISA Server and cannot be deleted.

Property Predefined As Boolean

Property Value

Boolean value that indicates whether the user set is predefined.

Remarks

This property is read-only.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCUserSet


FPCUserSets collection [ISA Server 2004]

FPCUserSets Collection

The FPCUserSets collection is a collection of FPCUserSet objects. The rules of an ISA Server computer refer to the user sets.

This collection is a member of the FPCRuleElements object.

Click here to see the ISA Server object hierarchy.

Inheritance

This collection inherits from the FPCPersist object, which contains methods and properties related to the persistent storage of an object's data. They include methods for exporting the object's data to and importing it from an XML document.

Methods

The FPCUserSets collection defines the following methods.

Method | Description
Add | Creates a new FPCUserSet object in the collection and returns a reference to it.
Item | Retrieves the specified FPCUserSet object from the collection.
Remove | Removes an FPCUserSet object from the collection.

Properties

The FPCUserSets collection has the following properties.

Property | Description
_NewEnum | Gets an enumerator object for the collection.
Count | Gets the number of FPCUserSet objects in the collection.

Methods Inherited from FPCPersist

Name | Description
CancelWaitForChanges | Cancels the registration established by the WaitForChanges method (for use in C and C++ programming only).
CanImport | Returns a Boolean value that indicates whether the properties of the collection, its elements, and their subobjects can be imported from the specified XML document.
Export | Recursively writes the stored values of all the properties of the collection, its elements, and their subobjects to the specified XML document.
ExportToFile | Recursively writes the stored values of all the properties of the collection, its elements, and their subobjects to the specified XML file.
GetServiceRestartMask | Retrieves a 32-bit bitmask of the FpcServices enumerated type that specifies which services need to be restarted for currently unsaved changes to take effect.
Import | Recursively copies the values of all the properties of the collection, its elements, and their subobjects from the specified XML document to persistent storage.
ImportFromFile | Recursively copies the values of all the properties of the collection, its elements, and their subobjects from the specified XML file to persistent storage.
LoadDocProperties | Provides the XML document's properties so that you can know what information can be imported from the document.
Refresh | Recursively reads the values of all the properties of the collection, its elements, and their subobjects from persistent storage, overwriting any changes that have not been saved.
Save | Recursively writes the current values of all the properties of the collection, its elements, and their subobjects to persistent storage.
WaitForChanges | Registers to wait for an event indicating that the contents of the object have changed (for use in C and C++ programming only).

Properties Inherited from FPCPersist

Name | Description
PersistentName | Gets the persistent name of the collection. The persistent name of an object is a name that is unique for the object at the respective level of the COM object hierarchy.
VendorParametersSets | Gets an FPCVendorParametersSets collection that can hold sets of custom data for extending the collection.

Remarks

This collection implements the IFPCUserSets interface.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

COM Objects


IFPCUserSets | FPCUserSets _NewEnum(IUnknown) property [ISA Server 2004]

_NewEnum Property of IFPCUserSets[C++]

FPCUserSets._NewEnum [Visual Basic]

[C++]

The _NewEnum property gets an enumerator object for the collection. An enumerator object provides serial access to the elements of the collection.

HRESULT get__NewEnum(
  IUnknown* ppEnum
);

Parameters

ppEnum
Address of an interface pointer that on return points to the IUnknown interface of an enumerator object that implements an IEnumVARIANT interface for the collection. An interface pointer to the IEnumVARIANT interface of the enumerator object can be retrieved by calling QueryInterface on the IUnknown interface returned.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The _NewEnum property gets an enumerator object for the collection. An enumerator object provides serial access to the elements of the collection.

Property _NewEnum As IUnknown

Property Value

Reference to an enumerator object that provides serial access to the elements of the collection.

Remarks

This property is read-only.

In Visual Basic and VBScript, this property is used implicitly in For Each...In...Next constructs.

Example Code

This VBScript script displays the names of all the user sets defined for an FPCArray object. It does not include error handling.

' Create the root object.
Dim root  ' The FPCLib.FPC root object
Set root = CreateObject("FPC.Root")

' Declare the other objects needed.
Dim array            ' An FPCArray object
Dim usersets  ' An FPCUserSets collection
Dim userset   ' An FPCUserSet object

' Get references to the array object
' and the user sets collection.
Set array = root.GetContainingArray()
Set usersets = array.RuleElements.UserSets

' Display the names of the user sets
' defined for the array object.
For Each userset In usersets
    WScript.Echo "User set name: " & userset.Name
Next

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCUserSets


IFPCUserSets | FPCUserSets Add(String,IFPCUserSet) method [ISA Server 2004]

IFPCUserSets::Add[C++]

FPCUserSets.Add [Visual Basic]

[C++]

The Add method creates a new FPCUserSet object in the collection and returns a reference to it. The Save method must be called for the new FPCUserSet object to be saved in persistent storage.

HRESULT Add(
  BSTR Name,
  IFPCUserSet** ppNewSet
);

Parameters

Name
[in] Required. BSTR that specifies the name of the new user set.
ppNewSet
Address of an interface pointer that on return points to the new IFPCUserSet interface created.

Return Values

This method can return one of the following:

  • S_OK, indicating that the operation succeeded.
  • An error code, indicating that the operation failed. In this case, the [out] parameter returned is a null object.

[Visual Basic]

The Add method creates a new FPCUserSet object in the collection and returns a reference to it. The Save method must be called for the new FPCUserSet object to be saved in persistent storage.

Function Add( _
  ByVal Name As String _
) As FPCUserSet

Parameters

Name
[in] Required. String that specifies the name of the new user set.

Return Values

This method returns a reference to the new FPCUserSet object if successful. Otherwise, an error is raised that can be intercepted by using an error handler.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCUserSets


IFPCUserSets | FPCUserSets Count(long) property [ISA Server 2004]

Count Property of IFPCUserSets[C++]

FPCUserSets.Count [Visual Basic]

[C++]

The Count property gets the number of FPCUserSet objects in the collection.

HRESULT get_Count(
  long* plCount
);

Parameters

plCount
Pointer to a variable that on return receives a 32-bit integer specifying the number of FPCUserSet objects in the collection.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The Count property gets the number of FPCUserSet objects in the collection.

Property Count As Long

Property Value

A 32-bit integer that specifies the number of FPCUserSet objects in the collection.

Remarks

This property is read-only.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCUserSets


IFPCUserSets | FPCUserSets Item(Variant,IFPCUserSet) method [ISA Server 2004]

IFPCUserSets::Item[C++]

FPCUserSets.Item [Visual Basic]

[C++]

The Item method retrieves the requested IFPCUserSet interface from the collection.

HRESULT Item(
  VARIANT Index,
  IFPCUserSet** ppItem
);

Parameters

Index
[in] Required. Name or one-based index of the object to retrieve.
ppItem
[out] Address of a variable that receives a pointer to the IFPCUserSet interface requested.

Return Values

This method can return one of the following:

  • S_OK, indicating that the operation succeeded.
  • An error message, indicating that the operation failed. In this case, the [out] parameter returned is a null object.
[Visual Basic]

The Item method retrieves the requested FPCUserSet object from the collection.

Function Item( _
  ByVal Index As Variant _
) As FPCUserSet

Parameters

Index
[in] Required. Name or one-based index of the object to retrieve.

Return Values

This method returns a reference to the FPCUserSet object requested if successful. Otherwise, an error is raised that can be intercepted by using an error handler.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCUserSets


IFPCUserSets | FPCUserSets Remove(Variant) method [ISA Server 2004]

IFPCUserSets::Remove[C++]

FPCUserSets.Remove [Visual Basic]

[C++]

The Remove method removes the specified FPCUserSet object from the collection.

HRESULT Remove(
  VARIANT Index
);

Parameters

Index
[in] Required. Name or one-based index of the FPCUserSet object to remove.

Return Values

This method returns S_OK if the call is successful; otherwise, it returns an error code.
[Visual Basic]

The Remove method removes the specified FPCUserSet object from the collection.

Sub Remove( _
  ByVal Index As Variant _
)

Parameters

Index
[in] Required. Name or one-based index of the FPCUserSet object to remove.

Return Values

This method has no return values. If the call is unsuccessful, an error is raised that can be intercepted by using an error handler.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCUserSets


FPCVendorParametersSet object [ISA Server 2004]

FPCVendorParametersSet

The FPCVendorParametersSet object holds a private set of configuration data that a third party can associate with an extensible object. All ISA Server COM objects that have a VendorParametersSets property are extensible. This property retrieves an FPCVendorParametersSets collection that holds a group of FPCVendorParametersSet objects.

Each FPCVendorParametersSet object is identified by a globally unique identifier (GUID) that is provided to the Add method of its FPCVendorParametersSets collection when a new set is created.

The FPCVendorParametersSet object stores data that is defined as {name, value} pairs by using the Value property. The following example stores a parameter named x having a value of 1:

FPCVendorParametersSet.Value("x") = 1

The expression Value("x") returns the value of the parameter x.

When FPCVendorParametersSet objects are used, a third party can take advantage of the configuration storage capabilities of ISA Server. The third-party data in an FPCVendorParametersSet object can be written to persistent storage by calling its Save method, the Save method of its FPCVendorParametersSets collection, the Save method of the object being extended, or the Save method of any object that contains the object being extended. Similarly, the stored values of the third-party data can be read from persistent storage by calling its Refresh method, the Refresh method of the FPCVendorParametersSets collection, the Refresh method of the object being extended, or the Refresh method of any object that contains the object being extended.

The FPCVendorParametersSet object is typically an element of an FPCVendorParametersSets collection.

Click here to see the ISA Server object hierarchy.

Methods

The FPCVendorParametersSet object defines the following methods.

Method | Description
CancelWaitForChanges | Cancels the registration established by the WaitForChanges method (for use in C and C++ programming only).
Refresh | Reads the object's data from persistent storage, overwriting any changes that were not saved.
RemoveValue | Removes the specified value from the set.
Save | Writes the current values of all of the object's properties to persistent storage.
WaitForChanges | Registers to wait for an event indicating that the contents of the object have changed (for use in C and C++ programming only).

Properties

The FPCVendorParametersSet object has the following properties.

Property | Description
AllNames | Gets the names of all the parameters in the set.
Name | Gets or sets the name of the parameters set.
Value | Gets or sets the value associated with the parameter name supplied.

Remarks

This object implements the IFPCVendorParametersSet interface.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

COM Objects


IFPCVendorParametersSet.AllNames(VARIANT) property [ISA Server 2004]

AllNames Property of IFPCVendorParametersSet[C++]

FPCVendorParametersSet.AllNames [Visual Basic]

[C++]

The AllNames property gets the names of all the parameters in the set.

HRESULT get_AllNames(
  VARIANT* pvItem
);

Parameters

pvItem
Pointer to a VARIANT that on return receives a safe array of strings containing the names of all the parameters in the set.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The AllNames property gets the names of all the parameters in the set.

Property AllNames As Variant

Property Value

Array of strings containing the names of all the parameters in the set.

Remarks

This property is read-only.

Example Code

The AllNames property stores a list of all the names of user-defined properties stored through the Value property.

For example, the following uses the Value property to store values for two user-defined parameters, x and y:

Dim vps As FPCVendorParametersSet
...
vps.Value("x") = 1
vps.Value("y") = 2

If the AllNames property is used now, it returns an array of strings containing the strings "x" and "y".

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCVendorParametersSet


IFPCVendorParametersSet.CancelWaitForChanges method [ISA Server 2004]

IFPCVendorParametersSet::CancelWaitForChanges

The CancelWaitForChanges method cancels the registration established by the WaitForChanges method.

HRESULT CancelWaitForChanges();

Parameters

This method has no parameters.

Return Values

This method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This method can only be used in C and C++ programming languages. Also, it cannot be used with DCOM.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCVendorParametersSet


IFPCVendorParametersSet.Name(BSTR,BSTR) property [ISA Server 2004]

Name Property of IFPCVendorParametersSet[C++]

FPCVendorParametersSet.Name [Visual Basic]

[C++]

The Name property gets or sets the name of the parameters set.

HRESULT get_Name(
  BSTR* pbstrName
);

HRESULT put_Name(
  BSTR bstrName
);

Parameters

pbstrName
Pointer to a BSTR that is set on return to a string value specifying the name of the parameters set.
bstrName
BSTR that specifies the name of the parameters set.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write. The default name of a vendor parameters set is the globally unique identifier (GUID) that was provided to the Add method of its FPCVendorParametersSets collection when it was created.

[Visual Basic]

The Name property gets or sets the name of the parameters set.

Property Name As String

Property Value

String that specifies the name of the parameters set.

Remarks

This property is read/write. The default name of a vendor parameters set is the globally unique identifier (GUID) that was provided to the Add method of its FPCVendorParametersSets collection when it was created.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCVendorParametersSet


IFPCVendorParametersSet.Refresh method [ISA Server 2004]

IFPCVendorParametersSet::Refresh[C++]

FPCVendorParametersSet.Refresh [Visual Basic]

[C++]

The Refresh method reads the values of all of the object's properties from persistent storage, discarding any changes that have not been saved.

HRESULT Refresh();

Parameters

This method has no parameters.

Return Values

This method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

Changes made to this object can be saved by calling the Save method of this object or the Save method of any object containing it.

[Visual Basic]

The Refresh method reads the values of all of the object's properties from persistent storage, discarding any changes that have not been saved.

Sub Refresh()

Parameters

This method has no parameters.

Return Values

This method has no return values. If the call is unsuccessful, an error is raised that can be intercepted by using an error handler.

Remarks

Changes made to this object can be saved by calling the Save method of this object or the Save method of any object containing it.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCVendorParametersSet


IFPCVendorParametersSet.RemoveValue(String) method [ISA Server 2004]

IFPCVendorParametersSet::RemoveValue[C++]

FPCVendorParametersSet.RemoveValue [Visual Basic]

[C++]

The RemoveValue method removes the specified {name, value} pair from the set.

HRESULT RemoveValue(
  BSTR Name
);

Parameters

Name
String value that specifies the name of the parameter in the {name, value} pair to remove.

Return Values

This method returns S_OK if the call is successful; otherwise, it returns an error code.
[Visual Basic]

The RemoveValue method removes the specified {name, value} pair from the set.

Sub RemoveValue( _
  ByVal Name As String _
)

Parameters

Name
String value that specifies the name of the parameter in the {name, value} pair to remove.

Return Values

This method has no return values. If the call is unsuccessful, an error is raised that can be intercepted by using an error handler.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCVendorParametersSet


IFPCVendorParametersSet | FPCVendorParametersSet Save method [ISA Server 2004]

IFPCVendorParametersSet::Save[C++]

FPCVendorParametersSet.Save [Visual Basic]

[C++]

The Save method writes the current values of all of the object's properties to persistent storage. It is important to remember that any changes made by scripts and programs are not saved until after the Save method is called.

HRESULT Save(
  VARIANT_BOOL fResetRequiredServices,
  VARIANT_BOOL fReloadConfiguration
);

Parameters

fResetRequiredServices
[in, optional] Boolean value that indicates whether to restart the services that need to be restarted for any of the changes saved to take effect. The default value is VARIANT_FALSE.
fReloadConfiguration
[in, optional] Boolean value that indicates whether the call will include synchronous reloading of all changes that can be applied dynamically without restarting services. The default value is VARIANT_TRUE.

Return Values

This method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

Configuration changes are applied only after the new settings are written to persistent storage and reloaded to the services that use them. Most changes can be applied dynamically without restarting any services. However, some changes can take effect only after the Microsoft Firewall service is restarted. For more information, see Restarting Services after Configuration Changes.

ISA Server maintains a bitmask that specifies which services need to be started for currently unsaved changes to take effect. This bitmask can be retrieved by calling the GetServiceRestartMask method on an object that contains this object as a subobject. Calling the Save method clears all of the bits in this bitmask even if the fResetRequiredServices parameter is set to VARIANT_FALSE.

If the fReloadConfiguration parameter is set to VARIANT_FALSE the current values of the object's properties will be written to persistent storage without updating the configuration being used by the ISA Server services. The configuration used by each service will not be updated until the service is restarted or the new settings are reloaded by another call to Save.

[Visual Basic]

The Save method writes the current values of all of the object's properties to persistent storage. It is important to remember that any changes made by scripts and programs are not saved until after the Save method is called.

Sub Save( _
  [ ByVal fResetRequiredServices As Boolean ], _
  [ ByVal fReloadConfiguration As Boolean ] _
)

Parameters

fResetRequiredServices
[in, optional] Boolean value that indicates whether to restart the services that need to be restarted for any of the changes saved to take effect. The default value is False.
fReloadConfiguration
[in, optional] Boolean value that indicates whether the call will include synchronous reloading of all the saved configuration changes that can be applied dynamically without restarting services. The default value is True.

Return Values

This method has no return values. If the call is unsuccessful, an error is raised that can be intercepted by using an error handler.

Remarks

Configuration changes are applied only after the new settings are written to persistent storage and reloaded to the services that use them. Most changes can be applied dynamically without restarting any services. However, some changes can take effect only after the Microsoft Firewall service is restarted. For more information, see Restarting Services after Configuration Changes.

ISA Server maintains a bitmask that specifies which services need to be started for currently unsaved changes to take effect. This bitmask can be retrieved by calling the GetServiceRestartMask method on an object that contains this object as a subobject. Calling the Save method clears all of the bits in this bitmask even if the fResetRequiredServices parameter is set to False.

If the fReloadConfiguration parameter is set to False the current values of the object's properties will be written to persistent storage without updating the configuration being used by the ISA Server services. The configuration used by each service will not be updated until the service is restarted or the new settings are reloaded by another call to Save.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCVendorParametersSet


IFPCVendorParametersSet.Value (4 Parameters) property [ISA Server 2004]

Value Property of IFPCVendorParametersSet[C++]

FPCVendorParametersSet.Value [Visual Basic]

[C++]

The Value property gets or sets the value associated with the parameter name supplied.

HRESULT get_Value(
  BSTR bstrName,
  VARIANT* pvValue
);

HRESULT put_Value(
  BSTR bstrName,
  VARIANT vValue
);

Parameters

bstrName
Name of the parameter for which the value is to be retrieved or set.
pvValue
Pointer to a VARIANT that on return receives the value associated with the parameter name specified in the Name parameter. The value can be of any subtype defined in the VARIANT type and is not necessarily a string.
vValue
Value to be associated with the parameter name specified in the Name parameter. The value can be of any subtype defined in the VARIANT type and is not necessarily a string.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write.

[Visual Basic]

The Value property gets or sets the value associated with the parameter name supplied.

Property Value( _
  ByVal Name As String _
) As Variant

Parameters

Name
Name of the parameter for which the value is to be retrieved or set.

Property Value

Value associated with the parameter name specified in the Name parameter. The value can be of any subtype defined in the Variant type and is not necessarily a string.

Remarks

This property is read/write.

Example Code

The FPCVendorParametersSet object is used to store data that is defined as {name, value} pairs by using the Value property. The following example stores a parameter named x having a value of 1:

Dim vps As FPCVendorParametersSet
...
vps.Value("x") = 1

The expression Value("x") will return the value. The Value property is also the default property. The following examples are equivalent:

vps.Value("x")
vps("x")

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCVendorParametersSet


IFPCVendorParametersSet.WaitForChanges() method [ISA Server 2004]

IFPCVendorParametersSet::WaitForChanges

The WaitForChanges method registers to wait for an event indicating that the contents of the object have changed.

HRESULT WaitForChanges(
   hEvent
);

Parameters

hEvent
An event that will be signaled whenever the contents of the object change.

Return Values

This method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This method allows application filters to handle dynamic configuration changes smoothly. Note that when you develop an application filter that uses the WaitForChanges method to handle dynamic changes, the FPCVendorParametersSet object should be preserved as long as is necessary to receive notifications. This can be done by making the FPCVendorParametersSet object a member of the filter (IFWXFilter) object.

This method can only be used in C and C++ programming languages. Also, it cannot be used with DCOM.

It is possible to use Visual Basic to get notification of storage changes in the FPCVendorParametersSet object without using the WaitForChanges method. For more information, see the Remarks section in the FPCVendorParametersSet topic.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCVendorParametersSet


FPCVendorParametersSets collection [ISA Server 2004]

FPCVendorParametersSets Collection

The FPCVendorParametersSets collection holds an ordered set of FPCVendorParametersSet objects. Most ISA Server objects have a VendorParametersSets property that retrieves this FPCVendorParametersSets collection. A third party can use this collection to associate private sets of configuration information with the object being extended. All objects that have a VendorParametersSets property are extensible.

Each set is identified by a globally unique identifier (GUID) that is provided to the Add method when a new set is created.

By using the FPCVendorParametersSets collection, a third party can take advantage of the configuration storage capabilities of ISA Server. The third-party data can be written to persistent storage by calling the Save method of this collection, the Save method of the object being extended, or the Save method of any object that contains the object being extended. Similarly, the stored values of the third-party data can be read from persistent storage by calling the Refresh method of this collection, the Refresh method of the object being extended, or the Refresh method of any object that contains the object being extended.

Click here to see the ISA Server object hierarchy.

Methods

The FPCVendorParametersSets collection defines the following methods.

Method | Description
Add | Creates a new FPCVendorParametersSet object in the collection and returns a reference to it.
CancelWaitForChanges | Cancels the registration established by the WaitForChanges method (for use in C and C++ programming only).
Item | Returns the requested FPCVendorParametersSet object from the collection.
Refresh | Reads the values of all the properties of the collection and its elements from persistent storage, discarding any changes that were not saved.
Remove | Removes the specified FPCVendorParametersSet object from the collection.
Save | Writes the current values of all the properties of the collection and its elements to persistent storage.
WaitForChanges | Registers to wait for an event indicating that the contents of the collection have changed (for use in C and C++ programming only).

Properties

The FPCVendorParametersSets collection has the following properties.

Property | Description
_NewEnum | Gets an enumerator object for the collection.
Count | Gets the number of FPCVendorParametersSet objects in the collection.

Remarks

This collection implements the IFPCVendorParametersSets interface.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

COM Objects


IFPCVendorParametersSets._NewEnum(IUnknown) property [ISA Server 2004]

_NewEnum Property of IFPCVendorParametersSets[C++]

FPCVendorParametersSets._NewEnum [Visual Basic]

[C++]

The _NewEnum property gets an enumerator object for the collection. An enumerator object provides serial access to the elements of the collection.

HRESULT get__NewEnum(
  IUnknown* ppEnum
);

Parameters

ppEnum
Address of an interface pointer that on return points to the IUnknown interface of an enumerator object that implements an IEnumVARIANT interface for the collection. An interface pointer to the IEnumVARIANT interface of the enumerator object can be retrieved by calling QueryInterface on the IUnknown interface returned.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The _NewEnum property gets an enumerator object for the collection. An enumerator object provides serial access to the elements of the collection.

Property _NewEnum As IUnknown

Property Value

Reference to an enumerator object that provides serial access to the elements of the collection.

Remarks

This property is read-only.

In Visual Basic and VBScript, this property is used implicitly in For Each...In...Next constructs.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCVendorParametersSets


IFPCVendorParametersSets | FPCVendorParametersSets Add method [ISA Server 2004]

IFPCVendorParametersSets::Add[C++]

FPCVendorParametersSets.Add [Visual Basic]

[C++]

The Add method creates a new FPCVendorParametersSet object in the collection and returns a reference to it.

HRESULT Add(
  BSTR Id,
  VARIANT_BOOL Encrypted,
  VARIANT_BOOL EncryptionReadable,
  IFPCVendorParametersSet** ppNewSet
);

Parameters

Id
[in] Required. The string-formatted globally unique identifier (GUID) of the new vendor parameters set.
Encrypted
[in, optional] A Boolean value that indicates whether data saved in the new FPCVendorParametersSet object will be encrypted. The default value is VARIANT_FALSE.
EncryptionReadable
[in, optional] When this Boolean value is set to VARIANT_TRUE, encrypted data saved in the new FPCVendorParametersSet object can be read by any user account. When it is set to VARIANT_FALSE, encrypted data can be read only by the local system account and the network service account. The default value is VARIANT_FALSE.
ppNewSet
[out] Address of an interface pointer that on return points to the new IFPCVendorParametersSet interface added.

Return Values

The method can return one of the following:

  • S_OK, indicating that the operation succeeded.
  • An error code, indicating that the operation failed. In this case, the [out] parameter returned is a null object.

Remarks

The GUID supplied is formatted as a string in the form {12345678-1234-1234-1234-123456789abc}. Note the presence of the braces normally used with GUIDs.

If an FPCVendorParametersSet object is added with the fEncrypted parameter set to VARIANT_TRUE and the fEncryptionReadable parameter set to VARIANT_FALSE, only calls made under the local system account or the network service account will be able to read the data stored in the object.

Note When a user that has permission to access storage, but not to read the encrypted data, requests an FPCVendorParametersSet object that was created with these parameter settings, an empty FPCVendorParametersSet object is returned. Then, if that user makes changes to the object and saves it to persistent storage, the original FPCVendorParametersSet object will be overwritten, and only the data added by that user will be saved.

[Visual Basic]

The Add method creates a new FPCVendorParametersSet object in the collection and returns a reference to it.

Function Add( _
  ByVal Id As String, _
  [ ByVal Encrypted As Boolean ], _
  [ ByVal EncryptionReadable As Boolean ] _
) As FPCVendorParametersSet

Parameters

Id
[in] Required. The string-formatted globally unique identifier (GUID) of the new vendor parameters set.
Encrypted
[in, optional] A Boolean value that indicates whether data saved in the new FPCVendorParametersSet object will be encrypted. The default value is False.
EncryptionReadable
[in, optional] When this Boolean value is set to True, encrypted data saved in the new FPCVendorParametersSet object can be read by any user account. When it is set to False, encrypted data can be read only by the local system account and the network service account. The default value is False.

Return Values

The method returns a reference to the FPCVendorParametersSet object added if the call is successful. Otherwise, an error is raised that can be intercepted by using an error handler.

Remarks

The GUID supplied is formatted as a string in the form {12345678-1234-1234-1234-123456789abc}. Note the presence of the braces normally used with GUIDs.

If an FPCVendorParametersSet object is added with the fEncrypted parameter set to True and the fEncryptionReadable parameter set to False, only calls made under the local system account or the network service account will be able to read the data stored in the object.

Note When a user that has permission to access storage, but not to read the encrypted data, requests an FPCVendorParametersSet object that was created with these parameter settings, an empty FPCVendorParametersSet object is returned. Then, if that user makes changes to the object and saves it to persistent storage, the original FPCVendorParametersSet object will be overwritten, and only the data added by that user will be saved.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCVendorParametersSets


IFPCVendorParametersSets.CancelWaitForChanges method [ISA Server 2004]

IFPCVendorParametersSets::CancelWaitForChanges

The CancelWaitForChanges method cancels the registration established by the WaitForChanges method.
HRESULT CancelWaitForChanges();

Parameters

This method has no parameters.

Return Values

This method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This method can only be used in C and C++ programming languages. Also, it cannot be used with DCOM.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCVendorParametersSets


IFPCVendorParametersSets.Count(long) property [ISA Server 2004]

Count Property of IFPCVendorParametersSets[C++]

FPCVendorParametersSets.Count [Visual Basic]

[C++]

The Count property gets the number of FPCVendorParametersSet objects in the collection.

HRESULT get_Count(
  long* plCount
);

Parameters

plCount
Pointer to a variable that receives a 32-bit integer specifying the number of FPCVendorParametersSet objects in the collection.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The Count property gets the number of FPCVendorParametersSet objects in the collection.

Property Count As Long

Property Value

A 32-bit integer that specifies the number of FPCVendorParametersSet objects in the collection.

Remarks

This property is read-only.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCVendorParametersSets


IFPCVendorParametersSets.Item (2 Parameters) method [ISA Server 2004]

IFPCVendorParametersSets::Item[C++]

FPCVendorParametersSets.Item [Visual Basic]

[C++]

The Item method retrieves the requested IFPCVendorParametersSet interface from the collection.

HRESULT Item(
  VARIANT Index,
  IFPCVendorParametersSet** ppItem
);

Parameters

Index
[in] Required. Name or one-based index of the object to retrieve.
ppItem
[out] Address of a variable that receives a pointer to the IFPCVendorParametersSet interface requested.

Return Values

This method can return one of the following:

  • S_OK, indicating that the operation succeeded.
  • An error message, indicating that the operation failed. In this case, the [out] parameter returned is a null object.
[Visual Basic]

The Item method retrieves the requested FPCVendorParametersSet object from the collection.

Function Item( _
  ByVal Index As Variant _
) As FPCVendorParametersSet

Parameters

Index
[in] Required. Name or one-based index of the object to retrieve.

Return Values

This method returns a reference to the FPCVendorParametersSet object requested if successful. Otherwise, an error is raised that can be intercepted by using an error handler.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCVendorParametersSets


IFPCVendorParametersSets.Refresh method [ISA Server 2004]

IFPCVendorParametersSets::Refresh[C++]

FPCVendorParametersSets.Refresh [Visual Basic]

[C++]

The Refresh method reads the values of all the properties of the collection and of its elements from persistent storage, discarding any changes that have not been saved.

HRESULT Refresh();

Parameters

This method has no parameters.

Return Values

This method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

Changes made to this collection or its elements can be saved by calling the Save method of this collection or the Save method of any object containing it.

[Visual Basic]

The Refresh method reads the values of all the properties of the collection and of its elements from persistent storage, discarding any changes that have not been saved.

Sub Refresh()

Parameters

This method has no parameters.

Return Values

This method has no return values. If the call is unsuccessful, an error is raised that can be intercepted by using an error handler.

Remarks

Changes made to this collection or its elements can be saved by calling the Save method of this collection or the Save method of any object containing it.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCVendorParametersSets


IFPCVendorParametersSets.Remove(Variant) method [ISA Server 2004]

IFPCVendorParametersSets::Remove[C++]

FPCVendorParametersSets.Remove [Visual Basic]

[C++]

The Remove method removes the specified FPCVendorParametersSet object from the collection.

HRESULT Remove(
  VARIANT Index
);

Parameters

Index
[in] Required. Name or one-based index of the FPCVendorParametersSet object to remove.

Return Values

This method returns S_OK if the call is successful; otherwise, it returns an error code.
[Visual Basic]

The Remove method removes the specified FPCVendorParametersSet object from the collection.

Sub Remove( _
  ByVal Index As Variant _
)

Parameters

Index
[in] Required. Name or one-based index of the FPCVendorParametersSet object to remove.

Return Values

This method has no return values. If the call is unsuccessful, an error is raised that can be intercepted by using an error handler.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCVendorParametersSets


IFPCVendorParametersSets.Save (2 Parameters) method [ISA Server 2004]

IFPCVendorParametersSets::Save[C++]

FPCVendorParametersSets.Save [Visual Basic]

[C++]

The Save method writes the current values of all the properties of the collection and its elements to persistent storage. It is important to remember that any changes made by scripts and programs are not saved until after the Save method is called.

HRESULT Save(
  VARIANT_BOOL fResetRequiredServices,
  VARIANT_BOOL fReloadConfiguration
);

Parameters

fResetRequiredServices
[in, optional] Boolean value that indicates whether to restart the services that need to be restarted for any of the changes saved to take effect. The default value is VARIANT_FALSE.
fReloadConfiguration
[in, optional] Boolean value that indicates whether the call will include synchronous reloading of all changes that can be applied dynamically without restarting services. The default value is VARIANT_TRUE.

Return Values

This method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

Configuration changes are applied only after the new settings are written to persistent storage and reloaded to the services that use them. Most changes can be applied dynamically without restarting any services. However, some changes can take effect only after the Microsoft Firewall service is restarted. For more information, see Restarting Services after Configuration Changes.

ISA Server maintains a bitmask that specifies which services need to be started for currently unsaved changes to take effect. This bitmask can be retrieved by calling the GetServiceRestartMask method on an object that contains this object as a subobject. Calling the Save method clears all of the bits in this bitmask even if the fResetRequiredServices parameter is set to VARIANT_FALSE.

If the fReloadConfiguration parameter is set to VARIANT_FALSE the current values of the properties of the collection and its elements will be written to persistent storage without updating the configuration being used by the ISA Server services. The configuration used by each service will not be updated until the service is restarted or the new settings are reloaded by another call to Save.

[Visual Basic]

The Save method writes the current values of all the properties of the collection and its elements to persistent storage. It is important to remember that any changes made by scripts and programs are not saved until after the Save method is called.

Sub Save( _
  [ ByVal fResetRequiredServices As Boolean ], _
  [ ByVal fReloadConfiguration As Boolean ] _
)

Parameters

fResetRequiredServices
[in, optional] Boolean value that indicates whether to restart the services that need to be restarted for any of the changes saved to take effect. The default value is False.
fReloadConfiguration
[in, optional] Boolean value that indicates whether the call will include synchronous reloading of all the saved configuration changes that can be applied dynamically without restarting services. The default value is True.

Return Values

This method has no return values. If the call is unsuccessful, an error is raised that can be intercepted by using an error handler.

Remarks

Configuration changes are applied only after the new settings are written to persistent storage and reloaded to the services that use them. Most changes can be applied dynamically without restarting any services. However, some changes can take effect only after the Microsoft Firewall service is restarted. For more information, see Restarting Services after Configuration Changes.

ISA Server maintains a bitmask that specifies which services need to be started for currently unsaved changes to take effect. This bitmask can be retrieved by calling the GetServiceRestartMask method on an object that contains this object as a subobject. Calling the Save method clears all of the bits in this bitmask even if the fResetRequiredServices parameter is set to False.

If the fReloadConfiguration parameter is set to False the current values of the properties of the collection and its elements will be written to persistent storage without updating the configuration being used by the ISA Server services. The configuration used by each service will not be updated until the service is restarted or the new settings are reloaded by another call to Save.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCVendorParametersSets


IFPCVendorParametersSets.WaitForChanges(DWORD) method [ISA Server 2004]

IFPCVendorParametersSets::WaitForChanges

The WaitForChanges method registers to wait for an event indicating that the contents of the collection have changed.

HRESULT WaitForChanges(
  DWORD hEvent
);

Parameters

hEvent
[in] An event that is signaled whenever the storage content of the FPCVendorParametersSets collection changes.

Return Values

This method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This method can only be used in C and C++ programming languages. Also, it cannot be used with DCOM.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCVendorParametersSets


FPCVpnConfiguration object [ISA Server 2004]

FPCVpnConfiguration

The FPCVpnConfiguration object defines the virtual private network (VPN) settings for an ISA Server computer that serves as a VPN gateway.

The VPN configuration includes VPN quarantine settings, which can be accessed through the QuarantineSettings property. A VPN quarantine uses the Network Access Quarantine Control feature of Windows Server 2003 to prevent remote VPN clients from obtaining normal remote access until the configuration of their systems has been examined by a server-provided script and validated as meeting the requirements of the organization's network policies. The connection to a remote VPN client can be closed if the time-out period elapses before the configuration is validated.

The clearing of VPN clients from a quarantine can be enabled by installing Remote Access Quarantine Agent (Rqs.exe) on the ISA Server computer and the Remote Access Quarantine Client utility (Rqc.exe) on VPN clients. Both of these utilities are available in the Microsoft Windows Server 2003 Resource Kit. Additional steps must also be performed. For detailed instructions on implementing the clearing of VPN clients from a quarantine, see VPN Roaming Clients in ISA Server 2004.

Alternatively, you can create a custom listener component that listens for messages from a matching notifier component running on quarantine-compatible remote access clients. These messages indicate that the scripts have been run successfully. Then your listening component can use the MprAdminConnectionRemoveQuarantine function to remove the quarantine restrictions from the remote access connections.

The FPCVpnConfiguration object is typically accessed through the VpnConfiguration property of an FPCNetworkConfiguration object.

Click here to see the ISA Server object hierarchy.

Inheritance

This object inherits from the FPCPersist object, which contains methods and properties related to persistent storage of an object's data. They include methods for exporting an object's data to and importing it from an XML document.

Methods

The FPCVpnConfiguration object defines the following methods.

Method | Description
SetDNSConfiguration | Sets the primary and backup DNS servers, or specifies that the DNS server name is obtained from a DHCP server.
SetNetworkToObtainDHCP | Sets the name of the network for obtaining DHCP services.
SetWINSConfiguration | Sets the primary and backup WINS servers, or specifies that the WINS server name is obtained from a DHCP server.

Properties

The FPCVpnConfiguration object has the following properties.

Property | Description
AllowCustomIPSecPolicyForL2TP | Gets or sets a Boolean value that indicates whether the IPSec policy for L2TP can be customized.
BackupDNSServer | Gets the name of the backup Domain Name System (DNS) server.
BackupWINSServer | Gets the name of the backup Windows Internet Name Service (WINS) server.
DomainGroups | Gets an FPCAccounts collection that contains accounts representing domain groups.
EnableL2TP | Gets or sets a Boolean value that indicates whether L2TP is enabled.
EnablePPTP | Gets or sets a Boolean value that indicates whether PPTP is enabled.
EnableRADIUSAccounting | Gets or sets a Boolean value that indicates whether RADIUS accounting is enabled for the VPN gateway.
EnableRADIUSAuthentication | Gets or sets a Boolean value that indicates whether RADIUS authentication is enabled for the VPN gateway.
EnableVpnClients | Gets or sets a Boolean value that indicates whether access for remote VPN clients is enabled.
EnableWindowsAccounting | Gets or sets a Boolean value that indicates whether Windows accounting is enabled for the VPN gateway.
MaximumVpnClients | Gets or sets the maximum number of concurrent VPN clients.
NetworkSetsToListenOn | Gets an FPCRefs collection of references to the network sets that are allowed access to VPN protocols.
NetworksToListenOn | Gets an FPCRefs collection of references to the networks that are allowed access to VPN protocols.
NetworkToObtainDHCP | Gets an FPCRef object that references the FPCNetwork object representing the network for obtaining DHCP services.
PPPSettings | Gets an FPCVpnPPPSettings object that represents the PPP settings for the VPN gateway.
PresharedIPSecKey | Gets or sets the preshared IPSec key.
PrimaryDNSServer | Gets the name of the primary DNS server.
PrimaryWINSServer | Gets the name of the primary WINS server.
QuarantineSettings | Gets an FPCVpnQuarantineSettings object that represents the quarantine settings for the VPN gateway.
RADIUSUserMapping | Gets an FPCUserMapping object that represents the RADIUS user mapping settings for the VPN gateway.
StaticAddressPool | Gets an FPCIPRangeSet collection that represents the static address pool for the VPN gateway.
UseDHCPForAddressAssignment | Gets or sets a Boolean value that indicates whether the DHCP is used for IP address assignment.
UseDHCPForDNS | Gets a Boolean value that indicates whether DHCP is used for DNS servers.
UseDHCPForWINS | Gets a Boolean value that indicates whether DHCP is used for WINS servers.

Methods Inherited from FPCPersist

Name | Description
CancelWaitForChanges | Cancels the registration established by the WaitForChanges method (for use in C and C++ programming only).
CanImport | Returns a Boolean value that indicates whether the object's properties can be imported from the specified XML document.
Export | Recursively writes the stored values of all the properties of the object and its subobjects to the specified XML document.
ExportToFile | Recursively writes the stored values of all the properties of the object and its subobjects to the specified XML file.
GetServiceRestartMask | Retrieves a 32-bit bitmask of the FpcServices enumerated type that specifies which services need to be restarted for currently unsaved changes to take effect.
Import | Recursively copies the values of all the properties of the object and of its subobjects from the specified XML document to persistent storage.
ImportFromFile | Recursively copies the values of all the properties of the object and of its subobjects from the specified XML file to persistent storage.
LoadDocProperties | Provides the XML document's properties so that you can know what information can be imported from the document.
Refresh | Recursively reads the values of all the properties of the object and of its subobjects from persistent storage, overwriting any changes that have not been saved.
Save | Recursively writes the current values of all the properties of the object and its subobjects to persistent storage.
WaitForChanges | Registers to wait for an event indicating that the contents of the object have changed (for use in C and C++ programming only).

Properties Inherited from FPCPersist

Name | Description
PersistentName | Gets the persistent name of the object. The persistent name of an object is a name that is unique for the object at the respective level of the COM object hierarchy.
VendorParametersSets | Gets an FPCVendorParametersSets collection that can hold sets of custom data for extending the object.

Remarks

This object implements the IFPCVpnConfiguration interface.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

COM Objects


IFPCVpnConfiguration.AllowCustomIPSecPolicyForL2TP property [ISA Server 2004]

AllowCustomIPSecPolicyForL2TP Property of IFPCVpnConfiguration[C++]

FPCVpnConfiguration.AllowCustomIPSecPolicyForL2TP [Visual Basic]

[C++]

The AllowCustomIPSecPolicyForL2TP property gets or sets a Boolean value that indicates whether the IPSec policy for L2TP can be customized.

HRESULT get_AllowCustomIPSecPolicyForL2TP(
  VARIANT_BOOL* pfAllowCustomIPSecPolicyForL2TP
);

HRESULT put_AllowCustomIPSecPolicyForL2TP(
  VARIANT_BOOL fAllowCustomIPSecPolicyForL2TP
);

Parameters

pfAllowCustomIPSecPolicyForL2TP
Pointer to a Boolean variable that is set on return to VARIANT_TRUE if the IPSec policy for L2TP can be customized, or to VARIANT_FALSE if the IPSec policy for L2TP cannot be customized.
fAllowCustomIPSecPolicyForL2TP
Boolean value that specifies whether the IPSec policy for L2TP can be customized.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

On computers running a Windows 2000 Server operating system, these property methods always return E_FPC_VPN_IPSEC_PRESHARED_SECRET_NOT_SUPPORTED.

Remarks

This property is read/write.

This property can be set only on computers running an operating system from the Windows Server 2003 family.

[Visual Basic]

The AllowCustomIPSecPolicyForL2TP property gets or sets a Boolean value that indicates whether the IPSec policy for L2TP can be customized.

Property AllowCustomIPSecPolicyForL2TP As Boolean

Property Value

Boolean value that indicates whether the IPSec policy for L2TP can be customized.

Remarks

This property is read/write.

This property can be set only on computers running an operating system from the Windows Server 2003 family. An attempt to set this property on a computer running a Windows 2000 Server operating system raises an E_FPC_VPN_IPSEC_PRESHARED_SECRET_NOT_SUPPORTED error, which can be intercepted by using an error handler.

Requirements

Server: Requires Windows Server 2003.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCVpnConfiguration


IFPCVpnConfiguration.BackupDNSServer(BSTR) property [ISA Server 2004]

BackupDNSServer Property of IFPCVpnConfiguration[C++]

FPCVpnConfiguration.BackupDNSServer [Visual Basic]

[C++]

The BackupDNSServer property gets the name of the backup Domain Name System (DNS) server.

HRESULT get_BackupDNSServer(
  BSTR* pbstrBackupDNSServer
);

Parameters

pbstrBackupDNSServer
Pointer to a BSTR that is set on return to a string value specifying the name of the backup DNS server name.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only. It can be set using the SetDNSConfiguration method.

[Visual Basic]

The BackupDNSServer property gets the name of the backup Domain Name System (DNS) server.

Property BackupDNSServer As String

Property Value

String value that specifies the name of the backup DNS server name.

Remarks

This property is read-only. It can be set using the SetDNSConfiguration method.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCVpnConfiguration


IFPCVpnConfiguration.BackupWINSServer(BSTR) property [ISA Server 2004]

BackupWINSServer Property of IFPCVpnConfiguration[C++]

FPCVpnConfiguration.BackupWINSServer [Visual Basic]

[C++]

The BackupWINSServer property gets the name of the backup Windows Internet Name System (WINS) server.

HRESULT get_BackupWINSServer(
  BSTR* pbstrBackupWINSServer
);

Parameters

pbstrBackupWINSServer
Pointer to a BSTR that is set on return to a string value specifying the name of the backup WINS server.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only. It can be set using the SetWINSConfiguration method.

[Visual Basic]

The BackupWINSServer property gets the name of the backup Windows Internet Name System (WINS) server.

Property BackupWINSServer As String

Property Value

String value that specifies the name of the backup WINS server.

Remarks

This property is read-only. It can be set using the SetWINSConfiguration method.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCVpnConfiguration


IFPCVpnConfiguration.DomainGroups(IFPCAccounts) property [ISA Server 2004]

DomainGroups Property of IFPCVpnConfiguration[C++]

FPCVpnConfiguration.DomainGroups [Visual Basic]

[C++]

The DomainGroups property gets an FPCAccounts collection that contains accounts representing domain groups.

HRESULT get_DomainGroups(
  IFPCAccounts** ppAccounts
);

Parameters

ppAccounts
Address of an interface pointer that on return points to an IFPCAccounts interface that represents the collection of accounts representing domain groups.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only. It can be modified through the IFPCAccounts interface retrieved.

[Visual Basic]

The DomainGroups property gets an FPCAccounts collection that contains accounts representing domain groups.

Property DomainGroups As FPCAccounts

Property Value

Reference to an FPCAccounts collection that contains accounts representing domain groups.

Remarks

This property is read-only. It can be modified through the IFPCAccounts collection retrieved.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCVpnConfiguration


IFPCVpnConfiguration.EnableL2TP (2 Parameters) property [ISA Server 2004]

EnableL2TP Property of IFPCVpnConfiguration[C++]

FPCVpnConfiguration.EnableL2TP [Visual Basic]

[C++]

The EnableL2TP property gets or sets a Boolean value that indicates whether L2TP is enabled.

HRESULT get_EnableL2TP(
  VARIANT_BOOL* pfEnableL2TP
);

HRESULT put_EnableL2TP(
  VARIANT_BOOL fEnableL2TP
);

Parameters

pfEnableL2TP
Pointer to a Boolean variable that is set on return to VARIANT_TRUE if the VPN L2TP is enabled, or to VARIANT_FALSE if L2TP is not enabled.
fEnableL2TP
Boolean value that specifies whether L2TP is enabled.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write.

[Visual Basic]

The EnableL2TP property gets or sets a Boolean value that indicates whether L2TP is enabled.

Property EnableL2TP As Boolean

Property Value

Boolean value that indicates whether L2TP is enabled.

Remarks

This property is read/write.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCVpnConfiguration


IFPCVpnConfiguration.EnablePPTP (2 Parameters) property [ISA Server 2004]

EnablePPTP Property of IFPCVpnConfiguration[C++]

FPCVpnConfiguration.EnablePPTP [Visual Basic]

[C++]

The EnablePPTP property gets or sets a Boolean value that indicates whether PPTP is enabled.

HRESULT get_EnablePPTP(
  VARIANT_BOOL* pfEnablePPTP
);

HRESULT put_EnablePPTP(
  VARIANT_BOOL fEnablePPTP
);

Parameters

pfEnablePPTP
Pointer to a Boolean variable that is set on return to VARIANT_TRUE if the VPN PPTP is enabled, or to VARIANT_FALSE if PPTP is not enabled.
fEnablePPTP
Boolean value that specifies whether PPTP is enabled.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write.

[Visual Basic]

The EnablePPTP property gets or sets a Boolean value that indicates whether PPTP is enabled.

Property EnablePPTP As Boolean

Property Value

Boolean value that indicates whether PPTP is enabled.

Remarks

This property is read/write.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCVpnConfiguration


IFPCVpnConfiguration.EnableRADIUSAccounting property [ISA Server 2004]

EnableRADIUSAccounting Property of IFPCVpnConfiguration[C++]

FPCVpnConfiguration.EnableRADIUSAccounting [Visual Basic]

[C++]

The EnableRADIUSAccounting property gets or sets a Boolean value that indicates whether RADIUS accounting is enabled for the VPN gateway.

HRESULT get_EnableRADIUSAccounting(
  VARIANT_BOOL* pfEnableRADIUSAccounting
);

HRESULT put_EnableRADIUSAccounting(
  VARIANT_BOOL fEnableRADIUSAccounting
);

Parameters

pfEnableRADIUSAccounting
Pointer to a Boolean variable that is set on return to VARIANT_TRUE if RADIUS accounting is enabled for the VPN gateway, or to VARIANT_FALSE if RADIUS accounting is not enabled.
fEnableRADIUSAccounting
Boolean value that specifies whether RADIUS accounting is enabled for the VPN gateway.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write. Its default value is VARIANT_TRUE.

[Visual Basic]

The EnableRADIUSAccounting property gets or sets a Boolean value that indicates whether RADIUS accounting is enabled for the VPN gateway.

Property EnableRADIUSAccounting As Boolean

Property Value

Boolean value that indicates whether RADIUS accounting is enabled for the VPN gateway.

Remarks

This property is read/write. Its default value is True.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCVpnConfiguration


IFPCVpnConfiguration.EnableRADIUSAuthentication property [ISA Server 2004]

EnableRADIUSAuthentication Property of IFPCVpnConfiguration[C++]

FPCVpnConfiguration.EnableRADIUSAuthentication [Visual Basic]

[C++]

The EnableRADIUSAuthentication property gets or sets a Boolean value that indicates whether RADIUS authentication is enabled for the VPN gateway.

HRESULT get_EnableRADIUSAuthentication(
  VARIANT_BOOL* pfEnableRADIUSAuthentication
);

HRESULT put_EnableRADIUSAuthentication(
  VARIANT_BOOL fEnableRADIUSAuthentication
);

Parameters

pfEnableRADIUSAuthentication
Pointer to a Boolean variable that is set on return to VARIANT_TRUE if RADIUS authentication is enabled for the VPN gateway, or to VARIANT_FALSE if RADIUS authentication is not enabled.
fEnableRADIUSAuthentication
Boolean value that specifies whether RADIUS authentication is enabled for the VPN gateway.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write.

[Visual Basic]

The EnableRADIUSAuthentication property gets or sets a Boolean value that indicates whether RADIUS authentication is enabled for the VPN gateway.

Property EnableRADIUSAuthentication As Boolean

Property Value

Boolean value that indicates whether RADIUS authentication is enabled for the VPN gateway.

Remarks

This property is read/write.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCVpnConfiguration


IFPCVpnConfiguration.EnableVpnClients (2 Parameters) property [ISA Server 2004]

EnableVpnClients Property of IFPCVpnConfiguration[C++]

FPCVpnConfiguration.EnableVpnClients [Visual Basic]

[C++]

The EnableVpnClients property gets or sets a Boolean value that indicates whether access for remote VPN clients is enabled.

HRESULT get_EnableVpnClients(
  VARIANT_BOOL* pfEnableVpnClients
);

HRESULT put_EnableVpnClients(
  VARIANT_BOOL fEnableVpnClients
);

Parameters

pfEnableVpnClients
Pointer to a Boolean variable that is set on return to VARIANT_TRUE if access for remote VPN clients is enabled, or to VARIANT_FALSE if access for remote VPN clients is not enabled.
fEnableVpnClients
Boolean value that gets or sets a Boolean value that indicates whether access for remote VPN clients is enabled.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read/write.

[Visual Basic]

The EnableVpnClients property gets or sets a Boolean value that indicates whether access for remote VPN clients is enabled.

Property EnableVpnClients As Boolean

Property Value

Boolean value that indicates whether access for remote VPN clients is enabled.

Remarks

This property is read/write.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCVpnConfiguration


IFPCVpnConfiguration.EnableWindowsAccounting property [ISA Server 2004]

EnableWindowsAccounting Property of IFPCVpnConfiguration[C++]

FPCVpnConfiguration.EnableWindowsAccounting [Visual Basic]

[C++]

The EnableWindowsAccounting property gets or sets a Boolean value that indicates whether Windows accounting is enabled for the VPN gateway.

HRESULT get_EnableWindowsAccounting(
  VARIANT_BOOL* pfEnableWindowsAccounting
);

HRESULT put_EnableWindowsAccounting(
  VARIANT_BOOL fEnableWindowsAccounting
);

Parameters

pfEnableWindowsAccounting
Pointer to a Boolean variable that is set on return to VARIANT_TRUE if Windows accounting is enabled for the VPN gateway, or to VARIANT_FALSE if Windows accounting is not enabled.
fEnableWindowsAccounting
Boolean value that specifies whether Windows accounting is enabled for the VPN gateway.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write. By default, Windows accounting is disabled. To enable Windows accounting, RADIUS accounting must be disabled by setting the EnableRADIUSAccounting property to VARIANT_FALSE.

[Visual Basic]

The EnableWindowsAccounting property gets or sets a Boolean value that indicates whether Windows accounting is enabled for the VPN gateway.

Property EnableWindowsAccounting As Boolean

Property Value

Boolean value that indicates whether Windows accounting is enabled for the VPN gateway.

Remarks

This property is read/write. By default, Windows accounting is disabled. To enable Windows accounting, RADIUS accounting must be disabled by setting the EnableRADIUSAccounting property to False.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCVpnConfiguration


IFPCVpnConfiguration.MaximumVpnClients(Long,Long) property [ISA Server 2004]

MaximumVpnClients Property of IFPCVpnConfiguration[C++]

FPCVpnConfiguration.MaximumVpnClients [Visual Basic]

[C++]

The MaximumVpnClients property gets or sets the maximum number of concurrent VPN clients.

HRESULT get_MaximumVpnClients(
  Long* pfMaximumVpnClients
);

HRESULT put_MaximumVpnClients(
  Long fMaximumVpnClients
);

Parameters

pfMaximumVpnClients
Pointer to a variable that on return receives a 32-bit integer specifying the maximum number of concurrent VPN clients.
fMaximumVpnClients
A 32-bit integer that specifies the maximum number of concurrent VPN clients.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write.

[Visual Basic]

The MaximumVpnClients property gets or sets the maximum number of concurrent VPN clients.

Property MaximumVpnClients As Long

Property Value

A 32-bit integer that specifies the maximum number of concurrent VPN clients.

Remarks

This property is read/write.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCVpnConfiguration


IFPCVpnConfiguration.NetworkSetsToListenOn(IFPCRefs) property [ISA Server 2004]

NetworkSetsToListenOn Property of IFPCVpnConfiguration[C++]

FPCVpnConfiguration.NetworkSetsToListenOn [Visual Basic]

[C++]

The NetworkSetsToListenOn property gets an FPCRefs collection of references to the network sets that are allowed access to VPN protocols.

HRESULT get_NetworkSetsToListenOn(
  IFPCRefs** ppRefs
);

Parameters

ppRefs
Address of an interface pointer that on return points to an IFPCRefs interface that represents a collection of references to the network sets that are allowed access to VPN protocols.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only. It can be modified by calling the methods of the IFPCRefs interface.

[Visual Basic]

The NetworkSetsToListenOn property gets an FPCRefs collection of references to the network sets that are allowed access to VPN protocols.

Property NetworkSetsToListenOn As FPCRefs

Property Value

Reference to an FPCRefs collection that contains references to the network sets that are allowed access to VPN protocols.

Remarks

This property is read-only. It can be modified by calling the methods of the FPCRefs collection.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCVpnConfiguration


IFPCVpnConfiguration.NetworksToListenOn(IFPCRefs) property [ISA Server 2004]

NetworksToListenOn Property of IFPCVpnConfiguration[C++]

FPCVpnConfiguration.NetworksToListenOn [Visual Basic]

[C++]

The NetworksToListenOn property gets an FPCRefs collection of references to the networks that are allowed access to VPN protocols.

HRESULT get_NetworksToListenOn(
  IFPCRefs** ppRefs
);

Parameters

ppRefs
Address of an interface pointer that on return points to an IFPCRefs interface that represents a collection of references to the networks that are allowed access to VPN protocols.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only. It can be modified by calling the methods of the IFPCRefs interface.

[Visual Basic]

The NetworksToListenOn property gets an FPCRefs collection of references to the networks that are allowed access to VPN protocols.

Property NetworksToListenOn As FPCRefs

Property Value

Reference to an FPCRefs collection that contains references to the networks that are allowed access to VPN protocols.

Remarks

This property is read-only. It can be modified by calling the methods of the FPCRefs collection.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCVpnConfiguration


IFPCVpnConfiguration.NetworkToObtainDHCP(IFPCRef) property [ISA Server 2004]

NetworkToObtainDHCP Property of IFPCVpnConfiguration[C++]

FPCVpnConfiguration.NetworkToObtainDHCP [Visual Basic]

[C++]

The NetworkToObtainDHCP property gets an FPCRef object that references the FPCNetwork object representing the network for obtaining DHCP services. For more information about DHCP, see Dynamic Host Configuration Protocol SDK documentation.

HRESULT get_NetworkToObtainDHCP(
  IFPCRef** ppRef
);

Parameters

ppRef
Address of an interface pointer that on return points to an IFPCRef interface that references the FPCNetwork object representing the network for obtaining DHCP services.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only. The network for obtaining DHCP services can be set by calling the SetNetworkToObtainDHCP method.

[Visual Basic]

The NetworkToObtainDHCP property gets an FPCRef object that references the FPCNetwork object representing the network for obtaining DHCP services. For more information about DHCP, see Dynamic Host Configuration Protocol SDK documentation.

Property NetworkToObtainDHCP As FPCRef

Property Value

Reference to an FPCRef object that references the FPCNetwork object representing the network for obtaining DHCP services.

Remarks

This property is read-only. The network for obtaining DHCP services can be set by calling the SetNetworkToObtainDHCP method.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCVpnConfiguration


IFPCVpnConfiguration.PPPSettings(IFPCVpnPPPSettings) property [ISA Server 2004]

PPPSettings Property of IFPCVpnConfiguration[C++]

FPCVpnConfiguration.PPPSettings [Visual Basic]

[C++]

The PPPSettings property gets an FPCVpnPPPSettings object that represents the PPP settings for the VPN gateway.

HRESULT get_PPPSettings(
  IFPCVpnPPPSettings** ppVpnPPPSettings
);

Parameters

ppVpnPPPSettings
Address of an interface pointer that on return points to an IFPCVpnPPPSettings interface that represents the Point-to-Point Protocol (PPP) settings for the VPN gateway.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only. It can be modified by calling the properties and methods of the IFPCVpnPPPSettings interface retrieved.

[Visual Basic]

The PPPSettings property gets an FPCVpnPPPSettings object that represents the PPP settings for the VPN gateway.

Property PPPSettings As FPCVpnPPPSettings

Property Value

Reference to an FPCVpnPPPSettings object that represents the Point-to-Point Protocol (PPP) settings for the VPN gateway.

Remarks

This property is read-only. It can be modified by calling the properties and methods of the FPCVpnPPPSettings object retrieved.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCVpnConfiguration


IFPCVpnConfiguration.PresharedIPSecKey(BSTR,BSTR) property [ISA Server 2004]

PresharedIPSecKey Property of IFPCVpnConfiguration[C++]

FPCVpnConfiguration.PresharedIPSecKey [Visual Basic]

[C++]

The PresharedIPSecKey property gets or sets the preshared Internet Protocol security (IPSec) key. A preshared key is a string of text that is configured on both the VPN client and the VPN server. A preshared key provides a relatively weak authentication method. Therefore, we recommend using it only in the interim when your public key infrastructure (PKI) is being deployed to obtain computer certificates, or when a preshared key is required by VPN clients.

HRESULT get_PresharedIPSecKey(
  BSTR* pbstrKey
);

HRESULT put_PresharedIPSecKey(
  BSTR bstrKey
);

Parameters

pbstrKey
Pointer to a BSTR that is set on return to a string value specifying the IPSec key.
bstrKey
BSTR that specifies the IPSec key.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

On computers running a Windows 2000 Server operating system, these property methods always return E_FPC_VPN_IPSEC_PRESHARED_SECRET_NOT_SUPPORTED.

Remarks

This property is read/write.

This property can be set only on computers running an operating system from the Windows Server 2003 family.

[Visual Basic]

The PresharedIPSecKey property gets or sets the preshared Internet Protocol security (IPSec) key. A preshared key is a string of text that is configured on both the VPN client and the VPN server. A preshared key provides a relatively weak authentication method. Therefore, we recommend using it only in the interim when your public key infrastructure (PKI) is being deployed to obtain computer certificates, or when a preshared key is required by VPN clients.

Property PresharedIPSecKey As String

Property Value

String value that specifies the IPSec key.

Remarks

This property is read/write.

This property can be set only on computers running an operating system from the Windows Server 2003 family. An attempt to set this property on a computer running a Windows 2000 Server operating system raises an E_FPC_VPN_IPSEC_PRESHARED_SECRET_NOT_SUPPORTED error, which can be intercepted by using an error handler.

Requirements

Server: Requires Windows Server 2003.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCVpnConfiguration


IFPCVpnConfiguration.PrimaryDNSServer(BSTR) property [ISA Server 2004]

PrimaryDNSServer Property of IFPCVpnConfiguration[C++]

FPCVpnConfiguration.PrimaryDNSServer [Visual Basic]

[C++]

The PrimaryDNSServer property gets the name of the primary Domain Name System (DNS) server.

HRESULT get_PrimaryDNSServer(
  BSTR* pbstrPrimaryDNSServer
);

Parameters

pbstrPrimaryDNSServer
Pointer to a BSTR that is set on return to a string value specifying the name of the primary DNS server.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only. It can be set using the SetDNSConfiguration method.

[Visual Basic]

The PrimaryDNSServer property gets the name of the primary Domain Name System (DNS) server.

Property PrimaryDNSServer As String

Property Value

String value that specifies the name of the primary DNS server.

Remarks

This property is read-only. It can be set using the SetDNSConfiguration method.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCVpnConfiguration


IFPCVpnConfiguration.PrimaryWINSServer(BSTR) property [ISA Server 2004]

PrimaryWINSServer Property of IFPCVpnConfiguration[C++]

FPCVpnConfiguration.PrimaryWINSServer [Visual Basic]

[C++]

The PrimaryWINSServer property gets the name of the primary Windows Internet Name System (WINS) server.

HRESULT get_PrimaryWINSServer(
  BSTR* pbstrPrimaryWINSServer
);

Parameters

pbstrPrimaryWINSServer
Pointer to a BSTR that is set on return to a string value specifying the name of the primary WINS server.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only. It can be set using the SetWINSConfiguration method.

[Visual Basic]

The PrimaryWINSServer property gets the name of the primary Windows Internet Name System (WINS) server.

Property PrimaryWINSServer As String

Property Value

String value that specifies the name of the primary WINS server.

Remarks

This property is read-only. It can be set using the SetWINSConfiguration method.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCVpnConfiguration


IFPCVpnConfiguration.QuarantineSettings (1 Parameter) property [ISA Server 2004]

QuarantineSettings Property of IFPCVpnConfiguration[C++]

FPCVpnConfiguration.QuarantineSettings [Visual Basic]

[C++]

The QuarantineSettings property gets an FPCVpnQuarantineSettings object that represents the quarantine settings for the virtual private network (VPN) gateway.

HRESULT get_QuarantineSettings(
  IFPCVpnQuarantineSettings** ppVpnQuarantineSettings
);

Parameters

ppVpnQuarantineSettings
Address of an interface pointer that on return points to an IFPCVpnQuarantineSettings interface that represents the quarantine settings for the VPN gateway.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only. It can be modified by calling the properties and methods of the IFPCVpnQuarantineSettings interface retrieved.

A VPN quarantine uses the Network Access Quarantine Control feature of Windows Server 2003 to prevent remote VPN clients from obtaining normal remote access until the configuration of their systems has been examined by a server-provided script and validated as meeting the requirements of the organization's network policies. The connection to a remote VPN client can be closed if the time-out period elapses before the configuration is validated.

The clearing of VPN clients from a quarantine can be enabled by installing Remote Access Quarantine Agent (Rqs.exe) on the ISA Server computer and the Remote Access Quarantine Client utility (Rqc.exe) on VPN clients. Both of these utilities are available in the Microsoft Windows Server 2003 Resource Kit. Additional steps must also be performed. For detailed instructions about implementing the clearing of VPN clients from a quarantine, see VPN Roaming Clients in ISA Server 2004.

Alternatively, you can create a custom listener component that listens for messages from a matching notifier component running on quarantine-compatible remote access clients. These messages indicate that the scripts have been run successfully. Then your listening component can use the MprAdminConnectionRemoveQuarantine function to remove the quarantine restrictions from the remote access connections.

[Visual Basic]

The QuarantineSettings property gets an FPCVpnQuarantineSettings object that represents the quarantine settings for the virtual private network (VPN) gateway.

Property QuarantineSettings As FPCVpnQuarantineSettings

Property Value

Reference to an FPCVpnQuarantineSettings object that represents the quarantine settings for the VPN gateway.

Remarks

This property is read-only. It can be modified by calling the properties and methods of the FPCVpnQuarantineSettings object retrieved.

A VPN quarantine uses the Network Access Quarantine Control feature of Windows Server 2003 to prevent remote VPN clients from obtaining normal remote access until the configuration of their systems has been examined by a server-provided script and validated as meeting the requirements of the organization's network policies. The connection to a remote VPN client can be closed if the time-out period elapses before the configuration is validated.

The clearing of VPN clients from a quarantine can be enabled by installing Remote Access Quarantine Agent (Rqs.exe) on the ISA Server computer and the Remote Access Quarantine Client utility (Rqc.exe) on VPN clients. Both of these utilities are available in the Microsoft Windows Server 2003 Resource Kit. Additional steps must also be performed. For detailed instructions about implementing the clearing of VPN clients from a quarantine, see VPN Roaming Clients in ISA Server 2004.

Alternatively, you can create a custom listener component that listens for messages from a matching notifier component running on quarantine-compatible remote access clients. These messages indicate that the scripts have been run successfully. Then your listening component can use the MprAdminConnectionRemoveQuarantine function to remove the quarantine restrictions from the remote access connections.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCVpnConfiguration


IFPCVpnConfiguration.RADIUSUserMapping (1 Parameter) property [ISA Server 2004]

RADIUSUserMapping Property of IFPCVpnConfiguration[C++]

FPCVpnConfiguration.RADIUSUserMapping [Visual Basic]

[C++]

The RADIUSUserMapping property gets an FPCUserMapping object that represents the RADIUS user mapping settings for the VPN gateway.

HRESULT get_RADIUSUserMapping(
  IFPCUserMapping** ppUserMapping
);

Parameters

ppUserMapping
Address of an interface pointer that on return points to an IFPCUserMapping interface that represents the RADIUS user mapping settings for the VPN gateway.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only. It can be modified by calling the properties and methods of the IFPCUserMapping interface retrieved.

[Visual Basic]

The RADIUSUserMapping property gets an FPCUserMapping object that represents the RADIUS user mapping settings for the VPN gateway.

Property RADIUSUserMapping As FPCUserMapping

Property Value

Reference to an FPCUserMapping object that represents the RADIUS user mapping settings for the VPN gateway.

Remarks

This property is read-only. It can be modified by calling the properties and methods of the FPCUserMapping object retrieved.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCVpnConfiguration


IFPCVpnConfiguration.SetDNSConfiguration (3 Parameters) method [ISA Server 2004]

IFPCVpnConfiguration::SetDNSConfiguration[C++]

FPCVpnConfiguration.SetDNSConfiguration [Visual Basic]

[C++]

The SetDNSConfiguration method sets the primary and backup DNS servers, or specifies that the DNS server name is obtained from a DHCP server.

HRESULT SetDNSConfiguration(
  VARIANT_BOOL ObtainFromDHCP,
  BSTR newPrimaryName,
  BSTR newBackupName
);

Parameters

ObtainFromDHCP
[in] Boolean value that indicates whether the DNS server name is obtained from a DHCP server.
newPrimaryName
[in, optional] String that specifies the name of the primary DNS server. The default value is an empty string.
newBackupName
[in, optional] String value that specifies the name of the backup DNS server. The default value is an empty string.

Return Values

This method returns S_OK if the call is successful; otherwise, it returns an error code.
[Visual Basic]

The SetDNSConfiguration method sets the primary and backup DNS servers, or specifies that the DNS server name is obtained from a DHCP server.

Sub SetDNSConfiguration( _
  ByVal ObtainFromDHCP As Boolean, _
  [ ByVal newPrimaryName As String ], _
  [ ByVal newBackupName As String ] _
)

Parameters

ObtainFromDHCP
[in] Boolean value that indicates whether the DNS server name is obtained from a DHCP server.
newPrimaryName
[in, optional] String that specifies the name of the primary DNS server. The default value is an empty string.
newBackupName
[in, optional] String value that specifies the name of the backup DNS server. The default value is an empty string.

Return Values

This method has no return values. If the call is unsuccessful, an error is raised that can be intercepted by using an error handler.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCVpnConfiguration


IFPCVpnConfiguration.SetNetworkToObtainDHCP(String) method [ISA Server 2004]

IFPCVpnConfiguration::SetNetworkToObtainDHCP[C++]

FPCVpnConfiguration.SetNetworkToObtainDHCP [Visual Basic]

[C++]

The SetNetworkToObtainDHCP method sets the name of the network for obtaining DHCP services. For more information about DHCP, see Dynamic Host Configuration Protocol SDK documentation.

HRESULT SetNetworkToObtainDHCP(
  BSTR NetworkName
);

Parameters

NetworkName
[in] BSTR that specifies the name of the network.

Return Values

This method returns S_OK if the call is successful; otherwise, it returns an error code.
[Visual Basic]

The SetNetworkToObtainDHCP method sets the name of the network for obtaining DHCP services. For more information about DHCP, see Dynamic Host Configuration Protocol SDK documentation.

Sub SetNetworkToObtainDHCP( _
  ByVal NetworkName As String _
)

Parameters

NetworkName
[in] String that specifies the name of the network.

Return Values

This method has no return values. If the call is unsuccessful, an error is raised that can be intercepted by using an error handler.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCVpnConfiguration


IFPCVpnConfiguration.SetWINSConfiguration method [ISA Server 2004]

IFPCVpnConfiguration::SetWINSConfiguration[C++]

FPCVpnConfiguration.SetWINSConfiguration [Visual Basic]

[C++]

The SetWINSConfiguration method sets the primary and backup WINS servers, or specifies that the WINS server name is obtained from a DHCP server.

HRESULT SetWINSConfiguration(
  VARIANT_BOOL ObtainFromDHCP,
  BSTR newPrimaryName,
  BSTR newBackupName
);

Parameters

ObtainFromDHCP
[in] Boolean value that indicates whether the WINS server name is obtained from a DHCP server.
newPrimaryName
[in, optional] String that specifies the name of the primary WINS server. The default value is an empty string.
newBackupName
[in, optional] String value that specifies the name of the backup WINS server. The default value is an empty string.

Return Values

This method returns S_OK if the call is successful; otherwise, it returns an error code.
[Visual Basic]

The SetWINSConfiguration method sets the primary and backup WINS servers, or specifies that the WINS server name is obtained from a DHCP server.

Sub SetWINSConfiguration( _
  ByVal ObtainFromDHCP As Boolean, _
  [ ByVal newPrimaryName As String ], _
  [ ByVal newBackupName As String ] _
)

Parameters

ObtainFromDHCP
[in] Boolean value that indicates whether the WINS server name is obtained from a DHCP server.
newPrimaryName
[in, optional] String that specifies the name of the primary WINS server. The default value is an empty string.
newBackupName
[in, optional] String value that specifies the name of the backup WINS server. The default value is an empty string.

Return Values

This method has no return values. If the call is unsuccessful, an error is raised that can be intercepted by using an error handler.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCVpnConfiguration


IFPCVpnConfiguration.StaticAddressPool(IFPIpRangeSet) property [ISA Server 2004]

StaticAddressPool Property of IFPCVpnConfiguration[C++]

FPCVpnConfiguration.StaticAddressPool [Visual Basic]

[C++]

The StaticAddressPool property gets an FPCIPRangeSet collection that represents the static address pool for the VPN gateway. The static address pool is a configured pool of IP addresses for allocation to TCP/IP-based remote access and demand-dial connections.

HRESULT get_StaticAddressPool(
  IFPIpRangeSet** ppIpRangeSet
);

Parameters

ppIpRangeSet
Address of an interface pointer that on return points to an IFPCIpRangeSet interface that represents the static address pool for the VPN gateway.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only. It can be modified by calling the methods of the IFPCIpRangeSet interface retrieved.

[Visual Basic]

The StaticAddressPool property gets an FPCIPRangeSet collection that represents the static address pool for the VPN gateway. The static address pool is a configured pool of IP addresses for allocation to TCP/IP-based remote access and demand-dial connections.

Property StaticAddressPool As FPCIpRangeSet

Property Value

Reference to the FPCIpRangeSet collection that represents the static address pool for the VPN gateway.

Remarks

This property is read-only. It can be modified by calling the methods of the FPCIpRangeSet collection retrieved.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCVpnConfiguration


IFPCVpnConfiguration.UseDHCPForAddressAssignment property [ISA Server 2004]

UseDHCPForAddressAssignment Property of IFPCVpnConfiguration[C++]

FPCVpnConfiguration.UseDHCPForAddressAssignment [Visual Basic]

[C++]

The UseDHCPForAddressAssignment property gets or sets a Boolean value that indicates whether DHCP is used for IP address assignment. For more information about DHCP, see the Dynamic Host Configuration Protocol SDK documentation.

HRESULT get_UseDHCPForAddressAssignment(
  VARIANT_BOOL* pfUseDHCPForAddress
);

HRESULT put_UseDHCPForAddressAssignment(
  VARIANT_BOOL fUseDHCPForAddress
);

Parameters

pfUseDHCPForAddress
Pointer to a Boolean variable that is set on return to VARIANT_TRUE if DHCP is used for IP address assignment, or to VARIANT_FALSE if DHCP is not used for IP address assignment.
fUseDHCPForAddress
Boolean value that indicates whether DHCP is used for IP address assignment.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write.

[Visual Basic]

The UseDHCPForAddressAssignment property gets or sets a Boolean value that indicates whether DHCP is used for IP address assignment. For more information about DHCP, see the Dynamic Host Configuration Protocol SDK documentation.

Property UseDHCPForAddressAssignment As Boolean

Property Value

Boolean value that indicates whether DHCP is used for IP address assignment.

Remarks

This property is read/write.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCVpnConfiguration


IFPCVpnConfiguration.UseDHCPForDNS(VARIANT_BOOL) property [ISA Server 2004]

UseDHCPForDNS Property of IFPCVpnConfiguration[C++]

FPCVpnConfiguration.UseDHCPForDNS [Visual Basic]

[C++]

The UseDHCPForDNS property gets a Boolean value that indicates whether DHCP is used for DNS servers. For more information about DHCP, see Dynamic Host Configuration Protocol SDK documentation.

HRESULT get_UseDHCPForDNS(
  VARIANT_BOOL* pfUseDHCPForDNS
);

Parameters

pfUseDHCPForDNS
Pointer to a Boolean variable that is set on return to VARIANT_TRUE if DHCP is used for DNS servers, or to VARIANT_FALSE if DHCP is not used for DNS servers.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only. You can set this property using the SetDNSConfiguration method.

[Visual Basic]

The UseDHCPForDNS property gets a Boolean value that indicates whether DHCP is used for DNS servers. For more information about DHCP, see Dynamic Host Configuration Protocol SDK documentation.

Property UseDHCPForDNS As Boolean

Property Value

Boolean value that indicates whether DHCP is used for DNS servers.

Remarks

This property is read-only. You can set this property using the SetDNSConfiguration method.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCVpnConfiguration


IFPCVpnConfiguration.UseDHCPForWINS(VARIANT_BOOL) property [ISA Server 2004]

UseDHCPForWINS Property of IFPCVpnConfiguration[C++]

FPCVpnConfiguration.UseDHCPForWINS [Visual Basic]

[C++]

The UseDHCPForWINS property gets a Boolean value that indicates whether DHCP is used for WINS servers. For more information about DHCP, see Dynamic Host Configuration Protocol SDK documentation.

HRESULT get_UseDHCPForWINS(
  VARIANT_BOOL* pfUseDHCPForWINS
);

Parameters

pfUseDHCPForWINS
Pointer to a Boolean variable that is set on return to VARIANT_TRUE if DHCP is used for WINS servers, or to VARIANT_FALSE if DHCP is not used for WINS servers.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only. You can set this property using the SetWINSConfiguration method.

[Visual Basic]

The UseDHCPForWINS property gets a Boolean value that indicates whether DHCP is used for WINS servers. For more information about DHCP, see Dynamic Host Configuration Protocol SDK documentation.

Property UseDHCPForWINS As Boolean

Property Value

Boolean value that indicates whether DHCP is used for WINS servers.

Remarks

This property is read-only. You can set this property using the SetWINSConfiguration method.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCVpnConfiguration


FPCVpnNetworkConfiguration object [ISA Server 2004]

FPCVpnNetworkConfiguration

The FPCVpnNetworkConfiguration object provides access to the configuration settings for site-to-site virtual private network (VPN) connections to the applicable network.

This object is typically accessed through the VpnConfiguration property of an FPCNetwork object.

Click here to see the ISA Server object hierarchy.

Methods

The FPCVpnNetworkConfiguration object defines the following methods.

Method | Description
Refresh | Recursively reads the values of all of the properties of the object and its subobjects from persistent storage, discarding any changes that have not been saved.
Save | Recursively writes the current values of all of the properties of the object and its subobjects to persistent storage.

Properties

The FPCVpnNetworkConfiguration object has the following properties.

Property | Description
Enable | Gets or sets a Boolean value that indicates whether the site-to-site VPN access is enabled.
IPSecSettings | Gets an FPCVpnNetworkIPSecSettings object that specifies the Internet Protocol security (IPSec) settings for site-to-site VPN connections.
L2tpPptpSettings | Gets an FPCVpnNetworkL2tpPptpSettings object that specifies the Layer Two Tunneling Protocol (L2TP) and Point-to-Point Tunneling Protocol (PPTP) settings for site-to-site VPN connections.

Remarks

This object implements the IFPCVpnNetworkConfiguration interface.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

COM Objects


IFPCVpnNetworkConfiguration.Enable (2 Parameters) property [ISA Server 2004]

Enable Property of IFPCVpnNetworkConfiguration[C++]

FPCVpnNetworkConfiguration.Enable [Visual Basic]

[C++]

The Enable property gets or sets a Boolean value that indicates whether the site-to-site VPN access is enabled.

HRESULT get_Enable(
  VARIANT_BOOL* pfEnabled
);

HRESULT put_Enable(
  VARIANT_BOOL fEnabled
);

Parameters

pfEnabled
Pointer to a Boolean variable that is set on return to VARIANT_TRUE if the site-to-site VPN access is enabled, or to VARIANT_FALSE if the site-to-site VPN access is disabled.
fEnabled
Boolean value that indicates whether the site-to-site VPN access is disabled.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write.

[Visual Basic]

The Enable property gets or sets a Boolean value that indicates whether the site-to-site VPN access is enabled.

Property Enable As Boolean

Property Value

Boolean value that indicates whether the site-to-site VPN access is enabled.

Remarks

This property is read/write.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCVpnNetworkConfiguration


IFPCVpnNetworkConfiguration.IPSecSettings property [ISA Server 2004]

IPSecSettings Property of IFPCVpnNetworkConfiguration[C++]

FPCVpnNetworkConfiguration.IPSecSettings [Visual Basic]

[C++]

The IPSecSettings property gets an FPCVpnNetworkIPSecSettings object that specifies the Internet Protocol security (IPSec) settings for site-to-site VPN connections.

HRESULT get_IPSecSettings(
  IFPCVpnNetworkIPSecSettings** ppVpnNetworkIPSecSettings
);

Parameters

ppVpnNetworkIPSecSettings
Address of an interface pointer that on return points to an IFPCVpnNetworkIPSecSettings interface that specifies the IPSec settings for site-to-site VPN connections.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only and can be accessed only if the NetworkConnectionType property of the containing FPCNetwork object is set to fpcIPSecConnection. The IPSec settings for site-to-site VPN connections can be modified through the properties of the IFPCVpnNetworkIPSecSettings interface retrieved.

[Visual Basic]

The IPSecSettings property gets an FPCVpnNetworkIPSecSettings object that specifies the Internet Protocol security (IPSec) settings for site-to-site VPN connections.

Property IPSecSettings As FPCVpnNetworkIPSecSettings

Property Value

Reference to an FPCVpnNetworkIPSecSettings object that specifies the IPSec settings for site-to-site VPN connections.

Remarks

This property is read-only and can be accessed only if the NetworkConnectionType property of the containing FPCNetwork object is set to fpcIPSecConnection. The IPSec settings for site-to-site VPN connections can be modified through the properties of the FPCVpnNetworkIPSecSettings object retrieved.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCVpnNetworkConfiguration


IFPCVpnNetworkConfiguration.L2tpPptpSettings property [ISA Server 2004]

L2tpPptpSettings Property of IFPCVpnNetworkConfiguration[C++]

FPCVpnNetworkConfiguration.L2tpPptpSettings [Visual Basic]

[C++]

The L2tpPptpSettings property gets an FPCVpnNetworkL2tpPptpSettings object that specifies the Layer Two Tunneling Protocol (L2TP) and Point-to-Point Tunneling Protocol (PPTP) settings for site-to-site VPN connections.

HRESULT get_L2tpPptpSettings(
  IFPCVpnNetworkL2tpPptpSettings** ppVpnNetworkL2tpPptpSettings
);

Parameters

ppVpnNetworkL2tpPptpSettings
Address of an interface pointer that on return points to an IFPCVpnNetworkL2tpPptpSettings interface that specifies the L2TP and PPTP settings for site-to-site VPN connections.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only and can be accessed only if the NetworkConnectionType property of the containing FPCNetwork object is set to fpcVPNConnection. The L2TP and PPTP settings for site-to-site VPN connections can be modified through the properties of the IFPCVpnNetworkL2tpPptpSettings interface retrieved.

[Visual Basic]

The L2tpPptpSettings property gets an FPCVpnNetworkL2tpPptpSettings object that specifies the Layer Two Tunneling Protocol (L2TP) and Point-to-Point Tunneling Protocol (PPTP) settings for site-to-site VPN connections.

Property L2tpPptpSettings As FPCVpnNetworkL2tpPptpSettings

Property Value

Reference to an FPCVpnNetworkL2tpPptpSettings object that specifies the L2TP and PPTP settings for site-to-site VPN connections.

Remarks

This property is read-only and can be accessed only if the NetworkConnectionType property of the containing FPCNetwork object is set to fpcVPNConnection. The IPSec settings for site-to-site VPN connections can be modified through the properties of the FPCVpnNetworkL2tpPptpSettings object retrieved.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCVpnNetworkConfiguration


IFPCVpnNetworkConfiguration.Refresh method [ISA Server 2004]

IFPCVpnNetworkConfiguration::Refresh[C++]

FPCVpnNetworkConfiguration.Refresh [Visual Basic]

[C++]

The Refresh method recursively reads the values of all of the properties of the object and its subobjects from persistent storage, discarding any changes that have not been saved.

HRESULT Refresh();

Parameters

This method has no parameters.

Return Values

This method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

Changes made to this object can be saved by calling the Save method of this object or the Save method of any object containing it.

[Visual Basic]

The Refresh method recursively reads the values of all of the properties of the object and its subobjects from persistent storage, discarding any changes that have not been saved.

Sub Refresh()

Parameters

This method has no parameters.

Return Values

This method has no return values. If the call is unsuccessful, an error is raised that can be intercepted by using an error handler.

Remarks

Changes made to this object can be saved by calling the Save method of this object or the Save method of any object containing it.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCVpnNetworkConfiguration


IFPCVpnNetworkConfiguration.Save (2 Parameters) method [ISA Server 2004]

IFPCVpnNetworkConfiguration::Save[C++]

FPCVpnNetworkConfiguration.Save [Visual Basic]

[C++]

The Save method recursively writes the current values of all of the properties of the object and its subobjects to persistent storage. It is important to remember that any changes made by scripts and programs are not saved until after the Save method is called.

HRESULT Save(
  VARIANT_BOOL fResetRequiredServices,
  VARIANT_BOOL fReloadConfiguration
);

Parameters

fResetRequiredServices
[in, optional] Boolean value that indicates whether to restart the services that need to be restarted for any of the changes saved to take effect. The default value is VARIANT_FALSE.
fReloadConfiguration
[in, optional] Boolean value that indicates whether the call will include synchronous reloading of all changes that can be applied dynamically without restarting services. The default value is VARIANT_TRUE.

Return Values

This method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

Configuration changes are applied only after the new settings are written to persistent storage and reloaded to the services that use them. Most changes can be applied dynamically without restarting any services. However, some changes can take effect only after the Microsoft Firewall service is restarted. For more information, see Restarting Services after Configuration Changes.

ISA Server maintains a bitmask that specifies which services need to be started for currently unsaved changes to take effect. This bitmask can be retrieved by calling the GetServiceRestartMask method on an object that contains this object as a subobject. Calling the Save method clears all of the bits in this bitmask even if the fResetRequiredServices parameter is set to VARIANT_FALSE.

If the fReloadConfiguration parameter is set to VARIANT_FALSE the current values of the properties of the object and its subobjects will be written to persistent storage without updating the configuration being used by the ISA Server services. The configuration used by each service will not be updated until the service is restarted or the new settings are reloaded by another call to Save.

[Visual Basic]

The Save method recursively writes the current values of all of the properties of the object and its subobjects to persistent storage. It is important to remember that any changes made by scripts and programs are not saved until after the Save method is called.

Sub Save( _
  [ ByVal fResetRequiredServices As Boolean ], _
  [ ByVal fReloadConfiguration As Boolean ] _
)

Parameters

fResetRequiredServices
[in, optional] Boolean value that indicates whether to restart the services that need to be restarted for any of the changes saved to take effect. The default value is False.
fReloadConfiguration
[in, optional] Boolean value that indicates whether the call will include synchronous reloading of all the saved configuration changes that can be applied dynamically without restarting services. The default value is True.

Return Values

This method has no return values. If the call is unsuccessful, an error is raised that can be intercepted by using an error handler.

Remarks

Configuration changes are applied only after the new settings are written to persistent storage and reloaded to the services that use them. Most changes can be applied dynamically without restarting any services. However, some changes can take effect only after the Microsoft Firewall service is restarted. For more information, see Restarting Services after Configuration Changes.

ISA Server maintains a bitmask that specifies which services need to be started for currently unsaved changes to take effect. This bitmask can be retrieved by calling the GetServiceRestartMask method on an object that contains this object as a subobject. Calling the Save method clears all of the bits in this bitmask even if the fResetRequiredServices parameter is set to False.

If the fReloadConfiguration parameter is set to False the current values of the properties of the object and its subobject will be written to persistent storage without updating the configuration being used by the ISA Server services. The configuration used by each service will not be updated until the service is restarted or the new settings are reloaded by another call to Save.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCVpnNetworkConfiguration


FPCVpnNetworkIPSecSettings object [ISA Server 2004]

FPCVpnNetworkIPSecSettings

The FPCVpnNetworkIPSecSettings object defines the Internet Protocol security (IPSec) settings for site-to-site virtual private network (VPN) connections.

The FPCVpnNetworkIPSecSettings object can be accessed through the IPSecSettings property of an FPCVpnNetworkConfiguration object when the NetworkConnectionType property of the containing FPCNetwork object is set to fpcIPSecConnection.

Click here to see the ISA Server object hierarchy.

Methods

The FPCVpnNetworkIPSecSettings object defines the following methods.

Method | Description
Refresh | Reads the values of all of the object's properties from persistent storage, discarding any changes that have not been saved.
Save | Writes the current values of all of the object's properties to persistent storage.

Properties

The FPCVpnNetworkIPSecSettings object has the following properties.

Property | Description
AuthenticationMethod | Gets or sets a value from the FpcVpnAuthenticationMethod enumerated type that specifies which IPSec authentication method is to be used.
CertificateAuthority | Gets or sets the name of the certification authority (CA) for the certificates used for IPSec authentication.
LocalServerAddress | Gets or sets the name or IP address of the local VPN tunnel endpoint.
Phase1DHGroup | Gets or sets a value from the FpcVpnDiffieHellmanGroup enumerated type that specifies the Diffie-Hellman group to be used in Phase 1 of the IPSec negotiation process.
Phase1Encryption | Gets or sets a value from the FpcVpnEncryptionAlgorithm enumerated type that specifies the encryption algorithm to be used in Phase 1 of the IPSec negotiation process.
Phase1Integrity | Gets or sets a value from the FpcVpnIntegrityAlgorithm enumerated type that specifies the integrity algorithm to be used in Phase 1 of the IPSec negotiation process.
Phase1RekeyingTime | Gets or sets the Phase 1 rekeying time, in seconds.
Phase2DHGroup | Gets or sets a value from the FpcVpnDiffieHellmanGroup enumerated type that specifies the Diffie-Hellman group to be used in Phase 2 of the IPSec negotiation process.
Phase2Encryption | Gets or sets a value from the FpcVpnEncryptionAlgorithm enumerated type that specifies the encryption algorithm to be used in Phase 2 of the IPSec negotiation process.
Phase2Integrity | Gets or sets a value from the FpcVpnIntegrityAlgorithm enumerated type that specifies the integrity algorithm to be used in Phase 2 of the IPSec negotiation process.
Phase2KBRekeying | Gets or sets the amount of data transferred before Phase 2 rekeying, in kilobytes (KB).
Phase2RekeyingTime | Gets or sets the Phase 2 rekeying time, in seconds.
Phase2UseKBRekeying | Gets or sets a Boolean value that indicates whether Phase 2 KB rekeying is to be used.
Phase2UsePFS | Gets or sets a Boolean value that indicates whether Perfect Forward Secrecy (PFS) is to be used for Phase 2.
Phase2UseTimeRekeying | Gets or sets a Boolean value that indicates whether Phase 2 time-based rekeying is to be used.
PresharedKey | Gets or sets the preshared key for IPSec authentication.
RemoteServerAddress | Gets or sets the name or IP address of the remote VPN tunnel endpoint.

Remarks

This object implements the IFPCVpnNetworkIPSecSettings interface.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

COM Objects


IFPCVpnNetworkIPSecSettings.AuthenticationMethod property [ISA Server 2004]

AuthenticationMethod Property of IFPCVpnNetworkIPSecSettings[C++]

FPCVpnNetworkIPSecSettings.AuthenticationMethod [Visual Basic]

[C++]

The AuthenticationMethod property gets or sets a value from the FpcVpnAuthenticationMethod enumerated type that specifies which IPSec authentication method is to be used.

HRESULT get_AuthenticationMethod(
  FpcVpnAuthenticationMethod* pAuthenticationMethod
);

HRESULT put_AuthenticationMethod(
  FpcVpnAuthenticationMethod AuthenticationMethod
);

Parameters

pAuthenticationMethod
Pointer to a value from the FpcVpnAuthenticationMethod enumerated type that is set on return to the value specifying the IPSec authentication method to be used.
AuthenticationMethod
Value from the FpcVpnAuthenticationMethod enumerated type that specifies which IPSec authentication method is to be used.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write. Its default value is fpcVpnCertificate, which specifies IPSec authentication using a certificate.

[Visual Basic]

The AuthenticationMethod property gets or sets a value from the FpcVpnAuthenticationMethod enumerated type that specifies which IPSec authentication method is to be used.

Property AuthenticationMethod As FpcVpnAuthenticationMethod

Property Value

Value from the FpcVpnAuthenticationMethod enumerated type that specifies which IPSec authentication method is to be used.

Remarks

This property is read/write. Its default value is fpcVpnCertificate, which specifies IPSec authentication using a certificate.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCVpnNetworkIPSecSettings


IFPCVpnNetworkIPSecSettings.CertificateAuthority property [ISA Server 2004]

CertificateAuthority Property of IFPCVpnNetworkIPSecSettings[C++]

FPCVpnNetworkIPSecSettings.CertificateAuthority [Visual Basic]

[C++]

The CertificateAuthority property gets or sets the name of the certification authority (CA) for the certificates used for IPSec authentication.

HRESULT get_CertificateAuthority(
  BSTR* pbstrRemoteServer
);

HRESULT put_CertificateAuthority(
  BSTR bstrRemoteServer
);

Parameters

pbstrRemoteServer
Pointer to a BSTR that is set on return to a string value specifying the name of the certification authority (CA) for the certificates used for IPSec authentication.
bstrRemoteServer
BSTR that specifies the name of the certification authority (CA) for the certificates used for IPSec authentication.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write.

[Visual Basic]

The CertificateAuthority property gets or sets the name of the certification authority (CA) for the certificates used for IPSec authentication.

Property CertificateAuthority As String

Property Value

String that specifies the name of the certification authority (CA) for the certificates used for IPSec authentication.

Remarks

This property is read/write.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCVpnNetworkIPSecSettings


IFPCVpnNetworkIPSecSettings.LocalServerAddress property [ISA Server 2004]

LocalServerAddress Property of IFPCVpnNetworkIPSecSettings[C++]

FPCVpnNetworkIPSecSettings.LocalServerAddress [Visual Basic]

[C++]

The LocalServerAddress property gets or sets the name or IP address of the local VPN tunnel endpoint.

HRESULT get_LocalServerAddress(
  BSTR* pbstrLocalServer
);

HRESULT put_LocalServerAddress(
  BSTR bstrLocalServer
);

Parameters

pbstrLocalServer
Pointer to a BSTR that is set on return to a string value specifying the name or IP address of the local VPN tunnel endpoint.
bstrLocalServer
BSTR that specifies the name or IP address of the local VPN tunnel endpoint.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write.

[Visual Basic]

The LocalServerAddress property gets or sets the name or IP address of the local VPN tunnel endpoint.

Property LocalServerAddress As String

Property Value

String that specifies the name or IP address of the local virtual private network (VPN) tunnel endpoint.

Remarks

This property is read/write.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCVpnNetworkIPSecSettings


IFPCVpnNetworkIPSecSettings.Phase1DHGroup property [ISA Server 2004]

Phase1DHGroup Property of IFPCVpnNetworkIPSecSettings[C++]

FPCVpnNetworkIPSecSettings.Phase1DHGroup [Visual Basic]

[C++]

The Phase1DHGroup property gets or sets a value from the FpcVpnDiffieHellmanGroup enumerated type that specifies the Diffie-Hellman group to be used in Phase 1 of the IPSec negotiation process.

HRESULT get_Phase1DHGroup(
  FpcVpnDiffieHellmanGroup* pPhase1DHGroup
);

HRESULT put_Phase1DHGroup(
  FpcVpnDiffieHellmanGroup Phase1DHGroup
);

Parameters

pPhase1DHGroup
Pointer to a value from the FpcVpnDiffieHellmanGroup enumerated type that is set on return to the value specifying the Diffie-Hellman group to be used in Phase 1 of the IPSec negotiation process.
Phase1DHGroup
Value from the FpcVpnDiffieHellmanGroup enumerated type that specifies the Diffie-Hellman group to be used in Phase 1 of the IPSec negotiation process.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write. Its default value is fpcVpnDHGroup2, which specifies Diffie-Hellman Group 2.

The Diffie-Hellman group sets the length of the base prime numbers used during the key exchange process. The cryptographic strength of any key derived depends, in part, on this length.

The value fpcVpnDHGroup2048, which specifies Diffie-Hellman Group 2048, is not supported on computers running a Windows 2000 Server operating system.

[Visual Basic]

The Phase1DHGroup property gets or sets a value from the FpcVpnDiffieHellmanGroup enumerated type that specifies the Diffie-Hellman group to be used in Phase 1 of the IPSec negotiation process.

Property Phase1DHGroup As FpcVpnDiffieHellmanGroup

Property Value

Value from the FpcVpnDiffieHellmanGroup enumerated type that specifies the Diffie-Hellman group to be used in Phase 1 of the IPSec negotiation process.

Remarks

This property is read/write. Its default value is fpcVpnDHGroup2, which specifies Diffie-Hellman Group 2.

The Diffie-Hellman group sets the length of the base prime numbers used during the key exchange process. The cryptographic strength of any key derived depends, in part, on this length.

The value fpcVpnDHGroup2048, which specifies Diffie-Hellman Group 2048, is not supported on computers running a Windows 2000 Server operating system.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCVpnNetworkIPSecSettings


IFPCVpnNetworkIPSecSettings.Phase1Encryption property [ISA Server 2004]

Phase1Encryption Property of IFPCVpnNetworkIPSecSettings[C++]

FPCVpnNetworkIPSecSettings.Phase1Encryption [Visual Basic]

[C++]

The Phase1Encryption property gets or sets a value from the FpcVpnEncryptionAlgorithm enumerated type that specifies the encryption algorithm to be used in Phase 1 of the IPSec negotiation process. The possible algorithms are the Data Encryption Standard (DES) algorithm, which uses a 56-bit key, and the Triple Data Encryption Standard (3DES) algorithm, which uses three 56-bit keys.

HRESULT get_Phase1Encryption(
  FpcVpnEncryptionAlgorithm* pPhase1Encryption
);

HRESULT put_Phase1Encryption(
  FpcVpnEncryptionAlgorithm Phase1Encryption
);

Parameters

pPhase1Encryption
Pointer to a value from the FpcVpnEncryptionAlgorithm enumerated type that is set on return to the value specifying the encryption algorithm to be used in Phase 1 of the IPSec negotiation process.
Phase1Encryption
Value from the FpcVpnEncryptionAlgorithm enumerated type that specifies the encryption algorithm to be used in Phase 1 of the IPSec negotiation process.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write. Its default value is fpcVpn3DES, which specifies the 3DES algorithm.

[Visual Basic]

The Phase1Encryption property gets or sets a value from the FpcVpnEncryptionAlgorithm enumerated type that specifies the encryption algorithm to be used in Phase 1 of the IPSec negotiation process. The possible algorithms are the Data Encryption Standard (DES) algorithm, which uses a 56-bit key, and the Triple Data Encryption Standard (3DES) algorithm, which uses three 56-bit keys.

Property Phase1Encryption As FpcVpnEncryptionAlgorithm

Property Value

Value from the FpcVpnEncryptionAlgorithm enumerated type that specifies the encryption algorithm to be used in Phase 1 of the IPSec negotiation process.

Remarks

This property is read/write. Its default value is fpcVpn3DES, which specifies the 3DES algorithm.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCVpnNetworkIPSecSettings


IFPCVpnNetworkIPSecSettings.Phase1Integrity property [ISA Server 2004]

Phase1Integrity Property of IFPCVpnNetworkIPSecSettings[C++]

FPCVpnNetworkIPSecSettings.Phase1Integrity [Visual Basic]

[C++]

The Phase1Integrity property gets or sets a value from the FpcVpnIntegrityAlgorithm enumerated type that specifies the integrity algorithm to be used in Phase 1 of the IPSec negotiation process. The possible algorithms are the Message Digest 5 (MD5) integrity algorithm, which uses a 128-bit key, and the Secure Hash Algorithm 1 (SHA1) integrity algorithm, which uses a 160-bit key.

HRESULT get_Phase1Integrity(
  FpcVpnIntegrityAlgorithm* pPhase1Integrity
);

HRESULT put_Phase1Integrity(
  FpcVpnIntegrityAlgorithm Phase1Integrity
);

Parameters

pPhase1Integrity
Pointer to a value from the FpcVpnIntegrityAlgorithm enumerated type that is set on return to the value specifying the integrity algorithm to be used in Phase 1 of the IPSec negotiation process.
Phase1Integrity
Value from the FpcVpnIntegrityAlgorithm enumerated type that specifies the integrity algorithm to be used in Phase 1 of the IPSec negotiation process.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write. Its default value is fpcVpnSHA1, which specifies the SHA1 integrity algorithm.

[Visual Basic]

The Phase1Integrity property gets or sets a value from the FpcVpnIntegrityAlgorithm enumerated type that specifies the integrity algorithm to be used in Phase 1 of the IPSec negotiation process. The possible algorithms are the Message Digest 5 (MD5) integrity algorithm, which uses a 128-bit key, and the Secure Hash Algorithm 1 (SHA1) integrity algorithm, which uses a 160-bit key.

Property Phase1Integrity As FpcVpnIntegrityAlgorithm

Property Value

Value from the FpcVpnIntegrityAlgorithm enumerated type that specifies the integrity algorithm to be used in Phase 1 of the IPSec negotiation process.

Remarks

This property is read/write. Its default value is fpcVpnSHA1, which specifies the SHA1 integrity algorithm.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCVpnNetworkIPSecSettings


IFPCVpnNetworkIPSecSettings.Phase1RekeyingTime property [ISA Server 2004]

Phase1RekeyingTime Property of IFPCVpnNetworkIPSecSettings[C++]

FPCVpnNetworkIPSecSettings.Phase1RekeyingTime [Visual Basic]

[C++]

The Phase1RekeyingTime property gets or sets the Phase 1 rekeying time, in seconds.

HRESULT get_Phase1RekeyingTime(
  long* plPhase1RekeyingTime
);

HRESULT put_Phase1RekeyingTime(
  long lPhase1RekeyingTime
);

Parameters

plPhase1RekeyingTime
Pointer to a 32-bit integer that is set on return to a long value specifying the Phase 1 rekeying time, in seconds.
lPhase1RekeyingTime
A 32-bit integer value that specifies the Phase 1 rekeying time, in seconds.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write. Its default value is 28,880 seconds (8 hours).

[Visual Basic]

The Phase1RekeyingTime property gets or sets the Phase 1 rekeying time, in seconds.

Property Phase1RekeyingTime As Long

Property Value

A 32-bit integer value that specifies the Phase 1 rekeying time, in seconds.

Remarks

This property is read/write. Its default value is 28,880 seconds (8 hours).

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCVpnNetworkIPSecSettings


IFPCVpnNetworkIPSecSettings.Phase2DHGroup property [ISA Server 2004]

Phase2DHGroup Property of IFPCVpnNetworkIPSecSettings[C++]

FPCVpnNetworkIPSecSettings.Phase2DHGroup [Visual Basic]

[C++]

The Phase2DHGroup property gets or sets a value from the FpcVpnDiffieHellmanGroup enumerated type that specifies the Diffie-Hellman group to be used in Phase 2 of the IPSec negotiation process.

HRESULT get_Phase2DHGroup(
  FpcVpnDiffieHellmanGroup* pPhase2DHGroup
);

HRESULT put_Phase2DHGroup(
  FpcVpnDiffieHellmanGroup Phase2DHGroup
);

Parameters

pPhase2DHGroup
Pointer to a value from the FpcVpnDiffieHellmanGroup enumerated type that is set on return to the value specifying the Diffie-Hellman group to be used in Phase 2 of the IPSec negotiation process.
Phase2DHGroup
Value from the FpcVpnDiffieHellmanGroup enumerated type that specifies the Diffie-Hellman group to be used in Phase 2 of the IPSec negotiation process.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write. Its default value is fpcVpnDHGroup2, which specifies Diffie-Hellman Group 2. On computers running a Windows 2000 Server operating system, the value of this property is always the same as the value of the Phase1DHGroup property.

The Diffie-Hellman group sets the length of the base prime numbers used during the key exchange process. The cryptographic strength of any key derived depends, in part, on this length.

[Visual Basic]

The Phase2DHGroup property gets or sets a value from the FpcVpnDiffieHellmanGroup enumerated type that specifies the Diffie-Hellman group to be used in Phase 2 of the IPSec negotiation process.

Property Phase2DHGroup As FpcVpnDiffieHellmanGroup

Property Value

Value from the FpcVpnDiffieHellmanGroup enumerated type that specifies the Diffie-Hellman group to be used in Phase 2 of the IPSec negotiation process.

Remarks

This property is read/write. Its default value is fpcVpnDHGroup2, which specifies Diffie-Hellman Group 2. On computers running a Windows 2000 Server operating system, the value of this property is always the same as the value of the Phase1DHGroup property.

The Diffie-Hellman group sets the length of the base prime numbers used during the key exchange process. The cryptographic strength of any key derived depends, in part, on this length.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCVpnNetworkIPSecSettings


IFPCVpnNetworkIPSecSettings.Phase2Encryption property [ISA Server 2004]

Phase2Encryption Property of IFPCVpnNetworkIPSecSettings[C++]

FPCVpnNetworkIPSecSettings.Phase2Encryption [Visual Basic]

[C++]

The Phase2Encryption property gets or sets a value from the FpcVpnEncryptionAlgorithm enumerated type that specifies the encryption algorithm to be used in Phase 2 of the IPSec negotiation process. The possible algorithms are the Data Encryption Standard (DES) algorithm, which uses a 56-bit key, and the Triple Data Encryption Standard (3DES) algorithm, which uses three 56-bit keys.

HRESULT get_Phase2Encryption(
  FpcVpnEncryptionAlgorithm* pPhase2Encryption
);

HRESULT put_Phase2Encryption(
  FpcVpnEncryptionAlgorithm Phase2Encryption
);

Parameters

pPhase2Encryption
Pointer to a value from the FpcVpnEncryptionAlgorithm enumerated type that is set on return to the value specifying the encryption algorithm to be used in Phase 2 of the IPSec negotiation process.
Phase2Encryption
Value from the FpcVpnEncryptionAlgorithm enumerated type that specifies the encryption algorithm to be used in Phase 2 of the IPSec negotiation process.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write. Its default value is fpcVpn3DES, which specifies the 3DES algorithm.

[Visual Basic]

The Phase2Encryption property gets or sets a value from the FpcVpnEncryptionAlgorithm enumerated type that specifies the encryption algorithm to be used in Phase 2 of the IPSec negotiation process. The possible algorithms are the Data Encryption Standard (DES) algorithm, which uses a 56-bit key, and the Triple Data Encryption Standard (3DES) algorithm, which uses three 56-bit keys.

Property Phase2Encryption As FpcVpnEncryptionAlgorithm

Property Value

Value from the FpcVpnEncryptionAlgorithm enumerated type that specifies the encryption algorithm to be used in Phase 2 of the IPSec negotiation process.

Remarks

This property is read/write. Its default value is fpcVpn3DES, which specifies the 3DES algorithm.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCVpnNetworkIPSecSettings


IFPCVpnNetworkIPSecSettings.Phase2Integrity property [ISA Server 2004]

Phase2Integrity Property of IFPCVpnNetworkIPSecSettings[C++]

FPCVpnNetworkIPSecSettings.Phase2Integrity [Visual Basic]

[C++]

The Phase2Integrity property gets or sets a value from the FpcVpnIntegrityAlgorithm enumerated type that specifies the integrity algorithm to be used in Phase 2 of the IPSec negotiation process. The possible algorithms are the Message Digest 5 (MD5) integrity algorithm, which uses a 128-bit key, and the Secure Hash Algorithm 1 (SHA1) integrity algorithm, which uses a 160-bit key.

HRESULT get_Phase2Integrity(
  FpcVpnIntegrityAlgorithm* pPhase2Integrity
);

HRESULT put_Phase2Integrity(
  FpcVpnIntegrityAlgorithm Phase2Integrity
);

Parameters

pPhase2Integrity
Pointer to a value from the FpcVpnIntegrityAlgorithm enumerated type that is set on return to the value specifying the integrity algorithm to be used in Phase 2 of the IPSec negotiation process.
Phase2Integrity
Value from the FpcVpnIntegrityAlgorithm enumerated type that specifies the integrity algorithm to be used in Phase 2 of the IPSec negotiation process.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write. Its default value is fpcVpnSHA1, which specifies the SHA1 integrity algorithm.

[Visual Basic]

The Phase2Integrity property gets or sets a value from the FpcVpnIntegrityAlgorithm enumerated type that specifies the integrity algorithm to be used in Phase 2 of the IPSec negotiation process. The possible algorithms are the Message Digest 5 (MD5) integrity algorithm, which uses a 128-bit key, and the Secure Hash Algorithm 1 (SHA1) integrity algorithm, which uses a 160-bit key.

Property Phase2Integrity As FpcVpnIntegrityAlgorithm

Property Value

Value from the FpcVpnIntegrityAlgorithm enumerated type that specifies the integrity algorithm to be used in Phase 2 of the IPSec negotiation process.

Remarks

This property is read/write. Its default value is fpcVpnSHA1, which specifies the SHA1 integrity algorithm.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCVpnNetworkIPSecSettings


IFPCVpnNetworkIPSecSettings.Phase2KBRekeying property [ISA Server 2004]

Phase2KBRekeying Property of IFPCVpnNetworkIPSecSettings[C++]

FPCVpnNetworkIPSecSettings.Phase2KBRekeying [Visual Basic]

[C++]

The Phase2KBRekeying property gets or sets the amount of data transferred before Phase 2 rekeying, in kilobytes (KB).

HRESULT get_Phase2KBRekeying(
  long* plPhase2KBRekeying
);

HRESULT put_Phase2KBRekeying(
  long lPhase2KBRekeying
);

Parameters

plPhase2KBRekeying
Pointer to a 32-bit integer that is set on return to a long value specifying the amount of data transferred before Phase 2 rekeying, in kilobytes.
lPhase2KBRekeying
A 32-bit integer value that specifies the amount of data transferred before Phase 2 rekeying, in kilobytes.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write. Its default value is 100,000 kilobytes.

Phase 2 rekeying based on the amount of data transferred occurs only if the Phase2UseKBRekeying property is set to VARIANT_TRUE.

[Visual Basic]

The Phase2KBRekeying property gets or sets the amount of data transferred before Phase 2 rekeying, in kilobytes (KB).

Property Phase2KBRekeying As Long

Property Value

A 32-bit integer value that specifies the amount of data transferred before Phase 2 rekeying, in kilobytes.

Remarks

This property is read/write. Its default value is 100,000 kilobytes.

Phase 2 rekeying based on the amount of data transferred occurs only if the Phase2UseKBRekeying property is set to True.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCVpnNetworkIPSecSettings


IFPCVpnNetworkIPSecSettings.Phase2RekeyingTime property [ISA Server 2004]

Phase2RekeyingTime Property of IFPCVpnNetworkIPSecSettings[C++]

FPCVpnNetworkIPSecSettings.Phase2RekeyingTime [Visual Basic]

[C++]

The Phase2RekeyingTime property gets or sets the Phase 2 rekeying time, in seconds.

HRESULT get_Phase2RekeyingTime(
  long* plPhase2RekeyingTime
);

HRESULT put_Phase2RekeyingTime(
  long lPhase2RekeyingTime
);

Parameters

plPhase2RekeyingTime
Pointer to a 32-bit integer that is set on return to a long value specifying the Phase 2 rekeying time, in seconds.
lPhase2RekeyingTime
A 32-bit integer value that specifies the Phase 2 rekeying time, in seconds.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write. Its default value is 3,600 seconds (1 hour).

[Visual Basic]

The Phase2RekeyingTime property gets or sets the Phase 2 rekeying time, in seconds.

Property Phase2RekeyingTime As Long

Property Value

A 32-bit integer value that specifies the Phase 2 rekeying time, in seconds.

Remarks

This property is read/write. Its default value is 3,600 seconds (1 hour).

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCVpnNetworkIPSecSettings


IFPCVpnNetworkIPSecSettings.Phase2UseKBRekeying property [ISA Server 2004]

Phase2UseKBRekeying Property of IFPCVpnNetworkIPSecSettings[C++]

FPCVpnNetworkIPSecSettings.Phase2UseKBRekeying [Visual Basic]

[C++]

The Phase2UseKBRekeying property gets or sets a Boolean value that indicates whether Phase 2 kilobyte (KB) rekeying is to be used.

HRESULT get_Phase2UseKBRekeying(
  VARIANT_BOOL* pfPhase2UseKBRekeying
);

HRESULT put_Phase2UseKBRekeying(
  VARIANT_BOOL fPhase2UseKBRekeying
);

Parameters

pfPhase2UseKBRekeying
Pointer to a Boolean variable that is set on return to VARIANT_TRUE if Phase 2 KB rekeying is to be used, or to VARIANT_FALSE if Phase 2 KB rekeying is not to be used.
fPhase2UseKBRekeying
Boolean value that specifies whether Phase 2 KB rekeying is to be used.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write. Its default value is VARIANT_FALSE.

If this property is set to VARIANT_TRUE, Phase 2 rekeying will occur after the amount of data specified in the Phase2KBRekeying property is transferred.

[Visual Basic]

The Phase2UseKBRekeying property gets or sets a Boolean value that indicates whether Phase 2 kilobyte (KB) rekeying is to be used.

Property Phase2UseKBRekeying As Boolean

Property Value

Boolean value that indicates whether Phase 2 KB rekeying is to be used.

Remarks

This property is read/write. Its default value is False.

If this property is set to True, Phase 2 rekeying will occur after the amount of data specified in the Phase2KBRekeying property is transferred.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCVpnNetworkIPSecSettings


IFPCVpnNetworkIPSecSettings.Phase2UsePFS property [ISA Server 2004]

Phase2UsePFS Property of IFPCVpnNetworkIPSecSettings[C++]

FPCVpnNetworkIPSecSettings.Phase2UsePFS [Visual Basic]

[C++]

The Phase2UsePFS property gets or sets a Boolean value that indicates whether Perfect Forward Secrecy (PFS) is to be used for Phase 2.

HRESULT get_Phase2UsePFS(
  VARIANT_BOOL* pfPhase2UsePFS
);

HRESULT put_Phase2UsePFS(
  VARIANT_BOOL fPhase2UsePFS
);

Parameters

pfPhase2UsePFS
Pointer to a Boolean variable that is set on return to VARIANT_TRUE if PFS is to be used for Phase 2, or to VARIANT_FALSE if PFS is not to be used for Phase 2.
fPhase2UsePFS
Boolean value that specifies whether PFS is to be used for Phase 2.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write.

[Visual Basic]

The Phase2UsePFS property gets or sets a Boolean value that indicates whether Perfect Forward Secrecy (PFS) is to be used for Phase 2.

Property Phase2UsePFS As Boolean

Property Value

Boolean value that indicates whether PFS is to be used for Phase 2.

Remarks

This property is read/write.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCVpnNetworkIPSecSettings


IFPCVpnNetworkIPSecSettings.Phase2UseTimeRekeying property [ISA Server 2004]

Phase2UseTimeRekeying Property of IFPCVpnNetworkIPSecSettings[C++]

FPCVpnNetworkIPSecSettings.Phase2UseTimeRekeying [Visual Basic]

[C++]

The Phase2UseTimeRekeying property gets or sets a Boolean value that indicates whether Phase 2 time-based rekeying is to be used.

HRESULT get_Phase2UseTimeRekeying(
  VARIANT_BOOL* pfPhase2UseTimeRekeying
);

HRESULT put_Phase2UseTimeRekeying(
  VARIANT_BOOL fPhase2UseTimeRekeying
);

Parameters

pfPhase2UseTimeRekeying
Pointer to a Boolean variable that is set on return to VARIANT_TRUE if Phase 2 time-based rekeying is to be used, or to VARIANT_FALSE if Phase 2 time-based rekeying is not to be used.
fPhase2UseTimeRekeying
Boolean value that specifies whether Phase 2 time-based rekeying is to be used.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write. Its default value is VARIANT_TRUE.

If this property is set to VARIANT_TRUE, Phase 2 rekeying will occur after the time specified in the Phase2RekeyingTime property elapses.

[Visual Basic]

The Phase2UseTimeRekeying property gets or sets a Boolean value that indicates whether Phase 2 time-based rekeying is to be used.

Property Phase2UseTimeRekeying As Boolean

Property Value

Boolean value that indicates whether Phase 2 time-based rekeying is to be used.

Remarks

This property is read/write. Its default value is True.

If this property is set to True, Phase 2 rekeying will occur after the time specified in the Phase2RekeyingTime property elapses.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCVpnNetworkIPSecSettings


IFPCVpnNetworkIPSecSettings.PresharedKey(BSTR,BSTR) property [ISA Server 2004]

PresharedKey Property of IFPCVpnNetworkIPSecSettings[C++]

FPCVpnNetworkIPSecSettings.PresharedKey [Visual Basic]

[C++]

The PresharedKey property gets or sets the preshared key for IPSec authentication. A preshared key is a string of text that is configured on both the VPN client and the VPN server. A preshared key provides a relatively weak authentication method. We therefore recommend that you use it only in the interim when your public key infrastructure (PKI) is being deployed to obtain computer certificates, or when a preshared key is required by VPN clients.

HRESULT get_PresharedKey(
  BSTR* pbstrPresharedKey
);

HRESULT put_PresharedKey(
  BSTR bstrPresharedKey
);

Parameters

pbstrPresharedKey
Pointer to a BSTR that is set on return to a string value specifying the name or IP address of the remote site.
bstrPresharedKey
BSTR that specifies the preshared key for L2TP connections.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write.

[Visual Basic]

The PresharedKey property gets or sets the preshared key for IPSec authentication. A preshared key is a string of text that is configured on both the VPN client and the VPN server. A preshared key provides a relatively weak authentication method. We therefore recommend that you use it only in the interim when your public key infrastructure (PKI) is being deployed to obtain computer certificates, or when a preshared key is required by VPN clients.

Property PresharedKey As String

Property Value

String that specifies the preshared key for IPSec authentication.

Remarks

This property is read/write.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCVpnNetworkIPSecSettings


IFPCVpnNetworkIPSecSettings.Refresh method [ISA Server 2004]

IFPCVpnNetworkIPSecSettings::Refresh[C++]

FPCVpnNetworkIPSecSettings.Refresh [Visual Basic]

[C++]

The Refresh method reads the values of all of the object's properties from persistent storage, discarding any changes that have not been saved.

HRESULT Refresh();

Parameters

This method has no parameters.

Return Values

This method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

Changes made to this object can be saved by calling the Save method of this object or the Save method of any object containing it.

[Visual Basic]

The Refresh method reads the values of all of the object's properties from persistent storage, discarding any changes that have not been saved.

Sub Refresh()

Parameters

This method has no parameters.

Return Values

This method has no return values. If the call is unsuccessful, an error is raised that can be intercepted by using an error handler.

Remarks

Changes made to this object can be saved by calling the Save method of this object or the Save method of any object containing it.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCVpnNetworkIPSecSettings


IFPCVpnNetworkIPSecSettings.RemoteServerAddress property [ISA Server 2004]

RemoteServerAddress Property of IFPCVpnNetworkIPSecSettings[C++]

FPCVpnNetworkIPSecSettings.RemoteServerAddress [Visual Basic]

[C++]

The RemoteServerAddress property gets or sets the name or IP address of the remote VPN tunnel endpoint.

HRESULT get_RemoteServerAddress(
  BSTR* pbstrRemoteServer
);

HRESULT put_RemoteServerAddress(
  BSTR bstrRemoteServer
);

Parameters

pbstrRemoteServer
Pointer to a BSTR that is set on return to a string value specifying the name or IP address of the remote VPN tunnel endpoint.
bstrRemoteServer
BSTR that specifies the name or IP address of the remote VPN tunnel endpoint.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write.

[Visual Basic]

The RemoteServerAddress property gets or sets the name or IP address of the remote VPN tunnel endpoint.

Property RemoteServerAddress As String

Property Value

String that specifies the name or IP address of the remote VPN tunnel endpoint.

Remarks

This property is read/write.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCVpnNetworkIPSecSettings


IFPCVpnNetworkIPSecSettings.Save (2 Parameters) method [ISA Server 2004]

IFPCVpnNetworkIPSecSettings::Save[C++]

FPCVpnNetworkIPSecSettings.Save [Visual Basic]

[C++]

The Save method writes the current values of all of the object's properties to persistent storage. It is important to remember that any changes made by scripts and programs are not saved until after the Save method is called.

HRESULT Save(
  VARIANT_BOOL fResetRequiredServices,
  VARIANT_BOOL fReloadConfiguration
);

Parameters

fResetRequiredServices
[in, optional] Boolean value that indicates whether to restart the services that need to be restarted for any of the changes saved to take effect. The default value is VARIANT_FALSE.
fReloadConfiguration
[in, optional] Boolean value that indicates whether the call will include synchronous reloading of all changes that can be applied dynamically without restarting services. The default value is VARIANT_TRUE.

Return Values

This method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

Configuration changes are applied only after the new settings are written to persistent storage and reloaded to the services that use them. Most changes can be applied dynamically without restarting any services. However, some changes can take effect only after the Microsoft Firewall service is restarted. For more information, see Restarting Services after Configuration Changes.

ISA Server maintains a bitmask that specifies which services need to be started for currently unsaved changes to take effect. This bitmask can be retrieved by calling the GetServiceRestartMask method on an object that contains this object as a subobject. Calling the Save method clears all of the bits in this bitmask even if the fResetRequiredServices parameter is set to VARIANT_FALSE.

If the fReloadConfiguration parameter is set to VARIANT_FALSE the current values of the object's properties will be written to persistent storage without updating the configuration being used by the ISA Server services. The configuration used by each service will not be updated until the service is restarted or the new settings are reloaded by another call to Save.

[Visual Basic]

The Save method writes the current values of all of the object's properties to persistent storage. It is important to remember that any changes made by scripts and programs are not saved until after the Save method is called.

Sub Save( _
  [ ByVal fResetRequiredServices As Boolean ], _
  [ ByVal fReloadConfiguration As Boolean ] _
)

Parameters

fResetRequiredServices
[in, optional] Boolean value that indicates whether to restart the services that need to be restarted for any of the changes saved to take effect. The default value is False.
fReloadConfiguration
[in, optional] Boolean value that indicates whether the call will include synchronous reloading of all the saved configuration changes that can be applied dynamically without restarting services. The default value is True.

Return Values

This method has no return values. If the call is unsuccessful, an error is raised that can be intercepted by using an error handler.

Remarks

Configuration changes are applied only after the new settings are written to persistent storage and reloaded to the services that use them. Most changes can be applied dynamically without restarting any services. However, some changes can take effect only after the Microsoft Firewall service is restarted. For more information, see Restarting Services after Configuration Changes.

ISA Server maintains a bitmask that specifies which services need to be started for currently unsaved changes to take effect. This bitmask can be retrieved by calling the GetServiceRestartMask method on an object that contains this object as a subobject. Calling the Save method clears all of the bits in this bitmask even if the fResetRequiredServices parameter is set to False.

If the fReloadConfiguration parameter is set to False the current values of the object's properties will be written to persistent storage without updating the configuration being used by the ISA Server services. The configuration used by each service will not be updated until the service is restarted or the new settings are reloaded by another call to Save.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCVpnNetworkIPSecSettings


FPCVpnNetworkL2tpPptpSettings object [ISA Server 2004]

FPCVpnNetworkL2tpPptpSettings

The FPCVpnNetworkL2tpPptpSettings object defines the Layer Two Tunneling Protocol (L2TP) or Point-to-Point Tunneling Protocol (PPTP) settings for site-to-site virtual private network (VPN) connections.

When the L2TP or PPTP protocol is used for site-to-site VPN connections, in addition to configuring the properties of this object, you must configure a default gateway for the local ISA Server computer. When no default gateway is defined, traffic from the VPN gateway in the remote site is denied.

The FPCVpnNetworkL2tpPptpSettings object can be accessed through the L2tpPptpSettings property of an FPCVpnNetworkConfiguration object when the NetworkConnectionType property of the containing FPCNetwork object is set to fpcVPNConnection.

Click here to see the ISA Server object hierarchy.

Methods

The FPCVpnNetworkL2tpPptpSettings object defines the following methods.

Method | Description
Refresh | Recursively reads the values of all of the object's properties from persistent storage, discarding any changes that have not been saved.
Save | Recursively writes the current values of all of the object's properties to persistent storage.

Properties

The FPCVpnNetworkL2tpPptpSettings object has the following properties.

Property | Description
AllowOutgoingConnection | Gets or sets a Boolean value that indicates whether the local site can initiate a connection to the remote site.
EnableCHAP | Gets or sets a Boolean value that indicates whether the Challenge Handshake Authentication Protocol (CHAP) can be used for outgoing authentication.
EnableEAP | Gets or sets a Boolean value that indicates whether the Extensible Authentication Protocol (EAP) can be used for outgoing authentication.
EnableMSCHAP | Gets or sets a Boolean value that indicates whether the Microsoft Challenge Handshake Authentication Protocol version 1 (MS-CHAP) can be used for outgoing authentication.
EnableMSCHAPv2 | Gets or sets a Boolean value that indicates whether the Microsoft Challenge Handshake Authentication Protocol version 2 (MS-CHAP v2) can be used for outgoing authentication.
EnablePAP | Gets or sets a Boolean value that indicates whether the Password Authentication Protocol (PAP) can be used for outgoing authentication.
EnableShivaPAP | Gets or sets a Boolean value that indicates whether the Shiva Password Authentication Protocol (SPAP) can be used for outgoing authentication.
IdleDisconnectTime | Gets or sets the time, in seconds, after which an inactive connection is closed.
PresharedKey | Gets or sets the preshared key for L2TP connections.
Protocol | Gets or sets a value from the FpcVpnProtocol enumerated type that specifies which VPN protocol is to be used.
RemoteCredentials | Gets an FPCCredentials object that specifies the user name, including the domain name, and the password that are presented to the remote site for authentication.
RemoteServerAddress | Gets or sets the name or IP address of the remote site.
UseIdleDisconnectTime | Gets or sets a Boolean value that indicates whether an inactive connection will be closed after the time specified in the IdleDisconnectTime property elapses.
UsePresharedKey | Gets or sets a Boolean value that indicates whether a preshared key is to be used for authenticating L2TP connections.

Remarks

This object implements the IFPCVpnNetworkL2tpPptpSettings interface.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

COM Objects


AllowOutgoingConnection property [ISA Server 2004]

AllowOutgoingConnection Property of IFPCVpnNetworkL2tpPptpSettings[C++]

FPCVpnNetworkL2tpPptpSettings.AllowOutgoingConnection [Visual Basic]

[C++]

The AllowOutgoingConnection property gets or sets a Boolean value that indicates whether the local site can initiate a connection to the remote site.

HRESULT get_AllowOutgoingConnection(
  VARIANT_BOOL* pfAllowOutgoingConnection
);

HRESULT put_AllowOutgoingConnection(
  VARIANT_BOOL fAllowOutgoingConnection
);

Parameters

pfAllowOutgoingConnection
Pointer to a Boolean variable that is set on return to VARIANT_TRUE if the local site can initiate a connection to the remote site, or to VARIANT_FALSE if the local site cannot initiate a connection to the remote site.
fAllowOutgoingConnection
Boolean value that specifies whether the local site can initiate a connection to the remote site.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write. Its default value is VARIANT_FALSE.

[Visual Basic]

The AllowOutgoingConnection property gets or sets a Boolean value that indicates whether the local site can initiate a connection to the remote site.

Property AllowOutgoingConnection As Boolean

Property Value

Boolean value that indicates whether the local site can initiate a connection to the remote site.

Remarks

This property is read/write. Its default value is False.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCVpnNetworkL2tpPptpSettings


IFPCVpnNetworkL2tpPptpSettings.EnableCHAP property [ISA Server 2004]

EnableCHAP Property of IFPCVpnNetworkL2tpPptpSettings[C++]

FPCVpnNetworkL2tpPptpSettings.EnableCHAP [Visual Basic]

[C++]

The EnableCHAP property gets or sets a Boolean value that indicates whether the Challenge Handshake Authentication Protocol (CHAP) can be used for outgoing authentication.

HRESULT get_EnableCHAP(
  VARIANT_BOOL* pfEnableCHAP
);

HRESULT put_EnableCHAP(
  VARIANT_BOOL fEnableCHAP
);

Parameters

pfEnableCHAP
Pointer to a Boolean variable that is set on return to VARIANT_TRUE if CHAP can be used for outgoing authentication, or to VARIANT_FALSE if CHAP can be used for outgoing authentication.
fEnableCHAP
Boolean value that specifies whether CHAP can be used for outgoing authentication.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write. Its default value is VARIANT_FALSE.

CHAP cannot be enabled together with the Extensible Authentication Protocol (EAP), but it can be enabled together with any combination of the other authentication protocols.

[Visual Basic]

The EnableCHAP property gets or sets a Boolean value that indicates whether the Challenge Handshake Authentication Protocol (CHAP) can be used for outgoing authentication.

Property EnableCHAP As Boolean

Property Value

Boolean value that indicates whether CHAP can be used for outgoing authentication.

Remarks

This property is read/write. Its default value is False.

CHAP cannot be enabled together with the Extensible Authentication Protocol (EAP), but it can be enabled together with any combination of the other authentication protocols.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCVpnNetworkL2tpPptpSettings


IFPCVpnNetworkL2tpPptpSettings.EnableEAP property [ISA Server 2004]

EnableEAP Property of IFPCVpnNetworkL2tpPptpSettings[C++]

FPCVpnNetworkL2tpPptpSettings.EnableEAP [Visual Basic]

[C++]

The EnableEAP property gets or sets a Boolean value that indicates whether the Extensible Authentication Protocol (EAP) can be used for outgoing authentication.

HRESULT get_EnableEAP(
  VARIANT_BOOL* pfEnableEAP
);

HRESULT put_EnableEAP(
  VARIANT_BOOL fEnableEAP
);

Parameters

pfEnableEAP
Pointer to a Boolean variable that is set on return to VARIANT_TRUE if EAP can be used for outgoing authentication, or to VARIANT_FALSE if EAP cannot be used for outgoing authentication.
fEnableEAP
Boolean value that specifies whether EAP can be used for outgoing authentication.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write. Its default value is VARIANT_FALSE.

EAP can be used to provide an added layer of security to Point-to-Point Tunneling Protocol (PPTP) and Layer Two Tunneling Protocol (L2TP) VPN connections. EAP enables this functionality through certification authority (CA) and smart card technologies, which provide mutual authentication of the client and the server. To use EAP with a VPN, the server must be configured to accept EAP authentication as a valid authentication method and it must have a user certificate (X.509). The client must be configured to use EAP, and either have a smart card (with a smart card certificate installed) or a user certificate.

EAP cannot be enabled together with any of the other authentication protocols.

[Visual Basic]

The EnableEAP property gets or sets a Boolean value that indicates whether the Extensible Authentication Protocol (EAP) can be used for outgoing authentication.

Property EnableEAP As Boolean

Property Value

Boolean value that indicates whether EAP can be used for outgoing authentication.

Remarks

This property is read/write. Its default value is False.

EAP can be used to provide an added layer of security to Point-to-Point Tunneling Protocol (PPTP) and Layer Two Tunneling Protocol (L2TP) VPN connections. EAP enables this functionality through certification authority (CA) and smart card technologies, which provide mutual authentication of the client and the server. To use EAP with a VPN, the server must be configured to accept EAP authentication as a valid authentication method and it must have a user certificate (X.509). The client must be configured to use EAP, and either have a smart card (with a smart card certificate installed) or a user certificate.

EAP cannot be enabled together with any of the other authentication protocols.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCVpnNetworkL2tpPptpSettings


IFPCVpnNetworkL2tpPptpSettings.EnableMSCHAP property [ISA Server 2004]

EnableMSCHAP Property of IFPCVpnNetworkL2tpPptpSettings[C++]

FPCVpnNetworkL2tpPptpSettings.EnableMSCHAP [Visual Basic]

[C++]

The EnableMSCHAP property gets or sets a Boolean value that indicates whether the Microsoft Challenge Handshake Authentication Protocol version 1 (MS-CHAP) can be used for outgoing authentication. MS-CHAP is a nonreversible, encrypted password authentication protocol.

HRESULT get_EnableMSCHAP(
  VARIANT_BOOL* pfEnableMSCHAP
);

HRESULT put_EnableMSCHAP(
  VARIANT_BOOL fEnableMSCHAP
);

Parameters

pfEnableMSCHAP
Pointer to a Boolean variable that is set on return to VARIANT_TRUE if MS-CHAP can be used for outgoing authentication, or to VARIANT_FALSE if MS-CHAP cannot be used for outgoing authentication.
fEnableMSCHAP
Boolean value that specifies whether MS-CHAP can be used for outgoing authentication.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write. Its default value is VARIANT_FALSE.

MS-CHAP cannot be enabled together with the Extensible Authentication Protocol (EAP), but it can be enabled together with any combination of the other authentication protocols.

[Visual Basic]

The EnableMSCHAP property gets or sets a Boolean value that indicates whether the Microsoft Challenge Handshake Authentication Protocol version 1 (MS-CHAP) can be used for outgoing authentication. MS-CHAP is a nonreversible, encrypted password authentication protocol.

Property EnableMSCHAP As Boolean

Property Value

Boolean value that indicates whether MS-CHAP can be used for outgoing authentication.

Remarks

This property is read/write. Its default value is False.

MS-CHAP cannot be enabled together with the Extensible Authentication Protocol (EAP), but it can be enabled together with any combination of the other authentication protocols.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCVpnNetworkL2tpPptpSettings


IFPCVpnNetworkL2tpPptpSettings.EnableMSCHAPv2 property [ISA Server 2004]

EnableMSCHAPv2 Property of IFPCVpnNetworkL2tpPptpSettings[C++]

FPCVpnNetworkL2tpPptpSettings.EnableMSCHAPv2 [Visual Basic]

[C++]

The EnableMSCHAPv2 property gets or sets a Boolean value that indicates whether the Microsoft Challenge Handshake Authentication Protocol version 2 (MS-CHAP v2) can be used for outgoing authentication.

HRESULT get_EnableMSCHAPv2(
  VARIANT_BOOL* pfEnableMSCHAPv2
);

HRESULT put_EnableMSCHAPv2(
  VARIANT_BOOL fEnableMSCHAPv2
);

Parameters

pfEnableMSCHAPv2
Pointer to a Boolean variable that is set on return to VARIANT_TRUE if MS-CHAP v2 can be used for outgoing authentication, or to VARIANT_FALSE if MS-CHAP v2 cannot be used for outgoing authentication.
fEnableMSCHAPv2
Boolean value that specifies whether MS-CHAP v2 can be used for outgoing authentication.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write. Its default value is VARIANT_FALSE.

All 32-bit Microsoft VPN clients support MS-CHAP v2.

MS-CHAP v2 cannot be enabled together with the Extensible Authentication Protocol (EAP), but it can be enabled together with any combination of the other authentication protocols.

[Visual Basic]

The EnableMSCHAPv2 property gets or sets a Boolean value that indicates whether the Microsoft Challenge Handshake Authentication Protocol version 2 (MS-CHAP v2) can be used for outgoing authentication.

Property EnableMSCHAPv2 As Boolean

Property Value

Boolean value that indicates whether MS-CHAP v2 can be used for outgoing authentication.

Remarks

This property is read/write. Its default value is False.

All 32-bit Microsoft VPN clients support MS-CHAP v2.

MS-CHAP v2 cannot be enabled together with the Extensible Authentication Protocol (EAP), but it can be enabled together with any combination of the other authentication protocols.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCVpnNetworkL2tpPptpSettings


IFPCVpnNetworkL2tpPptpSettings.EnablePAP property [ISA Server 2004]

EnablePAP Property of IFPCVpnNetworkL2tpPptpSettings[C++]

FPCVpnNetworkL2tpPptpSettings.EnablePAP [Visual Basic]

[C++]

The EnablePAP property gets or sets a Boolean value that indicates whether the Password Authentication Protocol (PAP) can be used for outgoing authentication.

HRESULT get_EnablePAP(
  VARIANT_BOOL* pfEnablePAP
);

HRESULT put_EnablePAP(
  VARIANT_BOOL fEnablePAP
);

Parameters

pfEnablePAP
Pointer to a Boolean variable that is set on return to VARIANT_TRUE if PAP can be used for outgoing authentication, or to VARIANT_FALSE if PAP cannot be used for outgoing authentication.
fEnablePAP
Boolean value that specifies whether PAP can be used for outgoing authentication.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write. Its default value is VARIANT_FALSE.

When PAP is used for authentication, passwords are sent in plaintext, or unencrypted, form. You should use this authentication protocol only when support for non-Microsoft remote PAP clients is required.

PAP cannot be enabled together with the Extensible Authentication Protocol (EAP), but it can be enabled together with any combination of the other authentication protocols.

[Visual Basic]

The EnablePAP property gets or sets a Boolean value that indicates whether the Password Authentication Protocol (PAP) can be used for outgoing authentication.

Property EnablePAP As Boolean

Property Value

Boolean value that indicates whether PAP can be used for outgoing authentication.

Remarks

This property is read/write. Its default value is False.

When PAP is used for authentication, passwords are sent in plaintext, or unencrypted, form. You should use this authentication protocol only when support for non-Microsoft remote PAP clients is required.

PAP cannot be enabled together with the Extensible Authentication Protocol (EAP), but it can be enabled together with any combination of the other authentication protocols.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCVpnNetworkL2tpPptpSettings


IFPCVpnNetworkL2tpPptpSettings.EnableShivaPAP property [ISA Server 2004]

EnableShivaPAP Property of IFPCVpnNetworkL2tpPptpSettings[C++]

FPCVpnNetworkL2tpPptpSettings.EnableShivaPAP [Visual Basic]

[C++]

The EnableShivaPAP property gets or sets a Boolean value that indicates whether the Shiva Password Authentication Protocol (SPAP) can be used for outgoing authentication.

HRESULT get_EnableShivaPAP(
  VARIANT_BOOL* pfEnableShivaPAP
);

HRESULT put_EnableShivaPAP(
  VARIANT_BOOL fEnableShivaPAP
);

Parameters

pfEnableShivaPAP
Pointer to a Boolean variable that is set on return to VARIANT_TRUE if SPAP can be used for outgoing authentication, or to VARIANT_FALSE if SPAP cannot be used for outgoing authentication.
fEnableShivaPAP
Boolean value that specifies whether SPAP can be used for outgoing authentication.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write. Its default value is VARIANT_FALSE.

SPAP cannot be enabled together with the Extensible Authentication Protocol (EAP), but it can be enabled together with any combination of the other authentication protocols.

[Visual Basic]

The EnableShivaPAP property gets or sets a Boolean value that indicates whether the Shiva Password Authentication Protocol (SPAP) can be used for outgoing authentication.

Property EnableShivaPAP As Boolean

Property Value

Boolean value that indicates whether SPAP can be used for outgoing authentication.

Remarks

This property is read/write. Its default value is False.

SPAP cannot be enabled together with the Extensible Authentication Protocol (EAP), but it can be enabled together with any combination of the other authentication protocols.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCVpnNetworkL2tpPptpSettings


IFPCVpnNetworkL2tpPptpSettings.IdleDisconnectTime property [ISA Server 2004]

IdleDisconnectTime Property of IFPCVpnNetworkL2tpPptpSettings[C++]

FPCVpnNetworkL2tpPptpSettings.IdleDisconnectTime [Visual Basic]

[C++]

The IdleDisconnectTime property gets or sets the time, in seconds, after which an inactive connection is closed.

HRESULT get_IdleDisconnectTime(
  long* plIdleDisconnectTime
);

HRESULT put_IdleDisconnectTime(
  long lIdleDisconnectTime
);

Parameters

plIdleDisconnectTime
Pointer to a 32-bit integer that is set on return to a long value specifying the time, in seconds, after which an inactive connection is closed.
lIdleDisconnectTime
A 32-bit integer value that specifies the time, in seconds, after which an inactive connection is closed.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write. Its default value is 86,400 seconds (24 hours).

Inactive sessions are disconnected only if the UseIdleDisconnectTime property is set to VARIANT_TRUE.

[Visual Basic]

The IdleDisconnectTime property gets or sets the time, in seconds, after which an inactive connection is closed.

Property IdleDisconnectTime As Long

Property Value

A 32-bit integer value that specifies the time, in seconds, after which an inactive connection is closed.

Remarks

This property is read/write. Its default value is 86,400 seconds (24 hours).

Inactive sessions are disconnected only if the UseIdleDisconnectTime property is set to True.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCVpnNetworkL2tpPptpSettings


IFPCVpnNetworkL2tpPptpSettings.PresharedKey property [ISA Server 2004]

PresharedKey Property of IFPCVpnNetworkL2tpPptpSettings[C++]

FPCVpnNetworkL2tpPptpSettings.PresharedKey [Visual Basic]

[C++]

The PresharedKey property gets or sets the preshared key for L2TP connections.

HRESULT get_PresharedKey(
  BSTR* pbstrPresharedKey
);

HRESULT put_PresharedKey(
  BSTR bstrPresharedKey
);

Parameters

pbstrPresharedKey
Pointer to a BSTR that is set on return to a string value specifying the preshared key for L2TP connections.
bstrPresharedKey
BSTR that specifies the preshared key for L2TP connections.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

On computers running a Windows 2000 Server operating system, these property methods always return E_FPC_VPN_IPSEC_PRESHARED_SECRET_NOT_SUPPORTED.

Remarks

This property is read/write. By default, no string is defined.

The preshared key will be used only if the UsePresharedKey property is set to VARIANT_TRUE.

This property is accessible only on computers running an operating system from the Windows Server 2003 family.

[Visual Basic]

The PresharedKey property gets or sets the preshared key for L2TP connections.

Property PresharedKey As String

Property Value

String that specifies the preshared key for L2TP connections.

Remarks

This property is read/write. By default, no string is defined.

The preshared key will be used only if the UsePresharedKey property is set to True.

This property is accessible only on computers running an operating system from the Windows Server 2003 family. An attempt to set or retrieve this property on a computer running a Windows 2000 Server operating system raises an E_FPC_VPN_IPSEC_PRESHARED_SECRET_NOT_SUPPORTED error, which can be intercepted by using an error handler.

Requirements

Server: Requires Windows Server 2003.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCVpnNetworkL2tpPptpSettings


IFPCVpnNetworkL2tpPptpSettings.Protocol property [ISA Server 2004]

Protocol Property of IFPCVpnNetworkL2tpPptpSettings[C++]

FPCVpnNetworkL2tpPptpSettings.Protocol [Visual Basic]

[C++]

The Protocol property gets or sets a value from the FpcVpnProtocol enumerated type that specifies which VPN protocol is to be used.

HRESULT get_Protocol(
  FpcVpnProtocol* pProtocol
);

HRESULT put_Protocol(
  FpcVpnProtocol Protocol
);

Parameters

pProtocol
Pointer to a value from the FpcVpnProtocol enumerated type that is set on return to the value specifying the VPN protocol to be used.
Protocol
Value from the FpcVpnProtocol enumerated type that specifies which VPN protocol is to be used.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write. Its default value is fpcVpnL2TP, which specifies that the Layer Two Tunneling Protocol (L2TP) protocol is used.

[Visual Basic]

The Protocol property gets or sets a value from the FpcVpnProtocol enumerated type that specifies which VPN protocol is to be used.

Property Protocol As FpcVpnProtocol

Property Value

Value from the FpcVpnProtocol enumerated type that specifies which VPN protocol is to be used.

Remarks

This property is read/write. Its default value is fpcVpnL2TP, which specifies that the Layer Two Tunneling Protocol (L2TP) protocol is used.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCVpnNetworkL2tpPptpSettings


IFPCVpnNetworkL2tpPptpSettings.Refresh method [ISA Server 2004]

IFPCVpnNetworkL2tpPptpSettings::Refresh[C++]

FPCVpnNetworkL2tpPptpSettings.Refresh [Visual Basic]

[C++]

The Refresh method recursively reads the values of all of the object's properties from persistent storage, discarding any changes that have not been saved.

HRESULT Refresh();

Parameters

This method has no parameters.

Return Values

This method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

Changes made to this object can be saved by calling the Save method of this object or the Save method of any object containing it.

[Visual Basic]

The Refresh method recursively reads the values of all of the object's properties from persistent storage, discarding any changes that have not been saved.

Sub Refresh()

Parameters

This method has no parameters.

Return Values

This method has no return values. If the call is unsuccessful, an error is raised that can be intercepted by using an error handler.

Remarks

Changes made to this object can be saved by calling the Save method of this object or the Save method of any object containing it.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCVpnNetworkL2tpPptpSettings


IFPCVpnNetworkL2tpPptpSettings.RemoteCredentials property [ISA Server 2004]

RemoteCredentials Property of IFPCVpnNetworkL2tpPptpSettings[C++]

FPCVpnNetworkL2tpPptpSettings.RemoteCredentials [Visual Basic]

[C++]

The RemoteCredentials property gets an FPCCredentials object that specifies the user name, including the domain name, and the password that are presented to the remote site for authentication.

HRESULT get_RemoteCredentials(
  IFPCCredentials** ppCredentials
);

Parameters

ppCredentials
Address of an interface pointer that on return points to an IFPCCredentials interface that represents the credentials that are presented to the remote site for authentication.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only. The credentials can be modified through the properties of the IFPCCredentials interface retrieved. By default, no user name or password are specified.

[Visual Basic]

The RemoteCredentials property gets an FPCCredentials object that specifies the user name, including the domain name, and the password that are presented to the remote site for authentication.

Property RemoteCredentials As FPCCredentials

Property Value

Reference to an FPCCredentials object that represents the credentials that are presented to the remote site for authentication.

Remarks

This property is read-only. The credentials can be modified through the properties of the FPCCredentials object retrieved. By default, no user name or password are specified.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCVpnNetworkL2tpPptpSettings


IFPCVpnNetworkL2tpPptpSettings.RemoteServerAddress property [ISA Server 2004]

RemoteServerAddress Property of IFPCVpnNetworkL2tpPptpSettings[C++]

FPCVpnNetworkL2tpPptpSettings.RemoteServerAddress [Visual Basic]

[C++]

The RemoteServerAddress property gets or sets the name or IP address of the remote site.

HRESULT get_RemoteServerAddress(
  BSTR* pbstrRemoteServer
);

HRESULT put_RemoteServerAddress(
  BSTR bstrRemoteServer
);

Parameters

pbstrRemoteServer
Pointer to a BSTR that is set on return to a string value specifying the name or IP address of the remote site.
bstrRemoteServer
BSTR that specifies the name or IP address of the remote site.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write. By default, it specifies an empty string.

[Visual Basic]

The RemoteServerAddress property gets or sets the name or IP address of the remote site.

Property RemoteServerAddress As String

Property Value

String that specifies the name or IP address of the remote site.

Remarks

This property is read/write. By default, it specifies an empty string.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCVpnNetworkL2tpPptpSettings


IFPCVpnNetworkL2tpPptpSettings.Save (2 Parameters) method [ISA Server 2004]

IFPCVpnNetworkL2tpPptpSettings::Save[C++]

FPCVpnNetworkL2tpPptpSettings.Save [Visual Basic]

[C++]

The Save method recursively writes the current values of all of the object's properties to persistent storage. It is important to remember that any changes made by scripts and programs are not saved until after the Save method is called.

HRESULT Save(
  VARIANT_BOOL fResetRequiredServices,
  VARIANT_BOOL fReloadConfiguration
);

Parameters

fResetRequiredServices
[in, optional] Boolean value that indicates whether to restart the services that need to be restarted for any of the changes saved to take effect. The default value is VARIANT_FALSE.
fReloadConfiguration
[in, optional] Boolean value that indicates whether the call will include synchronous reloading of all changes that can be applied dynamically without restarting services. The default value is VARIANT_TRUE.

Return Values

This method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

Configuration changes are applied only after the new settings are written to persistent storage and reloaded to the services that use them. Most changes can be applied dynamically without restarting any services. However, some changes can take effect only after the Microsoft Firewall service is restarted. For more information, see Restarting Services after Configuration Changes.

ISA Server maintains a bitmask that specifies which services need to be started for currently unsaved changes to take effect. This bitmask can be retrieved by calling the GetServiceRestartMask method on an object that contains this object as a subobject. Calling the Save method clears all of the bits in this bitmask even if the fResetRequiredServices parameter is set to VARIANT_FALSE.

If the fReloadConfiguration parameter is set to VARIANT_FALSE the current values of the object's properties will be written to persistent storage without updating the configuration being used by the ISA Server services. The configuration used by each service will not be updated until the service is restarted or the new settings are reloaded by another call to Save.

[Visual Basic]

The Save method recursively writes the current values of all of the object's properties to persistent storage. It is important to remember that any changes made by scripts and programs are not saved until after the Save method is called.

Sub Save( _
  [ ByVal fResetRequiredServices As Boolean ], _
  [ ByVal fReloadConfiguration As Boolean ] _
)

Parameters

fResetRequiredServices
[in, optional] Boolean value that indicates whether to restart the services that need to be restarted for any of the changes saved to take effect. The default value is False.
fReloadConfiguration
[in, optional] Boolean value that indicates whether the call will include synchronous reloading of all the saved configuration changes that can be applied dynamically without restarting services. The default value is True.

Return Values

This method has no return values. If the call is unsuccessful, an error is raised that can be intercepted by using an error handler.

Remarks

Configuration changes are applied only after the new settings are written to persistent storage and reloaded to the services that use them. Most changes can be applied dynamically without restarting any services. However, some changes can take effect only after the Microsoft Firewall service is restarted. For more information, see Restarting Services after Configuration Changes.

ISA Server maintains a bitmask that specifies which services need to be started for currently unsaved changes to take effect. This bitmask can be retrieved by calling the GetServiceRestartMask method on an object that contains this object as a subobject. Calling the Save method clears all of the bits in this bitmask even if the fResetRequiredServices parameter is set to False.

If the fReloadConfiguration parameter is set to False the current values of the object's properties will be written to persistent storage without updating the configuration being used by the ISA Server services. The configuration used by each service will not be updated until the service is restarted or the new settings are reloaded by another call to Save.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCVpnNetworkL2tpPptpSettings


IFPCVpnNetworkL2tpPptpSettings.UseIdleDisconnectTime property [ISA Server 2004]

UseIdleDisconnectTime Property of IFPCVpnNetworkL2tpPptpSettings[C++]

FPCVpnNetworkL2tpPptpSettings.UseIdleDisconnectTime [Visual Basic]

[C++]

The UseIdleDisconnectTime property gets or sets a Boolean value that indicates whether an inactive connection will be closed after the time specified in the IdleDisconnectTime property elapses.

HRESULT get_UseIdleDisconnectTime(
  VARIANT_BOOL* pfUseIdleDisconnectTime
);

HRESULT put_UseIdleDisconnectTime(
  VARIANT_BOOL fUseIdleDisconnectTime
);

Parameters

pfUseIdleDisconnectTime
Pointer to a Boolean variable that is set on return to VARIANT_TRUE if an inactive connection will be closed after the time specified in the IdleDisconnectTime property elapses, or to VARIANT_FALSE if inactive connections will not be disconnected.
fUseIdleDisconnectTime
Boolean value that specifies whether an inactive connection will be closed after the time specified in the IdleDisconnectTime property elapses.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write. Its default value is VARIANT_FALSE.

[Visual Basic]

The UseIdleDisconnectTime property gets or sets a Boolean value that indicates whether an inactive connection will be closed after the time specified in the IdleDisconnectTime property elapses.

Property UseIdleDisconnectTime As Boolean

Property Value

Boolean value that indicates whether an inactive connection will be closed after the time specified in the IdleDisconnectTime property elapses.

Remarks

This property is read/write. Its default value is False.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCVpnNetworkL2tpPptpSettings


IFPCVpnNetworkL2tpPptpSettings.UsePresharedKey property [ISA Server 2004]

UsePresharedKey Property of IFPCVpnNetworkL2tpPptpSettings[C++]

FPCVpnNetworkL2tpPptpSettings.UsePresharedKey [Visual Basic]

[C++]

The UsePresharedKey property gets or sets a Boolean value that indicates whether a preshared key is to be used for authenticating L2TP connections.

HRESULT get_UsePresharedKey(
  VARIANT_BOOL* pfUsePresharedKey
);

HRESULT put_UsePresharedKey(
  VARIANT_BOOL fUsePresharedKey
);

Parameters

pfUsePresharedKey
Pointer to a Boolean variable that is set on return to VARIANT_TRUE if a preshared key is to be used for authenticating L2TP connections, or to VARIANT_FALSE if a preshared key is not to be used for authenticating L2TP connections.
fUsePresharedKey
Boolean value that specifies whether a preshared key is to be used for authenticating L2TP connections.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

On computers running a Windows 2000 Server operating system, these property methods always return E_FPC_VPN_IPSEC_PRESHARED_SECRET_NOT_SUPPORTED.

Remarks

This property is read/write. Its default value is VARIANT_FALSE.

The preshared key to be used is specified by the PresharedKey property.

This property is accessible only on computers running an operating system from the Windows Server 2003 family.

[Visual Basic]

The UsePresharedKey property gets or sets a Boolean value that indicates whether a preshared key is to be used for authenticating L2TP connections.

Property UsePresharedKey As Boolean

Property Value

Boolean value that indicates whether a preshared key is to be used for authenticating L2TP connections.

Remarks

This property is read/write. Its default value is False.

The preshared key to be used is specified by the PresharedKey property.

This property is accessible only on computers running an operating system from the Windows Server 2003 family. An attempt to set or retrieve this property on a computer running a Windows 2000 Server operating system raises an E_FPC_VPN_IPSEC_PRESHARED_SECRET_NOT_SUPPORTED error, which can be intercepted by using an error handler.

Requirements

Server: Requires Windows Server 2003.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCVpnNetworkL2tpPptpSettings


FPCVpnPPPSettings object [ISA Server 2004]

FPCVpnPPPSettings

The FPCVpnPPPSettings object defines virtual private network (VPN) Point-to-Point Protocol (PPP) settings.

The FPCVpnPPPSettings object can be accessed through the PPPSettings property of the FPCVpnConfiguration object.

Click here to see the ISA Server object hierarchy.

Methods

The FPCVpnPPPSettings object defines the following methods.

Method | Description
Refresh | Reads the values of all of the object's properties from persistent storage, discarding any changes that have not been saved.
Save | Writes the current values of all of the object's properties to persistent storage.

Properties

The FPCVpnPPPSettings object has the following properties.

Property | Description
EnableCHAP | Gets or sets a Boolean value that indicates whether the Challenge Handshake Authentication Protocol (CHAP) is enabled.
EnableEAP | Gets or sets a Boolean value that indicates whether the Extensible Authentication Protocol (EAP) is enabled.
EnableMSCHAP | Gets or sets a Boolean value that indicates whether the Microsoft Challenge Handshake Authentication Protocol version 1 (MS-CHAP) is enabled.
EnableMSCHAPv2 | Gets or sets a Boolean value that indicates whether the Microsoft Challenge Handshake Authentication Protocol version 2 (MS-CHAP v2) is enabled.
EnablePAP | Gets or sets a Boolean value that indicates whether the Password Authentication Protocol (PAP) is enabled.
EnableShivaPAP | Gets or sets a Boolean value that indicates whether the Shiva Password Authentication Protocol (SPAP) is enabled.

Remarks

This object implements the IFPCVpnPPPSettings interface.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

COM Objects


IFPCVpnPPPSettings | FPCVpnPPPSettings EnableCHAP property [ISA Server 2004]

EnableCHAP Property of IFPCVpnPPPSettings[C++]

FPCVpnPPPSettings.EnableCHAP [Visual Basic]

[C++]

The EnableCHAP property gets or sets a Boolean value that indicates whether the Challenge Handshake Authentication Protocol (CHAP) is enabled. CHAP is a challenge/response authentication protocol for Point-to-Point Protocol (PPP) connections that applies the Message Digest 5 (MD-5) hashing algorithm to a combination of the challenge string issued by the authenticating server and the user's password, and then sends the result in the response.

HRESULT get_EnableCHAP(
  VARIANT_BOOL* pfEnableCHAP
);

HRESULT put_EnableCHAP(
  VARIANT_BOOL fEnableCHAP
);

Parameters

pfEnableCHAP
Pointer to a Boolean variable that is set on return to VARIANT_TRUE if CHAP is enabled, or to VARIANT_FALSE if CHAP is disabled.
fEnableCHAP
Boolean value that specifies whether CHAP is enabled.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write.

[Visual Basic]

The EnableCHAP property gets or sets a Boolean value that indicates whether the Challenge Handshake Authentication Protocol (CHAP) is enabled. CHAP is a challenge/response authentication protocol for Point-to-Point Protocol (PPP) connections that applies the Message Digest 5 (MD-5) hashing algorithm to a combination of the challenge string issued by the authenticating server and the user's password, and then sends the result in the response.

Property EnableCHAP As Boolean

Property Value

Boolean value that indicates whether CHAP is enabled.

Remarks

This property is read/write.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCVpnPPPSettings


IFPCVpnPPPSettings | FPCVpnPPPSettings EnableEAP property [ISA Server 2004]

EnableEAP Property of IFPCVpnPPPSettings[C++]

FPCVpnPPPSettings.EnableEAP [Visual Basic]

[C++]

The EnableEAP property gets or sets a Boolean value that indicates whether the Extensible Authentication Protocol (EAP) is enabled. In ISA Server, EAP is used only with the Transport Level Security authentication scheme (EAP-TLS) for incoming connections.

HRESULT get_EnableEAP(
  VARIANT_BOOL* pfEnableEAP
);

HRESULT put_EnableEAP(
  VARIANT_BOOL fEnableEAP
);

Parameters

pfEnableEAP
Pointer to a Boolean variable that is set on return to VARIANT_TRUE if EAP is enabled, or to VARIANT_FALSE if EAP is disabled.
fEnableEAP
Boolean value that indicates whether EAP is enabled.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write. Its default value is VARIANT_FALSE.

EAP can be used to provide an added layer of security to Point-to-Point Tunneling Protocol (PPTP) and Layer Two Tunneling Protocol (L2TP) VPN connections. EAP enables this functionality through certification authority (CA) and smart card technologies, which provide mutual authentication of the VPN client and the VPN server. To use EAP in a VPN scenario, the server must be configured to accept EAP authentication as a valid authentication method and it must have a user certificate (X.509). The client must be configured to use EAP, and either have a smart card (with a smart card certificate installed) or a user certificate.

On a computer running Windows Server 2003, multiple EAP types are supported. Enabling EAP through this property adds the EAP-TLS type to the list of EAP types that can be used on the computer, and disabling EAP through this property removes the EAP-TLS type from the list of EAP types. If no EAP type remains on the list, EAP is disabled on the computer.

On a Windows 2000 computer, only one EAP type can be enabled. If an EAP type with an authentication scheme other than TLS is enabled, an attempt to enable EAP-TLS in ISA Server through this property will fail. Similarly, an attempt to disable EAP with an authentication scheme other than TLS through this property will also fail.

[Visual Basic]

The EnableEAP property gets or sets a Boolean value that indicates whether the Extensible Authentication Protocol (EAP) is enabled. In ISA Server, EAP is used only with the Transport Level Security authentication scheme (EAP-TLS) for incoming connections.

Property EnableEAP As Boolean

Property Value

Boolean value that indicates whether EAP is enabled.

Remarks

This property is read/write. Its default value is False.

EAP can be used to provide an added layer of security to Point-to-Point Tunneling Protocol (PPTP) and Layer Two Tunneling Protocol (L2TP) VPN connections. EAP enables this functionality through certification authority (CA) and smart card technologies, which provide mutual authentication of the VPN client and the VPN server. To use EAP in a VPN scenario, the server must be configured to accept EAP authentication as a valid authentication method and it must have a user certificate (X.509). The client must be configured to use EAP, and either have a smart card (with a smart card certificate installed) or a user certificate.

On a computer running Windows Server 2003, multiple EAP types are supported. Enabling EAP through this property adds the EAP-TLS type to the list of EAP types that can be used on the computer, and disabling EAP through this property removes the EAP-TLS type from the list of EAP types. If no EAP type remains on the list, EAP is disabled on the computer.

On a Windows 2000 computer, only one EAP type can be enabled. If an EAP type with an authentication scheme other than TLS is enabled, an attempt to enable EAP-TLS in ISA Server through this property will fail. Similarly, an attempt to disable EAP with an authentication scheme other than TLS through this property will also fail.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCVpnPPPSettings


IFPCVpnPPPSettings | FPCVpnPPPSettings EnableMSCHAP property [ISA Server 2004]

EnableMSCHAP Property of IFPCVpnPPPSettings[C++]

FPCVpnPPPSettings.EnableMSCHAP [Visual Basic]

[C++]

The EnableMSCHAP property gets or sets a Boolean value that indicates whether the Microsoft Challenge Handshake Authentication Protocol version 1 (MS-CHAP) is enabled. MS-CHAP is a nonreversible, encrypted password authentication protocol.

HRESULT get_EnableMSCHAP(
  VARIANT_BOOL* pfEnableMSCHAP
);

HRESULT put_EnableMSCHAP(
  VARIANT_BOOL fEnableMSCHAP
);

Parameters

pfEnableMSCHAP
Pointer to a Boolean variable that is set on return to VARIANT_TRUE if MS-CHAP is enabled, or to VARIANT_FALSE if MS-CHAP is disabled.
fEnableMSCHAP
Boolean value that specifies whether MS-CHAP is enabled.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write.

[Visual Basic]

The EnableMSCHAP property gets or sets a Boolean value that indicates whether the Microsoft Challenge Handshake Authentication Protocol version 1 (MS-CHAP) is enabled. MS-CHAP is a nonreversible, encrypted password authentication protocol.

Property EnableMSCHAP As Boolean

Property Value

Boolean value that indicates whether MS-CHAP is enabled.

Remarks

This property is read/write.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCVpnPPPSettings


IFPCVpnPPPSettings.EnableMSCHAPv2 (2 Parameters) property [ISA Server 2004]

EnableMSCHAPv2 Property of IFPCVpnPPPSettings[C++]

FPCVpnPPPSettings.EnableMSCHAPv2 [Visual Basic]

[C++]

The EnableMSCHAPv2 property gets or sets a Boolean value that indicates whether the Microsoft Challenge Handshake Authentication Protocol version 2 (MS-CHAP v2) is enabled.

HRESULT get_EnableMSCHAPv2(
  VARIANT_BOOL* pfEnableMSCHAPv2
);

HRESULT put_EnableMSCHAPv2(
  VARIANT_BOOL fEnableMSCHAPv2
);

Parameters

pfEnableMSCHAPv2
Pointer to a Boolean variable that is set on return to VARIANT_TRUE if MS-CHAP v2 is enabled, or to VARIANT_FALSE if MS-CHAP v2 is disabled.
fEnableMSCHAPv2
Boolean value that indicates whether MS-CHAP v2 is enabled.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write.

All 32-bit Microsoft VPN clients support MS-CHAP v2.

[Visual Basic]

The EnableMSCHAPv2 property gets or sets a Boolean value that indicates whether the Microsoft Challenge Handshake Authentication Protocol version 2 (MS-CHAP v2) is enabled.

Property EnableMSCHAPv2 As Boolean

Property Value

Boolean value that indicates whether MS-CHAP v2 is enabled.

Remarks

This property is read/write.

All 32-bit Microsoft VPN clients support MS-CHAP v2.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCVpnPPPSettings


IFPCVpnPPPSettings | FPCVpnPPPSettings EnablePAP property [ISA Server 2004]

EnablePAP Property of IFPCVpnPPPSettings[C++]

FPCVpnPPPSettings.EnablePAP [Visual Basic]

[C++]

The EnablePAP property gets or sets a Boolean value that indicates whether the Password Authentication Protocol (PAP) is enabled.

HRESULT get_EnablePAP(
  VARIANT_BOOL* pfEnablePAP
);

HRESULT put_EnablePAP(
  VARIANT_BOOL fEnablePAP
);

Parameters

pfEnablePAP
Pointer to a Boolean variable that is set on return to VARIANT_TRUE if PAP is enabled, or to VARIANT_FALSE if PAP is disabled.
fEnablePAP
Boolean value that specifies whether PAP is enabled.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write.

When PAP is used for authentication, passwords are sent in plaintext, or unencrypted, form. You should use this authentication protocol only when support for non-Microsoft remote PAP clients is required.

[Visual Basic]

The EnablePAP property gets or sets a Boolean value that indicates whether the Password Authentication Protocol (PAP) is enabled.

Property EnablePAP As Boolean

Property Value

Boolean value that specifies whether PAP is enabled.

Remarks

This property is read/write.

When PAP is used for authentication, passwords are sent in plaintext, or unencrypted, form. You should use this authentication protocol only when support for non-Microsoft remote PAP clients is required.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCVpnPPPSettings


IFPCVpnPPPSettings.EnableShivaPAP (2 Parameters) property [ISA Server 2004]

EnableShivaPAP Property of IFPCVpnPPPSettings[C++]

FPCVpnPPPSettings.EnableShivaPAP [Visual Basic]

[C++]

The EnableShivaPAP property gets or sets a Boolean value that indicates whether the Shiva Password Authentication Protocol (SPAP) is enabled.

HRESULT get_EnableShivaPAP(
  VARIANT_BOOL* pfEnableShivaPAP
);

HRESULT put_EnableShivaPAP(
  VARIANT_BOOL fEnableShivaPAP
);

Parameters

pfEnableShivaPAP
Pointer to a Boolean variable that is set on return to VARIANT_TRUE if SPAP is enabled, or to VARIANT_FALSE if SPAP is disabled.
fEnableShivaPAP
Boolean value that specifies whether SPAP is enabled.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write.

[Visual Basic]

The EnableShivaPAP property gets or sets a Boolean value that indicates whether the Shiva Password Authentication Protocol (SPAP) is enabled.

Property EnableShivaPAP As Boolean

Property Value

Boolean value that indicates whether SPAP is enabled.

Remarks

This property is read/write.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCVpnPPPSettings


IFPCVpnPPPSettings | FPCVpnPPPSettings Refresh method [ISA Server 2004]

IFPCVpnPPPSettings::Refresh[C++]

FPCVpnPPPSettings.Refresh [Visual Basic]

[C++]

The Refresh method reads the values of all of the object's properties from persistent storage, discarding any changes that have not been saved.

HRESULT Refresh();

Parameters

This method has no parameters.

Return Values

This method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

Changes made to this object can be saved by calling the Save method of this object or the Save method of any object containing it.

[Visual Basic]

The Refresh method reads the values of all of the object's properties from persistent storage, discarding any changes that have not been saved.

Sub Refresh()

Parameters

This method has no parameters.

Return Values

This method has no return values. If the call is unsuccessful, an error is raised that can be intercepted by using an error handler.

Remarks

Changes made to this object can be saved by calling the Save method of this object or the Save method of any object containing it.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCVpnPPPSettings


IFPCVpnPPPSettings | FPCVpnPPPSettings Save method [ISA Server 2004]

IFPCVpnPPPSettings::Save[C++]

FPCVpnPPPSettings.Save [Visual Basic]

[C++]

The Save method writes the current values of all of the object's properties to persistent storage. It is important to remember that any changes made by scripts and programs are not saved until after the Save method is called.

HRESULT Save(
  VARIANT_BOOL fResetRequiredServices,
  VARIANT_BOOL fReloadConfiguration
);

Parameters

fResetRequiredServices
[in, optional] Boolean value that indicates whether to restart the services that need to be restarted for any of the changes saved to take effect. The default value is VARIANT_FALSE.
fReloadConfiguration
[in, optional] Boolean value that indicates whether the call will include synchronous reloading of all changes that can be applied dynamically without restarting services. The default value is VARIANT_TRUE.

Return Values

This method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

Configuration changes are applied only after the new settings are written to persistent storage and reloaded to the services that use them. Most changes can be applied dynamically without restarting any services. However, some changes can take effect only after the Microsoft Firewall service is restarted. For more information, see Restarting Services after Configuration Changes.

ISA Server maintains a bitmask that specifies which services need to be started for currently unsaved changes to take effect. This bitmask can be retrieved by calling the GetServiceRestartMask method on an object that contains this object as a subobject. Calling the Save method clears all of the bits in this bitmask even if the fResetRequiredServices parameter is set to VARIANT_FALSE.

If the fReloadConfiguration parameter is set to VARIANT_FALSE the current values of the object's properties will be written to persistent storage without updating the configuration being used by the ISA Server services. The configuration used by each service will not be updated until the service is restarted or the new settings are reloaded by another call to Save.

[Visual Basic]

The Save method writes the current values of all of the object's properties to persistent storage. It is important to remember that any changes made by scripts and programs are not saved until after the Save method is called.

Sub Save( _
  [ ByVal fResetRequiredServices As Boolean ], _
  [ ByVal fReloadConfiguration As Boolean ] _
)

Parameters

fResetRequiredServices
[in, optional] Boolean value that indicates whether to restart the services that need to be restarted for any of the changes saved to take effect. The default value is False.
fReloadConfiguration
[in, optional] Boolean value that indicates whether the call will include synchronous reloading of all the saved configuration changes that can be applied dynamically without restarting services. The default value is True.

Return Values

This method has no return values. If the call is unsuccessful, an error is raised that can be intercepted by using an error handler.

Remarks

Configuration changes are applied only after the new settings are written to persistent storage and reloaded to the services that use them. Most changes can be applied dynamically without restarting any services. However, some changes can take effect only after the Microsoft Firewall service is restarted. For more information, see Restarting Services after Configuration Changes.

ISA Server maintains a bitmask that specifies which services need to be started for currently unsaved changes to take effect. This bitmask can be retrieved by calling the GetServiceRestartMask method on an object that contains this object as a subobject. Calling the Save method clears all of the bits in this bitmask even if the fResetRequiredServices parameter is set to False.

If the fReloadConfiguration parameter is set to False the current values of the object's properties will be written to persistent storage without updating the configuration being used by the ISA Server services. The configuration used by each service will not be updated until the service is restarted or the new settings are reloaded by another call to Save.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCVpnPPPSettings


FPCVpnQuarantineSettings object [ISA Server 2004]

FPCVpnQuarantineSettings

The FPCVpnQuarantineSettings object defines the virtual private network (VPN) quarantine settings.

The FPCVpnQuarantineSettings object is typically accessed through the QuarantineSettings property of an FPCVpnConfiguration object.

Click here to see the ISA Server object hierarchy.

A VPN quarantine uses the Network Access Quarantine Control feature of Windows Server 2003 to prevent remote VPN clients from obtaining normal remote access until the configuration of their systems has been examined by a server-provided script and validated as meeting the requirements of the organization's network policies. The connection to a remote VPN client can be closed if the time-out period elapses before the configuration is validated.

The clearing of VPN clients from a quarantine can be enabled by installing Remote Access Quarantine Agent (Rqs.exe) on the ISA Server computer and the Remote Access Quarantine Client utility (Rqc.exe) on VPN clients. Both of these utilities are available in the Microsoft Windows Server 2003 Resource Kit. Additional steps must also be performed. For detailed instructions on implementing the clearing of VPN clients from a quarantine, see VPN Roaming Clients in ISA Server 2004.

Alternatively, you can create a custom listener component that listens for messages from a matching notifier component running on quarantine-compatible remote access clients. These messages indicate that the scripts have been run successfully. Then your listening component can use the MprAdminConnectionRemoveQuarantine function to remove the quarantine restrictions from the remote access connections.

Methods

The FPCVpnQuarantineSettings object defines the following methods.

Method | Description
Refresh | Recursively reads the values of all of the object's properties from persistent storage, discarding any changes that have not been saved.
Save | Writes the current values of all of the object's properties, including the properties of its subobjects and their elements (for collections), to persistent storage.

Properties

The FPCVpnQuarantineSettings object has the following properties.

Property | Description
QuarantineMode | Gets or sets a value from the FpcVpnQuarantineMode enumerated type that specifies whether the VPN quarantine is enabled or disabled and whether the ISA Server policy or the Remote Authentication Dial-in User Service (RADIUS) policy is used to validate the configuration of remote VPN clients.
QuarantineTimeout | Gets or sets the time, in seconds, that a connection can remain in the restricted state before being closed.
QuarantineTimeoutEnabled | Gets or sets a Boolean value that indicates whether the VPN quarantine time-out period is enabled.
UserSetsExcluded | Gets an FPCRefs collection that contains references to the FPCUserSet collections defining the user sets to which the VPN quarantine is not applied.

Remarks

This object implements the IFPCVpnQuarantineSettings interface.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

COM Objects


IFPCVpnQuarantineSettings.QuarantineMode property [ISA Server 2004]

QuarantineMode Property of IFPCVpnQuarantineSettings[C++]

FPCVpnQuarantineSettings.QuarantineMode [Visual Basic]

[C++]

The QuarantineMode property gets or sets a value from the FpcVpnQuarantineMode enumerated type that specifies whether the VPN quarantine is enabled or disabled and whether the ISA Server policy or the RADIUS policy is used to validate the configuration of remote VPN clients.

HRESULT get_QuarantineMode(
  FpcVpnQuarantineMode* pQuarantineMode
);

HRESULT put_QuarantineMode(
  FpcVpnQuarantineMode QuarantineMode
);

Parameters

pQuarantineMode
Pointer to a value from the FpcVpnQuarantineMode enumerated type that is set on return to fpcVpnQuarantineDisabled if the VPN quarantine is not enabled, to fpcVpnQuarantineEnabled if the VPN quarantine is enabled and the ISA Server policy is used, or to fpcVpnQuarantineEnabledWithRadiusPolicy if the VPN quarantine is enabled and the RADIUS policy is used.
QuarantineMode
Value from the FpcVpnQuarantineMode enumerated type that specifies whether the VPN quarantine is enabled or disabled, and whether the ISA Server policy or the RADIUS policy is used to validate the configuration of remote VPN clients.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

On computers running a Windows 2000 Server operating system, these property methods always return E_FPC_RADIUS_QUARANTINE_NOT_SUPPORTED.

Remarks

This property is read/write. Its default value is fpcVpnQuarantineDisabled, which specifies that the VPN quarantine is not enabled.

This property can be set to fpcVpnQuarantineEnabledWithRadiusPolicy only on computers running an operating system from the Windows Server 2003 family.

[Visual Basic]

The QuarantineMode property gets or sets a value from the FpcVpnQuarantineMode enumerated type that specifies whether the VPN quarantine is enabled or disabled and whether the ISA Server policy or the RADIUS policy is used to validate the configuration of remote VPN clients.

Property QuarantineMode As FpcVpnQuarantineMode

Property Value

Value from the FpcVpnQuarantineMode enumerated type that specifies whether the VPN quarantine is enabled or disabled and whether the ISA Server policy or the RADIUS policy is used to validate the configuration of remote VPN clients.

Remarks

This property is read/write. Its default value is fpcVpnQuarantineDisabled, which specifies that the VPN quarantine is not enabled.

A VPN quarantine based on RADIUS policies is supported only on computers running an operating system from the Windows Server 2003 family. An attempt to set this property to fpcVpnQuarantineEnabledWithRadiusPolicy on a computer running a Windows 2000 Server operating system raises an E_FPC_RADIUS_QUARANTINE_NOT_SUPPORTED error, which can be intercepted by using an error handler.

Requirements

Server: Requires Windows Server 2003.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCVpnQuarantineSettings


IFPCVpnQuarantineSettings.QuarantineTimeout property [ISA Server 2004]

QuarantineTimeout Property of IFPCVpnQuarantineSettings[C++]

FPCVpnQuarantineSettings.QuarantineTimeout [Visual Basic]

[C++]

The QuarantineTimeout property gets or sets the time, in seconds, that a connection can remain in the restricted state before disconnecting.

HRESULT get_QuarantineTimeout(
  long* plQuarantineTimeout
);

HRESULT put_QuarantineTimeout(
  long lQuarantineTimeout
);

Parameters

plQuarantineTimeout
Pointer to a variable that on return receives a 32-bit integer specifying the time, in seconds, that a connection can remain in the restricted state before disconnecting.
lQuarantineTimeout
A 32-bit integer that specifies the time, in seconds, that a connection can remain in the restricted state before disconnecting.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write. Its default value is 0.

[Visual Basic]

The QuarantineTimeout property gets or sets the time, in seconds, that a connection can remain in the restricted state before disconnecting.

Property QuarantineTimeout As Long

Property Value

A 32-bit integer that specifies the time, in seconds, that a connection can remain in the restricted state before disconnecting.

Remarks

This property is read/write. Its default value is 0.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCVpnQuarantineSettings


IFPCVpnQuarantineSettings.QuarantineTimeoutEnabled property [ISA Server 2004]

QuarantineTimeoutEnabled Property of IFPCVpnQuarantineSettings[C++]

FPCVpnQuarantineSettings.QuarantineTimeoutEnabled [Visual Basic]

[C++]

The QuarantineTimeoutEnabled property gets or sets a Boolean value that indicates whether the VPN quarantine time-out period is enabled.

HRESULT get_QuarantineTimeoutEnabled(
  VARIANT_BOOL* pfQuarantineTimeoutEnabled
);

HRESULT put_QuarantineTimeoutEnabled(
  VARIANT_BOOL fQuarantineTimeoutEnabled
);

Parameters

pfQuarantineTimeoutEnabled
Pointer to a Boolean variable that is set on return to VARIANT_TRUE if the VPN quarantine time-out period is enabled, or to VARIANT_FALSE if the VPN quarantine time-out period is disabled.
fQuarantineTimeoutEnabled
Boolean value that indicates whether the VPN quarantine time-out period is enabled.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write. Its default value is VARIANT_FALSE.

[Visual Basic]

The QuarantineTimeoutEnabled property gets or sets a Boolean value that indicates whether the VPN quarantine time-out period is enabled.

Property QuarantineTimeoutEnabled As Boolean

Property Value

Boolean value that indicates whether the VPN quarantine time-out period is enabled.

Remarks

This property is read/write. Its default value is False.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCVpnQuarantineSettings


IFPCVpnQuarantineSettings.Refresh method [ISA Server 2004]

IFPCVpnQuarantineSettings::Refresh[C++]

FPCVpnQuarantineSettings.Refresh [Visual Basic]

[C++]

The Refresh method recursively reads the values of all of the object's properties from persistent storage, discarding any changes that have not been saved.

HRESULT Refresh();

Parameters

This method has no parameters.

Return Values

This method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

Changes made to this object or its subobject can be saved by calling the Save method of this object or the Save method of any object containing it.

[Visual Basic]

The Refresh method recursively reads the values of all of the object's properties from persistent storage, discarding any changes that have not been saved.

Sub Refresh()

Parameters

This method has no parameters.

Return Values

This method has no return values. If the call is unsuccessful, an error is raised that can be intercepted by using an error handler.

Remarks

Changes made to this object or its subobject can be saved by calling the Save method of this object or the Save method of any object containing it.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCVpnQuarantineSettings


IFPCVpnQuarantineSettings.Save (2 Parameters) method [ISA Server 2004]

IFPCVpnQuarantineSettings::Save[C++]

FPCVpnQuarantineSettings.Save [Visual Basic]

[C++]

The Save method writes the current values of all of the object's properties, including the properties of its subobjects and their elements (for collections), to persistent storage. It is important to remember that any changes made by scripts and programs are not saved until after the Save method is called.

HRESULT Save(
  VARIANT_BOOL fResetRequiredServices,
  VARIANT_BOOL fReloadConfiguration
);

Parameters

fResetRequiredServices
[in, optional] Boolean value that indicates whether to restart the services that need to be restarted for any of the changes saved to take effect. The default value is VARIANT_FALSE.
fReloadConfiguration
[in, optional] Boolean value that indicates whether the call will include synchronous reloading of all changes that can be applied dynamically without restarting services. The default value is VARIANT_TRUE.

Return Values

This method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

Configuration changes are applied only after the new settings are written to persistent storage and reloaded to the services that use them. Most changes can be applied dynamically without restarting any services. However, some changes can take effect only after the Microsoft Firewall service is restarted. For more information, see Restarting Services after Configuration Changes.

ISA Server maintains a bitmask that specifies which services need to be started for currently unsaved changes to take effect. This bitmask can be retrieved by calling the GetServiceRestartMask method on an object that contains this object as a subobject. Calling the Save method clears all of the bits in this bitmask even if the fResetRequiredServices parameter is set to VARIANT_FALSE.

If the fReloadConfiguration parameter is set to VARIANT_FALSE the current values will be written to persistent storage without updating the configuration being used by the ISA Server services. The configuration used by each service will not be updated until the service is restarted or the new settings are reloaded by another call to Save.

[Visual Basic]

The Save method writes the current values of all of the object's properties, including the properties of its subobjects and their elements (for collections), to persistent storage. It is important to remember that any changes made by scripts and programs are not saved until after the Save method is called.

Sub Save( _
  [ ByVal fResetRequiredServices As Boolean ], _
  [ ByVal fReloadConfiguration As Boolean ] _
)

Parameters

fResetRequiredServices
[in, optional] Boolean value that indicates whether to restart the services that need to be restarted for any of the changes saved to take effect. The default value is False.
fReloadConfiguration
[in, optional] Boolean value that indicates whether the call will include synchronous reloading of all the saved configuration changes that can be applied dynamically without restarting services. The default value is True.

Return Values

This method has no return values. If the call is unsuccessful, an error is raised that can be intercepted by using an error handler.

Remarks

Configuration changes are applied only after the new settings are written to persistent storage and reloaded to the services that use them. Most changes can be applied dynamically without restarting any services. However, some changes can take effect only after the Microsoft Firewall service is restarted. For more information, see Restarting Services after Configuration Changes.

ISA Server maintains a bitmask that specifies which services need to be started for currently unsaved changes to take effect. This bitmask can be retrieved by calling the GetServiceRestartMask method on an object that contains this object as a subobject. Calling the Save method clears all of the bits in this bitmask even if the fResetRequiredServices parameter is set to False.

If the fReloadConfiguration parameter is set to False the current values will be written to persistent storage without updating the configuration being used by the ISA Server services. The configuration used by each service will not be updated until the service is restarted or the new settings are reloaded by another call to Save.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCVpnQuarantineSettings


IFPCVpnQuarantineSettings.UserSetsExcluded(IFPCRefs) property [ISA Server 2004]

UserSetsExcluded Property of IFPCVpnQuarantineSettings[C++]

FPCVpnQuarantineSettings.UserSetsExcluded [Visual Basic]

[C++]

The UserSetsExcluded property gets an FPCRefs collection that contains references to the FPCUserSet collections defining the user sets to which the virtual private network (VPN) quarantine is not applied.

HRESULT get_UserSetsExcluded(
  IFPCRefs** ppRefs
);

Parameters

ppRefs
Address of an interface pointer that on return points to an IFPCRefs interface that represents the collection of user sets to which the VPN quarantine is not applied.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only. It can be modified by calling the methods of the IFPCRefs interface. By default, this property does not reference any user sets.

[Visual Basic]

The UserSetsExcluded property gets an FPCRefs collection that contains references to the FPCUserSet collections defining the user sets to which the virtual private network (VPN) quarantine is not applied.

Property UserSetsExcluded As FPCRefs

Property Value

Reference to an FPCRefs collection that contains references to the user sets to which the VPN quarantine is not applied.

Remarks

This property is read-only. It can be modified by calling the methods of the FPCRefs collection. By default, this property does not reference any user sets.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCVpnQuarantineSettings


FPCWebBrowserClientConfig object [ISA Server 2004]

FPCWebBrowserClientConfig

The FPCWebBrowserClientConfig object represents the configuration settings for Web browsers running on Firewall clients. These settings are used in generating a configuration file for Firewall clients that will use the ISA Server computer as a Web proxy. This configuration file can be used by the Firewall client setup application to configure Web browsers on the client computers. This object also contains information about an automatic configuration script that can be downloaded and executed by a Web brower running on a Firewall client every time that it is opened.

This object is typically accessed through the Browser property of an FPCClientConfig object.

Click here to see the ISA Server object hierarchy.

Inheritance

This object inherits from the FPCPersist object, which contains methods and properties related to the persistent storage of an object's data. They include methods for exporting an object's data to and importing it from an XML document.

Methods

The FPCWebBrowserClientConfig object defines the following method.

Method | Description
SetBrowserConfigScript | Sets whether Web browsers running on Firewall clients will use the default automatic configuration script or the custom automatic configuration script, and can set the address (URL) or file name of the custom automatic configuration script.

Properties

The FPCWebBrowserClientConfig object has the following properties.

Property | Description
AutoScript | Gets an FPCClientAutoScript object that defines the contents of the default automatic configuration script for Web browsers running on Firewall clients.
BrowserConfigAutoDetect | Gets or sets a Boolean value that indicates whether the Web browser configuration settings are detected automatically.
BrowserConfigEnabled | Gets or sets a Boolean value that indicates whether an ISA Server Firewall client installation will affect the client's Web browser configuration settings.
BrowserConfigScriptAddress | Gets the address (URL) or file name of a custom script file for configuring Web browsers.
BrowserConfigScriptEnabled | Gets or sets a Boolean value that indicates whether Web browsers on Firewall clients will use an automatic configuration script.
BrowserConfigScriptFlag | Gets a value from the FpcBrowserConfigScriptFlag enumerated type that specifies whether Web browsers running on Firewall clients will use the default automatic configuration script, or a custom automatic configuration script.
ServerOrArrayName | Gets or sets the name of the ISA Server computer. This name is translated by the Domain Name System (DNS) and can point to multiple proxy servers.

Methods Inherited from FPCPersist

Name | Description
CancelWaitForChanges | Cancels the registration established by the WaitForChanges method (for use in C and C++ programming only).
CanImport | Returns a Boolean value that indicates whether the object's properties can be imported from the specified XML document.
Export | Recursively writes the stored values of all the properties of the object and its subobjects to the specified XML document.
ExportToFile | Recursively writes the stored values of all the properties of the object and its subobjects to the specified XML file.
GetServiceRestartMask | Retrieves a 32-bit bitmask of the FpcServices enumerated type that specifies which services need to be restarted for currently unsaved changes to take effect.
Import | Recursively copies the values of all the properties of the object and of its subobjects from the specified XML document to persistent storage.
ImportFromFile | Recursively copies the values of all the properties of the object and of its subobjects from the specified XML file to persistent storage.
LoadDocProperties | Provides the XML document's properties so that you can know what information can be imported from the document.
Refresh | Recursively reads the values of all the properties of the object and of its subobjects from persistent storage, overwriting any changes that have not been saved.
Save | Recursively writes the current values of all the properties of the object and its subobjects to persistent storage.
WaitForChanges | Registers to wait for an event indicating that the contents of the object have changed (for use in C and C++ programming only).

Properties Inherited from FPCPersist

Name | Description
PersistentName | Gets the persistent name of the object. The persistent name of an object is a name that is unique for the object at the respective level of the COM object hierarchy.
VendorParametersSets | Gets an FPCVendorParametersSets collection that can hold sets of custom data for extending the object.

Remarks

This object implements the IFPCWebBrowserClientConfig interface.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

COM Objects


IFPCWebBrowserClientConfig.AutoScript (1 Parameter) property [ISA Server 2004]

AutoScript Property of IFPCWebBrowserClientConfig[C++]

FPCWebBrowserClientConfig.AutoScript [Visual Basic]

[C++]

The Autoscript property gets an FPCClientAutoScript object that defines the contents of the default automatic configuration script for Web browsers running on Firewall clients.

HRESULT get_AutoScript(
  IFPCClientAutoScript** ppClientAutoScript
);

Parameters

ppClientAutoScript
Address of an interface pointer that on return points to an IFPCClientAutoScript interface that represents the contents of the default automatic configuration script for Web browsers running on Firewall clients.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

Web browsers running on Firewall clients use the default automatic configuration script only if the BrowserConfigScriptEnabled property is set to VARIANT_TRUE and the BrowserConfigScriptFlag property is set to fpcBrowserDefaultScript.

[Visual Basic]

The Autoscript property gets an FPCClientAutoScript object that defines the contents of the default automatic configuration script for Web browsers running on Firewall clients.

Property AutoScript As FPCClientAutoScript

Property Value

Reference to an FPCClientAutoScript object that defines the contents of the default automatic configuration script for Web browsers running on Firewall clients.

Remarks

This property is read-only.

Web browsers running on Firewall clients use the default automatic configuration script only if the BrowserConfigScriptEnabled property is set to True and the BrowserConfigScriptFlag property is set to fpcBrowserDefaultScript.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCWebBrowserClientConfig


IFPCWebBrowserClientConfig.BrowserConfigAutoDetect property [ISA Server 2004]

BrowserConfigAutoDetect Property of IFPCWebBrowserClientConfig[C++]

FPCWebBrowserClientConfig.BrowserConfigAutoDetect [Visual Basic]

[C++]

The BrowserConfigAutoDetect property gets or sets a Boolean value that indicates whether the Web browser configuration settings are detected automatically.

HRESULT get_BrowserConfigAutoDetect(
  VARIANT_BOOL* pfAutoDetect
);

HRESULT put_BrowserConfigAutoDetect(
  VARIANT_BOOL fAutoDetect
);

Parameters

pfAutoDetect
Pointer to a Boolean variable that is set on return to VARIANT_TRUE if the Web browser configuration settings will be detected automatically, or to VARIANT_FALSE if the Web browser configuration settings will not be detected automatically.
fAutoDetect
Boolean value that specifies whether the Web browser configuration settings will be detected automatically.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write.

The automatic discovery feature of ISA Server allows you to configure Web proxy clients so that they automatically discover the appropriate ISA Server computer. In this way, roaming clients can connect to the ISA Server computer, as appropriate and when necessary.

[Visual Basic]

The BrowserConfigAutoDetect property gets or sets a Boolean value that indicates whether the Web browser configuration settings are detected automatically.

Property BrowserConfigAutoDetect As Boolean

Property Value

Boolean value that specifies whether the Web browser configuration settings will be detected automatically.

Remarks

This property is read/write.

The automatic discovery feature of ISA Server allows you to configure Web proxy clients so that they automatically discover the appropriate ISA Server computer. In this way, roaming clients can connect to the ISA Server computer, as appropriate and when necessary.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCWebBrowserClientConfig


IFPCWebBrowserClientConfig.BrowserConfigEnabled property [ISA Server 2004]

BrowserConfigEnabled Property of IFPCWebBrowserClientConfig[C++]

FPCWebBrowserClientConfig.BrowserConfigEnabled [Visual Basic]

[C++]

The BrowserConfigEnabled property gets or sets a Boolean value that indicates whether an ISA Server Firewall client installation will affect a client's Web browser configuration settings.

HRESULT get_BrowserConfigEnabled(
  VARIANT_BOOL* pfBrowserConfigEnabled
);

HRESULT put_BrowserConfigEnabled(
  VARIANT_BOOL fBrowserConfigEnabled
);

Parameters

pfBrowserConfigEnabled
Pointer to a Boolean variable that is set on return to VARIANT_TRUE if a Firewall client installation will affect a client's Web browser configuration settings, or to VARIANT_FALSE if a Firewall client installation will not affect a client's Web browser configuration settings.
fBrowserConfigEnabled
Boolean value that indicates whether a Firewall client installation will affect a client's Web browser configuration settings.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write.

[Visual Basic]

The BrowserConfigEnabled property gets or sets a Boolean value that indicates whether an ISA Server Firewall client installation will affect a client's Web browser configuration settings.

Property BrowserConfigEnabled As Boolean

Property Value

Boolean value that indicates whether a Firewall client installation will affect a client's Web browser configuration settings.

Remarks

This property is read/write.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCWebBrowserClientConfig


IFPCWebBrowserClientConfig.BrowserConfigScriptAddress property [ISA Server 2004]

BrowserConfigScriptAddress Property of IFPCWebBrowserClientConfig[C++]

FPCWebBrowserClientConfig.BrowserConfigScriptAddress [Visual Basic]

[C++]

The BrowserConfigScriptAddress property gets the address (URL) or file name of a custom script file for configuring Web browsers.

HRESULT get_BrowserConfigScriptAddress(
  BSTR* pbstrAddress
);

Parameters

pbstrAddress
Pointer to a BSTR that is set on return to a string value specifying the address (URL) or file name of a custom script file for configuring Web browsers.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only. It can be set by calling the SetBrowserConfigScript method.

[Visual Basic]

The BrowserConfigScriptAddress property gets the address (URL) or file name of a custom script file for configuring Web browsers.

Property BrowserConfigScriptAddress As String

Property Value

String that specifies the address (URL) or file name of a custom script file for configuring Web browsers.

Remarks

This property is read-only. It can be set by calling the SetBrowserConfigScript method.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCWebBrowserClientConfig


IFPCWebBrowserClientConfig.BrowserConfigScriptEnabled property [ISA Server 2004]

BrowserConfigScriptEnabled Property of IFPCWebBrowserClientConfig[C++]

FPCWebBrowserClientConfig.BrowserConfigScriptEnabled [Visual Basic]

[C++]

The BrowserConfigScriptEnabled property gets or sets a Boolean value that indicates whether Web browsers on Firewall clients will use an automatic configuration script.

HRESULT get_BrowserConfigScriptEnabled(
  VARIANT_BOOL* pfBrowserConfigScriptEnabled
);

HRESULT put_BrowserConfigScriptEnabled(
  VARIANT_BOOL fBrowserConfigScriptEnabled
);

Parameters

pfBrowserConfigScriptEnabled
Pointer to a Boolean variable that is set on return to VARIANT_TRUE if Web browsers on Firewall clients will use an automatic configuration script, or to VARIANT_FALSE if Web browsers on Firewall clients will not use an automatic configuration script.
fBrowserConfigScriptEnabled
Boolean value that indicates whether Web browsers on Firewall clients will use an automatic configuration script.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write.

When this property is set to VARIANT_TRUE, the BrowserConfigScriptFlag property determines whether the Web browsers will use the default configuration script, or a custom configuration script.

[Visual Basic]

The BrowserConfigScriptEnabled property gets or sets a Boolean value that indicates whether Web browsers on Firewall clients will use an automatic configuration script.

Property BrowserConfigScriptEnabled As Boolean

Property Value

Boolean value that indicates whether Web browsers will use an automatic configuration script.

Remarks

This property is read/write.

When this property is set to True, the BrowserConfigScriptFlag property determines whether the Web browsers will use the default configuration script, or a custom configuration script.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCWebBrowserClientConfig


IFPCWebBrowserClientConfig.BrowserConfigScriptFlag property [ISA Server 2004]

BrowserConfigScriptFlag Property of IFPCWebBrowserClientConfig[C++]

FPCWebBrowserClientConfig.BrowserConfigScriptFlag [Visual Basic]

[C++]

The BrowserConfigScriptFlag property gets a value from the FpcBrowserConfigScriptFlag enumerated type that specifies whether Web browsers running on Firewall clients will use the default automatic configuration script, or a custom automatic configuration script.

HRESULT get_BrowserConfigScriptFlag(
  FpcBrowserConfigScriptFlag* pBrowserConfigScriptFlag
);

Parameters

pBrowserConfigScriptFlag
Pointer to a variable that is set on return to a value from the FpcBrowserConfigScriptFlag enumerated type specifying whether Web browsers running on Firewall clients will use the default automatic configuration script, or a custom automatic configuration script.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only. It can be set by calling the SetBrowserConfigScript method.

Web browsers running on Firewall clients use an automatic configuration script only if the BrowserConfigScriptEnabled property is set to VARIANT_TRUE.

[Visual Basic]

The BrowserConfigScriptFlag property gets a value from the FpcBrowserConfigScriptFlag enumerated type that specifies whether Web browsers running on Firewall clients will use the default automatic configuration script, or a custom automatic configuration script.

Property BrowserConfigScriptFlag As FpcBrowserConfigScriptFlag

Property Value

Value from the FpcBrowserConfigScriptFlag enumerated type that specifies whether Web browsers running on Firewall clients will use the default automatic configuration script, or a custom automatic configuration script.

Remarks

This property is read-only. It can be set by calling the SetBrowserConfigScript method.

Web browsers running on Firewall clients use an automatic configuration script only if the BrowserConfigScriptEnabled property is set to True.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCWebBrowserClientConfig


IFPCWebBrowserClientConfig.ServerOrArrayName property [ISA Server 2004]

ServerOrArrayName Property of IFPCWebBrowserClientConfig[C++]

FPCWebBrowserClientConfig.ServerOrArrayName [Visual Basic]

[C++]

The ServerOrArrayName property gets or sets the name of the ISA Server computer or array. This name is translated by the DNS service and can point to multiple proxy servers.

HRESULT get_ServerOrArrayName(
  BSTR* pbstrName
);

HRESULT put_ServerOrArrayName(
  BSTR bstrName
);

Parameters

pbstrName
Pointer to a BSTR that is set on return to a string value specifying the name of the ISA Server computer or array.
bstrName
BSTR that specifies the name of the ISA Server computer or array.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write.

[Visual Basic]

The ServerOrArrayName property gets or sets the name of the ISA Server computer or array. This name is translated by the DNS service and can point to multiple proxy servers.

Property ServerOrArrayName As String

Property Value

String that specifies the name of the ISA Server computer or array.

Remarks

This property is read/write.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCWebBrowserClientConfig


IFPCWebBrowserClientConfig.SetBrowserConfigScript method [ISA Server 2004]

IFPCWebBrowserClientConfig::SetBrowserConfigScript[C++]

FPCWebBrowserClientConfig.SetBrowserConfigScript [Visual Basic]

[C++]

The SetBrowserConfigScript method sets whether Web browsers running on Firewall clients will use the default automatic configuration script or the custom automatic configuration script, and can set the address (URL) or file name of the custom automatic configuration script.

HRESULT SetBrowserConfigScript(
  FpcBrowserConfigScriptFlag Flag,
  BSTR bstrScript
);

Parameters

Flag
[in] Value from the FpcBrowserConfigScriptFlag enumerated type that indicates whether the default automatic configuration script or a custom automatic configuration script will be used. The possible values are fpcBrowserDefaultScript and fpcBrowserCustomScript.
bstrScript
[in, optional] String that specifies the address (URL) or file name of the custom automatic configuration script.

Return Values

This method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This method sets the BrowserConfigScriptFlag and BrowserConfigScriptAddress properties.

[Visual Basic]

The SetBrowserConfigScript method sets whether Web browsers running on Firewall clients will use the default automatic configuration script or the custom automatic configuration script, and can set the address (URL) or file name of the custom automatic configuration script.

Sub SetBrowserConfigScript( _
  ByVal Flag As FpcBrowserConfigScriptFlag, _
  [ ByVal Script As String ] _
)

Parameters

Flag
[in] Value from the FpcBrowserConfigScriptFlag enumerated type that indicates whether the default automatic configuration script or a custom automatic configuration script will be used. The possible values are fpcBrowserDefaultScript and fpcBrowserCustomScript.
Script
[in, optional] String that specifies the address (URL) or file name of the custom automatic configuration script. The default is an empty string.

Return Values

This method has no return values. If the call is unsuccessful, an error is raised that can be intercepted by using an error handler.

Remarks

This method sets the BrowserConfigScriptFlag and BrowserConfigScriptAddress properties.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCWebBrowserClientConfig


FPCWebFilter object [ISA Server 2004]

FPCWebFilter

The FPCWebFilter object represents a single Web filter that is registered to extend the ISA Server Web proxy. Web filters are dynamic-link libraries (DLLs) that are loaded when the Web proxy is launched and stay in memory until it shuts down. After Web filters are loaded, they can be configured to receive a number of special filter-event notifications. These filter-event notifications are generated for each HTTP request that the Web proxy receives and for each response returned by an external Web server through the Web proxy.

This object is typically an element of an FPCWebFilters collection.

Click here to see the ISA Server object hierarchy.

Inheritance

This object inherits from the FPCPersist object, which contains methods and properties related to the persistent storage of an object's data. They include methods for exporting an object's data to and importing it from an XML document.

Methods

This object has no methods.

Properties

The FPCWebFilter object has the following properties.

Property | Description
Description | Gets or sets the vendor-supplied description of the Web filter.
Enabled | Gets or sets a Boolean value that indicates whether the Web filter is enabled.
FilterDirection | Gets a value from the FpcFilterDirection enumerated type that indicates whether the Web filter operates in reverse proxy, forward proxy, or both modes.
Guid | Gets the vendor-supplied globally unique identifier (GUID) of the Web filter.
Name | Gets or sets the vendor-supplied name of the Web filter.
Order | Gets the ordinal position of the Web filter in the list of Web filters, which establishes the order in which Web filters of the same priority receive data.
Priority | Gets or sets a value from the FpcFilterPriority enumerated type that specifies the priority of the Web filter.
RelativePath | Gets or sets the path to the dynamic-link library (DLL) for the Web filter relative to the ISA Server installation directory.
Vendor | Gets or sets the name of the vendor that supplied the Web filter.
Version | Gets or sets the vendor-supplied version of the filter.

Methods Inherited from FPCPersist

Name | Description
CancelWaitForChanges | Cancels the registration established by the WaitForChanges method (for use in C and C++ programming only).
CanImport | Returns a Boolean value that indicates whether the object's properties can be imported from the specified XML document.
Export | Writes the stored values of all of the object's properties to the specified XML document.
ExportToFile | Writes the stored values of all of the object's properties to the specified XML file.
GetServiceRestartMask | Retrieves a 32-bit bitmask of the FpcServices enumerated type that specifies which services need to be restarted for currently unsaved changes to take effect.
Import | Copies the values of all of the object's properties from the specified XML document to persistent storage.
ImportFromFile | Copies the values of all of the object's properties from the specified XML file to persistent storage.
LoadDocProperties | Provides the XML document's properties so that you can know what information can be imported from the document.
Refresh | Reads the values of all of the object's properties from persistent storage, overwriting any changes that have not been saved.
Save | Writes the current values of all of the object's properties to persistent storage.
WaitForChanges | Registers to wait for an event indicating that the contents of the object have changed (for use in C and C++ programming only).

Properties Inherited from FPCPersist

Name | Description
PersistentName | Gets the persistent name of the object. The persistent name of an object is a name that is unique for the object at the respective level of the COM object hierarchy.
VendorParametersSets | Gets an FPCVendorParametersSets object that can hold sets of custom data for extending the object.

Remarks

This object implements the IFPCWebFilter interface.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

COM Objects


IFPCWebFilter | FPCWebFilter Description(BSTR,BSTR) property [ISA Server 2004]

Description Property of IFPCWebFilter[C++]

FPCWebFilter.Description [Visual Basic]

[C++]

The Description property gets or sets the vendor-supplied description of the filter.

HRESULT get_Description(
  BSTR* pbstrDescription
);

HRESULT put_Description(
  BSTR bstrDescription
);

Parameters

pbstrDescription
Pointer to a BSTR that is set on return to a string value specifying the vendor-supplied description of the filter.
bstrDescription
BSTR that specifies the vendor-supplied description of the filter.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write.

[Visual Basic]

The Description property gets or sets the vendor-supplied description of the filter.

Property Description As String

Property Value

String that specifies the vendor-supplied description of the filter.

Remarks

This property is read/write.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCWebFilter


IFPCWebFilter | FPCWebFilter Enabled (2 Parameters) property [ISA Server 2004]

Enabled Property of IFPCWebFilter[C++]

FPCWebFilter.Enabled [Visual Basic]

[C++]

The Enabled property gets or sets a Boolean value that indicates whether the Web filter is enabled.

HRESULT get_Enabled(
  VARIANT_BOOL* pfEnabled
);

HRESULT put_Enabled(
  VARIANT_BOOL fEnabled
);

Parameters

pfEnabled
Pointer to a Boolean variable that is set on return to VARIANT_TRUE if the Web filter is enabled, or to VARIANT_FALSE if the Web filter is disabled.
fEnabled
Boolean value that indicates whether the Web filter is enabled.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write.

[Visual Basic]

The Enabled property gets or sets a Boolean value that indicates whether the Web filter is enabled.

Property Enabled As Boolean

Property Value

Boolean value that indicates whether the Web filter is enabled.

Remarks

This property is read/write.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCWebFilter


IFPCWebFilter | FPCWebFilter FilterDirection property [ISA Server 2004]

FilterDirection Property of IFPCWebFilter[C++]

FPCWebFilter.FilterDirection [Visual Basic]

[C++]

The FilterDirection property gets a value from the FpcFilterDirection enumerated type that specifies whether the Web filter operates in reverse proxy, forward proxy, or both modes.

HRESULT get_FilterDirection(
  FpcFilterDirection* pFilterDirection
);

Parameters

pFilterDirection
Pointer to a variable that on return receives a value from the FpcFilterDirection enumerated type that specifies whether the Web filter operates in reverse proxy, forward proxy, or both modes.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only. It is set when the object is created by a call to the Add method of the FPCWebFilters collection.

[Visual Basic]

The FilterDirection property gets a value from the FpcFilterDirection enumerated type that specifies whether the Web filter operates in reverse proxy, forward proxy, or both modes.

Property FilterDirection As FpcFilterDirection

Property Value

Value from the FpcFilterDirection enumerated type that specifies whether the Web filter operates in reverse proxy, forward proxy, or both modes.

Remarks

This property is read-only. It is set when the object is created by a call to the Add method of the FPCWebFilters collection.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCWebFilter


IFPCWebFilter | FPCWebFilter Guid(BSTR) property [ISA Server 2004]

Guid Property of IFPCWebFilter[C++]

FPCWebFilter.Guid [Visual Basic]

[C++]

The Guid property gets the vendor-supplied string-formatted globally unique identifier (GUID) for the filter.

HRESULT get_Guid(
  BSTR* pbstrGuid
);

Parameters

pbstrGuid
Pointer to a BSTR that is set on return to a string value specifying the string-formatted GUID for the filter.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

The GUID retrieved is formatted as a string in the form {12345678-1234-1234-1234-123456789ABC}. Note the presence of the braces normally used with GUIDs.

[Visual Basic]

The Guid property gets the vendor-supplied string-formatted globally unique identifier (GUID) for the filter.

Property Guid As String

Property Value

String that specifies the string-formatted GUID for the filter.

Remarks

This property is read-only.

The GUID retrieved is formatted as a string in the form {12345678-1234-1234-1234-123456789ABC}. Note the presence of the braces normally used with GUIDs.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCWebFilter


IFPCWebFilter | FPCWebFilter Name(BSTR,BSTR) property [ISA Server 2004]

Name Property of IFPCWebFilter[C++]

FPCWebFilter.Name [Visual Basic]

[C++]

The Name property gets or sets the vendor-supplied name of the filter.

HRESULT get_Name(
  BSTR* pbstrName
);

HRESULT put_Name(
  BSTR bstrName
);

Parameters

pbstrName
Pointer to a BSTR that is set on return to a string value specifying the vendor-supplied name of the filter.
bstrName
BSTR that specifies the vendor-supplied name of the filter.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write.

[Visual Basic]

The Name property gets or sets the vendor-supplied name of the filter.

Property Name As String

Property Value

String that specifies the vendor-supplied name of the filter.

Remarks

This property is read/write.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCWebFilter


IFPCWebFilter | FPCWebFilter Order(long) property [ISA Server 2004]

Order Property of IFPCWebFilter[C++]

FPCWebFilter.Order [Visual Basic]

[C++]

The Order property gets the ordinal position of the Web filter in the list of Web filters, which establishes the order in which Web filters of the same priority receive data.

HRESULT get_Order(
  long* plOrder
);

Parameters

plOrder
Pointer to a variable that receives a 32-bit integer specifying the ordinal position of the Web filter in the list of Web filters.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only. It can be modified by calling the MoveUp and MoveDown methods of the FPCWebFilters collection. Because these methods change the ordinal positions of more than one rule in the collection, the Save method must be called on the collection to write the changes to persistent storage.

[Visual Basic]

The Order property gets the ordinal position of the Web filter in the list of Web filters, which establishes the order in which Web filters of the same priority receive data.

Property Order As Long

Property Value

A 32-bit integer that specifies the ordinal position of the Web filter in the list of Web filters.

Remarks

This property is read-only. It can be modified by calling the MoveUp and MoveDown methods of the FPCWebFilters collection. Because these methods change the ordinal positions of more than one rule in the collection, the Save method must be called on the collection to write the changes to persistent storage.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCWebFilter


IFPCWebFilter | FPCWebFilter Priority (2 Parameters) property [ISA Server 2004]

Priority Property of IFPCWebFilter[C++]

FPCWebFilter.Priority [Visual Basic]

[C++]

The Priority property gets or sets a value from the FpcFilterPriority enumerated type that specifies the priority of the Web filter.

HRESULT get_Priority(
  FpcFilterPriority* pFilterPriority
);

HRESULT put_Priority(
  FpcFilterPriority FilterPriority
);

Parameters

pFilterPriority
Pointer to a variable that on return receives a value from the FpcFilterPriority enumerated type that specifies the priority of the Web filter. The possible values are fpcFilterPriority_Low, fpcFilterPriority_Medium, or fpcFilterPriority_High.
FilterPriority
Value from the FpcFilterPriority enumerated type that specifies the priority of the Web filter. The possible values are fpcFilterPriority_Low, fpcFilterPriority_Medium, or fpcFilterPriority_High.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write.

[Visual Basic]

The Priority property gets or sets a value from the FpcFilterPriority enumerated type that specifies the priority of the Web filter.

Property Priority As FpcFilterPriority

Property Value

Value from the FpcFilterPriority enumerated type that specifies the priority of the Web filter. The possible values are fpcFilterPriority_Low, fpcFilterPriority_Medium, or fpcFilterPriority_High.

Remarks

This property is read/write.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCWebFilter


IFPCWebFilter | FPCWebFilter RelativePath(BSTR,BSTR) property [ISA Server 2004]

RelativePath Property of IFPCWebFilter[C++]

FPCWebFilter.RelativePath [Visual Basic]

[C++]

The RelativePath property gets or sets the filter dynamic-link library (DLL) path relative to the Isapi folder under the ISA Server installation folder.

HRESULT get_RelativePath(
  BSTR* pbstrPath
);

HRESULT put_RelativePath(
  BSTR bstrPath
);

Parameters

pbstrPath
Pointer to a BSTR that is set on return to a string value specifying the relative path of the filter DLL.
bstrPath
BSTR that specifies the relative path of the filter DLL.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write.

[Visual Basic]

The RelativePath property gets or sets the filter dynamic-link library (DLL) path relative to the Isapi folder under the ISA Server installation folder.

Property RelativePath As String

Property Value

String that specifies the relative path of the filter DLL.

Remarks

This property is read/write.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCWebFilter


IFPCWebFilter | FPCWebFilter Vendor(BSTR,BSTR) property [ISA Server 2004]

Vendor Property of IFPCWebFilter[C++]

FPCWebFilter.Vendor [Visual Basic]

[C++]

The Vendor property gets or sets the name of the vendor that wrote the filter.

HRESULT get_Vendor(
  BSTR* pbstrVendor
);

HRESULT put_Vendor(
  BSTR bstrVendor
);

Parameters

pbstrVendor
Pointer to a BSTR that is set on return to a string value specifying the name of the vendor that wrote the filter.
bstrVendor
BSTR that specifies the name of the vendor that wrote the filter.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write.

[Visual Basic]

The Vendor property gets or sets the name of the vendor that wrote the filter.

Property Vendor As String

Property Value

String that specifies the name of the vendor that wrote the filter.

Remarks

This property is read/write.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCWebFilter


IFPCWebFilter | FPCWebFilter Version(BSTR,BSTR) property [ISA Server 2004]

Version Property of IFPCWebFilter[C++]

FPCWebFilter.Version [Visual Basic]

[C++]

The Version property gets or sets the vendor-supplied version of the filter.

HRESULT get_Version(
  BSTR* pbstrVersion
);

HRESULT put_Version(
  BSTR bstrVersion
);

Parameters

pbstrVersion
Pointer to a BSTR that is set on return to a string value specifying the vendor-supplied version of the filter.
bstrVersion
BSTR that specifies the vendor-supplied version of the filter.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write.

[Visual Basic]

The Version property gets or sets the vendor-supplied version of the filter.

Property Version As String

Property Value

String that specifies the vendor-supplied version of the filter.

Remarks

This property is read/write.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCWebFilter


FPCWebFilters collection [ISA Server 2004]

FPCWebFilters Collection

The FPCWebFilters collection holds an ordered set of FPCWebFilter objects.

This collection is typically accessed through the WebFilters property of the FPCExtensions object.

Click here to see the ISA Server object hierarchy.

Inheritance

This collection inherits from the FPCPersist object, which contains methods and properties related to the persistent storage of an object's data. They include methods for exporting the object's data to and importing it from an XML document.

Methods

The FPCWebFilters collection defines the following methods.

Method | Description
Add | Creates a new FPCWebFilter object, adds it to the collection, and returns a reference to it.
Item | Retrieves the requested FPCWebFilter object from the collection.
MoveDown | Moves the given filter one step down the list of Web filters.
MoveUp | Moves the given filter one step up the list of Web filters.
Remove | Removes a specified Web filter object from the collection.

Properties

The FPCWebFilters collection has the following properties.

Property | Description
_NewEnum | Gets an enumerator object for the collection.
Count | Gets the number of Web filters in the collection.

Methods Inherited from FPCPersist

Name | Description
CancelWaitForChanges | Cancels the registration established by the WaitForChanges method (for use in C and C++ programming only).
CanImport | Returns a Boolean value that indicates whether the properties of the collection and its elements can be imported from the specified XML document.
Export | Writes the stored values of all the properties of the collection and its elements to the specified XML document.
ExportToFile | Writes the stored values of all the properties of the collection and its elements to the specified XML file.
GetServiceRestartMask | Retrieves a 32-bit bitmask of the FpcServices enumerated type that specifies which services need to be restarted for currently unsaved changes to take effect.
Import | Copies the values of all the properties of the collection and its elements from the specified XML document to persistent storage.
ImportFromFile | Copies the values of all the properties of the collection and its elements from the specified XML file to persistent storage.
LoadDocProperties | Provides the XML document's properties so that you can know what information can be imported from the document.
Refresh | Reads the values of all the properties of the collection and its elements from persistent storage, overwriting any changes that have not been saved.
Save | Writes the current values of all the properties of the collection and its elements to persistent storage.
WaitForChanges | Registers to wait for an event indicating that the contents of the object have changed (for use in C and C++ programming only).

Properties Inherited from FPCPersist

Name | Description
PersistentName | Gets the persistent name of the collection. The persistent name of an object is a name that is unique for the object at the respective level of the COM object hierarchy.
VendorParametersSets | Gets an FPCVendorParametersSets collection that can hold sets of custom data for extending the collection.

Remarks

This collection implements the IFPCWebFilters interface.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

COM Objects


IFPCWebFilters | FPCWebFilters _NewEnum(IUnknown) property [ISA Server 2004]

_NewEnum Property of IFPCWebFilters[C++]

FPCWebFilters._NewEnum [Visual Basic]

[C++]

The _NewEnum property gets an enumerator object for the collection. An enumerator object provides serial access to the elements of the collection.

HRESULT get__NewEnum(
  IUnknown* ppEnum
);

Parameters

ppEnum
Address of an interface pointer that on return points to the IUnknown interface of an enumerator object that implements an IEnumVARIANT interface for the collection. An interface pointer to the IEnumVARIANT interface of the enumerator object can be retrieved by calling QueryInterface on the IUnknown interface returned.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The _NewEnum property gets an enumerator object for the collection. An enumerator object provides serial access to the elements of the collection.

Property _NewEnum As IUnknown

Property Value

Reference to an enumerator object that provides serial access to the elements of the collection.

Remarks

This property is read-only.

In Visual Basic and VBScript, this property is used implicitly in For Each...In...Next constructs.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCWebFilters


IFPCWebFilters | FPCWebFilters Add (6 Parameters) method [ISA Server 2004]

IFPCWebFilters::Add[C++]

FPCWebFilters.Add [Visual Basic]

[C++]

The Add method creates a new FPCWebFilter object in the collection and returns a reference to it.

HRESULT Add(
  BSTR Guid,
  BSTR Name,
  BSTR RelativePath,
  FpcFilterPriority Priority,
  FpcFilterDirection Direction,
  IFPCWebFilter** ppNewFilter
);

Parameters

Guid
[in] Required. String that specifies the GUID of the new filter.
Name
[in] Required. String that specifies the display name of the new filter.
RelativePath
[in] Required. String that specifies the path of the filter's DLL relative to the ISA Server installation folder (such as C:\Program Files\Microsoft ISA Server\).
Priority
[in] Value from the FpcFilterPriority enumerated type that specifies the priority of the new filter. The possible values are fpcFilterPriority_Low, fpcFilterPriority_Medium, or fpcFilterPriority_High.
Direction
[in] Value from the FpcFilterDirection enumerated type that specifies whether the new filter operates in the forward proxy mode, in the reverse proxy mode, or in both modes.
ppNewFilter
[out] Address of an interface pointer that on return points to the new IFPCWebFilter interface created.

Return Values

This method can return one of the following:

  • S_OK, indicating that the operation succeeded.
  • An error code, indicating that the operation failed. In this case, the [out] parameter returned is a null object.
[Visual Basic]

The Add method creates a new FPCWebFilter object in the collection and returns a reference to it.

Function Add( _
  ByVal Guid As String, _
  ByVal Name As String, _
  ByVal RelativePath As String, _
  ByVal Priority As FpcFilterPriority, _
  ByVal Direction As FpcFilterDirection _
) As FPCWebFilter

Parameters

Guid
[in] Required. String that specifies the GUID of the new filter.
Name
[in] Required. String that specifies the display name of the new filter.
RelativePath
[in] Required. String that specifies the path of the filter's DLL relative to the ISA Server installation folder (such as C:\Program Files\Microsoft ISA Server\).
Priority
[in] Value from the FpcFilterPriority enumerated type that specifies the priority of the new filter. The possible values are fpcFilterPriority_Low, fpcFilterPriority_Medium, or fpcFilterPriority_High.
Direction
[in] Value from the FpcFilterDirection enumerated type that specifies whether the new filter operates in the forward proxy mode, in the reverse proxy mode, or in both modes.

Return Values

This method returns a reference to an FPCWebFilter object if successful. Otherwise, an error is raised that can be intercepted by using an error handler.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCWebFilters


IFPCWebFilters | FPCWebFilters Count(long) property [ISA Server 2004]

Count Property of IFPCWebFilters[C++]

FPCWebFilters.Count [Visual Basic]

[C++]

The Count property gets the number of FPCWebFilter objects in the collection.

HRESULT get_Count(
  long* plCount
);

Parameters

plCount
Pointer to a variable that receives a 32-bit integer specifying the number of FPCWebFilter objects in the collection.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The Count property gets the number of FPCWebFilter objects in the collection.

Property Count As Long

Property Value

A 32-bit integer that specifies the number of FPCWebFilter objects in the collection.

Remarks

This property is read-only.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCWebFilters


IFPCWebFilters | FPCWebFilters Item (2 Parameters) method [ISA Server 2004]

IFPCWebFilters::Item[C++]

FPCWebFilters.Item [Visual Basic]

[C++]

The Item method retrieves the requested IFPCWebFilter interface from the collection.

HRESULT Item(
  VARIANT Index,
  IFPCWebFilter** ppItem
);

Parameters

Index
[in] Required. GUID or one-based index of the object to retrieve.
ppItem
[out] Address of an interface pointer that on return points to the IFPCWebFilter interface requested.

Return Values

This method can return one of the following:

  • S_OK, indicating that the operation succeeded.
  • An error message, indicating that the operation failed. In this case, the [out] parameter returned is a null object.
[Visual Basic]

The Item method retrieves the requested FPCWebFilter object from the collection.

Function Item( _
  ByVal Index As Variant _
) As FPCWebFilter

Parameters

Index
[in] Required. GUID or one-based index of the object to retrieve.

Return Values

This method returns a reference to the FPCWebFilter object requested if successful. Otherwise, an error is raised that can be intercepted by using an error handler.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCWebFilters


IFPCWebFilters | FPCWebFilters MoveDown(Long) method [ISA Server 2004]

IFPCWebFilters::MoveDown[C++]

FPCWebFilters.MoveDown [Visual Basic]

[C++]

The MoveDown method moves the specified filter one step down the list of filters.

HRESULT MoveDown(
  long Index
);

Parameters

Index
[in] Required. Index (the current position indicated by the Order property) of the filter to move down.

Return Values

This method returns S_OK if the call is successful; otherwise, it returns an error code.
[Visual Basic]

The MoveDown method moves the specified filter one step down the list of filters.

Sub MoveDown( _
  ByVal Index As Long _
)

Parameters

Index
[in] Required. Index (the current position indicated by the Order property) of the filter to move down.

Return Values

This method has no return values. If the call is unsuccessful, an error is raised that can be intercepted by using an error handler.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCWebFilters, MoveUp


IFPCWebFilters | FPCWebFilters MoveUp(Long) method [ISA Server 2004]

IFPCWebFilters::MoveUp[C++]

FPCWebFilters.MoveUp [Visual Basic]

[C++]

The MoveUp method moves the specified filter one step up the list of filters.

HRESULT MoveUp(
  long Index
);

Parameters

Index
[in] Required. Index (the current position indicated by the Order property) of the filter to move down.

Return Values

This method returns S_OK if the call is successful; otherwise, it returns an error code.
[Visual Basic]

The MoveUp method moves the specified filter one step up the list of filters.

Sub MoveUp( _
  ByVal Index As Long _
)

Parameters

Index
[in] Required. Index (the current position indicated by the Order property) of the filter to move down.

Return Values

This method has no return values. If the call is unsuccessful, an error is raised that can be intercepted by using an error handler.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCWebFilters


IFPCWebFilters | FPCWebFilters Remove(Variant) method [ISA Server 2004]

IFPCWebFilters::Remove[C++]

FPCWebFilters.Remove [Visual Basic]

[C++]

The Remove method removes the specified FPCWebFilter object from the collection.

HRESULT Remove(
  VARIANT Index
);

Parameters

Index
[in] Required. GUID or one-based index of the FPCWebFilter object to remove.

Return Values

This method returns S_OK if the call is successful; otherwise, it returns an error code.
[Visual Basic]

The Remove method removes the specified FPCWebFilter object from the collection.

Sub Remove( _
  ByVal Index As Variant _
)

Parameters

Index
[in] Required. GUID or one-based index of the FPCWebFilter object to remove.

Return Values

This method has no return values. If the call is unsuccessful, an error is raised that can be intercepted by using an error handler.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCWebFilters


FPCWebListener object [ISA Server 2004]

FPCWebListener

The FPCWebListener object represents a single Web listener. A Web listener is a rule element that can be used in a Web publishing rule. By default, every incoming Web request must go through the Web listener that is specified for the Web publishing rule that allows the request.

This object is typically an element of an FPCWebListeners collection.

Click here to see the ISA Server object hierarchy.

Inheritance

This object inherits from the FPCPersist object, which contains methods and properties related to the persistent storage of an object's data. They include methods for exporting the object's data to and importing it from an XML document.

Methods

This object has no methods.

Properties

The FPCWebListener object has the following properties.

Property | Description
Description | Gets or sets the description of the Web listener.
IPsOnNetworks | Gets an FPCIPsOnNetworks collection that contains IP addresses on which the Web listener listens.
Name | Gets or sets the name of the Web listener.
Properties | Gets an FPCWebListenerProperties object that contains the properties of the Web listener.
SourceNetworkSets | Gets an FPCRefs collection that contains references to the network sets to which the Web listener listens.

Methods Inherited from FPCPersist

Name | Description
CancelWaitForChanges | Cancels the registration established by the WaitForChanges method (for use in C and C++ programming only).
CanImport | Returns a Boolean value that indicates whether the object's properties can be imported from the specified XML document.
Export | Recursively writes the stored values of all the properties of the object and its subobjects to the specified XML document.
ExportToFile | Recursively writes the stored values of all the properties of the object and its subobjects to the specified XML file.
GetServiceRestartMask | Retrieves a 32-bit bitmask of the FpcServices enumerated type that specifies which services need to be restarted for currently unsaved changes to take effect.
Import | Recursively copies the values of all the properties of the object and of its subobjects from the specified XML document to persistent storage.
ImportFromFile | Recursively copies the values of all the properties of the object and of its subobjects from the specified XML file to persistent storage.
LoadDocProperties | Provides the XML document's properties so that you can know what information can be imported from the document.
Refresh | Recursively reads the values of all the properties of the object and of its subobjects from persistent storage, overwriting any changes that have not been saved.
Save | Recursively writes the current values of all the properties of the object and its subobjects to persistent storage.
WaitForChanges | Registers to wait for an event indicating that the contents of the object have changed (for use in C and C++ programming only).

Properties Inherited from FPCPersist

Name | Description
PersistentName | Gets the persistent name of the object. The persistent name of an object is a name that is unique for the object at the respective level of the COM object hierarchy.
VendorParametersSets | Gets an FPCVendorParametersSets collection that can hold sets of custom data for extending the object.

Remarks

This collection implements the IFPCWebListener interface.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

COM Objects


IFPCWebListener | FPCWebListener Description property [ISA Server 2004]

Description Property of IFPCWebListener[C++]

FPCWebListener.Description [Visual Basic]

[C++]

The Description property gets or sets the description of the Web listener.

HRESULT get_Description(
  BSTR* pbstrDescription
);

HRESULT put_Description(
  BSTR bstrDescription
);

Parameters

pbstrDescription
Pointer to a BSTR that is set on return to a string value specifying the description of the Web listener.
bstrDescription
String that specifies the description of the Web listener.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write.

[Visual Basic]

The Description property gets or sets the description of the Web listener.

Property Description As String

Property Value

String that specifies the description of the Web listener.

Remarks

This property is read/write.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCWebListener


IFPCWebListener | FPCWebListener IPsOnNetworks property [ISA Server 2004]

IPsOnNetworks Property of IFPCWebListener[C++]

FPCWebListener.IPsOnNetworks [Visual Basic]

[C++]

The IPsOnNetworks property gets an FPCIPsOnNetworks collection that contains IP addresses on which the Web listener listens.

HRESULT get_IPsOnNetworks(
  IFPCIPsOnNetworks** ppIPsOnNetworks
);

Parameters

ppIPsOnNetworks
Address of an interface pointer that on return points to an IFPCIPsOnNetworks interface that represents a collection of IP addresses on which the Web listener listens.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only. It can be modified by calling the properties and methods of the IFPCIPsOnNetworks interface retrieved.

[Visual Basic]

The IPsOnNetworks property gets an FPCIPsOnNetworks collection that contains IP addresses on which the Web listener listens.

Property IPsOnNetworks As FPCIPsOnNetworks

Property Value

Reference to an FPCIPsOnNetworks collection that contains IP addresses on which the Web listener listens.

Remarks

This property is read-only. It can be modified by modifying the FPCIPsOnNetworks collection retrieved.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCWebListener


IFPCWebListener | FPCWebListener Name(BSTR,BSTR) property [ISA Server 2004]

Name Property of IFPCWebListener[C++]

FPCWebListener.Name [Visual Basic]

[C++]

The Name property gets or sets the name of the Web listener.

HRESULT get_Name(
  BSTR* pbstrName
);

HRESULT put_Name(
  BSTR bstrName
);

Parameters

pbstrName
Pointer to a BSTR that is set on return to a string value specifying the name of the Web listener.
bstrName
BSTR that specifies the name of the Web listener.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write.

[Visual Basic]

The Name property gets or sets the name of the Web listener.

Property Name As String

Property Value

String that specifies the name of the Web listener.

Remarks

This property is read/write.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCWebListener


IFPCWebListener | FPCWebListener Properties property [ISA Server 2004]

Properties Property of IFPCWebListener[C++]

FPCWebListener.Properties [Visual Basic]

[C++]

The Properties property gets an FPCWebListenerProperties object that contains the properties of the Web listener.

HRESULT get_Properties(
  IFPCWebListenerProperties** ppWebListenerProperties
);

Parameters

ppWebListenerProperties
Address of an interface pointer that on return points to an IFPCWebListenerProperties interface that represents the properties of the Web listener.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only. It can be modified by using the properties of the IFPCWebListenerProperties interface retrieved.

[Visual Basic]

The Properties property gets an FPCWebListenerProperties object that contains the properties of the Web listener.

Property Properties As FPCWebListenerProperties

Property Value

Reference to an FPCWebListenerProperties object that contains the properties of the Web listener.

Remarks

This property is read-only. It can be modified by using the properties of the FPCWebListenerProperties object retrieved.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCWebListener


IFPCWebListener | FPCWebListener SourceNetworkSets property [ISA Server 2004]

SourceNetworkSets Property of IFPCWebListener[C++]

FPCWebListener.SourceNetworkSets [Visual Basic]

[C++]

The SourceNetworkSets property gets an FPCRefs collection that contains references to the network sets to which the Web listener listens.

HRESULT get_SourceNetworkSets(
  IFPCRefs** ppRefs
);

Parameters

ppRefs
Address of an interface pointer that on return points to an IFPCRefs interface that represents the collection of references to the network sets to which the Web listener listens.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only. It can be modified by calling the methods of the IFPCRefs interface retrieved.

[Visual Basic]

The SourceNetworkSets property gets an FPCRefs collection that contains references to the network sets to which the Web listener listens.

Property SourceNetworkSets As FPCRefs

Property Value

Reference to an FPCRefs collection that contains references to the network sets to which the Web listener listens.

Remarks

This property is read-only. It can be modified by calling the methods of the FPCRefs collection retrieved.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCWebListener


FPCWebListenerProperties object [ISA Server 2004]

FPCWebListenerProperties

The FPCWebListenerProperties object provides access to the properties of a Web listener for incoming or outgoing Web requests.

A Web listener can be configured to use Basic authentication, Digest authentication, Advanced Digest authentication, Integrated authentication, or Secure Sockets Layer (SSL) certificate authentication, or any combination of these methods to authenticate Web requests. Alternatively, a Web listener can be configured to use an authentication scheme defined by an FPCAuthenticationScheme object for authentication. The following authentication schemes are supplied with ISA Server 2004:

  • OWA Forms-Based.
  • RADIUS.
  • SecurID.

This object can be accessed through the Properties property of an FPCWebListener object, where it contains the properties of a Web listener for incoming Web requests, and through the WebListenerProperties property of an FPCNetwork object, where it contains the properties of a Web listener for outgoing Web requests.

Click here to see the ISA Server object hierarchy.

Methods

The FPCWebListenerProperties object defines the following methods.

Method | Description
Refresh | Recursively reads all the properties of the Web listener from persistent storage, overwriting any changes that were not saved.
Save | Recursively writes the current values of all of the object's properties, including all the properties of its subobject and its elements, to persistent storage.

Properties

The FPCWebListenerProperties object has the following properties.

Property | Description
AlwaysAuthenticate | Gets or sets a Boolean value that indicates whether the ISA Server Web proxy always authenticates requests even if the policy does not require authentication.
AppliedSSLCertificates | Gets an FPCAppliedSSLCertificates collection that contains the SSL server certificates used to authenticate the ISA Server computer when a client connects to the Web listener through the SSL port.
AuthenticationSchemes | Gets an FPCRefs collection that contains references to the FPCAuthenticationScheme objects defining the authentication schemes available to the Web listener.
BasicAuthentication | Gets or sets a Boolean value that indicates whether Basic authentication is used.
BasicAuthPersistSingleRequest | Gets or sets a Boolean value that indicates whether Basic authentication persists across requests, thereby lasting throughout a session.
ConnectionTimeout | Gets or sets the time, in seconds, of inactivity allowed on a connection before the connection is closed.
DigestAuthentication | Gets or sets a Boolean value that indicates whether Digest authentication is used.
DigestAuthPersistSingleRequest | Gets or sets a Boolean value that indicates whether Digest authentication persists across requests, thereby lasting throughout a session.
DomainForAuthentication | Gets or sets the domain for Basic or Digest authentication.
IntegratedAuthPersistSingleRequest | Gets or sets a Boolean value that indicates whether the Windows Integrated authentication persists across requests, thereby lasting throughout a session.
IntegratedWindowsAuthentication | Gets or sets a Boolean value that indicates whether Windows Integrated authentication is used.
NumberOfConnections | Gets or sets the number of simultaneous connections allowed from the ISA Server Web proxy to the Internet.
ResolveInArray | Gets or sets a Boolean value that indicates whether the Web listener will attempt to retrieve the requested URL from the cache of the current array or directly from the external site.
ReturnAuthRequiredIfAuthUserDenied | Gets or sets a Boolean value that indicates whether to return a Proxy Authorization Required message when a user is authenticated by the Web proxy but is denied access by the rules.
SingleRadiusServerAuthPerSession | Gets or sets a Boolean value that indicates whether RADIUS authentication persists across requests, thereby lasting throughout a session.
SSLCertificateAuthentication | Gets or sets a Boolean value that indicates whether SSL certificate authentication is used.
SSLPort | Gets or sets the SSL port for the Web listener.
TCPPort | Gets or sets the TCP port for the Web listener.
UnlimitedNumberOfConnections | Gets or sets a Boolean value that indicates whether the Web proxy can have an unlimited number of connections.

Remarks

This object implements the IFPCWebListenerProperties interface.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

COM Objects


IFPCWebListenerProperties.AlwaysAuthenticate property [ISA Server 2004]

AlwaysAuthenticate Property of IFPCWebListenerProperties[C++]

FPCWebListenerProperties.AlwaysAuthenticate [Visual Basic]

[C++]

The AlwaysAuthenticate property gets or sets a Boolean value that indicates whether the ISA Server Web proxy always authenticates requests even if the policy does not require authentication.

HRESULT get_AlwaysAuthenticate(
  VARIANT_BOOL** pfAlwaysAuthenticate
);

HRESULT put_AlwaysAuthenticate(
  VARIANT_BOOL fAlwaysAuthenticate
);

Parameters

pfAlwaysAuthenticate
Pointer to a Boolean variable that is set on return to VARIANT_TRUE if the Web proxy always authenticates requests, or to VARIANT_FALSE if the Web proxy authenticates requests when required by the policy.
fAlwaysAuthenticate
Boolean value that indicates whether the Web proxy always authenticates a request.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write.

[Visual Basic]

The AlwaysAuthenticate property gets or sets a Boolean value that indicates whether the ISA Server Web proxy always authenticates requests even if the policy does not require authentication.

Property AlwaysAuthenticate As Boolean

Property Value

Boolean value that indicates whether the Web proxy always authenticates requests.

Remarks

This property is read/write.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCWebListenerProperties


IFPCWebListenerProperties.AppliedSSLCertificates property [ISA Server 2004]

AppliedSSLCertificates Property of IFPCWebListenerProperties[C++]

FPCWebListenerProperties.AppliedSSLCertificates [Visual Basic]

[C++]

The AppliedSSLCertificates property gets an FPCAppliedSSLCertificates collection that contains the Secure Sockets Layer (SSL) server certificates used to authenticate the ISA Server computer when a client connects to the Web listener through the SSL port.

HRESULT get_AppliedSSLCertificates(
  IFPCAppliedSSLCertificates** ppAppliedSSLCertificates
);

Parameters

ppAppliedSSLCertificates
Address of an interface pointer that on return points to an IFPCAppliedSSLCertificates interface that represents the collection of SSL server certificates used to authenticate the ISA Server computer.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only. SSL server certificates can be added and removed and their properties can be obtained by calling the methods of the IFPCAppliedSSLCertificates interface retrieved.

The SSL port is specified by the SSLPort property.

[Visual Basic]

The AppliedSSLCertificates property gets an FPCAppliedSSLCertificates collection that contains the Secure Sockets Layer (SSL) server certificates used to authenticate the ISA Server computer when a client connects to the Web listener through the SSL port.

Property AppliedSSLCertificates As FPCAppliedSSLCertificates

Property Value

Reference to an FPCAppliedSSLCertificates collection that contains the SSL server certificates used to authenticate the ISA Server computer.

Remarks

This property is read-only. SSL server certificates can be added and removed and their properties can be obtained by calling the methods of the FPCAppliedSSLCertificates collection retrieved.

The SSL port is specified by the SSLPort property.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCWebListenerProperties


IFPCWebListenerProperties.AuthenticationSchemes property [ISA Server 2004]

AuthenticationSchemes Property of IFPCWebListenerProperties[C++]

FPCWebListenerProperties.AuthenticationSchemes [Visual Basic]

[C++]

The AuthenticationSchemes property gets an FPCRefs collection that contains references to the FPCAuthenticationScheme objects defining the authentication schemes available to the Web listener.

HRESULT get_AuthenticationSchemes(
  IFPCRefs** ppRefs
);

Parameters

ppRefs
Address of an interface pointer that on return points to an IFPCRefs interface that represents the collection of references to the authentication schemes available to the Web listener.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only. References to authentication schemes can be added and removed by calling the methods of the IFPCRefs interface retrieved.

[Visual Basic]

The AuthenticationSchemes property gets an FPCRefs collection that contains references to the FPCAuthenticationScheme objects defining the authentication schemes available to the Web listener.

Property AuthenticationSchemes As FPCRefs

Property Value

Reference to an FPCRefs collection that contains references to the FPCAuthenticationScheme objects defining the authentication schemes available to the Web listener.

Remarks

This property is read-only. References to authentication schemes can be added and removed by calling the methods of the FPCRefs collection retrieved.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCWebListenerProperties


IFPCWebListenerProperties.BasicAuthentication property [ISA Server 2004]

BasicAuthentication Property of IFPCWebListenerProperties[C++]

FPCWebListenerProperties.BasicAuthentication [Visual Basic]

[C++]

The BasicAuthentication property gets or sets a Boolean value that indicates whether Basic authentication is used.

HRESULT get_BasicAuthentication(
  VARIANT_BOOL* pfBasicAuthentication
);

HRESULT put_BasicAuthentication(
  VARIANT_BOOL fBasicAuthentication
);

Parameters

pfBasicAuthentication
Pointer to a Boolean variable that is set on return to VARIANT_TRUE if Basic authentication is used, or to VARIANT_FALSE if Basic authentication is not used.
fBasicAuthentication
Boolean value that indicates whether Basic authentication is used.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write.

The standard Hypertext Transfer Protocol (HTTP) method of authentication is Basic authentication. Basic authentication sends and receives user information as text characters that can be easily read. Although passwords and user names are encoded, no encryption is used with Basic authentication. The following describes the authentication procedure for Basic authentication:

  1. The client prompts the user for credentials, which consist of a user name and password.
  2. The credentials are then encoded by the client and sent to the server.
  3. The user name is verified as being an account on the ISA Server computer or in a trusted domain of the ISA Server computer.

Basic authentication can be enabled for a Web listener together with Digest authentication, Integrated authentication, and SSL certificate authentication.

[Visual Basic]

The BasicAuthentication property gets or sets a Boolean value that indicates whether Basic authentication is used.

Property BasicAuthentication As Boolean

Property Value

Boolean value that indicates whether Basic authentication is used.

Remarks

This property is read/write.

The standard Hypertext Transfer Protocol (HTTP) method of authentication is Basic authentication. Basic authentication sends and receives user information as text characters that can be easily read. Although passwords and user names are encoded, no encryption is used with Basic authentication. The following describes the authentication procedure for Basic authentication:

  1. The client prompts the user for credentials, which consist of a user name and password.
  2. The credentials are then encoded by the client and sent to the server.
  3. The user name is verified as being an account on the ISA Server computer or in a trusted domain of the ISA Server computer.

Basic authentication can be enabled for a Web listener together with Digest authentication, Integrated authentication, and SSL certificate authentication.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCWebListenerProperties


BasicAuthPersistSingleRequest property [ISA Server 2004]

BasicAuthPersistSingleRequest Property of IFPCWebListenerProperties[C++]

FPCWebListenerProperties.BasicAuthPersistSingleRequest [Visual Basic]

[C++]

The BasicAuthPersistSingleRequest property gets or sets a Boolean value that indicates whether Basic authentication persists across requests, thereby lasting throughout a session.

HRESULT get_BasicAuthPersistSingleRequest(
  VARIANT_BOOL* pfBasicSingleRequest
);

HRESULT put_BasicAuthPersistSingleRequest(
  VARIANT_BOOL fBasicSingleRequest
);

Parameters

pfBasicSingleRequest
[out] Pointer to a Boolean variable that is set on return to VARIANT_TRUE if Basic authentication persists throughout a session, or to VARIANT_FALSE if Basic authentication does not persist throughout a session.
fBasicSingleRequest
[in] Boolean value that indicates whether Basic authentication persists throughout a session.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write.

[Visual Basic]

The BasicAuthPersistSingleRequest property gets or sets a Boolean value that indicates whether Basic authentication persists across requests, thereby lasting throughout a session.

Property BasicAuthPersistSingleRequest As Boolean

Property Value

Boolean value that indicates whether Basic authentication persists throughout a session.

Remarks

This property is read/write.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCWebListenerProperties


IFPCWebListenerProperties.ConnectionTimeout property [ISA Server 2004]

ConnectionTimeout Property of IFPCWebListenerProperties[C++]

FPCWebListenerProperties.ConnectionTimeout [Visual Basic]

[C++]

The ConnectionTimeout property gets or sets the time, in seconds, of inactivity allowed on a connection before the connection is closed.

HRESULT get_ConnectionTimeout(
  long** plTime
);

HRESULT put_ConnectionTimeout(
  long lTime
);

Parameters

plTime
Pointer to a variable that on return receives a 32-bit integer specifying the time, in seconds, of inactivity allowed on a connection before the connection is closed.
lTime
A 32-bit integer that specifies time, in seconds, of inactivity allowed on a connection before the connection is closed.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write.

[Visual Basic]

The ConnectionTimeout property gets or sets the time, in seconds, of inactivity allowed on a connection before the connection is closed.

Property ConnectionTimeout As Long

Property Value

A 32-bit integer that specifies time, in seconds, of inactivity allowed on a connection before the connection is closed.

Remarks

This property is read/write.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCWebListenerProperties


IFPCWebListenerProperties.DigestAuthentication property [ISA Server 2004]

DigestAuthentication Property of IFPCWebListenerProperties[C++]

FPCWebListenerProperties.DigestAuthentication [Visual Basic]

[C++]

The DigestAuthentication property gets or sets a Boolean value that indicates whether Digest authentication is used.

HRESULT get_DigestAuthentication(
  VARIANT_BOOL* pfDigestAuthentication
);

HRESULT put_DigestAuthentication(
  VARIANT_BOOL fDigestAuthentication
);

Parameters

pfDigestAuthentication
Pointer to a Boolean variable that is set on return to VARIANT_TRUE if Digest authentication is used, or to VARIANT_FALSE if Digest authentication is not used.
fDigestAuthentication
Boolean value that indicates whether Digest authentication is used.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write.

Digest authentication offers the same features as Basic authentication but involves a different way of transmitting the client's identity. The authentication credentials (the user name and password) pass through a one-way process, often referred to as hashing. The result of this process is a fixed-length value called a hash or digest, which is not feasibly decrypted—the original user name and password cannot be recovered from the hash value.

Additional information is added to the password before hashing so that no one can capture the password hash and use it to impersonate the true user. Values are added that help to identify the user, the user's computer, and the domain to which the user belongs. A time stamp is added to prevent a user from using a password after it has been revoked. This is an advantage over Basic authentication, because the password cannot be intercepted and used by an unauthorized person.

If this property is set to VARIANT_TRUE and the UseDigestSSP property of the IFPCWebProxy interface is set to VARIANT_TRUE, Advanced Digest authentication will be used instead of Digest authentication provided all the conditions for using Advanced Digest authentication are met.

Digest authentication can be enabled for a Web listener together with Basic authentication, Integrated authentication, and SSL certificate authentication.

[Visual Basic]

The DigestAuthentication property gets or sets a Boolean value that indicates whether Digest authentication is used.

Property DigestAuthentication As Boolean

Property Value

Boolean value that indicates whether Digest authentication is used.

Remarks

This property is read/write.

Digest authentication offers the same features as Basic authentication but involves a different way of transmitting the client's identity. The authentication credentials (the user name and password) pass through a one-way process, often referred to as hashing. The result of this process is a fixed-length value called a hash or digest, which is not feasibly decrypted—the original user name and password cannot be recovered from the hash value.

Additional information is added to the password before hashing so that no one can capture the password hash and use it to impersonate the true user. Values are added that help to identify the user, the user's computer, and the domain to which the user belongs. A time stamp is added to prevent a user from using a password after it has been revoked. This is an advantage over Basic authentication, because the password cannot be intercepted and used by an unauthorized person.

If this property is set to True and the UseDigestSSP property of the FPCWebProxy object is set to True, Advanced Digest authentication will be used instead of Digest authentication provided all the conditions for using Advanced Digest authentication are met.

Digest authentication can be enabled for a Web listener together with Basic authentication, Integrated authentication, and SSL certificate authentication.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCWebListenerProperties


DigestAuthPersistSingleRequest property [ISA Server 2004]

DigestAuthPersistSingleRequest Property of IFPCWebListenerProperties[C++]

FPCWebListenerProperties.DigestAuthPersistSingleRequest [Visual Basic]

[C++]

The DigestAuthPersistSingleRequest property gets or sets a Boolean value that indicates whether Digest authentication persists across requests, thereby lasting throughout a session.

HRESULT get_DigestAuthPersistSingleRequest(
  VARIANT_BOOL* pfDigestPerSingleRequest
);

HRESULT put_DigestAuthPersistSingleRequest(
  VARIANT_BOOL fDigestPerSingleRequest
);

Parameters

pfDigestPerSingleRequest
[out] Pointer to a Boolean variable that is set on return to VARIANT_TRUE if Digest authentication persists throughout a session, or to VARIANT_FALSE if Digest authentication does not persist throughout a session.
fDigestPerSingleRequest
[in] Boolean value that indicates whether Digest authentication persists throughout a session.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write.

[Visual Basic]

The DigestAuthPersistSingleRequest property gets or sets a Boolean value that indicates whether Digest authentication persists across requests, thereby lasting throughout a session.

Property DigestAuthPersistSingleRequest As Boolean

Property Value

Boolean value that indicates whether Digest authentication persists throughout a session.

Remarks

This property is read/write.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCWebListenerProperties


IFPCWebListenerProperties.DomainForAuthentication property [ISA Server 2004]

DomainForAuthentication Property of IFPCWebListenerProperties[C++]

FPCWebListenerProperties.DomainForAuthentication [Visual Basic]

[C++]

The DomainForAuthentication property gets or sets the domain for Basic or Digest authentication.

HRESULT get_DomainForAuthentication(
  BSTR* pbstrDomain
);

HRESULT put_DomainForAuthentication(
  BSTR bstrDomain
);

Parameters

pbstrDomain
Pointer to a BSTR that is set on return to a string value specifying the name of the domain for authentication.
bstrDomain
BSTR that specifies the name of the domain for authentication.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write.

[Visual Basic]

The DomainForAuthentication property gets or sets the domain for Basic or Digest authentication.

Property DomainForAuthentication As String

Property Value

String that specifies the name of the domain for authentication.

Remarks

This property is read/write.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCWebListenerProperties


IntegratedAuthPersistSingleRequest property [ISA Server 2004]

IntegratedAuthPersistSingleRequest Property of IFPCWebListenerProperties[C++]

FPCWebListenerProperties.IntegratedAuthPersistSingleRequest [Visual Basic]

[C++]

The IntegratedAuthPersistSingleRequest property gets or sets a Boolean value that indicates whether Windows Integrated authentication persists across requests, thereby lasting throughout a session.

HRESULT get_IntegratedAuthPersistSingleRequest(
  VARIANT_BOOL* pfIntegratedPerSingleRequest
);

HRESULT put_IntegratedAuthPersistSingleRequest(
  VARIANT_BOOL fIntegratedPerSingleRequest
);

Parameters

pfIntegratedPerSingleRequest
[out] Pointer to a Boolean variable that is set on return to VARIANT_TRUE if Integrated authentication persists throughout a session, or to VARIANT_FALSE if Integrated authentication does not persist throughout a session.
fIntegratedPerSingleRequest
[in] Boolean value that indicates whether Integrated authentication persists throughout a session.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write.

[Visual Basic]

The IntegratedAuthPersistSingleRequest property gets or sets a Boolean value that indicates whether Windows Integrated authentication persists across requests, thereby lasting throughout a session.

Property IntegratedAuthPersistSingleRequest As Boolean

Property Value

Boolean value that indicates whether Integrated authentication persists throughout a session.

Remarks

This property is read/write.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCWebListenerProperties


IntegratedWindowsAuthentication property [ISA Server 2004]

IntegratedWindowsAuthentication Property of IFPCWebListenerProperties[C++]

FPCWebListenerProperties.IntegratedWindowsAuthentication [Visual Basic]

[C++]

The IntegratedWindowsAuthentication property gets or sets a Boolean value that indicates whether Windows Integrated authentication is used. Integrated authentication is the default authentication for a new listen entry.

HRESULT get_IntegratedWindowsAuthentication(
  VARIANT_BOOL* pfIntegratedWindowsAuthentication
);

HRESULT put_IntegratedWindowsAuthentication(
  VARIANT_BOOL fIntegratedWindowsAuthentication
);

Parameters

pfIntegratedWindowsAuthentication
Pointer to a Boolean variable that is set on return to VARIANT_TRUE if Integrated authentication is used, or to VARIANT_FALSE if Integrated authentication is not used.
fIntegratedWindowsAuthentication
Boolean value that indicates whether Integrated authentication is used.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write.

Integrated authentication is a secure form of authentication, because the user name and password are not sent across the network. Integrated authentication can use either the Kerberos V5 authentication protocol or its own challenge/response authentication protocol.

Note In a pass-through authentication scenario, ISA Server does not support Kerberos V5 authentication, because Kerberos V5 requires that the client be able to identify the authenticating server.

Integrated authentication can be enabled for a Web listener together with Basic authentication, Digest authentication, and SSL certificate authentication.

[Visual Basic]

The IntegratedWindowsAuthentication property gets or sets a Boolean value that indicates whether Windows Integrated authentication is used. Integrated authentication is the default authentication for a new listen entry.

Property IntegratedWindowsAuthentication As Boolean

Property Value

Boolean value that indicates whether Integrated authentication is used.

Remarks

This property is read/write.

Integrated authentication is a secure form of authentication, because the user name and password are not sent across the network. Integrated authentication can use either the Kerberos V5 authentication protocol or its own challenge/response authentication protocol.

Note In a pass-through authentication scenario, ISA Server does not support Kerberos V5 authentication, because Kerberos V5 requires that the client be able to identify the authenticating server.

Integrated authentication can be enabled for a Web listener together with Basic authentication, Digest authentication, and SSL certificate authentication.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCWebListenerProperties


IFPCWebListenerProperties.NumberOfConnections property [ISA Server 2004]

NumberOfConnections Property of IFPCWebListenerProperties[C++]

FPCWebListenerProperties.NumberOfConnections [Visual Basic]

[C++]

The NumberOfConnections property gets or sets the number of simultaneous connections allowed from the ISA Server Web proxy to the Internet.

HRESULT get_NumberOfConnections(
  long** plNumber
);

HRESULT put_NumberOfConnections(
  long lNumber
);

Parameters

plNumber
Pointer to a variable that on return receives a 32-bit integer specifying the number of connections.
lNumber
A 32-bit integer value that specifies the number of connections.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write.

[Visual Basic]

The NumberOfConnections property gets or sets the number of simultaneous connections allowed from the ISA Server Web proxy to the Internet.

Property NumberOfConnections As Long

Property Value

A 32-bit integer value that specifies the number of connections.

Remarks

This property is read/write.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCWebListenerProperties


IFPCWebListenerProperties.Refresh method [ISA Server 2004]

IFPCWebListenerProperties::Refresh[C++]

FPCWebListenerProperties.Refresh [Visual Basic]

[C++]

The Refresh method reads the values of all of the object's properties from persistent storage, discarding any changes that have not been saved.

HRESULT Refresh();

Parameters

This method has no parameters.

Return Values

This method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

Changes made to this object can be saved by calling the Save method of this object or the Save method of any object containing it.

[Visual Basic]

The Refresh method reads the values of all of the object's properties from persistent storage, discarding any changes that have not been saved.

Sub Refresh()

Parameters

This method has no parameters.

Return Values

This method has no return values. If the call is unsuccessful, an error is raised that can be intercepted by using an error handler.

Remarks

Changes made to this object can be saved by calling the Save method of this object or the Save method of any object containing it.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCWebListenerProperties


IFPCWebListenerProperties.ResolveInArray property [ISA Server 2004]

ResolveInArray Property of IFPCWebListenerProperties[C++]

FPCWebListenerProperties.ResolveInArray [Visual Basic]

[C++]

The ResolveInArray property gets or sets a Boolean value that indicates whether the Web listener will attempt to retrieve the requested URL from the cache of the current array or directly from the external site. If it is set to VARIANT_TRUE, the Web listener will attempt to retrieve the requested URL from the current array.

HRESULT get_ResolveInArray(
  VARIANT_BOOL** pfResolveInArray
);

HRESULT put_ResolveInArray(
  VARIANT_BOOL fResolveInArray
);

Parameters

pfResolveInArray
Pointer to a Boolean variable that is set on return to VARIANT_TRUE if the Web listener will attempt to retrieve the requested URL from the current array, or to VARIANT_FALSE if the Web listener will retrieve the requested URL from the external site.
fResolveInArray
Boolean value that indicates whether the Web listener will attempt to retrieve the requested URL from the current array.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write.

[Visual Basic]

The ResolveInArray property gets or sets a Boolean value that indicates whether the Web listener will attempt to retrieve the requested URL from the cache of the current array or directly from the external site.

Property ResolveInArray As Boolean

Property Value

Boolean value that indicates whether the Web listener will get the requested URL from the current array. If the value is set to True, the Web listener will attempt to retrieve the requested URL from the current array. If the value is set to False, the Web listener will retrieve the requested URL from the external site.

Remarks

This property is read/write.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCWebListenerProperties


ReturnAuthRequiredIfAuthUserDenied property [ISA Server 2004]

ReturnAuthRequiredIfAuthUserDenied Property of IFPCWebListenerProperties[C++]

FPCWebListenerProperties.ReturnAuthRequiredIfAuthUserDenied [Visual Basic]

[C++]

The ReturnAuthRequiredIfAuthUserDenied property gets or sets a Boolean value that indicates whether to return a Proxy Authorization Required message when a user is authenticated by the ISA Server Web proxy but is denied access by the rules. By default, an access denied message is returned, and the user is not given the option of authenticating with different credentials.

HRESULT get_ReturnAuthRequiredIfAuthUserDenied(
  VARIANT_BOOL** pfReturnAuthRequiredIfAuthUserDenied
);

HRESULT put_ReturnAuthRequiredIfAuthUserDenied(
  VARIANT_BOOL fReturnAuthRequiredIfAuthUserDenied
);

Parameters

pfReturnAuthRequiredIfAuthUserDenied
Pointer to a Boolean variable that is set on return to VARIANT_TRUE if a Proxy Authorization Required message will be returned when a user is authenticated by the Web proxy but is denied access by the rules, or to VARIANT_FALSE if a Proxy Authorization Required message will not be returned when a user is authenticated by the Web proxy but is denied access by the rules.
fReturnAuthRequiredIfAuthUserDenied
Boolean value that indicates whether to return a Proxy Authorization Required message when a user is authenticated by the Web proxy but is denied access by the rules.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write.

In the forward proxy scenario, when this property is set to VARIANT_TRUE, a user that is authenticated by the Web proxy but fails to pass the rules (for example, because they deny access to this user) receives HTTP error 407 (Proxy Authorization Required) and can try again using different credentials. If this property is set to VARIANT_FALSE, the user receives HTTP error 502 (Bad Gateway) with a resource denied error page, because the Web proxy denies access for the user request. In the reverse proxy scenario, the corresponding HTTP errors are 401 (Unauthorized: Logon Failed) and 403 (Forbidden: Execute Access Forbidden).

[Visual Basic]

The ReturnAuthRequiredIfAuthUserDenied property gets or sets a Boolean value that indicates whether to return a Proxy Authorization Required message when a user is authenticated by the ISA Server Web proxy but is denied access by the rules. By default, an access denied message is returned, and the user is not given the option of authenticating with different credentials.

Property ReturnAuthRequiredIfAuthUserDenied As Boolean

Property Value

Boolean value that indicates whether to return a Proxy Authorization Required message when a user is authenticated by the Web proxy but is denied access by the rules.

Remarks

This property is read/write.

In the forward proxy scenario, when this property is set to True, a user that is authenticated by the Web proxy but fails to pass the rules (for example, because they deny access to this user) receives HTTP error 407 (Proxy Authorization Required) and can try again using different credentials. If this property is set to False, the user receives HTTP error 502 (Bad Gateway) with a resource denied error page, because the Web proxy denies access for the user request. In the reverse proxy scenario, the corresponding HTTP errors are 401 (Unauthorized: Logon Failed) and 403 (Forbidden: Execute Access Forbidden).

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCWebListenerProperties


IFPCWebListenerProperties.Save (2 Parameters) method [ISA Server 2004]

IFPCWebListenerProperties::Save[C++]

FPCWebListenerProperties.Save [Visual Basic]

[C++]

The Save method recursively writes the current values of all of the object's properties, including all the properties of its subobject and its elements, to persistent storage. It is important to remember that any changes made by scripts and programs are not saved until after the Save method is called.

HRESULT Save(
  VARIANT_BOOL fResetRequiredServices,
  VARIANT_BOOL fReloadConfiguration
);

Parameters

fResetRequiredServices
[in, optional] Boolean value that indicates whether to restart the services that need to be restarted for any of the changes saved to take effect. The default value is VARIANT_FALSE.
fReloadConfiguration
[in, optional] Boolean value that indicates whether the call will include synchronous reloading of all changes that can be applied dynamically without restarting services. The default value is VARIANT_TRUE.

Return Values

This method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

Configuration changes are applied only after the new settings are written to persistent storage and reloaded to the services that use them. Most changes can be applied dynamically without restarting any services. However, some changes can take effect only after the Microsoft Firewall service is restarted. For more information, see Restarting Services after Configuration Changes.

ISA Server maintains a bitmask that specifies which services need to be started for currently unsaved changes to take effect. This bitmask can be retrieved by calling the GetServiceRestartMask method on an object that contains this object as a subobject. Calling the Save method clears all of the bits in this bitmask even if the fResetRequiredServices parameter is set to VARIANT_FALSE.

If the fReloadConfiguration parameter is set to VARIANT_FALSE the current values will be written to persistent storage without updating the configuration being used by the ISA Server services. The configuration used by each service will not be updated until the service is restarted or the new settings are reloaded by another call to Save.

[Visual Basic]

The Save method recursively writes the current values of all of the object's properties, including all the properties of its subobject and its elements, to persistent storage. It is important to remember that any changes made by scripts and programs are not saved until after the Save method is called.

Sub Save( _
  [ ByVal fResetRequiredServices As Boolean ], _
  [ ByVal fReloadConfiguration As Boolean ] _
)

Parameters

fResetRequiredServices
[in, optional] Boolean value that indicates whether to restart the services that need to be restarted for any of the changes saved to take effect. The default value is False.
fReloadConfiguration
[in, optional] Boolean value that indicates whether the call will include synchronous reloading of all the saved configuration changes that can be applied dynamically without restarting services. The default value is True.

Return Values

This method has no return values. If the call is unsuccessful, an error is raised that can be intercepted by using an error handler.

Remarks

Configuration changes are applied only after the new settings are written to persistent storage and reloaded to the services that use them. Most changes can be applied dynamically without restarting any services. However, some changes can take effect only after the Microsoft Firewall service is restarted. For more information, see Restarting Services after Configuration Changes.

ISA Server maintains a bitmask that specifies which services need to be started for currently unsaved changes to take effect. This bitmask can be retrieved by calling the GetServiceRestartMask method on an object that contains this object as a subobject. Calling the Save method clears all of the bits in this bitmask even if the fResetRequiredServices parameter is set to False.

If the fReloadConfiguration parameter is set to False the current values will be written to persistent storage without updating the configuration being used by the ISA Server services. The configuration used by each service will not be updated until the service is restarted or the new settings are reloaded by another call to Save.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCWebListenerProperties


SingleRadiusServerAuthPerSession property [ISA Server 2004]

SingleRadiusServerAuthPerSession Property of IFPCWebListenerProperties[C++]

FPCWebListenerProperties.SingleRadiusServerAuthPerSession [Visual Basic]

[C++]

The SingleRadiusServerAuthPerSession property gets or sets a Boolean value that indicates whether RADIUS authentication persists across requests, thereby lasting throughout a session.

HRESULT get_SingleRadiusServerAuthPerSession(
  VARIANT_BOOL* pfRadiusSingleRequest
);

HRESULT put_SingleRadiusServerAuthPerSession(
  VARIANT_BOOL fRadiusSingleRequest
);

Parameters

pfRadiusSingleRequest
[out] Pointer to a Boolean variable that is set on return to VARIANT_TRUE if RADIUS authentication persists throughout a session, or to VARIANT_FALSE if RADIUS authentication does not persist throughout a session.
fRadiusSingleRequest
[in] Boolean value that indicates whether RADIUS authentication persists throughout a session.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write.

[Visual Basic]

The SingleRadiusServerAuthPerSession property gets or sets a Boolean value that indicates whether RADIUS authentication persists across requests, thereby lasting throughout a session.

Property SingleRadiusServerAuthPerSession As Boolean

Property Value

Boolean value that indicates whether RADIUS authentication persists throughout a session.

Remarks

This property is read/write.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCWebListenerProperties


SSLCertificateAuthentication property [ISA Server 2004]

SSLCertificateAuthentication Property of IFPCWebListenerProperties[C++]

FPCWebListenerProperties.SSLCertificateAuthentication [Visual Basic]

[C++]

The SSLCertificateAuthentication property gets or sets a Boolean value that indicates whether SSL certificate authentication is used. For more information, see ISA Server and Secure Sockets Layer.

HRESULT get_SSLCertificateAuthentication(
  VARIANT_BOOL* pfSSLCertificateAuthentication
);

HRESULT put_SSLCertificateAuthentication(
  VARIANT_BOOL fSSLCertificateAuthentication
);

Parameters

pfSSLCertificateAuthentication
Pointer to a Boolean variable that is set on return to VARIANT_TRUE if SSL certificate authentication is used, or to VARIANT_FALSE if SSL certificate authentication is not used.
fSSLCertificateAuthentication
Boolean value that indicates whether SSL certificate authentication is used.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write.

When this property is set to VARIANT_TRUE, SSL certificate authentication is used only for HTTPS clients. If SSL certificate authentication fails, the Web listener can use another method that is enabled. HTTP clients are authenticated only by Basic authentication, Digest authentication, or Integrated authentication.

[Visual Basic]

The SSLCertificateAuthentication property gets or sets a Boolean value that indicates whether SSL certificate authentication is used. For more information, see ISA Server and Secure Sockets Layer.

Property SSLCertificateAuthentication As Boolean

Property Value

Boolean value that indicates whether SSL certificate authentication is used.

Remarks

This property is read/write.

When this property is set to True, SSL certificate authentication is used only for HTTPS clients. If SSL certificate authentication fails, the Web listener can use another method that is enabled. HTTP clients are authenticated only by Basic authentication, Digest authentication, or Integrated authentication.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCWebListenerProperties


IFPCWebListenerProperties.SSLPort(long,long) property [ISA Server 2004]

SSLPort Property of IFPCWebListenerProperties[C++]

FPCWebListenerProperties.SSLPort [Visual Basic]

[C++]

The SSLPort property gets or sets the Secure Sockets Layer (SSL) port for the Web listener.

HRESULT get_SSLPort(
  long** plSSLPortNumber
);

HRESULT put_SSLPort(
  long lSSLPortNumber
);

Parameters

plSSLPortNumber
Pointer to a variable that on return receives a 32-bit integer specifying the SSL port number.
lSSLPortNumber
A 32-bit integer that specifies the SSL port number.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write.

A value of 0 indicates that there is no SSL port.

[Visual Basic]

The SSLPort property gets or sets the Secure Sockets Layer (SSL) port for the Web listener.

Property SSLPort As Long

Property Value

A 32-bit integer that specifies the SSL port number.

Remarks

This property is read/write.

A value of 0 indicates that there is no SSL port.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCWebListenerProperties


IFPCWebListenerProperties.TCPPort(long,long) property [ISA Server 2004]

TCPPort Property of IFPCWebListenerProperties[C++]

FPCWebListenerProperties.TCPPort [Visual Basic]

[C++]

The TCPPort property gets or sets the TCP port for the Web listener.

HRESULT get_TCPPort(
  long** plTCPPortNumber
);

HRESULT put_TCPPort(
  long lTCPPortNumber
);

Parameters

plTCPPortNumber
Pointer to a variable that on return receives a 32-bit integer specifying the TCP port number.
lTCPPortNumber
A 32-bit integer that specifies the TCP port number.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write.

[Visual Basic]

The TCPPort property gets or sets the TCP port for the Web listener.

Property TCPPort As Long

Property Value

A 32-bit integer that specifies the TCP port number.

Remarks

This property is read/write.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCWebListenerProperties


UnlimitedNumberOfConnections property [ISA Server 2004]

UnlimitedNumberOfConnections Property of IFPCWebListenerProperties[C++]

FPCWebListenerProperties.UnlimitedNumberOfConnections [Visual Basic]

[C++]

The UnlimitedNumberOfConnections property gets or sets a Boolean that indicates whether the ISA Server Web proxy can have an unlimited number of connections.

HRESULT get_UnlimitedNumberOfConnections(
  VARIANT_BOOL** pfUnlimited
);

HRESULT put_UnlimitedNumberOfConnections(
  VARIANT_BOOL fUnlimited
);

Parameters

pfUnlimited
Pointer to a Boolean variable that is set on return to VARIANT_TRUE if the Web proxy can have an unlimited number of connections, or to VARIANT_FALSE if the Web proxy can have only a limited number of connections.
fUnlimited
Boolean value that indicates whether the Web proxy can have an unlimited number of connections.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write.

If this property is set to VARIANT_FALSE, the number of connections is specified by the NumberOfConnections property.

[Visual Basic]

The UnlimitedNumberOfConnections property gets or sets a Boolean that indicates whether the ISA Server Web proxy can have an unlimited number of connections.

Property UnlimitedNumberOfConnections As Boolean

Property Value

Boolean value that indicates whether the Web proxy can have an unlimited number of connections.

Remarks

This property is read/write.

If this property is set to False, the number of connections is specified by the NumberOfConnections property.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCWebListenerProperties


FPCWebListeners collection [ISA Server 2004]

FPCWebListeners Collection

The FPCWebListeners collection holds an ordered set of FPCWebListener objects.

This collection is typically accessed through the WebListeners property of the FPCRuleElements object.

Click here to see the ISA Server object hierarchy.

Inheritance

This collection inherits from the FPCPersist object, which contains methods and properties related to the persistent storage of an object's data. They include methods for exporting the object's data to and importing it from an XML document.

Methods

The FPCWebListeners collection defines the following methods.

Method | Description
Add | Creates a new FPCWebListener object, adds it to the collection, and returns a reference to it.
Item | Retrieves the requested FPCWebListener object from the collection.
Remove | Removes a specified Web listener object from the collection.

Properties

The FPCWebListeners collection has the following properties.

Property | Description
_NewEnum | Gets an enumerator object for the collection.
Count | Gets the number of Web listeners in the collection.

Methods Inherited from FPCPersist

Name | Description
CancelWaitForChanges | Cancels the registration established by the WaitForChanges method (for use in C and C++ programming only).
CanImport | Returns a Boolean value that indicates whether the properties of the collection, its elements, and their subobjects can be imported from the specified XML document.
Export | Recursively writes the stored values of all the properties of the collection, its elements, and their subobjects to the specified XML document.
ExportToFile | Recursively writes the stored values of all the properties of the collection, its elements, and their subobjects to the specified XML file.
GetServiceRestartMask | Retrieves a 32-bit bitmask of the FpcServices enumerated type that specifies which services need to be restarted for currently unsaved changes to take effect.
Import | Recursively copies the values of all the properties of the collection, its elements, and their subobjects from the specified XML document to persistent storage.
ImportFromFile | Recursively copies the values of all the properties of the collection, its elements, and their subobjects from the specified XML file to persistent storage.
LoadDocProperties | Provides the XML document's properties so that you can know what information can be imported from the document.
Refresh | Recursively reads the values of all the properties of the collection, its elements, and their subobjects from persistent storage, overwriting any changes that have not been saved.
Save | Recursively writes the current values of all the properties of the collection, its elements, and their subobjects to persistent storage.
WaitForChanges | Registers to wait for an event indicating that the contents of the object have changed (for use in C and C++ programming only).

Properties Inherited from FPCPersist

Name | Description
PersistentName | Gets the persistent name of the collection. The persistent name of an object is a name that is unique for the object at the respective level of the COM object hierarchy.
VendorParametersSets | Gets an FPCVendorParametersSets collection that can hold sets of custom data for extending the collection.

Remarks

This collection implements the IFPCWebListeners interface.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

COM Objects


IFPCWebListeners | FPCWebListeners _NewEnum(IUnknown) property [ISA Server 2004]

_NewEnum Property of IFPCWebListeners[C++]

FPCWebListeners._NewEnum [Visual Basic]

[C++]

The _NewEnum property gets an enumerator object for the collection. An enumerator object provides serial access to the elements of the collection.

HRESULT get__NewEnum(
  IUnknown* ppEnum
);

Parameters

ppEnum
Address of an interface pointer that on return points to the IUnknown interface of an enumerator object that implements an IEnumVARIANT interface for the collection. An interface pointer to the IEnumVARIANT interface of the enumerator object can be retrieved by calling QueryInterface on the IUnknown interface returned.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The _NewEnum property gets an enumerator object for the collection. An enumerator object provides serial access to the elements of the collection.

Property _NewEnum As IUnknown

Property Value

Reference to an enumerator object that provides serial access to the elements of the collection.

Remarks

This property is read-only.

In Visual Basic and VBScript, this property is used implicitly in For Each...In...Next constructs.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCWebListeners


IFPCWebListeners | FPCWebListeners Add (2 Parameters) method [ISA Server 2004]

IFPCWebListeners::Add[C++]

FPCWebListeners.Add [Visual Basic]

[C++]

The Add method creates a new FPCWebListener object in the collection and returns a reference to it.

HRESULT Add(
  BSTR Name,
  IFPWebListener** ppNewWebListener
);

Parameters

Name
[in] Required. BSTR that specifies the name of the new Web listener.
ppNewWebListener
[out] Address of an interface pointer that on return points to the new IFPCWebListener interface created.

Return Values

The method can return one of the following:

  • S_OK, indicating that the operation succeeded.
  • An error code, indicating that the operation failed. In this case, the [out] parameter returned is a null object.

[Visual Basic]

The Add method creates a new FPCWebListener object in the collection and returns a reference to it.

Function Add( _
  ByVal Name As String _
) As FPCWebListener

Parameters

Name
[in] Required. String that specifies the name of the new Web listener.

Return Values

The method returns a reference to an FPCWebListener object if successful. Otherwise, an error is raised that can be intercepted by using an error handler.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCWebListeners


IFPCWebListeners | FPCWebListeners Count(long) property [ISA Server 2004]

Count Property of IFPCWebListeners[C++]

FPCWebListeners.Count [Visual Basic]

[C++]

The Count property gets the number of FPCWebListener objects in the collection.

HRESULT get_Count(
  long* plCount
);

Parameters

plCount
Pointer to a variable that receives a 32-bit integer specifying the number of FPCWebListener objects in the collection.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The Count property gets the number of FPCWebListener objects in the collection.

Property Count As Long

Property Value

A 32-bit integer that specifies the number of FPCWebListener objects in the collection.

Remarks

This property is read-only.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCWebListeners


IFPCWebListeners | FPCWebListeners Item (2 Parameters) method [ISA Server 2004]

IFPCWebListeners::Item[C++]

FPCWebListeners.Item [Visual Basic]

[C++]

The Item method retrieves the requested IFPCWebListener interface from the collection.

HRESULT Item(
  VARIANT Index,
  IFPWebListener** ppItem
);

Parameters

Index
[in] Required. Name or one-based index of the object to retrieve.
ppItem
[out] Address of an interface pointer that on return points to the IFPCWebListener interface requested.

Return Values

The method can return one of the following:

  • S_OK, indicating that the operation succeeded.
  • An error code, indicating that the operation failed. In this case, the [out] parameter returned is a null object.

[Visual Basic]

The Item method retrieves the requested FPCWebListener object from the collection.

Function Item( _
  ByVal Index As Variant _
) As FPCWebListener

Parameters

Index
[in] Required. Name or one-based index of the object to retrieve.

Return Values

The method returns a reference to an FPCWebListener object if successful. Otherwise, an error is raised that can be intercepted by using an error handler.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCWebListeners


IFPCWebListeners | FPCWebListeners Remove(Variant) method [ISA Server 2004]

IFPCWebListeners::Remove[C++]

FPCWebListeners.Remove [Visual Basic]

[C++]

The Remove method removes the specified FPCWebListener object from the collection.

HRESULT Remove(
  VARIANT Index
);

Parameters

Index
[in] Required. Name or one-based index of the FPCWebListener object to remove.

Return Values

This method returns S_OK if the call is successful; otherwise, it returns an error code.
[Visual Basic]

The Remove method removes the specified FPCWebListener object from the collection.

Sub Remove( _
  ByVal Index As Variant _
)

Parameters

Index
[in] Required. Name or one-based index of the FPCWebListener object to remove.

Return Values

This method has no return values. If the call is unsuccessful, an error is raised that can be intercepted by using an error handler.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCWebListeners


FPCWebProxy object [ISA Server 2004]

FPCWebProxy

The FPCWebProxy object defines settings for the ISA Server Web proxy.

The FPCWebProxy object is typically accessed through the WebProxy property of an FPCArrayPolicy object.

Click here to see the ISA Server object hierarchy.

Inheritance

This object inherits from the FPCPersist object, which contains methods and properties related to the persistent storage of an object's data. They include methods for exporting the object's data to and importing it from an XML document.

Methods

This object has no methods.

Properties

The FPCWebProxy object has the following properties.

Property | Description
CARPNameSystem | Gets or sets a value from the FpcNameSystem enumerated type that specifies whether the ISA Server Web proxy is to use the Domain Name System (DNS) name lookup system or the Windows Internet Name Service (WINS) name lookup system for the Cache Array Routing Protocol (CARP).
ConnectCacheSize | Gets or sets the size of the connection cache.
EnforceLogUrlLengthInWebProxy | Gets or sets a Boolean value that indicates whether the ISA Server Web proxy will reject requests with URLs that are longer than the maximum length that can be logged.
MaxResponseHeadersSize | Gets or sets the maximum allowed size of an HTTP response header.
RemoveAllProxyAuthorization | Gets or sets a Boolean value that indicates whether the ISA Server Web proxy will remove all proxy authorization headers from requests passed to an upstream server.
RemoveRedundantProxyAuthorization | Gets or sets a Boolean value that indicates whether the ISA Server Web proxy will remove all redundant proxy authorization headers from requests passed to an upstream server when Basic authentication is used for authentication to the upstream server.
RemoveTrailersFromChunkedEncodedResponses | Gets or sets a Boolean value that indicates whether the ISA Server Web proxy will remove trailers from responses that are encoded with the chunked transfer coding (this property is relevant only for responses sent to HTTP 1.1 clients).
SkipNameResolutionForAccessAndRoutingRules | Gets or sets a Boolean value that indicates whether the ISA Server Web proxy will skip name resolution while checking access and routing rules.
SkipNameResolutionForWebPublishingRules | Gets or sets a Boolean value that indicates whether the ISA Server Web proxy will skip name resolution while checking Web publishing rules.
TunnelPortRanges | Gets an FPCTunnelPortRanges collection.
UpstreamResolveSystem | Gets or sets a value from the FpcNameSystem enumerated type that specifies which information the ISA Server Web proxy will use to resolve the name of an upstream server, either the Domain Name System (DNS) or the Windows Internet Name Service (WINS) information, both of which are returned by an upstream server.
UseDigestSSP | Gets or sets a Boolean value that indicates whether the ISA Server Web proxy will prefer Advanced Digest authentication over Digest authentication on a Windows Server 2003 computer.
ValidateClientCertificateCRL | Gets or sets a Boolean value that indicates whether the ISA Server Web proxy will validate client certificates against the relevant certificate revocation list (CRL).
ValidateCrlOnline | Gets or sets a Boolean value that indicates whether the ISA Server Web proxy will try to connect to the certification authority (CA) and download the latest certificate revocation list (CRL).
ValidateServerCertificateCRLInForward | Gets or sets a Boolean value that indicates whether the ISA Server Web proxy will validate server certificates against the relevant certificate revocation list (CRL) in the forward proxy scenario.
ValidateServerCertificateCRLInReverse | Gets or sets a Boolean value that indicates whether the ISA Server Web proxy will validate server certificates against the relevant certificate revocation list (CRL) in the reverse proxy scenario.
WebProxyFtpClientPassword | Gets or sets the password that will be used when mediating anonymous FTP requests.

Methods Inherited from FPCPersist

Name | Description
CancelWaitForChanges | Cancels the registration established by the WaitForChanges method (for use in C and C++ programming only).
CanImport | Returns a Boolean value that indicates whether the object's properties can be imported from the specified XML document.
Export | Recursively writes the stored values of all the properties of the object and its subobjects to the specified XML document.
ExportToFile | Recursively writes the stored values of all the properties of the object and its subobjects to the specified XML file.
GetServiceRestartMask | Retrieves a 32-bit bitmask of the FpcServices enumerated type that specifies which services need to be restarted for currently unsaved changes to take effect.
Import | Recursively copies the values of all the properties of the object and of its subobjects from the specified XML document to persistent storage.
ImportFromFile | Recursively copies the values of all the properties of the object and of its subobjects from the specified XML file to persistent storage.
LoadDocProperties | Provides the XML document's properties so that you can know what information can be imported from the document.
Refresh | Recursively reads the values of all the properties of the object and of its subobjects from persistent storage, overwriting any changes that have not been saved.
Save | Recursively writes the current values of all the properties of the object and its subobjects to persistent storage.
WaitForChanges | Registers to wait for an event indicating that the contents of the object have changed (for use in C and C++ programming only).

Properties Inherited from FPCPersist

Name | Description
PersistentName | Gets the persistent name of the object. The persistent name of an object is a name that is unique for the object at the respective level of the COM object hierarchy.
VendorParametersSets | Gets an FPCVendorParametersSets collection that can hold sets of custom data for extending the object.

Remarks

This object implements the IFPCWebProxy interface.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

COM Objects


IFPCWebProxy | FPCWebProxy CARPNameSystem property [ISA Server 2004]

CARPNameSystem Property of IFPCWebProxy[C++]

FPCWebProxy.CARPNameSystem [Visual Basic]

[C++]

The CARPNameSystem property gets or sets a value from the FpcNameSystem enumerated type that specifies whether the ISA Server Web proxy is to use the Domain Name System (DNS) name lookup system or the Windows Internet Name Service (WINS) name lookup system for the Cache Array Routing Protocol (CARP).

Note This property is available only for an array in ISA Server Enterprise Edition. It is not available for a stand-alone server, or for ISA Server Standard Edition.

HRESULT get_CARPNameSystem(
  FpcNameSystem* pNameSystem
);

HRESULT put_CARPNameSystem(
  FpcNameSystem NameSystem
);

Parameters

pNameSystem
Pointer to a value from the FpcNameSystem enumerated type that is set on return to fpc_NameSystem_DNS if the DNS name lookup system is to be used for CARP, or to fpc_NameSystem_WINS if the WINS name lookup system is to be used for CARP.
NameSystem
Value from the FpcNameSystem enumerated type that is set to fpc_NameSystem_DNS if the DNS name lookup system is to be used for CARP, or to fpc_NameSystem_WINS if the WINS name lookup system is to be used for CARP.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write.

Setting this property correctly is important because some computers do not have WINS names and will not work in CARP if DNS name lookup is not enabled.

After the value of this property has been changed, and the change has been saved by calling the Save method, the Microsoft Firewall service must be restarted for the change to take effect. The Firewall service can be restarted by calling the IFPCArray::RestartServices method.

[Visual Basic]

The CARPNameSystem property gets or sets a value from the FpcNameSystem enumerated type that specifies whether the ISA Server Web proxy is to use the Domain Name System (DNS) name lookup system or the Windows Internet Name Service (WINS) name lookup system for the Cache Array Routing Protocol (CARP).

Note This property is available only for an array in ISA Server Enterprise Edition. It is not available for a stand-alone server, or for ISA Server Standard Edition.

Property CARPNameSystem As FpcNameSystem

Property Value

Value from the FpcNameSystem enumerated type that is set to fpc_NameSystem_DNS if the DNS name lookup system is to be used for CARP, or to fpc_NameSystem_WINS if the WINS name lookup system is to be used for CARP.

Remarks

This property is read/write.

Setting this property correctly is important because some computers do not have WINS names and will not work in CARP if DNS name lookup is not enabled.

After the value of this property has been changed, and the change has been saved by calling the Save method, the Microsoft Firewall service must be restarted for the change to take effect. The Firewall service can be restarted by calling the FPCArray.RestartServices method.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCWebProxy


IFPCWebProxy | FPCWebProxy ConnectCacheSize property [ISA Server 2004]

ConnectCacheSize Property of IFPCWebProxy[C++]

FPCWebProxy.ConnectCacheSize [Visual Basic]

[C++]

The ConnectCacheSize property gets or sets the size of the connection cache.

HRESULT get_ConnectCacheSize(
  long* plCacheSize
);

HRESULT put_ConnectCacheSize(
  long lCacheSize
);

Parameters

plCacheSize
Pointer to a variable that is set on return to a 32-bit integer specifying the size of the connection cache.
lCacheSize
A 32-bit integer that specifies the size of the connection cache.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write. Its default value is 128, and its range of permissible values is from 0 to 50,000.

After the value of this property has been changed, and the change has been saved by calling the Save method, the Microsoft Firewall service must be restarted for the change to take effect. The Firewall service can be restarted by calling the IFPCArray::RestartServices method.

[Visual Basic]

The ConnectCacheSize property gets or sets the size of the connection cache.

Property ConnectCacheSize As Long

Property Value

A 32-bit integer that specifies the size of the connection cache.

Remarks

This property is read/write. Its default value is 128, and its range of permissible values is from 0 to 50,000.

After the value of this property has been changed, and the change has been saved by calling the Save method, the Microsoft Firewall service must be restarted for the change to take effect. The Firewall service can be restarted by calling the FPCArray.RestartServices method.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCWebProxy


IFPCWebProxy.EnforceLogUrlLengthInWebProxy property [ISA Server 2004]

EnforceLogUrlLengthInWebProxy Property of IFPCWebProxy[C++]

FPCWebProxy.EnforceLogUrlLengthInWebProxy [Visual Basic]

[C++]

The EnforceLogUrlLengthInWebProxy property gets or sets a Boolean value that indicates whether the ISA Server Web proxy will reject requests with URLs that are longer than the maximum length that can be logged. This maximum length is 2048 bytes.

HRESULT get_EnforceLogUrlLengthInWebProxy(
  VARIANT_BOOL* pfEnforceUrlLength
);

HRESULT put_EnforceLogUrlLengthInWebProxy(
  VARIANT_BOOL fEnforceUrlLength
);

Parameters

pfEnforceUrlLength
Pointer to a Boolean variable that is set on return to VARIANT_TRUE if the Web proxy will reject requests with URLs that are longer than the maximum length that can be logged, or to VARIANT_FALSE if the Web proxy will accept requests with URLs that are longer than the maximum length that can be logged.
fEnforceUrlLength
Boolean value that specifies whether the Web proxy will reject requests with URLs that are longer than the maximum length that can be logged.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write. Its default value is VARIANT_FALSE.

After the value of this property has been changed, and the change has been saved by calling the Save method, the Microsoft Firewall service must be restarted for the change to take effect. The Firewall service can be restarted by calling the IFPCArray::RestartServices method.

[Visual Basic]

The EnforceLogUrlLengthInWebProxy property gets or sets a Boolean value that indicates whether the ISA Server Web proxy will reject requests with URLs that are longer than the maximum length that can be logged. This maximum length is 2048 bytes.

Property EnforceLogUrlLengthInWebProxy

Property Value

Boolean value that specifies whether the Web proxy will reject requests with URLs that are longer than the maximum length that can be logged.

Remarks

This property is read/write. Its default value is False.

After the value of this property has been changed, and the change has been saved by calling the Save method, the Microsoft Firewall service must be restarted for the change to take effect. The Firewall service can be restarted by calling the FPCArray.RestartServices method.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCWebProxy


IFPCWebProxy | FPCWebProxy MaxResponseHeadersSize property [ISA Server 2004]

MaxResponseHeadersSize Property of IFPCWebProxy[C++]

FPCWebProxy.MaxResponseHeadersSize [Visual Basic]

[C++]

The MaxResponseHeadersSize property gets or sets the maximum allowed size of an HTTP response header.

HRESULT get_MaxResponseHeadersSize(
  long* plHeaderSize
);

HRESULT put_MaxResponseHeadersSize(
  long lHeaderSize
);

Parameters

plHeaderSize
Pointer to a variable that is set on return to a 32-bit integer specifying the maximum allowed size of an HTTP response header.
lHeaderSize
A 32-bit integer that specifies the maximum allowed size of an HTTP response header.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write. Its default value is 32,768.

The limit set by this property is enforced only when additional memory must be allocated for an HTTP response header. The limit is not enforced if an HTTP response header can be accommodated in the buffer initially allocated for it.

After the value of this property has been changed, and the change has been saved by calling the Save method, the Microsoft Firewall service must be restarted for the change to take effect. The Firewall service can be restarted by calling the IFPCArray::RestartServices method.

[Visual Basic]

The MaxResponseHeadersSize property gets or sets the maximum allowed size of an HTTP response header.

Property MaxResponseHeadersSize As Long

Property Value

A 32-bit integer that specifies the maximum allowed size of an HTTP response header.

Remarks

This property is read/write. Its default value is 32,768.

The limit set by this property is enforced only when additional memory must be allocated for an HTTP response header. The limit is not enforced if an HTTP response header can be accommodated in the buffer initially allocated for it.

After the value of this property has been changed, and the change has been saved by calling the Save method, the Microsoft Firewall service must be restarted for the change to take effect. The Firewall service can be restarted by calling the FPCArray.RestartServices method.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCWebProxy


IFPCWebProxy.RemoveAllProxyAuthorization property [ISA Server 2004]

RemoveAllProxyAuthorization Property of IFPCWebProxy[C++]

FPCWebProxy.RemoveAllProxyAuthorization [Visual Basic]

[C++]

The RemoveAllProxyAuthorization property gets or sets a Boolean value that indicates whether the ISA Server Web proxy will remove all proxy authorization headers from requests passed to an upstream server.

HRESULT get_RemoveAllProxyAuthorization(
  VARIANT_BOOL* pfRemoveAllProxyAuthorization
);

HRESULT put_RemoveAllProxyAuthorization(
  VARIANT_BOOL fRemoveAllProxyAuthorization
);

Parameters

pfRemoveAllProxyAuthorization
Pointer to a Boolean variable that is set on return to VARIANT_TRUE if the Web proxy will remove all proxy authorization headers from requests passed to an upstream server, or to VARIANT_FALSE if the Web proxy does not remove all proxy authorization headers from requests passed to an upstream server.
fRemoveAllProxyAuthorization
Boolean value that specifies whether the Web proxy will remove all proxy authorization headers from requests passed to an upstream server.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write. Its default value is VARIANT_FALSE.

After the value of this property has been changed, and the change has been saved by calling the Save method, the Microsoft Firewall service must be restarted for the change to take effect. The Firewall service can be restarted by calling the IFPCArray::RestartServices method.

[Visual Basic]

The RemoveAllProxyAuthorization property gets or sets a Boolean value that indicates whether the ISA Server Web proxy will remove all proxy authorization headers from requests passed to an upstream server.

Property RemoveAllProxyAuthorization As Boolean

Property Value

Boolean value that indicates whether the Web proxy will remove all proxy authorization headers from requests passed to an upstream server.

Remarks

This property is read/write. Its default value is False.

After the value of this property has been changed, and the change has been saved by calling the Save method, the Microsoft Firewall service must be restarted for the change to take effect. The Firewall service can be restarted by calling the FPCArray.RestartServices method.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCWebProxy


IFPCWebProxy.RemoveRedundantProxyAuthorization property [ISA Server 2004]

RemoveRedundantProxyAuthorization Property of IFPCWebProxy[C++]

FPCWebProxy.RemoveRedundantProxyAuthorization [Visual Basic]

[C++]

The RemoveRedundantProxyAuthorization property gets or sets a Boolean value that indicates whether the ISA Server Web proxy will remove all redundant proxy authorization headers from requests passed to an upstream server when Basic authentication is used for authentication to the upstream server.

HRESULT get_RemoveRedundantProxyAuthorization(
  VARIANT_BOOL* pfRemoveRedundantProxyAuthorization
);

HRESULT put_RemoveRedundantProxyAuthorization(
  VARIANT_BOOL fRemoveRedundantProxyAuthorization
);

Parameters

pfRemoveRedundantProxyAuthorization
Pointer to a Boolean variable that is set on return to VARIANT_TRUE if the Web proxy will remove all redundant proxy authorization headers from requests passed to an upstream server, or to VARIANT_FALSE if the Web proxy does not remove redundant proxy authorization headers from requests passed to an upstream server.
fRemoveRedundantProxyAuthorization
Boolean value that specifies whether the Web proxy will remove all redundant proxy authorization headers from requests passed to an upstream server.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write. Its default value is VARIANT_FALSE.

This property is applicable only if Basic authentication is used for authentication to an upstream server.

After the value of this property has been changed, and the change has been saved by calling the Save method, the Microsoft Firewall service must be restarted for the change to take effect. The Firewall service can be restarted by calling the IFPCArray::RestartServices method.

[Visual Basic]

The RemoveRedundantProxyAuthorization property gets or sets a Boolean value that indicates whether the ISA Server Web proxy will remove all redundant proxy authorization headers from requests passed to an upstream server when Basic authentication is used for authentication to the upstream server.

Property RemoveRedundantProxyAuthorization As Boolean

Property Value

Boolean value that indicates whether the Web proxy will remove all redundant proxy authorization headers from requests passed to an upstream server.

Remarks

This property is read/write. Its default value is False.

This property is applicable only if Basic authentication is used for authentication to an upstream server.

After the value of this property has been changed, and the change has been saved by calling the Save method, the Microsoft Firewall service must be restarted for the change to take effect. The Firewall service can be restarted by calling the FPCArray.RestartServices method.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCWebProxy


RemoveTrailersFromChunkedEncodedResponses property [ISA Server 2004]

RemoveTrailersFromChunkedEncodedResponses Property of IFPCWebProxy[C++]

FPCWebProxy.RemoveTrailersFromChunkedEncodedResponses [Visual Basic]

[C++]

The RemoveTrailersFromChunkedEncodedResponses property gets or sets a Boolean value that indicates whether the ISA Server Web proxy will remove trailers from responses that are encoded with the chunked transfer coding (this property is relevant only for responses sent to HTTP 1.1 clients).

HRESULT get_RemoveTrailersFromChunkedEncodedResponses(
  VARIANT_BOOL* pfRemoveTrailers
);

HRESULT put_RemoveTrailersFromChunkedEncodedResponses(
  VARIANT_BOOL fRemoveTrailers
);

Parameters

pfRemoveTrailers
Pointer to a Boolean variable that is set on return to VARIANT_TRUE if the Web proxy will remove trailers from remove trailers from chunked-encoded responses, or to VARIANT_FALSE if the Web proxy does not remove trailers from remove trailers from chunked-encoded responses.
fRemoveTrailers
Boolean value that specifies whether the Web proxy will remove trailers from remove trailers from chunked-encoded responses.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write. Its default value is VARIANT_TRUE.

After the value of this property has been changed, and the change has been saved by calling the Save method, the Microsoft Firewall service must be restarted for the change to take effect. The Firewall service can be restarted by calling the IFPCArray::RestartServices method.

[Visual Basic]

The RemoveTrailersFromChunkedEncodedResponses property gets or sets a Boolean value that indicates whether the ISA Server Web proxy will remove trailers from responses that are encoded with the chunked transfer coding (this property is relevant only for responses sent to HTTP 1.1 clients).

Property RemoveTrailersFromChunkedEncodedResponses As Boolean

Property Value

Boolean value that indicates whether the Web proxy will remove trailers from chunked-encoded responses.

Remarks

This property is read/write. Its default value is True.

After the value of this property has been changed, and the change has been saved by calling the Save method, the Microsoft Firewall service must be restarted for the change to take effect. The Firewall service can be restarted by calling the FPCArray.RestartServices method.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCWebProxy


SkipNameResolutionForAccessAndRoutingRules property [ISA Server 2004]

SkipNameResolutionForAccessAndRoutingRules Property of IFPCWebProxy[C++]

FPCWebProxy.SkipNameResolutionForAccessAndRoutingRules [Visual Basic]

[C++]

The SkipNameResolutionForAccessAndRoutingRules property gets or sets a Boolean value that indicates whether the ISA Server Web proxy will skip name resolution while checking access and routing rules. When name resolution is disabled in a forward proxy scenario with chaining, requests requiring DNS lookup on the downstream ISA Server computer are sent directly without delay to the chained upstream computer.

HRESULT get_SkipNameResolutionForAccessAndRoutingRules(
  VARIANT_BOOL* pfSkipNameResolutionForAccessAndRoutingRules
);

HRESULT put_SkipNameResolutionForAccessAndRoutingRules(
  VARIANT_BOOL fSkipNameResolutionForAccessAndRoutingRules
);

Parameters

pfSkipNameResolutionForAccessAndRoutingRules
Pointer to a Boolean variable that is set on return to VARIANT_TRUE if the Web proxy will skip name resolution while checking access and routing rules, or to VARIANT_FALSE if the Web proxy will not skip name resolution while checking access and routing rules.
fSkipNameResolutionForAccessAndRoutingRules
Boolean value that specifies whether the Web proxy will skip name resolution while checking access and routing rules.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write. Its default value is VARIANT_FALSE.

After the value of this property has been changed, and the change has been saved by calling the Save method, the Microsoft Firewall service must be restarted for the change to take effect. The Firewall service can be restarted by calling the IFPCArray::RestartServices method.

[Visual Basic]

The SkipNameResolutionForAccessAndRoutingRules property gets or sets a Boolean value that indicates whether the ISA Server Web proxy will skip name resolution while checking access and routing rules. When name resolution is disabled in a forward proxy scenario with chaining, requests requiring DNS lookup on the downstream ISA Server computer are sent directly without delay to the chained upstream computer.

Property SkipNameResolutionForAccessAndRoutingRules As Boolean

Property Value

Boolean value that indicates whether the Web proxy will skip name resolution while checking access and routing rules.

Remarks

This property is read/write. Its default value is False.

After the value of this property has been changed, and the change has been saved by calling the Save method, the Microsoft Firewall service must be restarted for the change to take effect. The Firewall service can be restarted by calling the FPCArray.RestartServices method.

Example Code

This VBScript script sets the value of the SkipNameResolutionForAccessAndRoutingRules property so that the Web proxy will skip name resolution while checking access and routing rules. This script does not include error handling.

' Create the root object.
Dim root  ' The FPCLib.FPC root object
Set root = CreateObject("FPC.Root")

' Declare the other objects needed.
Dim array     ' An FPCArray object
Dim webproxy  ' An FPCWebProxy object

' Get references to the array object
' and the Web proxy object.
Set array = root.GetContainingArray()
set webproxy = array.ArrayPolicy.WebProxy

' Configure the Web proxy to skip name resolution
' while checking access and routing rules and save
' the new configuration.
webproxy.SkipNameResolutionForAccessAndRoutingRules = True
webproxy.Save

' Restart the Firewall service so that
' the change will take effect.
array.RestartServices

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCWebProxy


IFPCWebProxy.SkipNameResolutionForWebPublishingRules property [ISA Server 2004]

SkipNameResolutionForWebPublishingRules Property of IFPCWebProxy[C++]

FPCWebProxy.SkipNameResolutionForWebPublishingRules [Visual Basic]

[C++]

The SkipNameResolutionForWebPublishingRules property gets or sets a Boolean value that indicates whether the ISA Server Web proxy will skip name resolution while checking Web publishing rules.

HRESULT get_SkipNameResolutionForWebPublishingRules(
  VARIANT_BOOL* pfSkipNameResolutionForWebPublishingRules
);

HRESULT put_SkipNameResolutionForWebPublishingRules(
  VARIANT_BOOL fSkipNameResolutionForWebPublishingRules
);

Parameters

pfSkipNameResolutionForWebPublishingRules
Pointer to a Boolean variable that is set on return to VARIANT_TRUE if the Web proxy will skip name resolution while checking Web publishing rules, or to VARIANT_FALSE if the Web proxy will not skip name resolution while checking Web publishing rules.
fSkipNameResolutionForWebPublishingRules
Boolean value that specifies whether the Web proxy will skip name resolution while checking Web publishing rules.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write. Its default value is VARIANT_TRUE.

After the value of this property has been changed, and the change has been saved by calling the Save method, the Microsoft Firewall service must be restarted for the change to take effect. The Firewall service can be restarted by calling the IFPCArray::RestartServices method.

[Visual Basic]

The SkipNameResolutionForWebPublishingRules property gets or sets a Boolean value that indicates whether the ISA Server Web proxy will skip name resolution while checking Web publishing rules.

Property SkipNameResolutionForWebPublishingRules As Boolean

Property Value

Boolean value that indicates whether the Web proxy will skip name resolution while checking Web publishing rules.

Remarks

This property is read/write. Its default value is True.

After the value of this property has been changed, and the change has been saved by calling the Save method, the Microsoft Firewall service must be restarted for the change to take effect. The Firewall service can be restarted by calling the FPCArray.RestartServices method.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCWebProxy


IFPCWebProxy | FPCWebProxy TunnelPortRanges property [ISA Server 2004]

TunnelPortRanges Property of IFPCWebProxy[C++]

FPCWebProxy.TunnelPortRanges [Visual Basic]

[C++]

The TunnelPortRanges property gets an FPCTunnelPortRanges collection.

HRESULT get_TunnelPortRanges(
  IFPCTunnelPortRanges** ppTunnelPortRanges
);

Parameters

ppTunnelPortRanges
Address of an interface pointer that on return points to an IFPCTunnelPortRanges interface that represents the collection of tunnel port ranges.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only.

[Visual Basic]

The TunnelPortRanges property gets an FPCTunnelPortRanges collection.

Property TunnelPortRanges As FPCTunnelPortRanges

Property Value

Reference to an FPCTunnelPortRanges collection.

Remarks

This property is read-only.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCWebProxy


IFPCWebProxy | FPCWebProxy UpstreamResolveSystem property [ISA Server 2004]

UpstreamResolveSystem Property of IFPCWebProxy[C++]

FPCWebProxy.UpstreamResolveSystem [Visual Basic]

[C++]

The UpstreamResolveSystem property gets or sets a value from the FpcNameSystem enumerated type that specifies which information the ISA Server Web proxy will use to resolve the name of an upstream server, either the Domain Name System (DNS) or the Windows Internet Name Service (WINS) information, both of which are returned by an upstream server.

HRESULT get_UpstreamResolveSystem(
  FpcNameSystem* pNameSystem
);

HRESULT put_UpstreamResolveSystem(
  FpcNameSystem NameSystem
);

Parameters

pNameSystem
Pointer to a value from the FpcNameSystem enumerated type that is set on return to fpc_NameSystem_DNS if the Web proxy is to use the DNS information to resolve the name of an upstream server, or to fpc_NameSystem_WINS if the Web proxy is to use the WINS information.
NameSystem
Value from the FpcNameSystem enumerated type that is set to fpc_NameSystem_DNS if the Web proxy is to use the DNS information to resolve the name of an upstream server, or to fpc_NameSystem_WINS if the Web proxy is to use the WINS information.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write.

After the value of this property has been changed, and the change has been saved by calling the Save method, the Microsoft Firewall service must be restarted for the change to take effect. The Firewall service can be restarted by calling the IFPCArray::RestartServices method.

[Visual Basic]

The UpstreamResolveSystem property gets or sets a value from the FpcNameSystem enumerated type that specifies which information the ISA Server Web proxy will use to resolve the name of an upstream server, either the Domain Name System (DNS) or the Windows Internet Name Service (WINS) information, both of which are returned by an upstream server.

Property UpstreamResolveSystem As FpcNameSystem

Property Value

Value from the FpcNameSystem enumerated type that is set to fpc_NameSystem_DNS if the Web proxy is to use the DNS information to resolve the name of an upstream server, or to fpc_NameSystem_WINS if the Web proxy is to use the WINS information.

Remarks

This property is read/write.

After the value of this property has been changed, and the change has been saved by calling the Save method, the Microsoft Firewall service must be restarted for the change to take effect. The Firewall service can be restarted by calling the FPCArray.RestartServices method.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCWebProxy


IFPCWebProxy | FPCWebProxy UseDigestSSP property [ISA Server 2004]

UseDigestSSP Property of IFPCWebProxy[C++]

FPCWebProxy.UseDigestSSP [Visual Basic]

[C++]

The UseDigestSSP property gets or sets a Boolean value that indicates whether the ISA Server Web proxy will prefer Advanced Digest authentication over Digest authentication on a Windows Server 2003 computer.

HRESULT get_UseDigestSSP(
  VARIANT_BOOL* pfUseDigestSSP
);

HRESULT put_UseDigestSSP(
  VARIANT_BOOL fUseDigestSSP
);

Parameters

pfUseDigestSSP
Pointer to a Boolean variable that is set on return to VARIANT_TRUE if the Web proxy will prefer Advanced Digest authentication over Digest authentication on a Windows Server 2003 computer, or to VARIANT_FALSE if the Web proxy does not prefer Digest authentication.
fUseDigestSSP
Boolean value that specifies whether the Web proxy will prefer Advanced Digest authentication over Digest authentication on a Windows Server 2003 computer.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write. Its default value is VARIANT_TRUE, and it can be changed only programmatically.

After the value of this property has been changed, and the change has been saved by calling the Save method, the Microsoft Firewall service must be restarted for the change to take effect. The Firewall service can be restarted by calling the IFPCArray::RestartServices method.

Advanced digest authentication will be used only if the following conditions are met.

  • ISA Server is installed on a computer running a Windows Server 2003 operating system.
  • The Firewall service is running under the LocalSystem account.
  • The IIS sub-authentication component (Iissuba.dll) is installed and registered.

[Visual Basic]

The UseDigestSSP property gets or sets a Boolean value that indicates whether the ISA Server Web proxy will prefer Advanced Digest authentication over Digest authentication on a Windows Server 2003 computer.

Property UseDigestSSP As Boolean

Property Value

Boolean value that indicates whether the Web proxy will prefer Advanced Digest authentication over Digest authentication on a Windows Server 2003 computer.

Remarks

This property is read/write. Its default value is True, and it can be changed only programmatically.

After the value of this property has been changed, and the change has been saved by calling the Save method, the Microsoft Firewall service must be restarted for the change to take effect. The Firewall service can be restarted by calling the FPCArray.RestartServices method.

Advanced digest authentication will be used only if the following conditions are met.

  • ISA Server is installed on a computer running a Windows Server 2003 operating system.
  • The Firewall service is running under the LocalSystem account.
  • The IIS sub-authentication component (Iissuba.dll) is installed and registered.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCWebProxy


IFPCWebProxy.ValidateClientCertificateCRL property [ISA Server 2004]

ValidateClientCertificateCRL Property of IFPCWebProxy[C++]

FPCWebProxy.ValidateClientCertificateCRL [Visual Basic]

[C++]

The ValidateClientCertificateCRL property gets or sets a Boolean value that indicates whether the ISA Server Web proxy will validate client certificates against the relevant certificate revocation list (CRL).

HRESULT get_ValidateClientCertificateCRL(
  VARIANT_BOOL* pfValidateClientCertificateCRL
);

HRESULT put_ValidateClientCertificateCRL(
  VARIANT_BOOL fValidateClientCertificateCRL
);

Parameters

pfValidateClientCertificateCRL
Pointer to a Boolean variable that is set on return to VARIANT_TRUE if the Web proxy will validate client certificates against the relevant CRL, or to VARIANT_FALSE if the Web proxy will not validate client certificates against the relevant CRL.
fValidateClientCertificateCRL
Boolean value that specifies whether the Web proxy will validate client certificates against the relevant CRL.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write.

After the value of this property has been changed, and the change has been saved by calling the Save method, the Microsoft Firewall service must be restarted for the change to take effect. The Firewall service can be restarted by calling the IFPCArray::RestartServices method.

[Visual Basic]

The ValidateClientCertificateCRL property gets or sets a Boolean value that indicates whether the ISA Server Web proxy will validate client certificates against the relevant certificate revocation list (CRL).

Property ValidateClientCertificateCRL

Property Value

Boolean value that specifies whether the Web proxy will validate client certificates against the relevant CRL.

Remarks

This property is read/write.

After the value of this property has been changed, and the change has been saved by calling the Save method, the Microsoft Firewall service must be restarted for the change to take effect. The Firewall service can be restarted by calling the FPCArray.RestartServices method.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCWebProxy


IFPCWebProxy | FPCWebProxy ValidateCrlOnline property [ISA Server 2004]

ValidateCrlOnline Property of IFPCWebProxy[C++]

FPCWebProxy.ValidateCrlOnline [Visual Basic]

[C++]

The ValidateCrlOnline property gets or sets a Boolean value that indicates whether the ISA Server Web proxy will try to connect to the certification authority (CA) and download the latest certificate revocation list (CRL).

HRESULT get_ValidateCrlOnline(
  VARIANT_BOOL* pfValidateCrlOnline
);

HRESULT put_ValidateCrlOnline(
  VARIANT_BOOL fValidateCrlOnline
);

Parameters

pfValidateCrlOnline
Pointer to a Boolean variable that is set on return to VARIANT_TRUE if the Web proxy will try to connect to the CA and download the latest CRL, or to VARIANT_FALSE if the Web proxy will not try to connect to the CA and download the latest CRL.
fValidateCrlOnline
Boolean value that specifies whether the Web proxy will try to connect to the CA and download the latest CRL.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write. Its default value is VARIANT_TRUE.

After the value of this property has been changed, and the change has been saved by calling the Save method, the Microsoft Firewall service must be restarted for the change to take effect. The Firewall service can be restarted by calling the IFPCArray::RestartServices method.

[Visual Basic]

The ValidateCrlOnline property gets or sets a Boolean value that indicates whether the ISA Server Web proxy will try to connect to the certification authority (CA) and download the latest certificate revocation list (CRL).

Property ValidateCrlOnline

Property Value

Boolean value that specifies whether the Web proxy will try to connect to the CA and download the latest CRL.

Remarks

This property is read/write. Its default value is True.

After the value of this property has been changed, and the change has been saved by calling the Save method, the Microsoft Firewall service must be restarted for the change to take effect. The Firewall service can be restarted by calling the FPCArray.RestartServices method.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCWebProxy


IFPCWebProxy.ValidateServerCertificateCRLInForward property [ISA Server 2004]

ValidateServerCertificateCRLInForward Property of IFPCWebProxy[C++]

FPCWebProxy.ValidateServerCertificateCRLInForward [Visual Basic]

[C++]

The ValidateServerCertificateCRLInForward property gets or sets a Boolean value that indicates whether the ISA Server Web proxy will validate server certificates against the relevant certificate revocation list (CRL) in the forward proxy scenario. The setting stored in this property is applicable when the ISA Server computer, acting as a Web proxy, opens a secure connection (SSL bridging) to an upstream proxy server or Web server.

HRESULT get_ValidateServerCertificateCRLInForward(
  VARIANT_BOOL* pfValidateServerCertificateCRLInForward
);

HRESULT put_ValidateServerCertificateCRLInForward(
  VARIANT_BOOL fValidateServerCertificateCRLInForward
);

Parameters

pfValidateServerCertificateCRLInForward
Pointer to a Boolean variable that is set on return to VARIANT_TRUE if the Web proxy will validate server certificates against the relevant CRL in the forward proxy scenario, or to VARIANT_FALSE if the Web proxy will not validate server certificates against the relevant CRL in the forward proxy scenario.
fValidateServerCertificateCRLInForward
Boolean value that specifies whether the Web proxy will validate server certificates against the relevant CRL in the forward proxy scenario.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write. Its default value is VARIANT_TRUE.

After the value of this property has been changed, and the change has been saved by calling the Save method, the Microsoft Firewall service must be restarted for the change to take effect. The Firewall service can be restarted by calling the IFPCArray::RestartServices method.

[Visual Basic]

The ValidateServerCertificateCRLInForward property gets or sets a Boolean value that indicates whether the ISA Server Web proxy will validate server certificates against the relevant certificate revocation list (CRL) in the forward proxy scenario. The setting stored in this property is applicable when the ISA Server computer, acting as a Web proxy, opens a secure connection (SSL bridging) to an upstream proxy server or Web server.

Property ValidateServerCertificateCRLInForward

Property Value

Boolean value that specifies whether the Web proxy will validate server certificates against the relevant CRL in the forward proxy scenario.

Remarks

This property is read/write. Its default value is True.

After the value of this property has been changed, and the change has been saved by calling the Save method, the Microsoft Firewall service must be restarted for the change to take effect. The Firewall service can be restarted by calling the FPCArray.RestartServices method.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCWebProxy


IFPCWebProxy.ValidateServerCertificateCRLInReverse property [ISA Server 2004]

ValidateServerCertificateCRLInReverse Property of IFPCWebProxy[C++]

FPCWebProxy.ValidateServerCertificateCRLInReverse [Visual Basic]

[C++]

The ValidateServerCertificateCRLInReverse property gets or sets a Boolean value that indicates whether the ISA Server Web proxy will validate server certificates against the relevant certificate revocation list (CRL) in the reverse proxy scenario. The setting stored in this property is applicable when the ISA Server computer, publishing a website, opens a secure connection (SSL bridging) to the published Web server.

HRESULT get_ValidateServerCertificateCRLInReverse(
  VARIANT_BOOL* pfValidateServerCertificateCRLInReverse
);

HRESULT put_ValidateServerCertificateCRLInReverse(
  VARIANT_BOOL fValidateServerCertificateCRLInReverse
);

Parameters

pfValidateServerCertificateCRLInReverse
Pointer to a Boolean variable that is set on return to VARIANT_TRUE if the Web proxy will validate server certificates against the relevant CRL in the reverse proxy scenario, or to VARIANT_FALSE if the Web proxy will not validate server certificates against the relevant CRL in the reverse proxy scenario.
fValidateServerCertificateCRLInReverse
Boolean value that specifies whether the Web proxy will validate server certificates against the relevant CRL in the reverse proxy scenario.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write. Its default value is VARIANT_TRUE.

After the value of this property has been changed, and the change has been saved by calling the Save method, the Microsoft Firewall service must be restarted for the change to take effect. The Firewall service can be restarted by calling the IFPCArray::RestartServices method.

[Visual Basic]

The ValidateServerCertificateCRLInReverse property gets or sets a Boolean value that indicates whether the ISA Server Web proxy will validate server certificates against the relevant certificate revocation list (CRL) in the reverse proxy scenario. The setting stored in this property is applicable when the ISA Server computer, publishing a website, opens a secure connection (SSL bridging) to the published Web server.

Property ValidateServerCertificateCRLInReverse

Property Value

Boolean value that specifies whether the Web proxy will validate server certificates against the relevant CRL in the reverse proxy scenario.

Remarks

This property is read/write. Its default value is True.

After the value of this property has been changed, and the change has been saved by calling the Save method, the Microsoft Firewall service must be restarted for the change to take effect. The Firewall service can be restarted by calling the FPCArray.RestartServices method.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCWebProxy


IFPCWebProxy | FPCWebProxy WebProxyFtpClientPassword property [ISA Server 2004]

WebProxyFtpClientPassword Property of IFPCWebProxy[C++]

FPCWebProxy.WebProxyFtpClientPassword [Visual Basic]

[C++]

The WebProxyFtpClientPassword property gets or sets the password that will be used when mediating anonymous FTP requests.

HRESULT get_WebProxyFtpClientPassword(
  BSTR* pbstrPassword
);

HRESULT put_WebProxyFtpClientPassword(
  BSTR bstrPassword
);

Parameters

pbstrPassword
Pointer to a BSTR that is set on return to a string value specifying the password that will be used when mediating anonymous FTP requests.
bstrPassword
BSTR that specifies the password that will be used when mediating anonymous FTP requests.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write. The default password is IEUser@.

After the value of this property has been changed, and the change has been saved by calling the Save method, the Microsoft Firewall service must be restarted for the change to take effect. The Firewall service can be restarted by calling the IFPCArray::RestartServices method.

[Visual Basic]

The WebProxyFtpClientPassword property gets or sets the password that will be used when mediating anonymous FTP requests.

Property WebProxyFtpClientPassword As String

Property Value

String that specifies the password that will be used when mediating anonymous FTP requests.

Remarks

This property is read/write. The default password is IEUser@.

After the value of this property has been changed, and the change has been saved by calling the Save method, the Microsoft Firewall service must be restarted for the change to take effect. The Firewall service can be restarted by calling the FPCArray.RestartServices method.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCWebProxy


FPCWebPublishingProperties object [ISA Server 2004]

FPCWebPublishingProperties

The FPCWebPublishingProperties object represents the properties of a policy rule that was created as a Web publishing rule using the AddWebPublishingRule method.

This object is typically accessed through the WebPublishingProperties property of an FPCPolicyRule object that represents a Web publishing rule.

Click here to see the ISA Server object hierarchy.

Methods

The FPCWebPublishingProperties object defines the following method.

Method | Description
SetWebListener | Sets the Web listener to be used by the rule.

Properties

The FPCWebPublishingProperties object has the following properties.

Property | Description
AllPublicNames | Gets or sets a Boolean value that indicates whether any public name that resolves to the IP address of the internal website will be accepted in incoming requests.
DelegateBasicCredentials | Gets or sets a Boolean value that indicates whether basic credentials are delegated.
FTPRedirectPort | Gets or sets the port for redirecting requests that are redirected as FTP requests.
HTTPRedirectPort | Gets or sets the port for redirecting requests that are redirected as HTTP requests.
PassOptionsRequestsToServer | Gets or sets a Boolean value that indicates whether the ISA Server Web proxy will pass options requests to the published server.
PathMappings | Gets an FPCPathMappings collection that contains mappings of published website names to the internal path of the website.
PublicNames | Gets an FPCPublicNames collection that contains names that are resolved to the name or IP address of the Web server published by the rule.
PublishedServerType | Gets or sets a value from the FpcPublishedServerType enumerated type that indicates the type of published server to which the rule applies.
SendAcceptEncodingHeader | Gets or sets a Boolean value that indicates whether ISA Server sends the original Accept-Encoding header received from the client to the published server.
SendOriginalHostHeader | Gets or sets a Boolean value that indicates whether ISA Server sends the original HTTP Host header or a Host header corresponding to the name or IP address specified in the WebSite property of the rule.
SSLClientCertificate | Gets or sets an FPCCertificate object that represents the SSL client certificate to use when the Web proxy authenticates to the published server.
SSLRedirectPort | Gets or sets the port for redirecting requests that are redirected as SSL requests.
SSLRequireSecureChannel | Gets or sets a value from the FpcSSLRequireSecureChannelMode enumerated type that indicates whether a secure channel is required and whether 128-bit encryption is required.
TranslateLinks | Gets or sets a Boolean value that indicates whether links are translated to the public names recognized by the rule.
UseFirewallIPAsSource | Gets or sets a Boolean value that indicates whether the firewall IP address will be used as the source IP address when a request is forwarded to the Web server.
UserSets | Gets an FPCRefs collection that contains references to the user sets to which the rule applies.
WebListenerUsed | Gets an FPCRef object that references the FPCWebListener object representing the Web listener used for the rule.
WebSite | Gets or sets the name or IP address of the server to which the rule redirects requests.

Remarks

This object implements the IFPCWebPublishingProperties interface.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

COM Objects


IFPCWebPublishingProperties.AllPublicNames property [ISA Server 2004]

AllPublicNames Property of IFPCWebPublishingProperties[C++]

FPCWebPublishingProperties.AllPublicNames [Visual Basic]

[C++]

The AllPublicNames property gets or sets a Boolean value that indicates whether any public name that resolves to the IP address of the internal website will be accepted in incoming requests.

HRESULT get_AllPublicNames(
  VARIANT_BOOL* pfAllPublicNames
);

HRESULT put_AllPublicNames(
  VARIANT_BOOL fAllPublicNames
);

Parameters

pfAllPublicNames
Pointer to a Boolean variable that is set on return to VARIANT_TRUE if any public name that resolves to the IP address of the internal website will be accepted in incoming requests, or to VARIANT_FALSE if public names are not accepted.
fAllPublicNames
Boolean value that indicates whether any public name that resolves to the IP address of the internal website will be accepted in incoming requests.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write. Its default value is VARIANT_FALSE.

[Visual Basic]

The AllPublicNames property gets or sets a Boolean value that indicates whether any public name that resolves to the IP address of the internal website will be accepted in incoming requests.

Property AllPublicNames As Boolean

Property Value

Boolean value that indicates whether any public name that resolves to the IP address of the internal website will be accepted in incoming requests.

Remarks

This property is read/write. Its default value is False.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCWebPublishingProperties


IFPCWebPublishingProperties.DelegateBasicCredentials property [ISA Server 2004]

DelegateBasicCredentials Property of IFPCWebPublishingProperties[C++]

FPCWebPublishingProperties.DelegateBasicCredentials [Visual Basic]

[C++]

The DelegateBasicCredentials property gets or sets a Boolean value that indicates whether basic credentials are delegated.

HRESULT get_DelegateBasicCredentials(
  VARIANT_BOOL* pfDelegateBasicCredentials
);

HRESULT put_DelegateBasicCredentials(
  VARIANT_BOOL fDelegateBasicCredentials
);

Parameters

pfDelegateBasicCredentials
Pointer to a Boolean variable that is set on return to VARIANT_TRUE if basic credentials are delegated, or to VARIANT_FALSE if basic credentials are not delegated.
fDelegateBasicCredentials
Boolean value that indicates whether basic credentials are delegated.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write. Its default value is VARIANT_FALSE.

[Visual Basic]

The DelegateBasicCredentials property gets or sets a Boolean value that indicates whether basic credentials are delegated.

Property DelegateBasicCredentials As Boolean

Property Value

Boolean value that indicates whether basic credentials are delegated.

Remarks

This property is read/write. Its default value is False.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCWebPublishingProperties


IFPCWebPublishingProperties.FTPRedirectPort property [ISA Server 2004]

FTPRedirectPort Property of IFPCWebPublishingProperties[C++]

FPCWebPublishingProperties.FTPRedirectPort [Visual Basic]

[C++]

The FTPRedirectPort property gets or sets the port for redirecting requests that are redirected as FTP requests.

HRESULT get_FTPRedirectPort(
  long* plFTPRedirectPort
);

HRESULT put_FTPRedirectPort(
  long lFTPRedirectPort
);

Parameters

plFTPRedirectPort
Pointer to a variable that on return receives a 32-bit integer specifying the port for redirecting requests that are redirected as FTP requests.
lFTPRedirectPort
A 32-bit integer that specifies the port for redirecting requests that are redirected as FTP requests.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write. Its default value is 21.

[Visual Basic]

The FTPRedirectPort property gets or sets the port for redirecting requests that are redirected as FTP requests.

Property FTPRedirectPort As Long

Property Value

A 32-bit integer that specifies the port for redirecting requests that are redirected as FTP requests.

Remarks

This property is read/write. Its default value is 21.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCWebPublishingProperties


IFPCWebPublishingProperties.HTTPRedirectPort property [ISA Server 2004]

HTTPRedirectPort Property of IFPCWebPublishingProperties[C++]

FPCWebPublishingProperties.HTTPRedirectPort [Visual Basic]

[C++]

The HTTPRedirectPort property gets or sets the port for redirecting requests that are redirected as HTTP requests.

HRESULT get_HTTPRedirectPort(
  long* plHTTPRedirectPort
);

HRESULT put_HTTPRedirectPort(
  long lHTTPRedirectPort
);

Parameters

plHTTPRedirectPort
Pointer to a variable that on return receives a 32-bit integer specifying the port for redirecting requests that are redirected as HTTP requests.
lHTTPRedirectPort
A 32-bit integer that specifies the port for redirecting requests that are redirected as HTTP requests.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write. Its default value is 80.

[Visual Basic]

The HTTPRedirectPort property gets or sets the port for redirecting requests that are redirected as HTTP requests.

Property HTTPRedirectPort As Long

Property Value

A 32-bit integer that specifies the port for redirecting requests that are redirected as HTTP requests.

Remarks

This property is read/write. Its default value is 80.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCWebPublishingProperties


PassOptionsRequestsToServer property [ISA Server 2004]

PassOptionsRequestsToServer Property of IFPCWebPublishingProperties[C++]

FPCWebPublishingProperties.PassOptionsRequestsToServer [Visual Basic]

[C++]

The PassOptionsRequestsToServer property gets or sets a Boolean value that indicates whether the ISA Server Web proxy will pass options requests to the published server.

HRESULT get_PassOptionsRequestsToServer(
  VARIANT_BOOL* pfPassOptionsRequestsToServer
);

HRESULT put_PassOptionsRequestsToServer(
  VARIANT_BOOL fPassOptionsRequestsToServer
);

Parameters

pfPassOptionsRequestsToServer
Pointer to a Boolean variable that is set on return to VARIANT_TRUE if the Web proxy will pass options requests to the published server, or to VARIANT_FALSE if the Web proxy will not pass options requests to the published server.
fPassOptionsRequestsToServer
Boolean value that indicates whether the Web proxy will pass options requests to the published server.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write. Its default value is VARIANT_TRUE.

[Visual Basic]

The PassOptionsRequestsToServer property gets or sets a Boolean value that indicates whether the ISA Server Web proxy will pass options requests to the published server.

Property PassOptionsRequestsToServer As Boolean

Property Value

Boolean value that indicates whether the Web proxy will pass options requests to the published server.

Remarks

This property is read/write. Its default value is True.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCWebPublishingProperties


IFPCWebPublishingProperties.PathMappings property [ISA Server 2004]

PathMappings Property of IFPCWebPublishingProperties[C++]

FPCWebPublishingProperties.PathMappings [Visual Basic]

[C++]

The PathMappings property gets an FPCPathMappings collection that contains mappings of published website names to the internal path of the website.

HRESULT get_PathMappings(
  IFPCPathMappings** ppPathMappings
);

Parameters

ppPathMappings
Address of an interface pointer that on return points to an IFPCPathMappings interface that represents the collection of path mappings.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only. It can be modified by calling the methods of the IFPCPathMappings interface retrieved.

[Visual Basic]

The PathMappings property gets an FPCPathMappings collection that contains mappings of published website names to the internal path of the website.

Property PathMappings As FPCPathMappings

Property Value

Reference to an FPCPathMappings collection that contains mappings of published website names to the internal path of the website.

Remarks

This property is read-only. It can be modified by calling the methods of the FPCPathMappings collection retrieved.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCWebPublishingProperties


IFPCWebPublishingProperties.PublicNames (1 Parameter) property [ISA Server 2004]

PublicNames Property of IFPCWebPublishingProperties[C++]

FPCWebPublishingProperties.PublicNames [Visual Basic]

[C++]

The PublicNames property gets an FPCPublicNames collection that contains names that are resolved to the name or IP address of the Web server published by the rule.

HRESULT get_PublicNames(
  IFPCPublicNames** ppPublicNames
);

Parameters

ppPublicNames
Address of an interface pointer that on return points to an IFPCPublicNames interface that represents the collection of public names.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only. It can be modified by calling the methods of the IFPCPublicNames interface retrieved.

[Visual Basic]

The PublicNames property gets an FPCPublicNames collection that contains names that are resolved to the name or IP address of the Web server published by the rule.

Property PublicNames As FPCPublicNames

Property Value

Reference to an FPCPublicNames collection that contains names that are resolved to the name or IP address of the Web server published by the rule.

Remarks

This property is read-only. It can be modified by calling the methods of the FPCPublicNames collection retrieved.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCWebPublishingProperties


IFPCWebPublishingProperties.PublishedServerType property [ISA Server 2004]

PublishedServerType Property of IFPCWebPublishingProperties[C++]

FPCWebPublishingProperties.PublishedServerType [Visual Basic]

[C++]

The PublishedServerType property gets or sets a value from the FpcPublishedServerType enumerated type that indicates the type of published server to which the rule applies.

HRESULT get_PublishedServerType(
  FpcPublishedServerType* pServerType
);

HRESULT put_PublishedServerType(
  FpcPublishedServerType ServerType
);

Parameters

pServerType
Pointer to a value from the FpcPublishedServerType enumerated type that is set on return to:

  • fpcWebServerThruHTTP, if the published server accepts requests routed using the HTTP protocol.
  • fpcWebServerThruSSL, if the published server accepts requests routed using the HTTP protocol over a secure channel.
  • fpcWebServerThruBothHTTPAndSSL, if the published server accepts HTTP requests routed using the HTTP protocol and HTTP requests sent over a secure channel that are routed using the HTTP protocol over a secure channel.
  • fpcFTPServer, if the published server accepts requests routed using the FTP protocol.
ServerType
Value from the FpcPublishedServerType enumerated type that indicates the type of published server to which the rule applies.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write.

[Visual Basic]

The PublishedServerType property gets or sets a value from the FpcPublishedServerType enumerated type that indicates the type of published server to which the rule applies.

Property PublishedServerType As FpcPublishedServerType

Property Value

Value from the FpcPublishedServerType enumerated type. The possible values are:

  • fpcWebServerThruHTTP, which indicates that the published server accepts requests routed using the HTTP protocol.
  • fpcWebServerThruSSL, which indicates that the published server accepts requests routed using the HTTP protocol over a secure channel.
  • fpcWebServerThruBothHTTPAndSSL, which indicates that the published server accepts HTTP requests routed using the HTTP protocol and HTTP requests sent over a secure channel that are routed using the HTTP protocol over a secure channel.
  • fpcFTPServer, which indicates that the published server accepts requests routed using the FTP protocol.

Remarks

This property is read/write.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCWebPublishingProperties


IFPCWebPublishingProperties.SendAcceptEncodingHeader property [ISA Server 2004]

SendAcceptEncodingHeader Property of IFPCWebPublishingProperties[C++]

FPCWebPublishingProperties.SendAcceptEncodingHeader [Visual Basic]

[C++]

The SendAcceptEncodingHeader property gets or sets a Boolean value that indicates whether ISA Server sends the original Accept-Encoding header received from the client to the published server.

HRESULT get_SendAcceptEncodingHeader(
  VARIANT_BOOL* pfSendAcceptEncodingHeader
);

HRESULT put_SendAcceptEncodingHeader(
  VARIANT_BOOL fSendAcceptEncodingHeader
);

Parameters

pfSendAcceptEncodingHeader
Pointer to a Boolean variable that is set on return to VARIANT_TRUE if ISA Server sends the original Accept-Encoding header received from the client to the published server, or to VARIANT_FALSE if ISA Server deletes any Accept-Encoding header supplied by the client from the request forwarded to the published server.
fSendAcceptEncodingHeader
Boolean value that indicates whether ISA Server sends the original Accept-Encoding header received from the client to the published server.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write. Its default value is VARIANT_FALSE for an ordinary Web publishing rule and VARIANT_TRUE for an Outlook Web Access publishing rule created using the Mail Publishing Rule Wizard.

If a Web publishing rule allows the ISA Server computer to forward Accept-Encoding headers from clients to a Web server and a client sends an Accept-Encoding header indicating that it will accept compressed content, the Web server may send a compressed response (as indicated by its Content-Encoding header), which will be accepted by the ISA Server computer and forwarded to the client. However, the ISA Server computer will not cache the compressed content.

If a Web publishing rule instructs the ISA Server computer to delete all Accept-Encoding headers from requests sent to the Web server (the default setting) and the Web server nevertheless sends a compressed response, the ISA Server computer will not forward the response to the client.

[Visual Basic]

The SendAcceptEncodingHeader property gets or sets a Boolean value that indicates whether ISA Server sends the original Accept-Encoding header received from the client to the published server.

Property SendAcceptEncodingHeader As Boolean

Property Value

Boolean value that indicates whether ISA Server sends the original Accept-Encoding header received from the client to the published server.

Remarks

This property is read/write. Its default value is False for an ordinary Web publishing rule and True for an Outlook Web Access publishing rule created using the Mail Publishing Rule Wizard.

If a Web publishing rule allows the ISA Server computer to forward Accept-Encoding headers from clients to a Web server and a client sends an Accept-Encoding header indicating that it will accept compressed content, the Web server may send a compressed response (as indicated by its Content-Encoding header), which will be accepted by the ISA Server computer and forwarded to the client. However, the ISA Server computer will not cache the compressed content.

If a Web publishing rule instructs the ISA Server computer to delete all Accept-Encoding headers from requests sent to the Web server (the default setting) and the Web server nevertheless sends a compressed response, the ISA Server computer will not forward the response to the client.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCWebPublishingProperties


IFPCWebPublishingProperties.SendOriginalHostHeader property [ISA Server 2004]

SendOriginalHostHeader Property of IFPCWebPublishingProperties[C++]

FPCWebPublishingProperties.SendOriginalHostHeader [Visual Basic]

[C++]

The SendOriginalHostHeader property gets or sets a Boolean value that indicates whether ISA Server sends the original HTTP Host header or a Host header corresponding to the name or IP address specified in the WebSite property of the rule.

HRESULT get_SendOriginalHostHeader(
  VARIANT_BOOL* pfSendOriginalHostHeader
);

HRESULT put_SendOriginalHostHeader(
  VARIANT_BOOL fSendOriginalHostHeader
);

Parameters

pfSendOriginalHostHeader
Pointer to a Boolean variable that is set on return to VARIANT_TRUE if ISA Server sends the original HTTP Host header, or to VARIANT_FALSE if ISA Server sends a Host header corresponding to the name or IP address specified in the WebSite property of the rule.
fSendOriginalHostHeader
Boolean value that indicates whether ISA Server sends the original HTTP Host header or a Host header corresponding to the name or IP address specified in the WebSite property of the rule. The default value is VARIANT_FALSE.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write. Its default value is VARIANT_FALSE.

This property cannot be set through ISA Server Management.

By default, ISA Server sends a Host header corresponding to the published site, that is, a Host header corresponding to the name or IP address specified in the WebSite property of the rule, rather than the original Host header that ISA Server received. However, there are scenarios where the published servers rely on the Host header to generate links on a page instead of generating relative links. These servers must receive the original Host header, which is recognized by the client. This property allows those servers to receive the original Host header.

[Visual Basic]

The SendOriginalHostHeader property gets or sets a Boolean value that indicates whether ISA Server sends the original HTTP Host header or a Host header corresponding to the name or IP address specified in the WebSite property of the rule.

Property SendOriginalHostHeader As Boolean

Property Value

Boolean value that indicates whether ISA Server sends the original HTTP Host header or a Host header corresponding to the name or IP address specified in the WebSite property of the rule. The default value is False.

Remarks

This property is read/write. Its default value is False.

This property cannot be set through ISA Server Management.

By default, ISA Server sends a Host header corresponding to the published site, that is, a Host header corresponding to the name or IP address specified in the WebSite property of the rule, rather than the original Host header that ISA Server received. However, there are scenarios where the published servers rely on the Host header to generate links on a page instead of generating relative links. These servers must receive the original Host header, which is recognized by the client. This property allows those servers to receive the original Host header.

Example Code

The following Visual Basic code fragment sets SendOriginalHostHeader to True for the first policy rule, which is assumed to be a Web publishing rule .

set root = CreateObject("FPC.Root")
set rule = root.GetContainingArray.ArrayPolicy.PolicyRules(1)
rule.WebPublishingProperties.SendOriginalHostHeader = True
rule.Save

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCWebPublishingProperties


IFPCWebPublishingProperties.SetWebListener(String) method [ISA Server 2004]

IFPCWebPublishingProperties::SetWebListener[C++]

FPCWebPublishingProperties.SetWebListener [Visual Basic]

[C++]

The SetWebListener method sets the Web listener to be used by the rule.

HRESULT SetWebListener(
  BSTR WebListenerName
);

Parameters

WebListenerName
[in] String value that specifies the name of the Web listener to be used by the rule. Only the name of an FPCWebListener object in the FPCWebListeners collection is valid.

Return Values

This method returns S_OK if the call is successful; otherwise, it returns an error code.
[Visual Basic]

The SetWebListener method sets the Web listener to be used by the rule.

Sub SetWebListener( _
  ByVal WebListenerName As String _
)

Parameters

WebListenerName
[in] String value that specifies the name of the Web listener to be used by the rule. Only the name of an FPCWebListener object in the FPCWebListeners collection is valid.

Return Values

This method has no return values. If the call is unsuccessful, an error is raised that can be intercepted by using an error handler.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCWebPublishingProperties


IFPCWebPublishingProperties.SSLClientCertificate property [ISA Server 2004]

SSLClientCertificate Property of IFPCWebPublishingProperties[C++]

FPCWebPublishingProperties.SSLClientCertificate [Visual Basic]

[C++]

The SSLClientCertificate property gets or sets an FPCCertificate object that represents the Secure Sockets Layer (SSL) client certificate to use when the ISA Server Web proxy authenticates to the published server.

HRESULT get_SSLClientCertificate(
  IFPCCertificate** ppCertificate
);

HRESULT put_SSLClientCertificate(
  IFPCCertificate* pCertificate
);

Parameters

ppCertificate
Address of an interface pointer that on return points to an IFPCCertificate interface representing the SSL client certificate to use when the Web proxy authenticates to the published server.
pCertificate
Pointer to an IFPCCertificate interface that points on return to the interface representing the SSL client certificate to use when the Web proxy authenticates to the published server.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write.

[Visual Basic]

The SSLClientCertificate property gets or sets an FPCCertificate object that represents the Secure Sockets Layer (SSL) client certificate to use when the ISA Server Web proxy authenticates to the published server.

Property SSLClientCertificate As FPCCertificate

Property Value

Reference to an FPCCertificate object that represents the SSL client certificate to use when the Web proxy authenticates to the published server.

Remarks

This property is read/write.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCWebPublishingProperties


IFPCWebPublishingProperties.SSLRedirectPort property [ISA Server 2004]

SSLRedirectPort Property of IFPCWebPublishingProperties[C++]

FPCWebPublishingProperties.SSLRedirectPort [Visual Basic]

[C++]

The SSLRedirectPort property gets or sets the port for redirecting requests that are redirected as Secure Sockets Layer (SSL) requests.

HRESULT get_SSLRedirectPort(
  long* plSSLRedirectPort
);

HRESULT put_SSLRedirectPort(
  long lSSLRedirectPort
);

Parameters

plSSLRedirectPort
Pointer to a variable that on return receives a 32-bit integer specifying the port for redirecting requests that are redirected as SSL requests.
lSSLRedirectPort
A 32-bit integer that specifies the port for redirecting requests that are redirected as SSL requests.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write. Its default value is 443.

[Visual Basic]

The SSLRedirectPort property gets or sets the port for redirecting requests that are redirected as Secure Sockets Layer (SSL) requests.

Property SSLRedirectPort As Long

Property Value

A 32-bit integer that specifies the port for redirecting requests that are redirected as SSL requests.

Remarks

This property is read/write. Its default value is 443.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCWebPublishingProperties


IFPCWebPublishingProperties.SSLRequireSecureChannel property [ISA Server 2004]

SSLRequireSecureChannel Property of IFPCWebPublishingProperties[C++]

FPCWebPublishingProperties.SSLRequireSecureChannel [Visual Basic]

[C++]

The SSLRequireSecureChannel property gets or sets a value from the FpcSSLRequireSecureChannelMode enumerated type that indicates whether a secure channel is required and whether 128-bit encryption is required.

HRESULT get_SSLRequireSecureChannel(
  FpcSSLRequireSecureChannelMode* pFpcSSLRequireSecureChannelMode
);

HRESULT put_SSLRequireSecureChannel(
  FpcSSLRequireSecureChannelMode FpcSSLRequireSecureChannelMode
);

Parameters

pFpcSSLRequireSecureChannelMode
Pointer to a value from the FpcSSLRequireSecureChannelMode enumerated type that is set on return to:

  • fpcSSLDontRequireSecureChannel, which indicates that a secure channel is not required.
  • fpcSSLRequireSecureChannel, which indicates that a secure channel is required.
  • fpcSSLRequire128BitSecureChannel, which indicates that a secure channel using 128-bit encryption is required.
  • fpcSSLRequireBoth, which indicates that a secure channel and 128-bit encryption are required.
FpcSSLRequireSecureChannelMode
Value from the FpcSSLRequireSecureChannelMode enumerated type that indicates whether a secure channel is required and whether 128-bit encryption is required.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write. The default value is fpcSSLDontRequireSecureChannel, which indicates that a secure channel is not required.

[Visual Basic]

The SSLRequireSecureChannel property gets or sets a value from the FpcSSLRequireSecureChannelMode enumerated type that indicates whether a secure channel is required and whether 128-bit encryption is required.

Property SSLRequireSecureChannel As FpcSSLRequireSecureChannelMode

Property Value

Value from the FpcSSLRequireSecureChannelMode enumerated type. The possible values are:

  • fpcSSLDontRequireSecureChannel, which indicates that a secure channel is not required.
  • fpcSSLRequireSecureChannel, which indicates that a secure channel is required.
  • fpcSSLRequire128BitSecureChannel, which indicates that a secure channel using 128-bit encryption is required.
  • fpcSSLRequireBoth, which indicates that a secure channel and 128-bit encryption are required.

Remarks

This property is read/write. The default value is fpcSSLDontRequireSecureChannel, which indicates that a secure channel is not required.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCWebPublishingProperties


IFPCWebPublishingProperties.TranslateLinks property [ISA Server 2004]

TranslateLinks Property of IFPCWebPublishingProperties[C++]

FPCWebPublishingProperties.TranslateLinks [Visual Basic]

[C++]

The TranslateLinks property gets or sets a Boolean value that indicates whether links are translated to the public names recognized by the rule.

HRESULT get_TranslateLinks(
  VARIANT_BOOL* pfTranslateLinks
);

HRESULT put_TranslateLinks(
  VARIANT_BOOL fTranslateLinks
);

Parameters

pfTranslateLinks
Pointer to a Boolean variable that is set on return to VARIANT_TRUE if links are translated to the public names recognized by the rule, or to VARIANT_FALSE if links are not translated.
fTranslateLinks
Boolean value that indicates whether links are translated to the public names recognized by the rule.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write. Its default value is VARIANT_FALSE.

[Visual Basic]

The TranslateLinks property gets or sets a Boolean value that indicates whether links are translated to the public names recognized by the rule.

Property TranslateLinks As Boolean

Property Value

Boolean value that indicates whether links are translated to the public names recognized by the rule.

Remarks

This property is read/write. Its default value is False.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCWebPublishingProperties


IFPCWebPublishingProperties.UseFirewallIPAsSource property [ISA Server 2004]

UseFirewallIPAsSource Property of IFPCWebPublishingProperties[C++]

FPCWebPublishingProperties.UseFirewallIPAsSource [Visual Basic]

[C++]

The UseFirewallIPAsSource property gets or sets a Boolean value that indicates whether the firewall IP address will be used as the source IP address when a request is forwarded to the server.

HRESULT get_UseFirewallIPAsSource(
  VARIANT_BOOL* pfUseFirewallIPAsSource
);

HRESULT put_UseFirewallIPAsSource(
  VARIANT_BOOL fUseFirewallIPAsSource
);

Parameters

pfUseFirewallIPAsSource
Pointer to a Boolean variable that is set on return to VARIANT_TRUE if the firewall IP address will be used as the source IP address when a request is forwarded to the server, or to VARIANT_FALSE if the original source IP address will not be used.
fUseFirewallIPAsSource
Boolean value that indicates whether the firewall IP address will be used as the source IP address when a request written in the published protocol of the rule is forwarded to the server.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write. Its default value is VARIANT_TRUE.

[Visual Basic]

The UseFirewallIPAsSource property gets or sets a Boolean value that indicates whether the firewall IP address will be used as the source IP address when a request is forwarded to the server.

Property UseFirewallIPAsSource As Boolean

Property Value

Boolean value that indicates whether the firewall IP address will be used as the source IP address when a request is forwarded to the server.

Remarks

This property is read/write. Its default value is True.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCWebPublishingProperties


IFPCWebPublishingProperties.UserSets(IFPCRefs) property [ISA Server 2004]

UserSets Property of IFPCWebPublishingProperties[C++]

FPCWebPublishingProperties.UserSets [Visual Basic]

[C++]

The UserSets property gets an FPCRefs collection that contains references to the user sets to which the rule applies.

HRESULT get_UserSets(
  IFPCRefs** ppRefs
);

Parameters

ppRefs
Address of an interface pointer that on return points to an IFPCRefs interface that represents the collection of references to the user sets.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only. It can be modified by calling the methods of the IFPCRefs interface retrieved.

[Visual Basic]

The UserSets property gets an FPCRefs collection that contains references to the user sets to which the rule applies.

Property UserSets As FPCRefs

Property Value

Reference to an FPCRefs collection that contains references to the user sets to which the rule applies.

Remarks

This property is read-only. It can be modified by calling the methods of the FPCRefs collection retrieved.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCWebPublishingProperties


IFPCWebPublishingProperties.WebListenerUsed(IFPCRef) property [ISA Server 2004]

WebListenerUsed Property of IFPCWebPublishingProperties[C++]

FPCWebPublishingProperties.WebListenerUsed [Visual Basic]

[C++]

The WebListenerUsed property gets an FPCRef object that references the FPCWebListener object representing the Web listener used for the rule.

HRESULT get_WebListenerUsed(
  IFPCRef** ppRef
);

Parameters

ppRef
Address of an interface pointer that on return points to an IFPCRef interface that references the FPCWebListener object representing the Web listener used for the rule.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This property is read-only. The Web listener used for the rule can be set by calling the SetWebListener method.

[Visual Basic]

The WebListenerUsed property gets an FPCRef object that references the FPCWebListener object representing the Web listener used for the rule.

Property WebListenerUsed As FPCRef

Property Value

Reference to an FPCRef object that references the FPCWebListener object representing the Web listener used for the rule.

Remarks

This property is read-only. The Web listener used for the rule can be set by calling the SetWebListener method.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCWebPublishingProperties


IFPCWebPublishingProperties.WebSite(BSTR,BSTR) property [ISA Server 2004]

WebSite Property of IFPCWebPublishingProperties[C++]

FPCWebPublishingProperties.WebSite [Visual Basic]

[C++]

The WebSite property gets or sets the name or IP address of the server to which the rule redirects requests.

HRESULT get_WebSite(
  BSTR* pbstrWebSite
);

HRESULT put_WebSite(
  BSTR bstrWebSite
);

Parameters

pbstrWebSite
Pointer to a BSTR that is set on return to a string value specifying the name or IP address of the server to which the rule redirects requests.
bstrWebSite
BSTR that specifies the name or IP address of the server to which the rule redirects requests.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write. It must be set before the properties of a new Web publishing rule can be written to persistent storage by calling the Save method.

[Visual Basic]

The WebSite property gets or sets the name or IP address of the server to which the rule redirects requests.

Property WebSite As String

Property Value

String that specifies the name or IP address of the server to which the rule redirects requests.

Remarks

This property is read/write. It must be set before the properties of a new Web publishing rule can be written to persistent storage by calling the Save method.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCWebPublishingProperties


FPCWebUsageReports object [ISA Server 2004]

FPCWebUsageReports

The FPCWebUsageReports object contains the properties of Web usage reports. This object is typically accessed through the WebUsageReports property of an FPCReportsProperties object.

Click here to see the ISA Server object hierarchy.

Inheritance

This object inherits from the FPCPersist object, which contains methods and properties related to the persistent storage of an object's data. They include methods for exporting the object's data to and importing it from an XML document.

Methods

This object has no methods.

Properties

The FPCWebUsageReports object has the following properties.

Property | Description
BrowsersReportSortOrder | Gets or sets a value from the FpcBrowsersReportSortOrder enumerated type that specifies how the information in the browsers report is to be sorted.
BrowsersReportTopNumber | Gets or sets the number of most frequently used browsers to include in the report.
ObjectTypesReportSortOrder | Gets or sets a value from the FpcObjectTypesReportSortOrder enumerated type that specifies how the information in the object types report is to be sorted.
ObjectTypesReportTopNumber | Gets or sets the number of most frequently requested object types to include in the report.
OperatingSystemsReportSortOrder | Gets or sets a value from the FpcOperatingSystemsReportSortOrder enumerated type that specifies how the information in the operating systems report is to be sorted.
OperatingSystemsReportTopNumber | Gets or sets the number of most frequently used client operating systems to include in the report.
ProtocolsReportSortOrder | Gets or sets a value from the FpcTopWebProtocolReportSortOrder enumerated type that specifies how the information in the protocols report is to be sorted.
ProtocolsReportTopNumber | Gets or sets the number of most frequently used protocols to include in the report.
SitesReportSortOrder | Gets or sets a value from the FpcTopSitesReportSortOrder enumerated type that specifies how the information in the sites report is to be sorted.
SitesReportTopNumber | Gets or sets the number of most frequently requested sites to include in the report.
UsersReportSortOrder | Gets or sets a value from the FpcTopUsersReportSortOrder enumerated type that specifies how the information in the users report is to be sorted.
UsersReportTopNumber | Gets or sets the number of most active users to include in the report.

Methods Inherited from FPCPersist

Name | Description
CancelWaitForChanges | Cancels the registration established by the WaitForChanges method (for use in C and C++ programming only).
CanImport | Returns a Boolean value that indicates whether the object's properties can be imported from the specified XML document.
Export | Writes the stored values of all of the object's properties to the specified XML document.
ExportToFile | Writes the stored values of all of the object's properties to the specified XML file.
GetServiceRestartMask | Retrieves a 32-bit bitmask of the FpcServices enumerated type that specifies which services need to be restarted for currently unsaved changes to take effect.
Import | Copies the values of all of the object's properties from the specified XML document to persistent storage.
ImportFromFile | Copies the values of all of the object's properties from the specified XML file to persistent storage.
LoadDocProperties | Provides the XML document's properties so that you can know what information can be imported from the document.
Refresh | Reads the values of all of the object's properties from persistent storage, overwriting any changes that have not been saved.
Save | Writes the current values of all of the object's properties to persistent storage.
WaitForChanges | Registers to wait for an event indicating that the contents of the object have changed (for use in C and C++ programming only).

Properties Inherited from FPCPersist

Name | Description
PersistentName | Gets the persistent name of the object. The persistent name of an object is a name that is unique for the object at the respective level of the COM object hierarchy.
VendorParametersSets | Gets an FPCVendorParametersSets object that can hold sets of custom data for extending the object.

Remarks

This collection implements the IFPCWebUsageReports interface.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

COM Objects


IFPCWebUsageReports.BrowsersReportSortOrder property [ISA Server 2004]

BrowsersReportSortOrder Property of IFPCWebUsageReports[C++]

FPCWebUsageReports.BrowsersReportSortOrder [Visual Basic]

[C++]

The BrowsersReportSortOrder property gets or sets how the information in the browsers report is to be sorted. The browsers report contains information about which Web browsers clients are using. The report can be sorted according to the number of users that use each Web browser, or the number of requests made using each Web browser.

HRESULT get_BrowsersReportSortOrder(
  FpcBrowsersReportSortOrder* pBrowsersSortOrder
);

HRESULT put_BrowsersReportSortOrder(
  FpcBrowsersReportSortOrder BrowsersSortOrder
);

Parameters

pBrowsersSortOrder
Pointer to a variable that on return receives a value from the FpcBrowsersReportSortOrder enumerated type specifying how the information in the browsers report is to be sorted.
BrowsersSortOrder
Value from the FpcBrowsersReportSortOrder enumerated type that indicates how the information in the browsers report is to be sorted.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write.

[Visual Basic]

The BrowsersReportSortOrder property gets or sets how the information in the browsers report is to be sorted. The browsers report contains information about which Web browsers clients are using. The report can be sorted according to the number of users that use each Web browser, or the number of requests made using each Web browser.

Property BrowsersReportSortOrder As FpcBrowsersReportSortOrder

Property Value

Value from the FpcBrowsersReportSortOrder enumerated type that indicates how the information in the browsers report is to be sorted.

Remarks

This property is read/write.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCWebUsageReports


IFPCWebUsageReports.BrowsersReportTopNumber property [ISA Server 2004]

BrowsersReportTopNumber Property of IFPCWebUsageReports[C++]

FPCWebUsageReports.BrowsersReportTopNumber [Visual Basic]

[C++]

The BrowsersReportTopNumber property gets or sets the number of most frequently used browsers to include in the report.

HRESULT get_BrowsersReportTopNumber(
  long* plTopNBrowsers
);

HRESULT put_BrowsersReportTopNumber(
  long lTopNBrowsers
);

Parameters

plTopNBrowsers
Pointer to a variable that on return receives a 32-bit integer specifying the number of most frequently used browsers to include in the report.
lTopNBrowsers
A 32-bit integer that specifies the number of most frequently used browsers to include in the report.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write.

[Visual Basic]

The BrowsersReportTopNumber property gets or sets the number of most frequently used browsers to include in the report.

Property BrowsersReportTopNumber As Long

Property Value

A 32-bit integer that specifies the number of most frequently used browsers to include in the report.

Remarks

This property is read/write.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCWebUsageReports


IFPCWebUsageReports.ObjectTypesReportSortOrder property [ISA Server 2004]

ObjectTypesReportSortOrder Property of IFPCWebUsageReports[C++]

FPCWebUsageReports.ObjectTypesReportSortOrder [Visual Basic]

[C++]

The ObjectTypesReportSortOrder property gets or sets how the information in the object types report is to be sorted. The object types report contains information about which Web object types clients are retrieving. The report can be sorted according to the number of users that request each object type, the number of requests for each object type, or the number of incoming bytes transferred for each object type.

HRESULT get_ObjectTypesReportSortOrder(
  FpcObjectTypesReportSortOrder* pObjectTypesSortOrder
);

HRESULT put_ObjectTypesReportSortOrder(
  FpcObjectTypesReportSortOrder ObjectTypesSortOrder
);

Parameters

pObjectTypesSortOrder
Pointer to a variable that on return receives a value from the FpcObjectTypesReportSortOrder enumerated type specifying how the information in the object types report is to be sorted.
ObjectTypesSortOrder
Value from the FpcObjectTypesReportSortOrder enumerated type that indicates how the information in the object types report is to be sorted.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write.

[Visual Basic]

The ObjectTypesReportSortOrder property gets or sets how the information in the object types report is to be sorted. The object types report contains information about which Web object types clients are retrieving. The report can be sorted according to the number of users that request each object type, the number of requests for each object type, or the number of incoming bytes transferred for each object type.

Property ObjectTypesReportSortOrder As FpcObjectTypesReportSortOrder

Property Value

Value from the FpcObjectTypesReportSortOrder enumerated type that indicates how the information in the object types report is to be sorted.

Remarks

This property is read/write.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCWebUsageReports


IFPCWebUsageReports.ObjectTypesReportTopNumber property [ISA Server 2004]

ObjectTypesReportTopNumber Property of IFPCWebUsageReports[C++]

FPCWebUsageReports.ObjectTypesReportTopNumber [Visual Basic]

[C++]

The ObjectTypesReportTopNumber property gets or sets the number of most frequently requested object types to include in the report.

HRESULT get_ObjectTypesReportTopNumber(
  long* plTopNObjectTypes
);

HRESULT put_ObjectTypesReportTopNumber(
  long lTopNObjectTypes
);

Parameters

plTopNObjectTypes
Pointer to a variable that on return receives a 32-bit integer specifying the number of most frequently requested object types to include in the report.
lTopNObjectTypes
A 32-bit integer that specifies the number of most frequently requested object types to include in the report.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write.

[Visual Basic]

The ObjectTypesReportTopNumber property gets or sets the number of most frequently requested object types to include in the report.

Property ObjectTypesReportTopNumber As Long

Property Value

A 32-bit integer that specifies the number of most frequently requested object types to include in the report.

Remarks

This property is read/write.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCWebUsageReports


IFPCWebUsageReports.OperatingSystemsReportSortOrder property [ISA Server 2004]

OperatingSystemsReportSortOrder Property of IFPCWebUsageReports[C++]

FPCWebUsageReports.OperatingSystemsReportSortOrder [Visual Basic]

[C++]

The OperatingSystemsReportSortOrder property gets or sets a value from the FpcOperatingSystemsReportSortOrder enumerated type that specifies how the information in the operating systems report is to be sorted. The operating systems report contains information about which operating systems clients are using. The report can be sorted according to the number of users that use each operating system, or the number of requests made using each operating system.

HRESULT get_OperatingSystemsReportSortOrder(
  FpcOperatingSystemsReportSortOrder* pOperatingSystemsSortOrder
);

HRESULT put_OperatingSystemsReportSortOrder(
  FpcOperatingSystemsReportSortOrder OperatingSystemsSortOrder
);

Parameters

pOperatingSystemsSortOrder
Pointer to a variable that on return receives a value from the FpcOperatingSystemsReportSortOrder enumerated type that specifies how the information in the operating systems report is to be sorted.
OperatingSystemsSortOrder
Value from the FpcOperatingSystemsReportSortOrder enumerated type that specifies how the information in the operating systems report is to be sorted.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write.

[Visual Basic]

The OperatingSystemsReportSortOrder property gets or sets a value from the FpcOperatingSystemsReportSortOrder enumerated type that specifies how the information in the operating systems report is to be sorted. The operating systems report contains information about which operating systems clients are using. The report can be sorted according to the number of users that use each operating system, or the number of requests made using each operating system.

Property OperatingSystemsReportSortOrder As FpcOperatingSystemsReportSortOrder

Property Value

Value from the FpcOperatingSystemsReportSortOrder enumerated type that specifies how the information in the operating systems report is to be sorted.

Remarks

This property is read/write.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCWebUsageReports


IFPCWebUsageReports.OperatingSystemsReportTopNumber property [ISA Server 2004]

OperatingSystemsReportTopNumber Property of IFPCWebUsageReports[C++]

FPCWebUsageReports.OperatingSystemsReportTopNumber [Visual Basic]

[C++]

The OperatingSystemsReportTopNumber property gets or sets the number of most frequently used client operating systems to include in the report.

HRESULT get_OperatingSystemsReportTopNumber(
  long* plTopNOperatingSystems
);

HRESULT put_OperatingSystemsReportTopNumber(
  long lTopNOperatingSystems
);

Parameters

plTopNOperatingSystems
Pointer to a variable that on return receives a 32-bit integer specifying the number of most frequently used client operating systems to include in the report.
lTopNOperatingSystems
A 32-bit integer that specifies the number of most frequently used client operating systems to include in the report.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write.

[Visual Basic]

The OperatingSystemsReportTopNumber property gets or sets the number of most frequently used client operating systems to include in the report.

Property OperatingSystemsReportTopNumber As Long

Property Value

A 32-bit integer that specifies the number of most frequently used client operating systems to include in the report.

Remarks

This property is read/write.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCWebUsageReports


IFPCWebUsageReports.ProtocolsReportSortOrder property [ISA Server 2004]

ProtocolsReportSortOrder Property of IFPCWebUsageReports[C++]

FPCWebUsageReports.ProtocolsReportSortOrder [Visual Basic]

[C++]

The ProtocolsReportSortOrder property gets or sets a value from the FpcTopWebProtocolReportSortOrder enumerated type that specifies how the information in the protocols report is to be sorted. The protocols report contains information about which Web protocols clients are using. The report can be sorted according to the number of users that use each protocol, the number of requests that are sent using each protocol, or the number of bytes transferred.

HRESULT get_ProtocolsReportSortOrder(
  FpcTopWebProtocolReportSortOrder* pProtocolsSortOrder
);

HRESULT put_ProtocolsReportSortOrder(
  FpcTopWebProtocolReportSortOrder ProtocolsSortOrder
);

Parameters

pProtocolsSortOrder
Pointer to a variable that on return receives a value from the FpcTopWebProtocolReportSortOrder enumerated type that specifies how the information in the protocols report is to be sorted.
ProtocolsSortOrder
Value from the FpcTopWebProtocolReportSortOrder enumerated type that specifies how the information in the protocols report is to be sorted.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write.

[Visual Basic]

The ProtocolsReportSortOrder property gets or sets a value from the FpcTopWebProtocolReportSortOrder enumerated type that specifies how the information in the protocols report is to be sorted. The protocols report contains information about which Web protocols clients are using. The report can be sorted according to the number of users that use each protocol, the number of requests that are sent using each protocol, or the number of bytes transferred.

Property ProtocolsReportSortOrder As FpcTopWebProtocolReportSortOrder

Property Value

Value from the FpcTopWebProtocolReportSortOrder enumerated type that specifies how the information in the protocols report is to be sorted.

Remarks

This property is read/write.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCWebUsageReports


IFPCWebUsageReports.ProtocolsReportTopNumber property [ISA Server 2004]

ProtocolsReportTopNumber Property of IFPCWebUsageReports[C++]

FPCWebUsageReports.ProtocolsReportTopNumber [Visual Basic]

[C++]

The ProtocolsReportTopNumber property gets or sets the number of most frequently used protocols to include in the report.

HRESULT get_ProtocolsReportTopNumber(
  long* plTopNProtocols
);

HRESULT put_ProtocolsReportTopNumber(
  long lTopNProtocols
);

Parameters

plTopNProtocols
Pointer to a variable that on return receives a 32-bit integer specifying the number of most frequently used protocols to include in the report.
lTopNProtocols
A 32-bit integer that specifies the number of most frequently used protocols to include in the report.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write.

[Visual Basic]

The ProtocolsReportTopNumber property gets or sets the number of most frequently used protocols to include in the report.

Property ProtocolsReportTopNumber As Long

Property Value

A 32-bit integer that specifies the number of most frequently used protocols to include in the report.

Remarks

This property is read/write.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCWebUsageReports


IFPCWebUsageReports.SitesReportSortOrder property [ISA Server 2004]

SitesReportSortOrder Property of IFPCWebUsageReports[C++]

FPCWebUsageReports.SitesReportSortOrder [Visual Basic]

[C++]

The SitesReportSortOrder property gets or sets a value from the FpcTopSitesReportSortOrder enumerated type that specifies how the information in the sites report is to be sorted. The sites report contains information about which sites clients are visiting. The report can be sorted according to the number of users that visit each site, the number of requests sent to each site, or the number of bytes transferred.

HRESULT get_SitesReportSortOrder(
  FpcTopWebSiteReportSortOrder* pSitesSortOrder
);

HRESULT put_SitesReportSortOrder(
  FpcTopWebSiteReportSortOrder SitesSortOrder
);

Parameters

pSitesSortOrder
Pointer to a variable that on return receives a value from the FpcTopSitesReportSortOrder enumerated type that specifies how the information in the sites report is to be sorted.
SitesSortOrder
Value from the FpcTopSitesReportSortOrder enumerated type that specifies how the information in the sites report is to be sorted.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write.

[Visual Basic]

The SitesReportSortOrder property gets or sets a value from the FpcTopSitesReportSortOrder enumerated type that specifies how the information in the sites report is to be sorted. The sites report contains information about which sites clients are visiting. The report can be sorted according to the number of users that visit each site, the number of requests sent to each site, or the number of bytes transferred.

Property SitesReportSortOrder As FpcTopWebSiteReportSortOrder

Property Value

Value from the FpcTopSitesReportSortOrder enumerated type that specifies how the information in the sites report is to be sorted.

Remarks

This property is read/write.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCWebUsageReports


IFPCWebUsageReports.SitesReportTopNumber(long,long) property [ISA Server 2004]

SitesReportTopNumber Property of IFPCWebUsageReports[C++]

FPCWebUsageReports.SitesReportTopNumber [Visual Basic]

[C++]

The SitesReportTopNumber property gets or sets the number of most frequently requested sites to include in the report.

HRESULT get_SitesReportTopNumber(
  long* plTopNSites
);

HRESULT put_SitesReportTopNumber(
  long lTopNSites
);

Parameters

plTopNSites
Pointer to a variable that on return receives a 32-bit integer specifying the number of most frequently requested sites to include in the report.
lTopNSites
A 32-bit integer that specifies the number of most frequently requested sites to include in the report.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write.

[Visual Basic]

The SitesReportTopNumber property gets or sets the number of most frequently requested sites to include in the report.

Property SitesReportTopNumber As Long

Property Value

A 32-bit integer that specifies the number of most frequently requested sites to include in the report.

Remarks

This property is read/write.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCWebUsageReports


IFPCWebUsageReports.UsersReportSortOrder property [ISA Server 2004]

UsersReportSortOrder Property of IFPCWebUsageReports[C++]

FPCWebUsageReports.UsersReportSortOrder [Visual Basic]

[C++]

The UsersReportSortOrder property gets or sets a value from the FpcTopUsersReportSortOrder enumerated type that specifies how the information in the users report is to be sorted. The users report contains information about the most active users. The report can be sorted according to the number of requests sent by each user or the number of bytes transferred for each user.

HRESULT get_UsersReportSortOrder(
  FpcTopUsersReportSortOrder* pUsersSortOrder
);

HRESULT put_UsersReportSortOrder(
  FpcTopUsersReportSortOrder UsersSortOrder
);

Parameters

pUsersSortOrder
Pointer to a variable that on return receives a value from the FpcTopUsersReportSortOrder enumerated type that specifies how the information in the users report is to be sorted.
UsersSortOrder
Value from the FpcTopUsersReportSortOrder enumerated type that specifies how the information in the users report is to be sorted.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write.

[Visual Basic]

The UsersReportSortOrder property gets or sets a value from the FpcTopUsersReportSortOrder enumerated type that specifies how the information in the users report is to be sorted. The users report contains information about the most active users. The report can be sorted according to the number of requests sent by each user or the number of bytes transferred for each user.

Property UsersReportSortOrder As FpcTopUsersReportSortOrder

Property Value

Value from the FpcTopUsersReportSortOrder enumerated type that specifies how the information in the users report is to be sorted.

Remarks

This property is read/write.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCWebUsageReports


IFPCWebUsageReports.UsersReportTopNumber(long,long) property [ISA Server 2004]

UsersReportTopNumber Property of IFPCWebUsageReports[C++]

FPCWebUsageReports.UsersReportTopNumber [Visual Basic]

[C++]

The UsersReportTopNumber property gets or sets the number of most active users to include in the report.

HRESULT get_UsersReportTopNumber(
  long* plTopNUsers
);

HRESULT put_UsersReportTopNumber(
  long lTopNUsers
);

Parameters

plTopNUsers
Pointer to a variable that on return receives a 32-bit integer specifying the number of most active users to include in the report.
lTopNUsers
A 32-bit integer that specifies the number of most active users to include in the report.

Return Values

These property methods return S_OK if the call is successful; otherwise, they return an error code.

Remarks

This property is read/write.

[Visual Basic]

The UsersReportTopNumber property gets or sets the number of most active users to include in the report.

Property UsersReportTopNumber As Long

Property Value

A 32-bit integer that specifies the number of most active users to include in the report.

Remarks

This property is read/write.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Msfpccom.idl.
Library: Use Microsoft Internet Security and Acceleration Server 2004 Administration Library.

See Also

FPCWebUsageReports


Enumerated Types [ISA Server 2004]

Enumerated Types

This section describes the enumerated data values used by the Internet Security and Acceleration (ISA) Server 2004 administration COM objects. They are defined in Comenum.h.

  • FpcAccountTypes
  • FpcAction
  • FpcActiveCachingPolicy
  • FpcAlertActionTypes
  • FpcAlertCategory
  • FpcAlertSeverity
  • FpcAppliesToContentMethodType
  • FpcArrayType
  • FpcAuthenticationSchemeProvides
  • FpcAuthType
  • FpcBackupRouteType
  • FpcBidirectional
  • FpcBrowserConfigScriptFlag
  • FpcBrowsersReportSortOrder
  • FpcCacheAction
  • FpcCacheContent
  • FpcCacheReportSortOrder
  • FpcClientAuthenticatedValues
  • FpcClientBackupRouteType
  • FpcComponents
  • FpcConnectionDirectionType
  • FpcConnectionProtocolType
  • FpcConnectivityErrorCode
  • FpcConnectivityGroupType
  • FpcDailyFrequency
  • FpcDaysOfWeek
  • FpcExportImportOptionalData
  • FpcFetchUrlFlags
  • FpcFilterCondition
  • FpcFilterCriteria
  • FpcFilterDirection
  • FpcFilterPriority
  • FpcFilterType
  • FpcFilterValueType
  • FpcFwForwardType
  • FpcIncludeStatus
  • FpcIpOptionsAction
  • FpcIPSelectionMethods
  • FpcLogFileDirectoryType
  • FpcLoggingComponents
  • FpcLogServiceType
  • FpcLogType
  • FpcNameSystem
  • FpcNetworkConnectionType
  • FpcNetworkRoutingTypes
  • FpcNetworkSetType
  • FpcNetworkTypes
  • FpcObjectTypesReportSortOrder
  • FpcOperatingSystemsReportSortOrder
  • FpcPolicyRuleActions
  • FpcPolicyRuleTypes
  • FpcPrimaryRouteType
  • FpcProtocolCategory
  • FpcProtocolSelectionType
  • FpcProxyObjSources
  • FpcPublishedServerType
  • FpcPublishProtocolRedirectionType
  • FpcReportJobCategory
  • FpcReportJobPeriodType
  • FpcReportSortOrder
  • FpcReportStatus
  • FpcRequestType
  • FpcScheduleDays
  • FpcScheduledTaskRunningPeriod
  • FpcScheduleHours
  • FpcServices
  • FpcServiceTypes
  • FpcSessionMonitorEvent
  • FpcSessionType
  • FpcSizeUnits
  • FpcSSLRequireSecureChannelMode
  • FpcSystemPolicyConfigGroup
  • FpcTimeScale
  • FpcTopAppProtocolReportSortOrder
  • FpcTopAppsReportSortOrder
  • FpcTopDestinationsReportSortOrder
  • FpcTopSitesReportSortOrder
  • FpcTopUsersReportSortOrder
  • FpcTopWebProtocolReportSortOrder
  • FpcUDPConnectionDirectionType
  • FpcVpnAuthenticationMethod
  • FpcVpnDiffieHellmanGroup
  • FpcVpnEncryptionAlgorithm
  • FpcVpnIntegrityAlgorithm
  • FpcVpnProtocol
  • FpcVpnQuarantineMode

See Also

Administration Reference


FpcAccountTypes enumeration [ISA Server 2004]

FpcAccountTypes

The FpcAccountTypes enumerated type contains values that describe types of Windows 2000 Server and Windows Server 2003 accounts.

typedef enum FpcAccountTypes
{
  fpcAccountTypeUser
fpcAccountTypeUser
A user.
 = 0,
  fpcAccountTypeGroup
fpcAccountTypeGroup
A group of users.
 = 1,
  fpcAccountTypeDomain
fpcAccountTypeDomain
A domain of users.
 = 2,
  fpcAccountTypeAlias
fpcAccountTypeAlias
An alias.
 = 3,
  fpcAccountTypeWellKnownGroup
fpcAccountTypeWellKnownGroup
A predefined account such as "Everyone."
 = 4

} FpcAccountTypes;

Constants

fpcAccountTypeUser
A user.
fpcAccountTypeGroup
A group of users.
fpcAccountTypeDomain
A domain of users.
fpcAccountTypeAlias
An alias.
fpcAccountTypeWellKnownGroup
A predefined account such as "Everyone."

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Comenum.h.

See Also

Enumerated Types


FpcAction enumeration [ISA Server 2004]

FpcAction

The FpcAction enumerated type contains values that specify types of actions that can be performed by the Microsoft Firewall service for a session or a connection.

typedef enum FpcAction
{
  fpcActionNotLogged
fpcActionNotLogged
No action was  logged.
 = 0,
  fpcActionBind
fpcActionBind
The Firewall service associated a local address with a socket.
 = 1,
  fpcActionListen
fpcActionListen
The Firewall service placed a socket in a state in which it listens for an incoming connection.
 = 2,
  fpcActionGHBN
fpcActionGHBN
The Firewall service retrieved host information corresponding to a host name.
 = 3,
  fpcActionGHBA
fpcActionGHBA
The Firewall service retrieved host information corresponding to a network address.
 = 4,
  fpcActionRedirectBind
fpcActionRedirectBind
The Firewall service enabled a connection using a local address associated with a socket.
 = 5,
  fpcActionEstablish
fpcActionEstablish
The Firewall service established a session.
 = 6,
  fpcActionTerminate
fpcActionTerminate
The Firewall service terminated a session.
 = 7,
  fpcActionDenied
fpcActionDenied
The action requested was denied.
 = 8,
  fpcActionAllowed
fpcActionAllowed
The action requested was allowed.
 = 9,
  fpcActionFailed
fpcActionFailed
The action requested failed.
 = 10,
  fpcActionIntermediate
fpcActionIntermediate
The action was intermediate.
 = 11,
  fpcActionSuccessfulConnection
fpcActionSuccessfulConnection
The Firewall service was successful in establishing a connection to a socket.
 = 12,
  fpcActionUnsuccessfulConnection
fpcActionUnsuccessfulConnection
The Firewall service was unsuccessful in establishing a connection to a socket.
 = 13,
  fpcActionDisconnection
fpcActionDisconnection
The Firewall service closed a connection on a socket.
 = 14,
  fpcActionUserclearedQuarantine
fpcActionUserclearedQuarantine
The Firewall service cleared a quarantined VPN client.
 = 15,
  fpcActionQuarantinetimeout
fpcActionQuarantinetimeout
The Firewall service disqualified a quarantined VPN client after the time-out period elapsed.
 = 16

} FpcAction;

Constants

fpcActionNotLogged
No action was logged.
fpcActionBind
The Firewall service associated a local address with a socket.
fpcActionListen
The Firewall service placed a socket in a state in which it listens for an incoming connection.
fpcActionGHBN
The Firewall service retrieved host information corresponding to a host name.
fpcActionGHBA
The Firewall service retrieved host information corresponding to a network address.
fpcActionRedirectBind
The Firewall service enabled a connection using a local address associated with a socket.
fpcActionEstablish
The Firewall service established a session.
fpcActionTerminate
The Firewall service terminated a session.
fpcActionDenied
The action requested was denied.
fpcActionAllowed
The action requested was allowed.
fpcActionFailed
The action requested failed.
fpcActionIntermediate
The action was intermediate.
fpcActionSuccessfulConnection
The Firewall service was successful in establishing a connection to a socket.
fpcActionUnsuccessfulConnection
The Firewall service was unsuccessful in establishing a connection to a socket.
fpcActionDisconnection
The Firewall service closed a connection on a socket.
fpcActionUserclearedQuarantine
The Firewall service cleared a quarantined VPN client.
fpcActionQuarantinetimeout
The Firewall service disqualified a quarantined VPN client after the time-out period elapsed.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Comenum.h.

See Also

Enumerated Types


FpcActiveCachingPolicy enumeration [ISA Server 2004]

FpcActiveCachingPolicy

The FpcActiveCachingPolicy enumerated type contains values that specify the behavior of the active caching mechanism.

typedef enum FpcActiveCachingPolicy
{
  fpcActiveCachingEmphasizeOnFewerNetworkAccesses
fpcActiveCachingEmphasizeOnFewerNetworkAccesses
Reduced network traffic is more important than the client cache-hit ratio.
 = 1,
  fpcActiveCachingNoEmphasize
fpcActiveCachingNoEmphasize
The client cache-hit ratio and reduced network traffic are equally important.
 = 2,
  fpcActiveCachingEmphasizeOnFasterUserResponse
fpcActiveCachingEmphasizeOnFasterUserResponse
The client cache-hit ratio is more important than reduced network traffic.
 = 3

} FpcActiveCachingPolicy;

Constants

fpcActiveCachingEmphasizeOnFewerNetworkAccesses
Reduced network traffic is more important than the client cache-hit ratio.
fpcActiveCachingNoEmphasize
The client cache-hit ratio and reduced network traffic are equally important.
fpcActiveCachingEmphasizeOnFasterUserResponse
The client cache-hit ratio is more important than reduced network traffic.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Comenum.h.

See Also

Enumerated Types


FpcALertActionTypes enumeration [ISA Server 2004]

FpcAlertActionTypes

The FpcAlertActionTypes enumerated type contains values that describe the types of action that alerts can trigger.

typedef enum FpcALertActionTypes
{
  fpcAlertActionLogEvent
fpcAlertActionLogEvent
Log events to the system event log.
 = 0,
  fpcAlertActionCommand
fpcAlertActionCommand
Run a specified command.
 = 1,
  fpcAlertActionSendMail
fpcAlertActionSendMail
Send an e-mail message.
 = 2,
  fpcAlertActionStopServices
fpcAlertActionStopServices
Stop  the specified ISA Server services.
 = 3,
  fpcAlertActionStartServices
fpcAlertActionStartServices
Start the specified ISA Server services.
 = 4

} FpcALertActionTypes;

Constants

fpcAlertActionLogEvent
Log events to the system event log.
fpcAlertActionCommand
Run a specified command.
fpcAlertActionSendMail
Send an e-mail message.
fpcAlertActionStopServices
Stop the specified ISA Server services.
fpcAlertActionStartServices
Start the specified ISA Server services.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Comenum.h.

See Also

Enumerated Types


FpcAlertCategory enumeration [ISA Server 2004]

FpcAlertCategory

The FpcAlertCategory enumerated type contains values that specify the categories of alerts.

typedef enum FpcAlertCategory
{
  fpcSecurityAlerts
fpcSecurityAlerts
Security alerts.
 = 0,
  fpcCacheAlerts
fpcCacheAlerts
Cache alerts.
 = 1,
  fpcRoutingAlerts
fpcRoutingAlerts
Routing alerts.
 = 2,
  fpcFwServiceAlerts
fpcFwServiceAlerts
Microsoft Firewall service alerts, such as alerts that start or stop a  service, or load a filter.
 = 3,
  fpcOtherAlerts
fpcOtherAlerts
Other alerts, including user-defined alerts.
 = 4

} FpcAlertCategory;

Constants

fpcSecurityAlerts
Security alerts.
fpcCacheAlerts
Cache alerts.
fpcRoutingAlerts
Routing alerts.
fpcFwServiceAlerts
Microsoft Firewall service alerts, such as alerts that start or stop a service, or load a filter.
fpcOtherAlerts
Other alerts, including user-defined alerts.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Comenum.h.

See Also

Enumerated Types


FpcAlertSeverity enumeration [ISA Server 2004]

FpcAlertSeverity

The FpcAlertSeverity enumerated type contains values that specify the severity of alerts. The severity determines the type of event that will be recorded in the system log when the alert triggers event logging.

typedef enum FpcAlertSeverity
{
  fpcAlertError
fpcAlertError
Error.
 = 0,
  fpcAlertWarning
fpcAlertWarning
Warning.
 = 1,
  fpcAlertInformation.
fpcAlertInformation.
Information.
 = 2

} FpcAlertSeverity;

Constants

fpcAlertError
Error.
fpcAlertWarning
Warning.
fpcAlertInformation.
Information.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Comenum.h.

See Also

Enumerated Types


FpcAppliesToContentMethodType enumeration [ISA Server 2004]

FpcAppliesToContentMethodType

The FpcAppliesToContentMethodType enumerated type contains values that specify whether an access rule applies to all types of content or only to specified types of content.

typedef enum FpcAppliesToContentMethodType
{
  fpcAppliesToAllContent
fpcAppliesToAllContent
The rule applies to all types of content.
 = 0,
  fpcAppliesToSpecifiedContent
fpcAppliesToSpecifiedContent
The rule applies to specified content.
 = 1

} FpcAppliesToContentMethodType;

Constants

fpcAppliesToAllContent
The rule applies to all types of content.
fpcAppliesToSpecifiedContent
The rule applies to specified content.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Comenum.h.

See Also

Enumerated Types


FpcArrayType enumeration [ISA Server 2004]

FpcArrayType

The FpcArrayType enumerated type contains values that identify whether an array is a stand-alone server or a shared array.

typedef enum FpcArrayType
{
  fpcTypeStandardEdition
fpcTypeStandardEdition
The array consists of a  single stand-alone (registry-based) server running  ISA Server, Standard Edition.
 = 0

} FpcArrayType;

Constants

fpcTypeStandardEdition
The array consists of a single stand-alone (registry-based) server running ISA Server, Standard Edition.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Comenum.h.

See Also

Enumerated Types


FpcAuthenticationSchemeProvides enumeration [ISA Server 2004]

FpcAuthenticationSchemeProvides

The FpcAuthenticationSchemeProvides enumerated type contains values that describe whether an authentication scheme provides a namespace or a method.

typedef enum FpcAuthenticationSchemeProvides
{
  fpcAuthenticationSchemeProvidesNothing
fpcAuthenticationSchemeProvidesNothing
The authentication scheme provides neither  a namespace nor a method.
 = 0x00000000,
  fpcAuthenticationSchemeProvidesNamespace
fpcAuthenticationSchemeProvidesNamespace
The authentication scheme provides   a namespace.
 = 0x00000001,
  fpcAuthenticationSchemeProvidesMethod
fpcAuthenticationSchemeProvidesMethod
The authentication scheme provides   a method.
 = 0x00000002,
  fpcAuthenticationSchemeProvidesBoth
fpcAuthenticationSchemeProvidesBoth
The authentication scheme provides   both a namespace and a method.
 = 0x00000003

} FpcAuthenticationSchemeProvides;

Constants

fpcAuthenticationSchemeProvidesNothing
The authentication scheme provides neither a namespace nor a method.
fpcAuthenticationSchemeProvidesNamespace
The authentication scheme provides a namespace.
fpcAuthenticationSchemeProvidesMethod
The authentication scheme provides a method.
fpcAuthenticationSchemeProvidesBoth
The authentication scheme provides both a namespace and a method.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Comenum.h.

See Also

Enumerated Types


FpcAuthType enumeration [ISA Server 2004]

FpcAuthType

The FpcAuthType enumerated type contains values that specify the type of authentication used for inter-server connections.

typedef enum FpcAuthType
{
  fpcUiAuthBasic
fpcUiAuthBasic
Basic authentication.
 = 0,
  fpcUiAuthIntegrated
fpcUiAuthIntegrated
Windows Integrated Authentication.
 = 1

} FpcAuthType;

Constants

fpcUiAuthBasic
Basic authentication.
fpcUiAuthIntegrated
Windows Integrated Authentication.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Comenum.h.

See Also

Enumerated Types


FpcBackupRouteType enumeration [ISA Server 2004]

FpcBackupRouteType

The FpcBackupRouteType enumerated type contains values that specify the type of backup route.

typedef enum FpcBackupRouteType
{
  fpcBackupRouteNone
fpcBackupRouteNone
There is no backup route.
 = 0,
  fpcBackupRouteDirect
fpcBackupRouteDirect
The backup route is direct to the Internet.
 = 1,
  fpcBackupRouteUpstream
fpcBackupRouteUpstream
The backup route is through an upstream proxy server.
 = 2

} FpcBackupRouteType;

Constants

fpcBackupRouteNone
There is no backup route.
fpcBackupRouteDirect
The backup route is direct to the Internet.
fpcBackupRouteUpstream
The backup route is through an upstream proxy server.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Comenum.h.

See Also

Enumerated Types


FpcBidirectional enumeration [ISA Server 2004]

FpcBidirectional

The FpcBidirectional enumerated type contains values that indicate whether a connection was bidirectional.

typedef enum FpcBidirectional
{
  fpcBidirectionalNotLogged
fpcBidirectionalNotLogged
The log entry does not indicate whether the connection was bidirectional.
 = 0,
  fpcBidirectionalYes
fpcBidirectionalYes
The  connection was bidirectional.
 = 1,
  fpcBidirectionalNo
fpcBidirectionalNo
The  connection was not bidirectional.
 = 2

} FpcBidirectional;

Constants

fpcBidirectionalNotLogged
The log entry does not indicate whether the connection was bidirectional.
fpcBidirectionalYes
The connection was bidirectional.
fpcBidirectionalNo
The connection was not bidirectional.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Comenum.h.

See Also

Enumerated Types


FpcBrowserConfigScriptFlag enumeration [ISA Server 2004]

FpcBrowserConfigScriptFlag

The FpcBrowserConfigScriptFlag enumerated type provides flags that specify the type of script to be used to configure the Web browser.

typedef enum FpcBrowserConfigScriptFlag
{
  fpcBrowserDefaultScript
fpcBrowserDefaultScript
The default script  will be used to configure the Web browser.
 = 0,
  fpcBrowserCustomScript
fpcBrowserCustomScript
A custom script will be used to configure the Web browser.
 = 1

} FpcBrowserConfigScriptFlag;

Constants

fpcBrowserDefaultScript
The default script will be used to configure the Web browser.
fpcBrowserCustomScript
A custom script will be used to configure the Web browser.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Comenum.h.

See Also

Enumerated Types


FpcBrowersReportSortOrder enumeration [ISA Server 2004]

FpcBrowsersReportSortOrder

The FpcBrowsersReportSortOrder enumerated type contains values that specify how the information in a Web browser's report (a Web usage report) will be sorted.

typedef enum FpcBrowersReportSortOrder
{
  fpcBrowsersRequests
fpcBrowsersRequests
The information is to be sorted by the number of requests made using each Web browser.
 = 0,
  fpcBrowsersUsers
fpcBrowsersUsers
The information is to be sorted by the number of users that use each Web browser.
 = 1

} FpcBrowersReportSortOrder;

Constants

fpcBrowsersRequests
The information is to be sorted by the number of requests made using each Web browser.
fpcBrowsersUsers
The information is to be sorted by the number of users that use each Web browser.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Comenum.h.

See Also

Enumerated Types


FpcCacheAction enumeration [ISA Server 2004]

FpcCacheAction

The FpcCacheAction enumerated type contains values that specify the conditions for which an object will be retrieved from the ISA Server cache and the conditions for which a new version of the object will be obtained from the Internet.

typedef enum FpcCacheAction
{
  fpcServeFromCacheIfValidObjectExists
fpcServeFromCacheIfValidObjectExists
If  there is a valid (unexpired) version of the object in the cache, the cached object should be used. Otherwise, a new version of the object should be obtained from the Internet.
 = 0,
  fpcServeFromCacheIfObjectExists
fpcServeFromCacheIfObjectExists
If   any version of the object is found in the cache, the cached object should be used. Otherwise, the object should be obtained from the Internet.
 = 1,
  fpcServeFromCacheOnly
fpcServeFromCacheOnly
If   any version of the object is found in the cache, the cached object should be used. Otherwise, an error page should be returned, and no attempt should be made to obtain the object from the Internet.
 = 2

} FpcCacheAction;

Constants

fpcServeFromCacheIfValidObjectExists
If there is a valid (unexpired) version of the object in the cache, the cached object should be used. Otherwise, a new version of the object should be obtained from the Internet.
fpcServeFromCacheIfObjectExists
If any version of the object is found in the cache, the cached object should be used. Otherwise, the object should be obtained from the Internet.
fpcServeFromCacheOnly
If any version of the object is found in the cache, the cached object should be used. Otherwise, an error page should be returned, and no attempt should be made to obtain the object from the Internet.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Comenum.h.

See Also

Enumerated Types


FpcRouteCacheContent enumeration [ISA Server 2004]

FpcCacheContent

The FpcCacheContent enumerated type contains values that specify the conditions for which a response will be cached.

typedef enum FpcCacheContent
{
  fpcCacheAlways
fpcCacheAlways
The response is always cached, even if the request or response headers indicate that the response should not be cached.
 = 0,
  fpcCacheCacheableAndDynamic
fpcCacheCacheableAndDynamic
The response is cached only if the headers indicate that the response should be cached, and that the response is dynamic.
 = 1,
  fpcCacheCacheable
fpcCacheCacheable
The response is cached only if the headers indicate that the response should be cached.
 = 2,
  fpcNeverCache
fpcNeverCache
The response is never cached.
 = 3

} FpcRouteCacheContent;

Constants

fpcCacheAlways
The response is always cached, even if the request or response headers indicate that the response should not be cached.
fpcCacheCacheableAndDynamic
The response is cached only if the headers indicate that the response should be cached, and that the response is dynamic.
fpcCacheCacheable
The response is cached only if the headers indicate that the response should be cached.
fpcNeverCache
The response is never cached.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Comenum.h.

See Also

Enumerated Types


FpcCacheReportSortOrder enumeration [ISA Server 2004]

FpcCacheReportSortOrder

The FpcCacheReportSortOrder enumerated type contains values that describe how the cache report information should be sorted.

typedef enum FpcCacheReportSortOrder
{
  fpcCacheRequests
fpcCacheRequests
Sort  by request.
 = 0,
  fpcCacheBytes
fpcCacheBytes
Sort  by the total number of bytes.
 = 4

} FpcCacheReportSortOrder;

Constants

fpcCacheRequests
Sort by request.
fpcCacheBytes
Sort by the total number of bytes.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Comenum.h.

See Also

Enumerated Types


FpcClientAuthenticatedValues enumeration [ISA Server 2004]

FpcClientAuthenticatedValues

The FpcClientAuthenticatedValues enumerated type contains values that indicate whether the client was authenticated to the ISA Server computer.

typedef enum FpcClientAuthenticatedValues
{
  fpcClientAuthenticatedNotLogged
fpcClientAuthenticatedNotLogged
The log entry does not indicate whether the client was authenticated to the ISA Server computer.
 = 0,
  fpcClientAuthenticatedYes
fpcClientAuthenticatedYes
The client was authenticated to the ISA Server computer.
 = 1,
  fpcClientAuthenticatedNo
fpcClientAuthenticatedNo
The client was not authenticated to the ISA Server computer.
 = 2

} FpcClientAuthenticatedValues;

Constants

fpcClientAuthenticatedNotLogged
The log entry does not indicate whether the client was authenticated to the ISA Server computer.
fpcClientAuthenticatedYes
The client was authenticated to the ISA Server computer.
fpcClientAuthenticatedNo
The client was not authenticated to the ISA Server computer.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Comenum.h.

See Also

Enumerated Types


FpcClientBackupRouteType enumeration [ISA Server 2004]

FpcClientBackupRouteType

The FpcClientBackupRouteType enumerated type contains values that specify the type of backup route for clients.

typedef enum FpcClientBackupRouteType
{
  fpcClientBackupRouteDirectToInternet
fpcClientBackupRouteDirectToInternet
The  backup route for clients is direct to the Internet.
 = 0,
  fpcClientBackupRouteViaProxy
fpcClientBackupRouteViaProxy
The  backup route for clients is  through an upstream proxy server.
 = 1

} FpcClientBackupRouteType;

Constants

fpcClientBackupRouteDirectToInternet
The backup route for clients is direct to the Internet.
fpcClientBackupRouteViaProxy
The backup route for clients is through an upstream proxy server.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Comenum.h.

See Also

Enumerated Types


FpcComponents enumeration [ISA Server 2004]

FpcComponents

The FpcComponents enumerated type contains values that specify the components installed on an array.

typedef enum FpcComponents
{
  fpcNoComponents
fpcNoComponents
No components.
 = 	0x00000000,
  fpcNAT
fpcNAT
SecureNAT.
 = 	0x00000002,
  fpcWebProxy
fpcWebProxy
Web proxy.
 = 	0x00000004,
  fpcHTTPTransparent
fpcHTTPTransparent
Microsoft Firewall service.
 = 	0x00000008,
  fpcGenericFwProtocols
fpcGenericFwProtocols
Generic firewall protocols.
 = 	0x00000010,
  fpcFirewallExtensions
fpcFirewallExtensions
Firewall extensions (application filters).
 = 	0x00000020,
  fpcAllComponents
fpcAllComponents
All ISA Server components.
 = 0xFFFFFFFF

} FpcComponents;

Constants

fpcNoComponents
No components.
fpcNAT
SecureNAT.
fpcWebProxy
Web proxy.
fpcHTTPTransparent
Microsoft Firewall service.
fpcGenericFwProtocols
Generic firewall protocols.
fpcFirewallExtensions
Firewall extensions (application filters).
fpcAllComponents
All ISA Server components.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Comenum.h.

See Also

Enumerated Types


FpcConnectionDirectionType enumeration [ISA Server 2004]

FpcConnectionDirectionType

The FpcConnectionDirectionType enumerated type contains values that specify the direction of a Microsoft Firewall service connection that uses the TCP protocol.

typedef enum FpcConnectionDirectionType
{
  fpcInbound
fpcInbound
Inbound connection.
 = 0,
  fpcOutbound
fpcOutbound
Outbound connection.
 = 1

} FpcConnectionDirectionType;

Constants

fpcInbound
Inbound connection.
fpcOutbound
Outbound connection.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Comenum.h.

See Also

Enumerated Types


FpcConnectionProtocolType enumeration [ISA Server 2004]

FpcConnectionProtocolType

The FpcConnectionProtocolType enumerated type contains values that describe protocol types.

typedef enum FpcConnectionProtocolType
{
  fpcICMP
fpcICMP
Internet Control Message Protocol (ICMP).
 = 1,
  fpcIGMP
fpcIGMP
Internet Group Management Protocol (IGMP).
 = 2,
  fpcGGP
fpcGGP
Gateway to Gateway Protocol (GGP).
 = 3,
  fpcIP
fpcIP
Internet Protocol (IP).
 = 4,
  fpcST
fpcST
Schedule Transfer (ST) protocol.
 = 5,
  fpcTCP
fpcTCP
Transmission Control Protocol (TCP).
 = 6,
  fpcUDP
fpcUDP
User Datagram Protocol (UDP).
 = 17

} FpcConnectionProtocolType;

Constants

fpcICMP
Internet Control Message Protocol (ICMP).
fpcIGMP
Internet Group Management Protocol (IGMP).
fpcGGP
Gateway to Gateway Protocol (GGP).
fpcIP
Internet Protocol (IP).
fpcST
Schedule Transfer (ST) protocol.
fpcTCP
Transmission Control Protocol (TCP).
fpcUDP
User Datagram Protocol (UDP).

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Comenum.h.

See Also

Enumerated Types


FpcConnectivityErrorCode enumeration [ISA Server 2004]

FpcConnectivityErrorCode

The FpcConnectivityErrorCode enumerated type contains values that specify error codes obtained in attempts to verify connectivity.

typedef enum FpcConnectivityErrorCode
{
  fpcConnNoError
fpcConnNoError
No error occurred in the attempt to verify connectivity.
 = 0,
  fpcConnDNSUnreachable
fpcConnDNSUnreachable
The DNS server could not be contacted.
 = 1,
  fpcConnUnresolvedName
fpcConnUnresolvedName
The server name supplied could not be resolved.
 = 2,
  fpcConnAuthenticationRequired
fpcConnAuthenticationRequired
Authentication is required to check connectivity to the specified server.
 = 3,
  fpcConnTimeout
fpcConnTimeout
The time-out period elapsed before connectivity was verified.
 = 4,
  fpcConnError
fpcConnError
An unspecified error occurred in the attempt to verify connectivity.
 = 5

} FpcConnectivityErrorCode;

Constants

fpcConnNoError
No error occurred in the attempt to verify connectivity.
fpcConnDNSUnreachable
The DNS server could not be contacted.
fpcConnUnresolvedName
The server name supplied could not be resolved.
fpcConnAuthenticationRequired
Authentication is required to check connectivity to the specified server.
fpcConnTimeout
The time-out period elapsed before connectivity was verified.
fpcConnError
An unspecified error occurred in the attempt to verify connectivity.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Comenum.h.

See Also

Enumerated Types


FpcConnectivityGroupType enumeration [ISA Server 2004]

FpcConnectivityGroupType

The FpcConnectivityGroupType enumerated type contains values that specify the group types used in ISA Server Management to categorize connectivity verifiers according to the type of servers with which connectivity is checked.

typedef enum FpcConnectivityGroupType
{
  fpcGroupFirst
fpcGroupFirst
A value that can be used to identify the first group when enumerating through the list of groups.
 = 0,
  fpcGroupActiveDirectory
fpcGroupActiveDirectory
The Active Directory group type.
 = 0,
  fpcGroupDHCP
fpcGroupDHCP
The DHCP group type.
 = 1,
  fpcGroupDNS
fpcGroupDNS
The DNS group type.
 = 2,
  fpcGroupPublishedServer
fpcGroupPublishedServer
The Published Servers group type.
 = 3,
  fpcGroupWeb
fpcGroupWeb
The Web (Internet) group type.
 = 4,
  fpcGroupOther
fpcGroupOther
The Others group type.
 = 5,
  fpcGroupLast
fpcGroupLast
A value that can be used to identify the last group when enumerating through the list of groups.
 = 5

} FpcConnectivityGroupType;

Constants

fpcGroupFirst
A value that can be used to identify the first group when enumerating through the list of groups.
fpcGroupActiveDirectory
The Active Directory group type.
fpcGroupDHCP
The DHCP group type.
fpcGroupDNS
The DNS group type.
fpcGroupPublishedServer
The Published Servers group type.
fpcGroupWeb
The Web (Internet) group type.
fpcGroupOther
The Others group type.
fpcGroupLast
A value that can be used to identify the last group when enumerating through the list of groups.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Comenum.h.

See Also

Enumerated Types


FpcDailyFrequency enumeration [ISA Server 2004]

FpcDailyFrequency

The FpcDailyFrequency enumerated type contains values that specify whether a scheduled content download takes place once a day or more than once a day.

typedef enum FpcDailyFrequency
{
  fpcOnce
fpcOnce
The download takes place once a day.
 = 0,
  fpcRecurring
fpcRecurring
The download takes place more than once a day.
 = 1

} FpcDailyFrequency;

Constants

fpcOnce
The download takes place once a day.
fpcRecurring
The download takes place more than once a day.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Comenum.h.

See Also

Enumerated Types


FpcDaysOfWeek enumeration [ISA Server 2004]

FpcDaysOfWeek

The FpcDaysOfWeek enumerated type contains bit values that describe the days of the week.

typedef enum FpcDaysOfWeek
{
  fpcNone
fpcNone
No day.
 = 0x00000000,
  fpcSundayBit
fpcSundayBit
Sunday.
 = 0x00000001,
  fpcMondayBit
fpcMondayBit
Monday.
 = 0x00000002,
  fpcTuesdayBit
fpcTuesdayBit
Tuesday.
 = 0x00000004,
  fpcWednesdayBit
fpcWednesdayBit
Wednesday.
 = 0x00000008,
  fpcThursdayBit
fpcThursdayBit
Thursday.
 = 0x00000010,
  fpcFridayBit
fpcFridayBit
Friday.
 = 0x00000020,
  fpcSaturdayBit
fpcSaturdayBit
Saturday.
 = 0x00000040

} FpcDaysOfWeek;

Constants

fpcNone
No day.
fpcSundayBit
Sunday.
fpcMondayBit
Monday.
fpcTuesdayBit
Tuesday.
fpcWednesdayBit
Wednesday.
fpcThursdayBit
Thursday.
fpcFridayBit
Friday.
fpcSaturdayBit
Saturday.

Remarks

You can combine these bit values using the Or operator to obtain a value that specifies two or more days of the week. For example, combining the binary values for Sunday (1), Tuesday (100), and Thursday (10000) results in the binary value 10101. The right bit represents Sunday, the next bit represents Monday, and so on. Thus, the bits corresponding to Sunday, Tuesday, and Thursday are set, while the bits corresponding to Monday and Wednesday are not set. This binary value is equal to the hexadecimal value 0x15 (which corresponds to the decimal value 21).

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Comenum.h.

See Also

Enumerated Types


FpcExportImportOptionalData enumeration [ISA Server 2004]

FpcExportImportOptionalData

The FpcExportImportOptionalData enumerated type provides values that specify the optional data that is exported or imported. Bitwise combinations of these values can be used.

typedef enum FpcExportImportOptionalData
{
  fpcExportImportPasswords
fpcExportImportPasswords
The optional data includes encrypted secret data, such as passwords or shared secrets that are used to create digital signatures for authenticating to RADIUS servers.
 = 0x00000001,
  fpcExportImportUserPermissions
fpcExportImportUserPermissions
The optional data includes the security roles assigned to delegated administrators. The delegated administrators are identified by the security identifiers (SIDs) of their user accounts, which are included in this optional data. These SIDs, which are relevant to the workgroup or domain of the exporting computer, are not necessarily relevant to that of the importing computer.
 = 0x00000002,
  fpcExportImportServerSpecific
fpcExportImportServerSpecific
The optional data includes server-specific information, which consists of cache drive settings and SSL certificates.
 = 0x00000004

} FpcExportImportOptionalData;

Constants

fpcExportImportPasswords
The optional data includes encrypted secret data, such as passwords or shared secrets that are used to create digital signatures for authenticating to RADIUS servers.
fpcExportImportUserPermissions
The optional data includes the security roles assigned to delegated administrators. The delegated administrators are identified by the security identifiers (SIDs) of their user accounts, which are included in this optional data. These SIDs, which are relevant to the workgroup or domain of the exporting computer, are not necessarily relevant to that of the importing computer.
fpcExportImportServerSpecific
The optional data includes server-specific information, which consists of cache drive settings and SSL certificates.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Comenum.h.

See Also

Enumerated Types


FpcFetchUrlFlags enumeration [ISA Server 2004]

FpcFetchUrlFlags

The FpcFetchUrlFlags enumerated type contains flags that control the behavior of the FetchUrl method.

typedef enum FpcFetchUrlFlags
{
  fpcFetchTtlIfNone
fpcFetchTtlIfNone
The TtlInMinutes parameter is used only if the object does not contain an "Expires" or "Cache-Control: maximum-age" HTTP header.
 = 1,
  fpcFetchTtlOverride
fpcFetchTtlOverride
The TtlInMinutes parameter takes precedence over any HTTP headers in the object.
 = 2,
  fpcFetchSynchronous
fpcFetchSynchronous
The method does not return until the fetch is completed.
 = 4,
  fpcFetchNoArrayRouting
fpcFetchNoArrayRouting
The object is fetched from the target server even if another array member is the preferred location.
 = 8,
  fpcFetchForceCache
fpcFetchForceCache
The object is cached even if it is not normally cacheable according to the HTTP specification.
 = 16,
  fpcFetchDynamicCache
fpcFetchDynamicCache
A dynamic object is cached  even if it is not normally cacheable according to the HTTP specification.

 = 32

} FpcFetchUrlFlags;

Constants

fpcFetchTtlIfNone
The TtlInMinutes parameter is used only if the object does not contain an "Expires" or "Cache-Control: maximum-age" HTTP header.
fpcFetchTtlOverride
The TtlInMinutes parameter takes precedence over any HTTP headers in the object.
fpcFetchSynchronous
The method does not return until the fetch is completed.
fpcFetchNoArrayRouting
The object is fetched from the target server even if another array member is the preferred location.
fpcFetchForceCache
The object is cached even if it is not normally cacheable according to the HTTP specification.
fpcFetchDynamicCache
A dynamic object is cached even if it is not normally cacheable according to the HTTP specification.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Comenum.h.

See Also

Enumerated Types


FpcFilterCondition enumeration [ISA Server 2004]

FpcFilterCondition

The FpcFilterCondition enumerated type contains descriptions of conditions used in query filtering by the FPCFilterExpression object.

typedef enum FpcFilterCondition
{
  fpcNoCondition
fpcNoCondition
No condition.
 = 0x00000000,
  fpcEqual
fpcEqual
Equal to.
 = 0x00000001,
  fpcNotEqual
fpcNotEqual
Not equal to.
 = 0x00000002,
  fpcGreaterOrEqual
fpcGreaterOrEqual
Greater than or equal to.
 = 0x00000004,
  fpcLessOrEqual
fpcLessOrEqual
Less than or equal to.
 = 0x00000008,
  fpcOnOrAfter
fpcOnOrAfter
On or after.
 = 0x00000010,
  fpcOnOrBefore
fpcOnOrBefore
On or before.
 = 0x00000020,
  fpcContains
fpcContains
Contains.
 = 0x00000040,
  fpcLiveData
fpcLiveData
After the query starts.
 = 0x00000080,
  fpcLastHour
fpcLastHour
During the last hour.
 = 0x00000100,
  fpcLast24Hours
fpcLast24Hours
During the last day.
 = 0x00000200,
  fpcLast7days
fpcLast7days
During the last week.
 = 0x00000400,
  fpcLast30days
fpcLast30days
During the last month.
 = 0x00000800,
  fpcNotContains
fpcNotContains
Does not contain.
 = 0x00001000

} FpcFilterCondition;

Constants

fpcNoCondition
No condition.
fpcEqual
Equal to.
fpcNotEqual
Not equal to.
fpcGreaterOrEqual
Greater than or equal to.
fpcLessOrEqual
Less than or equal to.
fpcOnOrAfter
On or after.
fpcOnOrBefore
On or before.
fpcContains
Contains.
fpcLiveData
After the query starts.
fpcLastHour
During the last hour.
fpcLast24Hours
During the last day.
fpcLast7days
During the last week.
fpcLast30days
During the last month.
fpcNotContains
Does not contain.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Comenum.h.

See Also

Enumerated Types


FpcFilterCriteria enumeration [ISA Server 2004]

FpcFilterCriteria

The FpcFilterCriteria enumerated type contains values that specify the criteria that can be included in a query filter expression defined by an FPCFilterExpression object.

typedef enum FpcFilterCriteria
{
  fpcNoFilter
fpcNoFilter
No filter criteria is used in the query filter expression.
 = 0,
  fpcFilterByClientIP
fpcFilterByClientIP
Filter  entries by the client IP address.
 = 1,
  fpcFilterByClientUserName
fpcFilterByClientUserName
Filter entries by client user name.
 = 2,
  fpcFilterByClientAgent
fpcFilterByClientAgent
Filter log entries by the client agent.
 = 3,
  fpcFilterByAuthenticated
fpcFilterByAuthenticated
Filter log entries by a value from FpcClientAuthenticatedValues enumerated type that indicates whether the client was authenticated to the ISA Server computer.
 = 4,
  fpcFilterByService
fpcFilterByService
Filter log entries a value from the FpcLogServiceType enumerated type that specifies the logged service type.
 = 5,
  fpcFilterByServername
fpcFilterByServername
Filter entries by the server name.
 = 6,
  fpcFilterByReferringServer
fpcFilterByReferringServer
Filter log entries by the referring server name.
 = 7,
  fpcFilterByDestHost
fpcFilterByDestHost
Filter log entries by the destination host name.
 = 8,
  fpcFilterByDestHostIP
fpcFilterByDestHostIP
Filter log entries by the destination IP address.
 = 9,
  fpcFilterByProtocol
fpcFilterByProtocol
Filter log entries by the protocol used.
 = 10,
  fpcFilterByTransport
fpcFilterByTransport
Filter log entries by the transport used.
 = 11,
  fpcFilterByOperation
fpcFilterByOperation
Filter log entries by the HTTP method used.
 = 12,
  fpcFilterByUrl
fpcFilterByUrl
Filter log entries by the URL.
 = 13,
  fpcFilterByRule
fpcFilterByRule
Filter log entries by the rule that either allowed or denied access for the request.
 = 14,
  fpcFilterByFilterInfo
fpcFilterByFilterInfo
Filter log entries by the second rule that either allowed or denied access for the request.
 = 15,
  fpcFilterByMimetype
fpcFilterByMimetype
Filter log entries by the Multipurpose Internet Mail Extensions (MIME) type.
 = 16,
  fpcFilterByObjectSource
fpcFilterByObjectSource
Filter log entries by a value from the FpcProxyObjSources enumerated type that specifies the source of the object supplied by the ISA Server Web proxy.
 = 17,
  fpcFilterByLogTime
fpcFilterByLogTime
Filter log entries by the log time.
 = 18,
  fpcFilterByCacheInfo
fpcFilterByCacheInfo
Filter log entries by the cache status, which indicates why an object was or was not cached.
 = 19,
  fpcFilterByErrorInfo
fpcFilterByErrorInfo
Filter log entries by the error information.
 = 20,
  fpcFilterByDestHostPort
fpcFilterByDestHostPort
Filter log entries by the destination host port.
 = 21,
  fpcFilterBySrcPort
fpcFilterBySrcPort
Filter log entries by the source port.
 = 22,
  fpcFilterByLogType
fpcFilterByLogType
Filter log entries by a value from the FpcLoggingComponents enumerated type that specifies a logging component.
 = 23,
  fpcFilterBySessionType
fpcFilterBySessionType
Filter sessions monitor entries by a value from the FpcSessionMonitorEvent enumeration that indicates a type of session event.
 = 24,
  fpcFilterByActivation
fpcFilterByActivation
Filter sessions monitor entries by the date and time when the session became active.
 = 25,
  fpcFilterByClientComputerName
fpcFilterByClientComputerName
Filter entries by the client computer name.
 = 26,
  fpcFilterBySourceNetwork
fpcFilterBySourceNetwork
Filter entries by the source network.
 = 27,
  fpcFilterByDestinationNetwork
fpcFilterByDestinationNetwork
Filter log entries by the destination network.
 = 28,
  fpcFilterBySourceProxy
fpcFilterBySourceProxy
Filter log entries by the source proxy.
 = 29,
  fpcFilterByDestinationProxy
fpcFilterByDestinationProxy
Filter log entries by the destination proxy.
 = 30,
  fpcFilterByAction
fpcFilterByAction
Filter log entries by a value from the FpcAction enumerated type that specifies an action performed by the Microsoft Firewall service.
 = 31,
  fpcFilterByBidirectional
fpcFilterByBidirectional
Filter log entries a value from the FpcBidirectional enumerated type that indicates whether the connection was bidirectional.
 = 32,
  fpcFilterByInterface
fpcFilterByInterface
Filter log entries by the IP address of the network adapter used.
 = 33,
  fpcFilterByHeader
fpcFilterByHeader
Filter log entries by the raw IP header.
 = 34,
  fpcFilterByPayload
fpcFilterByPayload
Filter log entries by the raw payload.
 = 35,
  fpcFilterProcessingTime
fpcFilterProcessingTime
Filter log entries by the processing time.
 = 36,
  fpcFilterByResultCode
fpcFilterByResultCode
Filter log entries by the result code.
 = 37,
  fpcFilterByBytesSent
fpcFilterByBytesSent
Filter log entries by the number of bytes sent.
 = 38,
  fpcFilterByBytesReceived
fpcFilterByBytesReceived
Filter log entries by the number of bytes received.
 = 39,
  fpcFilterByApplicationName
fpcFilterByApplicationName
Filter sessions monitor entries by the application name.
 = 40,
  fpcFilterByOriginalClientIP
fpcFilterByOriginalClientIP
Filter log entries by the original client IP address.
 = 41

} FpcFilterCriteria;

Constants

fpcNoFilter
No filter criteria is used in the query filter expression.
fpcFilterByClientIP
Filter entries by the client IP address.
fpcFilterByClientUserName
Filter entries by client user name.
fpcFilterByClientAgent
Filter log entries by the client agent.
fpcFilterByAuthenticated
Filter log entries by a value from FpcClientAuthenticatedValues enumerated type that indicates whether the client was authenticated to the ISA Server computer.
fpcFilterByService
Filter log entries a value from the FpcLogServiceType enumerated type that specifies the logged service type.
fpcFilterByServername
Filter entries by the server name.
fpcFilterByReferringServer
Filter log entries by the referring server name.
fpcFilterByDestHost
Filter log entries by the destination host name.
fpcFilterByDestHostIP
Filter log entries by the destination IP address.
fpcFilterByProtocol
Filter log entries by the protocol used.
fpcFilterByTransport
Filter log entries by the transport used.
fpcFilterByOperation
Filter log entries by the HTTP method used.
fpcFilterByUrl
Filter log entries by the URL.
fpcFilterByRule
Filter log entries by the rule that either allowed or denied access for the request.
fpcFilterByFilterInfo
Filter log entries by the second rule that either allowed or denied access for the request.
fpcFilterByMimetype
Filter log entries by the Multipurpose Internet Mail Extensions (MIME) type.
fpcFilterByObjectSource
Filter log entries by a value from the FpcProxyObjSources enumerated type that specifies the source of the object supplied by the ISA Server Web proxy.
fpcFilterByLogTime
Filter log entries by the log time.
fpcFilterByCacheInfo
Filter log entries by the cache status, which indicates why an object was or was not cached.
fpcFilterByErrorInfo
Filter log entries by the error information.
fpcFilterByDestHostPort
Filter log entries by the destination host port.
fpcFilterBySrcPort
Filter log entries by the source port.
fpcFilterByLogType
Filter log entries by a value from the FpcLoggingComponents enumerated type that specifies a logging component.
fpcFilterBySessionType
Filter sessions monitor entries by a value from the FpcSessionMonitorEvent enumeration that indicates a type of session event.
fpcFilterByActivation
Filter sessions monitor entries by the date and time when the session became active.
fpcFilterByClientComputerName
Filter entries by the client computer name.
fpcFilterBySourceNetwork
Filter entries by the source network.
fpcFilterByDestinationNetwork
Filter log entries by the destination network.
fpcFilterBySourceProxy
Filter log entries by the source proxy.
fpcFilterByDestinationProxy
Filter log entries by the destination proxy.
fpcFilterByAction
Filter log entries by a value from the FpcAction enumerated type that specifies an action performed by the Microsoft Firewall service.
fpcFilterByBidirectional
Filter log entries a value from the FpcBidirectional enumerated type that indicates whether the connection was bidirectional.
fpcFilterByInterface
Filter log entries by the IP address of the network adapter used.
fpcFilterByHeader
Filter log entries by the raw IP header.
fpcFilterByPayload
Filter log entries by the raw payload.
fpcFilterProcessingTime
Filter log entries by the processing time.
fpcFilterByResultCode
Filter log entries by the result code.
fpcFilterByBytesSent
Filter log entries by the number of bytes sent.
fpcFilterByBytesReceived
Filter log entries by the number of bytes received.
fpcFilterByApplicationName
Filter sessions monitor entries by the application name.
fpcFilterByOriginalClientIP
Filter log entries by the original client IP address.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Comenum.h.

See Also

Enumerated Types


FpcFilterDirection enumeration [ISA Server 2004]

FpcFilterDirection

The FpcFilterDirection enumerated type contains values that specify whether a Web filter operates in the forward proxy mode, in the reverse proxy mode, or in both modes.

typedef enum FpcFilterDirection
{
  fpcFilterDirectionForward
fpcFilterDirectionForward
The filter applies to incoming packets.
 = 0,
  fpcFilterDirectionReverse
fpcFilterDirectionReverse
The filter applies to outgoing packets.
 = 1,
  fpcFilterDirectionBoth
fpcFilterDirectionBoth
The filter applies to incoming and outgoing packets.
 = 2

} FpcFilterDirection;

Constants

fpcFilterDirectionForward
The filter applies to incoming packets.
fpcFilterDirectionReverse
The filter applies to outgoing packets.
fpcFilterDirectionBoth
The filter applies to incoming and outgoing packets.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Comenum.h.

See Also

Enumerated Types


FpcFilterPriority enumeration [ISA Server 2004]

FpcFilterPriority

The FpcFilterPriority enumerated type contains values that define Web filter priorities.

typedef enum FpcFilterPriority
{
  fpcFilterPriority_Low
fpcFilterPriority_Low
The Web filter has low priority.
 = 0,
  fpcFilterPriority_Medium
fpcFilterPriority_Medium
The Web filter has medium priority.
 = 1,
  fpcFilterPriority_High
fpcFilterPriority_High
The Web filter has high priority.
 = 2

} FpcFilterPriority;

Constants

fpcFilterPriority_Low
The Web filter has low priority.
fpcFilterPriority_Medium
The Web filter has medium priority.
fpcFilterPriority_High
The Web filter has high priority.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Comenum.h.

See Also

Enumerated Types


FpcFilterType enumeration [ISA Server 2004]

FpcFilterType

The FpcFilterType enumerated type contains values that describe whether an FPCFilterExpressions collection defines a session filter or a log filter.

typedef enum FpcFilterType
{
  fpcNoFilterType
fpcNoFilterType
No filter type.
 = 0,
  fpcSessionsFilter
fpcSessionsFilter
Session filter.
 = 1,
  fpcLogViewerFilter
fpcLogViewerFilter
Log viewer filter.
 = 2

} FpcFilterType;

Constants

fpcNoFilterType
No filter type.
fpcSessionsFilter
Session filter.
fpcLogViewerFilter
Log viewer filter.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Comenum.h.

See Also

Enumerated Types


FpcFilterValueType enumeration [ISA Server 2004]

FpcFilterValueType

The FpcFilterValueType enumerated type contains values that specify what can be included in a query filter expression defined by an FPCFilterExpression object.

typedef enum FpcFilterValueType
{
  fpcNoValueType
fpcNoValueType
A value of undefined type.
 = 0,
  fpcNumeric
fpcNumeric
A numeric value.
 = 1,
  fpcDate
fpcDate
A date value.
 = 2,
  fpcString
fpcString
A string value.
 = 3,
  fpcIPAddress
fpcIPAddress
An IP address.
 = 4,
  fpcEnum
fpcEnum
An enumeration value.
 = 5

} FpcFilterValueType;

Constants

fpcNoValueType
A value of undefined type.
fpcNumeric
A numeric value.
fpcDate
A date value.
fpcString
A string value.
fpcIPAddress
An IP address.
fpcEnum
An enumeration value.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Comenum.h.

See Also

Enumerated Types


FpcFwForwardType enumeration [ISA Server 2004]

FpcFwForwardType

The FpcFwForwardType enumerated type contains values that specify where to forward requests in Microsoft Firewall service chaining.

typedef enum FpcFwForwardType
{
  fpcPrimaryConnection
fpcPrimaryConnection
Requests should be forwarded to the primary connection.
 = 0,
  fpcChaining
fpcChaining
Requests should be forwarded to an upstream ISA Server computer.
 = 1

} FpcFwForwardType;

Constants

fpcPrimaryConnection
Requests should be forwarded to the primary connection.
fpcChaining
Requests should be forwarded to an upstream ISA Server computer.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Comenum.h.

See Also

Enumerated Types


FpcIncludeStatus enumeration [ISA Server 2004]

FpcIncludeStatus

The FpcIncludeStatus enumerated type contains values that specify whether a referenced item is included in or excluded from the list of items to which a rule applies.

typedef enum FpcIncludeStatus
{
  fpcInclude
fpcInclude
The referenced item is included.
 = 0,
  fpcExclude
fpcExclude
The referenced item is excluded.
 = 1

} FpcIncludeStatus;

Constants

fpcInclude
The referenced item is included.
fpcExclude
The referenced item is excluded.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Comenum.h.

See Also

Enumerated Types


FpcIpOptionsAction enumeration [ISA Server 2004]

FpcIpOptionsAction

The FpcIpOptionsAction enumerated type contains values that specify whether packets will be allowed or denied, based on whether IP options are selected.

typedef enum FpcIpOptionsAction
{
  fpcAllowPacketsIpOptions
fpcAllowPacketsIpOptions
Allow packets regardless of whether they include any IP options. (ISA Server will not check for IP options.)
 = 0,
  fpcDenyPacketsIpOptions
fpcDenyPacketsIpOptions
Deny packets if they include any IP options.
 = 1,
  fpcDenyPacketsUnSelectedIpOptions
fpcDenyPacketsUnSelectedIpOptions
Deny all packets that include an IP option that is not in the list of selected IP options.
 = 2,
  fpcDenyPacketsSelectedIpOptions
fpcDenyPacketsSelectedIpOptions
Deny all packets that include an IP option that is in the list of selected IP options.
 = 3

} FpcIpOptionsAction;

Constants

fpcAllowPacketsIpOptions
Allow packets regardless of whether they include any IP options. (ISA Server will not check for IP options.)
fpcDenyPacketsIpOptions
Deny packets if they include any IP options.
fpcDenyPacketsUnSelectedIpOptions
Deny all packets that include an IP option that is not in the list of selected IP options.
fpcDenyPacketsSelectedIpOptions
Deny all packets that include an IP option that is in the list of selected IP options.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Comenum.h.

See Also

Enumerated Types


FpcIpSelectionMethods enumeration [ISA Server 2004]

FpcIpSelectionMethods

The FpcIpSelectionMethods enumerated type contains values that specify methods for selecting IP addresses on a network.

typedef enum FpcIpSelectionMethods
{
  fpcAllIPAddresses
fpcAllIPAddresses
All of the IP addresses on the ISA Server computer in the network will be selected.
 = 0,
  fpcDefaultIPAddress
fpcDefaultIPAddress
Only the default IP address on the ISA Server computer in the network will be selected.
 = 1,
  fpcSpecifiedIPAddress
fpcSpecifiedIPAddress
Only the specified IP addresses on the ISA Server computer in the network will be selected.
 = 2

} FpcIpSelectionMethods;

Constants

fpcAllIPAddresses
All of the IP addresses on the ISA Server computer in the network will be selected.
fpcDefaultIPAddress
Only the default IP address on the ISA Server computer in the network will be selected.
fpcSpecifiedIPAddress
Only the specified IP addresses on the ISA Server computer in the network will be selected.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Comenum.h.

See Also

Enumerated Types


FpcLogFileDirectoryType enumeration [ISA Server 2004]

FpcLogFileDirectoryType

The FpcLogFileDirectoryType enumerated type contains values that indicate the type of path specified for the log file directory.

typedef enum FpcLogFileDirectoryType
{
  fpcFullPath
fpcFullPath
The full path is specified for the log file directory.
 = 0,
  fpcRelativePath
fpcRelativePath
The path  relative to the ISA Server installation  directory is specified for the log file directory.
 = 1

} FpcLogFileDirectoryType;

Constants

fpcFullPath
The full path is specified for the log file directory.
fpcRelativePath
The path relative to the ISA Server installation directory is specified for the log file directory.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Comenum.h.

See Also

Enumerated Types


FpcLoggingComponents enumeration [ISA Server 2004]

FpcLoggingComponents

The FpcLoggingComponents enumerated type contains values that specify the logging components.

typedef enum FpcLoggingComponents
{
  fpcProxyWebLog
fpcProxyWebLog
Web proxy logging.
 = 0x00000001,
  fpcProxyFwLog
fpcProxyFwLog
Firewall service logging.
 = 0x00000002,
  fpcProxyMailLog
fpcProxyMailLog
SMTP Message Screener logging.
 = 0x00000004

} FpcLoggingComponents;

Constants

fpcProxyWebLog
Web proxy logging.
fpcProxyFwLog
Firewall service logging.
fpcProxyMailLog
SMTP Message Screener logging.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Comenum.h.

See Also

Enumerated Types


FpcLogServiceType enumeration [ISA Server 2004]

FpcLogServiceType

The FpcLogServiceType enumerated type contains values that specify logged service types.

typedef enum FpcLogServiceType
{
  fpcLogServiceUnknown
fpcLogServiceUnknown
The log entry indicates that the service type is unknown.
 = 0,
  fpcLogServiceProxy
fpcLogServiceProxy
The logged service type is proxy.
 = 1,
  fpcLogServiceReverseProxy
fpcLogServiceReverseProxy
The logged  service type is reverse proxy.
 = 2

} FpcLogServiceType;

Constants

fpcLogServiceUnknown
The log entry indicates that the service type is unknown.
fpcLogServiceProxy
The logged service type is proxy.
fpcLogServiceReverseProxy
The logged service type is reverse proxy.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Comenum.h.

See Also

Enumerated Types


FpcLogType enumeration [ISA Server 2004]

FpcLogType

The FpcLogType enumerated type contains values that specify the type of logging.

typedef enum FpcLogType
{
  fpcFile_EXT_Format
fpcFile_EXT_Format
Logging to text log files in the World Wide Web Consortium (W3C) extended file format.
 = 0,
  fpcFile_ISA Server_Format
fpcFile_ISA Server_Format
Logging to text log files in the ISA Server file format.
 = 1,
  fpcODBC
fpcODBC
Logging to an Open Database Connectivity (ODBC)-compliant database.
 = 2,
  fpcMSDE
fpcMSDE
Logging to an Microsoft Data Engine (MSDE) database.
 = 3

} FpcLogType;

Constants

fpcFile_EXT_Format
Logging to text log files in the World Wide Web Consortium (W3C) extended file format.
fpcFile_ISA Server_Format
Logging to text log files in the ISA Server file format.
fpcODBC
Logging to an Open Database Connectivity (ODBC)-compliant database.
fpcMSDE
Logging to an Microsoft Data Engine (MSDE) database.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Comenum.h.

See Also

Enumerated Types


FpcNameSystem enumeration [ISA Server 2004]

FpcNameSystem

The FpcNameSystem enumerated type contains values that specify the name lookup system used for Cache Array Routing Protocol (CARP) hashing.

typedef enum FpcNameSystem
{
  fpcNameSystem_DNS
fpcNameSystem_DNS
The Domain Name System (DNS) name lookup system is to be used.
 = 0,
  fpcNameSystem_WINS
fpcNameSystem_WINS
The Windows Internet Name Service (WINS) name lookup system is to be used.
 = 1

} FpcNameSystem;

Constants

fpcNameSystem_DNS
The Domain Name System (DNS) name lookup system is to be used.
fpcNameSystem_WINS
The Windows Internet Name Service (WINS) name lookup system is to be used.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Comenum.h.

See Also

Enumerated Types


FpcNetworkConnectionType enumeration [ISA Server 2004]

FpcNetworkConnectionType

The FpcNetworkConnectionType enumerated type contains values that specify the type of connection to a network.

typedef enum FpcNetworkConnectionType
{
  fpcAdapter
fpcAdapter
The connection is through an adapter.
 = 0,
  fpcVPNConnection
fpcVPNConnection
A virtual private network (VPN) connection.
 = 1,
  fpcDialupConnection
fpcDialupConnection
A dial-up connection.
 = 2,
  fpcVirtualConnection
fpcVirtualConnection
A virtual connection, such as that for the VPN Clients and Local Host predefined networks. Only these predefined networks can have this value.
 = 3,
  fpcIPSecConnection
fpcIPSecConnection
An IPSec connection.
 = 4

} FpcNetworkConnectionType;

Constants

fpcAdapter
The connection is through an adapter.
fpcVPNConnection
A virtual private network (VPN) connection.
fpcDialupConnection
A dial-up connection.
fpcVirtualConnection
A virtual connection, such as that for the VPN Clients and Local Host predefined networks. Only these predefined networks can have this value.
fpcIPSecConnection
An IPSec connection.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Comenum.h.

See Also

Enumerated Types


FpcNetworkRoutingTypes enumeration [ISA Server 2004]

FpcNetworkRoutingTypes

The FpcNetworkRoutingTypes enumerated type contains values that specify the relationships between the source and destination network entities in network rules (FPCNetworkRule objects).

typedef enum FpcNetworkRoutingTypes
{
  fpcRoute
fpcRoute
The network entities have a routing relationship.
 = 0,
  fpcNat
fpcNat
The network entities have a network address translation (NAT) relationship.
 = 1

} FpcNetworkRoutingTypes;

Constants

fpcRoute
The network entities have a routing relationship.
fpcNat
The network entities have a network address translation (NAT) relationship.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Comenum.h.

See Also

Enumerated Types


FpcNetworkSetType enumeration [ISA Server 2004]

FpcNetworkSetType

The FpcNetworkSetType enumerated type contains values that specify whether a network set includes only the selected networks, or includes all networks except the selected networks.

typedef enum FpcNetworkSetType
{
  fpcSelectedNetworks
fpcSelectedNetworks
The network set includes only the selected networks.
 = 0,
  fpcAllExceptSelectedNetworks
fpcAllExceptSelectedNetworks
The network set includes all networks except those selected.
 = 1

} FpcNetworkSetType;

Constants

fpcSelectedNetworks
The network set includes only the selected networks.
fpcAllExceptSelectedNetworks
The network set includes all networks except those selected.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Comenum.h.

See Also

Enumerated Types


FpcNetworkTypes enumeration [ISA Server 2004]

FpcNetworkTypes

The FpcNetworkTypes enumerated type contains values that specify types of networks.

typedef enum FpcNetworkTypes
{
  fpcStandardNetwork
fpcStandardNetwork
An unclassified network. All networks other than predefined ISA Server networks are this type.
 = 0,
  fpcVPNClients
fpcVPNClients
The predefined VPN Clients network.
 = 1,
  fpcLocalHost
fpcLocalHost
The predefined Local Host network.
 = 2,
  fpcDefaultExternal
fpcDefaultExternal
The predefined Default External network.
 = 3,
  fpcInternalNetwork
fpcInternalNetwork
The predefined Internal network.
 = 4,
  fpcQuarantinedVPNClients
fpcQuarantinedVPNClients
The predefined Quarantined VPN Clients network.
 = 5

} FpcNetworkTypes;

Constants

fpcStandardNetwork
An unclassified network. All networks other than predefined ISA Server networks are this type.
fpcVPNClients
The predefined VPN Clients network.
fpcLocalHost
The predefined Local Host network.
fpcDefaultExternal
The predefined Default External network.
fpcInternalNetwork
The predefined Internal network.
fpcQuarantinedVPNClients
The predefined Quarantined VPN Clients network.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Comenum.h.

See Also

Enumerated Types


FpcObjectTypesReportSortOrder enumeration [ISA Server 2004]

FpcObjectTypesReportSortOrder

The FpcObjectTypesReportSortOrder enumerated type contains values that specify how the information in an object types report (a Web usage report) is to be sorted.

typedef enum FpcObjectTypesReportSortOrder
{
  fpcObjectTypesRequests
fpcObjectTypesRequests
The information is to be sorted  by the number of requests for each object type.
 = 0,
  fpcObjectTypesUsers
fpcObjectTypesUsers
The information is to be sorted  by the number of users that request each object type.
 = 1,
  fpcObjectTypesBytesIn
fpcObjectTypesBytesIn
The information is to be sorted  by the number of incoming bytes for each object type.
 = 2

} FpcObjectTypesReportSortOrder;

Constants

fpcObjectTypesRequests
The information is to be sorted by the number of requests for each object type.
fpcObjectTypesUsers
The information is to be sorted by the number of users that request each object type.
fpcObjectTypesBytesIn
The information is to be sorted by the number of incoming bytes for each object type.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Comenum.h.

See Also

Enumerated Types


FpcOperatingSystemsReportSortOrder enumeration [ISA Server 2004]

FpcOperatingSystemsReportSortOrder

The FpcOperatingSystemsReportSortOrder enumerated type contains values that specify how the information in an operating systems report (an application usage or Web usage report) is to be sorted.

typedef enum FpcOperatingSystemsReportSortOrder
{
  fpcOperatingSystemsRequests
fpcOperatingSystemsRequests
The information is to be sorted  by the number of requests made using each operating system.
 = 0,
  fpcOperatingSystemsUsers
fpcOperatingSystemsUsers
The information is to be sorted  by the number of users that use each operating system.
 = 1

} FpcOperatingSystemsReportSortOrder;

Constants

fpcOperatingSystemsRequests
The information is to be sorted by the number of requests made using each operating system.
fpcOperatingSystemsUsers
The information is to be sorted by the number of users that use each operating system.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Comenum.h.

See Also

Enumerated Types


FpcPolicyRuleActions enumeration [ISA Server 2004]

FpcPolicyRuleActions

The FpcPolicyRuleActions enumerated type contains values that indicate whether the rule allows or denies requests.

typedef enum FpcPolicyRuleActions
{
  fpcPolicyRuleActionAllow
fpcPolicyRuleActionAllow
The rule allows requests.
 = 0,
  fpcPolicyRuleActionDeny
fpcPolicyRuleActionDeny
The rule denies requests.
 = 1

} FpcPolicyRuleActions;

Constants

fpcPolicyRuleActionAllow
The rule allows requests.
fpcPolicyRuleActionDeny
The rule denies requests.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Comenum.h.

See Also

Enumerated Types


FpcPolicyRuleTypes enumeration [ISA Server 2004]

FpcPolicyRuleTypes

The FpcPolicyRuleTypes enumerated type contains values that specify types of policy rules.

typedef enum FpcPolicyRuleTypes
{
  fpcPolicyRuleAccess
fpcPolicyRuleAccess
The policy rule is an access rule.
 = 0,
  fpcPolicyRuleServerPublishing
fpcPolicyRuleServerPublishing
The policy rule is a server publishing rule.
 = 1,
  fpcPolicyRuleWebPublishing
fpcPolicyRuleWebPublishing
The policy rule is a Web publishing rule.
 = 2

} FpcPolicyRuleTypes;

Constants

fpcPolicyRuleAccess
The policy rule is an access rule.
fpcPolicyRuleServerPublishing
The policy rule is a server publishing rule.
fpcPolicyRuleWebPublishing
The policy rule is a Web publishing rule.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Comenum.h.

See Also

Enumerated Types


FpcPrimaryRouteType enumeration [ISA Server 2004]

FpcPrimaryRouteType

The FpcPrimaryRouteType enumerated type provides values that specify how requests are forwarded on the primary route.

typedef enum FpcPrimaryRouteType
{
  fpcPrimaryRouteDirect
fpcPrimaryRouteDirect
Requests are sent directly to the requested destination.
 = 0,
  fpcPrimaryRouteUpstream
fpcPrimaryRouteUpstream
Requests are sent to an upstream ISA Server computer or array.
 = 1,
  fpcPrimaryRouteAlternate
fpcPrimaryRouteAlternate
Requests are routed  to an alternate host.
 = 2

} FpcPrimaryRouteType;

Constants

fpcPrimaryRouteDirect
Requests are sent directly to the requested destination.
fpcPrimaryRouteUpstream
Requests are sent to an upstream ISA Server computer or array.
fpcPrimaryRouteAlternate
Requests are routed to an alternate host.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Comenum.h.

See Also

Enumerated Types


FpcProtocolCategory enumeration [ISA Server 2004]

FpcProtocolCategory

The FpcProtocolCategory enumerated type contains values that specify the categories to which a protocol can belong.

typedef enum FpcProtocolCategory
{
  fpcProtocolCategoriesAll
fpcProtocolCategoriesAll
All  of  the protocol categories.
 = 0x00000000,
  fpcProtocolCategoryUserDefined
fpcProtocolCategoryUserDefined
User-defined protocols.
 = 0x00000001,
  fpcProtocolCategoryCommon
fpcProtocolCategoryCommon
Common protocols.
 = 0x00000002,
  fpcProtocolCategoryInfrastructure
fpcProtocolCategoryInfrastructure
Infrastructure protocols.
 = 0x00000004,
  fpcProtocolCategoriesMail
fpcProtocolCategoriesMail
Mail protocols.
 = 0x00000008,
  fpcProtocolCategoriesMessaging
fpcProtocolCategoriesMessaging
Messaging protocols.
 = 0x00000010,
  fpcProtocolCategoriesRemote
fpcProtocolCategoriesRemote
Remote protocols.
 = 0x00000020,
  fpcProtocolCategoriesMedia
fpcProtocolCategoriesMedia
Media protocols.
 = 0x00000040,
  fpcProtocolCategoriesVpnIpsec
fpcProtocolCategoriesVpnIpsec
VPN Internet Protocol security (IPSec) protocols.
 = 0x00000080,
  fpcProtocolCategoriesWeb
fpcProtocolCategoriesWeb
Web protocols.
 = 0x00000100,
  fpcProtocolCategoriesAuthentication
fpcProtocolCategoriesAuthentication
Authentication protocols.
 = 0x00000200,
  fpcAllProtocolCategories
fpcAllProtocolCategories
All  of  the protocol categories.
 = 0xFFFFFFFF

} FpcProtocolCategory;

Constants

fpcProtocolCategoriesAll
All of the protocol categories.
fpcProtocolCategoryUserDefined
User-defined protocols.
fpcProtocolCategoryCommon
Common protocols.
fpcProtocolCategoryInfrastructure
Infrastructure protocols.
fpcProtocolCategoriesMail
Mail protocols.
fpcProtocolCategoriesMessaging
Messaging protocols.
fpcProtocolCategoriesRemote
Remote protocols.
fpcProtocolCategoriesMedia
Media protocols.
fpcProtocolCategoriesVpnIpsec
VPN Internet Protocol security (IPSec) protocols.
fpcProtocolCategoriesWeb
Web protocols.
fpcProtocolCategoriesAuthentication
Authentication protocols.
fpcAllProtocolCategories
All of the protocol categories.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Comenum.h.

See Also

Enumerated Types


FpcProtocolSelectionType enumeration [ISA Server 2004]

FpcProtocolSelectionType

The FpcProtocolSelectionType enumerated type contains values that specify the group of protocols to which a protocol rule applies.

typedef enum FpcProtocolSelectionType
{
  fpcAllIpTraffic
fpcAllIpTraffic
All Internet Protocol (IP) connections.
 = 0,
  fpcSpecifiedProtocols
fpcSpecifiedProtocols
Protocols specified by the
SpecifiedProtocols property.
 = 1,
  fpcAllExceptSpecifiedProtocols
fpcAllExceptSpecifiedProtocols
All IP traffic except the protocols specified by the
SpecifiedProtocols property.
 = 2

} FpcProtocolSelectionType;

Constants

fpcAllIpTraffic
All Internet Protocol (IP) connections.
fpcSpecifiedProtocols
Protocols specified by the SpecifiedProtocols property.
fpcAllExceptSpecifiedProtocols
All IP traffic except the protocols specified by the SpecifiedProtocols property.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Comenum.h.

See Also

Enumerated Types


FpcProxyObjSources enumeration [ISA Server 2004]

FpcProxyObjSources

The FpcProxyObjSources enumerated type contains values that indicate sources of proxy objects.

typedef enum FpcProxyObjSources
{
  fpcSrcUnknown
fpcSrcUnknown
The source of the proxy object is unknown.
 = 0,
  fpcSrcCache
fpcSrcCache
The proxy object was supplied from the cache.
 = 1,
  fpcSrcVerifiedCache
fpcSrcVerifiedCache
The cache sent an If-Modified-Since (IMS) request to the Internet server and received a 304 (Not Modified) response.
 = 2,
  fpcSrcNotVerifiedCache
fpcSrcNotVerifiedCache
The cache failed to send an IMS request to the Internet server and supplied the cached object.
 = 3,
  fpcSrcVerifyFailedInternet
fpcSrcVerifyFailedInternet
The cache sent an IMS request to the Internet server, but did not receive a 304 response.
 = 4,
  fpcSrcInternet
fpcSrcInternet
The proxy object was supplied from the Internet server.
 = 5,
  fpcSrcMember
fpcSrcMember
This value is reserved for a future release.
 = 6,
  fpcSrcUpstream
fpcSrcUpstream
The proxy object was supplied from an upstream server.
 = 7,
  fpcSrcNotModified
fpcSrcNotModified
The client requested an IMS request, and the cache returned a 304 response.
 = 8

} FpcProxyObjSources;

Constants

fpcSrcUnknown
The source of the proxy object is unknown.
fpcSrcCache
The proxy object was supplied from the cache.
fpcSrcVerifiedCache
The cache sent an If-Modified-Since (IMS) request to the Internet server and received a 304 (Not Modified) response.
fpcSrcNotVerifiedCache
The cache failed to send an IMS request to the Internet server and supplied the cached object.
fpcSrcVerifyFailedInternet
The cache sent an IMS request to the Internet server, but did not receive a 304 response.
fpcSrcInternet
The proxy object was supplied from the Internet server.
fpcSrcMember
This value is reserved for a future release.
fpcSrcUpstream
The proxy object was supplied from an upstream server.
fpcSrcNotModified
The client requested an IMS request, and the cache returned a 304 response.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Comenum.h.

See Also

Enumerated Types


FpcPublishedServerType enumeration [ISA Server 2004]

FpcPublishedServerType

The FpcPublishedServerType enumerated type contains values that specify how requests must be routed to a published Web server.

typedef enum FpcPublishedServerType
{
  fpcWebServerThruHTTP
fpcWebServerThruHTTP
The published Web server accepts requests routed using the HTTP protocol.
 = 0,
  fpcWebServerThruSSL
fpcWebServerThruSSL
The published Web server accepts requests routed using the HTTP protocol over a secure channel (Secure Sockets Layer or SSL).
 = 1,
  fpcWebServerThruBothHTTPAndSSL
fpcWebServerThruBothHTTPAndSSL
The published Web server accepts HTTP requests routed using the HTTP protocol, and  accepts HTTPS requests  routed using the HTTP protocol over a secure channel.
 = 2,
  fpcFTPServer
fpcFTPServer
The published Web server accepts requests routed using the FTP protocol.
 = 3

} FpcPublishedServerType;

Constants

fpcWebServerThruHTTP
The published Web server accepts requests routed using the HTTP protocol.
fpcWebServerThruSSL
The published Web server accepts requests routed using the HTTP protocol over a secure channel (Secure Sockets Layer or SSL).
fpcWebServerThruBothHTTPAndSSL
The published Web server accepts HTTP requests routed using the HTTP protocol, and accepts HTTPS requests routed using the HTTP protocol over a secure channel.
fpcFTPServer
The published Web server accepts requests routed using the FTP protocol.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Comenum.h.

See Also

Enumerated Types


FpcPublishProtocolRedirectionType enumeration [ISA Server 2004]

FpcPublishProtocolRedirectionType

The FpcPublishProtocolRedirectionType enumerated type contains values that describe the protocol chosen when redirecting a Web request.

typedef enum FpcPublishProtocolRedirectionType
{
  fpcHTTP
fpcHTTP
Redirected Web requests are routed using the HTTP protocol.
 = 0,
  fpcFTP
fpcFTP
This value is reserved for internal use by ISA Server.
 = 1,
  fpcSSL
fpcSSL
Redirected Web requests are routed using the SSL protocol.
 = 2

} FpcPublishProtocolRedirectionType;

Constants

fpcHTTP
Redirected Web requests are routed using the HTTP protocol.
fpcFTP
This value is reserved for internal use by ISA Server.
fpcSSL
Redirected Web requests are routed using the SSL protocol.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Comenum.h.

See Also

Enumerated Types


FpcReportJobCategory enumeration [ISA Server 2004]

FpcReportJobCategory

The FpcReportJobCategory enumerated type contains values that specify report job categories. Each report job category refers to a specific type of generated reports.

typedef enum FpcReportJobCategory
{
  fpcReportJobCategorySummaryBit
fpcReportJobCategorySummaryBit
Bit value that represents summary reports.
 = 0x00000001,
  fpcReportJobCategoryWebUsageBit
fpcReportJobCategoryWebUsageBit
Bit value that represents Web usage reports.
 = 0x00000002,
  fpcReportJobCategoryApplicationUsageBit
fpcReportJobCategoryApplicationUsageBit
Bit value that represents application usage reports.
 = 0x00000004,
  fpcReportJobCategoryTrafficAndUtilizationBit
fpcReportJobCategoryTrafficAndUtilizationBit
Bit value that represents traffic and utilization reports.
 = 0x00000008,
  fpcReportJobCategorySecurityBit
fpcReportJobCategorySecurityBit
Bit value that represents security  reports.
 = 0x00000010

} FpcReportJobCategory;

Constants

fpcReportJobCategorySummaryBit
Bit value that represents summary reports.
fpcReportJobCategoryWebUsageBit
Bit value that represents Web usage reports.
fpcReportJobCategoryApplicationUsageBit
Bit value that represents application usage reports.
fpcReportJobCategoryTrafficAndUtilizationBit
Bit value that represents traffic and utilization reports.
fpcReportJobCategorySecurityBit
Bit value that represents security reports.

Remarks

You can combine these bit values using the Or operator to obtain a value that specifies two or more job categories. For example, combining the binary values for summary reports (1), application usage reports (100), and security reports (10000) results in the binary value 10101. The right bit represents summary reports, the next bit represents Web usage reports, and so on. Thus, the bits corresponding to summary reports, application usage reports, and security reports are set, while the bits corresponding to the other report categories are not set. This binary value is equal to the hexadecimal value 0x15 (which corresponds to the decimal value 21).

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Comenum.h.

See Also

Enumerated Types


FpcReportJobPeriodType enumeration [ISA Server 2004]

FpcReportJobPeriodType

The FpcReportJobPeriodType enumerated type contains values that describe the type of period that a single report covers.

typedef enum FpcReportJobPeriodType
{
  fpcReportJobPeriodDay
fpcReportJobPeriodDay
The report covers a day.
 = 0,
  fpcReportJobPeriodWeek
fpcReportJobPeriodWeek
The report covers a week.
 = 1,
  fpcReportJobPeriodMonth
fpcReportJobPeriodMonth
The report covers a month.
 = 2,
  fpcReportJobPeriodYear
fpcReportJobPeriodYear
The report covers a year.
 = 3,
  fpcReportJobPeriodCustom
fpcReportJobPeriodCustom
The report uses a custom period. This value is associated with a "run-once" report.
 = 4

} FpcReportJobPeriodType;

Constants

fpcReportJobPeriodDay
The report covers a day.
fpcReportJobPeriodWeek
The report covers a week.
fpcReportJobPeriodMonth
The report covers a month.
fpcReportJobPeriodYear
The report covers a year.
fpcReportJobPeriodCustom
The report uses a custom period. This value is associated with a "run-once" report.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Comenum.h.

See Also

Enumerated Types


FpcReportSortOrder enumeration [ISA Server 2004]

FpcReportSortOrder

The FpcReportSortOrder enumerated type contains values that specify how the information in a report is to be sorted.

typedef enum FpcReportSortOrder
{
  fpcRequestsSortOrder
fpcRequestsSortOrder
The information is to be sorted  by the number of requests made.
 = 0,
  fpcUsersSortOrder
fpcUsersSortOrder
The information is to be sorted  by the number of users.
 = 1,
  fpcBytesInSortOrder
fpcBytesInSortOrder
The information is to be sorted  by the number of incoming bytes.
 = 2,
  fpcBytesOutSortOrder
fpcBytesOutSortOrder
The information is to be sorted  by the number of outgoing bytes.
 = 3,
  fpcTotalBytesSortOrder
fpcTotalBytesSortOrder
The information is to be sorted  by the total number of bytes.
 = 4

} FpcReportSortOrder;

Constants

fpcRequestsSortOrder
The information is to be sorted by the number of requests made.
fpcUsersSortOrder
The information is to be sorted by the number of users.
fpcBytesInSortOrder
The information is to be sorted by the number of incoming bytes.
fpcBytesOutSortOrder
The information is to be sorted by the number of outgoing bytes.
fpcTotalBytesSortOrder
The information is to be sorted by the total number of bytes.

Remarks

The values in this enumeration can be used as alternatives for the corresponding values in the FpcTopAppProtocolReportSortOrder, FpcTopAppsReportSortOrder, FpcTopDestinationsReportSortOrder, FpcTopSitesReportSortOrder, FpcTopUsersReportSortOrder, and FpcTopWebProtocolReportSortOrder enumerated types.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Comenum.h.

See Also

Enumerated Types


FpcReportStatus enumeration [ISA Server 2004]

FpcReportStatus

The FpcReportStatus enumerated type contains values that specify the status of a report.

typedef enum FpcReportStatus
{
  fpcReportFailed
fpcReportFailed
The report failed.
 = 0,
  fpcReportSucceded
fpcReportSucceded
The report succeeded.
 = 1,
  fpcReportRunning
fpcReportRunning
The report is being generated.
 = 2

} FpcReportStatus;

Constants

fpcReportFailed
The report failed.
fpcReportSucceded
The report succeeded.
fpcReportRunning
The report is being generated.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Comenum.h.

See Also

Enumerated Types


FpcRequestType enumeration [ISA Server 2004]

FpcRequestType

The FpcRequestType enumerated type contains values that specify the types of requests used in connectivity verification by the FPCConnectivityVerifier and FPCConnectivityResult objects.

typedef enum FpcRequestType
{
  fpcHttpRequest
fpcHttpRequest
An HTTP request (a request for a Web page).
 = 0,
  fpcPingRequest
fpcPingRequest
A ping request.
 = 1,
  fpcTcpConnect
fpcTcpConnect
A TCP connection request.
 = 2

} FpcRequestType;

Constants

fpcHttpRequest
An HTTP request (a request for a Web page).
fpcPingRequest
A ping request.
fpcTcpConnect
A TCP connection request.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Comenum.h.

See Also

Enumerated Types


FpcScheduleDays enumeration [ISA Server 2004]

FpcScheduleDays

The FpcScheduleDays enumerated type contains values that specify the days of the week for schedules.

typedef enum FpcScheduleDays
{
  fpcALL_WEEK
fpcALL_WEEK
Sunday through Saturday.
 = -1,
  fpcSUN
fpcSUN
Sunday.
 = 0,
  fpcMON
fpcMON
Monday.
 = 1,
  fpcTUE
fpcTUE
Tuesday.
 = 2,
  fpcWED
fpcWED
Wednesday.
 = 3,
  fpcTHU
fpcTHU
Thursday.
 = 4,
  fpcFRI
fpcFRI
Friday.
 = 5,
  fpcSAT
fpcSAT
Saturday.
 = 6

} FpcScheduleDays;

Constants

fpcALL_WEEK
Sunday through Saturday.
fpcSUN
Sunday.
fpcMON
Monday.
fpcTUE
Tuesday.
fpcWED
Wednesday.
fpcTHU
Thursday.
fpcFRI
Friday.
fpcSAT
Saturday.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Comenum.h.

See Also

Enumerated Types


FpcScheduledTaskRunningPeriod enumeration [ISA Server 2004]

FpcScheduledTaskRunningPeriod

The FpcScheduledTaskRunningPeriod enumerated type contains values that specify the recurrence period for running scheduled tasks. Scheduled tasks include content download jobs and report jobs.

typedef enum FpcScheduledTaskRunningPeriod
{
  fpcRunOnce
fpcRunOnce
The scheduled task is to be run only once.
 = 0,
  fpcRunDaily
fpcRunDaily
The scheduled task is to be run daily.
 = 1,
  fpcRunOnSpecifiedDaysOfWeek
fpcRunOnSpecifiedDaysOfWeek
The scheduled task is to be run on the specified days of the week.
 = 2,
  fpcRunOnSpecifiedDayOfMonth
fpcRunOnSpecifiedDayOfMonth
The scheduled task is to be run on the specified day of the month. This value is applicable only to report jobs.
 = 3

} FpcScheduledTaskRunningPeriod;

Constants

fpcRunOnce
The scheduled task is to be run only once.
fpcRunDaily
The scheduled task is to be run daily.
fpcRunOnSpecifiedDaysOfWeek
The scheduled task is to be run on the specified days of the week.
fpcRunOnSpecifiedDayOfMonth
The scheduled task is to be run on the specified day of the month. This value is applicable only to report jobs.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Comenum.h.

See Also

Enumerated Types


FpcScheduleHours enumeration [ISA Server 2004]

FpcScheduleHours

The FpcScheduleHours enumerated type contains values that specify the hours of the day for schedules.

typedef enum FpcScheduleHours
{
  fpcALL_DAY
fpcALL_DAY
All hours of the day.
 = -1,
  fpcAM_12
fpcAM_12
12 A.M. (00:00 midnight).
 = 0,
  fpcAM_1
fpcAM_1
1 A.M. (01:00).
 = 1,
  fpcAM_2
fpcAM_2
2 A.M. (02:00).
 = 2,
  fpcAM_3
fpcAM_3
3 A.M. (03:00).
 = 3,
  fpcAM_4
fpcAM_4
4 A.M. (04:00).
 = 4,
  fpcAM_5
fpcAM_5
5 A.M. (05:00).
 = 5,
  fpcAM_6
fpcAM_6
6 A.M. (06:00).
 = 6,
  fpcAM_7
fpcAM_7
7 A.M. (07:00).
 = 7,
  fpcAM_8
fpcAM_8
8 A.M. (08:00).
 = 8,
  fpcAM_9
fpcAM_9
9 A.M. (09:00).
 = 9,
  fpcAM_10
fpcAM_10
10 A.M. (10:00).
 = 10,
  fpcAM_11
fpcAM_11
11 A.M. (11:00)
 = 11,
  fpcPM_12
fpcPM_12
12 P.M. (12:00 noon).
 = 12,
  fpcPM_1
fpcPM_1
1 P.M. (13:00).
 = 13,
  fpcPM_2
fpcPM_2
2 P.M. (14:00).
 = 14,
  fpcPM_3
fpcPM_3
3 P.M. (15:00).
 = 15,
  fpcPM_4
fpcPM_4
4 P.M. (16:00).
 = 16,
  fpcPM_5
fpcPM_5
5 P.M. (17:00).
 = 17,
  fpcPM_6
fpcPM_6
6 P.M. (18:00).
 = 18,
  fpcPM_7
fpcPM_7
7 P.M. (19:00).
 = 19,
  fpcPM_8
fpcPM_8
8 P.M. (20:00).
 = 20,
  fpcPM_9
fpcPM_9
9 P.M. (21:00).
 = 21,
  fpcPM_10
fpcPM_10
10 P.M. (22:00).
 = 22,
  fpcPM_11
fpcPM_11
11 P.M. (23:00).
 = 23

} FpcScheduleHours;

Constants

fpcALL_DAY
All hours of the day.
fpcAM_12
12 A.M. (00:00 midnight).
fpcAM_1
1 A.M. (01:00).
fpcAM_2
2 A.M. (02:00).
fpcAM_3
3 A.M. (03:00).
fpcAM_4
4 A.M. (04:00).
fpcAM_5
5 A.M. (05:00).
fpcAM_6
6 A.M. (06:00).
fpcAM_7
7 A.M. (07:00).
fpcAM_8
8 A.M. (08:00).
fpcAM_9
9 A.M. (09:00).
fpcAM_10
10 A.M. (10:00).
fpcAM_11
11 A.M. (11:00)
fpcPM_12
12 P.M. (12:00 noon).
fpcPM_1
1 P.M. (13:00).
fpcPM_2
2 P.M. (14:00).
fpcPM_3
3 P.M. (15:00).
fpcPM_4
4 P.M. (16:00).
fpcPM_5
5 P.M. (17:00).
fpcPM_6
6 P.M. (18:00).
fpcPM_7
7 P.M. (19:00).
fpcPM_8
8 P.M. (20:00).
fpcPM_9
9 P.M. (21:00).
fpcPM_10
10 P.M. (22:00).
fpcPM_11
11 P.M. (23:00).

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Comenum.h.

See Also

Enumerated Types


FpcServices enumeration [ISA Server 2004]

FpcServices

The FpcServices enumerated type contains values that specify various ISA Server components such as the Microsoft Firewall service and the Microsoft ISA Server Job Scheduler service.

typedef enum FpcServices
{
  fpcNoService
fpcNoService
Neither the  Firewall service nor the Microsoft   ISA Server Job Scheduler service.
 = 0x00000000,
  fpcFwSrvSvc
fpcFwSrvSvc
The Firewall service.
 = 0x00000001,
  fpcJobSchedSvc
fpcJobSchedSvc
The  Microsoft ISA Server Job Scheduler  service.
 = 0x00000002,
  fpcMSDESvc
fpcMSDESvc
The  Microsoft Data Engine (MSDE)  service.
 = 0x00000004,
  fpcAllServices
fpcAllServices
Both the Firewall service and the  Microsoft ISA Server Job Scheduler service.
 = 0xFFFFFFFF

} FpcServices;

Constants

fpcNoService
Neither the Firewall service nor the Microsoft ISA Server Job Scheduler service.
fpcFwSrvSvc
The Firewall service.
fpcJobSchedSvc
The Microsoft ISA Server Job Scheduler service.
fpcMSDESvc
The Microsoft Data Engine (MSDE) service.
fpcAllServices
Both the Firewall service and the Microsoft ISA Server Job Scheduler service.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Comenum.h.

See Also

Enumerated Types


FpcServiceTypes enumeration [ISA Server 2004]

FpcServiceTypes

The FpcServiceTypes enumerated type contains values that specify which services can use an authentication scheme.

typedef enum FpcServiceTypes
{
  fpcServiceTypeUnknown
fpcServiceTypeUnknown
The service type that can use the authentication scheme is unknown.
 = 0x00000000,
  fpcServiceTypeWebProxyReverse
fpcServiceTypeWebProxyReverse
The ISA Server Web proxy can use the authentication scheme in a reverse direction.
 = 0x00000001,
  fpcServiceTypeWebProxyForward
fpcServiceTypeWebProxyForward
The Web proxy can use the authentication scheme in a forward direction.
 = 0x00000002,
  fpcServiceTypeWebProxyBoth
fpcServiceTypeWebProxyBoth
The Web proxy can use the authentication scheme in both directions.
 = 0x00000003

} FpcServiceTypes;

Constants

fpcServiceTypeUnknown
The service type that can use the authentication scheme is unknown.
fpcServiceTypeWebProxyReverse
The ISA Server Web proxy can use the authentication scheme in a reverse direction.
fpcServiceTypeWebProxyForward
The Web proxy can use the authentication scheme in a forward direction.
fpcServiceTypeWebProxyBoth
The Web proxy can use the authentication scheme in both directions.

Remarks

When a Web filter registers an authentication scheme, the Services property must be set to fpcServiceTypeWebProxyReverse, fpcServiceTypeWebProxyForward, or fpcServiceTypeWebProxyBoth.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Comenum.h.

See Also

Enumerated Types


FpcSessionMonitorEvent enumeration [ISA Server 2004]

FpcSessionMonitorEvent

The FpcSessionMonitorEvent enumerated type contains values that specify events generated by monitored sessions.

typedef enum FpcSessionMonitorEvent
{
  fpcSessionFound
fpcSessionFound
A session was found.
 = 0,
  fpcSessionAllFound
fpcSessionAllFound
All sessions were found.
 = 1,
  fpcSessionCreated
fpcSessionCreated
A session was created.
 = 2,
  fpcSessionDisconnected
fpcSessionDisconnected
A session was disconnected.
 = 3,
  fpcSessionDisconnectedAll
fpcSessionDisconnectedAll
All sessions were disconnected.
 = 4,
  fpcSessionNetworkChanged
fpcSessionNetworkChanged
A client IP was moved to a different network. This occurs when  a session  moves from a quarantined VPN network  to a VPN network that is not quarantined.
 = 5,
  fpcSessionConnectionRestored
fpcSessionConnectionRestored
A session connection was restored.
 = 6,
  fpcSessionFilteredOut
fpcSessionFilteredOut
A session was filtered out.
 = 7

} FpcSessionMonitorEvent;

Constants

fpcSessionFound
A session was found.
fpcSessionAllFound
All sessions were found.
fpcSessionCreated
A session was created.
fpcSessionDisconnected
A session was disconnected.
fpcSessionDisconnectedAll
All sessions were disconnected.
fpcSessionNetworkChanged
A client IP was moved to a different network. This occurs when a session moves from a quarantined VPN network to a VPN network that is not quarantined.
fpcSessionConnectionRestored
A session connection was restored.
fpcSessionFilteredOut
A session was filtered out.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Comenum.h.

See Also

Enumerated Types


FpcSessionType enumeration [ISA Server 2004]

FpcSessionType

The FpcSessionType enumerated type contains values that specify the session type, as used in the SessionType property.

typedef enum FpcSessionType
{
  fpcNoSessionType
fpcNoSessionType
No session type.
 = 0,
  fpcSecureNetSession
fpcSecureNetSession
A SecureNAT session.
 = 1,
  fpcFirewallClientSession
fpcFirewallClientSession
A session with a Firewall client.
 = 2,
  fpcProxySession
fpcProxySession
An  ISA Server Web proxy session.
 = 3,
  fpcVpnRemoteAccessSession
fpcVpnRemoteAccessSession
A session with a remote VPN client.
 = 4,
  fpcVpnRemoteSiteSession
fpcVpnRemoteSiteSession
A session with a remote VPN site.
 = 5

} FpcSessionType;

Constants

fpcNoSessionType
No session type.
fpcSecureNetSession
A SecureNAT session.
fpcFirewallClientSession
A session with a Firewall client.
fpcProxySession
An ISA Server Web proxy session.
fpcVpnRemoteAccessSession
A session with a remote VPN client.
fpcVpnRemoteSiteSession
A session with a remote VPN site.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Comenum.h.

See Also

Enumerated Types


FpcSizeUnits enumeration [ISA Server 2004]

FpcSizeUnits

The FpcSizeUnits enumerated type contains values that specify the size units used in cache rules.

typedef enum FpcSizeUnits
{
  fpcKB
fpcKB
The size unit is a kilobyte (KB).
 = 1,
  fpcMB
fpcMB
The size unit is a megabyte (MB).
 = 2,
  fpcGB
fpcGB
The size unit is a gigabyte (GB).
 = 3

} FpcSizeUnits;

Constants

fpcKB
The size unit is a kilobyte (KB).
fpcMB
The size unit is a megabyte (MB).
fpcGB
The size unit is a gigabyte (GB).

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Comenum.h.

See Also

Enumerated Types


FpcSSLRequireSecureChannelMode enumeration [ISA Server 2004]

FpcSSLRequireSecureChannelMode

The FpcSSLRequireSecureChannelMode enumerated type contains values that specify whether a routing rule or a Web publishing rule requires a Secure Sockets Layer (SSL) connection, an SSL connection using 128-bit encryption, or an SSL connection and 128-bit encryption.

typedef enum FpcSSLRequireSecureChannelMode
{
  fpcSSLDontRequireSecureChannel
fpcSSLDontRequireSecureChannel
A secure channel is not required.
 = 0,
  fpcSSLRequireSecureChannel
fpcSSLRequireSecureChannel
A secure channel is required.
 = 1,
  fpcSSLRequire128BitSecureChannel
fpcSSLRequire128BitSecureChannel
 A secure channel using 128-bit encryption is required.
 = 2,
  fpcSSLRequireBoth
fpcSSLRequireBoth
A secure channel using 128-bit encryption is required. This value is equivalent to fpcSSLRequire128BitSecureChannel, but is used only internally in ISA Server Management.
 = 3

} FpcSSLRequireSecureChannelMode;

Constants

fpcSSLDontRequireSecureChannel
A secure channel is not required.
fpcSSLRequireSecureChannel
A secure channel is required.
fpcSSLRequire128BitSecureChannel
A secure channel using 128-bit encryption is required.
fpcSSLRequireBoth
A secure channel using 128-bit encryption is required. This value is equivalent to fpcSSLRequire128BitSecureChannel, but is used only internally in ISA Server Management.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Comenum.h.

See Also

Enumerated Types


FpcSystemPolicyConfigGroupEnum enumeration [ISA Server 2004]

FpcSystemPolicyConfigGroupEnum

The FpcSystemPolicyConfigGroupEnum enumerated type contains values that specify groups of system policy rules that apply to a specific service and can be configured together. These groups, which are called configuration groups, specify the content of the instance of the FPCSystemPolicyConfigGroup object created by the CreateConfigurationGroupInstance method of the FPCSystemPolicy object.

typedef enum FpcSystemPolicyConfigGroupEnum
{
  fpcSystemPolicyConfigGroup_Unknown
fpcSystemPolicyConfigGroup_Unknown
A system policy configuration group of unknown type.
 = -1,
  fpcSystemPolicyConfigGroup_AD
fpcSystemPolicyConfigGroup_AD
The configuration group of system policy rules that allow an ISA Server computer to obtain Active Directory services from trusted domain controllers.
 = 0,
  fpcSystemPolicyConfigGroup_Radius
fpcSystemPolicyConfigGroup_Radius
The configuration group of system policy rules that allow an ISA Server computer to access trusted RADIUS servers for RADIUS user authentication.
 = 1,
  fpcSystemPolicyConfigGroup_Passport
fpcSystemPolicyConfigGroup_Passport
The configuration group of system policy rules that allow an ISA Server computer to use Passport.
 = 2,
  fpcSystemPolicyConfigGroup_RSASecureId
fpcSystemPolicyConfigGroup_RSASecureId
The configuration group of system policy rules that allow an ISA Server computer to use RSA Secure ID.
 = 3,
  fpcSystemPolicyConfigGroup_DNS
fpcSystemPolicyConfigGroup_DNS
The configuration group of system policy rules that allow an ISA Server computer to obtain Domain Name System (DNS) services from trusted servers.
 = 4,
  fpcSystemPolicyConfigGroup_DHCP
fpcSystemPolicyConfigGroup_DHCP
The configuration group of system policy rules that allow an ISA Server computer to obtain Dynamic Host Configuration Protocol (DHCP) services from trusted servers.
 = 5,
  fpcSystemPolicyConfigGroup_RemoteMgmt_FWCONTROL
fpcSystemPolicyConfigGroup_RemoteMgmt_FWCONTROL
The configuration group of system policy rules that allow remote management of an ISA Server computer from trusted computers using remote procedure call (RPC).
 = 6,
  fpcSystemPolicyConfigGroup_RemoteMgmt_TS
fpcSystemPolicyConfigGroup_RemoteMgmt_TS
The configuration group of system policy rules that allow remote management of an ISA Server computer from trusted computers using Terminal Services.
 = 7,
  fpcSystemPolicyConfigGroup_RemoteMgmt_ICMP
fpcSystemPolicyConfigGroup_RemoteMgmt_ICMP
The configuration group of system policy rules that allow remote management of an ISA Server computer from trusted computers using  the Internet Control Message Protocol (ICMP).
 = 8,
  fpcSystemPolicyConfigGroup_RemoteLogging
fpcSystemPolicyConfigGroup_RemoteLogging
The configuration group of system policy rules that allow  an ISA Server computer to create log files on specified remote computers.
 = 9,
  fpcSystemPolicyConfigGroup_RemoteLogging_SQL
fpcSystemPolicyConfigGroup_RemoteLogging_SQL
The configuration group of system policy rules that allow  an ISA Server computer to create SQL log files on specified remote computers.
 = 10,
  fpcSystemPolicyConfigGroup_ICMP
fpcSystemPolicyConfigGroup_ICMP
The configuration group of system policy rules that allow  an ISA Server computer to send ICMP packets to trusted computers (for diagnostic purposes).
 = 11,
  fpcSystemPolicyConfigGroup_Prefetcher
fpcSystemPolicyConfigGroup_Prefetcher
The configuration group of system policy rules that allow  the Microsoft ISA Server Job Scheduler service to download HTTP content directly to an ISA Server computer.
 = 12,
  fpcSystemPolicyConfigGroup_ManagementSites
fpcSystemPolicyConfigGroup_ManagementSites
The configuration group of system policy rules that allow  an ISA Server computer to access sites needed for maintenance and management.
 = 13,
  fpcSystemPolicyConfigGroup_ClientSetup
fpcSystemPolicyConfigGroup_ClientSetup
The configuration group of system policy rules that allow trusted computers to access a Firewall client share.
 = 14,
  fpcSystemPolicyConfigGroup_Perfmon
fpcSystemPolicyConfigGroup_Perfmon
The configuration group of system policy rules that allow remote monitoring of an ISA Server computer using the Performance snap-in (Performance Monitor in Windows 2000).
 = 15,
  fpcSystemPolicyConfigGroup_Diag_WinNet
fpcSystemPolicyConfigGroup_Diag_WinNet
The configuration group of system policy rules that allow Windows Networking (the NetBIOS family of protocols) from an ISA Server computer to trusted computers for diagnostic purposes.
 = 16,
  fpcSystemPolicyConfigGroup_Diag_Watson
fpcSystemPolicyConfigGroup_Diag_Watson
The configuration group of system policy rules that allow an ISA Server computer to send error reports to Microsoft.
 = 17,
  fpcSystemPolicyConfigGroup_MOM
fpcSystemPolicyConfigGroup_MOM
The configuration group of system policy rules that allow an ISA Server computer to use Microsoft Operations Manager.
 = 18,
  fpcSystemPolicyConfigGroup_Diag_Connectivity
fpcSystemPolicyConfigGroup_Diag_Connectivity
The configuration group of system policy rules that allow an ISA Server computer to send requests that verify connectivity for diagnostic purposes.
 = 19,
  fpcSystemPolicyConfigGroup_VPN
fpcSystemPolicyConfigGroup_VPN
The configuration group of system policy rules that allow VPN access.
 = 20,
  fpcSystemPolicyConfigGroup_NTP
fpcSystemPolicyConfigGroup_NTP
The configuration group of system policy rules that allow the ISA Server computer to access the Internal network using the NTP (UDP) protocol.
 = 21,
  fpcSystemPolicyConfigGroup_SMTP
fpcSystemPolicyConfigGroup_SMTP
The configuration group of system policy rules that allow the ISA Server computer to access the Internal network using the SMTP protocol.
 = 22,
  fpcSystemPolicyConfigGroup_CRL
fpcSystemPolicyConfigGroup_CRL
The configuration group of system policy rules that allow the ISA Server computer to access selected networks for downloading updated certificate revocation lists (CRLs) using the HTTP protocol.
 = 23,
  fpcSystemPolicyConfigGroup_MaxGroups
fpcSystemPolicyConfigGroup_MaxGroups
The current number of configuration groups.
 = 24

} FpcSystemPolicyConfigGroupEnum;

Constants

fpcSystemPolicyConfigGroup_Unknown
A system policy configuration group of unknown type.
fpcSystemPolicyConfigGroup_AD
The configuration group of system policy rules that allow an ISA Server computer to obtain Active Directory services from trusted domain controllers.
fpcSystemPolicyConfigGroup_Radius
The configuration group of system policy rules that allow an ISA Server computer to access trusted RADIUS servers for RADIUS user authentication.
fpcSystemPolicyConfigGroup_Passport
The configuration group of system policy rules that allow an ISA Server computer to use Passport.
fpcSystemPolicyConfigGroup_RSASecureId
The configuration group of system policy rules that allow an ISA Server computer to use RSA Secure ID.
fpcSystemPolicyConfigGroup_DNS
The configuration group of system policy rules that allow an ISA Server computer to obtain Domain Name System (DNS) services from trusted servers.
fpcSystemPolicyConfigGroup_DHCP
The configuration group of system policy rules that allow an ISA Server computer to obtain Dynamic Host Configuration Protocol (DHCP) services from trusted servers.
fpcSystemPolicyConfigGroup_RemoteMgmt_FWCONTROL
The configuration group of system policy rules that allow remote management of an ISA Server computer from trusted computers using remote procedure call (RPC).
fpcSystemPolicyConfigGroup_RemoteMgmt_TS
The configuration group of system policy rules that allow remote management of an ISA Server computer from trusted computers using Terminal Services.
fpcSystemPolicyConfigGroup_RemoteMgmt_ICMP
The configuration group of system policy rules that allow remote management of an ISA Server computer from trusted computers using the Internet Control Message Protocol (ICMP).
fpcSystemPolicyConfigGroup_RemoteLogging
The configuration group of system policy rules that allow an ISA Server computer to create log files on specified remote computers.
fpcSystemPolicyConfigGroup_RemoteLogging_SQL
The configuration group of system policy rules that allow an ISA Server computer to create SQL log files on specified remote computers.
fpcSystemPolicyConfigGroup_ICMP
The configuration group of system policy rules that allow an ISA Server computer to send ICMP packets to trusted computers (for diagnostic purposes).
fpcSystemPolicyConfigGroup_Prefetcher
The configuration group of system policy rules that allow the Microsoft ISA Server Job Scheduler service to download HTTP content directly to an ISA Server computer.
fpcSystemPolicyConfigGroup_ManagementSites
The configuration group of system policy rules that allow an ISA Server computer to access sites needed for maintenance and management.
fpcSystemPolicyConfigGroup_ClientSetup
The configuration group of system policy rules that allow trusted computers to access a Firewall client share.
fpcSystemPolicyConfigGroup_Perfmon
The configuration group of system policy rules that allow remote monitoring of an ISA Server computer using the Performance snap-in (Performance Monitor in Windows 2000).
fpcSystemPolicyConfigGroup_Diag_WinNet
The configuration group of system policy rules that allow Windows Networking (the NetBIOS family of protocols) from an ISA Server computer to trusted computers for diagnostic purposes.
fpcSystemPolicyConfigGroup_Diag_Watson
The configuration group of system policy rules that allow an ISA Server computer to send error reports to Microsoft.
fpcSystemPolicyConfigGroup_MOM
The configuration group of system policy rules that allow an ISA Server computer to use Microsoft Operations Manager.
fpcSystemPolicyConfigGroup_Diag_Connectivity
The configuration group of system policy rules that allow an ISA Server computer to send requests that verify connectivity for diagnostic purposes.
fpcSystemPolicyConfigGroup_VPN
The configuration group of system policy rules that allow VPN access.
fpcSystemPolicyConfigGroup_NTP
The configuration group of system policy rules that allow the ISA Server computer to access the Internal network using the NTP (UDP) protocol.
fpcSystemPolicyConfigGroup_SMTP
The configuration group of system policy rules that allow the ISA Server computer to access the Internal network using the SMTP protocol.
fpcSystemPolicyConfigGroup_CRL
The configuration group of system policy rules that allow the ISA Server computer to access selected networks for downloading updated certificate revocation lists (CRLs) using the HTTP protocol.
fpcSystemPolicyConfigGroup_MaxGroups
The current number of configuration groups.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Comenum.h.

See Also

Enumerated Types


FpcTimeScale enumeration [ISA Server 2004]

FpcTimeScale

The FpcTimeScale enumerated type contains values that specify units of time.

typedef enum FpcTimeScale
{
  fpcTimeInSeconds
fpcTimeInSeconds
Time in seconds.
 = 1,
  fpcTimeInMinutes
fpcTimeInMinutes
Time in minutes.
 = 2,
  fpcTimeInHours
fpcTimeInHours
Time in hours.
 = 3,
  fpcTimeInDays
fpcTimeInDays
Time in days.
 = 4,
  fpcTimeInWeeks
fpcTimeInWeeks
Time in weeks.
 = 5

} FpcTimeScale;

Constants

fpcTimeInSeconds
Time in seconds.
fpcTimeInMinutes
Time in minutes.
fpcTimeInHours
Time in hours.
fpcTimeInDays
Time in days.
fpcTimeInWeeks
Time in weeks.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Comenum.h.

See Also

Enumerated Types


FpcTopAppProtocolReportSortOrder enumeration [ISA Server 2004]

FpcTopAppProtocolReportSortOrder

The FpcTopAppProtocolReportSortOrder enumerated type contains values that specify how the information in a protocols report (an application usage report) is to be sorted.

typedef enum FpcTopAppProtocolReportSortOrder
{
  fpcAppProtocolRequests
fpcAppProtocolRequests
The information is to be sorted by the number of requests made in each protocol.
 = 0,
  fpcAppProtocolUsers
fpcAppProtocolUsers
The information is to be sorted by the number of users that use each protocol.
 = 1

} FpcTopAppProtocolReportSortOrder;

Constants

fpcAppProtocolRequests
The information is to be sorted by the number of requests made in each protocol.
fpcAppProtocolUsers
The information is to be sorted by the number of users that use each protocol.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Comenum.h.

See Also

Enumerated Types


FpcTopAppsReportSortOrder enumeration [ISA Server 2004]

FpcTopAppsReportSortOrder

The FpcTopAppsReportSortOrder enumerated type contains values that specify how the information in an applications report (an application usage report) is to be sorted.

typedef enum FpcTopAppsReportSortOrder
{
  fpcTopAppsRequests
fpcTopAppsRequests
The information is to be sorted by the number of requests submitted from each application.
 = 0,
  fpcTopAppsUsers
fpcTopAppsUsers
The information is to be sorted by the number of users that use each application.
 = 1

} FpcTopAppsReportSortOrder;

Constants

fpcTopAppsRequests
The information is to be sorted by the number of requests submitted from each application.
fpcTopAppsUsers
The information is to be sorted by the number of users that use each application.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Comenum.h.

See Also

Enumerated Types


FpcTopDestinationsReportSortOrder enumeration [ISA Server 2004]

FpcTopDestinationsReportSortOrder

The FpcTopDestinationsReportSortOrder enumerated type contains values that specify how the information in a destinations report (an application usage report) is to be sorted.

typedef enum FpcTopDestinationsReportSortOrder
{
  fpcTopDestinationsRequests
fpcTopDestinationsRequests
The information is to be sorted by the number of requests sent to each destination.
 = 0,
  fpcTopDestinationsUsers
fpcTopDestinationsUsers
The information is to be sorted by the number of users that access each destination.
 = 1,
  fpcTopDestinationsBytesIn
fpcTopDestinationsBytesIn
The information is to be sorted by the number of incoming bytes transferred to each destination.
 = 2,
  fpcTopDestinationsBytesOut
fpcTopDestinationsBytesOut
The information is to be sorted by the number of outgoing bytes transferred from each destination.
 = 3,
  fpcTopDestinationsTotalBytes
fpcTopDestinationsTotalBytes
The information is to be sorted by the total number of bytes transferred to or from each destination.
 = 4

} FpcTopDestinationsReportSortOrder;

Constants

fpcTopDestinationsRequests
The information is to be sorted by the number of requests sent to each destination.
fpcTopDestinationsUsers
The information is to be sorted by the number of users that access each destination.
fpcTopDestinationsBytesIn
The information is to be sorted by the number of incoming bytes transferred to each destination.
fpcTopDestinationsBytesOut
The information is to be sorted by the number of outgoing bytes transferred from each destination.
fpcTopDestinationsTotalBytes
The information is to be sorted by the total number of bytes transferred to or from each destination.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Comenum.h.

See Also

Enumerated Types


FpcTopSitesReportSortOrder enumeration [ISA Server 2004]

FpcTopSitesReportSortOrder

The FpcTopSitesReportSortOrder enumerated type contains values that specify how the information in a sites report (a summary report or a Web usage report) is to be sorted.

typedef enum FpcTopSitesReportSortOrder
{
  fpcTopSitesRequests
fpcTopSitesRequests
The information is to be sorted by the number of requests sent to each site.
 = 0,
  fpcTopSitesUsers
fpcTopSitesUsers
The information is to be sorted by the number of users that visit each site.
 = 1,
  fpcTopSitesBytesIn
fpcTopSitesBytesIn
The information is to be sorted by the number of incoming bytes transferred to each site.
 = 2,
  fpcTopSitesBytesOut
fpcTopSitesBytesOut
The information is to be sorted by the number of outgoing bytes transferred from each site.
 = 3,
  fpcTopSitesTotalBytes
fpcTopSitesTotalBytes
The information is to be sorted by the total number of bytes transferred to or from each site.
 = 4

} FpcTopSitesReportSortOrder;

Constants

fpcTopSitesRequests
The information is to be sorted by the number of requests sent to each site.
fpcTopSitesUsers
The information is to be sorted by the number of users that visit each site.
fpcTopSitesBytesIn
The information is to be sorted by the number of incoming bytes transferred to each site.
fpcTopSitesBytesOut
The information is to be sorted by the number of outgoing bytes transferred from each site.
fpcTopSitesTotalBytes
The information is to be sorted by the total number of bytes transferred to or from each site.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Comenum.h.

See Also

Enumerated Types


FpcTopUsersReportSortOrder enumeration [ISA Server 2004]

FpcTopUsersReportSortOrder

The FpcTopUsersReportSortOrder enumerated type contains values that specify how the information in a users report (a summary report, an application usage report, or a Web usage report) is to be sorted.

typedef enum FpcTopUsersReportSortOrder
{
  fpcTopUsersRequests
fpcTopUsersRequests
The information is to be sorted by the number of requests sent by each user.
 = 0,
  fpcTopUsersBytesIn
fpcTopUsersBytesIn
The information is to be sorted by the number of incoming bytes for each user.
 = 2,
  fpcTopUsersBytesOut
fpcTopUsersBytesOut
The information is to be sorted by the number of outgoing bytes for each user.
 = 3,
  fpcTopUsersTotalBytes
fpcTopUsersTotalBytes
The information is to be sorted  by the total number of bytes for each user.
 = 4

} FpcTopUsersReportSortOrder;

Constants

fpcTopUsersRequests
The information is to be sorted by the number of requests sent by each user.
fpcTopUsersBytesIn
The information is to be sorted by the number of incoming bytes for each user.
fpcTopUsersBytesOut
The information is to be sorted by the number of outgoing bytes for each user.
fpcTopUsersTotalBytes
The information is to be sorted by the total number of bytes for each user.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Comenum.h.

See Also

Enumerated Types


FpcTopWebProtocolReportSortOrder enumeration [ISA Server 2004]

FpcTopWebProtocolReportSortOrder

The FpcTopWebProtocolReportSortOrder enumerated type contains values that specify how the information in a Web protocols report (a Web usage report) is to be sorted.

typedef enum FpcTopWebProtocolReportSortOrder
{
  fpcWebProtocolRequests
fpcWebProtocolRequests
The information is to be sorted by the number of requests made in each protocol.
 = 0,
  fpcWebProtocolUsers
fpcWebProtocolUsers
The information is to be sorted by the number of users that use each protocol.
 = 1,
  fpcWebProtocolBytesIn
fpcWebProtocolBytesIn
The information is to be sorted by the number of incoming bytes transferred using each protocol.
 = 2,
  fpcWebProtocolBytesOut
fpcWebProtocolBytesOut
The information is to be sorted by the number of outgoing bytes transferred using each protocol.
 = 3,
  fpcWebProtocolTotalBytes
fpcWebProtocolTotalBytes
The information is to be sorted  by the total number of bytes transferred using each protocol.
 = 4

} FpcTopWebProtocolReportSortOrder;

Constants

fpcWebProtocolRequests
The information is to be sorted by the number of requests made in each protocol.
fpcWebProtocolUsers
The information is to be sorted by the number of users that use each protocol.
fpcWebProtocolBytesIn
The information is to be sorted by the number of incoming bytes transferred using each protocol.
fpcWebProtocolBytesOut
The information is to be sorted by the number of outgoing bytes transferred using each protocol.
fpcWebProtocolTotalBytes
The information is to be sorted by the total number of bytes transferred using each protocol.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Comenum.h.

See Also

Enumerated Types


FpcUDPConnectionDirectionType enumeration [ISA Server 2004]

FpcUDPConnectionDirectionType

The FpcUDPConnectionDirectionType enumerated type contains values that specify the directions for User Datagram Protocol (UDP) connections.

typedef enum FpcUDPConnectionDirectionType
{
  fpcReceiveOnly
fpcReceiveOnly
Receive only.
 = 0,
  fpcSendOnly
fpcSendOnly
Send only.
 = 1,
  fpcReceiveSend
fpcReceiveSend
Receive and then send.
 = 2,
  fpcSendReceive
fpcSendReceive
Send and then receive.
 = 3

} FpcUDPConnectionDirectionType;

Constants

fpcReceiveOnly
Receive only.
fpcSendOnly
Send only.
fpcReceiveSend
Receive and then send.
fpcSendReceive
Send and then receive.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Comenum.h.

See Also

Enumerated Types


FpcVpnAuthenticationMethod enumeration [ISA Server 2004]

FpcVpnAuthenticationMethod

The FpcVpnAuthenticationMethod enumerated type contains values that specify the Internet Protocol security (IPSec) authentication methods that can be used for virtual private network (VPN) connections.

typedef enum FpcVpnAuthenticationMethod
{
  fpcVpnCertificate
fpcVpnCertificate
Authentication using a certificate.
 = 0,
  fpcVpnPresharedKey
fpcVpnPresharedKey
Authentication using a preshared key.
 = 1

} FpcVpnAuthenticationMethod;

Constants

fpcVpnCertificate
Authentication using a certificate.
fpcVpnPresharedKey
Authentication using a preshared key.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Comenum.h.

See Also

Enumerated Types


FpcVpnDiffieHellmanGroup enumeration [ISA Server 2004]

FpcVpnDiffieHellmanGroup

The FpcVpnDiffieHellmanGroup enumerated type contains values that specify the Diffie-Hellman groups that can be used in Phase 1 or Phase 2 of the Internet Protocol security (IPSec) negotiation process. The Diffie-Hellman group sets the length of the base prime numbers used during the key exchange process. The cryptographic strength of any key derived depends, in part, on this length.

typedef enum FpcVpnDiffieHellmanGroup
{
  fpcVpnDHGroup1
fpcVpnDHGroup1
Diffie-Hellman Group 1, which provides a keying strength of 768 bits.
 = 0,
  fpcVpnDHGroup2
fpcVpnDHGroup2
Diffie-Hellman Group 2, which provides a keying strength of 1,024 bits.
 = 1,
  fpcVpnDHGroup2048
fpcVpnDHGroup2048
Diffie-Hellman Group 2048, which provides a keying strength of 2,048 bits. This value is not supported on computers running a Windows 2000 Server operating system.
 = 2

} FpcVpnDiffieHellmanGroup;

Constants

fpcVpnDHGroup1
Diffie-Hellman Group 1, which provides a keying strength of 768 bits.
fpcVpnDHGroup2
Diffie-Hellman Group 2, which provides a keying strength of 1,024 bits.
fpcVpnDHGroup2048
Diffie-Hellman Group 2048, which provides a keying strength of 2,048 bits. This value is not supported on computers running a Windows 2000 Server operating system.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Comenum.h.

See Also

Enumerated Types


FpcVpnEncryptionAlgorithm enumeration [ISA Server 2004]

FpcVpnEncryptionAlgorithm

The FpcVpnEncryptionAlgorithm enumerated type contains values that specify the encryption algorithms that can be used during Phase 1 and Phase 2 of the Internet Protocol security (IPSec) negotiation process.

typedef enum FpcVpnEncryptionAlgorithm
{
  fpcVpnDES
fpcVpnDES
The Data Encryption Standard (DES) algorithm, which uses a 56-bit key.
 = 0,
  fpcVpn3DES
fpcVpn3DES
The Triple Data Encryption Standard (3DES) algorithm, which uses three 56-bit keys.
 = 1

} FpcVpnEncryptionAlgorithm;

Constants

fpcVpnDES
The Data Encryption Standard (DES) algorithm, which uses a 56-bit key.
fpcVpn3DES
The Triple Data Encryption Standard (3DES) algorithm, which uses three 56-bit keys.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Comenum.h.

See Also

Enumerated Types


FpcVpnIntegrityAlgorithm enumeration [ISA Server 2004]

FpcVpnIntegrityAlgorithm

The FpcVpnIntegrityAlgorithm enumerated type contains values that specify the integrity algorithms that can be used during Phase 1 and Phase 2 of the Internet Protocol security (IPSec) negotiation process.

typedef enum FpcVpnIntegrityAlgorithm
{
  fpcVpnSHA1
fpcVpnSHA1
The Secure Hash Algorithm 1 (SHA1) integrity algorithm, which uses a 160-bit key.
 = 0,
  fpcVpnMD5
fpcVpnMD5
The Message Digest 5 (MD5) integrity algorithm, which uses a 128-bit key.
 = 1

} FpcVpnIntegrityAlgorithm;

Constants

fpcVpnSHA1
The Secure Hash Algorithm 1 (SHA1) integrity algorithm, which uses a 160-bit key.
fpcVpnMD5
The Message Digest 5 (MD5) integrity algorithm, which uses a 128-bit key.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Comenum.h.

See Also

Enumerated Types


FpcVpnProtocol enumeration [ISA Server 2004]

FpcVpnProtocol

The FpcVpnProtocol enumerated type contains values that specify the protocols that can be used for site-to-site virtual private network (VPN) connections.

typedef enum FpcVpnProtocol
{
  fpcVpnL2TP
fpcVpnL2TP
The Layer Two Tunneling Protocol (L2TP).
 = 0,
  fpcVpnPPTP
fpcVpnPPTP
The Point-to-Point Tunneling Protocol (PPTP).
 = 1

} FpcVpnProtocol;

Constants

fpcVpnL2TP
The Layer Two Tunneling Protocol (L2TP).
fpcVpnPPTP
The Point-to-Point Tunneling Protocol (PPTP).

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Comenum.h.

See Also

Enumerated Types


FpcVpnQuarantineMode enumeration [ISA Server 2004]

FpcVpnQuarantineMode

The FpcVpnQuarantineMode enumerated type contains values that specify whether the virtual private network (VPN) quarantine is enabled or disabled, and whether the VPN quarantine uses the ISA Server policy or the RADIUS policy.

typedef enum FpcVpnQuarantineMode
{
  fpcVpnQuarantineDisabled
fpcVpnQuarantineDisabled
The VPN quarantine is disabled.

 = 0,
  fpcVpnQuarantineEnabled
fpcVpnQuarantineEnabled
The VPN quarantine is enabled and is subject to the ISA Server policy.

 = 1,
  fpcVpnQuarantineEnabledWithRadiusPolicy
fpcVpnQuarantineEnabledWithRadiusPolicy
The VPN quarantine is enabled and is subject to the RADIUS policy.

 = 2

} FpcVpnQuarantineMode;

Constants

fpcVpnQuarantineDisabled
The VPN quarantine is disabled.
fpcVpnQuarantineEnabled
The VPN quarantine is enabled and is subject to the ISA Server policy.
fpcVpnQuarantineEnabledWithRadiusPolicy
The VPN quarantine is enabled and is subject to the RADIUS policy.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Comenum.h.

See Also

Enumerated Types


Log Fields [ISA Server 2004]

Log Fields

You can use Internet Security and Acceleration (ISA) Server 2004 logging to monitor and analyze status for the Microsoft Firewall service, the ISA Server Web proxy, and the SMTP Message Screener. This section provides tables that list the fields you can include in each of the ISA Server logs.

Topics included in this section are:

  • Firewall Log Fields
  • Web Proxy Log Fields
  • SMTP Message Screener Log Fields

See Also

Administration Reference


Firewall Log Fields [ISA Server 2004]

Firewall Log Fields

The following table lists the log fields that can be included in Firewall service log entries by setting the corresponding bit in the LogFieldSelection property of the FPCLog object for Firewall service logging.

Bit number | Field name (Log Viewer) | Field name (SQL files) | Description
0 | Server Name | servername | The name of the ISA Server computer. This is the computer name assigned in Microsoft Windows.
1 | Log Date | LogDate | The date on which the logged event occurred.
2 | Log Time | LogTime | The time when the logged event occurred. In W3C format, this is the Coordinated Universal Time (UTC).
3 | Transport | protocol | The transport protocol used for the connection. Common values are Transmission Control Protocol (TCP) and User Datagram Protocol (UDP).
4 | Client IP and Port | Source | The Internet Protocol (IP) address of the requesting client and the source port used.
5 | Destination IP and Port | Destination | The network IP address and the reserved port number on the remote computer that provides service to the current connection. The port number is used by the client application initiating the request.
6 | Original Client IP | OriginalClientIP | The original IP address of the requesting client.
7 | Source Network | SourceNetwork | The network from which the request originated.
8 | Destination Network | DestinationNetwork | The network to which the request was sent.
9 | Action | Action | The action performed by the Microsoft Firewall service for the current session or connection. The possible values are defined in the FpcAction enumerated type.
10 | Result Code | resultcode | A Windows error code or an ISA Server error code in HRESULT format.
11 Rule rule The rule that either allowed or denied access to the request, as follows:

  • If an outgoing request was allowed, this field reflects the protocol rule that allowed the request.
  • If an outgoing request was denied by a protocol rule, this field reflects the protocol rule.
  • If an outgoing request is denied by an access rule, this field reflects the protocol rule that would have allowed the request.
  • If an incoming request was denied, this field reflects the Web publishing or server publishing rule that denied the request.
  • If no rule specifically allowed the outgoing or incoming request, the request is denied. In this case, the field is empty.
12 | Protocol | ApplicationProtocol | The name of the application protocol used for the connection as defined in the colletion of protocol definitions.
13 | Bidirectional | Bidirectional | A value from the FpcBidirectional enumerated type that indicates whether the connection was bidirectional.
14 | Bytes Sent | bytessent | The total number of bytes sent from the client to the destination host during the current connection. A hyphen (-), a zero (0), or a negative number in this field indicates that this information was not provided by the destination host or that no bytes were sent to the destination host.
15 | Bytes Sent Delta | bytessentDelta | The number of bytes sent from the client to the destination host since the previous log entry for the current connection. A hyphen (-), a zero (0), or a negative number in this field indicates that this information was not provided by the destination host or that no bytes were sent to the destination host.
16 | Bytes Received | bytesrecvd | The total number of bytes sent from the remote computer and received by the client during the current connection. A hyphen (-), a zero (0), or a negative number in this field indicates that this information was not provided by the remote computer or that no bytes were received from the remote computer.
17 | Bytes Received Delta | bytesrecvdDelta | The number of bytes sent from the remote computer and received by the client since the previous log entry for the current connection. A hyphen (-), a zero (0), or a negative number in this field indicates that this information was not provided by the remote computer or that no bytes were received from the remote computer.
18 | Processing Time | connectiontime | The total time, in milliseconds, that was needed by ISA Server to process the current connection. It measures the time elapsed from the time when the ISA Server computer first received the request to the time when final processing occurred on the ISA Server computer—when results were returned to the client and the connection was closed.
19 | Processing Time Delta | connectiontimeDelta | The time, in milliseconds, that has elapsed since the previous log entry for the current connection.
20 | Source Proxy | SourceProxy | Reserved for future use.
21 | Destination Proxy | DestinationProxy | Reserved for future use.
22 | Client Host Name | SourceName | Reserved for future use.
23 | Destination Host Name | DestinationName | The domain name for the remote computer that provides service to the current connection.
24 | Client Username | ClientUserName | The account of the user making the request. A question mark (?) next to the user name indicates that the user name was sent but the user was not authenticated by ISA Server. If ISA Server access control is not being used, ISA Server uses Anonymous.
25 Client Agent ClientAgent The name and version of the operating system that is running on the Firewall client that created the session, as indicated by the Hypertext Transfer Protocol (HTTP) User-Agent header sent by the client's browser application. This field is not applicable to SecureNAT sessions.

For the supported strings, see Client Agent Values. A User-Agent header that is not supported is regarded as an unknown operating system.
26 | Session ID | sessionid | An identifier that identifies a session's connections. For Firewall clients, each process that connects through the Microsoft Firewall service initiates a session. For secure network address translation (SecureNAT) clients, a single session is opened for all the connections that originate from the same IP address.
27 | Connection ID | connectionid | An identifier that identifies entries belonging to the same socket. Outbound TCP usually has two entries for each connection: when the connection is established and when the connection is terminated. UDP usually has two entries for each remote address.
28 | Network Interface | Interface | The network adapter with which the connection was established on the ISA Server computer.
29 | Raw IP Header | IPHeader | The IP header of the current packet. Information is supplied to this field only for packets that are denied passage and are dropped by ISA Server.
30 | Raw Payload | Payload | The protocol header of the current packet. Information is supplied to this field only for packets that are denied passage and are dropped by ISA Server.

Client Agent Values

User-Agent header | Client Agent value
Windows NT 5.2 | Windows Server 2003
Windows NT 5.1 | Windows XP
windows nt 5 | Windows 2000
windows 2000 | Windows 2000
win2000 | Windows 2000
winnt | Windows NT
windows nt | Windows NT
win98 | Windows 98
windows 98 | Windows 98
win95 | Windows 95
windows 95 | Windows 95
win32 | Windows 32-bit
win16 | Windows 16-bit
windows ce | Windows CE
windows | Windows
aix | aix
amiga | amiga
hp | hp
irix | irix
linux | linux
mac | mac
solaris | solaris
sun | sun
unix | unix
vax | vax

See Also

Log Fields


Web Proxy Log Fields [ISA Server 2004]

Web Proxy Log Fields

The following table lists the log fields that can be included in ISA Server Web proxy log entries by setting the corresponding bit in the LogFieldSelection property of the FPCLog object for Web proxy logging.

Bit number | Field name (Log Viewer) | Field name (MSDE files) | Description
0 | Client IP | ClientIP | The Internet Protocol (IP) address of the requesting client.
1 | Client Username | ClientUserName | The account of the user making the request. A question mark (?) next to the user name indicates that the user name was sent but the user was not authenticated by ISA Server. If ISA Server access control is not being used, ISA Server uses Anonymous.
2 | Client Agent | ClientAgent | The name and version of the client application sent by the client in the Hypertext Transfer Protocol (HTTP) User-Agent header. When ISA Server is actively caching, this field is set to ISA Server.
3 | Authenticated Client | ClientAuthenticate | A value that indicates whether the client has been authenticated with the ISA Server computer. Possible values are Y and N.
4 | Log Date | TimeStamp | The date on which the logged event occurred.
5 | Log Time | Not applicable | The time when the logged event occurred. In W3C format, this is the Coordinated Universal Time (UTC).
6 | Service | service | The name of the service that is logged. For example, fwsrv indicates the Microsoft Firewall service.
7 | Server Name | servername | The name of the ISA Server computer. This is the computer name assigned in Windows Server 2003 and Windows 2000.
8 | Referring Server | referredserver | If ISA Server is used upstream in a chained configuration, this field contains the name of the downstream server that sent the request.
9 | Destination Host Name | DestHost | The domain name for the remote computer that provides service to the current connection. A hyphen (-) in this field may indicate that an object was retrieved from the local cache and not from the destination.
10 | Destination IP | DestHostIP | The network IP address of the remote computer that provides service to the current connection. A hyphen (-) in this field may indicate that an object was sourced from the local cache and not from the destination. One exception is negative caching. In that case, this field contains a destination IP address for which a negative cached object was returned.
11 | Destination Port | DestHostPort | The reserved port number on the remote computer that provides service to the current connection. This is used by the client application initiating the request.
12 Processing Time processingtime The total time, in milliseconds, that is needed by ISA Server to process the current connection. It measures the time elapsed from the time when the server first receives the request to the time when final processing occurs on the server—when results are returned to the client and the connection is closed.

For cache requests that are processed through the ISA Server Web proxy, the processing time measures the elapsed server time needed to fully process a client request and return an object from the server cache to the client.
13 | Bytes Received | bytesrecvd | The number of bytes sent from the remote computer and received by the client during the current connection. A hyphen (-), a zero (0), or a negative number in this field indicates that this information was not provided by the remote computer or that no bytes were received from the remote computer.
14 | Bytes Sent | bytessent | The number of bytes sent from the client to the remote computer during the current connection. A hyphen (-), a zero (0), or a negative number in this field indicates that this information was not provided by the remote computer or that no bytes were sent to the remote computer.
15 | Protocol | protocol | The application protocol used for the connection. Common values are Hypertext Transfer Protocol (HTTP), File Transfer Protocol (FTP), Gopher, and Secure HTTP (HTTPS).
16 | Transport | transport | The transport protocol used for the connection. Common values are Transmission Control Protocol (TCP) and User Datagram Protocol (UDP).
17 | HTTP Method | operation | The HTTP method used. Common values are GET, PUT, POST, and HEAD.
18 | URL | uri | The contents of the URL request.
19 | MIME Type | mimetype | The Multipurpose Internet Mail Extensions (MIME) type for the current object. This field may also contain a hyphen (-) to indicate that this field is not used or that a valid MIME type was not defined or supported by the remote computer.
20 | Object Source | objectsource | The type of source that was used to retrieve the current object. A table of some possible values is provided in Object Source Values.
21 | Result Code | resultcode | A Windows (Win32) error code (for values less than 100), an HTTP status code (for values between 100 and 1,000), or a Winsock error code (for values between 10,000 and 11,004). A table of some possible values is provided in Result Code Values.
22 | Cache Info | CacheInfo | A number reflecting the cache status of the object, which indicates why the object was or was not cached. A table of some possible values is provided in Cache Information Values.
23 Rule rule The rule that either allowed or denied access to the request, as follows:

  • If an outgoing request was allowed, this field reflects the protocol rule that allowed the request.
  • If an outgoing request was denied by a protocol rule, this field reflects the protocol rule.
  • If an outgoing request is denied by an access rule, this field reflects the protocol rule that would have allowed the request.
  • If an incoming request was denied, this field reflects the Web publishing or server publishing rule that denied the request.
  • If no rule specifically allowed the outgoing or incoming request, the request is denied. In this case, the field is empty.
24 Filter Information FilterInfo The second rule that either allowed or denied access to the request, as follows:

  • If an outgoing request is allowed, this field reflects the access rule that allowed the request.
  • If an outgoing request is denied by an access rule, this field reflects the access rule that denied the request.
  • If no rule specifically allowed the outgoing or incoming request, the request is denied. In this case, the field is empty.
25 | Source Network | SrcNetwork | The network from which the request originated.
26 | Destination Network | DstNetwork | The network to which the request was sent.
27 | Error info (ErrorInfo) | ErrorInfo | A 32-bit bitmask that provides additional information about the request that can help identify the source of the error if an error occurred. A table of the possible bit fields is provided in Error Information Bit Fields.
28 | Action | Action | The action performed by the Microsoft Firewall service for the current session or connection. The possible values are defined in the FpcAction enumerated type.

Object Source Values

Source values | Description
0 | No source information is available.
Cache | Source is the cache. Object returned from cache.
Inet | Source is the Internet. Object added to cache.
Member | Returned from another array member.
NotModified | Source is the cache. Client performed an If-Modified-Since request and object had not been modified.
NVCache | Source is the cache. Object could not be verified to source.
Upstream | Object returned from an upstream proxy cache.
Vcache | Source is the cache. Object was verified to source and had not been modified.
VFInet | Source is the Internet. Cached object was verified to source and had been modified.

Result Code Values

Value | Description
200 | OK.
201 | Created.
202 | Accepted.
204 | No content.
301 | Moved permanently.
302 | Moved temporarily.
304 | Not modified.
400 | Bad request.
401 | Unauthorized.
403 | Forbidden.
404 | Not found.
500 | Server error.
501 | Not implemented.
502 | Bad gateway.
503 | Out of resources.
10060 | Connection timed out.
10061 | Connection refused by destination.
10065 | No route to host.
11001 | Host not found.

Cache Information Values

Value | Description
0x00000001 | Request should not be served from the cache.
0x00000002 | Request includes the IF-MODIFIED-SINCE header.
0x00000004 | Request includes one of these headers: CACHE-CONTROL:NO-CACHE or PRAGMA:NO-CACHE.
0x00000008 | Request includes the AUTHORIZATION header.
0x00000010 | Request includes the VIA header.
0x00000020 | Request includes the IF-MATCH header.
0x00000040 | Request includes the RANGE header.
0x00000080 | Request includes the CACHE-CONTROL: NO-STORE header.
0x00000100 | Request includes the CACHE-CONTROL: MAX-AGE, or CACHE-CONTROL: MAX-STALE, or CACHE-CONTROL: MIN-FRESH header.
0x00000200 | Cache could not be updated.
0x00000400 | IF-MODIFIED-SINCE time specified in the request is newer than cached LASTMODIFIED time.
0x00000800 | Request includes the CACHE-CONTROL: ONLY-IF-CACHED header.
0x00001000 | Request includes the IF-NONE-MATCH header.
0x00002000 | Request includes the IF-UNMODIFIED-SINCE header.
0x00004000 | Request includes the IF-RANGE header.
0x00008000 | More than one VARY header.
0x00010000 | Response includes the CACHE-CONTROL: PUBLIC header.
0x00020000 | Response includes the CACHE-CONTROL: PRIVATE header.
0x00040000 | Response includes the CACHE-CONTROL: NO-CACHE or PRAGMA: NO-CACHE header.
0x00080000 | Response includes the CACHE-CONTROL: NO-STORE header.
0x00100000 | Response includes either the CACHE-CONTROL: MUST-REVALIDATE or CACHE-CONTROL: PROXY-REVALIDATE header.
0x00200000 | Response includes the CACHE-CONTROL: MAX-AGE or S-MAXAGE header.
0x00400000 | Response includes the VARY header.
0x00800000 | Response includes the LAST-MODIFIED header.
0x01000000 | Response includes the EXPIRES header.
0x02000000 | Response includes the SET-COOKIE header.
0x04000000 | Response includes the WWW-AUTHENTICATE header.
0x08000000 | Response includes the VIA header.
0x10000000 | Response includes the AGE header.
0x20000000 | Response includes the TRANSFER-ENCODING header.
0x40000000 | Response should not be cached.

Error Information Bit Fields

Value | Descriptive code
0x00000001 | ERROR_INFO_IO_RECV_FROM_CLIENT
0x00000002 | ERROR_INFO_IO_SEND_TO_CLIENT
0x00000004 | ERROR_INFO_IO_SEND_TO_SERVER
0x00000008 | ERROR_INFO_IO_RECV_FROM_SERVER
0x00000010 | ERROR_INFO_DEST_IS_MEMBER
0x00000020 | ERROR_INFO_CLIENT_IS_MEMBER
0x00000040 | ERROR_INFO_DURING_CONNECT
0x00000080 | ERROR_INFO_CLIENT_KA
0x00000100 | ERROR_INFO_SERVER_KA
0x00000200 | ERROR_INFO_REQUEST_HAS_BODY
0x00000400 | ERROR_INFO_RESPONSE_HAS_BODY
0x00000800 | ERROR_INFO_IP_FROM_DNS_CACHE

See Also

Log Fields


SMTP Message Screener Log Fields [ISA Server 2004]

SMTP Message Screener Log Fields

The following table lists the log fields that can be included in SMTP Message Screener log entries by setting the corresponding bit in the LogFieldSelection property of the FPCLog object for SMTP Message Screener logging.

Bit number | Field name | Description
0 | Log Date | The date on which the logged event occurred.
1 | Log Time | The time when the logged event occurred. In W3C format, this is the Coordinated Universal Time (UTC).
2 | Sender | The name of the sender as specified, for example, in the FROM: field of the SMTP header. Only the first seventy two characters are included in a log entry.
3 | Recipient | The list of recipients as specified, for example, in the TO: field of the SMTP header. Only the first seventy two characters are included in a log entry.
4 | Subject | The subject of the message as specified in the SUBJECT: field of the SMTP header. Only the first seventy two characters are included in a log entry.
5 | Message ID | The unique identifier of the message as specified in the MESSAGE-ID field of the SMTP header. Only the first seventy two characters are included in a log entry.
6 Action

The action taken by ISA Server. This field may contain one of the following possible actions:

  • Delete. (The message is deleted.)
  • Hold. (The message is stored in the BadMail queue.)
  • Forward. (The message is forwarded to a different recipient that is not specified in the original message).
  • Pass. (The message is sent to the recipient specified in the Recipient field.)
7 Reason

The reason why ISA Server performed the action specified in the Action field. This field may contain one of the following possible reasons:

  • Some message properties could not be read. Taking default action. (The default action is Hold.)
  • Policy rule stamp could not be found in the message. Taking default action. (The default action is Hold. The policy rule stamp is an indication that ISA Server puts in the message to let the message screener know which rule should be applied to the message. This is generated if the message did not pass via the SMTP application filter before being passed to the SMTP message screener.)
  • Logger is not initialized yet. Taking default action. (Default action is Hold.)
  • Policy rule could not be read. Taking default action. (Default action is Hold).
  • Failed while trying to forward the message. (The specific error code is also listed here).
  • The SMTP message screener policy rule does not allow messages from sender.
  • The SMTP message screener policy rule does not allow attachment.
  • The SMTP message screener policy rule does not allow attachment extension.
  • The SMTP message screener policy rule does not allow attachments of specified size.
  • The SMTP message screener policy rule does not allow messages with specified subject.
  • The SMTP message screener policy rule does not allow messages with specified message body.

See Also

Log Fields


Administration Object Error Codes [ISA Server 2004]

Administration Object Error Codes

The following are the COM object warning (WRN) and error (ERR) codes, defined in FpcErrorCodes.h.

Symbolic name | Code | Message ID | Message text
S_FPCLOG_BAD_COLUMN_SELECTION | FPC_WRN(0x200) | 0xC0040200 | For SQL (ODBC) logging, the date field must be selected..
S_FPC_ALERTSRV_ALERT_NOT_FOUND | FPC_WRN(0x201) | 0xC0040201 | The specified alert was not found.
S_FPC_SERVICE_INACCESSIBLE | FPC_WRN(0x202) | 0xC0040202 | The service is inaccessible.
E_FPC_CERTIFICATE_NOT_INSTALLED | FPC_ERR(0x300) | 0xC0040300 | The specified certificate cannot be located.
E_FPC_CROSS_PRIORITY_BOUNDARY | FPC_ERR(0x301) | 0xC0040301 | A Web application filter can be moved only into the positions of filters that have the same priority.
E_FPC_DEST_NOT_IP | FPC_ERR(0x302) | 0xC0040302 | This destination object is not defined using an IP address.
E_FPC_NO_STORAGE | FPC_ERR(0x303) | 0xC0040303 | The object does not have persistent storage. Save the parent object first.
E_FPC_OBJECT_INVALID | FPC_ERR(0x304) | 0xC0040304 | The object is not valid.
E_FPC_STRING_BAD | FPC_ERR(0x305) | 0xC0040305 | The string is empty or invalid.
E_FPC_EVENT_NOT_DEFINED | FPC_ERR(0x306) | 0xC0040306 | The GUID of the alert cannot be found in the Events collection.
E_FPC_NON_REMOVAL_EVENT | FPC_ERR(0x307) | 0xC0040307 | ISA Server predefined events cannot be removed.
E_FPC_ALERT_KEY_INVALID | FPC_ERR(0x308) | 0xC0040308 | The additional key is out of range.
E_FPC_CANNOT_DEL_DEFAULT_RULE | FPC_ERR(0x309) | 0xC0040309 | The default rule cannot be removed.
E_FPC_CANNOT_MOVE_DEFAULT_RULE | FPC_ERR(0x30A) | 0xC004030A | The order of execution for the default rule cannot be modified. It will always be executed last.
E_FPC_CORRUPTED_OBJECT_DATA | FPC_ERR(0x30B) | 0xC004030B | The object's data is corrupted.
E_DOMAIN_CANT_BE_IP_ADDR | FPC_ERR(0x30C) | 0xC004030C | An IP address cannot be used for a domain name.
E_FPC_QUERY_BUFFER_FULL | FPC_ERR(0x30D) | 0xC004030D | There are too many records in the query result.
E_FPC_THRESHOLD_OUT_OF_RANGE | FPC_ERR(0x30E) | 0xC004030E | The threshold range should be between 1 and 65535.
E_FPC_OLD_DAILYSUMMARY_VERSION | FPC_ERR(0x30F) | 0xC004030F | The Dailysum.exe file is corrupted, or was generated with a previous version of the product. It cannot be used to generate the report.
E_FPC_INVALID_SERVER_NAME | FPC_ERR(0x310) | 0xC0040310 | The server name has not been specified or is invalid. Enter a valid server name.
E_FPC_STRING_CONTAINS_INVALID_CHARACTERS | FPC_ERR(0x311) | 0xC0040311 | The server name contains invalid characters. Enter a valid server name.
E_FPC_EMPTY_STRING | FPC_ERR(0x312) | 0xC0040312 | The string is empty or invalid.
E_FPC_VALUE_TOO_LARGE | FPC_ERR(0x313) | 0xC0040313 | The value is larger than the maximum allowed value.
E_FPC_VALUE_TOO_SMALL | FPC_ERR(0x314) | 0xC0040314 | The value is smaller than the minimum allowed value.
E_FPC_COMPONENT_NOT_INSTALLED | FPC_ERR(0x315) | 0xC0040315 | The ISA Server component is not installed.
E_FPC_BAD_IP_FORMAT | FPC_ERR(0x316) | 0xC0040316 | You must provide a valid IP address.
E_FPC_IP_FROM_MORE_THAN_TO | FPC_ERR(0x317) | 0xC0040317 | The value of Ip_From must be lower than the value of Ip_To.
E_FPC_IP_PAIR_ALREADY_EXISTS | FPC_ERR(0x318) | 0xC0040318 | This IP range already exists in the list.
E_FPC_ALERT_MUST_HAVE_ACTIONS | FPC_ERR(0x319) | 0xC0040319 | The alert %1 must have at least one action enabled.
E_FPC_DEFAULT_RULE_IS_READ_ONLY | FPC_ERR(0x31A) | 0xC004031A | This property cannot be modified for the default rule.
E_FPC_PROTOCOL_IS_READ_ONLY | FPC_ERR(0x31B) | 0xC004031B | The protocol cannot be removed or modified.
E_FPC_ALERT_ALREADY_DEFINED | FPC_ERR(0x31C) | 0xC004031C | An alert with this event, server name, and additional key already exists.
E_FPC_FAILED_TO_READ_DISK_SIZE_AND_TYPE | FPC_ERR(0x31D) | 0xC004031D | The disk size and type properties cannot be read.
E_FPC_EVENT_IN USE | FPC_ERR(0x31E) | 0xC004031E | Event definition %1 cannot be removed because it is used by alert %2.
E_FPC_PNAT_PROTOCOL_NOT_INBOUND | FPC_ERR(0x31F) | 0xC004031F | The protocol specified is not a server (inbound) protocol.
E_FPC_ITEM_IN_USE | FPC_ERR(0x320) | 0xC0040320 | The %1 named "%2" cannot be deleted because it is used in the %3: %4.
E_FPC_LOW_RANGE_MORE_THAN_HIGH_RANGE | FPC_ERR(0x321) | 0xC0040321 | The lower port value must be less than or equal to the higher port value in the %1: %2.
E_FPC_PORT_OUT_OF_RANGE | FPC_ERR(0x322) | 0xC0040322 | The port range should be between 1 and 65535.
E_FPC_IDENTICAL_STORAGE_NAME | FPC_ERR(0x323) | 0xC0040323 | An item with an identical storage name already exists in this collection. Each item added to the collection must have a unique storage name.
E_FPC_NOT_COMMON_NETWORK_DIALUP_CONNECTION | FPC_ERR(0x324) | 0xC0040324 | The specified network dial-up connection cannot be found on the computer.
E_FPC_NOT_FULL_URL | FPC_ERR(0x325) | 0xC0040325 | The URL should start with http://.
E_FPC_NO_CREDENTIALS | FPC_ERR(0x326) | 0xC0040326 | You must specified credentials.
E_FPC_NO_DIALUP_AVAILABLE | FPC_ERR(0x327) | 0xC0040327 | Automatic dial-up cannot be used. There are no dial-up entries configured.
E_FPC_INVALID_NETWORK_CHOSEN_FOR_AUTODIAL | FPC_ERR(0x328) | 0xC0040328 | Automatic dial-up cannot be enabled for this type of network.
E_FPC_NOT_SUPPORTED_IN_STANDARD_EDITION | FPC_ERR(0x329) | 0xC0040329 | The method or property is not available in ISA Server Standard Edition.
E_FPC_BAD_LDT_DOMAIN_NAME_FORMAT | FPC_ERR(0x32A) | 0xC004032A | The string is not a valid local domain table (LDT) domain name.
E_FPC_TCP_UDP_MISMATCH | FPC_ERR(0x32B) | 0xC004032B | Invalid API was used for the specified protocol.
E_FPC_HTTP_CACHE_MIN_MUST_BE_LESS_THAN_MAX | FPC_ERR(0x32C) | 0xC004032C | The minimum time for content expiration in cache rule %1 must be less than or equal to the maximum time.
E_FPC_NEED_SERVER_FOR_CREDENTIALS | FPC_ERR(0x32D) | 0xC004032D | Credentials cannot be added when there is no server available.
E_FPC_INVALID_PORT | FPC_ERR(0x32E) | 0xC004032E | You must provide a port number between 1 and 65535.
E_FPC_INVALID_PORT_INC_0 | FPC_ERR(0x32F) | 0xC004032F | You must provide a port number between 0 and 65535.
E_FPC_INVALID_PERIODICAL_RUN_ARGUMENTS | FPC_ERR(0x330) | 0xC0040330 | The cycle time is longer than the specified interval.
E_FPC_INVALID_ICMP_CODE | FPC_ERR(0x331) | 0xC0040331 | You must provide a code number between 0 and 255.
E_FPC_INVALID_ICMP_TYPE | FPC_ERR(0x332) | 0xC0040332 | You must provide a type number between 0 and 255.
E_FPC_INVALID_PROTOCOL | FPC_ERR(0x333) | 0xC0040333 | You must provide a protocol number between 0 and 255.
E_FPC_PREDEFINED_ITEM_IS_READ_ONLY | FPC_ERR(0x334) | 0xC0040334 | This property cannot be modified for the predefined item.
E_FPC_CAN_NOT_DELETE_PREDEFINED | FPC_ERR(0x335) | 0xC0040335 | The item cannot be deleted. It is part of the static configuration.
E_FPC_IP_RANGE_SET_NOT_ALLOWED | FPC_ERR(0x336) | 0xC0040336 | This network type cannot have an IP Range Set.
E_FPC_XML_PASSWORD_REQUIRED | FPC_ERR(0x337) | 0xC0040337 | EncryptionPassword containing at least 8 characters must be specified when the fpcPersistencePasswords flag is set.
E_FPC_XML_MISMATCH_IMPORT_OBJECT | FPC_ERR(0x338) | 0xC0040338 | The object %1 cannot be imported into %2.
E_FPC_XML_SCHEMA_VALIDATION_FAILED | FPC_ERR(0x339) | 0xC0040339 | Schema validation failed on the exported XML document. For more details see the ParseError property.
E_FPC_XML_NO_SERVER_AVAILABLE_FOR_EXPORT_PASSWORD | FPC_ERR(0x33A) | 0xC004033A | There is no available ISA Server to decrypt the exported password. Verify that services are running on at least one ISA Server computer.
E_FPC_XML_IMPORTED_OBJECT_NOT_PERSISTENET | FPC_ERR(0x33B) | 0xC004033B | The object cannot be imported with the specified import options. Verify that the specified import options match the object being imported.
E_FPC_XML_IMPORT_CANNOT_USE_CLEAN_COLLECTIONS | FPC_ERR(0x33C) | 0xC004033C | Only Array object can be imported with the Clean Collections option.
E_FPC_XML_MISMATCH_IMPORT_EDITION | FPC_ERR(0x33D) | 0xC004033D | Enterprise Edition settings cannot be imported into Standard Edition.
E_FPC_XML_MISMATCH_BUILD | FPC_ERR(0x33E) | 0xC004033E | An XML DOM document object cannot be imported from an old build.
E_FPC_XML_WITH_PASSWORDS_REQUIRED | FPC_ERR(0x33F) | 0xC004033F | An XML DOM document object that was exported without fpcExportImportPasswords cannot be imported with the fpcExportImportPasswords flag set.
E_FPC_XML_WITH_SECURITY_DESCRIPTOR_REQUIRED | FPC_ERR(0x340) | 0xC0040340 | An XML DOM document object that was exported without fpcExportImportUserPermissions cannot be imported with the fpcExportImportUserPermissions flag set.
E_FPC_XML_WITH_SERVER_SPECIFIC_INFO_REQUIRED | FPC_ERR(0x341) | 0xC0040341 | An XML DOM document object that was exported without fpcExportImportServerSpecific cannot be imported with the fpcExportImportServerSpecific flag set.
E_FPC_XML_INVALID_OPTIONAL_DATA_VALUE | FPC_ERR(0x342) | 0xC0040342 | Optional data value must be a bitmask of FpcExportImportOptionalData values.
E_FPC_XML_WRONG_PASSWORD | FPC_ERR(0x343) | 0xC0040343 | The password you provided for the XML import is incorrect. Verify this password against the password provided during the export.
E_FPC_NO_VPN_CONNECTION_FOR_THE_NETWORK | FPC_ERR(0x344) | 0xC0040344 | The VPN properties cannot be configured for non-VPN networks.
E_FPC_CAN_NOT_CHANGE_CONNECTION_TYPE | FPC_ERR(0x345) | 0xC0040345 | The connection type cannot be set for this network.
E_FPC_IP_RANGE_ENTRY_INTERSECT_WITH_LOCAL_NETWORK | FPC_ERR(0x346) | 0xC0040346 | The %1 network includes IP addresses in the range %2-%3. Networks cannot contain IP addresses that overlap with another network.
E_FPC_IP_RANGE_ENTRY_INTERSECT_WITH_LIMITED_BROADCAST | FPC_ERR(0x347) | 0xC0040347 | The specified address range contains the limited broadcast IP address (255.255.255.255). Change the IP range so that it does not contain 255.255.255.255.
E_FPC_IP_RANGE_ENTRY_INTERSECT_WITH_LOCAL_VPN_CONFIG | FPC_ERR(0x348) | 0xC0040348 | The VPN configuration static address pool includes IP addresses the range %1-%2. Networks cannot contain IP addresses that overlap with the VPN configuration static address pool.
E_FPC_INVALID_NETWORK_CONNECTION_TYPE | FPC_ERR(0x349) | 0xC0040349 | The connection type is not valid for this network type.
E_FPC_VPN_STATIC_ADDRESS_POOL_RAN_OUT_OF_ADDRESSES | FPC_ERR(0x34A) | 0xC004034A | There are not enough IP addresses available for VPN connections. The static address pool size must be at least one value larger than the maximum number of connections allowed in the VPN configuration.
E_FPC_PREDEFINED_NETWORK_IS_READ_ONLY | FPC_ERR(0x34B) | 0xC004034B | This property cannot be modified for a predefined network.
E_FPC_STORAGE_VER_MISMATCH | FPC_ERR(0x34C) | 0xC004034C | The ISA Server storage version is incompatible.
E_FPC_BAD_ADMIN_VERSION | FPC_ERR(0x34D) | 0xC004034D | The version of the MMC management console in the remote ISA Server computer is incompatible. Upgrade either the local computer, or the remote ISA Server computer.
E_FPC_ALERTSRV_UNKNOWN_EVENT | FPC_ERR(0x34E) | 0xC004034E | The event signaled cannot be found.
E_FPC_ALERTSRV_BAD_EVENT_GUID | FPC_ERR(0x34F) | 0xC004034F | The event GUID is not a valid GUID.
E_FPC_ALERTSRV_DUPLICATED_ALERT | FPC_ERR(0x350) | 0xC0040350 | An alert with the same event condition, server name, and additional key is already defined.
E_FPC_PROTOCOL_NOT_OUTBOUND | FPC_ERR(0x351) | 0xC0040351 | The specified protocol is a server (inbound) protocol. Inbound protocols can only be used in server publishing rules.
E_FPC_VIP_IS_NOT_IN_RELATED_NETWORK | FPC_ERR(0x352) | 0xC0040352 | The specified Virtual IP address (VIP) "%1" is not part of the related network "%2".
E_FPC_NLB_NIC_IDNETIFIER_IS_NOT_UNIQUE | FPC_ERR(0x353) | 0xC0040353 | The specified network adapter "%1" in the Network Load Balancing configuration of network "%2", is already used for Network Load Balancing of network "%3" on this server.
E_FPC_NO_ACCESS_PROPERTIES_FOR_THE_RULE | FPC_ERR(0x354) | 0xC0040354 | Access rule properties can only be configured for access rules, and not for other rules such as Web publishing and server publishing rules.
E_FPC_NO_SERVER_PBLISHING_PROPERTIES_FOR_THE_RULE | FPC_ERR(0x355) | 0xC0040355 | Server publishing properties can only be configured for server publishing rules.
E_FPC_NO_WEB_PBLISHING_PROPERTIES_FOR_THE_RULE | FPC_ERR(0x356) | 0xC0040356 | Web publishing properties can only be configured for Web publishing rules.
E_FPC_BAD_ITEM_NAME | FPC_ERR(0x357) | 0xC0040357 | The %1 referenced by %2 %3 does not exist.
E_FPC_AUTHENTICATION_SCHEME_FORWARD_ONLY | FPC_ERR(0x358) | 0xC0040358 | The authentication method selected cannot be used to authenticate Web publishing requests. Only outgoing Web requests can be authenticated using this method.
E_FPC_AUTHENTICATION_SCHEME_REVERSE_ONLY | FPC_ERR(0x359) | 0xC0040359 | The authentication method selected cannot be used to authenticate outgoing web requests. Only Web Publishing rules can use this authentication method.
E_FPC_AUTHENTICATION_DOESNT_PROVIDE_NAMESPACE | FPC_ERR(0x35A) | 0xC004035A | The selected user namespace is not supported by an authentication method.
E_FPC_AUTHENTICATION_SCHEME_EXCLUSIVE | FPC_ERR(0x35B) | 0xC004035B | %1 authentication cannot be used together with any other authentication method.
E_FPC_SECONDARY_CONNECTIONS_ARE_NOT_APPLICABLE | FPC_ERR(0x35C) | 0xC004035C | The specified protocol contains references to application filters. The secondary connections are not applicable
E_FPC_INVALID_DIRECTORY | FPC_ERR(0x35D) | 0xC004035D | The directory is invalid.
E_FPC_INVALID_DATE | FPC_ERR(0x35E) | 0xC004035E | The date is invalid.
E_FPC_INVALID_DAYS_OF_WEEK | FPC_ERR(0x35F) | 0xC004035F | At least one day should be specified.
E_FPC_INVALID_DAY_OF_MONTH | FPC_ERR(0x360) | 0xC0040360 | The day of the month should between 1 to 31.
E_FPC_ADD_LINK_WITHOUT_PUBLISHING | FPC_ERR(0x361) | 0xC0040361 | To add a link to a report, publishing must be enabled for the report.To add a link to a report, publishing must be enabled for the report.
E_FPC_INVALID_EMAIL_CONFIGURATION | FPC_ERR(0x362) | 0xC0040362 | To send an e-mail, specify a valid SMTP server name, From address, and TO address (or CC address).
E_FPC_INVALID_PUBLISHING_CONFIGURATION | FPC_ERR(0x363) | 0xC0040363 | When publishing a report you must specify a valid publishing folder.
E_FPC_INVALID_CATEGORIES | FPC_ERR(0x364) | 0xC0040364 | The report must include one or more valid report categories.
E_FPC_VPN_STATIC_ADDRESS_POOL_INVALID_RANGE | FPC_ERR(0x365) | 0xC0040365 | IP address ranges in the static address pool must be between 1.0.0.0 and 223.255.255.255.
E_FPC_VPN_STATIC_ADDRESS_POOL_RANGE_TOO_SMALL | FPC_ERR(0x366) | 0xC0040366 | The address range is not valid. An address range must contain at least two IP addresses.
E_FPC_VPN_MAXIMUM_CONNECTION | FPC_ERR(0x367) | 0xC0040367 | The value specified for the maximum number of connections must be between %1 and %2.
E_FPC_VPN_INVALID_IP | FPC_ERR(0x368) | 0xC0040368 | An IP address must be either 0.0.0.0 or belong in the range of 1.0.0.0 to 223.255.255.255.
E_FPC_VPN_INVALID_VALUE_IPS | FPC_ERR(0x369) | 0xC0040369 | You must specify the primary server IP address or choose the option of using the DHCP server.
E_FPC_INVALID_SAVEASHTML_CALL | FPC_ERR(0x36A) | 0xC004036A | Only reports that have been generated successfully can be saved in HTML format.
E_FPC_SERVER_PUBLISHING_HAS_NO_NETWORKS | FPC_ERR(0x36B) | 0xC004036B | At least one network or network set must be specified for the server publishing rule %1.
E_FPC_VPN_NETWORK_LISTENER_LIST_EMPTY | FPC_ERR(0x36C) | 0xC004036C | At least one network must be selected for VPN client access.
E_FPC_VPN_PROTOCOL_NOT_CHOSEN | FPC_ERR(0x36D) | 0xC004036D | At least one protocol must be selected for VPN remote client access.
E_FPC_NO_FULL_ADMINISTRATORS_LEFT | FPC_ERR(0x36E) | 0xC004036E | ISA Server cannot delete the specified user. Your ISA Server configuration must include at least one user who is delegated the role of Full ISA Server Administrator.
E_FPC_PROTOCOL_RAW_CAN_NOT_HAVE_AN_APPLICATION_FILTER | FPC_ERR(0x36F) | 0xC004036F | A protocol definition that has a raw or ICMP protocol cannot have an application filter associated.
E_FPC_PROTOCOL_ONLY_ONE_RAW_CONNECTION_ALLOWED | FPC_ERR(0x370) | 0xC0040370 | A protocol definition can have only one raw connection.
E_FPC_NO_LOCALHOST_IN_NETWORK_RULE | FPC_ERR(0x371) | 0xC0040371 | The Local Host network cannot be included in a network rule.
E_FPC_WEB_PUB_RULE_MUST_HAVE_SPECIFIC_PUBLIC_NAMES | FPC_ERR(0x372) | 0xC0040372 | The Web publishing rule %1 can apply only to public names which do not include asterisk (*). When link translation is enabled, the public name cannot include wildcard characters, and must be specific.
E_FPC_PROTOCOL_MUST_HAVE_PRIMARY_CONNECTION | FPC_ERR(0x373) | 0xC0040373 | The protocol definition must include at least one primary connection.
E_FPC_PROTOCOL_ONLY_SAME_DIRECTION_CONNECTION_ALLOWED | FPC_ERR(0x374) | 0xC0040374 | Primary connections for the protocol definition must be configured for either outbound or inbound traffic, but not both.
E_FPC_REPORT_RUN_REQUIRES_SCHEDULER_RUNNING | FPC_ERR(0x375) | 0xC0040375 | The Job Scheduler service must be running in order to create a report.
E_FPC_WEB_PUBLISHING_RULE_NO_LISTENER | FPC_ERR(0x376) | 0xC0040376 | No Web listener is specified for the Web publishing rule: %1.
E_FPC_VPN_IPSEC_PRESHARED_SECRET_NOT_SUPPORTED | FPC_ERR(0x377) | 0xC0040377 | The use of a pre-shared IPSec key is not supported on this version of Windows.
E_FPC_RADIUS_QUARANTINE_NOT_SUPPORTED | FPC_ERR(0x378) | 0xC0040378 | VPN quarantine based on RADIUS policies is not supported on this version of Windows.
E_FPC_BACKUP_ROUTE_MISSING_SERVER_NAME | FPC_ERR(0x379) | 0xC0040379 | A server name must be specified in the backup route in chaining rule %1.
E_FPC_PRIMARY_ROUTE_MISSING_SERVER_NAME | FPC_ERR(0x37A) | 0xC004037A | A server name must be specified in the primary route in chaining rule %1.
E_FPC_WEB_BROWSER_CUSTOM_SCRIPT_MISSING | FPC_ERR(0x37B) | 0xC004037B | A custom script URL for the client browser configuration settings must be specified for network %1.
E_FPC_DIALUP_MISSING_USER_NAME | FPC_ERR(0x37C) | 0xC004037C | No user name was specified for the automatic dial-up configuration.
E_FPC_VPN_IPSEC_NETWORK_NOT_SUPPORTED | FPC_ERR(0x37D) | 0xC004037D | Retrieval of the IPSec VPN network settings is not supported for a non-IPSec network connection type.
E_FPC_VPN_L2TPPPTP_NETWORK_NOT_SUPPORTED | FPC_ERR(0x37E) | 0xC004037E | Retrieval of the L2TP/PPTP VPN network settings is not supported for a non-VPN network connection type.
E_FPC_VPN_INVALID_PRESHARED_SECRET | FPC_ERR(0x37F) | 0xC004037F | A non-empty string must be specified for the preshared secret.
E_FPC_VPN_IPSEC_NETWORK_REMOTE_SERVER_INVALID | FPC_ERR(0x380) | 0xC0040380 | The name specified for the remote server is not a valid IP address.
E_FPC_VPN_IPSEC_NETWORK_LOCAL_SERVER_INVALID | FPC_ERR(0x381) | 0xC0040381 | The name specified for the local server is not a valid IP address.
E_FPC_ITEM_IN_USE_NOT_IN_COLLECTION | FPC_ERR(0x382) | 0xC0040382 | The %1 named "%2" cannot be deleted because it is used in %3.
E_FPC_ISASCHED_DOWN | FPC_ERR(0x383) | 0xC0040383 | The job cannot be started because the Microsoft ISA Server Job Scheduler service is not running. Check the status of the service.
E_FPC_VPN_S2S_AUTHENTICATION_METHOD_EMPTY | FPC_ERR(0x384) | 0xC0040384 | At least one authentication method must be selected for site-to-site VPN access.
E_FPC_WEB_PUB_RULE_NO_PUBLIC_NAMES | FPC_ERR(0x385) | 0xC0040385 | No public domain name or site name is specified for Web publishing rule 1%.
E_FPC_VPN_NET_INVALID_CERTIFICATE_AUTHORITY | FPC_ERR(0x386) | 0xC0040386 | The certificate authority name must be between %1 and %2 characters.
E_FPC_VPN_NET_INVALID_PRESHARED_KEY | FPC_ERR(0x387) | 0xC0040387 | The pre-shared key must be between %1 and %2 characters.
E_FPC_SERVER_NOT_JOINED_TO_DOMAIN | FPC_ERR(0x388) | 0xC0040388 | The server is not joined to domain.
E_FPC_DENY_SRV_PUB_NOT_ALLOWED | FPC_ERR(0x389) | 0xC0040389 | Server publishing rules cannot be configured as "deny" rules. By design, server publishing rules allow access to specified servers for which access is denied by default.
E_FPC_VPN_NET_CONFLICTING_AUTH_PROTOCOLS | FPC_ERR(0x38A) | 0xC004038A | For VPN site-to-site authentication, you can specify EAP authentication, or any combination of the alternative authentication methods (PAP, SPAP, CHAP, MS-CHAP, MS-CHAP v2). EAP cannot be used in conjunction with any other authentication method.
E_FPC_ISASTG_SERVICE_UNAVAILABLE | FPC_ERR(0x38B) | 0xC004038B | The Microsoft ISA Server Storage service is unavailable.
E_NO_SITE_OR_DOMIAN_DEFINED | FPC_ERR(0x38C) | 0xC004038C | The URL specified does not contain a domain or site name. If you want to specify a folder, the folder prefix ("/"), should come after the domain name.
E_PORT_NUMBER_IN_WEB_SITE_NAME | FPC_ERR(0x38D) | 0xC004038D | The Web server name cannot contain a port number. You can specify the port number to be used for redirecting requests to this Web server on the Bridging tab of the Web publishing rule properties.
E_DISCONNECT_CONTAINING_ARRAY | FPC_ERR(0x38E) | 0xC004038E | You cannot disconnect the server from the containing array.
E_FPC_MSDE_NOT_INSTALLED | FPC_ERR(0x38F) | 0xC004038F | The MSDE feature is currently not installed. To install MSDE, in the Add/Remove Programs applet, select Microsoft ISA Server 2004 and click Change. Then, in the Microsoft ISA Server 2004 Installation Wizard use the Modify option to add MSDE to the installation.
E_FPC_LISTENER_WITH_SAME_IP_AND_PORT_IN_USE | FPC_ERR(0x390) | 0xC0040390 | A Web listener configured to listen on the same IP address and port is already being used by rule "%1".
E_FPC_2_LISTENERS_WITH_SAME_IP_AND_PORT_IN_USE | FPC_ERR(0x391) | 0xC0040391 | The Web listeners used in rule "%1" and in rule "%2" specify identical IP addresses and ports. Web listener IP addresses and ports used by different rules cannot overlap.
E_FPC_INVALID_PUBLISHING_CREDENTIALS_CONFIGURATION | FPC_ERR(0x392) | 0xC0040392 | The user account does not have the required permissions to publish the report.
E_FPC_UPLOAD_NEW_CONFIGURATION | FPC_ERR(0x393) | 0xC0040393 | Some configuration changes were not applied. See the Windows event viewer for more details.
E_FPC_INVALID_LOG_DIRECTORY_AND_TYPE | FPC_ERR(0x394) | 0xC0040394 | You cannot specify an empty string when specifying a log folder as part of a full path option.
E_FPC_PROTOCOL_NOT_SERVER_PROTOCOL | FPC_ERR(0x395) | 0xC0040395 | The specified protocol is not an inbound protocol (server) and cannot be used in server publishing rule %1.
E_FPC_SSL_MUST_HAVE_CERTIFICATE | FPC_ERR(0x396) | 0xC0040396 | When SSL is enabled and an SSL port specified, you must specify a certificate for SSL authentication.
E_FPC_CORRUPTED_ITEM_OBJECT_ATTRIBUTE | FPC_ERR(0x397) | 0xC0040397 | Attribute %1 of object type %2 is corrupted. You should delete the object owner %3 of type %4, fix the corrupted attribute, or import a valid configuration.
E_FPC_CORRUPTED_OBJECT_ATTRIBUTE | FPC_ERR(0x398) | 0xC0040398 | Attribute %1 of object type %2 is corrupted. You should delete the object, fix the corrupted attribute, or import a valid configuration.
E_FPC_XML_VERSION_MISMATCH | FPC_ERR(0x399) | 0xC0040399 | The XML file cannot be imported to this version of ISA Server. Install the latest version of ISA Server, including hot fixes and patches, and then try importing the XML file again.
E_FPC_CANNOT_IMPORT_SYSTEM_POLICY_RULE | FPC_ERR(0x39A) | 0xC004039A | System policy rules cannot be imported individually.
E_FPC_CANNOT_EXPORT_SYSTEM_POLICY_RULE | FPC_ERR(0x39B) | 0xC004039B | System policy rules cannot be exported individually.


MprAdminConnectionRemoveQuarantine (3 Parameters) function [ISA Server 2004]

MprAdminConnectionRemoveQuarantine

The MprAdminConnectionRemoveQuarantine function removes quarantine filters on a dialed-in RAS client if the filters were applied as a result of Internet Authentication Service (IAS) policies.

DWORD MprAdminConnectionRemoveQuarantine(
  HANDLE hRasServer,
  HANDLE hRasConnection,
  BOOL fIsIpAddress
);

Parameters

hRasServer
[in] Handle to the RAS server that services the connection. Obtain this handle by calling MprAdminServerConnect.
hRasConnection
[in] Handle to connection for the RAS client for which to remove the quarantine filters. Obtain this handle by calling MprAdminConnectionEnum.

Alternatively, this parameter specifies the IP address of the RAS client for which to remove the quarantine filter. The IP address should be specified as a DWORD in network byte order. Obtain the IP address by calling MprAdminConnectionEnum. If this parameter specifies an IP address, the fIsIpAddress parameter should specify a TRUE value.

fIsIpAddress
[in] Boolean value that indicates whether the hRasConnection parameter specifies the IP address of the client for which to remove the quarantine filters. If this parameter is a TRUE value, hRasConnection specifies an IP address. Otherwise, hRasConnection specifies a handle to a connection.

Return Values

NO_ERROR
The function succeeded.
ERROR_INVALID_PARAMETER
The handle to the RAS server or the handle to the RAS connection is invalid.
Other
An error from MprError.h, RasError.h, or WinError.h.

Remarks

The MprAdminConnectionRemoveQuarantine function is used by a custom listener component that you create. This component listens for messages from a notifier component running on quarantine-compatible remote access clients. These messages indicate that the clients have successfully run the scripts which validate that they conform to the requirements of your organization's network policies. When the listener component receives this message from the notifier component running on a client, it calls MprAdminConnectionRemoveQuarantine to remove the quarantine restrictions from the remote access connection. ISA Server then chains the call to Routing and Remote Access.

A listener component that calls MprAdminConnectionRemoveQuarantine must be running as under a system administrator account.

Requirements

Server: Requires Windows Server 2003.
Version: Requires Internet Security and Acceleration Server 2004.
Library: Included as a resource in Vpnplgin.dll.

See Also

Administration Reference


Application Filter Documentation [ISA Server 2004]

Application Filter Documentation

This section of the documentation describes how to extend the Microsoft Firewall service through the creation of application filters.

This section contains the following topics:

  • About Application Filters
  • Developing Application Filters
  • Application Filter Reference


About Application Filters [ISA Server 2004]

About Application Filters

Application filters are extensions of the Microsoft Firewall service. These filters register for and process Firewall service events. By exposing COM interfaces to developers, Internet Security and Acceleration (ISA) Server 2004 allows you to extend its security and functionality. You can use these interfaces to extend the security and access control for the Firewall service, and to create protocol-specific application filters. These filters can share the architecture, access control, and administration of the Firewall service.

This section contains the following topics:

  • About the Firewall
  • Introducing Application Filters


About the Firewall [ISA Server 2004]

About the Firewall

The ISA Server 2004 consists of the Microsoft Firewall service, application filters, the ISA Server Web proxy, and Web filters.

The ISA Server 2004 firewall provides secure network address translation (SecureNAT) to enable NAT clients to connect through ISA Server.

This section includes the following topics:

  • Intrusions and Alerts
  • Secure Network Address Translation

The Web proxy includes the ISA Server cache, discussed in About the ISA Server Cache.


Intrusions and Alerts [ISA Server 2004]

Intrusions and Alerts

ISA Server features an intrusion-detection mechanism, identifying when an attack is attempted against your network, and performing a set of configured actions in case of an attack.

To detect unwanted intruders, ISA Server compares network traffic and log entries to well-known attack methods. Suspicious activities trigger alerts, which are a set of actions that can be configured. Actions include connection termination, service termination, e-mail alerts, and logging.

ISA Server monitors for the following types of attacks:

  • All-port scan attack
  • Enumerated-port scan attack
  • IP-half scan attack
  • Land attack
  • Ping-of-death attack
  • UDP bomb attack
  • Windows out-of-band attack

For more information, see the ISA Server 2004 product documentation.


Secure Network Address Translation [ISA Server 2004]

Secure Network Address Translation

Secure network address translation (SecureNAT) is an extension of the Microsoft® Windows® Server 2003 and Windows 2000 network address translation (NAT) driver.

NAT substitutes a global IP address, valid on the Internet, for an internal IP address. This substitution allows multiple hosts with private IP addresses to share a single external (public) IP address, yet remain protected by the Microsoft Firewall service.

The ISA Server SecureNAT feature provides a degree of address transparency for networked clients. NAT is based on an Internet Engineering Task Force (IETF) standard. ISA Server enhances the underlying NAT functionality of Windows Server 2003 and Windows 2000 by enabling access control for FTP, ICMP, H.323, and PPTP. NAT also enables rerouting HTTP requests, which can then frequently be satisfied by a local cache, as is the case for CERN proxy.

SecureNAT provides Internet connectivity for multiple computers that share a single modem and Internet service provider account. SecureNAT lets multiple hosts connect through a single gateway computer to the public Internet. The SecureNAT feature allows a single dial-up or other connection to the public network to serve the entire network, which then allows access to both the Internet and corporate networks for telecommuting and other purposes. Every host on the private network shares one or more global addresses.

If network settings are configured so that the default gateway is the IP address of an ISA Server computer, NAT substitutes the globally valid source IP address for the private IP address of a client that originates an outgoing request. NAT substitutes the source address of the ISA Server computer in the data packet, because responses must return to the global ISA Server host IP address.

Although transparency in SecureNAT eliminates the need for settings, other than the default gateway settings, SecureNAT does not work for all protocols. SecureNAT does not work for certain gaming protocols or for new protocols, for which no protocol editors exist.

SecureNAT can be used with the Microsoft Firewall service in the case of applications with Windows Sockets (Winsock) capabilities. There is no need to perform manual configuration of this functionality, because configuration occurs automatically. Because SecureNAT works with the Firewall service, application filters can work as NAT editors, and NAT clients can be managed by the administrator as Firewall service clients. This means that ISA Server rules and policies can apply to NAT clients.

SecureNAT Considerations

Although SecureNAT provides transparency without special client configuration or installation of software on the client, and provides automatic setting of default gateways, NAT has the following limitations:

  • Only IP-based (not user-based) policies can be implemented, because the identity of users is not passed to the ISA Server computer. This limits policies to those based on the IP address of the client.
  • NAT works only for those protocols explicitly supported by NAT and may not be used with the majority of protocols that embed IP addresses within packets.

Note to Developers

With SecureNAT, ISA Server extends the underlying NAT functionality of Windows Server 2003 and Windows 2000 to the level of the firewall, and thus, to the user mode. An application filter that enables secondary connections for a NAT client takes the place of a NAT editor. Enabling secondary connections for NAT clients through SecureNAT is simplified, and you have access to user-mode debugging tools for the development process.

You can develop an application filter that enables secondary connections for a NAT client and adds functionality that is equally efficient for Firewall clients and NAT clients. Alternatively, you can develop an application filter to specifically address the secondary connection needs of NAT clients, enabling them to work with other application filters, such as those that perform content filtering.

If you create an application that uses a proprietary protocol, you can create an application filter that enables SecureNAT clients to use that application.

Because SecureNAT functions in user mode and is an integral part of ISA Server, ISA Server policy can be applied to NAT clients. With SecureNAT, you can control access to FTP, Streaming Media protocols, and Windows NetMeeting® for H.323. The ISA Server SecureNAT feature also permits you to reroute HTTP requests, which can then frequently be fulfilled by a local cache. This enhancement boosts HTTP performance and lowers bandwidth requirements.


Introducing Application Filters [ISA Server 2004]

Introducing Application Filters

ISA Server 2004 handles data transfer on two levels. On the lower level, the kernel-mode packet engine can block or allow traffic based on previously defined rules. It can also pass packets to the higher level, which is the user-mode Microsoft Firewall service, for rule-engine decision making and deeper data inspection. ISA Server application filters are implemented as in-proc COM server DLLs that run in user mode, in the process space of the Firewall service.

Application filters work with the Firewall service to intercept and process data. Application filters can access the data stream or datagrams associated with a session within the Firewall service by hooking on the Firewall service connections. The filters are registered with the Firewall service and act according to events detected by the service. An application filter can perform protocol-specific or system-specific tasks, such as authentication and checking for viruses.

This section contains the following topics, which are best read in sequence:

  1. Filter Types
  2. Firewall Events
  3. Connection Emulation
  4. Asynchronous Input/Output
  5. Filter Requirements for SecureNAT Clients
  6. Filter Requirements for Firewall Clients
  7. Setting Filter Priorities
  8. Application Filter Objects
  9. Filter Object Model
  10. Filter Alert Events
  11. Using Network Configuration Detection


Filter Types [ISA Server 2004]

Filter Types

You can develop a wide range of application filters by using the ISA Server Software Development Kit (SDK). Examples of filter types are:

  • Protocol-enabling filters. These application filters enable the usage of complicated protocols that require more than a single TCP connection to traverse the Microsoft Firewall service. These filters dynamically configure the Firewall service computer to allow future secondary connections, and edit secure network address translation (SecureNAT) addresses. The FTP access filter and the H.323 filter, which are provided with ISA Server, are examples of protocol-enabling filters. The FTP access filter handles all aspects of configuring the ISA Server computer to automatically allow an FTP secondary data channel.
  • Protocol-scanning filters. These filters scan data from specific protocols for items such as an intrusion or virus. Examples of protocol-scanning filters are the POP intrusion detection filter and the DNS intrusion detection filter that are based on technology from Internet Security Systems (ISS), and are provided with ISA Server.
  • Redirection filters. A redirection filter may cause specific connections to be redirected into its control. The filter can then act as a server.
  • NAT-supporting filters. Many protocols pass IP addresses of internal servers as part of their data. In a network address translation (NAT) environment, these internal IP addresses are hidden, and need to be translated to externally visible addresses. An application filter can monitor the traffic and modify the relevant fields within a message to include the correct external addresses according to existing publishing rules, or according to some other criteria. Using the FTP access filter, an FTP client behind the ISA Server computer may direct an FTP server to connect to it, passing its address and port information as part of the protocol. The FTP access filter translates this information to an externally visible listening socket, enabling the file transfer to take place without disclosing the internal address.
  • Intrusion-detection filters. Application filters can examine traffic going through the ISA Server computer and look for known attack signatures. Firewall service provides two such filters, which detect known intrusion signatures for DNS and POP3.
  • Content-filtering filters. Application filters can parse high-level application protocols, look for actual data (the payload), and apply rules and processing based on the content. Examples include applying protocol-level syntax validation, antivirus scanning on file transfers, SOAP or XML filtering, and content categorization. The Firewall service HTTP and SMTP filters demonstrate this capability. In these scenarios, the overall structure of the application filter is the same. It typically attaches itself to each connection, and implements the specifications and RFCs relevant to the protocols it represents to handle the traffic and apply rules to it. The filter should keep a session state and use it to control the data transfer through the ISA Server computer. It may modify the data flow, change the session payload, stop sessions that seem to violate the policy, or call ISA Server APIs to automatically configure allow/deny rules for expected future traffic. Content filtering for HTTP traffic is accomplished by developing an ISAPI filter, called a Web filter in the context of ISA Server and the Firewall service.
  • Other filters. The ISA Server architecture allows you to create a wide range of other filters.


Firewall Events [ISA Server 2004]

Firewall Events

Firewall events are events that the Microsoft Firewall service triggers in response to occurrences of specific types. The types of firewall events are defined in the FwxFirewallEventType enumerated type. An application filter has to be registered for specific events. When the Firewall service raises an event for which an application filter is registered, the filter is attached to the related session. The filter can then monitor the session for events where a filter response, such as data filtering, might be needed.

In general, the events are generated both in the case of Firewall clients and SecureNAT clients.


Connection Emulation [ISA Server 2004]

Connection Emulation

You can design a filter that intercepts a client request to connect to the Internet, and instead provide the information from another source. In this case, you are emulating an outside connection, and the client is unaware that the data is coming from a source other than the requested external one. An HTTP filter that provides a Web object from a cache is emulating a connection.

An inbound connection can also be emulated. For example, a filter can emulate a connection on a single well-known port, so that a number of client machines can effectively use the connection simultaneously.


Asynchronous Input/Output [ISA Server 2004]

Asynchronous Input/Output

ISA Server uses asynchronous input/output (I/O) to manage multiple I/O requests simultaneously. This results in more efficient use of resources because the Microsoft Firewall service can continue I/O while waiting for particular data.

Asynchronous I/O operation follows these steps:

  1. The data buffer object is created by the Firewall service.
  2. Data is received asynchronously.
  3. The data transfer is completed.
  4. The Firewall service receives the completion notification through the completion port, and passes it to the completion object.
  5. The completion method information is received by a Completion Notification object.

For this process to take place, the application filter follows these steps:

  1. Calls an asynchronous method to issue an overlapped request.
  2. Waits for the request to be handled asynchronously and completed.
  3. Receives notification through a completion notification interface.

    Note This process differs for Windows overlapped operations. For more information, see IFWXExternalIOCompletion.

The following objects are directly related to the ISA Server implementation of asynchronous I/O:

  • Buffer objects that implement the IFWXIOBuffer interface.
  • Overlapped objects that implement the IFWXOverlapped interface.
  • Completion notification objects that implement the IFWXAcceptCompletion, IFWXIOCompletion, or IFWXExternalIOCompletion interface.


Filter Requirements for SecureNAT Clients [ISA Server 2004]

Filter Requirements for SecureNAT Clients

Application filters can work with Firewall clients and SecureNAT clients. This section describes specific design considerations for filters that must work with SecureNAT clients. For information about designing filters to work with Firewall clients, see Filter Requirements for Firewall Clients.

To handle SecureNAT client connect requests for outbound primary connections, an application filter must register for events originating from a SecureNAT client. Use the fwxSourceNAT value of the FwxFirewallEventSource enumerated type when registering for SecureNAT client events. To handle both Firewall client and SecureNAT client requests, use the FWX_ALL_SOURCES macro.

If a filter will handle inbound connections to SecureNAT clients, including primary connections, a specific protocol must be registered. Use the IFWXFilterAdmin::RegisterProtocol method to register the protocol.

Inbound primary connections can be directed to a SecureNAT client by using the IFWXFirewall::CreatePrivateSession or IFWXFirewall::GetClientSession method. Use IFWXFirewall::CreatePrivateSession when the inbound connection was requested by an application, the SecureNAT client is not known by the Microsoft Firewall service, and no session object has been created. Use IFWXFirewall::GetClientSession only if the filter can assert that the client is configured to be a SecureNAT client of that server.

Use the IFWXSession::BindForClient method to permit SecureNAT clients to receive secondary inbound connections. Data filters that call IFWXSession::BindForClient and then edit addresses passed on a connection should use the fwx_dfpc_NAT value of the FwxDataFilterPriorityClass enumerated type. This places the filter as close to the client as possible, that is, it is the first data filter to receive data from the client. This is important because you want to ensure that the first filter to handle the SecureNAT data is one that is capable of doing so. For more information, see Setting Filter Priorities.

Note In a publishing scenario, mapping internal SecureNAT addresses for your publishing server to external IP addresses is done by using ISA Server Management or the FPCServerPublishingProperties object.


Filter Requirements for Firewall Clients [ISA Server 2004]

Filter Requirements for Firewall Clients

Application filters can work with both Firewall clients and SecureNAT clients. This section describes specific design considerations for filters that must work with Firewall clients. For information about designing filters to work with SecureNAT clients, see Filter Requirements for SecureNAT Clients.

To handle Firewall client connect requests for outgoing primary connections, the filter must register for events originating from a Firewall client. Use the fwxSourceWSP value of the FwxFirewallEventSource enumerated type to register for Firewall client events. A filter designed to handle both Firewall client and SecureNAT client requests should use the macro FWX_ALL_SOURCES to include both values.

To allow a Firewall client to receive a secondary inbound connection, use IFWXSession::RetroactiveAllowBind. Use this method because the client application may have already bound a socket on the Microsoft Firewall service, and the filter should use that socket. IFWXSession::RetroactiveAllowBind enables the previously created bind by associating it with a protocol, and also tests whether the client application bound a Firewall service socket. If the client application did not bind a Firewall service socket, IFWXSession::RetroactiveAllowBind will fail. Therefore, the filter should also call IFWXSession::BindForClient. IFWXSession::BindForClient lets a client application — for which the Firewall client component failed to create a remote socket for a bind call — receive an inbound connection.


Setting Filter Priorities [ISA Server 2004]

Setting Filter Priorities

Typically, more than one data filter will be registered for the same event. The order in which data filters react to events can affect the results.

The priority coded into the data filter determines the order in which filters access data. The possible priority settings are defined in the FwxDataFilterPriorityClass enumerated type. Each priority setting is defined as being closer to the client or closer to the server. A data filter that is closer to the client is likely to be the first to examine data flowing from the client, but least likely to be the first to examine data flowing to the client. A data filter that is closer to the server is likely to be the first to examine data flowing from the server to the client, and unlikely to be the first to examine data flowing from the client to the server.

Data filter priority is important because the first data filter in a chain of data filters can affect the data received by subsequent filters.

When two or more data filters share the same priority, the order in which they address the data is arbitrary.


Application Filter Objects [ISA Server 2004]

Application Filter Objects

Before developing application filters, it is useful to understand the basic objects related to filter function. These are:

  • Filter objects
  • Session objects
  • Session filter objects
  • Connection objects
  • Socket objects
  • Data filter objects
  • Buffer objects
  • Completion notification objects

    Note The ISA Server application filter objects use a free-threaded threading model.


Filter Objects [ISA Server 2004]

Filter Objects

A filter object is a COM object that implements the IFWXFilter interface. Each application filter must include a filter object. The names of filter objects typically include the word Filter. When the Microsoft Firewall service starts, it creates an instance of the filter object for each application filter that is installed on the ISA Server computer and enabled. The Firewall service uses the implementation of the IFWXFilter interface on each filter object to initialize the application filter, to create session filter objects, and to initiate the shutdown procedure that destroys the filter object when the Firewall service is stopped. The initialization process can also include the creation and initialization of other COM objects that are used in the application filter.


Session Objects [ISA Server 2004]

Session Objects

A session is a group of connections that are related because they are associated with a particular client. For Firewall clients, a session is created for each control channel. For SecureNAT clients, a session is created for each client IP address.

The Microsoft Firewall service creates a session object, which implements the IFWXSession interface, for each session. The session object can be used for querying information about the user that made the connection (including the user's permissions), for modifying the permissions of future connections, and for performing network operations on behalf of the application. The session object provides specific functionality through the IFWXSession interface, including the following:

  • Retrieving the name or address of the user's computer.
  • Allowing inbound connections for an existing bind.
  • Creating a bind on behalf of a client.
  • Impersonating the user's account.
  • Querying the Firewall service about a user's access rights.
  • Creating a user-specific socket for a client.


Session Filter Objects [ISA Server 2004]

Session Filter Objects

A session filter object is a COM object that implements the IFWXSessionFilter interface. The names of filter objects typically include the word combination SessionFilter. A session filter object is created and attached to the applicable session when the Microsoft Firewall service detects a network event for which an application filter is registered. Only one instance of a session filter object is created for a session. By being attached to the session, a session filter object can be notified about the Firewall service network events for which it is registered and react to them. The events for which a session filter object can register are specified by values from the FwxFirewallEventType enumerated type. For example, a session filter object can handle the events by creating a data filter object for each connection in the session.


Connection Objects [ISA Server 2004]

Connection Objects

Connection objects provide a means for the Microsoft Firewall service to perform services for a client socket. For those specific services, such as setting up a remote socket for a client socket, the connection object represents the client socket to the Firewall service. When a Firewall client uses bind, connect, or sendto Winsock functions, and the client DLL identifies a remote destination, the Firewall service creates a connection object that resides on the server.

Similarly, a connection object will be generated for a secure network address translation (SecureNAT) client. In the case of the SecureNAT client, the Firewall service first receives the request from the client, identifies it as originating from a SecureNAT client, and then creates the connection object and proceeds.

Connection objects are also created when BindForClient is called. In this case, an application filter, rather than the Firewall service, identifies that the client called bind.

Connection objects implement the IFWXConnection interface.


Socket Objects [ISA Server 2004]

Socket Objects

A socket is an endpoint of communication—an object through which your application communicates with other Windows Sockets (Winsock) applications across a network. There are sockets on the client and server sides.

The steps used on the client side for communication through sockets are:

  1. Open. The networking application creates a socket for a specific protocol.
  2. Bind. The socket is assigned a name (address). In TCP/IP, the application assigns a port, and may also assign an IP address if the computer is multihomed.
  3. Connect. A connection is established with the server socket, so that send and receive operations can take place. You can connect a socket for which there has been no bind, and the bind will take place as part of the connect. An explicit bind is needed only if a specific port and IP address are needed for the connection.

The steps used on the server side for communication through sockets are:

  1. Open. Create the socket.
  2. Bind. The bind is usually performed on a well-known port.
  3. Listen. Be prepared to accept connections. The listen operation takes place on the kernel level.
  4. Accept. Accept the connection and open a new socket for it. This socket is passed to the application so that it can communicate with the client. The listening socket continues to listen for additional connect requests, so that other accept functions can take place.

For more information about sockets, see MSDN. For details about using sockets with this product, see Socket Implementation in ISA Server.


Socket Implementation in ISA Server [ISA Server 2004]

Socket Implementation in ISA Server

Each data filter works with two objects that implement a socket interface. One represents the internal socket and the other represents the external socket, and the filter pumps data between them.

ISA Server has two interfaces through which you can manage socket activity:

  • IFWXSocket
  • IFWXNetworkSocket

IFWXSocket is the interface for a socket that was opened by the Microsoft Firewall service. Its methods allow you to send and receive on the socket, or to close the socket. This limited functionality is intentional. A data filter that uses two IFWXSocket interfaces to send and receive data does not know whether it is communicating with the Internet, the client, or another data filter in a chain of data filters.

Because IFWXSocket is for use only with existing connections, it does not provide methods that are equivalent to functions such as bind or connect.

IFWXNetworkSocket is an extension of the IFWXSocket interface. IFWXNetworkSocket represents a true socket object for either the client or server. It allows you to establish a connection, and then use the IFWXSocket functionality to perform send and receive operations. Therefore, in addition to the Send, Recv, and Close methods of IFWXSocket, IFWXNetworkSocket provides methods such as Bind, Connect, and Listen.

A socket object that implements the IFWXNetworkSocket interface can be created by calling IFWXFirewall::CreateNetworkSocket, IFWXSession::CreateNetworkSocket, or IFWXFirewall2::CreateSSLNetworkSocket. In the first two cases, the socket object created by calling CreateNetworkSocket has full socket functionality for operations such as interacting with the dynamic packet filtering mechanism or working with chained ISA Server computers.

A socket object created by calling IFWXFirewall::CreateNetworkSocket is not user-specific. An example of a socket that should not be user-specific is a listening socket.

To create a user-specific socket, use IFWXSession::CreateNetworkSocket. The socket object created by IFWXSession::CreateNetworkSocket has the same functionality as that created by IFWXFirewall::CreateNetworkSocket, but because it is user-specific, its activities can be logged, and the ISA Server policies apply to it. The use of this kind of socket is appropriate when a filter will be making a connection for a specific user.

A socket object created by calling IFWXFirewall2::CreateSSLNetworkSocket represents an SSL socket for secured communication. A socket object created by this method can interact with the dynamic packet filtering mechanism, but it does not implement the Accept, Connect, and SendTo methods.

Warning

There are three reasons to create Windows Sockets (Winsock) for ISA Server through the CreateNetworkSocket method only:

  • The application filters and the Firewall service should use the same thread pool, and thus the same completion port.
  • With IFWXNetworkSocket, the filter becomes part of the dynamic packet filtering scheme. A socket created by using Firewall service interfaces (a socket object that implements the IFWXSocket interface) cannot open a port for dynamic packet filtering.
  • Proxy chaining is supported only by IFWXNetworkSocket.


Data Filter Objects [ISA Server 2004]

Data Filter Objects

A data filter object is a COM object that implements the IFWXDataFilter interface. The names of filter objects typically include the word combination DataFilter. In response to a Microsoft Firewall service network event, a session filter object may create a data filter object for a specific connection. A data filter object is provided with an internal and external socket, and can perform alternate or two-way data pumping between the two sockets for the connection. A data filter object can allow secondary connections.


Buffer Objects [ISA Server 2004]

Buffer Objects

ISA Server handles data in data buffers. Each data buffer is represented by a buffer object. By using pointers to the buffer object, various components, such as a series of filters, can use the same data without the need to copy data. Avoiding copying data improves performance.

A buffer's size is defined in two ways:

  • Allocated size
  • Actual size

The allocated size is the buffer's capacity in bytes and does not reflect data actually stored in the buffer. When a buffer is created and filled by a filter, it begins with a defined allocated size. The actual size is the number of bytes of data the buffer currently holds.

A filter can perform the following buffer management activities:

  • Read into a buffer directly from a memory pointer by using the IFWXIOBuffer::Append method.
  • Read a buffer by using the IFWXIOBuffer::GetBufferAndSize method.
  • Read a portion of a buffer by using the IFWXIOBuffer::ReadAt method.
  • Send data from a buffer to another buffer by using the IFWXIOBuffer::SendToBuffer method.
  • Manipulate the memory directly by using the IFWXIOBuffer::GetBufferAndSize method. This operation can only be performed by the buffer owner (the filter that created the buffer).
  • Reset the buffer size by using the IFWXIOBuffer::SetDataSize method.

Buffer objects implement the IFWXIOBuffer interface. Using the IFWXIOBuffer interface, information about the buffer can be retrieved, and the buffer can be modified.


Completion Notification Objects [ISA Server 2004]

Completion Notification Objects

Completion notification objects work with completion port objects, also known as I/O completion port objects, to allow the operating system to handle multiple threads efficiently for asynchronous I/O. The Microsoft Firewall service completion port is a completion port requested by the Firewall service from Windows Server 2003 or Windows 2000 that remains associated with the service. The completion port is associated with a number of client connections. All I/O operations should make use of the Firewall service completion port so that I/O operations take place efficiently.

To use a completion port, you must provide an I/O completion notification object that will receive notification when the I/O operation is completed. Hook the handle to the Firewall service completion port by using the IFWXFirewall::HookToCompletionPort method. The Firewall service provides the overlapped object, completion port de-queuing, and the thread pool. To receive notification that the I/O is completed, use the IFWXOverlapped::SetNotificationInterface method.

When an asynchronous I/O operation has been completed on a particular connection, the Firewall service notifies the completion port by using one of these completion notification methods:

  • IFWXIOCompletion::CompleteAsyncIO
  • IFWXAcceptCompletion::CompleteAsyncAccept
  • IFWXExternalIOCompletion::CompleteAsyncIO

Each of these methods includes a Boolean succeed/fail parameter, a Windows error code parameter, and a user-data parameter that provides user-context information. However, the method used by the Firewall service to send the notification depends on the type of I/O operation that has been completed.

IFWXIOCompletion::CompleteAsyncIO is the general method for receiving notification from the Firewall service when an asynchronous I/O operation is completed. When a data buffer has been completed through an asynchronous I/O operation, the notification is sent to IFWXIOCompletion::CompleteAsyncIO.

IFWXAcceptCompletion::CompleteAsyncAcceptis the method for receiving notifications from the Firewall service when an IFWXNetworkSocket:Accept is completed on a listening socket.


IFWXExternalIOCompletion::CompleteAsyncIO [ISA Server 2004]

IFWXExternalIOCompletion::CompleteAsyncIO

IFWXExternalIOCompletion::CompleteAsyncIO is the I/O completion notification used with asynchronous I/O for operating system files. If the Microsoft Firewall service has a handle for an operating system file, and needs to read the file or write to it, this operation will be asynchronous, so that it can take place in the background. An example of an asynchronous I/O operation for operating system files is writing to or reading from a disk.

There are four sequential steps to this process:

  1. The Firewall service calls IFWXFirewall::HookToCompletionPort, which connects the file handle to the service completion port. This step takes place once per connection.
  2. The Firewall service calls IFWXFirewall::CreateOverlapped to create the overlapped object, which implements the IFWXOverlapped interface.
  3. The Firewall service uses IFWXOverlapped::GetOverlapped to get a pointer to the Winsock OVERLAPPED structure, and IFWXOverlapped::SetNotificationInterface to send notification when the I/O operation is completed.
  4. IFWXExternalIOCompletion::CompleteAsyncIO receives the notification, including a succeed or fail message, information regarding the user, and the number of bytes transferred.

The following figure summarizes the process of asynchronous I/O for operating system files.


Filter Object Model [ISA Server 2004]

Filter Object Model

When the Microsoft Firewall service starts, it exposes the IFWXFirewall interface, which provides access to Firewall service functions.

An application filter must include a COM object that implements the IFWXFilter interface. This object is called the filter object. When the Firewall service starts, it creates an instance of the filter object for each application filter that is installed on the ISA Server computer and enabled. The Firewall service initializes each application filter by calling the application filter's implementation of the FilterInit method on the IFWXFilter interface. The initialization process can include the creation and initialization of other COM objects that are used in the application filter.

The initial operation of an application filter is invoked by an event. The events for which the filter object representing an application filter will be registered are specified in an FwxFilterHookEvents structure, which can be created and populated during creation of the filter object. The contents of this FwxFilterHookEvents structure are returned to the Firewall service by the call to the FilterInit method.

When a client computer first connects to the ISA Server computer, the Firewall service creates a session object with the standard IFWXSession interface for it. If the Firewall service detects an event for which the application filter is registered when a new user session is opened, it calls the application filter's implementation of the IFWXFilter::AttachToSession method to inform the application filter that the event has occurred. During this call, the application filter creates an instance of an object that implements the IFWXSessionFilter interface. Such an object is called a session filter object.

The session filter object refers to the session object, represented by the IFWXSession interface, for client and user information.

After the Firewall service has called filter's implementation of the IFWXFilter::AttachToSession method, the Firewall service notifies the filter about the events specified in the output of this method by calling the IFWXSessionFilter::FirewallEventHandler method.

When the session filter object is notified by the Firewall service that an event for which the filter is registered has occurred, its FirewallEventHandler method can create an instance of a data filter object, which implements the IFWXDataFilter interface. Alternatively, a data filter object can be created by using IFWXSession::SetDataFilterFactory. The session filter object attaches the data filter object to the connection object related to the specific event.

The connection object provides the data filter with internal and external sockets by calling IFWXDataFilter::SetSockets. Each socket object implements the IFWXSocket interface. The data filter then performs the data pumping and filtering for the specific connection.

Application filters follow an active data-pumping programming model, where an application filter that registers itself on a connection takes full ownership of the connection and actively pipes the data through from one side to the other. This model is similar to I/O completion ports, where a filter dispatches I/O requests and receives notifications upon completion of the I/O operation. Although the application filter SDK hides the details of the worker-thread implementation, it is important to be aware of how this works and to realize that I/O completions for the same connection can be called in the context of different threads.

Application filters can be chained so that the same protocol is handled by more than one filter. This is achieved by using the virtual socket concept through the IFWXSocket interface. When an application filter pumps data through a socket interface, it can be a virtual socket that is actually connected to the next filter, or it can be a real network socket that actually writes and reads data from the network.

Data is received as buffers. To avoid the need to copy buffers, each buffer is created as an object that implements the IFWXIOBuffer interface. Because data is received asynchronously, the data filter must implement IFWXIOCompletion, which is necessary for asynchronous (I/O) on the sockets. When an asynchronous I/O operation is completed, the Firewall service uses IFWXIOCompletion::CompleteAsyncIO to notify the data filter that the buffer is available to it.

The data filter can then perform its filtering function on the data buffer.

Filter registration procedures are described in Filter Setup.


Filter Alert Events [ISA Server 2004]

Filter Alert Events

When you create an application filter, you may want it to register an event for which the Microsoft Firewall service can issue an alert to the ISA Server administrator. For example, you may want to make it possible for the administrator to be notified when your filter encounters a low-memory situation on the ISA Server computer.

The steps that you need to include in the code of your filter are as follows:

  1. Register an event in ISA Server.

    The filter must define an event, which it will signal whenever it encounters a specific situation.

    The event should be registered during registration of the filter with the Firewall service because you want the administrator to be able to define alerts for this event. When the filter is unregistered, it should remove this event definition.

  2. Create an alert that will be issued for the event.

    The filter can create an alert for the event during the filter registration process using ISA Server administration COM interfaces, or the administrator can create an alert for the event, as described in the ISA Server 2004 product documentation.

  3. Call the IFPCEventDefinition::Signal method to signal the event when the specific situation is encountered.

The Data Monitor filter sample provided with the ISA Server 2004 SDK creates both an event and an alert that is issued for the event during the registration process.

Note Uninstalling a filter should remove the events that were defined during filter installation, and any related alerts.


Using Network Configuration Detection [ISA Server 2004]

Using Network Configuration Detection

The ISA Server 2004 network configuration detection (NCD) mechanism allows application filters to react to network configuration changes without restarting a service. It specifically applies to changes related to Plug and Play network devices. The ISA Server 2004 NCD mechanism issues notifications of network configuration changes, and application filters can register to receive those notifications. This mechanism also maintains a consistent view of network information in a single location.

Network Configuration Detection Mechanism

When the NCD mechanism is initialized, it constructs an initial view of the relevant network configuration information. A view of the network configuration at a single point in time is referred to as a snapshot. When changes occur in the network configuration, the NCD mechanism undergoes a synchronization, at which time a new snapshot is created.

NCD clients such as application filters register with the NCD mechanism and provide a sink interface for NCD notifications. NCD sends notifications of any changes in the network configuration to all its clients. Each client handles the notifications that it is interested in.

Note When a client registers, the NCD mechanism sends a series of notifications that creates a picture of the current network configuration, in a logical order.

Network Configuration Detection Interfaces

The NCD interfaces provided in the SDK file Wspfwext.idl are:

  • IFWXNetConfigDetector, which can be retrieved using the IFWXFirewall2::GetNetConfigDetector method. This interface includes methods for registering and unregistering for NCD notifications. During registration, the client receives a handle specific to that registration operation.
  • IFWXNetworkAddress, which represents an IP address. Each IP address is associated with an ISA Server network represented by an IFWXNetworkElement interface.
  • IFWXNetworkAdapter, which represents a network adapter.
  • IFWXNetworkElement, which represents a network defined in the stored ISA Server administration COM configuration. Each network can be part of a network set represented by an IFWXNetworkSet interface.
  • IFWXNetworkSet, which represents a network set.
  • IFWXNetConfigDetectionNotification, which is the notification interface that should be implemented by each NCD client.
  • IFWXNetConfigDetectionSnapshot, which represents a snapshot of the complete network configuration.

Network Configuration Detection Configuration Events

The FwxNcdEvent structure defines types of NCD network configuration events, such as the addition or removal of a network adapter.

NCD Approaches

There are two ways to use the NCD mechanism:

  • Response to incremental notifications.
  • Response to a synchronization notification using a snapshot of the network configuration.

Use the incremental approach when the NCD client has to perform an action as a response to a single notification, and this action is not dependent on future notifications. To use the incremental approach, use the GetContext and SetContext methods of the applicable network configuration interface (such as IFWXNetworkAddress) to get and set the information and act appropriately when receiving a notification.

Use the synchronization approach when the NCD client has to examine a complete and consistent picture of the network configuration to perform an action. When you receive an incremental notification that you are interested in, set a flag. When you receive a synchronization notification (fwx_ncd_SyncConfig) indicating that an updated snapshot is available, examine your flags and examine the snapshot (IFWXNetConfigDetectionSnapshot), to determine how to act.


Developing Application Filters [ISA Server 2004]

Developing Application Filters

This section describes the basic steps required to create, deploy, and test an application filter. This section is intended for developers who are familiar with Microsoft® Visual C++® and COM. For performance reasons, application filter interfaces are not automation interfaces, and filter objects are best implemented as free-threaded objects. Therefore, Visual Basic®, Java, and scripting languages are not suitable for creating application filters.

Because application filters work with the Microsoft Firewall service, and the Firewall service works with Windows Sockets (Winsock), knowledge of Winsock is also helpful. For information about Winsock, see MSDN.

To become familiar with the filter development process, the following approach is recommended:

  1. For a description of ISA Server 2004 architecture, read About Internet Security and Acceleration Server 2004.
  2. For information about the basics of filter functionality, read About Application Filters.
  3. Examine the logic and interface usage of the sample filters provided with ISA Server.
  4. Develop a simple filter. For details about interface methods and parameters, see Application Filter Reference.

This section contains the following topics:

  • Filter Development
  • Filter Setup
  • Application Filter Test Environment


Filter Development [ISA Server 2004]

Filter Development

This section describes the tools provided by ISA Server to develop application filters and the application filter development process. This section contains the following topics:

  • Development Environment
  • Header and Interface Definition Language Files
  • Filter Development Process
  • Best Practices
  • Implementing a Filter Object
  • Implementing a Session Filter Object

For information about the interfaces used to create application filters, see Application Filter Reference.


Development Environment [ISA Server 2004]

Development Environment

The recommended environment for developing application filters for ISA Server 2004 is Visual C++ .Net. All the samples provided on the ISA Server 2004 CD are ready to be compiled in Visual C++ .Net. Application filters can also be written and compiled in a Visual C++ 6.0 development environment. However, to use Visual C++ 6.0, you must install Visual C++ 6.0 Service Pack 5 and the Platform Software Development Kit (Platform SDK).

The Platform SDK contains newer include files and binary files, including the Microsoft Interface Definition Language (MIDL) Compiler version 5.03.0280, which is needed by Visual C++ 6.0 to correctly compile application filters for ISA Server 2004. The Platform SDK can be downloaded by anyone free of charge from the Platform SDK Update website. The Platform SDK consists of several components, of which you need to download and install only the core SDK.

After you compile your application filter, you must install it on an ISA Server computer before running it. An application filter can include self-registration code, or separate scripts can be created to install it. For more information about installing your application filter on an ISA Server computer, see Filter Setup.


Header and Interface Definition Language Files [ISA Server 2004]

Header and Interface Definition Language Files

The ISA Server 2004 SDK provides you with the header (.h) and interface definition language (.idl) files needed to create an application filter. These files are located in the Inc folder under the SDK folder on the ISA Server 2004 CD. You need to include the appropriate SDK files in your project.

The SDK header and interface definition language files that can be used in application filters include:

  • Comenum.h
  • FpcErrorCodes.h
  • FpcEventGuids.h
  • FpcEventKeys.h
  • Fpcimports.h
  • Fpcimports.idl
  • FpcNodesGuids.h
  • Msfpccom.idl
  • Protocol_guids.h
  • Wpxhttpfilt.h
  • Wspfwerr.h
  • Wspfwext.idl
  • Wspfwtyp.h

Of these, Wspfwext.idl and Msfpccom.idl are of the greatest interest to filter developers.

Comenum.h

Defines the enumerated types used in the ISA Server administration COM objects. This file is included in Fpcimports.idl.

FpcErrorCodes.h

Contains error code definitions for the ISA Server administration COM objects. For more information about these error codes, see Administration Object Error Codes.

FpcEventGuids.h

Defines the globally unique identifiers (GUIDs) of the predefined events that are installed with ISA Server.

FpcEventKeys.h

Defines the additional keys for the subevents of predefined events that are installed with ISA Server.

Fpcimports.h

Allows inclusion of standard system header files in an .idl file. Used to include the header file Comenum.h in Fpcimports.idl. For more information about how to include a standard system header in an .idl file, see Importing System Header Files in the Platform SDK documentation.

Fpcimports.idl

An .idl file that includes the header file Fpcimports.h. For more information about how to include a standard system header in an .idl file, see Importing System Header Files in the Platform SDK documentation.

FpcNodesGuids.h

Contains the GUIDs of the snap-in nodes that can be extended when writing extension snap-ins. For more information, see Extending ISA Server Management.

Msfpccom.idl

Contains the definitions of the ISA Server administration COM objects.

This file generates the Msfpccom.tlb file. To use properties and methods that return enumeration values without explicitly specifying the namespace, specify no-namespace when you import the Msfpccom.tlb file, as follows:

#import "msfpccom.tlb" no_namespace

Protocol_guids.h

Provides a list of protocol GUIDs.

Wpxhttpfilt.h

Contains the definitions of the structures, notifications, and functions used in the development of Web filters.

Wspfwerr.h

Contains error code definitions for the Microsoft Firewall service. For more information about these error codes, see Error Codes.

Wspfwext.idl

Contains the definitions and GUIDs of the filter object interfaces. When you first compile your project, the files Wspfwext.h and Wspfwext_i.c are generated from Wspfwext.idl.

Wspfwtyp.h

Defines Windows and Winsock structures for the Microsoft Interface Definition Language (MIDL) compiler, which compiles the .idl files.


Filter Development Process [ISA Server 2004]

Filter Development Process

The filter development process is described in general terms. In describing this process, use of the Visual Studio® Active Template Library (ATL) is assumed and recommended because it handles routine work for the project.

Application filters typically require these procedures:

  • Create the necessary COM objects. Typically, these are the filter object, session filter object, and data filter object.
  • Monitor events.
  • Attach the filter to a session.
  • Process data.
  • Provide code to register and unregister the filter.
  • Install the filter.

Note Filters must be registered as COM servers and in the ISA Server configuration.


Best Practices [ISA Server 2004]

Best Practices

You can use these best practices to create more efficient application filters.

Registration for Events

  • Register for as small a set of events as possible. This is true for first-phase events registered in IFWXFilter::FilterInit and for events registered in IFWXFilter::AttachToSession. Unnecessary event registrations increase the load on the Microsoft Firewall service and reduce performance. Also, registration for unnecessary events may create a security risk, because your filter will not be designed to handle those events when they occur.
  • In IFWXFilter::AttachToSession, do not define explicit data filters unless monitoring or modification of the stream is required. This allows the Firewall service to do the data pumping in kernel mode, which is more efficient than the user-mode data pumping of data filters.

Buffers and Data

  • Copying data reduces performance, so avoid copying I/O buffer content. Instead, use the methods of the IFWXIOBuffer interface to manage data buffers. To avoid copying buffers, a filter should call IFWXSocket::Recv, specifying NULL as the buffer. This causes the Firewall service to pass to the filter an existing buffer, instead of copying from the existing buffer to the filter's buffer.

BSTR Strings

When working with BSTR strings, the implementing entity should be responsible for allocating and freeing memory. For example, if the Firewall service allocates the memory, it should also free it.

A likely scenario is the case where an application filter needs to use a BSTR held by the Firewall service. The Firewall service should provide a pointer to the BSTR, so that the application filter can allocate memory, copy the BSTR, and be responsible for freeing the memory. This approach reduces the likelihood of memory leaks.

Threading

  • If your filter performs asynchronous I/O on operating system files, use the completion notification mechanism provided by ISA Server. For more information, see Completion Notification Objects.
  • Call the IFWXFirewall::StartHeavyBlockingOperation method before making a blocking operation. When this method is used, the Firewall service keeps track of the number of threads that are busy with blocking operations, and creates new threads when necessary.
  • Do not call IFWXFirewall::StartHeavyBlockingOperation before waiting for a critical section or a resource on which other threads are likely to be blocked. If the newly created thread is blocked on the same critical section, there will be greater congestion on the critical section and more context switches, resulting in an overall reduction in performance.
  • Expect methods to be called from different threads simultaneously. If more than one thread accesses data at the same time, the data can be left in an inconsistent state. You can prevent this by using critical sections, which allow only one thread at a time to access the protected code section. The sample application filters provided with the ISA Server 2004 SDK contain examples of the use of critical sections. For more information about critical sections, see the reference page for the CCriticalSection object in the MSDN Library.
  • Similarly, you can use interlocked functions, which synchronize access to a variable that is shared by multiple threads. Interlocked functions prevent a thread from being preempted when it is in the middle of incrementing or checking a variable. For more information on critical sections, see Interlocked Variable Access in the MSDN Library.
  • In general, when calling a method of an object that may call back the calling object (either on the same thread or by waiting for another thread to perform the callback), a deadlock may arise. Therefore, avoid holding locks while calling methods of Firewall service implemented objects.

    For example, there may be a race between calls to Detach (IFWXDataFilter::Detach or IFWXSessionFilter::Detach) and other methods. Data filters receive IFWXSocket interfaces when the IFWXDataFilter::SetSockets API is called. Because the Firewall service is multithreaded, more than one thread can use the same IFWXSocket interface simultaneously. Furthermore, one thread may call Detach to release an IFWXSocket interface, while the other thread still attempts to access the interface, perhaps while doing a data pump. Access to the interface should be protected by a locking mechanism, such as a critical section. Because of locking by the Firewall service, deadlock situations may arise. For example, the following code can lead to a deadlock situation:

    Lock();
HRESULT hr = spSocket->Close(FALSE);
Unlock();

    To avoid the deadlock, use this code:

    // Copy the member interface pointer to a local "smart" pointer
// while the object is locked.
CComPtr<IFWXSocket> spSocket;
Lock();
spSocket = m_InternalSocket;
Unlock();   // lock released to avoid deadlocks

// Verify that interface was not released by Detach()
if (spSocket != NULL) {
// Here it is safe to send, receive, or close the socket.
HRESULT hr = spSocket->Close(FALSE);
}
  • Avoid creating too many threads in the Firewall service. If you create a thread that waits for an infrequent event, such as a configuration change, use the Windows synchronization function RegisterWaitForSingleObject. If you create a thread to perform periodic tasks that will spend most of its time sleeping, use the Windows function CreateTimerQueueTimer. Each of these functions uses thread pools to reduce the number of threads that are busy at one time.

Security for Secondary and Emulated Connections

There are situations where an application filter limits IP address access, including a:

  • Secondary inbound connection that occurs when using FTP.
  • Secondary or emulated connection in a publishing scenario.

For security purposes, the application filter defines a range of IP addresses for which a particular connection is allowed. Define that range of IP addresses by using the IFWXIpFilter interface.

Note If you set the range of IP addresses equal to NULL, you are allowing all addresses to connect.

Managing Application Filter Resource Usage

When no data filter is present, the Firewall service user-mode data pump controls resource usage by limiting the number of pending sends on a connection in either direction. For a given communication direction, buffers are received as long as there are less than two pending sends. If there are two pending sends, the receive is delayed until a send is completed. This prevents the accumulation of data buffers when the send rate does not match the receive rate.

When an application filter that uses a data filter is added to the data pump, the send-limiting mechanism does not operate. Your application filter should therefore check whether each send is completed, and should establish a limit as to how many sends can accumulate. When the limit has been reached, your filter should stop calling receive until the number of sends drops below the limit. If you do not create this type of resource usage control mechanism, a large download or a deliberate attack could cause buffers to accumulate, using extensive non-paged pool and user-mode memory. This could result in a denial of service.

Pending I/O Operations

During inbound or output emulation, a filter may build up an excessive number of pending I/O operations and overflow the Firewall service. A filter should impose a strict limit on the number of pending I/O operations that it allows.

Handling Data

Application filters should be designed not to allocate excessive amounts of memory per session or request so that they will not become vulnerabale to a denial-of-service (DoS) attack. If filters accumulate data (for example, until there is a complete message), they should set a maximum message size. If this maximum message size is significant, we also recommend that they limit the time during which a message can be stored.

Application filters should never trust data. They should verify that the data is coming from the correct side. For example, they should verify that the client is not sending information that should be coming only from the server. Your filter should also verify that the data has the correct format.

When using hash tables, use salt and other mechanisms to make sure that clients will not be able to craft data that will always be sent to the same bucket.

Filter Setup

If an application filter also provides an extension for ISA Server Management, the setup program should allow for separate installation of the administration component and the filter component because ISA Server Management can be run remotely. In particular, ISA Server Management can be run from a remote computer on which ISA Server 2004 is not installed.

During filter registration, the error code HRESULT_FROM_WIN32(ERROR_ALREADY_EXISTS) should be considered as a success code, and installation should continue in a normal flow. This is done to avoid problems in re-registering an existing filter.

When an application filter is being uninstalled, the filter should try to uninstall all the objects that it registered (events, alerts, etc.), even if some of them no longer exist and an error code is returned. This is done to ensure that maximum cleanup is achieved, and to ensure forward compatibility with future support for array mode.

Writing to the Stored Configuration

Application filters should not attempt to write to the stored ISA Server configuration. Application filters are allowed read-only access to the stored ISA Server configuration on computers running Windows Server 2003. Therefore, an application filter that relies on successfully writing to the stored configuration will fail.

Any changes to the stored configuration that are needed for an application filter should be made by the setup process or through the application filter's administrative component.


Implementing a Filter Object [ISA Server 2004]

Implementing a Filter Object

When the Microsoft Firewall service starts, it creates an instance of the registered filter object for each application filter that is installed and enabled. After the instance of each filter object is created, the Firewall service calls its implementation of the FilterInit method to initialize it, passing a pointer to an IFWXFirewall interface and a pointer to an FwxFilterHookEvents structure to receive the initial set of Firewall service network events for which the filter object will be registered.

The call to the FilterInit method is the entry point to the application filter and should be used to initialize all objects of global scope. It also provides an opportunity for the filter to tell the Firewall service which network events are of interest to it.

In the Data Monitor sample, the filter object's contructor sets the initial set of network events in a private member of type FwxFilterHookEvents. The implementation of the FilterInit method copies the set of network events to the FwxFilterHookEvents structure belonging to the Firewall service. It initializes a member object that signals events and a member object that represents the global policy. It also registers for notification of changes in the global policy and loads the global policy for the first time. This process is shown in the following code.

CDMFilter::CDMFilter()
{
    m_FwxFilterHookEvents.dwGlobalEvents = DWORD(fwx_Connect_Tcp
                                                 | fwx_AcceptedConnection
                                                 | FWX_ALL_SOURCES);
}

STDMETHODIMP CDMFilter::FilterInit(IFWXFirewall *  pIFWXFirewall,
                                   FwxFilterHookEvents * pFilterHookEvents)
{
    DBGTRACEENTRY();
    HRESULT hr;

    // Tell the Firewall service what events we want.
    *pFilterHookEvents = m_FwxFilterHookEvents;

    // Initialize the event signaller.
    CHECK_HR(m_Signaller.Initialize());

    // Initialize the global policy member.
    CComPtr<IFWXFilterAdmin> spFilterAdmin;
    hr = CoCreateInstance(CLSID_FWXFilterAdmin,
                          NULL,
                          CLSCTX_INPROC_SERVER,
                          IID_IFWXFilterAdmin,
                          (void**)&spFilterAdmin);
    if (FAILED(hr))
    {
        return hr;
    }
    CComPtr<IFPCApplicationFilter> spAppFilter;
    hr = spFilterAdmin->GetFilter(CLSID_DMFilter,&spAppFilter);
    if (FAILED(hr))
    {
        return hr;
    }
    hr = m_GlobalPolicy.Initialize(spAppFilter);
    if (FAILED(hr))
    {
        return hr;
    }

    // Register for global policy changes.
    hr = RegisterForConfigurationChanges();
    if (FAILED(hr))
    {
        return hr;
    }

    // Load the global policy for the first time.
    // (Subsequently, we will get the change notifications)
    (void) LoadGlobalPolicy();

     return S_OK;
}

When a client computer first connects to the ISA Server computer and a new user session is created in an event for which the application filter is registered, the Firewall service calls the application filter's implementation of the IFWXFilter::AttachToSession method. It passes a pointer to the session object representing the new user session, to inform the application filter that the event has occurred and that the filter should perform the tasks defined in its implementation of this method.

The implementation of the AttachToSession method in the Data Monitor sample creates an instance of the filter's session filter object. It passes the set of network events and a pointer to the instance of the session filter object created back to the Firewall service. This process is shown in the following code.

STDMETHODIMP CDMFilter::AttachToSession(IFWXSession * piSession,
                                        IFWXSessionFilter ** piSessionFilter,
                                        PFwxFilterHookEvents pFilterHookEvents)
{

    HRESULT hr = S_OK;

    // Create an instance of the session filter object.
    CComObject<CDMSessionFilter> *pSessionFilter;
    hr = CComObject<CDMSessionFilter>::CreateInstance (&pSessionFilter);
    if (FAILED(hr))
    {
        return hr;
    }
    pSessionFilter->AddRef();
    pSessionFilter->Initialize(this);

    // Give back the required events and the session filter object.
    *pFilterHookEvents = m_FwxFilterHookEvents;
    *piSessionFilter = pSessionFilter;

    return S_OK;
}


Implementing a Session Filter Object [ISA Server 2004]

Implementing a Session Filter Object

After the Microsoft Firewall service calls the IFWXFilter::AttachToSession method, which creates an instance of the filter's session filter object, it notifies the filter about events for which it is registered by calling the IFWXSessionFilter::FirewallEventHandler method.

In the Data Filter sample, the implementation of the IFWXSessionFilter::FirewallEventHandler method obtains a pointer to the connection object in accordance with the type of event. It retrieves the per-rule policy, and then calls the CreateDataFilter helper function. This process is shown in the following code.

STDMETHODIMP CDMSessionFilter::FirewallEventHandler(const FwxFirewallEvent *pProxyEvent )
{
    HRESULT hr = S_OK;
    IFWXConnection* pConnection  = NULL;
    CDMPerRulePolicy* pPerRulePolicy = NULL;

    switch (pProxyEvent->EventType)
    {
        case fwx_Connect_Tcp:
        {
            pConnection = pProxyEvent->Parameters.Connect.piConnection;
            pPerRulePolicy = (CDMPerRulePolicy*)pProxyEvent->Parameters.Connect.PerRuleProcessedData;
            break;
        }
        case fwx_AcceptedConnection:
        {
            pConnection = pProxyEvent->Parameters.Accept.piConnectionAccepted;
            pPerRulePolicy = (CDMPerRulePolicy*)pProxyEvent->Parameters.Accept.PerRuleProcessedData;
            break;
        }

        default:                     // An unexpected event type
            ATLASSERT(false);
            return E_FAIL;
    }
    hr = CreateDataFilter(pConnection,pPerRulePolicy);

    return  hr;

}

The following code implements the CreateDataFilter helper function, which creates a data filter object and attaches it to the current connection.

HRESULT CDMSessionFilter::CreateDataFilter(IFWXConnection* pConnection,
                                           CDMPerRulePolicy* pPerRulePolicy)
{
    // Create a data filter for this connection.
    HRESULT hr;
    CComObject<CDMDataFilter>*    pDataFilter;
    CHECK_HR(CComObject<CDMDataFilter>::CreateInstance(&pDataFilter));
    pDataFilter->AddRef();

    // If no per-rule policy was provided, create a default one.
    bool fFreePerRulePolicy = false;
    if (pPerRulePolicy == NULL)
    {
        pPerRulePolicy = new CComObject<CDMPerRulePolicy>;
        if (pPerRulePolicy == NULL)
        {
            return E_OUTOFMEMORY;
        }
        pPerRulePolicy->AddRef();
        fFreePerRulePolicy = true;
    }

    // Initialize and attach to the connection object.
    pDataFilter->Initialize(pConnection,pPerRulePolicy, m_spFilter);
    hr = pConnection->AttachDataFilter(pDataFilter, fwx_dfpc_Middle, NULL);
    if (FAILED(hr))
    {
        DBGTRACEF(("AttachDataFilter failed, error = %08x\n", hr));
    }

    if (fFreePerRulePolicy)
    {
        pPerRulePolicy->Release();
    }

    // The connection now owns the DataFilter ref-count, so we can release
    // it. (or if failed, we still have to release it to avoid leaks)
    pDataFilter->Release();

    return hr;
}


Filter Setup [ISA Server 2004]

Filter Setup

You must install application filters on the ISA Server computer, where they must reside locally. Filters must be registered as COM servers and as extensions of the Microsoft Firewall service in the ISA Server configuration. Each time that the Firewall service starts, it creates an instance of the registered COM object that implements the IFWXFilter interface, known as the filter object, for each application filter that is installed and enabled.

The process of installing and registering an application filter includes the following steps:

  1. Copy the dynamic-link library (DLL) and other necessary files to the ISA Server computer..
  2. Publish the COM objects, the type library, and all interfaces in the type library in the Windows registry. This registration is typically implemented in the DllRegisterServer function. The implementation of this function in your DLL can be called by the Regsvr32 command-line utility (Regsvr.exe), provided your DLL exports the function. This step must be performed even if the filter project is compiled on the ISA Server computer.
  3. Register the filter in the stored ISA Server configuration as an application filter for the Microsoft Firewall service by calling IFWXFilterAdmin::InstallFilter. This call passes the CLSID of the filter object, the name of the filter, a description, the name of the vendor who supplied it, the version number, and an array of GUIDs that specifies the protocols using GUIDs from the Protocol_guids.h file. You should implement this step using the DllInstall function, which must also be exported by your DLL.
  4. Register the primary connection ports and alert events, as necessary.

Customizing the Setup Process

The registration process can include changes to the ISA Server configuration. These changes can be invoked by your implementation of DllInstall using properties and methods of ISA Server administration COM objects. For example, to register a new event that the Firewall service will trigger when opening a log file fails, the implementation of DllInstall in the Data Monitor sample calls a method that performs the following steps:

  1. Use CoCreateInstance to create an instance of the FPC object and obtain a smart pointer to the IFPC interface exposed by it.
  2. Call IFPC::GetContainingArray to retrieve a pointer to the IFPCArray interface representing the array.
  3. Call IFPCArray::RuleElements to retrieve a pointer to the IFPCRuleElements interface representing the Firewall service rule elements container.
  4. Call IFPCRuleElements::EventDefinitions to retrieve a pointer to the IFPCEventDefinitions interface representing the collection of events defined in the array.
  5. Call IFPCEventDefinitions::Add to add the new event to the collection.

To create an alert that can be issued for the new event and configure it to log the signaled occurrences of the event in the system event log, the method called by the implementation of DllInstall in the Data Monitor sample also performs the following steps:

  1. Call IFPCArray::Alerts to retrieve a pointer to the IFPCAlerts interface representing the collection of alerts that are defined in the array.
  2. Call IFPCAlerts::Add to add an alert for the new event to the collection.
  3. Call the IFPCAlert::Actions property of the interface returned in the previous step to retrieve a pointer to the IFPCAlertAction interface for the new alert.
  4. Call the IFPCAlertActions::SetLogEvent method to create a new action for the alert that will log the signaled occurrences of the event in the system event log.

Example of Setup on an ISA Server Computer

To set up an application filter on an ISA Server computer, perform the following steps:

  1. Copy the DLL to the ISA Server computer.
  2. Call DllRegisterServer.
  3. Call DllInstall with the bInstall parameter set to TRUE and the pszCmdLine parameter set to the applicable command-line string.

As an alternative to steps 2 and 3, you can run:

regsvr32 /i:"command_line_string" mydll.dll

Example of Uninstall on an ISA Server Computer

To uninstall an application filter from an ISA Server computer, perform the following steps:

  1. Call DllInstall with the bInstall parameter set to FALSE and the pszCmdLine parameter set to the applicable command-line string.
  2. Call DllUnregisterServer.

As an alternative to these steps, you can run:

regsvr32 /u /i:"command_line_string" mydll.dll

Note Because the filter objects are created when the Firewall service starts, the Firewall service must be stopped and then restarted after setup is complete.

The RegSvr32 utility is not a required part of the setup. A setup utility can use RegSvr32, or load the DLL and call the registration code directly.

Services may not have the necessary permissions to allow them to write vendor-specific information to the directory service. For this reason, you should perform the saving of vendor parameters to ISA Server during filter setup.


Application Filter Test Environment [ISA Server 2004]

Application Filter Test Environment

After you develop an application filter, you will want to test it in a laboratory setting. To do this, configure the lab to represent a network/ISA Server-server/Internet situation:

Lab Configuration

Three computers are required to test application filters. One computer functions as the ISA Server computer. This computer must have two network adapters. Connect one adapter to a computer representing the internal client and the other to a computer representing the Internet.

The specific lab requirements will depend on the type of filter you are testing.


Application Filter Reference [ISA Server 2004]

Application Filter Reference

The application filter reference provides information on the interfaces, enumerated types, and structures you will use in the development of application filters.

This section contains the following topics:

  • Filter Interfaces
  • Structures
  • Filter Enumerated Types


Filter Interfaces [ISA Server 2004]

Filter Interfaces

Filter interfaces expose the COM objects needed to develop application filters. Some of the interfaces are implemented by the Microsoft Firewall service, some by the application filter. For more information, see the reference page for each interface.

This section contains the following filter interfaces:

  • IFWXAcceptCompletion
  • IFWXAuthenticatedUser
  • IFWXAuthenticatedWindowsUser
  • IFWXAuthenticationCompletion
  • IFWXConnection
  • IFWXDataFilter
  • IFWXExternalIOCompletion
  • IFWXFilter
  • IFWXFilterAdmin
  • IFWXFirewall
  • IFWXFirewall2
  • IFWXFirewallAction
  • IFWXGetXByY
  • IFWXImpersonator
  • IFWXIOBuffer
  • IFWXIOCompletion
  • IFWXIpFilter
  • IFWXLowResourceRecoverer
  • IFWXLowResourceRecoveryOperation
  • IFWXNetConfigDetectionSnapshot
  • IFWXNetConfigDetectionNotification
  • IFWXNetConfigDetector
  • IFWXNetworkAdapter
  • IFWXNetworkAdapters
  • IFWXNetworkAddress
  • IFWXNetworkAddresses
  • IFWXNetworkElement
  • IFWXNetworkElements
  • IFWXNetworkSet
  • IFWXNetworkSets
  • IFWXNetworkSocket
  • IFWXOverlapped
  • IFWXPerRuleData
  • IFWXPerRuleDataplugin
  • IFWXPolicyChangeNotification
  • IFWXRadiusAuthenticator
  • IFWXSession
  • IFWXSessionFilter
  • IFWXSlowDataFilter
  • IFWXSocket
  • IFWXTaskCompletion
  • IFWXUdpDestination


IFWXAcceptCompletion interface [ISA Server 2004]

IFWXAcceptCompletion

The IFWXAcceptCompletion interface includes a method for receiving a notification when an asynchronous accept operation is completed in a call to the IFWXNetworkSocket::Accept method.

When To Implement

An application filter that calls IFWXNetworkSocket::Accept must implement this interface to handle newly accepted connections.

Methods in Vtable Order

The IFWXAcceptCompletion interface inherits the methods of the standard COM interface IUnknown.

In addition, IFWXAcceptCompletion defines the following method.

Method | Description
CompleteAsyncAccept | Receives a notification that the work performed in a call to the IFWXNetworkSocket::Accept method is completed.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Wspfwext.idl.

See Also

Filter Interfaces


IFWXAcceptCompletion.CompleteAsyncAccept (9 Parameters) method [ISA Server 2004]

IFWXAcceptCompletion::CompleteAsyncAccept

The CompleteAsyncAccept method receives a notification that the work performed in a call to the IFWXNetworkSocket::Accept method is completed (that a client connected to the listening socket).

HRESULT CompleteAsyncAccept(
  BOOL fSuccess,
  DWORD Win32ErrorCode,
  IFWXNetworkSocket* pListeningSocket,
  IFWXNetworkSocket* pAcceptSocket,
  LPSOCKADDR RemoteAddress,
  DWORD RemoteAddressLength,
  LPSOCKADDR LocalAddress,
  DWORD LocalAddressLength,
  UserContextType UserData
);

Parameters

fSuccess
[in] Success flag. If TRUE, the IFWXNetworkSocket::Accept method succeeded. If FALSE, the method failed.
Win32ErrorCode
[in] Windows error code. This parameter is defined only if the fSuccess parameter is set to FALSE.
pListeningSocket
[in] Pointer to the IFWXNetworkSocket interface on the listening socket.
pAcceptSocket
[in] Pointer to the IFWXNetworkSocket interface on the newly accepted connection.
RemoteAddress
[in] Pointer to a sockaddr structure that contains the remote address of the connection. This is the same information that would be returned by the Windows Sockets (Winsock) getpeername function.
RemoteAddressLength
[in] Size, in bytes, of the buffer pointed to by the RemoteAddress parameter.
LocalAddress
[in] Pointer to a sockaddr structure that contains the local address of the connection. This is the same information that would be returned by the Winsock getsockname function.
LocalAddressLength
[in] Size, in bytes, of the buffer to which the LocalAddress parameter points.
UserData
[in] The UserData parameter that was supplied to the IFWXNetworkSocket::Accept method.

Return Values

Implementations of this method should handle any run-time error and return S_OK.

Remarks

The UserData parameter provides a context to the notification. You can use the same notification interface for receiving completion notifications from different network socket objects and differentiate among them by using different values for UserData.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Wspfwext.idl.

See Also

IFWXAcceptCompletion


IFWXAuthenticatedUser interface [ISA Server 2004]

IFWXAuthenticatedUser

The IFWXAuthenticatedUser interface represents a single authenticated user. This may be a Windows user or a non-Windows user. The IFWXAuthenticatedUser interface inherits from the IFWXImpersonator interface.

The IFWXAuthenticatedUser interface is the product of asynchronous firewall authentication, and is returned by IFWXAuthenticationCompletion::CompleteAsyncAuthentication. For example, if the authentication completion results from a call to the IFWXRadiusAuthenticator::AuthenticateRadiusUser, IFWXAuthenticatedUser will represent a RADIUS authenticated user.

Methods in Vtable Order

The IFWXAuthenticatedUser interface inherits the methods of the standard COM interface IUnknown.

In addition, IFWXAuthenticatedUser defines the following methods, including those inherited from IFWXImpersonator.

Method | Description
Impersonate | Impersonates the Windows user's account. For non-Windows users, this method does not perform any actual impersonation; it returns S_OK.
RevertToSelf | Undoes impersonation for a Windows user. For non-Windows users, this method does not undo impersonation; it returns S_OK.

Properties

The IFWXAuthenticatedUser interface has the following properties.

Property | Description
Namespace | Gets the namespace of the authentication scheme for the user.
UserGroups | Gets a semicolon delimited string detailing the groups to which the user belongs. This information may not always be available, and is specifically unavailable for Windows users.
Username | Gets the name of the authenticated user.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Wspfwext.idl.

See Also

Filter Interfaces


IFWXAuthenticatedUser.NameSpace(BSTR) property [ISA Server 2004]

NameSpace Property of IFWXAuthenticatedUser

The NameSpace property gets the namespace of the authentication scheme for the user.

HRESULT get_NameSpace(
  BSTR* pbstrNameSpace
);

HRESULT put_NameSpace();

Parameters

pbstrNameSpace
[out] Pointer to a BSTR that is set on return to a string value specifying the name of the authentication namespace.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

Memory is allocated by the Microsoft Firewall service, which implements the NameSpace property. The caller should free the memory using SysFreeString. For recommendations on memory allocation for BSTR strings, see Best Practices.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Wspfwext.idl.

See Also

IFWXAuthenticatedUser


IFWXAuthenticatedUser.UserGroups(BSTR) property [ISA Server 2004]

UserGroups Property of IFWXAuthenticatedUser

The UserGroups property gets a semicolon delimited string detailing the groups to which the user belongs.

HRESULT get_UserGroups(
  BSTR* pbstrUserGroups
);

Parameters

pbstrUserGroups
[out] Pointer to a BSTR that is set on return to a string value specifying a semicolon delimited string detailing the groups to which the user belongs.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

Memory is allocated by the Microsoft Firewall service, which implements the UserGroups property. The caller should free the memory using SysFreeString. For recommendations on memory allocation for BSTR strings, see Best Practices.

Note User group information may not always be available, and is specifically unavailable for Windows users. For a Windows user, this method will return E_NOTIMPL.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Wspfwext.idl.

See Also

IFWXAuthenticatedUser


IFWXAuthenticatedUser.Username(BSTR) property [ISA Server 2004]

Username Property of IFWXAuthenticatedUser

The Username property gets the name of the authenticated user.

HRESULT get_Username(
  BSTR* pbstrUsername
);

Parameters

pbstrUsername
[out] Pointer to a BSTR that is set on return to a string value specifying the name of the authenticated user.

Return Values

This property method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

Memory is allocated by the Microsoft Firewall service, which implements the Username property. The caller should free the memory using SysFreeString. For recommendations on memory allocation for BSTR strings, see Best Practices.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Wspfwext.idl.

See Also

IFWXAuthenticatedUser


IFWXAuthenticatedWindowsUser interface [ISA Server 2004]

IFWXAuthenticatedWindowsUser

The IFWXAuthenticatedWindowsUser interface represents a single authenticated Windows user. It inherits from the IFWXAuthenticatedUser interface, and adds token and security identifier (SID) information. IFWXAuthenticatedUser inherits from the IFWXImpersonator interface.

Methods in Vtable Order

The IFWXAuthenticatedWindowsUser interface inherits the methods of the standard COM interface IUnknown.

In addition, IFWXAuthenticatedWindowsUser defines the following methods, including those inherited from IFWXAuthenticatedUser.

Method | Description
Impersonate | Impersonates the user's account.
RevertToSelf | Undoes impersonation.

Properties

The IFWXAuthenticatedWindowsUser interface has the following properties.

Property | Description
Namespace | Gets the namespace of the authentication scheme for the user.
SID | Gets the SID for a Windows user.
Token | Gets the token for a Windows user.
UserGroups | This property is inherited from IFWXAuthenticatedUser but has no meaning for Windows users because all group information is available through the user's Token and SID properties. Accordingly, for Windows users, the property method always returns E_NOTIMPL.
Username | Gets the name of the authenticated user.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Wspfwext.idl.

See Also

Filter Interfaces


IFWXAuthenticatedWindowsUser.SID(DWORD) property [ISA Server 2004]

SID Property of IFWXAuthenticatedWindowsUser

The SID property gets the security identifier (SID) for a Windows user.

HRESULT get_SID(
  DWORD** ppSID
);

Parameters

ppSID
[out] Address of a pointer that on return points to the SID.

Return Values

This property method should return S_OK if the call is successful; otherwise, it should return an error code.

Remarks

Your implementation of IFWXAuthenticatedWindowsUser may return E_NOTIMPL for either the SID or Token property, but not both. It is not a requirement to support both properties, but one of the properties must have a meaningful implementation.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Wspfwext.idl.

See Also

IFWXAuthenticatedWindowsUser


IFWXAuthenticatedWindowsUser.Token(DWORD) property [ISA Server 2004]

Token Property of IFWXAuthenticatedWindowsUser

The Token property gets the token for a Windows user.

HRESULT get_Token(
  DWORD* phToken
);

Parameters

phToken
[out] Pointer to a variable that on return receives a handle to a duplicate token.

Return Values

This property method should return S_OK if the call is successful; otherwise, it should return an error code.

Remarks

The Token property retrieves a handle to a duplicate token. Your implementation of the Token property must call DuplicateToken before the function returns. When you invoke the Token property, you must call CloseHandle on the token that you received.

Your implementation of IFWXAuthenticatedWindowsUser may return E_NOTIMPL for either the SID or Token property, but not both. It is not a requirement to support both properties, but one of the properties must have a meaningful implementation.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Wspfwext.idl.

See Also

IFWXAuthenticatedWindowsUser


IFWXAuthenticationCompletion interface [ISA Server 2004]

IFWXAuthenticationCompletion

The IFWXAuthenticationCompletion interface includes a method for receiving an authentication completion notification and information associated with the authentication process.

When To Implement

An application filter that calls the IFWXRadiusAuthenticator::AuthenticateRadiusUser method to perform RADIUS authentication must implement this notification interface.

Methods in Vtable Order

The IFWXAuthenticationCompletion interface inherits the methods of the standard COM interface IUnknown.

In addition, IFWXAuthenticationCompletion defines the following method.

Method | Description
CompleteAsyncAuthentication | Receives a notification that an asynchronous authentication operation initiated by a call to IFWXRadiusAuthenticator::AuthenticateRadiusUser has completed, and receives information associated with the authentication process.

Remarks

A filter can use the IFWXFirewall2::CreateRadiusAuthenticator method to create a new IFWXRadiusAuthenticator interface and obtain a pointer to it. When a request is received on a listener that has RADIUS authentication enabled, and the filter requires RADIUS authentication, it calls IFWXRadiusAuthenticator::AuthenticateRadiusUser and supplies a pointer to an IFWXAuthenticationCompletion notification interface.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Wspfwext.idl.

See Also

Filter Interfaces


CompleteAsyncAuthentication method [ISA Server 2004]

IFWXAuthenticationCompletion::CompleteAsyncAuthentication

The CompleteAsyncAuthentication method receives a notification that an asynchronous authentication operation that was initiated by a call to IFWXRadiusAuthenticator::AuthenticateRadiusUser has completed, and receives information associated with the authentication process.

HRESULT CompleteAsyncAuthentication(
  BOOL fSuccess,
  DWORD Win32ErrorCode,
  IFWXAuthenticatedUser* pIFWXAuthenticatedUser,
  UserContextType UserData
);

Parameters

fSuccess
[in] Boolean value that specifies whether the authentication operation completed successfully. If TRUE, the operation succeeded. If FALSE, it failed.
Win32ErrorCode
[in] A Windows error code. This parameter is meaningful only when the fSuccess parameter is set to FALSE, in which case the error code provides the reason for the failure.
pIFWXAuthenticatedUser
[in] Pointer to the IFWXAuthenticatedUser interface representing the user that was successfully authenticated.
UserData
[in] The UserData parameter set in the call to the IFWXRadiusAuthenticator::AuthenticateRadiusUser method, for differentiation between completion notifications.

Return Values

Implementations of this method should handle any run-time error and return S_OK.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Wspfwext.idl.

See Also

IFWXAuthenticationCompletion


IFWXConnection interface [ISA Server 2004]

IFWXConnection

The IFWXConnection interface represents a particular connection and provides methods that are specific to it.

Methods in Vtable Order

The IFWXConnection interface inherits the methods of the standard COM interface IUnknown.

In addition, IFWXConnection defines the following methods.

Method | Description
AttachDataFilter | Attaches a data filter to the connection.
AttachDataFilterWithDestination | Attaches a data filter to the connection. The data filter is associated with a remote UDP destination.
EmulateConnection | Creates a connection to a client for a filter-emulated listening (inbound) connection.
EmulateForBind | Emulates a bind for an incoming request.
EmulateForConnect | Emulates a connection for an outbound request. In the outbound scenario, a data filter emulates the external connection for an internal client.
IncrementBytesSentCounter | Updates the counter with how many bytes have been sent over an emulated connection.
SetSocketName | sets the name of the socket for the connection. Call this method only if the caller is emulating the connection.
Kill | Forces the connection to terminate.
GetExternalSocketName | Gets the socket name for the external socket. This method is implemented by calling the Winsock getsockname function on the actual external socket.
SetClientAddress | Gives the client address for a connection returned by the IFWXSession::BindForClient method, for which the client address was not previously specified.
Deny | Denies the current operation on the connection object.
SetBufferSize | Sets the buffer size for a connection.
GetExternalPeerName | Gets the peer name for the external socket. This method is implemented by calling the Windows Sockets (Winsock) getpeername function on the actual external socket.
GetSession | Returns the session object to which a connection belongs.
SetIpFilter | Sets the IP filter for the connection. Either sets a new IP filter if there had not been one or replaces the current IP filter with a new one.
GetIpFilter | Gets a copy of the IP filter object for the connection.
GetConnectionFlags | Retrieves the flags that are set for the connection.

Remarks

The connection object represented by the IFWXConnection interface implements functions specific to a particular connection. Every remote socket created on behalf of a client has a connection object associated with it.

When a registered event occurs, the Microsoft Firewall service will call IFWXSessionFilter::FirewallEventHandler and will pass the FirewallEvent parameter to it. Included in the FirewallEvent parameter is a pointer to the IFWXConnection.

After the pointer is available, you can use the IFWXConnection methods, such as IFWXConnection::AttachDataFilter.

The IFWXConnection methods are understood most easily in the context of connection scenarios:

Scenario A: Bind and Connect

  1. The client requests a bind or connection.
  2. The Firewall service creates a connection object.
  3. The Firewall service checks access rights.
  4. The Firewall service provides an event notification to the application filters, so that the filters can then work with the connection object and use:

    • IFWXConnection::Deny to deny the connection.
    • IFWXConnection::AttachDataFilter to attach a data filter to the connection. In the case of a bind request, this applies to UDP only.

Scenario B: Bind and Listen

  1. The client requests a bind.
  2. The filter calls IFWXSession::BindForClient.
  3. The Firewall service creates a connection object.
  4. The Firewall service provides an event notification to the application filter, so that the filter can then work with the connection object.

When a listening socket exists, and an event of type fwx_AcceptedConnection occurs, an accepted socket is created on the Firewall service. The connection object for the accepted socket exists before the matching client socket is created.

Note A single TCP connection between a listening socket on the Firewall service and an external server may result in the creation of two connection objects: a listening connection on the Firewall service, and an inbound connection. When the remote server disconnects, the inbound connection is closed, but the listening connection may not close if FWX_FLAG_ALLOW_MULTIPLE was specified.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Wspfwext.idl.

See Also

Filter Interfaces


IFWXConnection.AttachDataFilter (3 Parameters) method [ISA Server 2004]

IFWXConnection::AttachDataFilter

The AttachDataFilter method attaches a data filter to the connection.

HRESULT AttachDataFilter(
  IFWXDataFilter* piDataFilter,
  FwxDataFilterPriorityClass PriorityClass,
  IUnknown* punkFilterContext
);

Parameters

piDataFilter
[in] Pointer to the IFWXDataFilter interface of the Microsoft Firewall service data filter object to use with this connection.
PriorityClass
[in] Priority class for the data filter. This determines the position of the data filter in relation to other data filters that may be attached to the connection. This parameter is a value from the FwxDataFilterPriorityClass enumeration.
punkFilterContext
[in] Pointer to the interface to use to pass contextual information to the data filter, such as the session to which the data filter is being attached. This interface is passed to the IFWXDataFilter::SetSockets method in the punkFilterContext parameter. This parameter can be NULL.

Return Values

S_OK
The method succeeded.
E_OUTOFMEMORY
Insufficient memory or resources; the method failed.
FWX_E_TERMINATING
The object is shutting down.
E_INVALIDARG
Invalid value was passed to the method.

Remarks

This method can be called only in the context of the IFWXSessionFilter::FirewallEventHandler method while handling events of types:

fwx_AcceptedConnection

fwx_Bind_Udp

fwx_Connect_Tcp

fwx_Udp_Destination

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Wspfwext.idl.

See Also

IFWXConnection, IFWXDataFilter, IFWXSessionFilter::FirewallEventHandler


IFWXConnection.AttachDataFilterWithDestination method [ISA Server 2004]

IFWXConnection::AttachDataFilterWithDestination

The AttachDataFilterWithDestination method attaches a data filter to the connection. The data filter is associated with a remote UDP destination.

HRESULT AttachDataFilterWithDestination(
  IFWXDataFilter* piDataFilter,
  FwxDataFilterPriorityClass PriorityClass,
  IUnknown* punkFilterContext,
  LPSOCKADDR ExternalAddress,
  INT ExternalAddressLength
);

Parameters

piDataFilter
[in] Pointer to the IFWXDataFilter interface on the data filter to use with this connection.
PriorityClass
[in] Priority class for the data filter. This determines the position of the data filter in relation to other data filters that may be attached to the connection. This parameter is a value from the FwxDataFilterPriorityClass enumeration.
punkFilterContext
[in] Pointer to the interface to use to pass context information to the data filter. This interface is passed to the IFWXDataFilter::SetSockets method. This parameter can be NULL.
ExternalAddress
[in]

Pointer to a sockaddr structure that contains the address of the peer of UDP datagrams for which the data filter is installed.

The data filter receives all datagrams sent through the connection but is removed if the service causes a destination to expire.

ExternalAddressLength
[in] Length, in bytes, of the ExternalAddress parameter.

Return Values

S_OK
The method succeeded.
E_OUTOFMEMORY
Insufficient memory or resources; the method failed.
FWX_E_TERMINATING
The object is shutting down.
E_INVALIDARG
Invalid value was passed to the method.

Remarks

This method must be called only in the context of the IFWXSessionFilter::FirewallEventHandler method while handling an event of type fwx_Udp_Destination. This method would be used when you want the filter to attach only to data from a specific destination, even if the connection is not destination specific, as is the case for UDP connections.

The data filter will receive all of the packets on the connection.

The data filter will be detached from the connection automatically if the UDP destination expires.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Wspfwext.idl.

See Also

IFWXConnection


IFWXConnection.Deny(DWORD) method [ISA Server 2004]

IFWXConnection::Deny

The Deny method denies the current operation on the connection object.

HRESULT Deny(
  DWORD Reserved
);

Parameters

Reserved
[in] Reserved for future use. The parameter value must be zero.

Return Values

S_OK
The connection will be denied.
E_INVALIDARG
Invalid value was passed to the Reserved parameter.
FWX_E_BAD_CONTEXT
The method was not called while handling any of the supported events.

Remarks

This method is rarely used. Using policy rules administration methods is the preferred way to control user activity.

This method must only be called in the context of the IFWXSessionFilter::FirewallEventHandler method while handling events of types:

  • fwx_AcceptedConnection
  • fwx_Bind_Udp
  • fwx_Bind_Tcp
  • fwx_Connect_Tcp

The action that caused the event will be canceled. A bind operation will fail with error code 10048 (WSAEADDRINUSE). A connect operation will fail with error code 10061 (WSAECONNREFUSED). An accepted connection will be aborted.

Note For an event of type fwx_Udp_Destination, use the IFWXUdpDestination::Deny method instead of the IFWXConnection::Deny method. Outbound UDP packets sent to a denied destination will be discarded.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Wspfwext.idl.

See Also

IFWXConnection


IFWXConnection.EmulateConnection (6 Parameters) method [ISA Server 2004]

IFWXConnection::EmulateConnection

The EmulateConnection method creates a connection to a client for a filter-emulated listening (inbound) connection.

HRESULT EmulateConnection(
  IFWXDataFilter* piDataFilter,
  LPSOCKADDR RemoteAddress,
  DWORD RemoteAddressLength,
  LPSOCKADDR LocalAddress,
  DWORD LocalAddressLength,
  IFWXConnection** ppNewIFWXConnection
);

Parameters

piDataFilter
[in] Pointer to the IFWXDataFilter interface on the data filter that supplies the data for the connection. The data filter is installed with fwx_dfpc_Emulation priority, which is closest to the Internet. The data filter only receives an interface of an internal socket. An external socket is assumed to be held by the caller.
RemoteAddress
[in] Pointer to a sockaddr structure that contains the address of the remote socket that is connecting to the client. This address is set in the output parameter of the accept and getpeername functions on the client.
RemoteAddressLength
[in] Length, in bytes, of the RemoteAddress parameter.
LocalAddress
[in] Pointer to a sockaddr structure that contains the local Microsoft Firewall service address that is used for the connection. This is the address that the getsockname function returns to the client.
LocalAddressLength
[in] Length, in bytes, of the LocalAddress parameter.
ppNewIFWXConnection
[out] Pointer to a variable that receives an IFWXConnection interface pointer on the connection object that is created for this new connection. The parameter can be NULL. The reference to the new connection object must not be held after an event of type fwx_ConnectionTerminating for that connection is received.

Return Values

S_OK
The method succeeded.
HRESULT_FROM_WIN32(WSAEINVAL)
The connection object is not in a listening state or is not being emulated.
HRESULT_FROM_WIN32
The method failed and returned a Windows Sockets (Winsock) error code.
E_OUTOFMEMORY
Insufficient memory or resources; the method failed.
FWX_E_TERMINATING
The object is shutting down.

Remarks

This method may be called only if this connection is in the listening state, and the caller is a filter that is emulating the listening state for the connection. Clients use the emulated connection, so that, effectively, only one real connection is used.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Wspfwext.idl.

See Also

IFWXConnection, EmulateForBind


IFWXConnection.EmulateForBind method [ISA Server 2004]

IFWXConnection::EmulateForBind

The EmulateForBind method emulates a bind for an incoming request.
HRESULT EmulateForBind();

Parameters

This method has no parameters.

Return Values

S_OK
The method succeeded.
FWX_E_TERMINATING
The object is shutting down.
FWX_E_ALREADY_EMULATED
The connection is already being emulated (cannot emulate the same connection twice).
FWX_E_BAD_CONTEXT
This method is only valid in the context of certain events. It cannot be used at other times.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Wspfwext.idl.

See Also

IFWXConnection, EmulateConnection


IFWXConnection.EmulateForConnect (2 Parameters) method [ISA Server 2004]

IFWXConnection::EmulateForConnect

The EmulateForConnect method emulates a connection for an outbound request. In the outbound scenario, a data filter emulates the external connection for an internal client.

HRESULT EmulateForConnect(
  IFWXDataFilter* piDataFilter,
  IUnknown* punkFilterContext
);

Parameters

piDataFilter
[in] Pointer to the IFWXDataFilter interface of the Microsoft Firewall service data filter object to use with this connection.
punkFilterContext
[in] Pointer to the interface to use to pass contextual information to the data filter, such as the session to which the data filter is being attached. This interface is passed to the IFWXDataFilter::SetSockets method in the punkFilterContext parameter. This parameter can be NULL.

Return Values

S_OK
The method succeeded.
E_OUTOFMEMORY
Insufficient memory or resources; the method failed.
FWX_E_TERMINATING
The object is shutting down.
E_INVALIDARG
Invalid value was passed to the method.
FWX_E_ALREADY_EMULATED
The connection is already being emulated (cannot emulate the same connection twice).
FWX_E_BAD_CONTEXT
This method is only valid in the context of certain events. It cannot be used at other times.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Wspfwext.idl.

See Also

IFWXConnection


IFWXConnection.GetConnectionFlags(LPDWORD) method [ISA Server 2004]

IFWXConnection::GetConnectionFlags

The GetConnectionFlags method retrieves the flags that are set for the connection.

HRESULT GetConnectionFlags(
  LPDWORD pOutputFlags
);

Parameters

pOutputFlags
[out] Pointer to a variable that on return is set to the following flag if it is set for the connection, or to 0.
Value | Meaning
FWX_CONNECTION_INTERNAL_ADDRESS_TRANSLATION | The translation of external addresses to internal addresses is enabled for the connection.

Return Values

This method returns S_OK if the call is successful; otherwise, it returns an error code.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Wspfwext.idl.

See Also

IFWXConnection


IFWXConnection.GetExternalPeerName(LPSOCKADDR,LPINT) method [ISA Server 2004]

IFWXConnection::GetExternalPeerName

The GetExternalPeerName method gets the peer name for the external socket. This method is implemented by calling the Windows Sockets (Winsock) getpeername function on the actual external socket.

HRESULT GetExternalPeerName(
  LPSOCKADDR Address,
  LPINT AddressLength
);

Parameters

Address
[out] Pointer to a sockaddr structure that receives the peer name.
AddressLength
[in, out] On input, this parameter specifies the size, in bytes, of the Address buffer. On output, it receives the size, in bytes, needed to hold the address.

Return Values

S_OK
The method succeeded.
HRESULT_FROM_WIN32(WSAEFAULT)
The name or namelen parameter is not a valid part of the user address space, or the namelen parameter is too small.
FWX_E_TERMINATING
The object is shutting down.

Remarks

When the firewall is chained to another firewall or proxy, this method returns the value for the next proxy in the chain.

Note This method should not be called from the session event handling portion of your filter code. At that point in the code, the network connection has not been established yet, and may be denied by the application filter or by another application filter. Typically you would call this method from within one of the IFWXDataFilter methods of a data filter attached to the connection; that is, at a point when you are certain that the connection has been established.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Wspfwext.idl.

See Also

IFWXConnection


IFWXConnection.GetExternalSocketName(LPSOCKADDR,LPINT) method [ISA Server 2004]

IFWXConnection::GetExternalSocketName

The GetExternalSocketName method gets the socket name for the external socket. This method is implemented by calling the Winsock getsockname function on the actual external socket.

HRESULT GetExternalSocketName(
  LPSOCKADDR Address,
  LPINT AddressLength
);

Parameters

Address
[out] Pointer to a sockaddr structure that receives the socket address (name).
AddressLength
[in, out] On input, this parameter specifies the size, in bytes, of the Address buffer. On output, it receives the size, in bytes, needed to hold the address.

Return Values

S_OK
The method succeeded.
E_OUTOFMEMORY
Insufficient memory or resources; the method failed.
FWX_E_TERMINATING
The object is shutting down.
HRESULT_FROM_WIN32(WSAEFAULT)
The name or namelen parameter is not a valid part of the user address space, or the namelen parameter is too small.
HRESULT_FROM_WIN32(WSAEINVAL)
The socket has not been bound to an address with Bind.

Remarks

Note This method should not be called from the session event handling portion of your filter code. At that point in the code, the network connection has not been established yet, and may be denied by the application filter or by another application filter. Typically you would call this method from within the IFWXDataFilter::SetSockets method of a data filter attached to the connection; that is, at a point when you are certain that the connection has been established.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Wspfwext.idl.

See Also

IFWXConnection


IFWXConnection.GetIpFilter(IFWXIpFilter) method [ISA Server 2004]

IFWXConnection::GetIpFilter

The GetIpFilter method gets a copy of the IP filter object for the connection. Returns NULL if the connection is not limited to a range of IP addresses.

HRESULT GetIpFilter(
  IFWXIpFilter** ppIpFilter
);

Parameters

ppIpFilter
[out] Address of a variable that receives a pointer to the IFWXIpFilter interface.

Remarks

Because the returned object is a copy, modifying the object does not affect the connection.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Wspfwext.idl.

See Also

IFWXConnection, IFWXIpFilter


IFWXConnection.GetSession(IFWXSession) method [ISA Server 2004]

IFWXConnection::GetSession

The GetExternalSocketName method returns the session object to which a connection belongs.

HRESULT GetSession(
  IFWXSession** ppSession
);

Parameters

ppSession
[out] Pointer to the session object.

Return Values

S_OK
The method succeeded.
FWX_E_TERMINATING
The socket is already closed.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Wspfwext.idl.

See Also

IFWXConnection


IFWXConnection.IncrementBytesSentCounter(DWORD) method [ISA Server 2004]

IFWXConnection::IncrementBytesSentCounter

The IncrementBytesSentCounter method updates the counter with how many bytes have been sent over an emulated connection.

HRESULT IncrementBytesSentCounter(
  DWORD dwBytesSent
);

Parameters

dwBytesSent
The number of bytes sent since the counter was last updated.

Return Values

S_OK
The method succeeded
FWX_E_NOT_EMULATED
The connection is not emulated.

Remarks

This method is used by application filters that use connection emulation. In an emulated connection, ISA Server does not have access to the emulated external socket associated only with the application filter and does not count bytes sent through that socket. The filter must call this function to count bytes sent on behalf of the client on the emulated connection. The total count appears in the log file in the bytes sent column.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.

See Also

IFWXConnection, EmulateConnection


IFWXConnection.Kill method [ISA Server 2004]

IFWXConnection::Kill

The Kill method forces the connection to terminate.

HRESULT Kill();

Parameters

This method has no parameters.

Return Values

This method always returns S_OK.

Remarks

This method can be used to end an established connection.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Wspfwext.idl.

See Also

IFWXConnection


IFWXConnection.SetBufferSize(DWORD) method [ISA Server 2004]

IFWXConnection::SetBufferSize

The SetBufferSize method sets the buffer size for a connection.

HRESULT SetBufferSize(
  DWORD BufferSize
);

Parameters

BufferSize
[in] Buffer size to be used for this connection.

Return Values

S_OK
The method succeeded.
E_INVALIDARG
Invalid value was passed to the method.

Remarks

This method allows you to modify the buffer size for a connection. By default, the service uses buffers of 4096 bytes for UDP and 2048 for TCP. UDP datagrams larger than the default buffer size are dropped by the service. Use this function to set a larger buffer size for protocols that use packets larger than 4096 bytes.

For TCP, the buffer size is used for optimization. In general, it should not be modified. For UDP, datagrams larger than the buffer size can be dropped. If the filter determines that larger datagrams can be transmitted, it should set the buffer size accordingly.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Wspfwext.idl.

See Also

IFWXConnection


IFWXConnection.SetClientAddress(LPSOCKADDR,DWORD) method [ISA Server 2004]

IFWXConnection::SetClientAddress

The SetClientAddress method gives the client address for a connection returned by the IFWXSession::BindForClient method for which the client address was not previously specified.

HRESULT SetClientAddress(
  LPSOCKADDR ClientAddress,
  DWORD ClientAddressLength
);

Parameters

ClientAddress
[in] Pointer to a sockaddr structure that contains the address that the client used.
ClientAddressLength
[in] Length, in bytes, of the ClientAddress parameter.

Return Values

S_OK
The method succeeded.
E_INVALIDARG
Invalid address passed to the method, or the client address was already specified.
HRESULT_FROM_WIN32(Windows error code)
Windows Sockets (Winsock) or Windows error code. The method failed.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Wspfwext.idl.

See Also

IFWXConnection


IFWXConnection.SetIpFilter(IFWXIpFilter) method [ISA Server 2004]

IFWXConnection::SetIpFilter

The SetIpFilter method sets the IP filter for the connection. Either sets a new IP filter if there had not been one or replaces the current IP filter with a new one.

HRESULT SetIpFilter(
  IFWXIpFilter* pIpFilter
);

Parameters

pIpFilter
[in] Pointer to the IFWXIpFilter interface. Setting this parameter equal to NULL will result in no IP address restrictions for this connection.

Remarks

This method should not be used for emulated connections.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Wspfwext.idl.

See Also

IFWXConnection, IFWXIpFilter


IFWXConnection.SetSocketName(LPSOCKADDR,DWORD) method [ISA Server 2004]

IFWXConnection::SetSocketName

The GetExternalSocketName method sets the name of the socket for the connection. Call this method only if the caller is emulating the connection.

HRESULT SetSocketName(
  LPSOCKADDR Address,
  DWORD AddressLength
);

Parameters

Address
[in] Pointer to a sockaddr structure that contains the socket address.
AddressLength
[in] Length, in bytes, of the Address parameter.

Return Values

S_OK
The method succeeded.
FWX_E_ALREADY_EXISTS
The socket is already bound.
FWX_E_INVALID_ARG
An invalid argument was provided to this method.

Remarks

On regular connections, the Microsoft Firewall service calls the getsockname Winsock function on the external socket and passes this information to the Firewall client. For an emulated connection, there is no external socket, or the external socket is known only to the filter. The filter is required to call this method and set the socket name.

When there is no connection, it is advisable to return an IP address of the Firewall service (external or internal as appropriate) because the client application may use this information to publish the address.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Wspfwext.idl.

See Also

IFWXConnection


IFWXDataFilter interface [ISA Server 2004]

IFWXDataFilter

The IFWXDataFilter interface represents a data filter. A data filter functions as the data pump of the Microsoft Firewall service and performs data filtering.

Note When you use the IFWXDataFilter interface, consider possible threading issues. For more information, see Best Practices.

When To Implement

An application filter that needs to hook into the data pump of the Firewall service must implement this interface.

Methods in Vtable Order

The IFWXDataFilter interface inherits the methods of the standard COM interface IUnknown.

In addition, IFWXDataFilter defines the following methods.

Method | Description
SetSockets | Sets the internal and external sockets for the data filter. When this method is called, the filter is expected to begin the data-pumping process between the sockets.
Detach | Detaches the data filter from the internal and external sockets attached to it. This method should release the references that the data filter object holds to the socket interfaces and to the connection.

Remarks

Filters that examine data require a data pump to pass data through the connection.

There are two approaches to creating data filter instances:

  • Implement IFWXConnection::AttachDataFilter to create and attach a data filter by adding code to the session filter. The session filter will then attach a data filter instance to the connection whenever the registered event occurs.
  • Provide an object that implements the standard COM IClassFactory interface.

Implement the IFWXConnection interface methods (implemented by the Firewall service) to attach the data pump, and IFWXSessionFilter::FirewallEventHandler to receive information about the event. Through the IFWXDataFilter::SetSockets method, the Firewall service provides socket interfaces to the data filter for the sockets on the internal and external computers. The Firewall service calls the IFWXDataFilter::Detach method when the connection to the sockets is no longer needed. When IFWXDataFilter::Detach is called, you must code a release to the sockets so that the system can delete the socket objects.

The Firewall service calls IFWXIOCompletion::CompleteAsyncIO when the I/O operation is completed. The data filter object inherits the CompleteAsyncIO method from IFWXIOCompletion. The data is then available for the data pump and filter.

Handling Data Received from Another Protocol

When the primary port of a protocol lies within the dynamic port range (1024 – 5000), a filter for that protocol will receive a Firewall service event if that port is selected for another protocol's secondary connection. However, when the data stream through that secondary connection does not comply with the filter's expected protocol, the filter must be able to handle this situation.

The proper approach is to design a filter to revert to a simple data pump if the data stream is not the expected protocol. Note that it is possible for data that would have been rejected at the primary port to pass through the filter at the secondary port.

Example Code

The following is a standard declaration of the data filter object.

//Note that IFWXIOCompletion::CompleteAsyncIO is made
//public in this declaration, and must be implemented
//by this object.
class ATL_NO_VTABLE CDumpData :
    public CComObjectRootEx<CComMultiThreadModel>,
    public IFWXDataFilter,
    public IFWXIOCompletion
{

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Wspfwext.idl.

See Also

Filter Interfaces


IFWXDataFilter.Detach method [ISA Server 2004]

IFWXDataFilter::Detach

The Detach method detaches the data filter from the internal and external sockets attached to it. This method should release the references that the data filter object holds to the socket interfaces and to the connection.

HRESULT Detach();

Parameters

This method has no parameters.

Return Values

Implementations of this method should handle any run-time error and return S_OK.

Remarks

This method is called by the Microsoft Firewall service to free the data filter object when the connection has ended.

This method may also be called before the IFWXDataFilter::SetSockets method to ensure cleanup in case of failures.

Example Code

The following is an example implementation of the Detach method.

HRESULT STDMETHODCALLTYPE CMyDataFilter::Detach()
{
    // Assume that m_spExternalSocket and m_spInternalSocket
    // are defined as CComPtr<IFWXSocket> and that
    // m_spConnection is defined as CComPtr<IFWXConnection>.
    Lock();
    m_spExternalSocket = NULL;
    m_spInternalSocket = NULL;
    m_spConnection = NULL;
    Unlock();

    return S_OK;
}

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Wspfwext.idl.

See Also

IFWXDataFilter


IFWXDataFilter.SetSockets (4 Parameters) method [ISA Server 2004]

IFWXDataFilter::SetSockets

The SetSockets method sets the internal and external sockets for the data filter. When this method is called, the filter is expected to begin the data-pumping process between the sockets.

HRESULT SetSockets(
  IFWXSocket* piInternalSocket,
  IFWXSocket* piExternalSocket,
  IFWXConnection* piConnection,
  IUnknown* punkFilterContext
);

Parameters

piInternalSocket
[in] Pointer to the IFWXSocket interface for an internal socket.
piExternalSocket
[in] Pointer to the IFWXSocket interface for an external socket.
piConnection
[in] Pointer to the IFWXConnection interface on the connection object on which this data filter is installed.
punkFilterContext
[in] Pointer to the interface used to pass context information to the data filter. The parameter will have the same value as the punkFilterContext parameter of the IFWXConnection::AttachDataFilter and IFWXSession::SetDataFilterFactory methods.

Return Values

Implementations of this method should return the following:
S_OK
The method succeeded.
E_OUTOFMEMORY
Insufficient memory or resources to process the event. The connection will be terminated.

Remarks

A filter that is emulating a connection receives NULL for the external socket interface.

Example Code

The following is an example implementation of the IFWXDataFilter::SetSockets method.

STDMETHODIMP
//CDumpData is the name of the object that implements
//IFWXDataFilter in this example.
CDumpData::SetSockets(
    IN   IFWXSocket *piInternalSocket,
    IN   IFWXSocket *piExternalSocket,
    IN   IFWXConnection *piConnection,
    IN   IUnknown *punkFilterContext
    )
{
    // Using Lock/Unlock, all access to the sockets is protected
    // because Detach could be called at any time.
    Lock();
    m_spInternalSocket = piInternalSocket;
    m_spExternalSocket = piExternalSocket;
    Unlock();

    //ReadFirstBuffers is a function that waits for
    //data on both sockets.
    return ReadFirstBuffers();
}

The variables m_spInternalSocket and m_spExternalSocket are defined as follows:

    CComPtr<IFWXSocket> m_spExternalSocket;
    CComPtr<IFWXSocket> m_spInternalSocket;

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Wspfwext.idl.

See Also

IFWXDataFilter


IFWXExternalIOCompletion interface [ISA Server 2004]

IFWXExternalIOCompletion

The IFWXExternalIOCompletion interface includes a method for receiving a notification from the Microsoft Firewall service upon completion of an asynchronous Windows input/output (I/O) operation involving reading or writing to a file on a disk for which the filter maintains a handle.

When To Implement

An application filter that needs to receive notifications from the Firewall service upon completion of asynchronous Windows I/O operations must implement this notification interface.

Methods in Vtable Order

The IFWXExternalIOCompletion interface inherits the methods of the standard COM interface IUnknown.

In addition, IFWXExternalIOCompletion defines the following method.

Method | Description
CompleteAsyncIO | Receives a notification from the Firewall service when an asynchronous Windows I/O operation involving reading or writing to a file on a disk completes.

Remarks

This interface is similar in function to the IFWXIOCompletion interface, but is used for reading or writing to files on a disk asynchronously.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Wspfwext.idl.

See Also

Filter Interfaces, IFWXFirewall::HookToCompletionPort, IFWXFirewall::CreateOverlapped, IFWXOverlapped


IFWXExternalIOCompletion.CompleteAsyncIO (5 Parameters) method [ISA Server 2004]

IFWXExternalIOCompletion::CompleteAsyncIO

The CompleteAsyncIO method receives a notification from the Microsoft Firewall service when an asynchronous Windows I/O operation involving reading or writing to a file on a disk completes.

HRESULT CompleteAsyncIO(
  BOOL fSuccess,
  DWORD NumberOfBytesTransfered,
  DWORD Win32ErrorCode,
  IFWXOverlapped* pOverlapped,
  UserContextType UserData
);

Parameters

fSuccess
[in] Success flag. If TRUE, the I/O operation succeeded. If FALSE, it failed.
NumberOfBytesTransfered
[in] Number of bytes transferred during a successful I/O operation.
Win32ErrorCode
[in] Windows error code for a failed I/O operation.
pOverlapped
[in] Pointer to the IFWXOverlapped interface on the overlapped object used for this operation.
UserData
[in] The UserData parameter set in the call to the IFWXOverlapped::SetNotificationInterface method.

Return Values

Implementations of this method should handle any run-time error and return S_OK.

Remarks

If the Firewall service is performing asynchronous I/O for an operating system file, it must have access to the Windows Sockets OVERLAPPED structure and a means of setting up a callback when the I/O is completed.

The IFWXOverlapped interface gets a pointer to the Windows Sockets OVERLAPPED structure. The IFWXOverlapped interface also provides the link between the OVERLAPPED structure and a completion notification interface and includes user context information that allows the filter to distinguish between different notifications.

Use the IFWXOverlapped::SetNotificationInterface method to set the notification interface and user context. Then use the IFWXOverlapped::GetOverlapped method to get an OVERLAPPED structure that will be used in a call to an asynchronous Windows API.

The call to the Windows API must use a handle that is associated with the Firewall service's completion port. For more information, see the IFWXFirewall::HookToCompletionPort method.

When the overlapped operation completes, the Firewall service will get the completion notification in its completion port and will call the completion notification method of the specified interface.

The UserData parameter provides a context to the notification. You can use the same notification interface for completion notifications from distinct network socket objects and differentiate between them by using different values for the UserData parameter.

Example Code

This example implementation of IFWXExternalIOCompletion::CompleteAsycnIO is taken from the Exeblock sample filter.

HRESULT
STDMETHODCALLTYPE
CEBScannerDataFilter::CompleteAsyncIO(
    /* [in] */ BOOL fSuccess,
    /* [in] */ DWORD NumberOfBytesTransfered,
    /* [in] */ DWORD Win32ErrorCode,
    /* [in] */ IFWXOverlapped __RPC_FAR *pOverlapped,
    /* [in] */ UserContextType UserData)
{

    UNREFERENCED_PARAMETER(UserData);
    UNREFERENCED_PARAMETER(Win32ErrorCode);
    UNREFERENCED_PARAMETER(NumberOfBytesTransfered);

    // The _Abort method closes and releases both sockets.
    if (!fSuccess) _Abort();
    pOverlapped->Release();
    IFWXSocket *pISocket = _GetExternalSocket();

    if (pISocket)
    {
        pISocket->Recv(NULL, this, 0);
        pISocket->Release();
    }

    return S_OK;
}

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Wspfwext.idl.

See Also

IFWXExternalIOCompletion


IFWXFilter interface [ISA Server 2004]

IFWXFilter

The IFWXFilter interface is used by the Microsoft Firewall service to load and initialize a filter and to create session filters. An IFWXFilter interface is called for each filter that is in ISA Server storage and is enabled.

When To Implement

Every application filter must implement this interface. When the Firewall service starts, it creates an instance of the filter object for each application filter that is installed on the ISA Server computer and enabled.

Methods in Vtable Order

The IFWXFilter interface inherits the methods of the standard COM interface IUnknown.

In addition, IFWXFilter defines the following methods.

Method | Description
FilterInit | Initializes the filter and passes it a pointer to the IFWXFirewall interface exposed by the Firewall service. This interface provides access to Firewall service functions that are not tied to any specific user session.
FilterShutdown | Begins the shutdown sequence for the filter object when the Firewall service is shutting down.
AttachToSession | Called by the Firewall service when it determines that a session filter is needed.

Remarks

Only one instance of the IFWXFilter interface is created per filter. In the IFWXFilter interface, you define a port, or range of ports, to be monitored, and the events that will trigger a call to the IFWXFilter::AttachToSession method.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Wspfwext.idl.

See Also

Filter Interfaces


IFWXFilter.AttachToSession (3 Parameters) method [ISA Server 2004]

IFWXFilter::AttachToSession

The AttachToSession method creates a session filter object when the Microsoft Firewall service detects an event for which the filter is registered. The AttachToSession method also indicates the set of events that the session filter will handle. This set of events includes the events requested in the IFWXFilter::FilterInit method. The events for which the filter is registered are received in a FwxFilterHookEvents structure.

The Firewall service calls this method when it detects an event for which the filter is registered.

HRESULT AttachToSession(
  IFWXSession* piSession,
  IFWXSessionFilter** piSessionFilter,
  PFwxFilterHookEvents pFilterHookEvents
);

Parameters

piSession
[in] Pointer to the IFWXSession interface associated with the session to be monitored.
piSessionFilter
[out] Address of a variable that receives a pointer to the IFWXSessionFilter interface on the session filter object created. The session filter object receives event notifications for the session.
pFilterHookEvents
[in, out] Pointer to a FwxFilterHookEvents structure containing the initial set of events that the filter monitors. Use the CoTaskMemAlloc function to allocate the structure.

Return Values

Implementations of this method should return the following:
S_OK
The method succeeded.
E_OUTOFMEMORY
Insufficient memory or resources to process the event. This will cause the request that generated the event to fail.

Example Code

The following is an example implementation of the AttachToSession method.

HRESULT STDMETHODCALLTYPE AttachToSession(IFWXSession *piSession,
                                          IFWXSessionFilter ** piSessionFilter,
                                          PFwxFilterHookEvents  *ppFilterHookEvents)
{
    UNREFERENCED_PARAMETER(piSession);

    HRESULT hr = S_OK;

    // Create an instance of the session filter.
    CComObject<CMyFWXSessionFilter> *pSessionFilter;
    hr = CComObject<CMyFWXSessionFilter>::CreateInstance(&pSessionFilter);
    if (SUCCEEDED(hr))
    {
        pSessionFilter->AddRef();
        pSessionFilter->Initialize(this);

        // Give back the required events and the session filter object
        *pFilterHookEvents = m_FwxFilterHookEvents;
        *piSessionFilter = pSessionFilter;

        return S_OK;
    }
    if (FAILED(hr))
    {
        return E_OUTOFMEMORY;
    }
}

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Wspfwext.idl.

See Also

IFWXFilter


IFWXFilter.FilterInit(IFWXFirewall,FwxFilterHookEvents) method [ISA Server 2004]

IFWXFilter::FilterInit

The FilterInit method initializes the filter and passes a pointer to the IFWXFirewall interface exposed by the Microsoft Firewall service to it. The IFWXFirewall interface provides access to Firewall service functions that are not tied to any specific user session. For a list of the general methods, see the IFWXFirewall interface.

HRESULT FilterInit(
  IFWXFirewall* pIFWXFirewall,
  FwxFilterHookEvents* pFilterHookEvents
);

Parameters

pIFWXFirewall
[in] Pointer to the IFWXFirewall interface on the Firewall service.
pFilterHookEvents
[out] Pointer to an FwxFilterHookEvents structure that on return contains the initial set of events that the filter monitors. This structure can be created as a private member of the object that implements this interface, or it can be created by calling the CoTaskMemAlloc function.

Return Values

Implementations of this method should handle any run-time error and return S_OK. For more information, see Remarks.

Remarks

Implementations of the FilterInit method should include all initializations, particularly events to monitor, as well as the reading of configurations and the creation of listening sockets.

If FilterInit does not succeed, as in a case where resources required by the filter are absent, this method should still return S_OK, but not register for any events. This will reduce the risk that the Firewall service will fail to start.

The FilterInit method should not return until the filter is in a valid state and is fully initialized. When the FilterInit method of a filter returns, the Firewall service assumes that the filter is fully initialized. If the implementation of the FilterInit method is asynchronous and it continues to perform initialization steps after returning, traffic can be sent through the filter when it is not yet in a valid state.

Example Code

The following is an example implementation of the FilterInit method for a filter object that has a private member of type FwxFilterHookEvents.

STDMETHODIMP CMyFilter::FilterInit(IFWXFirewall * pIFWXFirewall,
                                   FwxFilterHookEvents * pFilterHookEvents)
{
    // Save the pointer to the IFWXFirewall interface.
    m_spFirewall = pIFWXFirewall;

    // Populate the FwxFilterHookEvents structure.
    m_FwxFilterHookEvents.dwGlobalEvents = DWORD(fwx_Connect_Tcp |
                                                 fwx_AcceptedConnection |
                                                 fwxSourceWSP |
                                                 fwxSourceNAT);

    // Pass the initial set of events that the filter monitors
    // to the Firewall service.
    *pFilterHookEvents = m_FwxFilterHookEvents;

    // Perform other initialization tasks.

    // Return S_OK when finished.
    return S_OK;

}

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Wspfwext.idl.

See Also

IFWXFilter


IFWXFilter.FilterShutdown method [ISA Server 2004]

IFWXFilter::FilterShutdown

The FilterShutdown method begins the shutdown sequence for the filter object when the Microsoft Firewall service is shutting down.

HRESULT FilterShutdown();

Parameters

This method has no parameters.

Return Values

Implementations of this method should handle any run-time error and return S_OK.

Remarks

When shutting down the filter, the Firewall service releases references to all filter-implemented objects, after first making calls to the applicable Detach method (either the IFWXSessionFilter::Detach or IFWXDataFilter::Detach method). However, because of the asynchronous nature of the proxy, the order of calling the Detach and FilterShutdown methods is undefined, and the Firewall service may call the IFWXSessionFilter::Detach method after FilterShutdown has returned. When the Firewall service calls the IFWXSessionFilter::Detach method after FilterShutdown has returned, filter-implemented objects may still be in the process of shutting down. Typically, the shutdown of filter-implemented objects does not have to be considered in filter design because the shutdown of objects occurs in the context of proxy worker threads. When the Firewall service is stopped, it waits until all of its worker threads have terminated and the shutdown operations have completed.

However, if the filter is doing shutdown work in a context other than a proxy worker thread—for example, a remote procedure call (RPC) worker thread or a timer callback thread—the nonproxy thread may execute code after all proxy worker threads have ended. Thus, the nonproxy thread will not have an appropriate context in which to execute the code. To avoid this situation, the FilterShutdown method must not return until all shutdown work has completed in the nonproxy worker thread contexts.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Wspfwext.idl.

See Also

IFWXFilter


IFWXFilterAdmin interface [ISA Server 2004]

IFWXFilterAdmin

The IFWXFilterAdmin interface is used by filter setup to install and configure the filter. You must use this interface to install a filter.

Methods in Vtable Order

The IFWXFilterAdmin interface inherits the methods of the standard COM interface IUnknown.

In addition, IFWXFilterAdmin defines the following methods.

Method | Description
InstallFilter | Registers the filter with ISA Server.
UninstallFilter | Removes the filter registration from the ISA Server configuration.
RegisterProtocol | Registers a protocol. A registered protocol will appear in ISA Server Management.
UnregisterProtocol | Unregisters a protocol that is controlled by a filter.
GetProtocol | Gets the FPCProtocolDefinition object, which provides access to protocols previously registered by the IFWXFilterAdmin::RegisterProtocol method.
GetParameterSets | Gets an interface that provides access to the collection of vendor parameter sets (FPCVendorParametersSets).
GetFilterParameterSet | Gets an interface that provides access to the filter's private configuration parameter set.
GetFilter | Gets the IFPCApplicationFilter interface, which provides access to information about the application filter configuration.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Wspfwext.idl.

See Also

Filter Interfaces


IFWXFilterAdmin.GetFilter (2 Parameters) method [ISA Server 2004]

IFWXFilterAdmin::GetFilter

The GetFilter method retrieves the specified IFPCApplicationFilter interface. The IFPCApplicationFilter interface provides information about the corresponding application filter.

HRESULT GetFilter(
  REFCLSID guidFilter,
  IFPCApplicationFilter** ppFilter
);

Parameters

guidFilter
[in] Class identifier (CLSID) of the COM class that implements the IFWXFilter interface corresponding to the IFPCApplicationFilter interface to retrieve.
ppFilter
[out] Address of an interface pointer that on return points to the IFPCApplicationFilter interface requested.

Return Values

S_OK
The method succeeded.
E_OUTOFMEMORY
Insufficient memory or resources; the method failed.
HRESULT_FROM_WIN32(ERROR_FILE_NOT_FOUND)
A filter with that GUID does not exist.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Wspfwext.idl.

See Also

IFWXFilterAdmin


IFWXFilterAdmin.GetFilterParameterSet (2 Parameters) method [ISA Server 2004]

IFWXFilterAdmin::GetFilterParameterSet

The GetFilterParameterSet method gets an interface that provides access to the filter's private configuration parameter set.

HRESULT GetFilterParameterSet(
  REFCLSID guidFilter,
  IFPCVendorParametersSet** ppParameterSet
);

Parameters

guidFilter
[in] Class identifier (CLSID) of the COM class that implements the IFWXFilter interface for which the parameter set is required.
ppParameterSet
[out] Address of a variable that receives the interface pointer to the parameter set.

Return Values

This method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This method gets the FPCVendorParametersSet object of the filter object.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Wspfwext.idl.

See Also

IFWXFilterAdmin, FPCVendorParametersSet


IFWXFilterAdmin.GetParameterSets (2 Parameters) method [ISA Server 2004]

IFWXFilterAdmin::GetParameterSets

The GetParameterSets method gets an interface that provides access to the collection of vendor parameter sets (FPCVendorParametersSets).

HRESULT GetParameterSets(
  REFCLSID guidFilter,
  IFPCVendorParametersSets** ppParametersSets
);

Parameters

guidFilter
[in] Class identifier (CLSID) of the COM class that implements the IFWXFilter interface for which the parameter sets collection is required.
ppParametersSets
[out] Address of a variable that receives the interface pointer to the collection of parameters sets.

Return Values

This method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

Use this method to get the collection of parameters sets.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Wspfwext.idl.

See Also

IFWXFilterAdmin, FPCVendorParametersSets


IFWXFilterAdmin.GetProtocol (2 Parameters) method [ISA Server 2004]

IFWXFilterAdmin::GetProtocol

The GetProtocol method gets the FPCProtocolDefinition object, which provides access to protocols previously registered by the IFWXFilterAdmin::RegisterProtocol method.

HRESULT GetProtocol(
  REFGUID guidProtocol,
  IFPCProtocolDefinition** ppProtocol
);

Parameters

guidProtocol
[in] The protocol's GUID as specified by IFWXFilterAdmin::RegisterProtocol
ppProtocol
[out] Address of a variable that receives the interface pointer to the FPCProtocolDefinition object.

Return Values

S_OK
The method succeeded.
E_OUTOFMEMORY
Insufficient memory or resources; the method failed.
HRESULT_FROM_WIN32(ERROR_FILE_NOT_FOUND)
A filter with that GUID does not exist.

Remarks

Use this method to change the configuration of a protocol.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Wspfwext.idl.

See Also

IFWXFilterAdmin


IFWXFilterAdmin.InstallFilter (8 Parameters) method [ISA Server 2004]

IFWXFilterAdmin::InstallFilter

The InstallFilter method registers the filter with ISA Server.

HRESULT InstallFilter(
  REFCLSID guidFilter,
  LPCSTR Name,
  LPCSTR Description,
  LPCSTR Vendor,
  LPCSTR VersionString,
  LPCSTR Reserved,
  GUID AssociatedProtocols,
  UINT ProtocolsNumber
);

Parameters

guidFilter
[in] Class identifier (CLSID) of the COM class that implements the IFWXFilter interface, representing the filter to install.
Name
[in] Pointer to the display name of the filter.
Description
[in] Pointer to the description of the filter.
Vendor
[in] Pointer to the name of the company that wrote the filter.
VersionString
[in] Pointer to a string that specifies the version of the filter.
Reserved
[in] Reserved for future use. The Reserved parameter must be a null pointer.
AssociatedProtocols
[in] The GUIDs of the protocols associated with the filter. The size of this variable is determined by the ProtocolsNumber parameter.
ProtocolsNumber
[in] The number of protocols associated with the filter.

Return Values

S_OK
The filter was installed successfully.
HRESULT_FROM_WIN32(ERROR_ALREADY_EXISTS)
The filter is already installed.

Remarks

The Microsoft Firewall service uses the CLSID of the filter when loading it. The name, description, vendor, and version string are used for displaying information about the filter in ISA Server Management, and are not parsed or interpreted by the service.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Wspfwext.idl.

See Also

IFWXFilterAdmin


IFWXFilterAdmin.RegisterProtocol (5 Parameters) method [ISA Server 2004]

IFWXFilterAdmin::RegisterProtocol

The RegisterProtocol method registers a protocol. A registered protocol will appear in ISA Server Management.

HRESULT RegisterProtocol(
  REFGUID guidProtocol,
  LPCSTR szProtocolName,
  LPCSTR szDescription,
  long ProtocolCategory,
  LPCSTR Reserved
);

Parameters

guidProtocol
[in] GUID that will be used for uniquely identifying the protocol.
szProtocolName
[in] Pointer to the name of the protocol as it is to appear in ISA Server Management.
szDescription
[in] Pointer to the description text for the protocol.
ProtocolCategory
[in] A 32-bit integer that specifies the category of the protocol. This can be a bitwise combination of values from the FpcProtocolCategory enumerated type.
Reserved
Reserved for future use. The Reserved parameter passes a null string.

Return Values

S_OK
The protocol was registered successfully.
HRESULT_FROM_WIN32(ERROR_ALREADY_EXISTS)
The protocol is already defined.
Error code
The protocol registration failed.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Wspfwext.idl.

See Also

IFWXFilterAdmin


IFWXFilterAdmin.UninstallFilter(REFCLSID) method [ISA Server 2004]

IFWXFilterAdmin::UninstallFilter

The UninstallFilter method removes the filter registration from the ISA Server configuration.

HRESULT UninstallFilter(
  REFCLSID guidFilter
);

Parameters

guidFilter
[in] Class identifier (CLSID) of the COM class that implements the IFWXFilter interface, representing the filter to uninstall.

Return Values

This method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

Use this method in an uninstall procedure.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Wspfwext.idl.

See Also

IFWXFilterAdmin


IFWXFilterAdmin.UnregisterProtocol(REFGUID) method [ISA Server 2004]

IFWXFilterAdmin::UnregisterProtocol

The UnregisterProtocol method unregisters a protocol that is controlled by a filter.

HRESULT UnregisterProtocol(
  REFGUID guidProtocol
);

Parameters

guidProtocol
[in] GUID of the protocol to be removed.

Return Values

S_OK
The protocol was removed successfully.
Error code
The protocol was not removed.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Wspfwext.idl.

See Also

IFWXFilterAdmin


IFWXFirewall interface [ISA Server 2004]

IFWXFirewall

The IFWXFirewall interface provides application filter access to Microsoft Firewall service functions that are not tied to any specific user session.

The Firewall service implements this interface and passes it to the IFWXFilter::FilterInit method.

Methods in Vtable Order

The IFWXFirewall interface inherits the methods of the standard COM interface IUnknown.

In addition, IFWXFirewall defines the following methods.

Method | Description
HookToCompletionPort | Associates a handle with the Firewall service completion port.
CreateOverlapped | Creates an overlapped object that supports the IFWXOverlapped interface for use with handles hooked to the completion port with the HookToCompletionPort method.
CreateNetworkSocket | Creates a socket object that works with the dynamic packet filtering scheme.
CreateConstBuffer | Creates a buffer object that wraps a user-supplied memory buffer.
CreateBuffer | Creates (allocates) a buffer object of the given size.
CreateWindowBuffer | Creates a buffer object that represents a window inside another buffer.
CreateIpFilter | Creates an IP filter object that implements the IFWXIpFilter interface.
StartHeavyBlockingOperation | Notifies the Firewall service that a thread is busy with a lengthy blocking operation.
EndHeavyBlockingOperation | Notifies the Firewall service that a lengthy blocking operation has ended.
GetClientSession | Retrieves or, if necessary, creates a session object for a specified client address.
CreatePrivateSession | Creates a private session object for a given client.
GetHostByName | Retrieves host information corresponding to a host name.
GetHostByAddr | Retrieves host information corresponding to an address.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Wspfwext.idl.

See Also

Filter Interfaces


IFWXFirewall.CreateBuffer(DWORD,IFWXIOBuffer) method [ISA Server 2004]

IFWXFirewall::CreateBuffer

The CreateBuffer method creates (allocates) a buffer object of the given size.

HRESULT CreateBuffer(
  DWORD dwBufferLength,
  IFWXIOBuffer** pIOBuffer
);

Parameters

dwBufferLength
[in] Number of bytes to allocate.
pIOBuffer
[out] Address of a variable that receives a pointer to the IFWXIOBuffer interface.

Return Values

This method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

Use the CreateBuffer method to create an empty buffer for data that is not constant. To create a buffer for data that is constant, use the IFWXFirewall::CreateConstBuffer method.

Filters are not required to use this method. A filter may provide its own buffer objects as long as they support the IFWXIOBuffer interface.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Wspfwext.idl.

See Also

IFWXFirewall, IFWXFirewall::CreateConstBuffer, IFWXFirewall::CreateWindowBuffer


IFWXFirewall.CreateConstBuffer(BYTE,DWORD,IFWXIOBuffer) method [ISA Server 2004]

IFWXFirewall::CreateConstBuffer

The CreateConstBuffer method creates a buffer object that wraps a user-supplied memory buffer.

HRESULT CreateConstBuffer(
  BYTE* pBuffer,
  DWORD dwBufferLength,
  IFWXIOBuffer** pIOBuffer
);

Parameters

pBuffer
[in] Pointer to the data buffer.
dwBufferLength
[in] Length, in bytes, of the buffer pointed to by the pBuffer parameter.
pIOBuffer
[out] Address of a variable that receives a pointer to the IFWXIOBuffer interface.

Return Values

This method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

Use only when the data is known to be a constant and the buffer memory does not have to be freed. To create a buffer for data that is not constant, use the IFWXFirewall::CreateBuffer method.


IFWXFirewall.CreateIpFilter(IFWXIpFilter) method [ISA Server 2004]

IFWXFirewall::CreateIpFilter

The CreateIpFilter method creates an IP filter object that implements the IFWXIpFilter interface.

HRESULT CreateIpFilter(
  IFWXIpFilter** ppIpFilter
);

Parameters

ppIpFilter
[out] Address of a variable that receives a pointer to the IFWXIpFilter interface.

Return Values

This method returns S_OK if the call is successful; otherwise, it returns an error code.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Wspfwext.idl.

See Also

IFWXFirewall


IFWXFirewall.CreateNetworkSocket(INT,IFWXNetworkSocket) method [ISA Server 2004]

IFWXFirewall::CreateNetworkSocket

The CreateNetworkSocket method creates a socket object that works with the dynamic packet filtering scheme.

HRESULT CreateNetworkSocket(
  INT Protocol,
  IFWXNetworkSocket** piSocket
);

Parameters

Protocol
[in] Protocol flags. This parameter can have the following flag values:
Value | Meaning
FWX_PROTOCOL_TCP | The method will create a TCP socket.
FWX_PROTOCOL_UDP | The method will create a UDP socket.
piSocket
[out] Address of a variable that receives a pointer to the IFWXNetworkSocket interface.

Return Values

This method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

Filters must use this interface and not call the Winsock dynamic-link library (DLL) directly to create a socket. The ISA Server socket object automatically opens packet filter ports required for any operation made with this socket. Sockets created with the Winsock DLL will not work with the dynamic packet filtering of ISA Server.

A socket created by this method is not associated with a specific user and will therefore always be successfully created regardless of ISA Server access policy. To create a socket that is user-specific, use the IFWXSession::CreateNetworkSocket method.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Wspfwext.idl.

See Also

IFWXFirewall


IFWXFirewall.CreateOverlapped(IFWXOverlapped) method [ISA Server 2004]

IFWXFirewall::CreateOverlapped

The CreateOverlapped method creates an overlapped object that supports the IFWXOverlapped interface for use with handles hooked to the completion port with the HookToCompletionPort method.

HRESULT CreateOverlapped(
  IFWXOverlapped** ppOverlapped
);

Parameters

ppOverlapped
[out] Address of a parameter that receives a pointer to the IFWXOverlapped interface.

Return Values

This method returns S_OK if the call is successful; otherwise, it returns an error code.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Wspfwext.idl.

See Also

IFWXFirewall, IFWXExternalIOCompletion


IFWXFirewall.CreatePrivateSession (6 Parameters) method [ISA Server 2004]

IFWXFirewall::CreatePrivateSession

The CreatePrivateSession method creates a private session object for a given client.

HRESULT CreatePrivateSession(
  LPSOCKADDR ClientAddress,
  DWORD ClientAddressLength,
  LPSOCKADDR ProxyInternalAddress,
  DWORD ProxyInternalAddressLength,
  IFWXAuthenticatedUser* AuthenticatedUser,
  IFWXSession** ppPrivateSession
);

Parameters

ClientAddress
[in] Pointer to a sockaddr structure that contains the address of the client for which the session object is needed.
ClientAddressLength
[in] Length, in bytes, of the structure pointed to by the ClientAddress parameter.
ProxyInternalAddress
[in] Pointer to a sockaddr structure that contains the internal address of the proxy used to communicate with the client.
ProxyInternalAddressLength
[in] Length, in bytes, of the structure pointed to by the ProxyInternalAddress parameter. On a multihomed computer, one with more than one internal interface, the filter uses this parameter to set which interface is to be used. Can be NULL, in which case the Microsoft Firewall service will select the internal interface.
AuthenticatedUser
[in] Pointer to an authenticated user object that will be used for impersonating the session's user. This parameter can be NULL, in which case only the client IP address will be used when processing rules.
ppPrivateSession
[out] Address of a parameter that receives a pointer to the IFWXSession interface on the newly created session.

Return Values

This method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

A private session object allows a filter to use an application level authentication scheme.

Private sessions may be needed in outbound and inbound scenarios.

Outbound scenario: Session objects are created automatically for Firewall service or SecureNAT client requests, but not when an application connects to an internal address of the ISA Server computer through an application filter. A filter that acts as an application level proxy may have to create a private session object by using the IFWXFirewall::CreatePrivateSession method to have access to session dependent functions.

Inbound Scenario: Inbound primary connections can be directed to a SecureNAT client by using the IFWXFirewall::CreatePrivateSession or IFWXFirewall::GetClientSession method. Use IFWXFirewall::CreatePrivateSession when the inbound connection has been requested by an application, the SecureNAT client is not known by the Firewall service, and no session object has been created. Use the IFWXFirewall::GetClientSession method only if the filter can assert that the client is configured to be a SecureNAT client of that server.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Wspfwext.idl.

See Also

IFWXFirewall


IFWXFirewall.CreateWindowBuffer (4 Parameters) method [ISA Server 2004]

IFWXFirewall::CreateWindowBuffer

The CreateWindowBuffer method creates a buffer object that represents a window inside another buffer.

HRESULT CreateWindowBuffer(
  IFWXIOBuffer* pIOBufferOriginal,
  DWORD dwOffset,
  DWORD dwLength,
  IFWXIOBuffer** pIOBuffer
);

Parameters

pIOBufferOriginal
[in] Pointer to the IFWXIOBuffer interface on the buffer object from which the window should be taken.
dwOffset
[in] Offset in the original buffer of the beginning of the window.
dwLength
[in] Length, in bytes, of the window.
pIOBuffer
[out] Address of a variable that receives a pointer to the IFWXIOBuffer interface.

Return Values

This method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This method allows you to point to a portion of a buffer, so that a portion of it can be sent.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Wspfwext.idl.

See Also

IFWXFirewall


IFWXFirewall.EndHeavyBlockingOperation method [ISA Server 2004]

IFWXFirewall::EndHeavyBlockingOperation

The EndHeavyBlockingOperation method notifies the Microsoft Firewall service that a lengthy blocking operation has ended. For more information, see the IFWXFirewall::StartHeavyBlockingOperation method.

HRESULT EndHeavyBlockingOperation();

Parameters

This method has no parameters.

Return Values

S_OK
The method succeeded.
FWX_E_NOT_IN_BLOCKING_OP
There is no blocking operation to end.

Remarks

This method should be called even when the IFWXFirewall::StartHeavyBlockingOperation method returns FWX_E_ALREADY_IN_BLOCKING_OP.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Wspfwext.idl.

See Also

IFWXFirewall


IFWXFirewall.GetClientSession (3 Parameters) method [ISA Server 2004]

IFWXFirewall::GetClientSession

The GetClientSession method retrieves or, if necessary, creates a session object for a specified client address.

HRESULT GetClientSession(
  LPSOCKADDR Address,
  DWORD AddressLength,
  IFWXSession** ppiClientSession
);

Parameters

Address
[in] Pointer to a sockaddr structure that contains the address of the client for which the session object is needed. The port is ignored.
AddressLength
[in] Length, in bytes, of the structure pointed to by the Address parameter.
ppiClientSession
[out] Address of an interface pointer that on return points to the IFWXSession interface on the session object for the client address specified.

Return Values

This method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

Inbound primary connections can be directed to a SecureNAT client by using the IFWXFirewall::CreatePrivateSession or IFWXFirewall::GetClientSession method. Use the IFWXFirewall::CreatePrivateSession method when the inbound connection was requested by an application, the SecureNAT client is not known by the Microsoft Firewall service, and no session object has been created. Use the IFWXFirewall::GetClientSession method only if the filter can assert that the client is configured to be a SecureNAT client of that server.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Wspfwext.idl.

See Also

IFWXFirewall


IFWXFirewall.GetHostByAddr(char,int,int,char,int) method [ISA Server 2004]

IFWXFirewall::GetHostByAddr

The GetHostByAddr method retrieves host information corresponding to an address.

HRESULT GetHostByAddr(
  const char* addr,
  int len,
  int type,
  char* buf,
  int* buflen
);

Parameters

addr
[in] Pointer to the network address for the host. Host addresses are stored in network byte order.
len
[in] Length of the address.
type
[in] Type of the address.
buf
[out] Pointer to the data area to receive the hostent data. The data area must be larger than the size of a hostent structure because the supplied data area is used by Windows Sockets to contain a hostent structure and all of the data referenced by members of the hostent structure. A buffer of MAXGETHOSTSTRUCT bytes is recommended.
buflen
[in, out] On input, specifies the size of the data area for the buf parameter. If the buffer is too small, the error code HRESULT_FROM_WIN32(ERROR_INSUFFICIENT_BUFFER) is returned and the buflen parameter receives the size of the required buffer.

Return Values

S_OK
Success, the buffer was filled with the host information.
HRESULT_FROM_WIN32(ERROR_INSUFFICIENT_BUFFER)
Insufficient buffer space was provided. That is, the buffer pointed to by the buf parameter is not large enough to contain the host information. For more information, see the description of the buflen parameter.
HRESULT_FROM_WIN32(WSAHOST_NOT_FOUND)
The address specified could not be found in the relevant database.
HRESULT_FROM_WIN32(WSATRY_AGAIN)
No response was received from an authoritative server.
HRESULT_FROM_WIN32(WSANO_DATA)
The address specified is valid and was found in the database, but no information of the type requested is associated with it.

Remarks

Unlike the IFWXSession::GetHostByAddr method, this method does not check permissions or policy rules, does not log the name resolution, and cannot use autodial to dial out for the name resolution.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Wspfwext.idl.

See Also

IFWXFirewall, IFWXSession::GetHostByAddr


IFWXFirewall.GetHostByName(char,char,int) method [ISA Server 2004]

IFWXFirewall::GetHostByName

The GetHostByName method retrieves host information corresponding to a host name. This method is similar to the Winsock gethostbyname function.

HRESULT GetHostByName(
  const char* name,
  char* buf,
  int* buflen
);

Parameters

name
[in] Pointer to a null-terminated string that specifies the name of the host. UTF-8 encoding is expected in this parameter.
buf
[out] Pointer to the data area to receive the hostent data. The data area must be larger than the size of a hostent structure because the supplied data area is used by Windows Sockets to contain a hostent structure and all of the data referenced by members of the hostent structure. A buffer of MAXGETHOSTSTRUCT bytes is recommended. The strings returned in the structure are encoded using the current system ANSI code page (ACP).
buflen
[in, out] On input, specifies the size of data area for the buf parameter. If the buffer is too small, the error code HRESULT_FROM_WIN32(ERROR_INSUFFICIENT_BUFFER) is returned and the buflen parameter receives the size of the required buffer.

Return Values

S_OK
Success, the buffer was filled with the host information.
HRESULT_FROM_WIN32(ERROR_INSUFFICIENT_BUFFER)
Insufficient buffer space was provided. That is, the buffer pointed to by the buf parameter is not large enough to contain the host information. For more information, see the description of the buflen parameter.
HRESULT_FROM_WIN32(WSAHOST_NOT_FOUND)
The name specified could not be found in the relevant database.
HRESULT_FROM_WIN32(WSATRY_AGAIN)
No response was received from an authoritative server.
HRESULT_FROM_WIN32(WSANO_DATA)
The name specified is valid and was found in the database, but no information of the type requested is associated with it.

Remarks

Unlike the IFWXSession::GetHostByName method, this method does not check permissions or policy rules, does not log the name resolution, and cannot use autodial to dial out for the name resolution.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Wspfwext.idl.

See Also

IFWXFirewall, IFWXSession::GetHostByName


IFWXFirewall.HookToCompletionPort(DWORD) method [ISA Server 2004]

IFWXFirewall::HookToCompletionPort

The HookToCompletionPort method associates a handle with the Microsoft Firewall service completion port. The caller must use overlapped structures that are provided by the Firewall service by using the IFWXOverlapped interface. Overlapped objects are obtained by calling the IFWXFirewall::CreateOverlapped method.

HRESULT HookToCompletionPort(
  DWORD handle
);

Parameters

handle
[in] Windows handle that should be associated with the Firewall service completion port.

Return Values

This method returns S_OK if the call is successful; otherwise, it returns an error code.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Wspfwext.idl.

See Also

IFWXFirewall, IFWXExternalIOCompletion


IFWXFirewall.StartHeavyBlockingOperation method [ISA Server 2004]

IFWXFirewall::StartHeavyBlockingOperation

The StartHeavyBlockingOperation method notifies the Microsoft Firewall service that a thread is busy with a lengthy blocking operation.

HRESULT StartHeavyBlockingOperation();

Parameters

This method has no parameters.

Return Values

S_OK
The method succeeded.
FWX_E_ALREADY_IN_BLOCKING_OP
The blocking operation is already started.

Remarks

The IFWXFirewall::StartHeavyBlockingOperation and IFWXFirewall::EndHeavyBlockingOperation methods manage the creation of additional completion port worker threads when all existing threads are blocked. The completion port model works best when all I/O operations are overlapped. When some calls are blocking, all worker threads may be blocked, and the service will be idle. When this method is used, the Firewall service keeps track of the number of threads that are busy with blocking operations and creates new threads when necessary.

Call the IFWXFirewall::StartHeavyBlockingOperation method before making a blocking operation such as a call to the gethostbyname function or reading (non-overlapped) from a file or a pipe. Call the IFWXFirewall::EndHeavyBlockingOperation method after the blocking call returns.

Do not call the IFWXFirewall::StartHeavyBlockingOperation method before waiting for a critical section or a resource on which other threads are likely to be blocked. If the newly created thread is blocked on the same critical section, there will be greater congestion on the critical section and more context switches, resulting in an overall reduction in performance.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Wspfwext.idl.

See Also

IFWXFirewall, IFWXFirewall::EndHeavyBlockingOperation


IFWXFirewall2 interface [ISA Server 2004]

IFWXFirewall2

The IFWXFirewall2 interface provides access to Microsoft Firewall service functions added for the Internet Security and Acceleration Server 2004.

Methods in Vtable Order

The IFWXFirewall2 interface inherits the methods of the standard COM interface IUnknown.

In addition, IFWXFirewall2 defines the following methods, including those inherited from IFWXFirewall.

Method | Description
HookToCompletionPort | Associates a handle with the Firewall service completion port.
CreateOverlapped | Creates an overlapped object that supports the IFWXOverlapped interface for use with handles hooked to the completion port with the HookToCompletionPort method.
CreateNetworkSocket | Creates a socket object that works with the dynamic packet filtering scheme.
CreateConstBuffer | Creates a buffer object that wraps a user-supplied memory buffer.
CreateBuffer | Creates (allocates) a buffer object of the given size.
CreateWindowBuffer | Creates a buffer object that represents a window inside another buffer.
CreateIpFilter | Creates an IP filter object that implements the IFWXIpFilter interface.
StartHeavyBlockingOperation | Notifies the Firewall service that a thread is busy with a lengthy blocking operation.
EndHeavyBlockingOperation | Notifies the Firewall service that a lengthy blocking operation has ended.
GetClientSession | Retrieves or, if necessary, creates a session object for a specified client address.
CreatePrivateSession | Creates a private session object for a given client.
GetHostByName | Retrieves host information corresponding to a host name.
GetHostByAddr | Retrieves host information corresponding to an address.
UpdateServiceStatus | Updates the service status.
PostTaskCompletion | Posts a one-time task into the completion port's queue. The one-time task is represented by the IFWXTaskCompletion interface.
CreateRadiusAuthenticator | Creates a RADIUS authenticator interface (IFWXRadiusAuthenticator), which can be used to authenticate RADIUS users.
GetNetConfigDetector | Gets the interface that registers for network configuration detection (NCD) notifications.
GetLowResourceRecoverer | Gets the interface that registers for low resource recovery operations. Use a low resource recovery operation when you want to retry an operation that fails due to low resource availability.
CreateSSLNetworkSocket | Creates a Secure Sockets Layer (SSL) socket object that works with the dynamic packet filtering scheme.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Wspfwext.idl.

See Also

Filter Interfaces, IFWXFirewall


IFWXFirewall2.CreateRadiusAuthenticator (1 Parameter) method [ISA Server 2004]

IFWXFirewall2::CreateRadiusAuthenticator

The CreateRadiusAuthenticator method creates a RADIUS authenticator interface (IFWXRadiusAuthenticator), which can be used to authenticate RADIUS users.

HRESULT CreateRadiusAuthenticator(
  IFWXRadiusAuthenticator** ppIFWXRadiusAuthenticator
);

Parameters

ppIFWXRadiusAuthenticator
[out] Address of an interface pointer that on return points to the new IFWXRadiusAuthenticator interface created.

Return Values

This method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

An application filter can use the IFWXFirewall2::CreateRadiusAuthenticator method to get the IFWXRadiusAuthenticator interface. When a request is received on a listener that has RADIUS authentication enabled, and the application filter needs to perform RADIUS authentication, it calls IFWXRadiusAuthenticator::AuthenticateRadiusUser and gives it a pointer to its IFWXAuthenticationCompletion callback.

A component that has to perform RADIUS authentication should first call this method to obtain a RADIUS authenticator interface from the Microsoft Firewall service. Then the component can use this interface to perform RADIUS authentication, by invoking its IFWXRadiusAuthenticator::AuthenticateRadiusUser method. The component can keep a single instance of the interface and repeatedly invoke its IFWXRadiusAuthenticator::AuthenticateRadiusUser method for each user that requires authentication. When the component no longer needs to perform RADIUS authentication, it can release the IFWXRadiusAuthenticator interface.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Wspfwext.idl.

See Also

IFWXFirewall2


IFWXFirewall2.CreateSSLNetworkSocket (10 Parameters) method [ISA Server 2004]

IFWXFirewall2::CreateSSLNetworkSocket

The CreateSSLNetworkSocket method creates an SSL socket object that works with the dynamic packet filtering scheme.

HRESULT CreateSSLNetworkSocket(
  BOOL fAskForClientCert,
  LPSTR pszHostName,
  DWORD dwHostNameLen,
  LONG* pCreds,
  LONG* pDefaultCreds,
  FwxSSLSocketSide eSide,
  DWORD dwDefaultSendTimeout,
  DWORD dwDefaultRecvTimeout,
  BOOL fAllowHTTPSTunnelingMode,
  IFWXNetworkSocket** ppiSslSocket
);

Parameters

fAskForClientCert
[in] Boolean value that specifies whether a client certificate is requested.
pszHostName
[in] Pointer to a null-terminated string containing the name of the server you are trying to connect to. The pszHostName parameter is needed for authentication.
dwHostNameLen
[in] The length of the host name.
pCreds
[in] Pointer to a 32-bit integer that specifies the credentials of the socket creator.
pDefaultCreds
[in] Pointer to a 32-bit integer that specifies the default credentials, which do not include a user name.
eSide
[in] Value from the FwxSSLSocketSide enumerated type that specifies whether the socket is on the server side or client side of ISA Server.
Value | Meaning
eServerSide | The socket is on the server side.
eClientSide | The socket is on the client side.
dwDefaultSendTimeout
[in] The default send time-out period.
dwDefaultRecvTimeout
[in] The default receive time-out period.
fAllowHTTPSTunnelingMode
[in] Boolean value that specifies whether HTTPS (SSL) tunneling mode is allowed.
ppiSslSocket
[out] Address of an interface pointer that on return points to the IFWXNetworkSocket interface created.

Return Values

This method returns S_OK if the call is successful; otherwise, it returns an error code.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Wspfwext.idl.

See Also

IFWXFirewall2


IFWXFirewall2.GetLowResourceRecoverer (1 Parameter) method [ISA Server 2004]

IFWXFirewall2::GetLowResourceRecoverer

The GetLowResourceRecoverer method gets the interface that registers for low resource recovery operations. Use a low resource recovery operation when you want to retry an operation that fails due to low resource availability. For more information see the IFWXLowResourceRecoverer interface.

HRESULT GetLowResourceRecoverer(
  IFWXLowResourceRecoverer** ppIFWXLowResourceRecoverer
);

Parameters

ppIFWXLowResourceRecoverer
[out] Indirect pointer to the IFWXLowResourceRecoverer interface.

Return Values

This method returns S_OK if the call is successful; otherwise, it returns an error code.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Wspfwext.idl.

See Also

IFWXFirewall2, IFWXLowResourceRecoverer


IFWXFirewall2.GetNetConfigDetector (1 Parameter) method [ISA Server 2004]

IFWXFirewall2::GetNetConfigDetector

The GetNetConfigDetector method gets the interface that registers for network configuration detection (NCD) notifications. For more information, see Using Network Configuration Detection.

HRESULT GetNetConfigDetector(
  IFWXNetConfigDetector** ppIFWXNetConfigDetector
);

Parameters

ppIFWXNetConfigDetector
[out] Indirect pointer to the IFWXNetConfigDetector interface.

Return Values

This method returns S_OK if the call is successful; otherwise, it returns an error code.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Wspfwext.idl.

See Also

IFWXFirewall2, Using Network Configuration Detection


IFWXFirewall2.PostTaskCompletion (2 Parameters) method [ISA Server 2004]

IFWXFirewall2::PostTaskCompletion

The PostTaskCompletion method posts a one-time task into the completion port's queue. The one-time task is represented by the IFWXTaskCompletion interface.

HRESULT PostTaskCompletion(
  IFWXTaskCompletion* pIFWXTaskCompletion,
  UserContextType UserData
);

Parameters

pIFWXTaskCompletion
[in] Pointer to the IFWXTaskCompletion interface.
UserData
[in] The UserData parameter is used for differentiation between completion notifications.

Return Values

This method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

The UserData parameter provides a context to the notification. You can use the same notification interface for a number of completion notifications and differentiate among them by using different values for the UserData parameter.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Wspfwext.idl.

See Also

IFWXFirewall2


IFWXFirewall2.UpdateServiceStatus(DWORD) method [ISA Server 2004]

IFWXFirewall2::UpdateServiceStatus

The UpdateServiceStatus method updates the service status.

HRESULT UpdateServiceStatus(
  DWORD dwWaitHint
);

Parameters

dwWaitHint
[in] The estimated time required, in milliseconds, for a pending stop operation.

Return Values

This method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

A filter can use this method to allow itself more time to shut down before the Service Control Manager kills a service.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Wspfwext.idl.

See Also

IFWXFirewall2


IFWXFirewallAction interface [ISA Server 2004]

IFWXFirewallAction

The IFWXFirewallAction interface cancels a firewall action.

Methods in Vtable Order

The IFWXFirewallAction interface inherits the methods of the standard COM interface IUnknown.

In addition, IFWXFirewallAction defines the following method.

Method | Description
Cancel | Cancels a Microsoft Firewall service action.

Remarks

A filter may request that the Firewall service perform a firewall action, such as connecting to a certain target, based on a firewall event or address. A firewall action is always requested in anticipation of an event that may not occur. This interface permits cancellation of the Firewall service action request. Typically, a firewall action relates only to events for which a filter is not registered.

For example, if the action is the future establishment of a secondary connection, the IFWXFirewallAction interface can be used to cancel the action if the primary connection is terminated.

The firewall may automatically cancel certain actions, including:

  • Actions that are supposed to happen only once (the action is canceled after its first occurrence).
  • Actions that have a time-out.
  • An action associated with a session that has been killed.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Wspfwext.idl.

See Also

Filter Interfaces


IFWXFirewallAction.Cancel method [ISA Server 2004]

IFWXFirewallAction::Cancel

The Cancel method cancels a Microsoft Firewall service action.

HRESULT Cancel();

Parameters

This method has no parameters.

Return Values

S_OK
The method succeeded.
FWX_E_TERMINATING
The action has already been canceled.

Remarks

The Firewall service can automatically cancel certain actions, including:

  • Actions that are supposed to happen only once (the action is canceled after its first occurrence).
  • Actions that have a time-out.
  • An action associated with a session that has been killed.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Wspfwext.idl.

See Also

IFWXFirewallAction, IFWXSession::AllowFutureConnect, IFWXSession::SetDataFilterFactory


IFWXGetXByY interface [ISA Server 2004]

IFWXGetXByY

The IFWXGetXByY interface allows a filter to modify the result of remote gethostbyname or gethostbyaddr function calls made by a Firewall client.

Methods in Vtable Order

The IFWXGetXByY interface inherits the methods of the standard COM interface IUnknown.

In addition, IFWXGetXByY defines the following methods.

Method | Description
Deny | Denies the name resolution request.
SetResult | Sets the hostent structure that will be returned.

Remarks

The IFWXGetXByY interface is essentially used to override the gethostbyname or gethostbyaddr functions, returning a hostent structure with different contents than would have been returned by the unfiltered calls. The filter has to call this interface from within the IFWXSessionFilter::FirewallEventHandler method.

A typical use of this interface would be to return an IP address other than that requested by the client; that is, to redirect the request.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Wspfwext.idl.

See Also

Filter Interfaces


IFWXGetXByY.Deny(DWORD) method [ISA Server 2004]

IFWXGetXByY::Deny

The Deny method denies the name resolution request.

HRESULT Deny(
  DWORD Reserved
);

Parameters

Reserved
Reserved for future use. The parameter value must be zero.

Return Values

S_OK
The Deny method succeeded.
FWX_E_TERMINATING
The IFWXGetXByY interface is no longer valid.

Remarks

FWX_E_TERMINATING would be returned if the filter called this method from any point other than within the IFWXSessionFilter::FirewallEventHandler method because the IFWXGetXByY interface can no longer affect the results.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Wspfwext.idl.

See Also

IFWXGetXByY, FwxGetHostByAddrEvent, FwxGetHostByNameEvent


IFWXGetXByY.SetResult(LPHOSTENT) method [ISA Server 2004]

IFWXGetXByY::SetResult

The SetResult method sets the hostent structure that will be returned.

HRESULT SetResult(
  LPHOSTENT Hostent
);

Parameters

Hostent
[in] Pointer to a hostent structure that will be returned to the client.

Return Values

S_OK
The method succeeded.
FWX_E_TERMINATING
The object is no longer valid.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Wspfwext.idl.

See Also

IFWXGetXByY, FwxGetHostByAddrEvent, FwxGetHostByNameEvent


IFWXImpersonator interface [ISA Server 2004]

IFWXImpersonator

The IFWXImpersonator interface holds user information so that the Microsoft Firewall service can impersonate the user.

Methods in Vtable Order

The IFWXImpersonator interface inherits the methods of the standard COM interface IUnknown.

In addition, IFWXImpersonator defines the following methods.

Method | Description
Impersonate | Impersonates the authenticated user.
RevertToSelf | Reverts to the original user account after a successful call to the Impersonate method.

Remarks

Impersonators are typically implemented by the Firewall service (through the IFWXImpersonator interface that the applicable IFWXAuthenticatedUser interface inherits), as in the case when the service is performing an access check. This holds true for sessions that were created by the Firewall service.

Impersonators can also be implemented by filters that hold user credentials and are designed to function as application gateways. Such a filter can use the user credentials to implement the IFWXAuthenticatedUser interface (that inherits from IFWXImpersonator). The filter can create a session associated with a specific user by using the IFWXFirewall::CreatePrivateSession method, and providing it with the IFWXAuthenticatedUser interface that represents the applicable user.

A filter that needs to perform an access check for the user associated with a given session can do so by calling the IFWXSession::GetAuthenticatedUser method to retrieve the applicable IFWXAuthenticatedUser interface, and then calling the inherited IFWXImpersonator::Impersonate and IFWXImpersonator::RevertToSelf methods on that interface. These methods will invoke the corresponding methods of the IFWXImpersonator interface that is associated with the session object (regardless of whether it is implemented by the Firewall service or by an application filter).

For such a session, impersonation is performed by the application filter on behalf of the Firewall service through the IFWXAuthenticatedUser interface provided to the IFWXFirewall::CreatePrivateSession method.

Impersonators must be implemented as in-process servers.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Wspfwext.idl.

See Also

Filter Interfaces, IFWXFirewall::CreatePrivateSession


IFWXImpersonator.Impersonate method [ISA Server 2004]

IFWXImpersonator::Impersonate

The Impersonate method impersonates the authenticated user.

HRESULT Impersonate();

Parameters

This method has no parameters.

Return Values

S_OK
The impersonation succeeded.
FWX_E_NOT_AUTHENTICATED
Cannot impersonate the user because the session is not authenticated.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Wspfwext.idl.

See Also

IFWXImpersonator


IFWXImpersonator.RevertToSelf method [ISA Server 2004]

IFWXImpersonator::RevertToSelf

The RevertToSelf method reverts to the original user account after a successful call to the IFWXImpersonator::Impersonate method.

HRESULT RevertToSelf();

Parameters

This method has no parameters.

Return Values

This method returns S_OK if the call is successful; otherwise, it returns an error code.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Wspfwext.idl.

See Also

IFWXImpersonator


IFWXIOBuffer interface [ISA Server 2004]

IFWXIOBuffer

The IFWXIOBuffer interface points to a reference counted memory buffer and provides the means of managing the buffer. The interface is a wrapper around a memory buffer. This allows the buffer to be used by many filters in a chain, avoiding the inefficient copying of buffers. For more information on memory buffers, see Buffer Objects.

The following rules apply to these buffers:

  • The allocator of a buffer owns the buffer. Only the allocator may alter the contents of the buffer. This means that the receiver must not modify a buffer received in the IFWXIOCompletion::CompleteAsyncIO method after a call to the IFWXSocket::Recv method with the IOBuffer parameter set to NULL.
  • A buffer that is sent (by way of the IFWXSocket::Send or IFWXSocket::SendTo method) must remain valid and unmodified until the reference count reaches zero. Even the owner of the buffer is not allowed to modify a buffer after it is sent.

The IFWXSocket::Send, IFWXSocket::SendTo, and IFWXSocket::Recv methods increment the reference count on the buffer. This reference count is maintained until the IFWXIOCompletion::CompleteAsyncIO method returns. You must call the Release method for each AddRef method that you called, and once more if you also created the buffer. Call AddRef if you keep a pointer to the buffer.

Methods in Vtable Order

The IFWXIOBuffer interface inherits the methods of the standard COM interface IUnknown.

In addition, IFWXIOBuffer defines the following methods.

Method | Description
GetBufferAndSize | Gets the actual data from the memory buffer, and the actual size (not the allocated size) of the buffer.
SetDataSize | Sets the actual size of the memory buffer that was used.
Append | Appends a specified number of bytes of data to the buffer object.
ReadAt | Reads a specified number of bytes starting at a specified offset from the beginning of the buffer.
SendToBuffer | Copies a specified number of bytes starting at a specified offset from the beginning of the buffer to the given destination buffer.
GetBufferSizes | Gets the allocated and actual buffer sizes.

Remarks

Consider the size of the buffer needed. Data length information provided on the Internet may be inaccurate and may result in a buffer overflow.

This interface is generally implemented by the Microsoft Firewall service. You may want to implement IFWXIOBuffer in your filter if:

  • You already have an allocated buffer that you want to send, and want to avoid creating a buffer copy. For example, the buffer was received from a remote procedure call (RPC) or an API that cannot work with the Firewall service buffers.
  • You have to read into a preallocated buffer.
  • You want to use your own allocator for the buffer.

You can rely on the Firewall service implementation of IFWXIOBuffer, and not code a filter implementation, if:

  • You want to send a constant buffer.
  • You want to send a section of another buffer.
  • Your filter can handle or parse the data from IFWXIOBuffer
  • Buffer copy is not of concern.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Wspfwext.idl.

See Also

Filter Interfaces


IFWXIOBuffer.Append(void const,ULONG,ULONG) method [ISA Server 2004]

IFWXIOBuffer::Append

The Append method appends a specified number of bytes of data to the buffer object.

HRESULT Append(
  void const* pv,
  ULONG cb,
  ULONG* pcbWritten
);

Parameters

pv
[in] Pointer to the buffer that is appended to the buffer object.
cb
[in] The number of bytes of data to attempt to append to the data in the buffer object.
pcbWritten
[out] Pointer to a ULONG that on return receives the actual number of bytes appended to the data in the buffer object.

Return Values

S_OK
The data was successfully appended to the buffer object.
FWX_E_BUFFERFULL
Not all the data was appended to the buffer object because the buffer is full.

Remarks

This method does not resize the buffer. The pcbWritten parameter is valid even if a FWX_E_BUFFERFULL error is returned.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Wspfwext.idl.

See Also

IFWXIOBuffer


IFWXIOBuffer.GetBufferAndSize(BYTE,DWORD) method [ISA Server 2004]

IFWXIOBuffer::GetBufferAndSize

The GetBufferAndSize method gets the actual data from the memory buffer, and the actual size (not the allocated size) of the buffer.

HRESULT GetBufferAndSize(
  BYTE** ppBuffer,
  DWORD* pdwSize
);

Parameters

ppBuffer
[out] Address of a variable that receives a pointer to the buffer.
pdwSize
[out] Pointer to the DWORD data type that receives the actual size, in bytes, of the buffer.

Return Values

S_OK
The method succeeded.
E_NOTIMPL
Returned if the client and server are not in the same apartment. This may happen if the filter is not an in-process server.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Wspfwext.idl.

See Also

IFWXIOBuffer


IFWXIOBuffer.GetBufferSizes(LPDWORD,LPDWORD) method [ISA Server 2004]

IFWXIOBuffer::GetBufferSizes

The GetBufferSizes method gets the allocated and actual buffer sizes.

HRESULT GetBufferSizes(
  LPDWORD pdwAllocatedSize,
  LPDWORD pdwActualSize
);

Parameters

pdwAllocatedSize
[out] Pointer to a variable that receives the allocated buffer size. The allocated size is the maximum number of bytes that the buffer can hold.
pdwActualSize
[out] Pointer to a variable that receives the actual buffer size. The actual buffer size is the number of valid data bytes that the buffer currently holds.

Return Values

S_OK
The method succeeded.
E_POINTER
Null pointer argument.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Wspfwext.idl.

See Also

IFWXIOBuffer


IFWXIOBuffer.ReadAt(ULONG,void,ULONG,ULONG) method [ISA Server 2004]

IFWXIOBuffer::ReadAt

The ReadAt method reads a specified number of bytes starting at a specified offset from the beginning of the buffer.

HRESULT ReadAt(
  ULONG ulOffset,
  void* pv,
  ULONG cb,
  ULONG* pcbRead
);

Parameters

ulOffset
[in] Specifies the starting point from the beginning of the buffer for reading data.
pv
[out] Pointer to the buffer into which the buffer content is copied.
cb
[in] Specifies the number of bytes to attempt to read from the byte buffer.
pcbRead
Pointer to a location where this method writes the actual number of bytes copied from the buffer. You can set this pointer to NULL to indicate that you are not interested in this value. In this case, this method does not provide the actual number of bytes copied.

Return Values

S_OK
The method succeeded.
E_INVALIDARG
Invalid parameter.
E_POINTER
Null pointer argument.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Wspfwext.idl.

See Also

IFWXIOBuffer


IFWXIOBuffer.SendToBuffer (4 Parameters) method [ISA Server 2004]

IFWXIOBuffer::SendToBuffer

The SendToBuffer method copies a specified number of bytes starting at a specified offset from the beginning of the buffer to the given destination buffer.

HRESULT SendToBuffer(
  IFWXIOBuffer* pDestinationBuffer,
  ULONG ulOffset,
  ULONG cb,
  ULONG* pcbCopied
);

Parameters

pDestinationBuffer
[in] Buffer to which the data will be copied.
ulOffset
[in] Specifies the starting point from the beginning of the buffer for reading data.
cb
[in] Specifies the number of bytes to attempt to copy to the destination buffer.
pcbCopied
[out] Pointer to a ULONG that on return receives the actual number of bytes copied to the destination buffer object.

Return Values

S_OK
The method succeeded.
E_NOTIMPL
Returned if the client and server are not in the same apartment. This may happen if the filter is not an in-process server.
FWX_E_BUFFERFULL
The destination buffer does not have enough room to receive all the data. The pcbCopied parameter will contain the number of bytes that were actually copied.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Wspfwext.idl.

See Also

IFWXIOBuffer


IFWXIOBuffer.SetDataSize(DWORD) method [ISA Server 2004]

IFWXIOBuffer::SetDataSize

The SetDataSize method sets the actual size of the memory buffer that was used.

HRESULT SetDataSize(
  DWORD dwDataSize
);

Parameters

dwDataSize
[in] The actual size, in bytes, of the buffer that was used.

Return Values

S_OK
The data was successfully appended to the buffer object.
E_INVALIDARG
Requested size is larger than the allocated size.

Remarks

The IFWXIOBuffer::SetDataSize method can be called by a filter after buffer content is manipulated directly by means of IFWXIOBuffer::GetBufferAndSize.

The IFWXIOBuffer::SetDataSize method can also be called by the Microsoft Firewall service, when a buffer is passed to the IFWXSocket::Recv method, to set the number of bytes actually received.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Wspfwext.idl.

See Also

IFWXIOBuffer


IFWXIOCompletion interface [ISA Server 2004]

IFWXIOCompletion

The IFWXIOCompletion interface includes a method that receives a notification from the Microsoft Firewall service when an asynchronous I/O send, sendto, or receive operation is completed on an IFWXSocket interface. These overlapped operations require that the filter implement this interface to carry out data pumping.

When To Implement

An application filter that initiates overlapped operations by calling the asynchronous methods on an IFWXSocket interface must implement this notification interface.

Methods in Vtable Order

The IFWXIOCompletion interface inherits the methods of the standard COM interface IUnknown.

In addition, IFWXIOCompletion defines the following method.

Method | Description
CompleteAsyncIO | Receives a notification from the Firewall service when an asynchronous I/O operation that was initiated on an IFWXSocket interface completes.

Remarks

When calling a method that begins an overlapped operation, the filter must pass a pointer to its IFWXIOCompletion interface to that method. The Firewall service calls CompleteAsyncIO on the IFWXIOCompletion interface of the filter when the overlapped operation completes.

ISA Server has two other notification methods for overlapped operations. The IFWXExternalIOCompletion::CompleteAsyncIO notification method is used for notification when a Windows overlapped operation completes, and the IFWXAcceptCompletion::CompleteAsyncAccept method is used for notification when the IFWXNetworkSocket::Accept method completes.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Wspfwext.idl.

See Also

Filter Interfaces, IFWXSocket::Recv, IFWXSocket::Send, IFWXSocket::SendTo


IFWXIOCompletion.CompleteAsyncIO (6 Parameters) method [ISA Server 2004]

IFWXIOCompletion::CompleteAsyncIO

The CompleteAsyncIO method receives a notification from the Microsoft Firewall service when an asynchronous I/O operation that was initiated on an IFWXSocket interface completes.

The CompleteAsyncIO method is where you should implement the logic of your filter, based on the protocol in which you are working.

HRESULT CompleteAsyncIO(
  BOOL fSuccess,
  DWORD Win32ErrorCode,
  IFWXIOBuffer* pIOBuffer,
  UserContextType UserData,
  LPSOCKADDR ExternalAddress,
  INT ExternalAddressLength
);

Parameters

fSuccess
[in] Success flag. If TRUE, the I/O operation succeeded. If FALSE, it failed.
Win32ErrorCode
[in] Windows error code. This parameter is defined only if the fSuccess parameter is FALSE.
pIOBuffer
[in] Pointer to the IFWXIOBuffer interface for the data buffer, if this is a completion for a receive method.
UserData
[in] The UserData parameter that was passed to the I/O method.
ExternalAddress
[in] Pointer to a sockaddr structure that contains the address of the external source or external destination of a UDP packet. This parameter is passed only for the IFWXSocket::Recv method on a UDP socket. The ExternalAddress parameter is NULL for TCP sockets.

The address is the source when receiving from an external socket, and the target when receiving from an internal socket.

Note that IP packets on the Internet can be made to appear as though they are authorized when they are not. Therefore, do not rely on this address for authentication.

ExternalAddressLength
[in] Length, in bytes, of the ExternalAddress parameter.

Return Values

Implementations of this method should return S_OK if the call is successful; otherwise, they should return an error code.

Remarks

Completion of a send or sendto operation indicates only that the next filter in the chain of filters received the buffer and began processing it. The buffer cannot be recycled at this point.

The UserData parameter provides a context to the notification. You can use the same notification interface for completion notifications from distinct network socket objects and differentiate between them by using different values for the UserData parameter.

Example Code

The following example implementation of the IFWXIOCompletion::CompleteAsyncIO method is taken from the Exeblock sample filter.

HRESULT
CEBScannerDataFilter::CompleteAsyncIO(
    IN BOOL         fSuccess,
    IN DWORD        Win32ErrorCode,
    IN IFWXIOBuffer *pIOBuffer,
    IN DWORD        dwUserData,
    IN PSOCKADDR    From,
    IN INT          FromLen
    )
{
    UNREFERENCED_PARAMETER(FromLen);
    UNREFERENCED_PARAMETER(From);
    UNREFERENCED_PARAMETER(Win32ErrorCode);

    DWORD DataLength = 0;
    HRESULT hr;
    PBYTE pbBuffer = NULL;

    if (pIOBuffer)
    {
        pIOBuffer->GetBufferAndSize(&pbBuffer, &DataLength);
    }

    if (UserData == 0)
    {
        if (!fSuccess)
        {
            // The _Abort method closes and releases
            // both sockets.
            _Abort();
            return S_OK;
        }

        if (DataLength == 0)
        {
            // The _ScanFile method scans the file, blocks it if it is
            // an executable, and sends it to the client if it is OK.
            _ScanFile();
            return S_OK;
        }

        IFWXOverlapped * pOverlapped = NULL;

        hr = m_spCallBackInterface->CreateOverlapped(&pOverlapped);

        OVERLAPPED *pov = NULL;

        if (SUCCEEDED(hr))
        {
            hr = pOverlapped->GetOverlapped(&pov);
        }

        if (SUCCEEDED(hr))
        {
            hr = pOverlapped->SetNotificationInterface(this, 0);
        }

        if (FAILED(hr))
        {
            if (pOverlapped) pOverlapped->Release();
            _Abort();
            return hr;
        }

        pov->Offset = m_FileSize;
        m_FileSize += DataLength;
        if (!WriteFile(
            m_FileHandle,
            pbBuffer,
            DataLength,
            NULL,
            pov) && GetLastError() != ERROR_IO_PENDING)
        {
            pOverlapped->Release();
            _Abort();
        }

    }
    else
    {
        if (fSuccess)
        {
            _WriteNextChunk();
        }
        else
        {
            _Abort();
        }
    }

    return S_OK;
}

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Wspfwext.idl.

See Also

IFWXIOCompletion


IFWXIpFilter interface [ISA Server 2004]

IFWXIpFilter

The IFWXIpFilter interface is the application filter interface that represents an IP filter, which is a range of IP addresses for which a connection or socket is allowed to function. Use this interface to ensure that secondary and emulated connections are secure.

Methods in Vtable Order

The IFWXIpFilter interface inherits the methods of the standard COM interface IUnknown.

In addition, IFWXIpFilter defines the following methods.

Method | Description
IncludeRange | Includes a range of IP addresses in the IP filter.
ExcludeRange | Excludes a range of IP addresses from the IP filter.
IncludeFilter | Includes in the IP filter a range of IP addresses represented by an existing IP filter.
ExcludeFilter | Excludes from the IP filter a range of IP addresses represented by an existing IP filter.
IsIncluded | Checks if a particular IP address is included in the ranges of those allowed by the IP filter.
Compare | Compares the IP ranges of two IP filters.
Clone | Returns a copy of an IP filter. The copy will contain the same ranges of IP addresses as the original.

Remarks

There are situations in which an application filter is responsible for limiting what IP addresses are allowed access, including:

  • The case of a secondary inbound connection, as occurs in use of the FTP protocol. Use the IFWXIpFilter interface in the FTP scenario to restrict the access to the inbound socket of the secondary connection. For example, an FTP application filter opens a secondary connection with a range that includes only the IP address of the FTP server. All IP packets with a source address that is not the IP address of the FTP server will be rejected by the packet filter driver if they are addressed to the socket that the FTP application filter created for the secondary connection.
  • The case of a secondary or emulated connection in a publishing scenario.

For security purposes, the application filter has to define an IP filter, which is a range of IP addresses for which a particular connection or socket is allowed. The IFWXIpFilter interface is where you define that range of IP addresses.

Note If you set the range of IP addresses equal to NULL, you are allowing all addresses to connect.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Wspfwext.idl.

See Also

Filter Interfaces, IFWXConnection, IFWXFirewall::CreateIpFilter, IFWXNetworkSocket, IFWXSession


IFWXIpFilter.Clone(IFWXIpFilter) method [ISA Server 2004]

IFWXIpFilter::Clone

The Clone method returns a copy of an IP filter. The copy will contain the same ranges of IP addresses as the original.

HRESULT Clone(
  IFWXIpFilter** ppIpFilter
);

Parameters

ppIpFilter
[out] Address of a variable that receives a pointer to the IFWXIpFilter interface.

Return Values

This method returns S_OK if the call is successful; otherwise, it returns an error code.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Wspfwext.idl.

See Also

IFWXIpFilter


IFWXIpFilter.Compare(IFWXIpFilter) method [ISA Server 2004]

IFWXIpFilter::Compare

The Compare method compares the IP ranges of two IP filters.

HRESULT Compare(
  IFWXIpFilter* pIpFilter
);

Parameters

pIpFilter
[in] Pointer to the IFWXIpFilter interface.

Return Values

S_OK
The ranges are equal.
S_FALSE
The ranges are not equal.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Wspfwext.idl.

See Also

IFWXIpFilter


IFWXIpFilter.ExcludeFilter(IFWXIpFilter) method [ISA Server 2004]

IFWXIpFilter::ExcludeFilter

The ExcludeFilter method excludes from the IP filter a range of IP addresses represented by an existing IP filter.

HRESULT ExcludeFilter(
  IFWXIpFilter* pIpFilter
);

Parameters

pIpFilter
[in] Pointer to the IFWXIpFilter interface.

Return Values

This method returns S_OK if the call is successful; otherwise, it returns an error code.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Wspfwext.idl.

See Also

IFWXIpFilter


IFWXIpFilter.ExcludeRange(IN_ADDR,IN_ADDR) method [ISA Server 2004]

IFWXIpFilter::ExcludeRange

The ExcludeRange method excludes a range of IP addresses from the IP filter.

HRESULT ExcludeRange(
  IN_ADDR IP_From,
  IN_ADDR IP_To
);

Parameters

IP_From
[in] Lower end of IP range to exclude.
IP_To
[in] Upper end of IP range to exclude.

Return Values

This method returns S_OK if the call is successful; otherwise, it returns an error code.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Wspfwext.idl.

See Also

IFWXIpFilter


IFWXIpFilter.IncludeFilter(IFWXIpFilter) method [ISA Server 2004]

IFWXIpFilter::IncludeFilter

The IncludeFilter method includes in the IP filter a range of IP addresses represented by an existing IP filter.

HRESULT IncludeFilter(
  IFWXIpFilter* pIpFilter
);

Parameters

pIpFilter
[in] Pointer to the IFWXIpFilter interface.

Return Values

This method returns S_OK if the call is successful; otherwise, it returns an error code.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Wspfwext.idl.

See Also

IFWXIpFilter


IFWXIpFilter.IncludeRange(IN_ADDR,IN_ADDR) method [ISA Server 2004]

IFWXIpFilter::IncludeRange

The IncludeRange method includes a range of IP addresses in the IP filter.

HRESULT IncludeRange(
  IN_ADDR IP_From,
  IN_ADDR IP_To
);

Parameters

IP_From
[in] Lower end of IP range to include.
IP_To
[in] Upper end of IP range to include.

Return Values

This method returns S_OK if the call is successful; otherwise, it returns an error code.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Wspfwext.idl.

See Also

IFWXIpFilter


IFWXIpFilter.IsIncluded(IN_ADDR) method [ISA Server 2004]

IFWXIpFilter::IsIncluded

The IsIncluded method checks if a particular IP address is included in the ranges of those allowed by the IP filter.

HRESULT IsIncluded(
  IN_ADDR IP
);

Parameters

IP
IP address to check.

Return Values

S_OK
The address is included.
S_FALSE
The address is not included.

Remarks

Based on the value returned by the IFWXIpFilter::IsIncluded method, you can decide whether to initiate a connection. There is no automatic effect upon the connection. For example, you may use this method in the following way:

  1. Call the IFWXConnection::GetIpFilter method on a connection object, such as a listening connection object.
  2. Use the IFWXIpFilter::IsIncluded method to check if a specific IP address is included in the ranges specified by the filter.
  3. If the address is not included in the range, you can decide not to initiate the connection.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Wspfwext.idl.

See Also

IFWXIpFilter


IFWXLowResourceRecoverer interface [ISA Server 2004]

IFWXLowResourceRecoverer

The IFWXLowResourceRecoverer interface is the application filter interface that registers and unregisters an application filter for low resource recovery operations, and signals when a low resource recovery failure occurs. For a description of the low resource recovery process, see the Remarks section of this topic.

Methods in Vtable Order

The IFWXLowResourceRecoverer interface inherits the methods of the standard COM interface IUnknown.

In addition, IFWXLowResourceRecoverer defines the following methods.

Method | Description
RegisterForLowResourceRecovery | Registers an application filter for low resource recovery operations.
UnregisterFromLowResourceRecovery | Unregisters an application filter from a low resource recovery operation.
SignalLowResourceFailure | Signals the Microsoft Firewall service that a failure related to low resources has occurred.

Remarks

To use the low resource recovery mechanism, your filter has to register with the Firewall service using the IFWXLowResourceRecoverer::RegisterForLowResourceRecovery method so that the filter will handle failures. When a failure occurs, the filter can check the error message to ascertain whether the failure was caused by low resource availability. If so, the filter has to call the IFWXLowResourceRecoverer::SignalLowResourceFailure method, providing a cookie identifying the failure, and indicating to the Firewall service that the filter wants to recover from the failure. The Firewall service then calls the IFWXLowResourceRecoveryOperation::Recover method, which can retry the operation periodically until it succeeds.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Wspfwext.idl.

See Also

Filter Interfaces


IFWXLowResourceRecoverer.RegisterForLowResourceRecovery method [ISA Server 2004]

IFWXLowResourceRecoverer::RegisterForLowResourceRecovery

The RegisterForLowResourceRecovery method registers an application filter for low resource recovery operations.

HRESULT RegisterForLowResourceRecovery(
  IFWXLowResourceRecoveryOperation* pFWXLowResourceRecoveryOperation,
  DWORD UserData,
  DWORD* Cookie
);

Parameters

pFWXLowResourceRecoveryOperation
[in] A pointer to an IFWXLowResourceRecoveryOperation interface.
UserData
[in] Provides a context for the operation.
Cookie
[out] Pointer to an identifier used by the IFWXLowResourceRecoverer interface to differentiate between recovery registrations.

Return Values

This method returns S_OK if the call is successful; otherwise, it returns an error code.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Wspfwext.idl.

See Also

IFWXLowResourceRecoverer, IFWXLowResourceRecoveryOperation


IFWXLowResourceRecoverer.SignalLowResourceFailure method [ISA Server 2004]

IFWXLowResourceRecoverer::SignalLowResourceFailure

The SignalLowResourceFailure method signals the Microsoft Firewall service that a failure related to low resources has occurred.

HRESULT SignalLowResourceFailure(
  DWORD hCookie
);

Parameters

hCookie
[in] Identifier that indicates where the failure occurred.

Return Values

This method returns S_OK if the call is successful; otherwise, it returns an error code.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Wspfwext.idl.

See Also

IFWXLowResourceRecoverer, IFWXLowResourceRecoveryOperation


UnRegisterFromLowResourceRecovery method [ISA Server 2004]

IFWXLowResourceRecoverer::UnRegisterFromLowResourceRecovery

The UnRegisterFromLowResourceRecovery method unregisters an application filter from a low resource recovery operation.

HRESULT UnRegisterFromLowResourceRecovery(
  DWORD hCookie
);

Parameters

hCookie
Pointer to an identifier used by the IFWXLowResourceRecoverer interface to differentiate between recovery registrations.

Return Values

This method returns S_OK if the call is successful; otherwise, it returns an error code.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Wspfwext.idl.

See Also

IFWXLowResourceRecoverer


IFWXLowResourceRecoveryOperation interface [ISA Server 2004]

IFWXLowResourceRecoveryOperation

The IFWXLowResourceRecoveryOperation interface is the application filter interface that you implement to respond when a low resource failure occurs. For a description of the low resource recovery mechanism, see the Remarks section of this topic.

Methods in Vtable Order

The IFWXLowResourceRecoveryOperation interface inherits the methods of the standard COM interface IUnknown.

In addition, IFWXLowResourceRecoveryOperation defines the following method.

Method | Description
Recover | Implemented so that your application filter responds appropriately to a failure caused by low resources.

Remarks

To use the low resource recovery mechanism, your filter has to register with the Microsoft Firewall service using the IFWXLowResourceRecoverer::RegisterForLowResourceRecovery method so that the filter will handle failures. When a failure occurs, the filter can check the error message to ascertain whether the failure was caused by low resource availability. If so, the filter calls the IFWXLowResourceRecoverer::SignalLowResourceFailure method, providing a cookie identifying the failure, and indicating to the Firewall service that the filter wants to recover from the failure. The Firewall service then calls the IFWXLowResourceRecoveryOperation::Recover method, which can retry the operation periodically until it succeeds.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Wspfwext.idl.

See Also

Filter Interfaces


IFWXLowResourceRecoveryOperation.Recover(DWORD) method [ISA Server 2004]

IFWXLowResourceRecoveryOperation::Recover

The Recover method is implemented so that your application filter responds appropriately to a failure caused by low resources. For example, if an operation failed because of insufficient memory, you can implement the Recover method to cause the filter to retry the operation.

HRESULT Recover(
  DWORD UserData
);

Parameters

UserData
[in] Provides a context for the operation.

Return Values

This method returns S_OK if the call is successful; otherwise, it returns an error code.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Wspfwext.idl.

See Also

IFWXLowResourceRecoveryOperation


IFWXNetConfigDetectionNotification interface [ISA Server 2004]

IFWXNetConfigDetectionNotification

The IFWXNetConfigDetectionNotification interface includes a method for receiving a notification about a network configuration detection (NCD) event from the Microsoft Firewall service. An NCD event indicates that a change has been made to the network configuration. By registering for these events, an application filter can react appropriately to changes in network configuration. For example, if your application filter listens for Firewall service events on a particular network, you can use NCD events so that the filter can respond to changes to the network configuration, such as the addition of a network adapter. The filter can then be aware of where to listen for Firewall service events, even though the network configuration has changed. For more information, see Using Network Configuration Detection.

For more information about NCD events, see the FwxNcdEvent structure, the FwxNcdEventType enumerated type, and the FwxNcdEventParameters union.

When To Implement

An application filter that needs to receive notifications about NCD events from the Firewall service and handle these events must implement this notification interface.

Methods in Vtable Order

The IFWXNetConfigDetectionNotification interface inherits the methods of the standard COM interface IUnknown.

In addition, IFWXNetConfigDetectionNotification defines the following method.

Method | Description
NotifyNetworkChange | Receives a notification from the Firewall service about a network configuration detection (NCD) event and handles the event. Application filters must implement this method to handle NCD events.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Wspfwext.idl.

See Also

Filter Interfaces


IFWXNetConfigDetectionNotification.NotifyNetworkChange method [ISA Server 2004]

IFWXNetConfigDetectionNotification::NotifyNetworkChange

The NotifyNetworkChange method receives a notification from the Firewall service about a network configuration detection (NCD) event and handles the event. Application filters must implement this method to handle NCD events. Possible events are listed in the FwxNcdEvent structure.

HRESULT NotifyNetworkChange(
  const FwxNcdEvent* pEvent
);

Parameters

pEvent
[in] Pointer to an NCD event from the FwxNcdEvent structure.

Return Values

Implementations of this method should handle any run-time error and return S_OK.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Wspfwext.idl.

See Also

IFWXNetConfigDetectionNotification


IFWXNetConfigDetectionSnapshot interface [ISA Server 2004]

IFWXNetConfigDetectionSnapshot

The IFWXNetConfigDetectionSnapshot interface provides the configuration of the network at a given moment in time. For more information, see Using Network Configuration Detection.

When To Use

This interface is used when a network configuration detection (NCD) client requires the complete and static network configuration to perform an action.

Methods in Vtable Order

The IFWXNetConfigDetectionSnapshot interface inherits the methods of the standard COM interface IUnknown.

In addition, IFWXNetConfigDetectionSnapshot defines the following methods.

Method | Description
GetNetworkSets | Retrieves an IFWXNetworkSets interface that represents the collection of all network sets defined on the ISA Server computer.
GetNetworkElements | Retrieves an IFWXNetworkElements interface that represents the collection of all network elements defined on the ISA Server computer.
GetNetworkAdapters | Retrieves an IFWXNetworkAdapters interface that represents the collection of all network adapters defined on the ISA Server computer.
GetNetworkAddresses | Retrieves an IFWXNetworkAddresses interface that represents the collection of all network addresses defined on the ISA Server computer.
GetIpRangesToNetworkElements | Retrieves an FwxIpRangesToNetworkElements structure that maps all defined IP address ranges to their respective network elements.
LookupNetworkElementByAddress | Retrieves an IFWXNetworkElement interface that represents the ISA Server network to which the specified IP address belongs.
LookupNetworkElementByGuid | Retrieves an IFWXNetworkElement interface that represents the ISA Server network identified by the specified GUID.
GetLocalHostNetworkElement | Retrieves an IFWXNetworkElement interface that represents the predefined Local Host network.
GetDefaultExternalNetworkElement | Retrieves an IFWXNetworkElement interface that represents the default External network.
GetVpnClientsNetworkElement | Retrieves an IFWXNetworkElement interface that represents the VPN Clients network.
GetQuarantinedVpnClientsNetworkElement | Retrieves an IFWXNetworkElement interface that represents the Quarantined VPN Clients network.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Wspfwext.idl.

See Also

Filter Interfaces


GetDefaultExternalNetworkElement method [ISA Server 2004]

IFWXNetConfigDetectionSnapshot::GetDefaultExternalNetworkElement

The GetDefaultExternalNetworkElement method retrieves an IFWXNetworkElement interface that represents the default External network.

HRESULT GetDefaultExternalNetworkElement(
  IFWXNetworkElement** ppNetworkElement
);

Parameters

ppNetworkElement
[out] Address of an interface pointer that on return points to an IFWXNetworkElement interface that represents the default External network.

Return Values

This method returns S_OK if the call is successful; otherwise, it returns an error code.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Wspfwext.idl.

See Also

IFWXNetConfigDetectionSnapshot


GetIpRangesToNetworkElements method [ISA Server 2004]

IFWXNetConfigDetectionSnapshot::GetIpRangesToNetworkElements

The GetIpRangesToNetworkElements method retrieves an FwxIpRangesToNetworkElements structure that maps all defined IP address ranges to their respective network elements.
HRESULT GetIpRangesToNetworkElements(
  FwxIpRangesToNetworkElements** ppIpRanges
);

Parameters

ppIpRanges
[out] Address of a pointer that on return points to an FwxIpRangesToNetworkElements structure that maps all defined IP address ranges to their respective network elements.

Return Values

This method returns S_OK if the call is successful; otherwise, it returns an error code.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Wspfwext.idl.

See Also

IFWXNetConfigDetectionSnapshot


GetLocalHostNetworkElement method [ISA Server 2004]

IFWXNetConfigDetectionSnapshot::GetLocalHostNetworkElement

The GetLocalHostNetworkElement method retrieves an IFWXNetworkElement interface that represents the predefined Local Host network.

HRESULT GetLocalHostNetworkElement(
  IFWXNetworkElement** ppNetworkElement
);

Parameters

ppNetworkElement
[out] Address of an interface pointer that on return points to an IFWXNetworkElement interface that represents the predefined Local Host network.

Return Values

This method returns S_OK if the call is successful; otherwise, it returns an error code.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Wspfwext.idl.

See Also

IFWXNetConfigDetectionSnapshot


IFWXNetConfigDetectionSnapshot.GetNetworkAdapters method [ISA Server 2004]

IFWXNetConfigDetectionSnapshot::GetNetworkAdapters

The GetNetworkAdapters method retrieves an IFWXNetworkAdapters interface that represents the collection of all network adapters defined on the ISA Server computer.
HRESULT GetNetworkAdapters(
  IFWXNetworkAdapters** pNetworkAdapters
);

Parameters

pNetworkAdapters
[out] Address of an interface pointer that on return points to an IFWXNetworkAdapters interface that represents the collection of all network adapters defined on the ISA Server computer.

Return Values

This method returns S_OK if the call is successful; otherwise, it returns an error code.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Wspfwext.idl.

See Also

IFWXNetConfigDetectionSnapshot


IFWXNetConfigDetectionSnapshot.GetNetworkAddresses method [ISA Server 2004]

IFWXNetConfigDetectionSnapshot::GetNetworkAddresses

The GetNetworkAddresses method retrieves an IFWXNetworkAddresses interface that represents the collection of all network addresses defined on the ISA Server computer.

HRESULT GetNetworkAddresses(
  IFWXNetworkAddresses** pNetworkAddresses
);

Parameters

pNetworkAddresses
[out] Address of an interface pointer that on return points to an IFWXNetworkAddresses interface that represents the collection of all network addresses defined on the ISA Server computer.

Return Values

This method returns S_OK if the call is successful; otherwise, it returns an error code.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Wspfwext.idl.

See Also

IFWXNetConfigDetectionSnapshot


IFWXNetConfigDetectionSnapshot.GetNetworkElements method [ISA Server 2004]

IFWXNetConfigDetectionSnapshot::GetNetworkElements

The GetNetworkElements method retrieves an IFWXNetworkElements interface that represents the collection of all network elements defined on the ISA Server computer.

HRESULT GetNetworkElements(
  IFWXNetworkElements** pNetworkElements
);

Parameters

pNetworkElements
[out] Address of an interface pointer that on return points to an IFWXNetworkElements interface that represents the collection of all network elements defined on the ISA Server computer.

Return Values

This method returns S_OK if the call is successful; otherwise, it returns an error code.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Wspfwext.idl.

See Also

IFWXNetConfigDetectionSnapshot


IFWXNetConfigDetectionSnapshot.GetNetworkSets method [ISA Server 2004]

IFWXNetConfigDetectionSnapshot::GetNetworkSets

The GetNetworkSets method retrieves an IFWXNetworkSets interface that represents the collection of all network sets defined on the ISA Server computer.

HRESULT GetNetworkSets(
  IFWXNetworkSets** pNetworkSets
);

Parameters

pNetworkSets
[out] Address of an interface pointer that on return points to an IFWXNetworkSets interface that represents the collection of all network sets defined on the ISA Server computer.

Return Values

This method returns S_OK if the call is successful; otherwise, it returns an error code.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Wspfwext.idl.

See Also

IFWXNetConfigDetectionSnapshot


GetQuarantinedVpnClientsNetworkElement method [ISA Server 2004]

IFWXNetConfigDetectionSnapshot::GetQuarantinedVpnClientsNetworkElement

The GetQuarantinedVpnClientsNetworkElement method retrieves an IFWXNetworkElement interface that represents the Quarantined VPN Clients network.

HRESULT GetQuarantinedVpnClientsNetworkElement(
  IFWXNetworkElement** ppNetworkElement
);

Parameters

ppNetworkElement
[out] Address of an interface pointer that on return points to an IFWXNetworkElement interface that represents the Quarantined VPN Clients network.

Return Values

This method returns S_OK if the call is successful; otherwise, it returns an error code.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Wspfwext.idl.

See Also

IFWXNetConfigDetectionSnapshot


GetVpnClientsNetworkElement method [ISA Server 2004]

IFWXNetConfigDetectionSnapshot::GetVpnClientsNetworkElement

The GetVpnClientsNetworkElement method retrieves an IFWXNetworkElement interface that represents the VPN Clients network.

HRESULT GetVpnClientsNetworkElement(
  IFWXNetworkElement** ppNetworkElement
);

Parameters

ppNetworkElement
[out] Address of an interface pointer that on return points to an IFWXNetworkElement interface that represents the VPN Clients network.

Return Values

This method returns S_OK if the call is successful; otherwise, it returns an error code.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Wspfwext.idl.

See Also

IFWXNetConfigDetectionSnapshot


LookupNetworkElementByAddress method [ISA Server 2004]

IFWXNetConfigDetectionSnapshot::LookupNetworkElementByAddress

The LookupNetworkElementByAddress method retrieves an IFWXNetworkElement interface that represents the ISA Server network to which the specified IP address belongs.

HRESULT LookupNetworkElementByAddress(
  LPSOCKADDR Address,
  DWORD AddressLength,
  IFWXNetworkElement** ppNetworkElement
);

Parameters

Address
[in] Pointer to a sockaddr structure that contains the IP address to look up.
AddressLength
[in] Length, in bytes, of the structure pointed to by the Address parameter.
ppNetworkElement
[out] Address of an interface pointer that on return points to an IFWXNetworkElement interface that represents the ISA Server network to which the address belongs.

Return Values

This method returns S_OK if the call is successful; otherwise, it returns an error code.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Wspfwext.idl.

See Also

IFWXNetConfigDetectionSnapshot


LookupNetworkElementByGuid method [ISA Server 2004]

IFWXNetConfigDetectionSnapshot::LookupNetworkElementByGuid

The LookupNetworkElementByGuid method retrieves an IFWXNetworkElement interface that represents the ISA Server network identified by the specified GUID.

HRESULT LookupNetworkElementByGuid(
  GUID* pguidNetworkElement,
  IFWXNetworkElement** ppNetworkElement
);

Parameters

pguidNetworkElement
[in] Globally unique identifier (GUID) of the ISA Server network to look up.
ppNetworkElement
[out] Address of an interface pointer that on return points to an IFWXNetworkElement interface that represents the ISA Server network identified by the specified GUID.

Return Values

This method returns S_OK if the call is successful; otherwise, it returns an error code.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Wspfwext.idl.

See Also

IFWXNetConfigDetectionSnapshot


IFWXNetConfigDetector interface [ISA Server 2004]

IFWXNetConfigDetector

The IFWXNetConfigDetector interface is the interface that is used to register an application filter to receive notifications for network configuration detection (NCD) events. When an application filter is an NCD client, it can retrieve a snapshot of the current network configuration whenever a change in the configuration occurs. When the network configuration information is provided to a registered application filter, information about each element (address, adapter, network) of the configuration snapshot is provided separately.

NCD notifications are incremental. When a change in the network configuration occurs, the NCD mechanism informs its clients of the change in the configuration, such as a notification regarding the creation of a new network set, followed by a notification regarding the deletion of a network element. The last notification in every configuration change indicates the end of the information regarding the change. It informs the NCD client that it is now synchronized with the snapshot that the NCD mechanism holds. This synchronization notification also contains the new snapshot information.

The IFWXNetConfigDetector::Register method creates a registration handle, in which you can store and reuse information about the NCD objects you use. When an application filter registers as an NCD client, as part of the registration process it will receive all the incremental notifications required to compose the current network configuration snapshot.

For more information, see Using Network Configuration Detection.

Methods in Vtable Order

The IFWXNetConfigDetector interface inherits the methods of the standard COM interface IUnknown.

In addition, IFWXNetConfigDetector defines the following methods.

Method | Description
Register | Registers an application filter to receive NCD events.
Unregister | Unregisters an application filter from receiving NCD events.
LookupNetworkElementByAddress | Retrieves an IFWXNetworkElement interface that represents the ISA Server network to which the specified IP address belongs.
GetCurrentSnapshot | Gets a pointer to an IFWXNetConfigDetectionSnapshot interface that represents a snapshot of the current network configuration.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Wspfwext.idl.

See Also

Filter Interfaces


IFWXNetConfigDetector.GetCurrentSnapshot (1 Parameter) method [ISA Server 2004]

IFWXNetConfigDetector::GetCurrentSnapshot

The GetCurrentSnapshot method gets a pointer to an IFWXNetConfigDetectionSnapshot interface that represents a snapshot of the current network configuration.

HRESULT GetCurrentSnapshot(
  IFWXNetConfigDetectionSnapshot** ppNetConfigDetectionSnapshot
);

Parameters

ppNetConfigDetectionSnapshot
[out] Pointer to an IFWXNetConfigDetectionSnapshot interface that represents a snapshot of the network configuration.

Return Values

This method returns S_OK if the call is successful; otherwise, it returns an error code.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Wspfwext.idl.

See Also

IFWXNetConfigDetector


IFWXNetConfigDetector.LookupNetworkElementByAddress method [ISA Server 2004]

IFWXNetConfigDetector::LookupNetworkElementByAddress

The LookupNetworkElementByAddress method retrieves an IFWXNetworkElement interface that represents the ISA Server network to which the specified IP address belongs.

HRESULT LookupNetworkElementByAddress(
  LPSOCKADDR Address,
  DWORD AddressLength,
  IFWXNetworkElement** ppNetworkElement
);

Parameters

Address
[in] Pointer to a sockaddr structure that contains the IP address to look up.
AddressLength
[in] Length, in bytes, of the structure pointed to by the Address parameter.
ppNetworkElement
[out] Address of an interface pointer that on return points to an IFWXNetworkElement interface that represents the ISA Server network to which the address belongs.

Return Values

This method returns S_OK if the call is successful; otherwise, it returns an error code.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Wspfwext.idl.

See Also

IFWXNetConfigDetector


IFWXNetConfigDetector.Register (3 Parameters) method [ISA Server 2004]

IFWXNetConfigDetector::Register

The Register method registers an application filter to receive network configuration detection (NCD) events.

HRESULT Register(
  IFWXNetConfigDetectionNotification* ipNcdNotification,
  BOOL fIssueAllNotifications,
  unsigned int* puiNcdRegistrationHandle
);

Parameters

ipNcdNotification
[in] A pointer to an IFWXNetConfigDetectionNotification interface, which the application filter must implement.
fIssueAllNotifications
[in] Boolean value that specifies whether the IFWXNetConfigDetector::Register method will return synchronously (after all notifications are issued) or asynchronously (before any notification is issued). When an application filter registers as an NCD client, as part of the registration process it will receive all the incremental notifications required to compose the current network configuration snapshot. This flag indicates whether the client receives all of these initial notifications synchronously (before its call to the IFWXNetConfigDetector::Register method returns) or asynchronously (after its call to the IFWXNetConfigDetector::Register method returns).
puiNcdRegistrationHandle
[out] Unsigned integer value that specifies a registration handle created during the registration process.

Return Values

This method returns S_OK if the call is successful; otherwise, it returns an error code.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Wspfwext.idl.

See Also

IFWXNetConfigDetector, IFWXNetConfigDetectionNotification


IFWXNetConfigDetector.UnRegister(unsigned int) method [ISA Server 2004]

IFWXNetConfigDetector::UnRegister

The UnRegister method unregisters an application filter from receiving network configuration detection (NCD) events.

HRESULT UnRegister(
  unsigned int uiNcdRegistrationHandle
);

Parameters

uiNcdRegistrationHandle
[in] Unsigned integer value that specifies the registration handle.

Return Values

This method returns S_OK if the call is successful; otherwise, it returns an error code.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Wspfwext.idl.

See Also

IFWXNetConfigDetector, IFWXNetConfigDetectionNotification


IFWXNetworkAdapter interface [ISA Server 2004]

IFWXNetworkAdapter

The IFWXNetworkAdapter interface represents a single network adapter. The network adapter is not specific to ISA Server, but is received from TCP/IP. The IFWXNetworkAdapter interface is used by the IFWXNetConfigDetector interface to store context information based on network configuration detection (NCD) events. This enables you to store information about the adapter the first time an event is received for it, so that you do not have to retrieve the information from ISA Server for each subsequent adapter event.

Note The context information must implement IUnknown

Methods in Vtable Order

The IFWXNetworkAdapter interface inherits the methods of the standard COM interface IUnknown.

In addition, IFWXNetworkAdapter defines the following methods.

Method | Description
SetContext | Sets the context information.
GetContext | Gets the context information.
GetAdapterIndex | Gets the index of the adapter.
GetRouteTable | Gets the routing table information.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Wspfwext.idl.

See Also

Filter Interfaces


IFWXNetworkAdapter.GetAdapterIndex(DWORD) method [ISA Server 2004]

IFWXNetworkAdapter::GetAdapterIndex

The GetAdapterIndex method gets the index of the adapter.

HRESULT GetAdapterIndex(
  DWORD* pdwIndex
);

Parameters

pdwIndex
[out] Pointer to a DWORD that specifies the adapter index.

Return Values

This method returns S_OK if the call is successful; otherwise, it returns an error code.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Wspfwext.idl.

See Also

IFWXNetworkAdapter


IFWXNetworkAdapter.GetContext(unsigned int,IUnknown) method [ISA Server 2004]

IFWXNetworkAdapter::GetContext

The GetContext method gets the context information.

HRESULT GetContext(
  unsigned int uiContextSlot,
  IUnknown** ppunkContext
);

Parameters

uiContextSlot
[in] Unsigned integer value that specifies the registration handle, created by the IFWXNetConfigDetector::Register method. When you register a new network configuration detection (NCD) client, the first notification it receives is fwx_ncd_Startup, which provides the uiContextSlot parameter.
ppunkContext
[out] Indirect pointer to the context information.

Return Values

This method returns S_OK if the call is successful; otherwise, it returns an error code.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Wspfwext.idl.

See Also

IFWXNetworkAdapter


IFWXNetworkAdapter.GetRouteTable(IFWXIpFilter) method [ISA Server 2004]

IFWXNetworkAdapter::GetRouteTable

The GetRouteTable method gets the routing table information. Having this information allows the network configuration detection (NCD) mechanism to know the addresses that can be routed for a particular adapter, and to send a notification if the routing status changes (an event of type fwx_ncd_ChangeAdapterRoute).

An address that can be routed is one that allows a particular packet to be transmitted, based on the address definition in the routing table. For more information on routing tables, see Routing Tables. Note that ISA Server will remove addresses from the adapter’s routing table if they are not contained in the adapter’s network.

HRESULT GetRouteTable(
  IFWXIpFilter** ppIpRange
);

Parameters

ppIpRange
[out] Address of a variable that receives a pointer to the IFWXIpFilter interface, which represents a range of IP addresses for which a connection or socket is allowed to function.

Return Values

This method returns S_OK if the call is successful; otherwise, it returns an error code.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Wspfwext.idl.

See Also

IFWXNetworkAdapter


IFWXNetworkAdapter.SetContext(unsigned int,IUnknown) method [ISA Server 2004]

IFWXNetworkAdapter::SetContext

The SetContext method sets the context information.

HRESULT SetContext(
  unsigned int uiContextSlot,
  IUnknown* punkContext
);

Parameters

uiContextSlot
[in] Unsigned integer value that specifies the registration handle, created by the IFWXNetConfigDetector::Register method. When you register a new network configuration detection (NCD) client, the first notification it receives is fwx_ncd_Startup, which provides the uiContextSlot parameter.
punkContext
[in] Pointer to the context information.

Return Values

This method returns S_OK if the call is successful; otherwise, it returns an error code.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Wspfwext.idl.

See Also

IFWXNetworkAdapter


IFWXNetworkAdapters interface [ISA Server 2004]

IFWXNetworkAdapters

The IFWXNetworkAdapters interface represents a collection that provides access to a set of IFWXNetworkAdapter interfaces.

Methods in Vtable Order

The IFWXNetworkAdapters interface inherits the methods of the standard COM interface IUnknown.

In addition, IFWXNetworkAdapters defines the following methods.

Method | Description
GetCount | Gets the number of IFWXNetworkAdapter interfaces in the collection.
GetItem | Retrieves the requested IFWXNetworkAdapter interface from the collection.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Wspfwext.idl.

See Also

Filter Interfaces


IFWXNetworkAdapters.GetCount(unsigned int) method [ISA Server 2004]

IFWXNetworkAdapters::GetCount

The GetCount method gets the number of IFWXNetworkAdapter interfaces in the collection.
HRESULT GetCount(
  unsigned int* puiCount
);

Parameters

puiCount
[out] Pointer to the number of IFWXNetworkAdapter interfaces in the collection.

Return Values

This method returns S_OK if the call is successful; otherwise, it returns an error code.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Wspfwext.idl.

See Also

IFWXNetworkAdapters


IFWXNetworkAdapters.GetItem (2 Parameters) method [ISA Server 2004]

IFWXNetworkAdapters::GetItem

The GetItem method retrieves the requested IFWXNetworkAdapter interface from the collection.

HRESULT GetItem(
  unsigned int uiItemIndex,
  IFWXNetworkAdapter** ppNetworkAdapter
);

Parameters

uiItemIndex
[in] One-based index of the IFWXNetworkAdapter interface to retrieve.
ppNetworkAdapter
[out] Address of an interface pointer that on return points to the IFWXNetworkAdapter interface requested.

Return Values

This method can return one of the following:

  • S_OK, indicating that the operation succeeded.
  • An error code, indicating that the operation failed. In this case, the [out] parameter returned is a null object.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Wspfwext.idl.

See Also

IFWXNetworkAdapters


IFWXNetworkAddress interface [ISA Server 2004]

IFWXNetworkAddress

The IFWXNetworkAddress interface represents an IP address of the ISA Server computer. The IFWXNetworkAddress interface is used by the IFWXNetConfigDetector interface to store context information based on network configuration detection (NCD) events. This enables you to store information about an IP address the first time an event is received for it, so that you do not have to retrieve the information from ISA Server for each subsequent address event.

Note The context information must implement IUnknown

Methods in Vtable Order

The IFWXNetworkAddress interface inherits the methods of the standard COM interface IUnknown.

In addition, IFWXNetworkAddress defines the following methods.

Method | Description
SetContext | Sets the context information.
GetContext | Retrieves the context information.
GetAddress | Retrieves the IP address.
GetMask | Retrieves the subnet mask for the IP address.
GetNetworkAdapter | Retrieves a pointer to the IFWXNetworkAdapter interface to which the address belongs.
GetNetworkElement | Retrieves a pointer to the IFWXNetworkElement interface to which the address belongs.
IsPrimaryAddress | Verifies whether this is the primary address for the adapter.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Wspfwext.idl.

See Also

Filter Interfaces


IFWXNetworkAddress.GetAddress(LPSOCKADDR,DWORD) method [ISA Server 2004]

IFWXNetworkAddress::GetAddress

The GetAddress method retrieves the IP address.

HRESULT GetAddress(
  LPSOCKADDR Address,
  DWORD* AddressLength
);

Parameters

Address
[out] Pointer to a sockaddr structure that on return receives the IP address.
AddressLength
[in, out] Pointer to a variable that specifies the length, in bytes, of the structure pointed to by the Address parameter. On return, AddressLength receives the actual size, in bytes, of the address returned in the Address parameter.

Return Values

This method returns S_OK if the call is successful; otherwise, it returns an error code.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Wspfwext.idl.

See Also

IFWXNetworkAddress


IFWXNetworkAddress.GetContext(unsigned int,IUnknown) method [ISA Server 2004]

IFWXNetworkAddress::GetContext

The GetContext method retrieves the context information.

HRESULT GetContext(
  unsigned int uiContextSlot,
  IUnknown** ppunkContext
);

Parameters

uiContextSlot
[in] Unsigned integer value that specifies the registration handle, created by the IFWXNetConfigDetector::Register method. When you register a new network configuration detection client, the first notification it receives is fwx_ncd_Startup, which provides the uiContextSlot.
ppunkContext
[out] Indirect to the user context information.

Return Values

This method returns S_OK if the call is successful; otherwise, it returns an error code.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Wspfwext.idl.

See Also

IFWXNetworkAddress


IFWXNetworkAddress.GetMask(LPSOCKADDR,DWORD) method [ISA Server 2004]

IFWXNetworkAddress::GetMask

The GetMask method retrieves the subnet mask for the IP address.

HRESULT GetMask(
  LPSOCKADDR Mask,
  DWORD* MaskLength
);

Parameters

Mask
[out] Pointer to a sockaddr structure that on return receives the subnet mask for the IP address.
MaskLength
[in, out] Pointer to a variable that specifies the length, in bytes, of the structure pointed to by the Mask parameter. On return, MaskLength receives the actual size, in bytes, of the subnet mask returned in the Mask parameter.

Return Values

This method returns S_OK if the call is successful; otherwise, it returns an error code.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Wspfwext.idl.

See Also

IFWXNetworkAddress


IFWXNetworkAddress.GetNetworkAdapter (1 Parameter) method [ISA Server 2004]

IFWXNetworkAddress::GetNetworkAdapter

The GetNetworkAdapter method retrieves a pointer to the IFWXNetworkAdapter interface to which the address belongs.

HRESULT GetNetworkAdapter(
  IFWXNetworkAdapter** ppNetworkAdapter
);

Parameters

ppNetworkAdapter
[out] A pointer to the IFWXNetworkAdapter interface.

Return Values

This method returns S_OK if the call is successful; otherwise, it returns an error code.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Wspfwext.idl.

See Also

IFWXNetworkAddress


IFWXNetworkAddress.GetNetworkElement (1 Parameter) method [ISA Server 2004]

IFWXNetworkAddress::GetNetworkElement

The GetNetworkElement method retrieves a pointer to the IFWXNetworkElement interface to which the address belongs.

HRESULT GetNetworkElement(
  IFWXNetworkElement** ppNetworkElement
);

Parameters

ppNetworkElement
[out] A pointer to the IFWXNetworkElement interface.

Return Values

This method returns S_OK if the call is successful; otherwise, it returns an error code.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Wspfwext.idl.

See Also

IFWXNetworkAddress


IFWXNetworkAddress.IsPrimaryAddress(BOOL) method [ISA Server 2004]

IFWXNetworkAddress::IsPrimaryAddress

The IsPrimaryAddress method verifies whether this is the primary address for the adapter.

HRESULT IsPrimaryAddress(
  BOOL* pfPrimary
);

Parameters

pfPrimary
Boolean value that indicates whether the address is the primary address for the adapter.

Return Values

This method returns S_OK if the call is successful; otherwise, it returns an error code.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Wspfwext.idl.

See Also

IFWXNetworkAddress


IFWXNetworkAddress.SetContext(unsigned int,IUnknown) method [ISA Server 2004]

IFWXNetworkAddress::SetContext

The SetContext method sets the context information.

HRESULT SetContext(
  unsigned int uiContextSlot,
  IUnknown* punkContext
);

Parameters

uiContextSlot
[in] Unsigned integer value that specifies the registration handle, created by the IFWXNetConfigDetector::Register method. When you register a new network configuration detection client, the first notification it receives is fwx_ncd_Startup, which provides the uiContextSlot.
punkContext
[in] Pointer to the user context information.

Return Values

This method returns S_OK if the call is successful; otherwise, it returns an error code.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Wspfwext.idl.

See Also

IFWXNetworkAddress


IFWXNetworkAddresses interface [ISA Server 2004]

IFWXNetworkAddresses

The IFWXNetworkAddresses interface represents a collection that provides access to a set of IFWXNetworkAddress interfaces.

Methods in Vtable Order

The IFWXNetworkAddresses interface inherits the methods of the standard COM interface IUnknown.

In addition, IFWXNetworkAddresses defines the following methods.

Method | Description
GetCount | Retrieves the number of IFWXNetworkAddress interfaces in the collection.
GetItem | Retrieves the requested IFWXNetworkAddress interface from the collection.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Wspfwext.idl.

See Also

Filter Interfaces


IFWXNetworkAddresses.GetCount(unsigned int) method [ISA Server 2004]

IFWXNetworkAddresses::GetCount

The GetCount method retrieves the number of IFWXNetworkAddress interfaces in the collection.
HRESULT GetCount(
  unsigned int* puiCount
);

Parameters

puiCount
[out] Pointer to the number of IFWXNetworkAddress interfaces in the collection.

Return Values

This method returns S_OK if the call is successful; otherwise, it returns an error code.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Wspfwext.idl.

See Also

IFWXNetworkAddresses


IFWXNetworkAddresses.GetItem (2 Parameters) method [ISA Server 2004]

IFWXNetworkAddresses::GetItem

The GetItem method retrieves the requested IFWXNetworkAddress interface from the collection.
HRESULT GetItem(
  unsigned int uiItemIndex,
  IFWXNetworkAddress** ppNetworkAddress
);

Parameters

uiItemIndex
[in] One-based index of the IFWXNetworkAddress interface to retrieve.
ppNetworkAddress
[out] Address of an interface pointer that on return points to the IFWXNetworkAddress interface requested.

Return Values

This method can return one of the following:

  • S_OK, indicating that the operation succeeded.
  • An error code, indicating that the operation failed. In this case, the [out] parameter returned is a null object.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Wspfwext.idl.

See Also

IFWXNetworkAddresses


IFWXNetworkElement interface [ISA Server 2004]

IFWXNetworkElement

The IFWXNetworkElement interface represents a network element, which is is a network defined in the stored ISA Server administration COM configuration. The IFWXNetworkElement interface is used by the IFWXNetConfigDetector interface to store context information based on network configuration detection (NCD) events. This enables you to store information about the network element the first time an event is received for it, so that you do not have to retrieve the information from ISA Server for each subsequent network element event.

Note The context information must implement IUnknown.

Methods in Vtable Order

The IFWXNetworkElement interface inherits the methods of the standard COM interface IUnknown.

In addition, IFWXNetworkElement defines the following methods.

Method | Description
SetContext | Sets the context information.
GetContext | Retrieves the context information.
GetGUID | Retrieves the GUID of the network element.
GetName | Retrieves the name of the network element.
GetType | Retrieves the type of the network element.
IsLocalAddress | Verifies whether the specified IP address is contained in the network element and is an IP address of the local computer.
GetConnectingNetworkGUID | Retrieves the GUID of the connecting network.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Wspfwext.idl.

See Also

Filter Interfaces


IFWXNetworkElement.GetConnectingNetworkGUID(GUID) method [ISA Server 2004]

IFWXNetworkElement::GetConnectingNetworkGUID

The GetConnectingNetworkGUID method retrieves the GUID of the connecting network.

HRESULT GetConnectingNetworkGUID(
  GUID* pGuid
);

Parameters

pGuid
[out] Pointer to the GUID of the connecting network. Must point to a memory block large enough to contain a GUID.

Return Values

This method returns S_OK if the call is successful; otherwise, it returns an error code.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Wspfwext.idl.

See Also

IFWXNetworkElement


IFWXNetworkElement.GetContext(unsigned int,IUnknown) method [ISA Server 2004]

IFWXNetworkElement::GetContext

The GetContext method retrieves the context information.

HRESULT GetContext(
  unsigned int uiContextSlot,
  IUnknown** ppunkContext
);

Parameters

uiContextSlot
[in] Unsigned integer value that specifies the registration handle, created by the IFWXNetConfigDetector::Register method. When you register a new network configuration detection client, the first notification it receives is fwx_ncd_Startup, which provides the uiContextSlot.
ppunkContext
[in] Indirect to the user context information.

Return Values

This method returns S_OK if the call is successful; otherwise, it returns an error code.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Wspfwext.idl.

See Also

IFWXNetworkElement


IFWXNetworkElement.GetGUID(GUID) method [ISA Server 2004]

IFWXNetworkElement::GetGUID

The GetGUID method retrieves the GUID of the network element.

HRESULT GetGUID(
  GUID* pGuid
);

Parameters

pGuid
[out] Pointer to the GUID of the network element. Must point to a memory block large enough to contain a GUID.

Return Values

This method returns S_OK if the call is successful; otherwise, it returns an error code.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Wspfwext.idl.

See Also

IFWXNetworkElement


IFWXNetworkElement.GetName(BSTR) method [ISA Server 2004]

IFWXNetworkElement::GetName

The GetName method retrieves the name of the network element.

HRESULT GetName(
  BSTR* pBstrName
);

Parameters

pBstrName
[out] Pointer to the name of the network element.

Return Values

This method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

Free the memory allocated for pBstrName by using SysFreeString. For recommendations about memory allocation for BSTR strings, see Best Practices.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Wspfwext.idl.

See Also

IFWXNetworkElement


IFWXNetworkElement.GetType(FpcNetworkType) method [ISA Server 2004]

IFWXNetworkElement::GetType

The GetType method retrieves the type of the network element. The possible types are:

  • Standard Network
  • VPN Clients
  • Quarantined VPN Clients
  • Local Host
  • Default External
  • Internal Network

HRESULT GetType(
  FpcNetworkType* pFpcNetworkType
);

Parameters

pFpcNetworkType
[out] Pointer to a value from the FpcNetworkTypes enumerated type that specifies the type of network.

Return Values

This method returns S_OK if the call is successful; otherwise, it returns an error code.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Wspfwext.idl.

See Also

IFWXNetworkElement


IFWXNetworkElement.IsLocalAddress(LPSOCKADDR,DWORD) method [ISA Server 2004]

IFWXNetworkElement::IsLocalAddress

The IsLocalAddress method verifies whether the specified IP address is contained in the network element and is an IP address of the local computer.

HRESULT IsLocalAddress(
  LPSOCKADDR Address,
  DWORD AddressLength
);

Parameters

Address
[in] Pointer to a sockaddr structure that contains the IP address to be checked.
AddressLength
[in] Length, in bytes, of the structure pointed to by the Address parameter.

Return Values

This method can return one of the following:
S_OK
The method succeeded, and the specified IP address is contained in the network element and is an IP address of the local computer.
S_FALSE
The method succeeded, but the specified IP address is not contained in the network element or is not an IP address of the local computer.
E_INVALIDARG
The address passed to the method is not a valid IP address.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Wspfwext.idl.

See Also

IFWXNetworkElement


IFWXNetworkElement.SetContext(unsigned int,IUnknown) method [ISA Server 2004]

IFWXNetworkElement::SetContext

The SetContext method sets the context information.

HRESULT SetContext(
  unsigned int uiContextSlot,
  IUnknown* punkContext
);

Parameters

uiContextSlot
[in] Unsigned integer value that specifies the registration handle, created by the IFWXNetConfigDetector::Register method. When you register a new network configuration detection client, the first notification it receives is fwx_ncd_Startup, which provides the uiContextSlot.
punkContext
[in] Pointer to the user context information.

Return Values

This method returns S_OK if the call is successful; otherwise, it returns an error code.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Wspfwext.idl.

See Also

IFWXNetworkElement


IFWXNetworkElements interface [ISA Server 2004]

IFWXNetworkElements

IFWXNetworkElements represents a collection that provides access to a set of IFWXNetworkElement interfaces.

Methods in Vtable Order

The IFWXNetworkElements interface inherits the methods of the standard COM interface IUnknown.

In addition, IFWXNetworkElements defines the following methods.

Method | Description
GetCount | Retrieves the number of IFWXNetworkElement interfaces in the collection.
GetItem | Retrieves the requested IFWXNetworkElement interface from the collection.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Wspfwext.idl.

See Also

Filter Interfaces


IFWXNetworkElements.GetCount(unsigned int) method [ISA Server 2004]

IFWXNetworkElements::GetCount

The GetCount method retrieves the number of IFWXNetworkElement interfaces in the collection.
HRESULT GetCount(
  unsigned int* puiCount
);

Parameters

puiCount
[out] Pointer to the number of IFWXNetworkElement interfaces in the collection.

Return Values

This method returns S_OK if the call is successful; otherwise, it returns an error code.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Wspfwext.idl.

See Also

IFWXNetworkElements


IFWXNetworkElements.GetItem (2 Parameters) method [ISA Server 2004]

IFWXNetworkElements::GetItem

The GetItem method retrieves the requested IFWXNetworkElement interface from the collection.
HRESULT GetItem(
  unsigned int uiItemIndex,
  IFWXNetworkElement** ppNetworkElement
);

Parameters

uiItemIndex
[in] One-based index of the IFWXNetworkElement interface to retrieve.
ppNetworkElement
[out] Address of an interface pointer that on return points to the IFWXNetworkElement interface requested.

Return Values

This method can return one of the following:

  • S_OK, indicating that the operation succeeded.
  • An error code, indicating that the operation failed. In this case, the [out] parameter returned is a null object.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Wspfwext.idl.

See Also

IFWXNetworkElements


IFWXNetworkSet interface [ISA Server 2004]

IFWXNetworkSet

The IFWXNetworkSet interface represents a network set as defined in the ISA Server administration COM storage (FPCNetworkSet object). The IFWXNetworkSet interface is used by the IFWXNetConfigDetector interface to store context information based on network configuration detection (NCD) events. This enables you to store information about the network set the first time an event is received for it, so that you do not have to retrieve the information from ISA Server for each subsequent network set event.

Note The context information must implement IUnknown.

Methods in Vtable Order

The IFWXNetworkSet interface inherits the methods of the standard COM interface IUnknown.

In addition, IFWXNetworkSet defines the following methods.

Method | Description
SetContext | Sets the context information.
GetContext | Retrieves the context information.
GetGUID | Retrieves the GUID of the network set.
GetNetworkElements | Retrieves the network elements that comprise the network set.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Wspfwext.idl.

See Also

Filter Interfaces


IFWXNetworkSet.GetContext(unsigned int,IUnknown) method [ISA Server 2004]

IFWXNetworkSet::GetContext

The GetContext method retrieves the context information.

HRESULT GetContext(
  unsigned int uiContextSlot,
  IUnknown** ppunkContext
);

Parameters

uiContextSlot
[in] Unsigned integer value that specifies the registration handle. When you register a new network configuration detection client, the first notification it receives is fwx_ncd_Startup, which provides the uiContextSlot.
ppunkContext
[out] Indirect to the user context information.

Return Values

This method returns S_OK if the call is successful; otherwise, it returns an error code.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Wspfwext.idl.

See Also

IFWXNetworkSet


IFWXNetworkSet.GetGUID(GUID) method [ISA Server 2004]

IFWXNetworkSet::GetGUID

The GetGUID method retrieves the GUID of the network set.

HRESULT GetGUID(
  GUID* pGuid
);

Parameters

pGuid
[out] Pointer to the GUID for the network set. Must point to a memory block large enough to contain a GUID.

Return Values

This method returns S_OK if the call is successful; otherwise, it returns an error code.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Wspfwext.idl.

See Also

IFWXNetworkSet


IFWXNetworkSet.GetNetworkElements(IFWXNetworkElements) method [ISA Server 2004]

IFWXNetworkSet::GetNetworkElements

The GetNetworkElements method retrieves the network elements that comprise the network set.
HRESULT GetNetworkElements(
  IFWXNetworkElements** ppNetworkElements
);

Parameters

ppNetworkElements
[out] Pointer to an interface that represents the network elements that comprise the network set.

Return Values

This method returns S_OK if the call is successful; otherwise, it returns an error code.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Wspfwext.idl.

See Also

IFWXNetworkSet


IFWXNetworkSet.SetContext(unsigned int,IUnknown) method [ISA Server 2004]

IFWXNetworkSet::SetContext

The SetContext method sets the context information.

HRESULT SetContext(
  unsigned int uiContextSlot,
  IUnknown* punkContext
);

Parameters

uiContextSlot
[in] Unsigned integer value that specifies the registration handle. When you register a new network configuration detection client, the first notification it receives is fwx_ncd_Startup, which provides the uiContextSlot.
punkContext
[in] Pointer to the user context information.

Return Values

This method returns S_OK if the call is successful; otherwise, it returns an error code.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Wspfwext.idl.

See Also

IFWXNetworkSet


IFWXNetworkSets interface [ISA Server 2004]

IFWXNetworkSets

The IFWXNetworkSets interface represents a collection that provides access to a set of IFWXNetworkSet interfaces.

Methods in Vtable Order

The IFWXNetworkSets interface inherits the methods of the standard COM interface IUnknown.

In addition, IFWXNetworkSets defines the following methods.

Method | Description
GetCount | Retrieves the number of IFWXNetworkSet interfaces in the collection.
GetItem | Retrieves the requested IFWXNetworkSet interface from the collection.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Wspfwext.idl.

See Also

Filter Interfaces


IFWXNetworkSets.GetCount(unsigned int) method [ISA Server 2004]

IFWXNetworkSets::GetCount

The GetCount method retrieves the number of IFWXNetworkSet interfaces in the collection.
HRESULT GetCount(
  unsigned int* puiCount
);

Parameters

puiCount
[out] Pointer to the number of IFWXNetworkSet interfaces in the collection.

Return Values

This method returns S_OK if the call is successful; otherwise, it returns an error code.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Wspfwext.idl.

See Also

IFWXNetworkSets


IFWXNetworkSets.GetItem(unsigned int,IFWXNetworkSet) method [ISA Server 2004]

IFWXNetworkSets::GetItem

The GetItem method retrieves the requested IFWXNetworkSet interface from the collection.
HRESULT GetItem(
  unsigned int uiItemIndex,
  IFWXNetworkSet** ppNetworkSet
);

Parameters

uiItemIndex
[in] One-based index of the IFWXNetworkSet interface to retrieve.
ppNetworkSet
[out] Address of an interface pointer that on return points to the IFWXNetworkSet interface requested.

Return Values

This method can return one of the following:

  • S_OK, indicating that the operation succeeded.
  • An error code, indicating that the operation failed. In this case, the [out] parameter returned is a null object.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Wspfwext.idl.

See Also

IFWXNetworkSets


IFWXNetworkSocket interface [ISA Server 2004]

IFWXNetworkSocket

The IFWXNetworkSocket interface is a Microsoft Firewall service socket interface, and is derived from the IFWXSocket interface. The implementation uses the dynamic packet filtering functionality of ISA Server to automatically open a packet filter port when necessary, and to close it when the socket is closed.

Note Before releasing this interface, you must call the Close or Shutdown method on it.

Methods in Vtable Order

The IFWXNetworkSocket interface inherits the methods of the standard COM interface IUnknown.

In addition, IFWXNetworkSocket defines the following methods, including those inherited from IFWXSocket.

Method | Description
Send | Sends a buffer asynchronously. It performs an overlapped send operation.
SendTo | Sends a buffer asynchronously on UDP sockets to a specific address. It performs an overlapped sendto operation.
Recv | Receives a buffer asynchronously. It performs an overlapped receive (or receive from operation, depending on the socket type).
Shutdown | Starts transport shutdown on the socket.
Close | Closes the socket.
Connect | Establishes a connection to a specified socket. This method is similar to the Winsock connect function.
Bind | Associates a local address with a socket. This method is similar to the Winsock bind function.
GetSockName | Gets the local name of a socket. This method is similar to the Winsock getsockname function.
GetPeerName | Gets the remote name of a socket. This method is similar to the Winsock getpeername function.
Listen | Listens on a TCP socket.
SetSockOpt | Sets a socket option. This method is similar to the Winsock setsockopt function.
GetSockOpt | Gets a socket option. This method is similar to the Winsock getsockopt function.
Accept | Asynchronously permits a connection on a listening socket. This method is similar to the Winsock accept function.
SetIpFilter | Sets the IP filter for the socket. It sets a new IP filter if there was not one, or replaces the current IP filter with a new one.
GetIpFilter | Gets a copy of the IP filter object for the socket. Returns NULL if the connection is not limited to a range of IP addresses.

Remarks

A socket object that implements this interface can be created by calling IFWXFirewall::CreateNetworkSocket, IFWXSession::CreateNetworkSocket, or IFWXFirewall2::CreateSSLNetworkSocket.

The nature of the socket is determined by which of these three methods is used to create the object. A socket created by calling IFWXFirewall::CreateNetworkSocket is not user-specific. An example of a socket that should not be user-specific is a listening socket. To create a user-specific socket object, use IFWXSession::CreateNetworkSocket. Finally, a socket object created by calling IFWXFirewall2::CreateSSLNetworkSocket represents an SSL socket for secured communication.

An SSL socket does not implement the Accept, Connect, and SendTo methods. For more information, see Socket Implementation in ISA Server.

Implementation

This interface is implemented in the Firewall service.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Wspfwext.idl.

See Also

Filter Interfaces


IFWXNetworkSocket.Accept (2 Parameters) method [ISA Server 2004]

IFWXNetworkSocket::Accept

The Accept method asynchronously permits a connection on a listening socket. This method is similar to the Winsock accept function.

HRESULT Accept(
  IFWXAcceptCompletion* pIFWXAcceptCompletion,
  UserContextType UserData
);

Parameters

pIFWXAcceptCompletion
[in] Pointer to an IFWXAcceptCompletion interface, whose CompleteAsyncAccept method is called to receive a notification when the accept operation is completed.
UserData
[in] An opaque value that is to be passed to the IFWXAcceptCompletion::CompleteAsyncAccept notification method. This parameter provides a context to the notification.

Return Values

This method returns S_OK if the call is successful; otherwise, it returns an error code.

For an IFWXNetworkSocket interface created by a call to IFWXFirewall2::CreateSSLNetworkSocket, this method returns E_NOTIMPL.

Remarks

The UserData parameter provides a context to the notification. You can use the same notification interface for receiving completion notifications from different network socket objects and differentiate between them by using different values for UserData.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Wspfwext.idl.

See Also

IFWXNetworkSocket


IFWXNetworkSocket.Bind(LPSOCKADDR,INT,IFWXIpFilter) method [ISA Server 2004]

IFWXNetworkSocket::Bind

The Bind method associates a local address with a socket. This method is similar to the Winsock bind function.

HRESULT Bind(
  LPSOCKADDR Address,
  INT AddressLength,
  IFWXIpFilter* pIpFilter
);

Parameters

Address
[in] Pointer to a sockaddr structure that contains the address to assign to the socket.
AddressLength
[in] Length, in bytes, of the Address parameter.
pIpFilter
[in] Pointer to the IFWXIpFilter interface. The socket that is bound by using IFWXNetworkSocket::Bind will be restricted according to that IP filter, a range of IP addresses for which a connection or socket is allowed to function. If you specify NULL for this parameter, the socket will not be restricted.

Return Values

This method returns S_OK if the call is successful; otherwise, it returns an error code.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Wspfwext.idl.

See Also

IFWXNetworkSocket


IFWXNetworkSocket.Connect(LPSOCKADDR,DWORD) method [ISA Server 2004]

IFWXNetworkSocket::Connect

The Connect method establishes a connection to a specified socket. This method is similar to the Winsock connect function.

HRESULT Connect(
  LPSOCKADDR Address,
  DWORD AddressLength
);

Parameters

Address
[in] Pointer to a sockaddr structure that contains the address to which the connection is to be established.
AddressLength
[in] Length, in bytes, of the Address parameter.

Return Values

This method returns S_OK if the call is successful; otherwise, it returns an error code.

For an IFWXNetworkSocket interface created by a call to IFWXFirewall2::CreateSSLNetworkSocket, this method returns E_NOTIMPL.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Wspfwext.idl.

See Also

IFWXNetworkSocket


IFWXNetworkSocket.GetIpFilter(IFWXIpFilter) method [ISA Server 2004]

IFWXNetworkSocket::GetIpFilter

The GetIpFilter method gets a copy of the IP filter object for the socket. Returns NULL if the connection is not limited to a range of IP addresses.

HRESULT GetIpFilter(
  IFWXIpFilter** ppIpFilter
);

Parameters

ppIpFilter
[out] Address of an interface pointer that on return points to a copy of the IFWXIpFilter interface requested.

Return Values

This method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

Because the returned object is a copy, modifying the copy will not affect the socket object.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Wspfwext.idl.

See Also

IFWXNetworkSocket, IFWXIpFilter


IFWXNetworkSocket.GetPeerName(LPSOCKADDR,LPINT) method [ISA Server 2004]

IFWXNetworkSocket::GetPeerName

The GetPeerName method retrieves the remote name of a socket. This method is similar to the Winsock getpeername function.

HRESULT GetPeerName(
  LPSOCKADDR Address,
  LPINT AddressLength
);

Parameters

Address
[out] Pointer to a sockaddr structure that receives the address (name) of the peer.
AddressLength
[out] On input, specifies the size, in bytes, of the Address buffer. On output, receives the buffer size, in bytes, needed to hold the address.

Return Values

This method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This method is used when a connection has been requested from outside the network, and you want to identify it.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Wspfwext.idl.

See Also

IFWXNetworkSocket


IFWXNetworkSocket.GetSockName(LPSOCKADDR,LPINT) method [ISA Server 2004]

IFWXNetworkSocket::GetSockName

The GetSockName method retrieves the local name of a socket. This method is similar to the Winsock getsockname function.

HRESULT GetSockName(
  LPSOCKADDR Address,
  LPINT AddressLength
);

Parameters

Address
[out] Pointer to a sockaddr structure that receives the socket address (name).
AddressLength
[out] On input, specifies the size, in bytes, of the Address buffer. On output, receives the buffer size, in bytes, needed to hold the address.

Return Values

S_OK
The method succeeded.
HRESULT_FROM_WIN32(WSAEINVAL)
The socket has not been bound to an address with bind.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Wspfwext.idl.

See Also

IFWXNetworkSocket


IFWXNetworkSocket.GetSockOpt(int,int,char,int) method [ISA Server 2004]

IFWXNetworkSocket::GetSockOpt

The GetSockOpt method retrieves a socket option. This method is similar to the Winsock getsockopt function.

HRESULT GetSockOpt(
  int level,
  int optname,
  char* optval,
  int optlen
);

Parameters

level
[in] Level at which the option is defined. The supported levels include SOL_SOCKET and IPPROTO_TCP.
optname
[in] Socket option for which the value is to be retrieved.
optval
[out] Pointer to a buffer that receives the value of the requested option.
optlen
[in, out] Size, in bytes, of the optval buffer.

Return Values

This method returns S_OK if the call is successful; otherwise, it returns an error code.

For an IFWXNetworkSocket interface created by a call to IFWXSession::CreateNetworkSocket, this method returns E_NOTIMPL.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Wspfwext.idl.

See Also

IFWXNetworkSocket


IFWXNetworkSocket.Listen(INT) method [ISA Server 2004]

IFWXNetworkSocket::Listen

The Listen method listens on a TCP socket.

HRESULT Listen(
  INT Backlog
);

Parameters

Backlog
[in] Maximum length of the queue of pending connections. This is the same as the backlog parameter of the Winsock listen function.

Return Values

This method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

The Listen method indicates to the network that you are willing to accept connections to the port for which you have a bind.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Wspfwext.idl.

See Also

IFWXNetworkSocket


IFWXNetworkSocket.SetIpFilter(IFWXIpFilter) method [ISA Server 2004]

IFWXNetworkSocket::SetIpFilter

The SetIpFilter method sets the IP filter for the socket. It sets a new IP filter if there was not one, or replaces the current IP filter with a new one.

HRESULT SetIpFilter(
  IFWXIpFilter* pIpFilter
);

Parameters

pIpFilter
[in] Pointer to the IFWXIpFilter interface. Setting this parameter equal to NULL will result in no IP address restrictions for this socket.

Return Values

This method returns S_OK if the call is successful; otherwise, it returns an error code.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Wspfwext.idl.

See Also

IFWXNetworkSocket, IFWXIpFilter


IFWXNetworkSocket.SetSockOpt(int,int,char,int) method [ISA Server 2004]

IFWXNetworkSocket::SetSockOpt

The SetSockOpt method sets a socket option. This method is similar to the Winsock setsockopt function.

HRESULT SetSockOpt(
  int level,
  int optname,
  char* optval,
  int optlen
);

Parameters

level
[in] Level (type of socket) for which the option is defined. The supported levels include SOL_SOCKET and IPPROTO_TCP.
optname
[in] Socket option for which the value is to be set.
optval
[in] Pointer to the buffer in which the value for the requested option is supplied.
optlen
[in] Size, in bytes, of the optval buffer.

Return Values

This method returns S_OK if the call is successful; otherwise, it returns an error code.

For an IFWXNetworkSocket interface created by a call to IFWXSession::CreateNetworkSocket, this method returns E_NOTIMPL.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Wspfwext.idl.

See Also

IFWXNetworkSocket


IFWXOverlapped interface [ISA Server 2004]

IFWXOverlapped

The IFWXOverlapped interface is used to hook into the I/O completion port of the Microsoft Firewall service, for asynchronous I/O with files. You can hook into the completion port thread pool by linking a handle to the completion port (call the IFWXFirewall::HookToCompletionPort method). Overlapped Windows functions must then be called with the Winsock structure OVERLAPPED returned by this interface.

Methods in Vtable Order

The IFWXOverlapped interface inherits the methods of the standard COM interface IUnknown.

In addition, IFWXOverlapped defines the following methods.

Method | Description
GetOverlapped | Gets a pointer to a Winsock OVERLAPPED structure to use with Windows overlapped functions.
SetNotificationInterface | Sets the callback for the completion of the overlapped I/O.

Remarks

If the Firewall service is performing asynchronous I/O for an operating system file, it must have access to the Winsock OVERLAPPED structure and a means of setting up a callback when the I/O is completed.

The IFWXOverlapped interface gets a pointer to the Windows Sockets OVERLAPPED structure. The IFWXOverlapped interface also provides the link between the OVERLAPPED structure and a completion notification interface, and includes user context information that allows the filter to distinguish between different notifications.

Use the IFWXOverlapped::SetNotificationInterface method to set the notification interface and user context. Then use the IFWXOverlapped::GetOverlapped method to get an OVERLAPPED structure that will be used in a call to an asynchronous Windows API.

The call to the Windows API must use a handle that is associated with the Firewall service completion port. For more information, see IFWXFirewall::HookToCompletionPort.

When the overlapped operation completes, the Firewall service will get the completion notification in its completion port and will call the completion notification method of the specified interface.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Wspfwext.idl.

See Also

Filter Interfaces, IFWXExternalIOCompletion


IFWXOverlapped.GetOverlapped(LPOVERLAPPED) method [ISA Server 2004]

IFWXOverlapped::GetOverlapped

The GetOverlapped method gets a pointer to a Winsock OVERLAPPED structure to use with Windows overlapped functions.

HRESULT GetOverlapped(
  LPOVERLAPPED* ppov
);

Parameters

ppov
[out] Pointer to a variable that receives a pointer to an OVERLAPPED structure.

Return Values

This method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

The handle used with the OVERLAPPED structure must first be hooked into the completion port of the Microsoft Firewall service by using the IFWXFirewall::HookToCompletionPort method.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Wspfwext.idl.

See Also

IFWXOverlapped


IFWXOverlapped.SetNotificationInterface (2 Parameters) method [ISA Server 2004]

IFWXOverlapped::SetNotificationInterface

The SetNotificationInterface method sets the callback for the completion of the overlapped I/O.

HRESULT SetNotificationInterface(
  IFWXExternalIOCompletion* piExternalIOCompletion,
  UserContextType UserData
);

Parameters

piExternalIOCompletion
[in] Pointer to an IFWXExternalIOCompletion interface that is notified when the overlapped I/O is completed.
UserData
[in] An opaque value to pass to the IFWXExternalIOCompletion::CompleteAsyncIO notification method. This parameter provides a context to the notification.

Return Values

This method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

The UserData parameter provides a context to the notification. You can use the same notification interface for completion notifications from distinct network socket objects and differentiate between them by using different values for UserData.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Wspfwext.idl.

See Also

IFWXOverlapped


IFWXPerRuleData interface [ISA Server 2004]

IFWXPerRuleData

TheIFWXPerRuleData interface provides a method for preparing the per-rule configuration data.

Methods in Vtable Order

The IFWXPerRuleData interface inherits the methods of the standard COM interface IUnknown.

In addition, IFWXPerRuleData defines the following method.

Method | Description
PrepareRulesData | Prepares the per-rule configuration data.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Wspfwext.idl.

See Also

Filter Interfaces


IFWXPerRuleData.PrepareRulesData (2 Parameters) method [ISA Server 2004]

IFWXPerRuleData::PrepareRulesData

The PrepareRulesData method prepares the per-rule configuration data.
HRESULT PrepareRulesData(
  FPCPolicyRule* pPolicyRule,
  IFWXPerRuleDataplugin** ProcessedRulesData
);

Parameters

pPolicyRule
[in] Pointer to the FPCPolicyRule object.
ProcessedRulesData
[out] Address of an interface pointer that on return points to an IFWXPerRuleDataplugin interface representing the processed per-rule configuration data. This data is processed by the Microsoft Firewall service when it starts, or when the rules are changed.

Return Values

This method returns S_OK if the call is successful; otherwise, it returns an error code.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Wspfwext.idl.

See Also

IFWXPerRuleData


IFWXPerRuleDataplugin interface [ISA Server 2004]

IFWXPerRuleDataplugin

TheIFWXPerRuleDataplugin interface provides a method for comparing the per-rule configuration data with the per-rule configuration data in a previously created object.

Methods in Vtable Order

The IFWXPerRuleDataplugin interface inherits the methods of the standard COM interface IUnknown.

In addition, IFWXPerRuleDataplugin defines the following method.

Method | Description
CompareRulesData | Compares the per-rule configuration data with the per-rule configuration data in a previously created object.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Wspfwext.idl.

See Also

Filter Interfaces


IFWXPerRuleDataplugin.CompareRulesData (1 Parameter) method [ISA Server 2004]

IFWXPerRuleDataplugin::CompareRulesData

The CompareRulesData method compares the per-rule configuration data with the per-rule configuration data in a previously created object.
HRESULT CompareRulesData(
  IFWXPerRuleDataplugin* pProcessedRulesData
);

Parameters

pProcessedRulesData
[in] Pointer to a previously created object containing the per-rule configuration data that is to be compared.

Return Values

This method can return one of the following:
S_OK
The method succeeded, and the sets of per-rule configuration data in the objects compared are identical.
S_FALSE
The method succeeded, but the sets of per-rule configuration data in the objects compared are different.
An error code
The method failed.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Wspfwext.idl.

See Also

IFWXPerRuleDataplugin


IFWXPolicyChangeNotification interface [ISA Server 2004]

IFWXPolicyChangeNotification

The IFWXPolicyChangeNotification interface includes a method for receiving a notification from the Microsoft Firewall service when changes to the configuration of the ISA Server administration COM objects are applied in a call to a Save method with the fReloadConfiguration parameter set to VARIANT_TRUE. An application filter can handle this event by reloading the saved configuration of the ISA Server administration COM objects from persistent storage to synchronize with these changes.

When To Implement

An application filter that requires the current ISA Server administration configuration should implement this interface to receive notifications that changes to the configuration of the ISA Server administration COM objects have been applied.

Methods in Vtable Order

The IFWXPolicyChangeNotification interface inherits the methods of the standard COM interface IUnknown.

In addition, IFWXPolicyChangeNotification defines the following method.

Method | Description
ReloadConfiguration | Receives a notification from the Microsoft Firewall service that changes to the configuration of the ISA Server administration COM objects have been applied in a call to a Save method with the fReloadConfiguration parameter set to VARIANT_TRUE and can perform user-defined operations to reload the saved configuration of the ISA Server administration COM objects from persistent storage.

Remarks

A call to a Save method with the fReloadConfiguration parameter set to VARIANT_TRUE ensures only that configuration changes that can be applied dynamically without restarting services take effect. Changes that require restarting of the Firewall service are applied during a call to a Save method only if the fResetRequiredServices parameter is set to VARIANT_TRUE. For more information, see Restarting Services after Configuration Changes.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Wspfwext.idl.

See Also

Filter Interfaces


IFWXPolicyChangeNotification.ReloadConfiguration method [ISA Server 2004]

IFWXPolicyChangeNotification::ReloadConfiguration

The ReloadConfiguration method receives a notification from the Microsoft Firewall service that changes to the configuration of the ISA Server administration COM objects have been applied in a call to a Save method with the fReloadConfiguration parameter set to VARIANT_TRUE and can perform user-defined operations to reload the saved configuration of the ISA Server administration COM objects from persistent storage.

HRESULT ReloadConfiguration();

Parameters

This method has no parameters.

Return Values

The implementation of this method should return S_OK if the reloading operation succeeds or any valid Windows error code if reloading of any part of the configuration fails.

Remarks

A call to a Save method with the fReloadConfiguration parameter set to VARIANT_TRUE ensures only that configuration changes that can be applied dynamically without restarting services take effect. Changes that require restarting of the Firewall service are applied during a call to a Save method only if the fResetRequiredServices parameter is set to VARIANT_TRUE. For more information, see Restarting Services after Configuration Changes.

The Firewall service notifies multiple application filters one-by-one after it has reloaded the saved configuration with the most recent changes from persistent storage to the ISA Server services.

Calls to the ReloadConfiguration method are serialized with calls to the FilterInit and FilterShutdown methods of the filter.

When a Save method is invoked because the user pressed the Apply button in ISA Server Management and the ReloadConfiguration method returns an error, the Firewall service will display a message to the user in ISA Server Management, indicating that the reload operation failed and directing the user to look in the event log for details about the failure. It is the responsibility of the application filter to write the error code and a specific description in the event log with details about the part of the configuration that failed to reload.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Wspfwext.idl.

See Also

IFWXPolicyChangeNotification


IFWXRadiusAuthenticator interface [ISA Server 2004]

IFWXRadiusAuthenticator

The IFWXRadiusAuthenticator interface represents the mechanism that authenticates RADIUS users.

Methods in Vtable Order

The IFWXRadiusAuthenticator interface inherits the methods of the standard COM interface IUnknown.

In addition, IFWXRadiusAuthenticator defines the following method.

Method | Description
AuthenticateRadiusUser | Performs RADIUS authentication of the specified user in an asynchronous operation.

Remarks

An application filter can use IFWXFirewall2::CreateRadiusAuthenticator to get the IFWXRadiusAuthenticator interface.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Wspfwext.idl.

See Also

Filter Interfaces


IFWXRadiusAuthenticator.AuthenticateRadiusUser method [ISA Server 2004]

IFWXRadiusAuthenticator::AuthenticateRadiusUser

The AuthenticateRadiusUser method performs RADIUS authentication of the specified user in an asynchronous operation.

HRESULT AuthenticateRadiusUser(
  BSTR bstrUsername,
  BSTR bstrUserPassword,
  IFWXAuthenticationCompletion* pIFWXAuthenticationCompletion,
  UserContextType UserData
);

Parameters

bstrUsername
[in] String value that specifies the user name with which to perform authentication.
bstrUserPassword
[in] String value that specifies the user password with which to perform authentication.
pIFWXAuthenticationCompletion
[in] A pointer to an IFWXAuthenticationCompletion interface.
UserData
[in] An opaque value which you can use to differentiate between authentication operations. This value will be passed in the UserData parameter of the CompleteAsyncAuthentication method on the IFWXAuthenticationCompletion interface specified in the pIFWXAuthenticationCompletion parameter when this authentication operation completes.

Return Values

This method returns S_OK or ERROR_IO_PENDING if the call is successful; otherwise, it returns a Windows error code, in which case the authentication operation is not initiated and the completion function will not be called.

Remarks

An application filter can use IFWXFirewall2::CreateRadiusAuthenticator to get the IFWXRadiusAuthenticator interface. When a request is received on a listener that has RADIUS authentication enabled, and the application filter needs to perform RADIUS authentication, it calls IFWXRadiusAuthenticator::AuthenticateRadiusUser and gives it the pointer to its IFWXAuthenticationCompletion interface.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Wspfwext.idl.

See Also

IFWXRadiusAuthenticator


IFWXSession interface [ISA Server 2004]

IFWXSession

The IFWXSession interface is implemented by the Microsoft Firewall service on the session object. The IFWXSession interface is used to attach a data filter to a session and to monitor the session's events.

The session object implements session-specific functions that impersonate the user account, test access control lists (ACLs) against the session user, retrieve information about the client computer, and perform protocol operations.

Methods in Vtable Order

The IFWXSession interface inherits the methods of the standard COM interface IUnknown.

In addition, IFWXSession defines the following methods.

Method | Description
GetClientAddress | Retrieves the address of the user.
GetClientMachineName | Retrieves the name of the client computer, if it is available. The Firewall client passes the computer name in the request. The name is not available for SecureNAT clients.
GetAuthenticatedUser | Retrieves an IFWXAuthenticatedUser interface that represents the authenticated user for the session.
HostAccessCheck | Checks the permission of the session user to access a specified host, by using the access rules.
AllowFutureConnect | Allows the session's client to make a secondary outbound connection.
BindForClient | Binds a set of addresses on behalf of the session's client and creates the required instances of the IFWXConnection interface in preparation for secondary inbound connections.
EmulateClientBind | Allows a client that did not create a remote bind to receive a primary inbound connection.
GetSessionFlags | Retrieves flags that provide information about the session.
RedirectConnections | Enables connections by using a local, internal Microsoft Firewall service address.
AttachFilter | Causes a filter to be loaded for this session, even if the initial event for this filter has not yet happened. If the filter has already attached a session filter for this session, nothing happens. Otherwise, the filter's IFWXFilter::AttachToSession method is called.
SetDataFilterFactory | Allows a filter to set a data filter factory for events for which the filter is not registered. This method can be used to reduce the number of events for which a filter registers.
RetroactiveAllowBind | Allows a Firewall client to receive a secondary inbound connection on a socket that was previously bound by the Firewall client, but was not necessarily approved by the Microsoft Firewall service.
CreateNetworkSocket | Creates a TCP/IP socket that is associated with this session.
GetHostByName | Retrieves host information corresponding to a host name. This method is similar to the Winsock gethostbyname function.
GetHostByAddr | Retrieves host information corresponding to an address.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Wspfwext.idl.

See Also

Filter Interfaces


IFWXSession.AllowFutureConnect (11 Parameters) method [ISA Server 2004]

IFWXSession::AllowFutureConnect

The AllowFutureConnect method allows the session's client to make a secondary outbound connection.

HRESULT AllowFutureConnect(
  LPSOCKADDR Address,
  DWORD AddressLength,
  LPSOCKADDR ProxyExternalAddress,
  DWORD ProxyExternalAddressLength,
  INT Protocol,
  DWORD dwFlags,
  REFGUID ProtocolGuid,
  IFWXSessionFilter* pSessionFilter,
  IUnknown* punkContext,
  IFWXConnection* pConnection,
  IFWXFirewallAction** ppFirewallAction
);

Parameters

Address
[in] Pointer to a sockaddr structure that contains the address to which the client will connect.
AddressLength
[in] Length, in bytes, of the structure pointed to by the Address parameter.
ProxyExternalAddress
[in] Pointer to a sockaddr structure that contains the ISA Server computer's external address that will be used for the connection (in case there is a network address translation (NAT) relationship between the source and the destination). This is useful in the case of multihomed proxy servers. Requesting a specific address can ensure that a secondary connection uses the same external IP address as the primary connection. This parameter can be NULL, defaulting to INADDR_ANY and 0 (any port).
ProxyExternalAddressLength
[in] Length, in bytes, of the ProxyExternalAddress parameter.
Protocol
[in] Protocol flags. This parameter can have the following flag values:
Value | Meaning
FWX_PROTOCOL_TCP | The connection will use the TCP protocol.
FWX_PROTOCOL_UDP | The connection will use the UDP protocol.
dwFlags
[in] Connection flags. This parameter can be a combination of the following connection flags:
Value | Meaning
FWX_FLAG_ADDRESS_BASED | The permission should be associated with the client address, and not with the client session. This is necessary if the protocol involves connections that are initiated by different processes.
FWX_FLAG_ALLOW_MULTIPLE | By default, a single outbound connection is expected. If this flag is specified, multiple connections to the same address will be possible.
FWX_FLAG_TIMEOUT | The client is expected to use the permission within approximately one minute of the call. If the client does not make the connection, the permission automatically expires.
FWX_FLAG_NO_KERNEL_MODE | Each connection goes through user-mode code, regardless of whether kernel mode could be used for the connection.
FWX_FLAG_BIDIRECTIONAL | Permission is also granted for packets coming back from the destination socket to the sending socket. This flag is only valid for UDP.
FWX_FLAG_ALLOW_ADDRESSES_IN_CLASS_C_NETWORK | If the address specified in the Address parameter is in the same class-C network as the external peer, a secondary connection to it will be allowed.
FWX_FLAG_ALLOW_ADDRESSES_IN_NETWORK | If the address specified in the Address parameter is in the same network as the external peer, a secondary connection to it will be allowed.
FWX_FLAG_ALLOW_ADDRESSES_ALL | A secondary connection will be allowed to any address that is specified in the Address parameter.
FWX_INCREASE_RECEIVE_BUFFER | The receive buffer will be increased to 64 kilobytes. This flag should be set to prevent packet loss if high-bandwidth packet bursts occur in a secondary UDP connection.
ProtocolGuid
[in] GUID identifying the protocol that the connection is part of.
pSessionFilter
[in, optional] Pointer to the IFWXSessionFilter interface. Use with the punkContext parameter to receive an event of type fwx_EstablishedConnection (as defined in the FxwFirewallEventType enumerated type) from the Microsoft Firewall service.
punkContext
[in, optional] Provides user context information regarding the connection. Use with the pSessionFilter parameter to receive an event of type fwx_EstablishedConnection from the Firewall service. Specify NULL if notification of fwx_EstablishedConnection events is not required, or if you do not need to pass any context information.
pConnection
[in, optional] Pointer to the IFWXConnection interface. This parameter can be NULL if the FWX_FLAG_ALLOW_ADDRESSES_ALL flag is specified.
ppFirewallAction
[out] Address of a variable that receives a pointer to the IFWXFirewallAction interface on the Firewall service action object created as a result of this call. This parameter can be NULL.

Return Values

S_OK
The method succeeded.
FWX_E_ADDRESS_NOT_ALLOWED
No secondary connection will be allowed because the target address conflicts with the set of allowed addresses.
FWX_E_PROTOCOL_RULES_DENIED
The connection will not be allowed because it conflicts with the protocol rules for the session user.
FWX_E_SITE_AND_CONTENT_RULES_DENIED
The connection will not be allowed because it conflicts with the policy rules for the session user.
HRESULT_FROM_WIN32(ERROR_DUP_NAME)
The call failed because the filter was previously called AllowFutureConnect to allow a connection to the same IP address and port.

Remarks

A filter should call this method when it detects (by inspecting another connection, such as the primary connection) that the client is requested to make a TCP connection to a server, or to send one or more UDP datagrams to the server. This is usually known when the server sends an address to the client. For example, when an FTP server sends the following, it is instructing the client to connect to address 198.105.232.1 on port 1046.

227 Entering Passive Mode (198,105,232,1,4,22)

The call allows an outbound connection from the client designated in the session object (the IP address given by the GetClientAddress method) to the specified address.

A data filter cannot be attached to a kernel-mode connection. The Firewall service will not make a kernel-mode connection if a data filter is expected to be set on the connection, or if a filter is registered for the resulting connection event. When a filter calls SetDataFilterFactory, the decision has already been made and cannot be modified. A filter that is going to call SetDataFilterFactory for the resulting connection should specify FWX_FLAG_NO_KERNEL_MODE. A filter that already called SetDataFilterFactory for the resulting connection is not required to specify this flag.

The FWX_FLAG_TIMEOUT flag cannot be set together with the FWX_FLAG_ALLOW_MULTIPLE flag.

For enhanced security, a secondary connection will be allowed, by default, only if the address specified in the Address parameter is the address of the external peer of the session. Filters that need to allow connections to other addresses can do so by using a combination of flags that includes FWX_FLAG_ALLOW_ADDRESSES_IN_CLASS_C_NETWORK, FWX_FLAG_ALLOW_ADDRESSES_IN_NETWORK, or FWX_FLAG_ALLOW_ADDRESSES_ALL.

However, setting any of these flags can allow a malicious internal or external client to launch an attack in various protocols by telling an internal published server to connect to an arbitrary address, or can allow a malicious server to ask an internal client to connect to an arbitrary address. One such attack is the FTP bounce attack. In one form of this attack, a malicious FTP server sends a PASV response to an FTP client that induces a filter to allow a connection from the FTP client to an arbitrary address.

A filter should not call this method twice to allow a connection to the same IP address and port.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Wspfwext.idl.

See Also

IFWXSession, IFWXFirewallAction, IFWXSession::GetClientAddress, IFWXSession::SetDataFilterFactory


IFWXSession.AttachFilter(REFCLSID) method [ISA Server 2004]

IFWXSession::AttachFilter

The AttachFilter method causes a filter to be loaded for this session, even if the initial event for this filter has not yet happened. If the filter has already attached a session filter for this session, nothing happens. Otherwise, the filter's IFWXFilter::AttachToSession method is called.

HRESULT AttachFilter(
  REFCLSID guidFilter
);

Parameters

guidFilter
[in] CLSID of the filter to load.

Return Values

S_OK
The method succeeded.
REGDB_E_CLASSNOTREG
The GUID does not represent a valid filter.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Wspfwext.idl.

See Also

IFWXSession


IFWXSession.BindForClient (13 Parameters) method [ISA Server 2004]

IFWXSession::BindForClient

The BindForClient method binds a set of addresses on behalf of the session's client and creates the required instances of the IFWXConnection interface in preparation for secondary inbound connections.

This method permits a SecureNAT client to receive secondary inbound connections. It also allows a client application—for which the Firewall Client component failed to create a remote socket for a bind call—to receive an inbound connection. The processing done by the filter can be the same in both cases. The only difference is that in the case of a SecureNAT client, the filter knows that the client is sending a private address that has to be translated. For a Firewall client, the filter has to verify that the client is sending an internal address on an external network adapter.

HRESULT BindForClient(
  LPSOCKADDR ClientAddresses[],
  DWORD ClientAddressLength,
  LPSOCKADDR ProxyAddress,
  DWORD ProxyAddressLength,
  INT Protocol,
  DWORD dwNumberOfAddresses,
  DWORD dwFlags,
  INT Backlog,
  REFGUID ProtocolGuid,
  IFWXSessionFilter* pSessionFilter,
  IUnknown* punkContext,
  IFWXIpFilter* pIpFilter,
  IFWXConnection* ConnectionArray[]
);

Parameters

ClientAddresses
[in] Pointer to an array of pointers to sockaddr structures that contain the addresses that the client uses. The array contains dwNumberOfAddresses pointers. Occasionally, a client address is not yet known. In these rare cases, it is possible to specify an address of all zeros. After the client address is known, the IFWXConnection::SetClientAddress method can be called to change the address.
ClientAddressLength
[in] Length, in bytes, of the addresses pointed to by the ClientAddresses parameter.
ProxyAddress
[in, out] Pointer to a sockaddr structure that contains the address to which the filter is to bind. This address is typically an external IP address of the ISA Server computer, and the port number is set to PORT_ANY (0). On return, this parameter receives the actual address to which the filter binds. This parameter can also accept an internal client address, as in the case of routed networks. This allows inbound access for the specified internal client without allocating an address of the ISA Server computer.
ProxyAddressLength
[in] Length, in bytes, of the ProxyAddress parameter.
Protocol
[in] Protocol flags. This parameter can have the following flag values:
Value | Meaning
FWX_PROTOCOL_TCP | The request is for a TCP socket.
FWX_PROTOCOL_UDP | The request is for a UDP socket.
dwNumberOfAddresses
[in] Number of consecutive addresses to assign.
dwFlags
[in] Connection flags. This parameter can be any combination of the following flag values:
Value | Meaning
FWX_FLAG_ALLOW_MULTIPLE | By default, only a single connection is expected on a listening TCP socket (for example, FTP). If more than one connection to the same address and port is expected, specify this flag. For UDP sockets, set the flag if datagrams are expected from more than one source. If only a single source will send datagrams, do not set this flag.
FWX_FLAG_TIMEOUT | When this flag is set, UDP connections are closed automatically when they are detected to be idle. For TCP, when no connection is accepted within the time-out period of approximately one minute, the listening connection is closed. When not set, the calling filter must call the IFWXConnection::Kill method to terminate each connection.
FWX_FLAG_NO_KERNEL_MODE | Each connection goes through user-mode code, regardless of whether kernel mode could be used for the connection.
FWX_FLAG_BIDIRECTIONAL | Permission is also granted to send packets back to destinations that recently sent packets to the socket. This flag is only valid for UDP.
FWX_FLAG_PROXY_MODE | Full proxy mode (or source NAT) is enabled for each connection. In this mode, the IP addresses of the sources of requests sent to an address specified in the ClientAddresses parameter for a published server are translated to an IP address of the network adapter on the ISA Server computer that is connected to the network where the published server resides, if there is a NAT network relationship between the source and destination networks.
FWX_FLAG_ALLOW_ADDRESSES_IN_CLASS_C_NETWORK | If all of the addresses specified in the ClientAddresses parameter are in the same class-C network as the client, secondary connections to them will be allowed.
FWX_FLAG_ALLOW_ADDRESSES_IN_NETWORK | If all of the addresses specified in the ClientAddresses parameter are in the same network as the client, secondary connections to them will be allowed.
FWX_FLAG_ALLOW_ADDRESSES_ALL | A secondary connection will be allowed to any address specified in the ClientAddresses parameter.
FWX_INCREASE_RECEIVE_BUFFER | The receive buffer will be increased to 64 kilobytes. This flag should be set to prevent packet loss if high-bandwidth packet bursts occur in a secondary UDP connection.
Backlog
[in] The backlog to be used by the IFWXNetworkSocket::Listen method. The Backlog parameter specifies the maximum length of the queue of pending connections. This is the same as the backlog parameter of the Winsock listen function, described in MSDN.
ProtocolGuid
[in] Globally unique identifier (GUID) identifying the protocol for the connections.
pSessionFilter
[in, optional] Pointer to the IFWXSessionFilter interface. Use with the punkContext parameter to receive an event of type fwx_EstablishedConnection (as defined in the FwxFirewallEventType enumerated type) from the Microsoft Firewall service. This parameter can be NULL, in which case no notification will be provided.
punkContext
[in, optional] Provides user context information regarding the connections. Use with the pSessionFilter parameter to receive an event of type fwx_EstablishedConnection from the Firewall service. This parameter can be NULL. Specify NULL if notification of fwx_EstablishedConnection events is not required, or if you do not need to pass any context information.
pIpFilter
Pointer to an IFWXIpFilter interface. All connections that are created by the BindForClient call will be restricted by the IFWXIpFilter interface pointed to by this parameter. If you specify NULL for this parameter, the connections will not be restricted by an IFWXIpFilter interface.
ConnectionArray
[out] Pointer to an array of dwNumberOfAddresses IFWXConnection interface pointers. The array is filled with pointers to the IFWXConnection interfaces on the resulting connection objects. The array contains dwNumberOfAddresses pointers.

Return Values

S_OK
The method succeeded.
FWX_E_PROTOCOL_RULES_DENIED
The protocol rules do not allow the user to use the protocol specified by the ProtocolGuid parameter.
HRESULT_FROM_WIN32(WSAEADDRINUSE)
The proxy address requested is already in use.
HRESULT_FROM_WIN32(WSAEADDRNOTAVAIL)
The specified address is not a valid address for this computer.
FWX_E_ADDRESS_NOT_ALLOWED
No secondary connections will be allowed because one or more of the addresses specified in the ClientAddresses parameter conflicts with the set of allowed addresses.

Remarks

This method should be called by a filter that enables a specific protocol upon detecting, by inspecting the primary connection, that the client is expecting a secondary inbound connection (either TCP or UDP). This is usually known when the client sends its address to the server as part of the protocol. For example, when an FTP client sends the following, it is instructing the server to connect to the address 10.0.0.8 on port 1553:

PORT 10,0,0,8,6,17

A filter acting as a SecureNAT editor detecting such a command should call the BindForClient method, which binds an external socket and associates it with the client socket.

The call allows inbound connections to the client designated in the session object. The ClientAddresses parameter will contain the IP address and port sent by the client, and will usually contain the same IP address that is returned by the GetClientAddress method.

Like other bind requests, any filter registered for events of types fwx_Bind_Tcp and fwx_Bind_Udp (as defined in the FwxFirewallEventType enumerated type) is notified about this bind and has an opportunity to deny it. The filter may also install a data filter or even emulate the bind.

If no data filter is installed, the Firewall service handles this connection in kernel mode. A connection handled in kernel mode is less delayed and uses less CPU and memory resources on the Firewall service.

The filter is expected to modify the control stream and send a modified address to the server. For the FTP example, the PORT command will be modified to reflect the address and port returned in the ProxyAddress parameter.

This method also allows multiple consecutive ports to be assigned and returns connection objects that can be used to control the resulting connections.

When dwNumberOfAddresses is greater than 1, a set of consecutive ports is allocated. The lowest port allocated is a multiple of dwNumberOfAddresses. The set of addresses specified in ConnectionArray does not have to be consecutive. The first address in ConnectionArray corresponds to the lowest port, the second to the next port, and so on.

On input, the ProxyAddress parameter can be used to force binding to a specific network adapter of the ISA Server computer, and to force a specific port (only when dwNumberOfAddresses is 1). On output, the ProxyAddress is filled with the bound address. When dwNumberOfAddresses is greater than 1, the address with the lowest port number is returned.

If FWX_FLAG_TIMEOUT is not specified, the connection object will not be deleted until the filter calls the IFWXConnection::Kill method.

The FWX_FLAG_TIMEOUT flag cannot be specified together with the FWX_FLAG_ALLOW_MULTIPLE flag.

A data filter cannot be attached to a kernel-mode connection. The Firewall service will not make a kernel-mode connection if a data filter is expected to be set on the connection, or if a filter is registered for the resulting connection event. When a filter calls SetDataFilterFactory, the decision has already been taken and cannot be modified. A filter that is going to call SetDataFilterFactory for the resulting connection should specify FWX_FLAG_NO_KERNEL_MODE. A filter that already called SetDataFilterFactory for the resulting connection is not required to specify this flag.

An application filter should set the FWX_FLAG_PROXY_MODE flag in a call to BindForClient and thereby enable full proxy mode for secondary connections only if the session is in full proxy mode. Full proxy mode is stipulated by the applicable server publishing rule and can be determined by retrieving the connection flags that are set for the connection object of the primary connection. The following code calls the GetConnectionFlags method to retrieve these flags and tests whether the FWX_CONNECTION_INTERNAL_ADDRESS_TRANSLATION flag, which indicates full proxy mode, is set:

DWORD dwConnectionFlags = 0;
if (_spConnection)
{
    hr = _spConnection->GetConnectionFlags(&dwConnectionFlags;);
    if (FAILED(hr))
    {
        return hr;
    }
}
_IsFullProxyMode = (dwConnectionFlags & FWX_CONNECTION_INTERNAL_ADDRESS_TRANSLATION);

The filter can then use the value obtained to set the dwFlags parameter in the call to BindForClient:

DWORD dwFlags = _IsFullProxyMode ? FWX_FLAG_PROXY_MODE : 0;

For enhanced security, a secondary connection is allowed, by default, only if the addresses specified in the ClientAddresses parameter are IP addresses on the client of the session. Filters that need to allow connections to other hosts can do so by using a combination of flags that includes FWX_FLAG_ALLOW_ADDRESSES_IN_CLASS_C_NETWORK, FWX_FLAG_ALLOW_ADDRESSES_IN_NETWORK, or FWX_FLAG_ALLOW_ADDRESSES_ALL.

However, setting any of these flags can allow a malicious internal or external user to launch an attack in various protocols by asking an external server to connect to arbitrary ports on the ISA Server computer. One such attack is the FTP bounce attack. In one form of this attack, a malicious client that is allowed FTP access through an ISA Server computer can send a PORT command to an external FTP server that will induce a filter to open arbitrary ports on the ISA Server computer for unauthorized purposes.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Wspfwext.idl.

See Also

IFWXSession, IFWXConnection, IFWXIpFilter, IFWXConnection::Kill, IFWXConnection::SetClientAddress, IFWXSession::SetDataFilterFactory


IFWXSession.CreateNetworkSocket(INT,IFWXNetworkSocket) method [ISA Server 2004]

IFWXSession::CreateNetworkSocket

The CreateNetworkSocket method creates a TCP/IP socket that is associated with this session.

HRESULT CreateNetworkSocket(
  INT Protocol,
  IFWXNetworkSocket** piSocket
);

Parameters

Protocol
[in] Protocol flags. This parameter can have the following flag values:
Value | Meaning
FWX_PROTOCOL_TCP | The method will create a TCP socket.
FWX_PROTOCOL_UDP | The method will create a UDP socket.
piSocket
[out] Address of a variable that receives a pointer to the IFWXNetworkSocket interface.

Return Values

S_OK
The socket was created.
E_OUTOFMEMORY
Insufficient memory or resources to process the event. The socket was not created.
HRESULT_FROM_WIN32(win32 error code)
Winsock or Windows error code. The method failed and the socket was not created.

Remarks

The socket created by this method is user specific, and obeys the policy rules for the session. Connections are logged as if they were performed by the session's user.

To create a socket that is not user specific, use IFWXFirewall::CreateNetworkSocket.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Wspfwext.idl.

See Also

IFWXSession, IFWXFirewall::CreateNetworkSocket


IFWXSession.EmulateClientBind (8 Parameters) method [ISA Server 2004]

IFWXSession::EmulateClientBind

The EmulateClientBound method allows a client that did not create a remote bind to receive a primary inbound connection.

HRESULT EmulateClientBind(
  LPSOCKADDR ClientAddress,
  DWORD ClientAddressLength,
  LPSOCKADDR ProxyAddress,
  DWORD ProxyAddressLength,
  INT Protocol,
  REFGUID ProtocolGuid,
  IFWXConnection** piConnection,
  BOOL fInternalAddressTranslation
);

Parameters

ClientAddress
[in] Pointer to a sockaddr structure that contains the address that the client used.
ClientAddressLength
[in] Length, in bytes, of the ClientAddress parameter.
ProxyAddress
[in] Pointer to a sockaddr structure that contains the address to which the filter is to emulate a bind. This is usually an external IP address of the ISA Server computer and a specific port number. The EmulateClientBind method does not actually bind to that address. The address is used for the bind event generated.
ProxyAddressLength
[in] Length, in bytes, of the ProxyAddress parameter.
Protocol
[in] Protocol flag. This parameter can have the following flag values:
Value | Meaning
FWX_PROTOCOL_TCP | The request is for a TCP socket.
FWX_PROTOCOL_UDP | The request is for a UDP socket.
ProtocolGuid
[in] GUID identifying the protocol that the connection is part of.
piConnection
[out] Address of an interface pointer that on return points to the resulting IFWXConnection interface.
fInternalAddressTranslation
[in] Boolean value that indicates whether the translation of external addresses to internal addresses is to be enabled for the inbound connection.

Return Values

This method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This method should be called by a filter whose purpose is to enable a specific protocol. The filter uses this method when it needs to forward a primary connection made from an external source to a local computer that did not make a remote bind through the Microsoft Firewall service. For example, this could be a local computer that is not a Firewall client.

This method will usually be called by a filter that is listening on some well-known port when it receives a connection. The filter decides (based on the source address, data exchange with the caller, a hard-coded address, and so on) that this call should be forwarded to some internal client.

The filter cannot use the BindForClient method because the well-known port is already in use and the connection was already made.

This method creates a connection object on which the caller can call the IFWXConnection::EmulateConnection method and forward the connection to the client.

Like other bind requests, any filter registered for the fwx_Bind_* events is notified about this bind and has an opportunity to deny it. It may also install a data filter. Other filters cannot emulate this bind because the caller is already emulating it.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Wspfwext.idl.

See Also

IFWXSession, IFWXConnection::EmulateConnection, IFWXSession::BindForClient


IFWXSession.GetAuthenticatedUser(IFWXAuthenticatedUser) method [ISA Server 2004]

IFWXSession::GetAuthenticatedUser

The GetAuthenticatedUser method retrieves an IFWXAuthenticatedUser interface that represents the authenticated user for the session.

HRESULT GetAuthenticatedUser(
  IFWXAuthenticatedUser** ppIFWXAuthenticatedUser
);

Parameters

ppIFWXAuthenticatedUser
[out] Address of an interface pointer that on return points to the IFWXAuthenticatedUser interface that represents the authenticated user for the session.

Return Values

This method can return one of the following:

  • S_OK, indicating that the operation succeeded.
  • An error message, indicating that the operation failed. In this case, the [out] parameter returned is a null object.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Wspfwext.idl.

See Also

IFWXSession


IFWXSession.GetClientAddress(LPSOCKADDR,LPDWORD) method [ISA Server 2004]

IFWXSession::GetClientAddress

The GetClientAddress method retrieves the address of the user.

HRESULT GetClientAddress(
  LPSOCKADDR Address,
  LPDWORD AddressLength
);

Parameters

Address
[out] Pointer to a sockaddr structure that receives the client address (port = 0 for AF_INET).
AddressLength
[in, out] Pointer to the length, in bytes, of the address specified in the Address parameter. On return, AddressLength receives the actual size of the address returned in Address.

Return Values

This method returns S_OK if the call is successful; otherwise, it returns an error code.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Wspfwext.idl.

See Also

IFWXSession


IFWXSession.GetClientMachineName(LPSTR) method [ISA Server 2004]

IFWXSession::GetClientMachineName

The GetClientMachineName method retrieves the name of the client computer, if it is available. The Firewall client passes the computer name in the request. The name is not available for SecureNAT clients.

HRESULT GetClientMachineName(
  LPSTR* pszMachineName
);

Parameters

pszMachineName
[out] Address of a a pointer to a buffer that receives the requested computer name string. The caller must free the pszMachineName buffer by using the CoTaskMemFree function.

Return Values

This method returns S_OK if the call is successful; otherwise, it returns an error code.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Wspfwext.idl.

See Also

IFWXSession


IFWXSession.GetHostByAddr(char,int,int,char,int) method [ISA Server 2004]

IFWXSession::GetHostByAddr

The GetHostByAddr method retrieves host information corresponding to an address.

HRESULT GetHostByAddr(
  const char* addr,
  int len,
  int type,
  char* buf,
  int* buflen
);

Parameters

addr
[in] Pointer to the network address for the host. Host addresses are stored in network byte order.
len
[in] Length of the address.
type
[in] Type of the address.
buf
[out] Pointer to the data area to receive the hostent data. The data area must be larger than the size of a hostent structure because the supplied data area is used by Windows Sockets (Winsock) to contain a hostent structure and all of the data referenced by members of the hostent structure. A buffer of MAXGETHOSTSTRUCT bytes is recommended.
buflen
[in, out] On input, specifies the size of the data area for the buf parameter. If the buffer is too small, the error code HRESULT_FROM_WIN32(ERROR_INSUFFICIENT_BUFFER) is returned and the buflen parameter receives the size of the required buffer.

Return Values

S_OK
The method was successful. The buffer was filled with the host information.
HRESULT_FROM_WIN32(ERROR_INSUFFICIENT_BUFFER)
Insufficient buffer space was provided. That is, the buffer pointed to by buf is not large enough to contain the host information.
HRESULT_FROM_WIN32(WSAHOST_NOT_FOUND)
The address specified could not be found in the relevant database.
HRESULT_FROM_WIN32(WSATRY_AGAIN)
No response was received from an authoritative server.
HRESULT_FROM_WIN32(WSANO_DATA)
The address specified is valid and was found in the database, but no information of the type requested is associated with it.

Remarks

Like the IFWXFirewall::GetHostByAddr method, this method checks permissions and policy rules, prior to providing the address. If there are no permissions or if the policy rules do not allow access, the host information will not be provided, and the method will return HRESULT_FROM_WIN32(WSAHOST_NOT_FOUND). This method also logs the name resolution and can use autodial to dial out for the name resolution.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Wspfwext.idl.

See Also

IFWXSession


IFWXSession.GetHostByName(char,char,int) method [ISA Server 2004]

IFWXSession::GetHostByName

The GetHostByName method retrieves host information corresponding to a host name. This method is similar to the Winsock gethostbyname function.

HRESULT GetHostByName(
  const char* name,
  char* buf,
  int* buflen
);

Parameters

name
[in] Pointer to a null-terminated string that specifies the name of the host. UTF-8 encoding is expected in this parameter.
buf
[out] Pointer to the data area to receive the hostent data. The data area must be larger than the size of a hostent structure because the supplied data area is used by Windows Sockets (Winsock) to contain a hostent structure and all of the data referenced by members of the hostent structure. A buffer of MAXGETHOSTSTRUCT bytes is recommended. The strings returned in the structure are encoded using the current system ANSI code page (ACP).
buflen
[in, out] On input, specifies the size of data area for the buf parameter. If the buffer is too small, the error code HRESULT_FROM_WIN32(ERROR_INSUFFICIENT_BUFFER) is returned and the buflen parameter receives the size of the required buffer.

Return Values

S_OK
The method was successful. The buffer was filled with the host information.
HRESULT_FROM_WIN32(ERROR_INSUFFICIENT_BUFFER)
Insufficient buffer space was provided. That is, the buffer pointed to by buf is not large enough to contain the host information.
HRESULT_FROM_WIN32(WSAHOST_NOT_FOUND)
The name specified could not be found in the relevant database.
HRESULT_FROM_WIN32(WSATRY_AGAIN)
No response was received from an authoritative server.
HRESULT_FROM_WIN32(WSANO_DATA)
The name specified is valid and was found in the database, but no information of the type requested is associated with it.

Remarks

Like the IFWXFirewall::GetHostByName method, this method checks permissions and policy rules, prior to providing the address. If there are no permissions or if the policy rules do not allow access, the host information will not be provided, and the method returns HRESULT_FROM_WIN32(WSAHOST_NOT_FOUND). This method also logs the name resolution and can use autodial to dial out for the name resolution.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Wspfwext.idl.

See Also

IFWXSession


IFWXSession.GetSessionFlags(LPDWORD) method [ISA Server 2004]

IFWXSession::GetSessionFlags

The GetSessionFlags method retrieves flags that provide information about the session.

HRESULT GetSessionFlags(
  LPDWORD pOutputFlags
);

Parameters

pOutputFlags
[out] Pointer to a variable that receives the session flags. The flags can be a combination of the following values:
Value | Meaning
FWX_SESSION_NAT | The session is using SecureNAT, or is a session between routed networks (not a Microsoft Firewall service control channel).
FWX_SESSION_PRIVATE | The session was created by a filter by using IFWXFirewall::CreatePrivateSession.
FWX_SESSION_AUTHENTICATED | The Firewall service authenticated the session.
FWX_SESSION_TERMINATED | The session was terminated and is no longer valid.

Return Values

This method returns S_OK if the call is successful; otherwise, it returns an error code.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Wspfwext.idl.

See Also

IFWXSession, IFWXFirewall::CreatePrivateSession


IFWXSession.HostAccessCheck (8 Parameters) method [ISA Server 2004]

IFWXSession::HostAccessCheck

The HostAccessCheck method checks the permission of the session user to access a specified host, by using the access rules.

HRESULT HostAccessCheck(
  REFGUID FilterGuid,
  REFGUID ProtocolGuid,
  LPHOSTENT Hostent,
  USHORT SrcPort,
  LPCSTR pszPath,
  LPCSTR pszMime,
  DWORD dwFlags,
  IUnknown** ProcessedRulesData
);

Parameters

FilterGuid
[in] Reference to the GUID identifying the filter that the connection is part of.
ProtocolGuid
[in] Reference to the GUID that identifies the protocol.
Hostent
[in] Pointer to a hostent structure that specifies the host.
SrcPort
[in] The source port number.
pszPath
[in] Pointer to a null-terminated string containing the path to be checked. This parameter may be NULL if the path is unknown or irrelevant.
pszMime
[in] Pointer to a null-terminated string containing the MIME data type (such as "text/html") to be checked. This parameter can be NULL if the MIME type is unknown or irrelevant.
dwFlags
[in, optional] HostAccessCheck flags. This parameter can be a bitwise combination of the following values, or 0 if none of the options apply:
Value | Meaning
FWX_FLAG_USE_MIME | The pszMime parameter is currently NULL, but may be known later. If this flag is specified, and the pszMime parameter is NULL and the MIME type is required for processing of the rules, FWX_E_MIME_NEEDED will be returned.
FWX_FLAG_USE_EXTENTION | Use the extension of the pszPath parameters for content filtering.
FWX_FLAG_CHECK_PUBLISHING | Use this parameter to include publishing rules in the permission decision. If this parameter is not set, publishing rules will not be taken into consideration. This flag is typically used with FWX_FLAG_BYPASS_ALLOW_ACCESS. When these parameters are used together, only deny rules and publishing rules will be checked.
FWX_FLAG_BYPASS_ALLOW_ACCESS | Use this parameter to instruct the Microsoft Firewall service not to check allow rules. This flag is typically used with FWX_FLAG_CHECK_PUBLISHING. When these parameters are used together, only deny rules and publishing rules will be checked.
ProcessedRulesData
[in] Data regarding the per-rule configuration of the filter. This data is processed by the Firewall service when it starts, or when you change the rules.

Return Values

S_OK
The user is allowed to access the host.
S_FALSE
The user is denied access to the host.
E_INVALIDARG
More than one host name or IP address was specified in the Hostent parameter.
FWX_E_MIME_NEEDED
The FWX_FLAG_USE_MIME was specified, the pszMime parameter was NULL, and the MIME type is required to complete the processing of the rules.
Error code
The method failed.

Remarks

The hostent structure may contain a host name or an IP address, or both a host name and an IP address, but it may not contain more than one host name or IP address. Access is checked based on the information available in the hostent structure.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Wspfwext.idl.

See Also

IFWXSession, IFWXFirewall::CreatePrivateSession


IFWXSession.RedirectConnections (13 Parameters) method [ISA Server 2004]

IFWXSession::RedirectConnections

The RedirectConnections method enables connections by using a local, internal Microsoft Firewall service address.

HRESULT RedirectConnections(
  LPSOCKADDR ConnectAddresses[],
  DWORD ConnectAddressLength,
  DWORD dwNumberOfAddresses,
  LPSOCKADDR InternalAddress,
  LPDWORD InternalAddressLength,
  LPSOCKADDR ProxyExternalAddress,
  DWORD ProxyExternalAddressLength,
  INT Protocol,
  DWORD dwFlags,
  REFGUID ProtocolGuid,
  IFWXSessionFilter* pSessionFilter,
  IUnknown* punkContext,
  IFWXFirewallAction* FirewallActionArray[]
);

Parameters

ConnectAddresses
[in] Pointer to an array of pointers to sockaddr structures that contain the addresses to which the client connections will be redirected.
ConnectAddressLength
[in] Length, in bytes, of the addresses pointed to by the ConnectAddresses parameter.
dwNumberOfAddresses
[in] Number of addresses in the ConnectAddresses array.
InternalAddress
[out] The socket address on the ISA Server internal interface where the client should connect. This value is updated by the Firewall service.
InternalAddressLength
[in, out] Length, in bytes, of the InternalAddress parameter.
ProxyExternalAddress
[in] Pointer to a sockaddr structure that contains the ISA Server computer's external address used for the connection. This is useful in the case of multihomed ISA Server computers. Requesting a specific address ensures that a secondary connection uses the same IP address as the primary connection. This parameter can be NULL, defaulting to INADDR_ANY and 0 (any port).
ProxyExternalAddressLength
[in] Length, in bytes, of the ProxyExternalAddress structure.
Protocol
[in] Protocol flags. This parameter can have the following flag values:
Value | Meaning
FWX_PROTOCOL_TCP | The connection will use a TCP socket.
FWX_PROTOCOL_UDP | The connection will use a UDP socket.
dwFlags
[in] Connection flags. This parameter can be a combination of the following values:
Value | Meaning
FWX_FLAG_ALLOW_MULTIPLE | By default, a single outbound connection is expected. If this flag is specified, multiple connections to the same address will be possible.
FWX_FLAG_TIMEOUT | The client is expected to use the permission shortly after the call. If the client does not make the connection, the permission automatically expires.
FWX_FLAG_NO_KERNEL_MODE | Each connection goes through user-mode code, regardless of whether kernel mode could be used for the connection.
FWX_INCREASE_RECEIVE_BUFFER | The receive buffer will be increased to 64 kilobytes. This flag should be set to prevent packet loss if high-bandwidth packet bursts occur in a secondary UDP connection.
ProtocolGuid
[in] GUID that identifies the protocol that the connection is part of.
pSessionFilter
[in, optional] Pointer to the IFWXSessionFilter interface. Use with the UserContext parameter to receive an event of type fwx_EstablishedConnection (as defined in the FxwFirewallEventType enumerated type) from the proxy.
punkContext
[in, optional] Provides user context information regarding the connection. Use with the pSessionFilter parameter to receive an event of type fwx_EstablishedConnection from the Firewall service. This parameter can be NULL. Specify NULL if notification of fwx_EstablishedConnection events is not required, or if you do not need to pass any context information.
FirewallActionArray
[out] Pointer to an array of IFWXFirewallAction interface pointers. The array is filled with pointers to IFWXFirewallAction interfaces to the firewall action objects created by this call. The array contains dwNumberOfAddresses pointers.

Return Values

This method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This method is intended for use by filters that act as an application proxy that has to establish secondary connections and give the same address as the primary connection for the secondary connection.

Filters for Firewall clients and for SecureNAT clients usually use AllowFutureConnect instead.

Calling this method causes all filters that are registered for connect events on the appropriate port to be notified. If no data filters are installed, a kernel-mode NAT redirection may result.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Wspfwext.idl.

See Also

IFWXSession, IFWXFirewallAction, IFWXSession::AllowFutureConnect


IFWXSession.RetroactiveAllowBind (6 Parameters) method [ISA Server 2004]

IFWXSession::RetroactiveAllowBind

The RetroactiveAllowBind method allows a Firewall client to receive a secondary inbound connection on a socket that was previously bound by the Firewall client, but was not necessarily approved by the Microsoft Firewall service.

HRESULT RetroactiveAllowBind(
  INT Protocol,
  LPSOCKADDR Address,
  DWORD AddressLength,
  REFGUID ProtocolGuid,
  DWORD dwFlags,
  IFWXIpFilter* pIpFilter
);

Parameters

Protocol
[in] Protocol flags. This parameter can have the following flag values:
Value | Meaning
FWX_PROTOCOL_TCP | The bind uses the TCP protocol.
FWX_PROTOCOL_UDP | The bind uses the UDP protocol.
Address
[in] Pointer to a sockaddr structure that contains the external IP address of the ISA Server computer for which this request is made. The address can be INADDR_ANY. The port number must be nonzero.
AddressLength
[in] Length, in bytes, of the structure pointed to by the Address parameter.
ProtocolGuid
[in] GUID that identifies the protocol of which the connection is part.
dwFlags
[in] Connection flags. This parameter can be any combination of the following flag values:
Value | Meaning
FWX_FLAG_BIDIRECTIONAL | Permission is also granted to send packets back to destinations that recently sent packets to the socket. This flag is only valid for UDP.
FWX_INCREASE_RECEIVE_BUFFER | The receive buffer will be increased to 64 kilobytes. This flag should be set to prevent packet loss if high-bandwidth packet bursts occur in a secondary UDP connection.
pIpFilter
[in] Pointer to an IFWXIpFilter interface. All connections that are created by RetroactiveAllowBind will be restricted by the IFWXIpFilter interface pointed to by this parameter. If you specify NULL for this parameter, the connection will not be restricted by an IFWXIpFilter interface.

Return Values

S_OK
The method succeeded.
S_FALSE
The connection exists and was already allowed.
E_INVALIDARG
Invalid parameter.
HRESULT_FROM_WIN32(ERROR_NOT_FOUND)
No connection with the specified address was found.
FWX_E_TERMINATING
The (bind) connection exists, but is already terminating.
FWX_E_PROTOCOL_RULES_DENIED
The protocol rules do not allow the user to use the protocol specified by the ProtocolGuid parameter.

Remarks

Usually a filter will know that a bind call made by a Firewall client is valid only after the bind call succeeds and the Firewall client sends the address to its peer. For this reason, the Firewall service will not fail a bind call even when the service does not allow the client inbound access. Instead, the Firewall service marks the connection, and discards datagrams sent or connection attempts to that address, unless the bind becomes valid later.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Wspfwext.idl.

See Also

IFWXSession


IFWXSession.SetDataFilterFactory (8 Parameters) method [ISA Server 2004]

IFWXSession::SetDataFilterFactory

The SetDataFilterFactory method allows a filter to set a data filter factory for events for which the filter is not registered. This method can be used to reduce the number of events for which a filter registers.

HRESULT SetDataFilterFactory(
  FwxFirewallEventType eProxyEvent,
  LPSOCKADDR Address,
  DWORD AddressLength,
  IClassFactory* pIClassFactory,
  FwxDataFilterPriorityClass PriorityClass,
  IUnknown* punkFilterContext,
  DWORD dwFlags,
  IFWXFirewallAction** ppFirewallAction
);

Parameters

eProxyEvent
The type of event for which the data filter factory is set. Can have a value from the FwxFirewallEventType enumerated type.
Address
[in] Pointer to a sockaddr structure that contains the address and port for events which should cause a data filter to be instantiated and attached. If eProxyEvent is fwx_Connect_Tcp or fwx_Udp_Destination, the address is the remote address. If eProxyEvent is fwx_Bind_Udp or fwx_AcceptedConnection, the address is the bind address. The address must be of type AF_INET, and can be either a specific IP address or INADDR_ANY.
AddressLength
[in] Length, in bytes, of the structure pointed to by the Address parameter.
pIClassFactory
[in] Pointer to a class factory for objects that support the IFWXDataFilter interface.
PriorityClass
[in] Priority class in which the data filter created will be attached. This is a value from the FwxDataFilterPriorityClass enumerated type.
punkFilterContext
[in] Pointer to an optional interface that can be used to pass context information to the data filter. This interface will be passed to IFWXDataFilter::SetSockets. This parameter can be NULL.
dwFlags
Specifies the flags for the call. Any combination of the following values is acceptable for the dwFlags parameter.
Value | Meaning
FWX_FLAG_ADDRESS_BASED | The connection for which the data filter is needed may be created by a different process by using the same address.
ppFirewallAction
[out] Address of a buffer that received a pointer to the IFWXFirewallAction interface on the proxy action object created as a result of this call. This parameter can be NULL.

Return Values

This method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

This method is an alternative to registering to the corresponding event, comparing the address, and calling IFWXConnection::AttachDataFilter. The Microsoft Firewall service creates a data filter by using the COM IClassFactory interface, when the specified event is detected. The data filter is then attached to the appropriate connection.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Wspfwext.idl.

See Also

IFWXSession


IFWXSessionFilter interface [ISA Server 2004]

IFWXSessionFilter

The IFWXSessionFilter interface monitors and reacts to events in a given user session. Each user session may have a different combination of session filters attached to it. However, each session filter is attached to a single user session.

A session filter object is attached to a user session when the Microsoft Firewall service calls the IFWXFilter::AttachToSession method.

This is the interface typically used for attaching a data filter to a session.

When To Implement

Every application filter must implement this interface to monitor and react to events in a session.

Methods in Vtable Order

The IFWXSessionFilter interface inherits the methods of the standard COM interface IUnknown.

In addition, IFWXSessionFilter defines the following methods.

Method | Description
FirewallEventHandler | Provides the event sink for Firewall service events related to the session to which the session filter is attached.
Detach | Detaches the session filter from its session. This method should release all references that the session filter object holds on the session and any related objects.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Wspfwext.idl.

See Also

Filter Interfaces


IFWXSessionFilter.Detach method [ISA Server 2004]

IFWXSessionFilter::Detach

The Detach method detaches the session filter from its session. This method should release all references that the session filter object holds on the session and any related objects.

HRESULT Detach();

Parameters

This method has no parameters.

Return Values

Implementations of this method should return the following:
S_OK
The method succeeded.
E_FAIL
The method failed. This will cause the Firewall service to generate an alert.

Remarks

This method is typically called by the Microsoft Firewall service when the applicable session is about to be shut down.

Example Code

The following is an example implementation of the Detach method.

HRESULT CMySessionFilter::Detach()
{
    // Assume that m_spSession is defined as CComPtr<IFWXSession>
    // and that IFWXSession::Release() is called
    // by the assignment operator.
    Lock();
    m_spSession = NULL;
    Unlock();

    return S_OK;
}

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Wspfwext.idl.

See Also

IFWXSessionFilter


IFWXSessionFilter.FirewallEventHandler(FirewallEvent) method [ISA Server 2004]

IFWXSessionFilter::FirewallEventHandler

The FirewallEventHandler method provides the event sink for Microsoft Firewall service events related to the session to which the session filter is attached.

HRESULT FirewallEventHandler(
  const FirewallEvent* pFirewallEvent
);

Parameters

pFirewallEvent
[in] Pointer to a FwxFirewallEvent structure that describes the event for which this method is called and that receives information about the event. For more information, see the documentation for each event type.

Return Values

Implementations of this method should return S_OK if the call is successful; otherwise, they should return an error code.

Remarks

This method is called when an event occurs for which the filter is registered. In this method, you select an action based on the event data provided by the Firewall service.

Example Code

The following is an example implementation of the FirewallEventHandler method.

HRESULT STDMETHODCALLTYPE CMySessionFilter::FwxFirewallEventHandler(
                          FirewallEvent *pEvent)
{
    switch (pEvent->EventType) {
    case fwx_Connect_Tcp:
        // Handle connect event.
    case fwx_Accept:
        // Handle accept event
....
    default:
        return E_NOTIMPL;
}

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Wspfwext.idl.

See Also

IFWXSessionFilter, FwxFirewallEvent


IFWXSlowDataFilter interface [ISA Server 2004]

IFWXSlowDataFilter

The IFWXSlowDataFilter interface may be implemented by a data filter object to prevent premature termination of the connection.

Methods in Vtable Order

The IFWXSlowDataFilter interface inherits the methods of the standard COM interface IUnknown.

In addition, IFWXSlowDataFilter defines the following method.

Method | Description
OkToTerminate | Verifies that all data for this connection has been processed.

Remarks

When a Firewall client application calls the Winsock WSACleanup function, the client DLL will close the Microsoft Firewall service session. As a result, the Firewall service will terminate all the connections that were created in this session.

Occasionally, this may lead to data loss, if the client application relies on TCP/IP for receipt acknowledgement. The connection could be closed after acknowledgement of a packet receipt because the slow connection delays the receipt of the remainder of the packets. This is not an issue if the client application uses application level acknowledgement.

To prevent data loss in these cases, implement the IFWXSlowDataFilter interface.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Wspfwext.idl.

See Also

Filter Interfaces


IFWXSlowDataFilter.OkToTerminate method [ISA Server 2004]

IFWXSlowDataFilter::OkToTerminate

The OkToTerminate method verifies that all data for this connection has been processed.

HRESULT OkToTerminate();

Parameters

This method has no parameters.

Return Values

S_OK
The Microsoft Firewall service can safely terminate the connection.
S_FALSE
Not all data on the connection has been processed.

Remarks

When a data filter returns S_FALSE, it indicates that the Firewall service should not terminate the connection yet. The Firewall service may call this method periodically to check the status of the connection.

This method should take into account reasonable network time-out and eventually return S_OK.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Wspfwext.idl.

See Also

IFWXSlowDataFilter


IFWXSocket interface [ISA Server 2004]

IFWXSocket

The IFWXSocket interface is the Microsoft Firewall service socket interface.

Note Before releasing this interface, you must call IFWXSocket::Close or IFWXSocket::Shutdown on it.

Methods in Vtable Order

The IFWXSocket interface inherits the methods of the standard COM interface IUnknown.

In addition, IFWXSocket defines the following methods.

Method | Description
Send | Sends a buffer asynchronously. It performs an overlapped send operation.
SendTo | Sends a buffer asynchronously on UDP sockets to a specific address. It performs an overlapped sendto operation.
Recv | Receives a buffer asynchronously. It performs an overlapped receive (or receive from operation, depending on the socket type).
Shutdown | Starts transport shutdown on the socket.
Close | Closes the socket.

Remarks

This interface does not necessarily correspond to a network socket. It allows data filters to work with the data that is flowing through the socket by using a socket-like interface. A network socket implements the IFWXNetworkSocket interface. For more information about sockets and socket interfaces, see Socket Objects.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Wspfwext.idl.

See Also

Filter Interfaces


IFWXSocket.Close(BOOLEAN) method [ISA Server 2004]

IFWXSocket::Close

The Close method closes the socket.

HRESULT Close(
  BOOLEAN fAbortive
);

Parameters

fAbortive
[in] Close-type flag. If TRUE, the connection will be hard closed (RST packet). If FALSE, it will not be hard closed (FIN packet).

Return Values

This method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

A hard close is done by setting the SO_DONTLINGER option in the Winsock setsockopt function.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Wspfwext.idl.

See Also

IFWXSocket


IFWXSocket.Recv (3 Parameters) method [ISA Server 2004]

IFWXSocket::Recv

The Receive method receives a buffer asynchronously. It performs an overlapped receive (or receive from operation, depending on the socket type).

HRESULT Recv(
  IFWXIOBuffer* pIOBuffer,
  IFWXIOCompletion* pIFWXIOCompletion,
  UserContextType UserData
);

Parameters

pIOBuffer
[in] Pointer to the buffer that receives the data.

This parameter may be set to NULL, so that the Microsoft Firewall service will create the buffer. In this case, the same buffer object can be passed between data filters, and buffer copy will be avoided. The IFWXIOCompletion::CompleteAsyncIO completion method receives a buffer object as one of its arguments.

pIFWXIOCompletion
[in] Pointer to the IFWXIOCompletion interface that receives the completion notification. This parameter is required. it cannot be NULL.
UserData
[in] An opaque value to pass to the IFWXIOCompletion::CompleteAsyncIO notification method. This parameter provides a context to the notification.

Return Values

This method returns S_OK if the call is successful; otherwise, it returns an error code.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Wspfwext.idl.

See Also

IFWXSocket


IFWXSocket.Send (3 Parameters) method [ISA Server 2004]

IFWXSocket::Send

The Send method sends a buffer asynchronously. It performs an overlapped send operation.

HRESULT Send(
  IFWXIOBuffer* pIOBuffer,
  IFWXIOCompletion* pIFWXIOCompletion,
  UserContextType UserData
);

Parameters

pIOBuffer
[in] Pointer to the buffer to send.
pIFWXIOCompletion
[in] Pointer to the IFWXIOCompletion interface that is notified when the send operation is completed. Set this parameter to NULL if notification is not required.
UserData
[in] An opaque value to pass to the IFWXIOCompletion::CompleteAsyncIO notification method. This parameter provides a context to the notification, thereby allowing identification of each send operation.

Return Values

This method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

To receive a notification when the send operation is completed, specify an IFWXIOCompletion interface pointer in the pIFWXIOCompletion parameter.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Wspfwext.idl.

See Also

IFWXSocket, IFWXIOBuffer


IFWXSocket.SendTo (5 Parameters) method [ISA Server 2004]

IFWXSocket::SendTo

The SendTo method sends a buffer asynchronously on UDP sockets to a specified address. It performs an overlapped sendto operation.

HRESULT SendTo(
  IFWXIOBuffer* pIOBuffer,
  SOCKADDR* Address,
  INT AddressLength,
  IFWXIOCompletion* pIFWXIOCompletion,
  UserContextType UserData
);

Parameters

pIOBuffer
[in] Pointer to the buffer to send.
Address
[in] When calling this method on an external socket, this sockaddr structure should contain the target address for a UDP datagram. When calling this method on an internal socket, this parameter should contain the address of the datagram source. This is typically the Internet address from which the pIOBuffer packet originated. That is, the internal socket is associated with the Internet address of the pIOBuffer packet.
AddressLength
[in] Length, in bytes, of the Address parameter.
pIFWXIOCompletion
[in] Pointer to an IFWXIOCompletion interface that receives a notification when the sendto operation is completed. Set this parameter to NULL if notification is not required.
UserData
[in] An opaque value to pass to the IFWXIOCompletion::CompleteAsyncIO notification method. This parameter provides a context to the notification.

Return Values

This method returns S_OK if the call is successful; otherwise, it returns an error code.

For an IFWXNetworkSocket interface created by a call to IFWXFirewall2::CreateSSLNetworkSocket, this method returns E_NOTIMPL.

Remarks

To receive a notification when the sendto operation is completed, specify an IFWXIOCompletion interface pointer in the pIFWXIOCompletion parameter.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Wspfwext.idl.

See Also

IFWXSocket


IFWXSocket.Shutdown(BOOLEAN) method [ISA Server 2004]

IFWXSocket::Shutdown

The Shutdown method starts transport shutdown on the socket.

HRESULT Shutdown(
  BOOLEAN fAbortive
);

Parameters

fAbortive
[in] Close-type flag. If TRUE, the connection will be hard closed (RST packet). If FALSE, it will not be hard closed (FIN packet).

Return Values

This method returns S_OK if the call is successful; otherwise, it returns an error code.

Remarks

Shutdown is done with how=SD_SEND. An abortive shutdown is carried out by setting the SO_DONTLINGER option in the Winsock setsockopt function.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Wspfwext.idl.

See Also

IFWXSocket


IFWXTaskCompletion interface [ISA Server 2004]

IFWXTaskCompletion

The IFWXTaskCompletion interface enables the posting of a custom task to the Microsoft Firewall service completion port.

When To Implement

An application filter that needs to receive completion notifications for tasks posted to the Firewall service completion port must implement this notification interface.

Methods in Vtable Order

The IFWXTaskCompletion interface inherits the methods of the standard COM interface IUnknown.

In addition, IFWXTaskCompletion defines the following method.

Method | Description
CompleteTask | Receives a notification when a task posted using the IFWXFirewall2::PostTaskCompletion method has completed.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Wspfwext.idl.

See Also

Filter Interfaces, IFWXNetworkSocket::Accept


IFWXTaskCompletion.CompleteTask(UserContextType) method [ISA Server 2004]

IFWXTaskCompletion::CompleteTask

The CompleteTask method receives a notification when a task posted using the IFWXFirewall2::PostTaskCompletion method has completed.

HRESULT CompleteTask(
  UserContextType UserData
);

Parameters

UserData
[in] The UserData parameter that differentiates between completion notifications.

Return Values

Implementations of this method should handle any run-time error and return S_OK.

Remarks

The UserData parameter provides a context to the notification. You can use the same notification interface for a number of completion notifications and differentiate among them by using different values for UserData.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Wspfwext.idl.

See Also

IFWXTaskCompletion


IFWXUdpDestination interface [ISA Server 2004]

IFWXUdpDestination

The IFWXUdpDestination interface controls the outcome of a UDP destination event. Use IFWXUdpDestination::Deny to block the destination.

Methods in Vtable Order

The IFWXUdpDestination interface inherits the methods of the standard COM interface IUnknown.

In addition, IFWXUdpDestination defines the following method.

Method | Description
Deny | Blocks the destination.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Wspfwext.idl.

See Also

Filter Interfaces


IFWXUdpDestination.Deny(DWORD) method [ISA Server 2004]

IFWXUdpDestination::Deny

The Deny method blocks the destination.

HRESULT Deny(
  DWORD Reserved
);

Parameters

Reserved
Reserved for future use. Must be zero.

Return Values

S_OK
The destination will be denied.
E_INVALIDARG
Invalid (nonzero) value was passed to the Reserved parameter.
FWX_E_BAD_CONTEXT
The method was not called in the context of an event handler.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Wspfwext.idl.

See Also

IFWXUdpDestination


Structures [ISA Server 2004]

Structures

The application filter API uses the following unions and structures:

  • FwxAcceptEvent
  • FwxBindEvent
  • FwxConnectEvent
  • FwxEndConnectionEvent
  • FwxEstablishedConnectionEvent
  • FwxFilterHookEvents
  • FwxFirewallEvent
  • FwxFirewallEventParameters
  • FwxGetHostByAddrEvent
  • FwxGetHostByNameEvent
  • FwxIpRangesToNetworkElements
  • FwxIpRangesToNetworkElementsNotification
  • FwxIpRangeToNetworkElement
  • FwxListenEvent
  • FwxNcdEvent
  • FwxNcdEventParameters
  • FwxNetElementMembershipInNetworkSet
  • FwxUdpDestination

See Also

Application Filter Reference


FwxAcceptEvent structure [ISA Server 2004]

FwxAcceptEvent

The FwxAcceptEvent structure contains parameters for an event of the fwx_AcceptedConnection type, as defined in the FwxFirewallEventType enumerated type.

This event is a notification of a new connection that arrived on a listening socket.

typedef struct _tagFwxAcceptEvent {
  LPSOCKADDR RemoteAddress;
  DWORD RemoteAddressLength;
  LPSOCKADDR LocalAddress;
  DWORD LocalAddressLength;
  IFWXConnection* piConnectionAccepted;
  FwxFilterAccess FilterAccess;
  IFWXPerRuleDataplugin* PerRuleProcessedData;
  GUID ProtocolGuid;
  BOOL IsSecondary;
} FwxAcceptEvent;

Members

RemoteAddress
Pointer to a sockaddr structure that contains the address of the connecting peer.
RemoteAddressLength
Size, in bytes, of the RemoteAddress member.
LocalAddress
Pointer to a sockaddr structure that contains the local address for this connection.
LocalAddressLength
Size, in bytes, of the LocalAddress member.
piConnectionAccepted
Pointer to the IFWXConnection interface on the Microsoft Firewall service connection object for the newly accepted connection.
FilterAccess
Value from the FwxFilterAccess enumerated type that indicates the type of access permission granted for the event. This member is used internally by the Firewall service and should not be modified or relied upon by application filters.
PerRuleProcessedData
Pointer to a IFWXPerRuleDataplugin interface that represents the per-rule configuration data for the filter. This data is processed by the Firewall service when it starts, or when the rules are changed.
ProtocolGuid
The globally unique identifier (GUID) for the protocol, if known to the Firewall service. If the protocol is not known, this parameter has the value GUID_NULL.
IsSecondary
Boolean value that indicates whether the connection is a secondary connection.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Wspfwext.idl.

See Also

Structures, FwxBindEvent, FwxListenEvent


FwxBindEvent structure [ISA Server 2004]

FwxBindEvent

The FwxBindEvent structure contains parameters for events of the fwx_Bind_Udp and fwx_Bind_Tcp types, as defined in the FwxFirewallEventType enumerated type.

These events are the result of a Firewall client calling the bind function, or an application filter calling the IFWXSession::BindForClient method.

typedef struct _tagFwxBindEvent {
  LPSOCKADDR Address;
  DWORD AddressLength;
  IFWXConnection* piConnection;
  FwxFilterAccess FilterAccess;
  IFWXPerRuleDataplugin* PerRuleProcessedData;
  GUID ProtocolGuid;
  BOOL IsSecondary;
} FwxBindEvent;

Members

Address
Pointer to a sockaddr structure that contains the address that the client wants to assign to the socket.
AddressLength
Length, in bytes, of the data pointed to by the Address member.
piConnection
Pointer to the IFWXConnection interface on the Microsoft Firewall service connection object for this request.
FilterAccess
Value from the FwxFilterAccess enumerated type that indicates the type of access permission granted for the event. This member is used internally by the Firewall service and should not be modified or relied upon by application filters.
PerRuleProcessedData
Pointer to a IFWXPerRuleDataplugin interface that represents the per-rule configuration data for the filter. This data is processed by the Firewall service when it starts, or when the rules are changed.
ProtocolGuid
The globally unique identifier (GUID) for the protocol, if known to the Firewall service. If the protocol is not known, this parameter has the value GUID_NULL.
IsSecondary
Boolean value that indicates whether the connection is a secondary connection.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Wspfwext.idl.

See Also

Structures


FwxConnectEvent structure [ISA Server 2004]

FwxConnectEvent

The FwxConnectEvent structure contains parameters for an event of the fwx_Connect_Tcp type, as defined in the FwxFirewallEventType enumerated type.

This information concerns a connect call made by a Firewall client, or a TCP connection initiated by a SecureNAT client.

typedef struct _tagFwxConnectEvent {
  LPSOCKADDR Address;
  DWORD AddressLength;
  IFWXConnection* piConnection;
  FwxFilterAccess FilterAccess;
  IFWXPerRuleDataplugin* PerRuleProcessedData;
  GUID ProtocolGuid;
  BOOL IsSecondary;
} FwxConnectEvent;

Members

Address
Pointer to a sockaddr structure that contains the address to which the client is attempting to connect.
AddressLength
Length, in bytes, of the data pointed to by the Address member.
piConnection
Pointer to the IFWXConnection interface on the Microsoft Firewall service connection object for this request.
FilterAccess
Value from the FwxFilterAccess enumerated type that indicates the type of access permission granted for the event. This member is used internally by the Firewall service and should not be modified or relied upon by application filters.
PerRuleProcessedData
Pointer to a IFWXPerRuleDataplugin interface that represents the per-rule configuration data for the filter. This data is processed by the Firewall service when it starts, or when the rules are changed.
ProtocolGuid
The globally unique identifier (GUID) for the protocol, if known to the Firewall service. If the protocol is not known, this parameter has the value GUID_NULL.
IsSecondary
Boolean value that indicates whether the connection is a secondary connection.

Remarks

SecureNAT connections will generate an event only if the connection is to a port that is a primary port of a predefined protocol or to an address specified in a call to IFWXSession::AllowFutureConnect. Other connection attempts are dropped by the system before they reach the Firewall service. For more information about NAT and SecureNAT, see secure network address translation.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Wspfwext.idl.

See Also

Structures, FwxFirewallEventParameters, FwxFirewallEventType


FwxEndConnectionEvent structure [ISA Server 2004]

FwxEndConnectionEvent

The FwxEndConnectionEvent structure contains parameters for an event of the fwx_ConnectionTerminating type.

This event occurs as a result of a connection being terminated. A filter that holds a reference to the Microsoft Firewall service connection object must release the reference so that the connection object can be deleted.

typedef struct {
  IFWXConnection* piConnection;
  GUID ProtocolGuid;
} FwxEndConnectionEvent;

Members

piConnection
Pointer to the IFWXConnection interface on the Firewall service connection object that is terminating. References to this object must be released in response to the event.
ProtocolGuid
The globally unique identifier (GUID) for the protocol, if known to the Firewall service. If the protocol is not known, this parameter has the value GUID_NULL.

Remarks

It is unnecessary to register for this event in the IFWXFilter::FilterInit method because a session filter is never attached in response to this event.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Wspfwext.idl.

See Also

Structures


FwxEstablishedConnectionEvent structure [ISA Server 2004]

FwxEstablishedConnectionEvent

The FwxEstablishedConnectionEvent structure contains parameters for an event of the fwx_EstablishedConnection type.

This event provides notification of connections established for the IFWXSession::AllowFutureConnect, IFWXSession::BindForClient, and IFWXSession::RedirectConnections methods. When a connection is made as a result of a call to one of these three methods, the Microsoft Firewall service creates this event.

typedef struct {
  INT Protocol;
  DWORD AddressLength;
  IFWXConnection* piConnection;
  UserContextType UserContext;
} FwxEstablishedConnectionEvent;

Members

Protocol
Protocol flags. This parameter can have the following flag values:
Value | Meaning
FWX_PROTOCOL_TCP | The connection uses the TCP protocol.
FWX_PROTOCOL_UDP | The connection uses the UDP protocol.
AddressLength
Length, in bytes, of the data pointed to by the Address member.
piConnection
Pointer to the IFWXConnection interface on the Firewall service connection object for this request.
UserContext
User context for the connection. This is identical to the UserContextType parameter of the function that created the connection.

Remarks

Other filters cannot register for this event. This event is sent only to the filter that called one of the previous methods and passed its interface.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Wspfwext.idl.

See Also

Structures


FwxFilterHookEvents structure [ISA Server 2004]

FwxFilterHookEvents

The FwxFilterHookEvents structure defines all the events that a filter wants to monitor. When a user session generates an event that the filter monitors, a session filter object is created and notified of the event. At this point, the session filter may change the set of events for that specific client session.

typedef struct {
  DWORD dwGlobalEvents;
} FwxFilterHookEvents;

Members

dwGlobalEvents
A combination of FwxFirewallEventType values combined with a combination of FwxFirewallEventSource values by using the bitwise OR operator.

Specifies events for notification for the filter or session.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Wspfwext.idl.

See Also

Structures, IFWXFilter::AttachToSession, IFWXFilter::FilterInit


FwxFirewallEvent structure [ISA Server 2004]

FwxFirewallEvent

The FwxFirewallEvent structure describes a firewall event.

typedef struct {
  FwxFirewallEventType EventType;
  FwxFirewallEventSource EventSource;
  FwxFirewallEventParameters Parameters;
} FwxFirewallEvent;

Members

EventType
Type of event. This member is a value from the FwxFirewallEventType enumerated type.
EventSource
Source of the event. This member is a value from the FwxFirewallEventSource enumerated type.
Parameters
Parameters specific to the firewall event. This member is a value from the FwxFirewallEventParameters enumerated type.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Wspfwext.idl.

See Also

Structures, IFWXSessionFilter::FirewallEventHandler


FwxFirewallEventParameters union [ISA Server 2004]

FwxFirewallEventParameters

The FwxFirewallEventParameters union has members that specify the parameters for firewall events of different types. The union discriminant is a value from the FwxFirewallEventType enumerated type.

The FwxFirewallEventParameters union is typically a member of an FwxFirewallEvent structure.

typedef struct _tagFwxFirewallEventParameters {
  FwxConnectEvent Connect;
  FwxUdpDestination UdpDest;
  FwxBindEvent Bind;
  FwxListenEvent Listen;
  FwxAcceptEvent Accept;
  FwxGetHostByAddrEvent GetHostByAddr;
  FwxGetHostByNameEvent GetHostByName;
  FwxEndConnectionEvent EndConnect;
  FwxEstablishedConnectionEvent EstablishedConnection;
} FwxFirewallEventParameters;

Members

Connect
FwxConnectEvent structure that specifies the parameters for an event of type fwx_Connect_Tcp, as defined in the FwxFirewallEventType enumerated type.
UdpDest
FwxUdpDestination structure that specifies the parameters for an event of type fwx_Udp_Destination, as defined in the FwxFirewallEventType enumerated type.
Bind
FwxBindEvent structure that specifies the parameters for an event of type fwx_Bind_Tcp or fwx_Bind_Udp, as defined in the FwxFirewallEventType enumerated type.
Listen
FwxListenEvent structure that specifies the parameters for an event of type fwx_Listen, as defined in the FwxFirewallEventType enumerated type.
Accept
FwxAcceptEvent structure that specifies the parameters for an event of type fwx_AcceptedConnection, as defined in the FwxFirewallEventType enumerated type.
GetHostByAddr
FwxGetHostByAddrEvent structure that specifies the parameters for an event of type fwx_GetHostByAddr, as defined in the FwxFirewallEventType enumerated type.
GetHostByName
FwxGetHostByNameEvent structure that specifies the parameters for an event of type fwx_GetHostByName, as defined in the FwxFirewallEventType enumerated type.
EndConnect
FwxEndConnectionEvent structure that specifies the parameters for an event of type fwx_ConnectionTerminating, as defined in the FwxFirewallEventType enumerated type.
EstablishedConnection
FwxEstablishedConnectionEvent structure that specifies the parameters for an event of type fwx_EstablishedConnection, as defined in the FwxFirewallEventType enumerated type.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Wspfwext.idl.

See Also

Structures


FwxGetHostByAddrEvent structure [ISA Server 2004]

FwxGetHostByAddrEvent

The FwxGetHostByAddrEvent structure contains parameters for an event of the fwx_GetHostByAddr type, as defined in the FwxFirewallEventType enumerated type.

An event of this type event is a notification of a Firewall client operation that uses the Winsock gethostbyaddr function, which requests the host information corresponding to a specific network address. Such an event allows the filter to modify or block a name resolution request generated by gethostbyaddr by calling the IFWXGetXByY::SetResult or IFWXGetXByY::Deny method. Two events are generated, one before and one after the actual name resolution.

typedef struct _tagFwxGetHostByAddrEvent {
  BYTE* Address;
  DWORD AddressLength;
  INT AddressType;
  LPHOSTENT Hostent;
  DWORD HostentLength;
  BOOL fBeforeAction;
  FwxFilterAccess FilterAccess;
  IFWXGetXByY* piGetXByY;
} FwxGetHostByAddrEvent;

Members

Address
Pointer to the network address passed to the gethostbyaddr function in network byte order.
AddressLength
Length, in bytes, of the data pointed to by the Address member.
AddressType
Type of address, such as the AF_INET address family type (defined as TCP, UDP, and other associated Internet protocols). Address family types and their corresponding values are defined in Winsock2.h.
Hostent
Pointer to a hostent structure. This member points to a valid hostent structure if the fBeforeAction member is FALSE. Otherwise, the value of this member is undefined.
HostentLength
Length, in bytes, of the data pointed to by the hostent member.
fBeforeAction
Before-action flag. The value of this flag is TRUE if the event is generated before name resolution is performed, and FALSE if the event is generated after name resolution is performed.
FilterAccess
Value from the FwxFilterAccess enumerated type that indicates the type of access permission granted for the event. This member is used internally by the Microsoft Firewall service and should not be modified or relied upon by application filters.
piGetXByY
Pointer to an IFWXGetXByY interface that contains methods for controlling the outcome of the name query.

Remarks

The events for which this structure is used are generated only for Firewall clients (sources of type fwxSourceWSP, as defined in the FwxFirewallEventSource enumerated type). They are not generated for SecureNAT clients.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Wspfwext.idl.

See Also

Structures, IFWXGetXByY


FwxGetHostByNameEvent structure [ISA Server 2004]

FwxGetHostByNameEvent

The FwxGetHostByNameEvent structure contains parameters for an event of the fwx_GetHostByName type, as defined in the FwxFirewallEventType enumerated type.

This event is a notification of a Firewall client operation that uses the Winsock gethostbyname function, which requests the host information corresponding to a specific host name from a host database. Such an event allows the filter to modify or block a name resolution request generated by gethostbyname by calling the IFWXGetXByY::SetResult or IFWXGetXByY::Deny method. Two events are generated, one before and one after the actual name resolution.

typedef struct _tagFwxGetHostByNameEvent {
  LPSTR Hostname;
  LPHOSTENT Hostent;
  DWORD HostentLength;
  BOOL fBeforeAction;
  FwxFilterAccess FilterAccess;
  IFWXGetXByY* piGetXByY;
} FwxGetHostByNameEvent;

Members

Hostname
Pointer to a null-terminated string containing the host name passed to the gethostbyname function.
Hostent
Pointer to a hostent structure. This member points to a valid hostent structure if the fBeforeAction member is FALSE. Otherwise, the value of this member is undefined.
HostentLength
Length, in bytes, of the data pointed to by the hostent member.
fBeforeAction
Before-action flag. The value of this flag is TRUE if the event is generated before name resolution is performed, and FALSE if the event is generated after name resolution is performed.
FilterAccess
Value from the FwxFilterAccess enumerated type that indicates the type of access permission granted for the event. This member is used internally by the Microsoft Firewall service and should not be modified or relied upon by application filters.
piGetXByY
Pointer to an IFWXGetXByY interface that contains methods for controlling the outcome of the name query.

Remarks

The events for which this structure is used are generated only for Firewall clients (sources of type fwxSourceWSP, as defined in the FwxFirewallEventSource enumerated type). They are not generated for SecureNAT clients.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Wspfwext.idl.

See Also

Structures, IFWXGetXByY


FwxIpRangesToNetworkElements structure [ISA Server 2004]

FwxIpRangesToNetworkElements

The FwxIpRangesToNetworkElements structure maps IP ranges to their respective network elements. Each range is represented by its upper bound IP address, and the mapping covers the entire IP range (0.0.0.0 to 255.255.255.255). An application filter can use this mapping to identify what ranges are associated with which networks.

typedef struct {
  FwxIpRangeToNetworkElement* IpRanges;
  unsigned int IpRangesNumber;
} FwxIpRangesToNetworkElements;

Members

IpRanges
The array of upper bound IP addresses and the associated networks of the IP ranges(FwxIpRangeToNetworkElement).
IpRangesNumber
The number of IP range entries that are in the array.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Wspfwext.idl.

See Also

Structures


FwxIpRangesToNetworkElementsNotification structure [ISA Server 2004]

FwxIpRangesToNetworkElementsNotification

The FwxIpRangesToNetworkElementsNotification structure contains parameters of a network configuration detection (NCD) event that specify the altered mappings of the IP ranges to the ISA Server networks and the reason for the changes.

typedef struct _tagFwxIpRangesToNetworkElementsNotification {
  FwxIpRangesToNetworkElements Table;
  FwxNcdRangesChangeReason eReason;
} FwxIpRangesToNetworkElementsNotification;

Members

Table
FwxIpRangesToNetworkElements structure that contains the altered mappings of the IP ranges to the ISA Server networks.
eReason
Value from the FwxNcdRangesChangeReason enumerated type that specifies the reason for the changes in the mappings of the IP ranges to the ISA server networks.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Wspfwext.idl.

See Also

Structures


FwxIpRangeToNetworkElements structure [ISA Server 2004]

FwxIpRangeToNetworkElement

The FwxIpRangeToNetworkElement structure contains the upper bound IP address and network for an IP range in the ISA Server defined networks.

typedef struct {
  DWORD IpRangeUpperBound;
  IFWXNetworkElement* pNetworkElement;
} FwxIpRangeToNetworkElements;

Members

IpRangeUpperBound
The upper bound of the IP range.
pNetworkElement
The network that contains the IP range.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Wspfwext.idl.

See Also

Structures


FwxListenEvent structure [ISA Server 2004]

FwxListenEvent

The FwxListenEvent structure contains parameters for an event of the fwx_Listen type.

This is the result of the Firewall client calling the listen function, or an application filter calling the IFWXSession::BindForClient method.

typedef struct {
  LPSOCKADDR Address;
  DWORD AddressLength;
  IFWXConnection* piConnection;
  GUID ProtocolGuid;
} FwxListenEvent;

Members

Address
Pointer to a sockaddr structure that contains the address the socket was assigned. This is the same as the result of calling the getsockname function on the socket.
AddressLength
Length, in bytes, of the data pointed to by the Address member.
piConnection
Pointer to the IFWXConnection interface on the Microsoft Firewall service connection object for this request.
ProtocolGuid
The globally unique identifier (GUID) for the protocol, if known to the Firewall service. If the protocol is not known, this parameter has the value GUID_NULL.

Remarks

The filter cannot fail this request because client applications do not expect the listen function to fail. The place for a filter to deny inbound access is in the bind request or when a connection actually arrives. For example, this could occur in an event of the fwx_AcceptedConnection type.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Wspfwext.idl.

See Also

Structures


FwxNcdEvent structure [ISA Server 2004]

FwxNcdEvent

The FwxNcdEvent structure describes a network configuration detection (NCD) network configuration event. For more information, see Using Network Configuration Detection.

typedef struct {
  FwxNcdEventType EventType;
  FwxNcdEventParameters Parameters;
} FwxNcdEvent;

Members

EventType
Type of event. This member is a value from the FwxNcdEventType enumerated type.
Parameters
Parameters specific to the NCD network configuration event. This member is a value from the FwxNcdEventParameters union.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Wspfwext.idl.

See Also

Structures, FwxNcdEventType, FwxNcdEventParameters


FwxNcdEventParameters union [ISA Server 2004]

FwxNcdEventParameters

The FwxNcdEventParameters union has members that specify the parameters for network configuration detection (NCD) events of different types. The union discriminant is a value from the FwxNcdEventType enumerated type.

The FwxNcdEventParameters union is typically a member of an FwxNcdEvent structure.

typedef union _tagFwxNcdEventParameters {
  unsigned int uiContextSlot;
  IFWXNetworkElement* pNetworkElement;
  IFWXNetworkAdapter* pNetworkAdapter;
  IFWXNetworkAddress* pNetworkAddress;
  IFWXNetworkSet* pNetworkSet;
  FwxNetElementMembershipInNetworkSet NetElementSetMembership;
  FwxIpRangesToNetworkElementsNotification IpRangesToNetworkElements;
  IFWXNetConfigDetectionSnapshot pNetConfigDetectionSnapshot;
} FwxNcdEventParameters;

Members

uiContextSlot
Unsigned integer value that specifies the registration handle created during the call to the IFWXNetConfigDetector::Register method for a new NCD client. This member is used for an event of type fwx_ncd_Startup, as defined in the FwxNcdEventType enumerated type.
pNetworkElement
Pointer to an IFWXNetworkElement interface that represents the ISA Server network that was added or removed. This member is used for an event of type fwx_ncd_AddNetworkElement or fwx_ncd_RemoveNetworkElement, as defined in the FwxNcdEventType enumerated type.
pNetworkAdapter
Pointer to an IFWXNetworkAdapter interface that represents the network adapter that was added or removed or whose route was changed. This member is used for an event of type fwx_ncd_AddNetworkAdapter, fwx_ncd_RemoveNetworkAdapter, or fwx_ncd_ChangeAdapterRoute, as defined in the FwxNcdEventType enumerated type.
pNetworkAddress
Pointer to an IFWXNetworkAddress interface that represents the network address that was added to the local computer or removed from it. This member is used for an event of type fwx_ncd_AddNetworkAddress or fwx_ncd_RemoveNetworkAddress, as defined in the FwxNcdEventType enumerated type.
pNetworkSet
Pointer to an IFWXNetworkSet interface that represents the network set that was added or removed. This member is used for an event of type fwx_ncd_AddNetworkSet or fwx_ncd_RemoveNetworkSet, as defined in the FwxNcdEventType enumerated type.
NetElementSetMembership
FwxNetElementMembershipInNetworkSet structure that specifies the network set and the ISA server network that was added or removed from it. This member is used for an event of type fwx_ncd_AddNetworkElementToSet or fwx_ncd_RemoveNetworkElementFromSet, as defined in the FwxNcdEventType enumerated type.
IpRangesToNetworkElements
FwxIpRangesToNetworkElementsNotification structure that specifies the altered mappings of the IP address ranges to the ISA Server networks and the reason for the changes. This member is used for an event of type fwx_ncd_ChangeIpRange, as defined in the FwxNcdEventType enumerated type.
pNetConfigDetectionSnapshot
Pointer to an IFWXNetConfigDetectionSnapshot interface that represent the complete network configuration at the time of the NCD synchronization. This member is used for an event of type fwx_ncd_SyncConfig, as defined in the FwxNcdEventType enumerated type.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Wspfwext.idl.

See Also

Structures


FwxNetElementMembershipInNetworkSet structure [ISA Server 2004]

FwxNetElementMembershipInNetworkSet

The FwxNetElementMembershipInNetworkSet structure describes the membership of a network in a network set.

typedef struct {
  IFWXNetworkElement* pNetElement;
  IFWXNetworkSet* pNetSet;
} FwxNetElementMembershipInNetworkSet;

Members

pNetElement
The network element.
pNetSet
The network set to which the network element belongs.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Wspfwext.idl.

See Also

Structures


FwxUdpDestination structure [ISA Server 2004]

FwxUdpDestination

The FwxUdpDestination structure contains parameters for an event of the fwx_Udp_Destination type, as defined in the FwxFirewallEventType enumerated type.

An event of this type is triggered in response to the generation of a UDP destination, which occurs under the following circumstances:

  • A Firewall client application calls the connect function on a remote UDP socket.
  • A Firewall client or a SecureNAT client attempts a sendto operation to a new destination.
  • A packet has just been sent to the client from the address specified.

typedef struct _tagFwxUdpDestination {
  LPSOCKADDR Address;
  DWORD AddressLength;
  IFWXConnection* piConnection;
  IFWXUdpDestination* piUdpDestination;
  FwxFilterAccess FilterAccess;
  IFWXPerRuleDataplugin* PerRuleProcessedData;
  GUID ProtocolGuid;
  Boolean IsSecondary;
} FwxUdpDestination;

Members

Address
Pointer to a sockaddr structure that contains the address to which the client is attempting to connect.
AddressLength
Length, in bytes, of the data pointed to by the Address member.
piConnection
Pointer to the IFWXConnection interface on the Microsoft Firewall service connection object for this request.
piUdpDestination
Pointer to the IFWXUdpDestination interface that represents the UDP destination generated.
FilterAccess
Value from the FwxFilterAccess enumerated type that indicates the type of access permission granted for the event. This member is used internally by the Firewall service and should not be modified or relied upon by application filters.
PerRuleProcessedData
Per-rule configuration data for the filter. This data is processed by the Firewall service when it starts, or when the rules are changed.
ProtocolGuid
The globally unique identifier (GUID) for the protocol, if known to the Firewall service. If the protocol is not known, this parameter has the value GUID_NULL.
IsSecondary
Boolean value that indicates whether the connection is a secondary connection.

Remarks

The Firewall service keeps a cache of known UDP sources and destinations for each UDP connection object. An event is only generated for destinations that are not in this cache.

Although an fwx_Udp_Destination event may be generated as a result of an incoming datagram, it is not intended for the interception of inbound traffic. To examine inbound datagrams, use an fwx_Bind_Udp event.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Wspfwext.idl.

See Also

Structures


Filter Enumerated Types [ISA Server 2004]

Filter Enumerated Types

The application filter API uses the following enumerated types:

  • FwxFilterAccess
  • FwxDataFilterPriorityClass
  • FwxFirewallEventProtocolSource
  • FwxFirewallEventSource
  • FwxFirewallEventType
  • FwxNcdEventType
  • FwxNcdRangesChangeReason
  • FwxSslSocketSide
  • FwxTimeoutType

See Also

Application Filter Reference


FwxFilterAccess enumeration [ISA Server 2004]

FwxFilterAccess

The FwxFilterAccess enumerated type contains values that indicate the type of access permission for a filter event.

Note This field is used internally by the Microsoft Firewall service implementation and should not be modified or relied upon by application filters.

typedef enum FwxFilterAccess
{
  FWX_ALLOW
FWX_ALLOW
Grants permission. Overrides the default (built-in) protocol or permission check.
,
  FWX_DENY
FWX_DENY
Denies the action.
,
  FWX_PASS
FWX_PASS
Allows access if none of the other filters (including the built-in rules) denies it and at least one filter (including the built-in) allows it. This is the default value for
FwxFilterAccess.
,
  FWX_EMULATE
FWX_EMULATE
Signals that the filter wants to intercept and implement the request, emulating an external connection.

} FwxFilterAccess;

Constants

FWX_ALLOW
Grants permission. Overrides the default (built-in) protocol or permission check.
FWX_DENY
Denies the action.
FWX_PASS
Allows access if none of the other filters (including the built-in rules) denies it and at least one filter (including the built-in) allows it. This is the default value for FwxFilterAccess.
FWX_EMULATE
Signals that the filter wants to intercept and implement the request, emulating an external connection.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Wspfwext.idl.

See Also

Filter Enumerated Types, FwxGetHostByNameEvent, FwxGetHostByAddrEvent, FwxUdpDestination, FwxAcceptEvent, FwxBindEvent, FwxConnectEvent


FwxDataFilterPriorityClass enumeration [ISA Server 2004]

FwxDataFilterPriorityClass

The FwxDataFilterPriorityClass enumerated type contains values used to specify the order of data filters for the same connection. Within the same priority class, the order will be arbitrary.

typedef enum FwxDataFilterPriorityClass
{
  fwx_dfpc_NAT
fwx_dfpc_NAT
As close to the client as possible. This should be used only if the data filter is a SecureNAT editor.
,
  fwx_dfpc_Internal
fwx_dfpc_Internal
As close to the client as possible for a non-SecureNAT filter.
,
  fwx_dfpc_PostTrust
fwx_dfpc_PostTrust
Close to the client side.
,
  fwx_dfpc_Middle
fwx_dfpc_Middle
Middle of the chain. Virus scanners should use this priority.
,
  fwx_dfpc_PreTrust
fwx_dfpc_PreTrust
Close to the server side.
,
  fwx_dfpc_External
fwx_dfpc_External
As close to the external source as possible.
,
  fwx_dfpc_Emulation
fwx_dfpc_Emulation
Used by emulation filters. The filter is the source of the data.

} FwxDataFilterPriorityClass;

Constants

fwx_dfpc_NAT
As close to the client as possible. This should be used only if the data filter is a SecureNAT editor.
fwx_dfpc_Internal
As close to the client as possible for a non-SecureNAT filter.
fwx_dfpc_PostTrust
Close to the client side.
fwx_dfpc_Middle
Middle of the chain. Virus scanners should use this priority.
fwx_dfpc_PreTrust
Close to the server side.
fwx_dfpc_External
As close to the external source as possible.
fwx_dfpc_Emulation
Used by emulation filters. The filter is the source of the data.

Remarks

Each priority setting is defined as being closer to the client or closer to the server. A data filter that is closer to the client is likely to be the first to examine data flowing from the client, and unlikely to be the first to examine data flowing to the client. A data filter that is closer to the server is likely to be the first to examine data flowing from the server to the client, and unlikely to be the first to examine data flowing from the client to the server.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Wspfwext.idl.

See Also

Filter Enumerated Types, IFWXConnection::AttachDataFilter, IFWXConnection::AttachDataFilterWithDestination, IFWXConnection::EmulateConnection, IFWXSession::SetDataFilterFactory


FwxFirewallEventProtocolSource enumeration [ISA Server 2004]

FwxFirewallEventProtocolSource

The FwxFirewallEventProtocolSource enumerated type contains values that indicate the type of protocols associated with an event. You can use these values to indicate what protocols will be used to call a filter. For example, use the fwxAssociatedProtocolAllConnections value for a secondary connections traffic filter.

typedef enum FwxFirewallEventProtocolSource
{
  fwxAnyProtocol
fwxAnyProtocol
The filter will be called for any protocol.
,
  fwxAssociatedProtocolAllConnections
fwxAssociatedProtocolAllConnections
The filter will be called both for primary and secondary connections. If the flag is not set, only primary connection events fire the filter.

} FwxFirewallEventProtocolSource;

Constants

fwxAnyProtocol
The filter will be called for any protocol.
fwxAssociatedProtocolAllConnections
The filter will be called both for primary and secondary connections. If the flag is not set, only primary connection events fire the filter.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Wspfwext.idl.

See Also

Filter Enumerated Types


FwxFirewallEventSource enumeration [ISA Server 2004]

FwxFirewallEventSource

The FwxFirewallEventSource enumerated type contains values that indicate the source of an event. The source can be either a SecureNAT client or a Firewall client.

typedef enum FwxFirewallEventSource
{
  fwxSourceWSP
fwxSourceWSP
The source is a Firewall client.
,
  fwxSourceNAT
fwxSourceNAT
The source is a SecureNAT client.

} FwxFirewallEventSource;

Constants

fwxSourceWSP
The source is a Firewall client.
fwxSourceNAT
The source is a SecureNAT client.

Remarks

Use the FWX_ALL_SOURCES macro to set both the fwxSourceWSP and fwxSourceNAT values. For more information about developing filters for SecureNAT and Firewall clients, see Filter Requirements for SecureNAT Clients and Filter Requirements for Firewall Clients.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Wspfwext.idl.

See Also

Filter Enumerated Types, FwxFilterHookEvents, FwxFirewallEvent, FwxGetHostByNameEvent


FwxFirewallEventType enumeration [ISA Server 2004]

FwxFirewallEventType

The FwxFirewallEventType enumerated type defines the types of events to which a filter may hook. Each value in this enumeration is a bit. Values can be combined by using the bitwise OR operator to specify a set of events.

typedef enum FwxFirewallEventType
{
  fwx_Connect_Tcp
fwx_Connect_Tcp
Connect request for TCP sockets. For more information, see
FwxConnectEvent.
,
  fwx_Udp_Destination
fwx_Udp_Destination
Connect request for UDP sockets. For more information, see
FwxUdpDestination.
,
  fwx_Bind_Tcp
fwx_Bind_Tcp
Bind request for TCP sockets. For more information, see
FwxBindEvent.
,
  fwx_Bind_Udp
fwx_Bind_Udp
Bind request for UDP sockets. For more information, see
FwxBindEvent.
,
  fwx_Listen
fwx_Listen
Listen on a TCP socket. For more information, see
FwxListenEvent.
,
  fwx_AcceptedConnection
fwx_AcceptedConnection
Actual inbound connection on a listening TCP socket. For more information, see
FwxAcceptEvent.
,
  fwx_GetHostByName
fwx_GetHostByName
The Firewall client calls the gethostbyname function. This event can be generated only by a Firewall client. It will not be generated for a SecureNAT client. For more information, see
FwxGetHostByNameEvent.
,
  fwx_GetHostByAddr
fwx_GetHostByAddr
The Firewall client calls the gethostbyaddr function. This event can be generated only by a Firewall client. It will not be generated for a SecureNAT client. For more information, see
FwxGetHostByAddrEvent.
,
  fwx_ConnectionTerminating
fwx_ConnectionTerminating
Notification before shutting down a connection object. For more information, see
FwxEndConnectionEvent.
,
  fwx_EstablishedConnection
fwx_EstablishedConnection
Notification for connections established for
IFWXSession::AllowFutureConnect,
IFWXSession::BindForClient, and
IFWXSession::RedirectConnections methods. This event is created by the Microsoft Firewall service. For more information, see
FwxEstablishedConnectionEvent.

} FwxFirewallEventType;

Constants

fwx_Connect_Tcp
Connect request for TCP sockets. For more information, see FwxConnectEvent.
fwx_Udp_Destination
Connect request for UDP sockets. For more information, see FwxUdpDestination.
fwx_Bind_Tcp
Bind request for TCP sockets. For more information, see FwxBindEvent.
fwx_Bind_Udp
Bind request for UDP sockets. For more information, see FwxBindEvent.
fwx_Listen
Listen on a TCP socket. For more information, see FwxListenEvent.
fwx_AcceptedConnection
Actual inbound connection on a listening TCP socket. For more information, see FwxAcceptEvent.
fwx_GetHostByName
The Firewall client calls the gethostbyname function. This event can be generated only by a Firewall client. It will not be generated for a SecureNAT client. For more information, see FwxGetHostByNameEvent.
fwx_GetHostByAddr
The Firewall client calls the gethostbyaddr function. This event can be generated only by a Firewall client. It will not be generated for a SecureNAT client. For more information, see FwxGetHostByAddrEvent.
fwx_ConnectionTerminating
Notification before shutting down a connection object. For more information, see FwxEndConnectionEvent.
fwx_EstablishedConnection
Notification for connections established for IFWXSession::AllowFutureConnect, IFWXSession::BindForClient, and IFWXSession::RedirectConnections methods. This event is created by the Microsoft Firewall service. For more information, see FwxEstablishedConnectionEvent.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Wspfwext.idl.

See Also

Filter Enumerated Types, IFWXConnection, IFWXSession::SetDataFilterFactory


FwxNcdEventType enumeration [ISA Server 2004]

FwxNcdEventType

The FwxNcdEventType enumerated type defines types of network configuration detection (NCD) events.

typedef enum FwxNcdEventType
{
  fwx_ncd_AddNetworkElement
fwx_ncd_AddNetworkElement
A network element was added.
,
  fwx_ncd_RemoveNetworkElement
fwx_ncd_RemoveNetworkElement
A network element was removed.
,
  fwx_ncd_AddNetworkAdapter
fwx_ncd_AddNetworkAdapter
A network adapter was added.
,
  fwx_ncd_RemoveNetworkAdapter
fwx_ncd_RemoveNetworkAdapter
A network adapter was removed.
,
  fwx_ncd_AddNetworkAddress
fwx_ncd_AddNetworkAddress
A network address was added to the local computer.
,
  fwx_ncd_RemoveNetworkAddress
fwx_ncd_RemoveNetworkAddress
A network address was removed from the local computer.
,
  fwx_ncd_AddNetworkSet
fwx_ncd_AddNetworkSet
A network set was added.
,
  fwx_ncd_RemoveNetworkSet
fwx_ncd_RemoveNetworkSet
A network set was removed.
,
  fwx_ncd_AddNetworkElementToSet
fwx_ncd_AddNetworkElementToSet
A network element  was added to a network set.
,
  fwx_ncd_RemoveNetworkElementFromSet
fwx_ncd_RemoveNetworkElementFromSet
A network element  was removed from a network set.
,
  fwx_ncd_ChangeIpRange
fwx_ncd_ChangeIpRange
The mapping of IP address ranges to their respective network elements was changed.
,
  fwx_ncd_ChangeAdapterRoute
fwx_ncd_ChangeAdapterRoute
The adapter route was changed.
,
  fwx_ncd_Startup
fwx_ncd_Startup
The first notification was received by a newly registered NCD client. This notification provides a value for the uiContextSlot parameter  in SetContext and GetContext methods, such as IFWXNetworkElement::SetContext.
,
  fwx_ncd_Shutdown
fwx_ncd_Shutdown
The last of the incremental "remove" notifications was received by an NCD client when it unregisters, indicating that the unregistration process is complete.
,
  fwx_ncd_SyncConfig
fwx_ncd_SyncConfig
An  IFWXNetConfigDetectionSnapshot interface was created when an NCD synchronization took place.

} FwxNcdEventType;

Constants

fwx_ncd_AddNetworkElement
A network element was added.
fwx_ncd_RemoveNetworkElement
A network element was removed.
fwx_ncd_AddNetworkAdapter
A network adapter was added.
fwx_ncd_RemoveNetworkAdapter
A network adapter was removed.
fwx_ncd_AddNetworkAddress
A network address was added to the local computer.
fwx_ncd_RemoveNetworkAddress
A network address was removed from the local computer.
fwx_ncd_AddNetworkSet
A network set was added.
fwx_ncd_RemoveNetworkSet
A network set was removed.
fwx_ncd_AddNetworkElementToSet
A network element was added to a network set.
fwx_ncd_RemoveNetworkElementFromSet
A network element was removed from a network set.
fwx_ncd_ChangeIpRange
The mapping of IP address ranges to their respective network elements was changed.
fwx_ncd_ChangeAdapterRoute
The adapter route was changed.
fwx_ncd_Startup
The first notification was received by a newly registered NCD client. This notification provides a value for the uiContextSlot parameter in SetContext and GetContext methods, such as IFWXNetworkElement::SetContext.
fwx_ncd_Shutdown
The last of the incremental "remove" notifications was received by an NCD client when it unregisters, indicating that the unregistration process is complete.
fwx_ncd_SyncConfig
An IFWXNetConfigDetectionSnapshot interface was created when an NCD synchronization took place.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Wspfwext.idl.

See Also

Filter Enumerated Types


FwxNcdRangesChangeReason enumeration [ISA Server 2004]

FwxNcdRangesChangeReason

The FwxNcdRangesChangeReason enumerated type contains values that specify reasons for the changes in the mapping of the IP ranges to the ISA Server networks in a network configuration detection (NCD) event.

typedef enum _tagFwxNcdRangesChangeReason
{
  fwx_ncd_ServiceStartup
fwx_ncd_ServiceStartup
A service started up.
,
  fwx_ncd_StorageChanged
fwx_ncd_StorageChanged
The stored configuration was changed.
,
  fwx_ncd_VpnConnection
fwx_ncd_VpnConnection
A VPN connection was opened.
,
  fwx_ncd_VpnDisconnection
fwx_ncd_VpnDisconnection
A VPN connection was closed.
,
  fwx_ncd_ServiceShutdown
fwx_ncd_ServiceShutdown
A service was shut down.

} FwxNcdRangesChangeReason;

Constants

fwx_ncd_ServiceStartup
A service started up.
fwx_ncd_StorageChanged
The stored configuration was changed.
fwx_ncd_VpnConnection
A VPN connection was opened.
fwx_ncd_VpnDisconnection
A VPN connection was closed.
fwx_ncd_ServiceShutdown
A service was shut down.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Wspfwext.idl.

See Also

Filter Enumerated Types


FwxSslSocketSide enumeration [ISA Server 2004]

FwxSslSocketSide

The FwxSslSocketSide enumerated type defines whether an SSL socket is on the client side or server side.

typedef enum
{
  fwxServerSide
fwxServerSide
The socket is on the server side.
 = 1,
  fwxClientSide
fwxClientSide
The socket is on the client side.

} FwxSslSocketSide;

Constants

fwxServerSide
The socket is on the server side.
fwxClientSide
The socket is on the client side.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Wspfwext.idl.

See Also

Filter Enumerated Types


FwxTimeoutType enumeration [ISA Server 2004]

FwxTimeoutType

The FwxTimeoutType enumerated type defines types of time-outs for sockets.

typedef enum FwxTimeoutType
{
  fwxSendTimeout
fwxSendTimeout
Time out on a send operation.
 = 0x00000001,
  fwxRecvTimeout
fwxRecvTimeout
Time out on a receive operation.
 = 0x00000002,
  fwxAcceptTimeout
fwxAcceptTimeout
Time out on a Windows Sockets Accept operation, with time measured from the beginning of the accept operation until its end (ACK).
 = 0x00000004,
  fwxAcceptExTimeout
fwxAcceptExTimeout
Time out on a Windows Sockets AcceptEx operation, with time measured from the beginning of the operation until the first PUSH.
 = 0x00000008,
  fwxAcceptExRecvTimeout
fwxAcceptExRecvTimeout
Time out on a Windows Sockets AcceptEx operation, with time measured from the final ACK of the operation (the final ACK in the three-way handshake of the TCP) until the first PUSH.
 = 0x00000010,
  fwxConnectExSendTimeout
fwxConnectExSendTimeout
Time out on a Windows Sockets ConnectEx operation.
 = 0x00000020

} FwxTimeoutType;

Constants

fwxSendTimeout
Time out on a send operation.
fwxRecvTimeout
Time out on a receive operation.
fwxAcceptTimeout
Time out on a Windows Sockets Accept operation, with time measured from the beginning of the accept operation until its end (ACK).
fwxAcceptExTimeout
Time out on a Windows Sockets AcceptEx operation, with time measured from the beginning of the operation until the first PUSH.
fwxAcceptExRecvTimeout
Time out on a Windows Sockets AcceptEx operation, with time measured from the final ACK of the operation (the final ACK in the three-way handshake of the TCP) until the first PUSH.
fwxConnectExSendTimeout
Time out on a Windows Sockets ConnectEx operation.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Wspfwext.idl.

See Also

Filter Enumerated Types


Web Proxy Documentation [ISA Server 2004]

Web Proxy Documentation

This section describes the Internet Security and Acceleration (ISA) Server 2004 Web proxy, and how to extend it through the creation of Web filters.

This section contains the following topics:

  • Introduction to Web Filters
  • Developing Web Filters for ISA Server
  • Web Filter Reference


Introduction to Web Filters [ISA Server 2004]

Introduction to Web Filters

Using Web filters, you can intervene in the processing of HTTP requests. Web filters are dynamic-link libraries (DLLs) that are loaded when the Microsoft Firewall service is started and stay in memory until the service shuts down. Web filters can be configured to receive filter-event notifications that occur with each HTTP request that the ISA Server Web proxy receives and with each response returned through the Web proxy by an external Web server. For more information about the types of event notifications that are sent to Web filters, see Event Notifications.

The Web proxy sends event notifications to the Web filters that are registered to receive them by calling the applicable entry-point function. For more information about the entry-point functions that are implemented by Web filters, see Web Filter Entry-Point Functions.

In each call to an entry-point function, the Web proxy passes information to the Web filter in a structure, which also contains pointers to functions that the Web filter can use in its reaction to the call. For more information the structures used in Web filters, see Web Filter Structures.

The following illustration provides a schematic overview of the HTTP request-and-response process. A Web filter can register for and react to the events represented in the illustration. These events include both client-side events and server-side events. Client-side events occur when a client sends a request to the ISA Server computer, and when the ISA Server computer responds to the client. Server-side events occur when the ISA Server computer passes a request to a Web server, and when the Web server responds to the ISA Server computer. In this illustration, the ISA Server computer is represented by the Web proxy component of ISA Server.

This section contains the following topics:

  • Uses of Web Filters
  • Web Filter Basics
  • ISA Server Web Proxy Architecture


Uses of Web Filters [ISA Server 2004]

Uses of Web Filters

You can use Web filters to facilitate applications that perform a number of different tasks, including:

  • Request scanning and modification
  • Response scanning and modification
  • Traffic analysis or other request analyses
  • Logging
  • Encryption
  • Compression
  • Custom authentication schemes

Web filters are powerful and flexible because they can examine and, if necessary, modify both incoming and outgoing streams of data.


Web Filter Basics [ISA Server 2004]

Web Filter Basics

When a Web filter is loaded, the filter passes a structure to the ISA Server Web proxy, which contains, in addition to other information, a bit field that specifies the types of filter events for which the filter should be notified. Each time one of those events occurs, an event notification is sent to every Web filter that has specified interest in that event.

When designing a Web filter, consider what events you want the filter to react to, and decide what processing the filter will perform when each event occurs. In addition to these basic design considerations, you must select a priority for the filter, and ensure that it will be properly added to the collection of Web filters so that it is loaded by the Web proxy. For more information, see Web Filter Administration.

Web filters that alter the data being transferred, such as encrypting or decrypting filters, should be assigned a higher priority than the HTTP filter through the Priority property during setup.

Web filters should never trust an upstream proxy server and forward user credentials to it.

If a filter modifies the content of the data stream, the HTTP filter might inadvertently pass modified versions of signatures in the request or response header that it is configured to look for.

If a Web filter creates a new authentication scheme when it is regisered with ISA Server, ISA Server Management must be restarted before it will display the new authentication scheme.


ISA Server Web Proxy Architecture [ISA Server 2004]

ISA Server Web Proxy Architecture

The ISA Server Web proxy is an application filter on the Microsoft Firewall service. Functions provided by the Web proxy include:

  • Parsing of HTTP protocol traffic.
  • Support for HTTP 1.1 protocol features.
  • Authentication of client requests.
  • Web filter-notification support.

Note to Developers of Web Filters for Internet Information Services

There are several differences between the implementation of ISAPI in Internet Information Services (IIS) and in ISA Server. These are described in ISAPI: Comparing IIS and ISA Server.


Developing Web Filters for ISA Server [ISA Server 2004]

Developing Web Filters for ISA Server

Web filters detect and process HTTP request notifications. ISA Server 2004 supports ISAPI filter development, with additional functionality to that provided with Internet Information Services (IIS) and ISA Server 2000. ISA Server 2004 operates independently of IIS, while using the definition of ISAPI functions and structures provided in the Microsoft Windows Server™ 2003 Software Development Kit (Platform SDK). This section provides information about ISAPI filters, as implemented in ISA Server 2004.

In ISA Server Management and in the product documentation, ISAPI filters are referred to as Web filters.

For general information about ISAPI filter development, see ISAPI Filters on the MSDN Web site.

Note to Developers of Web Filters for Internet Information Services

There are several differences between implementation of ISAPI in IIS and in ISA Server. These are described in ISAPI: Comparing IIS and ISA Server.

This section contains the following topics:

  • Web Filter Development
  • Web Filter Administration
  • Web Filter Setup
  • Self-Registering Web Filters
  • Web Filter Samples
  • ISAPI: Comparing IIS and ISA Server


Web Filter Development [ISA Server 2004]

Web Filter Development

The ISA Server SDK provides a programming interface for the development of Web filters. Use of the programming interface is described briefly in this section and in more detail in Web Filter Reference. This section includes the following topics:

  • Web Filter Entry-Point Functions
  • Web Filter Structures
  • Event Notifications


Web Filter Entry-Point Functions [ISA Server 2004]

Web Filter Entry-Point Functions

Web filters for the ISA Server Web proxy implement the following standard entry functions:

  • GetFilterVersion
  • HttpFilterProc

Web filters for the ISA Server Web proxy implement the following entry points specific to ISA Server 2004:

  • GetWPXFilterVersion
  • HttpWPXFilterProc

Note At a minimum, a Web filter must implement either GetFilterVersion and HttpFilterProc, or GetWPXFilterVersion and HttpWPXFilterProc (or both pairs of functions).

In addition, a Web filter can implement the TerminateFilter function.

These functions are described here briefly and in greater detail in Entry-Point Functions.

GetFilterVersion

The GetFilterVersion function is the first entry-point function called by ISA Server Web proxy on your Web filter. The Web proxy passes a pointer to an HTTP_FILTER_VERSION data structure, which can be used to supply key filter configuration information to the Web proxy. The most important information passed to the Web proxy is the bitmask that contains flags that specify which notification events your filter can process, and a flag that indicates the overall processing priority for your filter. This function must be implemented together with HttpFilterProc.

HttpFilterProc

Whenever a notification event for which the filter has registered in GetFilterVersion occurs, the ISA Server Web proxy calls the HttpFilterProc function. The Web proxy uses this function to pass information and control to the Web filter. This function must be implemented together with GetFilterVersion.

GetWPXFilterVersion

The GetWPXFilterVersion function is called after the GetFilterVersion function (if it is implemented) to get notifications specific to ISA Server 2004. The Web proxy passes a pointer to a HTTP_FILTER_VERSION data structure, which can be used to supply key filter configuration information to the Web proxy. The most important information passed to the Web proxy is the bitmask that contains flags that specify which notification events your filter can process, and a flag that indicates the overall processing priority for your filter. This function must be implemented together with HttpWPXFilterProc.

HttpWPXFilterProc

Whenever a notification specific to ISA Server 2004 for which the filter has registered in GetWPXFilterVersion occurs, the ISA Server Web proxy calls the HttpWPXFilterProc function. The Web proxy uses this function to pass information and control to the Web filter. This function must be implemented together with GetWPXFilterVersion.

TerminateFilter

This function indicates to the filter that it will be removed from memory. When this function is called, make sure that the filter closes any attachments it has made to system resources.

Note TerminateFilter is an optional function. However, you must provide this function if your filter needs to free any allocated or locked resources before being unloaded.


Web Filter Structures [ISA Server 2004]

Web Filter Structures

The Web proxy of ISA Server works with the structures described here.

HTTP_FILTER_CONTEXT

The HTTP_FILTER_CONTEXT structure is used by HttpFilterProc to obtain information about the current request. The structure includes pointers to the following functions:

  • GetServerVariable
  • AddResponseHeaders
  • WriteClient
  • AllocMem
  • ServerSupportFunction

HTTP_FILTER_VERSION

The HTTP_FILTER_VERSION structure is used by the GetFilterVersion and the GetWPXFilterVersion functions to obtain the filter's version information and registered notifications.

WPX_FILTER_CONTEXT

The WPX_FILTER_CONTEXT structure provides additional information and functions for the current request. The structure extends HTTP_FILTER_CONTEXT and adds the following functions:

  • WriteServer
  • AllocMemoryPerRequest
  • GetAuthSchemeStatus
  • WPXSupportFunction

Note To use these functions you must get a pointer to the WPX_FILTER_CONTEXT structure from a pointer to an HTTP_FILTER_CONTEXT structure. To do so, use the TO_WPX_FILTER_CONTEXT macro as follows:

WPX_FILTER_CONTEXT* pwfc = TO_WPX_FILTER_CONTEXT(pfc);
if (pwfc != NULL) {
...
}


Event Notifications [ISA Server 2004]

Event Notifications

The following is an alphabetical table of notifications for which a Web filter can be registered. For more information about event notifications, including the typical order in which they occur, see Introduction to Web Filters.

Notifications Specific to ISA Server 2004

The following list describes the notifications specific to ISA Server 2004, which are associated with the HttpWPXFilterProc entry-point function.

SF_NOTIFY_FORWARD_RAW_DATA
A notification specific to ISA Server. Occurs before raw data is sent to the server. May be used by filters that want to modify this data. Provided with the HTTP_FILTER_RAW_DATA notification structure.
SF_NOTIFY_FORWARD_RAW_DATA_COMPLETED
A notification specific to ISA Server. Occurs when the sending of raw data to the server is complete. May be used by filters that want to modify the data based on the complete content.
SF_NOTIFY_POLICY_CHECK_COMPLETED
A notification specific to ISA Server. Occurs after the ISA Server policy check has been completed, and the request has either been allowed or denied. After this notification has been received, the Web filter can request the GUID of the policy rule that either allowed or denied the request. The filter can also request additional data from the client (SF_STATUS_REQ_READ_NEXT), although the read operation will fail if all of the data has already been received.
SF_NOTIFY_RECEIVE_RESPONSE_HEADERS
A notification specific to ISA Server. Occurs after the response headers have been received. May be used by filters to modify the headers received from the server before the response is processed by ISA Server. Provided with the WPX_FILTER_PREPROC_HEADERS notification structure.

Note This notification may arrive more than once for a client POST request. The notification is provided each time that a Web server returns an HTTP status 100 (Continue) response, and once more for the final response.

SF_NOTIFY_RECEIVE_RESPONSE_RAW_DATA
A notification specific to ISA Server. Occurs after data is received from the server, and before it is processed by ISA Server. May be used by a filter to modify the content of the data received from the server. Provided with the HTTP_FILTER_RAW_DATA notification structure.

Note A single request may get more than a single response header if the method is POST. If the data is parsed, take into account the possibility of multiple response headers.

If a filter accumulates a response in an SF_NOTIFY_RECEIVE_RESPONSE_RAW_DATA notification without releasing it to the next filter, the filter may not release the data until it receives an SF_NOTIFY_END_OF_REQUEST notification, which indicates that the server closed the connection. At this point, the filter will typically call WriteClient with the accumulated data. However, this will prevent other server-side filters from obtaining the raw response data, and those filters will be skipped. We recommend not accumulating the body of a response without releasing it to the next filter. If you must do so, accumulate the data in an SF_NOTIFY_SEND_RAW_DATA notification rather than an SF_NOTIFY_RECEIVE_RESPONSE_RAW_DATA notification.

SF_NOTIFY_ROUTING
A notification specific to ISA Server. Occurs before the Web filter forwards the request to the destination server. Can be used by a filter to override the host name, IP address, or port for the connection. Provided with the WPX_FILTER_ROUTE notification structure.

General Notifications

The following list describes the notifications and flags that are not specific to ISA Server, but are supported by it. These are associated with the HttpFilterProc entry-point function.

SF_NOTIFY_ACCESS_DENIED
Occurs just after ISA Server determines that access is denied for the request resource, but before ISA Server sends a response to the client. Provided with the HTTP_FILTER_ACCESS_DENIED notification structure.
SF_NOTIFY_AUTH_COMPLETE
In an HTTP authentication scenario, this notification occurs just after ISA Server determines that access is allowed for the request resource. Provided with the HTTP_FILTER_AUTH_COMPLETE_INFO notification structure.
SF_NOTIFY_AUTHENTICATION
Occurs just before ISA Server authenticates the client. Can be used with ISA Server to provide a custom authentication scheme. Provided with the WPX_FILTER_AUTHENT_EX notification structure. If authentication is not required by any rule then the notification occurs with an anonymous user.
SF_NOTIFY_END_OF_NET_SESSION
Occurs when a network session with a client is ending.
SF_NOTIFY_END_OF_REQUEST
Occurs at the end of a request.
SF_NOTIFY_LOG
Occurs at the end of a request, just before ISA Server writes the session to the ISA Server log. Provided with the HTTP_FILTER_LOG notification structure.
SF_NOTIFY_PREPROC_HEADERS
Occurs after ISA Server preprocesses headers, but before the program begins to process header content. Provided with the HTTP_FILTER_PREPROC_HEADERS notification structure.
SF_NOTIFY_READ_RAW_DATA
Occurs when data is being read from the client. May occur more than once per request. Provided with the HTTP_FILTER_RAW_DATA notification structure.
SF_NOTIFY_SEND_RAW_DATA
Occurs when ISA Server sends raw data back to the client. May occur more than once per request.

Note A single request may get more than a single response header if the method is POST. If the data is parsed, take into account the possibility of multiple response headers.

Provided with the HTTP_FILTER_RAW_DATA notification structure.
SF_NOTIFY_SEND_RESPONSE
Occurs after the request is processed by IIS, but before any headers are sent back to the client. This notification is not used when ISA Server returns a response from a Web server or from the cache. However, it is called when a filter generates a response by using SF_REQ_SEND_RESPONSE_HEADER (), or when the Web proxy generates a response, such as an error page.

Provided with the HTTP_FILTER_SEND_RESPONSE notification structure.

SF_NOTIFY_URL_MAP
Occurs after IIS translates a URL to a physical path on the server. This notification is irrelevant for the ISA Server Web proxy because it does not have any physical URLs. However, it is provided as it was in Microsoft Proxy Server 2.0, for compatibility with earlier versions.

Provided with the HTTP_FILTER_URL_MAP notification structure.

In addition to the notification events, the Web proxy uses flags relating to port security settings.

Term | Description
SF_NOTIFY_SECURE_PORT | Notify the Web filter only for connections over a secure port.
SF_NOTIFY_NONSECURE_PORT | Notify the Web filter only for connections over a nonsecure port.


Web Filter Administration [ISA Server 2004]

Web Filter Administration

Setup information for the ISA Server Web proxy is written to the stored ISA Server configuration. You can administer Web filters through the ISA Server administration COM objects. The COM object FPCWebFilter is provided so that you can access the administration information for an individual Web filter. Each FPCWebFilter object is an element of the FPCWebFilters collection.

An example of Web filter administration that uses the ISA Server FPC interfaces is provided in Web Filter Setup.

Use the corresponding COM objects, as shown in Web Filter Setup.

You can enable or disable Web filters, and change their order through ISA Server Management. In addition, you can add and remove filters programmatically using ISA Server administration COM objects.

Web filters should not attempt to write to the stored ISA Server configuration. Web filters are allowed read-only access to the stored ISA Server configuration on computers running Windows Server 2003. Therefore, a Web filter that relies on successfully writing to the stored configuration will fail.


Web Filter Setup [ISA Server 2004]

Web Filter Setup

To set up a filter, use the FPCWebFilter and FPCWebFilters COM objects. Each FPCWebFilter object is defined by the globally unique identifier (GUID) used to add it to the FPCWebFilters collection. The FPCWebFilters collection provides methods so that you can perform the following operations:

  • Add a new Web filter using the FPCWebFilters.Add method.
  • Change the order of the filters in the collection using the FPCWebFilters.MoveDown and FPCWebFilters.MoveUp methods.
  • Remove a Web filter using the FPCWebFilters.Remove method.

For more information, see each method's reference page.


Self-Registering Web Filters [ISA Server 2004]

Self-Registering Web Filters

You can create a Web filter that supports self-registration of the filter with ISA Server. The code is demonstrated in the WebResponseModifier filter sample. The sample uses ISA Server administration COM objects to add a self-registering Web filter to ISA Server. The sample files are in the Webfilters folder, under the samples folder in the SDK.

This section contains the following topics:

  • Building the ISA Server Web Filter Sample
  • ISA Server Web Filter Sample Administration Steps


Building the ISA Server Web Filter Sample [ISA Server 2004]

Building the ISA Server Web Filter Sample

The sample is included in the samples folder of the SDK, in the subfolder Web_filters.

To build the ISA Server Web filter included in the SDK, using Visual C++ 6.0

  1. Open Microsoft Visual C++ 6.0.
  2. Open the sample workspace, Webresponsemodifier.dsw.
  3. To see the project files, on the View menu, click workspace.
  4. Press the F7 key to build the sample.

These steps create Webresponsemodifier.dll.

Note You must have the Platform SDK installed to compile the project in Visual C++ 6.0

To build the ISA Server Web filter included in the SDK, using Visual Studio .NET

  1. Open Microsoft Visual Studio .NET.
  2. Open the sample project, Webresponsemodifier.vcproj.
  3. To see the project files, on the View menu, click Solution explorer.
  4. Build the sample. The first time you build the sample, you will be asked to save the solution.

These steps create Webresponsemodifier.dll.


ISA Server Web Filter Sample Administration Steps [ISA Server 2004]

ISA Server Web Filter Sample Administration Steps

The Webresponsemodifier sample filter is an example that demonstrates how a filter can register itself.

This section contains the following topics:

  • Register the Web Filter from the Command Line
  • Unregister the Web Filter from the Command Line
  • Add the Web Filter to ISA Server


Register the Web Filter from the Command Line [ISA Server 2004]

Register the Web Filter from the Command Line

To register the filter in ISA Server, type this line at the command prompt (from the folder where Webresponsemodifier.dll is located):

regsvr32 Webresponsemodifier.dll

This command is carried out by the code in the function DllRegisterServer in the Webresponsemodifier sample. The filter developer writes this function. The code from the Webresponsemodifier filter sample is shown as follows:

// DllRegisterServer - Adds entries to the system registry
STDAPI DllRegisterServer(void)
{
    HRESULT hr = RegisterWebFilter(true);
    return FAILED(hr) ? S_FALSE : S_OK;
}


Unregister the Web Filter from the Command Line [ISA Server 2004]

Unregister the Web Filter from the Command Line

To unregister the filter, type this line at the command prompt (from the folder where Webresponsemodifier.dll is located):

regsvr32 -u Webresponsemodifier.dll

This command is carried out by the code in the function DllUnregisterServer in the Webresponsemodifier sample. The filter developer writes this function. The code from the Webresponsemodifier filter sample is shown as follows.

// DllUnregisterServer - Removes entries from the system registry

STDAPI DllUnregisterServer(void)
{
    HRESULT hr = RegisterWebFilter(false);
    return hr;
}


Add the Web Filter to ISA Server [ISA Server 2004]

Add the Web Filter to ISA Server

The DllRegisterServer and DllUnregisterServer functions in the WebResponseModifier sample both call RegisterWebFilter. RegisterWebFilter receives a Boolean value. True indicates that the filter should be added to ISA Server, and false indicates that it should be removed. RegisterWebFilter uses the ISA Server administration COM objects.

The following RegisterWebFilter function code is taken from the file WebFltrRegister.cpp, included in the Webresponsemodifier folder:

// Define the filter GUID and the filter's path relative to
// the ISA installation folder.
const char StrGuid[] = "{87F18571-C71D-4a2f-9111-9E0927A00B51}";
const char FilterRelativePath[] = "WebResponseModifier.dll";

HRESULT RegisterWebFilter(bool fRegister)
{
    HRESULT hr = S_OK;

    // Get instance of filter admin object.
    hr = CoInitialize(NULL);

    if (FAILED(hr))
    {
        return hr;
    }
    else
    {
        ISALIB::IFPCPtr pIISA;

        hr = CoCreateInstance(
            ISALIB::CLSID_FPC,
            NULL,
            CLSCTX_INPROC_SERVER,
            ISALIB::IID_IFPC,
            (void**)&pIISA);

        if (FAILED(hr) || (pIISA == NULL))
        {
            CoUninitialize( );
            return hr;
        }

        ISALIB::IFPCArrayPtr pIISAArr;
        ISALIB::IFPCExtensionsPtr pIExtensions;
        ISALIB::IFPCWebFiltersPtr pWebFilters;
        ISALIB::IFPCWebFilterPtr pFilter;

        try
        {
            pIISAArr = pIISA->GetContainingArray();
            pIExtensions = pIISAArr->Extensions;
            pWebFilters = pIExtensions->WebFilters;
        }
        catch(_com_error& err)
        {
            hr = err.Error();
            CoUninitialize( );
            return hr;
        }

        if (fRegister)
        {
            try
            {
                pFilter = pWebFilters->Add(StrGuid,"Web Response modifier",FilterRelativePath,ISALIB::fpcFilterPriority_Medium,ISALIB::fpcFilterDirectionBoth);
                pFilter->PutDescription("Modifies the web servers' response");
                pFilter->PutVendor("Microsoft (R) Corporation");
                pFilter->PutVersion("4.0");
                pFilter->Save(VARIANT_FALSE, VARIANT_TRUE);
            }
            catch(_com_error& err)
            {
                if(err.Error() != HRESULT_FROM_WIN32(ERROR_ALREADY_EXISTS))
                {
                    hr = err.Error();
                }
            }
        else
        {
            try
            {
                pWebFilters->Remove(StrGuid);
                pWebFilters->Save(VARIANT_FALSE, VARIANT_TRUE);
                pWebFilters->Refresh();
            }
            catch(_com_error& err)
            {
                if(err.Error() != HRESULT_FROM_WIN32(ERROR_FILE_NOT_FOUND))
                {
                    hr = err.Error();
                }
            }
        }
    }

    CoUninitialize( );
    return hr;
}


Web Filter Samples [ISA Server 2004]

Web Filter Samples

Sample Web filters developed by using the ISA Server 2004 SDK are provided in the Samples\WebFilters folder on the ISA Server 2004 CD-ROM in the SDK folder. The following samples are provided:

  • MyAuth, which demonstrates the new authentication extensibility model of ISA Server 2004.
  • WebExeBlock, which demonstrates the use of server-side notifications to identify a Windows executable file and block it.
  • Webresponsemodifier, which demonstrates basic Web filter behavior, and filter self-registration.


MyAuth [ISA Server 2004]

MyAuth

The MyAuth Web filter sample is a Web filter that registers a new authentication scheme and performs the authentication in place of the Web proxy for every HTTP request. The authentication in the sample is not a true authentication. The filter asks for the user name, and when it receives the name, the user is considered authenticated.

After this sample registers the new authentication scheme with ISA Server, ISA Server Management must be restarted before the new authentication scheme will be displayed.


WebExeBlock [ISA Server 2004]

WebExeBlock

The WebExeBlock Web filter demonstrates the use of server-side notifications to identify a Windows executable file and block it. An executable file is identified when the response body starts with MZ. Note that this is a sample filter. For example, this filter handles only 200 OK responses, does not support chunked encoding or compression, and does not handle 100-continue.


Webresponsemodifier [ISA Server 2004]

Webresponsemodifier

The implementation of ISAPI in ISA Server enables you to accumulate response chunks to form a complete response, by means of a Web filter.

The Webresponsemodifier filter collects the response chunks and then changes them depending on the complete response. This filter is an adaptation of the filter that IIS uses for compression. (The original filter was written by David Treadwell in July 1997.)

The filter adds a line of text in the HTML response before sending the response to the client.

The filter works with two notifications. In SF_NOTIFY_SEND_RAW_DATA, it collects the response's chunks, and resets the buffer size to 0. Then, when all the chunks of this response have passed SF_NOTIFY_SEND_RAW_DATA notifications, ISA Server calls the SF_NOTIFY_END_OF_REQUEST notification. The filter then modifies the response, and sends the complete response using the WriteClient function.


ISAPI: Comparing IIS and ISA Server [ISA Server 2004]

ISAPI: Comparing IIS and ISA Server

The ISA Server Web proxy supports the Web filter extensibility model, so that third-party developers can examine and change the HTTP request-and-response flow by using Web filters. ISAPI extensions are not supported.

The Web proxy manages communication with clients, and therefore does not rely on Internet Information Services (IIS). The Web proxy provides the functions necessary for the implementation of Web filters. Web filters developed for IIS will generally work with the Web proxy because the APIs are similar.

There are several important differences between ISAPI support in IIS and in ISA Server.

Architecture

Web filters for IIS are typically installed on a Web server. Web filters for ISA Server are installed on an ISA Server computer, between the Web server and the Web client, and act as conduits for requests to all external and internal sites. There is no local site or content, and no direct access to Web server files.

Functions

Support for general ISAPI functions, server support functions, and notification-specific functions in ISA Server differs slightly from IIS. The following table compares support for ISAPI functions in IIS and in ISA Server.

Function or notification | Task | ISA Server support | IIS support
GetServerVariable |  | Yes. Not all variables are supported. | ISA Server 2004 provides some variables that are not provided by IIS.
AddResponseHeaders |  | Yes. Headers are added by AddResponseHeaders only for responses generated by ISA Server, where SEND_RESPONSE is triggered. Use SEND_RAW_DATA to add headers to all responses. | Yes.
WriteClient |  | Yes. | Yes.
AllocMem |  | Yes. | Yes.
ServerSupportFunction | SF_REQ_ADD_HEADERS_ON_DENIAL | Yes. | Yes.
 | SF_REQ_DISABLE_NOTIFICATIONS | Yes. | Yes.
 | SF_REQ_GET_CONNID | Returns 0. | Supported by versions earlier than IIS 4.0; otherwise, returns 0.
 | SF_REQ_GET_PROPERTY only for SF_PROPERTY_INSTANCE_NUM_ID | Returns 0. | Yes.
 | SF_REQ_NORMALIZE_URL | Yes. | Yes.
 | SF_REQ_SEND_RESPONSE_HEADER | Yes. | Yes.
 | SF_REQ_SET_NEXT_READ_SIZE | Not relevant to the implementation of ISAPI in ISA Server. Provided for compatibility with IIS. If you use it in an ISA Server Web filter, you should not assume that the number of bytes read during the subsequent read operation will not exceed the value set in the ul1 parameter. | Yes.
 | SF_REQ_SET_PROXY_INFO | No. | Yes.
SF_NOTIFY_SEND_RESPONSE |  | Not used when the Web proxy sends a response. Used when a filter generates a response using the SF_REQ_SEND_RESPONSE_HEADERS server support function. | Yes.

Administration

Administration, setup, and registration are significantly different in ISA Server. For specific information and procedures, see Web Filter Setup.

IIS stores configuration information in the Microsoft Active Directory, whereas the ISA Server Web proxy uses the ISA Server administration COM objects to store and retrieve filter configuration information.

Note Web filters developed for Microsoft Proxy Server 2.0 are not binary-compatible with ISA Server because of new notifications, setup requirements, and storage functionality.


Web Filter Reference [ISA Server 2004]

Web Filter Reference

The Web filter reference section contains the following topics:

  • Entry-Point Functions
  • Callback Functions
  • Notification Structures


Entry-Point Functions [ISA Server 2004]

Entry-Point Functions

The ISA Server Web proxy calls entry-point functions in a Web filter to pass initialization information to the Web filter, to notify the Web filter that a certain event has occurred, and to inform the Web filter that it is about to be unloaded from memory. Web filters can implement the following entry-point functions that were also available for ISAPI Web filters in ISA Server 2000:

  • GetFilterVersion
  • HttpFilterProc

Web filters can also implement the following entry-point functions that are specific to ISA Server 2004:

  • GetWPXFilterVersion
  • HttpWPXFilterProc

Note At a minimum, a Web filter must implement either GetFilterVersion and HttpFilterProc, or GetWPXFilterVersion and HttpWPXFilterProc (or both pairs of functions).

In addition, a Web filter can implement the following optional entry-point functions:

  • TerminateFilter
  • ReloadWpxFilterConfiguration

See Also

Web Filter Reference


GetFilterVersion(PHTTP_FILTER_VERSION) callback function [ISA Server 2004]

GetFilterVersion

The GetFilterVersion function is the first entry-point function called by ISA Server Web proxy on your Web filter. The Web proxy passes a pointer to a HTTP_FILTER_VERSION data structure, which can be used to supply key filter configuration information to the Web proxy. The most important information passed to the Web proxy is the bitmask that contains flags that specify which notification events your filter can process, and a flag that indicates the overall processing priority for your filter. This function must be implemented together with HttpFilterProc.

This function is used to set the notifications that were available to ISAPI filters in ISA Server 2000 and Internet Information Services (IIS). To set the new notifications available in ISA Server 2004, use GetWPXFilterVersion.

The function declaration is:

BOOL WINAPI GetFilterVersion(
  PHTTP_FILTER_VERSION pVer
);

Parameters

pVer
Points to the HTTP_FILTER_VERSION structure that contains both the version information for the server and members with which the filter must indicate filter API version number, and notifications. The priority flags and description field are not used in ISA Server 2004.

Return Values

If this function returns TRUE, the filter will remain loaded. If the function returns FALSE, the filter functionality will be terminated and the filter will be unloaded. If the function returns FALSE in your filter, the filter must call SetLastError with the nature of the failure.

Note It is important to register only for those notifications that are necessary for your filter's purposes. Registering for additional notifications will reduce performance.

Remarks

At a minimum, a Web filter must implement either GetFilterVersion and HttpFilterProc, or GetWPXFilterVersion and HttpWPXFilterProc (or both pairs of functions).

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Wpxhttpfilt.h.

See Also

Entry-Point Functions


GetWPXFilterVersion(PHTTP_FILTER_VERSION) function [ISA Server 2004]

GetWPXFilterVersion

The GetWPXFilterVersion function is called after the GetFilterVersion function (if it is implemented) to get notifications specific to ISA Server 2004. The Web proxy passes a pointer to an HTTP_FILTER_VERSION data structure, which can be used to supply key filter configuration information to the Web proxy. The most important information passed to the Web proxy is the bitmask that contains flags that specify which notification events your filter can process, and a flag that indicates the overall processing priority for your filter. This function must be implemented together with HttpWPXFilterProc.

This function is used to set the new notifications available in ISA Server 2004. To set the notifications that were available to ISAPI filters in ISA Server 2000 and Internet Information Services (IIS), use GetFilterVersion.

The function declaration is:

BOOL WINAPI GetWPXFilterVersion(
  PHTTP_FILTER_VERSION pVer
);

Parameters

pVer
Points to the HTTP_FILTER_VERSION structure that contains both the version information for the server and members with which the filter must indicate filter API version number, and notifications. The priority flags and description field are not used in ISA Server 2004.

Return Values

If this function returns TRUE, the filter will remain loaded. If the function returns FALSE, the filter functionality will be terminated and the filter will be unloaded. If the function returns FALSE in your filter, the filter must call SetLastError with the nature of the failure.

Note It is important to register only for those notifications that are necessary for your filter's purposes. Registering for additional notifications will reduce performance.

Remarks

At a minimum, a Web filter must implement either GetFilterVersion and HttpFilterProc, or GetWPXFilterVersion and HttpWPXFilterProc (or both pairs of functions).

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Wpxhttpfilt.h.

See Also

Entry-Point Functions


HttpFilterProc (3 Parameters) callback function [ISA Server 2004]

HttpFilterProc

The HttpFilterProc function is called by the ISA Server Web proxy whenever an event for which the filter has registered in the GetFilterVersion function occurs. The Web proxy uses this function to pass information and control to the Web filter. This function must be implemented together with GetFilterVersion.

Information about notifications is provided in Event Notifications.

The declaration of HttpFilterProc is:

DWORD WINAPI HttpFilterProc(
  PHTTP_FILTER_CONTEXT pfc,
  DWORD NotificationType,
  LPVOID pvNotification
);

Parameters

pfc
Pointer to the HTTP_FILTER_CONTEXT data structure that is associated with the current, active HTTP session.
NotificationType
Bitmask that indicates the type of event notification that is being processed. For a list of event-notification types, see Event Notifications.
pvNotification

Pointer to the notification-specific structure that contains more information about the current context of the request. You should cast this pointer to a pointer to the relevant notification structure according to the notification type, which is listed in the following table. For more information on the types of event notifications that are sent to Web filters, see Event Notifications.

Notification type | Notification structure
SF_NOTIFY_READ_RAW_DATA | HTTP_FILTER_RAW_DATA
SF_NOTIFY_PREPROC_HEADERS | HTTP_FILTER_PREPROC_HEADERS or WPX_FILTER_PREPROC_HEADERS
SF_NOTIFY_URL_MAP | HTTP_FILTER_URL_MAP
SF_NOTIFY_AUTHENTICATION | HTTP_FILTER_AUTHENT or WPX_FILTER_AUTHENT_EX
SF_NOTIFY_AUTH_COMPLETE | HTTP_FILTER_AUTH_COMPLETE_INFO or WPX_HTTP_FILTER_AUTH_COMPLETE_INFO
SF_NOTIFY_ACCESS_DENIED | HTTP_FILTER_ACCESS_DENIED
SF_NOTIFY_SEND_RESPONSE | HTTP_FILTER_SEND_RESPONSE
SF_NOTIFY_SEND_RAW_DATA | HTTP_FILTER_RAW_DATA
SF_NOTIFY_LOG | HTTP_FILTER_LOG

Note The SF_NOTIFY_END_OF_REQUEST and SF_NOTIFY_END_OF_NET_SESSION notifications do not have corresponding structures. The pointer will contain a NULL value.

Return Values

Implementations of this function may return the following values to indicate how the event was handled.

SF_STATUS_REQ_NEXT_NOTIFICATION
The next filter in the notification chain should be called. Typically, unless your filter specifically needs to return one of the other values, it should return this value.
SF_STATUS_REQ_FINISHED
The filter handled the HTTP request. The server should disconnect the session.

Note After this value is returned, the filter will continue to receive notifications. At a minimum, the filter will receive SF_NOTIFY_END_OF_REQUEST and SF_NOTIFY_END_OF_NET_SESSION notifications.

SF_STATUS_REQ_FINISHED_KEEP_CONN
Treated the same as SF_STATUS_REQ_FINISHED.
SF_STATUS_REQ_HANDLED_NOTIFICATION
The filter handled the notification. No other event handlers should be called for this specific notification, and the next notification will be called.
SF_STATUS_REQ_ERROR
An error occurred. The HTTP request will be aborted when this status is returned. If no data has been sent, the server will send an error message to the client. The filter should call SetLastError with the nature of the failure before returning this value.

Note

If a filter does not set the last error, the last error will be the error associated with the current thread. You can use GetLastError to see its value. If the last error is 0 or ERROR_IO_PENDING, ISA Server will treat the error as ERROR_INTERNAL_ERROR.

After the SF_STATUS_REQ_ERROR value is returned, the filter will continue to receive notifications.

If SetLastError is used with ERROR_ACCESS_DENIED, it causes the Web proxy to return a 405 Access Denied response. Otherwise, it will return a 50x response.

SF_STATUS_REQ_READ_NEXT

The complete request has not yet been received from the client or the Web server. The Web proxy should issue another read and notify the filter with the additional data.

SF_STATUS_REQ_READ_NEXT can only be returned for SF_NOTIFY_RECEIVE_RESPONSE_HEADERS notifications (for a response), or for SF_NOTIFY_READ_RAW_DATA and SF_NOTIFY_POLICY_CHECK_COMPLETED notifications (for a request). Also, it cannot be used for the request after the first SF_NOTIFY_FORWARD_RAW_DATA notification, that is, after the Web proxy has sent some data to the Web server.

Higher priority filters will only receive the additional data, whereas the filter that returns this value will receive both the initial data and the additional data.

Remarks

This function usually serves as the dispatch for a Web filter. Separate functions are often created to serve as handlers for the individual notifications, especially if the handling code is complicated.

At a minimum, a Web filter must implement either GetFilterVersion and HttpFilterProc, or GetWPXFilterVersion and HttpWPXFilterProc (or both pairs of functions).

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Wpxhttpfilt.h.

See Also

Entry-Point Functions


HttpWPXFilterProc(PHTTP_FILTER_CONTEXT,DWORD,VOID) function [ISA Server 2004]

HttpWPXFilterProc

The HttpWPXFilterProc function is called by the ISA Server Web proxy whenever an event for which the filter has registered in GetWPXFilterVersion occurs. The Web proxy uses this function to pass information and control to the Web filter. This function must be implemented together with GetWPXFilterVersion.

Information about notifications is provided in Event Notifications.

The declaration of HttpWPXFilterProc is:

DWORD WINAPI HttpWPXFilterProc(
  PHTTP_FILTER_CONTEXT pfc,
  DWORD NotificationType,
  VOID* pvNotification
);

Parameters

pfc
Pointer to the HTTP_FILTER_CONTEXT data structure that is associated with the current, active HTTP session.
NotificationType
Bitmask that indicates the type of notification event that is being processed. For a list of event-notification types, see Event Notifications.
pvNotification

Pointer to the notification-specific structure that contains more information about the current context of the request. You should cast this pointer to a pointer to the relevant notification structure according to the notification type, which is listed in the following table. For more information on the types of event notifications that are sent to Web filters, see Event Notifications.

Notification type | Notification structure
SF_NOTIFY_FORWARD_RAW_DATA | HTTP_FILTER_RAW_DATA
SF_NOTIFY_RECEIVE_RESPONSE_HEADERS | WPX_FILTER_PREPROC_HEADERS
SF_NOTIFY_RECEIVE_RESPONSE_RAW_DATA | HTTP_FILTER_RAW_DATA
SF_NOTIFY_ROUTING | WPX_FILTER_ROUTE

Note The SF_NOTIFY_FORWARD_RAW_DATA_COMPLETED notification does not have a corresponding structure. The pointer will contain a NULL value.

Return Values

Implementations of this function may return the following values to indicate how the event was handled.

SF_STATUS_REQ_NEXT_NOTIFICATION
The next filter in the notification chain should be called. Typically, unless your filter specifically needs to return one of the other values, it should return this value.
SF_STATUS_REQ_FINISHED
The filter handled the HTTP request. The server should disconnect the session.

Note After this value is returned, the filter will continue to receive notifications. At a minimum, the filter will receive SF_NOTIFY_END_OF_REQUEST and SF_NOTIFY_END_OF_NET_SESSION.

SF_STATUS_REQ_FINISHED_KEEP_CONN
Treated the same as SF_STATUS_REQ_FINISHED.
SF_STATUS_REQ_HANDLED_NOTIFICATION
This filter handled the notification. No other handlers should be called for this specific notification, and the next notification will be called.
SF_STATUS_REQ_ERROR
An error occurred. The HTTP request will be aborted when this status is returned. If no data has been sent, the server will send an error message to the client. The filter should call SetLastError with the nature of the failure before returning this value.

Note

If a filter does not set the last error, the last error will be the error currently associated with the current thread. You can use GetLastError to see its value. If the last error is 0 or ERROR_IO_PENDING, ISA Server will treat the error as ERROR_INTERNAL_ERROR.

After the SF_STATUS_REQ_ERROR value is returned, the filter will continue to receive notifications.

If SetLastError is used with ERROR_ACCESS_DENIED, it causes the Web proxy to return a 405 Access Denied response. Otherwise, it will return a 50x response.

SF_STATUS_REQ_READ_NEXT

The complete request has not yet been received from the client or the Web server. The Web proxy should issue another read and notify the filter with the additional data.

SF_STATUS_REQ_READ_NEXT can only be returned for SF_NOTIFY_RECEIVE_RESPONSE_HEADERS notifications (for a response), or for SF_NOTIFY_READ_RAW_DATA and SF_NOTIFY_POLICY_CHECK_COMPLETED notifications (for a request). Also, it cannot be used for a request after the first SF_NOTIFY_FORWARD_RAW_DATA notification, that is, after the Web proxy has sent some data to the Web server.

Higher priority filters will only receive the additional data, whereas the filter that returns this value will receive both the initial data and the additional data.

Remarks

This function usually serves as the dispatch for a Web filter. Separate functions are often created to serve as handlers for the separate notifications, especially if the handling code is complicated.

At a minimum, a Web filter must implement either GetFilterVersion and HttpFilterProc, or GetWPXFilterVersion and HttpWPXFilterProc (or both pairs of functions).

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Wpxhttpfilt.h.

See Also

Entry-Point Functions


ReloadWpxFilterConfiguration callback function [ISA Server 2004]

ReloadWpxFilterConfiguration

The ReloadWpxFilterConfiguration function receives a notification from the Web proxy that changes to the configuration of the ISA Server administration COM objects have been applied in a call to a Save method. You can use this function to perform operations to update the Web filter by reloading the saved configuration of the ISA Server administration COM objects from persistent storage.

Note The configuration used by the ISA Server services is only updated by the Save method when its fReloadConfiguration parameter is set to VARIANT_TRUE.

This function declaration is:

BOOL WINAPI ReloadWpxFilterConfiguration(void);

Parameters

This callback has no parameters.

Return Values

The implementation of this function should return TRUE if the filter is successfully updated with respect to changes in the stored ISA Server configuration or FALSE if reloading of any part of the configuration fails. If a failure occurs, the filter must call SetLastError with the nature of the failure before returning FALSE.

Remarks

ISA Server 2004 provides a new mechanism to enable filters to be updated when changes are made to objects in ISA Server storage. In ISA Server 2000, you would register your filter to receive notifications about changes to specific objects, but the filter had no means of indicating whether it had recognized the change. The new mechanism provides a means of indicating to the user whether changes were successfully applied (reloaded by the ISA Server services, application filters, and Web filters). If not, an event can be written to the event log.

A call to a Save method with the fReloadConfiguration parameter set to VARIANT_TRUE ensures only that configuration changes that can be applied dynamically take effect without restarting services. Changes that require restarting of the Firewall service are applied during a call to a Save method only if the fResetRequiredServices parameter is set to VARIANT_TRUE. For more information, see Restarting Services after Configuration Changes.

The Microsoft Firewall service notifies the Web proxy after it has reloaded the saved configuration with the most recent changes from persistent storage to the ISA Server services. The Web proxy then calls ReloadWpxFilterConfiguration in each registered Web filter after it has reloaded the most recent changes from persistent storage.

When this function returns FALSE, the Web proxy can pass the error back to the Firewall service. If the Save method was invoked because the user pressed the Apply button in ISA Server Management and the ReloadWpxFilterConfiguration method returns FALSE, the Firewall service will display a message to the user in ISA Server Management that the reload operation failed and will direct the user to look in the event log for details about the failure. When you implement this function in a Web filter, you should make sure that the filter writes the error code and a specific description in the event log with details about the part of the configuration that failed to reload.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Wpxhttpfilt.h.

See Also

Entry-Point Functions


TerminateFilter(DWORD) callback function [ISA Server 2004]

TerminateFilter

The TerminateFilter function indicates to the filter that it will be removed from memory. When this function is called, you should make sure that the filter closes any attachments it has made to system resources.

The TerminateFilter function is declared as:

BOOL WINAPI TerminateFilter(
  DWORD dwFlags
);

Parameters

dwFlags
No values for the dwFlags parameter have been identified at this time.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Wpxhttpfilt.h.

See Also

Entry-Point Functions


Callback Functions [ISA Server 2004]

Callback Functions

The ISA Server Web proxy implements the following new callback functions specific to ISA Server 2004:

  • AllocMemoryPerRequest
  • GetAuthSchemeStatus
  • SetADAuthenticatedUser
  • SetAuthenticatedUser
  • SetUserCachingKey
  • WPXSupportFunction
  • WriteServer

The ISA Server Web proxy also implements the following ISAPI callback functions:

  • AddHeader
  • AddResponseHeaders
  • AllocMem
  • GetHeader
  • GetServerVariable
  • GetUserToken
  • ServerSupportFunction
  • SetHeader
  • WriteClient


* AddHeader (3 Parameters) callback function [ISA Server 2004]

AddHeader

The AddHeader callback function adds an HTTP header to an incoming request after an SF_NOTIFY_PREPROC_HEADERS or SF_NOTIFY_AUTH_COMPLETE event notification, to an incoming response after an SF_NOTIFY_RECEIVE_RESPONSE_HEADERS notification, or to an outgoing response after an SF_NOTIFY_SEND_RESPONSE notification. For more information on the types of event notifications that are sent to Web filters, see Event Notifications.

The AddHeader callback function is declared as:

BOOL WINAPI * AddHeader(
  struct _HTTP_FILTER_CONTEXT* pfc,
  LPSTR lpszName ,
  LPSTR lpszValue
);

Parameters

pfc
Pointer to the HTTP_FILTER_CONTEXT data structure that is associated with the current, active HTTP session. Pass the filter context in this parameter.
lpszName
Pointer to a null-terminated string containing the name of the header to add. Header names should include the trailing colon (:). This parameter is not case-sensitive.
lpszValue
Pointer to a null-terminated string containing the new value to add to the header, or to \0 to add a header with an empty value.

Return Values

Returns TRUE if the function succeeded, or FALSE if the function failed.

Remarks

A pointer to this function is included as a member of the following structures:

  • HTTP_FILTER_AUTH_COMPLETE_INFO
  • HTTP_FILTER_PREPROC_HEADERS
  • HTTP_FILTER_SEND_RESPONSE
  • WPX_FILTER_PREPROC_HEADERS
  • WPX_HTTP_FILTER_AUTH_COMPLETE_INFO

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Wpxhttpfilt.h.

See Also

Callback Functions


* AddResponseHeaders (3 Parameters) callback function [ISA Server 2004]

AddResponseHeaders

The AddResponseHeaders callback function adds a header to the HTTP response, if the response was created by ISA Server.

The AddResponseHeaders callback function is declared as:

BOOL WINAPI * AddResponseHeaders(
  struct _HTTP_FILTER_CONTEXT* pfc,
  LPSTR lpszHeaders,
  LPSTR dwReserved
);

Parameters

pfc
Pointer to the HTTP_FILTER_CONTEXT data structure that is associated with the current, active HTTP session. Pass the filter context in this parameter.
lpszHeaders
Pointer to a null-terminated string containing a string that contains the headers to add. The string should be in the following format:
header1:value1\r\nheader2:value2\r\n
The string may contain one or more headers. Each header and value pair must be terminated by \r\n.
dwReserved
Reserved for future use. This must be zero.

Return Values

Returns TRUE if the function succeeded, or FALSE if the function failed.

Remarks

The AddResponseHeaders callback function can be used to add headers to responses for clients before the server processes the request, but not during or after SF_NOTIFY_ACCESS_DENIED or SF_NOTIFY_SEND_RESPONSE notifications. You can add a header when the SF_NOTIFY_SEND_RESPONSE notification occurs by using the AddHeader member of the HTTP_FILTER_SEND_RESPONSE structure.

Headers are added by AddResponseHeaders only for responses generated by ISA Server, such as error pages, where SF_NOTIFY_SEND_RESPONSE is triggered. Use SF_NOTIFY_SEND_RAW_DATA to add headers to all responses. For more information on the types of event notifications that are sent to Web filters, see Event Notifications.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Wpxhttpfilt.h.

See Also

Callback Functions


* AllocMem (3 Parameters) callback function [ISA Server 2004]

AllocMem

The AllocMem callback function is used to allocate memory from the process heap to a buffer. Any memory allocated by using this callback function will automatically be freed by the ISA Server Web proxy after the session ends (as indicated by the SF_NOTIFY_END_OF_NET_SESSION notification). If the memory cannot be allocated, this callback function returns NULL. For more information on the types of event notifications that are sent to Web filters, see Event Notifications.

The AllocMem callback function is declared as:

VOID* WINAPI * AllocMem(
  struct _HTTP_FILTER_CONTEXT* pfc,
  DWORD cbSize,
  DWORD dwReserved
);

Parameters

pfc
Pointer to the HTTP_FILTER_CONTEXT data structure that is associated with the current, active HTTP session. Pass the filter context in this parameter.
cbSize
Indicates the size of the buffer to be allocated, in bytes.
dwReserved
Reserved for use by the server.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Wpxhttpfilt.h.

See Also

Callback Functions


* AllocMemoryPerRequest (3 Parameters) callback function [ISA Server 2004]

AllocMemoryPerRequest

The AllocMemoryPerRequest callback function is used to allocate memory (from the process heap to a buffer) per request. Any memory allocated by using this function will automatically be freed by the ISA Server Web proxy at the end of the request (after the SF_NOTIFY_END_OF_REQUEST notification) even if the session continues. For more information on the types of event notifications that are sent to Web filters, see Event Notifications.

If the memory cannot be allocated, this function returns NULL.

The AllocMemoryPerRequest callback function is declared as:

VOID * WINAPI * AllocMemoryPerRequest(
  struct _HTTP_FILTER_CONTEXT* pfc,
  DWORD cbSize,
  DWORD dwReserved
);

Parameters

pfc
Pointer to the HTTP_FILTER_CONTEXT data structure that is associated with the current, active HTTP session. Pass the filter context in this parameter.
cbSize
Indicates the size of the buffer to be allocated, in bytes.
dwReserved
Reserved for use by the server.

Remarks

The AllocMemoryPerRequest function is called through a pointer that is a member of the WPX_FILTER_CONTEXT structure. To get a pointer to the WPX_FILTER_CONTEXT structure for calling the AllocMemoryPerRequest function, use the TO_WPX_FILTER_CONTEXT macro as follows:

WPX_FILTER_CONTEXT* pwfc = TO_WPX_FILTER_CONTEXT(pfc);
if (pwfc != NULL) {
...
}

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Wpxhttpfilt.h.

See Also

Callback Functions


* GetAuthSchemeStatus (3 Parameters) callback function [ISA Server 2004]

GetAuthSchemeStatus

The GetAuthSchemeStatus callback function returns the status (enabled or disabled) of a custom authentication scheme for the current listener. A Web filter that adds an authentication mechanism should use this function to determine if that scheme is enabled for the given request.

The GetAuthSchemeStatus callback function is declared as:

BOOL WINAPI * GetAuthSchemeStatus(
  struct _HTTP_FILTER_CONTEXT* pfc,
  LPSTR lpszAuthSchemeNamespace,
  BOOL* lpfStatus
);

Parameters

pfc
Pointer to the HTTP_FILTER_CONTEXT data structure that is associated with the current, active HTTP session. Pass the filter context in this parameter.
lpszAuthSchemeNamespace
Pointer to a null-terminated string containing the name of the authentication scheme. This parameter is not case-sensitive.
lpfStatus
[out] Pointer to a null-terminated string containing a Boolean value that will be set to TRUE if the scheme is enabled, or FALSE if not. This value is set upon the function's return.

Return Values

Returns TRUE if the function succeeded, or FALSE if the function failed.

Remarks

The GetAuthSchemeStatus function is called through a pointer that is a member of the WPX_FILTER_CONTEXT structure. To get a pointer to the WPX_FILTER_CONTEXT structure for callling the GetAuthSchemeStatus function, use the TO_WPX_FILTER_CONTEXT macro as follows:

WPX_FILTER_CONTEXT* pwfc = TO_WPX_FILTER_CONTEXT(pfc);
if (pwfc != NULL) {
...
}

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Wpxhttpfilt.h.

See Also

Callback Functions


* GetHeader (4 Parameters) callback function [ISA Server 2004]

GetHeader

The GetHeader callback function retrieves an HTTP header. The function retrieves a header for an incoming request after an SF_NOTIFY_PREPROC_HEADERS or SF_NOTIFY_AUTH_COMPLETE notification, for an incoming response after an SF_NOTIFY_RECEIVE_RESPONSE_HEADERS notification, and for an outgoing response after an SF_NOTIFY_SEND_RESPONSE notification. For more information on the types of event notifications that are sent to Web filters, see Event Notifications.

The GetHeader callback function is declared as:

BOOL WINAPI * GetHeader(
  struct _HTTP_FILTER_CONTEXT* pfc,
  LPSTR lpszName,
  LPVOID lpvBuffer,
  LPDWORD lpdwSize
);

Parameters

pfc
Pointer to the HTTP_FILTER_CONTEXT data structure that is associated with the current, active HTTP session. Pass the filter context in this parameter.
lpszName

Pointer to a null-terminated string containing the name of the header to retrieve. Header names should include the trailing colon (:). This parameter is not case-sensitive.

The special values "method", "url", "version", and "body" (for requests only) can be used to retrieve individual portions of the request line. When the value "body" is specified, the function retrieves the part of the body that has already been received.

The special value "status" can be used to retrieve the status from the response line.

Note that the special values do not include a trailing colon.

lpvBuffer
Pointer to a buffer of size lpdwSize for receiving the header requested.
lpdwSize
The size of the buffer. This should be set to the size of the buffer specified in lpvBuffer, for example, sizeof(achBuffer). After the call, it contains the number of bytes retrieved including the null terminator. Therefore, for retrieved strings, it is equal to strlen(lpvBuffer) + 1.

Return Values

This callback function returns TRUE if the call is successful; otherwise, it returns FALSE.

Remarks

A pointer to this function is included as a member of the following structures:

  • HTTP_FILTER_AUTH_COMPLETE_INFO
  • HTTP_FILTER_PREPROC_HEADERS
  • HTTP_FILTER_SEND_RESPONSE
  • WPX_FILTER_PREPROC_HEADERS
  • WPX_HTTP_FILTER_AUTH_COMPLETE_INFO

If the header is larger than the buffer size specified in the lpdwSize parameter, the function will fail. In that case GetLastError will return ERROR_INSUFFICIENT_BUFFER and lpdwSize will contain the required buffer size.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Wpxhttpfilt.h.

See Also

Callback Functions


* GetServerVariable (4 Parameters) callback function [ISA Server 2004]

GetServerVariable

The GetServerVariable callback function retrieves information about the server and this connection. For some notifications, some variables might not be defined. For example, the AUTH_TYPE variable might not be defined before an SF_NOTIFY_AUTHENTICATION notification. For more information on the types of event notifications that are sent to Web filters, see Event Notifications.

The GetServerVariable callback function is declared as:

BOOL WINAPI * GetServerVariable(
  struct _HTTP_FILTER_CONTEXT* pfc,
  LPSTR lpszVariableName,
  LPVOID lpvBuffer,
  LPDWORD lpdwSizeofBuffer
);

Parameters

pfc
Pointer to the HTTP_FILTER_CONTEXT data structure that is associated with the current, active HTTP session. Pass the filter context in this parameter.
lpszVariableName
Pointer to a null-terminated string that indicates which variable is requested. The Remarks section lists possible variables. In addition to the listed variables, any system environment variable can be requested, and any HTTP header can be requested by adding HTTP_ to its name (such as HTTP_HOST). Variables supported by ISA Server 2004 are presented in this table, along with a description of the information that is retrieved when the variable is specified.
lpvBuffer
Pointer to a buffer for receiving the requested information.
lpdwSizeofBuffer
Pointer to a DWORD that indicates the size of the buffer pointed to by the lpvBuffer parameter. On successful completion, the DWORD contains the number of bytes transferred into the buffer, including the null-terminating byte. If the function fails because the buffer is not large enough, the DWORD contains the size needed.

Return Values

If the function succeeds, the return value is TRUE. If the function fails, the return value is FALSE. The GetLastError function can be used to determine why the call failed. The following are possible error values.

ERROR_INVALID_PARAMETER
Invalid values in either lpszVariableName or lpdwSizeofBuffer.
ERROR_INVALID_INDEX
Invalid or unsupported variable identifier.
ERROR_INSUFFICIENT_BUFFER
Buffer too small. The required buffer size is *lpdwSizeofBuffer
ERROR_NO_DATA
The data requested is not available.

Remarks

The following are possible values for the lpszVariableName parameter.

ALL_HTTP
All HTTP headers that were received. These headers are of the form HTTP_header_field_name. The headers consist of a null-terminated string with the individual headers separated by line feeds. This value is invalid for SF_NOTIFY_ACCESS_DENIED, SF_NOTIFY_SEND_RESPONSE, SF_NOTIFY_END_OF_REQUEST, SF_NOTIFY_LOG , and SF_NOTIFY_END_OF_NET_SESSION notifications. In these cases, incorrect or partial data may be retrieved.
ALL_RAW
All headers in raw form. The header names and values appear as they are sent by the client. This value is invalid for SF_NOTIFY_ACCESS_DENIED, SF_NOTIFY_SEND_RESPONSE, SF_NOTIFY_END_OF_REQUEST, SF_NOTIFY_LOG , and SF_NOTIFY_END_OF_NET_SESSION notifications. In these cases, incorrect or partial data may be retrieved.
AUTH_PASSWORD
The password that is used for Basic authentication.
AUTH_TYPE
The type of authentication used. Possible values are Basic, Digest, Kerberos, NTLM, and RADIUS. An empty string indicates that no authentication is used. If authentication fails, the content of the AUTH_TYPE variable is meaningless.
AUTH_USER
The user name used for authentication.
CERT_COOKIE
A unique identifier (ID) for a client certificate. Retrieved as a string. Can be used as a signature for the entire client certificate.
CERT_FLAGS
Information about the client certificate. If bit 0 is set to 1, a client certificate is present. If bit 1 is set to 1, the certification authority (CA) of the client certificate is invalid; that is, it is not on this server's list of recognized CAs. This is a text value that must be converted to a numeric value. If the client connects using an SSL connection that does not require a client certificate, the value retrieved is an empty string.
CERT_ISSUER
The issuer field of the client certificate. For example, the codes might be O=MS, OU=IAS, CN=user name, or C=USA.
CERT_KEYSIZE
The number of bits in the SSL connection key size.
CERT_CONTEXT
A pointer to the client certificate CERT_CONTEXT structure. The following snippet demonstrates how to use this value.
PCERT_CONTEXT pCtxt = NULL;
DWORD dwSize = sizeof(PCERT_CONTEXT);
BOOL fOK = pfc->GetServerVariable(pfx, "CERT_CONTEXT", &pCtxt, &dwSize);
If (fOK == TRUE && pCtxt != NULL) {
      ...
}
CERT_SECRETKEYSIZE
The number of bits in the server certificate private key.
CERT_SERIALNUMBER
The serial-number field of the client certificate.
CERT_SERVER_ISSUER
The issuer field of the server certificate.
CERT_SERVER_SUBJECT
The subject field of the server certificate.
CERT_SUBJECT
The subject field of the client certificate.
CONTENT_LENGTH
The value of the request content length header, or 0 if it does not exist.
CONTENT_TYPE
The content type of the information supplied in the body of a request.
DEFAULT_DOMAIN
The default domain for authentication of the listener for the current session.
FILTERS_GUID
The current Web filter's GUID.
GATEWAY_INTERFACE
Returns CGI/1.1.
LOGON_USER
The Windows account that the user is logged on to.
HTTP_HOST
The contents of the HTTP Host header. This value is invalid for SF_NOTIFY_ACCESS_DENIED, SF_NOTIFY_SEND_RESPONSE, SF_NOTIFY_END_OF_REQUEST, SF_NOTIFY_LOG , and SF_NOTIFY_END_OF_NET_SESSION notifications. In these cases, incorrect or partial data may be retrieved.
HTTP_PROXY_URL
The request URL.
HTTP_REQ_REALM
The Web proxy realm for Basic and Digest authentication.
HTTPS
A string containing On if the request came in through a secure channel (with SSL encryption), or Off if the request is for an unsecure channel.
HTTPS_##CertProperty
The value stored in the client certificate CertProperty property.
HTTPS_KEYSIZE
The number of bits in the SSL connection key size.
HTTPS_SECRETKEYSIZE
The number of bits in the server certificate private key.
HTTPS_SERVER
A string containing On if the server response came in through a secure channel (with SSL encryption), or Off if the response came in through an unsecure channel.
HTTPS_SERVER_ISSUER
The issuer field of the server certificate.
HTTPS_SERVER_SUBJECT
The subject field of the server certificate.
IS_FROM_CACHE
A string containing 0 (false) or 1 (true), indicating whether the response is provided from the cache. This value is invalid for SF_NOTIFY_END_OF_REQUEST and SF_NOTIFY_LOG notifications. In these cases, 0 is always retrieved.
IS_PROXY_ORIGINATED_RESPONSE
A string containing 0 (false) or 1 (true). If true, the response was created by the Web proxy. This includes responses such as error pages, Web Proxy Auto-Discovery responses, or script-generated responses.
IS_REVERSE_PROXY
A string containing TRUE or FALSE, indicating if the request is a forward proxy or reverse proxy request.
LISTENER_GUID
The GUID of the Web listener for the current session.
LOCAL_ADDR
A string containing the local IP address.
QUERY_STRING
Not supported in ISA Server; the value retrieved is always an empty string.
REMOTE_ADDR
The IP address of the client or agent of the client (for example gateway, proxy, or firewall) that sent the request.
REMOTE_HOST
The host name of the client or agent of the client (for example, gateway, proxy, or firewall) that sent the request if reverse Domain Name System (DNS) is enabled. Otherwise, this value is set to the IP address specified by REMOTE_ADDR.
REMOTE_PORT
The port of the client or agent of the client (for example, gateway, proxy, or firewall) that sent the request.
REMOTE_USER
The user name supplied by the client and authenticated by the server. An empty string is retrieved when the user is anonymous.
REQUEST_METHOD
The HTTP request method verb.
REVERSE_PROXY
A value of 0 (false) or 1 (true), indicating if the request is a forward proxy or reverse proxy request.
ROUTING
A string containing DIRECT, UPSTREAM, or REDIRECT, depending on the selected routing rule.
SCRIPT_NAME
Not supported in ISA Server; w3proxy.dll is always retrieved.
SELECTED_RULE_GUID
The GUID of the selected policy rule.
SERVER_##CertProperty
The value stored in the server certificate CertProperty property.
SERVER_HTTPS_##CertProperty
The value stored in the server certificate CertProperty property.
SERVER_NAME
The server's host name, or IP address, as it should appear in self-referencing URLs.
SERVER_PORT
The TCP/IP port on which the request was received.
SERVER_PORT_SECURE
A string containing either 0 or 1. If the request is being handled on the secure port, this will be 1. Otherwise, it will be 0.
SERVER_PORT_SECURE_SERVER
A string containing either 0 (false) or 1 (true). If the server-side request is being handled by the server on the secure port, this will be 1. Otherwise, it will be 0.
SERVER_PROTOCOL
The name and version of the information retrieval protocol relating to the request.
SERVER_SOFTWARE
A string containing Microsoft-ISA Server/4.0.
URL
The request URL (after the request has been parsed). HTTP_PROXY_URL will also return this value.
USER_CACHING_KEY
The user caching key as set by the SetUserCachingKey function.
WEB_ROUTING_RULE
The routing rule's GUID.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Wpxhttpfilt.h.

See Also

Callback Functions


* GetUserToken (2 Parameters) callback function [ISA Server 2004]

GetUserToken

The GetUserToken callback function is used to get an impersonation token of the authenticated user.

The GetUserToken callback function is declared as:

BOOL WINAPI * GetUserToken(
  struct _HTTP_FILTER_CONTEXT* pfc,
  HANDLE* phToken
);

Parameters

pfc
Pointer to the HTTP_FILTER_CONTEXT data structure that is associated with the current, active HTTP session. Pass the filter context in this parameter.
phToken
Pointer to the token handle.

Return Values

Returns TRUE if the function succeeded, or FALSE if the function failed.

Remarks

When you invoke GetUserToken you must call the CloseHandle function to prevent handle leaks.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Wpxhttpfilt.h.

See Also

Callback Functions


* SetADAuthenticatedUser (4 Parameters) callback function [ISA Server 2004]

SetADAuthenticatedUser

The SetADAuthenticatedUser callback function is used by Web filters to set the authenticated Windows user. This enables associating authenticated user information with the current request.

The SetADAuthenticatedUser callback function is declared as:

BOOL WINAPI * SetADAuthenticatedUser(
  struct _HTTP_FILTER_CONTEXT* pfc,
  LPSTR lpszUserName ,
  LPSTR lpszPassword ,
  HANDLE hToken
);

Parameters

pfc
Pointer to the HTTP_FILTER_CONTEXT data structure that is associated with the current, active HTTP session. Pass the filter context in this parameter.
lpszUserName
Pointer to a null-terminated string containing the user name.
lpszPassword
Pointer to a null-terminated string containing the user password.
hToken
Pointer to the token handle.

Return Values

Returns TRUE if the function succeeded, or FALSE if the function failed.

Remarks

The user token is received using the Security Support Provider Interface (SSPI) layer.

If there is a token, there is no need to pass the password. However, if the token field is NULL, you should provide the password. The user name must be provided if there is a token or if the token field is NULL.

After you provide the token handle to the function, you should close the token handle to prevent handle leaks.

Web filters call the SetADAuthenticatedUser function through a pointer that is a member of the WPX_FILTER_AUTHENT_EX structure. A pointer to this structure is passed in each call to the HttpFilterProc entry-point function when the Web proxy sends an SF_NOTIFY_AUTHENTICATION notification to the Web filters that are registered to receive this notification just before ISA Server authenticates a client. If the fAuthIsRequired member of the WPX_FILTER_AUTHENT_EX structure is set to FALSE, the call to SetADAuthenticatedUser succeeds, but the user specified is not set as an authenticated user.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Wpxhttpfilt.h.

See Also

Callback Functions


* SetAuthenticatedUser (4 Parameters) callback function [ISA Server 2004]

SetAuthenticatedUser

The SetAuthenticatedUser callback function is used by Web filters to set an authenticated non-Windows user. This allows associating authenticated user information with the current request.

The SetAuthenticatedUser callback function is declared as:

BOOL WINAPI * SetAuthenticatedUser(
  struct _HTTP_FILTER_CONTEXT* pfc,
  LPSTR lpszUserName ,
  LPSTR lpszNameSpace ,
  LPSTR lpszUserGroups
);

Parameters

pfc
Pointer to the HTTP_FILTER_CONTEXT data structure that is associated with the current, active HTTP session. The filter context is passed in this parameter.
lpszUserName
Pointer to a null-terminated string containing the user name.
lpszNameSpace
Pointer to a null-terminated string containing the namespace of the authentication scheme for the user, as specified in IFPCAuthenticationScheme.

Note The server variables AUTH_USER, REMOTE_USER, LOGON_USER (described in GetServerVariable) do not contain the namespace when using SetAuthenticatedUser. These variables contain only the user name. The AUTH_TYPE variable contains the name of the custom authentication scheme, which should have the same name as the namespace. The authentication scheme can also be retrieved from the Web listener. Note that there can only be one extensible authentication scheme.

lpszUserGroups
Pointer to a null-terminated string containing the user groups.

Return Values

Returns TRUE if the function succeeded, or FALSE if the function failed.

Remarks

The filter should check whether the authentication scheme specified in the lpszNameSpace parameter is enabled by calling GetAuthSchemeStatus, before passing a user of this authentication scheme.

Both the lpszUserName and lpszNameSpace parameters are required. If the string supplied in lpszNameSpace is longer than UNLEN characters, the function will fail. UNLEN is defined in Lmcons.h.

The lpszUserGroups parameter is optional. It enables the administrator to create a broader rule. For example, an administrator could set a rule for MyAuthScheme\MyAdministrators. Then the Web filter implementing MyAuthScheme could pass a specific user name, indicating that the user is a member of MyAdministrators, and the user will match the rule.

The string supplied in lpszUserGroups can be a comma-separated list of user groups.

Web filters call the SetAuthenticatedUser function through a pointer that is a member of the WPX_FILTER_AUTHENT_EX structure. A pointer to this structure is passed in each call to the HttpFilterProc entry-point function when the Web proxy sends an SF_NOTIFY_AUTHENTICATION notification to the Web filters that are registered to receive this notification just before ISA Server authenticates a client. If the fAuthIsRequired member of the WPX_FILTER_AUTHENT_EX structure is set to FALSE, the call to SetAuthenticatedUser succeeds, but the user specified is not set as an authenticated user.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Wpxhttpfilt.h.

See Also

Callback Functions


* SetHeader (3 Parameters) callback function [ISA Server 2004]

SetHeader

The SetHeader callback function is used by Web filters to modify or delete the value of a header or to add a new header. The function can also be used to modify the special values included in the request or status line.

The SetHeader callback function is declared as:

BOOL WINAPI * SetHeader(
  struct _HTTP_FILTER_CONTEXT* pfc,
  LPSTR lpszName ,
  LPSTR lpszValue
);

Parameters

pfc
Pointer to the HTTP_FILTER_CONTEXT data structure that is associated with the current, active HTTP session. Pass the filter context in this parameter.
lpszName

Pointer to a null-terminated string containing the name of the header to modify or delete. Header names should include the trailing colon (:). This parameter is not case-sensitive.

The special values "method", "url", "version", and "body" (for requests only) can be used to set individual portions of the request line. When the value "body" is specified, the function sets the part of the body that has already been received.

The special value "status" can be used to set the status in the response line.

Note that the special values do not include a trailing colon.

lpszValue
Pointer to a null-terminated string containing the new string for the header, or to \0 (if the header is to be deleted).

Return Values

This callback function returns TRUE if the call is successful; otherwise, it returns FALSE.

Remarks

A pointer to this function is included as a member of the following structures:

  • HTTP_FILTER_AUTH_COMPLETE_INFO
  • HTTP_FILTER_PREPROC_HEADERS
  • HTTP_FILTER_SEND_RESPONSE
  • WPX_FILTER_PREPROC_HEADERS
  • WPX_HTTP_FILTER_AUTH_COMPLETE_INFO

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Wpxhttpfilt.h.

See Also

Callback Functions


* SetUserCachingKey (2 Parameters) callback function [ISA Server 2004]

SetUserCachingKey

The SetUserCachingKey callback function is used by Web filters to set the user caching key. The user caching key is the key that the request will be cached with. This key is used to check if the given request is in the cache, so there is no need to pass the request to the server. The key is also used to cache the server response after it arrives. The URL of the request is used as the default cache key.

The SetUserCachingKey callback function is declared as:

BOOL WINAPI * SetUserCachingKey(
  struct _HTTP_FILTER_CONTEXT* pfc,
  LPSTR lpszCacheKey
);

Parameters

pfc
Pointer to the HTTP_FILTER_CONTEXT data structure that is associated with the current, active HTTP session. Pass the filter context in this parameter.
lpszCacheKey
Pointer to a null-terminated string containing the new caching key.

Return Values

Returns TRUE if the function succeeded, or FALSE if the function failed.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Wpxhttpfilt.h.

See Also

Callback Functions


ServerSupportFunction [ISA Server 2004]

ServerSupportFunction

The ServerSupportFunction callback function extends the Web filter functions. Parameters are specific to the extensions. The ServerSupportFunction callback function can be used by Web filters to accomplish a wide variety of tasks.

The ServerSupportFunction callback function is declared as:

BOOL WINAPI * ServerSupportFunction(
  struct _HTTP_FILTER_CONTEXT pfc,
  enum SF_REQ_TYPE sfReq,
  PVOID pData,
  DWORD ul1,
  DWORD ul2
);

The parameter sfReq specifies the particular support function that is to be executed by the ISA Server Web filter. The remaining parameters are described in the individual support function sections. See the following list:

SF_REQ_ADD_HEADERS_ON_DENIAL

SF_REQ_DISABLE_NOTIFICATIONS

SF_REQ_NORMALIZE_URL

SF_REQ_SEND_RESPONSE_HEADER

SF_REQ_SET_NEXT_READ_SIZE

Note

If a parameter is designated as unused for a particular support function, you should set the parameter to NULL or 0, as appropriate.

SF_REQ_GET_CONNID is not supported by ISA Server or by Internet Information Services (IIS) 4.0 or later and will return 0.

SF_REQ_GET_PROPERTY is not supported by ISA Server and will return 0.

SF_REQ_SET_PROXY_INFO is not used in the ISA Server implementation of ISAPI.

SF_REQ_SET_NEXT_READ_SIZE is not relevant to the implementation of ISAPI in ISA Server. It is provided for compatibility with IIS.

For more information about the types of event notifications that are sent to Web filters, see Event Notifications.

See Also

Callback Functions


SF_REQ_ADD_HEADERS_ON_DENIAL (5 Parameters) callback function [ISA Server 2004]

SF_REQ_ADD_HEADERS_ON_DENIAL

The SF_REQ_ADD_HEADERS_ON_DENIAL form of the ServerSupportFunction callback function allows your Web filter to add specified headers to the server error response, in the event that the HTTP request is denied because authentication failed. This allows an authentication filter to advertise its services without filtering every request.

Note This support function will not work properly if called during or after the processing of SF_NOTIFY_SEND_RESPONSE or SF_NOTIFY_ACCESS_DENIED notifications.

BOOL WINAPI * ServerSupportFunction(
  struct _HTTP_FILTER_CONTEXT* pfc,
  enum SF_REQ_TYPE sfReq,
  PVOID pData,
  DWORD ul1,
  DWORD ul2
);

Parameters

pfc
Pointer to the HTTP_FILTER_CONTEXT data structure that is associated with the current, active HTTP session. Pass the filter context in this parameter.
sfReq
Specifies the particular support function that is to be executed by the ISA Server Web filter, in this case, SF_REQ_ADD_HEADERS_ON_DENIAL.
pData
Pointer to a null-terminated string that specifies one or more HTTP header lines. Each header should be terminated with a carriage return and line feed.
ul1
Unused in this support function.
ul2
Unused in this support function.

Return Values

Returns TRUE if the function succeeded, or FALSE if the function failed.

Remarks

Generally, the HTTP headers should be Proxy-Authenticate headers (forward proxy) or WWW-Authenticate headers (reverse proxy) that specify custom authentication schemes. However, no restriction is placed on which headers can be specified.

The headers are added only for a 401 response in a reverse proxy scenario or a 407 response in a forward proxy scenario.

For more information about the types of event notifications that are sent to Web filters, see Event Notifications.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Wpxhttpfilt.h.

See Also

ServerSupportFunction


SF_REQ_DISABLE_NOTIFICATIONS (5 Parameters) callback function [ISA Server 2004]

SF_REQ_DISABLE_NOTIFICATIONS

The SF_REQ_DISABLE_NOTIFICATIONS form of the ServerSupportFunction callback function can be used to disable specific notification types for your Web filter for the remaining lifetime of that request. If a particular notification event is disabled for your filter, the ISA Server Web server will not call your filter when that notification event occurs.

New requests will generate the notifications for which your filter registered when it was loaded.

BOOL WINAPI * ServerSupportFunction(
  struct _HTTP_FILTER_CONTEXT* pfc,
  enum SF_REQ_TYPE sfReq,
  PVOID pData,
  DWORD ul1,
  DWORD ul2
);

Parameters

pfc
Pointer to the HTTP_FILTER_CONTEXT data structure that is associated with the current, active HTTP session. Pass the filter context in this parameter.
sfReq
Specifies the particular support function that is to be executed by the ISA Server Web filter, in this case, SF_REQ_DISABLE_NOTIFICATIONS.
pData
Unused in this support function.
ul1
Contains flags, listed in the Remarks section, that indicate which notification types are to be disabled.
ul2
Unused in this support function.

Return Values

Returns TRUE if the function succeeded, or FALSE if the function failed.

Remarks

This callback function disables the following notifications:

  • SF_NOTIFY_READ_RAW_DATA
  • SF_NOTIFY_PREPROC_HEADERS
  • SF_NOTIFY_AUTHENTICATION
  • SF_NOTIFY_URL_MAP
  • SF_NOTIFY_ACCESS_DENIED
  • SF_NOTIFY_SEND_RESPONSE
  • SF_NOTIFY_SEND_RAW_DATA
  • SF_NOTIFY_LOG
  • SF_NOTIFY_END_OF_REQUEST
  • SF_NOTIFY_END_OF_NET_SESSION
  • SF_NOTIFY_AUTH_COMPLETE

For more information about the types of event notifications that are sent to Web filters, see Event Notifications.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Wpxhttpfilt.h.

See Also

ServerSupportFunction


SF_REQ_NORMALIZE_URL (5 Parameters) callback function [ISA Server 2004]

SF_REQ_NORMALIZE_URL

The SF_REQ_NORMALIZE_URL form of the ServerSupportFunction callback function can be used to normalize the URL. Normalization includes decoding hex codes, removing illegal characters, and handling some internationalization conversions.

BOOL WINAPI * ServerSupportFunction(
  struct _HTTP_FILTER_CONTEXT* pfc,
  enum SF_REQ_TYPE sfReq,
  PVOID pData,
  DWORD ul1,
  DWORD ul2
);

Parameters

pfc
Pointer to the HTTP_FILTER_CONTEXT data structure that is associated with the current, active HTTP session. Pass the filter context in this parameter.
sfReq
Specifies the particular support function that is to be executed by the ISA Server Web filter, in this case, SF_REQ_NORMALIZE_URL.
pData
Pointer to a buffer containing a null-terminated string that specifies the URL to normalize.
ul1
Unused in this support function.
ul2
Unused in this support function.

Return Values

Returns TRUE if the function succeeded, or FALSE if the function failed.

Remarks

For more information about the types of event notifications that are sent to Web filters, see Event Notifications.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Wpxhttpfilt.h.

See Also

ServerSupportFunction


SF_REQ_SEND_RESPONSE_HEADER (5 Parameters) callback function [ISA Server 2004]

SF_REQ_SEND_RESPONSE_HEADER

The SF_REQ_SEND_RESPONSE_HEADER form of the ServerSupportFunction callback function can be used to request that the ISA Server Web proxy send a complete HTTP response header to the client browser, including the HTTP status, server version, and message time. Your filter can also, optionally, append other header information to the end of a header generated by the Web proxy, such as a Content-Type or Content-Length header.

BOOL WINAPI * ServerSupportFunction(
  struct _HTTP_FILTER_CONTEXT* pfc,
  enum SF_REQ_TYPE sfReq,
  PVOID pData,
  DWORD ul1,
  DWORD ul2
);

Parameters

pfc
Pointer to the HTTP_FILTER_CONTEXT data structure that is associated with the current, active HTTP session. Pass the filter context in this parameter.
sfReq
Specifies the particular support function that is to be executed by the ISA Server Web filter, in this case, SF_REQ_SEND_RESPONSE_HEADER.
pData
Points to a null-terminated string that contains an HTTP status string, such as 401 Access Denied. If pData is set to NULL, the default response, 200 OK, will be sent in the response header.
ul1
Points to an optional null-terminated string that contains the headers to add. The string should be in the following format:
header1:value1\r\nheader2:value2\r\n\r\n
The string may contain one or more headers. Each header and value pair must be terminated by an extra \r\n.
ul2
Unused in this support function.

Return Values

Returns TRUE if the function succeeded, or FALSE if the function failed.

Remarks

If you append your own headers to the server-generated headers, you must terminate the header string with an extra carriage return and linefeed.

This support function can be called only once for each HTTP request.

After using this function, the filter should use WriteClient to send any other information, and then use the SF_STATUS_REQ_FINISHED return value to terminate the request.

A Web filter may cause a recursive call of itself or a simple call of another Web filter inside itself. This may occur if a Web filter sends a response by using either ServerSupportFunction (SF_REQ_SEND_RESPONSE_HEADER) or WriteClient.

Consider two cases:

  • The call was from a RAW_DATA notification, either READ_RAW_DATA or SEND_RAW_DATA.
  • The call was from any other notification (non-RAW_DATA).

After this function is used, all filters that are registered for the SF_NOTIFY_SEND_RESPONSE notification will receive that notification.

If the call was from a RAW_DATA notification, only filters with higher order than the filter that sent the response will be called in the SEND_RAW_DATA notification.

If the call was from any other notification, the filter that sent the response and the filters with higher order will be called in the SEND_RAW_DATA notification.

For example, suppose you have three filters: Filter_Low with low priority, Filter_Medium with medium priority, and Filter_High with high priority. Filter_Low and Filter_High subscribed to SEND_RESPONSE and SEND_RAW_DATA. Filter_Medium subscribed to SEND_RESPONSE and SEND_RAW_DATA as well, but also subscribed to another notification.

From its extra notification, Filter_Medium sends either ServerSupportFunction (SF_REQ_SEND_RESPONSE_HEADER) or WriteClient.

ISA Server will call the filters before the ServerSupportFunction (SF_REQ_SEND_RESPONSE_HEADER) or WriteClient complete, as follows:

  • If ServerSupportFunction (SF_REQ_SEND_RESPONSE_HEADER) or WriteClient is sent from a raw data notification, only Filter_High will receive the SF_NOTIFY_SEND_RAW_DATA notification.
  • If ServerSupportFunction (SF_REQ_SEND_RESPONSE_HEADER) or WriteClient is sent from a non-raw data notification, both Filter_Medium and Filter_High will receive SF_NOTIFY_SEND_RAW_DATA, but Filter_Low will not receive the SF_NOTIFY_SEND_RAW_DATA notification.
  • If ServerSupportFunction (SF_REQ_SEND_RESPONSE_HEADER) is sent from any notification, all filters that subscribed to SF_NOTIFY_SEND_RESPONSE will receive the SF_NOTIFY_SEND_RESPONSE notification, including Filter_Low.

For more information about the types of event notifications that are sent to Web filters, see Event Notifications.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Wpxhttpfilt.h.

See Also

ServerSupportFunction


SF_REQ_SET_NEXT_READ_SIZE (5 Parameters) callback function [ISA Server 2004]

SF_REQ_SET_NEXT_READ_SIZE

The SF_REQ_SET_NEXT_READ_SIZE form of the ServerSupportFunction callback function is used by raw-read Web filters to set the number of bytes that will be read during the next read event.

BOOL WINAPI * ServerSupportFunction(
  struct _HTTP_FILTER_CONTEXT* pfc,
  enum SF_REQ_TYPE sfReq,
  PVOID pData,
  DWORD ul1,
  DWORD ul2
);

Parameters

pfc
Pointer to the HTTP_FILTER_CONTEXT data structure that is associated with the current, active HTTP session. Pass the filter context in this parameter.
sfReq
Specifies the particular support function that is to be executed by the ISA Server Web filter, in this case, SF_REQ_SET_NEXT_READ_SIZE.
pData
Unused in this support function.
ul1
Specifies the maximum size, in bytes, that will be read during the next read event.
ul2
Unused in this support function.

Return Values

Returns TRUE if the function succeeded, or FALSE if the function failed.

Remarks

This support function is meaningful only for filters that respond to raw-read notifications and that return the status code SF_STATUS_REQ_READ_NEXT from their entry-point function HttpFilterProc.

This support function is not relevant to the implementation of ISAPI in ISA Server. It is provided for compatibility with Internet Information Services (IIS). If you use it in an ISA Server Web filter, you should not assume that the number of bytes read during the subsequent read operation will not exceed the value set in the ul1 parameter.

For more information about the types of event notifications that are sent to Web filters, see Event Notifications.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Wpxhttpfilt.h.

See Also

ServerSupportFunction


WPXSupportFunction [ISA Server 2004]

WPXSupportFunction

The WPXSupportFunction callback function extends the Web filter functions. Parameters are specific to the extensions.

The WPXSupportFunction callback function is declared as:

BOOL (WINAPI * WPXSupportFunction) (
    struct _HTTP_FILTER_CONTEXT *   pfc,
    enum SF_WPX_REQ_TYPE            sfReq,
    PVOID                           pData,
    ULONG_PTR                       ul1,
    ULONG_PTR                       ul2
);

The parameter sfReq specifies the particular support function that is to be executed by the ISA Server Web filter. The remaining parameters are described in the individual support function sections. See the following list:

SF_REQ_DISABLE_WPX_NOTIFICATIONS

For more information about the types of event notifications that are sent to Web filters, see Event Notifications.

Note If a parameter is designated as unused for a particular support function, you should set the parameter to NULL or 0, as appropriate.

See Also

Callback Functions


SF_REQ_DISABLE_WPX_NOTIFICATIONS callback function [ISA Server 2004]

SF_REQ_DISABLE_WPX_NOTIFICATIONS

The SF_REQ_DISABLE_WPX_NOTIFICATIONS form of the WPXSupportFunction callback function can be used to disable notification types specific to ISA Server 2004 for your Web filter for the remaining lifetime of a request. If a particular notification event is disabled for your filter, the ISA Server Web proxy will not call your filter when that notification event occurs.

This function does not affect new requests, even in the same session.

BOOL WINAPI * ServerSupportFunction(
  struct _HTTP_FILTER_CONTEXT* pfc,
  enum SF_REQ_TYPE sfReq,
  PVOID pData,
  DWORD ul1,
  DWORD ul2
);

Parameters

pfc
Pointer to the HTTP_FILTER_CONTEXT data structure that is associated with the current, active HTTP session. Pass the filter context in this parameter.
sfReq
Specifies the particular support function that is to be executed by the ISA Web filter, in this case, SF_REQ_DISABLE_WPX_NOTIFICATIONS.
pData
Unused in this support function.
ul1
Contains flags, listed in the Remarks section, that indicate which notification types are to be disabled.
ul2
Unused in this support function.

Return Values

Returns TRUE if the function succeeded, or FALSE if the function failed.

Remarks

This callback function disables the following notifications:

  • SF_NOTIFY_FORWARD_RAW_DATA
  • SF_NOTIFY_FORWARD_RAW_DATA_COMPLETED
  • SF_NOTIFY_RECEIVE_RESPONSE_HEADERS
  • SF_NOTIFY_RECEIVE_RESPONSE_RAW_DATA
  • SF_NOTIFY_ROUTING
  • SF_NOTIFY_POLICY_CHECK_COMPLETED

The WPXSupportFunction function is called through a pointer that is a member of the WPX_FILTER_CONTEXT structure. To get a pointer to the WPX_FILTER_CONTEXT structure for calling the WPXSupportFunction function, use the TO_WPX_FILTER_CONTEXT macro as follows:

WPX_FILTER_CONTEXT* pwfc = TO_WPX_FILTER_CONTEXT(pfc);
if (pwfc != NULL) {
...
}
For more information about the types of event notifications that are sent to Web filters, see Event Notifications.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Wpxhttpfilt.h.

See Also

WPXSupportFunction


* WriteClient (4 Parameters) callback function [ISA Server 2004]

WriteClient

The WriteClient callback function is called by a Web filter to send data to the client.

The WriteClient callback function is declared as:

BOOL WINAPI * WriteClient(
  struct _HTTP_FILTER_CONTEXT* pfc,
  LPVOID Buffer,
  LPDWORD lpdwBytes,
  DWORD dwReserved
);

Parameters

pfc
Pointer to the HTTP_FILTER_CONTEXT data structure that is associated with the current, active HTTP session. Pass the filter context in this parameter.
Buffer
Pointer to a buffer containing data to send to the client.
lpdwBytes
Pointer to the size of the buffer pointed to by the Buffer parameter.
dwReserved
Reserved for future use.

Return Values

Returns TRUE if the function succeeded, or FALSE if the function failed.

Remarks

For more information about the correct usage of WriteClient, see SF_REQ_SEND_RESPONSE_HEADER.

The WriteClient callback function is synchronous and and blocks the thread from which it is called until the IO operation is completed. A Web filter sending a large amount of data in calls to this function can block all of the available worker threads with a resultant denial of service (DoS).

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Wpxhttpfilt.h.

See Also

Callback Functions


* WriteServer (4 Parameters) callback function [ISA Server 2004]

WriteServer

The WriteServer callback function writes a data buffer to the server.

The WriteServer callback function is declared as:

BOOL WINAPI * WriteServer(
  struct _HTTP_FILTER_CONTEXT* pfc,
  LPVOID Buffer,
  LPDWORD lpdwBytes,
  DWORD dwReserved
);

Parameters

pfc
Pointer to the HTTP_FILTER_CONTEXT data structure that is associated with the current, active HTTP session. Pass the filter context in this parameter.
Buffer
Pointer to the buffer to write.
lpdwBytes
Pointer to the size of the buffer pointed to by the Buffer parameter.
dwReserved
Reserved for future use.

Return Values

Returns TRUE if the function succeeded, or FALSE if the function failed.

Remarks

The WriteServer function is called through a pointer that is a member of the WPX_FILTER_CONTEXT structure. To get a pointer to the WPX_FILTER_CONTEXT structure for calling the WriteServer function, use the TO_WPX_FILTER_CONTEXT macro as follows:

WPX_FILTER_CONTEXT* pwfc = TO_WPX_FILTER_CONTEXT(pfc);
if (pwfc != NULL) {
...
}

The WriteServer callback function is synchronous and and blocks the thread from which it is called until the IO operation is completed. A Web filter sending a large amount of data in calls to this function can block all of the available worker threads with a resultant denial of service (DoS).

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Wpxhttpfilt.h.

See Also

Callback Functions


Notification Structures [ISA Server 2004]

Notification Structures

The following structures and types are used by Web filters:

  • HTTP_FILTER_ACCESS_DENIED
  • HTTP_FILTER_AUTH_COMPLETE_INFO
  • HTTP_FILTER_AUTHENT
  • HTTP_FILTER_CONTEXT
  • HTTP_FILTER_LOG
  • HTTP_FILTER_PREPROC_HEADERS
  • HTTP_FILTER_RAW_DATA
  • HTTP_FILTER_SEND_RESPONSE
  • HTTP_FILTER_URL_MAP
  • HTTP_FILTER_VERSION
  • WPX_FILTER_AUTHENT_EX
  • WPX_FILTER_CONTEXT
  • WPX_FILTER_PREPROC_HEADERS
  • WPX_FILTER_ROUTE
  • WPX_HTTP_FILTER_AUTH_COMPLETE_INFO

Function declarations and data structures are declared in the file Wpxhttpfilt.h, which is included in the ISA Server 2004 SDK.


HTTP_FILTER_ACCESS_DENIED structure [ISA Server 2004]

HTTP_FILTER_ACCESS_DENIED

The ISA Server Web proxy includes a pointer to the HTTP_FILTER_ACCESS_DENIED structure when a user is presented with an Access Denied error message. If your filter should be notified for this event, it must register to receive SF_NOTIFY_ACCESS_DENIED notifications. For more information about the types of event notifications that are sent to Web filters, see Event Notifications.

typedef struct _HTTP_FILTER_ACCESS_DENIED {
  const CHAR* pszURL;
  const CHAR* pszPhysicalPath;
  DWORD dwReason;
} HTTP_FILTER_ACCESS_DENIED,
*PHTTP_FILTER_ACCESS_DENIED;

Members

pszURL
A null-terminated string that specifies the URL that requested access to the resource.
pszPhysicalPath
A null-terminated string that specifies the physical path of the resource that was requested.
dwReason
A DWORD date type containing flags that indicate the reasons for the denial. It can have one of the following values.
Value | Meaning
SF_DENIED_LOGON | The client could not be logged on.
SF_DENIED_RESOURCE | The resource was denied by a Windows discretionary access control list (DACL).
SF_DENIED_FILTER | A Web filter denied the request.
SF_DENIED_BY_CONFIG | The server configuration denied the request. For example, disabling anonymous requests on the server would generate this filter notification when a user without credentials tried to make a request to the server.

Remarks

This structure indicates that access to the requested resource has been denied by the server. The structure is generated when there has been a logon failure.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Wpxhttpfilt.h.

See Also

Notification Structures


HTTP_FILTER_AUTH_COMPLETE_INFO structure [ISA Server 2004]

HTTP_FILTER_AUTH_COMPLETE_INFO

The ISA Server Web proxy includes a pointer to the HTTP_FILTER_AUTH_COMPLETE_INFO structure in the notification that it sends to Web filters after it has successfully completed authentication. If your filter should be notified for this event, it must register to receive SF_NOTIFY_AUTH_COMPLETE notifications. For more information about the types of event notifications that are sent to Web filters, see Event Notifications.

Note When you are creating a Web filter for ISA Server, we recommend that you use WPX_HTTP_FILTER_AUTH_COMPLETE_INFO rather than HTTP_FILTER_AUTH_COMPLETE_INFO.

typedef struct _HTTP_FILTER_AUTH_COMPLETE_INFO {
  BOOL (WINAPI)* GetHeader;
  BOOL (WINAPI)* SetHeader;
  BOOL (WINAPI)* AddHeader;
  BOOL (WINAPI)* GetUserToken;
  DWORD HttpStatus;
  BOOL fResetAuth;
  DWORD dwReserved;
} HTTP_FILTER_AUTH_COMPLETE_INFO,
*PHTTP_FILTER_AUTH_COMPLETE_INFO;

Members

GetHeader
Pointer to the GetHeader callback function, which can be used to retrieve a specified header or a portion of the request line in the incoming request. Header names include a trailing colon (:). Individual portions of the request line are specified by the special values "method", "URL", and "version". The special values are case-sensitive and must not include the trailing colon.
SetHeader
Pointer to the SetHeader callback function, which can be used to modify or delete the value of a header or to add a new header. Unlike the IIS function of the same name, this function cannot be used to modify the portions of the request line specified by the special values.
AddHeader
Pointer to the AddHeader callback function, which can be used to add an HTTP header to the request.
GetUserToken
Pointer to the GetUserToken function that returns a handle to the token of the user for whom impersonation will be performed.
HttpStatus
Not used.
fResetAuth
If set to TRUE, the authentication process will be reset, and no impersonation will be done.
dwReserved
A DWORD reserved for later use.

Remarks

This structure allows you to view the method, URL, version, or headers, or to modify the headers sent from the client. The SF_NOTIFY_AUTH_COMPLETE notification is sent after the client's identity has been negotiated with the client, or when the client is anonymous. Because of the timing of this notification, the AUTH_USER server variable can be used to reliably obtain the identity of the user. Also, functionality is provided to retrieve a copy of the token that ISA Server will use to impersonate the client when processing the request.

All authentication scheme processes should result in either SF_NOTIFY_AUTH_COMPLETE, authentication, giving the filter a handle to a token of the user to be impersonated, or ACCESS_DENIED, when the user is not recognized by the system.

The SF_NOTIFY_AUTH_COMPLETE notification may be used for:

  • Accessing the user token of the user to be impersonated.
  • Actions that can be done in PREPROC_HEADERS, such as GET/ADD or SET request headers.
  • Resetting authentication.

Note If a filter needs to add authorization headers after a request is authenticated and before the request is sent to the upstream Web server, it must do so by parsing the request after the SF_NOTIFY_FORWARD_RAW_DATA notification, rather than after the SF_NOTIFY_AUTH_COMPLETE notification.

This is because when the request is authenticated, ISA Server removes every authorization header before sending the request on to the upstream Web server. (In forward-proxy scenarios, it removes proxy authorization headers. In reverse-proxy scenarios, it removes authorization headers.) Therefore, even if the filter adds an authorization header after the SF_NOTIFY_AUTH_COMPLETE notification, it will be removed.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Wpxhttpfilt.h.

See Also

Notification Structures


HTTP_FILTER_AUTHENT structure [ISA Server 2004]

HTTP_FILTER_AUTHENT

The ISA Server Web proxy includes a pointer to the HTTP_FILTER_AUTHENT structure when it is authenticating a user. If your filter should be notified for this event, it must register to receive SF_NOTIFY_AUTHENTICATION notifications. For more information about the types of event notifications that are sent to Web filters, see Event Notifications.

Note When you are creating a Web filter for ISA Server, we recommend that you use WPX_FILTER_AUTHENT_EX rather than HTTP_FILTER_AUTHENT.

typedef struct _HTTP_FILTER_AUTHENT {
  CHAR* pszUser;
  DWORD cbUserBuff;
  CHAR* pszPassword;
  DWORD cbPasswordBuff;
} HTTP_FILTER_AUTHENT,
*PHTTP_FILTER_AUTHENT;

Members

pszUser
Null-terminated string that specifies the user name for this request. An empty string indicates an anonymous user.
cbUserBuff
The size of the buffer pointed to by pszUser. This is guaranteed to be at least SF_MAX_USERNAME.
pszPassword
Null-terminated string that specifies the password for this request.
cbPasswordBuff
The size of the buffer pointed to by pszPassword. This is guaranteed to be at least SF_MAX_PASSWORD.

Remarks

When the server is about to authenticate the client, this structure is pointed to by the pvNotification parameter in the HttpFilterProc function when the notificationType parameter is SF_NOTIFY_AUTHENTICATION. The pszUser and pszPassword members contain the information sent by the client.

In the case of basic or RADIUS authentication, after exiting this notification, these values should represent a valid Windows user account and password. If another authentication method is used, the password value will not be available.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Wpxhttpfilt.h.

See Also

Notification Structures


HTTP_FILTER_CONTEXT structure [ISA Server 2004]

HTTP_FILTER_CONTEXT

The HTTP_FILTER_CONTEXT structure is used by HttpFilterProc and HttpWPXFilterProc to obtain information about the current request.

typedef struct _HTTP_FILTER_CONTEXT {
  DWORD cbSize;
  DWORD Revision;
  PVOID ServerContext;
  DWORD ulReserved;
  BOOL fIsSecurePort;
  PVOID pFilterContext;
  BOOL (WINAPI)* GetServerVariable;
  BOOL (WINAPI)* AddResponseHeaders;
  BOOL (WINAPI)* WriteClient;
  VOID*  (WINAPI)* AllocMem;
  BOOL (WINAPI)* ServerSupportFunction;
} HTTP_FILTER_CONTEXT,
*PHTTP_FILTER_CONTEXT;

Members

cbSize
The size of this structure, in bytes.
Revision
The revision level of this structure.
ServerContext
Reserved for server use.
ulReserved
Reserved for server use.
fIsSecurePort
A value of TRUE indicates that this event is over a secure port. A value of FALSE indicates that the event is not over a secure port.
pFilterContext
Pointer to any context information that the filter wants to associate with this request. Any memory associated with this request can be safely freed during the SF_NOTIFY_END_OF_NET_SESSION notification.
GetServerVariable
Pointer to the GetServerVariable function that retrieves information about the server and this connection. For some notifications, some variables may not be defined. For example, notifications that occur before PREPROC_HEADERS, such as the READ_RAW_DATA notification, may have undefined variables.
AddResponseHeaders
Pointer to the AddResponseHeaders function that adds a header to the HTTP response.
WriteClient
Pointer to the WriteClient function that sends raw data back to the client.
AllocMem
Pointer to the AllocMem function used to allocate memory. Any memory allocated with this function will automatically be freed when the session ends.
ServerSupportFunction
Pointer to the ServerSupportFunction function used to extend the Web filter functions. Parameters are specific to the extensions.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Wpxhttpfilt.h.

See Also

Notification Structures


HTTP_FILTER_LOG structure [ISA Server 2004]

HTTP_FILTER_LOG

The ISA Server Web proxy includes a pointer to the HTTP_FILTER_LOG structure when it is writing information to a log file. If your filter should be notified for this event, it must register to receive SF_NOTIFY_LOG notifications. For more information about the types of event notifications that are sent to Web filters, see Event Notifications.

typedef struct _HTTP_FILTER_LOG {
  const CHAR* pszClientHostName;
  const CHAR* pszClientUserName;
  const CHAR* pszServerName;
  const CHAR* pszOperation;
  const CHAR* pszTarget;
  const CHAR* pszParameters;
  DWORD dwHttpStatus;
  DWORD dwWin32Status;
  DWORD dwBytesSent;
  DWORD dwBytesRecvd;
  DWORD msTimeForProcessing;
} HTTP_FILTER_LOG,
*PHTTP_FILTER_LOG;

Members

pszClientHostName
The client's host name or IP address.
pszClientUserName
Null-terminated string that specifies the client's user name if authenticated, or "anonymous" otherwise.
pszServerName
Null-terminated string that specifies the name of the server to which the client is connected.
pszOperation
Null-terminated string that specifies the HTTP method.
pszTarget
Null-terminated string that specifies the target of the HTTP command.
pszParameters
Null-terminated string that specifies the parameters passed to the HTTP command.
dwHttpStatus
The HTTP return status.
dwWin32Status
The Windows error code.
dwBytesSent
The number of bytes sent from the server to the client.
dwBytesRecvd
The number of bytes received by the server from the client.
msTimeForProcessing
The time, in milliseconds, required to process the client request.

Remarks

When the server is about to log information to the server log file, this structure is pointed to by the pvNotification parameter in the HttpFilterProc function when the NotificationType parameter is SF_NOTIFY_LOG. The strings cannot be changed, but the string pointers can be replaced. If string pointers are changed, the memory they point to must remain valid until the next filter notification. The AllocMem callback function in the HTTP_FILTER_CONTEXT structure can be used to ensure this.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Wpxhttpfilt.h.

See Also

Notification Structures


HTTP_FILTER_PREPROC_HEADERS structure [ISA Server 2004]

HTTP_FILTER_PREPROC_HEADERS

The ISA Server Web proxy includes a pointer to the HTTP_FILTER_PREPROC_HEADERS structure in the notification that it sends to Web filters when it preprocesses a request's headers. If your filter should be notified for this event, it must register to receive SF_NOTIFY_PREPROC_HEADERS notifications. For more information about the types of event notifications that are sent to Web filters, see Event Notifications.

Note When you are creating a Web filter for ISA Server, we recommend that you use WPX_FILTER_PREPROC_HEADERS rather than HTTP_FILTER_PREPROC_HEADERS.

typedef struct _HTTP_FILTER_PREPROC_HEADERS {
  BOOL (WINAPI)* GetHeader;
  BOOL (WINAPI)* SetHeader;
  BOOL (WINAPI)* AddHeader;
  DWORD HttpStatus;
  DWORD dwReserved;
} HTTP_FILTER_PREPROC_HEADERS,
*PHTTP_FILTER_PREPROC_HEADERS;

Members

GetHeader
Pointer to the GetHeader callback function, which can be used to retrieve a specified header or a portion of the request line in the incoming request. Header names include a trailing colon (:). Individual portions of the request line are specified by the special values "body" (for requests only), "method", "URL", and "version". The status from the response line is specified by the special value "status". The special values are case-sensitive and must not include the trailing colon.
SetHeader
Pointer to the SetHeader callback function, which can be used to modify or delete the value of a header or to modify a portion included in the request line or response line specified by a special value.
AddHeader
Pointer to the AddHeader callback function, which can be used to add an HTTP header to the request.
HttpStatus
Not used.
dwReserved
A DWORD reserved for later use.

Remarks

When the Web proxy is about to process the client headers, it sends a notification by calling the HttpFilterProc entry-point function of each Web filter that is registered to receive the notification. The pvNotification parameter contains a pointer to an HTTP_FILTER_PREPROC_HEADERS structure, and the notificationType parameter is set to SF_NOTIFY_PREPROC_HEADERS.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Wpxhttpfilt.h.

See Also

Notification Structures


HTTP_FILTER_RAW_DATA structure [ISA Server 2004]

HTTP_FILTER_RAW_DATA

The ISA Server Web proxy includes a pointer to the HTTP_FILTER_RAW_DATA structure when it is either reading or sending raw data. If your filter should be notified for events involving reading or sending raw data, it must register to receive one of these notifications:

  • SF_NOTIFY_READ_RAW_DATA
  • SF_NOTIFY_SEND_RAW_DATA
  • SF_NOTIFY_FORWARD_RAW_DATA
  • SF_NOTIFY_RECEIVE_RESPONSE_RAW_DATA

For more information about the types of event notifications that are sent to Web filters, see Event Notifications.

typedef struct _HTTP_FILTER_RAW_DATA {
  PVOID pvInData;
  DWORD cbInData;
  DWORD cbInBuffer;
  DWORD dwReserved;
} HTTP_FILTER_RAW_DATA,
*PHTTP_FILTER_RAW_DATA;

Members

pvInData
Points to the data buffer.
cbInData
The amount of data in the buffer pointed to by pvInData.
cbInBuffer
The size of the buffer pointed to by pvInData.
dwReserved
Reserved for future use.

Remarks

When the server receives raw data, this structure is pointed to by the pvNotification parameter in HttpFilterProc when the notificationType parameter is set to SF_NOTIFY_READ_RAW_DATA or SF_NOTIFY_SEND_RAW_DATA, or in HttpWPXFilterProc when the pvNotification parameter is set to SF_NOTIFY_FORWARD_RAW_DATA or SF_NOTIFY_RECEIVE_RESPONSE_RAW_DATA. The pvInData pointer can be replaced by filters that modify the raw data being sent or received. (If the pointer is replaced, cbInData and cbInBuffer must also be appropriately updated.) The new buffer memory must remain valid until the end of the request. The new buffer memory can remain valid by using AllocMem or AllocMemoryPerRequest, or by using a buffer owned by the filter. In addition, the filter must not attempt to free or otherwise deallocate the old pvInData pointer. Only the owner of the memory block can free the buffer.

If a filter accumulates a response in an SF_NOTIFY_RECEIVE_RESPONSE_RAW_DATA notification without releasing it to the next filter, the filter may not release the data until it receives an SF_NOTIFY_END_OF_REQUEST notification, which indicates that the server closed the connection. At this point, the filter will typically call WriteClient with the accumulated data. However, this will prevent other server-side filters from obtaining the raw response data, and those filters will be skipped. We recommend not accumulating the body of a response without releasing it to the next filter. If you must do so, accumulate the data in an SF_NOTIFY_SEND_RAW_DATA notification rather than an SF_NOTIFY_RECEIVE_RESPONSE_RAW_DATA notification.

Warning We do not recommend that filters modify the raw data in place. The memory segment may be read-only or the data may be cached directly by an ISAPI extension.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Wpxhttpfilt.h.

See Also

Notification Structures


HTTP_FILTER_SEND_RESPONSE structure [ISA Server 2004]

HTTP_FILTER_SEND_RESPONSE

The ISA Server Web proxy includes a pointer to the HTTP_FILTER_SEND_RESPONSE structure in the notification that it sends to Web filters when ISA Server sends headers to the client. A filter can inspect, modify, or add headers that the client will receive as part of the response to the client's original request. The structure contains the same members as HTTP_FILTER_PREPROC_HEADERS. If your filter should be notified for this event, it must register to receive SF_NOTIFY_SEND_RESPONSE notifications. For more information about the types of event notifications that are sent to Web filters, see Event Notifications.

Note An SF_NOTIFY_SEND_RESPONSE notification is not sent when ISA Server returns a response from a website or from the cache. However, it is sent when ISA Server creates a response, such as an error page, or when a filter generates a response by using SF_REQ_SEND_RESPONSE_HEADER.

typedef struct HTTP_FILTER_SEND_RESPONSE {
  BOOL (WINAPI)* GetHeader;
  BOOL (WINAPI)* SetHeader;
  BOOL (WINAPI)* AddHeader;
  DWORD HttpStatus;
  DWORD dwReserved;
} HTTP_FILTER_SEND_RESPONSE,
*PHTTP_FILTER_SEND_RESPONSE;

Members

GetHeader
Pointer to the GetHeader function, which can be used to retrieve the specified header value. Header names should include the trailing colon (:).
SetHeader
Pointer to the SetHeader function, which can be used to modify or delete the value of a header. The function cannot be used to modify the portions included in the request line that are specified by the special values.
AddHeader
Pointer to the AddHeader callback function, which can be used to add an HTTP header to the response.
HttpStatus
The current HTTP status code.
dwReserved
A DWORD data type reserved for later use.

Remarks

The Web proxy sends an SF_NOTIFY_SEND_RESPONSE notification by calling the HttpFilterProc entry-point function of each Web filter that is registered to receive the notification. The pvNotification parameter contains a pointer to an HTTP_FILTER_SEND_RESPONSE structure, and the notificationType parameter is set to SF_NOTIFY_SEND_RESPONSE.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Wpxhttpfilt.h.

See Also

Notification Structures


structure [ISA Server 2004]

HTTP_FILTER_URL_MAP

The HTTP_FILTER_URL_MAP structure is not relevant to the implementation of ISAPI by ISA Server. It is provided for compatibility with Internet Information Services (IIS).

typedef struct {
  ...
}

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Wpxhttpfilt.h.

See Also

Notification Structures


HTTP_FILTER_VERSION structure [ISA Server 2004]

HTTP_FILTER_VERSION

This HTTP_FILTER_VERSION structure is used by GetFilterVersion or GetWPXFilterVersion to set the filter version information.

typedef struct _HTTP_FILTER_VERSION {
  DWORD dwServerFilterVersion;
  DWORD dwFilterVersion;
  CHAR lpszFilterDesc[SF_MAX_FILTER_DESC_LEN];
  DWORD dwFlags;
} HTTP_FILTER_VERSION,
*PHTTP_FILTER_VERSION;

Members

dwServerFilterVersion
The ISAPI version in use by the server.
dwFilterVersion
The version number of the Web filter API used by the Web filter. The version used by your filter can be set by using the WPX_HTTP_FILTER_REVISION definition from the Wpxhttpfilt.h header file.

The filter version is required. If the filter version is higher than the server API version (dwServerFilterVersion), the filter will not be loaded, to avoid version issues.

lpszFilterDesc
Not used in ISA Server 2004.
dwFlags
Contains flags that indicate for which notification event types the filter should be notified. For a list of priority flag values, see Event Notifications

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Wpxhttpfilt.h.

See Also

Notification Structures


WPX_FILTER_AUTHENT_EX structure [ISA Server 2004]

WPX_FILTER_AUTHENT_EX

The ISA Server Web proxy includes a pointer to the WPX_FILTER_AUTHENT_EX structure when it is authenticating a user. If your filter should be notified for this event, it must register to receive SF_NOTIFY_AUTHENTICATION notifications. For more information about the types of event notifications that are sent to Web filters, see Event Notifications.

typedef struct _WPX_FILTER_AUTHENT_EX {
  CHAR* pszUser;
  DWORD cbUserBuff;
  CHAR* pszPassword;
  DWORD cbPasswordBuff;
  BOOL fAuthIsRequired;
  BOOL (WINAPI)* SetAuthenticatedUser;
  BOOL (WINAPI)* SetADAuthenticatedUser;
} WPX_FILTER_AUTHENT_EX,
*PWPX_FILTER_AUTHENT_EX;

Members

pszUser
Null-terminated string that specifies the user name for this request. An empty string indicates an anonymous user.
cbUserBuff
The size of the buffer pointed to by pszUser. This is guaranteed to be at least SF_MAX_USERNAME.
pszPassword
Null-terminated string that specifies the password for this request.
cbPasswordBuff
The size of the buffer pointed to by pszPassword. This is guaranteed to be at least SF_MAX_PASSWORD.
fAuthIsRequired
Indicates whether authentication is required for this request.
SetAuthenticatedUser
Points to the SetAuthenticatedUser function, which is used by Web filters to set an authenticated non-Windows user.
SetADAuthenticatedUser
Points to the SetADAuthenticatedUser function, which is used by Web filters to set an authenticated Windows user.

Remarks

This notification can be used to implement a Web filter that adds an authentication scheme to ISA Server.

When the server is about to authenticate the client, this structure is pointed to by the pvNotification parameter in the HttpFilterProc function when the notificationType parameter is SF_NOTIFY_AUTHENTICATION. The pszUser and pszPassword members contain the information sent by the client.

In the case of basic or RADIUS authentication, after exiting this notification, these values should represent a valid Windows user account and password. If another authentication method is used, the password value will not be available.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Wpxhttpfilt.h.

See Also

Notification Structures


WPX_FILTER_CONTEXT structure [ISA Server 2004]

WPX_FILTER_CONTEXT

The WPX_FILTER_CONTEXT structure is used to obtain information about the current request.

Note To get a pointer to the WPX_FILTER_CONTEXT structure from the pointer to the HTTP_FILTER_CONTEXT structure, use the TO_WPX_FILTER_CONTEXT macro as follows:

WPX_FILTER_CONTEXT* pwfc = TO_WPX_FILTER_CONTEXT(pfc);
if (pwfc != NULL) {
...
}

typedef struct _WPX_FILTER_CONTEXT {
  DWORD cbSize;
  DWORD Revision;
  PVOID ServerContext;
  DWORD ulReserved;
  BOOL fIsSecurePort;
  PVOID pFilterContext;
  BOOL (WINAPI)* GetServerVariable;
  BOOL (WINAPI)* AddResponseHeaders;
  BOOL (WINAPI)* WriteClient;
  VOID* (WINAPI)* AllocMem;
  BOOL (WINAPI)* ServerSupportFunction;
  BOOL (WINAPI)* WriteServer;
  VOID* (WINAPI)* AllocMemoryPerRequest;
  BOOL (WINAPI)* GetAuthSchemeStatus;
  BOOL (WINAPI)* WPXSupportFunction;
} WPX_FILTER_CONTEXT,
*PWPX_FILTER_CONTEXT;

Members

cbSize
The size of this structure, in bytes.
Revision
The revision level of this structure.
ServerContext
Reserved for server use.
ulReserved
Reserved for server use.
fIsSecurePort
A value of TRUE indicates that this event is over a secure port. A value of FALSE indicates that the event is not over a secure port.
pFilterContext
Pointer to any context information that the filter wants to associate with this request. Any memory associated with this request can be safely freed during the SF_NOTIFY_END_OF_NET_SESSION notification.
GetServerVariable
Pointer to the GetServerVariable function that retrieves information about the server and this connection. For some notifications, some variables may not be defined. For example, notifications that occur before PREPROC_HEADERS, such as the READ_RAW_DATA notification, may have undefined variables.
AddResponseHeaders
Pointer to the AddResponseHeaders function that adds a header to the HTTP response.
WriteClient
Pointer to the WriteClient function that sends raw data back to the client.
AllocMem
Pointer to the AllocMem function used to allocate memory. Any memory allocated with this function will automatically be freed when the session ends.
ServerSupportFunction
Pointer to the ServerSupportFunction function used to extend the Web filter functions. Parameters are specific to the extensions.
WriteServer
Pointer to the WriteServer function that writes a data buffer to the server.
AllocMemoryPerRequest
Pointer to the AllocMemoryPerRequest function that allocates memory per request.
GetAuthSchemeStatus
Pointer to the GetAuthSchemeStatus function that returns the status (enabled or disabled) of an authentication scheme for the listener.
WPXSupportFunction
Pointer to the WPXSupportFunction callback function that extends the Web filter functions. Parameters are specific to the extensions.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Wpxhttpfilt.h.

See Also

Notification Structures


WPX_FILTER_PREPROC_HEADERS structure [ISA Server 2004]

WPX_FILTER_PREPROC_HEADERS

The ISA Server Web proxy includes a pointer to the WPX_FILTER_PREPROC_HEADERS structure in the notification that it sends to Web filters when it preprocesses a request's headers or a Web server response's headers. If your filter should be notified for this event, it must register to receive SF_NOTIFY_PREPROC_HEADERS or SF_NOTIFY_RECEIVE_RESPONSE_HEADERS notifications. For more information about the types of event notifications that are sent to Web filters, see Event Notifications.

typedef struct _WPX_FILTER_PREPROC_HEADERS {
  BOOL (WINAPI)* GetHeader;
  BOOL (WINAPI)* SetHeader;
  BOOL (WINAPI)* AddHeader;
  DWORD HttpStatus;
  DWORD dwReserved;
  BOOL (WINAPI)* SetUserCachingKey;
} WPX_FILTER_PREPROC_HEADERS,
*PWPX_FILTER_PREPROC_HEADERS;

Members

GetHeader
Pointer to the GetHeader callback function, which can be used to retrieve a specified header, a portion of the request line in the request, or the status from the response. Header names include a trailing colon (:). Individual portions of the request line are specified by the special values "body" (for requests only), "method", "URL", and "version". The status from the response line is specified by the special value "status". The special values are case-sensitive and must not include the trailing colon.
SetHeader
Pointer to the SetHeader callback function, which can be used to modify or delete the value of a header or to modify a portion of the request line or the response line that is specified by a special value.
AddHeader
Pointer to the AddHeader callback function, which can be used to add an HTTP header to the response.
HttpStatus
Not used.
dwReserved
A DWORD reserved for later use.
SetUserCachingKey
Sets the user caching key.

Remarks

When the server is about to process the client headers, it sends a notification by calling the HttpFilterProc entry-point function of each Web filter that is registered to receive the notification. The pvNotification parameter contains a pointer to an WPX_FILTER_PREPROC_HEADERS structure, and the notificationType parameter is set to SF_NOTIFY_PREPROC_HEADERS.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Wpxhttpfilt.h.

See Also

Notification Structures


WPX_FILTER_ROUTE structure [ISA Server 2004]

WPX_FILTER_ROUTE

The ISA Server Web proxy includes a pointer to the WPX_FILTER_ROUTE structure when it forwards the request to the Web server. If your filter should be notified for this event, it must register to receive SF_NOTIFY_ROUTING notifications. For more information about the types of event notifications that are sent to Web filters, see Event Notifications.

typedef struct _WPX_FILTER_ROUTE {
  CHAR* pszHost;
  DWORD cbInHost;
  WORD    wPort;
} WPX_FILTER_ROUTE,
*PWPX_FILTER_ROUTE;

Members

pszHost
Null-terminated string that specifies the host name or IP address.
cbInHost
The size of the buffer pointed to by pszHost.
wPort
The port for the host.

Remarks

The SF_NOTIFY_ROUTING notification is received each time a request is forwarded to a Web server or upstream proxy. Use this structure to change the host or port to which ISA Server will forward the request.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Wpxhttpfilt.h.

See Also

Notification Structures


WPX_HTTP_FILTER_AUTH_COMPLETE_INFO structure [ISA Server 2004]

WPX_HTTP_FILTER_AUTH_COMPLETE_INFO

The ISA Server Web proxy includes a pointer to the WPX_HTTP_FILTER_AUTH_COMPLETE_INFO structure in the notification that it sends to Web filters after it has successfully completed authentication. If your filter should be notified for this event, it must register to receive SF_NOTIFY_AUTH_COMPLETE notifications. For more information about the types of event notifications that are sent to Web filters, see Event Notifications.

typedef struct WPX_HTTP_FILTER_AUTH_COMPLETE_INFO {
  BOOL (WINAPI)* GetHeader;
  BOOL (WINAPI)* SetHeader;
  BOOL (WINAPI)* AddHeader;
  BOOL (WINAPI)* GetUserToken;
  DWORD HttpStatus;
  BOOL fResetAuth;
  DWORD dwReserved;
  BOOL (WINAPI)* SetUserCachingKey;
} WPX_HTTP_FILTER_AUTH_COMPLETE_INFO;

Members

GetHeader
Pointer to the GetHeader callback function, which can be used to retrieve a specified header or a portion of the request line in the incoming request. Header names include a trailing colon (:). Individual portions of the request line are specified by the special values "method", "URL", and "version". The special values are case-sensitive and must not include the trailing colon.
SetHeader
Pointer to the SetHeader callback function, which can be used to modify or delete the value of a header or to add a new header. This function cannot be used to modify the portions of the request line specified by the special values.
AddHeader
Pointer to the AddHeader callback function, which can be used to add an HTTP header to the request.
GetUserToken
Points to the GetUserToken function that returns a handle to the token of the user for whom impersonation will be performed.
HttpStatus
Not used.
fResetAuth
If set to TRUE, the authentication process will be reset, and no impersonation will be done.
dwReserved
A DWORD reserved for later use.
SetUserCachingKey
Sets the user caching key.

Remarks

This structure allows you to view the method, URL, version, or headers, or to modify the headers sent from the client. It also allows you to set the caching key for this request. You can use this to provide a different caching key for each user.

The SF_NOTIFY_AUTH_COMPLETE occurs after the client's identity has been negotiated with the client, or when the client is anonymous. Because of the timing of this notification, the AUTH_USER server variable can be used to reliably obtain the identity of the user. Also, functionality is provided to retrieve a copy of the token that ISA Server will use to impersonate the client when processing the request.

All authentication scheme processes should result in either SF_NOTIFY_AUTH_COMPLETE, authentication, giving the filter a handle to a token of the user to be impersonated, or ACCESS_DENIED, when the user is not recognized by the system.

SF_NOTIFY_AUTH_COMPLETE notification may be used for:

  • Accessing the user token of the user to be impersonated.
  • Actions that can be done in PREPROC_HEADERS, such as GET/ADD or SET request headers.
  • Resetting authentication.

Note If a filter needs to add authorization headers after a request is authenticated and before the request is sent to the upstream/Web server, it must do so by parsing the request in the SF_NOTIFY_FORWARD_RAW_DATA notification, rather than in the SF_NOTIFY_AUTH_COMPLETE notification.

This is because when the request is authenticated, ISA removes every authorization header before sending the request on to the upstream Web server. (In forward-proxy scenarios, it removes proxy authorization headers. In reverse-proxy scenarios, it removes authorization headers.) Therefore, even if the filter adds an authorization header in SF_NOTIFY_AUTH_COMPLETE notification, it will be removed.

Requirements

Server: Requires Windows Server 2003 or Windows 2000.
Version: Requires Internet Security and Acceleration Server 2004.
Header: Declared in Wpxhttpfilt.h.

See Also

Notification Structures


Extending ISA Server Management [ISA Server 2004]

Extending ISA Server Management

ISA Server Management is designed to be extensible. One way that you can extend ISA Server Management is to use Microsoft® Management Console (MMC) extension snap-ins. The ISA Server Management tree is itself an MMC snap-in.

This topic contains information specifically related to extending the ISA Server MMC snap-in. For general information about working with MMC, see Microsoft Management Console in MSDN.

Any ISA Server node can be extended with a snap-in.

What Can Extension Snap-ins Extend?

Extension snap-ins can extend the following:

  • The name space by adding scope pane child nodes.
  • Context menus.
  • Toolbars and toolbar buttons.
  • Property pages.

There are several steps you need to take to create an extension snap-in.

To create an extension snap-in

  1. Define your schema in the FPCVendorParametersSet object.
  2. Write the code for the MMC snap-in.
  3. Store/retrieve the data in the FPCVendorParametersSet object retrieved by using the FPCSnapinNode.CurrentObject.VendorParametersSets property.

Each node of an ISA Server snap-in exposes its specific data to extension snap-ins by using the COM interface: IFPCSnapinNode. The interface contains five properties:

  • ParentArray (of type IDispatch)
  • CurrentObject (of type IDispatch)
  • ComRoot (of type IDispatch)
  • ParentPolicy (of type IDispatch)
  • PluginPolicy (of type IFPCSnapinPluginPolicy)

The IFPCSnapinNode interface can be retrieved by querying the IDataObject interface of the ISA Server node that you want to extend. The ParentArray property retrieves an FPCArray object as exposed through the ISA Server administration COM object model. Note that this property returns an error for the Root node of the ISA Server snap-in. The CurrentObject property is interface-specific to the node to be extended. The PluginPolicy property retrieves the plug-in policy for the node to be extended. See How to Create a Microsoft Management Console Snap-in for more details.

The ISA Server nodes that support MMC extensions and their GUIDs are listed in the Globally Unique Identifiers topic of the Reference section.

This section contains the following topics:

  • How to Create a Microsoft Management Console Snap-in
  • How to Create a Context-Sensitive Menu Extension


How to Create a Microsoft Management Console Snap-in [ISA Server 2004]

How to Create a Microsoft Management Console Snap-in

You can use ISA Server to create application filters. After creating the application filters, you can use the Microsoft Management Console (MMC), described in MSDN, to modify the application filter properties in ISA Server Management.

This section contains the following topic:

  • Creating a Microsoft Management Console Snap-in for an Application Filter


Creating a Microsoft Management Console Snap-in for an Application Filter

To create a Microsoft Management Console (MMC) snap-in for an application filter you need to follow these steps, as described in the following sections:

  1. Create the property sheet. Initially, this property sheet will be displayed for all of the application filters.
  2. Test the property sheet extension.
  3. Limit the property sheet, so that it displays only on the relevant application filter.
  4. Design the property page layout.
  5. Create message handlers for the property sheet elements.
  6. Load filter configuration data from vendor parameter sets and display it in ISA Server Management.
  7. Save the configuration data from ISA Server Management to the vendor parameter set.


Creating the Property Sheet [ISA Server 2004]

Creating the Property Sheet

Create the property sheet following the procedures in the MMC documentation (Microsoft Management Console). The property sheet must be created on a computer that has the ISA Server administration tool installed. The node you want to extend is ISA Server Application Filter.


Testing the Property Sheet Extension [ISA Server 2004]

Testing the Property Sheet Extension

Follow this procedure to test the new property sheet.

To test the new property sheet

  1. Run ISA Server Management (Click Start, point to Programs, point to Microsoft ISA Server, and then click ISA Server Management).
  2. Select the applicable array, select Extensions and then click Application Filters.
  3. Display the properties of any of the application filters listed in the details pane, by either double-clicking the name of the filter, or right-clicking and selecting Properties. Check if each of the application filters has the new (empty) property sheet.


Limiting the Property Sheet Display [ISA Server 2004]

Limiting the Property Sheet Display

The property sheet should display only on the relevant application filter.

To limit the property sheet display

  1. Select a unique attribute name for the application filter; for example, its GUID.
  2. Add the directory of the file Msfpccom.dll (SDK installation root\bin) to the include path.
  3. In Stdafx.h add the following #import statement:
    #import "msfpccom.dll" named_guids

    The #import directive is used to incorporate information from a type library. The content of the type library is converted into C++ classes, mostly describing the COM interfaces.

  4. In the the .cpp file where your snap-in is defined, add the if statement in the following example code to this method and change the GUID to the GUID of your application filter:
    HRESULT CFilterSnapInExtData::CreatePropertyPages(LPPROPERTYSHEETCALLBACK lpProvider,
    long handle,
    IUnknown* pUnk,
    DATA_OBJECT_TYPES type)
{
    FPCLib::IFPCSnapinNodePtr spiFPCSnapinNode(m_pDataObject);

    FPCLib::IFPCApplicationFilterPtr spiApplicationFilter(spiFPCSnapinNode->CurrentObject);

    _bstr_t bstrGUID(spiApplicationFilter->GetGuid());

    // if (type == CCT_SCOPE || type == CCT_RESULT)
    if (bstrGUID == _bstr_t("{7CCF6FF0-D995-4da1-B452-4228047B2D1D}"))  // Filter GUID
    {
        CFilterSnapInPage* pPage = new CFilterSnapInPage(handle, true, _T("FilterSnapIn"));
        lpProvider->AddPage(pPage->Create());

        // The second parameter to the property page class constructor
        // should be true for only one page.

        // TODO : Add code here to add additional pages
        return S_OK;
    }
    return E_UNEXPECTED;
}
  5. Build.
  6. Test. Run ISA Server Management. Notice that the property sheet appears only on the appropriate filter.


Designing the Property Page Layout [ISA Server 2004]

Designing the Property Page Layout

Once you've succeeded in testing the property page, you can change its design.

To design the property page

  1. In Visual C++ 6.0, click the Resource View tab.
  2. Double-click the IDD_FilterSnapIn node in the Dialog section.
  3. Use the Controls toolbar to select the graphical elements to place on the page. For example, you may design the property page as follows:


Creating Message Handlers for the Property Sheet Elements [ISA Server 2004]

Creating Message Handlers for the Property Sheet Elements

You need to add handlers to the design elements you have placed on the property page.

To create the message handlers

  1. Double-click a design element on the property page. The following dialog box displays.

  2. Select the design element name from the Class orobject tohandle list.
  3. Select the name of the event you want to handle (for example, the EN_CHANGE event).
  4. Click the Add andEdit button – this will generate the needed method specification and let you edit the code. For example, if you use the EN_CHANGE event in the IDC_VIRUS_STRING edit box, the following code will be generated:
    LRESULT OnChange_VirusString(WORD wNotifyCode, WORD wID, HWND hWndCtl, BOOL& bHandled)
    {
        // TODO : Add Code for control notification handler.
        return 0;
    }
  5. You would like, at least, to enable the Apply button whenever a change to any of the controls is made. To do so you need to add the following code to the message handler:
        // Enable the Apply button
    SetModified();


Loading and Displaying the Filter Configuration [ISA Server 2004]

Loading and Displaying the Filter Configuration

Note that the fields on the property page that you will create are based on information extracted from the VendorParametersSets collection associated with the FPCApplicationFilter object. The FPCApplicationFilter object is identified by the filter GUID, and is created when a user accesses the filter node in the ISA Server MMC snap-in. When the property page is created, it runs on a separate thread from that of the FPCApplicationFilter object. For this reason, part of the code provided in this example uses marshalling techniques so that pointers can be passed between these two threads.

To load and display the filter configuration

  1. To read the values stored in the vendor parameters sets associated with the filter, add the following function to your project:
    HRESULT GetVendorData(FPCLib::IFPCApplicationFilterPtr spiApplicationFilter,
                _bstr_t* pbsVirusString,
                _bstr_t* pbsPrefixString)
{
    HRESULT hr = S_OK;
    FPCLib::IFPCVendorParametersSetsPtr spIFPCVendorParametersSets;
    FPCLib::IFPCVendorParametersSetPtr spIFPCVendorParametersSet;

    try
    {
        spIFPCVendorParametersSet = spiApplicationFilter->VendorParametersSets->Item(_bstr_t(PARAM_SET_GUID));
        *pbsVirusString  = spIFPCVendorParametersSet->Value[_bstr_t("VirusString")];
        *pbsPrefixString = spIFPCVendorParametersSet->Value[_bstr_t("PrefixString")];
    }
    catch(_com_error& err)
    {
        return err.Error();
    }

    return S_OK;
}
  2. You need to add code that will call GetVendorData() and display the data retreived on the property page. Create the OnInitDialog method by using the message-handler wizard. Do this in the same way that you create other message handlers: Use the dialog box itself as the control in the Class or object to handle list and the WM_INITDIALOG message as the event. Add the following code to the code generated (m_hWnd serves as a handle to the property page; use it when you need to access any of the controls on the property page):
        HRESULT hr = S_OK;

    _bstr_t bsVirusString, bsPrefixString;

    // Unmarshall an object interface pointer.
    hr =  CoGetInterfaceAndReleaseStream(
                    m_spStreamMarshalApplicationFilter,
                    FPCLib::IID_IFPCApplicationFilter,
                    (void**)&m_spiApplicationFilter);

    // CoGetInterfaceAndReleaseStream releases m_spStreamMarshalApplicationFilter even if it fails.
    // We set it to NULL so that the destructor doesn't try to release this again.
    m_spStreamMarshalApplicationFilter.p = NULL;

    if (FAILED(hr) || !m_spiApplicationFilter.operator bool())
        return hr;

    hr = ::GetVendorData(m_spiApplicationFilter, &bsVirusString, &bsPrefixString);
    if (FAILED (hr))
    {
        bsVirusString  = "Default Virus String";
        bsPrefixString = "Default Prefix String";
    }

    ::SetWindowText(::GetDlgItem(m_hWnd, IDC_VIRUS_STRING),  bsVirusString);
    ::SetWindowText(::GetDlgItem(m_hWnd, IDC_PREFIX_STRING), bsPrefixString);
  3. Add an initialization method to the class FilterSnapInPage:
    //This method is used for passing a pointer to the FPCApplicationFilter object of the filter
HRESULT Initialize(FPCLib::IFPCApplicationFilterPtr DataSource)
{
    HRESULT hr = S_OK;

    hr = CoMarshalInterThreadInterfaceInStream(FPCLib::IID_IFPCApplicationFilter,
                (IUnknown*)DataSource,
                &m_spStreamMarshalApplicationFilter);

    return hr;
}
  4. Add the two following private members to the class:
    private:
    FPCLib::IFPCApplicationFilterPtr m_spiApplicationFilter;

    // Pointer to stream into which this page's IApplicationFilter object interface
    // pointer will be marshaled.
    CComPtr<IStream>    m_spStreamMarshalApplicationFilter;
  5. Check whether the page was created and initialize the page.
  6. Add the following code to the .cpp file where your snap-in is defined and change the GUID to the GUID of your application filter.
    HRESULT CFilterSnapInExtData::CreatePropertyPages(LPPROPERTYSHEETCALLBACK lpProvider,
    long handle,
    IUnknown* pUnk,
    DATA_OBJECT_TYPES type)
{
    HRESULT hr = S_OK;
    // if (type == CCT_SCOPE || type == CCT_RESULT)
    CFilterSnapInPage* pPage = new CFilterSnapInPage(handle, true, _T("FilterSnapIn"));
    if (bstrGUID == _bstr_t("{7CCF6FF0-D995-4da1-B452-4228047B2D1D}"))  // Filter GUID
    {
        // Check whether the page was created.
        if(pPage == NULL)
            return E_UNEXPECTED;

        // Initialize the page.
        if (FAILED(hr = pPage->Initialize(spiApplicationFilter)))
            return hr;
        lpProvider->AddPage(pPage->Create());

        // The second parameter to the property page class constructor
        // should be true for only one page.

        // TODO : Add code here to add additional pages
        return S_OK;
    }
    return E_UNEXPECTED;
}


Saving Configuration Data in the Vendor Parameter Set [ISA Server 2004]

Saving Configuration Data in the Vendor Parameter Set

Using this procedure, add code to save the filter configuration data in the vendor parameter set.

To save the filter configuration data in the vendor parameter set

  1. Add the following function to store the values in the filter's vendor parameter set:
    HRESULT PutVendorData(FPCLib::IFPCApplicationFilterPtr spiApplicationFilter,
                    const _bstr_t& bsVirusString,
                    const _bstr_t& bsPrefixString,
                    const _bstr_t& bsFilterIPAddress)
{
    HRESULT hr = S_OK;
    FPCLib::IFPCVendorParametersSetsPtr spIFPCVendorParametersSets;
    FPCLib::IFPCVendorParametersSetPtr spIFPCVendorParametersSet;

    try
    {
        spIFPCVendorParametersSets = spiApplicationFilter->VendorParametersSets;

        try
        {
            spIFPCVendorParametersSet = spIFPCVendorParametersSets->Item(_bstr_t(PARAM_SET_GUID));
        }
        catch(_com_error&)
        {
            //Create a new parameter set
            spIFPCVendorParametersSet = spIFPCVendorParametersSets->Add(_bstr_t(PARAM_SET_GUID),VARIANT_FALSE);

            spIFPCVendorParametersSets->Save();
        }

        spIFPCVendorParametersSet->Value[_bstr_t("VirusString")]   = bsVirusString;
        spIFPCVendorParametersSet->Value[_bstr_t("PrefixString")]  = bsPrefixString;
        spIFPCVendorParametersSet->Value[_bstr_t("Filter IPAddress")] = bsFilterIPAddress;
        spIFPCVendorParametersSet->Save();

    }
    catch(_com_error& err)
    {
        return err.Error();
    }

    return S_OK;
}
  2. You need to add a function that will call PutVendorData with the values from ISA Server Management. To implement this function, override the OnApply method of the CSnapInPropertyPageImpl class. This method is called whenever you click the Apply or OK buttons. Add the following code to your class:
        // This member function is called when the user clicks the OK or the Apply button.
    virtual BOOL OnApply()
    {
        HRESULT hr;
        // _bstr_t bsVirusString, bsPrefixString;
        char sVirusString[100], sPrefixString[100];

        ::GetWindowTextA (::GetDlgItem (m_hWnd, IDC_VIRUS_STRING),
                            reinterpret_cast <char *> (&sVirusString),
                            100);

        ::GetWindowTextA (::GetDlgItem (m_hWnd, IDC_PREFIX_STRING),
                             reinterpret_cast <char *> (&sPrefixString),
                            100);

        hr = ::PutVendorData (m_spiApplicationFilter,
                    _bstr_t(sVirusString),
                    _bstr_t(sPrefixString));

        return TRUE;
    }
  3. Build.


How to Create a Context-Sensitive Menu Extension [ISA Server 2004]

How to Create a Context-Sensitive Menu Extension

The ISA Server Software Development Kit (SDK) includes a sample that extends ISA Server Management by adding a context sensitive menu. The sample files are in the serversconfig directory, under the samples/admin/mmc_extensions directory in the SDK. The sample adds a menu to the servers node in ISA Server Management, and by clicking on the node you can see all the adapters for each server in the array.

This section contains the following topics:

  • Building the Context-Sensitive Menu Sample
  • Context-Sensitive Menu Sample Steps
  • Remote Administration Installation


Building the Context-Sensitive Menu Sample [ISA Server 2004]

Building the Context-Sensitive Menu Sample

The sample is included in the samples folder of the SDK, in the folder serversconfig. To build the sample take the following steps.

To build the context-sensitive menu included in the SDK

  1. Open Microsoft Visual Studio®.
  2. Open the sample workspace, serversconfigsample.dsw.
  3. To see the project files, select the View menu, and then the workspace.
  4. Press the F7 key to build the sample.

This will create the necessary dynamic-link library (DLL). When you register this DLL, you can see the menu when you right click on the servers node in ISA Server Management and select "view adapters".


Context-Sensitive Menu Sample Steps [ISA Server 2004]

Context-Sensitive Menu Sample Steps

To show the context sensitive menu, the sample traverses all the servers in the array, retrieving all the adapters. The information about the adapters on each server is obtained through the administration COM objects. This sample retrieves information about the servers in the array through the IFPCServers and IFPCServer interfaces, and information about the adapters is retrieved through the IFPCAdapter and IFPCAdapters interfaces.

The sample takes the following steps:

  1. Retrieves each server in the array.
  2. Lists all the adapters on each server.
  3. Displays all the adapters.


Retrieving Each Server in the Array [ISA Server 2004]

Retrieving Each Server in the Array

The following code retrieves and stores each server and adapter. This code is taken from the file AdapterList.cpp, included in the serversconfig directory.

  1. Create the tree that stores the server and adapter information, shown here:
        /* Make the root of the tree */
    HTREEITEM RootItem = m_ListTree.InsertItem( _T("All Servers"), 0, 0);
    HTREEITEM ServItem;

    /* Make headlines */
    m_ListCtl.InsertColumn( 0, _T("Server Name") );
    m_ListCtl.InsertColumn( 1, _T("Adapter Description") );

    m_ListCtl.SetColumnWidth( 0, LVSCW_AUTOSIZE_USEHEADER );
    m_ListCtl.SetColumnWidth( 1, LVSCW_AUTOSIZE_USEHEADER);
  2. Find each server in the array, shown here:
        /* Go along the hierarchy to find the all the servers */
    /* and their adapters                                 */
    FPCLib::IFPCSnapinNodePtr spiFPCSnapinNode(m_pDataObject);
    FPCLib::IFPCServersPtr spiServers(spiFPCSnapinNode->CurrentObject);


Listing the Adapters [ISA Server 2004]

Listing the Adapters

Now that each server has been retrieved, the names of each adapter must be retrieved. This code is taken from the file AdapterList.cpp, included in the serversconfig directory.

The code will loop through all the servers in the array, then find all adapters on each server. The names of each are stored, as shown. Each adapter stored in this list will be displayed in the menu.

  1. Find the number of servers in the array. Here the number of servers is being retrieved by using the Count property of the FPCServer administration COM object.
        int Servnum = spiServers->Count;
    int index,index2,LineNumber=0;
    VARIANT ItemNum;
  2. Loop through all servers in the array, and find all adapters on each server. Here is where the code uses the administration objects Adapters and FPCServer to retrieve information about the adapters.
        /* Loop on all the servers */
    for (index=1;index<=Servnum;index++)
    {
        ItemNum.vt = VT_I4;
        ItemNum.lVal =  index;
        FPCLib::IFPCServerPtr spiServer(spiServers->Item(ItemNum));
        _bstr_t name = spiServer->Name;
        FPCLib::IFPCAdaptersPtr spiAdapterList(spiServer->Adapters);

        int AdapNum = spiAdapterList->Count;

        /* Make a node for this server */
        ServItem = m_ListTree.InsertItem( name, 0, 0,RootItem);

        /* Loop on all the adapters */
        for (index2=1;index2<=AdapNum;index2++)
        {
            FPCLib::IFPCAdapterPtr spiAdapter(spiAdapterList->Item(index2));
            _bstr_t Desc = spiAdapter->Description;

            /* Make a line for every adapter */
            m_ListTree.InsertItem( Desc, 0, 0,ServItem);
            m_ListCtl.InsertItem( (LineNumber), _T(""));
            m_ListCtl.SetItemText((LineNumber),0, name );
            m_ListCtl.SetItemText((LineNumber),1, Desc);
            LineNumber++;

        }

    }


Displaying the Adapters [ISA Server 2004]

Displaying the Adapters

The following code works with the MMC console to show the adapters. This code is taken from the file Adapters.cpp in the sample directory, is written by the Active Template Library (ATL) object wizard and is used at the start of development.

To use the ATL object wizard

  1. Open Microsoft Visual C++.
  2. Click New ATL Object on the Insert menu.
  3. Select MMC Snapin from the Objects list.
  4. Click Next.
  5. Type Adapters in the ShortName box on the Names tab.
  6. Select the Extension and IExtendcontextmenu check boxes on the MMC Snapin tab. (Be sure to leave IComponentData, IComponent, and ISnapInAbout checked.).
  7. Clear the Support Persistence check box.
  8. On the MMC Snapin tab, in the Extends Node box, select the node you want to extend(servers).

The wizard produces the following code.

HRESULT CAdaptersData::Notify( MMC_NOTIFY_TYPE event,
    long arg,
    long param,
    IComponentData* pComponentData,
    IComponent* pComponent,
    DATA_OBJECT_TYPES type)
{
    // Add code to handle the different notifications.
    // Handle MMCN_SHOW and MMCN_EXPAND to enumerate child items.
    // In response to MMCN_SHOW you must enumerate both the scope
    // and result-pane items.
    // For MMCN_EXPAND you only need to enumerate the scope items
    // Use IConsoleNameSpace::InsertItem to insert scope pane items
    // Use IResultData::InsertItem to insert result pane item.
    HRESULT hr = E_NOTIMPL;

    _ASSERTE(pComponentData != NULL || pComponent != NULL);

    CComPtr<IConsole> spConsole;
    CComQIPtr<IHeaderCtrl, &IID_IHeaderCtrl> spHeader;
    if (pComponentData != NULL)
        spConsole = ((CAdapters*)pComponentData)->m_spConsole;
    else
    {
        spConsole = ((CAdaptersComponent*)pComponent)->m_spConsole;
        spHeader = spConsole;
    }

    switch (event)
    {
    case MMCN_SHOW:
        {
            CComQIPtr<IResultData, &IID_IResultData> spResultData(spConsole);
            // TODO : Enumerate the result pane items
            hr = S_OK;
            break;
        }
    case MMCN_EXPAND:
        {
            CComQIPtr<IConsoleNameSpace, &IID_IConsoleNameSpace> spConsoleNameSpace(spConsole);
            // TODO : Enumerate scope pane items
            hr = S_OK;
            break;
        }
    case MMCN_ADD_IMAGES:
        {
            // Add Images
            IImageList* pImageList = (IImageList*) arg;
            hr = E_FAIL;
            // Load bitmaps associated with the scope pane
            // and add them to the image list
            // Loads the default bitmaps generated by the wizard
            // Change as required
            HBITMAP hBitmap16 = LoadBitmap(_Module.GetResourceInstance(), MAKEINTRESOURCE(IDB_ADAPTERS_16));
            if (hBitmap16 != NULL)
            {
                HBITMAP hBitmap32 = LoadBitmap(_Module.GetResourceInstance(), MAKEINTRESOURCE(IDB_ADAPTERS_32));
                if (hBitmap32 != NULL)
                {
                    hr = pImageList->ImageListSetStrip((long*)hBitmap16,
                    (long*)hBitmap32, 0, RGB(0, 128, 128));
                    if (FAILED(hr))
                        ATLTRACE(_T("IImageList::ImageListSetStrip failed\n"));
                }
            }
            break;
        }
    }
    return hr;
}


Remote Administration Installation [ISA Server 2004]

Remote Administration Installation

A user may choose to install only the administration components of ISA Server on a particular computer, thereby creating a remote administration computer for ISA Server. That computer will provide the administrator with ISA Server Management, but will not include ISA Server engine components.

If your filter includes user interface elements, you should provide an administration component installation option. The administrator will then be able to install only the administrator's user interface for your filter to the administration computer, and install the filter itself to ISA Server computers.

If you create scripts that will run on a remote administration computer, you should create the root object by using the FPCDS object, rather than the FPC object. For more information, see FPC Object and Creating the Root ISA Server Object.


Appendices [ISA Server 2004]

Appendices

This section contains additional reference materials related to the Microsoft Internet Security and Acceleration Server 2004 Software Development Kit (SDK).

The ISA Server reference section contains the following topics:

  • Error Codes
  • Globally Unique Identifiers
  • Glossary


Error Codes [ISA Server 2004]

Error Codes

The following are the run-time error codes, defined in Wspfwerr.h, that may be returned by the Microsoft Firewall service.

Symbolic name | Message ID | Message text
FWX_E_TERMINATING | 0xC0040001 | The object is shutting down.
FWX_E_INVALID_ARG | 0xC0040002 | The argument is invalid.
FWX_E_ALREADY_IN_BLOCKING_OP | 0xC0040003 | The blocking operation is already started.
FWX_E_NOT_IN_BLOCKING_OP | 0xC0040004 | There is no blocking operation to be ended.
FWX_E_FILTER_NOT_REGISTERED | 0xC0040005 | The filter is not registered.
FWX_E_ALREADY_EXISTS | 0x800700B7 | The object cannot be created because an object with the same name already exists.
FWX_E_BUFFERFULL | 0xC0040007 | Not all the data was appended to the buffer object because the buffer was full.
FWX_E_ALREADY_EMULATED | 0xC0040009 | The connection is already emulated by another filter.
FWX_E_BAD_CONTEXT | 0xC004000A | The method was not called while handling any of the supported events.
FWX_E_NOT_SUPPORTED | 0xC004000B | Modifying this property is not allowed for this session.
FWX_E_NOT_AUTHENTICATED | 0xC004000C | The action cannot be performed because the session is not authenticated.
FWX_E_POLICY_RULES_DENIED | 0xC004000D | The policy rules do not allow the user request.
FWX_E_MIME_NEEDED | 0xC004000E | The MIME type is required.
FWX_E_MUST_USE_DS | 0xC004000F |
FWX_E_NOT_EMULATED | 0xC0040010 | The connection is not emulated.
FWX_E_IS_BUSY | 0xC0040011 |
FWX_E_NETWORK_RULES_DENIED | 0xC0040012 |
FWX_E_FRAGMENT_PACKET_DROPPED | 0xC0040013 |
FWX_E_FWE_SPOOFING_PACKET_DROPPED | 0xC0040014 |
FWX_E_TCPIPDROP_PACKET_DROPPED | 0xC0040015 |
FWX_E_NO_BACKLOG_PACKET_DROPPED | 0xC0040016 |
FWX_E_TCP_NOT_SYN_PACKET_DROPPED | 0xC0040017 |
FWX_E_BAD_LENGTH_PACKET_DROPPED | 0xC0040018 |
FWX_E_PING_OF_DEATH_PACKET_DROPPED | 0xC0040019 |
FWX_E_OUT_OF_BAND_PACKET_DROPPED | 0xC004001A |
FWX_E_IP_HALF_SCAN_PACKET_DROPPED | 0xC004001B |
FWX_E_LAND_ATTACK_DROPPED | 0xC004001C |
FWX_E_UDP_BOMB_DROPPED | 0xC004001D |
FWX_E_FULLDENY_DROPPED | 0xC004001E |
FWX_E_IPOPTIONS_DROPPED | 0xC004001F |
FWX_E_UNCOMPLETED_CONNECTION_REQUEST | 0xC0040020 | An attempt to log on to the VPN server was rejected during the authentication phase because the authentication data was not received in a timely manner. The client session was disconnected.
FWX_E_CONNECTION_REQUEST_REJECTED | 0xC0040021 | An attempt to log on to the VPN server was rejected during the authentication phase. The client session was disconnected.
FWX_E_VALIDATE_QUARANTINE_FAILED | 0xC0040022 | The VPN quarantine settings could not be validated. The client session was disconnected.
FWX_E_VPN_CONNECTIONS_LIMIT_EXCEEDED | 0xC0040023 | The VPN client connection limit was exceeded. The client session was disconnected.
FWX_E_OUT_OF_RESOURCES | 0xC0040024 |
FWX_E_BROADCAST_PACKET_DROPPED | 0xC0040025 |
FWX_E_UNKNOWN_ADAPTER_DROPPED | 0xC0040026 |
FWX_E_ICMP_ERROR_PACKET_DROPPED | 0xC0040027 |
FWX_E_INVALID_PROTCOL_PACKET_DROPPED | 0xC0040028 |
FWX_E_PORT_ZERO_PACKET_DROPPED | 0xC0040029 |
FWX_E_SYN_ATTACK_START | 0xC004002A | ISA Server detected a SYN attack.
FWX_E_SYN_ATTACK_END | 0xC004002B | ISA Server is no longer experiencing a SYN attack.
FWX_E_INVALID_DHCP_OFFER | 0xC004002C |
FWX_E_UNREACHABLE_ADDRESS | 0xC004002D |
FWX_E_ADDRESS_NOT_ALLOWED | 0xC004002E |
FWX_E_IPSEC_NO_ROUTE_DROPPED | 0xC004002F |
FWX_E_OUTBOUND_PATH_THROUGH_DROPPED | 0xC0040030 |
FWX_E_BAD_TCP_CHECKSUM_DROPPED | 0xC0040031 |
FWX_E_VPN_USER_MAPPING_FAILED | 0xC0040032 | An attempt to map a VPN client to a Windows user failed. The client session was disconnected.
FWX_E_RULE_QUOTA_EXCEEDED_DROPPED | 0xC0040033 | A connection was rejected because the maximum number of connections that can be created for a rule during one second was exceeded.


Globally Unique Identifiers [ISA Server 2004]

Globally Unique Identifiers

ISA Server supports MMC-like extension snap-ins. The following table lists the ISA Server snap-in nodes, their globally unique identifiers (GUIDs), and some properties of the FPCSnapinNode object for each node.

The Fpcnodesguids.h header file, which can be found in the Inc folder under the SDK folder on the ISA Server 2004 CD, defines symbolic names for the GUIDs. For more information on creating MMC snap-in extensions for ISA Server Management, see Extending ISA Server Management.

Node | GUID | Property of FPCSnapinNode
 |  | ParentArray | ParentPolicy | CurrentObject
Root scope | 43E06AFC-729B-49AB-8BC2-33A9E35BB12D | N/A | N/A | E_NOINTERFACE
Array scope | 41223021-4684-4CF4-BD24-4AD71FFC4445 | N/A | N/A | E_NOINTERFACE
Firewall policy scope | CAB89263-C55E-4492-958B-C24723083320 | N/A | N/A | E_NOINTERFACE
Policy rule item | 9F1DBD83-12D1-408C-BD4C-6A5EFE4866D1 | The containing array | N/A | FPCPolicyRule
Policy rules collection array | 904AF5AB-43A5-4D91-973F-EA36A801C2C6 | The containing array | N/A | FPCPolicyRules
Policy rules collection system | 9ABAD875-A653-4DC1-9997-8713A9DE01AD | The containing array | N/A | FPCPolicyRules
VPN scope | EB601D5F-8909-48DB-8FA8-CCAD1BA895DD | N/A | N/A | E_NOINTERFACE
VPN site-to-site networks collection | BD325A51-DB15-4730-A414-E0486350DCB8 | N/A | N/A | E_NOINTERFACE
Configuration scope | 7A461DD2-311D-43F9-8686-E9CB4E230309 | N/A | N/A | E_NOINTERFACE
Add-ins scope | DF766C48-C4FF-4AB5-AD91-077DDDEA44BA |  |  | E_NOINTERFACE
Application filter item | 4A5749E9-FC71-4BD9-9E44-F7F76D0BE1B8 | The containing array | N/A | FPCApplicationFilter
Web filter item | 0828ADE3-80DD-49E1-A2B5-ECCE1174B349 | The containing array | N/A | FPCWebFilter
Network scope | 57E67A24-4EBC-4F39-B295-BB427CDB370B | N/A | N/A | E_NOINTERFACE
Address translation rule | 92C518D8-776C-4379-B725-DFC5C7C067A3 | N/A | N/A | E_NOINTERFACE
Web routing rule item | 7E735B2B-2B2F-484E-B186-F13C8C60E8D6 | The containing array | N/A | FPCRoutingRule
General scope | B9FE792D-76C3-4AEA-847F-BA661AC28AD1 | N/A | N/A | E_NOINTERFACE
Network item | 42AAB0B5-19B7-4229-AE54-2B479CE985F2 | The containing array | N/A | FPCNetwork
Network set item | 078CE6B5-EEC0-4DA7-80F5-85DB0D5C4021 | The containing array | N/A | FPCNetworkSet
Computer item | 586B984B-C983-47D6-B77A-84CC58BC40D2 | The containing array | N/A | FPCComputer
Computer set item | AE2F45D2-FA44-46CD-85DF-9B5E9BA1E8C7 | The containing array | N/A | FPCComputerSet
Address range item | C4D2C0A8-51BD-4E32-9CC6-18ECA6D3B66F | The containing array | N/A | FPCAddressRange
Subnet item | 817559CA-6DF6-4C43-A7A4-121650F0A6A3 | The containing array | N/A | FPCSubnet
URL set item | A2F94302-CF4D-4F3F-B2F6-3970E5D711FF | The containing array | N/A | FPCURLSet
Domain name set item | 7271654B-5017-4BC0-A577-182767B60E67 | The containing array | N/A | FPCDomainNameSet
Web listener item | 12A7CCB5-2FAA-4BE7-B756-52626FFB7AD7 | The containing array | N/A | FPCWebListener
Schedule item | 258D4A4B-F468-446C-A90A-2A0F854AE424 | The containing array | N/A | FPCSchedule
Protocol item | C7B10495-1501-467F-9320-BB7322855259 | The containing array | N/A | FPCProtocolDefinition
User set item | E0EB0239-C4B7-4500-A273-DCF7E708098D | The containing array | N/A | FPCUserSet
Content type item | 69050B0D-45F4-4BE0-B924-8943B8C00C6A | The containing array | N/A | FPCContentTypeSet
Cache scope | 16DCA601-E902-4655-8BCB-443B76696C01 | N/A | N/A | E_NOINTERFACE
Scheduled content download item | 4C2B4D2C-E563-42DF-A1C2-F8ACA98A70C9 | The containing array | N/A | FPCScheduledContentDownloadConfig
Cache drive item | A122ABEC-4808-41BF-801E-710E2205475F | The containing array | N/A | FPCCacheDrive
Cache rule item | BF5E43AA-D056-416B-98E0-CF088F3DBB2B | The containing array | N/A | FPCCacheRule
Monitoring scope | 1FC3773B-C941-450C-BA39-224904EFD093 | N/A | N/A | E_NOINTERFACE
Dashboard alerts collection | 69039453-E693-4058-8271-1F126C6E27A1 | N/A | N/A | E_NOINTERFACE
Dashboard signaled alert item | DBB8D29F-C42F-46EA-B822-7C0FD38E3F52 | N/A | N/A | E_NOINTERFACE
Dashboard sessions collection | 42D4AF87-DC29-478B-9038-7CCE0835FB8B | N/A | N/A | E_NOINTERFACE
Dashboard session item specific type | 1A567C24-8038-4641-9797-686298FFEADE | N/A | N/A | E_NOINTERFACE
Dashboard session item per server | 7ACD4220-8DAB-4516-963D-D61596795BDD | N/A | N/A | E_NOINTERFACE
Dashboard services collection | 5C4E04FA-247A-4668-992A-10060D1F5BE7 | N/A | N/A | E_NOINTERFACE
Dashboard service item | A0F0ADBF-4A08-4F68-82FD-E2C6F3DB86D6 | N/A | N/A | E_NOINTERFACE
Services collection | A271438E-34C6-4EB6-AAF7-4F8FD2C74C95 | N/A | N/A | E_NOINTERFACE
Service item | 1F4F4D72-A437-48ED-8752-C4887636A22D | N/A | N/A | E_NOINTERFACE
Sessions collection | 8427D867-2452-4B04-AFA2-B92508448553 | The containing array | N/A | FPCSessionsMonitor
Session item | AE05C0A9-5A8A-4369-9E43-FDBE82C79A55 | The containing array | N/A | FPCSessionsMonitorEntry
Log entry item | 4F74641C-77C2-40B1-94D2-9AC8851B591E | The containing array | N/A | FPCLogEntry
Logging collection | FBDEC32D-461A-4575-9784-076F3C68EFD9 | The containing array | N/A | FPCLogContent
Alerts collection | B918D0BC-FD24-4456-824F-2F373DFBD919 | The containing array | N/A | FPCAlerts
Signaled alert item | 7F3AD8C8-41E3-457F-87F6-C6EC763BEBF5 | The containing array | N/A | FPCSignaledAlert
Signaled alert instance item | 3626144A-2A79-4208-A34A-22B0D4F24F61 | The containing array | N/A | FPCSignaledAlertInstance
Ready reports collection | 6B93E94B-48B0-4861-9D12-1B3798AE587D | The containing array | N/A | FPCReadyReports
Ready report tab item | 6203AFBC-5A1B-402C-BA04-FFDF8143C3EE | The containing array | N/A | FPCReadyReport
Dashboard ready report item | B4BBEB5D-EB3A-4424-A9C8-717A240AAEFF | N/A | N/A | E_NOINTERFACE
Dashboard reports collection | 2B080CE8-2F95-4A9B-9A61-EA0ED7EC43C8 | N/A | N/A | E_NOINTERFACE
Connectivity collection | 005897FC-4F23-4EFA-807B-EE745B9AE6DD | The containing array | N/A | FPCConnectivityResults
Connectivity item | 3D2447C5-C3E8-4D9D-9F29-1B2EA7906586 | The containing array | N/A | FPCConnectivityResult
Dashboard connectivity collection | 8ECCDC5F-878A-466E-B260-8F3FB7C23D86 | N/A | N/A | E_NOINTERFACE
Dashboard connectivity item | 4709BA24-94AC-4634-8D3A-26D77B4C1AEE | N/A | N/A | E_NOINTERFACE


Glossary [ISA Server 2004]

Glossary

This glossary defines some of the terms found in the documentation for Internet Security and Acceleration Server 2004. Click a letter to jump to that section of the glossary, or use your browser's Find command to search for a word across the entire glossary.

A B C D E F G H I J K L M N O P Q R S T U V W X Y Z


A [ISA Server 2004]

A

A B C D E F G H I J K L M N O P Q R S T U V W X Y Z

access control list (ACL)
A level of permission that can be set on a file or a directory allowing specified users access within an NTFS directory. An access control entry (ACE) is an entry in the list.
ACL
See access control list (ACL).
active caching
A mechanism used to automatically initiate new requests to update cached file objects without user intervention. Requests can be activated based on the length of time an object has been cached or was last retrieved from the source location of the object. This type of caching can be used to ensure the freshness of specified data within the cache. See also passive caching.
address spoofing
See spoofing.
Advanced Digest authentication
An improved version of Digest authentication that is provided for user accounts stored in Active Directory in a Windows Server 2003 domain. With this method, user credentials are stored on domain controllers as an MD5 hash, rather than in a reversibly encrypted form, and cannot feasibly be recovered by anyone with access to a domain controller. See also Basic authentication and Integrated authentication.
alerting
A feature that notifies administrators about suspicious network events, such as rejected packets, protocol violations, and a full hard disk. Alerts can log events to the system event log, run a specified command line, send an SMTP e-mail message to specified recipients, and stop or start specified ISA Server services.
API
See application programming interface (API).
application filter
A firewall extension that registers for and processes events related to connection with another network. Application filters are typically designed to enhance the security provided by a firewall by excluding or modifying data that approaches the network.
application gateway
Computer software intended to maintain security on a secluded network yet allow certain traffic to go between the private network and the outside world. See also firewall.
application programming interface (API)
A set of routines used by an application to direct the performance of procedures by a computer's operating system.
array
An administrative unit that provides access to the ISA Server configuration settings that are contained in the hierarchy of administration COM objects for an ISA Server computer. Each ISA Server computer is associated with a single array. In ISA Server 2004 Standard Edition, an array contains a single ISA Server computer.
array member
An ISA Server computer that is associated with an array.
asynchronous I/O
A feature that allows some input/output (I/O) functions to return immediately, even though an I/O request is still pending. Asynchronous I/O enables an application to continue with other processing and wait for the I/O to be completed at a later time. Asynchronous I/O is also called overlapped I/O.
authentication
Validation of a user's logon information to determine permission to access a resource or perform an operation. See also Basic authentication, Integrated authentication, Digest authentication, Advanced Digest authentication, and Microsoft Challenge Handshake Authentication Protocol (MS-CHAP).
autodial
A component of ISA Server that enables users to automatically connect to remote networks, such as the Internet, during predetermined times.


B [ISA Server 2004]

B

A B C D E F G H I J K L M N O P Q R S T U V W X Y Z

bandwidth
The data transfer capacity of a digital communications system.
bandwidth control
The practice of setting the maximum network capacity that a service is allowed to use. You can deliberately limit a server's workload by not allowing it to receive requests at full capacity, saving resources for other programs, such as e-mail.
Basic authentication
An authentication method that encodes the user name and password before transmitting them over the network. Basic authentication is also called clear-text authentication because the encoding (base-64) can be decoded by anyone with a freely available decoding utility. Note that encoding is not the same as encryption. See also Digest authentication, Advanced Digest authentication, and Integrated authentication.
BIND service
See Domain Name System (DNS).
binding
A process that establishes the initial communication channel between the protocol driver and the network adapter driver.
bitmask
A numeric value intended for a bit-by-bit value comparison with other numeric values, typically to flag options in parameters or return values. Usually this comparison is done with bitwise logical operators, such as And and Or in Visual Basic, and ampersand (&) and pipe (|) in C++.
browser
An application for navigating and accessing information on either the Internet or an intranet.


C [ISA Server 2004]

C

A B C D E F G H I J K L M N O P Q R S T U V W X Y Z

cache
A store of frequently retrieved objects and URLs located on the cache drive of an ISA Server computer. Instead of retrieving an object directly from an Internet Web server, the object is stored and retrieved from the cache instead. Caches improve network performance by reducing the number of objects retrieved from the Internet based on their popularity.
cache drive
A cache drive is a hard disk partition where cached content is stored on an ISA Server computer that is configured for caching. Each cache drive is identified by its drive letter (C:, D:, etc.), and each cache drive has a limited amount of space, in megabytes, that can be allocated for caching.
certificate
See digital certificate.
CGI
See Common Gateway Interface (CGI).
chaining
A method to link multiple ISA Server computers together for routing requests among them. Communication is in an upstream, hierarchical order.
challenge/response
See Microsoft Challenge Handshake Authentication Protocol (MS-CHAP).
clear text
See Basic authentication.
COM object
A programming structure that includes both data and functionality. A COM object is defined and allocated as a single unit. The only public access to a COM object is through the programming structure's interfaces. At a minimum, a COM object must support the IUnknown interface, which maintains the object's existence while it is being used and provides access to the object's other interfaces.
Common Gateway Interface (CGI)
A standard interface for HTTP server applications. It is used by an application that runs on a server to generate dynamic content based on parameters sent by the requesting Web browser.
completion port
See I/O completion port.
connection object
In application filters, a COM object that implements the IFWXConnection interface and represents a single connection within the Microsoft Firewall service.
credentials
An authentication method used to validate client-to-server and server-to-server communication. Credentials include a user name and a password that is used to validate requests from client computers or from other computers in an array or chain.


D [ISA Server 2004]

D

A B C D E F G H I J K L M N O P Q R S T U V W X Y Z

DACL
See discretionary access control list (DACL).
data filter
A component of an application filter that monitors content, as in a check for viruses, and that can also modify content.
data filter object
In application filters, a COM object that implements the IFWXDataFilter interface.
data packet
A sequence of binary digits, including data and control signals, that is transmitted and switched as a composite whole. The data, control signals, and, possibly, error control information are arranged in a specific format.
data source name (DSN)
The logical name that allows a connection to an Open Database Connectivity (ODBC) data source, such as a SQL Server database.
demand-dial connections
A process used by autodial to perform on-demand outgoing connections either to an Internet service provider or to a corporate office from a branch office.
DHCP
See Dynamic Host Configuration Protocol (DHCP).
Digest authentication
An authentication method for HTTP clients, in which an encrypted digest or hash of the user’s credentials and additional data is created in a process known as hashing. This way, no other user can impersonate the original sender of the request. A hash cannot feasibly be decrypted to recover the original user name and password. Digest authentication can be used only in Windows Server 2003 and Windows 2000 domains for users who have an account stored in Active Directory. See also Basic authentication, Integrated authentication, and Advanced Digest authentication.
digital certificate
A digital document that is commonly used for authentication and secure exchange of information on open networks, such as the Internet, extranets, and intranets. A certificate securely binds a public key to the entity that holds the corresponding private key. Certificates are digitally signed by the issuing certification authority and can be issued for a user, a computer, or a service. The most widely accepted format for certificates is defined by the ITU-T X.509 version 3 international standard.
discretionary access control list (DACL)
A list that is controlled by the owner of an object and that specifies the access that particular users or groups can have to the object.
distributed caching
The caching of Internet objects in an array or chain of ISA Server computers, providing load balancing and fault tolerance. Client requests are sent through the array, to upstream ISA Server computers, or any combination thereof.
DNS
See Domain Name System (DNS).
DNS spoofing
See spoofing.
domain name
The computer name that substitutes for a network IP address. For example, www.microsoft.com is a computer name that represents the IP address 157.45.60.81. A computer name is also called a friendly name. See also Domain Name System (DNS).
Domain Name System (DNS)
A protocol and computer-naming hierarchy used throughout the Internet to map computer IP addresses to their domain names. DNS is sometimes referred to as the BIND service.
driver
A software component that allows a computer to send and receive information to and from a hardware device.
DSN
See data source name (DSN).
dynamic filters
Filters that are automatically started by the Microsoft Firewall service, Web proxy, or SOCKS proxy service. This feature allows the ISA Server services to automatically open and close communication ports on the external interface when transmission of packets is needed.
Dynamic Host Configuration Protocol (DHCP)
A protocol that offers dynamic assignment of IP addresses and related information for temporarily connected network users. DHCP provides safe, reliable, and simple TCP/IP network configuration, prevents address conflicts, and helps conserve the use of IP addresses through centralized management of address allocation.


E [ISA Server 2004]

E

A B C D E F G H I J K L M N O P Q R S T U V W X Y Z

encryption
The process of making information indecipherable to protect it from unauthorized viewing or use, especially during network transmission or when it is stored on a transportable magnetic medium.


F [ISA Server 2004]

F

A B C D E F G H I J K L M N O P Q R S T U V W X Y Z

FAT
See file allocation table (FAT).
fault tolerance
The ability of ISA Servers in a domain array to take over the responsibilities of a failed server.
file allocation table (FAT)
A table or list maintained by some operating systems to keep track of the status of various segments of disk space used for file storage. See also NTFS file system.
File Transfer Protocol (FTP)
The Internet standard protocol for transferring files between computers. FTP uses the Telnet and TCP protocols. The server requires a client to supply a logon user name and password before honoring requests.
filter
A means of excluding information that does not match a predefined set of specifications. See application filter.
filter object
In application filters, a COM object that implements the IFWXFilter interface. Every application filter must include a filter object. When the Microsoft Firewall service starts, it creates an instance of the filter object for each application filter that is installed on the ISA Server computer and enabled. All filter objects are destroyed when the Microsoft Firewall service shuts down.
firewall
A security system intended to protect an organization's network against external threats, such as hackers coming from another network, such as the Internet. See also application gateway.
firewall event
Any of several events that the Microsoft Firewall service triggers in response to occurrences of specific types.
Firewall service
See Microsoft Firewall service.
Firewall service completion port
See I/O completion port.
forward caching
Caching that is implemented for clients on the Internal network accessing servers on the Internet.
forward proxy
A Web proxy scenario where internal clients access the Internet.
FQDN
See fully qualified domain name (FQDN).
FTP
See File Transfer Protocol (FTP).
full proxy mode
A reverse proxy mode with source network address translation (NAT), in which the IP address of a client sending requests to a published server is translated to an IP address of the network adapter on the ISA Server computer that is connected to the network where the published server resides if there is a NAT network relationship between the source and destination networks.
fully qualified domain name (FQDN)
In TCP/IP, host names with their domain names appended to them. For example, a computer with host name zebra and domain name microsoft.com has an FQDN of zebra.microsoft.com. See also Domain Name System (DNS).


G [ISA Server 2004]

G

A B C D E F G H I J K L M N O P Q R S T U V W X Y Z

gateway
A device that routes data packets between multiple TCP/IP networks having dissimilar transport protocols. ISA Server can act as a gateway between an internal network (an intranet) and the public network (the Internet). See also router.
Generic Route Encapsulation (GRE)
A protocol that is used in conjunction with the Point-to-Point Tunneling Protocol (PPTP) to create virtual private networks (VPNs). After the PPTP control session has been established, GRE is used to encapsulate the data or payload in a secure manner.
globally unique identifier (GUID)
A 128-bit value that uniquely identifies objects such as OLE servers, interfaces, manager entry-point vectors, and client objects.
Gopher
A hierarchical system for finding and retrieving information from the Internet or an intranet. An enhanced version, Gopher Plus, returns more information about an item, such as file size, last date of modification, and the administrator's name. A display of all files available on a Gopher server is called the Gopherspace.
GRE
See Generic Route Encapsulation (GRE).
group
In a network, an account containing user accounts that are called members. The permissions and rights granted to a group are also provided to its members, making groups a convenient way to grant common capabilities to collections of user accounts. Groups are assigned unique names within a domain.
GUID
See globally unique identifier (GUID).


H [ISA Server 2004]

H

A B C D E F G H I J K L M N O P Q R S T U V W X Y Z

H.323 protocol
The International Telecommunications Union - Telecommunications (ITU-T) standard protocol for real-time multimedia communications and conferencing over packet-based networks.
hash
A mathematical algorithm used for routing client requests within an array or a chain. The result of the hash determines which specific ISA Server computer to send the client request.
header
In data packet communications, a specified number of bytes that precedes the actual data being transmitted. It identifies control information used to deliver, route, and process the data contents of a packet.
hierarchical caching
The forwarding of a client HTTP request from one ISA Server computer to another ISA Server computer upstream. The downstream (source) ISA Server computer forwards client requests that it cannot service from its own cache. Hierarchical caching uses upstream routing and is a subset of distributed caching.
host name
The name given to a computer that is part of a network domain and used for client authentication. Also called the computer name. See also fully qualified domain name (FQDN).
HTML
See Hypertext Markup Language (HTML).
HTTP
See Hypertext Transfer Protocol (HTTP).
Hypertext Markup Language (HTML)
A markup language derived from the Standard Generalized Markup Language (SGML). HTML is used to create a text document with formatting specifications that tells a software browser how to display the page or pages included in the document.
Hypertext Transfer Protocol (HTTP)
The client/server protocol used to access information about the Web.


I [ISA Server 2004]

I

A B C D E F G H I J K L M N O P Q R S T U V W X Y Z

IANA
See Internet Assigned Number Authority (IANA).
ICMP
See Internet Control Message Protocol (ICMP).
IIS
See Internet Information Services (IIS).
inbound access
The ability to send information from an external network, such as the Internet, to an internal or external network.
Integrated authentication
A secure form of authentication, where the user name and password are not sent across the network. Users are authenticated by using either the Kerberos V5 authentication protocol or its own challenge/response authentication protocol. See also Basic authentication, Digest authentication, and Advanced Digest authentication.
Integrated Services Digital Network (ISDN)
A dial-up connection to the Internet installed by your Internet service provider (ISP) or telephone company. An ISDN line can offer speeds up to 128,000 bits per second (bps) and must be installed at both the server site and the remote site.
interactive application
A program written in C, Perl, or as a Windows batch file. The user initiates the program by clicking a link in a hypertext document.
Internet Assigned Number Authority (IANA)
A regulatory organization that is responsible for the assignment and registration of the values of unique parameters for Internet protocols. These values include top-level domain names, IP addresses, port numbers, protocol and enterprise numbers, content types, content subtypes, character sets, and access types.
Internet Control Message Protocol (ICMP)
The Internet standard protocol subset of IP that handles control and error messages. Gateways use ICMP to send problem reports on packets back to the source that sent the packet.
Internet Information Services (IIS)
The Microsoft® Internet server feature designed for implementing and managing Web sites. Although IIS supports multiple protocols, it primarily transmits information in HTML pages by using HTTP. ISA Server integrates fully with IIS and Windows Server 2003.
Internet Protocol (IP)
The Internet standard routing protocol that defines the IP datagram as the unit of data transfer and provides the IP address scheme to route packets from one network location to another. IP includes the ICMP protocol. The Internet Protocol suite is often called Transmission Control Protocol/Internet Protocol (TCP/IP).
Internet Protocol security (IPSec)
A set of standards that are used to implement virtual private networks (VPNs). IPSec supports a tunnel mode, in which both the packet header and the payload are encrypted.
I/O completion port
A Windows construct that efficiently manages threads used for asynchronous input/output (I/O). An I/O completion port is created by the operating system at the request of the ISA Server.
IP
See Internet Protocol (IP).
IPSec
See Internet Protocol security (IPSec).
ISA Server Management
The interface tool used to manage ISA Server computers.
ISDN
See Integrated Services Digital Network (ISDN).


K [ISA Server 2004]

K

A B C D E F G H I J K L M N O P Q R S T U V W X Y Z

Kerberos
A network authentication protocol supporting authentication services.


L [ISA Server 2004]

L

A B C D E F G H I J K L M N O P Q R S T U V W X Y Z

L2TP
See Layer Two Tunneling Protocol (L2TP).
LAT
See local address table (LAT).
Layer Two Tunneling Protocol (L2TP)
An industry-standard Internet tunneling protocol that provides encapsulation for sending Point-to-Point Protocol (PPP) frames across packet-oriented media.
layered service provider (LSP)
A service that provides higher-level custom communication functions and relies on services provided by an underlying base provider. In ISA Server, the Firewall Client software is a layered service provider that extends Winsock 2 from the client to the ISA Server computer and uses the underlying base TCP/IP service provider to communicate with the ISA Server computer.
load balancing
A method to distribute client requests among ISA Server computers. If one ISA Server computer is unavailable, another server can accept the request, preventing an interruption in service.
local address table (LAT)
A table of all the IP address ranges on the ISA Server network in which a Firewall client resides. If Firewall client support is enabled for a specific network, all the IP address ranges included in that network are distributed to Firewall clients and stored locally. Firewall clients recognize IP addresses that are included in the IP address ranges in the LAT as local destinations that can be contacted directly. The LAT is updated periodically by ISA Server.
LSP
See layered service provider (LSP).


M [ISA Server 2004]

M

A B C D E F G H I J K L M N O P Q R S T U V W X Y Z

member server
A server that has been assigned to a domain but is not designated as either the primary domain controller (PDC) or the backup domain controller (BDC) within the assigned domain.
Microsoft Challenge Handshake Authentication Protocol (MS-CHAP)
A method of authentication in which a server uses Windows Server 2003 security to allow access to its resources.
Microsoft Firewall service
An API service used by ISA Server that inspects traffic along connections between source and destination computers in user mode to determine whether to allow or deny it based on rules that are associated with specific protocols. Traffic can be directed to extensions of the Firewall service, called application filters, for deeper inspection before allowing or denying it. The Firewall service also provides a DNS cache, connectivity monitoring, logging, network configuration detection, and automatic dialing.
Microsoft Management Console (MMC)
General, ISV-extensible common management console in Windows operating systems. The MMC console is a Windows-based multiple document interface (MDI) application. MMC provides no management behavior, but instead provides a common environment for snap-ins, which provide the actual management functionality.
MIME
See Multipurpose Internet Mail Extensions (MIME).
MMC
See Microsoft Management Console (MMC).
MS-CHAP
See Microsoft Challenge Handshake Authentication Protocol (MS-CHAP).
multihomed
A computer with network connections to multiple separate physical networks.
Multipurpose Internet Mail Extensions (MIME)
A way of configuring browsers to view files that are in multiple formats. MIME permits the exchanging of objects, different character sets, and multimedia in e-mail on different computer systems.


N [ISA Server 2004]

N

A B C D E F G H I J K L M N O P Q R S T U V W X Y Z

name resolution
The process of mapping a computer name (friendly name) into its corresponding numeric IP address.
namespace
A tree-formatted, ordered list of all the nodes available in the current tool. The display of the namespace is similar to a folder and directory structure on a hard drive. It is required for the Domain Name System (DNS) to work properly. The DNS namespace is hierarchical in nature and allows host names to be stated in absolute or relative terms. Absolute names, or fully qualified domain names (FQDNs), are defined from the root of the namespace and uniquely identify a node in the hierarchy. Relative names are represented relative to a name in the hierarchy.
NAT
See network address translation (NAT).
negative caching
The caching of HTTP error conditions associated with accessing a particular URL. If the URL is unavailable, the error response message can be cached and returned to subsequent clients that request the same URL.
NetBIOS
See network basic input/output system (NetBIOS).
network address translation (NAT)
The process that a computer forwarding packets uses to convert the IP addresses and TCP/UDP port numbers of packets from the private values that are used on the source network to public values that are recognized on the destination network. See also secure network address translation (SecureNAT).
network adapter
A hardware device that enables a computer to connect to a network. A network adapter in the form a card that can be inserted into a motherboard slot is sometimes called a network interface card (NIC).
network basic input/output system (NetBIOS)
An API that can be used by applications on a local area network (LAN). NetBIOS provides applications with a uniform set of commands for mapping input/output (I/O) operations into equivalent network operations.
Network News Transfer Protocol (NNTP)
The Internet standard protocol for posting, distributing, and reading network news messages posted among news groups on the Internet. Messages are posted to NNTP servers and are accessed by NNTP clients (newsreaders).
NNTP
See Network News Transfer Protocol (NNTP).
NTFS file system
An advanced file system that supports file system recovery, very large storage media, and object-oriented applications. NTFS also offers enhanced security over the older FAT file system.


O [ISA Server 2004]

O

A B C D E F G H I J K L M N O P Q R S T U V W X Y Z

ODBC
See Open Database Connectivity (ODBC).
Open Database Connectivity (ODBC)
An API that enables applications to access data from a variety of database systems.
overlapped I/O
See asynchronous I/O.


P [ISA Server 2004]

P

A B C D E F G H I J K L M N O P Q R S T U V W X Y Z

passive caching
In this type of service, data is cached and discarded entirely on the basis of object size, popularity, or time since the requested object was last updated in the cache. Frequently referred to as on-demand caching because all caching updates are user-initiated. See also active caching.
password authentication
See authentication.
ping
A TCP/IP utility that verifies connections to one or more remote computers by sending ICMP packets and listening for reply packets.
plug-in
A third-party application that is installed to extend and enhance the functionality of ISA Server.
Point-to-Point Protocol (PPP)
A communications protocol that allows a computer to connect to other computers over a standard dial-up telephone line using a high-speed modem.
Point-to-Point Tunneling Protocol (PPTP)
A networking protocol that enables remote users to access corporate networks securely across the Internet by dialing into an Internet service provider (ISP) or by connecting directly to the Internet. PPTP supports multiprotocol virtual private networks (VPNs). Because PPTP allows multiprotocol encapsulation, users can send any packet type over an IP network.
POP
See Post Office Protocol (POP).
popularity
A measure of the frequency with which objects or URLs are requested by client applications, such as Web browsers. See also cache.
port number
A number that identifies a certain Internet application with a specific connection. Ports are used in TCP to name the ends of logical connections that carry long-term conversations.
Post Office Protocol (POP)
A network protocol that permits a client computer to access e-mail on a server. Usually, this means that a POP3 server is used to allow a client computer to retrieve mail that an SMTP server is holding for it.
PPP
See Point-to-Point Protocol (PPP).
PPTP
See Point-to-Point Tunneling Protocol (PPTP).
protocol
Software that allows computers to communicate over a network. The Internet protocol is Transmission Control Protocol/Internet Protocol (TCP/IP).
proxy
A software program that connects a user to a remote destination through an intermediary gateway.
proxy client
A client computer that must use a proxy server to gain access to network services not directly supported for client usage.
proxy server
A computer that acts as a relay between remote servers and clients to intercept requests and process communications on behalf of proxy clients.
publishing
The process that allows computers remote from an ISA Server computer to publish to the Internet. Publishing includes reverse hosting and secure Web publishing.


Q [ISA Server 2004]

Q

A B C D E F G H I J K L M N O P Q R S T U V W X Y Z

QoS
See Quality of Service (QoS).
Quality of Service (QoS)
A set of quality assurance standards and mechanisms for data transmission.


R [ISA Server 2004]

R

A B C D E F G H I J K L M N O P Q R S T U V W X Y Z

RADIUS
See Remote Authentication Dial-In User Service (RADIUS).
RADIUS accounting
The user log on and log off accounting method used by the Remote Authentication Dial-in User Service (RADIUS) protocol. For more information see RADIUS Authentication and Accounting.
RADIUS authentication
The authentication method used by the Remote Authentication Dial-in User Service (RADIUS) protocol. For more information see RADIUS Authentication and Accounting.
Remote Authentication Dial-in User Service (RADIUS)
An industry-standard protocol that is used to transmit authentication, authorization, and configuration information between an ISA Server computer and an authenticating server, called a RADIUS server, with a database that stores user information. For more information see RADIUS Protocol
remote administration
The practice of administering a computer from another computer connected across the network.
remote procedure call (RPC)
A message-passing facility that allows a distributed application to call services available on various computers in a network. RPC is used during remote administration of computers.
remote socket
An external socket on the ISA server computer that listens to or connects to the Internet. The remote socket represents the client's internal socket.
reverse caching
Caching implemented for incoming requests to local Web servers from the Internet.
reverse hosting
The process by which any server sitting behind an ISA Server can publish to the Internet. See also secure Web publishing and publishing.
router
An intermediary device on a communications network that expedites message delivery.
routing
The process of forwarding packets to other routers. Routing is used with arrays to direct client requests for Internet objects. Routing is done in conjunction with arrays, chained ISA Server computers, or directly to the Internet.
Routing and Remote Access Service
A Microsoft-developed service that allows remote client computers running Microsoft dial-up networking, all Microsoft RAS clients, or any third-party PPP client to dial in to a network server (RAS server). RAS servers can also be configured to allow local client computers to dial out to servers outside an internal network.
RPC
See remote procedure call (RPC).


S [ISA Server 2004]

S

A B C D E F G H I J K L M N O P Q R S T U V W X Y Z

secure network address translation (SecureNAT)
The ISA Server extension of the Windows network address translation (NAT) feature. SecureNAT provides a degree of address transparency for networked clients. NAT substitutes a global IP address, valid on the Internet, for an internal IP address. ISA Server enhances the underlying Windows NAT functionality by enabling access control for FTP, Windows NetMeeting for H.323, and T-120 protocols. It also enables rerouting HTTP requests, which can then frequently be satisfied by a local cache. This enhancement greatly improves HTTP performance and lowers bandwidth requirements.
Secure Sockets Layer (SSL)
A protocol that supplies secure data communication through data encryption and decryption. SSL enables communications privacy over networks.
secure Web publishing
The process by which a server behind an ISA Server computer can publish to the World Wide Web (WWW) without compromising security. See also reverse hosting and publishing.
SecureNAT
See secure network address translation (SecureNAT).
security identifier (SID)
An identifier that is part of the access control entry (ACE).
server certificate
A digital certificate (SSL certificate) installed on a server and used by the server to authenticate itself to a client.
session filter object
In application filters, a COM object that implements an IFWXSessionFilter interface. A session filter object is created by an application filter for a specific session (client computer) when the Microsoft Firewall service raises a network event for which the application filter is registered.
SID
See security identifier (SID).
Simple Mail Transfer Protocol (SMTP)
An Internet standard protocol used for exchanging e-mail messages between SMTP servers on the Internet.
SMTP
See Simple Mail Transfer Protocol (SMTP).
snap-in
Software that makes up the smallest unit of console extension. One snap-in represents one unit of management behavior (for example, the event log viewer is a functional unit of management and thus a good candidate to become a snap-in). Technically, snap-ins are OLE InProc servers.
socket
A logical communications channel used by TCP/IP applications. Sockets are data structures created by using a combination of device IP addresses and reserved TCP/UDP port numbers to indicate connection and delivery service information. See also Windows Sockets (Winsock).
SOCKS
A protocol for traversing firewalls in a secure and controlled manner, made available to the public by the Internet Engineering Task Force (IETF).
source NAT
See full proxy mode.
spoofing
The practice of making a transmission appear to come from an authorized user. For example, in DNS spoofing, the DNS name of another system is assumed either by corrupting a name-service cache or by compromising a domain-name server for a valid domain.
SQL
See Structured Query Language (SQL).
SQL server
A server that uses the Structured Query Language (SQL) to query, update, and manage a relational database.
SSL
See Secure Sockets Layer (SSL).
SSL certificate
See digital certificate.
Structured Query Language (SQL)
A database query and programming language widely used for accessing data in, querying, updating, and managing relational database systems. See also SQL server.
subnet mask
A TCP/IP configuration parameter that extracts network and host configuration data from an IP address. This 32-bit value enables the recipient of IP packets to distinguish the network ID portion (domain name) of the IP address from the host ID (host name).


T [ISA Server 2004]

T

A B C D E F G H I J K L M N O P Q R S T U V W X Y Z

TCP
See Transmission Control Protocol (TCP).
TCP/IP
See Transmission Control Protocol/Internet Protocol (TCP/IP).
Telnet
The Internet standard protocol for remote terminal connection service. Telnet allows a user to interact with the remote computer as if the user was on a terminal directly connected to the remote computer.
Time to Live (TTL)
A standard field in a TCP/IP header that indicates an age-of-expiration value that is examined by receiving hosts. Data with active TTL values is maintained and forwarded on the network; data with expired TTL values is discarded.
Transmission Control Protocol (TCP)
The Internet standard transport protocol that provides the reliable, two-way connected service that allows an application to send a stream of data end-to-end between two computers across a network. The Internet protocol suite is often called TCP/IP.
Transmission Control Protocol/Internet Protocol (TCP/IP)
A family of networking protocols that allows computers with diverse hardware architectures and various operating systems to communicate across interconnected networks and the Internet. TCP/IP includes standards for how computers communicate and conventions for connecting networks and routing traffic. Every computer on the Internet supports TCP/IP.
TTL
See Time to Live (TTL).
tunneling
See Point-to-Point Tunneling Protocol (PPTP).


U [ISA Server 2004]

U

A B C D E F G H I J K L M N O P Q R S T U V W X Y Z

UDP
See User Datagram Protocol (UDP).
Uniform Resource Locator (URL)
The address of a resource on the Internet. URL syntax is in the form protocol://host/localinfo, where protocol specifies the means of returning the object, such as Hypertext Transfer Protocol (HTTP) or File Transfer Protocol (FTP); host specifies the remote location where the object resides; and localinfo is a string — often a file name — passed to the protocol handler at the remote location.
upstream routing
The routing of a response from one ISA Server computer to another ISA Server computer. A request from a client computer always flows upstream to ISA Server computers until the requested item is found, whether it is in the cache of an ISA Server computer or from the Internet. ISA Server sends the response downstream to the client computer.
URL
See Uniform Resource Locator (URL).
User Datagram Protocol (UDP)
A standard transport protocol in TCP/IP networking that provides connectionless service for unacknowledged delivery of packets. UDP adds port addresses to the service provided by IP.


V [ISA Server 2004]

V

A B C D E F G H I J K L M N O P Q R S T U V W X Y Z

virtual private network (VPN)
A network that is constructed using public systems such as the Internet but uses security mechanisms to ensure privacy and that only authorized users are allowed access.
VPN
See virtual private network (VPN).


W [ISA Server 2004]

W

A B C D E F G H I J K L M N O P Q R S T U V W X Y Z

Web filter
Filters that can monitor, evaluate, and intercept HTTP communication between ISA Server clients and the Internet. Web filters are similar in functionality to ISAPI filters that work with Internet Information Services (IIS).
Windows challenge/response authentication
See Microsoft Challenge Handshake Authentication Protocol (MS-CHAP).
Windows Internet (WinINet) API
A collection of functions contained in Wininet.dll that simplifies client access to the Internet by way of HTTP, FTP, and Gopher.
Windows Internet Name Service (WINS)
A name resolution service that runs on Windows Server 2003. WINS maps friendly names to IP addresses. A WINS server handles name registrations, queries, and releases. See also Domain Name System (DNS).
Windows NTFS file system (NTFS)
See NTFS file system.
Windows Script Host
A language-independent scripting host for 32-bit Microsoft Windows operating system platforms that enables scripts to be executed directly on the Windows desktop or command console, without the need to embed those scripts in an HTML document.
Windows Sockets (Winsock)
A Windows implementation of the widely used University of California-Berkeley Sockets API. Winsock is a networking API used to create TCP/IP-based sockets applications. Winsock provides interfaces between applications and the transport protocol and works as a bidirectional connection for incoming and outgoing data. See also socket.
WinINet
See Windows Internet (WinINet) API.
WINS
See Windows Internet Name Service (WINS).
Winsock
See Windows Sockets (Winsock).


Topic Not Found

Topic Not Found

No matching topic was found. Some possible reasons and remedies are as follows:

  • The file (.chm) that contains the destination topic is not in the expected location.

    Remedy: Rerun the MSDN Library Setup.

  • The file (.chm) that contains the current topic or destination topic is out-of-date and the link is no longer valid.

    Remedy: Install the latest version of the MSDN Library.

  • The MSDN Library CD is not in the CD-ROM drive.

    Remedy: Insert the MSDN Library CD into the CD-ROM drive.