About Script Blocking options

Choose from these options to customize the automatic Script Blocking feature of Norton AntiVirus. The "recommended" options for this feature provide maximum protection against malicious scripts.

If you are developing or debugging scripts, disable Script Blocking. Otherwise this feature might block the script that you are developing

If Script Blocking is not enabled, the How to respond options are unavailable.

How to stay protected from malicious scripts

Enable Script Blocking (recommended): Turns Script Blocking on or off. You should have Script Blocking turned on at all times to continuously protect your computer from malicious scripts.

How to respond when a malicious script is found

Ask me what to do (recommended): Alerts you when Script Blocking finds a potentially malicious activity in a script file and displays the name of the script file. The alert asks you if you want to stop the script, allow the script activity to run once, allow the entire script to run once, quarantine the script, or authorize the script to run without further alerts.

Stop all suspicious activities and do not prompt me: Automatically prevents all scripts from running when Script Blocking detects a potentially malicious activity within the script. You are not prompted to take any action.

More Information

Script Blocking stops script-based viruses


Script Blocking Status

Script Blocking monitors script-based viruses and alerts you of virus-like malicious behavior, stopping these viruses before they can infect your computer.

Enable Script Blocking and set what Norton AntiVirus should do if it finds a malicious script.

More Information


Script Blocking stops script-based viruses

A script is a program that is written with a scripting language, such as Visual Basic Script or JavaScript and can be executed without user interaction. Scripts can be opened with text editors or word processing programs, so that they are very easy to change.

Scripts can be used when you log on to the Internet, or check your email. Restarting your computer involves using scripts that tell your computer what programs to load and run.

A script can also be written to perform malicious activities when it is launched. You can unknowingly receive a malicious script by opening an infected document or email attachment, viewing an infected HTML email message, or visiting an infected Internet Web site.

Script Blocking detects Visual Basic and JavaScript viruses without the need for specific virus definitions. It monitors the scripts for virus-like activity and in most cases you receive an alert telling you that a potential threat was found.

You must choose one of the options to remove the threat. The recommended action is to stop the script from running. You can click Help on the alert for additional information about how to respond.

More Information

About Script Blocking options


Script Blocking Alert

The Norton AntiVirus Script Blocking feature has detected virus-like activity in a script file on your computer. Because the Script Blocking options are set to ask you what to do when a malicious script is found, the alert is prompting you to select one of the options in the Action list. You can change the Script Blocking options to disable the feature or have Script Blocking stop the script without asking you what to do.

Stop this script (recommended): Prevents the script from running. Choose this if you do not trust the script source or the current script activity.

Allow this activity once: Lets the potentially dangerous activity within the script run once. You might spread the problem to other files or other computers if you choose this action.

Allow the entire script once: Lets the entire script run once. Choose this option if you trust all the activities in the script.

Quarantine this script: Isolates the file in the Quarantine folder. This prevents the problem from spreading.

Authorize this script: Lets the script run with no further Script Blocking alerts. Choose this option if you know and trust the script's source.

More Info about the Script Blocking Alert from the Symantec Knowledge Base Web site

More Information


Script successfully quarantined

Norton AntiVirus has successfully isolated the file in the Quarantine folder. This prevents the problem from spreading.

Resume using your computer (recommended): Closes the alert so you can continue to use your computer.

Send to Symantec: Opens the Quarantine window so you can send the quarantined file over the Internet directly to Symantec Security Response for analysis. Symantec Security Response will determine whether the file is infected and report the results to you.