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Topics in this section

Welcome to Microsoft Office Visio 2003

Microsoft® Office Visio® 2003 provides 
templates, shapes, and drawing tools you can 
use to create effective business and technical 
diagrams. Using Visio Standard, you can 
analyze business processes, schedule projects, 
visualize thought processes, and chart your 
organization. Using Visio Professional, you can 
do all of those things, as well as visualize your 
network infrastructures, floor plans, facilities 
equipment, electrical circuits, software systems, 
and database structures.

Working in a familiar Microsoft environment, 
you can also import data to create diagrams, 
export data from diagrams, store data with 
diagrams, generate reports from stored data, 
and incorporate diagrams into Microsoft 
Office files.

The Microsoft Office Visio 2003 User Guide 
includes the following topics to get you started:

• Visio installation and activation
• Visio diagram examples and an overview 

of the drawing process
• The basic methods you need to know 

to create any Visio diagram, shape, 
or template

• More specific methods you can use to 
create several common diagram types

Visio installation and activation ...........................vi

Visio diagrams for all of your business and 
technical needs .............................................. vii

What’s new in Visio 2003.................................... xv

Task-specific information while you work ......... xvii

Visio Help and other sources of information ..... xix

Personalized Visio experience and drawing 
environment ................................................... xxi
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Visio installation and activation

Installing and activating Visio is a quick and 
simple process.

Installation
Before you begin the installation, locate the 
product key on your Visio CD. To prevent 
installation conflicts, close all programs and 
turn off virus-protection software. Then, place 
your Visio CD in the CD-ROM drive. On most 
computers, Visio Setup will start automatically 
and guide you through the installation.

If Visio Setup does not start automatically, 
complete the following procedure.

Manually start Visio Setup 
1 Insert your Visio CD into the CD-ROM 

drive.
2 On the Start menu click Run.
3 Type drive:\setup (replace drive with the 

letter assigned to the CD-ROM drive).
4 Click OK.

Visio Setup starts and guides you through 
the installation.

TIP: After installing Visio, if you suspect a 
problem with your product, on the Help menu, 
click Detect and Repair to repair it. To check 
for product updates on the Web, on the Help 
menu, click Check for Updates.

Activation
The first time you start Visio, you are prompted 
to activate the product. The Activation Wizard 
guides you though all the steps necessary to 
activate Visio through an Internet connection or 
on the telephone.

If you choose not to activate Visio the first time 
you start the product, you can complete 
activation later by clicking Activate Product on 
the Help menu.

NOTE: If you do not activate the product after 
using it several times, you will experience 
reduced product functionality. Eventually, the 
only thing you will be able to do without 
activating Visio is open and view files.
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Visio diagrams for all of your business and technical needs

Unlike many bundled programs that provide 
limited drawing capabilities, Visio provides a 
dedicated, familiar, Microsoft drawing 
environment, complete with a broad range of 
templates, shapes, and sophisticated tools 
designed to make creating a wide variety of 
business and technical diagrams easy. The 
sample diagrams on the following pages 
represent just a few of the many types of 
diagrams you can create using Visio 
Standard 2003 and Visio Professional 2003.

TIP: Visio 2003 includes Diagram Gallery, 
which provides you with sample diagrams for 
every diagram type in Visio and ideas about 
who could use them and how. To browse these 
sample diagrams, on the Help menu, click 
Diagram Gallery.
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Flowcharts • Accountants can use flowcharts to describe 
fiscal management, money management, 
and financial inventory processes.

• Hiring managers can use product 
development flowcharts to highlight the 
important decisions new employees need to 
be prepared for.

• Insurance companies can use flowcharts to 
document risk-assessment processes.

Cross-functional 
Flowcharts

• TQM personnel can use cross-functional 
flowcharts to understand how processes 
work and which departments are involved.

• Executive assistants can use cross-functional 
flowcharts to describe processes to 
executives and suggest improvements.

• Project managers can use cross-functional 
flowcharts to determine the effects of 
projects across organizations.

Organization 
Charts

• Project managers can use organization 
charts to show team structures and task 
allocations when developing project 
schedules.

• Managers can use organization charts to 
visualize how to restructure their 
departments or to estimate staffing needs.

• Human resources professionals can create 
organization charts and post them on a 
company’s intranet.
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Block Diagrams • Software programmers can use block 
diagrams to communicate ideas and 
complex concepts.

• Project managers can create conceptual 
block diagrams that illustrate how project 
tasks fit together.

• Sales and marketing professionals can 
include block diagrams in their presentations, 
proposals, and reports.

Office Layouts • Space planning consultants can use office 
layouts to make recommendations to clients.

• Operations departments can use office 
layouts to track asset inventories.

• Interior designers can use office layouts to 
determine the best ergonomic layout for 
an office.

Marketing Charts 
and Diagrams

• CFOs can use marketing charts to describe 
company finances in annual reports.

• Newspaper and magazine professionals can 
use diagrams, sometimes called 
infographics, to illustrate statistical data.

• Marketing professionals can use charts to 
display data more effectively than in 
text form.
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Directional Maps • Traffic officers can use directional maps to 
evaluate traffic patterns.

• Event planners can use directional maps 
to provide directions to employees for 
company events.

• Sales managers can use directional maps to 
provide clients with directions to trade shows.

Calendars • Administrators can use calendars to keep 
track of employee holidays.

• Project managers can incorporate calendars 
into project management documents to help 
team members visualize project schedules.

• Event planners can use calendars to 
schedule and track events throughout 
the year.

Timelines • Project managers can use timelines to 
represent project durations and milestones.

• Supervisors can use timelines to make sure 
team members understand their deadlines.

• Documentation specialists can use timelines 
to track process-completion dates.
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Brainstorming 
Diagrams

• Project managers can use brainstorming 
diagrams in team meetings to analyze and 
solve process problems or identify new 
product ideas.

• Writers can visually organize their ideas 
with brainstorming diagrams.

• Project team members can use 
brainstorming diagrams to generate 
action items.

Web Diagrams • Intranet site managers can use Web 
diagrams as visual aids in reorganizing 
departmental intranet sites.

• Web developers can use maps of their sites 
to help them inventory files, pictures, data, 
and other content.

• Web designers can incorporate Web 
diagrams into presentations for 
company meetings.

Logical Network 
Diagrams

• Network managers can create logical 
network diagrams to show high-level views 
of their networks.

• IT professionals can use logical network 
diagrams to determine how geographic 
locations are interconnected.

• IT engineers can identify obstacles or 
backlogs in their network flows.
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Physical Network 
Diagrams

• Facilities managers can incorporate physical 
network diagrams into plans for disaster 
recovery and documents about 
company assets.

• Network managers can use physical network 
diagrams to show the distribution of products 
throughout their organizations.

• Employees can refer to physical network 
diagrams to find printers, copy machines, and 
other devices.

Floor Plans • Architects can use floor plans in 
brainstorming sessions to quickly show 
various layout options.

• General contractors can use floor plans to 
configure the best wiring plans for buildings.

• Facilities managers can annotate proposed 
floor plans, and then return them to the 
architect for review.

Site Plans • Facilities managers can use site plans to 
design parking lot configurations.

• Space planners can incorporate site plans 
into relocation proposals.

• Contractors and site designers can use 
site plans to see how buildings fit their 
surroundings.
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Process 
Engineering 
Diagrams

• Process engineers can create process flow 
diagrams to show piping plans for 
petroleum plants.

• Plant operators can use P&IDs to document 
changes to existing facilities, such as 
boiler systems.

• Controls operators can use piping diagrams 
to show how logic diagrams relate to physical 
pipe plans.

Mechanical 
Engineering 
Diagrams

• Mechanical engineers can diagram hydraulic 
systems, fluid power assemblies, and valves.

• Engineering teams can share and comment 
on design concepts.

• Engineers can use 2-D mechanical 
engineering diagrams with 3-D 
design systems.

Electrical 
Engineering 
Diagrams

• Electrical engineers can create blueprints, 
schematics, and wiring diagrams.

• Control engineers can use electrical 
engineering diagrams to design complex 
industrial control components and systems.

• Telecommunication engineers can use 
telecommunications diagrams to share 
component and service design ideas.
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Software 
Diagrams

• Software engineers can create code structure 
diagrams, and then test and revise the 
diagrams during the development process.

• User interface designers can use software 
diagrams to create prototypes of dialog 
boxes, menus, toolbars, and wizards.

• Usability engineers can use software 
diagrams to test user interaction with 
proposed software.

Database Model 
Diagrams

• Technical support personnel can use 
database model diagrams to see and 
troubleshoot database schemas.

• Software engineers can design and revise 
database model diagrams after they 
brainstorm with colleagues.

• Trainers can use database model diagrams 
to show students database structures.
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What’s new in Visio 2003

New or improved features and templates in 
Visio 2003 make it easier than ever to create 
professional diagrams that help you better 
communicate key information and make a more 
professional impact on your audience.

Work faster and do more with new or 
improved Visio 2003 features
You can work faster and do more using the 
following core group of new or improved 
features that Visio 2003 provides:

• Easily rotate shapes with the new rotation 
handle ( ) that appears on two-
dimensional shapes.

• Easily select multiple shapes using the new 
Area Select ( ) and Lasso Select ( ) 
tools and the Multiple Select mode. Resize 
all of the selected shapes at once using the 
new selection handles that enclose them.

• Share information and ideas with 
colleagues on your Tablet PC wherever you 
happen to be with the new Ink tool ( ). 
Sketch freely and work through ideas as 
you would on paper or whiteboards.

• Quickly find shapes with the improved 
Search for Shapes feature in the Shapes 
window. Drag the shapes you find directly 
onto the drawing page.

• Organize the shapes you use often in one 
location so they’re easy to find. Save them 
on the new Favorites stencil or custom 
stencils in the new My Shapes folder.

• Use the task panes docked to the right of the 
drawing page to quickly access options for 
starting diagrams, searching the Web, 
inserting clip art into diagrams, researching, 
reviewing, collaborating, and getting Help.

• Mark up Visio diagrams with shapes and 
annotations using the new Reviewing task 
pane. It supports global teams, whose 
members need to review and collaborate on 
projects, but may not be in the same 
building, or even the same country.

• Easily collaborate on and share documents 
with Microsoft SharePoint® integration in 
Visio 2003. Work with documents in the 
Shared Workspace task pane, which 
contains a library of all related files, and 
provides immediate access to your 
collaboration group, assignments and action 
items, and external links to information.

• View, share, and print Visio diagrams in 
Microsoft Internet Explorer 5.0 or later 
using the improved Visio Viewer, even if 
your team members, clients, and partners 
don’t have Visio.

• Ensure CAD files you convert to the Visio 
file format have higher fidelity than your 
original CAD files. The DWG Converter 
also includes improved text handling and 
graphic support.
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Create a lasting impression with new or 
enhanced templates and shapes
Gain more control over your Visio diagrams 
and use them to create a lasting impression on 
your audiences using new or enhanced 
Visio 2003 templates.

Templates with shapes already positioned on 

the drawing page Create diagrams faster with 
new Visio templates that come with shapes 
already on the drawing page. Just fill in the 
detail without worrying about the layout or 
starting from a blank page.

Brainstorming Diagram  Capture and arrange 
ideas generated by a group or generate and 
diagram ideas on your own with the new 
Brainstorming Diagram template. Then, 
export the diagram to a Microsoft Word outline 
for those who prefer to see the information in 
a linear view, or to an XML file for 
reuse elsewhere.

Organization Chart Specify the employee 
information you want to show in your 
organization charts, add employee photographs 
to shapes, show dotted-line reporting 
relationships, and experiment with different 
layouts using the enhanced features and shapes 
in the Organization Chart template.

Timeline Easily communicate schedule 
information, visualize milestones, and reinforce 
the progression of time with the improved 
Timeline template. Create vertical timelines 
and synchronize milestones and intervals across 
multiple timelines. Use the new Expanded 
timeline shape to create a more detailed 
timeline segment. Edit all date and time 
formatting at once, and divide your timeline by 
seconds, minutes, hours, or quarters of the year.

Basic Network Diagram and Detailed Network 

Diagram Create presentation-quality network 
diagrams with the enhanced Basic Network 
Diagram template in both Visio Standard 2003 
and Visio Professional 2003. Document the 
physical and logical topology of your network 
using the Detailed Network Diagram template 
in Visio Professional 2003. Shapes in both 
templates have a dramatically improved 
appearance.

Rack Diagram Quickly diagram rack space 
requirements for new network equipment using 
the Rack Diagram template in Visio 
Professional 2003. The new shapes are designed 
with industry-standard measurements, to fit 
together precisely, making it easy to stack 
shapes in a rack and size them appropriately. 
You can also store data, such as serial number 
and location, with the shapes and then generate 
detailed reports.

Windows XP User Interface Prototype user 
interfaces with the new Windows XP User 
Interface template in Visio Professional 2003, 
which includes all the controls you need to draft 
your user interfaces before you begin coding. 
Create drop-down menus, tabbed dialog boxes, 
and toolbars that comply with the Microsoft 
Windows XP® look and feel.

Web Site Map Take advantage of the enhanced 
features in the Web Site Map template included 
with Visio Professional 2003. Gain more 
control over layout options and shape text, use 
new shapes to represent current and upcoming 
technologies, and generate Web site maps 
faster. Using the new interactive discovery 
feature, you can even map protected Web site 
areas for which you have the appropriate 
access rights.
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Task-specific information while you work

Visio 2003 includes new task panes that give 
you quick access to task and diagram-specific 
information while you work. You can use them 
to get Visio and template-specific Help, insert 
clip art into your diagrams, search and do 
research on the Web, collaborate, review shared 
documents, and update your copy of a shared 
document to the most recent version—all in the 
Visio drawing window and over your 
Internet connection.

Show a specific task pane
• On the task pane title bar, click the arrow, 

and then click the name of the task pane 
you want to show.

NOTE: If a task pane is not open, on the 
View menu, click Task Pane.

The Microsoft Office 
Visio 2003 drawing 
environment

1 Task panes are docked to the right of the 
drawing page.

2 On the task pane title bar, click the arrow to see 
the list of task panes you can choose from. 
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Visio 2003 includes the following task panes to 
help you work faster and smarter:

• Getting Started Quickly open diagrams, 
create new diagrams, and search for shapes, 
templates, and diagram-specific 
information on your computer or on 
Microsoft Office Online.

• Visio Help Get detailed, up-to-date answers 
to your Visio questions so you can create 
diagrams effectively.

• Clip Art Search for clip art on your 
computer or on Microsoft Office Online. 
Then organize and insert the clip art into 
your Visio diagrams.

• Research Search for and research diagram-
specific or work-related topics on the 
Microsoft Web site using the Microsoft 
Research Library, which includes 
encyclopedias, dictionaries, 
and thesauruses.

• Search Results Search for Microsoft product 
information on the Microsoft Web site.

• New Drawing Start new drawings from 
scratch or from one of your most recently 
used templates. Search for templates 
installed on your computer or new ones on 
Microsoft Office Online.

• Template Help Follow template-specific 
procedures to create your diagrams, get 
template information on Microsoft Office 
Online, and give feedback to 
Microsoft Corporation.

• Shared Workspace Share diagrams with 
team members in the next building or the 
next country.

• Document Updates Update your copies of 
shared documents. This pane works in 
conjunction with diagrams shared through 
the Shared Workspace task pane.

• Reviewing Review and annotate project 
diagrams circulated among team members.

TIP: For detailed information on using specific 
task panes, type the name of the task pane in the 
Type a question for help box to the right of the 
menu bar, press ENTER, and then choose the 
appropriate topic from the list that appears.
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Visio Help and other sources of information

Details and how-to information on working in 
Visio are just a click away in online Visio Help.

Get Visio Help
Visio Help provides topics that answer your 
questions about working with Visio. To provide 
you with the most up-to-date information, Visio 
looks for the most recent Help on Microsoft 
Office Online by default.

Get Visio Help from the Visio menu bar
1 Start Visio. In the Type a question for help 

box, located on the right side of the menu 
bar, type your question or keyword, and 
then press ENTER.

2 From the list of topics that appears, select the 
topic that answers your question.

Get Visio Help in the Help task pane
• Start Visio. On the Help menu, click 

Microsoft Office Visio Help.

Use the Visio Help task pane
The Visio Help task pane opens to the right 
of the drawing page. It contains three main 
sections:

• Assistance Allows you to search for the 
appropriate Help topic using questions or 
keywords and browse the table of contents.

• Office Online Directs you to the most recent 
Help on the Microsoft Office Web site, 
training materials, community forums, new 
templates, and Office updates.

• See Also Provides access to frequently used 
information and online content settings so 
you can personalize your Help experience.

TIP: You can move backward and forward 
through Help topics you already viewed using 
the arrow keys under the task pane title bar.

Get help quickly while you work
For help with Do this

Concepts, terms, and features Type a question in the Type a question for help box on the menu bar.

Shapes Do one of the following:

• Pause the pointer over a shape in the Shapes window until a 
ScreenTip appears.

• Right-click a shape on the drawing page or in the Shapes window, and then 
click Help on the shortcut menu.

Menu commands Type the menu command in the Type a question for help box on the menu bar.

Dialog boxes Click the Help button ( ) in the dialog box.

Automation and the 
ShapeSheet® spreadsheet

With a ShapeSheet cell or automation object selected, press the F1 key. Or on 
the Help menu, click Developer Reference.
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Developer Reference
Developer Reference provides detailed help for 
software developers who want to extend Visio 
functionality by creating their own applications 
or customizing the existing Visio environment. 
It includes information on what’s new for 
developers in Visio 2003; detailed Visio object, 
property, method, and event topics; and how-to 
information for first-time Visio developers.

Start Developer Reference
• Start Visio. On the Help menu, click 

Developer Reference.

Getting Started Tutorial
Getting Started Tutorial introduces you to the 
Visio drawing environment and uses a 
combination of step-by-step procedures and 
animation to teach you the basic skills you need 
to create and share any Visio diagram.

Start Getting Started Tutorial
• Start Visio. On the Help menu, click 

Getting Started Tutorial.

Diagram Gallery
Diagram Gallery gives you examples of 
diagrams you can create using Visio templates 
and shapes. It also suggests who could use 
particular diagram types and how.

Start Diagram Gallery
• Start Visio. On the Help menu, click 

Diagram Gallery.

Microsoft Office Online
The Microsoft Office Web site connects you to 
information that helps you get the most out of 
your Visio product. The site offers product 
tours, templates, sample diagrams, tutorials, tips 
and tricks, in-depth articles about using Visio, 
answers to frequently asked questions, and links 
to Knowledge Base articles. You’ll also find 
information that helps you get software 
upgrades, new components, and 
service releases.

Go to Microsoft Office Online
• Start Visio. On the Help menu, click Office 

on Microsoft.com.

TIP: To find contact information for Microsoft 
Corporation, on the Help menu, click 
Contact Us.
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Personalized Visio experience and drawing environment

You can personalize your Visio experience 
and drawing environment to make working in 
Visio comfortable for you.

If you have a slow Internet connection and you 
don’t want Visio to look for the most recent 
Help on Microsoft Office Online, use the 
Service Options dialog box to use the installed 
Help on your computer instead.

Use the Visio Help installed on your computer 
instead of the Help on Microsoft Office Online
1 Do any of the following to open the Service 

Options dialog box:
• On the task pane title bar, click the arrow, 

and then click Help. Under See also, 
click Online Content Settings.

• On the Help menu, click Customer 
Feedback Options.

• On the Tools menu, click Options. On 
the General tab, click Service Options.

2 In the Service Options dialog box, under 
Category, click Online Content.

3 Under Settings, clear the Search Office 
Online content automatically when 
connected check box, and then click OK.

If you’re an experienced Visio user and you 
don’t want to show the Template Help task 
pane each time you open a template, specify this 
in the Service Options dialog box. You can also 
use this dialog box to select Visio feedback and 
shared workspace settings.

Hide the Template Help task pane
1 On the task pane title bar, click the arrow, 

and then click Help.
2 In the Visio Help task pane, under See also, 

click Online Content Settings.
3 In the Service Options dialog box, under 

Category, click Online Content.
4 Under Settings, clear the Show Template 

Help automatically when opening a 
template check box, and then click OK.

If you want Visio to show all of the commands 
on its menus instead of only the most commonly 
used commands, you can change the settings in 
the Customize dialog box. You can also use the 
settings in this dialog box to customize your 
menus and toolbars.

Show full Visio menus
1 On the Tools menu, click Customize.
2 Under Personalized Menus and Toolbars, 

select the Always show full menus check 
box, and then click Close.
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If you want to customize your Visio drawing 
environment, you can use the use the Options 
dialog box to do the following: 

• Change the color of the drawing window 
and stencil background.

• Set text quality so your text appears smooth 
or jagged. Visio takes longer to display 
smooth text.

• Change the default file paths for Visio 
drawings, templates, stencils, and 
other files.

• Specify developer settings.
• Specify how and where the Search for 

Shapes feature looks for shapes.
• Change the language, regional settings, and 

default units of measurement for Visio.

Specify Visio drawing environment settings
1 On the Tools menu, click Options.
2 Do any of the following:

• To change drawing window and stencil 
background colors, click the Advanced 
tab, and then click Color Settings. In the 
Color Settings dialog box, change the 
drawing environment colors, and then 
click OK.

• To set text quality, click the View tab, 
and then under Text quality, specify 
the quality.

• To change the default file paths, click the 
Advanced tab, click File Paths, type the 
new file paths, and then click OK.

• To specify developer settings, click the 
Advanced tab, and then under 
Advanced options, select the 
appropriate check boxes.

• To specify how and where the Search 
for Shapes feature looks for shapes, 
click the Shape Search tab, and then 
specify search settings.

• To change language, regional settings, 
and default units of measurement for 
Visio, click the Regional tab, and then 
change the settings.

3 Click OK.
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Topics in this chapter

1
Microsoft Office Visio basics

Microsoft® Office Visio® Standard 2003 and 
Microsoft Office Visio Professional 2003 share 
a core set of features, allowing you to use 
common methods to create your diagrams.

This section begins with an overview of the 
basic Visio drawing process, and then explains 
the following tasks that will get you started 
creating your diagrams:

• Begin your diagrams with a template.
• Work with shapes in your diagrams.
• Connect shapes in your diagrams.
• Add and change text in your diagrams.
• Format shapes in your diagrams.
• Add and work with pages in your 

drawing files.
• Save and print your diagrams.
• Share your diagrams.

Subsequent sections focus on using these basic 
tasks and diagram-specific tools in your 
everyday work to create flowcharts, 
organization charts, network diagrams, and 
floor plans.

Overview of the Visio drawing process................. 2

Begin your diagrams with a template .................. 4

Work with shapes in your diagrams ..................... 6

Connect shapes in your diagrams........................ 9

Add and change text in your diagrams ..............12

Format shapes in your diagrams........................13

Add and work with pages in your 
drawing files................................................... 14

Save and print your diagrams.............................15

Share your diagrams........................................... 16
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Overview of the Visio drawing process

The following illustrations show the basic steps you’ll follow to create most Visio diagrams.

Overview of the
Visio drawing

process

1 Begin your diagram by opening a template. 2 Add shapes to your diagram by dragging them 
onto the drawing page. Then rearrange, resize, 
and rotate them.

3 Connect the shapes in your 
diagram using the 
Connector tool.

4 Add text to shapes in your 
diagram, and add 
independent text for titles.

5 Format shapes in your 
diagram using formatting 
menus and toolbar buttons.
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7 Save and print your diagram.

8 Share your diagram by publishing it to the Web or incorporating it into Microsoft Office files.

6 Add and work with drawing pages in your 
drawing file.

Overview of the 
Visio drawing 
process
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Begin your diagrams with a template

You begin a Visio diagram with a template—a 
file that opens a drawing page and stencils that 
contain the shapes you need to create your 
diagram. A template also includes the styles, 
tools, and other settings appropriate for the 
drawing type.

For example, to create a basic flowchart, you 
open the Basic Flowchart template, which 
includes flowchart shapes and arrowhead line 
styles appropriate for many types of flowcharts. 
Then you drag shapes from the stencils in the 
Shapes window onto the drawing page.

The Microsoft
Office Visio 2003

drawing
environment

1 The drawing page, on which you create diagrams, 
represents the printed page. It opens with size, 
orientation, scale, grid, and units of measurement 
appropriate for the drawing type.

2 The grid helps you align and position shapes on 
the drawing page.

3 Stencils contain the shapes you need to create 
your diagrams. By default, they dock to the left of 
the drawing page in the Shapes window.

4 Shape information appears when you pause the 
pointer over a shape on a stencil.
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Begin your diagram by opening a template and 
adding shapes to the drawing page
1 Start Visio. In the Choose Drawing Type 

window, under Category, click the drawing 
type you want to create.

2 Under Template, click the template you 
want to open.
A drawing page appears, with the shapes 
and tools you need to begin your diagram.

NOTE: To open the Choose Drawing Type 
window again without restarting Visio, on 
the File menu, point to New, and then click 
Choose Drawing Type.

3 Drag shapes from stencils in the Shapes 
window onto the drawing page.
Visio snaps the shape to the nearest grid line 
on the drawing page so you can position it 
precisely in your diagram.

TIP: From the task pane to the right of the 
drawing page, you can get help using Visio 
templates, open other drawing files, add clip 
art, search the Web, or add review comments to 
diagrams. The Getting Started task pane opens 
when you start Visio. To work in other task 
panes, click the arrow on the task pane title bar, 
and then click the type of information you want 
to display.

Find more shapes
If the shapes you want to add to your diagram 
are not included with the template you’re using, 
you can easily search for them on your 
computer or the Web.

Find more shapes
1 On the View menu, make sure Shapes 

Window is selected.
2 In the Shapes window, under Search for 

Shapes, type the name, a keyword, or a 
description of the shape you want to find, 
and then click the arrow or press the 
ENTER key. 

A new stencil appears, containing the shapes 
that match the search description you typed.

3 Drag the shape you want from the Shapes 
window onto the drawing page.

Do either of the following to open more stencils
• To open a Visio stencil, on the File menu, 

point to Shapes, point to the appropriate 
drawing type, and then click the name of 
the stencil you want to open.

• To open a custom stencil, on the File menu, 
point to Shapes, point to My Shapes, and 
then click the name of the stencil you want 
to open.
The stencil opens in the Shapes window.
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Work with shapes in your diagrams

After you begin adding shapes to your diagram, 
you can rearrange, resize, rotate, and change the 
appearance of them as you refine your diagram. 
If you’re creating a large or detailed diagram, 
you may also want to zoom in on the drawing to 
see more detail.

Resize, rotate, and change the 
appearance of shapes using handles
Visio shapes are one-dimensional (1-D) or two-
dimensional (2-D). When you select a shape, it 
shows selection handles ( ), which you use to 
resize it, and a rotation handle ( ), which you 
use to rotate it. The number and type of 
selection handles a shape displays depends on 
whether it’s 1-D or 2-D.

Some shapes also have control handles ( ), 
which perform actions that are unique to the 
particular shape on which they appear. For 
example, you might use a control handle to 
create a connection between network shapes or 
open a drawer in a filing cabinet shape.

1-D shapes behave like lines and display endpoints 
you drag to resize the shapes.

2-D shapes have corner handles you drag to resize 
the shapes proportionally, and side selection 
handles you drag to resize the shapes horizontally 
or vertically. 

2-D shapes also include a rotation handle you can 
use to rotate them.

Control handles look 
like yellow diamonds. 
To see a ScreenTip 
describing a control 
handle’s function, pause 
the pointer over the 
control handle.

Drag a control handle 
to perform the action 
described in the 
ScreenTip.
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Move one or more shapes at one time
Moving Visio shapes is as easy as selecting the 
shapes and then dragging them to a new location 
in your diagram. You can also position shapes 
precisely by nudging them slightly in one 
direction using the arrow keys on the keyboard.

Move one shape
• To move one shape, click the shape with the 

Pointer tool ( ), hold the left mouse button 
while dragging the shape to the location you 
want in your diagram, and then release.
A four-headed arrow appears under the 
pointer ( ) when the shape is ready to 
be moved.

NOTE: You don’t have to place the Pointer 
tool exactly over the center of the shape; 
however, it’s a good habit to develop so you 
don’t drag a shape handle by mistake. 
Dragging a shape handle changes the 
appearance of the shape. If you drag a 
shape handle by mistake, just undo your 
last action. (On the Edit menu, click Undo.)

Nudge a shape
• Click a shape, and then press the up, down, 

left, or right arrow keys.

Move multiple shapes 
1 Do one of the following to select more than 

one shape:
• Click one of the shapes you want to move 

with the Pointer tool ( ), hold down the 
SHIFT key, and then click the other 
shapes you want to move.

• Using the Pointer tool, drag a selection 
rectangle around all of the shapes you 
want to move.

• Click the arrow next to the Pointer tool, 
and then click the Area Select tool ( ) 
to draw a selection rectangle around all 
of the shapes you want to move.

• Click the arrow next to the Pointer tool, 
and then click the Lasso Select tool ( ) 
to draw a freeform selection outline 
around all of the shapes you want 
to move.

• Click the arrow next to the Pointer tool, 
click Multiple Select, and then select the 
shapes you want to move. After you 
move the shapes, click Multiple Select 
again to turn multiple selection off.

2 Move the pointer over one of the selected 
shapes until a four-headed arrow appears 
under the pointer ( ).

3 Drag the shapes to their new position.
All selected shapes move, retaining their 
original relative spatial relationship.

TIP: To limit the movement of shapes to 
horizontal or vertical, hold the SHIFT key 
while dragging the shapes.

Move shapes by dragging them with the Pointer tool.

0 - Visio 11.book  Page 7  Tuesday, July 1, 2003  10:50 PM



8 M I C R O S O F T ® O F F I C E  V I S I O ® 2 0 0 3  U S E R  G U I D E

Zoom in and out of the drawing page to 
work with shapes
If the shapes in your diagram look too small to 
work with, you’ll want to zoom in closer. If 
you’re working with a large diagram (for 
example, a network diagram or floor plan) you 
may need to zoom out to check the overall view.

Zoom in on the drawing page using either of the 
following keyboard shortcuts
• To zoom in on specific shapes in your 

diagram, click the Pointer tool ( ), and 
then hold down the CTRL+SHIFT keys 
while you drag a selection rectangle around 
the shapes.
When you hold down the CTRL+SHIFT 
keys, the pointer changes to a magnifying 
glass ( ). This visual clue tells you Visio 
is ready for you to specify the shapes you 
want it to zoom in on.

• To zoom in on an area of the drawing page, 
click the Pointer tool, position it over the 
area you want to magnify, and then hold 
down the CTRL+SHIFT keys while you 
click the left mouse button.

Zoom out of the drawing page using either of the 
following keyboard shortcuts
• To zoom out of the drawing page, click the 

Pointer tool ( ), position it over the area 
you want to zoom out of, and then hold 
down the CTRL+SHIFT keys while you 
click the right mouse button.

• To quickly center the drawing page in the 
Visio window and check the overall look of 
your diagram, press the CTRL+W keys.

Zoom in and out of the drawing page using the 
Zoom toolbar box
• Click the arrow in the Zoom toolbar box, 

and then select a zoom percentage.

TIP: You can also use the Pan & Zoom window 
to zoom in and out of and pan (move around) 
your diagram. To open the Pan & Zoom 
window, on the View menu, click 
Pan & Zoom Window.
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Connect shapes in your diagrams

Diagrams such as flowcharts, organization 
charts, block diagrams, network diagrams, and 
Web diagrams all have one thing in common: 
connections. In Visio, you create these 
connections by attaching, or gluing, one-
dimensional shapes called connectors to 
two-dimensional shapes.

Connectors stay glued when you move the 
shapes. For example, when you move a 
flowchart shape, the connector automatically 
repositions itself to keep its endpoints glued to 
the shape.

You can use two types of connections in 
Visio—shape-to-shape and point-to-point. The 
type of connection you use depends on how 
much control you want over the diagram layout.

With shape-to-shape connections, Visio 
maintains the most direct connection between 
the two connected shapes. This means that the 
points of connection might change when you 
move the connected shapes.

With point-to-point connections, you determine 
the points of connection by gluing endpoints to 
specific points on the shapes. The connector 
endpoints stay where you put them no matter 
where you move the connected shapes.

When you move shapes that have a shape-to-shape connection, the connector attaches to the closest points 
between the shapes, which might be different from the original point of connection.

When you move shapes that have a point-to-point connection, no matter how you arrange the shapes in relation 
to each other on the drawing page, the shapes maintain their original points of connection. 

Shape-to-shape 
connection

Point-to-point 
connection
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Connect shapes with a shape-to-shape connection 
as you drag them onto the drawing page 
1 Click the Connector tool ( ).
2 Drag a shape from the Shapes window onto 

the drawing page.
3 While the shape is still selected, drag another 

shape from the Shapes window onto the 
drawing page.
A connector appears, establishing a shape-to-
shape connection. When you select the 
connector, both of its endpoints turn red to 
show they are glued.

TIP: You can change the style of a connector 
you draw with the Connector tool. Right-click 
the connector, and then click Right-Angle 
Connector, Straight Connector, or Curved 
Connector on the shortcut menu.

Connect shapes that are already on the drawing 
page with a shape-to-shape connection 
1 Using the Pointer tool ( ), drag two shapes, 

one at a time, from the Shapes window onto 
the drawing page.

2 Click the Connector tool ( ), and then 
position it over the center of the first shape 
until a red outline appears around the shape.

3 Hold down the mouse button and drag to 
draw a connector to the center of the second 
shape until a red outline appears around the 
shape, and then release the mouse button.
The connector endpoints turn red to show 
they are glued.

TIP: To delete a connector, just click it to select 
it, and then press the DELETE key.

Using connections
Connection type When to use it How to create it

Shape-to-shape Use to connect shapes when 
their specific points of 
connection don’t matter, and 
you want Visio to maintain the 
closest points of connection.

Click the Connector tool ( ), and then drag 
shapes you want to connect onto the 
drawing page. Visio creates a shape-to-
shape connection by default.

When shapes are already on the drawing 
page, click the Connector tool, position it 
over the center of the first shape, and then 
drag it to the center of the second shape.

Point-to-point Use to control where the 
connector attaches to the 
2-D shape.

Click the Connector tool ( ), hold down the 
mouse button on a connection point ( ) on 
the first shape, and then drag to a 
connection point on the second shape. 
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Connect shapes that are already on the drawing 
page with a point-to-point connection
1 Using the Pointer tool ( ), drag two shapes, 

one at a time, from the Shapes window onto 
the drawing page.

2 Click the Connector tool ( ), and then drag 
from a connection point ( ) on the 
first shape to a connection point on the 
second shape.
The connector endpoints turn red to show 
they are glued at the connection points you 
specified. When shapes are connected 
point-to-point, the connector endpoints 
appear smaller than they do for shape-to-
shape connections.

If a shape does not have a connection point at 
the location where you want to create a point-to-
point connection, you can add one.

Add a connection point to a shape
1 Select the shape.
2 Click the arrow next to the Connector 

tool, and then click the Connection Point 
tool ( ).

3 Hold down the CTRL key, and then click 
the shape where you want to add the 
connection point.
The new connection point ( ) appears, 
highlighted in magenta, on the shape.

You can also add text to connectors and connect 
shapes with connectors from the Shapes 
window. For example, in a flowchart, you can 
drag curved connectors from the Shapes 
window and use them instead of straight lines to 
connect your shapes.

Add text to a connector
• Click the connector to select it, and 

then type.

TIP: You can change the position of text on 
connectors drawn with the Connector tool by 
dragging the control handle ( ) located at the 
base of the text.

Connect shapes with a connector from the Shapes 
window and with a point-to-point connection
1 Drag a connector from the Shapes window 

onto the drawing page.
2 Drag one of the connector endpoints to a 

connection point on a shape.
The connection point turns red to show the 
connector is glued to it.

3 Drag the other end of the connector onto the 
connection point of the second shape you 
want to connect.
Both connector endpoints turn red to show 
they are glued.
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Add and change text in your diagrams

Most Visio shapes, including connectors, are 
designed so that you can add text to them. If a 
shape has text, you can edit the text by opening 
its text block.

In addition, you can create text-only shapes—
shapes that show no lines or fill—to add notes, 
titles, and lists to diagrams.

Add text to a shape
1 Select the shape, and then type the text.
2 When you finish typing, press the ESC key 

or click outside the shape.

Delete all of the text from a shape
1 Double-click the shape to select all of 

its text.
2 Press the DELETE key, and then click 

outside the shape.

Change or delete a portion of a shape’s text 
1 Click the Text tool ( ), and then click 

the shape.
2 Click in the text block where you want to 

place an insertion point, and then type the 
new text. Or highlight the text you want to 
change or delete, and then type the new text.
To replace all of the existing text, press the 
CTRL+A keys to select all of the text, and 
then type the new text.

3 When you finish typing, press the ESC key 
or click outside the shape.

Do any of the following to format selected text
• On the Format menu, click Text to open 

the Text dialog box. 
• Use the tools on the Formatting toolbar to 

change the font, size, font style (bold, italic, 
underline), horizontal alignment, or color of 
the text.

• Use the Text Style list on the Format Text 
toolbar to apply a style, which can contain 
multiple formatting attributes, to the 
selected text.

Create a text-only shape
1 Click the Text tool ( ).

2 Click the drawing page where you want the 
text to begin, and then type.
Or, hold down the left mouse button and 
drag it to create a text block the size you 
want, release the mouse button, and 
then type.

3 When you finish typing, press the ESC key 
or click outside the text-only shape.

Move a text-only shape
• Using the Pointer tool ( ), position the 

pointer directly over the text, and then drag 
the text to a new location.
A four-headed arrow appears under the 
pointer ( ) when the text-only shape is ready 
to be moved.
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Format shapes in your diagrams

The type of formatting you apply to a shape 
depends on whether the shape is one-
dimensional (1-D) or two-dimensional (2-D). 
You can change the following formatting 
settings for 2-D shapes:

• Fill color (the color inside the shape)
• Fill pattern (the pattern inside the shape)
• Pattern color (the color of the lines that 

form the pattern)
• Line color and pattern
• Line weight (the thickness of the line)
• Fill and line transparency

You can also add a shadow to a 2-D shape and 
control the corner rounding.

Do any of the following to format a 2-D shape
• Click a 2-D shape, click the arrow next to 

the Line Color ( ) or Fill Color ( ) 
button on the Formatting toolbar to display 
the color palette, and then choose a line or 
fill color.

• Click a 2-D shape, and then on the Format 
Shape toolbar, click the Corner Rounding 
( ), Transparency ( ), Fill Pattern 
( ), or Shadow Color ( ) button.
To display the Format Shape toolbar, 
right-click the menu bar, and then click 
Format Shape on the shortcut menu.

• Click a 2-D shape, and then on the Format 
menu, click Line, Fill, Shadow, or Corner 
Rounding.

You can change the following formatting 
settings for 1-D shapes, including connectors:

• Line color, pattern, and transparency
• Line weight (the thickness of the line)
• Line end type and size
• Line end cap (whether the line end is square 

or round)

You can also add a shadow to a 1-D shape.

Do any of the following to format a 1-D shape
• Click a 1-D shape, and then on the 

Formatting toolbar, click the Line Color 
( ), Line Weight ( ), Line Pattern ( ), 
or Line Ends ( ) button.

• Click a 1-D shape, and then on the Format 
Shape toolbar, click the Transparency 
( ) or Shadow Color ( ) button.

• Click a 1-D shape, and then on the Format 
menu, click Line or Shadow.
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Add and work with pages in your drawing files

For some projects, you might need multiple-
page diagrams, in which each page represents 
a different aspect or stage of a project. For 
example, one drawing file might contain a 
high-level project timeline on one drawing 
page, a process flowchart for the project on 
another page, and the staffing and resources 
plan on another page.

When you add a new drawing page to your 
drawing file, the new page inherits the current 
page’s size, orientation, scale, measurement 
units, shadow offset, and grid settings. You can 
change these settings using the Page Setup 
dialog box when you add the page, or at any 
other time.

Add a drawing page
1 Right-click a page tab at the bottom of the 

drawing page window, and then click 
Insert Page on the shortcut menu.

2 In the Page Setup dialog box, on the 
Page Properties tab, type a name for the 
page, or use the default name.

3 To define additional page settings, click the 
Page Size tab, choose the settings you want, 
and then click OK.

Set the page size, orientation, and drawing scale
1 Display the drawing page you want 

to change.
2 On the File menu, click Page Setup.
3 In the Page Setup dialog box, click the 

Page Size tab. Choose the page size and 
orientation you want.

4 Click the Drawing Scale tab, choose the 
scale you want, and then click OK.

Display a different drawing page
• Click the page tab for the page you want 

to display.

Delete a drawing page
• Right-click the page tab for the page you 

want to delete, and then click Delete Page 
on the shortcut menu. 

Rename a drawing page
1 Right-click the page tab for the page you 

want to rename, and then click Rename 
Page on the shortcut menu.
Visio highlights the page tab name.

2 Type the name of the new page, and then 
press the ENTER key.

Reorder drawing pages
• For the page you want to move, drag the 

page tab to its new location in the page 
tab sequence.
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Save and print your diagrams

After you finish your diagram, you can save or 
print it much the same way you save or print any 
Microsoft Office file.

Save your diagrams
You can save your Visio diagrams in the Visio 
file format or other file formats.

Save your diagram
1 On the File menu, click Save or Save As.
2 For File name, type a name for the 

drawing file.
3 For Save in, open the folder in which you 

want to save the file.
4 If you want to save your diagram in another 

file format, in the Save as type box, select 
the file format you want. If you want to save 
your diagram in the Visio file format, you 
can skip this step.

5 Click Save.

Print your diagrams
Most templates are set up so that the drawing 
page size is the same as the size of the paper in 
your printer, so you don’t have to change page 
settings to print the diagram the way it appears 
on the screen. However, it’s a good idea to 
preview your diagram before you print to make 
sure you get the results you expect.

Preview your diagram before printing
• Click the Print Preview button ( ) on the 

Standard toolbar.

In the print preview window, shapes that 
appear in the gray margins will not print. 
To print them, move them to the white area 
within the gray margins.

If the drawing page and printer page 
orientation do not match, on the File menu, 
click Page Setup, to adjust these settings so 
they match.

Do either of the following to print your diagram
• To specify which pages to print or to print 

all pages, on the File menu, click Print.
• To print the current page, click the Print 

Page button ( ) on the Standard toolbar.
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Share your diagrams

You can incorporate your Visio diagrams into 
project documents that you create in other 
programs and share with your teams. You can 
also share your diagrams with your entire 
company by publishing them to the Web or 
your company’s intranet site.

Incorporate Visio diagrams into 
Microsoft Office files
One way to share your Visio diagrams with a 
wider audience is to incorporate them into 
project documents created with Microsoft 
Office programs, such as Microsoft Word, 
Microsoft Excel, and Microsoft PowerPoint®.

NOTE: The following steps focus on using Visio 
diagrams in Word documents. You can use 
similar steps in other Office files.

Incorporate a diagram into a Word document
1 Open your Visio diagram. On the Edit 

menu, click Select All.

TIP: To incorporate only a few shapes into 
a Word document, select only the shapes 
you want to include in the document.

2 On the Edit menu, click Copy.
3 Open a Word document and click an 

insertion point in the location you want to 
insert your Visio diagram.

4 On the Edit menu, click Paste.
Word pastes your Visio diagram into 
the document.

The Visio diagram or shapes that you paste into 
a Word document become part of the document. 
When you modify the diagram in the document, 
you do not change the original Visio diagram.

Modify a Visio diagram in a Word document
1 In the Word document, double-click the 

Visio diagram.
Visio opens within Word and displays Visio 
toolbars and menus.

2 Make a change to the diagram; for example, 
move or change the color of a shape.
The change applies only to the diagram in 
the Word document.

3 Return to the Word document by clicking in 
the document outside the Visio diagram.
Visio closes, and Word becomes the active 
program again.

You can easily modify your diagram in a Word 
document.

0 - Visio 11.book  Page 16  Tuesday, July 1, 2003  10:50 PM



M I C R O S O F T  O F F I C E  V I S I O  B A S I C S 17

Publish your diagrams to the Web
Using Visio, publishing your diagrams to the 
Web or an intranet site is as easy as saving a file. 
Visio adds the HTML codes necessary to 
display your diagram in a Web browser, so all 
you have to do is make sure your diagram looks 
the way you want it to.

Save a diagram as a Web page 
1 Open the diagram you want to save as a 

Web page. On the File menu, click 
Save As Web Page.

2 For Save in, open the folder in which you 
want to save the file.

3 Click Save.

TIP: You can customize your Web page 
settings by clicking Publish in the Save As 
dialog box and altering the settings.

Add hyperlinks to shapes or pages
You can add one or more hyperlinks to Visio 
shapes and drawing pages before you save your 
diagram as a Web page. A link can jump to a 
Web site, another page in the same Visio 
diagram, another Visio drawing file, or any 
other file. For example, you can link a process 
shape in a flowchart to a Microsoft Word file 
containing Total Quality Management (TQM) 
documentation for that process.

Add a hyperlink to a page or shape 
1 Do one of the following:

• To add a link to a page, display the page 
with nothing selected.

• To add a link to a shape, select the shape.

2 On the Insert menu, click Hyperlinks.
3 Do one of the following:

• Link to a Web site For Address, type the 
Web site address. If you don’t know the 
address, click Browse, and then click 
Internet Address to open your default 
Web browser.

• Link to a file For Address, click Browse, 
and then click Local File. Locate the file 
you want, and then click Open. (If 
necessary, change the type of file in 
Files of type.)

4 For Description, type a link description, 
which appears on a shape’s shortcut menu, a 
page’s shortcut menu, or when you pause the 
pointer over a shape.

5 Click OK.

You can save diagrams in many different file formats, 
including Web page format with hyperlinks.
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Add a hyperlink to another page in the same 
Visio diagram
1 Do one of the following:

• To add a link to a page, display the page 
with nothing selected.

• To add a link to a shape, select the shape.

2 On the Insert menu, click Hyperlinks.
3 In the Hyperlinks dialog box, for Address, 

click Browse, and then click Local File.
4 In the Link to File dialog box, locate the 

Visio drawing file, and then click Open.
5 For Sub-address, click Browse.
6 In the Hyperlink dialog box, for Page, click 

the down arrow and select the page you want 
this shape or page to link to, and then 
click OK.

7 Click OK in the Hyperlinks dialog box.

NOTE: To follow a hyperlink on a page or 
shape, right-click the page or shape, and then 
click the link description on the shortcut menu.
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Create your own shapes and templates

As well as providing you with ready-to-use 
templates and shapes, Microsoft® Office 
Visio® 2003 gives you the flexibility to create 
your own. For example, you can use drawing 
tools or menu commands to create or customize 
shapes. Then, you can organize your favorite 
shapes in one location so it’s easy to find them 
while you work. You can also design new 
templates that include Visio shapes, your own 
custom shapes, and drawing page settings you 
know you’ll use again.

Create your own shapes .....................................20

Organize your shapes..........................................23

Design your own templates ................................25
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Create your own shapes

Visio offers several ways to create your 
own shapes:

• Draw a shape from scratch using any of the 
drawing tools—Rectangle, Ellipse, Line, 
Arc, Freeform, or Pencil—on the Drawing 
toolbar. For example, if you want to add a 
freeform arrow to a block diagram, you can 
draw the arrow with the Freeform tool.

• Merge two or more shapes. For example, to 
create a round sign with an arrow cut out of 
its center, you can place an arrow shape on 
top of a circle and then use the Combine 
command.

• Revise an existing shape. For example, if 
your company uses a special process shape 
for flowcharts, you can modify a Visio 
process shape, save your modified version, 
and then use it in future flowcharts.

TIP: When you use the drawing tools, you can 
hold down the SHIFT key while you draw to 
constrain the drawing behavior.

Draw shapes from scratch using Visio 
drawing tools
When you use the Visio drawing tools on the 
Drawing toolbar to create shapes from scratch, 
keep in mind that shapes can be either open 
or closed.

Open shapes are lines, arcs, or zigzag shapes. 
You can format the line ends, but you cannot fill 
the shapes with colors or patterns, because they 
contain no enclosed area.

Closed shapes are rectangles, circles, or other 
shapes that include an area you can fill with 
colors and patterns.

Draw a shape using a Visio drawing tool 
1 Show the Drawing toolbar by clicking the 

Drawing Tools button ( ) on the 
Standard toolbar.

2 On the Drawing toolbar, click a 
drawing tool.

3 Hold down the mouse button and drag on the 
drawing page to create the shape you want.

You can apply a fill and pattern to a closed shape, 
such as a rectangle, and ends to open shapes, such 
as lines. 
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Merge existing shapes to create 
new ones
An easy way to create a complex shape is to use 
shape operation commands to merge simple 
shapes. To use the shape operation commands, 
select the shapes you want to merge, and then, 
on the Shape menu, point to Operations.

NOTE: When you merge existing shapes, the 
new shape inherits the formatting of the first 
shape you select (the primary selection).

Examples showing different ways you can use shape operation commands

Command Result Example

Fragment Breaks a shape into smaller parts or creates new shapes from 
intersecting lines or from 2-D shapes that overlap.

Combine Creates a new shape from selected shapes. If the selected 
shapes overlap, the area where they overlap is cut out 
(discarded), creating a cookie-cutter effect.

Union Creates a new shape from the perimeter of two or more 
overlapping shapes.

Subtract Creates a new shape by subtracting the area where selections 
overlap from the primary selection.

Intersect Creates a new shape from the area where the selected shapes 
overlap, eliminating non-overlapping areas.

Offset Duplicates a line or curve to the right and left of the original 
shape, at the distance you specify. If the shape is an arc, Visio 
creates the new arcs so that their endpoints remain on the same 
x- and y-axes.
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Revise existing shapes
You can revise any shape that isn’t locked to 
prevent specific changes. When a shape is 
locked, you see gray boxes when you select 
the shape.

When you select shapes for revision using 
the Pencil tool ( ), the Line tool ( ), the 
Arc tool ( ), or the Freeform tool ( ), 
vertices ( ) appear at the ends of each line 
segment. Once the vertices appear, pause the 
mouse pointer over the shape to display control 
points ( ) at the midpoint of each line segment. 
You drag these vertices and midpoints to change 
the appearance of the shape.

Revise an existing shape with the Pencil tool
• Select a shape with the Pencil tool ( ), 

and then do one or more of the following:
• Drag a vertex ( ) to change the angle of 

a segment.

• Add a vertex by pressing the CTRL key 
and clicking a line segment.

• Delete a vertex by clicking it and 
pressing the DELETE key.

• Drag a control point ( ) to change the 
curve of a segment.

Shapes with gray boxes are locked to 
prevent changes.

You can reshape shapes by selecting them with the 
Pencil tool, and then dragging, adding, or deleting 
vertices and control points.
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Organize your shapes

If you create or modify a shape you want to 
keep for future diagrams, you can save it on a 
stencil—a file that contains groups of similar 
shapes. Once it’s saved on a stencil, Visio treats 
it as any other shape. To use it again, you just 
open the stencil and drag the shape onto the 
drawing page.

You can also import a graphic created in another 
program and save it on a stencil. For example, if 
the company logo you use in all of your reports 
is in the .gif file format, you can import the file 
into a Visio diagram, and then save it on a 
stencil, just as you would any other Visio shape.

TIP: Visio 2003 stencils are read-only, so you 
cannot modify them. However, you can add a 
shape from any Visio stencil to your Favorites 
stencil. Right-click the shape on the Visio 
stencil, point to Add to My Shapes, and then 
click Favorites.

Add a shape to your Favorites stencil or another 
custom stencil
1 Display the drawing containing the shape 

you want to add to your Favorites stencil or 
another custom stencil.

2 On the File menu, point to Shapes, point to 
My Shapes, and then click Favorites or the 
stencil you want to add the shape to.
The stencil appears docked to left side of 
the drawing window. 

3 Right-click the title bar of the Favorites 
stencil, and then click Edit Stencil on the 
shortcut menu.
The icon on the stencil title bar has a red 
asterisk ( ) to indicate that you can edit it.

4 Hold down the CTRL key, and then drag 
the shape from the drawing page onto 
the stencil.
A new icon representing your shape appears 
on the stencil, with a name such as 
Master.0.

NOTE: When you hold down the CTRL key 
and drag a shape onto the stencil, Visio 
makes a copy of the shape on the stencil. If 
you do not hold down the CTRL key, Visio 
moves the shape onto the stencil, removing 
the shape from the drawing page.

5 Select the new shape on the stencil, click the 
name, and then type a new name.

6 Click the Save Stencil button ( ) on the 
stencil title bar to save the changes.

You can easily save your shapes on custom stencils, 
so you can reuse them at any time.
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Add a shape to a new stencil
1 Display the diagram containing the shape 

you want to add to a new stencil.
2 On the File menu, point to Shapes, and then 

click New Stencil.
The new stencil appears docked to left side 
of the drawing window. The icon on the 
stencil title bar has a red asterisk ( ) to 
indicate that you can edit it.

3 Hold down the CTRL key, and then drag the 
shape from the drawing page onto the 
new stencil.
A new icon representing your shape appears 
on the stencil, with a name such as 
Master.0.

4 Select the new shape on the stencil, click the 
name, and then type a new name.

5 Click the Save Stencil button ( ) on the 
stencil title bar.

6 In the Save As dialog box, for File name, 
type a name for your stencil.

7 Click Save.
Now you can use the new shape as you do any 
other Visio shape.

NOTE: To open a custom stencil you created, on 
the File menu, point to Shapes, point to 
My Shapes, and then click the name of the 
stencil you want to open.

Import a graphic created in another program and 
save it on a stencil
1 Open any Visio diagram.
2 On the Insert menu, point to Picture, and 

then click From File.
You can also choose other commands to 
import pictures directly from your scanner 
or digital camera, or to import clip art.

3 In the Insert Picture dialog box, locate 
the picture you want to insert, and then 
click Open.
Visio inserts the picture on the drawing 
page.

4 Do either of the following:
• To save the picture on a custom stencil, 

on the File menu, point to Shapes, point to 
My Shapes, and then click Favorites or 
the stencil you want to add the shape to. 
Then, right-click the title bar of the 
stencil and click Edit Stencil on the 
shortcut menu.

• To save the picture on a new stencil, on 
the File menu, point to Shapes, and then 
click New Stencil.

5 Drag the picture from the drawing page onto 
the stencil.

6 Select the new shape on the stencil, click the 
name, and then type a new name.

7 Click the Save Stencil button ( ) on the 
stencil title bar to save the changes.

8 If you saved the picture on a new stencil, in 
the Save As dialog box, for File name, type 
a name for your stencil. Then, click Save.
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Design your own templates

When you design a template, you can specify 
page settings, create your own styles, include 
the stencils you want, and so on. After you save 
a file as a template, you can reuse it as often as 
you want or share it with colleagues.

You might want to create your own templates 
if your drawings fall into either of these 
categories:

• They require customized settings such as 
page size or scale, window size and 
position, or shape or text styles.

• They often use the same shapes in a 
particular location on the drawing page. For 
example, if you use the same border for 
every drawing, you can create a template 
with the border on a background page.

Create and save your own template 
1 Do any of the following to start creating 

your template:
• To open an existing drawing file you 

want to save as a template, on the File 
menu, click Open. In the Open dialog 
box, locate your drawing file, and then 
click Open.

• To open a Visio template you want to 
revise and save as a custom template, 
on the File menu, point to New, point to 
the appropriate drawing type, and then 
click the name of the template you want 
to open.

• To start your template with only a blank 
drawing page, on the File menu, point to 
New, and then click New Drawing.

2 Open any additional stencils you want to 
save with your template by doing either of 
the following:
• On the File menu, point to Shapes, click 

Open Stencil and then click the custom 
stencil you want to open.

• On the File menu, point to Shapes, point 
to the appropriate drawing type, and then 
click the name of the stencil you want 
to open.

3 Change drawing page settings and styles. To 
change page settings, click Page Setup on 
the File menu. To add or modify styles, click 
Define Styles on the Format menu.

4 On the File menu, click Save As.
5 For Save as type, select Template.
6 For File name, type a name for your 

template.
7 For Save in, open the folder in which you 

want to save the template.
8 For Save, click the arrow next to Save and 

verify that Workspace is selected, and then 
click Save.
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Use background pages to display 
common page elements in templates
You can include background pages in your 
template to give the diagrams you create with 
the template a uniform look. For example, if 
you want your company logo to appear in all 
diagrams you create with your template, you 
can create a background page that contains 
the logo and then assign the background page to 
the foreground page (the page on which you 
create your diagram). When you save the 
drawing file as a template, the logo appears on 
the drawing page each time you open the 
template. Because the logo is on a background 
page, you can’t accidentally modify it while 
you’re working with your diagram.

Create a background page for your diagram
1 Right-click a page tab in the lower left corner 

of the drawing window, and then click 
Insert Page on the shortcut menu.

2 On the Page Properties tab, for Type, 
click Background.

3 If necessary, click the Drawing Scale tab to 
change the scale or the Page Size tab to 
change the page size for the new page, and 
then click OK.

4 Place shapes and other design elements onto 
the drawing page.

NOTE: When you assign this background page 
to a blank foreground page and then save it as 
a template, any diagram you create with the 
template includes the design elements on a 
background page.

Assign the background page to your diagram
1 Display the diagram (foreground page) 

to which you want to assign the 
background page.

2 On the File menu, click Page Setup, and 
then click the Page Properties tab.

3 In the Background list, select the name of 
the background page you want to assign, and 
then click OK.
The background page appears behind the 
shapes in the diagram on the foreground page.
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Display the background to modify it
• Click the page tab for the background page, and then modify the background page as you 

would any other page.

Use a background page to repeat a common element in multiple diagrams. Each of these three drawing pages 
uses the same background page to display the sailboat in the same position.
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Analyze your business 
processes with flowcharts

Flowcharts can often make complex business 
processes easier to analyze and explain to 
others. Using the Microsoft® Office 
Visio® 2003 flowchart templates, you can 
accomplish the following tasks:

• Facilitate communication between 
departments using business flowcharts.

• Examine the causes of problems and see 
relationships among factors with 
cause-and-effect diagrams.

• Communicate how a process works or 
how to improve a process and the 
departments it affects using cross-
functional flowcharts.

Create flowcharts ................................................30

Work with large flowcharts .................................32
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Create flowcharts

Flowcharts are visual representations of a 
process and are frequently referred to as process 
flowcharts. Managers often create process 
flowcharts to help them understand and 
communicate how a process works and how it 
can be improved.

Visio Standard and Visio Professional provide a 
number of flowchart drawing types, as shown in 
the illustration below.

Examples of
flowcharts you can

create with Visio

0 - Visio 11.book  Page 30  Tuesday, July 1, 2003  10:50 PM



A N A L Y Z E  Y O U R  B U S I N E S S  P R O C E S S E S W I T H F L O W C H A R T S 31

Create a basic flowchart using the Connector tool 
and point-to-point connections
1 Start Visio. In the Choose Drawing Type 

window, under Category, click Flowchart.
2 Under Template, click Basic Flowchart.
3 Drag a shape, such as Process or Decision, 

from Basic Flowchart Shapes onto the 
drawing page.

4 Drag a second shape onto the drawing page.
5 On the Standard toolbar, click the 

Connector tool ( ), and then drag from a 
connection point ( ) on the first shape to a 
connection point on the second shape.
The connector endpoints ( ) turn red to 
show they are glued at the connection 
points you specified.

NOTE: If you want to create a shape-to-
shape connection instead, position the 
Connector tool over the center of the first 
shape until a red outline appears around 
the shape, and then drag to the center of the 
second shape.

6 To change the style of the connector, right-
click the connector, and then click Right-
Angle Connector, Straight Connector, or 
Curved Connector on the shortcut menu.

7 Continue adding and connecting shapes to 
complete your diagram.

TIP: To connect shapes as you drag them onto 
the drawing page, use the Connector tool to 
drag shapes onto the page instead of the 
Pointer tool. Visio connects each shape you 
drag onto the drawing page to the 
selected shape.

Add information to your flowchart
You can add information to your flowchart in 
the following ways:

• Add titles, callouts, captions, or other text.
• Add information, or custom properties, to 

flowchart shapes. Custom properties 
provide a way for you to store data such as 
cost, duration, and resources associated 
with a process.

• Add hyperlinks to shapes in your flowchart, 
to jump to other drawing pages, files, or 
documents on an intranet or the Web.

Add custom property data to a shape
1 Right-click a shape in your basic flowchart 

diagram, and then click Properties.
2 Type the information you want for Cost, 

Duration, and Resources.

NOTE: If a shape doesn’t include a custom 
property for the type of information you want to 
add to it, you can create a new custom 
property. Right-click the shape, and then click 
Properties on the shortcut menu. In the Custom 
Properties dialog box, click Define, and then 
click New. Complete the settings for the new 
property, and then click OK.

Add a hyperlink to your flowchart by doing one of 
the following
• In the Shapes window, click the Borders 

and Titles title bar to show the shapes, and 
then drag one of the hyperlink shapes onto 
the drawing page.

• Click the shape you want to add the 
hyperlink to, and then on the Insert menu, 
click Hyperlinks.
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Work with large flowcharts

Large flowcharts frequently depict complex 
processes that span multiple pages.

Visio provides useful methods for working with 
multiple-page flowcharts:

• Use shape numbering to cross-reference 
explanatory notes, or to indicate the 
sequence of steps in a large business 
process.

• Use Off-page reference shapes to navigate 
pages in multiple-page flowcharts, or to 
link to another page in your diagram.

Number shapes in your flowchart
1 Open the flowchart for which you want to 

indicate the sequence of steps.
2 On the Tools menu, point to Add-Ons, 

point to Visio Extras, and then click 
Number Shapes.

3 In the Number Shapes dialog box, under 
Operation, select the option you want:
• Manually by clicking Specifies that you 

can assign numbers one at a time so that 
you can specify the order. If you choose 
this option, the Manual Numbering 
dialog box appears instructing you to 
click the shape to which you want Visio 
to assign the next number. When you 
finish assigning numbers, click Close.

• Auto number Specifies that numbers are 
automatically assigned and begin a new 
sequence. The numbering order is top to 
bottom and left to right.

• Renumber maintaining sequence Specifies 
that you can preserve an existing 
numbering sequence for shapes 
already numbered.

4 Under Number assigned, specify the 
number you want to start with, the intervals 
you want to use, and the type of text you 
want to precede each number.

5 Under Apply to, choose whether you want 
to apply your numbering assignments to all 
shapes or to selected shapes.

6 If you want to number shapes that you 
subsequently add to your flowchart, select 
the Continue numbering shapes as 
dropped on page check box.

7 Click the Advanced tab to specify whether 
you want numbers to be placed before or 
after text in shapes, and to be applied to all or 
selected layers (if applicable). Select the 
numbering sequence or the renumbering 
option you want.

8 Select the Hide shape numbers check box if 
you prefer that numbers do not appear in 
shapes. Select the Exclude connectors 
check box if you don’t want numbering to 
apply to connector shapes.

9 Click OK.
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Connect to a new or existing page in your basic 
flowchart using the Off-page reference shape
1 Display the flowchart page you want to 

connect to another.
2 From Basic Flowchart Shapes, drag the 

Off-page reference shape onto the 
drawing page.

NOTE: If the Basic Flowchart Shapes stencil 
isn’t open, on the File menu, point to 
Shapes, point to Flowchart, and then click 
Basic Flowchart Shapes.

3 In the Off-page reference dialog box, 
choose whether you want the page to refer 
to a new page or to an existing page in the 
diagram.

4 If you want the page to refer to an existing 
page, click OK. If you want the page to refer 
to a new page, do one or more of the 
following:
• Select the Drop off-page reference 

shape on page check box if you also want 
this shape to be added to your new 
drawing page.

• Select the Keep shape text 
synchronized check box if you want text 
in both of the Off-page reference shapes 
to reflect changes when you add, modify, 
or delete the text for one of them.

• Select the Insert hyperlinks on shapes 
check box if you want to create links 
between the shapes. This is useful for 
moving from shape to shape in large 
flowcharts.

5 To change the appearance of the Off-page 
reference shape, right-click the shape, and 
then click Outgoing, Incoming, Circle, or 
Arrow on the shortcut menu.

Using the Off-page reference shape, you can easily show different parts of a complex process on several pages.
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4
Chart your organization

Organization charts give you an at-a-glance 
view of your company’s employees and 
reporting structure. Using the shapes and tools 
included in Microsoft® Office Visio® 2003, you 
can create organization charts that contain basic 
employee information such as name and job 
title, or details such as office location, salary, 
date hired, manager name, and so on. You can 
even show employee photographs in your 
organization charts.

If you already store your employee data in a 
spreadsheet, database, or text file, Visio can 
use the information to generate a chart for you. 
You can choose which information to display 
in the chart and which to keep hidden in shape 
properties that do not appear on the 
drawing page.

You can also compare different versions of 
organization charts to make sure you’re sending 
the most recent chart to your employees.

Create organization charts .................................36

Manage large organization charts ..................... 41

Compare information in organization charts.....42

Create an organization chart from 
existing information .......................................43
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Create organization charts

Organization charts show a company in terms of 
its departments and reporting relationships. You 
can differentiate departments by color and 
reporting relationships by line styles.

The Organization Chart template includes all 
the shapes and tools you need to create and 
maintain your organization chart.

Examples of
organization charts

you can create
with Visio
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Chart your organization
To create an organization chart that shows 
reporting relationships, you add Executive or 
Manager shapes, and then you drop shapes 
representing employees onto the shape that 
represents the person they report to. Visio 
automatically positions and adds a connector 
between the two shapes in the reporting 
relationship.

Begin creating your organization chart
1 Start Visio. In Choose Drawing Type, under 

Category, click Organization Chart.
2 Under Template, click Organization Chart.
3 From Organization Chart Shapes, drag the 

Executive shape onto the drawing page.

The Connecting Shapes dialog box 
appears, and an animated demonstration of 
positioning and connecting shapes appears. 
Select the Don’t show this message again 
check box and click OK if you do not want 
the demonstration to appear again.

4 Drag a Manager shape directly on top of the 
Executive shape.
Visio positions the Manager shape below 
the Executive shape and adds a connector 
between them, establishing a reporting 
relationship.

5 Repeat step 4 to add more managers.
6 To establish a relationship between a 

manager and a person who reports to that 
manager, drag a Position shape directly on 
top of the Manager shape.

7 Repeat step 6 to add more positions.
8 To create a second reporting relationship 

between two positions, drag the Dotted-Line 
Report shape from the Shapes window onto 
the drawing page. Drag one of the connector 
endpoints to a connection point on one of the 
shapes in the reporting relationship, and then 
drag the other endpoint to the other shape.

9 To represent other types of positions and 
establish reporting relationships, drag 
Consultant, Vacancy, and Assistant shapes 
onto the shapes they report to.

10 To replace the default shape text with an 
employee’s name and job title, double-click 
the shape, type the name, press the ENTER 
key, and then type the job title.

Drag shapes on top of other shapes to automatically 
position and connect them.
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Store data in your organization chart
You can store data, called custom properties, 
with shapes in your organization chart. You can 
use this data for reports, reference, or shape text 
in your chart.

The default custom properties for organization 
chart shapes are Department, Telephone, 
Name, Title, and Email. By default, the Name 
and Title properties are shown in the shapes. 
The other default custom properties and 
additional ones you create are stored with the 
shapes, but not shown in the chart. You can 
choose to keep them hidden or to display them 
in the shapes.

Store custom property data with organization 
chart shapes
1 Select the shape you want to add data to.
2 On the Shape menu, click Custom 

Properties.
3 In the Custom Properties dialog box, type 

data in each field, and then click OK.

View custom properties not shown in your 
organization chart shapes
• Right-click the shape, and then click 

Properties on the shortcut menu.

Add, change, or delete custom properties 
1 Right-click the shape, and then click 

Properties on the shortcut menu.
2 In the Custom Properties dialog box, click 

Define, and then in the Define Custom 
Properties dialog box, add, change, or 
delete properties, and then click OK.

Format the information and shapes in 
your organization chart
The Name and Title custom properties are 
shown by default in organization chart shapes; 
however, you can show the other default custom 
properties—Department, Telephone, and 
Email—in your shapes too. You can also insert 
employee photographs in your shapes, represent 
departments by using one color for all the 
shapes in the department, and change the design 
theme or color scheme for your chart.

Show and format employee information in your 
organization chart shapes
1 On the Organization Chart menu, click 

Options, and then click the Fields tab.
2 For each text block, select the type of 

information you want to display in it.
The preview on the right side of the dialog 
box displays the information as it will 
appear in the shape.

3 Click the Text tab. In the Fields box, select 
the information you want to format, specify 
formatting options, and then click OK.

4 To replace the default shape text, click a 
shape, select the text block for the text you 
want to replace, and then type the new text.

You can choose which employee information you 
want to display in your organization chart shapes.
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Insert employee photographs in your organization 
chart shapes
1 Right-click the shape you want to add the 

photograph to, and then click Insert Picture 
on the shortcut menu.

2 In the Insert Picture dialog box, locate the 
photograph, and then click Open.

Replace an employee photograph in an 
organization chart shape
1 Right-click the shape for which you want to 

replace the photograph, and then click 
Replace Picture on the shortcut menu.

2 In the Insert Picture dialog box, locate the 
photograph, and then click Open.

Hide an employee photograph in an organization 
chart shape
• Right-click the shape for which you want to 

hide the photograph, and then click Hide 
Picture on the shortcut menu.

TIP: To hide all employee photographs in your 
organization chart, on the Organization 
Chart menu, click Options, and then clear the 
Show Pictures check box.

Delete an employee photograph from an 
organization chart shape
• Right-click the shape for which you want to 

delete the photograph, and then click 
Delete Picture on the shortcut menu.

Change the color of all the shapes in a department
1 Click one of the shapes in the department, 

hold down the SHIFT key while you click 
the remaining shapes in the department to 
select all of them.

TIP: Visio provides different methods and 
tools you can use to select multiple shapes. 
Next to the Pointer tool ( ), click the 
arrow, and then click the Area Select tool 
( ), the Lasso Select tool ( ), or 
Multiple Select.

2 Click the arrow next to the Fill Color button 
( ) on the toolbar, and then click a color on 
the color palette.

TIP: To convert a shape to another type of 
position, right-click the shape, click Change 
Position Type, select the new position, and then 
click OK.

Change the design theme for your 
organization chart
1 On the Organization Chart menu, 

click Options.
2 In the Options dialog box, on the Options 

tab, for Org chart theme, select the theme 
from the list, and then click OK.

Change the color scheme for your 
organization chart
1 Right-click the drawing page, and then click 

Color Schemes on the shortcut menu.
2 In the Color Schemes dialog box, choose the 

scheme you want, and then click OK.
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Add multiple shapes to your 
organization chart
Using the Multiple shapes shape, you can add 
a department of up to 50 people at the same 
reporting level at once. Using the Three 
positions shape, you can add three positions 
at once.

Add up to 50 positions to your chart at once
1 From Organization Chart Shapes, drag the 

Multiple shapes shape onto the drawing 
page or on top of the shape you want the 
positions to report to.

2 In the Add Multiple Shapes dialog box, for 
Number of shapes, select the number of 
shapes you want to add.

3 Select the type of shape you want from the 
Shape list, and then click OK.

Add three positions to your chart at once
• From Organization Chart Shapes, drag the 

Three positions shape onto the drawing 
page or on top of the shape you want the 
positions to report to.

Change the location or layout of 
shapes in your organization chart
You can change the location of individual 
shapes in your organization charts or the layout 
of all the shapes in a department using the 
buttons on the Organization Chart toolbar. 
You can also change individual reporting 
relationships.

Change an individual reporting relationship
• Drag a subordinate shape onto the new 

shape you want it to report to.

Move a shape within a reporting relationship
• Select the shape, and then on the 

Organization Chart toolbar, click 
Move Left ( ) or Move Right ( ).

Change the layout of an entire department
1 Select the shape representing the manager of 

the department for which you want to change 
the layout.

2 On the Organization Chart toolbar, click 
any of the following buttons:
• Re-layout ( ) to lay out the shapes 

below the selected shape.

• Horizontal Layout ( ), Vertical 
Layout ( ), or Side By Side ( ), and 
then click the button that represents the 
layout you want.

Use the Organization Chart toolbar to quickly change 
the layout of a department and rearrange shapes.
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Manage large organization charts

To display all the departments and positions in 
your company, you may need to create an 
organization chart that spans multiple drawing 
pages. Once you add all the shapes you want to 
the first drawing page, you can continue your 
chart on a new page. You add the new page by 
creating a synchronized copy of a department on 
the new page. Visio maintains relationships 
across the drawing pages, so changes you make 
to the text or custom properties of a shape carry 
over to all synchronized copies of that shape.

Create a synchronized copy of a department on a 
new page
1 Open your organization chart, and then 

select the shape you want to place at the top 
level of a new page.

2 On the Organization Chart menu, point to 
Synchronize, and then click Create 
Synchronized Copy. Or, right-click the 
selected shape, and then click Create 
Synchronized Copy on the shortcut menu.

3 In the Create Synchronized Copy dialog 
box, select the Hide subordinates on 
original page check box if you want to 
hide the subordinate positions on the 
original page.

TIP: To hide subordinate positions for any 
top-level shape, right-click the top-level 
shape, and then click Hide Subordinates on 
the shortcut menu.

4 In the Create Synchronized Copy dialog 
box, click OK to create and open a new 
drawing page that displays a copy of the 
shape you selected and any shapes that are 
subordinate to that shape.
Visio synchronizes the new shapes with the 
original shapes. When you update the text, 
custom property data, or photographs in a 
shape, the changes appear in all 
synchronized copies.

NOTE: Changes such as adding, deleting, or 
moving synchronized shapes do not apply to 
all copies of the synchronized shapes, only 
to that shape and page.

5 To add employees to the department, drag 
the appropriate shapes onto the new page, 
creating reporting relationships as you go.

6 At the bottom of the drawing page window, 
click the page tab for the original drawing 
page to display it.

You can use synchronized copies of shapes to create 
organization charts that span multiple pages.
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Compare information in organization charts

Comparing information in different versions of 
your organization chart is useful if you need to 
update your chart frequently and ensure you 
communicate the most recent changes to others 
in the company.

You can use the Compare Organization Data 
command to generate a report that lists the 
differences between current and previous 
versions of your chart.

Compare organization charts 
1 Open the organization chart you want to 

compare with another chart.
2 On the Organization Chart menu, click 

Compare Organization Data.
In the Compare Organization Data dialog 
box, the name of the chart open in Visio 
appears in My drawing to compare.

3 Click Browse, and then locate the chart you 
want to compare with the chart you have 
open in Visio.
The name of the chart you located appears 
in Drawing to compare it with.

4 Under Compare Type, select one of 
the following:
• My drawing is older Select this option if 

the chart specified for My drawing to 
compare is not the most recent version.

• My drawing is newer Select this option if 
the chart specified for My drawing to 
compare is the most recent version.

5 If you want to compare custom property data 
in the charts, click Advanced, and then in 
the Compare Data Values dialog box, 
select the custom properties you want to 
compare. Click OK.

6 In the Compare Organization Data dialog 
box, click OK.
Visio creates a comparison report, which 
displays the differences between the two 
diagrams, if there are any, in Web page 
format and opens it in your browser.

TIP: You can save this Web page if you want to 
distribute or refer to at a later time.
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Create an organization chart from existing information

If you store employee information such as 
name, title, reporting structure, and so on in 
another data file, you can use the Organization 
Chart Wizard to generate a Visio organization 
chart based on the information in that file.

You can use a data file such as a text file, 
Microsoft Excel file, Microsoft Exchange 
Server directory, or other ODBC-compliant 
data source.

NOTE: If you do not already have a data file, 
but you prefer typing data in a file to dragging 
shapes in Visio, you can use the Organization 
Chart Wizard to open a data file template in 
text (.txt) or Excel (.xls) format. Then you can 
build your chart by typing in the file, and then 
using it to generate the chart in Visio.

Example of an 
organization chart 
created in Visio 
from a text file
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When you use the Organization Chart 
Wizard, you can specify elements such as 
the following:

• Data you want the wizard to display in the 
organization chart shapes, such as name, 
title, and department.

• Fields from your data file that you want to 
use as custom properties in organization 
chart shapes.

• Whether you want the wizard to determine 
the number of positions to display on each 
page, or you want to decide as you create 
the chart.

Create an organization chart from a data file
1 Start Visio. In Choose Drawing Type, under 

Category, click Organization Chart.
2 Under Template, click Organization 

Chart Wizard.
3 On the first wizard screen, select 

Information that’s already stored in a file 
or database, then click Next.

4 On the next wizard screen, select the format 
of the file in which you store your employee 
information, and then click Next.

5 On the next wizard screen, locate the file that 
contains your employee information, and 
then click Next.

6 On the next wizard screen, choose the fields 
in your data file that correspond to the 
Name, Reports to, and First name 
information in your organization chart, and 
then click Next.

7 On the next wizard screen, under Data file 
columns, select the type of information you 
want to display in the shapes, such as name, 
and then click Add to move it to the 
Displayed fields list. Repeat this step for 
each type of information you want to 
display, and then click Next.

8 On the next wizard screen, under Data file 
columns, select the type of information you 
want to add to shapes as custom property 
fields, and then click Add to move it to the 
Custom Property fields list. Repeat this 
step for each type of information you want to 
add as a custom property field, and then 
click Next.

9 On the next wizard screen, do one of 
the following:
• Select I want to specify how much of 

my organization to display on each 
page. On the subsequent wizard screens, 
specify the information you want to 
appear on each page of the organization 
chart. On the last wizard screen, 
click Finish.

• Select I want the wizard to 
automatically break my organization 
chart across pages. Click Finish.

The wizard generates your organization chart.

TIP: You can also import information into 
existing organization charts. Open an 
organization chart in Visio, and then click 
Import Organization Data on the 
Organization Chart menu.
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Design and manage your networks 
with network diagrams

Microsoft® Office Visio® Standard 2003 and 
Microsoft Office Visio Professional 2003 
include the tools you need to create detailed 
logical and physical network diagrams. Using 
the Detailed Network Diagram template in 
Visio Professional 2003 to lay out your 
network, you can use layers to identify and 
work with specific components in your 
diagrams. For example, you can quickly 
identify all computers made by a particular 
manufacturer or print only the servers in 
your diagram.

You can also store information with each 
network shape, such as manufacturer, product 
name, product description, and model number, 
so you can troubleshoot problem areas, track 
equipment, perform quick inventories, and 
generate custom reports.

Create network diagrams ...................................46

Work with network diagrams ..............................48
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Create network diagrams

You can use detailed network diagrams to 
design and implement network configurations, 
keep track of cabling and equipment, and 
visualize the complexity of an existing network. 
Troubleshooting your network’s infrastructure 
then becomes easier, because you have accurate 
and detailed information to refer to.

Using Visio diagramming tools, you can make 
your diagrams more useful by designating 
layers to differentiate network components. 
You can also use custom properties to store 
and report on data associated with your 
network shapes.

Examples of
network

diagrams you
can create
using Visio
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Create a detailed logical or physical 
network diagram
1 Start Visio Professional. In the Choose 

Drawing Type window, under Category, 
click Network.

2 Under Template, click Detailed Network 
Diagram.

3 From Network and Peripherals, drag an 
Ethernet or Ring network network 
backbone shape onto the drawing page.

4 From the stencils in the Shapes window, 
drag server, workstation, and other 
component shapes onto the drawing page 
and position them around the network 
backbone shape.

NOTE: To show shapes on a particular 
stencil in the Shapes window, click the 
stencil title bar.

5 Select the network backbone shape, and then 
drag a control handle ( ) to a connection 
point ( ) on one of the surrounding shapes.
Visio draws a connector, and the connector 
endpoint turns red, indicating the connector 
is glued to the shape.

6 Continue connecting other shapes to the 
network backbone.

TIP: In large network diagrams, you can 
use the Pan & Zoom window to magnify 
shapes so you can position them precisely 
and connect them correctly. On the View 
menu, click Pan & Zoom Window.

7 Hide any unnecessary connectors on the 
network backbone shape by dragging the 
corresponding control handle on top of 
the shape.

8 To change the color scheme of your network 
diagram, right-click the drawing page, and 
then click Color Schemes on the shortcut 
menu. Choose a color, and then click OK.

9 To add text to a network shape, select the 
shape, and then type.
To reposition the text for many network 
shapes, drag the control handle ( ), which 
appears on top of the text after you type it, 
to a different location.

TIP: You can also represent network equipment 
in rack diagrams by using the Rack Diagram 
template included with Visio Professional 2003.
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Work with network diagrams

You can manage shapes with layers and store 
data with network diagrams.

Manage network diagrams with layers
When you create a network diagram using the 
Detailed Network Diagram template, you can 
place shapes on layers. For example, you can 
add an Ethernet shape to a general 
Network layer.

By working with layers, you can manage one 
category of your diagram, such as all server 
shapes or all equipment made by a particular 
manufacturer, without affecting others, or 
without others getting in the way. For example, 
you can hide or lock all layers except the one 
you want to work on, or you can print shapes 
based on their layer assignments. You can also 
create your own layers and assign shapes 
to them.

View or print only one layer in a network diagram
1 On the View menu, click Layer Properties.
2 In the Layer Properties dialog box, do 

either of the following:
• Under Visible, clear the check boxes for 

all of the layers except for the layer you 
want to view, and then click OK.

• Under Print, clear the check boxes for all 
of the layers except for the layer you 
want to print, and then click OK.

Add a shape to an existing layer
1 Select the shape you want to add to an 

existing layer.
2 On the Format menu, click Layer.
3 In the Layer dialog box, select the layer, and 

then click OK.

Create a new layer and add a shape to it
1 Select the shape you want to add to the 

new layer.
2 On the Format menu, click Layer.
3 In the Layer dialog box, click New.
4 In the New Layer dialog box, type the name 

of the new layer, and then click OK.
Visio automatically selects the new layer in 
the Layer dialog box.

5 In the Layer dialog box, click OK.

TIP: To quickly see which layer a shape is 
assigned to, display the Format Shape toolbar. 
Right-click the menu bar, and then click Format 
Shape on the shortcut menu. Select a shape, 
and then view the layer to which it is assigned 
in the Layer box on the Format Shape toolbar.

Use the Layer Properties dialog box to view and 
change the properties of layers, create new ones, 
and remove old ones.
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Create and view network 
shape properties
The Detailed Network Diagram template 
contains network shapes that, by default, have 
individual custom properties associated with 
them, which you can use to quickly identify 
components in your network diagram, track 
equipment, and generate reports, such as 
inventories, cost estimates, or bills of materials. 
For example, the Mainframe shape has Asset 
Number, Serial Number, Location, Building, 
Room, Manufacturer properties, among 
others, that you can use to identify and track it.

Open the Custom Properties window
• On the View menu, click Custom 

Properties Window.
The Custom Properties window doesn’t 
display any custom properties until you select 
a shape (or page) with custom properties.

TIP: You can resize the Custom Properties 
window by dragging a window edge. You can 
also undock the window so you can move it 
around. Right-click the window, click Float 
Window on the shortcut menu, and then drag 
the window to a new location.

Do any of the following to view custom properties 
for a network shape
• If the Custom Properties window is 

already open, select a shape to display its 
custom properties in the window.

• If the Custom Properties window isn’t 
open, right-click a shape, and then click 
Properties on the shortcut menu.
The Custom Properties window opens and 
shows the custom properties that are 
already defined for the shape.

NOTE: If the Properties command doesn’t 
appear on a shape’s shortcut menu, the 
shape doesn’t contain custom properties. 
Follow the steps in the Define New Custom 
Properties procedure to add them.

• Select the shape, and then on the Shape 
menu, click Custom Properties.
The Custom Properties dialog box appears 
and shows the custom properties that are 
already defined for the shape.

View custom properties and enter network shape 
data in the Custom Properties window.
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Define new custom properties
1 Select the shape you want to add custom 

properties to.
2 On the Shape menu, click Custom 

Properties.

NOTE: If the shape doesn’t contain any 
custom properties, a message appears 
asking if you want to add custom 
properties. Click Yes.

3 In the Custom Properties dialog box, 
click Define.
The Define Custom Properties dialog 
box appears.

4 In the Define Custom Properties dialog 
box, click New, and then enter the label, 
type, format, value, and prompt for the new 
custom property.

5 Click OK in the Define Custom Properties 
and Custom Properties dialog boxes.

Enter custom property data for a shape
1 Right-click a shape, and then click 

Properties on the shortcut menu.
2 In the Custom Properties window, select 

the custom property, and then enter the data 
for the shape.
To move to the next property in the list, press 
the ENTER key.
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In addition to defining individual custom 
properties, you can define sets of custom 
properties for shapes. A custom property set 
contains one or more individual custom 
properties and provides an easy way to add, 
organize, and report on multiple custom 
properties. For example, if you want to create a 
series of custom network equipment shapes that 
contain name, manufacturer, and serial number 
information, you can create a custom property 
set for those three properties. When you apply 
the set to the shapes, Visio adds all three 
properties at once.

Do either of the following to open the Custom 
Property Sets window
• If the Custom Properties window is open, 

right-click it, and then click Custom 
Property Sets on the shortcut menu.

• If the Custom Properties window isn’t 
open, on the Tools menu, click Custom 
Property Sets.

TIP: To resize the Custom Property Sets 
window, drag a window edge. To move it, first 
undock it by right-clicking the window and 
clicking Float Window on the shortcut menu, 
and then drag the window to a new location.

Define custom property sets
1 On the Tools menu, click Custom 

Property Sets.
The Custom Property Sets window 
appears.

2 In the Custom Property Sets window, 
click Add.

3 In the Add Custom Property Set dialog 
box, type the name of the set, select Create a 
new set, and then click OK.

4 To define individual custom properties in the 
set, in the Custom Properties Sets window, 
click Define.

5 In the Define Custom Properties dialog 
box, define the properties, and then 
click OK.
The individual custom properties for each set 
appear in the Properties column in the 
Custom Property Sets window.
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Define a custom property set using a shape’s 
existing, individual properties
1 Right-click the shape that contains the 

custom properties for which you want to 
create a set, and then click Properties on the 
shortcut menu.

2 Right-click the Custom Properties window, 
and then click Custom Property Sets.

3 In the Custom Property Sets window, 
click Add.

4 In the Add Custom Property Set dialog 
box, type the name of the set, select Create a 
new set from the shape selected in Visio, 
and then click OK.
The individual custom properties for the set 
appear in the Properties column in the 
Custom Property Sets window.

Apply a custom property set to a shape
1 Select the shape, and then in the Custom 

Property Sets window, select the check box 
next to the property set you want to apply to 
the shape.

2 Under Apply checked custom property 
sets to, select Shapes selected in drawing, 
and then click Apply.

Generate a report on the custom properties in your 
network diagram
1 On the Tools menu, click Reports.
2 In the Reports dialog box, choose an 

existing report or click New to create a 
custom report.

3 Follow the steps on the wizard screens.
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6
Design your buildings
with floor plans

Whether you are an architect designing a 
commercial building or a facilities manager 
planning interior spaces, Microsoft® Office 
Visio® Professional 2003 provides the tools 
you need to create detailed, scaled floor plans.

Using the Floor Plan template in Visio 
Professional, you can draw floor plans that 
show the location of walls, doors, and 
windows; building core features, such as 
stairways and elevators; and electrical and 
telecommunications systems, such as lights, 
outlets, and switches.

Using other Building Plan templates included 
with Visio Professional, you can build 
architectural or landscape site plans, lay out 
manufacturing plants, and draw home plans for 
your own remodeling, interior design, or 
landscaping projects.

Create floor plans................................................54

Work with large floor plans .................................58
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Create floor plans

Floor plans are the core diagrams in a set of 
construction documents and are frequently used 
as background images in a wide range of 
diagrams, from office furniture layouts to 
electrical wiring diagrams.

Visio Professional includes the shapes and tools 
you need to assemble walls quickly, add doors 
and windows, and add dimension lines to your 
floor plan.

Examples of
floor plans you

can create with
Visio Professional
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Begin your floor plan by assembling the 
building shell
When creating a floor plan, first you assemble 
the building shell, which includes exterior and 
interior walls and columns, and major structural 
features, such as stairways and elevators. 

Start a floor plan
1 Start Visio Professional. In the Choose 

Drawing Type window, under Category, 
click Building Plan.

2 Under Template, click Floor Plan.
3 To change the page size or drawing scale, on 

the File menu, click Page Setup.
4 Click the Page Size tab to choose a page 

size, and then click the Drawing Scale tab to 
choose a drawing scale.

5 Click OK to accept the new settings and 
begin creating your floor plan.

Assemble the building shell
1 Drag guides from the horizontal and vertical 

rulers and position the guides on the drawing 
page so that they indicate the perimeter of 
the building.

2 For each exterior wall, drag a wall shape 
from Walls, Shell, and Structure in the 
Shapes window onto the drawing page. 
Drag the endpoints of the wall shape to the 
intersections of the horizontal and vertical 
guides to glue them to the guides and join 
the walls.

3 To reposition exterior walls, drag the guides 
to which they are glued.

4 Add columns or other structural shapes from 
Walls, Shell and Structure, or from 
Building Core.

5 Position interior and cubicle walls by 
dragging wall shapes onto the drawing page. 
Drag the endpoint of one wall to another 
wall to join and glue them.

6 Add guides to interior walls by right-clicking 
a wall and clicking Add a Guide on the 
shortcut menu.

7 To reposition interior walls, drag the guides 
to which they are glued.

TIP: You can insert a CAD floor plan into your 
diagram to use it as your building shell, and 
then add more detail using Visio shapes. To 
insert a CAD plan, on the Insert menu, click 
CAD Drawing.
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Create interior spaces
The next step in assembling your floor plan is to 
create interior spaces and lay out the building by 
using space shapes that you can easily convert 
into rooms outlined by fully dimensioned walls. 
You can then continue to create the rest of your 
floor plan with as much detail as necessary.

Create interior spaces
1 From Walls, Shell and Structure, drag a 

space shape onto the drawing page.
To create a space that is not a rectangle, 
position several space shapes to represent 
the room. Select all of the shapes, right-
click them, and then click Union, Subtract, 
or Intersect on the shortcut menu to 
merge them. 

2 To resize the space shape, drag a 
shape corner.
The shape updates to show its new 
dimensions.

3 Position shapes to represent all of the rooms 
and common areas in your floor plan.

4 To convert the space shapes into rooms, 
select the shape, and on the Plan menu, click 
Convert to Walls.

5 In the Convert to Walls dialog box, under 
Settings, select Add dimensions and 
Add guides so that you can easily reposition 
walls after they are created.

6 Under Original geometry, click Delete to 
delete the space shape, and then click OK.

TIP:  You can also use the Line tool ( ) or 
Rectangle tool ( ) on the Drawing toolbar to 
draw outlines of rooms and common areas in 
your plan. Then, convert them into rooms using 
the Convert to Walls command on the 
Plan menu.
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Add doors, windows, and openings
Adding the shapes for doors, windows, and 
other openings to your floor plan is as easy as 
creating the shell. When you drag a door or 
window shape onto a wall, the door or window 
automatically aligns with the wall and glues 
itself to it. The doors and windows also inherit 
the wall’s thickness.

Add doors, windows, and openings to walls
1 From Walls, Shell and Structure, drag a 

door, window, or opening shape onto a wall.
The shape aligns and glues to the wall.

2 To reposition a door or window, drag it 
along the wall.

Change the appearance of walls, doors, 
and windows
For detailed construction diagrams, you can 
change the default appearance of a single wall, 
door, window, or space or for all walls, doors, 
windows, and spaces on a drawing page. For 
example, you can hide door header or frame 
components or display walls as single lines 
instead of double lines.

Change the appearance of all walls, doors, 
windows, and spaces on the drawing page
1 On the Plan menu, click Set Display 

Options.
2 On the Doors tab, Walls tab, Windows tab, 

or Spaces tab, choose the settings you want.

Change the appearance of a single wall, door, 
window, or space
1 Right-click the wall, door, window, or space 

shape, and then click Set Display Options 
on the shortcut menu.

2 On the Doors tab, Walls tab, Windows tab, 
or Spaces tab, choose the settings you want.

Measure walls and spaces
Using Visio Professional, you can add 
dimension lines to walls at any time. As you 
refine your plan, the dimensions update along 
with it. You can also determine the area and 
perimeter of rooms in your floor plan.

Add dimension lines to a wall
1 Select the walls to which you want to add 

dimensions.
2 Right-click one of the selected walls, and 

then click Add a Dimension on the 
shortcut menu.

Measure the area and perimeter of rooms
1 Select the wall shapes that make up the 

perimeter.
2 On the Tools menu, point to Add-Ons, point 

to Visio Extras, and then click Shape Area 
and Perimeter.

You can quickly change the appearance of all walls 
on the drawing page from double-line to single-line.

0 - Visio 11.book  Page 57  Tuesday, July 1, 2003  10:50 PM



58 M I C R O S O F T ® O F F I C E  V I S I O ® 2 0 0 3  U S E R  G U I D E

Work with large floor plans

Floor plans are usually large and contain many 
shapes. Visio 2003 provides the tools you need 
to easily work with large diagrams. You can 
magnify details, print a large diagram across 
multiple pages, or scale your diagram to print on 
a single page.

Zoom and pan diagrams
You can use the Pan & Zoom window to 
quickly locate and magnify an area of a large 
diagram. Panning moves the visible part of the 
diagram in the drawing window. Zooming 
changes the magnification of the diagram.

Zoom and pan a diagram
1 On the View menu, click Pan & Zoom 

Window.
2 In the Pan & Zoom window, drag a 

rectangle around the area you want 
to magnify.

3 To pan to a different part of the diagram, 
position the pointer over the rectangle until it 
becomes a four-headed arrow ( ), and then 
drag the rectangle.

4 To zoom in on part of a diagram, decrease 
the size of the red rectangle by dragging a 
corner or side; to zoom out, increase the size 
of the red rectangle.

View in Pan & Zoom window Magnified view on the drawing page
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Print large diagrams
When you work with large diagrams, it’s 
possible to have a drawing page that is larger 
than the printed page. If the size of a Visio 
diagram is larger than the paper in your printer, 
Visio tiles the diagram, which means that the 
diagram prints on several sheets of paper.

You can preview a large diagram to see if it will 
require more than one printed page. When you 
know your diagram will print on multiple pages, 

you can choose how much a tiled diagram 
overlaps between adjacent pages. You can also 
specify the number of pages you want your 
drawing to span.

Determine whether a large diagram will print on 
several pages
• On the View menu, click Page Breaks.

Gray bands appear on the drawing page, 
indicating the printed page size and margins 
selected in the Print Setup dialog box.

You can print a diagram on large printer paper or on several smaller sheets of paper.
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Reduce or enlarge the size of a printed diagram
1 On the File menu, click Page Setup.
2 On the Print Setup tab, under Print zoom, 

select Adjust to, and then type a number 
greater or less than 100%.

3 Look at the preview on the right side of the 
dialog box to make sure your drawing page 
and printer paper appear the way you want, 
make any necessary adjustments, and then 
click OK.

Specify the number of printed pages for a 
tiled diagram 
1 On the File menu, click Page Setup.
2 On the Print Setup tab, under Print zoom, 

select Fit to, and then type the number of 
pages across and down on which you want 
the drawing to print.

3 Look at the preview on the right side of the 
dialog box to make sure your drawing page 
and printer paper appear the way you want, 
make any necessary adjustments, and then 
click OK.

Reduce or increase the amount of overlap 
between printed pages for a tiled diagram
1 On the File menu, click Page Setup.
2 On the Print Setup tab, click the 

Setup button.
3 Type smaller or larger amounts for the 

margin settings, and then click OK.
The larger the margins, the greater the 
overlap. Shapes that appear in the margins 
do not print.

4 In the Page Setup dialog box, click OK.
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1-D shapes 6, 13
2-D shapes 6, 13

A
Activating Visio after installation vi
Adding custom properties to shapes 31, 38
Adding hyperlinks to shapes and pages 17, 31
Adding review comments to diagrams xv
Adding shapes

to diagrams 5
to stencils 23–24

Adding text to shapes 11, 12
Adding Visio diagrams to other documents 16
Add-ons

measuring shape area and perimeter 57
numbering shapes 32

Aligning shapes to guides 55
Annotating diagrams xv
Applying formatting to shapes 13
Area Select tool xv, 7
Area, calculating in shapes 57
Assigning shapes to layers 48
AutoCAD, importing CAD files xv, 55
Automation, finding Help for using xix

B
Background pages 26–27

assigning to foreground pages 26
creating for repeated page elements 26
modifying 27

Basic flowcharts, creating 31
Basic Visio tasks, illustrated 2–3
Bills of materials, creating using custom 

properties 52
Block diagrams, illustrated example of ix
Borders, in diagrams

See Background pages
Brainstorming diagrams, illustrated example 

of xi
Browsing sample diagrams vii, xx
Building plans

creating 54–57
illustrated example of 54
See also Floor plans

Building shells, in floor plans 55

C
CAD drawings, opening in Visio xv, 55
Calendars, illustrated example of x
Changing the magnification of a diagram 8
Closed shapes 20
Color palette for filling shapes 13
Coloring shapes 13
Combine command 21
Connecting shapes

adding connection points to shapes 11
changing connector style 10, 31
Connection Point tool 11
connection points 10–11
connection types 9–11, 31
Connector tool 10
connectors 9–11
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Connection Point tool 11
Connection points 10–11

adding to shapes 11
Connection types

point-to-point 9–11, 31
shape-to-shape 9–10, 31

Connector tool 10, 31
Connectors 9–11

adding text to 11
Constraining drawing behavior 20
Construction documents, creating building 

plans 54–57
Contacting Microsoft Corporation xx
Control handles 6
Control points 22
Converting diagrams to Web pages 17
Copying shapes 16
Creating organization charts from data 

files 43–44
Creating your own shapes 20–22
Creating your own stencils 23–24
Creating your own templates 25
Custom properties

adding and deleting in shapes 38
adding data to 38, 50
defining new 50
displaying data in organization chart 

shapes 38
sets, creating 51–52
viewing 38, 49

Custom Properties window 49
Custom properties, adding to shapes 31
Custom property sets

about 51
applying to shapes 52
defining new 51–52

Custom Property Sets window 51
Custom stencils 23
Customizing shapes 21, 22

Customizing Visio
creating templates 25
creating your own shapes 20–22
displaying full menus xxi
personalizing the drawing 

environment xxi–xxii
saving shapes on custom stencils 23

D
Data

adding to shapes 31, 38, 49–52
generating organization charts from 43–44
viewing custom properties 38

Database files, generating organization charts 
from 43–44

Deleting a page from a diagram 14
Deleting shapes 10
Deleting text from shapes 12
Design themes, changing in organization 

charts 39
Detect and Repair feature for troubleshooting vi
Developer Reference online Help xx
Diagram Gallery vii, xx
Diagram types

basic flowcharts 31
building and floor plans 54–57
network 46–52
organization charts 36–44

Diagrams
adding shapes to 5
assigning background pages to 26
creating using a template 4–5
creating, illustrated overview 2–3
generating organization charts from data 

files 43–44
managing using layers 48
multiple-page 14
printing 15, 59–60
publishing to the Web 17–18
saving 15
scaled 14, 55
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Dimensioning in floor plans 57
Directional maps, illustrated example of x
Displaying background pages for editing 27
Distributing Visio diagrams 16–17
Dragging shapes 5
Drawing environment 4
Drawing page settings and properties 14
Drawing page window 4
Drawing pages

adding 14
adding hyperlinks to 17
deleting from a diagram 14
orientation 14
page tabs 14
renaming 14
setting page size and scale 14, 55
using backgrounds for repeated 

elements 26–27
Drawing process, illustrated 2–3
Drawing scale, changing 14, 55
Drawing shapes from scratch 20
Drawing tools

contraining drawing behavior 20
Drawing toolbar 20

Drawings
See Diagrams

DWG converter xv

E
Editing stencils 23–24
Endpoints 6
Engineering diagrams, illustrated examples 

of xiii
Example diagrams

block diagram ix
brainstorm diagram xi
calendar x
database model xiv
Diagram Gallery xx
directional map x

engineering xiii
floor plan xii
flowcharts viii, 30
marketing chart ix
network xi, xii, 46
office layout ix
organization charts viii, 36, 43
site plans xii
software xiv
timeline x
Web diagram xi

Excel files, generating organization charts 
from 43–44

Exchange Server directory, generating 
organization charts from 43–44

Exterior walls, in floor plans 55

F
Favorites stencil xv, 23
Features, finding Help for using xix
Files

CAD, importing 55
of other formats, importing 24
printing 15
saving 15

Fill color palette 13
Filling shapes with color 13
Finding shapes xv, 5

changing search parameters xxii
Floor plans

adding dimension lines to walls 57
creating 54–57
illustrated example of xii, 54
measuring area and perimeter of rooms 57

Flowcharts
basic 31
illustrated examples of viii, 30
linking pages in 33
numbering shapes in 32

0 - Visio 11.book  Page 63  Tuesday, July 1, 2003  10:50 PM



64 M I C R O S O F T ® O F F I C E  V I S I O ® 2 0 0 3  U S E R  G U I D E

Footers and headers
See Background pages

Format Shape toolbar 13, 48
Formatting shapes

fill color and pattern 13
in organization charts 38
line color and pattern 13
text 12

Fragment command 21
Full menus, displaying by default xxi

G
Generating organization charts from data 

files 43–44
Getting started

Getting Started Tutorial xx
installing and activating Visio vi
overview of drawing process 2–3
using a template 4–5
using online Visio Help xix

Glue 9
See also Connecting shapes

Graphics, importing 24
Gray selection handles on shapes 22
Grid, drawing page 4
Guides, adding to diagrams 55

H
Handles

See Shape handles
Headers and footers

See Background pages
Help

Developer Reference xx
online documentation xix
Template Help display settings xxi
using installed Help instead of Help on 

Web xxi
Visio Help task pane xix
Visio information on the Web xx

Hiding the Template Help task pane xxi
Hierarchical structures, creating in organization 

charts 37, 40
HTML, converting diagrams to 17
Hyperlinks, adding to shapes and pages 17, 31

I
Importing

AutoCAD files xv, 55
files of other formats 24
information into organization charts 44

Improved features in this product version xv–xviii
Incorporating Visio diagrams in other 

documents 16
Ink tool xv
Installing and activating Visio vi
Interior walls, in floor plans 55
Internet

finding Visio information on xx
publishing diagrams to 17–18

Intersect command 21
Inventory reports, generating from custom 

properties 52

J
Jumps

See Hyperlinks

K
Keyboard shortcuts

centering the drawing page 8
selecting all text in a text block 12
zooming in and out of the drawing page 8

L
Large diagrams

printing 59–60
viewing page breaks in 59

Lasso Select tool xv, 7

0 - Visio 11.book  Page 64  Tuesday, July 1, 2003  10:50 PM



I N D E X 65

Layers
creating and assigning shapes to 48
viewing 48

Layouts
changing reporting relationships in 

organization charts 40
rearranging shapes in organization charts 40

Linking pages
in flowcharts 33
in organization charts 41

Links, adding hyperlinks to shapes and pages 17, 
31

Locked shapes 22
Logical network diagrams

See Network diagrams

M
Managing diagrams with layers 48
Margins, on printed pages 59
Marketing diagrams, illustrated example of ix
Masters

See Saving shapes on custom stencils
Measuring spaces in floor plans 57
Menu commands, finding Help for using xix
Menus, showing full menus xxi
Merging shapes to create new ones 21
Microsoft Office Online xx
Microsoft SharePoint, using with Visio xv
Microsoft Word, adding Visio diagrams to 

documents 16
Modifying backgrounds 27
Modifying shapes

using drawing tools 22
using shape operation commands 21

Modifying stencils 23–24
Moving shapes 7, 12

nudging 7
restricting shape movement to horizontal or 

vertical 7

Multiple Select mode xv, 7, 39
Multiple shapes

moving 7
selecting xv, 7, 39

Multiple-page diagrams
adding backgrounds 26–27
adding pages 14
deleting pages 14
flowcharts 32
navigating 14
organization charts 41
rearranging pages 14

My Shapes xv, 5, 23, 24

N
Naming drawing pages 14
Navigating a multiple-page diagram 14
Network diagrams

connecting shapes in 47
creating and managing 46–52
custom properties in network shapes 49
illustrated example of xi, xii, 46
using layers in 48

New features in this product version xv–xviii
Nudging shapes 7
Numbering shapes in flowcharts 32

O
ODBC-compliant database, generating 

organization charts from 43–44
Office layouts

illustrated example of ix
See also Floor plans

Off-page reference shape 32
using to link pages in flowcharts 33

Offset command 21
One-dimensional shapes 6, 13
Online Help, finding xix
Open shapes 20
Opening diagrams without Visio xv
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Opening stencils 5, 24, 25
Organization Chart Toolbar 40
Organization Chart Wizard 43–44
Organization charts

adding employee photos to shapes 39
changing design theme 39
comparing versions of 42
converting shape type 39
creating 37
creating departments 40
displaying custom property data 38
establishing reporting relationships 37
formatting 38
generating from data file 43–44
illustrated example of viii, 36, 43
multiple-page 41
storing data in shapes 38
synchronizing shapes in 41
updating 42

Organizing shapes 23–24
Orientation, drawing page 14
Overview of Visio drawing process 2–3

P
Page breaks

adjusting overlap between pages 60
viewing in large diagrams 59

Page order, changing 14
Page tabs 14
Pages

See Drawing pages
Pan & Zoom window 8, 58
Panning a diagram 8, 58
Pasting shapes 16
Perimeter, calculating for a shape 57
Photos, adding to organization chart shapes 39
Physical network diagrams

See Network diagrams
Pictures, importing 24
Pointer tool 7

Point-to-point connections 9–11, 31
Previewing diagrams before printing 15
Printing diagrams 15, 59–60

Print Preview 15
reducing or enlarging 60
specifying number of pages 60
tiling over multiple pages 59

Printing diagrams without Visio xv
Properties

changing design theme in organization 
charts 39

drawing page 14
layers in diagrams 48
See also Custom properties

Publishing diagrams to the Web 17–18

R
Rearranging pages in a diagram 14
Renaming drawing pages 14
Repeating elements over multiple pages 26
Reporting relationships in organization charts

changing 40
converting shape type 39
creating 37

Reports, generating from custom properties 52
Repositioning shapes 7, 12
Resizing a window 49, 51
Resizing shapes 6
Restricting drawing behavior 20
Restricting shape movement to horizontal or 

vertical 7
Review comments, adding to diagrams xv
Revising shapes

using drawing tools 22
using shape operation commands 21

Rotating shapes 6
Rotation handles xv, 6
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S
Sample diagrams

See Example diagrams
Saving diagrams 15

as Web pages 17
Saving shapes on custom stencils 23–24
Saving templates 25
Scale, drawing page 14, 55
Scaled diagrams 55
Searching for shapes xv, 5

changing search parameters xxii
Selecting multiple shapes xv, 7, 39
Selection handles 6
Setup, installing and activating Visio vi
Shape handles

about 6
control handles 6
control points 22
gray boxes 22
rotation handles xv, 6
selection handles 6
vertices 22

Shape operation commands 21
Shapes

1-D 6, 13
2-D 6, 13
adding data to 31, 38, 49–52
adding hyperlinks to 17, 31
adding text to 12
adding to diagrams 5
closed 20
copying 16
creating your own 20–22
custom properties 49–52
deleting 10
finding Help for using xix
formatting 13
formatting text 12
locked to prevent changes 22
merging 21

moving 7, 12
My Shapes 5, 23, 24
new or improved in this product version xvi
numbering in flowcharts 32
open 20
pasting 16
resizing 6
revising existing 22
rotating 6
saving on custom stencils 23–24
searching for xv, 5
shape handles 6
text-only shapes 12

Shapes window 4
ShapeSheet, finding Help for using xix
Shape-to-shape connections 9–10, 31
Sharing Visio diagrams xv, 16–17
Site plans, illustrated example of xii
Snapping shapes to guides 55
Software diagrams, illustrated example of xiv
Stencils

adding shapes to 23–24
creating your own 23–24
dragging shapes from 5
Favorites stencil 23
opening 5, 24, 25

Subtract command 21
Synchronizing shapes in organization charts 41

T
Tabs, on drawing pages 14
Task panes xv, xvii–xviii, xix, xxi
Template Help, hiding or displaying xxi
Templates 4

creating diagrams with 4–5
creating your own 25
new or improved in this product version xvi
Template Help display settings xxi

Terms, finding Help for xix
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Text
adding to shapes 11, 12
deleting from shapes 12
formatting 12
modifying 12
text-only shapes 12

Text files
generating organization charts from 43–44

Text-only shapes, creating 12
Tiling

adjusting how much pages overlap 60
printing large diagrams 59
viewing page breaks before printing 59

Timelines, illustrated example of x
Toolbars

Drawing 20
Format Shape 13, 48
Format Text 12
Formatting 12, 13
Organization Chart 40

Tools
Area Select xv, 7, 39
Connection Point 11
Connector 10, 31
Ink xv
Lasso Select xv, 7, 39
Pencil 22
Pointer 7
Zoom box 8

Troubleshooting Visio using Detect and Repair vi
Tutorial, Getting Started xx
Two-dimensional shapes 6, 13
Typing text into shapes 11, 12

U
Undocking a window 49, 51
Undoing an action 7
Union command 21
Units of measurement, changing default 

settings xxii
Updating organization charts 42
Using templates 4–5
Using Visio with Microsoft Word 16

V
Vertices 22
Viewer, opening diagrams without Visio xv
Viewing

diagrams before printing 15
diagrams without Visio xv
layers in drawings 48
page breaks in large diagrams 59

Visio window 4

W
Walls, in floor plans 55
Web

finding Visio information on xx
publishing diagrams to 17–18

Web diagrams, illustrated example of xi
Web pages, converting diagrams to 17
Windows

Custom Properties 49
Custom Property Sets 51
drawing page 4
Pan & Zoom 8, 58
resizing 49, 51
Shapes 4
undocking 49, 51

Z
Zoom toolbar box 8
Zooming in on and out of a diagram 8, 58
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